POS for .NET v1.12 SDK Documentation

Microsoft Point of Service for .NET
POS for .NET v1.12 SDK Documentation |
 | See Also

1/18/2008

Microsoft Point of Service for .NET v1.12 is a class library that enables POS developers to apply Microsoft .NET technologies in their products. It provides a simple and consistent interface for.NET Framework applications to interact with POS devices, a set of interfaces and classes created to help Vendors write applications for common devices such as Cash Drawers or Line Displays, and support for Windows Plug and Play functionality. The following documentation can help you use POS for .NET to develop POS applications and Service Objects (SOs) more efficiently, learn more about the benefits of POS for .NET, and achieve better compatibility with POS devices.

In This Section

Technical Support for POS for .NET

Provides contact information for technical support for POS for .NET.

Copyright Information for POS for .NET v1.12

Provides copyright information about POS for .NET v1.12.

What's New for POS for .NET

Describes the features introduced in each new version of POS for .NET in the following topics:

  • What's New in POS for .NET v1.12

  • What's New in POS for .NET v1.11

  • What's New in POS for .NET v1.1

POS for .NET v1.12 Features

Provides an in-depth view at POS for .NET, its architecture, and features in the following topics:

  • POS for .NET Architecture

  • Service Object Overview

  • Supported Device Classes

  • Event Management

  • POS Exception Handling

  • POS for .NET Integration with Plug and Play

  • Log Files

  • Integration of Legacy Service Objects

Developing a POS Application

Describes the POS for .NET predefined interfaces and classes, how best to use them in your code, and demonstrates suitable procedures for developing POS for .NET code in the following topics:

  • Typical POS Application Architecture

  • POS for .NET API Support

  • Event Handler Sample

Developing a Custom Service Object

Discusses the procedures, issues, and conventions for developing custom service objects in the following topics:

  • POS for .NET Service Object Architecture

  • System Configuration

  • Service Object Samples: Getting Started

  • Developing Service Objects Using Base Classes

  • Device Input and Events

  • Device Output Models

  • Asynchronous Output Sample

  • Statistics Sample

  • Base Class DirectIO Method

  • Capability Properties

POS Device Manager

Describes how WEPOS helps you manage your POS devices in the following topics:

  • Changing Windows Firewall Settings to Enable Remote Device Management

  • Using the WMI API to Manage Devices

  • Using Visual Studio .NET Management Extensions and the WEPOS WMI Management Classes

  • Using the POS Device Manager Command-Line Tool

See Also

Reference

Microsoft.PointOfService

© 2008 Microsoft Corporation. All rights reserved.


Technical Support for POS for .NET

Technical Support for POS for .NET
POS for .NET v1.12 SDK Documentation >

1/18/2008

Contact your Premier Support Services contact for technical support.


Copyright Information for POS for .NET v1.12

Copyright Information for POS for .NET v1.12 |
 | See Also
POS for .NET v1.12 SDK Documentation >

1/18/2008

Information in this document, including URL and other Internet Web site references, is subject to change without notice. Unless otherwise noted, the example companies, organizations, products, domain names, e-mail addresses, logos, people, places, and events depicted herein are fictitious, and no association with any real company, organization, product, domain name, e-mail address, logo, person, place, or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Microsoft Corporation.

Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Microsoft, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

© 2008 Microsoft Corporation. All rights reserved.

Microsoft, MS-DOS, JScript, MSDN, Visual Basic, Visual C#, Visual C++, Visual J#, Visual Studio, Windows, Windows NT, Windows Server, Windows Vista, and Win32 are trademarks of the Microsoft group of companies.

All other trademarks are property of their respective owners.

See Also

Concepts

POS for .NET v1.12 SDK Documentation


What's New for POS for .NET

What's New for POS for .NET
POS for .NET v1.12 SDK Documentation >

1/18/2008

This section provides an overview of what's new in POS for .NET API content.

In This Section

What's New in POS for .NET v1.12

Describes API changes introduced in POS for .NET 1.12.

What's New in POS for .NET v1.11

Describes API changes introduced in POS for .NET 1.11.

What's New in POS for .NET v1.1

Describes API changes introduced in POS for .NET 1.1.

Related Sections

POS for .NET v1.11 Documentation Updates

Provides an overview of documentation updates for POS for .NET.


What's New in POS for .NET v1.12

What's New in POS for .NET v1.12 |
 | See Also
POS for .NET v1.12 SDK Documentation > What's New for POS for .NET >

1/18/2008

The following sections show the new device topics in the POS for .NET 1.12 Software Development Kit (SDK). POS for .NET has been updated to be fully compliant with the latest release of the UPOS specification. Please provide feedback by using the Send Feedback link included in the topics.

New Device Classes in the POS for .NET 1.12 Release

New Device Class | UPOS Version Introduced
Belt | 1.12
ElectronicValueRW | 1.12
Gate | 1.12
ItemDispenser | 1.12
Lights | 1.12
RFIDScanner | 1.12

Updated Device Classes in the POS for .NET 1.12 Release

Updated Class | Added Members
Msr | CapCardAuthentication property, CapDataEncryption property, CapDeviceAuthentication property, CapTrackDataMasking property, AdditionalSecurityInformation property, CardAuthenticationData property, CardAuthenticationDataLength property, DataEncryptionAlgorithm property, DeviceAuthenticated property, DeviceAuthenticationProtocol property, Track1EncryptedData property, Track1EncryptedDataLength property, Track2EncryptedData property, Track2EncryptedDataLength property, Track3EncryptedData property, Track3EncryptedDataLength property, Track4EncryptedData property, Track4EncryptedDataLength property, AuthenticateDevice method, DeauthenticateDevice method, RetrieveDeviceAuthenticationData method , UpdateKey method
FiscalPrinter | PrintRecItemRefund method, PrintRecItemRefundVoid method

See Also

Reference

Microsoft.PointOfService


What's New in POS for .NET v1.11

What's New in POS for .NET v1.11 |
 | See Also
POS for .NET v1.12 SDK Documentation > What's New for POS for .NET >

1/18/2008

The following sections show the new device topics in the POS for .NET 1.11 Software Development Kit (SDK). POS for .NET has been updated to be fully compliant with the release of the UPOS specification. Please provide feedback by using the Send Feedback link included in each topic.

New Device Classes in the POS to .NET 1.11 Release

New Device Class | UPOS Version Introduced
BillAcceptor | 1.11
BillDispenser | 1.11
Biometrics | 1.10
CoinAcceptor | 1.11
ElectronicJournal | 1.10
ImageScanner | 1.11

Updated Classes in the POS for .NET 1.11 Release

Updated Class | Added Members
CashChanger | CapJamSensor property, CapRealTimeData property, CurrentService property, RealTimeDataEnabled property, ServiceCount property, ServiceIndex property, AdjustCashCounts method.
CheckScanner | ClearInputProperties method.
CoinDispenser | AdjustCashCounts method, ReadCashCounts method.
FiscalPrinter | CapPositiveSubtotalAdjustment property, PrintRecItemVoid method, PrintRecItemAdjustmentVoid. The CapAmountNotPaid and PrintRecVoidItem methods have been deprecated and are now obsolete.
Keylock | CapKeylockType property, ElectronicKeyValue property.
Micr | ClearInputProperties method.
Msr | CapWritableTracks property, EncodingMaxLength property, TracksToWrite property, ClearInputProperties method, WriteTracks method.
PinPad | ClearInputProperties method.
PointCardRW | ClearInputProperties method.
Scanner | ClearInputProperties method.

See Also

Concepts

What's New in POS for .NET v1.1

Other Resources

POS for .NET v1.11 Documentation Updates


POS for .NET v1.11 Documentation Updates

POS for .NET v1.11 Documentation Updates
POS for .NET v1.12 SDK Documentation > What's New for POS for .NET > What's New in POS for .NET v1.11 >

1/18/2008

This section provides an overview of documentation updates for POS for .NET.

In This Section

December 2006 Documentation Update

Describes Documentation changes for December 2006.

October 2006 Documentation Update

Describes Documentation changes for October 2006.

September 2006 Documentation Update

Describes Documentation changes for September 2006.

Related Sections

What's New in POS for .NET v1.11

Provides an overview of new features added to POS for .NET v1.11.

What's New in POS for .NET v1.1

Provides an overview of new features added to POS for .NET v1.1.


December 2006 Documentation Update

December 2006 Documentation Update |
 | See Also
What's New for POS for .NET > What's New in POS for .NET v1.11 > POS for .NET v1.11 Documentation Updates >

1/18/2008

The following table shows the new topics in the December documentation release for the POS for .NET 1.11 Software Development Kit (SDK). Please provide feedback by using the Send Feedback link included in the topics.

New Topics

New Topic | Description
Biometrics | Describes the Biometrics device type.
BillAcceptor | Describes the Bill Acceptor device type.
BillDispenser | Describes the Bill Dispenser device type.
Updated CashChanger | Describes new properties in compliance with the UPOS v1.11 specification.
CoinAcceptor | Describes a Coin Acceptor device type.
CoinDispenser | Describes a Coin Dispenser device type.
ElectronicJournal | Describes Electronic Journal device type.
Updated FiscalPrinter | Describes new properties and removed deprecated properties in compliance with the UPOS v1.11 specification.
ImageScanner | Describes a new Image Scanner device type.
Updated Keylock | Describes new properties in compliance with the UPOS v1.11 specification.
Service Object Overview | Describes how Service Objects are used by applications to communicate with POS devices.
POS Exception Handling | Describes how to handle exceptions in the POS for .NET architecture.
Event Management | Explains how applications can use events sent from Service Objects.
DeviceInfo Class | Provides greater detail in the update.
Event Handler Sample | Provides a code sample demonstrating event handlers in POS for .NET applications.
Device Input and Events | Explains how events are generated for various types of input.
Device Output Models | Explains the asynchronous and synchronous output models.
Asynchronous Output Sample | Provides a sample demonstrating the use of the asynchronous output features provided by POS for .NET.
Statistics Sample | Provides a sample demonstrating how a Service Object records statistics, and how those statistics can be monitored by the application.
Base Class DirectIO Method | Explains the situations where using vendor-specific direct IO is necessary.
Capability Properties | Explains how capability and other properties should be accessed from within a Service Object.
What's New in POS for .NET v1.11 | Describes the features introduced in POS for .NET v1.11.
Using Visual Studio .NET Management Extensions and the WEPOS WMI Management Classes | Provides updated sample code.

See Also

Concepts

What's New for POS for .NET
POS for .NET v1.12 SDK Documentation

Other Resources

POS for .NET v1.11 Documentation Updates


October 2006 Documentation Update

October 2006 Documentation Update |
 | See Also
What's New for POS for .NET > What's New in POS for .NET v1.11 > POS for .NET v1.11 Documentation Updates >

1/18/2008

The following table shows the new topics in the October documentation release for the POS for .NET 1.1 Software Development Kit (SDK). Please provide feedback by using the Send Feedback link included in the topics.

New Topic | Description
Developing Service Objects Using Base Classes | Provides an overview of features which support developing Service Objects using POS for .NET Base classes.
Device Input and Events | Describes how Service Objects retrieve data and events from the device and notify the application.
Base Class DirectIO Method | Explains how Service Objects should implement the DirectIO method to provide vendor-specific data to the application.
Scanner Implementation | Provides an overview and samples for developing a Scanner Service Object.
Scanner Events | Provides an overview of events sent by Scanner Service Objects.
Data Decoding | Explains how data decoding is used in a Scanner Service Object.
CashDrawer Implementation | Provides an overview for developing a CashDrawer Service Object using the POS for .NET Base class.
LineDisplay Implementation | Provides an overview and sample code for developing a Service Object for a Line Display device.
LineDisplay Sample | Provides sample code for a LineDisplay Service Object.
PinPad Implementation | Provides an overview and sample code for developing a PinPad Service Object.
PinPad Capabilities | Provides an overview of the features supported by a PinPad Service Object.
PinPad Sample | Provides sample code for developing a PinPad Service Object.
PosKeyboard Implementation | Provides sample code for developing a PosKeyboard Service Object.

See Also

Concepts

September 2006 Documentation Update
What's New for POS for .NET
POS for .NET v1.12 SDK Documentation

Other Resources

POS for .NET v1.11 Documentation Updates


September 2006 Documentation Update

September 2006 Documentation Update |
 | See Also
What's New for POS for .NET > What's New in POS for .NET v1.11 > POS for .NET v1.11 Documentation Updates >

1/18/2008

The following table shows the new topics in the September documentation release for the POS for .NET 1.1 Software Development Kit (SDK). Please provide feedback by using the Send Feedback link included in the topics.

New Topic | Description
Technical Support for POS for .NET | Provides technical support beyond the scope of this document.
POS for .NET v1.11 Documentation Updates | Lists all Help topics added or updated in this release.
What's New in POS for .NET v1.1 | Describes the features introduced in POS for .NET v1.1.
POS for .NET v1.12 Features | Provides a high-level overview of the POS for .NET architecture.
POS for .NET Architecture | Describes POS for .NET application architecture and organization.
Supported Device Classes | Describes the POS devices recognized by POS for .NET and the level of support that they receive.
POS for .NET Integration with Plug and Play | Describes how POS for .NET supports Windows Plug and Play device detection.
Log Files | Explains how to create and interpret POS for .NET log files.
Integration of Legacy Service Objects | Describes how legacy Service Objects are supported by POS for .NET.
Developing a POS Application | Provides an overview of POS for .NET API support and links to specific important API classes and conceptual topics.
Typical POS Application Architecture | Illustrates the typical architecture model of a POS application.
POS for .NET API Support | Outlines how the POS for .NET API can help developers create simple and robust applications.
PosCommon Class | Describes the PosCommon class, the Base class upon which each Service Object class or interface is built.
PosExplorer Class | Describes the PosExplorer class, a key part of POS for .NET functionality.
DeviceInfo Class | Describes the DeviceInfo class and implementation.
Exception Classes | Describes the POS exception classes and their associated error codes.
Developing a Custom Service Object | Demonstrates how to create POS for .NET applications which use Service Objects to communicate with hardware devices.
POS for .NET Service Object Architecture | Presents an overview of the POS for .NET architecture used for building custom Service Objects.
POS for .NET Class Tree | Provides an overview of the POS for .NET class structure.
Attributes for Identifying Service Objects and Assigning Hardware | Describes how the POS for .NET architecture uses reflection and .NET attributes to locate assemblies and identify service objects.
Hydra Devices | Provides a broad overview of the problems involved when developing for hardware that may be in use by several Service Objects simultaneously.
Plug and Play Support | Outlines how POS for .NET supports Plug and Play for Service Object writers.
PosCommon Information for Service Object Developers | Describes methods and properties of the PosCommon class that are central to POS for .NET functionality.
POS for .NET Device Basic Classes | Provides information about using the POS for .NET Basic classes as the starting point for Service Objects.
System Configuration | Provides information about settings and configuration for POS for .NET installations.
POS for .NET Registry Settings | Describes the POS for .NET registry settings, how they can be modified, and why you might want to do so.
POS Device Manager Output | Describes how to use the configuration file created by the POS Device Manager (POSDM.EXE).
Point of Service Performance Counters | Explains how to use POS for .NET performance counters to monitor your system.
Plug and Play XML Configuration | Demonstrates how POS devices can be associated with a specific Service Object using an XML file instead of assembly attributes.
Service Object Samples: Getting Started | Provides a step-by-step guide to creating a functional, multithreaded Service Object.
Setting up a Service Object Project | Explains how to use Visual Studio to create a class library project with references to the appropriate POS for .NET assemblies.
Creating a Basic Service Object Code Template | Demonstrates how to write the necessary references, attributes, and methods to create a fundamental Service Object template.
Adding Plug and Play Support | Demonstrates how to add Plug and Play support to a sample Service Object.
Creating a Service Object Sample | Demonstrates how to implement the methods needed to compile a sample Service Object.
Introducing Service Object Reader Threads | Introduces the concept of multithreaded programming in Service Objects.
Creating a Working, Multithreaded Service Object | Combines all of sample topics concepts to create a working, multithreaded MSR Service Object class.
POS Device Manager | Describes how WEPOS helps you to manage your POS devices.
Changing Windows Firewall Settings to Enable Remote Device Management | Describes how to allow remote device management through your firewall.
Using the Command Line to Enable Remote Management | Demonstrates how to use the POSDM command line to enable remote device management.
Using the WMI API to Manage Devices | Describes how to use WMI tools to manage your POS devices.
ServiceObject Class | Lists the properties and methods of the ServiceObject class.
PosDevice Class | Lists the properties and methods of the PosDevice class.
LogicalDevice Class | Lists the properties and methods of the LogicalDevice class.
DeviceProperty Class | Lists the properties and methods of the DeviceProperty class.
Using Visual Studio .NET Management Extensions and the WEPOS WMI Management Classes | Describes how to use Visual Studio and the WEPOS WMI management classes with your POS devices.
Using the POS Device Manager Command-Line Tool | Outlines how to use the POS Device Manager command-line tool.
Command-Line Help for POSDM | Demonstrates how to access Help about POSDM syntax, usage, and commands.
General POSDM Switches | Describes several commonly used POSDM command-line switches.
POSDM Commands | Provides a comprehensive list of the commands that you can use in POSDM.
POSDM Command Arguments | Describes several switches that you can use as arguments in POSDM.

See Also

Concepts

What's New in POS for .NET v1.11
POS for .NET v1.12 SDK Documentation

Other Resources

POS for .NET v1.11 Documentation Updates


What's New in POS for .NET v1.1

What's New in POS for .NET v1.1 |
 | See Also
POS for .NET v1.12 SDK Documentation > What's New for POS for .NET >

1/18/2008

POS for .NET 1.1 provides support for version 1.9 of the Unified Point of Service (UPOS) industry specification, as well as:

  • Enhanced support for legacy COM interoperability

  • Support for version 2.0 of the .NET Framework

Support for UPOS 1.9

The UPOS specification is a common architecture that all POS applications share. It is platform, hardware, and language independent and is the basis for nearly all POS design. Version 1.1 brings POS for .NET support of UPOS functionality up-to-date with the current version of UPOS, 1.9.

Enhanced Support for Legacy COM interoperability

POS for .NET 1.1 supports legacy COM interoperability for the following device classes:

  • Cash Drawer

  • Check Scanner

  • Coin Dispenser

  • Keylock

  • Line Display

  • MICR (Magnetic Ink Character Recognition Reader)

  • MSR (Magnetic Stripe Reader)

  • PIN Pad

  • POS Keyboard

  • POS Power

  • POS Printer

  • Scale

  • Scanner (Bar Code Reader)

  • Signature Capture

  • Tone Indicator

There is no legacy COM interoperability support for the following device classes at this time:

  • Bump Bar

  • Cash Changer

  • CAT (Credit Authorization Terminal)

  • Fiscal Printer

  • Hard Totals

  • Motion Sensor

  • Point Card Reader/Writer

  • Remote Order Display

  • Smart Card Reader/Writer

Library Compatibility with Applications and Service Objects

As new versions of the UPOS specification enter wider use, it is important to ensure that your POS applications dependent on them are supported by an up-to-date version of POS for .NET.

Compatibility scenarios are shown in the following table.

POS for .NET | Application | Service Object | Compatible
POS for .NET 1.1 (synchronized with UPOS v1.9) | UPOS v1.8 | UPOS v1.8 | Yes
 | UPOS v1.8 | UPOS v1.9 | Yes
 | UPOS v1.9 | UPOS v1.8 | Yes
 | UPOS v1.9 | UPOS v1.9 | Yes
POS for .NET 1.0 (synchronized with UPOS v1.8) | UPOS v1.8 | UPOS v1.8 | Yes
 | UPOS v1.8 | UPOS v1.9 | No
 | UPOS v1.9 | UPOS v1.8 | No
 | UPOS v1.9 | UPOS v1.9 | No

Support for version 2.0 of the .NET Framework

POS for .NET v1.1 supports version 2.0 of the .NET Framework and is fully compatible with all .NET v2.0 features. It is important to note that Microsoft .NET Framework 2.0 is not distributed with POS for .NET 1.1 and must downloaded separately.

See Also

Concepts

POS for .NET v1.12 SDK Documentation
What's New for POS for .NET

Other Resources

POS for .NET v1.11 Documentation Updates


POS for .NET v1.12 Features

POS for .NET v1.12 Features |
 | See Also
POS for .NET v1.12 SDK Documentation >

1/18/2008

Point of Service for .NET (POS for .NET) version 1.12 applies the power of .NET technology to provide a flexible, easy-to-use platform that supports retail POS applications and device peripherals.

POS for .NET implements the Unified Point of Service (UPOS) version 1.12 standard so that retailers, hospitality organizations, and industry partner companies can quickly and reliably configure .NET-based POS applications and device peripherals for interoperability.

POS for .NET tools and classes facilitate developing POS applications and device Service Objects.

In This Section

POS for .NET Architecture

Describes the POS for .NET architecture and the relationship between POS for .NET, POS devices, and applications.

Service Object Overview

Describes how Service Objects facilitate communication between the device and the application.

Supported Device Classes

Describes the POS devices that are recognized by POS for .NET and the level of support they receive.

Event Management

Describes how event management is implemented in POS for .NET.

POS Exception Handling

Discusses the exception classes used by POS for the.NET and POS for .NET error handling model.

POS for .NET Integration with Plug and Play

Describes how to integrate your POS device with Plug and Play functionality for Microsoft Windows.

Log Files

Describes the logging feature for recording POS for .NET, Service Object, and application events and debug log size limit.

Integration of Legacy Service Objects

Describes how POS for .NET supports legacy Service Objects.

Related Sections

Developing a POS Application

Outlines key POS for .NET concepts and features for developing POS applications.

Developing a Custom Service Object

Demonstrates how to create POS for .NET applications that use Service Objects to communicate with hardware devices.

POS Device Manager

Describes how Windows Embedded for Point of Service (WEPOS) enables you to manage your POS devices.

See Also

Concepts

What's New in POS for .NET v1.11


POS for .NET Architecture

POS for .NET Architecture |
 | See Also
POS for .NET v1.12 SDK Documentation > POS for .NET v1.12 Features >

1/18/2008

The POS for .NET architecture supports both developers writing POS applications and peripheral device hardware vendors writing .NET-based Service Objects. The following illustration shows the POS for .NET architecture.

Support for POS Applications

The POS for .NET public API provides POS applications with information about connected POS devices. The public API also creates instances of the Service Object (SO) classes for interacting with the devices.

POS for .NET uses Plug and Play for Windows Embedded to detect POS device connection and disconnection. The public API conveys Plug and Play events to the application.

For older applications, the POS for .NET legacy interoperability system exposes legacy OLE for Point of Service (OPOS) controls as .NET Service Objects.

For more information, see POS for .NET API Support.

Support for Service Objects

Hardware vendors write device-specific Service Objects that interact with peripheral hardware. The Service Objects also implement interfaces as specified in the Unified Point of Service (UPOS) standard. With POS for .NET device classes, hardware vendors can concentrate their efforts on implementing the device-specific details.

POS for .NET offers abstract Basic device classes for all of the device types defined in the UPOS specification. The enhanced Basic classes, called Base classes, supply functionality common to all POS devices. In addition, POS for .NET provides abstract Base device classes for nine devices. The Base classes further implement core POS functionality specific to the particular device class.

POS for .NET supplies Base classes for the following devices:

  • Cash Drawer

  • Check Scanner

  • Keyboard

  • Line Display

  • Magnetic Stripe Reader

  • Pin Pad

  • Printer

  • Scanner

  • RFID Scanner

See Also

Concepts

Typical POS Application Architecture
POS for .NET Integration with Plug and Play
Supported Device Classes

Other Resources

POS for .NET Service Object Architecture
POS for .NET v1.12 Features
POS for .NET API Support


Service Object Overview

Service Object Overview |
 | See Also
POS for .NET v1.12 SDK Documentation > POS for .NET v1.12 Features >

1/18/2008

Service Objects function as the interface between an application and a POS device. Each Service Object facilitates communication between the application and its associated device by implementing one device interface. The device interfaces provide the properties, methods, and events required by unique POS devices. This enables the application to manage and read data from them.

Not all devices receive the same level of support in POS for .NET. Each POS device that POS for .NET recognizes is provided with up to three levels of Interface classes that provide some level of functional support. The three levels of Interface classes are Interface classes, Basic classes, and Base classes. For more information about POS for .NET Interface classes, see POS for .NET Class Tree. For more information about the default level of support provided by Service Objects, see the individual entries for each Service Object in Microsoft.PointOfService.BaseServiceObjects and Supported Device Classes.

Because each Service Object facilitates communications with a specific device, a different Service Object instance must be created for each connected peripheral device.

See Also

Reference

PosCommon
Microsoft.PointOfService.BaseServiceObjects

Concepts

POS for .NET Architecture
Supported Device Classes
POS for .NET Device Basic Classes

Other Resources

Developing a Custom Service Object
POS for .NET Service Object Architecture


Supported Device Classes

Supported Device Classes |
 | See Also
POS for .NET v1.12 SDK Documentation > POS for .NET v1.12 Features >

1/18/2008

POS for .NET represents the 36 peripheral devices identified in the Unified Point of Service (UPOS) specification by abstract Interface and Basic device classes. POS for .NET also provides nine abstract Base device classes that further implement core POS functionality specific to those particular device types.

Hardware vendors use the device classes to create Service Objects that link their peripheral devices to the applications.

Interface Classes

POS for .NET supplies Interface classes for all 36 UPOS devices. The Interface classes provide the entry points as specified in the UPOS specification, but offer minimal functionality.

Basic Classes

POS for .NET Basic classes contain basic functional support for all 36 devices. Basic classes provide generic support for opening, claiming, and enabling the device, device statistics, and management of delivering events to the application. In addition, each Basic class contains a set of inherited and protected methods that can be implemented by the Service Object.

Base Classes

For the nine primary UPOS device types, POS for .NET supplies fully functional Base classes that extend their corresponding Basic classes with device-specific members. You could think of these classes as enhanced or extended Basic classes. Because Base classes provide a nearly complete implementation, Service Object developers should derive from these classes whenever possible.

UPOS Devices and POS for .NET Device Classes

The following table lists the UPOS devices with their equivalent POS for .NET Basic and Base device classes (where applicable).

UPOS Device | Interface Class | Basic Class | Base Class
Belt | Belt | BeltBasic |
Biometrics | Biometrics | BiometricsBasic |
Bill Acceptor | BillAcceptor | BillAcceptorBasic |
Bill Dispenser | BillDispenser | BillDispenserBasic |
Bump Bar | BumpBar | BumpBarBasic |
Cash Changer | CashChanger | CashChangerBasic |
Cash Drawer | CashDrawer | CashDrawerBasic | CashDrawerBase
CAT - Credit Authorization Terminal | Cat | CatBasic |
Check Scanner | CheckScanner | CheckScannerBasic | CheckScannerBase
Coin Acceptor | CoinAcceptor | CoinAcceptorBasic |
Coin Dispenser | CoinDispenser | CoinDispenserBasic |
Electronic Journal | ElectronicJournal | ElectronicJournalBasic |
Electronic Value Reader / Writer | ElectronicValueRW | ElectronicValueRWBasic |
Fiscal Printer | FiscalPrinter | FiscalPrinterBasic |
Gate | Gate | GateBasic |
Hard Totals | HardTotals | HardTotalsBasic |
Image Scanner | ImageScanner | ImageScannerBasic |
Item Dispenser | ItemDispenser | ItemDispenserBasic |
Keylock | Keylock | KeylockBasic |
Lights | Lights | LightsBasic |
Line Display | LineDisplay | LineDisplayBasic | LineDisplayBase
MICR - Magnetic Ink Character Recognition | Micr | MicrBasic |
Motion Sensor | MotionSensor | MotionSensorBasic |
MSR - Magnetic Stripe Reader | Msr | MsrBasic | MsrBase
PIN Pad | PinPad | PinPadBasic | PinPadBase
Point Card Reader / Writer | PointCardRW | PointCardRWBasic |
POS Keyboard | PosKeyboard | PosKeyboardBasic | PosKeyboardBase
POS Power | PosPower | PosPowerBasic |
POS Printer | PosPrinter | PosPrinterBasic | PosPrinterBase
Remote Order Display | RemoteOrderDisplay | RemoteOrderDisplayBasic |
RFID Scanner | RFIDScanner | RFIDScannerBasic | RFIDScannerBase
Scale | Scale | ScaleBasic |
Scanner (Bar Code Reader) | Scanner | ScannerBasic | ScannerBase
Signature Capture | SignatureCapture | SignatureCaptureBasic |
Smart Card Reader / Writer | SmartCardRW | SmartCardRWBasic |
Tone Indicator | ToneIndicator | ToneIndicatorBasic |

See Also

Reference

Microsoft.PointOfService
Microsoft.PointOfService.BaseServiceObjects

Concepts

What's New in POS for .NET v1.11

Other Resources

POS for .NET v1.12 Features


Event Management

Event Management |
 | See Also
POS for .NET v1.12 SDK Documentation > POS for .NET v1.12 Features >

1/18/2008

Events management represents one of the key aspects of programming applications for POS for .NET. All input in the POS for .NET system is event-driven, and each segment of the POS for .NET Architecture uses events to communicate with the other applications and Service Objects.

Event-Driven Processing Model

Event-driven input begins when an attached POS device receives data input. If that device is enabled (the DeviceEnabled property is set to true), then received data will be queued as a DataEvent event and sent to the application. Events are delivered in a first-in, first-out manner by an internal service thread. Just before this event is raised, a Service Object may use the PreFireEvent method to update properties before that event is sent off.

After the event data is received, the device will automatically disable itself (setting the DeviceEnabled property to false) if the AutoDisable property is set to true. While disabled, the device cannot queue new input, and the physical device will be disabled, if possible.

When the application is ready to receive input from the device, it sets the DataEventEnabled property to true. The application then starts to receive queued DataEvent events, even if those DataEvent events were queued before DataEventEnabled property was set to true.

Additional data events may be disabled by setting the DataEventEnabled property or the FreezeEvents property to false. This causes later input data to be queued while the application processes the current input and associated properties. When the application is ready for more data, it may re-enable events by setting the DataEventEnabled property to true.

Event-Driven Input and Device Sharing

If the input device is an exclusive-use device, the application must both claim and enable the device before it uses it to read input.

If the device is shareable, one or more applications must open and enable the device before it uses it to read input. An application must call the Claim method to request exclusive access to the device before the Service Object sends data to it by using DataEvent. If event-driven input is received but the device remains unclaimed, the input is buffered until an application claims the device and the DataEventEnabled property is set to true. This behavior promotes orderly sharing of the device between multiple applications, effectively passing the input focus between them.

Event-Driven Input and Error Handling

The device enters an error state if an error is encountered while receiving event-driven input. Then it queues an ErrorEvent event (that contains InputData or Input ErrorEvent loci). These events are not delivered until the DataEventEnabled property is set to true to guarantee orderly application sequencing. Each ErrorEvent indicates which one of two possible error loci is responsible:

  • InputData –Used if the error occurred while one or more DataEvent events are queued. The ErrorEvent jumps to the head of the event queue for immediate handling so that the application can immediately respond by clearing input or notifying the user of the error. Then finish processing the buffered input.

  • Input – Used if an error has occurred and no data is available. If input data is already queued when the error occurs, an ErrorEvent with the InputData locus is queued and delivered first, then the remaining DataEvents in the queue are raised and handled. Finally, an ErrorEvent with the Input value is sent to indicate that the queue is empty and no data is available. It is significant to notice that if an ErrorEvent with the InputData value was delivered and the application event handler responded with a Clear value, this InputData ErrorEvent is not delivered. Typically, this error is entered at the end of the event queue.

The device may exit the Error state when one of the following occurs:

  • The application returns from the Input ErrorEvent.

    The application returns from the InputData ErrorEvent with a Clear value for the ErrorResponse property.

  • The application calls the ClearInput method.

For some devices, the application must call a method to begin event-driven input. After the input is received by the Service Object, then typically no additional input will be received until the method is called again. Examples for devices that use this variation of event-driven input, also known as asynchronous input, include the magnetic ink character recognition (MICR) and Signature Capture devices. The DataCount property can be read to obtain the number of DataEvent events in the queue.

All input in the queue can be deleted by calling the ClearInput method. ClearInput may be called after Claim for exclusive-use devices or Open for shareable devices.

The general event-driven input model does not prevent the definition of device classes that contain methods or properties that return input data directly. An example of this variation of event-driven input, also known as synchronous input, is the Keylock device.

Event Types

POS for .NET implements Unified Point of Service (UPOS) events as standard .NET events with multicast delegates. The events inform an application of various activities or changes with a device, such as when a device is added or removed. The following table lists the event types.

Event | Description
DataEvent | An event raised by the Service Object to notify the application that input data is available.
ErrorEvent | An event raised by the Service Object to notify the application that a device error has occurred and that a suitable response by the application is necessary to process the error condition.
StatusUpdateEvent | An event raised by the Service Object to alert the application of a device status change.
OutputCompleteEvent | An event raised by the Service Object to notify the application that the queued output request has been completed successfully.
DirectIOEvent | An event raised by the Service Object to communicate information directly to the application.

The Service Object must stack these events on an internally created and managed queue. Events are delivered in a first-in, first-out manner and are delivered by an internal service thread.

The following conditions cause event delivery to be delayed until the condition is corrected:

  • The application has set the FreezeEvents property to true. The FreezeEvents property allows events to be queued but prevents their delivery until FreezeEvents is set to false.

  • The event is a DataEvent or an input ErrorEvent but the property DataEventEnabled is false.

Rules for event queue management are as follows:

  • The device may only queue new events while the device is enabled.

  • The device delivers queued events until the application calls the Close method or, for exclusive-use devices, the Release method. When these methods are called, any remaining events in the queue are deleted.

  • The ClearInput method clears DataEvents and input DeviceErrorEvents (ErrorLocus = Input or InputData).

  • The ClearOutput method clears output DeviceErrorEvents (ErrorLocus = Output).

See Also

Reference

FreezeEvents
StatusUpdateEvent
DirectIOEvent
ErrorLocus

Concepts

Device Output Models
POS Exception Handling


POS Exception Handling

POS Exception Handling |
 | See Also
POS for .NET v1.12 SDK Documentation > POS for .NET v1.12 Features >

1/18/2008

Error handling in POS for .NET is built on the object-oriented model of throwing and catching exceptions. Different exceptions are thrown in response to run-time errors, and each exception contains information about the error that triggered it in the form of an ErrorCode.

The ErrorCode property of a thrown exception holds information about the cause of the error. Possible values for this property represent the full set of standard Point of Service (UPOS) error codes. For more information about the mapping between UPOS error codes and the POS for .NET ErrorCode values, see POS for .NET Exception Classes.

POS for .NET provides four exception classes to help applications better handle errors. These are PosException, PosControlException, PosManagementException, and PosLibraryException:

  • PosException is an abstract class that holds general exception data. PosException fulfills a role similar to that of the System.Exception class in the .NET Framework, and is the POS for .NET implementation of the UposException class in the UPOS specification. All other POS for .NET exception classes are derived from PosException.

  • PosControlException is the standard exception thrown by POS for .NET Service Objects. PosControlException contains a ErrorCode property which holds information about the cause of the exception.

  • PosLibraryException holds the exception data generated by PosExplorer during class operations. PosLibraryException does not contain an ErrorCode property.

  • PosManagementException holds the exception data generated by POS for .NET management APIs. PosManagementException does not contain an ErrorCode property.

Error Handling in POS for .NET

Error handling in POS for .NET is compliant with UPOS specification guidelines. Error handling is event-driven, uses error codes to store exception information, and is largely implementation-specific.

Handling errors in POS for .NET follows this general procedure:

  1. An error is thrown by event-driven input.

  2. The device changes its State property to indicate that it has encountered an error.

  3. An ErrorEvent event is queued to alert the application that an error has occurred. The ErrorEvent is added to the end of the queue.

  4. If one or more DataEvent events are queued in front of the ErrorEvent event, another ErrorEvent is queued and added at the head of queue. This warns the application about the error quickly so it can respond in an implementation-specific manner prior to processing any queued DataEvents.

  5. If the applications properties are configured to accept events (DataEventEnabled is true and FreezeEvents is false), it responds to the ErrorEvent event in a manner determined by the ErrorResponse property, as indicated in the following table.

    Value Meaning of Response

    Clear

    Clears any buffered DataEvent events and ErrorEvent events, exits the Error state, and changes the device State to Idle.

    ContinueInput

    Acknowledges the error and directs the device to continue processing. The device remains in the Error state and will deliver additional data events as directed by the DataEventEnabled property. When all input has been delivered, and the DataEventEnabled property is again set to true, another ErrorEvent is delivered with the locus Input.

    Retry

    Directs the device to retry the input. The Error state is exited, and State is changed to Idle. This response is only selected when the device chapter specifically allows it and when the locus is Input.

    The application may also take implementation-specific steps to respond to the error at this time.

See Also

Reference

PosException
PosLibraryException
PosManagementException
PosControlException
ErrorCode
PosExplorer

Concepts

PosExplorer Class
Exception Classes
Event Management


POS for .NET Integration with Plug and Play

POS for .NET Integration with Plug and Play |
 | See Also
POS for .NET v1.12 SDK Documentation > POS for .NET v1.12 Features >

1/18/2008

POS for .NET leverages Windows Embedded Plug and Play technology specifications to detect peripheral POS devices that are enabled for Plug and Play. Plug and Play support simplifies the installation and maintenance of POS devices.

PosExplorer

The POS for .NET PosExplorer class serves as the interface between Plug and Play notifications and POS applications. PosExplorer translates the relevant Plug and Play notifications into POS for .NET events, which it then sends to the POS application.

Plug and Play Events

The PosExplorer class exposes two Plug and Play events for use by POS applications:

  • DeviceAddedEvent

    The DeviceAddedEvent triggers when a POS device is connected to the system.

  • DeviceRemovedEvent

    The DeviceRemovedEvent triggers when a POS device is disconnected from the system.

See Also

Reference

DeviceAddedEvent
DeviceRemovedEvent

Concepts

PosExplorer Class
Supported Device Classes
Plug and Play Support

Other Resources

POS for .NET v1.12 Features


Log Files

Log Files |
 | See Also
POS for .NET v1.12 SDK Documentation > POS for .NET v1.12 Features >

1/18/2008

POS for .NET includes a logging feature for recording POS for .NET, Service Objects, and application events. Logging parameters are read from the POS for.NET registry key, \HKLM\SOFTWARE\POSfor.NET\Logging, and entries are written using the Logger class.

Enabling Logging

Logging is enabled when the registry key \HKLM\SOFTWARE\POSfor.NET\Logging\Enabled is set to any non-zero value.

Log File Size

The maximum log file size is specified in the registry key \HKLM\SOFTWARE\POSfor.NET\Logging\MaxLogFileSizeMB. If this file size is exceeded while logging is enabled, logging will stop. There will be no exception or error returned to the application.

By default, the maximum log file size is 10 megabyte (MB).

Log File Location

The registry key \HKLM\SOFTWARE\POSfor.NET\Logging\location is used to determine where log files will be written.

By default, this location is set to the environment variable %TEMP% which, in Windows, defaults to the directory C:\Documents and Settings\(username)\Local Settings\temp. This is a per-user directory.

Log File Names

Log file names are composed of three elements:

  • The base file name contained in the registry key \HKLM\SOFTWARE\POSfor.NET\Logging\Name. The default for this value is PosFor.Net.

  • A timestamp in this format: (yyyy-mm-dd hh-mm-ssZ)

  • The file extension .txt.

This is an example of a typical log file name:

PosFor.Net(2006-08-10 18-33-29Z).txt

Log File Header

A header containing information such as the user, OS, calling thread, and process is written to each log file when it is created. This header includes the following fields:

  • Current user: The name of the current user.

  • Computer name: The name of the computer creating the log.

  • OS version: The version of Windows that is being run, including service packs.

  • .Net runtime: The version of the .NET runtime.

  • Process Id: The PID of the process that created the log file.

  • Thread Id: The thread that created the log.

  • Max log file size: The maximum file size to be used for this log file.

  • File: The name of the executable that created the log file.

  • InternalName: The internal name of the executable.

  • OriginalFilename: The original name of the executable.

  • FileVersion: The version information stored in the executable.

  • FileDescription: The description stored in the executable.

  • Product: The product description stored in the executable.

  • ProductVersion: The file version stored in the executable.

  • Debug: Debug flag.

  • Patched: Patched file.

  • PreRelease: Pre-release flag.

  • PrivateBuild: Private build flag.

  • SpecialBuild: Special build flag.

  • Language: The language used to create the log file.

Log File Entries

Log entries can be created by POS for .NET or by either the application or the Service Object. Entries are created by calling the appropriate method on an instance of the Logger class.

Each entry contains the following fields:

  • Timestamp.

  • Thread ID that created the entry.

  • Importance level. Each log entry is marked with its level of importance which is determined by which Logger method is involved.

    Importance Tag in Log Entries Corresponding Logger Method

    INFO

    Logger.Info

    WARNING

    Logger.Warning

    ERROR

    Logger.Error
  • Name string specified by the code that called the Logger method. This string is specified when the Logger method is invoked and may not necessarily contain the name of the executable.

  • For example, a typical entry in the log file would look like this:

    [8/10/2006 6:12:14 PM 2936 INFO PosExplorer] Entering LoadExplorer()

Comments

If there is a log file open, and the application calls the Refresh method, the file is closed and a new one created with the updated time stamp.

See Also

Reference

Logger

Concepts

POS for .NET Registry Settings
Plug and Play Support

Other Resources

POS Device Manager
System Configuration


Integration of Legacy Service Objects

Integration of Legacy Service Objects |
 | See Also
POS for .NET v1.12 SDK Documentation > POS for .NET v1.12 Features >

1/18/2008

POS for .NET supports both .NET-based Service Objects and legacy OLE for Point of Service (OPOS), COM-based Service Objects. POS for .NET provides applications with the same interface to both generations of Service Objects.

See Also

Concepts

What's New for POS for .NET

Other Resources

POS for .NET v1.12 Features


Developing a POS Application

Developing a POS Application
POS for .NET v1.12 SDK Documentation >

1/18/2008

Microsoft Point of Service for .NET (POS for .NET) provides classes and tools that make writing robust POS applications simple and easy.

Service Object classes represent POS peripheral devices, supplying the properties, methods, and events that are defined in the Unified Point of Service (UPOS) Retail Peripheral Architecture specification.

The PosExplorer class lets applications enumerate installed POS devices, instantiate Service Objects for them, and receive Plug and Play events when a POS peripheral device is connected or disconnected.

With the POS Device Manager command-line tool, administrators can configure POS devices attached to the system.

In This Section

Typical POS Application Architecture

Describes the POS for .NET application architecture and organization.

POS for .NET API Support

Provides an overview of POS for .NET API support and links to specific important API classes and conceptual topics.

Event Handler Sample

Demonstrates the use of POS for .NET events in an application.

Related Sections

POS for .NET v1.12 Features

Provides a high-level overview of the POS for .NET system.

POS Device Manager

Describes the use of the POS Device Manager to configure a POS for .NET installation.

Developing a Custom Service Object

Demonstrates how to create a POS for .NET application, which uses Service Objects to communicate with hardware devices.


Typical POS Application Architecture

Typical POS Application Architecture |
 | See Also
POS for .NET v1.12 SDK Documentation > Developing a POS Application >

1/18/2008

The principal elements of POS application architecture are event handlers and the public interface to Service Objects and the POS for .NET PosExplorer Class, as shown in the following illustration.

Event Handlers

POS for .NET uses five Service Object events to inform POS applications of POS device activities or changes, as specified in the Unified Point of Service (UPOS) standard.

The PosExplorer Class translates Plug and Play notifications into events that it sends to applications.

Applications implement event handlers to manage these events.

Public Interface to Service Objects

Service Objects expose public methods and properties to POS applications, including those defined in the UPOS standard.

POS applications use those methods and properties to get device status and to transfer data to and from devices.

Public Interface to PosExplorer

The PosExplorer class exposes public methods to POS applications that create Service Objects and provide information about Service Objects and devices.

See Also

Concepts

POS for .NET Architecture
PosExplorer Class

Other Resources

POS for .NET Service Object Architecture
Developing a POS Application


POS for .NET API Support

POS for .NET API Support
POS for .NET v1.12 SDK Documentation > Developing a POS Application >

1/18/2008

The POS for .NET class library supports the development of POS applications with Base classes that support POS devices, exceptions, and events. The POS for .NET class library also provides applications with the ability to discover and load Service Objects using the PosExplorer and DeviceInfo classes.

In This Section

PosExplorer Class

Describes the PosExplorer class, a key component of POS for .NET functionality.

DeviceInfo Class

Describes the DeviceInfo class and implementation.

Exception Classes

Describes the POS exception classes and their associated ErrorCode properties.

PosCommon Class

Describes the PosCommon class, the Base class upon which each Service Object class or interface is built.

Related Sections

Typical POS Application Architecture

Illustrates the architecture model of a POS application.

Developing a POS Application

Provides an overview of POS for .NET API support and supplies links to important POS for .NET device classes and conceptual Help topics.

Microsoft.PointOfService

Contains the POS for .NET API topics, including the PosExplorer and PosCommon classes, as well as interfaces for specific POS devices.


PosCommon Class

PosCommon Class |
 | See Also
POS for .NET v1.12 SDK Documentation > Developing a POS Application > POS for .NET API Support >

1/18/2008

PosCommon is the Base class for all specific Interface classes, and all Service Objects indirectly derive from it. PosCommon defines the common properties, methods, and events that the Unified Point of Service (UPOS) specification requires in all device classes.

PosCommon Properties

The following table describes the properties of the PosCommon class available to POS applications.

Property | Type | Description
CapCompareFirmwareVersion | bool | Indicates whether the Service Object and device supports comparing the firmware version in the physical device against that of a firmware file.
CapPowerReporting | PowerReporting enum | Indicates the power reporting capabilities of the device.
CapStatisticsReporting | bool | Indicates whether the device can accumulate and can provide various statistics regarding usage.
CapUpdateStatistics | bool | If set to true, some or all of the device statistics can be reset to 0 (zero) using the ResetStatistic method for one update and ResetStatistics method for a list of updates, or updated using the UpdateStatistic method for one update and the UpdateStatistics method for a list of updates with the corresponding specified values.
CapUpdateFirmware | bool | Indicates whether the device's firmware can be updated via the UpdateFirmware method.
CheckHealthText | string | Indicates the health of the device.
Claimed | bool | Indicates whether the device is claimed for exclusive access.
DeviceDescription | string | Holds a string identifying the device and the company that manufactured it.
DeviceEnabled | bool | Indicates whether the device is in an operational state.
DeviceName | string | UPOS calls it PhysicalDeviceName; OPOS calls it DeviceName.
DevicePath | string | Set by POS for .NET for Plug and Play devices. For non-Plug and Play devices, DevicePath can be assigned using a configuration file.
FreezeEvents | bool | When set to true, the application has requested that the Service Object not deliver events.
PowerNotify | PowerNotification enum | Holds the type of power notification selection made by the application.
PowerState | PowerState enum | Holds the current power condition.
ServiceObjectDescription | string | Identifies the Service Object supporting the device and the company that produced it. This property is listed as DeviceServiceDescription in the UPOS specification.
ServiceObjectVersion | System.Version | Holds the Service Object version number. This property is listed as DeviceServiceVersion in the UPOS specification.
State | ControlState enum | Holds the current state of the device.
SynchronizingObject | ISynchronizeInvoke | Gets or sets the marshalling object for event handler calls from a POS event.

PosCommon Methods

The following table describes the methods of the PosCommon class available to applications.

Method | Return Type | Description
CheckHealth | string | Performs a health check on the device. The type of check to be performed is indicated by the HealthCheckLevel parameter. The method also updates the CheckHealthText property.
Claim | void | Requests exclusive access to the device. Service Object writers are advised to only throw exceptions in unexpected conditions; for example, OutOfMemory. Otherwise, Service Objects should return True if the device was claimed and False if a time-out occurred.
Close | void | Releases the device and its resources.
CompareFirmwareVersion | CompareFirmwareResult | Determines whether the version of the specified firmware is newer than, older than, or the same as the version of firmware in the physical device.
DirectIO | DirectIOData | Used to communicate directly with the Service Object. In the UPOS specification, it has two in/out parameters. As used by POS for .NET, this method returns a structure and no in/out parameters.
Open | void | Opens a device for subsequent input/output processing.
Release | void | Releases exclusive access to the device.
ResetStatistic | void | Resets the specified statistic to zero. Used in POS for .NET for operations on a single statistic.
ResetStatistics | void | Resets all statistics for a specified category to 0 (zero).
ResetStatistics | void | Resets the specified statistics to 0 (zero).
ResetStatistics | void | Resets all statistics associated with a device to 0 (zero).
RetrieveStatistic | string | Retrieves the specified device statistic. Used in POS for .NET for operations on a single statistic.
RetrieveStatistics | string | Retrieves all device statistics.
RetrieveStatistics | void | Retrieves the statistics for the specified category.
RetrieveStatistics | void | Retrieves the specified statistics.
UpdateFirmware | void | Updates the firmware of a device with the version of the firmware contained in the specified filename.
UpdateStatistic | void | Updates a statistic. Added to POS for .NET for operations on a single statistic.
UpdateStatistics | void | Updates a list of statistics with the corresponding specified values.
UpdateStatistics | void | Updates the specified category of statistics with the specified value.

PosCommon Events

The following table describes the PosCommon class events.

Method | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change.

Example

The following code example demonstrates how to use the properties and methods common to all Service Objects to display information about a connected device.

Copy Code
    // Create a dervied class of PosCommon
    public class PosCommonSample: PosCommon
    {
        // Implement all base methods and properties.
        // ...
    }

    // Create instances for the example.
    PosExplorer explorer = new PosExplorer();
    PosCommonSample pcs = new PosCommonSample();
    DeviceInfo device = explorer.GetDevice("MSR");
    pcs = (PosCommonSample)explorer.CreateInstance(device);

    // Open and claim the device, then print information
    // about the device to the console.
    pcs.Open();
    pcs.Claim(1000);
    Console.WriteLine("Name: {0}", pcs.DeviceName);
    Console.WriteLine("Description: {0}", pcs.DeviceDescription);
    Console.WriteLine("Path: {0}", pcs.DevicePath);
    Console.WriteLine("Enabled: {0}", pcs.DeviceEnabled);

    pcs.Close();

See Also

Concepts

POS for .NET Class Tree


PosExplorer Class

PosExplorer Class |
 | See Also
POS for .NET v1.12 SDK Documentation > Developing a POS Application > POS for .NET API Support >

1/18/2008

PosExplorer provides Point of Service (POS) applications with a single entry point to POS for .NET services. PosExplorer supports applications by:

  • Enumerating installed POS devices.

  • Instantiating Service Objects.

  • Receiving Plug and Play events when a POS peripheral device is connected or disconnected.

PosExplorer Properties

The following table describes PosExplorer properties.

Property | Type | Description
PosRegistryKey | string | Returns POS for .NET configuration root registry key relative to HKEY_LOCAL_MACHINE.
StatisticsFile | string | Returns a path to the file where device statistics are contained.
SynchronizingObject | ISynchronizeInvoke | Holds the ISynchronizeInvoke object.

PosExplorer Methods

The following table describes PosExplorer methods.

Method | Return Type | Description
CreateInstance | PosDevice | Instantiates a Service Object for the device.
GetDevice | DeviceInfo | Returns a device of the specified type (must be only one in the system).
GetDevice | DeviceInfo | Returns a device of the type with the specified logical name or alias.
GetDevices | DeviceCollection | Returns all POS devices.
GetDevices | DeviceCollection | Returns all POS devices with the specified compatibility level.
GetDevices | DeviceCollection | Returns POS devices of the type.
GetDevices | DeviceCollection | Returns POS devices of the type and compatibility level.
Refresh | None | Re-enumerates the list of attached POS devices and rebuilds internal data structures.

PosExplorer Events

The following table describes PosExplorer events.

Event | Description
DeviceAddedEvent | Received when a Plug and Play-compatible POS device is connected.
DeviceRemovedEvent | Received when a Plug and Play-compatible POS device is disconnected.

Example

The following code example demonstrates how to create an instance of PosExplorer, connect to Plug and Play events, and use it to identify all connected Magnetic Stripe Reader (MSR) devices. The code example prints information about the MSR to the console and closes the device after it has finished.

Copy Code
// Creates a new instance of an MSR.
void CreateMsr(DeviceInfo msrinfo)
{
   msr = (Msr)explorer.CreateInstance(msrinfo);
   msr.Open();
   msr.Claim(1000);
   msr.DeviceEnabled = true;
}

static void Main(string[] args)
{

   // Create a new instance of PosExplorer and use it to
   // collect device information.
   PosExplorer explorer = new PosExplorer();
   DeviceCollection devices = explorer.GetDevices();

   // Search all connected devices for an MSR, print its service
   // object name to the console, and close it when finished.
   foreach (DeviceInfo device in devices)
   {
      if (device.Type == DeviceType.Msr)
      {
         if (device.ServiceObjectName == currentMsr)
         {
            CreateMsr(device);
            Console.WriteLine(device.ServiceObjectName);

            // It is important that applications close all open
            // Service Objects before terminating.
            msr.Close();
            msr = null;
         }
      }
   }
}

See Also

Concepts

POS for .NET Integration with Plug and Play

Other Resources

POS for .NET API Support
Developing Service Objects Using Base Classes


DeviceInfo Class

DeviceInfo Class |
 | See Also
POS for .NET v1.12 SDK Documentation > Developing a POS Application > POS for .NET API Support >

1/18/2008

The DeviceInfo class supplies POS applications with information about POS devices and the Service Objects associated with them. The PosExplorer methods, GetDevice and GetDevices return instances of DeviceInfo.

DeviceInfo Properties

The following table shows the DeviceInfo properties.

Property | Type | Description
Compatibility | DeviceCompatibilities | Lists the valid compatibility levels for a POS device (an OLE for Point of Service (OPOS) or .NET Service Object).
Description | string | Describes the Service Object.
HardwareDescription | string | Describes the physical device.
HardwareId | string | Provides the ID of the physical device.
HardwarePath | string | Provides the physical hardware path of the device.
IsDefault | bool | Returns true if the device is the default for its type.
LogicalNames | strings[] | Provides the alternative name(s) assigned to the device in the global configuration file by POS Device Manager (POSDM).
ManufacturerName | string | Provides the physical device manufacturer name.
ServiceObjectName | string | Provides the name of the Service Object.
ServiceObjectVersion | Version | Provides the Service Object version.
DeviceType | string | Provides the physical device type.
UposVersion | Version | Provides the UPOS version number.

DeviceInfo Methods

The following table shows the DeviceInfo methods.

Method | Return Type | Description
IsDeviceInfoOf | bool | Returns true if the Service Object corresponds to the DeviceInfo class properties.
ToString | string | Returns a string that describes the properties of the device.

Populating DeviceInfo Properties

The following table provides the sources for the information used by the PosExplorer methods GetDevice(System.String), and GetDevices when populating and returning instances of DeviceInfo. The table describes how PosExplorer populates DeviceInfo properties for three types of devices:

  • POS for .NET devices using Plug and Play

  • POS for .NET devices that are not using Plug and Play

  • Legacy OLE for Point of Service (OPOS) devices

Numbered lists show the sequence in which information sources are accessed. Iteration through the sequence stops when the sought-after data is first acquired.

DeviceInfo Property Information Source(s) for POS for .NET Plug and Play Devices Information Source(s) for POS for .NET Non-Plug and Play Devices Information Source(s) for Legacy OPOS Devices

Compatibility

PosExplorer sets to CompatibilityLevel1.

PosExplorer sets to CompatibilityLevel1.

PosExplorer sets to Opos.

Description

ServiceObject attribute in a Service Object assembly.

ServiceObject attribute in Service Object assembly.
  1. OPOS registry Description value under Device Name Key.

  2. OPOS registry Device Name Key subkey under Device Class Key.

HardwareDescription

Windows Plug and Play subsystem.

Blank.

Blank.

HardwareId

  1. HardwareId attribute in a Service Object assembly.

  2. XML configuration file in location specified by the ControlConfigs registry key.

Blank.

Blank.

HardwarePath

Windows Plug and Play subsystem.
  • Blank, or

  • POS Device Manager (POSDM) global configuration file as specified by adddevice or setpath.

Blank.

IsDefault

POSDM global configuration file as specified by setdefault.

POSDM global configuration file as specified by setdefault.

POSDM global configuration file as specified by setdefault.

LogicalNames

POSDM global configuration file as specified by addname.

POSDM global configuration file as specified by addname.
  1. POSDM global configuration file as specified by addname.

  2. The logical device name(s) as defined in the OPOS registry.

ManufacturerName

PosAssembly attribute in a Service Object assembly.

PosAssembly attribute in Service Object assembly.

Blank.

ServiceObjectName

ServiceObject attribute in a Service Object assembly.

ServiceObject attribute in Service Object assembly.

OPOS registry Device Name Key subkey under Device Class Key.

ServiceObjectVersion

Service Object AssemblyVersion attribute.

Service Object AssemblyVersion attribute.

OPOS registry Version value under Device Name Key.

DeviceType

ServiceObject attribute in a Service Object assembly.

ServiceObject attribute in Service Object assembly.

OPOS registry Device Class Key.

UposVersion

ServiceObject attribute in a Service Object assembly.

ServiceObject attribute in Service Object assembly.

OPOS registry Version value under Device Name Key.

See Also

Concepts

PosExplorer Class
Exception Classes

Other Resources

Developing a POS Application
POS for .NET API Support
POS Device Manager


Exception Classes

Exception Classes |
 | See Also
POS for .NET v1.12 SDK Documentation > Developing a POS Application > POS for .NET API Support >

1/18/2008

POS for .NET error handling is implemented through the use of exceptions. The four POS for .NET exception classes are as follows:

  • PosException

  • PosControlException

  • PosManagementException

  • PosLibraryException

Standard UPOS error codes are represented by the ErrorCode enumeration.

PosException

PosException is the Base exception class for PosControlException, PosManagementException, and PosLibraryException. PosException is derived from System.Exception.

PosControlException

PosControlException is the standard exception thrown by Service Objects to POS for .NET applications.

PosManagementException

PosManagementException is thrown by POS for .NET Device Management. Applications and Service Objects must not throw PosManagementException.

PosLibraryException

PosLibraryException is thrown by PosExplorer. Applications and Service Objects must not throw PosLibraryException.

Error Codes

The following table provides a mapping between the UPOS standard error codes and the ErrorCode values that POS for .NET provides.

POS ErrorCode Member | UPOS Error Code | Error Cause
Busy | E_BUSY | The current Service Object state does not allow this request.
Claimed | E_CLAIMED | Another Service Object instance has already claimed the POS device.
Closed | E_CLOSED | The POS device is closed.
Deprecated | E_DEPRECATED | The method has been deprecated and is no longer available.
Disabled | E_DISABLED | The operation cannot be performed while the device is disabled.
Exists | E_EXISTS | The file name or other specified value already exists.
Extended | E_EXTENDED | A device-specific error condition occurred.
Failure | E_FAILURE | The POS device cannot perform the requested procedure, even though the device is connected to the system and active.
Illegal | E_ILLEGAL | The POS application attempted an illegal or unsupported operation with the device, or used an invalid parameter value.
NoExist | E_NOEXIST | The file name or other specified value does not exist.
NoHardware | E_NOHARDWARE | The POS device is not connected to the system or is not turned on.
NoService | E_NOSERVICE | The Service Object cannot communicate with the device, normally because of a setup or configuration error.
NotClaimed | E_NOTCLAIMED | The POS application attempted to access an exclusive-use device that must be claimed before the method or property set action can be used.
Offline | E_OFFLINE | The POS device is offline.
Timeout | E_TIMEOUT | The Service Object timed out waiting for a response from the POS device.

Example

The following code example demonstrates how MSR handles POS exceptions and uses the ErrorCodes contained in those exceptions to gather information about them.

Copy Code
// Create a new instance of the MSR and opens the device.
msr = (Msr)explorer.CreateInstance(msrinfo);
msr.Open();

// Try to enable the device without first claiming it.
// This will throw a PosControlException which, through
// its ErrorCode, will yield information about the exception.
try
{
   msr.DeviceEnabled = true;
}
catch (PosControlException e)
{

   // Examine the ErrorCode to determine the cause of the error.
   if (e.ErrorCode == ErrorCode.NoHardware)
   {
      Console.WriteLine("The POS device is not connected ");
      Console.WriteLine("to the system or is not turned on.");
   }
   if (e.ErrorCode == ErrorCode.Timeout)
   {
      Console.WriteLine("The Service Object timed out
            waiting for a response from the POS device.");
   }

   // The example has not claimed the MSR, which is an
   // exclusive-access device, before trying to enable
   // it. This will throw the PosControlException
   // and trigger the following conditional block.
   // Once triggered, the MSR will be claimed and enabled.
   if (e.ErrorCode == ErrorCode.NotClaimed)
   {
      Console.WriteLine("The POS application attempted to access ");
      Console.WriteLine("an exclusive-use device that must be ");
      Console.WriteLine("claimed before the method or property ");
      Console.WriteLine("set action can be used.")
      msr.Claim(1000);
      msr.DeviceEnabled = true;
   }
}

See Also

Reference

PosException
PosControlException
PosManagementException
PosLibraryException

Concepts

PosExplorer Class
POS Exception Handling

Other Resources

POS for .NET API Support


Event Handler Sample

Event Handler Sample |
 | See Also Example
POS for .NET v1.12 SDK Documentation > Developing a POS Application >

1/18/2008

This sample demonstrates how applications can register handlers for any of the five event types supported by POS for .NET:

  • DataEvent

  • ErrorEvent

  • StatusUpdateEvent

  • OutputCompleteEvent

  • DirectIOEvent

It also shows how an application manages asynchronous output requests to a PosPrinter device.

To create the sample project

  1. Compile and install the Service Object sample code from Asynchronous Output Sample.

  2. Create a Windows Application project in Visual Studio 2005.

  3. The code section below includes two files, AsyncApp.cs and AsyncApp.Designer.cs.

  4. In the newly created project, replace Form1.cs with AsyncApp.cs and Form1.Designer.cs with AsyncApp.Designer.cs.

  5. Compile and run.

To run the sample

  1. This sample displays a GUI user interface that allows the user to send asynchronous and synchronous print requests to the Asynchronous Output Sample Service Object.

  2. The Service Object waits for several seconds before returning from a request, whether it is synchronous or asynchronous.

  3. The UI displays the status of each request in the text box.

Example

This sample code demonstrates several key points:

  • Using an OutputCompleteEvent event to notify the application that the Service Object has completed an output request.

  • Registering event handlers, including using reflection to do so.

  • Using PosExplorer to search for specific Service Objects.

To demonstrate how reflection can be used to discover which events are available on a given object, this code uses the PosCommon object returned from CreateInstance without first casting it to a PosPrinter. In most cases, an application does not need to be generic in that way and so would cast the object as appropriate.
Copy Code
// ASYNCAPP.CS
using System;
using System.Collections.Generic;
using System.ComponentModel;
using System.Data;
using System.Drawing;
using System.Text;
using System.Threading;
using System.Windows.Forms;
using System.Reflection;
using Microsoft.PointOfService;

namespace AsyncOutputApp
{
    public partial class AsyncApp : Form
    {
        PosCommon posCommon;
        PosExplorer posExplorer;

        public AsyncApp()
        {
            InitializeComponent();

            btnPrintAsync.Enabled = true;
            btnPrintSync.Enabled = true;

            posExplorer = new PosExplorer(this);
            posCommon = null;

            string SOName = "AsyncOutputPrinter";

            try
            {
                OpenDevice(SOName);
                SetupEvents();
            }
            catch
            {
                MessageBox.Show("The Service Object '" +
                        SOName + "' failed to load",
                        "Service Object Error",
                        MessageBoxButtons.OK,
                        MessageBoxIcon.Exclamation);

                btnPrintAsync.Enabled = false;
                btnPrintSync.Enabled = false;
            }
        }

        private void OpenDevice(string SOName)
        {
            string str = txtPrintResults.Text;
            DeviceInfo device = null;

            txtPrintResults.Clear();

            {
                // Retrieve the list of PosPrinter Service Objects.
                DeviceCollection devices =
                        posExplorer.GetDevices(
                        DeviceType.PosPrinter);

                // Iterate through the list looking for the one
                // needed for this sample.
                foreach(DeviceInfo d in devices)
                {
                    if(d.ServiceObjectName == SOName)
                    {
                        device = d;
                        break;
                    }
                }

                if (device == null)
                {
                    throw new Exception("Service Object not found");
                }

                txtPrintResults.Text = "Opening device: " +
                        device.ServiceObjectName + ", type: " +
                        device.Type + "\r\n";

                posCommon =
                        (PosCommon)posExplorer.CreateInstance(device);

                posCommon.Open();
                posCommon.Claim(0);
                posCommon.DeviceEnabled = true;
            }
        }

        // When this button is pressed, AsyncMode is turned off,
        // and the application waits for each print request
        // to complete before regaining control.
        private void btnPrintSync_Click(object sender, EventArgs e)
        {
            PosPrinter posPrinter = posCommon as PosPrinter;
            posPrinter.AsyncMode = false;

            txtPrintResults.AppendText(
                        "Printing will take place " +
                        "synchronously.\r\n");

            StartPrinting();
        }

        // When this button is pressed, AsyncMode is turned on. Print
        // requests will be queued and delivered on a
        // first-in-first-out basis.
        private void btnPrintAsync_Click(object sender, EventArgs e)
        {
            PosPrinter posPrinter = posCommon as PosPrinter;
            posPrinter.AsyncMode = true;

            txtPrintResults.AppendText(
                        "Printing will take place " +
                        "asynchronously.\r\n");

            StartPrinting();
        }

        private void StartPrinting()
        {
            PosPrinter posPrinter = posCommon as PosPrinter;

            txtPrintResults.AppendText(
                        "Calling PrintNormal to start " +
                        "printing...\r\n");

            // Notice that calling PrintNormal() here may not result
            // in a print request being sent immediately to the
            // printer. In asynchronous mode, the requested is
            // placed in a first-in-first-out queue managed by
            // POS for .NET.
            try
            {
                posPrinter.PrintNormal(
                            PrinterStation.Receipt,
                            "This is do-nothing print data");
            }
            catch (PosControlException e)
            {
                txtPrintResults.AppendText(
                            "PrintNormal threw a " +
                            "PosControlException! Description: " +
                            e.Message + "\r\n");

                return;
            }

            // When data is sent to an output device, POS for .NET
            // updates the OutputId property in the target object.
            // When an OutputCompleteEvent is sent to the app,
            // the OutputCompleteEventArgs will contain this id.
            Int32 id = posPrinter.OutputId;

            txtPrintResults.AppendText(
                        "PrintNormal has returned! OutputID = " +
                        id + "\r\n");
        }

        // Visual Studio-generated code.
        private void AsyncApp_Load(object sender, EventArgs e)
        {
        }

        #region Event Registration
        private void SetupEvents()
        {
            // All PosCommon objects support StatusUpdateEvent and
            // DirectIOEvent events, so simply register a handler
            // for those events.
            posCommon.StatusUpdateEvent +=
                        new StatusUpdateEventHandler(
                        co_OnStatusUpdateEvent);

            posCommon.DirectIOEvent +=
                        new DirectIOEventHandler(
                        co_OnDirectIOEvent);

            // In addition to the events common to all devices
            // (StatusUpdateEvent and DirectIOEvent), a device
            // type may also support DataEvent, ErrorEvent, or
            // OutputCompleteEvent events.
            //
            // In this example, the following code uses reflection
            // to determine which events are supported by this
            // object (posCommon).
            //
            // However, in the general case, an application will know
            // what type of device was returned when PosExplorer
            // CreateInstance() was called;therefore will not
            // need to use reflection, but can instead register
            // event handlers using the mechanism used for
            // StatusUpdateEvent and DirectIOEvent events above.
            EventInfo dataEvent =
                        posCommon.GetType().GetEvent(
                        "DataEvent");
            if (dataEvent != null)
            {
                dataEvent.AddEventHandler(posCommon,
                        new DataEventHandler(
                        co_OnDataEvent));

                txtPrintResults.AppendText("Registering Event: " +
                        "DataEvent\r\n");
            }

            EventInfo errorEvent =
                        posCommon.GetType().GetEvent(
                        "ErrorEvent");
            if (errorEvent != null)
            {
                errorEvent.AddEventHandler(posCommon,
                        new DeviceErrorEventHandler(
                        co_OnErrorEvent));

                txtPrintResults.AppendText("Registering Event: " +
                        "ErrorEvent\r\n");
            }

            EventInfo outputCompleteEvent =
                        posCommon.GetType().GetEvent(
                        "OutputCompleteEvent");
            if (outputCompleteEvent != null)
            {
                outputCompleteEvent.AddEventHandler(
                        posCommon, new OutputCompleteEventHandler(
                        co_OnOutputCompleteEvent));

                txtPrintResults.AppendText("Registering Event: " +
                        "OutputCompleteEvent\r\n");
            }
        }
        #endregion Event Registration

        #region Event Handlers
        private void co_OnDataEvent(
                        object obj,
                        DataEventArgs d)
        {
            txtPrintResults.AppendText(d.ToString() + "\r\n");
        }

        private void co_OnStatusUpdateEvent(
                        object source,
                        StatusUpdateEventArgs d)
        {
            txtPrintResults.AppendText(d.ToString() + "\r\n");
        }

        private void co_OnDirectIOEvent(
                        object source,
                        DirectIOEventArgs d)
        {
            txtPrintResults.AppendText(d.ToString() + "\r\n");
        }

        private void co_OnErrorEvent(
                        object source,
                        DeviceErrorEventArgs d)
        {
            string str = d.ToString();

            MessageBox.Show(d.ToString(),
                        "OnErrorEvent called",
                        MessageBoxButtons.OK,
                        MessageBoxIcon.Error);

            txtPrintResults.AppendText(d.ToString() + "\r\n");
        }

        private void co_OnOutputCompleteEvent(
                        object source,
                        OutputCompleteEventArgs d)
        {
            txtPrintResults.AppendText(d.ToString() + "\r\n");
        }
        #endregion Event Handlers
    }
}
Copy Code
// ASYNCAPP.DESIGNER.CS
namespace AsyncOutputApp
{
    partial class AsyncApp
    {
        /// <summary>
        /// Required designer variable.
        /// </summary>
        private System.ComponentModel.IContainer components = null;

        /// <summary>
        /// Clean up any resources being used.
        /// </summary>
        /// <param name="disposing">true if managed resources should be disposed; otherwise, false.</param>
        protected override void Dispose(bool disposing)
        {
            if (disposing && (components != null))
            {
                components.Dispose();
            }
            base.Dispose(disposing);
        }

        #region Windows Form Designer generated code

        /// <summary>
        /// Required method for Designer support - do not modify
        /// the contents of this method with the code editor.
        /// </summary>
        private void InitializeComponent()
        {
            this.txtPrintResults = new System.Windows.Forms.TextBox();
            this.btnPrintSync = new System.Windows.Forms.Button();
            this.btnPrintAsync = new System.Windows.Forms.Button();
            this.SuspendLayout();
            //
            // txtPrintResults
            //
            this.txtPrintResults.BackColor = System.Drawing.SystemColors.Window;
            this.txtPrintResults.Location = new System.Drawing.Point(12, 119);
            this.txtPrintResults.Multiline = true;
            this.txtPrintResults.Name = "txtPrintResults";
            this.txtPrintResults.ReadOnly = true;
            this.txtPrintResults.ScrollBars = System.Windows.Forms.ScrollBars.Vertical;
            this.txtPrintResults.Size = new System.Drawing.Size(650, 200);
            this.txtPrintResults.TabIndex = 3;
            //
            // btnPrintSync
            //
            this.btnPrintSync.Location = new System.Drawing.Point(12, 12);
            this.btnPrintSync.Name = "btnPrintSync";
            this.btnPrintSync.Size = new System.Drawing.Size(132, 39);
            this.btnPrintSync.TabIndex = 1;
            this.btnPrintSync.Text = "Print Synchronous";
            this.btnPrintSync.UseVisualStyleBackColor = true;
            this.btnPrintSync.Click += new System.EventHandler(this.btnPrintSync_Click);
            //
            // btnPrintAsync
            //
            this.btnPrintAsync.Location = new System.Drawing.Point(12, 57);
            this.btnPrintAsync.Name = "btnPrintAsync";
            this.btnPrintAsync.Size = new System.Drawing.Size(132, 39);
            this.btnPrintAsync.TabIndex = 2;
            this.btnPrintAsync.Text = "Print Asynchronously";
            this.btnPrintAsync.UseVisualStyleBackColor = true;
            this.btnPrintAsync.Click += new System.EventHandler(this.btnPrintAsync_Click);
            //
            // AsyncApp
            //
            this.AutoScaleDimensions = new System.Drawing.SizeF(6F, 13F);
            this.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font;
            this.ClientSize = new System.Drawing.Size(685, 331);
            this.Controls.Add(this.btnPrintAsync);
            this.Controls.Add(this.btnPrintSync);
            this.Controls.Add(this.txtPrintResults);
            this.Name = "AsyncApp";
            this.Text = "Form1";
            this.Load += new System.EventHandler(this.AsyncApp_Load);
            this.ResumeLayout(false);
            this.PerformLayout();

        }

        #endregion

        private System.Windows.Forms.TextBox txtPrintResults;
        private System.Windows.Forms.Button btnPrintSync;
        private System.Windows.Forms.Button btnPrintAsync;
    }
}

The program should display the following text if you first press the Print Synchronous and then the Print Asynchronous button.

Opening device: AsyncOutputPrinter, type: PosPrinterRegistering Event: ErrorEventRegistering Event: OutputCompleteEventPrinting will take place synchronously.Calling PrintNormal to start printing...PrintNormal has returned! OutputID = 0Printing will take place asynchronously.Calling PrintNormal to start printing...PrintNormal has returned! OutputID = 1Microsoft.PointOfService.OutputCompleteEventArgs, TimeStamp: 11:35:39 AM, EventId: 1, OutputId: 1.

See Also

Tasks

Asynchronous Output Sample

Concepts

Event Management

Other Resources

Developing a Custom Service Object


Developing a Custom Service Object

Developing a Custom Service Object
POS for .NET v1.12 SDK Documentation >

1/18/2008

The POS for .NET SDK delivers support for developing UPOS-compliant applications. The POS for .NET class tree delivers support for both applications that use a specific UPOS device, and Service Objects which provide the link between the physical hardware and the application.

Service Objects are typically implemented by independent hardware vendors (IHVs) to provide an interface between POS for .NET applications and the IHVs particular UPOS device. The POS for .NET SDK includes a set of .NET classes which you can use to create fully functional, UPOS-compliant Service Objects. By taking advantage of the POS for .NET SDK classes, you can write Service Objects quickly and with relatively little device-specific code.

In This Section

POS for .NET Service Object Architecture

Presents an overview of the POS for .NET architecture used for building custom Service Objects.

System Configuration

Provides information about settings and configuration for POS for .NET installations.

Service Object Samples: Getting Started

Provides a step-by-step guide to creating a functional, multithreaded Service Object.

Developing Service Objects Using Base Classes

POS for .NET includes a nearly complete Base class implementation for nine POS device types. This section explains how to use these classes as a foundation for device-specific Service Objects.

Device Input and Events

Explains how events are used to send input from the POS device to the application.

Device Output Models

Explains the difference between synchronous and asynchronous output to POS devices.

Asynchronous Output Sample

Implements a simple PosPrinterBase Service Object in order to demonstrate how POS for .NET manages asynchronous output.

Statistics Sample

Implements a sample Service Object that uses the POS for .NET statistics methods.

Base Class DirectIO Method

Explains how Service Objects can implement the method DirectIO to provide access to manufacturer-specific data to the application.

Capability Properties

Demonstrates how certain properties, such as capability properties, are set by the Service Object.

Related Sections

POS for .NET v1.12 Features

Provides a high-level overview of the POS for .NET system.

Developing a POS Application

Provides details for creating a POS application using POS for .NET.

POS Device Manager

Describes using POS Device Manager to configure a POS for .NET installation.


POS for .NET Service Object Architecture

POS for .NET Service Object Architecture
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object >

1/18/2008

There are features and design elements in POS for .NET that must be taken into account by Service Object developers. This section includes topics discussing several of these important concepts.

In This Section

POS for .NET Class Tree

Provides an overview of the POS for .NET class structure. POS for .NET Service Object classes are derived from an appropriate class in this tree.

Attributes for Identifying Service Objects and Assigning Hardware

Explains how POS for .NET uses reflection and .NET attributes to locate POS for .NET assemblies and identify valid Service Objects within those assemblies.

Hydra Devices

Provides a broad overview of the problems involved when developing for hardware that may be in use by several Service Objects simultaneously.

Plug and Play Support

Provides an overview of Plug and Play support available to Service Object developers.

PosCommon Information for Service Object Developers

Describes methods and properties of PosCommon that are useful to Service Object developers.

POS for .NET Device Basic Classes

Provides information about using the POS for .NET Basic classes as the starting point for Service Objects.

Related Sections

POS for .NET Architecture

Describes the components that support developers writing POS applications as well as peripheral device hardware vendors writing .NET-based Service Objects.

Typical POS Application Architecture

Describes event handlers and the public interface to Service Objects and the PosExplorer Class as the principal elements of POS application architecture.

Service Object Samples: Getting Started

Includes a step-by-step guide to creating a functioning Service Object and demonstrates how the features discussed above are utilized.

Developing a POS Application

Explains how to create POS for .NET applications, the ultimate consumers of POS for .NET Service Objects.

System Configuration

Describes how to configure POS for .NET to meet the requirements of your installation.


POS for .NET Class Tree

POS for .NET Class Tree |
 | See Also
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object > POS for .NET Service Object Architecture >

1/18/2008

The POS for .NET SDK contains a set of classes which provide the Service Object with much of the functionality needed to meet the UPOS specification. There are three levels of base classes, referred to as Interface, Basic, and Base classes.

At the base of the class tree is PosCommon Class . Interface classes are derived from PosCommon, Basic classes are derived from Interface classes, and Base classes are derived from Basic classes. For each POS device type, there are separate Interface, Basic, and Base classes.

The POS for .NET base classes follow a specific naming convention. Interface classes are represented by just the short name of the device type (for example, Scanner or Msr). Basic classes append the suffix Basic after the name used for the Interface class (for example, MsrBasic or ScannerBasic). And finally, Base classes use the suffix Base (for example, MsrBase or ScannerBase). For the complete list of class names, see Supported Device Classes.

Interface Classes

The Interface classes are the most fundamental base classes provided by POS for .NET. There is an Interface class for each of the 36 device types in the UPOS specification, and they contain methods and properties that correspond to those required by the specification. They provide no device-specific functionality so deriving from these classes requires the Service Object developer to provide the greatest amount of additional code and therefore should rarely be used directly.

Basic Classes

Basic classes are derived from their corresponding Interface class. There is a Basic class for all 36 devices supported by the UPOS specification. These classes provide some functionality and are the best choice if no Base class exists for your device type. Basic classes, however, implement only the UPOS common members.

Base Classes

The Base classes, each of which is derived from its corresponding Basic class, offer the greatest level of functionality. The Base classes provide nearly complete Service Object implementations. By deriving from these classes, the Service Object developer only needs to implement code to control the specific hardware device. Since Base classes provide so much functionality, Service Object developers should use them whenever possible. POS for .NET provides Base-level support for only nine primary device types.

UPOS Device | Corresponding POS for .NET Base Class
Cash Drawer | CashDrawerBase
Check Scanner | CheckScannerBase
Line Displays | LineDisplayBase
Magnetic Stripe Reader | MsrBase
Pin Pad | PinPadBase
POS Keyboards | PosKeyboardBase
POS Printers | PosPrinterBase
RFIDScanner | RFIDScanner
Scanner (Bar Code Reader) | ScannerBase

See Also

Concepts

Supported Device Classes

Other Resources

Developing a Custom Service Object
POS for .NET Service Object Architecture


Attributes for Identifying Service Objects and Assigning Hardware

Attributes for Identifying Service Objects and Assigning Hardware |
 | See Also
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object > POS for .NET Service Object Architecture >

1/18/2008

POS for .NET uses .NET reflection and .NET attributes to locate Service Object assemblies, identify Service Objects within those assemblies, and finally to associate a Plug and Play device with that Service Object. By leveraging these .NET features, PosExplorer can identify Service Objects within an assembly and quickly assess their Plug and Play requirements. The expensive process of loading a .NET assembly is delayed until needed by the application.

In order to provide these features, POS for .NET depends on three different .NET attributes:

  • PosAssembly

    This is a global, assembly-level attribute that tells PosExplorer that this is a POS for .NET assembly which contains one or more Service Objects. Generally, it should be set in your AssemblyInfo.cs source file. For an example, see Setting up a Service Object Project.

  • ServiceObject

    This attribute is applied to the Service Object class and specifies the type, name, and version information for the Service Object. See the Creating a Basic Service Object Code Template section for an example.

  • HardwareId

    This attribute is used to specify which hardware IDs will be used by this Service Object. This information is used by PosExplorer to filter out Service Objects that use Plug and Play hardware which is not currently plugged in. The HardwareId attribute allows multiples, so there may be several attached to a Server Object class. See the sample topic Adding Plug and Play Support for an example. For a more lengthy discussion of Plug and Play features, including how the HardwareId attribute is utilized, see the topics Adding Plug and Play Support and POS for .NET POS for .NET Integration with Plug and Play.

See Also

Reference

PosAssemblyAttribute
HardwareIdAttribute
ServiceObjectAttribute

Concepts

Plug and Play Support
POS for .NET Registry Settings

Other Resources

POS for .NET Service Object Architecture
System Configuration
Service Object Samples: Getting Started


Hydra Devices

Hydra Devices |
 | See Also
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object > POS for .NET Service Object Architecture >

1/18/2008

Some peripheral POS devices combine UPOS device types. These are referred to as Hydra devices, and their interface to the POS application requires more than one Service Object.

For example, a magnetic ink character recognition (MICR) device may include a POS printer. In that case, the device is represented by both a MICR Service Object and a POS printer Service Object. Even though they interact with the same peripheral device, both Service Objects must be created and controlled separately. The MICR Service Object manages the MICR check scanning and character recognition function and the POS printer Service Object manages the receipt and validation printers.

However, both MICR and POS printer Service Objects must work together in a single transaction. Check processing combines check insertion and removal operations in the MICR device with validation printing functions in the POS printer.

Considerations

In the normal case, a Service Object would simply open a connection to the device and perform its read and write operations. With Hydra devices, however, the task is more complicated since IO ports are normally exclusive. Therefore, multiple Service Objects accessing the same device must synchronize with each other, typically with some variety of inter-process communication.

POS for .NET offers no features to help multiple Service Objects synchronize with each other. The Service Object developer must write this code and tailor it to the specific system configuration.

See Also

Concepts

Service Object Overview

Other Resources

POS for .NET Service Object Architecture


Plug and Play Support

Plug and Play Support |
 | See Also
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object > POS for .NET Service Object Architecture >

1/18/2008

POS for .NET fully supports Windows Embedded Plug and Play technology. To utilize this feature, Service Object developers can simply add one or more HardwareId attributes to their code, or include the hardware reference in a Plug and Play XML Configuration file.

Adding this attribute to a Service Object helps application developers, who will now know that when they use PosExplorer to get a list of Service Objects, any Service Object in that list will be associated with a functioning POS device. The application benefits directly from this association by greater reliability and ease of use. We recommend that Service Objects support the Plug and Play feature whenever possible.

Plug and Play Behavior

Once the Service Object has been associated with the POS device's hardware ID, POS for .NET uses the Windows Plug and Play Manager to determine what POS devices are connected to the computer. No additional code is required by the application or Service Object.

When an application invokes the method PosExplorer.GetDevices, PosExplorer finds the device that is associated with each Plug and Play Service Object and then queries the Windows Plug and Play Manager to determine the device's status. If the device is not available, it will not be added to the device list that is returned to the application from PosExplorer.GetDevices.

PosExplorer Service Object Filtering

PosExplorer is able to effectively filter the list of Plug and Play Service Objects when the application calls PosExplorer.GetDevices. The filtering process works as follows:

  1. Searches for all assemblies in the specified POS for .NET directories.

  2. If the assembly is not marked with the PosAssembly global attribute, discards it.

  3. Searches for classes marked with the ServiceObject attribute. For each such class:

    1. Looks for a hardware ID associated with this class, as either a HardwareId attribute or within the Plug and Play XML Configuration file. If there is no hardware ID, leaves the Service Object in the PosExplorer list.

    2. If there is a hardware ID, then queries Windows to retrieve the device's status. If the device is attached to the computer, leaves it in the PosExplorer list.

    3. If the device is not attached to the computer, removes it from the PosExplorer list.

Example

The following code example demonstrates a simple method of handling Plug and Play events. Information generated by PosExplorer is used to instantiate the correct device, in this case a Magnetic Stripe Reader (MSR).

Copy Code
// Connect the Plug and Play events to detect the removal or
// connection of a new device.
   explorer.DeviceAddedEvent += new
         DeviceChangedEventHandler(explorer_DeviceAddedEvent);
   explorer.DeviceRemovedEvent += new
         DeviceChangedEventHandler(explorer_DeviceRemovedEvent);

// This event handler extends Plug and Play functionality to the MSR
// device type. A message is printed to the console if the connection
// is successful.
void explorer_DeviceAddedEvent(object sender, DeviceChangedEventArgs e)
{

   // Checks if the newly added device is an MSR.
   if (e.Device.Type == DeviceType.Msr)
   {

      // Checks if an MSR instance has already been created and,
      // if not,creates one. If a new MSR instance is created, its
      // name is recorded in a string and written to the console.
      // Once the printing is finished, the MSR is closed.
      if (msr == null)
      {
         CreateMsr(e.Device);
         strMsrConfig = e.Device.ServiceObjectName;
         Console.WriteLine(strMsrConfig);
         // It is important that applications close all open
         // Service Objects before terminating.
         msr.Close();
      }
   }
}

See Also

Tasks

Adding Plug and Play Support

Reference

PosExplorer
HardwareIdAttribute
PosAssemblyAttribute
ServiceObjectAttribute

Concepts

Attributes for Identifying Service Objects and Assigning Hardware
POS for .NET Registry Settings
Plug and Play XML Configuration

Other Resources

POS for .NET Service Object Architecture


PosCommon Information for Service Object Developers

PosCommon Information for Service Object Developers |
 | See Also
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object > POS for .NET Service Object Architecture >

1/18/2008

At the base of the POS for .NET Server Object class tree (Interface, Basic, Base) is PosCommon. This class is a direct implementation of the "Common Properties, Methods, and Events" chapter in the UPOS specification.

Each POS for .NET Basic class overrides or implements PosCommon properties and methods which are of particular importance to a Service Object developer. This topic provides information about these methods and properties.

CapPowerReporting Property

Once POS for .NET has successfully opened a device, it tries to retrieve the current value of the CapPowerReporting property. The PowerReporting class is initialized to None, indicating that the Service Object is not able to provide power reporting. If, however, the Service Object's device does support power reporting, the Service Object may set PowerReporting to Standard or Advanced in the Service Object's method.

CapStatisticsReporting Property

POS for .NET verifies that the device has been opened and then retrieves the current value of the CapStatisticsReporting property.

When statistics are created for the device, POS for .NET sets CapStatisticsReporting to true.

CapUpdateStatistics Property

POS for .NET verifies that the device has been opened and then retrieves the current value of the CapUpdateStatistics property.

When statistics are created for the device, and if those statistics can be reset or updated, then POS for .NET sets CapUpdateStatistics to true.

Claimed Property

POS for .NET verifies that the device has been opened, and then retrieves the current value of the Claimed property.

Claimed is initialized to false. Claimed should be set to true when the application calls the Claim method, then set back to false when the application calls the Release method.

DeviceDescription Property

POS for .NET verifies that the device has been opened, and then retrieves the current value of the DeviceDescription property.

DeviceEnabled Property

DeviceEnabled is a read/write property.

It can be used to return the object's current state; enabled or disabled. If this object has not been previously opened and enabled, this property returns false.

This property is also used to enable or disable the device by setting the property of the value to true or false. It is common for Service Objects to override this property and perform its hardware initialization and release here.

DeviceName Property

POS for .NET verifies that the device has been opened, and then retrieves the current value of the DeviceName property.

Within Base class implementations, this value is set automatically based on the contents of the ServiceObject attribute.

If you are not deriving from a POS for .NET Base class, and are instead deriving from an Interface-level or Basic-level class, then DeviceName should be set by the Service Subject during the Open method.

FreezeEvents Property

FreezeEvents is a read/write property.

POS for .NET verifies that the device has been opened and claimed, then retrieves or sets the current value of the FreezeEvents property. When this property is set to true, POS for .NET queues events until this property is set to false, not that the queuing mechanism can vary from one device type to another.

The FreezeEvents property is initialized to false.

PowerNotify Property

PowerNotify is a read/write property.

POS for .NET verifies that the device has been opened, then retrieves or sets the current value of PowerNotify. If PowerNotify is set, then power state notifications will be sent to the application.

PowerNotify is initialized to Disabled.

Attempting to set PowerNotify can cause the following exceptions to be thrown.

Value Meaning

Illegal

One of the following conditions has occurred:

  • The device is enabled.

  • P:Microsoft.PointOfService.PosCommon.CapPowerReporting is set to None, indicating that the device does not support power notification.

  • The specified value is not a valid T:Microsoft.PointOfService.PowerNotification enumeration value.

PowerState Property

POS for .NET verifies that the device has been opened, and then retrieves the current value of the PowerState property. If CapPowerReporting is set to None, PowerNotify is set to Disabled, or DeviceEnabled set to false, PowerState is returned as Unknown.

PowerState is initialized to Unknown. When PowerNotify is set to Enabled and DeviceEnabled is true, PowerState should be updated as the Service Object detects power condition changes. POS for .NET detects the state change when the Service Object sets PowerState and—if PowerNotify is set to Enabled—queues a StatusUpdateEvent event, notifying the application.

Setting PowerState can cause the following exceptions to be thrown.

Value Meaning

Illegal

One of the following conditions has occurred:

  • CapPowerReporting = Standard and PowerNotify is set to Online, Off, or Offline.

  • CapPowerReporting = Advanced and PowerState is set to Online, Off, or Offline.

ServiceObjectDescription Property

POS for .NET verifies that the device has been opened, and then retrieves the current value of the ServiceObjectDescription property. The Service Object developer should not have to set this value, since it is set by the POS for .NET Basic class using the description information provided in the ServiceObject attribute.

ServiceObjectVersion Property

POS for .NET verifies that the device has been opened, and then retrieves the current value of the ServiceObjectVersion property. The Service Object developer should not have to set this value, since it is set by the POS for .NET Basic class using the version information provided in the ServiceObject attribute.

State Property

No device state verification is required—the application can retrieve the current value of the State property.at any time.

State is initialized to Closed. If the Service Object sets State to an invalid ControlState value, POS for .NET throws an Illegal exception. Changes in State cause POS for .NET to queue a StateChangedEvent event.

Claim Method

POS for .NET verifies that the application has the device opened.

If the timeout parameter is set to a value less than -1, POS for .NET throws an exception. If the timeout value is set to -1, the Claim method will wait forever.

If the device is already claimed by the application, POS for .NET simply returns.

If the device is in use by another application, timeout is reached; POS for .NET throws a time-out exception.

If Claim is successful, POS for .NET loads the statistics for the device and sets the Claimed property to true.

Close Method

If the application calls the Close method when State is set to Closed, POS for .NET throws a Closed exception. If State is set to Busy, POS for .NET throws a Busy exception.

If the DeviceEnabled method when Claimed is set to false, POS for .NET throws an Illegal exception. If State is set to Busy, POS for .NET calls the ClearOutput method. If the device is enabled, POS for .NET sets DeviceEnabled to false. POS for .NET clears the event queue, and then sets Claimed to false.

ResetStatistic Method

POS for .NET verifies that the application has opened, claimed, and enabled the device, then calls the ResetStatistic method.

ResetStatistics() Method

POS for .NET verifies that the application has opened, claimed, and enabled the device, then calls the ResetStatistics method.

ResetStatistics(categories parameter) Method

POS for .NET verifies that the application has opened, claimed, and enabled the device, then calls the ResetStatistics method.

ResetStatistics(string parameter) Method

POS for .NET verifies that the application has opened, claimed, and enabled the device, then calls the ResetStatistics method.

RetrieveStatistic Method

POS for .NET verifies that the application has opened, claimed, and enabled the device, then calls the RetrieveStatistic method.

RetrieveStatistics() Method

POS for .NET verifies that the application has opened, claimed, and enabled the device, then calls the RetrieveStatistics method.

RetrieveStatistics(categories parameter) Method

POS for .NET verifies that the application has opened, claimed, and enabled the device, then calls the RetrieveStatistics method.

RetrieveStatistics(string parameter) Method

POS for .NET verifies that the application has opened, claimed, and enabled the device, then calls the RetrieveStatistics method.

UpdateStatistic Method

POS for .NET verifies that the application has opened, claimed, and enabled the device, then calls the UpdateStatistic method.

UpdateStatistics(categories parameter) Method

POS for .NET verifies that the application has opened, claimed, and enabled the device, then calls the UpdateStatistics method.

UpdateStatistics(statistic array parameter) Method

POS for .NET verifies that the application has opened, claimed, and enabled the device, then calls the UpdateStatistics method.

See Also

Reference

PosCommon

Concepts

POS for .NET Class Tree

Other Resources

Service Object Samples: Getting Started


POS for .NET Device Basic Classes

POS for .NET Device Basic Classes |
 | See Also
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object > POS for .NET Service Object Architecture >

1/18/2008

Each hardware device in POS for .NET is represented by both an abstract interface, such as CashDrawer class, and a Basic class, such as CashDrawerBasic. Basic classes derive from the underlying interface and contain basic functional support for the device. POS for .NET provides generic support for opening, claiming, and enabling the device, device statistics, and for managing delivery of events to the application. In addition, each Basic class contains a set of inherited and protected methods that can be implemented by the Service Object. This topic provides summary information about Basic classes that can be used by Service Objects that derive from the device’s Basic class, rather than taking advantage of the more fully implemented device Base class.

Constructor

Each Basic class includes a constructor that creates an instance of the class and initializes statistics for the UPOS version, the device category, and the installation date.

Common Properties and Methods

Each Basic class provides overridden PosCommon property and method definitions. For each of these properties and methods, the Basic class handles state validation—that is, verification that the application has opened, claimed, or enabled the device—and then calls the POS for .NET implementation of that property or method. For more information about the PosCommon class, see PosCommon.

The Service Object can use the CommonProperties class to update PosCommon properties that are designated read-only for the application, or to update those properties without worrying about state validation.

Dispose Methods

Each Basic class includes two implemented Dispose methods for use by the Service Object. For information about how these work, see the .NET Framework documentation for the IDisposable class.

Opening, Claiming, and Enabling Devices

Each Basic class provides the core functionality for opening, claiming, and enabling devices. Typically, though, Service Objects want to override these methods to add their own custom processing.

Protected Methods and Events for Service Object Developers

Each Basic class contains a group of methods and events for the Service Object developer.

The following protected properties are defined as follows:

  • CommonProperties property, which returns an instance of CommonProperties with get and set values for all PosCommon properties. The Service Object can use CommonProperties to update properties without worrying about state validation or whether the property is designated read-only for the application.

  • ExternallyClaimed property, which Service Objects can retrieve to determine if another instance of the device has been claimed (in which case, the property is set to true).

  • ErrorCount property. When the Service Object queries for the value of ErrorCount, the basic class checks the event queue and tallies the number of ErrorEvent events found, and then returns that tally as the value of ErrorCount.

  • DataCount property. POS for .NET verifies that the device has been opened, and then returns the number of DataEvent events currently queued for the device.

The following protected methods are defined:

  • StateChangedEvent and delegate StateChangedEventHandler (EventArgs class). The Service Object can implement these to receive notification when the device’s State property has changed.

  • PreFireEvent protected methods for each type of event supported by the device. Each basic class provides a default, generic implementation of PreFireEvent that returns immediately. If the Service Object needs to update its internal state prior to an event being sent to the application, the Service Object can override the default implementation of PreFireEvent and provide its own implementation for the event type in question.

  • QueueEvent protected methods for each type of event supported by the device. The Service Object calls QueueEvent to add an event to the event queue. The Basic class verifies that the device is enabled, and then adds the event to the event queue to be delivered to the application. Immediately before delivery, the Basic class calls the appropriate PreFireEvent to give the Service Object an opportunity to update its internal state. When PreFireEvent returns, the Basic class delivers the event to the application.

  • QueueEventAndWait protected methods. The Service Object calls QueueEventAndWait to add an ErrorEvent event or DirectIOEvent event to the event queue, from which the Service Object expects a response from the application. The Basic class verifies that the device is enabled, and then adds the event to the event queue, to be delivered to the application when conditions are correct. Immediately before delivery, the Basic class calls PreFireEvent to give the Service Object an opportunity to update its internal state. When PreFireEvent returns, the Basic class delivers the event to the application.

  • VerifyState method, which takes two Boolean values, mustBeClaimed and mustBeEnabled. The Service Object can call the POS for .NET implementation of this method to perform the necessary state validation for the device, prior to a method or property call.

  • CreateStatistic method. The Service Object should use these methods to create custom (that is, manufacturer-specific) statistics. POS for .NET handles the creation and management of all UPOS-defined statistics.

  • SetStatisticValue and IncrementStatistic methods allow the Service Object to update a specified statistic even if it is not defined as resettable (that is, these methods bypass the rules enforced by the PosCommon ResetStatistic and UpdateStatistic methods).

  • SetStatisticHandlers method, which allows Service Objects to provide external callback functions for the retrieval and setting of hardware-based statistics. If a get property is not defined, the Basic class assumes that the statistic is software-based, and its value is maintained in the statistics XML file. If both get and set properties are defined, the Basic class calls these functions whenever the statistic needs to be updated or reset. It is up to the Service Object to provide code to update the statistic in the hardware.

  • ClearInput method. POS for .NET clears the event queues for the device and then calls the Service Object’s implementation of ClearInputImpl.

  • ClearInputImpl method. The Service Object should implement this method to clear any hardware buffers for the device.

See Also

Other Resources

Developing a Custom Service Object
POS for .NET Service Object Architecture


System Configuration

System Configuration
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object >

1/18/2008

POS for .NET has several configurable settings which can be adapted to meet the needs of a particular installation. This section explains how to modify the various POS for .NET settings.

In This Section

POS for .NET Registry Settings

Shows which keys and values are used by POS for .NET and how they can be modified. Basic POS for .NET settings are stored in the Windows Registry.

POS Device Manager Output

Contains details about how to use the configuration file created by the POS Device Manager (POSDM.EXE).

Point of Service Performance Counters

Explains how to use POS for .NET performance counters to monitor your system.

Plug and Play XML Configuration

Demonstrates how POS devices can be associated with a specific Service Object using an XML file instead of assembly attributes.

Related Sections

Service Object Samples: Getting Started

Includes a step-by-step guide to creating a functioning Service Object and demonstrates how the features discussed above are utilized.

POS for .NET Service Object Architecture

Outlines the general concepts of the POS for .NET architecture.


POS for .NET Registry Settings

POS for .NET Registry Settings |
 | See Also
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object > System Configuration >

1/18/2008

POS for .NET stores certain configuration information in the system registry. During installation, default values are written to the registry. The POS for .NET values are stored under the key \HKLM\SOFTWARE\POSfor.NET. Below is a list of registry keys and their values that POS for .NET uses.

POSfor.NET Key

This key contains the following values.

Name | Description | Data Type | Default value
Configuration | Name of the configuration file written by the POS Device Manager. | REG_SZ | C:\Documents and Settings\All Users\Application Data\Microsoft\Point Of Service\Configuration\Configuration.xml
StatisticsFile | Name of the file used to record POS for .NET statistics. | REG_SZ | C:\Documents and Settings\All Users\Application Data\Microsoft\Point Of Service\Statistics\PosDeviceStatistics.xml

The POSfor.NET registry key has three subkeys:

  • ControlAssemblies

  • ControlConfigs

  • Logging

POSfor.NET\ControlAssemblies Key

This key may contain any number of values of type REG_SZ, each of which contains the name of a directory. PosExplorer will iterate through the entire list of values, searching each directory. Therefore, the names of the values are not important.

These values will need to be modified during system configuration so that they point to the locations appropriate for the specific requirements of the installation.

The following table shows the default values that are written during the POS for .NET SDK setup process.

Name | Default Values
(Default) | C:\Program Files\Common Files\Microsoft Shared\Point Of Service\Control Assemblies\
ExampleSOs | C:\Program Files\Microsoft Point Of Service\SDK\Samples\Example Service Objects\
Simulators | C:\Program Files\Microsoft Point Of Service\SDK\Samples\Simulator Service Objects\

POSfor.NET\ControlConfigs Key

In most cases, POS devices are paired with specific Service Objects using the HardwareId attribute, but in some rare situations, a Service Object provider may need the ability to assign a different device to a Service Object without redistributing the entire assembly.

To accommodate these situations, POS for .NET supports the ability to associate the device to a Service Object in a Plug and Play XML Configuration file.

This key contains a value which points to the location of these Plug and Play configuration files.

Name | Default Value
(Default) | C:\Program Files\Common Files\Microsoft Shared\Point Of Service\Control Configurations\

POSfor.NET\Logging Key

This key contains values which dictate how POS for .NET handles log files. Both POS for .NET and applications, using the Logger object, may write to the log file.

The following table shows the values of this key.

Name | Description | Data Type | Default
Enabled | Set to true if logging is enabled. | REG_DWORD | 0 (not enabled)
Location | The location where the log files will be written. | REG_SZ | %TEMP%
MaxLogFileSizeMB | The maximum allowed log size, in megabytes. | REG_DWORD | 10
Name | The Base name of the log file. Date and time information follows the file name. The .txt extension is appended. | REG_SZ | CCL

See Also

Reference

Logger

Concepts

Log Files
Plug and Play XML Configuration
Plug and Play Support

Other Resources

System Configuration


POS Device Manager Output

POS Device Manager Output |
 | See Also
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object > System Configuration >

1/18/2008

The POS Device Manager is used to set up the device configuration for a given system. The output from the POS Device Manager is written to an XML file. The name of this file is the value of the registry key \HKLM\SOFTWARE\POSfor.NET\Configuration.

Configuration Migration

You should not modify this file directly. Doing so may lead to unexpected behavior. You can, however, migrate the file from one system to another, making it possible to build a configuration on one system, and propagate that same setup to others.

API Support

You may also access configuration properties with the following methods in PosCommon:

  • GetConfigurationProperty

  • SetConfigurationProperty

  • DeleteConfigurationProperty

See Also

Other Resources

POS Device Manager


Point of Service Performance Counters

Point of Service Performance Counters |
 | See Also
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object > System Configuration >

1/18/2008

The Point of Service Performance Counters service application helps applications and management tools to monitor device statistics. It is included in the standard POS for .NET Package Installer. However, it is disabled by default.

Device statistics are supported by POS for .NET Basic classes. They contain the code used by Service Object developers to implement statistics. Device statistic values are periodically saved to an XML file where they can be persisted across sessions. The POS for .NET statistics service uses this XML file to expose the statistics as performance counters that can be monitored by management tools and do not require direct interaction with a Service Object. Even if the Service Object is claimed by another POS application, the counters can still be monitored by other tools.

The service application creates a counter for any statistic that is represented by a value that may be cast to an integer.

To enable Point of Service performance counters

  1. On the taskbar, choose Start, choose Control Panel, and then double-click Administrative Tools.

  2. Choose Services to open the Services window.

  3. Right-click the Point of Service Performance Counters service and choose Properties.

  4. In the Point of Service Performance Counters Properties window, open the Startup Type drop-down menu and select when to enable Point of Service Performance Counters. There are three options:

    • Disabled. This is the default option. When Performance Counters are disabled, the service cannot run.

    • Manual. When Performance Counters are set to Manual, the service may be run, but does not automatically do so.

    • Automatic. When Performance Counters are set to Automatic, the service automatically runs every time that your computer starts or restarts.

  5. If you have selected Manual or Automatic in the Startup Type drop-down menu, start the service by choosing Start the Service.

To monitor Point of Service performance counters

  1. On the taskbar, choose Start, choose Control Panel, and then choose Administrative Tools.

  2. Choose Performance to open the Performance Monitor.

  3. Right-click the Performance window and choose Add Counters.

  4. In the Add Counters window, open the Performance Object drop-down list and select the POS for .NET device class whose statistics you want to display.

  5. Select the counters associated with the device class that you have chosen to monitor. Then choose Add.

  6. Choose Close to return to the Performance window.

See Also

Tasks

Statistics Sample


Plug and Play XML Configuration

Plug and Play XML Configuration |
 | See Also
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object > System Configuration >

1/18/2008

Although the Plug and Play hardware ID should generally be specified using the HardwareId property within the Service Object source code, there may be times when Service Object vendors require more flexibility. For example, the hardware ID needs to be changed without redistributing the entire Service Object assembly.

To support these cases, POS for .NET specifies hardware associations in an XML file. These XML files are read from the directory that is specified in the registry key HKEY_LOCAL_MACHINE/SOFTWARE/POSfor.NET/ControlConfigs. When constructing the list of available Service Objects and devices, PosExplorer processes each file in that directory and associates the device where possible. No additional action is required by either the Service Object or the application.

Schema

A Plug and Play configuration file must begin with a top-level node named PointOfServiceConfig and have the attribute Version to indicate the XML version of the file.

Following that, there may be any number of ServiceObject subnodes. Each service object node must include Type and Name attributes to indicate the POS device type and name of the Service Object. These two fields will be matched against available Service Objects to determine which, if any, should be associated with devices specified in the subnode HardwareId. There is also an optional attribute on the ServiceObject node, Override. If this attribute is set, then the device associations in the XML file overrides those contained in the assembly.

The ServiceObject node contains subnodes with the name HardwareId, which have From and To attributes. The contents of these attributes are the same as would be found in the HardwareId attribute in a Service Object assembly and specify the range of hardware IDs to associate with the Service Object.

Example

The example shows a typical XML Plug and Play configuration file.

Copy Code
<PointOfServiceConfig Version="1.0">
    <ServiceObject Type="Msr" Name="ExampleMsr" Override="yes">
        <HardwareId From="HID\Vid_0801&Pid_0002&Rev_0100"
                    To="HID\Vid_0801&Pid_0002&Rev_9999" />
    </ServiceObject>
</PointOfServiceConfig>

Hardeware ID Precedence

If the Override attribute on the ServiceObject node is set, then the device association specified in the XML takes precedence, and any HardwareId attribute on the Service Object will be discarded.

If the Override attribute is not set, then neither the XML nor the HardwareId has precedence. Instead, PosExplorer associates the union of all specified devices with the Service Object.

See Also

Tasks

Adding Plug and Play Support

Concepts

Plug and Play Support
POS for .NET Registry Settings


Service Object Samples: Getting Started

Service Object Samples: Getting Started
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object >

1/18/2008

POS for .NET provides a class tree which implements most of the functionality required by the UPOS specification. In many cases, the Service Object developer only needs to implement the methods and properties required to operate the specific piece of hardware, for which the Service Object is being written.

This section provides a step-by-step guide to creating a simple, but functional sample Service Object for a Magnetic Strip Reader (MSR) device.

In This Section

Setting up a Service Object Project

Explains how to use Visual Studio to create a class library project with references to the appropriate POS for .NET assemblies.

Creating a Basic Service Object Code Template

Continues adding to the sample by modifying the code to create the necessary references, attributes, and methods to create a fundamental Service Object template.

Adding Plug and Play Support

Adds to the sample template by integrating Plug and Play support.

Creating a Service Object Sample

Describes how the sample code implements the methods needed to compile the sample. The Service Object will now be recognized by POS for .NET applications, but has no functionality.

Introducing Service Object Reader Threads

Introduces the concept of multithreaded programming in Service Objects. A sample thread helper class is included upon which other multithreaded Service Object samples are built.

Creating a Working, Multithreaded Service Object

Implements a complete Magnetic Strip Reader (MSR) Service Object. It expands the appropriate methods from the earlier sample so that it returns data to the application. In addition, it uses the thread helper class from the previous section to start and stop a separate read thread.

Related Sections

System Configuration

Describes how to configure POS for .NET to meet the needs of your installation.

Developing a POS Application

Explains how to create POS for .NET applications, the ultimate consumers of POS for .NET Service Objects.


Setting up a Service Object Project

Setting up a Service Object Project |
 | See Also
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object > Service Object Samples: Getting Started >

1/18/2008

To begin programming your Service Object, you first need to create a new Class Library project and add the appropriate resources to your project. To create your basic project, perform the following steps.

To create a new class library project for your Service Object

  1. Open Visual Studio. On the File menu, choose New and then choose Project to create a new project.

  2. In the New Project dialog box, select Class Library from the Visual Studio Installed Templates list.

  3. Choose an appropriate name for your Service Object. Note that Visual Studio creates a namespace for your project based on the name that you enter here.

To add references to Point of Service assemblies

  1. Be sure that you have installed the Microsoft Point of Service product.

  2. From the Solution Explorer window, right-click the References drop-down and then select Add References.

  3. On the Browse tab, locate the Microsoft.PointOfService and Microsoft.PointOfService.ControlBase assemblies in the Program Files\Microsoft Point of Service\SDK directory.

  4. Select both assemblies and add them to your reference list.

To add the PosAssembly global attribute to your assembly

  1. The PosExplorer requires that Service Object assemblies contain the PosAssemblyAttribute global attribute.

  2. From the Solution Explorer window, open and edit the file AssemblyInfo.cs.

  3. At the top of the file, add a using directive for Microsoft.PointOfService, for example:

    using Microsoft.PointOfService;

  4. Insert the global attribute, PosAssembly, into the file. This attribute takes a single argument for the name of your organization. For example:

    [assembly: PosAssembly("Your Company Name, Inc")]

See Also

Concepts

Attributes for Identifying Service Objects and Assigning Hardware

Other Resources

Service Object Samples: Getting Started


Creating a Basic Service Object Code Template

Creating a Basic Service Object Code Template |
 | See Also Example
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object > Service Object Samples: Getting Started >

1/18/2008

The previous section, Setting up a Service Object Project, explained how to create an empty project to begin writing your Service Object. This section continues by adding features to that sample project. The following procedures and the sample in this topic show the steps that you must follow to create a basic Service Object template.

To create a simple class template

  1. Add using directives for the Microsoft.PointOfService and Microsoft.PointOfService.BaseServiceObjects to the top of the source file.

  2. Choose the POS for .NET Base class your Service Object will be derived from. The Base class you choose is based on the type of POS device for which you are developing this Service Object. (See POS for .NET Class Tree)

  3. If you are building your class on top of Point of Service Basic classes, also add a using directive for Microsoft.PointOfService.BasicServiceObjects.

  4. Apply a ServiceObject attribute to your Service Object class. This includes the following elements:

    • Device Type

    • Service Object name

    • Description of the Service Object

    • Major version

    • Minor version

  5. Create a default public parameterless constructor. This is required for PosExplorer to create an instance of your class by using .NET reflection.

Example

In this sample, notice the additional using directives, the ServiceObject attribute applied to the Service Object class, the Base class used for the Service Object class, and finally the public constructor without arguments.
Copy Code
using system;
using Microsoft.PointOfService;
using Microsoft.PointOfService.BaseServiceObjects;

namespace Samples.ServiceObjects.SOTemplate
{
    [ServiceObject(
                DeviceType.Msr,
                "ServiceObjectTemplate",
                "Bare bones Service Object class",
                1,
                9)]
    public class MyServiceObject : MsrBase
    {
        public MyServiceObject()
        {
        }
    }
}

This sample does not compile as is. Its purpose is to demonstrate what elements are necessary for any Service Object class. However, for each POS for .NET Service Object Base class, the list of abstract methods which must be implemented is different. The following sections continue to add features to the sample until it becomes a complete, functional Service Object implementation.

See Also

Tasks

Setting up a Service Object Project
Adding Plug and Play Support

Concepts

POS for .NET Class Tree
Attributes for Identifying Service Objects and Assigning Hardware

Other Resources

Service Object Samples: Getting Started
POS for .NET Service Object Architecture


Adding Plug and Play Support

Adding Plug and Play Support |
 | See Also Example
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object > Service Object Samples: Getting Started >

1/18/2008

POS for .NET includes support for Plug and Play devices. By adding Plug and Play support to your Service Objects, applications can become more simple, reliable, and efficient. Service Objects should support it whenever possible.

Implementing Plug and Play support at the Service Object level is very simple. Once you know the hardware ID of your device, simply add a single attribute to your class, HardwareIdAttribute. The HardwareId attribute is used by PosExplorer to intelligently filter out Service Objects from the list of available devices depending on the state of the device. If the Service Object has a HardwareId attribute that refers to an installed Plug and Play device, but that device is not connected, the Service Object will be excluded from the PosExplorer device list. This list is returned when applications call GetDevices.

Service Objects may also have more than one HardwareId attribute, in which case PosExplorer associates a union of all specified devices with the Service Object. It is possible to override the HardwareId attributes or add to the list of associated hardware on the Service Object without rebuilding the Service Object assembly. For information about overriding or adding the HardwareId attribute, see Plug and Play XML Configuration.

Only the application is responsible for catching DeviceAddedEvent and DeviceRemovedEvent events and updating its status as appropriate based on the updated device list returned from PosExplorer. The Service Object does not need to detect these events.

To add a HardwareId attribute to your Service Object class

  1. Determine the range of hardware IDs for the device or devices that your Service Object supports.

  2. Add a HardwareId attribute before your class definition using the lowest hardware ID used by your device and the highest. Multiple HardwareId attributes may be used to identify multiple ranges of hardware IDs.

Example

The following sample adds a HardwareId attribute to the basic template shown in the previous section.
Copy Code
using System;

using Microsoft.PointOfService;
using Microsoft.PointOfService.BaseServiceObjects;

namespace SOTemplate
{

    [HardwareId("HID\\Vid_05e0&amp;Pid_038a",
                "HID\\Vid_05e0&amp;Pid_038a")]

    [ServiceObject(
                DeviceType.Msr,
                "ServiceObjectTemplate",
                "Bare bones Service Object class",
                1,
                9)]
    public class MyServiceObject : MsrBase
    {
        public MyServiceObject()
        {
        }
    }
}

See Also

Tasks

Creating a Basic Service Object Code Template
Creating a Service Object Sample

Concepts

Attributes for Identifying Service Objects and Assigning Hardware
Plug and Play XML Configuration

Other Resources

Service Object Samples: Getting Started
POS for .NET Service Object Architecture


Creating a Service Object Sample

Creating a Service Object Sample |
 | See Also Example
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object > Service Object Samples: Getting Started >

1/18/2008

Previous topics explained how to create a basic Service Object template with Plug and Play support. This section adds how to create a limited sample with the following new features:

  • Necessary abstract methods are implemented so that the sample will compile successfully.

  • The Service Object will be recognized by applications using PosExplorer, for example, the POS for .NET Test Application included with the SDK.

  • Applications may now invoke methods on the Service Object or access properties, although no useful results will be returned.

Requirements

To compile this sample, your project has to have the correct references and global attributes.

Example

Copy Code
using System;
using Microsoft.PointOfService;
using Microsoft.PointOfService.BaseServiceObjects;

namespace Samples.ServiceObjects.MSR
{
    [HardwareId(@"HID\Vid_05e0&Pid_038a", @"HID\Vid_05e0&Pid_038a")]

    [ServiceObject(DeviceType.Msr,
        "SampleMsr",
        "Sample Msr Service Object",
        1,
        9)]
    public class SampleMsr : MsrBase
    {
        //  String returned from CheckHealth
        private string MyHealthText;

        public SampleMsr()
        {
            // Initialize device capability properties.
            Properties.CapIso = true;
            Properties.CapTransmitSentinels = true;
            Properties.DeviceDescription = "Sample MSR";

            // Initialize other class variables.
            MyHealthText = "";
        }

        ~SampleMsr()
        {
            Dispose(false);
        }

        // Release any resources managed by this object.
        protected override void Dispose(bool disposing)
        {
            try
            {
                // Your code here.
            }
            finally
            {
                // Must call base class Dispose.
                base.Dispose(disposing);
            }
        }

        #region PosCommon overrides
        // Returns the result of the last call to CheckHealth().
        public override string CheckHealthText
        {
            get
            {
                // MsrBasic.VerifyState(mustBeClaimed,
                // mustBeEnabled). This may throw an exception.
                VerifyState(false, false);

                return MyHealthText;
            }
        }

        public override string CheckHealth(
                    HealthCheckLevel level)
        {
            // Verify that device is open, claimed, and enabled.
            VerifyState(true, true);

            // Your code here:
            // check the health of the device and return a
            // descriptive string.

            // Cache result in the CheckHealthText property.
            MyHealthText = "Ok";
            return MyHealthText;
        }

        public override DirectIOData DirectIO(
                        int command,
                        int data,
                        object obj)
        {
            // Verify that device is open.
            VerifyState(false, false);

            return new DirectIOData(data, obj);
        }
        #endregion // PosCommon overrides

        #region MsrBasic Overrides
        protected override MsrFieldData ParseMsrFieldData(
                        byte[] track1Data,
                        byte[] track2Data,
                        byte[] track3Data,
                        byte[] track4Data,
                        CardType cardType)
        {
            // Your code here:
            // Implement this method to parse track data
            // into fields which will be returned as
            // properties to the application
            // (for example, FirstName,
            // AccountNumber, etc.)
            return new MsrFieldData();
        }

        protected override MsrTrackData ParseMsrTrackData(
                        byte[] track1Data,
                        byte[] track2Data,
                        byte[] track3Data,
                        byte[] track4Data,
                        CardType cardType)
        {

            // Your code here:
            // Implement this method to convert raw track data.
            return new MsrTrackData();
        }
        #endregion
    }
}

In order to simplify this sample, the code does not implement any globalization features. For example, the value for Properties.DeviceDescription would typically be read from a localized strings resource file.

See Also

Tasks

Adding Plug and Play Support
Introducing Service Object Reader Threads

Concepts

POS for .NET Class Tree

Other Resources

Service Object Samples: Getting Started


Introducing Service Object Reader Threads

Introducing Service Object Reader Threads |
 | See Also Example
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object > Service Object Samples: Getting Started >

1/18/2008

Most Service Objects need to be able to respond to hardware events asynchronously by starting a separate hardware reader thread. Service Objects are the link between the Point of Service application and the hardware. Therefore, Service Objects must read data from the associated hardware while still being available to the application.

This section demonstrates one way to implement the code necessary for multithreaded Service Objects.

Requirements

To compile this code, the application must include a reference to the System.Threading namespace.

The sample below implements a threading helper class which may be used by Service Object implementations, but does not compile or run on its own.

Demonstrates

This sample demonstrates how Service Objects may use threading to support monitoring hardware events asynchronously. The sample code implements a thread helper class which can be used to add basic threading support to a Service Object.

To use the thread helper class provided in this section, you will need to create a class derived from ServiceObjectThreadHelper, which is included in the code below, and implement the following methods:

  • ServiceObjectThreadOpen

    This method is called from the OpenThread method of the thread helper class after initialization has been completed. Implement any hardware-specific initialization code here. This method is virtual. The default implementation simply returns.

  • ServiceObjectThreadClose

    This method is called when the thread helper object is terminating its thread or when calling the Dispose method and should be used to release any unmanaged handles or other resources related to the device. This method is virtual. The default implementation simply returns.

  • ServiceObjectProcedure

    This method will be invoked once all initialization has taken place and the thread has been started successfully. This method is abstract and must be implemented in the class derived from the thread helper class.

    The ServiceObjectProcedure method takes a single argument, a ManualEvent handle. Your thread procedure must exit when this handle is set. This is done by calling ManualEvent.WaitOne within a while loop. For example:

    Copy Code

    while (true)
    {
        // Wait for a hardware event or the thread stop event.

        // Test to see if the thread terminated event is set and
        // exit the thread if so.
        if (ThreadStopEvent.WaitOne(0, false))
        {
           break;
        }

        // The thread is not terminating, so it must be a
        // a hardware event.
    }

Example

Copy Code
using System;
using System.Threading;
using Microsoft.PointOfService;

namespace Samples.ServiceObjects.Advanced
{
    // The following code implements a thread helper class.
    // This class may be used by other Point Of Service
    // samples which may require a separate thread for monitoring
    // hardware.
    public abstract class ServiceObjectThreadHelper : IDisposable
    {
        // The thread object which will wait for data from the POS
        // device.
        private Thread ReadThread;

        // These events signal that the thread is starting or stopping.
        private AutoResetEvent ThreadTerminating;
        private AutoResetEvent ThreadStarted;

        // Keeps track of whether or not a thread should
        // be running.
        bool ThreadWasStarted;

        public ServiceObjectThreadHelper()
        {
            // Create events to signal the reader thread.
            ThreadTerminating = new AutoResetEvent(false);
            ThreadStarted = new AutoResetEvent(false);

            ThreadWasStarted = false;

            // You need to handle the ApplicationExit event so
            // that you can properly clean up the thread.
            System.Windows.Forms.Application.ApplicationExit +=
                        new EventHandler(Application_ApplicationExit);
        }

        ~ServiceObjectThreadHelper()
        {
            Dispose(true);
        }

        public virtual void ServiceObjectThreadOpen()
        {
            return;
        }

        public virtual void ServiceObjectThreadClose()
        {
            return;
        }

        // This is called when the thread starts successfully and
        // will be run on the new thread.
        public abstract void ServiceObjectThreadProcedure(
                AutoResetEvent ThreadStopEvent);

        private bool IsDisposed = false;
        protected virtual void Dispose(bool disposing)
        {
            if (!IsDisposed)
            {
                try
                {
                    if (disposing == true)
                    {
                        CloseThread();
                    }
                }
                finally
                {
                    IsDisposed = true;
                }
            }
        }

        public void Dispose()
        {
            Dispose(true);

            // This object has been disposed of, so no need for
            // the GC to call the finalization code again.
            GC.SuppressFinalize(this);
        }

        public void OpenThread()
        {
            try
            {
                // Check to see if this object is still valid.
                if (IsDisposed)
                {
                    // Throw system exception to indicate that
                     // the object has already been disposed.
                    throw new ObjectDisposedException(
                            "ServiceObjectSampleThread");
                }

                // In case the application has called OpenThread
                // before calling CloseThread, stop any previously
                // started thread.
                SignalThreadClose();

                ServiceObjectThreadOpen();

                // Reset event used to signal the thread to quit.
                ThreadTerminating.Reset();

                // Reset the event that used by the thread to signal
                // that it has started.
                ThreadStarted.Reset();

                // Create the thread object and give it a name. The
                // method used here, ThreadMethod, is a wrapper around
                // the actual thread procedure, which will be run in
                // the threading object provided by the Service
                // Object.
                ReadThread = new Thread(
                        new ThreadStart(ThreadMethod));

                // Set the thread background mode.
                ReadThread.IsBackground = false;

                // Finally, attempt to start the thread.
                ReadThread.Start();

                // Wait for the thread to start, or until the time-out
                // is reached.
                if (!ThreadStarted.WaitOne(3000, false))
                {
                    // If the time-out was reached before the event
                    // was set, then throw an exception.
                    throw new PosControlException(
                            "Unable to open the device for reading",
                            ErrorCode.Failure);
                }

                // The thread has started succesfully.
                ThreadWasStarted = true;
            }
            catch (Exception e)
            {
                // If an error occurred, be sure the new thread is
                // stopped.
                CloseThread();

                // Re-throw to let the application handle the
                // failure.
                throw;
            }
        }

        private void SignalThreadClose()
        {
            if(ThreadTerminating != null && ThreadWasStarted)
            {
                // Tell the thread to terminate.
                ThreadTerminating.Set();

                // Give the thread a few seconds to end.
                ThreadStarted.WaitOne(10000, false);

                // Mark the thread as being terminated.
                ThreadWasStarted = false;
            }
        }

        public void CloseThread()
        {
            // Signal the thread that it should stop.
            SignalThreadClose();

            // Call back into the SO for any cleanup.
            ServiceObjectThreadClose();
        }

        private void Application_ApplicationExit(
                            object sender,
                            EventArgs e)
        {
            SignalThreadClose();
        }

        // This is the method run on the new thread. First it signals
        // the caller indicating that the thread has started
        // correctly. Next, it calls the service object's thread
        // method which will loop waiting for data or a signal
        // to close.
        private void ThreadMethod()
        {
            try
            {
                // Set the event to indicate that the thread has
                // started successfully.
                ThreadStarted.Set();

                // Call into the thread procedure defined by the
                // Service Object.
                ServiceObjectThreadProcedure(ThreadTerminating);

                // Signal that the thread procedure is exiting.
                ThreadStarted.Set();
            }
            catch (Exception e)
            {
                Logger.Info("ServiceObjectThreadHelper",
                        "ThreadMethod Exception = " + e.ToString());
                throw;
            }
        }
    }
}

See Also

Tasks

Creating a Working, Multithreaded Service Object
Adding Plug and Play Support

Other Resources

Service Object Samples: Getting Started
POS for .NET Service Object Architecture


Creating a Working, Multithreaded Service Object

Creating a Working, Multithreaded Service Object |
 | See Also Example
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object > Service Object Samples: Getting Started >

1/18/2008

The previous sections provided samples and guides to start your project including:

  • Creating a simple template.

  • Implementing a Service Object class that can be compiled and seen by the Point Of Service sample application via PosExplorer.

  • Implementing a thread helper class.

This sample combines all of these steps to create a working, multithreaded MSR Service Object class. This sample does not actually read from any hardware. It simply pushes test data through the system. It illustrates, however, how to add code that is specific to your Service Object.

To customize this code for your Service Object

  1. Modify the PosAssembly attribute in AssemblyInfo.cs so that it contains your organization's name.

  2. Be sure that the name of the namespace is appropriate for your organization and Service Object.

  3. Modify the ServiceObject attribute to contain the type, name, description, and version number of the Service Object that you are creating.

  4. Add a HardwareId attribute to associate this Service Object with a Plug and Play device, or a range of devices.

  5. Include the ThreadHelper class presented in Introducing Service Object Reader Threads. You can do this by either pasting the code into your source file, or compiling it as a separate source file in your project. Be sure that the ThreadHelper class is in an accessible namespace.

  6. Implement the members necessary depending on the Base class used by the Service Object and the functionality that you want to support. This sample is a functioning MSR Service Object with very little functionality.

Requirements

To compile this sample, your project has to have the correct references and global attributes. If you have not already created a working POS for .NET Service Object, review the Service Object Samples: Getting Started sections.

In addition, you will also need to include the code from the previous section, Introducing Service Object Reader Threads, into your project.

Demonstrates

Most Service Objects need to use a second thread to monitor hardware and notify the application of various incoming data events. This sample shows one way to create a multithreaded Service Object. It relies on the ServiceObjectThreadHelper class discussed in Introducing Service Object Reader Threads to do this.

To use the helper class, an application needs to define a new class that implements the ServiceObjectThreadHelper interface. This interface includes three methods:

  • ServiceObjectThreadOpen

    This method is called during thread initialization and should be used to initialize any hardware-specific resources.

  • ServiceObjectThreadClose

    This method is called when the thread is terminated and should be used to release any hardware-specific resources.

  • ServiceObjectThreadProcedure

    This method will be called once the thread has been successfully started and should loop waiting on hardware events, and should not exit until the proper ManualEvent is triggered.

This code builds on the sample presented in the topic Creating a Service Object Sample and adds the following features:

  • Creates a class derived from ServiceObjectThreadHelper.

  • Creates an instance of an MsrThreadingObject class. The constructor for this class takes a single argument, a reference to the service object.

  • Calls methods on the MsrThreadingObject object from the Service Object to start and stop the thread helper as appropriate.

Example

Copy Code
using System;
using System.Threading;
using Microsoft.PointOfService;
using Microsoft.PointOfService.BaseServiceObjects;
using System.Text;

namespace Samples.ServiceObjects.Advanced.MSR
{
    public class MsrThreadingObject :
            ServiceObjectThreadHelper, IDisposable
    {
        // This is a helper class which will depend on
        // being able to call back into the actual Service
        // Object to pass along data. However, you cannot
        // keep a strong reference to the Service Object,
        // since that will prevent proper disposal, which
        // may create a state in which all hardware resources
        // are not properly released by the SO. Therefore,
        // create a weak reference. From this reference,
        // you can get a temporary strong reference, which
        // you act on and then release.
        WeakReference ServiceObjectReference;

        // The name of the Service Object.
        string ObjectName;

        public MsrThreadingObject(AdvancedSampleMsr so)
        {
            ObjectName = GetType().Name;
            ServiceObjectReference = new WeakReference(so);
        }

        ~MsrThreadingObject()
        {
            Dispose(true);
        }

        private bool IsDisposed = false;
        protected virtual void Dispose(bool disposing)
        {
            if (!IsDisposed)
            {
                IsDisposed = true;
                base.Dispose(disposing);
            }
        }

        public void Dispose()
        {
            Dispose(false);
        }

        #region Methods of ServiceObjectThreadHelper

        // This will be called during initialization.
        public override void ServiceObjectThreadOpen()
        {
            Logger.Info(ObjectName, "Msr Thread Open");
        }

        // This method will be called during shutdown.
        public override void ServiceObjectThreadClose()
        {
            Logger.Info(ObjectName, "Msr Thread Open");
        }

        public override void ServiceObjectThreadProcedure(
                            AutoResetEvent ThreadStopEvent)
        {
            // Convert a C# string into a sample byte array.
            UTF8Encoding encoder = new UTF8Encoding();

            // Convert sample data to a byte array.
            byte[] MsrData = encoder.GetBytes(
                        "This is MSR test data");

            Logger.Info(ObjectName, "Msr Thread Procedure Entered");

            while (true)
            {
                // When this method is called by the
                // ServiceObjectThreadHelper, it is obligated to
                // exit when the event ThreadStopEvent has been
                // set.

                // Additionally, this method will also wait for
                // hardware events or for a time-out. That should
                // be done here.

                // This example waits for the event to be set
                // or times out after several seconds.

                if (ThreadStopEvent.WaitOne(2000, false))
                {
                    break;
                }

                Logger.Info(ObjectName, "Reader Thread cycling");

                // Try to get a strong reference to the Service
                // Object using the weak reference saved when
                // this helper object was created.
                AdvancedSampleMsr msr =
                    ServiceObjectReference.Target
                    as AdvancedSampleMsr;

                // If this fails, that means the Service
               // Object has already been disposed of. Exit the
                // thread.
                if (msr == null)
                {
                    break;
                }

                // Using the strong reference, you can now make
                // calls back into the Service Object.
                msr.OnCardSwipe(MsrData);
                msr = null;
            }
            #endregion Methods of ServiceObjectThreadHelper
        }

        // Implementation of the Service Object class. This class
        // implements all the methods needed for an MSR Service
        // Object.
        //
        // A Service Object which supports a Plug and Play device
        // should also have a HardwareId attribute here.

        [HardwareId(
                @"HID\Vid_05e0&Pid_038a",
                @"HID\Vid_05e0&Pid_038a")]

        [ServiceObject(
                DeviceType.Msr,
                "AdvancedSampleMsr",
                "Advanced Sample Msr Service Object",
                1,
                9)]
        public class AdvancedSampleMsr : MsrBase
        {
            // String returned for various health checks.
            private string MyHealthText;
            private const string PollingStatistic =
                            "Polling Interval";

            // Create a class with interface methods called from the
            // threading object.
            MsrThreadingObject ReadThread;
            public AdvancedSampleMsr()
            {
                // DevicePath must be set before Open() is called.
                // In the case of Plug and Play hardware, the POS
                // for .NET Base class will set this value.
                DevicePath = "Sample Msr";

                Properties.CapIso = true;
                Properties.CapTransmitSentinels = true;

                Properties.DeviceDescription =
                            "Advanced Sample Msr";

                // Initialize the string to be returned from
                // CheckHealthText().
                MyHealthText = "";
            }

            ~AdvancedSampleMsr()
            {
                // Code added from previous sections to terminate
                // the read thread started by the thread-helper
                // object.
                ReadThread.CloseThread();

                Dispose(false);
            }

            protected override void Dispose(bool disposing)
            {
                try
                {
                    if (disposing)
                    {
                        if (ReadThread != null)
                        {
                            ReadThread.Dispose();
                            ReadThread = null;
                        }
                    }
                }
                finally
                {
                    // Must call base class Dispose.
                    base.Dispose(disposing);
                }
            }

            #region Internal Members
            // This is a private method called from the task
            // interface when a data event occurs in the reader
            // thread.
            internal void OnCardSwipe(byte[] CardData)
            {
                // Simple sample data.
                UTF8Encoding utf8 = new UTF8Encoding();
                byte[] track1Data = utf8.GetBytes(
                                "this is test track 1");
                byte[] track2Data = utf8.GetBytes(
                                "this is test track 2");

                // Call GoodRead(), UnreadableCard, or FailedRead
                // from here.
                GoodRead(
                        track1Data,
                        track2Data,
                        null,
                        null,
                        Microsoft.PointOfService.BaseServiceObjects.CardType.Iso);
            }
            #endregion Internal Members

            #region PosCommon overrides
            //  PosCommon.Open.
            public override void Open()
            {
                // Call base class Open.
                base.Open();

                // Initialize statistic values.

                // Set values for common statistics.
                SetStatisticValue(StatisticManufacturerName,
                                "Microsoft Corporation");
                SetStatisticValue(
                            StatisticManufactureDate, "2004-10-23");
                SetStatisticValue(
                            StatisticModelName, "Msr Simulator");
                SetStatisticValue(
                            StatisticMechanicalRevision, "1.0");
                SetStatisticValue(
                            StatisticInterface, "USB");

                // Create a new manufacturer statistic.
                CreateStatistic(
                            PollingStatistic,
                            false,
                            "milliseconds");

                // Set handlers for statistics stored in hardware.
                // Create a class with interface methods called
                // from the threading object.
                ReadThread = new MsrThreadingObject(this);
            }

            // PosCommon.CheckHealthText.
            public override string CheckHealthText
            {
                get
                {
                    // MsrBasic.VerifyState(mustBeClaimed,
                    // mustBeEnabled).
                    VerifyState(false, false);
                    return MyHealthText;
                }
            }

            //  PosCommon.CheckHealth.
            public override string CheckHealth(
                            HealthCheckLevel
                            level)
            {
                // Verify that device is open, claimed, and enabled.
                VerifyState(true, true);

                // Your code here checks the health of the device and
                // returns a descriptive string.

                // Cache result in the CheckHealthText property.
                MyHealthText = "Ok";
                return MyHealthText;
            }

            //  PosCommon.DirectIO.
            public override DirectIOData DirectIO(
                                int command,
                                int data,
                                object obj)
            {
                return new DirectIOData(data, obj);
            }

            public override bool DeviceEnabled
            {
                get
                {
                    return base.DeviceEnabled;
                }
                set
                {
                    if (value != base.DeviceEnabled)
                    {
                        base.DeviceEnabled = value;

                        if (value == false)
                        {
                            // Stop the reader thread when the
                            // device is disabled.
                            ReadThread.CloseThread();
                        }
                        else
                        {
                            try
                            {
                                // Enabling the device, start the
                                // reader thread.
                                ReadThread.OpenThread();
                            }
                            catch (Exception e)
                            {
                                base.DeviceEnabled = false;

                                if (e is PosControlException)
                                    throw;

                                throw new PosControlException(
                                        "Unable to Enable Device",
                                        ErrorCode.Failure, e);
                            }
                        }
                    }
                }
            }
            #endregion PosCommon overrides.

            #region MsrBasic Overrides

            // MsrBasic.MsrFieldData
            // Once the track data is retrieved, this method is
            // called when the application accesses various data
            // properties in the MsrBasic class. For example,
            // FirstName and AccountNumber.
            protected override MsrFieldData ParseMsrFieldData(
                                    byte[] track1Data,
                                    byte[] track2Data,
                                    byte[] track3Data,
                                    byte[] track4Data,
                                    CardType cardType)
            {
                // MsrFieldData contains the data elements that
                // MsrBasic will return as properties to the
                // application, as they are requested.
                MsrFieldData data = new MsrFieldData();

                // Parse the raw track data and store in fields to
                // be used by the app.
                data.FirstName = "FirstName";
                data.Surname = "LastName";
                data.Title = "Mr.";
                data.AccountNumber = "123412341234";

                return data;
            }

            // MsrBasic.MsrTrackData.
            protected override MsrTrackData ParseMsrTrackData(
                                    byte[] track1Data,
                                    byte[] track2Data,
                                    byte[] track3Data,
                                    byte[] track4Data,
                                    CardType cardType)
            {
                MsrTrackData data = new MsrTrackData();

                // Modify the track data as appropriate for your SO.
                // Remove the sentinal characters from the track data,
                // for example.
                data.Track1Data = (byte[])track1Data.Clone();
                data.Track2Data = (byte[])track2Data.Clone();

                return data;
            }
            #endregion MsrBasic overrides
        }
    }
}

See Also

Tasks

Introducing Service Object Reader Threads
Adding Plug and Play Support

Other Resources

Service Object Samples: Getting Started
POS for .NET Service Object Architecture


Developing Service Objects Using Base Classes

Developing Service Objects Using Base Classes
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object >

1/18/2008

The UPOS Specification version 1.12 defines 36 UPOS device types. POS for .NET provides Base class for nine of those. This section builds on the basics covered in the Service Object Samples: Getting Started and provides additional information specific to each device type.

In This Section

Scanner Implementation

Provides additional details about developing a ScannerDrawer Service Object.

CashDrawer Implementation

Provides additional details about developing a CashDrawer Service Object.

LineDisplay Implementation

Provides additional details about developing a LineDisplay Service Object.

PinPad Implementation

Provides additional details about developing a PinPad Service Object.

PosKeyboard Implementation

Provides additional details about developing a PosKeyboard Service Object.

Using Impl Methods for Synchronous or Asynchronous Output

Describes how these special helper methods allow for a single implementation of an output method that supports both synchronous and asynchronous operations.

Related Sections

Service Object Samples: Getting Started

Provides a step-by-step guide to creating a functional, multithreaded Service Object.

Developing a Custom Service Object

Discusses the procedures, issues, and conventions for developing a custom Service Object.


Scanner Implementation

Scanner Implementation
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object > Developing Service Objects Using Base Classes >

1/18/2008

A scanner device is used to read bar code data.

The scanner is an exclusive-use device, as follows:

  • The application must claim the device before enabling it.

  • The application must claim and enable the device before the device begins reading input.

The scanner object follows the general model for event-drive input:

  • When input is received from the device, a DataEvent event is queued using the Microsoft helper method, ScannerBase.GoodRead. If the device receives bad data, the Service Object may also queue an ErrorEvent event by calling ScannerBase.FailedRead.

  • If the PosCommon.AutoDisable property is set to true, the ScannerBase class will set the PosCommon.EnableDevice property to false. If your Service Object has implemented this method, it will need to disable the device as appropriate.

A queued DataEvent event will only be delivered to the application when the property ScannerBase.DataEventEnabled is set to true.

  • The UPOS specification requires that data from the incoming DataEvent must be copied into the corresponding properties before being delivered to the application. The method ScannerBase.PreFireEvent, which is called just before delivering the DataEvent to the application, meets this requirement by calling ScannerBase.DecodeScanDataLabel and ScannerBase.DecodeScanDataType if the DecodeData property is set to true. Usually you have to implement these methods in your Service Object.

  • Scanned data is placed into the Scanner.BaseScanData property. If the application has set the ScannerBase.DecodeData property to true, then data is decoded into the ScannerBase.ScanDataLabel and ScanDataType properties.

  • Before the DataEvent is delivered to the application, the property ScannerBase.DataEventEnabled is set to false. This prevents further DataEvents from being delivered to the application until it has finished processing the current one. The application sets ScannerBase.DataEventEnabled to true when it is ready to process incoming events.

  • The ScannerBasic.DataCount property may be read to obtain the total number of queued events.

  • All queued events may be deleted by calling the ScannerBasic.ClearInput method.

In This Section

Data Decoding

Describes the code necessary to decode device-specific data.

Scanner Events

Demonstrates how a scanner Service Object uses POS for .NET queuing to raise events to applications.


Data Decoding

Data Decoding |
 | See Also Example
Developing a Custom Service Object > Developing Service Objects Using Base Classes > Scanner Implementation >

1/18/2008

The ScannerBase class provides two methods, DecodeDataLabel and DecodeScanDataType for decoding incoming date. These methods are called when the properties ScanDataLabel and ScanDataType, respectively, are accessed. The ScannerBase class defers data decoding until the application accesses the data properties and the decoded data will be cached for future reads.

The ScannerBase class implements the ScannerBase.DecodeData attribute as required by the UPOS specification. If DecodeData is not set to true when the application reads the ScanDataLabel property, an empty byte array will be returned. Similarly, ScanDataType returns BarCodeSymbology.Unknown. This functionality is implemented in the ScannerBase class and is transparent to both the application and the Service Object.

To implement DecodeScanDataLabel

  1. Override the protected, virtual ScannerBasic member DecodeScanDataLable.

  2. DecodeScanData takes an argument, scanData, which contains the complete data buffer. There is no need to cache any additional data in the Service Object code.

  3. DecodeScanData should process the scanned data to remove header and type information at the start and end of the data buffer. The modified buffer will be returned in a byte array.

To implement DecodeScanDataType

  1. Override the protected, virtual ScannerBasic member DecodeScanDataType.

  2. Like DecodeScanDataLabel, DecodeScanDataType receives an argument containing the complete scanned buffer.

  3. DecodeScanDataType examines the buffer to find the data type of the scanned data and returns the appropriate BarCodeSymbology value.

Example

The following code demonstrates a typical method the Service Object developer could implement in order to extract label and data values from a scanned buffer. Note that this code is demonstrative of a particular device. Different Service Objects will require device-specific decoding.
Copy Code
// Decode the incoming scanner data, removing header and
// type information.
override protected byte[] DecodeScanDataLabel(
                byte[] scanData)
{
    int i;
    int len = 0;

    // Get length of label data.
    for (i = 5; i < (int)scanData[1]
                && (int)scanData[i] > 31; i++)
    {
        len++;
    }

    // Copy label data into buffer.
    byte[] label = new byte[len];
    len = 0;

    for (i = 5; i < (int)scanData[1]
                && (int)scanData[i] > 31; i++)
    {
        label[len++] = scanData[i];
    }

    return label;
}

// Process the incoming scanner data to find the data type.
override protected BarCodeSymbology DecodeScanDataType(
                byte[] scanData)
{
    int i;

    for (i = 5; i < (int)scanData[1]
                && (int)scanData[i] > 31; i++)
    {
    }

    // last 3 (or 1) bytes indicate symbology.
    if (i + 2 <= (int)ScanData[1])
    {
        return GetSymbology(
                ScanData[i],
                ScanData[i + 1],
                ScanData[i + 2]);
    }
    else
    {
        return GetSymbology(ScanData[i], 0, 0);
    }
}

// This method determines the data type by examining
// the end of the scanned data buffer. Either 1 byte
// or 3 byte is used to determine the type, depending on
// the incoming buffer.
static private BarCodeSymbology GetSymbology(
            byte b1,
            byte b2,
            byte b3)
{
    if (b1 == 0 && b3 == 11)
    {
        // Use all 3 bytes to determine the date type.
        switch (b2)
        {
            case 10:
                return BarCodeSymbology.Code39;
            case 13:
                return BarCodeSymbology.Itf;
            case 14:
                return BarCodeSymbology.Codabar;
            case 24:
                return BarCodeSymbology.Code128;
            case 25:
                return BarCodeSymbology.Code93;
            case 37:
                return BarCodeSymbology.Ean128;
            case 255:
                return BarCodeSymbology.Rss14;
            default:
                break;
        }

    }
    else if (b2 == 0 && b3 == 0)
    {
        // Only use the first byte to determine the data type.
        switch (b1)
        {
            case 13:
                return BarCodeSymbology.Upca;
            case 22:
                return BarCodeSymbology.EanJan13;
            case 12:
                return BarCodeSymbology.EanJan8;
            default:
                break;
        }
    }

    return BarCodeSymbology.Other;
}

Additional details about how label and type data should be extracted from a scanned data buffer can be found in the UPOS specification.

Compiling the Code

  • For additional information about creating and compiling a Service Object project, see Service Object Samples: Getting Started.

See Also

Reference

DecodeScanDataLabel
DecodeScanDataType

Other Resources

Scanner Implementation


Scanner Events

Scanner Events |
 | See Also Example
Developing a Custom Service Object > Developing Service Objects Using Base Classes > Scanner Implementation >

1/18/2008

Bar code scanners operate asynchronously and therefore have to notify applications when data is available, or the device state has changed. You perform this task by using .NET delegates to raise events to the application.

As discussed in the Device Input and Events topic, events are queued before they are delivered to the application. The Microsoft POS for .NET Base classes provide a means for Service Object code to queue events so that their delivery to the application can be deferred until the application can process them. Meanwhile, the Service Object can continue waiting for additional incoming hardware events.

The Scanner device can send four events to the application. For two of these events, DataEvent and ErrorEvent, the POS for .NET ScannerBase class provides a protected helper method to simplify the code that is required to raise these events:

Event | Method That Queues the Event
DataEvent | Protected method ScannerBase.GoodRead
ErrorEvent | Protected method ScannerBase.FailedRead

The two other events, DirectIOEvent and StatusUpdateEvent, must be raised by using members of the lower-level ScannerBasic class. For more information, see Device Input and Events.

Because a Scanner device can deliver data to the system at any time, a Scanner Service Object must wait for data asynchronously by starting a separate reader thread. Events should be queued from this thread as data arrives from the device.

To raise events based on device input

  1. Start a reader thread to wait for input from the device.

  2. Wait for input on the reader thread, most frequently by using Win32 direct functions to read data from the USB bus.

  3. After you receive data, verify that the data is valid, for example, that there are enough bytes in the packet for the header and the data type.

  4. If the data is not valid, call the ScannerBase.FailedScan method to queue an ErrorEvent event that will be raised in the application.

  5. If the data is valid, call the ScannerBase.GoodScan method to queue a DataEvent event that will eventually be raised in the application.

Example

As soon as input is received from the device, the Service Object queues the appropriate event. You can do this by writing a method, such as the one in the sample in this topic that would be called from the reader thread of the Service Object.
Copy Code
// A Service Object may implement a method such as this one to
// be called from the reader thread of the Service Object.
void OnDataScanned(byte[] data)
{
    // Ignore input if process in the Error state. There is no
    // need to send an ErrorEvent to the application, because it has
    // already been notified by this point.
    if (State == ControlState.Error)
    {
        return;
    }

    // Make sure that the incoming buffer is large enough to contain
    // at least the header and type data.
    if ((int)data[1] < 5)
    {
        // By calling FailedRead, you are queueing an
        // ErrorEvent for eventual delivery to the application.
        FailedScan();
    }
    else
    {
        // The buffer received from the device will be longer
        // than we need. Therefore, trim it down. Allocate space for
        // the number of bytes contained in data[1], plus one
        // more for the first byte in the buffer.
        byte[] b = new byte[(int)data[1] + 1];

        // Copy the data into a new buffer.
        for (int i = 0; i <= (int)data[1]; i++)
        {
            b[i] = data[i];
        }

        // By calling GoodScan, you are queueing a DataEvent
        // which will delivered to the application when it is suitable.
        GoodScan(b);
    }
}

This sample cannot be compiled on its own, but may be inserted into a complete scanner Service Object implementation.

See Also

Tasks

Creating a Basic Service Object Code Template

Concepts

Base Class DirectIO Method
Device Input and Events

Other Resources

Service Object Samples: Getting Started


CashDrawer Implementation

CashDrawer Implementation |
 | See Also
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object > Developing Service Objects Using Base Classes >

1/18/2008

Most point-of-sale applications will use a cash drawer for financial transactions. Service Object developers can use the POS for .NET class, CashDrawerBase, to easily implement a UPOS-compliant CashDrawer Service Object.

Capabilities

All CashDrawer Service Objects must support, at a minimum, the ability to open the drawer. This is done by implementing the abstract method, CashDrawerBase.OpenDrawerImpl, in your Service Object class.

The Service Object may also be able to determine if the cash drawer is open or not. If the Service Object does have this capability, it should set the CapStatus property to true. If CapStatus is true, then applications may examine the state of the device using the DrawerOpened property. If CapStatus is not set, then DrawerOpened will always be set to false and any attempt to set it to true will generate an exception.

If CapStatus has been set to true, the Service Object needs to update the DrawerOpened property. You should do this in the Service Object's implementation of the OpenDrawerImpl method. A background thread monitoring the state of the device may also set the DrawerOpened property.

CashDrawer Events

If the Service Object has set the CapStatus property to true, CashDrawerBasic.DrawerOpened sends a StatusUpdateEvent to the application.

Depending on the cash drawer device and the Service Object implementation, the Service Object may need a separate thread to monitor the state of the hardware and report any changes asynchronously. This would be necessary, for example, if the cash drawer could be opened manually by the operator and the application needs to be notified.

The CashDrawer Service Object may also send a DirectIOEvent to the application. The DirectIOEvent is used to send data to the application that is specific to the Service Object implementation and may therefore be incompatible with some applications. For more information, see Device Input and Events.

Device Sharing

A cash drawer is a shareable device. Multiple applications will be able to open, enable, and access all of its properties and methods. However, once an application has claimed the device, only that application may call CashDrawerBase.OpenDrawer or CashDrawerBase.WaitForDrawerClose. A PosException with ErrorCode.Claimed will be thrown if other applications attempt to call these methods.

If more than one application has opened and enabled the device, then each application will receive all events sent by the Service Object.

The code necessary to support this feature is implemented in the POS for .NET CashDrawerBase class.

Multiple Cash Drawers

It is possible to have more than one cash drawer attached to the computer and using the same hardware port. In such situations, a CashDrawer Service Object may know to which cash drawer it is not specifically connected. If the Service Object can distinguish to which cash drawer device it is connected, it should set the CapStatusMultiDrawerDetect property to true. The value of this property will influence the behavior of the DrawerOpened property and the WaitForDrawerClose method.

If CapStatusMultiDrawerDetect is set to false, then a DrawerOpened value of true indicates that at least one drawer is open. The application is not able to determine whether any drawer in particular is open.

If CapStatusMultiDrawerDetect is set to false, the method WaitForDrawerClose waits for all open cash drawers to be closed before returning to the application.

See Also

Other Resources

Developing Service Objects Using Base Classes


LineDisplay Implementation

LineDisplay Implementation
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object > Developing Service Objects Using Base Classes >

1/18/2008

A LineDisplay Service Object is used to display text, bitmaps, and glyphs to a LineDisplay Point of Service device. This section provides information needed to implement LineDisplay Service Objects derived from the LineDisplayBase class.

In This Section

LineDisplay Capabilities

Lists the capability attributes and their related methods.

LineDisplay Sample

Contains a sample framework for a LineDisplay Service Object.

Reference

Service Object Samples: Getting Started

Microsoft.PointOfService.BaseServiceObjects


LineDisplay Capabilities

LineDisplay Capabilities |
 | See Also
Developing a Custom Service Object > Developing Service Objects Using Base Classes > LineDisplay Implementation >

1/18/2008

A LineDisplay Service Object supports, at a minimum, the ability to display characters on the output device. In addition, the device may also support additional features, which the Service Object exposes to the application by setting capability properties and implementing their corresponding methods and properties.

For each additional feature, there is a capability property defined in the LineDisplayBase class. The capability properties may not be queried until the application has called Open on the Service Object. Thereafter, the capability properties will indicate which properties and methods may be set and called on the Service Object.

This section lists the features that a LineDisplay Service Object may support. For each feature, there is a capability attribute that must be set by the Service Object as well a set of properties or methods which will be used by the application to access these features. In some cases, the feature is fully supported in LineDisplayBase and requires no additional code in the Service Object class.

The capability properties are implemented as read-only in order to prevent the application from changing their values. This means, too, that they cannot be set directly by the Service Object. Instead, LineDisplayBase has a protected property, Properties, which returns a LineDisplayProperties object. This class provides public equivalents for all capability properties. For example, in order to advertise that it supports blinking, a Service Object would write:

Copy Code
Properties.CapBlink = true;

And not:

Copy Code
CapBlink = true;

Marquee-like Scrolling of the Window

The Service Object may support either horizontal or vertical marquees. If horizontal scrolling is supported, the Service Object sets Properties.CapHMarquee to true. Likewise, if vertical scrolling is supported, Properties.CapVMarquee is set to true.

Thereafter, applications and Service Objects may use the following to set or get the marquee type:

Copy Code
DisplayMarqueeType MaqueeType {get, set; }

Inter-Character Wait

A line display device may have the ability to wait for a specified period of time before displaying each character to create a teletype effect. If this feature is supported, the Properties.CapICharWait property is set to true.

Thereafter, applications and Service Objects may use the following to set or get the inter-character wait time:

Copy Code
int InterCharacterWait { get; set; }

Blinking Text

A line display device may support character-level or device-level blinking at adjustable blink rates. If this feature is supported, the Service Object should set the Properties.CapBlink property to one of the following Properties.DisplayBlink enumeration values.

DisplayBlink Value | Corresponding UPOS Value | Description
None | DISP_CR_NOBLINK | The device does not support blinking.
All | DISP_CR_BLINKALL | The device supports blinking for the entire display.
Each | DISP_CR_BLINKEACH | The device supports blinking for each individual character.

Thereafter, applications and Service Objects may use the following to set or get the blink rate:

Copy Code
int BlinkRate {get; set; }

Reverse Video

A line display may support character-level or device-level reverse video. If this feature is supported, the Service Object should set the Properties.CapReverse to a value in the DisplayReverse enumeration.

DisplayReverse Value | Corresponding UPOS Value | Description
None | DISP-CR_NONE | Reverse video is not supported.
All | DISP_CR_REVERSEALL | The entire contents of the display are either displayed in reserve video or displayed normally.
Each | DIS_CR_REVERSEEACH | Each character may be individually set to reverse video or normal.

The CapReverse property is used by the DisplayText method.

Device Descriptors

Descriptors are small indicators with a fixed label, and are typically used to indicate transaction states such as item, total, and change. The Service Object should set Properties.CapDescriptors to true if descriptors are supported.

Thereafter, applications and Service Objects may use the following to set, get, or clear the Descriptors:

  • int DeviceDescriptors {get; set; }

  • void ClearDescriptors();

  • void SetDescriptor(int descriptor, DisplaySetDescriptor attribute);

Brightness Control

All LineDisplay Service Objects support two brightness levels, normal and blank, even if not supported by the physical device. If the device supports additional brightness levels, then Properties.CapBrightness should be set to true.

Thereafter, applications and Service Objects may use the following to set or get the device brightness:

Copy Code
int DeviceBrightness {get; set; }

Cursor Attributes

A line display device may support a variety of different cursor types. The Properties.CapCursorType property defines which of these types are supported. The CapCursorType property is set using the DisplayCursors enumeration and holds a bitwise indication of the supported cursor types, which can be any of the following types shown in the table.

CapCursorType enum | UPOS Value | Description
Blink | DISP_CCT_BLINK | A blinking cursor is supported.
Block | DISP_CCT_BLOCK | Cursor is displayable as a block.
Fixed | DISP_CCT_FIXED | Cursor is always displayed.
HalfBlock | DISP_CCT_HALFBLOCK | Cursor is displayable as a half block.
None | DISP_CCT_NONE | Cursor is not displayable.
Other | DISP_CCT_OTHER | Cursor is displayable, but the form is unknown.
Reverse | DISP_CCT_REVERSE | Cursor is displayable in reverse video.
Underline | DISP_CCT_UNDERLINE | Cursor is displayable as an underline.

Thereafter, applications and Service Objects may use the following to set or get the cursor type:

DisplayCursors CursorType { get; set; }

Glyphs

Glyphs are a pixel-level user definition of character cells. If glyphs are supported by the device, then Properties.CapCustomGlyph should be set to true.

Thereafter, applications and Service Objects may use the following to set or get the glyph list and settings:

  • RangeOfCharacters [] CustomGlyphList { get; set; }

  • int GlyphHeight { get; }

  • int GlyphWidth { get; }

  • void DefineGlyph(int glyphCode, byte[] glyph);

Screen Modes

A device may support changing the screen mode; that is, the number of rows and columns displayed. If this feature is supported by the device, the Service Object should set Properties.CapScreenMode to true.

Thereafter, the application and Service Object may use the following to set or get the screen mode:

  • int ScreenMode { get; set; }

  • DisplayScreenMode [] ScreenModeList { get; }

Bitmaps

The Service Object should set the Properties.CapBitmap property to true if the device supports displaying bitmaps.

The Service Object may want to override the following methods if this capability is supported:

  • void DisplayBitmap(string fileName, int alignmentX, int alignmentY);

  • void DisplayBitmap(string fileName, int width, int alignmentX, int alignmentY);

Character Sets

A Service Object should set the Properties.CapCharacterSet property with the default character set capability of the line display device. This property can be set to a member of the CharacterSetCapability enumeration as shown in the following table.

CharacterSetCapability Value | UPOS Value | Description
Alpha | PTR_CCS_ALPHA | The default character set supports uppercase alphabetic plus numeric, space, minus, and period.
ANSI | N/A | This value is not used for LineDisplay devices.
ASCII | PTR_CCS_ASCII | The default character set supports 0x20 through 0x75.
Kana | PTR_CCS_KANA | The default character set supports partial code page 932, including ASCII characters 0x20 through 0x7F and the Japanese Kana characters 0xA1 through 0xDF, but excluding the Japanese Kanji characters.
Kanji | DISP_CCS_KANJI | The default character set supports code page 932 including the Shift-JIS Kanji characters, Levels 1 and 2.
Numeric | N/A | This value is not used for LineDisplay devices.
Unicode | DISP_CCS_UNICODE | The default character set supports UNICODE.
Windows | N/A | This value is not used for LineDisplay devices.

Thereafter, applications and Service Objects may use the following to set or get the character set:

Copy Code
int CharacterSet { get; set; }

See Also

Tasks

LineDisplay Sample

Other Resources

LineDisplay Implementation


LineDisplay Sample

LineDisplay Sample |
 | See Also Example
Developing a Custom Service Object > Developing Service Objects Using Base Classes > LineDisplay Implementation >

1/18/2008

The LineDisplayBase class is a relatively thin abstraction layer when compared to other Service Object Base classes—there is little code needed between the application and the physical device. The LineDisplay Service Object simply needs to advertise which features the physical device supports and modify its output according to the display properties the application has set.

A LineDisplay Service Object may also monitor the device and report power or other status changes back to the application using a StatusUpdateEvent. This can be done by using the Queue methods or, for example, by using the power reporting features in PosCommon. Monitoring the device this way will generally require starting a new thread to wait for hardware events and queue the appropriate StatusUpdateEvent. A LineDisplay Service Object may also send DirectIOEvents to the application.

To implement the LineDisplay class and attributes

  1. Add using directives for the Microsoft.PointOfService and Microsoft.PointOfService.BaseServiceObject namespaces.

  2. Add the global attribute PosAssemblyAttribute so that PosExplorer recognizes this as a POS for .NET assembly.

  3. Create a new class which is derived from LineDisplayBase.

  4. Add the class-level attribute ServiceObjectAttribute to your new class so that PosExplorer recognizes it as a Service Object.

To implement abstract LineDisplayBase members

  1. All LineDisplay Service Objects must support at least one screen mode. To provide the application with specifics about the supported screen modes, implement the abstract property LineDisplayScreenModes.

  2. At a minimum, all LineDisplay Service Objects must implement DisplayData to display characters on the output device.

Additional Capabilities

Set capability properties in your Service Object to advertise support for the features of your device. This sample demonstrates how to implement the LineDisplay blink feature.

To implement the blink feature

  1. In the constructor, set the CapBlink property to either DisplayBlink.All or DisplayBlink.Each to indicate which blinking mode this Service Object supports.

  2. Set the CapBlink property to true indicating that the blink rate may be set by the application by calling BlinkRate.

  3. Take these and other settings into account when implementing DisplayData.

Example

Copy Code
using System;
using System.Collections.Generic;
using System.Text;

using Microsoft.PointOfService;
using Microsoft.PointOfService.BaseServiceObjects;

[assembly: PosAssembly("Service Object Contractors, Inc.")]

namespace SOSample.LineDisplay
{
    [ServiceObject(
          DeviceType.LineDisplay,
          "SampleLineDisplay",
          "Sample LineDiplay Service Object",
          1,
          9)]

    public class SampleLineDisplay : LineDisplayBase
    {
        SampleLineDisplay()
        {
            // The CapBlink property is initially set to
            // DisplayBlink.None in LineDisplayBase. This property
            // will be set here to indicate what mode of blinking
            // text our Service Object can support.
            Properties.CapBlink = DisplayBlink.All;

            // Set the CapBlinkRate property to true to indicate
            // that this device has the ability to change the
            // rate at which it blinks by setting the property
            // BlinkRate.
            Properties.CapBlinkRate = true;
        }

        #region Implement Abstract LineDisplayBase Members
        // LineDisplayScreenMode must be implemented to
        // allow the application to find out which screen modes
        // are supported by this device.
        protected override LineDisplayScreenMode[]
                                    LineDisplayScreenModes
        {
            get
            {
                LineDisplayScreenMode[] SupportedModes;

                // Create a LineDisplayScreenMode object; this SO
                // has a screen mode 10 columns wide and 2 rows deep.
                LineDisplayScreenMode mode =
                        new LineDisplayScreenMode(10, 2, 0, 0);

                // Allocate space for our screen mode array and
                // initialize it to hold our supported screen
                // mode(s).
                SupportedModes =
                        new LineDisplayScreenMode[] { mode };

                return SupportedModes;
            }
        }

        // DisplayData is the method called from the application
        // specifying what data should be displayed on the
        // device.
        protected override void DisplayData(Cell[] cells)
        {
            // Your code here:
            // Send the data to your device. Take settings such
            // as blink and blink rate into account here.
            return;
        }
        #endregion Implement Abstract LineDisplayBase Members

        #region Implement Abstract PosCommon Members
        private string MyHealthText = "";

        // PosCommon.CheckHealthText.
        public override string CheckHealthText
        {
            get
            {
                // VerifyState(mustBeClaimed,
                // mustBeEnabled).
                VerifyState(false, false);
                return MyHealthText;
            }
        }

        //  PosCommon.CheckHealth.
        public override string CheckHealth(
                        HealthCheckLevel level)
        {
            // Verify that the device is open, claimed and enabled.
            VerifyState(true, true);

            // Your code here:
            // check the health of the device and return a
            // descriptive string.

            // Cache result in the CheckHealthText property.
            MyHealthText = "Ok";
            return MyHealthText;
        }

        // PosCommon.DirectIOData.
        public override DirectIOData DirectIO(
                                int command,
                                int data,
                                object obj)
        {
            // Verify that the device is open.
            VerifyState(false, false);

            return new DirectIOData(data, obj);
        }
        #endregion Abstract PosCommon Members
    }
}

See Also

Other Resources

LineDisplay Implementation
Developing Service Objects Using Base Classes


PinPad Implementation

PinPad Implementation
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object > Developing Service Objects Using Base Classes >

1/18/2008

A PinPad device provides a mechanism for customers to perform PIN entry and acts as a cryptographic engine for communicating with an EFT Transaction Host. To perform these tasks, a PinPad Service Object may implement one or more PIN Pad Management Systems. A PinPad Management System defines the manner in which the PinPad performs functions such as PIN Encryption, Message Authentication Code calculations, and Key Updating. Examples of PinPad management systems include Master-Session, DUKPT, APACS40, HGEP02, AS2805, and JDEBIT2, along with many others.

A PinPad Service Object must have the following minimum capability:

  • Accepts a PIN Entry at its keyboard and provides an Encrypted PIN to the application.

A PinPad Service Object may also have the following additional capabilities:

  • Computes Message Authentication Codes.

  • Performs Key Updating in accordance with the selected PIN Pad Management System.

  • Allows use of the PIN Pad Keyboard, Display, and Tone Generator for application usage. If one or more of these features are available, then the application opens and uses the associated POS Keyboard, Line Display, or Tone Indicator Device Objects.

In This Section

PinPad Capabilities

Outlines the programming model and capabilities for PinPad Service Objects.

PinPad Sample

Provides the PinPad sample code.

Reference

PinPadBase

Provides the POS for .NET reference for the PinPadBase class.

Developing a Custom Service Object

Describes the POS for .NET Service Object development.


PinPad Capabilities

PinPad Capabilities |
 | See Also
Developing a Custom Service Object > Developing Service Objects Using Base Classes > PinPad Implementation >

1/18/2008

A PIN Pad performs encryption functions under control of a PIN Pad Management System. Some PinPad Service Objects support multiple PIN Pad Management Systems and some PIN Pad Management Systems support multiple key sets for different Electronic Funds Transfer (EFT) Transaction Hosts. Thus, for each EFT transaction, the application needs to select the PIN Pad Management System and EFT Transaction Host to be used.

Programming Model

Depending on the PIN Pad Management System, one or more EFT transaction parameters need to be provided to the PIN Pad for use in the encryption functions. The application should set the value of ALL EFT Transaction parameter properties to enable easier migration to EFT Transaction Hosts that require a different PIN Pad Management System.

  • After opening, claiming, and enabling the PIN Pad Control, an application should use the following general scenario for each EFT Transaction.

  • Set the EFT transaction parameters (AccountNumber, Amount, MerchantID, TerminalID, Track1Data, Track2Data, Track3Data, Track4Data, and TransactionType properties) and then call the BeginEftTransaction method. This will initialize the device to perform the encryption functions for the EFT transaction.

If PIN Entry is OnFailure, call the EnablePinEntry method. Then set the DataEventEnabled property and wait for the DataEvent event.

  • If Message Authentication Codes are required, use the ComputeMac and VerifyMac methods as needed.

  • Call the EndEftTransaction method to notify the device that all operations for the EFT transaction have been completed. This specification supports two models of usage of the display. The CapDisplay property indicates one of the following models:

    • An application has complete control of the text that is to be displayed. For this model, there is an associated LineDisplay control that is used by the application to interact with the display.

    • An application cannot supply the text to be displayed. Instead, it can only select from a list of predefined messages to be displayed. For this model, there is a set of PIN Pad properties that are used to control the display.

Device Sharing

The PIN Pad is an exclusive-use device, therefore:

  • The application must claim the device before enabling it.

  • The application must claim and enable the device before the device begins reading input, or before calling methods that manipulate the device.

POS for .NET ~Impl Methods

The protected abstract methods that end with the suffix, "Impl" are called from their POS for .NET public counterparts. This allows the Base class implementation to perform appropriate status and error checking before and after the ~Impl method is called. These methods must be implemented in the Service Object code, but the public, nonabstract counterparts should be overridden only in special cases, such as when the Service Object code needs to remove or change the standard validation tests.

POS for .NET ~Impl Methods

  • A PinPad Service Object may send the following events to the application:

  • DataEvent

  • DirectIOEvent

  • StatusUpdateEvent

  • ErrorEvent

See Also

Other Resources

PinPad Implementation


PinPad Sample

PinPad Sample |
 | See Also Example
Developing a Custom Service Object > Developing Service Objects Using Base Classes > PinPad Implementation >

1/18/2008

This sample demonstrates which methods must be implemented in a PinPad Service Object.

To implement a PinPad Service Object framework

  1. Add using directives for Microsoft.PointofService, Microsoft.PointOfService.BaseServiceObjects.

  2. Add the global attribute PosAssembly.

  3. Choose an appropriate namespace name for your project.

  4. Create a Service Object class derived from PinPadBase.

  5. Add the ServiceObject attribute to your Service Object class, using the DeviceType.PinPad value as your device type.

Example

Copy Code
using System;
using System.Collections.Generic;
using System.Text;
using System.Threading;

using Microsoft.PointOfService.BaseServiceObjects;
using Microsoft.PointOfService;

[assembly: PosAssembly("Service Object Contractors, Inc")]

namespace SOSamples.PinPad
{
    [ServiceObject(
             DeviceType.PinPad,
             "SamplePinPad",
             "Sample PinPad Service Object",
             1,
             9)]
    public class SamplePinPad : PinPadBase
    {
        PinPadSystem pinPadSystemSupported = PinPadSystem.Dukpt;

        public SamplePinPad()
        {
        }

        #region Implement Abstract PinPadBase Members

        // These abstract protected methods are called from their
        // public, counterpart methods after error and state
        // validation checks are performed.

        protected override void BeginEftTransactionImpl(
                        PinPadSystem pinpadSystem,
                        int transactionHost)
        {
            // If pinpadSystem is not supported by this device,
            // throw a PosControlException.
            if (pinpadSystem != pinPadSystemSupported)
            {
                throw new PosControlException(
                            "PinPadSystem not supported",
                            ErrorCode.Illegal);
            }

            // Your code here. Perform any device-specific
            // initialization, such as computing session keys.
        }

        protected override string ComputeMacImpl(
                        string inMsg)
        {
            // Your code here. Depending on the selected PIN Pad
            // Management system, the PinPad Service Object may
            // insert additional fields into the message (inMsg).
            return inMsg;
        }

        protected override void EnablePinEntryImpl()
        {
            // PinPadBase sets PINEntryEnabled if this method
            // succeeds. After that, the Service Object may
            // send a DataEvent to the application.
        }

        protected override void EndEftTransactionImpl(
                        EftTransactionCompletion completionCode)
        {
            // Your code here. Perform any device or Service
            // Object cleanup such as computing the next
            // transaction keys.
        }

        protected override void UpdateKeyImpl(
                        int keyNumber,
                        string key)
        {
            // Your code here. Update the specified key
            // on your device.
        }

        protected override void VerifyMacImpl(
                        string message)
        {
            // Your code here. Verify the MAC value in a message
            // received from the EFT Transaction host.
        }
        #endregion Implement Abstract PinPadBase Members

        #region Implement Abstract PosCommon Members
        private string MyHealthText = "";

        // PosCommon.CheckHealthText.
        public override string CheckHealthText
        {
            get
            {
                // VerifyState(mustBeClaimed,
                // mustBeEnabled).
                VerifyState(false, false);
                return MyHealthText;
            }
        }

        //  PosCommon.CheckHealth.
        public override string CheckHealth(
                        HealthCheckLevel level)
        {
            // Verify that the device is open, claimed, and enabled.
            VerifyState(true, true);

            // Your code here:
            // check the health of the device and return a
            // descriptive string.

            // Cache result in the CheckHealthText property.
            MyHealthText = "Ok";
            return MyHealthText;
        }

        // PosCommon.DirectIOData.
        public override DirectIOData DirectIO(
                                int command,
                                int data,
                                object obj)
        {
            // Verify that the device is open.
            VerifyState(false, false);

            return new DirectIOData(data, obj);
        }
        #endregion  Implement Abstract PosCommon Members
    }
}

See Also

Other Resources

PinPad Implementation


PosKeyboard Implementation

PosKeyboard Implementation |
 | See Also Example
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object > Developing Service Objects Using Base Classes >

1/18/2008

A PosKeyboard Service Object reads keys from a POS keyboard. A POS keyboard may be an auxiliary keyboard, or it may be a virtual keyboard consisting of some or all of the keys on the system keyboard. The POS keyboard Base class is PosKeyboardBase.

A PosKeyboard Service Object follows the general input device model:

  • When input is received from the POS keyboard, a DataEvent is queued.

  • If the AutoDisable property is true, then the device automatically disables itself when a DataEvent event is queued. This is done automatically by the PosKeyboardBase class.

  • A queued DataEvent event will be delivered to the application when the DataEventEnabled property is true and other event delivery requirements are met. The PosKeyboardBase class will manage event delivery automatically.

  • An ErrorEvent event is queued if an error while gathering or processing input, and is delivered to the application when DataEventEnabled is true and other event delivery requirements are met.

  • The DataCount property, which is maintained by the PosKeyboardBase class, may be read to obtain the number of queued events.

  • All queued input may be deleted by calling ClearInput.

The POS keyboard is an exclusive-use device:

  • The application must claim the device before enabling it.

  • The application must claim and enable the device before the device begins reading input.

This section contains a sample PosKeyboard Service Object that generates simulated keystrokes which are sent to the application by using DataEvents. This sample depends on the thread-helper object presented in Introducing Service Object Reader Threads. To compile this sample, you need to include the code from that topic.

To write a Service Object

  1. Add using directives for Microsoft.PointofService, Microsoft.PointOfService.BaseServiceObjects, and System.Threading.

  2. Add the global attribute PosAssembly.

  3. Choose an appropriate namespace name for your project.

  4. Create a Service Object class derived from PosKeyboardBase.

  5. Add the ServiceObject attribute to your Service Object class, using the DeviceType.PosKeyboard value as your device type.

To add features to the sample keyboard Service Object

  1. Create a thread helper class, KeyboardThreadingObject, derived from ServiceObjectThreadHelper from the Service Object Read Threads section.

  2. Implement the ServiceObjectThreadProcedure method in the KeyboardThreadingObject class. This is the procedure that will be run on a separate thread. In the sample code below, this method simulates keyboard input.

  3. This sample class implements a method called SendKey and another called ChangePowerState. These methods are wrappers around protected members. Because they are protected, they cannot be invoked directly from the threading object.

  4. Override the PosCommon.Open method to specify capabilities supported by this Service Object and create a new thread-helper object.

  5. Override the PosCommon.DeviceEnable specifically to Open and Close the thread-helper.

  6. Implement the abstract virtual methods from PosCommon, providing minimum functionality.

Running the Application

This sample Service Object can be run in conjunction with the test application provided with the POS for .NET SDK.

To test the Service Object

  1. Start the test application and select SamplePosKeyboard from the Keyboard drop-down list.

  2. Open and Claim the device, and then select the device with the DeviceEnabled check box to enable it.

  3. Checking the DataEventEnabled box will allow the Service Object to send a single simulated key to the application. The DataEvent is queued automatically by the PosKeyboardBase class when KeyDown is called.

  4. Selecting the Automatically enable data events box allows the Service Object to continue delivering characters, two seconds apart.

  5. The Service Object will send simulated key strokes for characters 'a' through 'z'. After that, a StatusUpdateEvent event will be sent indicating the device is now offline. This event is sent automatically by the PosKeyboardBase class when Properties.PowerState is changed.

Example

This sample demonstrates how to develop a simple PosKeyboard Service Object. It supports a separate reader thread to send DataEvents asynchronously to the application. Once compiled, you can execute the Service Object in conjunction with the test application included with the POS for .NET SDK.
Copy Code
using System;
using System.Collections.Generic;
using System.Text;
using System.Threading;

using Microsoft.PointOfService;
using Microsoft.PointOfService.BaseServiceObjects;

[assembly: PosAssembly("Service Object Contractors, Inc.")]

namespace SOSamples.Keyboard
{
    [ServiceObject(
          DeviceType.PosKeyboard,
          "SamplePosKeyboard",
          "Sample PosKeyboard Service Object",
          1,
          9)]

    public class SampleKeyboard : PosKeyboardBase
    {
        KeyboardThreadingObject ReadThread = null;

        public SampleKeyboard()
        {
            // DevicePath must be set before Open() is called.
            // In the case of Play and Plug hardware, the
            // POS for .NET Base class will set this value.
            DevicePath = "Sample Keyboard";

            // NOTE: You can test the power notification events
            // sent from this Service Object by selecting the
            // "Power Notify" check box.

            // Let the application know advanced power
            // reporting is supported.
            Properties.CapPowerReporting = PowerReporting.Advanced;
            Properties.CapKeyUp = false;
        }

        ~SampleKeyboard()
        {
            // Code added from previous sections to terminate
            // the read thread started by the thread-helper
            // object.
            if (ReadThread != null)
            {
                ReadThread.CloseThread();
            }

            Dispose(false);
        }

        // Expose the protected KeyDown() method so that it can be
        // called from our threading helper.
        public void SendKey(int key)
        {
            KeyDown(key);
        }

        // Expose the protected PowerState property so it can be
        // changed from the threading helper.
        public void ChangePowerState(PowerState state)
        {
            Properties.PowerState = state;
        }

        #region Override Virtual PosCommon Members
        public override void Open()
        {
            base.Open();

            // Create the reader-thread object.
            ReadThread = new KeyboardThreadingObject(this);
        }

        public override bool DeviceEnabled
        {
            get
            {
                return base.DeviceEnabled;
            }
            set
            {
                if (value != base.DeviceEnabled)
                {
                    base.DeviceEnabled = value;

                    if (value == false)
                    {
                        // Stop the reader thread when the device
                        // is disabled.
                        ReadThread.CloseThread();
                    }
                    else
                    {
                        try
                        {
                            // By enabling the device, start the
                            // reader thread.
                            ReadThread.OpenThread();
                        }
                        catch (Exception e)
                        {
                            base.DeviceEnabled = false;

                            if (e is PosControlException)
                                throw;

                            throw new PosControlException(
                                    "Unable to Enable Device",
                                    ErrorCode.Failure, e);
                        }
                    }
                }
            }
        }
        #endregion Override Virtual PosCommon Members

        #region Implement Abstract PosCommon Members
        private string MyHealthText = "";

        // PosCommon.CheckHealthText.
        public override string CheckHealthText
        {
            get
            {
                // VerifyState(mustBeClaimed,
                // mustBeEnabled).
                VerifyState(false, false);
                return MyHealthText;
            }
        }

        //  PosCommon.CheckHealth.
        public override string CheckHealth(
                        HealthCheckLevel level)
        {
            // Verify that device is open, claimed and enabled.
            VerifyState(true, true);

            // Your code here:
            // Check the health of the device and return a
            // descriptive string.

            // Cache result in the CheckHealthText property.
            MyHealthText = "Ok";
            return MyHealthText;
        }

        // PosCommon.DirectIOData.
        public override DirectIOData DirectIO(
                                int command,
                                int data,
                                object obj)
        {
            // Verify that the device is open.
            VerifyState(false, false);

            return new DirectIOData(data, obj);
        }
        #endregion  Implement Abstract PosCommon Members
    }

    #region Thread Helper Class
    public class KeyboardThreadingObject :
        ServiceObjectThreadHelper, IDisposable
    {
        // This is a helper class which will depend on
        // being able to call back into the actual Service
        // Object to pass along data. However, you cannot
        // keep a strong reference to the Service Object,
        // since that may prevent clean disposal, leaving
        // hardware resources unavailable to other processes.
        // Therefore, you create a weak reference. From this
        // reference, you can get a temporary strong reference,
        // which you can act on and then release.
        WeakReference ServiceObjectReference;

        // The name of the Service Object.
        string ObjectName;

        public KeyboardThreadingObject(SampleKeyboard so)
        {
            ObjectName = GetType().Name;
            ServiceObjectReference = new WeakReference(so);
        }

        // This method will be called during initialization.
        public override void ServiceObjectThreadOpen()
        {
            Logger.Info(ObjectName, "Keyboard Thread Open");
        }

        // This method will be called curing shutdown.
        public override void ServiceObjectThreadClose()
        {
            Logger.Info(ObjectName, "Keyboard Thread Open");
        }

        // Your code used to monitor your device for input should
        // go here. The implementation below generates simulated
        // input as an example.
        public override void ServiceObjectThreadProcedure(
                            AutoResetEvent ThreadStopEvent)
        {
            Logger.Info(ObjectName,
                            "Keyboard Thread Procedure Entered");
            int KeyValue = (int)'a';

            while (true)
            {
                // When this method is called by the
                // ServiceObjectThreadHelper, it is obligated to
                // exit when the event ThreadStopEvent has been
                // set.
                if (ThreadStopEvent.WaitOne(2000, false))
                {
                    break;
                }

                if (KeyValue <= (int) 'z')
                {
                    Logger.Info(ObjectName, "Reader Thread cycling");

                    // Try to get a strong reference to the Service
                    // Object using the weak reference saved when
                    // this helper object was created.
                    SampleKeyboard Keyboard =
                        ServiceObjectReference.Target
                        as SampleKeyboard;

                    // If this fails, that means the Service Object
                    // has already been disposed of - exit the thread.
                    if (Keyboard == null)
                    {
                        break;
                    }

                    if (Keyboard.DataEventEnabled == true)
                    {
                        // Call a method implemented in our Keyboard
                        // class to queue the key stroke.
                        Keyboard.SendKey(KeyValue);

                        // Simulate input by moving through the
                        // alphabet, sending one character at a time.
                        KeyValue++;
                        if (KeyValue >= (int)'z')
                        {
                            // Once you run out of input, simulate a
                            // power state change. Setting the SO's
                            // PowerState property to
                            // PowerState.Offline will cause a
                            // StatusUpdateEvent to be sent to the
                            // application.
                            Keyboard.ChangePowerState(
                                            PowerState.Offline);

                            // Release the strong reference.
                            Keyboard = null;

                            // There is no more work, so exit the
                            // loop.
                            break;
                        }
                    }

                    // Release the strong reference.
                    Keyboard = null;
                }
            }
        }
    }
    #endregion Thread Helper Class
}

Compiling the Code

  • This sample requires that the code from the Introducing Service Object Reader Threads section be included.

  • The assemblies Microsoft.PointOfService and Microsoft.PointOfService.BaseServiceObjects must be referenced.

See Also

Tasks

Introducing Service Object Reader Threads

Other Resources

Developing Service Objects Using Base Classes
Service Object Samples: Getting Started


Using Impl Methods for Synchronous or Asynchronous Output

Using Impl Methods for Synchronous or Asynchronous Output |
 | See Also
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object > Developing Service Objects Using Base Classes >

1/18/2008

Some POS device types support printed or displayed output, for example, the PosPrinter or LineDisplay. Service Objects written for output-enabled devices should provide support for both asynchronous and synchronous output.

An application that performs an operation asynchronously will set the AsyncMode property of the Service Object to true before calling the desired output method. The Service Object may throw an exception if it is unable to process the request asynchronously, but this is not ideal since it limits the scope of applications that may use that particular Service Object.

Supporting asynchronous output may, however, require additional and potentially complicated code. This code would manage a queue of incoming requests, maintain a thread to monitor the queue and dispatch requests in the proper order, and raise events back to the application.

The POS for .NET Base classes can manage all of these tasks for the developer. For each output method, the Base class has a helper method associated with each output method. These methods, which end with the Impl suffix, are written as if they were simply the synchronous implementation of their parent method. The Base class transparently manages a queue, dispatches requests to the Impl functions at the right time in the right order, and raises the appropriate events back to the application. This same method is called for both synchronous and asynchronous operations.

By deriving from a POS for .NET Base class, the Service Object gets asynchronous functionality without implementing additional code.

Base Class Implementation

POS for .NET provides Base classes for a subset of POS device types. For each output method in these classes, there is a corresponding method with an Impl suffix. The Service Object derived from a Base class should override only the Impl method and not the corresponding parent method. For example, in a class derived from the POS for .NET Base class PosPrinterBase, the Service Object would provide an implementation for PrintNormalImpl and would not override PrintNormal.

The POS for .NET Base classes implement all output methods and perform the following tasks in order to support the Impl method implemented by the Service Object:

  • Validate arguments.

  • If the AsyncMode property is false, the corresponding Impl method is called immediately.

  • If the AsyncMode property is set to true:

    1. The request is placed in a queue. This queue is owned by POS for .NET and is managed by its own thread.

    2. Requests on the queue are examined by the queue's thread and the corresponding Impl method is called. This call could be delayed if the device is already processing an output request or if a request of higher priority on the queue exists.

  • When the Impl method returns, the POS for .NET Base class code handles all results. For a synchronous call, the method may either return a value or throw an exception. For an asynchronous call, the method may raise OutputCompleteEvent or ErrorEvent events back to the application.

  • Impl methods may also return an object which contains not only error information, but also statistics values.

Service Object Impl Methods

Since most processing is handled by the Base class code, the Service Object's Impl method can be relatively simple.

In many cases, the state of the device at the time of the original call is required by the Impl method. In these situations, the Base class code saves the current device state along with the output request. The device state is later sent as an argument to the Impl method. For example, the definition for PrintNormalImpl is:

Copy Code
protected override PrintResults PrintNormalImpl(
    PrinterStation station,
    PrinterState printerState,
    string data);

The argument printerState above is specific to the Impl method and does not exist in the PrintNormal definition.

The return value of Impl functions also differs from their calling methods. For example, note that the PrintNormalImpl method returns a class of type PrintResults. In addition to ErrorCode, ErrorCodeExtended, ErrorLevel, and ErrorString, there are a number of additional properties which will be used by the calling method to update statistic counts.

Example

The following example demonstrates how these methods are implemented in Service Object code.

Copy Code
protected override PrintResults PrintNormalImpl(
        PrinterStation station,
        PrinterState printerState,
        string data)
{
    // First, create a PrintResults object to hold return values.
    PrintResults pr = new PrintResults();

    // Now print, depending on the station.
    if (station == PrinterStation.Receipt)
    {
        // Your code goes here.

        // Update statistics to be returned to the caller.
        pr.ReceiptLinePrintedCount = 1;
        pr.ReceiptCharacterPrintedCount = data.Length;
    }
    else if (station == PrinterStation.Slip)
    {
        // Your code goes here.

        // Update statistics to be returned to the caller.
        pr.SlipLinePrintedCount = 1;
        pr.SlipCharacterPrintedCount = data.Length;
    }

    return pr;
}

See Also

Tasks

Asynchronous Output Sample

Reference

PosPrinterBase

Concepts

Device Output Models

Other Resources

Developing a Custom Service Object


Device Input and Events

Device Input and Events |
 | See Also
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object >

1/18/2008

All POS devices have the ability to generate events or change state independent of the application. For example, if an operator unplugs a PinPad device, the application has no direct way of detecting this change since it is not a state change requested by the application. A Service Object must have some way of alerting the application to these state changes.

Multithreading

Since having the application continuously poll the Service Object for its current state would be far too expensive, another solution is needed. Typically, the solution is to create a background thread to monitor the device.

As other examples have demonstrated, creating a reader thread is always necessary for input devices such scanners or magnetic strip readers. For output devices such as line displays and printers, however, a second thread is often necessary to watch for state changes, such as losing power or going offline, and then to send a StatusUpdateEvent event to the application.

In this way, the Service Object can be responsive to requests from the application while asynchronously monitoring the hardware.

Defining Events

Events are the mechanism by which the Service Object notifies the application of a state change in the device, or the arrival of new data.

In general terms, an event is a notification between one thread or process and another that something has occurred. More specifically, POS for .NET uses the .NET delegates feature to deliver to the application.

The UPOS specification defines a set of five events: DataEvent, DirectIOEvent, ErrorEvent, OutputCompleteEvent, and StatusUpdateEvent. Each Service Object may be permitted to only support a subset of these. The exact contents of the data also depends on the Service Object type.

Event Queues

When you create a Service Object class derived from one of the POS for .NET Base classes, events are not sent directly from the Service Object to the application. Instead, events are placed into a queue managed by the Base class. Since there are conditions that must be met before events may be delivered to an application, code in the Base class dispatches events only when it is appropriate to do so. The Service Object does not need be aware of the queue or of the requirements that must be met before an event can be fired. This greatly eases the burden on the Service Object developer.

The event queue operates asynchronously by using its own thread. This means that the Service Object does not wait for the actual delivery of the event.

Adding Events to the Queue

The POS for .NET Base classes provide a number of ways to add an event to the queue depending on the Service Object and the event type.

Many Base classes have helper methods to simplify the queuing of certain events; most commonly, DataEvent events. For instance, the method MsrBase.GoodRead can be used to queue a DataEvent event after a successful card read. Likewise, PosKeyboard.KeyDown queues a DataEvent indicating that a key has been pressed.

Events may also be queued automatically by the Base class when a certain state is changed. For example, if a Service Object has set its Properties.CapPowerReporting property, then a StatusUpdateEvent indicating a power change can be sent simply by setting the Properties.PowerState property in the Service Object.

Finally, if needed a Service Object may specifically queue an event using any of the QueueEvent overrides. This may be used most often for sending a DirectIOEvent. Since DirectIOEvent events are vendor-specific and device-specific, no generic mechanism can be used to queue them.

Synchronous Input

Although most device input is read asynchronously by the Service Object and then dispatched to the application in the form of events, there are instances, however, where the application may request data from the Service Object and not return until the data is ready or a time-out has been reached. For more information about event-driven input, see Event Management.

See Also

Tasks

Event Handler Sample

Concepts

Event Management

Other Resources

Developing Service Objects Using Base Classes


Device Output Models

Device Output Models |
 | See Also
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object >

1/18/2008

The UPOS output model consists of two output types; synchronous and asynchronous. A POS device type may support one or both types, or neither type.

Synchronous Output

When an application uses a device type-specific synchronous method to write output, the write operation takes place on the same thread that called the method. The Service Object may not return until the write operation has either been completed or failed.

Using synchronous output is simple, but can potentially impact application performance if the output cannot be completed relatively quickly. Service Object developers should take this into account.

Asynchronous Output

Certain POS device types support asynchronous output. In the asynchronous output model, the application calls the Service Object to request that data be output to the device. Unlike the synchronous model, however, the Service Object must not wait for the write operation to complete; instead it should return control to the application as soon as possible. When a Service Object receives a request from the application, it should do the following:

  • If the physical device is not able to receive data, the Service Object should buffer it in memory until the device is ready.

  • Set the OutputId property to an identifier for this request, to be used during future events that are sent to the application.

  • Return as soon as possible.

The Service Object must then wait for the device to complete the request. Typically, this is done with a separate thread, managed by the Service Object, which monitors the hardware. Once the request is completed successfully, an OutputCompleteEvent event, with OutputEventArgs.OutputId set to the previously specified identifier, is queued for delivery to the application.

Service Object Managed Queue

The POS for .NET class library offers support for asynchronous output, which is sufficient for nearly all Service Object scenarios.

There are, however, some scenarios where Service Object developers may need to implement their own asynchronous output handling. The primary scenario is to support devices that support hardware-based print queues. In this case, the Service Object sets UseExternalPrintQueue to true, overrides the PreQueuePrintData method, and implements their own queue mechanism.

When UseExternalPrintQueue is set to true, the Base class no longer adds the print requests to its internal asynchronous queue, so it is up to the Service Object developers to queue data in any way they require. This is often done by using the device's hardware print queuing features. The Base class still prevalidates the same print requests but does not do any additional processing.

In these cases, the Service Object will be responsible for the following:

  • Implementing its own queuing logic.

  • Sending StatusUpdateEvents for successful operations.

  • Sending ErrorEvents for failed asynchronous operations and handling the retry.

  • Updating the state property.

  • All other asynchronous operations defined in the UPOS specification.

See Also

Tasks

Event Handler Sample
Asynchronous Output Sample
Introducing Service Object Reader Threads

Other Resources

Developing Service Objects Using Base Classes


Asynchronous Output Sample

Asynchronous Output Sample |
 | See Also Example
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object >

1/18/2008

POS for .NET supports asynchronous output in compliance with the UPOS specification. In the asynchronous output model, the Service Object must queue output requests so that it can return control to the application as quickly as possible. A second thread must then dispatch output to the device and notify applications when the request has been fulfilled, either with an OutputCompleteEvent or an ErrorEvent event.

The POS for .NET class library handles most of these functions for the Service Object developer so that there is little, if any, difference between an asynchronous output device and a synchronous output only device.

To create the project

  1. Create a Visual Studio class library project.

  2. Add the sample code below to your project.

  3. Add references to the Microsoft.PointOfService assemblies.

  4. Compile and copy the Service Object to one of the directories in your Service Object assembly load path.

To use the application sample with the Service Object

  • This Service Object can be used with the application sample presented in Event Handler Sample.

Example

To output to a PosPrinter device, an application will most commonly use the PrintNormal method. Notice that the PosPrinter Service Object code below does not provide an implementation for this method. Instead, PrintNormalImpl is implemented. This method is called by the POS for .NET library for both synchronous and asynchronous output requests.

When an application calls an output method, such as PrintNormal, the POS for .NET implementation checks the value of the AsyncMode property. If this value is false, then the POS for .NET library sends the request to PrintNormalImpl immediately and waits for it to return. If the value is true, however, then the POS for .NET implementation of PrintNormal adds the request to an internally managed queue. While there are items in the queue, a POS for .NET managed thread will send each request, in first-in-first-out (FIFO) order, to the device by calling PrintNormalImpl. When PrintNormalImpl returns, the library implementation will raise an OutputCompleteEvent in the application. In short, the same Service Object code can support both synchronous and asynchronous output without ever needing to know which output mode is being used.
Copy Code
using System;
using System.Collections.Generic;
using System.Text;
using System.Threading;
using Microsoft.PointOfService;
using Microsoft.PointOfService.BaseServiceObjects;

[assembly: PosAssembly("Service Object Contractors, Inc.")]

namespace SOSamples.AsyncOutput
{
    [ServiceObject(
          DeviceType.PosPrinter,
          "AsyncOutputPrinter",
          "Sample Async Printer",
          1,
          9)]

    public class AsyncOutputSimulator : PosPrinterBase
    {
        public AsyncOutputSimulator()
        {
            DevicePath = "Sample Async Printer";

            // Indicate that the Service Object supports
            // the receipt printer.
            Properties.CapRecPresent = true;
        }

        // Note that this method will be called by the POS for .NET
        // library code, regardless of whether the print request
        // is synchronous or asynchronous. The print request
        // queue is managed completely by POS for .NET so the
        // Service Object should simply write data to the device
        // here.
        protected override PrintResults PrintNormalImpl(
                        PrinterStation station,
                        PrinterState printerState,
                        string data)
        {
            // Your code to print to the actual hardware would go
            // here.

            // For demonstration, however, the code simulates
            // that fulfilling this print request took 4 seconds.
            Thread.Sleep(4000);

            PrintResults results = new PrintResults();
            return results;
        }

        // This method must be implemented by the Service
        // Object, and should validate the data to be printed,
        // including any escape sequences. This method should throw
        // a PosControlException to indicate failure.
        protected override void ValidateDataImpl(
                        PrinterStation station,
                        string data)
        {
            // Insert your validation code here.
            return;
        }

        #region Implement Abstract PosCommon Members
        private string MyHealthText = "";

        // PosCommon.CheckHealthText.
        public override string CheckHealthText
        {
            get
            {
                // VerifyState(mustBeClaimed,
                // mustBeEnabled).
                VerifyState(false, false);
                return MyHealthText;
            }
        }

        //  PosCommon.CheckHealth.
        public override string CheckHealth(
                        HealthCheckLevel level)
        {
            // Verify that device is open, claimed, and enabled.
            VerifyState(true, true);

            // Insert your code here:
            // check the health of the device and return a
            // descriptive string.

            // Cache result in the CheckHealthText property.
            MyHealthText = "Ok";
            return MyHealthText;
        }

        // PosCommon.DirectIOData.
        public override DirectIOData DirectIO(
                                int command,
                                int data,
                                object obj)
        {
            // Verify that the device is open.
            VerifyState(false, false);

            return new DirectIOData(data, obj);
        }
        #endregion Implement Abstract PosCommon Members
    }
}

The application code in the Event Handler Sample can be compiled and run with this Service Object.

See Also

Tasks

Event Handler Sample

Concepts

Event Management
Device Output Models

Other Resources

Developing a Custom Service Object


Statistics Sample

Statistics Sample |
 | See Also Example
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object >

1/18/2008

POS for .NET Service Objects continually track and update a number of device statistics for each connected device. The statistic tracking is accomplished using the DeviceStatistics class, which contains methods for resetting, retrieving, and updating statistics, as well as helper methods for creating statistics, incrementing statistics, and loading or saving statistics to or from XML file storage.

Statistics reporting in POS for .NET supports statistics stored in either hardware or software. Software-based statistics are stored in an XML statistics file, \Program Files\Common Files\Microsoft Shared\Point of Service\Statistics\PosDeviceStatistics.xml, and updated at a globally defined flush interval which is determined at the time of system installation and setup. By default, this flush interval is 1 second. When the application claims a device, POS for .NET loads the appropriate statistics from the XML file.

Device specific statistics management is supported by the Base or Basic device class interface. Service Objects inheriting from a Base or Basic class are typically only required to call IncrementStatistic, which increments the value of a specified statistic, or SetStatistic, which sets one statistic to a specified value. All other statistics implementation is provided by the Base or Basic class interface.

The key members of the DeviceStatistics class are detailed below:

  • CapStatisticsReporting identifies the statistics reporting capabilities of the device. When CapStatisticsReporting is set to false, no statistical data regarding the device is available. If CapStatisticsReporting is true, some statistical data is available, and the device may begin accumulating various statistics regarding usage. The information accumulated and reported is device-specific, and is retrieved using the RetrieveStatistics method.

  • CapUpdateStatistics defines whether the gathered statistics can be reset or updated by an application employing the UpdateStatistics and ResetStatistics methods. This property is only valid if CapStatisticsReporting is true. If CapStatisticsReporting is false, the CapUpdateStatistics property is always false.

  • ResetStatistics can only be called if both CapStatisticsReporting and CapUpdateStatistics are true. This method resets one, some, or all of the resettable device statistics to zero. It resets the defined resettable statistics in a device to zero. All the requested statistics must be successfully reset in order for this method to complete successfully. Otherwise, an error is thrown with the Extended ErrorCode method. This method is always executed synchronously.

  • UpdateStatistics sets one, some, or all of the resettable device statistics to the specified values. All the requested statistics must be successfully updated in order for this method to complete successfully. If some cannot be updated for any reason, an ErrorCode event is returned. Both CapStatisticsReporting and CapUpdateStatistics must be set to true to call this method. The UpdateStatistics method is always executed synchronously.

  • RetrieveStatistics retrieves the requested statistics from a device. CapStatisticsReporting must be true in order to successfully use this method. All calls to RetrieveStatistics will return the following XML as a minimum.

    Copy Code
    <?xml version='1.0'?>
<UPOSStat version="1.10.0"
xmlns:xsi=http://www.w3.org/2001/XMLSchema-instance
xmlns="http://www.nrf-arts.org/IXRetail/namespace/"
xsi:schemaLocation="http://www.nrf-arts.org/IXRetail/namespace/
UPOSStat.xsd">
   <Event>
      <Parameter>
         <Name>RequestedStatistic</Name>
         <Value>1234</Value>
      </Parameter>
   </Event>
   <Equipment>
   <UnifiedPOSVersion>1.10</UnifiedPOSVersion>
   <DeviceCategory UPOS="CashDrawer"/>
   <ManufacturerName>Cashdrawers R Us</ManufacturerName>
   <ModelName>CD-123</ModelName>
   <SerialNumber>12345</SerialNumber>
   <FirmwareRevision>1.0 Rev. B</FirmwareRevision>
   <Interface>RS232</Interface>
   <InstallationDate>2000-03-01</InstallationDate>
   </Equipment>
</UPOSStat>
    If the application requests a statistic name that the device does not support, the <Parameter> entry will be returned with an empty <Value>. For example:

    Copy Code
          <Parameter>
         <Name>RequestedStatistic</Name>
         <Value></Value>
      </Parameter>
    All statistics that the device collects that are manufacturer specific and not defined in the schema will be returned in a <ManufacturerSpecific> tag instead of a <Parameter> tag. For example:

    Copy Code
          <ManufacturerSpecific>
         <Name>TheAnswer</Name>
         <Value>42</Value>
      </ManufacturerSpecific>
    When an application requests all statistics from the device, the device returns a <Parameter> entry for every defined statistic in the device category. The device category is defined by the version of the XML schema specified by the version attribute in the <UPOSStat> tag. If the device does not record any statistics, the <Value> tag will be empty.

POS for .NET uses handlers to perform the reading and writing of statistics in a manner similar to the way events are handled. When one of these statistic handlers is created, it is assigned to a particular device statistic. When this statistic is read or updated, the handler calls a delegate that is able to read from or write to the device as necessary.

Statistic handlers use different types of delegates to perform different statistics operations. GetStatistic delegates are used to retrieve statistic values, while SetStatistic delegates assign statistic values. GetStatistics delegates take the name of the statistic to be retrieved as a parameter and return a string representing the value of that statistic. SetStatistic delegates take the name of the statistic to be changed and the value which is to be assigned to that statistic as parameters. SetStatistic delegates do not return any values.

Statistics handlers may be assigned to any of the standard statistics defined by the UPOS specification, but custom handlers for any statistics that are created using CreateStatistic by Service Object code are also supported.

Example

The following code example demonstrates how to enable, handle, and retrieve statistics data from an MSR device.
Copy Code
      // File FORM1.CS
using System;
using System.Collections.Generic;
using System.ComponentModel;
using System.Data;
using System.Drawing;
using System.Text;
using System.Windows.Forms;
using System.Xml;
using System.IO;

using Microsoft.PointOfService;
using Microsoft.PointOfService.BaseServiceObjects;

namespace Statistics
{
    public partial class SampleStatistics : Form
    {
        // Indicates whether or not the Service Object has
        // been started.
        bool ServiceObjectStarted = false;

        // The Service Object.
        PosCommon so = null;

        public SampleStatistics()
        {
            InitializeComponent();

            // Disable the buttons until the SO is loaded successfully.
            UpdateControls();
        }

        public void UpdateControls()
        {
            btnGenerateStatistics.Enabled = ServiceObjectStarted;
            btnRetrieveStatistics.Enabled = ServiceObjectStarted ;
            txtStatisticName.Enabled = ServiceObjectStarted;

            // The statistic name text box is disabled until the
            // Service Object is loaded.
            if (ServiceObjectStarted)
            {
                btnStartSO.Text = "Close SO";
            }
            else
            {
                txtStatisticName.Clear();
                txtRetrievedStatistics.Clear();
                btnStartSO.Text = "Start SO";
            }

            // The retrieve one statistic button is disabled until
            // the user has entered a statistic name.
            if (txtStatisticName.TextLength > 0)
            {
                btnRetreiveStatistic.Enabled = true;
            }
            else
            {
                btnRetreiveStatistic.Enabled = false;
            }
        }

        private void StartServiceObject(object sender, EventArgs e)
        {
            PosExplorer explorer = new PosExplorer(this);
            string SOName = "SampleStatistics";

            if (ServiceObjectStarted)
            {
                so.DeviceEnabled = false;
                so.Close();
                so = null;
                ServiceObjectStarted = false;
                UpdateControls();
            }
            else
            {
                foreach (DeviceInfo d in explorer.GetDevices())
                {
                    if (d.ServiceObjectName == SOName)
                    {
                        try
                        {
                            // Standard Service Object startup.
                            so = explorer.CreateInstance(d)
                                            as PosCommon;

                            so.Open();
                            so.Claim(0);
                            so.DeviceEnabled = true;

                            // Application-specific setup.
                            ServiceObjectStarted = true;
                            UpdateControls();
                        }
                        catch
                        {
                            // Something went wrong starting the SO
                            MessageBox.Show("The Service Object '" +
                                SOName + "' failed to load",
                                "Service Object Error",
                                MessageBoxButtons.OK,
                                MessageBoxIcon.Exclamation);
                            return;
                        }

                        break;
                    }
                }

                if (so == null)
                {
                    // No Service Object with the
                    // specified name could be found.
                    MessageBox.Show("The Service Object '" +
                        SOName + "' could not be found",
                        "Service Object Error",
                        MessageBoxButtons.OK,
                        MessageBoxIcon.Exclamation);
                }
            }
        }

        private void GenerateStatistics(object sender, EventArgs e)
        {
            // In this example case, you use this
            // property to tell the Service Object to change statistic
            // values.
            so.DeviceEnabled = true;

            // Report status.
            txtRetrievedStatistics.Text = "DeviceEnabled called to" +
                        " to modify statistic values.";
        }

        private void RetrieveStatistics(object sender, EventArgs e)
        {
            string statistics;
            bool IsXml = true;

            try
            {
                statistics = so.RetrieveStatistics();
            }
            catch
            {
                statistics = "No statistics found";
                IsXml = false;
            }

            DisplayStatistics(statistics, IsXml);
        }

        private void RetrieveOneStatistic(object sender, EventArgs e)
        {
            string statistics;
            bool IsXml = true;

            try
            {
                statistics = so.RetrieveStatistic(
                            txtStatisticName.Text);
            }
            catch
            {
                statistics = "Statistic not found: " +
                            txtStatisticName.Text;

                IsXml = false;
            }

            DisplayStatistics(statistics, IsXml);
            txtStatisticName.Clear();
            btnRetreiveStatistic.Enabled = false;
        }

        private void StatisticSizeChanged(object sender, EventArgs e)
        {
            if (txtStatisticName.TextLength > 0)
            {
                btnRetreiveStatistic.Enabled = true;
            }
            else
            {
                btnRetreiveStatistic.Enabled = false;
            }
        }

        // When retrieving statistics, POS for .NET returns a block
        // of XML (as specified in the UPOS specification). This
        // method will make it look readable with white space
        // and indenting and then display it in the text box.
        private void DisplayStatistics(string inputString, bool isXml)
        {
            string s = null;

            // In case of an exception, you do not have an XML
            // string, so just display the error description. Otherwise,
            // load the XML string into an XmlDocument object and
            // make it look readable.
            if (!isXml)
            {
                s = inputString;
            }
            if(isXml)
            {
                // Create new XML document and load the statistics
                // XML string.
                XmlDocument doc = new XmlDocument();
                doc.LoadXml(inputString);

                // Create a XmlTextWriter using a MemoryStream and
                // tell it to indent the XML output (so that it is
                // readable.)
                MemoryStream m = new MemoryStream();
                XmlTextWriter writer = new XmlTextWriter(m, null);
                writer.Formatting = Formatting.Indented;
                writer.Indentation = 4;

                // Save the document to the memory stream using the
                // XmlWriter.
                doc.Save(writer);

                // The stream will be encoded as UTF8, so convert the
                // buffer into a string.
                UTF8Encoding u = new UTF8Encoding();
                s = u.GetString(m.GetBuffer());
            }

            // Write the string to the text box.
            txtRetrievedStatistics.Text = s;
        }
    }
}
Copy Code
      // File FORM1.DESIGNER.CS
namespace Statistics
{
    partial class SampleStatistics
    {
        /// <summary>
        /// Required designer variable.
        /// </summary>
        private System.ComponentModel.IContainer components = null;

        /// <summary>
        /// Clean up any resources being used.
        /// </summary>
        /// <param name="disposing">true if managed resources should be disposed; otherwise, false.</param>
        protected override void Dispose(bool disposing)
        {
            if (disposing && (components != null))
            {
                components.Dispose();
            }
            base.Dispose(disposing);
        }

        #region Windows Form Designer generated code

        /// <summary>
        /// Required method for Designer support - do not modify
        /// the contents of this method with the code editor.
        /// </summary>
        private void InitializeComponent()
        {
            this.btnStartSO = new System.Windows.Forms.Button();
            this.btnGenerateStatistics = new System.Windows.Forms.Button();
            this.btnRetrieveStatistics = new System.Windows.Forms.Button();
            this.txtStatisticName = new System.Windows.Forms.TextBox();
            this.txtRetrievedStatistics = new System.Windows.Forms.TextBox();
            this.btnRetreiveStatistic = new System.Windows.Forms.Button();
            this.groupBox1 = new System.Windows.Forms.GroupBox();
            this.groupBox1.SuspendLayout();
            this.SuspendLayout();
            //
            // btnStartSO
            //
            this.btnStartSO.Location = new System.Drawing.Point(45, 35);
            this.btnStartSO.Name = "btnStartSO";
            this.btnStartSO.Size = new System.Drawing.Size(133, 23);
            this.btnStartSO.TabIndex = 0;
            this.btnStartSO.Text = "Start SO";
            this.btnStartSO.UseVisualStyleBackColor = true;
            this.btnStartSO.Click += new System.EventHandler(this.StartServiceObject);
            //
            // btnGenerateStatistics
            //
            this.btnGenerateStatistics.Location = new System.Drawing.Point(45, 75);
            this.btnGenerateStatistics.Name = "btnGenerateStatistics";
            this.btnGenerateStatistics.Size = new System.Drawing.Size(133, 23);
            this.btnGenerateStatistics.TabIndex = 1;
            this.btnGenerateStatistics.Text = "GenerateStatistics";
            this.btnGenerateStatistics.UseVisualStyleBackColor = true;
            this.btnGenerateStatistics.Click += new System.EventHandler(this.GenerateStatistics);
            //
            // btnRetrieveStatistics
            //
            this.btnRetrieveStatistics.Location = new System.Drawing.Point(45, 117);
            this.btnRetrieveStatistics.Name = "btnRetrieveStatistics";
            this.btnRetrieveStatistics.Size = new System.Drawing.Size(133, 23);
            this.btnRetrieveStatistics.TabIndex = 2;
            this.btnRetrieveStatistics.Text = "Retrieve Statistics";
            this.btnRetrieveStatistics.UseVisualStyleBackColor = true;
            this.btnRetrieveStatistics.Click += new System.EventHandler(this.RetrieveStatistics);
            //
            // txtStatisticName
            //
            this.txtStatisticName.Location = new System.Drawing.Point(16, 68);
            this.txtStatisticName.Name = "txtStatisticName";
            this.txtStatisticName.Size = new System.Drawing.Size(205, 20);
            this.txtStatisticName.TabIndex = 4;
            this.txtStatisticName.TextChanged += new System.EventHandler(this.StatisticSizeChanged);
            //
            // txtRetrievedStatistics
            //
            this.txtRetrievedStatistics.BackColor = System.Drawing.Color.White;
            this.txtRetrievedStatistics.Location = new System.Drawing.Point(45, 157);
            this.txtRetrievedStatistics.Multiline = true;
            this.txtRetrievedStatistics.Name = "txtRetrievedStatistics";
            this.txtRetrievedStatistics.ReadOnly = true;
            this.txtRetrievedStatistics.ScrollBars = System.Windows.Forms.ScrollBars.Both;
            this.txtRetrievedStatistics.Size = new System.Drawing.Size(476, 247);
            this.txtRetrievedStatistics.TabIndex = 5;
            //
            // btnRetreiveStatistic
            //
            this.btnRetreiveStatistic.Location = new System.Drawing.Point(16, 30);
            this.btnRetreiveStatistic.Name = "btnRetreiveStatistic";
            this.btnRetreiveStatistic.Size = new System.Drawing.Size(133, 23);
            this.btnRetreiveStatistic.TabIndex = 6;
            this.btnRetreiveStatistic.Text = "Retrieve Statistic";
            this.btnRetreiveStatistic.UseVisualStyleBackColor = true;
            this.btnRetreiveStatistic.Click += new System.EventHandler(this.RetrieveOneStatistic);
            //
            // groupBox1
            //
            this.groupBox1.Controls.Add(this.btnRetreiveStatistic);
            this.groupBox1.Controls.Add(this.txtStatisticName);
            this.groupBox1.Location = new System.Drawing.Point(219, 35);
            this.groupBox1.Name = "groupBox1";
            this.groupBox1.Size = new System.Drawing.Size(302, 105);
            this.groupBox1.TabIndex = 7;
            this.groupBox1.TabStop = false;
            this.groupBox1.Text = "Single Statistic";
            //
            // SampleStatistics
            //
            this.AutoScaleDimensions = new System.Drawing.SizeF(6F, 13F);
            this.AutoScaleMode = System.Windows.Forms.AutoScaleMode.Font;
            this.BackColor = System.Drawing.SystemColors.MenuBar;
            this.ClientSize = new System.Drawing.Size(565, 439);
            this.Controls.Add(this.groupBox1);
            this.Controls.Add(this.txtRetrievedStatistics);
            this.Controls.Add(this.btnRetrieveStatistics);
            this.Controls.Add(this.btnGenerateStatistics);
            this.Controls.Add(this.btnStartSO);
            this.Name = "SampleStatistics";
            this.Text = "Form1";
            this.groupBox1.ResumeLayout(false);
            this.groupBox1.PerformLayout();
            this.ResumeLayout(false);
            this.PerformLayout();

        }

        #endregion

        private System.Windows.Forms.Button btnStartSO;
        private System.Windows.Forms.Button btnGenerateStatistics;
        private System.Windows.Forms.Button btnRetrieveStatistics;
        private System.Windows.Forms.TextBox txtStatisticName;
        private System.Windows.Forms.TextBox txtRetrievedStatistics;
        private System.Windows.Forms.Button btnRetreiveStatistic;
        private System.Windows.Forms.GroupBox groupBox1;
    }
}
Copy Code
      // File STATISTICSSO.CS
using System;
using System.Collections.Generic;
using System.Text;

using Microsoft.PointOfService;
using Microsoft.PointOfService.BaseServiceObjects;

[assembly: PosAssembly("Service Object Contractors, Inc.")]

namespace SOSamples.Statistics
{
    [ServiceObject(DeviceType.Msr,
        "SampleStatistics",
        "Sample Statistics Service Object",
        1,
        9)]

    public class StatisticsTest : MsrBase
    {
        // This will be incremented every time DeviceEnabled
        // is set so that different sets of demonstration
        // statistics can be generated.
        int enableCount = 0;

        // The name of a custom created statistic used to demonstrate
        // custom Statistic handlers.
        private const string PollingStatistic = "Polling Interval";

        // Statistic used to demonstrate IncrementStatistic.
        private const string TestIncrement = "MyIncrementableStat";

        // String returned from CheckHealth
        private string MyHealthText;

        public StatisticsTest()
        {
            DevicePath = "Sample Statistics";
        }

        // This is the delegate which will be called for each
        // statistic that we have associated with this delegate by
        // calling SetStatisticHandler().
        //
        // Delegates like this should most commonly be used
        // to get and set statistics in hardware. The delegate
        // allows the POS for .NET statistic subsystem to query
        // the value of a statistic in real time, before it is
        // returned to the application.
        private string GetHardwareInfo(string name)
        {
            // Add your code to query values from hardware here.

            // Very simple demonstration: just return the name
            // of the statistic as its value;
            return name;
        }

        // In a typical Service Object implementation, statistics
        // will be modified throughout the Service Object code. This
        // method demonstrates the methods used to modify statistic
        // values.
        public void SetDemonstrationStatistics()
        {
            // IncrementStatistic can be used to easily
            // increment a numeric statistic.
            IncrementStatistic(TestIncrement);

            switch(enableCount)
            {
                case 0:
                    SetStatisticValue(StatisticManufacturerName,
                        "Microsoft Corporation");
                    break;
                case 1:
                    SetStatisticValue(StatisticManufacturerName,
                        "Service Control Contractors, Inc.");
                    break;
                case 2:
                    SetStatisticValue(StatisticManufacturerName,
                        "Point of Service Controls .com");
                    break;
            }

            if (++enableCount == 3 )
            {
                enableCount = 0;
            }
        }

        #region PosCommon overrides
        // Returns the result of the last call to CheckHealth()

        public override void Open()
        {
            base.Open();

            // In your implementation of Open(), your Service Object
            // code should:
            //    1. Initialize statistics.
            //    2. Create custom statistics.
            //    3. Set statistic handlers for hardware Statistics.

            // 1. Initialize statistics
            SetStatisticValue(StatisticManufacturerName,
                            "Microsoft Corporation");
            SetStatisticValue(StatisticManufactureDate,
                            "2004-10-23");
            SetStatisticValue(StatisticModelName,
                            "Statistic Sample");
            SetStatisticValue(StatisticMechanicalRevision,
                            "1.0");
            SetStatisticValue(StatisticInterface,
                            "USB");

            // 2a. Create a new new statistic to test Increment
            // method. No custom handler needed.
            CreateStatistic(TestIncrement, false, "blobs");

            // 2b. Create a new manufacturer statistic to demonstrate
            // custom attributes with StatisticHandlers.
            CreateStatistic(PollingStatistic, false,
                            "milliseconds");

            // 3. Set handlers for statistics stored in hardware.
            SetStatisticHandlers(PollingStatistic,
                        new GetStatistic(GetHardwareInfo), null);
            SetStatisticHandlers(StatisticSerialNumber,
                        new GetStatistic(GetHardwareInfo), null);
        }

        public override bool DeviceEnabled
        {
            get
            {
                return base.DeviceEnabled;
            }
            set
            {
                // This method will set various statistics to
                // demonstrate the statistic APIs. We are going
                // to change statistic values every time the device
                // is enabled. This operation is just for
                // demonstration and would not be found in live code.
                SetDemonstrationStatistics();

                base.DeviceEnabled = value;
            }
        }

        public override string CheckHealthText
        {
            get
            {
                // MsrBasic.VerifyState(musBeClaimed,
                // mustBeEnabled). This may throw an exception
                VerifyState(false, false);

                return MyHealthText;
            }
        }

        public override string CheckHealth(
                        HealthCheckLevel level)
        {
            // Verify that device is open, claimed, and enabled.
            VerifyState(true, true);

            // Your code here:
            // check the health of the device and return a
            // descriptive string.

            // Cache result in the CheckHealthText property.
            MyHealthText = "Ok";
            return MyHealthText;
        }

        public override DirectIOData DirectIO(
                        int command,
                        int data,
                        object obj)
        {
            // Verify that the device is open.
            VerifyState(false, false);

            return new DirectIOData(data, obj);
        }
        #endregion  PosCommon overrides

        #region MsrBasic Overrides
        protected override MsrFieldData ParseMsrFieldData(
                        byte[] track1Data,
                        byte[] track2Data,
                        byte[] track3Data,
                        byte[] track4Data,
                        CardType cardType)
        {
            // Your code here:
            // Implement this method to parse track data
            // into fields which will be returned as
            // properties to the application (e.g.,FirstName,
            // AccountNumber, etc.)
            return new MsrFieldData();
        }

        protected override MsrTrackData ParseMsrTrackData(
                        byte[] track1Data,
                        byte[] track2Data,
                        byte[] track3Data,
                        byte[] track4Data,
                        CardType cardType)
        {
            // Your code here:
            // Implement this method to convert raw track data.
            return new MsrTrackData();
        }
        #endregion MsrBasic Overrides
    }
}

Compiling the Code

  • For additional information about creating and compiling a Service Object project, see Service Object Samples: Getting Started.

See Also

Other Resources

Developing a Custom Service Object
System Configuration


Base Class DirectIO Method

Base Class DirectIO Method |
 | See Also
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object >

1/18/2008

The DirectIO method and the DirectIOEvent event are used to provide functionality to the application that is not otherwise supported by the standard UPOS specification for a particular device type.

DirectIO Method

If a device has features that are not supported by the standard UPOS specification, a Service Object may implement a DirectIO method to give the application access to those features.

An example might be a LineDisplay device that supports multicolor output. Few, if any, LineDisplay-type devices support color output, but an independent hardware vendor (IHV) might produce such a device and want to have the new features available to applications.

Use of this method will make the application nonportable, since the implementation of the DirectIO method is vendor-specific. An application that uses a DirectIO method on Vendor A's LineDisplay device cannot depend on using a Vendor B's device.

DirectIOEvent

This event can be used to send vendor-specific information directly to the application. This event provides a means for a vendor-specific UPOS service to provide events to the application that are not otherwise supported by the UPOS control.

Using this event will make an application incompatible with devices from other vendors.

See Also

Other Resources

Developing Service Objects Using Base Classes


Capability Properties

Capability Properties |
 | See Also
POS for .NET v1.12 SDK Documentation > Developing a Custom Service Object >

1/18/2008

Certain properties cannot be set directly within a Service Object. This comes up most often in the case of capability properties; those with the Cap prefix in their names. According to the UPOS specification, these properties must be read-only; therefore, an implementation-specific mechanism is needed for the Service Object to change the value of these properties.

BaseClass Properties

POS for .NET Base classes have a protected property, Properties, for this purpose. This property returns a helper class which has writable versions of the read-only properties implemented in the Base class. For example, PinPadBase has a property called Properties that returns an object of type PinPadProperties. And this object contains properties used to set various PinPad-specific capability properties, such as CapDisplay.

PosCommon Properties

In addition to device-specific property classes, all POS for .NET Base and Basic classes also have a protected property called CommonProperties which returns an object of type CommonProperties. This helper class is used to modify capability and status properties found in PosCommon.

Setting Properties Using Helper Classes

In general, a Service Object should always access the value of its common and class-specific properties using the helper classes. These properties may be written to by the Service Object and always contain the appropriate values.

The Service Object developer should be aware of what the POS for .NET framework may do when a particular value is changed. For example, the Service Object should generally not change CommonProperties.State since this may interfere with the POS for .NET internal state. Similarly, the Service Object developer should be aware that changing CommonProperties.PowerState may send a StatusUpdateEvent event to the application.

Note:
When deriving from the POS for .NET Base or Basic classes, the Service Object should generally not change the value of CommonProperties.State to ControlState.Closed. Doing so prevents cleanup of the event queue, and POS for .NET may later throw exceptions as it tries to process events already in the queue.

See Also

Reference

PinPadProperties
StatusUpdateEventHandler


POS Device Manager

POS Device Manager
POS for .NET v1.12 SDK Documentation >

1/18/2008

With Windows Embedded for Point of Service (WEPOS), you can manage your POS devices in various ways, including:

  • Adding and deleting POS devices from computers (non-Plug and Play devices only).

  • Listing POS devices and/or Service Objects for particular computers.

  • Configuring a WEPOS Service Object (SO) to run for a particular device port (non-Plug and Play devices only).

  • Setting a default device for a POS device class.

  • Preventing a Service Object from running for a device.

  • Assigning a logical name by which a POS application can access the Service Object for a device.

POS devices are managed via a Windows Management Instrumentation (WMI) provider installed on the POS device host as part of the WEPOS installation. Instructions in this Guide assume that you have already installed WEPOS.

You can access this WMI provider through the WMI API or by using the command-line tool included in WEPOS, POSDM.EXE.

In This Section

Changing Windows Firewall Settings to Enable Remote Device Management

Describes how you can manage devices remotely through your firewall.

Using the WMI API to Manage Devices

Describes how to use WMI tools to manage your POS devices.

Using Visual Studio .NET Management Extensions and the WEPOS WMI Management Classes

Describes how to use Visual Studio and the WEPOS WMI management classes with your POS devices.

Using the POS Device Manager Command-Line Tool

Demonstrates how to use the POSDM command line to enable remote device management.

Related Sections

POS for .NET v1.12 Features

Provides a high-level overview of the POS for .NET architecture.

Developing a POS Application

Outlines POS for .NET key concepts and features that are useful to programmers developing POS applications.

Developing a Custom Service Object

Demonstrates how to create POS for .NET applications which use Service Objects to communicate with hardware devices.


Changing Windows Firewall Settings to Enable Remote Device Management

Changing Windows Firewall Settings to Enable Remote Device Management |
 | See Also
POS for .NET v1.12 SDK Documentation > POS Device Manager >

1/18/2008

The default Windows Firewall settings require you to enable remote administration before you can use POS Device Manager to manage your POS devices. To enable this functionality, you can use the following:

  • The command netsh firewall set service RemoteAdmin as described in Using the Command Line to Enable Remote Management.

    -or-

  • A script to enable the Windows Firewall remote administration feature.

In This Section

Using the Command Line to Enable Remote Management

Demonstrates how to use the POSDM command line to enable remote device management.

See Also

Other Resources

POS Device Manager
Using the POS Device Manager Command-Line Tool


Using the Command Line to Enable Remote Management

Using the Command Line to Enable Remote Management |
 | See Also
POS for .NET v1.12 SDK Documentation > POS Device Manager > Changing Windows Firewall Settings to Enable Remote Device Management >

1/18/2008

The following command line enables remote management of devices:

Copy Code
netsh firewall set service RemoteAdmin
Note:
After the first boot of the newly installed WEPOS, the Windows Firewall service is not running. To turn it on, you must either restart the operating system or start the Windows Firewall service. You can start the Windows Firewall service from the command line or from the Control Panel.

To start from the command line

  • Type net start sharedaccess and then press ENTER.

To start from the Control Panel

  • Click Administrative Tools, click Component Services, click Services, and then click Windows Firewall and choose options in the dialog box.

See Also

Other Resources

Using the POS Device Manager Command-Line Tool
Changing Windows Firewall Settings to Enable Remote Device Management


Using the WMI API to Manage Devices

Using the WMI API to Manage Devices |
 | See Also
POS for .NET v1.12 SDK Documentation > POS Device Manager >

1/18/2008

The WMI provider serves a WMI namespace called /root/MicrosoftPointOfService. This namespace defines four classes:

  • ServiceObject Class

  • PosDevice Class

  • LogicalDevice Class

  • DeviceProperty Class

ServiceObject represents a POS for .NET Service Object from a management perspective. PosDevice represents the physical device serviced by the Service Object. LogicalDevice represents a logical name assigned to a PosDevice, providing third-party applications with the ability to access a Service Object without conflicting with other applications that may also be accessing the same Service Object. DeviceProperty instances are name/value pairs that can be associated with a PosDevice to store optional configuration data for Service Objects.

In This Section

ServiceObject Class

Lists the properties and methods of the ServiceObject Class.

PosDevice Class

Lists the properties and methods of the PosDevice Class.

LogicalDevice Class

Lists the properties and methods of the LogicalDevice Class.

DeviceProperty Class

Lists the properties and methods of the DeviceProperty Class.

Using VBScript to Manage Devices

Demonstrates how to programmatically manage devices using the WMI API.

See Also

Other Resources

POS Device Manager


ServiceObject Class

ServiceObject Class |
 | See Also
POS for .NET v1.12 SDK Documentation > POS Device Manager > Using the WMI API to Manage Devices >

1/18/2008

The ServiceObject class represents the management view of a Service Object.

Properties

Name | Description
Name | Represents the name of the Service Object in string format.
Type | Represents the type of the POS device class that is implemented by the Service Object.
UposVersion | Represents version of the UPOS standard that the Service Object is implementing in string format.
Path | Represents the path of the Service Object’s assembly as a string.
Version | The version number of the Service Object’s assembly in string format.
Compatibility | The major version of POS for .NET with which the Service Object is compatible.
Description | A short string describing the Service Object.
IsPlugNPlay | A Boolean indicator of whether the Service Object supports Plug and Play.
IsLegacy | A Boolean indicator of whether the device is using a legacy (OPOS) Service Object.

Methods

Name | Description
AddDevice | Adds a non-Plug and Play device for this Service Object. Accepts one string parameter, Path, which is the hardware path of the non-Plug and Play device to add. There is no return value.
DeleteDevice | Deletes a non-Plug and Play device associated with this Service Object. Accepts one string parameter, Path, which is the hardware path of the non-Plug and Play device to delete. There is no return value.

See Also

Tasks

Using VBScript to Manage Devices

Other Resources

Using the WMI API to Manage Devices


PosDevice Class

PosDevice Class |
 | See Also
POS for .NET v1.12 SDK Documentation > POS Device Manager > Using the WMI API to Manage Devices >

1/18/2008

The PosDevice class represents a single physical POS device. The class provides properties and methods that are needed to manage that physical device.

Properties

Name | Description
Type | String representation of the POS device type or category.
SoName | The name of the Service Object for this physical device, in string format.
Path | The hardware path of a device, in string format. For Plug and Play devices, this path comes from the Plug and Play engine. For non-Plug and Play devices, it is provided via the AddDevice method of ServiceObject. For devices using legacy (OPOS) Service Objects, this may be blank.
HardwareDescription | The device description of the logical device, returned from the registry in string format and used by the Plug and Play engine. This may be blank for devices using legacy (OPOS) Service Objects.
IsPlugNPlay | A Boolean indicator of whether the device supports Plug and Play.
IsLegacy | A Boolean indicator of whether the device is using a legacy (OPOS) Service Object.
Enabled | A Boolean representation of whether the device is enabled or not. This property allows write access.
Default | A Boolean representation of whether the device is the default device in a POS device category. This property allows write access.

Methods

Name | Description
AddName | Adds a logical name for the device. Accepts one string parameter, Name, which is the name of the logical device to add. The name must be unique within a device class (type). There is no returned value. Logical names are represented by the LogicalDevice class.
Deletename | Deletes the logical name from the device. Accepts one string parameter, Name, which is the name of the logical device to delete. There is no returned value. Logical names are represented by the LogicalDevice class.
AddProperty | Adds a property (a name/value pair) to this device. Accepts two string parameters, Name, which is the name of the property, and Value, which is the value of the property. There is no returned value. Device properties are represented by the Property class.
DeleteProperty | Deletes a property from this device. Accepts one string parameter, Name, which is the name of the property to be deleted. There is no return value. Device properties are represented by the Property class.

See Also

Tasks

Using VBScript to Manage Devices

Other Resources

Using the WMI API to Manage Devices


LogicalDevice Class

LogicalDevice Class |
 | See Also
POS for .NET v1.12 SDK Documentation > POS Device Manager > Using the WMI API to Manage Devices >

1/18/2008

The LogicalDevice class represents a logical device associated with a PosDevice. It provides a naming mechanism so that applications can be developed independently and refers to the same device without conflict.

Properties

Name | Description
Type | String representing the POS device category that the logical device belongs to.
SoName | String representing the name of the Service Object.
Path | String representing the path of the physical device.
Name | String representing the name for the logical device.

See Also

Tasks

Using VBScript to Manage Devices

Other Resources

Using the WMI API to Manage Devices


DeviceProperty Class

DeviceProperty Class |
 | See Also
POS for .NET v1.12 SDK Documentation > POS Device Manager > Using the WMI API to Manage Devices >

1/18/2008

The DeviceProperty class represents a name/value pair of a configuration property for a physical device. There may be multiple DeviceProperty classes associated with a PosDevice.

Properties

Name | Description
Type | String representing the POS device category.
SoName | String representing the name of the Service Object.
Path | String representing the path of the physical device.
Name | String representing the name of this property.
Value | String representing the data of this property.

See Also

Tasks

Using VBScript to Manage Devices

Concepts

PosDevice Class

Other Resources

Using the WMI API to Manage Devices


Using VBScript to Manage Devices

Using VBScript to Manage Devices |
 | See Also Example
POS for .NET v1.12 SDK Documentation > POS Device Manager > Using the WMI API to Manage Devices >

1/18/2008

Using the WMI API documented in this section, it is possible to manage devices using managed code or scripting. POSDM.EXE is a command-line interface to this API. This VBScript sample does the following:

  • It uses the WMI method ExecQuery to retrieve a list of installed PosDevice objects. With this list of Service Objects, the script displays their type, name, corresponding path, and their enabled or disabled status. This is analogous to running the following command:

    Copy Code
    PosDM.exe LISTDEVICES
  • It then attempts to assign the path COM1 to the installed Service Object, Microsoft Msr Simulator using the AddDevice method. This is equivalent to running:

    Copy Code
    PosDM.exe ADDDEVICE COM1 /SONAME:Microsoft Msr Simulator
  • If the AddDevice method fails, the script catches the error and assumes that COM1 may have already been added to the device and therefore attempts to delete it by calling DeleteDevice. This is equivalent to running:

    Copy Code
    PosDM.exe DELETEDEVICE COM1
  • If the AddDevice method had previously failed, the script then attempts to call AddDevice again. The program exits if the method fails.

  • Finally, the sample attempts to add the logical name MSRSim to this Service Object by calling AddName. This is equivalent to running:

    Copy Code
    PosDM.exe ADDNAME MSRSim /SONAME:"Microsoft Msr Simulator"

It is possible to see the results of this sample by running:

Copy Code
PosDM.exe LISTDEVICES

And

Copy Code
PosDM.exe LISTNAMES

To run the sample

  1. The Service Object Microsoft Msr Simulator was installed with the SDK. Be sure that it is installed on the computer which you will be using to run the sample.

  2. Copy this script to a file PosDMSample.vbs

  3. Execute the script with the following command line:

    Copy Code
    CScript //U PosDMSample.vbs

Example

Copy Code
'Get a handle to the POS namespace service into 'objServices'.
Set objLocator = CreateObject("WbemScripting.SWbemLocator")
Set objServices = objLocator.ConnectServer(, "/root/MicrosoftPointOfService")

'List the POS devices.
EnumeratePosDevice

'Add a name: MSRSim for Msr Simulator by retrieving the SO and invoking AddDevice() then AddName()
WScript.Echo "Add Device on COM1 and add name 'MSRSim' for MsrSimulator ..."
Set objSO = objServices.Get("ServiceObject.Type='Msr',Name='Microsoft Msr Simulator'")

On Error Resume Next
objSO.AddDevice "COM1"
if Err.number <> 0 Then
  WScript.Echo "AddDevice failed - it already is in use."
  WScript.Echo "Try to delete the device..."

  On Error Resume Next
  objSO.DeleteDevice "COM1"
  if Err.number <> 0 Then
    WScript.Echo "DeleteDevice failed"
    WScript.Quit 1
  end if

  WScript.Echo "DeleteDevice succeeded! Attempting AddDevice again..."

  On Error Resume Next
  objSO.AddDevice "COM1"
  if Err.number <> 0 Then
     WScript.Echo "AddDevice failed a second time - exiting"
     WScript.Quit 2
  end if
end if

Set objDevice = objServices.Get("PosDevice.SoName='Microsoft Msr Simulator',Type='Msr',Path='COM1'")
objDevice.AddName "MSRSim"
Set objDevice = GetDevice("Msr", "MSRSim")
WScript.Echo "Added 'MSRSim' to: " & objDevice.Type & vbTab & objDevice.SoName & vbTab & objDevice.Path

'Enumerate the sClass by name
Sub EnumeratePosDevice( )
  sClass = "PosDevice"
  WScript.Echo "Enumerating " & sClass & "..." & vbCrLf

  Set collection = objServices.ExecQuery("SELECT * From " & sClass)
  For Each obj In collection
   Enabled = "DISABLED"
   if obj.Enabled = true Then
     Enabled = "ENABLED"
   end If
     WScript.Echo obj.Type & Space(15-len(obj.type)) & obj.SoName & Space(35-len(obj.SoName)) & Enabled & vbTab & obj.Path
  Next
  WScript.Echo vbCrLf
End Sub

'Return a PosDevice matching DeviceType and Name.
Function GetDevice( DeviceType, Name )
  Set Logical = GetLogicalDevice( DeviceType, Name )
  objectPath = "PosDevice.SoName='" & Logical.SoName & "',Type='" & DeviceType & "',Path='" & Logical.Path & "'"
  Set GetDevice = objServices.Get(objectPath)
End Function

'Return a LogicalDevice matching DeviceType and Name.
Function GetLogicalDevice( DeviceType, Name )
  Query = "SELECT * From LogicalDevice WHERE Type = '" & DeviceType & "' AND Name='" & Name & "'"
  Set collection = objServices.ExecQuery( Query )
  For Each obj In collection
    Set GetLogicalDevice = obj
    exit For
  Next
End Function

If the path COM1 has not been assigned to a device, the sample produces output similar to this code.

Copy Code
Microsoft (R) Windows Script Host Version 5.6
Copyright (C) Microsoft Corporation 1996-2001. All rights reserved.

Enumerating PosDevice...

Msr            Microsoft Msr Simulator            ENABLED
Msr            Microsoft Msr Simulator            ENABLED       COM1
Keylock        Microsoft Keylock Simulator        ENABLED
Scanner        Microsoft Scanner Simulator        ENABLED
CashDrawer     Microsoft CashDrawer Simulator     ENABLED
CheckScanner   Microsoft CheckScanner Simulator   ENABLED
LineDisplay    Microsoft LineDisplay Simulator    ENABLED
PinPad         Microsoft PinPad Simulator         ENABLED
PosPrinter     Microsoft PosPrinter Simulator     ENABLED
PosKeyboard    Microsoft PosKeyboard Simulator    ENABLED

Add Device on COM1 and add name 'MSRSim' for MsrSimulator ...
AddDevice failed - it already be in use.
Try to delete the device...
DeleteDevice succeeded! Attempting AddDevice again...
Added 'MSRSim' to: Msr  Microsoft Msr Simulator

If the path COM1 is already in use and no other error occurs, the script produces output that looks like this code.

Copy Code
Microsoft (R) Windows Script Host Version 5.6
Copyright (C) Microsoft Corporation 1996-2001. All rights reserved.

Enumerating PosDevice...

Msr            Microsoft Msr Simulator            ENABLED
Msr            Microsoft Msr Simulator            ENABLED       COM1
Keylock        Microsoft Keylock Simulator        ENABLED
Scanner        Microsoft Scanner Simulator        ENABLED
CashDrawer     Microsoft CashDrawer Simulator     ENABLED
CheckScanner   Microsoft CheckScanner Simulator   ENABLED
LineDisplay    Microsoft LineDisplay Simulator    ENABLED
PinPad         Microsoft PinPad Simulator         ENABLED
PosPrinter     Microsoft PosPrinter Simulator     ENABLED
PosKeyboard    Microsoft PosKeyboard Simulator    ENABLED

Add Device on COM1 and add name 'MSRSim' for MsrSimulator ...
AddDevice failed - it already be in use.
Try to delete the device...
DeleteDevice succeeded! Attempting AddDevice again...
Added 'MSRSim' to: Msr  Microsoft Msr Simulator

See Also

Other Resources

Using the WMI API to Manage Devices
POS Device Manager


Using Visual Studio .NET Management Extensions and the WEPOS WMI Management Classes

Using Visual Studio .NET Management Extensions and the WEPOS WMI Management Classes |
 | See Also Example
POS for .NET v1.12 SDK Documentation > POS Device Manager >

1/18/2008

A Visual Studio extension called Management (WMI) Extensions for Visual Studio .NET 2003 Server Explorer adds management services to the Server Explorer in Visual Studio .NET. Using this extension, you can navigate the Microsoft.PointOfService namespace and drag the instances of the classes onto your project’s Class Designer.

This feature requires Microsoft Visual Studio .NET 2003 and the Windows Embedded for Point of Service (WEPOS) runtimes to be installed on the local development computer. You can learn more about Management Extensions for Visual Studio at this Microsoft Web .

To use the extension

  1. Launch Visual Studio .NET 2003 and open the Server Explorer window.

  2. Expand the Servers node, and then expand the Machine node.

  3. Right-click the Management Classes node and then click Add Classes on the shortcut menu.

  4. In the Add Classes dialog box, expand the root\MicrosoftPointOfService node in the Available Classes tree view.

  5. Select the DeviceProperty class, and then click Add to add the class to the Server Explorer. Repeat this step for the LogicalDevice, PosDevice, and ServiceObject classes.

To use the management classes

  1. Create a .NET project.

  2. Open the Server Explorer.

  3. Right-click the DeviceProperty node, and then click Generate Managed Class on the shortcut menu to add the generated class to the project. Repeat this step for the LogicalDevice, PosDevice, and ServiceObject classes to generate managed classes.

To use an instance of a management class

  1. In the Server Explorer, expand the desired class to list the available class objects.

  2. Drag the instances onto the projects class designer.

Example

The following code example demonstrates the use of the PosDevice class GetInstances method to enumerate Point of Service devices. It creates a collection of the devices within a scope. It then lists the type, name and path for each device in the collection and indicates whether the device is enabled or disabled.
Copy Code
using System;
using System.Management;
using ROOT.MICROSOFTPOINTOFSERVICE;

namespace Management
{
   public class Test
   {
      public Test()
      {
         ManagementScope scope = new ManagementScope("root\\microsoftpointofservice");
         scope.Connect();
         PosDevice.PosDeviceCollection devices = PosDevice.GetInstances(scope, "");
         string format = "{0,10}\t{1,25}\t{2}\t{3,50}";
         if( devices.Count > 0 )
            Console.WriteLine(format, "Type", "Name", "Enabled", "Path");
         foreach( PosDevice d in devices )
         {
            Console.WriteLine(format, d.Type, d.SoName, d.Enabled ? 'Y' : 'N', d.Path);
         }
      }

      static int Main()
      {
         Test t = new Test();
         return 0;
      }
   }
}

An alternative to using the GUI to create your wrapper is to use the command-line tool called mgmtClassGen.exe. This tool will generate a .NET class wrapper for classes in a WMI namespace. This feature requires Microsoft Visual Studio .NET 2003 and the Microsoft WEPOS runtimes to be installed on the local development machine. The tool is found in the \Microsoft Visual Studio .NET 2003\SDK\v1.1\Bin folder.

Using this tool, you can create a .NET class for the WMI root/microsoftpointofservice/PosDevice class as follows:

mgmtClassGen.exe /n root/microsoftpointofservice /l cs PosDevice

This command creates the C# class in a file called PosDevice.cs in the current directory. Create a C# command-line project and add the PosDevice.cs file to the project. Compile the following C# code against it. This code simply enumerates the PosDevice classes on the local computer.

Note:
Before you run this sample on Windows XP Professional or Windows Embedded for Point of Service, you must install the .NET Framework v1.1 SP1

See Also

Reference

PosCommon

Other Resources

POS Device Manager
Using the POS Device Manager Command-Line Tool
Using the WMI API to Manage Devices


Using the POS Device Manager Command-Line Tool

Using the POS Device Manager Command-Line Tool |
 | See Also
POS for .NET v1.12 SDK Documentation > POS Device Manager >

1/18/2008

To use the POS Device Manager Command-Line Tool after Windows Embedded for Point of Service has been installed on your computer, and after the Windows Firewall settings have been changed as described in Changing Windows Firewall Settings to Enable Remote Device Management.

On the command line, type posdm followed by a space and then any of the commands and switches listed below.

The general syntax is:

posdm [general switches] command [command arguments]

In This Section

Command-Line Help for POSDM

Demonstrates how to access Help about POSDM syntax, usage, and commands.

General POSDM Switches

Describes several commonly used POSDM command-line switches.

POSDM Commands

Provides a comprehensive list of the commands that you can use in POSDM.

POSDM Command Arguments

Describes several switches that can be used as arguments in POSDM.

See Also

Other Resources

Changing Windows Firewall Settings to Enable Remote Device Management
POS Device Manager


Command-Line Help for POSDM

Command-Line Help for POSDM |
 | See Also
POS for .NET v1.12 SDK Documentation > POS Device Manager > Using the POS Device Manager Command-Line Tool >

1/18/2008

You can display information about the general usage and syntax for POSDM.EXE by typing the following on the command line:

Copy Code
posdm /?

To get more information about any POSDM command, type the following on the command line:

Copy Code
posdm help command

Example:

Copy Code
posdm help listdevices

See Also

Concepts

POSDM Commands

Other Resources

Using the POS Device Manager Command-Line Tool


General POSDM Switches

General POSDM Switches |
 | See Also
POS for .NET v1.12 SDK Documentation > POS Device Manager > Using the POS Device Manager Command-Line Tool >

1/18/2008

The following general switches may be used between POSDM and a command on the command line.

Switch | Description
/? | Displays posdm Help information.
/output:file | Prints all output to file instead of to the console.
/machine:host | Uses host as the remote computer. Default is the local computer.
/user:username | Uses user name as the user account. Prefix with domain separated by a backslash if the user domain is not the current one.
/password:password | Uses password with the specified user name account.

See Also

Concepts

POSDM Commands

Other Resources

Using the POS Device Manager Command-Line Tool


POSDM Commands

POSDM Commands |
 | See Also
POS for .NET v1.12 SDK Documentation > POS Device Manager > Using the POS Device Manager Command-Line Tool >

1/18/2008

POSDM uses the following commands.

Command

Description

Syntax and Examples

adddevice

Adds a physical non-Plug and Play device.

posdm [general switches] adddevice path filter [/info]

where path is a hardware path of the physical device,

filter is one or more of the following:

/type:devicetype

/soname:soname

and

/info is a switch that displays all device properties.

Example:

posdm adddevice COM3 /soname:MsrSimulator

This adds a device with the hardware path COM3 to the MsrSimulator Service Object.

addname

Adds a logical name to a device.

posdm [general switches] addname devicename filter

where devicename is the logical name to give to the device, and filter is one or more of the following needed to uniquely identify a device:

/type:devicetype

/soname:soname

/path:hardware_path

/name:devicename

Example:

posdm addname MainMSR /type:MSR /path:COM3

This adds the logical name MainMSR for the MSR device on the COM3 hardware path.

posdm addname BackupMSR /name:MainMSR

This adds the logical name BackupMSR for the device named MainMSR.

addproperty

Adds a configuration property to a device.

posdm [general switches] addproperty propertyname value filter [/info]

where propertyname is the name of the property and value is the initial value for that property, and filter is one or more of the following needed to uniquely identify a device:

/type:devicetype

/soname:soname

/path:hardware_path

/name:devicename

/info is a switch that displays all device properties.

Example:

posdm addproperty PrintSpecialGreeting "Happy New Year!" /name:MainMSR

This adds the PrintSpecialGreeting property with the value of "Happy New Year!" to the device named MainMSR.

deletedevice

Deletes a physical non-Plug and Play device.

posdm [general switches] deletedevice [path] filter

where filter is one or more of the following needed to uniquely identify a device:

/type:devicetype

/soname:soname

/path:hardware_path

Example:

posdm deletedevice COM3 /type:Msr

This deletes the MSR device on COM3.

Only devices previously added by the adddevice command can be deleted.

deletename

Deletes a logical name from a device's list of names.

posdm [general switches] deletename devicename filter [/info]

where filter is one or more of the following needed to uniquely identify a device:

/type:devicetype

/soname:soname

/path:hardware_path

/name:devicename

and

/info is a switch that displays all device properties.

Example:

posdm deletename "Main Scanner" /type:Scanner /path:COM3

This deletes the logical name Main Scanner for the scanner device on the COM3 path.

Only logical names previously added by the addname command can be deleted.

deleteproperty

Deletes a configuration property from a device.

posdm [general switches] deleteproperty propertyname filter [/info]

where filter is one or more of the following needed to uniquely identify a device:

/type:devicetype

/soname:soname

/path:hardware_path

/name:devicename

and

/info is a switch that displays all device properties.

posdm deleteproperty PrintSpecialGreeting /name:MainMSR

This deletes the PrintSpecialGreeting property from the device named MainMSR.

Only configuration properties previously added by the addproperty command can be deleted.

disable

Prevents a Service Object from running for a physical POS device.

posdm [general switches] disable filter

where filter is one or more of the following needed to uniquely identify a device:

/type:devicetype

/soname:soname

/path:hardware_path

/name:devicename

Example:

posdm disable /name:ReceiptPrn

This prevents a Service Object from running for a device named ReceiptPrn. As a result, applications will not see the device in the list of available POS devices.

enable

Permits a Service Object to run for a physical POS device.

posdm [general switches] enable filter

where filter is one or more of the following needed to uniquely identify a device:

/type:devicetype

/soname:soname

/path:hardware_path

/name:devicename

Example:

posdm enable /type:MSR

This permits a Service Object to run for all MSR devices.

info

Displays information about the device, including its configuration properties.

posdm [general switches] info filter

where filter is one or more of the following needed to uniquely identify a device:

/type:devicetype

/soname:soname

/path:hardware_path

/name:devicename

Example:

posdm info /name:MSR1

This command displays information about a device with the logical name "MSR1."

listdevices

Lists the physical POS devices.

posdm [general switches] listdevices [/type: devicetype]

where the /type: devicetype switch narrows the list to a particular type of device.

Examples:

posdm listdevices

This displays a list of all physical POS devices installed on the local computer.

posdm listdevices /type:MSR

This displays a list of all MSR devices installed on the local computer.

posdm /machine:Center10 /username:JohnDoe3 /password:B$tg59ce listdevices

This lists all physical POS devices installed on the computer named Center10, after logging on with username and password credentials.

listnames

Lists the logical names associated with POS devices.

posdm [general switches] listnames filter

where filter is one or more of the following needed to uniquely identify a device:

/type:devicetype

/soname:soname

/path:hardware_path

Example:

posdm listnames /type:MSR /path:COM3

This displays a list of names associated with the MSR device on COM3.

listprops

Lists the configuration properties associated with a POS device and their values.

posdm [general switches] listprops filter

where filter is one or more of the following needed to uniquely identify a device:

/type:devicetype

/soname:soname

/path:hardware_path

/name:devicename

Example:

posdm listprops /type:MSR /path:COM3

This displays a list of property names and values associated with the MSR device on COM3.

listsos

Lists the POS Service Objects on the target machine.

posdm [general switches] listsos [/type: devicetype]

where the /type: devicetype switch narrows the list to a particular type of device.

Examples:

posdm /output:a:\solist.txt listsos

This writes a list of all Service Objects installed on the local computer to a file named solist.txt on drive A.

posdm listsos /type:MSR

This displays a list of all Service Objects associated with MSR devices on the local computer.

posdm /machine:Center10 /username:JohnDoe3 /password:B$tg59ce listsos

This lists all Service Objects on the computer named Center10, after logging on with username and password credentials.

setdefault

Sets one device as the default of its type.

The default flag directs the PosExplorer.GetDevice(type) method to return this device even if there is more than one device of the type available.

posdm [general switches] setdefault ON|OFF filter [/info]

where filter is one or more of the following needed to uniquely identify a device:

/type:devicetype

/soname:soname

/path:hardware_path

/name:devicename

The /info switch causes all device properties to be displayed.

Example:

posdm setdefault ON /name:FirstScanner

This example designates FirstScanner as the one the CCL device enumeration will find.

setpath

Sets the POS device path for non-Plug and Play devices.

posdm [general switches] setpath hardware_path filter

where filter is one or more of the following needed to uniquely identify a device:

/type:devicetype

/soname:soname

/path:hardware_path

/name:devicename

Example:

posdm setpath COM2 /type:MSR

This sets the hardware path for MSR devices to COM2.

The setpath command works only for non-Plug and Play devices previously added with the adddevice command.

See Also

Concepts

POSDM Command Arguments
Command-Line Help for POSDM

Other Resources

Using the POS Device Manager Command-Line Tool


POSDM Command Arguments

POSDM Command Arguments |
 | See Also
POS for .NET v1.12 SDK Documentation > POS Device Manager > Using the POS Device Manager Command-Line Tool >

1/18/2008

The following switches can be used as arguments for POSDM commands.

Command Switch

Description

/type:devicetype

The device type as determined by the Service Object supplier.

Example: /type:msr specifies a magnetic strip reader.

/soname:soname

The Service Object name from the Service Object supplier. Names containing spaces must be enclosed in double quotation marks (").

Example: /soname:"Super MSR" specifies a Service Object named Super MSR.

/path:hardware_path

The hardware path for the device.

Example: /path:COM2 specifies a location of COM2.

/name:devicename

The logical name for the device. This is useful when there are multiple instances of the Service Object, and also provides a way for an application to refer to a Service Object without hard coding. This name must be unique within devicetype. If a name contains a space, it must be contained within double quotation marks (" ").

Examples: /name:msr4 refers to a device with the logical name msr4, /name:"Main MSR" refers to a device with the logical name of Main MSR.

See Also

Concepts

POSDM Commands

Other Resources

Using the POS Device Manager Command-Line Tool


Class Library

Class Library
1/18/2008

Namespaces

Namespace
Microsoft.PointOfService
Microsoft.PointOfService.BaseServiceObjects


Microsoft.PointOfService Namespace

Microsoft.PointOfService Namespace
1/18/2008

Classes

Class | Description
Belt | Defines the programmatic interface for a UPOS Belt Device.
BillAcceptor | Defines the programmatic interface for a UPOS Bill Acceptor device.
BillDispenser | Defines the programmatic interface for a UPOS Bill Dispenser device.
Biometrics | Defines the programmatic interface for a UPOS Biometrics device.
BiometricsInformationRecord | Represents the Biometrics data that is returned to the application from a Biometrics device.
BiometricsVerifyResult | Defines the programmatic interface that is used for verifying biometrics data.
BumpBar | Defines the programmatic interface for a UPOS Bump Bar device.
CashChanger | Defines the programmatic interface for a UPOS Cash Changer device.
CashDrawer | Defines the programmatic interface for a UPOS Cash Drawer device.
Cat | Defines the programmatic interface for a UPOS credit authorization terminal (CAT) device.
CheckScanner | Defines the programmatic interface for a UPOS Check Scanner device.
CoinAcceptor | Defines the programmatic interface of a UPOS Coin Acceptor device.
CoinDispenser | Defines the programmatic interface for a UPOS Coin Dispenserdevice.
DataEventArgs | Defines the programmatic interface for the transmission of Data Events.
Device | Defines the programmatic interface for a Device.
DeviceChangedEventArgs | Defines the programmatic interface for the transmission of Device Added Events and Device Removed Events.
DeviceCollection | Defines an indexed array of DeviceInfo objects.
DeviceErrorEventArgs | Defines the programmatic interface for the transmission of Device Error Events.
DeviceInfo | Defines a programmatic interface for device information that is used to create a service object.
DevicePlugAndPlay | Defines the programmatic interface for the DevicePlugAndPlay class.
DeviceStatusChangedEventArgs | Defines the programmatic interface for the transmission of Device Status Changed Events.
DeviceType | Defines 28 constants, each representing a POS device.
DirectIOEventArgs | Defines the programmatic interface for the transmission of Direct IO Events.
DisplayScreenMode | Defines a screen mode—that is, the number of rows and columns supported—for a line display device.
ElectronicJournal | Defines the programmatic interface for an Electronic Journal device.
ElectronicValueRW | Defines the programmatic interface for an Electronic Value Reader/Writer (R/W) device.
FiscalPrinter | Defines the programmatic interface for a UPOS fiscal printer device.
Gate | Defines the programmatic interface for a UPOS Gate device.
HardTotals | Defines the programmatic interface for a UPOS hard totals device.
HardwareIdAttribute | Defines a class containing a range of hardware Ids supported by a service object.
ImageScanner | Defines the programmatic interface for a UPOS Image Scanner device.
ItemDispenser | Defines the programmatic interface for an Item Dispenser device.
Keylock | Defines the programmatic interface for a UPOS keylock device.
Lights | Defines the programmatic interface for a Light device.
LineDisplay | Defines the programmatic interface for a UPOS Line Display device.
Logger | Defines an event log file structure to which programs can write informational or programmatic warning or error events.
Micr | Defines the programmatic interface for a UPOS magnetic ink character recognition (MICR) device.
MotionSensor | Defines the programmatic interface for a UPOS Motion Sensor device.
Msr | Defines the programmatic interface for a UPOS magnetic stripe reader (MSR) device.
Msr.AamvaCardProperties | Contains the different properties that can be accessed for AAMVA cards.
Msr.BankCardProperties | Contains the properties that can be accessed from the bank card.
OutputCompleteEventArgs | Defines the programmatic interface for the transmission of Output Complete Events.
PinPad | Defines the programmatic interface for a UPOS PIN pad device.
PointCardRW | Defines the programmatic interface for a UPOS Point Card Reader/Writer device.
PosAssemblyAttribute | Defines an assembly attribute that can be attached as metadata to a .dll, identifying that assembly as a POS for .NET service object.
PosCommon | Defines the programmatic interface for constants, properties, methods, and events common to all UPOS devices.
PosControlException | Defines the programmatic interface for exceptions thrown by service objects.
PosDevice | Defines the programmatic interface that represents a generic POS device. The PosCommon class inherits from the PosDevice class.
PosEventArgs | Defines the base class for POS for .NET classes containing event data.
PosException | Defines the programmatic interface for a generic exception in the POS for .NET system. All other exception classes inherit from PosException.
PosExplorer | Defines the programmatic interface for enumeration and initialization of POS installed devices.
PosKeyboard | Defines the programmatic interface for a UPOS Keyboard device.
PosLibraryException | Defines the programmatic interface used by PosExplorer class to throw exceptions.
PosManagementException | Defines the programmatic interface used by POS for .NET management APIs to throw exceptions.
PosPower | Defines the programmatic interface for a UPOS power system device.
PosPrinter | Defines the programmatic interface for a UPOS Printer device.
RangeOfCharacters | Defines a helper class that can be used to create an array representing custom glyphs for a Line Display device.
RemoteOrderDisplay | Defines the programmatic interface for a remote order display.
RFIDScanner | Defines the programmatic interface for an RFID Scanner device.
Scale | Defines the programmatic interface for a UPOS scale device.
Scanner | Defines the programmatic interface for a UPOS Scanner device.
ServiceObjectAttribute | Defines a class-level attribute that can be used to identify the service object that implements the class.
SignatureCapture | Defines the programmatic interface for a UPOS signature capture device.
SmartCardRW | Defines the programmatic interface for a UPOS smart card reader/writer device.
Statistic | Defines the programmatic interface used to create an array, or list, of device statistics.
StatusUpdateEventArgs | Defines the programmatic interface for the transmission of Status Update Events.
ToneIndicator | Defines the programmatic interface for a UPOS Tone Indicator device.

Interfaces

Interface | Description
IDeviceEnumeration | Defines the interface to enumerate devices.
IDeviceEnumerationPnp | Defines the interface to enumerate Plug and Play devices.
ILegacyControlObject | Defines the interface to access a legacy OPOS control object.

Structures

Structure | Description
CashCount | Represents an individual count of a particular type of currency for a Cash Changer or Bill Dispenser device.
CashCounts | Defines a programmatic structure used to create an array representing the total cash in a Cash Changer device.
CashUnits | Holds arrays of bill and coin types for use in POS devices such as Cash Changers and Bill Dispensers.
DirectIOData | Defines the programmatic structure the service object uses to return data to an application.
EVRWResult | Holds the structured return value for methods in the ElectronicValueRW class.
FiscalDataItem | Defines the programmatic structure used by the service object to return a fiscal data item from a Fiscal Printer device.
PointCardReadWriteStates | Defines a programmatic structure used by the service object to communicate write or read state information for a Point Card Reader Writer device during an error condition.
PointCardReceiveLengths | Defines a programmatic structure used by the service object to communicate the length of track data for a Point Card Reader Writer device.
ServiceIndex | Allows the extraction of information from Cash Changer subservices.
TotalsFileInfo | Defines the programmatic structure used by the service object to identify the current totals file for the application.
VatInfo | Defines the programmatic structure used to build a list of adjustments for value added tax (VAT) information.
VideoMode | Defines the programmatic structure used by the service object to build an array of video modes supported by each online video unit.

Delegates

Delegate | Description
DataEventHandler | Defines the method that handles the DataEventArgs event.
DeviceChangedEventHandler | Defines the method that handles the DeviceChangedEventArgs event.
DeviceErrorEventHandler | Defines the method that handles DeviceErrorEventArgs events.
DeviceStatusChangedEventHandler | Defines the method that handles the DeviceStatusChangedEventHandler event.
DirectIOEventHandler | Defines the method that handles a DirectIOEventArgs events.
OutputCompleteEventHandler | Defines the method that will handle a OutputCompleteEventArgs events.
StatusUpdateEventHandler | Defines the method that will handle a StatusUpdateEventArgs events.

Enumerations

Enumeration | Description
BarCodeSymbology | Enumerates the valid bar code symbol types.
BarCodeTextPosition | Enumerates possible placements for the readable character string of a bar code.
BeginDetectionType | Enumerates the card detection process.
BeltDirection | Enumerates the belt direction.
BeltMotionStatus | Enumerates possible values of the current motion state of the device.
BinaryConversion | Enumerates the possible binary conversion methods for legacy controls.
BirDataTypes | Enumerates the possible types of data that the BiometricsInformationRecord (BIR) class can hold.
BirPurpose | Enumerates the possible purpose for gathering the biometrics information.
BorderType | Enumerates the possible types of borders to display.
CapSensorColors | Enumerates the possible image formats that the device supports.
CapSensorOrientations | Enumerates the possible degrees of rotation of the sensor image prior to processing.
CapSensorTypes | Enumerates the types of biometrics data that can be captured by the attached sensor.
CardDetectionControl | Enumerates whether the application or the reader/writer can control the detection processing, ejection processing, or storing processing of the card.
CardDetectionTypes | Enumerates the types of card detection.
CashChangerFullStatus | Enumerates values that describe the full status of cash slots in a Cash Changer device.
CashChangerStatus | Enumerates possible current status values for the CashChanger class.
CashCountType | Enumerates the possible types of cash, bill or coin.
CashDepositAction | Enumerates the possible ways to deal with deposited cash.
CashDepositPause | Enumerates two possible values, Pause and Resume, for a cash acceptance operation.
CashDepositStatus | Enumerates the possible current status values of the cash acceptance operation.
CatLogs | Enumerates the available log functions for a credit authorization terminal (CAT) device.
CharacterSetCapability | Enumerates the possible default character sets for a printer, line display, or point card reader/writer device.
CheckColors | Enumerates the possible image format color ranges for a check scanner.
CheckCountryCode | Enumerates the possible countries/regions in which the check originated.
CheckImageClear | Enumerates the possible values for how an image file is to be located.
CheckImageFormats | Enumerates the possible formats of a data image file.
CheckImageLocate | Enumerates the possible values for how an image file is to be retrieved from memory.
CheckType | Enumerates the valid check types for the most recently read Magnetic Ink Character Recognition (MICR) data.
ClockFunction | Enumerates valid clock commands.
ClockMode | Enumerates the valid display formats for the clock.
CoinDispenserStatus | Enumerates the valid states of the coin dispenser device.
CompareFirmwareResult | Enumerates the valid comparison results between firmware files.
ControlState | Enumerates the valid states of a device.
CreditTransactionType | Enumerates the valid transaction types for an authorization operation.
DealingLogStatus | Enumerates the possible status conditions of the Dealing Log for a CAT device.
DepositStatus | Enumerates possible deposit status values.
DetectionState | Enumerates the state of card detection.
DeviceAuthenticationLevel | Enumerates the level of device authentication supported by the service.
DeviceAuthenticationProtocol | Enumerates the device authentication protocol supported by the device.
DeviceCompatibilities | Enumerates the valid compatibility levels for a POS device.
DeviceUnits | Enumerates the valid unit IDs of a single video unit for a Bump Bar or Remote Order Display device.
DisplayBlink | Enumerates the valid line display blink capabilities for a Line Display device.
DisplayCursors | Enumerates the possible supported cursor types.
DisplayMarqueeFormat | Enumerates the possible marquee format values.
DisplayMarqueeType | Enumerates the valid marquee type values.
DisplayReadBack | Enumerates the possible read back capability values.
DisplayReverse | Enumerates the possible reverse video capability values.
DisplayScrollText | Enumerates the possible scrolling directions.
DisplaySetDescriptor | Enumerates the possible display descriptor attributes.
DisplayTextMode | Enumerates the possible text mode values.
EftTransactionCompletion | Enumerates possible completion values for an EFT transaction.
EftTransactionType | Enumerates the possible EFT transaction types.
ElectronicJournalStations | Enumerates the station for subsequent data storing into the medium.
EncryptionAlgorithm | Enumerates the encryption algorithms supported by the device.
EndDepositAction | Enumerates a value that indicates that the cash acceptance operation has been completed.
ErrorCode | Enumerates the valid types of errors for an error event.
ErrorLocus | Enumerates possible times when an error occurred.
ErrorResponse | Enumerates the valid responses an application can make to an error event.
FiscalAdjustment | Enumerates the valid types of fiscal adjustments.
FiscalAdjustmentType | Enumerates the valid types of package adjustments.
FiscalContractorId | Enumerates the valid contractors to whom the receipt and/or some items of the receipt can be assigned.
FiscalCountryCodes | Enumerates the valid countries/regions supported by the fiscal printer.
FiscalCurrency | Enumerates the valid currencies for a fiscal printer.
FiscalData | Enumerates the valid data items that can be retrieved from a Fiscal Printer.
FiscalDateType | Enumerates the valid types of dates that can be supported by the fiscal printer.
FiscalErrorLevel | Enumerates the valid severity levels for an error condition on a fiscal printer.
FiscalMessageType | Enumerates all possible fiscal message types.
FiscalPrinterState | Enumerates the possible printer operational states that can be reported for a fiscal printer.
FiscalPrinterStations | Enumerates the possible fiscal printer stations that can be set to print or reported as printing during the occurrence of an error.
FiscalReceiptStation | Enumerates the valid fiscal printer stations that can be used to start non-fiscal fixed text printing.
FiscalReceiptType | Enumerates the valid types of receipts for a fiscal printer.
FiscalSlipSelection | Enumerates two document types—full-length and validation—to be printed.
FiscalTotalizer | Enumerates the possible types of totalizers for a fiscal printer.
FiscalTotalizerType | Enumerates the possible types of totalizers.
FrameType | Enumerates the possible types of information contained within the Image Scanner's FrameData property.
GateStatus | Enumerates the status of the Gate.
HealthCheckLevel | Enumerates the possible types of health checks to be performed on a device.
ImageMemoryStatus | Enumerates the availability status values for image memory.
ImageMode | Enumerates the possible modes of operation that an Image Scanner device can use.
ImageQuality | Enumerates the level of image quality supported by the Image Scanner device.
ItemDispenserStatus | Enumerates the status of the ItemDispenser.
KeyboardEventType | Enumerates the possible type of keyboard events that the application will receive.
KeyEvent | Enumerates the possible types for the most recent key event.
KeylockType | Lists the possible keylock device types.
LightAlarms | Enumerates the different alarms supported by the Light device.
LightColors | Enumerates the supported colors for the Light device.
LogState | Enumerates the state of the transaction log.
MapMode | Lists the valid units of measure for Printer, Check Scanner, and Point Card Reader Writer devices.
MarkerType | Lists the possible marker types.
MsrErrorReporting | Lists the error reporting types for an MSR device.
MsrTracks | Lists the possible combinations of track data to be read.
PageModeDescriptors | Lists the valid page mode functions of the printer for the selected PageModeStation.
PageModePrintControl | Lists the valid Page Mode controls for a print station.
PageModePrintDirection | Lists the possible print directions that can be set for a print station.
PaymentCondition | Lists the valid payment conditions for an authorization operation.
PaymentMedia | Lists the valid payment media types for an approval method.
PinEntryStatus | Lists the possible PIN entry status values.
PinPadDisplay | Lists the possible ways in which an application can use the PIN pad’s display.
PinPadLanguage | Lists language characteristics for predefined prompt messages of the PIN pad device.
PinPadMessage | Lists the possible prompt messages for the PIN pad device.
PinPadSystem | Enumerates the possible PIN pad management systems to use.
PointCardAreas | Lists the valid parts of the point card that can be cleared.
PointCardReadWriteState | Lists valid track states for a Point Card Reader Writer.
PointCardRWTracks | Enumerates the possible tracks to read from or write to.
PointCardState | Enumerates the possible card states the point card device can be in.
PowerNotification | Enumerates the possible states of power notification for the current device.
PowerReporting | Enumerates the possible power reporting capabilities of a device.
PowerSource | Enumerates possible current power sources for a device.
PowerState | Enumerates the possible current power state values for a device.
PrinterCartridgeNotify | Enumerates the possible cartridge-state notification capabilities for a printer.
PrinterCartridgeSensors | Enumerates the possible printer-cartridge-monitoring sensors.
PrinterCartridgeStates | Enumerates the possible printer cartridge states.
PrinterColors | Enumerates the possible printer color cartridges.
PrinterErrorLevel | Enumerates the possible severity levels for the most recent error condition.
PrinterLogoLocation | Enumerates the possible locations for setting a logo.
PrinterMarkFeeds | Enumerates the possible kinds of mark-sensed paper handling.
PrinterSide | Enumerates possible sides of the print station document on which printing can occur.
PrinterStation | Enumerates the possible printer station modes.
PrinterTransactionControl | Enumerates the possible transaction modes for a printer station.
PrintRotation | Enumerates the possible rotation settings for a printer device.
RemoteOrderDisplayEventTypes | Lists the possible event types for touch video input on a Remote Order Display device.
RemoteOrderDisplayTransaction | Lists the possible transaction control functions for a Remote Order Display device.
ReportType | Lists all report types used in POS for .NET.
RFIDProtocols | Enumerates the available predefined RFID tag protocols the device supports.
RFIDReadOptions | Enumerates the tags within range that meet a parameterized criteria.
Rotation | Lists the possible bitmap and bar code rotations for printing.
SensorColor | Lists the image capture modes for available biometric capture operations.
SensorOrientation | Indicates the requested orientation adjustment to the received sensor data prior to BiometricsInformationRecord creation.
SensorType | Lists the possible types of data that the Biometrics Scanner may be designed to capture.
SmartCardInterfaceModes | Lists the possible communication modes for Smart Card devices.
SmartCardIsoEmvModes | Lists the valid message standards for a Smart Card device.
SmartCardReadAction | Lists the possible types of processing of the data that is to be done by the smart card.
SmartCardTransmissionProtocols | Lists the possible types of transmission protocols for a Smart Card device.
SmartCardWriteAction | Lists the possible types of processing of the data that is to be done by the smart card.
StatisticCategories | Lists the possible categories of device statistics that can be retrieved, reset, or updated.
StatusNotify | Lists the possible scale weight notification capabilities a service object can use for a Scale device.
SystemStateChangeReason | Lists the possible actions an application can allow for a PosPower device.
TransactionControl | Enumerates the transaction mode.
TransactionLogType | Enumerates the transaction log type.
UpsChargeStates | Lists the possible UPS charge states for a PosPower device.
VideoAttributeCommand | Lists the possible video region attibutes for a Remote Order Display device.
VideoAttributes | Lists the possible foreground and background colors, and blinking and intensity attributes of a video display on a Remote Order Display device.
VideoCursorType | Lists the possible video cursor types for a Remote Order Display device.
WeightUnit | Lists the valid weight units for a Scale device.
WriteTagSections | Enumerates the writable fields in the tag.


BarCodeSymbology Enumeration

BarCodeSymbology Enumeration |
 | See Also

1/18/2008

Enumerates the valid bar code symbol types.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration BarCodeSymbology
public enum BarCodeSymbology
public enum class BarCodeSymbology
public enum BarCodeSymbology
public enum BarCodeSymbology

Members

Member name | Description
Aztec | Aztec
Cca | Composite Component A--up to 56 characters of data
Ccb | Composite Component B--up to 338 characters of data
Ccc | Composite Conponent C--up to 2361 characters of data
Codabar | CodaBar
Code128 | Code 128
Code128Parsed | Code 128 with parsing
Code39 | Code 39
Code93 | Code 93
DataMatrix | DataMatrix
Ean128 | EAN-128
Ean13S | EAN-13
Ean8S | EAN-8
EanJan13 | EAN/JAN-13
EanJan8 | EAN/JAN-8
Itf | Interleaved 2 of 5
Maxicode | Maxicode
MicroPDF417 | MicroPDF417
MicroQRCode | MicroQRCode
Ocra | OCRa
Ocrb | OCRb
Other | If greater than or equal to this type, the service object has returned an undefined symbology
Pdf417 | PDF417
QRCode | QRCode
Rss14 | Reduced space symbology
RssExpanded | Reduced space symbology - expanded
TF | Standard (or discrete) 2 of 5
Unknown | The service object cannot determine the barcode symbology
Upca | UPC-A
Upcas | UPC-A with supplemental barcode
Upcd1 | UPC 1-digit supplement
Upcd2 | UPC 2-digit supplement
Upcd3 | UPC 3-digit supplement
Upcd4 | UPC 4-digit supplement
Upcd5 | UPC 5-digit supplement
Upce | UPC-E
Upces | UPC-E with supplemental barcode

Remarks

Used by the PrintBarCode method of the PosPrinter class; also used by the ScanDataType property of the Scanner class. Replaces the PTR_BCS_et al constants from UPOS.

See Also

Reference

Microsoft.PointOfService Namespace


BarCodeTextPosition Enumeration

BarCodeTextPosition Enumeration |
 | See Also

1/18/2008

Enumerates possible placements for the readable character string of a bar code.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration BarCodeTextPosition
public enum BarCodeTextPosition
public enum class BarCodeTextPosition
public enum BarCodeTextPosition
public enum BarCodeTextPosition

Members

Member name | Description
Above | Indicates to print the text above the bar code.
Below | Indicates to print the text below the bar code.
None | Indicates that no text is printed. Only prints the bar code.

Remarks

Used by the PrintBarCode method. Replaces the PTR_BC_TEXT_NONE, PTR_BC_TEXT_ABOVE, and PTR_BC_TEXT_BELOW constants from UPOS.

See Also

Reference

Microsoft.PointOfService Namespace
PrintBarCode


BeginDetectionType Enumeration

BeginDetectionType Enumeration |
 | See Also

1/18/2008

Enumerates the card detection process.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration BeginDetectionType
public enum BeginDetectionType
public enum class BeginDetectionType
public enum BeginDetectionType
public enum BeginDetectionType

Members

Member name | Description
Any | The content of the detected card can be anything.
Specific | When this method is called, only the card that corresponds to the identifier in the MediumId property can be detected.

Remarks

Supports the both contact IC card devices and those that do not have contacts.

When called, the device starts a card detection process, and starts the card detection in the device. This method is called together with the EndDetection method that ends the card detection process.

If the device cannot be set to the detection process, an error exception will be raised such as Timeout. However, the device stays in the detection mode until the EndDetection method is called.

If the timeout parameter value is zero, the method initiates the detection mode immediately. If a value is set (in milliseconds), the card detection process waits for this time period if necessary. If a value of WaitForever is specified, the method initiates the card detection process and then waits as long as necessary until either the card is detected or an error occurs. The type parameter specifies the type of the detected card.

See Also

Reference

Microsoft.PointOfService Namespace


Belt Class

Belt Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a UPOS Belt Device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class Belt
    Inherits PosCommon
public abstract class Belt : PosCommon
public ref class Belt abstract : public PosCommon
public abstract class Belt extends PosCommon
public abstract class Belt extends PosCommon

Remarks

Required Version

The Belt class requires POS for .NET version 1.12 or later versions.

Capabilities

The Belt class supports the following methods to do the following:

  • Move the belt in forward direction.

  • Stop and reset the belt.

The Belt class may support several additional methods. These enable moving in backward direction, moving with different speeds, light barriers, security flap, controlling an automatic stop, and emergency stop. See the "General Model" section and the capabilities properties for specific information.

General Model

The general model of a Belt class is as follows:

  • After the belt is enabled, an application can call the MoveForward and StopBelt methods to control the motion.

  • If the CapMoveBackward property is true, the application may also call the MoveBackward method. The CapSpeedStepsBackward and CapSpeedStepsForward properties define how many speed steps the belt motor supports in backward and forward direction.

  • Because of safety regulations, a belt is usually equipped with security flaps at the end of the belt at both ends, if it can move backward. The CapSecurityFlapBackward and CapSecurityFlapForward properties indicate whether a device has a backward and forward security flap.

  • The P:Microsoft.PointOfService.Belt.CapAutoStopBackward and CapAutoStopForward properties indicate whether a belt supports an automatic motor stop in backward and forward direction.

  • Whether the application wants to use this feature can be controlled by setting the AutoStopBackward and AutoStopForward properties. The belt is stopped if an automatic stop condition is true. Usually such a condition is controlled by light barriers. However, it can also correspond to an internal state of the device which is not exposed. The condition is device-specific and has to be explained in the device documentation.

  • Light barriers may be available for handling an automatic stop feature. The CapLightBarrierBackward and CapLightBarrierForward properties indicate whether a device has a backward and forward light barrier.

  • If the CapAutoStopForwardItemCount property is true, the application may control the automatic stop feature depending on several items passing the light barrier or any other item counting mechanism in forward direction by calling the AdjustItemCount and ResetItemCount methods. In this case, the belt is automatically stopped if the AutoStopForwardItemCount property is zero and an additional item is detected. This feature may be also available for backward direction.

  • If the CapAutoStopForward property is true, an application may also delay automatic stop in forward direction by setting the AutoStopForwardDelayTime property. The delay time starts when an automatic stop condition becomes true. The belt is stopped when the delay time has expired. During delay time, automatic stop is canceled if the automatic stop condition becomes false. This feature may be also available for backward direction.

  • The application is informed about any status change with a StatusUpdateEvent event. All corresponding status properties are updated before event delivery.

  • An emergency stop occurs if one of the security flaps is open or the operator presses an emergency button. In this case, technical help is needed and the application has to reset the belt by calling the ResetBelt method. A security stop occurs if the belt has been stopped because of safety requirement regulations, but no technical help is needed.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.Belt
Microsoft.PointOfService.BasicServiceObjects.BeltBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Belt Members
Microsoft.PointOfService Namespace


Belt Members

Belt Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a UPOS Belt Device.

The following tables list the members exposed by the Belt type.

Protected Constructors

Name | Description
Belt | Creates an instance of the Belt class.
Top

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusAutoStop | Indicates that the belt has stopped automatically.
StatusEmergencyStop | Indicates that the belt has stopped caused by an emergency condition, either a security flap is open or an emergency button has been pressed.
StatusLightBarrierBackwardInterrupted | Indicates that the belt has stopped for safety reasons.
StatusLightBarrierBackwardOk | Indicates that the light barrier in backward direction is no longer interrupted.
StatusLightBarrierForwardInterrupted | Indicates that the light barrier in forward direction is interrupted.
StatusLightBarrierForwardOk | Indicates that the light barrier in forward direction is no longer interrupted.
StatusMotorFuseDefect | Indicates that the belt has stopped due to a defective fuse.
StatusMotorOverheating | Indicates that the belt has stopped due to a motor overheating.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusSafetyStop | Indicates that the belt has stopped for safety reasons.
StatusSecurityFlapBackwardClosed | Indicates that the security flap in backward direction is closed.
StatusSecurityFlapBackwardOpened | Indicates that the security flap in backward direction is open.
StatusSecurityFlapForwardClosed | Indicates that the security flap in forward direction is closed.
StatusSecurityFlapForwardOpened | Indicates that the security flap in forward direction is open.
StatusTimeoutStop | Indicates that the belt has stopped due to a hardware time-out protecting the motor against overheating.
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
AutoStopBackward | Gets or sets the Boolean value that indicates whether the belt may automatically stop in backward direction.
AutoStopBackwardDelayTime | Gets or sets a delay time for an automatic stop of the belt in backward direction.
AutoStopBackwardItemCount | Gets the item counter for an automatic stop of the belt in backward direction.
AutoStopForward | Gets or sets the Boolean value that indicates whether the belt may automatically stop in forward direction.
AutoStopForwardDelayTime | Gets or sets a delay time in milliseconds for an automatic stop in forward direction.
AutoStopForwardItemCount | Gets the actual item counter for an automatic stop in forward direction.
CapAutoStopBackward | Gets the Boolean value that indicates whether a device supports an automatic motor stop in backward direction.
CapAutoStopBackwardItemCount | Gets the Boolean value that indicates whether a device supports an automatic motor stop in backward direction depending on item count.
CapAutoStopForward | Gets the Boolean value that indicates whether a device supports an automatic motor stop in forward direction.
CapAutoStopForwardItemCount | Gets the Boolean value that indicates whether a device supports an automatic motor stop in forward direction depending on item count.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapLightBarrierBackward | Gets the Boolean value that indicates whether a device has a backward light barrier.
CapLightBarrierForward | Gets the Boolean value that indicates whether a device has a forward light barrier.
CapMoveBackward | Gets the Boolean value that indicates whether a belt can move backward.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapSecurityFlapBackward | Gets the Boolean value that indicates whether a device has a backward security flap.
CapSecurityFlapForward | Gets the Boolean value that indicates whether a device has a forward security flap.
CapSpeedStepsBackward | Gets the integer value for how many speed steps the belt motor supports in backward direction.
CapSpeedStepsForward | Gets the integer value for how many speed steps the belt motor supports in forward direction.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
LightBarrierBackwardInterrupted | Gets the Boolean value that indicates whether the light barrier in backward direction is interrupted.
LightBarrierForwardInterrupted | Gets the Boolean value that indicates whether the light barrier in forward direction is interrupted.
MotionStatus | Gets the current motion state of the device.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
SecurityFlapBackwardOpened | Gets the Boolean value that indicates whether the security flap in backward direction is open.
SecurityFlapForwardOpened | Gets the Boolean value that indicates whether the security flap in forward direction is open.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether the Belt is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
AdjustItemCount | Indicates the direction of a belt and adjusts the item count accordingly.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
MoveBackward | Starts the belt motor to move backward with the specified speed.
MoveForward | Starts the belt motor to move forward with the specified speed.
Open | Opens a device for later input/output processing. (inherited from PosCommon)
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetBelt | Resets the belt after an emergency stop caused by an open security flap or a pressed emergency button.
ResetItemCount | Resets the item counter of the belt direction.
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
StopBelt | Stops the belt motor.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

Belt Class
Microsoft.PointOfService Namespace


Belt Fields

Belt Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusAutoStop | Indicates that the belt has stopped automatically.
StatusEmergencyStop | Indicates that the belt has stopped caused by an emergency condition, either a security flap is open or an emergency button has been pressed.
StatusLightBarrierBackwardInterrupted | Indicates that the belt has stopped for safety reasons.
StatusLightBarrierBackwardOk | Indicates that the light barrier in backward direction is no longer interrupted.
StatusLightBarrierForwardInterrupted | Indicates that the light barrier in forward direction is interrupted.
StatusLightBarrierForwardOk | Indicates that the light barrier in forward direction is no longer interrupted.
StatusMotorFuseDefect | Indicates that the belt has stopped due to a defective fuse.
StatusMotorOverheating | Indicates that the belt has stopped due to a motor overheating.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusSafetyStop | Indicates that the belt has stopped for safety reasons.
StatusSecurityFlapBackwardClosed | Indicates that the security flap in backward direction is closed.
StatusSecurityFlapBackwardOpened | Indicates that the security flap in backward direction is open.
StatusSecurityFlapForwardClosed | Indicates that the security flap in forward direction is closed.
StatusSecurityFlapForwardOpened | Indicates that the security flap in forward direction is open.
StatusTimeoutStop | Indicates that the belt has stopped due to a hardware time-out protecting the motor against overheating.
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

Belt Class
Microsoft.PointOfService Namespace


Belt.StatusAutoStop Field

Belt.StatusAutoStop Field |
 | See Also

1/18/2008

Indicates that the belt has stopped automatically.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusAutoStop As Integer
public const int StatusAutoStop
public:
literal int StatusAutoStop
public static final int StatusAutoStop
public const var StatusAutoStop : int

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.StatusEmergencyStop Field

Belt.StatusEmergencyStop Field |
 | See Also

1/18/2008

Indicates that the belt has stopped caused by an emergency condition, either a security flap is open or an emergency button has been pressed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusEmergencyStop As Integer
public const int StatusEmergencyStop
public:
literal int StatusEmergencyStop
public static final int StatusEmergencyStop
public const var StatusEmergencyStop : int

Remarks

Technical help is needed.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.StatusLightBarrierBackwardInterrupted Field

Belt.StatusLightBarrierBackwardInterrupted Field |
 | See Also

1/18/2008

Indicates that the belt has stopped for safety reasons.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusLightBarrierBackwardInterrupted As Integer
public const int StatusLightBarrierBackwardInterrupted
public:
literal int StatusLightBarrierBackwardInterrupted
public static final int StatusLightBarrierBackwardInterrupted
public const var StatusLightBarrierBackwardInterrupted : int

Remarks

Technical help is not needed.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.StatusLightBarrierBackwardOk Field

Belt.StatusLightBarrierBackwardOk Field |
 | See Also

1/18/2008

Indicates that the light barrier in backward direction is no longer interrupted.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusLightBarrierBackwardOk As Integer
public const int StatusLightBarrierBackwardOk
public:
literal int StatusLightBarrierBackwardOk
public static final int StatusLightBarrierBackwardOk
public const var StatusLightBarrierBackwardOk : int

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.StatusLightBarrierForwardInterrupted Field

Belt.StatusLightBarrierForwardInterrupted Field |
 | See Also

1/18/2008

Indicates that the light barrier in forward direction is interrupted.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusLightBarrierForwardInterrupted As Integer
public const int StatusLightBarrierForwardInterrupted
public:
literal int StatusLightBarrierForwardInterrupted
public static final int StatusLightBarrierForwardInterrupted
public const var StatusLightBarrierForwardInterrupted : int

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.StatusLightBarrierForwardOk Field

Belt.StatusLightBarrierForwardOk Field |
 | See Also

1/18/2008

Indicates that the light barrier in forward direction is no longer interrupted.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusLightBarrierForwardOk As Integer
public const int StatusLightBarrierForwardOk
public:
literal int StatusLightBarrierForwardOk
public static final int StatusLightBarrierForwardOk
public const var StatusLightBarrierForwardOk : int

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.StatusMotorFuseDefect Field

Belt.StatusMotorFuseDefect Field |
 | See Also

1/18/2008

Indicates that the belt has stopped due to a defective fuse.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusMotorFuseDefect As Integer
public const int StatusMotorFuseDefect
public:
literal int StatusMotorFuseDefect
public static final int StatusMotorFuseDefect
public const var StatusMotorFuseDefect : int

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.StatusMotorOverheating Field

Belt.StatusMotorOverheating Field |
 | See Also

1/18/2008

Indicates that the belt has stopped due to a motor overheating.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusMotorOverheating As Integer
public const int StatusMotorOverheating
public:
literal int StatusMotorOverheating
public static final int StatusMotorOverheating
public const var StatusMotorOverheating : int

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.StatusSafetyStop Field

Belt.StatusSafetyStop Field |
 | See Also

1/18/2008

Indicates that the belt has stopped for safety reasons.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusSafetyStop As Integer
public const int StatusSafetyStop
public:
literal int StatusSafetyStop
public static final int StatusSafetyStop
public const var StatusSafetyStop : int

Remarks

Technical assistance is not needed.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.StatusSecurityFlapBackwardClosed Field

Belt.StatusSecurityFlapBackwardClosed Field |
 | See Also

1/18/2008

Indicates that the security flap in backward direction is closed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusSecurityFlapBackwardClosed As Integer
public const int StatusSecurityFlapBackwardClosed
public:
literal int StatusSecurityFlapBackwardClosed
public static final int StatusSecurityFlapBackwardClosed
public const var StatusSecurityFlapBackwardClosed : int

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.StatusSecurityFlapBackwardOpened Field

Belt.StatusSecurityFlapBackwardOpened Field |
 | See Also

1/18/2008

Indicates that the security flap in backward direction is open.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusSecurityFlapBackwardOpened As Integer
public const int StatusSecurityFlapBackwardOpened
public:
literal int StatusSecurityFlapBackwardOpened
public static final int StatusSecurityFlapBackwardOpened
public const var StatusSecurityFlapBackwardOpened : int

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.StatusSecurityFlapForwardClosed Field

Belt.StatusSecurityFlapForwardClosed Field |
 | See Also

1/18/2008

Indicates that the security flap in forward direction is closed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusSecurityFlapForwardClosed As Integer
public const int StatusSecurityFlapForwardClosed
public:
literal int StatusSecurityFlapForwardClosed
public static final int StatusSecurityFlapForwardClosed
public const var StatusSecurityFlapForwardClosed : int

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.StatusSecurityFlapForwardOpened Field

Belt.StatusSecurityFlapForwardOpened Field |
 | See Also

1/18/2008

Indicates that the security flap in forward direction is open.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusSecurityFlapForwardOpened As Integer
public const int StatusSecurityFlapForwardOpened
public:
literal int StatusSecurityFlapForwardOpened
public static final int StatusSecurityFlapForwardOpened
public const var StatusSecurityFlapForwardOpened : int

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.StatusTimeoutStop Field

Belt.StatusTimeoutStop Field |
 | See Also

1/18/2008

Indicates that the belt has stopped due to a hardware time-out protecting the motor against overheating.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusTimeoutStop As Integer
public const int StatusTimeoutStop
public:
literal int StatusTimeoutStop
public static final int StatusTimeoutStop
public const var StatusTimeoutStop : int

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt Constructor

Belt Constructor |
 | See Also

1/18/2008

Creates an instance of the Belt class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected Belt ()
protected:
Belt ()
protected Belt ()
protected function Belt ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt Methods

Belt Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
AdjustItemCount | Indicates the direction of a belt and adjusts the item count accordingly.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
MoveBackward | Starts the belt motor to move backward with the specified speed.
MoveForward | Starts the belt motor to move forward with the specified speed.
Open | Opens a device for later input/output processing. (inherited from PosCommon )
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetBelt | Resets the belt after an emergency stop caused by an open security flap or a pressed emergency button.
ResetItemCount | Resets the item counter of the belt direction.
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
StopBelt | Stops the belt motor.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

Belt Class
Microsoft.PointOfService Namespace


Belt.AdjustItemCount Method

Belt.AdjustItemCount Method |
 | See Also

1/18/2008

Indicates the direction of a belt and adjusts the item count accordingly.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub AdjustItemCount ( _
    direction As BeltDirection, _
    count As Integer _
)
public abstract void AdjustItemCount (
    BeltDirection direction,
    int count
)
public:
virtual void AdjustItemCount (
    BeltDirection direction,
    int count
) abstract
public abstract void AdjustItemCount (
    BeltDirection direction,
    int count
)
public abstract function AdjustItemCount (
    direction : BeltDirection,
    count : int
)

Parameters

direction

Specifies the auto stop item count property to be adjusted. May be either Backward or

Forward.

count

Contains the number of items to be adjusted.

Remarks

Depending on direction, either the AutoStopBackwardItemCount or the AutoStopForwardItemCount property will be adjusted by count. It can be an increment or decrement depending on whether count is positive or negative.

This method is only valid if at least one of the corresponding capabilities of the

CapAutoStopBackwardItemCount or the CapAutoStopForwardItemCount property is true.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.MoveBackward Method

Belt.MoveBackward Method |
 | See Also

1/18/2008

Starts the belt motor to move backward with the specified speed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub MoveBackward ( _
    speed As Integer _
)
public abstract void MoveBackward (
    int speed
)
public:
virtual void MoveBackward (
    int speed
) abstract
public abstract void MoveBackward (
    int speed
)
public abstract function MoveBackward (
    speed : int
)

Parameters

speed

Specifies the speed step. Valid speed steps are 1 through CapSpeedStepsForward.

Remarks

This method is only valid if CapMoveBackward is true.

Subsequent calls to MoveBackward change the speed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.MoveForward Method

Belt.MoveForward Method |
 | See Also

1/18/2008

Starts the belt motor to move forward with the specified speed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub MoveForward ( _
    speed As Integer _
)
public abstract void MoveForward (
    int speed
)
public:
virtual void MoveForward (
    int speed
) abstract
public abstract void MoveForward (
    int speed
)
public abstract function MoveForward (
    speed : int
)

Parameters

speed

Specifies the speed step. Valid speed steps are 1 through CapSpeedStepsForward.

Remarks

Subsequent calls to MoveForward will change the speed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.ResetBelt Method

Belt.ResetBelt Method |
 | See Also

1/18/2008

Resets the belt after an emergency stop caused by an open security flap or a pressed emergency button.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ResetBelt
public abstract void ResetBelt ()
public:
virtual void ResetBelt () abstract
public abstract void ResetBelt ()
public abstract function ResetBelt ()

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.ResetItemCount Method

Belt.ResetItemCount Method |
 | See Also

1/18/2008

Resets the item counter of the belt direction.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ResetItemCount ( _
    direction As BeltDirection _
)
public abstract void ResetItemCount (
    BeltDirection direction
)
public:
virtual void ResetItemCount (
    BeltDirection direction
) abstract
public abstract void ResetItemCount (
    BeltDirection direction
)
public abstract function ResetItemCount (
    direction : BeltDirection
)

Parameters

direction

Specifies the auto stop item count property to be reset. May be either Backward or Forward.

Remarks

Depending on direction, either AutoStopBackwardItemCount or AutoStopForwardItemCount are reset to zero (0).This method is only valid if at least one of the corresponding capabilities CapAutoStopBackwardItemCount or CapAutoStopForwardItemCount is true.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.StopBelt Method

Belt.StopBelt Method |
 | See Also

1/18/2008

Stops the belt motor.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub StopBelt
public abstract void StopBelt ()
public:
virtual void StopBelt () abstract
public abstract void StopBelt ()
public abstract function StopBelt ()

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt Properties

Belt Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
AutoStopBackward | Gets or sets the Boolean value that indicates whether the belt may automatically stop in backward direction.
AutoStopBackwardDelayTime | Gets or sets a delay time for an automatic stop of the belt in backward direction.
AutoStopBackwardItemCount | Gets the item counter for an automatic stop of the belt in backward direction.
AutoStopForward | Gets or sets the Boolean value that indicates whether the belt may automatically stop in forward direction.
AutoStopForwardDelayTime | Gets or sets a delay time in milliseconds for an automatic stop in forward direction.
AutoStopForwardItemCount | Gets the actual item counter for an automatic stop in forward direction.
CapAutoStopBackward | Gets the Boolean value that indicates whether a device supports an automatic motor stop in backward direction.
CapAutoStopBackwardItemCount | Gets the Boolean value that indicates whether a device supports an automatic motor stop in backward direction depending on item count.
CapAutoStopForward | Gets the Boolean value that indicates whether a device supports an automatic motor stop in forward direction.
CapAutoStopForwardItemCount | Gets the Boolean value that indicates whether a device supports an automatic motor stop in forward direction depending on item count.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapLightBarrierBackward | Gets the Boolean value that indicates whether a device has a backward light barrier.
CapLightBarrierForward | Gets the Boolean value that indicates whether a device has a forward light barrier.
CapMoveBackward | Gets the Boolean value that indicates whether a belt can move backward.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapSecurityFlapBackward | Gets the Boolean value that indicates whether a device has a backward security flap.
CapSecurityFlapForward | Gets the Boolean value that indicates whether a device has a forward security flap.
CapSpeedStepsBackward | Gets the integer value for how many speed steps the belt motor supports in backward direction.
CapSpeedStepsForward | Gets the integer value for how many speed steps the belt motor supports in forward direction.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
LightBarrierBackwardInterrupted | Gets the Boolean value that indicates whether the light barrier in backward direction is interrupted.
LightBarrierForwardInterrupted | Gets the Boolean value that indicates whether the light barrier in forward direction is interrupted.
MotionStatus | Gets the current motion state of the device.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
SecurityFlapBackwardOpened | Gets the Boolean value that indicates whether the security flap in backward direction is open.
SecurityFlapForwardOpened | Gets the Boolean value that indicates whether the security flap in forward direction is open.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether the Belt is an exclusive-use device.

See Also

Reference

Belt Class
Microsoft.PointOfService Namespace


Belt.AutoStopBackward Property

Belt.AutoStopBackward Property |
 | See Also

1/18/2008

Gets or sets the Boolean value that indicates whether the belt may automatically stop in backward direction.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AutoStopBackward As Boolean
public abstract bool AutoStopBackward { get; set; }
public:
virtual property bool AutoStopBackward {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_AutoStopBackward ()

/** @property */
public abstract void set_AutoStopBackward (boolean value)

public abstract function get AutoStopBackward () : boolean

public abstract function set AutoStopBackward (value : boolean)

Remarks

The Boolean value of true indicates that the automatic stop feature in backward direction is enabled. If false, it is disabled. The belt automatically stops if an automatic stop condition becomes true.

If the CapAutoStopBackward property is false, this property is always false.

This property is initialized to false by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.AutoStopBackwardDelayTime Property

Belt.AutoStopBackwardDelayTime Property |
 | See Also

1/18/2008

Gets or sets a delay time for an automatic stop of the belt in backward direction.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AutoStopBackwardDelayTime As Integer
public abstract int AutoStopBackwardDelayTime { get; set; }
public:
virtual property int AutoStopBackwardDelayTime {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_AutoStopBackwardDelayTime ()

/** @property */
public abstract void set_AutoStopBackwardDelayTime (int value)

public abstract function get AutoStopBackwardDelayTime () : int

public abstract function set AutoStopBackwardDelayTime (value : int)

Remarks

The integer value indicates a delay time in milliseconds for an automatic stop in backward direction. The delay time starts when an automatic stop condition becomes true. The delay time counting stops and automatic stop is canceled if the condition becomes false.

If the CapAutoStopBackward property is false, this property has no meaning and setting this property is ignored.

This property is initialized to zero (0) by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.AutoStopBackwardItemCount Property

Belt.AutoStopBackwardItemCount Property |
 | See Also

1/18/2008

Gets the item counter for an automatic stop of the belt in backward direction.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property AutoStopBackwardItemCount As Integer
public abstract int AutoStopBackwardItemCount { get; }
public:
virtual property int AutoStopBackwardItemCount {
    int get () abstract;
}
/** @property */
public abstract int get_AutoStopBackwardItemCount ()

public abstract function get AutoStopBackwardItemCount () : int

Remarks

The integer value indicates the item counter for an automatic stop in backward direction. If an item is detected, this property will be decreased. The automatic stop condition becomes true if the item counter mechanism detects an additional item and the counter is already zero.

This property can be increased or decreased by calling the AdjustItemCount method and can be reset to zero by calling the ResetItemCount method.

If the CapAutoStopBackward or CapAutoStopBackwardItemCount property is false, this property has no meaning.

This property is initialized to zero (0) by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.AutoStopForward Property

Belt.AutoStopForward Property |
 | See Also

1/18/2008

Gets or sets the Boolean value that indicates whether the belt may automatically stop in forward direction.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AutoStopForward As Boolean
public abstract bool AutoStopForward { get; set; }
public:
virtual property bool AutoStopForward {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_AutoStopForward ()

/** @property */
public abstract void set_AutoStopForward (boolean value)

public abstract function get AutoStopForward () : boolean

public abstract function set AutoStopForward (value : boolean)

Remarks

The Boolean value of true indicates that the automatic stop feature in forward direction is enabled. If false, it is disabled. The belt automatically stops if an automatic stop condition becomes true.

If the CapAutoStopForward property is false, this property is always false.

This property is initialized to false by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.AutoStopForwardDelayTime Property

Belt.AutoStopForwardDelayTime Property |
 | See Also

1/18/2008

Gets or sets a delay time in milliseconds for an automatic stop in forward direction.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AutoStopForwardDelayTime As Integer
public abstract int AutoStopForwardDelayTime { get; set; }
public:
virtual property int AutoStopForwardDelayTime {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_AutoStopForwardDelayTime ()

/** @property */
public abstract void set_AutoStopForwardDelayTime (int value)

public abstract function get AutoStopForwardDelayTime () : int

public abstract function set AutoStopForwardDelayTime (value : int)

Remarks

Gets or sets the integer value of a delay time in milliseconds for an automatic stop in forward direction. The delay time starts when an automatic stop condition becomes true. The delay time counting stops and automatic stop is canceled if the condition becomes false.

If the CapAutoStopForward property is false, this property has no meaning. Setting this property is ignored.

This property is initialized to zero (0) by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.AutoStopForwardItemCount Property

Belt.AutoStopForwardItemCount Property |
 | See Also

1/18/2008

Gets the actual item counter for an automatic stop in forward direction.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property AutoStopForwardItemCount As Integer
public abstract int AutoStopForwardItemCount { get; }
public:
virtual property int AutoStopForwardItemCount {
    int get () abstract;
}
/** @property */
public abstract int get_AutoStopForwardItemCount ()

public abstract function get AutoStopForwardItemCount () : int

Remarks

Gets the integer value of the actual item counter for an automatic stop in forward direction. If an item is detected, this property is decreased. The automatic stop condition becomes true, if the item counter mechanism detects an additional item and the counter is already zero.

This property can be increased or decreased by calling the AdjustItemCount method and can be reset to zero by calling the ResetItemCount method.

If CapAutoStopForward or CapAutoStopForwardItemCount property is false, this property has no meaning.

This property is initialized to zero (0) by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.CapAutoStopBackward Property

Belt.CapAutoStopBackward Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether a device supports an automatic motor stop in backward direction.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapAutoStopBackward As Boolean
public abstract bool CapAutoStopBackward { get; }
public:
virtual property bool CapAutoStopBackward {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapAutoStopBackward ()

public abstract function get CapAutoStopBackward () : boolean

Remarks

If the Boolean value is true, the device supports an automatic motor stop when moving backward, based on an automatic stop condition.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.CapAutoStopBackwardItemCount Property

Belt.CapAutoStopBackwardItemCount Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether a device supports an automatic motor stop in backward direction depending on item count.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapAutoStopBackwardItemCount As Boolean
public abstract bool CapAutoStopBackwardItemCount { get; }
public:
virtual property bool CapAutoStopBackwardItemCount {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapAutoStopBackwardItemCount ()

public abstract function get CapAutoStopBackwardItemCount () : boolean

Remarks

If the Boolean value is true, the device supports an automatic motor stop when moving backward depending on the number of items specified by the AutoStopBackwardItemCount property.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.CapAutoStopForward Property

Belt.CapAutoStopForward Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether a device supports an automatic motor stop in forward direction.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapAutoStopForward As Boolean
public abstract bool CapAutoStopForward { get; }
public:
virtual property bool CapAutoStopForward {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapAutoStopForward ()

public abstract function get CapAutoStopForward () : boolean

Remarks

If the Boolean value is true, the device supports an automatic motor stop when moving forward, based on an automatic stop condition.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.CapAutoStopForwardItemCount Property

Belt.CapAutoStopForwardItemCount Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether a device supports an automatic motor stop in forward direction depending on item count.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapAutoStopForwardItemCount As Boolean
public abstract bool CapAutoStopForwardItemCount { get; }
public:
virtual property bool CapAutoStopForwardItemCount {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapAutoStopForwardItemCount ()

public abstract function get CapAutoStopForwardItemCount () : boolean

Remarks

If the Boolean is true, the device supports an automatic motor stop when moving forward depending on the number of items specified by the AutoStopForwardItemCount property.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.CapLightBarrierBackward Property

Belt.CapLightBarrierBackward Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether a device has a backward light barrier.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapLightBarrierBackward As Boolean
public abstract bool CapLightBarrierBackward { get; }
public:
virtual property bool CapLightBarrierBackward {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapLightBarrierBackward ()

public abstract function get CapLightBarrierBackward () : boolean

Remarks

If the Boolean value is true, the device has a backward light barrier and the LightBarrierBackwardInterrupted property holds the actual state of the light barrier.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.CapLightBarrierForward Property

Belt.CapLightBarrierForward Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether a device has a forward light barrier.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapLightBarrierForward As Boolean
public abstract bool CapLightBarrierForward { get; }
public:
virtual property bool CapLightBarrierForward {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapLightBarrierForward ()

public abstract function get CapLightBarrierForward () : boolean

Remarks

If the Boolean value is true, the device has a backward light barrier and the LightBarrierForwardInterrupted property holds the actual state of the light barrier.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.CapMoveBackward Property

Belt.CapMoveBackward Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether a belt can move backward.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapMoveBackward As Boolean
public abstract bool CapMoveBackward { get; }
public:
virtual property bool CapMoveBackward {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapMoveBackward ()

public abstract function get CapMoveBackward () : boolean

Remarks

If the Boolean value is true, the belt can move backward.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.CapSecurityFlapBackward Property

Belt.CapSecurityFlapBackward Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether a device has a backward security flap.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSecurityFlapBackward As Boolean
public abstract bool CapSecurityFlapBackward { get; }
public:
virtual property bool CapSecurityFlapBackward {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSecurityFlapBackward ()

public abstract function get CapSecurityFlapBackward () : boolean

Remarks

If the Boolean value is true, the device has a backward security flap and the SecurityFlapBackwardOpened property holds the actual state of the flap.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.CapSecurityFlapForward Property

Belt.CapSecurityFlapForward Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether a device has a forward security flap.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSecurityFlapForward As Boolean
public abstract bool CapSecurityFlapForward { get; }
public:
virtual property bool CapSecurityFlapForward {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSecurityFlapForward ()

public abstract function get CapSecurityFlapForward () : boolean

Remarks

If the Boolean value is true, the device has a forward security flap and the SecurityFlapForwardOpened property holds the actual state of the flap.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.CapSpeedStepsBackward Property

Belt.CapSpeedStepsBackward Property |
 | See Also

1/18/2008

Gets the integer value for how many speed steps the belt motor supports in backward direction.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSpeedStepsBackward As Integer
public abstract int CapSpeedStepsBackward { get; }
public:
virtual property int CapSpeedStepsBackward {
    int get () abstract;
}
/** @property */
public abstract int get_CapSpeedStepsBackward ()

public abstract function get CapSpeedStepsBackward () : int

Remarks

The integer value defines how many speed steps the belt motor supports in backward direction. Minimum is one (1). This property is only valid if the CapMoveBackward property is true. If the CapMoveBackward property is false, this property is initialized to zero (0).

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.CapSpeedStepsForward Property

Belt.CapSpeedStepsForward Property |
 | See Also

1/18/2008

Gets the integer value for how many speed steps the belt motor supports in forward direction.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSpeedStepsForward As Integer
public abstract int CapSpeedStepsForward { get; }
public:
virtual property int CapSpeedStepsForward {
    int get () abstract;
}
/** @property */
public abstract int get_CapSpeedStepsForward ()

public abstract function get CapSpeedStepsForward () : int

Remarks

The integer value defines how many speed steps the belt motor supports in forward direction. Minimum is one (1).

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.IsExclusiveUseDevice Property

Belt.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the Belt is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Remarks

A value of true indicates that the Belt is exclusive-use. Otherwise, the value is false.

An exclusive-use device has the following properties:

  • The application must claim the device before enabling it.

  • The application must claim and enable the device before accessing some properties or calling methods that update the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.LightBarrierBackwardInterrupted Property

Belt.LightBarrierBackwardInterrupted Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the light barrier in backward direction is interrupted.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property LightBarrierBackwardInterrupted As Boolean
public abstract bool LightBarrierBackwardInterrupted { get; }
public:
virtual property bool LightBarrierBackwardInterrupted {
    bool get () abstract;
}
/** @property */
public abstract boolean get_LightBarrierBackwardInterrupted ()

public abstract function get LightBarrierBackwardInterrupted () : boolean

Remarks

If the Boolean value is true, the light barrier in backward direction is interrupted. Otherwise, it is false. An appropriate StatusUpdateEvent event indicates that a status change will be enqueued.

If the CapLightBarrierBackward property is false, this property is always false.

This property is initialized and kept current while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.LightBarrierForwardInterrupted Property

Belt.LightBarrierForwardInterrupted Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the light barrier in forward direction is interrupted.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property LightBarrierForwardInterrupted As Boolean
public abstract bool LightBarrierForwardInterrupted { get; }
public:
virtual property bool LightBarrierForwardInterrupted {
    bool get () abstract;
}
/** @property */
public abstract boolean get_LightBarrierForwardInterrupted ()

public abstract function get LightBarrierForwardInterrupted () : boolean

Remarks

If the Boolean value is true, the light barrier in forward direction is interrupted. Otherwise, it is false. An appropriate StatusUpdateEvent event indicates that a status change will be enqueued.

If the CapLightBarrierForward property is false, this property is always false.

This property is initialized and kept current while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.MotionStatus Property

Belt.MotionStatus Property |
 | See Also

1/18/2008

Gets the current motion state of the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property MotionStatus As BeltMotionStatus
public abstract BeltMotionStatus MotionStatus { get; }
public:
virtual property BeltMotionStatus MotionStatus {
    BeltMotionStatus get () abstract;
}
/** @property */
public abstract BeltMotionStatus get_MotionStatus ()

public abstract function get MotionStatus () : BeltMotionStatus

Remarks

This property is initialized and kept current while the device is enabled.

An appropriate StatusUpdateEvent indicating a status change will be enqueued.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.SecurityFlapBackwardOpened Property

Belt.SecurityFlapBackwardOpened Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the security flap in backward direction is open.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property SecurityFlapBackwardOpened As Boolean
public abstract bool SecurityFlapBackwardOpened { get; }
public:
virtual property bool SecurityFlapBackwardOpened {
    bool get () abstract;
}
/** @property */
public abstract boolean get_SecurityFlapBackwardOpened ()

public abstract function get SecurityFlapBackwardOpened () : boolean

Remarks

If the Boolean value is true, the security flap in backward direction is open. Otherwise, it is closed. An appropriate StatusUpdateEvent event indicates that a status change will be enqueued.

If the CapSecurityFlapBackward property is false, this property is always false.

This property is initialized and kept current while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt.SecurityFlapForwardOpened Property

Belt.SecurityFlapForwardOpened Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the security flap in forward direction is open.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property SecurityFlapForwardOpened As Boolean
public abstract bool SecurityFlapForwardOpened { get; }
public:
virtual property bool SecurityFlapForwardOpened {
    bool get () abstract;
}
/** @property */
public abstract boolean get_SecurityFlapForwardOpened ()

public abstract function get SecurityFlapForwardOpened () : boolean

Remarks

If the Boolean value is true, the security flap in forward direction is open. Otherwise, it is closed. An appropriate StatusUpdateEvent event indicates that a status change will be enqueued.

If the CapSecurityFlapForward property is false, this property is always false.

This property is initialized and kept current while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Belt Class
Belt Members
Microsoft.PointOfService Namespace


Belt Events

Belt Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

Belt Class
Microsoft.PointOfService Namespace


BeltDirection Enumeration

BeltDirection Enumeration |
 | See Also

1/18/2008

Enumerates the belt direction.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration BeltDirection
public enum BeltDirection
public enum class BeltDirection
public enum BeltDirection
public enum BeltDirection

Members

Member name | Description
Backward | Indicates that the belt moves in backward direction.
Forward | Indicates that the belt moves in forward direction.

Remarks

Used by the AdjustItemCount and ResetItemCount methods. Replaces the BELT_AIC_BACKWARD and BELT_AIC_FORWARD properties from UPOS.

See Also

Reference

Microsoft.PointOfService Namespace


BeltMotionStatus Enumeration

BeltMotionStatus Enumeration |
 | See Also

1/18/2008

Enumerates possible values of the current motion state of the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration BeltMotionStatus
public enum BeltMotionStatus
public enum class BeltMotionStatus
public enum BeltMotionStatus
public enum BeltMotionStatus

Members

Member name | Description
Backward | The device is moving backward.
Emergency | Emergency stop. Either a security flap is open or the emergency button was pressed. Technical help is needed to reactivate the belt device.
Forward | The device is moving forward.
MotorFault | The device has stopped because of a motor failure like overheating or a defective fuse. Technical help may be needed to reactivate the motor.
Stopped | The device has stopped because of an automatic stop, security stop or motor time-out stop.

Remarks

Replaces the BELT_MT_BACKWARD, BELT_MT_EMERGENCY, BELT_MT_FORWARD, BELT_MT_MOTOR_FAULT, and BELT_MT_STOPPED properties from UPOS.

See Also

Reference

Microsoft.PointOfService Namespace


BillAcceptor Class

BillAcceptor Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a UPOS Bill Acceptor device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class BillAcceptor
    Inherits PosCommon
public abstract class BillAcceptor : PosCommon
public ref class BillAcceptor abstract : public PosCommon
public abstract class BillAcceptor extends PosCommon
public abstract class BillAcceptor extends PosCommon

Remarks

Capabilities

The Bill Acceptor has the following capabilities:

  • Reports the cash units and corresponding unit counts available in the Bill Acceptor.

  • Reports jam conditions within the device.

  • Supports more than one currency.

The Bill Acceptor may also have the following additional capabilities:

  • Reports the levels of the Bill Acceptor’s cash units. Conditions which may be indicated include full and almost full states.

  • Reports a possible (or probable) cash count discrepancy in the data reported by the ReadCashCounts method.

  • The money (bills which are deposited into the device between the start and end of cash acceptance) is reported to the application. The contents of the report are cash units and cash counts.

General Model

The general model of a Bill Acceptor is as follows:

  • Supports several bill denominations. The supported cash type for a particular currency is noted by the list of cash units in the DepositCashList property.

  • Consists of any combination of features to help generate the cash processing functions such as a cash entry holding bin, a number of slots or bins which can hold the cash, and cash exits.

  • Controls the removal of cash from the device (for example, to empty deposited cash) by the AdjustCashCounts method, unless the device can determine how much cash on its own. The application can call the ReadCashCounts method to retrieve the current unit count for each cash unit.

  • Sets the cash slot (or cash bin) conditions in the FullStatus property to show full and almost full status. If there are one or more full cash slots, FullStatus has the Full value.

  • Starts cash acceptance into the "cash acceptance mechanism" by invoking the BeginDeposit method. The previous values of the properties DepositCounts and DepositAmount are initialized to zero.

The total amount of cash put into the device continues to be accumulated until either the FixDeposit method or the PauseDeposit method is executed. When theFixDeposit method is executed, the total amount of accumulated cash is stored in the DepositCounts and DepositAmount properties. If the PauseDeposit method is executed with a parameter value of Pause, the counting of the deposited cash is suspended, and the current amount of accumulated cash is also updated to the DepositCounts and DepositAmount properties. When PauseDeposit method is executed with a parameter value of Restart, counting of deposited cash is resumed and added to the accumulated totals. When the FixDeposit method is executed, the current amount of accumulated cash is updated in the DepositCounts and DepositAmount properties, and the process remains static until the EndDeposit method is invoked by using a Complete value to complete the deposit.

  • When the ClearInput method is executed, the queued DataEvent event associated with the receipt of cash is cleared. The DepositCounts and DepositAmount properties remain set and are not cleared.

Device Sharing

The Bill Acceptor is an exclusive-use device, as follows:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before accessing some properties, dispensing, collecting, or receiving events.

Platforms

The BillAcceptor class requires POS for .NET version 1.11 or later versions.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.BillAcceptor
Microsoft.PointOfService.BasicServiceObjects.BillAcceptorBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillAcceptor Members
Microsoft.PointOfService Namespace


BillAcceptor Members

BillAcceptor Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a UPOS Bill Acceptor device.

The following tables list the members exposed by the BillAcceptor type.

Protected Constructors

Name | Description
BillAcceptor | Creates an instance of the BillAcceptor class.
Top

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusFull | Indicates that the Bill Acceptor is full.
StatusFullOk | Indicates that the Bill Acceptor is no longer full.
StatusJam | Indicates that a mechanical problem has occurred.
StatusJamOk | Indicates that the Bill Acceptor is no longer jammed.
StatusNearFull | Indicates that the Bill Acceptor is almost full.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapDiscrepancy | Gets the Boolean value that indicates whether the ReadCashCounts method can report effective discrepancy values.
CapFullSensor | Gets the Boolean value that indicates whether the Bill Acceptor can report that some cash slots are full.
CapJamSensor | Gets the Boolean value that indicates whether the Bill Acceptor can report a mechanical jam or failure condition.
CapNearFullSensor | Gets the Boolean value that indicates whether the Bill Acceptor can report that its cash slots are almost full.
CapPauseDeposit | Gets the Boolean value that indicates whether the Bill Acceptor may suspend cash acceptance processing temporarily.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapRealTimeData | Gets the Boolean value that indicates whether the device can supply data as money is accepted.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
CurrencyCode | Gets or sets the Boolean value that indicates the currency code used for Bill Acceptor operations.
DataCount | Gets the total number of currently queued DataEvent events at the service object.
DataEventEnabled | Gets or sets the Boolean value that indicates whether a DataEvent event is delivered when input data is queued.
DepositAmount | Gets the total amount of deposited cash.
DepositCashList | Gets a list that indicates the cash units supported in the Bill Acceptor for the currency represented by the CurrencyCode property.
DepositCodeList | Gets the currency code list that indicates which types of currency are accepted.
DepositCounts | Gets the total count of all the cash in the Bill Acceptor.
DepositStatus | Gets the current status of the cash acceptance operation.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
FullStatus | Gets the current full status of the cash slots.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
RealTimeDataEnabled | Gets or sets the Boolean value indicating whether data is collected in real time.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets the Boolean value that indicates whether the Bill Acceptor is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
AdjustCashCounts | Sets the amount currently in the device to specific values.
BeginDeposit | Begins the cash acceptance process.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all device input that has been buffered.
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
EndDeposit | Ends the cash acceptance process.
Equals | Overloaded. (inherited from Object )
FixDeposit | Updates property values to reflect the current values in the Bill Acceptor.
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon)
PauseDeposit | Suspends or resumes the process of depositing cash.
ReadCashCounts | Returns the cash counts of all cash in the bill acceptor.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DataEvent | Notifies the application when the Bill Acceptor has accepted a bill.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

BillAcceptor Class
Microsoft.PointOfService Namespace


BillAcceptor Fields

BillAcceptor Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusFull | Indicates that the Bill Acceptor is full.
StatusFullOk | Indicates that the Bill Acceptor is no longer full.
StatusJam | Indicates that a mechanical problem has occurred.
StatusJamOk | Indicates that the Bill Acceptor is no longer jammed.
StatusNearFull | Indicates that the Bill Acceptor is almost full.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

BillAcceptor Class
Microsoft.PointOfService Namespace


BillAcceptor.StatusFull Field

BillAcceptor.StatusFull Field |
 | See Also

1/18/2008

Indicates that the Bill Acceptor is full.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusFull As Integer
public const int StatusFull
public:
literal int StatusFull
public static final int StatusFull
public const var StatusFull : int

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace


BillAcceptor.StatusFullOk Field

BillAcceptor.StatusFullOk Field |
 | See Also

1/18/2008

Indicates that the Bill Acceptor is no longer full.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusFullOk As Integer
public const int StatusFullOk
public:
literal int StatusFullOk
public static final int StatusFullOk
public const var StatusFullOk : int

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace


BillAcceptor.StatusJam Field

BillAcceptor.StatusJam Field |
 | See Also

1/18/2008

Indicates that a mechanical problem has occurred.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusJam As Integer
public const int StatusJam
public:
literal int StatusJam
public static final int StatusJam
public const var StatusJam : int

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace


BillAcceptor.StatusJamOk Field

BillAcceptor.StatusJamOk Field |
 | See Also

1/18/2008

Indicates that the Bill Acceptor is no longer jammed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusJamOk As Integer
public const int StatusJamOk
public:
literal int StatusJamOk
public static final int StatusJamOk
public const var StatusJamOk : int

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace


BillAcceptor.StatusNearFull Field

BillAcceptor.StatusNearFull Field |
 | See Also

1/18/2008

Indicates that the Bill Acceptor is almost full.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusNearFull As Integer
public const int StatusNearFull
public:
literal int StatusNearFull
public static final int StatusNearFull
public const var StatusNearFull : int

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace


BillAcceptor Constructor

BillAcceptor Constructor |
 | See Also

1/18/2008

Creates an instance of the BillAcceptor class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected BillAcceptor ()
protected:
BillAcceptor ()
protected BillAcceptor ()
protected function BillAcceptor ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace


BillAcceptor Methods

BillAcceptor Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
AdjustCashCounts | Sets the amount currently in the device to specific values.
BeginDeposit | Begins the cash acceptance process.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all device input that has been buffered.
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
EndDeposit | Ends the cash acceptance process.
Equals | Overloaded. (inherited from Object )
FixDeposit | Updates property values to reflect the current values in the Bill Acceptor.
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon )
PauseDeposit | Suspends or resumes the process of depositing cash.
ReadCashCounts | Returns the cash counts of all cash in the bill acceptor.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

BillAcceptor Class
Microsoft.PointOfService Namespace


BillAcceptor.AdjustCashCounts Method

BillAcceptor.AdjustCashCounts Method |
 | See Also

1/18/2008

Sets the amount currently in the device to specific values.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub AdjustCashCounts ( _
    cashCounts As IEnumerable(Of CashCount) _
)
public abstract void AdjustCashCounts (
    IEnumerable<CashCount> cashCounts
)
public:
virtual void AdjustCashCounts (
    IEnumerable<CashCount>^ cashCounts
) abstract
public abstract void AdjustCashCounts (
    IEnumerable<CashCount> cashCounts
)
public abstract function AdjustCashCounts (
    cashCounts : IEnumerable<CashCount>
)

Parameters

cashCounts

The cashCounts parameter contains cash types and amounts to be initialized.

Remarks

This method is called to set the initial amounts in the Bill Acceptor after setup, or to adjust cash counts after replenishment or removal, such as a paid in or paid out operation. This method is called when it is required for devices which cannot determine the exact amount of cash in them automatically. If the device can determine the exact amount, this method call is ignored. The application would first call ReadCashCounts for the current counts, and then adjust them to the amount being replenished.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace
ReadCashCounts


BillAcceptor.BeginDeposit Method

BillAcceptor.BeginDeposit Method |
 | See Also

1/18/2008

Begins the cash acceptance process.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub BeginDeposit
public abstract void BeginDeposit ()
public:
virtual void BeginDeposit () abstract
public abstract void BeginDeposit ()
public abstract function BeginDeposit ()

Remarks

The following property values are initialized by the call to this method:

  • The value of each cash unit of the DepositCounts property is set to zero.

  • The DepositAmount property is set to zero.

After the code calls this method, cash acceptance is continually reported by the DataEvent events until the FixDeposit method is called while the deposit process is running (not paused).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace
DepositAmount
DepositCounts
EndDeposit
FixDeposit
PauseDeposit


BillAcceptor.ClearInput Method

BillAcceptor.ClearInput Method |
 | See Also

1/18/2008

Clears all device input that has been buffered.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearInput
public abstract void ClearInput ()
public:
virtual void ClearInput () abstract
public abstract void ClearInput ()
public abstract function ClearInput ()

Remarks

Any data events or input error events that are queued, usually waiting for DataEventEnabled to be set to true and FreezeEvents to be set to false, are also cleared.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace
DataEventEnabled
DataEvent


BillAcceptor.EndDeposit Method

BillAcceptor.EndDeposit Method |
 | See Also

1/18/2008

Ends the cash acceptance process.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub EndDeposit ( _
    success As EndDepositAction _
)
public abstract void EndDeposit (
    EndDepositAction success
)
public:
virtual void EndDeposit (
    EndDepositAction success
) abstract
public abstract void EndDeposit (
    EndDepositAction success
)
public abstract function EndDeposit (
    success : EndDepositAction
)

Parameters

success

The deposit is accepted and the process is complete.

Remarks

Before the code calls this method, the application must calculate the difference between the deposit and the amount required.

The application must call the BeginDeposit and FixDeposit methods in sequence before the code calls this method, or a PosControlException exception is thrown with the ErrorCode property that contains the value Illegal.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace
DepositAmount
DepositCounts
BillAcceptor.BeginDeposit Method
FixDeposit
PauseDeposit


BillAcceptor.FixDeposit Method

BillAcceptor.FixDeposit Method |
 | See Also

1/18/2008

Updates property values to reflect the current values in the Bill Acceptor.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub FixDeposit
public abstract void FixDeposit ()
public:
virtual void FixDeposit () abstract
public abstract void FixDeposit ()
public abstract function FixDeposit ()

Remarks

When this method is called, all property values are updated to reflect the current values in the Bill Acceptor.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace
DepositAmount
DepositCounts
BillAcceptor.BeginDeposit Method
BillAcceptor.EndDeposit Method
PauseDeposit


BillAcceptor.PauseDeposit Method

BillAcceptor.PauseDeposit Method |
 | See Also

1/18/2008

Suspends or resumes the process of depositing cash.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PauseDeposit ( _
    control As CashDepositPause _
)
public abstract void PauseDeposit (
    CashDepositPause control
)
public:
virtual void PauseDeposit (
    CashDepositPause control
) abstract
public abstract void PauseDeposit (
    CashDepositPause control
)
public abstract function PauseDeposit (
    control : CashDepositPause
)

Parameters

control

Indicates whether the cash acceptance process is paused or restarted. If the value of this parameter is Pause, acceptance is paused. If the value is Restart, cash acceptance resumes.

Remarks

This method is called to suspend or resume the process of depositing cash. If the value of control is Pause, the cash acceptance operation becomes paused. As soon as it is paused, the deposit process remains paused until this method is called again with Restart as the parameter value, which causes the process to be resumed.

It is valid to call the FixDeposit method, then the EndDeposit method while the deposit process is paused.

When the deposit process is paused, the DepositCounts and DepositAmount properties are updated to reflect the current state of the Bill Acceptor. The property values are not changed again until the deposit process is resumed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace
DepositAmount
DepositCounts
BillAcceptor.BeginDeposit Method
BillAcceptor.EndDeposit Method
BillAcceptor.FixDeposit Method


BillAcceptor.ReadCashCounts Method

BillAcceptor.ReadCashCounts Method |
 | See Also

1/18/2008

Returns the cash counts of all cash in the bill acceptor.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function ReadCashCounts As CashCounts
public abstract CashCounts ReadCashCounts ()
public:
virtual CashCounts ReadCashCounts () abstract
public abstract CashCounts ReadCashCounts ()
public abstract function ReadCashCounts () : CashCounts

Remarks

Each unit in cashCounts matches a unit in the DepositCashList property, and is in the same order.

Typically, the cash total returned in the CashCounts structure is equal to the cash total in a Bill Acceptor. There are some cases in which a discrepancy may occur because of existing uncountable cash in a Bill Acceptor, such as when a cash slot is "overflowing" to the extent that the device has lost its ability to accurately detect and monitor the cash.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace
DepositCashList


BillAcceptor Properties

BillAcceptor Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapDiscrepancy | Gets the Boolean value that indicates whether the ReadCashCounts method can report effective discrepancy values.
CapFullSensor | Gets the Boolean value that indicates whether the Bill Acceptor can report that some cash slots are full.
CapJamSensor | Gets the Boolean value that indicates whether the Bill Acceptor can report a mechanical jam or failure condition.
CapNearFullSensor | Gets the Boolean value that indicates whether the Bill Acceptor can report that its cash slots are almost full.
CapPauseDeposit | Gets the Boolean value that indicates whether the Bill Acceptor may suspend cash acceptance processing temporarily.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapRealTimeData | Gets the Boolean value that indicates whether the device can supply data as money is accepted.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
CurrencyCode | Gets or sets the Boolean value that indicates the currency code used for Bill Acceptor operations.
DataCount | Gets the total number of currently queued DataEvent events at the service object.
DataEventEnabled | Gets or sets the Boolean value that indicates whether a DataEvent event is delivered when input data is queued.
DepositAmount | Gets the total amount of deposited cash.
DepositCashList | Gets a list that indicates the cash units supported in the Bill Acceptor for the currency represented by the CurrencyCode property.
DepositCodeList | Gets the currency code list that indicates which types of currency are accepted.
DepositCounts | Gets the total count of all the cash in the Bill Acceptor.
DepositStatus | Gets the current status of the cash acceptance operation.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
FullStatus | Gets the current full status of the cash slots.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
RealTimeDataEnabled | Gets or sets the Boolean value indicating whether data is collected in real time.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets the Boolean value that indicates whether the Bill Acceptor is an exclusive-use device.

See Also

Reference

BillAcceptor Class
Microsoft.PointOfService Namespace


BillAcceptor.CapDiscrepancy Property

BillAcceptor.CapDiscrepancy Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the ReadCashCounts method can report effective discrepancy values.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapDiscrepancy As Boolean
public abstract bool CapDiscrepancy { get; }
public:
virtual property bool CapDiscrepancy {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapDiscrepancy ()

public abstract function get CapDiscrepancy () : boolean

Remarks

If true, the ReadCashCounts method can report effective discrepancy values.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace
BillAcceptor.ReadCashCounts Method


BillAcceptor.CapFullSensor Property

BillAcceptor.CapFullSensor Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the Bill Acceptor can report that some cash slots are full.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapFullSensor As Boolean
public abstract bool CapFullSensor { get; }
public:
virtual property bool CapFullSensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapFullSensor ()

public abstract function get CapFullSensor () : boolean

Remarks

If true, the Bill Acceptor device can report that some cash slots are full.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace
FullStatus
BillAcceptor.StatusFull Field


BillAcceptor.CapJamSensor Property

BillAcceptor.CapJamSensor Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the Bill Acceptor can report a mechanical jam or failure condition.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapJamSensor As Boolean
public abstract bool CapJamSensor { get; }
public:
virtual property bool CapJamSensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapJamSensor ()

public abstract function get CapJamSensor () : boolean

Remarks

If true, the Bill Acceptor can report a mechanical jam or failure condition.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace
BillAcceptor.StatusJam Field


BillAcceptor.CapNearFullSensor Property

BillAcceptor.CapNearFullSensor Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the Bill Acceptor can report that its cash slots are almost full.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapNearFullSensor As Boolean
public abstract bool CapNearFullSensor { get; }
public:
virtual property bool CapNearFullSensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapNearFullSensor ()

public abstract function get CapNearFullSensor () : boolean

Remarks

If true, the Bill Acceptor can report the condition that some cash slots are almost full.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace
FullStatus
BillAcceptor.StatusNearFull Field


BillAcceptor.CapPauseDeposit Property

BillAcceptor.CapPauseDeposit Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the Bill Acceptor may suspend cash acceptance processing temporarily.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapPauseDeposit As Boolean
public abstract bool CapPauseDeposit { get; }
public:
virtual property bool CapPauseDeposit {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapPauseDeposit ()

public abstract function get CapPauseDeposit () : boolean

Remarks

If true, the Bill Acceptor can suspend cash acceptance processing temporarily.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace
BillAcceptor.PauseDeposit Method


BillAcceptor.CapRealTimeData Property

BillAcceptor.CapRealTimeData Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the device can supply data as money is accepted.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRealTimeData As Boolean
public abstract bool CapRealTimeData { get; }
public:
virtual property bool CapRealTimeData {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRealTimeData ()

public abstract function get CapRealTimeData () : boolean

Remarks

If true, the device can supply data as the money is being accepted.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace
RealTimeDataEnabled


BillAcceptor.CurrencyCode Property

BillAcceptor.CurrencyCode Property |
 | See Also

1/18/2008

Gets or sets the Boolean value that indicates the currency code used for Bill Acceptor operations.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property CurrencyCode As String
public abstract string CurrencyCode { get; set; }
public:
virtual property String^ CurrencyCode {
    String^ get () abstract;
    void set (String^ value) abstract;
}
/** @property */
public abstract String get_CurrencyCode ()

/** @property */
public abstract void set_CurrencyCode (String value)

public abstract function get CurrencyCode () : String

public abstract function set CurrencyCode (value : String)

Remarks

Holds the currency code used for Bill Acceptor operations.

This property is initialized to an appropriate value by the Open method. This value is guaranteed to be one of the set of currencies specified by the DepositCodeList property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace
DepositCodeList


BillAcceptor.DataCount Property

BillAcceptor.DataCount Property |
 | See Also

1/18/2008

Gets the total number of currently queued DataEvent events at the service object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DataCount As Integer
public abstract int DataCount { get; }
public:
virtual property int DataCount {
    int get () abstract;
}
/** @property */
public abstract int get_DataCount ()

public abstract function get DataCount () : int

Remarks

Indicates the total number of currently queued DataEvent events at the service object. All online units are included in this value.

The application can interrogate DataCount to determine whether additional input is queued from a device but has not yet been delivered because of other application processing, freezing of events, or other causes.

DataCount is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace
DataEvent


BillAcceptor.DataEventEnabled Property

BillAcceptor.DataEventEnabled Property |
 | See Also

1/18/2008

Gets or sets the Boolean value that indicates whether a DataEvent event is delivered when input data is queued.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property DataEventEnabled As Boolean
public abstract bool DataEventEnabled { get; set; }
public:
virtual property bool DataEventEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_DataEventEnabled ()

/** @property */
public abstract void set_DataEventEnabled (boolean value)

public abstract function get DataEventEnabled () : boolean

public abstract function set DataEventEnabled (value : boolean)

Remarks

If true, a DataEvent is delivered as soon as input data is queued. If this property is changed to true while input data is already in the queue, a DataEvent event will be delivered immediately. This event may be delayed if FreezeEvents is true or if another event is already being processed at the application. In this case, the DataEvent event remains queued until it can be processed.

If false, input data is queued for later delivery to the application. Also, if an input error occurs, the input ErrorEvent is not delivered while DataEventEnabled is false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace
DataEvent
ErrorEvent
ErrorEvent
ErrorEvent
ErrorEvent


BillAcceptor.DepositAmount Property

BillAcceptor.DepositAmount Property |
 | See Also

1/18/2008

Gets the total amount of deposited cash.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DepositAmount As Integer
public abstract int DepositAmount { get; }
public:
virtual property int DepositAmount {
    int get () abstract;
}
/** @property */
public abstract int get_DepositAmount ()

public abstract function get DepositAmount () : int

Remarks

For example, if the currency is Japanese yen and DepositAmount is set to 18057, after the call to the BeginDeposit method there would be 18,057 yen in the Bill Acceptor.

This property is initialized to zero by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace
BillAcceptor.CurrencyCode Property


BillAcceptor.DepositCashList Property

BillAcceptor.DepositCashList Property |
 | See Also

1/18/2008

Gets a list that indicates the cash units supported in the Bill Acceptor for the currency represented by the CurrencyCode property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DepositCashList As CashUnits
public abstract CashUnits DepositCashList { get; }
public:
virtual property CashUnits DepositCashList {
    CashUnits get () abstract;
}
/** @property */
public abstract CashUnits get_DepositCashList ()

public abstract function get DepositCashList () : CashUnits

Remarks

Holds the cash units supported in the Bill Acceptor for the currency represented by the CurrencyCode property.

Currency totals are contained in a pair of integer arrays that represent the number of bills and coins in the device.

This property is initialized by the Open method, and is updated when CurrencyCode is set.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace
BillAcceptor.CurrencyCode Property
DepositCodeList


BillAcceptor.DepositCodeList Property

BillAcceptor.DepositCodeList Property |
 | See Also

1/18/2008

Gets the currency code list that indicates which types of currency are accepted.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DepositCodeList As String()
public abstract string[] DepositCodeList { get; }
public:
virtual property array<String^>^ DepositCodeList {
    array<String^>^ get () abstract;
}
/** @property */
public abstract String[] get_DepositCodeList ()

public abstract function get DepositCodeList () : String[]

Remarks

Holds the currency codes that indicate which types of currency are accepted.

Currency codes are made up of a list of 3-character ASCII ISO 4217 currency codes separated by commas.

For example, if the string is "JPY,USD", the Bill Acceptor supports both Japanese and U.S. monetary units.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace
BillAcceptor.CurrencyCode Property
BillAcceptor.DepositCashList Property


BillAcceptor.DepositCounts Property

BillAcceptor.DepositCounts Property |
 | See Also

1/18/2008

Gets the total count of all the cash in the Bill Acceptor.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DepositCounts As CashCount()
public abstract CashCount[] DepositCounts { get; }
public:
virtual property array<CashCount>^ DepositCounts {
    array<CashCount>^ get () abstract;
}
/** @property */
public abstract CashCount[] get_DepositCounts ()

public abstract function get DepositCounts () : CashCount[]

Remarks

Holds the total count of all the cash in the Bill Acceptor. Currency codes inside the string are the same as the DepositCashList property, and follow the same order.

For example, if the currency is Japanese yen and string of the DepositCounts property is set to 1000:80,5000:77,10000:0,50000:54,100:0,500000:87, after the call to the BeginDeposit method there would be 80 one thousand yen bills, 77 five thousand yen bills, 54 fifty thousand yen bills, and 87 five hundred thousand yen bills in the Bill Acceptor.

This property is initialized to zero by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace
BillAcceptor.CurrencyCode Property


BillAcceptor.DepositStatus Property

BillAcceptor.DepositStatus Property |
 | See Also

1/18/2008

Gets the current status of the cash acceptance operation.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DepositStatus As DepositStatus
public abstract DepositStatus DepositStatus { get; }
public:
virtual property DepositStatus DepositStatus {
    DepositStatus get () abstract;
}
/** @property */
public abstract DepositStatus get_DepositStatus ()

public abstract function get DepositStatus () : DepositStatus

Remarks

Holds the current status of the cash acceptance operation. The DepositStatus property may hold one of the following values from the CashDepositStatus enumeration.

Value | Meaning
Start | Indicates that the cash acceptance started.
End | Indicates that the cash acceptance stopped.
Count | Indicates that the deposited money is counted or repaid.
Jam | Indicates that a mechanical fault has occurred.

This property is initialized and kept current while the device is enabled and is set to End after initialization.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace
CashDepositStatus
BillAcceptor.DepositAmount Property
BillAcceptor.DepositCashList Property


BillAcceptor.FullStatus Property

BillAcceptor.FullStatus Property |
 | See Also

1/18/2008

Gets the current full status of the cash slots.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property FullStatus As CashChangerFullStatus
public abstract CashChangerFullStatus FullStatus { get; }
public:
virtual property CashChangerFullStatus FullStatus {
    CashChangerFullStatus get () abstract;
}
/** @property */
public abstract CashChangerFullStatus get_FullStatus ()

public abstract function get FullStatus () : CashChangerFullStatus

Remarks

Holds the current full status of the cash slots. It may be one of the following values from the CashChangerFullStatus enumeration.

Value | Meaning
OK | Indicates that cash acceptance started.
Full | Indicates that cash acceptance stopped.
NearFull | Indicates that the deposited money is counted or repaid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace
CashChangerFullStatus
BillAcceptor.CapFullSensor Property


BillAcceptor.IsExclusiveUseDevice Property

BillAcceptor.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the Bill Acceptor is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Property Value

A Boolean value of true indicates the fiscal printer is an exclusive-use device. Otherwise, the value is false.

Remarks

An exclusive-use device has the following properties:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before accessing some properties or calling methods that update the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace
Claim
DeviceEnabled


BillAcceptor.RealTimeDataEnabled Property

BillAcceptor.RealTimeDataEnabled Property |
 | See Also

1/18/2008

Gets or sets the Boolean value indicating whether data is collected in real time.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property RealTimeDataEnabled As Boolean
public abstract bool RealTimeDataEnabled { get; set; }
public:
virtual property bool RealTimeDataEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_RealTimeDataEnabled ()

/** @property */
public abstract void set_RealTimeDataEnabled (boolean value)

public abstract function get RealTimeDataEnabled () : boolean

public abstract function set RealTimeDataEnabled (value : boolean)

Remarks

If true and CapRealTimeData is true, each fired data event updates the DepositAmount and DepositCounts properties. Otherwise, DepositAmount and DepositCounts are updated with the value of the money collected when FixDeposit is called. Setting RealTimeDataEnabled does not cause any change in system behavior until the next BeginDeposit method is performed. This prevents confusion about what would occur if it were modified between a BeginDeposit - EndDeposit pairing.

This property is initialized to false by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace
BillAcceptor.CapRealTimeData Property
BillAcceptor.DepositAmount Property
BillAcceptor.DepositCounts Property
BillAcceptor.BeginDeposit Method
BillAcceptor.EndDeposit Method
BillAcceptor.FixDeposit Method


BillAcceptor Events

BillAcceptor Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DataEvent | Notifies the application when the Bill Acceptor has accepted a bill.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

BillAcceptor Class
Microsoft.PointOfService Namespace


BillAcceptor.DataEvent Event

BillAcceptor.DataEvent Event |
 | See Also

1/18/2008

Notifies the application when the Bill Acceptor has accepted a bill.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event DataEvent As DataEventHandler
public abstract event DataEventHandler DataEvent
public:
virtual event DataEventHandler^ DataEvent {
    void add (DataEventHandler^ value) abstract;
    void remove (DataEventHandler^ value) abstract;
}
/** @event */
public abstract void add_DataEvent (DataEventHandler value)

/** @event */
public abstract void remove_DataEvent (DataEventHandler value)

See Also

Reference

BillAcceptor Class
BillAcceptor Members
Microsoft.PointOfService Namespace
BillAcceptor.DataEventEnabled Property


BillDispenser Class

BillDispenser Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a UPOS Bill Dispenser device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class BillDispenser
    Inherits PosCommon
public abstract class BillDispenser : PosCommon
public ref class BillDispenser abstract : public PosCommon
public abstract class BillDispenser extends PosCommon
public abstract class BillDispenser extends PosCommon

Remarks

Capabilities

The BillDispenser has the following capabilities:

  • Reports the cash units and corresponding unit counts available in the bill dispenser.

  • Dispenses a specified number of cash units (bills) from the device into auser-specified exit.

  • Reports jam or mechanical failure conditions within the device.

  • Support of multiple types and denominations of currency.

The BillDispenser may also have the following additional capabilities:

  • Reports the supply levels of the bill dispenser’s cash units. Conditions which may be indicated include empty and near-empty states.

  • Reports of a possible (or probable) cash count discrepancy in the data reported by the ReadCashCounts method.

Programming Model

  • The general model of a bill dispenser is as follows:

  • Supports several bill denominations. The supported bill denomination for a particular currency is noted by the list of cash units in the CurrencyCashList property.

  • Consists of any combination of features to help generate the cash processing functions such as several slots or bins which can hold the cash, and cash exits.

  • This specification provides programmatic control only for the dispensing of cash. The accepting of cash by the device (for example, to replenish cash) is controlled by the AdjustCashCounts method, unless the device can determine the cash on its own. The application can call ReadCashCounts to retrieve the current unit count for each cash unit, but cannot control when or how cash is added to the device.

  • May have multiple exits. The number of exits is specified in the DeviceExits property. The application chooses a dispensing exit by setting the CurrentExit property. The cash units which may be dispensed to the current exit are indicated by the ExitCashList property. When CurrentExit is 1, the exit is considered the primary exit which is typically used during usual processing for dispensing cash to a customer following a retail transaction. When CurrentExit is greater than 1, the exit is considered an auxiliary exit. An auxiliary exit is typically used for special purposes, such as dispensing quantities or types of cash not targeted for the primary exit.

  • Dispenses cash into the exit specified by CurrentExit when DispenseCash is called. With DispenseCash, the application specifies a count of each cash unit to be dispensed.

  • Dispenses cash either synchronously or asynchronously, depending on the value of the AsyncMode property.

  • When AsyncMode is false, the cash dispensing methods are performed synchronously and the DispenseCash method returns the completion status to the application.

  • When AsyncMode is true and no exception is thrown by DispenseCash, the method is performed asynchronously and its completion is indicated by a StatusUpdateEvent event, with the Status property of the resulting StatusUpdateEventArgs set to StatusAsync.

  • The request’s completion status is set in the AsyncResultCode and AsyncResultCodeExtended properties.

  • The values of AsyncResultCode and AsyncResultCodeExtended properties are the same as those for the ErrorCode and ErrorCodeExtended properties of a PosControlException when an error occurs during synchronous dispensing.

  • Nesting of asynchronous BillDispenser operations is illegal; only one asynchronous method can be processed at a time.

  • The ReadCashCounts method may not be called while an asynchronous method is being performed because doing this could likely report incorrect cash counts.

Device Sharing

  • The BillDispenser is an exclusive-use device, as follows:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before accessing some properties, dispensing or collecting, or receiving events.

Platforms

  • The BillDispenser class requires POS for .NET version 1.11 or later versions.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.BillDispenser
Microsoft.PointOfService.BasicServiceObjects.BillDispenserBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillDispenser Members
Microsoft.PointOfService Namespace


BillDispenser Members

BillDispenser Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a UPOS Bill Dispenser device.

The following tables list the members exposed by the BillDispenser type.

Protected Constructors

Name | Description
BillDispenser | Creates an instance of the BillDispenser class.
Top

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorOverDispense | Indicates the specified cash cannot be dispensed because of a cash shortage.
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusAsync | Indicates an asynchronously performed method has finished.
StatusEmpty | Indicates some cash slots are empty.
StatusEmptyOk | Indicates no cash slots are empty or almost empty.
StatusJam | Indicates a mechanical fault has occurred.
StatusJamOk | Indicates a mechanical fault has recovered.
StatusNearEmpty | Indicates some cash slots are almost empty.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
AsyncMode | Gets or sets a Boolean value that indicates whether BillDispenser methods are performed asynchronously.
AsyncResultCode | Gets the completion status of the last asynchronous dispense request.
AsyncResultCodeExtended | Gets the completion status of the last asynchronous dispense request.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapDiscrepancy | Gets a Boolean value that indicates whether ReadCashCounts can report effective discrepancy values.
CapEmptySensor | Gets a Boolean value that indicates whether the device can report that some cash slots are empty.
CapJamSensor | Gets a Boolean value that indicates whether the device can report that a mechanical fault has occurred in the bill dispenser.
CapNearEmptySensor | Gets a Boolean value that indicates whether the device can report that some cash slots are almost empty.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
CurrencyCashList | Gets a list of cash units supported by the bill dispenser for the currency represented by the CurrencyCode property.
CurrencyCode | Gets or sets the active currency code to be used by BillDispenser operations.
CurrencyCodeList | Gets a list of ASCII 3-character ISO 4217 currency codes, separated by commas.
CurrentExit | Gets or sets a value that indicates the current cash dispensing exit.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceExits | Gets the number of exits for dispensing cash.
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
DeviceStatus | Gets the current status of the BillDispenser.
ExitCashList | Gets the list of cash units that can be dispensed to the exit indicated by the CurrentExit property.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether the bill dispenser is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
AdjustCashCounts | Sets or adjusts the cash count in the bill dispenser.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
DispenseCash | Dispenses the specified cash units and cash counts from the device.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon)
ReadCashCounts | Reads the current cash counts in the bill dispenser.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

BillDispenser Class
Microsoft.PointOfService Namespace


BillDispenser Fields

BillDispenser Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorOverDispense | Indicates the specified cash cannot be dispensed because of a cash shortage.
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusAsync | Indicates an asynchronously performed method has finished.
StatusEmpty | Indicates some cash slots are empty.
StatusEmptyOk | Indicates no cash slots are empty or almost empty.
StatusJam | Indicates a mechanical fault has occurred.
StatusJamOk | Indicates a mechanical fault has recovered.
StatusNearEmpty | Indicates some cash slots are almost empty.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

BillDispenser Class
Microsoft.PointOfService Namespace


BillDispenser.ExtendedErrorOverDispense Field

BillDispenser.ExtendedErrorOverDispense Field |
 | See Also

1/18/2008

Indicates the specified cash cannot be dispensed because of a cash shortage.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorOverDispense As Integer
public const int ExtendedErrorOverDispense
public:
literal int ExtendedErrorOverDispense
public static final int ExtendedErrorOverDispense
public const var ExtendedErrorOverDispense : int

Remarks

This value is contained by the ErrorCodeExtended property of the PosControlException class when a cash shortage has been detected during a DispenseCash operation.

See Also

Reference

BillDispenser Class
BillDispenser Members
Microsoft.PointOfService Namespace
DispenseCash
PosControlException


BillDispenser.StatusAsync Field

BillDispenser.StatusAsync Field |
 | See Also

1/18/2008

Indicates an asynchronously performed method has finished.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusAsync As Integer
public const int StatusAsync
public:
literal int StatusAsync
public static final int StatusAsync
public const var StatusAsync : int

Remarks

This value is returned by a StatusUpdateEvent in the Status property.

See Also

Reference

BillDispenser Class
BillDispenser Members
Microsoft.PointOfService Namespace


BillDispenser.StatusEmpty Field

BillDispenser.StatusEmpty Field |
 | See Also

1/18/2008

Indicates some cash slots are empty.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusEmpty As Integer
public const int StatusEmpty
public:
literal int StatusEmpty
public static final int StatusEmpty
public const var StatusEmpty : int

Remarks

This value is returned by a StatusUpdateEvent in the Status property.

See Also

Reference

BillDispenser Class
BillDispenser Members
Microsoft.PointOfService Namespace


BillDispenser.StatusEmptyOk Field

BillDispenser.StatusEmptyOk Field |
 | See Also

1/18/2008

Indicates no cash slots are empty or almost empty.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusEmptyOk As Integer
public const int StatusEmptyOk
public:
literal int StatusEmptyOk
public static final int StatusEmptyOk
public const var StatusEmptyOk : int

Remarks

This value is returned by a StatusUpdateEvent in the Status property.

See Also

Reference

BillDispenser Class
BillDispenser Members
Microsoft.PointOfService Namespace


BillDispenser.StatusJam Field

BillDispenser.StatusJam Field |
 | See Also

1/18/2008

Indicates a mechanical fault has occurred.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusJam As Integer
public const int StatusJam
public:
literal int StatusJam
public static final int StatusJam
public const var StatusJam : int

Remarks

This value is returned by a StatusUpdateEvent in the Status property.

See Also

Reference

BillDispenser Class
BillDispenser Members
Microsoft.PointOfService Namespace


BillDispenser.StatusJamOk Field

BillDispenser.StatusJamOk Field |
 | See Also

1/18/2008

Indicates a mechanical fault has recovered.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusJamOk As Integer
public const int StatusJamOk
public:
literal int StatusJamOk
public static final int StatusJamOk
public const var StatusJamOk : int

See Also

Reference

BillDispenser Class
BillDispenser Members
Microsoft.PointOfService Namespace


BillDispenser.StatusNearEmpty Field

BillDispenser.StatusNearEmpty Field |
 | See Also

1/18/2008

Indicates some cash slots are almost empty.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusNearEmpty As Integer
public const int StatusNearEmpty
public:
literal int StatusNearEmpty
public static final int StatusNearEmpty
public const var StatusNearEmpty : int

Remarks

This value is returned by a StatusUpdateEvent in the Status property.

See Also

Reference

BillDispenser Class
BillDispenser Members
Microsoft.PointOfService Namespace


BillDispenser Constructor

BillDispenser Constructor |
 | See Also

1/18/2008

Creates an instance of the BillDispenser class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected BillDispenser ()
protected:
BillDispenser ()
protected BillDispenser ()
protected function BillDispenser ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

BillDispenser Class
BillDispenser Members
Microsoft.PointOfService Namespace


BillDispenser Methods

BillDispenser Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
AdjustCashCounts | Sets or adjusts the cash count in the bill dispenser.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
DispenseCash | Dispenses the specified cash units and cash counts from the device.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon )
ReadCashCounts | Reads the current cash counts in the bill dispenser.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

BillDispenser Class
Microsoft.PointOfService Namespace


BillDispenser.AdjustCashCounts Method

BillDispenser.AdjustCashCounts Method |
 | See Also

1/18/2008

Sets or adjusts the cash count in the bill dispenser.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub AdjustCashCounts ( _
    cashCounts As IEnumerable(Of CashCount) _
)
public abstract void AdjustCashCounts (
    IEnumerable<CashCount> cashCounts
)
public:
virtual void AdjustCashCounts (
    IEnumerable<CashCount>^ cashCounts
) abstract
public abstract void AdjustCashCounts (
    IEnumerable<CashCount> cashCounts
)
public abstract function AdjustCashCounts (
    cashCounts : IEnumerable<CashCount>
)

Parameters

cashCounts

Indicates the cash types and amounts to be initialized.

Remarks

This method is called to set the initial amounts in the BillDispenser after initial setup, or to adjust cash counts after replenishment or removal, such as a paid-in or paid-out operation. This method may be called when needed for devices which cannot automatically detect the cash within them. If the device can automatically determine the exact amount, this method call is ignored.

In typical use, the application first calls ReadCashCounts for the current counts, and then adjusts them by the amounts replenished or removed. Then, the application calls AdjustCashCounts to set the amounts currently in the Bill Dispenser.

To reset all cash counts to zero, set each denomination amount to zero.

Invoking this method can cause general exceptions to be thrown and PosControlExceptions with the following ErrorCode value.

Value | Meaning
Busy | Cash units and counts cannot be initialized because an asynchronous method is in progress.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillDispenser Class
BillDispenser Members
Microsoft.PointOfService Namespace
ReadCashCounts


BillDispenser.DispenseCash Method

BillDispenser.DispenseCash Method |
 | See Also

1/18/2008

Dispenses the specified cash units and cash counts from the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub DispenseCash ( _
    cashCounts As IEnumerable(Of CashCount) _
)
public abstract void DispenseCash (
    IEnumerable<CashCount> cashCounts
)
public:
virtual void DispenseCash (
    IEnumerable<CashCount>^ cashCounts
) abstract
public abstract void DispenseCash (
    IEnumerable<CashCount> cashCounts
)
public abstract function DispenseCash (
    cashCounts : IEnumerable<CashCount>
)

Parameters

cashCounts

Indicates the dispensing cash units and counts.

Remarks

Dispenses cash from the bill dispenser to the exit specified by CurrentExit.

This method is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

DispenseCash can throw general exceptions, and PosControlExceptions with the following ErrorCode values.

Value | Meaning
Busy | Cash cannot be dispensed because an asynchronous method is in progress.
Illegal | The cashCounts parameter value was illegal for the current exit.
ExtendedErrorOverDispense | The specified cash cannot be dispensed because of a cash shortage.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillDispenser Class
BillDispenser Members
Microsoft.PointOfService Namespace
AsyncMode
CurrentExit


BillDispenser.ReadCashCounts Method

BillDispenser.ReadCashCounts Method |
 | See Also

1/18/2008

Reads the current cash counts in the bill dispenser.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function ReadCashCounts As CashCounts
public abstract CashCounts ReadCashCounts ()
public:
virtual CashCounts ReadCashCounts () abstract
public abstract CashCounts ReadCashCounts ()
public abstract function ReadCashCounts () : CashCounts

Return Value

A CashCounts structure representing the cash in the bill dispenser.

Remarks

The format of the CashCounts structure is the same as CashCounts in the DispenseCash method. Each unit in CashCounts matches a unit in the CurrencyCashList property, and is in the same order.

If CapDiscrepancy is false, Discrepancy is always false.

Usually, the cash total returned is equal to the cash total in the bill dispenser. There are some cases in which a discrepancy may occur because of existing uncountable cash in a bill dispenser. An example would be when a bill dispenser has diverted an unusable bill to a holding area.

ReadCashCounts can throw general exceptions, and PosControlExceptions with the following ErrorCode value,

Value | Meaning
Busy | Cash units and counts cannot be read because an asynchronous method is in progress.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillDispenser Class
BillDispenser Members
Microsoft.PointOfService Namespace
CapDiscrepancy
CurrencyCashList
BillDispenser.DispenseCash Method


BillDispenser Properties

BillDispenser Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
AsyncMode | Gets or sets a Boolean value that indicates whether BillDispenser methods are performed asynchronously.
AsyncResultCode | Gets the completion status of the last asynchronous dispense request.
AsyncResultCodeExtended | Gets the completion status of the last asynchronous dispense request.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapDiscrepancy | Gets a Boolean value that indicates whether ReadCashCounts can report effective discrepancy values.
CapEmptySensor | Gets a Boolean value that indicates whether the device can report that some cash slots are empty.
CapJamSensor | Gets a Boolean value that indicates whether the device can report that a mechanical fault has occurred in the bill dispenser.
CapNearEmptySensor | Gets a Boolean value that indicates whether the device can report that some cash slots are almost empty.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
CurrencyCashList | Gets a list of cash units supported by the bill dispenser for the currency represented by the CurrencyCode property.
CurrencyCode | Gets or sets the active currency code to be used by BillDispenser operations.
CurrencyCodeList | Gets a list of ASCII 3-character ISO 4217 currency codes, separated by commas.
CurrentExit | Gets or sets a value that indicates the current cash dispensing exit.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceExits | Gets the number of exits for dispensing cash.
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
DeviceStatus | Gets the current status of the BillDispenser.
ExitCashList | Gets the list of cash units that can be dispensed to the exit indicated by the CurrentExit property.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether the bill dispenser is an exclusive-use device.

See Also

Reference

BillDispenser Class
Microsoft.PointOfService Namespace


BillDispenser.AsyncMode Property

BillDispenser.AsyncMode Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether BillDispenser methods are performed asynchronously.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AsyncMode As Boolean
public abstract bool AsyncMode { get; set; }
public:
virtual property bool AsyncMode {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_AsyncMode ()

/** @property */
public abstract void set_AsyncMode (boolean value)

public abstract function get AsyncMode () : boolean

public abstract function set AsyncMode (value : boolean)

Remarks

If true, the DispenseCash method are performed asynchronously. If false, DispenseCash are performed synchronously.

This property is initialized to false when the Open method is called.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillDispenser Class
BillDispenser Members
Microsoft.PointOfService Namespace
AsyncResultCode
AsyncResultCodeExtended
BillDispenser.DispenseCash Method


BillDispenser.AsyncResultCode Property

BillDispenser.AsyncResultCode Property |
 | See Also

1/18/2008

Gets the completion status of the last asynchronous dispense request.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property AsyncResultCode As Integer
public abstract int AsyncResultCode { get; }
public:
virtual property int AsyncResultCode {
    int get () abstract;
}
/** @property */
public abstract int get_AsyncResultCode ()

public abstract function get AsyncResultCode () : int

Remarks

Holds the completion status of the last asynchronous dispense request, that is, when the DispenseCash method was called with AsyncMode set to true.

This property is set before a StatusUpdateEvent event is delivered with a Status value of StatusAsync.

The value of AsyncResultCode is the same as the value that would have been set in the ErrorCode property, had the method been performed synchronously.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillDispenser Class
BillDispenser Members
Microsoft.PointOfService Namespace
BillDispenser.AsyncMode Property
BillDispenser.DispenseCash Method


BillDispenser.AsyncResultCodeExtended Property

BillDispenser.AsyncResultCodeExtended Property |
 | See Also

1/18/2008

Gets the completion status of the last asynchronous dispense request.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property AsyncResultCodeExtended As Integer
public abstract int AsyncResultCodeExtended { get; }
public:
virtual property int AsyncResultCodeExtended {
    int get () abstract;
}
/** @property */
public abstract int get_AsyncResultCodeExtended ()

public abstract function get AsyncResultCodeExtended () : int

Remarks

Holds the completion status of the last asynchronous dispense request, that is, when the DispenseCash method was called with AsyncMode set to true.

This property is set before a StatusUpdateEvent event is delivered with a Status value of StatusAsync.

The value of AsyncResultCodeExtended is the same as the value that would have been set in the ErrorCodeExtended property, had the method been performed synchronously.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillDispenser Class
BillDispenser Members
Microsoft.PointOfService Namespace
BillDispenser.AsyncMode Property
BillDispenser.DispenseCash Method
BillDispenser.AsyncResultCode Property


BillDispenser.CapDiscrepancy Property

BillDispenser.CapDiscrepancy Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether ReadCashCounts can report effective discrepancy values.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapDiscrepancy As Boolean
public abstract bool CapDiscrepancy { get; }
public:
virtual property bool CapDiscrepancy {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapDiscrepancy ()

public abstract function get CapDiscrepancy () : boolean

Remarks

If true, the ReadCashCounts method can report effective discrepancy values.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillDispenser Class
BillDispenser Members
Microsoft.PointOfService Namespace
BillDispenser.ReadCashCounts Method


BillDispenser.CapEmptySensor Property

BillDispenser.CapEmptySensor Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device can report that some cash slots are empty.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapEmptySensor As Boolean
public abstract bool CapEmptySensor { get; }
public:
virtual property bool CapEmptySensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapEmptySensor ()

public abstract function get CapEmptySensor () : boolean

Remarks

If true, the BillDispenser can report the condition that some cash slots are empty.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillDispenser Class
BillDispenser Members
Microsoft.PointOfService Namespace
DeviceStatus
StatusUpdateEvent


BillDispenser.CapJamSensor Property

BillDispenser.CapJamSensor Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device can report that a mechanical fault has occurred in the bill dispenser.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapJamSensor As Boolean
public abstract bool CapJamSensor { get; }
public:
virtual property bool CapJamSensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapJamSensor ()

public abstract function get CapJamSensor () : boolean

Remarks

If true, the BillDispenser can report the occurrence of a mechanical fault in the bill dispenser.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillDispenser Class
BillDispenser Members
Microsoft.PointOfService Namespace
DeviceStatus
StatusUpdateEvent


BillDispenser.CapNearEmptySensor Property

BillDispenser.CapNearEmptySensor Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device can report that some cash slots are almost empty.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapNearEmptySensor As Boolean
public abstract bool CapNearEmptySensor { get; }
public:
virtual property bool CapNearEmptySensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapNearEmptySensor ()

public abstract function get CapNearEmptySensor () : boolean

Property Value

If true, the bill dispenser can report the condition that some cash slots are almost empty. This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillDispenser Class
BillDispenser Members
Microsoft.PointOfService Namespace
DeviceStatus
StatusUpdateEvent


BillDispenser.CurrencyCashList Property

BillDispenser.CurrencyCashList Property |
 | See Also Example

1/18/2008

Gets a list of cash units supported by the bill dispenser for the currency represented by the CurrencyCode property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CurrencyCashList As CashUnits
public abstract CashUnits CurrencyCashList { get; }
public:
virtual property CashUnits CurrencyCashList {
    CashUnits get () abstract;
}
/** @property */
public abstract CashUnits get_CurrencyCashList ()

public abstract function get CurrencyCashList () : CashUnits

Remarks

CurrencyCashList holds a CashUnits structure that contains an array of supported cash units in the currency represented by the CurrencyCode property.

The CashUnits structure actually contains two integer arrays that contain units of bills and coins that can be used with both Cash Changers, Bill Dispensers, and other devices.

Bill Dispensers only use the Bills array of CashUnits.

This property is initialized by the Open method, and is updated when CurrencyCode is set.

Example

The following is a sample of typical CurrencyCashList values in Japan:

  • 1000, 5000, 10000

These values in the Bills array of the CashUnits structure held by CurrencyCashList would indicate that 1000, 5000, and 10000-yen bills may be used with this bill dispenser.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillDispenser Class
BillDispenser Members
Microsoft.PointOfService Namespace
CurrencyCode
CashUnits


BillDispenser.CurrencyCode Property

BillDispenser.CurrencyCode Property |
 | See Also

1/18/2008

Gets or sets the active currency code to be used by BillDispenser operations.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property CurrencyCode As String
public abstract string CurrencyCode { get; set; }
public:
virtual property String^ CurrencyCode {
    String^ get () abstract;
    void set (String^ value) abstract;
}
/** @property */
public abstract String get_CurrencyCode ()

/** @property */
public abstract void set_CurrencyCode (String value)

public abstract function get CurrencyCode () : String

public abstract function set CurrencyCode (value : String)

Remarks

This property is initialized to an appropriate value by the Open method. This value is guaranteed to be one of the set of currencies specified by the CurrencyCodeList property.

Setting CurrencyCode can cause general exceptions to be thrown, and PosControlException exceptions with the following values in ErrorCode.

Value | Meaning
Illegal | A value was specified that is not within CurrencyCodeList.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillDispenser Class
BillDispenser Members
Microsoft.PointOfService Namespace
CurrencyCodeList


BillDispenser.CurrencyCodeList Property

BillDispenser.CurrencyCodeList Property |
 | See Also Example

1/18/2008

Gets a list of ASCII 3-character ISO 4217 currency codes, separated by commas.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CurrencyCodeList As String()
public abstract string[] CurrencyCodeList { get; }
public:
virtual property array<String^>^ CurrencyCodeList {
    array<String^>^ get () abstract;
}
/** @property */
public abstract String[] get_CurrencyCodeList ()

public abstract function get CurrencyCodeList () : String[]

Remarks

This parameter is initialized by the Open method.

Example

The string "JPY,USD" indicates that the Bill Dispenser supports both Japanese and U.S. monetary units.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillDispenser Class
BillDispenser Members
Microsoft.PointOfService Namespace
BillDispenser.CurrencyCode Property


BillDispenser.CurrentExit Property

BillDispenser.CurrentExit Property |
 | See Also Example

1/18/2008

Gets or sets a value that indicates the current cash dispensing exit.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property CurrentExit As Integer
public abstract int CurrentExit { get; set; }
public:
virtual property int CurrentExit {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_CurrentExit ()

/** @property */
public abstract void set_CurrentExit (int value)

public abstract function get CurrentExit () : int

public abstract function set CurrentExit (value : int)

Remarks

The value 1 represents the primary exit or usual exit, while values greater than 1 represent auxiliary exits. Legal values range from 1 to the value held by DeviceExits.

This property is initialized to 1 by the Open method.

Accessing CurrentExit can cause general exceptions to be thrown, and PosControlExceptions with the following ErrorCode value.

Value | Meaning
Illegal | An invalid CurrentExit is specified.

Example

The following is an example of a typical property set value in Japan. CurrencyCode is "JPY" and CurrencyCodeList is "JPY".

  • The bill dispenser uses two exits; an auxiliary exit is used for dispensing bills of higher value:CurrencyCashList = ";1000,5000,10000"DeviceExits = 2When CurrentExit = 1 : ExitCashList = ";1000,5000"When CurrentExit = 2 : ExitCashList = ";1000,5000,10000"

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillDispenser Class
BillDispenser Members
Microsoft.PointOfService Namespace


BillDispenser.DeviceExits Property

BillDispenser.DeviceExits Property |
 | See Also

1/18/2008

Gets the number of exits for dispensing cash.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DeviceExits As Integer
public abstract int DeviceExits { get; }
public:
virtual property int DeviceExits {
    int get () abstract;
}
/** @property */
public abstract int get_DeviceExits ()

public abstract function get DeviceExits () : int

Remarks

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillDispenser Class
BillDispenser Members
Microsoft.PointOfService Namespace
BillDispenser.CurrentExit Property


BillDispenser.DeviceStatus Property

BillDispenser.DeviceStatus Property |
 | See Also

1/18/2008

Gets the current status of the BillDispenser.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DeviceStatus As CashChangerStatus
public abstract CashChangerStatus DeviceStatus { get; }
public:
virtual property CashChangerStatus DeviceStatus {
    CashChangerStatus get () abstract;
}
/** @property */
public abstract CashChangerStatus get_DeviceStatus ()

public abstract function get DeviceStatus () : CashChangerStatus

Remarks

The value held by DeviceStatus is one of the values from CashChangerStatus.

Value | Description
OK | The current condition of the bill dispenser is satisfactory
Empty | Some cash slots are empty.
NearEmpty | Some cash slots are almost empty.
Jam | A mechanical fault has occurred.

This property is initialized by the Open method, and kept current while the device is enabled. If more than one condition is present, the value represents the most important condition.

The order of precedence, from most critical to least critical is as follows: Jam, Empty, NearEmpty, and OK.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillDispenser Class
BillDispenser Members
Microsoft.PointOfService Namespace


BillDispenser.ExitCashList Property

BillDispenser.ExitCashList Property |
 | See Also

1/18/2008

Gets the list of cash units that can be dispensed to the exit indicated by the CurrentExit property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ExitCashList As CashUnits
public abstract CashUnits ExitCashList { get; }
public:
virtual property CashUnits ExitCashList {
    CashUnits get () abstract;
}
/** @property */
public abstract CashUnits get_ExitCashList ()

public abstract function get ExitCashList () : CashUnits

Remarks

The supported cash units may be all, or a subset, of the values in CurrencyCashList. The string format is identical to that of CurrencyCashList.

This property is initialized by the Open method, and is updated when CurrencyCode or CurrentExit is set.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillDispenser Class
BillDispenser Members
Microsoft.PointOfService Namespace
CashUnits
BillDispenser.CurrencyCode Property
BillDispenser.CurrencyCashList Property
BillDispenser.CurrentExit Property


BillDispenser.IsExclusiveUseDevice Property

BillDispenser.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the bill dispenser is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Property Value

A value of true indicates the fiscal printer is an exclusive-use device. Otherwise, the value is false.

Remarks

An exclusive-use device has the following properties:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before accessing some properties or calling methods that update the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BillDispenser Class
BillDispenser Members
Microsoft.PointOfService Namespace


BillDispenser Events

BillDispenser Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

BillDispenser Class
Microsoft.PointOfService Namespace


BinaryConversion Enumeration

BinaryConversion Enumeration |
 | See Also

1/18/2008

Enumerates the possible binary conversion methods for legacy controls.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration BinaryConversion
public enum BinaryConversion
public enum class BinaryConversion
public enum BinaryConversion
public enum BinaryConversion

Members

Member name | Description
Decimal | Each byte is converted into three characters. This option provides for the easiest conversion between binary and ASCII characters for Visual Basic and similar languages.
Nibble | Each byte is converted into two characters. This option provides for the fastest conversion between binary and ASCII characters.
None | Data is placed one byte per character, with no conversion. This is the default.

Remarks

Used by the BinaryConversion property of the ILegacyControlObject class.

Note:
This enumeration only applies to legacy OPOS controls.

See Also

Reference

Microsoft.PointOfService Namespace
BinaryConversion


Biometrics Class

Biometrics Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a UPOS Biometrics device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class Biometrics
    Inherits PosCommon
public abstract class Biometrics : PosCommon
public ref class Biometrics abstract : public PosCommon
public abstract class Biometrics extends PosCommon
public abstract class Biometrics extends PosCommon

Remarks

Biometrics devices capture data by using a biometrics sensor. The biometrics data is encoded in Biometrics Information Records, each of which contains one or more Biometrics Data Blocks which in turn contain one or more biometric data samples or biometric templates.

This standard model uses the term template, as adapted from the BioAPI to refer to the biometric enrollment data for a user. The term Biometric Information Record refers to any biometric data that is returned to the application. This includes raw data, intermediate data, processed samples ready for verification or identification, and enrollment data. Typically, the only data that is stored persistently by the application is the Biometrics Information Record generated for enrollment.

The format of the Biometric Data Blocks is indicated by the Format field of the Header. This may be a standard or proprietary format. In this case, the Biometric Data Block may be encrypted. The digital signature is optional, and may be used to verify integrity of the data during transmission and storage. When present, the digital signature is calculated on the Header and the Biometric Data Block. For standardized Biometrics Information Record formats, the signature would take a standard form, but, for proprietary Biometrics Information Record formats, the signature can take any form that suits the Service. Therefore, there is no C structure definition of the signature. The Biometrics Information Record Data Type indicates whether the Biometrics Information Record is signed and encrypted or only encrypted.

Capabilities

All Biometrics devices have the following capabilities:

  • The device can capture Biometrics data for enrollment. The notion of enrollment requires better quality for the final Biometrics Information Record that is created. Generally, the Biometrics Information Record aggregates a series of biometric captures.

  • The device may capture Biometrics data for verification. Verification does not require the same level of quality as enrollment.

  • The device can determine whether two Biometrics Information Records match within the degree of error specified by the False Accept Rate (FAR) and False Reject Rate (FRR). The FAR is the margin of percentage error acceptable that two nonmatching biometric samples are falsely regarded as not matching.

  • The device can compare a Biometrics Information Record against a sample population of Biometrics Information Records and create a rank ordering of the population for identification.

Some Biometrics devices may have the following additional capabilities:

  • The device returns the raw biometric data in "real time" as it is captured by the device. If this capability is true and has been enabled by the application having set the RealTimeDataEnabled property to true, a series of StatusUpdateEvent are queued, each as a raw image representing a partial biometrics image capture.

Programming Model

The Biometrics device usage model is as follows:

The Biometrics Device follows the general Device Input Model for event driven input:

  • When input is received by the Service, it queues a DataEvent event.

  • If AutoDisable is true, the Device automatically disables itself when a DataEvent event is queued.

  • A queued DataEvent event can be delivered to the application when the property DataEventEnabled is true and other event delivery requirements are met. Just before delivering this event, data is copied into properties, and additional data events are disabled by setting DataEventEnabled to false. This causes later input data to be queued while the application processes the current input and associated properties. When the application has finished processing the current input and is ready for more data, it re-enables events by setting DataEventEnabled to true.

  • A ErrorEvent event is queued if an error occurs while collecting or processing input, and is delivered to the application when DataEventEnabled is true and other event delivery requirements are met.

  • The DataCount property may be read to obtain the number of queued DataEvent events.

  • All queued input may be deleted by calling the ClearInput method.

  • Deviations from the general Device Input Model for event-driven input are as follows:

  • The capture of biometrics data begins when the BeginEnrollCapture or BeginVerifyCapture method is called.

  • If biometrics capture is stopped by calling EndCapture then no DataEvent or ErrorEvent events will be queued.

Device Sharing

The Biometrics device is exclusive-use, as follows:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before the application accesses many of the Biometrics specific properties.

  • The application must claim and enable the device before the application calls methods that manipulate the device or before the application changes some writable properties.

Platforms

The Biometrics class requires POS for .NET version 1.10 or later versions.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.Biometrics
Microsoft.PointOfService.BasicServiceObjects.BiometricsBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Biometrics Members
Microsoft.PointOfService Namespace


Biometrics Members

Biometrics Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a UPOS Biometrics device.

The following tables list the members exposed by the Biometrics type.

Protected Constructors

Name | Description
Biometrics | Creates an instance of the Biometrics class.
Top

Public Fields

Name | Description
DataEventEnroll | Indicates the status of enrollment for captured biometrics data.
DataEventVerify | Indicates the status of data verification for captured biometrics data.
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticAverageFalseAcceptRate | Indicates the average false acceptance rate.
StatisticAverageFalseRejectRate | Indicates the average false rejection rate.
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticSuccessfulMatchCount | Increments the number when a match is completed successfully.
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatisticUnsuccessfulMatchCount | Increments the number when a match is completed unsuccessfully.
StatusMoveAway | Indicates that the position was too close.
StatusMoveBackward | Indicates that the position was too far forward.
StatusMoveCloser | Indicates that the position was too far away.
StatusMoveDown | Indicates that the position was too high.
StatusMoveFaster | Indicates that the motion was too slow.
StatusMoveForward | Indicates that the position was too far backward.
StatusMoveLeft | Indicates that the position was too far to the right.
StatusMoveRight | Indicates that the position was too far to the left.
StatusMoveSlower | Indicates that the motion was too fast.
StatusMoveUp | Indicates that the position was too low.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusRawData | Indicates that raw image data is available.
StatusSensorComplete |
StatusSensorDirty | Indicates that the sensor is dirty.
StatusSensorReady |
StatusUnspecifiedReadFailure |
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
UseDefault |
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
Algorithm | Gets or sets the biometric algorithm that is used for generating the biometrics template.
AlgorithmList | Gets the list of algorithms that are supported by the Biometrics device.
AutoDisable | Gets or sets a Boolean value that indicates whether the device is disabled after data is received.
BiometricsInformationRecord | Gets the biometric enrollment data that is returned to the application.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapPrematchData | Gets a Boolean value that indicates whether the server can use Match-On-Card SmartCard technology to generate a processed BiometricsInformationRecord.
CapRawSensorData | Gets a Boolean value that indicates whether the service may return unprocessed data from the biometrics sensor.
CapRealTimeData | Gets a Boolean value that indicates whether the biometrics device may supply unprocessed biometrics data as it is captured.
CapSensorColor | Gets a value or combination of values that indicates whether the biometrics device supports image formats other than bi-tonal.
CapSensorOrientation | Gets a value that indicates whether the sensor image should be rotated before processing, and to what degree.
CapSensorType | Gets a value that indicates the type of biometric data that the sensor records.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapTemplateAdaptation | Gets a Boolean value that indicates whether an adapted Biometrics Information Record can be returned by the service.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
DataCount | Gets the number of currently queued DataEvent events.
DataEventEnabled | Get or sets a Boolean value that indicates whether a DataEvent event is delivered when input data is queued.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
RawSensorData | Gets an unprocessed biometrics image as raw pixel data.
RealTimeDataEnabled | Gets or sets a Boolean value that indicates whether biometrics data is queued as it is captured.
SensorColor | Gets or sets which image capture mode will be applied to new biometrics data.
SensorOrientation | Gets or sets the requested orientation adjustment to the received sensor data before BiometricsInformationRecord creation.
SensorType | Gets or sets the type of biometrics sensor being accessed.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether Biometrics is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
BeginEnrollCapture | Begins capturing biometrics data for enrollment.
BeginVerifyCapture | Begins capturing biometrics data for verification.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all buffered device input.
ClearInputProperties | Resets the values of properties altered by DataEvent or ErrorEvent.
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
EndCapture | Ends the capturing of biometrics data.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Identify | Captures biometrics data, compares it to an array of BiometricsInformationRecords, and then returns a rank ordered array of indexes.
IdentifyMatch | Compares a sample Biometrics Information Record against the entries of a collection of other Biometrics Information Records, and then returns a rank ordered array of indexes.
Open | Opens a device for later input/output processing. (inherited from PosCommon)
ProcessPrematchData | Creates biometric samples for use by Match-On-Card and enabled Match-On-Card implementations that require prematch data before matching operations.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
Verify | Captures biometrics data and compares it against a designated Biometrics Information Record.
VerifyMatch | Indicates the event type for DataEvent events.
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DataEvent | Notifies the application that input data is available.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
ErrorEvent | Notifies the application that a Biometrics device error has been detected and that a suitable response by the application is necessary to process the error condition.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

Biometrics Class
Microsoft.PointOfService Namespace


Biometrics Fields

Biometrics Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
DataEventEnroll | Indicates the status of enrollment for captured biometrics data.
DataEventVerify | Indicates the status of data verification for captured biometrics data.
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticAverageFalseAcceptRate | Indicates the average false acceptance rate.
StatisticAverageFalseRejectRate | Indicates the average false rejection rate.
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticSuccessfulMatchCount | Increments the number when a match is completed successfully.
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatisticUnsuccessfulMatchCount | Increments the number when a match is completed unsuccessfully.
StatusMoveAway | Indicates that the position was too close.
StatusMoveBackward | Indicates that the position was too far forward.
StatusMoveCloser | Indicates that the position was too far away.
StatusMoveDown | Indicates that the position was too high.
StatusMoveFaster | Indicates that the motion was too slow.
StatusMoveForward | Indicates that the position was too far backward.
StatusMoveLeft | Indicates that the position was too far to the right.
StatusMoveRight | Indicates that the position was too far to the left.
StatusMoveSlower | Indicates that the motion was too fast.
StatusMoveUp | Indicates that the position was too low.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusRawData | Indicates that raw image data is available.
StatusSensorComplete |
StatusSensorDirty | Indicates that the sensor is dirty.
StatusSensorReady |
StatusUnspecifiedReadFailure |
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
UseDefault |
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

Biometrics Class
Microsoft.PointOfService Namespace


Biometrics.DataEventEnroll Field

Biometrics.DataEventEnroll Field |
 | See Also

1/18/2008

Indicates the status of enrollment for captured biometrics data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const DataEventEnroll As Integer
public const int DataEventEnroll
public:
literal int DataEventEnroll
public static final int DataEventEnroll
public const var DataEventEnroll : int

Remarks

DataEventEnroll is used as a status parameter of a DataEvent.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace


Biometrics.DataEventVerify Field

Biometrics.DataEventVerify Field |
 | See Also

1/18/2008

Indicates the status of data verification for captured biometrics data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const DataEventVerify As Integer
public const int DataEventVerify
public:
literal int DataEventVerify
public static final int DataEventVerify
public const var DataEventVerify : int

Remarks

DataEventVerify is used as a status parameter of a DataEvent event.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace


Biometrics.StatisticAverageFalseAcceptRate Field

Biometrics.StatisticAverageFalseAcceptRate Field |
 | See Also

1/18/2008

Indicates the average false acceptance rate.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticAverageFalseAcceptRate As String
public const string StatisticAverageFalseAcceptRate
public:
literal String^ StatisticAverageFalseAcceptRate
public static final String StatisticAverageFalseAcceptRate
public const var StatisticAverageFalseAcceptRate : String

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace


Biometrics.StatisticAverageFalseRejectRate Field

Biometrics.StatisticAverageFalseRejectRate Field |
 | See Also

1/18/2008

Indicates the average false rejection rate.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticAverageFalseRejectRate As String
public const string StatisticAverageFalseRejectRate
public:
literal String^ StatisticAverageFalseRejectRate
public static final String StatisticAverageFalseRejectRate
public const var StatisticAverageFalseRejectRate : String

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace


Biometrics.StatisticSuccessfulMatchCount Field

Biometrics.StatisticSuccessfulMatchCount Field |
 | See Also

1/18/2008

Increments the number when a match is completed successfully.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticSuccessfulMatchCount As String
public const string StatisticSuccessfulMatchCount
public:
literal String^ StatisticSuccessfulMatchCount
public static final String StatisticSuccessfulMatchCount
public const var StatisticSuccessfulMatchCount : String

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace


Biometrics.StatisticUnsuccessfulMatchCount Field

Biometrics.StatisticUnsuccessfulMatchCount Field |
 | See Also

1/18/2008

Increments the number when a match is completed unsuccessfully.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticUnsuccessfulMatchCount As String
public const string StatisticUnsuccessfulMatchCount
public:
literal String^ StatisticUnsuccessfulMatchCount
public static final String StatisticUnsuccessfulMatchCount
public const var StatisticUnsuccessfulMatchCount : String

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace


Biometrics.StatusMoveAway Field

Biometrics.StatusMoveAway Field |
 | See Also

1/18/2008

Indicates that the position was too close.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusMoveAway As Integer
public const int StatusMoveAway
public:
literal int StatusMoveAway
public static final int StatusMoveAway
public const var StatusMoveAway : int

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace


Biometrics.StatusMoveBackward Field

Biometrics.StatusMoveBackward Field |
 | See Also

1/18/2008

Indicates that the position was too far forward.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusMoveBackward As Integer
public const int StatusMoveBackward
public:
literal int StatusMoveBackward
public static final int StatusMoveBackward
public const var StatusMoveBackward : int

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace


Biometrics.StatusMoveCloser Field

Biometrics.StatusMoveCloser Field |
 | See Also

1/18/2008

Indicates that the position was too far away.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusMoveCloser As Integer
public const int StatusMoveCloser
public:
literal int StatusMoveCloser
public static final int StatusMoveCloser
public const var StatusMoveCloser : int

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace


Biometrics.StatusMoveDown Field

Biometrics.StatusMoveDown Field |
 | See Also

1/18/2008

Indicates that the position was too high.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusMoveDown As Integer
public const int StatusMoveDown
public:
literal int StatusMoveDown
public static final int StatusMoveDown
public const var StatusMoveDown : int

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace


Biometrics.StatusMoveFaster Field

Biometrics.StatusMoveFaster Field |
 | See Also

1/18/2008

Indicates that the motion was too slow.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusMoveFaster As Integer
public const int StatusMoveFaster
public:
literal int StatusMoveFaster
public static final int StatusMoveFaster
public const var StatusMoveFaster : int

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace


Biometrics.StatusMoveForward Field

Biometrics.StatusMoveForward Field |
 | See Also

1/18/2008

Indicates that the position was too far backward.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusMoveForward As Integer
public const int StatusMoveForward
public:
literal int StatusMoveForward
public static final int StatusMoveForward
public const var StatusMoveForward : int

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace


Biometrics.StatusMoveLeft Field

Biometrics.StatusMoveLeft Field |
 | See Also

1/18/2008

Indicates that the position was too far to the right.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusMoveLeft As Integer
public const int StatusMoveLeft
public:
literal int StatusMoveLeft
public static final int StatusMoveLeft
public const var StatusMoveLeft : int

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace


Biometrics.StatusMoveRight Field

Biometrics.StatusMoveRight Field |
 | See Also

1/18/2008

Indicates that the position was too far to the left.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusMoveRight As Integer
public const int StatusMoveRight
public:
literal int StatusMoveRight
public static final int StatusMoveRight
public const var StatusMoveRight : int

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace


Biometrics.StatusMoveSlower Field

Biometrics.StatusMoveSlower Field |
 | See Also

1/18/2008

Indicates that the motion was too fast.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusMoveSlower As Integer
public const int StatusMoveSlower
public:
literal int StatusMoveSlower
public static final int StatusMoveSlower
public const var StatusMoveSlower : int

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace


Biometrics.StatusMoveUp Field

Biometrics.StatusMoveUp Field |
 | See Also

1/18/2008

Indicates that the position was too low.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusMoveUp As Integer
public const int StatusMoveUp
public:
literal int StatusMoveUp
public static final int StatusMoveUp
public const var StatusMoveUp : int

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace


Biometrics.StatusRawData Field

Biometrics.StatusRawData Field |
 | See Also

1/18/2008

Indicates that raw image data is available.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusRawData As Integer
public const int StatusRawData
public:
literal int StatusRawData
public static final int StatusRawData
public const var StatusRawData : int

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace


Biometrics.StatusSensorComplete Field

Biometrics.StatusSensorComplete Field |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusSensorComplete As Integer

public const int StatusSensorComplete

public:
literal int StatusSensorComplete

public static final int StatusSensorComplete

public const var StatusSensorComplete : int

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace


Biometrics.StatusSensorDirty Field

Biometrics.StatusSensorDirty Field |
 | See Also

1/18/2008

Indicates that the sensor is dirty.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusSensorDirty As Integer
public const int StatusSensorDirty
public:
literal int StatusSensorDirty
public static final int StatusSensorDirty
public const var StatusSensorDirty : int

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace


Biometrics.StatusSensorReady Field

Biometrics.StatusSensorReady Field |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusSensorReady As Integer

public const int StatusSensorReady

public:
literal int StatusSensorReady

public static final int StatusSensorReady

public const var StatusSensorReady : int

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace


Biometrics.StatusUnspecifiedReadFailure Field

Biometrics.StatusUnspecifiedReadFailure Field |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusUnspecifiedReadFailure As Integer

public const int StatusUnspecifiedReadFailure

public:
literal int StatusUnspecifiedReadFailure

public static final int StatusUnspecifiedReadFailure

public const var StatusUnspecifiedReadFailure : int

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace


Biometrics.UseDefault Field

Biometrics.UseDefault Field |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const UseDefault As Integer

public const int UseDefault

public:
literal int UseDefault

public static final int UseDefault

public const var UseDefault : int

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace


Biometrics Constructor

Biometrics Constructor |
 | See Also

1/18/2008

Creates an instance of the Biometrics class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected Biometrics ()
protected:
Biometrics ()
protected Biometrics ()
protected function Biometrics ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace


Biometrics Methods

Biometrics Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
BeginEnrollCapture | Begins capturing biometrics data for enrollment.
BeginVerifyCapture | Begins capturing biometrics data for verification.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all buffered device input.
ClearInputProperties | Resets the values of properties altered by DataEvent or ErrorEvent.
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
EndCapture | Ends the capturing of biometrics data.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Identify | Captures biometrics data, compares it to an array of BiometricsInformationRecords, and then returns a rank ordered array of indexes.
IdentifyMatch | Compares a sample Biometrics Information Record against the entries of a collection of other Biometrics Information Records, and then returns a rank ordered array of indexes.
Open | Opens a device for later input/output processing. (inherited from PosCommon )
ProcessPrematchData | Creates biometric samples for use by Match-On-Card and enabled Match-On-Card implementations that require prematch data before matching operations.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
Verify | Captures biometrics data and compares it against a designated Biometrics Information Record.
VerifyMatch | Indicates the event type for DataEvent events.

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

Biometrics Class
Microsoft.PointOfService Namespace


Biometrics.BeginEnrollCapture Method

Biometrics.BeginEnrollCapture Method |
 | See Also

1/18/2008

Begins capturing biometrics data for enrollment.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub BeginEnrollCapture ( _
    referenceBir As BiometricsInformationRecord, _
    payload As Byte() _
)
public abstract void BeginEnrollCapture (
    BiometricsInformationRecord referenceBir,
    byte[] payload
)
public:
virtual void BeginEnrollCapture (
    BiometricsInformationRecord^ referenceBir,
    array<unsigned char>^ payload
) abstract
public abstract void BeginEnrollCapture (
    BiometricsInformationRecord referenceBir,
    byte[] payload
)
public abstract function BeginEnrollCapture (
    referenceBir : BiometricsInformationRecord,
    payload : byte[]
)

Parameters

referenceBir

Optional Biometrics Information Record to be adapted (updated). This parameter is ignored if it is empty.

payload

Data that will be stored by the BSP. This parameter is ignored if it is empty.

Remarks

Starts capturing biometrics data for enrollment. Although not required, enrollment captures typically result in a series of biometrics data captures which, when you combine it, make up the body of the final BiometricsInformationRecord. Optionally if CapTemplateAdaptation is true, a referenceBir can be provided for adaptation with the enrollment. If a payload is provided, that data is added into the resulting BiometricsInformationRecord.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace
BiometricsInformationRecord
CapTemplateAdaptation
EndCapture
BiometricsInformationRecord


Biometrics.BeginVerifyCapture Method

Biometrics.BeginVerifyCapture Method |
 | See Also

1/18/2008

Begins capturing biometrics data for verification.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub BeginVerifyCapture
public abstract void BeginVerifyCapture ()
public:
virtual void BeginVerifyCapture () abstract
public abstract void BeginVerifyCapture ()
public abstract function BeginVerifyCapture ()

Remarks

Begins capturing biometrics data for verification. The resulting processed data is stored in the BiometricsInformationRecord property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace
BiometricsInformationRecord
EndCapture


Biometrics.ClearInput Method

Biometrics.ClearInput Method |
 | See Also

1/18/2008

Clears all buffered device input.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearInput
public abstract void ClearInput ()
public:
virtual void ClearInput () abstract
public abstract void ClearInput ()
public abstract function ClearInput ()

Remarks

ClearInput may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Claimed | The device is claimed by another process.
NotClaimed | The device must be claimed before ClearInput can be used.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace


Biometrics.ClearInputProperties Method

Biometrics.ClearInputProperties Method |
 | See Also

1/18/2008

Resets the values of properties altered by DataEvent or ErrorEvent.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearInputProperties
public abstract void ClearInputProperties ()
public:
virtual void ClearInputProperties () abstract
public abstract void ClearInputProperties ()
public abstract function ClearInputProperties ()

Remarks

Sets all data properties populated by a firing of DataEvent or ErrorEvent back to their default values. This does not reset the DataCount or State properties.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace
DataEvent
ErrorEvent
DataCount


Biometrics.EndCapture Method

Biometrics.EndCapture Method |
 | See Also

1/18/2008

Ends the capturing of biometrics data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub EndCapture
public abstract void EndCapture ()
public:
virtual void EndCapture () abstract
public abstract void EndCapture ()
public abstract function EndCapture ()

Remarks

Ends the capturing of biometrics data.

If RealTimeDataEnabled isfalse and biometrics data was captured, it is put in the BiometricsInformationRecord and RawSensorData properties. If no biometrics data was captured, the BiometricsInformationRecord and RawSensorData properties remain empty.

If RealTimeDataEnabled is true and there is biometrics data which has not yet been delivered to the application by a StatusUpdateEvent , the remaining biometrics data is put into the properties BiometricsInformationRecord and RawSensorData. If no biometrics data was captured or all biometrics data has been delivered to the application, the BiometricsInformationRecord and RawSensorDataproperties remain empty.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace
BiometricsInformationRecord
RawSensorData
RealTimeDataEnabled
BeginEnrollCapture
BeginVerifyCapture
DataEventEnabled


Biometrics.Identify Method

Biometrics.Identify Method |
 | See Also

1/18/2008

Captures biometrics data, compares it to an array of BiometricsInformationRecords, and then returns a rank ordered array of indexes.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function Identify ( _
    maximumFalseAcceptRateRequested As Integer, _
    maximumFalseRejectRateRequested As Integer, _
    falseAcceptRatePrecedence As Boolean, _
    referenceBirPopulation As IEnumerable(Of BiometricsInformationRecord), _
    timeout As Integer _
) As Integer()
public abstract int[] Identify (
    int maximumFalseAcceptRateRequested,
    int maximumFalseRejectRateRequested,
    bool falseAcceptRatePrecedence,
    IEnumerable<BiometricsInformationRecord> referenceBirPopulation,
    int timeout
)
public:
virtual array<int>^ Identify (
    int maximumFalseAcceptRateRequested,
    int maximumFalseRejectRateRequested,
    bool falseAcceptRatePrecedence,
    IEnumerable<BiometricsInformationRecord^>^ referenceBirPopulation,
    int timeout
) abstract
public abstract int[] Identify (
    int maximumFalseAcceptRateRequested,
    int maximumFalseRejectRateRequested,
    boolean falseAcceptRatePrecedence,
    IEnumerable<BiometricsInformationRecord> referenceBirPopulation,
    int timeout
)
public abstract function Identify (
    maximumFalseAcceptRateRequested : int,
    maximumFalseRejectRateRequested : int,
    falseAcceptRatePrecedence : boolean,
    referenceBirPopulation : IEnumerable<BiometricsInformationRecord>,
    timeout : int
) : int[]

Parameters

maximumFalseAcceptRateRequested

The requested FAR criterion for successful verification.

maximumFalseRejectRateRequested

The requested FRR criterion for successful verification.

falseAcceptRatePrecedence

If both criteria are provided, this parameter indicates which takes precedence. falseAcceptRatePrecedence indicates that maxFARRRequested takes precedence; falseRejectRatePrecedence indicates that maxFRRRequested takes precedence.

referenceBirPopulation

A collection of BiometricsInformationRecord properties against which the Identify match is performed.

timeout

Maximum number of milliseconds to try a successful biometric capture before failing.

Remarks

This function captures biometric data from the attached device within the allocated time-out, and compares it against a set of BiometricsInformationRecord properties in referenceBirPopulation. It then returns a rank ordered array of referenceBirPopulation indexes.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace
BiometricsInformationRecord
IdentifyMatch


Biometrics.IdentifyMatch Method

Biometrics.IdentifyMatch Method |
 | See Also

1/18/2008

Compares a sample Biometrics Information Record against the entries of a collection of other Biometrics Information Records, and then returns a rank ordered array of indexes.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function IdentifyMatch ( _
    maximumFalseAcceptRateRequested As Integer, _
    maximumFalseRejectRateRequested As Integer, _
    falseAcceptRatePrecedence As Boolean, _
    sampleBir As BiometricsInformationRecord, _
    referenceBirPopulation As IEnumerable(Of BiometricsInformationRecord) _
) As Integer()
public abstract int[] IdentifyMatch (
    int maximumFalseAcceptRateRequested,
    int maximumFalseRejectRateRequested,
    bool falseAcceptRatePrecedence,
    BiometricsInformationRecord sampleBir,
    IEnumerable<BiometricsInformationRecord> referenceBirPopulation
)
public:
virtual array<int>^ IdentifyMatch (
    int maximumFalseAcceptRateRequested,
    int maximumFalseRejectRateRequested,
    bool falseAcceptRatePrecedence,
    BiometricsInformationRecord^ sampleBir,
    IEnumerable<BiometricsInformationRecord^>^ referenceBirPopulation
) abstract
public abstract int[] IdentifyMatch (
    int maximumFalseAcceptRateRequested,
    int maximumFalseRejectRateRequested,
    boolean falseAcceptRatePrecedence,
    BiometricsInformationRecord sampleBir,
    IEnumerable<BiometricsInformationRecord> referenceBirPopulation
)
public abstract function IdentifyMatch (
    maximumFalseAcceptRateRequested : int,
    maximumFalseRejectRateRequested : int,
    falseAcceptRatePrecedence : boolean,
    sampleBir : BiometricsInformationRecord,
    referenceBirPopulation : IEnumerable<BiometricsInformationRecord>
) : int[]

Parameters

maximumFalseAcceptRateRequested

The requested FAR criterion for successful verification.

maximumFalseRejectRateRequested

The requested FRR criterion for successful verification.

An EMPTY pointer indicates that this criterion is not provided.

falseAcceptRatePrecedence

If both criteria are provided, this parameter indicates which takes precedence. falseAcceptRatePrecedence indicates that maxFARRRequested takes precedence, falseRejectRatePrecedence indicates that maxFRRRequested takes precedence.

sampleBir

The BiometricsInformationRecord property to be identified.

referenceBirPopulation

An array of BiometricsInformationRecord properties against which the Identify match is performed.

Remarks

This function accepts a sampleir and compares it against a set of BiometricsInformationRecord properties in referenceBirPopulation. It then returns a rank ordered array of referenceBirPopulation indexes.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace
Biometrics.Identify Method
BiometricsInformationRecord


Biometrics.ProcessPrematchData Method

Biometrics.ProcessPrematchData Method |
 | See Also

1/18/2008

Creates biometric samples for use by Match-On-Card and enabled Match-On-Card implementations that require prematch data before matching operations.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function ProcessPrematchData ( _
    sampleBir As BiometricsInformationRecord, _
    prematchDataBir As BiometricsInformationRecord _
) As BiometricsInformationRecord
public abstract BiometricsInformationRecord ProcessPrematchData (
    BiometricsInformationRecord sampleBir,
    BiometricsInformationRecord prematchDataBir
)
public:
virtual BiometricsInformationRecord^ ProcessPrematchData (
    BiometricsInformationRecord^ sampleBir,
    BiometricsInformationRecord^ prematchDataBir
) abstract
public abstract BiometricsInformationRecord ProcessPrematchData (
    BiometricsInformationRecord sampleBir,
    BiometricsInformationRecord prematchDataBir
)
public abstract function ProcessPrematchData (
    sampleBir : BiometricsInformationRecord,
    prematchDataBir : BiometricsInformationRecord
) : BiometricsInformationRecord

Parameters

sampleBir

The BiometricsInformationRecord to be processed.

prematchDataBir

The BiometricsInformationRecord property that contains prematch data previously emitted by the associated Match-On-Card Library.

Remarks

This method processes biometric samples that are suitable for Match-on-Card. It enables Match-On-Card implementations that require the retrieval of prematch data from the card before the matching operation.

Because smart cards generally cannot capture and process biometric samples, the Match-On-Card functionality needs a host to perform off-card operations such as sample acquisition and feature extraction. In this case, the card needs the host to perform an operation based on prematch data that is retrieved from the card.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace
CapPrematchData
BiometricsInformationRecord


Biometrics.Verify Method

Biometrics.Verify Method |
 | See Also

1/18/2008

Captures biometrics data and compares it against a designated Biometrics Information Record.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function Verify ( _
    maximumFalseAcceptRateRequested As Integer, _
    maximumFalseRejectRateRequested As Integer, _
    falseAcceptRatePrecedence As Boolean, _
    referenceBir As BiometricsInformationRecord, _
    adaptBir As Boolean, _
    timeout As Integer _
) As BiometricsVerifyResult
public abstract BiometricsVerifyResult Verify (
    int maximumFalseAcceptRateRequested,
    int maximumFalseRejectRateRequested,
    bool falseAcceptRatePrecedence,
    BiometricsInformationRecord referenceBir,
    bool adaptBir,
    int timeout
)
public:
virtual BiometricsVerifyResult^ Verify (
    int maximumFalseAcceptRateRequested,
    int maximumFalseRejectRateRequested,
    bool falseAcceptRatePrecedence,
    BiometricsInformationRecord^ referenceBir,
    bool adaptBir,
    int timeout
) abstract
public abstract BiometricsVerifyResult Verify (
    int maximumFalseAcceptRateRequested,
    int maximumFalseRejectRateRequested,
    boolean falseAcceptRatePrecedence,
    BiometricsInformationRecord referenceBir,
    boolean adaptBir,
    int timeout
)
public abstract function Verify (
    maximumFalseAcceptRateRequested : int,
    maximumFalseRejectRateRequested : int,
    falseAcceptRatePrecedence : boolean,
    referenceBir : BiometricsInformationRecord,
    adaptBir : boolean,
    timeout : int
) : BiometricsVerifyResult

Parameters

maximumFalseAcceptRateRequested

The requested FAR criterion for successful verification.

maximumFalseRejectRateRequested

The requested FRR criterion for successful verification.

falseAcceptRatePrecedence

If both criteria are provided, this parameter indicates which takes precedence.

referenceBir

The BiometricsInformationRecord to be verified against.

adaptBir

Indicates whether the referenceBir will be adapted from information taken from the captured BiometricsInformationRecord.

timeout

Maximum number of milliseconds to try a successful biometric capture before failing.

Remarks

This function captures biometric data from the attached device within the allocated time-out, and compares it against the referenceBir. If the match is successful as indicated by a positive result, the Service tries to adapt the referenceBir from information take format the captured BiometricsInformationRecord.

The data formats of the two BiometricsInformationRecord may be different because the format depends on the physical device model.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace
BiometricInformationRecord
CapTemplateAdaptation
VerifyMatch
Biometrics.Identify Method


Biometrics.VerifyMatch Method

Biometrics.VerifyMatch Method |
 | See Also

1/18/2008

Indicates the event type for DataEvent events.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function VerifyMatch ( _
    maximumFalseAcceptRateRequested As Integer, _
    maximumFalseRejectRateRequested As Integer, _
    falseAcceptRatePrecedence As Boolean, _
    sampleBir As BiometricsInformationRecord, _
    referenceBir As BiometricsInformationRecord, _
    adaptBir As Boolean _
) As BiometricsVerifyResult
public abstract BiometricsVerifyResult VerifyMatch (
    int maximumFalseAcceptRateRequested,
    int maximumFalseRejectRateRequested,
    bool falseAcceptRatePrecedence,
    BiometricsInformationRecord sampleBir,
    BiometricsInformationRecord referenceBir,
    bool adaptBir
)
public:
virtual BiometricsVerifyResult^ VerifyMatch (
    int maximumFalseAcceptRateRequested,
    int maximumFalseRejectRateRequested,
    bool falseAcceptRatePrecedence,
    BiometricsInformationRecord^ sampleBir,
    BiometricsInformationRecord^ referenceBir,
    bool adaptBir
) abstract
public abstract BiometricsVerifyResult VerifyMatch (
    int maximumFalseAcceptRateRequested,
    int maximumFalseRejectRateRequested,
    boolean falseAcceptRatePrecedence,
    BiometricsInformationRecord sampleBir,
    BiometricsInformationRecord referenceBir,
    boolean adaptBir
)
public abstract function VerifyMatch (
    maximumFalseAcceptRateRequested : int,
    maximumFalseRejectRateRequested : int,
    falseAcceptRatePrecedence : boolean,
    sampleBir : BiometricsInformationRecord,
    referenceBir : BiometricsInformationRecord,
    adaptBir : boolean
) : BiometricsVerifyResult

Parameters

maximumFalseAcceptRateRequested

The requested FAR criterion for successful verification.

maximumFalseRejectRateRequested

The requested FRR criterion for successful verification.

falseAcceptRatePrecedence

If both criteria are provided, this parameter indicates which takes precedence.

sampleBir

The BiometricsInformationRecord to be identified.

referenceBir

The BiometricsInformationRecord to be verified against.

adaptBir

Remarks

This function compares a sampleBir against the referenceBir. If the match is successful, as indicated by a positive result, the Service tries to adapt the referenceBir from information taken from the captured BiometricsInformationRecord.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace
Verify
BiometricsInformationRecord
Biometrics.IdentifyMatch Method
CapTemplateAdaptation


Biometrics Properties

Biometrics Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
Algorithm | Gets or sets the biometric algorithm that is used for generating the biometrics template.
AlgorithmList | Gets the list of algorithms that are supported by the Biometrics device.
AutoDisable | Gets or sets a Boolean value that indicates whether the device is disabled after data is received.
BiometricsInformationRecord | Gets the biometric enrollment data that is returned to the application.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapPrematchData | Gets a Boolean value that indicates whether the server can use Match-On-Card SmartCard technology to generate a processed BiometricsInformationRecord.
CapRawSensorData | Gets a Boolean value that indicates whether the service may return unprocessed data from the biometrics sensor.
CapRealTimeData | Gets a Boolean value that indicates whether the biometrics device may supply unprocessed biometrics data as it is captured.
CapSensorColor | Gets a value or combination of values that indicates whether the biometrics device supports image formats other than bi-tonal.
CapSensorOrientation | Gets a value that indicates whether the sensor image should be rotated before processing, and to what degree.
CapSensorType | Gets a value that indicates the type of biometric data that the sensor records.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapTemplateAdaptation | Gets a Boolean value that indicates whether an adapted Biometrics Information Record can be returned by the service.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
DataCount | Gets the number of currently queued DataEvent events.
DataEventEnabled | Get or sets a Boolean value that indicates whether a DataEvent event is delivered when input data is queued.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
RawSensorData | Gets an unprocessed biometrics image as raw pixel data.
RealTimeDataEnabled | Gets or sets a Boolean value that indicates whether biometrics data is queued as it is captured.
SensorColor | Gets or sets which image capture mode will be applied to new biometrics data.
SensorOrientation | Gets or sets the requested orientation adjustment to the received sensor data before BiometricsInformationRecord creation.
SensorType | Gets or sets the type of biometrics sensor being accessed.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether Biometrics is an exclusive-use device.

See Also

Reference

Biometrics Class
Microsoft.PointOfService Namespace


Biometrics.Algorithm Property

Biometrics.Algorithm Property |
 | See Also

1/18/2008

Gets or sets the biometric algorithm that is used for generating the biometrics template.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property Algorithm As Integer
public abstract int Algorithm { get; set; }
public:
virtual property int Algorithm {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_Algorithm ()

/** @property */
public abstract void set_Algorithm (int value)

public abstract function get Algorithm () : int

public abstract function set Algorithm (value : int)

Remarks

Contains the biometric algorithm that is used currently for generating the biometrics template. The values can be set to index the values that are contained in AlgorithmList.

Value | Meaning
0 | Default value
1 | First algorithm in AlgorithmList
2 | Second algorithm in AlgorithmList
3 | Third algorithm in AlgorithmList, and so on.
Note:
This property can only be updated when the device is opened, claimed, and not yet enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace
AlgorithmList


Biometrics.AlgorithmList Property

Biometrics.AlgorithmList Property |
 | See Also

1/18/2008

Gets the list of algorithms that are supported by the Biometrics device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property AlgorithmList As String()
public abstract string[] AlgorithmList { get; }
public:
virtual property array<String^>^ AlgorithmList {
    array<String^>^ get () abstract;
}
/** @property */
public abstract String[] get_AlgorithmList ()

public abstract function get AlgorithmList () : String[]

Remarks

Contains the comma-delimited list of algorithms that are supported by the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace
Biometrics.Algorithm Property


Biometrics.AutoDisable Property

Biometrics.AutoDisable Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether the device is disabled after data is received.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AutoDisable As Boolean
public abstract bool AutoDisable { get; set; }
public:
virtual property bool AutoDisable {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_AutoDisable ()

/** @property */
public abstract void set_AutoDisable (boolean value)

public abstract function get AutoDisable () : boolean

public abstract function set AutoDisable (value : boolean)

Remarks

AutoDisable provides the application that has an additional option for controlling the receipt of input data. If the application wants to receive and process only one input, or only one input at a time, this property can be set to true.

When true, the service object sets the DeviceEnabled property to false as soon as it receives and queues data to be raised as a DataEvent. Before the service object raises any later events, the application must set DeviceEnabled back to true.

When false, the service object does not automatically disable the device when data is received; instead, it relies on the application to set the value of the DeviceEnabled property.

AutoDisable is typically initialized to false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace
DeviceEnabled
DataEvent


Biometrics.BiometricsInformationRecord Property

Biometrics.BiometricsInformationRecord Property |
 | See Also

1/18/2008

Gets the biometric enrollment data that is returned to the application.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property BiometricsInformationRecord As BiometricsInformationRecord
public abstract BiometricsInformationRecord BiometricsInformationRecord { get; }
public:
virtual property BiometricsInformationRecord^ BiometricsInformationRecord {
    BiometricsInformationRecord^ get () abstract;
}
/** @property */
public abstract BiometricsInformationRecord get_BiometricsInformationRecord ()

public abstract function get BiometricsInformationRecord () : BiometricsInformationRecord

Remarks

This standard uses the term template to refer to the biometrics enrollment data for a user. The term BiometricsInformationRecord refers to any biometrics data that is returned to the application; including raw data, intermediate data, processed samples ready for verification or identification, and enrollment data. Typically, the only data that is stored persistently by the application is the BiometricsInformationRecord generated for enrollment, such as the template. The format of the opaque Biometric Data Block is indicated by the Format field of the Header. This may be a standard or proprietary format. The Biometric Data Block may be encrypted. The digital signature is optional, and may be used to verify integrity of the data during transmission and storage. When present, it is calculated on the header + Biometric Data Block.

For standardized BiometricsInformationRecord formats, the signature takes a standard form (to be determined when the format is standardized). For proprietary BiometricsInformationRecord formats (all that exists currently), the signature can take any form that suits the Service. Therefore, there is no C structure definition of the signature. The BiometricsInformationRecord Data Type indicates whether the BiometricsInformationRecord is signed and encrypted or only encrypted. Processed biometrics data obtained through the methods BeginEnrollCapture, BeginVerifyCapture, and Verify are stored in this property upon their successful completion.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace
BeginEnrollCapture
BeginVerifyCapture
verify
Biometrics.IdentifyMatch Method
Biometrics.Identify Method
Biometrics.ProcessPrematchData Method
VerifyMatch
BiometricsInformationRecord


Biometrics.CapPrematchData Property

Biometrics.CapPrematchData Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the server can use Match-On-Card SmartCard technology to generate a processed BiometricsInformationRecord.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapPrematchData As Boolean
public abstract bool CapPrematchData { get; }
public:
virtual property bool CapPrematchData {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapPrematchData ()

public abstract function get CapPrematchData () : boolean

Remarks

If true, the Service can use Match On Card SmartCard technology to generate a processed BiometricsInformationRecord property based on prematch data that is stored on a SmartCard.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace
Biometrics.ProcessPrematchData Method
Biometrics.BiometricsInformationRecord Property


Biometrics.CapRawSensorData Property

Biometrics.CapRawSensorData Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the service may return unprocessed data from the biometrics sensor.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRawSensorData As Boolean
public abstract bool CapRawSensorData { get; }
public:
virtual property bool CapRawSensorData {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRawSensorData ()

public abstract function get CapRawSensorData () : boolean

Remarks

If true, the Service can return unprocessed raw data from the biometrics sensor.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace
RawSensorData


Biometrics.CapRealTimeData Property

Biometrics.CapRealTimeData Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the biometrics device may supply unprocessed biometrics data as it is captured.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRealTimeData As Boolean
public abstract bool CapRealTimeData { get; }
public:
virtual property bool CapRealTimeData {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRealTimeData ()

public abstract function get CapRealTimeData () : boolean

Remarks

If true, the device can supply raw biometrics data as the biometrics information is being captured.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace
RawSensorData
RealTimeDataEnabled


Biometrics.CapSensorColor Property

Biometrics.CapSensorColor Property |
 | See Also

1/18/2008

Gets a value or combination of values that indicates whether the biometrics device supports image formats other than bi-tonal.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSensorColor As CapSensorColors
public abstract CapSensorColors CapSensorColor { get; }
public:
virtual property CapSensorColors CapSensorColor {
    CapSensorColors get () abstract;
}
/** @property */
public abstract CapSensorColors get_CapSensorColor ()

public abstract function get CapSensorColor () : CapSensorColors

Remarks

This capability indicates if this device supports image formats other than bi-tonal. CapSensorColor is a logical OR combination of any of the following values.

Value | Meaning
Mono | Bi-tonal (B/W)
Grayscale | Grayscale
Color16 | 16 Colors
Color256 | 256 Colors
Full | Full Colors

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace
SensorColor
CapSensorColors


Biometrics.CapSensorOrientation Property

Biometrics.CapSensorOrientation Property |
 | See Also

1/18/2008

Gets a value that indicates whether the sensor image should be rotated before processing, and to what degree.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSensorOrientation As CapSensorOrientations
public abstract CapSensorOrientations CapSensorOrientation { get; }
public:
virtual property CapSensorOrientations CapSensorOrientation {
    CapSensorOrientations get () abstract;
}
/** @property */
public abstract CapSensorOrientations get_CapSensorOrientation ()

public abstract function get CapSensorOrientation () : CapSensorOrientations

Remarks

This capability indicates the ability of the sensor image to be rotated before processing. CapSensorOrientation is a logical OR combination of any of the following values.

Value | Meaning
Normal | 0°
Right | 90°
Inverted | 180°
Left | 270°

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace
SensorOrientation
CapSensorOrientations


Biometrics.CapSensorType Property

Biometrics.CapSensorType Property |
 | See Also

1/18/2008

Gets a value that indicates the type of biometric data that the sensor records.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSensorType As CapSensorTypes
public abstract CapSensorTypes CapSensorType { get; }
public:
virtual property CapSensorTypes CapSensorType {
    CapSensorTypes get () abstract;
}
/** @property */
public abstract CapSensorTypes get_CapSensorType ()

public abstract function get CapSensorType () : CapSensorTypes

Remarks

Indicates the types of biometrics data that can be captured by the attached sensor. CapSensorType is a logical combination of any of the following values:

Value | Meaning
FacialFeatures | Facial Features/Topography
Voice | Voice
Fingerprint | Fingerprint
Iris | Iris
Retina | Retina
Geometry | Hand Geometry
SignatureDynamics | Signature
KeystrokeDynamics | Keystrokes
LipMovement | Lip Movement
ThermalFaceImage | Face Image
ThermalHandImage | Hand Image
Gait | Gait/Stride
Password | Password

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace
SensorType
SensorType


Biometrics.CapTemplateAdaptation Property

Biometrics.CapTemplateAdaptation Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether an adapted Biometrics Information Record can be returned by the service.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapTemplateAdaptation As Boolean
public abstract bool CapTemplateAdaptation { get; }
public:
virtual property bool CapTemplateAdaptation {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapTemplateAdaptation ()

public abstract function get CapTemplateAdaptation () : boolean

Remarks

If true, the Service can return an adapted BiometricsInformationRecord property that is the result of updating a reference BiometricsInformationRecord property with information taken from a sample BiometricsInformationRecord or capture BiometricsInformationRecord property. The purpose of this adaptation is to keep the reference BiometricsInformationRecord property current as biometric data shifts over time.

Note:
This capability must be populated after Open Claim and DeviceEnabled because it depends on the selected Algorithm.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace
Biometrics.Algorithm Property
BinaryInformationRecord
verify
verifyMatch


Biometrics.DataCount Property

Biometrics.DataCount Property |
 | See Also

1/18/2008

Gets the number of currently queued DataEvent events.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DataCount As Integer
public abstract int DataCount { get; }
public:
virtual property int DataCount {
    int get () abstract;
}
/** @property */
public abstract int get_DataCount ()

public abstract function get DataCount () : int

Remarks

Indicates the total number of currently queued DataEvent events at the service object. All online units are included in this value.

The application can interrogate DataCount to determine whether additional input is queued from a device but has not yet been delivered because of other application processing, freezing of events, or other causes.

DataCount is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace
Biometrics.DataCount Property
DataEvent


Biometrics.DataEventEnabled Property

Biometrics.DataEventEnabled Property |
 | See Also

1/18/2008

Get or sets a Boolean value that indicates whether a DataEvent event is delivered when input data is queued.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property DataEventEnabled As Boolean
public abstract bool DataEventEnabled { get; set; }
public:
virtual property bool DataEventEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_DataEventEnabled ()

/** @property */
public abstract void set_DataEventEnabled (boolean value)

public abstract function get DataEventEnabled () : boolean

public abstract function set DataEventEnabled (value : boolean)

Remarks

If true, a DataEvent is delivered as soon as input data is queued. If this property is changed to true while input data is already in the queue, a DataEvent event is delivered immediately. This event may be delayed if FreezeEvents is true or if another event is already being processed at the application. In this case, the DataEvent remains queued until it can be processed.

If false, input data is queued for later delivery to the application. Also, if an input error occurs, the ErrorEvent is not delivered while DataEventEnabled is false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace
DataEvent


Biometrics.IsExclusiveUseDevice Property

Biometrics.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether Biometrics is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Property Value

A value of true indicates the fiscal printer is an exclusive-use device. Otherwise, the value is false.

Remarks

An exclusive-use device has the following properties:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before accessing some properties or calling methods that update the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace
Claim
DeviceEnabled


Biometrics.RawSensorData Property

Biometrics.RawSensorData Property |
 | See Also

1/18/2008

Gets an unprocessed biometrics image as raw pixel data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property RawSensorData As Bitmap
public abstract Bitmap RawSensorData { get; }
public:
virtual property Bitmap^ RawSensorData {
    Bitmap^ get () abstract;
}
/** @property */
public abstract Bitmap get_RawSensorData ()

public abstract function get RawSensorData () : Bitmap

Remarks

Holds the biometrics image data as raw pixel data scan lines from the top, left to the bottom, right. SensorColor defines the interpretation of the pixel data.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace
Biometrics.CapRawSensorData Property
SensorColor


Biometrics.RealTimeDataEnabled Property

Biometrics.RealTimeDataEnabled Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether biometrics data is queued as it is captured.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property RealTimeDataEnabled As Boolean
public abstract bool RealTimeDataEnabled { get; set; }
public:
virtual property bool RealTimeDataEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_RealTimeDataEnabled ()

/** @property */
public abstract void set_RealTimeDataEnabled (boolean value)

public abstract function get RealTimeDataEnabled () : boolean

public abstract function set RealTimeDataEnabled (value : boolean)

Remarks

If true and CapRealTimeData is true, a series of partial biometric data events is queued as the biometric is captured until biometric capture is stopped. Otherwise, the captured biometric data is queued as a single StatusUpdateEvent when biometric capture is stopped.

Setting RealTimeDataEnabled does not cause any change in system behavior until a later BeginEnrollCapture or BeginVerifyCapture method is performed. This prevents confusion about what would occur if it were modified between a BeginEnrollCapture - EndCapture or BeginVerifyCapture - EndCapture pairing.

This property is initialized to false by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace
Biometrics.EndCapture Method
Biometrics.CapRealTimeData Property
Biometrics.BeginEnrollCapture Method
Biometrics.BeginVerifyCapture Method


Biometrics.SensorColor Property

Biometrics.SensorColor Property |
 | See Also

1/18/2008

Gets or sets which image capture mode will be applied to new biometrics data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property SensorColor As SensorColor
public abstract SensorColor SensorColor { get; set; }
public:
virtual property SensorColor SensorColor {
    SensorColor get () abstract;
    void set (SensorColor value) abstract;
}
/** @property */
public abstract SensorColor get_SensorColor ()

/** @property */
public abstract void set_SensorColor (SensorColor value)

public abstract function get SensorColor () : SensorColor

public abstract function set SensorColor (value : SensorColor)

Remarks

This property is used to select the image capture mode for later biometric capture operations. Certain SensorType devices may not be compatible with the full range of colors. Changing the SensorColor property does not affect any stored data currently residing in the RawSensorData property or BiometricsInformationRecord property.

It may contain one of the following values, which is defined in the SensorColor enumeration.

Value | Meaning
Mono | Bi-tonal (B/W)
Grayscale | Grayscale
Color16 | 16 Colors
Color256 | 256 Colors
Full | Full Colors

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace
Biometrics.CapSensorColor Property
Biometrics.RawSensorData Property
SensorType
Biometrics.BiometricsInformationRecord Property
SensorColor


Biometrics.SensorOrientation Property

Biometrics.SensorOrientation Property |
 | See Also

1/18/2008

Gets or sets the requested orientation adjustment to the received sensor data before BiometricsInformationRecord creation.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property SensorOrientation As SensorOrientation
public abstract SensorOrientation SensorOrientation { get; set; }
public:
virtual property SensorOrientation SensorOrientation {
    SensorOrientation get () abstract;
    void set (SensorOrientation value) abstract;
}
/** @property */
public abstract SensorOrientation get_SensorOrientation ()

/** @property */
public abstract void set_SensorOrientation (SensorOrientation value)

public abstract function get SensorOrientation () : SensorOrientation

public abstract function set SensorOrientation (value : SensorOrientation)

Remarks

Holds the requested orientation adjustment to the received sensor data before BiometricsInformationRecord creation.

Value | Meaning
Normal | 0°
Right | 90°
Inverted | 180°
Left | 270°

Valid sensor orientation values are defined in the SensorOrientation enumeration.

This property can be updated when the device is opened and claimed, but not when the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace
Biometrics.CapSensorOrientation Property
SensorOrientation


Biometrics.SensorType Property

Biometrics.SensorType Property |
 | See Also

1/18/2008

Gets or sets the type of biometrics sensor being accessed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property SensorType As SensorType
public abstract SensorType SensorType { get; set; }
public:
virtual property SensorType SensorType {
    SensorType get () abstract;
    void set (SensorType value) abstract;
}
/** @property */
public abstract SensorType get_SensorType ()

/** @property */
public abstract void set_SensorType (SensorType value)

public abstract function get SensorType () : SensorType

public abstract function set SensorType (value : SensorType)

Remarks

Holds the type of biometrics sensor being accessed. Valid sensor types are stored in the SensorType enumeration.

Value | Meaning
FacialFeatures | Facial Features/Topography
Voice | Voice
Fingerprint | Fingerprint
Iris | Iris
Retina | Retina
HandGeometry | Hand Geometry
SignatureDynamics | Signature
KeystrokeDynamics | Keystrokes
LipMovement | Lip Movement
ThermalFaceImage | Face Image
ThermalHandImage | Hand Image
Gait | Gait/Stride
Password | Password

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace
Biometrics.CapSensorType Property
Biometrics.SensorColor Property
Biometrics.RawSensorData Property
SensorType


Biometrics Events

Biometrics Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DataEvent | Notifies the application that input data is available.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
ErrorEvent | Notifies the application that a Biometrics device error has been detected and that a suitable response by the application is necessary to process the error condition.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

Biometrics Class
Microsoft.PointOfService Namespace


Biometrics.DataEvent Event

Biometrics.DataEvent Event |
 | See Also

1/18/2008

Notifies the application that input data is available.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event DataEvent As DataEventHandler
public abstract event DataEventHandler DataEvent
public:
virtual event DataEventHandler^ DataEvent {
    void add (DataEventHandler^ value) abstract;
    void remove (DataEventHandler^ value) abstract;
}
/** @event */
public abstract void add_DataEvent (DataEventHandler value)

/** @event */
public abstract void remove_DataEvent (DataEventHandler value)

Remarks

The properties BiometricsInformationRecord and RawSensorData are set to appropriate values before a DataEvent event being delivered to the application.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace
Biometrics.DataEventEnabled Property
Biometrics.RawSensorData Property
Biometrics.BiometricsInformationRecord Property


Biometrics.ErrorEvent Event

Biometrics.ErrorEvent Event |
 | See Also

1/18/2008

Notifies the application that a Biometrics device error has been detected and that a suitable response by the application is necessary to process the error condition.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event ErrorEvent As DeviceErrorEventHandler
public abstract event DeviceErrorEventHandler ErrorEvent
public:
virtual event DeviceErrorEventHandler^ ErrorEvent {
    void add (DeviceErrorEventHandler^ value) abstract;
    void remove (DeviceErrorEventHandler^ value) abstract;
}
/** @event */
public abstract void add_ErrorEvent (DeviceErrorEventHandler value)

/** @event */
public abstract void remove_ErrorEvent (DeviceErrorEventHandler value)

Remarks

This event is queued when an error is detected while biometrics capture data are read. This ErrorEvent is not delivered until DataEventEnabled is set to true and all other event delivery requirements are met to makes sure that correct application sequencing occurs.

See Also

Reference

Biometrics Class
Biometrics Members
Microsoft.PointOfService Namespace
Biometrics.DataEvent Event
Biometrics.DataEventEnabled Property


BiometricsInformationRecord Class

BiometricsInformationRecord Class |
 | See Also Members

1/18/2008

Represents the Biometrics data that is returned to the application from a Biometrics device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<SerializableAttribute> _
Public Class BiometricsInformationRecord
    Implements IXmlSerializable
[SerializableAttribute]
public class BiometricsInformationRecord : IXmlSerializable
[SerializableAttribute]
public ref class BiometricsInformationRecord : IXmlSerializable
/** @attribute SerializableAttribute() */
public class BiometricsInformationRecord implements IXmlSerializable
SerializableAttribute
public class BiometricsInformationRecord implements IXmlSerializable

Remarks

This class provides applications that have context information about the biometrics data that has been returned from a service object by exposing information such as the date of creation, version, and purpose.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BiometricsInformationRecord

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BiometricsInformationRecord Members
Microsoft.PointOfService Namespace
Biometrics.BiometricsInformationRecord Property


BiometricsInformationRecord Members

BiometricsInformationRecord Members |
 | See Also Constructors Methods Properties

1/18/2008

Represents the Biometrics data that is returned to the application from a Biometrics device.

The following tables list the members exposed by the BiometricsInformationRecord type.

Public Constructors (see also Protected Constructors )

Name | Description
BiometricsInformationRecord | Overloaded.
Top

Protected Constructors

Name | Description
BiometricsInformationRecord | Overloaded.
Top

Public Properties

Name | Description
BiometricDataBlockSize |
CreatedTime | Gets the time at which the BIR was created.
DataType | Gets the data type of biometrics information that the BIR contains.
FormatId | Gets the integer value assigned by the format owner, optionally registered with the IBIA.
FormatOwner | Gets the integer value assigned by the format owner and registered by the IBIA.
Purpose | Gets the purpose of the stored biometrics information.
SensorType | Gets a value that indicates the type of biometrics sensor.
Version | Gets the version of the biometrics information record header.
Top

Public Methods (see also Protected Methods )

Name | Description
Clone | Creates a BiometricsInformationRecord object that is identical to the current BiometricsInformationRecord object.
Equals | Overloaded. (inherited from Object )
GetBiometricDataBlock | Returns the data block contained within the biometric information record.
GetHashCode | (inherited from Object )
GetSchema |
GetType | (inherited from Object )
ReadXml |
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
WriteXml |
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

BiometricsInformationRecord Class
Microsoft.PointOfService Namespace
Biometrics.BiometricsInformationRecord Property


BiometricsInformationRecord Constructor

BiometricsInformationRecord Constructor |
 | See Also

1/18/2008

Overload List

Name | Description
BiometricsInformationRecord () |
BiometricsInformationRecord (BiometricsInformationRecord) | Creates an instance of the BiometricsInformationRecord class by using data copied from the specified BiometricsInformationRecord.
BiometricsInformationRecord (Version, BirDataTypes, Int32, Int32, BirPurpose, SensorType, Byte[]) | Creates an instance of the BiometricsInformationRecord class.

See Also

Reference

BiometricsInformationRecord Class
BiometricsInformationRecord Members
Microsoft.PointOfService Namespace


BiometricsInformationRecord Constructor ()

BiometricsInformationRecord Constructor () |
 | See Also

1/18/2008

Initializes a new instance of the BiometricsInformationRecord Class .

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New

protected BiometricsInformationRecord ()

protected:
BiometricsInformationRecord ()

protected BiometricsInformationRecord ()

protected function BiometricsInformationRecord ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

BiometricsInformationRecord Class
BiometricsInformationRecord Members
Microsoft.PointOfService Namespace


BiometricsInformationRecord Constructor (BiometricsInformationRecord)

BiometricsInformationRecord Constructor (BiometricsInformationRecord) |
 | See Also

1/18/2008

Creates an instance of the BiometricsInformationRecord class by using data copied from the specified BiometricsInformationRecord.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    bir As BiometricsInformationRecord _
)
public BiometricsInformationRecord (
    BiometricsInformationRecord bir
)
public:
BiometricsInformationRecord (
    BiometricsInformationRecord^ bir
)
public BiometricsInformationRecord (
    BiometricsInformationRecord bir
)
public function BiometricsInformationRecord (
    bir : BiometricsInformationRecord
)

Parameters

bir

The BIR from which data are used to populate the new BIR.

Remarks

Data from the specified BIR is used to populate the newly created BIR.

See Also

Reference

BiometricsInformationRecord Class
BiometricsInformationRecord Members
Microsoft.PointOfService Namespace


BiometricsInformationRecord Constructor (Version, BirDataTypes, Int32, Int32, BirPurpose, SensorType, Byte[])

BiometricsInformationRecord Constructor (Version, BirDataTypes, Int32, Int32, BirPurpose, SensorType, Byte[]) |
 | See Also

1/18/2008

Creates an instance of the BiometricsInformationRecord class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    version As Version, _
    dataType As BirDataTypes, _
    formatOwner As Integer, _
    formatId As Integer, _
    purpose As BirPurpose, _
    sensorType As SensorType, _
    biometricDataBlock As Byte() _
)
public BiometricsInformationRecord (
    Version version,
    BirDataTypes dataType,
    int formatOwner,
    int formatId,
    BirPurpose purpose,
    SensorType sensorType,
    byte[] biometricDataBlock
)
public:
BiometricsInformationRecord (
    Version^ version,
    BirDataTypes dataType,
    int formatOwner,
    int formatId,
    BirPurpose purpose,
    SensorType sensorType,
    array<unsigned char>^ biometricDataBlock
)
public BiometricsInformationRecord (
    Version version,
    BirDataTypes dataType,
    int formatOwner,
    int formatId,
    BirPurpose purpose,
    SensorType sensorType,
    byte[] biometricDataBlock
)
public function BiometricsInformationRecord (
    version : Version,
    dataType : BirDataTypes,
    formatOwner : int,
    formatId : int,
    purpose : BirPurpose,
    sensorType : SensorType,
    biometricDataBlock : byte[]
)

Parameters

version

The version of the BIR, which is defined by the service object.

dataType

The type of data contained in the BIR.

formatOwner

FormatOwner values that are assigned and registered by the International Biometric Industry Association (IBIA).

formatId

Assigned by the format owner; optionally registered with the IBIA.

purpose

The purpose of the biometrics information.

sensorType

The type of the Biometric sensor used to record the data.

biometricDataBlock

The recorded biometrics data, in a format that is defined by the service object. Other information about the BIR such as a checksum or proprietary information may also be included in the biometric data.

Remarks

Creates an instance of the BiometricsInformationRecord class that has the specified values.

Possible SensorType values include the following values.

Member | Description
FacialFeatures | Captures biometrics data about facial features.
Fingerprint | Captures biometrics data about fingerprints.
Gait | Captures biometrics data about gait.
HandGeometry | Captures biometrics data about hand geometry.
Iris | Captures biometrics data about the iris.
KeystrokeDynamics | Captures biometrics data about keystroke dynamics.
LipMovement | Captures biometrics data about lip movement.
Password | Contains the password.
Retina | Captures biometrics data about the retina.
SignatureDynamics | Captures biometrics data about the signature dynamics.
ThermalFaceImage | Captures biometrics data about thermal face imaging.
ThermalHandImage | Captures biometrics data about thermal hand imaging.
Unspecified | Captures unspecified biometrics data.
Voice | Captures biometrics data about voice.

See Also

Reference

BiometricsInformationRecord Class
BiometricsInformationRecord Members
Microsoft.PointOfService Namespace


BiometricsInformationRecord Methods

BiometricsInformationRecord Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Clone | Creates a BiometricsInformationRecord object that is identical to the current BiometricsInformationRecord object.
Equals | Overloaded. (inherited from Object )
GetBiometricDataBlock | Returns the data block contained within the biometric information record.
GetHashCode | (inherited from Object )
GetSchema |
GetType | (inherited from Object )
ReadXml |
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
WriteXml |

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

BiometricsInformationRecord Class
Microsoft.PointOfService Namespace
Biometrics.BiometricsInformationRecord Property


BiometricsInformationRecord.Clone Method

BiometricsInformationRecord.Clone Method |
 | See Also

1/18/2008

Creates a BiometricsInformationRecord object that is identical to the current BiometricsInformationRecord object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Function Clone As BiometricsInformationRecord
public BiometricsInformationRecord Clone ()
public:
BiometricsInformationRecord^ Clone ()
public BiometricsInformationRecord Clone ()
public function Clone () : BiometricsInformationRecord

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BiometricsInformationRecord Class
BiometricsInformationRecord Members
Microsoft.PointOfService Namespace


BiometricsInformationRecord.GetBiometricDataBlock Method

BiometricsInformationRecord.GetBiometricDataBlock Method |
 | See Also

1/18/2008

Returns the data block contained within the biometric information record.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Function GetBiometricDataBlock As Byte()
public byte[] GetBiometricDataBlock ()
public:
array<unsigned char>^ GetBiometricDataBlock ()
public byte[] GetBiometricDataBlock ()
public function GetBiometricDataBlock () : byte[]

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BiometricsInformationRecord Class
BiometricsInformationRecord Members
Microsoft.PointOfService Namespace


BiometricsInformationRecord.GetSchema Method

BiometricsInformationRecord.GetSchema Method |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Function GetSchema As XmlSchema

public XmlSchema GetSchema ()

public:
virtual XmlSchema^ GetSchema () sealed

public final XmlSchema GetSchema ()

public final function GetSchema () : XmlSchema

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BiometricsInformationRecord Class
BiometricsInformationRecord Members
Microsoft.PointOfService Namespace


BiometricsInformationRecord.ReadXml Method

BiometricsInformationRecord.ReadXml Method |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub ReadXml ( _
    reader As XmlReader _
)

public void ReadXml (
    XmlReader reader
)

public:
virtual void ReadXml (
    XmlReader^ reader
) sealed

public final void ReadXml (
    XmlReader reader
)

public final function ReadXml (
    reader : XmlReader
)

Parameters

reader

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BiometricsInformationRecord Class
BiometricsInformationRecord Members
Microsoft.PointOfService Namespace


BiometricsInformationRecord.WriteXml Method

BiometricsInformationRecord.WriteXml Method |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub WriteXml ( _
    writer As XmlWriter _
)

public void WriteXml (
    XmlWriter writer
)

public:
virtual void WriteXml (
    XmlWriter^ writer
) sealed

public final void WriteXml (
    XmlWriter writer
)

public final function WriteXml (
    writer : XmlWriter
)

Parameters

writer

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BiometricsInformationRecord Class
BiometricsInformationRecord Members
Microsoft.PointOfService Namespace


BiometricsInformationRecord Properties

BiometricsInformationRecord Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
BiometricDataBlockSize |
CreatedTime | Gets the time at which the BIR was created.
DataType | Gets the data type of biometrics information that the BIR contains.
FormatId | Gets the integer value assigned by the format owner, optionally registered with the IBIA.
FormatOwner | Gets the integer value assigned by the format owner and registered by the IBIA.
Purpose | Gets the purpose of the stored biometrics information.
SensorType | Gets a value that indicates the type of biometrics sensor.
Version | Gets the version of the biometrics information record header.

See Also

Reference

BiometricsInformationRecord Class
Microsoft.PointOfService Namespace
Biometrics.BiometricsInformationRecord Property


BiometricsInformationRecord.BiometricDataBlockSize Property

BiometricsInformationRecord.BiometricDataBlockSize Property |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property BiometricDataBlockSize As Integer

public int BiometricDataBlockSize { get; }

public:
property int BiometricDataBlockSize {
    int get ();
}

/** @property */
public int get_BiometricDataBlockSize ()

public function get BiometricDataBlockSize () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BiometricsInformationRecord Class
BiometricsInformationRecord Members
Microsoft.PointOfService Namespace


BiometricsInformationRecord.CreatedTime Property

BiometricsInformationRecord.CreatedTime Property |
 | See Also

1/18/2008

Gets the time at which the BIR was created.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property CreatedTime As DateTime
public DateTime CreatedTime { get; }
public:
property DateTime CreatedTime {
    DateTime get ();
}
/** @property */
public DateTime get_CreatedTime ()

public function get CreatedTime () : DateTime

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BiometricsInformationRecord Class
BiometricsInformationRecord Members
Microsoft.PointOfService Namespace


BiometricsInformationRecord.DataType Property

BiometricsInformationRecord.DataType Property |
 | See Also

1/18/2008

Gets the data type of biometrics information that the BIR contains.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property DataType As BirDataTypes
public BirDataTypes DataType { get; }
public:
property BirDataTypes DataType {
    BirDataTypes get ();
}
/** @property */
public BirDataTypes get_DataType ()

public function get DataType () : BirDataTypes

Remarks

Possible values are listed here.

Value | Meaning
Encrypted | The BIR holds encrypted biometrics data.
Intermediate | The BIR holds intermediate biometrics data.
Processed | The BIR holds processed biometrics data.
Raw | The BIR holds raw, unprocessed biometrics data.
Signed | The BIR holds signed biometrics data.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BiometricsInformationRecord Class
BiometricsInformationRecord Members
Microsoft.PointOfService Namespace
BiometricsInformationRecord.DataType Property


BiometricsInformationRecord.FormatId Property

BiometricsInformationRecord.FormatId Property |
 | See Also

1/18/2008

Gets the integer value assigned by the format owner, optionally registered with the IBIA.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property FormatId As Integer
public int FormatId { get; }
public:
property int FormatId {
    int get ();
}
/** @property */
public int get_FormatId ()

public function get FormatId () : int

Remarks

A value assigned by the format owner which is optionally registered with the International Biometric Industry Association (IBIA).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BiometricsInformationRecord Class
BiometricsInformationRecord Members
Microsoft.PointOfService Namespace
FormatOwner


BiometricsInformationRecord.FormatOwner Property

BiometricsInformationRecord.FormatOwner Property |
 | See Also

1/18/2008

Gets the integer value assigned by the format owner and registered by the IBIA.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property FormatOwner As Integer
public int FormatOwner { get; }
public:
property int FormatOwner {
    int get ();
}
/** @property */
public int get_FormatOwner ()

public function get FormatOwner () : int

Remarks

Gets the value that assigned by the format owner and registered by the International Biometric Industry Association (IBIA).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BiometricsInformationRecord Class
BiometricsInformationRecord Members
Microsoft.PointOfService Namespace


BiometricsInformationRecord.Purpose Property

BiometricsInformationRecord.Purpose Property |
 | See Also

1/18/2008

Gets the purpose of the stored biometrics information.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Purpose As BirPurpose
public BirPurpose Purpose { get; }
public:
property BirPurpose Purpose {
    BirPurpose get ();
}
/** @property */
public BirPurpose get_Purpose ()

public function get Purpose () : BirPurpose

Remarks

The following values are supported.

Value | Meaning
Unspecified | The purpose of the biometrics data is unspecified.
Verify | The biometrics data was collected for verification purposes. Verification does not require the same level of quality as enrollment.
Enroll | The biometrics data was collected for enrollment purposes.
EnrollForVerificationOnly | The biometrics data was collected for verification only. Verification does not require the same level of quality as enrollment.
EntrollForIdentificationOnly | The biometrics data was collected for comparison against other data only.
Audit | The biometrics data was collected for auditing.
Identify | The biometrics data was collected for comparison against other data.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BiometricsInformationRecord Class
BiometricsInformationRecord Members
Microsoft.PointOfService Namespace


BiometricsInformationRecord.SensorType Property

BiometricsInformationRecord.SensorType Property |
 | See Also

1/18/2008

Gets a value that indicates the type of biometrics sensor.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property SensorType As SensorType
public SensorType SensorType { get; }
public:
property SensorType SensorType {
    SensorType get ();
}
/** @property */
public SensorType get_SensorType ()

public function get SensorType () : SensorType

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BiometricsInformationRecord Class
BiometricsInformationRecord Members
Microsoft.PointOfService Namespace


BiometricsInformationRecord.Version Property

BiometricsInformationRecord.Version Property |
 | See Also

1/18/2008

Gets the version of the biometrics information record header.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Version As Version
public Version Version { get; }
public:
property Version^ Version {
    Version^ get ();
}
/** @property */
public Version get_Version ()

public function get Version () : Version

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BiometricsInformationRecord Class
BiometricsInformationRecord Members
Microsoft.PointOfService Namespace


BiometricsVerifyResult Class

BiometricsVerifyResult Class |
 | See Also Members

1/18/2008

Defines the programmatic interface that is used for verifying biometrics data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Class BiometricsVerifyResult
public class BiometricsVerifyResult
public ref class BiometricsVerifyResult
public class BiometricsVerifyResult
public class BiometricsVerifyResult

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BiometricsVerifyResult

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BiometricsVerifyResult Members
Microsoft.PointOfService Namespace


BiometricsVerifyResult Members

BiometricsVerifyResult Members |
 | See Also Constructors Methods Properties

1/18/2008

Defines the programmatic interface that is used for verifying biometrics data.

The following tables list the members exposed by the BiometricsVerifyResult type.

Public Constructors

Name | Description
BiometricsVerifyResult | Creates an instance of the BiometricsVerifyResult class and initializes its members to the specified values.
Top

Public Properties

Name | Description
AdaptedBir | Gets the adapted Biometrics Information Record (BIR).
FalseAcceptRateAchieved | Gets the value of the false accept rate achieved for the match.
FalseRejectRateAchieved | Gets the value of the false reject rate achieved for the match.
Result | Gets a Boolean value that indicates whether the match was successful.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetPayload | Returns the payload.
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

BiometricsVerifyResult Class
Microsoft.PointOfService Namespace


BiometricsVerifyResult Constructor

BiometricsVerifyResult Constructor |
 | See Also

1/18/2008

Creates an instance of the BiometricsVerifyResult class and initializes its members to the specified values.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    result As Boolean, _
    falseAcceptRateAchieved As Integer, _
    falseRejectRateAchieved As Integer, _
    adaptedBir As BiometricsInformationRecord, _
    payload As Byte() _
)
public BiometricsVerifyResult (
    bool result,
    int falseAcceptRateAchieved,
    int falseRejectRateAchieved,
    BiometricsInformationRecord adaptedBir,
    byte[] payload
)
public:
BiometricsVerifyResult (
    bool result,
    int falseAcceptRateAchieved,
    int falseRejectRateAchieved,
    BiometricsInformationRecord^ adaptedBir,
    array<unsigned char>^ payload
)
public BiometricsVerifyResult (
    boolean result,
    int falseAcceptRateAchieved,
    int falseRejectRateAchieved,
    BiometricsInformationRecord adaptedBir,
    byte[] payload
)
public function BiometricsVerifyResult (
    result : boolean,
    falseAcceptRateAchieved : int,
    falseRejectRateAchieved : int,
    adaptedBir : BiometricsInformationRecord,
    payload : byte[]
)

Parameters

result

A Boolean value that is true for a successful match or false for a failed match.

falseAcceptRateAchieved

Contains the value of the false accept rate achieved for the match. This value is an indicator of the closeness of match.

falseRejectRateAchieved

Contains the value of the false reject rate achieved for the match. This value is an indicator of the closeness of the match.

adaptedBir

A pointer to handle the adapted BIR. If this parameter is left empty, an adapted BIR is not created.

payload

If a payload is associated with the referenceBIR, it is returned in an allocated byte[] if the FARAchieved satisfies the match criteria of the Service.

See Also

Reference

BiometricsVerifyResult Class
BiometricsVerifyResult Members
Microsoft.PointOfService Namespace


BiometricsVerifyResult Methods

BiometricsVerifyResult Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetPayload | Returns the payload.
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

BiometricsVerifyResult Class
Microsoft.PointOfService Namespace


BiometricsVerifyResult.GetPayload Method

BiometricsVerifyResult.GetPayload Method |
 | See Also

1/18/2008

Returns the payload.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Function GetPayload As Byte()
public byte[] GetPayload ()
public:
array<unsigned char>^ GetPayload ()
public byte[] GetPayload ()
public function GetPayload () : byte[]

Remarks

If a payload is associated with the referenceBIR, it is returned in an allocated byte[] if the FalseAcceptRateAchieved property satisfies the match criteria of the service.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BiometricsVerifyResult Class
BiometricsVerifyResult Members
Microsoft.PointOfService Namespace


BiometricsVerifyResult Properties

BiometricsVerifyResult Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
AdaptedBir | Gets the adapted Biometrics Information Record (BIR).
FalseAcceptRateAchieved | Gets the value of the false accept rate achieved for the match.
FalseRejectRateAchieved | Gets the value of the false reject rate achieved for the match.
Result | Gets a Boolean value that indicates whether the match was successful.

See Also

Reference

BiometricsVerifyResult Class
Microsoft.PointOfService Namespace


BiometricsVerifyResult.AdaptedBir Property

BiometricsVerifyResult.AdaptedBir Property |
 | See Also

1/18/2008

Gets the adapted Biometrics Information Record (BIR).

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property AdaptedBir As BiometricsInformationRecord
public BiometricsInformationRecord AdaptedBir { get; }
public:
property BiometricsInformationRecord^ AdaptedBir {
    BiometricsInformationRecord^ get ();
}
/** @property */
public BiometricsInformationRecord get_AdaptedBir ()

public function get AdaptedBir () : BiometricsInformationRecord

Remarks

If this parameter is left empty, an adapted BIR is not created.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BiometricsVerifyResult Class
BiometricsVerifyResult Members
Microsoft.PointOfService Namespace


BiometricsVerifyResult.FalseAcceptRateAchieved Property

BiometricsVerifyResult.FalseAcceptRateAchieved Property |
 | See Also

1/18/2008

Gets the value of the false accept rate achieved for the match.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property FalseAcceptRateAchieved As Integer
public int FalseAcceptRateAchieved { get; }
public:
property int FalseAcceptRateAchieved {
    int get ();
}
/** @property */
public int get_FalseAcceptRateAchieved ()

public function get FalseAcceptRateAchieved () : int

Remarks

This value is an indicator of the closeness of match.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BiometricsVerifyResult Class
BiometricsVerifyResult Members
Microsoft.PointOfService Namespace


BiometricsVerifyResult.FalseRejectRateAchieved Property

BiometricsVerifyResult.FalseRejectRateAchieved Property |
 | See Also

1/18/2008

Gets the value of the false reject rate achieved for the match.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property FalseRejectRateAchieved As Integer
public int FalseRejectRateAchieved { get; }
public:
property int FalseRejectRateAchieved {
    int get ();
}
/** @property */
public int get_FalseRejectRateAchieved ()

public function get FalseRejectRateAchieved () : int

Remarks

This value is an indicator of the closeness of match.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BiometricsVerifyResult Class
BiometricsVerifyResult Members
Microsoft.PointOfService Namespace


BiometricsVerifyResult.Result Property

BiometricsVerifyResult.Result Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the match was successful.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Result As Boolean
public bool Result { get; }
public:
property bool Result {
    bool get ();
}
/** @property */
public boolean get_Result ()

public function get Result () : boolean

Remarks

A Boolean value that is true indicates a successful match; false indicates a failed match.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BiometricsVerifyResult Class
BiometricsVerifyResult Members
Microsoft.PointOfService Namespace


BirDataTypes Enumeration

BirDataTypes Enumeration |
 | See Also

1/18/2008

Enumerates the possible types of data that the BiometricsInformationRecord (BIR) class can hold.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration BirDataTypes
[FlagsAttribute]
public enum BirDataTypes
[FlagsAttribute]
public enum class BirDataTypes
/** @attribute FlagsAttribute() */
public enum BirDataTypes
FlagsAttribute
public enum BirDataTypes

Members

Member name | Description
Encrypted | The BIR is encrypted.
Intermediate | The BIR contains intermediate data.
Processed | The BIR contains processed data.
Raw | The BIR contains raw data.
Signed | The BIR contains signed data.

Remarks

Used by the Biometrics device.

See Also

Reference

Microsoft.PointOfService Namespace


BirPurpose Enumeration

BirPurpose Enumeration |
 | See Also

1/18/2008

Enumerates the possible purpose for gathering the biometrics information.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration BirPurpose
public enum BirPurpose
public enum class BirPurpose
public enum BirPurpose
public enum BirPurpose

Members

Member name | Description
Audit | The biometrics data was gathered for auditing purposes.
Enroll | BIR was generated for Enrollment.
EnrollForIdentificationOnly | The biometrics data was gathered for verification only. Verification does not require the same level of quality as enrollment.
EnrollForVerificationOnly | The biometrics data was gathered for comparison against other data only.
Identify | The biometrics data was gathered for comparison against other data.
Unspecified | The purpose of the biometrics data is unspecified.
Verify | The biometrics data was gathered for verification purposes. Verification does not require the same level of quality as enrollment.

See Also

Reference

Microsoft.PointOfService Namespace


BorderType Enumeration

BorderType Enumeration |
 | See Also

1/18/2008

Enumerates the possible types of borders to display.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration BorderType
public enum BorderType
public enum class BorderType
public enum BorderType
public enum BorderType

Members

Member name | Description
Double | A double line border.
Single | A single line border.
Solid | A solid block border.

Remarks

Used by the DrawBox method. Replaces the ROD_BDR_SINGLE, ROD_BDR_DOUBLE, and ROD_BDR_SOLID constants from UPOS.

See Also

Reference

Microsoft.PointOfService Namespace
DrawBox


BumpBar Class

BumpBar Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a UPOS Bump Bar device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class BumpBar
    Inherits PosCommon
public abstract class BumpBar : PosCommon
public ref class BumpBar abstract : public PosCommon
public abstract class BumpBar extends PosCommon
public abstract class BumpBar extends PosCommon

Remarks

BumpBar supports broadcast methods that can communicate with one, a range, or all online bump bar units. BumpBar also supports bump bar input (keys 0-255).

BumpBar may also support bump bar enunciator output with frequency and duration, and tactile feedback through an automatic tone when a bump bar key is pressed.

Programming Model

The general model of a bump bar is as follows:

  • The BumpBar device class is a subsystem of bump bar units. The initial targeted environment is food service, to control the display of order preparation and fulfillment information. Bump bars typically are used together with remote order displays.

    The subsystem can support up to 32 bump bar units.

    One application on one computer or POS terminal is typically used to manage and control the subsystem of bump bars. If applications on the same or other computers and POS terminals must access the subsystem, this application must act as a subsystem server and expose interfaces to other applications.

  • All specific methods are broadcast methods. This means the method can apply to one unit, a selection of units, or all online units. The UnitsOnline property is a DeviceUnits enumeration, with each enumerator identifying an individual bump bar unit. (One or more of the constants Unit1 through Unit32 are bitwise ORed to form the bitmask.) The service object tries to satisfy the method for all unit(s) indicated in the UnitsOnline property. If an error is received from one or more units, the ErrorUnits property is updated with the appropriate units in error. The ErrorString property is updated with a description of the error or errors received. The method then returns with the corresponding error. In the case in which two or more units encounter different errors, the service object should determine the most severe error to return.

  • The ClearInput and ClearOutput methods (and the common method CheckHealth) are not broadcast methods and use the unit ID indicated in the CurrentUnitId property. (One of the enumerators Unit1 through Unit32 is selected.) See the description of these methods to understand how the CurrentUnitId property is used.

  • When the CurrentUnitId property is set by the application, all the corresponding properties are updated to reflect the settings for that unit.

    If the CurrentUnitId property is set to a unit ID that is not online, the dependent properties contain non-initialized values.

    The CurrentUnitId property uniquely represents a single bump bar unit. The definitions range from Unit1 to Unit32. These definitions are also used to create the bitwise parameter, Units, used in the broadcast methods. See the Examples section in this topic for usage.

The bump bar follows the general "Input Model" for event-driven input with some differences:

  • When input is received by the service object, it queues a DataEvent event.

  • This device does not support the AutoDisable property. So, the device does not automatically disable itself when a DataEvent is queued.

  • A queued DataEvent event can be delivered to the application when the DataEventEnabled property is true and other event delivery requirements are met. Just before delivering this event, the service object copies the data into properties and disables additional data events by setting the DataEventEnabled property to false. This causes later input data to be queued while the application processes the current input and associated properties. When the application has finished the current input and is ready for more data, it re-enables events by setting DataEventEnabled to true.

  • An ErrorEvent or events are queued if the service object encounters an error while collecting or processing input, and are delivered to the application when the DataEventEnabled property is true and other event delivery requirements are met.

  • The BumpBarDataCount property can be read to obtain the number of bump bar DataEvent entries for a specific unit ID queued by the service object. You can read the DataCount property to obtain the total number of data events queued by the service object.

  • You can delete queued input by calling the ClearInput method.

The Bump Bar service object must supply a mechanism for translating its internal key scan codes into user-defined codes that are returned by the DataEvent. Notice that this translation must be end-user configurable. The default translated key value is the scan code value.

The bump bar follows the general Output Model, with some improvements:

  • The BumpBarSound method is performed either synchronously or asynchronously, depending on the value of the AsyncMode property. When AsyncMode is false, BumpBarSound operates synchronously and returns its completion status to the application.

  • When AsyncMode is true, the following operations occur:

    • The service object buffers the request, sets the OutputId property to an identifier for this request, and returns as soon as possible. When the device completes the request successfully, the service object updates the EventUnits property and raises an OutputCompleteEvent event. A parameter of this event contains the output ID of the completed request.

  • Asynchronous methods do not return an error status because of a bump bar problem, such as a communications failure. These errors are only reported by an ErrorEvent event. An error status is returned only if the bump bar is not claimed and enabled, a parameter is invalid, or the request cannot be queued. The first two error cases are because of an application error, while the last is a serious system resource exception.

    • If an error occurs when you perform an asynchronous request, an ErrorEvent event is raised. The EventUnits property is set to the unit or units in error. The EventString property is also set.

      Note ErrorEvent updates the EventUnits and EventString properties. If an error is reported by a broadcast method, the ErrorUnits and ErrorString properties are set instead.

The event handler can call synchronous bump bar methods, but not asynchronous methods, can either retry the outstanding output or clear it.

  • The service object guarantees that asynchronous output is performed on a first-in, first-out basis.

  • You can delete all output buffered by the service object by setting the CurrentUnitId property and calling the ClearOutput method. OutputCompleteEvent events are not raised for cleared output. When it is possible, the ClearOutput method stops any output that may be in progress.

Device Sharing

The bump bar is an exclusive-use device. Its device-sharing rules are as follows:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before accessing many bump bar-specific properties.

  • The application must claim and enable the device before it calls methods that manipulate the device.

  • When the Claim method is called again, settable device characteristics are restored to their condition at Release.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.BumpBar
Microsoft.PointOfService.BasicServiceObjects.BumpBarBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BumpBar Members
Microsoft.PointOfService Namespace


BumpBar Members

BumpBar Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a UPOS Bump Bar device.

The following tables list the members exposed by the BumpBar type.

Protected Constructors

Name | Description
BumpBar | Creates an instance of the BumpBar class.
Top

Public Fields

Name | Description
DataEventKey | Indicates the event type for DataEvent events.
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticBumpCount | Incremented every time that the bump bar is pressed.
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
AsyncMode | Gets or sets a Boolean value that indicates whether the BumpBarSound method is performed asynchronously.
AutoToneDuration | Gets or sets the duration of the automatic tone.
AutoToneFrequency | Gets or sets the frequency of the automatic tone.
BumpBarDataCount | Gets the number of queued DataEvents.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapTone | Gets a Boolean value that indicates whether the bump bar device supports an enunciator.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
CurrentUnitId | Gets or sets the current bump bar unit ID.
DataCount | Gets the number of currently queued DataEvent events.
DataEventEnabled | Gets or sets a Boolean value that indicates whether a DataEvent event is delivered when input data is queued.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
ErrorString | Gets an error description.
ErrorUnits | Gets a bitwise mask of the unit(s) that encountered an error.
EventString | Gets a description of the error that occurred to the specified unit(s).
EventUnitId | Gets the bump bar unit ID causing a DataEvent event.
EventUnits | Gets a bitwise mask of the unit(s) when some events are delivered.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
Keys | Gets the number of keys on the specified bump bar unit.
OutputId | Gets the identifier of the most recently started asynchronous output.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Timeout | Gets or sets the time-out value that is used to complete output methods.
UnitsOnline | Gets a bitwise mask that indicates which bump bar units are online.
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether the Bump Bar is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
BumpBarSound | Sounds the bump bar enunciator for the bump bar(s) specified by the units parameter.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all buffered device input.
ClearOutput | Clears all buffered tone outputs.
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon)
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
SetKeyTranslation | Assigns a logical key value to key scan code.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DataEvent | Raised by the service object to notify the application that input data from the bump bar is available.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
ErrorEvent | Raised by the service object to notify the application that a bump bar error has been detected and a suitable response by the application is necessary to process the error condition.
OutputCompleteEvent | Raised by the service object to notify the application that the queued output request associated with the OutputId property has completed successfully.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

BumpBar Class
Microsoft.PointOfService Namespace


BumpBar Fields

BumpBar Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
DataEventKey | Indicates the event type for DataEvent events.
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticBumpCount | Incremented every time that the bump bar is pressed.
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

BumpBar Class
Microsoft.PointOfService Namespace


BumpBar.DataEventKey Field

BumpBar.DataEventKey Field |
 | See Also

1/18/2008

Indicates the event type for DataEvent events.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const DataEventKey As Integer
public const int DataEventKey
public:
literal int DataEventKey
public static final int DataEventKey
public const var DataEventKey : int

Remarks

Replaces the BB_DE_KEY from UPOS.

See Also

Reference

BumpBar Class
BumpBar Members
Microsoft.PointOfService Namespace
DataEvent


BumpBar.StatisticBumpCount Field

BumpBar.StatisticBumpCount Field |
 | See Also

1/18/2008

Incremented every time that the bump bar is pressed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticBumpCount As String
public const string StatisticBumpCount
public:
literal String^ StatisticBumpCount
public static final String StatisticBumpCount
public const var StatisticBumpCount : String

See Also

Reference

BumpBar Class
BumpBar Members
Microsoft.PointOfService Namespace
DataEvent


BumpBar Constructor

BumpBar Constructor |
 | See Also

1/18/2008

Creates an instance of the BumpBar class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected BumpBar ()
protected:
BumpBar ()
protected BumpBar ()
protected function BumpBar ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

BumpBar Class
BumpBar Members
Microsoft.PointOfService Namespace


BumpBar Methods

BumpBar Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
BumpBarSound | Sounds the bump bar enunciator for the bump bar(s) specified by the units parameter.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all buffered device input.
ClearOutput | Clears all buffered tone outputs.
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon )
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
SetKeyTranslation | Assigns a logical key value to key scan code.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

BumpBar Class
Microsoft.PointOfService Namespace


BumpBar.BumpBarSound Method

BumpBar.BumpBarSound Method |
 | See Also

1/18/2008

Sounds the bump bar enunciator for the bump bar(s) specified by the units parameter.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub BumpBarSound ( _
    units As DeviceUnits, _
    frequency As Integer, _
    duration As Integer, _
    numberOfCycles As Integer, _
    interSoundWait As Integer _
)
public abstract void BumpBarSound (
    DeviceUnits units,
    int frequency,
    int duration,
    int numberOfCycles,
    int interSoundWait
)
public:
virtual void BumpBarSound (
    DeviceUnits units,
    int frequency,
    int duration,
    int numberOfCycles,
    int interSoundWait
) abstract
public abstract void BumpBarSound (
    DeviceUnits units,
    int frequency,
    int duration,
    int numberOfCycles,
    int interSoundWait
)
public abstract function BumpBarSound (
    units : DeviceUnits,
    frequency : int,
    duration : int,
    numberOfCycles : int,
    interSoundWait : int
)

Parameters

units

Bitwise mask that indicates which bump bar unit(s) to operate on.

frequency

Tone frequency in Hertz.

duration

Tone duration in milliseconds.

numberOfCycles

If WaitForever, starts bump bar sounding and, repeats continuously. Else performs the specified number of cycles.

interSoundWait

When numberOfCycles is not one, pauses for interSoundWait milliseconds before repeating the tone cycle, that is before playing the tone again.

Remarks

BumpBarSound is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

The duration of a tone cycle is as follows:

duration parameter +

After the bump bar has started an asynchronous sound, you can stop the sound by using the ClearOutput method. When an interSoundWait value of WaitForever is used to start the sound, an application must use ClearOutput to stop the continuous sounding of tones.

If the CapTone property is false for the selected unit(s), an Illegal exception is thrown.

The following code example sounds one tone on unit ID 1 and unit ID 4. The frequency is set to 64 Hertz and will sound for 100 milliseconds:

Copy Code
BB.BumpBarSound( Unit1 | Unit4, 64, 100, 1, 0 )

BumpBarSound may throw a PosControlException with the following ErrorCodes.

Value

Meaning

Illegal

One of the following errors occurred:

  • numberOfCycles is neither a positive, nonzero value nor WaitForever.

  • numberOfCycles is WaitForever when AsyncMode is false.

  • A negative interSoundWait is specified.

  • units is zero or a nonexistent unit is specified.

  • A unit in units does not support the CapTone capability.

The ErrorUnits and ErrorCodeExtended properties may be updated before return.

Failure

An error occurred while communicating with one of the bump bar units specified by the units parameter. The ErrorUnits and ErrorCodeExtended properties are updated before return. (Can only be returned if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BumpBar Class
BumpBar Members
Microsoft.PointOfService Namespace
AsyncMode
ErrorString
ErrorUnits
CapTone
ClearOutput


BumpBar.ClearInput Method

BumpBar.ClearInput Method |
 | See Also

1/18/2008

Clears all buffered device input.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearInput
public abstract void ClearInput ()
public:
virtual void ClearInput () abstract
public abstract void ClearInput ()
public abstract function ClearInput ()

Remarks

Clears the device input that has been buffered for the unit specified by the CurrentUnitId property.

Any data events that are queued, usually waiting for the DataEventEnabled property to be set to true and the FreezeEvents property to be set to false, are also cleared.

ClearInput may cause a PosControlException to be thrown with the following ErrorCodes:

Value | Meaning
Claimed | The device is claimed by another process.
NotClaimed | The device must be claimed before ClearInput can be used.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BumpBar Class
BumpBar Members
Microsoft.PointOfService Namespace
CurrentUnitId
ClearOutput
DataEventEnabled


BumpBar.ClearOutput Method

BumpBar.ClearOutput Method |
 | See Also

1/18/2008

Clears all buffered tone outputs.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearOutput
public abstract void ClearOutput ()
public:
virtual void ClearOutput () abstract
public abstract void ClearOutput ()
public abstract function ClearOutput ()

Remarks

Clears the tone outputs that have been buffered. This includes asynchronous output for the unit specified by the CurrentUnitId property.

Any output complete and output error events that are queued, usually waiting for the DataEventEnabled property to be set to true and the FreezeEvents property to be set to false, are also cleared.

The ClearOutput method may cause a PosControlException exception to be thrown with the following ErrorCodes.

Value | Meaning
Claimed | The device is claimed by another process.
NotClaimed | The device must be claimed before ClearOutput can be used.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BumpBar Class
BumpBar Members
Microsoft.PointOfService Namespace
CurrentUnitId
BumpBar.ClearInput Method
DataEventEnabled


BumpBar.SetKeyTranslation Method

BumpBar.SetKeyTranslation Method |
 | See Also

1/18/2008

Assigns a logical key value to key scan code.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub SetKeyTranslation ( _
    units As DeviceUnits, _
    scanCode As Integer, _
    logicalKey As Integer _
)
public abstract void SetKeyTranslation (
    DeviceUnits units,
    int scanCode,
    int logicalKey
)
public:
virtual void SetKeyTranslation (
    DeviceUnits units,
    int scanCode,
    int logicalKey
) abstract
public abstract void SetKeyTranslation (
    DeviceUnits units,
    int scanCode,
    int logicalKey
)
public abstract function SetKeyTranslation (
    units : DeviceUnits,
    scanCode : int,
    logicalKey : int
)

Parameters

units

Bitwise mask that indicates which bump bar unit(s) to set key translation for.

scanCode

The bump bar generated key scan code. Valid values 0-255.

logicalKey

The translated logical key value. Valid values 0-255.

Remarks

SetKeyTranslation assigns a logical key value to a device-specific key scan code for the bump bar unit(s) specified by the units parameter. The logical key value is used during translation during the DataEvent.

SetKeyTranslation may cause a PosControlException to be thrown with the following ErrorCodes.

Value

Meaning

Illegal

One of the following errors occurred:

  • scanCode or logicalKey are out of range.

  • units is zero or a nonexistent unit was specified.

The DeviceErrorEventArgs and ErrorCodeExtended properties are updated before return.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BumpBar Class
BumpBar Members
Microsoft.PointOfService Namespace
ErrorUnits
ErrorString
DataEvent


BumpBar Properties

BumpBar Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
AsyncMode | Gets or sets a Boolean value that indicates whether the BumpBarSound method is performed asynchronously.
AutoToneDuration | Gets or sets the duration of the automatic tone.
AutoToneFrequency | Gets or sets the frequency of the automatic tone.
BumpBarDataCount | Gets the number of queued DataEvents.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapTone | Gets a Boolean value that indicates whether the bump bar device supports an enunciator.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
CurrentUnitId | Gets or sets the current bump bar unit ID.
DataCount | Gets the number of currently queued DataEvent events.
DataEventEnabled | Gets or sets a Boolean value that indicates whether a DataEvent event is delivered when input data is queued.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
ErrorString | Gets an error description.
ErrorUnits | Gets a bitwise mask of the unit(s) that encountered an error.
EventString | Gets a description of the error that occurred to the specified unit(s).
EventUnitId | Gets the bump bar unit ID causing a DataEvent event.
EventUnits | Gets a bitwise mask of the unit(s) when some events are delivered.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
Keys | Gets the number of keys on the specified bump bar unit.
OutputId | Gets the identifier of the most recently started asynchronous output.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )
Timeout | Gets or sets the time-out value that is used to complete output methods.
UnitsOnline | Gets a bitwise mask that indicates which bump bar units are online.

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether the Bump Bar is an exclusive-use device.

See Also

Reference

BumpBar Class
Microsoft.PointOfService Namespace


BumpBar.AsyncMode Property

BumpBar.AsyncMode Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether the BumpBarSound method is performed asynchronously.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AsyncMode As Boolean
public abstract bool AsyncMode { get; set; }
public:
virtual property bool AsyncMode {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_AsyncMode ()

/** @property */
public abstract void set_AsyncMode (boolean value)

public abstract function get AsyncMode () : boolean

public abstract function set AsyncMode (value : boolean)

Remarks

If true, the BumpBarSound method is performed asynchronously.If false, tones are generated synchronously.

AsyncMode is set by the service object and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BumpBar Class
BumpBar Members
Microsoft.PointOfService Namespace
BumpBar.BumpBarSound Method


BumpBar.AutoToneDuration Property

BumpBar.AutoToneDuration Property |
 | See Also

1/18/2008

Gets or sets the duration of the automatic tone.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AutoToneDuration As Integer
public abstract int AutoToneDuration { get; set; }
public:
virtual property int AutoToneDuration {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_AutoToneDuration ()

/** @property */
public abstract void set_AutoToneDuration (int value)

public abstract function get AutoToneDuration () : int

public abstract function set AutoToneDuration (value : int)

Remarks

Sets the duration (in milliseconds) of the automatic tone for the bump bar unit specified by the CurrentUnitId property.

AutoToneDuration is set and kept current by the service object while the device is enabled.

When it is accessed, AutoToneDuration may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Illegal | An illegal value was specified. The ErrorCodeExtended property is updated before return.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BumpBar Class
BumpBar Members
Microsoft.PointOfService Namespace
CurrentUnitId\
AutoToneFrequency
BumpBar.BumpBarSound Method


BumpBar.AutoToneFrequency Property

BumpBar.AutoToneFrequency Property |
 | See Also

1/18/2008

Gets or sets the frequency of the automatic tone.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AutoToneFrequency As Integer
public abstract int AutoToneFrequency { get; set; }
public:
virtual property int AutoToneFrequency {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_AutoToneFrequency ()

/** @property */
public abstract void set_AutoToneFrequency (int value)

public abstract function get AutoToneFrequency () : int

public abstract function set AutoToneFrequency (value : int)

Remarks

Sets the frequency (in Hertz) of the automatic tone for the bump bar unit specified by the CurrentUnitId property.

AutoToneFrequency is set and kept current by the service object while the device is enabled.

When it is accessed, AutoToneFrequency may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Illegal | An illegal value was specified. The DeviceErrorEventArgs.ErrorCodeExtended property is updated before return.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BumpBar Class
BumpBar Members
Microsoft.PointOfService Namespace
CurrentUnitId
BumpBar.AutoToneDuration Property
BumpBar.BumpBarSound Method


BumpBar.BumpBarDataCount Property

BumpBar.BumpBarDataCount Property |
 | See Also

1/18/2008

Gets the number of queued DataEvents.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property BumpBarDataCount As Integer
public abstract int BumpBarDataCount { get; }
public:
virtual property int BumpBarDataCount {
    int get () abstract;
}
/** @property */
public abstract int get_BumpBarDataCount ()

public abstract function get BumpBarDataCount () : int

Remarks

Indicates the number of currently queued DataEvents for the bump bar unit specified by the CurrentUnitId property.

An application can interrogate the BumpBarDataCount property to determine whether additional input is queued from a bump bar unit but has not yet been delivered because of other application processing, freezing of events, or other causes.

BumpBarDataCount is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BumpBar Class
BumpBar Members
Microsoft.PointOfService Namespace
CurrentUnitId
DataEvent


BumpBar.CapTone Property

BumpBar.CapTone Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the bump bar device supports an enunciator.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapTone As Boolean
public abstract bool CapTone { get; }
public:
virtual property bool CapTone {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapTone ()

public abstract function get CapTone () : boolean

Remarks

If true, the bump bar unit specified by the CurrentUnitId property supports an enunciator; otherwise it is false.

CapTone is updated by the service object based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BumpBar Class
BumpBar Members
Microsoft.PointOfService Namespace
CurrentUnitId


BumpBar.CurrentUnitId Property

BumpBar.CurrentUnitId Property |
 | See Also

1/18/2008

Gets or sets the current bump bar unit ID.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property CurrentUnitId As DeviceUnits
public abstract DeviceUnits CurrentUnitId { get; set; }
public:
virtual property DeviceUnits CurrentUnitId {
    DeviceUnits get () abstract;
    void set (DeviceUnits value) abstract;
}
/** @property */
public abstract DeviceUnits get_CurrentUnitId ()

/** @property */
public abstract void set_CurrentUnitId (DeviceUnits value)

public abstract function get CurrentUnitId () : DeviceUnits

public abstract function set CurrentUnitId (value : DeviceUnits)

Remarks

Some properties and methods apply only to the selected bump bar unit ID as noted. Up to 32 units are allowed for one bump bar device. The unit ID definitions range from Unit1 to Unit32 (replacing BB_UID_1 to BB_UID_32).

The following properties and methods apply only to the selected bump bar ID:

  • Properties: AutoToneDuration, AutoToneFrequency, BumpBarDataCount, CapTone, and Keys.

    Setting the CurrentUnitId property updates these properties to the current values for the specified unit.

  • Methods: CheckHealth, ClearInput, ClearOutput.

CurrentUnitId is set and updated by the service object while the device is enabled.

Accessing CurrentUnitId can cause general exceptions to be thrown and a PosControlException with the following specific ErrorCode.

Value | Meaning
Illegal | An illegal unit ID was specified. The ErrorCodeExtended property is updated before return.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BumpBar Class
BumpBar Members
Microsoft.PointOfService Namespace
BumpBar.AutoToneDuration Property
BumpBar.AutoToneFrequency Property
BumpBar.BumpBarDataCount Property
BumpBar.CapTone Property
Keys
CheckHealth
BumpBar.ClearInput Method
BumpBar.ClearOutput Method


BumpBar.DataCount Property

BumpBar.DataCount Property |
 | See Also

1/18/2008

Gets the number of currently queued DataEvent events.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DataCount As Integer
public abstract int DataCount { get; }
public:
virtual property int DataCount {
    int get () abstract;
}
/** @property */
public abstract int get_DataCount ()

public abstract function get DataCount () : int

Remarks

Indicates the total number of currently queued DataEvent events at the service object. All online units are included in this value. The number of queued events for a specific unit ID is stored in the BumpBarDataCount property.

The application can interrogate DataCount to determine whether additional input is queued from a device but has not yet been delivered because of other application processing, freezing of events, or other causes.

DataCount is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BumpBar Class
BumpBar Members
Microsoft.PointOfService Namespace
BumpBar.BumpBarDataCount Property
DataEvent
BumpBar.CurrentUnitId Property


BumpBar.DataEventEnabled Property

BumpBar.DataEventEnabled Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether a DataEvent event is delivered when input data is queued.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property DataEventEnabled As Boolean
public abstract bool DataEventEnabled { get; set; }
public:
virtual property bool DataEventEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_DataEventEnabled ()

/** @property */
public abstract void set_DataEventEnabled (boolean value)

public abstract function get DataEventEnabled () : boolean

public abstract function set DataEventEnabled (value : boolean)

Remarks

If true, a DataEvent is delivered as soon as input data is queued. If changed to true and some input data is already queued, a DataEvent event is delivered immediately. Notice that other conditions may delay "immediate" delivery: if FreezeEvents is true or another event is already being processed at the application, the DataEvent remains queued until the condition is corrected.

If false, input data is queued for later delivery to the application. Also, if an input error occurs, the ErrorEvent is not delivered while DataEventEnabled is false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BumpBar Class
BumpBar Members
Microsoft.PointOfService Namespace
DataEvent
ErrorEvent


BumpBar.ErrorString Property

BumpBar.ErrorString Property |
 | See Also

1/18/2008

Gets an error description.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ErrorString As String
public abstract string ErrorString { get; }
public:
virtual property String^ ErrorString {
    String^ get () abstract;
}
/** @property */
public abstract String get_ErrorString ()

public abstract function get ErrorString () : String

Remarks

When an error occurs for any method that acts on a bitwise set of bump bar units, ErrorString contains a description of the error that occurred to the unit(s) specified by ErrorUnits.

If an error occurs during processing of an asynchronous request, ErrorEvent updates the EventString property instead.

ErrorString is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BumpBar Class
BumpBar Members
Microsoft.PointOfService Namespace
ErrorUnits
ErrorEvent
EventString


BumpBar.ErrorUnits Property

BumpBar.ErrorUnits Property |
 | See Also

1/18/2008

Gets a bitwise mask of the unit(s) that encountered an error.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ErrorUnits As DeviceUnits
public abstract DeviceUnits ErrorUnits { get; }
public:
virtual property DeviceUnits ErrorUnits {
    DeviceUnits get () abstract;
}
/** @property */
public abstract DeviceUnits get_ErrorUnits ()

public abstract function get ErrorUnits () : DeviceUnits

Remarks

When an error occurs for any method that acts on a bitwise set of bump bar units, ErrorUnits will contain a bitwise mask of the unit(s) that encountered an error.

If an error occurs during processing of an asynchronous request, ErrorEvent updates the EventUnits property instead.

ErrorUnits is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BumpBar Class
BumpBar Members
Microsoft.PointOfService Namespace
BumpBar.ErrorString Property
ErrorEvent
EventUnits


BumpBar.EventString Property

BumpBar.EventString Property |
 | See Also

1/18/2008

Gets a description of the error that occurred to the specified unit(s).

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property EventString As String
public abstract string EventString { get; }
public:
virtual property String^ EventString {
    String^ get () abstract;
}
/** @property */
public abstract String get_EventString ()

public abstract function get EventString () : String

Remarks

When an ErrorEvent event is delivered, EventString contains a description of the error that occurred to the unit(s) specified by the EventUnits property.

EventString is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BumpBar Class
BumpBar Members
Microsoft.PointOfService Namespace
EventUnits
ErrorEvent


BumpBar.EventUnitId Property

BumpBar.EventUnitId Property |
 | See Also

1/18/2008

Gets the bump bar unit ID causing a DataEvent event.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property EventUnitId As DeviceUnits
public abstract DeviceUnits EventUnitId { get; }
public:
virtual property DeviceUnits EventUnitId {
    DeviceUnits get () abstract;
}
/** @property */
public abstract DeviceUnits get_EventUnitId ()

public abstract function get EventUnitId () : DeviceUnits

Remarks

Just before the service object delivers a DataEvent event to the application, it sets the EventUnitId property to the bump bar unit ID causing the event. The unit ID definitions range from Unit1 to Unit32.

EventUnitId is set and kept current by the service object based on the bump bar unit ID.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BumpBar Class
BumpBar Members
Microsoft.PointOfService Namespace
DataEvent


BumpBar.EventUnits Property

BumpBar.EventUnits Property |
 | See Also

1/18/2008

Gets a bitwise mask of the unit(s) when some events are delivered.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property EventUnits As DeviceUnits
public abstract DeviceUnits EventUnits { get; }
public:
virtual property DeviceUnits EventUnits {
    DeviceUnits get () abstract;
}
/** @property */
public abstract DeviceUnits get_EventUnits ()

public abstract function get EventUnits () : DeviceUnits

Remarks

When an OutputCompleteEvent, ErrorEvent, or StatusUpdateEvent occurs, the EventUnits property contains a bitwise mask of the unit(s).

EventUnits is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BumpBar Class
BumpBar Members
Microsoft.PointOfService Namespace
OutputCompleteEvent
ErrorEvent
StatusUpdateEvent


BumpBar.IsExclusiveUseDevice Property

BumpBar.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the Bump Bar is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Property Value

The Boolean value of true indicates that the physical printer is an exclusive-use device. Otherwise, the value is false.

Remarks

An exclusive-use device has the following properties:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before accessing some properties or calling methods that update the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BumpBar Class
BumpBar Members
Microsoft.PointOfService Namespace


BumpBar.Keys Property

BumpBar.Keys Property |
 | See Also

1/18/2008

Gets the number of keys on the specified bump bar unit.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property Keys As Integer
public abstract int Keys { get; }
public:
virtual property int Keys {
    int get () abstract;
}
/** @property */
public abstract int get_Keys ()

public abstract function get Keys () : int

Remarks

Gets the number of keys on the bump bar unit specified by the CurrentUnitId property.

The Keys property is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BumpBar Class
BumpBar Members
Microsoft.PointOfService Namespace
BumpBar.CurrentUnitId Property
BumpBar.Keys Property


BumpBar.OutputId Property

BumpBar.OutputId Property |
 | See Also

1/18/2008

Gets the identifier of the most recently started asynchronous output.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property OutputId As Integer
public abstract int OutputId { get; }
public:
virtual property int OutputId {
    int get () abstract;
}
/** @property */
public abstract int get_OutputId ()

public abstract function get OutputId () : int

Remarks

When a method successfully starts an asynchronous output, the device assigns an identifier to the request. When the output is complete, an OutputCompleteEvent event is queued with this output ID as a parameter.

The output ID numbers are assigned by POS for .NET and are guaranteed to be unique among the set of outstanding asynchronous outputs. No other facts about the ID should be assumed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BumpBar Class
BumpBar Members
Microsoft.PointOfService Namespace
OutputCompleteEvent


BumpBar.Timeout Property

BumpBar.Timeout Property |
 | See Also

1/18/2008

Gets or sets the time-out value that is used to complete output methods.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property Timeout As Integer
public abstract int Timeout { get; set; }
public:
virtual property int Timeout {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_Timeout ()

/** @property */
public abstract void set_Timeout (int value)

public abstract function get Timeout () : int

public abstract function set Timeout (value : int)

Remarks

The time-out value (in milliseconds) is used by the bump bar device to complete all supported output methods. If the device cannot successfully complete an output method within the specified time, the method returns a failure status if the AsyncMode property is false, or queues an ErrorEvent event, if the AsyncMode property is true.

The Timeout property is set by the service object.

Accessing Timeout property may cause a PosControlException exception to be thrown with the following ErrorCodes.

Value | Meaning
Illegal | A negative time-out value was specified. The ErrorCodeExtended property is updated before return.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BumpBar Class
BumpBar Members
Microsoft.PointOfService Namespace
BumpBar.AsyncMode Property
BumpBar.ErrorString Property
BumpBar.BumpBarSound Method
BumpBar.Timeout Property
ErrorEvent


BumpBar.UnitsOnline Property

BumpBar.UnitsOnline Property |
 | See Also

1/18/2008

Gets a bitwise mask that indicates which bump bar units are online.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property UnitsOnline As DeviceUnits
public abstract DeviceUnits UnitsOnline { get; }
public:
virtual property DeviceUnits UnitsOnline {
    DeviceUnits get () abstract;
}
/** @property */
public abstract DeviceUnits get_UnitsOnline ()

public abstract function get UnitsOnline () : DeviceUnits

Remarks

Zero or more of the unit constants Unit1 (bit 0 on) through Unit32 (bit 31 on) are joined together bitwise with the OR operator. 32 units are supported.

The UnitsOnline method is first set by the service object and updated as changes are detected, such as before a StatusUpdateEvent event is raised and during the CheckHealth method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

BumpBar Class
BumpBar Members
Microsoft.PointOfService Namespace
CheckHealth
StatusUpdateEvent


BumpBar Events

BumpBar Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DataEvent | Raised by the service object to notify the application that input data from the bump bar is available.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
ErrorEvent | Raised by the service object to notify the application that a bump bar error has been detected and a suitable response by the application is necessary to process the error condition.
OutputCompleteEvent | Raised by the service object to notify the application that the queued output request associated with the OutputId property has completed successfully.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

BumpBar Class
Microsoft.PointOfService Namespace


BumpBar.DataEvent Event

BumpBar.DataEvent Event |
 | See Also

1/18/2008

Raised by the service object to notify the application that input data from the bump bar is available.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event DataEvent As DataEventHandler
public abstract event DataEventHandler DataEvent
public:
virtual event DataEventHandler^ DataEvent {
    void add (DataEventHandler^ value) abstract;
    void remove (DataEventHandler^ value) abstract;
}
/** @event */
public abstract void add_DataEvent (DataEventHandler value)

/** @event */
public abstract void remove_DataEvent (DataEventHandler value)

Remarks

The Status property is divided into four bytes. Depending on the Event Type (located in the low word), the remaining two bytes contain additional data.

The high word, low byte contains additional data depending on the event type. When the event type is DataEventKey (replaces the BB_DE_KEY from UPOS), the low byte of the high word contains the logicalKey code for the key pressed on the bump bar unit. The logicalKey value is device independent. It has been translated by the service object from its original hardware specific value. Valid ranges are 0-255.

The high word, high byte value is unused.

The EventUnitId property is updated before delivering the event.

See Also

Reference

BumpBar Class
BumpBar Members
Microsoft.PointOfService Namespace
BumpBar.EventUnitId Property
BumpBar.DataEventEnabled Property
FreezeEvents
BumpBar.DataEventKey Field


BumpBar.ErrorEvent Event

BumpBar.ErrorEvent Event |
 | See Also

1/18/2008

Raised by the service object to notify the application that a bump bar error has been detected and a suitable response by the application is necessary to process the error condition.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event ErrorEvent As DeviceErrorEventHandler
public abstract event DeviceErrorEventHandler ErrorEvent
public:
virtual event DeviceErrorEventHandler^ ErrorEvent {
    void add (DeviceErrorEventHandler^ value) abstract;
    void remove (DeviceErrorEventHandler^ value) abstract;
}
/** @event */
public abstract void add_ErrorEvent (DeviceErrorEventHandler value)

/** @event */
public abstract void remove_ErrorEvent (DeviceErrorEventHandler value)

Remarks

The ErrorLocus property can be one of the following values.

Value | Description
Input | Error occurred while collecting or processing event-driven input. No input data is available.
InputData | Error occurred while collecting or processing event-driven input, and some previously buffered data is available.
Output | Error occurred when it processes asynchronous output.

The ErrorResponse property is preset by the service object to a default value, based on the ErrorLocus. The application can change it to one of the following values.

Value | Description
Clear | Clear all buffered output data (including all asynchronous output) or buffered input data. The error state is exited. Default when locus is Input.
ContinueInput | Use only when locus is InputData. Acknowledges the error and directs the service object to continue to process. The service object remains in the error state and delivers additional DataEvent events as directed by the DataEventEnabled property. When all input has been delivered and the DataEventEnabled property is again set to true, another ErrorEvent is delivered with locus Input. Default when locus is InputData.
Retry | Use only when locus is Output. Retry the asynchronous output. The error state is exited. Default when locus is Output.

ErrorEvent is queued when an error is detected while collecting data from or processing asynchronous output for the bump bar.

Input error events are not delivered until the DataEventEnabled property is true so that suitable application sequencing occurs.

The EventUnits and EventString properties are updated before ErrorEvent is delivered.

See Also

Reference

BumpBar Class
BumpBar Members
Microsoft.PointOfService Namespace
DeviceErrorEventArgs
BumpBar.DataEventEnabled Property
BumpBar.EventUnits Property
BumpBar.EventString Property


BumpBar.OutputCompleteEvent Event

BumpBar.OutputCompleteEvent Event |
 | See Also

1/18/2008

Raised by the service object to notify the application that the queued output request associated with the OutputId property has completed successfully.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event OutputCompleteEvent As OutputCompleteEventHandler
public abstract event OutputCompleteEventHandler OutputCompleteEvent
public:
virtual event OutputCompleteEventHandler^ OutputCompleteEvent {
    void add (OutputCompleteEventHandler^ value) abstract;
    void remove (OutputCompleteEventHandler^ value) abstract;
}
/** @event */
public abstract void add_OutputCompleteEvent (OutputCompleteEventHandler value)

/** @event */
public abstract void remove_OutputCompleteEvent (OutputCompleteEventHandler value)

Remarks

The OutputId property indicates the ID number of the asynchronous output request that is complete. The EventUnits property is updated before delivering.

OutputCompleteEvent is queued when a previously started asynchronous output request is completed successfully.

See Also

Reference

BumpBar Class
BumpBar Members
Microsoft.PointOfService Namespace
BumpBar.EventUnits Property
BumpBar.OutputId Property


CapSensorColors Enumeration

CapSensorColors Enumeration |
 | See Also

1/18/2008

Enumerates the possible image formats that the device supports.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration CapSensorColors
[FlagsAttribute]
public enum CapSensorColors
[FlagsAttribute]
public enum class CapSensorColors
/** @attribute FlagsAttribute() */
public enum CapSensorColors
FlagsAttribute
public enum CapSensorColors

Members

Member name | Description
Color16 | 16 Colors
Color256 | 256 Colors
Full | Full Colors
Grayscale | Grayscale
Mono | Bi-tonal (B/W)
None | No supported Image formats specified

Remarks

Indicates which image formats the device supports, other than bi-tonal (black and white).

See Also

Reference

Microsoft.PointOfService Namespace


CapSensorOrientations Enumeration

CapSensorOrientations Enumeration |
 | See Also

1/18/2008

Enumerates the possible degrees of rotation of the sensor image prior to processing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration CapSensorOrientations
[FlagsAttribute]
public enum CapSensorOrientations
[FlagsAttribute]
public enum class CapSensorOrientations
/** @attribute FlagsAttribute() */
public enum CapSensorOrientations
FlagsAttribute
public enum CapSensorOrientations

Members

Member name | Description
Inverted | 180°
Left | 270°
None | No specified value
Normal | 0°
Right | 90°

Remarks

This capability indicates the ability of the sensor image to be rotated prior to processing.

See Also

Reference

Microsoft.PointOfService Namespace


CapSensorTypes Enumeration

CapSensorTypes Enumeration |
 | See Also

1/18/2008

Enumerates the types of biometrics data that can be captured by the attached sensor.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration CapSensorTypes
[FlagsAttribute]
public enum CapSensorTypes
[FlagsAttribute]
public enum class CapSensorTypes
/** @attribute FlagsAttribute() */
public enum CapSensorTypes
FlagsAttribute
public enum CapSensorTypes

Members

Member name | Description
FacialFeatures | Facial Features/Topography
Fingerprint | Fingerprint
Gait | Gait/Stride
HandGeometry | Hand Geometry
Iris | Iris
KeystrokeDynamics | Keystrokes
LipMovement | Lip Movement
None | None
Password | Password
Retina | Retina
SignatureDynamics | Signature
ThermalFaceImage | Face Image
ThermalHandImage | Hand Image
Voice | Voice

Remarks

Indicates the types of biometrics data that can be captured by the attached sensor.

See Also

Reference

Microsoft.PointOfService Namespace


CardDetectionControl Enumeration

CardDetectionControl Enumeration |
 | See Also

1/18/2008

Enumerates whether the application or the reader/writer can control the detection processing, ejection processing, or storing processing of the card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration CardDetectionControl
public enum CardDetectionControl
public enum class CardDetectionControl
public enum CardDetectionControl
public enum CardDetectionControl

Members

Member name | Description
Application | The application can control the detection, ejection, or storing processing.
Device | The Electronic Value Reader/Writer (R/W) device can control the detection ejection, or storing processing.

Remarks

Replaces the EVRW_CDC_RWCONTROL and EVRW_CDC_APPLICATIONCONTROL properties from UPOS.

See Also

Reference

Microsoft.PointOfService Namespace


CardDetectionTypes Enumeration

CardDetectionTypes Enumeration |
 | See Also

1/18/2008

Enumerates the types of card detection.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration CardDetectionTypes
[FlagsAttribute]
public enum CardDetectionTypes
[FlagsAttribute]
public enum class CardDetectionTypes
/** @attribute FlagsAttribute() */
public enum CardDetectionTypes
FlagsAttribute
public enum CardDetectionTypes

Members

Member name | Description
Capture | The card is in the stock space. The stock space sensor detects the card.
Detect | There is a card in the device. The card detection sensor detects the card.
Entry | Card remaining at the insertion slot. The insertion slot sensor detects the card.

See Also

Reference

Microsoft.PointOfService Namespace


CashChanger Class

CashChanger Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a UPOS Cash Changer device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class CashChanger
    Inherits PosCommon
public abstract class CashChanger : PosCommon
public ref class CashChanger abstract : public PosCommon
public abstract class CashChanger extends PosCommon
public abstract class CashChanger extends PosCommon

Remarks

Capabilities

The cash changer has the following capabilities:

  • Reports the cash units and corresponding unit counts available in the cash changer.

  • Dispenses a specified amount of cash from the device in either bills, coins, or both into a user-specified exit.

  • Dispenses a specified number of cash units from the device in either bills, coins, or both into a user-specified exit.

  • Reports jam conditions within the device.

  • Supports more than one currency.

The cash changer may also have the following additional capabilities:

  • Reporting the fullness levels of the cash units of a cash changer. Conditions which can be indicated include empty, almost empty, full, and almost full states.

  • Reporting of a possible (or probable) cash count discrepancy in the data reported by the ReadCashCounts method.

Programming Model

The general model of a cash changer is as follows:

  • Supports several cash types such as coins, bills, and combinations of coins and bills. The supported cash type for a particular currency is noted by the list of cash units in the CurrencyCashList property.

  • Consists of any combination of features to help carry out the cash-processing functions such as a cash entry holding bin, several slots or bins that can hold the cash, and cash exits.

  • Provides programmatic control only for the dispensing of cash. The acceptance of cash by the device (for example, to replenish cash) cannot be controlled by the APIs provided in this model. The application can call the ReadCashCounts method to retrieve the current unit count for each cash unit.

  • May have multiple exits. The number of exits is specified in the DeviceExits property. The application chooses a dispensing exit by setting the CurrentExit property. The cash units that may be dispensed to the current exit are indicated by the ExitCashList property. When the CurrentExit value is 1, the exit is considered the primary exit, typically used during usual processing for dispensing cash to a customer following a retail transaction. When the CurrentExit property is a value greater than 1, the exit is considered an auxiliary exit. An auxiliary exit typically is used for special purposes such as dispensing quantities or types of cash not targeted for the primary exit.

  • Dispensing cash into the exit specified by the CurrentExit property is performed by calling either the DispenseChange or DispenseCash method. With the DispenseChange method, the application specifies a total amount to dispense, and it is the responsibility of the cash changer device or the service object to dispense the correct amount of cash from the various slots or bins. With the DispenseCash method, the application specifies a count of each cash unit to dispense.

  • Dispenses cash either synchronously or asynchronously, depending on the value of the AsyncMode property.

    When AsyncMode is false, the cash dispensing methods are performed synchronously and the dispensing method returns the completion status to the application.

When the AsyncMode property is true and the DispenseChange or DispenseCash method is successful, the method is performed asynchronously and its completion is indicated by a StatusUpdateEvent event containing StatusAsync as its Status value. The method’s completion status is set in the AsyncResultCode and AsyncResultCodeExtended properties.

The values of the AsyncResultCode and AsyncResultCodeExtended properties are the same as those returned in the ErrorCode and ErrorCodeExtended properties when synchronous dispensing is chosen.

The ReadCashCounts method cannot be performed while an asynchronous method is being performed because doing this might report incorrect cash counts.

  • Can support more than one currency. The CurrencyCode property can be set to the currency, selecting from a currency in CurrencyCodeList. The properties and methods CurrencyCashList, ExitCashList, DispenseCash, DispenseChange and ReadCashCounts all act upon the current currency only.

  • Sets the cash slot (or cash bin) conditions in the DeviceStatus property to show empty and almost empty status, and in the FullStatus property to show full and almost full status. If there are one or more empty cash slots, DeviceStatus is Empty, and if there are one or more full cash slots, then FullStatus is Full.

The cash acceptance model is as follows:

  • The DispenseChange and DispenseCash methods are independent of the cash acceptance function. The AsyncMode property value does not affect cash acceptance methods.

  • If the CapDeposit property is true, cash acceptance is supported and the BeginDeposit, FixDeposit, and EndDeposit methods are in use. Cash dispensing is disabled while cash acceptance is in progress. Also, cash acceptance is disabled while cash dispensing is in progress.

  • When the application calls the BeginDeposit method, the DepositCounts and DepositAmount properties are initialized to zero.

  • When the cash changer accepts cash, the value of the DepositCounts and DepositAmount properties increase, and a DataEvent event is raised if the CapDepositDataEvent property is true.

  • If the CapPauseDeposit property is true, the application can pause cash acceptance by calling the PauseDeposit method with a parameter of Pause. Then, the value of the DepositCounts and DepositAmount properties is fixed. If the application wants to resume cash acceptance, it calls the PauseDeposit method again with a parameter value of Restart. By reading either the DepositCounts or DepositAmount property, the application can get the exact amount of accepted cash, and compare the accepted cash total with the sale amount. If the accepted cash is equal to or greater than the amount of the sale, the application calls the FixDeposit method. If the accepted cash is less than amount of the sale, the application calls the PauseDeposit method with Restart. To get the total amount of accepted cash, the application should repeat the PauseDeposit method.

  • When the FixDeposit method is called, the cash changer stops accepting cash and the value of the DepositCounts and DepositAmount is fixed.

  • If it is necessary, the application can calculate the change by using the DepositCounts and DepositAmount properties after the FixDeposit method. After the FixDeposit method is called, the application cannot resume cash acceptance and must call the EndDeposit method to complete the cash acceptance process.

  • To exit the cash acceptance process, the application must call the EndDeposit method.

  • The values of the success parameter of the EndDeposit method have the following meanings:

    • Change: The application dispenses cash. This is typically used to dispense change due from a sale.

    • NoChange: The application does not dispense cash. This typically indicates that the total amount of accepted cash is equal to the total amount of the sale.

    • Repay: The application repays the total amount of cash. This typically is a cancellation of the sale. Repay can only be used when CapRepayDeposit is true. If CapRepayDeposit is false, the application must dispense the total amount of accepted cash by calling either the DispenseChange or DispenseCash method. Some cash changers may not repay accepted cash, depending on the cash changer mechanism.

  • When the ClearInput method is run, all queued DataEvent events associated with cash acceptance are cleared. But the value of the DepositCounts and DepositAmount properties are not cleared.

Device Sharing

The cash changer is an exclusive-use device. Its device sharing rules are as follows:

  • The application must claim the device the application enables it.

  • The application must claim and enable the device before accessing some properties, dispensing or collecting, or receiving status update events.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.CashChanger
Microsoft.PointOfService.BasicServiceObjects.CashChangerBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Members
Microsoft.PointOfService Namespace


CashChanger Members

CashChanger Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a UPOS Cash Changer device.

The following tables list the members exposed by the CashChanger type.

Protected Constructors

Name | Description
CashChanger | Creates an instance of CashChanger class.
Top

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorOverDispense | Indicates that the specified cash cannot be dispensed because of a cash shortage.
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusAsync | Indicates that an asynchronously performed method has finished.
StatusEmpty | Indicates that some cash slots are empty.
StatusEmptyOK | Indicates that no cash slots are empty or almost empty.
StatusFull | Indicates that some cash slots are full.
StatusFullOK | Indicates that no cash slots are full or almost full.
StatusJam | Indicates that a mechanical fault has occurred.
StatusJamOK | Indicates that a mechanical fault has recovered.
StatusNearEmpty | Indicates that some cash slots are almost empty.
StatusNearFull | Indicates that some cash slots are almost full.
StatusOK | Indicates that the device is ready to dispense coinage.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
AsyncMode | Gets or sets a Boolean value that indicates whether CashChanger methods are performed asynchronously.
AsyncResultCode | Gets the completion status of the last asynchronous dispense request.
AsyncResultCodeExtended | Gets the completion status of the last asynchronous dispense request.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapDeposit | Gets a Boolean value that indicates whether the device supports cash acceptance.
CapDepositDataEvent | Gets a Boolean value that indicates whether the device can report cash acceptance events.
CapDiscrepancy | Gets a Boolean value that indicates whether ReadCashCounts can report effective Discrepancy values.
CapEmptySensor | Gets a Boolean value that indicates whether the device can report that some cash slots are empty.
CapFullSensor | Gets a Boolean value that indicates whether the device can report that some cash slots are full.
CapJamSensor | Gets a Boolean value that indicates whether the device can report that a mechanical fault has occurred in the cash changer.
CapNearEmptySensor | Gets a Boolean value that indicates whether the device can report that some cash slots are almost empty.
CapNearFullSensor | Gets a Boolean value that indicates whether the device can report that some cash slots are almost full.
CapPauseDeposit | Gets a Boolean value that indicates whether the device can suspend cash acceptance.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapRealTimeData | Gets a Boolean value that indicates whether the device may supply data as the money is being accepted.
CapRepayDeposit | Gets a Boolean value that indicates whether the device can return deposited money.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
CurrencyCashList | Gets a list of cash units supported in the cash changer for the currency represented by the CurrencyCode property.
CurrencyCode | Gets or sets the active currency code to be used by cash changer operations.
CurrencyCodeList | Gets a list of ASCII 3-character ISO 4217 currency codes, separated by commas.
CurrentExit | Gets or sets a value that indicates the current cash-dispensing exit.
CurrentService | Gets or sets the current service.
DataCount | Gets the number of currently queued DataEvent events.
DataEventEnabled | Gets or sets a Boolean value that indicates whether a DataEvent event can be delivered when input data is queued.
DepositAmount | Gets the total amount of cash accepted.
DepositCashList | Gets the cash units supported in the cash changer for the currency represented by the CurrencyCode property.
DepositCodeList | Gets a list of the currency code indicators for the cash accepted.
DepositCounts | Gets the total of the cash accepted by the cash units.
DepositStatus | Gets the current status of the cash acceptance operation.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceExits | Gets the number of exits for dispensing cash.
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
DeviceStatus | Gets the current status of the cash changer.
ExitCashList | Gets the cash units that can be dispensed to the exit denoted by the CurrentExit property.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
FullStatus | Gets the current full status of the cash slots.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
RealTimeDataEnabled | Get or sets the Boolean value that indicates whether the DepositAmount and DepositCounts properties are updated in real time.
ServiceCount | Gets the number of integrated services used by the cash changer service.
ServiceIndex | Indicates the service index for each type of the integrated service types.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicated whether the Cash Changer is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
AdjustCashCounts | Sets the initial amount of cash after setup or adjusts cash counts after replenishment or removal.
BeginDeposit | Starts a cash acceptance operation.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all device input that has been buffered.
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
DispenseCash | Dispenses the specified cash units and cash counts from the device.
DispenseChange | Dispenses the specified amount of cash.
EndDeposit | Completes a cash acceptance operation.
Equals | Overloaded. (inherited from Object )
FixDeposit | Updates property values to reflect the current values in the device.
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon)
PauseDeposit | Suspends or resumes depositing cash.
ReadCashCounts | Reads the current cash counts.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DataEvent | Raised by the service object to notify the application when the cash changer has a status change.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

CashChanger Class
Microsoft.PointOfService Namespace


CashChanger Fields

CashChanger Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorOverDispense | Indicates that the specified cash cannot be dispensed because of a cash shortage.
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusAsync | Indicates that an asynchronously performed method has finished.
StatusEmpty | Indicates that some cash slots are empty.
StatusEmptyOK | Indicates that no cash slots are empty or almost empty.
StatusFull | Indicates that some cash slots are full.
StatusFullOK | Indicates that no cash slots are full or almost full.
StatusJam | Indicates that a mechanical fault has occurred.
StatusJamOK | Indicates that a mechanical fault has recovered.
StatusNearEmpty | Indicates that some cash slots are almost empty.
StatusNearFull | Indicates that some cash slots are almost full.
StatusOK | Indicates that the device is ready to dispense coinage.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

CashChanger Class
Microsoft.PointOfService Namespace


CashChanger.ExtendedErrorOverDispense Field

CashChanger.ExtendedErrorOverDispense Field |
 | See Also

1/18/2008

Indicates that the specified cash cannot be dispensed because of a cash shortage.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorOverDispense As Integer
public const int ExtendedErrorOverDispense
public:
literal int ExtendedErrorOverDispense
public static final int ExtendedErrorOverDispense
public const var ExtendedErrorOverDispense : int

Remarks

Used by the DispenseCash and DispenseChange methods. Represents the UPOS standard error code ECHAN_OVERDISPENSE.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
DispenseCash
DispenseChange


CashChanger.StatusAsync Field

CashChanger.StatusAsync Field |
 | See Also

1/18/2008

Indicates that an asynchronously performed method has finished.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusAsync As Integer
public const int StatusAsync
public:
literal int StatusAsync
public static final int StatusAsync
public const var StatusAsync : int

Remarks

Represents the UPOS standard error code CHAN_STATUS_ASYNC.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
AsyncResultCode
AsyncResultCodeExtended


CashChanger.StatusEmpty Field

CashChanger.StatusEmpty Field |
 | See Also

1/18/2008

Indicates that some cash slots are empty.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusEmpty As Integer
public const int StatusEmpty
public:
literal int StatusEmpty
public static final int StatusEmpty
public const var StatusEmpty : int

Remarks

Represents the UPOS standard error code CHAN_STATUS_EMPTY.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
StatusUpdateEvent


CashChanger.StatusEmptyOK Field

CashChanger.StatusEmptyOK Field |
 | See Also

1/18/2008

Indicates that no cash slots are empty or almost empty.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusEmptyOK As Integer
public const int StatusEmptyOK
public:
literal int StatusEmptyOK
public static final int StatusEmptyOK
public const var StatusEmptyOK : int

Remarks

Represents the UPOS standard error code CHAN_STATUS_EMPTYOK.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
StatusUpdateEvent


CashChanger.StatusFull Field

CashChanger.StatusFull Field |
 | See Also

1/18/2008

Indicates that some cash slots are full.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusFull As Integer
public const int StatusFull
public:
literal int StatusFull
public static final int StatusFull
public const var StatusFull : int

Remarks

Represents the UPOS standard error code CHAN_STATUS_FULL.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
StatusUpdateEvent


CashChanger.StatusFullOK Field

CashChanger.StatusFullOK Field |
 | See Also

1/18/2008

Indicates that no cash slots are full or almost full.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusFullOK As Integer
public const int StatusFullOK
public:
literal int StatusFullOK
public static final int StatusFullOK
public const var StatusFullOK : int

Remarks

Represents the UPOS standard error code CHAN_STATUS_FULLOK.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
StatusUpdateEvent


CashChanger.StatusJam Field

CashChanger.StatusJam Field |
 | See Also

1/18/2008

Indicates that a mechanical fault has occurred.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusJam As Integer
public const int StatusJam
public:
literal int StatusJam
public static final int StatusJam
public const var StatusJam : int

Remarks

Represents the UPOS standard error code CHAN_STATUS_JAM.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
StatusUpdateEvent


CashChanger.StatusJamOK Field

CashChanger.StatusJamOK Field |
 | See Also

1/18/2008

Indicates that a mechanical fault has recovered.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusJamOK As Integer
public const int StatusJamOK
public:
literal int StatusJamOK
public static final int StatusJamOK
public const var StatusJamOK : int

Remarks

Represents the UPOS standard error code CHAN_STATUS_JAMOK.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
StatusUpdateEvent


CashChanger.StatusNearEmpty Field

CashChanger.StatusNearEmpty Field |
 | See Also

1/18/2008

Indicates that some cash slots are almost empty.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusNearEmpty As Integer
public const int StatusNearEmpty
public:
literal int StatusNearEmpty
public static final int StatusNearEmpty
public const var StatusNearEmpty : int

Remarks

Represents the UPOS standard error code CHAN_STATUS_NEAREMPTY.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
StatusUpdateEvent


CashChanger.StatusNearFull Field

CashChanger.StatusNearFull Field |
 | See Also

1/18/2008

Indicates that some cash slots are almost full.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusNearFull As Integer
public const int StatusNearFull
public:
literal int StatusNearFull
public static final int StatusNearFull
public const var StatusNearFull : int

Remarks

Represents the UPOS standard error code CHAN_STATUS_NEARFULL.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
StatusUpdateEvent


CashChanger.StatusOK Field

CashChanger.StatusOK Field |
 | See Also

1/18/2008

Indicates that the device is ready to dispense coinage.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusOK As Integer
public const int StatusOK
public:
literal int StatusOK
public static final int StatusOK
public const var StatusOK : int

Remarks

Also used to indicate the dispenser is unable to detect an error condition.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
StatusUpdateEvent


CashChanger Constructor

CashChanger Constructor |
 | See Also

1/18/2008

Creates an instance of CashChanger class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected CashChanger ()
protected:
CashChanger ()
protected CashChanger ()
protected function CashChanger ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace


CashChanger Methods

CashChanger Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
AdjustCashCounts | Sets the initial amount of cash after setup or adjusts cash counts after replenishment or removal.
BeginDeposit | Starts a cash acceptance operation.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all device input that has been buffered.
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
DispenseCash | Dispenses the specified cash units and cash counts from the device.
DispenseChange | Dispenses the specified amount of cash.
EndDeposit | Completes a cash acceptance operation.
Equals | Overloaded. (inherited from Object )
FixDeposit | Updates property values to reflect the current values in the device.
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon )
PauseDeposit | Suspends or resumes depositing cash.
ReadCashCounts | Reads the current cash counts.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

CashChanger Class
Microsoft.PointOfService Namespace


CashChanger.AdjustCashCounts Method

CashChanger.AdjustCashCounts Method |
 | See Also

1/18/2008

Sets the initial amount of cash after setup or adjusts cash counts after replenishment or removal.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Sub AdjustCashCounts ( _
    cashCounts As IEnumerable(Of CashCount) _
)
public virtual void AdjustCashCounts (
    IEnumerable<CashCount> cashCounts
)
public:
virtual void AdjustCashCounts (
    IEnumerable<CashCount>^ cashCounts
)
public void AdjustCashCounts (
    IEnumerable<CashCount> cashCounts
)
public function AdjustCashCounts (
    cashCounts : IEnumerable<CashCount>
)

Parameters

cashCounts

The cashCounts parameter contains cash types and amounts to be initialized.

Remarks

This method is called to set the initial amounts in the cash changer after initial setup, or to adjust cash counts after replenishment or removal, such as a paid in or paid out operation. This method is called when it is necessary for devices which cannot determine the exact amount of cash in them automatically. If the device can determine the exact amount, then this method call is ignored. The application would first call ReadCashCounts for the current counts, and adjust them to the amount being replenished. Then the application calls this method to set the amount currently in the changer.

To reset all cash counts to zero, set each denomination amount to zero.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
ReadCashCounts


CashChanger.BeginDeposit Method

CashChanger.BeginDeposit Method |
 | See Also

1/18/2008

Starts a cash acceptance operation.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub BeginDeposit
public abstract void BeginDeposit ()
public:
virtual void BeginDeposit () abstract
public abstract void BeginDeposit ()
public abstract function BeginDeposit ()

Remarks

Cash acceptance is started.

The following property values are initialized by the call to this method:

  • The value of each cash unit of the DepositCounts property is set to zero.

  • The DepositAmount property is set to zero.

After the code calls this method, if CapDepositDataEvent is true, cash acceptance is reported by DataEvent until FixDeposit is called while the deposit process is not paused.

BeginDeposit may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Illegal | Either the cash changer does not support cash acceptance, or the call sequence is incorrect.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
DepositCounts
DepositAmount
CapDepositDataEvent
EndDeposit
FixDeposit
PauseDeposit


CashChanger.ClearInput Method

CashChanger.ClearInput Method |
 | See Also

1/18/2008

Clears all device input that has been buffered.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearInput
public abstract void ClearInput ()
public:
virtual void ClearInput () abstract
public abstract void ClearInput ()
public abstract function ClearInput ()

Remarks

Any data events or input error events that are queued, usually waiting for DataEventEnabled to be set to true and FreezeEvents to be set to false, are also cleared.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace


CashChanger.DispenseCash Method

CashChanger.DispenseCash Method |
 | See Also

1/18/2008

Dispenses the specified cash units and cash counts from the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub DispenseCash ( _
    cashCounts As CashCount() _
)
public abstract void DispenseCash (
    CashCount[] cashCounts
)
public:
virtual void DispenseCash (
    array<CashCount>^ cashCounts
) abstract
public abstract void DispenseCash (
    CashCount[] cashCounts
)
public abstract function DispenseCash (
    cashCounts : CashCount[]
)

Parameters

cashCounts

Contains the dispensing cash units and counts, as an array of CashCount objects.

Remarks

Dispenses the cash from the cash changer into the exit specified by CurrentExit. The cash dispensed is specified by pairs of cash units and counts.

DispenseCash is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

DispenseCash can throw general exceptions and PosControlExceptions with the following values in ErrorCode:

Value

Meaning

Busy

The specified cash cannot be dispensed because an asynchronous method is in progress.

Illegal

One of the following errors occurred:

  • The cashCounts parameter value is illegal for the current exit.

  • Cash cannot be dispensed because cash acceptance is in progress.

Extended

An extended error has occurred.

The following value may be set in ErrorCodeExtended if P:Microsoft.PointOfService.PosControlException.ErrorCode is Extended:

Value | Meaning
ExtendedErrorOverDispense | The specified cash cannot be dispensed because of a cash shortage.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
CashCount
AsyncMode
CurrentExit


CashChanger.DispenseChange Method

CashChanger.DispenseChange Method |
 | See Also Example

1/18/2008

Dispenses the specified amount of cash.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub DispenseChange ( _
    amount As Integer _
)
public abstract void DispenseChange (
    int amount
)
public:
virtual void DispenseChange (
    int amount
) abstract
public abstract void DispenseChange (
    int amount
)
public abstract function DispenseChange (
    amount : int
)

Parameters

amount

Indicates the change to be dispensed.

Remarks

Dispenses the specified amount of cash from the cash changer into the exit represented by CurrentExit.

It is up to the cash changer to determine which combination of bills and coins satisfies the request, based on the current CurrencyCode and the amounts and denominations of coins and bills available.

DispenseChange is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

DispenseChange can throw general exceptions and PosControlExceptions with the following values in ErrorCode.

Value

Meaning

Busy

The specified change cannot be dispensed because an asynchronous method is in progress.

Illegal

One of the following errors occurred:

  • A negative or zero amount is specified.

  • The amount cannot be dispensed based on the values specified in ExitCashList for the current exit.

  • Change cannot be dispensed because cash acceptance was in progress.

Extended

An extended error has occurred.

The following value may be set in ErrorCodeExtended if P:Microsoft.PointOfService.PosControlException.ErrorCode is Extended.

Value | Meaning
ExtendedErrorOverDispense | The specified cash cannot be dispensed because of a cash shortage.

Example

Given a POS device that offers booklets of stamps for $7.50 in United States currency (USD) and given a deposit of $20, the Cash Changer should then distribute $12.50 in change.

The amount passed to DispenseChange is 1250, representing 1250 in the base US currency unit: in this case, cents.

The supported denominations and cash supply of the device determine the actual form of the change distribution. Given a Cash Changer that can distribute bills in increments of 10-, 5-, or 1-dollars, and coins in 25-, 10- and 5-cent denominations, the actual distribution might be any of the following, given variances in cash amounts in the device:

  • one 10-dollar bill, two 1-dollar bills, and two 25-cent coins

  • two 5-dollar bills and ten 25-cent coins

  • one 5-dollar bill, seven 1-dollar bills, and five 10-cent coins

  • or any other combination of these types of bills and coins that satisfy the request.

If no combination of available bills and coins could satisfy the request, a PosControlException is thrown, with either an Illegal or ExtendedErrorOverDispense error code depending on the reason the change could not be dispensed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
AsyncMode
CurrentExit


CashChanger.EndDeposit Method

CashChanger.EndDeposit Method |
 | See Also

1/18/2008

Completes a cash acceptance operation.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub EndDeposit ( _
    successAction As CashDepositAction _
)
public abstract void EndDeposit (
    CashDepositAction successAction
)
public:
virtual void EndDeposit (
    CashDepositAction successAction
) abstract
public abstract void EndDeposit (
    CashDepositAction successAction
)
public abstract function EndDeposit (
    successAction : CashDepositAction
)

Parameters

successAction

Valid values are defined by the CashDepositAction enumeration.

Remarks

Determines how to deal with the cash that was deposited, determined by the successAction parameter.

Before the code calls this method, the application must calculate the difference between the deposit and the amount required. If the deposited amount was greater than the amount required, use Change as the successAction parameter. If the deposited amount was equal to or less than the amount required, use NoChange as the successAction parameter.

If successAction is Repay, the deposit is repaid through either the cash deposit exit or the cash payment exit without storing the actual deposited cash.

The application must call FixDeposit before it calls EndDeposit

EndDeposit may throw a PosControlException with the following ErrorCodes.

Value

Meaning

Illegal

One of the following errors occurred:

  • Cash acceptance is not supported.

  • The call sequence is incorrect. BeginDeposit and FixDeposit must be called in sequence before you call this method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
DepositCounts
DepositAmount
CapDepositDataEvent
CashChanger.BeginDeposit Method
FixDeposit
PauseDeposit


CashChanger.FixDeposit Method

CashChanger.FixDeposit Method |
 | See Also

1/18/2008

Updates property values to reflect the current values in the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub FixDeposit
public abstract void FixDeposit ()
public:
virtual void FixDeposit () abstract
public abstract void FixDeposit ()
public abstract function FixDeposit ()

Remarks

When FixDeposit is called, all property values are updated to reflect the current values in the cash changer.

FixDeposit may cause a PosControlException to be thrown with the following ErrorCodes.

Value

Meaning

Illegal

One of the following errors occurred:

  • Cash acceptance is not supported.

  • The call sequence is incorrect. BeginDeposit must be called before the code calls this method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
DepositCounts
DepositAmount
CashChanger.BeginDeposit Method
CashChanger.EndDeposit Method
PauseDeposit


CashChanger.PauseDeposit Method

CashChanger.PauseDeposit Method |
 | See Also

1/18/2008

Suspends or resumes depositing cash.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PauseDeposit ( _
    pauseAction As CashDepositPause _
)
public abstract void PauseDeposit (
    CashDepositPause pauseAction
)
public:
virtual void PauseDeposit (
    CashDepositPause pauseAction
) abstract
public abstract void PauseDeposit (
    CashDepositPause pauseAction
)
public abstract function PauseDeposit (
    pauseAction : CashDepositPause
)

Parameters

pauseAction

Valid values are defined by the CashDepositPause enumeration.

Remarks

PauseDeposit is used to suspend or resume depositing cash.

If pauseAction is Pause, the cash acceptance operation is paused. The deposit process remains paused until PauseDeposit is called by using pauseAction equal to Restart. You can call the FixDeposit method while cash acceptance is paused.

When the deposit process is paused, the DepositCounts and DepositAmount properties are updated to reflect the current state of the cash changer. The property values are not changed again until the deposit is resumed.

If pauseAction is Restart, the deposit process is resumed.

PauseDeposit may cause a PosControlException to be thrown with the following ErrorCodes.

Value

Meaning

Illegal

One of the following errors occurred:

  • Cash acceptance is not supported.

  • The call sequence is incorrect. BeginDeposit must be called before the code calls PauseDeposit.

  • The deposit process is already paused and pauseAction is Pause, or the deposit process in not paused and pauseAction is Restart.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
DepositCounts
DepositAmount
CapDepositDataEvent
CapPauseDeposit
CashChanger.BeginDeposit Method
CashChanger.EndDeposit Method
CashChanger.FixDeposit Method


CashChanger.ReadCashCounts Method

CashChanger.ReadCashCounts Method |
 | See Also

1/18/2008

Reads the current cash counts.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function ReadCashCounts As CashCounts
public abstract CashCounts ReadCashCounts ()
public:
virtual CashCounts ReadCashCounts () abstract
public abstract CashCounts ReadCashCounts ()
public abstract function ReadCashCounts () : CashCounts

Remarks

The format of the CashCounts structure is the same as CashCounts in the DispenseCash method. Each unit in CashCounts matches a unit in the CurrencyCashList property, and is in the same order.

If the CapDiscrepancy property is false, then Discrepancy is always false.

Usually, the cash total calculated by the CashCounts structure is equal to the cash total in a cash changer. However, there are some cases in which a discrepancy can occur because of existing uncountable cash in a cash changer. For example, when a cash slot is "overflowing," in such a way that the device has lost its ability to accurately detect and monitor the cash.

ReadCashCounts may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Busy | Cash units and counts cannot be read because an asynchronous method is outstanding.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
CashCounts
CashChanger.DispenseCash Method
CapDiscrepancy
CurrencyCashList


CashChanger Properties

CashChanger Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
AsyncMode | Gets or sets a Boolean value that indicates whether CashChanger methods are performed asynchronously.
AsyncResultCode | Gets the completion status of the last asynchronous dispense request.
AsyncResultCodeExtended | Gets the completion status of the last asynchronous dispense request.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapDeposit | Gets a Boolean value that indicates whether the device supports cash acceptance.
CapDepositDataEvent | Gets a Boolean value that indicates whether the device can report cash acceptance events.
CapDiscrepancy | Gets a Boolean value that indicates whether ReadCashCounts can report effective Discrepancy values.
CapEmptySensor | Gets a Boolean value that indicates whether the device can report that some cash slots are empty.
CapFullSensor | Gets a Boolean value that indicates whether the device can report that some cash slots are full.
CapJamSensor | Gets a Boolean value that indicates whether the device can report that a mechanical fault has occurred in the cash changer.
CapNearEmptySensor | Gets a Boolean value that indicates whether the device can report that some cash slots are almost empty.
CapNearFullSensor | Gets a Boolean value that indicates whether the device can report that some cash slots are almost full.
CapPauseDeposit | Gets a Boolean value that indicates whether the device can suspend cash acceptance.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapRealTimeData | Gets a Boolean value that indicates whether the device may supply data as the money is being accepted.
CapRepayDeposit | Gets a Boolean value that indicates whether the device can return deposited money.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
CurrencyCashList | Gets a list of cash units supported in the cash changer for the currency represented by the CurrencyCode property.
CurrencyCode | Gets or sets the active currency code to be used by cash changer operations.
CurrencyCodeList | Gets a list of ASCII 3-character ISO 4217 currency codes, separated by commas.
CurrentExit | Gets or sets a value that indicates the current cash-dispensing exit.
CurrentService | Gets or sets the current service.
DataCount | Gets the number of currently queued DataEvent events.
DataEventEnabled | Gets or sets a Boolean value that indicates whether a DataEvent event can be delivered when input data is queued.
DepositAmount | Gets the total amount of cash accepted.
DepositCashList | Gets the cash units supported in the cash changer for the currency represented by the CurrencyCode property.
DepositCodeList | Gets a list of the currency code indicators for the cash accepted.
DepositCounts | Gets the total of the cash accepted by the cash units.
DepositStatus | Gets the current status of the cash acceptance operation.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceExits | Gets the number of exits for dispensing cash.
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
DeviceStatus | Gets the current status of the cash changer.
ExitCashList | Gets the cash units that can be dispensed to the exit denoted by the CurrentExit property.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
FullStatus | Gets the current full status of the cash slots.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
RealTimeDataEnabled | Get or sets the Boolean value that indicates whether the DepositAmount and DepositCounts properties are updated in real time.
ServiceCount | Gets the number of integrated services used by the cash changer service.
ServiceIndex | Indicates the service index for each type of the integrated service types.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicated whether the Cash Changer is an exclusive-use device.

See Also

Reference

CashChanger Class
Microsoft.PointOfService Namespace


CashChanger.AsyncMode Property

CashChanger.AsyncMode Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether CashChanger methods are performed asynchronously.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AsyncMode As Boolean
public abstract bool AsyncMode { get; set; }
public:
virtual property bool AsyncMode {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_AsyncMode ()

/** @property */
public abstract void set_AsyncMode (boolean value)

public abstract function get AsyncMode () : boolean

public abstract function set AsyncMode (value : boolean)

Remarks

If true, the DispenseCash and DispenseChange methods are performed asynchronously. If false, DispenseCash and DispenseChange methods are performed synchronously.

The AsyncMode property is set and kept current by the service object while the device is enabled.

When the AsyncMode property is set, the following value is put in the ErrorCode property.

Value | Meaning
Success | The AsyncMode property was set successfully.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
CashChanger.DispenseCash Method
CashChanger.DispenseChange Method
AsyncResultCode
AsyncResultCodeExtended


CashChanger.AsyncResultCode Property

CashChanger.AsyncResultCode Property |
 | See Also

1/18/2008

Gets the completion status of the last asynchronous dispense request.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property AsyncResultCode As Integer
public abstract int AsyncResultCode { get; }
public:
virtual property int AsyncResultCode {
    int get () abstract;
}
/** @property */
public abstract int get_AsyncResultCode ()

public abstract function get AsyncResultCode () : int

Remarks

Holds the completion status of the last asynchronous dispense request (that is, when the DispenseCash or DispenseChange method is called when the AsyncMode property is set to true). AsyncResultCode is set by the service object before a StatusUpdateEvent event is delivered with a Status value of StatusAsync.

The value of AsyncResultCode is the same as the value that would have been in the ErrorCode property had the method been performed synchronously.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
CashChanger.DispenseCash Method
CashChanger.DispenseChange Method
CashChanger.AsyncMode Property


CashChanger.AsyncResultCodeExtended Property

CashChanger.AsyncResultCodeExtended Property |
 | See Also

1/18/2008

Gets the completion status of the last asynchronous dispense request.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property AsyncResultCodeExtended As Integer
public abstract int AsyncResultCodeExtended { get; }
public:
virtual property int AsyncResultCodeExtended {
    int get () abstract;
}
/** @property */
public abstract int get_AsyncResultCodeExtended ()

public abstract function get AsyncResultCodeExtended () : int

Remarks

Holds the completion status of the last asynchronous dispense request (that is, when DispenseCash or DispenseChange method was called by using the AsyncMode property set to true). AsyncResultCodeExtended is set by the service object before a StatusUpdateEvent event is delivered with a status value of StatusAsync. The value of AsyncResultCodeExtended is same as the value that would have been in the ErrorCodeExtended property had the method been performed synchronously.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
CashChanger.DispenseCash Method
CashChanger.DispenseChange Method
CashChanger.AsyncMode Property


CashChanger.CapDeposit Property

CashChanger.CapDeposit Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device supports cash acceptance.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapDeposit As Boolean
public abstract bool CapDeposit { get; }
public:
virtual property bool CapDeposit {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapDeposit ()

public abstract function get CapDeposit () : boolean

Remarks

If true, the cash changer supports cash acceptance; otherwise, false.

The CapDeposit property is set and kept updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
CashChanger.BeginDeposit Method
CashChanger.EndDeposit Method
CashChanger.FixDeposit Method
CashChanger.PauseDeposit Method


CashChanger.CapDepositDataEvent Property

CashChanger.CapDepositDataEvent Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device can report cash acceptance events.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapDepositDataEvent As Boolean
public abstract bool CapDepositDataEvent { get; }
public:
virtual property bool CapDepositDataEvent {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapDepositDataEvent ()

public abstract function get CapDepositDataEvent () : boolean

Remarks

If true, the cash changer can report cash acceptance events; otherwise, false.

CapDepositDataEvent is set and kept updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
CashChanger.BeginDeposit Method
CashChanger.EndDeposit Method
CashChanger.FixDeposit Method
CashChanger.PauseDeposit Method


CashChanger.CapDiscrepancy Property

CashChanger.CapDiscrepancy Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether ReadCashCounts can report effective Discrepancy values.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapDiscrepancy As Boolean
public abstract bool CapDiscrepancy { get; }
public:
virtual property bool CapDiscrepancy {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapDiscrepancy ()

public abstract function get CapDiscrepancy () : boolean

Remarks

If true, the ReadCashCounts method can report effective Discrepancy values; otherwise, false.

CapDiscrepancy is set and kept updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
CashChanger.ReadCashCounts Method


CashChanger.CapEmptySensor Property

CashChanger.CapEmptySensor Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device can report that some cash slots are empty.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapEmptySensor As Boolean
public abstract bool CapEmptySensor { get; }
public:
virtual property bool CapEmptySensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapEmptySensor ()

public abstract function get CapEmptySensor () : boolean

Remarks

If true, the cash changer can report the condition that some cash slots are empty; otherwise, false.

CapEmptySensor is set and kept updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
DeviceStatus
StatusUpdateEvent


CashChanger.CapFullSensor Property

CashChanger.CapFullSensor Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device can report that some cash slots are full.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapFullSensor As Boolean
public abstract bool CapFullSensor { get; }
public:
virtual property bool CapFullSensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapFullSensor ()

public abstract function get CapFullSensor () : boolean

Remarks

If true, the cash changer can report that some cash slots are full; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
FullStatus
StatusUpdateEvent


CashChanger.CapJamSensor Property

CashChanger.CapJamSensor Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device can report that a mechanical fault has occurred in the cash changer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CapJamSensor As Boolean
public virtual bool CapJamSensor { get; }
public:
virtual property bool CapJamSensor {
    bool get ();
}
/** @property */
public boolean get_CapJamSensor ()

public function get CapJamSensor () : boolean

Remarks

If true, the Cash Changer can report the occurrence of a mechanical fault.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
DeviceStatus
StatusUpdateEvent


CashChanger.CapNearEmptySensor Property

CashChanger.CapNearEmptySensor Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device can report that some cash slots are almost empty.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapNearEmptySensor As Boolean
public abstract bool CapNearEmptySensor { get; }
public:
virtual property bool CapNearEmptySensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapNearEmptySensor ()

public abstract function get CapNearEmptySensor () : boolean

Remarks

If true, the cash changer can report that some cash slots are almost empty; otherwise, false.

CapNearEmptySensor is set and kept updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
DeviceStatus
StatusUpdateEvent


CashChanger.CapNearFullSensor Property

CashChanger.CapNearFullSensor Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device can report that some cash slots are almost full.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapNearFullSensor As Boolean
public abstract bool CapNearFullSensor { get; }
public:
virtual property bool CapNearFullSensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapNearFullSensor ()

public abstract function get CapNearFullSensor () : boolean

Remarks

If true, the cash changer can report that some cash slots are almost full. Otherwise, false.

CapNearFullSensor is set and kept updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
FullStatus
StatusUpdateEvent


CashChanger.CapPauseDeposit Property

CashChanger.CapPauseDeposit Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device can suspend cash acceptance.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapPauseDeposit As Boolean
public abstract bool CapPauseDeposit { get; }
public:
virtual property bool CapPauseDeposit {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapPauseDeposit ()

public abstract function get CapPauseDeposit () : boolean

Remarks

If true, the cash changer can suspend cash acceptance temporarily; otherwise, false.

CapPauseDeposit is set and kept updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
CashChanger.PauseDeposit Method


CashChanger.CapRealTimeData Property

CashChanger.CapRealTimeData Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device may supply data as the money is being accepted.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CapRealTimeData As Boolean
public virtual bool CapRealTimeData { get; }
public:
virtual property bool CapRealTimeData {
    bool get ();
}
/** @property */
public boolean get_CapRealTimeData ()

public function get CapRealTimeData () : boolean

Remarks

If true, the device can supply data as the money is being accepted ("real time").

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
RealTimeDataEnabled


CashChanger.CapRepayDeposit Property

CashChanger.CapRepayDeposit Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device can return deposited money.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRepayDeposit As Boolean
public abstract bool CapRepayDeposit { get; }
public:
virtual property bool CapRepayDeposit {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRepayDeposit ()

public abstract function get CapRepayDeposit () : boolean

Remarks

If true, the cash changer can return cash that is deposited; otherwise, false.

CapRepayDeposit is set and kept updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
CashChanger.EndDeposit Method


CashChanger.CurrencyCashList Property

CashChanger.CurrencyCashList Property |
 | See Also Example

1/18/2008

Gets a list of cash units supported in the cash changer for the currency represented by the CurrencyCode property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CurrencyCashList As CashUnits
public abstract CashUnits CurrencyCashList { get; }
public:
virtual property CashUnits CurrencyCashList {
    CashUnits get () abstract;
}
/** @property */
public abstract CashUnits get_CurrencyCashList ()

public abstract function get CurrencyCashList () : CashUnits

Remarks

CurrencyCashList holds a CashUnits structure that contains an array of supported cash units in the currency represented by the CurrencyCode property.

This property is initialized by the Open method, and is updated when the CurrencyCode property is set.

Example

Given a currency code of JPY, and the following CashUnits structure:

Copy Code
Coins = 1, 5, 10, 50, 100, 500
Bills = 1000, 5000, 10000

The cash changer can use 1, 5, 10, 50, 100, and 500-yen coins; and can use 1000, 5000, and 10000-yen bills.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
CashUnits
CurrencyCode


CashChanger.CurrencyCode Property

CashChanger.CurrencyCode Property |
 | See Also

1/18/2008

Gets or sets the active currency code to be used by cash changer operations.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property CurrencyCode As String
public abstract string CurrencyCode { get; set; }
public:
virtual property String^ CurrencyCode {
    String^ get () abstract;
    void set (String^ value) abstract;
}
/** @property */
public abstract String get_CurrencyCode ()

/** @property */
public abstract void set_CurrencyCode (String value)

public abstract function get CurrencyCode () : String

public abstract function set CurrencyCode (value : String)

Remarks

CurrencyCode is set by the service object. This value is guaranteed to be one of the set of currencies specified by the CurrencyCodeList property.

Accessing CurrencyCode may cause a PosControlException to be thrown with the following ErrorCode.

Value | Meaning
Illegal | A value was specified that is not within CurrencyCodeList.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
CurrencyCodeList


CashChanger.CurrencyCodeList Property

CashChanger.CurrencyCodeList Property |
 | See Also

1/18/2008

Gets a list of ASCII 3-character ISO 4217 currency codes, separated by commas.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CurrencyCodeList As String()
public abstract string[] CurrencyCodeList { get; }
public:
virtual property array<String^>^ CurrencyCodeList {
    array<String^>^ get () abstract;
}
/** @property */
public abstract String[] get_CurrencyCodeList ()

public abstract function get CurrencyCodeList () : String[]

Remarks

CurrencyCodeList is set by the service object.

For example, if the string is "JPY,USD", the cash changer supports both Japanese and U.S. monetary units.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
CashChanger.CurrencyCode Property


CashChanger.CurrentExit Property

CashChanger.CurrentExit Property |
 | See Also

1/18/2008

Gets or sets a value that indicates the current cash-dispensing exit.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property CurrentExit As Integer
public abstract int CurrentExit { get; set; }
public:
virtual property int CurrentExit {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_CurrentExit ()

/** @property */
public abstract void set_CurrentExit (int value)

public abstract function get CurrentExit () : int

public abstract function set CurrentExit (value : int)

Remarks

The value 1 represents the primary exit (or normal exit), while values greater then 1 are considered auxiliary exits. Legal values range from 1 to DeviceExits.

CurrentExit is set and kept current by the service object while the device is enabled.

Accessing CurrentExit may cause a PosControlException exception to be thrown with the following ErrorCodes:

Value | Meaning
Illegal | An invalid CurrentExit is specified.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
CashChanger.CurrencyCashList Property
DeviceExits
ExitCashList


CashChanger.CurrentService Property

CashChanger.CurrentService Property |
 | See Also

1/18/2008

Gets or sets the current service.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Property CurrentService As Integer
public virtual int CurrentService { get; set; }
public:
virtual property int CurrentService {
    int get ();
    void set (int value);
}
/** @property */
public int get_CurrentService ()

/** @property */
public void set_CurrentService (int value)

public function get CurrentService () : int

public function set CurrentService (value : int)

Remarks

Holds the current service. The value 0 represents the primary service, while values greater than 0 and less than or equal to ServiceCount are used to request information from the integrated services. Legal values range from 0 to ServiceCount. The ReadCashCounts method and all the properties, common and specific, can be accessed when the CurrentService is greater than 0. CurrentService, ServiceCount and ServiceIndex always reflects the primary service.

Later in this topic are examples of a cash changer service that use services for a separate Coin Acceptor, Dispenser, and a bills-only cash changer. A StatusUpdateEvent that indicates a jam has been received by the application. Only the bill changer and the coin dispenser can detect a jam.

  • Checking the values of the primary service:

    CurrentService = 0

    ServiceCount = 3

    ServiceIndex = 50528769 (X'03030201')

    DeviceStatus = Jam

    DeviceDescription = "Integrated Cash Changer Service 1.11.05"

  • Changing the service for information about the coin dispenser:

    CurrentService = 2

    ServiceCount = 3

    ServiceIndex = 50528769 (X'03030201')

    DeviceStatus = OK

    DeviceDescription = "Pennybrite Coin Dispenser Service"

  • The coin dispenser looks OK. Check the bill changer:

    CurrentService = 3

    ServiceCount = 3

    ServiceIndex = 50528769 (X'03030201')

    DeviceStatus = Jam

    DeviceDescription = "Benjamin Bill Changer Service"

This property is initialized to 0 by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
ServiceCount
ServiceIndex
CashChanger.ReadCashCounts Method


CashChanger.DataCount Property

CashChanger.DataCount Property |
 | See Also

1/18/2008

Gets the number of currently queued DataEvent events.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DataCount As Integer
public abstract int DataCount { get; }
public:
virtual property int DataCount {
    int get () abstract;
}
/** @property */
public abstract int get_DataCount ()

public abstract function get DataCount () : int

Remarks

The application can read this property to determine whether additional input is queued from a device but has not yet been delivered because of other application processing, freezing of events, or other causes.

DataCount is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
DataEvent


CashChanger.DataEventEnabled Property

CashChanger.DataEventEnabled Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether a DataEvent event can be delivered when input data is queued.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property DataEventEnabled As Boolean
public abstract bool DataEventEnabled { get; set; }
public:
virtual property bool DataEventEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_DataEventEnabled ()

/** @property */
public abstract void set_DataEventEnabled (boolean value)

public abstract function get DataEventEnabled () : boolean

public abstract function set DataEventEnabled (value : boolean)

Remarks

If true, a DataEvent is delivered as soon as input data is queued. If changed to true and some input data is already queued, a DataEvent is delivered immediately. (Notice that other conditions may delay "immediate" delivery: if FreezeEvents is true or another event is already being processed at the application, the DataEvent remains queued until the condition is corrected.)

If false, input data is queued for later delivery to the application. An ErrorEvent in response to an input error is also not be delivered while this property is false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
DataEvent


CashChanger.DepositAmount Property

CashChanger.DepositAmount Property |
 | See Also

1/18/2008

Gets the total amount of cash accepted.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DepositAmount As Integer
public abstract int DepositAmount { get; }
public:
virtual property int DepositAmount {
    int get () abstract;
}
/** @property */
public abstract int get_DepositAmount ()

public abstract function get DepositAmount () : int

Remarks

For example, if the currency is Japanese yen and DepositAmount is set to 18057, after it calls the BeginDeposit method, there are 18,057 yen in the cash changer.

DepositAmount is initialized to an appropriate value by the service object.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
CashChanger.CurrencyCode Property
CashChanger.BeginDeposit Method


CashChanger.DepositCashList Property

CashChanger.DepositCashList Property |
 | See Also

1/18/2008

Gets the cash units supported in the cash changer for the currency represented by the CurrencyCode property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DepositCashList As CashUnits
public abstract CashUnits DepositCashList { get; }
public:
virtual property CashUnits DepositCashList {
    CashUnits get () abstract;
}
/** @property */
public abstract CashUnits get_DepositCashList ()

public abstract function get DepositCashList () : CashUnits

Remarks

DepositCashList is set to null when cash acceptance is not supported.

DepositCashList is typically initialized by the service object, and is updated when CurrencyCode is set.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
CashUnits
CashChanger.CurrencyCashList Property
CashChanger.CurrencyCode Property


CashChanger.DepositCodeList Property

CashChanger.DepositCodeList Property |
 | See Also

1/18/2008

Gets a list of the currency code indicators for the cash accepted.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DepositCodeList As String()
public abstract string[] DepositCodeList { get; }
public:
virtual property array<String^>^ DepositCodeList {
    array<String^>^ get () abstract;
}
/** @property */
public abstract String[] get_DepositCodeList ()

public abstract function get DepositCodeList () : String[]

Remarks

DepositCodeList is set to null when cash acceptance is not supported.

The string consists of an array of ASCII 3-character ISO 4217 currency codes. For example, if the array contains the strings "JPY" and "USD", the cash changer supports both Japanese and U.S. monetary units.

DepositCodeList is set to null and updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
CashChanger.CurrencyCode Property


CashChanger.DepositCounts Property

CashChanger.DepositCounts Property |
 | See Also

1/18/2008

Gets the total of the cash accepted by the cash units.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DepositCounts As CashCount()
public abstract CashCount[] DepositCounts { get; }
public:
virtual property array<CashCount>^ DepositCounts {
    array<CashCount>^ get () abstract;
}
/** @property */
public abstract CashCount[] get_DepositCounts ()

public abstract function get DepositCounts () : CashCount[]

Remarks

Cash units inside CashCount are the same as the DepositCashList property, and are in the same order. DepositCounts is null when cash acceptance is not supported.

DepositCounts is typically initialized to null. It is kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
CashCount
CashChanger.CurrencyCode Property


CashChanger.DepositStatus Property

CashChanger.DepositStatus Property |
 | See Also

1/18/2008

Gets the current status of the cash acceptance operation.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DepositStatus As CashDepositStatus
public abstract CashDepositStatus DepositStatus { get; }
public:
virtual property CashDepositStatus DepositStatus {
    CashDepositStatus get () abstract;
}
/** @property */
public abstract CashDepositStatus get_DepositStatus ()

public abstract function get DepositStatus () : CashDepositStatus

Remarks

DepositStatus is initialized to End, or None if the device does not support cash acceptance, and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
CashDepositStatus


CashChanger.DeviceExits Property

CashChanger.DeviceExits Property |
 | See Also

1/18/2008

Gets the number of exits for dispensing cash.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DeviceExits As Integer
public abstract int DeviceExits { get; }
public:
virtual property int DeviceExits {
    int get () abstract;
}
/** @property */
public abstract int get_DeviceExits ()

public abstract function get DeviceExits () : int

Remarks

DeviceExits is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
CashChanger.CurrentExit Property


CashChanger.DeviceStatus Property

CashChanger.DeviceStatus Property |
 | See Also

1/18/2008

Gets the current status of the cash changer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DeviceStatus As CashChangerStatus
public abstract CashChangerStatus DeviceStatus { get; }
public:
virtual property CashChangerStatus DeviceStatus {
    CashChangerStatus get () abstract;
}
/** @property */
public abstract CashChangerStatus get_DeviceStatus ()

public abstract function get DeviceStatus () : CashChangerStatus

Remarks

DeviceStatus is set by the service object and kept current while the device is enabled.

If more than one condition is present, the order of precedence starting at the highest is Jam, Empty, and NearEmpty.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
CashChangerStatus


CashChanger.ExitCashList Property

CashChanger.ExitCashList Property |
 | See Also

1/18/2008

Gets the cash units that can be dispensed to the exit denoted by the CurrentExit property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ExitCashList As CashUnits
public abstract CashUnits ExitCashList { get; }
public:
virtual property CashUnits ExitCashList {
    CashUnits get () abstract;
}
/** @property */
public abstract CashUnits get_ExitCashList ()

public abstract function get ExitCashList () : CashUnits

Remarks

The supported cash units are either the same as CurrencyCashList, or a subset of it. The string format is identical to that of CurrencyCashList.

ExitCashList is updated by the service object when CurrencyCode or CurrentExit is set.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
CashUnits
CashChanger.CurrencyCode Property
CashChanger.CurrencyCashList Property
CashChanger.CurrentExit Property


CashChanger.FullStatus Property

CashChanger.FullStatus Property |
 | See Also

1/18/2008

Gets the current full status of the cash slots.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property FullStatus As CashChangerFullStatus
public abstract CashChangerFullStatus FullStatus { get; }
public:
virtual property CashChangerFullStatus FullStatus {
    CashChangerFullStatus get () abstract;
}
/** @property */
public abstract CashChangerFullStatus get_FullStatus ()

public abstract function get FullStatus () : CashChangerFullStatus

Remarks

FullStatus is typically initialized to OK. It is kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace


CashChanger.IsExclusiveUseDevice Property

CashChanger.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Gets a Boolean value that indicated whether the Cash Changer is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Property Value

A value of true indicates the fiscal printer is an exclusive-use device. Otherwise, the value is false.

Remarks

An exclusive-use device has the following properties:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before accessing some properties or calling methods that update the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace


CashChanger.RealTimeDataEnabled Property

CashChanger.RealTimeDataEnabled Property |
 | See Also

1/18/2008

Get or sets the Boolean value that indicates whether the DepositAmount and DepositCounts properties are updated in real time.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Property RealTimeDataEnabled As Boolean
public virtual bool RealTimeDataEnabled { get; set; }
public:
virtual property bool RealTimeDataEnabled {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_RealTimeDataEnabled ()

/** @property */
public void set_RealTimeDataEnabled (boolean value)

public function get RealTimeDataEnabled () : boolean

public function set RealTimeDataEnabled (value : boolean)

Remarks

If true and CapRealTimeData is true, each data event fired updates the DepositAmount and DepositCounts properties. Otherwise, DepositAmount and DepositCounts are updated when FixDeposit is called. Setting RealTimeDataEnabled does not cause any change in system behavior until a later BeginDeposit method is performed. This prevents confusion about what would occur if it were modified between a BeginDeposit -EndDeposit pairing.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
CashChanger.CapRealTimeData Property
CashChanger.DepositAmount Property
CashChanger.DepositCounts Property
CashChanger.BeginDeposit Method
CashChanger.EndDeposit Method
CashChanger.FixDeposit Method


CashChanger.ServiceCount Property

CashChanger.ServiceCount Property |
 | See Also

1/18/2008

Gets the number of integrated services used by the cash changer service.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property ServiceCount As Integer
public virtual int ServiceCount { get; }
public:
virtual property int ServiceCount {
    int get ();
}
/** @property */
public int get_ServiceCount ()

public function get ServiceCount () : int

Remarks

Holds the number of integrated services used by the cash changer service. If the service does not use other services, this value is zero.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
CashChanger.CurrentService Property
ServiceIndex


CashChanger.ServiceIndex Property

CashChanger.ServiceIndex Property |
 | See Also

1/18/2008

Indicates the service index for each type of the integrated service types.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property ServiceIndex As ServiceIndex
public virtual ServiceIndex ServiceIndex { get; }
public:
virtual property ServiceIndex ServiceIndex {
    ServiceIndex get ();
}
/** @property */
public ServiceIndex get_ServiceIndex ()

public function get ServiceIndex () : ServiceIndex

Remarks

The value is divided into four bytes that indicates the service index for each integrated service type. The following table indicates how the property is divided:

High Word

Low Word

High Byte | Low Byte
Bill Dispenser | Bill Acceptor

High Byte | Low Byte
Coin Dispenser | Coin Acceptor

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
CashChanger.CurrentService Property
ServiceCount


CashChanger Events

CashChanger Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DataEvent | Raised by the service object to notify the application when the cash changer has a status change.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

CashChanger Class
Microsoft.PointOfService Namespace


CashChanger.DataEvent Event

CashChanger.DataEvent Event |
 | See Also

1/18/2008

Raised by the service object to notify the application when the cash changer has a status change.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event DataEvent As DataEventHandler
public abstract event DataEventHandler DataEvent
public:
virtual event DataEventHandler^ DataEvent {
    void add (DataEventHandler^ value) abstract;
    void remove (DataEventHandler^ value) abstract;
}
/** @event */
public abstract void add_DataEvent (DataEventHandler value)

/** @event */
public abstract void remove_DataEvent (DataEventHandler value)

Remarks

A DataEvent is raised to notify the application when cash counts change while cash acceptance is in progress. Status contains zero.

See Also

Reference

CashChanger Class
CashChanger Members
Microsoft.PointOfService Namespace
Status
CashChanger.DataEventEnabled Property


CashChangerFullStatus Enumeration

CashChangerFullStatus Enumeration |
 | See Also

1/18/2008

Enumerates values that describe the full status of cash slots in a Cash Changer device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration CashChangerFullStatus
public enum CashChangerFullStatus
public enum class CashChangerFullStatus
public enum CashChangerFullStatus
public enum CashChangerFullStatus

Members

Member name | Description
Full | Some cash slots are full.
NearFull | Some cash slots are almost full.
OK | All cash slots are neither almost full nor full.

Remarks

Used by the FullStatus property. Replaces the CHAN_STATUS_OK, CHAN_STATUS_FULL, and CHAN_STATUS_NEARFULL UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
CashChanger Class
CashChanger.FullStatus Property


CashChangerStatus Enumeration

CashChangerStatus Enumeration |
 | See Also

1/18/2008

Enumerates possible current status values for the CashChanger class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration CashChangerStatus
public enum CashChangerStatus
public enum class CashChangerStatus
public enum CashChangerStatus
public enum CashChangerStatus

Members

Member name | Description
Empty | Some cash slots are empty.
Jam | A mechanical fault has occurred.
NearEmpty | Some cash slots are nearly empty.
OK | The current condition of the cash changer is satisfactory.

Remarks

Used by the DeviceStatus property. Replaces the CHAN_STATUS_OK, CHAN_STATUS_EMPTY, CHAN_STATUS_NEAREMPTY, and CHAN_STATUS_JAM UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
CashChanger.DeviceStatus Property


CashCount Structure

CashCount Structure |
 | See Also Members

1/18/2008

Represents an individual count of a particular type of currency for a Cash Changer or Bill Dispenser device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Structure CashCount
public struct CashCount
public value class CashCount
public final class CashCount extends ValueType

Remarks

Used by the DepositCounts property and the DispenseCash method of the CashChanger class. POS applications create an array of CashCount instances when they call the DispenseCash method to dispense cash from a Cash Changer device. Service objects create an array representing a list of deposit amounts when reporting the results of a cash acceptance operation (by updating the DepositCounts property).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashCount Members
Microsoft.PointOfService Namespace
CashChanger Class
BillDispenser Class


CashCount Members

CashCount Members |
 | See Also Constructors Methods Properties

1/18/2008

Represents an individual count of a particular type of currency for a Cash Changer or Bill Dispenser device.

The following tables list the members exposed by the CashCount type.

Public Constructors

Name | Description
CashCount | Creates an instance of the CashCount structure from parameters specifying the instance's constituent parts.
Top

Public Properties

Name | Description
Count | Gets the number of bills or coins.
NominalValue | Gets the face value of the bill or coin.
Type | Gets the type of cash, currency or coins.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded.
GetHashCode | Overridden.
GetType | (inherited from Object )
op_Equality | Compares the specified CashCount and object to determine whether they are the same.
op_Inequality | Compares the specified CashCount and object to determine whether they are different.
ReferenceEquals | (inherited from Object )
ToString | (inherited from ValueType )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

CashCount Structure
Microsoft.PointOfService Namespace
CashChanger Class
BillDispenser Class


CashCount Constructor

CashCount Constructor |
 | See Also

1/18/2008

Creates an instance of the CashCount structure from parameters specifying the instance's constituent parts.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    type As CashCountType, _
    nominalValue As Integer, _
    count As Integer _
)
public CashCount (
    CashCountType type,
    int nominalValue,
    int count
)
public:
CashCount (
    CashCountType type,
    int nominalValue,
    int count
)
public CashCount (
    CashCountType type,
    int nominalValue,
    int count
)
public function CashCount (
    type : CashCountType,
    nominalValue : int,
    count : int
)

Parameters

type
nominalValue

The face value of each unit of currency to be held by this CashCount.

count

See Also

Reference

CashCount Structure
CashCount Members
Microsoft.PointOfService Namespace


CashCount Methods

CashCount Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded.
GetHashCode | Overridden.
GetType | (inherited from Object )
op_Equality | Compares the specified CashCount and object to determine whether they are the same.
op_Inequality | Compares the specified CashCount and object to determine whether they are different.
ReferenceEquals | (inherited from Object )
ToString | (inherited from ValueType )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

CashCount Structure
Microsoft.PointOfService Namespace
CashChanger Class
BillDispenser Class


CashCount.Equals Method

CashCount.Equals Method |
 | See Also

1/18/2008

Overload List

Name | Description
CashCount.Equals (CashCount) |
CashCount.Equals (Object) |
CashCount.Equals (CashCount, CashCount) |
CashCount.Equals (Object, Object) | (inherited from Equals )

See Also

Reference

CashCount Structure
CashCount Members
Microsoft.PointOfService Namespace


CashCount.Equals Method (CashCount)

CashCount.Equals Method (CashCount) |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Function Equals ( _
    count As CashCount _
) As Boolean

public bool Equals (
    CashCount count
)

public:
bool Equals (
    CashCount count
)

public boolean Equals (
    CashCount count
)

public function Equals (
    count : CashCount
) : boolean

Parameters

count

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashCount Structure
CashCount Members
Microsoft.PointOfService Namespace


CashCount.Equals Method (Object)

CashCount.Equals Method (Object) |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

public override bool Equals (
    Object obj
)

public:
virtual bool Equals (
    Object^ obj
) override

public boolean Equals (
    Object obj
)

public override function Equals (
    obj : Object
) : boolean

Parameters

obj

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashCount Structure
CashCount Members
Microsoft.PointOfService Namespace


CashCount.Equals Method (CashCount, CashCount)

CashCount.Equals Method (CashCount, CashCount) |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Function Equals ( _
    a As CashCount, _
    b As CashCount _
) As Boolean

public static bool Equals (
    CashCount a,
    CashCount b
)

public:
static bool Equals (
    CashCount a,
    CashCount b
)

public static boolean Equals (
    CashCount a,
    CashCount b
)

public static function Equals (
    a : CashCount,
    b : CashCount
) : boolean

Parameters

a
b

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashCount Structure
CashCount Members
Microsoft.PointOfService Namespace


CashCount.GetHashCode Method

CashCount.GetHashCode Method |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function GetHashCode As Integer

public override int GetHashCode ()

public:
virtual int GetHashCode () override

public int GetHashCode ()

public override function GetHashCode () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashCount Structure
CashCount Members
Microsoft.PointOfService Namespace


CashCount.op_Equality Method

CashCount.op_Equality Method |
 | See Also

1/18/2008

Compares the specified CashCount and object to determine whether they are the same.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Operator = ( _
    a As CashCount, _
    b As Object _
) As Boolean
public static bool operator == (
    CashCount a,
    Object b
)
public:
static bool operator == (
    CashCount a,
    Object^ b
)

Parameters

a

The CashCount to be compared to b.

b

The object to be compared to a.

Return Value

True if a is equal to b; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashCount Structure
CashCount Members
Microsoft.PointOfService Namespace


CashCount.op_Inequality Method

CashCount.op_Inequality Method |
 | See Also

1/18/2008

Compares the specified CashCount and object to determine whether they are different.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Operator <> ( _
    a As CashCount, _
    b As Object _
) As Boolean
public static bool operator != (
    CashCount a,
    Object b
)
public:
static bool operator != (
    CashCount a,
    Object^ b
)

Parameters

a

The CashCount to be compared to b.

b

The object to be compared to a.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashCount Structure
CashCount Members
Microsoft.PointOfService Namespace


CashCount Properties

CashCount Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
Count | Gets the number of bills or coins.
NominalValue | Gets the face value of the bill or coin.
Type | Gets the type of cash, currency or coins.

See Also

Reference

CashCount Structure
Microsoft.PointOfService Namespace
CashChanger Class
BillDispenser Class


CashCount.Count Property

CashCount.Count Property |
 | See Also Example

1/18/2008

Gets the number of bills or coins.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Count As Integer
public int Count { get; }
public:
property int Count {
    int get ();
}
/** @property */
public int get_Count ()

public function get Count () : int

Remarks

This property holds the number of bills or coins represented by this CashCount.

Example

A CashCount that represents 36 20-dollar U.S. bills holds the following values:

Count = 36

NominalValue = 20

Type = Bill

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashCount Structure
CashCount Members
Microsoft.PointOfService Namespace
NominalValue
Type
CashCountType


CashCount.NominalValue Property

CashCount.NominalValue Property |
 | See Also Example

1/18/2008

Gets the face value of the bill or coin.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property NominalValue As Integer
public int NominalValue { get; }
public:
property int NominalValue {
    int get ();
}
/** @property */
public int get_NominalValue ()

public function get NominalValue () : int

Remarks

This property holds the value of each unit of this type of bill or coin.

Example

A CashCount that represents 36 20-dollar U.S. bills holds the following values:

Count = 36

NominalValue = 20

Type = Bill

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashCount Structure
CashCount Members
Microsoft.PointOfService Namespace
CashCount.Count Property
Type
CashCountType


CashCount.Type Property

CashCount.Type Property |
 | See Also Example

1/18/2008

Gets the type of cash, currency or coins.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Type As CashCountType
public CashCountType Type { get; }
public:
property CashCountType Type {
    CashCountType get ();
}
/** @property */
public CashCountType get_Type ()

public function get Type () : CashCountType

Remarks

The value of this property holds one of the members of the CashCountType enumeration that indicates whether this CashCount enumeration represents a quantity of bills or coins.

Example

A CashCount that represents 36 20-dollar U.S. bills holds the following values:

Count = 36

NominalValue = 20

Type = Bill

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashCount Structure
CashCount Members
Microsoft.PointOfService Namespace
CashCount.Count Property
CashCount.NominalValue Property
CashCountType


CashCounts Structure

CashCounts Structure |
 | See Also Members

1/18/2008

Defines a programmatic structure used to create an array representing the total cash in a Cash Changer device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Structure CashCounts
public struct CashCounts
public value class CashCounts
public final class CashCounts extends ValueType

Remarks

Used by the ReadCashCounts method of the CashChanger and BillDispenser classes.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashCounts Members
Microsoft.PointOfService Namespace
CashChanger.DepositCounts Property
CashChanger.DispenseCash Method


CashCounts Members

CashCounts Members |
 | See Also Constructors Methods Properties

1/18/2008

Defines a programmatic structure used to create an array representing the total cash in a Cash Changer device.

The following tables list the members exposed by the CashCounts type.

Public Constructors

Name | Description
CashCounts | Creates an instance of the CashCounts structure from parameters specifying the instance's constituent parts.
Top

Public Properties

Name | Description
Counts | Gets the CashCount data.
Discrepancy | Gets a Boolean value that indicates the discrepancy of cash that is not included in the count.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded.
GetHashCode | Overridden.
GetType | (inherited from Object )
op_Equality | Compares the specified CashCounts and object and determines whether they are equal.
op_Inequality | Compares the specified CashCounts and object and determines whether they are unequal.
ReferenceEquals | (inherited from Object )
ToString | (inherited from ValueType )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

CashCounts Structure
Microsoft.PointOfService Namespace
CashChanger.DepositCounts Property
CashChanger.DispenseCash Method


CashCounts Constructor

CashCounts Constructor |
 | See Also

1/18/2008

Creates an instance of the CashCounts structure from parameters specifying the instance's constituent parts.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    counts As CashCount(), _
    discrepancy As Boolean _
)
public CashCounts (
    CashCount[] counts,
    bool discrepancy
)
public:
CashCounts (
    array<CashCount>^ counts,
    bool discrepancy
)
public CashCounts (
    CashCount[] counts,
    boolean discrepancy
)
public function CashCounts (
    counts : CashCount[],
    discrepancy : boolean
)

Parameters

counts

CashCount array.

discrepancy

If true, some cash could not be included in counts; otherwise, false.

See Also

Reference

CashCounts Structure
CashCounts Members
Microsoft.PointOfService Namespace


CashCounts Methods

CashCounts Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded.
GetHashCode | Overridden.
GetType | (inherited from Object )
op_Equality | Compares the specified CashCounts and object and determines whether they are equal.
op_Inequality | Compares the specified CashCounts and object and determines whether they are unequal.
ReferenceEquals | (inherited from Object )
ToString | (inherited from ValueType )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

CashCounts Structure
Microsoft.PointOfService Namespace
CashChanger.DepositCounts Property
CashChanger.DispenseCash Method


CashCounts.Equals Method

CashCounts.Equals Method |
 | See Also

1/18/2008

Overload List

Name | Description
CashCounts.Equals (CashCounts) |
CashCounts.Equals (Object) |
CashCounts.Equals (CashCounts, CashCounts) |
CashCounts.Equals (Object, Object) | (inherited from Equals )

See Also

Reference

CashCounts Structure
CashCounts Members
Microsoft.PointOfService Namespace


CashCounts.Equals Method (CashCounts)

CashCounts.Equals Method (CashCounts) |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Function Equals ( _
    counts As CashCounts _
) As Boolean

public bool Equals (
    CashCounts counts
)

public:
bool Equals (
    CashCounts counts
)

public boolean Equals (
    CashCounts counts
)

public function Equals (
    counts : CashCounts
) : boolean

Parameters

counts

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashCounts Structure
CashCounts Members
Microsoft.PointOfService Namespace


CashCounts.Equals Method (Object)

CashCounts.Equals Method (Object) |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

public override bool Equals (
    Object obj
)

public:
virtual bool Equals (
    Object^ obj
) override

public boolean Equals (
    Object obj
)

public override function Equals (
    obj : Object
) : boolean

Parameters

obj

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashCounts Structure
CashCounts Members
Microsoft.PointOfService Namespace


CashCounts.Equals Method (CashCounts, CashCounts)

CashCounts.Equals Method (CashCounts, CashCounts) |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Function Equals ( _
    a As CashCounts, _
    b As CashCounts _
) As Boolean

public static bool Equals (
    CashCounts a,
    CashCounts b
)

public:
static bool Equals (
    CashCounts a,
    CashCounts b
)

public static boolean Equals (
    CashCounts a,
    CashCounts b
)

public static function Equals (
    a : CashCounts,
    b : CashCounts
) : boolean

Parameters

a
b

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashCounts Structure
CashCounts Members
Microsoft.PointOfService Namespace


CashCounts.GetHashCode Method

CashCounts.GetHashCode Method |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function GetHashCode As Integer

public override int GetHashCode ()

public:
virtual int GetHashCode () override

public int GetHashCode ()

public override function GetHashCode () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashCounts Structure
CashCounts Members
Microsoft.PointOfService Namespace


CashCounts.op_Equality Method

CashCounts.op_Equality Method |
 | See Also

1/18/2008

Compares the specified CashCounts and object and determines whether they are equal.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Operator = ( _
    a As CashCounts, _
    b As Object _
) As Boolean
public static bool operator == (
    CashCounts a,
    Object b
)
public:
static bool operator == (
    CashCounts a,
    Object^ b
)

Parameters

a

The CashCounts to compare with b.

b

The object to compare with a.

Return Value

True if a and b are equal. Otherwise, false.

Remarks

This method compares the specified CashCounts and object and determines whether they are equal.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashCounts Structure
CashCounts Members
Microsoft.PointOfService Namespace


CashCounts.op_Inequality Method

CashCounts.op_Inequality Method |
 | See Also

1/18/2008

Compares the specified CashCounts and object and determines whether they are unequal.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Operator <> ( _
    a As CashCounts, _
    b As Object _
) As Boolean
public static bool operator != (
    CashCounts a,
    Object b
)
public:
static bool operator != (
    CashCounts a,
    Object^ b
)

Parameters

a

The CashCounts to compare with b.

b

The object to compare with a.

Return Value

True if a and b are not equal. Otherwise, false.

Remarks

This method compares the specified CashCounts and object and determines whether they are unequal.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashCounts Structure
CashCounts Members
Microsoft.PointOfService Namespace


CashCounts Properties

CashCounts Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
Counts | Gets the CashCount data.
Discrepancy | Gets a Boolean value that indicates the discrepancy of cash that is not included in the count.

See Also

Reference

CashCounts Structure
Microsoft.PointOfService Namespace
CashChanger.DepositCounts Property
CashChanger.DispenseCash Method


CashCounts.Counts Property

CashCounts.Counts Property |
 | See Also

1/18/2008

Gets the CashCount data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Counts As CashCount()
public CashCount[] Counts { get; }
public:
property array<CashCount>^ Counts {
    array<CashCount>^ get ();
}
/** @property */
public CashCount[] get_Counts ()

public function get Counts () : CashCount[]

Remarks

This property holds an array of CashCount objects representing the data held by this instance of CashCounts.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashCounts Structure
CashCounts Members
Microsoft.PointOfService Namespace


CashCounts.Discrepancy Property

CashCounts.Discrepancy Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates the discrepancy of cash that is not included in the count.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Discrepancy As Boolean
public bool Discrepancy { get; }
public:
property bool Discrepancy {
    bool get ();
}
/** @property */
public boolean get_Discrepancy ()

public function get Discrepancy () : boolean

Property Value

If true, some cash could not be included in a CashCount; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashCounts Structure
CashCounts Members
Microsoft.PointOfService Namespace


CashCountType Enumeration

CashCountType Enumeration |
 | See Also

1/18/2008

Enumerates the possible types of cash, bill or coin.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration CashCountType
public enum CashCountType
public enum class CashCountType
public enum CashCountType
public enum CashCountType

Members

Member name | Description
Bill | Indicates paper currency.
Coin | Indicates coin currency.

Remarks

Used by the constructor and Type property of the CashCount structure.

See Also

Reference

Microsoft.PointOfService Namespace
CashCount.Type Property


CashDepositAction Enumeration

CashDepositAction Enumeration |
 | See Also

1/18/2008

Enumerates the possible ways to deal with deposited cash.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration CashDepositAction
public enum CashDepositAction
public enum class CashDepositAction
public enum CashDepositAction
public enum CashDepositAction

Members

Member name | Description
Change | The deposited amount is greater than the amount required.
NoChange | The deposited amount is equal to or less than the amount required.
Repay | The deposit is to be repaid through the cash deposit exit or the cash payment exit.

Remarks

Used by the EndDeposit method. Replaces the CHAN_DEPOSIT_CHANGE, CHAN_DEPOSIT_NOCHANGE, and CHAN_DEPOSIT_REPAY UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
CashChanger.EndDeposit Method


CashDepositPause Enumeration

CashDepositPause Enumeration |
 | See Also

1/18/2008

Enumerates two possible values, Pause and Resume, for a cash acceptance operation.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration CashDepositPause
public enum CashDepositPause
public enum class CashDepositPause
public enum CashDepositPause
public enum CashDepositPause

Members

Member name | Description
Pause | Cash acceptance is paused.
Restart | Cash acceptance is resumed.

Remarks

Used by the PauseDeposit method. Replaces the CHAN_DEPOSIT_PAUSE and CHAN_DEPOSIT_RESTART UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
CashChanger.PauseDeposit Method


CashDepositStatus Enumeration

CashDepositStatus Enumeration |
 | See Also

1/18/2008

Enumerates the possible current status values of the cash acceptance operation.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration CashDepositStatus
public enum CashDepositStatus
public enum class CashDepositStatus
public enum CashDepositStatus
public enum CashDepositStatus

Members

Member name | Description
Count | Counting or repaying the cash accepted.
End | Finished accepting cash.
Jam | A mechanical fault has occurred.
None | Does not support cash acceptance.
Start | Start accepting cash.

Remarks

Used by the DepositStatus property. Replaces the CHAN_STATUS_DEPOSIT_et al constants from UPOS.

See Also

Reference

Microsoft.PointOfService Namespace
CashChanger.DepositStatus Property


CashDrawer Class

CashDrawer Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a UPOS Cash Drawer device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class CashDrawer
    Inherits PosCommon
public abstract class CashDrawer : PosCommon
public ref class CashDrawer abstract : public PosCommon
public abstract class CashDrawer extends PosCommon
public abstract class CashDrawer extends PosCommon

Remarks

The Cash Drawer device always supports a command to open the cash drawer.

The cash drawer may have the following additional capabilities:

  • Drawer status reporting: Can determine whether a particular drawer is open or closed in environments where the drawer is the only drawer available through a hardware port.

  • Drawer unique status reporting: Can determine whether a particular drawer is open or closed in environments where more than one drawer can be accessed through the same hardware port.

The cash drawer is a shareable device. Its device sharing rules are as follows:

  • After you open and enabling the device, the application may access all properties and methods and receives status update events.

  • If more than one application has opened and enabled the device, all applications may access its properties and methods. Status update events are raised to all the applications.

  • If one application claims the cash drawer, then only that application may call the OpenDrawer and WaitForDrawerClose methods. This feature provides a degree of security, because these methods may effectively be restricted to the main application if that application claims the device at startup.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.CashDrawer
Microsoft.PointOfService.BasicServiceObjects.CashDrawerBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashDrawer Members
Microsoft.PointOfService Namespace


CashDrawer Members

CashDrawer Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a UPOS Cash Drawer device.

The following tables list the members exposed by the CashDrawer type.

Protected Constructors

Name | Description
CashDrawer | Creates an instance of the CashDrawer class.
Top

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticDrawerFailedOpenCount | Incremented during the OpenDrawer method if the cash drawer does not open.
StatisticDrawerGoodOpenCount | Incremented during the OpenDrawer method if the cash drawer successfully opens.
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusClosed | Indicates that the cash drawer is closed.
StatusOpen | Indicates that the cash drawer is open.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapStatus | Gets the status of the cash drawer status, open or closed.
CapStatusMultiDrawerDetect | Gets the Boolean value that indicates the status of multidrawer configurations.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
DrawerOpened | Gets the Boolean value that indicates whether the drawer is open.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets the Boolean value that indicates whether the Cash Drawer is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon)
OpenDrawer | Physically opens the cash drawer.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
WaitForDrawerClose | The application calls WaitForDrawerClose to wait until the cash drawer is closed. If the drawer is still open after beepTimeout milliseconds, the message beeper should be started.
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

CashDrawer Class
Microsoft.PointOfService Namespace


CashDrawer Fields

CashDrawer Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticDrawerFailedOpenCount | Incremented during the OpenDrawer method if the cash drawer does not open.
StatisticDrawerGoodOpenCount | Incremented during the OpenDrawer method if the cash drawer successfully opens.
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusClosed | Indicates that the cash drawer is closed.
StatusOpen | Indicates that the cash drawer is open.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

CashDrawer Class
Microsoft.PointOfService Namespace


CashDrawer.StatisticDrawerFailedOpenCount Field

CashDrawer.StatisticDrawerFailedOpenCount Field |
 | See Also

1/18/2008

Incremented during the OpenDrawer method if the cash drawer does not open.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticDrawerFailedOpenCount As String
public const string StatisticDrawerFailedOpenCount
public:
literal String^ StatisticDrawerFailedOpenCount
public static final String StatisticDrawerFailedOpenCount
public const var StatisticDrawerFailedOpenCount : String

See Also

Reference

CashDrawer Class
CashDrawer Members
Microsoft.PointOfService Namespace


CashDrawer.StatisticDrawerGoodOpenCount Field

CashDrawer.StatisticDrawerGoodOpenCount Field |
 | See Also

1/18/2008

Incremented during the OpenDrawer method if the cash drawer successfully opens.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticDrawerGoodOpenCount As String
public const string StatisticDrawerGoodOpenCount
public:
literal String^ StatisticDrawerGoodOpenCount
public static final String StatisticDrawerGoodOpenCount
public const var StatisticDrawerGoodOpenCount : String

See Also

Reference

CashDrawer Class
CashDrawer Members
Microsoft.PointOfService Namespace


CashDrawer.StatusClosed Field

CashDrawer.StatusClosed Field |
 | See Also

1/18/2008

Indicates that the cash drawer is closed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusClosed As Integer
public const int StatusClosed
public:
literal int StatusClosed
public static final int StatusClosed
public const var StatusClosed : int

Remarks

Replaces CASH_SUE_DRAWERCLOSED from UPOS.

See Also

Reference

CashDrawer Class
CashDrawer Members
Microsoft.PointOfService Namespace


CashDrawer.StatusOpen Field

CashDrawer.StatusOpen Field |
 | See Also

1/18/2008

Indicates that the cash drawer is open.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusOpen As Integer
public const int StatusOpen
public:
literal int StatusOpen
public static final int StatusOpen
public const var StatusOpen : int

Remarks

Replaces CASH_SUE_DRAWEROPEN from UPOS.

See Also

Reference

CashDrawer Class
CashDrawer Members
Microsoft.PointOfService Namespace


CashDrawer Constructor

CashDrawer Constructor |
 | See Also

1/18/2008

Creates an instance of the CashDrawer class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected CashDrawer ()
protected:
CashDrawer ()
protected CashDrawer ()
protected function CashDrawer ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

CashDrawer Class
CashDrawer Members
Microsoft.PointOfService Namespace


CashDrawer Methods

CashDrawer Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon )
OpenDrawer | Physically opens the cash drawer.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
WaitForDrawerClose | The application calls WaitForDrawerClose to wait until the cash drawer is closed. If the drawer is still open after beepTimeout milliseconds, the message beeper should be started.

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

CashDrawer Class
Microsoft.PointOfService Namespace


CashDrawer.OpenDrawer Method

CashDrawer.OpenDrawer Method |
 | See Also

1/18/2008

Physically opens the cash drawer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub OpenDrawer
public abstract void OpenDrawer ()
public:
virtual void OpenDrawer () abstract
public abstract void OpenDrawer ()
public abstract function OpenDrawer ()

Remarks

If the drawer opens successfully and the cash drawer supports status reporting (that is, the CapStatus property is set to true), the service object sets the DrawerOpened property to true. StatisticDrawerGoodOpenCount should also be incremented.

If the drawer does not open, StatisticDrawerFailedOpenCount should be incremented.

OpenDrawer may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Claimed | The cash drawer is currently claimed by another application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashDrawer Class
CashDrawer Members
Microsoft.PointOfService Namespace
CashDrawer.StatisticDrawerGoodOpenCount Field
CashDrawer.StatisticDrawerFailedOpenCount Field
CapStatus


CashDrawer.WaitForDrawerClose Method

CashDrawer.WaitForDrawerClose Method |
 | See Also

1/18/2008

The application calls WaitForDrawerClose to wait until the cash drawer is closed. If the drawer is still open after beepTimeout milliseconds, the message beeper should be started.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub WaitForDrawerClose ( _
    beepTimeout As Integer, _
    beepFrequency As Integer, _
    beepDuration As Integer, _
    beepDelay As Integer _
)
public abstract void WaitForDrawerClose (
    int beepTimeout,
    int beepFrequency,
    int beepDuration,
    int beepDelay
)
public:
virtual void WaitForDrawerClose (
    int beepTimeout,
    int beepFrequency,
    int beepDuration,
    int beepDelay
) abstract
public abstract void WaitForDrawerClose (
    int beepTimeout,
    int beepFrequency,
    int beepDuration,
    int beepDelay
)
public abstract function WaitForDrawerClose (
    beepTimeout : int,
    beepFrequency : int,
    beepDuration : int,
    beepDelay : int
)

Parameters

beepTimeout

Number of milliseconds to wait before starting a message beeper.

beepFrequency

Audio frequency of the message beeper in hertz.

beepDuration

Number of milliseconds that the beep tone sounds.

beepDelay

Number of milliseconds between the sounding of beeper tones.

Remarks

Unless an error occurs, WaitForDrawerClose does not return to the application while the drawer is open. When the cashier closes the drawer, the beeper should be turned off.

If the CapStatusMultiDrawerDetect property is false, then, unless an error occurs, WaitForDrawerClose does not return to the application while any drawers are open in a multidrawer configuration. When all drawers are detected as closed, the beeper should be turned off.

If the CapStatus property is set to false, then the device does not support status reporting, and WaitForDrawerClose should return immediately with a successful status.

WaitForDrawerClose may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Claimed | The drawer is currently claimed by another application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashDrawer Class
CashDrawer Members
Microsoft.PointOfService Namespace
CapStatus
CapStatusMultiDrawerDetect


CashDrawer Properties

CashDrawer Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapStatus | Gets the status of the cash drawer status, open or closed.
CapStatusMultiDrawerDetect | Gets the Boolean value that indicates the status of multidrawer configurations.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
DrawerOpened | Gets the Boolean value that indicates whether the drawer is open.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets the Boolean value that indicates whether the Cash Drawer is an exclusive-use device.

See Also

Reference

CashDrawer Class
Microsoft.PointOfService Namespace


CashDrawer.CapStatus Property

CashDrawer.CapStatus Property |
 | See Also

1/18/2008

Gets the status of the cash drawer status, open or closed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapStatus As Boolean
public abstract bool CapStatus { get; }
public:
virtual property bool CapStatus {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapStatus ()

public abstract function get CapStatus () : boolean

Remarks

If true, the drawer can report its status, open or closed.

CapStatus is set by the service object and then kept updated by the service object based on the capability of the device.

Accessing CapStatus may cause a PosControlException to be thrown with the following ErrorCode.

Value | Meaning
Closed | The cash drawer device must be opened before CapStatus can be retrieved.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashDrawer Class
CashDrawer Members
Microsoft.PointOfService Namespace


CashDrawer.CapStatusMultiDrawerDetect Property

CashDrawer.CapStatusMultiDrawerDetect Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates the status of multidrawer configurations.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapStatusMultiDrawerDetect As Boolean
public abstract bool CapStatusMultiDrawerDetect { get; }
public:
virtual property bool CapStatusMultiDrawerDetect {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapStatusMultiDrawerDetect ()

public abstract function get CapStatusMultiDrawerDetect () : boolean

Remarks

If true, statuses unique to each drawer in multidrawer configurations* can be reported.

If false, the following implications exist:

  • A DrawerOpened property value of false indicates that the drawer is closed.

  • A DrawerOpened property value of true indicates that at least one drawer is open, and it might be the particular drawer in question. This case can occur in multidrawer configurations* where only one status is reported that indicates either a) all drawers are closed, or b) one or more drawers are open.

CapStatusMultiDrawerDetect is only meaningful if the CapStatus property is set to true.

CapStatusMultiDrawerDetect is set by the service object and then kept updated by the service object based on the capability of the device.

Accessing CapStatusMultiDrawerDetect may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Closed | The cash drawer device must be opened before CapStatusMultiDrawerDetect can be retrieved.

*Multidrawer Configuration – A hardware configuration where a printer or terminal supports opening more than one drawer independently through the same channel or hardware port. A typical example is a configuration with a "Y" cable connected to a single hardware port that controls two drawers.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashDrawer Class
CashDrawer Members
Microsoft.PointOfService Namespace
CashDrawer.CapStatus Property
DrawerOpened


CashDrawer.DrawerOpened Property

CashDrawer.DrawerOpened Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the drawer is open.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DrawerOpened As Boolean
public abstract bool DrawerOpened { get; }
public:
virtual property bool DrawerOpened {
    bool get () abstract;
}
/** @property */
public abstract boolean get_DrawerOpened ()

public abstract function get DrawerOpened () : boolean

Remarks

This property indicates whether the drawer is open. If the Boolean value is true, the drawer is open; if false, it is closed. When the value of DrawerOpened changes, a StatusUpdateEvent event is generated. This indicates a drawer status change.

If the CapStatus property is set to false, the device does not support status reporting and DrawerOpened is always false.

DrawerOpened is set by the service object and then kept current by the service object while the device is enabled.

Accessing DrawerOpened may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Closed | The cash drawer device must be opened before DrawerOpened can be retrieved.
Illegal | The cash drawer device does not support status reporting, that is, the CapStatus property is set to false.

*If the CapStatusMultiDrawerDetect property is false, then a DrawerOpened value of true indicates at least one drawer is open, and it might be the particular drawer in question for multidrawer configurations. See CapStatusMultiDrawerDetect for clarification.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashDrawer Class
CashDrawer Members
Microsoft.PointOfService Namespace
CashDrawer.CapStatus Property
CashDrawer.CapStatusMultiDrawerDetect Property


CashDrawer.IsExclusiveUseDevice Property

CashDrawer.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the Cash Drawer is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Property Value

A value of true indicates the fiscal printer is an exclusive-use device. Otherwise, the value is false.

Remarks

An exclusive-use device has the following properties:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before accessing some properties or calling methods that update the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashDrawer Class
CashDrawer Members
Microsoft.PointOfService Namespace


CashDrawer Events

CashDrawer Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

CashDrawer Class
Microsoft.PointOfService Namespace


CashUnits Structure

CashUnits Structure |
 | See Also Members

1/18/2008

Holds arrays of bill and coin types for use in POS devices such as Cash Changers and Bill Dispensers.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Structure CashUnits
public struct CashUnits
public value class CashUnits
public final class CashUnits extends ValueType

Remarks

Each array contains a set of values that indicates the face value of each unit of currency supported by the device.

This structure is typically used together with a value that indicates the type of currency (for example, USD, JPY) that is used by the device.

Used by the CurrencyCashList, DepositCashList, and ExitCashList properties of the CashChanger and BillDispenser classes.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashUnits Members
Microsoft.PointOfService Namespace
BillDispenser Class
CashChanger Class


CashUnits Members

CashUnits Members |
 | See Also Constructors Methods Properties

1/18/2008

Holds arrays of bill and coin types for use in POS devices such as Cash Changers and Bill Dispensers.

The following tables list the members exposed by the CashUnits type.

Public Constructors

Name | Description
CashUnits | Creates an instance of the CashUnits class from parameters specifying the constituent parts of the instance.
Top

Public Properties

Name | Description
Bills | Gets an array that contains a set of nominal (face) values for bills in the current currency type.
Coins | Gets an array that contains a set of nominal (face) values for coins in the current currency type.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded.
GetHashCode | Overridden.
GetType | (inherited from Object )
op_Equality | Compares the specified CashUnits and object to determine whether they are equal.
op_Inequality | Returns a value that indicates whether an instance of CashUnits and an object are not equal.
ReferenceEquals | (inherited from Object )
ToString | (inherited from ValueType )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

CashUnits Structure
Microsoft.PointOfService Namespace
BillDispenser Class
CashChanger Class


CashUnits Constructor

CashUnits Constructor |
 | See Also

1/18/2008

Creates an instance of the CashUnits class from parameters specifying the constituent parts of the instance.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    coins As Integer(), _
    bills As Integer() _
)
public CashUnits (
    int[] coins,
    int[] bills
)
public:
CashUnits (
    array<int>^ coins,
    array<int>^ bills
)
public CashUnits (
    int[] coins,
    int[] bills
)
public function CashUnits (
    coins : int[],
    bills : int[]
)

Parameters

coins
bills

See Also

Reference

CashUnits Structure
CashUnits Members
Microsoft.PointOfService Namespace


CashUnits Methods

CashUnits Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded.
GetHashCode | Overridden.
GetType | (inherited from Object )
op_Equality | Compares the specified CashUnits and object to determine whether they are equal.
op_Inequality | Returns a value that indicates whether an instance of CashUnits and an object are not equal.
ReferenceEquals | (inherited from Object )
ToString | (inherited from ValueType )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

CashUnits Structure
Microsoft.PointOfService Namespace
BillDispenser Class
CashChanger Class


CashUnits.Equals Method

CashUnits.Equals Method |
 | See Also

1/18/2008

Overload List

Name | Description
CashUnits.Equals (CashUnits) |
CashUnits.Equals (Object) |
CashUnits.Equals (CashUnits, CashUnits) |
CashUnits.Equals (Object, Object) | (inherited from Equals )

See Also

Reference

CashUnits Structure
CashUnits Members
Microsoft.PointOfService Namespace


CashUnits.Equals Method (CashUnits)

CashUnits.Equals Method (CashUnits) |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Function Equals ( _
    units As CashUnits _
) As Boolean

public bool Equals (
    CashUnits units
)

public:
bool Equals (
    CashUnits units
)

public boolean Equals (
    CashUnits units
)

public function Equals (
    units : CashUnits
) : boolean

Parameters

units

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashUnits Structure
CashUnits Members
Microsoft.PointOfService Namespace


CashUnits.Equals Method (Object)

CashUnits.Equals Method (Object) |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

public override bool Equals (
    Object obj
)

public:
virtual bool Equals (
    Object^ obj
) override

public boolean Equals (
    Object obj
)

public override function Equals (
    obj : Object
) : boolean

Parameters

obj

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashUnits Structure
CashUnits Members
Microsoft.PointOfService Namespace


CashUnits.Equals Method (CashUnits, CashUnits)

CashUnits.Equals Method (CashUnits, CashUnits) |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Function Equals ( _
    a As CashUnits, _
    b As CashUnits _
) As Boolean

public static bool Equals (
    CashUnits a,
    CashUnits b
)

public:
static bool Equals (
    CashUnits a,
    CashUnits b
)

public static boolean Equals (
    CashUnits a,
    CashUnits b
)

public static function Equals (
    a : CashUnits,
    b : CashUnits
) : boolean

Parameters

a
b

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashUnits Structure
CashUnits Members
Microsoft.PointOfService Namespace


CashUnits.GetHashCode Method

CashUnits.GetHashCode Method |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function GetHashCode As Integer

public override int GetHashCode ()

public:
virtual int GetHashCode () override

public int GetHashCode ()

public override function GetHashCode () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashUnits Structure
CashUnits Members
Microsoft.PointOfService Namespace


CashUnits.op_Equality Method

CashUnits.op_Equality Method |
 | See Also

1/18/2008

Compares the specified CashUnits and object to determine whether they are equal.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Operator = ( _
    a As CashUnits, _
    b As Object _
) As Boolean
public static bool operator == (
    CashUnits a,
    Object b
)
public:
static bool operator == (
    CashUnits a,
    Object^ b
)

Parameters

a

The CashUnits to be compared to b.

b

The object to be compared to a.

Return Value

True if a is equal to b; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashUnits Structure
CashUnits Members
Microsoft.PointOfService Namespace


CashUnits.op_Inequality Method

CashUnits.op_Inequality Method |
 | See Also

1/18/2008

Returns a value that indicates whether an instance of CashUnits and an object are not equal.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Operator <> ( _
    a As CashUnits, _
    b As Object _
) As Boolean
public static bool operator != (
    CashUnits a,
    Object b
)
public:
static bool operator != (
    CashUnits a,
    Object^ b
)

Parameters

a

The CashUnits to be compared to b.

b

The object to be compared to a.

Return Value

True if a is not equal to b; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashUnits Structure
CashUnits Members
Microsoft.PointOfService Namespace


CashUnits Properties

CashUnits Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
Bills | Gets an array that contains a set of nominal (face) values for bills in the current currency type.
Coins | Gets an array that contains a set of nominal (face) values for coins in the current currency type.

See Also

Reference

CashUnits Structure
Microsoft.PointOfService Namespace
BillDispenser Class
CashChanger Class


CashUnits.Bills Property

CashUnits.Bills Property |
 | See Also Example

1/18/2008

Gets an array that contains a set of nominal (face) values for bills in the current currency type.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Bills As Integer()
public int[] Bills { get; }
public:
property array<int>^ Bills {
    array<int>^ get ();
}
/** @property */
public int[] get_Bills ()

public function get Bills () : int[]

Remarks

Bills is an array of integers that contains a set of values that represent face values for bills in the current currency type.

Example

A Bills array that contains the following USD values:

  • 5, 10, 20, 50, 100

indicates that the device supports bills in denominations of five, ten, twenty, fifty, and one-hundred dollars.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashUnits Structure
CashUnits Members
Microsoft.PointOfService Namespace


CashUnits.Coins Property

CashUnits.Coins Property |
 | See Also Example

1/18/2008

Gets an array that contains a set of nominal (face) values for coins in the current currency type.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Coins As Integer()
public int[] Coins { get; }
public:
property array<int>^ Coins {
    array<int>^ get ();
}
/** @property */
public int[] get_Coins ()

public function get Coins () : int[]

Remarks

Coins is an array of integers that contains a set of values that represent face values for coins in the current currency type.

Example

A Coins array that contains the following USD values:

  • 5, 10, 25

indicates that the device supports U.S. nickels, dimes, and quarters.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashUnits Structure
CashUnits Members
Microsoft.PointOfService Namespace


Cat Class

Cat Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a UPOS credit authorization terminal (CAT) device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class Cat
    Inherits PosCommon
public abstract class Cat : PosCommon
public ref class Cat abstract : public PosCommon
public abstract class Cat extends PosCommon
public abstract class Cat extends PosCommon

Remarks

The CAT control can perform the following general mode of operation:

  • This standard defines the application interface with the CAT control and does not depend on the CAT device hardware implementation. Therefore, the hardware implementation of a CAT device may be as follows:

    • Separate type (POS interlock)

      The dedicated CAT device is externally connected to the POS (for example, through an RS-232 connection).

    • Built-in type

      The hardware structure is the same as the separate type but is installed within the POS housing.

  • The CAT device receives each authorization request that contains a purchase amount and tax from CAT control.

  • The CAT device generally asks the user to swipe a magnetic card when the device receives an authorization request from CAT control.

  • After a magnetic card is swiped at the CAT device, the device sends the purchase amount and tax to the approval agency that uses the communications device.

  • The CAT device returns the result from the approval agency to the CAT control. The returned data is stored in the authorization properties by the CAT control for access by applications.

A CAT control that is considered as an electronic money device has the following additional model composition:

  • The electronic money device is constituted by card reader [contact type / contact-less type], communication module for Closing processing and so on.

  • The electronic money device receives the information about amount of money, tax, and so on from CAT control, and then starts settlement processing.

  • When the electronic money device is required settlement of account requirement by CAT control, it generally requires card [contact type / contact-less type].

  • When a card [contact type / contact-less type] is input by the electronic money device, it tries to close the account by information about amount of money, tax, and so on.

  • The electronic money device sends CAT control settlement result to CAT control. The settlement result is stored in each property by the CAT control, and notifies the application.

  • After the electronic money device receives the settlement requirement from the application, the remaining operations occur on the side of the electronic money device. Lastly, the settlement result is sent to the application.

  • The electronic money device may save the settlement result as DealingLog on the device memory. Such as device may send DealingLog to the Center by closing processing.

Programming Model

The general models for the CAT service object are shown here:

  • The CAT service object basically follows the output device model. However, multiple methods cannot be issued for asynchronous output; only one outstanding asynchronous request is allowed.

  • The CAT service object issues requests to the CAT device for different types of authorization by invoking the following methods:

Function | Method Name | Corresponding Cap Property
Purchase | AuthorizeSales | None
Cancel Purchase | AuthorizeVoid | CapAuthorizeVoid
Refund Purchase | AuthorizeRefund | CapAuthorizeRefund
Authorization Completion | AuthorizeCompletion | CapAuthorizeCompletion
Pre-Authorization | AuthorizePreSales | CapAuthorizePreSales
Cancel Pre-Authorization | AuthorizeVoidPreSales | CapAuthorizeVoidPreSales

  • The CAT service object issues requests to the CAT device for special processing local to the CAT device by invoking the following methods:

Function | Method Name | Corresponding Cap Property
Card Check | CheckCard | CapCheckCard
Daily log | AccessDailyLog | CapDailyLog

  • The CAT service object stores the authorization results in the following properties when an authorization operation finishes successfully.

Description | Property Name | Corresponding Cap Property
Account number | AccountNumber | None
Additional information | AdditionalSecurityInformation | CapAdditionalSecurityInformation
Approval code | ApprovalCode | None
Card company ID | CardCompanyId | None
Code from the approval agency | CenterResultCode | CapCenterResultCode
Payment condition | PaymentCondition | None
Payment detail | PaymentDetail | CapPaymentDetail
Sequence number | SequenceNumber | None
Slip number | SlipNumber | None
Center transaction number | TransactionNumber | CapTransactionNumber
Transaction type | TransactionType | None

  • The AccessDailyLog method sets the following property.

Description | Property Name | Corresponding Cap Property
Daily log | DailyLog | CapDailyLog
DealingLog | DailyLog | CapDailyLog

  • The CAT control requires the electronic money device to each settlement and closing DealingLog requirement by the following methods.

Function | Property Name | Corresponding Cap Property
Settlement | AuthorizeSales | None
Charge | CashDeposit | CapCashDeposit
Inquiry for the balances | CheckCard | CapCheckCard
Closing DealingLog | AccessDailyLog | CapDailyLog
Setting security lock | LockTerminal | CapLockTerminal
Releasing security lock | UnlockTerminal | CapUnlockTerminal

  • When the CAT Control receives the settlement results from the electronic money device, it stores these results in the following properties.

Description | Property Name | Corresponding Cap Property
CardId | AccountNumber | None
More information | AdditionalSecurityInformation | CapAdditionalSecurityInformation
Approval code | ApprovalCode | None
Settled amount | SettledAmount | None
Balance | Balance | None
Sequence number | SequenceNumber | None
Transaction type | TransactionType | None

  • Sequence numbers are used to validate that the properties set at completion of a method are indeed associated with the completed method. An incoming sequenceNumber argument for each method is compared with the resulting SequenceNumber property after the operation associated with the method has finished. If the numbers do not match, or if an application does not determine the number, there is no guarantee that the values of the properties listed in the two tables correspond to the completed method.

  • The AsyncMode property determines whether methods are run synchronously or asynchronously.

    • When AsyncMode is false, methods are executed synchronously and their corresponding properties will contain data when the method returns.

    • When AsyncMode is true, methods return immediately to the application. When the operation associated with the method is complete, each corresponding property is updated by the CAT service object before an OutputCompleteEvent. When AsyncMode is true, methods cannot be issued immediately after issuing a prior method; only one outstanding asynchronous method is allowed at a time. However, ClearOutput is an exception because its purpose is to cancel an outstanding asynchronous method.

  • The methods supported and their corresponding properties vary depending on the CAT control implementation. Applications should verify that particular Cap properties are supported before applications use the capability-dependent methods and properties.

  • Results of synchronous calls to methods and writable properties are stored in ErrorCode. Results of asynchronous processing are indicated by an OutputCompleteEvent event or returned in ErrorCode. The result code from the approval agency is stored in CenterResultCode in either mode.

  • Training mode occurs continually when TrainingMode is true. To stop training mode, set TrainingMode to false.

  • An outstanding asynchronous method can be canceled through the ClearOutput method.

  • The daily log can be collected by the AccessDailyLog method. Collection will be run either synchronously or asynchronously according to the value of AsyncMode.

Synchronous Mode Usage Sequence

  1. Open

  2. Claim Device

  3. DeviceEnabled=true

  4. Definition of the sequenceNumber argument.

  5. Set PaymentMedia.

  6. AuthorizeSales .

  7. Check ErrorCode.

  8. Verify that the SequenceNumber property matches the value of the AuthorizeSalessequenceNumber argument.

  9. Access the properties set by AuthorizeSales .

  10. DeviceEnabled=false.

  11. Release Device.

  12. Close.

Asynchronous Mode Usage Sequence

  1. Open.

  2. Claim Device.

  3. DeviceEnabled = true.

  4. AsyncMode = true.

  5. Definition of the sequenceNumber argument.

  6. Set PaymentMedia.

  7. AuthorizeSales .

  8. Check ErrorCode.

  9. Wait for OutputCompleteEvent.

  10. Check the ErrorCode.

  11. Verify that the SequenceNumber property matches the value of the AuthorizeSalessequenceNumber argument.

  12. Access the properties set by AuthorizeSales .

DeviceEnabled=false.

  1. Release Device.

  2. Close.

Device Sharing

The CAT is an exclusive-use device, as follows:

  • After you open the device, properties are readable.

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before the application calls methods that manipulate the device.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.Cat
Microsoft.PointOfService.BasicServiceObjects.CatBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Members
Microsoft.PointOfService Namespace


Cat Members

Cat Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a UPOS credit authorization terminal (CAT) device.

The following tables list the members exposed by the Cat type.

Protected Constructors

Name | Description
Cat | Creates an instance of the Cat class.
Top

Public Fields

Name | Description
ExtendedErrorCenterError | Indicates an error was returned from the approval agency in CenterResultCode.
ExtendedErrorCommandError | Indicates the command sent to the CAT is incorrect.
ExtendedErrorCommunicationError | Indicates a communication error has occurred between the approval agency and the CAT.
ExtendedErrorDailyLogOverflow | Indicates the daily log is too big to be stored.
ExtendedErrorDeficient | Indicates the balance is insufficient for an electronic money device. The device cannot close the settlement.
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorOverDeposit | Indicates a failure occurs for an electronic money device if the attempted settlement amount exceeds the charge account limit.
ExtendedErrorReset | Indicates the CAT was stopped during processing by the CAT Reset key or Stop key.
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
AccountNumber | Gets the credit card number of the settled account.
AdditionalSecurityInformation | Gets or sets additional security information for an authorization operation.
ApprovalCode | Gets the credit approval code.
AsyncMode | Gets or sets the Boolean value that indicates whether the authorization runs asynchronously.
Balance | Gets a credit card balance.
CapAdditionalSecurityInformation | Gets the Boolean value that indicates whether the AdditionalSecurityInformation property can be used.
CapAuthorizeCompletion | Gets the Boolean value that indicates whether the AuthorizeCompletion method is implemented.
CapAuthorizePreSales | Gets the Boolean value that indicates whether the AuthorizePreSales method is implemented.
CapAuthorizeRefund | Gets the Boolean value that indicates whether the AuthorizeRefund method is implemented.
CapAuthorizeVoid | Gets the Boolean value that indicates whether the AuthorizeVoid method is implemented.
CapAuthorizeVoidPreSales | Gets the Boolean value that indicates whether the AuthorizeVoidPreSales method is implemented.
CapCashDeposit | Gets the Boolean value that indicates whether the CashDeposit method is implemented.
CapCenterResultCode | Gets the Boolean value that indicates whether the CenterResultCode method is implemented.
CapCheckCard | Gets the Boolean value that indicates whether the CheckCard method is implemented.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapDailyLog | Gets the daily log ability of the device.
CapInstallments | Gets the Boolean value that indicates whether the "Installments" item is provided.
CapLockTerminal | Gets a Boolen value that indicates whether the device has a security lock and can set it.
CapLogStatus | Gets a Boolen value that indicates whether the device can give information about the status of the log.
CapPaymentDetail | Gets the Boolean value that indicates whether the PaymentDetail property is implemented.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapTaxOthers | Gets the Boolean value that indicates whether the item "TaxOthers" is provided.
CapTrainingMode | Gets the Boolean value that indicates whether the TrainingMode property is implemented.
CapTransactionNumber | Gets the Boolean value that indicates whether the TransactionNumber property is implemented.
CapUnlockTerminal | Gets the Boolean value that indicates whether the security lock can be released.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CardCompanyId | Gets the credit card company ID.
CenterResultCode | Gets the code from the approval agency.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
DailyLog | Gets the result of the AccessDailyLog method.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
LogStatus | Gets the status of the dealing log of the CAT device.
OutputId | Gets the identifier of the most recently started asynchronous output.
PaymentCondition | Gets the payment condition of the most recent successful authorization operation.
PaymentDetail | Gets payment condition details as the result of an authorization operation.
PaymentMedia | Gets or sets the payment media type that the approval method should approve.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
SequenceNumber | Gets a "sequence number" as the result of each method call.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
SettledAmount | Gets the amount of the settlement for an electronic money device.
SlipNumber | Gets a "slip number" as the result of each authorization operation.
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
TrainingMode | Gets or sets the Boolean value that indicates whether each operation is run in training mode.
TransactionNumber | Gets a transaction number as the result of each authorization operation.
TransactionType | Gets a transaction number as the result of each authorization operation.
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets the Boolean value that indicates whether the credit authorization terminal is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
AccessDailyLog | Gets the daily log from CAT.
AuthorizeCompletion | Authorizes the purchase after approval.
AuthorizePreSales | Preauthorizes a purchase.
AuthorizeRefund | Approves a refund for a purchase.
AuthorizeSales | Approves a purchase.
AuthorizeVoid | Approves cancellation of a purchase.
AuthorizeVoidPreSales | Preauthorizes a cancellation.
CashDeposit | Charges the specified amount of money to the account.
CheckCard | Indicates that a card check is intended.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearOutput | Clears outputs that have been buffered for the unit.
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
LockTerminal | Sets the security lock.
Open | Opens a device for later input/output processing. (inherited from PosCommon)
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UnlockTerminal | Releases the security lock.
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
ErrorEvent | Notifies the application that a CAT error has been detected and suitable response by the application is necessary to process the error condition.
OutputCompleteEvent | Notifies the application that the queued output request associated with the OutputId property has completed successfully.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

Cat Class
Microsoft.PointOfService Namespace


Cat Fields

Cat Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorCenterError | Indicates an error was returned from the approval agency in CenterResultCode.
ExtendedErrorCommandError | Indicates the command sent to the CAT is incorrect.
ExtendedErrorCommunicationError | Indicates a communication error has occurred between the approval agency and the CAT.
ExtendedErrorDailyLogOverflow | Indicates the daily log is too big to be stored.
ExtendedErrorDeficient | Indicates the balance is insufficient for an electronic money device. The device cannot close the settlement.
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorOverDeposit | Indicates a failure occurs for an electronic money device if the attempted settlement amount exceeds the charge account limit.
ExtendedErrorReset | Indicates the CAT was stopped during processing by the CAT Reset key or Stop key.
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

Cat Class
Microsoft.PointOfService Namespace


Cat.ExtendedErrorCenterError Field

Cat.ExtendedErrorCenterError Field |
 | See Also

1/18/2008

Indicates an error was returned from the approval agency in CenterResultCode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorCenterError As Integer
public const int ExtendedErrorCenterError
public:
literal int ExtendedErrorCenterError
public static final int ExtendedErrorCenterError
public const var ExtendedErrorCenterError : int

Remarks

This value of this field indicates whether an error was returned from the approval agency in CenterResultCode.

This field replaces ECAT_CENTERERROR that is used by UPOS.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
CenterResultCode


Cat.ExtendedErrorCommandError Field

Cat.ExtendedErrorCommandError Field |
 | See Also

1/18/2008

Indicates the command sent to the CAT is incorrect.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorCommandError As Integer
public const int ExtendedErrorCommandError
public:
literal int ExtendedErrorCommandError
public static final int ExtendedErrorCommandError
public const var ExtendedErrorCommandError : int

Remarks

This field replaces ECAT_COMMANDERROR that is used by UPOS.

This error is never returned if the CAT service object is working correctly.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
ErrorEvent


Cat.ExtendedErrorCommunicationError Field

Cat.ExtendedErrorCommunicationError Field |
 | See Also

1/18/2008

Indicates a communication error has occurred between the approval agency and the CAT.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorCommunicationError As Integer
public const int ExtendedErrorCommunicationError
public:
literal int ExtendedErrorCommunicationError
public static final int ExtendedErrorCommunicationError
public const var ExtendedErrorCommunicationError : int

Remarks

This field replaces ECAT_COMMUNICATIONERROR that is used in UPOS. This error is never returned if the CAT service object is working correctly.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
ErrorEvent


Cat.ExtendedErrorDailyLogOverflow Field

Cat.ExtendedErrorDailyLogOverflow Field |
 | See Also

1/18/2008

Indicates the daily log is too big to be stored.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorDailyLogOverflow As Integer
public const int ExtendedErrorDailyLogOverflow
public:
literal int ExtendedErrorDailyLogOverflow
public static final int ExtendedErrorDailyLogOverflow
public const var ExtendedErrorDailyLogOverflow : int

Remarks

This field replaces ECAT_DAILYLOGOVERFLOW that is used in UPOS. This field indicates whether the daily log is too large to be stored.

Updates to the daily log have been stopped and the value of the DailyLog property is uncertain.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
DailyLog
ErrorEvent


Cat.ExtendedErrorDeficient Field

Cat.ExtendedErrorDeficient Field |
 | See Also

1/18/2008

Indicates the balance is insufficient for an electronic money device. The device cannot close the settlement.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorDeficient As Integer
public const int ExtendedErrorDeficient
public:
literal int ExtendedErrorDeficient
public static final int ExtendedErrorDeficient
public const var ExtendedErrorDeficient : int

Remarks

Used in an ErrorEvent.

This field replaces ECAT_DEFICIENT that is used in UPOS.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace


Cat.ExtendedErrorOverDeposit Field

Cat.ExtendedErrorOverDeposit Field |
 | See Also

1/18/2008

Indicates a failure occurs for an electronic money device if the attempted settlement amount exceeds the charge account limit.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorOverDeposit As Integer
public const int ExtendedErrorOverDeposit
public:
literal int ExtendedErrorOverDeposit
public static final int ExtendedErrorOverDeposit
public const var ExtendedErrorOverDeposit : int

Remarks

Used in an ErrorEvent. This field replaces ECAT_OVERDEPOSIT that is used in UPOS.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace


Cat.ExtendedErrorReset Field

Cat.ExtendedErrorReset Field |
 | See Also

1/18/2008

Indicates the CAT was stopped during processing by the CAT Reset key or Stop key.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorReset As Integer
public const int ExtendedErrorReset
public:
literal int ExtendedErrorReset
public static final int ExtendedErrorReset
public const var ExtendedErrorReset : int

Remarks

This field indicates whether the CAT was stopped during processing by the Reset or Stop keys.

This field replaces ECAT_RESET, which is used in UPOS.

Updates to the daily log have been stopped and the value of the DailyLog property is uncertain.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
DailyLog
ErrorEvent


Cat Constructor

Cat Constructor |
 | See Also

1/18/2008

Creates an instance of the Cat class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected Cat ()
protected:
Cat ()
protected Cat ()
protected function Cat ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace


Cat Methods

Cat Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
AccessDailyLog | Gets the daily log from CAT.
AuthorizeCompletion | Authorizes the purchase after approval.
AuthorizePreSales | Preauthorizes a purchase.
AuthorizeRefund | Approves a refund for a purchase.
AuthorizeSales | Approves a purchase.
AuthorizeVoid | Approves cancellation of a purchase.
AuthorizeVoidPreSales | Preauthorizes a cancellation.
CashDeposit | Charges the specified amount of money to the account.
CheckCard | Indicates that a card check is intended.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearOutput | Clears outputs that have been buffered for the unit.
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
LockTerminal | Sets the security lock.
Open | Opens a device for later input/output processing. (inherited from PosCommon )
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UnlockTerminal | Releases the security lock.
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

Cat Class
Microsoft.PointOfService Namespace


Cat.AccessDailyLog Method

Cat.AccessDailyLog Method |
 | See Also

1/18/2008

Gets the daily log from CAT.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub AccessDailyLog ( _
    sequenceNumber As Integer, _
    type As CatLogs, _
    timeout As Integer _
)
public abstract void AccessDailyLog (
    int sequenceNumber,
    CatLogs type,
    int timeout
)
public:
virtual void AccessDailyLog (
    int sequenceNumber,
    CatLogs type,
    int timeout
) abstract
public abstract void AccessDailyLog (
    int sequenceNumber,
    CatLogs type,
    int timeout
)
public abstract function AccessDailyLog (
    sequenceNumber : int,
    type : CatLogs,
    timeout : int
)

Parameters

sequenceNumber

The sequence number to get the daily log.

type

Specifies whether the daily log is intermediate total or final total and erase.

timeout

The maximum waiting time (in milliseconds) until the response is received from the CAT device. WaitForever, 0, and positive values can be specified.

Remarks

The daily log is retrieved and stored in DailyLog as specified by sequenceNumber.

When timeout is WaitForever, time-out never occurs and the device waits until it receives a response from the CAT.

The application must specify one of the following values for type for daily log type (either intermediate total or adjustment). Legal values depend on the CapDailyLog value.

Value | Meaning
Reporting | Intermediate total.
ReportingAndSettlement | Final total and erase.

AccessDailyLog may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Illegal | An invalid or unsupported type or timeout parameter is specified, or CapDailyLog is false.
Timeout | No response was received from CAT during the specified time-out time in milliseconds.
Extended | The detail code is stored in ErrorCodeExtended.
Busy | The CAT device cannot accept any commands now.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
CapDailyLog
DailyLog


Cat.AuthorizeCompletion Method

Cat.AuthorizeCompletion Method |
 | See Also

1/18/2008

Authorizes the purchase after approval.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub AuthorizeCompletion ( _
    sequenceNumber As Integer, _
    amount As Decimal, _
    taxOthers As Decimal, _
    timeout As Integer _
)
public abstract void AuthorizeCompletion (
    int sequenceNumber,
    decimal amount,
    decimal taxOthers,
    int timeout
)
public:
virtual void AuthorizeCompletion (
    int sequenceNumber,
    Decimal amount,
    Decimal taxOthers,
    int timeout
) abstract
public abstract void AuthorizeCompletion (
    int sequenceNumber,
    Decimal amount,
    Decimal taxOthers,
    int timeout
)
public abstract function AuthorizeCompletion (
    sequenceNumber : int,
    amount : decimal,
    taxOthers : decimal,
    timeout : int
)

Parameters

sequenceNumber

Sequence number for approval.

amount

Purchase amount for approval.

taxOthers

Tax and other amounts for approval.

timeout

The maximum wait time (in milliseconds) until the response is received from the CAT device. WaitForever, 0, and positive values can be specified.

Remarks

Sales after approval for amount and taxOthers is intended as the approval specified by sequenceNumber.

When timeout is WaitForever, time-out never occurs and the device waits until it receives response from the CAT.

AuthorizeCompletion may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Illegal | An invalid timeout parameter is specified, or CapAuthorizeCompletion is false.
Timeout | No response was received from CAT during the specified timeout time in milliseconds.
Extended | The detail code is stored in ErrorCodeExtended.
Busy | The CAT device cannot accept any commands now.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
CapAuthorizeCompletion


Cat.AuthorizePreSales Method

Cat.AuthorizePreSales Method |
 | See Also

1/18/2008

Preauthorizes a purchase.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub AuthorizePreSales ( _
    sequenceNumber As Integer, _
    amount As Decimal, _
    taxOthers As Decimal, _
    timeout As Integer _
)
public abstract void AuthorizePreSales (
    int sequenceNumber,
    decimal amount,
    decimal taxOthers,
    int timeout
)
public:
virtual void AuthorizePreSales (
    int sequenceNumber,
    Decimal amount,
    Decimal taxOthers,
    int timeout
) abstract
public abstract void AuthorizePreSales (
    int sequenceNumber,
    Decimal amount,
    Decimal taxOthers,
    int timeout
)
public abstract function AuthorizePreSales (
    sequenceNumber : int,
    amount : decimal,
    taxOthers : decimal,
    timeout : int
)

Parameters

sequenceNumber

Sequence number for approval.

amount

Purchase amount for approval.

taxOthers

Tax and other amounts for approval.

timeout

The maximum wait time (in milliseconds) until the response is received from the CAT device. WaitForever, 0, and positive values can be specified.

Remarks

Preauthorization for amount and taxOthers is made as the approval specified by sequenceNumber.

When timeout is WaitForever, time-out never occurs and the device waits until it receives a response from the CAT.

AuthorizePreSales may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Illegal | An invalid timeout parameter is specified, or CapAuthorizePreSales is false.
Timeout | No response was received from CAT during the specified timeout time in milliseconds.
Extended | The detail code is stored in ErrorCodeExtended.
Busy | The CAT device cannot accept any commands now.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
CapAuthorizeCompletion


Cat.AuthorizeRefund Method

Cat.AuthorizeRefund Method |
 | See Also

1/18/2008

Approves a refund for a purchase.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub AuthorizeRefund ( _
    sequenceNumber As Integer, _
    amount As Decimal, _
    taxOthers As Decimal, _
    timeout As Integer _
)
public abstract void AuthorizeRefund (
    int sequenceNumber,
    decimal amount,
    decimal taxOthers,
    int timeout
)
public:
virtual void AuthorizeRefund (
    int sequenceNumber,
    Decimal amount,
    Decimal taxOthers,
    int timeout
) abstract
public abstract void AuthorizeRefund (
    int sequenceNumber,
    Decimal amount,
    Decimal taxOthers,
    int timeout
)
public abstract function AuthorizeRefund (
    sequenceNumber : int,
    amount : decimal,
    taxOthers : decimal,
    timeout : int
)

Parameters

sequenceNumber

Sequence number for approval.

amount

Purchase amount for approval.

taxOthers

Tax and other amounts for approval.

timeout

The maximum wait time (in milliseconds) until the response is received from the CAT device. WaitForever, 0, and positive values can be specified.

Remarks

Refund purchase approval for amount and taxOthers is intended as the approval specified by sequenceNumber.

When timeout is WaitForever, time-out never occurs and the device waits until it receives a response from the CAT.

AuthorizeRefund may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Illegal | An invalid timeout parameter is specified, or CapAuthorizeRefund is false.
Timeout | No response was received from CAT during the specified timeout time in milliseconds.
Extended | The detail code is stored in ErrorCodeExtended.
Busy | The CAT device cannot accept any commands now.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
CapAuthorizeRefund


Cat.AuthorizeSales Method

Cat.AuthorizeSales Method |
 | See Also

1/18/2008

Approves a purchase.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub AuthorizeSales ( _
    sequenceNumber As Integer, _
    amount As Decimal, _
    taxOthers As Decimal, _
    timeout As Integer _
)
public abstract void AuthorizeSales (
    int sequenceNumber,
    decimal amount,
    decimal taxOthers,
    int timeout
)
public:
virtual void AuthorizeSales (
    int sequenceNumber,
    Decimal amount,
    Decimal taxOthers,
    int timeout
) abstract
public abstract void AuthorizeSales (
    int sequenceNumber,
    Decimal amount,
    Decimal taxOthers,
    int timeout
)
public abstract function AuthorizeSales (
    sequenceNumber : int,
    amount : decimal,
    taxOthers : decimal,
    timeout : int
)

Parameters

sequenceNumber

Sequence number for approval.

amount

Purchase amount for approval.

taxOthers

Tax and other amounts for approval.

timeout

The maximum wait time (in milliseconds) until the response is received from the CAT device. WaitForever, 0, and positive values can be specified.

Remarks

Normal purchase approval for amount and taxOthers is intended as the approval specified by sequenceNumber.

When timeout is WaitForever, time-out never occurs and the device waits until it receives a response from the CAT.

AuthorizeSales may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Illegal | An invalid timeout parameter is specified.
Timeout | No response was received from CAT during the specified timeout time in milliseconds.
Extended | The detail code is stored in ErrorCodeExtended.
Busy | The CAT device cannot accept any commands now.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
CapAuthorizeSales


Cat.AuthorizeVoid Method

Cat.AuthorizeVoid Method |
 | See Also

1/18/2008

Approves cancellation of a purchase.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub AuthorizeVoid ( _
    sequenceNumber As Integer, _
    amount As Decimal, _
    taxOthers As Decimal, _
    timeout As Integer _
)
public abstract void AuthorizeVoid (
    int sequenceNumber,
    decimal amount,
    decimal taxOthers,
    int timeout
)
public:
virtual void AuthorizeVoid (
    int sequenceNumber,
    Decimal amount,
    Decimal taxOthers,
    int timeout
) abstract
public abstract void AuthorizeVoid (
    int sequenceNumber,
    Decimal amount,
    Decimal taxOthers,
    int timeout
)
public abstract function AuthorizeVoid (
    sequenceNumber : int,
    amount : decimal,
    taxOthers : decimal,
    timeout : int
)

Parameters

sequenceNumber

Sequence number for approval.

amount

Purchase amount for approval.

taxOthers

Tax and other amounts for approval.

timeout

The maximum wait time (in milliseconds) until the response is received from the CAT device. WaitForever, 0, and positive values can be specified.

Remarks

Cancellation approval for amount and taxOthers is intended as the approval specified by sequenceNumber.

When timeout is WaitForever, time-out never occurs and the device waits until it receives response from the CAT.

AuthorizeVoid may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Illegal | An invalid timeout parameter is specified, or CapAuthorizeVoid is false.
Timeout | No response was received from CAT during the specified timeout time in milliseconds.
Extended | The detail code is stored in ErrorCodeExtended.
Busy | The CAT device cannot accept any commands now.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
CapAuthorizeVoid


Cat.AuthorizeVoidPreSales Method

Cat.AuthorizeVoidPreSales Method |
 | See Also

1/18/2008

Preauthorizes a cancellation.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub AuthorizeVoidPreSales ( _
    sequenceNumber As Integer, _
    amount As Decimal, _
    taxOthers As Decimal, _
    timeout As Integer _
)
public abstract void AuthorizeVoidPreSales (
    int sequenceNumber,
    decimal amount,
    decimal taxOthers,
    int timeout
)
public:
virtual void AuthorizeVoidPreSales (
    int sequenceNumber,
    Decimal amount,
    Decimal taxOthers,
    int timeout
) abstract
public abstract void AuthorizeVoidPreSales (
    int sequenceNumber,
    Decimal amount,
    Decimal taxOthers,
    int timeout
)
public abstract function AuthorizeVoidPreSales (
    sequenceNumber : int,
    amount : decimal,
    taxOthers : decimal,
    timeout : int
)

Parameters

sequenceNumber

Sequence number for approval.

amount

Purchase amount for approval.

taxOthers

Tax and other amounts for approval.

timeout

The maximum wait time (in milliseconds) until the response is received from the CAT device. WaitForever, 0, and positive values can be specified.

Remarks

Preauthorization cancellation approval for amount and taxOthers is intended as the approval specified by sequenceNumber.

When timeout is WaitForever, time-out never occurs and the device waits until it receives response from the CAT.

Normal cancellation can be used for CAT service object and CAT devices that have not implemented the preauthorization approval cancellation. Refer to the documentation supplied with the CAT device and/or CAT service object.

AuthorizeVoidPreSales may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Illegal | An invalid timeout parameter is specified, or CapAuthorizeVoidPreSales is false.
Timeout | No response was received from CAT during the specified timeout time in milliseconds.
Extended | The detail code is stored in ErrorCodeExtended.
Busy | The CAT device cannot accept any commands now.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
CapAuthorizeVoidPreSales


Cat.CashDeposit Method

Cat.CashDeposit Method |
 | See Also

1/18/2008

Charges the specified amount of money to the account.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Sub CashDeposit ( _
    sequenceNumber As Integer, _
    amount As Decimal, _
    timeout As Integer _
)
public virtual void CashDeposit (
    int sequenceNumber,
    decimal amount,
    int timeout
)
public:
virtual void CashDeposit (
    int sequenceNumber,
    Decimal amount,
    int timeout
)
public void CashDeposit (
    int sequenceNumber,
    Decimal amount,
    int timeout
)
public function CashDeposit (
    sequenceNumber : int,
    amount : decimal,
    timeout : int
)

Parameters

sequenceNumber

Sequence number for charge.

amount

Amount of money for charge.

timeout

The maximum wait time (in milliseconds) until the response is received from the CAT device. WaitForever, 0, and positive values can be specified.

Remarks

The amount is stored on the device. If timeout is WaitForever, a time-out does not occur and the process waits forever until the device responds.

CashDeposit may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Description
Illegal | An invalid timeout parameter is specified, or CapCashDeposit is false.
Timeout | No response was received from the CAT during the specified timeout time in milliseconds.
Busy | The device cannot accept any commands now.
Extended | The detailed code is stored in an ErrorCodeExtended.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
CapCashDeposit


Cat.CheckCard Method

Cat.CheckCard Method |
 | See Also

1/18/2008

Indicates that a card check is intended.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub CheckCard ( _
    sequenceNumber As Integer, _
    timeout As Integer _
)
public abstract void CheckCard (
    int sequenceNumber,
    int timeout
)
public:
virtual void CheckCard (
    int sequenceNumber,
    int timeout
) abstract
public abstract void CheckCard (
    int sequenceNumber,
    int timeout
)
public abstract function CheckCard (
    sequenceNumber : int,
    timeout : int
)

Parameters

sequenceNumber

Sequence number for approval.

timeout

The maximum wait time (in milliseconds) until the response is received from the CAT device. WaitForever, 0, and positive values can be specified.

Remarks

Card check is made as specified by sequenceNumber.

When timeout is WaitForever, time-out never occurs and the device waits until it receives response from the CAT.

CheckCard may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Illegal | An invalid timeout parameter is specified, or CapCheckCard is false.
Timeout | No response was received from CAT during the specified timeout time in milliseconds.
Extended | The detail code is stored in ErrorCodeExtended.
Busy | The CAT device cannot accept any commands now.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
CapCheckCard


Cat.ClearOutput Method

Cat.ClearOutput Method |
 | See Also

1/18/2008

Clears outputs that have been buffered for the unit.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearOutput
public abstract void ClearOutput ()
public:
virtual void ClearOutput () abstract
public abstract void ClearOutput ()
public abstract function ClearOutput ()

Remarks

When it is possible, ClearOutput also halts outputs that are in progress.

Any output error events that are queued, usually waiting for FreezeEvents to be set to false, are also cleared.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace


Cat.LockTerminal Method

Cat.LockTerminal Method |
 | See Also

1/18/2008

Sets the security lock.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Sub LockTerminal
public virtual void LockTerminal ()
public:
virtual void LockTerminal ()
public void LockTerminal ()
public function LockTerminal ()

Remarks

When locked, the device cannot accept any commands.

AdditionalSecurityInformation property is used when key information is required.

LockTerminal may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Description
Illegal | The device does not have a security lock function.
Busy | The device cannot accept any commands now.
Extended | The detailed code is stored in an ErrorCodeExtended.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
CaplockTerminal


Cat.UnlockTerminal Method

Cat.UnlockTerminal Method |
 | See Also

1/18/2008

Releases the security lock.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Sub UnlockTerminal
public virtual void UnlockTerminal ()
public:
virtual void UnlockTerminal ()
public void UnlockTerminal ()
public function UnlockTerminal ()

Remarks

The AdditionalSecurityInformation property is used when key information is required.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
CapUnlockTerminal


Cat Properties

Cat Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
AccountNumber | Gets the credit card number of the settled account.
AdditionalSecurityInformation | Gets or sets additional security information for an authorization operation.
ApprovalCode | Gets the credit approval code.
AsyncMode | Gets or sets the Boolean value that indicates whether the authorization runs asynchronously.
Balance | Gets a credit card balance.
CapAdditionalSecurityInformation | Gets the Boolean value that indicates whether the AdditionalSecurityInformation property can be used.
CapAuthorizeCompletion | Gets the Boolean value that indicates whether the AuthorizeCompletion method is implemented.
CapAuthorizePreSales | Gets the Boolean value that indicates whether the AuthorizePreSales method is implemented.
CapAuthorizeRefund | Gets the Boolean value that indicates whether the AuthorizeRefund method is implemented.
CapAuthorizeVoid | Gets the Boolean value that indicates whether the AuthorizeVoid method is implemented.
CapAuthorizeVoidPreSales | Gets the Boolean value that indicates whether the AuthorizeVoidPreSales method is implemented.
CapCashDeposit | Gets the Boolean value that indicates whether the CashDeposit method is implemented.
CapCenterResultCode | Gets the Boolean value that indicates whether the CenterResultCode method is implemented.
CapCheckCard | Gets the Boolean value that indicates whether the CheckCard method is implemented.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapDailyLog | Gets the daily log ability of the device.
CapInstallments | Gets the Boolean value that indicates whether the "Installments" item is provided.
CapLockTerminal | Gets a Boolen value that indicates whether the device has a security lock and can set it.
CapLogStatus | Gets a Boolen value that indicates whether the device can give information about the status of the log.
CapPaymentDetail | Gets the Boolean value that indicates whether the PaymentDetail property is implemented.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapTaxOthers | Gets the Boolean value that indicates whether the item "TaxOthers" is provided.
CapTrainingMode | Gets the Boolean value that indicates whether the TrainingMode property is implemented.
CapTransactionNumber | Gets the Boolean value that indicates whether the TransactionNumber property is implemented.
CapUnlockTerminal | Gets the Boolean value that indicates whether the security lock can be released.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CardCompanyId | Gets the credit card company ID.
CenterResultCode | Gets the code from the approval agency.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
DailyLog | Gets the result of the AccessDailyLog method.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
LogStatus | Gets the status of the dealing log of the CAT device.
OutputId | Gets the identifier of the most recently started asynchronous output.
PaymentCondition | Gets the payment condition of the most recent successful authorization operation.
PaymentDetail | Gets payment condition details as the result of an authorization operation.
PaymentMedia | Gets or sets the payment media type that the approval method should approve.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
SequenceNumber | Gets a "sequence number" as the result of each method call.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
SettledAmount | Gets the amount of the settlement for an electronic money device.
SlipNumber | Gets a "slip number" as the result of each authorization operation.
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )
TrainingMode | Gets or sets the Boolean value that indicates whether each operation is run in training mode.
TransactionNumber | Gets a transaction number as the result of each authorization operation.
TransactionType | Gets a transaction number as the result of each authorization operation.

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets the Boolean value that indicates whether the credit authorization terminal is an exclusive-use device.

See Also

Reference

Cat Class
Microsoft.PointOfService Namespace


Cat.AccountNumber Property

Cat.AccountNumber Property |
 | See Also

1/18/2008

Gets the credit card number of the settled account.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property AccountNumber As String
public abstract string AccountNumber { get; }
public:
virtual property String^ AccountNumber {
    String^ get () abstract;
}
/** @property */
public abstract String get_AccountNumber ()

public abstract function get AccountNumber () : String

Remarks

AccountNumber is updated by the service object when an authorization operation finishes successfully.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace


Cat.AdditionalSecurityInformation Property

Cat.AdditionalSecurityInformation Property |
 | See Also

1/18/2008

Gets or sets additional security information for an authorization operation.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AdditionalSecurityInformation As String
public abstract string AdditionalSecurityInformation { get; set; }
public:
virtual property String^ AdditionalSecurityInformation {
    String^ get () abstract;
    void set (String^ value) abstract;
}
/** @property */
public abstract String get_AdditionalSecurityInformation ()

/** @property */
public abstract void set_AdditionalSecurityInformation (String value)

public abstract function get AdditionalSecurityInformation () : String

public abstract function set AdditionalSecurityInformation (value : String)

Remarks

An application can send data to the CAT device by setting AdditionalSecurityInformation before issuing an authorization method. Also, data obtained from the CAT device and not stored in any other property as the result of an authorization operation (for example, the account code for a loyalty program) can be provided to an application by storing it in this property. Because the data that is stored here is device-specific, it should not be used for any development that requires portability.

This property should then be updated by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
CapAdditionalSecurityInformation
BinaryConversion Enumeration


Cat.ApprovalCode Property

Cat.ApprovalCode Property |
 | See Also

1/18/2008

Gets the credit approval code.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ApprovalCode As String
public abstract string ApprovalCode { get; }
public:
virtual property String^ ApprovalCode {
    String^ get () abstract;
}
/** @property */
public abstract String get_ApprovalCode ()

public abstract function get ApprovalCode () : String

Remarks

ApprovalCode is updated by the service object when an authorization operation finishes successfully.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace


Cat.AsyncMode Property

Cat.AsyncMode Property |
 | See Also

1/18/2008

Gets or sets the Boolean value that indicates whether the authorization runs asynchronously.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AsyncMode As Boolean
public abstract bool AsyncMode { get; set; }
public:
virtual property bool AsyncMode {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_AsyncMode ()

/** @property */
public abstract void set_AsyncMode (boolean value)

public abstract function get AsyncMode () : boolean

public abstract function set AsyncMode (value : boolean)

Remarks

If true, the authorization methods run asynchronously.

If false, the authorization methods run synchronously.

AsyncMode is set and kept current by service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace


Cat.Balance Property

Cat.Balance Property |
 | See Also

1/18/2008

Gets a credit card balance.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property Balance As Decimal
public virtual decimal Balance { get; }
public:
virtual property Decimal Balance {
    Decimal get ();
}
/** @property */
public Decimal get_Balance ()

public function get Balance () : decimal

Remarks

When the CAT service object receives the settlement results from an electronic money device, it stores the results in the Balance Property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace


Cat.CapAdditionalSecurityInformation Property

Cat.CapAdditionalSecurityInformation Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the AdditionalSecurityInformation property can be used.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapAdditionalSecurityInformation As Boolean
public abstract bool CapAdditionalSecurityInformation { get; }
public:
virtual property bool CapAdditionalSecurityInformation {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapAdditionalSecurityInformation ()

public abstract function get CapAdditionalSecurityInformation () : boolean

Remarks

If true, the AdditionalSecurityInformation property can be used; otherwise, false.

CapAdditionalSecurityInformation is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
Cat.AdditionalSecurityInformation Property


Cat.CapAuthorizeCompletion Property

Cat.CapAuthorizeCompletion Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the AuthorizeCompletion method is implemented.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapAuthorizeCompletion As Boolean
public abstract bool CapAuthorizeCompletion { get; }
public:
virtual property bool CapAuthorizeCompletion {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapAuthorizeCompletion ()

public abstract function get CapAuthorizeCompletion () : boolean

Remarks

If true, the AuthorizeCompletion method is implemented; otherwise, false.

CapAuthorizeCompletion is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
Cat.AuthorizeCompletion Method


Cat.CapAuthorizePreSales Property

Cat.CapAuthorizePreSales Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the AuthorizePreSales method is implemented.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapAuthorizePreSales As Boolean
public abstract bool CapAuthorizePreSales { get; }
public:
virtual property bool CapAuthorizePreSales {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapAuthorizePreSales ()

public abstract function get CapAuthorizePreSales () : boolean

Remarks

If true, the AuthorizePreSales method is implemented; otherwise, false.

CapAuthorizePreSales is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
Cat.AuthorizePreSales Method


Cat.CapAuthorizeRefund Property

Cat.CapAuthorizeRefund Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the AuthorizeRefund method is implemented.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapAuthorizeRefund As Boolean
public abstract bool CapAuthorizeRefund { get; }
public:
virtual property bool CapAuthorizeRefund {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapAuthorizeRefund ()

public abstract function get CapAuthorizeRefund () : boolean

Remarks

If true, the AuthorizeRefund method is implemented; otherwise, false.

CapAuthorizeRefund is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
Cat.AuthorizeRefund Method


Cat.CapAuthorizeVoid Property

Cat.CapAuthorizeVoid Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the AuthorizeVoid method is implemented.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapAuthorizeVoid As Boolean
public abstract bool CapAuthorizeVoid { get; }
public:
virtual property bool CapAuthorizeVoid {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapAuthorizeVoid ()

public abstract function get CapAuthorizeVoid () : boolean

Remarks

If true, the AuthorizeVoid method is implemented; otherwise, false.

CapAuthorizeVoid is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
Cat.AuthorizeVoid Method


Cat.CapAuthorizeVoidPreSales Property

Cat.CapAuthorizeVoidPreSales Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the AuthorizeVoidPreSales method is implemented.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapAuthorizeVoidPreSales As Boolean
public abstract bool CapAuthorizeVoidPreSales { get; }
public:
virtual property bool CapAuthorizeVoidPreSales {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapAuthorizeVoidPreSales ()

public abstract function get CapAuthorizeVoidPreSales () : boolean

Remarks

If true, the AuthorizeVoidPreSales method is implemented; otherwise, false.

CapAuthorizeVoidPreSale is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
Cat.AuthorizeVoidPreSales Method


Cat.CapCashDeposit Property

Cat.CapCashDeposit Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the CashDeposit method is implemented.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CapCashDeposit As Boolean
public virtual bool CapCashDeposit { get; }
public:
virtual property bool CapCashDeposit {
    bool get ();
}
/** @property */
public boolean get_CapCashDeposit ()

public function get CapCashDeposit () : boolean

Remarks

If true, the CashDeposit method is implemented; otherwise, false.

CapCashDeposit is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
Cat.AuthorizeVoidPreSales Method


Cat.CapCenterResultCode Property

Cat.CapCenterResultCode Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the CenterResultCode method is implemented.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapCenterResultCode As Boolean
public abstract bool CapCenterResultCode { get; }
public:
virtual property bool CapCenterResultCode {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapCenterResultCode ()

public abstract function get CapCenterResultCode () : boolean

Remarks

If true, the CenterResultCode property is implemented; otherwise, false.

CapCenterResultCode is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
CenterResultCode


Cat.CapCheckCard Property

Cat.CapCheckCard Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the CheckCard method is implemented.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapCheckCard As Boolean
public abstract bool CapCheckCard { get; }
public:
virtual property bool CapCheckCard {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapCheckCard ()

public abstract function get CapCheckCard () : boolean

Remarks

If true, the CheckCard method is implemented; otherwise, false.

CapCheckCard is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
Cat.CheckCard Method


Cat.CapDailyLog Property

Cat.CapDailyLog Property |
 | See Also

1/18/2008

Gets the daily log ability of the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapDailyLog As CatLogs
public abstract CatLogs CapDailyLog { get; }
public:
virtual property CatLogs CapDailyLog {
    CatLogs get () abstract;
}
/** @property */
public abstract CatLogs get_CapDailyLog ()

public abstract function get CapDailyLog () : CatLogs

Remarks

CapDailyLog is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
DailyLog
Cat.AccessDailyLog Method


Cat.CapInstallments Property

Cat.CapInstallments Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the "Installments" item is provided.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapInstallments As Boolean
public abstract bool CapInstallments { get; }
public:
virtual property bool CapInstallments {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapInstallments ()

public abstract function get CapInstallments () : boolean

Remarks

If true, the item "Installments," which is stored in the DailyLog property as the result of AccessDailyLog, is provided; otherwise, false.

CapInstallments is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
DailyLog


Cat.CapLockTerminal Property

Cat.CapLockTerminal Property |
 | See Also

1/18/2008

Gets a Boolen value that indicates whether the device has a security lock and can set it.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CapLockTerminal As Boolean
public virtual bool CapLockTerminal { get; }
public:
virtual property bool CapLockTerminal {
    bool get ();
}
/** @property */
public boolean get_CapLockTerminal ()

public function get CapLockTerminal () : boolean

Remarks

If true, the device has a security lock and the device can set the lock by using the LockTerminal method; otherwise false.

CapLockTerminal is set by the service object.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
Cat.LockTerminal Method


Cat.CapLogStatus Property

Cat.CapLogStatus Property |
 | See Also

1/18/2008

Gets a Boolen value that indicates whether the device can give information about the status of the log.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CapLogStatus As Boolean
public virtual bool CapLogStatus { get; }
public:
virtual property bool CapLogStatus {
    bool get ();
}
/** @property */
public boolean get_CapLogStatus ()

public function get CapLogStatus () : boolean

Remarks

If true, the device can notify the condition of the log by the LogStatus property; otherwise false.

CapLogStatus is set by the service object.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
LogStatus


Cat.CapPaymentDetail Property

Cat.CapPaymentDetail Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the PaymentDetail property is implemented.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapPaymentDetail As Boolean
public abstract bool CapPaymentDetail { get; }
public:
virtual property bool CapPaymentDetail {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapPaymentDetail ()

public abstract function get CapPaymentDetail () : boolean

Remarks

If true, the PaymentDetail property is implemented; otherwise, false.

CapPaymentDetail is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
PaymentDetail


Cat.CapTaxOthers Property

Cat.CapTaxOthers Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the item "TaxOthers" is provided.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapTaxOthers As Boolean
public abstract bool CapTaxOthers { get; }
public:
virtual property bool CapTaxOthers {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapTaxOthers ()

public abstract function get CapTaxOthers () : boolean

Remarks

If true, the item "TaxOthers," which is stored in the DailyLog property as the result of AccessDailyLog, is provided; otherwise, false.

Note:
CapTaxOthers is not related to the taxOthers argument used with authorization methods.

CapTaxOthers is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
DailyLog


Cat.CapTrainingMode Property

Cat.CapTrainingMode Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the TrainingMode property is implemented.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapTrainingMode As Boolean
public abstract bool CapTrainingMode { get; }
public:
virtual property bool CapTrainingMode {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapTrainingMode ()

public abstract function get CapTrainingMode () : boolean

Remarks

If true, the TrainingMode property is implemented; otherwise, false.

CapTrainingMode is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
TrainingMode


Cat.CapTransactionNumber Property

Cat.CapTransactionNumber Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the TransactionNumber property is implemented.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapTransactionNumber As Boolean
public abstract bool CapTransactionNumber { get; }
public:
virtual property bool CapTransactionNumber {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapTransactionNumber ()

public abstract function get CapTransactionNumber () : boolean

Remarks

If true, the TransactionNumber property is implemented; otherwise, false.

CapTransactionNumber is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
TransactionNumber


Cat.CapUnlockTerminal Property

Cat.CapUnlockTerminal Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the security lock can be released.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CapUnlockTerminal As Boolean
public virtual bool CapUnlockTerminal { get; }
public:
virtual property bool CapUnlockTerminal {
    bool get ();
}
/** @property */
public boolean get_CapUnlockTerminal ()

public function get CapUnlockTerminal () : boolean

Remarks

If true, the device has a security lock and the device can release the lock by using the UnlockTerminal method, otherwise false.

CapUnlockTerminal is set by the service object.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
Cat.UnlockTerminal Method


Cat.CardCompanyId Property

Cat.CardCompanyId Property |
 | See Also

1/18/2008

Gets the credit card company ID.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CardCompanyId As String
public abstract string CardCompanyId { get; }
public:
virtual property String^ CardCompanyId {
    String^ get () abstract;
}
/** @property */
public abstract String get_CardCompanyId ()

public abstract function get CardCompanyId () : String

Remarks

CardCompanyId is updated when an authorization operation finishes successfully. The length of the ID string varies depending on the CAT device.

CardCompanyId is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace


Cat.CenterResultCode Property

Cat.CenterResultCode Property |
 | See Also

1/18/2008

Gets the code from the approval agency.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CenterResultCode As String
public abstract string CenterResultCode { get; }
public:
virtual property String^ CenterResultCode {
    String^ get () abstract;
}
/** @property */
public abstract String get_CenterResultCode ()

public abstract function get CenterResultCode () : String

Remarks

Check the approval agency for the actual codes to be stored.

CenterResultCode is updated by the service object when an authorization operation finishes successfully.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace


Cat.DailyLog Property

Cat.DailyLog Property |
 | See Also

1/18/2008

Gets the result of the AccessDailyLog method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DailyLog As String
public abstract string DailyLog { get; }
public:
virtual property String^ DailyLog {
    String^ get () abstract;
}
/** @property */
public abstract String get_DailyLog ()

public abstract function get DailyLog () : String

Remarks

The data is delimited by CR (13 Decimal) + LF (10 Decimal) for each transaction, and is stored in ASCII code. The detailed data of each transaction is comma-separated [that is, delimited by "," (44 Decimal)].

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
Cat.CapDailyLog Property
Cat.AccessDailyLog Method


Cat.IsExclusiveUseDevice Property

Cat.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the credit authorization terminal is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Property Value

A value of true indicates the fiscal printer is an exclusive-use device. Otherwise, the value is false.

Remarks

An exclusive-use device has the following properties:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before accessing some properties or calling methods that update the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace


Cat.LogStatus Property

Cat.LogStatus Property |
 | See Also

1/18/2008

Gets the status of the dealing log of the CAT device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property LogStatus As DealingLogStatus
public virtual DealingLogStatus LogStatus { get; }
public:
virtual property DealingLogStatus LogStatus {
    DealingLogStatus get ();
}
/** @property */
public DealingLogStatus get_LogStatus ()

public function get LogStatus () : DealingLogStatus

Remarks

If the dealing log of the CAT device becomes full, settlement processing may be unable to operate.

LogStatus is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace


Cat.OutputId Property

Cat.OutputId Property |
 | See Also

1/18/2008

Gets the identifier of the most recently started asynchronous output.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property OutputId As Integer
public abstract int OutputId { get; }
public:
virtual property int OutputId {
    int get () abstract;
}
/** @property */
public abstract int get_OutputId ()

public abstract function get OutputId () : int

Remarks

When a method starts successfully an asynchronous output, the device assigns an identifier to the request. When the output is completed, an OutputCompleteEvent is queued with this output ID as a parameter.

The output ID numbers are assigned by POS for .NET and are guaranteed to be unique among the set of outstanding asynchronous outputs. No other facts about the ID should be assumed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
OutputCompleteEvent


Cat.PaymentCondition Property

Cat.PaymentCondition Property |
 | See Also

1/18/2008

Gets the payment condition of the most recent successful authorization operation.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property PaymentCondition As PaymentCondition
public abstract PaymentCondition PaymentCondition { get; }
public:
virtual property PaymentCondition PaymentCondition {
    PaymentCondition get () abstract;
}
/** @property */
public abstract PaymentCondition get_PaymentCondition ()

public abstract function get PaymentCondition () : PaymentCondition

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
PaymentDetail


Cat.PaymentDetail Property

Cat.PaymentDetail Property |
 | See Also

1/18/2008

Gets payment condition details as the result of an authorization operation.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property PaymentDetail As String
public abstract string PaymentDetail { get; }
public:
virtual property String^ PaymentDetail {
    String^ get () abstract;
}
/** @property */
public abstract String get_PaymentDetail ()

public abstract function get PaymentDetail () : String

Remarks

Payment details vary depending on the value of PaymentCondition. The data is stored as comma-separated ASCII code. Null means that no data is stored and represents an empty string.

PaymentCondition | PaymentDetail
Lump | null
Bonus1 | null
Bonus2 | Number of bonus payments
Bonus3 | 1st bonus month
Bonus4 | Number of bonus payments, 1st bonus month, 2nd bonus month, 3rd bonus month, 4th bonus month, 5th bonus month, 6th bonus month
Bonus5 | Number of bonus payments, 1st bonus month, 1st bonus amount, 2nd bonus month, 2nd bonus amount, 3rd bonus month, 3rd bonus amount, 4th bonus month, 4th bonus amount, 5th bonus month, 5th bonus amount, 6th bonus month, 6th bonus amount
Installment1 | 1st billing month, Number of payments
Installment2 | 1st billing month, Number of payments, 1st amount, 2nd amount, 3rd amount, 4th amount, 5th amount, 6th amount
Installment3 | 1st billing month, Number of payments, 1st amount
BonusCombination1 | 1st billing month, Number of payments
BonusCombination2 | 1st billing month, Number of payments, bonus amount
BonusCombination3 | 1st billing month, Number of payments, number of bonus payments, 1st bonus month, 2nd bonus month, 3rd bonus month, 4th bonus month, 5th bonus month, 6th bonus month
BonusCombination4 | 1st billing month, Number of payments, number of bonus payments, 1st bonus month, 1st bonus amount, 2nd bonus month, 2nd bonus amount, 3rd bonus month, 3rd bonus amount, 4th bonus month, 4th bonus amount, 5th bonus month, 5th bonus amount, 6th bonus month, 6th bonus amount
Revolving | null
Debit | null

The payment types and names vary depending on the CAT device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
Cat.CapPaymentDetail Property


Cat.PaymentMedia Property

Cat.PaymentMedia Property |
 | See Also

1/18/2008

Gets or sets the payment media type that the approval method should approve.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property PaymentMedia As PaymentMedia
public abstract PaymentMedia PaymentMedia { get; set; }
public:
virtual property PaymentMedia PaymentMedia {
    PaymentMedia get () abstract;
    void set (PaymentMedia value) abstract;
}
/** @property */
public abstract PaymentMedia get_PaymentMedia ()

/** @property */
public abstract void set_PaymentMedia (PaymentMedia value)

public abstract function get PaymentMedia () : PaymentMedia

public abstract function set PaymentMedia (value : PaymentMedia)

Remarks

The application sets PaymentMedia before issuing an approval method call. Unspecified means that payment media is determined by the CAT device, not by the POS application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace


Cat.SequenceNumber Property

Cat.SequenceNumber Property |
 | See Also

1/18/2008

Gets a "sequence number" as the result of each method call.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property SequenceNumber As Integer
public abstract int SequenceNumber { get; }
public:
virtual property int SequenceNumber {
    int get () abstract;
}
/** @property */
public abstract int get_SequenceNumber ()

public abstract function get SequenceNumber () : int

Remarks

This number has to be checked by an application to see whether it matches the sequenceNumber argument of the originating method.

If the "sequence number" returned from the CAT device is not numeric, the CAT service object sets SequenceNumber to zero.

SequenceNumber is updated by the service object when an authorization operation finishes successfully.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace


Cat.SettledAmount Property

Cat.SettledAmount Property |
 | See Also

1/18/2008

Gets the amount of the settlement for an electronic money device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property SettledAmount As Decimal
public virtual decimal SettledAmount { get; }
public:
virtual property Decimal SettledAmount {
    Decimal get ();
}
/** @property */
public Decimal get_SettledAmount ()

public function get SettledAmount () : decimal

Remarks

For an electronic money device, this property holds the real amount of the settlement.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace


Cat.SlipNumber Property

Cat.SlipNumber Property |
 | See Also

1/18/2008

Gets a "slip number" as the result of each authorization operation.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property SlipNumber As String
public abstract string SlipNumber { get; }
public:
virtual property String^ SlipNumber {
    String^ get () abstract;
}
/** @property */
public abstract String get_SlipNumber ()

public abstract function get SlipNumber () : String

Remarks

The SlipNumber property is updated by the service object when an authorization operation finishes successfully.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace


Cat.TrainingMode Property

Cat.TrainingMode Property |
 | See Also

1/18/2008

Gets or sets the Boolean value that indicates whether each operation is run in training mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property TrainingMode As Boolean
public abstract bool TrainingMode { get; set; }
public:
virtual property bool TrainingMode {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_TrainingMode ()

/** @property */
public abstract void set_TrainingMode (boolean value)

public abstract function get TrainingMode () : boolean

public abstract function set TrainingMode (value : boolean)

Remarks

If true, each operation is run in training mode; otherwise each operation is run in normal mode.

An application must set the TrainingMode value explicitly to false to exit from training mode, because the value is not automatically set to false after the completion of an operation.

When it is accessed, the TrainingMode property may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Illegal | CapTrainingMode is false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
Cat.CapTrainingMode Property


Cat.TransactionNumber Property

Cat.TransactionNumber Property |
 | See Also

1/18/2008

Gets a transaction number as the result of each authorization operation.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property TransactionNumber As String
public abstract string TransactionNumber { get; }
public:
virtual property String^ TransactionNumber {
    String^ get () abstract;
}
/** @property */
public abstract String get_TransactionNumber ()

public abstract function get TransactionNumber () : String

Remarks

TransactionNumber is set and updated by the service object when an authorization operation finishes successfully.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace


Cat.TransactionType Property

Cat.TransactionType Property |
 | See Also

1/18/2008

Gets a transaction number as the result of each authorization operation.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property TransactionType As CreditTransactionType
public abstract CreditTransactionType TransactionType { get; }
public:
virtual property CreditTransactionType TransactionType {
    CreditTransactionType get () abstract;
}
/** @property */
public abstract CreditTransactionType get_TransactionType ()

public abstract function get TransactionType () : CreditTransactionType

Remarks

TransactionType is updated by the service object when an authorization operation finishes successfully.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace


Cat Events

Cat Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
ErrorEvent | Notifies the application that a CAT error has been detected and suitable response by the application is necessary to process the error condition.
OutputCompleteEvent | Notifies the application that the queued output request associated with the OutputId property has completed successfully.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

Cat Class
Microsoft.PointOfService Namespace


Cat.ErrorEvent Event

Cat.ErrorEvent Event |
 | See Also

1/18/2008

Notifies the application that a CAT error has been detected and suitable response by the application is necessary to process the error condition.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event ErrorEvent As DeviceErrorEventHandler
public abstract event DeviceErrorEventHandler ErrorEvent
public:
virtual event DeviceErrorEventHandler^ ErrorEvent {
    void add (DeviceErrorEventHandler^ value) abstract;
    void remove (DeviceErrorEventHandler^ value) abstract;
}
/** @event */
public abstract void add_ErrorEvent (DeviceErrorEventHandler value)

/** @event */
public abstract void remove_ErrorEvent (DeviceErrorEventHandler value)

Remarks

Raised by the service object when an error is detected while processing an asynchronous Authorize group method or the AccessDailyLog method. The state of the control changes into the error state.

ErrorLocus is set to Output.

If the ErrorCode is Extended, ErrorCodeExtended is set to one of the following values.

Value | Description
ExtendedErrorCenterError | An error was returned from the approval agency. The detailed error code is defined in CenterResultCode.
ExtendedErrorCommandError | The command sent to CAT is wrong. This error is never returned if the CAT service object is working correctly.
ExtendedErrorReset | CAT was stopped during processing by the CAT reset key or stop key.
ExtendedErrorCommunicationError | A communication error has occurred between the approval agency and CAT.
ExtendedErrorDailyLogOverflow | The daily log was too big to be stored. Updates to the daily log have been stopped and the value of DailyLog property is uncertain.

ErrorResponse is preset to the default value of Retry. An application can set one of the following values for ErrorResponse:

Value | Description
Retry | Retries the asynchronous processing. The error state is exited.
Clear | Clears the asynchronous processing. The error state is exited.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
Cat.AccessDailyLog Method
DeviceErrorEventArgs
ErrorResponse


Cat.OutputCompleteEvent Event

Cat.OutputCompleteEvent Event |
 | See Also

1/18/2008

Notifies the application that the queued output request associated with the OutputId property has completed successfully.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event OutputCompleteEvent As OutputCompleteEventHandler
public abstract event OutputCompleteEventHandler OutputCompleteEvent
public:
virtual event OutputCompleteEventHandler^ OutputCompleteEvent {
    void add (OutputCompleteEventHandler^ value) abstract;
    void remove (OutputCompleteEventHandler^ value) abstract;
}
/** @event */
public abstract void add_OutputCompleteEvent (OutputCompleteEventHandler value)

/** @event */
public abstract void remove_OutputCompleteEvent (OutputCompleteEventHandler value)

Remarks

Raised by the service object, OutputCompleteEvent is queued after the request's data has been both sent and POS for .NET has confirmation that it was processed by the device successfully.

See Also

Reference

Cat Class
Cat Members
Microsoft.PointOfService Namespace
OutputCompleteEventArgs


CatLogs Enumeration

CatLogs Enumeration |
 | See Also

1/18/2008

Enumerates the available log functions for a credit authorization terminal (CAT) device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration CatLogs
[FlagsAttribute]
public enum CatLogs
[FlagsAttribute]
public enum class CatLogs
/** @attribute FlagsAttribute() */
public enum CatLogs
FlagsAttribute
public enum CatLogs

Members

Member name | Description
None | The CAT device does not have the daily log functions.
Reporting | The CAT device has only an intermediate total function that reads the daily log, but does not erase the log.
ReportingAndSettlement | The CAT device has the intermediate total function and the final total and erases daily log functions.
Settlement | The CAT device has only the final total and erases daily log functions.

Remarks

Used by the CapDailyLog property and the AccessDailyLog method. Replaces the CAT_DL family of UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
Cat.AccessDailyLog Method


CharacterSetCapability Enumeration

CharacterSetCapability Enumeration |
 | See Also

1/18/2008

Enumerates the possible default character sets for a printer, line display, or point card reader/writer device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration CharacterSetCapability
public enum CharacterSetCapability
public enum class CharacterSetCapability
public enum CharacterSetCapability
public enum CharacterSetCapability

Members

Member name | Description
Alpha | The default character set supports uppercase alphabetic plus numeric data, space, minus, and period.
Ansi | The default character set supports ANSI characters.
Ascii | The default character set supports all ASCII characters between 20-hex and 7F-hex.
Kana | The default character set supports partial code page 932. This includes ASCII characters 20-hex through 7F-hex and the Japanese kana characters A1-hex through DF-hex, but excluding the Japanese kanji characters.
Kanji | The default character set supports code page 932, including the Shift-JIS kanji characters, Levels 1 and 2.
Numeric | The default character set suports numeric data, plus space, minus, and period. (Line Display devices only.)
Unicode | The default character set supports UNICODE.
Windows | The default character set supports ANSI characters.

Remarks

Used by the CapCharacterSet properties of the PosPrinter, LineDisplay, and PointCardRW classes. The members of this enumeration replace the PTR_CCS_, DISP_CCS_, and PCRW_CCS_ families of UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace


CheckColors Enumeration

CheckColors Enumeration |
 | See Also

1/18/2008

Enumerates the possible image format color ranges for a check scanner.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration CheckColors
[FlagsAttribute]
public enum CheckColors
[FlagsAttribute]
public enum class CheckColors
/** @attribute FlagsAttribute() */
public enum CheckColors
FlagsAttribute
public enum CheckColors

Members

Member name | Description
Color16 | 16 colors
Color256 | 256 colors
Full | Full colors
GrayScale | Grayscale
Mono | One color

Remarks

Used by the CapColor and Color properties. The members of this enumeration replace the CHK_CL_MONO, CHK_CL_GRAYSCALE, CHK_CL_16, CHK_CL_256, and CHK_CL_FULL UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace


CheckCountryCode Enumeration

CheckCountryCode Enumeration |
 | See Also

1/18/2008

Enumerates the possible countries/regions in which the check originated.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration CheckCountryCode
public enum CheckCountryCode
public enum class CheckCountryCode
public enum CheckCountryCode
public enum CheckCountryCode

Members

Member name | Description
Canada | Canada
Mexico | Mexico
Unknown | Unknown
Usa | United States

Remarks

Used by the CountryCode property. The members of this enumeration replace the MICR_CC_USA, MICR_CC_CANADA, MICR_CC_MEXICO, and MICR_CC_UNKNOWN UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
CountryCode


CheckImageClear Enumeration

CheckImageClear Enumeration |
 | See Also

1/18/2008

Enumerates the possible values for how an image file is to be located.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration CheckImageClear
public enum CheckImageClear
public enum class CheckImageClear
public enum CheckImageClear
public enum CheckImageClear

Members

Member name | Description
All | Clears all images in the device.
FileId | Locates the file to be cleared using the FileID property value.
FileIndex | Locates the file to be cleared using the FileIndex property value.
ImageTagData | Locates the file to be cleared using the ImageTagData property value.

Remarks

Used in conjunction with the by parameter in the ClearImage method. The members of this enumeration replace the CHK_CLR_ALL, CHK_CLR_BY_FILEID, CHK_CLR_BY_FILEINDEX, and CHK_CLR_BY_IMAGETAGDATA UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
ClearImage


CheckImageFormats Enumeration

CheckImageFormats Enumeration |
 | See Also

1/18/2008

Enumerates the possible formats of a data image file.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration CheckImageFormats
[FlagsAttribute]
public enum CheckImageFormats
[FlagsAttribute]
public enum class CheckImageFormats
/** @attribute FlagsAttribute() */
public enum CheckImageFormats
FlagsAttribute
public enum CheckImageFormats

Members

Member name | Description
Bmp | BMP format
Gif | GIF format
Jpeg | JPEG format
Native | Hardware native format
Tiff | TIFF format

Remarks

Used by the ImageFormat and CapImageFormat property. The members of this enumeration replace the CHK_IF_ and CHK_CIF_ families of UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
ImageFormat
CapImageFormat


CheckImageLocate Enumeration

CheckImageLocate Enumeration |
 | See Also

1/18/2008

Enumerates the possible values for how an image file is to be retrieved from memory.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration CheckImageLocate
public enum CheckImageLocate
public enum class CheckImageLocate
public enum CheckImageLocate
public enum CheckImageLocate

Members

Member name | Description
FileId | Locates the file to be cleared by using the FileID property value.
FileIndex | Locates the file to be cleared by using the FileIndex property value.
ImageTagData | Locates the file to be cleared by using the ImageTagData property value.

Remarks

Used in conjunction with the by parameter in the RetrieveMemory method. The members of this enumeration replace the CHK_LOCATE_BY_FILEID, CHK_LOCATE_BY_FILEINDEX, and CHK_LOCATE_BY_IMAGETAGDATA UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
RetrieveMemory


CheckScanner Class

CheckScanner Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a UPOS Check Scanner device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class CheckScanner
    Inherits PosCommon
public abstract class CheckScanner : PosCommon
public ref class CheckScanner abstract : public PosCommon
public abstract class CheckScanner extends PosCommon
public abstract class CheckScanner extends PosCommon

Remarks

The main purpose of a Check Scanner device is to capture the image of a personal or business check for electronic check conversion. However, other documents (vouchers, signature receipts, and more) may be scanned if they fall within the capture size parameters of the check scanner.

The CheckScanner interface has the following minimal set of capabilities:

  • Reads image data from a Check Scanner device.

  • Has programmatic control of check insertion, reading, and removal. For some Check Scanner devices, this will require no processing in the application because the device may automate many of these functions.

The CheckScanner interface has the following additional capabilities:

  • The Check Scanner device may store successive check images in its hardware memory.

  • Cropping of areas of interest within the check image may be supported by the Check Scanner device to help reduce the memory needed to transmit or store the check image data.

  • The RetrieveImage method’s data is deposited in the ImageData property in binary form.

  • The Check Scanner device can allow for retrieval of images that are stored in its hardware memory.

  • The Check Scanner device may support image tag data information to identify the check image.

  • The application reads the contents of the ImageData property when it wants to additionally process the check image.

  • The Check Scanner device may be physically attached to or incorporated into a check validation print device and a MICR device. If this is the case, as soon as a check is inserted through check scanner methods, the check can still be used by the printer and MICR control before check removal.

The basic programming model for the CheckScanner interface is as follows:

  • The Check Scanner device is opened, claimed, and enabled.

  • When the BeginInsertion method is called, the check scanner is ready to read the check within the specified time as indicated by the time-out value. If the check is not inserted before the time-out value expires, an exception is thrown.

  • If there is a time-out, the Check Scanner device remains in a state that enables a check to be inserted. The application may provide an operator prompt that requests that a check be inserted. Following this prompt, the application would then reissue the BeginInsertion method and wait for the check to be inserted.

  • As soon as a check is inserted, the BeginInsertion method returns and the application calls the EndInsertion method. This results in the Check Scanner device exiting the check insertion mode and causes the check image to be captured.

  • Following the EndInsertion method, the scan image data is stored in a working buffer memory area and the service object generates a StatusUpdateEvent event to indicate that a successful scan image process has occurred. No DataEvent event is queued because data has not been transferred to the ImageData property at this point.

  • The application must use the RetrieveImage method to retrieve the current scan image data. However, if the check image was not successfully captured by the device, the service object queues an ErrorEvent event to indicate the capture was not successful.

  • If the application has set the AutoDisable property to true, the device is automatically disabled when the image is successfully captured.

  • A queued DataEvent event can be delivered to the application when it has set the DataEventEnabled property to true and other event delivery requirements are met. Just before delivering this event, the service object copies data into specific properties, and disables additional data events by setting the DataEventEnabled property to false. This causes later input data to be queued by the service object while the application processes the current input and associated properties. When the application has finished the current input and is ready for more data, it enables events by setting DataEventEnabled to true.

  • If the CapAutoSize property is set to true, when the DataEvent event is delivered, the height and width of the captured image are automatically stored in the corresponding DocumentHeight and DocumentWidth properties. If the CapAutoSize property is false, the application must set the DocumentHeight and the DocumentWidth property values before the BeginInsertion method being invoked.

  • If the CapDefineCropArea property is set to true. Then the application can use the DefineCropArea method to define crop areas in the captured image.

  • If the application has to retrieve the image or a cropped part of the image, it calls the RetrieveImage method. The image data is sent from the device to the service object and stored in the ImageData property. When the corresponding DataEvent event is delivered, the current image (or cropped part of the current image) may be accessed by the application reading the image file that is contained in the ImageData property.

  • If the CapStoreImageFiles property is set to true, the current image or cropped image can be stored in the memory by using the StoreImage method.

  • Any stored image may be retrieved by using the RetrieveMemory method. The stored image may be identified by using the by parameter and requesting that the image be located by the value of the FileId, FileIndex, or ImageTagData properties.

  • ErrorEvent events are queued if the service object encounters errors while you read the check, and are delivered to the application when the DataEventEnabled property is set to true and other event delivery requirements are met.

  • All input data queued by the service object may be deleted by the application calling the ClearInput method.

  • After you process the EndInsertionDataEvent event, the application can query the CapMicrDevice property to determine whether the device supports Magnetic Ink Character Recognition (MICR). If the CapMicrDevice property is set to true, a MICR read function may be performed in a “single pass” or “multiple pass” cycle before the check being removed from the device. If the CapConcurrentMicr property is set to true, the device can support a “single pass” MICR read during an image scan. If CapConcurrentMicr and ConcurrentMicr are both set to true, the MICR data would be read and calling the MICR's BeginInsertion and EndInsertion methods would not be needed to reposition the check for MICR reading.

  • Additionally, after it processes a DataEvent event, the application should query the CapValidationDevice property to determine whether validation printing can be performed on the check before check removal. If this property is true, the application may call the POS Printer Interface’s BeginInsertion and EndInsertion methods. This positions the check for validation printing. The Printer's validation printing methods can then be used to perform validation printing.

  • If the CapImageTagData property is set to true, an identifying name—for example, the transaction number, date and time, or some other naming element—could be used to determine the image data. The identifying name is set in the ImageTagData property.

  • When the check is no longer needed in the device, the application must call the BeginRemoval method of the check scanner, the MICR (if CapMicrDevice is true), or the POS printer (if CapValidationDevice is true), also specifying a time-out value. This method will throw an exception if the check is not removed within the time-out period. In this case, the application can perform any additional prompting before calling the method again. As soon as the check is removed, the application should call the same device’s EndRemoval method to take the device out of removal mode.

  • To accommodate many different check scanning devices, the application should follow this sequence of method calls even though the device may not physically require one or more of the methods. An example may be a check scanner that is “auto armed” and can detect the presence of a check and automatically starting a check scan and MICR read cycle. In this case, the BeginInsertion, EndInsertion, BeginRemoval, and EndRemoval method calls may actually do no more than return from the service object.

  • The model assumes that the device has a work area that can be used in the following ways:

    • When a document is scanned, its image will be loaded as raw data into this work area. When the RetrieveImage method is invoked, the data from the work area may be modified by a previously defined crop area, as specified by the cropAreaID parameter, and loaded into the ImageData property. The work area will still contain the original scanned image data. Additional RetrieveImage method calls by by using different crop area criteria can then be employed to load the ImageData property.

    • The work area contains image data either from a recently scanned image or because of a RetrieveMemory method. Before invoking the StoreImage method, the FileIndex property is set to the correct index number (as maintained by the service object) and if you use it, the FileId and ImageTagData properties are set. When the StoreImage method is invoked, the data from the work area may be modified by a previously defined crop area, as specified by the cropAreaID parameter, and stored in the device memory. The work area will still contain the original scanned image data. Additional StoreImage method calls by using different crop area criteria can then be employed to store the image data in the device’s memory. The RemainingImagesEstimate property is adjusted to reflect the approximate number of additional images that may be stored in the device memory, based on the file size history of stored images.

    • When the RetrieveMemory method is invoked, the work area is loaded with an image data file that was stored in the device memory. The FileIndex, FileId, or ImageTagData properties may be used to locate the stored image. The ImageData property is also loaded with the retrieved image data.

    • To accommodate the various storage and retrieval architectures that are used for the Check Scanner device class, the model has been designed to allow for three different addressing ways to locate stored image data: FileIndex, FileId, and ImageTagData.

  • The FileIndex is an addressing scheme that is automatically provided by the service object to physically store and retrieve the file data. The definition of file data in this case includes any and all the following: image data, tag data information (the data that is appended and included with the image data file), and a file identification (a file name associated with the image data file). The FileIndex is only used by the service object to save and retrieve the scan data and its associated data elements.

  • The FileId is a “file name” that may be provided automatically by the hardware device or the service. It may also be populated by the application before calling a StoreImage method. As soon as it is created, it remains with the ImageData and can be used to locate a specific file for uploading to the POS system and post-processing applications.

  • The ImageTagData is a set of information about the image that has been scanned. Typically it contains information about when the image was captured (date and time, for example), store number, lane number, clerk identification, and more This data is typically appended to the ImageData and remains a part of the combined data file as a record of the origin of the data.

The check scanner is an exclusive-use device, and follows the following constraints:

  • The application must claim the device before you enable it.

  • The application must claim and enable the device before the device begins reading input, or before you call methods that manipulate the device.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.CheckScanner
Microsoft.PointOfService.BasicServiceObjects.CheckScannerBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Members
Microsoft.PointOfService Namespace


CheckScanner Members

CheckScanner Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a UPOS Check Scanner device.

The following tables list the members exposed by the CheckScanner type.

Protected Constructors

Name | Description
CheckScanner | Creates an instance of the CheckScanner class.
Top

Public Fields

Name | Description
AutomaticContrast | Indicates the device can automatically adjust the contrast of the image.
CropAreaBottom | Indicates that the y endpoint value of the scanned image is set to the value of the DocumentHeight property.
CropAreaEntireImage | Indicates the crop area is equal to the scanned image.
CropAreaResetAll | Indicates that the crop area definitions (as specified by the value of the MaxCropAreas property) have their x,y and width/height values reset to 0,0 and DocumentWidth and DocumentHeight, respectively.
CropAreaRight | Indicates that the x endpoint value of a scanned image are set to the value of the DocumentWidth property.
ExtendedErrorCheck | Indicates that a check was detected in the check scanner device.
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorNoCheck | Indicates that no check was detected in the check scanner device.
ExtendedErrorNoRoom | Indicates there is no room for the scanned image to be stored in memory.
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
GetRawImageData | Indicates the image data from the check scanner is in a native format that cannot be converted to a bitmap.
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusScanComplete | Indicates that the check scan is complete.
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
AutoDisable | Gets or sets the Boolean value that indicates whether POS for .NET automatically disables the device when data is received.
CapAutoContrast | Gets the Boolean value that indicates whether the contrast can be adjusted automatically.
CapAutoGenerateFileId | Gets the Boolean value that indicates whether the Check Scanner device can create a file name for the image file automatically.
CapAutoGenerateImageTagData | Gets the Boolean value that indicates whether the Check Scanner device can generate tag data automatically.
CapAutoSize | Gets the Boolean value that indicates whether the size of the scanned document can be set automatically.
CapColor | Gets the Boolean value that indicates whether the Check Scanner device supports image formats other than bitonal.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapConcurrentMicr | Gets the Boolean value that indicates whether the Magnetic Ink Character Recognition (MICR) data can be captured.
CapContrast | Gets the Boolean value that indicates the ability of the device to lighten or darken the scanned image.
CapDefineCropArea | Gets the Boolean value that indicates whether the Check Scanner device supports a feature that allows cropping of areas of interest within the scan image area defined by the DocumentHeight and DocumentWidth properties.
CapImageFormat | Gets the image file formats that this Check Scanner device supports.
CapImageTagData | Gets the Boolean value that indicates whether the Check Scanner device can set tag data.
CapMicrDevice | Gets the Boolean value that indicates whether the Check Scanner device supports a check Magnetic Ink Character Recognition (MICR) read function.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapStoreImageFiles | Gets the Boolean value that indicates whether the Check Scanner device can store check images.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CapValidationDevice | Gets the Boolean value that indicates whether a check has to be removed before validation printing.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Color | Gets or sets the image scan mode for later document scan operations.
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
ConcurrentMicr | Gets or sets the Boolean value that indicates whether the Check Scanner device can conduct a MICR read.
Contrast | Gets or sets the contrast to adjust the darkness of the image.
CropAreaCount | Gets the number of defined crop areas that may be applied to the captured image.
DataCount | Gets the number of data events currently queued by the service object.
DataEventEnabled | Gets or sets the Boolean value that indicates whether the service object can deliver a queued event.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
DocumentHeight | Gets or sets the height of the document scanned or the height of the document to be scanned.
DocumentWidth | Gets or sets the width of the document scanned or the width of the document to be scanned.
FileId | Gets or sets the file name associated with the image data file.
FileIndex | Gets or sets the file location associated with the image data file.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
ImageData | Gets the image data.
ImageFormat | Gets or sets the data format of the image file that the device uses when it captures an image.
ImageMemoryStatus | Gets the current memory availability status if the device can store multiple image files.
ImageTagData | Gets or sets a string that specifies the tag name for the captured image data.
MapMode | Gets or sets the units of measure that are currently valid for the Check Scanner device.
MaxCropAreas | Gets the maximum number of crop areas the device can support.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
Quality | Gets or sets the resolution of the device when a scan image is to occur. The resolution value is defined as dpi (dots per inch).
QualityList | Gets the resolutions that the Check Scanner device can support.
RemainingImagesEstimate | Gets a "best guess" estimate of the remaining number of images that can be stored.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets the Boolean value that indicates whether the Check Scanner is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
BeginInsertion | Starts the document insertion process.
BeginRemoval | Starts the document removal process.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearImage | Clears a specific image or all the images in the device memory.
ClearInput | Clears all device input that has been buffered.
ClearInputProperties | Resets the values of properties altered by DataEvent or ErrorEvent.
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DefineCropArea | Establishes one or more cropping areas that can be applied to a scanned image.
DirectIO | (inherited from PosCommon )
EndInsertion | Ends the document insertion process.
EndRemoval | Ends the document removal or ejection mode.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon)
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveImage | Retrieves the most recently scanned image that resides in the available memory and uses it to populate the ImageData property.
RetrieveMemory | Retrieves an image that was stored in memory and uses it to set the ImageData property.
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
StoreImage | Stores an image or a cropped area of the image in the memory of the device.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DataEvent | Raised to notify the application that a scanned check image is available.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
ErrorEvent | Raised to indicate an error has been detected while trying to read keyboard device input data.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

CheckScanner Class
Microsoft.PointOfService Namespace


CheckScanner Fields

CheckScanner Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
AutomaticContrast | Indicates the device can automatically adjust the contrast of the image.
CropAreaBottom | Indicates that the y endpoint value of the scanned image is set to the value of the DocumentHeight property.
CropAreaEntireImage | Indicates the crop area is equal to the scanned image.
CropAreaResetAll | Indicates that the crop area definitions (as specified by the value of the MaxCropAreas property) have their x,y and width/height values reset to 0,0 and DocumentWidth and DocumentHeight, respectively.
CropAreaRight | Indicates that the x endpoint value of a scanned image are set to the value of the DocumentWidth property.
ExtendedErrorCheck | Indicates that a check was detected in the check scanner device.
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorNoCheck | Indicates that no check was detected in the check scanner device.
ExtendedErrorNoRoom | Indicates there is no room for the scanned image to be stored in memory.
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
GetRawImageData | Indicates the image data from the check scanner is in a native format that cannot be converted to a bitmap.
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusScanComplete | Indicates that the check scan is complete.
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

CheckScanner Class
Microsoft.PointOfService Namespace


CheckScanner.AutomaticContrast Field

CheckScanner.AutomaticContrast Field |
 | See Also

1/18/2008

Indicates the device can automatically adjust the contrast of the image.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const AutomaticContrast As Integer
public const int AutomaticContrast
public:
literal int AutomaticContrast
public static final int AutomaticContrast
public const var AutomaticContrast : int

Remarks

This field indicates whether the device can automatically adjust the contrast of the image.

This field replaces the CHK_AUTOMATIC_CONTRAST UPOS constant.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace


CheckScanner.CropAreaBottom Field

CheckScanner.CropAreaBottom Field |
 | See Also

1/18/2008

Indicates that the y endpoint value of the scanned image is set to the value of the DocumentHeight property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const CropAreaBottom As Integer
public const int CropAreaBottom
public:
literal int CropAreaBottom
public static final int CropAreaBottom
public const var CropAreaBottom : int

Remarks

Used in the DefineCropArea method.

This field replaces the CHK_CROP_AREA_BOTTOM UPOS constant.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
DocumentHeight
DefineCropArea


CheckScanner.CropAreaEntireImage Field

CheckScanner.CropAreaEntireImage Field |
 | See Also

1/18/2008

Indicates the crop area is equal to the scanned image.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const CropAreaEntireImage As Integer
public const int CropAreaEntireImage
public:
literal int CropAreaEntireImage
public static final int CropAreaEntireImage
public const var CropAreaEntireImage : int

Remarks

Used in the DefineCropArea and StoreImage methods.

This field replaces the CHK_CROP_AREA_ENTIRE_IMAGE UPOS constant.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
DefineCropArea
StoreImage


CheckScanner.CropAreaResetAll Field

CheckScanner.CropAreaResetAll Field |
 | See Also

1/18/2008

Indicates that the crop area definitions (as specified by the value of the MaxCropAreas property) have their x,y and width/height values reset to 0,0 and DocumentWidth and DocumentHeight, respectively.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const CropAreaResetAll As Integer
public const int CropAreaResetAll
public:
literal int CropAreaResetAll
public static final int CropAreaResetAll
public const var CropAreaResetAll : int

Remarks

Used in the DefineCropArea method.

This field replaces the CHK_CROP_AREA_RESET_ALL UPOS constant.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
MaxCropAreas
DocumentWidth
DocumentHeight
DefineCropArea


CheckScanner.CropAreaRight Field

CheckScanner.CropAreaRight Field |
 | See Also

1/18/2008

Indicates that the x endpoint value of a scanned image are set to the value of the DocumentWidth property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const CropAreaRight As Integer
public const int CropAreaRight
public:
literal int CropAreaRight
public static final int CropAreaRight
public const var CropAreaRight : int

Remarks

Used in the DefineCropArea method.

This field replaces the CHK_CROP_AREA_RIGHT UPOS constant.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
DefineCropArea
DocumentWidth


CheckScanner.ExtendedErrorCheck Field

CheckScanner.ExtendedErrorCheck Field |
 | See Also

1/18/2008

Indicates that a check was detected in the check scanner device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorCheck As Integer
public const int ExtendedErrorCheck
public:
literal int ExtendedErrorCheck
public static final int ExtendedErrorCheck
public const var ExtendedErrorCheck : int

Remarks

Used in the EndRemoval method.

This field replaces the ECHK_CHECK UPOS constant.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace


CheckScanner.ExtendedErrorNoCheck Field

CheckScanner.ExtendedErrorNoCheck Field |
 | See Also

1/18/2008

Indicates that no check was detected in the check scanner device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorNoCheck As Integer
public const int ExtendedErrorNoCheck
public:
literal int ExtendedErrorNoCheck
public static final int ExtendedErrorNoCheck
public const var ExtendedErrorNoCheck : int

Remarks

Used in the EndInsertion method.

This field replaces the ECHK_NOCHECK UPOS constant.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
EndInsertion


CheckScanner.ExtendedErrorNoRoom Field

CheckScanner.ExtendedErrorNoRoom Field |
 | See Also

1/18/2008

Indicates there is no room for the scanned image to be stored in memory.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorNoRoom As Integer
public const int ExtendedErrorNoRoom
public:
literal int ExtendedErrorNoRoom
public static final int ExtendedErrorNoRoom
public const var ExtendedErrorNoRoom : int

Remarks

Used in the StoreImage method.

This field replaces the ECHK_NOROOM UPOS constant.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
StoreImage


CheckScanner.GetRawImageData Field

CheckScanner.GetRawImageData Field |
 | See Also

1/18/2008

Indicates the image data from the check scanner is in a native format that cannot be converted to a bitmap.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const GetRawImageData As Integer
public const int GetRawImageData
public:
literal int GetRawImageData
public static final int GetRawImageData
public const var GetRawImageData : int

Remarks

Used when the application calls DirectIOEvent, passing the constant. This causes the service object to return a byte array of the raw data.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace


CheckScanner.StatusScanComplete Field

CheckScanner.StatusScanComplete Field |
 | See Also

1/18/2008

Indicates that the check scan is complete.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusScanComplete As Integer
public const int StatusScanComplete
public:
literal int StatusScanComplete
public static final int StatusScanComplete
public const var StatusScanComplete : int

Remarks

The value of this field indicates that the check scan is complete.

This field replaces CHK_SUE_SCANCOMPLETE UPOS constant.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
StatusUpdateEvent
StatusUpdateEventArgs


CheckScanner Constructor

CheckScanner Constructor |
 | See Also

1/18/2008

Creates an instance of the CheckScanner class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected CheckScanner ()
protected:
CheckScanner ()
protected CheckScanner ()
protected function CheckScanner ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace


CheckScanner Methods

CheckScanner Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
BeginInsertion | Starts the document insertion process.
BeginRemoval | Starts the document removal process.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearImage | Clears a specific image or all the images in the device memory.
ClearInput | Clears all device input that has been buffered.
ClearInputProperties | Resets the values of properties altered by DataEvent or ErrorEvent.
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DefineCropArea | Establishes one or more cropping areas that can be applied to a scanned image.
DirectIO | (inherited from PosCommon )
EndInsertion | Ends the document insertion process.
EndRemoval | Ends the document removal or ejection mode.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon )
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveImage | Retrieves the most recently scanned image that resides in the available memory and uses it to populate the ImageData property.
RetrieveMemory | Retrieves an image that was stored in memory and uses it to set the ImageData property.
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
StoreImage | Stores an image or a cropped area of the image in the memory of the device.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

CheckScanner Class
Microsoft.PointOfService Namespace


CheckScanner.BeginInsertion Method

CheckScanner.BeginInsertion Method |
 | See Also

1/18/2008

Starts the document insertion process.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub BeginInsertion ( _
    timeout As Integer _
)
public abstract void BeginInsertion (
    int timeout
)
public:
virtual void BeginInsertion (
    int timeout
) abstract
public abstract void BeginInsertion (
    int timeout
)
public abstract function BeginInsertion (
    timeout : int
)

Parameters

timeout

Specifies the number of milliseconds before failing the method. If timeout is set to 0 (zero), the method tries to begin insertion mode, returns immediately if this is successful. Otherwise, an exception is thrown. If timeout is set to WaitForever, the method tries to begin insertion mode, waits as long as needed until either the check is inserted or an error occurs.

Remarks

When it is called, the check scanner is made ready to receive a check by opening the device’s check handling "jaws" or starting the device’s insertion mode. BeginInsertion is paired with the EndInsertion method for controlling check insertion. Although some Check Scanner devices do not require this kind of processing, the application should use these methods to make sure the application works across different Check Scanner devices.

If the Check Scanner device cannot be put in insertion mode, the service object throws an exception. Otherwise, check insertion is monitored until either:

  • The check is successfully inserted; or

  • The check is not inserted before timeout milliseconds have elapsed, or an error is reported by the device. In this case, the service object throws an exception and the check scanner remains in insertion mode. This enables the application to perform some user interaction and reissue the BeginInsertion method without altering the check scanner check-handling mechanism.

BeginInsertion may throw a PosControlException with the following ErrorCodes.

Value | Meaning
Timeout | The value of timeout was reached before insertion mode could be initiated.
Busy | If the check scanner is a combination device, the peer device may be busy.
Illegal | An invalid value has been specified for timeout.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
BeginRemoval
EndInsertion
EndRemoval


CheckScanner.BeginRemoval Method

CheckScanner.BeginRemoval Method |
 | See Also

1/18/2008

Starts the document removal process.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub BeginRemoval ( _
    timeout As Integer _
)
public abstract void BeginRemoval (
    int timeout
)
public:
virtual void BeginRemoval (
    int timeout
) abstract
public abstract void BeginRemoval (
    int timeout
)
public abstract function BeginRemoval (
    timeout : int
)

Parameters

timeout

Gives the number of milliseconds before failing the method. If timeout is set to 0 (zero), the method tries to begin removal mode, returns immediately if this is successful. Otherwise, it throws an exception. If timeout is set to WaitForever (-1), the method tries to begin removal mode, waits as long as needed until either the check is removed or an error occurs.

Remarks

When it is called, the check scanner is made ready to remove a check by opening the device’s check handling "jaws" or starting the device’s ejection mode. BeginRemoval is paired with the EndRemoval method for controlling check removal. Although some Check Scanner devices do not require this kind of processing, the application should use these methods to make sure the application works across different Check Scanner devices.

If the Check Scanner device cannot be put in removal mode, the service object throws an exception. Otherwise, check removal is monitored until either:

  • The check is successfully removed; or

  • The check is not removed before timeout milliseconds have elapsed, or an error is reported by the device. In this case, the service object throws an exception and the check scanner remains in removal mode. This enables the application to perform some user interaction and reissue the BeginRemoval method without altering the check scanner check handling mechanism.

BeginRemoval may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Timeout | The value of timeout was reached before removal mode could be initiated.
Busy | If the check scanner is a combination device, the peer device may be busy.
Illegal | An invalid value has been specified for timeout.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
CheckScanner.BeginInsertion Method
EndInsertion
EndRemoval


CheckScanner.ClearImage Method

CheckScanner.ClearImage Method |
 | See Also

1/18/2008

Clears a specific image or all the images in the device memory.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearImage ( _
    by As CheckImageClear _
)
public abstract void ClearImage (
    CheckImageClear by
)
public:
virtual void ClearImage (
    CheckImageClear by
) abstract
public abstract void ClearImage (
    CheckImageClear by
)
public abstract function ClearImage (
    by : CheckImageClear
)

Parameters

by

Indicates how the image file is to be located so that it can be removed from the device storage. Possible values are defined by the CheckImageClear enumerator.

Remarks

The following table shows the valid values for the by parameter.

Value | Meaning
All | All images in the device are cleared.
FileId | Locate the file to be cleared by using the FileId property value.
FileIndex | Locate the file to be cleared by using the FileIndex property value.
ImageTagData | Locate the file to be cleared by using the ImageTagData property value.

ClearImage may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Illegal | An invalid value has been specified for by.
NoExist | The image specified could not be found.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
CapStoreImageFiles
FileId
FileIndex
ImageTagData


CheckScanner.ClearInput Method

CheckScanner.ClearInput Method |
 | See Also

1/18/2008

Clears all device input that has been buffered.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearInput
public abstract void ClearInput ()
public:
virtual void ClearInput () abstract
public abstract void ClearInput ()
public abstract function ClearInput ()

Remarks

Any data events or input error events that were queued by the service object are also cleared, Usually, the events are waiting for DataEventEnabled to be set to true and FreezeEvents to be set to false,.

ClearInput may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Claimed | The device is claimed by another process.
NotClaimed | The device must be claimed before ClearInput can be used.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
FreezeEvents
DataEventEnabled
DataEvent
ErrorEvent


CheckScanner.ClearInputProperties Method

CheckScanner.ClearInputProperties Method |
 | See Also

1/18/2008

Resets the values of properties altered by DataEvent or ErrorEvent.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Sub ClearInputProperties
public virtual void ClearInputProperties ()
public:
virtual void ClearInputProperties ()
public void ClearInputProperties ()
public function ClearInputProperties ()

Remarks

Sets all data properties populated by raising the DataEvent event or ErrorEvent event back to their default values. This does not reset the DataCount or State properties.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
DataEvent
ErrorEvent
DataCount


CheckScanner.DefineCropArea Method

CheckScanner.DefineCropArea Method |
 | See Also

1/18/2008

Establishes one or more cropping areas that can be applied to a scanned image.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub DefineCropArea ( _
    cropAreaId As Integer, _
    x As Integer, _
    y As Integer, _
    width As Integer, _
    height As Integer _
)
public abstract void DefineCropArea (
    int cropAreaId,
    int x,
    int y,
    int width,
    int height
)
public:
virtual void DefineCropArea (
    int cropAreaId,
    int x,
    int y,
    int width,
    int height
) abstract
public abstract void DefineCropArea (
    int cropAreaId,
    int x,
    int y,
    int width,
    int height
)
public abstract function DefineCropArea (
    cropAreaId : int,
    x : int,
    y : int,
    width : int,
    height : int
)

Parameters

cropAreaId

The numeric identifier for the defined crop area.

x

The starting X-coordinate of the cropping area.

y

The starting Y-coordinate of the cropping area.

width

The value added to the X-coordinate to determine the x endpoint for the cropping area. If set to CropAreaRight, the x endpoint value is set to the value of the DocumentWidth property.

height

The value added to the Y-coordinate to determine the y endpoint for the cropping area. If set to CropAreaBottom, the y endpoint value is set to the value of the DocumentHeight property.

Remarks

The values are specified in units designated by the MapMode property, and use the upper-left corner of the scanned document as the origin (0,0). All values are positive.

DefineCropArea specifies an area of interest that is contained within a crop box and given an index number for reference. Only the data that is defined by this index number is sent when the application calls the RetrieveImage method. The crop areas should be set before calling RetrieveImage, and they remain in effect until changed.

A crop box cannot contain an area larger than that defined by the current DocumentWidth and DocumentHeight properties. If the resultant value for the endpoint (x + width) is greater than the DocumentWidth value, then, the x endpoint value is set to DocumentWidth. If the resultant value for the endpoint (y + height) is greater than the DocumentHeight value, then the y endpoint value is set to DocumentHeight.

The following table shows the possible constant values for the cropAreaID parameter.

Value | Meaning
CropAreaResetAll | The crop area definitions (as specified by the value of the MaxCropAreas property) will have their x,y and width/height values reset to 0,0 and DocumentWidth and DocumentHeight, respectively.
CropAreaEntireImage | The crop area is equal to the scanned image. The method returns without storing the image.

DefineCropArea may cause a PosControlException to be thrown with the following ErrorCodes.

Value

Meaning

Illegal

One of the following problems was found:

  • The Check Scanner device does not support crop areas (that is, the CapDefineCropArea property is set to false).

  • The value that is stored in cropAreaID is invalid.

  • All available crop areas have already been defined for the device.

  • The values specified for x and y or y are invalid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
CapDefineCropArea
CropAreaCount
DocumentHeight
DocumentWidth
MapMode
MaxCropAreas


CheckScanner.EndInsertion Method

CheckScanner.EndInsertion Method |
 | See Also

1/18/2008

Ends the document insertion process.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub EndInsertion
public abstract void EndInsertion ()
public:
virtual void EndInsertion () abstract
public abstract void EndInsertion ()
public abstract function EndInsertion ()

Remarks

The EndInsertion method checks to make sure that the device is in insertion mode, then tries to remove the check scanner from insertion mode.

If the check scanner is successfully removed from insertion mode, EndInsertion puts the scanned image in a working buffer memory area, checks it for resolution quality, and then raises a StatusUpdateEvent event to indicate that a successful scan has occurred. Because no data has been transferred to the ImageData property at this point, no DataEvent event is raised. The application must call the RetrieveImage method to populate the ImageData property.

If no check is detected in the device, or if the working buffer memory area is empty indicating no check was scanned, EndInsertion throws an exception. If the resolution of the scanned image is not equal to the value of the Quality property, the resolution is reset to match the Quality property, and an informational error is logged.

EndInsertion is paired with the BeginInsertion method for controlling check insertion. Although some Check Scanner devices do not require this kind of processing, the application should still use these methods to make sure application portability across different Check Scanner devices.

EndInsertion may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Illegal | The Check Scanner device was not in check insertion mode—BeginInsertion had not been called before calling EndInsertion.
Extended | ErrorCodeExtended = ExtendedErrorNoCheck. No check was detected in the Check Scanner device.
Failure | There is no check image in the working area buffer—the check scan failed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
CheckScanner.BeginRemoval Method
CheckScanner.BeginInsertion Method
EndRemoval


CheckScanner.EndRemoval Method

CheckScanner.EndRemoval Method |
 | See Also

1/18/2008

Ends the document removal or ejection mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub EndRemoval
public abstract void EndRemoval ()
public:
virtual void EndRemoval () abstract
public abstract void EndRemoval ()
public abstract function EndRemoval ()

Remarks

If a check is detected in the device, the service object throws an exception.

EndRemoval is paired with the BeginRemoval method for controlling check removal. Although some Check Scanner devices do not require this kind of processing, the application should still use these methods to make sure the application works across different Check Scanner devices.

EndRemoval may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Illegal | The Check Scanner device was not in check removal mode—BeginRemoval had not been called before calling EndRemoval.
Extended | ErrorCodeExtended = ExtendedErrorCheck. A check was detected in the Check Scanner device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
CheckScanner.BeginRemoval Method
CheckScanner.BeginInsertion Method
CheckScanner.EndInsertion Method


CheckScanner.RetrieveImage Method

CheckScanner.RetrieveImage Method |
 | See Also

1/18/2008

Retrieves the most recently scanned image that resides in the available memory and uses it to populate the ImageData property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub RetrieveImage ( _
    cropAreaId As Integer _
)
public abstract void RetrieveImage (
    int cropAreaId
)
public:
virtual void RetrieveImage (
    int cropAreaId
) abstract
public abstract void RetrieveImage (
    int cropAreaId
)
public abstract function RetrieveImage (
    cropAreaId : int
)

Parameters

cropAreaId

Specifies the numeric identifier for the storage location of the crop area definition to be applied to the most recently scanned image held in the working area memory of the device. If cropAreaID is set to CropAreaEntireImage, the area of the most recently scanned image is retrieved.

Remarks

If RetrieveImage is successful, it queues a DataEvent event. If an error occurs, RetrieveImage queues an ErrorEvent event.

If the CapImageTagData property is set to true, the ImageTagData property is set to the tag data associated with the image data file.

If a file name has been created for the image data by the Check Scanner device, then the FileId property is set to the file name. If no file name is available, FileId is set to null.

Many models of check scanner devices do not require any check handling processing from the application. Such devices may always be able to receive a check, scan the image into their available memory area, and require no commands to read and eject the check. For these types of Check Scanner devices, the BeginInsertion, EndInsertion, BeginRemoval, and EndRemoval methods return, and the service object raises the DataEvent event when the application sets the DataEventEnabled property to true. However, applications should still use these methods to make sure the application works across different check scanner devices.

RetrieveImage cannot be called after the RetrieveMemory method has been called, until a new document has been scanned.

RetrieveImage may cause a PosControlException to be thrown with the following ErrorCodes.

Value

Meaning

Illegal

One of the following is the case:

  • There is no scanned image available in the available memory buffer to be retrieved.

  • The image has not yet been scanned.

  • The cropped area specified by CropAreaId is invalid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
CapImageTagData
FileId
ImageData
CheckScanner.BeginInsertion Method
CheckScanner.BeginRemoval Method
CheckScanner.EndInsertion Method
CheckScanner.EndRemoval Method


CheckScanner.RetrieveMemory Method

CheckScanner.RetrieveMemory Method |
 | See Also

1/18/2008

Retrieves an image that was stored in memory and uses it to set the ImageData property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub RetrieveMemory ( _
    by As CheckImageLocate _
)
public abstract void RetrieveMemory (
    CheckImageLocate by
)
public:
virtual void RetrieveMemory (
    CheckImageLocate by
) abstract
public abstract void RetrieveMemory (
    CheckImageLocate by
)
public abstract function RetrieveMemory (
    by : CheckImageLocate
)

Parameters

by

Indicates how the image file is to be located so that it can be retrieved from the device memory storage. Possible values are defined by the CheckImageLocate enumeration.

Remarks

If RetrieveMemory is successful, it queues a DataEvent event. If the scanned data was not put in the ImageData property, RetrieveMemory queues an ErrorEvent event.

The following table shows the valid values for the by parameter.

Value | Meaning
FileId | Locates the image file that uses the FileId property value..
FileIndex | Locates the image file that uses the FileIndex property value.
ImageTagData | Locates the image file that uses the ImageTagData property value.

The FileId, FileIndex, and ImageTagData properties are all updated to reflect their respective values associated with the image data file after RetrieveMemory is called. A value for FileIndex is always available. The FileId and ImageTagData properties is set to null if the image file does not have data to be retrieved for those properties.

The RetrieveImage method cannot be called after RetrieveMemory has been called, until a new document has been scanned.

RetrieveMemory may cause a PosControlException to be thrown with the following ErrorCodes.

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The CapStoreImageFiles property is set to false. This indicates that the device does not support storage of image files.

  • A value has been specified for the by parameter that does not exist in the CheckImageLocate enumerator.

  • The image data file could not be located because of an invalid value that is stored in the FileId, FileIndex, or ImageTagData properties.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
FileId
FileIndex
ImageTagData
CheckImageLocate Enumeration


CheckScanner.StoreImage Method

CheckScanner.StoreImage Method |
 | See Also

1/18/2008

Stores an image or a cropped area of the image in the memory of the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub StoreImage ( _
    cropAreaId As Integer _
)
public abstract void StoreImage (
    int cropAreaId
)
public:
virtual void StoreImage (
    int cropAreaId
) abstract
public abstract void StoreImage (
    int cropAreaId
)
public abstract function StoreImage (
    cropAreaId : int
)

Parameters

cropAreaId

Specifies the numeric identifier for the storage location of the crop area definition to be applied to the image data file that is currently in the buffer memory area of the check scanner device. If cropAreaID is set to CropAreaEntireImage then an exact image of the buffer memory is stored in the device memory (no cropping applied).

Remarks

The RemainingImagesEstimate property is adjusted to reflect the approximate number of additional images that may be stored in the device memory based on the file size history of stored images.

The ImageMemoryStatus property indicates whether the device memory is full and is adjusted because of StoreImage.

The FileId, FileIndex, and ImageTagData properties must all be updated to reflect their respective values associated with the image data file before StoreImage is called. A value for FileIndex is always available and is supplied by the service object. The FileId and ImageTagData properties are set to null if the service object does not support those properties.

StoreImage may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Illegal | Either the check scanner device does not support storing images, that is, the CapStoreImageFiles property is set to false, or the cropped area that is specified by cropAreaID is invalid.
Failure | There was an internal error while trying to store the data.
Extended | ErrorCodeExtended = ExtendedErrorNoRoom. There is no room for the image in memory.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
FileId
FileIndex
ImageMemoryStatus
CapStoreImageFiles
ImageTagData


CheckScanner Properties

CheckScanner Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
AutoDisable | Gets or sets the Boolean value that indicates whether POS for .NET automatically disables the device when data is received.
CapAutoContrast | Gets the Boolean value that indicates whether the contrast can be adjusted automatically.
CapAutoGenerateFileId | Gets the Boolean value that indicates whether the Check Scanner device can create a file name for the image file automatically.
CapAutoGenerateImageTagData | Gets the Boolean value that indicates whether the Check Scanner device can generate tag data automatically.
CapAutoSize | Gets the Boolean value that indicates whether the size of the scanned document can be set automatically.
CapColor | Gets the Boolean value that indicates whether the Check Scanner device supports image formats other than bitonal.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapConcurrentMicr | Gets the Boolean value that indicates whether the Magnetic Ink Character Recognition (MICR) data can be captured.
CapContrast | Gets the Boolean value that indicates the ability of the device to lighten or darken the scanned image.
CapDefineCropArea | Gets the Boolean value that indicates whether the Check Scanner device supports a feature that allows cropping of areas of interest within the scan image area defined by the DocumentHeight and DocumentWidth properties.
CapImageFormat | Gets the image file formats that this Check Scanner device supports.
CapImageTagData | Gets the Boolean value that indicates whether the Check Scanner device can set tag data.
CapMicrDevice | Gets the Boolean value that indicates whether the Check Scanner device supports a check Magnetic Ink Character Recognition (MICR) read function.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapStoreImageFiles | Gets the Boolean value that indicates whether the Check Scanner device can store check images.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CapValidationDevice | Gets the Boolean value that indicates whether a check has to be removed before validation printing.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Color | Gets or sets the image scan mode for later document scan operations.
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
ConcurrentMicr | Gets or sets the Boolean value that indicates whether the Check Scanner device can conduct a MICR read.
Contrast | Gets or sets the contrast to adjust the darkness of the image.
CropAreaCount | Gets the number of defined crop areas that may be applied to the captured image.
DataCount | Gets the number of data events currently queued by the service object.
DataEventEnabled | Gets or sets the Boolean value that indicates whether the service object can deliver a queued event.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
DocumentHeight | Gets or sets the height of the document scanned or the height of the document to be scanned.
DocumentWidth | Gets or sets the width of the document scanned or the width of the document to be scanned.
FileId | Gets or sets the file name associated with the image data file.
FileIndex | Gets or sets the file location associated with the image data file.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
ImageData | Gets the image data.
ImageFormat | Gets or sets the data format of the image file that the device uses when it captures an image.
ImageMemoryStatus | Gets the current memory availability status if the device can store multiple image files.
ImageTagData | Gets or sets a string that specifies the tag name for the captured image data.
MapMode | Gets or sets the units of measure that are currently valid for the Check Scanner device.
MaxCropAreas | Gets the maximum number of crop areas the device can support.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
Quality | Gets or sets the resolution of the device when a scan image is to occur. The resolution value is defined as dpi (dots per inch).
QualityList | Gets the resolutions that the Check Scanner device can support.
RemainingImagesEstimate | Gets a "best guess" estimate of the remaining number of images that can be stored.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets the Boolean value that indicates whether the Check Scanner is an exclusive-use device.

See Also

Reference

CheckScanner Class
Microsoft.PointOfService Namespace


CheckScanner.AutoDisable Property

CheckScanner.AutoDisable Property |
 | See Also

1/18/2008

Gets or sets the Boolean value that indicates whether POS for .NET automatically disables the device when data is received.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AutoDisable As Boolean
public abstract bool AutoDisable { get; set; }
public:
virtual property bool AutoDisable {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_AutoDisable ()

/** @property */
public abstract void set_AutoDisable (boolean value)

public abstract function get AutoDisable () : boolean

public abstract function set AutoDisable (value : boolean)

Remarks

AutoDisable adds an additional option to the application for controlling the receipt of input data. If the application wants to receive and process only one input, or only one input at a time, then this property can be set to true.

When true, the service object sets the DeviceEnabled property to false as soon as it receives and queues data to be raised as a DataEvent event. Before the service object raises any later events, the application must set DeviceEnabled back to true.

When false, the service object does not automatically disable the device when data is received; instead, it relies on the application to set the value of the DeviceEnabled property.

AutoDisable is set by the service object.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
DeviceEnabled


CheckScanner.CapAutoContrast Property

CheckScanner.CapAutoContrast Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the contrast can be adjusted automatically.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CapAutoContrast As Boolean
public virtual bool CapAutoContrast { get; }
public:
virtual property bool CapAutoContrast {
    bool get ();
}
/** @property */
public boolean get_CapAutoContrast ()

public function get CapAutoContrast () : boolean

Remarks

If true, then when Contrast is set to AutomaticContrast, the device attempts to automatically adjust the contrast. The darkness adjustment is based on sensing the paper to produce the optimal brightness for the best image under typical circumstances.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
Contrast


CheckScanner.CapAutoGenerateFileId Property

CheckScanner.CapAutoGenerateFileId Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the Check Scanner device can create a file name for the image file automatically.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapAutoGenerateFileId As Boolean
public abstract bool CapAutoGenerateFileId { get; }
public:
virtual property bool CapAutoGenerateFileId {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapAutoGenerateFileId ()

public abstract function get CapAutoGenerateFileId () : boolean

Remarks

If set to true, the Check Scanner device can automatically create a file name for the captured image file.

CapAutoGenerateFileId is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
FileId


CheckScanner.CapAutoGenerateImageTagData Property

CheckScanner.CapAutoGenerateImageTagData Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the Check Scanner device can generate tag data automatically.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapAutoGenerateImageTagData As Boolean
public abstract bool CapAutoGenerateImageTagData { get; }
public:
virtual property bool CapAutoGenerateImageTagData {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapAutoGenerateImageTagData ()

public abstract function get CapAutoGenerateImageTagData () : boolean

Remarks

If set to true, the Check Scanner device can automatically generate tag data that is used for the image file for the captured image.

CapAutoGenerateImageTagData is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
ImageTagData


CheckScanner.CapAutoSize Property

CheckScanner.CapAutoSize Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the size of the scanned document can be set automatically.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapAutoSize As Boolean
public abstract bool CapAutoSize { get; }
public:
virtual property bool CapAutoSize {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapAutoSize ()

public abstract function get CapAutoSize () : boolean

Remarks

If set to true, the height and width of the scanned document will be automatically placed in the DocumentHeight and DocumentWidth properties when the image is captured.

If CapAutoSize is set to false, the application can set the DocumentHeight and DocumentWidth properties before scanning an image.

CapAutoSize is typically initialized to true. The service object should then set CapAutoSize to false if it wants the application to manage the setting of DocumentWidth and DocumentHeight.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
DocumentHeight
DocumentWidth


CheckScanner.CapColor Property

CheckScanner.CapColor Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the Check Scanner device supports image formats other than bitonal.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapColor As CheckColors
public abstract CheckColors CapColor { get; }
public:
virtual property CheckColors CapColor {
    CheckColors get () abstract;
}
/** @property */
public abstract CheckColors get_CapColor ()

public abstract function get CapColor () : CheckColors

Remarks

Possible values are defined by the CheckColors enumeration.

CapColor is a logical OR combination of any of the values that are defined by the CheckColors enumeration.

CapColor is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
Color
CheckColors Enumeration


CheckScanner.CapConcurrentMicr Property

CheckScanner.CapConcurrentMicr Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the Magnetic Ink Character Recognition (MICR) data can be captured.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapConcurrentMicr As Boolean
public abstract bool CapConcurrentMicr { get; }
public:
virtual property bool CapConcurrentMicr {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapConcurrentMicr ()

public abstract function get CapConcurrentMicr () : boolean

Remarks

If set to true, the MICR data of a check can be captured during a check scanning cycle (single-pass scanning).

For devices that are both a Check Scanner device and a MICR device, following a check scan, the device automatically passes the MICR data to the MICR service object. The check does not have to be reread during the MICR BeginInsertion and EndInsertion methods.

If CapConcurrentMicr is set to false, then it would be necessary to read the MICR data (if the Check Scanner device supports MICR reading) by using the MICR BeginInsertion and EndInsertion methods. Usually, the MICR read is performed before the check scanning process.

If the CapMicrDevice property is set to false, CapConcurrentMicr is set to false.

CapConcurrentMicr is set by the service object based on the capability of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
ConcurrentMicr
CapMicrDevice
BeginInsertion
EndInsertion


CheckScanner.CapContrast Property

CheckScanner.CapContrast Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates the ability of the device to lighten or darken the scanned image.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CapContrast As Boolean
public virtual bool CapContrast { get; }
public:
virtual property bool CapContrast {
    bool get ();
}
/** @property */
public boolean get_CapContrast ()

public function get CapContrast () : boolean

Remarks

This affects the image regardless of the value of the CapColor property.

If true, the darkness of the image can be adjusted by using the Contrast property. If false, the application cannot adjust the darkness of the image.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace


CheckScanner.CapDefineCropArea Property

CheckScanner.CapDefineCropArea Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the Check Scanner device supports a feature that allows cropping of areas of interest within the scan image area defined by the DocumentHeight and DocumentWidth properties.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapDefineCropArea As Boolean
public abstract bool CapDefineCropArea { get; }
public:
virtual property bool CapDefineCropArea {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapDefineCropArea ()

public abstract function get CapDefineCropArea () : boolean

Remarks

If set to true, one or more cropping areas are allowed.

CapDefineCropArea is set by the service object, based on the capability of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
DocumentHeight
DocumentWidth
CropAreaCount
MaxCropAreas
CheckScanner.DefineCropArea Method


CheckScanner.CapImageFormat Property

CheckScanner.CapImageFormat Property |
 | See Also

1/18/2008

Gets the image file formats that this Check Scanner device supports.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapImageFormat As CheckImageFormats
public abstract CheckImageFormats CapImageFormat { get; }
public:
virtual property CheckImageFormats CapImageFormat {
    CheckImageFormats get () abstract;
}
/** @property */
public abstract CheckImageFormats get_CapImageFormat ()

public abstract function get CapImageFormat () : CheckImageFormats

Remarks

Possible values are defined by the CheckImageFormats enumeration.

CapImageFormat is a logical OR combination of any of the values specified by the CheckImageFormats enumeration.

CapImageFormat is set by the service object, based on the capability of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
ImageFormat
CheckImageFormats Enumeration


CheckScanner.CapImageTagData Property

CheckScanner.CapImageTagData Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the Check Scanner device can set tag data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapImageTagData As Boolean
public abstract bool CapImageTagData { get; }
public:
virtual property bool CapImageTagData {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapImageTagData ()

public abstract function get CapImageTagData () : boolean

Remarks

If set to true, the Check Scanner device can set tag data, as defined by the ImageTagData property, to the image data file that is stored in the ImageData property.

CapImageTagData is set by the service object, based on the capability of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
ImageTagData
ImageData
CheckScanner.RetrieveImage Method
CheckScanner.StoreImage Method


CheckScanner.CapMicrDevice Property

CheckScanner.CapMicrDevice Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the Check Scanner device supports a check Magnetic Ink Character Recognition (MICR) read function.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapMicrDevice As Boolean
public abstract bool CapMicrDevice { get; }
public:
virtual property bool CapMicrDevice {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapMicrDevice ()

public abstract function get CapMicrDevice () : boolean

Remarks

If set to true, the Check Scanner device supports a check MICR read function.

If the CapConcurrentMicr property is set to true, the MICR data of a check can be captured during a check scanning cycle (single-pass scanning). For devices that are both a check scanner and a MICR reader, following a check scan, the device automatically passes the MICR data to the MICR service object. The check does not have to be re-read during the MICR BeginInsertion and EndInsertion methods.

If CapConcurrentMicr is set to false, then it would be necessary to read the MICR data by using the MICR BeginInsertion and EndInsertion methods. In this case, the MICR read is usually performed before the check scanning process.

CapMicrDevice is set by the service object, based on the capability of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
CheckScanner.CapConcurrentMicr Property
ConcurrentMicr


CheckScanner.CapStoreImageFiles Property

CheckScanner.CapStoreImageFiles Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the Check Scanner device can store check images.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapStoreImageFiles As Boolean
public abstract bool CapStoreImageFiles { get; }
public:
virtual property bool CapStoreImageFiles {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapStoreImageFiles ()

public abstract function get CapStoreImageFiles () : boolean

Remarks

If set to true, the Check Scanner device can store check images in its hardware memory by using the StoreImage method.

CapStoreImageFiles is set by the service object, based on the capability of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
CheckScanner.RetrieveImage Method
CheckScanner.StoreImage Method


CheckScanner.CapValidationDevice Property

CheckScanner.CapValidationDevice Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether a check has to be removed before validation printing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapValidationDevice As Boolean
public abstract bool CapValidationDevice { get; }
public:
virtual property bool CapValidationDevice {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapValidationDevice ()

public abstract function get CapValidationDevice () : boolean

Remarks

If set to true, a check does not have to be removed from the Check Scanner device before performing validation printing.

For devices that are both a check scanner and a printer, the device automatically positions the check for validation printing after successfully performing a check scanner read. The BeginRemoval and EndRemoval methods of either the check scanner service object or the printer service object can be called to remove the check when the process is complete.

CapValidationDevice is set by the service object, based on the capability of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
CheckScanner.BeginRemoval Method
CheckScanner.EndRemoval Method
BeginRemoval
EndRemoval


CheckScanner.Color Property

CheckScanner.Color Property |
 | See Also

1/18/2008

Gets or sets the image scan mode for later document scan operations.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property Color As CheckColors
public abstract CheckColors Color { get; set; }
public:
virtual property CheckColors Color {
    CheckColors get () abstract;
    void set (CheckColors value) abstract;
}
/** @property */
public abstract CheckColors get_Color ()

/** @property */
public abstract void set_Color (CheckColors value)

public abstract function get Color () : CheckColors

public abstract function set Color (value : CheckColors)

Remarks

Possible values are defined by the CheckColors enumerator.

Available options may be affected by the current file type specified by the ImageFormat property. Certain file types may not work with all the "colors" that the device may support. It is up to the application to verify that the Color and ImageFormat properties are compatible. Changing the Color property does not affect any stored data currently residing in the ImageData property.

Color is set by the service object, based on the capabilities of the device.

Accessing Color may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Illegal | Color has been set to a value that does not exist in the CheckColors enumerator.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
CheckColors Enumeration
CheckScanner.CapColor Property
ImageFormat


CheckScanner.ConcurrentMicr Property

CheckScanner.ConcurrentMicr Property |
 | See Also

1/18/2008

Gets or sets the Boolean value that indicates whether the Check Scanner device can conduct a MICR read.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property ConcurrentMicr As Boolean
public abstract bool ConcurrentMicr { get; set; }
public:
virtual property bool ConcurrentMicr {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_ConcurrentMicr ()

/** @property */
public abstract void set_ConcurrentMicr (boolean value)

public abstract function get ConcurrentMicr () : boolean

public abstract function set ConcurrentMicr (value : boolean)

Remarks

If set to true, the Check Scanner device can conduct a MICR read during a check-scanning cycle.

For devices that are both a check scanner and a MICR reader, following a check scan, the device automatically passes the MICR data to the MICR service object. The check does not have to be re-read during the MICR BeginInsertion and EndInsertion methods.

If ConcurrentMicr is set to false and MICR data is required, it must read MICR data by using the MICR BeginInsertion and EndInsertion methods. In this case, the MICR read is usually performed before the check scanning process.

ConcurrentMicr is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
CheckScanner.CapConcurrentMicr Property
CheckScanner.CapMicrDevice Property


CheckScanner.Contrast Property

CheckScanner.Contrast Property |
 | See Also

1/18/2008

Gets or sets the contrast to adjust the darkness of the image.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Property Contrast As Integer
public virtual int Contrast { get; set; }
public:
virtual property int Contrast {
    int get ();
    void set (int value);
}
/** @property */
public int get_Contrast ()

/** @property */
public void set_Contrast (int value)

public function get Contrast () : int

public function set Contrast (value : int)

Remarks

Contrast is valid only if the CapContrast property is true.

A value of 0 sets or indicates that the device generates the lightest image possible. A value of 100 sets or indicates that the device generates the darkest image possible. All values between 0 and 100 produce images with varying degrees of darkness. A value of 50 should produce an image that is the optimal brightness for the best image under typical circumstances.

If the CapAutoContrast property is true then Contrast can be set to AutomaticContrast to allow the device to automatically adjust the darkness of the image based on sensing of the paper to produce the optimal brightness for the best image under usual circumstances.

If CapAutoContrast is false, trying to set this property to AutomaticConstrast is illegal.

If CapAutoContrast is true, Contrast is initialized to AutomaticContrast when the device is enabled. If CapAutoContrast is false, Contrast is initialized either to 50 or to a user-configured value when the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
CheckScanner.CapAutoContrast Property
CheckScanner.CapContrast Property
CheckScanner.AutomaticContrast Field


CheckScanner.CropAreaCount Property

CheckScanner.CropAreaCount Property |
 | See Also

1/18/2008

Gets the number of defined crop areas that may be applied to the captured image.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CropAreaCount As Integer
public abstract int CropAreaCount { get; }
public:
virtual property int CropAreaCount {
    int get () abstract;
}
/** @property */
public abstract int get_CropAreaCount ()

public abstract function get CropAreaCount () : int

Remarks

If the CapDefineCropArea property is set to false, CropAreaCount is always 0 (zero).

CropAreaCount is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
CheckScanner.CapDefineCropArea Property
MaxCropAreas
CheckScanner.DefineCropArea Method


CheckScanner.DataCount Property

CheckScanner.DataCount Property |
 | See Also

1/18/2008

Gets the number of data events currently queued by the service object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DataCount As Integer
public abstract int DataCount { get; }
public:
virtual property int DataCount {
    int get () abstract;
}
/** @property */
public abstract int get_DataCount ()

public abstract function get DataCount () : int

Remarks

The application can read DataCount to determine whether additional input is queued from a device but has not yet been delivered because of other application processing, freezing of events, or other causes.

DataCount is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
DataEvent


CheckScanner.DataEventEnabled Property

CheckScanner.DataEventEnabled Property |
 | See Also

1/18/2008

Gets or sets the Boolean value that indicates whether the service object can deliver a queued event.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property DataEventEnabled As Boolean
public abstract bool DataEventEnabled { get; set; }
public:
virtual property bool DataEventEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_DataEventEnabled ()

/** @property */
public abstract void set_DataEventEnabled (boolean value)

public abstract function get DataEventEnabled () : boolean

public abstract function set DataEventEnabled (value : boolean)

Remarks

When set to true by the application, the service object can deliver a queued event by raising a DataEvent event.

When DataEventEnabled is set to false by the application, the service object queues input data for later delivery to the application.

Notice that if an error occurs during input processing, the service object queues the error event but does not deliver it until the DataEventEnabled property is set to true.

DataEventEnabled is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
FreezeEvents
DeviceEnabled
CheckScanner.AutoDisable Property
DataEvent


CheckScanner.DocumentHeight Property

CheckScanner.DocumentHeight Property |
 | See Also

1/18/2008

Gets or sets the height of the document scanned or the height of the document to be scanned.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property DocumentHeight As Integer
public abstract int DocumentHeight { get; set; }
public:
virtual property int DocumentHeight {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_DocumentHeight ()

/** @property */
public abstract void set_DocumentHeight (int value)

public abstract function get DocumentHeight () : int

public abstract function set DocumentHeight (value : int)

Remarks

Height is expressed in the unit of measure defined by the MapMode property.

If the CapAutoSize property is set to true, the height of the scanned document is automatically put in DocumentHeight when the image is captured. If CapAutoSize is set to false, the height of the document must be set in DocumentHeight by the application before scanning a document.

DocumentHeight is set by the service object, based on the capabilities of the device.

Accessing DocumentHeight may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Illegal | DocumentHeight has been set to a value less than 0 (zero).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
CheckScanner.CapAutoSize Property
MapMode
DocumentWidth


CheckScanner.DocumentWidth Property

CheckScanner.DocumentWidth Property |
 | See Also

1/18/2008

Gets or sets the width of the document scanned or the width of the document to be scanned.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property DocumentWidth As Integer
public abstract int DocumentWidth { get; set; }
public:
virtual property int DocumentWidth {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_DocumentWidth ()

/** @property */
public abstract void set_DocumentWidth (int value)

public abstract function get DocumentWidth () : int

public abstract function set DocumentWidth (value : int)

Remarks

Width is expressed in the unit of measure defined by the MapMode property.

If the CapAutoSize property is set to true, the width of the scanned document is automatically put in DocumentWidth when the image is captured. If CapAutoSize is set to false, the width of the document must be set in DocumentWidth by the application before scanning a document.

DocumentWidth is set by the service object, based on the capabilities of the device.

Accessing DocumentWidth may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Illegal | DocumentWidth has been set to a value less than 0 (zero).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
CheckScanner.CapAutoSize Property
MapMode
CheckScanner.DocumentHeight Property


CheckScanner.FileId Property

CheckScanner.FileId Property |
 | See Also

1/18/2008

Gets or sets the file name associated with the image data file.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property FileId As String
public abstract string FileId { get; set; }
public:
virtual property String^ FileId {
    String^ get () abstract;
    void set (String^ value) abstract;
}
/** @property */
public abstract String get_FileId ()

/** @property */
public abstract void set_FileId (String value)

public abstract function get FileId () : String

public abstract function set FileId (value : String)

Remarks

If the application chooses to create the data for FileId, it must set FileId before calling the StoreImage method. After it calls the RetrieveMemory method, FileId is set to the image data file name, if available. If the file name is not available, FileId is set to null. The FileId value is set before a DataEvent event that is delivered to the application.

If the CapAutoGenerateFileId property is set to true, the FileId is automatically generated by the service object based on the capabilities of the device when the image is scanned.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
CheckScanner.CapAutoGenerateFileId Property
CheckScanner.RetrieveImage Method
CheckScanner.StoreImage Method
CheckScanner.RetrieveMemory Method


CheckScanner.FileIndex Property

CheckScanner.FileIndex Property |
 | See Also

1/18/2008

Gets or sets the file location associated with the image data file.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property FileIndex As Integer
public abstract int FileIndex { get; set; }
public:
virtual property int FileIndex {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_FileIndex ()

/** @property */
public abstract void set_FileIndex (int value)

public abstract function get FileIndex () : int

public abstract function set FileIndex (value : int)

Remarks

Holds the file location associated with the image data file when either the StoreImage or RetrieveMemory methods are called.

Its value is set before a DataEvent event is delivered to the application.

FileIndex is used only by the service object together with the device to store and locate an image data file.

FileIndex is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
CheckScanner.ClearImage Method
CheckScanner.RetrieveImage Method
CheckScanner.RetrieveMemory Method


CheckScanner.ImageData Property

CheckScanner.ImageData Property |
 | See Also

1/18/2008

Gets the image data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ImageData As Bitmap
public abstract Bitmap ImageData { get; }
public:
virtual property Bitmap^ ImageData {
    Bitmap^ get () abstract;
}
/** @property */
public abstract Bitmap get_ImageData ()

public abstract function get ImageData () : Bitmap

Remarks

Holds the image data after the RetrieveImage or RetrieveMemory methods are called.

If no image data was available, ImageData will be set to Null. Its value is set before a DataEvent event being delivered to the application.

ImageData is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
CheckScanner.RetrieveImage Method
CheckScanner.RetrieveMemory Method
DataEvent


CheckScanner.ImageFormat Property

CheckScanner.ImageFormat Property |
 | See Also

1/18/2008

Gets or sets the data format of the image file that the device uses when it captures an image.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property ImageFormat As CheckImageFormats
public abstract CheckImageFormats ImageFormat { get; set; }
public:
virtual property CheckImageFormats ImageFormat {
    CheckImageFormats get () abstract;
    void set (CheckImageFormats value) abstract;
}
/** @property */
public abstract CheckImageFormats get_ImageFormat ()

/** @property */
public abstract void set_ImageFormat (CheckImageFormats value)

public abstract function get ImageFormat () : CheckImageFormats

public abstract function set ImageFormat (value : CheckImageFormats)

Remarks

Holds the data format of the image file that the device will use when it captures an image.

Possible values are defined by the CheckImageFormats enumeration.

The availability of acceptable file types is specified in the CapImageFormat property. ImageFormat must be set before a document is scanned. Any stored data in the ImageData property will not be affected by changing ImageFormat.

ImageFormat is set by the service object, based on the capabilities of the device.

Accessing ImageFormat may cause a PosControlException to be thrown with the following ErrorCodes:

Value | Meaning
Illegal | ImageFormat has been set to a value that does not exist in the CheckImageFormats enumerator.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
CheckScanner.CapImageFormat Property
CheckImageFormats Enumeration
CheckScanner.ImageData Property


CheckScanner.ImageMemoryStatus Property

CheckScanner.ImageMemoryStatus Property |
 | See Also

1/18/2008

Gets the current memory availability status if the device can store multiple image files.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ImageMemoryStatus As ImageMemoryStatus
public abstract ImageMemoryStatus ImageMemoryStatus { get; }
public:
virtual property ImageMemoryStatus ImageMemoryStatus {
    ImageMemoryStatus get () abstract;
}
/** @property */
public abstract ImageMemoryStatus get_ImageMemoryStatus ()

public abstract function get ImageMemoryStatus () : ImageMemoryStatus

Remarks

ImageMemoryStatus is valid only if the CapStoreImageFiles property is set to true. Possible values for ImageMemoryStatus are defined by the ImageMemoryStatus enumeration.

ImageMemoryStatus is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
CheckScanner.CapStoreImageFiles Property
CheckScanner.StoreImage Method
ImageMemoryStatus


CheckScanner.ImageTagData Property

CheckScanner.ImageTagData Property |
 | See Also

1/18/2008

Gets or sets a string that specifies the tag name for the captured image data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property ImageTagData As String
public abstract string ImageTagData { get; set; }
public:
virtual property String^ ImageTagData {
    String^ get () abstract;
    void set (String^ value) abstract;
}
/** @property */
public abstract String get_ImageTagData ()

/** @property */
public abstract void set_ImageTagData (String value)

public abstract function get ImageTagData () : String

public abstract function set ImageTagData (value : String)

Remarks

Holds a string that specifies the tag name for the captured image data. The string may be specified by the application or automatically generated by the Check Scanner device.

If the application chooses to create the data for ImageTagData, it must set ImageTagData before calling the StoreImage method. After it calls the RetrieveMemory method, ImageTagData is set if available. ImageTagData is set before a DataEvent event is delivered to the application.

If the CapAutoGenerateImageTagData property is set to true, the ImageTagData is automatically generated by the service object based on the capabilities of the device when the image is scanned.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
CheckScanner.CapAutoGenerateImageTagData Property
CheckScanner.RetrieveImage Method
CheckScanner.RetrieveMemory Method
CheckScanner.StoreImage Method


CheckScanner.IsExclusiveUseDevice Property

CheckScanner.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the Check Scanner is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Property Value

A value of true indicates the fiscal printer is an exclusive-use device. Otherwise, the value is false.

Remarks

An exclusive-use device has the following properties:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before accessing some properties or calling methods that update the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace


CheckScanner.MapMode Property

CheckScanner.MapMode Property |
 | See Also

1/18/2008

Gets or sets the units of measure that are currently valid for the Check Scanner device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property MapMode As MapMode
public abstract MapMode MapMode { get; set; }
public:
virtual property MapMode MapMode {
    MapMode get () abstract;
    void set (MapMode value) abstract;
}
/** @property */
public abstract MapMode get_MapMode ()

/** @property */
public abstract void set_MapMode (MapMode value)

public abstract function get MapMode () : MapMode

public abstract function set MapMode (value : MapMode)

Remarks

Possible values are defined by the MapMode enumeration.

The mapping mode defines the unit of measure used by other properties, such as DocumentHeight and DocumentWidth.

MapMode is set by the service object, based on the capabilities of the device.

Accessing MapMode may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Illegal | MapMode has been set to a value that does not exist in the MapMode enumerator. If the value is invalid, the DocumentHeight and DocumentWidth properties are reset based on the default map mode value of English and the current resolution value in the Quality property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
CheckScanner.DocumentHeight Property
CheckScanner.DocumentWidth Property
CheckScanner.DefineCropArea Method


CheckScanner.MaxCropAreas Property

CheckScanner.MaxCropAreas Property |
 | See Also

1/18/2008

Gets the maximum number of crop areas the device can support.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property MaxCropAreas As Integer
public abstract int MaxCropAreas { get; }
public:
virtual property int MaxCropAreas {
    int get () abstract;
}
/** @property */
public abstract int get_MaxCropAreas ()

public abstract function get MaxCropAreas () : int

Remarks

MaxCropAreas is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
CheckScanner.CapDefineCropArea Property
CheckScanner.CropAreaCount Property
CheckScanner.DefineCropArea Method


CheckScanner.Quality Property

CheckScanner.Quality Property |
 | See Also

1/18/2008

Gets or sets the resolution of the device when a scan image is to occur. The resolution value is defined as dpi (dots per inch).

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property Quality As Integer
public abstract int Quality { get; set; }
public:
virtual property int Quality {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_Quality ()

/** @property */
public abstract void set_Quality (int value)

public abstract function get Quality () : int

public abstract function set Quality (value : int)

Remarks

Any stored data in the ImageData property are not affected by setting Quality.

Quality is set by the service object, based on the capabilities of the device.

Accessing Quality may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Illegal | Quality has been set to a value that does not exist in the QualityList property, or the QualityList property is empty.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
QualityList
CheckScanner.ImageData Property


CheckScanner.QualityList Property

CheckScanner.QualityList Property |
 | See Also

1/18/2008

Gets the resolutions that the Check Scanner device can support.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property QualityList As Integer()
public abstract int[] QualityList { get; }
public:
virtual property array<int>^ QualityList {
    array<int>^ get () abstract;
}
/** @property */
public abstract int[] get_QualityList ()

public abstract function get QualityList () : int[]

Remarks

The array consists of comma-separated values of available scanning resolutions, expressed in dpi (dots per inch). An empty array indicates that resolution is not available.

An example might be "160,320". This indicates that the device supports 160 and 320 dpi.

Any stored data in the ImageData property is not affected by setting QualityList.

QualityList is set by the service object, based on the capabilities of the device. If the current value of the Quality property is not in the list provided by the service object, Quality is reset to the first value in the list.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
CheckScanner.Quality Property
CheckScanner.ImageData Property


CheckScanner.RemainingImagesEstimate Property

CheckScanner.RemainingImagesEstimate Property |
 | See Also

1/18/2008

Gets a "best guess" estimate of the remaining number of images that can be stored.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property RemainingImagesEstimate As Integer
public abstract int RemainingImagesEstimate { get; }
public:
virtual property int RemainingImagesEstimate {
    int get () abstract;
}
/** @property */
public abstract int get_RemainingImagesEstimate ()

public abstract function get RemainingImagesEstimate () : int

Remarks

RemainingImagesEstimate is updated after every new image is stored or cleared from the available memory of the device. RemainingImagesEstimate, together with the ImageMemoryStatus, is intended to be used by the application to monitor the available image storage.

RemainingImagesEstimate is typically initialized to 0 (zero). The service object should then update RemainingImagesEstimate to a "best guess" estimate of the total number of image files that can be stored in the memory of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
CheckScanner.ImageMemoryStatus Property


CheckScanner Events

CheckScanner Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DataEvent | Raised to notify the application that a scanned check image is available.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
ErrorEvent | Raised to indicate an error has been detected while trying to read keyboard device input data.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

CheckScanner Class
Microsoft.PointOfService Namespace


CheckScanner.DataEvent Event

CheckScanner.DataEvent Event |
 | See Also

1/18/2008

Raised to notify the application that a scanned check image is available.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event DataEvent As DataEventHandler
public abstract event DataEventHandler DataEvent
public:
virtual event DataEventHandler^ DataEvent {
    void add (DataEventHandler^ value) abstract;
    void remove (DataEventHandler^ value) abstract;
}
/** @event */
public abstract void add_DataEvent (DataEventHandler value)

/** @event */
public abstract void remove_DataEvent (DataEventHandler value)

Remarks

Before the event is delivered to the application, the scanned image is put in the ImageData property. The Status property is set to 0 (zero).

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
CheckScanner.ImageData Property
DataEventArgs
DataEventHandler


CheckScanner.ErrorEvent Event

CheckScanner.ErrorEvent Event |
 | See Also

1/18/2008

Raised to indicate an error has been detected while trying to read keyboard device input data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event ErrorEvent As DeviceErrorEventHandler
public abstract event DeviceErrorEventHandler ErrorEvent
public:
virtual event DeviceErrorEventHandler^ ErrorEvent {
    void add (DeviceErrorEventHandler^ value) abstract;
    void remove (DeviceErrorEventHandler^ value) abstract;
}
/** @event */
public abstract void add_ErrorEvent (DeviceErrorEventHandler value)

/** @event */
public abstract void remove_ErrorEvent (DeviceErrorEventHandler value)

Remarks

The ErrorLocus property can hold one of the following values.

Value | Meaning
Input | Error occurred while collecting or processing event-driven input. No input data is available.
InputData | Error occurred while collecting or processing event-driven input, and some previously buffered data is available.

The ErrorResponse property is preset by the service object to a default value, based on the ErrorLocus. The application may change it to one of the following values.

Value | Meaning
Clear | Clears the buffered input data. Typically, the application has called the ClearInput method to clear all input buffers and queued events. The error state is then exited. Default when locus is Input.
ContinueInput | Uses only when locus is InputData. Acknowledges the error and directs the service object to continue to process. The service object remains in the error state and delivers additional data events as directed by the DataEventEnabled property. When all input has been delivered and the DataEventEnabled property is again set to true, then another ErrorEvent is delivered with locus Input. Default when locus is InputData.
Note:
ErrorEvent events are not delivered until the application has set the DataEventEnabled property to true. This indicates that it is ready to receive more input.

See Also

Reference

CheckScanner Class
CheckScanner Members
Microsoft.PointOfService Namespace
DeviceErrorEventHandler
DeviceErrorEventArgs
CheckScanner.DataEventEnabled Property


CheckType Enumeration

CheckType Enumeration |
 | See Also

1/18/2008

Enumerates the valid check types for the most recently read Magnetic Ink Character Recognition (MICR) data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration CheckType
public enum CheckType
public enum class CheckType
public enum CheckType
public enum CheckType

Members

Member name | Description
Business | The check is a business or commercial check.
Personal | The check is a personal check.
Unknown | The type of check is unknown.

Remarks

Used by the CheckType property.

The members of this enumeration replace the MICR_CT_PERSONAL, MICR_CT_BUSINESS, and MICR_CT_UNKNOWN UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
CheckType


ClockFunction Enumeration

ClockFunction Enumeration |
 | See Also

1/18/2008

Enumerates valid clock commands.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration ClockFunction
public enum ClockFunction
public enum class ClockFunction
public enum ClockFunction
public enum ClockFunction

Members

Member name | Description
Move | Moves an instantiated clock to a new position.
Pause | Temporarily stops a clock from updating the display until a Resume is requested.
Resume | Resumes a clock that was previously paused, in such a way that display updates continue.
Start | Starts a clock display assigned to the given clockId.
Stop | Permanently stops the clock from updating the display, and the clockId becomes free.

Remarks

Used together with the function parameter of the ControlClock method.

The members of this enumeration replace the ROD_CLK_START, ROD_CLK_PAUSE, ROD_CLK_RESUME, ROD_CLK_STOP, and ROD_CLK_MOVE UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
ControlClock


ClockMode Enumeration

ClockMode Enumeration |
 | See Also

1/18/2008

Enumerates the valid display formats for the clock.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration ClockMode
public enum ClockMode
public enum class ClockMode
public enum ClockMode
public enum ClockMode

Members

Member name | Description
Hours12 | Displays a 12 hour clock with "HH:MM:SS" format.
Hours24 | Displays a 24 hour clock with "HH:MM:SS" format.
Normal | Displays a clock with "MM:SS" format.
Short | Displays a clock with "M:SS" format.

Remarks

Used by the ControlClock method.

The members of this enumeration replace the ROD_CLK_SHORT, ROD_CLK_NORMAL, ROD_CLK_12_int, and ROD_CLK_24_int UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
ControlClock


CoinAcceptor Class

CoinAcceptor Class |
 | See Also Members

1/18/2008

Defines the programmatic interface of a UPOS Coin Acceptor device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class CoinAcceptor
    Inherits PosCommon
public abstract class CoinAcceptor : PosCommon
public ref class CoinAcceptor abstract : public PosCommon
public abstract class CoinAcceptor extends PosCommon
public abstract class CoinAcceptor extends PosCommon

Remarks

Capabilities

The Coin Acceptor can do the following:

  • Reports the cash units and corresponding unit counts available in the Coin Acceptor.

  • Reports the cash units and cash counts of the coins which are deposited into the device between the start and end of cash acceptance to the application.

  • Reports jam conditions within the device.

  • Supports more than one currency.

The Coin Acceptor may also have the following additional capabilities:

  • Reporting the fullness levels of the Coin Acceptor’s cash units. Conditions which may be indicated include full, and almost full states.

  • Reporting of a possible (or probable) cash count discrepancy in the data reported by the ReadCashCounts method.

The general model of a Coin Acceptor is as follows:

  • The Coin Acceptor device is set to support several coin denominations. The supported cash type for a particular currency is noted by the list of cash units in the DepositCashList property.

  • This specification provides programmatic control only for the accepting of cash. The removal of cash from the device, for example, removing deposited cash, is controlled by the AdjustCashCounts method, unless the device can determine the cash on its own. The application can call ReadCashCounts to retrieve the current unit count for each cash unit, but cannot control when or how cash is removed from the device.

  • The Coin Acceptor may be set to support more than one currency. The CurrencyCode property may be set to the currency, selecting from a currency in the list DepositCodeList. DepositCashList and ReadCashCounts all act upon the current currency only.

  • Set the cash slot (or cash bin) conditions in the FullStatus property to show full and almost full status. If there are one or more full cash slots, then FullStatus is Full.

  • Coin acceptance is started by invoking the BeginDeposit method. The previous values of the properties DepositCounts and DepositAmount are initialized to zero.

The total amount of cash put into the device continues to be accumulated until either the FixDeposit method or the PauseDeposit method is executed. When the FixDeposit method is executed, the total amount of accumulated cash is stored in the DepositCounts and DepositAmount properties. If the PauseDeposit method is executed with a parameter value of Pause, then the counting of the deposited cash is suspended and the current amount of accumulated cash is also updated to the DepositCounts and DepositAmount properties. When PauseDeposit method is executed with a parameter value of Restart, counting of deposited cash is resumed and added to the accumulated totals. When the FixDeposit method is executed, the current amount of accumulated cash is updated in the DepositCounts and DepositAmount properties, and the process remains static until the EndDeposit method is invoked by using a Complete parameter to complete the deposit.

  • When the ClearInput method is executed, the queued DataEvent associated with the receipt of cash is cleared. The DepositCounts and DepositAmount properties remain set and are not cleared.

Device Sharing

The Coin Acceptor is an exclusive-use device, as follows:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before accessing some properties, dispensing or collecting, or receiving events.

Platforms

The CoinAcceptor class requires POS for .NET version 1.11 or later versions.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.CoinAcceptor
Microsoft.PointOfService.BasicServiceObjects.CoinAcceptorBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinAcceptor Members
Microsoft.PointOfService Namespace


CoinAcceptor Members

CoinAcceptor Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface of a UPOS Coin Acceptor device.

The following tables list the members exposed by the CoinAcceptor type.

Protected Constructors

Name | Description
CoinAcceptor | Creates an instance of the CoinAcceptor class.
Top

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusFull | Indicates that the Coin Acceptor is full.
StatusFullOk | Indicates that the Coin Acceptor is no longer full.
StatusJam | Indicates that the Coin Acceptor is jammed.
StatusJamOk | Indicates that the Coin Acceptor is no longer jammed.
StatusNearFull | Indicates that the Coin Acceptor is almost full.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapDiscrepancy | Gets the Boolean value that indicates whether the ReadCashCounts method can report effective discrepancy values.
CapFullSensor | Gets the Boolean value that indicates whether the Coin Acceptor can report that some of its cash slots are full.
CapJamSensor | Gets the Boolean value that indicates whether the Coin Acceptor can report mechanical failures or jams.
CapNearFullSensor | Gets the Boolean value that indicates whether the Coin Acceptor can report that some cash slots are almost full.
CapPauseDeposit | Gets the Boolean value that indicates whether the Coin Acceptor can suspend cash acceptance processing.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapRealTimeData | Gets the Boolean value that indicates whether the device can supply data as money is being accepted.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
CurrencyCode | Gets or sets the active currency code to be used by Coin Acceptor operations.
DataCount | Gets the total number of currently queued DataEvent events at the service object.
DataEventEnabled | Gets or sets the Boolean value that indicates whether a DataEvent event is delivered when input data is queued.
DepositAmount | Gets the total amount of deposited cash.
DepositCashList | Gets the cash units supported in the Coin Acceptor for the currency represented by the CurrencyCode property.
DepositCodeList | Gets the currency code indicators for cash accepted.
DepositCounts | Gets the total of the cash accepted by the cash units
DepositStatus | Gets the current status of the coin acceptance operation.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
FullStatus | Gets the current full status of the cash slots.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
RealTimeDataEnabled | Gets or sets the Boolean value that indicates whether data is collected in real time.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets the Boolean value that indicates whether the Coin Acceptor is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
AdjustCashCounts | Sets the initial amounts in the Coin Acceptor after setup or adjusts cash counts after replenishment or removal.
BeginDeposit | Begins the cash acceptance process.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all device input that has been buffered.
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
EndDeposit | Indicates that the cash acceptance operation has been completed.
Equals | Overloaded. (inherited from Object )
FixDeposit | Updates property values to reflect the current values in the Coin Acceptor.
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon)
PauseDeposit | Suspends or resumes depositing cash.
ReadCashCounts | Returns the cash counts of all cash in the Coin Acceptor.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DataEvent | Notifies the application when one or more coins have been accepted.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

CoinAcceptor Class
Microsoft.PointOfService Namespace


CoinAcceptor Fields

CoinAcceptor Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusFull | Indicates that the Coin Acceptor is full.
StatusFullOk | Indicates that the Coin Acceptor is no longer full.
StatusJam | Indicates that the Coin Acceptor is jammed.
StatusJamOk | Indicates that the Coin Acceptor is no longer jammed.
StatusNearFull | Indicates that the Coin Acceptor is almost full.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

CoinAcceptor Class
Microsoft.PointOfService Namespace


CoinAcceptor.StatusFull Field

CoinAcceptor.StatusFull Field |
 | See Also

1/18/2008

Indicates that the Coin Acceptor is full.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusFull As Integer
public const int StatusFull
public:
literal int StatusFull
public static final int StatusFull
public const var StatusFull : int

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace


CoinAcceptor.StatusFullOk Field

CoinAcceptor.StatusFullOk Field |
 | See Also

1/18/2008

Indicates that the Coin Acceptor is no longer full.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusFullOk As Integer
public const int StatusFullOk
public:
literal int StatusFullOk
public static final int StatusFullOk
public const var StatusFullOk : int

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace


CoinAcceptor.StatusJam Field

CoinAcceptor.StatusJam Field |
 | See Also

1/18/2008

Indicates that the Coin Acceptor is jammed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusJam As Integer
public const int StatusJam
public:
literal int StatusJam
public static final int StatusJam
public const var StatusJam : int

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace


CoinAcceptor.StatusJamOk Field

CoinAcceptor.StatusJamOk Field |
 | See Also

1/18/2008

Indicates that the Coin Acceptor is no longer jammed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusJamOk As Integer
public const int StatusJamOk
public:
literal int StatusJamOk
public static final int StatusJamOk
public const var StatusJamOk : int

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace


CoinAcceptor.StatusNearFull Field

CoinAcceptor.StatusNearFull Field |
 | See Also

1/18/2008

Indicates that the Coin Acceptor is almost full.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusNearFull As Integer
public const int StatusNearFull
public:
literal int StatusNearFull
public static final int StatusNearFull
public const var StatusNearFull : int

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace


CoinAcceptor Constructor

CoinAcceptor Constructor |
 | See Also

1/18/2008

Creates an instance of the CoinAcceptor class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected CoinAcceptor ()
protected:
CoinAcceptor ()
protected CoinAcceptor ()
protected function CoinAcceptor ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace


CoinAcceptor Methods

CoinAcceptor Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
AdjustCashCounts | Sets the initial amounts in the Coin Acceptor after setup or adjusts cash counts after replenishment or removal.
BeginDeposit | Begins the cash acceptance process.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all device input that has been buffered.
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
EndDeposit | Indicates that the cash acceptance operation has been completed.
Equals | Overloaded. (inherited from Object )
FixDeposit | Updates property values to reflect the current values in the Coin Acceptor.
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon )
PauseDeposit | Suspends or resumes depositing cash.
ReadCashCounts | Returns the cash counts of all cash in the Coin Acceptor.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

CoinAcceptor Class
Microsoft.PointOfService Namespace


CoinAcceptor.AdjustCashCounts Method

CoinAcceptor.AdjustCashCounts Method |
 | See Also

1/18/2008

Sets the initial amounts in the Coin Acceptor after setup or adjusts cash counts after replenishment or removal.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub AdjustCashCounts ( _
    cashCounts As IEnumerable(Of CashCount) _
)
public abstract void AdjustCashCounts (
    IEnumerable<CashCount> cashCounts
)
public:
virtual void AdjustCashCounts (
    IEnumerable<CashCount>^ cashCounts
) abstract
public abstract void AdjustCashCounts (
    IEnumerable<CashCount> cashCounts
)
public abstract function AdjustCashCounts (
    cashCounts : IEnumerable<CashCount>
)

Parameters

cashCounts

The cashCounts parameter contains cash types and amounts to be initialized.

Remarks

This method is called to set the initial amounts in the Coin Acceptor after initial setup or to adjust cash counts after replenishment or removal, such as a paid-in or paid-out operation. Typically, this method is used by devices which cannot determine the exact amount of cash in them automatically. If the device can determine the exact amount, then this method call is ignored.

The application typically first calls ReadCashCounts for the current counts, then calls this method to adjust them to the amount currently in the acceptor.

To reset all cash counts to zero, set each denomination amount to 0 (zero).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace
ReadCashCounts


CoinAcceptor.BeginDeposit Method

CoinAcceptor.BeginDeposit Method |
 | See Also

1/18/2008

Begins the cash acceptance process.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub BeginDeposit
public abstract void BeginDeposit ()
public:
virtual void BeginDeposit () abstract
public abstract void BeginDeposit ()
public abstract function BeginDeposit ()

Remarks

The following property values are initialized when this method is called:

  • The value of each cash unit held by the DepositCounts property is set to zero.

  • The DepositAmount property is set to zero.

After it calls this method, cash acceptance is reported by DataEvents until

FixDeposit is called while the deposit process is not paused.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace
DepositAmount
DepositCounts
EndDeposit
FixDeposit
PauseDeposit


CoinAcceptor.ClearInput Method

CoinAcceptor.ClearInput Method |
 | See Also

1/18/2008

Clears all device input that has been buffered.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearInput
public abstract void ClearInput ()
public:
virtual void ClearInput () abstract
public abstract void ClearInput ()
public abstract function ClearInput ()

Remarks

Any data events or input error events that are queued, usually waiting for DataEventEnabled to be set to true and FreezeEventsto be set to false, are also cleared.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace


CoinAcceptor.EndDeposit Method

CoinAcceptor.EndDeposit Method |
 | See Also

1/18/2008

Indicates that the cash acceptance operation has been completed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub EndDeposit ( _
    success As EndDepositAction _
)
public abstract void EndDeposit (
    EndDepositAction success
)
public:
virtual void EndDeposit (
    EndDepositAction success
) abstract
public abstract void EndDeposit (
    EndDepositAction success
)
public abstract function EndDeposit (
    success : EndDepositAction
)

Parameters

success

The deposit is accepted and the deposited amount is equal to or less than the amount required.

Remarks

Before it calls this method, the application must calculate the difference between the deposit and the required amount.

The application must call the FixDeposit method before it calls this method, or an exception is thrown with an ErrorCode value of Illegal.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace
DepositAmount
DepositCounts
CoinAcceptor.BeginDeposit Method
FixDeposit
PauseDeposit


CoinAcceptor.FixDeposit Method

CoinAcceptor.FixDeposit Method |
 | See Also

1/18/2008

Updates property values to reflect the current values in the Coin Acceptor.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub FixDeposit
public abstract void FixDeposit ()
public:
virtual void FixDeposit () abstract
public abstract void FixDeposit ()
public abstract function FixDeposit ()

Remarks

When this method is called, all property values are updated to reflect the current values in the Coin Acceptor.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace
DepositAmount
DepositCounts
CoinAcceptor.BeginDeposit Method
CoinAcceptor.EndDeposit Method
PauseDeposit


CoinAcceptor.PauseDeposit Method

CoinAcceptor.PauseDeposit Method |
 | See Also

1/18/2008

Suspends or resumes depositing cash.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PauseDeposit ( _
    control As CashDepositPause _
)
public abstract void PauseDeposit (
    CashDepositPause control
)
public:
virtual void PauseDeposit (
    CashDepositPause control
) abstract
public abstract void PauseDeposit (
    CashDepositPause control
)
public abstract function PauseDeposit (
    control : CashDepositPause
)

Parameters

control

Indicates whether the coin acceptance process will be paused or restarted. If the value of this parameter is Pause, acceptance will be paused. If the value is Restart, cash acceptance will resume.

Remarks

Called to suspend or resume depositing cash. If the value of control is Pause, the cash acceptance operation becomes paused. As soon as paused, the deposit process remains paused until this method is called again with Restart as the parameter value. This will cause the process to be resumed.

It is valid to call the FixDeposit method, then the EndDeposit method, while the deposit process is paused.

When the deposit process is paused, the DepositCounts and DepositAmount properties are updated to reflect the current state of the Coin Acceptor. The property values are not changed again until the deposit process is resumed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace


CoinAcceptor.ReadCashCounts Method

CoinAcceptor.ReadCashCounts Method |
 | See Also

1/18/2008

Returns the cash counts of all cash in the Coin Acceptor.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function ReadCashCounts As CashCounts
public abstract CashCounts ReadCashCounts ()
public:
virtual CashCounts ReadCashCounts () abstract
public abstract CashCounts ReadCashCounts ()
public abstract function ReadCashCounts () : CashCounts

Remarks

Each unit in CashCounts matches a unit in the DepositCashList property, and is in the same order.

Typically, the cash total returned in the CashCounts parameter is equal to the cash total in a Coin Acceptor, although there are some cases in which a discrepancy may occur because of existing uncountable cash in a Coin Acceptor. An example would be when a cash slot is "overflowing" in such a way that the device has lost its ability to accurately detect and monitor the cash.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace
DepositCashList


CoinAcceptor Properties

CoinAcceptor Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapDiscrepancy | Gets the Boolean value that indicates whether the ReadCashCounts method can report effective discrepancy values.
CapFullSensor | Gets the Boolean value that indicates whether the Coin Acceptor can report that some of its cash slots are full.
CapJamSensor | Gets the Boolean value that indicates whether the Coin Acceptor can report mechanical failures or jams.
CapNearFullSensor | Gets the Boolean value that indicates whether the Coin Acceptor can report that some cash slots are almost full.
CapPauseDeposit | Gets the Boolean value that indicates whether the Coin Acceptor can suspend cash acceptance processing.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapRealTimeData | Gets the Boolean value that indicates whether the device can supply data as money is being accepted.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
CurrencyCode | Gets or sets the active currency code to be used by Coin Acceptor operations.
DataCount | Gets the total number of currently queued DataEvent events at the service object.
DataEventEnabled | Gets or sets the Boolean value that indicates whether a DataEvent event is delivered when input data is queued.
DepositAmount | Gets the total amount of deposited cash.
DepositCashList | Gets the cash units supported in the Coin Acceptor for the currency represented by the CurrencyCode property.
DepositCodeList | Gets the currency code indicators for cash accepted.
DepositCounts | Gets the total of the cash accepted by the cash units
DepositStatus | Gets the current status of the coin acceptance operation.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
FullStatus | Gets the current full status of the cash slots.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
RealTimeDataEnabled | Gets or sets the Boolean value that indicates whether data is collected in real time.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets the Boolean value that indicates whether the Coin Acceptor is an exclusive-use device.

See Also

Reference

CoinAcceptor Class
Microsoft.PointOfService Namespace


CoinAcceptor.CapDiscrepancy Property

CoinAcceptor.CapDiscrepancy Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the ReadCashCounts method can report effective discrepancy values.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapDiscrepancy As Boolean
public abstract bool CapDiscrepancy { get; }
public:
virtual property bool CapDiscrepancy {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapDiscrepancy ()

public abstract function get CapDiscrepancy () : boolean

Remarks

If true, the ReadCashCounts method can report effective discrepancy values.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace
CoinAcceptor.ReadCashCounts Method


CoinAcceptor.CapFullSensor Property

CoinAcceptor.CapFullSensor Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the Coin Acceptor can report that some of its cash slots are full.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapFullSensor As Boolean
public abstract bool CapFullSensor { get; }
public:
virtual property bool CapFullSensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapFullSensor ()

public abstract function get CapFullSensor () : boolean

Remarks

If true, the Coin Acceptor can report the condition that some cash slots are full.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace
FullStatus


CoinAcceptor.CapJamSensor Property

CoinAcceptor.CapJamSensor Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the Coin Acceptor can report mechanical failures or jams.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapJamSensor As Boolean
public abstract bool CapJamSensor { get; }
public:
virtual property bool CapJamSensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapJamSensor ()

public abstract function get CapJamSensor () : boolean

Remarks

If true, the Coin Acceptor can report a mechanical jam or failure condition.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace


CoinAcceptor.CapNearFullSensor Property

CoinAcceptor.CapNearFullSensor Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the Coin Acceptor can report that some cash slots are almost full.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapNearFullSensor As Boolean
public abstract bool CapNearFullSensor { get; }
public:
virtual property bool CapNearFullSensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapNearFullSensor ()

public abstract function get CapNearFullSensor () : boolean

Remarks

If true, the Coin Acceptor can report the condition that some cash slots are almost full.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace
FullStatus


CoinAcceptor.CapPauseDeposit Property

CoinAcceptor.CapPauseDeposit Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the Coin Acceptor can suspend cash acceptance processing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapPauseDeposit As Boolean
public abstract bool CapPauseDeposit { get; }
public:
virtual property bool CapPauseDeposit {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapPauseDeposit ()

public abstract function get CapPauseDeposit () : boolean

Remarks

If true, the Coin Acceptor can suspend cash acceptance processing temporarily.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace
CoinAcceptor.PauseDeposit Method


CoinAcceptor.CapRealTimeData Property

CoinAcceptor.CapRealTimeData Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the device can supply data as money is being accepted.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRealTimeData As Boolean
public abstract bool CapRealTimeData { get; }
public:
virtual property bool CapRealTimeData {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRealTimeData ()

public abstract function get CapRealTimeData () : boolean

Remarks

If true, the device can supply data as the money is being accepted ("real time").

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace
RealTimeDataEnabled


CoinAcceptor.CurrencyCode Property

CoinAcceptor.CurrencyCode Property |
 | See Also

1/18/2008

Gets or sets the active currency code to be used by Coin Acceptor operations.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property CurrencyCode As String
public abstract string CurrencyCode { get; set; }
public:
virtual property String^ CurrencyCode {
    String^ get () abstract;
    void set (String^ value) abstract;
}
/** @property */
public abstract String get_CurrencyCode ()

/** @property */
public abstract void set_CurrencyCode (String value)

public abstract function get CurrencyCode () : String

public abstract function set CurrencyCode (value : String)

Remarks

Contains the active currency code to be used by Coin Acceptor operations.

This property is initialized to an appropriate value by the Open method. This value is guaranteed to be one of the set of currencies specified by the DepositCodeList property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace
DepositCodeList


CoinAcceptor.DataCount Property

CoinAcceptor.DataCount Property |
 | See Also

1/18/2008

Gets the total number of currently queued DataEvent events at the service object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DataCount As Integer
public abstract int DataCount { get; }
public:
virtual property int DataCount {
    int get () abstract;
}
/** @property */
public abstract int get_DataCount ()

public abstract function get DataCount () : int

Remarks

Indicates the total number of currently queued DataEvent events at the service object. All online units are included in this value.

The application can interrogate DataCount to determine whether additional input is queued from a device but has not yet been delivered because of other application processing, freezing of events, or other causes.

DataCount is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace
DataEvent


CoinAcceptor.DataEventEnabled Property

CoinAcceptor.DataEventEnabled Property |
 | See Also

1/18/2008

Gets or sets the Boolean value that indicates whether a DataEvent event is delivered when input data is queued.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property DataEventEnabled As Boolean
public abstract bool DataEventEnabled { get; set; }
public:
virtual property bool DataEventEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_DataEventEnabled ()

/** @property */
public abstract void set_DataEventEnabled (boolean value)

public abstract function get DataEventEnabled () : boolean

public abstract function set DataEventEnabled (value : boolean)

Remarks

If true, a DataEvent is delivered as soon as input data is queued. If this property is changed to true while input data is already in the queue, a DataEvent event is delivered immediately. This event may be delayed if FreezeEvents is true or if another event is already being processed at the application. In this case, the DataEvent remains queued until it can be processed.

If false, input data is queued for later delivery to the application. Also, if an input error occurs, the ErrorEvent is not delivered while DataEventEnabled is false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace
DataEvent


CoinAcceptor.DepositAmount Property

CoinAcceptor.DepositAmount Property |
 | See Also

1/18/2008

Gets the total amount of deposited cash.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DepositAmount As Integer
public abstract int DepositAmount { get; }
public:
virtual property int DepositAmount {
    int get () abstract;
}
/** @property */
public abstract int get_DepositAmount ()

public abstract function get DepositAmount () : int

Remarks

Holds the total amount of deposited cash.

For example, if the currency is Japanese yen and DepositAmount is set to 18057, after the call to the BeginDeposit method, there would be 18,057 yen in the Coin Acceptor.

This property is initialized to 0 (zero) by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace
CoinAcceptor.CurrencyCode Property


CoinAcceptor.DepositCashList Property

CoinAcceptor.DepositCashList Property |
 | See Also

1/18/2008

Gets the cash units supported in the Coin Acceptor for the currency represented by the CurrencyCode property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DepositCashList As CashUnits
public abstract CashUnits DepositCashList { get; }
public:
virtual property CashUnits DepositCashList {
    CashUnits get () abstract;
}
/** @property */
public abstract CashUnits get_DepositCashList ()

public abstract function get DepositCashList () : CashUnits

Remarks

Holds the cash units supported in the Coin Acceptor for the currency represented by the CurrencyCode property.

Currency totals are contained in a pair of integer arrays that represent the number of bills and coins in the device.

This property is initialized by the Open method, and is updated when CurrencyCode is set.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace
CoinAcceptor.CurrencyCode Property


CoinAcceptor.DepositCodeList Property

CoinAcceptor.DepositCodeList Property |
 | See Also

1/18/2008

Gets the currency code indicators for cash accepted.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DepositCodeList As String()
public abstract string[] DepositCodeList { get; }
public:
virtual property array<String^>^ DepositCodeList {
    array<String^>^ get () abstract;
}
/** @property */
public abstract String[] get_DepositCodeList ()

public abstract function get DepositCodeList () : String[]

Remarks

Holds the currency code indicators for cash accepted.

It is a list of ASCII 3-character ISO 4217 currency codes, separated by commas.

For example, if the string is "JPY,USD", then the Coin Acceptor supports both Japanese and U.S. monetary units.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace
CoinAcceptor.CurrencyCode Property


CoinAcceptor.DepositCounts Property

CoinAcceptor.DepositCounts Property |
 | See Also

1/18/2008

Gets the total of the cash accepted by the cash units

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DepositCounts As CashCount()
public abstract CashCount[] DepositCounts { get; }
public:
virtual property array<CashCount>^ DepositCounts {
    array<CashCount>^ get () abstract;
}
/** @property */
public abstract CashCount[] get_DepositCounts ()

public abstract function get DepositCounts () : CashCount[]

Remarks

Holds the total of the cash accepted by the cash units.

CashCount currency totals are contained in a pair of integer arrays that represent the number of bills and coins in the device.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace
CoinAcceptor.CurrencyCode Property


CoinAcceptor.DepositStatus Property

CoinAcceptor.DepositStatus Property |
 | See Also

1/18/2008

Gets the current status of the coin acceptance operation.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DepositStatus As DepositStatus
public abstract DepositStatus DepositStatus { get; }
public:
virtual property DepositStatus DepositStatus {
    DepositStatus get () abstract;
}
/** @property */
public abstract DepositStatus get_DepositStatus ()

public abstract function get DepositStatus () : DepositStatus

Remarks

Holds the current status of the coin acceptance operation. It may be one of the

following values.

Value | Meaning
Start | Cash acceptance has started.
End | Cash acceptance has ended.
Count | The deposited money is being counted or repaid.
Jam | A mechanical fault has occurred.

This property is initialized and kept current while the device is enabled.

After initialization, this property is set to End.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace


CoinAcceptor.FullStatus Property

CoinAcceptor.FullStatus Property |
 | See Also

1/18/2008

Gets the current full status of the cash slots.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property FullStatus As CashChangerFullStatus
public abstract CashChangerFullStatus FullStatus { get; }
public:
virtual property CashChangerFullStatus FullStatus {
    CashChangerFullStatus get () abstract;
}
/** @property */
public abstract CashChangerFullStatus get_FullStatus ()

public abstract function get FullStatus () : CashChangerFullStatus

Remarks

Holds the current full status of the cash slots. It may be one of the following values.

Value | Meaning
Ok | None of the cash slots are full or almost full.
Full | Some cash slots are full.
NearFull | Some cash slots are almost full.

This property is initialized and kept current while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace


CoinAcceptor.IsExclusiveUseDevice Property

CoinAcceptor.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the Coin Acceptor is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Property Value

A value of true indicates the fiscal printer is an exclusive-use device. Otherwise, the value will be false.

Remarks

An exclusive-use device has the following properties:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before accessing some properties or calling methods that update the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace


CoinAcceptor.RealTimeDataEnabled Property

CoinAcceptor.RealTimeDataEnabled Property |
 | See Also

1/18/2008

Gets or sets the Boolean value that indicates whether data is collected in real time.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property RealTimeDataEnabled As Boolean
public abstract bool RealTimeDataEnabled { get; set; }
public:
virtual property bool RealTimeDataEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_RealTimeDataEnabled ()

/** @property */
public abstract void set_RealTimeDataEnabled (boolean value)

public abstract function get RealTimeDataEnabled () : boolean

public abstract function set RealTimeDataEnabled (value : boolean)

Remarks

If true, each data event fired updates the DepositAmount and DepositCounts properties. Otherwise, DepositAmount and DepositCounts are updated with the value of the money collected when FixDeposit is called. Setting RealTimeDataEnabled doesl not cause any change in system behavior until a later BeginDeposit method is performed. This prevents confusion about what would occur if it were modified between a BeginDeposit - EndDeposit pairing.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace
CoinAcceptor.CapRealTimeData Property
CoinAcceptor.DepositAmount Property
CoinAcceptor.DepositCounts Property
CoinAcceptor.BeginDeposit Method
CoinAcceptor.EndDeposit Method
CoinAcceptor.FixDeposit Method


CoinAcceptor Events

CoinAcceptor Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DataEvent | Notifies the application when one or more coins have been accepted.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

CoinAcceptor Class
Microsoft.PointOfService Namespace


CoinAcceptor.DataEvent Event

CoinAcceptor.DataEvent Event |
 | See Also

1/18/2008

Notifies the application when one or more coins have been accepted.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event DataEvent As DataEventHandler
public abstract event DataEventHandler DataEvent
public:
virtual event DataEventHandler^ DataEvent {
    void add (DataEventHandler^ value) abstract;
    void remove (DataEventHandler^ value) abstract;
}
/** @event */
public abstract void add_DataEvent (DataEventHandler value)

/** @event */
public abstract void remove_DataEvent (DataEventHandler value)

See Also

Reference

CoinAcceptor Class
CoinAcceptor Members
Microsoft.PointOfService Namespace


CoinDispenser Class

CoinDispenser Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a UPOS Coin Dispenserdevice.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class CoinDispenser
    Inherits PosCommon
public abstract class CoinDispenser : PosCommon
public ref class CoinDispenser abstract : public PosCommon
public abstract class CoinDispenser extends PosCommon
public abstract class CoinDispenser extends PosCommon

Remarks

Capabilities

Coin Dispenser devices support a method to dispense a specified amount of coins. A Coin Dispenser device may also support status reporting to indicate an empty or near-empty coin slot, discrepancies in reported data, or a jammed coin slot condition.

Model

A coin dispenser has several coin slots that hold coins to dispense. When you write code for a coin dispenser, you are not concerned with controlling individual coin slots; instead, you call the DispenseChange method with the change to dispense. It is the responsibility of the coin dispenser or the service object to dispense the correct amount of change from the various slots.

Cash is set in the device programmatically by adding amount to counts when cash is added. The coin dispenser then reads cash counts from device, either directly from the hardware or from the service, by tracking what has been dispensed and what has been added to the device.

Device Sharing

The coin dispenser is an exclusive-use device. Its device-sharing rules are as follows:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before accessing some properties, dispensing change, or receiving status update events.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.CoinDispenser
Microsoft.PointOfService.BasicServiceObjects.CoinDispenserBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinDispenser Members
Microsoft.PointOfService Namespace


CoinDispenser Members

CoinDispenser Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a UPOS Coin Dispenserdevice.

The following tables list the members exposed by the CoinDispenser type.

Protected Constructors

Name | Description
CoinDispenser | Creates an instance of the CoinDispenser class.
Top

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusEmpty | Indicates the Coin Dispenser device cannot dispense coins because it is empty.
StatusJam | Indicates a mechanical fault has occurred in the Coin Dispenser device.
StatusNearEmpty | Indicates the Coin Dispenser device can still dispense coins, but the device is almost empty.
StatusOk | Indicates the Coin Dispenser device is ready to dispense coins, or the device is unable to detect an error condition.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapEmptySensor | Gets the Boolean value that indicates whether the device can support an out-of-coins condition.
CapJamSensor | Gets the Boolean value that indicates whether the Coin Dispenser device can report a mechanical jam or failure condition.
CapNearEmptySensor | Gets the Boolean value that indicates whether the Coin Dispenser device can report when it is almost out of coins.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
DispenserStatus | Gets the current status of the dispenser.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets the Boolean value that indicates whether the Coin Dispenser device is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
AdjustCashCounts | Sets initial amounts in the Coin Dispenser after initial setup or adjusts cash counts after replenishment or removal.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
DispenseChange | Indicates a count of the coins it dispenses.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon)
ReadCashCounts | Reads the currency totals contained in the device.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

CoinDispenser Class
Microsoft.PointOfService Namespace


CoinDispenser Fields

CoinDispenser Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusEmpty | Indicates the Coin Dispenser device cannot dispense coins because it is empty.
StatusJam | Indicates a mechanical fault has occurred in the Coin Dispenser device.
StatusNearEmpty | Indicates the Coin Dispenser device can still dispense coins, but the device is almost empty.
StatusOk | Indicates the Coin Dispenser device is ready to dispense coins, or the device is unable to detect an error condition.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

CoinDispenser Class
Microsoft.PointOfService Namespace


CoinDispenser.StatusEmpty Field

CoinDispenser.StatusEmpty Field |
 | See Also

1/18/2008

Indicates the Coin Dispenser device cannot dispense coins because it is empty.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusEmpty As Integer
public const int StatusEmpty
public:
literal int StatusEmpty
public static final int StatusEmpty
public const var StatusEmpty : int

Remarks

This field replaces the COIN_STATUS_EMPTY constant used by UPOS.

See Also

Reference

CoinDispenser Class
CoinDispenser Members
Microsoft.PointOfService Namespace


CoinDispenser.StatusJam Field

CoinDispenser.StatusJam Field |
 | See Also

1/18/2008

Indicates a mechanical fault has occurred in the Coin Dispenser device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusJam As Integer
public const int StatusJam
public:
literal int StatusJam
public static final int StatusJam
public const var StatusJam : int

Remarks

The value of this field indicates that a mechanical fault has occurred in the coin dispenser.

This field replaces the COIN_STATUS_JAM constant used by UPOS.

See Also

Reference

CoinDispenser Class
CoinDispenser Members
Microsoft.PointOfService Namespace


CoinDispenser.StatusNearEmpty Field

CoinDispenser.StatusNearEmpty Field |
 | See Also

1/18/2008

Indicates the Coin Dispenser device can still dispense coins, but the device is almost empty.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusNearEmpty As Integer
public const int StatusNearEmpty
public:
literal int StatusNearEmpty
public static final int StatusNearEmpty
public const var StatusNearEmpty : int

Remarks

The value of this field indicates that the coin dispenser device can still dispense coins, but that the device is almost empty.

This field replaces COIN_STATUS_NEAREMPTY constant used by UPOS.

See Also

Reference

CoinDispenser Class
CoinDispenser Members
Microsoft.PointOfService Namespace


CoinDispenser.StatusOk Field

CoinDispenser.StatusOk Field |
 | See Also

1/18/2008

Indicates the Coin Dispenser device is ready to dispense coins, or the device is unable to detect an error condition.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusOk As Integer
public const int StatusOk
public:
literal int StatusOk
public static final int StatusOk
public const var StatusOk : int

Remarks

The value of this field indicates that the coin dispenser is ready to dispense coins or is unable to detect any error conditions.

This field replaces the COIN_STATUS_OK constant used by UPOS.

See Also

Reference

CoinDispenser Class
CoinDispenser Members
Microsoft.PointOfService Namespace


CoinDispenser Constructor

CoinDispenser Constructor |
 | See Also

1/18/2008

Creates an instance of the CoinDispenser class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected CoinDispenser ()
protected:
CoinDispenser ()
protected CoinDispenser ()
protected function CoinDispenser ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

CoinDispenser Class
CoinDispenser Members
Microsoft.PointOfService Namespace


CoinDispenser Methods

CoinDispenser Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
AdjustCashCounts | Sets initial amounts in the Coin Dispenser after initial setup or adjusts cash counts after replenishment or removal.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
DispenseChange | Indicates a count of the coins it dispenses.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon )
ReadCashCounts | Reads the currency totals contained in the device.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

CoinDispenser Class
Microsoft.PointOfService Namespace


CoinDispenser.AdjustCashCounts Method

CoinDispenser.AdjustCashCounts Method |
 | See Also

1/18/2008

Sets initial amounts in the Coin Dispenser after initial setup or adjusts cash counts after replenishment or removal.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Sub AdjustCashCounts ( _
    cashCounts As IEnumerable(Of CashCount) _
)
public virtual void AdjustCashCounts (
    IEnumerable<CashCount> cashCounts
)
public:
virtual void AdjustCashCounts (
    IEnumerable<CashCount>^ cashCounts
)
public void AdjustCashCounts (
    IEnumerable<CashCount> cashCounts
)
public function AdjustCashCounts (
    cashCounts : IEnumerable<CashCount>
)

Parameters

cashCounts

Contains cash types and amounts to be initialized.

Remarks

This method is called to set the initial amounts in the Coin Dispenser after initial setup, or to adjust cash counts after replenishment or removal, such as a paid-in or paid-out operation.

This method is called when it is necessary for devices which cannot determine the exact amount of cash in them automatically. If the device can determine the exact amount, then this method call is ignored.

The application would first call ReadCashCounts to get the current counts, and adjust them to the amount being replenished. Then the application calls this method to set the amount currently in the dispenser.

To reset all cash counts to 0 (zero), set each denomination amount to 0 (zero).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinDispenser Class
CoinDispenser Members
Microsoft.PointOfService Namespace
CashChanger.ReadCashCounts Method
CashCounts Structure


CoinDispenser.DispenseChange Method

CoinDispenser.DispenseChange Method |
 | See Also

1/18/2008

Indicates a count of the coins it dispenses.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub DispenseChange ( _
    amount As Integer _
)
public abstract void DispenseChange (
    int amount
)
public:
virtual void DispenseChange (
    int amount
) abstract
public abstract void DispenseChange (
    int amount
)
public abstract function DispenseChange (
    amount : int
)

Parameters

amount

A count of the currency units to dispense (such as cents or yen).

Remarks

DispenseChange may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Illegal | An amount parameter value of 0 (zero) was specified, or the amount parameter contained a negative value or a value greater than the device can dispense.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinDispenser Class
CoinDispenser Members
Microsoft.PointOfService Namespace


CoinDispenser.ReadCashCounts Method

CoinDispenser.ReadCashCounts Method |
 | See Also

1/18/2008

Reads the currency totals contained in the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Function ReadCashCounts As CashCounts
public virtual CashCounts ReadCashCounts ()
public:
virtual CashCounts ReadCashCounts ()
public CashCounts ReadCashCounts ()
public function ReadCashCounts () : CashCounts

Remarks

Currency totals are contained in a pair of integer arrays that represent the number of bills and coins in the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinDispenser Class
CoinDispenser Members
Microsoft.PointOfService Namespace
CashCounts Structure


CoinDispenser Properties

CoinDispenser Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapEmptySensor | Gets the Boolean value that indicates whether the device can support an out-of-coins condition.
CapJamSensor | Gets the Boolean value that indicates whether the Coin Dispenser device can report a mechanical jam or failure condition.
CapNearEmptySensor | Gets the Boolean value that indicates whether the Coin Dispenser device can report when it is almost out of coins.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
DispenserStatus | Gets the current status of the dispenser.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets the Boolean value that indicates whether the Coin Dispenser device is an exclusive-use device.

See Also

Reference

CoinDispenser Class
Microsoft.PointOfService Namespace


CoinDispenser.CapEmptySensor Property

CoinDispenser.CapEmptySensor Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the device can support an out-of-coins condition.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapEmptySensor As Boolean
public abstract bool CapEmptySensor { get; }
public:
virtual property bool CapEmptySensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapEmptySensor ()

public abstract function get CapEmptySensor () : boolean

Remarks

If true, the coin dispenser can report an out-of-coins condition; otherwise, false.

CapEmptySensor is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinDispenser Class
CoinDispenser Members
Microsoft.PointOfService Namespace


CoinDispenser.CapJamSensor Property

CoinDispenser.CapJamSensor Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the Coin Dispenser device can report a mechanical jam or failure condition.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapJamSensor As Boolean
public abstract bool CapJamSensor { get; }
public:
virtual property bool CapJamSensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapJamSensor ()

public abstract function get CapJamSensor () : boolean

Remarks

If true, the coin dispenser can report a mechanical jam or failure condition; otherwise, false.

CapJamSensor is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinDispenser Class
CoinDispenser Members
Microsoft.PointOfService Namespace


CoinDispenser.CapNearEmptySensor Property

CoinDispenser.CapNearEmptySensor Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the Coin Dispenser device can report when it is almost out of coins.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapNearEmptySensor As Boolean
public abstract bool CapNearEmptySensor { get; }
public:
virtual property bool CapNearEmptySensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapNearEmptySensor ()

public abstract function get CapNearEmptySensor () : boolean

Remarks

If true, the coin dispenser can report when it is almost out of coins; otherwise, false.

CapNearEmptySensor is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinDispenser Class
CoinDispenser Members
Microsoft.PointOfService Namespace


CoinDispenser.DispenserStatus Property

CoinDispenser.DispenserStatus Property |
 | See Also

1/18/2008

Gets the current status of the dispenser.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DispenserStatus As CoinDispenserStatus
public abstract CoinDispenserStatus DispenserStatus { get; }
public:
virtual property CoinDispenserStatus DispenserStatus {
    CoinDispenserStatus get () abstract;
}
/** @property */
public abstract CoinDispenserStatus get_DispenserStatus ()

public abstract function get DispenserStatus () : CoinDispenserStatus

Remarks

Contains the current status of the dispenser. as defined by the CoinDispenserStatus enumeration.

DispenserStatus is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinDispenser Class
CoinDispenser Members
Microsoft.PointOfService Namespace
CoinDispenserStatus


CoinDispenser.IsExclusiveUseDevice Property

CoinDispenser.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the Coin Dispenser device is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Property Value

A value of true indicates the fiscal printer is an exclusive-use device. Otherwise, the value will be false.

Remarks

An exclusive-use device has the following properties:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before accessing some properties or calling methods that update the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CoinDispenser Class
CoinDispenser Members
Microsoft.PointOfService Namespace
Claim
DeviceEnabled


CoinDispenser Events

CoinDispenser Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

CoinDispenser Class
Microsoft.PointOfService Namespace


CoinDispenserStatus Enumeration

CoinDispenserStatus Enumeration |
 | See Also

1/18/2008

Enumerates the valid states of the coin dispenser device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration CoinDispenserStatus
public enum CoinDispenserStatus
public enum class CoinDispenserStatus
public enum CoinDispenserStatus
public enum CoinDispenserStatus

Members

Member name | Description
Empty | Cannot dispense coins because the dispenser is empty.
Jam | A mechanical fault has occurred.
NearEmpty | Can dispense coins, but the dispenser is almost empty.
OK | Ready to dispense coins. This value is also set when the dispenser is unable to detect an error condition.

Remarks

Used by the DispenserStatus property. The members of this enumeration replace the COIN_STATUS_OK, COIN_STATUS_EMPTY, COIN_STATUS_NEAREMPTY, and COIN_STATUS_JAM constants used by UPOS.

See Also

Reference

Microsoft.PointOfService Namespace
CoinDispenser.DispenserStatus Property


CompareFirmwareResult Enumeration

CompareFirmwareResult Enumeration |
 | See Also

1/18/2008

Enumerates the valid comparison results between firmware files.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration CompareFirmwareResult
public enum CompareFirmwareResult
public enum class CompareFirmwareResult
public enum CompareFirmwareResult
public enum CompareFirmwareResult

Members

Member name | Description
Different | Indicates that the version of one or more of the firmware files is different than the firmware in the device, but either:
Newer | Indicates that the version of one or more of the firmware files is newer than the firmware in the device and that none of the firmware files is older than the firmware in the device.
Older | Indicates that the version of one or more of the firmware files is older than the firmware in the device and that none of the firmware files is newer than the firmware in the device.
Same | Indicates that the versions of all of the firmware files are the same as the firmware in the device.
Unknown | Indicates that a relationship between the two firmware versions could not be determined. A possible reason for this result could be an attempt to compare Japanese and US versions of firmware.

Remarks

Used by the CompareFirmwareVersion method. Members of this enumeration replace the CFV_FIRMWARE_OLDER, CFV_FIRMWARE_SAME, CFV_FIRMWARE_NEWER, CFV_FIRMWARE_DIFFERENT, and CFV_FIRMWARE_UNKNOWN UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace


ControlState Enumeration

ControlState Enumeration |
 | See Also

1/18/2008

Enumerates the valid states of a device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration ControlState
public enum ControlState
public enum class ControlState
public enum ControlState
public enum ControlState

Members

Member name | Description
Busy | The device is in a good state and is busy performing output.
Closed | The device is closed. The service object is not initialized.
Error | An error has been reported, and the application must recover the Control to a good state before normal I/O can resume.
Idle | The device is in a good state and is not busy.

Remarks

Used by the State property. The members of this enumeration replace the S_CLOSED, S_IDLE, S_BUSY, and S_ERROR UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
State


CreditTransactionType Enumeration

CreditTransactionType Enumeration |
 | See Also

1/18/2008

Enumerates the valid transaction types for an authorization operation.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration CreditTransactionType
public enum CreditTransactionType
public enum class CreditTransactionType
public enum CreditTransactionType
public enum CreditTransactionType

Members

Member name | Description
CashDeposit | Card check.
CheckCard | Purchase after approval.
Completion | Preauthorization.
PreSales | Refund purchase.
Refund | Sales.
Sales | Cancellation.
Void | Cancel preauthorization approval.
VoidPreSales | Charge.

Remarks

Used by the TransactionType property. The members of this enumeration replace the CAT_TRANSACTION_ family of UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
Cat.TransactionType Property


DataEventArgs Class

DataEventArgs Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for the transmission of Data Events.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Class DataEventArgs
    Inherits PosEventArgs
public class DataEventArgs : PosEventArgs
public ref class DataEventArgs : public PosEventArgs
public class DataEventArgs extends PosEventArgs
public class DataEventArgs extends PosEventArgs

Remarks

Holds event data for DataEvent events.

Inheritance Hierarchy

System.Object
System.EventArgs
Microsoft.PointOfService.PosEventArgs
Microsoft.PointOfService.DataEventArgs
Microsoft.PointOfService.BaseServiceObjects.RFIDDataEventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DataEventArgs Members
Microsoft.PointOfService Namespace


DataEventArgs Members

DataEventArgs Members |
 | See Also Constructors Fields Methods Properties

1/18/2008

Defines the programmatic interface for the transmission of Data Events.

The following tables list the members exposed by the DataEventArgs type.

Public Constructors

Name | Description
DataEventArgs | Creates an instance of the DataEventArgs class by using device input status.
Top

Public Fields

Name | Description
Empty | (inherited from EventArgs )
Top

Public Properties

Name | Description
EventId | Gets the event identifier. (inherited from PosEventArgs)
Status | Gets the integer value for the device input status.
TimeStamp | Gets the DateTime of the event. (inherited from PosEventArgs)
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Overridden. Returns a string that represents the input status.
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
SetStatus | Sets the device input status.
Top

See Also

Reference

DataEventArgs Class
Microsoft.PointOfService Namespace


DataEventArgs Fields

DataEventArgs Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
Empty | (inherited from EventArgs )

See Also

Reference

DataEventArgs Class
Microsoft.PointOfService Namespace


DataEventArgs Constructor

DataEventArgs Constructor |
 | See Also

1/18/2008

Creates an instance of the DataEventArgs class by using device input status.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    status As Integer _
)
public DataEventArgs (
    int status
)
public:
DataEventArgs (
    int status
)
public DataEventArgs (
    int status
)
public function DataEventArgs (
    status : int
)

Parameters

status

The device input status.

See Also

Reference

DataEventArgs Class
DataEventArgs Members
Microsoft.PointOfService Namespace


DataEventArgs Methods

DataEventArgs Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Overridden. Returns a string that represents the input status.

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
SetStatus | Sets the device input status.

See Also

Reference

DataEventArgs Class
Microsoft.PointOfService Namespace


DataEventArgs.SetStatus Method

DataEventArgs.SetStatus Method |
 | See Also

1/18/2008

Sets the device input status.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Function SetStatus ( _
    status As Integer _
) As Integer
protected int SetStatus (
    int status
)
protected:
int SetStatus (
    int status
)
protected int SetStatus (
    int status
)
protected function SetStatus (
    status : int
) : int

Parameters

status

The device input status value to set.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DataEventArgs Class
DataEventArgs Members
Microsoft.PointOfService Namespace


DataEventArgs.ToString Method

DataEventArgs.ToString Method |
 | See Also

1/18/2008

Returns a string that represents the input status.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function ToString As String
public override string ToString ()
public:
virtual String^ ToString () override
public String ToString ()
public override function ToString () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DataEventArgs Class
DataEventArgs Members
Microsoft.PointOfService Namespace


DataEventArgs Properties

DataEventArgs Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
EventId | Gets the event identifier. (inherited from PosEventArgs )
Status | Gets the integer value for the device input status.
TimeStamp | Gets the DateTime of the event. (inherited from PosEventArgs )

See Also

Reference

DataEventArgs Class
Microsoft.PointOfService Namespace


DataEventArgs.Status Property

DataEventArgs.Status Property |
 | See Also

1/18/2008

Gets the integer value for the device input status.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Status As Integer
public int Status { get; }
public:
property int Status {
    int get ();
}
/** @property */
public int get_Status ()

public function get Status () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DataEventArgs Class
DataEventArgs Members
Microsoft.PointOfService Namespace


DataEventHandler Delegate

DataEventHandler Delegate |
 | See Also

1/18/2008

Defines the method that handles the DataEventArgs event.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Delegate Sub DataEventHandler ( _
    sender As Object, _
    e As DataEventArgs _
)
public delegate void DataEventHandler (
    Object sender,
    DataEventArgs e
)
public delegate void DataEventHandler (
    Object^ sender,
    DataEventArgs^ e
)
/** @delegate */
public delegate void DataEventHandler (
    Object sender,
    DataEventArgs e
)

Parameters

sender

The source of the event.

e

A DataEventArgs that contains the event data.

Remarks

The declaration of your event handler must have the same parameters as the DataEventHandler delegate declaration.

See Also

Reference

Microsoft.PointOfService Namespace


DealingLogStatus Enumeration

DealingLogStatus Enumeration |
 | See Also

1/18/2008

Enumerates the possible status conditions of the Dealing Log for a CAT device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration DealingLogStatus
public enum DealingLogStatus
public enum class DealingLogStatus
public enum DealingLogStatus
public enum DealingLogStatus

Members

Member name | Description
Full | DealingLog is full.
NearFull | DealingLog is almost full.
Ok | DealingLog has enough capacity.

Remarks

Used by the LogStatus property. The members of this enumeration replace the CAT_LOGSTATUS_OK, CAT_LOGSTATUS_NEARFULL, and CAT_LOGSTATUS_FULL UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace


DepositStatus Enumeration

DepositStatus Enumeration |
 | See Also

1/18/2008

Enumerates possible deposit status values.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration DepositStatus
public enum DepositStatus
public enum class DepositStatus
public enum DepositStatus
public enum DepositStatus

Members

Member name | Description
Count | The deposited money is being counted or repaid.
End | Cash acceptance has ended.
Jam | A mechanical fault has occurred.
Start | Cash acceptance has started.

Remarks

Lists possible deposit status values. Used by DepositStatus properties.

See Also

Reference

Microsoft.PointOfService Namespace


DetectionState Enumeration

DetectionState Enumeration |
 | See Also

1/18/2008

Enumerates the state of card detection.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration DetectionState
public enum DetectionState
public enum class DetectionState
public enum DetectionState
public enum DetectionState

Members

Member name | Description
Captured | The card is in the stock space. The stock space sensor detects the card.
Detected | There is a card in the device. The card detection sensor detects the card.
Entered | Card remaining at the insertion slot. The insertion slot sensor detects the card.
NoCard | No card. The card detection sensor does not detect a card.

Remarks

Replaces the EVRW_DS_CAPTURED, EVRW_DS_DETECTED, EVRW_DS_ENTERED, and EVRW_DS_NOCARD properties from UPOS. Used by the ElectronicValueRW.

See Also

Reference

Microsoft.PointOfService Namespace


Device Class

Device Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a Device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<SerializableAttribute> _
Public Class Device
[SerializableAttribute]
public class Device
[SerializableAttribute]
public ref class Device
/** @attribute SerializableAttribute() */
public class Device
SerializableAttribute
public class Device

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.Device

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Device Members
Microsoft.PointOfService Namespace


Device Members

Device Members |
 | See Also Constructors Methods Properties

1/18/2008

Defines the programmatic interface for a Device.

The following tables list the members exposed by the Device type.

Public Constructors

Name | Description
Device | Creates an instance of the Device class.
Top

Public Properties

Name | Description
Description | Gets text identifying the device and any pertinent information about it.
DevicePath | Gets the hardware path of a device.
Name | Gets a short string identifying the device and any abbreviated information about it.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

Device Class
Microsoft.PointOfService Namespace


Device Constructor

Device Constructor |
 | See Also

1/18/2008

Creates an instance of the Device class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    name As String, _
    description As String, _
    devicePath As String _
)
public Device (
    string name,
    string description,
    string devicePath
)
public:
Device (
    String^ name,
    String^ description,
    String^ devicePath
)
public Device (
    String name,
    String description,
    String devicePath
)
public function Device (
    name : String,
    description : String,
    devicePath : String
)

Parameters

name

Contains a short string identifying the device and any abbreviated information about it.

description

Contains text identifying the device and any pertinent information about it.

devicePath

Contains the hardware path of a device.

See Also

Reference

Device Class
Device Members
Microsoft.PointOfService Namespace


Device Methods

Device Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

Device Class
Microsoft.PointOfService Namespace


Device Properties

Device Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
Description | Gets text identifying the device and any pertinent information about it.
DevicePath | Gets the hardware path of a device.
Name | Gets a short string identifying the device and any abbreviated information about it.

See Also

Reference

Device Class
Microsoft.PointOfService Namespace


Device.Description Property

Device.Description Property |
 | See Also Example

1/18/2008

Gets text identifying the device and any pertinent information about it.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Description As String
public string Description { get; }
public:
property String^ Description {
    String^ get ();
}
/** @property */
public String get_Description ()

public function get Description () : String

Remarks

This property is initialized when the application calls the Open method.

Example

"NCR 7192-0184 Printer, Japanese Version"

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Device Class
Device Members
Microsoft.PointOfService Namespace


Device.DevicePath Property

Device.DevicePath Property |
 | See Also

1/18/2008

Gets the hardware path of a device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property DevicePath As String
public string DevicePath { get; }
public:
property String^ DevicePath {
    String^ get ();
}
/** @property */
public String get_DevicePath ()

public function get DevicePath () : String

Remarks

The PosExplorer class attempts to initialize DevicePath to the hardware path of the physical device using the following algorithm:

  • If the physical hardware supports Plug and Play and the service object is mapped to a specific hardware ID through the HardwareId custom attribute or a configuration XML file, the PosExplorer class sets DevicePath to the HardwarePath of the physical device. Service objects can typically use this DevicePath to directly access the device.

  • If the device does not support Plug and Play, but has been configured through Posdm.exe or WMI, the DevicePath property is set to the path specified when the device was configured.

  • If the device does not support Plug and Play and has not been configured through Posdm.exe or WMI, the DevicePath property is set to empty string ("") and must be set by the service object before the Open method in the base/basic class can be called.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Device Class
Device Members
Microsoft.PointOfService Namespace


Device.Name Property

Device.Name Property |
 | See Also Example

1/18/2008

Gets a short string identifying the device and any abbreviated information about it.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Name As String
public string Name { get; }
public:
property String^ Name {
    String^ get ();
}
/** @property */
public String get_Name ()

public function get Name () : String

Remarks

This is a short version of Description and should be limited to 30 characters.

Name is typically used to identify the device in an application message box, where the full description is too verbose.

Example

"NCR 7192 Printer, Japanese"

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Device Class
Device Members
Microsoft.PointOfService Namespace


DeviceAuthenticationLevel Enumeration

DeviceAuthenticationLevel Enumeration |
 | See Also

1/18/2008

Enumerates the level of device authentication supported by the service.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration DeviceAuthenticationLevel
public enum DeviceAuthenticationLevel
public enum class DeviceAuthenticationLevel
public enum DeviceAuthenticationLevel
public enum DeviceAuthenticationLevel

Members

Member name | Description
NotSupported | The service does not support device authentication.
Optional | The service supports device authentication, but does not require it.
Required | The service requires device authentication.

Remarks

If device authentication is supported, the service must keep the value of DeviceAuthenticated current when the device is enabled. The service should also queue a StatusUpdateEvent with status value set to StatusDeviceAuthenticated or StatusDeviceDeauthenticated when the authentication status changes.

Replaces the DA_NOT_SUPPORTED, DA_OPTIONAL, and DA_REQUIRED properties from UPOS.

See Also

Reference

Microsoft.PointOfService Namespace


DeviceAuthenticationProtocol Enumeration

DeviceAuthenticationProtocol Enumeration |
 | See Also

1/18/2008

Enumerates the device authentication protocol supported by the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration DeviceAuthenticationProtocol
public enum DeviceAuthenticationProtocol
public enum class DeviceAuthenticationProtocol
public enum DeviceAuthenticationProtocol
public enum DeviceAuthenticationProtocol

Members

Member name | Description
ChallengeResponse | The service supports the challenge response protocol.
None | The service does not support device authentication.

Remarks

Replaces the AP_NONE and AP_CHALLENGERESPONSE properties from UPOS.

This property is initialized by the Open method.

See Also

Reference

Microsoft.PointOfService Namespace


DeviceChangedEventArgs Class

DeviceChangedEventArgs Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for the transmission of Device Added Events and Device Removed Events.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Class DeviceChangedEventArgs
    Inherits EventArgs
public class DeviceChangedEventArgs : EventArgs
public ref class DeviceChangedEventArgs : public EventArgs
public class DeviceChangedEventArgs extends EventArgs
public class DeviceChangedEventArgs extends EventArgs

Remarks

DeviceAddedEvent is a Plug and Play notification that a device has been added. DeviceRemovedEvent is a Plug and Play notification that a device has been removed.

Inheritance Hierarchy

System.Object
System.EventArgs
Microsoft.PointOfService.DeviceChangedEventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceChangedEventArgs Members
Microsoft.PointOfService Namespace


DeviceChangedEventArgs Members

DeviceChangedEventArgs Members |
 | See Also Constructors Fields Methods Properties

1/18/2008

Defines the programmatic interface for the transmission of Device Added Events and Device Removed Events.

The following tables list the members exposed by the DeviceChangedEventArgs type.

Public Constructors

Name | Description
DeviceChangedEventArgs | Initializes an instance of the DeviceChangedEventArgs class with the specified DeviceInfo.
Top

Public Fields

Name | Description
Empty | (inherited from EventArgs )
Top

Public Properties

Name | Description
Device | Gets the DeviceInfo for an event.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

DeviceChangedEventArgs Class
Microsoft.PointOfService Namespace


DeviceChangedEventArgs Fields

DeviceChangedEventArgs Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
Empty | (inherited from EventArgs )

See Also

Reference

DeviceChangedEventArgs Class
Microsoft.PointOfService Namespace


DeviceChangedEventArgs Constructor

DeviceChangedEventArgs Constructor |
 | See Also

1/18/2008

Initializes an instance of the DeviceChangedEventArgs class with the specified DeviceInfo.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    device As DeviceInfo _
)
public DeviceChangedEventArgs (
    DeviceInfo device
)
public:
DeviceChangedEventArgs (
    DeviceInfo^ device
)
public DeviceChangedEventArgs (
    DeviceInfo device
)
public function DeviceChangedEventArgs (
    device : DeviceInfo
)

Parameters

device

The DeviceInfo object to initialize with.

See Also

Reference

DeviceChangedEventArgs Class
DeviceChangedEventArgs Members
Microsoft.PointOfService Namespace


DeviceChangedEventArgs Methods

DeviceChangedEventArgs Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

DeviceChangedEventArgs Class
Microsoft.PointOfService Namespace


DeviceChangedEventArgs Properties

DeviceChangedEventArgs Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
Device | Gets the DeviceInfo for an event.

See Also

Reference

DeviceChangedEventArgs Class
Microsoft.PointOfService Namespace


DeviceChangedEventArgs.Device Property

DeviceChangedEventArgs.Device Property |
 | See Also

1/18/2008

Gets the DeviceInfo for an event.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Device As DeviceInfo
public DeviceInfo Device { get; }
public:
property DeviceInfo^ Device {
    DeviceInfo^ get ();
}
/** @property */
public DeviceInfo get_Device ()

public function get Device () : DeviceInfo

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceChangedEventArgs Class
DeviceChangedEventArgs Members
Microsoft.PointOfService Namespace


DeviceChangedEventHandler Delegate

DeviceChangedEventHandler Delegate |
 | See Also

1/18/2008

Defines the method that handles the DeviceChangedEventArgs event.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Delegate Sub DeviceChangedEventHandler ( _
    sender As Object, _
    e As DeviceChangedEventArgs _
)
public delegate void DeviceChangedEventHandler (
    Object sender,
    DeviceChangedEventArgs e
)
public delegate void DeviceChangedEventHandler (
    Object^ sender,
    DeviceChangedEventArgs^ e
)
/** @delegate */
public delegate void DeviceChangedEventHandler (
    Object sender,
    DeviceChangedEventArgs e
)

Parameters

sender

The source of the event.

e

A DeviceChangedEventArgs that contains the event data.

Remarks

The declaration of the event handler must have the same parameters as the DeviceChangedEventHandler delegate declaration.

When you create a DeviceChangedEventHandler delegate, you identify the method that handles the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

See Also

Reference

Microsoft.PointOfService Namespace


DeviceCollection Class

DeviceCollection Class |
 | See Also Members

1/18/2008

Defines an indexed array of DeviceInfo objects.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<DefaultMemberAttribute("Item")> _
Public Class DeviceCollection
    Inherits ReadOnlyCollectionBase
    Implements IEnumerable
[DefaultMemberAttribute("Item")]
public class DeviceCollection : ReadOnlyCollectionBase, IEnumerable
[DefaultMemberAttribute(L"Item")]
public ref class DeviceCollection : public ReadOnlyCollectionBase, IEnumerable
/** @attribute DefaultMemberAttribute("Item") */
public class DeviceCollection extends ReadOnlyCollectionBase implements IEnumerable
DefaultMemberAttribute("Item")
public class DeviceCollection extends ReadOnlyCollectionBase implements IEnumerable

Inheritance Hierarchy

System.Object
System.Collections.ReadOnlyCollectionBase
Microsoft.PointOfService.DeviceCollection

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceCollection Members
Microsoft.PointOfService Namespace


DeviceCollection Members

DeviceCollection Members |
 | See Also Constructors Methods Properties Explicit Interface Implementations

1/18/2008

Defines an indexed array of DeviceInfo objects.

The following tables list the members exposed by the DeviceCollection type.

Public Constructors

Name | Description
DeviceCollection | Creates an instance of the DeviceCollection class.
Top

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from ReadOnlyCollectionBase )
Item | Overloaded.
Top

Protected Properties

Name | Description
InnerList | (inherited from ReadOnlyCollectionBase )
Top

Public Methods (see also Protected Methods )

Name | Description
Contains | Returns a value indicating whether the specified DeviceInfo object is a member of the DeviceCollection class.
CopyTo | Copies the collection to an array, starting to write at the specified array index.
Equals | Overloaded. (inherited from Object )
GetEnumerator | (inherited from ReadOnlyCollectionBase )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Retrieves the index of the specified DeviceInfo object in the collection.
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from ReadOnlyCollectionBase )
System.Collections.ICollection.IsSynchronized | (inherited from ReadOnlyCollectionBase )
System.Collections.ICollection.SyncRoot | (inherited from ReadOnlyCollectionBase )
Top

See Also

Reference

DeviceCollection Class
Microsoft.PointOfService Namespace


DeviceCollection Constructor

DeviceCollection Constructor |
 | See Also

1/18/2008

Creates an instance of the DeviceCollection class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New
public DeviceCollection ()
public:
DeviceCollection ()
public DeviceCollection ()
public function DeviceCollection ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

DeviceCollection Class
DeviceCollection Members
Microsoft.PointOfService Namespace


DeviceCollection Methods

DeviceCollection Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Contains | Returns a value indicating whether the specified DeviceInfo object is a member of the DeviceCollection class.
CopyTo | Copies the collection to an array, starting to write at the specified array index.
Equals | Overloaded. (inherited from Object )
GetEnumerator | (inherited from ReadOnlyCollectionBase )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IndexOf | Retrieves the index of the specified DeviceInfo object in the collection.
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from ReadOnlyCollectionBase )

See Also

Reference

DeviceCollection Class
Microsoft.PointOfService Namespace


DeviceCollection.Contains Method

DeviceCollection.Contains Method |
 | See Also

1/18/2008

Returns a value indicating whether the specified DeviceInfo object is a member of the DeviceCollection class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Function Contains ( _
    value As DeviceInfo _
) As Boolean
public bool Contains (
    DeviceInfo value
)
public:
bool Contains (
    DeviceInfo^ value
)
public boolean Contains (
    DeviceInfo value
)
public function Contains (
    value : DeviceInfo
) : boolean

Parameters

value

The DeviceInfo object to find in the collection.

Remarks

If true, the collection contains the specified DeviceInfo object; otherwise, it is false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceCollection Class
DeviceCollection Members
Microsoft.PointOfService Namespace


DeviceCollection.CopyTo Method

DeviceCollection.CopyTo Method |
 | See Also

1/18/2008

Copies the collection to an array, starting to write at the specified array index.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub CopyTo ( _
    array As DeviceInfo(), _
    index As Integer _
)
public void CopyTo (
    DeviceInfo[] array,
    int index
)
public:
void CopyTo (
    array<DeviceInfo^>^ array,
    int index
)
public void CopyTo (
    DeviceInfo[] array,
    int index
)
public function CopyTo (
    array : DeviceInfo[],
    index : int
)

Parameters

array

An array to copy the objects in the collection to.

index

The index of the array at which copying should begin.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceCollection Class
DeviceCollection Members
Microsoft.PointOfService Namespace


DeviceCollection.IndexOf Method

DeviceCollection.IndexOf Method |
 | See Also

1/18/2008

Retrieves the index of the specified DeviceInfo object in the collection.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Function IndexOf ( _
    value As DeviceInfo _
) As Integer
public int IndexOf (
    DeviceInfo value
)
public:
int IndexOf (
    DeviceInfo^ value
)
public int IndexOf (
    DeviceInfo value
)
public function IndexOf (
    value : DeviceInfo
) : int

Parameters

value

The DeviceInfo object for which to search in the collection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceCollection Class
DeviceCollection Members
Microsoft.PointOfService Namespace


DeviceCollection Properties

DeviceCollection Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from ReadOnlyCollectionBase )
Item | Overloaded.

Protected Properties

Name | Description
InnerList | (inherited from ReadOnlyCollectionBase )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.IsSynchronized | (inherited from ReadOnlyCollectionBase )
System.Collections.ICollection.SyncRoot | (inherited from ReadOnlyCollectionBase )

See Also

Reference

DeviceCollection Class
Microsoft.PointOfService Namespace


DeviceCollection.Item Property

DeviceCollection.Item Property |
 | See Also

1/18/2008

Overload List

Name | Description
DeviceCollection.Item (Int32) | Gets the DeviceInfo object specified by index.
DeviceCollection.Item (String) | Gets the DeviceInfo object specified by name.

See Also

Reference

DeviceCollection Class
DeviceCollection Members
Microsoft.PointOfService Namespace


DeviceCollection.Item Property (Int32)

DeviceCollection.Item Property (Int32) |
 | See Also

1/18/2008

Gets the DeviceInfo object specified by index.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Default Property Item ( _
    index As Integer _
) As DeviceInfo
public DeviceInfo this [
    int index
] { get; }
public:
property DeviceInfo^ default [int] {
    DeviceInfo^ get (int index);
}
/** @property */
public DeviceInfo get_Item (int index)

Parameters

index

The zero-based index of the DeviceInfo object to get.

Remarks

In C#, this property is the indexer of the DeviceCollection class.

The index number is zero-based. Therefore, you must subtract one from the numerical position of a particular DeviceInfo object to access that DeviceInfo. For example, to get the third DeviceInfo, you have to specify myDeviceInfo[2].

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceCollection Class
DeviceCollection Members
Microsoft.PointOfService Namespace


DeviceCollection.Item Property (String)

DeviceCollection.Item Property (String) |
 | See Also

1/18/2008

Gets the DeviceInfo object specified by name.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Default Property Item ( _
    name As String _
) As DeviceInfo
public DeviceInfo this [
    string name
] { get; }
public:
property DeviceInfo^ default [String^] {
    DeviceInfo^ get (String^ name);
}
/** @property */
public DeviceInfo get_Item (String name)

Parameters

name

The name of the DeviceInfo object to get.

Remarks

In C#, this property is the indexer of the DeviceCollection class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceCollection Class
DeviceCollection Members
Microsoft.PointOfService Namespace


DeviceCompatibilities Enumeration

DeviceCompatibilities Enumeration |
 | See Also

1/18/2008

Enumerates the valid compatibility levels for a POS device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration DeviceCompatibilities
[FlagsAttribute]
public enum DeviceCompatibilities
[FlagsAttribute]
public enum class DeviceCompatibilities
/** @attribute FlagsAttribute() */
public enum DeviceCompatibilities
FlagsAttribute
public enum DeviceCompatibilities

Members

Member name | Description
CompatibilityLevel1 | Indicates compatibility with any .NET service object.
Opos | Indicates compatibility with any COM service object.
OposAndCompatibilityLevel1 | Indicates compatibility with any .NET or COM service object.

Remarks

Used by the GetDevices method of the PosExplorer class; also used by the Compatibility properties of the DeviceInfo, PosDevice, and ServiceObjectAttributes classes.

See Also

Reference

Microsoft.PointOfService Namespace


DeviceErrorEventArgs Class

DeviceErrorEventArgs Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for the transmission of Device Error Events.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Class DeviceErrorEventArgs
    Inherits PosEventArgs
public class DeviceErrorEventArgs : PosEventArgs
public ref class DeviceErrorEventArgs : public PosEventArgs
public class DeviceErrorEventArgs extends PosEventArgs
public class DeviceErrorEventArgs extends PosEventArgs

Remarks

Holds event data for device errors.

Inheritance Hierarchy

System.Object
System.EventArgs
Microsoft.PointOfService.PosEventArgs
Microsoft.PointOfService.DeviceErrorEventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceErrorEventArgs Members
Microsoft.PointOfService Namespace


DeviceErrorEventArgs Members

DeviceErrorEventArgs Members |
 | See Also Constructors Fields Methods Properties

1/18/2008

Defines the programmatic interface for the transmission of Device Error Events.

The following tables list the members exposed by the DeviceErrorEventArgs type.

Public Constructors

Name | Description
DeviceErrorEventArgs | Creates an instance of the DeviceErrorEventArgs class with the specified data.
Top

Public Fields

Name | Description
Empty | (inherited from EventArgs )
Top

Public Properties

Name | Description
ErrorCode | Gets the device error code.
ErrorCodeExtended | Gets the device-extended error code. This value is device-specific.
ErrorLocus | Gets the location of the error.
ErrorResponse | Gets or sets the error response.
EventId | Gets the event identifier. (inherited from PosEventArgs)
TimeStamp | Gets the DateTime of the event. (inherited from PosEventArgs)
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Overridden. Returns a string representation of the object.
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

DeviceErrorEventArgs Class
Microsoft.PointOfService Namespace


DeviceErrorEventArgs Fields

DeviceErrorEventArgs Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
Empty | (inherited from EventArgs )

See Also

Reference

DeviceErrorEventArgs Class
Microsoft.PointOfService Namespace


DeviceErrorEventArgs Constructor

DeviceErrorEventArgs Constructor |
 | See Also

1/18/2008

Creates an instance of the DeviceErrorEventArgs class with the specified data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    errorCode As ErrorCode, _
    errorCodeExtended As Integer, _
    errorLocus As ErrorLocus, _
    errorResponse As ErrorResponse _
)
public DeviceErrorEventArgs (
    ErrorCode errorCode,
    int errorCodeExtended,
    ErrorLocus errorLocus,
    ErrorResponse errorResponse
)
public:
DeviceErrorEventArgs (
    ErrorCode errorCode,
    int errorCodeExtended,
    ErrorLocus errorLocus,
    ErrorResponse errorResponse
)
public DeviceErrorEventArgs (
    ErrorCode errorCode,
    int errorCodeExtended,
    ErrorLocus errorLocus,
    ErrorResponse errorResponse
)
public function DeviceErrorEventArgs (
    errorCode : ErrorCode,
    errorCodeExtended : int,
    errorLocus : ErrorLocus,
    errorResponse : ErrorResponse
)

Parameters

errorCode

The device error code.

errorCodeExtended

The device extended error code. This value is device-specific.

errorLocus

The location of the error.

errorResponse

The error response.

See Also

Reference

DeviceErrorEventArgs Class
DeviceErrorEventArgs Members
Microsoft.PointOfService Namespace


DeviceErrorEventArgs Methods

DeviceErrorEventArgs Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Overridden. Returns a string representation of the object.

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

DeviceErrorEventArgs Class
Microsoft.PointOfService Namespace


DeviceErrorEventArgs.ToString Method

DeviceErrorEventArgs.ToString Method |
 | See Also

1/18/2008

Returns a string representation of the object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function ToString As String
public override string ToString ()
public:
virtual String^ ToString () override
public String ToString ()
public override function ToString () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceErrorEventArgs Class
DeviceErrorEventArgs Members
Microsoft.PointOfService Namespace


DeviceErrorEventArgs Properties

DeviceErrorEventArgs Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
ErrorCode | Gets the device error code.
ErrorCodeExtended | Gets the device-extended error code. This value is device-specific.
ErrorLocus | Gets the location of the error.
ErrorResponse | Gets or sets the error response.
EventId | Gets the event identifier. (inherited from PosEventArgs )
TimeStamp | Gets the DateTime of the event. (inherited from PosEventArgs )

See Also

Reference

DeviceErrorEventArgs Class
Microsoft.PointOfService Namespace


DeviceErrorEventArgs.ErrorCode Property

DeviceErrorEventArgs.ErrorCode Property |
 | See Also

1/18/2008

Gets the device error code.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property ErrorCode As ErrorCode
public ErrorCode ErrorCode { get; }
public:
property ErrorCode ErrorCode {
    ErrorCode get ();
}
/** @property */
public ErrorCode get_ErrorCode ()

public function get ErrorCode () : ErrorCode

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceErrorEventArgs Class
DeviceErrorEventArgs Members
Microsoft.PointOfService Namespace


DeviceErrorEventArgs.ErrorCodeExtended Property

DeviceErrorEventArgs.ErrorCodeExtended Property |
 | See Also

1/18/2008

Gets the device-extended error code. This value is device-specific.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property ErrorCodeExtended As Integer
public int ErrorCodeExtended { get; }
public:
property int ErrorCodeExtended {
    int get ();
}
/** @property */
public int get_ErrorCodeExtended ()

public function get ErrorCodeExtended () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceErrorEventArgs Class
DeviceErrorEventArgs Members
Microsoft.PointOfService Namespace


DeviceErrorEventArgs.ErrorLocus Property

DeviceErrorEventArgs.ErrorLocus Property |
 | See Also

1/18/2008

Gets the location of the error.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property ErrorLocus As ErrorLocus
public ErrorLocus ErrorLocus { get; }
public:
property ErrorLocus ErrorLocus {
    ErrorLocus get ();
}
/** @property */
public ErrorLocus get_ErrorLocus ()

public function get ErrorLocus () : ErrorLocus

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceErrorEventArgs Class
DeviceErrorEventArgs Members
Microsoft.PointOfService Namespace


DeviceErrorEventArgs.ErrorResponse Property

DeviceErrorEventArgs.ErrorResponse Property |
 | See Also

1/18/2008

Gets or sets the error response.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Property ErrorResponse As ErrorResponse
public ErrorResponse ErrorResponse { get; set; }
public:
property ErrorResponse ErrorResponse {
    ErrorResponse get ();
    void set (ErrorResponse value);
}
/** @property */
public ErrorResponse get_ErrorResponse ()

/** @property */
public void set_ErrorResponse (ErrorResponse value)

public function get ErrorResponse () : ErrorResponse

public function set ErrorResponse (value : ErrorResponse)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceErrorEventArgs Class
DeviceErrorEventArgs Members
Microsoft.PointOfService Namespace


DeviceErrorEventHandler Delegate

DeviceErrorEventHandler Delegate |
 | See Also

1/18/2008

Defines the method that handles DeviceErrorEventArgs events.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Delegate Sub DeviceErrorEventHandler ( _
    sender As Object, _
    e As DeviceErrorEventArgs _
)
public delegate void DeviceErrorEventHandler (
    Object sender,
    DeviceErrorEventArgs e
)
public delegate void DeviceErrorEventHandler (
    Object^ sender,
    DeviceErrorEventArgs^ e
)
/** @delegate */
public delegate void DeviceErrorEventHandler (
    Object sender,
    DeviceErrorEventArgs e
)

Parameters

sender

The source of the event.

e

A DeviceErrorEventArgs that contains the event data.

Remarks

The declaration of your event handler must have the same parameters as the DeviceErrorEventHandler delegate declaration.

When you create a DeviceErrorEventHandler delegate, you identify the method that handles the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

See Also

Reference

Microsoft.PointOfService Namespace


DeviceInfo Class

DeviceInfo Class |
 | See Also Members

1/18/2008

Defines a programmatic interface for device information that is used to create a service object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class DeviceInfo
public abstract class DeviceInfo
public ref class DeviceInfo abstract
public abstract class DeviceInfo
public abstract class DeviceInfo

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.DeviceInfo

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceInfo Members
Microsoft.PointOfService Namespace


DeviceInfo Members

DeviceInfo Members |
 | See Also Methods Properties Constructors

1/18/2008

Defines a programmatic interface for device information that is used to create a service object.

The following tables list the members exposed by the DeviceInfo type.

Protected Constructors

Name | Description
DeviceInfo | Creates an instance of the DeviceInfo class.
Top

Public Properties

Name | Description
Compatibility | Gets device compatibility information.
Description | Gets a device description.
HardwareDescription | Gets a hardware description.
HardwareId | Gets the hardware ID.
HardwarePath | Gets the path of the device.
IsDefault | Gets the Boolean value that indicates whether the device is the default.
LogicalNames | Gets the logical names of a device.
ManufacturerName | Gets the manufacturer name of a device.
ServiceObjectName | Gets the service object name for a device.
ServiceObjectVersion | Gets the service object version for a device.
Type | Gets the device type.
UposVersion | Gets the UPOS version of a device.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IsDeviceInfoOf | Gets the Boolean value that indicates whether a DeviceInfo instance applies to the specified service object.
ReferenceEquals | (inherited from Object )
ToString | Overridden.
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

DeviceInfo Class
Microsoft.PointOfService Namespace


DeviceInfo Constructor

DeviceInfo Constructor |
 | See Also

1/18/2008

Creates an instance of the DeviceInfo class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected DeviceInfo ()
protected:
DeviceInfo ()
protected DeviceInfo ()
protected function DeviceInfo ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

DeviceInfo Class
DeviceInfo Members
Microsoft.PointOfService Namespace


DeviceInfo Methods

DeviceInfo Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
IsDeviceInfoOf | Gets the Boolean value that indicates whether a DeviceInfo instance applies to the specified service object.
ReferenceEquals | (inherited from Object )
ToString | Overridden.

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

DeviceInfo Class
Microsoft.PointOfService Namespace


DeviceInfo.IsDeviceInfoOf Method

DeviceInfo.IsDeviceInfoOf Method |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether a DeviceInfo instance applies to the specified service object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Function IsDeviceInfoOf ( _
    serviceObject As PosCommon _
) As Boolean
public bool IsDeviceInfoOf (
    PosCommon serviceObject
)
public:
bool IsDeviceInfoOf (
    PosCommon^ serviceObject
)
public boolean IsDeviceInfoOf (
    PosCommon serviceObject
)
public function IsDeviceInfoOf (
    serviceObject : PosCommon
) : boolean

Parameters

serviceObject

The service object to compare.

Remarks

The IsDeviceInfoOf method compares the Type and HardwarePath properties of a DeviceInfo object and a service object.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceInfo Class
DeviceInfo Members
Microsoft.PointOfService Namespace


DeviceInfo.ToString Method

DeviceInfo.ToString Method |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function ToString As String

public override string ToString ()

public:
virtual String^ ToString () override

public String ToString ()

public override function ToString () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceInfo Class
DeviceInfo Members
Microsoft.PointOfService Namespace


DeviceInfo Properties

DeviceInfo Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
Compatibility | Gets device compatibility information.
Description | Gets a device description.
HardwareDescription | Gets a hardware description.
HardwareId | Gets the hardware ID.
HardwarePath | Gets the path of the device.
IsDefault | Gets the Boolean value that indicates whether the device is the default.
LogicalNames | Gets the logical names of a device.
ManufacturerName | Gets the manufacturer name of a device.
ServiceObjectName | Gets the service object name for a device.
ServiceObjectVersion | Gets the service object version for a device.
Type | Gets the device type.
UposVersion | Gets the UPOS version of a device.

See Also

Reference

DeviceInfo Class
Microsoft.PointOfService Namespace


DeviceInfo.Compatibility Property

DeviceInfo.Compatibility Property |
 | See Also

1/18/2008

Gets device compatibility information.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property Compatibility As DeviceCompatibilities
public abstract DeviceCompatibilities Compatibility { get; }
public:
virtual property DeviceCompatibilities Compatibility {
    DeviceCompatibilities get () abstract;
}
/** @property */
public abstract DeviceCompatibilities get_Compatibility ()

public abstract function get Compatibility () : DeviceCompatibilities

Remarks

Valid compatibilities are defined by the DeviceCompatibilities enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceInfo Class
DeviceInfo Members
Microsoft.PointOfService Namespace


DeviceInfo.Description Property

DeviceInfo.Description Property |
 | See Also

1/18/2008

Gets a device description.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property Description As String
public abstract string Description { get; }
public:
virtual property String^ Description {
    String^ get () abstract;
}
/** @property */
public abstract String get_Description ()

public abstract function get Description () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceInfo Class
DeviceInfo Members
Microsoft.PointOfService Namespace


DeviceInfo.HardwareDescription Property

DeviceInfo.HardwareDescription Property |
 | See Also

1/18/2008

Gets a hardware description.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property HardwareDescription As String
public abstract string HardwareDescription { get; }
public:
virtual property String^ HardwareDescription {
    String^ get () abstract;
}
/** @property */
public abstract String get_HardwareDescription ()

public abstract function get HardwareDescription () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceInfo Class
DeviceInfo Members
Microsoft.PointOfService Namespace


DeviceInfo.HardwareId Property

DeviceInfo.HardwareId Property |
 | See Also

1/18/2008

Gets the hardware ID.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property HardwareId As String
public abstract string HardwareId { get; }
public:
virtual property String^ HardwareId {
    String^ get () abstract;
}
/** @property */
public abstract String get_HardwareId ()

public abstract function get HardwareId () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceInfo Class
DeviceInfo Members
Microsoft.PointOfService Namespace


DeviceInfo.HardwarePath Property

DeviceInfo.HardwarePath Property |
 | See Also

1/18/2008

Gets the path of the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property HardwarePath As String
public abstract string HardwarePath { get; }
public:
virtual property String^ HardwarePath {
    String^ get () abstract;
}
/** @property */
public abstract String get_HardwarePath ()

public abstract function get HardwarePath () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceInfo Class
DeviceInfo Members
Microsoft.PointOfService Namespace


DeviceInfo.IsDefault Property

DeviceInfo.IsDefault Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the device is the default.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property IsDefault As Boolean
public abstract bool IsDefault { get; }
public:
virtual property bool IsDefault {
    bool get () abstract;
}
/** @property */
public abstract boolean get_IsDefault ()

public abstract function get IsDefault () : boolean

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceInfo Class
DeviceInfo Members
Microsoft.PointOfService Namespace


DeviceInfo.LogicalNames Property

DeviceInfo.LogicalNames Property |
 | See Also

1/18/2008

Gets the logical names of a device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property LogicalNames As String()
public abstract string[] LogicalNames { get; }
public:
virtual property array<String^>^ LogicalNames {
    array<String^>^ get () abstract;
}
/** @property */
public abstract String[] get_LogicalNames ()

public abstract function get LogicalNames () : String[]

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceInfo Class
DeviceInfo Members
Microsoft.PointOfService Namespace


DeviceInfo.ManufacturerName Property

DeviceInfo.ManufacturerName Property |
 | See Also

1/18/2008

Gets the manufacturer name of a device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ManufacturerName As String
public abstract string ManufacturerName { get; }
public:
virtual property String^ ManufacturerName {
    String^ get () abstract;
}
/** @property */
public abstract String get_ManufacturerName ()

public abstract function get ManufacturerName () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceInfo Class
DeviceInfo Members
Microsoft.PointOfService Namespace


DeviceInfo.ServiceObjectName Property

DeviceInfo.ServiceObjectName Property |
 | See Also

1/18/2008

Gets the service object name for a device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ServiceObjectName As String
public abstract string ServiceObjectName { get; }
public:
virtual property String^ ServiceObjectName {
    String^ get () abstract;
}
/** @property */
public abstract String get_ServiceObjectName ()

public abstract function get ServiceObjectName () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceInfo Class
DeviceInfo Members
Microsoft.PointOfService Namespace


DeviceInfo.ServiceObjectVersion Property

DeviceInfo.ServiceObjectVersion Property |
 | See Also

1/18/2008

Gets the service object version for a device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ServiceObjectVersion As Version
public abstract Version ServiceObjectVersion { get; }
public:
virtual property Version^ ServiceObjectVersion {
    Version^ get () abstract;
}
/** @property */
public abstract Version get_ServiceObjectVersion ()

public abstract function get ServiceObjectVersion () : Version

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceInfo Class
DeviceInfo Members
Microsoft.PointOfService Namespace


DeviceInfo.Type Property

DeviceInfo.Type Property |
 | See Also

1/18/2008

Gets the device type.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property Type As String
public abstract string Type { get; }
public:
virtual property String^ Type {
    String^ get () abstract;
}
/** @property */
public abstract String get_Type ()

public abstract function get Type () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceInfo Class
DeviceInfo Members
Microsoft.PointOfService Namespace


DeviceInfo.UposVersion Property

DeviceInfo.UposVersion Property |
 | See Also

1/18/2008

Gets the UPOS version of a device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property UposVersion As Version
public abstract Version UposVersion { get; }
public:
virtual property Version^ UposVersion {
    Version^ get () abstract;
}
/** @property */
public abstract Version get_UposVersion ()

public abstract function get UposVersion () : Version

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceInfo Class
DeviceInfo Members
Microsoft.PointOfService Namespace


DevicePlugAndPlay Class

DevicePlugAndPlay Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for the DevicePlugAndPlay class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class DevicePlugAndPlay
    Inherits MarshalByRefObject
public abstract class DevicePlugAndPlay : MarshalByRefObject
public ref class DevicePlugAndPlay abstract : public MarshalByRefObject
public abstract class DevicePlugAndPlay extends MarshalByRefObject
public abstract class DevicePlugAndPlay extends MarshalByRefObject

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
Microsoft.PointOfService.DevicePlugAndPlay

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DevicePlugAndPlay Members
Microsoft.PointOfService Namespace


DevicePlugAndPlay Members

DevicePlugAndPlay Members |
 | See Also Events Methods Constructors

1/18/2008

Defines the programmatic interface for the DevicePlugAndPlay class.

The following tables list the members exposed by the DevicePlugAndPlay type.

Protected Constructors

Name | Description
DevicePlugAndPlay | Creates an instance of the DevicePlugAndPlay class.
Top

Public Methods (see also Protected Methods )

Name | Description
CreateObjRef | (inherited from MarshalByRefObject )
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetLifetimeService | (inherited from MarshalByRefObject )
GetType | (inherited from Object )
InitializeLifetimeService | (inherited from MarshalByRefObject )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | Overloaded. (inherited from MarshalByRefObject )
RaiseDeviceAddedEvent | Raises an event that notifies the service objects that hardware has been added.
RaiseDeviceRemovedEvent | Raises an event that notifies the service objects that hardware has been removed.
Top

Public Events

Name | Description
DeviceAddedEvent | An event that notifies the service objects that hardware has been added.
DeviceRemovedEvent | An event that notifies the service objects that hardware has been removed.
Top

See Also

Reference

DevicePlugAndPlay Class
Microsoft.PointOfService Namespace


DevicePlugAndPlay Constructor

DevicePlugAndPlay Constructor |
 | See Also

1/18/2008

Creates an instance of the DevicePlugAndPlay class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected DevicePlugAndPlay ()
protected:
DevicePlugAndPlay ()
protected DevicePlugAndPlay ()
protected function DevicePlugAndPlay ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

DevicePlugAndPlay Class
DevicePlugAndPlay Members
Microsoft.PointOfService Namespace


DevicePlugAndPlay Methods

DevicePlugAndPlay Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
CreateObjRef | (inherited from MarshalByRefObject )
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetLifetimeService | (inherited from MarshalByRefObject )
GetType | (inherited from Object )
InitializeLifetimeService | (inherited from MarshalByRefObject )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | Overloaded. (inherited from MarshalByRefObject )
RaiseDeviceAddedEvent | Raises an event that notifies the service objects that hardware has been added.
RaiseDeviceRemovedEvent | Raises an event that notifies the service objects that hardware has been removed.

See Also

Reference

DevicePlugAndPlay Class
Microsoft.PointOfService Namespace


DevicePlugAndPlay.RaiseDeviceAddedEvent Method

DevicePlugAndPlay.RaiseDeviceAddedEvent Method |
 | See Also

1/18/2008

Raises an event that notifies the service objects that hardware has been added.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub RaiseDeviceAddedEvent ( _
    device As Device _
)
protected void RaiseDeviceAddedEvent (
    Device device
)
protected:
void RaiseDeviceAddedEvent (
    Device^ device
)
protected void RaiseDeviceAddedEvent (
    Device device
)
protected function RaiseDeviceAddedEvent (
    device : Device
)

Parameters

device

The hardware device that was added.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DevicePlugAndPlay Class
DevicePlugAndPlay Members
Microsoft.PointOfService Namespace


DevicePlugAndPlay.RaiseDeviceRemovedEvent Method

DevicePlugAndPlay.RaiseDeviceRemovedEvent Method |
 | See Also

1/18/2008

Raises an event that notifies the service objects that hardware has been removed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub RaiseDeviceRemovedEvent ( _
    device As Device _
)
protected void RaiseDeviceRemovedEvent (
    Device device
)
protected:
void RaiseDeviceRemovedEvent (
    Device^ device
)
protected void RaiseDeviceRemovedEvent (
    Device device
)
protected function RaiseDeviceRemovedEvent (
    device : Device
)

Parameters

device

The hardware device that was removed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DevicePlugAndPlay Class
DevicePlugAndPlay Members
Microsoft.PointOfService Namespace


DevicePlugAndPlay Events

DevicePlugAndPlay Events |
 | See Also

1/18/2008

Public Events

Name | Description
DeviceAddedEvent | An event that notifies the service objects that hardware has been added.
DeviceRemovedEvent | An event that notifies the service objects that hardware has been removed.

See Also

Reference

DevicePlugAndPlay Class
Microsoft.PointOfService Namespace


DevicePlugAndPlay.DeviceAddedEvent Event

DevicePlugAndPlay.DeviceAddedEvent Event |
 | See Also

1/18/2008

An event that notifies the service objects that hardware has been added.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event DeviceAddedEvent As DeviceStatusChangedEventHandler
public event DeviceStatusChangedEventHandler DeviceAddedEvent
public:
event DeviceStatusChangedEventHandler^ DeviceAddedEvent {
    void add (DeviceStatusChangedEventHandler^ value);
    void remove (DeviceStatusChangedEventHandler^ value);
}
/** @event */
public void add_DeviceAddedEvent (DeviceStatusChangedEventHandler value)

/** @event */
public void remove_DeviceAddedEvent (DeviceStatusChangedEventHandler value)

See Also

Reference

DevicePlugAndPlay Class
DevicePlugAndPlay Members
Microsoft.PointOfService Namespace


DevicePlugAndPlay.DeviceRemovedEvent Event

DevicePlugAndPlay.DeviceRemovedEvent Event |
 | See Also

1/18/2008

An event that notifies the service objects that hardware has been removed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event DeviceRemovedEvent As DeviceStatusChangedEventHandler
public event DeviceStatusChangedEventHandler DeviceRemovedEvent
public:
event DeviceStatusChangedEventHandler^ DeviceRemovedEvent {
    void add (DeviceStatusChangedEventHandler^ value);
    void remove (DeviceStatusChangedEventHandler^ value);
}
/** @event */
public void add_DeviceRemovedEvent (DeviceStatusChangedEventHandler value)

/** @event */
public void remove_DeviceRemovedEvent (DeviceStatusChangedEventHandler value)

See Also

Reference

DevicePlugAndPlay Class
DevicePlugAndPlay Members
Microsoft.PointOfService Namespace


DeviceStatusChangedEventArgs Class

DeviceStatusChangedEventArgs Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for the transmission of Device Status Changed Events.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Class DeviceStatusChangedEventArgs
    Inherits EventArgs
public class DeviceStatusChangedEventArgs : EventArgs
public ref class DeviceStatusChangedEventArgs : public EventArgs
public class DeviceStatusChangedEventArgs extends EventArgs
public class DeviceStatusChangedEventArgs extends EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Microsoft.PointOfService.DeviceStatusChangedEventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceStatusChangedEventArgs Members
Microsoft.PointOfService Namespace


DeviceStatusChangedEventArgs Members

DeviceStatusChangedEventArgs Members |
 | See Also Constructors Fields Methods Properties

1/18/2008

Defines the programmatic interface for the transmission of Device Status Changed Events.

The following tables list the members exposed by the DeviceStatusChangedEventArgs type.

Public Constructors

Name | Description
DeviceStatusChangedEventArgs | Creates an instance of the DeviceStatusChangedEventArgs class with the specified DeviceInfo.
Top

Public Fields

Name | Description
Empty | (inherited from EventArgs )
Top

Public Properties

Name | Description
Device | Gets the DeviceInfo for a status changed event.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

DeviceStatusChangedEventArgs Class
Microsoft.PointOfService Namespace


DeviceStatusChangedEventArgs Fields

DeviceStatusChangedEventArgs Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
Empty | (inherited from EventArgs )

See Also

Reference

DeviceStatusChangedEventArgs Class
Microsoft.PointOfService Namespace


DeviceStatusChangedEventArgs Constructor

DeviceStatusChangedEventArgs Constructor |
 | See Also

1/18/2008

Creates an instance of the DeviceStatusChangedEventArgs class with the specified DeviceInfo.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    device As Device _
)
public DeviceStatusChangedEventArgs (
    Device device
)
public:
DeviceStatusChangedEventArgs (
    Device^ device
)
public DeviceStatusChangedEventArgs (
    Device device
)
public function DeviceStatusChangedEventArgs (
    device : Device
)

Parameters

device

The DeviceInfo object to initialize with.

See Also

Reference

DeviceStatusChangedEventArgs Class
DeviceStatusChangedEventArgs Members
Microsoft.PointOfService Namespace


DeviceStatusChangedEventArgs Methods

DeviceStatusChangedEventArgs Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

DeviceStatusChangedEventArgs Class
Microsoft.PointOfService Namespace


DeviceStatusChangedEventArgs Properties

DeviceStatusChangedEventArgs Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
Device | Gets the DeviceInfo for a status changed event.

See Also

Reference

DeviceStatusChangedEventArgs Class
Microsoft.PointOfService Namespace


DeviceStatusChangedEventArgs.Device Property

DeviceStatusChangedEventArgs.Device Property |
 | See Also

1/18/2008

Gets the DeviceInfo for a status changed event.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Device As Device
public Device Device { get; }
public:
property Device^ Device {
    Device^ get ();
}
/** @property */
public Device get_Device ()

public function get Device () : Device

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceStatusChangedEventArgs Class
DeviceStatusChangedEventArgs Members
Microsoft.PointOfService Namespace


DeviceStatusChangedEventHandler Delegate

DeviceStatusChangedEventHandler Delegate |
 | See Also

1/18/2008

Defines the method that handles the DeviceStatusChangedEventHandler event.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Delegate Sub DeviceStatusChangedEventHandler ( _
    sender As Object, _
    e As DeviceStatusChangedEventArgs _
)
public delegate void DeviceStatusChangedEventHandler (
    Object sender,
    DeviceStatusChangedEventArgs e
)
public delegate void DeviceStatusChangedEventHandler (
    Object^ sender,
    DeviceStatusChangedEventArgs^ e
)
/** @delegate */
public delegate void DeviceStatusChangedEventHandler (
    Object sender,
    DeviceStatusChangedEventArgs e
)

Parameters

sender

The source of the event.

e

A DeviceStatusChangedEventArgs that contains the event data.

Remarks

The declaration of the event handler must have the same parameters as the DeviceStatusChangedEventHandler delegate declaration.

When you create a DeviceStatusChangedEventHandler delegate, you identify the method that handles the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

See Also

Reference

Microsoft.PointOfService Namespace


DeviceType Class

DeviceType Class |
 | See Also Members

1/18/2008

Defines 28 constants, each representing a POS device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Class DeviceType
public class DeviceType
public ref class DeviceType
public class DeviceType
public class DeviceType

Remarks

Used internally by POS for .NET when it opens a device and initializes its statistics.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.DeviceType

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceType Members
Microsoft.PointOfService Namespace


DeviceType Members

DeviceType Members |
 | See Also Constructors Fields Methods

1/18/2008

Defines 28 constants, each representing a POS device.

The following tables list the members exposed by the DeviceType type.

Public Constructors

Name | Description
DeviceType | Creates an instance of the DeviceType class.
Top

Public Fields

Name | Description
Belt |
BillAcceptor | Indicates a bill acceptor device.
BillDispenser | Indicates a bill dispenser device.
Biometrics | Indicates that the device is a biometrics scanner.
BumpBar | Indicates a bump bar device.
CashChanger | Indicates a cash changer device.
CashDrawer | Indicates a cash drawer device.
Cat | Indicates a credit authorization terminal (CAT) device.
CheckScanner | Indicates a check scanner device.
CoinAcceptor | Indicates a coin acceptor device.
CoinDispenser | Indicates a coin dispenser device.
ElectronicJournal | Indicates that the device is an electronic journal.
ElectronicValueRW |
FiscalPrinter | Indicates a fiscal printer device.
Gate |
HardTotals | Indicates a hard totals device.
ImageScanner | Indicates an image scanner device.
ItemDispenser |
Keylock | Indicates a keylock device.
Lights |
LineDisplay | Indicates a line display device.
Micr | Indicates a magnetic ink character reader (MICR) device.
MotionSensor | Indicates a motion sensor device.
Msr | Indicates a magnetic stripe reader (MSR) device.
PinPad | Indicates a PIN pad device.
PointCardRW | Indicates a point card reader/writer device.
PosKeyboard | Indicates a keyboard device.
PosPower | Indicates a power device.
PosPrinter | Indicates a printer.
RemoteOrderDisplay | Indicates a remote order display device.
RFIDScanner |
Scale | Indicates a weight scale.
Scanner | Indicates a scanner (bar code reader) device.
SignatureCapture | Indicates a signature capture device.
SmartCardRW | Indicates a smart card reader / writer device.
ToneIndicator | Indicates a tone indicator device.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

DeviceType Class
Microsoft.PointOfService Namespace


DeviceType Fields

DeviceType Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
Belt |
BillAcceptor | Indicates a bill acceptor device.
BillDispenser | Indicates a bill dispenser device.
Biometrics | Indicates that the device is a biometrics scanner.
BumpBar | Indicates a bump bar device.
CashChanger | Indicates a cash changer device.
CashDrawer | Indicates a cash drawer device.
Cat | Indicates a credit authorization terminal (CAT) device.
CheckScanner | Indicates a check scanner device.
CoinAcceptor | Indicates a coin acceptor device.
CoinDispenser | Indicates a coin dispenser device.
ElectronicJournal | Indicates that the device is an electronic journal.
ElectronicValueRW |
FiscalPrinter | Indicates a fiscal printer device.
Gate |
HardTotals | Indicates a hard totals device.
ImageScanner | Indicates an image scanner device.
ItemDispenser |
Keylock | Indicates a keylock device.
Lights |
LineDisplay | Indicates a line display device.
Micr | Indicates a magnetic ink character reader (MICR) device.
MotionSensor | Indicates a motion sensor device.
Msr | Indicates a magnetic stripe reader (MSR) device.
PinPad | Indicates a PIN pad device.
PointCardRW | Indicates a point card reader/writer device.
PosKeyboard | Indicates a keyboard device.
PosPower | Indicates a power device.
PosPrinter | Indicates a printer.
RemoteOrderDisplay | Indicates a remote order display device.
RFIDScanner |
Scale | Indicates a weight scale.
Scanner | Indicates a scanner (bar code reader) device.
SignatureCapture | Indicates a signature capture device.
SmartCardRW | Indicates a smart card reader / writer device.
ToneIndicator | Indicates a tone indicator device.

See Also

Reference

DeviceType Class
Microsoft.PointOfService Namespace


DeviceType.Belt Field

DeviceType.Belt Field |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const Belt As String

public const string Belt

public:
literal String^ Belt

public static final String Belt

public const var Belt : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.BillAcceptor Field

DeviceType.BillAcceptor Field |
 | See Also

1/18/2008

Indicates a bill acceptor device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const BillAcceptor As String
public const string BillAcceptor
public:
literal String^ BillAcceptor
public static final String BillAcceptor
public const var BillAcceptor : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.BillDispenser Field

DeviceType.BillDispenser Field |
 | See Also

1/18/2008

Indicates a bill dispenser device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const BillDispenser As String
public const string BillDispenser
public:
literal String^ BillDispenser
public static final String BillDispenser
public const var BillDispenser : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.Biometrics Field

DeviceType.Biometrics Field |
 | See Also

1/18/2008

Indicates that the device is a biometrics scanner.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const Biometrics As String
public const string Biometrics
public:
literal String^ Biometrics
public static final String Biometrics
public const var Biometrics : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.BumpBar Field

DeviceType.BumpBar Field |
 | See Also

1/18/2008

Indicates a bump bar device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const BumpBar As String
public const string BumpBar
public:
literal String^ BumpBar
public static final String BumpBar
public const var BumpBar : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.CashChanger Field

DeviceType.CashChanger Field |
 | See Also

1/18/2008

Indicates a cash changer device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const CashChanger As String
public const string CashChanger
public:
literal String^ CashChanger
public static final String CashChanger
public const var CashChanger : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.CashDrawer Field

DeviceType.CashDrawer Field |
 | See Also

1/18/2008

Indicates a cash drawer device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const CashDrawer As String
public const string CashDrawer
public:
literal String^ CashDrawer
public static final String CashDrawer
public const var CashDrawer : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.Cat Field

DeviceType.Cat Field |
 | See Also

1/18/2008

Indicates a credit authorization terminal (CAT) device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const Cat As String
public const string Cat
public:
literal String^ Cat
public static final String Cat
public const var Cat : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.CheckScanner Field

DeviceType.CheckScanner Field |
 | See Also

1/18/2008

Indicates a check scanner device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const CheckScanner As String
public const string CheckScanner
public:
literal String^ CheckScanner
public static final String CheckScanner
public const var CheckScanner : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.CoinAcceptor Field

DeviceType.CoinAcceptor Field |
 | See Also

1/18/2008

Indicates a coin acceptor device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const CoinAcceptor As String
public const string CoinAcceptor
public:
literal String^ CoinAcceptor
public static final String CoinAcceptor
public const var CoinAcceptor : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.CoinDispenser Field

DeviceType.CoinDispenser Field |
 | See Also

1/18/2008

Indicates a coin dispenser device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const CoinDispenser As String
public const string CoinDispenser
public:
literal String^ CoinDispenser
public static final String CoinDispenser
public const var CoinDispenser : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.ElectronicJournal Field

DeviceType.ElectronicJournal Field |
 | See Also

1/18/2008

Indicates that the device is an electronic journal.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ElectronicJournal As String
public const string ElectronicJournal
public:
literal String^ ElectronicJournal
public static final String ElectronicJournal
public const var ElectronicJournal : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.ElectronicValueRW Field

DeviceType.ElectronicValueRW Field |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ElectronicValueRW As String

public const string ElectronicValueRW

public:
literal String^ ElectronicValueRW

public static final String ElectronicValueRW

public const var ElectronicValueRW : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.FiscalPrinter Field

DeviceType.FiscalPrinter Field |
 | See Also

1/18/2008

Indicates a fiscal printer device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const FiscalPrinter As String
public const string FiscalPrinter
public:
literal String^ FiscalPrinter
public static final String FiscalPrinter
public const var FiscalPrinter : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.Gate Field

DeviceType.Gate Field |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const Gate As String

public const string Gate

public:
literal String^ Gate

public static final String Gate

public const var Gate : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.HardTotals Field

DeviceType.HardTotals Field |
 | See Also

1/18/2008

Indicates a hard totals device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const HardTotals As String
public const string HardTotals
public:
literal String^ HardTotals
public static final String HardTotals
public const var HardTotals : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.ImageScanner Field

DeviceType.ImageScanner Field |
 | See Also

1/18/2008

Indicates an image scanner device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ImageScanner As String
public const string ImageScanner
public:
literal String^ ImageScanner
public static final String ImageScanner
public const var ImageScanner : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.ItemDispenser Field

DeviceType.ItemDispenser Field |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ItemDispenser As String

public const string ItemDispenser

public:
literal String^ ItemDispenser

public static final String ItemDispenser

public const var ItemDispenser : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.Keylock Field

DeviceType.Keylock Field |
 | See Also

1/18/2008

Indicates a keylock device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const Keylock As String
public const string Keylock
public:
literal String^ Keylock
public static final String Keylock
public const var Keylock : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.Lights Field

DeviceType.Lights Field |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const Lights As String

public const string Lights

public:
literal String^ Lights

public static final String Lights

public const var Lights : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.LineDisplay Field

DeviceType.LineDisplay Field |
 | See Also

1/18/2008

Indicates a line display device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const LineDisplay As String
public const string LineDisplay
public:
literal String^ LineDisplay
public static final String LineDisplay
public const var LineDisplay : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.Micr Field

DeviceType.Micr Field |
 | See Also

1/18/2008

Indicates a magnetic ink character reader (MICR) device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const Micr As String
public const string Micr
public:
literal String^ Micr
public static final String Micr
public const var Micr : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.MotionSensor Field

DeviceType.MotionSensor Field |
 | See Also

1/18/2008

Indicates a motion sensor device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const MotionSensor As String
public const string MotionSensor
public:
literal String^ MotionSensor
public static final String MotionSensor
public const var MotionSensor : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.Msr Field

DeviceType.Msr Field |
 | See Also

1/18/2008

Indicates a magnetic stripe reader (MSR) device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const Msr As String
public const string Msr
public:
literal String^ Msr
public static final String Msr
public const var Msr : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.PinPad Field

DeviceType.PinPad Field |
 | See Also

1/18/2008

Indicates a PIN pad device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PinPad As String
public const string PinPad
public:
literal String^ PinPad
public static final String PinPad
public const var PinPad : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.PointCardRW Field

DeviceType.PointCardRW Field |
 | See Also

1/18/2008

Indicates a point card reader/writer device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PointCardRW As String
public const string PointCardRW
public:
literal String^ PointCardRW
public static final String PointCardRW
public const var PointCardRW : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.PosKeyboard Field

DeviceType.PosKeyboard Field |
 | See Also

1/18/2008

Indicates a keyboard device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PosKeyboard As String
public const string PosKeyboard
public:
literal String^ PosKeyboard
public static final String PosKeyboard
public const var PosKeyboard : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.PosPower Field

DeviceType.PosPower Field |
 | See Also

1/18/2008

Indicates a power device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PosPower As String
public const string PosPower
public:
literal String^ PosPower
public static final String PosPower
public const var PosPower : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.PosPrinter Field

DeviceType.PosPrinter Field |
 | See Also

1/18/2008

Indicates a printer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PosPrinter As String
public const string PosPrinter
public:
literal String^ PosPrinter
public static final String PosPrinter
public const var PosPrinter : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.RemoteOrderDisplay Field

DeviceType.RemoteOrderDisplay Field |
 | See Also

1/18/2008

Indicates a remote order display device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const RemoteOrderDisplay As String
public const string RemoteOrderDisplay
public:
literal String^ RemoteOrderDisplay
public static final String RemoteOrderDisplay
public const var RemoteOrderDisplay : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.RFIDScanner Field

DeviceType.RFIDScanner Field |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const RFIDScanner As String

public const string RFIDScanner

public:
literal String^ RFIDScanner

public static final String RFIDScanner

public const var RFIDScanner : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.Scale Field

DeviceType.Scale Field |
 | See Also

1/18/2008

Indicates a weight scale.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const Scale As String
public const string Scale
public:
literal String^ Scale
public static final String Scale
public const var Scale : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.Scanner Field

DeviceType.Scanner Field |
 | See Also

1/18/2008

Indicates a scanner (bar code reader) device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const Scanner As String
public const string Scanner
public:
literal String^ Scanner
public static final String Scanner
public const var Scanner : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.SignatureCapture Field

DeviceType.SignatureCapture Field |
 | See Also

1/18/2008

Indicates a signature capture device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const SignatureCapture As String
public const string SignatureCapture
public:
literal String^ SignatureCapture
public static final String SignatureCapture
public const var SignatureCapture : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.SmartCardRW Field

DeviceType.SmartCardRW Field |
 | See Also

1/18/2008

Indicates a smart card reader / writer device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const SmartCardRW As String
public const string SmartCardRW
public:
literal String^ SmartCardRW
public static final String SmartCardRW
public const var SmartCardRW : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType.ToneIndicator Field

DeviceType.ToneIndicator Field |
 | See Also

1/18/2008

Indicates a tone indicator device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ToneIndicator As String
public const string ToneIndicator
public:
literal String^ ToneIndicator
public static final String ToneIndicator
public const var ToneIndicator : String

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType Constructor

DeviceType Constructor |
 | See Also

1/18/2008

Creates an instance of the DeviceType class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New
public DeviceType ()
public:
DeviceType ()
public DeviceType ()
public function DeviceType ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

DeviceType Class
DeviceType Members
Microsoft.PointOfService Namespace


DeviceType Methods

DeviceType Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

DeviceType Class
Microsoft.PointOfService Namespace


DeviceUnits Enumeration

DeviceUnits Enumeration |
 | See Also

1/18/2008

Enumerates the valid unit IDs of a single video unit for a Bump Bar or Remote Order Display device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration DeviceUnits
[FlagsAttribute]
public enum DeviceUnits
[FlagsAttribute]
public enum class DeviceUnits
/** @attribute FlagsAttribute() */
public enum DeviceUnits
FlagsAttribute
public enum DeviceUnits

Members

Member name | Description
Unit1 | Unit 1
Unit10 | Unit 10
Unit11 | Unit 11
Unit12 | Unit 12
Unit13 | Unit 13
Unit14 | Unit 14
Unit15 | Unit 15
Unit16 | Unit 16
Unit17 | Unit 17
Unit18 | Unit 18
Unit19 | Unit 19
Unit2 | Unit 2
Unit20 | Unit 20
Unit21 | Unit 21
Unit22 | Unit 22
Unit23 | Unit 23
Unit24 | Unit 24
Unit25 | Unit 25
Unit26 | Unit 26
Unit27 | Unit 27
Unit28 | Unit 28
Unit29 | Unit 29
Unit3 | Unit 3
Unit30 | Unit 30
Unit31 | Unit 31
Unit32 | Unit 32
Unit4 | Unit 4
Unit5 | Unit 5
Unit6 | Unit 6
Unit7 | Unit 7
Unit8 | Unit 8
Unit9 | Unit 9

Remarks

Used by the CurrentUnitId, ErrorUnits, UnitsOnline, EventUnitId, and EventUnits properties of the BumpBar and RemoteOrderDisplay classes. Also used by methods of both classes.

Members of this enumeration replaces the BB_UID_ and ROD_UID_ families of UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
BumpBar Class
RemoteOrderDisplay


DirectIOData Structure

DirectIOData Structure |
 | See Also Members

1/18/2008

Defines the programmatic structure the service object uses to return data to an application.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Structure DirectIOData
public struct DirectIOData
public value class DirectIOData
public final class DirectIOData extends ValueType

Remarks

Used as the return value of the DirectIO method of PosCommon class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DirectIOData Members
Microsoft.PointOfService Namespace
DirectIO


DirectIOData Members

DirectIOData Members |
 | See Also Constructors Methods Properties

1/18/2008

Defines the programmatic structure the service object uses to return data to an application.

The following tables list the members exposed by the DirectIOData type.

Public Constructors

Name | Description
DirectIOData | Creates an instance of the DirectIOData structure with the specified data.
Top

Public Properties

Name | Description
Data | Gets the data, as defined by the service object, to be transferred through the DirectIO method.
Object | Gets an object, as defined by the service object, to be transferred through the DirectIO method.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. Determines whether the specified object is equal to the current DirectIOData.
GetHashCode | Overridden. Returns the hash code of the current DirectIOData.
GetType | (inherited from Object )
op_Equality | Compares the specified DirectIOData and object to determine whether they are equal.
op_Inequality | Returns a value indicating whether an instance of DirectIOData and an object are not equal.
ReferenceEquals | (inherited from Object )
ToString | Overridden. Returns a string representation of the DirectIOData instance.
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

DirectIOData Structure
Microsoft.PointOfService Namespace
DirectIO


DirectIOData Constructor

DirectIOData Constructor |
 | See Also

1/18/2008

Creates an instance of the DirectIOData structure with the specified data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    data As Integer, _
    obj As Object _
)
public DirectIOData (
    int data,
    Object obj
)
public:
DirectIOData (
    int data,
    Object^ obj
)
public DirectIOData (
    int data,
    Object obj
)
public function DirectIOData (
    data : int,
    obj : Object
)

Parameters

data

Integer data.

obj

An object.

Remarks

This constructor creates an instance of the DirectIOData structure with the specified data.

See Also

Reference

DirectIOData Structure
DirectIOData Members
Microsoft.PointOfService Namespace


DirectIOData Methods

DirectIOData Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. Determines whether the specified object is equal to the current DirectIOData.
GetHashCode | Overridden. Returns the hash code of the current DirectIOData.
GetType | (inherited from Object )
op_Equality | Compares the specified DirectIOData and object to determine whether they are equal.
op_Inequality | Returns a value indicating whether an instance of DirectIOData and an object are not equal.
ReferenceEquals | (inherited from Object )
ToString | Overridden. Returns a string representation of the DirectIOData instance.

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

DirectIOData Structure
Microsoft.PointOfService Namespace
DirectIO


DirectIOData.Equals Method

DirectIOData.Equals Method |
 | See Also

1/18/2008

Determines whether the specified object is equal to the current DirectIOData.

Overload List

Name | Description
DirectIOData.Equals (DirectIOData) | Determines whether the specified DirectIOData is equal to the current DirectIOData.
DirectIOData.Equals (Object) | Determines whether the specified Object is equal to the current DirectIOData.
DirectIOData.Equals (DirectIOData, DirectIOData) | Determines whether the specified DirectIOData instances are equal.
DirectIOData.Equals (Object, Object) | (inherited from Equals )

See Also

Reference

DirectIOData Structure
DirectIOData Members
Microsoft.PointOfService Namespace


DirectIOData.Equals Method (DirectIOData)

DirectIOData.Equals Method (DirectIOData) |
 | See Also

1/18/2008

Determines whether the specified DirectIOData is equal to the current DirectIOData.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Function Equals ( _
    d As DirectIOData _
) As Boolean
public bool Equals (
    DirectIOData d
)
public:
bool Equals (
    DirectIOData d
)
public boolean Equals (
    DirectIOData d
)
public function Equals (
    d : DirectIOData
) : boolean

Parameters

d

The DirectIOData object to be compared to the current DirectIOData.

Return Value

A Boolean value that is true if the two instances are equal; otherwise, the value is false.

Remarks

This method determines whether the specified DirectIOData is equal to the current DirectIOData.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DirectIOData Structure
DirectIOData Members
Microsoft.PointOfService Namespace


DirectIOData.Equals Method (Object)

DirectIOData.Equals Method (Object) |
 | See Also

1/18/2008

Determines whether the specified Object is equal to the current DirectIOData.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public override bool Equals (
    Object obj
)
public:
virtual bool Equals (
    Object^ obj
) override
public boolean Equals (
    Object obj
)
public override function Equals (
    obj : Object
) : boolean

Parameters

obj

The object to be compared with the current DirectIOData.

Return Value

True if the specified object is equal to the current DirectIOData; otherwise, false.

Remarks

This method determines whether the specified Object is equal to the current DirectIOData.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DirectIOData Structure
DirectIOData Members
Microsoft.PointOfService Namespace


DirectIOData.Equals Method (DirectIOData, DirectIOData)

DirectIOData.Equals Method (DirectIOData, DirectIOData) |
 | See Also

1/18/2008

Determines whether the specified DirectIOData instances are equal.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Function Equals ( _
    a As DirectIOData, _
    b As DirectIOData _
) As Boolean
public static bool Equals (
    DirectIOData a,
    DirectIOData b
)
public:
static bool Equals (
    DirectIOData a,
    DirectIOData b
)
public static boolean Equals (
    DirectIOData a,
    DirectIOData b
)
public static function Equals (
    a : DirectIOData,
    b : DirectIOData
) : boolean

Parameters

a

The first DirectIOData instance.

b

The second DirectIOData instance.

Return Value

True if the value of a is equal to the value of b; otherwise, false.

Remarks

This method determines whether the specified DirectIOData instances are equal.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DirectIOData Structure
DirectIOData Members
Microsoft.PointOfService Namespace


DirectIOData.GetHashCode Method

DirectIOData.GetHashCode Method |
 | See Also

1/18/2008

Returns the hash code of the current DirectIOData.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function GetHashCode As Integer
public override int GetHashCode ()
public:
virtual int GetHashCode () override
public int GetHashCode ()
public override function GetHashCode () : int

Return Value

An Int32 representation of the hash code for the current DirectIOData.

Remarks

This method returns the hash code of the current DirectIOData.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DirectIOData Structure
DirectIOData Members
Microsoft.PointOfService Namespace


DirectIOData.op_Equality Method

DirectIOData.op_Equality Method |
 | See Also

1/18/2008

Compares the specified DirectIOData and object to determine whether they are equal.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Operator = ( _
    a As DirectIOData, _
    b As Object _
) As Boolean
public static bool operator == (
    DirectIOData a,
    Object b
)
public:
static bool operator == (
    DirectIOData a,
    Object^ b
)

Parameters

a

The DirectIOData to be compared to b.

b

The object to be compared to a.

Return Value

True if the value of a is equal to the value of b; otherwise, false.

Remarks

This method compares the specified DirectIOData and object to determine whether they are equal.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DirectIOData Structure
DirectIOData Members
Microsoft.PointOfService Namespace


DirectIOData.op_Inequality Method

DirectIOData.op_Inequality Method |
 | See Also

1/18/2008

Returns a value indicating whether an instance of DirectIOData and an object are not equal.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Operator <> ( _
    a As DirectIOData, _
    b As Object _
) As Boolean
public static bool operator != (
    DirectIOData a,
    Object b
)
public:
static bool operator != (
    DirectIOData a,
    Object^ b
)

Parameters

a

The DirectIOData to be compared to b.

b

The object to be compared to a.

Return Value

A Boolean value that is true if a is not equal to b and false otherwise.

Remarks

This method returns a value indicating whether an instance of DirectIOData and an object are unequal.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DirectIOData Structure
DirectIOData Members
Microsoft.PointOfService Namespace


DirectIOData.ToString Method

DirectIOData.ToString Method |
 | See Also

1/18/2008

Returns a string representation of the DirectIOData instance.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function ToString As String
public override string ToString ()
public:
virtual String^ ToString () override
public String ToString ()
public override function ToString () : String

Return Value

A string representation of the DirectIOData.

Remarks

Returns a string representation of the DirectIOData instance.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DirectIOData Structure
DirectIOData Members
Microsoft.PointOfService Namespace


DirectIOData Properties

DirectIOData Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
Data | Gets the data, as defined by the service object, to be transferred through the DirectIO method.
Object | Gets an object, as defined by the service object, to be transferred through the DirectIO method.

See Also

Reference

DirectIOData Structure
Microsoft.PointOfService Namespace
DirectIO


DirectIOData.Data Property

DirectIOData.Data Property |
 | See Also

1/18/2008

Gets the data, as defined by the service object, to be transferred through the DirectIO method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Data As Integer
public int Data { get; }
public:
property int Data {
    int get ();
}
/** @property */
public int get_Data ()

public function get Data () : int

Remarks

This property holds the Direct IO data, as defined by the service object that is transferred through the DirectIO method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DirectIOData Structure
DirectIOData Members
Microsoft.PointOfService Namespace


DirectIOData.Object Property

DirectIOData.Object Property |
 | See Also

1/18/2008

Gets an object, as defined by the service object, to be transferred through the DirectIO method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Object As Object
public Object Object { get; }
public:
property Object^ Object {
    Object^ get ();
}
/** @property */
public Object get_Object ()

public function get Object () : Object

Remarks

This property holds an object, as defined by the service object, to be transferred through the DirectIO method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DirectIOData Structure
DirectIOData Members
Microsoft.PointOfService Namespace


DirectIOEventArgs Class

DirectIOEventArgs Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for the transmission of Direct IO Events.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Class DirectIOEventArgs
    Inherits PosEventArgs
public class DirectIOEventArgs : PosEventArgs
public ref class DirectIOEventArgs : public PosEventArgs
public class DirectIOEventArgs extends PosEventArgs
public class DirectIOEventArgs extends PosEventArgs

Remarks

Holds event data for DirectIOEvent events.

Inheritance Hierarchy

System.Object
System.EventArgs
Microsoft.PointOfService.PosEventArgs
Microsoft.PointOfService.DirectIOEventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DirectIOEventArgs Members
Microsoft.PointOfService Namespace
DirectIOEvent


DirectIOEventArgs Members

DirectIOEventArgs Members |
 | See Also Constructors Fields Methods Properties

1/18/2008

Defines the programmatic interface for the transmission of Direct IO Events.

The following tables list the members exposed by the DirectIOEventArgs type.

Public Constructors

Name | Description
DirectIOEventArgs | Creates an instance of the DirectIOEventArgs class with the specified data.
Top

Public Fields

Name | Description
Empty | (inherited from EventArgs )
Top

Public Properties

Name | Description
Data | Gets or sets additional numeric data for a DirectIOEvent event.
EventId | Gets the event identifier. (inherited from PosEventArgs)
EventNumber | Gets the event number for a DirectIOEvent event.
Object | Gets or sets the object that is the DirectIOEvent event.
TimeStamp | Gets the DateTime of the event. (inherited from PosEventArgs)
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Overridden. Returns a string representation of the object.
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

DirectIOEventArgs Class
Microsoft.PointOfService Namespace
DirectIOEvent


DirectIOEventArgs Fields

DirectIOEventArgs Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
Empty | (inherited from EventArgs )

See Also

Reference

DirectIOEventArgs Class
Microsoft.PointOfService Namespace
DirectIOEvent


DirectIOEventArgs Constructor

DirectIOEventArgs Constructor |
 | See Also

1/18/2008

Creates an instance of the DirectIOEventArgs class with the specified data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    eventNumber As Integer, _
    data As Integer, _
    obj As Object _
)
public DirectIOEventArgs (
    int eventNumber,
    int data,
    Object obj
)
public:
DirectIOEventArgs (
    int eventNumber,
    int data,
    Object^ obj
)
public DirectIOEventArgs (
    int eventNumber,
    int data,
    Object obj
)
public function DirectIOEventArgs (
    eventNumber : int,
    data : int,
    obj : Object
)

Parameters

eventNumber

Event number whose specific values are assigned by POS for .NET.

data

Additional numeric data.

obj

An object.

See Also

Reference

DirectIOEventArgs Class
DirectIOEventArgs Members
Microsoft.PointOfService Namespace
BinaryConversion Enumeration


DirectIOEventArgs Methods

DirectIOEventArgs Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Overridden. Returns a string representation of the object.

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

DirectIOEventArgs Class
Microsoft.PointOfService Namespace
DirectIOEvent


DirectIOEventArgs.ToString Method

DirectIOEventArgs.ToString Method |
 | See Also

1/18/2008

Returns a string representation of the object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function ToString As String
public override string ToString ()
public:
virtual String^ ToString () override
public String ToString ()
public override function ToString () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DirectIOEventArgs Class
DirectIOEventArgs Members
Microsoft.PointOfService Namespace


DirectIOEventArgs Properties

DirectIOEventArgs Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
Data | Gets or sets additional numeric data for a DirectIOEvent event.
EventId | Gets the event identifier. (inherited from PosEventArgs )
EventNumber | Gets the event number for a DirectIOEvent event.
Object | Gets or sets the object that is the DirectIOEvent event.
TimeStamp | Gets the DateTime of the event. (inherited from PosEventArgs )

See Also

Reference

DirectIOEventArgs Class
Microsoft.PointOfService Namespace
DirectIOEvent


DirectIOEventArgs.Data Property

DirectIOEventArgs.Data Property |
 | See Also

1/18/2008

Gets or sets additional numeric data for a DirectIOEvent event.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Property Data As Integer
public int Data { get; set; }
public:
property int Data {
    int get ();
    void set (int value);
}
/** @property */
public int get_Data ()

/** @property */
public void set_Data (int value)

public function get Data () : int

public function set Data (value : int)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DirectIOEventArgs Class
DirectIOEventArgs Members
Microsoft.PointOfService Namespace


DirectIOEventArgs.EventNumber Property

DirectIOEventArgs.EventNumber Property |
 | See Also

1/18/2008

Gets the event number for a DirectIOEvent event.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property EventNumber As Integer
public int EventNumber { get; }
public:
property int EventNumber {
    int get ();
}
/** @property */
public int get_EventNumber ()

public function get EventNumber () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DirectIOEventArgs Class
DirectIOEventArgs Members
Microsoft.PointOfService Namespace


DirectIOEventArgs.Object Property

DirectIOEventArgs.Object Property |
 | See Also

1/18/2008

Gets or sets the object that is the DirectIOEvent event.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Property Object As Object
public Object Object { get; set; }
public:
property Object^ Object {
    Object^ get ();
    void set (Object^ value);
}
/** @property */
public Object get_Object ()

/** @property */
public void set_Object (Object value)

public function get Object () : Object

public function set Object (value : Object)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DirectIOEventArgs Class
DirectIOEventArgs Members
Microsoft.PointOfService Namespace


DirectIOEventHandler Delegate

DirectIOEventHandler Delegate |
 | See Also

1/18/2008

Defines the method that handles a DirectIOEventArgs events.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Delegate Sub DirectIOEventHandler ( _
    sender As Object, _
    e As DirectIOEventArgs _
)
public delegate void DirectIOEventHandler (
    Object sender,
    DirectIOEventArgs e
)
public delegate void DirectIOEventHandler (
    Object^ sender,
    DirectIOEventArgs^ e
)
/** @delegate */
public delegate void DirectIOEventHandler (
    Object sender,
    DirectIOEventArgs e
)

Parameters

sender

The source of the event.

e

A DirectIOEventArgs that contains the event data.

Remarks

The declaration of your event handler must have the same parameters as the DirectIOEventHandler delegate declaration.

When you create a DirectIOEventHandler delegate, you identify the method that handles the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

See Also

Reference

Microsoft.PointOfService Namespace


DisplayBlink Enumeration

DisplayBlink Enumeration |
 | See Also

1/18/2008

Enumerates the valid line display blink capabilities for a Line Display device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration DisplayBlink
public enum DisplayBlink
public enum class DisplayBlink
public enum DisplayBlink
public enum DisplayBlink

Members

Member name | Description
All | The line display supports blinking for the entire display. The service object sets the entire contents of the display to blink or to be in a steady state.
Each | The line display supports blinking for each character. The service object can set each character to blink individually or to be in a steady state.
None | The line display device does not support blinking; the value is 0 (zero).

Remarks

Used by the CapBlink property. Members of this enumeration replace the DSP_CB_NOBLINK, DSP_CB_BLINKALL, and DSB_CB_BLINKEACH UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
CapBlink


DisplayCursors Enumeration

DisplayCursors Enumeration |
 | See Also

1/18/2008

Enumerates the possible supported cursor types.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration DisplayCursors
[FlagsAttribute]
public enum DisplayCursors
[FlagsAttribute]
public enum class DisplayCursors
/** @attribute FlagsAttribute() */
public enum DisplayCursors
FlagsAttribute
public enum DisplayCursors

Members

Member name | Description
Blink | A blinking cursor is supported.
Block | Cursor is displayable as a block.
Fixed | Cursor is always displayed.
HalfBlock | Cursor is displayable as a half block.
None | Cursor is not displayable.
Other | Cursor is displayable but form is unknown.
Reverse | Cursor is displayable in reverse video.
Underline | Cursor is displayable as an underline.

Remarks

Used by the CapCursorType and CursorType properties. Members of this enumeration replace the DISP_CCT_ and DISP_CT_ families of UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
CapCursorType
CursorType


DisplayMarqueeFormat Enumeration

DisplayMarqueeFormat Enumeration |
 | See Also

1/18/2008

Enumerates the possible marquee format values.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration DisplayMarqueeFormat
public enum DisplayMarqueeFormat
public enum class DisplayMarqueeFormat
public enum DisplayMarqueeFormat
public enum DisplayMarqueeFormat

Members

Member name | Description
Place | Begin the marquee by 'walking' data from the opposite side.
Walk | Begin the marquee by placing data.

Remarks

Used by the MarqueeFormat property. Members of this property replace the DISP_MF_WALK and DISP_MF_PLACE UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
MarqueeFormat


DisplayMarqueeType Enumeration

DisplayMarqueeType Enumeration |
 | See Also

1/18/2008

Enumerates the valid marquee type values.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration DisplayMarqueeType
public enum DisplayMarqueeType
public enum class DisplayMarqueeType
public enum DisplayMarqueeType
public enum DisplayMarqueeType

Members

Member name | Description
Down | Scrolls the window down.
Init | Indicates the Marquee Init mode.
Left | Scrolls the window left.
None | Marquees are disabled for this window.
Right | Scrolls the window right.
Up | Scrolls the window up.

Remarks

Used by the MarqueeType property. Members of this enumeration replace the DISP_MT_NONE, DISP_MT_INIT, DISP_MT_UP, DISP_MT_DOWN, DISP_MT_LEFT, and DISP_MT_RIGHT UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
MarqueeFormat


DisplayReadBack Enumeration

DisplayReadBack Enumeration |
 | See Also

1/18/2008

Enumerates the possible read back capability values.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration DisplayReadBack
public enum DisplayReadBack
public enum class DisplayReadBack
public enum DisplayReadBack
public enum DisplayReadBack

Members

Member name | Description
None | Read back is not supported.
Single | Read back of a single character at a time is supported.

Remarks

Used by the CapReadBack property. Members of this enumeration replace the DISP_CRB_NONE and DISP_CRB_SINGLE UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
CapReadBack


DisplayReverse Enumeration

DisplayReverse Enumeration |
 | See Also

1/18/2008

Enumerates the possible reverse video capability values.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration DisplayReverse
public enum DisplayReverse
public enum class DisplayReverse
public enum DisplayReverse
public enum DisplayReverse

Members

Member name | Description
All | Reverse video is not supported.
Each | Reverse video is supported. The entire contents of the display are either in reverse video or displayed normally.
None | Reverse video is supported. Each character may be individually set to reverse video or normal.

Remarks

Used by the CapReverse property. Members of this enumeration replace the DISP_CR_NONE, DISP_CR_REVERSEALL, and DISP_CR_REVERSEEACH UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
CapReverse


DisplayScreenMode Class

DisplayScreenMode Class |
 | See Also Members

1/18/2008

Defines a screen mode—that is, the number of rows and columns supported—for a line display device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Class DisplayScreenMode
public class DisplayScreenMode
public ref class DisplayScreenMode
public class DisplayScreenMode
public class DisplayScreenMode

Remarks

An array of DisplayScreenMode instances is used to provide a list supported screen modes for the ScreenModeList property.

DisplayScreenMode is also inherited by the LineDisplayScreenMode class, which is used by POS for .NET LineDisplayBase class to create a list of supported line display screen modes defined by row, column, glyph height, glyph width, maximum X, and maximum Y values.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.DisplayScreenMode
Microsoft.PointOfService.BaseServiceObjects.LineDisplayScreenMode

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DisplayScreenMode Members
Microsoft.PointOfService Namespace


DisplayScreenMode Members

DisplayScreenMode Members |
 | See Also Constructors Methods Properties

1/18/2008

Defines a screen mode—that is, the number of rows and columns supported—for a line display device.

The following tables list the members exposed by the DisplayScreenMode type.

Public Constructors

Name | Description
DisplayScreenMode | Creates an instance of the DisplayScreenMode class.
Top

Public Properties

Name | Description
Columns | Gets the number of columns supported for this screen mode.
Rows | Gets the number of rows supported for this screen mode.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Overridden. Returns a string representation of the object.
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

DisplayScreenMode Class
Microsoft.PointOfService Namespace


DisplayScreenMode Constructor

DisplayScreenMode Constructor |
 | See Also

1/18/2008

Creates an instance of the DisplayScreenMode class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    rows As Integer, _
    columns As Integer _
)
public DisplayScreenMode (
    int rows,
    int columns
)
public:
DisplayScreenMode (
    int rows,
    int columns
)
public DisplayScreenMode (
    int rows,
    int columns
)
public function DisplayScreenMode (
    rows : int,
    columns : int
)

Parameters

rows

Number of rows.

columns

Number of columns.

See Also

Reference

DisplayScreenMode Class
DisplayScreenMode Members
Microsoft.PointOfService Namespace


DisplayScreenMode Methods

DisplayScreenMode Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Overridden. Returns a string representation of the object.

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

DisplayScreenMode Class
Microsoft.PointOfService Namespace


DisplayScreenMode.ToString Method

DisplayScreenMode.ToString Method |
 | See Also

1/18/2008

Returns a string representation of the object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function ToString As String
public override string ToString ()
public:
virtual String^ ToString () override
public String ToString ()
public override function ToString () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DisplayScreenMode Class
DisplayScreenMode Members
Microsoft.PointOfService Namespace


DisplayScreenMode Properties

DisplayScreenMode Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
Columns | Gets the number of columns supported for this screen mode.
Rows | Gets the number of rows supported for this screen mode.

See Also

Reference

DisplayScreenMode Class
Microsoft.PointOfService Namespace


DisplayScreenMode.Columns Property

DisplayScreenMode.Columns Property |
 | See Also

1/18/2008

Gets the number of columns supported for this screen mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Columns As Integer
public int Columns { get; }
public:
property int Columns {
    int get ();
}
/** @property */
public int get_Columns ()

public function get Columns () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DisplayScreenMode Class
DisplayScreenMode Members
Microsoft.PointOfService Namespace


DisplayScreenMode.Rows Property

DisplayScreenMode.Rows Property |
 | See Also

1/18/2008

Gets the number of rows supported for this screen mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Rows As Integer
public int Rows { get; }
public:
property int Rows {
    int get ();
}
/** @property */
public int get_Rows ()

public function get Rows () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DisplayScreenMode Class
DisplayScreenMode Members
Microsoft.PointOfService Namespace


DisplayScrollText Enumeration

DisplayScrollText Enumeration |
 | See Also

1/18/2008

Enumerates the possible scrolling directions.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration DisplayScrollText
public enum DisplayScrollText
public enum class DisplayScrollText
public enum DisplayScrollText
public enum DisplayScrollText

Members

Member name | Description
Down | Scrolls the window down.
Left | Scrolls the window left.
Right | Scrolls the window right.
Up | Scrolls the window up.

Remarks

Used by the ScrollText method. Members of this enumeration replace the DISP_ST_UP, DISP_ST_DOWN, DISP_ST_LEFT, and DISP_ST_RIGHT UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
ScrollText


DisplaySetDescriptor Enumeration

DisplaySetDescriptor Enumeration |
 | See Also

1/18/2008

Enumerates the possible display descriptor attributes.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration DisplaySetDescriptor
public enum DisplaySetDescriptor
public enum class DisplaySetDescriptor
public enum DisplaySetDescriptor
public enum DisplaySetDescriptor

Members

Member name | Description
Blink | Sets the descriptor to blinking.
Off | Turns the descriptor off.
On | Turns the descriptor on.

Remarks

Used by the SetDescriptor method. Members of this enumeration replace the DISP_SD_ON, DISP_SD_BLINK, and DISP_SD_OFF UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
SetDescriptor


DisplayTextMode Enumeration

DisplayTextMode Enumeration |
 | See Also

1/18/2008

Enumerates the possible text mode values.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration DisplayTextMode
public enum DisplayTextMode
public enum class DisplayTextMode
public enum DisplayTextMode
public enum DisplayTextMode

Members

Member name | Description
Blink | Displays the text as blinking.
BlinkReverse | Displays the text in reverse video and blinking.
Normal | Displays the text normally.
Reverse | Displays the text in reverse video.

Remarks

Used by the DisplayText and DisplayTextAt methods. Members of this enumeration replace the DISP_DT_NORMAL, DISP_DT_BLINK, DISP_DT_REVERSE, DISP_DT_BLINKREVERSE UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
DisplayText
DisplayText
DisplayTextAt
DisplayTextAt


EftTransactionCompletion Enumeration

EftTransactionCompletion Enumeration |
 | See Also

1/18/2008

Enumerates possible completion values for an EFT transaction.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration EftTransactionCompletion
public enum EftTransactionCompletion
public enum class EftTransactionCompletion
public enum EftTransactionCompletion
public enum EftTransactionCompletion

Members

Member name | Description
Abnormal | The EFT transaction completed abnormally.
Normal | The EFT transaction completed normally.

Remarks

Used by the EndEftTransaction method. Members of this enumeration replace the PPAD_EFT_NORMAL and PPAD_EFT_ABNORMAL UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
EndEftTransaction


EftTransactionType Enumeration

EftTransactionType Enumeration |
 | See Also

1/18/2008

Enumerates the possible EFT transaction types.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration EftTransactionType
public enum EftTransactionType
public enum class EftTransactionType
public enum EftTransactionType
public enum EftTransactionType

Members

Member name | Description
Admin | Indicates an administrative transaction.
Credit | Credits (increases) the specified amount.
Debit | Debits (decreases) the specified amount.
Inquiry | Indicates a balance inquiry.
Reconcile | Indicates reconciliation or settlement.

Remarks

Used by the TransactionType property. Members of this enumeration replaces the PPAD_TRANS_ family of UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
TransactionType


ElectronicJournal Class

ElectronicJournal Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for an Electronic Journal device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class ElectronicJournal
    Inherits PosCommon
public abstract class ElectronicJournal : PosCommon
public ref class ElectronicJournal abstract : public PosCommon
public abstract class ElectronicJournal extends PosCommon
public abstract class ElectronicJournal extends PosCommon

Remarks

The Electronic Journal device stores transaction records on digital media as electronic data. If the recording function of the Electronic Journal device is enabled, it stores all printer data that is output to the PosPrinter device. For the FiscalPrinter device, the Fiscal Printing output is always stored.

The Electronic Journal is primarily tasked with storing and transferring transaction data, but may also have the following capabilities:

  • Print stored data on the attached PosPrinter or FiscalPrinter.

  • Erase stored data.

  • Initialize recording medium.

In fiscal environments, Electronic Journal may also let you reprint whole fiscal documents and tickets, specifying a range of ticket numbers or ticket dates and times.

Programming Model

The Electronic Journal writing process is started implicitly when a printing method for the PosPrinter or FiscalPrinter is performed. All output is performed on a first-in first-out basis. Therefore, an ErrorEvent event is delivered if the writing process fails.

ElectronicJournal always performs the following methods synchronously: AddMarker RetrieveCurrentMarkerRetrieveMarkerRetrieveMarkerByDateTime and RetrieveMarkersDateTime. These methods will fail if output to the PosPrinter or FiscalPrinter is outstanding.

The SuspendPrintContent and SuspendQueryContent methods are also always performed synchronously. But these methods try to stop printing at the next printer operation and may be called when asynchronous output is outstanding. These methods are primarily intended for use in exception conditions when asynchronous output is outstanding.

The following methods are performed either synchronously or asynchronously, depending on the value of the AsyncMode property: EraseMedium, InitializeMedium, PrintContent, PrintContentFile, and QueryContent. When AsyncMode is false, these methods are performed synchronously. A marker can be added where data is stored to be used as an index. The data range can be obtained by adding markers at the beginning and at the end of the data when getting or printing stored data. During asynchronous data printing or transfer process, it can be suspended by interrupt methods.

In fiscal environments the markers are set implicitly by the FiscalPrinter device. The stored data is organized in sessions that correspond to the fiscal days that contain documents that correspond to fiscal tickets. Sessions and documents can be queried by the application indirectly by using the RetrieveMarker, RetrieveMarkerByDateTime, and RetrieveCurrentMarker methods. The returned markers are intended to be used with the PrintContent and QueryContent methods. The content and format of the markers are implementation-specific and do not have to be known or analyzed by the application.

An Electronic Journal device combines both the properties of an input device (query) and an output device (store and print). The data that is stored in the medium is data output into PosPrinter and FiscalPrinter that is electronic data of receipts and its data format depends on the physical device model. The data should be stored in nonvolatile memory, and flash cards; memory cards, CD-RW, and HDD can all be used as physical media. You do not have to distinguish the differences between the physical media.

If the recording medium can be removed from or inserted into the device, a StatusUpdateEvent is delivered when the medium status is changed. Additionally, the medium status can be checked and it can be initialized if it is necessary. The primary responsibility is storing transaction data as it is. Therefore, there are no functions to convert or reprocess the data.

Device Sharing

The Electronic Journal is an exclusive-use device, as follows:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before accessing many of the Electronic Journal-specific properties.

  • The application must claim and enable the device before it calls methods that manipulate the device.

Platforms

The ElectronicJournal class requires POS for .NET 1.10 or later versions.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.ElectronicJournal
Microsoft.PointOfService.BasicServiceObjects.ElectronicJournalBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Members
Microsoft.PointOfService Namespace


ElectronicJournal Members

ElectronicJournal Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for an Electronic Journal device.

The following tables list the members exposed by the ElectronicJournal type.

Protected Constructors

Name | Description
ElectronicJournal | Creates an instance of the ElectronicJournal class.
Top

Public Fields

Name | Description
ExtendedErrorCorruptedMedium | Indicates that the medium is corrupted.
ExtendedErrorExisting | Indicates that the marker name is already specified in the medium.
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorMediumFull | Holds a value that indicates that the medium is full.
ExtendedErrorMultipleMarker | Indicates that more than one marker exists for the specified time period.
ExtendedErrorMultipleMarkers | Indicates that, although multiple markers were requested, only one can be returned.
ExtendedErrorNotEnoughSpace | Indicates that there is insufficient free space.
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
ExtendedErrorUninitializedMedium | Indicates that the medium is not initialized.
ExtendedErrorUnknownDataFormat | Indicates that the medium has an unknown or unsupported data format.
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticEraseCount | Indicates the number of times the medium has been erased.
StatisticFailedWriteCount | Holds the number of failed write operations.
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticMediumFreeSpace | Holds a value that indicates the free space on the medium.
StatisticMediumRemovedCount | Indicates the number of times the medium is removed.
StatisticMediumSize | Indicates the medium size.
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatisticWriteCount | Indicates the number of write operations that are performed on the medium.
StatusIdle |
StatusMediumFull | Holds a value that indicates that the medium is full.
StatusMediumInserted | Holds a value that indicates that the medium is currently inserted.
StatusMediumNearFull | Holds a value that indicates that the medium is almost full.
StatusMediumRemoved | Holds a value that indicates that the medium has been removed.
StatusMediumSuspended | Holds a value that indicates that the medium is suspended.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
AsyncMode | Gets or sets the Boolean value that indicates whether the print methods are performed asynchronously.
AutoDisable | Gets or sets the Boolean value that indicates whether POS for .NET automatically disables the device when data is received.
CapAddMarker | Gets the Boolean value that indicates whether the application can use the AddMarker method.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapErasableMedium | Gets the Boolean value that indicates whether the storage medium can be erased.
CapInitializeMedium | Gets the Boolean value that indicates whether the application can initialize the medium.
CapMediumIsAvailable | Gets the Boolean value that indicates whether the application can search for a connected recording medium.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapPrintContent | Gets the Boolean value that indicates whether the device can reprint stored journal documents on a connected printer.
CapPrintContentFile | Gets the Boolean value that indicates whether journal documents that are extracted from the storage medium can be printed on a connected printing device.
CapRetrieveCurrentMarker | Gets the Boolean value that indicates whether the application can use the RetrieveCurrentMarker method.
CapRetrieveMarker | Gets the Boolean value that indicates whether the application can use the RetrieveMarker method.
CapRetrieveMarkerByDateTime | Gets the Boolean value that indicates whether the application can use the RetrieveMarkerByDateTime method.
CapRetrieveMarkersDateTime | Gets the Boolean value that indicates whether the application can use the RetrieveMarkersDateTime method.
CapStation | Gets the availability of data capturing for the device and the storage medium.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapStorageEnabled | Gets the Boolean value that indicates whether the recording of print data can be managed by the StorageEnabled property.
CapSuspendPrintContent | Gets the Boolean value that indicates whether the printing process can be suspended.
CapSuspendQueryContent | Gets the Boolean value that indicates whether the data querying process can be suspended.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CapWatermark | Gets the Boolean value that indicates whether the device can print predefined background when reprinting journal documents.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
DataCount | Gets the Boolean value that indicates the number of currently queued DataEvent events.
DataEventEnabled | Gets or sets the Boolean value that indicates whether a DataEvent event is delivered whenever input data is queued.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
FlagWhenIdle | Gets or sets the Boolean value that indicates whether the device delivers a StatusUpdateEvent when it becomes idle.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
MediumFreeSpace | Gets the remaining free space of the storage medium, in bytes,.
MediumId | Gets identification for the currently plugged medium.
MediumIsAvailable | Gets the Boolean value that indicates whether a recording medium is attached or not.
MediumSize | Gets the size of the storage medium in bytes.
OutputId | Gets the identifier of the most recently started asynchronous output.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
Station | Gets or sets the station for later data storing into the medium.
StorageEnabled | Gets or sets the Boolean value that indicates whether the device is in a recordable state.
Suspended | Gets the Boolean value that indicates whether the printing or data obtaining process is suspended.
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Watermark | Gets or sets the Boolean value that indicates whether a predefined background should be printed with journal documents.
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets the Boolean value that indicates whether the device is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
AddMarker | Adds a marker to the end of the data that is stored on the recording medium.
CancelPrintContent | Cancels the suspended data printing process.
CancelQueryContent | Cancels a suspended data transfer process.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all buffered device input.
ClearOutput | Clears all buffered tone outputs.
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
EraseMedium | Erases all data in the medium.
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
InitializeMedium | Initializes the recording medium.
Open | Opens a device for later input/output processing. (inherited from PosCommon)
PrintContent | Prints the current journal document stored in the recording medium onto the connected printer system.
PrintContentFile | Prints the journal document from the specified file onto the connected printer.
QueryContent | Queries the content and stores it. The format of the data that is stored on the medium depends on the physical device model.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
ResumePrintContent | Resumes the suspended data printing process.
ResumeQueryContent | Resumes the suspended data transfer process.
RetrieveCurrentMarker | Returns the last implicitly stored marker.
RetrieveMarker | Returns a marker implicitly stored on the record medium.
RetrieveMarkerByDateTime | Returns a marker implicitly stored on the record medium.
RetrieveMarkersDateTime | Returns the date/time of the given marker.
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
SuspendPrintContent | Suspends all data transfer from the device and then suspends the device state.
SuspendQueryContent | Suspends all data transfer from the device, and then suspends the device state.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DataEvent | Notifies the application that the queried Electronic Journal has finished storing its content in a host file.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
ErrorEvent | Notifies the application that an Electronic Journal error has been detected and that a suitable response by the application is necessary to process the error condition.
OutputCompleteEvent | Notifies the application that the queued output request has completed successfully.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

ElectronicJournal Class
Microsoft.PointOfService Namespace


ElectronicJournal Fields

ElectronicJournal Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorCorruptedMedium | Indicates that the medium is corrupted.
ExtendedErrorExisting | Indicates that the marker name is already specified in the medium.
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorMediumFull | Holds a value that indicates that the medium is full.
ExtendedErrorMultipleMarker | Indicates that more than one marker exists for the specified time period.
ExtendedErrorMultipleMarkers | Indicates that, although multiple markers were requested, only one can be returned.
ExtendedErrorNotEnoughSpace | Indicates that there is insufficient free space.
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
ExtendedErrorUninitializedMedium | Indicates that the medium is not initialized.
ExtendedErrorUnknownDataFormat | Indicates that the medium has an unknown or unsupported data format.
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticEraseCount | Indicates the number of times the medium has been erased.
StatisticFailedWriteCount | Holds the number of failed write operations.
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticMediumFreeSpace | Holds a value that indicates the free space on the medium.
StatisticMediumRemovedCount | Indicates the number of times the medium is removed.
StatisticMediumSize | Indicates the medium size.
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatisticWriteCount | Indicates the number of write operations that are performed on the medium.
StatusIdle |
StatusMediumFull | Holds a value that indicates that the medium is full.
StatusMediumInserted | Holds a value that indicates that the medium is currently inserted.
StatusMediumNearFull | Holds a value that indicates that the medium is almost full.
StatusMediumRemoved | Holds a value that indicates that the medium has been removed.
StatusMediumSuspended | Holds a value that indicates that the medium is suspended.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

ElectronicJournal Class
Microsoft.PointOfService Namespace


ElectronicJournal.ExtendedErrorCorruptedMedium Field

ElectronicJournal.ExtendedErrorCorruptedMedium Field |
 | See Also

1/18/2008

Indicates that the medium is corrupted.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorCorruptedMedium As Integer
public const int ExtendedErrorCorruptedMedium
public:
literal int ExtendedErrorCorruptedMedium
public static final int ExtendedErrorCorruptedMedium
public const var ExtendedErrorCorruptedMedium : int

Remarks

Used by ErrorEvent as an extended errorcode.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace


ElectronicJournal.ExtendedErrorExisting Field

ElectronicJournal.ExtendedErrorExisting Field |
 | See Also

1/18/2008

Indicates that the marker name is already specified in the medium.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorExisting As Integer
public const int ExtendedErrorExisting
public:
literal int ExtendedErrorExisting
public static final int ExtendedErrorExisting
public const var ExtendedErrorExisting : int

Remarks

Used by ErrorEvent as an extended errorcode.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace


ElectronicJournal.ExtendedErrorMediumFull Field

ElectronicJournal.ExtendedErrorMediumFull Field |
 | See Also

1/18/2008

Holds a value that indicates that the medium is full.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorMediumFull As Integer
public const int ExtendedErrorMediumFull
public:
literal int ExtendedErrorMediumFull
public static final int ExtendedErrorMediumFull
public const var ExtendedErrorMediumFull : int

Remarks

Used by ErrorEvent as an extended errorcode.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace


ElectronicJournal.ExtendedErrorMultipleMarker Field

ElectronicJournal.ExtendedErrorMultipleMarker Field |
 | See Also

1/18/2008

Indicates that more than one marker exists for the specified time period.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorMultipleMarker As Integer
public const int ExtendedErrorMultipleMarker
public:
literal int ExtendedErrorMultipleMarker
public static final int ExtendedErrorMultipleMarker
public const var ExtendedErrorMultipleMarker : int

Remarks

Used by ErrorEvent as an extended errorcode.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace


ElectronicJournal.ExtendedErrorMultipleMarkers Field

ElectronicJournal.ExtendedErrorMultipleMarkers Field |
 | See Also

1/18/2008

Indicates that, although multiple markers were requested, only one can be returned.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorMultipleMarkers As Integer
public const int ExtendedErrorMultipleMarkers
public:
literal int ExtendedErrorMultipleMarkers
public static final int ExtendedErrorMultipleMarkers
public const var ExtendedErrorMultipleMarkers : int

Remarks

Used by ErrorEvent as an extended errorcode.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace


ElectronicJournal.ExtendedErrorNotEnoughSpace Field

ElectronicJournal.ExtendedErrorNotEnoughSpace Field |
 | See Also

1/18/2008

Indicates that there is insufficient free space.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorNotEnoughSpace As Integer
public const int ExtendedErrorNotEnoughSpace
public:
literal int ExtendedErrorNotEnoughSpace
public static final int ExtendedErrorNotEnoughSpace
public const var ExtendedErrorNotEnoughSpace : int

Remarks

Used by ErrorEvent as an extended errorcode.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace


ElectronicJournal.ExtendedErrorUninitializedMedium Field

ElectronicJournal.ExtendedErrorUninitializedMedium Field |
 | See Also

1/18/2008

Indicates that the medium is not initialized.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorUninitializedMedium As Integer
public const int ExtendedErrorUninitializedMedium
public:
literal int ExtendedErrorUninitializedMedium
public static final int ExtendedErrorUninitializedMedium
public const var ExtendedErrorUninitializedMedium : int

Remarks

Used by ErrorEvent as an extended errorcode.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace


ElectronicJournal.ExtendedErrorUnknownDataFormat Field

ElectronicJournal.ExtendedErrorUnknownDataFormat Field |
 | See Also

1/18/2008

Indicates that the medium has an unknown or unsupported data format.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorUnknownDataFormat As Integer
public const int ExtendedErrorUnknownDataFormat
public:
literal int ExtendedErrorUnknownDataFormat
public static final int ExtendedErrorUnknownDataFormat
public const var ExtendedErrorUnknownDataFormat : int

Remarks

Used by ErrorEvent as an extended errorcode.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace


ElectronicJournal.StatisticEraseCount Field

ElectronicJournal.StatisticEraseCount Field |
 | See Also

1/18/2008

Indicates the number of times the medium has been erased.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticEraseCount As String
public const string StatisticEraseCount
public:
literal String^ StatisticEraseCount
public static final String StatisticEraseCount
public const var StatisticEraseCount : String

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace


ElectronicJournal.StatisticFailedWriteCount Field

ElectronicJournal.StatisticFailedWriteCount Field |
 | See Also

1/18/2008

Holds the number of failed write operations.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticFailedWriteCount As String
public const string StatisticFailedWriteCount
public:
literal String^ StatisticFailedWriteCount
public static final String StatisticFailedWriteCount
public const var StatisticFailedWriteCount : String

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace


ElectronicJournal.StatisticMediumFreeSpace Field

ElectronicJournal.StatisticMediumFreeSpace Field |
 | See Also

1/18/2008

Holds a value that indicates the free space on the medium.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticMediumFreeSpace As String
public const string StatisticMediumFreeSpace
public:
literal String^ StatisticMediumFreeSpace
public static final String StatisticMediumFreeSpace
public const var StatisticMediumFreeSpace : String

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace


ElectronicJournal.StatisticMediumRemovedCount Field

ElectronicJournal.StatisticMediumRemovedCount Field |
 | See Also

1/18/2008

Indicates the number of times the medium is removed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticMediumRemovedCount As String
public const string StatisticMediumRemovedCount
public:
literal String^ StatisticMediumRemovedCount
public static final String StatisticMediumRemovedCount
public const var StatisticMediumRemovedCount : String

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace


ElectronicJournal.StatisticMediumSize Field

ElectronicJournal.StatisticMediumSize Field |
 | See Also

1/18/2008

Indicates the medium size.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticMediumSize As String
public const string StatisticMediumSize
public:
literal String^ StatisticMediumSize
public static final String StatisticMediumSize
public const var StatisticMediumSize : String

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace


ElectronicJournal.StatisticWriteCount Field

ElectronicJournal.StatisticWriteCount Field |
 | See Also

1/18/2008

Indicates the number of write operations that are performed on the medium.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticWriteCount As String
public const string StatisticWriteCount
public:
literal String^ StatisticWriteCount
public static final String StatisticWriteCount
public const var StatisticWriteCount : String

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace


ElectronicJournal.StatusIdle Field

ElectronicJournal.StatusIdle Field |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusIdle As Integer

public const int StatusIdle

public:
literal int StatusIdle

public static final int StatusIdle

public const var StatusIdle : int

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace


ElectronicJournal.StatusMediumFull Field

ElectronicJournal.StatusMediumFull Field |
 | See Also

1/18/2008

Holds a value that indicates that the medium is full.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusMediumFull As Integer
public const int StatusMediumFull
public:
literal int StatusMediumFull
public static final int StatusMediumFull
public const var StatusMediumFull : int

Remarks

Used as a parameter for StatusUpdateEvent events.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace


ElectronicJournal.StatusMediumInserted Field

ElectronicJournal.StatusMediumInserted Field |
 | See Also

1/18/2008

Holds a value that indicates that the medium is currently inserted.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusMediumInserted As Integer
public const int StatusMediumInserted
public:
literal int StatusMediumInserted
public static final int StatusMediumInserted
public const var StatusMediumInserted : int

Remarks

Used as a parameter for StatusUpdateEvent events.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace


ElectronicJournal.StatusMediumNearFull Field

ElectronicJournal.StatusMediumNearFull Field |
 | See Also

1/18/2008

Holds a value that indicates that the medium is almost full.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusMediumNearFull As Integer
public const int StatusMediumNearFull
public:
literal int StatusMediumNearFull
public static final int StatusMediumNearFull
public const var StatusMediumNearFull : int

Remarks

Used as a parameter for StatusUpdateEvent events.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace


ElectronicJournal.StatusMediumRemoved Field

ElectronicJournal.StatusMediumRemoved Field |
 | See Also

1/18/2008

Holds a value that indicates that the medium has been removed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusMediumRemoved As Integer
public const int StatusMediumRemoved
public:
literal int StatusMediumRemoved
public static final int StatusMediumRemoved
public const var StatusMediumRemoved : int

Remarks

Used as a parameter for StatusUpdateEvent events.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace


ElectronicJournal.StatusMediumSuspended Field

ElectronicJournal.StatusMediumSuspended Field |
 | See Also

1/18/2008

Holds a value that indicates that the medium is suspended.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusMediumSuspended As Integer
public const int StatusMediumSuspended
public:
literal int StatusMediumSuspended
public static final int StatusMediumSuspended
public const var StatusMediumSuspended : int

Remarks

Used as a parameter for StatusUpdateEvent events.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace


ElectronicJournal Constructor

ElectronicJournal Constructor |
 | See Also

1/18/2008

Creates an instance of the ElectronicJournal class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected ElectronicJournal ()
protected:
ElectronicJournal ()
protected ElectronicJournal ()
protected function ElectronicJournal ()

Remarks

Creates an instance of the ElectronicJournal class.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace


ElectronicJournal Methods

ElectronicJournal Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
AddMarker | Adds a marker to the end of the data that is stored on the recording medium.
CancelPrintContent | Cancels the suspended data printing process.
CancelQueryContent | Cancels a suspended data transfer process.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all buffered device input.
ClearOutput | Clears all buffered tone outputs.
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
EraseMedium | Erases all data in the medium.
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
InitializeMedium | Initializes the recording medium.
Open | Opens a device for later input/output processing. (inherited from PosCommon )
PrintContent | Prints the current journal document stored in the recording medium onto the connected printer system.
PrintContentFile | Prints the journal document from the specified file onto the connected printer.
QueryContent | Queries the content and stores it. The format of the data that is stored on the medium depends on the physical device model.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
ResumePrintContent | Resumes the suspended data printing process.
ResumeQueryContent | Resumes the suspended data transfer process.
RetrieveCurrentMarker | Returns the last implicitly stored marker.
RetrieveMarker | Returns a marker implicitly stored on the record medium.
RetrieveMarkerByDateTime | Returns a marker implicitly stored on the record medium.
RetrieveMarkersDateTime | Returns the date/time of the given marker.
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
SuspendPrintContent | Suspends all data transfer from the device and then suspends the device state.
SuspendQueryContent | Suspends all data transfer from the device, and then suspends the device state.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

ElectronicJournal Class
Microsoft.PointOfService Namespace


ElectronicJournal.AddMarker Method

ElectronicJournal.AddMarker Method |
 | See Also

1/18/2008

Adds a marker to the end of the data that is stored on the recording medium.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub AddMarker ( _
    marker As String _
)
public abstract void AddMarker (
    string marker
)
public:
virtual void AddMarker (
    String^ marker
) abstract
public abstract void AddMarker (
    String marker
)
public abstract function AddMarker (
    marker : String
)

Parameters

marker

Marker identifier.

Remarks

Adds a marker to the end of the data that is stored on the recording medium. Index numbers may be specified as arguments to specify the data range when obtaining data or printing on the connected PosPrinter system.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
CapAddMarker
RetrieveMarker


ElectronicJournal.CancelPrintContent Method

ElectronicJournal.CancelPrintContent Method |
 | See Also

1/18/2008

Cancels the suspended data printing process.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub CancelPrintContent
public abstract void CancelPrintContent ()
public:
virtual void CancelPrintContent () abstract
public abstract void CancelPrintContent ()
public abstract function CancelPrintContent ()

Remarks

If this method is performed successfully, any remaining data is not printed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
PrintContent
ResumePrintContent
SuspendPrintContent
Suspended
CapSuspendPrintContent


ElectronicJournal.CancelQueryContent Method

ElectronicJournal.CancelQueryContent Method |
 | See Also

1/18/2008

Cancels a suspended data transfer process.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub CancelQueryContent
public abstract void CancelQueryContent ()
public:
virtual void CancelQueryContent () abstract
public abstract void CancelQueryContent ()
public abstract function CancelQueryContent ()

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
Suspended
QueryContent
ResumeQueryContent
CapSuspendQueryContent


ElectronicJournal.ClearInput Method

ElectronicJournal.ClearInput Method |
 | See Also

1/18/2008

Clears all buffered device input.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearInput
public abstract void ClearInput ()
public:
virtual void ClearInput () abstract
public abstract void ClearInput ()
public abstract function ClearInput ()

Remarks

Clears all device input that has been buffered for the unit.

Any data events that are queued, usually waiting for DataEventEnabled to be set to true and FreezeEvents to be set to false, are also cleared.

ClearInput may throw a PosControlException with the following ErrorCodes.

Value | Meaning
Claimed | The device is claimed by another process.
NotClaimed | The device must be claimed before ClearInput can be used.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
ClearOutput


ElectronicJournal.ClearOutput Method

ElectronicJournal.ClearOutput Method |
 | See Also

1/18/2008

Clears all buffered tone outputs.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearOutput
public abstract void ClearOutput ()
public:
virtual void ClearOutput () abstract
public abstract void ClearOutput ()
public abstract function ClearOutput ()

Remarks

Clears the tone outputs that have been buffered. This includes asynchronous output.

Any output complete and output error events that are queued, usually waiting for DataEventEnabled to be set to true and FreezeEvents to be set to false, are also cleared.

ClearOutput may cause a PosControlException to be thrown with the following ErrorCodes.

Value | Meaning
Claimed | The device is claimed by another process.
NotClaimed | The device must be claimed before ClearOutput can be used.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
ElectronicJournal.ClearInput Method


ElectronicJournal.EraseMedium Method

ElectronicJournal.EraseMedium Method |
 | See Also

1/18/2008

Erases all data in the medium.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub EraseMedium
public abstract void EraseMedium ()
public:
virtual void EraseMedium () abstract
public abstract void EraseMedium ()
public abstract function EraseMedium ()

Remarks

All the data in this medium is erased. This includes Marker information.

This method is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

When it is performed asynchronously, the results are stored in an OutputCompleteEvent event. If method fails or the OutputCompleteEvent event cannot be delivered, ErrorEvent event will be raised.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
CapErasableMedium
AsyncMode


ElectronicJournal.InitializeMedium Method

ElectronicJournal.InitializeMedium Method |
 | See Also

1/18/2008

Initializes the recording medium.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub InitializeMedium ( _
    mediumId As String _
)
public abstract void InitializeMedium (
    string mediumId
)
public:
virtual void InitializeMedium (
    String^ mediumId
) abstract
public abstract void InitializeMedium (
    String mediumId
)
public abstract function InitializeMedium (
    mediumId : String
)

Parameters

mediumId

The identification of the medium to be initialized.

Remarks

Initializes the recording medium and assigns it the specified name.

If the medium is not namable, the MediumID property is set to null.

This method is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

When it is performed asynchronously, the results are stored in an OutputCompleteEvent event. If method fails or the OutputCompleteEvent event cannot be delivered, an ErrorEvent event is raised.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
AsyncMode
MediumID
CapInitializeMedium


ElectronicJournal.PrintContent Method

ElectronicJournal.PrintContent Method |
 | See Also

1/18/2008

Prints the current journal document stored in the recording medium onto the connected printer system.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintContent ( _
    fromMarker As String, _
    toMarker As String _
)
public abstract void PrintContent (
    string fromMarker,
    string toMarker
)
public:
virtual void PrintContent (
    String^ fromMarker,
    String^ toMarker
) abstract
public abstract void PrintContent (
    String fromMarker,
    String toMarker
)
public abstract function PrintContent (
    fromMarker : String,
    toMarker : String
)

Parameters

fromMarker

Marker identifier that indicates start position of the data.

A setting of null uses the position of the data at the beginning of the recording medium.

toMarker

Marker identifier that indicates end position of the data.

A setting of null uses the position of the data at the end of the recording medium.

Remarks

Prints the current journal document stored in the recording medium onto the connected printer system.

Setting fromMarker to null sets its value to the position of the data at the beginning of the recording medium, while setting toMarker to null sets its value to the position of the data at the end of the recording medium.

This method is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

When they are performed asynchronously, the results are stored in an OutputCompleteEvent event event. If method fails or the OutputCompleteEvent event cannot be delivered, the ErrorEvent event is raised.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
AsyncMode
CapPrintContent
ResumePrintContent
SuspendPrintContent
PrintContentFile


ElectronicJournal.PrintContentFile Method

ElectronicJournal.PrintContentFile Method |
 | See Also

1/18/2008

Prints the journal document from the specified file onto the connected printer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintContentFile ( _
    fileName As String _
)
public abstract void PrintContentFile (
    string fileName
)
public:
virtual void PrintContentFile (
    String^ fileName
) abstract
public abstract void PrintContentFile (
    String fileName
)
public abstract function PrintContentFile (
    fileName : String
)

Parameters

fileName

Name of the file that contains printing data.

Remarks

Prints the journal document from the specified file onto the connected printer.

This method is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

When they are performed asynchronously, the results are stored an OutputCompleteEvent event. If method fails or the OutputCompleteEvent event cannot be delivered, the ErrorEvent event is raised.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
AsyncMode
PrintContent
CapPrintContentFile
SuspendPrintContent
ResumePrintContent


ElectronicJournal.QueryContent Method

ElectronicJournal.QueryContent Method |
 | See Also

1/18/2008

Queries the content and stores it. The format of the data that is stored on the medium depends on the physical device model.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub QueryContent ( _
    fileName As String, _
    fromMarker As String, _
    toMarker As String _
)
public abstract void QueryContent (
    string fileName,
    string fromMarker,
    string toMarker
)
public:
virtual void QueryContent (
    String^ fileName,
    String^ fromMarker,
    String^ toMarker
) abstract
public abstract void QueryContent (
    String fileName,
    String fromMarker,
    String toMarker
)
public abstract function QueryContent (
    fileName : String,
    fromMarker : String,
    toMarker : String
)

Parameters

fileName

Name of the file that contains printing data.

fromMarker

Marker identifier that indicates start position of the data.

Specifying a null string means specifying the data at the beginning of the recording medium.

toMarker

Marker identifier that indicates end position of the data.

Specifying a null string means specifying the data at the end of the recording medium.

Remarks

Data that is stored in the medium can be obtained as a file.

This method is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

The method starts the querying and then returns immediately. As soon as the storing of the queried content data is successfully completed, a DataEvent event is delivered to the application. If the method fails, an ErrorEvent event is delivered.

Setting fromMarker to null defaults its value to the position of the data at the beginning of the recording medium, while setting toMarker to null defaults its value to the position of the data at the end of the recording medium.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
AsyncMode
SuspendQueryContent
ResumeQueryContent


ElectronicJournal.ResumePrintContent Method

ElectronicJournal.ResumePrintContent Method |
 | See Also

1/18/2008

Resumes the suspended data printing process.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ResumePrintContent
public abstract void ResumePrintContent ()
public:
virtual void ResumePrintContent () abstract
public abstract void ResumePrintContent ()
public abstract function ResumePrintContent ()

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
PrintContent
ElectronicJournal.PrintContentFile Method
SuspendPrintContent


ElectronicJournal.ResumeQueryContent Method

ElectronicJournal.ResumeQueryContent Method |
 | See Also

1/18/2008

Resumes the suspended data transfer process.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ResumeQueryContent
public abstract void ResumeQueryContent ()
public:
virtual void ResumeQueryContent () abstract
public abstract void ResumeQueryContent ()
public abstract function ResumeQueryContent ()

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
SuspendQueryContent
QueryContent


ElectronicJournal.RetrieveCurrentMarker Method

ElectronicJournal.RetrieveCurrentMarker Method |
 | See Also

1/18/2008

Returns the last implicitly stored marker.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function RetrieveCurrentMarker ( _
    markerType As MarkerType _
) As String
public abstract string RetrieveCurrentMarker (
    MarkerType markerType
)
public:
virtual String^ RetrieveCurrentMarker (
    MarkerType markerType
) abstract
public abstract String RetrieveCurrentMarker (
    MarkerType markerType
)
public abstract function RetrieveCurrentMarker (
    markerType : MarkerType
) : String

Parameters

markerType

Specifies the type of the queried current marker. See values in Remarks.

Remarks

Returns the last implicitly stored marker. The format and content of the marker is represented by a string and is implementation specific. The returned marker is typically used as an input parameter for the PrintContent and QueryContent methods.

This method is only supported if the CapRetrieveCurrentMarker property value is true.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
CapRetrieveCurrentMarker
QueryContent
PrintContent
RetrieveMarker
RetrieveMarkerByDateTime
ElectronicJournal.AddMarker Method


ElectronicJournal.RetrieveMarker Method

ElectronicJournal.RetrieveMarker Method |
 | See Also

1/18/2008

Returns a marker implicitly stored on the record medium.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function RetrieveMarker ( _
    markerType As MarkerType, _
    sessionNumber As Integer, _
    documentNumber As Integer _
) As String
public abstract string RetrieveMarker (
    MarkerType markerType,
    int sessionNumber,
    int documentNumber
)
public:
virtual String^ RetrieveMarker (
    MarkerType markerType,
    int sessionNumber,
    int documentNumber
) abstract
public abstract String RetrieveMarker (
    MarkerType markerType,
    int sessionNumber,
    int documentNumber
)
public abstract function RetrieveMarker (
    markerType : MarkerType,
    sessionNumber : int,
    documentNumber : int
) : String

Parameters

markerType

Specifies the type of the queried current marker. See values in Remarks.

sessionNumber

Contains the session number of the queried marker. If a session concept is not supported by the device, this parameter must be set to a value that is less than zero.

documentNumber

Contains the number of the queried markers document. If the value of markerType is SessionBegin or SessionEnd, this parameter is ignored.

Remarks

Returns a marker implicitly stored on the record medium. The queried marker is specified by the parameters MarkerType, SessionNumber, andDocumentNumber. The format and content of the marker that is represented by a string, is implementation specific. The returned marker is intended to be used as an input parameter for the PrintContent and QueryContent methods.

If there is a fiscal Electronic Journal device, the SessionNumber corresponds to a fiscal day counter number returned by the FiscalPrinter device (see the GetData parameter value Report). In the same manner the DocumentNumber corresponds to a fiscal ticket number.

This method is only supported if CapRetrieveMarker is true.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
CapRetrieveMarker
PrintContent
QueryContent
FiscalPrinter
RetrieveCurrentMarker
RetrieveMarkerByDateTime
ElectronicJournal.AddMarker Method


ElectronicJournal.RetrieveMarkerByDateTime Method

ElectronicJournal.RetrieveMarkerByDateTime Method |
 | See Also

1/18/2008

Returns a marker implicitly stored on the record medium.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function RetrieveMarkerByDateTime ( _
    markerType As MarkerType, _
    dateTime As String, _
    markerNumber As String _
) As String
public abstract string RetrieveMarkerByDateTime (
    MarkerType markerType,
    string dateTime,
    string markerNumber
)
public:
virtual String^ RetrieveMarkerByDateTime (
    MarkerType markerType,
    String^ dateTime,
    String^ markerNumber
) abstract
public abstract String RetrieveMarkerByDateTime (
    MarkerType markerType,
    String dateTime,
    String markerNumber
)
public abstract function RetrieveMarkerByDateTime (
    markerType : MarkerType,
    dateTime : String,
    markerNumber : String
) : String

Parameters

markerType

Specifies the type of the queried current marker.

dateTime

The date/time period the marker is queried for. The format of dateTime is 'YYYYMMDDhhmmss'. If the application cannot specify the hours, minutes, and seconds, then these fields can be omitted.

markerNumber

If more than one marker of the requested type exists during the time period specified by the dateTime parameter, this parameter specifies the number of the marker which will be queried. Numbering for markers begins at 1 and is continuously incremented by one for each marker.

Remarks

Returns a marker implicitly stored on the record medium. The queried marker is specified by the parameters markerType, dateTime, and markerNumber. The format and content of the marker that is returned as a string, is implementation specific. The returned marker can be used as an input parameter for the PrintContent and QueryContent methods.

This method is only supported if CapRetrieveMarkerByDateTime is true.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
CapRetrieveMarkersDateTime
PrintContent
QueryContent
RetrieveMarker
RetrieveCurrentMarker
ElectronicJournal.AddMarker Method


ElectronicJournal.RetrieveMarkersDateTime Method

ElectronicJournal.RetrieveMarkersDateTime Method |
 | See Also

1/18/2008

Returns the date/time of the given marker.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function RetrieveMarkersDateTime ( _
    marker As String _
) As String
public abstract string RetrieveMarkersDateTime (
    string marker
)
public:
virtual String^ RetrieveMarkersDateTime (
    String^ marker
) abstract
public abstract String RetrieveMarkersDateTime (
    String marker
)
public abstract function RetrieveMarkersDateTime (
    marker : String
) : String

Parameters

marker

Specifies the marker from which the date/time will be retrieved.

Remarks

Returns the date/time of the given marker. The marker must be instantiated by the application that uses the AddMarker method or queried by the RetrieveMarker or RetrieveCurrentMarker methods. The determined date/time is returned as a string in the YYYYMMDDhhmmss format. If the hours, minutes, or seconds cannot be determined, the unknown digits are represented by question marks.

This method is only supported if the CapRetrieveMarkerByDateTime property value is true.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
CapRetrieveMarkerByDateTime
ElectronicJournal.AddMarker Method
RetrieveCurrentMarker
RetrieveMarker


ElectronicJournal.SuspendPrintContent Method

ElectronicJournal.SuspendPrintContent Method |
 | See Also

1/18/2008

Suspends all data transfer from the device and then suspends the device state.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub SuspendPrintContent
public abstract void SuspendPrintContent ()
public:
virtual void SuspendPrintContent () abstract
public abstract void SuspendPrintContent ()
public abstract function SuspendPrintContent ()

Remarks

This method is primarily intended for use in exception conditions when asynchronous output is outstanding, such as in an error event handler. This method cannot be called unless asynchronous output is outstanding.

After this method is called, the Suspended property is set to true, and a StatusUpdateEvent event is delivered.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
Suspended
PrintContent
ElectronicJournal.PrintContentFile Method
ElectronicJournal.ResumePrintContent Method
ElectronicJournal.CancelPrintContent Method


ElectronicJournal.SuspendQueryContent Method

ElectronicJournal.SuspendQueryContent Method |
 | See Also

1/18/2008

Suspends all data transfer from the device, and then suspends the device state.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub SuspendQueryContent
public abstract void SuspendQueryContent ()
public:
virtual void SuspendQueryContent () abstract
public abstract void SuspendQueryContent ()
public abstract function SuspendQueryContent ()

Remarks

This method is primarily intended for use in exception conditions when asynchronous output is outstanding, such as in an Error event handler.

After this method is called, the Suspended property is set to true, and a StatusUpdateEvent event is delivered.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
Suspended
QueryContent
ElectronicJournal.ResumeQueryContent Method
ElectronicJournal.CancelQueryContent Method


ElectronicJournal Properties

ElectronicJournal Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
AsyncMode | Gets or sets the Boolean value that indicates whether the print methods are performed asynchronously.
AutoDisable | Gets or sets the Boolean value that indicates whether POS for .NET automatically disables the device when data is received.
CapAddMarker | Gets the Boolean value that indicates whether the application can use the AddMarker method.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapErasableMedium | Gets the Boolean value that indicates whether the storage medium can be erased.
CapInitializeMedium | Gets the Boolean value that indicates whether the application can initialize the medium.
CapMediumIsAvailable | Gets the Boolean value that indicates whether the application can search for a connected recording medium.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapPrintContent | Gets the Boolean value that indicates whether the device can reprint stored journal documents on a connected printer.
CapPrintContentFile | Gets the Boolean value that indicates whether journal documents that are extracted from the storage medium can be printed on a connected printing device.
CapRetrieveCurrentMarker | Gets the Boolean value that indicates whether the application can use the RetrieveCurrentMarker method.
CapRetrieveMarker | Gets the Boolean value that indicates whether the application can use the RetrieveMarker method.
CapRetrieveMarkerByDateTime | Gets the Boolean value that indicates whether the application can use the RetrieveMarkerByDateTime method.
CapRetrieveMarkersDateTime | Gets the Boolean value that indicates whether the application can use the RetrieveMarkersDateTime method.
CapStation | Gets the availability of data capturing for the device and the storage medium.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapStorageEnabled | Gets the Boolean value that indicates whether the recording of print data can be managed by the StorageEnabled property.
CapSuspendPrintContent | Gets the Boolean value that indicates whether the printing process can be suspended.
CapSuspendQueryContent | Gets the Boolean value that indicates whether the data querying process can be suspended.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CapWatermark | Gets the Boolean value that indicates whether the device can print predefined background when reprinting journal documents.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
DataCount | Gets the Boolean value that indicates the number of currently queued DataEvent events.
DataEventEnabled | Gets or sets the Boolean value that indicates whether a DataEvent event is delivered whenever input data is queued.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
FlagWhenIdle | Gets or sets the Boolean value that indicates whether the device delivers a StatusUpdateEvent when it becomes idle.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
MediumFreeSpace | Gets the remaining free space of the storage medium, in bytes,.
MediumId | Gets identification for the currently plugged medium.
MediumIsAvailable | Gets the Boolean value that indicates whether a recording medium is attached or not.
MediumSize | Gets the size of the storage medium in bytes.
OutputId | Gets the identifier of the most recently started asynchronous output.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
Station | Gets or sets the station for later data storing into the medium.
StorageEnabled | Gets or sets the Boolean value that indicates whether the device is in a recordable state.
Suspended | Gets the Boolean value that indicates whether the printing or data obtaining process is suspended.
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )
Watermark | Gets or sets the Boolean value that indicates whether a predefined background should be printed with journal documents.

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets the Boolean value that indicates whether the device is an exclusive-use device.

See Also

Reference

ElectronicJournal Class
Microsoft.PointOfService Namespace


ElectronicJournal.AsyncMode Property

ElectronicJournal.AsyncMode Property |
 | See Also

1/18/2008

Gets or sets the Boolean value that indicates whether the print methods are performed asynchronously.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AsyncMode As Boolean
public abstract bool AsyncMode { get; set; }
public:
virtual property bool AsyncMode {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_AsyncMode ()

/** @property */
public abstract void set_AsyncMode (boolean value)

public abstract function get AsyncMode () : boolean

public abstract function set AsyncMode (value : boolean)

Remarks

If true, then the print methods is performed asynchronously. If false, they are performed synchronously.

This property is initialized to false by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace


ElectronicJournal.AutoDisable Property

ElectronicJournal.AutoDisable Property |
 | See Also

1/18/2008

Gets or sets the Boolean value that indicates whether POS for .NET automatically disables the device when data is received.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AutoDisable As Boolean
public abstract bool AutoDisable { get; set; }
public:
virtual property bool AutoDisable {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_AutoDisable ()

/** @property */
public abstract void set_AutoDisable (boolean value)

public abstract function get AutoDisable () : boolean

public abstract function set AutoDisable (value : boolean)

Remarks

AutoDisable provides the application that has an additional option for controlling the receipt of input data. If the application wants to receive and process only one input, or only one input at a time, then this property can be set to true.

When true, the service object sets the DeviceEnabled property to false as soon as it receives and queues data to be raised as a DataEvent event. Before the service object raises any later events, the application must set DeviceEnabled back to true.

When false, the service object does not automatically disable the device when data is received; instead, it relies on the application to set the value of the DeviceEnabled property.

AutoDisable is typically initialized to false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
DeviceEnabled
DataEvent


ElectronicJournal.CapAddMarker Property

ElectronicJournal.CapAddMarker Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the application can use the AddMarker method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapAddMarker As Boolean
public abstract bool CapAddMarker { get; }
public:
virtual property bool CapAddMarker {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapAddMarker ()

public abstract function get CapAddMarker () : boolean

Remarks

If true, the application can use the AddMarker method. This property is usually false for fiscal Electronic Journal devices.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
ElectronicJournal.AddMarker Method


ElectronicJournal.CapErasableMedium Property

ElectronicJournal.CapErasableMedium Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the storage medium can be erased.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapErasableMedium As Boolean
public abstract bool CapErasableMedium { get; }
public:
virtual property bool CapErasableMedium {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapErasableMedium ()

public abstract function get CapErasableMedium () : boolean

Remarks

If true, the storage medium can be erased. If false, it cannot be erased.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
MediumID
MediumIsAvailable
CapMediumIsAvailable


ElectronicJournal.CapInitializeMedium Property

ElectronicJournal.CapInitializeMedium Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the application can initialize the medium.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapInitializeMedium As Boolean
public abstract bool CapInitializeMedium { get; }
public:
virtual property bool CapInitializeMedium {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapInitializeMedium ()

public abstract function get CapInitializeMedium () : boolean

Remarks

If true, the application can initialize the medium.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
MediumIsAvailable
ElectronicJournal.CapErasableMedium Property


ElectronicJournal.CapMediumIsAvailable Property

ElectronicJournal.CapMediumIsAvailable Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the application can search for a connected recording medium.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapMediumIsAvailable As Boolean
public abstract bool CapMediumIsAvailable { get; }
public:
virtual property bool CapMediumIsAvailable {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapMediumIsAvailable ()

public abstract function get CapMediumIsAvailable () : boolean

Remarks

If true, the application can check whether a recording medium is plugged or not.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
ElectronicJournal.CapInitializeMedium Property
ElectronicJournal.InitializeMedium Method
MediumIsAvailable


ElectronicJournal.CapPrintContent Property

ElectronicJournal.CapPrintContent Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the device can reprint stored journal documents on a connected printer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapPrintContent As Boolean
public abstract bool CapPrintContent { get; }
public:
virtual property bool CapPrintContent {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapPrintContent ()

public abstract function get CapPrintContent () : boolean

Remarks

If true, the device can reprint stored journal documents directly on a connected printing device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
CapPrintContentFile
PrintContent
ElectronicJournal.PrintContentFile Method


ElectronicJournal.CapPrintContentFile Property

ElectronicJournal.CapPrintContentFile Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether journal documents that are extracted from the storage medium can be printed on a connected printing device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapPrintContentFile As Boolean
public abstract bool CapPrintContentFile { get; }
public:
virtual property bool CapPrintContentFile {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapPrintContentFile ()

public abstract function get CapPrintContentFile () : boolean

Remarks

If true, the device can print journal documents that are extracted from the storage medium on a connected printing device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
ElectronicJournal.CapPrintContent Property
PrintContent
ElectronicJournal.PrintContentFile Method


ElectronicJournal.CapRetrieveCurrentMarker Property

ElectronicJournal.CapRetrieveCurrentMarker Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the application can use the RetrieveCurrentMarker method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRetrieveCurrentMarker As Boolean
public abstract bool CapRetrieveCurrentMarker { get; }
public:
virtual property bool CapRetrieveCurrentMarker {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRetrieveCurrentMarker ()

public abstract function get CapRetrieveCurrentMarker () : boolean

Remarks

If true, the application can use the RetrieveCurrentMarker method. This property is typically true for FiscalPrinter devices.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
RetrieveCurrentMarker
CapRetrieveMarker
CapRetrieveMarkerByDateTime
RetrieveCurrentMarker
RetrieveMarker
RetrieveMarkerByDateTime


ElectronicJournal.CapRetrieveMarker Property

ElectronicJournal.CapRetrieveMarker Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the application can use the RetrieveMarker method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRetrieveMarker As Boolean
public abstract bool CapRetrieveMarker { get; }
public:
virtual property bool CapRetrieveMarker {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRetrieveMarker ()

public abstract function get CapRetrieveMarker () : boolean

Remarks

If true, the application can use the RetrieveMarker method. This property is typically true for FiscalPrinter devices.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
RetrieveMarker
ElectronicJournal.CapRetrieveCurrentMarker Property
CapRetrieveMarkerByDateTime
RetrieveMarker
RetrieveMarkerByDateTime
RetrieveCurrentMarker


ElectronicJournal.CapRetrieveMarkerByDateTime Property

ElectronicJournal.CapRetrieveMarkerByDateTime Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the application can use the RetrieveMarkerByDateTime method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRetrieveMarkerByDateTime As Boolean
public abstract bool CapRetrieveMarkerByDateTime { get; }
public:
virtual property bool CapRetrieveMarkerByDateTime {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRetrieveMarkerByDateTime ()

public abstract function get CapRetrieveMarkerByDateTime () : boolean

Remarks

If true, the application can use the RetrieveMarkerByDateTime method. This property is typically true for FiscalPrinter devices.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
ElectronicJournal.RetrieveMarkersDateTime Method
ElectronicJournal.CapRetrieveMarker Property
ElectronicJournal.CapRetrieveCurrentMarker Property
CapRetrieveMarkersDateTime
RetrieveMarker
RetrieveCurrentMarker
RetrieveMarkerByDateTime


ElectronicJournal.CapRetrieveMarkersDateTime Property

ElectronicJournal.CapRetrieveMarkersDateTime Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the application can use the RetrieveMarkersDateTime method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRetrieveMarkersDateTime As Boolean
public abstract bool CapRetrieveMarkersDateTime { get; }
public:
virtual property bool CapRetrieveMarkersDateTime {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRetrieveMarkersDateTime ()

public abstract function get CapRetrieveMarkersDateTime () : boolean

Remarks

If true, the application can use the RetrieveMarkersDateTime method. This property is typically true for FiscalPrinter devices.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
ElectronicJournal.RetrieveMarkersDateTime Method


ElectronicJournal.CapStation Property

ElectronicJournal.CapStation Property |
 | See Also

1/18/2008

Gets the availability of data capturing for the device and the storage medium.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapStation As ElectronicJournalStations
public abstract ElectronicJournalStations CapStation { get; }
public:
virtual property ElectronicJournalStations CapStation {
    ElectronicJournalStations get () abstract;
}
/** @property */
public abstract ElectronicJournalStations get_CapStation ()

public abstract function get CapStation () : ElectronicJournalStations

Remarks

CapStation property is a logical OR combination of any of the following values, contained in the ElectronicJournalStations enumeration:

Value | Meaning
Receipt | Captures data output into receipt station and stores it into the medium.
Slip | Captures data output into slip station and stores it into the medium.
Journal | Captures data output into journal station and stores it into the medium.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
ElectronicJournalStations
Station


ElectronicJournal.CapStorageEnabled Property

ElectronicJournal.CapStorageEnabled Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the recording of print data can be managed by the StorageEnabled property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapStorageEnabled As Boolean
public abstract bool CapStorageEnabled { get; }
public:
virtual property bool CapStorageEnabled {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapStorageEnabled ()

public abstract function get CapStorageEnabled () : boolean

Remarks

This property indicates whether the recording print data can be changed by the StorageEnabled property. If false, StorageEnabled is always set to true.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
StorageEnabled


ElectronicJournal.CapSuspendPrintContent Property

ElectronicJournal.CapSuspendPrintContent Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the printing process can be suspended.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSuspendPrintContent As Boolean
public abstract bool CapSuspendPrintContent { get; }
public:
virtual property bool CapSuspendPrintContent {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSuspendPrintContent ()

public abstract function get CapSuspendPrintContent () : boolean

Remarks

If true, the printing process can be suspended.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
Suspended
ElectronicJournal.SuspendPrintContent Method
PrintContent
ElectronicJournal.PrintContentFile Method


ElectronicJournal.CapSuspendQueryContent Property

ElectronicJournal.CapSuspendQueryContent Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the data querying process can be suspended.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSuspendQueryContent As Boolean
public abstract bool CapSuspendQueryContent { get; }
public:
virtual property bool CapSuspendQueryContent {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSuspendQueryContent ()

public abstract function get CapSuspendQueryContent () : boolean

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
Suspended
ElectronicJournal.SuspendQueryContent Method
ElectronicJournal.ResumeQueryContent Method
QueryContent


ElectronicJournal.CapWatermark Property

ElectronicJournal.CapWatermark Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the device can print predefined background when reprinting journal documents.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapWatermark As Boolean
public abstract bool CapWatermark { get; }
public:
virtual property bool CapWatermark {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapWatermark ()

public abstract function get CapWatermark () : boolean

Remarks

If true, the device can print specific predefined background when reprinting journal documents.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
WaterMark


ElectronicJournal.DataCount Property

ElectronicJournal.DataCount Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates the number of currently queued DataEvent events.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DataCount As Integer
public abstract int DataCount { get; }
public:
virtual property int DataCount {
    int get () abstract;
}
/** @property */
public abstract int get_DataCount ()

public abstract function get DataCount () : int

Remarks

Indicates the total number of currently queued DataEvent events at the service object. All online units are included in this value.

The application can interrogate DataCount to determine whether additional input is queued from a device but has not yet been delivered because of other application processing, freezing of events, or other causes.

DataCount is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
ElectronicJournal.DataCount Property
DataEvent


ElectronicJournal.DataEventEnabled Property

ElectronicJournal.DataEventEnabled Property |
 | See Also

1/18/2008

Gets or sets the Boolean value that indicates whether a DataEvent event is delivered whenever input data is queued.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property DataEventEnabled As Boolean
public abstract bool DataEventEnabled { get; set; }
public:
virtual property bool DataEventEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_DataEventEnabled ()

/** @property */
public abstract void set_DataEventEnabled (boolean value)

public abstract function get DataEventEnabled () : boolean

public abstract function set DataEventEnabled (value : boolean)

Remarks

When true, a DataEvent is delivered as soon as any input data is queued. If this property is set to true when input data is already in the queue, a DataEvent event is delivered immediately.

Certain conditions may delay immediate delivery, in this case. If the FreezeEvents property is true, or if another event is already being processed by the application, the DataEvent remains queued until the blocking condition is resolved.

If false, input data is queued for delivery to the application. If an input error occurs, the ErrorEvent cannot be not delivered while the DataEventEnabled property is false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
DataEvent
ElectronicJournal.DataEventEnabled Property
ErrorEvent


ElectronicJournal.FlagWhenIdle Property

ElectronicJournal.FlagWhenIdle Property |
 | See Also

1/18/2008

Gets or sets the Boolean value that indicates whether the device delivers a StatusUpdateEvent when it becomes idle.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property FlagWhenIdle As Boolean
public abstract bool FlagWhenIdle { get; set; }
public:
virtual property bool FlagWhenIdle {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_FlagWhenIdle ()

/** @property */
public abstract void set_FlagWhenIdle (boolean value)

public abstract function get FlagWhenIdle () : boolean

public abstract function set FlagWhenIdle (value : boolean)

Remarks

If true, a StatusUpdateEvent is queued whenever the device state is idle. This property is automatically reset to false as soon as the queued StatusUpdateEvent is delivered.

The main use of FlagWhenIdle property is to give the application control when all outstanding asynchronous outputs have been processed. The event is queued if the outputs were completed successfully or if they were cleared by the ClearOutput method or the ErrorEvent handler.

If the State property is already set to idle when this property is set to true, a StatusUpdateEvent is queued immediately. The application can depend on this event, without a race condition between the starting of its last asynchronous output and the setting of this flag.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
ElectronicJournal.ClearOutput Method
ErrorEvent
ElectronicJournal.FlagWhenIdle Property


ElectronicJournal.IsExclusiveUseDevice Property

ElectronicJournal.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the device is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace


ElectronicJournal.MediumFreeSpace Property

ElectronicJournal.MediumFreeSpace Property |
 | See Also

1/18/2008

Gets the remaining free space of the storage medium, in bytes,.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property MediumFreeSpace As Decimal
public abstract decimal MediumFreeSpace { get; }
public:
virtual property Decimal MediumFreeSpace {
    Decimal get () abstract;
}
/** @property */
public abstract Decimal get_MediumFreeSpace ()

public abstract function get MediumFreeSpace () : decimal

Remarks

Holds the size of the remaining free space on the storage medium, in bytes. After each storing process caused by printing with PosPrinter or FiscalPrinter device, this value is decreased. It notifies the StatusUpdateEvent event when free space is almost empty or empty.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
MediumSize


ElectronicJournal.MediumId Property

ElectronicJournal.MediumId Property |
 | See Also

1/18/2008

Gets identification for the currently plugged medium.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property MediumId As String
public abstract string MediumId { get; }
public:
virtual property String^ MediumId {
    String^ get () abstract;
}
/** @property */
public abstract String get_MediumId ()

public abstract function get MediumId () : String

Remarks

This property indicates identification of the currently plugged medium. It holds a value from the physical medium, so it is initialized when it is enabled.

If it is not possible to obtain any information from the physical medium, then this property is initialized to empty string.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
ElectronicJournal.InitializeMedium Method


ElectronicJournal.MediumIsAvailable Property

ElectronicJournal.MediumIsAvailable Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether a recording medium is attached or not.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property MediumIsAvailable As Boolean
public abstract bool MediumIsAvailable { get; }
public:
virtual property bool MediumIsAvailable {
    bool get () abstract;
}
/** @property */
public abstract boolean get_MediumIsAvailable ()

public abstract function get MediumIsAvailable () : boolean

Remarks

Indicates whether a recording medium is attached or not.

If true, a recording medium is attached. If false, it is not attached.

If the storage medium is not exchangeable, this property is always set true.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
ElectronicJournal.InitializeMedium Method
ElectronicJournal.CapMediumIsAvailable Property


ElectronicJournal.MediumSize Property

ElectronicJournal.MediumSize Property |
 | See Also

1/18/2008

Gets the size of the storage medium in bytes.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property MediumSize As Decimal
public abstract decimal MediumSize { get; }
public:
virtual property Decimal MediumSize {
    Decimal get () abstract;
}
/** @property */
public abstract Decimal get_MediumSize ()

public abstract function get MediumSize () : decimal

Remarks

Holds the size of the storage medium in bytes.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
ElectronicJournal.MediumFreeSpace Property


ElectronicJournal.OutputId Property

ElectronicJournal.OutputId Property |
 | See Also

1/18/2008

Gets the identifier of the most recently started asynchronous output.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property OutputId As Integer
public abstract int OutputId { get; }
public:
virtual property int OutputId {
    int get () abstract;
}
/** @property */
public abstract int get_OutputId ()

public abstract function get OutputId () : int

Remarks

When a method successfully initiates an asynchronous output, the device assigns an identifier to the request. When the output is complete, an OutputCompleteEvent event is queued with this output ID as a parameter.

The output ID numbers are assigned by POS for .NET and are guaranteed to be unique among the set of outstanding asynchronous outputs. No other facts about the ID should be assumed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace


ElectronicJournal.Station Property

ElectronicJournal.Station Property |
 | See Also

1/18/2008

Gets or sets the station for later data storing into the medium.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property Station As ElectronicJournalStations
public abstract ElectronicJournalStations Station { get; set; }
public:
virtual property ElectronicJournalStations Station {
    ElectronicJournalStations get () abstract;
    void set (ElectronicJournalStations value) abstract;
}
/** @property */
public abstract ElectronicJournalStations get_Station ()

/** @property */
public abstract void set_Station (ElectronicJournalStations value)

public abstract function get Station () : ElectronicJournalStations

public abstract function set Station (value : ElectronicJournalStations)

Remarks

Set the station for later data storing into the medium. Station is a logical OR combination of any of the following values.

Value | Meaning
Receipt | Captures data output into receipt station of PosPrinter and stores it into the medium.
Slip | Captures data output into slip station of PosPrinter and stores it into the medium.
Journal | Captures data output into journal station of PosPrinter and stores it into the medium.

This property is initialized to Receiptby the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
ElectronicJournal.CapStation Property


ElectronicJournal.StorageEnabled Property

ElectronicJournal.StorageEnabled Property |
 | See Also

1/18/2008

Gets or sets the Boolean value that indicates whether the device is in a recordable state.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property StorageEnabled As Boolean
public abstract bool StorageEnabled { get; set; }
public:
virtual property bool StorageEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_StorageEnabled ()

/** @property */
public abstract void set_StorageEnabled (boolean value)

public abstract function get StorageEnabled () : boolean

public abstract function set StorageEnabled (value : boolean)

Remarks

If true, the device is in a recordable state. Output data from PosPrinter or FiscalPrinter is stored on the medium as electronic information sequentially. The Station property must be specified in advance to specify what station is available to record.

If false, the device has been disabled to record data.

This property is initialized to false by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
ElectronicJournal.CapStorageEnabled Property
ElectronicJournal.Station Property


ElectronicJournal.Suspended Property

ElectronicJournal.Suspended Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the printing or data obtaining process is suspended.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property Suspended As Boolean
public abstract bool Suspended { get; }
public:
virtual property bool Suspended {
    bool get () abstract;
}
/** @property */
public abstract boolean get_Suspended ()

public abstract function get Suspended () : boolean

Remarks

If true, the printing or data obtaining process is being suspended. When both CapSuspendPrintContent and CapSuspendQueryContent are false, the application cannot suspend the process, and this property must be set to false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
ElectronicJournal.CapSuspendPrintContent Property
ElectronicJournal.CapSuspendQueryContent Property
ElectronicJournal.SuspendQueryContent Method
ElectronicJournal.SuspendPrintContent Method


ElectronicJournal.Watermark Property

ElectronicJournal.Watermark Property |
 | See Also

1/18/2008

Gets or sets the Boolean value that indicates whether a predefined background should be printed with journal documents.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property Watermark As Boolean
public abstract bool Watermark { get; set; }
public:
virtual property bool Watermark {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_Watermark ()

/** @property */
public abstract void set_Watermark (boolean value)

public abstract function get Watermark () : boolean

public abstract function set Watermark (value : boolean)

Remarks

This property specifies whether or not a specific predefined background will be printed with journal documents. If true, the background is printed and indicates that the output is a reprint of the stored data.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
ElectronicJournal.CapWatermark Property


ElectronicJournal Events

ElectronicJournal Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DataEvent | Notifies the application that the queried Electronic Journal has finished storing its content in a host file.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
ErrorEvent | Notifies the application that an Electronic Journal error has been detected and that a suitable response by the application is necessary to process the error condition.
OutputCompleteEvent | Notifies the application that the queued output request has completed successfully.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

ElectronicJournal Class
Microsoft.PointOfService Namespace


ElectronicJournal.DataEvent Event

ElectronicJournal.DataEvent Event |
 | See Also

1/18/2008

Notifies the application that the queried Electronic Journal has finished storing its content in a host file.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event DataEvent As DataEventHandler
public abstract event DataEventHandler DataEvent
public:
virtual event DataEventHandler^ DataEvent {
    void add (DataEventHandler^ value) abstract;
    void remove (DataEventHandler^ value) abstract;
}
/** @event */
public abstract void add_DataEvent (DataEventHandler value)

/** @event */
public abstract void remove_DataEvent (DataEventHandler value)

Remarks

This event is delivered after an asynchronous QueryContent method call, when DataEventEnabled is set true.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace
ElectronicJournal.DataEventEnabled Property
QueryContent


ElectronicJournal.ErrorEvent Event

ElectronicJournal.ErrorEvent Event |
 | See Also

1/18/2008

Notifies the application that an Electronic Journal error has been detected and that a suitable response by the application is necessary to process the error condition.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event ErrorEvent As DeviceErrorEventHandler
public abstract event DeviceErrorEventHandler ErrorEvent
public:
virtual event DeviceErrorEventHandler^ ErrorEvent {
    void add (DeviceErrorEventHandler^ value) abstract;
    void remove (DeviceErrorEventHandler^ value) abstract;
}
/** @event */
public abstract void add_ErrorEvent (DeviceErrorEventHandler value)

/** @event */
public abstract void remove_ErrorEvent (DeviceErrorEventHandler value)

Remarks

Raised by the service object, notifies the application that an Electronic Journal device error has been detected and that a suitable response by the application is necessary to process the error condition.

ErrorEvent event notifications are delivered if the following conditions are true:

  • When the PosPrinter or FiscalPrinter device asynchronously performs printing jobs which include writing to the Electronic Journal media and this writing fails.

  • When the QueryContent method fails in asynchronous mode.

  • When one of the methods InitializeMedium, EraseMedium, PrintContent, or PrintContentFile - is performed in asynchronous mode and fails.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace


ElectronicJournal.OutputCompleteEvent Event

ElectronicJournal.OutputCompleteEvent Event |
 | See Also

1/18/2008

Notifies the application that the queued output request has completed successfully.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event OutputCompleteEvent As OutputCompleteEventHandler
public abstract event OutputCompleteEventHandler OutputCompleteEvent
public:
virtual event OutputCompleteEventHandler^ OutputCompleteEvent {
    void add (OutputCompleteEventHandler^ value) abstract;
    void remove (OutputCompleteEventHandler^ value) abstract;
}
/** @event */
public abstract void add_OutputCompleteEvent (OutputCompleteEventHandler value)

/** @event */
public abstract void remove_OutputCompleteEvent (OutputCompleteEventHandler value)

Remarks

Raised by the service object, notifies the application that the queued output request associated with the OutputCompleteEventArgs.OutputId property has completed successfully.

OutputCompleteEvent is queued after the request’s data has been both sent and POS for .NET has confirmation that it was successfully processed by the device.

See Also

Reference

ElectronicJournal Class
ElectronicJournal Members
Microsoft.PointOfService Namespace


ElectronicJournalStations Enumeration

ElectronicJournalStations Enumeration |
 | See Also

1/18/2008

Enumerates the station for subsequent data storing into the medium.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration ElectronicJournalStations
[FlagsAttribute]
public enum ElectronicJournalStations
[FlagsAttribute]
public enum class ElectronicJournalStations
/** @attribute FlagsAttribute() */
public enum ElectronicJournalStations
FlagsAttribute
public enum ElectronicJournalStations

Members

Member name | Description
Journal | Captures data output into journal station of PosPrinter and stores it into the medium.
Receipt | Captures data output into receipt station of PosPrinter and stores it into the medium.
Slip | Captures data output into slip station of PosPrinter and stores it into the medium.

Remarks

Set the station for subsequent data storing into the medium. Station is a logical OR combination of any of the following values.

See Also

Reference

Microsoft.PointOfService Namespace


ElectronicValueRW Class

ElectronicValueRW Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for an Electronic Value Reader/Writer (R/W) device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class ElectronicValueRW
    Inherits PosCommon
public abstract class ElectronicValueRW : PosCommon
public ref class ElectronicValueRW abstract : public PosCommon
public abstract class ElectronicValueRW extends PosCommon
public abstract class ElectronicValueRW extends PosCommon

Remarks

Electronic Value is defined as a collection of services such as electronic money, points, and voucher/ticket, maintained on a contact-less or contact IC card (this is referred to as "card" in the following sections). The Electronic Value R/W device is a device that can hold the settlement addition, subtraction, setting, and reading electronically.

The electronic money service supports the postpaid type electronic money settlement, prepaid type electronic money settlement, the credit card settlement, and the debit card settlement.

The point service maintains (can add or subtract) points directly on the card. Alternatively, the points may be stored in another location and only a reference is maintained on the card.

The voucher/ticket service maintains two or more identifiers that validate the card holder. The card holder can receive and exchange the value at any time. The service provider can provide value to the card holder at its discretion.

Required Version

The ElectronicValueRW class requires POS for .NET version 1.12 or later versions.

Capabilities

The Electronic Value R/W has the following set of capabilities:

  • Access the card for the settlement.

  • Read/write the content of Electronic Value that can be used for the settlement from the card.

  • Execute the settlement service that uses Electronic Value.

  • Accumulate the result of the settlement in the device as a log.

General Model

Device Sharing

The Electronic Value Reader / Writer is an exclusive-use device, as follows:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before the application calls methods that manipulate the device.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.ElectronicValueRW
Microsoft.PointOfService.BasicServiceObjects.ElectronicValueRWBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW Members

ElectronicValueRW Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for an Electronic Value Reader/Writer (R/W) device.

The following tables list the members exposed by the ElectronicValueRW type.

Protected Constructors

Name | Description
ElectronicValueRW | Creates an instance of the ElectronicValueRW class.
Top

Public Fields

Name | Description
ExtendedErrorCenterError | Indicates that an error was returned from the approval agency.
ExtendedErrorCommandError | Indicates that the command sent to the device is wrong.
ExtendedErrorCommunicationError | Indicates that a communication error has occurred between the approval agency and the device.
ExtendedErrorDailyLogOverflow | Indicates that the transaction log on the device is full.
ExtendedErrorDeficient | Indicates that the amount cannot be subtracted because the balance is insufficient.
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorLogOverflow | Indicates that the transaction log was too large to be stored.
ExtendedErrorOverdeposit | Indicates that the device cannot add the charge because the maximum charge amount has been exceeded.
ExtendedErrorReset | Indicates that the device was stopped during processing by the device Reset key (Stop key).
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusCardCaptured | Indicates that the stock space sensor detects a card in the stock space.
StatusCardDetected | Indicates that the card detection sensor detects a card in the device.
StatusCardEntered | Indicates that the insertion slot sensor detects that a card is remaining in the slot.
StatusLogFull | Indicates that the transaction log is full.
StatusLogNearFull | Indicates that the transaction log is almost full.
StatusLogOk | Indicates that the transaction log has enough capacity.
StatusNoCard | Indicates that the card detection sensor does not detect a card.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
AccountNumber | Gets information for the service provider such as the card number to specify the user (owner) information from the card.
AdditionalSecurityInformation | Gets or sets additional security information that is stored before issuing an authorization method to an ElectronicValueRW device.
Amount | Gets or sets the payment amount on the electronic money service.
ApprovalCode | Gets or sets the payment approval code.
AsyncMode | Gets or sets the Boolean value that indicates whether associated methods are performed asynchronously or synchronously.
Balance | Gets the balance of the electronic money service.
BalanceOfPoint | Gets the point balance on the point service.
CapActivateService | Gets the Boolean value that indicates whether activation processing is supported.
CapAddValue | Gets the Boolean value that indicates whether the addition of Electronic Value is supported.
CapCancelValue | Gets the Boolean value that indicates whether the cancellation of the operation to the Electronic Value is supported.
CapCardSensor | Gets a bitmask that indicates the types of card detection that are supported.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapDetectionControl | Gets information that indicates detection, ejection, or storing processes can be controlled from the application or the reader/writer.
CapElectronicMoney | Gets the Boolean value that indicates whether the electronic money service is supported.
CapEnumerateCardServices | Gets the Boolean value that indicates whether the enumeration of service in the card is supported.
CapIndirectTransactionLog | Gets the Boolean value that indicates whether the transaction log is accessed as a file.
CapLockTerminal | Gets the Boolean value that indicates whether the security lock setting is supported.
CapLogStatus | Gets the Boolean value that indicates whether the reporting of the status of the transaction log is supported.
CapMediumId | Gets the Boolean value that indicates whether the specification of the medium identifier is supported.
CapPoint | Gets the Boolean value that indicates whether the point service is supported.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapSubtractValue | Gets the Boolean value that indicates whether the subtraction of Electronic Value is supported.
CapTransaction | Gets the Boolean value that indicates whether the transaction mode is supported.
CapTransactionLog | Gets the Boolean value that indicates whether the transaction log is supported.
CapUnlockTerminal | Gets the Boolean value that indicates whether releasing of the security lock is supported.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateKey | Gets the Boolean value that indicates whether the update of key information is supported.
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CapVoucher | Gets the Boolean value that indicates whether the voucher/ticket service is supported.
CapWriteValue | Gets the Boolean value that indicates whether the writing of Electronic Value is supported.
CardServiceList | Gets a comma-separated (CSV) list of services supported by the card.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
CurrentService | Gets or sets the character string that identifies the currently selected service.
DataCount | Gets a value that indicates the number of enqueued data events
DataEventEnabled | Gets or sets the Boolean value that indicates whether the DataEvent event will be delivered to the application.
DetectionControl | Gets or sets the Boolean value that indicates whether detection control is enabled.
DetectionStatus | Gets or sets the Boolean value that indicates the detection status.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
ExpirationDate | Gets the expiration date.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
LastUsedDate | Gets the last used date.
LogStatus | Gets the status of the transaction log.
MediumId | Gets or sets the medium identifier of the card.
OutputId | Gets the ID number of the asynchronous output request that is complete.
Point | Gets or sets the settlement point on the point service.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
ReaderWriterServiceList | Gets the comma-separated values (CSV) list of services that are supported by the Electronic Value RW device.
SequenceNumber | Gets a "sequence number" as the result of each method call.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
SettledAmount | Gets the real amount of the settlement on the electronic money service.
SettledPoint | Gets the settlement point on the point service.
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
TransactionLog | Stores the result of the AccessLog method.
VoucherId | Gets or sets the ID of voucher/ticket on the voucher/ticket service.
VoucherIdList | Gets or sets the IDs of voucher/ticket that are enumerated on the voucher/ticket service.
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets the Boolean value that indicates whether the Electronic Value RW device is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
AccessLog | Gets the transaction log from the device.
ActivateService | Executes the device activation process.
AddValue | Adds Electronic Value on demand to the card as specified by sequenceNumber.
BeginDetection | Executes the card detection process.
BeginRemoval | Executes the card removal process.
CancelValue | Cancels the Electronic Value related operation specified by SequenceNumber on demand.
CaptureCard | The card left in the slot is removed.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all buffered device input.
ClearInputProperties | Resets the values of properties altered by the DataEvent or ErrorEvent event.
ClearOutput | Clears all buffered device output.
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
EndDetection | Ends the card detection process.
EndRemoval | Ends the card removal process.
EnumerateCardServices | Enumerates the services which are used in the card and also sets the CardServiceList property.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
LockTerminal | Locks the security lock.
Open | Opens a device for later input/output processing. (inherited from PosCommon)
ReadValue | Reads the Electronic Value from the card.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
SubtractValue | Subtracts the Electronic Value from the card.
ToString | (inherited from Object )
TransactionAccess | Enters or exits transaction mode.
UnlockTerminal | Releases the security lock.
UpdateFirmware | (inherited from PosCommon )
UpdateKey | Updates the key information in the device.
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
WriteValue | Electronic Value is added to the card as specified by SequenceNumber on demand.
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DataEvent | Notifies the application about the available input data from the device.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
ErrorEvent | Notifies the application that an ElectronicValue R/W error has been detected and a suitable response by the application is necessary to process the error condition.
OutputCompleteEvent | Notifies the application that the queued asynchronous output request associated with the OutputId attribute has completed successfully.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

ElectronicValueRW Class
Microsoft.PointOfService Namespace


ElectronicValueRW Fields

ElectronicValueRW Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorCenterError | Indicates that an error was returned from the approval agency.
ExtendedErrorCommandError | Indicates that the command sent to the device is wrong.
ExtendedErrorCommunicationError | Indicates that a communication error has occurred between the approval agency and the device.
ExtendedErrorDailyLogOverflow | Indicates that the transaction log on the device is full.
ExtendedErrorDeficient | Indicates that the amount cannot be subtracted because the balance is insufficient.
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorLogOverflow | Indicates that the transaction log was too large to be stored.
ExtendedErrorOverdeposit | Indicates that the device cannot add the charge because the maximum charge amount has been exceeded.
ExtendedErrorReset | Indicates that the device was stopped during processing by the device Reset key (Stop key).
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusCardCaptured | Indicates that the stock space sensor detects a card in the stock space.
StatusCardDetected | Indicates that the card detection sensor detects a card in the device.
StatusCardEntered | Indicates that the insertion slot sensor detects that a card is remaining in the slot.
StatusLogFull | Indicates that the transaction log is full.
StatusLogNearFull | Indicates that the transaction log is almost full.
StatusLogOk | Indicates that the transaction log has enough capacity.
StatusNoCard | Indicates that the card detection sensor does not detect a card.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

ElectronicValueRW Class
Microsoft.PointOfService Namespace


ElectronicValueRW.ExtendedErrorCenterError Field

ElectronicValueRW.ExtendedErrorCenterError Field |
 | See Also

1/18/2008

Indicates that an error was returned from the approval agency.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorCenterError As Integer
public const int ExtendedErrorCenterError
public:
literal int ExtendedErrorCenterError
public static final int ExtendedErrorCenterError
public const var ExtendedErrorCenterError : int

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.ExtendedErrorCommandError Field

ElectronicValueRW.ExtendedErrorCommandError Field |
 | See Also

1/18/2008

Indicates that the command sent to the device is wrong.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorCommandError As Integer
public const int ExtendedErrorCommandError
public:
literal int ExtendedErrorCommandError
public static final int ExtendedErrorCommandError
public const var ExtendedErrorCommandError : int

Remarks

This error is never returned if the device control is working correctly.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.ExtendedErrorCommunicationError Field

ElectronicValueRW.ExtendedErrorCommunicationError Field |
 | See Also

1/18/2008

Indicates that a communication error has occurred between the approval agency and the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorCommunicationError As Integer
public const int ExtendedErrorCommunicationError
public:
literal int ExtendedErrorCommunicationError
public static final int ExtendedErrorCommunicationError
public const var ExtendedErrorCommunicationError : int

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.ExtendedErrorDailyLogOverflow Field

ElectronicValueRW.ExtendedErrorDailyLogOverflow Field |
 | See Also

1/18/2008

Indicates that the transaction log on the device is full.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorDailyLogOverflow As Integer
public const int ExtendedErrorDailyLogOverflow
public:
literal int ExtendedErrorDailyLogOverflow
public static final int ExtendedErrorDailyLogOverflow
public const var ExtendedErrorDailyLogOverflow : int

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.ExtendedErrorDeficient Field

ElectronicValueRW.ExtendedErrorDeficient Field |
 | See Also

1/18/2008

Indicates that the amount cannot be subtracted because the balance is insufficient.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorDeficient As Integer
public const int ExtendedErrorDeficient
public:
literal int ExtendedErrorDeficient
public static final int ExtendedErrorDeficient
public const var ExtendedErrorDeficient : int

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.ExtendedErrorLogOverflow Field

ElectronicValueRW.ExtendedErrorLogOverflow Field |
 | See Also

1/18/2008

Indicates that the transaction log was too large to be stored.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorLogOverflow As Integer
public const int ExtendedErrorLogOverflow
public:
literal int ExtendedErrorLogOverflow
public static final int ExtendedErrorLogOverflow
public const var ExtendedErrorLogOverflow : int

Remarks

Getting transaction log has been stopped and the value of TransactionLog is uncertain.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.ExtendedErrorOverdeposit Field

ElectronicValueRW.ExtendedErrorOverdeposit Field |
 | See Also

1/18/2008

Indicates that the device cannot add the charge because the maximum charge amount has been exceeded.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorOverdeposit As Integer
public const int ExtendedErrorOverdeposit
public:
literal int ExtendedErrorOverdeposit
public static final int ExtendedErrorOverdeposit
public const var ExtendedErrorOverdeposit : int

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.ExtendedErrorReset Field

ElectronicValueRW.ExtendedErrorReset Field |
 | See Also

1/18/2008

Indicates that the device was stopped during processing by the device Reset key (Stop key).

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorReset As Integer
public const int ExtendedErrorReset
public:
literal int ExtendedErrorReset
public static final int ExtendedErrorReset
public const var ExtendedErrorReset : int

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.StatusCardCaptured Field

ElectronicValueRW.StatusCardCaptured Field |
 | See Also

1/18/2008

Indicates that the stock space sensor detects a card in the stock space.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusCardCaptured As Integer
public const int StatusCardCaptured
public:
literal int StatusCardCaptured
public static final int StatusCardCaptured
public const var StatusCardCaptured : int

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.StatusCardDetected Field

ElectronicValueRW.StatusCardDetected Field |
 | See Also

1/18/2008

Indicates that the card detection sensor detects a card in the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusCardDetected As Integer
public const int StatusCardDetected
public:
literal int StatusCardDetected
public static final int StatusCardDetected
public const var StatusCardDetected : int

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.StatusCardEntered Field

ElectronicValueRW.StatusCardEntered Field |
 | See Also

1/18/2008

Indicates that the insertion slot sensor detects that a card is remaining in the slot.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusCardEntered As Integer
public const int StatusCardEntered
public:
literal int StatusCardEntered
public static final int StatusCardEntered
public const var StatusCardEntered : int

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.StatusLogFull Field

ElectronicValueRW.StatusLogFull Field |
 | See Also

1/18/2008

Indicates that the transaction log is full.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusLogFull As Integer
public const int StatusLogFull
public:
literal int StatusLogFull
public static final int StatusLogFull
public const var StatusLogFull : int

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.StatusLogNearFull Field

ElectronicValueRW.StatusLogNearFull Field |
 | See Also

1/18/2008

Indicates that the transaction log is almost full.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusLogNearFull As Integer
public const int StatusLogNearFull
public:
literal int StatusLogNearFull
public static final int StatusLogNearFull
public const var StatusLogNearFull : int

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.StatusLogOk Field

ElectronicValueRW.StatusLogOk Field |
 | See Also

1/18/2008

Indicates that the transaction log has enough capacity.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusLogOk As Integer
public const int StatusLogOk
public:
literal int StatusLogOk
public static final int StatusLogOk
public const var StatusLogOk : int

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.StatusNoCard Field

ElectronicValueRW.StatusNoCard Field |
 | See Also

1/18/2008

Indicates that the card detection sensor does not detect a card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusNoCard As Integer
public const int StatusNoCard
public:
literal int StatusNoCard
public static final int StatusNoCard
public const var StatusNoCard : int

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW Constructor

ElectronicValueRW Constructor |
 | See Also

1/18/2008

Creates an instance of the ElectronicValueRW class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected ElectronicValueRW ()
protected:
ElectronicValueRW ()
protected ElectronicValueRW ()
protected function ElectronicValueRW ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW Methods

ElectronicValueRW Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
AccessLog | Gets the transaction log from the device.
ActivateService | Executes the device activation process.
AddValue | Adds Electronic Value on demand to the card as specified by sequenceNumber.
BeginDetection | Executes the card detection process.
BeginRemoval | Executes the card removal process.
CancelValue | Cancels the Electronic Value related operation specified by SequenceNumber on demand.
CaptureCard | The card left in the slot is removed.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all buffered device input.
ClearInputProperties | Resets the values of properties altered by the DataEvent or ErrorEvent event.
ClearOutput | Clears all buffered device output.
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
EndDetection | Ends the card detection process.
EndRemoval | Ends the card removal process.
EnumerateCardServices | Enumerates the services which are used in the card and also sets the CardServiceList property.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
LockTerminal | Locks the security lock.
Open | Opens a device for later input/output processing. (inherited from PosCommon )
ReadValue | Reads the Electronic Value from the card.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
SubtractValue | Subtracts the Electronic Value from the card.
ToString | (inherited from Object )
TransactionAccess | Enters or exits transaction mode.
UnlockTerminal | Releases the security lock.
UpdateFirmware | (inherited from PosCommon )
UpdateKey | Updates the key information in the device.
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
WriteValue | Electronic Value is added to the card as specified by SequenceNumber on demand.

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

ElectronicValueRW Class
Microsoft.PointOfService Namespace


ElectronicValueRW.AccessLog Method

ElectronicValueRW.AccessLog Method |
 | See Also

1/18/2008

Gets the transaction log from the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub AccessLog ( _
    sequenceNumber As Integer, _
    type As TransactionLogType, _
    timeout As Integer _
)
public abstract void AccessLog (
    int sequenceNumber,
    TransactionLogType type,
    int timeout
)
public:
virtual void AccessLog (
    int sequenceNumber,
    TransactionLogType type,
    int timeout
) abstract
public abstract void AccessLog (
    int sequenceNumber,
    TransactionLogType type,
    int timeout
)
public abstract function AccessLog (
    sequenceNumber : int,
    type : TransactionLogType,
    timeout : int
)

Parameters

sequenceNumber

The sequence number to get transaction log.

type

Specifies whether the transaction log is the intermediate total or the last total.

timeout

The maximum waiting time (in milliseconds) until the response is received from the device. WaitForever can be specified.

Remarks

Gets transaction log on demand by SequenceNumber and it is stored in the TransactionLog property.

When timeout is WaitForever, a time-out never occurs and it waits indefinitely until it receives a response from the device.

If the ElectronicValueRW device needs the last total processing of a transaction, it performs this method.

The last total processing might be cleared in the transaction log, this depends on the implementation. However, the intermediate total must not be cleared in the transaction log.

It depends on the implementation if the transaction log are passed to the service center directly and not to the application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.ActivateService Method

ElectronicValueRW.ActivateService Method |
 | See Also

1/18/2008

Executes the device activation process.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function ActivateService ( _
    data As Integer, _
    obj As Object _
) As EVRWResult
public abstract EVRWResult ActivateService (
    int data,
    Object obj
)
public:
virtual EVRWResult ActivateService (
    int data,
    Object^ obj
) abstract
public abstract EVRWResult ActivateService (
    int data,
    Object obj
)
public abstract function ActivateService (
    data : int,
    obj : Object
) : EVRWResult

Parameters

data

Data depends on implementation.

obj

Object depends on implementation.

Remarks

If the device has the activation process function, it is supported.

The activation process is initialization or installation of device. The details of process contents and parameters depend on implementation.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.AddValue Method

ElectronicValueRW.AddValue Method |
 | See Also

1/18/2008

Adds Electronic Value on demand to the card as specified by sequenceNumber.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub AddValue ( _
    sequenceNumber As Integer, _
    timeout As Integer _
)
public abstract void AddValue (
    int sequenceNumber,
    int timeout
)
public:
virtual void AddValue (
    int sequenceNumber,
    int timeout
) abstract
public abstract void AddValue (
    int sequenceNumber,
    int timeout
)
public abstract function AddValue (
    sequenceNumber : int,
    timeout : int
)

Parameters

sequenceNumber

Sequence number.

timeout

The maximum waiting time (in milliseconds) until the response is received from the device. WaitForever can be specified.

Remarks

When timeout is WaitForever, time-out never occurs and it waits indefinitely until it receives a response from the device.

This method is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.BeginDetection Method

ElectronicValueRW.BeginDetection Method |
 | See Also

1/18/2008

Executes the card detection process.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub BeginDetection ( _
    type As BeginDetectionType, _
    timeout As Integer _
)
public abstract void BeginDetection (
    BeginDetectionType type,
    int timeout
)
public:
virtual void BeginDetection (
    BeginDetectionType type,
    int timeout
) abstract
public abstract void BeginDetection (
    BeginDetectionType type,
    int timeout
)
public abstract function BeginDetection (
    type : BeginDetectionType,
    timeout : int
)

Parameters

type

The type parameter specifies the type of the detected card.

timeout

If a value of WaitForever is specified, the method starts the card detection process and then waits as long as necessary until either the card is detected or an error occurs.

Remarks

Supports the both contact-less and contact IC card devices.

When called, the device starts a card detection process, and starts the card detection in the device. This method is called together with the EndDetection method that ends the card detection process.

If the device cannot be set to the detection process, an error exception is raised such as Timeout. However, the device stays in the detection mode until the EndDetection method is called.

If the timeout parameter value is zero, the method starts the detection mode immediately. If a value is set (in milliseconds), the card detection process waits for this time period if it is necessary.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.BeginRemoval Method

ElectronicValueRW.BeginRemoval Method |
 | See Also

1/18/2008

Executes the card removal process.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub BeginRemoval ( _
    timeout As Integer _
)
public abstract void BeginRemoval (
    int timeout
)
public:
virtual void BeginRemoval (
    int timeout
) abstract
public abstract void BeginRemoval (
    int timeout
)
public abstract function BeginRemoval (
    timeout : int
)

Parameters

timeout

If a value of WaitForever is specified, the method starts the card removal process and then waits as long as necessary until either the card is removed or an error occurs.

Remarks

If the device is a contact-less IC card device, when this method is called the device starts the card ejection process. Then it ejects the card and this method ends successfully at any time.

If the device is a contact IC card device with card detection sensor, this method is complete when card ejection was detected.

If the device is a contact IC card device without card detection sensor, this method is complete when this method is executed.

This method is called together with the EndRemoval method that ends the card ejection process.

If the device cannot be set to the card ejection mode, an error exception is raised, for example, Timeout. However, the device remains in card ejection mode until the EndRemoval method is called.

If the timeout parameter value is zero, the method starts the removal mode immediately. If a value is set (in milliseconds), the card removal process waits for this time period if it is necessary.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.CancelValue Method

ElectronicValueRW.CancelValue Method |
 | See Also

1/18/2008

Cancels the Electronic Value related operation specified by SequenceNumber on demand.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub CancelValue ( _
    sequenceNumber As Integer, _
    timeout As Integer _
)
public abstract void CancelValue (
    int sequenceNumber,
    int timeout
)
public:
virtual void CancelValue (
    int sequenceNumber,
    int timeout
) abstract
public abstract void CancelValue (
    int sequenceNumber,
    int timeout
)
public abstract function CancelValue (
    sequenceNumber : int,
    timeout : int
)

Parameters

sequenceNumber

Sequence number.

timeout

The maximum waiting time (in milliseconds) until the response is received from the device. WaitForever can be specified.

Remarks

The targeted cancellation operation is identified by the settlement number that is contained in the ApprovalCode property.

When timeout is WaitForever, time-out never occurs, and it waits indefinitely until it receives a response from the device.

This method is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.CaptureCard Method

ElectronicValueRW.CaptureCard Method |
 | See Also

1/18/2008

The card left in the slot is removed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub CaptureCard
public abstract void CaptureCard ()
public:
virtual void CaptureCard () abstract
public abstract void CaptureCard ()
public abstract function CaptureCard ()

Remarks

This method is effective, if the device is equipped with a card detection sensor.

When the card insertion slot sensor detects the card, because the card ejection process was executed, the application may call this method to keep and maintain the card.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.ClearInput Method

ElectronicValueRW.ClearInput Method |
 | See Also

1/18/2008

Clears all buffered device input.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearInput
public abstract void ClearInput ()
public:
virtual void ClearInput () abstract
public abstract void ClearInput ()
public abstract function ClearInput ()

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.ClearInputProperties Method

ElectronicValueRW.ClearInputProperties Method |
 | See Also

1/18/2008

Resets the values of properties altered by the DataEvent or ErrorEvent event.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearInputProperties
public abstract void ClearInputProperties ()
public:
virtual void ClearInputProperties () abstract
public abstract void ClearInputProperties ()
public abstract function ClearInputProperties ()

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.ClearOutput Method

ElectronicValueRW.ClearOutput Method |
 | See Also

1/18/2008

Clears all buffered device output.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearOutput
public abstract void ClearOutput ()
public:
virtual void ClearOutput () abstract
public abstract void ClearOutput ()
public abstract function ClearOutput ()

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.EndDetection Method

ElectronicValueRW.EndDetection Method |
 | See Also

1/18/2008

Ends the card detection process.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub EndDetection
public abstract void EndDetection ()
public:
virtual void EndDetection () abstract
public abstract void EndDetection ()
public abstract function EndDetection ()

Remarks

When called, the device ends card detection mode. If the card is correctly detected in the device control is returned to the application. If the card cannot be detected an exception is delivered with its ErrorCodeExtended property set to NoCard.

This method is called together with the BeginDetection method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.EndRemoval Method

ElectronicValueRW.EndRemoval Method |
 | See Also

1/18/2008

Ends the card removal process.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub EndRemoval
public abstract void EndRemoval ()
public:
virtual void EndRemoval () abstract
public abstract void EndRemoval ()
public abstract function EndRemoval ()

Remarks

When called, the device ends the card removal mode. If the card is not detected in the device, control is returned to the application. If the card remains in the device, an exception is delivered with its ErrorCodeExtended property set to Release. If the device is contact-less IC card, you do not have to implement this and control is always returned to the application without any exceptions.

This method is called together with the BeginRemoval method for the card removal processing.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.EnumerateCardServices Method

ElectronicValueRW.EnumerateCardServices Method |
 | See Also

1/18/2008

Enumerates the services which are used in the card and also sets the CardServiceList property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub EnumerateCardServices
public abstract void EnumerateCardServices ()
public:
virtual void EnumerateCardServices () abstract
public abstract void EnumerateCardServices ()
public abstract function EnumerateCardServices ()

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.LockTerminal Method

ElectronicValueRW.LockTerminal Method |
 | See Also

1/18/2008

Locks the security lock.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub LockTerminal
public abstract void LockTerminal ()
public:
virtual void LockTerminal () abstract
public abstract void LockTerminal ()
public abstract function LockTerminal ()

Remarks

If the device is locked, the device cannot accept any commands.

AdditionalSecurityInformation property is set if key information is required to lock for the authentication.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.ReadValue Method

ElectronicValueRW.ReadValue Method |
 | See Also

1/18/2008

Reads the Electronic Value from the card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ReadValue ( _
    sequenceNumber As Integer, _
    timeout As Integer _
)
public abstract void ReadValue (
    int sequenceNumber,
    int timeout
)
public:
virtual void ReadValue (
    int sequenceNumber,
    int timeout
) abstract
public abstract void ReadValue (
    int sequenceNumber,
    int timeout
)
public abstract function ReadValue (
    sequenceNumber : int,
    timeout : int
)

Parameters

sequenceNumber

Sequence number.

timeout

The maximum waiting time (in milliseconds) until the response is received from the device. WaitForever can be specified.

Remarks

Electronic Value is read from the card specified by SequenceNumber on demand.

When timeout is WaitForever, a time-out never occurs, and the service waits indefinitely until it receives a response from the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.SubtractValue Method

ElectronicValueRW.SubtractValue Method |
 | See Also

1/18/2008

Subtracts the Electronic Value from the card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub SubtractValue ( _
    sequenceNumber As Integer, _
    timeout As Integer _
)
public abstract void SubtractValue (
    int sequenceNumber,
    int timeout
)
public:
virtual void SubtractValue (
    int sequenceNumber,
    int timeout
) abstract
public abstract void SubtractValue (
    int sequenceNumber,
    int timeout
)
public abstract function SubtractValue (
    sequenceNumber : int,
    timeout : int
)

Parameters

sequenceNumber

Sequence number.

timeout

The maximum waiting time (in milliseconds) until the response is received from the device. WaitForever can be specified.

Remarks

Electronic Value is subtracted from the card specified by SequenceNumber on demand.

When timeout is WaitForever, time-out never occurs and the service waits indefinitely until it receives a response from the device.

This method is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.TransactionAccess Method

ElectronicValueRW.TransactionAccess Method |
 | See Also

1/18/2008

Enters or exits transaction mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub TransactionAccess ( _
    control As TransactionControl _
)
public abstract void TransactionAccess (
    TransactionControl control
)
public:
virtual void TransactionAccess (
    TransactionControl control
) abstract
public abstract void TransactionAccess (
    TransactionControl control
)
public abstract function TransactionAccess (
    control : TransactionControl
)

Parameters

control

The transaction control, can be set to TransactionNormal

Remarks

If control is Transaction, then transaction mode is entered. Later calls to ReadValue, WriteValue, AddValue, SubtractValue, and CancelValue will buffer the data until TransactionAccess is called by using the control parameter set to Normal. It depends on the implementation if buffering is finished in the ElectronicValueRW device or buffering is finished within the service.

If control is Normal, then transaction mode is exited. If some requests were buffered by calls to the methods ReadValue, WriteValue, AddValue, SubtractValue and CancelValue, then the buffered requests will be executed.

The transaction requests are treated as one message. This method is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

Calling the ClearOutput method cancels transaction mode. Any buffered print lines are also cleared.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.UnlockTerminal Method

ElectronicValueRW.UnlockTerminal Method |
 | See Also

1/18/2008

Releases the security lock.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub UnlockTerminal
public abstract void UnlockTerminal ()
public:
virtual void UnlockTerminal () abstract
public abstract void UnlockTerminal ()
public abstract function UnlockTerminal ()

Remarks

When the device has a security lock function, it is supported.

AdditionalSecurityInformation property is set when key information is required to release the lock.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.UpdateKey Method

ElectronicValueRW.UpdateKey Method |
 | See Also

1/18/2008

Updates the key information in the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function UpdateKey ( _
    data As Integer, _
    obj As Object _
) As EVRWResult
public abstract EVRWResult UpdateKey (
    int data,
    Object obj
)
public:
virtual EVRWResult UpdateKey (
    int data,
    Object^ obj
) abstract
public abstract EVRWResult UpdateKey (
    int data,
    Object obj
)
public abstract function UpdateKey (
    data : int,
    obj : Object
) : EVRWResult

Parameters

data

Data depends on implementation.

obj

Object depends on implementation.

Remarks

If the device has the function to the key information, it is supported.

The content of processing and the content of the parameter depend on the implementation.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.WriteValue Method

ElectronicValueRW.WriteValue Method |
 | See Also

1/18/2008

Electronic Value is added to the card as specified by SequenceNumber on demand.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub WriteValue ( _
    sequenceNumber As Integer, _
    timeout As Integer _
)
public abstract void WriteValue (
    int sequenceNumber,
    int timeout
)
public:
virtual void WriteValue (
    int sequenceNumber,
    int timeout
) abstract
public abstract void WriteValue (
    int sequenceNumber,
    int timeout
)
public abstract function WriteValue (
    sequenceNumber : int,
    timeout : int
)

Parameters

sequenceNumber

Sequence number.

timeout

The maximum waiting time (in milliseconds) until the response is received from the device. WaitForever and positive values can be specified.

Remarks

When timeout is WaitForever, time-out never occurs, and it waits indefinitely until it receives a response from the device.

This method is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW Properties

ElectronicValueRW Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
AccountNumber | Gets information for the service provider such as the card number to specify the user (owner) information from the card.
AdditionalSecurityInformation | Gets or sets additional security information that is stored before issuing an authorization method to an ElectronicValueRW device.
Amount | Gets or sets the payment amount on the electronic money service.
ApprovalCode | Gets or sets the payment approval code.
AsyncMode | Gets or sets the Boolean value that indicates whether associated methods are performed asynchronously or synchronously.
Balance | Gets the balance of the electronic money service.
BalanceOfPoint | Gets the point balance on the point service.
CapActivateService | Gets the Boolean value that indicates whether activation processing is supported.
CapAddValue | Gets the Boolean value that indicates whether the addition of Electronic Value is supported.
CapCancelValue | Gets the Boolean value that indicates whether the cancellation of the operation to the Electronic Value is supported.
CapCardSensor | Gets a bitmask that indicates the types of card detection that are supported.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapDetectionControl | Gets information that indicates detection, ejection, or storing processes can be controlled from the application or the reader/writer.
CapElectronicMoney | Gets the Boolean value that indicates whether the electronic money service is supported.
CapEnumerateCardServices | Gets the Boolean value that indicates whether the enumeration of service in the card is supported.
CapIndirectTransactionLog | Gets the Boolean value that indicates whether the transaction log is accessed as a file.
CapLockTerminal | Gets the Boolean value that indicates whether the security lock setting is supported.
CapLogStatus | Gets the Boolean value that indicates whether the reporting of the status of the transaction log is supported.
CapMediumId | Gets the Boolean value that indicates whether the specification of the medium identifier is supported.
CapPoint | Gets the Boolean value that indicates whether the point service is supported.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapSubtractValue | Gets the Boolean value that indicates whether the subtraction of Electronic Value is supported.
CapTransaction | Gets the Boolean value that indicates whether the transaction mode is supported.
CapTransactionLog | Gets the Boolean value that indicates whether the transaction log is supported.
CapUnlockTerminal | Gets the Boolean value that indicates whether releasing of the security lock is supported.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateKey | Gets the Boolean value that indicates whether the update of key information is supported.
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CapVoucher | Gets the Boolean value that indicates whether the voucher/ticket service is supported.
CapWriteValue | Gets the Boolean value that indicates whether the writing of Electronic Value is supported.
CardServiceList | Gets a comma-separated (CSV) list of services supported by the card.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
CurrentService | Gets or sets the character string that identifies the currently selected service.
DataCount | Gets a value that indicates the number of enqueued data events
DataEventEnabled | Gets or sets the Boolean value that indicates whether the DataEvent event will be delivered to the application.
DetectionControl | Gets or sets the Boolean value that indicates whether detection control is enabled.
DetectionStatus | Gets or sets the Boolean value that indicates the detection status.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
ExpirationDate | Gets the expiration date.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
LastUsedDate | Gets the last used date.
LogStatus | Gets the status of the transaction log.
MediumId | Gets or sets the medium identifier of the card.
OutputId | Gets the ID number of the asynchronous output request that is complete.
Point | Gets or sets the settlement point on the point service.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
ReaderWriterServiceList | Gets the comma-separated values (CSV) list of services that are supported by the Electronic Value RW device.
SequenceNumber | Gets a "sequence number" as the result of each method call.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
SettledAmount | Gets the real amount of the settlement on the electronic money service.
SettledPoint | Gets the settlement point on the point service.
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )
TransactionLog | Stores the result of the AccessLog method.
VoucherId | Gets or sets the ID of voucher/ticket on the voucher/ticket service.
VoucherIdList | Gets or sets the IDs of voucher/ticket that are enumerated on the voucher/ticket service.

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets the Boolean value that indicates whether the Electronic Value RW device is an exclusive-use device.

See Also

Reference

ElectronicValueRW Class
Microsoft.PointOfService Namespace


ElectronicValueRW.AccountNumber Property

ElectronicValueRW.AccountNumber Property |
 | See Also

1/18/2008

Gets information for the service provider such as the card number to specify the user (owner) information from the card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property AccountNumber As String
public abstract string AccountNumber { get; }
public:
virtual property String^ AccountNumber {
    String^ get () abstract;
}
/** @property */
public abstract String get_AccountNumber ()

public abstract function get AccountNumber () : String

Remarks

This property is initialized to an empty string ("") by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.AdditionalSecurityInformation Property

ElectronicValueRW.AdditionalSecurityInformation Property |
 | See Also

1/18/2008

Gets or sets additional security information that is stored before issuing an authorization method to an ElectronicValueRW device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AdditionalSecurityInformation As String
public abstract string AdditionalSecurityInformation { get; set; }
public:
virtual property String^ AdditionalSecurityInformation {
    String^ get () abstract;
    void set (String^ value) abstract;
}
/** @property */
public abstract String get_AdditionalSecurityInformation ()

/** @property */
public abstract void set_AdditionalSecurityInformation (String value)

public abstract function get AdditionalSecurityInformation () : String

public abstract function set AdditionalSecurityInformation (value : String)

Remarks

An application can send data to the ElectronicValueRW device by setting this property before issuing an authorization method. Also, data obtained from the ElectronicValueRW device and not stored in any other property as the result of an authorization operation can be provided to an application by storing it in this property. Because the data that is stored here is device-specific, it should not be used for any development that requires portability.

This property is initialized to an empty string ("") by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.Amount Property

ElectronicValueRW.Amount Property |
 | See Also

1/18/2008

Gets or sets the payment amount on the electronic money service.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property Amount As Decimal
public abstract decimal Amount { get; set; }
public:
virtual property Decimal Amount {
    Decimal get () abstract;
    void set (Decimal value) abstract;
}
/** @property */
public abstract Decimal get_Amount ()

/** @property */
public abstract void set_Amount (Decimal value)

public abstract function get Amount () : decimal

public abstract function set Amount (value : decimal)

Remarks

This property is initialized to zero by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.ApprovalCode Property

ElectronicValueRW.ApprovalCode Property |
 | See Also

1/18/2008

Gets or sets the payment approval code.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property ApprovalCode As String
public abstract string ApprovalCode { get; set; }
public:
virtual property String^ ApprovalCode {
    String^ get () abstract;
    void set (String^ value) abstract;
}
/** @property */
public abstract String get_ApprovalCode ()

/** @property */
public abstract void set_ApprovalCode (String value)

public abstract function get ApprovalCode () : String

public abstract function set ApprovalCode (value : String)

Remarks

The content of the approval code depends on the implementation of the device. When a unique number is issued to the processing done with the device, the information is set.

This property is set to specify the cancellation of the payment when the device supports cancellation of the payment and the CancelValue method is executed.

This property is initialized to an empty string ("") by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.AsyncMode Property

ElectronicValueRW.AsyncMode Property |
 | See Also

1/18/2008

Gets or sets the Boolean value that indicates whether associated methods are performed asynchronously or synchronously.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AsyncMode As Boolean
public abstract bool AsyncMode { get; set; }
public:
virtual property bool AsyncMode {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_AsyncMode ()

/** @property */
public abstract void set_AsyncMode (boolean value)

public abstract function get AsyncMode () : boolean

public abstract function set AsyncMode (value : boolean)

Remarks

If true, the WriteValue, AddValue, SubtractValue, CancelValue, AccessLog, and TransactionAccess methods are performed asynchronously.

If false, these methods are performed synchronously.

This property is initialized to false by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.Balance Property

ElectronicValueRW.Balance Property |
 | See Also

1/18/2008

Gets the balance of the electronic money service.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property Balance As Decimal
public abstract decimal Balance { get; }
public:
virtual property Decimal Balance {
    Decimal get () abstract;
}
/** @property */
public abstract Decimal get_Balance ()

public abstract function get Balance () : decimal

Remarks

This property is initialized to zero by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.BalanceOfPoint Property

ElectronicValueRW.BalanceOfPoint Property |
 | See Also

1/18/2008

Gets the point balance on the point service.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property BalanceOfPoint As Decimal
public abstract decimal BalanceOfPoint { get; }
public:
virtual property Decimal BalanceOfPoint {
    Decimal get () abstract;
}
/** @property */
public abstract Decimal get_BalanceOfPoint ()

public abstract function get BalanceOfPoint () : decimal

Remarks

This property is initialized to zero by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.CapActivateService Property

ElectronicValueRW.CapActivateService Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether activation processing is supported.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapActivateService As Boolean
public abstract bool CapActivateService { get; }
public:
virtual property bool CapActivateService {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapActivateService ()

public abstract function get CapActivateService () : boolean

Remarks

If true, activation processing is supported; otherwise it is false.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.CapAddValue Property

ElectronicValueRW.CapAddValue Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the addition of Electronic Value is supported.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapAddValue As Boolean
public abstract bool CapAddValue { get; }
public:
virtual property bool CapAddValue {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapAddValue ()

public abstract function get CapAddValue () : boolean

Remarks

If true, the addition of Electronic Value is supported; otherwise it is false.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.CapCancelValue Property

ElectronicValueRW.CapCancelValue Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the cancellation of the operation to the Electronic Value is supported.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapCancelValue As Boolean
public abstract bool CapCancelValue { get; }
public:
virtual property bool CapCancelValue {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapCancelValue ()

public abstract function get CapCancelValue () : boolean

Remarks

If true, the cancellation of the operation to the Electronic Value is supported; otherwise it is false.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.CapCardSensor Property

ElectronicValueRW.CapCardSensor Property |
 | See Also

1/18/2008

Gets a bitmask that indicates the types of card detection that are supported.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapCardSensor As CardDetectionTypes
public abstract CardDetectionTypes CapCardSensor { get; }
public:
virtual property CardDetectionTypes CapCardSensor {
    CardDetectionTypes get () abstract;
}
/** @property */
public abstract CardDetectionTypes get_CapCardSensor ()

public abstract function get CapCardSensor () : CardDetectionTypes

Remarks

When the sensor exists, the detection is set to the DetectionStatus property and a StatusUpdateEvent event is delivered.

This property is set to the logical value.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.CapDetectionControl Property

ElectronicValueRW.CapDetectionControl Property |
 | See Also

1/18/2008

Gets information that indicates detection, ejection, or storing processes can be controlled from the application or the reader/writer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapDetectionControl As CardDetectionControl
public abstract CardDetectionControl CapDetectionControl { get; }
public:
virtual property CardDetectionControl CapDetectionControl {
    CardDetectionControl get () abstract;
}
/** @property */
public abstract CardDetectionControl get_CapDetectionControl ()

public abstract function get CapDetectionControl () : CardDetectionControl

Remarks

This property is set to the logical value.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.CapElectronicMoney Property

ElectronicValueRW.CapElectronicMoney Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the electronic money service is supported.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapElectronicMoney As Boolean
public abstract bool CapElectronicMoney { get; }
public:
virtual property bool CapElectronicMoney {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapElectronicMoney ()

public abstract function get CapElectronicMoney () : boolean

Remarks

If true, the electronic money service is supported; otherwise it is false.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.CapEnumerateCardServices Property

ElectronicValueRW.CapEnumerateCardServices Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the enumeration of service in the card is supported.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapEnumerateCardServices As Boolean
public abstract bool CapEnumerateCardServices { get; }
public:
virtual property bool CapEnumerateCardServices {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapEnumerateCardServices ()

public abstract function get CapEnumerateCardServices () : boolean

Remarks

If true, the enumeration of service in the card is supported; otherwise it is false.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.CapIndirectTransactionLog Property

ElectronicValueRW.CapIndirectTransactionLog Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the transaction log is accessed as a file.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapIndirectTransactionLog As Boolean
public abstract bool CapIndirectTransactionLog { get; }
public:
virtual property bool CapIndirectTransactionLog {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapIndirectTransactionLog ()

public abstract function get CapIndirectTransactionLog () : boolean

Remarks

If true, the transaction log is accessed as a file; otherwise it is false.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.CapLockTerminal Property

ElectronicValueRW.CapLockTerminal Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the security lock setting is supported.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapLockTerminal As Boolean
public abstract bool CapLockTerminal { get; }
public:
virtual property bool CapLockTerminal {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapLockTerminal ()

public abstract function get CapLockTerminal () : boolean

Remarks

If true, the security lock setting is supported; otherwise it is false.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.CapLogStatus Property

ElectronicValueRW.CapLogStatus Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the reporting of the status of the transaction log is supported.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapLogStatus As Boolean
public abstract bool CapLogStatus { get; }
public:
virtual property bool CapLogStatus {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapLogStatus ()

public abstract function get CapLogStatus () : boolean

Remarks

If true, the reporting of the status of the transaction log is supported; otherwise it

is false.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.CapMediumId Property

ElectronicValueRW.CapMediumId Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the specification of the medium identifier is supported.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapMediumId As Boolean
public abstract bool CapMediumId { get; }
public:
virtual property bool CapMediumId {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapMediumId ()

public abstract function get CapMediumId () : boolean

Remarks

If true, the specification of the medium identifier is supported; otherwise it is false.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.CapPoint Property

ElectronicValueRW.CapPoint Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the point service is supported.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapPoint As Boolean
public abstract bool CapPoint { get; }
public:
virtual property bool CapPoint {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapPoint ()

public abstract function get CapPoint () : boolean

Remarks

If true, the point service is supported otherwise it is false.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.CapSubtractValue Property

ElectronicValueRW.CapSubtractValue Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the subtraction of Electronic Value is supported.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSubtractValue As Boolean
public abstract bool CapSubtractValue { get; }
public:
virtual property bool CapSubtractValue {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSubtractValue ()

public abstract function get CapSubtractValue () : boolean

Remarks

If true, the subtraction of Electronic Value is supported; otherwise it is false.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.CapTransaction Property

ElectronicValueRW.CapTransaction Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the transaction mode is supported.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapTransaction As Boolean
public abstract bool CapTransaction { get; }
public:
virtual property bool CapTransaction {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapTransaction ()

public abstract function get CapTransaction () : boolean

Remarks

If true, the transaction mode is supported; otherwise it is false.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.CapTransactionLog Property

ElectronicValueRW.CapTransactionLog Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the transaction log is supported.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapTransactionLog As Boolean
public abstract bool CapTransactionLog { get; }
public:
virtual property bool CapTransactionLog {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapTransactionLog ()

public abstract function get CapTransactionLog () : boolean

Remarks

If true, the transaction log is supported; otherwise it is false.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.CapUnlockTerminal Property

ElectronicValueRW.CapUnlockTerminal Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether releasing of the security lock is supported.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapUnlockTerminal As Boolean
public abstract bool CapUnlockTerminal { get; }
public:
virtual property bool CapUnlockTerminal {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapUnlockTerminal ()

public abstract function get CapUnlockTerminal () : boolean

Remarks

If true, releasing of the security lock is supported; otherwise it is false.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.CapUpdateKey Property

ElectronicValueRW.CapUpdateKey Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the update of key information is supported.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapUpdateKey As Boolean
public abstract bool CapUpdateKey { get; }
public:
virtual property bool CapUpdateKey {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapUpdateKey ()

public abstract function get CapUpdateKey () : boolean

Remarks

If true, the update of key information is supported; otherwise it is false.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.CapVoucher Property

ElectronicValueRW.CapVoucher Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the voucher/ticket service is supported.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapVoucher As Boolean
public abstract bool CapVoucher { get; }
public:
virtual property bool CapVoucher {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapVoucher ()

public abstract function get CapVoucher () : boolean

Remarks

If true, the voucher/ticket service is supported; otherwise it is false.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.CapWriteValue Property

ElectronicValueRW.CapWriteValue Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the writing of Electronic Value is supported.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapWriteValue As Boolean
public abstract bool CapWriteValue { get; }
public:
virtual property bool CapWriteValue {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapWriteValue ()

public abstract function get CapWriteValue () : boolean

Remarks

If true, the writing of Electronic Value is supported; otherwise it is false.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.CardServiceList Property

ElectronicValueRW.CardServiceList Property |
 | See Also

1/18/2008

Gets a comma-separated (CSV) list of services supported by the card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CardServiceList As ReadOnlyCollection(Of String)
public abstract ReadOnlyCollection<string> CardServiceList { get; }
public:
virtual property ReadOnlyCollection<String^>^ CardServiceList {
    ReadOnlyCollection<String^>^ get () abstract;
}
/** @property */
public abstract ReadOnlyCollection<String> get_CardServiceList ()

public abstract function get CardServiceList () : ReadOnlyCollection<String>

Remarks

This list is populated by the EnumerateCardServices method.

For example, when the character string that identifies "A" electronic money service is "MoneyA" and the character string that identifies "B" electronic point service is "PointB," the CardServiceList property becomes "MoneyA,PointB."

This property is initialized to an empty string ("") by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.CurrentService Property

ElectronicValueRW.CurrentService Property |
 | See Also

1/18/2008

Gets or sets the character string that identifies the currently selected service.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property CurrentService As String
public abstract string CurrentService { get; set; }
public:
virtual property String^ CurrentService {
    String^ get () abstract;
    void set (String^ value) abstract;
}
/** @property */
public abstract String get_CurrentService ()

/** @property */
public abstract void set_CurrentService (String value)

public abstract function get CurrentService () : String

public abstract function set CurrentService (value : String)

Remarks

This value is guaranteed to be one of the set of services specified by the ReaderWriterServiceList property.

The character string being enumerated by the ReaderWriterServiceList property can be set.

If an empty string ("") is set, it enters the state that no service has been selected. In this state, depending on the device, an application can operate directly to the device.

When a valid string is set, the service is selected and started.

If the service supports the subservice, the execution of the method and the setting of property are performed to the subservice of the service that property shows. And only the event raises from the subservice which is selected by this property.

This property is initialized to an empty string ("") by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.DataCount Property

ElectronicValueRW.DataCount Property |
 | See Also

1/18/2008

Gets a value that indicates the number of enqueued data events

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DataCount As Integer
public abstract int DataCount { get; }
public:
virtual property int DataCount {
    int get () abstract;
}
/** @property */
public abstract int get_DataCount ()

public abstract function get DataCount () : int

Remarks

If true, the detection processing of the card by the BeginDetection/EndDetection methods and the card ejection processing by the BeginRemoval/EndRemoval methods are controlled by the application.

This property can only be set true by the application when CapDetectionControl is set to Application.

If false, neither detection nor the ejection processing of the card is controlled from the application. Invocation of the BeginDetection/EndDetection methods and the BeginRemoval/EndRemoval methods from the application is invalid.

When CardDetectionControl is specified for the CapDetectionControl property, you can set it.

This property is initialized to false by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.DataEventEnabled Property

ElectronicValueRW.DataEventEnabled Property |
 | See Also

1/18/2008

Gets or sets the Boolean value that indicates whether the DataEvent event will be delivered to the application.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property DataEventEnabled As Boolean
public abstract bool DataEventEnabled { get; set; }
public:
virtual property bool DataEventEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_DataEventEnabled ()

/** @property */
public abstract void set_DataEventEnabled (boolean value)

public abstract function get DataEventEnabled () : boolean

public abstract function set DataEventEnabled (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.DetectionControl Property

ElectronicValueRW.DetectionControl Property |
 | See Also

1/18/2008

Gets or sets the Boolean value that indicates whether detection control is enabled.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property DetectionControl As Boolean
public abstract bool DetectionControl { get; set; }
public:
virtual property bool DetectionControl {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_DetectionControl ()

/** @property */
public abstract void set_DetectionControl (boolean value)

public abstract function get DetectionControl () : boolean

public abstract function set DetectionControl (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.DetectionStatus Property

ElectronicValueRW.DetectionStatus Property |
 | See Also

1/18/2008

Gets or sets the Boolean value that indicates the detection status.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DetectionStatus As DetectionState
public abstract DetectionState DetectionStatus { get; }
public:
virtual property DetectionState DetectionStatus {
    DetectionState get () abstract;
}
/** @property */
public abstract DetectionState get_DetectionStatus ()

public abstract function get DetectionStatus () : DetectionState

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.ExpirationDate Property

ElectronicValueRW.ExpirationDate Property |
 | See Also

1/18/2008

Gets the expiration date.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ExpirationDate As DateTime
public abstract DateTime ExpirationDate { get; }
public:
virtual property DateTime ExpirationDate {
    DateTime get () abstract;
}
/** @property */
public abstract DateTime get_ExpirationDate ()

public abstract function get ExpirationDate () : DateTime

Remarks

Holds the expiration date in the format "YYYYMMDD."

This property is initialized to an empty string ("") by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.IsExclusiveUseDevice Property

ElectronicValueRW.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the Electronic Value RW device is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.LastUsedDate Property

ElectronicValueRW.LastUsedDate Property |
 | See Also

1/18/2008

Gets the last used date.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property LastUsedDate As DateTime
public abstract DateTime LastUsedDate { get; }
public:
virtual property DateTime LastUsedDate {
    DateTime get () abstract;
}
/** @property */
public abstract DateTime get_LastUsedDate ()

public abstract function get LastUsedDate () : DateTime

Remarks

Holds the last used date in the format "YYYYMMDDHHMMSS."

This property is initialized to an empty string ("") by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.LogStatus Property

ElectronicValueRW.LogStatus Property |
 | See Also

1/18/2008

Gets the status of the transaction log.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property LogStatus As LogState
public abstract LogState LogStatus { get; }
public:
virtual property LogState LogStatus {
    LogState get () abstract;
}
/** @property */
public abstract LogState get_LogStatus ()

public abstract function get LogStatus () : LogState

Remarks

If transaction log becomes full, depending on the device, the settlement processing may be unable to operate.

After this property is initialized, it is kept current as long as the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.MediumId Property

ElectronicValueRW.MediumId Property |
 | See Also

1/18/2008

Gets or sets the medium identifier of the card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property MediumId As String
public abstract string MediumId { get; set; }
public:
virtual property String^ MediumId {
    String^ get () abstract;
    void set (String^ value) abstract;
}
/** @property */
public abstract String get_MediumId ()

/** @property */
public abstract void set_MediumId (String value)

public abstract function get MediumId () : String

public abstract function set MediumId (value : String)

Remarks

The medium identifier is information (manufacturer’s serial number, and so on) to specify the card uniquely, and its content depends on implementation for the card. The following methods are processed to the card with the medium identifier specified by this property:

  • AddValue

  • BeginDetection

  • CancelValue

  • ReadValue

  • SubtractValue

  • WriteValue

The application can specify the card to be operated on by setting the medium identifier to this property before the method call is issued. Setting an empty string ("") for this property means the operation can be performed with any card.

The medium identifier of the card is set when the method that have relation to the card succeeds.

This property is initialized to an empty string ("") by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.OutputId Property

ElectronicValueRW.OutputId Property |
 | See Also

1/18/2008

Gets the ID number of the asynchronous output request that is complete.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property OutputId As Integer
public abstract int OutputId { get; }
public:
virtual property int OutputId {
    int get () abstract;
}
/** @property */
public abstract int get_OutputId ()

public abstract function get OutputId () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.Point Property

ElectronicValueRW.Point Property |
 | See Also

1/18/2008

Gets or sets the settlement point on the point service.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property Point As Decimal
public abstract decimal Point { get; set; }
public:
virtual property Decimal Point {
    Decimal get () abstract;
    void set (Decimal value) abstract;
}
/** @property */
public abstract Decimal get_Point ()

/** @property */
public abstract void set_Point (Decimal value)

public abstract function get Point () : decimal

public abstract function set Point (value : decimal)

Remarks

Holds the settlement point on the point service.

This property is initialized to zero by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.ReaderWriterServiceList Property

ElectronicValueRW.ReaderWriterServiceList Property |
 | See Also

1/18/2008

Gets the comma-separated values (CSV) list of services that are supported by the Electronic Value RW device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ReaderWriterServiceList As ReadOnlyCollection(Of String)
public abstract ReadOnlyCollection<string> ReaderWriterServiceList { get; }
public:
virtual property ReadOnlyCollection<String^>^ ReaderWriterServiceList {
    ReadOnlyCollection<String^>^ get () abstract;
}
/** @property */
public abstract ReadOnlyCollection<String> get_ReaderWriterServiceList ()

public abstract function get ReaderWriterServiceList () : ReadOnlyCollection<String>

Remarks

Holds the comma-separated list of services that are supported by the ElectronicValueRW device.

For example, when the character string that identifies 'A' electronic money service is "MoneyA" and the character string that identifies 'B' electronic point service is "PointB," the ReaderWriterServiceList property becomes "MoneyA,PointB."

If the service supports the subservice, the Open method succeeds, the service that all the subservices provide is enumerated.

If the ElectronicValueRW service does not support the subservice and an ElectronicValueRW service supports many services, those services are enumerated by this property.

This property is initialized by the Open method. The initialization value depends on what services are supported; for example, if the ElectronicValueRW device supports "MoneyA" and "PointB" services, this property is initialized to "MoneyA, PointB."

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.SequenceNumber Property

ElectronicValueRW.SequenceNumber Property |
 | See Also

1/18/2008

Gets a "sequence number" as the result of each method call.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property SequenceNumber As Integer
public abstract int SequenceNumber { get; }
public:
virtual property int SequenceNumber {
    int get () abstract;
}
/** @property */
public abstract int get_SequenceNumber ()

public abstract function get SequenceNumber () : int

Remarks

Holds a "sequence number" as the result of each method call. This number has to be checked by an application to see whether it matches with the argument SequenceNumber of the originating method.

This property is initialized to zero by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.SettledAmount Property

ElectronicValueRW.SettledAmount Property |
 | See Also

1/18/2008

Gets the real amount of the settlement on the electronic money service.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property SettledAmount As Decimal
public abstract decimal SettledAmount { get; }
public:
virtual property Decimal SettledAmount {
    Decimal get () abstract;
}
/** @property */
public abstract Decimal get_SettledAmount ()

public abstract function get SettledAmount () : decimal

Remarks

This property is initialized to zero by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.SettledPoint Property

ElectronicValueRW.SettledPoint Property |
 | See Also

1/18/2008

Gets the settlement point on the point service.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property SettledPoint As Decimal
public abstract decimal SettledPoint { get; }
public:
virtual property Decimal SettledPoint {
    Decimal get () abstract;
}
/** @property */
public abstract Decimal get_SettledPoint ()

public abstract function get SettledPoint () : decimal

Remarks

This property is initialized to zero by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.TransactionLog Property

ElectronicValueRW.TransactionLog Property |
 | See Also

1/18/2008

Stores the result of the AccessLog method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property TransactionLog As String
public abstract string TransactionLog { get; }
public:
virtual property String^ TransactionLog {
    String^ get () abstract;
}
/** @property */
public abstract String get_TransactionLog ()

public abstract function get TransactionLog () : String

Remarks

Stores the result of the AccessLog method.

If the CapIndirectTransactionLog property is true, the TransactionLog property shows a URL that shows the position such as files where the transaction log is stored.

The content of the transaction log depends on the device and service.

This property is initialized to an empty string ("") by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.VoucherId Property

ElectronicValueRW.VoucherId Property |
 | See Also

1/18/2008

Gets or sets the ID of voucher/ticket on the voucher/ticket service.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property VoucherId As String
public abstract string VoucherId { get; set; }
public:
virtual property String^ VoucherId {
    String^ get () abstract;
    void set (String^ value) abstract;
}
/** @property */
public abstract String get_VoucherId ()

/** @property */
public abstract void set_VoucherId (String value)

public abstract function get VoucherId () : String

public abstract function set VoucherId (value : String)

Remarks

It consists of pairs of the identifier and the number which validate the card holder.

For example, six tickets of identifier "001" are shown by the character string "001:6". The ":" is a separator between the identifier and the number of sheets.

This property is initialized to an empty string ("") by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.VoucherIdList Property

ElectronicValueRW.VoucherIdList Property |
 | See Also

1/18/2008

Gets or sets the IDs of voucher/ticket that are enumerated on the voucher/ticket service.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property VoucherIdList As String
public abstract string VoucherIdList { get; set; }
public:
virtual property String^ VoucherIdList {
    String^ get () abstract;
    void set (String^ value) abstract;
}
/** @property */
public abstract String get_VoucherIdList ()

/** @property */
public abstract void set_VoucherIdList (String value)

public abstract function get VoucherIdList () : String

public abstract function set VoucherIdList (value : String)

Remarks

If six tickets of identifier "001," one ticket of identifier "002," two tickets of identifier "034" are maintained, this is expressed by the CSV character string in the format "001:6,002:1,034:2." The "," is a separator when two or more rights are maintained.

This property is initialized to an empty string ("") by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW Events

ElectronicValueRW Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DataEvent | Notifies the application about the available input data from the device.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
ErrorEvent | Notifies the application that an ElectronicValue R/W error has been detected and a suitable response by the application is necessary to process the error condition.
OutputCompleteEvent | Notifies the application that the queued asynchronous output request associated with the OutputId attribute has completed successfully.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

ElectronicValueRW Class
Microsoft.PointOfService Namespace


ElectronicValueRW.DataEvent Event

ElectronicValueRW.DataEvent Event |
 | See Also

1/18/2008

Notifies the application about the available input data from the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event DataEvent As DataEventHandler
public abstract event DataEventHandler DataEvent
public:
virtual event DataEventHandler^ DataEvent {
    void add (DataEventHandler^ value) abstract;
    void remove (DataEventHandler^ value) abstract;
}
/** @event */
public abstract void add_DataEvent (DataEventHandler value)

/** @event */
public abstract void remove_DataEvent (DataEventHandler value)

Remarks

Before this event is delivered, the input data is set to the appropriate property.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.ErrorEvent Event

ElectronicValueRW.ErrorEvent Event |
 | See Also

1/18/2008

Notifies the application that an ElectronicValue R/W error has been detected and a suitable response by the application is necessary to process the error condition.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event ErrorEvent As DeviceErrorEventHandler
public abstract event DeviceErrorEventHandler ErrorEvent
public:
virtual event DeviceErrorEventHandler^ ErrorEvent {
    void add (DeviceErrorEventHandler^ value) abstract;
    void remove (DeviceErrorEventHandler^ value) abstract;
}
/** @event */
public abstract void add_ErrorEvent (DeviceErrorEventHandler value)

/** @event */
public abstract void remove_ErrorEvent (DeviceErrorEventHandler value)

Remarks

Notifies when the error is detected when a method is asynchronously executed, and the state of the control moves to the error state.

Input error events are generated when errors occur while they read the data from a card, directed by ReadValue method. These error events are not delivered until the DataEventEnabled property is set to true to enable correct application sequencing. All error information is put into the applicable properties before this event is delivered.

Output error events are generated and delivered when errors occur during asynchronous output processing. The errors are put into the applicable properties before the events are delivered.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


ElectronicValueRW.OutputCompleteEvent Event

ElectronicValueRW.OutputCompleteEvent Event |
 | See Also

1/18/2008

Notifies the application that the queued asynchronous output request associated with the OutputId attribute has completed successfully.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event OutputCompleteEvent As OutputCompleteEventHandler
public abstract event OutputCompleteEventHandler OutputCompleteEvent
public:
virtual event OutputCompleteEventHandler^ OutputCompleteEvent {
    void add (OutputCompleteEventHandler^ value) abstract;
    void remove (OutputCompleteEventHandler^ value) abstract;
}
/** @event */
public abstract void add_OutputCompleteEvent (OutputCompleteEventHandler value)

/** @event */
public abstract void remove_OutputCompleteEvent (OutputCompleteEventHandler value)

Remarks

This event is enqueued after the request’s data has been both sent and the Service has confirmation that it was processed by the device successfully.

See Also

Reference

ElectronicValueRW Class
ElectronicValueRW Members
Microsoft.PointOfService Namespace


EncryptionAlgorithm Enumeration

EncryptionAlgorithm Enumeration |
 | See Also

1/18/2008

Enumerates the encryption algorithms supported by the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration EncryptionAlgorithm
[FlagsAttribute]
public enum EncryptionAlgorithm
[FlagsAttribute]
public enum class EncryptionAlgorithm
/** @attribute FlagsAttribute() */
public enum EncryptionAlgorithm
FlagsAttribute
public enum EncryptionAlgorithm

Members

Member name | Description
None | Data encryption is not supported.
TripleDeaDukpt | Derived Unique Key Per Transaction (United States, Latin America).

Remarks

Holds a bitwise indication of the encryption algorithms supported by the device and is selectable by using the DataEncryptionAlgorithm property.

This property is initialized by the Open method.

See Also

Reference

Microsoft.PointOfService Namespace


EndDepositAction Enumeration

EndDepositAction Enumeration |
 | See Also Example

1/18/2008

Enumerates a value that indicates that the cash acceptance operation has been completed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration EndDepositAction
public enum EndDepositAction
public enum class EndDepositAction
public enum EndDepositAction
public enum EndDepositAction

Members

Member name | Description
Complete | Indicates that the deposit was accepted and that the process is complete.

Remarks

Holds a value that indicates that the cash acceptance operation has been completed.

Example

CoinAcceptor

BillAcceptor

See Also

Reference

Microsoft.PointOfService Namespace


ErrorCode Enumeration

ErrorCode Enumeration |
 | See Also

1/18/2008

Enumerates the valid types of errors for an error event.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration ErrorCode
public enum ErrorCode
public enum class ErrorCode
public enum ErrorCode
public enum ErrorCode

Members

Member name | Description
Busy | The current state does not allow this request. For example: if asynchronous output is in progress, certain methods may not be allowed.
Claimed | The device is opened but not claimed. Another application has the device claimed, so it cannot be claimed at this time.
Closed | The device must be opened.
Deprecated | The method has been deprecated and is no longer available.
Disabled | The device is opened and claimed (if this is an exclusive use device), but not enabled.
Exists | The file name (or other specified value) already exists.
Extended | A device category-specific error condition occurred. The error condition code is held in the exception's ErrorCodeExtended property.
Failure | The device cannot perform the requested procedure, even though the physical device is connected to the system, powered on, and on-line.
Illegal | An attempt was made to perform an illegal or unsupported operation with the device, or an invalid parameter value was used.
NoExist | The file name (or other specified value) does not exist.
NoHardware | The physical device is not connected to the system or is not powered on.
NoService | The control cannot communicate with the service object, normally because of a setup or configuration error.
NotClaimed | The device is opened but not claimed. No other application has the device claimed, so it can and must be claimed.
Offline | The physical device is off-line.
Success | No error occurred.
Timeout | The service object timed out waiting for a response from the physical device, or the control timed out waiting for a response from the service object.

Remarks

The ErrorCode enumeration represents the full set of standard UPOS error codes. A mapping between the UPOS error codes and their POS for .NET equivalents is provided in the Exception Classes topic in the POS for .NET Reference Guide.

It is typically used by the PosControlException class to return these UPOS-defined error codes to the POS for .NET application for handling.

ErrorCode is also used by the DeviceErrorEventArgs constructor and ErrorCode property.

The special value Extended allows the application to receive device-specific extended error codes in the exception's ErrorCodeExtended property. See the device documentation to find what extended error codes may be used in conjunction with this value.

See Also

Reference

Microsoft.PointOfService Namespace


ErrorLocus Enumeration

ErrorLocus Enumeration |
 | See Also

1/18/2008

Enumerates possible times when an error occurred.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration ErrorLocus
public enum ErrorLocus
public enum class ErrorLocus
public enum ErrorLocus
public enum ErrorLocus

Members

Member name | Description
Input | Error occurred while gathering or processing event-driven input. No input data is available.
InputData | An error occurred while gathering or processing event-driven input, and some previously buffered data is available.
Output | An error occurred while processing asynchronous output.

See Also

Reference

Microsoft.PointOfService Namespace


ErrorResponse Enumeration

ErrorResponse Enumeration |
 | See Also

1/18/2008

Enumerates the valid responses an application can make to an error event.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration ErrorResponse
public enum ErrorResponse
public enum class ErrorResponse
public enum ErrorResponse
public enum ErrorResponse

Members

Member name | Description
Clear | Clear the buffered DataEvent events and ErrorEvent events and exit the error state, changing State to Idle.
ContinueInput | This response acknowledges the error and directs the device to continue processing. The device remains in the error state, and delivers additional data events as directed by the DataEventEnabled property. When all input has been delivered and the DataEventEnabled property is again set to TRUE, another ErrorEvent is delivered with locus Input.
Retry | This response directs the device to retry the input. The error state is exited, and State is changed to Idle.

Remarks

Used by the constructor and ErrorResponse property of the DeviceErrorEventArgs class. Members of this enumeration replace the ER_RETRY, ER_CLEAR, and ER_CONTINUEINPUT UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace


EVRWResult Structure

EVRWResult Structure |
 | See Also Members

1/18/2008

Holds the structured return value for methods in the ElectronicValueRW class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Structure EVRWResult
public struct EVRWResult
public value class EVRWResult
public final class EVRWResult extends ValueType

Remarks

Replaces UPOS return parameters for ElectronicValueRW class methods.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

EVRWResult Members
Microsoft.PointOfService Namespace


EVRWResult Members

EVRWResult Members |
 | See Also Constructors Methods Properties

1/18/2008

Holds the structured return value for methods in the ElectronicValueRW class.

The following tables list the members exposed by the EVRWResult type.

Public Constructors

Name | Description
EVRWResult | Creates an instance of the EVRWResult structure.
Top

Public Properties

Name | Description
Data | Gets the returned data that depends on the specific implementation.
Object | Gets the returned object that depends on the specific implementation.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from ValueType )
GetHashCode | (inherited from ValueType )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from ValueType )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

EVRWResult Structure
Microsoft.PointOfService Namespace


EVRWResult Constructor

EVRWResult Constructor |
 | See Also

1/18/2008

Creates an instance of the EVRWResult structure.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    data As Integer, _
    obj As Object _
)
public EVRWResult (
    int data,
    Object obj
)
public:
EVRWResult (
    int data,
    Object^ obj
)
public EVRWResult (
    int data,
    Object obj
)
public function EVRWResult (
    data : int,
    obj : Object
)

Parameters

data

The returned data that depends on the specific implementation.

obj

The returned object that depends on the specific implementation.

See Also

Reference

EVRWResult Structure
EVRWResult Members
Microsoft.PointOfService Namespace


EVRWResult Methods

EVRWResult Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from ValueType )
GetHashCode | (inherited from ValueType )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from ValueType )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

EVRWResult Structure
Microsoft.PointOfService Namespace


EVRWResult Properties

EVRWResult Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
Data | Gets the returned data that depends on the specific implementation.
Object | Gets the returned object that depends on the specific implementation.

See Also

Reference

EVRWResult Structure
Microsoft.PointOfService Namespace


EVRWResult.Data Property

EVRWResult.Data Property |
 | See Also

1/18/2008

Gets the returned data that depends on the specific implementation.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Data As Integer
public int Data { get; }
public:
property int Data {
    int get ();
}
/** @property */
public int get_Data ()

public function get Data () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

EVRWResult Structure
EVRWResult Members
Microsoft.PointOfService Namespace


EVRWResult.Object Property

EVRWResult.Object Property |
 | See Also

1/18/2008

Gets the returned object that depends on the specific implementation.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Object As Object
public Object Object { get; }
public:
property Object^ Object {
    Object^ get ();
}
/** @property */
public Object get_Object ()

public function get Object () : Object

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

EVRWResult Structure
EVRWResult Members
Microsoft.PointOfService Namespace


FiscalAdjustment Enumeration

FiscalAdjustment Enumeration |
 | See Also

1/18/2008

Enumerates the valid types of fiscal adjustments.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration FiscalAdjustment
public enum FiscalAdjustment
public enum class FiscalAdjustment
public enum FiscalAdjustment
public enum FiscalAdjustment

Members

Member name | Description
AmountDiscount | Fixed amount discount. The amount parameter contains a currency value.
AmountSurcharge | Fixed amount surcharge. The amount parameter contains a currency value.
CouponAmountDiscount | Fixed amount discount. The amount parameter contains a currency value.
CouponPercentageDiscount | Percentage discount. The amount parameter contains a percentage value.
PercentageDiscount | Percentage discount. The amount parameter contains a percentage value.
PercentageSurcharge | Percentage surcharge. The amount parameter contains a percentage value.

Remarks

Used by the PrintRecItemAdjustment, PrintRecSubtotalAdjustment, and PrintRecSubtotalAdjustVoid methods. Members of this enumeration replace the FPTR_AT_AMOUNT_DISCOUNT, FPTR_AT_AMOUNT_SURCHARGE, FPTR_AT_PERCENTAGE_DISCOUNT, and FPTR_AT_PERCENTAGE_SURCHARGE UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
PrintRecItemAdjustment
PrintRecSubtotalAdjustment
PrintRecSubtotalAdjustVoid
PrintRecVoidItem


FiscalAdjustmentType Enumeration

FiscalAdjustmentType Enumeration |
 | See Also

1/18/2008

Enumerates the valid types of package adjustments.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration FiscalAdjustmentType
public enum FiscalAdjustmentType
public enum class FiscalAdjustmentType
public enum FiscalAdjustmentType
public enum FiscalAdjustmentType

Members

Member name | Description
Discount | Discount.
Surcharge | Surcharge.

Remarks

Used by the PrintRecPackageAdjustment and PrintRecPackageAdjustVoid methods. Members of this enumeration replace the FPTR_AT_DISCOUNT and FPTR_AT_SURCHARGE UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
PrintRecPackageAdjustment
PrintRecPackageAdjustVoid


FiscalContractorId Enumeration

FiscalContractorId Enumeration |
 | See Also

1/18/2008

Enumerates the valid contractors to whom the receipt and/or some items of the receipt can be assigned.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration FiscalContractorId
public enum FiscalContractorId
public enum class FiscalContractorId
public enum FiscalContractorId
public enum FiscalContractorId

Members

Member name | Description
First | First contractor is defined.
Second | Second contractor is defined.
Single | Single contractor.

Remarks

Used by the ContractorId property. Members of the FiscalContractorId enumeration replace the FPTR_CID_FIRST, FPTR_CID_SECOND, and FPTR_CID_SINGLE UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace


FiscalCountryCodes Enumeration

FiscalCountryCodes Enumeration |
 | See Also

1/18/2008

Enumerates the valid countries/regions supported by the fiscal printer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration FiscalCountryCodes
[FlagsAttribute]
public enum FiscalCountryCodes
[FlagsAttribute]
public enum class FiscalCountryCodes
/** @attribute FlagsAttribute() */
public enum FiscalCountryCodes
FlagsAttribute
public enum FiscalCountryCodes

Members

Member name | Description
Brazil | The fiscal printer supports Brazil’s fiscal rules.
Bulgaria | The fiscal printer supports Bulgaria's fiscal rules.
CzechRepublic | The fiscal printer supports Czech Republic fiscal rules.
Greece | The fiscal printer supports Greece's fiscal rules.
Hungary | The fiscal printer supports Hungary's fiscal rules.
Italy | The fiscal printer supports Italy's fiscal rules.
Other | The fiscal printer supports other fiscal rules.
Poland | The fiscal printer supports Poland's fiscal rules.
Romania | The fiscal printer supports Romania's fiscal rules.
Russia | The fiscal printer supports Russia's fiscal rules.
Sweden |
Turkey | The fiscal printer supports Turkey's fiscal rules.
Ukraine | The fiscal printer supports Ukraine's fiscal rules.

Remarks

Used by the CountryCode property. Members of this enumeration replace the FPTR_CC_ family of UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
CountryCode


FiscalCurrency Enumeration

FiscalCurrency Enumeration |
 | See Also

1/18/2008

Enumerates the valid currencies for a fiscal printer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration FiscalCurrency
public enum FiscalCurrency
public enum class FiscalCurrency
public enum FiscalCurrency
public enum FiscalCurrency

Members

Member name | Description
BrazilianCruceiro | The actual currency is Brazilian cruceiro.
BulgarianLev | The actual currency is Bulgarian lev.
CzechianKoruna |
Euro | The actual currency is euro.
GreekDrachma | The actual currency is Greek drachma.
HungarianForint | The actual currency is Hungarian forint.
ItalianLira | The actual currency is Italian lira.
Other | The actual currency is Other.
PolishZloty | The actual currency is Polish zloty.
RomanianLeu | The actual currency is Romanian leu.
RussianRouble | The actual currency is Russian rouble.
SwedishKrona |
TurkishLira | The actual currency is New Turkish lira.
UkrainianHryvnia |

Remarks

Used by the ActualCurrency property and the SetCurrency method.

Members of this enumeration replace the FPTR_AC_ and the FPTR_SC_EURO families of UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
ActualCurrency


FiscalData Enumeration

FiscalData Enumeration |
 | See Also

1/18/2008

Enumerates the valid data items that can be retrieved from a Fiscal Printer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration FiscalData
public enum FiscalData
public enum class FiscalData
public enum FiscalData
public enum FiscalData

Members

Member name | Description
CurrentTotal | Gets the current receipt total.
DailyTotal | Gets the daily total.
DescriptionLength | Gets the maximum number of characters that can be passed as a description parameter for a specific method, defined by the given identifier in the itemOption parameter.
Firmware | Gets the fiscal printer’s firmware release number.
FiscalDocument | Gets the number of daily fiscal documents.
FiscalDocumentVoid | Gets the number of daily voided fiscal documents.
FiscalReceipt | Gets the number of daily fiscal sales receipts.
FiscalReceiptVoid | Gets the number of daily voided fiscal sales receipts.
GrandTotal | Gets the fiscal printer’s grand total.
LineCount | Gets the number of printed lines, defined by the given identifier in the itemOption argument. If the CapMultiContractor property is true, line counters depend on the contractor defined by the ContractorId property.
NonFiscalDocument | Gets the number of daily non fiscal documents.
NonFiscalDocumentVoid | Gets the number of daily voided non fiscal documents.
NonFiscalReceipt | Gets the number of daily non fiscal receipts.
NotPaid | Gets the current total of not paid receipts.
NumberOfConfigurationBlocks | Gets the grand number of configuration blocks.
NumberOfCurrencyBlocks | Gets the grand number of currency blocks.
NumberOfHeaderBlocks | Gets the grand number of header blocks.
NumberOfResetBlocks | Gets the grand number of reset blocks.
NumberOfVatBlocks | Gets the grand number of VAT blocks.
NumberOfVoidedReceipts | Gets the total number of voided receipts.
PrinterId | Gets the fiscal printer’s fiscal ID.
ReceiptNumber | Gets the number of fiscal receipts printed.
Refund | Gets the current total of refunds.
RefundVoid | Gets the current total of voided refunds.
Restart | Gets the fiscal printer’s restart count.
SimplifiedInvoice | Gets the number of daily simplified invoices.
Tender | Gets the payment description used in the PrintRecTotal method. When specifying this value, a PaymentDescription value from FiscalPrinter must be passed in the itemOption parameter.
ZReport | Gets the Z report number.

Remarks

Used by the dataItem parameter of the GetData method to specify what data should be returned. These values replace the FPTR_GD constants used in the UPOS 1.11 specification.

See Also

Reference

Microsoft.PointOfService Namespace
GetData
FiscalPrinter


FiscalDataItem Structure

FiscalDataItem Structure |
 | See Also Members

1/18/2008

Defines the programmatic structure used by the service object to return a fiscal data item from a Fiscal Printer device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Structure FiscalDataItem
public struct FiscalDataItem
public value class FiscalDataItem
public final class FiscalDataItem extends ValueType

Remarks

Used as the return value of GetData. The POS application calls GetData to request a specified fiscal data item for a fiscal printer. The service object returns this information in the form of a FiscalDataItem structure.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalDataItem Members
Microsoft.PointOfService Namespace
GetData


FiscalDataItem Members

FiscalDataItem Members |
 | See Also Constructors Methods Properties

1/18/2008

Defines the programmatic structure used by the service object to return a fiscal data item from a Fiscal Printer device.

The following tables list the members exposed by the FiscalDataItem type.

Public Constructors

Name | Description
FiscalDataItem | Creates an instance of the FiscalDataItem structure from parameters specifying the instance's constituent parts.
Top

Public Properties

Name | Description
Data | Gets a character string that contains the returned data requested from GetData.
ItemOption | Gets optional integer data retrieved for some FiscalData values.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded.
GetHashCode | Overridden.
GetType | (inherited from Object )
op_Equality | Compares the specified FiscalDataItem and object to determine whether they are the same.
op_Inequality | Compares the specified FiscalDataItem and object to determine whether they are different.
ReferenceEquals | (inherited from Object )
ToString | (inherited from ValueType )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

FiscalDataItem Structure
Microsoft.PointOfService Namespace
GetData


FiscalDataItem Constructor

FiscalDataItem Constructor |
 | See Also

1/18/2008

Creates an instance of the FiscalDataItem structure from parameters specifying the instance's constituent parts.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    data As String, _
    itemOption As Integer _
)
public FiscalDataItem (
    string data,
    int itemOption
)
public:
FiscalDataItem (
    String^ data,
    int itemOption
)
public FiscalDataItem (
    String data,
    int itemOption
)
public function FiscalDataItem (
    data : String,
    itemOption : int
)

Parameters

data

A character string that contains the returned data requested from GetData.

itemOption

Optional integer data retrieved for some FiscalData values.

See Also

Reference

FiscalDataItem Structure
FiscalDataItem Members
Microsoft.PointOfService Namespace
FiscalData Enumeration
GetData


FiscalDataItem Methods

FiscalDataItem Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded.
GetHashCode | Overridden.
GetType | (inherited from Object )
op_Equality | Compares the specified FiscalDataItem and object to determine whether they are the same.
op_Inequality | Compares the specified FiscalDataItem and object to determine whether they are different.
ReferenceEquals | (inherited from Object )
ToString | (inherited from ValueType )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

FiscalDataItem Structure
Microsoft.PointOfService Namespace
GetData


FiscalDataItem.Equals Method

FiscalDataItem.Equals Method |
 | See Also

1/18/2008

Overload List

Name | Description
FiscalDataItem.Equals (FiscalDataItem) |
FiscalDataItem.Equals (Object) |
FiscalDataItem.Equals (FiscalDataItem, FiscalDataItem) |
FiscalDataItem.Equals (Object, Object) | (inherited from Equals )

See Also

Reference

FiscalDataItem Structure
FiscalDataItem Members
Microsoft.PointOfService Namespace


FiscalDataItem.Equals Method (FiscalDataItem)

FiscalDataItem.Equals Method (FiscalDataItem) |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Function Equals ( _
    fiscalDataItem As FiscalDataItem _
) As Boolean

public bool Equals (
    FiscalDataItem fiscalDataItem
)

public:
bool Equals (
    FiscalDataItem fiscalDataItem
)

public boolean Equals (
    FiscalDataItem fiscalDataItem
)

public function Equals (
    fiscalDataItem : FiscalDataItem
) : boolean

Parameters

fiscalDataItem

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalDataItem Structure
FiscalDataItem Members
Microsoft.PointOfService Namespace


FiscalDataItem.Equals Method (Object)

FiscalDataItem.Equals Method (Object) |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

public override bool Equals (
    Object obj
)

public:
virtual bool Equals (
    Object^ obj
) override

public boolean Equals (
    Object obj
)

public override function Equals (
    obj : Object
) : boolean

Parameters

obj

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalDataItem Structure
FiscalDataItem Members
Microsoft.PointOfService Namespace


FiscalDataItem.Equals Method (FiscalDataItem, FiscalDataItem)

FiscalDataItem.Equals Method (FiscalDataItem, FiscalDataItem) |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Function Equals ( _
    a As FiscalDataItem, _
    b As FiscalDataItem _
) As Boolean

public static bool Equals (
    FiscalDataItem a,
    FiscalDataItem b
)

public:
static bool Equals (
    FiscalDataItem a,
    FiscalDataItem b
)

public static boolean Equals (
    FiscalDataItem a,
    FiscalDataItem b
)

public static function Equals (
    a : FiscalDataItem,
    b : FiscalDataItem
) : boolean

Parameters

a
b

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalDataItem Structure
FiscalDataItem Members
Microsoft.PointOfService Namespace


FiscalDataItem.GetHashCode Method

FiscalDataItem.GetHashCode Method |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function GetHashCode As Integer

public override int GetHashCode ()

public:
virtual int GetHashCode () override

public int GetHashCode ()

public override function GetHashCode () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalDataItem Structure
FiscalDataItem Members
Microsoft.PointOfService Namespace


FiscalDataItem.op_Equality Method

FiscalDataItem.op_Equality Method |
 | See Also

1/18/2008

Compares the specified FiscalDataItem and object to determine whether they are the same.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Operator = ( _
    a As FiscalDataItem, _
    b As Object _
) As Boolean
public static bool operator == (
    FiscalDataItem a,
    Object b
)
public:
static bool operator == (
    FiscalDataItem a,
    Object^ b
)

Parameters

a

The FiscalDataItem to be compared to b

b

The object to be compared to a.

Return Value

True if a is equal to b; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalDataItem Structure
FiscalDataItem Members
Microsoft.PointOfService Namespace


FiscalDataItem.op_Inequality Method

FiscalDataItem.op_Inequality Method |
 | See Also

1/18/2008

Compares the specified FiscalDataItem and object to determine whether they are different.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Operator <> ( _
    a As FiscalDataItem, _
    b As Object _
) As Boolean
public static bool operator != (
    FiscalDataItem a,
    Object b
)
public:
static bool operator != (
    FiscalDataItem a,
    Object^ b
)

Parameters

a

The FiscalDataItem to be compared to b

b

The object to be compared to a.

Return Value

True if a is not equal to b; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalDataItem Structure
FiscalDataItem Members
Microsoft.PointOfService Namespace


FiscalDataItem Properties

FiscalDataItem Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
Data | Gets a character string that contains the returned data requested from GetData.
ItemOption | Gets optional integer data retrieved for some FiscalData values.

See Also

Reference

FiscalDataItem Structure
Microsoft.PointOfService Namespace
GetData


FiscalDataItem.Data Property

FiscalDataItem.Data Property |
 | See Also

1/18/2008

Gets a character string that contains the returned data requested from GetData.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Data As String
public string Data { get; }
public:
property String^ Data {
    String^ get ();
}
/** @property */
public String get_Data ()

public function get Data () : String

Remarks

The form and content of this string depends on the type of data requested. Please refer to the members of FiscalData and the Service vendor's documentation for more information.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalDataItem Structure
FiscalDataItem Members
Microsoft.PointOfService Namespace


FiscalDataItem.ItemOption Property

FiscalDataItem.ItemOption Property |
 | See Also

1/18/2008

Gets optional integer data retrieved for some FiscalData values.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property ItemOption As Integer
public int ItemOption { get; }
public:
property int ItemOption {
    int get ();
}
/** @property */
public int get_ItemOption ()

public function get ItemOption () : int

Remarks

This parameter is device-dependent. Consult the Service vendor's documentation for an explanation of what may be returned here.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalDataItem Structure
FiscalDataItem Members
Microsoft.PointOfService Namespace


FiscalDateType Enumeration

FiscalDateType Enumeration |
 | See Also

1/18/2008

Enumerates the valid types of dates that can be supported by the fiscal printer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration FiscalDateType
public enum FiscalDateType
public enum class FiscalDateType
public enum FiscalDateType
public enum FiscalDateType

Members

Member name | Description
Configuration | Date of configuration.
EndOfDay | Date of last end of day.
RealTimeClock | Real time clock of the fiscal printer.
Reset | Date of last reset.
Start | Date of start.
VatChange | Date of last VAT change.

Remarks

Used by the DateType property. Members of this enumeration replaces the FPTR_DT_CONF, FPTR_DT_EOD, FPTR_DT_RESET, FPTR_DT_RTC, and FPTR_DT_VAT UPOS 1.11 constants.

See Also

Reference

Microsoft.PointOfService Namespace
DateType


FiscalErrorLevel Enumeration

FiscalErrorLevel Enumeration |
 | See Also

1/18/2008

Enumerates the valid severity levels for an error condition on a fiscal printer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration FiscalErrorLevel
public enum FiscalErrorLevel
public enum class FiscalErrorLevel
public enum FiscalErrorLevel
public enum FiscalErrorLevel

Members

Member name | Description
Blocked | A severe hardware failure (for example, a fiscal memory failure) that can be resolved only by authorized technicians has occurred. This error cannot be recovered.
Fatal | A nonrecoverable error (for example, an internal printer failure) has occurred.
None | No error condition is present.
Recoverable | A recoverable error (for example, out of paper) has occurred.

Remarks

Used by the ErrorLevel property. Members of this enumeration replace the FPTR_EL_NONE, FPTR_EL_RECOVERABLE, FPTR_EL_FATAL, and FPTR_EL_BLOCKED UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
ErrorLevel


FiscalMessageType Enumeration

FiscalMessageType Enumeration |
 | See Also

1/18/2008

Enumerates all possible fiscal message types.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration FiscalMessageType
public enum FiscalMessageType
public enum class FiscalMessageType
public enum FiscalMessageType
public enum FiscalMessageType

Members

Member name | Description
Advance | Advance.
AdvancePaid | Advance paid.
AmountToBePaid | Amount to be paid.
AmountToBePaidBack | Amount to be paid back.
Card | Card.
CardNumber | Card number.
CardType | Card type.
Cash | Cash.
Cashier | Cashier.
CashRegisterNumber | Cash register number.
Change | Change.
Cheque | Check.
ClientNumber | Client number.
ClientSignature | Client signature.
CounterState | Counter state.
CreditCard | Credit card.
Currency | Currency.
CurrencyValue | Currency value.
Deposit | Deposit.
DepositReturned | Deposit returned.
DotLine | Dot line.
DriverNumber | Driver number.
EmptyLine | Empty line.
FreeText | Free text
FreeTextWithDayLimit | Free text with day limit.
GivenDiscount | Given discount.
LocalCredit | Local credit.
MileageKilometers | Mileage (kilometers).
Note | Note.
Paid | Paid.
PayIn | Pay in.
PointGranted | Point granted.
PointsBonus | Points bonus.
PointsReceipt | Points receipt.
PointsTotal | Points total.
Profited | Profited.
Rate | Rate.
RegisterNumber | Register number.
ShiftNumber | Shift number.
StateOfAnAccount | State of an account.
Subscription | Subscription.
Table | Table.
ThankYouForLoyalty | Thank you for your loyalty.
TransactionNumber | Transaction number.
ValidTo | Valid to.
Voucher | Voucher.
VoucherPaid | Voucher paid.
VoucherValue | Voucher value.
WithDiscount | With discount.
WithoutUplift | Without uplift.

Remarks

Used by the MessageType property. Members of this enumeration replace the FPTR_MT_ family of UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
MessageType


FiscalPrinter Class

FiscalPrinter Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a UPOS fiscal printer device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class FiscalPrinter
    Inherits PosCommon
public abstract class FiscalPrinter : PosCommon
public ref class FiscalPrinter abstract : public PosCommon
public abstract class FiscalPrinter extends PosCommon
public abstract class FiscalPrinter extends PosCommon

Remarks

The Fiscal Printer service object does not try to encapsulate the generic Windows graphics printer. Instead, for performance and ease of use considerations, the interfaces are defined to directly control a printer.

Because fiscal rules differ from country to country and from region to region, this interface tries to generalize the common requirements at the maximum extent specifications. This interface is based on the fiscal requirements of the following countries/regions. However, it may fit the needs of other countries/regions also.

  • Brazil

  • Bulgaria

  • Europe (Euro)

  • Greece

  • Hungary

  • Italy

  • Poland

  • Romania

  • Russia

  • Turkey

The printer model defines three stations with the following general uses:

  • Journal, which logs transaction information, and must be kept by the store for audit.

  • Receipt that prints transaction information. You must give a printed fiscal receipt to the customer. Contains either a knife to delete the paper between transactions, or a tear bar to manually delete the paper.

  • Slip that prints information on a form, and is usually given to the customer.

    Slip is also used to print "validation" information on a form, typically a check or credit card slip.

Configuration and initialization of the fiscal memory of the printer are not covered in this SDK. These low-level operations must be performed by technical help personnel.

Device Sharing

The Fiscal Printer is an exclusive-use device, as follows:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before accessing many printer-specific properties.

  • The application must claim and enable the device before the application calls methods that manipulate the device.

General Requirements

Fiscal printers do not print text as standard printers do. They are used to monitor and memorize all fiscal information about a sale transaction. A fiscal printer has to accumulate totals, discounts, number of canceled receipts, taxes, and more. It is insufficient to send unformatted strings of text to the printer: each field must be kept separate in a receipt line item, therefore differentiating between descriptions, prices, and discounts. Moreover, different print commands must be defined for each different sale function, such as refund, item, or void.

Fiscal rules differ among countries or regions. This interface tries to generalize these requirements by summarizing the common requirements. Fiscal law requires that:

  • Fiscal receipts must be printed and given to the customer.

  • Fiscal printers must be equipped with memory to store daily totals. Each receipt line item must increment totals registers and, in most countries/regions (Greece, Poland, Brazil, Hungary, and Turkey) tax registers also.

  • Discounts, canceled items, and canceled receipts must increment their associated registers on the printer.

  • Fiscal printers must include a clock to store date and time information for each receipt.

  • Each fiscal receipt line item is printed both on the receipt and on the journal. (Italy, Greece, Poland)

  • After a power failure or a turn-off, the fiscal printer must be in the same state as it was before this event occurred. This implies that care must be taken in managing the fiscal printer status and that power failure events must be managed by the application. In some countries/regions, a power failure must be logged and a report must be printed.

Printer Modes

According to fiscal rules, it is possible for a fiscal printer to also offer functionality beyond the required fiscal printing mode. These additional modes are optional and may be present on any particular fiscal printer.

There are three possible printer modes:

  • Fiscal. The only required mode for a fiscal printer. In this mode, the application has access to all the methods needed to manage a sale transaction and to print a fiscal receipt. It is assumed that any lines printed to the receipt station while in fiscal mode are also printed on the journal station.

  • Training. Used for training purposes, such as cashier training. In this mode, the printer accepts fiscal commands but indicates on each receipt or document that the transaction is not an actual fiscal transaction. The printer does not update any of its internal fiscal registers while in training mode. Printed receipts are usually marked as "training" receipts by fiscal printers while in this mode.The CapTrainingMode property is set to true if the printer supports training mode; otherwise it is false.

  • Nonfiscal. Can be used to print simple text on the receipt station (echoed on the journal station) or the slip station. Additional lines are usually printed together with the application-requested output to indicate that this output is not of a fiscal nature. Such printed receipts are usually marked as "nonfiscal" receipts by fiscal printers. The CapNonFiscalMode property is set to true if the printer supports nonfiscal printing; otherwise it is false.

Model

The fiscal printer follows the general output model, with some improvements:

Most methods are always performed synchronously. Synchronous methods fail if asynchronous output is outstanding.

The following methods are performed either synchronously or asynchronously, depending on the value of the AsyncMode property:

  • PrintFiscalDocumentLine

  • PrintFixedOutput

  • PrintNormal

  • PrintRecItem

  • PrintRecItemAdjustment

  • PrintRecItemAdjustmentVoid

  • PrintRecMessage

  • PrintRecNotPaid

  • PrintRecRefund

  • PrintRecSubtotal

  • PrintRecSubtotalAdjustment

  • PrintRecTotal

  • PrintRecVoid

    When AsyncMode is false, these methods print synchronously and return their completion status to the application.

    When AsyncMode is true, these methods operate as follows:

    • The service object buffers the request, sets the OutputId property to an identifier for this request, and returns as soon as possible. When the device completes the request successfully, the service object raises an OutputCompleteEvent. A parameter of this event contains the OutputId of the completed request.

Asynchronous printer methods do not return an error status because of a printing problem, such as out of paper or printer fault. These errors are only reported by an ErrorEvent event. An error status is returned only if the printer is not claimed and enabled, a parameter is invalid, or the request cannot be queued. The first two error cases occur because of an application error, while the last is a serious system resource exception.

  • If an error occurs while performing an asynchronous request, an ErrorEvent is queued and delivered. The ErrorStation property is set to the station or stations that were printing when the error occurred. The ErrorLevel, ErrorString and ErrorState and ErrorOutId properties are also set.

  • The event handler can call synchronous print methods, but not asynchronous methods. Either retry the outstanding output or clear it.

  • The service object guarantees that asynchronous output is performed on a first-in first-out basis.

  • All output buffered by OPOS can be deleted by calling the ClearOutput method. An OutputCompleteEvent is not raised for cleared output. ClearOutput also stops any output that may be in progress, when it is possible.

  • The FlagWhenIdle property can be set to cause the service object to raise a StatusUpdateEvent event when all outstanding outputs have finished, whether successfully or because they were cleared.

SET ErrorModel "ErrorModel" \* MERGEFORMAT ErrorModelThe fiscal printer error reporting model is as follows:

  • Most of the fiscal printer error conditions are reported by setting the ErrorCode to Extended and then setting ErrorCodeExtended to one of the following error conditions.

Value | Description
ExtendedErrorCoverOpen | The printer cover is open.
ExtendedErrorJournalEmpty | The journal station is out of paper.
ExtendedErrorReceiptEmpty | The receipt station is out of paper.
ExtendedErrorSlipEmpty | The slip station is out of paper.
ExtendedErrorMissingDevices | A device required by local fiscal legislation is not connected. In some countries/regions, a set of peripheral devices (such as cash drawer and customer display) must be connected to the POS to use a fiscal printer. If any of these devices is not present, sales are not allowed.
ExtendedErrorWrongState | The requested method could not be executed in the printer’s current state.
ExtendedErrorTechnicalAssistance | The printer has encountered a severe error condition. Calling for printer technical help is required.
ExtendedErrorClockError | The printer’s internal clock has failed.
ExtendedErrorMemoryFull | The printer’s fiscal memory has been exhausted.
ExtendedErrorMemoryDisconnected | The printer’s fiscal memory has been disconnected.
ExtendedErrorTotalsError | The Grand Total in available memory does not match the one in the EPROM.
ExtendedErrorBadItemQuantity | The quantity parameter is invalid.
ExtendedErrorBadItemAmount | The amount parameter is invalid.
ExtendedErrorBadItemDescription | The description parameter is too long, contains illegal characters, or contains a reserved word.
ExtendedErrorBadLength | The length of the string to be printed after or before the line is too long.
ExtendedErrorReceiptTotalOverflow | The receipt total has overflowed.
ExtendedErrorBadVat | The VAT parameter is invalid.
ExtendedErrorBadPrice | The price parameter is invalid.
ExtendedErrorBadDate | The date parameter is invalid.
ExtendedErrorNegativeTotal | The printer’s computed total or subtotal is less than zero.
ExtendedErrorWordNotAllowed | The description contains a reserved word.

  • Other printer errors are reported by setting the ErrorCode to Failure or another standard error status. These failures are typically because of a printer fault or jam, or to a more serious error.

SET PrinterStates \* MERGEFORMAT Printer StatesSET PrinterStates "here" \* MERGEFORMAT hereSET PrinterStates \* MERGEFORMAT

As previously described, a fiscal printer is characterized by different printing modes. The set of commands that can be executed at a particular moment depends on the current state of the printer.

The current state of the fiscal printer is kept in the PrinterState property.

The fiscal printer has the following states:

  • Monitor

    This is a neutral state. From this state, you can move to most of the other printer states. After a successful call to the ClaimDevice method and successfully setting the DeviceEnabled property to true, the printer should be in Monitor state unless there is a printer error.

  • FiscalReceipt

    The printer is processing a fiscal receipt. All PrintRec methods are available for use while in this state. The FiscalReceipt state is entered from the Monitor state by using the BeginFiscalReceipt method.

  • FiscalReceiptTotal

    The printer has already accepted at least one payment method, but the receipt’s total amount has not yet been tendered. This state is entered from the FiscalReceipt state by use of the PrintRecTotal method. The printer remains in this state while the total remains unpaid. The FiscalReceiptTotal state is exited by using the PrintRecTotal, PrintRecNotPaid or PrintRecVoid methods.

  • FiscalReceiptEnding

    The printer has completed the receipt up to the Total line. In this state you may be able to print general messages by using the PrintRecMessage method if it is supported by the printer. This state is entered from the FiscalReceipt state through the PrintRecVoid method or from the FiscalReceiptTotal state by using the PrintRecTotal, PrintRecNotPaid or PrintRecVoid methods. The FiscalReceiptEnding state is exited by using the EndFiscalReceipt method, at which time that the printer returns to the Monitor state.

  • FiscalDocument

    The printer is processing a fiscal document. The printer accepts the PrintFiscalDocumentLine method while in this state. This state is entered from the Monitor state by using the BeginFiscalDocument method. The FiscalDocument state is exited by using the EndFiscalDocument method, at which time that the printer returns to the Monitor state.

  • Monitor and TrainingModeActive = true

    The printer is being used for training purposes. All fiscal receipt and document commands are available. This state is entered from the Monitor state by using the BeginTraining method. This state is exited by using the EndTraining method, at which time that the printer returns to the Monitor state.

  • FiscalReceipt and TrainingModeActive = true

    The printer is being used for training purposes and a receipt is opened. Special text is added to each line of the receipt to differentiate it from a fiscal receipt.

  • FiscalTotal and TrainingModeActive = true

    The printer is in training mode and receipt total is being handled.

  • FiscalReceiptEnding and TrainingModeActive = true

    The printer is being used for training and is in the receipt-ending phase.

  • NonFiscal

    The printer is printing nonfiscal output on either the receipt (echoed on the journal) or the slip. In this state the printer accepts the PrintNormal method. The printer prints a message that has all application text to indicate that this is nonfiscal output. This state is entered from the Monitor state by using the BeginNonFiscal method. This state is exited by using the EndNonFiscal method, at which time the printer returns to the Monitor state.

  • Fixed

    The printer is being used to print fixed, nonfiscal output to one of the printer’s stations. In this state, the printer accepts the PrintFixedOutput method. This state is entered from the Monitor state by using the BeginFixedOutput method. The Fixed state is exited by using the EndFixedOutput method, at which time that the printer returns to the Monitor state.

  • ItemList

    The printer is printing a line item report. In this state the printer accepts the VerifyItem method. This state is entered from the Monitor state by using the BeginItemList method. The ItemList state is exited by using the EndItemList method, at which time that the printer returns to the Monitor state.

  • Report

    The printer is printing one of the supported types of reports. This state is entered from the Monitor state by using one of the PrintReport, PrintPeriodicTotalsReport, PrintPowerLossReport, PrintXReport or PrintZReport methods. When the report print is complete, the printer automatically returns to Monitor state.

  • Locked

    The printer is no longer operational because of one of the following reasons:

    • The printer has been disconnected or has lost power.

    • The printer’s fiscal memory has been exhausted.

    • The printer’s internal data has become inconsistent.

    In the Locked state, the printer accepts only methods that print reports and retrieve data. The printer cannot exit this state without the assistance of an authorized technician.

When the application sets the property DeviceEnabled to true, it also monitors its state. In a standard situation, the PrinterState property is set to Monitor after successfully setting DeviceEnabled to true. This indicates there was no interrupted operation remaining in the printer.

If the printer is not in the Monitor state, the state reflects the printer's interrupted operation and the PowerState property is set to Off. This means that a power failure occurred or the last application to access the device left it in an uncleared state. In this situation, the ResetPrinter method must be called to force the printer to a normal state.

Notice that even in this case, the DeviceErrorEventArgs.ErrorCode property is set to Success after you set DeviceEnabled to true. It is required that the application check the PowerState property and check for a received StatusUpdateEvent with the value Off in the data argument after successfully setting the DeviceEnabled property.

Document Printing

By using a fiscal printer’s slip station, it may be possible, depending on the printer’s capabilities and on special fiscal rules, to print the following kinds of documents:

  • Fiscal Documents

    To print fiscal documents, an amount value must be sent to and recorded by the printer. The CapSlpFiscalDocument property is set to true if the printer supports printing fiscal documents, and false otherwise. If fiscal documents are supported, they may be either full length (if CapSlpFullSlip is true) or validation (if CapSlpValidation is true). The actual selection is made by using the SlipSelection property but only one totalizer is assigned to all the fiscal documents.

  • Nonfiscal Full Length Documents

    Full length slip documents can be printed if CapSlpFullSlip is true and SlipSelection is set to FullLength.

  • Nonfiscal Validation Documents

    Validation documents can be printed if CapSlpValidation is true and SlipSelection is set to Validation.

  • Fixed Text Documents

    Fixed text documents can be printed if CapFixedOutput is true. If fixed text documents are supported, they may be either full length (if CapSlpFullSlip is true) or validation (if CapSlpValidation is true). The actual selection is made by using the SlipSelection property.

Ordering of Fiscal Receipt Print Requests

A fiscal receipt is started by using the BeginFiscalReceipt method. If the CapIndependentHeader property is true, the application must determine whether the fiscal receipt header lines are to be printed currently. Otherwise, header lines are printed immediately before the first line item inside a fiscal receipt. Printing the header lines currently reduces the time that is required to process the first fiscal receipt print method. However, it may result in more receipt voids also. The BeginFiscalReceipt method can be called only when the printer is in the Monitor state and will change the printer’s state to FiscalReceipt.

Before selling the first line item you can exit from the fiscal receipt state by calling the EndFiscalReceipt method. If header lines have already been printed, EndFiscalReceipt also cause receipt voiding.

When the first line item has been printed and the printer is in the FiscalReceipt state, the following fiscal print methods are available:

  • PrintRecItem

  • PrintRecItemAdjustment

  • PrintRecNotPaid

  • PrintRecRefund

  • PrintRecSubtotal

  • PrintRecSubtotalAdjustment

  • PrintRecTotal

  • PrintRecVoid

  • PrintRecItemVoid

  • PrintRecItemAdjustmentVoid

The PrintRecItem, PrintRecItemAdjustment, PrintRecRefund, PrintRecSubtotal, PrintRecSubtotalAdjustment, PrintRecItemVoid and PrintRecItemAdjustmentVoid methods leave the printer in the FiscalReceipt state. The PrintRecNotPaid (available only when the CapReceiptNotPaid property is true) and PrintRecTotal methods change the printer’s state to either FiscalReceiptTotal or FiscalReceiptEnding, depending on whether the receipt total has been met. The PrintRecVoid method changes the printer’s state to FiscalReceiptEnding.

Whereas in the FiscalReceiptTotal state, the following fiscal print methods are available:

  • PrintRecNotPaid

  • PrintRecTotal

  • PrintRecVoid

The PrintRecNotPaid method, available only if the CapReceiptNotPaid property is true and the PrintRecTotal method either leave the printer in the FiscalReceiptTotal state or change the printer’s state to FiscalReceiptEnding, depending on whether the receipt total has been met. The PrintRecVoid method changes the printer’s state to FiscalReceiptEnding.

Whereas in the FiscalReceiptEnding state, the following fiscal methods are available:

  • PrintRecMessage

  • EndFiscalReceipt

The PrintRecMessage method, available only if the CapAdditionalLines property is true, leaves the printer in the FiscalReceiptEnding state. The EndFiscalReceipt method causes receipt closing and then changes the printer’s state to Monitor.

Be aware that at no time can the printer’s total for the receipt be negative. If this occurs, the printer generates an error.

Receipt Layouts

The following is an example of a typical receipt layout:

  • Header Lines

    All the information about the store, such as telephone number, address, and name of the store. All these lines are fixed and are defined before selling the first item by using the SetHeaderLine method. These lines can be printed either when the BeginFiscalReceipt method is called or when the first fiscal receipt method is called.

  • Transaction Lines

    All the lines of a fiscal transaction, such as line items, discounts, and surcharges.

  • Total Line

    The line that contains the transaction total, tender amounts, and possibly change due.

  • Trailer Lines

    Fixed promotional messages stored on the printer by using the SetTrailerLine method. Trailer lines are automatically printed when the EndFiscalReceipt method is called. Notice that the fiscal logotype, date and time, and serial number lines are not considered part of the trailer lines. In fact, depending on fiscal legislation and on the printer vendor, the positions of the trailer and the fiscal logotype lines can vary. Information that must be inserted in the receipt because of fiscal legislation is automatically printed at receipt closure.

VAT Tables

Some fiscal printers support storing VAT (value-added tax) tables in the printer’s memory. Some of these printers allow the application to set and modify table entries. Other applications allow addition of new table entries but not modification of existing entries. Some printers allow the VAT table to be set only one time.

If the printer supports VAT tables, the CapHasVatTable property is set to true. If the printer allows the VAT table entries to be set or modified, the CapSetVatTable property is set to true. The maximum number of VAT rate entries in the VAT table is specified by the NumVatRates property. VAT tables are set through a 2-step process. First, the application uses the SetVatValue method to set each table entry. Next, the SetVatTable method is called to send the VAT table to the printer.

Receipt Duplication

In some countries/regions, fiscal legislation allows printing more than one copy of a receipt. The CapDuplicateReceipt property is set to true if the printer can print duplicate receipts. Setting the DuplicateReceipt property to true causes the buffering of all receipt printing commands. DuplicateReceipt property is set to false after receipt closing. To print the receipt again, call the PrintDuplicateReceipt method.

CURRENCY amounts, percentage amounts, VAT rates, and quantity amounts

  • CURRENCY amounts and prices are passed as values with the data type CURRENCY. On a Win32-based platform this is a 64-bit signed long value that implicitly assumes four digits as the fractional part. So, the range supported is from

    -922,337,203,685,477.5808

    to

    +922,337,203,685,477.5807

    The fractional part used in the calculation unit of a fiscal printer may differ from the CURRENCY data type. The number of digits in the fractional part is stored in the AmountDecimalPlaces property and determined by the fiscal printer. The application has to make sure that calculations in the application use the same fractional part for amounts.

  • If the CapHasVatTable property is true, VAT rates are passed by using the indexes that were sent to the SetVatValue method. If the CapHasVatTable property is false, VAT rates are passed as amounts with the data type LONG. The number of digits in the fractional part is implicitly assumed to be four.

  • Percentage amounts are used in methods that also allow surcharge and discount amounts or discount amounts. If the amounts are specified to be a percentage value, the value is also passed in a parameter of type CURRENCY. On a Win32-based platform, the percentage value has then (as given by the CURRENCY data type) four digits in the fractional part. It is the percentage (0.0001% to 99.9999% ) multiplied by 10000.

  • Quantity amounts are passed as values with the data type LONG. The number of digits in the fractional part is stored in the QuantityDecimalPlaces property and determined by the fiscal printer.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.FiscalPrinter
Microsoft.PointOfService.BasicServiceObjects.FiscalPrinterBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter Members

FiscalPrinter Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a UPOS fiscal printer device.

The following tables list the members exposed by the FiscalPrinter type.

Protected Constructors

Name | Description
FiscalPrinter | Creates an instance of FiscalPrinter class.
Top

Public Fields

Name | Description
CurrencyEuro | Indicates that the fiscal currency is the euro.
DescriptionLengthItem | Indicates the PrintRecItem method for itemOption in the GetData method.
DescriptionLengthItemAdjustment | Indicates the PrintRecItemAdjustment method for itemOption in the GetData method.
DescriptionLengthItemFuel | Indicates the PrintRecItemFuel method for itemOption in the GetData method.
DescriptionLengthItemFuelVoid | Indicates the PrintRecItemFuelVoid method for itemOption in the GetData method.
DescriptionLengthNotPaid | Indicates the PrintRecNotPaid method for itemOption in the GetData method.
DescriptionLengthPackageAdjustment | Indicates the PrintRecPackageAdjustment method for itemOption in the GetData method.
DescriptionLengthRefund | Indicates the PrintRecRefund method for itemOption in the GetData method.
DescriptionLengthRefundVoid | Indicates the PrintRecRefundVoid method for itemOption in the GetData method.
DescriptionLengthSubtotalAdjustment | Indicates the PrintRecSubtotalAdjustment method for itemOption in the GetData method.
DescriptionLengthTotal | Indicates the PrintRecTotal method for itemOption in the GetData method.
DescriptionLengthVoid | Indicates the PrintRecVoid method for itemOption in the GetData method.
DescriptionLengthVoidItem | Indicates the PrintRecItemVoid and PrintRecItemAdjustmentVoid method for itemOption in the GetData method.
ExtendedErrorBadDate | Indicates one of the date parameters is invalid.
ExtendedErrorBadItemAmount | Indicates the amount parameter is invalid.
ExtendedErrorBadItemDescription | Indicates the description parameter is either too long, contains illegal characters, or contains a reserved word.
ExtendedErrorBadItemQuantity | Indicates the quantity parameter is invalid.
ExtendedErrorBadLength | Indicates the length of the string to print is too long.
ExtendedErrorBadPrice | Indicates the price parameter is invalid.
ExtendedErrorBadVat | Indicates the VAT parameter is invalid.
ExtendedErrorClockError | Indicates the fiscal printer's internal clock has failed.
ExtendedErrorCoverOpen | Indicates the fiscal printer cover is open.
ExtendedErrorDayEndRequired | Calls the PrintZReport method to print the report. The fiscal day must be completed before calling this function.
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorJournalEmpty | Indicates the journal station has run out of paper.
ExtendedErrorMemoryDisconnected | Indicates the fiscal printer's memory has been disconnected.
ExtendedErrorMemoryFull | Indicates the fiscal printer’s fiscal memory has been exhausted.
ExtendedErrorMissingDevices | Indicates that some of the other devices (according to the local fiscal legislation) that should be connected are missing.
ExtendedErrorMissingSetCurrency | Indicates the fiscal printer is expecting the activation of a new currency.
ExtendedErrorNegativeTotal | Indicates the fiscal printer’s computed total or subtotal is less than zero.
ExtendedErrorReceiptEmpty | Indicates the receipt station has run out of paper.
ExtendedErrorReceiptTotalOverflow | Indicates the receipt total has overflowed.
ExtendedErrorSlipEmpty | Indicates the slip station has run out of paper.
ExtendedErrorSlipForm | Indicates a slip form is present.
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
ExtendedErrorTechnicalAssistance | Indicates the fiscal printer has encountered a severe error condition. Calling for fiscal printer technical help is required.
ExtendedErrorTotalsError | Indicates the Grand Total in working memory does not match the one in the EPROM.
ExtendedErrorWordNotAllowed | Indicates the description contains a reserved word.
ExtendedErrorWrongState | Indicates the requested method cannot be executed in the fiscal printer’s current state.
LineCountComment | Indicates the number of comment lines.
LineCountDiscount | Indicates the number of discount lines.
LineCountDiscountVoid | Indicates the number of voided refund lines.
LineCountItem | Indicates the number of item lines.
LineCountItemVoid | Indicates the number of voided item lines.
LineCountRefund | Indicates the number of refund lines.
LineCountRefundVoid | Indicates the number of voided refund lines.
LineCountSubtotal | Indicates the number of subtotal lines.
LineCountSubtotalDiscount | Indicates the number of subtotal discount lines.
LineCountSubtotalDiscountVoid | Indicates the number of voided subtotal discount lines.
LineCountSubtotalSurcharge | Indicates the number of subtotal surcharge lines.
LineCountSubtotalSurchargeVoid | Indicates the number of voided subtotal surcharge lines.
LineCountSurcharge | Indicates the number of surcharge lines.
LineCountSurchargeVoid | Indicates the number of voided surcharge lines.
LineCountTotal | Indicates the number of total lines.
PaymentDescriptionCash | Indicates cash.
PaymentDescriptionCheque | Indicates cheque.
PaymentDescriptionChitty | Indicates chitty.
PaymentDescriptionCoupon | Indicates coupon.
PaymentDescriptionCurrency | Indicates currency.
PaymentDescriptionDrivenOff | Indicates that the description has been driven off.
PaymentDescriptionEftImprinter | Indicates printer EFT.
PaymentDescriptionEftTerminal | Indicates terminal EFT.
PaymentDescriptionFreeGift | Indicates gift.
PaymentDescriptionGiro | Indicates giro.
PaymentDescriptionHome | Indicates home.
PaymentDescriptionImprinterWithIssuer | Indicates imprinter with issuer.
PaymentDescriptionLocalAccount | Indicates local account.
PaymentDescriptionLocalAccountCard | Indicates local card account.
PaymentDescriptionPayCard | Indicates pay card.
PaymentDescriptionPayCardManual | Indicates manual pay card.
PaymentDescriptionPrepay | Indicates prepay.
PaymentDescriptionPumpTest | Indicates pump test.
PaymentDescriptionShortCredit | Indicates credit.
PaymentDescriptionStaff | Indicates staff.
PaymentDescriptionTerminalImprinter | Indicates a terminal imprinter.
PaymentDescriptionVoucher | Indicates a voucher.
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusCoverOK | Indicates the cover is closed.
StatusCoverOpen | Indicates the cover is open.
StatusIdle | Indicates all asynchronous output has finished, either successfully or because output has been cleared.
StatusJournalCoverOK | Indicates the journal station cover is closed.
StatusJournalCoverOpen | Indicates the receipt station cover is open.
StatusJournalEmpty | Indicates no journal paper.
StatusJournalNearEmpty | Indicates journal paper is low.
StatusJournalPaperOK | Indicates journal paper is ready.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusReceiptCoverOK | Indicates receipt station cover is closed.
StatusReceiptCoverOpen | Indicates receipt station cover is open.
StatusReceiptEmpty | Indicates no receipt paper.
StatusReceiptNearEmpty | Indicates receipt paper is low.
StatusReceiptPaperOK | Indicates receipt paper is ready.
StatusSlipCoverOK | Indicates slip station cover is closed.
StatusSlipCoverOpen | Indicates slip station cover is open.
StatusSlipEmpty | Indicates no slip form is inserted, and no slip form has been detected at the entrance to the slip station.
StatusSlipNearEmpty | Indicates almost at the bottom of the slip form.
StatusSlipPaperOK | Indicates a slip form is inserted.
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
ActualCurrency | Gets a value identifying which actual currency is used by the fiscal printer.
AdditionalHeader | Gets or sets user-specific text to be printed on the receipt after the fixed header lines when calling the BeginFiscalReceipt method.
AdditionalTrailer | Get or sets user-specific text to be printed on the receipt after the fiscal trailer lines when calling the EndFiscalReceipt method.
AmountDecimalPlaces | Gets the number of decimal places that the fiscal printer uses for calculations.
AsyncMode | Gets or sets a Boolean value that indicates whether certain print methods are performed asynchronously.
CapAdditionalHeader | Gets a Boolean value that indicates whether the printer can print application-specific text after the fixed header lines.
CapAdditionalLines | Gets a Boolean value that indicates whether the printer can print application-defined lines.
CapAdditionalTrailer | Gets a Boolean value that indicates whether the printer can print application-specific text after the fiscal trailer lines.
CapAmountAdjustment | Gets a Boolean value that indicates whether the printer handles discounts or surcharges.
CapChangeDue | Gets a Boolean value that indicates whether text can be defined in the ChangeDue property.
CapCheckTotal | Gets a Boolean value that indicates whether automatic total comparison can be enabled.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapCoverSensor | Gets a Boolean value that indicates whether the printer has a "cover open" sensor.
CapDoubleWidth | Gets a Boolean value that indicates whether the printer can print double-width characters.
CapDuplicateReceipt | Gets a Boolean value that indicates whether the printer allows printing of more than one fiscal receipt.
CapEmptyReceiptIsVoidable | Gets a Boolean value that indicates whether the printer can void an opened receipt.
CapFiscalReceiptStation | Gets a Boolean value that indicates whether the printer can print transactions on the station defined by FiscalReceiptStation.
CapFiscalReceiptType | Gets a Boolean value that indicates whether the printer can print receipts defined by FiscalReceiptType.
CapFixedOutput | Gets a Boolean value that indicates whether the printer supports fixed-format printing through certain methods.
CapHasVatTable | Gets a Boolean value that indicates whether the printer has a VAT table.
CapIndependentHeader | Gets a Boolean value that indicates whether the printer can print header lines before the first fiscal receipt command is processed.
CapItemList | Gets a Boolean value that indicates whether the printer can print a report of items of a specified VAT class.
CapJrnEmptySensor | Gets a Boolean value that indicates whether the printer has an out-of-paper sensor.
CapJrnNearEndSensor | Gets a Boolean value that indicates whether the printer has a low-paper sensor.
CapJrnPresent | Gets a Boolean value that indicates whether the journal print station is present.
CapMultiContractor | Gets a Boolean value that indicates whether the printer supports more than one contractor.
CapNonFiscalMode | Gets a Boolean value that indicates whether the printer can print in nonfiscal mode.
CapOnlyVoidLastItem | Gets a Boolean value that indicates whether only the last printed item can be voided.
CapOrderAdjustmentFirst | Gets a Boolean value that indicates the order of use of PrintRecItem and PrintRecItemAdjustment.
CapPackageAdjustment | Gets a Boolean value that indicates whether an adjustment can be given to a package of booked items.
CapPercentAdjustment | Gets a Boolean value that indicates whether the printer handles percentage discounts or surcharges.
CapPositiveAdjustment | Gets a Boolean property that indicates whether you can use the PrintRecItemAdjustment method to apply surcharges.
CapPositiveSubtotalAdjustment | Gets a Boolean value that indicates whether you can use the PrintRecSubtotalAdjustment method to apply surcharges.
CapPostPreLine | Gets a Boolean value that indicates whether the printer can support additional lines defined by the PostLine and PreLine properties.
CapPowerLossReport | Gets a Boolean value that indicates whether the printer can print a power-loss report by using the PrintPowerLossReport method.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapPredefinedPaymentLines | Gets a Boolean value that indicates whether the printer can print predefined payment descriptions.
CapReceiptNotPaid | Gets a Boolean value that indicates whether the printer supports the PrintRecNotPaid method.
CapRecEmptySensor | Gets a Boolean value that indicates whether the receipt print station has an out-of-paper sensor.
CapRecNearEndSensor | Gets a Boolean value that indicates whether the receipt print station has a low-paper sensor.
CapRecPresent | Gets a Boolean value that indicates whether the receipt print station is present.
CapRemainingFiscalMemory | Gets a Boolean value that indicates whether the printer supports the RemainingFiscalMemory property to show the Fiscal Memory remaining.
CapReservedWord | Gets a Boolean value that indicates whether the printer prints a reserved word before printing the total.
CapSetCurrency | Gets a Boolean value that indicates whether the fiscal printer can change the currency to a new one by calling the SetCurrency method.
CapSetHeader | Gets a Boolean value that indicates whether the SetHeaderLine method can be used to initialize the contents of a particular line of the receipt header.
CapSetPosId | Gets a Boolean value that indicates whether the SetPosId method can be used to initialize the values of PointOfServiceId and CashierId.
CapSetStoreFiscalId | Gets a Boolean value that indicates whether the SetStoreFiscalId method can be used to set up the Fiscal ID number.
CapSetTrailer | Gets a Boolean value that indicates whether the SetTrailerLine method can be used to initialize the contents of a particular line of the receipt trailer.
CapSetVatTable | Gets a Boolean value that indicates whether SetVatValue and SetVatTable can be used to modify the contents of the printer’s VAT table.
CapSlpEmptySensor | Gets a Boolean value that indicates whether the slip has a "slip in" sensor.
CapSlpFiscalDocument | Gets a Boolean value that indicates whether the printer enables fiscal printing to the slip station.
CapSlpFullSlip | Gets a Boolean value that indicates whether the printer supports printing full-length forms on the slip station.
CapSlpNearEndSensor | Gets a Boolean value that indicates whether the slip has a "slip near end" sensor.
CapSlpPresent | Gets a Boolean value that indicates whether the printer has a slip station.
CapSlpValidation | Gets a Boolean value that indicates whether the printer supports printing validation information on the slip station.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapSubAmountAdjustment | Gets a Boolean value that indicates whether the printer handles fixed-amount discounts on the subtotal.
CapSubPercentAdjustment | Gets a Boolean value that indicates whether the printer handles percentage discounts on the subtotal.
CapSubtotal | Gets a Boolean value that indicates whether the PrintRecSubtotal method can be used to print the subtotal.
CapTotalizerType | Gets a Boolean value that indicates whether the printer supports reading different types of totalizers by calling the GetTotalizer method.
CapTrainingMode | Gets a Boolean value that indicates whether the printer supports a training mode.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CapValidateJournal | Gets a Boolean value that indicates whether the PrintNormal method can be used to print a validation string on the journal station.
CapXReport | Gets a Boolean value that indicates whether the PrintXReport method can be used to print an X report.
ChangeDue | Gets or sets the text to print as a description for the cash return when using the PrintRecTotal method.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
CheckTotal | Gets or sets a Boolean value that indicates whether automatic comparison between the total of the fiscal printer and the total of the application is enabled.
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
ContractorId | Gets or sets the identification of the contractor to whom the receipt and some items of the receipt or to whom the receipt or some items of the receipt are assigned.
CountryCode | Gets a value identifying the countries/regions supported by this service object.
CoverOpen | Gets a Boolean value that indicates whether the printer's cover is open.
DateType | Gets or sets the type of date to be requested when calling the GetDate method.
DayOpened | Gets a Boolean value that indicates whether the fiscal day has been started.
DescriptionLength | Gets the maximum number of characters that can be passed as a description parameter.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
DuplicateReceipt | Gets or sets a Boolean value that indicates whether all the printing commands inside a fiscal receipt are buffered and can be printed again with the PrintDuplicateReceipt method.
ErrorLevel | Gets a value that indicates the severity of the error condition.
ErrorOutId | Gets the identifier of the output in the queue that raised an error event when you use asynchronous printing.
ErrorState | Gets the current state of the printer when raising an error event for an asynchronous output.
ErrorStation | Gets the station or stations that were printing when an error was detected.
ErrorString | Gets a vendor-supplied description of the current error.
FiscalReceiptStation | Gets or sets the station where the transaction of the fiscal receipt started with BeginFiscalReceipt method will be printed.
FiscalReceiptType | Gets or sets the type of the fiscal receipt.
FlagWhenIdle | Gets or sets a Boolean value that indicates whether the service object raises a StatusUpdateEvent event if it is in the Idle state.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
JrnEmpty | Gets a Boolean value that indicates whether the journal is out of paper.
JrnNearEnd | Gets a Boolean value that indicates whether journal paper is low.
MessageLength | Gets the maximum number of characters that can be passed as a message line in the PrintRecMessage method.
MessageType | Gets or sets the kind of message to be printed when you use the PrintRecMessage method.
NumHeaderLines | Gets the maximum number of header lines that can be printed for each fiscal receipt.
NumTrailerLines | Gets the maximum number of trailer lines that can be printed for each fiscal receipt.
NumVatRates | Gets the maximum number of VAT rates that can be entered into the printer’s VAT table.
OutputId | Gets the identifier of the most recently started asynchronous output.
PostLine | Gets or sets application-specific text to print on the fiscal receipt after a line item invoked by some PrintRec methods.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
PredefinedPaymentLines | Gets a string that indicates that only predefined payment lines are allowed.
PreLine | Gets or sets application-specific text to be printed on the fiscal receipt before a line item invoked by some PrintRec methods.
PrinterState | Gets the printer's current operational state.
QuantityDecimalPlaces | Gets the number of decimal digits in the fractional part that should be assumed to be in any quantity parameter that is passed to this service object.
QuantityLength | Gets the maximum number of digits that can be passed as a quantity parameter. This includes both the whole and fractional parts.
RecEmpty | Gets a Boolean value that indicates whether the receipt station is out of paper.
RecNearEnd | Gets a Boolean value that indicates whether the receipt station is low on paper.
RemainingFiscalMemory | Gets the remaining counter of Fiscal Memory.
ReservedWord | Gets the string that is automatically printed with the total when the PrintRecTotal method is called.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
SlipSelection | Gets or sets the kind of document to print on the slip station.
SlpEmpty | Gets a Boolean value that indicates whether a slip form is present.
SlpNearEnd | Gets a Boolean value that indicates whether a slip form is almost at its end.
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
TotalizerType | Gets or sets the type of totalizer to be requested when calling the GetTotalizer method.
TrainingModeActive | Gets a Boolean value that indicates whether the printer's operational state allows the training mode.
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether the Fiscal Printer is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
BeginFiscalDocument | Starts fiscal printing to the slip station.
BeginFiscalReceipt | Starts fiscal printing to the receipt station.
BeginFixedOutput | Starts nonfiscal fixed text printing on a printer station.
BeginInsertion | Starts slip processing.
BeginItemList | Starts a validation report of items that belong to a particular VAT class.
BeginNonFiscal | Starts nonfiscal operations on the printer.
BeginRemoval | Starts form-removal processing.
BeginTraining | Starts training operations.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearError | Clears all printer error conditions.
ClearOutput | Clears all buffered output data. This includes all asynchronous output.
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
EndFiscalDocument | Stops fiscal printing to the slip station.
EndFiscalReceipt | Stops fiscal printing to the receipt station.
EndFixedOutput | Stops nonfiscal fixed text printing on a printer station.
EndInsertion | Ends form insertion processing.
EndItemList | Closes a validation report of items that belong to a particular VAT class.
EndNonFiscal | Closes nonfiscal operations on one printer station.
EndRemoval | Ends form removal processing.
EndTraining | Stops training operations on either the receipt or slip station.
Equals | Overloaded. (inherited from Object )
GetData | Retrieves data and counters from the printer’s fiscal module.
GetDate | Gets the printer's date and time.
GetHashCode | (inherited from Object )
GetTotalizer | Gets the totalizer associated with the specified vat id and totalizer type.
GetType | (inherited from Object )
GetVatEntry | Gets the rate associated with a given VAT identifier.
Open | Opens a device for later input/output processing. (inherited from PosCommon)
PrintDuplicateReceipt | Prints a duplicate of a buffered transaction.
PrintFiscalDocumentLine | Prints a line of fiscal text to the slip station.
PrintFixedOutput | Prints a line of a fixed document to the print station specified in the BeginFixedOutput method.
PrintNormal | Prints data on the printer station.
PrintPeriodicTotalsReport | Prints a report of totals for a range of dates on the receipt.
PrintPowerLossReport | Prints on the receipt a report of a power failure that resulted in a loss of data that is stored in the CMOS of the printer.
PrintRecCash | Prints a cash-in or cash-out receipt amount on the station defined by the FiscalReceiptStation property.
PrintRecItem | Prints a receipt item for a sold item on the station specified by the FiscalReceiptStation property.
PrintRecItemAdjustment | Applies and prints a discount or a surcharge to the last receipt item sold.
PrintRecItemAdjustmentVoid | Takes a VAT rate identifier that corresponds to an entry in the VAT table.
PrintRecItemFuel | Prints a receipt fuel item on the station specified by the FiscalReceiptStation property.
PrintRecItemFuelVoid | Voids a fuel item on the station specified by the FiscalReceiptStation property.
PrintRecItemRefund | Processes one or more item refunds.
PrintRecItemRefundVoid | Processes a void of one or more item refunds.
PrintRecItemVoid | Cancels one or more items that has been added to the receipt and prints a void description on the station defined by the FiscalReceiptStation property.
PrintRecMessage | Prints a message on the fiscal receipt.
PrintRecNotPaid | Indicates a part of the receipt's total that is unpaid.
PrintRecPackageAdjustment | Called to give an adjustment for a package of some items booked before.
PrintRecPackageAdjustVoid | Specifies a list of adjustments to be voided.
PrintRecRefund | Processes a refund.
PrintRecRefundVoid | Processes a void of a refund.
PrintRecSubtotal | Checks and prints the current receipt subtotal.
PrintRecSubtotalAdjustment | Applies and prints a discount or surcharge to the current receipt subtotal.
PrintRecSubtotalAdjustVoid | Voids a preceding subtotal adjustment on the station defined by the FiscalReceiptStation property.
PrintRecTaxId | Prints the customer's tax identification on the station defined by the FiscalReceiptStation property.
PrintRecTotal | Checks and prints the current receipt total on the station defined by the FiscalReceiptStation property and tenders a payment.
PrintRecVoid | Cancels the current receipt.
PrintReport | Prints a report of the fiscal EPROM contents on the receipt that occurred between two end points.
PrintXReport | Prints a report of all the daily fiscal activities on the receipt.
PrintZReport | Prints a report of all the daily fiscal activities on the receipt.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetPrinter | Forces the printer to return to the Monitor state.
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
SetCurrency | Changes to a new currency (for example, euro).
SetDate | Sets the printer's date and time.
SetHeaderLine | Sets one of the fiscal receipt header lines.
SetPosId | Sets the POS and cashier identifiers.
SetStoreFiscalId | Sets the store fiscal ID.
SetTrailerLine | Sets one of the fiscal receipt trailer lines.
SetVatTable | Sends the VAT table built inside the service object to the printer.
SetVatValue | Sets the VAT ID and VAT value.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
VerifyItem | Compares itemName and its vatId with the values stored in the printer.
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
ErrorEvent | Notifies the application that a fiscal printer error has been detected and that a suitable response by the application is necessary to process the error condition.
OutputCompleteEvent | Notifies the application that the queued output request associated with the OutputId property has completed successfully.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

FiscalPrinter Class
Microsoft.PointOfService Namespace


FiscalPrinter Fields

FiscalPrinter Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
CurrencyEuro | Indicates that the fiscal currency is the euro.
DescriptionLengthItem | Indicates the PrintRecItem method for itemOption in the GetData method.
DescriptionLengthItemAdjustment | Indicates the PrintRecItemAdjustment method for itemOption in the GetData method.
DescriptionLengthItemFuel | Indicates the PrintRecItemFuel method for itemOption in the GetData method.
DescriptionLengthItemFuelVoid | Indicates the PrintRecItemFuelVoid method for itemOption in the GetData method.
DescriptionLengthNotPaid | Indicates the PrintRecNotPaid method for itemOption in the GetData method.
DescriptionLengthPackageAdjustment | Indicates the PrintRecPackageAdjustment method for itemOption in the GetData method.
DescriptionLengthRefund | Indicates the PrintRecRefund method for itemOption in the GetData method.
DescriptionLengthRefundVoid | Indicates the PrintRecRefundVoid method for itemOption in the GetData method.
DescriptionLengthSubtotalAdjustment | Indicates the PrintRecSubtotalAdjustment method for itemOption in the GetData method.
DescriptionLengthTotal | Indicates the PrintRecTotal method for itemOption in the GetData method.
DescriptionLengthVoid | Indicates the PrintRecVoid method for itemOption in the GetData method.
DescriptionLengthVoidItem | Indicates the PrintRecItemVoid and PrintRecItemAdjustmentVoid method for itemOption in the GetData method.
ExtendedErrorBadDate | Indicates one of the date parameters is invalid.
ExtendedErrorBadItemAmount | Indicates the amount parameter is invalid.
ExtendedErrorBadItemDescription | Indicates the description parameter is either too long, contains illegal characters, or contains a reserved word.
ExtendedErrorBadItemQuantity | Indicates the quantity parameter is invalid.
ExtendedErrorBadLength | Indicates the length of the string to print is too long.
ExtendedErrorBadPrice | Indicates the price parameter is invalid.
ExtendedErrorBadVat | Indicates the VAT parameter is invalid.
ExtendedErrorClockError | Indicates the fiscal printer's internal clock has failed.
ExtendedErrorCoverOpen | Indicates the fiscal printer cover is open.
ExtendedErrorDayEndRequired | Calls the PrintZReport method to print the report. The fiscal day must be completed before calling this function.
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorJournalEmpty | Indicates the journal station has run out of paper.
ExtendedErrorMemoryDisconnected | Indicates the fiscal printer's memory has been disconnected.
ExtendedErrorMemoryFull | Indicates the fiscal printer’s fiscal memory has been exhausted.
ExtendedErrorMissingDevices | Indicates that some of the other devices (according to the local fiscal legislation) that should be connected are missing.
ExtendedErrorMissingSetCurrency | Indicates the fiscal printer is expecting the activation of a new currency.
ExtendedErrorNegativeTotal | Indicates the fiscal printer’s computed total or subtotal is less than zero.
ExtendedErrorReceiptEmpty | Indicates the receipt station has run out of paper.
ExtendedErrorReceiptTotalOverflow | Indicates the receipt total has overflowed.
ExtendedErrorSlipEmpty | Indicates the slip station has run out of paper.
ExtendedErrorSlipForm | Indicates a slip form is present.
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
ExtendedErrorTechnicalAssistance | Indicates the fiscal printer has encountered a severe error condition. Calling for fiscal printer technical help is required.
ExtendedErrorTotalsError | Indicates the Grand Total in working memory does not match the one in the EPROM.
ExtendedErrorWordNotAllowed | Indicates the description contains a reserved word.
ExtendedErrorWrongState | Indicates the requested method cannot be executed in the fiscal printer’s current state.
LineCountComment | Indicates the number of comment lines.
LineCountDiscount | Indicates the number of discount lines.
LineCountDiscountVoid | Indicates the number of voided refund lines.
LineCountItem | Indicates the number of item lines.
LineCountItemVoid | Indicates the number of voided item lines.
LineCountRefund | Indicates the number of refund lines.
LineCountRefundVoid | Indicates the number of voided refund lines.
LineCountSubtotal | Indicates the number of subtotal lines.
LineCountSubtotalDiscount | Indicates the number of subtotal discount lines.
LineCountSubtotalDiscountVoid | Indicates the number of voided subtotal discount lines.
LineCountSubtotalSurcharge | Indicates the number of subtotal surcharge lines.
LineCountSubtotalSurchargeVoid | Indicates the number of voided subtotal surcharge lines.
LineCountSurcharge | Indicates the number of surcharge lines.
LineCountSurchargeVoid | Indicates the number of voided surcharge lines.
LineCountTotal | Indicates the number of total lines.
PaymentDescriptionCash | Indicates cash.
PaymentDescriptionCheque | Indicates cheque.
PaymentDescriptionChitty | Indicates chitty.
PaymentDescriptionCoupon | Indicates coupon.
PaymentDescriptionCurrency | Indicates currency.
PaymentDescriptionDrivenOff | Indicates that the description has been driven off.
PaymentDescriptionEftImprinter | Indicates printer EFT.
PaymentDescriptionEftTerminal | Indicates terminal EFT.
PaymentDescriptionFreeGift | Indicates gift.
PaymentDescriptionGiro | Indicates giro.
PaymentDescriptionHome | Indicates home.
PaymentDescriptionImprinterWithIssuer | Indicates imprinter with issuer.
PaymentDescriptionLocalAccount | Indicates local account.
PaymentDescriptionLocalAccountCard | Indicates local card account.
PaymentDescriptionPayCard | Indicates pay card.
PaymentDescriptionPayCardManual | Indicates manual pay card.
PaymentDescriptionPrepay | Indicates prepay.
PaymentDescriptionPumpTest | Indicates pump test.
PaymentDescriptionShortCredit | Indicates credit.
PaymentDescriptionStaff | Indicates staff.
PaymentDescriptionTerminalImprinter | Indicates a terminal imprinter.
PaymentDescriptionVoucher | Indicates a voucher.
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusCoverOK | Indicates the cover is closed.
StatusCoverOpen | Indicates the cover is open.
StatusIdle | Indicates all asynchronous output has finished, either successfully or because output has been cleared.
StatusJournalCoverOK | Indicates the journal station cover is closed.
StatusJournalCoverOpen | Indicates the receipt station cover is open.
StatusJournalEmpty | Indicates no journal paper.
StatusJournalNearEmpty | Indicates journal paper is low.
StatusJournalPaperOK | Indicates journal paper is ready.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusReceiptCoverOK | Indicates receipt station cover is closed.
StatusReceiptCoverOpen | Indicates receipt station cover is open.
StatusReceiptEmpty | Indicates no receipt paper.
StatusReceiptNearEmpty | Indicates receipt paper is low.
StatusReceiptPaperOK | Indicates receipt paper is ready.
StatusSlipCoverOK | Indicates slip station cover is closed.
StatusSlipCoverOpen | Indicates slip station cover is open.
StatusSlipEmpty | Indicates no slip form is inserted, and no slip form has been detected at the entrance to the slip station.
StatusSlipNearEmpty | Indicates almost at the bottom of the slip form.
StatusSlipPaperOK | Indicates a slip form is inserted.
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

FiscalPrinter Class
Microsoft.PointOfService Namespace


FiscalPrinter.CurrencyEuro Field

FiscalPrinter.CurrencyEuro Field |
 | See Also

1/18/2008

Indicates that the fiscal currency is the euro.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const CurrencyEuro As Integer
public const int CurrencyEuro
public:
literal int CurrencyEuro
public static final int CurrencyEuro
public const var CurrencyEuro : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.DescriptionLengthItem Field

FiscalPrinter.DescriptionLengthItem Field |
 | See Also

1/18/2008

Indicates the PrintRecItem method for itemOption in the GetData method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const DescriptionLengthItem As Integer
public const int DescriptionLengthItem
public:
literal int DescriptionLengthItem
public static final int DescriptionLengthItem
public const var DescriptionLengthItem : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData


FiscalPrinter.DescriptionLengthItemAdjustment Field

FiscalPrinter.DescriptionLengthItemAdjustment Field |
 | See Also

1/18/2008

Indicates the PrintRecItemAdjustment method for itemOption in the GetData method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const DescriptionLengthItemAdjustment As Integer
public const int DescriptionLengthItemAdjustment
public:
literal int DescriptionLengthItemAdjustment
public static final int DescriptionLengthItemAdjustment
public const var DescriptionLengthItemAdjustment : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData


FiscalPrinter.DescriptionLengthItemFuel Field

FiscalPrinter.DescriptionLengthItemFuel Field |
 | See Also

1/18/2008

Indicates the PrintRecItemFuel method for itemOption in the GetData method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const DescriptionLengthItemFuel As Integer
public const int DescriptionLengthItemFuel
public:
literal int DescriptionLengthItemFuel
public static final int DescriptionLengthItemFuel
public const var DescriptionLengthItemFuel : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData


FiscalPrinter.DescriptionLengthItemFuelVoid Field

FiscalPrinter.DescriptionLengthItemFuelVoid Field |
 | See Also

1/18/2008

Indicates the PrintRecItemFuelVoid method for itemOption in the GetData method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const DescriptionLengthItemFuelVoid As Integer
public const int DescriptionLengthItemFuelVoid
public:
literal int DescriptionLengthItemFuelVoid
public static final int DescriptionLengthItemFuelVoid
public const var DescriptionLengthItemFuelVoid : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData


FiscalPrinter.DescriptionLengthNotPaid Field

FiscalPrinter.DescriptionLengthNotPaid Field |
 | See Also

1/18/2008

Indicates the PrintRecNotPaid method for itemOption in the GetData method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const DescriptionLengthNotPaid As Integer
public const int DescriptionLengthNotPaid
public:
literal int DescriptionLengthNotPaid
public static final int DescriptionLengthNotPaid
public const var DescriptionLengthNotPaid : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData


FiscalPrinter.DescriptionLengthPackageAdjustment Field

FiscalPrinter.DescriptionLengthPackageAdjustment Field |
 | See Also

1/18/2008

Indicates the PrintRecPackageAdjustment method for itemOption in the GetData method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const DescriptionLengthPackageAdjustment As Integer
public const int DescriptionLengthPackageAdjustment
public:
literal int DescriptionLengthPackageAdjustment
public static final int DescriptionLengthPackageAdjustment
public const var DescriptionLengthPackageAdjustment : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData


FiscalPrinter.DescriptionLengthRefund Field

FiscalPrinter.DescriptionLengthRefund Field |
 | See Also

1/18/2008

Indicates the PrintRecRefund method for itemOption in the GetData method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const DescriptionLengthRefund As Integer
public const int DescriptionLengthRefund
public:
literal int DescriptionLengthRefund
public static final int DescriptionLengthRefund
public const var DescriptionLengthRefund : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData


FiscalPrinter.DescriptionLengthRefundVoid Field

FiscalPrinter.DescriptionLengthRefundVoid Field |
 | See Also

1/18/2008

Indicates the PrintRecRefundVoid method for itemOption in the GetData method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const DescriptionLengthRefundVoid As Integer
public const int DescriptionLengthRefundVoid
public:
literal int DescriptionLengthRefundVoid
public static final int DescriptionLengthRefundVoid
public const var DescriptionLengthRefundVoid : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData


FiscalPrinter.DescriptionLengthSubtotalAdjustment Field

FiscalPrinter.DescriptionLengthSubtotalAdjustment Field |
 | See Also

1/18/2008

Indicates the PrintRecSubtotalAdjustment method for itemOption in the GetData method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const DescriptionLengthSubtotalAdjustment As Integer
public const int DescriptionLengthSubtotalAdjustment
public:
literal int DescriptionLengthSubtotalAdjustment
public static final int DescriptionLengthSubtotalAdjustment
public const var DescriptionLengthSubtotalAdjustment : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData


FiscalPrinter.DescriptionLengthTotal Field

FiscalPrinter.DescriptionLengthTotal Field |
 | See Also

1/18/2008

Indicates the PrintRecTotal method for itemOption in the GetData method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const DescriptionLengthTotal As Integer
public const int DescriptionLengthTotal
public:
literal int DescriptionLengthTotal
public static final int DescriptionLengthTotal
public const var DescriptionLengthTotal : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData


FiscalPrinter.DescriptionLengthVoid Field

FiscalPrinter.DescriptionLengthVoid Field |
 | See Also

1/18/2008

Indicates the PrintRecVoid method for itemOption in the GetData method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const DescriptionLengthVoid As Integer
public const int DescriptionLengthVoid
public:
literal int DescriptionLengthVoid
public static final int DescriptionLengthVoid
public const var DescriptionLengthVoid : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData


FiscalPrinter.DescriptionLengthVoidItem Field

FiscalPrinter.DescriptionLengthVoidItem Field |
 | See Also

1/18/2008

Indicates the PrintRecItemVoid and PrintRecItemAdjustmentVoid method for itemOption in the GetData method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const DescriptionLengthVoidItem As Integer
public const int DescriptionLengthVoidItem
public:
literal int DescriptionLengthVoidItem
public static final int DescriptionLengthVoidItem
public const var DescriptionLengthVoidItem : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData
PrintRecItemVoid
PrintRecItemAdjustmentVoid


FiscalPrinter.ExtendedErrorBadDate Field

FiscalPrinter.ExtendedErrorBadDate Field |
 | See Also

1/18/2008

Indicates one of the date parameters is invalid.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorBadDate As Integer
public const int ExtendedErrorBadDate
public:
literal int ExtendedErrorBadDate
public static final int ExtendedErrorBadDate
public const var ExtendedErrorBadDate : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
PrintPeriodicTotalsReport
SetDate


FiscalPrinter.ExtendedErrorBadItemAmount Field

FiscalPrinter.ExtendedErrorBadItemAmount Field |
 | See Also

1/18/2008

Indicates the amount parameter is invalid.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorBadItemAmount As Integer
public const int ExtendedErrorBadItemAmount
public:
literal int ExtendedErrorBadItemAmount
public static final int ExtendedErrorBadItemAmount
public const var ExtendedErrorBadItemAmount : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
BeginFiscalDocument
PrintRecItemAdjustment
PrintRecNotPaid
PrintRecRefund
PrintRecRefundVoid
PrintRecSubtotal
PrintRecSubtotalAdjustment


FiscalPrinter.ExtendedErrorBadItemDescription Field

FiscalPrinter.ExtendedErrorBadItemDescription Field |
 | See Also

1/18/2008

Indicates the description parameter is either too long, contains illegal characters, or contains a reserved word.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorBadItemDescription As Integer
public const int ExtendedErrorBadItemDescription
public:
literal int ExtendedErrorBadItemDescription
public static final int ExtendedErrorBadItemDescription
public const var ExtendedErrorBadItemDescription : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
PrintRecItem
PrintRecItemAdjustment
PrintRecItemFuel
PrintRecItemFuelVoid
PrintRecMessage


FiscalPrinter.ExtendedErrorBadItemQuantity Field

FiscalPrinter.ExtendedErrorBadItemQuantity Field |
 | See Also

1/18/2008

Indicates the quantity parameter is invalid.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorBadItemQuantity As Integer
public const int ExtendedErrorBadItemQuantity
public:
literal int ExtendedErrorBadItemQuantity
public static final int ExtendedErrorBadItemQuantity
public const var ExtendedErrorBadItemQuantity : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
PrintRecItem
PrintRecItemFuel
PrintRecItemFuelVoid


FiscalPrinter.ExtendedErrorBadLength Field

FiscalPrinter.ExtendedErrorBadLength Field |
 | See Also

1/18/2008

Indicates the length of the string to print is too long.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorBadLength As Integer
public const int ExtendedErrorBadLength
public:
literal int ExtendedErrorBadLength
public static final int ExtendedErrorBadLength
public const var ExtendedErrorBadLength : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
ChangeDue
PostLine
PreLine


FiscalPrinter.ExtendedErrorBadPrice Field

FiscalPrinter.ExtendedErrorBadPrice Field |
 | See Also

1/18/2008

Indicates the price parameter is invalid.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorBadPrice As Integer
public const int ExtendedErrorBadPrice
public:
literal int ExtendedErrorBadPrice
public static final int ExtendedErrorBadPrice
public const var ExtendedErrorBadPrice : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
PrintRecItem
PrintRecItemFuel
PrintRecItemFuelVoid


FiscalPrinter.ExtendedErrorBadVat Field

FiscalPrinter.ExtendedErrorBadVat Field |
 | See Also

1/18/2008

Indicates the VAT parameter is invalid.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorBadVat As Integer
public const int ExtendedErrorBadVat
public:
literal int ExtendedErrorBadVat
public static final int ExtendedErrorBadVat
public const var ExtendedErrorBadVat : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
BeginItemList
PrintRecItem
PrintRecItemAdjustment


FiscalPrinter.ExtendedErrorClockError Field

FiscalPrinter.ExtendedErrorClockError Field |
 | See Also

1/18/2008

Indicates the fiscal printer's internal clock has failed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorClockError As Integer
public const int ExtendedErrorClockError
public:
literal int ExtendedErrorClockError
public static final int ExtendedErrorClockError
public const var ExtendedErrorClockError : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.ExtendedErrorCoverOpen Field

FiscalPrinter.ExtendedErrorCoverOpen Field |
 | See Also

1/18/2008

Indicates the fiscal printer cover is open.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorCoverOpen As Integer
public const int ExtendedErrorCoverOpen
public:
literal int ExtendedErrorCoverOpen
public static final int ExtendedErrorCoverOpen
public const var ExtendedErrorCoverOpen : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
EndInsertion
PrintFiscalDocumentLine
PrintNormal


FiscalPrinter.ExtendedErrorDayEndRequired Field

FiscalPrinter.ExtendedErrorDayEndRequired Field |
 | See Also

1/18/2008

Calls the PrintZReport method to print the report. The fiscal day must be completed before calling this function.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorDayEndRequired As Integer
public const int ExtendedErrorDayEndRequired
public:
literal int ExtendedErrorDayEndRequired
public static final int ExtendedErrorDayEndRequired
public const var ExtendedErrorDayEndRequired : int

Remarks

The completion of the fiscal day is required by calling PrintZReport. No further fiscal receipts or documents can be started before this is done.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.ExtendedErrorJournalEmpty Field

FiscalPrinter.ExtendedErrorJournalEmpty Field |
 | See Also

1/18/2008

Indicates the journal station has run out of paper.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorJournalEmpty As Integer
public const int ExtendedErrorJournalEmpty
public:
literal int ExtendedErrorJournalEmpty
public static final int ExtendedErrorJournalEmpty
public const var ExtendedErrorJournalEmpty : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.ExtendedErrorMemoryDisconnected Field

FiscalPrinter.ExtendedErrorMemoryDisconnected Field |
 | See Also

1/18/2008

Indicates the fiscal printer's memory has been disconnected.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorMemoryDisconnected As Integer
public const int ExtendedErrorMemoryDisconnected
public:
literal int ExtendedErrorMemoryDisconnected
public static final int ExtendedErrorMemoryDisconnected
public const var ExtendedErrorMemoryDisconnected : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.ExtendedErrorMemoryFull Field

FiscalPrinter.ExtendedErrorMemoryFull Field |
 | See Also

1/18/2008

Indicates the fiscal printer’s fiscal memory has been exhausted.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorMemoryFull As Integer
public const int ExtendedErrorMemoryFull
public:
literal int ExtendedErrorMemoryFull
public static final int ExtendedErrorMemoryFull
public const var ExtendedErrorMemoryFull : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.ExtendedErrorMissingDevices Field

FiscalPrinter.ExtendedErrorMissingDevices Field |
 | See Also

1/18/2008

Indicates that some of the other devices (according to the local fiscal legislation) that should be connected are missing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorMissingDevices As Integer
public const int ExtendedErrorMissingDevices
public:
literal int ExtendedErrorMissingDevices
public static final int ExtendedErrorMissingDevices
public const var ExtendedErrorMissingDevices : int

Remarks

In some countries or regions, in order to use a fiscal printer a full set of peripheral devices must be connected to the POS (such as cash drawer and customer display). In case one of these devices is not present, sales are not allowed.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.ExtendedErrorMissingSetCurrency Field

FiscalPrinter.ExtendedErrorMissingSetCurrency Field |
 | See Also

1/18/2008

Indicates the fiscal printer is expecting the activation of a new currency.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorMissingSetCurrency As Integer
public const int ExtendedErrorMissingSetCurrency
public:
literal int ExtendedErrorMissingSetCurrency
public static final int ExtendedErrorMissingSetCurrency
public const var ExtendedErrorMissingSetCurrency : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.ExtendedErrorNegativeTotal Field

FiscalPrinter.ExtendedErrorNegativeTotal Field |
 | See Also

1/18/2008

Indicates the fiscal printer’s computed total or subtotal is less than zero.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorNegativeTotal As Integer
public const int ExtendedErrorNegativeTotal
public:
literal int ExtendedErrorNegativeTotal
public static final int ExtendedErrorNegativeTotal
public const var ExtendedErrorNegativeTotal : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.ExtendedErrorReceiptEmpty Field

FiscalPrinter.ExtendedErrorReceiptEmpty Field |
 | See Also

1/18/2008

Indicates the receipt station has run out of paper.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorReceiptEmpty As Integer
public const int ExtendedErrorReceiptEmpty
public:
literal int ExtendedErrorReceiptEmpty
public static final int ExtendedErrorReceiptEmpty
public const var ExtendedErrorReceiptEmpty : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.ExtendedErrorReceiptTotalOverflow Field

FiscalPrinter.ExtendedErrorReceiptTotalOverflow Field |
 | See Also

1/18/2008

Indicates the receipt total has overflowed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorReceiptTotalOverflow As Integer
public const int ExtendedErrorReceiptTotalOverflow
public:
literal int ExtendedErrorReceiptTotalOverflow
public static final int ExtendedErrorReceiptTotalOverflow
public const var ExtendedErrorReceiptTotalOverflow : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.ExtendedErrorSlipEmpty Field

FiscalPrinter.ExtendedErrorSlipEmpty Field |
 | See Also

1/18/2008

Indicates the slip station has run out of paper.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorSlipEmpty As Integer
public const int ExtendedErrorSlipEmpty
public:
literal int ExtendedErrorSlipEmpty
public static final int ExtendedErrorSlipEmpty
public const var ExtendedErrorSlipEmpty : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.ExtendedErrorSlipForm Field

FiscalPrinter.ExtendedErrorSlipForm Field |
 | See Also

1/18/2008

Indicates a slip form is present.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorSlipForm As Integer
public const int ExtendedErrorSlipForm
public:
literal int ExtendedErrorSlipForm
public static final int ExtendedErrorSlipForm
public const var ExtendedErrorSlipForm : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.ExtendedErrorTechnicalAssistance Field

FiscalPrinter.ExtendedErrorTechnicalAssistance Field |
 | See Also

1/18/2008

Indicates the fiscal printer has encountered a severe error condition. Calling for fiscal printer technical help is required.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorTechnicalAssistance As Integer
public const int ExtendedErrorTechnicalAssistance
public:
literal int ExtendedErrorTechnicalAssistance
public static final int ExtendedErrorTechnicalAssistance
public const var ExtendedErrorTechnicalAssistance : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.ExtendedErrorTotalsError Field

FiscalPrinter.ExtendedErrorTotalsError Field |
 | See Also

1/18/2008

Indicates the Grand Total in working memory does not match the one in the EPROM.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorTotalsError As Integer
public const int ExtendedErrorTotalsError
public:
literal int ExtendedErrorTotalsError
public static final int ExtendedErrorTotalsError
public const var ExtendedErrorTotalsError : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.ExtendedErrorWordNotAllowed Field

FiscalPrinter.ExtendedErrorWordNotAllowed Field |
 | See Also

1/18/2008

Indicates the description contains a reserved word.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorWordNotAllowed As Integer
public const int ExtendedErrorWordNotAllowed
public:
literal int ExtendedErrorWordNotAllowed
public static final int ExtendedErrorWordNotAllowed
public const var ExtendedErrorWordNotAllowed : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.ExtendedErrorWrongState Field

FiscalPrinter.ExtendedErrorWrongState Field |
 | See Also

1/18/2008

Indicates the requested method cannot be executed in the fiscal printer’s current state.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorWrongState As Integer
public const int ExtendedErrorWrongState
public:
literal int ExtendedErrorWrongState
public static final int ExtendedErrorWrongState
public const var ExtendedErrorWrongState : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.LineCountComment Field

FiscalPrinter.LineCountComment Field |
 | See Also

1/18/2008

Indicates the number of comment lines.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const LineCountComment As Integer
public const int LineCountComment
public:
literal int LineCountComment
public static final int LineCountComment
public const var LineCountComment : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.LineCountDiscount Field

FiscalPrinter.LineCountDiscount Field |
 | See Also

1/18/2008

Indicates the number of discount lines.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const LineCountDiscount As Integer
public const int LineCountDiscount
public:
literal int LineCountDiscount
public static final int LineCountDiscount
public const var LineCountDiscount : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.LineCountDiscountVoid Field

FiscalPrinter.LineCountDiscountVoid Field |
 | See Also

1/18/2008

Indicates the number of voided refund lines.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const LineCountDiscountVoid As Integer
public const int LineCountDiscountVoid
public:
literal int LineCountDiscountVoid
public static final int LineCountDiscountVoid
public const var LineCountDiscountVoid : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.LineCountItem Field

FiscalPrinter.LineCountItem Field |
 | See Also

1/18/2008

Indicates the number of item lines.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const LineCountItem As Integer
public const int LineCountItem
public:
literal int LineCountItem
public static final int LineCountItem
public const var LineCountItem : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.LineCountItemVoid Field

FiscalPrinter.LineCountItemVoid Field |
 | See Also

1/18/2008

Indicates the number of voided item lines.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const LineCountItemVoid As Integer
public const int LineCountItemVoid
public:
literal int LineCountItemVoid
public static final int LineCountItemVoid
public const var LineCountItemVoid : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.LineCountRefund Field

FiscalPrinter.LineCountRefund Field |
 | See Also

1/18/2008

Indicates the number of refund lines.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const LineCountRefund As Integer
public const int LineCountRefund
public:
literal int LineCountRefund
public static final int LineCountRefund
public const var LineCountRefund : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.LineCountRefundVoid Field

FiscalPrinter.LineCountRefundVoid Field |
 | See Also

1/18/2008

Indicates the number of voided refund lines.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const LineCountRefundVoid As Integer
public const int LineCountRefundVoid
public:
literal int LineCountRefundVoid
public static final int LineCountRefundVoid
public const var LineCountRefundVoid : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.LineCountSubtotal Field

FiscalPrinter.LineCountSubtotal Field |
 | See Also

1/18/2008

Indicates the number of subtotal lines.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const LineCountSubtotal As Integer
public const int LineCountSubtotal
public:
literal int LineCountSubtotal
public static final int LineCountSubtotal
public const var LineCountSubtotal : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.LineCountSubtotalDiscount Field

FiscalPrinter.LineCountSubtotalDiscount Field |
 | See Also

1/18/2008

Indicates the number of subtotal discount lines.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const LineCountSubtotalDiscount As Integer
public const int LineCountSubtotalDiscount
public:
literal int LineCountSubtotalDiscount
public static final int LineCountSubtotalDiscount
public const var LineCountSubtotalDiscount : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.LineCountSubtotalDiscountVoid Field

FiscalPrinter.LineCountSubtotalDiscountVoid Field |
 | See Also

1/18/2008

Indicates the number of voided subtotal discount lines.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const LineCountSubtotalDiscountVoid As Integer
public const int LineCountSubtotalDiscountVoid
public:
literal int LineCountSubtotalDiscountVoid
public static final int LineCountSubtotalDiscountVoid
public const var LineCountSubtotalDiscountVoid : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.LineCountSubtotalSurcharge Field

FiscalPrinter.LineCountSubtotalSurcharge Field |
 | See Also

1/18/2008

Indicates the number of subtotal surcharge lines.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const LineCountSubtotalSurcharge As Integer
public const int LineCountSubtotalSurcharge
public:
literal int LineCountSubtotalSurcharge
public static final int LineCountSubtotalSurcharge
public const var LineCountSubtotalSurcharge : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.LineCountSubtotalSurchargeVoid Field

FiscalPrinter.LineCountSubtotalSurchargeVoid Field |
 | See Also

1/18/2008

Indicates the number of voided subtotal surcharge lines.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const LineCountSubtotalSurchargeVoid As Integer
public const int LineCountSubtotalSurchargeVoid
public:
literal int LineCountSubtotalSurchargeVoid
public static final int LineCountSubtotalSurchargeVoid
public const var LineCountSubtotalSurchargeVoid : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.LineCountSurcharge Field

FiscalPrinter.LineCountSurcharge Field |
 | See Also

1/18/2008

Indicates the number of surcharge lines.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const LineCountSurcharge As Integer
public const int LineCountSurcharge
public:
literal int LineCountSurcharge
public static final int LineCountSurcharge
public const var LineCountSurcharge : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.LineCountSurchargeVoid Field

FiscalPrinter.LineCountSurchargeVoid Field |
 | See Also

1/18/2008

Indicates the number of voided surcharge lines.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const LineCountSurchargeVoid As Integer
public const int LineCountSurchargeVoid
public:
literal int LineCountSurchargeVoid
public static final int LineCountSurchargeVoid
public const var LineCountSurchargeVoid : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.LineCountTotal Field

FiscalPrinter.LineCountTotal Field |
 | See Also

1/18/2008

Indicates the number of total lines.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const LineCountTotal As Integer
public const int LineCountTotal
public:
literal int LineCountTotal
public static final int LineCountTotal
public const var LineCountTotal : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.PaymentDescriptionCash Field

FiscalPrinter.PaymentDescriptionCash Field |
 | See Also

1/18/2008

Indicates cash.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PaymentDescriptionCash As Integer
public const int PaymentDescriptionCash
public:
literal int PaymentDescriptionCash
public static final int PaymentDescriptionCash
public const var PaymentDescriptionCash : int

Remarks

This value is passed in the itemOption parameter of GetData when Tender is used as the dataItem.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData
FiscalData Enumeration


FiscalPrinter.PaymentDescriptionCheque Field

FiscalPrinter.PaymentDescriptionCheque Field |
 | See Also

1/18/2008

Indicates cheque.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PaymentDescriptionCheque As Integer
public const int PaymentDescriptionCheque
public:
literal int PaymentDescriptionCheque
public static final int PaymentDescriptionCheque
public const var PaymentDescriptionCheque : int

Remarks

This value is passed in the itemOption parameter of GetData when Tender is used as the dataItem.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData
FiscalData Enumeration


FiscalPrinter.PaymentDescriptionChitty Field

FiscalPrinter.PaymentDescriptionChitty Field |
 | See Also

1/18/2008

Indicates chitty.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PaymentDescriptionChitty As Integer
public const int PaymentDescriptionChitty
public:
literal int PaymentDescriptionChitty
public static final int PaymentDescriptionChitty
public const var PaymentDescriptionChitty : int

Remarks

This value is passed in the itemOption parameter of GetData when Tender is used as the dataItem.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData
FiscalData Enumeration


FiscalPrinter.PaymentDescriptionCoupon Field

FiscalPrinter.PaymentDescriptionCoupon Field |
 | See Also

1/18/2008

Indicates coupon.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PaymentDescriptionCoupon As Integer
public const int PaymentDescriptionCoupon
public:
literal int PaymentDescriptionCoupon
public static final int PaymentDescriptionCoupon
public const var PaymentDescriptionCoupon : int

Remarks

This value is passed in the itemOption parameter of GetData when Tender is used as the dataItem.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData
FiscalData Enumeration


FiscalPrinter.PaymentDescriptionCurrency Field

FiscalPrinter.PaymentDescriptionCurrency Field |
 | See Also

1/18/2008

Indicates currency.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PaymentDescriptionCurrency As Integer
public const int PaymentDescriptionCurrency
public:
literal int PaymentDescriptionCurrency
public static final int PaymentDescriptionCurrency
public const var PaymentDescriptionCurrency : int

Remarks

This value is passed in the itemOption parameter of GetData when Tender is used as the dataItem.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData
FiscalData Enumeration


FiscalPrinter.PaymentDescriptionDrivenOff Field

FiscalPrinter.PaymentDescriptionDrivenOff Field |
 | See Also

1/18/2008

Indicates that the description has been driven off.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PaymentDescriptionDrivenOff As Integer
public const int PaymentDescriptionDrivenOff
public:
literal int PaymentDescriptionDrivenOff
public static final int PaymentDescriptionDrivenOff
public const var PaymentDescriptionDrivenOff : int

Remarks

This value is passed in the itemOption parameter of GetData when Tender is used as the dataItem.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData
FiscalData Enumeration


FiscalPrinter.PaymentDescriptionEftImprinter Field

FiscalPrinter.PaymentDescriptionEftImprinter Field |
 | See Also

1/18/2008

Indicates printer EFT.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PaymentDescriptionEftImprinter As Integer
public const int PaymentDescriptionEftImprinter
public:
literal int PaymentDescriptionEftImprinter
public static final int PaymentDescriptionEftImprinter
public const var PaymentDescriptionEftImprinter : int

Remarks

This value is passed in the itemOption parameter of GetData when Tender is used as the dataItem.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData
FiscalData Enumeration


FiscalPrinter.PaymentDescriptionEftTerminal Field

FiscalPrinter.PaymentDescriptionEftTerminal Field |
 | See Also

1/18/2008

Indicates terminal EFT.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PaymentDescriptionEftTerminal As Integer
public const int PaymentDescriptionEftTerminal
public:
literal int PaymentDescriptionEftTerminal
public static final int PaymentDescriptionEftTerminal
public const var PaymentDescriptionEftTerminal : int

Remarks

This value is passed in the itemOption parameter of GetData when Tender is used as the dataItem.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData
FiscalData Enumeration


FiscalPrinter.PaymentDescriptionFreeGift Field

FiscalPrinter.PaymentDescriptionFreeGift Field |
 | See Also

1/18/2008

Indicates gift.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PaymentDescriptionFreeGift As Integer
public const int PaymentDescriptionFreeGift
public:
literal int PaymentDescriptionFreeGift
public static final int PaymentDescriptionFreeGift
public const var PaymentDescriptionFreeGift : int

Remarks

This value is passed in the itemOption parameter of GetData when Tender is used as the dataItem.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData
FiscalData Enumeration


FiscalPrinter.PaymentDescriptionGiro Field

FiscalPrinter.PaymentDescriptionGiro Field |
 | See Also

1/18/2008

Indicates giro.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PaymentDescriptionGiro As Integer
public const int PaymentDescriptionGiro
public:
literal int PaymentDescriptionGiro
public static final int PaymentDescriptionGiro
public const var PaymentDescriptionGiro : int

Remarks

This value is passed in the itemOption parameter of GetData when Tender is used as the dataItem.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData
FiscalData Enumeration


FiscalPrinter.PaymentDescriptionHome Field

FiscalPrinter.PaymentDescriptionHome Field |
 | See Also

1/18/2008

Indicates home.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PaymentDescriptionHome As Integer
public const int PaymentDescriptionHome
public:
literal int PaymentDescriptionHome
public static final int PaymentDescriptionHome
public const var PaymentDescriptionHome : int

Remarks

This value is passed in the itemOption parameter of GetData when Tender is used as the dataItem.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData
FiscalData Enumeration


FiscalPrinter.PaymentDescriptionImprinterWithIssuer Field

FiscalPrinter.PaymentDescriptionImprinterWithIssuer Field |
 | See Also

1/18/2008

Indicates imprinter with issuer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PaymentDescriptionImprinterWithIssuer As Integer
public const int PaymentDescriptionImprinterWithIssuer
public:
literal int PaymentDescriptionImprinterWithIssuer
public static final int PaymentDescriptionImprinterWithIssuer
public const var PaymentDescriptionImprinterWithIssuer : int

Remarks

This value is passed in the itemOption parameter of GetData when Tender is used as the dataItem.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData
FiscalData Enumeration


FiscalPrinter.PaymentDescriptionLocalAccount Field

FiscalPrinter.PaymentDescriptionLocalAccount Field |
 | See Also

1/18/2008

Indicates local account.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PaymentDescriptionLocalAccount As Integer
public const int PaymentDescriptionLocalAccount
public:
literal int PaymentDescriptionLocalAccount
public static final int PaymentDescriptionLocalAccount
public const var PaymentDescriptionLocalAccount : int

Remarks

This value is passed in the itemOption parameter of GetData when Tender is used as the dataItem.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData
FiscalData Enumeration


FiscalPrinter.PaymentDescriptionLocalAccountCard Field

FiscalPrinter.PaymentDescriptionLocalAccountCard Field |
 | See Also

1/18/2008

Indicates local card account.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PaymentDescriptionLocalAccountCard As Integer
public const int PaymentDescriptionLocalAccountCard
public:
literal int PaymentDescriptionLocalAccountCard
public static final int PaymentDescriptionLocalAccountCard
public const var PaymentDescriptionLocalAccountCard : int

Remarks

This value is passed in the itemOption parameter of GetData when Tender is used as the dataItem.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData
FiscalData Enumeration


FiscalPrinter.PaymentDescriptionPayCard Field

FiscalPrinter.PaymentDescriptionPayCard Field |
 | See Also

1/18/2008

Indicates pay card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PaymentDescriptionPayCard As Integer
public const int PaymentDescriptionPayCard
public:
literal int PaymentDescriptionPayCard
public static final int PaymentDescriptionPayCard
public const var PaymentDescriptionPayCard : int

Remarks

This value is passed in the itemOption parameter of GetData when Tender is used as the dataItem.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData
FiscalData Enumeration


FiscalPrinter.PaymentDescriptionPayCardManual Field

FiscalPrinter.PaymentDescriptionPayCardManual Field |
 | See Also

1/18/2008

Indicates manual pay card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PaymentDescriptionPayCardManual As Integer
public const int PaymentDescriptionPayCardManual
public:
literal int PaymentDescriptionPayCardManual
public static final int PaymentDescriptionPayCardManual
public const var PaymentDescriptionPayCardManual : int

Remarks

This value is passed in the itemOption parameter of GetData when Tender is used as the dataItem.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData
FiscalData Enumeration


FiscalPrinter.PaymentDescriptionPrepay Field

FiscalPrinter.PaymentDescriptionPrepay Field |
 | See Also

1/18/2008

Indicates prepay.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PaymentDescriptionPrepay As Integer
public const int PaymentDescriptionPrepay
public:
literal int PaymentDescriptionPrepay
public static final int PaymentDescriptionPrepay
public const var PaymentDescriptionPrepay : int

Remarks

This value is passed in the itemOption parameter of GetData when Tender is used as the dataItem.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData
FiscalData Enumeration


FiscalPrinter.PaymentDescriptionPumpTest Field

FiscalPrinter.PaymentDescriptionPumpTest Field |
 | See Also

1/18/2008

Indicates pump test.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PaymentDescriptionPumpTest As Integer
public const int PaymentDescriptionPumpTest
public:
literal int PaymentDescriptionPumpTest
public static final int PaymentDescriptionPumpTest
public const var PaymentDescriptionPumpTest : int

Remarks

This value is passed in the itemOption parameter of GetData when Tender is used as the dataItem.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData
FiscalData Enumeration


FiscalPrinter.PaymentDescriptionShortCredit Field

FiscalPrinter.PaymentDescriptionShortCredit Field |
 | See Also

1/18/2008

Indicates credit.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PaymentDescriptionShortCredit As Integer
public const int PaymentDescriptionShortCredit
public:
literal int PaymentDescriptionShortCredit
public static final int PaymentDescriptionShortCredit
public const var PaymentDescriptionShortCredit : int

Remarks

This value is passed in the itemOption parameter of GetData when Tender is used as the dataItem.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData
FiscalData Enumeration


FiscalPrinter.PaymentDescriptionStaff Field

FiscalPrinter.PaymentDescriptionStaff Field |
 | See Also

1/18/2008

Indicates staff.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PaymentDescriptionStaff As Integer
public const int PaymentDescriptionStaff
public:
literal int PaymentDescriptionStaff
public static final int PaymentDescriptionStaff
public const var PaymentDescriptionStaff : int

Remarks

This value is passed in the itemOption parameter of GetData when Tender is used as the dataItem.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData
FiscalData Enumeration


FiscalPrinter.PaymentDescriptionTerminalImprinter Field

FiscalPrinter.PaymentDescriptionTerminalImprinter Field |
 | See Also

1/18/2008

Indicates a terminal imprinter.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PaymentDescriptionTerminalImprinter As Integer
public const int PaymentDescriptionTerminalImprinter
public:
literal int PaymentDescriptionTerminalImprinter
public static final int PaymentDescriptionTerminalImprinter
public const var PaymentDescriptionTerminalImprinter : int

Remarks

This value is passed in the itemOption parameter of GetData when Tender is used as the dataItem.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData
FiscalData Enumeration


FiscalPrinter.PaymentDescriptionVoucher Field

FiscalPrinter.PaymentDescriptionVoucher Field |
 | See Also

1/18/2008

Indicates a voucher.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PaymentDescriptionVoucher As Integer
public const int PaymentDescriptionVoucher
public:
literal int PaymentDescriptionVoucher
public static final int PaymentDescriptionVoucher
public const var PaymentDescriptionVoucher : int

Remarks

This value is passed in the itemOption parameter of GetData when Tender is used as the dataItem.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
GetData
FiscalData Enumeration


FiscalPrinter.StatusCoverOK Field

FiscalPrinter.StatusCoverOK Field |
 | See Also

1/18/2008

Indicates the cover is closed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusCoverOK As Integer
public const int StatusCoverOK
public:
literal int StatusCoverOK
public static final int StatusCoverOK
public const var StatusCoverOK : int

Remarks

This value is returned by a StatusUpdateEvent in the Status property.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
StatusUpdateEvent
CoverOpen


FiscalPrinter.StatusCoverOpen Field

FiscalPrinter.StatusCoverOpen Field |
 | See Also

1/18/2008

Indicates the cover is open.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusCoverOpen As Integer
public const int StatusCoverOpen
public:
literal int StatusCoverOpen
public static final int StatusCoverOpen
public const var StatusCoverOpen : int

Remarks

This value is returned by a StatusUpdateEvent in the Status property.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
StatusUpdateEvent
CoverOpen


FiscalPrinter.StatusIdle Field

FiscalPrinter.StatusIdle Field |
 | See Also

1/18/2008

Indicates all asynchronous output has finished, either successfully or because output has been cleared.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusIdle As Integer
public const int StatusIdle
public:
literal int StatusIdle
public static final int StatusIdle
public const var StatusIdle : int

Remarks

The fiscal printer state is now Idle. The FlagWhenIdle property must be true for this event to be delivered, and the property is automatically reset to false just before the event is delivered.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
StatusUpdateEvent


FiscalPrinter.StatusJournalCoverOK Field

FiscalPrinter.StatusJournalCoverOK Field |
 | See Also

1/18/2008

Indicates the journal station cover is closed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusJournalCoverOK As Integer
public const int StatusJournalCoverOK
public:
literal int StatusJournalCoverOK
public static final int StatusJournalCoverOK
public const var StatusJournalCoverOK : int

Remarks

This value is returned by a StatusUpdateEvent in the Status property.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
StatusUpdateEvent


FiscalPrinter.StatusJournalCoverOpen Field

FiscalPrinter.StatusJournalCoverOpen Field |
 | See Also

1/18/2008

Indicates the receipt station cover is open.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusJournalCoverOpen As Integer
public const int StatusJournalCoverOpen
public:
literal int StatusJournalCoverOpen
public static final int StatusJournalCoverOpen
public const var StatusJournalCoverOpen : int

Remarks

This value is returned by a StatusUpdateEvent in the Status property.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
StatusUpdateEvent


FiscalPrinter.StatusJournalEmpty Field

FiscalPrinter.StatusJournalEmpty Field |
 | See Also

1/18/2008

Indicates no journal paper.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusJournalEmpty As Integer
public const int StatusJournalEmpty
public:
literal int StatusJournalEmpty
public static final int StatusJournalEmpty
public const var StatusJournalEmpty : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
StatusUpdateEvent


FiscalPrinter.StatusJournalNearEmpty Field

FiscalPrinter.StatusJournalNearEmpty Field |
 | See Also

1/18/2008

Indicates journal paper is low.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusJournalNearEmpty As Integer
public const int StatusJournalNearEmpty
public:
literal int StatusJournalNearEmpty
public static final int StatusJournalNearEmpty
public const var StatusJournalNearEmpty : int

Remarks

This value is returned by a StatusUpdateEvent in the Status property.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
StatusUpdateEvent


FiscalPrinter.StatusJournalPaperOK Field

FiscalPrinter.StatusJournalPaperOK Field |
 | See Also

1/18/2008

Indicates journal paper is ready.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusJournalPaperOK As Integer
public const int StatusJournalPaperOK
public:
literal int StatusJournalPaperOK
public static final int StatusJournalPaperOK
public const var StatusJournalPaperOK : int

Remarks

This value is returned by a StatusUpdateEvent in the Status property.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
StatusUpdateEvent


FiscalPrinter.StatusReceiptCoverOK Field

FiscalPrinter.StatusReceiptCoverOK Field |
 | See Also

1/18/2008

Indicates receipt station cover is closed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusReceiptCoverOK As Integer
public const int StatusReceiptCoverOK
public:
literal int StatusReceiptCoverOK
public static final int StatusReceiptCoverOK
public const var StatusReceiptCoverOK : int

Remarks

This value is returned by a StatusUpdateEvent in the Status property.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
StatusUpdateEvent


FiscalPrinter.StatusReceiptCoverOpen Field

FiscalPrinter.StatusReceiptCoverOpen Field |
 | See Also

1/18/2008

Indicates receipt station cover is open.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusReceiptCoverOpen As Integer
public const int StatusReceiptCoverOpen
public:
literal int StatusReceiptCoverOpen
public static final int StatusReceiptCoverOpen
public const var StatusReceiptCoverOpen : int

Remarks

This value is returned by a StatusUpdateEvent in the Status property.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
StatusUpdateEvent


FiscalPrinter.StatusReceiptEmpty Field

FiscalPrinter.StatusReceiptEmpty Field |
 | See Also

1/18/2008

Indicates no receipt paper.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusReceiptEmpty As Integer
public const int StatusReceiptEmpty
public:
literal int StatusReceiptEmpty
public static final int StatusReceiptEmpty
public const var StatusReceiptEmpty : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
StatusUpdateEvent


FiscalPrinter.StatusReceiptNearEmpty Field

FiscalPrinter.StatusReceiptNearEmpty Field |
 | See Also

1/18/2008

Indicates receipt paper is low.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusReceiptNearEmpty As Integer
public const int StatusReceiptNearEmpty
public:
literal int StatusReceiptNearEmpty
public static final int StatusReceiptNearEmpty
public const var StatusReceiptNearEmpty : int

Remarks

This value is returned by a StatusUpdateEvent in the Status property.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
StatusUpdateEvent


FiscalPrinter.StatusReceiptPaperOK Field

FiscalPrinter.StatusReceiptPaperOK Field |
 | See Also

1/18/2008

Indicates receipt paper is ready.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusReceiptPaperOK As Integer
public const int StatusReceiptPaperOK
public:
literal int StatusReceiptPaperOK
public static final int StatusReceiptPaperOK
public const var StatusReceiptPaperOK : int

Remarks

This value is returned by a StatusUpdateEvent in the Status property.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
StatusUpdateEvent


FiscalPrinter.StatusSlipCoverOK Field

FiscalPrinter.StatusSlipCoverOK Field |
 | See Also

1/18/2008

Indicates slip station cover is closed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusSlipCoverOK As Integer
public const int StatusSlipCoverOK
public:
literal int StatusSlipCoverOK
public static final int StatusSlipCoverOK
public const var StatusSlipCoverOK : int

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
StatusUpdateEvent


FiscalPrinter.StatusSlipCoverOpen Field

FiscalPrinter.StatusSlipCoverOpen Field |
 | See Also

1/18/2008

Indicates slip station cover is open.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusSlipCoverOpen As Integer
public const int StatusSlipCoverOpen
public:
literal int StatusSlipCoverOpen
public static final int StatusSlipCoverOpen
public const var StatusSlipCoverOpen : int

Remarks

This value is returned by a StatusUpdateEvent in the Status property.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
StatusUpdateEvent


FiscalPrinter.StatusSlipEmpty Field

FiscalPrinter.StatusSlipEmpty Field |
 | See Also

1/18/2008

Indicates no slip form is inserted, and no slip form has been detected at the entrance to the slip station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusSlipEmpty As Integer
public const int StatusSlipEmpty
public:
literal int StatusSlipEmpty
public static final int StatusSlipEmpty
public const var StatusSlipEmpty : int

Remarks

This value is returned by a StatusUpdateEvent in the Status property.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
StatusUpdateEvent


FiscalPrinter.StatusSlipNearEmpty Field

FiscalPrinter.StatusSlipNearEmpty Field |
 | See Also

1/18/2008

Indicates almost at the bottom of the slip form.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusSlipNearEmpty As Integer
public const int StatusSlipNearEmpty
public:
literal int StatusSlipNearEmpty
public static final int StatusSlipNearEmpty
public const var StatusSlipNearEmpty : int

Remarks

This value is returned by a StatusUpdateEvent in the Status property.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
StatusUpdateEvent


FiscalPrinter.StatusSlipPaperOK Field

FiscalPrinter.StatusSlipPaperOK Field |
 | See Also

1/18/2008

Indicates a slip form is inserted.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusSlipPaperOK As Integer
public const int StatusSlipPaperOK
public:
literal int StatusSlipPaperOK
public static final int StatusSlipPaperOK
public const var StatusSlipPaperOK : int

Remarks

This value is returned by a StatusUpdateEvent in the Status property.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
StatusUpdateEvent


FiscalPrinter Constructor

FiscalPrinter Constructor |
 | See Also

1/18/2008

Creates an instance of FiscalPrinter class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected FiscalPrinter ()
protected:
FiscalPrinter ()
protected FiscalPrinter ()
protected function FiscalPrinter ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter Methods

FiscalPrinter Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
BeginFiscalDocument | Starts fiscal printing to the slip station.
BeginFiscalReceipt | Starts fiscal printing to the receipt station.
BeginFixedOutput | Starts nonfiscal fixed text printing on a printer station.
BeginInsertion | Starts slip processing.
BeginItemList | Starts a validation report of items that belong to a particular VAT class.
BeginNonFiscal | Starts nonfiscal operations on the printer.
BeginRemoval | Starts form-removal processing.
BeginTraining | Starts training operations.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearError | Clears all printer error conditions.
ClearOutput | Clears all buffered output data. This includes all asynchronous output.
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
EndFiscalDocument | Stops fiscal printing to the slip station.
EndFiscalReceipt | Stops fiscal printing to the receipt station.
EndFixedOutput | Stops nonfiscal fixed text printing on a printer station.
EndInsertion | Ends form insertion processing.
EndItemList | Closes a validation report of items that belong to a particular VAT class.
EndNonFiscal | Closes nonfiscal operations on one printer station.
EndRemoval | Ends form removal processing.
EndTraining | Stops training operations on either the receipt or slip station.
Equals | Overloaded. (inherited from Object )
GetData | Retrieves data and counters from the printer’s fiscal module.
GetDate | Gets the printer's date and time.
GetHashCode | (inherited from Object )
GetTotalizer | Gets the totalizer associated with the specified vat id and totalizer type.
GetType | (inherited from Object )
GetVatEntry | Gets the rate associated with a given VAT identifier.
Open | Opens a device for later input/output processing. (inherited from PosCommon )
PrintDuplicateReceipt | Prints a duplicate of a buffered transaction.
PrintFiscalDocumentLine | Prints a line of fiscal text to the slip station.
PrintFixedOutput | Prints a line of a fixed document to the print station specified in the BeginFixedOutput method.
PrintNormal | Prints data on the printer station.
PrintPeriodicTotalsReport | Prints a report of totals for a range of dates on the receipt.
PrintPowerLossReport | Prints on the receipt a report of a power failure that resulted in a loss of data that is stored in the CMOS of the printer.
PrintRecCash | Prints a cash-in or cash-out receipt amount on the station defined by the FiscalReceiptStation property.
PrintRecItem | Prints a receipt item for a sold item on the station specified by the FiscalReceiptStation property.
PrintRecItemAdjustment | Applies and prints a discount or a surcharge to the last receipt item sold.
PrintRecItemAdjustmentVoid | Takes a VAT rate identifier that corresponds to an entry in the VAT table.
PrintRecItemFuel | Prints a receipt fuel item on the station specified by the FiscalReceiptStation property.
PrintRecItemFuelVoid | Voids a fuel item on the station specified by the FiscalReceiptStation property.
PrintRecItemRefund | Processes one or more item refunds.
PrintRecItemRefundVoid | Processes a void of one or more item refunds.
PrintRecItemVoid | Cancels one or more items that has been added to the receipt and prints a void description on the station defined by the FiscalReceiptStation property.
PrintRecMessage | Prints a message on the fiscal receipt.
PrintRecNotPaid | Indicates a part of the receipt's total that is unpaid.
PrintRecPackageAdjustment | Called to give an adjustment for a package of some items booked before.
PrintRecPackageAdjustVoid | Specifies a list of adjustments to be voided.
PrintRecRefund | Processes a refund.
PrintRecRefundVoid | Processes a void of a refund.
PrintRecSubtotal | Checks and prints the current receipt subtotal.
PrintRecSubtotalAdjustment | Applies and prints a discount or surcharge to the current receipt subtotal.
PrintRecSubtotalAdjustVoid | Voids a preceding subtotal adjustment on the station defined by the FiscalReceiptStation property.
PrintRecTaxId | Prints the customer's tax identification on the station defined by the FiscalReceiptStation property.
PrintRecTotal | Checks and prints the current receipt total on the station defined by the FiscalReceiptStation property and tenders a payment.
PrintRecVoid | Cancels the current receipt.
PrintReport | Prints a report of the fiscal EPROM contents on the receipt that occurred between two end points.
PrintXReport | Prints a report of all the daily fiscal activities on the receipt.
PrintZReport | Prints a report of all the daily fiscal activities on the receipt.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetPrinter | Forces the printer to return to the Monitor state.
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
SetCurrency | Changes to a new currency (for example, euro).
SetDate | Sets the printer's date and time.
SetHeaderLine | Sets one of the fiscal receipt header lines.
SetPosId | Sets the POS and cashier identifiers.
SetStoreFiscalId | Sets the store fiscal ID.
SetTrailerLine | Sets one of the fiscal receipt trailer lines.
SetVatTable | Sends the VAT table built inside the service object to the printer.
SetVatValue | Sets the VAT ID and VAT value.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
VerifyItem | Compares itemName and its vatId with the values stored in the printer.

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

FiscalPrinter Class
Microsoft.PointOfService Namespace


FiscalPrinter.BeginFiscalDocument Method

FiscalPrinter.BeginFiscalDocument Method |
 | See Also

1/18/2008

Starts fiscal printing to the slip station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub BeginFiscalDocument ( _
    documentAmount As Integer _
)
public abstract void BeginFiscalDocument (
    int documentAmount
)
public:
virtual void BeginFiscalDocument (
    int documentAmount
) abstract
public abstract void BeginFiscalDocument (
    int documentAmount
)
public abstract function BeginFiscalDocument (
    documentAmount : int
)

Parameters

documentAmount

Amount of document to be stored by the printer.

Remarks

The BeginFiscalDocument method is supported only if the CapSlpFiscalDocument property is true.

The slip paper must be inserted into the slip station by using the BeginInsertion and EndInsertion methods before it calls this method.

Each fiscal line is printed by using the PrintFiscalDocumentLine method.

The BeginFiscalDocument method may cause a PosControlException to be thrown with the following ErrorCode.

Value

Description

Busy

Cannot perform while output is in progress.

Illegal

One of the following errors occurred:

  • The slip station does not exist (see the CapSlpPresent property).

  • The printer does not support fiscal output to the slip station (see the CapSlpFiscalDocument property).

Extended

One of the following errors occurred:

  • ExtendedErrorWrongState. The printer's current state does not allow this state transition.

  • ExtendedErrorSlipEmpty. There is no paper in the slip station.

  • ExtendedErrorBadItemAmount. The documentAmount parameter is invalid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
EndFiscalDocument
PrintFiscalDocumentLine
AmountDecimalPlaces


FiscalPrinter.BeginFiscalReceipt Method

FiscalPrinter.BeginFiscalReceipt Method |
 | See Also

1/18/2008

Starts fiscal printing to the receipt station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub BeginFiscalReceipt ( _
    printHeader As Boolean _
)
public abstract void BeginFiscalReceipt (
    bool printHeader
)
public:
virtual void BeginFiscalReceipt (
    bool printHeader
) abstract
public abstract void BeginFiscalReceipt (
    boolean printHeader
)
public abstract function BeginFiscalReceipt (
    printHeader : boolean
)

Parameters

printHeader

Indicates whether to print the header lines currently.

Remarks

If printHeader and the CapIndependentHeader property are both true, all defined header lines are printed before control is returned. Otherwise, header lines are printed when the first item is sold.

If BeginFiscalReceipt is successful, the PrinterState property is changed to FiscalReceipt.

BeginFiscalReceipt may cause a PosControlException to be thrown with the following ErrorCode:

Value | Description
Busy | Cannot perform while output is in progress.
ExtendedErrorWrongState: | The printer’s current state does not allow this state transition.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
EndFiscalReceipt
CapIndependentHeader


FiscalPrinter.BeginFixedOutput Method

FiscalPrinter.BeginFixedOutput Method |
 | See Also

1/18/2008

Starts nonfiscal fixed text printing on a printer station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub BeginFixedOutput ( _
    station As FiscalReceiptStation, _
    documentType As Integer _
)
public abstract void BeginFixedOutput (
    FiscalReceiptStation station,
    int documentType
)
public:
virtual void BeginFixedOutput (
    FiscalReceiptStation station,
    int documentType
) abstract
public abstract void BeginFixedOutput (
    FiscalReceiptStation station,
    int documentType
)
public abstract function BeginFixedOutput (
    station : FiscalReceiptStation,
    documentType : int
)

Parameters

station

The printer station to be used. Can be either Receipt or Slip.

documentType

Identifier of a document stored in the printer.

Remarks

BeginFixedOutput is supported only if CapFixedOutput is true.

If the station parameter is Slip, the slip paper must be inserted into the slip station by using Begin/EndInsertion before it calls BeginFixedOutput.

Each fixed output is printed by using the PrintFixedOutput method. If BeginFixedOutput is successful, the PrinterState property is changed to FixedOutput. The EndFixedOutput method ends fixed output modality and resets PrinterState.

BeginFixedOutput may cause a PosControlException to be thrown with the following ErrorCode:

Value

Description

Busy

Cannot perform while output is in progress.

Illegal

One of the following errors occurred:

  • The slip station does not exist (see the CapSlpPresent property).

  • The printer does not support fixed output (see the CapFixedOutput property).

  • The station parameter is invalid.

  • The documentType parameter is invalid.

ExtendedErrorWrongState

The printer’s current state does not allow this state transition.

ExtendedErrorSlipEmpty

There is no paper in the slip station.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
EndFixedOutput
PrintFixedOutput


FiscalPrinter.BeginInsertion Method

FiscalPrinter.BeginInsertion Method |
 | See Also

1/18/2008

Starts slip processing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub BeginInsertion ( _
    timeout As Integer _
)
public abstract void BeginInsertion (
    int timeout
)
public:
virtual void BeginInsertion (
    int timeout
) abstract
public abstract void BeginInsertion (
    int timeout
)
public abstract function BeginInsertion (
    timeout : int
)

Parameters

timeout

Specifies the number of milliseconds before failing the method. If zero, BeginInsertion tries to begin insertion mode, then returns the appropriate status immediately. If WaitForever, BeginInsertion tries to begin insertion mode, then waits as long as needed until either the form is inserted or an error occurs.

Remarks

When it is called, the slip station is made ready to receive a form by opening the form's handling "jaws" or starting a form insertion mode. BeginInsertion is paired with the EndInsertion method for controlling form insertion.

If the printer device cannot be put into insertion mode, an error is returned to the application. Otherwise, the service object continues to monitor form insertion until one of the following results occurs:

  • The form is successfully inserted. In this case, the service object returns Success.

  • The form is not inserted before time-out milliseconds have elapsed, or an error is reported by the printer device. In this case, the service object returns either Timeout or another error. The printer device remains in form insertion mode. This enables an application to perform some user interaction and reissue the BeginInsertion method without altering the form-handling mechanism.

BeginInsertion may cause a PosControlException to be thrown with the following ErrorCode:

Value | Description
Busy | Cannot perform while output is in progress.
Illegal | The slip station does not exist (see the CapSlpPresent property).
Timeout | The specified time has elapsed without the form being correctly inserted.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
EndInsertion
BeginRemoval
EndRemoval


FiscalPrinter.BeginItemList Method

FiscalPrinter.BeginItemList Method |
 | See Also

1/18/2008

Starts a validation report of items that belong to a particular VAT class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub BeginItemList ( _
    vatId As Integer _
)
public abstract void BeginItemList (
    int vatId
)
public:
virtual void BeginItemList (
    int vatId
) abstract
public abstract void BeginItemList (
    int vatId
)
public abstract function BeginItemList (
    vatId : int
)

Parameters

vatId

VAT identifier for reporting.

Remarks

BeginItemList is supported only if CapItemList is true.

If BeginItemList is successful, the PrinterState property is changed to ItemList.

After the BeginItemList method, only VerifyItem and EndItemList methods can be called.

BeginItemList may cause a PosControlException exception to be thrown with the following ErrorCode:

Value

Description

Busy

Cannot perform while output is in progress.

Illegal

One of the following errors occurred:

  • The printer does not support an item list report (see the CapItemList property).

  • The printer does not support VAT tables (see the CapHasVatTable property).

ExtendedErrorWrongState

The printer's current state does not allow this state transition.

ExtendedErrorBadVat

The vatId parameter is invalid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
EndItemList
VerifyItem


FiscalPrinter.BeginNonFiscal Method

FiscalPrinter.BeginNonFiscal Method |
 | See Also

1/18/2008

Starts nonfiscal operations on the printer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub BeginNonFiscal
public abstract void BeginNonFiscal ()
public:
virtual void BeginNonFiscal () abstract
public abstract void BeginNonFiscal ()
public abstract function BeginNonFiscal ()

Remarks

BeginNonFiscal is supported only if CapNonFiscalMode is true. Output in this mode is performed by using the PrintNormal method.

BeginNonFiscal can be called only when the value of the PrinterState property is Monitor.

If BeginNonFiscal is successful, the PrinterState property is changed to Nonfiscal. To stop nonfiscal modality, call the EndNonFiscal method.

BeginNonFiscal may cause a PosControlException to be thrown with the following ErrorCode:

Value

Description

Busy

Cannot perform while output is in progress.

Illegal

One of the following errors occurred:

  • The printer does not support nonfiscal output (see the CapNonFiscalMode property).

ExtendedErrorWrongState

The printer’s current state does not allow this state transition.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
EndNonFiscal
PrintNormal


FiscalPrinter.BeginRemoval Method

FiscalPrinter.BeginRemoval Method |
 | See Also

1/18/2008

Starts form-removal processing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub BeginRemoval ( _
    timeout As Integer _
)
public abstract void BeginRemoval (
    int timeout
)
public:
virtual void BeginRemoval (
    int timeout
) abstract
public abstract void BeginRemoval (
    int timeout
)
public abstract function BeginRemoval (
    timeout : int
)

Parameters

timeout

Specifies the number of milliseconds before failing the method. If zero, BeginRemoval tries to begin removal mode, then immediately returns the appropriate status. If WaitForever, BeginRemoval tries to begin removal mode, then waits as long as needed until either the form is removed or an error occurs.

Remarks

When it is called, the printer is made ready to remove a form by opening the form-handling "jaws" or starting a form-ejection mode. BeginRemoval is paired with the EndRemoval method for controlling form removal.

If the printer device cannot be put into removal or ejection mode, an error is returned to the application. Otherwise, the service object continues to monitor form removal until one of the following results occurs:

  • The form is successfully removed. In this case, the service object returns a Success status.

  • The form is not removed before timeout milliseconds have elapsed, or an error is reported by the printer device. In this case, the service object either returns Timeout or another error. The printer device remains in form-removal mode. This enables an application to perform some user interaction and reissue the BeginRemoval method without altering the form-handling mechanism.

BeginRemoval may cause a PosControlException to be thrown with the following ErrorCode:

Value | Description
Busy | Cannot perform while output is in progress.
Illegal | The printer does not have a slip station (see the CapSlpPresent property).
Timeout | The specified time has elapsed without the form being properly removed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
FiscalPrinter.BeginInsertion Method
EndInsertion
EndRemoval


FiscalPrinter.BeginTraining Method

FiscalPrinter.BeginTraining Method |
 | See Also

1/18/2008

Starts training operations.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub BeginTraining
public abstract void BeginTraining ()
public:
virtual void BeginTraining () abstract
public abstract void BeginTraining ()
public abstract function BeginTraining ()

Remarks

BeginTraining is supported only if CapTrainingMode is true.

Output in this mode can be produced by using the PrintRec methods to print a receipt, or other methods to print reports.

BeginTraining can be successfully called only if the current value of the PrinterState property is Monitor.

If BeginTraining is successful, the TrainingModeActive property is changed to true.

BeginTraining may cause a PosControlException to be thrown with one of the following ErrorCodes:

Value | Description
Busy | Cannot perform while output is in progress.
Illegal | The printer does not support training mode (see the CapTrainingMode property).
ExtendedErrorWrongState | The printer’s current state does not allow this state transition.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
EndTraining


FiscalPrinter.ClearError Method

FiscalPrinter.ClearError Method |
 | See Also

1/18/2008

Clears all printer error conditions.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearError
public abstract void ClearError ()
public:
virtual void ClearError () abstract
public abstract void ClearError ()
public abstract function ClearError ()

Remarks

ClearError is always performed synchronously.

ClearError may cause a PosControlException exception to be thrown with the following ErrorCode:

Value | Description
Failure | Error recovery failed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.ClearOutput Method

FiscalPrinter.ClearOutput Method |
 | See Also

1/18/2008

Clears all buffered output data. This includes all asynchronous output.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearOutput
public abstract void ClearOutput ()
public:
virtual void ClearOutput () abstract
public abstract void ClearOutput ()
public abstract function ClearOutput ()

Remarks

When it is possible, stops outputs that are in progress. Any output error events that are queued and are usually waiting for FreezeEvents to be set to false are also cleared.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.EndFiscalDocument Method

FiscalPrinter.EndFiscalDocument Method |
 | See Also

1/18/2008

Stops fiscal printing to the slip station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub EndFiscalDocument
public abstract void EndFiscalDocument ()
public:
virtual void EndFiscalDocument () abstract
public abstract void EndFiscalDocument ()
public abstract function EndFiscalDocument ()

Remarks

EndFiscalDocument is supported only if CapSlpFiscalDocument is true.

If EndFiscalDocument is successful, the PrinterState property is changed to Monitor.

EndFiscalDocument may cause a PosControlException exception to be thrown with one of the following ErrorCodes:

Value | Description
Busy | Cannot perform while output is in progress.
Illegal | The printer does not support fiscal output to the slip station (see CapSlpFiscalDocument).
ExtendedErrorWrongState: | The printer is not in the FiscalDocument state.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
FiscalPrinter.BeginFiscalDocument Method
PrintFiscalDocumentLine


FiscalPrinter.EndFiscalReceipt Method

FiscalPrinter.EndFiscalReceipt Method |
 | See Also

1/18/2008

Stops fiscal printing to the receipt station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub EndFiscalReceipt ( _
    printHeader As Boolean _
)
public abstract void EndFiscalReceipt (
    bool printHeader
)
public:
virtual void EndFiscalReceipt (
    bool printHeader
) abstract
public abstract void EndFiscalReceipt (
    boolean printHeader
)
public abstract function EndFiscalReceipt (
    printHeader : boolean
)

Parameters

printHeader

Indicates whether to print the header lines currently.

Remarks

If printHeader is false, EndFiscalReceipt closes the current fiscal receipt, cuts it, and prints the trailer lines and fiscal logotype, if they were not already printed after the total lines. All functions performed by EndFiscalReceipt are completed before this call returns.

If EndFiscalReceipt is successful, the PrinterState property is changed to Monitor.

EndFiscalReceipt may cause a PosControlException to be thrown with the following ErrorCode:

Value | Description
Busy | Cannot perform while output is in progress.
ExtendedErrorWrongState | The printer is not in the Fiscal Receipt Ending state.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
FiscalPrinter.BeginFiscalReceipt Method
PrintRec…


FiscalPrinter.EndFixedOutput Method

FiscalPrinter.EndFixedOutput Method |
 | See Also

1/18/2008

Stops nonfiscal fixed text printing on a printer station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub EndFixedOutput
public abstract void EndFixedOutput ()
public:
virtual void EndFixedOutput () abstract
public abstract void EndFixedOutput ()
public abstract function EndFixedOutput ()

Remarks

EndFixedOutput is supported only if CapFixedOutput is true.

If EndFixedOutput is successful, the PrinterState property is changed to Monitor.

EndFixedOutput may cause a PosControlException exception to be thrown with one of the following ErrorCodes:

Value | Description
Busy | Cannot perform while output is in progress.
Illegal | The printer does not support fixed output (see the CapFixedOutput property).
ExtendedErrorWrongState | The printer is not in the Fixed Output state.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
FiscalPrinter.BeginFixedOutput Method
PrintFixedOutput


FiscalPrinter.EndInsertion Method

FiscalPrinter.EndInsertion Method |
 | See Also

1/18/2008

Ends form insertion processing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub EndInsertion
public abstract void EndInsertion ()
public:
virtual void EndInsertion () abstract
public abstract void EndInsertion ()
public abstract function EndInsertion ()

Remarks

When it is called, the printer is taken out of form insertion mode. If the slip device has forms "jaws," EndInsertion closes them. If a form is detected in the device, a successful status of Success is returned to the application. If no form is present, an extended error status ExtendedErrorSlipEmpty is returned.

EndInsertion is paired with the BeginInsertion method for controlling form insertion. The application may choose to call EndInsertion immediately after a successful BeginInsertion to use the printer sensors to determine when a form is positioned within the slip printer. Alternatively, the application may prompt the user and wait for a key press before it calls EndInsertion.

EndInsertion may cause a PosControlException exception to be thrown with one of the following ErrorCodes:

Value | Description
Illegal | The printer is not in slip insertion mode.
ExtendedErrorCoverOpen | The device was taken out of insertion mode while the printer cover was open.
ExtendedErrorSlipEmpty | The device was taken out of insertion mode without a form being inserted.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
FiscalPrinter.BeginInsertion Method
FiscalPrinter.BeginRemoval Method
EndRemoval


FiscalPrinter.EndItemList Method

FiscalPrinter.EndItemList Method |
 | See Also

1/18/2008

Closes a validation report of items that belong to a particular VAT class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub EndItemList
public abstract void EndItemList ()
public:
virtual void EndItemList () abstract
public abstract void EndItemList ()
public abstract function EndItemList ()

Remarks

EndItemList is supported only if CapItemList is true and CapHasVatTable is true.

EndItemList is paired with the BeginItemList method.

EndItemList can be successfully called only if current value of PrinterState property is equal to ItemList.

If EndItemList is successful, the PrinterState property is changed to Monitor.

EndItemList may cause a PosControlException to be thrown with one of the following ErrorCodes:

Value

Description

Busy

Cannot perform while output is in progress.

Illegal

One of the following errors occurred:

  • The printer does not support fixed output (see CapItemList).

  • The printer does not support VAT tables (see CapHasVatTable).

ExtendedErrorWrongState

The printer’s current state does not allow for this state transition.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
FiscalPrinter.BeginItemList Method
VerifyItem


FiscalPrinter.EndNonFiscal Method

FiscalPrinter.EndNonFiscal Method |
 | See Also

1/18/2008

Closes nonfiscal operations on one printer station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub EndNonFiscal
public abstract void EndNonFiscal ()
public:
virtual void EndNonFiscal () abstract
public abstract void EndNonFiscal ()
public abstract function EndNonFiscal ()

Remarks

EndNonFiscal is supported only if CapNonFiscalMode is true.

If EndNonFiscal is successful, the PrinterState property is changed to Monitor.

EndNonFiscal may cause a PosControlException to be thrown with one of the following ErrorCodes:

Value | Description
Busy | Cannot perform while output is in progress.
Illegal | The printer does not support nonfiscal output (see CapNonFiscalMode).
ExtendedErrorWrongState | The printer is not in the NonFiscal state.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
FiscalPrinter.BeginNonFiscal Method
PrintNormal


FiscalPrinter.EndRemoval Method

FiscalPrinter.EndRemoval Method |
 | See Also

1/18/2008

Ends form removal processing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub EndRemoval
public abstract void EndRemoval ()
public:
virtual void EndRemoval () abstract
public abstract void EndRemoval ()
public abstract function EndRemoval ()

Remarks

When it is called, the printer is taken out of form removal or ejection mode. If no form is detected in the device, a successful status of Success is returned to the application. If a form is present, an extended error status ExtendedErrorSlipForm is returned.

EndRemoval is paired with the BeginRemoval method for controlling form removal. The application may choose to call EndRemoval immediately after a successful BeginRemoval if it wants to use the printer sensors to determine when the form has been removed. Alternatively, the application may prompt the user and wait for a key press before it calls this method.

EndRemoval may cause a PosControlException to be thrown with one of the following ErrorCodes:

Value | Description
Illegal | The printer is not in slip removal mode.
ExtendedErrorSlipForm | The device was taken out of removal mode while a form was still present.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
FiscalPrinter.BeginInsertion Method
FiscalPrinter.EndInsertion Method
FiscalPrinter.BeginRemoval Method


FiscalPrinter.EndTraining Method

FiscalPrinter.EndTraining Method |
 | See Also

1/18/2008

Stops training operations on either the receipt or slip station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub EndTraining
public abstract void EndTraining ()
public:
virtual void EndTraining () abstract
public abstract void EndTraining ()
public abstract function EndTraining ()

Remarks

EndTraining is supported only if CapTrainingMode is true.

If EndTraining is successful, the TrainingModeActive property is changed to false.

EndTraining may cause a PosControlException to be thrown with one of the following ErrorCodes:

Value | Description
Busy | Cannot perform while output is in progress.
Illegal | The printer does not support training mode (see the CapTrainingMode property).
ExtendedErrorWrongState: | The printer is not in the Training state.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
FiscalPrinter.BeginTraining Method
PrintRecCash
PrintRecItem
PrintRecItemAdjustment
PrintRecItemFuel
PrintRecItemFuelVoid
PrintRecMessage
PrintRecNotPaid
PrintRecPackageAdjustment
PrintRecPackageAdjustVoid
PrintRecRefund
PrintRecRefundVoid
PrintRecSubtotal
PrintRecSubtotalAdjustment
PrintRecSubtotalAdjustVoid
PrintRecTaxId
PrintRecTotal
PrintRecVoid


FiscalPrinter.GetData Method

FiscalPrinter.GetData Method |
 | See Also

1/18/2008

Retrieves data and counters from the printer’s fiscal module.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function GetData ( _
    dataItem As FiscalData, _
    optArgs As Integer _
) As FiscalDataItem
public abstract FiscalDataItem GetData (
    FiscalData dataItem,
    int optArgs
)
public:
virtual FiscalDataItem GetData (
    FiscalData dataItem,
    int optArgs
) abstract
public abstract FiscalDataItem GetData (
    FiscalData dataItem,
    int optArgs
)
public abstract function GetData (
    dataItem : FiscalData,
    optArgs : int
) : FiscalDataItem

Parameters

dataItem

The specific FiscalData item to retrieve.

optArgs

For some dataItem types this additional argument may be needed. Contact the Service Object vendor's documentation for more information.

Return Value

A FiscalDataItem that contains the information retrieved.

Remarks

If CapMultiContractor is true, line counters depend on the contractor defined by the ContractorId property.

GetData may cause a PosControlException to be thrown with one of the following ErrorCodes:

Value | Description
Busy | Cannot perform while output is in progress.
Illegal | The dataItem specified is invalid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
FiscalData Enumeration
FiscalDataItem Structure


FiscalPrinter.GetDate Method

FiscalPrinter.GetDate Method |
 | See Also

1/18/2008

Gets the printer's date and time.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function GetDate As DateTime
public abstract DateTime GetDate ()
public:
virtual DateTime GetDate () abstract
public abstract DateTime GetDate ()
public abstract function GetDate () : DateTime

Remarks

The date and time are returned as a DateTime value.

GetDate may cause a PosControlException to be thrown with the following ErrorCode:

Value | Description
Illegal | The date and time cannot be retrieved currently.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.GetTotalizer Method

FiscalPrinter.GetTotalizer Method |
 | See Also

1/18/2008

Gets the totalizer associated with the specified vat id and totalizer type.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function GetTotalizer ( _
    vatId As Integer, _
    optArgs As FiscalTotalizer _
) As String
public abstract string GetTotalizer (
    int vatId,
    FiscalTotalizer optArgs
)
public:
virtual String^ GetTotalizer (
    int vatId,
    FiscalTotalizer optArgs
) abstract
public abstract String GetTotalizer (
    int vatId,
    FiscalTotalizer optArgs
)
public abstract function GetTotalizer (
    vatId : int,
    optArgs : FiscalTotalizer
) : String

Parameters

vatId

VAT identifier of the required totalizer.

optArgs

The totalizer type.

Remarks

If CapSetVatTable is false, then only one totalizer is present.

GetTotalizer may cause a PosControlException to be thrown with the following ErrorCode:

Value | Description
Illegal | The vatId parameter is invalid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.GetVatEntry Method

FiscalPrinter.GetVatEntry Method |
 | See Also

1/18/2008

Gets the rate associated with a given VAT identifier.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function GetVatEntry ( _
    vatId As Integer, _
    optArgs As Integer _
) As Integer
public abstract int GetVatEntry (
    int vatId,
    int optArgs
)
public:
virtual int GetVatEntry (
    int vatId,
    int optArgs
) abstract
public abstract int GetVatEntry (
    int vatId,
    int optArgs
)
public abstract function GetVatEntry (
    vatId : int,
    optArgs : int
) : int

Parameters

vatId

VAT identifier of the required rate.

optArgs

Rate associated with the VAT identifier.

Remarks

GetVatEntry is supported only if CapSetVatTable is true.

GetVatEntry may cause a PosControlException to be thrown with the following ErrorCode:

Value | Description
Illegal | The vatId parameter is invalid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.PrintDuplicateReceipt Method

FiscalPrinter.PrintDuplicateReceipt Method |
 | See Also

1/18/2008

Prints a duplicate of a buffered transaction.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintDuplicateReceipt
public abstract void PrintDuplicateReceipt ()
public:
virtual void PrintDuplicateReceipt () abstract
public abstract void PrintDuplicateReceipt ()
public abstract function PrintDuplicateReceipt ()

Remarks

PrintDuplicateReceipt is supported only if CapDuplicateReceipt is true.

PrintDuplicateReceipt succeeds if both the CapDuplicateReceipt and DuplicateReceipt properties are true.

PrintDuplicateReceipt resets the DuplicateReceipt property to false.

PrintDuplicateReceipt may cause a PosControlException to be thrown with one of the following ErrorCodes:

Value

Description

Busy

Cannot perform while output is in progress. (Can be returned only if AsyncMode is false.)

Illegal

One of the following errors occurred:

  • The printer does not support duplicate receipts (see the CapDuplicateReceipt property).

  • There is no buffered transaction to print (see DuplicateReceipt property).

ExtendedErrorWrongState

The printer is not in the Monitor state.

ExtendedErrorJournalEmpty

The journal station is out of paper.

ExtendedErrorReceiptEmpty

The receipt station is out of paper.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.PrintFiscalDocumentLine Method

FiscalPrinter.PrintFiscalDocumentLine Method |
 | See Also

1/18/2008

Prints a line of fiscal text to the slip station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintFiscalDocumentLine ( _
    documentLine As String _
)
public abstract void PrintFiscalDocumentLine (
    string documentLine
)
public:
virtual void PrintFiscalDocumentLine (
    String^ documentLine
) abstract
public abstract void PrintFiscalDocumentLine (
    String documentLine
)
public abstract function PrintFiscalDocumentLine (
    documentLine : String
)

Parameters

documentLine

String to be printed on the fiscal slip.

Remarks

PrintFiscalDocumentLine is supported only if CapSlpFiscalDocument is true.

PrintFiscalDocumentLine is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

PrintFiscalDocumentLine may cause a PosControlException to be thrown with one of the following ErrorCodes:

Value | Description
Busy | Cannot perform while output is in progress. (Can be returned only if AsyncMode is false.)
Illegal | The printer does not support fiscal documents (see the CapSlpFiscalDocument property).
ExtendedErrorWrongState: | The printer is not in the FiscalDocument state.
ExtendedErrorCoverOpen: | The printer cover is open.(Can be returned only if AsyncMode is false.)
ExtendedErrorSlipEmpty: | The slip station was specified, but a form is not inserted.(Can be returned only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
FiscalPrinter.BeginFiscalDocument Method
FiscalPrinter.EndFiscalDocument Method


FiscalPrinter.PrintFixedOutput Method

FiscalPrinter.PrintFixedOutput Method |
 | See Also

1/18/2008

Prints a line of a fixed document to the print station specified in the BeginFixedOutput method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintFixedOutput ( _
    documentType As Integer, _
    lineNumber As Integer, _
    data As String _
)
public abstract void PrintFixedOutput (
    int documentType,
    int lineNumber,
    string data
)
public:
virtual void PrintFixedOutput (
    int documentType,
    int lineNumber,
    String^ data
) abstract
public abstract void PrintFixedOutput (
    int documentType,
    int lineNumber,
    String data
)
public abstract function PrintFixedOutput (
    documentType : int,
    lineNumber : int,
    data : String
)

Parameters

documentType

Identifier of a document stored in the printer.

lineNumber

Number of the line in the document to print.

data

String parameter for placement in printed line.

Remarks

Each call prints a single line from a document by merging the stored text with the parameter data. Within a document, lines must be printed sequentially. Some lines are optional and some lines are required, such as the first and last lines.

PrintFixedOutput is supported only if CapFixedOutput is true.

The printer state is set to FixedOutput.

PrintFixedOutput is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

PrintFixedOutput may cause a PosControlException to be thrown with one of the following ErrorCodes:

Value

Description

Busy

Cannot perform while output is in progress. (Can be returned only if AsyncMode is false.)

Illegal

One of the following errors occurred:

  • The printer does not support fixed output (see the CapFixedOutput property).

  • The LineNumber is invalid.

ExtendedErrorWrongState:

The printer is not in the FixedOutput state.

ExtendedErrorCoverOpen:

The printer cover is open. (Can be returned only if AsyncMode is false.)

ExtendedErrorJournalEmpty:

The journal station is out of paper. (Can be returned only if AsyncMode is false.)

ExtendedErrorReceiptEmpty:

The receipt station was specified but is out of paper. (Can be returned only if AsyncMode is false.)

ExtendedErrorSlipEmpty:

The slip station was specified, but a form is not inserted. (Can be returned only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
FiscalPrinter.BeginFixedOutput Method
FiscalPrinter.EndFixedOutput Method


FiscalPrinter.PrintNormal Method

FiscalPrinter.PrintNormal Method |
 | See Also

1/18/2008

Prints data on the printer station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintNormal ( _
    station As FiscalPrinterStations, _
    data As String _
)
public abstract void PrintNormal (
    FiscalPrinterStations station,
    string data
)
public:
virtual void PrintNormal (
    FiscalPrinterStations station,
    String^ data
) abstract
public abstract void PrintNormal (
    FiscalPrinterStations station,
    String data
)
public abstract function PrintNormal (
    station : FiscalPrinterStations,
    data : String
)

Parameters

station

The printer station to use (Receipt, Journal, JournalReceipt, or Slip).

data

The characters to print, consisting mostly of printable characters.

Remarks

PrintNormal performs nonfiscal printing. Escape sequences, carriage returns (13 decimal), and new line / line feed (10 decimal) are available on some printers, but frequently these are not supported.

PrintNormal is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

Special character values within data is as follows:

Value

Description

New line / Line Feed (10 Decimal)

Print any data in the line buffer, and feed to the next print line. (A carriage return is not required in order to cause the line to be printed.)

Carriage Return (13 Decimal)

If a carriage return immediately comes before a line feed, or if the line buffer is empty, then it is ignored.

Otherwise, the line buffer is printed and the printer does not feed to the next print line. On some printers, print without feed may be directly supported. On others, a print may always feed to the next line. In this case, the service object prints the line buffer and performs a reverse line feed if supported. If the printer does not support either of these features, carriage return functions like a line feed.

PrintNormal may cause a PosControlException to be thrown with one of the following ErrorCodes:

Value | Description
Busy | Cannot perform while output is in progress. (Can only be returned if AsyncMode is false.)
Illegal | The specified station does not exist. (See the CapSlpPresent property.)
ExtendedErrorWrongState | The printer is not in the NonFiscal state.
ExtendedErrorCoverOpen | The printer cover is open. (Can only be returned if AsyncMode is false.)
ExtendedErrorJournalEmpty | The journal station was specified but is out of paper. (Can only be returned if AsyncMode is false.)
ExtendedErrorReceiptEmpty | The receipt station was specified but is out of paper. (Can only be returned if AsyncMode is false.)
ExtendedErrorSlipEmpty | The slip station was specified, but a form is not inserted. (Can only be returned if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
FiscalPrinter.BeginNonFiscal Method
FiscalPrinter.EndNonFiscal Method
AsyncMode


FiscalPrinter.PrintPeriodicTotalsReport Method

FiscalPrinter.PrintPeriodicTotalsReport Method |
 | See Also

1/18/2008

Prints a report of totals for a range of dates on the receipt.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintPeriodicTotalsReport ( _
    startingDate As DateTime, _
    endingDate As DateTime _
)
public abstract void PrintPeriodicTotalsReport (
    DateTime startingDate,
    DateTime endingDate
)
public:
virtual void PrintPeriodicTotalsReport (
    DateTime startingDate,
    DateTime endingDate
) abstract
public abstract void PrintPeriodicTotalsReport (
    DateTime startingDate,
    DateTime endingDate
)
public abstract function PrintPeriodicTotalsReport (
    startingDate : DateTime,
    endingDate : DateTime
)

Parameters

startingDate

Starting date of report to print.

endingDate

Ending date of report to print.

Remarks

PrintPeriodicTotalsReport is always performed synchronously.

PrintPeriodicTotalsReport may cause a PosControlException to be thrown with the following ErrorCode:

Value | Description
Busy | Cannot perform while output is in progress
ExtendedErrorWrongState: | The printer’s current state does not allow for this state transition.
ExtendedErrorJournalEmpty: | The journal station is out of paper.
ExtendedErrorReceiptEmpty: | The receipt station is out of paper.
ExtendedErrorBadDate: | One of the date parameters is invalid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.PrintPowerLossReport Method

FiscalPrinter.PrintPowerLossReport Method |
 | See Also

1/18/2008

Prints on the receipt a report of a power failure that resulted in a loss of data that is stored in the CMOS of the printer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintPowerLossReport
public abstract void PrintPowerLossReport ()
public:
virtual void PrintPowerLossReport () abstract
public abstract void PrintPowerLossReport ()
public abstract function PrintPowerLossReport ()

Remarks

PrintPowerLossReport is supported only if CapPowerLossReport is true.

PrintPowerLossReport is always performed synchronously.

PrintPowerLossReport may cause a PosControlException to be thrown with one of the following ErrorCodes:

Value | Description
Busy | Cannot perform while output is in progress.
Illegal | The printer does not support power loss reports (see the CapPowerLossReport property).
ExtendedErrorWrongState | The printer's current state does not allow this state transition.
ExtendedErrorCoverOpen | The printer cover is open.
ExtendedErrorJournalEmpty | The journal station is out of paper.
ExtendedErrorReceiptEmpty | The receipt station is out of paper.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.PrintRecCash Method

FiscalPrinter.PrintRecCash Method |
 | See Also

1/18/2008

Prints a cash-in or cash-out receipt amount on the station defined by the FiscalReceiptStation property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintRecCash ( _
    amount As Decimal _
)
public abstract void PrintRecCash (
    decimal amount
)
public:
virtual void PrintRecCash (
    Decimal amount
) abstract
public abstract void PrintRecCash (
    Decimal amount
)
public abstract function PrintRecCash (
    amount : decimal
)

Parameters

amount

Amount to be incremented or decremented.

Remarks

PrintRecCash is only allowed if CapFiscalReceiptType is true and the FiscalReceiptType property is set to CashIn or CashOut (replaces the FPTR_RT_CASH_IN and FPTR_RT_CASH_OUT UPOS constants) and the fiscal printer is in the Fiscal Receipt state.

PrintRecCash is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

PrintRecCash may cause a PosControlException to be thrown with one of the following ErrorCodes:

Value | Description
Busy | Cannot perform while output is in progress. (Applies only if AsyncMode is false.)
Illegal | The printer does not support this method.
ExtendedErrorWrongState | The printer is currently not in the Fiscal Receipt state.
ExtendedErrorCoverOpen | The printer cover is open. (Applies only if AsyncMode is false.)
ExtendedErrorJournalEmpty | The journal station is out of paper. (Applies only if AsyncMode is false.)
ExtendedErrorReceiptEmpty | The receipt station is out of paper.
ExtendedErrorSlipEmpty | The slip station was specified, but a form is not inserted. (Applies only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
FiscalPrinter.BeginFiscalReceipt Method
FiscalReceiptStation
FiscalReceiptType


FiscalPrinter.PrintRecItem Method

FiscalPrinter.PrintRecItem Method |
 | See Also

1/18/2008

Prints a receipt item for a sold item on the station specified by the FiscalReceiptStation property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintRecItem ( _
    description As String, _
    price As Decimal, _
    quantity As Integer, _
    vatInfo As Integer, _
    unitPrice As Decimal, _
    unitName As String _
)
public abstract void PrintRecItem (
    string description,
    decimal price,
    int quantity,
    int vatInfo,
    decimal unitPrice,
    string unitName
)
public:
virtual void PrintRecItem (
    String^ description,
    Decimal price,
    int quantity,
    int vatInfo,
    Decimal unitPrice,
    String^ unitName
) abstract
public abstract void PrintRecItem (
    String description,
    Decimal price,
    int quantity,
    int vatInfo,
    Decimal unitPrice,
    String unitName
)
public abstract function PrintRecItem (
    description : String,
    price : decimal,
    quantity : int,
    vatInfo : int,
    unitPrice : decimal,
    unitName : String
)

Parameters

description

Text describing the item sold.

price

Price of the line item.

quantity

Number of items. If zero, a single item is assumed.

vatInfo

VAT rate identifier. If not used, a zero is transferred.

unitPrice

Price of each item. If not used, a zero is transferred.

unitName

Name of the unit; for example, "kg" or "ltr" or "pcs". If not used, an empty string ("") is transferred.

Remarks

If the quantity parameter is zero, a single item quantity is assumed.

The vatId parameter contains a VAT table identifier if CapHasVatTable is true.

Minimum parameters are description and price or description, price, quantity, and unitPrice. Most countries or regions require quantity and vatRate and some countries or regions also require unitPrice and unitName.

PrintRecItem is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

If CapPostPreLine is true, additional application-specific lines defined by the PostLine and PreLine properties will be printed. After printing these lines PostLine and PreLine are reset to an empty string.

PrintRecItem may cause a PosControlException to be thrown with the following ErrorCode:

Value | Description
Busy | Cannot perform while output is in progress. (Can only be returned if AsyncMode is false.)
ExtendedErrorWrongState | The printer is not in the FiscalReceipt state.
ExtendedErrorCoverOpen | The printer cover is open. (Can be returned only if AsyncMode is false.)
ExtendedErrorJournalEmpty | The journal station is out of paper. (Can be returned only if AsyncMode is false.)
ExtendedErrorReceiptEmpty | The receipt station is out of paper. (Can be returned only if AsyncMode is false.)
ExtendedErrorBadItemQuantity | The quantity is invalid. (Can be returned only if AsyncMode is false.)
ExtendedErrorBadPrice | The unit price is invalid. (Can be returned only if AsyncMode is false.)
ExtendedErrorBadItemDescription | The discount description is too long or contains a reserved word. (Can be returned only if AsyncMode is false.)
ExtendedErrorBadVat | The vatRate parameter is invalid. (Can be returned only if AsyncMode is false.)
ExtendedErrorReceiptTotalOverflow | The receipt total has overflowed. (Can be returned only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
SetVatTable
SetVatValue


FiscalPrinter.PrintRecItemAdjustment Method

FiscalPrinter.PrintRecItemAdjustment Method |
 | See Also

1/18/2008

Applies and prints a discount or a surcharge to the last receipt item sold.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintRecItemAdjustment ( _
    adjustmentType As FiscalAdjustment, _
    description As String, _
    amount As Decimal, _
    vatInfo As Integer _
)
public abstract void PrintRecItemAdjustment (
    FiscalAdjustment adjustmentType,
    string description,
    decimal amount,
    int vatInfo
)
public:
virtual void PrintRecItemAdjustment (
    FiscalAdjustment adjustmentType,
    String^ description,
    Decimal amount,
    int vatInfo
) abstract
public abstract void PrintRecItemAdjustment (
    FiscalAdjustment adjustmentType,
    String description,
    Decimal amount,
    int vatInfo
)
public abstract function PrintRecItemAdjustment (
    adjustmentType : FiscalAdjustment,
    description : String,
    amount : decimal,
    vatInfo : int
)

Parameters

adjustmentType

Type of discount.

description

Text that describes the discount.

amount

Amount of the discount.

vatInfo

VAT rate identifier.

Remarks

The vatInfo parameter contains an index to the table of VAT values created by SetVatTable and SetVatValue.

Called to apply and print a discount or a surcharge to the last receipt item sold. This discount can be either a fixed currency amount or a percentage amount that relates to the last item.

If CapOrderAdjustmentFirst is true, PrintRecItemAdjustment must be called before the corresponding PrintRecItem method. If CapOrderAdjustmentFirst is false, PrintRecItemAdjustment must be called after the PrintRecItem.

This discount or surcharge can be either a fixed currency amount or a percentage amount that relates to the last item. If the discount amount is greater than the receipt subtotal, an error occurs because the subtotal can never be negative. In many countries or regions, discount operations cause the printing of a fixed line of text expressing the kind of operation that has been performed.

Fixed amount discounts/surcharges are supported only if CapAmountAdjustment is true.

Percentage discounts are supported only if CapPercentAdjustment is true.

PrintRecItemAdjustment is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

PrintRecItemAdjustment may cause a PosControlException to be thrown with one of the following values:

Value | Description
Busy | Cannot perform while output is in progress. (Can be returned only if AsyncMode is false.)
Illegal | One of the following errors occurred: The printer does not support fixed amount adjustments (see the CapAmountAdjustment property). The printer does not support percentage discounts (see the CapPercentAdjustment property). The adjustmentType parameter is invalid.
ExtendedErrorWrongState | The printer is not in the FiscalReceipt state.
ExtendedErrorCoverOpen | The printer cover is open. (Can be returned only if AsyncMode is false.)
ExtendedErrorJournalEmpty | The journal station is out of paper. (Can be returned only if AsyncMode is false.)
ExtendedErrorReceiptEmpty | The receipt station is out of paper. (Can be returned only if AsyncMode is false.)
ExtendedErrorBadItemAmount | The discount amount is invalid. (Can be returned only if AsyncMode is false.)
ExtendedErrorBadItemDescription | The discount description is too long or contains a reserved word. (Can be returned only if AsyncMode is false.)
ExtendedErrorBadVat | The VAT parameter is invalid. (Can be returned only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
SetVatTable
SetVatValue


FiscalPrinter.PrintRecItemAdjustmentVoid Method

FiscalPrinter.PrintRecItemAdjustmentVoid Method |
 | See Also

1/18/2008

Takes a VAT rate identifier that corresponds to an entry in the VAT table.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintRecItemAdjustmentVoid ( _
    adjustmentType As FiscalAdjustment, _
    description As String, _
    amount As Decimal, _
    vatInfo As Integer _
)
public abstract void PrintRecItemAdjustmentVoid (
    FiscalAdjustment adjustmentType,
    string description,
    decimal amount,
    int vatInfo
)
public:
virtual void PrintRecItemAdjustmentVoid (
    FiscalAdjustment adjustmentType,
    String^ description,
    Decimal amount,
    int vatInfo
) abstract
public abstract void PrintRecItemAdjustmentVoid (
    FiscalAdjustment adjustmentType,
    String description,
    Decimal amount,
    int vatInfo
)
public abstract function PrintRecItemAdjustmentVoid (
    adjustmentType : FiscalAdjustment,
    description : String,
    amount : decimal,
    vatInfo : int
)

Parameters

adjustmentType

Type of adjustment to be voided. See FiscalAdjustment for descriptions of the possible values.

description

Text describing the adjustment to be voided.

amount

Amount of the adjustment to be voided. If a currency value was specified by the adjustmentType, four decimal places are used.

vatInfo

VAT rate identifier.

Remarks

This overload takes a VAT rate identifier that corresponds to an entry in the VAT table.

Used if the CapHasVatTable property is set to true.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
SetVatTable
SetVatValue


FiscalPrinter.PrintRecItemFuel Method

FiscalPrinter.PrintRecItemFuel Method |
 | See Also

1/18/2008

Prints a receipt fuel item on the station specified by the FiscalReceiptStation property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintRecItemFuel ( _
    description As String, _
    price As Decimal, _
    quantity As Integer, _
    vatInfo As Integer, _
    unitPrice As Decimal, _
    unitName As String, _
    specialTax As Decimal, _
    specialTaxName As String _
)
public abstract void PrintRecItemFuel (
    string description,
    decimal price,
    int quantity,
    int vatInfo,
    decimal unitPrice,
    string unitName,
    decimal specialTax,
    string specialTaxName
)
public:
virtual void PrintRecItemFuel (
    String^ description,
    Decimal price,
    int quantity,
    int vatInfo,
    Decimal unitPrice,
    String^ unitName,
    Decimal specialTax,
    String^ specialTaxName
) abstract
public abstract void PrintRecItemFuel (
    String description,
    Decimal price,
    int quantity,
    int vatInfo,
    Decimal unitPrice,
    String unitName,
    Decimal specialTax,
    String specialTaxName
)
public abstract function PrintRecItemFuel (
    description : String,
    price : decimal,
    quantity : int,
    vatInfo : int,
    unitPrice : decimal,
    unitName : String,
    specialTax : decimal,
    specialTaxName : String
)

Parameters

description

Text that describes the fuel product.

price

Price of the fuel item.

quantity

Number of items. If zero, a single item is assumed.

vatInfo

VAT rate identifier.

unitPrice

Price of the fuel item per volume.

unitName

Name of the volume unit (for example, "ltr").

specialTax

Special tax amount (for example, road tax).

specialTaxName

Name of the special tax.

Remarks

The vatId parameter contains an index to the table of VAT values created by SetVatTable and SetVatValue.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
SetVatTable
SetVatValue


FiscalPrinter.PrintRecItemFuelVoid Method

FiscalPrinter.PrintRecItemFuelVoid Method |
 | See Also

1/18/2008

Voids a fuel item on the station specified by the FiscalReceiptStation property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintRecItemFuelVoid ( _
    description As String, _
    price As Decimal, _
    vatInfo As Integer, _
    specialTax As Decimal _
)
public abstract void PrintRecItemFuelVoid (
    string description,
    decimal price,
    int vatInfo,
    decimal specialTax
)
public:
virtual void PrintRecItemFuelVoid (
    String^ description,
    Decimal price,
    int vatInfo,
    Decimal specialTax
) abstract
public abstract void PrintRecItemFuelVoid (
    String description,
    Decimal price,
    int vatInfo,
    Decimal specialTax
)
public abstract function PrintRecItemFuelVoid (
    description : String,
    price : decimal,
    vatInfo : int,
    specialTax : decimal
)

Parameters

description

Text that describes the fuel product.

price

Price of the fuel item.

vatInfo

VAT table identifier.

specialTax

Special tax amount (for example, road tax).

Remarks

The vatInfo parameter contains an index to the table of VAT values created by SetVatTable and SetVatValue.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
SetVatTable
SetVatValue


FiscalPrinter.PrintRecItemRefund Method

FiscalPrinter.PrintRecItemRefund Method |
 | See Also

1/18/2008

Processes one or more item refunds.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Sub PrintRecItemRefund ( _
    description As String, _
    amount As Decimal, _
    quantity As Integer, _
    vatInfo As Integer, _
    unitAmount As Decimal, _
    unitName As String _
)
public virtual void PrintRecItemRefund (
    string description,
    decimal amount,
    int quantity,
    int vatInfo,
    decimal unitAmount,
    string unitName
)
public:
virtual void PrintRecItemRefund (
    String^ description,
    Decimal amount,
    int quantity,
    int vatInfo,
    Decimal unitAmount,
    String^ unitName
)
public void PrintRecItemRefund (
    String description,
    Decimal amount,
    int quantity,
    int vatInfo,
    Decimal unitAmount,
    String unitName
)
public function PrintRecItemRefund (
    description : String,
    amount : decimal,
    quantity : int,
    vatInfo : int,
    unitAmount : decimal,
    unitName : String
)

Parameters

description

Text describing the refund.

amount

The amount of the refund line.

quantity

Number of items. If zero, a single item is assumed.

vatInfo

VAT rate identifier or amount. If not used a zero must be transferred.

unitAmount

Amount of each refund item. If not used a zero must be transferred.

unitName

Name of the unit i.e., “kg” or “ltr” or “pcs”. If not used an empty string (“”) must be transferred.

Remarks

The amount is positive, but it is printed as a negative number and the totals registers are decremented.

If unitAmount and quantity are non-zero then the amount parameter corresponds to the product of quantity and unitAmount. Otherwise this method has the same functionality as the method PrintRecRefund.

Some fixed text, along with the description, will be printed on the station defined by the FiscalReceiptStation property to indicate that a refund has occurred.

The vatInfo parameter contains a VAT table identifier if CapHasVatTable is true. Otherwise it contains a VAT amount.

If CapPostPreLine is true an additional application specific line defined by the PreLine property will be printed. After printing this line, PreLine will be reset to an empty string.

This method is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.PrintRecItemRefundVoid Method

FiscalPrinter.PrintRecItemRefundVoid Method |
 | See Also

1/18/2008

Processes a void of one or more item refunds.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Sub PrintRecItemRefundVoid ( _
    description As String, _
    amount As Decimal, _
    quantity As Integer, _
    vatInfo As Integer, _
    unitAmount As Decimal, _
    unitName As String _
)
public virtual void PrintRecItemRefundVoid (
    string description,
    decimal amount,
    int quantity,
    int vatInfo,
    decimal unitAmount,
    string unitName
)
public:
virtual void PrintRecItemRefundVoid (
    String^ description,
    Decimal amount,
    int quantity,
    int vatInfo,
    Decimal unitAmount,
    String^ unitName
)
public void PrintRecItemRefundVoid (
    String description,
    Decimal amount,
    int quantity,
    int vatInfo,
    Decimal unitAmount,
    String unitName
)
public function PrintRecItemRefundVoid (
    description : String,
    amount : decimal,
    quantity : int,
    vatInfo : int,
    unitAmount : decimal,
    unitName : String
)

Parameters

description

Text describing the refund.

amount

The amount of the refund line.

quantity

Number of items. If zero, a single item is assumed.

vatInfo

VAT rate identifier or amount. If not used a zero must be transferred.

unitAmount

Amount of each refund item. If not used a zero must be transferred.

unitName

Name of the unit i.e., “kg” or “ltr” or “pcs”. If not used an empty string (“”) must be transferred.

Remarks

The amount is positive and the totals registers are incremented.

If unitAmount and quantity are non-zero then the amount parameter corresponds to the product of quantity and unitAmount. Otherwise this method has the same functionality as the method PrintRecRefundVoid.

Some fixed text, along with the description, will be printed on the station defined by the FiscalReceiptStation property to indicate that a void of a refund has occurred.

The vatInfo parameter contains a VAT table identifier if CapHasVatTable is true. Otherwise it contains a VAT amount.

If CapOnlyVoidLastItem is true, only the last refund item transferred to the Fiscal Printer can be voided.

This method is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.PrintRecItemVoid Method

FiscalPrinter.PrintRecItemVoid Method |
 | See Also

1/18/2008

Cancels one or more items that has been added to the receipt and prints a void description on the station defined by the FiscalReceiptStation property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintRecItemVoid ( _
    description As String, _
    price As Decimal, _
    quantity As Integer, _
    vatInfo As Integer, _
    unitPrice As Decimal, _
    unitName As String _
)
public abstract void PrintRecItemVoid (
    string description,
    decimal price,
    int quantity,
    int vatInfo,
    decimal unitPrice,
    string unitName
)
public:
virtual void PrintRecItemVoid (
    String^ description,
    Decimal price,
    int quantity,
    int vatInfo,
    Decimal unitPrice,
    String^ unitName
) abstract
public abstract void PrintRecItemVoid (
    String description,
    Decimal price,
    int quantity,
    int vatInfo,
    Decimal unitPrice,
    String unitName
)
public abstract function PrintRecItemVoid (
    description : String,
    price : decimal,
    quantity : int,
    vatInfo : int,
    unitPrice : decimal,
    unitName : String
)

Parameters

description

Text describing the item to be voided.

price

Price of the item to be voided.

quantity

Quantity of item to be voided. If zero, a single item is assumed.

vatInfo

VAT rate identifier.

unitPrice

Price of each item. If not used, a zero must be transferred.

unitName

Name of the unit (for example: "kg" or "ltr" or "pcs"). If not used, an empty string ("") must be transferred.

Remarks

Cancels one or more items that has been added to the receipt and prints a void description on the station defined by the FiscalReceiptStation property. Minimum parameters are description and price or description, quantity, and unitPrice. Most countries or regions require quantity and vatInfo and some countries or regions also require unitPrice and unitName.

If price is a positive number, it is printed as a negative and is decremented from the totals registers. In some countries or regions, price is ignored, instead the computation from quantity and unitPrice are printed as a negative amount.

The vatInfo parameter contains a VAT table identifier if CapHasVatTable is true. Otherwise, it contains a VAT amount.

If CapOnlyVoidLastItem is true, only the last item transferred to the Fiscal Printer can be voided exclusive an adjustment line for this item.

If CapPostPreLine is true, additional application specific lines defined by the PostLine and PreLine properties will be printed. After printing these lines, PostLine and PreLine will be reset to an empty string.

This method is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

PrintRecItemVoid can raise general exceptions as well as the following specific exceptions:

Value | Meaning
Busy | Cannot perform while output is in progress. (Only applies if AsyncMode is false.)
Illegal | Canceling is not allowed at this ticket state. May be because no item has been sold previously. (See CapOnlyVoidLastItem.)
ExtendedErrorWrongState | The Fiscal Printer is not currently in the FiscalReceipt state.
ExtendedErrorCoverOpen | The printer cover is open. (Can be returned only if AsyncMode is false.)
ExtendedErrorJournalEmpty | The journal station is out of paper. (Can be returned only if AsyncMode is false.)
ExtendedErrorReceiptEmpty | The receipt station is out of paper. (Can be returned only if AsyncMode is false.)
ExtendedErrorSlipEmpty | The slip station was specified, but a form is not inserted. (Applies only if AsyncMode is false.)
ExtendedErrorBadItemAmount | The price is invalid. (Can be returned only if AsyncMode is false.)
ExtendedErrorBadItemQuantity | The quantity is invalid. (Can be returned only if AsyncMode is false.)
ExtendedErrorBadVat | The VAT information is invalid. (Can be returned only if AsyncMode is false.)
ExtendedErrorBadItemDescription | The description is too long or contains a reserved word. (Can be returned only if AsyncMode is false.)
ExtendedErrorNegativeTotal | The computed total is less than zero. (Can be returned only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.PrintRecMessage Method

FiscalPrinter.PrintRecMessage Method |
 | See Also

1/18/2008

Prints a message on the fiscal receipt.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintRecMessage ( _
    message As String _
)
public abstract void PrintRecMessage (
    string message
)
public:
virtual void PrintRecMessage (
    String^ message
) abstract
public abstract void PrintRecMessage (
    String message
)
public abstract function PrintRecMessage (
    message : String
)

Parameters

message

Text message to print.

Remarks

The length of an individual message is limited to the number of characters given in the MessageLength property.

This method is supported only if CapAdditionalLines is true.

This method is supported only when the printer is in the FiscalReceiptEnding state.

This method is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

PrintRecMessage may cause a PosControlException to be thrown with one of the following ErrorCodes:

Value | Description
Busy | Cannot perform while output is in progress. (Can be returned only if AsyncMode is false.)
ExtendedErrorWrongState: | The printer is not in the FiscalReceiptEnding state.
ExtendedErrorCoverOpen: | The printer cover is open. (Can be returned only if AsyncMode is false.)
ExtendedErrorJournalEmpty: | The journal station is out of paper. (Can be returned only if AsyncMode is false.)
ExtendedErrorReceiptEmpty: | The receipt station is out of paper. (Can be returned only if AsyncMode is false.)
ExtendedErrorBadItemDescription: | The message is too long or contains a reserved word. (Can be returned only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
FiscalPrinter.BeginFiscalReceipt Method
FiscalPrinter.EndFiscalReceipt Method
MessageLength
CapAdditionalLines
FiscalPrinter.PrintRecCash Method
PrintRecItem
PrintRecItem
PrintRecItemAdjustment
FiscalPrinter.PrintRecItemAdjustment Method
PrintRecItemFuel
PrintRecItemFuel
PrintRecItemFuelVoid
FiscalPrinter.PrintRecItemFuelVoid Method
PrintRecNotPaid
PrintRecPackageAdjustment
PrintRecPackageAdjustVoid
PrintRecRefund
PrintRecRefund
PrintRecRefundVoid
PrintRecRefundVoid
PrintRecSubtotal
PrintRecSubtotalAdjustment
PrintRecSubtotalAdjustVoid
PrintRecTaxId
PrintRecTotal
PrintRecVoid


FiscalPrinter.PrintRecNotPaid Method

FiscalPrinter.PrintRecNotPaid Method |
 | See Also

1/18/2008

Indicates a part of the receipt's total that is unpaid.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintRecNotPaid ( _
    description As String, _
    amount As Decimal _
)
public abstract void PrintRecNotPaid (
    string description,
    decimal amount
)
public:
virtual void PrintRecNotPaid (
    String^ description,
    Decimal amount
) abstract
public abstract void PrintRecNotPaid (
    String description,
    Decimal amount
)
public abstract function PrintRecNotPaid (
    description : String,
    amount : decimal
)

Parameters

description

Text that describes the unpaid amount.

amount

Amount not paid.

Remarks

Some fixed text, together with the description, is printed on the receipt and journal to indicate that part of the receipt total has not been paid. PrintRecNotPaid is supported only if CapReceiptNotPaid is true.

PrintRecNotPaid is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

If PrintRecNotPaid is successful, the PrinterState property is changed to either FiscalReceiptTotal or FiscalReceiptEnding depending on whether the receipt total is now accounted for.

PrintRecNotPaid may cause a PosControlException to be thrown with one of the following ErrorCodes:

Value | Description
Busy | Cannot perform while output is in progress. (Can be returned only if AsyncMode is false.)
ExtendedErrorWrongState | The printer is not in either the FiscalReceipt or the FiscalReceiptTotal state.
ExtendedErrorCoverOpen | The printer cover is open. (Can be returned only if AsyncMode is false.)
ExtendedErrorJournalEmpty | The journal station is out of paper. (Can be returned only if AsyncMode is false.)
ExtendedErrorReceiptEmpty | The receipt station is out of paper. (Can be returned only if AsyncMode is false.)
ExtendedErrorBadItemDescription | The description is too long or contains a reserved word. (Can be returned only if AsyncMode is false.)
ExtendedErrorBadItemAmount | The amount is invalid. Can be returned only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
AmountDecimalPlaces
CapReceiptNotPaid
FiscalReceiptStation
FiscalPrinter.BeginFiscalReceipt Method
FiscalPrinter.EndFiscalReceipt Method


FiscalPrinter.PrintRecPackageAdjustment Method

FiscalPrinter.PrintRecPackageAdjustment Method |
 | See Also

1/18/2008

Called to give an adjustment for a package of some items booked before.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintRecPackageAdjustment ( _
    adjustmentType As FiscalAdjustmentType, _
    description As String, _
    vatAdjustments As IEnumerable(Of VatInfo) _
)
public abstract void PrintRecPackageAdjustment (
    FiscalAdjustmentType adjustmentType,
    string description,
    IEnumerable<VatInfo> vatAdjustments
)
public:
virtual void PrintRecPackageAdjustment (
    FiscalAdjustmentType adjustmentType,
    String^ description,
    IEnumerable<VatInfo>^ vatAdjustments
) abstract
public abstract void PrintRecPackageAdjustment (
    FiscalAdjustmentType adjustmentType,
    String description,
    IEnumerable<VatInfo> vatAdjustments
)
public abstract function PrintRecPackageAdjustment (
    adjustmentType : FiscalAdjustmentType,
    description : String,
    vatAdjustments : IEnumerable<VatInfo>
)

Parameters

adjustmentType

Type of adjustment.

description

Text describing the adjustment.

vatAdjustments

Structure containing a list of adjustment(s) for different VAT(s).

Remarks

This adjustment (discount or surcharge) can be either a fixed currency amount or a percentage amount relating to items combined to an adjustment package. Each item of the package must be transferred before.

Fixed amount adjustments are only supported if CapPackageAdjustment is true. This method is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

PrintRecPackageAdjustment may cause a PosControlException to be thrown with the following ErrorCode:

Value | Description
Busy | Cannot perform while output is in progress. (Can be returned only if AsyncMode is false.)
Illegal | The fiscal printer does not support package adjustments (see the CapPackageAdjustment property), or the adjustmentType parameter is invalid.
ExtendedErrorWrongState: | The printer is not in either the FiscalReceipt or the FiscalReceiptTotal state.
ExtendedErrorCoverOpen: | The printer cover is open. (Can be returned only if AsyncMode is false.)
ExtendedErrorJournalEmpty: | The journal station is out of paper. (Can be returned only if AsyncMode is false.)
ExtendedErrorReceiptEmpty: | The receipt station is out of paper. (Can be returned only if AsyncMode is false.)
ExtendedErrorSlipEmpty | The slip station was specified, but a form is not inserted. (Applies only if AsyncMode is false.)
ExtendedErrorBadItemDescription: | The description is too long or contains a reserved word. (Can be returned only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.PrintRecPackageAdjustVoid Method

FiscalPrinter.PrintRecPackageAdjustVoid Method |
 | See Also

1/18/2008

Specifies a list of adjustments to be voided.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintRecPackageAdjustVoid ( _
    adjustmentType As FiscalAdjustmentType, _
    vatAdjustments As IEnumerable(Of VatInfo) _
)
public abstract void PrintRecPackageAdjustVoid (
    FiscalAdjustmentType adjustmentType,
    IEnumerable<VatInfo> vatAdjustments
)
public:
virtual void PrintRecPackageAdjustVoid (
    FiscalAdjustmentType adjustmentType,
    IEnumerable<VatInfo>^ vatAdjustments
) abstract
public abstract void PrintRecPackageAdjustVoid (
    FiscalAdjustmentType adjustmentType,
    IEnumerable<VatInfo> vatAdjustments
)
public abstract function PrintRecPackageAdjustVoid (
    adjustmentType : FiscalAdjustmentType,
    vatAdjustments : IEnumerable<VatInfo>
)

Parameters

adjustmentType

Type of adjustment.

vatAdjustments

Structure containing a list of adjustment(s) to be voided for different VAT(s).

Remarks

This adjustment (discount or surcharge) can be either a fixed currency amount or a percentage amount relating to the current receipt subtotal.

Fixed amount void adjustments are only supported if CapPackageAdjustment is true.

If CapPostPreLine is true, an additional application specific line defined by the PreLine property is printed. After printing this line, PreLine is reset to an empty string.

PrintRecPackageAdjustVoid is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

PrintRecPackageAdjustVoid may cause a PosControlException to be thrown with the following ErrorCode:

Value | Description
Busy | Cannot perform while output is in progress. (Can be returned only if AsyncMode is false.)
Illegal | The fiscal printer does not support package adjustments (see the CapPackageAdjustment property), or the adjustmentType parameter is invalid.
ExtendedErrorWrongState: | The printer is not in either the FiscalReceipt or the FiscalReceiptTotal state.
ExtendedErrorCoverOpen: | The printer cover is open. (Can be returned only if AsyncMode is false.)
ExtendedErrorJournalEmpty: | The journal station is out of paper. (Can be returned only if AsyncMode is false.)
ExtendedErrorReceiptEmpty: | The receipt station is out of paper. (Can be returned only if AsyncMode is false.)
ExtendedErrorSlipEmpty | The slip station was specified, but a form is not inserted. (Applies only if AsyncMode is false.)
ExtendedErrorBadItemDescription: | The description is too long or contains a reserved word. (Can be returned only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.PrintRecRefund Method

FiscalPrinter.PrintRecRefund Method |
 | See Also

1/18/2008

Processes a refund.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintRecRefund ( _
    description As String, _
    amount As Decimal, _
    vatInfo As Integer _
)
public abstract void PrintRecRefund (
    string description,
    decimal amount,
    int vatInfo
)
public:
virtual void PrintRecRefund (
    String^ description,
    Decimal amount,
    int vatInfo
) abstract
public abstract void PrintRecRefund (
    String description,
    Decimal amount,
    int vatInfo
)
public abstract function PrintRecRefund (
    description : String,
    amount : decimal,
    vatInfo : int
)

Parameters

description

Text that describes the refund.

amount

Amount of the refund.

vatInfo

VAT table identifier.

Remarks

The amount is positive, but is printed as a negative number and the totals registers are decremented.

Some fixed text, together with the description, is printed on the receipt and journal to indicate that a refund has occurred.

PrintRecRefund is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

PrintRecRefund may cause a PosControlException to be thrown with one of the following ErrorCodes:

Value | Description
Busy | Cannot perform while output is in progress. (Can be returned only if AsyncMode is false.)
ExtendedErrorWrongState: | The printer is not in the FiscalReceipt state.
ExtendedErrorCoverOpen: | The printer cover is open. (Can be returned only if AsyncMode is false.)
ExtendedErrorJournalEmpty: | The journal station is out of paper. (Can be returned only if AsyncMode is false.)
ExtendedErrorReceiptEmpty: | The receipt station is out of paper. (Can be returned only if AsyncMode is false.)
ExtendedErrorSlipEmpty | The slip station was specified, but a form is not inserted. (Applies only if AsyncMode is false.)
ExtendedErrorBadItemDescription: | The description is too long or contains a reserved word. (Can be returned only if AsyncMode is false.)
ExtendedErrorBadItemAmount: | The amount is invalid. (Can be returned only if AsyncMode is false.)
ExtendedErrorBadVat: | The VAT information is invalid. (Can be returned only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
FiscalPrinter.BeginFiscalReceipt Method
FiscalPrinter.EndFiscalReceipt Method
AmountDecimalPlaces
FiscalPrinter.PrintRecCash Method
PrintRecItem
PrintRecItem
PrintRecItemAdjustment
FiscalPrinter.PrintRecItemAdjustment Method
PrintRecItemFuel
PrintRecItemFuel
PrintRecItemFuelVoid
FiscalPrinter.PrintRecItemFuelVoid Method
FiscalPrinter.PrintRecMessage Method
FiscalPrinter.PrintRecNotPaid Method
PrintRecPackageAdjustment
PrintRecPackageAdjustVoid
FiscalPrinter.PrintRecRefund Method
PrintRecRefundVoid
PrintRecRefundVoid
PrintRecSubtotal
PrintRecSubtotalAdjustment
PrintRecSubtotalAdjustVoid
PrintRecTaxId
PrintRecTotal
PrintRecVoid


FiscalPrinter.PrintRecRefundVoid Method

FiscalPrinter.PrintRecRefundVoid Method |
 | See Also

1/18/2008

Processes a void of a refund.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintRecRefundVoid ( _
    description As String, _
    amount As Decimal, _
    vatInfo As Integer _
)
public abstract void PrintRecRefundVoid (
    string description,
    decimal amount,
    int vatInfo
)
public:
virtual void PrintRecRefundVoid (
    String^ description,
    Decimal amount,
    int vatInfo
) abstract
public abstract void PrintRecRefundVoid (
    String description,
    Decimal amount,
    int vatInfo
)
public abstract function PrintRecRefundVoid (
    description : String,
    amount : decimal,
    vatInfo : int
)

Parameters

description

Text that describes the refund.

amount

Amount of the refund.

vatInfo

VAT table identifier.

Remarks

The amount is positive and the totals registers are incremented.

Some fixed text, along with the description, will be printed on the station defined by the FiscalReceiptStation property to indicate that a refund has been voided.

If CapOnlyVoidLastItem is true, only the last refund item transferred to the fiscal printer can be voided.

This method is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

PrintRecRefundVoid may cause a PosControlException to be thrown with one of the following ErrorCodes:

Value | Description
Busy | Cannot perform while output is in progress. (Can be returned only if AsyncMode is false.)
ExtendedErrorWrongState: | The printer is not in the FiscalReceipt state.
ExtendedErrorCoverOpen: | The printer cover is open. (Can be returned only if AsyncMode is false.)
ExtendedErrorJournalEmpty: | The journal station is out of paper. (Can be returned only if AsyncMode is false.)
ExtendedErrorReceiptEmpty: | The receipt station is out of paper. (Can be returned only if AsyncMode is false.)
ExtendedErrorSlipEmpty | The slip station was specified, but a form is not inserted. (Applies only if AsyncMode is false.)
ExtendedErrorBadItemDescription: | The description is too long or contains a reserved word. (Can be returned only if AsyncMode is false.)
ExtendedErrorBadItemAmount: | The amount is invalid. (Can be returned only if AsyncMode is false.)
ExtendedErrorBadVat: | The VAT information is invalid. (Can be returned only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
PrintRecRefund
FiscalReceiptStation


FiscalPrinter.PrintRecSubtotal Method

FiscalPrinter.PrintRecSubtotal Method |
 | See Also

1/18/2008

Checks and prints the current receipt subtotal.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintRecSubtotal ( _
    amount As Decimal _
)
public abstract void PrintRecSubtotal (
    decimal amount
)
public:
virtual void PrintRecSubtotal (
    Decimal amount
) abstract
public abstract void PrintRecSubtotal (
    Decimal amount
)
public abstract function PrintRecSubtotal (
    amount : decimal
)

Parameters

amount

Amount of the subtotal.

Remarks

If the CapCheckTotal property is true, the amount value is compared to the subtotal calculated by the printer. If the subtotals match, the subtotal is printed on both the receipt and journal. If the results do not match, the receipt is automatically canceled. If the CapCheckTotal property is false, the subtotal is printed on the receipt. In this case, the amount value is never compared to the subtotal computed by the printer.

PrintRecSubtotal is capable of asynchronous processing. It is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

If PrintRecSubtotal compares the application’s subtotal with the printer’s subtotal and they do not match, the PrinterState property is changed to FiscalReceiptEnding.

PrintRecSubtotal may cause a PosControlException to be thrown with one of the following values:

Value | Description
Busy | Cannot perform while output is in progress. (Can be returned only if AsyncMode is false.)
ExtendedErrorWrongState: | The printer is not in the FiscalReceipt state.
ExtendedErrorCoverOpen: | The printer cover is open. (Can be returned only if AsyncMode is false.)
ExtendedErrorJournalEmpty: | The journal station is out of paper. (Can be returned only if AsyncMode is false.)
ExtendedErrorReceiptEmpty: | The receipt station is out of paper. (Can be returned only if AsyncMode is false.)
ExtendedErrorBadItemAmount: | The description is too long or contains a reserved word. (Can be returned only if AsyncMode is false.)
ExtendedErrorBadItemAmount: | The subtotal from the application does not match the subtotal computed by the printer. (Can be returned only if AsyncMode is false.)
ExtendedErrorNegativeTotal: | The total computed by the printer is less than zero. (Can be returned only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
FiscalPrinter.BeginFiscalReceipt Method
FiscalPrinter.EndFiscalReceipt Method
AmountDecimalPlaces
FiscalPrinter.PrintRecCash Method
PrintRecItem
PrintRecItem
PrintRecItemAdjustment
FiscalPrinter.PrintRecItemAdjustment Method
PrintRecItemFuel
PrintRecItemFuel
PrintRecItemFuelVoid
FiscalPrinter.PrintRecItemFuelVoid Method
FiscalPrinter.PrintRecMessage Method
FiscalPrinter.PrintRecNotPaid Method
PrintRecPackageAdjustment
PrintRecPackageAdjustVoid
PrintRecRefund
FiscalPrinter.PrintRecRefund Method
PrintRecRefundVoid
FiscalPrinter.PrintRecRefundVoid Method
PrintRecSubtotalAdjustment
PrintRecSubtotalAdjustVoid
PrintRecTaxId
PrintRecTotal
PrintRecVoid


FiscalPrinter.PrintRecSubtotalAdjustment Method

FiscalPrinter.PrintRecSubtotalAdjustment Method |
 | See Also

1/18/2008

Applies and prints a discount or surcharge to the current receipt subtotal.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintRecSubtotalAdjustment ( _
    adjustmentType As FiscalAdjustment, _
    description As String, _
    amount As Decimal _
)
public abstract void PrintRecSubtotalAdjustment (
    FiscalAdjustment adjustmentType,
    string description,
    decimal amount
)
public:
virtual void PrintRecSubtotalAdjustment (
    FiscalAdjustment adjustmentType,
    String^ description,
    Decimal amount
) abstract
public abstract void PrintRecSubtotalAdjustment (
    FiscalAdjustment adjustmentType,
    String description,
    Decimal amount
)
public abstract function PrintRecSubtotalAdjustment (
    adjustmentType : FiscalAdjustment,
    description : String,
    amount : decimal
)

Parameters

adjustmentType

Type of discount.

description

Text describing the discount.

amount

Amount of the discount.

Remarks

This discount or surcharge can be either a fixed currency amount or a percentage amount relating to the current receipt subtotal.

If the discount or surcharge amount is greater than the receipt subtotal, an error occurs because the subtotal cannot be negative.

In many countries or regions, discount or surcharge operations cause the printing of a fixed line of text expressing the kind of operation that has been performed.

Fixed amount discounts are supported only if CapSubAmountAdjustment is true.

Percentage discounts are supported only if CapSubPercentAdjustment is true.

PrintRecSubtotalAdjustment is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

PrintRecSubtotalAdjustment may cause a PosControlException to be thrown with one of the following values:

Value

Description

Busy

Cannot perform while output is in progress. (Can be returned only if AsyncMode is false.)

Illegal

One of the following errors occurred:

  • The printer does not support fixed amount discounts (see the CapSubAmountAdjustment property).

  • The printer does not support percentage discounts (see the CapSubPercentAdjustment property).

  • The adjustmentType parameter is invalid.

ExtendedErrorWrongState

The printer is not in the FiscalReceipt state.

ExtendedErrorCoverOpen

The printer cover is open.(Can be returned only if AsyncMode is false.)

ExtendedErrorJournalEmpty

The journal station is out of paper. (Can be returned only if AsyncMode is false.)

ExtendedErrorReceiptEmpty

The receipt station is out of paper. (Can be returned only if AsyncMode is false.)

ExtendedErrorBadItemAmount

The discount amount is invalid. (Can be returned only if AsyncMode is false.)

ExtendedErrorBadItemDescription

The discount description is too long or contains a reserved word. (Can be returned only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
FiscalPrinter.BeginFiscalReceipt Method
FiscalPrinter.EndFiscalReceipt Method
AmountDecimalPlaces
FiscalPrinter.PrintRecCash Method
PrintRecItem
PrintRecItem
PrintRecItemAdjustment
FiscalPrinter.PrintRecItemAdjustment Method
PrintRecItemFuel
PrintRecItemFuel
PrintRecItemFuelVoid
FiscalPrinter.PrintRecItemFuelVoid Method
FiscalPrinter.PrintRecMessage Method
FiscalPrinter.PrintRecNotPaid Method
PrintRecPackageAdjustment
PrintRecPackageAdjustVoid
PrintRecRefund
FiscalPrinter.PrintRecRefund Method
PrintRecRefundVoid
FiscalPrinter.PrintRecRefundVoid Method
FiscalPrinter.PrintRecSubtotal Method
PrintRecSubtotalAdjustVoid
PrintRecTaxId
PrintRecTotal
PrintRecVoid


FiscalPrinter.PrintRecSubtotalAdjustVoid Method

FiscalPrinter.PrintRecSubtotalAdjustVoid Method |
 | See Also

1/18/2008

Voids a preceding subtotal adjustment on the station defined by the FiscalReceiptStation property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintRecSubtotalAdjustVoid ( _
    adjustmentType As FiscalAdjustment, _
    amount As Decimal _
)
public abstract void PrintRecSubtotalAdjustVoid (
    FiscalAdjustment adjustmentType,
    decimal amount
)
public:
virtual void PrintRecSubtotalAdjustVoid (
    FiscalAdjustment adjustmentType,
    Decimal amount
) abstract
public abstract void PrintRecSubtotalAdjustVoid (
    FiscalAdjustment adjustmentType,
    Decimal amount
)
public abstract function PrintRecSubtotalAdjustVoid (
    adjustmentType : FiscalAdjustment,
    amount : decimal
)

Parameters

adjustmentType

Type of adjustment.

amount

Amount of the adjustment (discount or surcharge).

Remarks

This discount or surcharge adjustment can be either a fixed currency amount or a percentage amount relating to the current receipt subtotal.

Fixed amount void discounts are only supported if CapSubAmountAdjustment is true. Percentage void discounts are only supported if the property CapSubPercentAdjustment is true.

If CapPostPreLine is true, an additional application-specific line defined by the PreLine property will be printed. After printing this line, the PreLine property is reset to an empty string.

This method is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

PrintRecSubtotalAdjustVoid may cause a PosControlException to be thrown with one of the following values:

Value

Description

Busy

Cannot perform while output is in progress. (Can be returned only if AsyncMode is false.)

Illegal

One of the following errors occurred:

  • The printer does not support fixed amount discounts (see the CapSubAmountAdjustment property).

  • The printer does not support percentage discounts (see the CapSubPercentAdjustment property).

  • The adjustmentType parameter is invalid.

ExtendedErrorWrongState

The printer is not in the FiscalReceipt state.

ExtendedErrorCoverOpen

The printer cover is open. (Can be returned only if AsyncMode is false.)

ExtendedErrorJournalEmpty

The journal station is out of paper. (Can be returned only if AsyncMode is false.)

ExtendedErrorReceiptEmpty

The receipt station is out of paper. (Can be returned only if AsyncMode is false.)

ExtendedErrorSlipEmpty

The slip station was specified, but a form is not inserted. (Applies only if AsyncMode is false.)

ExtendedErrorBadItemAmount

The discount amount is invalid. (Can be returned only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
FiscalPrinter.BeginFiscalReceipt Method
FiscalPrinter.EndFiscalReceipt Method
AmountDecimalPlaces
FiscalReceiptStation
PreLine


FiscalPrinter.PrintRecTaxId Method

FiscalPrinter.PrintRecTaxId Method |
 | See Also

1/18/2008

Prints the customer's tax identification on the station defined by the FiscalReceiptStation property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintRecTaxId ( _
    taxId As String _
)
public abstract void PrintRecTaxId (
    string taxId
)
public:
virtual void PrintRecTaxId (
    String^ taxId
) abstract
public abstract void PrintRecTaxId (
    String taxId
)
public abstract function PrintRecTaxId (
    taxId : String
)

Parameters

taxId

Customer identification with identification characters and tax number.

Remarks

This method is only supported when the fiscal printer is in the Fiscal Receipt Ending state.

This method is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

PrintRecTaxId may cause a PosControlException to be thrown with one of the following values:

Value | Description
Busy | Cannot perform while output is in progress. (Can be returned only if AsyncMode is false.)
Illegal | The fiscal printer does not support printing tax identifications.
ExtendedErrorWrongState | The printer is not in the FiscalReceipt state.
ExtendedErrorCoverOpen | The printer cover is open. (Can be returned only if AsyncMode is false.)
ExtendedErrorJournalEmpty | The journal station is out of paper. (Can be returned only if AsyncMode is false.)
ExtendedErrorReceiptEmpty | The receipt station is out of paper. (Can be returned only if AsyncMode is false.)
ExtendedErrorSlipEmpty | The slip station was specified, but a form is not inserted. (Applies only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
FiscalReceiptStation


FiscalPrinter.PrintRecTotal Method

FiscalPrinter.PrintRecTotal Method |
 | See Also

1/18/2008

Checks and prints the current receipt total on the station defined by the FiscalReceiptStation property and tenders a payment.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintRecTotal ( _
    total As Decimal, _
    payment As Decimal, _
    description As String _
)
public abstract void PrintRecTotal (
    decimal total,
    decimal payment,
    string description
)
public:
virtual void PrintRecTotal (
    Decimal total,
    Decimal payment,
    String^ description
) abstract
public abstract void PrintRecTotal (
    Decimal total,
    Decimal payment,
    String description
)
public abstract function PrintRecTotal (
    total : decimal,
    payment : decimal,
    description : String
)

Parameters

total

Application-computed receipt total.

payment

Amount of payment tendered.

description

Text description of the payment or the index of a predefined payment description.

Remarks

If CapCheckTotal is true, the total is compared to the total calculated by the printer. If the totals match, the total is printed on both the receipt and journal along with some fixed text. If the results do not match, the receipt is automatically canceled. If CapCheckTotal is false, the total is printed on the receipt and journal and the parameter is never compared to the total computed by the printer.

If CapPredefinedPaymentLines is true, the description parameter contains the index of one of the printer’s predefined payment descriptions. The index is typically a single character of the alphabet. The set of allowed values for this index is to be described in the description of the service object and stored in the PredefinedPaymentLines property.

If payment = total, a line containing the description and payment is printed. The PrinterState property is set to FiscalReceiptEnding.

If payment > total, a line containing the description and payment is printed, followed by a second line containing the change due. The PrinterState property is set to FiscalReceiptEnding.

If payment < total, a line containing the description and payment is printed. Because the entire receipt total has not yet been tendered, the PrinterState property is set to FiscalReceiptTotal.

If CapAdditionalLines property is false, then receipt trailer lines, fiscal logotype, and receipt cut are executed after the last total line, whenever the receipt total becomes equal to the payment from the application. Otherwise these lines are printed by calling the EndFiscalReceipt method.

PrintRecTotal is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

PrintRecTotal may cause a PosControlException to be thrown with one of the following values:

Value

Description

Busy

Cannot perform while output is in progress. (Can be returned only if AsyncMode is false.)

ExtendedErrorWrongState:

The printer is not in the FiscalReceipt state.

ExtendedErrorCoverOpen:

The printer cover is open. (Can be returned only if AsyncMode is false.)

ExtendedErrorJournalEmpty:

The journal station is out of paper. (Can be returned only if AsyncMode is false.)

ExtendedErrorReceiptEmpty:

The receipt station is out of paper. (Can be returned only if AsyncMode is false.)

ExtendedErrorSlipEmpty

The slip station was specified, but a form is not inserted. (Applies only if AsyncMode is false.)

ExtendedErrorBadItemAmount:

One of the following errors occurred:

  • The application-computed total does not match the printer-computed total.

  • The total parameter is invalid.

  • The payment parameter is invalid (Can be returned only if AsyncMode is false.)

ExtendedErrorBadItemDescription:

The description is too long or contains a reserved word. (Can be returned only if AsyncMode is false.)

ExtendedErrorNegativeTotal:

The total computed by the printer is less than zero. (Can be returned only if AsyncMode is false.)

ExtendedErrorWordNotAllowed:

The description contains a reserved word.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
FiscalPrinter.BeginFiscalReceipt Method
FiscalPrinter.EndFiscalReceipt Method
PredefinedPaymentLines
AmountDecimalPlaces
FiscalPrinter.PrintRecCash Method
PrintRecItem
PrintRecItem
PrintRecItemAdjustment
FiscalPrinter.PrintRecItemAdjustment Method
PrintRecItemFuel
PrintRecItemFuel
PrintRecItemFuelVoid
FiscalPrinter.PrintRecItemFuelVoid Method
FiscalPrinter.PrintRecMessage Method
FiscalPrinter.PrintRecNotPaid Method
PrintRecPackageAdjustment
PrintRecPackageAdjustVoid
PrintRecRefund
FiscalPrinter.PrintRecRefund Method
PrintRecRefundVoid
FiscalPrinter.PrintRecRefundVoid Method
FiscalPrinter.PrintRecSubtotal Method
FiscalPrinter.PrintRecSubtotalAdjustment Method
FiscalPrinter.PrintRecSubtotalAdjustVoid Method
FiscalPrinter.PrintRecTaxId Method
PrintRecVoid


FiscalPrinter.PrintRecVoid Method

FiscalPrinter.PrintRecVoid Method |
 | See Also

1/18/2008

Cancels the current receipt.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintRecVoid ( _
    description As String _
)
public abstract void PrintRecVoid (
    string description
)
public:
virtual void PrintRecVoid (
    String^ description
) abstract
public abstract void PrintRecVoid (
    String description
)
public abstract function PrintRecVoid (
    description : String
)

Parameters

description

The text that describes the void.

Remarks

The receipt is annulled but it is not physically canceled from the printer’s fiscal memory because fiscal receipts are printed with an increasing serial number and totals are accumulated in registers. When a receipt is canceled, its subtotal is subtracted from the totals registers, but it is added to the canceled receipt register.

Some fixed text, together with the description, are printed on the receipt and journal to indicate that the receipt has been canceled.

PrintRecVoid is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

If PrintRecVoid is successful, the PrinterState property is set to FiscalReceiptEnding.

PrintRecVoid may cause a PosControlException to be thrown with one of the following values:

Value | Description
Busy | Cannot perform while output is in progress. (Can be returned only if AsyncMode is false.)
ExtendedErrorWrongState | The printer is not in the FiscalReceipt state.
ExtendedErrorCoverOpen | The printer cover is open. (Can be returned only if AsyncMode is false.)
ExtendedErrorJournalEmpty | The journal station is out of paper. (Can be returned only if AsyncMode is false.)
ExtendedErrorReceiptEmpty | The receipt station is out of paper. (Can be returned only if AsyncMode is false.)
ExtendedErrorSlipEmpty | The slip station was specified, but a form is not inserted. (Applies only if AsyncMode is false.)
ExtendedErrorBadItemDescription | The description is too long or contains a reserved word. (Can be returned only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
FiscalPrinter.BeginFiscalReceipt Method
FiscalPrinter.EndFiscalReceipt Method
FiscalPrinter.PrintRecCash Method
PrintRecItem
PrintRecItem
PrintRecItemAdjustment
FiscalPrinter.PrintRecItemAdjustment Method
PrintRecItemFuel
PrintRecItemFuel
PrintRecItemFuelVoid
FiscalPrinter.PrintRecItemFuelVoid Method
FiscalPrinter.PrintRecMessage Method
FiscalPrinter.PrintRecNotPaid Method
PrintRecPackageAdjustment
PrintRecPackageAdjustVoid
PrintRecRefund
FiscalPrinter.PrintRecRefund Method
PrintRecRefundVoid
FiscalPrinter.PrintRecRefundVoid Method
FiscalPrinter.PrintRecSubtotal Method
FiscalPrinter.PrintRecSubtotalAdjustment Method
FiscalPrinter.PrintRecSubtotalAdjustVoid Method
FiscalPrinter.PrintRecTaxId Method
FiscalPrinter.PrintRecTotal Method


FiscalPrinter.PrintReport Method

FiscalPrinter.PrintReport Method |
 | See Also

1/18/2008

Prints a report of the fiscal EPROM contents on the receipt that occurred between two end points.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintReport ( _
    reportType As ReportType, _
    startNum As String, _
    endNum As String _
)
public abstract void PrintReport (
    ReportType reportType,
    string startNum,
    string endNum
)
public:
virtual void PrintReport (
    ReportType reportType,
    String^ startNum,
    String^ endNum
) abstract
public abstract void PrintReport (
    ReportType reportType,
    String startNum,
    String endNum
)
public abstract function PrintReport (
    reportType : ReportType,
    startNum : String,
    endNum : String
)

Parameters

reportType

The type of report to print. This will be one of the values defined by ReportType.

startNum

ASCII string identifying the starting record in Fiscal Printer memory from which to begin printing.

endNum

ASCII string identifying the final record in Fiscal Printer memory at which printing is to end.

Remarks

This method is always performed synchronously.

The meaning of the startNum and endNum parameters depends upon the type of report printed.

Report Type | Meaning
Date | startNum and endNum represent dates in the format "ddmmyyyyhhmmm", where: ddday of the month (01-31)mmmonth (01-12)yyyyyear (1997-…)hhhour (00-23)mmminutes (00-59)
EndOfDayOrdinal | startNum and endNum represent report numbers.
Ordinal | startNum and endNum represent fiscal memory record numbers.

A report will be printed that represents the period between the two numbers given.

For the EndOfDayOrdinal and Ordinal report types, If endNum is zero, a report will be generated based on startNum only.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
ReportType


FiscalPrinter.PrintXReport Method

FiscalPrinter.PrintXReport Method |
 | See Also

1/18/2008

Prints a report of all the daily fiscal activities on the receipt.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintXReport
public abstract void PrintXReport ()
public:
virtual void PrintXReport () abstract
public abstract void PrintXReport ()
public abstract function PrintXReport ()

Remarks

No data is written to the fiscal EPROM as a result of this method invocation.

PrintXReport is supported only if CapXReport is true.

PrintXReport is always performed synchronously.

PrintXReport may cause a PosControlException to be thrown with one of the following values:

Value | Description
Busy | Cannot perform while output is in progress.
Illegal | The printer does not support X reports (see the CapXReport property).
ExtendedErrorWrongState | The printer’s current state does not allow this state transition.
ExtendedErrorCoverOpen | The printer cover is open.
ExtendedErrorJournalEmpty | The journal station is out of paper
ExtendedErrorReceiptEmpty | The receipt station is out of paper.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.PrintZReport Method

FiscalPrinter.PrintZReport Method |
 | See Also

1/18/2008

Prints a report of all the daily fiscal activities on the receipt.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintZReport
public abstract void PrintZReport ()
public:
virtual void PrintZReport () abstract
public abstract void PrintZReport ()
public abstract function PrintZReport ()

Remarks

Data is written to the fiscal EPROM as a result of this method invocation.

PrintZReport is always performed synchronously.

PrintZReport may cause a PosControlException to be thrown with one of the following values:

Value | Description
Busy | Cannot perform while output is in progress.
ExtendedErrorWrongState | The printer’s current state does not allow this state transition.
ExtendedErrorCoverOpen | The printer cover is open.
ExtendedErrorJournalEmpty | The journal station is out of paper
ExtendedErrorReceiptEmpty | The receipt station is out of paper.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.ResetPrinter Method

FiscalPrinter.ResetPrinter Method |
 | See Also

1/18/2008

Forces the printer to return to the Monitor state.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ResetPrinter
public abstract void ResetPrinter ()
public:
virtual void ResetPrinter () abstract
public abstract void ResetPrinter ()
public abstract function ResetPrinter ()

Remarks

This forces any interrupted operations to be canceled and closed. ResetPrinter must be invoked when the printer is not in a Monitor state after a successful call to the ClaimDevice method and successful setting of the DeviceEnabled property to true. This typically happens if a power failure occurs during a fiscal operation.

Calling ResetPrinter does not close the printer; that is, it does not force a Z report to be printed.

The service object handles this command as follows:

  • If the printer is in FiscalReceipt, FiscalReceiptTotal, or FiscalReceiptEnding state, the receipt is ended without updating any registers.

  • If the printer is in a nonfiscal or training state, the printer exits that state.

ResetPrinter is always performed synchronously.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.SetCurrency Method

FiscalPrinter.SetCurrency Method |
 | See Also

1/18/2008

Changes to a new currency (for example, euro).

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub SetCurrency ( _
    newCurrency As FiscalCurrency _
)
public abstract void SetCurrency (
    FiscalCurrency newCurrency
)
public:
virtual void SetCurrency (
    FiscalCurrency newCurrency
) abstract
public abstract void SetCurrency (
    FiscalCurrency newCurrency
)
public abstract function SetCurrency (
    newCurrency : FiscalCurrency
)

Parameters

newCurrency

The new currency.

Remarks

This method is only supported if CapSetCurrency is true and can only be called while DayOpened is false. The actual currency is kept in the ActualCurrency property.

SetCurrency may throw a PosControlException with the following ErrorCode:

Value

Description

Illegal

One of the following errors occurred:

  • The fiscal printer does not support this method (see the CapSetCurrency property).

  • The fiscal printer has already begun the fiscal day (see the DayOpened property).

  • The specified newCurrency value is not valid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
ActualCurrency
CapSetCurrency
DayOpened


FiscalPrinter.SetDate Method

FiscalPrinter.SetDate Method |
 | See Also

1/18/2008

Sets the printer's date and time.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub SetDate ( _
    newDate As DateTime _
)
public abstract void SetDate (
    DateTime newDate
)
public:
virtual void SetDate (
    DateTime newDate
) abstract
public abstract void SetDate (
    DateTime newDate
)
public abstract function SetDate (
    newDate : DateTime
)

Parameters

newDate

DateTime value.

Remarks

The date and time is passed as a DateTime value. SetDate can be called only while DayOpened is false.

SetDate may throw a PosControlException with the following ErrorCode:

Value | Description
Illegal | The printer has already begun the fiscal day (see the DayOpened property).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
DayOpened


FiscalPrinter.SetHeaderLine Method

FiscalPrinter.SetHeaderLine Method |
 | See Also

1/18/2008

Sets one of the fiscal receipt header lines.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub SetHeaderLine ( _
    lineNumber As Integer, _
    text As String, _
    doubleWidth As Boolean _
)
public abstract void SetHeaderLine (
    int lineNumber,
    string text,
    bool doubleWidth
)
public:
virtual void SetHeaderLine (
    int lineNumber,
    String^ text,
    bool doubleWidth
) abstract
public abstract void SetHeaderLine (
    int lineNumber,
    String text,
    boolean doubleWidth
)
public abstract function SetHeaderLine (
    lineNumber : int,
    text : String,
    doubleWidth : boolean
)

Parameters

lineNumber

Line number of the header line to set.

text

Text to which to set the header line.

doubleWidth

Print this line in double-wide characters.

Remarks

The text set by SetHeaderLine is stored by the printer and retained across power losses.

lineNumber must be between 1 and the value of the NumHeaderLines property.

If headerText is an empty string (““), the header line is unset and is not printed.

doubleWidth characters are printed if the printer supports them. See the CapDoubleWidth property to determine if they are supported.

SetHeaderLine is supported only if CapSetHeader is true.

SetHeaderLine can be called only while DayOpened is false.

SetHeaderLine may cause a PosControlException to be thrown with one of the following ErrorCodes:

Value

Description

Illegal

One of the following errors occurred:

  • The printer has already begun the fiscal day (see the DayOpened property).

  • The lineNumber parameter is invalid.

ExtendedErrorBadItemDescription:

The headerText parameter is too long or contains a reserved word. (Can be returned only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
CapDoubleWidth
CapMultiContractor
CapSetHeader
ContractorId
DayOpened
NumHeaderLines


FiscalPrinter.SetPosId Method

FiscalPrinter.SetPosId Method |
 | See Also

1/18/2008

Sets the POS and cashier identifiers.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub SetPosId ( _
    posId As String, _
    cashierId As String _
)
public abstract void SetPosId (
    string posId,
    string cashierId
)
public:
virtual void SetPosId (
    String^ posId,
    String^ cashierId
) abstract
public abstract void SetPosId (
    String posId,
    String cashierId
)
public abstract function SetPosId (
    posId : String,
    cashierId : String
)

Parameters

posId

Identifier for the POS system.

cashierId

Identifier of the cashier.

Remarks

These values are printed when each fiscal receipt is closed.

SetPosId is supported only if CapSetPosId is true. SetPosId can be called only while DayOpened is false.

SetPosId may throw a PosControlException with the following ErrorCode:

Value

Description

Illegal

One of the following errors occurred:

  • The printer does not support setting the POS identifier (see the CapSetPosId property).

  • The printer has already begun the fiscal day (see the DayOpened property).

  • Either the pointOfServiceId or cashierID parameter is invalid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
CapSetPosId
DayOpened


FiscalPrinter.SetStoreFiscalId Method

FiscalPrinter.SetStoreFiscalId Method |
 | See Also

1/18/2008

Sets the store fiscal ID.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub SetStoreFiscalId ( _
    id As String _
)
public abstract void SetStoreFiscalId (
    string id
)
public:
virtual void SetStoreFiscalId (
    String^ id
) abstract
public abstract void SetStoreFiscalId (
    String id
)
public abstract function SetStoreFiscalId (
    id : String
)

Parameters

id

Fiscal identifier.

Remarks

This value is retained by the printer even after power failures. This ID is automatically printed by the printer after the fiscal receipt header lines.

SetStoreFiscalId is supported only if CapSetStoreFiscalID is true. SetStoreFiscalId can be called only while DayOpened is false.

SetStoreFiscalId may cause a PosControlException to be thrown with the following ErrorCode:

Value

Description

Illegal

One of the following errors occurred:

  • The printer does not support setting the store fiscal identifier (see the CapSetStoreFiscalId property).

  • The printer has already begun the fiscal day (see the DayOpened property).

  • The id parameter is invalid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
CapSetStoreFiscalId
DayOpened


FiscalPrinter.SetTrailerLine Method

FiscalPrinter.SetTrailerLine Method |
 | See Also

1/18/2008

Sets one of the fiscal receipt trailer lines.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub SetTrailerLine ( _
    lineNumber As Integer, _
    text As String, _
    doubleWidth As Boolean _
)
public abstract void SetTrailerLine (
    int lineNumber,
    string text,
    bool doubleWidth
)
public:
virtual void SetTrailerLine (
    int lineNumber,
    String^ text,
    bool doubleWidth
) abstract
public abstract void SetTrailerLine (
    int lineNumber,
    String text,
    boolean doubleWidth
)
public abstract function SetTrailerLine (
    lineNumber : int,
    text : String,
    doubleWidth : boolean
)

Parameters

lineNumber

Line number of the trailer line to set.

text

Text to which to set the trailer line.

doubleWidth

Print this line in double-wide characters.

Remarks

The text set by SetTrailerLine is stored by the printer and retained across power losses.

lineNumber must be between 1 and the value of the NumTrailerLines property.

If text is an empty string (""), the trailer line is unset and is not printed.

doubleWidth characters are printed if the printer supports them. See the CapDoubleWidth property to determine if they are supported.

SetTrailerLine is supported only if CapSetTrailer is true. SetTrailerLine can be called only while DayOpened is false.

SetTrailerLine may cause a PosControlException to be thrown with one of the following values:

Value

Description

Illegal

One of the following errors occurred:

  • The printer has already begun the fiscal day (see the DayOpened property).

  • The lineNumber parameter was invalid.

ExtendedErrorBadItemDescription:

The trailerText parameter is too long or contains a reserved word. (Can be returned only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
CapDoubleWidth
CapSetTrailer
DayOpened
NumTrailerLines


FiscalPrinter.SetVatTable Method

FiscalPrinter.SetVatTable Method |
 | See Also

1/18/2008

Sends the VAT table built inside the service object to the printer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub SetVatTable
public abstract void SetVatTable ()
public:
virtual void SetVatTable () abstract
public abstract void SetVatTable ()
public abstract function SetVatTable ()

Remarks

The VAT table is built one entry at a time using the SetVatValue method.

SetVatTable is supported only if CapHasVatTable is true. SetVatTable can only be called while DayOpened is false.

SetVatTable may throw a PosControlException with the following ErrorCode:

Value | Description
Illegal | The printer has already begun the fiscal day (see the DayOpened property).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
CapHasVatTable
DayOpened
SetVatValue


FiscalPrinter.SetVatValue Method

FiscalPrinter.SetVatValue Method |
 | See Also

1/18/2008

Sets the VAT ID and VAT value.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub SetVatValue ( _
    vatId As Integer, _
    vatValue As String _
)
public abstract void SetVatValue (
    int vatId,
    string vatValue
)
public:
virtual void SetVatValue (
    int vatId,
    String^ vatValue
) abstract
public abstract void SetVatValue (
    int vatId,
    String vatValue
)
public abstract function SetVatValue (
    vatId : int,
    vatValue : String
)

Parameters

vatId

Index of the VAT table entry to set.

vatValue

Tax value as a percentage.

Remarks

This overload takes an ASCII string for vatValue.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.VerifyItem Method

FiscalPrinter.VerifyItem Method |
 | See Also

1/18/2008

Compares itemName and its vatId with the values stored in the printer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub VerifyItem ( _
    itemName As String, _
    vatId As Integer _
)
public abstract void VerifyItem (
    string itemName,
    int vatId
)
public:
virtual void VerifyItem (
    String^ itemName,
    int vatId
) abstract
public abstract void VerifyItem (
    String itemName,
    int vatId
)
public abstract function VerifyItem (
    itemName : String,
    vatId : int
)

Parameters

itemName

Item to be verified.

vatId

VAT identifier of the item.

Remarks

VerifyItem is supported only if CapHasVatTable is true. VerifyItem can be called only while the printer is in the Item List state.

VerifyItem may cause a PosControlException to be thrown with one of the following ErrorCodes:

Value | Description
Illegal | The printer does not support VAT tables (see the CapHasVatTable property).
ExtendedErrorWrongState | The printer is not in the Item List state.
ExtendedErrorBadItemDescription | The item name is too long or contains a reserved word. (Can be returned only if AsyncMode is false.)
ExtendedErrorBadVat | The vatId parameter is invalid. (Can be returned only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
CapHasVatTable
FiscalPrinter.SetVatTable Method


FiscalPrinter Properties

FiscalPrinter Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
ActualCurrency | Gets a value identifying which actual currency is used by the fiscal printer.
AdditionalHeader | Gets or sets user-specific text to be printed on the receipt after the fixed header lines when calling the BeginFiscalReceipt method.
AdditionalTrailer | Get or sets user-specific text to be printed on the receipt after the fiscal trailer lines when calling the EndFiscalReceipt method.
AmountDecimalPlaces | Gets the number of decimal places that the fiscal printer uses for calculations.
AsyncMode | Gets or sets a Boolean value that indicates whether certain print methods are performed asynchronously.
CapAdditionalHeader | Gets a Boolean value that indicates whether the printer can print application-specific text after the fixed header lines.
CapAdditionalLines | Gets a Boolean value that indicates whether the printer can print application-defined lines.
CapAdditionalTrailer | Gets a Boolean value that indicates whether the printer can print application-specific text after the fiscal trailer lines.
CapAmountAdjustment | Gets a Boolean value that indicates whether the printer handles discounts or surcharges.
CapChangeDue | Gets a Boolean value that indicates whether text can be defined in the ChangeDue property.
CapCheckTotal | Gets a Boolean value that indicates whether automatic total comparison can be enabled.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapCoverSensor | Gets a Boolean value that indicates whether the printer has a "cover open" sensor.
CapDoubleWidth | Gets a Boolean value that indicates whether the printer can print double-width characters.
CapDuplicateReceipt | Gets a Boolean value that indicates whether the printer allows printing of more than one fiscal receipt.
CapEmptyReceiptIsVoidable | Gets a Boolean value that indicates whether the printer can void an opened receipt.
CapFiscalReceiptStation | Gets a Boolean value that indicates whether the printer can print transactions on the station defined by FiscalReceiptStation.
CapFiscalReceiptType | Gets a Boolean value that indicates whether the printer can print receipts defined by FiscalReceiptType.
CapFixedOutput | Gets a Boolean value that indicates whether the printer supports fixed-format printing through certain methods.
CapHasVatTable | Gets a Boolean value that indicates whether the printer has a VAT table.
CapIndependentHeader | Gets a Boolean value that indicates whether the printer can print header lines before the first fiscal receipt command is processed.
CapItemList | Gets a Boolean value that indicates whether the printer can print a report of items of a specified VAT class.
CapJrnEmptySensor | Gets a Boolean value that indicates whether the printer has an out-of-paper sensor.
CapJrnNearEndSensor | Gets a Boolean value that indicates whether the printer has a low-paper sensor.
CapJrnPresent | Gets a Boolean value that indicates whether the journal print station is present.
CapMultiContractor | Gets a Boolean value that indicates whether the printer supports more than one contractor.
CapNonFiscalMode | Gets a Boolean value that indicates whether the printer can print in nonfiscal mode.
CapOnlyVoidLastItem | Gets a Boolean value that indicates whether only the last printed item can be voided.
CapOrderAdjustmentFirst | Gets a Boolean value that indicates the order of use of PrintRecItem and PrintRecItemAdjustment.
CapPackageAdjustment | Gets a Boolean value that indicates whether an adjustment can be given to a package of booked items.
CapPercentAdjustment | Gets a Boolean value that indicates whether the printer handles percentage discounts or surcharges.
CapPositiveAdjustment | Gets a Boolean property that indicates whether you can use the PrintRecItemAdjustment method to apply surcharges.
CapPositiveSubtotalAdjustment | Gets a Boolean value that indicates whether you can use the PrintRecSubtotalAdjustment method to apply surcharges.
CapPostPreLine | Gets a Boolean value that indicates whether the printer can support additional lines defined by the PostLine and PreLine properties.
CapPowerLossReport | Gets a Boolean value that indicates whether the printer can print a power-loss report by using the PrintPowerLossReport method.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapPredefinedPaymentLines | Gets a Boolean value that indicates whether the printer can print predefined payment descriptions.
CapReceiptNotPaid | Gets a Boolean value that indicates whether the printer supports the PrintRecNotPaid method.
CapRecEmptySensor | Gets a Boolean value that indicates whether the receipt print station has an out-of-paper sensor.
CapRecNearEndSensor | Gets a Boolean value that indicates whether the receipt print station has a low-paper sensor.
CapRecPresent | Gets a Boolean value that indicates whether the receipt print station is present.
CapRemainingFiscalMemory | Gets a Boolean value that indicates whether the printer supports the RemainingFiscalMemory property to show the Fiscal Memory remaining.
CapReservedWord | Gets a Boolean value that indicates whether the printer prints a reserved word before printing the total.
CapSetCurrency | Gets a Boolean value that indicates whether the fiscal printer can change the currency to a new one by calling the SetCurrency method.
CapSetHeader | Gets a Boolean value that indicates whether the SetHeaderLine method can be used to initialize the contents of a particular line of the receipt header.
CapSetPosId | Gets a Boolean value that indicates whether the SetPosId method can be used to initialize the values of PointOfServiceId and CashierId.
CapSetStoreFiscalId | Gets a Boolean value that indicates whether the SetStoreFiscalId method can be used to set up the Fiscal ID number.
CapSetTrailer | Gets a Boolean value that indicates whether the SetTrailerLine method can be used to initialize the contents of a particular line of the receipt trailer.
CapSetVatTable | Gets a Boolean value that indicates whether SetVatValue and SetVatTable can be used to modify the contents of the printer’s VAT table.
CapSlpEmptySensor | Gets a Boolean value that indicates whether the slip has a "slip in" sensor.
CapSlpFiscalDocument | Gets a Boolean value that indicates whether the printer enables fiscal printing to the slip station.
CapSlpFullSlip | Gets a Boolean value that indicates whether the printer supports printing full-length forms on the slip station.
CapSlpNearEndSensor | Gets a Boolean value that indicates whether the slip has a "slip near end" sensor.
CapSlpPresent | Gets a Boolean value that indicates whether the printer has a slip station.
CapSlpValidation | Gets a Boolean value that indicates whether the printer supports printing validation information on the slip station.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapSubAmountAdjustment | Gets a Boolean value that indicates whether the printer handles fixed-amount discounts on the subtotal.
CapSubPercentAdjustment | Gets a Boolean value that indicates whether the printer handles percentage discounts on the subtotal.
CapSubtotal | Gets a Boolean value that indicates whether the PrintRecSubtotal method can be used to print the subtotal.
CapTotalizerType | Gets a Boolean value that indicates whether the printer supports reading different types of totalizers by calling the GetTotalizer method.
CapTrainingMode | Gets a Boolean value that indicates whether the printer supports a training mode.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CapValidateJournal | Gets a Boolean value that indicates whether the PrintNormal method can be used to print a validation string on the journal station.
CapXReport | Gets a Boolean value that indicates whether the PrintXReport method can be used to print an X report.
ChangeDue | Gets or sets the text to print as a description for the cash return when using the PrintRecTotal method.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
CheckTotal | Gets or sets a Boolean value that indicates whether automatic comparison between the total of the fiscal printer and the total of the application is enabled.
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
ContractorId | Gets or sets the identification of the contractor to whom the receipt and some items of the receipt or to whom the receipt or some items of the receipt are assigned.
CountryCode | Gets a value identifying the countries/regions supported by this service object.
CoverOpen | Gets a Boolean value that indicates whether the printer's cover is open.
DateType | Gets or sets the type of date to be requested when calling the GetDate method.
DayOpened | Gets a Boolean value that indicates whether the fiscal day has been started.
DescriptionLength | Gets the maximum number of characters that can be passed as a description parameter.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
DuplicateReceipt | Gets or sets a Boolean value that indicates whether all the printing commands inside a fiscal receipt are buffered and can be printed again with the PrintDuplicateReceipt method.
ErrorLevel | Gets a value that indicates the severity of the error condition.
ErrorOutId | Gets the identifier of the output in the queue that raised an error event when you use asynchronous printing.
ErrorState | Gets the current state of the printer when raising an error event for an asynchronous output.
ErrorStation | Gets the station or stations that were printing when an error was detected.
ErrorString | Gets a vendor-supplied description of the current error.
FiscalReceiptStation | Gets or sets the station where the transaction of the fiscal receipt started with BeginFiscalReceipt method will be printed.
FiscalReceiptType | Gets or sets the type of the fiscal receipt.
FlagWhenIdle | Gets or sets a Boolean value that indicates whether the service object raises a StatusUpdateEvent event if it is in the Idle state.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
JrnEmpty | Gets a Boolean value that indicates whether the journal is out of paper.
JrnNearEnd | Gets a Boolean value that indicates whether journal paper is low.
MessageLength | Gets the maximum number of characters that can be passed as a message line in the PrintRecMessage method.
MessageType | Gets or sets the kind of message to be printed when you use the PrintRecMessage method.
NumHeaderLines | Gets the maximum number of header lines that can be printed for each fiscal receipt.
NumTrailerLines | Gets the maximum number of trailer lines that can be printed for each fiscal receipt.
NumVatRates | Gets the maximum number of VAT rates that can be entered into the printer’s VAT table.
OutputId | Gets the identifier of the most recently started asynchronous output.
PostLine | Gets or sets application-specific text to print on the fiscal receipt after a line item invoked by some PrintRec methods.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
PredefinedPaymentLines | Gets a string that indicates that only predefined payment lines are allowed.
PreLine | Gets or sets application-specific text to be printed on the fiscal receipt before a line item invoked by some PrintRec methods.
PrinterState | Gets the printer's current operational state.
QuantityDecimalPlaces | Gets the number of decimal digits in the fractional part that should be assumed to be in any quantity parameter that is passed to this service object.
QuantityLength | Gets the maximum number of digits that can be passed as a quantity parameter. This includes both the whole and fractional parts.
RecEmpty | Gets a Boolean value that indicates whether the receipt station is out of paper.
RecNearEnd | Gets a Boolean value that indicates whether the receipt station is low on paper.
RemainingFiscalMemory | Gets the remaining counter of Fiscal Memory.
ReservedWord | Gets the string that is automatically printed with the total when the PrintRecTotal method is called.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
SlipSelection | Gets or sets the kind of document to print on the slip station.
SlpEmpty | Gets a Boolean value that indicates whether a slip form is present.
SlpNearEnd | Gets a Boolean value that indicates whether a slip form is almost at its end.
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )
TotalizerType | Gets or sets the type of totalizer to be requested when calling the GetTotalizer method.
TrainingModeActive | Gets a Boolean value that indicates whether the printer's operational state allows the training mode.

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether the Fiscal Printer is an exclusive-use device.

See Also

Reference

FiscalPrinter Class
Microsoft.PointOfService Namespace


FiscalPrinter.ActualCurrency Property

FiscalPrinter.ActualCurrency Property |
 | See Also

1/18/2008

Gets a value identifying which actual currency is used by the fiscal printer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ActualCurrency As FiscalCurrency
public abstract FiscalCurrency ActualCurrency { get; }
public:
virtual property FiscalCurrency ActualCurrency {
    FiscalCurrency get () abstract;
}
/** @property */
public abstract FiscalCurrency get_ActualCurrency ()

public abstract function get ActualCurrency () : FiscalCurrency

Remarks

The ActualCurrency property is only valid if the CapSetCurrency property is true.

ActualCurrency is set and kept current by the Service Object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
FiscalPrinter.SetCurrency Method
CapSetCurrency
FiscalCurrency Enumeration


FiscalPrinter.AdditionalHeader Property

FiscalPrinter.AdditionalHeader Property |
 | See Also

1/18/2008

Gets or sets user-specific text to be printed on the receipt after the fixed header lines when calling the BeginFiscalReceipt method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AdditionalHeader As String
public abstract string AdditionalHeader { get; set; }
public:
virtual property String^ AdditionalHeader {
    String^ get () abstract;
    void set (String^ value) abstract;
}
/** @property */
public abstract String get_AdditionalHeader ()

/** @property */
public abstract void set_AdditionalHeader (String value)

public abstract function get AdditionalHeader () : String

public abstract function set AdditionalHeader (value : String)

Remarks

The AdditionallHeader property is only valid if the CapAdditionalHeader property is true. AdditionalHeader is set and kept current by the Service Object while the device is enabled.

Accessing AdditionalHeader may cause a PosControlException to be thrown with the following ErrorCode.

Value | Description
Illegal | The fiscal printer does not support printing text after the fixed header lines.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
FiscalPrinter.BeginFiscalReceipt Method
CapAdditionalHeader


FiscalPrinter.AdditionalTrailer Property

FiscalPrinter.AdditionalTrailer Property |
 | See Also

1/18/2008

Get or sets user-specific text to be printed on the receipt after the fiscal trailer lines when calling the EndFiscalReceipt method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AdditionalTrailer As String
public abstract string AdditionalTrailer { get; set; }
public:
virtual property String^ AdditionalTrailer {
    String^ get () abstract;
    void set (String^ value) abstract;
}
/** @property */
public abstract String get_AdditionalTrailer ()

/** @property */
public abstract void set_AdditionalTrailer (String value)

public abstract function get AdditionalTrailer () : String

public abstract function set AdditionalTrailer (value : String)

Remarks

The AdditionalTrailer property is only valid if the CapAdditionalTrailer property is true.

The AdditionalTrailer property is set and kept current by the Service Object while the device is enabled.

Accessing AdditionalTrailer may cause a PosControlException to be thrown with the following ErrorCode.

Value | Description
Illegal | The fiscal printer does not support printing text after the fiscal trailer lines.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
FiscalPrinter.EndFiscalReceipt Method
CapAdditionalTrailer


FiscalPrinter.AmountDecimalPlaces Property

FiscalPrinter.AmountDecimalPlaces Property |
 | See Also

1/18/2008

Gets the number of decimal places that the fiscal printer uses for calculations.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property AmountDecimalPlaces As Integer
public abstract int AmountDecimalPlaces { get; }
public:
virtual property int AmountDecimalPlaces {
    int get () abstract;
}
/** @property */
public abstract int get_AmountDecimalPlaces ()

public abstract function get AmountDecimalPlaces () : int

Remarks

The AmountDecimalPlaces property is set by the Service Object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.AsyncMode Property

FiscalPrinter.AsyncMode Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether certain print methods are performed asynchronously.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AsyncMode As Boolean
public abstract bool AsyncMode { get; set; }
public:
virtual property bool AsyncMode {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_AsyncMode ()

/** @property */
public abstract void set_AsyncMode (boolean value)

public abstract function get AsyncMode () : boolean

public abstract function set AsyncMode (value : boolean)

Remarks

If true, some print methods such as the PrintRecItemAdjustment, PrintRecItem, and PrintNormal methods and so on are performed asynchronously. If false, they are performed synchronously.

AsyncMode is set and kept current by the Service Object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapAdditionalHeader Property

FiscalPrinter.CapAdditionalHeader Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer can print application-specific text after the fixed header lines.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapAdditionalHeader As Boolean
public abstract bool CapAdditionalHeader { get; }
public:
virtual property bool CapAdditionalHeader {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapAdditionalHeader ()

public abstract function get CapAdditionalHeader () : boolean

Remarks

If true, the fiscal printer can print application-specific text defined in the AdditionalHeader property after printing the fixed header lines.

The CapAdditionalHeader property is set by the Service Object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapAdditionalLines Property

FiscalPrinter.CapAdditionalLines Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer can print application-defined lines.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapAdditionalLines As Boolean
public abstract bool CapAdditionalLines { get; }
public:
virtual property bool CapAdditionalLines {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapAdditionalLines ()

public abstract function get CapAdditionalLines () : boolean

Remarks

If true, the printer supports the printing of application-defined lines on a fiscal receipt between the total line and the end of the fiscal receipt; otherwise, false.

If CapAdditionalLines is true, after all totals lines are printed, you can print application-defined strings, such as the ones used for fidelity cards. In this case, after the total lines are printed, the PrinterState property is set to ReceiptEnding and PrintRecMessage can be called.

CapAdditionalLines is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapAdditionalTrailer Property

FiscalPrinter.CapAdditionalTrailer Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer can print application-specific text after the fiscal trailer lines.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapAdditionalTrailer As Boolean
public abstract bool CapAdditionalTrailer { get; }
public:
virtual property bool CapAdditionalTrailer {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapAdditionalTrailer ()

public abstract function get CapAdditionalTrailer () : boolean

Remarks

If true, then the fiscal printer can print application-specific text defined in the AdditionalTrailer property after printing the fiscal trailer lines.

The CapAdditionalTrailer property is set by the Service Object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapAmountAdjustment Property

FiscalPrinter.CapAmountAdjustment Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer handles discounts or surcharges.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapAmountAdjustment As Boolean
public abstract bool CapAmountAdjustment { get; }
public:
virtual property bool CapAmountAdjustment {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapAmountAdjustment ()

public abstract function get CapAmountAdjustment () : boolean

Remarks

If true, the printer handles fixed-amount discounts or fixed-amount surcharges on items; otherwise, false.

The CapAmountAdjustment property is set by the Service Object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapChangeDue Property

FiscalPrinter.CapChangeDue Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether text can be defined in the ChangeDue property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapChangeDue As Boolean
public abstract bool CapChangeDue { get; }
public:
virtual property bool CapChangeDue {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapChangeDue ()

public abstract function get CapChangeDue () : boolean

Remarks

If true, the text to be printed as the cash return description when you use PrintRecTotal method can be defined in the ChangeDue property.

The CapChangeDue property is set by the Service Object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapCheckTotal Property

FiscalPrinter.CapCheckTotal Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether automatic total comparison can be enabled.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapCheckTotal As Boolean
public abstract bool CapCheckTotal { get; }
public:
virtual property bool CapCheckTotal {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapCheckTotal ()

public abstract function get CapCheckTotal () : boolean

Remarks

If true, automatic comparison of the printer’s total and the application’s total can be enabled and disabled. If false, the automatic comparison cannot be enabled and is always considered disabled.

The CapCheckTotal property is set by the Service Object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapCoverSensor Property

FiscalPrinter.CapCoverSensor Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer has a "cover open" sensor.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapCoverSensor As Boolean
public abstract bool CapCoverSensor { get; }
public:
virtual property bool CapCoverSensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapCoverSensor ()

public abstract function get CapCoverSensor () : boolean

Remarks

If true, the printer has a "cover open" sensor; otherwise, false.

The CapCoverSensor property is set by the Service Object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapDoubleWidth Property

FiscalPrinter.CapDoubleWidth Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer can print double-width characters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapDoubleWidth As Boolean
public abstract bool CapDoubleWidth { get; }
public:
virtual property bool CapDoubleWidth {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapDoubleWidth ()

public abstract function get CapDoubleWidth () : boolean

Remarks

If true, the printer can print double-width characters; otherwise, false.

The CapDoubleWidth property is set by the Service Object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapDuplicateReceipt Property

FiscalPrinter.CapDuplicateReceipt Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer allows printing of more than one fiscal receipt.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapDuplicateReceipt As Boolean
public abstract bool CapDuplicateReceipt { get; }
public:
virtual property bool CapDuplicateReceipt {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapDuplicateReceipt ()

public abstract function get CapDuplicateReceipt () : boolean

Remarks

If true, the printer allows printing more than one copy of a fiscal receipt; otherwise, false.

The CapDuplicateReceipt property is set by the Service Object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapEmptyReceiptIsVoidable Property

FiscalPrinter.CapEmptyReceiptIsVoidable Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer can void an opened receipt.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapEmptyReceiptIsVoidable As Boolean
public abstract bool CapEmptyReceiptIsVoidable { get; }
public:
virtual property bool CapEmptyReceiptIsVoidable {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapEmptyReceiptIsVoidable ()

public abstract function get CapEmptyReceiptIsVoidable () : boolean

Remarks

If true, then it can void an opened receipt without any items.

CapEmptyReceiptIsVoidable is set by the Service Object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapFiscalReceiptStation Property

FiscalPrinter.CapFiscalReceiptStation Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer can print transactions on the station defined by FiscalReceiptStation.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapFiscalReceiptStation As Boolean
public abstract bool CapFiscalReceiptStation { get; }
public:
virtual property bool CapFiscalReceiptStation {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapFiscalReceiptStation ()

public abstract function get CapFiscalReceiptStation () : boolean

Remarks

If true, then the fiscal printer supports printing transactions on the station defined by the FiscalReceiptStation property.

The CapFiscalReceiptStation property is set by the Service Object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapFiscalReceiptType Property

FiscalPrinter.CapFiscalReceiptType Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer can print receipts defined by FiscalReceiptType.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapFiscalReceiptType As Boolean
public abstract bool CapFiscalReceiptType { get; }
public:
virtual property bool CapFiscalReceiptType {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapFiscalReceiptType ()

public abstract function get CapFiscalReceiptType () : boolean

Remarks

If true, then the fiscal printer supports printing different types of fiscal receipts defined by the FiscalReceiptType property.

The CapFiscalReceiptType property is set by the Service Object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapFixedOutput Property

FiscalPrinter.CapFixedOutput Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer supports fixed-format printing through certain methods.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapFixedOutput As Boolean
public abstract bool CapFixedOutput { get; }
public:
virtual property bool CapFixedOutput {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapFixedOutput ()

public abstract function get CapFixedOutput () : boolean

Remarks

If true, the printer supports fixed-format text printing through the BeginFixedOutput, PrintFixedOutput, and EndFixedOutput methods; otherwise, false.

The CapFixedOutput property is set by the Service Object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapHasVatTable Property

FiscalPrinter.CapHasVatTable Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer has a VAT table.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapHasVatTable As Boolean
public abstract bool CapHasVatTable { get; }
public:
virtual property bool CapHasVatTable {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapHasVatTable ()

public abstract function get CapHasVatTable () : boolean

Remarks

If true, the printer has a value-added tax table; otherwise, false.

The CapHasVatTable property is set by the Service Object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapIndependentHeader Property

FiscalPrinter.CapIndependentHeader Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer can print header lines before the first fiscal receipt command is processed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapIndependentHeader As Boolean
public abstract bool CapIndependentHeader { get; }
public:
virtual property bool CapIndependentHeader {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapIndependentHeader ()

public abstract function get CapIndependentHeader () : boolean

Remarks

If true, the printer supports printing the fiscal receipt header lines before the first fiscal receipt command is processed; otherwise, false.

CapIndependentHeader is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapItemList Property

FiscalPrinter.CapItemList Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer can print a report of items of a specified VAT class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapItemList As Boolean
public abstract bool CapItemList { get; }
public:
virtual property bool CapItemList {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapItemList ()

public abstract function get CapItemList () : boolean

Remarks

If true, the printer can print a report of items of a specified VAT class; otherwise, false.

CapItemList is set the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapJrnEmptySensor Property

FiscalPrinter.CapJrnEmptySensor Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer has an out-of-paper sensor.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapJrnEmptySensor As Boolean
public abstract bool CapJrnEmptySensor { get; }
public:
virtual property bool CapJrnEmptySensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapJrnEmptySensor ()

public abstract function get CapJrnEmptySensor () : boolean

Remarks

If true, the journal has an out-of-paper sensor; otherwise, false.

CapJrnEmptySensor is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapJrnNearEndSensor Property

FiscalPrinter.CapJrnNearEndSensor Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer has a low-paper sensor.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapJrnNearEndSensor As Boolean
public abstract bool CapJrnNearEndSensor { get; }
public:
virtual property bool CapJrnNearEndSensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapJrnNearEndSensor ()

public abstract function get CapJrnNearEndSensor () : boolean

Remarks

If true, the journal has a low-paper sensor; otherwise, false.

CapJrnNearEndSensor is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapJrnPresent Property

FiscalPrinter.CapJrnPresent Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the journal print station is present.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapJrnPresent As Boolean
public abstract bool CapJrnPresent { get; }
public:
virtual property bool CapJrnPresent {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapJrnPresent ()

public abstract function get CapJrnPresent () : boolean

Remarks

If true, the journal print station is present; otherwise, false.

Unlike POS printers, on fiscal printers the application cannot directly access the journal. The fiscal printer prints on the journal if present.

CapJrnPresent is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapMultiContractor Property

FiscalPrinter.CapMultiContractor Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer supports more than one contractor.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapMultiContractor As Boolean
public abstract bool CapMultiContractor { get; }
public:
virtual property bool CapMultiContractor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapMultiContractor ()

public abstract function get CapMultiContractor () : boolean

Remarks

If true, then the fiscal printer supports more than one contractor assigned to the fiscal receipt and items.

CapMultiContractor is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapNonFiscalMode Property

FiscalPrinter.CapNonFiscalMode Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer can print in nonfiscal mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapNonFiscalMode As Boolean
public abstract bool CapNonFiscalMode { get; }
public:
virtual property bool CapNonFiscalMode {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapNonFiscalMode ()

public abstract function get CapNonFiscalMode () : boolean

Remarks

If true, the printer allows printing in nonfiscal mode; otherwise, false.

CapNonFiscalMode is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapOnlyVoidLastItem Property

FiscalPrinter.CapOnlyVoidLastItem Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether only the last printed item can be voided.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapOnlyVoidLastItem As Boolean
public abstract bool CapOnlyVoidLastItem { get; }
public:
virtual property bool CapOnlyVoidLastItem {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapOnlyVoidLastItem ()

public abstract function get CapOnlyVoidLastItem () : boolean

Remarks

If true, then only the last printed item can be voided.

CapOnlyVoidLastItem is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapOrderAdjustmentFirst Property

FiscalPrinter.CapOrderAdjustmentFirst Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates the order of use of PrintRecItem and PrintRecItemAdjustment.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapOrderAdjustmentFirst As Boolean
public abstract bool CapOrderAdjustmentFirst { get; }
public:
virtual property bool CapOrderAdjustmentFirst {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapOrderAdjustmentFirst ()

public abstract function get CapOrderAdjustmentFirst () : boolean

Remarks

CapOrderAdjustmentFirst defines the usage of PrintRecItem and PrintRecItemAdjustment.

If false, the application has to call PrintRecItem first and then call PrintRecItemAdjustment to give a discount or a surcharge for a single article. If true, the application has to call PrintRecItemAdjustment first and then call PrintRecItem.

CapOrderAdjustmentFirst is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapPackageAdjustment Property

FiscalPrinter.CapPackageAdjustment Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether an adjustment can be given to a package of booked items.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapPackageAdjustment As Boolean
public abstract bool CapPackageAdjustment { get; }
public:
virtual property bool CapPackageAdjustment {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapPackageAdjustment ()

public abstract function get CapPackageAdjustment () : boolean

Remarks

If true, an adjustment can be given to a package of booked items; otherwise, false.

CapPackageAdjustment is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapPercentAdjustment Property

FiscalPrinter.CapPercentAdjustment Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer handles percentage discounts or surcharges.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapPercentAdjustment As Boolean
public abstract bool CapPercentAdjustment { get; }
public:
virtual property bool CapPercentAdjustment {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapPercentAdjustment ()

public abstract function get CapPercentAdjustment () : boolean

Remarks

If true, the printer handles percentage discounts or percentage surcharges on items; otherwise, false.

CapPercentAdjustment is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapPositiveAdjustment Property

FiscalPrinter.CapPositiveAdjustment Property |
 | See Also

1/18/2008

Gets a Boolean property that indicates whether you can use the PrintRecItemAdjustment method to apply surcharges.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapPositiveAdjustment As Boolean
public abstract bool CapPositiveAdjustment { get; }
public:
virtual property bool CapPositiveAdjustment {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapPositiveAdjustment ()

public abstract function get CapPositiveAdjustment () : boolean

Remarks

If CapPositiveAdjustment is true, you can apply surcharges. Otherwise, false.

CapPositiveAdjustment is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapPositiveSubtotalAdjustment Property

FiscalPrinter.CapPositiveSubtotalAdjustment Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether you can use the PrintRecSubtotalAdjustment method to apply surcharges.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapPositiveSubtotalAdjustment As Boolean
public abstract bool CapPositiveSubtotalAdjustment { get; }
public:
virtual property bool CapPositiveSubtotalAdjustment {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapPositiveSubtotalAdjustment ()

public abstract function get CapPositiveSubtotalAdjustment () : boolean

Remarks

If true, then you can apply surcharges through the PrintRecSubtotalAdjustment method. Otherwise, the value is false.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapPostPreLine Property

FiscalPrinter.CapPostPreLine Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer can support additional lines defined by the PostLine and PreLine properties.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapPostPreLine As Boolean
public abstract bool CapPostPreLine { get; }
public:
virtual property bool CapPostPreLine {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapPostPreLine ()

public abstract function get CapPostPreLine () : boolean

Remarks

If true, then the fiscal printer supports printing additional lines defined by the PostLine and the PreLine properties when you call some PrintRec... methods.

CapPostPreline is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapPowerLossReport Property

FiscalPrinter.CapPowerLossReport Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer can print a power-loss report by using the PrintPowerLossReport method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapPowerLossReport As Boolean
public abstract bool CapPowerLossReport { get; }
public:
virtual property bool CapPowerLossReport {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapPowerLossReport ()

public abstract function get CapPowerLossReport () : boolean

Remarks

If true, the printer can print a power-loss report by using the PrintPowerLossReport method; otherwise, false.

CapPowerLossReport is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapPredefinedPaymentLines Property

FiscalPrinter.CapPredefinedPaymentLines Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer can print predefined payment descriptions.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapPredefinedPaymentLines As Boolean
public abstract bool CapPredefinedPaymentLines { get; }
public:
virtual property bool CapPredefinedPaymentLines {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapPredefinedPaymentLines ()

public abstract function get CapPredefinedPaymentLines () : boolean

Remarks

If true, the printer can store and print predefined payment descriptions; otherwise, false.

CapPredefinedPaymentLines is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapReceiptNotPaid Property

FiscalPrinter.CapReceiptNotPaid Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer supports the PrintRecNotPaid method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapReceiptNotPaid As Boolean
public abstract bool CapReceiptNotPaid { get; }
public:
virtual property bool CapReceiptNotPaid {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapReceiptNotPaid ()

public abstract function get CapReceiptNotPaid () : boolean

Remarks

If true, the printer supports by using the PrintRecNotPaid method to specify a part of the receipt total that is not paid; otherwise, false.

CapReceiptNotPaid is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapRecEmptySensor Property

FiscalPrinter.CapRecEmptySensor Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the receipt print station has an out-of-paper sensor.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRecEmptySensor As Boolean
public abstract bool CapRecEmptySensor { get; }
public:
virtual property bool CapRecEmptySensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRecEmptySensor ()

public abstract function get CapRecEmptySensor () : boolean

Remarks

If true, the receipt print station has an out-of-paper sensor; otherwise, false.

CapRecEmptySensor is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapRecNearEndSensor Property

FiscalPrinter.CapRecNearEndSensor Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the receipt print station has a low-paper sensor.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRecNearEndSensor As Boolean
public abstract bool CapRecNearEndSensor { get; }
public:
virtual property bool CapRecNearEndSensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRecNearEndSensor ()

public abstract function get CapRecNearEndSensor () : boolean

Remarks

If true, the receipt has a low-paper sensor; otherwise it is false.

CapRecNearEndSensor is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapRecPresent Property

FiscalPrinter.CapRecPresent Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the receipt print station is present.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRecPresent As Boolean
public abstract bool CapRecPresent { get; }
public:
virtual property bool CapRecPresent {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRecPresent ()

public abstract function get CapRecPresent () : boolean

Remarks

If true, the receipt print station is present; otherwise, false.

CapRecPresent is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapRemainingFiscalMemory Property

FiscalPrinter.CapRemainingFiscalMemory Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer supports the RemainingFiscalMemory property to show the Fiscal Memory remaining.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRemainingFiscalMemory As Boolean
public abstract bool CapRemainingFiscalMemory { get; }
public:
virtual property bool CapRemainingFiscalMemory {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRemainingFiscalMemory ()

public abstract function get CapRemainingFiscalMemory () : boolean

Remarks

If true, the printer supports If false, the printer does not support reporting the Fiscal Memory status of the printer.

CapRemainingFiscalMemory is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapReservedWord Property

FiscalPrinter.CapReservedWord Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer prints a reserved word before printing the total.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapReservedWord As Boolean
public abstract bool CapReservedWord { get; }
public:
virtual property bool CapReservedWord {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapReservedWord ()

public abstract function get CapReservedWord () : boolean

Remarks

If true, the printer prints a reserved word (for example, "TOTALS") before printing the total amount; otherwise, false.

If true, the reserved word is stored in the ReservedWord property. This reserved word may not be printed by using any fiscal print method.

CapReservedWord is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapSetCurrency Property

FiscalPrinter.CapSetCurrency Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the fiscal printer can change the currency to a new one by calling the SetCurrency method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSetCurrency As Boolean
public abstract bool CapSetCurrency { get; }
public:
virtual property bool CapSetCurrency {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSetCurrency ()

public abstract function get CapSetCurrency () : boolean

Remarks

If true, then the fiscal printer can change the currency to a new one by calling the SetCurrency method.

CapSetCurrency is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapSetHeader Property

FiscalPrinter.CapSetHeader Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the SetHeaderLine method can be used to initialize the contents of a particular line of the receipt header.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSetHeader As Boolean
public abstract bool CapSetHeader { get; }
public:
virtual property bool CapSetHeader {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSetHeader ()

public abstract function get CapSetHeader () : boolean

Remarks

If true, the SetHeaderLine method can be used to initialize the contents of a particular line of the receipt header; otherwise, false.

CapSetHeader is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapSetPosId Property

FiscalPrinter.CapSetPosId Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the SetPosId method can be used to initialize the values of PointOfServiceId and CashierId.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSetPosId As Boolean
public abstract bool CapSetPosId { get; }
public:
virtual property bool CapSetPosId {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSetPosId ()

public abstract function get CapSetPosId () : boolean

Remarks

If true, the SetPosId method can be used to initialize the values of PointOfServiceId and CashierId; otherwise, false.

These values are printed on each fiscal receipt.

CapSetPOSID is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapSetStoreFiscalId Property

FiscalPrinter.CapSetStoreFiscalId Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the SetStoreFiscalId method can be used to set up the Fiscal ID number.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSetStoreFiscalId As Boolean
public abstract bool CapSetStoreFiscalId { get; }
public:
virtual property bool CapSetStoreFiscalId {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSetStoreFiscalId ()

public abstract function get CapSetStoreFiscalId () : boolean

Remarks

If true, the SetStoreFiscalId method can be used to set up the Fiscal ID number printed on each fiscal receipt; otherwise, false.

CapSetStoreFiscalId is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapSetTrailer Property

FiscalPrinter.CapSetTrailer Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the SetTrailerLine method can be used to initialize the contents of a particular line of the receipt trailer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSetTrailer As Boolean
public abstract bool CapSetTrailer { get; }
public:
virtual property bool CapSetTrailer {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSetTrailer ()

public abstract function get CapSetTrailer () : boolean

Remarks

If true, the SetTrailerLine method can be used to initialize the contents of a particular line of the receipt trailer; otherwise it is false.

CapSetTrailer is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapSetVatTable Property

FiscalPrinter.CapSetVatTable Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether SetVatValue and SetVatTable can be used to modify the contents of the printer’s VAT table.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSetVatTable As Boolean
public abstract bool CapSetVatTable { get; }
public:
virtual property bool CapSetVatTable {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSetVatTable ()

public abstract function get CapSetVatTable () : boolean

Remarks

If true, the SetVatValue and SetVatTable methods can be used to modify the contents of the printer’s VAT table; otherwise, false.

Some printers may not allow existing VAT table entries to be modified. Only new entries can be set on these printers.

CapSetVatTable is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapSlpEmptySensor Property

FiscalPrinter.CapSlpEmptySensor Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the slip has a "slip in" sensor.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSlpEmptySensor As Boolean
public abstract bool CapSlpEmptySensor { get; }
public:
virtual property bool CapSlpEmptySensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSlpEmptySensor ()

public abstract function get CapSlpEmptySensor () : boolean

Remarks

If true, the slip has a "slip in" sensor; otherwise, false.

CapSlpEmptySensor is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapSlpFiscalDocument Property

FiscalPrinter.CapSlpFiscalDocument Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer enables fiscal printing to the slip station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSlpFiscalDocument As Boolean
public abstract bool CapSlpFiscalDocument { get; }
public:
virtual property bool CapSlpFiscalDocument {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSlpFiscalDocument ()

public abstract function get CapSlpFiscalDocument () : boolean

Remarks

If true, the printer allows fiscal printing to the slip station; otherwise, false.

CapSlpFiscalDocument is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapSlpFullSlip Property

FiscalPrinter.CapSlpFullSlip Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer supports printing full-length forms on the slip station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSlpFullSlip As Boolean
public abstract bool CapSlpFullSlip { get; }
public:
virtual property bool CapSlpFullSlip {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSlpFullSlip ()

public abstract function get CapSlpFullSlip () : boolean

Remarks

If true, the printer supports printing full-length forms on the slip station; otherwise, false.

You can select full slip or validation documents by setting the SlipSelection property.

CapSlpFullSlip is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapSlpNearEndSensor Property

FiscalPrinter.CapSlpNearEndSensor Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the slip has a "slip near end" sensor.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSlpNearEndSensor As Boolean
public abstract bool CapSlpNearEndSensor { get; }
public:
virtual property bool CapSlpNearEndSensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSlpNearEndSensor ()

public abstract function get CapSlpNearEndSensor () : boolean

Remarks

If true, the slip has a “slip near end” sensor; otherwise, false.

CapSlpNearEndSensor is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapSlpPresent Property

FiscalPrinter.CapSlpPresent Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer has a slip station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSlpPresent As Boolean
public abstract bool CapSlpPresent { get; }
public:
virtual property bool CapSlpPresent {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSlpPresent ()

public abstract function get CapSlpPresent () : boolean

Remarks

If true, the printer has a slip station; otherwise, false.

CapSlpPresent is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapSlpValidation Property

FiscalPrinter.CapSlpValidation Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer supports printing validation information on the slip station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSlpValidation As Boolean
public abstract bool CapSlpValidation { get; }
public:
virtual property bool CapSlpValidation {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSlpValidation ()

public abstract function get CapSlpValidation () : boolean

Remarks

If true, the printer supports printing validation information on the slip station; otherwise, false.

You can select full slip or validation documents by setting the SlipSelection property.

In some countries/regions, when printing nonfiscal validations by using the slip station, a limited number of lines can be printed.

CapSlpValidation is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapSubAmountAdjustment Property

FiscalPrinter.CapSubAmountAdjustment Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer handles fixed-amount discounts on the subtotal.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSubAmountAdjustment As Boolean
public abstract bool CapSubAmountAdjustment { get; }
public:
virtual property bool CapSubAmountAdjustment {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSubAmountAdjustment ()

public abstract function get CapSubAmountAdjustment () : boolean

Remarks

If true, the printer handles fixed-amount discounts on the subtotal; otherwise, false.

CapSubAmountAdjustment is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapSubPercentAdjustment Property

FiscalPrinter.CapSubPercentAdjustment Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer handles percentage discounts on the subtotal.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSubPercentAdjustment As Boolean
public abstract bool CapSubPercentAdjustment { get; }
public:
virtual property bool CapSubPercentAdjustment {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSubPercentAdjustment ()

public abstract function get CapSubPercentAdjustment () : boolean

Remarks

If true, the printer handles percentage discounts on the subtotal; otherwise, false.

CapSubPercentAdjustment is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapSubtotal Property

FiscalPrinter.CapSubtotal Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the PrintRecSubtotal method can be used to print the subtotal.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSubtotal As Boolean
public abstract bool CapSubtotal { get; }
public:
virtual property bool CapSubtotal {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSubtotal ()

public abstract function get CapSubtotal () : boolean

Remarks

If true, the PrintRecSubtotal method can be used to print the subtotal; otherwise, false.

CapSubtotal is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapTotalizerType Property

FiscalPrinter.CapTotalizerType Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer supports reading different types of totalizers by calling the GetTotalizer method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapTotalizerType As Boolean
public abstract bool CapTotalizerType { get; }
public:
virtual property bool CapTotalizerType {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapTotalizerType ()

public abstract function get CapTotalizerType () : boolean

Remarks

If true, the printer supports reading different types of totalizers by calling the GetTotalizer method; otherwise, false.

CapTotalizerType is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapTrainingMode Property

FiscalPrinter.CapTrainingMode Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer supports a training mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapTrainingMode As Boolean
public abstract bool CapTrainingMode { get; }
public:
virtual property bool CapTrainingMode {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapTrainingMode ()

public abstract function get CapTrainingMode () : boolean

Remarks

If true, the printer supports a training mode; otherwise, false.

CapTrainingMode is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapValidateJournal Property

FiscalPrinter.CapValidateJournal Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the PrintNormal method can be used to print a validation string on the journal station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapValidateJournal As Boolean
public abstract bool CapValidateJournal { get; }
public:
virtual property bool CapValidateJournal {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapValidateJournal ()

public abstract function get CapValidateJournal () : boolean

Remarks

If true, the PrintNormal method can be used to print a validation string on the journal station; otherwise, false.

CapValidateJournal is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CapXReport Property

FiscalPrinter.CapXReport Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the PrintXReport method can be used to print an X report.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapXReport As Boolean
public abstract bool CapXReport { get; }
public:
virtual property bool CapXReport {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapXReport ()

public abstract function get CapXReport () : boolean

Remarks

If true, the PrintXReport method can be used to print an X report; otherwise, false.

CapXReport is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.ChangeDue Property

FiscalPrinter.ChangeDue Property |
 | See Also

1/18/2008

Gets or sets the text to print as a description for the cash return when using the PrintRecTotal method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property ChangeDue As String
public abstract string ChangeDue { get; set; }
public:
virtual property String^ ChangeDue {
    String^ get () abstract;
    void set (String^ value) abstract;
}
/** @property */
public abstract String get_ChangeDue ()

/** @property */
public abstract void set_ChangeDue (String value)

public abstract function get ChangeDue () : String

public abstract function set ChangeDue (value : String)

Remarks

ChangeDue holds the text to print as a description for the cash return when you use the PrintRecTotal method.

ChangeDue is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CheckTotal Property

FiscalPrinter.CheckTotal Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether automatic comparison between the total of the fiscal printer and the total of the application is enabled.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property CheckTotal As Boolean
public abstract bool CheckTotal { get; set; }
public:
virtual property bool CheckTotal {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_CheckTotal ()

/** @property */
public abstract void set_CheckTotal (boolean value)

public abstract function get CheckTotal () : boolean

public abstract function set CheckTotal (value : boolean)

Remarks

If true, automatic comparison between the total of the fiscal printer and the total of the application is enabled. If false, automatic comparison is disabled. CheckTotal is only valid if CapCheckTotal is true.

CheckTotal is set and kept current by the service object while the device is enabled.

Accessing CheckTotal may cause a PosControlException to be thrown with the following ErrorCode:

Value | Description
Illegal | Setting CheckTotal is not valid for this service object (see CapCheckTotal)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.ContractorId Property

FiscalPrinter.ContractorId Property |
 | See Also

1/18/2008

Gets or sets the identification of the contractor to whom the receipt and some items of the receipt or to whom the receipt or some items of the receipt are assigned.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property ContractorId As FiscalContractorId
public abstract FiscalContractorId ContractorId { get; set; }
public:
virtual property FiscalContractorId ContractorId {
    FiscalContractorId get () abstract;
    void set (FiscalContractorId value) abstract;
}
/** @property */
public abstract FiscalContractorId get_ContractorId ()

/** @property */
public abstract void set_ContractorId (FiscalContractorId value)

public abstract function get ContractorId () : FiscalContractorId

public abstract function set ContractorId (value : FiscalContractorId)

Remarks

ContractorID is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CountryCode Property

FiscalPrinter.CountryCode Property |
 | See Also

1/18/2008

Gets a value identifying the countries/regions supported by this service object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CountryCode As FiscalCountryCodes
public abstract FiscalCountryCodes CountryCode { get; }
public:
virtual property FiscalCountryCodes CountryCode {
    FiscalCountryCodes get () abstract;
}
/** @property */
public abstract FiscalCountryCodes get_CountryCode ()

public abstract function get CountryCode () : FiscalCountryCodes

Remarks

CountryCode can contain any FiscalCountryCodes values joined to a logical OR.

CountryCode is typically set when the device is first initialized.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.CoverOpen Property

FiscalPrinter.CoverOpen Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer's cover is open.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CoverOpen As Boolean
public abstract bool CoverOpen { get; }
public:
virtual property bool CoverOpen {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CoverOpen ()

public abstract function get CoverOpen () : boolean

Remarks

If true, the printer's cover is open; otherwise, false.

If the CapCoverSensor property is false, the printer does not have a cover-open sensor, and CoverOpen always returns false.

CoverOpen is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.DateType Property

FiscalPrinter.DateType Property |
 | See Also

1/18/2008

Gets or sets the type of date to be requested when calling the GetDate method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property DateType As FiscalDateType
public abstract FiscalDateType DateType { get; set; }
public:
virtual property FiscalDateType DateType {
    FiscalDateType get () abstract;
    void set (FiscalDateType value) abstract;
}
/** @property */
public abstract FiscalDateType get_DateType ()

/** @property */
public abstract void set_DateType (FiscalDateType value)

public abstract function get DateType () : FiscalDateType

public abstract function set DateType (value : FiscalDateType)

Remarks

Valid values are defined by the FiscalDateType enumeration.

DateType is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.DayOpened Property

FiscalPrinter.DayOpened Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the fiscal day has been started.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DayOpened As Boolean
public abstract bool DayOpened { get; }
public:
virtual property bool DayOpened {
    bool get () abstract;
}
/** @property */
public abstract boolean get_DayOpened ()

public abstract function get DayOpened () : boolean

Remarks

If true, the fiscal day has been started on the printer; otherwise, false.

The fiscal day of the printer can be either opened or not opened. The DayOpened property reflects whether the printer considers its fiscal day to be opened or not.

Some methods can only be called while the fiscal day is not yet opened (that is, when DayOpened is false). Methods that can be called after the fiscal day is opened vary from country to country and region to region. Typically all the configuration methods should be called only before the fiscal day is opened.

Depending on fiscal legislation, some following methods may be allowed only if the printer has not yet begun its fiscal day:

SetDate SetHeaderLine SetPosId SetStoreFiscalId SetTrailerLine SetVatTable SetVatValue

DayOpened is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.DescriptionLength Property

FiscalPrinter.DescriptionLength Property |
 | See Also

1/18/2008

Gets the maximum number of characters that can be passed as a description parameter.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DescriptionLength As Integer
public abstract int DescriptionLength { get; }
public:
virtual property int DescriptionLength {
    int get () abstract;
}
/** @property */
public abstract int get_DescriptionLength ()

public abstract function get DescriptionLength () : int

Remarks

DescriptionLength is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.DuplicateReceipt Property

FiscalPrinter.DuplicateReceipt Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether all the printing commands inside a fiscal receipt are buffered and can be printed again with the PrintDuplicateReceipt method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property DuplicateReceipt As Boolean
public abstract bool DuplicateReceipt { get; set; }
public:
virtual property bool DuplicateReceipt {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_DuplicateReceipt ()

/** @property */
public abstract void set_DuplicateReceipt (boolean value)

public abstract function get DuplicateReceipt () : boolean

public abstract function set DuplicateReceipt (value : boolean)

Remarks

If true, all the printing commands inside a fiscal receipt are buffered and can be printed again with the PrintDuplicateReceipt method; otherwise, false.

DuplicateReceipt is valid only if CapDuplicateReceipt is true.

DuplicateReceipt is set and kept current by the service object while the device is enabled.

Accessing DuplicateReceipt may cause a PosControlException to be thrown with the following ErrorCode:

Value | Description
Illegal | Setting this property is not valid for this service object (see CapDuplicateReceipt).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.ErrorLevel Property

FiscalPrinter.ErrorLevel Property |
 | See Also

1/18/2008

Gets a value that indicates the severity of the error condition.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ErrorLevel As FiscalErrorLevel
public abstract FiscalErrorLevel ErrorLevel { get; }
public:
virtual property FiscalErrorLevel ErrorLevel {
    FiscalErrorLevel get () abstract;
}
/** @property */
public abstract FiscalErrorLevel get_ErrorLevel ()

public abstract function get ErrorLevel () : FiscalErrorLevel

Remarks

ErrorLevel is set and kept current by the service object while the device is enabled. ErrorLevel is set by the service object only before delivering an ErrorEvent. When the error is cleared, the property is changed to None.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.ErrorOutId Property

FiscalPrinter.ErrorOutId Property |
 | See Also

1/18/2008

Gets the identifier of the output in the queue that raised an error event when you use asynchronous printing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ErrorOutId As Integer
public abstract int ErrorOutId { get; }
public:
virtual property int ErrorOutId {
    int get () abstract;
}
/** @property */
public abstract int get_ErrorOutId ()

public abstract function get ErrorOutId () : int

Remarks

ErrorOutId is set exactly before an ErrorEvent is delivered.

ErrorOutId is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.ErrorState Property

FiscalPrinter.ErrorState Property |
 | See Also

1/18/2008

Gets the current state of the printer when raising an error event for an asynchronous output.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ErrorState As FiscalPrinterState
public abstract FiscalPrinterState ErrorState { get; }
public:
virtual property FiscalPrinterState ErrorState {
    FiscalPrinterState get () abstract;
}
/** @property */
public abstract FiscalPrinterState get_ErrorState ()

public abstract function get ErrorState () : FiscalPrinterState

Remarks

Valid values are defined by the FiscalPrinterState enumeration.

ErrorState is set and kept current by the service object while the device is enabled. ErrorState is set only before an ErrorEvent is delivered.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
PrinterState


FiscalPrinter.ErrorStation Property

FiscalPrinter.ErrorStation Property |
 | See Also

1/18/2008

Gets the station or stations that were printing when an error was detected.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ErrorStation As FiscalPrinterStations
public abstract FiscalPrinterStations ErrorStation { get; }
public:
virtual property FiscalPrinterStations ErrorStation {
    FiscalPrinterStations get () abstract;
}
/** @property */
public abstract FiscalPrinterStations get_ErrorStation ()

public abstract function get ErrorStation () : FiscalPrinterStations

Remarks

Valid values are defined by the FiscalPrinterStations enumeration.

ErrorStation should then be kept current by the service object while the device is enabled.

ErrorStation is set only before an ErrorEvent is delivered.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.ErrorString Property

FiscalPrinter.ErrorString Property |
 | See Also

1/18/2008

Gets a vendor-supplied description of the current error.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ErrorString As String
public abstract string ErrorString { get; }
public:
virtual property String^ ErrorString {
    String^ get () abstract;
}
/** @property */
public abstract String get_ErrorString ()

public abstract function get ErrorString () : String

Remarks

ErrorString is set and kept current by the service object while the device is enabled.

ErrorString is set by the service object only before delivering an ErrorEvent. If no description is available, ErrorString is set to an empty string. When the error is cleared, ErrorString is changed to an empty string.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.FiscalReceiptStation Property

FiscalPrinter.FiscalReceiptStation Property |
 | See Also

1/18/2008

Gets or sets the station where the transaction of the fiscal receipt started with BeginFiscalReceipt method will be printed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property FiscalReceiptStation As FiscalReceiptStation
public abstract FiscalReceiptStation FiscalReceiptStation { get; set; }
public:
virtual property FiscalReceiptStation FiscalReceiptStation {
    FiscalReceiptStation get () abstract;
    void set (FiscalReceiptStation value) abstract;
}
/** @property */
public abstract FiscalReceiptStation get_FiscalReceiptStation ()

/** @property */
public abstract void set_FiscalReceiptStation (FiscalReceiptStation value)

public abstract function get FiscalReceiptStation () : FiscalReceiptStation

public abstract function set FiscalReceiptStation (value : FiscalReceiptStation)

Remarks

Valid values are defined by the FiscalReceiptStation enumeration.

Setting FiscalReceiptStation is only allowed in the Monitor state.

This property is only valid if CapFiscalReceiptStation is true.

FiscalReceiptStation is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.FiscalReceiptType Property

FiscalPrinter.FiscalReceiptType Property |
 | See Also

1/18/2008

Gets or sets the type of the fiscal receipt.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property FiscalReceiptType As FiscalReceiptType
public abstract FiscalReceiptType FiscalReceiptType { get; set; }
public:
virtual property FiscalReceiptType FiscalReceiptType {
    FiscalReceiptType get () abstract;
    void set (FiscalReceiptType value) abstract;
}
/** @property */
public abstract FiscalReceiptType get_FiscalReceiptType ()

/** @property */
public abstract void set_FiscalReceiptType (FiscalReceiptType value)

public abstract function get FiscalReceiptType () : FiscalReceiptType

public abstract function set FiscalReceiptType (value : FiscalReceiptType)

Remarks

Valid values are defined by the FiscalReceiptType enumeration.

Setting FiscalReceiptType is only allowed in the Monitor state.

FiscalReceiptType is only valid if CapFiscalReceiptType is true.

FiscalReceiptType is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.FlagWhenIdle Property

FiscalPrinter.FlagWhenIdle Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether the service object raises a StatusUpdateEvent event if it is in the Idle state.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property FlagWhenIdle As Boolean
public abstract bool FlagWhenIdle { get; set; }
public:
virtual property bool FlagWhenIdle {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_FlagWhenIdle ()

/** @property */
public abstract void set_FlagWhenIdle (boolean value)

public abstract function get FlagWhenIdle () : boolean

public abstract function set FlagWhenIdle (value : boolean)

Remarks

If true, the service object raises a StatusUpdateEvent if it is in the Idle state. If false, this event is not raised.

FlagWhenIdle is automatically reset to false when the status event is delivered.

The main use of idle status event controlled by FlagWhenIdle is to give the application control when all outstanding asynchronous outputs have been processed. The event is raised if the outputs were completed successfully or if they were cleared by the ClearOutput method or by an ErrorEvent handler.

If the state is already set to Idle when the FlagWhenIdle property is set to true, a StatusUpdateEvent is raised immediately. The application can therefore depend on the event, without a race condition between the starting of its last asynchronous output and the setting of this flag.

FlagWhenIdle is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.IsExclusiveUseDevice Property

FiscalPrinter.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the Fiscal Printer is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Property Value

A value of true indicates the fiscal printer is an exclusive-use device. Otherwise, the value will be false.

Remarks

An exclusive-use device has the following properties:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before accessing some properties or calling methods that update the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.JrnEmpty Property

FiscalPrinter.JrnEmpty Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the journal is out of paper.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property JrnEmpty As Boolean
public abstract bool JrnEmpty { get; }
public:
virtual property bool JrnEmpty {
    bool get () abstract;
}
/** @property */
public abstract boolean get_JrnEmpty ()

public abstract function get JrnEmpty () : boolean

Remarks

If true, the journal is out of paper. If false, journal paper is present.

If CapJrnEmptySensor is false, the value of JrnEmpty is always false.

JrnEmpty is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
JrnNearEnd


FiscalPrinter.JrnNearEnd Property

FiscalPrinter.JrnNearEnd Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether journal paper is low.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property JrnNearEnd As Boolean
public abstract bool JrnNearEnd { get; }
public:
virtual property bool JrnNearEnd {
    bool get () abstract;
}
/** @property */
public abstract boolean get_JrnNearEnd ()

public abstract function get JrnNearEnd () : boolean

Remarks

If true, the journal paper is low. If false, journal paper is not low.

If CapJrnNearEndSensor is false, the value of JrnNearEnd is always false.

JrnNearEnd is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
FiscalPrinter.JrnEmpty Property


FiscalPrinter.MessageLength Property

FiscalPrinter.MessageLength Property |
 | See Also

1/18/2008

Gets the maximum number of characters that can be passed as a message line in the PrintRecMessage method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property MessageLength As Integer
public abstract int MessageLength { get; }
public:
virtual property int MessageLength {
    int get () abstract;
}
/** @property */
public abstract int get_MessageLength ()

public abstract function get MessageLength () : int

Remarks

The value may change in different modes of the fiscal printer. For example, in the FiscalReceipt mode, the number of characters may be bigger than in the FiscalReceiptTotal mode.

MessageLength is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.MessageType Property

FiscalPrinter.MessageType Property |
 | See Also

1/18/2008

Gets or sets the kind of message to be printed when you use the PrintRecMessage method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property MessageType As FiscalMessageType
public abstract FiscalMessageType MessageType { get; set; }
public:
virtual property FiscalMessageType MessageType {
    FiscalMessageType get () abstract;
    void set (FiscalMessageType value) abstract;
}
/** @property */
public abstract FiscalMessageType get_MessageType ()

/** @property */
public abstract void set_MessageType (FiscalMessageType value)

public abstract function get MessageType () : FiscalMessageType

public abstract function set MessageType (value : FiscalMessageType)

Remarks

Valid types are defined by the FiscalMessageType enumeration.

MessageLength is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.NumHeaderLines Property

FiscalPrinter.NumHeaderLines Property |
 | See Also

1/18/2008

Gets the maximum number of header lines that can be printed for each fiscal receipt.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property NumHeaderLines As Integer
public abstract int NumHeaderLines { get; }
public:
virtual property int NumHeaderLines {
    int get () abstract;
}
/** @property */
public abstract int get_NumHeaderLines ()

public abstract function get NumHeaderLines () : int

Remarks

Header lines usually contain information such as store address, store name, store fiscal ID. Each header line is set by using the SetHeaderLine method and remains set even after the printer is switched off. Header lines are automatically printed when a fiscal receipt is initiated by using the BeginFiscalReceipt method or when the first line item inside a receipt is sold.

NumHeaderLines is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.NumTrailerLines Property

FiscalPrinter.NumTrailerLines Property |
 | See Also

1/18/2008

Gets the maximum number of trailer lines that can be printed for each fiscal receipt.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property NumTrailerLines As Integer
public abstract int NumTrailerLines { get; }
public:
virtual property int NumTrailerLines {
    int get () abstract;
}
/** @property */
public abstract int get_NumTrailerLines ()

public abstract function get NumTrailerLines () : int

Remarks

Trailer lines are usually promotional messages. Each trailer line is set by using the SetTrailerLine method and remains set even after the printer is switched off. Trailer lines are automatically printed either after the last PrintRecTotal or when a fiscal receipt is closed by using the EndFiscalReceipt method.

NumTrailerLines is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.NumVatRates Property

FiscalPrinter.NumVatRates Property |
 | See Also

1/18/2008

Gets the maximum number of VAT rates that can be entered into the printer’s VAT table.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property NumVatRates As Integer
public abstract int NumVatRates { get; }
public:
virtual property int NumVatRates {
    int get () abstract;
}
/** @property */
public abstract int get_NumVatRates ()

public abstract function get NumVatRates () : int

Remarks

NumVatRates is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.OutputId Property

FiscalPrinter.OutputId Property |
 | See Also

1/18/2008

Gets the identifier of the most recently started asynchronous output.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property OutputId As Integer
public abstract int OutputId { get; }
public:
virtual property int OutputId {
    int get () abstract;
}
/** @property */
public abstract int get_OutputId ()

public abstract function get OutputId () : int

Remarks

When a method successfully starts an asynchronous output, the device assigns an identifier to the request. When the output is complete, an OutputCompleteEvent is queued with this output ID as a parameter.

The output ID numbers are assigned by the POS for .NET and are guaranteed to be unique among the set of outstanding asynchronous outputs. No other facts about the ID should be assumed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.PostLine Property

FiscalPrinter.PostLine Property |
 | See Also

1/18/2008

Gets or sets application-specific text to print on the fiscal receipt after a line item invoked by some PrintRec methods.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property PostLine As String
public abstract string PostLine { get; set; }
public:
virtual property String^ PostLine {
    String^ get () abstract;
    void set (String^ value) abstract;
}
/** @property */
public abstract String get_PostLine ()

/** @property */
public abstract void set_PostLine (String value)

public abstract function get PostLine () : String

public abstract function set PostLine (value : String)

Remarks

PostLine can be written in the Fiscal Receipt state. The length of the text is reduced to a country/region-specific value.

PostLine is only valid if CapPostPreLine is true.

PostLine is typically initialized to an empty string and is reset to an empty string after it is used.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.PredefinedPaymentLines Property

FiscalPrinter.PredefinedPaymentLines Property |
 | See Also

1/18/2008

Gets a string that indicates that only predefined payment lines are allowed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property PredefinedPaymentLines As String()
public abstract string[] PredefinedPaymentLines { get; }
public:
virtual property array<String^>^ PredefinedPaymentLines {
    array<String^>^ get () abstract;
}
/** @property */
public abstract String[] get_PredefinedPaymentLines ()

public abstract function get PredefinedPaymentLines () : String[]

Remarks

If CapPredefinedPaymentLines is true, only predefined payment lines are allowed. The value of PredefinedPaymentLines is the list of all possible words to be used as indexes of the predefined payment lines (for example, “a,b,c,d,z”). Those indexes are used in the PrintRecTotal method for the description parameter.

PredefinedPaymentLines is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.PreLine Property

FiscalPrinter.PreLine Property |
 | See Also

1/18/2008

Gets or sets application-specific text to be printed on the fiscal receipt before a line item invoked by some PrintRec methods.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property PreLine As String
public abstract string PreLine { get; set; }
public:
virtual property String^ PreLine {
    String^ get () abstract;
    void set (String^ value) abstract;
}
/** @property */
public abstract String get_PreLine ()

/** @property */
public abstract void set_PreLine (String value)

public abstract function get PreLine () : String

public abstract function set PreLine (value : String)

Remarks

PreLine can be written in the Fiscal Receipt state. The length of the text is reduced to a country/region-specific value.

PreLine is only valid if CapPostPreLine is true.

PreLine is typically initialized to an empty string and is reset to an empty string after it is used.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.PrinterState Property

FiscalPrinter.PrinterState Property |
 | See Also

1/18/2008

Gets the printer's current operational state.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property PrinterState As FiscalPrinterState
public abstract FiscalPrinterState PrinterState { get; }
public:
virtual property FiscalPrinterState PrinterState {
    FiscalPrinterState get () abstract;
}
/** @property */
public abstract FiscalPrinterState get_PrinterState ()

public abstract function get PrinterState () : FiscalPrinterState

Remarks

Valid values are defined by the FiscalPrinterState enumeration.

PrinterState controls which methods are currently legal.

A few methods are accepted in any state except Locked. These are as follows: BeginInsertion, EndInsertion, BeginRemoval, EndRemoval, GetDate, GetData, GetTotalizer, GetVatEntry, ResetPrinter and ClearOutput.

PrinterState is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.QuantityDecimalPlaces Property

FiscalPrinter.QuantityDecimalPlaces Property |
 | See Also

1/18/2008

Gets the number of decimal digits in the fractional part that should be assumed to be in any quantity parameter that is passed to this service object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property QuantityDecimalPlaces As Integer
public abstract int QuantityDecimalPlaces { get; }
public:
virtual property int QuantityDecimalPlaces {
    int get () abstract;
}
/** @property */
public abstract int get_QuantityDecimalPlaces ()

public abstract function get QuantityDecimalPlaces () : int

Remarks

QuantityDecimalPlaces is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.QuantityLength Property

FiscalPrinter.QuantityLength Property |
 | See Also

1/18/2008

Gets the maximum number of digits that can be passed as a quantity parameter. This includes both the whole and fractional parts.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property QuantityLength As Integer
public abstract int QuantityLength { get; }
public:
virtual property int QuantityLength {
    int get () abstract;
}
/** @property */
public abstract int get_QuantityLength ()

public abstract function get QuantityLength () : int

Remarks

QuantityLength is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.RecEmpty Property

FiscalPrinter.RecEmpty Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the receipt station is out of paper.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property RecEmpty As Boolean
public abstract bool RecEmpty { get; }
public:
virtual property bool RecEmpty {
    bool get () abstract;
}
/** @property */
public abstract boolean get_RecEmpty ()

public abstract function get RecEmpty () : boolean

Remarks

If true, the receipt station is out of paper. If false, receipt paper is present.

If CapRecEmptySensor is false, then the value of this property is always false.

RecEmpty is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
RecNearEnd


FiscalPrinter.RecNearEnd Property

FiscalPrinter.RecNearEnd Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the receipt station is low on paper.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property RecNearEnd As Boolean
public abstract bool RecNearEnd { get; }
public:
virtual property bool RecNearEnd {
    bool get () abstract;
}
/** @property */
public abstract boolean get_RecNearEnd ()

public abstract function get RecNearEnd () : boolean

Remarks

If true, the receipt paper is low. If false, receipt paper is not low.

If CapRecNearEndSensor is false, then the value of this property is always false.

RecNearEnd is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
FiscalPrinter.RecEmpty Property


FiscalPrinter.RemainingFiscalMemory Property

FiscalPrinter.RemainingFiscalMemory Property |
 | See Also

1/18/2008

Gets the remaining counter of Fiscal Memory.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property RemainingFiscalMemory As Integer
public abstract int RemainingFiscalMemory { get; }
public:
virtual property int RemainingFiscalMemory {
    int get () abstract;
}
/** @property */
public abstract int get_RemainingFiscalMemory ()

public abstract function get RemainingFiscalMemory () : int

Remarks

RemainingFiscalMemory is set and kept current by the service object while the device is enabled. It can be updated by the PrintZReport method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
FiscalPrinter.CapRemainingFiscalMemory Property


FiscalPrinter.ReservedWord Property

FiscalPrinter.ReservedWord Property |
 | See Also

1/18/2008

Gets the string that is automatically printed with the total when the PrintRecTotal method is called.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ReservedWord As String
public abstract string ReservedWord { get; }
public:
virtual property String^ ReservedWord {
    String^ get () abstract;
}
/** @property */
public abstract String get_ReservedWord ()

public abstract function get ReservedWord () : String

Remarks

This word is not allowed in any string that is passed into a fiscal output method.

ReservedWord is only valid if CapReservedWord is true. ReservedWord is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.SlipSelection Property

FiscalPrinter.SlipSelection Property |
 | See Also

1/18/2008

Gets or sets the kind of document to print on the slip station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property SlipSelection As FiscalSlipSelection
public abstract FiscalSlipSelection SlipSelection { get; set; }
public:
virtual property FiscalSlipSelection SlipSelection {
    FiscalSlipSelection get () abstract;
    void set (FiscalSlipSelection value) abstract;
}
/** @property */
public abstract FiscalSlipSelection get_SlipSelection ()

/** @property */
public abstract void set_SlipSelection (FiscalSlipSelection value)

public abstract function get SlipSelection () : FiscalSlipSelection

public abstract function set SlipSelection (value : FiscalSlipSelection)

Remarks

Valid values are defined by the FiscalSlipSelection enumeration.

SlipSelection is typically initialized to FullLength.

Accessing SlipSelection may cause a PosControlException to be thrown with the following ErrorCode:

Value | Description
Illegal | An invalid slip type was specified.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.SlpEmpty Property

FiscalPrinter.SlpEmpty Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether a slip form is present.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property SlpEmpty As Boolean
public abstract bool SlpEmpty { get; }
public:
virtual property bool SlpEmpty {
    bool get () abstract;
}
/** @property */
public abstract boolean get_SlpEmpty ()

public abstract function get SlpEmpty () : boolean

Remarks

If true, a slip form is not present. If false, a slip form is present.

If CapSlpEmptySensor is false, the value of this property is always false.

SlpEmpty is set and kept current by the service object while the device is enabled.

Note:
The "slip empty" sensor should be primarily used to determine whether a form has been inserted before printing, and can be monitored to determine whether a form is still available. This sensor is usually put one or more print lines above the slip print head. However, the "slip near end" sensor (when present) should be used to determine when nearing the end of the slip. This sensor is usually put one or more print lines below the slip print head.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
SlpNearEnd


FiscalPrinter.SlpNearEnd Property

FiscalPrinter.SlpNearEnd Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether a slip form is almost at its end.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property SlpNearEnd As Boolean
public abstract bool SlpNearEnd { get; }
public:
virtual property bool SlpNearEnd {
    bool get () abstract;
}
/** @property */
public abstract boolean get_SlpNearEnd ()

public abstract function get SlpNearEnd () : boolean

Remarks

If true, the slip form is near its end. If false, the slip form is not near its end.

The "near end" sensor is also also known as the "trailing edge" sensor, referring to the bottom edge of the slip.

If the CapSlpNearEndSensor property is false, the value of the SlpNearEnd property is always false.

SlpNearEnd is set and kept current by the service object while the device is enabled.

Note:
The "slip empty" sensor should be primarily used to determine whether a form has been inserted before printing, and can be monitored to determine whether a form is still in place. This sensor is usually put one or more print lines above the slip print head. However, the "slip near end" sensor (when present) should be used to determine when nearing the end of the slip. This sensor is usually put one or more print lines below the slip print head.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace
FiscalPrinter.SlpEmpty Property


FiscalPrinter.TotalizerType Property

FiscalPrinter.TotalizerType Property |
 | See Also

1/18/2008

Gets or sets the type of totalizer to be requested when calling the GetTotalizer method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property TotalizerType As FiscalTotalizerType
public abstract FiscalTotalizerType TotalizerType { get; set; }
public:
virtual property FiscalTotalizerType TotalizerType {
    FiscalTotalizerType get () abstract;
    void set (FiscalTotalizerType value) abstract;
}
/** @property */
public abstract FiscalTotalizerType get_TotalizerType ()

/** @property */
public abstract void set_TotalizerType (FiscalTotalizerType value)

public abstract function get TotalizerType () : FiscalTotalizerType

public abstract function set TotalizerType (value : FiscalTotalizerType)

Remarks

Valid types are defined by the FiscalTotalizerType enumeration.

TotalizerType is set and kept current by the service object while the device is enabled.

TotalizerType is only valid if CapTotalizerType is true.

Accessing TotalizerType may cause a PosControlException to be thrown with the following ErrorCode:

Value | Description
Illegal | An invalid slip type was specified.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.TrainingModeActive Property

FiscalPrinter.TrainingModeActive Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer's operational state allows the training mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property TrainingModeActive As Boolean
public abstract bool TrainingModeActive { get; }
public:
virtual property bool TrainingModeActive {
    bool get () abstract;
}
/** @property */
public abstract boolean get_TrainingModeActive ()

public abstract function get TrainingModeActive () : boolean

Remarks

Training mode allows all fiscal commands, but each receipt is marked as nonfiscal and no internal printer registers are updated with data while in training mode. Some fiscal rules for countries/regions require that all blank characters on a training mode receipt are replaced by another character. Italy, for example, requires that all training mode receipts print a "?" (question mark) instead of a blank.

TrainingModeActive is set and kept current by the service object while the device is enabled.

Values are as follows:

Value | Description
true | The printer is in training mode. No data is written into the EPROM of the fiscal printer.
false | The printer is in normal mode. All printed receipts are also update the fiscal memory.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter Events

FiscalPrinter Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
ErrorEvent | Notifies the application that a fiscal printer error has been detected and that a suitable response by the application is necessary to process the error condition.
OutputCompleteEvent | Notifies the application that the queued output request associated with the OutputId property has completed successfully.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

FiscalPrinter Class
Microsoft.PointOfService Namespace


FiscalPrinter.ErrorEvent Event

FiscalPrinter.ErrorEvent Event |
 | See Also

1/18/2008

Notifies the application that a fiscal printer error has been detected and that a suitable response by the application is necessary to process the error condition.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event ErrorEvent As DeviceErrorEventHandler
public abstract event DeviceErrorEventHandler ErrorEvent
public:
virtual event DeviceErrorEventHandler^ ErrorEvent {
    void add (DeviceErrorEventHandler^ value) abstract;
    void remove (DeviceErrorEventHandler^ value) abstract;
}
/** @event */
public abstract void add_ErrorEvent (DeviceErrorEventHandler value)

/** @event */
public abstract void remove_ErrorEvent (DeviceErrorEventHandler value)

Remarks

ErrorEvent is queued when an error is detected and the POS for .NET state transitions into the error state. This event is not delivered until DataEventEnabled is true, so that proper application sequencing occurs.

If DeviceErrorEventArgs.ErrorCode property is set to Extended, then ErrorCodeExtended is set to one of the following values:

Value | Description
ExtendedErrorCoverOpen | The printer cover is open.
ExtendedErrorJournalEmpty | The journal station is out of paper.
ExtendedErrorReceiptEmpty | The receipt station is out of paper.
ExtendedErrorSlipEmpty | A form is not inserted in the slip station.
ExtendedErrorWrongState | The requested method could not be executed in the printer’s current state.
ExtendedErrorTechnicalAssistance | The printer has encountered a severe error condition. Calling for printer technical assistance is required.
ExtendedErrorClockError | The printer’s internal clock has failed.
ExtendedErrorMemoryFull | The printer memory has been exhausted.
ExtendedErrorMemoryDisconnected | The printer memory has been disconnected.
ExtendedErrorTotalsError | The Grand Total in working memory does not match the one in the EPROM.
ExtendedErrorBadItemQuantity | The quantity parameter is invalid.
ExtendedErrorBadItemAmount | The amount parameter is invalid.
ExtendedErrorBadItemDescription | The description parameter is either to long, contains illegal characters, or contains a reserved word.
ExtendedErrorReceiptTotalOverflow | The receipt total has overflowed.
ExtendedErrorBadVat | The VAT parameter is invalid.
ExtendedErrorBadPrice | The price parameter is invalid.
ExtendedErrorNegativeTotal | The printer’s computed total or subtotal is less than zero.
ExtendedErrorMissingDevices | A device required by local fiscal legislation is not connected. In some countries or regions, a set of peripheral devices (such as cash drawer and customer display) must be connected to the POS to use a fiscal printer. If any of these devices is not present, sales are not allowed.

DeviceErrorEventArgs.ErrorLocus is set to Output, indicating the error occurred while processing asynchronous output.

DeviceErrorEventArgs.ErrorResponse is preset to the default value of Retry. The application's error processing can also change the value of ErrorResponse to Clear to clear all buffered output data.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinter.OutputCompleteEvent Event

FiscalPrinter.OutputCompleteEvent Event |
 | See Also

1/18/2008

Notifies the application that the queued output request associated with the OutputId property has completed successfully.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event OutputCompleteEvent As OutputCompleteEventHandler
public abstract event OutputCompleteEventHandler OutputCompleteEvent
public:
virtual event OutputCompleteEventHandler^ OutputCompleteEvent {
    void add (OutputCompleteEventHandler^ value) abstract;
    void remove (OutputCompleteEventHandler^ value) abstract;
}
/** @event */
public abstract void add_OutputCompleteEvent (OutputCompleteEventHandler value)

/** @event */
public abstract void remove_OutputCompleteEvent (OutputCompleteEventHandler value)

Remarks

OutputCompleteEvent is queued after the request's data has been sent and POS for .NET has confirmation that it was processed successfully by the device.

See Also

Reference

FiscalPrinter Class
FiscalPrinter Members
Microsoft.PointOfService Namespace


FiscalPrinterState Enumeration

FiscalPrinterState Enumeration |
 | See Also

1/18/2008

Enumerates the possible printer operational states that can be reported for a fiscal printer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration FiscalPrinterState
public enum FiscalPrinterState
public enum class FiscalPrinterState
public enum FiscalPrinterState
public enum FiscalPrinterState

Members

Member name | Description
FiscalDocument | The printer is processing a fiscal slip. In this state, the printer accepts either the PrintFiscalDocumentLine or EndFiscalDocument method.
FiscalReceipt | If the TrainingModeActive property is false, the printer is processing a fiscal receipt. In this state, the printer accepts any of the PrintRec methods.
FiscalReceiptEnding | If the TrainingModeActive property is false, the printer has completed the receipt up to the total line. In this state, the printer accepts either the PrintRecMessage or EndFiscalReceipt method.
FiscalReceiptTotal | If the TrainingModeActive property is false, the printer has already accepted at least one payment. However, the total has not been completely paid. In this state, the printer accepts either the PrintRecTotal or PrintRecNotPaid method.
FixedOutput | The printer is processing fixed text output to one or more stations. In this state, the printer accepts either the PrintFixedOutput or EndFixedOutput method.
ItemList | The printer is processing an item list report. In this state, the printer accepts either the VerifyItem or EndItemList method.
Locked | The printer has encountered a non-recoverable hardware problem. An authorized printer technician must be contacted to exit this state.
Monitor | If the TrainingModeActive property is false, the printer is not in a specific operational mode. In this state, the printer accepts any of the Begin methods and the Set methods.
NonFiscal | The printer is processing nonfiscal output to one or more stations. In this state, the printer accepts either the PrintNormal or EndNonFiscal method.
Report | The printer is processing a fiscal report. In this state, the printer does not accept any methods until the report has been completed.

Remarks

Used by the ErrorState and PrinterState properties. Members of this enumeration replace the FPTR_PS_ family of UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
FiscalPrinter.PrinterState Property


FiscalPrinterStations Enumeration

FiscalPrinterStations Enumeration |
 | See Also

1/18/2008

Enumerates the possible fiscal printer stations that can be set to print or reported as printing during the occurrence of an error.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration FiscalPrinterStations
[FlagsAttribute]
public enum FiscalPrinterStations
[FlagsAttribute]
public enum class FiscalPrinterStations
/** @attribute FlagsAttribute() */
public enum FiscalPrinterStations
FlagsAttribute
public enum FiscalPrinterStations

Members

Member name | Description
Journal | Journal station.
JournalReceipt | Journal receipt station.
JournalSlip | Journal slip station.
Receipt | Receipt station.
ReceiptSlip | Receipt slip station.
Slip | Slip station.

Remarks

Used by the ErrorStation property and PrintNormal method. Members of this enumeration replace the FPTR_S_ family of UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
FiscalPrinter.ErrorStation Property


FiscalReceiptStation Enumeration

FiscalReceiptStation Enumeration |
 | See Also

1/18/2008

Enumerates the valid fiscal printer stations that can be used to start non-fiscal fixed text printing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration FiscalReceiptStation
public enum FiscalReceiptStation
public enum class FiscalReceiptStation
public enum FiscalReceiptStation
public enum FiscalReceiptStation

Members

Member name | Description
Receipt | The following transactions will be printed on the receipt station.
Slip | The following transactions will be printed on the slip station.

Remarks

Used by the FiscalReceiptStation property and the BeginFixedOutput method. Members of this enumeration replace the FPTR_S_RECEIPT and FPTR_S_SLIP constants form UPOS.

See Also

Reference

Microsoft.PointOfService Namespace
FiscalPrinter.FiscalReceiptStation Property
FiscalPrinter.BeginFixedOutput Method


FiscalReceiptType Enumeration

FiscalReceiptType Enumeration |
 | See Also

1/18/2008

Enumerates the valid types of receipts for a fiscal printer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration FiscalReceiptType
public enum FiscalReceiptType
public enum class FiscalReceiptType
public enum FiscalReceiptType
public enum FiscalReceiptType

Members

Member name | Description
CashIn | Cash-in receipt.
CashOut | Cash-out receipt.
Generic | Generic receipt.
Refund | Refund receipt.
Sales | Retail sales receipt.
Service | Service sales receipt.
SimpleInvoice | Simplified invoice receipt.

Remarks

Used by the FiscalReceiptType property. Members of this enumeration replace the FPTR_RT_ family of UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
FiscalPrinter.FiscalReceiptType Property


FiscalSlipSelection Enumeration

FiscalSlipSelection Enumeration |
 | See Also

1/18/2008

Enumerates two document types—full-length and validation—to be printed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration FiscalSlipSelection
public enum FiscalSlipSelection
public enum class FiscalSlipSelection
public enum FiscalSlipSelection
public enum FiscalSlipSelection

Members

Member name | Description
FullLength | Prints full-length documents.
Validation | Prints validation documents.

Remarks

Used by the SlipSelection property. Members of this property replace the FPTR_SS_FULL_LENGTH and FPTR_SS_VALIDATION UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
FiscalPrinter.SlipSelection Property


FiscalTotalizer Enumeration

FiscalTotalizer Enumeration |
 | See Also

1/18/2008

Enumerates the possible types of totalizers for a fiscal printer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration FiscalTotalizer
public enum FiscalTotalizer
public enum class FiscalTotalizer
public enum FiscalTotalizer
public enum FiscalTotalizer

Members

Member name | Description
Discount | Discount totalizer specified by the TotalizerType and ContractorId properties.
DiscountVoid | Voided discount totalizer specified by the TotalizerType and ContractorId properties.
Gross | Gross totalizer specified by the TotalizerType and ContractorId properties.
Item | Item totalizer specified by the TotalizerType and ContractorId properties.
ItemVoid | Voided item totalizer specified by the TotalizerType and ContractorId properties.
Net | Net totalizer specified by the TotalizerType and ContractorId properties.
NotPaid | Not paid totalizer specified by the TotalizerType and ContractorId properties.
Refund | Refund totalizer specified by the TotalizerType and ContractorId properties.
RefundVoid | Voided refund totalizer specified by the TotalizerType and ContractorId properties.
SubtotalDiscount | Subtotal discount totalizer specified by the TotalizerType and ContractorId properties.
SubtotalDiscountVoid | Voided discount totalizer specified by the TotalizerType and ContractorId properties.
SubtotalSurcharges | Subtotal surcharges totalizer specified by the TotalizerType and ContractorId properties.
SubtotalSurchargesVoid | Voided surcharges totalizer specified by the TotalizerType and ContractorId properties.
Surcharge | Surcharge totalizer specified by the TotalizerType and ContractorId properties.
SurchargeVoid | Voided surcharge totalizer specified by the TotalizerType and ContractorId properties.
Vat | VAT totalizer specified by the TotalizerType and ContractorId properties.
VatCategory | VAT totalizer per VAT category specified by the TotalizerType and ContractorId properties associated to the given vatId.

Remarks

Used by the GetTotalizer method. Members of this enumeration replace the FPTR_GT_ family of UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
FiscalPrinter.GetTotalizer Method
FiscalPrinter.TotalizerType Property
ContractorId


FiscalTotalizerType Enumeration

FiscalTotalizerType Enumeration |
 | See Also

1/18/2008

Enumerates the possible types of totalizers.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration FiscalTotalizerType
public enum FiscalTotalizerType
public enum class FiscalTotalizerType
public enum FiscalTotalizerType
public enum FiscalTotalizerType

Members

Member name | Description
Day | Day totalizer.
Document | Document totalizer.
Grand | Grand totalizer.
Receipt | Receipt totalizer.

Remarks

Used by the TotalizerType property. Members of this enumeration replace the FPTR_TT_DOCUMENT, FPTR_TT_DAY, FPTR_TT_RECEIPT, and FPTR_TT_GRAND UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
FiscalPrinter.TotalizerType Property


FrameType Enumeration

FrameType Enumeration |
 | See Also Example

1/18/2008

Enumerates the possible types of information contained within the Image Scanner's FrameData property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration FrameType
public enum FrameType
public enum class FrameType
public enum FrameType
public enum FrameType

Members

Member name | Description
Still | The FrameData property contains a single still image.
Video | The FrameData property contains a block of video data.

Example

FrameData

ImageScanner

See Also

Reference

Microsoft.PointOfService Namespace


Gate Class

Gate Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a UPOS Gate device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class Gate
    Inherits PosCommon
public abstract class Gate : PosCommon
public ref class Gate abstract : public PosCommon
public abstract class Gate extends PosCommon
public abstract class Gate extends PosCommon

Remarks

Various doors and gates can be controlled by the Gate device category. Examples include the following:

  • Kiosk front door which can be opened by an application for servicing.

  • Self Checkout door which can be opened by an application for servicing.

  • Exit gate in kiosk or self checkout environments where a customer scans a bar code printed on the receipt in order to open the gate.

Required Version

The Gate class requires POS for .NET version 1.12 or later versions.

Capabilities

The Gate device has the following capability:

  • Supports a command to "open" the gate.

The Gate device may have the following additional capability:

  • Gate status reporting to indicate that the service can determine whether the gate is opened or closed in environments where the gate can be accessed through a hardware port.

Device Sharing

The gate is a shareable device. The device sharing rules are as follows:

  • After you open and enabling the device, the application may access all properties and methods and receives status update events.

  • If more than one application has opened and enabled the device, each of these applications may access its properties and methods. Status update events are raised to all these applications.

  • If one application claims the gate, then only that application may call the OpenGate and WaitForGateClose methods. This feature provides a degree of security, in such a way that these methods may effectively be restricted to the main application if that application claims the device at startup.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.Gate
Microsoft.PointOfService.BasicServiceObjects.GateBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Gate Members
Microsoft.PointOfService Namespace


Gate Members

Gate Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a UPOS Gate device.

The following tables list the members exposed by the Gate type.

Protected Constructors

Name | Description
Gate | Creates an instance of the Gate class.
Top

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusBlocked | Indicates that the gate is blocked.
StatusClosed | Indicates that the gate is closed.
StatusMalfunction | Indicates that the gate has a hardware problem.
StatusOpen | Indicates that the gate is open.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapGateStatus | Gets a Boolean value that indicates whether the gate can report a status.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
GateStatus | Gets the current status of the device.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether the device is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon)
OpenGate | Opens the gate.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
WaitForGateClose | Waits until the gate is closed.
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

Gate Class
Microsoft.PointOfService Namespace


Gate Fields

Gate Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusBlocked | Indicates that the gate is blocked.
StatusClosed | Indicates that the gate is closed.
StatusMalfunction | Indicates that the gate has a hardware problem.
StatusOpen | Indicates that the gate is open.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

Gate Class
Microsoft.PointOfService Namespace


Gate.StatusBlocked Field

Gate.StatusBlocked Field |
 | See Also

1/18/2008

Indicates that the gate is blocked.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusBlocked As Integer
public const int StatusBlocked
public:
literal int StatusBlocked
public static final int StatusBlocked
public const var StatusBlocked : int

See Also

Reference

Gate Class
Gate Members
Microsoft.PointOfService Namespace


Gate.StatusClosed Field

Gate.StatusClosed Field |
 | See Also

1/18/2008

Indicates that the gate is closed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusClosed As Integer
public const int StatusClosed
public:
literal int StatusClosed
public static final int StatusClosed
public const var StatusClosed : int

See Also

Reference

Gate Class
Gate Members
Microsoft.PointOfService Namespace


Gate.StatusMalfunction Field

Gate.StatusMalfunction Field |
 | See Also

1/18/2008

Indicates that the gate has a hardware problem.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusMalfunction As Integer
public const int StatusMalfunction
public:
literal int StatusMalfunction
public static final int StatusMalfunction
public const var StatusMalfunction : int

Remarks

Technical help is needed.

See Also

Reference

Gate Class
Gate Members
Microsoft.PointOfService Namespace


Gate.StatusOpen Field

Gate.StatusOpen Field |
 | See Also

1/18/2008

Indicates that the gate is open.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusOpen As Integer
public const int StatusOpen
public:
literal int StatusOpen
public static final int StatusOpen
public const var StatusOpen : int

See Also

Reference

Gate Class
Gate Members
Microsoft.PointOfService Namespace


Gate Constructor

Gate Constructor |
 | See Also

1/18/2008

Creates an instance of the Gate class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected Gate ()
protected:
Gate ()
protected Gate ()
protected function Gate ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

Gate Class
Gate Members
Microsoft.PointOfService Namespace


Gate Methods

Gate Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon )
OpenGate | Opens the gate.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
WaitForGateClose | Waits until the gate is closed.

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

Gate Class
Microsoft.PointOfService Namespace


Gate.OpenGate Method

Gate.OpenGate Method |
 | See Also

1/18/2008

Opens the gate.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub OpenGate
public abstract void OpenGate ()
public:
virtual void OpenGate () abstract
public abstract void OpenGate ()
public abstract function OpenGate ()

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Gate Class
Gate Members
Microsoft.PointOfService Namespace


Gate.WaitForGateClose Method

Gate.WaitForGateClose Method |
 | See Also

1/18/2008

Waits until the gate is closed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub WaitForGateClose ( _
    timeout As Integer _
)
public abstract void WaitForGateClose (
    int timeout
)
public:
virtual void WaitForGateClose (
    int timeout
) abstract
public abstract void WaitForGateClose (
    int timeout
)
public abstract function WaitForGateClose (
    timeout : int
)

Parameters

timeout

Maximum number of milliseconds to wait until the gate is closed before it returns control back to the application. If WaitForever is defined, the method waits as long as needed until the gate is closed or an error occurs.

Remarks

Unless an exception is thrown, this method does not return to the application while the gate is open.

If the CapGateStatus property is false, then the device does not support status reporting, and this method returns immediately.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Gate Class
Gate Members
Microsoft.PointOfService Namespace


Gate Properties

Gate Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapGateStatus | Gets a Boolean value that indicates whether the gate can report a status.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
GateStatus | Gets the current status of the device.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether the device is an exclusive-use device.

See Also

Reference

Gate Class
Microsoft.PointOfService Namespace


Gate.CapGateStatus Property

Gate.CapGateStatus Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the gate can report a status.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapGateStatus As Boolean
public abstract bool CapGateStatus { get; }
public:
virtual property bool CapGateStatus {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapGateStatus ()

public abstract function get CapGateStatus () : boolean

Remarks

If true, the gate can report status. If false, the service cannot determine whether the gate is open or closed.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Gate Class
Gate Members
Microsoft.PointOfService Namespace


Gate.GateStatus Property

Gate.GateStatus Property |
 | See Also

1/18/2008

Gets the current status of the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property GateStatus As GateStatus
public abstract GateStatus GateStatus { get; }
public:
virtual property GateStatus GateStatus {
    GateStatus get () abstract;
}
/** @property */
public abstract GateStatus get_GateStatus ()

public abstract function get GateStatus () : GateStatus

Remarks

If the CapGateStatus property is false, then the device does not support status reporting, and this property has no meaning.

This property is initialized and kept current while the device is enabled.

An appropriate StatusUpdateEvent event indicates a status change will be enqueued.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Gate Class
Gate Members
Microsoft.PointOfService Namespace


Gate.IsExclusiveUseDevice Property

Gate.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Gate Class
Gate Members
Microsoft.PointOfService Namespace


Gate Events

Gate Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

Gate Class
Microsoft.PointOfService Namespace


GateStatus Enumeration

GateStatus Enumeration |
 | See Also

1/18/2008

Enumerates the status of the Gate.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration GateStatus
public enum GateStatus
public enum class GateStatus
public enum GateStatus
public enum GateStatus

Members

Member name | Description
Blocked | The gate is blocked.
Closed | The gate is closed.
Malfunction | The gate has a hardware problem. Technical help is needed.
Open | The gate is open.

See Also

Reference

Microsoft.PointOfService Namespace


HardTotals Class

HardTotals Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a UPOS hard totals device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class HardTotals
    Inherits PosCommon
public abstract class HardTotals : PosCommon
public ref class HardTotals abstract : public PosCommon
public abstract class HardTotals extends PosCommon
public abstract class HardTotals extends PosCommon

Remarks

Capabilities

The hard totals device has the following minimal set of capabilities:

  • Supports at least one totals file that has the name "" (the empty string) in an area of totals memory. Each totals file is read and written as if it were a sequence of byte data.

  • Each totals file is created by using a fixed size and can be deleted, initialized, and claimed for exclusive use.

The hard totals device may have the following additional capabilities:

  • Supports additional named totals files. They share some characteristics of a file system with only a root directory level. In addition to the minimal capabilities listed earlier, each totals file may also be renamed.

  • Supports transactions, with begin and commit operations, plus rollback.

  • Supports advanced error detection. This detection may be implemented through hardware or software.

Model

Totals memory is frequently a limited but secure resource perhaps of only several thousand bytes of storage. The following is the general model of the hard totals:

  • A hard totals device is logically treated as a sequence of byte data that the application subdivides into "totals files." This is done by the service object Create method that assigns a name, size, and error detection level to the totals file. Totals files have a fixed-length that is set at Create time.

    At a minimum, a single totals file that has the name "" (the empty string) can be created and manipulated. Optionally, additional totals files that have arbitrary names can be created.

    Totals files model many of the characteristics of a traditional file system. However, the intent is not to provide a robust file system. Instead, totals files allow partitioning and ease of access into what is frequently a limited but secure resource. To reduce unnecessary overhead usage of this resource, directory hierarchies are not supported, file attributes are minimized, and files may not be dynamically resized.

  • The following operations can be performed on a totals file:

    • Read: Read a series of data bytes.

    • Write: Write a series of data bytes.

    • SetAll: Set all the data in a totals file to a value.

    • Find: Locate an existing totals file by name, and return a file handle and size.

    • FindByIndex: Used to enumerate all the files in the hard totals area.

    • Delete: Delete a totals file by name.

    • Rename: Rename an existing totals file.

    • ClaimFile: Gain exclusive access to a specific file for use by the claiming application. A timeout value may be specified in case another application maintains access for a period a time.The common Claim method can also be used to claim the hard totals device.

    • ReleaseFile: Releases exclusive access to the file.

  • The FreeData property holds the current number of unassigned data bytes.

  • The TotalsSize property holds the totals memory size.

  • The NumberOfFiles property holds the number of totals files that exist in the hard totals device.

  • Transaction operations are optionally supported. A transaction is defined as a series of data writes to be applied as an atomic operation to one or more hard totals files.

  • During a transaction, data writes are typically maintained in memory until a commit or rollback. Also, FreeData is typically reduced during a transaction to make sure that the commit has temporary totals space to perform the commit as an atomic operation.

    • BeginTrans: Marks the beginning of a transaction.

    • CommitTrans: Ends the current transaction, and saves the updated data. Software and hardware methods are used to make sure that either the transaction is saved, or that no updates are applied.

      This typically requires writing the transaction to temporary totals space, setting state information within the device that indicates that a commit is in progress, writing the data to the totals files, and freeing the temporary totals space. If the commit is interrupted, perhaps because of a system power loss or reset, then when the hard totals service object is reloaded and initialized, it can complete the commit by copying data from the temporary space into the totals files. This guarantees the integrity of related totals data.

    • Rollback: Ends the current transaction, and discards the updates. This may be useful if there is user intervention to cancel an update. Also, if advanced error detection shows that some totals data cannot be read suitably in preparation for an update, then the transaction may have to be aborted.

    • TransactionInProgress: This property holds the current state of transactions.

    The application should claim the files that are used during a transaction so that no other hard totals Control claims a file before CommitTrans. This causes the commit to fail, returning an already claimed status.

  • Advanced error detection is optionally supported by the following:

    • A Read or a Write can report a validation error. Data is usually divided into validation blocks, over which sumchecks or CRCs are maintained. The size of validation data blocks is determined by the specific service object.

    • A validation error informs the application that one or more of the validation blocks that contains the data to be read or written may be invalid because of a hardware error. (An error on a Write can occur when only a part of a validation block must be changed. The validation block must be read and the block validated before the portion is changed.)

    • When a validation error is reported, we recommend that the application read all the data in the totals file. The application must determine which sections of data is invalid, and take action based on the results of the reads.

    • RecalculateValidationData can be called to cause recalculation of all validation data within a totals file. This may be called after recovery has been performed as in the previous paragraph.

    • ValidateData can be called to verify that all data within a totals file passes validation.

    • Data writes automatically cause recalculation of validation data for the validation block or blocks in which the written data resides.

    • Because advanced error detection usually imposes a performance penalty, the application can select this feature when each totals file is created.

Device Sharing

The hard totals device is shareable. Its device-sharing rules are as follows:

  • After opening the device, most properties are readable.

  • After opening and enabling the device, the application can access all properties and methods.

  • If more than one application has opened and enabled the device, all applications can access its properties and methods.

  • One application can claim the hard totals device. This restricts all other applications from reading, changing, or claiming any files on the device.

  • One application can claim a hard totals file. This restricts all other applications from reading, changing, or claiming the file, and from claiming the hard totals device.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.HardTotals
Microsoft.PointOfService.BasicServiceObjects.HardTotalsBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

HardTotals Members
Microsoft.PointOfService Namespace


HardTotals Members

HardTotals Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a UPOS hard totals device.

The following tables list the members exposed by the HardTotals type.

Protected Constructors

Name | Description
HardTotals | Creates an instance of the HardTotals class.
Top

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorNoRoom | Indicates that you cannot write because a transaction is in progress, and there is insufficient free space to prepare for the transaction commit.
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
ExtendedErrorValidation | Indicates a validation error has occurred while it reads data.
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapErrorDetection | Gets a Boolean value that indicates whether error detection is supported.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapSingleFile | Gets a Boolean value that indicates whether only a single file is supported.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapTransactions | Gets a Boolean value that indicates whether transactions are supported.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
FreeData | Gets the number of bytes of unallocated data in the hard totals device.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
NumberOfFiles | Gets the number of totals files in the hard totals device.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
TotalsSize | Gets the size of the hard totals area.
TransactionInProgress | Gets a Boolean value that indicates whether a transaction is in progress.
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets the Boolean value that indicates whether the HardTotals is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
BeginTrans | Marks the beginning of a series of hard totals writes.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClaimFile | Tries to gain exclusive access to a specific file for use.
Close | Releases the device and its resources. (inherited from PosCommon)
CommitTrans | Ends the current transaction.
CompareFirmwareVersion | (inherited from PosCommon )
Create | Creates a totals file.
Delete | Deletes the named file.
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
Find | Locates an existing totals file.
FindByIndex | Returns the name of the totals file associated with the given index.
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon)
Read | Reads data from a totals file.
RecalculateValidationData | Recalculates validation data for the specified totals file.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ReleaseFile | Releases exclusive access to a specific file.
Rename | Renames a totals file.
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
Rollback | Ends the current transaction.
SetAll | Sets all the data in a totals file to the specified value.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
ValidateData | Verifies that all data in the specified totals file passes validation checks.
Write | Writes data to a totals file.
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

HardTotals Class
Microsoft.PointOfService Namespace


HardTotals Fields

HardTotals Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorNoRoom | Indicates that you cannot write because a transaction is in progress, and there is insufficient free space to prepare for the transaction commit.
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
ExtendedErrorValidation | Indicates a validation error has occurred while it reads data.
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

HardTotals Class
Microsoft.PointOfService Namespace


HardTotals.ExtendedErrorNoRoom Field

HardTotals.ExtendedErrorNoRoom Field |
 | See Also

1/18/2008

Indicates that you cannot write because a transaction is in progress, and there is insufficient free space to prepare for the transaction commit.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorNoRoom As Integer
public const int ExtendedErrorNoRoom
public:
literal int ExtendedErrorNoRoom
public static final int ExtendedErrorNoRoom
public const var ExtendedErrorNoRoom : int

See Also

Reference

HardTotals Class
HardTotals Members
Microsoft.PointOfService Namespace
Write


HardTotals.ExtendedErrorValidation Field

HardTotals.ExtendedErrorValidation Field |
 | See Also

1/18/2008

Indicates a validation error has occurred while it reads data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorValidation As Integer
public const int ExtendedErrorValidation
public:
literal int ExtendedErrorValidation
public static final int ExtendedErrorValidation
public const var ExtendedErrorValidation : int

See Also

Reference

HardTotals Class
HardTotals Members
Microsoft.PointOfService Namespace
Write


HardTotals Constructor

HardTotals Constructor |
 | See Also

1/18/2008

Creates an instance of the HardTotals class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected HardTotals ()
protected:
HardTotals ()
protected HardTotals ()
protected function HardTotals ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

HardTotals Class
HardTotals Members
Microsoft.PointOfService Namespace


HardTotals Methods

HardTotals Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
BeginTrans | Marks the beginning of a series of hard totals writes.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClaimFile | Tries to gain exclusive access to a specific file for use.
Close | Releases the device and its resources. (inherited from PosCommon )
CommitTrans | Ends the current transaction.
CompareFirmwareVersion | (inherited from PosCommon )
Create | Creates a totals file.
Delete | Deletes the named file.
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
Find | Locates an existing totals file.
FindByIndex | Returns the name of the totals file associated with the given index.
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon )
Read | Reads data from a totals file.
RecalculateValidationData | Recalculates validation data for the specified totals file.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ReleaseFile | Releases exclusive access to a specific file.
Rename | Renames a totals file.
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
Rollback | Ends the current transaction.
SetAll | Sets all the data in a totals file to the specified value.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
ValidateData | Verifies that all data in the specified totals file passes validation checks.
Write | Writes data to a totals file.

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

HardTotals Class
Microsoft.PointOfService Namespace


HardTotals.BeginTrans Method

HardTotals.BeginTrans Method |
 | See Also

1/18/2008

Marks the beginning of a series of hard totals writes.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub BeginTrans
public abstract void BeginTrans ()
public:
virtual void BeginTrans () abstract
public abstract void BeginTrans ()
public abstract function BeginTrans ()

Remarks

Marks the beginning of a series of hard totals writes that must be either applied as a group or not at all.

BeginTrans may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | Transactions are not supported by this device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

HardTotals Class
HardTotals Members
Microsoft.PointOfService Namespace
CommitTrans
Rollback


HardTotals.ClaimFile Method

HardTotals.ClaimFile Method |
 | See Also

1/18/2008

Tries to gain exclusive access to a specific file for use.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClaimFile ( _
    handle As Integer, _
    timeout As Integer _
)
public abstract void ClaimFile (
    int handle,
    int timeout
)
public:
virtual void ClaimFile (
    int handle,
    int timeout
) abstract
public abstract void ClaimFile (
    int handle,
    int timeout
)
public abstract function ClaimFile (
    handle : int,
    timeout : int
)

Parameters

handle

Handle to the totals file to claim.

timeout

The time (in milliseconds) to wait for the file to become available.If zero, ClaimFile tries to claim the file, then returns the appropriate status immediately.If WaitForever is specified, ClaimFile waits as long as needed until exclusive access is satisfied.

Remarks

Tries to gain exclusive access to a specific file for use by the claiming application. When it is granted, the application maintains exclusive access until it explicitly releases access or until the device is closed.

If any other applications have claimed exclusive access to this file by using ClaimFile, or if any other application has claimed exclusive access to the whole totals area by using Claim then this ClaimFile cannot be satisfied until those claims have been released.

All claims are released when the application calls the Close method.

ClaimFile may cause a PosControlException to be thrown with one of the following ErrorCodes.

Value | Meaning
Illegal | The handle is invalid, or an invalid timeout parameter was specified.
Timeout | The timeout value expired before another application released exclusive access of either the requested totals file or the whole totals area.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

HardTotals Class
HardTotals Members
Microsoft.PointOfService Namespace
ReleaseFile


HardTotals.CommitTrans Method

HardTotals.CommitTrans Method |
 | See Also

1/18/2008

Ends the current transaction.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub CommitTrans
public abstract void CommitTrans ()
public:
virtual void CommitTrans () abstract
public abstract void CommitTrans ()
public abstract function CommitTrans ()

Remarks

All writes between the previous BeginTrans method and CommitTrans are saved to the hard totals areas.

CommitTrans may cause a PosControlException to be thrown with the following ErrorCode.

Value | Meaning
Illegal | Transactions are not supported by this device, or no transaction is in progress.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

HardTotals Class
HardTotals Members
Microsoft.PointOfService Namespace
HardTotals.BeginTrans Method
Rollback


HardTotals.Create Method

HardTotals.Create Method |
 | See Also

1/18/2008

Creates a totals file.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function Create ( _
    fileName As String, _
    size As Integer, _
    errorDetection As Boolean _
) As Integer
public abstract int Create (
    string fileName,
    int size,
    bool errorDetection
)
public:
virtual int Create (
    String^ fileName,
    int size,
    bool errorDetection
) abstract
public abstract int Create (
    String fileName,
    int size,
    boolean errorDetection
)
public abstract function Create (
    fileName : String,
    size : int,
    errorDetection : boolean
) : int

Parameters

fileName

The name to be assigned to the file.Must not exceed 10 characters. All displayable characters - characters ≥ 20-hex – are valid.

size

The length of the file in bytes. When it is created, the file size cannot be changed: totals files are fixed-length files.

errorDetection

The level of error detection desired for this file:If true, the service object enables advanced error detection if supported.If false, better performance access is required so that advanced error detection do not have to be enabled for this file.

Remarks

Creates a totals file that has the specified name, size, and error-detection level. The data area is initialized to binary zeros.

If CapSingleFile is true, only one file may be created, and its name must be the empty string (""). Otherwise, the number of totals files that may be created is limited only by the free space in the hard totals area.

Create returns a file handle if this is successful, and may cause a PosControlException to be thrown with one of the following ErrorCodes.

Value | Meaning
Claimed | Cannot create because the totals file area is claimed by another application.
Illegal | The fileName is too long or contains invalid characters.
Exists | fileName already exists.
Extended | ExtendedErrorNoRoom:There is insufficient room in the totals area to create the file.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

HardTotals Class
HardTotals Members
Microsoft.PointOfService Namespace
Find
Delete
Rename


HardTotals.Delete Method

HardTotals.Delete Method |
 | See Also

1/18/2008

Deletes the named file.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub Delete ( _
    fileName As String _
)
public abstract void Delete (
    string fileName
)
public:
virtual void Delete (
    String^ fileName
) abstract
public abstract void Delete (
    String fileName
)
public abstract function Delete (
    fileName : String
)

Parameters

fileName

The fileName parameter specifies the totals file to delete.

Remarks

Delete may cause a PosControlException to be thrown with one of the following ErrorCodes.

Value | Meaning
Claimed | Cannot delete because either the totals file or the totals area is claimed by another application.
Illegal | The fileName is too long or contains invalid characters.
NoExist | fileName was not found.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

HardTotals Class
HardTotals Members
Microsoft.PointOfService Namespace
HardTotals.Create Method
Find
Rename


HardTotals.Find Method

HardTotals.Find Method |
 | See Also

1/18/2008

Locates an existing totals file.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function Find ( _
    fileName As String _
) As TotalsFileInfo
public abstract TotalsFileInfo Find (
    string fileName
)
public:
virtual TotalsFileInfo Find (
    String^ fileName
) abstract
public abstract TotalsFileInfo Find (
    String fileName
)
public abstract function Find (
    fileName : String
) : TotalsFileInfo

Parameters

fileName

The name of the totals file to be located.

Remarks

Find returns a TotalsFileInfo structure, and may cause a PosControlException to be thrown with one of the following ErrorCodes:

Value | Meaning
Claimed | Cannot find the file because the entire totals file area is claimed by another application.
Illegal | The fileName is too long or contains invalid characters.
NoExist | fileName was not found.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

HardTotals Class
HardTotals Members
Microsoft.PointOfService Namespace
HardTotals.Create Method
HardTotals.Delete Method
Rename


HardTotals.FindByIndex Method

HardTotals.FindByIndex Method |
 | See Also

1/18/2008

Returns the name of the totals file associated with the given index.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function FindByIndex ( _
    index As Integer _
) As String
public abstract string FindByIndex (
    int index
)
public:
virtual String^ FindByIndex (
    int index
) abstract
public abstract String FindByIndex (
    int index
)
public abstract function FindByIndex (
    index : int
) : String

Parameters

index

The index of the totals file to be found.

Remarks

FindByIndex provides a means for enumerating all the totals files that are currently defined. An index of zero returns the name of the file at the first file position, with later indexes returning additional file names. The largest valid index value is one less than NumberOfFiles.

The creation and deletion of files can change the relationship between indexes and the file names, as the service object may compact or rearrange the data areas used to manage file names and attributes at these times. Therefore, the application may have to claim the device to make sure that all file names are retrieved successfully.

FindByIndex returns the hard totals filename if this is successful, and may cause a PosControlException to be thrown with one of the following ErrorCodes.

Value | Meaning
Claimed | Cannot find files because the totals file area is claimed by another application.
Illegal | The index is greater than the largest file index that is currently defined.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

HardTotals Class
HardTotals Members
Microsoft.PointOfService Namespace
HardTotals.Create Method
HardTotals.Find Method


HardTotals.Read Method

HardTotals.Read Method |
 | See Also

1/18/2008

Reads data from a totals file.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function Read ( _
    handle As Integer, _
    offset As Integer, _
    count As Integer _
) As Byte()
public abstract byte[] Read (
    int handle,
    int offset,
    int count
)
public:
virtual array<unsigned char>^ Read (
    int handle,
    int offset,
    int count
) abstract
public abstract byte[] Read (
    int handle,
    int offset,
    int count
)
public abstract function Read (
    handle : int,
    offset : int,
    count : int
) : byte[]

Parameters

handle

Totals file handle returned from a Create or Find method.

offset

Starting offset for the data to be read.

count

Number of bytes of data to read.

Remarks

Read returns file data if this is successful, and may cause a PosControlException to be thrown with one of the following ErrorCodes.

Value | Meaning
Claimed | Cannot read because either the totals file or the totals area is claimed by another application.
Illegal | The handle is invalid, or part of the data range is outside the bounds of the totals file.
Extended | ErrorCodeExtended = ExtendedErrorValidation:A validation error has occurred while it is reading data.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

HardTotals Class
HardTotals Members
Microsoft.PointOfService Namespace
Write


HardTotals.RecalculateValidationData Method

HardTotals.RecalculateValidationData Method |
 | See Also

1/18/2008

Recalculates validation data for the specified totals file.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub RecalculateValidationData ( _
    handle As Integer _
)
public abstract void RecalculateValidationData (
    int handle
)
public:
virtual void RecalculateValidationData (
    int handle
) abstract
public abstract void RecalculateValidationData (
    int handle
)
public abstract function RecalculateValidationData (
    handle : int
)

Parameters

handle

The handle parameter contains the handle to a totals file.

Remarks

RecalculateValidationData may cause a PosControlException to be thrown with one of the following ErrorCodes.

Value | Meaning
Claimed | Cannot recalculate because either the totals file or the totals area is claimed by another application.
Illegal | The handle is invalid, or advanced error detection is not supported by either the service object or by this file.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

HardTotals Class
HardTotals Members
Microsoft.PointOfService Namespace


HardTotals.ReleaseFile Method

HardTotals.ReleaseFile Method |
 | See Also

1/18/2008

Releases exclusive access to a specific file.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ReleaseFile ( _
    handle As Integer _
)
public abstract void ReleaseFile (
    int handle
)
public:
virtual void ReleaseFile (
    int handle
) abstract
public abstract void ReleaseFile (
    int handle
)
public abstract function ReleaseFile (
    handle : int
)

Parameters

handle

The handle parameter contains the handle to the totals file to be released.

Remarks

ReleaseFile may cause a PosControlException to be thrown with one of the following ErrorCodes.

Value | Meaning
Illegal | The handle is invalid, or the specified file is not claimed by this application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

HardTotals Class
HardTotals Members
Microsoft.PointOfService Namespace
HardTotals.ClaimFile Method


HardTotals.Rename Method

HardTotals.Rename Method |
 | See Also

1/18/2008

Renames a totals file.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub Rename ( _
    handle As Integer, _
    newName As String _
)
public abstract void Rename (
    int handle,
    string newName
)
public:
virtual void Rename (
    int handle,
    String^ newName
) abstract
public abstract void Rename (
    int handle,
    String newName
)
public abstract function Rename (
    handle : int,
    newName : String
)

Parameters

handle

Handle to the totals file to be renamed.

newName

The new name to be assigned to the file.The name must not exceed 10 characters. All displayable characters ( ≥ 20 hexadecimal) are valid.

Remarks

If CapSingleFile is true, Rename fails.

Rename may cause a PosControlException to be thrown with one of the following ErrorCodes.

Value | Meaning
Claimed | Cannot rename because either the totals file or the totals area is claimed by another application.
Illegal | The file handle is invalid, the newName is too long or contains invalid characters, or the CapSingleFile property is TRUE.
Exists | newName already exists.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

HardTotals Class
HardTotals Members
Microsoft.PointOfService Namespace


HardTotals.Rollback Method

HardTotals.Rollback Method |
 | See Also

1/18/2008

Ends the current transaction.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub Rollback
public abstract void Rollback ()
public:
virtual void Rollback () abstract
public abstract void Rollback ()
public abstract function Rollback ()

Remarks

All writes between the previous BeginTrans and Rollback are discarded. They are not saved to the hard totals areas.

Rollback may cause a PosControlException to be thrown with one of the following ErrorCodes.

Value | Meaning
Illegal | Transactions are not supported by this device, or no transaction is in progress.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

HardTotals Class
HardTotals Members
Microsoft.PointOfService Namespace
HardTotals.BeginTrans Method
HardTotals.CommitTrans Method


HardTotals.SetAll Method

HardTotals.SetAll Method |
 | See Also

1/18/2008

Sets all the data in a totals file to the specified value.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub SetAll ( _
    handle As Integer, _
    targetValue As Byte _
)
public abstract void SetAll (
    int handle,
    byte targetValue
)
public:
virtual void SetAll (
    int handle,
    unsigned char targetValue
) abstract
public abstract void SetAll (
    int handle,
    byte targetValue
)
public abstract function SetAll (
    handle : int,
    targetValue : byte
)

Parameters

handle

Handle to a totals file.

targetValue

Value to set is in the low byte.

Remarks

Sets all the data in a totals file to the specified value.

SetAll may cause a PosControlException to be thrown with the following ErrorCode.

Value | Meaning
Claimed | Cannot set because either the totals file or the totals area is claimed by another application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

HardTotals Class
HardTotals Members
Microsoft.PointOfService Namespace


HardTotals.ValidateData Method

HardTotals.ValidateData Method |
 | See Also

1/18/2008

Verifies that all data in the specified totals file passes validation checks.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ValidateData ( _
    handle As Integer _
)
public abstract void ValidateData (
    int handle
)
public:
virtual void ValidateData (
    int handle
) abstract
public abstract void ValidateData (
    int handle
)
public abstract function ValidateData (
    handle : int
)

Parameters

handle

The handle parameter contains the handle to a totals file.

Remarks

ValidateData may cause a PosControlException to be thrown with one of the following ErrorCodes.

Value | Meaning
Claimed | Cannot validate the data because either the totals file or the totals area is claimed by another application.
Illegal | The handle is invalid, or advanced error detection is not supported either by the service object or by this file.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

HardTotals Class
HardTotals Members
Microsoft.PointOfService Namespace


HardTotals.Write Method

HardTotals.Write Method |
 | See Also

1/18/2008

Writes data to a totals file.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub Write ( _
    handle As Integer, _
    data As Byte(), _
    offset As Integer _
)
public abstract void Write (
    int handle,
    byte[] data,
    int offset
)
public:
virtual void Write (
    int handle,
    array<unsigned char>^ data,
    int offset
) abstract
public abstract void Write (
    int handle,
    byte[] data,
    int offset
)
public abstract function Write (
    handle : int,
    data : byte[],
    offset : int
)

Parameters

handle

Totals file handle returned from a Create or Find method.

data

Data buffer that contains the totals data to be written.

offset

Starting offset for the data to be written.

Remarks

If a transaction is in progress, the write will be buffered until a CommitTrans or Rollback method is called.

Write may cause a PosControlException to be thrown with one of the following ErrorCodes.

Value | Meaning
Claimed | Cannot write data because either the totals file or the totals area is claimed by another application.
Illegal | The handle is invalid, or part of all the data range is outside the bounds of the totals file.
Extended | ExtendedErrorNoRoom:Cannot write because a transaction is in progress, and there is insufficient free space to prepare for the transaction commit. ExtendedErrorValidation:A validation error has occurred while you read data.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

HardTotals Class
HardTotals Members
Microsoft.PointOfService Namespace
HardTotals.Read Method
HardTotals.BeginTrans Method
HardTotals.CommitTrans Method
HardTotals.Rollback Method
FreeData


HardTotals Properties

HardTotals Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapErrorDetection | Gets a Boolean value that indicates whether error detection is supported.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapSingleFile | Gets a Boolean value that indicates whether only a single file is supported.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapTransactions | Gets a Boolean value that indicates whether transactions are supported.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
FreeData | Gets the number of bytes of unallocated data in the hard totals device.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
NumberOfFiles | Gets the number of totals files in the hard totals device.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )
TotalsSize | Gets the size of the hard totals area.
TransactionInProgress | Gets a Boolean value that indicates whether a transaction is in progress.

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets the Boolean value that indicates whether the HardTotals is an exclusive-use device.

See Also

Reference

HardTotals Class
Microsoft.PointOfService Namespace


HardTotals.CapErrorDetection Property

HardTotals.CapErrorDetection Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether error detection is supported.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapErrorDetection As Boolean
public abstract bool CapErrorDetection { get; }
public:
virtual property bool CapErrorDetection {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapErrorDetection ()

public abstract function get CapErrorDetection () : boolean

Remarks

If true, advanced error detection is supported; otherwise, false.

CapErrorDetection is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

HardTotals Class
HardTotals Members
Microsoft.PointOfService Namespace


HardTotals.CapSingleFile Property

HardTotals.CapSingleFile Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether only a single file is supported.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSingleFile As Boolean
public abstract bool CapSingleFile { get; }
public:
virtual property bool CapSingleFile {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSingleFile ()

public abstract function get CapSingleFile () : boolean

Remarks

If true, only a single file, identified by the empty string (""), is supported; otherwise, false.

CapSingleFile is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

HardTotals Class
HardTotals Members
Microsoft.PointOfService Namespace


HardTotals.CapTransactions Property

HardTotals.CapTransactions Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether transactions are supported.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapTransactions As Boolean
public abstract bool CapTransactions { get; }
public:
virtual property bool CapTransactions {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapTransactions ()

public abstract function get CapTransactions () : boolean

Remarks

If true, transactions are supported; otherwise, false.

CapTransactions is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

HardTotals Class
HardTotals Members
Microsoft.PointOfService Namespace


HardTotals.FreeData Property

HardTotals.FreeData Property |
 | See Also

1/18/2008

Gets the number of bytes of unallocated data in the hard totals device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property FreeData As Integer
public abstract int FreeData { get; }
public:
virtual property int FreeData {
    int get () abstract;
}
/** @property */
public abstract int get_FreeData ()

public abstract function get FreeData () : int

Remarks

FreeData is initialized when the device is enabled and is updated as files are created and deleted. If creating a file requires some overhead to support the file information, then FreeData is reduced by this overhead amount. This guarantees that a new file of size FreeData can be created.

Data writes within a transaction may temporarily reduce FreeData, because some hard totals space may have to be allocated to prepare for the transaction commit. Therefore, the application should maintain sufficient FreeData to perform its largest possible transactions.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

HardTotals Class
HardTotals Members
Microsoft.PointOfService Namespace
HardTotals.Create Method
HardTotals.Write Method


HardTotals.IsExclusiveUseDevice Property

HardTotals.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the HardTotals is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Remarks

A value of true indicates that the HardTotals is exclusive-use, while a value of false indicates that it is not.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

HardTotals Class
HardTotals Members
Microsoft.PointOfService Namespace


HardTotals.NumberOfFiles Property

HardTotals.NumberOfFiles Property |
 | See Also

1/18/2008

Gets the number of totals files in the hard totals device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property NumberOfFiles As Integer
public abstract int NumberOfFiles { get; }
public:
virtual property int NumberOfFiles {
    int get () abstract;
}
/** @property */
public abstract int get_NumberOfFiles ()

public abstract function get NumberOfFiles () : int

Remarks

NumberOfFiles is set and kept current while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

HardTotals Class
HardTotals Members
Microsoft.PointOfService Namespace
HardTotals.FreeData Property


HardTotals.TotalsSize Property

HardTotals.TotalsSize Property |
 | See Also

1/18/2008

Gets the size of the hard totals area.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property TotalsSize As Integer
public abstract int TotalsSize { get; }
public:
virtual property int TotalsSize {
    int get () abstract;
}
/** @property */
public abstract int get_TotalsSize ()

public abstract function get TotalsSize () : int

Remarks

This size is equal to the largest totals file that can be created if no other files exist.

TotalsSize is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

HardTotals Class
HardTotals Members
Microsoft.PointOfService Namespace
HardTotals.FreeData Property


HardTotals.TransactionInProgress Property

HardTotals.TransactionInProgress Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether a transaction is in progress.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property TransactionInProgress As Boolean
public abstract bool TransactionInProgress { get; }
public:
virtual property bool TransactionInProgress {
    bool get () abstract;
}
/** @property */
public abstract boolean get_TransactionInProgress ()

public abstract function get TransactionInProgress () : boolean

Remarks

If true, the application is within a transaction; otherwise, false.

TransactionInProgress is set and kept current while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

HardTotals Class
HardTotals Members
Microsoft.PointOfService Namespace
HardTotals.BeginTrans Method


HardTotals Events

HardTotals Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

HardTotals Class
Microsoft.PointOfService Namespace


HardwareIdAttribute Class

HardwareIdAttribute Class |
 | See Also Members

1/18/2008

Defines a class containing a range of hardware Ids supported by a service object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple:=True, Inherited:=False)> _
Public NotInheritable Class HardwareIdAttribute
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple=true, Inherited=false)]
public sealed class HardwareIdAttribute : Attribute
[AttributeUsageAttribute(AttributeTargets::Class, AllowMultiple=true, Inherited=false)]
public ref class HardwareIdAttribute sealed : public Attribute
/** @attribute AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple=true, Inherited=false) */
public final class HardwareIdAttribute extends Attribute
AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple=true, Inherited=false)
public final class HardwareIdAttribute extends Attribute

Remarks

HardwareIdAttribute is used by the PosExplorer class to map the range of hardware IDs to a service object (for determining device path, and for Plug and Play support). A service object can implement more than one instance of HardwareIdAttribute class, to support more than one range of hardware Ids.

Implementation of HardwareIdAttribute class is optional. Alternatively, the information can be set via a ControlConfig XML file. Service objects can install an XML file under HKLM\Software\Microsoft\POSfor.NET\ControlConfigs, allowing a company to update hardware mappings without recompiling and shipping the service object (shipping just the XML file instead).

Inheritance Hierarchy

System.Object
System.Attribute
Microsoft.PointOfService.HardwareIdAttribute

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

HardwareIdAttribute Members
Microsoft.PointOfService Namespace


HardwareIdAttribute Members

HardwareIdAttribute Members |
 | See Also Constructors Methods Properties Explicit Interface Implementations

1/18/2008

Defines a class containing a range of hardware Ids supported by a service object.

The following tables list the members exposed by the HardwareIdAttribute type.

Public Constructors

Name | Description
HardwareIdAttribute | Overloaded. Creates an instance of the HardwareIdAttribute class.
Top

Public Properties

Name | Description
From | Gets the first hardware ID in a range.
To | Gets the last hardware ID in a range.
TypeId | (inherited from Attribute )
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Attribute )
GetCustomAttribute | Overloaded. (inherited from Attribute )
GetCustomAttributes | Overloaded. (inherited from Attribute )
GetHashCode | (inherited from Attribute )
GetType | (inherited from Object )
IsDefaultAttribute | (inherited from Attribute )
IsDefined | Overloaded. (inherited from Attribute )
Match | (inherited from Attribute )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

Explicit Interface Implementations

Name | Description
System.Runtime.InteropServices._Attribute.GetIDsOfNames | (inherited from Attribute )
System.Runtime.InteropServices._Attribute.GetTypeInfo | (inherited from Attribute )
System.Runtime.InteropServices._Attribute.GetTypeInfoCount | (inherited from Attribute )
System.Runtime.InteropServices._Attribute.Invoke | (inherited from Attribute )
Top

See Also

Reference

HardwareIdAttribute Class
Microsoft.PointOfService Namespace


HardwareIdAttribute Constructor

HardwareIdAttribute Constructor |
 | See Also

1/18/2008

Creates an instance of the HardwareIdAttribute class.

Overload List

Name | Description
HardwareIdAttribute (String) | Creates an instance of the HardwareIdAttribute class with the hardware ID.
HardwareIdAttribute (String, String) | Creates an instance of the HardwareIdAttribute class with the first and last hardware ID in a range.

See Also

Reference

HardwareIdAttribute Class
HardwareIdAttribute Members
Microsoft.PointOfService Namespace


HardwareIdAttribute Constructor (String)

HardwareIdAttribute Constructor (String) |
 | See Also

1/18/2008

Creates an instance of the HardwareIdAttribute class with the hardware ID.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    id As String _
)
public HardwareIdAttribute (
    string id
)
public:
HardwareIdAttribute (
    String^ id
)
public HardwareIdAttribute (
    String id
)
public function HardwareIdAttribute (
    id : String
)

Parameters

id

Hardware ID.

See Also

Reference

HardwareIdAttribute Class
HardwareIdAttribute Members
Microsoft.PointOfService Namespace


HardwareIdAttribute Constructor (String, String)

HardwareIdAttribute Constructor (String, String) |
 | See Also

1/18/2008

Creates an instance of the HardwareIdAttribute class with the first and last hardware ID in a range.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    fromId As String, _
    toId As String _
)
public HardwareIdAttribute (
    string fromId,
    string toId
)
public:
HardwareIdAttribute (
    String^ fromId,
    String^ toId
)
public HardwareIdAttribute (
    String fromId,
    String toId
)
public function HardwareIdAttribute (
    fromId : String,
    toId : String
)

Parameters

fromId

First ID in a range.

toId

Last ID in a range.

See Also

Reference

HardwareIdAttribute Class
HardwareIdAttribute Members
Microsoft.PointOfService Namespace


HardwareIdAttribute Methods

HardwareIdAttribute Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Attribute )
GetCustomAttribute | Overloaded. (inherited from Attribute )
GetCustomAttributes | Overloaded. (inherited from Attribute )
GetHashCode | (inherited from Attribute )
GetType | (inherited from Object )
IsDefaultAttribute | (inherited from Attribute )
IsDefined | Overloaded. (inherited from Attribute )
Match | (inherited from Attribute )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

Explicit Interface Implementations

Name | Description
System.Runtime.InteropServices._Attribute.GetIDsOfNames | (inherited from Attribute )
System.Runtime.InteropServices._Attribute.GetTypeInfo | (inherited from Attribute )
System.Runtime.InteropServices._Attribute.GetTypeInfoCount | (inherited from Attribute )
System.Runtime.InteropServices._Attribute.Invoke | (inherited from Attribute )

See Also

Reference

HardwareIdAttribute Class
Microsoft.PointOfService Namespace


HardwareIdAttribute Properties

HardwareIdAttribute Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
From | Gets the first hardware ID in a range.
To | Gets the last hardware ID in a range.
TypeId | (inherited from Attribute )

See Also

Reference

HardwareIdAttribute Class
Microsoft.PointOfService Namespace


HardwareIdAttribute.From Property

HardwareIdAttribute.From Property |
 | See Also

1/18/2008

Gets the first hardware ID in a range.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property From As String
public string From { get; }
public:
property String^ From {
    String^ get ();
}
/** @property */
public String get_From ()

public function get From () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

HardwareIdAttribute Class
HardwareIdAttribute Members
Microsoft.PointOfService Namespace


HardwareIdAttribute.To Property

HardwareIdAttribute.To Property |
 | See Also

1/18/2008

Gets the last hardware ID in a range.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property To As String
public string To { get; }
public:
property String^ To {
    String^ get ();
}
/** @property */
public String get_To ()

public function get To () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

HardwareIdAttribute Class
HardwareIdAttribute Members
Microsoft.PointOfService Namespace


HealthCheckLevel Enumeration

HealthCheckLevel Enumeration |
 | See Also

1/18/2008

Enumerates the possible types of health checks to be performed on a device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration HealthCheckLevel
public enum HealthCheckLevel
public enum class HealthCheckLevel
public enum HealthCheckLevel
public enum HealthCheckLevel

Members

Member name | Description
External | Performs a more thorough test that may change the device. For example, a pattern may be printed on the printer.
Interactive | Performs an interactive test of the device. The supporting service object typically displays a modal dialog box to present test options and results.
Internal | Performs a health check that does not physically change the device. The device is tested by internal tests to the extent possible.

Remarks

Used by the CheckHealth method. Members of this enumeration replace the CH_INTERNAL, CH_EXTERNAL, and CH_INTERACTIVE UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
CheckHealth


IDeviceEnumeration Interface

IDeviceEnumeration Interface |
 | See Also Members

1/18/2008

Defines the interface to enumerate devices.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Interface IDeviceEnumeration
public interface IDeviceEnumeration
public interface class IDeviceEnumeration
public interface IDeviceEnumeration
public interface IDeviceEnumeration

Remarks

Provides the interface to enumerate devices through the EnumerateDevices method.

See Also

Reference

IDeviceEnumeration Members
Microsoft.PointOfService Namespace


IDeviceEnumeration Members

IDeviceEnumeration Members |
 | See Also Methods

1/18/2008

Defines the interface to enumerate devices.

The following tables list the members exposed by the IDeviceEnumeration type.

Public Methods

Name | Description
EnumerateDevices | Provides the current ReadOnlyCollection enumeration of devices.
Top

See Also

Reference

IDeviceEnumeration Interface
Microsoft.PointOfService Namespace


IDeviceEnumeration Methods

IDeviceEnumeration Methods |
 | See Also

1/18/2008

Public Methods

Name | Description
EnumerateDevices | Provides the current ReadOnlyCollection enumeration of devices.

See Also

Reference

IDeviceEnumeration Interface
Microsoft.PointOfService Namespace


IDeviceEnumeration.EnumerateDevices Method

IDeviceEnumeration.EnumerateDevices Method |
 | See Also

1/18/2008

Provides the current ReadOnlyCollection enumeration of devices.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Function EnumerateDevices As ReadOnlyCollection(Of Device)
ReadOnlyCollection<Device> EnumerateDevices ()
ReadOnlyCollection<Device^>^ EnumerateDevices ()
ReadOnlyCollection<Device> EnumerateDevices ()
function EnumerateDevices () : ReadOnlyCollection<Device>

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

IDeviceEnumeration Interface
IDeviceEnumeration Members
Microsoft.PointOfService Namespace


IDeviceEnumerationPnp Interface

IDeviceEnumerationPnp Interface |
 | See Also Members

1/18/2008

Defines the interface to enumerate Plug and Play devices.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Interface IDeviceEnumerationPnp
    Inherits IDeviceEnumeration
public interface IDeviceEnumerationPnp : IDeviceEnumeration
public interface class IDeviceEnumerationPnp : IDeviceEnumeration
public interface IDeviceEnumerationPnp extends IDeviceEnumeration
public interface IDeviceEnumerationPnp extends IDeviceEnumeration

Remarks

Provides the interface to enumerate Plug and Play devices through the GetPlugAndPlayObject method.

See Also

Reference

IDeviceEnumerationPnp Members
Microsoft.PointOfService Namespace


IDeviceEnumerationPnp Members

IDeviceEnumerationPnp Members |
 | See Also Methods

1/18/2008

Defines the interface to enumerate Plug and Play devices.

The following tables list the members exposed by the IDeviceEnumerationPnp type.

Public Methods

Name | Description
GetPlugAndPlayObject | Gets the Plug and Play object.
Top

See Also

Reference

IDeviceEnumerationPnp Interface
Microsoft.PointOfService Namespace


IDeviceEnumerationPnp Methods

IDeviceEnumerationPnp Methods |
 | See Also

1/18/2008

Public Methods

Name | Description
GetPlugAndPlayObject | Gets the Plug and Play object.

See Also

Reference

IDeviceEnumerationPnp Interface
Microsoft.PointOfService Namespace


IDeviceEnumerationPnp.GetPlugAndPlayObject Method

IDeviceEnumerationPnp.GetPlugAndPlayObject Method |
 | See Also

1/18/2008

Gets the Plug and Play object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Function GetPlugAndPlayObject As DevicePlugAndPlay
DevicePlugAndPlay GetPlugAndPlayObject ()
DevicePlugAndPlay^ GetPlugAndPlayObject ()
DevicePlugAndPlay GetPlugAndPlayObject ()
function GetPlugAndPlayObject () : DevicePlugAndPlay

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

IDeviceEnumerationPnp Interface
IDeviceEnumerationPnp Members
Microsoft.PointOfService Namespace


ILegacyControlObject Interface

ILegacyControlObject Interface |
 | See Also Members

1/18/2008

Defines the interface to access a legacy OPOS control object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Interface ILegacyControlObject
public interface ILegacyControlObject
public interface class ILegacyControlObject
public interface ILegacyControlObject
public interface ILegacyControlObject

Remarks

The IlegacyControlObject interface provides the interface to access control object properties used for a legacy (OPOS) service object.

See Also

Reference

ILegacyControlObject Members
Microsoft.PointOfService Namespace


ILegacyControlObject Members

ILegacyControlObject Members |
 | See Also Properties

1/18/2008

Defines the interface to access a legacy OPOS control object.

The following tables list the members exposed by the ILegacyControlObject type.

Public Properties

Name | Description
BinaryConversion | Gets or sets the binary conversion property.
ControlObjectDescription | Gets the string identifying the control object and the company that produced it.
ControlObjectVersion | Gets the version of a control object.
Top

See Also

Reference

ILegacyControlObject Interface
Microsoft.PointOfService Namespace


ILegacyControlObject Properties

ILegacyControlObject Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
BinaryConversion | Gets or sets the binary conversion property.
ControlObjectDescription | Gets the string identifying the control object and the company that produced it.
ControlObjectVersion | Gets the version of a control object.

See Also

Reference

ILegacyControlObject Interface
Microsoft.PointOfService Namespace


ILegacyControlObject.BinaryConversion Property

ILegacyControlObject.BinaryConversion Property |
 | See Also

1/18/2008

Gets or sets the binary conversion property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Property BinaryConversion As BinaryConversion
BinaryConversion BinaryConversion { get; set; }
property BinaryConversion BinaryConversion {
    BinaryConversion get ();
    void set (BinaryConversion value);
}
/** @property */
BinaryConversion get_BinaryConversion ()

/** @property */
void set_BinaryConversion (BinaryConversion value)

function get BinaryConversion () : BinaryConversion

function set BinaryConversion (value : BinaryConversion)

Property Value

Returns a BinaryConversion enumeration.

Remarks

The BinaryConversion enumeration is typically initialized to None.

Accessing the BinaryConversion enumeration may cause a PosControlException exception to be thrown with the following ErrorCode:

Value | Description
Illegal | An illegal value was specified.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ILegacyControlObject Interface
ILegacyControlObject Members
Microsoft.PointOfService Namespace


ILegacyControlObject.ControlObjectDescription Property

ILegacyControlObject.ControlObjectDescription Property |
 | See Also

1/18/2008

Gets the string identifying the control object and the company that produced it.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

ReadOnly Property ControlObjectDescription As String
string ControlObjectDescription { get; }
property String^ ControlObjectDescription {
    String^ get ();
}
/** @property */
String get_ControlObjectDescription ()

function get ControlObjectDescription () : String

Remarks

The following is an example return string:

"POS Printer OLE Control, (C) 1995 Epson"

The ControlObjectDescription property is always is always readable, and is initialized to a control object-dependent string.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ILegacyControlObject Interface
ILegacyControlObject Members
Microsoft.PointOfService Namespace


ILegacyControlObject.ControlObjectVersion Property

ILegacyControlObject.ControlObjectVersion Property |
 | See Also

1/18/2008

Gets the version of a control object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

ReadOnly Property ControlObjectVersion As Version
Version ControlObjectVersion { get; }
property Version^ ControlObjectVersion {
    Version^ get ();
}
/** @property */
Version get_ControlObjectVersion ()

function get ControlObjectVersion () : Version

Remarks

The following is an example version number:

1002038

This value can be displayed as version "1.2.38", and interpreted as major version 1, minor version 2, build 38 of the control object.

The ControlObjectVersion property is always readable, and is initialized to a control object-dependent number.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ILegacyControlObject Interface
ILegacyControlObject Members
Microsoft.PointOfService Namespace


ImageMemoryStatus Enumeration

ImageMemoryStatus Enumeration |
 | See Also

1/18/2008

Enumerates the availability status values for image memory.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration ImageMemoryStatus
public enum ImageMemoryStatus
public enum class ImageMemoryStatus
public enum ImageMemoryStatus
public enum ImageMemoryStatus

Members

Member name | Description
Empty | The image memory is empty.
Full | The image memory is full.
OK | The image memory has storage available.

Remarks

Used by the ImageMemoryStatus property. Members of this enumeration replace the CHK_IMS_EMPTY, CHK_IMS_OK, and CHK_IMS_FULL UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
CheckScanner.ImageMemoryStatus Property


ImageMode Enumeration

ImageMode Enumeration |
 | See Also

1/18/2008

Enumerates the possible modes of operation that an Image Scanner device can use.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration ImageMode
public enum ImageMode
public enum class ImageMode
public enum ImageMode
public enum ImageMode

Members

Member name | Description
All | The image scanner transmits video streams, and it tries to read bar code data. When a bar code is read, the bar code data and a still image are transmitted. The image resolution of video data could be different from the resolution of still image data. A hydra implementation of Image Scanner and Scanner is required for this mode.
DecodeOnly | The image scanner does not transmit still images or video to the application. However, it transmits bar code data decoded from purchased images through a Scanner service. A hydra implementation of Image Scanner and Scanner is required for this mode.
StillAndDecode | The image scanner transmits still images, and it tries to read bar code data. However, it does not transmit video streams. A hydra implementation of ImageScanner and Scanner is required for this mode.
StillOnly | The image scanner transmits still images. However, it does not try to read bar code data, nor does it transmit video.
VideoAndDecode | The image scanner transmits video streams, and it tries to read bar code data. A hydra implementation of Image Scanner and Scanner is required for this mode.
VideoAndStill | The image scanner transmits video streams, and it transmits still images. However, it does not try to read bar code data. The image resolution of video data could be different from the resolution of still image data.

See Also

Reference

Microsoft.PointOfService Namespace


ImageQuality Enumeration

ImageQuality Enumeration |
 | See Also

1/18/2008

Enumerates the level of image quality supported by the Image Scanner device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration ImageQuality
public enum ImageQuality
public enum class ImageQuality
public enum ImageQuality
public enum ImageQuality

Members

Member name | Description
High | High image quality is supported.
Low | Only low image quality is supported.
Medium | Medium image quality is supported.

See Also

Reference

Microsoft.PointOfService Namespace


ImageScanner Class

ImageScanner Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a UPOS Image Scanner device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class ImageScanner
    Inherits PosCommon
public abstract class ImageScanner : PosCommon
public ref class ImageScanner abstract : public PosCommon
public abstract class ImageScanner extends PosCommon
public abstract class ImageScanner extends PosCommon

Remarks

The Image Scanner has the capability of reading a single frame of image data in self-initiated scanning sessions. The Image Scanner may also have one or more of the following capabilities:

  • Reads encoded data from a label.

  • Reads low-resolution video streams for aiming purposes.

  • The host can control the Illumination mode.

  • The host can control the Aiming mode.

  • The host can start and stop a scanning session.

Programming Model

The Image Scanner follows the general Device Input Model for event-driven input:

  • Frames of image data is received from the device and a DataEvent event is queued in response.

  • If the AutoDisable property is true and the Image Scanner is in Decode or Still Image mode, the device automatically disables itself when a DataEvent event is queued. The AutoDisable property is not available in the Low-Resolution Video mode.

  • If the DataEventEnabled property is true and other event delivery requirements are met, queued DataEvent events are delivered to the application. Just before an event is delivered, data is copied into corresponding properties and additional DataEvent events are disabled by setting DataEventEnabled property to false. This causes later input data to be queued while the application processes the current input and its associated properties. When the application has finished processing the current input and is ready for more data, it re-enables events by setting the DataEventEnabled property to true.

  • If an error occurs while collecting or processing input, one or more ErrorEvent events are queued. These ErrorEvent events are delivered to the application when the DataEventEnabled property is true and other event delivery requirements are met.

  • The DataCount property may be read to obtain the total number of queued DataEvent events.

  • All queued input may be deleted by calling ClearInput method. For more information, see the ClearInput method.

  • All data properties that are populated as a result of raising a DataEvent event or an ErrorEvent event may be reset to their default values by calling the ClearInputProperties method. Image Scanners that also decode labels are implemented as a Hydra Devices. Services are supported for both a Scanner device and an Image Scanner device.

  • When a frame of image data yields decode data, a DataEvent event is queued by the Scanner service object and the scanned data is put into the ScanData property. If the application has set the DecodeData property to true, the data is decoded and put into the ScanDataLabel and ScanDataType properties.

Device Sharing

The Image Scanner is an exclusive-use device, as follows:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before the device begins reading input.

Platforms

The ImageScanner class requires POS for .NET version 1.11 or later versions.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.ImageScanner
Microsoft.PointOfService.BasicServiceObjects.ImageScannerBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ImageScanner Members
Microsoft.PointOfService Namespace


ImageScanner Members

ImageScanner Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a UPOS Image Scanner device.

The following tables list the members exposed by the ImageScanner type.

Protected Constructors

Name | Description
ImageScanner |
Top

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticGoodReadCount | Holds the number of performed good read operations.
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticNoReadCount | Holds the number of performed failed read operations.
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticSessionCount | Holds the number of total statistic sessions.
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
AimMode | Gets or sets a Boolean value that indicates whether the device turns on an aiming spot or an aiming grid.
AutoDisable | Gets or sets a Boolean value that indicates whether the device is automatically disabled after data is received.
CapAim | Gets a Boolean value that indicates whether the device supports aiming spots or aiming grids.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapDecodeData | Gets a Boolean value that indicates whether the device can read encoded data from a label.
CapHostTriggered | Gets a Boolean value that indicates whether the device supports StartSession and StopSession method calls.
CapIlluminate | Gets a Boolean value that indicates whether the device supports using illumination sources.
CapImageData | Gets a Boolean value that indicates whether the Image Scanner supports a still image capture mode.
CapImageQuality | Gets a Boolean value that indicates whether the Image Scanner supports the ImageQuality property to control image compression or capture.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CapVideoData | Gets a Boolean value that indicates whether the device supports a low-resolution video stream mode.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
DataCount | Gets the number of currently queued DataEvent events.
DataEventEnabled | Gets or sets a Boolean value that indicates whether a DataEvent event is delivered when input data is queued.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
FrameData | Gets one ore more bitmap images or video data that is read from the device.
FrameType | Gets a value identifying the contents of the FrameData property.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
IlluminateMode | Gets or sets a Boolean value that indicates whether the device enables the illumination source during a scan session.
ImageMode | Gets or sets a value identifying the Image mode.
ImageQuality | Gets or sets the picture quality used when recording images.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
VideoCount | Gets or sets a value that identifies how many frames of video data is sent with each DataEvent event.
VideoRate | Gets or sets a value identifying the number of video frames per second that the application can receive.
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Get a Boolean value that indicates whether the Image Scanner is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all buffered device input.
ClearInputProperties | Resets the values of properties altered by the DataEvent event or the ErrorEvent event.
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon)
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
StartSession | Starts the Image Scanner session to obtain still images, decode, and video stream data in a mode specified by the ImageMode property.
StopSession | Ends a session started by the StartSession method.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DataEvent | Notifies the application that input data from the Image Scanner is available.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
ErrorEvent | Notifies the application that an Image Scanner device error has been detected and a suitable response by the application is necessary to process the error condition.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

ImageScanner Class
Microsoft.PointOfService Namespace


ImageScanner Fields

ImageScanner Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticGoodReadCount | Holds the number of performed good read operations.
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticNoReadCount | Holds the number of performed failed read operations.
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticSessionCount | Holds the number of total statistic sessions.
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

ImageScanner Class
Microsoft.PointOfService Namespace


ImageScanner.StatisticGoodReadCount Field

ImageScanner.StatisticGoodReadCount Field |
 | See Also

1/18/2008

Holds the number of performed good read operations.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticGoodReadCount As String
public const string StatisticGoodReadCount
public:
literal String^ StatisticGoodReadCount
public static final String StatisticGoodReadCount
public const var StatisticGoodReadCount : String

See Also

Reference

ImageScanner Class
ImageScanner Members
Microsoft.PointOfService Namespace


ImageScanner.StatisticNoReadCount Field

ImageScanner.StatisticNoReadCount Field |
 | See Also

1/18/2008

Holds the number of performed failed read operations.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticNoReadCount As String
public const string StatisticNoReadCount
public:
literal String^ StatisticNoReadCount
public static final String StatisticNoReadCount
public const var StatisticNoReadCount : String

See Also

Reference

ImageScanner Class
ImageScanner Members
Microsoft.PointOfService Namespace


ImageScanner.StatisticSessionCount Field

ImageScanner.StatisticSessionCount Field |
 | See Also

1/18/2008

Holds the number of total statistic sessions.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticSessionCount As String
public const string StatisticSessionCount
public:
literal String^ StatisticSessionCount
public static final String StatisticSessionCount
public const var StatisticSessionCount : String

See Also

Reference

ImageScanner Class
ImageScanner Members
Microsoft.PointOfService Namespace


ImageScanner Constructor

ImageScanner Constructor |
 | See Also

1/18/2008

Initializes a new instance of the ImageScanner Class .

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New

protected ImageScanner ()

protected:
ImageScanner ()

protected ImageScanner ()

protected function ImageScanner ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

ImageScanner Class
ImageScanner Members
Microsoft.PointOfService Namespace


ImageScanner Methods

ImageScanner Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all buffered device input.
ClearInputProperties | Resets the values of properties altered by the DataEvent event or the ErrorEvent event.
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon )
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
StartSession | Starts the Image Scanner session to obtain still images, decode, and video stream data in a mode specified by the ImageMode property.
StopSession | Ends a session started by the StartSession method.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

ImageScanner Class
Microsoft.PointOfService Namespace


ImageScanner.ClearInput Method

ImageScanner.ClearInput Method |
 | See Also

1/18/2008

Clears all buffered device input.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearInput
public abstract void ClearInput ()
public:
virtual void ClearInput () abstract
public abstract void ClearInput ()
public abstract function ClearInput ()

Remarks

ClearInput may cause a PosControlException exception to be thrown with the following ErrorCode:

Value | Meaning
Claimed | The device is claimed by another process.
NotClaimed | The device must be claimed before the ClearInput method can be used.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ImageScanner Class
ImageScanner Members
Microsoft.PointOfService Namespace
DataEvent


ImageScanner.ClearInputProperties Method

ImageScanner.ClearInputProperties Method |
 | See Also

1/18/2008

Resets the values of properties altered by the DataEvent event or the ErrorEvent event.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearInputProperties
public abstract void ClearInputProperties ()
public:
virtual void ClearInputProperties () abstract
public abstract void ClearInputProperties ()
public abstract function ClearInputProperties ()

Remarks

Sets all data properties populated by raising of the DataEvent event or the ErrorEvent event back to their default values. This does not reset the DataCount or State properties.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ImageScanner Class
ImageScanner Members
Microsoft.PointOfService Namespace
DataEvent
DataCount
ErrorEvent


ImageScanner.StartSession Method

ImageScanner.StartSession Method |
 | See Also

1/18/2008

Starts the Image Scanner session to obtain still images, decode, and video stream data in a mode specified by the ImageMode property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub StartSession
public abstract void StartSession ()
public:
virtual void StartSession () abstract
public abstract void StartSession ()
public abstract function StartSession ()

Remarks

A session is active until the StopSession method is invoked or until the Image Scanner ends the session on its own. A session may close early if decode data or an image is obtained, or when a session time-out has expired. The criteria for ending a session depends on the implementation.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ImageScanner Class
ImageScanner Members
Microsoft.PointOfService Namespace
CapHostTriggered
ImageMode
StopSession


ImageScanner.StopSession Method

ImageScanner.StopSession Method |
 | See Also

1/18/2008

Ends a session started by the StartSession method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub StopSession
public abstract void StopSession ()
public:
virtual void StopSession () abstract
public abstract void StopSession ()
public abstract function StopSession ()

Remarks

This method is used to end a session initiated by a StartSession method call. If this method is invoked and the session is no longer active, then no exception is raised.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ImageScanner Class
ImageScanner Members
Microsoft.PointOfService Namespace
CapHostTriggered
ImageScanner.StartSession Method


ImageScanner Properties

ImageScanner Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
AimMode | Gets or sets a Boolean value that indicates whether the device turns on an aiming spot or an aiming grid.
AutoDisable | Gets or sets a Boolean value that indicates whether the device is automatically disabled after data is received.
CapAim | Gets a Boolean value that indicates whether the device supports aiming spots or aiming grids.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapDecodeData | Gets a Boolean value that indicates whether the device can read encoded data from a label.
CapHostTriggered | Gets a Boolean value that indicates whether the device supports StartSession and StopSession method calls.
CapIlluminate | Gets a Boolean value that indicates whether the device supports using illumination sources.
CapImageData | Gets a Boolean value that indicates whether the Image Scanner supports a still image capture mode.
CapImageQuality | Gets a Boolean value that indicates whether the Image Scanner supports the ImageQuality property to control image compression or capture.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CapVideoData | Gets a Boolean value that indicates whether the device supports a low-resolution video stream mode.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
DataCount | Gets the number of currently queued DataEvent events.
DataEventEnabled | Gets or sets a Boolean value that indicates whether a DataEvent event is delivered when input data is queued.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
FrameData | Gets one ore more bitmap images or video data that is read from the device.
FrameType | Gets a value identifying the contents of the FrameData property.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
IlluminateMode | Gets or sets a Boolean value that indicates whether the device enables the illumination source during a scan session.
ImageMode | Gets or sets a value identifying the Image mode.
ImageQuality | Gets or sets the picture quality used when recording images.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )
VideoCount | Gets or sets a value that identifies how many frames of video data is sent with each DataEvent event.
VideoRate | Gets or sets a value identifying the number of video frames per second that the application can receive.

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Get a Boolean value that indicates whether the Image Scanner is an exclusive-use device.

See Also

Reference

ImageScanner Class
Microsoft.PointOfService Namespace


ImageScanner.AimMode Property

ImageScanner.AimMode Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether the device turns on an aiming spot or an aiming grid.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AimMode As Boolean
public abstract bool AimMode { get; set; }
public:
virtual property bool AimMode {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_AimMode ()

/** @property */
public abstract void set_AimMode (boolean value)

public abstract function get AimMode () : boolean

public abstract function set AimMode (value : boolean)

Remarks

If true, the Image Scanner turns on an aiming spot or aiming grid during a scan session. If false, the Image Scanner turns off the aiming spot during a scan session.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ImageScanner Class
ImageScanner Members
Microsoft.PointOfService Namespace
CapAim


ImageScanner.AutoDisable Property

ImageScanner.AutoDisable Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether the device is automatically disabled after data is received.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AutoDisable As Boolean
public abstract bool AutoDisable { get; set; }
public:
virtual property bool AutoDisable {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_AutoDisable ()

/** @property */
public abstract void set_AutoDisable (boolean value)

public abstract function get AutoDisable () : boolean

public abstract function set AutoDisable (value : boolean)

Remarks

The AutoDisable property provides the application with an additional option for controlling the receipt of input data. If the application wants to receive and process only one input, or only one input at a time, this property can be set to true.

When true, the service object sets the DeviceEnabled property to false as soon as it receives and queues data to be raised as a DataEvent event. Before the service object raises any later events, the application must set the DeviceEnabled property back to true.

When false, the service object does not automatically disable the device when data is received; instead, it relies on the application to set the value of the DeviceEnabled property.

The P:Microsoft.PointOfService.ImageScanner.AutoDisable property is typically initialized to false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ImageScanner Class
ImageScanner Members
Microsoft.PointOfService Namespace
DataEvent
DeviceEnabled


ImageScanner.CapAim Property

ImageScanner.CapAim Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device supports aiming spots or aiming grids.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapAim As Boolean
public abstract bool CapAim { get; }
public:
virtual property bool CapAim {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapAim ()

public abstract function get CapAim () : boolean

Remarks

If true, the Image Scanner supports the property to enable or disable the display of an aiming spot or grid.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ImageScanner Class
ImageScanner Members
Microsoft.PointOfService Namespace
ImageScanner.AimMode Property


ImageScanner.CapDecodeData Property

ImageScanner.CapDecodeData Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device can read encoded data from a label.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapDecodeData As Boolean
public abstract bool CapDecodeData { get; }
public:
virtual property bool CapDecodeData {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapDecodeData ()

public abstract function get CapDecodeData () : boolean

Remarks

If true, then the Image Scanner can read encoded data from a label. Any label data that is read is sent by a Scanner service.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ImageScanner Class
ImageScanner Members
Microsoft.PointOfService Namespace


ImageScanner.CapHostTriggered Property

ImageScanner.CapHostTriggered Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device supports StartSession and StopSession method calls.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapHostTriggered As Boolean
public abstract bool CapHostTriggered { get; }
public:
virtual property bool CapHostTriggered {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapHostTriggered ()

public abstract function get CapHostTriggered () : boolean

Remarks

If true. the Image Scanner supports the StartSession and StopSession method calls.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ImageScanner Class
ImageScanner Members
Microsoft.PointOfService Namespace
ImageScanner.StartSession Method
ImageScanner.StopSession Method


ImageScanner.CapIlluminate Property

ImageScanner.CapIlluminate Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device supports using illumination sources.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapIlluminate As Boolean
public abstract bool CapIlluminate { get; }
public:
virtual property bool CapIlluminate {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapIlluminate ()

public abstract function get CapIlluminate () : boolean

Remarks

If true, the Image Scanner supports the property to enable or disable using an illumination source.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ImageScanner Class
ImageScanner Members
Microsoft.PointOfService Namespace
IlluminateMode


ImageScanner.CapImageData Property

ImageScanner.CapImageData Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the Image Scanner supports a still image capture mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapImageData As Boolean
public abstract bool CapImageData { get; }
public:
virtual property bool CapImageData {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapImageData ()

public abstract function get CapImageData () : boolean

Remarks

If true, the Image Scanner supports a still image capture mode.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ImageScanner Class
ImageScanner Members
Microsoft.PointOfService Namespace
ImageMode


ImageScanner.CapImageQuality Property

ImageScanner.CapImageQuality Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the Image Scanner supports the ImageQuality property to control image compression or capture.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapImageQuality As Boolean
public abstract bool CapImageQuality { get; }
public:
virtual property bool CapImageQuality {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapImageQuality ()

public abstract function get CapImageQuality () : boolean

Remarks

If true, then the Image Scanner supports the ImageQuality property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ImageScanner Class
ImageScanner Members
Microsoft.PointOfService Namespace


ImageScanner.CapVideoData Property

ImageScanner.CapVideoData Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device supports a low-resolution video stream mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapVideoData As Boolean
public abstract bool CapVideoData { get; }
public:
virtual property bool CapVideoData {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapVideoData ()

public abstract function get CapVideoData () : boolean

Remarks

If true, then the Image Scanner supports a low-resolution video stream mode.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ImageScanner Class
ImageScanner Members
Microsoft.PointOfService Namespace
ImageMode


ImageScanner.DataCount Property

ImageScanner.DataCount Property |
 | See Also

1/18/2008

Gets the number of currently queued DataEvent events.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DataCount As Integer
public abstract int DataCount { get; }
public:
virtual property int DataCount {
    int get () abstract;
}
/** @property */
public abstract int get_DataCount ()

public abstract function get DataCount () : int

Remarks

Indicates the total number of currently queued DataEvent events at the service object. All online units are included in this value.

The application can interrogate the DataCount property to determine whether additional input is queued from a device but has not yet been delivered because of other application processing, freezing of events, or other causes.

The DataCount property is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ImageScanner Class
ImageScanner Members
Microsoft.PointOfService Namespace
ImageScanner.DataCount Property
DataEvent


ImageScanner.DataEventEnabled Property

ImageScanner.DataEventEnabled Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether a DataEvent event is delivered when input data is queued.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property DataEventEnabled As Boolean
public abstract bool DataEventEnabled { get; set; }
public:
virtual property bool DataEventEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_DataEventEnabled ()

/** @property */
public abstract void set_DataEventEnabled (boolean value)

public abstract function get DataEventEnabled () : boolean

public abstract function set DataEventEnabled (value : boolean)

Remarks

If true, a DataEvent event is delivered as soon as input data is queued. If this property is changed to true while input data is already in the queue, a DataEvent event will be delivered immediately. This event may be delayed if FreezeEvents is true or if another event is already being processed at the application. In this case, the DataEvent remains queued until it can be processed.

If false, input data is queued for later delivery to the application. Also, if an input error occurs, the ErrorEvent event is not delivered while DataEventEnabled property is false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ImageScanner Class
ImageScanner Members
Microsoft.PointOfService Namespace
DataEvent


ImageScanner.FrameData Property

ImageScanner.FrameData Property |
 | See Also

1/18/2008

Gets one ore more bitmap images or video data that is read from the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property FrameData As ReadOnlyCollection(Of Bitmap)
public abstract ReadOnlyCollection<Bitmap> FrameData { get; }
public:
virtual property ReadOnlyCollection<Bitmap^>^ FrameData {
    ReadOnlyCollection<Bitmap^>^ get () abstract;
}
/** @property */
public abstract ReadOnlyCollection<Bitmap> get_FrameData ()

public abstract function get FrameData () : ReadOnlyCollection<Bitmap>

Remarks

Typically, video data is one or more still images that are concatenated together in one frame without data compression. This video data is typically used to project a "view finder" that the operator can use to aim the Image Scanner (without an aiming pattern). Each block contains at most the number of frames specified in the VideoCount property. A DataEvent event is raised for each block of video data sent. Multiple blocks of image data is periodically sent by the service object to up to the maximum frames per second rate set by the VideoRate property. Image data, whether for still images or video streams may be obtained in a scan session started by the StartSession method, or by a scan session started asynchronously by the Image Scanner. The FrameType property indicates whether the bitmaps held by the FrameData property represent still images or a block of video data.

Its value is set before a DataEvent event is being delivered to the application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ImageScanner Class
ImageScanner Members
Microsoft.PointOfService Namespace
FrameType
VideoCount
VideoRate
DataEvent
ImageScanner.StartSession Method


ImageScanner.FrameType Property

ImageScanner.FrameType Property |
 | See Also

1/18/2008

Gets a value identifying the contents of the FrameData property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property FrameType As FrameType
public abstract FrameType FrameType { get; }
public:
virtual property FrameType FrameType {
    FrameType get () abstract;
}
/** @property */
public abstract FrameType get_FrameType ()

public abstract function get FrameType () : FrameType

Remarks

Holds a value identifying the contents of the FrameData property. The value can be one of the following values.

Value | Meaning
Still | The FrameData property contains a single still image.
Video | The FrameData property contains a block of video stream frames; defined as one or more still images concatenated without data compression.

Values are set before a DataEvent event is being delivered to the application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ImageScanner Class
ImageScanner Members
Microsoft.PointOfService Namespace
ImageScanner.FrameData Property
ImageScanner.FrameData Property


ImageScanner.IlluminateMode Property

ImageScanner.IlluminateMode Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether the device enables the illumination source during a scan session.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property IlluminateMode As Boolean
public abstract bool IlluminateMode { get; set; }
public:
virtual property bool IlluminateMode {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_IlluminateMode ()

/** @property */
public abstract void set_IlluminateMode (boolean value)

public abstract function get IlluminateMode () : boolean

public abstract function set IlluminateMode (value : boolean)

Remarks

If true, the Image Scanner enables the illumination source during a scan session. If false, the Image Scanner does not turn on the illumination source during a scan session

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ImageScanner Class
ImageScanner Members
Microsoft.PointOfService Namespace
ImageScanner.CapIlluminate Property


ImageScanner.ImageMode Property

ImageScanner.ImageMode Property |
 | See Also

1/18/2008

Gets or sets a value identifying the Image mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property ImageMode As ImageMode
public abstract ImageMode ImageMode { get; set; }
public:
virtual property ImageMode ImageMode {
    ImageMode get () abstract;
    void set (ImageMode value) abstract;
}
/** @property */
public abstract ImageMode get_ImageMode ()

/** @property */
public abstract void set_ImageMode (ImageMode value)

public abstract function get ImageMode () : ImageMode

public abstract function set ImageMode (value : ImageMode)

Remarks

The value of this property indicates the type of data that is put into the FrameData property upon a DataEvent event.

This property is initialized by the Open method. The default value of this property is StillOnly.

Value | Meaning
DecodeOnly | The Image Scanner does not transmit still images or video to the application. However, it transmits bar code data decoded from obtained images through a Scanner service. A Hydra implementation of Image Scanner and Scanner is required for this mode.
StillOnly | The Image Scanner transmits still images. However, it does not try to read bar code data, nor does it transmit video.
StillAndDecode | The Image Scanner transmits still images, and it tries to read bar code data. However, it does not transmit video streams. A Hydra implementation of ImageScanner and Scanner is required for this mode.
VideoAndDecode | The Image Scanner transmits video streams, and it tries to read bar code data. A Hydra implementation of Image Scanner and Scanner is required for this mode.
VideoAndStill | The Image Scanner transmits video streams, and it transmits still images. However, it does not try to read bar code data. The image resolution of video data could be different from the resolution of still image data.
All | The Image Scanner transmits video streams, and it tries to read bar code data. When a bar code is read, the bar code data and a still image are transmitted. The image resolution of video data could be different from the resolution of still image data. A Hydra implementation of Image Scanner and Scanner is required for this mode.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ImageScanner Class
ImageScanner Members
Microsoft.PointOfService Namespace
ImageScanner.CapDecodeData Property
ImageScanner.CapImageData Property
ImageScanner.CapVideoData Property
ImageScanner.FrameData Property
ImageScanner.StartSession Method


ImageScanner.ImageQuality Property

ImageScanner.ImageQuality Property |
 | See Also

1/18/2008

Gets or sets the picture quality used when recording images.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property ImageQuality As ImageQuality
public abstract ImageQuality ImageQuality { get; set; }
public:
virtual property ImageQuality ImageQuality {
    ImageQuality get () abstract;
    void set (ImageQuality value) abstract;
}
/** @property */
public abstract ImageQuality get_ImageQuality ()

/** @property */
public abstract void set_ImageQuality (ImageQuality value)

public abstract function get ImageQuality () : ImageQuality

public abstract function set ImageQuality (value : ImageQuality)

Remarks

Value | Meaning
High |
Medium |
Low |

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ImageScanner Class
ImageScanner Members
Microsoft.PointOfService Namespace


ImageScanner.IsExclusiveUseDevice Property

ImageScanner.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Get a Boolean value that indicates whether the Image Scanner is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Property Value

A value of true indicates that the Image Scanner is exclusive-use. Otherwise, the value is false.

Remarks

An exclusive-use device has the following properties:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before accessing some properties or calling methods that update the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ImageScanner Class
ImageScanner Members
Microsoft.PointOfService Namespace


ImageScanner.VideoCount Property

ImageScanner.VideoCount Property |
 | See Also

1/18/2008

Gets or sets a value that identifies how many frames of video data is sent with each DataEvent event.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property VideoCount As Integer
public abstract int VideoCount { get; set; }
public:
virtual property int VideoCount {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_VideoCount ()

/** @property */
public abstract void set_VideoCount (int value)

public abstract function get VideoCount () : int

public abstract function set VideoCount (value : int)

Remarks

The default value of this property is 15. Therefore, if the VideoRate property is set to 30 frames per second, this value would yield a DataEvent event two times a second.

If the value of the VideoCount property is larger than the Image Scanner ’s memory storage, then the value of this property will be reset to the device's maximum supported value.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ImageScanner Class
ImageScanner Members
Microsoft.PointOfService Namespace
VideoRate


ImageScanner.VideoRate Property

ImageScanner.VideoRate Property |
 | See Also

1/18/2008

Gets or sets a value identifying the number of video frames per second that the application can receive.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property VideoRate As Integer
public abstract int VideoRate { get; set; }
public:
virtual property int VideoRate {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_VideoRate ()

/** @property */
public abstract void set_VideoRate (int value)

public abstract function get VideoRate () : int

public abstract function set VideoRate (value : int)

Remarks

The default value of this property is 30 frames per second.

The application can set this property and the VideoCount property to throttle the number of DataEvent events that are raised. For example, with the default values of the VideoCount and VideoRate properties, the application would get a DataEvent event two times a second.

If the value of this property is larger than the Image Scanner ’s maximum supported rate, the value of this property will be coerced by the Service to the Image Scanner’s maximum supported rate.

The Image Scanner may discard frames of image data that exceed the specified VideoRate property.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ImageScanner Class
ImageScanner Members
Microsoft.PointOfService Namespace
ImageScanner.VideoCount Property


ImageScanner Events

ImageScanner Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DataEvent | Notifies the application that input data from the Image Scanner is available.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
ErrorEvent | Notifies the application that an Image Scanner device error has been detected and a suitable response by the application is necessary to process the error condition.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

ImageScanner Class
Microsoft.PointOfService Namespace


ImageScanner.DataEvent Event

ImageScanner.DataEvent Event |
 | See Also

1/18/2008

Notifies the application that input data from the Image Scanner is available.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event DataEvent As DataEventHandler
public abstract event DataEventHandler DataEvent
public:
virtual event DataEventHandler^ DataEvent {
    void add (DataEventHandler^ value) abstract;
    void remove (DataEventHandler^ value) abstract;
}
/** @event */
public abstract void add_DataEvent (DataEventHandler value)

/** @event */
public abstract void remove_DataEvent (DataEventHandler value)

Remarks

The Image Scanner data is put in the FrameData property before a DataEvent event is being delivered to the application.

See Also

Reference

ImageScanner Class
ImageScanner Members
Microsoft.PointOfService Namespace
ImageScanner.FrameData Property
ImageScanner.DataEventEnabled Property


ImageScanner.ErrorEvent Event

ImageScanner.ErrorEvent Event |
 | See Also

1/18/2008

Notifies the application that an Image Scanner device error has been detected and a suitable response by the application is necessary to process the error condition.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event ErrorEvent As DeviceErrorEventHandler
public abstract event DeviceErrorEventHandler ErrorEvent
public:
virtual event DeviceErrorEventHandler^ ErrorEvent {
    void add (DeviceErrorEventHandler^ value) abstract;
    void remove (DeviceErrorEventHandler^ value) abstract;
}
/** @event */
public abstract void add_ErrorEvent (DeviceErrorEventHandler value)

/** @event */
public abstract void remove_ErrorEvent (DeviceErrorEventHandler value)

Remarks

Queued when an error is detected when it tries to read Image Scanner data. This event is not delivered until the DataEventEnabled property is true to guarantee correct application sequencing.

See Also

Reference

ImageScanner Class
ImageScanner Members
Microsoft.PointOfService Namespace
ImageScanner.DataEvent Event
ImageScanner.DataEventEnabled Property


ItemDispenser Class

ItemDispenser Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for an Item Dispenser device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class ItemDispenser
    Inherits PosCommon
public abstract class ItemDispenser : PosCommon
public ref class ItemDispenser abstract : public PosCommon
public abstract class ItemDispenser extends PosCommon
public abstract class ItemDispenser extends PosCommon

Remarks

Required Version

The ItemDispenser class requires POS for .NET version 1.12 or later versions.

Capabilities

The Item Dispenser has the following capability:

  • Supports a method that allows a specified number of items to be dispensed from the device.

The Item Dispenser may have the following additional capabilities:

  • Status reporting which indicates empty item slot conditions, almost empty item slot conditions and item slot jamming conditions.

  • Supports multiple items dispensed from different slots.

  • Status reporting in individual item type.

Programming Model

An Item Dispenser consists of slots holding items (for example, CDs, prepaid telephone card, and more) to be dispensed. An application that uses the Item Dispenser service is not concerned with controlling the individual slots of items to be dispensed, but calls a method with the number of items to be dispensed. It is the responsibility of the Item Dispenser device or the service to dispense the correct number of items from the various slots.

Device Sharing

The Item Dispenser is an exclusive-use device. The device sharing rules are as follows:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before accessing some properties, dispensing or collecting, or receiving events.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.ItemDispenser
Microsoft.PointOfService.BasicServiceObjects.ItemDispenserBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ItemDispenser Members
Microsoft.PointOfService Namespace


ItemDispenser Members

ItemDispenser Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for an Item Dispenser device.

The following tables list the members exposed by the ItemDispenser type.

Protected Constructors

Name | Description
ItemDispenser | Creates an instance of the ItemDispenser class.
Top

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusEmpty | Indicates whether the Item Dispenser is empty.
StatusJam | Indicates whether the Item Dispenser is jammed.
StatusNearEmpty | Indicates whether the Item Dispenser is almost empty.
StatusOk | Indicates whether the Item Dispenser is working correctly.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapEmptySensor | Gets a Boolean value that indicates whether the Item Dispenser can report an out-of-item condition.
CapIndividualSlotStatus | Gets a Boolean value that indicates whether the Item Dispenser can report an individual status for each slot.
CapJamSensor | Gets a Boolean value that indicates whether the Item Dispenser can report a mechanical jam or failure condition.
CapNearEmptySensor | Gets a Boolean value that indicates whether the Item Dispenser can report when it is almost out of items.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
DispenserStatus | Gets the current status of the Item Dispenser.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
MaxSlots | Gets an integer value that indicates the maximum number of slots that the Item Dispenser device can support.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether the ItemDispenser is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
AdjustItemCount | Sets the number of items in the Item Dispenser.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
DispenseItem | Dispenses items.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon)
ReadItemCount | Reads the number of items that are currently in the Item Dispenser.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

ItemDispenser Class
Microsoft.PointOfService Namespace


ItemDispenser Fields

ItemDispenser Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusEmpty | Indicates whether the Item Dispenser is empty.
StatusJam | Indicates whether the Item Dispenser is jammed.
StatusNearEmpty | Indicates whether the Item Dispenser is almost empty.
StatusOk | Indicates whether the Item Dispenser is working correctly.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

ItemDispenser Class
Microsoft.PointOfService Namespace


ItemDispenser.StatusEmpty Field

ItemDispenser.StatusEmpty Field |
 | See Also

1/18/2008

Indicates whether the Item Dispenser is empty.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusEmpty As Integer
public const int StatusEmpty
public:
literal int StatusEmpty
public static final int StatusEmpty
public const var StatusEmpty : int

Remarks

Cannot dispense items because the dispenser is empty. If MaxSlots is greater than one (1), some slots are empty.

See Also

Reference

ItemDispenser Class
ItemDispenser Members
Microsoft.PointOfService Namespace


ItemDispenser.StatusJam Field

ItemDispenser.StatusJam Field |
 | See Also

1/18/2008

Indicates whether the Item Dispenser is jammed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusJam As Integer
public const int StatusJam
public:
literal int StatusJam
public static final int StatusJam
public const var StatusJam : int

Remarks

Cannot dispense items because a mechanical fault has occurred.

See Also

Reference

ItemDispenser Class
ItemDispenser Members
Microsoft.PointOfService Namespace


ItemDispenser.StatusNearEmpty Field

ItemDispenser.StatusNearEmpty Field |
 | See Also

1/18/2008

Indicates whether the Item Dispenser is almost empty.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusNearEmpty As Integer
public const int StatusNearEmpty
public:
literal int StatusNearEmpty
public static final int StatusNearEmpty
public const var StatusNearEmpty : int

Remarks

Can still dispense items. However, the dispenser is almost empty. If MaxSlots is greater than one (1), some slots are almost empty.

See Also

Reference

ItemDispenser Class
ItemDispenser Members
Microsoft.PointOfService Namespace


ItemDispenser.StatusOk Field

ItemDispenser.StatusOk Field |
 | See Also

1/18/2008

Indicates whether the Item Dispenser is working correctly.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusOk As Integer
public const int StatusOk
public:
literal int StatusOk
public static final int StatusOk
public const var StatusOk : int

Remarks

Ready to dispense items from all slots. This value is also set when the dispenser is unable to detect error conditions.

See Also

Reference

ItemDispenser Class
ItemDispenser Members
Microsoft.PointOfService Namespace


ItemDispenser Constructor

ItemDispenser Constructor |
 | See Also

1/18/2008

Creates an instance of the ItemDispenser class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected ItemDispenser ()
protected:
ItemDispenser ()
protected ItemDispenser ()
protected function ItemDispenser ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

ItemDispenser Class
ItemDispenser Members
Microsoft.PointOfService Namespace


ItemDispenser Methods

ItemDispenser Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
AdjustItemCount | Sets the number of items in the Item Dispenser.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
DispenseItem | Dispenses items.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon )
ReadItemCount | Reads the number of items that are currently in the Item Dispenser.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

ItemDispenser Class
Microsoft.PointOfService Namespace


ItemDispenser.AdjustItemCount Method

ItemDispenser.AdjustItemCount Method |
 | See Also

1/18/2008

Sets the number of items in the Item Dispenser.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub AdjustItemCount ( _
    itemCount As Integer, _
    slotNumber As Integer _
)
public abstract void AdjustItemCount (
    int itemCount,
    int slotNumber
)
public:
virtual void AdjustItemCount (
    int itemCount,
    int slotNumber
) abstract
public abstract void AdjustItemCount (
    int itemCount,
    int slotNumber
)
public abstract function AdjustItemCount (
    itemCount : int,
    slotNumber : int
)

Parameters

itemCount

Contains the number of items to be initialized.

slotNumber

Contains the slot number to be initialized. Valid slot numbers are 1 through

Remarks

This method is called to set the number of items in the Item Dispenser after initial setup, or to adjust the item count after replenishment or removal. This method is called for devices which cannot determine the exact number of items in them automatically. If the device can determine the exact number of items, this method call is ignored. The application would first call the ReadItemCount method for the current item count, and adjust it to the amount being replenished. Then the application calls this method to set the number of items that are currently in the dispenser.

To reset the item count, set it to zero (0).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ItemDispenser Class
ItemDispenser Members
Microsoft.PointOfService Namespace


ItemDispenser.DispenseItem Method

ItemDispenser.DispenseItem Method |
 | See Also

1/18/2008

Dispenses items.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub DispenseItem ( _
    numItem As Integer, _
    slotNumber As Integer _
)
public abstract void DispenseItem (
    int numItem,
    int slotNumber
)
public:
virtual void DispenseItem (
    int numItem,
    int slotNumber
) abstract
public abstract void DispenseItem (
    int numItem,
    int slotNumber
)
public abstract function DispenseItem (
    numItem : int,
    slotNumber : int
)

Parameters

numItem

Contains the number of items to be dispensed. On return, it contains the number of items dispensed.

slotNumber

Contains the slot number that is used for dispensing items. Valid slot numbers are 1 through MaxSlots

Remarks

The actual number of dispensed items is returned in numItem.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ItemDispenser Class
ItemDispenser Members
Microsoft.PointOfService Namespace


ItemDispenser.ReadItemCount Method

ItemDispenser.ReadItemCount Method |
 | See Also

1/18/2008

Reads the number of items that are currently in the Item Dispenser.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function ReadItemCount ( _
    slotNumber As Integer _
) As Integer
public abstract int ReadItemCount (
    int slotNumber
)
public:
virtual int ReadItemCount (
    int slotNumber
) abstract
public abstract int ReadItemCount (
    int slotNumber
)
public abstract function ReadItemCount (
    slotNumber : int
) : int

Parameters

slotNumber

Contains the slot number that is used for reading the item count. Valid slot numbers are 1 through MaxSlots

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ItemDispenser Class
ItemDispenser Members
Microsoft.PointOfService Namespace


ItemDispenser Properties

ItemDispenser Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapEmptySensor | Gets a Boolean value that indicates whether the Item Dispenser can report an out-of-item condition.
CapIndividualSlotStatus | Gets a Boolean value that indicates whether the Item Dispenser can report an individual status for each slot.
CapJamSensor | Gets a Boolean value that indicates whether the Item Dispenser can report a mechanical jam or failure condition.
CapNearEmptySensor | Gets a Boolean value that indicates whether the Item Dispenser can report when it is almost out of items.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
DispenserStatus | Gets the current status of the Item Dispenser.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
MaxSlots | Gets an integer value that indicates the maximum number of slots that the Item Dispenser device can support.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether the ItemDispenser is an exclusive-use device.

See Also

Reference

ItemDispenser Class
Microsoft.PointOfService Namespace


ItemDispenser.CapEmptySensor Property

ItemDispenser.CapEmptySensor Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the Item Dispenser can report an out-of-item condition.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapEmptySensor As Boolean
public abstract bool CapEmptySensor { get; }
public:
virtual property bool CapEmptySensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapEmptySensor ()

public abstract function get CapEmptySensor () : boolean

Remarks

The Boolean value of true indicates the Item Dispenser can report an out-of-item condition.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ItemDispenser Class
ItemDispenser Members
Microsoft.PointOfService Namespace


ItemDispenser.CapIndividualSlotStatus Property

ItemDispenser.CapIndividualSlotStatus Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the Item Dispenser can report an individual status for each slot.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapIndividualSlotStatus As Boolean
public abstract bool CapIndividualSlotStatus { get; }
public:
virtual property bool CapIndividualSlotStatus {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapIndividualSlotStatus ()

public abstract function get CapIndividualSlotStatus () : boolean

Remarks

The Boolean value of true indicates that the Item Dispenser can report an individual status for each slot.

An individual status can be only reported if the device supports multiple slots. Therefore, if the CapIndividualSlotStatus property is true, then it is implied that the MaxSlots property is greater than one (1).

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ItemDispenser Class
ItemDispenser Members
Microsoft.PointOfService Namespace


ItemDispenser.CapJamSensor Property

ItemDispenser.CapJamSensor Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the Item Dispenser can report a mechanical jam or failure condition.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapJamSensor As Boolean
public abstract bool CapJamSensor { get; }
public:
virtual property bool CapJamSensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapJamSensor ()

public abstract function get CapJamSensor () : boolean

Remarks

The Boolean value of true indicates that the item dispenser can report a mechanical jam or failure condition.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ItemDispenser Class
ItemDispenser Members
Microsoft.PointOfService Namespace


ItemDispenser.CapNearEmptySensor Property

ItemDispenser.CapNearEmptySensor Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the Item Dispenser can report when it is almost out of items.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapNearEmptySensor As Boolean
public abstract bool CapNearEmptySensor { get; }
public:
virtual property bool CapNearEmptySensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapNearEmptySensor ()

public abstract function get CapNearEmptySensor () : boolean

Remarks

The Boolean value of true indicates that the item dispenser can report when it is almost out of items.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ItemDispenser Class
ItemDispenser Members
Microsoft.PointOfService Namespace


ItemDispenser.DispenserStatus Property

ItemDispenser.DispenserStatus Property |
 | See Also

1/18/2008

Gets the current status of the Item Dispenser.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DispenserStatus As ItemDispenserStatus
public abstract ItemDispenserStatus DispenserStatus { get; }
public:
virtual property ItemDispenserStatus DispenserStatus {
    ItemDispenserStatus get () abstract;
}
/** @property */
public abstract ItemDispenserStatus get_DispenserStatus ()

public abstract function get DispenserStatus () : ItemDispenserStatus

Remarks

This property is initialized and kept current while the device is enabled. If more than one condition is present, then the order of precedence starting at the highest is: fault, empty, and near empty.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ItemDispenser Class
ItemDispenser Members
Microsoft.PointOfService Namespace


ItemDispenser.IsExclusiveUseDevice Property

ItemDispenser.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the ItemDispenser is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Remarks

The Boolean value of true indicates that the ItemDispenser is an exclusive-use device. Otherwise, the value is false.

An exclusive-use device has the following properties:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before accessing some properties or calling methods that update the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ItemDispenser Class
ItemDispenser Members
Microsoft.PointOfService Namespace


ItemDispenser.MaxSlots Property

ItemDispenser.MaxSlots Property |
 | See Also

1/18/2008

Gets an integer value that indicates the maximum number of slots that the Item Dispenser device can support.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property MaxSlots As Integer
public abstract int MaxSlots { get; }
public:
virtual property int MaxSlots {
    int get () abstract;
}
/** @property */
public abstract int get_MaxSlots ()

public abstract function get MaxSlots () : int

Remarks

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ItemDispenser Class
ItemDispenser Members
Microsoft.PointOfService Namespace


ItemDispenser Events

ItemDispenser Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

ItemDispenser Class
Microsoft.PointOfService Namespace


ItemDispenserStatus Enumeration

ItemDispenserStatus Enumeration |
 | See Also

1/18/2008

Enumerates the status of the ItemDispenser.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration ItemDispenserStatus
public enum ItemDispenserStatus
public enum class ItemDispenserStatus
public enum ItemDispenserStatus
public enum ItemDispenserStatus

Members

Member name | Description
Empty | Ready to dispense items from all slots. This value is also set when the dispenser is unable to detect error conditions.
Jam | Cannot dispense items, because a mechanical fault has occurred.
NearEmpty | Can still dispense items. However, the dispenser is almost empty. If MaxSlots is greater than one (1), some slots are almost empty.
Ok | Ready to dispense items from all slots. This value is also set when the dispenser is unable to detect error conditions.

Remarks

Applies for status changes of the sensor types supported as indicated by CapEmptySensor, CapNearEmptySensor and CapJamSensor properties.

If MaxSlots is greater than one (1) but the device cannot report status changes on individual slots, the application is notified when some slots are empty or almost empty.

If in addition, the CapIndividualSlotStatus property is true, the High Word of the Status attribute contains the corresponding number of the slot having a status change.

See Also

Reference

Microsoft.PointOfService Namespace


KeyboardEventType Enumeration

KeyboardEventType Enumeration |
 | See Also

1/18/2008

Enumerates the possible type of keyboard events that the application will receive.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration KeyboardEventType
public enum KeyboardEventType
public enum class KeyboardEventType
public enum KeyboardEventType
public enum KeyboardEventType

Members

Member name | Description
Down |
DownUp |

Remarks

Used by the EventTypes property. Members of this enumeration replace the KBD_ET_DOWN and KBD_ET_DOWN_UP UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
EventTypes


KeyEvent Enumeration

KeyEvent Enumeration |
 | See Also

1/18/2008

Enumerates the possible types for the most recent key event.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration KeyEvent
public enum KeyEvent
public enum class KeyEvent
public enum KeyEvent
public enum KeyEvent

Members

Member name | Description
Down | The key was pressed.
Up | The key was released.

Remarks

Used by the PosKeyEventType property. Members of this enumeration replace the KBR_KET_KEYDOWN and KBR_KET_KEYUP UPOS 1.11 constants.

See Also

Reference

Microsoft.PointOfService Namespace
PosKeyEventType


Keylock Class

Keylock Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a UPOS keylock device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class Keylock
    Inherits PosCommon
public abstract class Keylock : PosCommon
public ref class Keylock abstract : public PosCommon
public abstract class Keylock extends PosCommon
public abstract class Keylock extends PosCommon

Remarks

Capabilities

All keylock devices have the following capabilities:

  • The Keylock supports at least three keylock positions.

  • The Keylock uses hardware or software detection to report of keylock position changes.

Model

The Keylock class defines three keylock positions, locked, normal, and supervisor, as constants. The constants representing these Keylock positions are listed below:

Constant | Value
PositionAny | 0
PositionLocked | 1
PositionNormal | 2
PositionSupervisor | 3

The value representing the current keylock position is held in the KeyPosition property. Possible values range from one to the number of keylock positions contained within the PositionCount property

Device Sharing

The Keylock device is sharable. Its device-sharing rules are:

  • After opening and enabling the device, the application can access all properties and methods and will receive status update events.

  • If more than one application has opened and enabled the device, each of these applications can access its properties and methods. StatusUpdateEvent events are fired to all of these applications.

  • The Keylock cannot be claimed for exclusive access. If an application calls ClaimDevice, the method always returns Illegal.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.Keylock
Microsoft.PointOfService.BasicServiceObjects.KeylockBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Keylock Members
Microsoft.PointOfService Namespace


Keylock Members

Keylock Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a UPOS keylock device.

The following tables list the members exposed by the Keylock type.

Protected Constructors

Name | Description
Keylock | Creates an instance of the Keylock class.
Top

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
PositionAny | Indicates to wait for any keylock position change.
PositionElectronic | Indicates to wait for keylock position to be set to the "electronic" position.
PositionLocked | Indicates to wait for keylock position to be set to the "locked" position.
PositionNormal | Indicates to wait for keylock position to be set to the "normal" position.
PositionSupervisor | Indicates to wait for keylock position to be set to the "supervisor" position.
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticLockPositionChangeCount | Indicates how many times the keylock position has changed from "locked."
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapKeylockType | Holds a value that indicates the type of the keylock.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
ElectronicKeyValue | Holds the value read from an electronic Keylock device.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
KeyPosition | Holds a value that indicates the Keylock's current position.
PositionCount | Holds the total number of keylock positions on the Keylock device.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Indicates whether the Keylock is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon)
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
WaitForKeylockChange | Used by the application to wait for a specified keylock position to be set.
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

Keylock Class
Microsoft.PointOfService Namespace


Keylock Fields

Keylock Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
PositionAny | Indicates to wait for any keylock position change.
PositionElectronic | Indicates to wait for keylock position to be set to the "electronic" position.
PositionLocked | Indicates to wait for keylock position to be set to the "locked" position.
PositionNormal | Indicates to wait for keylock position to be set to the "normal" position.
PositionSupervisor | Indicates to wait for keylock position to be set to the "supervisor" position.
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticLockPositionChangeCount | Indicates how many times the keylock position has changed from "locked."
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

Keylock Class
Microsoft.PointOfService Namespace


Keylock.PositionAny Field

Keylock.PositionAny Field |
 | See Also

1/18/2008

Indicates to wait for any keylock position change.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PositionAny As Integer
public const int PositionAny
public:
literal int PositionAny
public static final int PositionAny
public const var PositionAny : int

Remarks

Indicates to wait for any keylock position change.

See Also

Reference

Keylock Class
Keylock Members
Microsoft.PointOfService Namespace
WaitForKeylockChange


Keylock.PositionElectronic Field

Keylock.PositionElectronic Field |
 | See Also

1/18/2008

Indicates to wait for keylock position to be set to the "electronic" position.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PositionElectronic As Integer
public const int PositionElectronic
public:
literal int PositionElectronic
public static final int PositionElectronic
public const var PositionElectronic : int

Remarks

Indicates to wait for keylock position to be set to the "electronic" position.

See Also

Reference

Keylock Class
Keylock Members
Microsoft.PointOfService Namespace


Keylock.PositionLocked Field

Keylock.PositionLocked Field |
 | See Also

1/18/2008

Indicates to wait for keylock position to be set to the "locked" position.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PositionLocked As Integer
public const int PositionLocked
public:
literal int PositionLocked
public static final int PositionLocked
public const var PositionLocked : int

Remarks

Indicates to wait for keylock position to be set to the "locked" position.

See Also

Reference

Keylock Class
Keylock Members
Microsoft.PointOfService Namespace
WaitForKeylockChange


Keylock.PositionNormal Field

Keylock.PositionNormal Field |
 | See Also

1/18/2008

Indicates to wait for keylock position to be set to the "normal" position.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PositionNormal As Integer
public const int PositionNormal
public:
literal int PositionNormal
public static final int PositionNormal
public const var PositionNormal : int

Remarks

Indicates to wait for keylock position to be set to the "normal" position.

See Also

Reference

Keylock Class
Keylock Members
Microsoft.PointOfService Namespace
WaitForKeylockChange


Keylock.PositionSupervisor Field

Keylock.PositionSupervisor Field |
 | See Also

1/18/2008

Indicates to wait for keylock position to be set to the "supervisor" position.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PositionSupervisor As Integer
public const int PositionSupervisor
public:
literal int PositionSupervisor
public static final int PositionSupervisor
public const var PositionSupervisor : int

Remarks

Indicates to wait for keylock position to be set to the "supervisor" position.

See Also

Reference

Keylock Class
Keylock Members
Microsoft.PointOfService Namespace
WaitForKeylockChange


Keylock.StatisticLockPositionChangeCount Field

Keylock.StatisticLockPositionChangeCount Field |
 | See Also

1/18/2008

Indicates how many times the keylock position has changed from "locked."

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticLockPositionChangeCount As String
public const string StatisticLockPositionChangeCount
public:
literal String^ StatisticLockPositionChangeCount
public static final String StatisticLockPositionChangeCount
public const var StatisticLockPositionChangeCount : String

Remarks

Indicates how many times the keylock position has changed from "locked."

See Also

Reference

Keylock Class
Keylock Members
Microsoft.PointOfService Namespace


Keylock Constructor

Keylock Constructor |
 | See Also

1/18/2008

Creates an instance of the Keylock class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected Keylock ()
protected:
Keylock ()
protected Keylock ()
protected function Keylock ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

Keylock Class
Keylock Members
Microsoft.PointOfService Namespace


Keylock Methods

Keylock Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon )
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
WaitForKeylockChange | Used by the application to wait for a specified keylock position to be set.

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

Keylock Class
Microsoft.PointOfService Namespace


Keylock.WaitForKeylockChange Method

Keylock.WaitForKeylockChange Method |
 | See Also

1/18/2008

Used by the application to wait for a specified keylock position to be set.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub WaitForKeylockChange ( _
    keyPosition As Integer, _
    timeout As Integer _
)
public abstract void WaitForKeylockChange (
    int keyPosition,
    int timeout
)
public:
virtual void WaitForKeylockChange (
    int keyPosition,
    int timeout
) abstract
public abstract void WaitForKeylockChange (
    int keyPosition,
    int timeout
)
public abstract function WaitForKeylockChange (
    keyPosition : int,
    timeout : int
)

Parameters

keyPosition

Requested keylock position.keyPosition can contain one of the following values:

Value

Meaning

PositionAny

Wait for any keylock position change.

PositionLocked

Wait for keylock position to be set to the “locked” position.

PositionNormal

Wait for keylock position to be set to the “normal” position.

PositionElectronic

Wait for keylock position to be set to the “electronic” position.

PositionSupervisor

Wait for keylock position to be set to the “supervisor” position.

Other Values

Wait for keylock position to be set to one of the auxiliary positions. This value may range from four (4) up to the total number of keylock positions indicated by the PositionCount property.

timeout

Maximum number of milliseconds to wait for the keylock before returning control back to the application.If zero, WaitForKeylockChange returns the appropriate status immediately.If WaitForever, WaitForKeylockChange waits as long as needed until the requested key position is satisfied or an error occurs.

Remarks

If the keylock position specified by KeyPosition is the same as the current keylock position, the method returns immediately.

If CapKeylockType is Electronic, only PositionAny is allowed as value of the KeyPosition parameter.

WaitForKeylockChange may cause a PosControlException to be thrown with one of the following ErrorCodes:

Value | Meaning
Illegal | The specified value is not valid.
Timeout | The timeout period expired before the requested keylock positioning occurred.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Keylock Class
Keylock Members
Microsoft.PointOfService Namespace
CapKeylockType
PositionCount


Keylock Properties

Keylock Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapKeylockType | Holds a value that indicates the type of the keylock.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
ElectronicKeyValue | Holds the value read from an electronic Keylock device.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
KeyPosition | Holds a value that indicates the Keylock's current position.
PositionCount | Holds the total number of keylock positions on the Keylock device.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Indicates whether the Keylock is an exclusive-use device.

See Also

Reference

Keylock Class
Microsoft.PointOfService Namespace


Keylock.CapKeylockType Property

Keylock.CapKeylockType Property |
 | See Also

1/18/2008

Holds a value that indicates the type of the keylock.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CapKeylockType As KeylockType
public virtual KeylockType CapKeylockType { get; }
public:
virtual property KeylockType CapKeylockType {
    KeylockType get ();
}
/** @property */
public KeylockType get_CapKeylockType ()

public function get CapKeylockType () : KeylockType

Remarks

Holds a value that indicates the type of the keylock.

This property holds one of the following values:

Value | Meaning
Standard | Indicates that the Keylock device is a standard Keylock. This is equivalent to Services compatible with prior versions of the specification.
Electronic | Indicates that the Keylock device is an electronic keylock.

KeyPosition is updated by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Keylock Class
Keylock Members
Microsoft.PointOfService Namespace
ElectronicKeyValue
KeyPosition
PositionCount


Keylock.ElectronicKeyValue Property

Keylock.ElectronicKeyValue Property |
 | See Also

1/18/2008

Holds the value read from an electronic Keylock device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property ElectronicKeyValue As Byte()
public virtual byte[] ElectronicKeyValue { get; }
public:
virtual property array<unsigned char>^ ElectronicKeyValue {
    array<unsigned char>^ get ();
}
/** @property */
public byte[] get_ElectronicKeyValue ()

public function get ElectronicKeyValue () : byte[]

Remarks

Holds the value read from an electronic keylock.

This property is only valid if CapKeylockType is electronic. Typically, electronic keylocks send unique key numbers in raw format when an electronic key is plugged in. Therefore, a typical value could be e.g., “0x00, 0x00, 0x01, 0x52, 0x27, 0xaf” if an electronic key is plugged in, or “0x00, 0x00, 0x00, 0x00, 0x00, 0x00” if it is removed.

This property is initialized and kept current while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Keylock Class
Keylock Members
Microsoft.PointOfService Namespace
CapKeylockType


Keylock.IsExclusiveUseDevice Property

Keylock.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Indicates whether the Keylock is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Property Value

A value of true indicates that the Keylock is exclusive-use. Otherwise, false.

Remarks

An exclusive-use device has the following properties:

  • The application must claim the device before enabling it.

  • The application must claim and enable the device before accessing some properties or calling methods that update the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Keylock Class
Keylock Members
Microsoft.PointOfService Namespace


Keylock.KeyPosition Property

Keylock.KeyPosition Property |
 | See Also

1/18/2008

Holds a value that indicates the Keylock's current position.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property KeyPosition As Integer
public abstract int KeyPosition { get; }
public:
virtual property int KeyPosition {
    int get () abstract;
}
/** @property */
public abstract int get_KeyPosition ()

public abstract function get KeyPosition () : int

Remarks

This value is set whenever the keylock position is changed. In addition to the application receiving the StatusUpdateEvent, this value is changed to reflect the new keylock position.

KeyPosition can hold one of the following values:

Value | Meaning
PositionAny | Keylock is in one of the auxiliary positions. This value can range from four up to the total number of keylock positions indicated by the PositionCount property.
PositionLocked | Keylock is in the “locked” position.
PositionNormal | Keylock is in the “normal” position.
PositionSupervisor | Keylock is in the “supervisor” position.

KeyPosition is updated by the service object while the device is enabled. If CapKeylockType is Electronic this property is meaningless and holds a value of 0.

This property is initialized and kept current while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Keylock Class
Keylock Members
Microsoft.PointOfService Namespace
CapKeylockType
PositionCount


Keylock.PositionCount Property

Keylock.PositionCount Property |
 | See Also

1/18/2008

Holds the total number of keylock positions on the Keylock device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property PositionCount As Integer
public abstract int PositionCount { get; }
public:
virtual property int PositionCount {
    int get () abstract;
}
/** @property */
public abstract int get_PositionCount ()

public abstract function get PositionCount () : int

Remarks

PositionCount is updated by the service object while the device is enabled. If CapKeylockType is Electronic this property is meaningless and holds a value of 0.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Keylock Class
Keylock Members
Microsoft.PointOfService Namespace


Keylock Events

Keylock Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

Keylock Class
Microsoft.PointOfService Namespace


KeylockType Enumeration

KeylockType Enumeration |
 | See Also

1/18/2008

Lists the possible keylock device types.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration KeylockType
public enum KeylockType
public enum class KeylockType
public enum KeylockType
public enum KeylockType

Members

Member name | Description
Electronic | The Keylock is an electronic keylock.
Standard | The Keylock is a standard keylock.

Remarks

Lists the possible keylock device types. Currently, the two types of keylocks are supported by POS for .NET: Electronic keylocks, and standard keylocks.

See Also

Reference

Microsoft.PointOfService Namespace


LightAlarms Enumeration

LightAlarms Enumeration |
 | See Also

1/18/2008

Enumerates the different alarms supported by the Light device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration LightAlarms
[FlagsAttribute]
public enum LightAlarms
[FlagsAttribute]
public enum class LightAlarms
/** @attribute FlagsAttribute() */
public enum LightAlarms
FlagsAttribute
public enum LightAlarms

Members

Member name | Description
Custom1 | Supports first custom alarm.
Custom2 | Supports second custom alarm.
Fast | Supports a fast beep.
Medium | Supports a medium beep.
None | Alarms are not supported.
Slow | Supports a slow beep.

Remarks

LightAlarms is a logical value or a combination of the listed members.

This property is initialized by the Open method. If the device does not support alarms, it is initialized to None.

See Also

Reference

Microsoft.PointOfService Namespace


LightColors Enumeration

LightColors Enumeration |
 | See Also

1/18/2008

Enumerates the supported colors for the Light device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration LightColors
[FlagsAttribute]
public enum LightColors
[FlagsAttribute]
public enum class LightColors
/** @attribute FlagsAttribute() */
public enum LightColors
FlagsAttribute
public enum LightColors

Members

Member name | Description
Custom1 | Supports first custom color (usually red).
Custom2 | Supports second custom color (usually yellow).
Custom3 | Supports third custom color.
Custom4 | Supports fourth custom color.
Custom5 | Supports fifth custom color.
Primary | Supports primary color (usually green).

Remarks

LightColors is a logical value or a combination of the listed members.

This property is initialized by the Open method. If the device supports only one color, it is initialized to Primary.

See Also

Reference

Microsoft.PointOfService Namespace


Lights Class

Lights Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a Light device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class Lights
    Inherits PosCommon
public abstract class Lights : PosCommon
public ref class Lights abstract : public PosCommon
public abstract class Lights extends PosCommon
public abstract class Lights extends PosCommon

Remarks

Required Version

The Lights class requires POS for .NET version 1.12 or later versions.

Capabilities

The Lights device has the following capability:

  • Supports commands to "switch on" and "switch off" a light.

The Lights device may have the following additional capabilities:

  • Supports device-level blinking at adjustable blink cycles.

  • Supports multiple lights.

  • Supports different colors of a light.

  • Supports different alarms.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.Lights
Microsoft.PointOfService.BasicServiceObjects.LightsBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Lights Members
Microsoft.PointOfService Namespace


Lights Members

Lights Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a Light device.

The following tables list the members exposed by the Lights type.

Protected Constructors

Name | Description
Lights | Creates an instance of the Lights class.
Top

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
CapAlarm | Gets the property that indicates if the device supports different alarms.
CapBlink | Gets the Boolean value that indicates if a blinking capability is supported.
CapColor | Gets the property that indicates what colors the device supports.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
MaxLights | Gets the integer value that indicates the maximum number of lights that the device can support.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets the Boolean value that indicates whether the Lights device is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon)
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
SwitchOff | Switches off the specified light.
SwitchOn | Switches on the specified light or lets it blink.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

Lights Class
Microsoft.PointOfService Namespace


Lights Fields

Lights Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

Lights Class
Microsoft.PointOfService Namespace


Lights Constructor

Lights Constructor |
 | See Also

1/18/2008

Creates an instance of the Lights class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected Lights ()
protected:
Lights ()
protected Lights ()
protected function Lights ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

Lights Class
Lights Members
Microsoft.PointOfService Namespace


Lights Methods

Lights Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon )
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
SwitchOff | Switches off the specified light.
SwitchOn | Switches on the specified light or lets it blink.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

Lights Class
Microsoft.PointOfService Namespace


Lights.SwitchOff Method

Lights.SwitchOff Method |
 | See Also

1/18/2008

Switches off the specified light.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub SwitchOff ( _
    lightNumber As Integer _
)
public abstract void SwitchOff (
    int lightNumber
)
public:
virtual void SwitchOff (
    int lightNumber
) abstract
public abstract void SwitchOff (
    int lightNumber
)
public abstract function SwitchOff (
    lightNumber : int
)

Parameters

lightNumber

Specifies the light number. Valid light numbers are 1 through MaxLights.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Lights Class
Lights Members
Microsoft.PointOfService Namespace


Lights.SwitchOn Method

Lights.SwitchOn Method |
 | See Also

1/18/2008

Switches on the specified light or lets it blink.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub SwitchOn ( _
    lightNumber As Integer, _
    blinkOnCycle As Integer, _
    blinkOffCycle As Integer, _
    color As LightColors, _
    alarm As LightAlarms _
)
public abstract void SwitchOn (
    int lightNumber,
    int blinkOnCycle,
    int blinkOffCycle,
    LightColors color,
    LightAlarms alarm
)
public:
virtual void SwitchOn (
    int lightNumber,
    int blinkOnCycle,
    int blinkOffCycle,
    LightColors color,
    LightAlarms alarm
) abstract
public abstract void SwitchOn (
    int lightNumber,
    int blinkOnCycle,
    int blinkOffCycle,
    LightColors color,
    LightAlarms alarm
)
public abstract function SwitchOn (
    lightNumber : int,
    blinkOnCycle : int,
    blinkOffCycle : int,
    color : LightColors,
    alarm : LightAlarms
)

Parameters

lightNumber

Specifies the light number. Valid light numbers are 1 through MaxLights.

blinkOnCycle

A zero (0) value indicates no blink cycle. A positive value indicates the blink on cycle time in milliseconds. Negative values are not allowed.

blinkOffCycle

A zero (0) value indicates no blink cycle. A positive value indicates the blink off cycle time in milliseconds. Negative values are not allowed.

color

Specifies the color of the light, must be one of the colors defined by CapColor.

alarm

Specifies the used alarm type, must be one of the alarms defined by CapAlarm.

Remarks

If blinkOnCycle and blinkOffCycle are zero (0) or CapBlink is false, then the parameters blinkOnCycle and blinkOffCycle are ignored and the light is only switched on.

If CapBlink is true and blinkOnCycle and blinkOffCycle are positive, then the light blinks.

If CapColor is Primary, the light does not support different colors and color is ignored; otherwise, switchOn uses the color specified by color.

If CapAlarm is None, the light does not support different alarms and alarm is ignored; otherwise, switchOn uses the alarm specified by alarm.

Later calls to switchOn change the blink cycles, the color, or the alarm type of the light.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Lights Class
Lights Members
Microsoft.PointOfService Namespace


Lights Properties

Lights Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
CapAlarm | Gets the property that indicates if the device supports different alarms.
CapBlink | Gets the Boolean value that indicates if a blinking capability is supported.
CapColor | Gets the property that indicates what colors the device supports.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
MaxLights | Gets the integer value that indicates the maximum number of lights that the device can support.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets the Boolean value that indicates whether the Lights device is an exclusive-use device.

See Also

Reference

Lights Class
Microsoft.PointOfService Namespace


Lights.CapAlarm Property

Lights.CapAlarm Property |
 | See Also

1/18/2008

Gets the property that indicates if the device supports different alarms.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapAlarm As LightAlarms
public abstract LightAlarms CapAlarm { get; }
public:
virtual property LightAlarms CapAlarm {
    LightAlarms get () abstract;
}
/** @property */
public abstract LightAlarms get_CapAlarm ()

public abstract function get CapAlarm () : LightAlarms

Remarks

This property is initialized by the Open method. If the device does not support alarms, it is initialized to None.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Lights Class
Lights Members
Microsoft.PointOfService Namespace


Lights.CapBlink Property

Lights.CapBlink Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates if a blinking capability is supported.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapBlink As Boolean
public abstract bool CapBlink { get; }
public:
virtual property bool CapBlink {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapBlink ()

public abstract function get CapBlink () : boolean

Remarks

If true, a blinking capability is supported. It may be either a physical capability of the device or emulated by the service.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Lights Class
Lights Members
Microsoft.PointOfService Namespace


Lights.CapColor Property

Lights.CapColor Property |
 | See Also

1/18/2008

Gets the property that indicates what colors the device supports.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapColor As LightColors
public abstract LightColors CapColor { get; }
public:
virtual property LightColors CapColor {
    LightColors get () abstract;
}
/** @property */
public abstract LightColors get_CapColor ()

public abstract function get CapColor () : LightColors

Remarks

This property is initialized by the Open method. If the device supports only one color, it is initialized to Primary.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Lights Class
Lights Members
Microsoft.PointOfService Namespace


Lights.IsExclusiveUseDevice Property

Lights.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the Lights device is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Lights Class
Lights Members
Microsoft.PointOfService Namespace


Lights.MaxLights Property

Lights.MaxLights Property |
 | See Also

1/18/2008

Gets the integer value that indicates the maximum number of lights that the device can support.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property MaxLights As Integer
public abstract int MaxLights { get; }
public:
virtual property int MaxLights {
    int get () abstract;
}
/** @property */
public abstract int get_MaxLights ()

public abstract function get MaxLights () : int

Remarks

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Lights Class
Lights Members
Microsoft.PointOfService Namespace


Lights Events

Lights Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

Lights Class
Microsoft.PointOfService Namespace


LineDisplay Class

LineDisplay Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a UPOS Line Display device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class LineDisplay
    Inherits PosCommon
public abstract class LineDisplay : PosCommon
public ref class LineDisplay abstract : public PosCommon
public abstract class LineDisplay extends PosCommon
public abstract class LineDisplay extends PosCommon

Remarks

All Line Display devices in POS for .NET support text character display as their default capability.

In addition, a Line Display device can support the following operations:

  • Marquee-like scrolling of the window, either vertical or horizontal, or both;

  • Waiting periods between displaying characters, for a teletype effect;

  • Character-level or device-level blinking;

  • One or more descriptors. Descriptors are small indicators with a fixed label, and they are typically used to indicate transaction states such as "Item," "Total," and "Change"; and

  • Control of device brightness, with one or more levels of device dimming, in addition to the default, software-based support of brightness levels of "normal" and "blank."

The general programming model of a Line Display:

  • Consists of one or more rows that contains one or more columns of characters. The characters in the default character set will include at least one of the following, with a capability defining the character set:

    • The digits '0' through '9' plus space, minus ('-'), and period ('.').

    • The previous set plus uppercase 'A' through 'Z.'

    • All ASCII characters from 0x20 through 0x7F. This includes space, digits, uppercase, lowercase, and some special characters.

  • The rows and columns are numbered that begins with (0, 0) at the upper-left corner of the window.

  • Window 0 is always defined as follows:

    • Its "viewport," the part of the display that is updated by the window, covers the display.

    • The size of the window matches the display.

    Therefore, window 0 that is also known as the "device window," maps directly onto the display.

  • Additional windows can be created. A created window has the following characteristics:

    • Its viewport covers part or all the display.

    • The window can either match the size of the viewport, or it can be larger than the viewport in either the horizontal or vertical direction. In the second case, marquee scrolling of the window can be set.

    • The window maintains its own values for rows and columns, current cursor row and column, cursor update flag, scroll type and format, and timers.

    • All viewports behave transparently. If two viewports overlap, then the last character displayed at a position by either of the windows will be visible.

Display Modes

  • Immediate mode

    In effect when MarqueeType is none and InterCharacterWait is 0.

    If the window is bigger than the viewport, only those characters that map into the viewport will be seen.

  • Teletype mode

    In effect when MarqueeType is None and InterCharacterWait is not 0.

    DisplayText and DisplayTextAt requests are queued and processed in the order they are received. The InterCharacterWait timer specifies the time to wait between outputting each character. InterCharacterWait applies only to those characters within the viewport.

  • Marquee mode

    In effect when MarqueeType is a value other than None.

    The window must be bigger than the viewport.

    A marquee is typically initialized after entering Marquee Init mode by setting MarqueeType to Init, then calling ClearText, DisplayText, and DisplayTextAt methods. Then, when MarqueeType is changed to an "on" value, Marquee On mode is entered, and the marquee begins to be displayed in the viewport beginning at the start of the window (or end if the type is right or down).

    When the mode is changed from Marquee On mode to off, the marquee stops in place. A later change back to Marquee On mode continues from the current position.

    When the mode is switched from Marquee On mode to Marquee Init mode, the marquee stops. Changes can be made to the window, then the window can be returned to Marquee On mode to restart the marquee with the new data.

    It is illegal to use DisplayText, DisplayTextAt, ClearText, RefreshWindow, and ScrollText unless in Marquee Init mode or marquees are off.

Device Sharing

The Line Display device is an exclusive-use device. Its device-sharing rules are as follows:

  • The application must claim the device before it enables it.

  • The application must claim and enable the device before accessing some properties or calling methods that update the device.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.LineDisplay
Microsoft.PointOfService.BasicServiceObjects.LineDisplayBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Members
Microsoft.PointOfService Namespace


LineDisplay Members

LineDisplay Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a UPOS Line Display device.

The following tables list the members exposed by the LineDisplay type.

Protected Constructors

Name | Description
LineDisplay | Creates an instance of the LineDisplay class.
Top

Public Fields

Name | Description
CharacterSetAnsi | Indicates the default character set is ANSI.
CharacterSetAscii | Indicates the default character set is ASCII.
CharacterSetUnicode | Indicates the default character set is Unicode.
DisplayBitmapAsIs | Displays the bitmap with one bitmap pixel per dot.
DisplayBitmapBottom | Aligns the bitmap’s bottom edge with the bottommost pixel of the current character position, as specified by the CursorRow property setting.
DisplayBitmapCenter | Aligns the bitmap in the horizontal center of the current character position, as specified by the CursorColumn property setting.
DisplayBitmapLeft | Aligns the bitmap’s left edge with the leftmost pixel of the current character position, as specified by the CursorColumn property setting.
DisplayBitmapRight | Aligns the bitmap’s right edge with the rightmost pixel of the current character position, as specified by the CursorColumn property setting.
DisplayBitmapTop | Aligns the bitmap’s top edge with the topmost pixel of the current character position, as specified by the CursorRow property setting.
ExtendedErrorBadFormat | Indicates that the specified file is either not a bitmap file or it is in an unsupported format.
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
ExtendedErrorTooBig | Indicates that the bitmap is either too wide to display without transformation, or it is too big to transform.
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticOnlineTransitionCount | Incremented when data is successfully drawn in the line display window.
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
BlinkRate | Gets or sets the blink cycle in milliseconds.
CapBitmap | Gets the Boolean value that indicates whether the display of bitmaps is supported.
CapBlink | Gets the character blink capability of the Line Display device.
CapBlinkRate | Gets the Boolean value that indicates whether the blink rate of the device can be controlled.
CapBrightness | Gets the Boolean value that indicates whether brightness can be controlled.
CapCharacterSet | Gets the default character set capability of the Line Display device.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapCursorType | Gets a bitwise indication of the cursor types supported by the Line Display device, selectable through the CursorType property.
CapCustomGlyph | Gets the Boolean value that indicates whether the device support custom glyph definition.
CapDescriptors | Gets the Boolean value that indicates whether the device supports descriptors.
CapHMarquee | Gets the Boolean value that indicates whether the device supports horizontal marquee windows.
CapICharWait | Gets the Boolean value that indicates whether the device supports inter-character wait.
CapMapCharacterSet | Gets the Boolean value that indicates whether the service object can map the characters provided by the application to the character sets defined in the CharacterSetList property when displaying data.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapReadBack | Gets the capability of the Line Display device to read back the data displayed on it.
CapReverse | Gets the reverse video capability of the Line Display device.
CapScreenMode | Gets the Boolean value that indicates whether the Line Display device supports changing the screen mode; that is, the number of text rows and columns.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CapVMarquee | Gets the Boolean value that indicates whether the device supports vertical marquee windows.
CharacterSet | Gets or sets the character set for displaying characters.
CharacterSetList | Gets a string of character set numbers.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Columns | Gets the number of columns for this window.
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
CurrentWindow | Gets or sets the active window to which text is displayed.
CursorColumn | Gets or sets the column in the active window to which the next displayed character will be output.
CursorRow | Gets or sets the row in the active window to which the next displayed character is written.
CursorType | Gets or sets the cursor type for the active window. Possible values are defined by the DisplayCursors enumeration.
CursorUpdate | Gets or sets the Boolean value that indicates whether characters are updated.
CustomGlyphList | Gets an array of instances of the RangeOfCharacters helper class, which represents the character code ranges that are available for defining glyphs.
DeviceBrightness | Gets or sets the device brightness value, expressed as a percentage between 0 and 100.
DeviceColumns | Gets the number of columns on this device.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceDescriptors | Gets the number of descriptors on this device.
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
DeviceRows | Gets the number of rows on this device.
DeviceWindows | Gets the maximum number of windows that the Line Display device supports.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
GlyphHeight | Gets the glyph height based on the number of pixels for a character cell.
GlyphWidth | Gets the glyph width based on the number of pixels for a character cell.
InterCharacterWait | Gets or sets the wait time, specified in milliseconds, between the display of each character with the DisplayText and DisplayTextAt methods.
MapCharacterSet | Gets or sets the Boolean value that indicates whether the Line Display device supports mapping character sets.
MarqueeFormat | Gets or sets the marquee format for the active window.
MarqueeRepeatWait | Gets or sets the wait time, specified in milliseconds, between scrolling the final character or row of the window into its viewport and restarting the marquee with the first or last character or row.
MarqueeType | Gets or sets the marquee type for the active window.
MarqueeUnitWait | Gets or sets the wait time, specified in milliseconds, between marquee scrolling of each column or row in the window.
MaximumX | Gets the maximum number of horizontal pixels that the device supports
MaximumY | Gets the maximum number of vertical pixels that the device supports.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
Rows | Gets the number of rows for this window.
ScreenMode | Gets or sets the screen mode value of the device.
ScreenModeList | Gets the array of DisplayScreenMode class instances that are supported by the device.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets the Boolean value that indicates whether the Line Display device is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearDescriptors | Turns off all descriptors.
ClearText | Clears the active window by displaying blanks, sets the CursorRow and CursorColumn properties to zero, and then resynchronizes the beginning of the window with the start of the viewport.
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
CreateWindow | Creates a viewport over the part of the display specified by the first four parameters.
DefineGlyph | Defines a glyph character.
DestroyWindow | Destroys the active window.
DirectIO | (inherited from PosCommon )
DisplayBitmap | Overloaded.
DisplayText | Overloaded.
DisplayTextAt | Overloaded.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon)
ReadCharacterAtCursor | Reads the currently displayed character at the cursor position.
ReferenceEquals | (inherited from Object )
RefreshWindow | Changes the active window to the one specified by the window parameter, then redisplays that window’s viewport.
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ScrollText | Scrolls text in the active window, in the specified direction.
SetBitmap | Overloaded.
SetDescriptor | Sets the state of a descriptor.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

LineDisplay Class
Microsoft.PointOfService Namespace


LineDisplay Fields

LineDisplay Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
CharacterSetAnsi | Indicates the default character set is ANSI.
CharacterSetAscii | Indicates the default character set is ASCII.
CharacterSetUnicode | Indicates the default character set is Unicode.
DisplayBitmapAsIs | Displays the bitmap with one bitmap pixel per dot.
DisplayBitmapBottom | Aligns the bitmap’s bottom edge with the bottommost pixel of the current character position, as specified by the CursorRow property setting.
DisplayBitmapCenter | Aligns the bitmap in the horizontal center of the current character position, as specified by the CursorColumn property setting.
DisplayBitmapLeft | Aligns the bitmap’s left edge with the leftmost pixel of the current character position, as specified by the CursorColumn property setting.
DisplayBitmapRight | Aligns the bitmap’s right edge with the rightmost pixel of the current character position, as specified by the CursorColumn property setting.
DisplayBitmapTop | Aligns the bitmap’s top edge with the topmost pixel of the current character position, as specified by the CursorRow property setting.
ExtendedErrorBadFormat | Indicates that the specified file is either not a bitmap file or it is in an unsupported format.
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
ExtendedErrorTooBig | Indicates that the bitmap is either too wide to display without transformation, or it is too big to transform.
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticOnlineTransitionCount | Incremented when data is successfully drawn in the line display window.
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

LineDisplay Class
Microsoft.PointOfService Namespace


LineDisplay.CharacterSetAnsi Field

LineDisplay.CharacterSetAnsi Field |
 | See Also

1/18/2008

Indicates the default character set is ANSI.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const CharacterSetAnsi As Integer
public const int CharacterSetAnsi
public:
literal int CharacterSetAnsi
public static final int CharacterSetAnsi
public const var CharacterSetAnsi : int

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace


LineDisplay.CharacterSetAscii Field

LineDisplay.CharacterSetAscii Field |
 | See Also

1/18/2008

Indicates the default character set is ASCII.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const CharacterSetAscii As Integer
public const int CharacterSetAscii
public:
literal int CharacterSetAscii
public static final int CharacterSetAscii
public const var CharacterSetAscii : int

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace


LineDisplay.CharacterSetUnicode Field

LineDisplay.CharacterSetUnicode Field |
 | See Also

1/18/2008

Indicates the default character set is Unicode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const CharacterSetUnicode As Integer
public const int CharacterSetUnicode
public:
literal int CharacterSetUnicode
public static final int CharacterSetUnicode
public const var CharacterSetUnicode : int

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace


LineDisplay.DisplayBitmapAsIs Field

LineDisplay.DisplayBitmapAsIs Field |
 | See Also

1/18/2008

Displays the bitmap with one bitmap pixel per dot.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const DisplayBitmapAsIs As Integer
public const int DisplayBitmapAsIs
public:
literal int DisplayBitmapAsIs
public static final int DisplayBitmapAsIs
public const var DisplayBitmapAsIs : int

Remarks

Used in the DisplayBitmap method.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
DisplayBitmap


LineDisplay.DisplayBitmapBottom Field

LineDisplay.DisplayBitmapBottom Field |
 | See Also

1/18/2008

Aligns the bitmap’s bottom edge with the bottommost pixel of the current character position, as specified by the CursorRow property setting.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const DisplayBitmapBottom As Integer
public const int DisplayBitmapBottom
public:
literal int DisplayBitmapBottom
public static final int DisplayBitmapBottom
public const var DisplayBitmapBottom : int

Remarks

Used in the DisplayBitmap and SetBitmap methods.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
DisplayBitmap
SetBitmap
CursorRow


LineDisplay.DisplayBitmapCenter Field

LineDisplay.DisplayBitmapCenter Field |
 | See Also

1/18/2008

Aligns the bitmap in the horizontal center of the current character position, as specified by the CursorColumn property setting.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const DisplayBitmapCenter As Integer
public const int DisplayBitmapCenter
public:
literal int DisplayBitmapCenter
public static final int DisplayBitmapCenter
public const var DisplayBitmapCenter : int

Remarks

Used in the DisplayBitmap and SetBitmap methods.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
DisplayBitmap
SetBitmap
CursorColumn


LineDisplay.DisplayBitmapLeft Field

LineDisplay.DisplayBitmapLeft Field |
 | See Also

1/18/2008

Aligns the bitmap’s left edge with the leftmost pixel of the current character position, as specified by the CursorColumn property setting.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const DisplayBitmapLeft As Integer
public const int DisplayBitmapLeft
public:
literal int DisplayBitmapLeft
public static final int DisplayBitmapLeft
public const var DisplayBitmapLeft : int

Remarks

Used in the DisplayBitmap and SetBitmap methods.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
DisplayBitmap
SetBitmap
CursorColumn


LineDisplay.DisplayBitmapRight Field

LineDisplay.DisplayBitmapRight Field |
 | See Also

1/18/2008

Aligns the bitmap’s right edge with the rightmost pixel of the current character position, as specified by the CursorColumn property setting.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const DisplayBitmapRight As Integer
public const int DisplayBitmapRight
public:
literal int DisplayBitmapRight
public static final int DisplayBitmapRight
public const var DisplayBitmapRight : int

Remarks

Used in the DisplayBitmap and SetBitmap methods.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
DisplayBitmap
SetBitmap
CursorColumn


LineDisplay.DisplayBitmapTop Field

LineDisplay.DisplayBitmapTop Field |
 | See Also

1/18/2008

Aligns the bitmap’s top edge with the topmost pixel of the current character position, as specified by the CursorRow property setting.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const DisplayBitmapTop As Integer
public const int DisplayBitmapTop
public:
literal int DisplayBitmapTop
public static final int DisplayBitmapTop
public const var DisplayBitmapTop : int

Remarks

Used in the DisplayBitmap and SetBitmap methods.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
DisplayBitmap
SetBitmap
CursorRow


LineDisplay.ExtendedErrorBadFormat Field

LineDisplay.ExtendedErrorBadFormat Field |
 | See Also

1/18/2008

Indicates that the specified file is either not a bitmap file or it is in an unsupported format.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorBadFormat As Integer
public const int ExtendedErrorBadFormat
public:
literal int ExtendedErrorBadFormat
public static final int ExtendedErrorBadFormat
public const var ExtendedErrorBadFormat : int

Remarks

Used in the DisplayBitmap and SetBitmap methods.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
DisplayBitmap
SetBitmap


LineDisplay.ExtendedErrorTooBig Field

LineDisplay.ExtendedErrorTooBig Field |
 | See Also

1/18/2008

Indicates that the bitmap is either too wide to display without transformation, or it is too big to transform.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorTooBig As Integer
public const int ExtendedErrorTooBig
public:
literal int ExtendedErrorTooBig
public static final int ExtendedErrorTooBig
public const var ExtendedErrorTooBig : int

Remarks

Used in the DisplayBitmap and SetBitmap methods.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
DisplayBitmap
SetBitmap


LineDisplay.StatisticOnlineTransitionCount Field

LineDisplay.StatisticOnlineTransitionCount Field |
 | See Also

1/18/2008

Incremented when data is successfully drawn in the line display window.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticOnlineTransitionCount As String
public const string StatisticOnlineTransitionCount
public:
literal String^ StatisticOnlineTransitionCount
public static final String StatisticOnlineTransitionCount
public const var StatisticOnlineTransitionCount : String

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace


LineDisplay Constructor

LineDisplay Constructor |
 | See Also

1/18/2008

Creates an instance of the LineDisplay class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected LineDisplay ()
protected:
LineDisplay ()
protected LineDisplay ()
protected function LineDisplay ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace


LineDisplay Methods

LineDisplay Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearDescriptors | Turns off all descriptors.
ClearText | Clears the active window by displaying blanks, sets the CursorRow and CursorColumn properties to zero, and then resynchronizes the beginning of the window with the start of the viewport.
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
CreateWindow | Creates a viewport over the part of the display specified by the first four parameters.
DefineGlyph | Defines a glyph character.
DestroyWindow | Destroys the active window.
DirectIO | (inherited from PosCommon )
DisplayBitmap | Overloaded.
DisplayText | Overloaded.
DisplayTextAt | Overloaded.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon )
ReadCharacterAtCursor | Reads the currently displayed character at the cursor position.
ReferenceEquals | (inherited from Object )
RefreshWindow | Changes the active window to the one specified by the window parameter, then redisplays that window’s viewport.
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ScrollText | Scrolls text in the active window, in the specified direction.
SetBitmap | Overloaded.
SetDescriptor | Sets the state of a descriptor.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

LineDisplay Class
Microsoft.PointOfService Namespace


LineDisplay.ClearDescriptors Method

LineDisplay.ClearDescriptors Method |
 | See Also

1/18/2008

Turns off all descriptors.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearDescriptors
public abstract void ClearDescriptors ()
public:
virtual void ClearDescriptors () abstract
public abstract void ClearDescriptors ()
public abstract function ClearDescriptors ()

Remarks

If the CapDescriptors property is set to false, ClearDescriptors throws an Illegal exception and returns immediately.

ClearDescriptors may cause a PosControlException to be thrown with the following ErrorCode.

Value | Meaning
Illegal | The device does not support descriptors.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
SetDescriptor
DeviceDescriptors


LineDisplay.ClearText Method

LineDisplay.ClearText Method |
 | See Also

1/18/2008

Clears the active window by displaying blanks, sets the CursorRow and CursorColumn properties to zero, and then resynchronizes the beginning of the window with the start of the viewport.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearText
public abstract void ClearText ()
public:
virtual void ClearText () abstract
public abstract void ClearText ()
public abstract function ClearText ()

Remarks

If the device is in Immediate mode or Teletype mode, the viewport is also cleared immediately.

If in Marquee Init mode, the viewport is not changed.

If in Marquee On mode, ClearText is illegal.

ClearText may cause a PosControlException to be thrown with the following ErrorCode.

Value | Meaning
Illegal | The device is in Marquee On mode and cannot be cleared.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
DisplayText
DisplayText


LineDisplay.CreateWindow Method

LineDisplay.CreateWindow Method |
 | See Also

1/18/2008

Creates a viewport over the part of the display specified by the first four parameters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub CreateWindow ( _
    viewportRow As Integer, _
    viewportColumn As Integer, _
    viewportHeight As Integer, _
    viewportWidth As Integer, _
    windowHeight As Integer, _
    windowWidth As Integer _
)
public abstract void CreateWindow (
    int viewportRow,
    int viewportColumn,
    int viewportHeight,
    int viewportWidth,
    int windowHeight,
    int windowWidth
)
public:
virtual void CreateWindow (
    int viewportRow,
    int viewportColumn,
    int viewportHeight,
    int viewportWidth,
    int windowHeight,
    int windowWidth
) abstract
public abstract void CreateWindow (
    int viewportRow,
    int viewportColumn,
    int viewportHeight,
    int viewportWidth,
    int windowHeight,
    int windowWidth
)
public abstract function CreateWindow (
    viewportRow : int,
    viewportColumn : int,
    viewportHeight : int,
    viewportWidth : int,
    windowHeight : int,
    windowWidth : int
)

Parameters

viewportRow

The viewport’s start device row.

viewportColumn

The viewport’s start device column.

viewportHeight

The number of device rows in the viewport.

viewportWidth

The number of device columns in the viewport.

windowHeight

The number of rows in the window.

windowWidth

The number of columns in the window.

Remarks

The window size is specified by the last two parameters. Valid window row values range from (0) to (windowHeight-1) and column values range from (0) to (windowWidth-1).

The window size must be at least as large as the viewport size.

The window size can be larger than the viewport size in one direction. By using the window marquee properties MarqueeType, MarqueeFormat, MarqueeUnitWait, and MarqueeRepeatWait, such a window can be continuously scrolled as a marquee.

When successful, CreateWindow sets the CurrentWindow property to the window number assigned to this window. The following table shows the properties that are maintained for each window and with what value they are initialized.

Property | Value
Rows | windowHeight
Columns | windowWidth
CursorRow | 0
CursorColumn | 0
CursorUpdate | true
MarqueeType | None
MarqueeFormat | Walk
MarqueeUnitWait | 0
MarqueeRepeatWait | 0
InterCharacterWait | 0

CreateWindow may cause a PosControlException to be thrown with the following ErrorCode.

Value

Meaning

Illegal

One of the following conditions has occurred:

  • CreateWindow cannot be called for Window 0.

  • One or more parameters are out of their valid ranges.

  • All available windows are already that is used.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
DestroyWindow
CurrentWindow


LineDisplay.DefineGlyph Method

LineDisplay.DefineGlyph Method |
 | See Also

1/18/2008

Defines a glyph character.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub DefineGlyph ( _
    glyphCode As Integer, _
    glyph As Byte() _
)
public abstract void DefineGlyph (
    int glyphCode,
    byte[] glyph
)
public:
virtual void DefineGlyph (
    int glyphCode,
    array<unsigned char>^ glyph
) abstract
public abstract void DefineGlyph (
    int glyphCode,
    byte[] glyph
)
public abstract function DefineGlyph (
    glyphCode : int,
    glyph : byte[]
)

Parameters

glyphCode

The character code to be defined.

glyph

Data bytes that define the glyph.

Remarks

The glyph is defined as bits representing each pixel packed into bytes, by using whole bytes to represent each row.

The minimum number of bytes are sent for each row, based on the value of the GlyphWidth property, and using 8 bits per byte. Bytes are sent left-to-right across each row; if more than one byte is required per row, the leftmost byte is sent first. The lowest-order bit within a byte represents the rightmost pixel. Bits that do not represent pixels are the highest-order bits, and their value is ignored. Rows are sent from the top down.

For example, a 10-pixel wide glyph would have the two leftmost pixels represented in bits 1 and 0 of the first byte, respectively. The remaining 8 pixels would be represented in the second byte.

Enough rows must be sent to define the whole character. Whether changing the definition of a glyph causes currently displayed characters to change, or the change appears only when the next glyph is drawn, is hardware-defined.

DefineGlyph may cause a PosControlException to be thrown with the following ErrorCode.

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The CapCustomGlyph property is set to false. This indicates that the device does not support custom glyphs.

  • The glyphCode parameter contains an unsupported character code for glyph definition.

  • The glyph parameter contains an incorrect number of bytes, (based on the GlyphWidth and GlyphHeight properties and 8 bits per byte).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
CapCustomGlyph
GlyphHeight
GlyphWidth


LineDisplay.DestroyWindow Method

LineDisplay.DestroyWindow Method |
 | See Also

1/18/2008

Destroys the active window.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub DestroyWindow
public abstract void DestroyWindow ()
public:
virtual void DestroyWindow () abstract
public abstract void DestroyWindow ()
public abstract function DestroyWindow ()

Remarks

The characters displayed in its viewport are not changed.

DestroyWindow sets the CurrentWindow property to window 0, the device window. The device window and the associated window properties are updated.

DestroyWindow may cause a PosControlException to be thrown with the following ErrorCode.

Value | Meaning
Illegal | The active window is set to 0, the device window. This window cannot be destroyed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
LineDisplay.CreateWindow Method
CurrentWindow


LineDisplay.DisplayBitmap Method

LineDisplay.DisplayBitmap Method |
 | See Also

1/18/2008

Overload List

Name | Description
LineDisplay.DisplayBitmap (String, Int32, Int32) | Displays the bitmap with the specified alignment.
LineDisplay.DisplayBitmap (String, Int32, Int32, Int32) | Displays the bitmap with the specified alignment and width.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace


LineDisplay.DisplayBitmap Method (String, Int32, Int32)

LineDisplay.DisplayBitmap Method (String, Int32, Int32) |
 | See Also

1/18/2008

Displays the bitmap with the specified alignment.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub DisplayBitmap ( _
    fileName As String, _
    alignmentX As Integer, _
    alignmentY As Integer _
)
public abstract void DisplayBitmap (
    string fileName,
    int alignmentX,
    int alignmentY
)
public:
virtual void DisplayBitmap (
    String^ fileName,
    int alignmentX,
    int alignmentY
) abstract
public abstract void DisplayBitmap (
    String fileName,
    int alignmentX,
    int alignmentY
)
public abstract function DisplayBitmap (
    fileName : String,
    alignmentX : int,
    alignmentY : int
)

Parameters

fileName

File name or URL of the bitmap file. Various file formats can be supported, such as BMP, GIF, or JPEG.

alignmentX

Horizontal placement of the bitmap to be displayed. For possible values, see Remarks.

alignmentY

Vertical placement of the bitmap to be displayed. For possible values, see Remarks.

Remarks

The alignmentX parameter has one of the following values.

Value | Meaning
DisplayBitmapLeft | Align the bitmap’s left edge with the leftmost pixel of the current character position, as specified by the CursorColumn property setting.
DisplayBitmapCenter | Align the bitmap in the horizontal center of the current character position, as specified by the CursorColumn property setting.
DisplayBitmapRight | Align the bitmap’s right edge with the rightmost pixel of the current character position, as specified by the CursorColumn property setting.
Other values | Distance from the window’s leftmost pixel column to the left edge of the bitmap, expressed in number of pixels.

The alignmentY parameter has one of the following values.

Value | Meaning
DisplayBitmapTop | Align the bitmap’s top edge with the topmost pixel of the current character position, as specified by the CursorRow property setting.
DisplayBitmapCenter | Align the bitmap in the vertical center of the current character position, as specified by the CursorRow property setting.
DisplayBitmapBottom | Align the bitmap’s bottom edge with the bottommost pixel of the current character position, as specified by the CursorRow property setting.
Other values | Distance from the window’s topmost pixel row to the start of the bitmap, expressed in number of pixels.

The application calls DisplayBitmap to display a bitmap on the Line Display device. The bitmap is displayed within the active window’s viewport.

If the values specified for the alignmentX and alignmentY are the values that are defined by the DisplayBitmap f constants. Then the bitmap is displayed in relation to the character positions specified by the CursorColumn and CursorRow properties. In addition, if the CursorUpdate property is set to true, then CursorColumn and CursorRow are updated to point to the first character position following the bitmap.

If the bitmap does not exactly occupy a multiple of rows and columns, then the unused pixels of those character positions that are partially occupied are displayed with the background color. In other words, the service object will fill all character positions partially or completely occupied by the bitmap with the background color before drawing the bitmap.

Bitmap display has the following restrictions:

  • Bitmap display is only legal when in Immediate mode.

  • The window size must match the window’s viewport size.

  • The bitmap must be displayable within the window, after consideration of the function parameters. For example, if alignmentX specifies a pixel near the bottom of the window and the bitmap height (after bitmap transformation, if they are required) exceeds the distance from alignmentX to the window bottom, then the bitmap is not displayed.

DisplayBitmap may cause a PosControlException to be thrown with one of the following ErrorCodes.

Value

Meaning

Illegal

One of the following errors occurred:

  • The Line Display device does not support bitmap display (the CapBitmap property is set to false;

  • The alignmentX/alignmentY parameters are invalid or too big.

  • The window is not in Immediate mode.

  • The window size does not match its viewport size.

NoExist

The specified fileName was not found.

Extended

ErrorCodeExtended = ExtendedErrorTooBig: The bitmap is either too wide to display without transformation, or it is too big to transform.

ErrorCodeExtended = ExtendedErrorBadFormat: The specified file is either not a bitmap file or it is in an unsupported format.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace


LineDisplay.DisplayBitmap Method (String, Int32, Int32, Int32)

LineDisplay.DisplayBitmap Method (String, Int32, Int32, Int32) |
 | See Also

1/18/2008

Displays the bitmap with the specified alignment and width.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub DisplayBitmap ( _
    fileName As String, _
    width As Integer, _
    alignmentX As Integer, _
    alignmentY As Integer _
)
public abstract void DisplayBitmap (
    string fileName,
    int width,
    int alignmentX,
    int alignmentY
)
public:
virtual void DisplayBitmap (
    String^ fileName,
    int width,
    int alignmentX,
    int alignmentY
) abstract
public abstract void DisplayBitmap (
    String fileName,
    int width,
    int alignmentX,
    int alignmentY
)
public abstract function DisplayBitmap (
    fileName : String,
    width : int,
    alignmentX : int,
    alignmentY : int
)

Parameters

fileName

File name or URL of the bitmap file. Various file formats can be supported, such as BMP, GIF, or JPEG.

width

Width of the bitmap to be displayed. See values below.

alignmentX

Horizontal placement of the bitmap to be displayed. For possible values, see Remarks.

alignmentY

Vertical placement of the bitmap to be displayed. For possible values, see Remarks.

Remarks

The width parameter has one of the following values:

Value | Meaning
DisplayBitmapAsIs | Display the bitmap with one bitmap pixel per dot.
Other values | Bitmap width expressed in number of pixels.

The alignmentX parameter has one of the following values:

Value | Meaning
DisplayBitmapLeft | Align the bitmap’s left edge with the leftmost pixel of the current character position, as specified by the CursorColumn property setting.
DisplayBitmapCenter | Align the bitmap in the horizontal center of the current character position, as specified by the CursorColumn property setting.
DisplayBitmapRight | Align the bitmap’s right edge with the rightmost pixel of the current character position, as specified by the CursorColumn property setting.
Other values | Distance from the window’s leftmost pixel column to the left edge of the bitmap, expressed in number of pixels.

The alignmentY parameter has one of the following values:

Value | Meaning
DisplayBitmapTop | Align the bitmap’s top edge with the topmost pixel of the current character position, as specified by the CursorRow property setting.
DisplayBitmapCenter | Align the bitmap in the vertical center of the current character position, as specified by the CursorRow property setting.
DisplayBitmapBottom | Align the bitmap’s bottom edge with the bottommost pixel of the current character position, as specified by the CursorRow property setting.
Other values | Distance from the window’s topmost pixel row to the start of the bitmap, expressed in number of pixels.

The application calls DisplayBitmap to display a bitmap on the Line Display device. The bitmap is displayed within the active window’s viewport.

If the values specified for the alignmentX and alignmentY are the values that are defined by the DisplayBitmap constants, then the bitmap is displayed in relation to the character positions specified by the CursorColumn and CursorRow properties. In addition, if the CursorUpdate property is set to true, then CursorColumn and CursorRow are updated to point to the first character position following the bitmap.

If the bitmap does not exactly occupy a multiple of rows and columns, then the unused pixels of those character positions that are partially occupied are displayed with the background color. In other words, the service object will fill all character positions partially or completely occupied by the bitmap with the background color before drawing the bitmap.

Bitmap display has the following restrictions:

  • Bitmap display is only legal when in Immediate mode;

  • The window size must match the window’s viewport size;

  • The bitmap must be displayable within the window, after consideration of the function parameters. For example, if alignmentX specifies a pixel near the bottom of the window and the bitmap height (after bitmap transformation, if they are required) exceeds the distance from alignmentX to the window bottom, then the bitmap is not displayed.

The width parameter controls transformation of the bitmap. If width is DisplayBitmapAsIs, then no transformation is performed. The bitmap is displayed with one bitmap pixel per Line Display pixel. The advantages of this option are as follows:

  • It provides the highest performance bitmap display; and

  • It works well for bitmaps tuned for a specific Line Display device’s aspect ratio between horizontal and vertical dots.

If width is nonzero, then the bitmap will be transformed by stretching or compressing the bitmap in such a way that its width is the specified width and the aspect ratio is unchanged. The advantages of this option are as follows:

  • It sizes the bitmap to fit many Line Display devices; and

  • It maintains the bitmap’s aspect ratio.

The disadvantages of this option are as follows:

  • Reduced performance than untransformed data; and

  • Some lines and images that are "smooth" in the original bitmap may show some "ratcheting."

DisplayBitmap may cause a PosControlException to be thrown with one of the following ErrorCodes:

Value

Meaning

Illegal

One of the following errors occurred:

The Line Display device does not support bitmap display (the CapBitmap property is set to false;

The width parameter is invalid or too big;

The alignmentX/alignmentY parameters are invalid or too big;

The window is not in Immediate mode; or

The window size does not match its viewport size.

NoExist

The specified fileName was not found.

Extended

ErrorCodeExtended = ExtendedErrorTooBig: The bitmap is either too wide to display without transformation, or it is too big to transform.

ErrorCodeExtended = ExtendedErrorBadFormat: The specified file is either not a bitmap file or it is in an unsupported format.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace


LineDisplay.DisplayText Method

LineDisplay.DisplayText Method |
 | See Also

1/18/2008

Overload List

Name | Description
LineDisplay.DisplayText (String) | Displays the specified string of characters.
LineDisplay.DisplayText (String, DisplayTextMode) | Displays the specified string of characters in the specified display mode.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
LineDisplay.ClearText Method
DisplayTextAt
DisplayTextAt
InterCharacterWait


LineDisplay.DisplayText Method (String)

LineDisplay.DisplayText Method (String) |
 | See Also

1/18/2008

Displays the specified string of characters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub DisplayText ( _
    data As String _
)
public abstract void DisplayText (
    string data
)
public:
virtual void DisplayText (
    String^ data
) abstract
public abstract void DisplayText (
    String data
)
public abstract function DisplayText (
    data : String
)

Parameters

data

The string of characters to display.

Remarks

The characters in data is processed beginning at the location that is specified by the CursorRow and CursorColumn property settings, and continue in succeeding columns.

Character processing continues to the next row when the end of a window row is reached. If the end of the window is reached with additional characters to be processed, then the window is scrolled upward by one row and the bottom row is set to blanks. If the CursorUpdate property is set to true, then CursorRow and CursorColumn are updated to point to the character following the last character of data.

Notice that scrolling does not occur when the last character of data is put at the end of a row. In this case, when CursorUpdate is true, then CursorRow is set to the row that contains the last character, and CursorColumn is set to the Columns setting (that is, to one more than the final character of the row). This stipulation guarantees that the display does not scroll when a character is written into its last position. Instead, the window does not scroll until another character is written.

The operation of DisplayText and DisplayTextAt varies for each mode:

  • Immediate mode (The MarqueeType property = None and the InterCharacterWait property = 0): Updates the window and viewport immediately.

  • Teletype mode (MarqueeType = None and InterCharacterWait not = 0): The data is queued. Queued data requests are processed in order, typically by another thread within the service object, updating the window and viewport by by using a wait time in milliseconds of the InterCharacterWait property after each character is sent to the viewport.

  • Marquee Init mode (MarqueeType = Init): Updates the window, but does not change the viewport.

  • Marquee On mode (MarqueeType not = Init): Illegal.

Special character values within data are as follows:

Value | Meaning
Carriage Return (13 Decimal) | Change the next character’s output position to the beginning of the current row.
Newline / Line Feed (10 Decimal) | Change the next character’s output position to the beginning of the next row. Scroll the window if the current row is the last row of the window.

DisplayText may cause a PosControlException to be thrown with the following ErrorCode.

Value | Meaning
Illegal | The display is in Marquee On mode, and DisplayText cannot be called when the device is in that mode.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
LineDisplay.ClearText Method
DisplayTextAt
DisplayTextAt
InterCharacterWait


LineDisplay.DisplayText Method (String, DisplayTextMode)

LineDisplay.DisplayText Method (String, DisplayTextMode) |
 | See Also

1/18/2008

Displays the specified string of characters in the specified display mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub DisplayText ( _
    data As String, _
    attribute As DisplayTextMode _
)
public abstract void DisplayText (
    string data,
    DisplayTextMode attribute
)
public:
virtual void DisplayText (
    String^ data,
    DisplayTextMode attribute
) abstract
public abstract void DisplayText (
    String data,
    DisplayTextMode attribute
)
public abstract function DisplayText (
    data : String,
    attribute : DisplayTextMode
)

Parameters

data

The string of characters to display.

attribute

The display attribute for the text. Possible values are defined by the DisplayTextMode enumeration. Valid values are Normal or Blink.

Remarks

The characters in data is processed beginning at the location that is specified by the CursorRow and CursorColumn property settings, and continue in succeeding columns.

Character processing continues to the next row when the end of a window row is reached. If the end of the window is reached with additional characters to be processed, then the window is scrolled upward by one row and the bottom row is set to blanks. If the CursorUpdate property is set to true, then CursorRow and CursorColumn are updated to point to the character following the last character of data.

Notice that scrolling does not occur when the last character of data is put at the end of a row. In this case, when CursorUpdate is true, then CursorRow is set to the row that contains the last character, and CursorColumn is set to the Columns setting (that is, to one more than the final character of the row). This stipulation guarantees that the display does not scroll when a character is written into its last position. Instead, the window does not scroll until another character is written.

The operation of DisplayText (and DisplayTextAt) varies for each mode:

  • Immediate mode (The MarqueeType property = None and the InterCharacterWait property = 0): Updates the window and viewport immediately.

  • Teletype mode (MarqueeType = None and InterCharacterWait not = 0): The data is queued. Queued data requests are processed in order (typically by another thread within the service object), updating the window and viewport by using a wait time in milliseconds of the InterCharacterWait property after each character is sent to the viewport.

  • Marquee Init mode (MarqueeType = Init): Updates the window, but does not change the viewport.

  • Marquee On mode (MarqueeType not = Init): Illegal.

If the service object has set the CapBlink property to NoBlink, then attribute is ignored. If it has been set to BlinkAll, then the display will blink when one or more characters have been set to blink. If it has been set to BlinkEach, then only those characters displayed with the blink attribute will blink.

Special character values within data is as follows:

Value | Meaning
Carriage Return (13 Decimal) | Change the next character’s output position to the beginning of the current row.
Newline / Line Feed (10 Decimal) | Change the next character’s output position to the beginning of the next row. Scroll the window if the current row is the last row of the window.

DisplayText may cause a PosControlException to be thrown with the following ErrorCode.

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The value specified for attribute was not found in the DisplayTextMode enumerator.

  • The display is in Marquee On mode, and DisplayText cannot be called when the device is in that mode.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
LineDisplay.ClearText Method
DisplayTextAt
DisplayTextAt
InterCharacterWait


LineDisplay.DisplayTextAt Method

LineDisplay.DisplayTextAt Method |
 | See Also

1/18/2008

Overload List

Name | Description
LineDisplay.DisplayTextAt (Int32, Int32, String) | Displays the string of characters at the specified row and column.
LineDisplay.DisplayTextAt (Int32, Int32, String, DisplayTextMode) | Displays the string of characters at the specified row and column, in the specified display mode.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
LineDisplay.DisplayText Method
LineDisplay.DisplayText Method
LineDisplay.ClearText Method
InterCharacterWait


LineDisplay.DisplayTextAt Method (Int32, Int32, String)

LineDisplay.DisplayTextAt Method (Int32, Int32, String) |
 | See Also

1/18/2008

Displays the string of characters at the specified row and column.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub DisplayTextAt ( _
    row As Integer, _
    column As Integer, _
    data As String _
)
public abstract void DisplayTextAt (
    int row,
    int column,
    string data
)
public:
virtual void DisplayTextAt (
    int row,
    int column,
    String^ data
) abstract
public abstract void DisplayTextAt (
    int row,
    int column,
    String data
)
public abstract function DisplayTextAt (
    row : int,
    column : int,
    data : String
)

Parameters

row

The start row for the text.

column

The start column for the text.

data

The string of characters to display.

Remarks

The characters in data are processed beginning at the window location that is specified by the row and column parameters, and continuing in succeeding columns.

If the CapBlink property is set to NoBlink, all blink escape sequences will be filtered out for display. If the CapReverse property is set to None, all reverse escape sequences will be filtered out.

DisplayTextAt has the same effect as setting the CursorRow property to row, setting the CursorColumn property to column, and then calling the DisplayText method.

DisplayTextAt may cause a PosControlException to be thrown with the following ErrorCode.

Value

Meaning

Illegal

One or more of the following conditions has occurred:

  • The value specified for row or for column is out of range.

  • The window is in Marquee On mode, and DisplayTextAt cannot be called while the device is in that mode.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
LineDisplay.DisplayText Method
LineDisplay.DisplayText Method
LineDisplay.ClearText Method
InterCharacterWait


LineDisplay.DisplayTextAt Method (Int32, Int32, String, DisplayTextMode)

LineDisplay.DisplayTextAt Method (Int32, Int32, String, DisplayTextMode) |
 | See Also

1/18/2008

Displays the string of characters at the specified row and column, in the specified display mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub DisplayTextAt ( _
    row As Integer, _
    column As Integer, _
    data As String, _
    attribute As DisplayTextMode _
)
public abstract void DisplayTextAt (
    int row,
    int column,
    string data,
    DisplayTextMode attribute
)
public:
virtual void DisplayTextAt (
    int row,
    int column,
    String^ data,
    DisplayTextMode attribute
) abstract
public abstract void DisplayTextAt (
    int row,
    int column,
    String data,
    DisplayTextMode attribute
)
public abstract function DisplayTextAt (
    row : int,
    column : int,
    data : String,
    attribute : DisplayTextMode
)

Parameters

row

The start row for the text.

column

The start column for the text.

data

The string of characters to display.

attribute

The display attribute for the text. Possible values are defined by the DisplayTextMode enumeration. Must be either Normal or Blink.

Remarks

The characters in data are processed beginning at the window location that is specified by the row and column parameters, and continuing in succeeding columns.

If the CapBlink property is set to NoBlink, all blink escape sequences is filtered out for display. If the CapReverse property is set to None, all reverse escape sequences is filtered out.

DisplayTextAt has the same effect as setting the CursorRow property to row, setting the CursorColumn property to column, and then calling the DisplayText method.

DisplayTextAt may cause a PosControlException to be thrown with the following ErrorCode.

Value

Meaning

Illegal

One or more of the following conditions has occurred:

  • The value specified for row or for column is out of range.

  • The value specified for attribute is not found in the DisplayTextMode enumerator.

  • The window is in Marquee On mode, and DisplayTextAt cannot be called while the device is in that mode.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
LineDisplay.DisplayText Method
LineDisplay.DisplayText Method
LineDisplay.ClearText Method
InterCharacterWait


LineDisplay.ReadCharacterAtCursor Method

LineDisplay.ReadCharacterAtCursor Method |
 | See Also

1/18/2008

Reads the currently displayed character at the cursor position.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function ReadCharacterAtCursor As Integer
public abstract int ReadCharacterAtCursor ()
public:
virtual int ReadCharacterAtCursor () abstract
public abstract int ReadCharacterAtCursor ()
public abstract function ReadCharacterAtCursor () : int

Remarks

ReadCharacterAtCursor returns the displayed character if this is successful, and may cause a PosControlException exception to be thrown with the following ErrorCode.

Value | Meaning
Illegal | The CapReadBack property is set to DisplayReadBack.None.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
CapReadBack


LineDisplay.RefreshWindow Method

LineDisplay.RefreshWindow Method |
 | See Also

1/18/2008

Changes the active window to the one specified by the window parameter, then redisplays that window’s viewport.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub RefreshWindow ( _
    window As Integer _
)
public abstract void RefreshWindow (
    int window
)
public:
virtual void RefreshWindow (
    int window
) abstract
public abstract void RefreshWindow (
    int window
)
public abstract function RefreshWindow (
    window : int
)

Parameters

window

Specifies the window to be refreshed.

Remarks

Neither the mapping of the window to its viewport nor the window’s cursor position is changed.

RefreshWindow can be used to restore a window after another window has overwritten some of its viewport.

RefreshWindow may cause a PosControlException to be thrown with the following ErrorCode.

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The specified window is larger than the value of the DeviceWindows property.

  • The window has not been created.

  • The window is in Marquee On mode, and RefreshWindow cannot be called while the device is in this mode.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
DeviceWindows


LineDisplay.ScrollText Method

LineDisplay.ScrollText Method |
 | See Also Example

1/18/2008

Scrolls text in the active window, in the specified direction.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ScrollText ( _
    direction As DisplayScrollText, _
    units As Integer _
)
public abstract void ScrollText (
    DisplayScrollText direction,
    int units
)
public:
virtual void ScrollText (
    DisplayScrollText direction,
    int units
) abstract
public abstract void ScrollText (
    DisplayScrollText direction,
    int units
)
public abstract function ScrollText (
    direction : DisplayScrollText,
    units : int
)

Parameters

direction

Indicates the scrolling direction, as defined by the DisplayScrollText enumeration.

units

Indicates the number of columns or rows to scroll.

Remarks

ScrollText is legal only when the window is in Immediate mode.

If the window size for the scroll direction matches its viewport size, then the window data is scrolled, the last units rows or columns are set to spaces, and the viewport is updated.

If the window size for the scroll direction is larger than its viewport, then the window data is not changed. Instead, the mapping of the window into the viewport is moved in the specified direction. The window data is not altered. However, the viewport is updated. If scrolling by units would go beyond the beginning of the window data, then the window is scrolled so that the first viewport row or column contains the first window row or column. If scrolling by units would go beyond the end of the window data, then the window is scrolled so that the last viewport row or column contains the last window row or column.

ScrollText may cause a PosControlException to be thrown with the following ErrorCode.

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The specified direction was not found in the DisplayScrollText enumerator.

  • The window is not in Immediate mode (that is, the MarqueeType property must be set to None and the InterCharacterWait property must be set to 0 (zero).

Example

Example 1

Assume a 2x20 display.

A Visual Basic application has a line display object named LD.

The application has performed:

Copy Code
LD.CreateWindow(0, 3, 2, 4, 2, 4)  ’ 2x4 viewport of 2x4 window
LD.DisplayText("abcdABCD", Normal)

The window contains:

 | 0 | 1 | 2 | 3
0 | a | b | c | d
1 | A | B | C | D

and the viewport on the display is as follows:

 | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19
0 |  |  |  | a | b | c | d |  |  |  |  |  |  |  |  |  |  |  |  |
1 |  |  |  | A | B | C | D |  |  |  |  |  |  |  |  |  |  |  |  |

If the method

Copy Code
LD.ScrollText (Left, 2)

is called, the window data becomes:

 | 0 | 1 | 2 | 3
0 | c | d |  |
1 | C | D |  |

and the viewport becomes:

 | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19
0 |  |  |  | c | d |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
1 |  |  |  | C | D |  |  |  |  |  |  |  |  |  |  |  |  |  |  |

Example 2

Assume a 2x20 display.

A Visual Basic application has a line display object named LD.

The application has performed:

Copy Code
LD.CreateWindow(0, 3, 2, 4, 2, 8)  ’ 2x4 viewport of 2x8 window
LD.DisplayText("abcdefghABCDEFGH", Normal)

The window contains:

 | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7
0 | a | b | c | d | e | f | g | h
1 | A | B | C | D | E | F | G | H

and the viewport on the display is as follows:

 | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19
0 |  |  |  | a | b | c | d |  |  |  |  |  |  |  |  |  |  |  |  |
1 |  |  |  | A | B | C | D |  |  |  |  |  |  |  |  |  |  |  |  |

If the method

Copy Code
LD.ScrollText (Left, 2)

is called, the window data is unchanged, and the viewport becomes:

 | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19
0 |  |  |  | c | d | e | f |  |  |  |  |  |  |  |  |  |  |  |  |
1 |  |  |  | C | D | E | F |  |  |  |  |  |  |  |  |  |  |  |  |

If the method

Copy Code
LD.ScrollText (Up, 1)

is called next, the window data becomes:

 | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7
0 | A | B | C | D | E | F | G | H
1 |  |  |  |  |  |  |  |

and the viewport becomes:

 | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19
0 |  |  |  | C | D | E | F |  |  |  |  |  |  |  |  |  |  |  |  |
1 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
LineDisplay.DisplayText Method
LineDisplay.DisplayText Method


LineDisplay.SetBitmap Method

LineDisplay.SetBitmap Method |
 | See Also

1/18/2008

Overload List

Name | Description
LineDisplay.SetBitmap (Int32, String, Int32, Int32) | Sets the bitmap number and placement.
LineDisplay.SetBitmap (Int32, String, Int32, Int32, Int32) | Sets the bitmap number, placement, and width.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace


LineDisplay.SetBitmap Method (Int32, String, Int32, Int32)

LineDisplay.SetBitmap Method (Int32, String, Int32, Int32) |
 | See Also

1/18/2008

Sets the bitmap number and placement.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub SetBitmap ( _
    bitmapNumber As Integer, _
    fileName As String, _
    alignmentX As Integer, _
    alignmentY As Integer _
)
public abstract void SetBitmap (
    int bitmapNumber,
    string fileName,
    int alignmentX,
    int alignmentY
)
public:
virtual void SetBitmap (
    int bitmapNumber,
    String^ fileName,
    int alignmentX,
    int alignmentY
) abstract
public abstract void SetBitmap (
    int bitmapNumber,
    String fileName,
    int alignmentX,
    int alignmentY
)
public abstract function SetBitmap (
    bitmapNumber : int,
    fileName : String,
    alignmentX : int,
    alignmentY : int
)

Parameters

bitmapNumber

The number to be assigned to this bitmap. Valid bitmap numbers are 1 through 100.

fileName

The file name or URL of the bitmap file. Various file formats may be supported, such as BMP, GIF, or JPEG. If fileName is set to an empty string (""), then the bitmap is unset.

alignmentX

The horizontal placement of the bitmap. For possible values, see Remarks.

alignmentY

The vertical placement of the bitmap. For possible values, see Remarks.

Remarks

The alignmentX parameter has one of the following values:

Value | Meaning
DisplayBitmapLeft | Align the bitmap’s left edge with the leftmost pixel of the current character position.
DisplayBitmapCenter | Align the bitmap in the horizontal center of the current character position.
DisplayBitmapRight | Align the bitmap’s right edge with the rightmost pixel of the current character position.
Other values | Distance from the window’s leftmost pixel column to the left edge of the bitmap, expressed in number of pixels.

The alignmentY parameter has one of the following values:

Value | Meaning
DisplayBitmapTop | Align the bitmap’s top edge with the topmost pixel of the current character position.
DisplayBitmapCenter | Align the bitmap in the vertical center of the current character position.
DisplayBitmapBottom | Align the bitmap’s bottom edge with the bottommost pixel of the current character position.
Other values | Distance from the window’s topmost pixel row to the start of the bitmap, expressed in number of pixels.

Called to save information about a bitmap for later display. The bitmap may then be displayed by calling the DisplayText or DisplayTextAt methods with the display bitmap escape sequences in the display data. The display bitmap escape sequence will typically be included in a string for displaying advertisements, store logos, or icons. See the "Remarks" section of the DisplayBitmap method for restrictions on displaying the saved bitmap. If one or more restrictions are not fulfilled, then the bitmap is not displayed, and the method continues on with the next character of display data.

A service object may choose to cache the bitmap for later use to provide better performance. Regardless, the bitmap file and parameters are validated for correctness by this method.

The most frequently used bitmaps should be assigned a small bitmapNumber (close to 1), while occasionally used bitmaps should be assigned the larger bitmapNumbers. The service object will use this information to determine how best to store the bitmaps. It may download them to the device when it is possible, or cache them in service object memory, or remember the fileName and associated properties for use when it is displayed.

An application must make sure that the LineDisplay window metrics, such as viewport width and height, are set before it calls this method. A service object may perform transformations on the bitmap in preparation for later displaying based on the current values of these metrics.

SetBitmap may cause a PosControlException to be thrown with the following ErrorCode.

Value

Meaning

Illegal

One of the following errors occurred:

  • The bitmapNumber parameter is invalid.

  • The Line Display device does not support bitmap display (the CapBitmap property is set to false.

  • The alignmentX/alignmentY parameters are invalid or too big.

NoExist

The specified fileName was not found.

Extended

ErrorCodeExtended = ExtendedErrorTooBig: The bitmap is either too wide to display without transformation, or it is too big to transform.

ErrorCodeExtended = ExtendedErrorBadFormat: The specified file is either not a bitmap file or it is in an unsupported format.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace


LineDisplay.SetBitmap Method (Int32, String, Int32, Int32, Int32)

LineDisplay.SetBitmap Method (Int32, String, Int32, Int32, Int32) |
 | See Also

1/18/2008

Sets the bitmap number, placement, and width.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub SetBitmap ( _
    bitmapNumber As Integer, _
    fileName As String, _
    width As Integer, _
    alignmentX As Integer, _
    alignmentY As Integer _
)
public abstract void SetBitmap (
    int bitmapNumber,
    string fileName,
    int width,
    int alignmentX,
    int alignmentY
)
public:
virtual void SetBitmap (
    int bitmapNumber,
    String^ fileName,
    int width,
    int alignmentX,
    int alignmentY
) abstract
public abstract void SetBitmap (
    int bitmapNumber,
    String fileName,
    int width,
    int alignmentX,
    int alignmentY
)
public abstract function SetBitmap (
    bitmapNumber : int,
    fileName : String,
    width : int,
    alignmentX : int,
    alignmentY : int
)

Parameters

bitmapNumber

The number to be assigned to this bitmap. Valid bitmap numbers are 1 through 100.

fileName

The file name or URL of the bitmap file. Various file formats may be supported, such as BMP, GIF, or JPEG. If fileName is set to an empty string (""), then the bitmap is unset.

width

The width of the bitmap to be displayed. See values here.

alignmentX

The horizontal placement of the bitmap. For possible values, see Remarks.

alignmentY

The vertical placement of the bitmap. For possible values, see Remarks.

Remarks

The width parameter has one of the following values:

Value | Meaning
DisplayBitmapAsIs | Display the bitmap with one bitmap pixel per dot.
Other values | Bitmap width is expressed in number of pixels.

The alignmentX parameter has one of the following values:

Value | Meaning
DisplayBitmapLeft | Align the bitmap’s left edge with the leftmost pixel of the current character position.
DisplayBitmapCenter | Align the bitmap in the horizontal center of the current character position.
DisplayBitmapRight | Align the bitmap’s right edge with the rightmost pixel of the current character position.
Other values | Distance from the window’s leftmost pixel column to the left edge of the bitmap, expressed in number of pixels.

The alignmentY parameter has one of the following values:

Value | Meaning
DisplayBitmapTop | Align the bitmap’s top edge with the topmost pixel of the current character position.
DisplayBitmapCenter | Align the bitmap in the vertical center of the current character position.
DisplayBitmapBottom | Align the bitmap’s bottom edge with the bottommost pixel of the current character position.
Other values | Distance from the window’s topmost pixel row to the start of the bitmap, expressed in number of pixels.

Called to save information about a bitmap for later display. The bitmap may then be displayed by calling the DisplayText or DisplayTextAt methods with the display bitmap escape sequences in the display data. The display bitmap escape sequence will typically be included in a string for displaying advertisements, store logos, or icons. See the "Remarks" section of the DisplayBitmap method for restrictions on displaying the saved bitmap. If one or more restrictions are not fulfilled, then the bitmap is not displayed, and the method continues on with the next character of display data.

A service object may choose to cache the bitmap for later use to provide better performance. Regardless, the bitmap file and parameters are validated for correctness by this method.

The most frequently used bitmaps should be assigned a small bitmapNumber (close to 1), while occasionally used bitmaps should be assigned the larger bitmapNumbers. The service object will use this information to determine how best to store the bitmaps. It may download them to the device when it is possible, or cache them in service object memory, or remember the fileName and associated properties for use when it is displayed.

An application must make sure that the LineDisplay window metrics, such as viewport width and height, are set before it calls this method. A service object may perform transformations on the bitmap in preparation for later displaying based on the current values of these metrics.

SetBitmap may cause a PosControlException to be thrown with the following ErrorCode.

Value

Meaning

Illegal

One of the following errors occurred:

  • The bitmapNumber parameter is invalid.

  • The Line Display device does not support bitmap display (the CapBitmap property is set to false.

  • The width parameter is invalid or too big.

  • The alignmentX/alignmentY parameters are invalid or too big.

NoExist

The specified fileName was not found.

Extended

ErrorCodeExtended = ExtendedErrorTooBig: The bitmap is either too wide to display without transformation, or it is too big to transform.

ErrorCodeExtended = ExtendedErrorBadFormat: The specified file is either not a bitmap file or it is in an unsupported format.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace


LineDisplay.SetDescriptor Method

LineDisplay.SetDescriptor Method |
 | See Also

1/18/2008

Sets the state of a descriptor.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub SetDescriptor ( _
    descriptor As Integer, _
    attribute As DisplaySetDescriptor _
)
public abstract void SetDescriptor (
    int descriptor,
    DisplaySetDescriptor attribute
)
public:
virtual void SetDescriptor (
    int descriptor,
    DisplaySetDescriptor attribute
) abstract
public abstract void SetDescriptor (
    int descriptor,
    DisplaySetDescriptor attribute
)
public abstract function SetDescriptor (
    descriptor : int,
    attribute : DisplaySetDescriptor
)

Parameters

descriptor

Indicates which descriptor to change. The value can range between zero and one less than the value of the DeviceDescriptors property.

attribute

Indicates the attribute for the descriptor. Possible values are defined by the DisplaySetDescriptor enumeration.

Remarks

Sets the state of one of the descriptors that are small indicators with a fixed label.

If the CapDescriptors property is set to false, SetDescriptor throws an Illegal exception.

The Line Display service object determines the mapping of descriptor to its descriptors.

SetDescriptor may cause a PosControlException to be thrown with the following ErrorCode.

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The Line Display device does not support descriptors—that is, the CapDescriptors property is set to false.

  • The value specified for descriptor is either less than zero or greater than the value of the DeviceDescriptors.

  • The value specified for attribute was not found in the DisplaySetDescriptor enumerator.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
LineDisplay.ClearDescriptors Method
CapDescriptors
DeviceDescriptors


LineDisplay Properties

LineDisplay Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
BlinkRate | Gets or sets the blink cycle in milliseconds.
CapBitmap | Gets the Boolean value that indicates whether the display of bitmaps is supported.
CapBlink | Gets the character blink capability of the Line Display device.
CapBlinkRate | Gets the Boolean value that indicates whether the blink rate of the device can be controlled.
CapBrightness | Gets the Boolean value that indicates whether brightness can be controlled.
CapCharacterSet | Gets the default character set capability of the Line Display device.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapCursorType | Gets a bitwise indication of the cursor types supported by the Line Display device, selectable through the CursorType property.
CapCustomGlyph | Gets the Boolean value that indicates whether the device support custom glyph definition.
CapDescriptors | Gets the Boolean value that indicates whether the device supports descriptors.
CapHMarquee | Gets the Boolean value that indicates whether the device supports horizontal marquee windows.
CapICharWait | Gets the Boolean value that indicates whether the device supports inter-character wait.
CapMapCharacterSet | Gets the Boolean value that indicates whether the service object can map the characters provided by the application to the character sets defined in the CharacterSetList property when displaying data.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapReadBack | Gets the capability of the Line Display device to read back the data displayed on it.
CapReverse | Gets the reverse video capability of the Line Display device.
CapScreenMode | Gets the Boolean value that indicates whether the Line Display device supports changing the screen mode; that is, the number of text rows and columns.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CapVMarquee | Gets the Boolean value that indicates whether the device supports vertical marquee windows.
CharacterSet | Gets or sets the character set for displaying characters.
CharacterSetList | Gets a string of character set numbers.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Columns | Gets the number of columns for this window.
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
CurrentWindow | Gets or sets the active window to which text is displayed.
CursorColumn | Gets or sets the column in the active window to which the next displayed character will be output.
CursorRow | Gets or sets the row in the active window to which the next displayed character is written.
CursorType | Gets or sets the cursor type for the active window. Possible values are defined by the DisplayCursors enumeration.
CursorUpdate | Gets or sets the Boolean value that indicates whether characters are updated.
CustomGlyphList | Gets an array of instances of the RangeOfCharacters helper class, which represents the character code ranges that are available for defining glyphs.
DeviceBrightness | Gets or sets the device brightness value, expressed as a percentage between 0 and 100.
DeviceColumns | Gets the number of columns on this device.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceDescriptors | Gets the number of descriptors on this device.
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
DeviceRows | Gets the number of rows on this device.
DeviceWindows | Gets the maximum number of windows that the Line Display device supports.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
GlyphHeight | Gets the glyph height based on the number of pixels for a character cell.
GlyphWidth | Gets the glyph width based on the number of pixels for a character cell.
InterCharacterWait | Gets or sets the wait time, specified in milliseconds, between the display of each character with the DisplayText and DisplayTextAt methods.
MapCharacterSet | Gets or sets the Boolean value that indicates whether the Line Display device supports mapping character sets.
MarqueeFormat | Gets or sets the marquee format for the active window.
MarqueeRepeatWait | Gets or sets the wait time, specified in milliseconds, between scrolling the final character or row of the window into its viewport and restarting the marquee with the first or last character or row.
MarqueeType | Gets or sets the marquee type for the active window.
MarqueeUnitWait | Gets or sets the wait time, specified in milliseconds, between marquee scrolling of each column or row in the window.
MaximumX | Gets the maximum number of horizontal pixels that the device supports
MaximumY | Gets the maximum number of vertical pixels that the device supports.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
Rows | Gets the number of rows for this window.
ScreenMode | Gets or sets the screen mode value of the device.
ScreenModeList | Gets the array of DisplayScreenMode class instances that are supported by the device.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets the Boolean value that indicates whether the Line Display device is an exclusive-use device.

See Also

Reference

LineDisplay Class
Microsoft.PointOfService Namespace


LineDisplay.BlinkRate Property

LineDisplay.BlinkRate Property |
 | See Also

1/18/2008

Gets or sets the blink cycle in milliseconds.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property BlinkRate As Integer
public abstract int BlinkRate { get; set; }
public:
virtual property int BlinkRate {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_BlinkRate ()

/** @property */
public abstract void set_BlinkRate (int value)

public abstract function get BlinkRate () : int

public abstract function set BlinkRate (value : int)

Remarks

A blink cycle is the time when text completes an on-off-on cycle during blinking. After BlinkRate is set, the service object sets the blink rate to the closest supported rate and change BlinkRate to reflect the actual rate. Performing this approximation is necessary because blink cycles are hardware-dependent and probably not controllable at precise milliseconds.

BlinkRate is typically initialized to 0 (zero).

Accessing BlinkRate may cause a PosControlException to be thrown with the following ErrorCode.

Value | Meaning
Illegal | BlinkRate has been set to a value less than zero, or BlinkRate has been set to a valid value, but the CapBlinkRate property is set to false. This indicates that the device does not support blinking.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
CapBlinkRate


LineDisplay.CapBitmap Property

LineDisplay.CapBitmap Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the display of bitmaps is supported.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapBitmap As Boolean
public abstract bool CapBitmap { get; }
public:
virtual property bool CapBitmap {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapBitmap ()

public abstract function get CapBitmap () : boolean

Remarks

If true, the display of bitmaps is supported.

CapBitmap is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace


LineDisplay.CapBlink Property

LineDisplay.CapBlink Property |
 | See Also

1/18/2008

Gets the character blink capability of the Line Display device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapBlink As DisplayBlink
public abstract DisplayBlink CapBlink { get; }
public:
virtual property DisplayBlink CapBlink {
    DisplayBlink get () abstract;
}
/** @property */
public abstract DisplayBlink get_CapBlink ()

public abstract function get CapBlink () : DisplayBlink

Remarks

Possible values are defined by the DisplayBlink enumeration. Valid values are as follows:

Value | Meaning
None | The Line Display device does not support blinking. The value is 0.
All | The Line Display supports blinking for the display. The service object sets the contents of the display to blink or to be in a steady state.
Each | The Line Display supports blinking for each character. The service object can set each character to blink individually or to be in a steady state.

CapBlink is typically set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
DisplayBlink Enumeration


LineDisplay.CapBlinkRate Property

LineDisplay.CapBlinkRate Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the blink rate of the device can be controlled.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapBlinkRate As Boolean
public abstract bool CapBlinkRate { get; }
public:
virtual property bool CapBlinkRate {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapBlinkRate ()

public abstract function get CapBlinkRate () : boolean

Remarks

If true, the device’s blink rate can be controlled, and the application uses the BlinkRate property to indicate the rate at which the display blinks.

CapBlinkRate is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
LineDisplay.BlinkRate Property


LineDisplay.CapBrightness Property

LineDisplay.CapBrightness Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether brightness can be controlled.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapBrightness As Boolean
public abstract bool CapBrightness { get; }
public:
virtual property bool CapBrightness {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapBrightness ()

public abstract function get CapBrightness () : boolean

Remarks

If true, brightness control is supported.

CapBrightness is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace


LineDisplay.CapCharacterSet Property

LineDisplay.CapCharacterSet Property |
 | See Also

1/18/2008

Gets the default character set capability of the Line Display device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapCharacterSet As CharacterSetCapability
public abstract CharacterSetCapability CapCharacterSet { get; }
public:
virtual property CharacterSetCapability CapCharacterSet {
    CharacterSetCapability get () abstract;
}
/** @property */
public abstract CharacterSetCapability get_CapCharacterSet ()

public abstract function get CapCharacterSet () : CharacterSetCapability

Remarks

Possible values are defined by the CharacterSetCapability enumeration.

The default character set can contain a superset of these ranges. The CharacterSet property can contain additional character set information.

CapCharacterSet is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
CharacterSet
CapCharacterSet


LineDisplay.CapCursorType Property

LineDisplay.CapCursorType Property |
 | See Also

1/18/2008

Gets a bitwise indication of the cursor types supported by the Line Display device, selectable through the CursorType property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapCursorType As DisplayCursors
public abstract DisplayCursors CapCursorType { get; }
public:
virtual property DisplayCursors CapCursorType {
    DisplayCursors get () abstract;
}
/** @property */
public abstract DisplayCursors get_CapCursorType ()

public abstract function get CapCursorType () : DisplayCursors

Remarks

Possible values are defined by the DisplayCursors enumeration.

If CapCursorType is set to None, then none of the other values are set.

If CapCursorType is set to Fixed, then DisplayCursors.Blink may also be set, plus exactly one of the other values. This other value indicates the cursor type that is always displayed.

CapCursorType is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
DisplayCursors Enumeration
CursorType


LineDisplay.CapCustomGlyph Property

LineDisplay.CapCustomGlyph Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the device support custom glyph definition.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapCustomGlyph As Boolean
public abstract bool CapCustomGlyph { get; }
public:
virtual property bool CapCustomGlyph {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapCustomGlyph ()

public abstract function get CapCustomGlyph () : boolean

Remarks

If true, the device supports custom glyph definition.

CapCustomGlyph is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace


LineDisplay.CapDescriptors Property

LineDisplay.CapDescriptors Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the device supports descriptors.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapDescriptors As Boolean
public abstract bool CapDescriptors { get; }
public:
virtual property bool CapDescriptors {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapDescriptors ()

public abstract function get CapDescriptors () : boolean

Remarks

If true, the device supports descriptors.

CapDescriptors is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace


LineDisplay.CapHMarquee Property

LineDisplay.CapHMarquee Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the device supports horizontal marquee windows.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapHMarquee As Boolean
public abstract bool CapHMarquee { get; }
public:
virtual property bool CapHMarquee {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapHMarquee ()

public abstract function get CapHMarquee () : boolean

Remarks

If true, the device supports horizontal marquee windows.

CapHMarquee is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace


LineDisplay.CapICharWait Property

LineDisplay.CapICharWait Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the device supports inter-character wait.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapICharWait As Boolean
public abstract bool CapICharWait { get; }
public:
virtual property bool CapICharWait {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapICharWait ()

public abstract function get CapICharWait () : boolean

Remarks

If true, the device supports inter-character wait.

CapICharWait is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace


LineDisplay.CapMapCharacterSet Property

LineDisplay.CapMapCharacterSet Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the service object can map the characters provided by the application to the character sets defined in the CharacterSetList property when displaying data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapMapCharacterSet As Boolean
public abstract bool CapMapCharacterSet { get; }
public:
virtual property bool CapMapCharacterSet {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapMapCharacterSet ()

public abstract function get CapMapCharacterSet () : boolean

Remarks

If true, then the service object can map the characters provided by the application to the character sets defined in the CharacterSetList property when displaying data.

CapMapCharacterSet is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace


LineDisplay.CapReadBack Property

LineDisplay.CapReadBack Property |
 | See Also

1/18/2008

Gets the capability of the Line Display device to read back the data displayed on it.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapReadBack As DisplayReadBack
public abstract DisplayReadBack CapReadBack { get; }
public:
virtual property DisplayReadBack CapReadBack {
    DisplayReadBack get () abstract;
}
/** @property */
public abstract DisplayReadBack get_CapReadBack ()

public abstract function get CapReadBack () : DisplayReadBack

Remarks

Possible values are defined by the DisplayReadBack enumeration.

CapReadBack is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
DisplayReadBack Enumeration


LineDisplay.CapReverse Property

LineDisplay.CapReverse Property |
 | See Also

1/18/2008

Gets the reverse video capability of the Line Display device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapReverse As DisplayReverse
public abstract DisplayReverse CapReverse { get; }
public:
virtual property DisplayReverse CapReverse {
    DisplayReverse get () abstract;
}
/** @property */
public abstract DisplayReverse get_CapReverse ()

public abstract function get CapReverse () : DisplayReverse

Remarks

Possible values are defined by the DisplayReverse enumeration.

CapReverse is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
DisplayReverse Enumeration


LineDisplay.CapScreenMode Property

LineDisplay.CapScreenMode Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the Line Display device supports changing the screen mode; that is, the number of text rows and columns.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapScreenMode As Boolean
public abstract bool CapScreenMode { get; }
public:
virtual property bool CapScreenMode {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapScreenMode ()

public abstract function get CapScreenMode () : boolean

Remarks

If true, the Line Display device supports changing the screen mode (that is, the number of text rows and columns).

CapScreenMode is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace


LineDisplay.CapVMarquee Property

LineDisplay.CapVMarquee Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the device supports vertical marquee windows.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapVMarquee As Boolean
public abstract bool CapVMarquee { get; }
public:
virtual property bool CapVMarquee {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapVMarquee ()

public abstract function get CapVMarquee () : boolean

Remarks

If true, the device supports vertical marquee windows.

CapVMarquee is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace


LineDisplay.CharacterSet Property

LineDisplay.CharacterSet Property |
 | See Also

1/18/2008

Gets or sets the character set for displaying characters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property CharacterSet As Integer
public abstract int CharacterSet { get; set; }
public:
virtual property int CharacterSet {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_CharacterSet ()

/** @property */
public abstract void set_CharacterSet (int value)

public abstract function get CharacterSet () : int

public abstract function set CharacterSet (value : int)

Remarks

CharacterSet may be one of the following ranges or values.

Value | Meaning
Range 101 - 199 | A device-specific character set that does not match a code page or the ASCII or Windows ANSI character sets.
Range 400 - 990 | Code page; matches one of the standard values.
CharacterSetUnicode | The character set supports Unicode. The value of this constant is 997.
CharacterSetAscii | The ASCII character set, supporting the ASCII characters between 0x20 and 0x7F. The value of this constant is 998.
CharacterSetAnsi | The Windows ANSI character set. The value of this constant is 999. This is exactly equal to the Windows code page 1252.
Range 1000 and higher | Windows code page; matches one of the standard values.

CharacterSet is typically initialized to zero (0). This value is guaranteed to support at least the set of characters specified by the CapCharacterSet property.

Accessing CharacterSet may cause a PosControlException to be thrown with the following ErrorCode.

Value | Meaning
Illegal | CharacterSet has been set to a value that does not exist in the character sets listed for the CharacterSetList property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
CharacterSetList
LineDisplay.CapCharacterSet Property


LineDisplay.CharacterSetList Property

LineDisplay.CharacterSetList Property |
 | See Also

1/18/2008

Gets a string of character set numbers.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CharacterSetList As Integer()
public abstract int[] CharacterSetList { get; }
public:
virtual property array<int>^ CharacterSetList {
    array<int>^ get () abstract;
}
/** @property */
public abstract int[] get_CharacterSetList ()

public abstract function get CharacterSetList () : int[]

Remarks

The string consists of ASCII numeric set numbers separated by commas. For example, if the string is "101,850,999", then the device supports a device-specific character set, code page 850, and the Windows ANSI character set.

CharacterSetList is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
LineDisplay.CharacterSet Property


LineDisplay.Columns Property

LineDisplay.Columns Property |
 | See Also

1/18/2008

Gets the number of columns for this window.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property Columns As Integer
public abstract int Columns { get; }
public:
virtual property int Columns {
    int get () abstract;
}
/** @property */
public abstract int get_Columns ()

public abstract function get Columns () : int

Remarks

For window 0, Columns is the same as the value of the DeviceColumns property. For other windows created by the application, it can be less or greater than DeviceColumns.

Columns is typically initialized to the value of the DeviceColumns property. The Columns property is updated when the application sets the CurrentWindow property and calls the CreateWindow or DestroyWindow methods.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
DeviceColumns
CurrentWindow
LineDisplay.CreateWindow Method
LineDisplay.DestroyWindow Method


LineDisplay.CurrentWindow Property

LineDisplay.CurrentWindow Property |
 | See Also

1/18/2008

Gets or sets the active window to which text is displayed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property CurrentWindow As Integer
public abstract int CurrentWindow { get; set; }
public:
virtual property int CurrentWindow {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_CurrentWindow ()

/** @property */
public abstract void set_CurrentWindow (int value)

public abstract function get CurrentWindow () : int

public abstract function set CurrentWindow (value : int)

Remarks

Several properties are associated with each window: Rows, Columns, CursorRow, CursorColumn, CursorUpdate, CursorType, MarqueeFormat, MarqueeType, MarqueeUnitWait, MarqueeRepeatWait, and InterCharacterWait.

When the application sets CurrentWindow, it changes the active window (for display) and sets the associated properties to their values for this window.

Setting a window does not update its viewport. If this window and another window’s viewports overlap, and the other window has changed the viewport, then the application can call the RefreshWindow method to restore this window’s viewport contents.

CurrentWindow is typically initialized to 0, the device window. CurrentWindow is updated when the application calls the CreateWindow or DestroyWindow methods.

Accessing CurrentWindow may cause a PosControlException to be thrown with the following ErrorCode.

Value | Meaning
Illegal | CurrentWindow has been set to a value that is not valid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
Rows
LineDisplay.Columns Property
CursorRow
CursorColumn
CursorUpdate
CursorType
MarqueeFormat
MarqueeType
MarqueeUnitWait
MarqueeRepeatWait
InterCharacterWait
LineDisplay.CreateWindow Method
LineDisplay.DestroyWindow Method
LineDisplay.RefreshWindow Method


LineDisplay.CursorColumn Property

LineDisplay.CursorColumn Property |
 | See Also

1/18/2008

Gets or sets the column in the active window to which the next displayed character will be output.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property CursorColumn As Integer
public abstract int CursorColumn { get; set; }
public:
virtual property int CursorColumn {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_CursorColumn ()

/** @property */
public abstract void set_CursorColumn (int value)

public abstract function get CursorColumn () : int

public abstract function set CursorColumn (value : int)

Remarks

Legal values range from zero through the value of the Columns property. (See the DisplayText method for a note on the interpretation of CursorColumn = Columns.)

The Open and CreateWindow methods initialize CursorColumn to 0 (zero), and it is updated when the application sets the CurrentWindow property or calls the ClearText, DisplayTextAt, or DestroyWindow methods. CursorColumn is also updated when the application calls the DisplayText method, if the CursorUpdate property is set to true.

Accessing CursorColumn may cause a PosControlException to be thrown with the following ErrorCode.

Value | Meaning
Illegal | CursorColumn was set to a value that is not valid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
CursorRow
CursorUpdate
LineDisplay.CreateWindow Method
LineDisplay.DestroyWindow Method
LineDisplay.RefreshWindow Method
LineDisplay.ClearText Method
LineDisplay.CurrentWindow Property


LineDisplay.CursorRow Property

LineDisplay.CursorRow Property |
 | See Also

1/18/2008

Gets or sets the row in the active window to which the next displayed character is written.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property CursorRow As Integer
public abstract int CursorRow { get; set; }
public:
virtual property int CursorRow {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_CursorRow ()

/** @property */
public abstract void set_CursorRow (int value)

public abstract function get CursorRow () : int

public abstract function set CursorRow (value : int)

Remarks

Legal values range from (zero) through the value of the Rows property, minus 1.

The Open and CreateWindow methods initialize CursorRow to 0 (zero), and it is updated when the application sets the CurrentWindow property or calls the ClearText, DisplayTextAt, or DestroyWindow methods. CursorRow is also updated when the application calls the DisplayText method, if the CursorUpdate property is set to true.

Accessing CursorRow may cause a PosControlException to be thrown with the following ErrorCode.

Value | Meaning
Illegal | CursorRow was set to a value that is not valid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
LineDisplay.CursorColumn Property
LineDisplay.ClearText Method
LineDisplay.CreateWindow Method
LineDisplay.DestroyWindow Method


LineDisplay.CursorType Property

LineDisplay.CursorType Property |
 | See Also

1/18/2008

Gets or sets the cursor type for the active window. Possible values are defined by the DisplayCursors enumeration.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property CursorType As DisplayCursors
public abstract DisplayCursors CursorType { get; set; }
public:
virtual property DisplayCursors CursorType {
    DisplayCursors get () abstract;
    void set (DisplayCursors value) abstract;
}
/** @property */
public abstract DisplayCursors get_CursorType ()

/** @property */
public abstract void set_CursorType (DisplayCursors value)

public abstract function get CursorType () : DisplayCursors

public abstract function set CursorType (value : DisplayCursors)

Remarks

CursorType cannot be set if the CapCursorType property is set to either None or Fixed. Otherwise, CursorType can be set to one of the cursor types that are specified by CapCursorType. If supported, the setting of Blink can be logically combined with that cursor type to display a blinking cursor.

CursorType is maintained for each window. Setting CursorType affects only the active window, because only the active window has a displayable cursor.

The Open and CreateWindow methods initialize CursorType to None, or if CapCursorType is set to Fixed, the appropriate cursor type. CursorType is updated when the CurrentWindow property is set or the DestroyWindow method is called.

Accessing CursorType may cause a PosControlException to be thrown with the following ErrorCode.

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The CapCursorType property is set to either None or Fixed. Therefore, CursorType should not be set.

  • CursorType was set to a value other than None but does not match the setting for CapCursorType.

  • CursorType was set to Blink, but blinking is not supported.

  • CursorType was set to a value other than Blink which is not defined in the DisplayCursors enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
LineDisplay.CapCursorType Property
DisplayCursors Enumeration


LineDisplay.CursorUpdate Property

LineDisplay.CursorUpdate Property |
 | See Also

1/18/2008

Gets or sets the Boolean value that indicates whether characters are updated.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property CursorUpdate As Boolean
public abstract bool CursorUpdate { get; set; }
public:
virtual property bool CursorUpdate {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_CursorUpdate ()

/** @property */
public abstract void set_CursorUpdate (boolean value)

public abstract function get CursorUpdate () : boolean

public abstract function set CursorUpdate (value : boolean)

Remarks

If true, when characters are displayed by using the DisplayText and DisplayTextAt methods, then the CursorRow and CursorColumn properties will be updated to point to the character beyond the last character output.

CursorUpdate is set and maintained for each window. It is initialized to true by the Open and CreateWindow methods, then updated when the CurrentWindow property is set or the DestroyWindow method is called.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
LineDisplay.CursorRow Property
LineDisplay.CursorColumn Property
LineDisplay.CurrentWindow Property
LineDisplay.CreateWindow Method
LineDisplay.DestroyWindow Method


LineDisplay.CustomGlyphList Property

LineDisplay.CustomGlyphList Property |
 | See Also

1/18/2008

Gets an array of instances of the RangeOfCharacters helper class, which represents the character code ranges that are available for defining glyphs.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CustomGlyphList As RangeOfCharacters()
public abstract RangeOfCharacters[] CustomGlyphList { get; }
public:
virtual property array<RangeOfCharacters^>^ CustomGlyphList {
    array<RangeOfCharacters^>^ get () abstract;
}
/** @property */
public abstract RangeOfCharacters[] get_CustomGlyphList ()

public abstract function get CustomGlyphList () : RangeOfCharacters[]

Remarks

An instance in the array can contain one character, or a range of characters. Character codes are represented as 2-digit ASCII or 4-digit Unicode hexadecimal values. Each value can actually represent a range of values specified by using To and From properties of the RangeOfCharacters class.

For example, if the From property is set to "2D," and the To property to "4D," then the device supports glyph definitions for the characters "-" and "M," respectively. If the range is "002D" to "004D", then the device supports glyph definitions for the Unicode characters between 002D and 004D inclusive. Also, if the array contains two instances, or ranges, "2D and 2F", and "3D and 3F", then the device supports glyph definitions for the ranges of hexadecimal characters 2D through 2F and 3D through 3F.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
LineDisplay.CapCustomGlyph Property
GlyphHeight
GlyphWidth
LineDisplay.DefineGlyph Method
RangeOfCharacters


LineDisplay.DeviceBrightness Property

LineDisplay.DeviceBrightness Property |
 | See Also

1/18/2008

Gets or sets the device brightness value, expressed as a percentage between 0 and 100.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property DeviceBrightness As Integer
public abstract int DeviceBrightness { get; set; }
public:
virtual property int DeviceBrightness {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_DeviceBrightness ()

/** @property */
public abstract void set_DeviceBrightness (int value)

public abstract function get DeviceBrightness () : int

public abstract function set DeviceBrightness (value : int)

Remarks

Any device can support 0 percent (blank) and 100 percent (full intensity). The service object can also support blanking by sending spaces to the device. If the CapBrightness property is set to true, then the device also supports one or more levels of dimming.

If the Line Display device does not support the brightness value specified by the application, then the service object will choose an appropriate substitute.

DeviceBrightness is typically initialized to 100.

Accessing DeviceBrightness may cause a PosControlException exception to be thrown with the following ErrorCode:

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The CapBrightness property is set to false. This indicates the device does not support the setting of brightness values, but DeviceBrightness was set to a value other than 100.

  • DeviceBrightness was set to a value less than 0 (zero) or greater than 100.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
LineDisplay.CapBrightness Property


LineDisplay.DeviceColumns Property

LineDisplay.DeviceColumns Property |
 | See Also

1/18/2008

Gets the number of columns on this device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DeviceColumns As Integer
public abstract int DeviceColumns { get; }
public:
virtual property int DeviceColumns {
    int get () abstract;
}
/** @property */
public abstract int get_DeviceColumns ()

public abstract function get DeviceColumns () : int

Remarks

DeviceColumns is set by the service object, based on the capabilities of the device, then updated when the ScreenMode property is changed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
DeviceRows


LineDisplay.DeviceDescriptors Property

LineDisplay.DeviceDescriptors Property |
 | See Also

1/18/2008

Gets the number of descriptors on this device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DeviceDescriptors As Integer
public abstract int DeviceDescriptors { get; }
public:
virtual property int DeviceDescriptors {
    int get () abstract;
}
/** @property */
public abstract int get_DeviceDescriptors ()

public abstract function get DeviceDescriptors () : int

Remarks

If the CapDescriptors property is set to true, then the DeviceDescriptors property is nonzero.

DeviceDescriptors is typically initialized to 0 (zero).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
LineDisplay.CapDescriptors Property
LineDisplay.SetDescriptor Method
LineDisplay.ClearDescriptors Method


LineDisplay.DeviceRows Property

LineDisplay.DeviceRows Property |
 | See Also

1/18/2008

Gets the number of rows on this device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DeviceRows As Integer
public abstract int DeviceRows { get; }
public:
virtual property int DeviceRows {
    int get () abstract;
}
/** @property */
public abstract int get_DeviceRows ()

public abstract function get DeviceRows () : int

Remarks

DeviceRows is typically initialized to 0 (zero). The service object updates the DeviceRows property when the ScreenMode property is changed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
LineDisplay.DeviceColumns Property


LineDisplay.DeviceWindows Property

LineDisplay.DeviceWindows Property |
 | See Also

1/18/2008

Gets the maximum number of windows that the Line Display device supports.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DeviceWindows As Integer
public abstract int DeviceWindows { get; }
public:
virtual property int DeviceWindows {
    int get () abstract;
}
/** @property */
public abstract int get_DeviceWindows ()

public abstract function get DeviceWindows () : int

Remarks

A value of zero indicates that only the device window is supported and that no other windows can be created.

DeviceWindows is typically initialized to 0 (zero).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
LineDisplay.CurrentWindow Property


LineDisplay.GlyphHeight Property

LineDisplay.GlyphHeight Property |
 | See Also

1/18/2008

Gets the glyph height based on the number of pixels for a character cell.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property GlyphHeight As Integer
public abstract int GlyphHeight { get; }
public:
virtual property int GlyphHeight {
    int get () abstract;
}
/** @property */
public abstract int get_GlyphHeight ()

public abstract function get GlyphHeight () : int

Remarks

GlyphHeight is typically initialized to 0 (zero).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
LineDisplay.CapCustomGlyph Property
LineDisplay.CustomGlyphList Property
LineDisplay.DefineGlyph Method


LineDisplay.GlyphWidth Property

LineDisplay.GlyphWidth Property |
 | See Also

1/18/2008

Gets the glyph width based on the number of pixels for a character cell.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property GlyphWidth As Integer
public abstract int GlyphWidth { get; }
public:
virtual property int GlyphWidth {
    int get () abstract;
}
/** @property */
public abstract int get_GlyphWidth ()

public abstract function get GlyphWidth () : int

Remarks

The GlyphWidth property is typically initialized to 0 (zero).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
LineDisplay.CapCustomGlyph Property
LineDisplay.CustomGlyphList Property
LineDisplay.DefineGlyph Method


LineDisplay.InterCharacterWait Property

LineDisplay.InterCharacterWait Property |
 | See Also

1/18/2008

Gets or sets the wait time, specified in milliseconds, between the display of each character with the DisplayText and DisplayTextAt methods.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property InterCharacterWait As Integer
public abstract int InterCharacterWait { get; set; }
public:
virtual property int InterCharacterWait {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_InterCharacterWait ()

/** @property */
public abstract void set_InterCharacterWait (int value)

public abstract function get InterCharacterWait () : int

public abstract function set InterCharacterWait (value : int)

Remarks

InterCharacterWait can be used to give a "teletype" appearance when displaying text.

Notice that InterCharacterWait is used only if the service object has set the CapICharWait property to true. This indicates that the Line Display device supports intercharacter wait.

If intercharacter wait is supported, InterCharacterWait is used only if the window is not in Marquee mode; that is, when the application has set the MarqueeType property to None.

When the InterCharacterWait value is not zero and the window is not in Marquee mode, the window is in Teletype mode: DisplayText and DisplayTextAt requests are queued by the service object and processed in the order they are received. InterCharacterWait specifies the time to wait between outputting each character to the viewport. Notice that the system timer resolution can reduce the precision of the wait time.

If the CursorUpdate property is set to true, the CursorRow and CursorColumn properties are updated to their final values by the DisplayText or DisplayTextAt methods before they return, even though all the data are not yet displayed.

When the application sets InterCharacterWait to zero and Marquee Type to None, Immediate mode goes into effect and characters are displayed as quickly as possible. If some display requests are queued by the service object when InterCharacterWait is set to zero, the requests are completed as quickly as possible.

InterCharacterWait is typically initialized to 0 (zero), and it is updated when the application sets the CurrentWindow property or calls the DestroyWindow method.

Accessing InterCharacterWait may cause a PosControlException to be thrown with the following ErrorCode.

Value

Meaning

Illegal

One of the following conditions occurred:

  • InterCharacterWait was set, but the CapICharWait property is set to false. This indicates the device does not support inter-character wait functionality.

  • InterCharacterWait was set to a value less than 0 (zero).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace


LineDisplay.IsExclusiveUseDevice Property

LineDisplay.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the Line Display device is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Property Value

A value of true indicates that the LineDisplay is exclusive-use. Otherwise, the value is false.

Remarks

An exclusive-use device has the following properties:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before accessing some properties or calling methods that update the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace


LineDisplay.MapCharacterSet Property

LineDisplay.MapCharacterSet Property |
 | See Also

1/18/2008

Gets or sets the Boolean value that indicates whether the Line Display device supports mapping character sets.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property MapCharacterSet As Boolean
public abstract bool MapCharacterSet { get; set; }
public:
virtual property bool MapCharacterSet {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_MapCharacterSet ()

/** @property */
public abstract void set_MapCharacterSet (boolean value)

public abstract function get MapCharacterSet () : boolean

public abstract function set MapCharacterSet (value : boolean)

Remarks

If true when outputting data, the service object maps the characters transferred by the application to the character set selected in the CharacterSet property.

If false, no mapping is supported. In such a case, the application has to guarantee the mapping of the character set used in the application to the character set selected in the CharacterSet property.

If CapMapCharacterSet is set to false, then MapCharacterSet is always false.

Accessing MapCharacterSet may cause a PosControlException to be thrown with the following ErrorCode.

Value | Meaning
Illegal | MapCharacterSet was set to true. However, the CapMapCharacterSet property is set to false. This indicates the device does not support character set mapping.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
LineDisplay.CharacterSet Property
LineDisplay.CapMapCharacterSet Property


LineDisplay.MarqueeFormat Property

LineDisplay.MarqueeFormat Property |
 | See Also

1/18/2008

Gets or sets the marquee format for the active window.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property MarqueeFormat As DisplayMarqueeFormat
public abstract DisplayMarqueeFormat MarqueeFormat { get; set; }
public:
virtual property DisplayMarqueeFormat MarqueeFormat {
    DisplayMarqueeFormat get () abstract;
    void set (DisplayMarqueeFormat value) abstract;
}
/** @property */
public abstract DisplayMarqueeFormat get_MarqueeFormat ()

/** @property */
public abstract void set_MarqueeFormat (DisplayMarqueeFormat value)

public abstract function get MarqueeFormat () : DisplayMarqueeFormat

public abstract function set MarqueeFormat (value : DisplayMarqueeFormat)

Remarks

Value | Meaning
Walk | Begin the marquee by 'walking' data from the opposite side. For example, if the marquee type is Left, then the viewport is filled by bringing characters in from the right side and scrolling them to the left.
Place | Begin the marquee by placing data. For example, if the marquee type is Left, then the viewport is filled by putting characters starting at the left side, and beginning scrolling only after the viewport is full.

The Open and CreateWindow methods initialize the value of MarqueeFormat to Walk, and it is updated when the application sets the CurrentWindow property or calls the DestroyWindow method.

MarqueeFormat is read when a transition is made to Marquee On mode. It is not used when it is not in Marquee mode.

When MarqueeFormat is Walk, and a transition is made from Marquee Init mode to Marquee On mode, the following steps occur:

  1. Map the window to the viewport as follows:

    Marquee Type

    Window

    Viewport

    Left

    First Column

    Last Column

    Up

    First Row

    Last Row

    Right

    Last Column

    First Column

    Down

    Last Row

    First Row

    Fill the viewport with blanks. Continue to step 2 without waiting.

  2. Display the mapped part of the window into the viewport, and then wait MarqueeUnitWait milliseconds. Move the window mapping onto the viewport by one row or column in the marquee direction. Repeat the step until the viewport is full.

  3. Refresh the viewport and wait MarqueeUnitWait milliseconds. Move the window mapping by one row or column. Repeat the steps until the last row or column is scrolled into the viewport (in which case, omit the unit wait).

  4. Wait MarqueeRepeatWait milliseconds. Then move to step back to step 1.

When MarqueeFormat is Place, and a transition is made from Marquee Init mode to Marquee On mode, the following steps occur:

  1. Map the window to the viewport as follows:

    Marquee Type

    Window

    Viewport

    Left

    Column

    First Column

    Up

    First Row

    First Row

    Right

    Last Column

    Last Column

    Down

    Last Row

    Last Row

    Fill the viewport with blanks. Continue to step 2 without waiting.

  2. Display a row or column into viewport, and then wait MarqueeUnitWait milliseconds. Repeat the step until the viewport is full.

  3. Move the window mapping onto the viewport by one row or column in the marquee direction, and update the viewport, and then wait MarqueeUnitWait milliseconds. Repeat the step until the last row or column is scrolled into the viewport (in which case, omit the unit wait).

  4. Wait MarqueeRepeatWait milliseconds. Then move to Step back to step 1.

Accessing MarqueeFormat may cause a PosControlException to be thrown with the following ErrorCode.

Value

Meaning

Illegal

One of the following conditions occurred:

  • The value specified for MarqueeFormat is not found in the DisplayMarqueeFormat enumeration.

  • The active window is Window 0—marquee format cannot be changed for Window 0.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
MarqueeType
MarqueeUnitWait
MarqueeRepeatWait


LineDisplay.MarqueeRepeatWait Property

LineDisplay.MarqueeRepeatWait Property |
 | See Also

1/18/2008

Gets or sets the wait time, specified in milliseconds, between scrolling the final character or row of the window into its viewport and restarting the marquee with the first or last character or row.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property MarqueeRepeatWait As Integer
public abstract int MarqueeRepeatWait { get; set; }
public:
virtual property int MarqueeRepeatWait {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_MarqueeRepeatWait ()

/** @property */
public abstract void set_MarqueeRepeatWait (int value)

public abstract function get MarqueeRepeatWait () : int

public abstract function set MarqueeRepeatWait (value : int)

Remarks

Notice that the timer resolution can reduce the precision of the wait time.

The Open and CreateWindow methods initialize MarqueeRepeatWait to zero, and it is updated when the application sets the CurrentWindow property or calls the DestroyWindow method.

MarqueeRepeatWait is not used if the window is not in Marquee mode.

Accessing MarqueeRepeatWait may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The value specified is less than 0 (zero).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
MarqueeType
LineDisplay.MarqueeFormat Property
MarqueeUnitWait
LineDisplay.CreateWindow Method
LineDisplay.CurrentWindow Property
LineDisplay.DestroyWindow Method


LineDisplay.MarqueeType Property

LineDisplay.MarqueeType Property |
 | See Also

1/18/2008

Gets or sets the marquee type for the active window.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property MarqueeType As DisplayMarqueeType
public abstract DisplayMarqueeType MarqueeType { get; set; }
public:
virtual property DisplayMarqueeType MarqueeType {
    DisplayMarqueeType get () abstract;
    void set (DisplayMarqueeType value) abstract;
}
/** @property */
public abstract DisplayMarqueeType get_MarqueeType ()

/** @property */
public abstract void set_MarqueeType (DisplayMarqueeType value)

public abstract function get MarqueeType () : DisplayMarqueeType

public abstract function set MarqueeType (value : DisplayMarqueeType)

Remarks

Possible values are defined by the DisplayMarqueeType enumeration. When it is not set to None, the window is in Marquee mode. Valid values are as follows:

Value | Meaning
None | Marquees are disabled for this window.
Init | Marquee Init mode. Changes to the window are not reflected in the viewport until MarqueeType is changed to another value.
Up | Scroll the window up. Illegal unless Rows is greater than the viewportHeight parameter used for the window’s CreateWindow method, and the service object has set the CapVMarquee property to true.
Down | Scroll the window down. Illegal unless Rows is greater than the viewportHeight parameter used for the window’s CreateWindow method, and the service object has set the CapVMarquee property to true.
Left | Scroll the window left. Illegal unless Columns is greater than the viewportWidth parameter used for the window’s CreateWindow method, and the service object has set the CapHMarquee property to true.
Right | Scroll the window right. Illegal unless Columns is greater than the viewportWidth parameter that is used for the window’s CreateWindow method, and the service object has set the CapHMarquee property to true.

A marquee is typically initialized after entering Marquee Init mode by the application setting MarqueeType to Init, then calling the ClearText and DisplayTextAt methods. Then, when MarqueeType is changed to an "on" value, Marquee On mode is entered, and the marquee begins to be displayed in the viewport beginning at the start of the window (or end if the type is right or down).

When the application changes from Marquee On mode to OFF, the marquee stops in place. A later transition back to Marquee On mode continues from the current position.

When the application changes the mode from Marquee On mode to Marquee Init mode, the marquee stops. The application can modify the window, then return to Marquee On mode to restart the marquee with the new data.

Note:
MarqueeType is always None for window 0 – the device window.

The Open and CreateWindow methods initialize MarqueeType to None, and it is updated when the application sets the CurrentWindow property or calls the DestroyWindow method.

Accessing MarqueeType may cause a PosControlException to be thrown with the following ErrorCode.

Value

Meaning

Illegal

One of the following conditions occurred:

  • The value specified for MarqueeType is not found in the DisplayMarqueeType enumeration.

  • MarqueeType was set to either Up or Down, but the CapVMarquee property is set to false. This indicates that the device does not support vertical marquees.

  • MarqueeType was set to either DisplayMarqueeType.Right or DisplayMarqueeType.Left. But the CapHMarquee property was set to false. This indicates that the device does not support horizontal marquees.

  • The active window is Window 0—the marquee cannot be changed for Window 0.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
LineDisplay.MarqueeFormat Property
MarqueeUnitWait
LineDisplay.MarqueeRepeatWait Property


LineDisplay.MarqueeUnitWait Property

LineDisplay.MarqueeUnitWait Property |
 | See Also

1/18/2008

Gets or sets the wait time, specified in milliseconds, between marquee scrolling of each column or row in the window.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property MarqueeUnitWait As Integer
public abstract int MarqueeUnitWait { get; set; }
public:
virtual property int MarqueeUnitWait {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_MarqueeUnitWait ()

/** @property */
public abstract void set_MarqueeUnitWait (int value)

public abstract function get MarqueeUnitWait () : int

public abstract function set MarqueeUnitWait (value : int)

Remarks

Notice that the timer resolution can reduce the precision of the wait time.

MarqueeUnitWait is not used if MarqueeType is None.

The Open and CreateWindow methods initialize MarqueeUnitWait to zero, and it is updated when the application sets the CurrentWindow property or calls the DestroyWindow method.

Accessing MarqueeUnitWait may cause a PosControlException to be thrown with the following ErrorCode.

Value | Meaning
Illegal | The wait value specified was less than 0 (zero).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
LineDisplay.MarqueeType Property
LineDisplay.MarqueeFormat Property
LineDisplay.MarqueeRepeatWait Property
LineDisplay.CreateWindow Method
LineDisplay.CurrentWindow Property
LineDisplay.DestroyWindow Method


LineDisplay.MaximumX Property

LineDisplay.MaximumX Property |
 | See Also

1/18/2008

Gets the maximum number of horizontal pixels that the device supports

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property MaximumX As Integer
public abstract int MaximumX { get; }
public:
virtual property int MaximumX {
    int get () abstract;
}
/** @property */
public abstract int get_MaximumX ()

public abstract function get MaximumX () : int

Remarks

A value of 0 (zero) indicates that bitmaps are not supported.

Otherwise, MaximumX contains the maximum number of horizontal pixels supported by the device. It must be less than 65,536. Dividing MaximumX by the DeviceColumns property value gives the number of pixels required for each character.

The service object may update the MaximumX property when the ScreenMode property is changed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
LineDisplay.DeviceColumns Property
ScreenMode
MaximumY


LineDisplay.MaximumY Property

LineDisplay.MaximumY Property |
 | See Also

1/18/2008

Gets the maximum number of vertical pixels that the device supports.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property MaximumY As Integer
public abstract int MaximumY { get; }
public:
virtual property int MaximumY {
    int get () abstract;
}
/** @property */
public abstract int get_MaximumY ()

public abstract function get MaximumY () : int

Remarks

A value of zero (0) indicates that bitmaps are not supported

Otherwise, MaximumY contains the maximum number of vertical pixels supported by the device. It must be less than 65, 536. Dividing MaximumY by the value of the DeviceRows property gives the number of pixels required for each character.

The service object may update the MaximumY property when the ScreenMode property is changed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
LineDisplay.DeviceColumns Property
ScreenMode
LineDisplay.MaximumX Property


LineDisplay.Rows Property

LineDisplay.Rows Property |
 | See Also

1/18/2008

Gets the number of rows for this window.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property Rows As Integer
public abstract int Rows { get; }
public:
virtual property int Rows {
    int get () abstract;
}
/** @property */
public abstract int get_Rows ()

public abstract function get Rows () : int

Remarks

For window 0, Rows is the same as the value of the DeviceRows property. For other windows, it can be less or greater than DeviceRows.

When the application calls the Open method, Rows is initialized to the value of DeviceRows. Rows is updated when the application sets the CurrentWindow property or calls the CreateWindow or DestroyWindow methods.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
LineDisplay.DeviceColumns Property
LineDisplay.DeviceRows Property
LineDisplay.CreateWindow Method
LineDisplay.CurrentWindow Property
LineDisplay.DestroyWindow Method


LineDisplay.ScreenMode Property

LineDisplay.ScreenMode Property |
 | See Also

1/18/2008

Gets or sets the screen mode value of the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property ScreenMode As Integer
public abstract int ScreenMode { get; set; }
public:
virtual property int ScreenMode {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_ScreenMode ()

/** @property */
public abstract void set_ScreenMode (int value)

public abstract function get ScreenMode () : int

public abstract function set ScreenMode (value : int)

Remarks

If the CapScreenMode property is set to false, ScreenMode is always set to 0. If CapScreenMode is set to true, then ScreenMode can be set to index the values that are contained in the ScreenModeList property. For example:

0 = Default value;

1 = First setting in ScreenModeList;

2 = Second setting in ScreenModeList

Notice that ScreenMode can only be updated when the device is opened and claimed, but not enabled.

Changing ScreenMode also changes the DeviceColumns and DeviceRows properties to the new screen size. Also, for some devices, the MaximumX and MaximumY properties may be changed because of the columns and rows or because of the columns or rows requiring a different number of physical pixels.

ScreenMode is typically initialized to 0 (zero).

Accessing ScreenMode may cause a PosControlException to be thrown with the following ErrorCode.

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The device is enabled. Screen mode can only be set when the device is opened and claimed, but not enabled.

  • The CapScreenMode property is set to false, that indicates that the device does not support screen mode.

  • The index value specified for ScreenMode is either less than 0 (zero) or greater than the length of the ScreenModeList array.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
LineDisplay.CapScreenMode Property
LineDisplay.DeviceColumns Property
LineDisplay.DeviceRows Property
LineDisplay.MaximumX Property
LineDisplay.MaximumY Property


LineDisplay.ScreenModeList Property

LineDisplay.ScreenModeList Property |
 | See Also

1/18/2008

Gets the array of DisplayScreenMode class instances that are supported by the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ScreenModeList As DisplayScreenMode()
public abstract DisplayScreenMode[] ScreenModeList { get; }
public:
virtual property array<DisplayScreenMode^>^ ScreenModeList {
    array<DisplayScreenMode^>^ get () abstract;
}
/** @property */
public abstract DisplayScreenMode[] get_ScreenModeList ()

public abstract function get ScreenModeList () : DisplayScreenMode[]

Remarks

If the CapScreenMode property is set to false, the array will contain only one instance of the DisplayScreenMode structure.

ScreenModeList is typically initialized to an empty array. When ScreenModeList is set to a valid value, the CapScreenMode property is set to true.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplay Class
LineDisplay Members
Microsoft.PointOfService Namespace
LineDisplay.CapScreenMode Property
LineDisplay.ScreenMode Property


LineDisplay Events

LineDisplay Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

LineDisplay Class
Microsoft.PointOfService Namespace


Logger Class

Logger Class |
 | See Also Members

1/18/2008

Defines an event log file structure to which programs can write informational or programmatic warning or error events.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public NotInheritable Class Logger
public sealed class Logger
public ref class Logger sealed
public final class Logger
public final class Logger

Remarks

Logger is used to write event messages that are not written to Windows Event Viewer. The default file location is the user's \Application Data folder. The default file name is the application name appended with a time stamp.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.Logger

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Logger Members
Microsoft.PointOfService Namespace


Logger Members

Logger Members |
 | See Also Methods Properties

1/18/2008

Defines an event log file structure to which programs can write informational or programmatic warning or error events.

The following tables list the members exposed by the Logger type.

Public Properties

Name | Description
Enabled | Indicates whether logging is enabled.
RegistryPath | Holds the registry path to the log file.
Top

Public Methods (see also Protected Methods )

Name | Description
Close | Closes the log stream.
Equals | Overloaded. (inherited from Object )
Error | Overloaded.
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Info | Overloaded.
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Warn | Overloaded.
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

Logger Class
Microsoft.PointOfService Namespace


Logger Methods

Logger Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Close | Closes the log stream.
Equals | Overloaded. (inherited from Object )
Error | Overloaded.
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Info | Overloaded.
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Warn | Overloaded.

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

Logger Class
Microsoft.PointOfService Namespace


Logger.Close Method

Logger.Close Method |
 | See Also

1/18/2008

Closes the log stream.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Sub Close
public static void Close ()
public:
static void Close ()
public static void Close ()
public static function Close ()

Remarks

After calling Close, the logger reinitializes.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Logger Class
Logger Members
Microsoft.PointOfService Namespace


Logger.Error Method

Logger.Error Method |
 | See Also

1/18/2008

Overload List

Name | Description
Logger.Error (String, String) | Logs an error event with the specified parameters.
Logger.Error (String, String, Exception) | Logs an error event with the specified parameters.

See Also

Reference

Logger Class
Logger Members
Microsoft.PointOfService Namespace


Logger.Error Method (String, String)

Logger.Error Method (String, String) |
 | See Also

1/18/2008

Logs an error event with the specified parameters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Sub Error ( _
    caller As String, _
    message As String _
)
public static void Error (
    string caller,
    string message
)
public:
static void Error (
    String^ caller,
    String^ message
)
public static void Error (
    String caller,
    String message
)
public static function Error (
    caller : String,
    message : String
)

Parameters

caller

The source of the error

message

The error message

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Logger Class
Logger Members
Microsoft.PointOfService Namespace


Logger.Error Method (String, String, Exception)

Logger.Error Method (String, String, Exception) |
 | See Also

1/18/2008

Logs an error event with the specified parameters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Sub Error ( _
    caller As String, _
    message As String, _
    e As Exception _
)
public static void Error (
    string caller,
    string message,
    Exception e
)
public:
static void Error (
    String^ caller,
    String^ message,
    Exception^ e
)
public static void Error (
    String caller,
    String message,
    Exception e
)
public static function Error (
    caller : String,
    message : String,
    e : Exception
)

Parameters

caller

The source of the error

message

The error message

e

The exception that is the source of the error

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Logger Class
Logger Members
Microsoft.PointOfService Namespace


Logger.Info Method

Logger.Info Method |
 | See Also

1/18/2008

Overload List

Name | Description
Logger.Info (String, String) | Logs an informational event with the specified parameters.
Logger.Info (String, String, Boolean) | Logs an informational event with the specified parameters.

See Also

Reference

Logger Class
Logger Members
Microsoft.PointOfService Namespace


Logger.Info Method (String, String)

Logger.Info Method (String, String) |
 | See Also

1/18/2008

Logs an informational event with the specified parameters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Sub Info ( _
    caller As String, _
    message As String _
)
public static void Info (
    string caller,
    string message
)
public:
static void Info (
    String^ caller,
    String^ message
)
public static void Info (
    String caller,
    String message
)
public static function Info (
    caller : String,
    message : String
)

Parameters

caller

The source of the information

message

An informational message

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Logger Class
Logger Members
Microsoft.PointOfService Namespace


Logger.Info Method (String, String, Boolean)

Logger.Info Method (String, String, Boolean) |
 | See Also

1/18/2008

Logs an informational event with the specified parameters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Sub Info ( _
    caller As String, _
    message As String, _
    eventLog As Boolean _
)
public static void Info (
    string caller,
    string message,
    bool eventLog
)
public:
static void Info (
    String^ caller,
    String^ message,
    bool eventLog
)
public static void Info (
    String caller,
    String message,
    boolean eventLog
)
public static function Info (
    caller : String,
    message : String,
    eventLog : boolean
)

Parameters

caller

The source of the information

message

An informational message

eventLog

TRUE to write to the Windows event log; otherwise, FALSE

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Logger Class
Logger Members
Microsoft.PointOfService Namespace


Logger.Warn Method

Logger.Warn Method |
 | See Also

1/18/2008

Overload List

Name | Description
Logger.Warn (String, String) | Logs a warning event with the specified parameters.
Logger.Warn (String, String, Boolean) | Logs a warning event with the specified parameters.

See Also

Reference

Logger Class
Logger Members
Microsoft.PointOfService Namespace


Logger.Warn Method (String, String)

Logger.Warn Method (String, String) |
 | See Also

1/18/2008

Logs a warning event with the specified parameters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Sub Warn ( _
    caller As String, _
    message As String _
)
public static void Warn (
    string caller,
    string message
)
public:
static void Warn (
    String^ caller,
    String^ message
)
public static void Warn (
    String caller,
    String message
)
public static function Warn (
    caller : String,
    message : String
)

Parameters

caller

The warning source

message

A warning

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Logger Class
Logger Members
Microsoft.PointOfService Namespace


Logger.Warn Method (String, String, Boolean)

Logger.Warn Method (String, String, Boolean) |
 | See Also

1/18/2008

Logs a warning event with the specified parameters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Sub Warn ( _
    caller As String, _
    message As String, _
    eventLog As Boolean _
)
public static void Warn (
    string caller,
    string message,
    bool eventLog
)
public:
static void Warn (
    String^ caller,
    String^ message,
    bool eventLog
)
public static void Warn (
    String caller,
    String message,
    boolean eventLog
)
public static function Warn (
    caller : String,
    message : String,
    eventLog : boolean
)

Parameters

caller

The warning source

message

A warning

eventLog

TRUE to write to the Windows event log; otherwise, FALSE

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Logger Class
Logger Members
Microsoft.PointOfService Namespace


Logger Properties

Logger Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
Enabled | Indicates whether logging is enabled.
RegistryPath | Holds the registry path to the log file.

See Also

Reference

Logger Class
Microsoft.PointOfService Namespace


Logger.Enabled Property

Logger.Enabled Property |
 | See Also

1/18/2008

Indicates whether logging is enabled.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Property Enabled As Boolean
public static bool Enabled { get; set; }
public:
static property bool Enabled {
    bool get ();
    void set (bool value);
}
/** @property */
public static boolean get_Enabled ()

/** @property */
public static void set_Enabled (boolean value)

public static function get Enabled () : boolean

public static function set Enabled (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Logger Class
Logger Members
Microsoft.PointOfService Namespace


Logger.RegistryPath Property

Logger.RegistryPath Property |
 | See Also

1/18/2008

Holds the registry path to the log file.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared ReadOnly Property RegistryPath As String
public static string RegistryPath { get; }
public:
static property String^ RegistryPath {
    String^ get ();
}
/** @property */
public static String get_RegistryPath ()

public static function get RegistryPath () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Logger Class
Logger Members
Microsoft.PointOfService Namespace


LogState Enumeration

LogState Enumeration |
 | See Also

1/18/2008

Enumerates the state of the transaction log.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration LogState
public enum LogState
public enum class LogState
public enum LogState
public enum LogState

Members

Member name | Description
Full | The transaction log is full.
NearFull | The transaction log is nearly full.
Ok | The transaction log has enough capacity.

Remarks

If the transaction log becomes full, depending on the device, the settlement processing may not be able to operate.

After this property is initialized, it is kept current as long as the device is enabled.

See Also

Reference

Microsoft.PointOfService Namespace


MapMode Enumeration

MapMode Enumeration |
 | See Also

1/18/2008

Lists the valid units of measure for Printer, Check Scanner, and Point Card Reader Writer devices.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration MapMode
public enum MapMode
public enum class MapMode
public enum MapMode
public enum MapMode

Members

Member name | Description
Dots | The device's dot width.
English | 0.001 inch
Metric | 0.01 millimeter
Twips | 1/1440 of an inch

Remarks

Used by multiple properties and methods for the three devices. Members of this enumeration replace the PTR_MM_, PCRW_MM_, and CHK_MM_ families of UPOS 1.11 constants.

See Also

Reference

Microsoft.PointOfService Namespace


MarkerType Enumeration

MarkerType Enumeration |
 | See Also

1/18/2008

Lists the possible marker types.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration MarkerType
public enum MarkerType
public enum class MarkerType
public enum MarkerType
public enum MarkerType

Members

Member name | Description
Document | Marker for a document or ticket.
Head | Marks the first implicitly stored marker on the medium.
None | No assigned type.
SessionBegin | Marks the beginning of a session.
SessionEnd | Marks the end of a session.
Tail | Marks the last implicitly stored marker on the medium.

Remarks

Lists the possible marker types.

See Also

Reference

Microsoft.PointOfService Namespace


Micr Class

Micr Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a UPOS magnetic ink character recognition (MICR) device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class Micr
    Inherits PosCommon
public abstract class Micr : PosCommon
public ref class Micr abstract : public PosCommon
public abstract class Micr extends PosCommon
public abstract class Micr extends PosCommon

Remarks

This object defines the programmatic interface for a UPOS magnetic ink character recognition (MICR) device.

Capabilities

The MICR service object has the following minimal set of capabilities:

  • Reads magnetic ink characters from a check.

  • Has programmatic control of check insertion, reading, and removal. For some MICR devices, this requires no processing in the service object because the device may automate many of these functions.

  • Parses the MICR data into the output properties provided by this service object. This release of POS for .NET specifies parsing of fields indicated in the ANSI MICR standard used in the United States of America, Canada, Australia, United Kingdom, Japan, India, Mexico, Colombia, and Turkey. For other countries/regions, the application may have to parse the MICR data from the data in RawData.

The MICR may have the following additional capability:

  • The MICR device may be physically attached to or incorporated into a check validation print device. If this is the case, after a check is inserted through MICR service object methods, the check can still be used by the printer service object before check removal.

  • Some MICR devices support exception tables. This cause nonstandard parsing of the serial number for specific check routing numbers. Exception tables are not directly supported by this POS for .NET release. However, a service object can support them, and can assign registry entries under its device name key to define the exception entries.

This release of POS for .NET does not define any parsing of partial MICR check data if an error occurs while reading a check, because any service object that implements such functionality cannot guarantee that fields parsed from partial data is correct. For example, it is possible to get MICR data that contains no '?' characters, but fails its checksum. This indicates that one or more characters in the data is incorrect, but you cannot determine which characters they are. If an application wants to parse the partial data, the RawData property is filled in with whatever was successfully read, even in error cases.

Model

The MICR service object follows the general Device Input Model for event-driven input. One point of difference is that the MICR service object requires the execution of methods to insert and remove the check for processing. Therefore, this service object requires more than setting the DataEventEnabled property to true to receive data. The basic model is as follows:

  • The MICR service object is opened, claimed, and enabled.

  • When an application wants to perform a MICR read, the application calls the BeginInsertion method, specifying a time-out value. This results in the device being made ready to have a check inserted. The method returns either a success status if the check is inserted before the time-out limit was expired, or a time-out status.

  • If there is a time-out, the MICR device remains in a state that allows a check to be inserted while the application provides any additional prompting required, and then reissues the BeginInsertion method.

  • After a check is inserted, the method returns successfully and the application calls the EndInsertion method. This results in the MICR device being taken out of check Insertion mode and the check, if present, actually being read.

    • If the check is successfully read by the MICR service object, it queues a DataEvent event.

    • If the AutoDisable property is true, then the MICR service object automatically disables itself when a DataEvent event is queued.

    • A queued DataEvent can be delivered to the application when the DataEventEnabled property is true. Just before delivering this event, the service object copies the data into properties, and disables additional data events by setting the DataEventEnabled property to false. This causes later input data to be queued by the service object while the application processes the current input and associated properties. When the application finishes the current input and is ready for more data, it re-enables events by setting DataEventEnabled to true.

    • ErrorEvent events are queued if the service object encounters an error while reading the check, and are delivered to the application when the DataEventEnabled property is true.

    • The DataCount property can be read to obtain the number of DataEvent events queued by the service object.

    • All input queued by the service object can be deleted with the ClearInput method.

  • After it processes a DataEvent event, the application should query the CapValidationDevice property to determine whether validation printing can be performed on the check before check removal. If the CapValidationDevice property is true, the application can call the Printer service object's BeginInsertion and EndInsertion methods. This positions the check for validation printing. You can then use the Printer service object validation printing methods to perform validation printing. When validation printing is complete, the application should call the Printer service object's removal methods to remove the check.

  • After the check is no longer needed in the device, the application must call the BeginRemoval method, also specifying a time-out value. This method returns either a Success status if the check is removed, or a Time-out status if the check is not removed. If a Timeout is returned, the application can perform any additional prompting before it calls the method again. After the check is removed, the application should call the EndRemoval method to take the MICR device out of Removal mode.

Many models of MICR devices do not require any check-handling processing from the application. Such devices may always be able to receive a check and require no commands to actually read and eject the check. For these types of MICR devices, the BeginInsertion, EndInsertion, BeginRemoval and EndRemoval methods return a Success status, and the service object queues the data until the DataEventEnabled property is set to true. However, applications should still use these methods to guarantee application portability across different MICR devices.

Device Sharing

The MICR is an exclusive-use device, as follows:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before the device begins reading input, or before the application calls methods that manipulate the device.

MICR Character Substitution

The E13B MICR format that is used by the ANSI MICR standard contains fifteen possible characters: the numbers 0 through 9, the space character, and four characters unique to MICR data known as the Transit, Amount, On-Us, and Dash characters. These special characters are used to mark the boundaries of certain fields in MICR data.

Because these characters are not in the ASCII character set, the following lowercase characters are used to represent them in properties and parameters to methods.

Property name (POS Dot Net MICR names ) | Length | Standard settings | Symbol
AccountNumber | > 6 | The section between the transit number field and the On-Us symbol. | o
Amount | 10 | Bounded by two Amount symbols, that is 'a.' | a
BankNumber | 5 | Characters 4 to 8 of the transit field. |
CheckType |  | If Auxiliary On-Us field is not present, the type is Personal Check. If the On-Us field is present, it is a Business check. When no information is available, it is an Unknown check type. |
CountryCode |  | N/A |
Epc | 1 | When Transit Number is present, the number immediately before the Transit number. Spaces are ignored. | a
SerialNumber | varies | If On-Us field present, the data from On-Us field. If not, the data in On-Us field excluding the Account Number data. |
TransitNumber | 9 | All characters that are read between the Transit symbols. | t
RawData | varies | All data that is read in from MICR. |

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.Micr
Microsoft.PointOfService.BasicServiceObjects.MicrBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Micr Members
Microsoft.PointOfService Namespace


Micr Members

Micr Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a UPOS magnetic ink character recognition (MICR) device.

The following tables list the members exposed by the Micr type.

Protected Constructors

Name | Description
Micr | Creates an instance of the Micr class.
Top

Public Fields

Name | Description
ExtendedErrorBadData | Indicates an unreadable character was detected during input processing.
ExtendedErrorBadSize | Indicates the length of the check was beyond the expected readable range.
ExtendedErrorCheck | Indicates the device was taken out of Removal mode while a check is still present.
ExtendedErrorCheckDigit | Indicates the check digit verification has failed even though there was no error during input processing.
ExtendedErrorCoverOpen | Indicates the check insertion process failed because of the POS printer cover being open.
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorJam | Indicates the check insertion process has caused a paper jam.
ExtendedErrorNoCheck | Indicates the device was taken out of Insertion mode without a check being inserted.
ExtendedErrorNoData | Indicates the input data stream was unreadable.
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFailedDataParseCount | Contains the failed data parse count.
StatisticFailedReadCount | Contains the failed read count.
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticGoodReadCount | Contains the successful read count.
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
AccountNumber | Gets the account number parsed from the most recently read MICR data.
Amount | Gets the amount field parsed from the most recently read MICR data.
AutoDisable | Gets or sets a Boolean value that indicates whether POS for .NET automatically disables the device when data is received.
BankNumber | Gets the bank number part of the transit field parsed from the most recently read MICR data.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CapValidationDevice | Gets a Boolean value that indicates whether this device also performs validation printing through the POS Printer service object's slip station.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
CheckType | Gets a number that represents the type of check parsed from the most recently read MICR data.
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
CountryCode | Gets a number that represents the country/region of origin of the check, parsed from the most recently read MICR data.
DataCount | Gets the number of currently queued DataEvent events.
DataEventEnabled | Gets or sets a Boolean value that indicates whether a DataEvent event is delivered when input data is queued.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
Epc | Gets the Extended Processing Code ("EPC") field.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
RawData | Gets the MICR data from the most recent MICR read.
SerialNumber | Gets the serial number of the check parsed from the most recently read MICR data.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
TransitNumber | Gets the transit field of the check parsed from the most recently read MICR data.
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether the Micr is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
BeginInsertion | Starts check insertion processing.
BeginRemoval | Starts the check removal processing.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all device input that has been buffered.
ClearInputProperties | Resets the values of properties altered by DataEvent or ErrorEvent.
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
EndInsertion | Ends the check insertion processing.
EndRemoval | Ends the check removal processing.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon)
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DataEvent | Raised by the service object to notify the application when MICR data is read from a check and is available to read.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
ErrorEvent | Raised by the service object to notify the application that an error has been detected when it reads MICR data.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

Micr Class
Microsoft.PointOfService Namespace


Micr Fields

Micr Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorBadData | Indicates an unreadable character was detected during input processing.
ExtendedErrorBadSize | Indicates the length of the check was beyond the expected readable range.
ExtendedErrorCheck | Indicates the device was taken out of Removal mode while a check is still present.
ExtendedErrorCheckDigit | Indicates the check digit verification has failed even though there was no error during input processing.
ExtendedErrorCoverOpen | Indicates the check insertion process failed because of the POS printer cover being open.
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorJam | Indicates the check insertion process has caused a paper jam.
ExtendedErrorNoCheck | Indicates the device was taken out of Insertion mode without a check being inserted.
ExtendedErrorNoData | Indicates the input data stream was unreadable.
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFailedDataParseCount | Contains the failed data parse count.
StatisticFailedReadCount | Contains the failed read count.
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticGoodReadCount | Contains the successful read count.
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

Micr Class
Microsoft.PointOfService Namespace


Micr.ExtendedErrorBadData Field

Micr.ExtendedErrorBadData Field |
 | See Also

1/18/2008

Indicates an unreadable character was detected during input processing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorBadData As Integer
public const int ExtendedErrorBadData
public:
literal int ExtendedErrorBadData
public static final int ExtendedErrorBadData
public const var ExtendedErrorBadData : int

Remarks

The RawData property contains partial data if available; otherwise it is an empty string.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace
ErrorEvent


Micr.ExtendedErrorBadSize Field

Micr.ExtendedErrorBadSize Field |
 | See Also

1/18/2008

Indicates the length of the check was beyond the expected readable range.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorBadSize As Integer
public const int ExtendedErrorBadSize
public:
literal int ExtendedErrorBadSize
public static final int ExtendedErrorBadSize
public const var ExtendedErrorBadSize : int

Remarks

The RawData property contains partial data if available; otherwise it is an empty string.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace
ErrorEvent


Micr.ExtendedErrorCheck Field

Micr.ExtendedErrorCheck Field |
 | See Also

1/18/2008

Indicates the device was taken out of Removal mode while a check is still present.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorCheck As Integer
public const int ExtendedErrorCheck
public:
literal int ExtendedErrorCheck
public static final int ExtendedErrorCheck
public const var ExtendedErrorCheck : int

Remarks

Indicates the device was taken out of Removal mode while a check is still present.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace
ErrorEvent


Micr.ExtendedErrorCheckDigit Field

Micr.ExtendedErrorCheckDigit Field |
 | See Also

1/18/2008

Indicates the check digit verification has failed even though there was no error during input processing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorCheckDigit As Integer
public const int ExtendedErrorCheckDigit
public:
literal int ExtendedErrorCheckDigit
public static final int ExtendedErrorCheckDigit
public const var ExtendedErrorCheckDigit : int

Remarks

The RawData property contains partial data if available; otherwise it is an empty string.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace
ErrorEvent


Micr.ExtendedErrorCoverOpen Field

Micr.ExtendedErrorCoverOpen Field |
 | See Also

1/18/2008

Indicates the check insertion process failed because of the POS printer cover being open.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorCoverOpen As Integer
public const int ExtendedErrorCoverOpen
public:
literal int ExtendedErrorCoverOpen
public static final int ExtendedErrorCoverOpen
public const var ExtendedErrorCoverOpen : int

Remarks

Indicates the check insertion process failed because of the POS printer cover being open.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace
ErrorEvent


Micr.ExtendedErrorJam Field

Micr.ExtendedErrorJam Field |
 | See Also

1/18/2008

Indicates the check insertion process has caused a paper jam.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorJam As Integer
public const int ExtendedErrorJam
public:
literal int ExtendedErrorJam
public static final int ExtendedErrorJam
public const var ExtendedErrorJam : int

Remarks

Indicates the check insertion process has caused a paper jam.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace
ErrorEvent


Micr.ExtendedErrorNoCheck Field

Micr.ExtendedErrorNoCheck Field |
 | See Also

1/18/2008

Indicates the device was taken out of Insertion mode without a check being inserted.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorNoCheck As Integer
public const int ExtendedErrorNoCheck
public:
literal int ExtendedErrorNoCheck
public static final int ExtendedErrorNoCheck
public const var ExtendedErrorNoCheck : int

Remarks

Indicates the device was taken out of Insertion mode without a check being inserted.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace
ErrorEvent


Micr.ExtendedErrorNoData Field

Micr.ExtendedErrorNoData Field |
 | See Also

1/18/2008

Indicates the input data stream was unreadable.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorNoData As Integer
public const int ExtendedErrorNoData
public:
literal int ExtendedErrorNoData
public static final int ExtendedErrorNoData
public const var ExtendedErrorNoData : int

Remarks

Indicates the input data stream was unreadable.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace
ErrorEvent


Micr.StatisticFailedDataParseCount Field

Micr.StatisticFailedDataParseCount Field |
 | See Also

1/18/2008

Contains the failed data parse count.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticFailedDataParseCount As String
public const string StatisticFailedDataParseCount
public:
literal String^ StatisticFailedDataParseCount
public static final String StatisticFailedDataParseCount
public const var StatisticFailedDataParseCount : String

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace
ErrorEvent


Micr.StatisticFailedReadCount Field

Micr.StatisticFailedReadCount Field |
 | See Also

1/18/2008

Contains the failed read count.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticFailedReadCount As String
public const string StatisticFailedReadCount
public:
literal String^ StatisticFailedReadCount
public static final String StatisticFailedReadCount
public const var StatisticFailedReadCount : String

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace


Micr.StatisticGoodReadCount Field

Micr.StatisticGoodReadCount Field |
 | See Also

1/18/2008

Contains the successful read count.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticGoodReadCount As String
public const string StatisticGoodReadCount
public:
literal String^ StatisticGoodReadCount
public static final String StatisticGoodReadCount
public const var StatisticGoodReadCount : String

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace


Micr Constructor

Micr Constructor |
 | See Also

1/18/2008

Creates an instance of the Micr class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected Micr ()
protected:
Micr ()
protected Micr ()
protected function Micr ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace


Micr Methods

Micr Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
BeginInsertion | Starts check insertion processing.
BeginRemoval | Starts the check removal processing.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all device input that has been buffered.
ClearInputProperties | Resets the values of properties altered by DataEvent or ErrorEvent.
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
EndInsertion | Ends the check insertion processing.
EndRemoval | Ends the check removal processing.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon )
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

Micr Class
Microsoft.PointOfService Namespace


Micr.BeginInsertion Method

Micr.BeginInsertion Method |
 | See Also

1/18/2008

Starts check insertion processing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub BeginInsertion ( _
    timeout As Integer _
)
public abstract void BeginInsertion (
    int timeout
)
public:
virtual void BeginInsertion (
    int timeout
) abstract
public abstract void BeginInsertion (
    int timeout
)
public abstract function BeginInsertion (
    timeout : int
)

Parameters

timeout

The timeout parameter gives the number of milliseconds before failing the method.If timeout is zero, BeginInsertion tries to begin Insertion mode, then returns the appropriate status immediately.If timeout is WaitForever, BeginInsertion tries to begin Insertion mode, then waits as long until either the check is inserted or an error occurs.

Remarks

When it is called, the MICR is made ready to receive a check by opening the MICR's check handling "jaws" or starting a MICR's check Insertion mode. BeginInsertion is paired with the EndInsertion method for controlling check insertion. For MICR devices that do not require this kind of processing, the BeginInsertion and EndInsertion methods return Success. However, the application should still use these methods to guarantee application portability across different MICR devices.

If the MICR device cannot be put in Insertion mode, an error is returned to the application. Otherwise, the service object continues to monitor check insertion until either:

  • The check is successfully inserted. In this case, the service object returns a Success status.

-Or-

  • The check is not inserted before time-out milliseconds have elapsed, or an error is reported by the MICR device. In this case, the service object either returns Timeout or another error. The MICR device remains in check Insertion mode. This allows an application to perform some user interaction and reissue the BeginInsertion method without altering the MICR check handling mechanism.

BeginInsertion may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Busy | If the MICR is a combination device, the peer device may be Busy.
Illegal | An invalid timeout parameter was specified.
Timeout | The specified time has elapsed without the check being correctly inserted.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace
EndInsertion
BeginRemoval
EndRemoval


Micr.BeginRemoval Method

Micr.BeginRemoval Method |
 | See Also

1/18/2008

Starts the check removal processing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub BeginRemoval ( _
    timeout As Integer _
)
public abstract void BeginRemoval (
    int timeout
)
public:
virtual void BeginRemoval (
    int timeout
) abstract
public abstract void BeginRemoval (
    int timeout
)
public abstract function BeginRemoval (
    timeout : int
)

Parameters

timeout

The timeout parameter gives the number of milliseconds before failing the method.If timeout is zero, BeginRemoval tries to begin Removal mode, then returns the appropriate status immediately.If timeout is WaitForever, BeginRemoval tries to begin Removal mode, then waits until either the check is removed or an error occurs.

Remarks

When BeginRemoval is called, the MICR is made ready to remove a check by opening the MICR's check handling "jaws" or starting a MICR's check Ejection mode. BeginRemoval is paired with the EndRemoval method for controlling check removal. For MICR devices that do not require this kind of processing, the BeginRemoval and EndRemoval methods return Success. However, the application should still use these methods to guarantee application portability across different MICR devices.

If the MICR device cannot be put into Removal or Ejection mode, an error is returned to the application. Otherwise, the service object continues to monitor check removal until either:

  • The check is successfully removed. In this case, the service object returns a Success status.

-Or-

  • The check is not removed before time-out milliseconds have elapsed, or an error is reported by the MICR device. In this case, the service object either returns Timeout or another error. The MICR device remains in check Removal mode. This allows an application to perform some user interaction and reissue the BeginRemoval method without altering the MICR check handling mechanism.

BeginRemoval may cause a PosControlException exception to be thrown with the following ErrorCode:

Value | Meaning
Busy | If the MICR is a combination device, the peer device may be Busy.
Illegal | An invalid timeout parameter was specified.
Timeout | The specified time has elapsed without the check being correctly removed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace
Micr.BeginInsertion Method
EndInsertion
EndRemoval


Micr.ClearInput Method

Micr.ClearInput Method |
 | See Also

1/18/2008

Clears all device input that has been buffered.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearInput
public abstract void ClearInput ()
public:
virtual void ClearInput () abstract
public abstract void ClearInput ()
public abstract function ClearInput ()

Remarks

Any data events or input error events that are queued—usually waiting for DataEventEnabled to be set to true and FreezeEvents to be set to false—are also cleared.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace
DataEventEnabled
DataEvent


Micr.ClearInputProperties Method

Micr.ClearInputProperties Method |
 | See Also

1/18/2008

Resets the values of properties altered by DataEvent or ErrorEvent.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Sub ClearInputProperties
public virtual void ClearInputProperties ()
public:
virtual void ClearInputProperties ()
public void ClearInputProperties ()
public function ClearInputProperties ()

Remarks

Sets all data properties populated by raising a DataEvent or ErrorEvent event back to their default values. This does not reset the DataCount or State properties.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace


Micr.EndInsertion Method

Micr.EndInsertion Method |
 | See Also

1/18/2008

Ends the check insertion processing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub EndInsertion
public abstract void EndInsertion ()
public:
virtual void EndInsertion () abstract
public abstract void EndInsertion ()
public abstract function EndInsertion ()

Remarks

When it is called, the MICR is taken out of check Insertion mode. If a check is detected in the device, a successful status of Success is returned to the application. If no check is present, an extended error status ExtendedErrorNoCheck is returned. Upon completion of EndInsertion, the check is read by the MICR device, and data is available as soon as the DataEventEnabled property is set to true. This allows an application to prompt the user before it calls the EndInsertion method to make sure that the form is correctly positioned.

EndInsertion is paired with the BeginInsertion method for controlling check insertion. For MICR devices that do not require this kind of processing, the EndInsertion and BeginInsertion methods return Success. However, the application should still use these methods to guarantee application portability across different MICR devices.

EndInsertion may cause a PosControlException exception to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The printer is not in check Insertion mode.
ExtendedErrorNoCheck | The device was taken out of Insertion mode without a check being inserted.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace
Micr.BeginInsertion Method
Micr.BeginRemoval Method
EndRemoval


Micr.EndRemoval Method

Micr.EndRemoval Method |
 | See Also

1/18/2008

Ends the check removal processing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub EndRemoval
public abstract void EndRemoval ()
public:
virtual void EndRemoval () abstract
public abstract void EndRemoval ()
public abstract function EndRemoval ()

Remarks

When EndRemoval is called, the MICR is taken out of check Removal or Ejection mode. If no check is detected in the device, a status of Success is returned to the application. If a check is present, an extended error status of ExtendedErrorCheck is returned.

EndRemoval is paired with the BeginRemoval method for controlling check removal. For MICR devices that do not require this kind of processing, these methods return Success. However, the application should still use these methods to guarantee application portability across different MICR devices.

EndRemoval may cause a PosControlException exception to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The printer is not in check Removal mode.
ExtendedErrorCheck | The device was taken out of Removal mode while a check is present.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace
Micr.BeginInsertion Method
Micr.BeginRemoval Method
Micr.EndInsertion Method


Micr Properties

Micr Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
AccountNumber | Gets the account number parsed from the most recently read MICR data.
Amount | Gets the amount field parsed from the most recently read MICR data.
AutoDisable | Gets or sets a Boolean value that indicates whether POS for .NET automatically disables the device when data is received.
BankNumber | Gets the bank number part of the transit field parsed from the most recently read MICR data.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CapValidationDevice | Gets a Boolean value that indicates whether this device also performs validation printing through the POS Printer service object's slip station.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
CheckType | Gets a number that represents the type of check parsed from the most recently read MICR data.
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
CountryCode | Gets a number that represents the country/region of origin of the check, parsed from the most recently read MICR data.
DataCount | Gets the number of currently queued DataEvent events.
DataEventEnabled | Gets or sets a Boolean value that indicates whether a DataEvent event is delivered when input data is queued.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
Epc | Gets the Extended Processing Code ("EPC") field.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
RawData | Gets the MICR data from the most recent MICR read.
SerialNumber | Gets the serial number of the check parsed from the most recently read MICR data.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )
TransitNumber | Gets the transit field of the check parsed from the most recently read MICR data.

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether the Micr is an exclusive-use device.

See Also

Reference

Micr Class
Microsoft.PointOfService Namespace


Micr.AccountNumber Property

Micr.AccountNumber Property |
 | See Also

1/18/2008

Gets the account number parsed from the most recently read MICR data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property AccountNumber As String
public abstract string AccountNumber { get; }
public:
virtual property String^ AccountNumber {
    String^ get () abstract;
}
/** @property */
public abstract String get_AccountNumber ()

public abstract function get AccountNumber () : String

Remarks

This account number does not include a check serial number if a check serial number can be separately parsed, even if the check serial number is embedded in the account number part of the "On-Us" field.

If the account number cannot be identified, the string is empty ("").

AccountNumber is set by the service object before it sends a data event to the application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace
RawData
DataEvent


Micr.Amount Property

Micr.Amount Property |
 | See Also

1/18/2008

Gets the amount field parsed from the most recently read MICR data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property Amount As String
public abstract string Amount { get; }
public:
virtual property String^ Amount {
    String^ get () abstract;
}
/** @property */
public abstract String get_Amount ()

public abstract function get Amount () : String

Remarks

The amount field on a check consists of ten digits bordered by Amount symbols. All nonspace digits are represented in the test string. This includes leading zeros.

If the amount is not present, the string is empty ("").

Amount is set by the service object before it sends a data event to the application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace
RawData
DataEvent


Micr.AutoDisable Property

Micr.AutoDisable Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether POS for .NET automatically disables the device when data is received.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AutoDisable As Boolean
public abstract bool AutoDisable { get; set; }
public:
virtual property bool AutoDisable {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_AutoDisable ()

/** @property */
public abstract void set_AutoDisable (boolean value)

public abstract function get AutoDisable () : boolean

public abstract function set AutoDisable (value : boolean)

Remarks

If true, POS for .NET sets DeviceEnabled to false after it receives and queues data as a DataEvent event. Before any additional input can be received, the application must set DeviceEnabled to true.

If false, POS for .NET does not automatically disable the device when data is received.

AutoDisable provides the application with an additional option for controlling the receipt of input data. If an application wants to receive and process only one input, or only one input at a time, then AutoDisable should be set to true.

AutoDisable is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace


Micr.BankNumber Property

Micr.BankNumber Property |
 | See Also

1/18/2008

Gets the bank number part of the transit field parsed from the most recently read MICR data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property BankNumber As String
public abstract string BankNumber { get; }
public:
virtual property String^ BankNumber {
    String^ get () abstract;
}
/** @property */
public abstract String get_BankNumber ()

public abstract function get BankNumber () : String

Remarks

The bank number is contained in digits 4 through 8 of the transit field.

If the bank number or transit field is not present or cannot be identified, the string is empty ("").

BankNumber is set by the service object before it sends a data event to the application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace
RawData
DataEvent
TransitNumber


Micr.CapValidationDevice Property

Micr.CapValidationDevice Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether this device also performs validation printing through the POS Printer service object's slip station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapValidationDevice As Boolean
public abstract bool CapValidationDevice { get; }
public:
virtual property bool CapValidationDevice {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapValidationDevice ()

public abstract function get CapValidationDevice () : boolean

Remarks

If CapValidationDevice is true, a check does not have to be removed from the MICR device before it performs validation printing. For devices that are both a MICR device and a POS Printer, the device automatically positions the check for validation printing after successfully performing a MICR read. Either the MICR Control or the POS Printer Control BeginRemoval and EndRemoval methods can be called to remove the check when processing is complete.

CapValidationDevice is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace
Micr.BeginRemoval Method
Micr.EndRemoval Method


Micr.CheckType Property

Micr.CheckType Property |
 | See Also

1/18/2008

Gets a number that represents the type of check parsed from the most recently read MICR data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CheckType As CheckType
public abstract CheckType CheckType { get; }
public:
virtual property CheckType CheckType {
    CheckType get () abstract;
}
/** @property */
public abstract CheckType get_CheckType ()

public abstract function get CheckType () : CheckType

Remarks

Valid values are defined by the CheckType enumeration.

CheckType is set and kept current by the service object while the device is enabled. CheckType is set before a DataEvent event is sent to the application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace
RawData
DataEvent


Micr.CountryCode Property

Micr.CountryCode Property |
 | See Also

1/18/2008

Gets a number that represents the country/region of origin of the check, parsed from the most recently read MICR data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CountryCode As CheckCountryCode
public abstract CheckCountryCode CountryCode { get; }
public:
virtual property CheckCountryCode CountryCode {
    CheckCountryCode get () abstract;
}
/** @property */
public abstract CheckCountryCode get_CountryCode ()

public abstract function get CountryCode () : CheckCountryCode

Remarks

Valid values are defined by the CheckCountryCode enumeration.

CountryCode is set and kept current by the service object while the device is enabled. CountryCode is set before a DataEvent is sent to the application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace
RawData
DataEvent


Micr.DataCount Property

Micr.DataCount Property |
 | See Also

1/18/2008

Gets the number of currently queued DataEvent events.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DataCount As Integer
public abstract int DataCount { get; }
public:
virtual property int DataCount {
    int get () abstract;
}
/** @property */
public abstract int get_DataCount ()

public abstract function get DataCount () : int

Remarks

The application can read this property to determine whether additional input is queued from a device but has not yet been delivered because of other application processing, freezing of events, or other causes.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace
DataEvent


Micr.DataEventEnabled Property

Micr.DataEventEnabled Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether a DataEvent event is delivered when input data is queued.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property DataEventEnabled As Boolean
public abstract bool DataEventEnabled { get; set; }
public:
virtual property bool DataEventEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_DataEventEnabled ()

/** @property */
public abstract void set_DataEventEnabled (boolean value)

public abstract function get DataEventEnabled () : boolean

public abstract function set DataEventEnabled (value : boolean)

Remarks

If true, a DataEvent event is delivered as soon as input data is queued. If changed to true and some input data is already queued, then a DataEvent event is delivered immediately. (Notice that other conditions may delay "immediate" delivery: if FreezeEvents is true or another event is already being processed at the application, the DataEvent remains queued until the condition is corrected.)

If false, input data is queued for later delivery to the application. Also, if an input error occurs, the ErrorEvent event is not delivered while this property is false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace
DataEvent


Micr.Epc Property

Micr.Epc Property |
 | See Also

1/18/2008

Gets the Extended Processing Code ("EPC") field.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property Epc As String
public abstract string Epc { get; }
public:
virtual property String^ Epc {
    String^ get () abstract;
}
/** @property */
public abstract String get_Epc ()

public abstract function get Epc () : String

Remarks

The string that contains the EPC field is parsed from the most recently read MICR data. If the field is present, the string contains a single character 0 though 9. If the field is not present, the string is empty ("").

EPC is set and kept current by the service object while the device is enabled. EPC is set before a DataEvent event is sent to the application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace
RawData
DataEvent


Micr.IsExclusiveUseDevice Property

Micr.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the Micr is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Property Value

A value of true indicates that the Micr is exclusive-use. Otherwise, the value is false.

Remarks

An exclusive-use device has the following properties:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before accessing some properties or calling methods that update the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace


Micr.RawData Property

Micr.RawData Property |
 | See Also

1/18/2008

Gets the MICR data from the most recent MICR read.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property RawData As String
public abstract string RawData { get; }
public:
virtual property String^ RawData {
    String^ get () abstract;
}
/** @property */
public abstract String get_RawData ()

public abstract function get RawData () : String

Remarks

The string contains any of the 15 MICR characters with appropriate substitution to represent non-ASCII characters. The data returned to this string are not parsed or processed in any special way. The following is a sample value:

"2t123456789t123 4 567890o 123 a0000001957a"

Notice that the property value includes spaces to represent spaces in the MICR data.

RawData is set and kept current by the service object while the device is enabled. RawData is set before a DataEvent event is sent to the application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace
Micr.AccountNumber Property
Micr.Amount Property
Micr.BankNumber Property
Micr.CheckType Property
Micr.CountryCode Property
Micr.Epc Property
SerialNumber
TransitNumber
DataEvent


Micr.SerialNumber Property

Micr.SerialNumber Property |
 | See Also

1/18/2008

Gets the serial number of the check parsed from the most recently read MICR data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property SerialNumber As String
public abstract string SerialNumber { get; }
public:
virtual property String^ SerialNumber {
    String^ get () abstract;
}
/** @property */
public abstract String get_SerialNumber ()

public abstract function get SerialNumber () : String

Remarks

If the serial number cannot be successfully parsed, the value of SerialNumber is empty ("").

SerialNumber is set and kept current by the service object while the device is enabled. SerialNumber is set before a DataEvent event is sent to the application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace
Micr.RawData Property
DataEvent


Micr.TransitNumber Property

Micr.TransitNumber Property |
 | See Also

1/18/2008

Gets the transit field of the check parsed from the most recently read MICR data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property TransitNumber As String
public abstract string TransitNumber { get; }
public:
virtual property String^ TransitNumber {
    String^ get () abstract;
}
/** @property */
public abstract String get_TransitNumber ()

public abstract function get TransitNumber () : String

Remarks

The transmit number consists of all the characters that are read between the 'Transit' symbols on the check. It is a 9-character string.

TransitNumber is set and kept current by the service object while the device is enabled. TransitNumber is set before a DataEvent event is sent to the application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace
Micr.RawData Property
DataEvent


Micr Events

Micr Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DataEvent | Raised by the service object to notify the application when MICR data is read from a check and is available to read.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
ErrorEvent | Raised by the service object to notify the application that an error has been detected when it reads MICR data.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

Micr Class
Microsoft.PointOfService Namespace


Micr.DataEvent Event

Micr.DataEvent Event |
 | See Also

1/18/2008

Raised by the service object to notify the application when MICR data is read from a check and is available to read.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event DataEvent As DataEventHandler
public abstract event DataEventHandler DataEvent
public:
virtual event DataEventHandler^ DataEvent {
    void add (DataEventHandler^ value) abstract;
    void remove (DataEventHandler^ value) abstract;
}
/** @event */
public abstract void add_DataEvent (DataEventHandler value)

/** @event */
public abstract void remove_DataEvent (DataEventHandler value)

Remarks

Before delivering DataEvent, the MICR service object updates the RawData property and tries to parse this data into the MICR data fields.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace
Micr.RawData Property
Micr.AccountNumber Property
Micr.Amount Property
Micr.BankNumber Property
Micr.CheckType Property
Micr.CountryCode Property
Micr.Epc Property
Micr.SerialNumber Property
Micr.TransitNumber Property


Micr.ErrorEvent Event

Micr.ErrorEvent Event |
 | See Also

1/18/2008

Raised by the service object to notify the application that an error has been detected when it reads MICR data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event ErrorEvent As DeviceErrorEventHandler
public abstract event DeviceErrorEventHandler ErrorEvent
public:
virtual event DeviceErrorEventHandler^ ErrorEvent {
    void add (DeviceErrorEventHandler^ value) abstract;
    void remove (DeviceErrorEventHandler^ value) abstract;
}
/** @event */
public abstract void add_ErrorEvent (DeviceErrorEventHandler value)

/** @event */
public abstract void remove_ErrorEvent (DeviceErrorEventHandler value)

Remarks

Input error events are not delivered until the DataEventEnabled property is true so that correct application sequencing occurs.

See Also

Reference

Micr Class
Micr Members
Microsoft.PointOfService Namespace
Status, Result Code, and State Model


MotionSensor Class

MotionSensor Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a UPOS Motion Sensor device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class MotionSensor
    Inherits PosCommon
public abstract class MotionSensor : PosCommon
public ref class MotionSensor abstract : public PosCommon
public abstract class MotionSensor extends PosCommon
public abstract class MotionSensor extends PosCommon

Remarks

Capabilities

The motion sensor has the following minimal set of capabilities:

  • Supports detection of a person present at the POS device.

  • Supports reporting of motion-detection changes, either by hardware or software detection.

Model

The motion sensor defines two motion sensor indications as constants. It is assumed that the motion sensor supports present and absent indications. The constants for the motion sensor are as follows:

  • StatusMotionPresent

  • StatusMotionAbsent

StatusUpdateEvent events are raised by using the previous values. The Timeout value is used to set the number of milliseconds between the last time someone was present and a StatusMotionAbsentStatusUpdateEvent being raised.

Device Sharing

The Motion Sensor is a shareable device. Its device-sharing rules are as follows:

  • After opening and enabling the device, the application can access all properties and methods and receive StatusUpdateEvent events.

  • If more than one application has opened and enabled the device, each of these applications can access its properties and methods. StatusUpdateEvent events are raised to all these applications.

  • The Motion Sensor cannot be claimed for exclusive access. Therefore, if an application calls claim or release, these methods raise an exception.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.MotionSensor
Microsoft.PointOfService.BasicServiceObjects.MotionSensorBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MotionSensor Members
Microsoft.PointOfService Namespace


MotionSensor Members

MotionSensor Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a UPOS Motion Sensor device.

The following tables list the members exposed by the MotionSensor type.

Protected Constructors

Name | Description
MotionSensor | Creates an instance of MotionSensor class.
Top

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticMotionEventCount | Indicates statistics for motion event reporting.
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusMotionAbsent | Indicates the absence of motion.
StatusMotionPresent | Indicates the presence of motion.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
Motion | Gets a Boolean value that indicates whether motion has been detected.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Timeout | Gets or sets the number of milliseconds from the last time motion was detected until the status update event of StatusMotionAbsent is raised.
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether the MotionSensor is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon)
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
WaitForMotion | Used by the application to wait for detection of a motion from the motion sensor.
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

MotionSensor Class
Microsoft.PointOfService Namespace


MotionSensor Fields

MotionSensor Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticMotionEventCount | Indicates statistics for motion event reporting.
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusMotionAbsent | Indicates the absence of motion.
StatusMotionPresent | Indicates the presence of motion.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

MotionSensor Class
Microsoft.PointOfService Namespace


MotionSensor.StatisticMotionEventCount Field

MotionSensor.StatisticMotionEventCount Field |
 | See Also

1/18/2008

Indicates statistics for motion event reporting.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticMotionEventCount As String
public const string StatisticMotionEventCount
public:
literal String^ StatisticMotionEventCount
public static final String StatisticMotionEventCount
public const var StatisticMotionEventCount : String

See Also

Reference

MotionSensor Class
MotionSensor Members
Microsoft.PointOfService Namespace


MotionSensor.StatusMotionAbsent Field

MotionSensor.StatusMotionAbsent Field |
 | See Also

1/18/2008

Indicates the absence of motion.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusMotionAbsent As Integer
public const int StatusMotionAbsent
public:
literal int StatusMotionAbsent
public static final int StatusMotionAbsent
public const var StatusMotionAbsent : int

See Also

Reference

MotionSensor Class
MotionSensor Members
Microsoft.PointOfService Namespace


MotionSensor.StatusMotionPresent Field

MotionSensor.StatusMotionPresent Field |
 | See Also

1/18/2008

Indicates the presence of motion.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusMotionPresent As Integer
public const int StatusMotionPresent
public:
literal int StatusMotionPresent
public static final int StatusMotionPresent
public const var StatusMotionPresent : int

See Also

Reference

MotionSensor Class
MotionSensor Members
Microsoft.PointOfService Namespace


MotionSensor Constructor

MotionSensor Constructor |
 | See Also

1/18/2008

Creates an instance of MotionSensor class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected MotionSensor ()
protected:
MotionSensor ()
protected MotionSensor ()
protected function MotionSensor ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

MotionSensor Class
MotionSensor Members
Microsoft.PointOfService Namespace


MotionSensor Methods

MotionSensor Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon )
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
WaitForMotion | Used by the application to wait for detection of a motion from the motion sensor.

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

MotionSensor Class
Microsoft.PointOfService Namespace


MotionSensor.WaitForMotion Method

MotionSensor.WaitForMotion Method |
 | See Also

1/18/2008

Used by the application to wait for detection of a motion from the motion sensor.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub WaitForMotion ( _
    timeout As Integer _
)
public abstract void WaitForMotion (
    int timeout
)
public:
virtual void WaitForMotion (
    int timeout
) abstract
public abstract void WaitForMotion (
    int timeout
)
public abstract function WaitForMotion (
    timeout : int
)

Parameters

timeout

Maximum number of milliseconds for the motion sensor to wait for a person to be present before it returns control back to the application. If 0, the method returns immediately. If WaitForever, the method waits as long as needed until motion is detected or an error occurs.

Remarks

If the motion sensor detects someone is present, then the method returns immediately.

WaitForMotion may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Timeout | The time-out period expired before motion was detected.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MotionSensor Class
MotionSensor Members
Microsoft.PointOfService Namespace


MotionSensor Properties

MotionSensor Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
Motion | Gets a Boolean value that indicates whether motion has been detected.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )
Timeout | Gets or sets the number of milliseconds from the last time motion was detected until the status update event of StatusMotionAbsent is raised.

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether the MotionSensor is an exclusive-use device.

See Also

Reference

MotionSensor Class
Microsoft.PointOfService Namespace


MotionSensor.IsExclusiveUseDevice Property

MotionSensor.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the MotionSensor is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Property Value

A value of true indicates that the MotionSensor is exclusive-use. Otherwise, the value will be false.

Remarks

An exclusive-use device has the following properties:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before the application accesses some properties or calling methods that update the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MotionSensor Class
MotionSensor Members
Microsoft.PointOfService Namespace


MotionSensor.Motion Property

MotionSensor.Motion Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether motion has been detected.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property Motion As Boolean
public abstract bool Motion { get; }
public:
virtual property bool Motion {
    bool get () abstract;
}
/** @property */
public abstract boolean get_Motion ()

public abstract function get Motion () : boolean

Remarks

Motion is typically initialized to false. It should be kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MotionSensor Class
MotionSensor Members
Microsoft.PointOfService Namespace


MotionSensor.Timeout Property

MotionSensor.Timeout Property |
 | See Also

1/18/2008

Gets or sets the number of milliseconds from the last time motion was detected until the status update event of StatusMotionAbsent is raised.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property Timeout As Integer
public abstract int Timeout { get; set; }
public:
virtual property int Timeout {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_Timeout ()

/** @property */
public abstract void set_Timeout (int value)

public abstract function get Timeout () : int

public abstract function set Timeout (value : int)

Remarks

This property must be application-specific for a shared device. If several applications are sharing the device, each application can set an independent Timeout value, and each application receives StatusUpdateEvent events according to its supplied time-out.

Timeout is typically initialized to zero. It should then be kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MotionSensor Class
MotionSensor Members
Microsoft.PointOfService Namespace
StatusUpdateEvent


MotionSensor Events

MotionSensor Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

MotionSensor Class
Microsoft.PointOfService Namespace


Msr Class

Msr Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a UPOS magnetic stripe reader (MSR) device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class Msr
    Inherits PosCommon
public abstract class Msr : PosCommon
public ref class Msr abstract : public PosCommon
public abstract class Msr extends PosCommon
public abstract class Msr extends PosCommon

Remarks

MSR devices support the following functionality:

  • The reading of encoded data from a magnetic stripe. The data is read from any combination of Tracks 1, 2, 3 and JIS-II. The alphanumeric data bytes can be decoded into their corresponding alphanumeric codes. Furthermore, this decoded alphanumeric data can be divided into specific fields accessed as device properties.

An MSR device can also support:

  • Specific card types ISO, JIS Type I, and/or JIS Type II. The following conventions are assumed:

    • Track 1 is ISO or JIS-I Track 1.

    • Track 2 is ISO or JIS-I Track 2.

    • Track 3 is ISO or JIS-I Track 3.

    • Track 4 is JIS-II data.

    • Determination of the type of card is based on the type of content the card tracks are expected to hold.

  • The optional return of the track sentinels with track data.

To remain compatible with prior versions, the service object can also store the JIS-II data in a previously used TracknData property. In such cases, the service object should set the DataEventArgs.Status property and the ErrorCodeExtended property to reflect both Track4Data and TracknData. Note that this programming code may not be readily portable.

Four writable properties control MSR data handling:

  • The TracksToRead property controls which combination of the four tracks should be read. It is not an error to swipe a card containing less than this set of tracks. Rather, TracksToRead should be set to the set of tracks that the application may need to process;

  • The DecodeData property controls decoding of track data from raw format into displayable data;

  • The ParseDecodeData property controls parsing of decoded data into fields, based on common MSR standards; and

  • The ErrorReportingType property controls the type of handling that occurs when a track containing invalid data is read.

Programming Model

MSR devices follow the general input model for event-driven input:

  • When input is received by the service object, it queues a DataEvent.

  • If the AutoDisable property is true, then the service object automatically disables itself when a DataEvent is queued.

  • A queued DataEvent can be delivered to the application when the DataEventEnabled property is true. Just before delivering this event, the service object copies the data into properties, then disables further data events by setting the DataEventEnabled property to false. Subsequent input data is queued while the application processes the current input and associated properties. When the application is ready to receive more data, it sets DataEventEnabled back to true.

  • If the service object encounters an error while gathering or processing input, it queues an ErrorEvent event, which is delivered to the application when it sets the DataEventEnabled property to true.

  • The DataCount property may be read to obtain the number of DataEvent events currently queued by the service object.

  • All input queued by the service object can be deleted by calling the ClearInput method.

Device Sharing

The MSR is an exclusive-use device. Therefore:

  • The application must claim the device before enabling it.

  • The application must claim and enable the device before the device begins reading input, or before calling methods that manipulate the device.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.Msr
Microsoft.PointOfService.BasicServiceObjects.MsrBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Members
Microsoft.PointOfService Namespace


Msr Members

Msr Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a UPOS magnetic stripe reader (MSR) device.

The following tables list the members exposed by the Msr type.

Protected Constructors

Name | Description
Msr | Creates an instance of the Msr class.
Top

Public Fields

Name | Description
CardTypeAamva | Indicates the card type is AAMVA.
CardTypeBank | Indicates the card type is BANK.
ExtendedErrorDeviceAuthenticationFailed | Indicates an extended error where the device authentication process failed.
ExtendedErrorDeviceDeauthenticationFailed | Indicates an extended error where the device deauthentication failed.
ExtendedErrorEnd | Indicates an end sentinel error.
ExtendedErrorFailure | Indicates a general error.
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorLrc | Indicates an LRC error.
ExtendedErrorParity | Indicates a parity error.
ExtendedErrorStart | Indicates a start sentinel error.
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
ExtendedErrorSuccess | Indicates no error.
StatisticChallengeRequestCount | Contains the count of challenge requests.
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFailedCardAuthenticationDataCount | Contains the count of failed card authentication attempts.
StatisticFailedDeviceAuthenticationCount | Contains the count of failed device authentication attempts.
StatisticFailedReadCount | This is field contains the node name used in the POS.NET XML statistics file. The number of failed card reads is stored in this node.
StatisticFailedWriteCount | This is field contains a node name used in the POS.NET XML statistics file. The number of failed card writes is stored in this node.
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticGoodCardAuthenticationDataCount | Contains the count of successful card authentication attempts.
StatisticGoodDeviceAuthenticationCount | Contains the count of successful device authentication attempts.
StatisticGoodReadCount | This is field contains the node name used in the POS.NET XML statistics file. The number of successful card reads is stored in this node.
StatisticGoodWriteCount | This is field contains a node name used in the POS.NET XML statistics file. The number of successful card writes is stored in this node.
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticMissingStartSentinelTrack1Count | This is field contains a node name used in the POS.NET XML statistics file. The number of times the track 1 sentinel was found missing is stored in this node.
StatisticMissingStartSentinelTrack2Count | This is field contains a node name used in the POS.NET XML statistics file. The number of times the track 2 sentinel was found missing is stored in this node.
StatisticMissingStartSentinelTrack3Count | This is field contains a node name used in the POS.NET XML statistics file. The number of times the track 3 sentinel was found missing is stored in this node.
StatisticMissingStartSentinelTrack4Count | This is field contains a node name used in the POS.NET XML statistics file. The number of times the track 1 sentinel was found missing is stored in this node.
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticParityLrcErrorTrack1Count | This is field contains the node name used in the POS.NET XML statistics file. The number of parity errors for track 1 is stored in this node.
StatisticParityLrcErrorTrack2Count | This is field contains the node name used in the POS.NET XML statistics file. The number of parity errors for track 2 is stored in this node.
StatisticParityLrcErrorTrack3Count | This is field contains the node name used in the POS.NET XML statistics file. The number of parity errors for track 3 is stored in this node.
StatisticParityLrcErrorTrack4Count | This is field contains the node name used in the POS.NET XML statistics file. The number of parity errors for track 4 is stored in this node.
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatisticUnreadableCardCount | This is field contains the node name used in the POS.NET XML statistics file. The number of failed card reads is stored in this node.
StatusDeviceAuthenticated | Indicates if the device is authenticated.
StatusDeviceDeauthenticated | Indicates if the device is deauthenticated.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
AccountNumber | Holds the account number from the most recently swiped card.
AdditionalSecurityInformation | Gets additional security/encryption information when a DataEvent is delivered.
AutoDisable | Indicates whether POS for .NET automatically disables the device when data is received.
CapCardAuthentication | Gets the type, if any, of card authentication data that is supported by the device.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapDataEncryption | Gets a bitwise indication of the encryption algorithms supported by the device and is selectable via the DataEncryptionAlgorithm property.
CapDeviceAuthentication | Gets the level of device authentication supported by the service.
CapIso | If true, the MSR device supports ISO cards; otherwise it is false.
CapJisOne | If true, the MSR device supports JIS Type-I cards; otherwise it is false.
CapJisTwo | If true, the MSR device supports JIS Type-II cards; otherwise it is false.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapTrackDataMasking | Gets a Boolean value that indicates whether the service supports track data masking.
CapTransmitSentinels | If true, the MSR device can transmit start and end sentinels. If false, these characters cannot be returned to the application.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CapWritableTracks | Indicates if the MSR device supports the writing of track data, and which tracks are supported.
CardAuthenticationData | Gets the card authentication information when a DataEvent is delivered.
CardAuthenticationDataLength | Gets the length of the raw CardAuthenticationData before it is encrypted.
CardPropertyList | Gets a comma separated list of the names of the properties parsed from the most recently swiped card.
CardType | Gets the card type identifier for the most recently swiped card.
CardTypeList | Gets a comma separated list of string names of card types supported by the service.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
DataCount | Holds the number of data events currently queued by the service object.
DataEncryptionAlgorithm | Gets and sets the encryption algorithm that will be used to encrypt the track data.
DataEventEnabled | When set to true by the application, POS for .NET delivers the next event in the event queue.
DecodeData | If false, the Track1Data, Track2Data, Track3Data, and Track4Data properties contain the original encoded bit sequence, known as “raw format.”
DeviceAuthenticated | Gets a Boolean value that indicates whether the device supports authentication.
DeviceAuthenticationProtocol | Gets the device authentication protocol supported by the device.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
EncodingMaxLength | Holds the maximum length of data that can be written by the MSR to the track or tracks defined by the TracksToWrite property.
ErrorReportingType | Holds the type of error reporting the application wants to receive. Possible values are defined by the MsrErrorReporting enumeration.
ExpirationDate | Holds the expiration date from the most recently swiped card, as four ASCII decimal characters in the form YYMM. For example, February 1998 is “9802” and August 2018 is “1808”.
FirstName | Holds the first name from the most recently swiped card.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
MiddleInitial | Holds the middle initial from the most recently swiped card.
ParseDecodeData | If true, the decoded data contained within the Track1Data and Track2Data properties is further separated into fields for access via various other properties.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
ServiceCode | Holds the service code from the most recently swiped card.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
Suffix | Holds the suffix from the most recently swiped card.
Surname | Holds the surname from the most recently swiped card.
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Title | Holds the title from the most recently swiped card.
Track1Data | Holds either the Track 1 data from the most recently swiped card or an empty array.
Track1DiscretionaryData | Holds the Track 1 discretionary data from the most recently swiped card.
Track1EncryptedData | Gets the length of the raw Track1Data before it is encrypted.
Track1EncryptedDataLength | Gets the encrypted track 1 data obtained from the most recently swiped card.
Track2Data | Holds either the Track 2 data from the most recently swiped card or an empty array.
Track2DiscretionaryData | The Track 2 discretionary data from the most recently swiped card.
Track2EncryptedData | Holds the length of the raw Track2Data before it is encrypted.
Track2EncryptedDataLength | Gets the encrypted track 2 data obtained from the most recently swiped card.
Track3Data | Holds either the Track 3 data from the most recently swiped card or an empty array.
Track3EncryptedData | Gets the length of the raw Track3Data before it is encrypted.
Track3EncryptedDataLength | Gets the encrypted track 3 data obtained from the most recently swiped card.
Track4Data | Holds the Track 4 data (JIS-II) from the most recently swiped card.
Track4EncryptedData | Gets the encrypted track 4 data obtained from the most recently swiped card.
Track4EncryptedDataLength | Gets the length of the raw Track4Data before it is encrypted.
TracksToRead | Indicates the track data that the application wishes to place into the Track1Data, Track2Data, Track3Data and Track4Data properties following a card swipe.
TracksToWrite | Specifies which MSR tracks will be written when the WriteTracks method is called and an MSR card swiped.
TransmitSentinels | If true, the Track1Data, Track2Data, Track3Data, and Track4Data properties contain start sentinel and end sentinel values.
WriteCardType | Holds the card type to be used the next time the WriteTracks method is called.
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Indicates whether the Msr is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
AuthenticateDevice | Authenticates a device.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all device input that has been buffered.
ClearInputProperties | Resets the values of properties altered by DataEvent or ErrorEvent.
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DeauthenticateDevice | Deauthenticates a device that is currently in the authenticated state
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon)
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveCardProperty | Retrieves the value of specific parsed properties from the last card swiped.
RetrieveDeviceAuthenticationData | Applications call this method to retrieve a challenge token that will subsequently be used to generate response tokens that will be passed to the AuthenticateDevice and DeauthenticateDevice methods.
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateKey | Provides a new encryption key to the device.
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
WriteTracks | Initiates the encoding of data to the MSR track(s) selected in the TracksToWrite property.
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DataEvent | Raised by the service object to indicate the delivery of input data from the device to the application.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
ErrorEvent | Raised by the service object when an error is detected while trying to read MSR data.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

Msr Class
Microsoft.PointOfService Namespace


Msr Fields

Msr Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
CardTypeAamva | Indicates the card type is AAMVA.
CardTypeBank | Indicates the card type is BANK.
ExtendedErrorDeviceAuthenticationFailed | Indicates an extended error where the device authentication process failed.
ExtendedErrorDeviceDeauthenticationFailed | Indicates an extended error where the device deauthentication failed.
ExtendedErrorEnd | Indicates an end sentinel error.
ExtendedErrorFailure | Indicates a general error.
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorLrc | Indicates an LRC error.
ExtendedErrorParity | Indicates a parity error.
ExtendedErrorStart | Indicates a start sentinel error.
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
ExtendedErrorSuccess | Indicates no error.
StatisticChallengeRequestCount | Contains the count of challenge requests.
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFailedCardAuthenticationDataCount | Contains the count of failed card authentication attempts.
StatisticFailedDeviceAuthenticationCount | Contains the count of failed device authentication attempts.
StatisticFailedReadCount | This is field contains the node name used in the POS.NET XML statistics file. The number of failed card reads is stored in this node.
StatisticFailedWriteCount | This is field contains a node name used in the POS.NET XML statistics file. The number of failed card writes is stored in this node.
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticGoodCardAuthenticationDataCount | Contains the count of successful card authentication attempts.
StatisticGoodDeviceAuthenticationCount | Contains the count of successful device authentication attempts.
StatisticGoodReadCount | This is field contains the node name used in the POS.NET XML statistics file. The number of successful card reads is stored in this node.
StatisticGoodWriteCount | This is field contains a node name used in the POS.NET XML statistics file. The number of successful card writes is stored in this node.
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticMissingStartSentinelTrack1Count | This is field contains a node name used in the POS.NET XML statistics file. The number of times the track 1 sentinel was found missing is stored in this node.
StatisticMissingStartSentinelTrack2Count | This is field contains a node name used in the POS.NET XML statistics file. The number of times the track 2 sentinel was found missing is stored in this node.
StatisticMissingStartSentinelTrack3Count | This is field contains a node name used in the POS.NET XML statistics file. The number of times the track 3 sentinel was found missing is stored in this node.
StatisticMissingStartSentinelTrack4Count | This is field contains a node name used in the POS.NET XML statistics file. The number of times the track 1 sentinel was found missing is stored in this node.
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticParityLrcErrorTrack1Count | This is field contains the node name used in the POS.NET XML statistics file. The number of parity errors for track 1 is stored in this node.
StatisticParityLrcErrorTrack2Count | This is field contains the node name used in the POS.NET XML statistics file. The number of parity errors for track 2 is stored in this node.
StatisticParityLrcErrorTrack3Count | This is field contains the node name used in the POS.NET XML statistics file. The number of parity errors for track 3 is stored in this node.
StatisticParityLrcErrorTrack4Count | This is field contains the node name used in the POS.NET XML statistics file. The number of parity errors for track 4 is stored in this node.
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatisticUnreadableCardCount | This is field contains the node name used in the POS.NET XML statistics file. The number of failed card reads is stored in this node.
StatusDeviceAuthenticated | Indicates if the device is authenticated.
StatusDeviceDeauthenticated | Indicates if the device is deauthenticated.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

Msr Class
Microsoft.PointOfService Namespace


Msr.CardTypeAamva Field

Msr.CardTypeAamva Field |
 | See Also

1/18/2008

Indicates the card type is AAMVA.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const CardTypeAamva As String
public const string CardTypeAamva
public:
literal String^ CardTypeAamva
public static final String CardTypeAamva
public const var CardTypeAamva : String

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.CardTypeBank Field

Msr.CardTypeBank Field |
 | See Also

1/18/2008

Indicates the card type is BANK.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const CardTypeBank As String
public const string CardTypeBank
public:
literal String^ CardTypeBank
public static final String CardTypeBank
public const var CardTypeBank : String

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.ExtendedErrorDeviceAuthenticationFailed Field

Msr.ExtendedErrorDeviceAuthenticationFailed Field |
 | See Also

1/18/2008

Indicates an extended error where the device authentication process failed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorDeviceAuthenticationFailed As Integer
public const int ExtendedErrorDeviceAuthenticationFailed
public:
literal int ExtendedErrorDeviceAuthenticationFailed
public static final int ExtendedErrorDeviceAuthenticationFailed
public const var ExtendedErrorDeviceAuthenticationFailed : int

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.ExtendedErrorDeviceDeauthenticationFailed Field

Msr.ExtendedErrorDeviceDeauthenticationFailed Field |
 | See Also

1/18/2008

Indicates an extended error where the device deauthentication failed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorDeviceDeauthenticationFailed As Integer
public const int ExtendedErrorDeviceDeauthenticationFailed
public:
literal int ExtendedErrorDeviceDeauthenticationFailed
public static final int ExtendedErrorDeviceDeauthenticationFailed
public const var ExtendedErrorDeviceDeauthenticationFailed : int

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.ExtendedErrorEnd Field

Msr.ExtendedErrorEnd Field |
 | See Also

1/18/2008

Indicates an end sentinel error.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorEnd As Integer
public const int ExtendedErrorEnd
public:
literal int ExtendedErrorEnd
public static final int ExtendedErrorEnd
public const var ExtendedErrorEnd : int

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.ExtendedErrorFailure Field

Msr.ExtendedErrorFailure Field |
 | See Also

1/18/2008

Indicates a general error.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorFailure As Integer
public const int ExtendedErrorFailure
public:
literal int ExtendedErrorFailure
public static final int ExtendedErrorFailure
public const var ExtendedErrorFailure : int

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.ExtendedErrorLrc Field

Msr.ExtendedErrorLrc Field |
 | See Also

1/18/2008

Indicates an LRC error.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorLrc As Integer
public const int ExtendedErrorLrc
public:
literal int ExtendedErrorLrc
public static final int ExtendedErrorLrc
public const var ExtendedErrorLrc : int

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.ExtendedErrorParity Field

Msr.ExtendedErrorParity Field |
 | See Also

1/18/2008

Indicates a parity error.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorParity As Integer
public const int ExtendedErrorParity
public:
literal int ExtendedErrorParity
public static final int ExtendedErrorParity
public const var ExtendedErrorParity : int

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.ExtendedErrorStart Field

Msr.ExtendedErrorStart Field |
 | See Also

1/18/2008

Indicates a start sentinel error.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorStart As Integer
public const int ExtendedErrorStart
public:
literal int ExtendedErrorStart
public static final int ExtendedErrorStart
public const var ExtendedErrorStart : int

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.ExtendedErrorSuccess Field

Msr.ExtendedErrorSuccess Field |
 | See Also

1/18/2008

Indicates no error.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorSuccess As Integer
public const int ExtendedErrorSuccess
public:
literal int ExtendedErrorSuccess
public static final int ExtendedErrorSuccess
public const var ExtendedErrorSuccess : int

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.StatisticChallengeRequestCount Field

Msr.StatisticChallengeRequestCount Field |
 | See Also

1/18/2008

Contains the count of challenge requests.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticChallengeRequestCount As String
public const string StatisticChallengeRequestCount
public:
literal String^ StatisticChallengeRequestCount
public static final String StatisticChallengeRequestCount
public const var StatisticChallengeRequestCount : String

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.StatisticFailedCardAuthenticationDataCount Field

Msr.StatisticFailedCardAuthenticationDataCount Field |
 | See Also

1/18/2008

Contains the count of failed card authentication attempts.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticFailedCardAuthenticationDataCount As String
public const string StatisticFailedCardAuthenticationDataCount
public:
literal String^ StatisticFailedCardAuthenticationDataCount
public static final String StatisticFailedCardAuthenticationDataCount
public const var StatisticFailedCardAuthenticationDataCount : String

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.StatisticFailedDeviceAuthenticationCount Field

Msr.StatisticFailedDeviceAuthenticationCount Field |
 | See Also

1/18/2008

Contains the count of failed device authentication attempts.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticFailedDeviceAuthenticationCount As String
public const string StatisticFailedDeviceAuthenticationCount
public:
literal String^ StatisticFailedDeviceAuthenticationCount
public static final String StatisticFailedDeviceAuthenticationCount
public const var StatisticFailedDeviceAuthenticationCount : String

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.StatisticFailedReadCount Field

Msr.StatisticFailedReadCount Field |
 | See Also

1/18/2008

This is field contains the node name used in the POS.NET XML statistics file. The number of failed card reads is stored in this node.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticFailedReadCount As String
public const string StatisticFailedReadCount
public:
literal String^ StatisticFailedReadCount
public static final String StatisticFailedReadCount
public const var StatisticFailedReadCount : String

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.StatisticFailedWriteCount Field

Msr.StatisticFailedWriteCount Field |
 | See Also

1/18/2008

This is field contains a node name used in the POS.NET XML statistics file. The number of failed card writes is stored in this node.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticFailedWriteCount As String
public const string StatisticFailedWriteCount
public:
literal String^ StatisticFailedWriteCount
public static final String StatisticFailedWriteCount
public const var StatisticFailedWriteCount : String

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.StatisticGoodCardAuthenticationDataCount Field

Msr.StatisticGoodCardAuthenticationDataCount Field |
 | See Also

1/18/2008

Contains the count of successful card authentication attempts.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticGoodCardAuthenticationDataCount As String
public const string StatisticGoodCardAuthenticationDataCount
public:
literal String^ StatisticGoodCardAuthenticationDataCount
public static final String StatisticGoodCardAuthenticationDataCount
public const var StatisticGoodCardAuthenticationDataCount : String

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.StatisticGoodDeviceAuthenticationCount Field

Msr.StatisticGoodDeviceAuthenticationCount Field |
 | See Also

1/18/2008

Contains the count of successful device authentication attempts.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticGoodDeviceAuthenticationCount As String
public const string StatisticGoodDeviceAuthenticationCount
public:
literal String^ StatisticGoodDeviceAuthenticationCount
public static final String StatisticGoodDeviceAuthenticationCount
public const var StatisticGoodDeviceAuthenticationCount : String

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.StatisticGoodReadCount Field

Msr.StatisticGoodReadCount Field |
 | See Also

1/18/2008

This is field contains the node name used in the POS.NET XML statistics file. The number of successful card reads is stored in this node.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticGoodReadCount As String
public const string StatisticGoodReadCount
public:
literal String^ StatisticGoodReadCount
public static final String StatisticGoodReadCount
public const var StatisticGoodReadCount : String

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.StatisticGoodWriteCount Field

Msr.StatisticGoodWriteCount Field |
 | See Also

1/18/2008

This is field contains a node name used in the POS.NET XML statistics file. The number of successful card writes is stored in this node.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticGoodWriteCount As String
public const string StatisticGoodWriteCount
public:
literal String^ StatisticGoodWriteCount
public static final String StatisticGoodWriteCount
public const var StatisticGoodWriteCount : String

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.StatisticMissingStartSentinelTrack1Count Field

Msr.StatisticMissingStartSentinelTrack1Count Field |
 | See Also

1/18/2008

This is field contains a node name used in the POS.NET XML statistics file. The number of times the track 1 sentinel was found missing is stored in this node.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticMissingStartSentinelTrack1Count As String
public const string StatisticMissingStartSentinelTrack1Count
public:
literal String^ StatisticMissingStartSentinelTrack1Count
public static final String StatisticMissingStartSentinelTrack1Count
public const var StatisticMissingStartSentinelTrack1Count : String

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.StatisticMissingStartSentinelTrack2Count Field

Msr.StatisticMissingStartSentinelTrack2Count Field |
 | See Also

1/18/2008

This is field contains a node name used in the POS.NET XML statistics file. The number of times the track 2 sentinel was found missing is stored in this node.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticMissingStartSentinelTrack2Count As String
public const string StatisticMissingStartSentinelTrack2Count
public:
literal String^ StatisticMissingStartSentinelTrack2Count
public static final String StatisticMissingStartSentinelTrack2Count
public const var StatisticMissingStartSentinelTrack2Count : String

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.StatisticMissingStartSentinelTrack3Count Field

Msr.StatisticMissingStartSentinelTrack3Count Field |
 | See Also

1/18/2008

This is field contains a node name used in the POS.NET XML statistics file. The number of times the track 3 sentinel was found missing is stored in this node.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticMissingStartSentinelTrack3Count As String
public const string StatisticMissingStartSentinelTrack3Count
public:
literal String^ StatisticMissingStartSentinelTrack3Count
public static final String StatisticMissingStartSentinelTrack3Count
public const var StatisticMissingStartSentinelTrack3Count : String

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.StatisticMissingStartSentinelTrack4Count Field

Msr.StatisticMissingStartSentinelTrack4Count Field |
 | See Also

1/18/2008

This is field contains a node name used in the POS.NET XML statistics file. The number of times the track 1 sentinel was found missing is stored in this node.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticMissingStartSentinelTrack4Count As String
public const string StatisticMissingStartSentinelTrack4Count
public:
literal String^ StatisticMissingStartSentinelTrack4Count
public static final String StatisticMissingStartSentinelTrack4Count
public const var StatisticMissingStartSentinelTrack4Count : String

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.StatisticParityLrcErrorTrack1Count Field

Msr.StatisticParityLrcErrorTrack1Count Field |
 | See Also

1/18/2008

This is field contains the node name used in the POS.NET XML statistics file. The number of parity errors for track 1 is stored in this node.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticParityLrcErrorTrack1Count As String
public const string StatisticParityLrcErrorTrack1Count
public:
literal String^ StatisticParityLrcErrorTrack1Count
public static final String StatisticParityLrcErrorTrack1Count
public const var StatisticParityLrcErrorTrack1Count : String

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.StatisticParityLrcErrorTrack2Count Field

Msr.StatisticParityLrcErrorTrack2Count Field |
 | See Also

1/18/2008

This is field contains the node name used in the POS.NET XML statistics file. The number of parity errors for track 2 is stored in this node.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticParityLrcErrorTrack2Count As String
public const string StatisticParityLrcErrorTrack2Count
public:
literal String^ StatisticParityLrcErrorTrack2Count
public static final String StatisticParityLrcErrorTrack2Count
public const var StatisticParityLrcErrorTrack2Count : String

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.StatisticParityLrcErrorTrack3Count Field

Msr.StatisticParityLrcErrorTrack3Count Field |
 | See Also

1/18/2008

This is field contains the node name used in the POS.NET XML statistics file. The number of parity errors for track 3 is stored in this node.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticParityLrcErrorTrack3Count As String
public const string StatisticParityLrcErrorTrack3Count
public:
literal String^ StatisticParityLrcErrorTrack3Count
public static final String StatisticParityLrcErrorTrack3Count
public const var StatisticParityLrcErrorTrack3Count : String

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.StatisticParityLrcErrorTrack4Count Field

Msr.StatisticParityLrcErrorTrack4Count Field |
 | See Also

1/18/2008

This is field contains the node name used in the POS.NET XML statistics file. The number of parity errors for track 4 is stored in this node.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticParityLrcErrorTrack4Count As String
public const string StatisticParityLrcErrorTrack4Count
public:
literal String^ StatisticParityLrcErrorTrack4Count
public static final String StatisticParityLrcErrorTrack4Count
public const var StatisticParityLrcErrorTrack4Count : String

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.StatisticUnreadableCardCount Field

Msr.StatisticUnreadableCardCount Field |
 | See Also

1/18/2008

This is field contains the node name used in the POS.NET XML statistics file. The number of failed card reads is stored in this node.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticUnreadableCardCount As String
public const string StatisticUnreadableCardCount
public:
literal String^ StatisticUnreadableCardCount
public static final String StatisticUnreadableCardCount
public const var StatisticUnreadableCardCount : String

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.StatusDeviceAuthenticated Field

Msr.StatusDeviceAuthenticated Field |
 | See Also

1/18/2008

Indicates if the device is authenticated.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusDeviceAuthenticated As Integer
public const int StatusDeviceAuthenticated
public:
literal int StatusDeviceAuthenticated
public static final int StatusDeviceAuthenticated
public const var StatusDeviceAuthenticated : int

Remarks

If the device supports authentication (CapDeviceAuthentication not equal to NotSupported) the service must keep the value of this property up to date when the device is enabled.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.StatusDeviceDeauthenticated Field

Msr.StatusDeviceDeauthenticated Field |
 | See Also

1/18/2008

Indicates if the device is deauthenticated.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusDeviceDeauthenticated As Integer
public const int StatusDeviceDeauthenticated
public:
literal int StatusDeviceDeauthenticated
public static final int StatusDeviceDeauthenticated
public const var StatusDeviceDeauthenticated : int

Remarks

If the device supports authentication (CapDeviceAuthentication not equal to NotSupported) the service must keep the value of this property up to date when the device is enabled.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr Constructor

Msr Constructor |
 | See Also

1/18/2008

Creates an instance of the Msr class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected Msr ()
protected:
Msr ()
protected Msr ()
protected function Msr ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr Methods

Msr Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
AuthenticateDevice | Authenticates a device.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all device input that has been buffered.
ClearInputProperties | Resets the values of properties altered by DataEvent or ErrorEvent.
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DeauthenticateDevice | Deauthenticates a device that is currently in the authenticated state
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon )
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveCardProperty | Retrieves the value of specific parsed properties from the last card swiped.
RetrieveDeviceAuthenticationData | Applications call this method to retrieve a challenge token that will subsequently be used to generate response tokens that will be passed to the AuthenticateDevice and DeauthenticateDevice methods.
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateKey | Provides a new encryption key to the device.
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
WriteTracks | Initiates the encoding of data to the MSR track(s) selected in the TracksToWrite property.

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

Msr Class
Microsoft.PointOfService Namespace


Msr.AuthenticateDevice Method

Msr.AuthenticateDevice Method |
 | See Also

1/18/2008

Authenticates a device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Sub AuthenticateDevice ( _
    responseToken As Byte() _
)
public virtual void AuthenticateDevice (
    byte[] responseToken
)
public:
virtual void AuthenticateDevice (
    array<unsigned char>^ responseToken
)
public void AuthenticateDevice (
    byte[] responseToken
)
public function AuthenticateDevice (
    responseToken : byte[]
)

Parameters

responseToken

A response token generated from the challenge token retrieved from a previous call to the RetrieveDeviceAuthenticationData method.

Remarks

To authenticate a device, the application first calls the RetrieveDeviceAuthenticationData method to retrieve a challenge token from the device. The application then typically passes this token to another entity that has special knowledge of a shared secret and is able to create a proper response token. This response token is then passed as the response parameter to this method and the service uses it to validate the authentication request. If this method succeeds, the device enters the authenticated state and the service sets the DeviceAuthenticated property to true.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.ClearInput Method

Msr.ClearInput Method |
 | See Also

1/18/2008

Clears all device input that has been buffered.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearInput
public abstract void ClearInput ()
public:
virtual void ClearInput () abstract
public abstract void ClearInput ()
public abstract function ClearInput ()

Remarks

Any data events or input error events that were queued by the service object– usually waiting for DataEventEnabled to be set to true and FreezeEvents to be set to false – are also cleared.

ClearInput may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Claimed | The device is claimed by another application.
NotClaimed | The device must be claimed before ClearInput can be used.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace
FreezeEvents
DataEventEnabled


Msr.ClearInputProperties Method

Msr.ClearInputProperties Method |
 | See Also

1/18/2008

Resets the values of properties altered by DataEvent or ErrorEvent.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Sub ClearInputProperties
public virtual void ClearInputProperties ()
public:
virtual void ClearInputProperties ()
public void ClearInputProperties ()
public function ClearInputProperties ()

Remarks

Sets all data properties populated by a firing of DataEvent or ErrorEvent back to their default values. This does not reset the DataCount or State properties.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.DeauthenticateDevice Method

Msr.DeauthenticateDevice Method |
 | See Also

1/18/2008

Deauthenticates a device that is currently in the authenticated state

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Sub DeauthenticateDevice ( _
    responseToken As Byte() _
)
public virtual void DeauthenticateDevice (
    byte[] responseToken
)
public:
virtual void DeauthenticateDevice (
    array<unsigned char>^ responseToken
)
public void DeauthenticateDevice (
    byte[] responseToken
)
public function DeauthenticateDevice (
    responseToken : byte[]
)

Parameters

responseToken

A response token generated from the challenge token retrieved from a previous call to the RetrieveDeviceAuthenticationData method.

Remarks

A device that is currently authenticated implies that DeviceAuthenticated is set to true.

The token is typically generated by passing the challenge retrieved from the RetrieveDeviceAuthenticationData method to an entity that has special knowledge of a shared secret. If this method succeeds the service sets DeviceAuthenticated to false and queues a StatusUpdateEvent with status value set to StatusDeviceDeauthenticated.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.RetrieveCardProperty Method

Msr.RetrieveCardProperty Method |
 | See Also

1/18/2008

Retrieves the value of specific parsed properties from the last card swiped.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Function RetrieveCardProperty ( _
    name As String _
) As String
public virtual string RetrieveCardProperty (
    string name
)
public:
virtual String^ RetrieveCardProperty (
    String^ name
)
public String RetrieveCardProperty (
    String name
)
public function RetrieveCardProperty (
    name : String
) : String

Parameters

name

Name of the property whose value is to be retrieved. The CardPropertyList property can be parsed to determine the set of valid properties for the most recently swiped card.

Remarks

Until a card is swiped, all defined properties will return an empty string.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.RetrieveDeviceAuthenticationData Method

Msr.RetrieveDeviceAuthenticationData Method |
 | See Also

1/18/2008

Applications call this method to retrieve a challenge token that will subsequently be used to generate response tokens that will be passed to the AuthenticateDevice and DeauthenticateDevice methods.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Function RetrieveDeviceAuthenticationData As Byte()
public virtual byte[] RetrieveDeviceAuthenticationData ()
public:
virtual array<unsigned char>^ RetrieveDeviceAuthenticationData ()
public byte[] RetrieveDeviceAuthenticationData ()
public function RetrieveDeviceAuthenticationData () : byte[]

Remarks

The challenge token is typically sent to another entity that has special knowledge of a shared secret that is required to generate the proper response token(s).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.UpdateKey Method

Msr.UpdateKey Method |
 | See Also

1/18/2008

Provides a new encryption key to the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Sub UpdateKey ( _
    key As String, _
    keyName As String _
)
public virtual void UpdateKey (
    string key,
    string keyName
)
public:
virtual void UpdateKey (
    String^ key,
    String^ keyName
)
public void UpdateKey (
    String key,
    String keyName
)
public function UpdateKey (
    key : String,
    keyName : String
)

Parameters

key

A Hex-ASCII value for a new key.

keyName

A name used to identify the key.

Remarks

UpdateKey used only for those encryption algorithms in which new key values are sent to the terminal as a field in standard messages from the host.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.WriteTracks Method

Msr.WriteTracks Method |
 | See Also

1/18/2008

Initiates the encoding of data to the MSR track(s) selected in the TracksToWrite property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Sub WriteTracks ( _
    track1Data As Byte(), _
    track2Data As Byte(), _
    track3Data As Byte(), _
    track4Data As Byte(), _
    timeout As Integer _
)
public virtual void WriteTracks (
    byte[] track1Data,
    byte[] track2Data,
    byte[] track3Data,
    byte[] track4Data,
    int timeout
)
public:
virtual void WriteTracks (
    array<unsigned char>^ track1Data,
    array<unsigned char>^ track2Data,
    array<unsigned char>^ track3Data,
    array<unsigned char>^ track4Data,
    int timeout
)
public void WriteTracks (
    byte[] track1Data,
    byte[] track2Data,
    byte[] track3Data,
    byte[] track4Data,
    int timeout
)
public function WriteTracks (
    track1Data : byte[],
    track2Data : byte[],
    track3Data : byte[],
    track4Data : byte[],
    timeout : int
)

Parameters

track1Data

The first data track.

track2Data

The second data track.

track3Data

The third data track.

track4Data

The fourth data track.

timeout

The number of milliseconds before failing the method. If -1, the method waits as long as need before the card is swiped.

Remarks

When called, data is prepared to be written on to the next card that is swiped within the allotted timeout period. If no card is swiped within the timeout period then an Exception is thrown.

Data that is written to the card is read back from the card in the exact same format, the Service must not decode/encode the data in any fashion.

This method is always performed synchronously, so that the write will be attempted to the next card that is swiped.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace
TracksToWrite
EncodingMaxLength


Msr Properties

Msr Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
AccountNumber | Holds the account number from the most recently swiped card.
AdditionalSecurityInformation | Gets additional security/encryption information when a DataEvent is delivered.
AutoDisable | Indicates whether POS for .NET automatically disables the device when data is received.
CapCardAuthentication | Gets the type, if any, of card authentication data that is supported by the device.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapDataEncryption | Gets a bitwise indication of the encryption algorithms supported by the device and is selectable via the DataEncryptionAlgorithm property.
CapDeviceAuthentication | Gets the level of device authentication supported by the service.
CapIso | If true, the MSR device supports ISO cards; otherwise it is false.
CapJisOne | If true, the MSR device supports JIS Type-I cards; otherwise it is false.
CapJisTwo | If true, the MSR device supports JIS Type-II cards; otherwise it is false.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapTrackDataMasking | Gets a Boolean value that indicates whether the service supports track data masking.
CapTransmitSentinels | If true, the MSR device can transmit start and end sentinels. If false, these characters cannot be returned to the application.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CapWritableTracks | Indicates if the MSR device supports the writing of track data, and which tracks are supported.
CardAuthenticationData | Gets the card authentication information when a DataEvent is delivered.
CardAuthenticationDataLength | Gets the length of the raw CardAuthenticationData before it is encrypted.
CardPropertyList | Gets a comma separated list of the names of the properties parsed from the most recently swiped card.
CardType | Gets the card type identifier for the most recently swiped card.
CardTypeList | Gets a comma separated list of string names of card types supported by the service.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
DataCount | Holds the number of data events currently queued by the service object.
DataEncryptionAlgorithm | Gets and sets the encryption algorithm that will be used to encrypt the track data.
DataEventEnabled | When set to true by the application, POS for .NET delivers the next event in the event queue.
DecodeData | If false, the Track1Data, Track2Data, Track3Data, and Track4Data properties contain the original encoded bit sequence, known as “raw format.”
DeviceAuthenticated | Gets a Boolean value that indicates whether the device supports authentication.
DeviceAuthenticationProtocol | Gets the device authentication protocol supported by the device.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
EncodingMaxLength | Holds the maximum length of data that can be written by the MSR to the track or tracks defined by the TracksToWrite property.
ErrorReportingType | Holds the type of error reporting the application wants to receive. Possible values are defined by the MsrErrorReporting enumeration.
ExpirationDate | Holds the expiration date from the most recently swiped card, as four ASCII decimal characters in the form YYMM. For example, February 1998 is “9802” and August 2018 is “1808”.
FirstName | Holds the first name from the most recently swiped card.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
MiddleInitial | Holds the middle initial from the most recently swiped card.
ParseDecodeData | If true, the decoded data contained within the Track1Data and Track2Data properties is further separated into fields for access via various other properties.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
ServiceCode | Holds the service code from the most recently swiped card.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
Suffix | Holds the suffix from the most recently swiped card.
Surname | Holds the surname from the most recently swiped card.
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )
Title | Holds the title from the most recently swiped card.
Track1Data | Holds either the Track 1 data from the most recently swiped card or an empty array.
Track1DiscretionaryData | Holds the Track 1 discretionary data from the most recently swiped card.
Track1EncryptedData | Gets the length of the raw Track1Data before it is encrypted.
Track1EncryptedDataLength | Gets the encrypted track 1 data obtained from the most recently swiped card.
Track2Data | Holds either the Track 2 data from the most recently swiped card or an empty array.
Track2DiscretionaryData | The Track 2 discretionary data from the most recently swiped card.
Track2EncryptedData | Holds the length of the raw Track2Data before it is encrypted.
Track2EncryptedDataLength | Gets the encrypted track 2 data obtained from the most recently swiped card.
Track3Data | Holds either the Track 3 data from the most recently swiped card or an empty array.
Track3EncryptedData | Gets the length of the raw Track3Data before it is encrypted.
Track3EncryptedDataLength | Gets the encrypted track 3 data obtained from the most recently swiped card.
Track4Data | Holds the Track 4 data (JIS-II) from the most recently swiped card.
Track4EncryptedData | Gets the encrypted track 4 data obtained from the most recently swiped card.
Track4EncryptedDataLength | Gets the length of the raw Track4Data before it is encrypted.
TracksToRead | Indicates the track data that the application wishes to place into the Track1Data, Track2Data, Track3Data and Track4Data properties following a card swipe.
TracksToWrite | Specifies which MSR tracks will be written when the WriteTracks method is called and an MSR card swiped.
TransmitSentinels | If true, the Track1Data, Track2Data, Track3Data, and Track4Data properties contain start sentinel and end sentinel values.
WriteCardType | Holds the card type to be used the next time the WriteTracks method is called.

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Indicates whether the Msr is an exclusive-use device.

See Also

Reference

Msr Class
Microsoft.PointOfService Namespace


Msr.AccountNumber Property

Msr.AccountNumber Property |
 | See Also

1/18/2008

Holds the account number from the most recently swiped card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property AccountNumber As String
public abstract string AccountNumber { get; }
public:
virtual property String^ AccountNumber {
    String^ get () abstract;
}
/** @property */
public abstract String get_AccountNumber ()

public abstract function get AccountNumber () : String

Remarks

AccountNumber is set to an empty string under the following conditions:

  • The field was not included in the track data read; or

  • The ParseDecodeData property is set to true, but AccountNumber is not included in the separated fields of the Track1Data or Track2Data properties; or

  • ParseDecodeData is set to false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace
ParseDecodeData
Track1Data
Track2Data


Msr.AdditionalSecurityInformation Property

Msr.AdditionalSecurityInformation Property |
 | See Also

1/18/2008

Gets additional security/encryption information when a DataEvent is delivered.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property AdditionalSecurityInformation As Byte()
public virtual byte[] AdditionalSecurityInformation { get; }
public:
virtual property array<unsigned char>^ AdditionalSecurityInformation {
    array<unsigned char>^ get ();
}
/** @property */
public byte[] get_AdditionalSecurityInformation ()

public function get AdditionalSecurityInformation () : byte[]

Remarks

The information content and internal format of this property will vary among encryption algorithms. For example, if the encryption algorithm is DUKPT, then this property will contain the “DUKPT sequence number”. If the selected encryption algorithm does not require this property, its value will be set to empty.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.AutoDisable Property

Msr.AutoDisable Property |
 | See Also

1/18/2008

Indicates whether POS for .NET automatically disables the device when data is received.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AutoDisable As Boolean
public abstract bool AutoDisable { get; set; }
public:
virtual property bool AutoDisable {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_AutoDisable ()

/** @property */
public abstract void set_AutoDisable (boolean value)

public abstract function get AutoDisable () : boolean

public abstract function set AutoDisable (value : boolean)

Remarks

AutoDisable provides the application with an additional option for controlling the receipt of input data. If the application wants to receive and process only one input, or only one input at a time, then this property can be set to true.

When true, the service object sets the DeviceEnabled property to false as soon as it receives and queues data to be raised as a DataEvent. Before the service object raises any subsequent events, the application must set DeviceEnabled back to true.

When false, the service object does not automatically disable the device when data is received; instead, it relies on the application to set the value of the DeviceEnabled property.

AutoDisable is typically initialized to false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace
DeviceEnabled
DataEvent


Msr.CapCardAuthentication Property

Msr.CapCardAuthentication Property |
 | See Also

1/18/2008

Gets the type, if any, of card authentication data that is supported by the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CapCardAuthentication As String
public virtual string CapCardAuthentication { get; }
public:
virtual property String^ CapCardAuthentication {
    String^ get ();
}
/** @property */
public String get_CapCardAuthentication ()

public function get CapCardAuthentication () : String

Remarks

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.CapDataEncryption Property

Msr.CapDataEncryption Property |
 | See Also

1/18/2008

Gets a bitwise indication of the encryption algorithms supported by the device and is selectable via the DataEncryptionAlgorithm property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CapDataEncryption As EncryptionAlgorithm
public virtual EncryptionAlgorithm CapDataEncryption { get; }
public:
virtual property EncryptionAlgorithm CapDataEncryption {
    EncryptionAlgorithm get ();
}
/** @property */
public EncryptionAlgorithm get_CapDataEncryption ()

public function get CapDataEncryption () : EncryptionAlgorithm

Remarks

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.CapDeviceAuthentication Property

Msr.CapDeviceAuthentication Property |
 | See Also

1/18/2008

Gets the level of device authentication supported by the service.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CapDeviceAuthentication As DeviceAuthenticationLevel
public virtual DeviceAuthenticationLevel CapDeviceAuthentication { get; }
public:
virtual property DeviceAuthenticationLevel CapDeviceAuthentication {
    DeviceAuthenticationLevel get ();
}
/** @property */
public DeviceAuthenticationLevel get_CapDeviceAuthentication ()

public function get CapDeviceAuthentication () : DeviceAuthenticationLevel

Remarks

If device authentication is supported the service must keep the value of DeviceAuthenticated current when the device is enabled. The service should also queue a StatusUpdateEvent with status value set to StatusDeviceAuthenticated or StatusDeviceDeauthenticated when the authentication status changes.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.CapIso Property

Msr.CapIso Property |
 | See Also

1/18/2008

If true, the MSR device supports ISO cards; otherwise it is false.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapIso As Boolean
public abstract bool CapIso { get; }
public:
virtual property bool CapIso {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapIso ()

public abstract function get CapIso () : boolean

Remarks

CapIso is updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.CapJisOne Property

Msr.CapJisOne Property |
 | See Also

1/18/2008

If true, the MSR device supports JIS Type-I cards; otherwise it is false.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapJisOne As Boolean
public abstract bool CapJisOne { get; }
public:
virtual property bool CapJisOne {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapJisOne ()

public abstract function get CapJisOne () : boolean

Remarks

JIS-I cards are a superset of ISO cards. Therefore, if CapJISOne is set to true, then it is implied that the CapIso property is also true.

CapJisOne is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace
Msr.CapIso Property


Msr.CapJisTwo Property

Msr.CapJisTwo Property |
 | See Also

1/18/2008

If true, the MSR device supports JIS Type-II cards; otherwise it is false.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapJisTwo As Boolean
public abstract bool CapJisTwo { get; }
public:
virtual property bool CapJisTwo {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapJisTwo ()

public abstract function get CapJisTwo () : boolean

Remarks

CapJisTwo is typically initialized to false. The service object should then set CapJisTwo based on the capability of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.CapTrackDataMasking Property

Msr.CapTrackDataMasking Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the service supports track data masking.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CapTrackDataMasking As Boolean
public virtual bool CapTrackDataMasking { get; }
public:
virtual property bool CapTrackDataMasking {
    bool get ();
}
/** @property */
public boolean get_CapTrackDataMasking ()

public function get CapTrackDataMasking () : boolean

Remarks

The Boolean value of true indicates that the service supports track data masking. CapTrackDataMasking can be true only if the device supports data encryption.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.CapTransmitSentinels Property

Msr.CapTransmitSentinels Property |
 | See Also

1/18/2008

If true, the MSR device can transmit start and end sentinels. If false, these characters cannot be returned to the application.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapTransmitSentinels As Boolean
public abstract bool CapTransmitSentinels { get; }
public:
virtual property bool CapTransmitSentinels {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapTransmitSentinels ()

public abstract function get CapTransmitSentinels () : boolean

Remarks

CapTransmitSentinels is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace
TransmitSentinels


Msr.CapWritableTracks Property

Msr.CapWritableTracks Property |
 | See Also Example

1/18/2008

Indicates if the MSR device supports the writing of track data, and which tracks are supported.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CapWritableTracks As MsrTracks
public virtual MsrTracks CapWritableTracks { get; }
public:
virtual property MsrTracks CapWritableTracks {
    MsrTracks get ();
}
/** @property */
public MsrTracks get_CapWritableTracks ()

public function get CapWritableTracks () : MsrTracks

Remarks

This capability indicates if the MSR device supports the writing of track data - and which tracks are supported - or if this functionality is not supported.

For example, if set to Tracks123 then the MSR device supports writing to tracks 1, 2, and 3; if set to None, then writing to MSR tracks is not supported. Possible values are listed below:

Value | Meaning
None | The MSR does not support writing track data.
Tracks1 | Track 1 is writable.
Tracks2 | Track 2 is writable.
Tracks3 | Track 3 is writable.
Tracks12 | Tracks 1 and 2 are writable.
Tracks13 | Tracks 1 and 3 are writable.
Tracks23 | Tracks 2 and 3 are writable.
Tracks123 | Tracks 1, 2, and 3 are writable.
Tracks4 | Track 4 is writable.
Tracks14 | Tracks 1 and 4 are writable.
Tracks24 | Tracks 2 and 4 are writable.
Tracks34 | Tracks 3 and 4 are writable.
Tracks124 | Tracks 1, 2, and 4 are writable.
Tracks134 | Tracks 1, 3, and 4 are writable.
Tracks234 | Tracks 2, 3, and 4 are writable.
Tracks1234 | All four tracks are writable.

Example

TracksToWrite

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.CardAuthenticationData Property

Msr.CardAuthenticationData Property |
 | See Also

1/18/2008

Gets the card authentication information when a DataEvent is delivered.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CardAuthenticationData As Byte()
public virtual byte[] CardAuthenticationData { get; }
public:
virtual property array<unsigned char>^ CardAuthenticationData {
    array<unsigned char>^ get ();
}
/** @property */
public byte[] get_CardAuthenticationData ()

public function get CardAuthenticationData () : byte[]

Remarks

The information content and internal format of this property will vary among services and depends on the value of the CapCardAuthentication property. This property will be empty if CapCardAuthentication is None. The value of this property will be encrypted via the encryption algorithm contained in the DataEncryptionAlgorithm property. The length of the raw (unencrypted) value of this property is contained in the CardAuthenticationDataLength property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.CardAuthenticationDataLength Property

Msr.CardAuthenticationDataLength Property |
 | See Also

1/18/2008

Gets the length of the raw CardAuthenticationData before it is encrypted.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CardAuthenticationDataLength As Integer
public virtual int CardAuthenticationDataLength { get; }
public:
virtual property int CardAuthenticationDataLength {
    int get ();
}
/** @property */
public int get_CardAuthenticationDataLength ()

public function get CardAuthenticationDataLength () : int

Remarks

Many encryption algorithms require padding of the input data before it can be encrypted. This property contains the length of the original unpadded data before it is encrypted. It may be needed to restore the original data after decryption.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.CardPropertyList Property

Msr.CardPropertyList Property |
 | See Also

1/18/2008

Gets a comma separated list of the names of the properties parsed from the most recently swiped card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CardPropertyList As ReadOnlyCollection(Of String)
public virtual ReadOnlyCollection<string> CardPropertyList { get; }
public:
virtual property ReadOnlyCollection<String^>^ CardPropertyList {
    ReadOnlyCollection<String^>^ get ();
}
/** @property */
public ReadOnlyCollection<String> get_CardPropertyList ()

public function get CardPropertyList () : ReadOnlyCollection<String>

Remarks

This property is initialized to an empty string if the type of card swiped was not recognized or ParseDecodeData is false.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.CardType Property

Msr.CardType Property |
 | See Also

1/18/2008

Gets the card type identifier for the most recently swiped card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CardType As String
public virtual string CardType { get; }
public:
virtual property String^ CardType {
    String^ get ();
}
/** @property */
public String get_CardType ()

public function get CardType () : String

Remarks

If the card's format is not recognized, this property will be empty. If this property's value begins with an underscore ('_'), the card type is vendor specific. If this property does not begin with an underscore, the card type is one of the standard card types.

The two currently defined standard card types are "BANK" and "AAMVA."

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.CardTypeList Property

Msr.CardTypeList Property |
 | See Also

1/18/2008

Gets a comma separated list of string names of card types supported by the service.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CardTypeList As ReadOnlyCollection(Of String)
public virtual ReadOnlyCollection<string> CardTypeList { get; }
public:
virtual property ReadOnlyCollection<String^>^ CardTypeList {
    ReadOnlyCollection<String^>^ get ();
}
/** @property */
public ReadOnlyCollection<String> get_CardTypeList ()

public function get CardTypeList () : ReadOnlyCollection<String>

Remarks

The vendor is allowed to support non-standard card type by specifying names beginning with an underscore ('_'). All names not beginning with an underscore are considered to be standard card types.

The two currently defined standard card types are "BANK" and "AAMVA."

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.DataCount Property

Msr.DataCount Property |
 | See Also

1/18/2008

Holds the number of data events currently queued by the service object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DataCount As Integer
public abstract int DataCount { get; }
public:
virtual property int DataCount {
    int get () abstract;
}
/** @property */
public abstract int get_DataCount ()

public abstract function get DataCount () : int

Remarks

The application can read DataCount to determine whether additional input is queued from a device but has not yet been delivered (because of other application processing, freezing of events, or other causes).

DataCount is typically initialized to 0 (zero).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace
DataEvent


Msr.DataEncryptionAlgorithm Property

Msr.DataEncryptionAlgorithm Property |
 | See Also

1/18/2008

Gets and sets the encryption algorithm that will be used to encrypt the track data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Property DataEncryptionAlgorithm As EncryptionAlgorithm
public virtual EncryptionAlgorithm DataEncryptionAlgorithm { get; set; }
public:
virtual property EncryptionAlgorithm DataEncryptionAlgorithm {
    EncryptionAlgorithm get ();
    void set (EncryptionAlgorithm value);
}
/** @property */
public EncryptionAlgorithm get_DataEncryptionAlgorithm ()

/** @property */
public void set_DataEncryptionAlgorithm (EncryptionAlgorithm value)

public function get DataEncryptionAlgorithm () : EncryptionAlgorithm

public function set DataEncryptionAlgorithm (value : EncryptionAlgorithm)

Remarks

This property may be set to any of the supported encryption algorithms as defined in the CapDataEncryption property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.DataEventEnabled Property

Msr.DataEventEnabled Property |
 | See Also

1/18/2008

When set to true by the application, POS for .NET delivers the next event in the event queue.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property DataEventEnabled As Boolean
public abstract bool DataEventEnabled { get; set; }
public:
virtual property bool DataEventEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_DataEventEnabled ()

/** @property */
public abstract void set_DataEventEnabled (boolean value)

public abstract function get DataEventEnabled () : boolean

public abstract function set DataEventEnabled (value : boolean)

Remarks

Note that conditions may exist that delay “immediate” delivery: If the FreezeEvents property is set to true, or if the AutoDisable property is set to true and the DeviceEnabled property is set to false.

When DataEventEnabled is set to false by the application, the service object queues data for later delivery to the application.

Note: If an error occurs during input processing, the service object queues the error event, but POS for .NET doesn’t deliver it until the application sets DataEventEnabled to true.

DataEventEnabled is typically initialized to false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace
Msr.AutoDisable Property
DataEvent
FreezeEvents
DeviceEnabled


Msr.DecodeData Property

Msr.DecodeData Property |
 | See Also

1/18/2008

If false, the Track1Data, Track2Data, Track3Data, and Track4Data properties contain the original encoded bit sequence, known as “raw format.”

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property DecodeData As Boolean
public abstract bool DecodeData { get; set; }
public:
virtual property bool DecodeData {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_DecodeData ()

/** @property */
public abstract void set_DecodeData (boolean value)

public abstract function get DecodeData () : boolean

public abstract function set DecodeData (value : boolean)

Remarks

If true, each byte of track data contained within the Track1Data, Track2Data, Track3Data, and Track4Data properties is mapped from its raw format to its corresponding decoded ASCII bit sequence. This conversion is mainly of relevance for data that is not of the 7-bit format, since 7-bit data needs no decoding to decipher its corresponding alphanumeric and/or Katakana characters.

This table describes the decoding that takes place:

Card Type | Track Data Property | Data Format | Raw Bytes | Decoded Bytes
ISO | Track1Data | 6-Bit | 0x00 - 0x3F | 0x20 - 0x5F
 | Track2Data | 4-Bit | 0x00 - 0x0F | 0x30 - 0x3F
 | Track3Data | 4-Bit | 0x00 - 0x0F | 0x30 - 0x3F
JIS-I | Track1Data | 6-Bit | 0x00 - 0x3F | 0x20 - 0x5F
 | Track1Data | 7-Bit | 0x00 - 0x7F | Unchanged
 | Track2Data | 4-Bit | 0x00 - 0x0F | 0x30 - 0x3F
 | Track3Data | 4-Bit | 0x00 - 0x0F | 0x30 - 0x3F
 | Track3Data | 7-Bit | 0x00 - 0x7F | Unchanged
JIS-II | Track4Data | 7-Bit | 0x00 - 0x7F | Unchanged

DecodeData is typically initialized to true.

Setting DecodeData to false automatically sets the ParseDecodeData property to false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace
ParseDecodeData
Track1Data
Track2Data
Track3Data
Track4Data


Msr.DeviceAuthenticated Property

Msr.DeviceAuthenticated Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device supports authentication.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property DeviceAuthenticated As Boolean
public virtual bool DeviceAuthenticated { get; }
public:
virtual property bool DeviceAuthenticated {
    bool get ();
}
/** @property */
public boolean get_DeviceAuthenticated ()

public function get DeviceAuthenticated () : boolean

Remarks

The Boolean value of true indicates that the device supports authentication.

If the device supports authentication, the service must keep the value of this property up to date when the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.DeviceAuthenticationProtocol Property

Msr.DeviceAuthenticationProtocol Property |
 | See Also

1/18/2008

Gets the device authentication protocol supported by the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property DeviceAuthenticationProtocol As DeviceAuthenticationProtocol
public virtual DeviceAuthenticationProtocol DeviceAuthenticationProtocol { get; }
public:
virtual property DeviceAuthenticationProtocol DeviceAuthenticationProtocol {
    DeviceAuthenticationProtocol get ();
}
/** @property */
public DeviceAuthenticationProtocol get_DeviceAuthenticationProtocol ()

public function get DeviceAuthenticationProtocol () : DeviceAuthenticationProtocol

Remarks

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.EncodingMaxLength Property

Msr.EncodingMaxLength Property |
 | See Also Example

1/18/2008

Holds the maximum length of data that can be written by the MSR to the track or tracks defined by the TracksToWrite property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property EncodingMaxLength As Integer
public virtual int EncodingMaxLength { get; }
public:
virtual property int EncodingMaxLength {
    int get ();
}
/** @property */
public int get_EncodingMaxLength ()

public function get EncodingMaxLength () : int

Remarks

The maximum length of data that can be written by the MSR to the track or tracks defined by the TracksToWrite property. If multiple tracks are selected in the TracksToWrite property, the length of the shortest track should be reflected by this property.

This property is initialized to zero by the :Microsoft.PointOfService.PosCommon.Open method.

Example

TracksToWrite

WriteTracks

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.ErrorReportingType Property

Msr.ErrorReportingType Property |
 | See Also

1/18/2008

Holds the type of error reporting the application wants to receive. Possible values are defined by the MsrErrorReporting enumeration.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property ErrorReportingType As MsrErrorReporting
public abstract MsrErrorReporting ErrorReportingType { get; set; }
public:
virtual property MsrErrorReporting ErrorReportingType {
    MsrErrorReporting get () abstract;
    void set (MsrErrorReporting value) abstract;
}
/** @property */
public abstract MsrErrorReporting get_ErrorReportingType ()

/** @property */
public abstract void set_ErrorReportingType (MsrErrorReporting value)

public abstract function get ErrorReportingType () : MsrErrorReporting

public abstract function set ErrorReportingType (value : MsrErrorReporting)

Remarks

The service object reports an error by means of an ErrorEvent when a card is swiped and one or more of the tracks specified by the TracksToRead property contains data with errors. When the ErrorEvent event is raised by the service object to the application, two types of error reporting are supported:

  • Card level: A general error status is given, with no data returned.

    The service object should use this level when a simple pass/fail of the card data is sufficient.

  • Track level: The service object can return an extended status with a separate status for each of the tracks. Also, for those tracks that contain valid data or no data, the track’s properties are updated as with a DataEvent. For those tracks that contain invalid data, the track’s properties are set to empty.

    The service object should use this level when the application may be able to utilize a successfully read track or tracks even though another of the tracks contains errors.

    For example, suppose TracksToRead is set to Tracks123, and a swiped card contains good track 1 and 2 data, but track 3 contains “random noise” that is flagged as an error by the MSR device. With track-level error reporting, the service object sets the track 1 and 2 properties with the valid data, sets the track 3 properties to empty, and returns an error code indicating the status of each track.

ErrorReportingType is typically initialized to MsrErrorReporting.Card. The application should then set ErrorReportingType according to the type of error reporting it wants to receive.

Accessing ErrorReportingType may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The error reporting type specified is not valid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace
MsrErrorReporting
TracksToRead
DataEvent
ErrorEvent


Msr.ExpirationDate Property

Msr.ExpirationDate Property |
 | See Also

1/18/2008

Holds the expiration date from the most recently swiped card, as four ASCII decimal characters in the form YYMM. For example, February 1998 is “9802” and August 2018 is “1808”.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ExpirationDate As String
public abstract string ExpirationDate { get; }
public:
virtual property String^ ExpirationDate {
    String^ get () abstract;
}
/** @property */
public abstract String get_ExpirationDate ()

public abstract function get ExpirationDate () : String

Remarks

ExpirationDate is set to an empty string under the following conditions:

  • The field was not included in the track data read; or

  • The ParseDecodeData property is set to true, but ExpirationDate is not included in the separated fields of the Track1Data or Track2Data properties; or

  • ParseDecodeData is set to false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace
ParseDecodeData
Track1Data
Track2Data


Msr.FirstName Property

Msr.FirstName Property |
 | See Also

1/18/2008

Holds the first name from the most recently swiped card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property FirstName As String
public abstract string FirstName { get; }
public:
virtual property String^ FirstName {
    String^ get () abstract;
}
/** @property */
public abstract String get_FirstName ()

public abstract function get FirstName () : String

Remarks

FirstName is set to an empty string under the following conditions:

  • The field was not included in the track data read; or

  • The ParseDecodeData property is set to true, but FirstName is not included in the separated fields of the Track1Data or Track2Data properties; or

  • ParseDecodeData is set to false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace
ParseDecodeData
Track1Data
Track2Data


Msr.IsExclusiveUseDevice Property

Msr.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Indicates whether the Msr is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Property Value

A value of true indicates that the Msr is exclusive-use. Otherwise, the value will be false.

Remarks

An exclusive-use device has the following properties:

  • The application must claim the device before enabling it.

  • The application must claim and enable the device before accessing some properties or calling methods that update the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.MiddleInitial Property

Msr.MiddleInitial Property |
 | See Also

1/18/2008

Holds the middle initial from the most recently swiped card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property MiddleInitial As String
public abstract string MiddleInitial { get; }
public:
virtual property String^ MiddleInitial {
    String^ get () abstract;
}
/** @property */
public abstract String get_MiddleInitial ()

public abstract function get MiddleInitial () : String

Remarks

MiddleInitial is set to an empty string under the following conditions:

  • The field was not included in the track data read; or

  • The ParseDecodeData property is set to true, but MiddleInitial is not included in the separated fields of the Track1Data or Track2Data properties; or

  • ParseDecodeData is set to false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace
ParseDecodeData
Track1Data
Track2Data


Msr.ParseDecodeData Property

Msr.ParseDecodeData Property |
 | See Also

1/18/2008

If true, the decoded data contained within the Track1Data and Track2Data properties is further separated into fields for access via various other properties.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property ParseDecodeData As Boolean
public abstract bool ParseDecodeData { get; set; }
public:
virtual property bool ParseDecodeData {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_ParseDecodeData ()

/** @property */
public abstract void set_ParseDecodeData (boolean value)

public abstract function get ParseDecodeData () : boolean

public abstract function set ParseDecodeData (value : boolean)

Remarks

Track3Data is not parsed because its data content is of an open format defined by the card issuer. JIS-I Track 1 Format C and ISO Track 1 Format C data are not parsed for similar reasons. Track4Data is also not parsed.

The parsed data properties are the defined possible fields for cards with data consisting of the following formats:

  • JIS-I / ISO Track 1 Format A

  • JIS-I / ISO Track 1 Format B

  • JIS-I / ISO Track 1 VISA Format (a de-facto standard)

  • JIS-I / ISO Track 2 Format

ParseDecodeData is typically initialized to true.

Setting ParseDecodeData to true automatically sets the DecodeData property to true.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace
Msr.DecodeData Property


Msr.ServiceCode Property

Msr.ServiceCode Property |
 | See Also

1/18/2008

Holds the service code from the most recently swiped card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ServiceCode As String
public abstract string ServiceCode { get; }
public:
virtual property String^ ServiceCode {
    String^ get () abstract;
}
/** @property */
public abstract String get_ServiceCode ()

public abstract function get ServiceCode () : String

Remarks

ServiceCode is set to an empty string under the following conditions:

  • The field was not included in the track data read; or

  • The ParseDecodeData property is set to true, but ServiceCode is not included in the separated fields of the Track1Data or Track2Data properties; or

  • ParseDecodeData is set to false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace
Msr.ParseDecodeData Property
Track1Data
Track2Data


Msr.Suffix Property

Msr.Suffix Property |
 | See Also

1/18/2008

Holds the suffix from the most recently swiped card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property Suffix As String
public abstract string Suffix { get; }
public:
virtual property String^ Suffix {
    String^ get () abstract;
}
/** @property */
public abstract String get_Suffix ()

public abstract function get Suffix () : String

Remarks

Suffix is set to an empty string under the following conditions:

  • The field was not included in the track data read; or

  • The ParseDecodeData property is set to true, but Suffix is not included in the separated fields of the Track1Data or Track2Data properties; or

  • ParseDecodeData is set to false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace
Msr.ParseDecodeData Property
Track1Data
Track2Data


Msr.Surname Property

Msr.Surname Property |
 | See Also

1/18/2008

Holds the surname from the most recently swiped card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property Surname As String
public abstract string Surname { get; }
public:
virtual property String^ Surname {
    String^ get () abstract;
}
/** @property */
public abstract String get_Surname ()

public abstract function get Surname () : String

Remarks

Surname is set to an empty string under the following conditions:

  • The field was not included in the track data read; or

  • The ParseDecodeData property is set to true, but Surname is not included in the separated fields of the Track1Data or Track2Data properties; or

  • ParseDecodeData is set to false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace
Msr.ParseDecodeData Property
Track1Data
Track2Data


Msr.Title Property

Msr.Title Property |
 | See Also

1/18/2008

Holds the title from the most recently swiped card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property Title As String
public abstract string Title { get; }
public:
virtual property String^ Title {
    String^ get () abstract;
}
/** @property */
public abstract String get_Title ()

public abstract function get Title () : String

Remarks

Title is set to an empty string under the following conditions:

  • The field was not included in the track data read; or

  • The ParseDecodeData property is set to true, but Title is not included in the separated fields of the Track1Data or Track2Data properties; or

  • ParseDecodeData is set to false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace
Msr.ParseDecodeData Property
Track1Data
Track2Data


Msr.Track1Data Property

Msr.Track1Data Property |
 | See Also

1/18/2008

Holds either the Track 1 data from the most recently swiped card or an empty array.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property Track1Data As Byte()
public abstract byte[] Track1Data { get; }
public:
virtual property array<unsigned char>^ Track1Data {
    array<unsigned char>^ get () abstract;
}
/** @property */
public abstract byte[] get_Track1Data ()

public abstract function get Track1Data () : byte[]

Remarks

If the TransmitSentinels property is set to false, Track1Data contains track data between, but not including, the start and end sentinels. If TransmitSentinels is set to true, then the start and end sentinels are included.

If the DecodeData property is set to true, the data returned by Track1Data has been decoded from “raw” format. The data may also be parsed into other properties when the ParseDecodeData property is set.

An empty array indicates that the track was not accessible.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace
Msr.DecodeData Property
Msr.ParseDecodeData Property
TransmitSentinels


Msr.Track1DiscretionaryData Property

Msr.Track1DiscretionaryData Property |
 | See Also

1/18/2008

Holds the Track 1 discretionary data from the most recently swiped card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property Track1DiscretionaryData As Byte()
public abstract byte[] Track1DiscretionaryData { get; }
public:
virtual property array<unsigned char>^ Track1DiscretionaryData {
    array<unsigned char>^ get () abstract;
}
/** @property */
public abstract byte[] get_Track1DiscretionaryData ()

public abstract function get Track1DiscretionaryData () : byte[]

Remarks

Track1DiscretionaryData is set to an empty array under the following conditions:

  • The field was not included in the track data read; or

  • The ParseDecodeData property is set to true, but Track1DiscretionaryData is not included in the separated fields of the Track1Data or Track2Data properties; or

  • ParseDecodeData is set to false.

The amount of data contained in Track1DiscretionaryData varies widely, depending upon the format of the Track 1 data.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace
Msr.ParseDecodeData Property


Msr.Track1EncryptedData Property

Msr.Track1EncryptedData Property |
 | See Also

1/18/2008

Gets the length of the raw Track1Data before it is encrypted.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property Track1EncryptedData As Byte()
public virtual byte[] Track1EncryptedData { get; }
public:
virtual property array<unsigned char>^ Track1EncryptedData {
    array<unsigned char>^ get ();
}
/** @property */
public byte[] get_Track1EncryptedData ()

public function get Track1EncryptedData () : byte[]

Remarks

Many encryption algorithms require padding of the input data before it can be encrypted. This property contains the length of the original unpadded track data before it is encrypted. It may be needed to restore the original track data after decryption.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.Track1EncryptedDataLength Property

Msr.Track1EncryptedDataLength Property |
 | See Also

1/18/2008

Gets the encrypted track 1 data obtained from the most recently swiped card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property Track1EncryptedDataLength As Integer
public virtual int Track1EncryptedDataLength { get; }
public:
virtual property int Track1EncryptedDataLength {
    int get ();
}
/** @property */
public int get_Track1EncryptedDataLength ()

public function get Track1EncryptedDataLength () : int

Remarks

The length of this property after it is decrypted is contained in the Track1EncryptedDataLength property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.Track2Data Property

Msr.Track2Data Property |
 | See Also

1/18/2008

Holds either the Track 2 data from the most recently swiped card or an empty array.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property Track2Data As Byte()
public abstract byte[] Track2Data { get; }
public:
virtual property array<unsigned char>^ Track2Data {
    array<unsigned char>^ get () abstract;
}
/** @property */
public abstract byte[] get_Track2Data ()

public abstract function get Track2Data () : byte[]

Remarks

If the TransmitSentinels property is set to false, Track2Data contains track data between, but not including, the start and end sentinels. If TransmitSentinels is set to true, then the start and end sentinels are included.

If the DecodeData property is set to true, the data returned by Track2Data has been decoded from “raw” format. It may also be parsed into other properties when the ParseDecodeData property is set.

An empty array indicates that the track was not accessible.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace
Msr.DecodeData Property
Msr.ParseDecodeData Property
TransmitSentinels


Msr.Track2DiscretionaryData Property

Msr.Track2DiscretionaryData Property |
 | See Also

1/18/2008

The Track 2 discretionary data from the most recently swiped card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property Track2DiscretionaryData As Byte()
public abstract byte[] Track2DiscretionaryData { get; }
public:
virtual property array<unsigned char>^ Track2DiscretionaryData {
    array<unsigned char>^ get () abstract;
}
/** @property */
public abstract byte[] get_Track2DiscretionaryData ()

public abstract function get Track2DiscretionaryData () : byte[]

Remarks

Track2DiscretionaryData is set to an empty array under the following conditions:

  • The field was not included in the track data read; or

  • The ParseDecodeData property is set to true, but Track2DiscretionaryData is not included in the separated fields of the Track1Data or Track2Data properties; or

  • ParseDecodeData is set to false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace
Msr.ParseDecodeData Property


Msr.Track2EncryptedData Property

Msr.Track2EncryptedData Property |
 | See Also

1/18/2008

Holds the length of the raw Track2Data before it is encrypted.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property Track2EncryptedData As Byte()
public virtual byte[] Track2EncryptedData { get; }
public:
virtual property array<unsigned char>^ Track2EncryptedData {
    array<unsigned char>^ get ();
}
/** @property */
public byte[] get_Track2EncryptedData ()

public function get Track2EncryptedData () : byte[]

Remarks

Many encryption algorithms require padding of the input data before it can be encrypted. This property contains the length of the original unpadded track data before it is encrypted. It may be needed to restore the original track data after decryption.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.Track2EncryptedDataLength Property

Msr.Track2EncryptedDataLength Property |
 | See Also

1/18/2008

Gets the encrypted track 2 data obtained from the most recently swiped card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property Track2EncryptedDataLength As Integer
public virtual int Track2EncryptedDataLength { get; }
public:
virtual property int Track2EncryptedDataLength {
    int get ();
}
/** @property */
public int get_Track2EncryptedDataLength ()

public function get Track2EncryptedDataLength () : int

Remarks

The length of this property after it is decrypted is contained in the Track2EncryptedDataLength property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.Track3Data Property

Msr.Track3Data Property |
 | See Also

1/18/2008

Holds either the Track 3 data from the most recently swiped card or an empty array.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property Track3Data As Byte()
public abstract byte[] Track3Data { get; }
public:
virtual property array<unsigned char>^ Track3Data {
    array<unsigned char>^ get () abstract;
}
/** @property */
public abstract byte[] get_Track3Data ()

public abstract function get Track3Data () : byte[]

Remarks

If the TransmitSentinels property is set to false, Track3Data contains track data between, but not including, the start and end sentinels. If TransmitSentinels is true, the start and end sentinels are included.

If the DecodeData property is set to true, the data returned by Track3Data has been decoded from “raw” format.

An empty string indicates that the track was not accessible.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace
Msr.DecodeData Property
TransmitSentinels


Msr.Track3EncryptedData Property

Msr.Track3EncryptedData Property |
 | See Also

1/18/2008

Gets the length of the raw Track3Data before it is encrypted.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property Track3EncryptedData As Byte()
public virtual byte[] Track3EncryptedData { get; }
public:
virtual property array<unsigned char>^ Track3EncryptedData {
    array<unsigned char>^ get ();
}
/** @property */
public byte[] get_Track3EncryptedData ()

public function get Track3EncryptedData () : byte[]

Remarks

Many encryption algorithms require padding of the input data before it can be encrypted. This property contains the length of the original unpadded track data before it is encrypted. It may be needed to restore the original track data after decryption.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.Track3EncryptedDataLength Property

Msr.Track3EncryptedDataLength Property |
 | See Also

1/18/2008

Gets the encrypted track 3 data obtained from the most recently swiped card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property Track3EncryptedDataLength As Integer
public virtual int Track3EncryptedDataLength { get; }
public:
virtual property int Track3EncryptedDataLength {
    int get ();
}
/** @property */
public int get_Track3EncryptedDataLength ()

public function get Track3EncryptedDataLength () : int

Remarks

The length of this property after it is decrypted is contained in the Track3EncryptedDataLength property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.Track4Data Property

Msr.Track4Data Property |
 | See Also

1/18/2008

Holds the Track 4 data (JIS-II) from the most recently swiped card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property Track4Data As Byte()
public abstract byte[] Track4Data { get; }
public:
virtual property array<unsigned char>^ Track4Data {
    array<unsigned char>^ get () abstract;
}
/** @property */
public abstract byte[] get_Track4Data ()

public abstract function get Track4Data () : byte[]

Remarks

If the TransmitSentinels property is set to false, Track4Data contains track data between, but not including, the start and end sentinels. If TransmitSentinels is true, the start and end sentinels are included.

If the DecodeData property is set to true, the data returned by Track4Data has been decoded from “raw” format.

An empty array indicates that the track was not accessible.

To maintain compatibility with previous versions, the MSR device’s service object can also continue to store the JIS-II data in another TracknData property. However, to ensure application portability, Track4Data should be used to access JIS-II data.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace
Msr.DecodeData Property
TransmitSentinels


Msr.Track4EncryptedData Property

Msr.Track4EncryptedData Property |
 | See Also

1/18/2008

Gets the encrypted track 4 data obtained from the most recently swiped card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property Track4EncryptedData As Byte()
public virtual byte[] Track4EncryptedData { get; }
public:
virtual property array<unsigned char>^ Track4EncryptedData {
    array<unsigned char>^ get ();
}
/** @property */
public byte[] get_Track4EncryptedData ()

public function get Track4EncryptedData () : byte[]

Remarks

The length of this property after it is decrypted is contained in the Track4EncryptedDataLength property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.Track4EncryptedDataLength Property

Msr.Track4EncryptedDataLength Property |
 | See Also

1/18/2008

Gets the length of the raw Track4Data before it is encrypted.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property Track4EncryptedDataLength As Integer
public virtual int Track4EncryptedDataLength { get; }
public:
virtual property int Track4EncryptedDataLength {
    int get ();
}
/** @property */
public int get_Track4EncryptedDataLength ()

public function get Track4EncryptedDataLength () : int

Remarks

Many encryption algorithms require padding of the input data before it can be encrypted. This property contains the length of the original unpadded track data before it is encrypted. It may be needed to restore the original track data after decryption.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr.TracksToRead Property

Msr.TracksToRead Property |
 | See Also

1/18/2008

Indicates the track data that the application wishes to place into the Track1Data, Track2Data, Track3Data and Track4Data properties following a card swipe.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property TracksToRead As MsrTracks
public abstract MsrTracks TracksToRead { get; set; }
public:
virtual property MsrTracks TracksToRead {
    MsrTracks get () abstract;
    void set (MsrTracks value) abstract;
}
/** @property */
public abstract MsrTracks get_TracksToRead ()

/** @property */
public abstract void set_TracksToRead (MsrTracks value)

public abstract function get TracksToRead () : MsrTracks

public abstract function set TracksToRead (value : MsrTracks)

Remarks

Possible values are defined by the MsrTracks enumeration.

Decreasing the required number of tracks can provide a greater swipe success rate and somewhat greater responsiveness by removing the processing for unaccessed data.

TracksToRead does not indicate a capability of the MSR device, but instead is an application-configurable property indicating from which track(s) data will be obtained, potentially decoded, and returned if possible. Some situations will always prevent the receipt of data: for example, an ISO-type card swiped through a JIS-II read head, or a card with no data in some tracks.

TracksToRead is typically initialized to Tracks123.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace
Msr.Track1Data Property
Msr.Track2Data Property
Msr.Track3Data Property
Msr.Track4Data Property


Msr.TracksToWrite Property

Msr.TracksToWrite Property |
 | See Also

1/18/2008

Specifies which MSR tracks will be written when the WriteTracks method is called and an MSR card swiped.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Property TracksToWrite As MsrTracks
public virtual MsrTracks TracksToWrite { get; set; }
public:
virtual property MsrTracks TracksToWrite {
    MsrTracks get ();
    void set (MsrTracks value);
}
/** @property */
public MsrTracks get_TracksToWrite ()

/** @property */
public void set_TracksToWrite (MsrTracks value)

public function get TracksToWrite () : MsrTracks

public function set TracksToWrite (value : MsrTracks)

Remarks

The contents of the TracksToWrite property can be specified using the MsrTracks enumeration. Only values which are equal to, or a subset of the CapWritableTracks property are valid.

If CapWritableTracks is set to MsrTracks.None then writing to this MSR device is not supported and attempting to set this property will throw an exception.

Setting this property may also update the EncodingMaxLength property since each track may have a different encoding limit.

This property is set to MsrTracks.None by default during the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace
Msr.TracksToWrite Property
Msr.EncodingMaxLength Property
MsrTracks
Msr.CapWritableTracks Property


Msr.TransmitSentinels Property

Msr.TransmitSentinels Property |
 | See Also

1/18/2008

If true, the Track1Data, Track2Data, Track3Data, and Track4Data properties contain start sentinel and end sentinel values.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property TransmitSentinels As Boolean
public abstract bool TransmitSentinels { get; set; }
public:
virtual property bool TransmitSentinels {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_TransmitSentinels ()

/** @property */
public abstract void set_TransmitSentinels (boolean value)

public abstract function get TransmitSentinels () : boolean

public abstract function set TransmitSentinels (value : boolean)

Remarks

If false, these properties contain only the track data between these sentinels.

TransmitSentinels is set by the service object, based on the capability of the device.

Accessing TransmitSentinels can cause one of the following values to be placed in the ErrorCode property:

Value | Meaning
Success | TransmitSentinels was set successfully.
Illegal | The CapTransmitSentinels property has been set to false by the service object; start sentinel and end sentinel values are not supported by the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace
Msr.CapTransmitSentinels Property


Msr.WriteCardType Property

Msr.WriteCardType Property |
 | See Also

1/18/2008

Holds the card type to be used the next time the WriteTracks method is called.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Property WriteCardType As String
public virtual string WriteCardType { get; set; }
public:
virtual property String^ WriteCardType {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_WriteCardType ()

/** @property */
public void set_WriteCardType (String value)

public function get WriteCardType () : String

public function set WriteCardType (value : String)

Remarks

If this property's value begins with an underscore ('_') the card type is vendor specific. If this property does not begin with an underscore the card type is one of the standard card types.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace


Msr Events

Msr Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DataEvent | Raised by the service object to indicate the delivery of input data from the device to the application.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
ErrorEvent | Raised by the service object when an error is detected while trying to read MSR data.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

Msr Class
Microsoft.PointOfService Namespace


Msr.DataEvent Event

Msr.DataEvent Event |
 | See Also

1/18/2008

Raised by the service object to indicate the delivery of input data from the device to the application.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event DataEvent As DataEventHandler
public abstract event DataEventHandler DataEvent
public:
virtual event DataEventHandler^ DataEvent {
    void add (DataEventHandler^ value) abstract;
    void remove (DataEventHandler^ value) abstract;
}
/** @event */
public abstract void add_DataEvent (DataEventHandler value)

/** @event */
public abstract void remove_DataEvent (DataEventHandler value)

Remarks

Before delivering the event, the swiped data is placed into Track1Data, Track2Data, Track3Data, and Track4Data. If DecodeData is true, then this track data is decoded. If ParseDecodeData is true, the data is parsed into several additional properties.

The DataEventArgs.Status property is divided into four bytes representing information about the four tracks. This diagram indicates how the property Status is divided:

High Word |  | Low Word |
High Byte | Low Byte | High Byte | Low Byte
Track 4 | Track 3 | Track 2 | Track 1

A value of zero for a track byte means that no data was received for that particular track from the card swipe. This could be due to several factors: for example, the hardware device may not have a read head for the track, or the application intentionally precluded incoming data from the track via the TracksToRead property.

A value greater than zero indicates the length in bytes of the corresponding TracknData property.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace
DataEventHandler Delegate
DataEventArgs Class
Msr.Track1Data Property
Msr.Track2Data Property
Msr.Track3Data Property
Msr.Track4Data Property
Msr.DecodeData Property
Msr.ParseDecodeData Property


Msr.ErrorEvent Event

Msr.ErrorEvent Event |
 | See Also

1/18/2008

Raised by the service object when an error is detected while trying to read MSR data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event ErrorEvent As DeviceErrorEventHandler
public abstract event DeviceErrorEventHandler ErrorEvent
public:
virtual event DeviceErrorEventHandler^ ErrorEvent {
    void add (DeviceErrorEventHandler^ value) abstract;
    void remove (DeviceErrorEventHandler^ value) abstract;
}
/** @event */
public abstract void add_ErrorEvent (DeviceErrorEventHandler value)

/** @event */
public abstract void remove_ErrorEvent (DeviceErrorEventHandler value)

Remarks

POS for .NET doesn’t deliver ErrorEvent events until the application sets the DataEventEnabled property to true.

If the ErrorReportingType property is set to MsrErrorReporting.Card, the track that caused the fault cannot be determined, and the track data properties are not changed.

If the ErrorReportingType property is set to Track the DeviceErrorEventArgs.ErrorCode and DeviceErrorEventArgs.ErrorCode properties may indicate the track-level status. Also, the track data properties are updated as with DataEvent, with the properties for the track(s) in error set to empty strings. Unlike DataEvent, individual track lengths are not reported. However, the application can determine their lengths by getting the length of each of the TracknData properties. Also, because this is an ErrorEvent (even though it is reporting partial data), the DataCount property is not incremented and the service object remains enabled, regardless of the AutoDisable property value.

If the ErrorReportingType property is set to MsrErrorReporting.Card, the DeviceErrorEventArgs.ErrorCode property may be one of the following:

Value | Meaning
Extended | ErrorCodeExtended = ExtendedErrorStart: Start sentinel error. ErrorCodeExtended = ExtendedErrorEnd: End sentinel error. ErrorCodeExtended = ExtendedErrorParity: Parity error. ErrorCodeExtended = ExtendedErrorLrc: LRC error.
Other values | See ErrorCode and ErrorCodeExtended.

If the ErrorReportingType property is set to MsrErrorReporting.Track, the DeviceErrorEventArgs.ErrorCode property may be one of the following:

Value

Meaning

Extended

ErrorCodeExtended = Track-level status, broken down as follows:

High Word |  | Low Word |
High Byte | Low Byte | High Byte | Low Byte
Track 4 | Track 3 | Track 2 | Track 1

Each of the track status bytes may be one of the following:

ExtendedErrorSuccess No error.

ExtendedErrorStartStart sentinel error.

ExtendedErrorEndEnd sentinel error.

ExtendedErrorParityParity error.

ExtendedErrorLrcLRC error.

ExtendedErrorFailureOther or general error.

Other values

See ErrorCode and ErrorCodeExtended.

The DeviceErrorEventArgs.ErrorLocus property can be one of the following:

Value | Meaning
Input | Error occurred while gathering or processing event-driven input. No input data is available.
InputData | Error occurred while gathering or processing event-driven input, and some previously buffered data is available.

The contents of the DeviceErrorEventArgs.ErrorResponse property are preset to a default value, based on the value of DeviceErrorEventArgs.ErrorLocus. The application can change the value to one of the following:

Value | Meaning
Clear | Clear the buffered input data. The error state is exited. This is the default value when locus is Input.
ContinueInput | Use only when locus is InputData. Acknowledges the error and directs the service object to continue processing. The service object remains in the error state and will deliver additional DataEvents as directed by the DataEventEnabled property. When all input has been delivered and the DataEventEnabled property is again set to true, then another ErrorEvent is delivered with locus Input. This is the default value when locus is InputData.

See Also

Reference

Msr Class
Msr Members
Microsoft.PointOfService Namespace
DeviceErrorEventHandler Delegate
DeviceErrorEventArgs Class
Msr.DataEventEnabled Property
Msr.AutoDisable Property
Msr.ErrorReportingType Property


Msr.AamvaCardProperties Class

Msr.AamvaCardProperties Class |
 | See Also Members

1/18/2008

Contains the different properties that can be accessed for AAMVA cards.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public NotInheritable Class AamvaCardProperties
public static class AamvaCardProperties
public ref class AamvaCardProperties abstract sealed
public final class AamvaCardProperties
public final class AamvaCardProperties

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.Msr.AamvaCardProperties

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr.AamvaCardProperties Members
Microsoft.PointOfService Namespace


Msr.AamvaCardProperties Members

Msr.AamvaCardProperties Members |
 | See Also Fields Methods

1/18/2008

Contains the different properties that can be accessed for AAMVA cards.

The following tables list the members exposed by the Msr.AamvaCardProperties type.

Public Fields

Name | Description
Address | Contains the address property from the AAMVA card.
BirthDate | Contains the birth date property from the AAMVA card.
City | Contains the city property from the AAMVA card.
Class | Contains the class property from the AAMVA card.
Endorsements | Contains the endorsements property from the AAMVA card.
ExpirationDate | Contains the expiration date property from the AAMVA card.
EyeColor | Contains the eye color property from the AAMVA card.
FirstName | Contains the first name property from the AAMVA card.
Gender | Contains the gender property from the AAMVA card.
HairColor | Contains the hair color property from the AAMVA card.
Height | Contains the height property from the AAMVA card.
LicenseNumber | Contains the license number property from the AAMVA card.
PostalCode | Contains the postal code property from the AAMVA card.
Restrictions | Contains the restrictions property from the AAMVA card.
State | Contains the state property from the AAMVA card.
Suffix | Contains the suffix property from the AAMVA card.
Surname | Contains the surname property from the AAMVA card.
Weight | Contains the weight property from the AAMVA card.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

Msr.AamvaCardProperties Class
Microsoft.PointOfService Namespace


Msr.AamvaCardProperties Fields

Msr.AamvaCardProperties Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
Address | Contains the address property from the AAMVA card.
BirthDate | Contains the birth date property from the AAMVA card.
City | Contains the city property from the AAMVA card.
Class | Contains the class property from the AAMVA card.
Endorsements | Contains the endorsements property from the AAMVA card.
ExpirationDate | Contains the expiration date property from the AAMVA card.
EyeColor | Contains the eye color property from the AAMVA card.
FirstName | Contains the first name property from the AAMVA card.
Gender | Contains the gender property from the AAMVA card.
HairColor | Contains the hair color property from the AAMVA card.
Height | Contains the height property from the AAMVA card.
LicenseNumber | Contains the license number property from the AAMVA card.
PostalCode | Contains the postal code property from the AAMVA card.
Restrictions | Contains the restrictions property from the AAMVA card.
State | Contains the state property from the AAMVA card.
Suffix | Contains the suffix property from the AAMVA card.
Surname | Contains the surname property from the AAMVA card.
Weight | Contains the weight property from the AAMVA card.

See Also

Reference

Msr.AamvaCardProperties Class
Microsoft.PointOfService Namespace


Msr.AamvaCardProperties.Address Field

Msr.AamvaCardProperties.Address Field |
 | See Also

1/18/2008

Contains the address property from the AAMVA card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const Address As String
public const string Address
public:
literal String^ Address
public static final String Address
public const var Address : String

See Also

Reference

Msr.AamvaCardProperties Class
Msr.AamvaCardProperties Members
Microsoft.PointOfService Namespace


Msr.AamvaCardProperties.BirthDate Field

Msr.AamvaCardProperties.BirthDate Field |
 | See Also

1/18/2008

Contains the birth date property from the AAMVA card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const BirthDate As String
public const string BirthDate
public:
literal String^ BirthDate
public static final String BirthDate
public const var BirthDate : String

See Also

Reference

Msr.AamvaCardProperties Class
Msr.AamvaCardProperties Members
Microsoft.PointOfService Namespace


Msr.AamvaCardProperties.City Field

Msr.AamvaCardProperties.City Field |
 | See Also

1/18/2008

Contains the city property from the AAMVA card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const City As String
public const string City
public:
literal String^ City
public static final String City
public const var City : String

See Also

Reference

Msr.AamvaCardProperties Class
Msr.AamvaCardProperties Members
Microsoft.PointOfService Namespace


Msr.AamvaCardProperties.Class Field

Msr.AamvaCardProperties.Class Field |
 | See Also

1/18/2008

Contains the class property from the AAMVA card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const Class As String
public const string Class
public:
literal String^ Class
public static final String Class
public const var Class : String

See Also

Reference

Msr.AamvaCardProperties Class
Msr.AamvaCardProperties Members
Microsoft.PointOfService Namespace


Msr.AamvaCardProperties.Endorsements Field

Msr.AamvaCardProperties.Endorsements Field |
 | See Also

1/18/2008

Contains the endorsements property from the AAMVA card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const Endorsements As String
public const string Endorsements
public:
literal String^ Endorsements
public static final String Endorsements
public const var Endorsements : String

See Also

Reference

Msr.AamvaCardProperties Class
Msr.AamvaCardProperties Members
Microsoft.PointOfService Namespace


Msr.AamvaCardProperties.ExpirationDate Field

Msr.AamvaCardProperties.ExpirationDate Field |
 | See Also

1/18/2008

Contains the expiration date property from the AAMVA card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExpirationDate As String
public const string ExpirationDate
public:
literal String^ ExpirationDate
public static final String ExpirationDate
public const var ExpirationDate : String

See Also

Reference

Msr.AamvaCardProperties Class
Msr.AamvaCardProperties Members
Microsoft.PointOfService Namespace


Msr.AamvaCardProperties.EyeColor Field

Msr.AamvaCardProperties.EyeColor Field |
 | See Also

1/18/2008

Contains the eye color property from the AAMVA card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const EyeColor As String
public const string EyeColor
public:
literal String^ EyeColor
public static final String EyeColor
public const var EyeColor : String

See Also

Reference

Msr.AamvaCardProperties Class
Msr.AamvaCardProperties Members
Microsoft.PointOfService Namespace


Msr.AamvaCardProperties.FirstName Field

Msr.AamvaCardProperties.FirstName Field |
 | See Also

1/18/2008

Contains the first name property from the AAMVA card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const FirstName As String
public const string FirstName
public:
literal String^ FirstName
public static final String FirstName
public const var FirstName : String

See Also

Reference

Msr.AamvaCardProperties Class
Msr.AamvaCardProperties Members
Microsoft.PointOfService Namespace


Msr.AamvaCardProperties.Gender Field

Msr.AamvaCardProperties.Gender Field |
 | See Also

1/18/2008

Contains the gender property from the AAMVA card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const Gender As String
public const string Gender
public:
literal String^ Gender
public static final String Gender
public const var Gender : String

See Also

Reference

Msr.AamvaCardProperties Class
Msr.AamvaCardProperties Members
Microsoft.PointOfService Namespace


Msr.AamvaCardProperties.HairColor Field

Msr.AamvaCardProperties.HairColor Field |
 | See Also

1/18/2008

Contains the hair color property from the AAMVA card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const HairColor As String
public const string HairColor
public:
literal String^ HairColor
public static final String HairColor
public const var HairColor : String

See Also

Reference

Msr.AamvaCardProperties Class
Msr.AamvaCardProperties Members
Microsoft.PointOfService Namespace


Msr.AamvaCardProperties.Height Field

Msr.AamvaCardProperties.Height Field |
 | See Also

1/18/2008

Contains the height property from the AAMVA card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const Height As String
public const string Height
public:
literal String^ Height
public static final String Height
public const var Height : String

See Also

Reference

Msr.AamvaCardProperties Class
Msr.AamvaCardProperties Members
Microsoft.PointOfService Namespace


Msr.AamvaCardProperties.LicenseNumber Field

Msr.AamvaCardProperties.LicenseNumber Field |
 | See Also

1/18/2008

Contains the license number property from the AAMVA card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const LicenseNumber As String
public const string LicenseNumber
public:
literal String^ LicenseNumber
public static final String LicenseNumber
public const var LicenseNumber : String

See Also

Reference

Msr.AamvaCardProperties Class
Msr.AamvaCardProperties Members
Microsoft.PointOfService Namespace


Msr.AamvaCardProperties.PostalCode Field

Msr.AamvaCardProperties.PostalCode Field |
 | See Also

1/18/2008

Contains the postal code property from the AAMVA card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PostalCode As String
public const string PostalCode
public:
literal String^ PostalCode
public static final String PostalCode
public const var PostalCode : String

See Also

Reference

Msr.AamvaCardProperties Class
Msr.AamvaCardProperties Members
Microsoft.PointOfService Namespace


Msr.AamvaCardProperties.Restrictions Field

Msr.AamvaCardProperties.Restrictions Field |
 | See Also

1/18/2008

Contains the restrictions property from the AAMVA card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const Restrictions As String
public const string Restrictions
public:
literal String^ Restrictions
public static final String Restrictions
public const var Restrictions : String

See Also

Reference

Msr.AamvaCardProperties Class
Msr.AamvaCardProperties Members
Microsoft.PointOfService Namespace


Msr.AamvaCardProperties.State Field

Msr.AamvaCardProperties.State Field |
 | See Also

1/18/2008

Contains the state property from the AAMVA card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const State As String
public const string State
public:
literal String^ State
public static final String State
public const var State : String

See Also

Reference

Msr.AamvaCardProperties Class
Msr.AamvaCardProperties Members
Microsoft.PointOfService Namespace


Msr.AamvaCardProperties.Suffix Field

Msr.AamvaCardProperties.Suffix Field |
 | See Also

1/18/2008

Contains the suffix property from the AAMVA card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const Suffix As String
public const string Suffix
public:
literal String^ Suffix
public static final String Suffix
public const var Suffix : String

See Also

Reference

Msr.AamvaCardProperties Class
Msr.AamvaCardProperties Members
Microsoft.PointOfService Namespace


Msr.AamvaCardProperties.Surname Field

Msr.AamvaCardProperties.Surname Field |
 | See Also

1/18/2008

Contains the surname property from the AAMVA card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const Surname As String
public const string Surname
public:
literal String^ Surname
public static final String Surname
public const var Surname : String

See Also

Reference

Msr.AamvaCardProperties Class
Msr.AamvaCardProperties Members
Microsoft.PointOfService Namespace


Msr.AamvaCardProperties.Weight Field

Msr.AamvaCardProperties.Weight Field |
 | See Also

1/18/2008

Contains the weight property from the AAMVA card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const Weight As String
public const string Weight
public:
literal String^ Weight
public static final String Weight
public const var Weight : String

See Also

Reference

Msr.AamvaCardProperties Class
Msr.AamvaCardProperties Members
Microsoft.PointOfService Namespace


Msr.AamvaCardProperties Methods

Msr.AamvaCardProperties Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

Msr.AamvaCardProperties Class
Microsoft.PointOfService Namespace


Msr.BankCardProperties Class

Msr.BankCardProperties Class |
 | See Also Members

1/18/2008

Contains the properties that can be accessed from the bank card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public NotInheritable Class BankCardProperties
public static class BankCardProperties
public ref class BankCardProperties abstract sealed
public final class BankCardProperties
public final class BankCardProperties

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.Msr.BankCardProperties

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Msr.BankCardProperties Members
Microsoft.PointOfService Namespace


Msr.BankCardProperties Members

Msr.BankCardProperties Members |
 | See Also Fields Methods

1/18/2008

Contains the properties that can be accessed from the bank card.

The following tables list the members exposed by the Msr.BankCardProperties type.

Public Fields

Name | Description
AccountNumber | Contains the account number property from the bank card.
ExpirationDate | Contains the expiration date property from the bank card.
FirstName | Contains the first name property from the bank card.
MiddleInitial | Contains the middle initial property from the bank card.
ServiceCode | Contains the service code property from the bank card.
Suffix | Contains the suffix property from the bank card.
Surname | Contains the surname property from the bank card.
Title | Contains the title from the bank card.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

Msr.BankCardProperties Class
Microsoft.PointOfService Namespace


Msr.BankCardProperties Fields

Msr.BankCardProperties Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
AccountNumber | Contains the account number property from the bank card.
ExpirationDate | Contains the expiration date property from the bank card.
FirstName | Contains the first name property from the bank card.
MiddleInitial | Contains the middle initial property from the bank card.
ServiceCode | Contains the service code property from the bank card.
Suffix | Contains the suffix property from the bank card.
Surname | Contains the surname property from the bank card.
Title | Contains the title from the bank card.

See Also

Reference

Msr.BankCardProperties Class
Microsoft.PointOfService Namespace


Msr.BankCardProperties.AccountNumber Field

Msr.BankCardProperties.AccountNumber Field |
 | See Also

1/18/2008

Contains the account number property from the bank card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const AccountNumber As String
public const string AccountNumber
public:
literal String^ AccountNumber
public static final String AccountNumber
public const var AccountNumber : String

See Also

Reference

Msr.BankCardProperties Class
Msr.BankCardProperties Members
Microsoft.PointOfService Namespace


Msr.BankCardProperties.ExpirationDate Field

Msr.BankCardProperties.ExpirationDate Field |
 | See Also

1/18/2008

Contains the expiration date property from the bank card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExpirationDate As String
public const string ExpirationDate
public:
literal String^ ExpirationDate
public static final String ExpirationDate
public const var ExpirationDate : String

See Also

Reference

Msr.BankCardProperties Class
Msr.BankCardProperties Members
Microsoft.PointOfService Namespace


Msr.BankCardProperties.FirstName Field

Msr.BankCardProperties.FirstName Field |
 | See Also

1/18/2008

Contains the first name property from the bank card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const FirstName As String
public const string FirstName
public:
literal String^ FirstName
public static final String FirstName
public const var FirstName : String

See Also

Reference

Msr.BankCardProperties Class
Msr.BankCardProperties Members
Microsoft.PointOfService Namespace


Msr.BankCardProperties.MiddleInitial Field

Msr.BankCardProperties.MiddleInitial Field |
 | See Also

1/18/2008

Contains the middle initial property from the bank card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const MiddleInitial As String
public const string MiddleInitial
public:
literal String^ MiddleInitial
public static final String MiddleInitial
public const var MiddleInitial : String

See Also

Reference

Msr.BankCardProperties Class
Msr.BankCardProperties Members
Microsoft.PointOfService Namespace


Msr.BankCardProperties.ServiceCode Field

Msr.BankCardProperties.ServiceCode Field |
 | See Also

1/18/2008

Contains the service code property from the bank card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ServiceCode As String
public const string ServiceCode
public:
literal String^ ServiceCode
public static final String ServiceCode
public const var ServiceCode : String

See Also

Reference

Msr.BankCardProperties Class
Msr.BankCardProperties Members
Microsoft.PointOfService Namespace


Msr.BankCardProperties.Suffix Field

Msr.BankCardProperties.Suffix Field |
 | See Also

1/18/2008

Contains the suffix property from the bank card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const Suffix As String
public const string Suffix
public:
literal String^ Suffix
public static final String Suffix
public const var Suffix : String

See Also

Reference

Msr.BankCardProperties Class
Msr.BankCardProperties Members
Microsoft.PointOfService Namespace


Msr.BankCardProperties.Surname Field

Msr.BankCardProperties.Surname Field |
 | See Also

1/18/2008

Contains the surname property from the bank card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const Surname As String
public const string Surname
public:
literal String^ Surname
public static final String Surname
public const var Surname : String

See Also

Reference

Msr.BankCardProperties Class
Msr.BankCardProperties Members
Microsoft.PointOfService Namespace


Msr.BankCardProperties.Title Field

Msr.BankCardProperties.Title Field |
 | See Also

1/18/2008

Contains the title from the bank card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const Title As String
public const string Title
public:
literal String^ Title
public static final String Title
public const var Title : String

See Also

Reference

Msr.BankCardProperties Class
Msr.BankCardProperties Members
Microsoft.PointOfService Namespace


Msr.BankCardProperties Methods

Msr.BankCardProperties Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

Msr.BankCardProperties Class
Microsoft.PointOfService Namespace


MsrErrorReporting Enumeration

MsrErrorReporting Enumeration |
 | See Also

1/18/2008

Lists the error reporting types for an MSR device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration MsrErrorReporting
public enum MsrErrorReporting
public enum class MsrErrorReporting
public enum MsrErrorReporting
public enum MsrErrorReporting

Members

Member name | Description
Card | Report errors at a card level.
Track | Report errors at a track level.

Remarks

Used by the ErrorReportingType property. Members of this enumeration replace the MSR_ERT_CARD and MSR_ERT_TRACK UPOS 1.11 constants.

See Also

Reference

Microsoft.PointOfService Namespace
Msr.ErrorReportingType Property


MsrTracks Enumeration

MsrTracks Enumeration |
 | See Also

1/18/2008

Lists the possible combinations of track data to be read.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration MsrTracks
[FlagsAttribute]
public enum MsrTracks
[FlagsAttribute]
public enum class MsrTracks
/** @attribute FlagsAttribute() */
public enum MsrTracks
FlagsAttribute
public enum MsrTracks

Members

Member name | Description
None | No track will be obtained.
Track1 | Obtain track 1.
Track2 | Obtain track 2.
Track3 | Obtain track 3.
Track4 | Obtain track 4.
Tracks12 | Obtain tracks 1 and 2.
Tracks123 | Obtain tracks 1, 2, and 3.
Tracks1234 | Obtain tracks 1, 2, 3, and 4.
Tracks124 | Obtain tracks 1, 2, and 4.
Tracks13 | Obtain tracks 1 and 3.
Tracks134 | Obtain tracks 1, 3, and 4.
Tracks14 | Obtain tracks 1 and 4.
Tracks23 | Obtain tracks 2 and 3.
Tracks234 | Obtain tracks 2, 3, and 4.
Tracks24 | Obtain tracks 2 and 4.
Tracks34 | Obtain tracks 3 and 4.

Remarks

Used by the TracksToRead property. Members of this enumeration replace the MSR_TR_ range of UPOS 1.11 constants.

See Also

Reference

Microsoft.PointOfService Namespace
Msr.TracksToRead Property


OutputCompleteEventArgs Class

OutputCompleteEventArgs Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for the transmission of Output Complete Events.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Class OutputCompleteEventArgs
    Inherits PosEventArgs
public class OutputCompleteEventArgs : PosEventArgs
public ref class OutputCompleteEventArgs : public PosEventArgs
public class OutputCompleteEventArgs extends PosEventArgs
public class OutputCompleteEventArgs extends PosEventArgs

Remarks

Holds event data for OutputCompleteEvent events.

Inheritance Hierarchy

System.Object
System.EventArgs
Microsoft.PointOfService.PosEventArgs
Microsoft.PointOfService.OutputCompleteEventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

OutputCompleteEventArgs Members
Microsoft.PointOfService Namespace


OutputCompleteEventArgs Members

OutputCompleteEventArgs Members |
 | See Also Constructors Fields Methods Properties

1/18/2008

Defines the programmatic interface for the transmission of Output Complete Events.

The following tables list the members exposed by the OutputCompleteEventArgs type.

Public Constructors

Name | Description
OutputCompleteEventArgs | Creates a new instance of OutputCompleteEventArgs with the specified data.
Top

Public Fields

Name | Description
Empty | (inherited from EventArgs )
Top

Public Properties

Name | Description
EventId | Gets the event identifier. (inherited from PosEventArgs)
OutputId | Holds the ID number of the asynchronous output request that is complete.
TimeStamp | Gets the DateTime of the event. (inherited from PosEventArgs)
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Overridden.
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

OutputCompleteEventArgs Class
Microsoft.PointOfService Namespace


OutputCompleteEventArgs Fields

OutputCompleteEventArgs Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
Empty | (inherited from EventArgs )

See Also

Reference

OutputCompleteEventArgs Class
Microsoft.PointOfService Namespace


OutputCompleteEventArgs Constructor

OutputCompleteEventArgs Constructor |
 | See Also

1/18/2008

Creates a new instance of OutputCompleteEventArgs with the specified data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    outputId As Integer _
)
public OutputCompleteEventArgs (
    int outputId
)
public:
OutputCompleteEventArgs (
    int outputId
)
public OutputCompleteEventArgs (
    int outputId
)
public function OutputCompleteEventArgs (
    outputId : int
)

Parameters

outputId

ID number of the asynchronous output request that is complete.

See Also

Reference

OutputCompleteEventArgs Class
OutputCompleteEventArgs Members
Microsoft.PointOfService Namespace


OutputCompleteEventArgs Methods

OutputCompleteEventArgs Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Overridden.

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

OutputCompleteEventArgs Class
Microsoft.PointOfService Namespace


OutputCompleteEventArgs.ToString Method

OutputCompleteEventArgs.ToString Method |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function ToString As String
public override string ToString ()
public:
virtual String^ ToString () override
public String ToString ()
public override function ToString () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

OutputCompleteEventArgs Class
OutputCompleteEventArgs Members
Microsoft.PointOfService Namespace


OutputCompleteEventArgs Properties

OutputCompleteEventArgs Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
EventId | Gets the event identifier. (inherited from PosEventArgs )
OutputId | Holds the ID number of the asynchronous output request that is complete.
TimeStamp | Gets the DateTime of the event. (inherited from PosEventArgs )

See Also

Reference

OutputCompleteEventArgs Class
Microsoft.PointOfService Namespace


OutputCompleteEventArgs.OutputId Property

OutputCompleteEventArgs.OutputId Property |
 | See Also

1/18/2008

Holds the ID number of the asynchronous output request that is complete.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property OutputId As Integer
public int OutputId { get; }
public:
property int OutputId {
    int get ();
}
/** @property */
public int get_OutputId ()

public function get OutputId () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

OutputCompleteEventArgs Class
OutputCompleteEventArgs Members
Microsoft.PointOfService Namespace


OutputCompleteEventHandler Delegate

OutputCompleteEventHandler Delegate |
 | See Also

1/18/2008

Defines the method that will handle a OutputCompleteEventArgs events.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Delegate Sub OutputCompleteEventHandler ( _
    sender As Object, _
    e As OutputCompleteEventArgs _
)
public delegate void OutputCompleteEventHandler (
    Object sender,
    OutputCompleteEventArgs e
)
public delegate void OutputCompleteEventHandler (
    Object^ sender,
    OutputCompleteEventArgs^ e
)
/** @delegate */
public delegate void OutputCompleteEventHandler (
    Object sender,
    OutputCompleteEventArgs e
)

Parameters

sender

The service object sending the event.

e

The event, which is an instance of the OutputCompleteEventArgs class. The OutputId property should contain the OutputId associated with the complete asynchronous processing function.

Remarks

Delegate for the OutputCompleteEvent event.

See Also

Reference

Microsoft.PointOfService Namespace
OutputCompleteEvent
OutputCompleteEventArgs Class


PageModeDescriptors Enumeration

PageModeDescriptors Enumeration |
 | See Also

1/18/2008

Lists the valid page mode functions of the printer for the selected PageModeStation.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration PageModeDescriptors
[FlagsAttribute]
public enum PageModeDescriptors
[FlagsAttribute]
public enum class PageModeDescriptors
/** @attribute FlagsAttribute() */
public enum PageModeDescriptors
FlagsAttribute
public enum PageModeDescriptors

Members

Member name | Description
Barcode | Printing of barcodes on the PageModeStation is supported.
BarcodeRotate | Rotation of barcodes on the PageModeStation is supported.
Bitmap | Printing of bitmaps on the PageModeStation is supported.
BitmapRotate | Rotation of bitmaps on the PageModeStation is supported.
None | No function is supported.
Opaque | Text, graphics, and background are opaque, meaning items already placed on the page area in the specified print area will not be visible after being printed over.

Remarks

Used by the PageModeDescriptor property. Members of this enumeration replace the PTR_PM_ range of UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace


PageModePrintControl Enumeration

PageModePrintControl Enumeration |
 | See Also

1/18/2008

Lists the valid Page Mode controls for a print station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration PageModePrintControl
public enum PageModePrintControl
public enum class PageModePrintControl
public enum PageModePrintControl
public enum PageModePrintControl

Members

Member name | Description
Cancel | Clear the page and exit the Page Mode without any printing of any print area.
Normal | Print the print area and destroy the canvas and exit Page Mode.
PageMode | Enter Page Mode.
PrintSave | Print PageModePrintArea and save the canvas. Page Mode is not exited. Use for printing of repeated pages.

Remarks

Used by the PageModePrint method. Members of this enumeration replace the PTR_PM_PAGE_MODE, PTR_PM_PRINT_SAVE, PTR_PM_NORMAL, and PTR_PM_CANCEL UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace


PageModePrintDirection Enumeration

PageModePrintDirection Enumeration |
 | See Also

1/18/2008

Lists the possible print directions that can be set for a print station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration PageModePrintDirection
public enum PageModePrintDirection
public enum class PageModePrintDirection
public enum PageModePrintDirection
public enum PageModePrintDirection

Members

Member name | Description
BottomToTop | Print bottom to top, starting at the bottom left position of the print area (that is, rotated left 90° printing).
LeftToRight | Print left to right, starting at top left position of the print area (that is, normal printing).
None | No valid station is selected.
RightToLeft | Print right to left, starting at the bottom right position of the print area (that is, upside down printing).
TopToBottom | Print top to bottom, starting at the top right position of the print area (that is, rotated right 90° printing.)

Remarks

Used by the PageModePrintDirection property. Members of this enumeration replace the PTR_PD_LEFT_TO_RIGHT, PTR_PD_BOTTOM_TO_TOP, PTR_PD_RIGHT_TO_LEFT, and PTR_PD_TOP_TO_BOTTOM UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace


PaymentCondition Enumeration

PaymentCondition Enumeration |
 | See Also

1/18/2008

Lists the valid payment conditions for an authorization operation.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration PaymentCondition
public enum PaymentCondition
public enum class PaymentCondition
public enum PaymentCondition
public enum PaymentCondition

Members

Member name | Description
Bonus1 | Bonus 1
Bonus2 | Bonus 2
Bonus3 | Bonus 3
Bonus4 | Bonus 4
Bonus5 | Bonus 5
BonusCombination1 | Bonus combination payments 1
BonusCombination2 | Bonus combination payments 2
BonusCombination3 | Bonus combination payments 3
BonusCombination4 | Bonus combination payments 4
Debit | Debit card
ElectronicMoney | Electronic money
Installment1 | Installment 1
Installment2 | Installment 2
Installment3 | Installment 3
Lump | Lump-sum
Revolving | Revolving

Remarks

Used by the PaymentCondition property. Members of this enumeration replace the CAT_PAYMENT_ range of UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
Cat.PaymentCondition Property


PaymentMedia Enumeration

PaymentMedia Enumeration |
 | See Also

1/18/2008

Lists the valid payment media types for an approval method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration PaymentMedia
public enum PaymentMedia
public enum class PaymentMedia
public enum PaymentMedia
public enum PaymentMedia

Members

Member name | Description
Credit | Credit card
Debit | Debit card
ElectronicMoney |
Unspecified | No media type specified

Remarks

Used by the PaymentMedia property. Members of this enumeration replace the CAT_MEDIA_UNSPECIFIED, CAT_MEDIA_CREDIT, CAT_MEDIA_DEBIT, and CAT_MEDIA_ELECTRONIC_MONEY UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
Cat.PaymentMedia Property


PinEntryStatus Enumeration

PinEntryStatus Enumeration |
 | See Also

1/18/2008

Lists the possible PIN entry status values.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration PinEntryStatus
public enum PinEntryStatus
public enum class PinEntryStatus
public enum PinEntryStatus
public enum PinEntryStatus

Members

Member name | Description
BadKey | The user pressed an invalid key during PIN entry.
Cancel | The user pressed the Cancel key, canceling PIN entry.
Error |
Success | PIN entry was successfully completed.
Timeout | The device timed out before PIN entry was completed.

Remarks

Used by the ExitPinEntryMode method implemented by the service object. For more information about ExitPinEntryMode, see PinPadBase class.

See Also

Reference

Microsoft.PointOfService Namespace
ExitPinEntryMode


PinPad Class

PinPad Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a UPOS PIN pad device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class PinPad
    Inherits PosCommon
public abstract class PinPad : PosCommon
public ref class PinPad abstract : public PosCommon
public abstract class PinPad extends PosCommon
public abstract class PinPad extends PosCommon

Remarks

PIN pad devices in POS for .NET support two types of operations:

  • Entering personal identification numbers (PINs), and

  • Communicating with an Electronic Funds Transfer (EFT) Transaction Host, using encrypted data.

PIN pads perform these operations by using one or more PIN Pad Management Systems, which define how the PIN pad performs tasks such as PIN encryption. For example, a PIN pad service object might include PIN Pad Management System implementations for any of the following: Master-Session, DUKPT, APACS40, HGEPOS, AS2805, and JDEBIT2.

The POS for .NET provides methods for implementing the following features:

  • PIN entry at the PIN pad keyboard, which can be encrypted and transferred to the application;

  • Message Authentication Code computations;

  • Key updates in accordance with the parameters of the selected PIN Pad Management System;

  • Support of multiple PIN Pad Management Systems for each PIN pad object; and

  • Use of the PIN pad keyboard, line display, and tone generator devices in conjunction with the PIN pad device.

Programming Model

PIN pads are exclusive-use devices. Therefore, to access and use a PIN pad, the application must:

  • Claim the PIN pad before enabling it; and

  • Claim and enable the PIN pad before it begins reading input, or before the application calls methods that manipulate it.

A PIN pad performs encryption operations under the control of a PIN Pad Management System, which the PIN pad’s service object implements. Depending on the capabilities of the PIN pad, the service object may implement multiple PIN Pad Management Systems, as well as support for multiple key sets within the PIN Pad Management Systems, based on the number and variety of EFT Transaction Hosts. Therefore, for each EFT transaction, the application must select the PIN Pad Management System and EFT Transaction Host to be used.

One or more EFT transaction parameters typically must be provided to the PIN pad for use in encryption operations. To facilitate migration to an EFT Transaction Host that requires a different PIN Pad Management System, it is best to set all EFT Transaction properties.

After claiming and enabling the PIN pad, the application should do the following for each EFT Transaction:

  • Set the PinPad AccountNumber, Amount, MerchantID, TerminalID, Track1Data, Track2Data, Track3Data, Track4Data and TransactionType properties. Call the BeginEftTransaction method, which initializes the service object and PinPad for performing the encryption functions for the EFT transaction.

  • If PIN entry is required, call the EnablePinEntry method, then set the DataEventEnabled property and wait for the DataEvent event.

  • If Message Authentication Codes (MAC) are required, use the ComputeMac and VerifyMac methods.

  • Call the EndEftTransaction method, which notifies the service object that all operations for the EFT transaction have been completed.

  • POS for .NET supports two programming models for how to use the display on the PIN pad. The CapDisplay property, set by the service object and initialized when the application calls the Open method, indicates which of the following models the PIN pad supports:

    In the first model, if the CapDisplay property is set to either PinPadDisplay.Unrestricted or PinPadDisplay.PinRestricted, the application controls the displayed text. The application uses the POS for .NET LineDisplay class to display messages.

    In the second model, if the CapDisplay property is set to either PinPadDisplay.RestrictedList or PinPadDisplay.RestrictedOrder, the application must select from a list of pre-defined and possibly pre-ordered messages to be displayed. For this model, there is a set of PIN pad properties that are used to control the display.

All methods for the PinPadBase Class do basic validation and then call their associated [MethodName]Impl methods, which the underlying Service Object implements. For example, the BeginEftTransaction method sets an internal variable that keeps track of whether or not the transaction is an EFT transaction, prior to calling the underlying service object implementation. Calling the EndEftTransaction method resets this variable.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.PinPad
Microsoft.PointOfService.BasicServiceObjects.PinPadBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Members
Microsoft.PointOfService Namespace


PinPad Members

PinPad Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a UPOS PIN pad device.

The following tables list the members exposed by the PinPad type.

Protected Constructors

Name | Description
PinPad | Creates an instance of the PinPad class.
Top

Public Fields

Name | Description
ExtendedErrorBadKey | Indicates that an encryption key is corrupted or missing.
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticInvalidPINEntryCount | Incremented during the ExitPinEntryMode method if PIN entry has failed.
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatisticValidPINEntryCount | Incremented during the ExitPinEntryMode method if PIN entry has occurred successfully.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
AccountNumber | Holds the user’s account number for the current EFT transaction.
AdditionalSecurityInformation | Holds security/encryption information, formatted as a Hex-ASCII string, after a successful PIN entry operation in which the DataEvent event is queued to the application with a DataEventArgs.Status of Success.
Amount | Holds the amount of the current EFT transaction.
AvailableLanguagesList | Holds an array of the languages supported by the pre-defined prompts in the PIN pad device, as defined by the CultureInfo .NET Framework Class.
AvailablePromptsList | Holds a comma-separated string of supported values for the Prompt property.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapDisplay | Indicates the operations that the application can perform on the PIN pad display.
CapKeyboard | If set to true, the application can use the PIN pad keyboard to obtain input.
CapLanguage | Indicates the language of pre-defined messages for the PIN pad device (for example, English, French, Arabic, and so on).
CapMacCalculation | If set to true, the PIN pad supports MAC calculation.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapTone | If set to true, the PIN pad has a tone indicator, which is implemented as a ToneIndicator class object.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
DataCount | Holds the number of data events currently queued by the service object.
DataEventEnabled | When set to true by the application, the service object can deliver the next queued DataEvent event.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
EncryptedPin | Holds the value of the encrypted PIN after the DataEvent event notifies the application that a PIN entry operation has been completed.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
MaximumPinLength | Holds the maximum acceptable number of digits to be entered for the PIN.
MerchantId | Holds the Merchant ID, as it is known to the EFT Transaction Host.
MinimumPinLength | Holds the minimum acceptable number of digits to be entered for a PIN.
PinEntryEnabled | Indicates whether the PinPad is ready to accept PIN entry.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
Prompt | Holds a pre-defined message to be displayed on the PIN Pad.
PromptLanguage | Specifies the language in which the message specified by the Prompt property will be displayed, as defined by the CultureInfo .NET Framework class.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
TerminalId | Holds the Terminal ID, as it is known to the EFT Transaction Host.
Track1Data | Holds either the decoded Track 1 data from the previous card swipe or an empty string.
Track2Data | Holds either the decoded Track 2 data from the previous card swipe or an empty string.
Track3Data | Holds either the decoded Track 3 data from the previous card swipe or an empty string.
Track4Data | Holds either the decoded Track 4 data from the previous card swipe or an empty string.
TransactionType | Holds the current EFT transaction type.
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Indicates whether the PinPad is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
BeginEftTransaction | Informs the PIN Pad’s service object that an EFT Transaction is starting.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all device input that has been buffered.
ClearInputProperties | Resets the values of properties altered by DataEvent or ErrorEvent.
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
ComputeMac | Tells the service object to compute a MAC value and return it to the application.
DirectIO | (inherited from PosCommon )
EnablePinEntry | Starts PIN entry at the PIN pad device. When EnablePinEntry is called, the service object sets the PinEntryEnabled property to true.
EndEftTransaction | Takes the PIN pad out of EFT Transaction Mode.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon)
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateKey | Provides a new encryption key to the PIN pad service object for those PIN Pad Management Systems in which new key values are sent to the terminal as a field in standard messages from the EFT Transaction Host.
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
VerifyMac | Tells the service object to verify the MAC value in a message received from an EFT Transaction Host.
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DataEvent | Raised by the service object to present input data from the PIN pad device to the application.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
ErrorEvent | Raised by the service object when an error is detected while trying to perform a PIN encryption function.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

PinPad Class
Microsoft.PointOfService Namespace


PinPad Fields

PinPad Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorBadKey | Indicates that an encryption key is corrupted or missing.
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticInvalidPINEntryCount | Incremented during the ExitPinEntryMode method if PIN entry has failed.
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatisticValidPINEntryCount | Incremented during the ExitPinEntryMode method if PIN entry has occurred successfully.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

PinPad Class
Microsoft.PointOfService Namespace


PinPad.ExtendedErrorBadKey Field

PinPad.ExtendedErrorBadKey Field |
 | See Also

1/18/2008

Indicates that an encryption key is corrupted or missing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorBadKey As Integer
public const int ExtendedErrorBadKey
public:
literal int ExtendedErrorBadKey
public static final int ExtendedErrorBadKey
public const var ExtendedErrorBadKey : int

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
ErrorEvent


PinPad.StatisticInvalidPINEntryCount Field

PinPad.StatisticInvalidPINEntryCount Field |
 | See Also

1/18/2008

Incremented during the ExitPinEntryMode method if PIN entry has failed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticInvalidPINEntryCount As String
public const string StatisticInvalidPINEntryCount
public:
literal String^ StatisticInvalidPINEntryCount
public static final String StatisticInvalidPINEntryCount
public const var StatisticInvalidPINEntryCount : String

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
ExitPinEntryMode


PinPad.StatisticValidPINEntryCount Field

PinPad.StatisticValidPINEntryCount Field |
 | See Also

1/18/2008

Incremented during the ExitPinEntryMode method if PIN entry has occurred successfully.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticValidPINEntryCount As String
public const string StatisticValidPINEntryCount
public:
literal String^ StatisticValidPINEntryCount
public static final String StatisticValidPINEntryCount
public const var StatisticValidPINEntryCount : String

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
ExitPinEntryMode


PinPad Constructor

PinPad Constructor |
 | See Also

1/18/2008

Creates an instance of the PinPad class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected PinPad ()
protected:
PinPad ()
protected PinPad ()
protected function PinPad ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace


PinPad Methods

PinPad Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
BeginEftTransaction | Informs the PIN Pad’s service object that an EFT Transaction is starting.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all device input that has been buffered.
ClearInputProperties | Resets the values of properties altered by DataEvent or ErrorEvent.
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
ComputeMac | Tells the service object to compute a MAC value and return it to the application.
DirectIO | (inherited from PosCommon )
EnablePinEntry | Starts PIN entry at the PIN pad device. When EnablePinEntry is called, the service object sets the PinEntryEnabled property to true.
EndEftTransaction | Takes the PIN pad out of EFT Transaction Mode.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon )
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateKey | Provides a new encryption key to the PIN pad service object for those PIN Pad Management Systems in which new key values are sent to the terminal as a field in standard messages from the EFT Transaction Host.
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
VerifyMac | Tells the service object to verify the MAC value in a message received from an EFT Transaction Host.

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

PinPad Class
Microsoft.PointOfService Namespace


PinPad.BeginEftTransaction Method

PinPad.BeginEftTransaction Method |
 | See Also

1/18/2008

Informs the PIN Pad’s service object that an EFT Transaction is starting.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub BeginEftTransaction ( _
    pinpadSystem As PinPadSystem, _
    transactionHost As Integer _
)
public abstract void BeginEftTransaction (
    PinPadSystem pinpadSystem,
    int transactionHost
)
public:
virtual void BeginEftTransaction (
    PinPadSystem pinpadSystem,
    int transactionHost
) abstract
public abstract void BeginEftTransaction (
    PinPadSystem pinpadSystem,
    int transactionHost
)
public abstract function BeginEftTransaction (
    pinpadSystem : PinPadSystem,
    transactionHost : int
)

Parameters

pinpadSystem

Name of the desired PIN Pad Management System.

transactionHost

Identifies the EFT Transaction Host to be used for this transaction.

Remarks

The service object will perform initialization functions (for example, computing session keys). No other PIN pad functions can be performed until BeginEftTransaction is called.

BeginEftTransaction may cause a PosControlException to be thrown with the following ErrorCode:

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The requested PIN Pad Management System is not supported by the service object; or

  • The requested EFT Transaction Host is an illegal value for the selected PIN Pad Management System.

Busy

The PIN pad device is already performing an EFT transaction.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
EndEftTransaction


PinPad.ClearInput Method

PinPad.ClearInput Method |
 | See Also

1/18/2008

Clears all device input that has been buffered.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearInput
public abstract void ClearInput ()
public:
virtual void ClearInput () abstract
public abstract void ClearInput ()
public abstract function ClearInput ()

Remarks

Any data events or input error events that were queued by the service object– usually waiting for DataEventEnabled to be set to true and FreezeEvents to be set to false – are also cleared.

ClearInput may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Claimed | The device is claimed by another process.
NotClaimed | The device must be claimed before ClearInput can be used.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
DataEventEnabled
FreezeEvents


PinPad.ClearInputProperties Method

PinPad.ClearInputProperties Method |
 | See Also

1/18/2008

Resets the values of properties altered by DataEvent or ErrorEvent.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Sub ClearInputProperties
public virtual void ClearInputProperties ()
public:
virtual void ClearInputProperties ()
public void ClearInputProperties ()
public function ClearInputProperties ()

Remarks

Sets all data properties populated by a firing of DataEvent or ErrorEvent back to their default values. This does not reset the DataCount or State properties.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace


PinPad.ComputeMac Method

PinPad.ComputeMac Method |
 | See Also

1/18/2008

Tells the service object to compute a MAC value and return it to the application.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function ComputeMac ( _
    inMsg As String _
) As String
public abstract string ComputeMac (
    string inMsg
)
public:
virtual String^ ComputeMac (
    String^ inMsg
) abstract
public abstract String ComputeMac (
    String inMsg
)
public abstract function ComputeMac (
    inMsg : String
) : String

Parameters

inMsg

Contains the message that the application intends to send to the EFT Transaction Host.

Remarks

Depending on the selected PIN Pad Management System, the service object may also insert other fields into the returned string.

Note:
The ComputeMac method cannot be used when the PinEntryEnabled property is set to true.

ComputeMac returns the MAC value if successful. It may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Disabled | The application has not called the BeginEftTransaction method prior to calling ComputeMac.
Busy | The PinEntryEnabled property is set to true. The PIN pad can’t perform a MAC calculation during PIN entry.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
PinEntryEnabled
PinPad.BeginEftTransaction Method


PinPad.EnablePinEntry Method

PinPad.EnablePinEntry Method |
 | See Also

1/18/2008

Starts PIN entry at the PIN pad device. When EnablePinEntry is called, the service object sets the PinEntryEnabled property to true.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub EnablePinEntry
public abstract void EnablePinEntry ()
public:
virtual void EnablePinEntry () abstract
public abstract void EnablePinEntry ()
public abstract function EnablePinEntry ()

Remarks

When the user has completed the PIN entry operation (either by entering their PIN or by hitting Cancel), the service object calls the ExitPinEntry protected method of the PinPadBase class. ExitPinEntry raises a DataEvent event to provide the encrypted PIN to the application (when the DataEventEnabled property is set to true). In addition, ExitPinEntry sets the PinEntryEnabled property to false.

Note that any data the user enters at the PIN pad while the PinEntryEnabled property is set to true will be supplied in encrypted form to the application and will NOT be provided to any associated PosKeyboard Class.

EnablePinEntry may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Disabled | The application has not called the BeginEftTransaction method prior to calling EnablePinEntry.
Busy | The PinEntryEnabled property was already set to true, indicating that the PIN pad device is already performing pin entry.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
PinEntryEnabled
Prompt
PinPad.BeginEftTransaction Method


PinPad.EndEftTransaction Method

PinPad.EndEftTransaction Method |
 | See Also

1/18/2008

Takes the PIN pad out of EFT Transaction Mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub EndEftTransaction ( _
    completionCode As EftTransactionCompletion _
)
public abstract void EndEftTransaction (
    EftTransactionCompletion completionCode
)
public:
virtual void EndEftTransaction (
    EftTransactionCompletion completionCode
) abstract
public abstract void EndEftTransaction (
    EftTransactionCompletion completionCode
)
public abstract function EndEftTransaction (
    completionCode : EftTransactionCompletion
)

Parameters

completionCode

Valid values for the completionCode are defined by the EftTransactionCompletion enumeration.

Remarks

The service object will perform termination functions (for example, computing next transaction keys). EndEftTransaction sets the PinEntryEnabled property to false.

EndEftTransaction may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Disabled | The application has not called the BeginEftTransaction method prior to calling EndEftTransaction.
Illegal | The value specified for the completionCode parameter doesn’t exist in the EftTransactionCompletion enumerator.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
PinPad.BeginEftTransaction Method


PinPad.UpdateKey Method

PinPad.UpdateKey Method |
 | See Also

1/18/2008

Provides a new encryption key to the PIN pad service object for those PIN Pad Management Systems in which new key values are sent to the terminal as a field in standard messages from the EFT Transaction Host.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub UpdateKey ( _
    keyNumber As Integer, _
    key As String _
)
public abstract void UpdateKey (
    int keyNumber,
    string key
)
public:
virtual void UpdateKey (
    int keyNumber,
    String^ key
) abstract
public abstract void UpdateKey (
    int keyNumber,
    String key
)
public abstract function UpdateKey (
    keyNumber : int,
    key : String
)

Parameters

keyNumber

Contains a key number.

key

Contains a Hex-ASCII value for a new key.

Remarks

UpdateKey may cause a PosControlException to be thrown with the following ErrorCode:

Value

Meaning

Disabled

The application has not called the BeginEftTransaction method prior to calling EndEftTransaction.

Illegal

One of the following conditions occurred:

  • The selected PIN Pad Management System does not support UpdateKey;

  • The keyNumber parameter specifies an unacceptable key number; or

  • The key parameter contains a bad key (not Hex-ASCII or wrong length or bad parity).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
PinPad.BeginEftTransaction Method
PinPad.EndEftTransaction Method


PinPad.VerifyMac Method

PinPad.VerifyMac Method |
 | See Also

1/18/2008

Tells the service object to verify the MAC value in a message received from an EFT Transaction Host.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub VerifyMac ( _
    message As String _
)
public abstract void VerifyMac (
    string message
)
public:
virtual void VerifyMac (
    String^ message
) abstract
public abstract void VerifyMac (
    String message
)
public abstract function VerifyMac (
    message : String
)

Parameters

message

The message parameter contains a message received from an EFT Transaction Host.

Remarks

VerifyMac may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Disabled | The application has not called the BeginEftTransaction method.
Illegal | The PinEntryEnabled property is set to true; the PIN pad can’t perform a MAC verification during PIN entry.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
PinPad.BeginEftTransaction Method
PinEntryEnabled


PinPad Properties

PinPad Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
AccountNumber | Holds the user’s account number for the current EFT transaction.
AdditionalSecurityInformation | Holds security/encryption information, formatted as a Hex-ASCII string, after a successful PIN entry operation in which the DataEvent event is queued to the application with a DataEventArgs.Status of Success.
Amount | Holds the amount of the current EFT transaction.
AvailableLanguagesList | Holds an array of the languages supported by the pre-defined prompts in the PIN pad device, as defined by the CultureInfo .NET Framework Class.
AvailablePromptsList | Holds a comma-separated string of supported values for the Prompt property.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapDisplay | Indicates the operations that the application can perform on the PIN pad display.
CapKeyboard | If set to true, the application can use the PIN pad keyboard to obtain input.
CapLanguage | Indicates the language of pre-defined messages for the PIN pad device (for example, English, French, Arabic, and so on).
CapMacCalculation | If set to true, the PIN pad supports MAC calculation.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapTone | If set to true, the PIN pad has a tone indicator, which is implemented as a ToneIndicator class object.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
DataCount | Holds the number of data events currently queued by the service object.
DataEventEnabled | When set to true by the application, the service object can deliver the next queued DataEvent event.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
EncryptedPin | Holds the value of the encrypted PIN after the DataEvent event notifies the application that a PIN entry operation has been completed.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
MaximumPinLength | Holds the maximum acceptable number of digits to be entered for the PIN.
MerchantId | Holds the Merchant ID, as it is known to the EFT Transaction Host.
MinimumPinLength | Holds the minimum acceptable number of digits to be entered for a PIN.
PinEntryEnabled | Indicates whether the PinPad is ready to accept PIN entry.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
Prompt | Holds a pre-defined message to be displayed on the PIN Pad.
PromptLanguage | Specifies the language in which the message specified by the Prompt property will be displayed, as defined by the CultureInfo .NET Framework class.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )
TerminalId | Holds the Terminal ID, as it is known to the EFT Transaction Host.
Track1Data | Holds either the decoded Track 1 data from the previous card swipe or an empty string.
Track2Data | Holds either the decoded Track 2 data from the previous card swipe or an empty string.
Track3Data | Holds either the decoded Track 3 data from the previous card swipe or an empty string.
Track4Data | Holds either the decoded Track 4 data from the previous card swipe or an empty string.
TransactionType | Holds the current EFT transaction type.

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Indicates whether the PinPad is an exclusive-use device.

See Also

Reference

PinPad Class
Microsoft.PointOfService Namespace


PinPad.AccountNumber Property

PinPad.AccountNumber Property |
 | See Also

1/18/2008

Holds the user’s account number for the current EFT transaction.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AccountNumber As String
public abstract string AccountNumber { get; set; }
public:
virtual property String^ AccountNumber {
    String^ get () abstract;
    void set (String^ value) abstract;
}
/** @property */
public abstract String get_AccountNumber ()

/** @property */
public abstract void set_AccountNumber (String value)

public abstract function get AccountNumber () : String

public abstract function set AccountNumber (value : String)

Remarks

The application must set AccountNumber before calling the BeginEftTransaction method.

Accessing AccountNumber may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The BeginEftTransaction method was called before the attempt to set this property; AccountNumber can’t be changed while in EFT Transaction Mode.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
PinPad.BeginEftTransaction Method


PinPad.AdditionalSecurityInformation Property

PinPad.AdditionalSecurityInformation Property |
 | See Also

1/18/2008

Holds security/encryption information, formatted as a Hex-ASCII string, after a successful PIN entry operation in which the DataEvent event is queued to the application with a DataEventArgs.Status of Success.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property AdditionalSecurityInformation As String
public abstract string AdditionalSecurityInformation { get; }
public:
virtual property String^ AdditionalSecurityInformation {
    String^ get () abstract;
}
/** @property */
public abstract String get_AdditionalSecurityInformation ()

public abstract function get AdditionalSecurityInformation () : String

Remarks

The content and internal format of this string will vary depending on the PIN Pad Management System being used. For example, for DUKPT-based key encryption, AdditionalSecurityInformation contains the PIN pad sequence number. If the user cancels the PIN entry operation, resulting in the DataEvent event DataEventArgs.Status property set to Cancel, AdditionalSecurityInformation will contain an empty string.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
DataEvent


PinPad.Amount Property

PinPad.Amount Property |
 | See Also

1/18/2008

Holds the amount of the current EFT transaction.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property Amount As Decimal
public abstract decimal Amount { get; set; }
public:
virtual property Decimal Amount {
    Decimal get () abstract;
    void set (Decimal value) abstract;
}
/** @property */
public abstract Decimal get_Amount ()

/** @property */
public abstract void set_Amount (Decimal value)

public abstract function get Amount () : decimal

public abstract function set Amount (value : decimal)

Remarks

The application must set Amount before calling the BeginEftTransaction method.

Accessing Amount may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The BeginEftTransaction method was called before setting this property: Amount can’t be changed while in EFT Transaction Mode.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
PinPad.BeginEftTransaction Method


PinPad.AvailableLanguagesList Property

PinPad.AvailableLanguagesList Property |
 | See Also

1/18/2008

Holds an array of the languages supported by the pre-defined prompts in the PIN pad device, as defined by the CultureInfo .NET Framework Class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property AvailableLanguagesList As CultureInfo()
public abstract CultureInfo[] AvailableLanguagesList { get; }
public:
virtual property array<CultureInfo^>^ AvailableLanguagesList {
    array<CultureInfo^>^ get () abstract;
}
/** @property */
public abstract CultureInfo[] get_AvailableLanguagesList ()

public abstract function get AvailableLanguagesList () : CultureInfo[]

Remarks

Languages are represented by numeric values and are Microsoft Windows Language IDs, defined in the .NET Framework Class Library documentation. If the CapLanguage property is set to CultureInfo.None, then AvailableLanguagesList will be an empty string.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
CapLanguage


PinPad.AvailablePromptsList Property

PinPad.AvailablePromptsList Property |
 | See Also

1/18/2008

Holds a comma-separated string of supported values for the Prompt property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property AvailablePromptsList As PinPadMessage()
public abstract PinPadMessage[] AvailablePromptsList { get; }
public:
virtual property array<PinPadMessage>^ AvailablePromptsList {
    array<PinPadMessage>^ get () abstract;
}
/** @property */
public abstract PinPadMessage[] get_AvailablePromptsList ()

public abstract function get AvailablePromptsList () : PinPadMessage[]

Remarks

Possible values are defined by the PinPadMessage enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
Prompt
PinPadMessage


PinPad.CapDisplay Property

PinPad.CapDisplay Property |
 | See Also

1/18/2008

Indicates the operations that the application can perform on the PIN pad display.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapDisplay As PinPadDisplay
public abstract PinPadDisplay CapDisplay { get; }
public:
virtual property PinPadDisplay CapDisplay {
    PinPadDisplay get () abstract;
}
/** @property */
public abstract PinPadDisplay get_CapDisplay ()

public abstract function get CapDisplay () : PinPadDisplay

Remarks

Possible values are defined by the PinPadDisplay enumeration. Values are:

Value | Meaning
Unrestricted | The application can use the PIN pad’s display in an unrestricted manner to display messages. The associated LineDisplay Class is the interface to the PIN pad’s display; the application must call LineDisplay methods to manipulate the display.
PinRestricted | The application can use the PIN pad’s display in an unrestricted manner except during PIN entry. The PIN pad will display a pre-defined message during PIN entry. If the application attempts to use the associated line display while PIN entry is enabled, the line display’s service object will set the ErrorCode property to Busy.
RestrictedList | The application cannot specify the text of messages to display; it can only select from a list of pre-defined messages. There is no associated line display object.
RestrictedOrder | The application cannot specify the text of messages to display; it can only select from a list of pre-defined messages. The selections must occur in a pre-defined order. There is no associated line display object.
None | The PIN pad device in use does not have a display.

CapDisplay is set by the service object, based on the capability of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
LineDisplay Class
PinPadDisplay
PinPad.CapDisplay Property


PinPad.CapKeyboard Property

PinPad.CapKeyboard Property |
 | See Also

1/18/2008

If set to true, the application can use the PIN pad keyboard to obtain input.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapKeyboard As Boolean
public abstract bool CapKeyboard { get; }
public:
virtual property bool CapKeyboard {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapKeyboard ()

public abstract function get CapKeyboard () : boolean

Remarks

The PIN pad keyboard is implemented as a PosKeyboard class object.

The PosKeyboard class object is disabled while the PinEntryEnabled property is set to true.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
PosKeyboard


PinPad.CapLanguage Property

PinPad.CapLanguage Property |
 | See Also

1/18/2008

Indicates the language of pre-defined messages for the PIN pad device (for example, English, French, Arabic, and so on).

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapLanguage As PinPadLanguage
public abstract PinPadLanguage CapLanguage { get; }
public:
virtual property PinPadLanguage CapLanguage {
    PinPadLanguage get () abstract;
}
/** @property */
public abstract PinPadLanguage get_CapLanguage ()

public abstract function get CapLanguage () : PinPadLanguage

Remarks

Possible values are defined by the PinPadLanguage enumeration. Values are:

Value | Meaning
None | The PIN pad supports no pre-defined prompt messages. CapLanguage will be set to this value if the CapDisplay property is set to PinPadDisplay.RestrictedOrder. If the application tries to set the value of the PromptLanguage property, the service object sets the ErrorCode property to Illegal.
One | The PIN pad supports pre-defined prompt messages in one language. If the application tries to set the value of the PromptLanguage property, the service object will set the ErrorCode property to Illegal.
PinRestricted | The PIN pad cannot change prompt languages during PIN entry. The application must set the PromptLanguage property to the desired value before calling the EnablePinEntry method. Attempting to set the value of the PromptLanguage while the PinEntryEnabled property is set to true will cause the service object to set the ErrorCode property to Busy.
Unrestricted | The application can change the language of pre-defined prompt messages at any time, and the currently displayed message will change immediately.

CapLanguage is set by the service object, based on the capability of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
PromptLanguage
PinEntryEnabled
PinPad.EnablePinEntry Method
PinPadLanguage


PinPad.CapMacCalculation Property

PinPad.CapMacCalculation Property |
 | See Also

1/18/2008

If set to true, the PIN pad supports MAC calculation.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapMacCalculation As Boolean
public abstract bool CapMacCalculation { get; }
public:
virtual property bool CapMacCalculation {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapMacCalculation ()

public abstract function get CapMacCalculation () : boolean

Remarks

CapMacCalculation is set by the service object, based on the capability of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace


PinPad.CapTone Property

PinPad.CapTone Property |
 | See Also

1/18/2008

If set to true, the PIN pad has a tone indicator, which is implemented as a ToneIndicator class object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapTone As Boolean
public abstract bool CapTone { get; }
public:
virtual property bool CapTone {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapTone ()

public abstract function get CapTone () : boolean

Remarks

CapTone is set by the service object, based on the capability of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
CapTone


PinPad.DataCount Property

PinPad.DataCount Property |
 | See Also

1/18/2008

Holds the number of data events currently queued by the service object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DataCount As Integer
public abstract int DataCount { get; }
public:
virtual property int DataCount {
    int get () abstract;
}
/** @property */
public abstract int get_DataCount ()

public abstract function get DataCount () : int

Remarks

The application can read DataCount to determine whether additional input is queued from a device but has not yet been delivered (because of other application processing, freezing of events, or other causes).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
DataEvent


PinPad.DataEventEnabled Property

PinPad.DataEventEnabled Property |
 | See Also

1/18/2008

When set to true by the application, the service object can deliver the next queued DataEvent event.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property DataEventEnabled As Boolean
public abstract bool DataEventEnabled { get; set; }
public:
virtual property bool DataEventEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_DataEventEnabled ()

/** @property */
public abstract void set_DataEventEnabled (boolean value)

public abstract function get DataEventEnabled () : boolean

public abstract function set DataEventEnabled (value : boolean)

Remarks

Note that conditions may exist that delay “immediate” delivery: If the FreezeEvents property is set to true, or if the AutoDisable property is set to true and the DeviceEnabled property is set to false.

When DataEventEnabled is set to false by the application, the service object queues input data for later delivery to the application.

Note:
If an error occurs during input processing, the service object queues the error event but doesn’t deliver it until the application sets DataEventEnabled to true.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
FreezeEvents
DeviceEnabled
DataEvent


PinPad.EncryptedPin Property

PinPad.EncryptedPin Property |
 | See Also

1/18/2008

Holds the value of the encrypted PIN after the DataEvent event notifies the application that a PIN entry operation has been completed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property EncryptedPin As String
public abstract string EncryptedPin { get; }
public:
virtual property String^ EncryptedPin {
    String^ get () abstract;
}
/** @property */
public abstract String get_EncryptedPin ()

public abstract function get EncryptedPin () : String

Remarks

EncryptedPin is formatted as a hexadecimal ASCII string, in which each character ranges from ‘0’ through ‘9’ or ‘A’ through ‘F’. Each pair of characters is the hexadecimal representation for a byte. For example, if the first four characters are “12FA”, then the first two bytes of the PIN are 12 hexadecimal (18) and FA hexadecimal (250).

If the PIN entry was canceled, EncryptedPin will contain an empty string.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
DataEvent


PinPad.IsExclusiveUseDevice Property

PinPad.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Indicates whether the PinPad is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Property Value

A value of true indicates that the PinPad is exclusive-use. Otherwise, the value will be false.

Remarks

An exclusive-use device has the following properties:

  • The application must claim the device before enabling it.

  • The application must claim and enable the device before accessing some properties or calling methods that update the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace


PinPad.MaximumPinLength Property

PinPad.MaximumPinLength Property |
 | See Also

1/18/2008

Holds the maximum acceptable number of digits to be entered for the PIN.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property MaximumPinLength As Integer
public abstract int MaximumPinLength { get; set; }
public:
virtual property int MaximumPinLength {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_MaximumPinLength ()

/** @property */
public abstract void set_MaximumPinLength (int value)

public abstract function get MaximumPinLength () : int

public abstract function set MaximumPinLength (value : int)

Remarks

The application should set MaximumPinLength prior to calling the EnablePinEntry method. For some PIN pad device implementations, this value cannot be changed by the application.

Accessing MaximumPinLength may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | One of the following conditions has occurred:The EnablePinEntry method has been called—MaximumPinLength can’t be changed during PIN entry;The value specified is less than 0 (zero); orThe value specified is less than that specified for the MinimumPinLength property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
PinPad.EnablePinEntry Method


PinPad.MerchantId Property

PinPad.MerchantId Property |
 | See Also

1/18/2008

Holds the Merchant ID, as it is known to the EFT Transaction Host.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property MerchantId As String
public abstract string MerchantId { get; set; }
public:
virtual property String^ MerchantId {
    String^ get () abstract;
    void set (String^ value) abstract;
}
/** @property */
public abstract String get_MerchantId ()

/** @property */
public abstract void set_MerchantId (String value)

public abstract function get MerchantId () : String

public abstract function set MerchantId (value : String)

Remarks

The application must set MerchantID before calling the BeginEftTransaction method. Attempting to change MerchantID after calling the BeginEftTransaction method will result in the service object setting the ErrorCode property to Illegal.

Accessing MerchantID may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The application has called the BeginEftTransaction method—MerchantID can’t be set while in EFT Transaction Mode.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
PinPad.BeginEftTransaction Method


PinPad.MinimumPinLength Property

PinPad.MinimumPinLength Property |
 | See Also

1/18/2008

Holds the minimum acceptable number of digits to be entered for a PIN.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property MinimumPinLength As Integer
public abstract int MinimumPinLength { get; set; }
public:
virtual property int MinimumPinLength {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_MinimumPinLength ()

/** @property */
public abstract void set_MinimumPinLength (int value)

public abstract function get MinimumPinLength () : int

public abstract function set MinimumPinLength (value : int)

Remarks

The application should set MinimumPinLength to the minimum acceptable number of digits for the PIN to be entered, prior to calling the EnablePinEntry method. For some PIN pad device implementations, this value cannot be changed by the application.

Accessing MinimumPinLength may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | One of the following conditions has occurred:The EnablePinEntry method has been called— MinimumPinLength can’t be changed during PIN entry;The value specified is less than 0 (zero); orThe value specified is greater than that specified for the MaximumPinLength property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
PinPad.EnablePinEntry Method


PinPad.PinEntryEnabled Property

PinPad.PinEntryEnabled Property |
 | See Also

1/18/2008

Indicates whether the PinPad is ready to accept PIN entry.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property PinEntryEnabled As Boolean
public abstract bool PinEntryEnabled { get; }
public:
virtual property bool PinEntryEnabled {
    bool get () abstract;
}
/** @property */
public abstract boolean get_PinEntryEnabled ()

public abstract function get PinEntryEnabled () : boolean

Remarks

The service object sets PinEntryEnabled to true when the application calls the EnablePinEntry method. When the user has completed the PIN entry operation or an EndEftTransaction is executed, the service object sets PinEntryEnabled to false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
PinPad.EnablePinEntry Method
PinPad.EndEftTransaction Method


PinPad.Prompt Property

PinPad.Prompt Property |
 | See Also

1/18/2008

Holds a pre-defined message to be displayed on the PIN Pad.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property Prompt As PinPadMessage
public abstract PinPadMessage Prompt { get; set; }
public:
virtual property PinPadMessage Prompt {
    PinPadMessage get () abstract;
    void set (PinPadMessage value) abstract;
}
/** @property */
public abstract PinPadMessage get_Prompt ()

/** @property */
public abstract void set_Prompt (PinPadMessage value)

public abstract function get Prompt () : PinPadMessage

public abstract function set Prompt (value : PinPadMessage)

Remarks

Prompt identifies a pre-defined message for the application to display on the PIN pad device. Prompt is used if the CapDisplay property is set to PinPadDisplay.RestrictedList or PinPadDisplay.RestrictedOrder. Prompt is also used during PIN entry if CapDisplay is set to PinPadDisplay.PinRestricted. The AvailablePromptsList property lists the values that the service object will accept for Prompt. These values are defined by the PinPadMessage enumeration.

Accessing Prompt may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The application tried to set Prompt to a value that isn’t in the AvailablePromptsList property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
PromptLanguage
PinPad.CapDisplay Property
PinPad.AvailablePromptsList Property
PinPadMessage


PinPad.PromptLanguage Property

PinPad.PromptLanguage Property |
 | See Also

1/18/2008

Specifies the language in which the message specified by the Prompt property will be displayed, as defined by the CultureInfo .NET Framework class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property PromptLanguage As CultureInfo
public abstract CultureInfo PromptLanguage { get; set; }
public:
virtual property CultureInfo^ PromptLanguage {
    CultureInfo^ get () abstract;
    void set (CultureInfo^ value) abstract;
}
/** @property */
public abstract CultureInfo get_PromptLanguage ()

/** @property */
public abstract void set_PromptLanguage (CultureInfo value)

public abstract function get PromptLanguage () : CultureInfo

public abstract function set PromptLanguage (value : CultureInfo)

Remarks

The exact effect of changing PromptLanguage depends on the value of the CapLanguage property.

The values for PromptLanguage are Microsoft Windows Language IDs, defined in the .NET Framework Class Library documentation. The service object initializes PromptLanguage to a default value when the application calls the Open method.

Accessing PromptLanguage may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Busy | PIN entry is currently enabled.
Illegal | One of the following conditions occurred:The application tried to set PromptLanguage to a value that doesn’t exist in the AvailableLanguagesList property; orOnly one language is supported, and it is not the language specified.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
PinPad.CapLanguage Property


PinPad.TerminalId Property

PinPad.TerminalId Property |
 | See Also

1/18/2008

Holds the Terminal ID, as it is known to the EFT Transaction Host.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property TerminalId As String
public abstract string TerminalId { get; set; }
public:
virtual property String^ TerminalId {
    String^ get () abstract;
    void set (String^ value) abstract;
}
/** @property */
public abstract String get_TerminalId ()

/** @property */
public abstract void set_TerminalId (String value)

public abstract function get TerminalId () : String

public abstract function set TerminalId (value : String)

Remarks

The application must set TerminalID before calling the BeginEftTransaction method.

Accessing TerminalID may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The application has called the BeginEftTransaction method—TerminalID can’t be set while the device is in EFT Transaction Mode.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
PinPad.BeginEftTransaction Method


PinPad.Track1Data Property

PinPad.Track1Data Property |
 | See Also

1/18/2008

Holds either the decoded Track 1 data from the previous card swipe or an empty string.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property Track1Data As Byte()
public abstract byte[] Track1Data { get; set; }
public:
virtual property array<unsigned char>^ Track1Data {
    array<unsigned char>^ get () abstract;
    void set (array<unsigned char>^ value) abstract;
}
/** @property */
public abstract byte[] get_Track1Data ()

/** @property */
public abstract void set_Track1Data (byte[] value)

public abstract function get Track1Data () : byte[]

public abstract function set Track1Data (value : byte[])

Remarks

An empty string indicates that the track was not physically read. The application must set Track1Data before calling the BeginEftTransaction method.

Accessing Track1Data may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The application has called the BeginEftTransaction method-- Track1Data can’t be set while the device is in EFT Transaction Mode.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
PinPad.BeginEftTransaction Method


PinPad.Track2Data Property

PinPad.Track2Data Property |
 | See Also

1/18/2008

Holds either the decoded Track 2 data from the previous card swipe or an empty string.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property Track2Data As Byte()
public abstract byte[] Track2Data { get; set; }
public:
virtual property array<unsigned char>^ Track2Data {
    array<unsigned char>^ get () abstract;
    void set (array<unsigned char>^ value) abstract;
}
/** @property */
public abstract byte[] get_Track2Data ()

/** @property */
public abstract void set_Track2Data (byte[] value)

public abstract function get Track2Data () : byte[]

public abstract function set Track2Data (value : byte[])

Remarks

An empty string indicates that the track was not physically read. The application must set Track2Data before calling the BeginEftTransaction method.

Accessing Track2Data may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The application has called the BeginEftTransaction method-- Track2Data can’t be set while the device is in EFT Transaction Mode.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
PinPad.BeginEftTransaction Method


PinPad.Track3Data Property

PinPad.Track3Data Property |
 | See Also

1/18/2008

Holds either the decoded Track 3 data from the previous card swipe or an empty string.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property Track3Data As Byte()
public abstract byte[] Track3Data { get; set; }
public:
virtual property array<unsigned char>^ Track3Data {
    array<unsigned char>^ get () abstract;
    void set (array<unsigned char>^ value) abstract;
}
/** @property */
public abstract byte[] get_Track3Data ()

/** @property */
public abstract void set_Track3Data (byte[] value)

public abstract function get Track3Data () : byte[]

public abstract function set Track3Data (value : byte[])

Remarks

An empty string indicates that the track was not physically read. The application must set Track3Data before calling the BeginEftTransaction method.

Accessing Track3Data may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The application has called the BeginEftTransaction method-- Track3Data can’t be set while the device is in EFT Transaction Mode.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
PinPad.BeginEftTransaction Method


PinPad.Track4Data Property

PinPad.Track4Data Property |
 | See Also

1/18/2008

Holds either the decoded Track 4 data from the previous card swipe or an empty string.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property Track4Data As Byte()
public abstract byte[] Track4Data { get; set; }
public:
virtual property array<unsigned char>^ Track4Data {
    array<unsigned char>^ get () abstract;
    void set (array<unsigned char>^ value) abstract;
}
/** @property */
public abstract byte[] get_Track4Data ()

/** @property */
public abstract void set_Track4Data (byte[] value)

public abstract function get Track4Data () : byte[]

public abstract function set Track4Data (value : byte[])

Remarks

An empty string indicates that the track was not physically read. The application must set Track4Data before calling the BeginEftTransaction method.

To maintain compatibility with previous versions, the base class may also continue to store the JIS-II data in another TracknData property. However, to ensure application portability, it is best to use Track4Data to access JIS-II data.

Accessing Track4Data may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The application has called the BeginEftTransaction method-- Track4Data can’t be set while the device is in EFT Transaction Mode.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
PinPad.BeginEftTransaction Method


PinPad.TransactionType Property

PinPad.TransactionType Property |
 | See Also

1/18/2008

Holds the current EFT transaction type.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property TransactionType As EftTransactionType
public abstract EftTransactionType TransactionType { get; set; }
public:
virtual property EftTransactionType TransactionType {
    EftTransactionType get () abstract;
    void set (EftTransactionType value) abstract;
}
/** @property */
public abstract EftTransactionType get_TransactionType ()

/** @property */
public abstract void set_TransactionType (EftTransactionType value)

public abstract function get TransactionType () : EftTransactionType

public abstract function set TransactionType (value : EftTransactionType)

Remarks

The application must set TransactionType before calling the BeginEftTransaction method. Valid types are defined by the EftTransactionType enumeration.

Accessing TransactionType may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | One of the following conditions has occurred:The application has called the BeginEftTransaction method—TransactionType can’t be changed while the device is in EFT Transaction Mode; orThe value specified wasn’t found in the EftTransactionType enumerator.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
PinPad.BeginEftTransaction Method


PinPad Events

PinPad Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DataEvent | Raised by the service object to present input data from the PIN pad device to the application.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
ErrorEvent | Raised by the service object when an error is detected while trying to perform a PIN encryption function.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

PinPad Class
Microsoft.PointOfService Namespace


PinPad.DataEvent Event

PinPad.DataEvent Event |
 | See Also

1/18/2008

Raised by the service object to present input data from the PIN pad device to the application.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event DataEvent As DataEventHandler
public abstract event DataEventHandler DataEvent
public:
virtual event DataEventHandler^ DataEvent {
    void add (DataEventHandler^ value) abstract;
    void remove (DataEventHandler^ value) abstract;
}
/** @event */
public abstract void add_DataEvent (DataEventHandler value)

/** @event */
public abstract void remove_DataEvent (DataEventHandler value)

Remarks

The DataEventArgs.Status property is set to one of the following values:

Value | Meaning
Success | The user has entered a PIN and values have been stored into the EncryptedPin and AdditionalSecurityInformation properties.
Cancel | The user hit the cancel button on the PIN pad device.
Timeout | A timeout condition occurred in the PIN pad device. (Not all PIN pads will report this condition).

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
DataEventArgs Class
DataEventHandler Delegate


PinPad.ErrorEvent Event

PinPad.ErrorEvent Event |
 | See Also

1/18/2008

Raised by the service object when an error is detected while trying to perform a PIN encryption function.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event ErrorEvent As DeviceErrorEventHandler
public abstract event DeviceErrorEventHandler ErrorEvent
public:
virtual event DeviceErrorEventHandler^ ErrorEvent {
    void add (DeviceErrorEventHandler^ value) abstract;
    void remove (DeviceErrorEventHandler^ value) abstract;
}
/** @event */
public abstract void add_ErrorEvent (DeviceErrorEventHandler value)

/** @event */
public abstract void remove_ErrorEvent (DeviceErrorEventHandler value)

Remarks

The DataEventArgs.ErrorCode property can be one of the following:

Value | Meaning
Extended | The DataEventArgs.ErrorCodeExtended property is set to ExtendedErrorBadKey: an encryption key is corrupted or missing.
Other Values | See ErrorCode and ErrorCodeExtended properties.

The DataEventArgs.ErrorLocus property can be set to:

Value | Meaning
Input | An error occurred while gathering or processing event-driven input. No input data is available.

The contents of the DataEventArgs.ErrorResponse property are preset to a default value, based on the DataEventArgs.ErrorLocus:

Value | Meaning
Clear | Clear the buffered input data. The error state is exited.

See Also

Reference

PinPad Class
PinPad Members
Microsoft.PointOfService Namespace
PosCommon.ErrorEvent
PinPad.ExtendedErrorBadKey Field
DeviceErrorEventArgs Class
DeviceErrorEventHandler Delegate


PinPadDisplay Enumeration

PinPadDisplay Enumeration |
 | See Also

1/18/2008

Lists the possible ways in which an application can use the PIN pad’s display.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration PinPadDisplay
public enum PinPadDisplay
public enum class PinPadDisplay
public enum PinPadDisplay
public enum PinPadDisplay

Members

Member name | Description
None | The PIN pad device in use does not have a display.
PinRestricted | The application can use the PIN pad’s display in an unrestricted manner except during PIN entry.
RestrictedList | The application cannot specify the text of messages to display; it can only select from a list of pre-defined messages.
RestrictedOrder | The application cannot specify the text of messages to display; it can only select from a list of pre-defined messages, and the selections must occur in a pre-defined order.
Unrestricted | The application can use the PIN pad’s display in an unrestricted manner to display messages.

Remarks

Used by the CapDisplay property. Members of this enumeration replace the PPAD_DISP_UNRESTRICTED, PPAD_DISP_PINRESTRICTED, PPAD_DISP_RESTRICTED_LIST, PPAD_DISP_RESTRICTED_ORDER, and PPAD_DISP_NONE UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
PinPad.CapDisplay Property


PinPadLanguage Enumeration

PinPadLanguage Enumeration |
 | See Also

1/18/2008

Lists language characteristics for predefined prompt messages of the PIN pad device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration PinPadLanguage
public enum PinPadLanguage
public enum class PinPadLanguage
public enum PinPadLanguage
public enum PinPadLanguage

Members

Member name | Description
None | The PIN pad supports no pre-defined prompt messages.
One | The PIN pad supports pre-defined prompt messages in one language.
PinRestricted | The PIN Pad cannot change prompt languages during PIN entry.
Unrestricted | The application can change the language of pre-defined prompt messages at any time.

Remarks

Used by the CapLanguage property. Members of this enumeration replace the PPAD_LANG_NONE, PPAD_LANG_ONE, PPAD_LANG_PINRESTRICTED, and PPAD_LANG_UNRESTRICTED UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
PinPad.CapLanguage Property


PinPadMessage Enumeration

PinPadMessage Enumeration |
 | See Also

1/18/2008

Lists the possible prompt messages for the PIN pad device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration PinPadMessage
public enum PinPadMessage
public enum class PinPadMessage
public enum PinPadMessage
public enum PinPadMessage

Members

Member name | Description
AmountOK | The customer should enter Yes/No to approve the amount.
Approved | The request has been approved.
Canceled | The request is canceled.
Declined | The EFT Transaction Host has declined to perform the requested function.
EnterPin | The user should enter his PIN on the PIN pad.
EnterValidPin | The PIN that was entered is not correct. The user should enter the correct PIN.
Idle | The system is Idle.
InsertCard | The customer should insert their (smart)card.
NotReady | The PIN pad is not ready for use by customer.
PleaseWait | The system is processing. The user should wait.
RetriesExceeded | The user has failed to enter the correct PIN and the maximum number of attempts has been exceeded.
SelectCardType | The customer should select the card type (typically credit or debit).
SlideCard | The user should slide their card through the integrated magnetic strip reader (MSR).

Remarks

Used by the AvailablePromptsList and Prompt property. Members of this enumeration replace the PPAD_MSG_ range of UPOS constants.

Note:
Values 1000 and above are reserved for device-specific values to be defined by the service object.

See Also

Reference

Microsoft.PointOfService Namespace
PinPad.AvailablePromptsList Property
Prompt


PinPadSystem Enumeration

PinPadSystem Enumeration |
 | See Also

1/18/2008

Enumerates the possible PIN pad management systems to use.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration PinPadSystem
public enum PinPadSystem
public enum class PinPadSystem
public enum PinPadSystem
public enum PinPadSystem

Members

Member name | Description
Apacs40 | Standard 40 (UK and other countries/regions)
AS2805 | Australian Standard 2805
Dukpt | Derived Unique Key Per Transaction (USA, Latin America)
Hgepos | (Italian)
Jdebit2 | Japanese Debit 2
MasterSession | Master/Session. (USA, Latin America)

Remarks

Used by the BeginEftTransaction method. Members of this enumeration replace the M/S, DUKPT, APACS40, AS2805, HGEPOS (Italian), and JDEBIT2 UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
PinPad.BeginEftTransaction Method


PointCardAreas Enumeration

PointCardAreas Enumeration |
 | See Also

1/18/2008

Lists the valid parts of the point card that can be cleared.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration PointCardAreas
[FlagsAttribute]
public enum PointCardAreas
[FlagsAttribute]
public enum class PointCardAreas
/** @attribute FlagsAttribute() */
public enum PointCardAreas
FlagsAttribute
public enum PointCardAreas

Members

Member name | Description
MagneticTracks | Magnetic tracks
PrintingArea | Printing area
PrintingAreaAndMagneticTracks | Both printing area and magnetic tracks

Remarks

Used by the ClearPrintWrite and PrintWrite methods.

See Also

Reference

Microsoft.PointOfService Namespace
ClearPrintWrite
PrintWrite


PointCardReadWriteState Enumeration

PointCardReadWriteState Enumeration |
 | See Also

1/18/2008

Lists valid track states for a Point Card Reader Writer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration PointCardReadWriteState
public enum PointCardReadWriteState
public enum class PointCardReadWriteState
public enum PointCardReadWriteState
public enum PointCardReadWriteState

Members

Member name | Description
Encode | No encoding
End | End sentinel error
Failure | Another error
LrcError | LRC error
Parity | Parity error
Start | Start sentinel error
Success | Successful read of the data
Verify | Verify error

Remarks

Used by the PoiontCardReadWriteStates structure.

See Also

Reference

Microsoft.PointOfService Namespace


PointCardReadWriteStates Structure

PointCardReadWriteStates Structure |
 | See Also Members

1/18/2008

Defines a programmatic structure used by the service object to communicate write or read state information for a Point Card Reader Writer device during an error condition.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Structure PointCardReadWriteStates
public struct PointCardReadWriteStates
public value class PointCardReadWriteStates
public final class PointCardReadWriteStates extends ValueType

Remarks

Used by the ReadState and WriteState properties of PointCardRW class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardReadWriteStates Members
Microsoft.PointOfService Namespace


PointCardReadWriteStates Members

PointCardReadWriteStates Members |
 | See Also Constructors Methods Properties

1/18/2008

Defines a programmatic structure used by the service object to communicate write or read state information for a Point Card Reader Writer device during an error condition.

The following tables list the members exposed by the PointCardReadWriteStates type.

Public Constructors

Name | Description
PointCardReadWriteStates | Creates a new instance of PointCardReadWriteStates from parameters specifying the instance's constituent parts.
Top

Public Properties

Name | Description
Track1 | Holds a PointCardReadWriteState enumeration value.
Track2 | Holds a PointCardReadWriteState enumeration value.
Track3 | Holds a PointCardReadWriteState enumeration value.
Track4 | Holds a PointCardReadWriteState enumeration value.
Track5 | Holds a PointCardReadWriteState enumeration value.
Track6 | Holds a PointCardReadWriteState enumeration value.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. Overridden.
GetHashCode | Overridden. Returns the hash code of the current PointCardReadWriteStates.
GetType | (inherited from Object )
op_Equality | Compares the specified PointCardReadWriteStates and object to determine whether they are equal.
op_Inequality | Returns a value indicating whether an instance of PointCardReadWriteStates and an object are not equal.
ReferenceEquals | (inherited from Object )
ToString | (inherited from ValueType )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

PointCardReadWriteStates Structure
Microsoft.PointOfService Namespace


PointCardReadWriteStates Constructor

PointCardReadWriteStates Constructor |
 | See Also

1/18/2008

Creates a new instance of PointCardReadWriteStates from parameters specifying the instance's constituent parts.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    track1 As PointCardReadWriteState, _
    track2 As PointCardReadWriteState, _
    track3 As PointCardReadWriteState, _
    track4 As PointCardReadWriteState, _
    track5 As PointCardReadWriteState, _
    track6 As PointCardReadWriteState _
)
public PointCardReadWriteStates (
    PointCardReadWriteState track1,
    PointCardReadWriteState track2,
    PointCardReadWriteState track3,
    PointCardReadWriteState track4,
    PointCardReadWriteState track5,
    PointCardReadWriteState track6
)
public:
PointCardReadWriteStates (
    PointCardReadWriteState track1,
    PointCardReadWriteState track2,
    PointCardReadWriteState track3,
    PointCardReadWriteState track4,
    PointCardReadWriteState track5,
    PointCardReadWriteState track6
)
public PointCardReadWriteStates (
    PointCardReadWriteState track1,
    PointCardReadWriteState track2,
    PointCardReadWriteState track3,
    PointCardReadWriteState track4,
    PointCardReadWriteState track5,
    PointCardReadWriteState track6
)
public function PointCardReadWriteStates (
    track1 : PointCardReadWriteState,
    track2 : PointCardReadWriteState,
    track3 : PointCardReadWriteState,
    track4 : PointCardReadWriteState,
    track5 : PointCardReadWriteState,
    track6 : PointCardReadWriteState
)

Parameters

track1

A PointCardReadWriteState enumeration value.

track2

A PointCardReadWriteState enumeration value.

track3

A PointCardReadWriteState enumeration value.

track4

A PointCardReadWriteState enumeration value.

track5

A PointCardReadWriteState enumeration value.

track6

A PointCardReadWriteState enumeration value.

See Also

Reference

PointCardReadWriteStates Structure
PointCardReadWriteStates Members
Microsoft.PointOfService Namespace


PointCardReadWriteStates Methods

PointCardReadWriteStates Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. Overridden.
GetHashCode | Overridden. Returns the hash code of the current PointCardReadWriteStates.
GetType | (inherited from Object )
op_Equality | Compares the specified PointCardReadWriteStates and object to determine whether they are equal.
op_Inequality | Returns a value indicating whether an instance of PointCardReadWriteStates and an object are not equal.
ReferenceEquals | (inherited from Object )
ToString | (inherited from ValueType )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

PointCardReadWriteStates Structure
Microsoft.PointOfService Namespace


PointCardReadWriteStates.Equals Method

PointCardReadWriteStates.Equals Method |
 | See Also

1/18/2008

Overload List

Name | Description
PointCardReadWriteStates.Equals (Object) | Determines whether the specified Object is equal to the current PointCardReadWriteStates.
PointCardReadWriteStates.Equals (PointCardReadWriteStates) | Determines whether the specified PointCardReadWriteStates is equal to the current PointCardReadWriteStates.
PointCardReadWriteStates.Equals (Object, Object) | (inherited from Equals )
PointCardReadWriteStates.Equals (PointCardReadWriteStates, PointCardReadWriteStates) | Determines whether the specified PointCardReadWriteStates instances are equal.

See Also

Reference

PointCardReadWriteStates Structure
PointCardReadWriteStates Members
Microsoft.PointOfService Namespace


PointCardReadWriteStates.Equals Method (Object)

PointCardReadWriteStates.Equals Method (Object) |
 | See Also

1/18/2008

Determines whether the specified Object is equal to the current PointCardReadWriteStates.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public override bool Equals (
    Object obj
)
public:
virtual bool Equals (
    Object^ obj
) override
public boolean Equals (
    Object obj
)
public override function Equals (
    obj : Object
) : boolean

Parameters

obj

Return Value

True if the specified object is equal to the current PointCardReadWriteStates; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardReadWriteStates Structure
PointCardReadWriteStates Members
Microsoft.PointOfService Namespace


PointCardReadWriteStates.Equals Method (PointCardReadWriteStates)

PointCardReadWriteStates.Equals Method (PointCardReadWriteStates) |
 | See Also

1/18/2008

Determines whether the specified PointCardReadWriteStates is equal to the current PointCardReadWriteStates.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Function Equals ( _
    states As PointCardReadWriteStates _
) As Boolean
public bool Equals (
    PointCardReadWriteStates states
)
public:
bool Equals (
    PointCardReadWriteStates states
)
public boolean Equals (
    PointCardReadWriteStates states
)
public function Equals (
    states : PointCardReadWriteStates
) : boolean

Parameters

states

The PointCardReadWriteStates to be compared with the current PointCardReadWriteStates

Return Value

True if the specified PointCardReadWriteStates is equal to the current PointCardReadWriteStates; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardReadWriteStates Structure
PointCardReadWriteStates Members
Microsoft.PointOfService Namespace


PointCardReadWriteStates.Equals Method (PointCardReadWriteStates, PointCardReadWriteStates)

PointCardReadWriteStates.Equals Method (PointCardReadWriteStates, PointCardReadWriteStates) |
 | See Also

1/18/2008

Determines whether the specified PointCardReadWriteStates instances are equal.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Function Equals ( _
    a As PointCardReadWriteStates, _
    b As PointCardReadWriteStates _
) As Boolean
public static bool Equals (
    PointCardReadWriteStates a,
    PointCardReadWriteStates b
)
public:
static bool Equals (
    PointCardReadWriteStates a,
    PointCardReadWriteStates b
)
public static boolean Equals (
    PointCardReadWriteStates a,
    PointCardReadWriteStates b
)
public static function Equals (
    a : PointCardReadWriteStates,
    b : PointCardReadWriteStates
) : boolean

Parameters

a

The first PointCardReadWriteStates instance

b

The second PointCardReadWriteStates instance

Return Value

True if a is equal to b; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardReadWriteStates Structure
PointCardReadWriteStates Members
Microsoft.PointOfService Namespace


PointCardReadWriteStates.GetHashCode Method

PointCardReadWriteStates.GetHashCode Method |
 | See Also

1/18/2008

Returns the hash code of the current PointCardReadWriteStates.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function GetHashCode As Integer
public override int GetHashCode ()
public:
virtual int GetHashCode () override
public int GetHashCode ()
public override function GetHashCode () : int

Return Value

Int32 representation of the hash code for the current PointCardReadWriteStates.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardReadWriteStates Structure
PointCardReadWriteStates Members
Microsoft.PointOfService Namespace


PointCardReadWriteStates.op_Equality Method

PointCardReadWriteStates.op_Equality Method |
 | See Also

1/18/2008

Compares the specified PointCardReadWriteStates and object to determine whether they are equal.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Operator = ( _
    a As PointCardReadWriteStates, _
    b As Object _
) As Boolean
public static bool operator == (
    PointCardReadWriteStates a,
    Object b
)
public:
static bool operator == (
    PointCardReadWriteStates a,
    Object^ b
)

Parameters

a

The PointCardReadWriteStates to be compared to b

b

The object to be compared to a

Return Value

True if a is equal to b; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardReadWriteStates Structure
PointCardReadWriteStates Members
Microsoft.PointOfService Namespace


PointCardReadWriteStates.op_Inequality Method

PointCardReadWriteStates.op_Inequality Method |
 | See Also

1/18/2008

Returns a value indicating whether an instance of PointCardReadWriteStates and an object are not equal.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Operator <> ( _
    a As PointCardReadWriteStates, _
    b As Object _
) As Boolean
public static bool operator != (
    PointCardReadWriteStates a,
    Object b
)
public:
static bool operator != (
    PointCardReadWriteStates a,
    Object^ b
)

Parameters

a

The PointCardReadWriteStates to be compared to b

b

The object to be compared to a

Return Value

True if a is not equal to b; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardReadWriteStates Structure
PointCardReadWriteStates Members
Microsoft.PointOfService Namespace


PointCardReadWriteStates Properties

PointCardReadWriteStates Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
Track1 | Holds a PointCardReadWriteState enumeration value.
Track2 | Holds a PointCardReadWriteState enumeration value.
Track3 | Holds a PointCardReadWriteState enumeration value.
Track4 | Holds a PointCardReadWriteState enumeration value.
Track5 | Holds a PointCardReadWriteState enumeration value.
Track6 | Holds a PointCardReadWriteState enumeration value.

See Also

Reference

PointCardReadWriteStates Structure
Microsoft.PointOfService Namespace


PointCardReadWriteStates.Track1 Property

PointCardReadWriteStates.Track1 Property |
 | See Also

1/18/2008

Holds a PointCardReadWriteState enumeration value.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Track1 As PointCardReadWriteState
public PointCardReadWriteState Track1 { get; }
public:
property PointCardReadWriteState Track1 {
    PointCardReadWriteState get ();
}
/** @property */
public PointCardReadWriteState get_Track1 ()

public function get Track1 () : PointCardReadWriteState

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardReadWriteStates Structure
PointCardReadWriteStates Members
Microsoft.PointOfService Namespace


PointCardReadWriteStates.Track2 Property

PointCardReadWriteStates.Track2 Property |
 | See Also

1/18/2008

Holds a PointCardReadWriteState enumeration value.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Track2 As PointCardReadWriteState
public PointCardReadWriteState Track2 { get; }
public:
property PointCardReadWriteState Track2 {
    PointCardReadWriteState get ();
}
/** @property */
public PointCardReadWriteState get_Track2 ()

public function get Track2 () : PointCardReadWriteState

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardReadWriteStates Structure
PointCardReadWriteStates Members
Microsoft.PointOfService Namespace


PointCardReadWriteStates.Track3 Property

PointCardReadWriteStates.Track3 Property |
 | See Also

1/18/2008

Holds a PointCardReadWriteState enumeration value.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Track3 As PointCardReadWriteState
public PointCardReadWriteState Track3 { get; }
public:
property PointCardReadWriteState Track3 {
    PointCardReadWriteState get ();
}
/** @property */
public PointCardReadWriteState get_Track3 ()

public function get Track3 () : PointCardReadWriteState

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardReadWriteStates Structure
PointCardReadWriteStates Members
Microsoft.PointOfService Namespace


PointCardReadWriteStates.Track4 Property

PointCardReadWriteStates.Track4 Property |
 | See Also

1/18/2008

Holds a PointCardReadWriteState enumeration value.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Track4 As PointCardReadWriteState
public PointCardReadWriteState Track4 { get; }
public:
property PointCardReadWriteState Track4 {
    PointCardReadWriteState get ();
}
/** @property */
public PointCardReadWriteState get_Track4 ()

public function get Track4 () : PointCardReadWriteState

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardReadWriteStates Structure
PointCardReadWriteStates Members
Microsoft.PointOfService Namespace


PointCardReadWriteStates.Track5 Property

PointCardReadWriteStates.Track5 Property |
 | See Also

1/18/2008

Holds a PointCardReadWriteState enumeration value.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Track5 As PointCardReadWriteState
public PointCardReadWriteState Track5 { get; }
public:
property PointCardReadWriteState Track5 {
    PointCardReadWriteState get ();
}
/** @property */
public PointCardReadWriteState get_Track5 ()

public function get Track5 () : PointCardReadWriteState

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardReadWriteStates Structure
PointCardReadWriteStates Members
Microsoft.PointOfService Namespace


PointCardReadWriteStates.Track6 Property

PointCardReadWriteStates.Track6 Property |
 | See Also

1/18/2008

Holds a PointCardReadWriteState enumeration value.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Track6 As PointCardReadWriteState
public PointCardReadWriteState Track6 { get; }
public:
property PointCardReadWriteState Track6 {
    PointCardReadWriteState get ();
}
/** @property */
public PointCardReadWriteState get_Track6 ()

public function get Track6 () : PointCardReadWriteState

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardReadWriteStates Structure
PointCardReadWriteStates Members
Microsoft.PointOfService Namespace


PointCardReceiveLengths Structure

PointCardReceiveLengths Structure |
 | See Also Members

1/18/2008

Defines a programmatic structure used by the service object to communicate the length of track data for a Point Card Reader Writer device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Structure PointCardReceiveLengths
public struct PointCardReceiveLengths
public value class PointCardReceiveLengths
public final class PointCardReceiveLengths extends ValueType

Remarks

This class defines a programmatic structure used by the service object to communicate the length of track data for a Point Card Reader Writer device.

Instances of this class are used by the RecvLength property of the PointCardRW class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardReceiveLengths Members
Microsoft.PointOfService Namespace


PointCardReceiveLengths Members

PointCardReceiveLengths Members |
 | See Also Constructors Methods Properties

1/18/2008

Defines a programmatic structure used by the service object to communicate the length of track data for a Point Card Reader Writer device.

The following tables list the members exposed by the PointCardReceiveLengths type.

Public Constructors

Name | Description
PointCardReceiveLengths | Creates an instance of PointCardReceiveLengths with the specified data tracks.
Top

Public Properties

Name | Description
Track1 | Holds the length in bytes for Track 1.
Track2 | Holds the length in bytes for Track 2.
Track3 | Holds the length in bytes for Track 3.
Track4 | Holds the length in bytes for Track 4.
Track5 | Holds the length in bytes for Track 5.
Track6 | Holds the length in bytes for Track 6.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. Overridden.
GetHashCode | Overridden. Returns the hash code of the current PointCardReceiveLengths.
GetType | (inherited from Object )
op_Equality | Compares the specified PointCardReceiveLengths and object to determine whether they are equal.
op_Inequality | Returns a value indicating whether an instance of PointCardReceiveLengths and an object are not equal.
ReferenceEquals | (inherited from Object )
ToString | (inherited from ValueType )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

PointCardReceiveLengths Structure
Microsoft.PointOfService Namespace


PointCardReceiveLengths Constructor

PointCardReceiveLengths Constructor |
 | See Also

1/18/2008

Creates an instance of PointCardReceiveLengths with the specified data tracks.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    track1 As Integer, _
    track2 As Integer, _
    track3 As Integer, _
    track4 As Integer, _
    track5 As Integer, _
    track6 As Integer _
)
public PointCardReceiveLengths (
    int track1,
    int track2,
    int track3,
    int track4,
    int track5,
    int track6
)
public:
PointCardReceiveLengths (
    int track1,
    int track2,
    int track3,
    int track4,
    int track5,
    int track6
)
public PointCardReceiveLengths (
    int track1,
    int track2,
    int track3,
    int track4,
    int track5,
    int track6
)
public function PointCardReceiveLengths (
    track1 : int,
    track2 : int,
    track3 : int,
    track4 : int,
    track5 : int,
    track6 : int
)

Parameters

track1

The first data track's length in bytes.

track2

The second data track's length in bytes.

track3

The third data track's length in bytes.

track4

The fourth data track's length in bytes.

track5

The fifth data track's length in bytes.

track6

The sixth data track's length in bytes.

Remarks

Creates an instance of PointCardReceiveLengths with the specified data tracks.

See Also

Reference

PointCardReceiveLengths Structure
PointCardReceiveLengths Members
Microsoft.PointOfService Namespace


PointCardReceiveLengths Methods

PointCardReceiveLengths Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. Overridden.
GetHashCode | Overridden. Returns the hash code of the current PointCardReceiveLengths.
GetType | (inherited from Object )
op_Equality | Compares the specified PointCardReceiveLengths and object to determine whether they are equal.
op_Inequality | Returns a value indicating whether an instance of PointCardReceiveLengths and an object are not equal.
ReferenceEquals | (inherited from Object )
ToString | (inherited from ValueType )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

PointCardReceiveLengths Structure
Microsoft.PointOfService Namespace


PointCardReceiveLengths.Equals Method

PointCardReceiveLengths.Equals Method |
 | See Also

1/18/2008

Overload List

Name | Description
PointCardReceiveLengths.Equals (Object) | Determines whether the specified object is equal to the current PointCardReceiveLengths.
PointCardReceiveLengths.Equals (PointCardReceiveLengths) | Determines whether the specified PointCardReceiveLengths is equal to the current PointCardReceiveLengths.
PointCardReceiveLengths.Equals (Object, Object) | (inherited from Equals )
PointCardReceiveLengths.Equals (PointCardReceiveLengths, PointCardReceiveLengths) | Determines whether the specified PointCardReceiveLengths instances are equal.

See Also

Reference

PointCardReceiveLengths Structure
PointCardReceiveLengths Members
Microsoft.PointOfService Namespace


PointCardReceiveLengths.Equals Method (Object)

PointCardReceiveLengths.Equals Method (Object) |
 | See Also

1/18/2008

Determines whether the specified object is equal to the current PointCardReceiveLengths.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public override bool Equals (
    Object obj
)
public:
virtual bool Equals (
    Object^ obj
) override
public boolean Equals (
    Object obj
)
public override function Equals (
    obj : Object
) : boolean

Parameters

obj

Return Value

A boolean value that is true if the specified object is equal to the current PointCardReceiveLengths and false otherwise.

Remarks

Determines whether the specified object is equal to the current PointCardReceiveLengths.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardReceiveLengths Structure
PointCardReceiveLengths Members
Microsoft.PointOfService Namespace


PointCardReceiveLengths.Equals Method (PointCardReceiveLengths)

PointCardReceiveLengths.Equals Method (PointCardReceiveLengths) |
 | See Also

1/18/2008

Determines whether the specified PointCardReceiveLengths is equal to the current PointCardReceiveLengths.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Function Equals ( _
    lengths As PointCardReceiveLengths _
) As Boolean
public bool Equals (
    PointCardReceiveLengths lengths
)
public:
bool Equals (
    PointCardReceiveLengths lengths
)
public boolean Equals (
    PointCardReceiveLengths lengths
)
public function Equals (
    lengths : PointCardReceiveLengths
) : boolean

Parameters

lengths

The PointCardReceiveLengths to be compared with the current PointCardReceiveLengths

Return Value

A boolean value that is true if the specified PointCardReceiveLengths is equal to the current PointCardReceiveLengths and false otherwise.

Remarks

Determines whether the specified PointCardReceiveLengths is equal to the current PointCardReceiveLengths.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardReceiveLengths Structure
PointCardReceiveLengths Members
Microsoft.PointOfService Namespace


PointCardReceiveLengths.Equals Method (PointCardReceiveLengths, PointCardReceiveLengths)

PointCardReceiveLengths.Equals Method (PointCardReceiveLengths, PointCardReceiveLengths) |
 | See Also

1/18/2008

Determines whether the specified PointCardReceiveLengths instances are equal.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Function Equals ( _
    a As PointCardReceiveLengths, _
    b As PointCardReceiveLengths _
) As Boolean
public static bool Equals (
    PointCardReceiveLengths a,
    PointCardReceiveLengths b
)
public:
static bool Equals (
    PointCardReceiveLengths a,
    PointCardReceiveLengths b
)
public static boolean Equals (
    PointCardReceiveLengths a,
    PointCardReceiveLengths b
)
public static function Equals (
    a : PointCardReceiveLengths,
    b : PointCardReceiveLengths
) : boolean

Parameters

a

The first PointCardReceiveLengths instance

b

The second PointCardReceiveLengths instance

Return Value

A boolean value indicating whether the specified instances are equal. The boolean is true if a is equal to b; otherwise, it is false.

Remarks

Determines whether the specified PointCardReceiveLengths instances are equal.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardReceiveLengths Structure
PointCardReceiveLengths Members
Microsoft.PointOfService Namespace


PointCardReceiveLengths.GetHashCode Method

PointCardReceiveLengths.GetHashCode Method |
 | See Also

1/18/2008

Returns the hash code of the current PointCardReceiveLengths.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function GetHashCode As Integer
public override int GetHashCode ()
public:
virtual int GetHashCode () override
public int GetHashCode ()
public override function GetHashCode () : int

Return Value

An integer representation of the hash code for the current PointCardReceiveLengths.

Remarks

Returns the hash code of the current PointCardReceiveLengths.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardReceiveLengths Structure
PointCardReceiveLengths Members
Microsoft.PointOfService Namespace


PointCardReceiveLengths.op_Equality Method

PointCardReceiveLengths.op_Equality Method |
 | See Also

1/18/2008

Compares the specified PointCardReceiveLengths and object to determine whether they are equal.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Operator = ( _
    a As PointCardReceiveLengths, _
    b As Object _
) As Boolean
public static bool operator == (
    PointCardReceiveLengths a,
    Object b
)
public:
static bool operator == (
    PointCardReceiveLengths a,
    Object^ b
)

Parameters

a

The PointCardReceiveLengths to be compared to b

b

The object to be compared to a

Return Value

A boolean indicating whether a and b are equal. The boolean is true if a is equal to b; otherwise, it is false.

Remarks

Compares the specified PointCardReceiveLengths and object to determine whether they are equal.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardReceiveLengths Structure
PointCardReceiveLengths Members
Microsoft.PointOfService Namespace


PointCardReceiveLengths.op_Inequality Method

PointCardReceiveLengths.op_Inequality Method |
 | See Also

1/18/2008

Returns a value indicating whether an instance of PointCardReceiveLengths and an object are not equal.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Operator <> ( _
    a As PointCardReceiveLengths, _
    b As Object _
) As Boolean
public static bool operator != (
    PointCardReceiveLengths a,
    Object b
)
public:
static bool operator != (
    PointCardReceiveLengths a,
    Object^ b
)

Parameters

a

The PointCardReceiveLengths to be compared to b

b

The object to be compared to a

Return Value

A boolean value indicating whether a and b are unequal. The boolean is true if a is not equal to b; otherwise, false.

Remarks

Returns a value indicating whether an instance of PointCardReceiveLengths and an object are not equal.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardReceiveLengths Structure
PointCardReceiveLengths Members
Microsoft.PointOfService Namespace


PointCardReceiveLengths Properties

PointCardReceiveLengths Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
Track1 | Holds the length in bytes for Track 1.
Track2 | Holds the length in bytes for Track 2.
Track3 | Holds the length in bytes for Track 3.
Track4 | Holds the length in bytes for Track 4.
Track5 | Holds the length in bytes for Track 5.
Track6 | Holds the length in bytes for Track 6.

See Also

Reference

PointCardReceiveLengths Structure
Microsoft.PointOfService Namespace


PointCardReceiveLengths.Track1 Property

PointCardReceiveLengths.Track1 Property |
 | See Also

1/18/2008

Holds the length in bytes for Track 1.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Track1 As Integer
public int Track1 { get; }
public:
property int Track1 {
    int get ();
}
/** @property */
public int get_Track1 ()

public function get Track1 () : int

Property Value

An integer representing the length of data track 1.

Remarks

Holds the length in bytes for Track 1.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardReceiveLengths Structure
PointCardReceiveLengths Members
Microsoft.PointOfService Namespace


PointCardReceiveLengths.Track2 Property

PointCardReceiveLengths.Track2 Property |
 | See Also

1/18/2008

Holds the length in bytes for Track 2.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Track2 As Integer
public int Track2 { get; }
public:
property int Track2 {
    int get ();
}
/** @property */
public int get_Track2 ()

public function get Track2 () : int

Property Value

An integer representing the length of data track 2.

Remarks

Holds the length in bytes for Track 2.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardReceiveLengths Structure
PointCardReceiveLengths Members
Microsoft.PointOfService Namespace


PointCardReceiveLengths.Track3 Property

PointCardReceiveLengths.Track3 Property |
 | See Also

1/18/2008

Holds the length in bytes for Track 3.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Track3 As Integer
public int Track3 { get; }
public:
property int Track3 {
    int get ();
}
/** @property */
public int get_Track3 ()

public function get Track3 () : int

Property Value

An integer representing the length of data track 3.

Remarks

Holds the length in bytes for Track 3.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardReceiveLengths Structure
PointCardReceiveLengths Members
Microsoft.PointOfService Namespace


PointCardReceiveLengths.Track4 Property

PointCardReceiveLengths.Track4 Property |
 | See Also

1/18/2008

Holds the length in bytes for Track 4.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Track4 As Integer
public int Track4 { get; }
public:
property int Track4 {
    int get ();
}
/** @property */
public int get_Track4 ()

public function get Track4 () : int

Property Value

An integer representing the length of data track 4.

Remarks

Holds the length in bytes for Track 4.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardReceiveLengths Structure
PointCardReceiveLengths Members
Microsoft.PointOfService Namespace


PointCardReceiveLengths.Track5 Property

PointCardReceiveLengths.Track5 Property |
 | See Also

1/18/2008

Holds the length in bytes for Track 5.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Track5 As Integer
public int Track5 { get; }
public:
property int Track5 {
    int get ();
}
/** @property */
public int get_Track5 ()

public function get Track5 () : int

Property Value

An integer representing the length of data track 5.

Remarks

Holds the length in bytes for Track 5.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardReceiveLengths Structure
PointCardReceiveLengths Members
Microsoft.PointOfService Namespace


PointCardReceiveLengths.Track6 Property

PointCardReceiveLengths.Track6 Property |
 | See Also

1/18/2008

Holds the length in bytes for Track 6.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Track6 As Integer
public int Track6 { get; }
public:
property int Track6 {
    int get ();
}
/** @property */
public int get_Track6 ()

public function get Track6 () : int

Property Value

An integer representing the length of data track 6.

Remarks

Holds the length in bytes for Track 6.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardReceiveLengths Structure
PointCardReceiveLengths Members
Microsoft.PointOfService Namespace


PointCardRW Class

PointCardRW Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a UPOS Point Card Reader/Writer device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class PointCardRW
    Inherits PosCommon
public abstract class PointCardRW : PosCommon
public ref class PointCardRW abstract : public PosCommon
public abstract class PointCardRW extends PosCommon
public abstract class PointCardRW extends PosCommon

Remarks

Capabilities

The point card reader/writer has the following capabilities:

  • Supports reading and writing of the magnetic data of the point card.

  • Supports reading and writing of data from up to six tracks. The data on the tracks is in a device-specific format. For more information, see the device manual for specific definitions. The data is usually in ASCII format.

  • Supports point cards with or without a printing area. Actual printing support depends on the capabilities of the device.

  • Supports both card insertion and ejection.

  • No special security capabilities, for example, encryption, are supported.

Model

The point card reader/writer reads all the magnetic stripes on a point card. The data length and reading information are put in the property that corresponds to a track.

The point card reader/writer follows the input model of event-driven input during the card insertion process. Also, writing to the printing area and the magnetic stripe follows the output model.

Input Model

  • An application must call the Open and Claim methods, and then set the DeviceEnabled property to true.

  • When an application wants a card inserted, it calls the BeginInsertion method, specifying a time-out value.

  • If a card is not inserted before the time-out period elapses, the point card reader/writer returns an error.

  • Even if a time-out occurs, the point card reader/writer remains in Insertion mode. If the application still wants a card inserted, it must call the BeginInsertion method again.

  • To exit insertion mode after a card was inserted or when the application wants to end insertion, the application calls the EndInsertion method.

  • If there is a point card in the point card reader/writer when the EndInsertion method is called, the point card's data tracks are automatically read and a DataEvent event is queued. When the application sets the DataEventEnabled property to true, the DataEvent event is delivered.

If an error occurs while it reads the point card's data tracks, an ErrorEvent event is queued instead of a DataEvent event. When the application sets the DataEventEnabled property to true, the ErrorEvent event is delivered.

  • The application can obtain the current number of queued data events by reading the DataCount property.

  • All queued but undelivered input can be deleted by calling the ClearInput method.

Output Model

  • To write data to a card, the application calls the PrintWrite method. The ability to write data depends on the capabilities of the device.

  • The PrintWrite method is always performed asynchronously. All asynchronous output is performed on a first-in, first-out basis.

  • When the application calls the PrintWrite method, the point card reader/writer assigns a unique identification number for this request. This ID is stored in the OutputId property The point card reader/writer then either queues the request or starts its processing. Either way, the point card reader/writer returns to the application quickly.

  • When the PrintWrite method is complete, an OutputCompleteEvent event is delivered to the application. The OutputId property associated with the completed request is passed in the OutputCompleteEvent event.

  • If the PrintWrite method fails during its processing, an ErrorEvent event is delivered to the application. If the application has multiple outstanding output requests, the OutputId property of the request that failed can be determined by watching which requests have successfully completed by monitoring OutputCompleteEvent events. The request that failed is the one that was issued immediately after the last request that successfully completed.

  • All incomplete output requests can be deleted by calling the ClearOutput method. This method also stops any output that is in progress, if it is possible. No OutputCompleteEvent events are delivered for output requests stopped in this manner.

  • When done accessing the point card, the application calls the BeginRemoval method, specifying a Timeout value.

  • If the card is not removed before the time-out period elapses, the point card reader/writer returns an error.

  • Even if a time-out occurs, the point card reader/writer remains in Removal mode. If the application still wants the card removed, it must call the BeginRemoval method again.

  • To exit Removal mode, after the card was physically removed or the application wants to end removal, the application calls the EndRemoval method.

Printing Capability

  • The point card reader/writer supports devices that allow for rewriting the print area of a card.

  • The point card reader/writer supports printing specified either by dot units or by line units. When the CapPrintMode property is true, the unit type is determined by the value of the MapMode property. When the CapPrintMode property is false, the unit type is defined as lines.

  • The data to print is passed to the PrintWrite method as the data parameter. Special character modifications, such as double height, depend on the capabilities of the device. The verticalPosition and horizontalPosition parameters indicate the vertical and horizontal start position respectively, expressed in units defined by the MapMode property value.

  • When using line units, the start position for lines that contains both single and double-high characters is the top of a single-high character for horizontal printing and the bottom of all characters for vertical printing.

Cleaning Capability

  • The point card reader/writer must be cleaned to prevent errors caused by dirt build-up inside the device.

  • A special cleaning card is used: either a wet card (such as a card wet with ethanol before use) or a dry card.

  • To clean, the inserted cleaning card makes several passes over the read heads inside the device.

  • Some point card reader/writers perform the cleaning operation by use of a switch on the device. Other point card reader/writers perform the cleaning operation completely under control of the application.

Initialization of Magnetic Stripe Data

  • Some point card reader/writers can initialize the magnetic stripe data to prevent the illegal use of a point card.

  • Three initialization techniques can be used for point card reader/writers:

    • Initialize all the data. This includes the start sentinel, end sentinel, and a correct LRC.

    • Write an application-specific code into the data area by using no sentinels.

    • Initialize all tracks to empty by writing only start and end sentinels.

  • Initialization of the magnetic stripe depends on the capability of the device.

Device Sharing

The point card reader/writer is an exclusive-use device, as follows:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before accessing many point card reader/writer-specific properties.

  • The application must claim and enable the device before it calls methods that manipulate the device.

Data Characters and Escape Sequences

The default character set of all point card reader/writers is assumed to support at least the ASCII characters 0x20 through 0x7F. This include spaces, digits, uppercase, lowercase, and some special characters. If the point card reader/writer does not support lowercase characters, the service object can translate them to uppercase.

Every escape sequence begins with the escape character ESC, whose value is 27 decimal, followed by a vertical bar (|). This is followed by zero or more digits and lowercase alphabetic characters. The escape sequence is closed by an uppercase alphabetic character. Sequences that do not begin with ESC | are passed through to the point card reader/writer. Also, sequences that begin with ESC | but which are not valid OPOS for .NET escape sequences are passed through to point card reader/writer.

To determine whether escape sequences or data can be performed on point card reader/writer, the application can call the ValidateData method. (For some escape sequences, corresponding capability properties can also be used.)

The following escape sequences are recognized. If an escape sequence specifies an operation that is not supported by the point card reader/writer, then it is ignored.

Print Mode.Characteristics that are remembered until explicitly changed.

Name | Data | Remarks
Font typeface selection | ESC |#fT | Selects a new typeface for the following data. Values for the character '#' are as follows: 0 = Default typeface.1 = Select first typeface from the FontTypefaceList property.2 = Select second typeface from the FontTypefaceList property,and so on.

Print Lin.Characteristics that are reset at the end of each print method or by a “Normal” sequence.

Name | Data | Remarks
Bold | ESC |bC | Prints in bold or double-strike.
Underline | ESC |#uC | Prints with underline. The character '#' is replaced by an ASCII decimal string telling the thickness of the underline in printer dot units. If '#' is omitted, then a printer-specific default width is used.
Italic | ESC |iC | Prints in italic.
Reverse video | ESC |rvC | Prints in a reverse-video format.
Single high and wide | ESC |1C | Prints normal size.
Double wide | ESC |2C | Prints double-wide characters.
Double high | ESC |3C | Prints double-high characters.
Double high and wide | ESC |4C | Prints double-high/double-wide characters.
Scale horizontally | ESC |#hC | Prints with the width scaled '#' times the normal size, where '#' is replaced by an ASCII decimal string.
Scale vertically | ESC |#vC | Prints with the height scaled '#' times the normal size, where '#' is replaced by an ASCII decimal string.
Center | ESC |cA | Aligns following text in the center.
Right justify | ESC |rA | Aligns following text at the right side.
Normal | ESC |N | Restores printer characteristics to normal condition.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.PointCardRW
Microsoft.PointOfService.BasicServiceObjects.PointCardRWBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW Members

PointCardRW Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a UPOS Point Card Reader/Writer device.

The following tables list the members exposed by the PointCardRW type.

Protected Constructors

Name | Description
PointCardRW | Creates an instance of the PointCardRW class.
Top

Public Fields

Name | Description
CharacterSetAnsi | The ANSI character set.
CharacterSetAscii | The ASCII character set, supporting the ASCII characters between 0x20 and 0x7F.
CharacterSetUnicode | The character set supports Unicode.
ExtendedErrorCover | Indicates the conveyance motor cover is open.
ExtendedErrorDisplay | Indicates a display indicator error.
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorJam | Indicates a card jam.
ExtendedErrorMotor | Indicates a conveyance motor error.
ExtendedErrorNoCard | Indicates there is no card in the reader.
ExtendedErrorPrinter | Indicates a printer error.
ExtendedErrorRead | Indicates a read error.
ExtendedErrorRelease | Indicates a card jam.
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
ExtendedErrorWrite | Indicates a write error.
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusInserted | Indicates a card is in the device.
StatusNoCard | Indicates no card is in the device, or the card sensor position is indeterminate.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusRemaining | Indicates a card remains in the entrance.
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
CapBold | Gets a Boolean value that indicates whether the device can print bold characters.
CapCardEntranceSensor | Gets a Boolean value that indicates whether the device has an entrance sensor.
CapCharacterSet | Gets the default character set capability.
CapCleanCard | Gets a Boolean value that indicates whether the device supports cleaning under application control.
CapClearPrint | Gets a Boolean value that indicates whether the device can erase the printing area.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapDHigh | Gets a Boolean value that indicates whether the device can print double-high characters.
CapDWide | Gets a Boolean value that indicates whether the device can print double-wide characters.
CapDWideDHigh | Gets a Boolean value that indicates whether the device can print double-high/double-width characters.
CapItalic | Gets a Boolean value that indicates whether the device can print italic characters.
CapLeft90 | Gets a Boolean value that indicates whether the device can print in rotated-90-degree-left mode.
CapMapCharacterSet | Gets a Boolean value that indicates whether the service object can map
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapPrint | Gets a Boolean value that indicates whether the device has printing capability.
CapPrintMode | Gets a Boolean value that indicates whether the device can designate a starting position with the MapMode property.
CapRight90 | Gets a Boolean value that indicates the device can print in a rotated-90 degree-right mode.
CapRotate180 | Gets a Boolean value that indicates the device can print in a rotated upside-down mode.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapTracksToRead | Gets a bitmask that indicates which magnetic tracks are available.
CapTracksToWrite | Gets a bitmask that indicates which tracks are writable on the point card.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CardState | Gets the point card state.
CharacterSet | Gets or sets the character set for printing characters.
CharacterSetList | Gets a string of character set numbers.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
DataCount | Gets the number of currently queued data events.
DataEventEnabled | Gets or sets a Boolean value that indicates whether a DataEvent event is delivered when input data is queued.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
FontTypefaceList | Gets the fonts and typefaces supported by the point card reader/writer.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
LineChars | Gets or sets the number of characters that can be printed on a line on the point card reader/writer.
LineCharsList | Gets the line character widths supported by the point card reader/writer.
LineHeight | Gets or sets the point card reader/writer print line height.
LineSpacing | Gets or sets the spacing of each single-high print line. This includes both the printed line height plus the white space between each pair of lines.
LineWidth | Gets the width of a line of LineChars characters.
MapCharacterSet | Gets or sets a Boolean value that indicates whether characters are mapped from the application to the set specified in the CharacterSetproperty.
MapMode | Gets or sets the mapping mode of the point card reader/writer.
MaxLine | Gets the maximum printable line number.
OutputId | Gets a unique output request ID.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
PrintHeight | Gets the height of the largest character in a character set.
ReadState | Gets read state information for Track1 through Track6.
RecvLength | Gets length information for Track1 through Track6.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
SidewaysMaxChars | Gets the maximum number of characters that can be printed on each line in sideways mode.
SidewaysMaxLines | Gets the maximum number of lines that can be printed in sideways mode.
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Track1Data | Gets the Track1 data from the point card.
Track2Data | Gets the Track2 data from the point card.
Track3Data | Gets the Track3 data from the point card.
Track4Data | Gets the Track4 data from the point card.
Track5Data | Gets the Track5 data from the point card.
Track6Data | Gets the Track6 data from the point card.
TracksToRead | Gets or sets the tracks to read from the point card.
TracksToWrite | Gets or sets the tracks to write to the point card.
Write1Data | Gets or sets the data PrintWrite uses to write to Track1.
Write2Data | Gets or sets the data PrintWrite uses to write to Track2.
Write3Data | Gets or sets the data PrintWrite uses to write to Track3.
Write4Data | Gets or sets the data PrintWrite uses to write to Track4.
Write5Data | Gets or sets the data PrintWrite uses to write to Track5.
Write6Data | Gets or sets the data PrintWrite uses to write to Track6.
WriteState | Gets write state information for Track1 through Track6.
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether the PointCardRW is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
BeginInsertion | Starts point card processing.
BeginRemoval | Starts point card removal processing.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
CleanCard | Cleans the read/write heads of the point card reader/writer.
ClearInput | Clears all buffered device input.
ClearInputProperties | Resets the values of properties altered by DataEvent or ErrorEvent.
ClearOutput | Clears all buffered output data. This includes all asynchronous output.
ClearPrintWrite | Erases the printing area of a point card and erases the magnetic track data on a point card or erases the magnetic track data on a point card.
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
EndInsertion | Ends point card insertion processing.
EndRemoval | Ends point card removal processing.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon)
PrintWrite | Prints the specified data on the printing area of the point card, writes data from the WriteXData properties to the magnetic tracks, or both.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
RotatePrint | Enters or exits rotated print mode.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
ValidateData | Determines whether a data sequence, possibly including one or more escape sequences, is valid for the specified station, before it calls the PrintWrite method.
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DataEvent | Raised by the service object to notify the application that input data is available from the device.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
ErrorEvent | Raised by the service object to notify the application that a point card error has been detected and a suitable response by the application is necessary to process the error condition.
OutputCompleteEvent | Raised by the service object to notify the application that the queued output request associated with the OutputId property has completed successfully.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

PointCardRW Class
Microsoft.PointOfService Namespace


PointCardRW Fields

PointCardRW Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
CharacterSetAnsi | The ANSI character set.
CharacterSetAscii | The ASCII character set, supporting the ASCII characters between 0x20 and 0x7F.
CharacterSetUnicode | The character set supports Unicode.
ExtendedErrorCover | Indicates the conveyance motor cover is open.
ExtendedErrorDisplay | Indicates a display indicator error.
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorJam | Indicates a card jam.
ExtendedErrorMotor | Indicates a conveyance motor error.
ExtendedErrorNoCard | Indicates there is no card in the reader.
ExtendedErrorPrinter | Indicates a printer error.
ExtendedErrorRead | Indicates a read error.
ExtendedErrorRelease | Indicates a card jam.
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
ExtendedErrorWrite | Indicates a write error.
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusInserted | Indicates a card is in the device.
StatusNoCard | Indicates no card is in the device, or the card sensor position is indeterminate.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusRemaining | Indicates a card remains in the entrance.
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

PointCardRW Class
Microsoft.PointOfService Namespace


PointCardRW.CharacterSetAnsi Field

PointCardRW.CharacterSetAnsi Field |
 | See Also

1/18/2008

The ANSI character set.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const CharacterSetAnsi As Integer
public const int CharacterSetAnsi
public:
literal int CharacterSetAnsi
public static final int CharacterSetAnsi
public const var CharacterSetAnsi : int

Remarks

The value of this constant is 999. Used in the CharacterSet property.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.CharacterSetAscii Field

PointCardRW.CharacterSetAscii Field |
 | See Also

1/18/2008

The ASCII character set, supporting the ASCII characters between 0x20 and 0x7F.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const CharacterSetAscii As Integer
public const int CharacterSetAscii
public:
literal int CharacterSetAscii
public static final int CharacterSetAscii
public const var CharacterSetAscii : int

Remarks

The value of this constant is 998. Used in the CharacterSet property.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.CharacterSetUnicode Field

PointCardRW.CharacterSetUnicode Field |
 | See Also

1/18/2008

The character set supports Unicode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const CharacterSetUnicode As Integer
public const int CharacterSetUnicode
public:
literal int CharacterSetUnicode
public static final int CharacterSetUnicode
public const var CharacterSetUnicode : int

Remarks

The value of this constant is 997. Used in the CharacterSet property.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.ExtendedErrorCover Field

PointCardRW.ExtendedErrorCover Field |
 | See Also

1/18/2008

Indicates the conveyance motor cover is open.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorCover As Integer
public const int ExtendedErrorCover
public:
literal int ExtendedErrorCover
public static final int ExtendedErrorCover
public const var ExtendedErrorCover : int

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
ErrorEvent


PointCardRW.ExtendedErrorDisplay Field

PointCardRW.ExtendedErrorDisplay Field |
 | See Also

1/18/2008

Indicates a display indicator error.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorDisplay As Integer
public const int ExtendedErrorDisplay
public:
literal int ExtendedErrorDisplay
public static final int ExtendedErrorDisplay
public const var ExtendedErrorDisplay : int

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
ErrorEvent


PointCardRW.ExtendedErrorJam Field

PointCardRW.ExtendedErrorJam Field |
 | See Also

1/18/2008

Indicates a card jam.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorJam As Integer
public const int ExtendedErrorJam
public:
literal int ExtendedErrorJam
public static final int ExtendedErrorJam
public const var ExtendedErrorJam : int

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
ErrorEvent


PointCardRW.ExtendedErrorMotor Field

PointCardRW.ExtendedErrorMotor Field |
 | See Also

1/18/2008

Indicates a conveyance motor error.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorMotor As Integer
public const int ExtendedErrorMotor
public:
literal int ExtendedErrorMotor
public static final int ExtendedErrorMotor
public const var ExtendedErrorMotor : int

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
ErrorEvent


PointCardRW.ExtendedErrorNoCard Field

PointCardRW.ExtendedErrorNoCard Field |
 | See Also

1/18/2008

Indicates there is no card in the reader.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorNoCard As Integer
public const int ExtendedErrorNoCard
public:
literal int ExtendedErrorNoCard
public static final int ExtendedErrorNoCard
public const var ExtendedErrorNoCard : int

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
ErrorEvent


PointCardRW.ExtendedErrorPrinter Field

PointCardRW.ExtendedErrorPrinter Field |
 | See Also

1/18/2008

Indicates a printer error.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorPrinter As Integer
public const int ExtendedErrorPrinter
public:
literal int ExtendedErrorPrinter
public static final int ExtendedErrorPrinter
public const var ExtendedErrorPrinter : int

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
ErrorEvent


PointCardRW.ExtendedErrorRead Field

PointCardRW.ExtendedErrorRead Field |
 | See Also

1/18/2008

Indicates a read error.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorRead As Integer
public const int ExtendedErrorRead
public:
literal int ExtendedErrorRead
public static final int ExtendedErrorRead
public const var ExtendedErrorRead : int

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
ErrorEvent


PointCardRW.ExtendedErrorRelease Field

PointCardRW.ExtendedErrorRelease Field |
 | See Also

1/18/2008

Indicates a card jam.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorRelease As Integer
public const int ExtendedErrorRelease
public:
literal int ExtendedErrorRelease
public static final int ExtendedErrorRelease
public const var ExtendedErrorRelease : int

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
ErrorEvent


PointCardRW.ExtendedErrorWrite Field

PointCardRW.ExtendedErrorWrite Field |
 | See Also

1/18/2008

Indicates a write error.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorWrite As Integer
public const int ExtendedErrorWrite
public:
literal int ExtendedErrorWrite
public static final int ExtendedErrorWrite
public const var ExtendedErrorWrite : int

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
ErrorEvent


PointCardRW.StatusInserted Field

PointCardRW.StatusInserted Field |
 | See Also

1/18/2008

Indicates a card is in the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusInserted As Integer
public const int StatusInserted
public:
literal int StatusInserted
public static final int StatusInserted
public const var StatusInserted : int

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
StatusUpdateEvent


PointCardRW.StatusNoCard Field

PointCardRW.StatusNoCard Field |
 | See Also

1/18/2008

Indicates no card is in the device, or the card sensor position is indeterminate.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusNoCard As Integer
public const int StatusNoCard
public:
literal int StatusNoCard
public static final int StatusNoCard
public const var StatusNoCard : int

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
ErrorEvent


PointCardRW.StatusRemaining Field

PointCardRW.StatusRemaining Field |
 | See Also

1/18/2008

Indicates a card remains in the entrance.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusRemaining As Integer
public const int StatusRemaining
public:
literal int StatusRemaining
public static final int StatusRemaining
public const var StatusRemaining : int

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
ErrorEvent


PointCardRW Constructor

PointCardRW Constructor |
 | See Also

1/18/2008

Creates an instance of the PointCardRW class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected PointCardRW ()
protected:
PointCardRW ()
protected PointCardRW ()
protected function PointCardRW ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW Methods

PointCardRW Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
BeginInsertion | Starts point card processing.
BeginRemoval | Starts point card removal processing.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
CleanCard | Cleans the read/write heads of the point card reader/writer.
ClearInput | Clears all buffered device input.
ClearInputProperties | Resets the values of properties altered by DataEvent or ErrorEvent.
ClearOutput | Clears all buffered output data. This includes all asynchronous output.
ClearPrintWrite | Erases the printing area of a point card and erases the magnetic track data on a point card or erases the magnetic track data on a point card.
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
EndInsertion | Ends point card insertion processing.
EndRemoval | Ends point card removal processing.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon )
PrintWrite | Prints the specified data on the printing area of the point card, writes data from the WriteXData properties to the magnetic tracks, or both.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
RotatePrint | Enters or exits rotated print mode.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
ValidateData | Determines whether a data sequence, possibly including one or more escape sequences, is valid for the specified station, before it calls the PrintWrite method.

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

PointCardRW Class
Microsoft.PointOfService Namespace


PointCardRW.BeginInsertion Method

PointCardRW.BeginInsertion Method |
 | See Also

1/18/2008

Starts point card processing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub BeginInsertion ( _
    timeout As Integer _
)
public abstract void BeginInsertion (
    int timeout
)
public:
virtual void BeginInsertion (
    int timeout
) abstract
public abstract void BeginInsertion (
    int timeout
)
public abstract function BeginInsertion (
    timeout : int
)

Parameters

timeout

The timeout parameter gives the number of milliseconds before failing the method. If zero, BeginInsertion tries to begin insertion mode, then returns the appropriate status immediately. If WaitForever, BeginInsertion tries to begin insertion mode, then waits as long as needed until the point card is inserted or an error occurs.

Remarks

When it is called, the point card reader/writer state is changed to allow the insertion of a point card and the point card insertion mode is entered. BeginInsertion is paired with the EndInsertion method for controlling point card insertion.

If the point card reader/writer device cannot be put into insertion mode, an error is returned to the application. Otherwise, the service object monitors point card insertion at one of the two occurrences:

  • The point card is successfully inserted. In this case, the service object returns a Success status.

  • The point card is not inserted before timeout milliseconds have elapsed, or an error is reported by the point card reader/writer device. In this case, the service object either returns Timeout or another error. The point card reader/writer device remains in point card insertion mode. This allows an application to perform some user interaction and reissue the BeginInsertion method without altering the point card handling mechanism.

BeginInsertion may throw a PosControlException exception with the following ErrorCodes:

Value | Meaning
Busy | This operation cannot be performed because asynchronous output is in progress.
Illegal | The point card reader/writer does not exist or an invalid timeout parameter was specified.
Timeout | The specified time has elapsed without the point card being suitably inserted.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
EndInsertion
BeginRemoval
EndRemoval


PointCardRW.BeginRemoval Method

PointCardRW.BeginRemoval Method |
 | See Also

1/18/2008

Starts point card removal processing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub BeginRemoval ( _
    timeout As Integer _
)
public abstract void BeginRemoval (
    int timeout
)
public:
virtual void BeginRemoval (
    int timeout
) abstract
public abstract void BeginRemoval (
    int timeout
)
public abstract function BeginRemoval (
    timeout : int
)

Parameters

timeout

Gives the number of milliseconds before failing the method. If zero, the BeginRemoval method tries to begin removal mode, then returns the appropriate status immediately. If WaitForever, BeginRemoval tries to begin the Removal mode, then waits as long as needed until the point card is ejected or an error occurs.

Remarks

When it is called, the point card reader/writer is made ready to eject a point card or start a print card ejection mode. BeginRemoval is paired with the EndRemoval method for controlling point card removal.

A device with the sensor in the entrance ends normally when a card is ejected from the point card reader/writer.

A device without the sensor ends normally when ejection processing is implemented.

If the point card reader/writer cannot be put into Removal or Ejection mode, an error is returned to the application. Otherwise, the service object continues to monitor point card removal until one of the following occurs:

  • The point card is successfully ejected. In this case, the service object returns a Success status.

  • The point card is not ejected before timeout milliseconds have elapsed, or an error is reported by the point card reader/writer. In this case, the service object either returns Time-out or another error. The point card reader/writer remains in point card ejection mode. This allows an application to perform some user interaction and reissue the BeginRemoval method without altering the point card handling mechanism.

BeginRemoval may throw a PosControlException exception with the following ErrorCodes:

Value | Meaning
Busy | This operation cannot be performed because asynchronous output is in progress.
Illegal | An invalid timeout parameter is specified.
Timeout | The specified time has elapsed without the point card being suitably ejected.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
CapCardEntranceSensor
CardState
PointCardRW.BeginInsertion Method
EndInsertion
EndRemoval


PointCardRW.CleanCard Method

PointCardRW.CleanCard Method |
 | See Also

1/18/2008

Cleans the read/write heads of the point card reader/writer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub CleanCard
public abstract void CleanCard ()
public:
virtual void CleanCard () abstract
public abstract void CleanCard ()
public abstract function CleanCard ()

Remarks

CleanCard is supported only if CapCleanCard property is true.

CleanCard may throw a PosControlException exception with the following ErrorCodes:

Value | Meaning
Illegal | The device has no cleaning capability.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
CapCleanCard


PointCardRW.ClearInput Method

PointCardRW.ClearInput Method |
 | See Also

1/18/2008

Clears all buffered device input.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearInput
public abstract void ClearInput ()
public:
virtual void ClearInput () abstract
public abstract void ClearInput ()
public abstract function ClearInput ()

Remarks

Any data events or input error events that are queued by the service object, usually waiting for the DataEventEnabled property to be set to true and FreezeEvents property to be set to false, are also cleared.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
DataEventEnabled
FreezeEvents


PointCardRW.ClearInputProperties Method

PointCardRW.ClearInputProperties Method |
 | See Also

1/18/2008

Resets the values of properties altered by DataEvent or ErrorEvent.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Sub ClearInputProperties
public virtual void ClearInputProperties ()
public:
virtual void ClearInputProperties ()
public void ClearInputProperties ()
public function ClearInputProperties ()

Remarks

Sets all data properties populated by raising the DataEvent event or the ErrorEvent event back to their default values. This does not reset the DataCount or State properties.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.ClearOutput Method

PointCardRW.ClearOutput Method |
 | See Also

1/18/2008

Clears all buffered output data. This includes all asynchronous output.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearOutput
public abstract void ClearOutput ()
public:
virtual void ClearOutput () abstract
public abstract void ClearOutput ()
public abstract function ClearOutput ()

Remarks

The application calls the ClearOutput method to delete incomplete output requests. ClearOutput also stops any output that is in progress, if it is possible. Any output error events that are queued, usually waiting for the FreezeEvents property to be set to false, are also cleared. No OutputCompleteEvent events are delivered for output requests exited in this manner.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.ClearPrintWrite Method

PointCardRW.ClearPrintWrite Method |
 | See Also

1/18/2008

Erases the printing area of a point card and erases the magnetic track data on a point card or erases the magnetic track data on a point card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearPrintWrite ( _
    kind As PointCardAreas, _
    horizontalPosition As Integer, _
    verticalPosition As Integer, _
    width As Integer, _
    height As Integer _
)
public abstract void ClearPrintWrite (
    PointCardAreas kind,
    int horizontalPosition,
    int verticalPosition,
    int width,
    int height
)
public:
virtual void ClearPrintWrite (
    PointCardAreas kind,
    int horizontalPosition,
    int verticalPosition,
    int width,
    int height
) abstract
public abstract void ClearPrintWrite (
    PointCardAreas kind,
    int horizontalPosition,
    int verticalPosition,
    int width,
    int height
)
public abstract function ClearPrintWrite (
    kind : PointCardAreas,
    horizontalPosition : int,
    verticalPosition : int,
    width : int,
    height : int
)

Parameters

kind

Defines the parts of the point card that will be cleared (erased).

1: PrintingArea

2: MagneticTracks

3: PrintingAreaAndMagneticTracks

horizontalPosition

The horizontal start position for erasing the printing area. The value is in MapMode units if CapPrintMode is true.

verticalPosition

The vertical start position for erasing the printing area. The value is in MapMode units if CapPrintMode is true.

width

The width used for erasing the printing area. The value is in MapMode units if CapPrintMode is true.

height

The height used for erasing the printing area. The value is in MapMode units if CapPrintMode is true.

Remarks

When the CapPrint and CapClearPrint properties are both true, ClearPrintWrite can be used to clear the printing area of a point card. The horizontalPosition, verticalPosition, width, and height parameters define the rectangle to clear. If these parameters are 0, 0, -1, –1 respectively, ClearPrintWrite erases the printing area.

The initialization of the magnetic track data relies on the capability of the device.

ClearPrintWrite may throw a PosControlException exception with the following ErrorCodes:

Value | Meaning
Success | ClearPrintWrite was initiated successfully.
Illegal | The point card reader/writer is not in Point Card Removal mode.
Busy | This operation cannot be performed because asynchronous output is in progress.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
CapClearPrint
CapPrint


PointCardRW.EndInsertion Method

PointCardRW.EndInsertion Method |
 | See Also

1/18/2008

Ends point card insertion processing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub EndInsertion
public abstract void EndInsertion ()
public:
virtual void EndInsertion () abstract
public abstract void EndInsertion ()
public abstract function EndInsertion ()

Remarks

When it is called, the point card reader/writer is taken out of point card Insertion mode. If a point card is detected in the device, a successful status of Success is returned to the application. If no point card is present, an extended error status NoCard is returned.

EndInsertion is paired with the BeginInsertion method for controlling point card insertion.

EndInsertion may throw a PosControlException exception with the following ErrorCodes:

Value | Meaning
Success | EndInsertion was initiated successfully.
Illegal | The point card reader/writer is not in Point Card Insertion mode.
Failure | A card is not included in point card reader/writer.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
PointCardRW.BeginInsertion Method
PointCardRW.BeginRemoval Method
EndRemoval


PointCardRW.EndRemoval Method

PointCardRW.EndRemoval Method |
 | See Also

1/18/2008

Ends point card removal processing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub EndRemoval
public abstract void EndRemoval ()
public:
virtual void EndRemoval () abstract
public abstract void EndRemoval ()
public abstract function EndRemoval ()

Remarks

When it is called, the point card reader/writer is taken out of point card removal or ejection mode. If no point card is detected in the device, a successful status of Success is returned to the application. If a point card is present, an extended error status ExtendedErrorRelease is returned.

EndRemoval is paired with the BeginRemoval method for controlling point card removal.

The application may choose to call EndRemoval immediately after a successful BeginRemoval if it wants to use the point card reader/writer sensors to determine when the point card has been ejected. Alternatively, the application may prompt the user and wait for a key press before it calls EndRemoval.

EndRemoval may throw a PosControlException exception with the following ErrorCodes:

Value | Meaning
Success | EndRemoval was initiated successfully.
Illegal | The point card reader/writer is not in Point Card Removal mode.
Failure | There is a card in the point card reader/writer.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
PointCardRW.BeginInsertion Method
PointCardRW.EndInsertion Method
PointCardRW.BeginRemoval Method


PointCardRW.PrintWrite Method

PointCardRW.PrintWrite Method |
 | See Also

1/18/2008

Prints the specified data on the printing area of the point card, writes data from the WriteXData properties to the magnetic tracks, or both.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintWrite ( _
    kind As PointCardAreas, _
    horizontalPosition As Integer, _
    verticalPosition As Integer, _
    data As String _
)
public abstract void PrintWrite (
    PointCardAreas kind,
    int horizontalPosition,
    int verticalPosition,
    string data
)
public:
virtual void PrintWrite (
    PointCardAreas kind,
    int horizontalPosition,
    int verticalPosition,
    String^ data
) abstract
public abstract void PrintWrite (
    PointCardAreas kind,
    int horizontalPosition,
    int verticalPosition,
    String data
)
public abstract function PrintWrite (
    kind : PointCardAreas,
    horizontalPosition : int,
    verticalPosition : int,
    data : String
)

Parameters

kind

Designates the effect of the point card.

horizontalPosition

The horizontal start position for printing. The value is in MapMode units if CapPrintMode is true.

verticalPosition

The vertical start position for printing. The value is in MapMode units if CapPrintMode is true.

data

The data to print. Any escape sequences in the data depends on the capabilities of the device.

Remarks

To print on a point card, the CapPrint property must be true. To write the magnetic tracks on a point card, the WriteXData properties for each track must be set to the desired value, the TracksToWrite property must be set to a bitmask that indicates which tracks to write (see TracksToWrite for a complete description), and the CapTracksToWrite property must indicate that each track specified in TracksToWrite is legal.

PrintWrite may throw a PosControlException exception with the following ErrorCodes:

Value | Meaning
Illegal | The point card reader/writer is not in Point Card Ejection mode.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
CapTracksToWrite
CapPrint
CapPrintMode
Write1Data
Write2Data
Write3Data
Write4Data
Write5Data
Write6Data
TracksToWrite


PointCardRW.RotatePrint Method

PointCardRW.RotatePrint Method |
 | See Also

1/18/2008

Enters or exits rotated print mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub RotatePrint ( _
    rotation As Rotation _
)
public abstract void RotatePrint (
    Rotation rotation
)
public:
virtual void RotatePrint (
    Rotation rotation
) abstract
public abstract void RotatePrint (
    Rotation rotation
)
public abstract function RotatePrint (
    rotation : Rotation
)

Parameters

rotation

Direction of rotation.

Remarks

The RotatePrint method designates the rotation of the printing area. After it calls this method, the application calls the PrintWrite method and the print data is printed in the direction specified by the RotatePrint call. If rotation is Normal, rotated print mode is exited.

Changing the rotation mode may also change the point card reader/writer's line height, line spacing, line width, and other metrics.

RotatePrint may throw a PosControlException exception with the following ErrorCodes:

Value | Meaning
Illegal | The point card reader/writer does not support the specified rotation.
Busy | This operation cannot be performed because asynchronous output is in progress.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
Data Characters and Escape Sequences


PointCardRW.ValidateData Method

PointCardRW.ValidateData Method |
 | See Also

1/18/2008

Determines whether a data sequence, possibly including one or more escape sequences, is valid for the specified station, before it calls the PrintWrite method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ValidateData ( _
    data As String _
)
public abstract void ValidateData (
    string data
)
public:
virtual void ValidateData (
    String^ data
) abstract
public abstract void ValidateData (
    String data
)
public abstract function ValidateData (
    data : String
)

Parameters

data

The data to validate. May include printable data and escape sequences.

Remarks

ValidateData causes no printing, but is used to determine the capabilities of the point card reader/writer.

ValidateData may throw a PosControlException exception with the following ErrorCodes:

Value | Meaning
Illegal | Some of data is not exactly supported by the point card reader/writer. However, the service object can select valid alternatives.
Failure | Some data is not supported. No alternatives can be selected.

Cases that cause Illegal to be returned are as follows:

Escape Sequence | Condition
Underline | The thickness '#' is not exactly supported: the service object selects the closest supported value.
Shading | The percentage '#' is not exactly supported: the service object selects the closest supported value.
Scale horizontally | The scaling factor '#' is not supported: the service object selects the closest supported value.
Scale vertically | The scaling factor '#' is not supported: the service object selects the closest supported value.

Cases that will cause Failure to be returned are as follows:

Escape Sequence | Condition
(General) | The escape sequence format is not valid.
Font typeface | The typeface '#' is not supported.
Bold | Not supported.
Underline | Not supported.
Italic | Not supported.
Reverse video | Not supported.
Single high and wide | Not supported.
Double wide | Not supported.
Double high | Not supported.
Double high and wide | Not supported.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
Data Characters and Escape Sequences


PointCardRW Properties

PointCardRW Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
CapBold | Gets a Boolean value that indicates whether the device can print bold characters.
CapCardEntranceSensor | Gets a Boolean value that indicates whether the device has an entrance sensor.
CapCharacterSet | Gets the default character set capability.
CapCleanCard | Gets a Boolean value that indicates whether the device supports cleaning under application control.
CapClearPrint | Gets a Boolean value that indicates whether the device can erase the printing area.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapDHigh | Gets a Boolean value that indicates whether the device can print double-high characters.
CapDWide | Gets a Boolean value that indicates whether the device can print double-wide characters.
CapDWideDHigh | Gets a Boolean value that indicates whether the device can print double-high/double-width characters.
CapItalic | Gets a Boolean value that indicates whether the device can print italic characters.
CapLeft90 | Gets a Boolean value that indicates whether the device can print in rotated-90-degree-left mode.
CapMapCharacterSet | Gets a Boolean value that indicates whether the service object can map
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapPrint | Gets a Boolean value that indicates whether the device has printing capability.
CapPrintMode | Gets a Boolean value that indicates whether the device can designate a starting position with the MapMode property.
CapRight90 | Gets a Boolean value that indicates the device can print in a rotated-90 degree-right mode.
CapRotate180 | Gets a Boolean value that indicates the device can print in a rotated upside-down mode.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapTracksToRead | Gets a bitmask that indicates which magnetic tracks are available.
CapTracksToWrite | Gets a bitmask that indicates which tracks are writable on the point card.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CardState | Gets the point card state.
CharacterSet | Gets or sets the character set for printing characters.
CharacterSetList | Gets a string of character set numbers.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
DataCount | Gets the number of currently queued data events.
DataEventEnabled | Gets or sets a Boolean value that indicates whether a DataEvent event is delivered when input data is queued.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
FontTypefaceList | Gets the fonts and typefaces supported by the point card reader/writer.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
LineChars | Gets or sets the number of characters that can be printed on a line on the point card reader/writer.
LineCharsList | Gets the line character widths supported by the point card reader/writer.
LineHeight | Gets or sets the point card reader/writer print line height.
LineSpacing | Gets or sets the spacing of each single-high print line. This includes both the printed line height plus the white space between each pair of lines.
LineWidth | Gets the width of a line of LineChars characters.
MapCharacterSet | Gets or sets a Boolean value that indicates whether characters are mapped from the application to the set specified in the CharacterSetproperty.
MapMode | Gets or sets the mapping mode of the point card reader/writer.
MaxLine | Gets the maximum printable line number.
OutputId | Gets a unique output request ID.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
PrintHeight | Gets the height of the largest character in a character set.
ReadState | Gets read state information for Track1 through Track6.
RecvLength | Gets length information for Track1 through Track6.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
SidewaysMaxChars | Gets the maximum number of characters that can be printed on each line in sideways mode.
SidewaysMaxLines | Gets the maximum number of lines that can be printed in sideways mode.
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )
Track1Data | Gets the Track1 data from the point card.
Track2Data | Gets the Track2 data from the point card.
Track3Data | Gets the Track3 data from the point card.
Track4Data | Gets the Track4 data from the point card.
Track5Data | Gets the Track5 data from the point card.
Track6Data | Gets the Track6 data from the point card.
TracksToRead | Gets or sets the tracks to read from the point card.
TracksToWrite | Gets or sets the tracks to write to the point card.
Write1Data | Gets or sets the data PrintWrite uses to write to Track1.
Write2Data | Gets or sets the data PrintWrite uses to write to Track2.
Write3Data | Gets or sets the data PrintWrite uses to write to Track3.
Write4Data | Gets or sets the data PrintWrite uses to write to Track4.
Write5Data | Gets or sets the data PrintWrite uses to write to Track5.
Write6Data | Gets or sets the data PrintWrite uses to write to Track6.
WriteState | Gets write state information for Track1 through Track6.

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether the PointCardRW is an exclusive-use device.

See Also

Reference

PointCardRW Class
Microsoft.PointOfService Namespace


PointCardRW.CapBold Property

PointCardRW.CapBold Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device can print bold characters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapBold As Boolean
public abstract bool CapBold { get; }
public:
virtual property bool CapBold {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapBold ()

public abstract function get CapBold () : boolean

Remarks

If true, the point card reader/writer can print bold characters; otherwise, false.

The CapBold property is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.CapCardEntranceSensor Property

PointCardRW.CapCardEntranceSensor Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device has an entrance sensor.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapCardEntranceSensor As Boolean
public abstract bool CapCardEntranceSensor { get; }
public:
virtual property bool CapCardEntranceSensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapCardEntranceSensor ()

public abstract function get CapCardEntranceSensor () : boolean

Remarks

If true, the point card reader/writer has an entrance sensor; otherwise, false.

The CapCardEntranceSensor property is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.CapCharacterSet Property

PointCardRW.CapCharacterSet Property |
 | See Also

1/18/2008

Gets the default character set capability.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapCharacterSet As CharacterSetCapability
public abstract CharacterSetCapability CapCharacterSet { get; }
public:
virtual property CharacterSetCapability CapCharacterSet {
    CharacterSetCapability get () abstract;
}
/** @property */
public abstract CharacterSetCapability get_CapCharacterSet ()

public abstract function get CapCharacterSet () : CharacterSetCapability

Remarks

The default character set can contain a superset of these ranges. The initial CharacterSet property can be examined for additional information information.

CapCharacterSet is updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.CapCleanCard Property

PointCardRW.CapCleanCard Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device supports cleaning under application control.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapCleanCard As Boolean
public abstract bool CapCleanCard { get; }
public:
virtual property bool CapCleanCard {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapCleanCard ()

public abstract function get CapCleanCard () : boolean

Remarks

If true, the point card reader/writer supports cleaning under application control; otherwise, false.

The CapCleanCard property is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.CapClearPrint Property

PointCardRW.CapClearPrint Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device can erase the printing area.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapClearPrint As Boolean
public abstract bool CapClearPrint { get; }
public:
virtual property bool CapClearPrint {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapClearPrint ()

public abstract function get CapClearPrint () : boolean

Remarks

If true, the Point Card Reader/Writer supports clearing (erasing) the printing area; otherwise, false.

The CapClearPrint property is updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.CapDHigh Property

PointCardRW.CapDHigh Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device can print double-high characters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapDHigh As Boolean
public abstract bool CapDHigh { get; }
public:
virtual property bool CapDHigh {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapDHigh ()

public abstract function get CapDHigh () : boolean

Remarks

If true, the point card reader/writer can print double-high characters; otherwise it is false.

The CapDhigh property is updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.CapDWide Property

PointCardRW.CapDWide Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device can print double-wide characters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapDWide As Boolean
public abstract bool CapDWide { get; }
public:
virtual property bool CapDWide {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapDWide ()

public abstract function get CapDWide () : boolean

Remarks

If true, the point card reader/writer can print double-wide characters; otherwise, false.

The CapDwide property is updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.CapDWideDHigh Property

PointCardRW.CapDWideDHigh Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device can print double-high/double-width characters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapDWideDHigh As Boolean
public abstract bool CapDWideDHigh { get; }
public:
virtual property bool CapDWideDHigh {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapDWideDHigh ()

public abstract function get CapDWideDHigh () : boolean

Remarks

If true, the point card reader/writer can print double-high/double-wide characters; otherwise, false

The CapDwideDhigh property is updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.CapItalic Property

PointCardRW.CapItalic Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device can print italic characters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapItalic As Boolean
public abstract bool CapItalic { get; }
public:
virtual property bool CapItalic {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapItalic ()

public abstract function get CapItalic () : boolean

Remarks

If true, the point card reader/writer can print italic characters; otherwise, false.

The CapItalic property is updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.CapLeft90 Property

PointCardRW.CapLeft90 Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device can print in rotated-90-degree-left mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapLeft90 As Boolean
public abstract bool CapLeft90 { get; }
public:
virtual property bool CapLeft90 {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapLeft90 ()

public abstract function get CapLeft90 () : boolean

Remarks

If true, the point card reader/writer can print in rotated-90 degree-left mode; otherwise, false

The CapLeft90 property is updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.CapMapCharacterSet Property

PointCardRW.CapMapCharacterSet Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the service object can map

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapMapCharacterSet As Boolean
public abstract bool CapMapCharacterSet { get; }
public:
virtual property bool CapMapCharacterSet {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapMapCharacterSet ()

public abstract function get CapMapCharacterSet () : boolean

Remarks

Defines the ability of the service object to map characters of the application to the selected character set when printing data.

If the CapMapCharacterSet property is true, the service object can map the characters to the character sets that are defined in the CharacterSetList property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.CapPrint Property

PointCardRW.CapPrint Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device has printing capability.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapPrint As Boolean
public abstract bool CapPrint { get; }
public:
virtual property bool CapPrint {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapPrint ()

public abstract function get CapPrint () : boolean

Remarks

If true, the point card reader/writer has printing capability; otherwise, false.

The CapPrint property is updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.CapPrintMode Property

PointCardRW.CapPrintMode Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device can designate a starting position with the MapMode property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapPrintMode As Boolean
public abstract bool CapPrintMode { get; }
public:
virtual property bool CapPrintMode {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapPrintMode ()

public abstract function get CapPrintMode () : boolean

Remarks

If true, the point card reader/writer can designate a starting print position with the MapMode property; otherwise, false

The CapPrintMode property is updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.CapRight90 Property

PointCardRW.CapRight90 Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates the device can print in a rotated-90 degree-right mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRight90 As Boolean
public abstract bool CapRight90 { get; }
public:
virtual property bool CapRight90 {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRight90 ()

public abstract function get CapRight90 () : boolean

Remarks

If true, the point card reader/writer can print in a rotated-90 degree-right mode; otherwise, false.

The CapRight90 property is updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.CapRotate180 Property

PointCardRW.CapRotate180 Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates the device can print in a rotated upside-down mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRotate180 As Boolean
public abstract bool CapRotate180 { get; }
public:
virtual property bool CapRotate180 {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRotate180 ()

public abstract function get CapRotate180 () : boolean

Remarks

If true, the point card reader/writer can print in a rotated upside-down mode; otherwise, false.

The CapRotate180 property is updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.CapTracksToRead Property

PointCardRW.CapTracksToRead Property |
 | See Also

1/18/2008

Gets a bitmask that indicates which magnetic tracks are available.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapTracksToRead As PointCardRWTracks
public abstract PointCardRWTracks CapTracksToRead { get; }
public:
virtual property PointCardRWTracks CapTracksToRead {
    PointCardRWTracks get () abstract;
}
/** @property */
public abstract PointCardRWTracks get_CapTracksToRead ()

public abstract function get CapTracksToRead () : PointCardRWTracks

Remarks

A bitmask that indicates which magnetic tracks can be accessed on the inserted point card. The value contained in this property is a bitwise OR of the constants Track1 through Track6. Valid values are defined by the PointCardRWTracks enumeration.

For example, access to track 1 is possible when the bit is Track1.

The CapTracksToRead property is updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.CapTracksToWrite Property

PointCardRW.CapTracksToWrite Property |
 | See Also

1/18/2008

Gets a bitmask that indicates which tracks are writable on the point card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapTracksToWrite As PointCardRWTracks
public abstract PointCardRWTracks CapTracksToWrite { get; }
public:
virtual property PointCardRWTracks CapTracksToWrite {
    PointCardRWTracks get () abstract;
}
/** @property */
public abstract PointCardRWTracks get_CapTracksToWrite ()

public abstract function get CapTracksToWrite () : PointCardRWTracks

Remarks

A bitmask that indicates which magnetic tracks are writable on the inserted point card. The value contained in the CapTracksToWrite property is a bitwise OR of the constants Track1 through Track6. Valid values are defined by the PointCardRWTracks enumeration.

For example, access to track 1 is possible when the bit is Track1.

The CapTracksToWrite property is updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.CardState Property

PointCardRW.CardState Property |
 | See Also

1/18/2008

Gets the point card state.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CardState As PointCardState
public abstract PointCardState CardState { get; }
public:
virtual property PointCardState CardState {
    PointCardState get () abstract;
}
/** @property */
public abstract PointCardState get_CardState ()

public abstract function get CardState () : PointCardState

Remarks

Valid values are defined by the PointCardState enumeration.

If the CapCardEntranceSensor property is true, the current card entrance sensor status is stored in the CardState property.

NoCard is always set when the CapCardEntranceSensor property is false.

The CardState property is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
PointCardRW.CapCardEntranceSensor Property


PointCardRW.CharacterSet Property

PointCardRW.CharacterSet Property |
 | See Also

1/18/2008

Gets or sets the character set for printing characters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property CharacterSet As Integer
public abstract int CharacterSet { get; set; }
public:
virtual property int CharacterSet {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_CharacterSet ()

/** @property */
public abstract void set_CharacterSet (int value)

public abstract function get CharacterSet () : int

public abstract function set CharacterSet (value : int)

Remarks

The CharacterSet property is updated by the service object, based on the capabilities of the device.

Values are as follows:

Value | Meaning
Range 101 - 199 | Device-specific character sets that do not match a code page or the ASCII or Windows ANSI character sets.
Range 400 - 990 | Code page; matches one of the standard values.
Unicode | The character set supports UNICODE.
Ascii | The ASCII character set, supporting the ASCII characters between 0x20 and 0x7F. The value of this constant is 998.
Windows | The Windows ANSI character set. The value of this constant is 999. This is exactly the same as the Windows code page 1252.
Range 1000 and higher | Windows code page; matches one of the standard values.

Accessing the CharacterSet property may throw a PosControlException exception with the following ErrorCodes:

Value | Meaning
Illegal | An invalid property value was used.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
CharacterSetList


PointCardRW.CharacterSetList Property

PointCardRW.CharacterSetList Property |
 | See Also

1/18/2008

Gets a string of character set numbers.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CharacterSetList As Integer()
public abstract int[] CharacterSetList { get; }
public:
virtual property array<int>^ CharacterSetList {
    array<int>^ get () abstract;
}
/** @property */
public abstract int[] get_CharacterSetList ()

public abstract function get CharacterSetList () : int[]

Remarks

The CharacterSetList property is typically initialized to "998,999" (ASCII, Windows ANSI character set). The string consists of ASCII numeric set numbers separated by commas.

For example, the string "101,850,999" indicates that the device supports a device-specific character set, code page 850, and the Windows ANSI character set.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
PointCardRW.CharacterSet Property


PointCardRW.DataCount Property

PointCardRW.DataCount Property |
 | See Also

1/18/2008

Gets the number of currently queued data events.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DataCount As Integer
public abstract int DataCount { get; }
public:
virtual property int DataCount {
    int get () abstract;
}
/** @property */
public abstract int get_DataCount ()

public abstract function get DataCount () : int

Remarks

The application can read this property to determine whether additional input is queued from a device but has not yet been delivered because of other application processing, freezing of events, or other causes.

The DataCount property is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.DataEventEnabled Property

PointCardRW.DataEventEnabled Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether a DataEvent event is delivered when input data is queued.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property DataEventEnabled As Boolean
public abstract bool DataEventEnabled { get; set; }
public:
virtual property bool DataEventEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_DataEventEnabled ()

/** @property */
public abstract void set_DataEventEnabled (boolean value)

public abstract function get DataEventEnabled () : boolean

public abstract function set DataEventEnabled (value : boolean)

Remarks

When set to true by the application, the service object can deliver a queued event by raising a DataEvent event. When the DataEventEnabled property is set to false by the application, the service object queues data for later delivery to the application.

Note:
If an error occurs during input processing, the service object queues the error event but does not deliver it until the application sets the DataEventEnabled property to true.

The DataEventEnabled property is set and kept current by the service object while the device is enabled.

DataEvent

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.FontTypefaceList Property

PointCardRW.FontTypefaceList Property |
 | See Also

1/18/2008

Gets the fonts and typefaces supported by the point card reader/writer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property FontTypefaceList As String()
public abstract string[] FontTypefaceList { get; }
public:
virtual property array<String^>^ FontTypefaceList {
    array<String^>^ get () abstract;
}
/** @property */
public abstract String[] get_FontTypefaceList ()

public abstract function get FontTypefaceList () : String[]

Remarks

The FontTypefaceList property is updated by the service object, based on the capabilities of the device. The string consists of font or typeface names separated by commas. The application selects a font or typeface for the point card reader/writer by using the font typeface selection escape sequence (ESC |#fT). The "#”" character is replaced by the number of the font or typeface within the list: 1, 2, and so on.

In Japan, the FontTypefaceList property frequently includes the fonts "Mincho" and "Gothic." Other fonts or typefaces may be typically supported in other countries or regions.

An empty string indicates that only the default typeface is supported.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
Data Characters and Escape Sequences


PointCardRW.IsExclusiveUseDevice Property

PointCardRW.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the PointCardRW is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Property Value

A value of true indicates that the PointCardRW device is exclusive-use. Otherwise, the value will be false.

Remarks

An exclusive-use device has the following properties:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before accessing some properties or calling methods that update the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.LineChars Property

PointCardRW.LineChars Property |
 | See Also

1/18/2008

Gets or sets the number of characters that can be printed on a line on the point card reader/writer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property LineChars As Integer
public abstract int LineChars { get; set; }
public:
virtual property int LineChars {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_LineChars ()

/** @property */
public abstract void set_LineChars (int value)

public abstract function get LineChars () : int

public abstract function set LineChars (value : int)

Remarks

If changed to a line character width that can be supported, then the width is set to the specified value. If the exact width cannot be supported, then later lines are printed with a character size that most closely supports the specified characters per line. For example, if set to 36 and the point card reader/writer can print either 30 or 40 characters per line, the service object should select the character size "40" and print up to 36 characters on each line.

If the character width cannot be supported, an error is returned. For example, if set to 42 and the point card reader/writer can print either 30 or 40 characters per line, the service object cannot support the request.

Setting LineChars may also update the LineWidth, LineHeight, and LineSpacing properties because the character pitch or font may change.

The value of the LineChars property is typically initialized to the point card reader/writer's default line character width when the device is first enabled by the service object.

Accessing the LineChars property may throw a PosControlException exception with the following ErrorCodes:

Value | Meaning
Illegal | An invalid line character width was specified.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
LineCharsList


PointCardRW.LineCharsList Property

PointCardRW.LineCharsList Property |
 | See Also

1/18/2008

Gets the line character widths supported by the point card reader/writer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property LineCharsList As Integer()
public abstract int[] LineCharsList { get; }
public:
virtual property array<int>^ LineCharsList {
    array<int>^ get () abstract;
}
/** @property */
public abstract int[] get_LineCharsList ()

public abstract function get LineCharsList () : int[]

Remarks

The LineCharsList property is typically initialized to the point card reader/writer's default line character widths by the service object. The string consists of ASCII numeric set numbers separated by commas.

For example, the string "32,36,40" indicates that the device supports line widths of 32, 36, and 40 characters.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
PointCardRW.LineChars Property


PointCardRW.LineHeight Property

PointCardRW.LineHeight Property |
 | See Also

1/18/2008

Gets or sets the point card reader/writer print line height.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property LineHeight As Integer
public abstract int LineHeight { get; set; }
public:
virtual property int LineHeight {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_LineHeight ()

/** @property */
public abstract void set_LineHeight (int value)

public abstract function get LineHeight () : int

public abstract function set LineHeight (value : int)

Remarks

If the CapPrintMode property is true, expressed in the unit of measure given by MapMode.

If changed to a height supported by the current character width, the line height is set to this value. If the exact height cannot be supported, the height is set to the closest supported value.

When LineChars is changed, LineHeight is updated to the default line height for the selected width.

The LineHeight property is typically initialized to the point card reader/writer's default line height by the service object.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.LineSpacing Property

PointCardRW.LineSpacing Property |
 | See Also

1/18/2008

Gets or sets the spacing of each single-high print line. This includes both the printed line height plus the white space between each pair of lines.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property LineSpacing As Integer
public abstract int LineSpacing { get; set; }
public:
virtual property int LineSpacing {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_LineSpacing ()

/** @property */
public abstract void set_LineSpacing (int value)

public abstract function get LineSpacing () : int

public abstract function set LineSpacing (value : int)

Remarks

Depending on point card reader/writer and the current line spacing, a multi-high print line might exceed this value. If the CapPrintMode property is true, line spacing is expressed in the unit of measure given by MapMode.

If changed to a spacing that can be supported by point card reader/writer, then the line spacing is set to this value. If the spacing cannot be supported, then the spacing is set to the closest supported value.

When the LineChars or LineHeight property is changed, the LineSpacing property is updated to the default line spacing for the selected width or height.

The value of the LineSpacing property is typically initialized to the point card reader/writer's default line spacing when the device is first enabled following the Open method. It should then be kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.LineWidth Property

PointCardRW.LineWidth Property |
 | See Also

1/18/2008

Gets the width of a line of LineChars characters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property LineWidth As Integer
public abstract int LineWidth { get; }
public:
virtual property int LineWidth {
    int get () abstract;
}
/** @property */
public abstract int get_LineWidth ()

public abstract function get LineWidth () : int

Remarks

If the CapPrintMode property is true, expressed in the unit of measure given by MapMode, setting the LineChars property may also update the LineWidth property.

The LineWidth property is typically initialized to the point card reader/writer's default line width by the service object.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.MapCharacterSet Property

PointCardRW.MapCharacterSet Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether characters are mapped from the application to the set specified in the CharacterSetproperty.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property MapCharacterSet As Boolean
public abstract bool MapCharacterSet { get; set; }
public:
virtual property bool MapCharacterSet {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_MapCharacterSet ()

/** @property */
public abstract void set_MapCharacterSet (boolean value)

public abstract function get MapCharacterSet () : boolean

public abstract function set MapCharacterSet (value : boolean)

Remarks

If MapCharacterSet is true and when outputting data, the service object maps the characters transferred by the application to the character set selected in the CharacterSet property for printing data.

If MapCharacterSet is false, then no mapping is supported. In such a case the application must guarantee the mapping of the character set used in the application to the character set selected in the CharacterSet property.

If CapMapCharacterSet is false, then MapCharacterSet is always false.

MapCharacterSet is updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
PointCardRW.CharacterSet Property
PointCardRW.CapMapCharacterSet Property


PointCardRW.MapMode Property

PointCardRW.MapMode Property |
 | See Also

1/18/2008

Gets or sets the mapping mode of the point card reader/writer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property MapMode As MapMode
public abstract MapMode MapMode { get; set; }
public:
virtual property MapMode MapMode {
    MapMode get () abstract;
    void set (MapMode value) abstract;
}
/** @property */
public abstract MapMode get_MapMode ()

/** @property */
public abstract void set_MapMode (MapMode value)

public abstract function get MapMode () : MapMode

public abstract function set MapMode (value : MapMode)

Remarks

The mapping mode defines the unit of measure used for other properties, such as line heights and line spacing.

Setting MapMode may also change the LineHeight, LineSpacing, and LineWidth properties.

MapMode is set by the service object.

Accessing MapMode may throw a PosControlException exception with the following ErrorCodes:

Value | Meaning
Illegal | An invalid mapping mode was specified.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.MaxLine Property

PointCardRW.MaxLine Property |
 | See Also

1/18/2008

Gets the maximum printable line number.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property MaxLine As Integer
public abstract int MaxLine { get; }
public:
virtual property int MaxLine {
    int get () abstract;
}
/** @property */
public abstract int get_MaxLine ()

public abstract function get MaxLine () : int

Remarks

When the CapPrintMode property is false, MaxLine contains the maximum printable line number.

In the case that there is a double-high character in the same line, it relies on the capability of the device.

When the LineHeight property and the LineSpacing property change, the MaxLine property can be renewed.

MaxLine is typically initialized to the point card reader/writer's default maximum printable line number by the service object. It should then be kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
PointCardRW.LineHeight Property


PointCardRW.OutputId Property

PointCardRW.OutputId Property |
 | See Also

1/18/2008

Gets a unique output request ID.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property OutputId As Integer
public abstract int OutputId { get; }
public:
virtual property int OutputId {
    int get () abstract;
}
/** @property */
public abstract int get_OutputId ()

public abstract function get OutputId () : int

Remarks

When the application calls the PrintWrite method, the point card reader/writer assigns a unique identification number for this request. This ID is stored in the OutputId Property. The point card reader/writer then either queues the request or starts its processing. Either way, the point card reader/writer returns to the application quickly.

When the PrintWrite method is complete, an OutputCompleteEvent event is delivered to the application. The OutputId associated with the completed request is passed in the OutputCompleteEvent event.

If the PrintWrite method fails during its processing, an ErrorEvent event is delivered to the application. If the application has multiple outstanding output requests, the OutputId of the request that failed can be determined by watching which requests have successfully completed by monitoring OutputCompleteEvent events. The request that failed is the one that was issued immediately after the last request that successfully completed.

OutputId is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.PrintHeight Property

PointCardRW.PrintHeight Property |
 | See Also

1/18/2008

Gets the height of the largest character in a character set.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property PrintHeight As Integer
public abstract int PrintHeight { get; }
public:
virtual property int PrintHeight {
    int get () abstract;
}
/** @property */
public abstract int get_PrintHeight ()

public abstract function get PrintHeight () : int

Remarks

When the CapPrintMode property is true, the height of the largest character in the character set, expressed in MapMode units, is stored in PrintHeight.

When the MapMode property is changed, the value of PrintHeight changes.

PrintHeight is typically initialized to the point card reader/writer's default print height by the service object. It should then be kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
PointCardRW.CapPrintMode Property
PointCardRW.MapMode Property


PointCardRW.ReadState Property

PointCardRW.ReadState Property |
 | See Also

1/18/2008

Gets read state information for Track1 through Track6.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ReadState As PointCardReadWriteStates
public abstract PointCardReadWriteStates ReadState { get; }
public:
virtual property PointCardReadWriteStates ReadState {
    PointCardReadWriteStates get () abstract;
}
/** @property */
public abstract PointCardReadWriteStates get_ReadState ()

public abstract function get ReadState () : PointCardReadWriteStates

Remarks

Valid values are defined by the PointCardReadWriteStates enumeration.

The service object initializes ReadState immediately before it queues an ErrorEvent or DataEvent event.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.RecvLength Property

PointCardRW.RecvLength Property |
 | See Also

1/18/2008

Gets length information for Track1 through Track6.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property RecvLength As PointCardReceiveLengths
public abstract PointCardReceiveLengths RecvLength { get; }
public:
virtual property PointCardReceiveLengths RecvLength {
    PointCardReceiveLengths get () abstract;
}
/** @property */
public abstract PointCardReceiveLengths get_RecvLength ()

public abstract function get RecvLength () : PointCardReceiveLengths

Remarks

Valid values are defined by the PointCardReceiveLengths enumeration.

A value of zero means that no data was obtained from the swipe for that track. This can occur if the hardware device does not have a read head for the track; if only STX (prefix character), ETX (terminator character) and LRC were obtained from the swipe for that track; if the data that is read included errors; or if the application intentionally precluded incoming data from the track through the TracksToRead property.

A value greater than zero (> 0) indicates the length in bytes of the corresponding track property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
PointCardRW.CapPrintMode Property


PointCardRW.SidewaysMaxChars Property

PointCardRW.SidewaysMaxChars Property |
 | See Also

1/18/2008

Gets the maximum number of characters that can be printed on each line in sideways mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property SidewaysMaxChars As Integer
public abstract int SidewaysMaxChars { get; }
public:
virtual property int SidewaysMaxChars {
    int get () abstract;
}
/** @property */
public abstract int get_SidewaysMaxChars ()

public abstract function get SidewaysMaxChars () : int

Remarks

If the capabilities CapLeft90 and CapRight90 are both false, then SidewaysMaxChars is zero.

Changing the LineHeight, LineSpacing, and LineChars properties may cause SidewaysMaxChars to change.

SidewaysMaxChars is typically initialized by the service object to the default maximum number of sideways characters for the point card.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
SidewaysMaxLines


PointCardRW.SidewaysMaxLines Property

PointCardRW.SidewaysMaxLines Property |
 | See Also

1/18/2008

Gets the maximum number of lines that can be printed in sideways mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property SidewaysMaxLines As Integer
public abstract int SidewaysMaxLines { get; }
public:
virtual property int SidewaysMaxLines {
    int get () abstract;
}
/** @property */
public abstract int get_SidewaysMaxLines ()

public abstract function get SidewaysMaxLines () : int

Remarks

If the capabilities CapLeft90 and CapRight90 are both false, then SidewaysMaxLines is zero.

Changing the LineHeight, LineSpacing, and LineChars properties may cause SidewaysMaxLines to change.

SidewaysMaxLines is typically initialized by the service object to the default maximum number of lines for the point card.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
PointCardRW.SidewaysMaxChars Property


PointCardRW.Track1Data Property

PointCardRW.Track1Data Property |
 | See Also

1/18/2008

Gets the Track1 data from the point card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property Track1Data As Byte()
public abstract byte[] Track1Data { get; }
public:
virtual property array<unsigned char>^ Track1Data {
    array<unsigned char>^ get () abstract;
}
/** @property */
public abstract byte[] get_Track1Data ()

public abstract function get Track1Data () : byte[]

Remarks

Track1Data contains track data between, but excluding the start and end sentinels.

An empty string indicates the track is inaccessible.

Track1Data is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.Track2Data Property

PointCardRW.Track2Data Property |
 | See Also

1/18/2008

Gets the Track2 data from the point card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property Track2Data As Byte()
public abstract byte[] Track2Data { get; }
public:
virtual property array<unsigned char>^ Track2Data {
    array<unsigned char>^ get () abstract;
}
/** @property */
public abstract byte[] get_Track2Data ()

public abstract function get Track2Data () : byte[]

Remarks

Track2Data contains track data between, but excluding the start and end sentinels.

An empty string indicates the track is inaccessible.

Track2Data is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.Track3Data Property

PointCardRW.Track3Data Property |
 | See Also

1/18/2008

Gets the Track3 data from the point card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property Track3Data As Byte()
public abstract byte[] Track3Data { get; }
public:
virtual property array<unsigned char>^ Track3Data {
    array<unsigned char>^ get () abstract;
}
/** @property */
public abstract byte[] get_Track3Data ()

public abstract function get Track3Data () : byte[]

Remarks

Track3Data contains track data between, but excluding the start and end sentinels.

An empty string indicates the track is inaccessible.

Track3Data is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.Track4Data Property

PointCardRW.Track4Data Property |
 | See Also

1/18/2008

Gets the Track4 data from the point card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property Track4Data As Byte()
public abstract byte[] Track4Data { get; }
public:
virtual property array<unsigned char>^ Track4Data {
    array<unsigned char>^ get () abstract;
}
/** @property */
public abstract byte[] get_Track4Data ()

public abstract function get Track4Data () : byte[]

Remarks

Track4Data contains track data between, but excluding the start and end sentinels.

An empty string indicates the track is inaccessible.

Track4Data is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.Track5Data Property

PointCardRW.Track5Data Property |
 | See Also

1/18/2008

Gets the Track5 data from the point card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property Track5Data As Byte()
public abstract byte[] Track5Data { get; }
public:
virtual property array<unsigned char>^ Track5Data {
    array<unsigned char>^ get () abstract;
}
/** @property */
public abstract byte[] get_Track5Data ()

public abstract function get Track5Data () : byte[]

Remarks

Track5Data contains track data between, but excluding the start and end sentinels.

An empty string indicates the track is inaccessible.

Track5Data is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.Track6Data Property

PointCardRW.Track6Data Property |
 | See Also

1/18/2008

Gets the Track6 data from the point card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property Track6Data As Byte()
public abstract byte[] Track6Data { get; }
public:
virtual property array<unsigned char>^ Track6Data {
    array<unsigned char>^ get () abstract;
}
/** @property */
public abstract byte[] get_Track6Data ()

public abstract function get Track6Data () : byte[]

Remarks

Track6Data contains track data between, but excluding the start and end sentinels.

An empty string indicates the track is inaccessible.

Track6Data is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.TracksToRead Property

PointCardRW.TracksToRead Property |
 | See Also

1/18/2008

Gets or sets the tracks to read from the point card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property TracksToRead As PointCardRWTracks
public abstract PointCardRWTracks TracksToRead { get; set; }
public:
virtual property PointCardRWTracks TracksToRead {
    PointCardRWTracks get () abstract;
    void set (PointCardRWTracks value) abstract;
}
/** @property */
public abstract PointCardRWTracks get_TracksToRead ()

/** @property */
public abstract void set_TracksToRead (PointCardRWTracks value)

public abstract function get TracksToRead () : PointCardRWTracks

public abstract function set TracksToRead (value : PointCardRWTracks)

Remarks

It contains a bitwise OR of the constants Track1 through Track6. It can contain only values that the CapTracksToRead property marked as allowed. For example, to read tracks 1, 2, and 3, TracksToRead is set to Track1 | Track2 | Track3.

TracksToRead is typically initialized by the service object to the default track to read for the point card. It should then be kept current by the service object.

When TracksToRead is accessed, it may throw a PosControlException exception with the following ErrorCodes:

Value | Meaning
Busy | This operation cannot be performed because asynchronous output is in progress.
Illegal | An illegal track is defined. The track is not available for writing. Refer to CapTracksToRead.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
PointCardRW.CapTracksToRead Property


PointCardRW.TracksToWrite Property

PointCardRW.TracksToWrite Property |
 | See Also

1/18/2008

Gets or sets the tracks to write to the point card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property TracksToWrite As PointCardRWTracks
public abstract PointCardRWTracks TracksToWrite { get; set; }
public:
virtual property PointCardRWTracks TracksToWrite {
    PointCardRWTracks get () abstract;
    void set (PointCardRWTracks value) abstract;
}
/** @property */
public abstract PointCardRWTracks get_TracksToWrite ()

/** @property */
public abstract void set_TracksToWrite (PointCardRWTracks value)

public abstract function get TracksToWrite () : PointCardRWTracks

public abstract function set TracksToWrite (value : PointCardRWTracks)

Remarks

Valid values are defined by the PointCardRWTracks enumeration.

It contains a bitwise OR of the constants Track1 through Track6. It can contain only values that the CapTracksToWrite property marked as allowed. For example, to write to tracks 1, 2, and 3, TracksToWrite would be set to Track1 | Track2 | Track3.

TracksToWrite is typically initialized by the service object to the default tracks to write.

Accessing TracksToWrite may throw a PosControlException exception with the following ErrorCodes:

Value | Meaning
Busy | This operation cannot be performed because asynchronous output is in progress.
Illegal | An illegal track was defined. The Track is not available for writing. Refer to CapTracksToWrite.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
PointCardRW.CapTracksToWrite Property
PointCardRW.PrintWrite Method


PointCardRW.Write1Data Property

PointCardRW.Write1Data Property |
 | See Also

1/18/2008

Gets or sets the data PrintWrite uses to write to Track1.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property Write1Data As Byte()
public abstract byte[] Write1Data { get; set; }
public:
virtual property array<unsigned char>^ Write1Data {
    array<unsigned char>^ get () abstract;
    void set (array<unsigned char>^ value) abstract;
}
/** @property */
public abstract byte[] get_Write1Data ()

/** @property */
public abstract void set_Write1Data (byte[] value)

public abstract function get Write1Data () : byte[]

public abstract function set Write1Data (value : byte[])

Remarks

The PrintWrite method writes this data in Track1 of a point card.

Write1Data contains track data between, but excluding the start and end sentinels.

Write1Data is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.Write2Data Property

PointCardRW.Write2Data Property |
 | See Also

1/18/2008

Gets or sets the data PrintWrite uses to write to Track2.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property Write2Data As Byte()
public abstract byte[] Write2Data { get; set; }
public:
virtual property array<unsigned char>^ Write2Data {
    array<unsigned char>^ get () abstract;
    void set (array<unsigned char>^ value) abstract;
}
/** @property */
public abstract byte[] get_Write2Data ()

/** @property */
public abstract void set_Write2Data (byte[] value)

public abstract function get Write2Data () : byte[]

public abstract function set Write2Data (value : byte[])

Remarks

The PrintWrite method writes this data in track 2 of a point card.

Write2Data contains track data between, but excluding the start and end sentinels.

Write2Data is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.Write3Data Property

PointCardRW.Write3Data Property |
 | See Also

1/18/2008

Gets or sets the data PrintWrite uses to write to Track3.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property Write3Data As Byte()
public abstract byte[] Write3Data { get; set; }
public:
virtual property array<unsigned char>^ Write3Data {
    array<unsigned char>^ get () abstract;
    void set (array<unsigned char>^ value) abstract;
}
/** @property */
public abstract byte[] get_Write3Data ()

/** @property */
public abstract void set_Write3Data (byte[] value)

public abstract function get Write3Data () : byte[]

public abstract function set Write3Data (value : byte[])

Remarks

The PrintWrite method writes this data in track 3 of a point card.

Write3Data contains track data between, but excluding the start and end sentinels.

Write3Data is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.Write4Data Property

PointCardRW.Write4Data Property |
 | See Also

1/18/2008

Gets or sets the data PrintWrite uses to write to Track4.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property Write4Data As Byte()
public abstract byte[] Write4Data { get; set; }
public:
virtual property array<unsigned char>^ Write4Data {
    array<unsigned char>^ get () abstract;
    void set (array<unsigned char>^ value) abstract;
}
/** @property */
public abstract byte[] get_Write4Data ()

/** @property */
public abstract void set_Write4Data (byte[] value)

public abstract function get Write4Data () : byte[]

public abstract function set Write4Data (value : byte[])

Remarks

The PrintWrite method writes this data in track 4 of a point card.

Write4Data contains track data between, but excluding the start and end sentinels.

Write4Data is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.Write5Data Property

PointCardRW.Write5Data Property |
 | See Also

1/18/2008

Gets or sets the data PrintWrite uses to write to Track5.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property Write5Data As Byte()
public abstract byte[] Write5Data { get; set; }
public:
virtual property array<unsigned char>^ Write5Data {
    array<unsigned char>^ get () abstract;
    void set (array<unsigned char>^ value) abstract;
}
/** @property */
public abstract byte[] get_Write5Data ()

/** @property */
public abstract void set_Write5Data (byte[] value)

public abstract function get Write5Data () : byte[]

public abstract function set Write5Data (value : byte[])

Remarks

The PrintWrite method writes this data in track 5 of a point card.

Write5Data contains track data between, but excluding the start and end sentinels.

Write5Data is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.Write6Data Property

PointCardRW.Write6Data Property |
 | See Also

1/18/2008

Gets or sets the data PrintWrite uses to write to Track6.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property Write6Data As Byte()
public abstract byte[] Write6Data { get; set; }
public:
virtual property array<unsigned char>^ Write6Data {
    array<unsigned char>^ get () abstract;
    void set (array<unsigned char>^ value) abstract;
}
/** @property */
public abstract byte[] get_Write6Data ()

/** @property */
public abstract void set_Write6Data (byte[] value)

public abstract function get Write6Data () : byte[]

public abstract function set Write6Data (value : byte[])

Remarks

The PrintWrite method writes this data in track 6 of a point card.

Write6Data contains track data between, but excluding the start and end sentinels.

Write6Data is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW.WriteState Property

PointCardRW.WriteState Property |
 | See Also

1/18/2008

Gets write state information for Track1 through Track6.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property WriteState As PointCardReadWriteStates
public abstract PointCardReadWriteStates WriteState { get; }
public:
virtual property PointCardReadWriteStates WriteState {
    PointCardReadWriteStates get () abstract;
}
/** @property */
public abstract PointCardReadWriteStates get_WriteState ()

public abstract function get WriteState () : PointCardReadWriteStates

Remarks

Valid values are defined by the PointCardReadWriteStates enumeration.

The service object sets the WriteState property immediately before it notifies the ErrorEvent event.

WriteState is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRW Events

PointCardRW Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DataEvent | Raised by the service object to notify the application that input data is available from the device.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
ErrorEvent | Raised by the service object to notify the application that a point card error has been detected and a suitable response by the application is necessary to process the error condition.
OutputCompleteEvent | Raised by the service object to notify the application that the queued output request associated with the OutputId property has completed successfully.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

PointCardRW Class
Microsoft.PointOfService Namespace


PointCardRW.DataEvent Event

PointCardRW.DataEvent Event |
 | See Also

1/18/2008

Raised by the service object to notify the application that input data is available from the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event DataEvent As DataEventHandler
public abstract event DataEventHandler DataEvent
public:
virtual event DataEventHandler^ DataEvent {
    void add (DataEventHandler^ value) abstract;
    void remove (DataEventHandler^ value) abstract;
}
/** @event */
public abstract void add_DataEvent (DataEventHandler value)

/** @event */
public abstract void remove_DataEvent (DataEventHandler value)

Remarks

The point card data is put in each property before this event is delivered.

When this event is delivered to the application, the DataEventEnabled property is changed to false so that no additional data events are delivered until the application sets DataEventEnabled back to true. The actual byte array input data is put in one or more device-specific properties.

If DataEventEnabled is false at the time that data is received, then the data is queued in an internal buffer, the device-specific input data properties are not updated, and the event is not delivered. When DataEventEnabled is later changed back to true, the event will be delivered immediately if input data is queued and FreezeEvents is false.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
PointCardRW.DataEventEnabled Property
FreezeEvents


PointCardRW.ErrorEvent Event

PointCardRW.ErrorEvent Event |
 | See Also

1/18/2008

Raised by the service object to notify the application that a point card error has been detected and a suitable response by the application is necessary to process the error condition.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event ErrorEvent As DeviceErrorEventHandler
public abstract event DeviceErrorEventHandler ErrorEvent
public:
virtual event DeviceErrorEventHandler^ ErrorEvent {
    void add (DeviceErrorEventHandler^ value) abstract;
    void remove (DeviceErrorEventHandler^ value) abstract;
}
/** @event */
public abstract void add_ErrorEvent (DeviceErrorEventHandler value)

/** @event */
public abstract void remove_ErrorEvent (DeviceErrorEventHandler value)

Remarks

Input error events are generated when errors occur while they read the magnetic track data from a newly inserted card. Input error events are not delivered until DataEventEnabled is true so that correct application sequencing occurs.

The error information data is put in ReadState property before this event is delivered. The RecvLength property is set to 0 for each track that had an error and the TrackXData property is set to empty for each track that had an error.

Output error events are generated and delivered when an error occurs during asynchronous PrintWrite processing. The errors are put into the WriteState property before the event is delivered.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace
Status, Result Code, and State Model
PointCardRW.ReadState Property
PointCardRW.RecvLength Property
PointCardRW.Track1Data Property
PointCardRW.Track2Data Property
PointCardRW.Track3Data Property
PointCardRW.Track4Data Property
PointCardRW.Track5Data Property
PointCardRW.Track6Data Property
PointCardRW.WriteState Property


PointCardRW.OutputCompleteEvent Event

PointCardRW.OutputCompleteEvent Event |
 | See Also

1/18/2008

Raised by the service object to notify the application that the queued output request associated with the OutputId property has completed successfully.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event OutputCompleteEvent As OutputCompleteEventHandler
public abstract event OutputCompleteEventHandler OutputCompleteEvent
public:
virtual event OutputCompleteEventHandler^ OutputCompleteEvent {
    void add (OutputCompleteEventHandler^ value) abstract;
    void remove (OutputCompleteEventHandler^ value) abstract;
}
/** @event */
public abstract void add_OutputCompleteEvent (OutputCompleteEventHandler value)

/** @event */
public abstract void remove_OutputCompleteEvent (OutputCompleteEventHandler value)

Remarks

The OutputCompleteEvent event is queued after the request's data has been both sent and the service object has confirmation that it was successfully processed by the device.

See Also

Reference

PointCardRW Class
PointCardRW Members
Microsoft.PointOfService Namespace


PointCardRWTracks Enumeration

PointCardRWTracks Enumeration |
 | See Also

1/18/2008

Enumerates the possible tracks to read from or write to.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration PointCardRWTracks
[FlagsAttribute]
public enum PointCardRWTracks
[FlagsAttribute]
public enum class PointCardRWTracks
/** @attribute FlagsAttribute() */
public enum PointCardRWTracks
FlagsAttribute
public enum PointCardRWTracks

Members

Member name | Description
Track1 | Track 1
Track2 | Track 2
Track3 | Track 3
Track4 | Track 4
Track5 | Track 5
Track6 | Track 6

Remarks

Used by the TracksToRead,TracksToWrite, CapTracksToRead, and CapTracksToWrite properties. Members of this enumeration replace the PCRW_TRACKn range of UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
PointCardRW.CapTracksToRead Property
PointCardRW.CapTracksToWrite Property
PointCardRW.TracksToRead Property
PointCardRW.TracksToWrite Property


PointCardState Enumeration

PointCardState Enumeration |
 | See Also

1/18/2008

Enumerates the possible card states the point card device can be in.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration PointCardState
public enum PointCardState
public enum class PointCardState
public enum PointCardState
public enum PointCardState

Members

Member name | Description
Inserted | There is a card in the device.
NoCard | No card or card sensor position indeterminate.
Remaining | There is a card remaining in an entrance.

Remarks

Used by the CardState property. Members of this enumeration replace the PCRW_STATE_NOCARD, PCRW_STATE_REMAINING, and PCRW_STATE_INRW UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
PointCardRW.CardState Property


PosAssemblyAttribute Class

PosAssemblyAttribute Class |
 | See Also Members

1/18/2008

Defines an assembly attribute that can be attached as metadata to a .dll, identifying that assembly as a POS for .NET service object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple:=False, Inherited:=False)> _
Public NotInheritable Class PosAssemblyAttribute
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple=false, Inherited=false)]
public sealed class PosAssemblyAttribute : Attribute
[AttributeUsageAttribute(AttributeTargets::Assembly, AllowMultiple=false, Inherited=false)]
public ref class PosAssemblyAttribute sealed : public Attribute
/** @attribute AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple=false, Inherited=false) */
public final class PosAssemblyAttribute extends Attribute
AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple=false, Inherited=false)
public final class PosAssemblyAttribute extends Attribute

Remarks

Used by the PosExplorer class to verify that an assembly is a POS for .NET service object. For more information about assembly attributes and how to use them, see the .NET Framework documentation.

Inheritance Hierarchy

System.Object
System.Attribute
Microsoft.PointOfService.PosAssemblyAttribute

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosAssemblyAttribute Members
Microsoft.PointOfService Namespace


PosAssemblyAttribute Members

PosAssemblyAttribute Members |
 | See Also Constructors Methods Properties Explicit Interface Implementations

1/18/2008

Defines an assembly attribute that can be attached as metadata to a .dll, identifying that assembly as a POS for .NET service object.

The following tables list the members exposed by the PosAssemblyAttribute type.

Public Constructors

Name | Description
PosAssemblyAttribute | Creates an instance of the PosAssemblyAttribute class with the specified manufacturer name.
Top

Public Properties

Name | Description
ManufacturerName | Gets the manufacturer name.
TypeId | (inherited from Attribute )
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Attribute )
GetCustomAttribute | Overloaded. (inherited from Attribute )
GetCustomAttributes | Overloaded. (inherited from Attribute )
GetHashCode | (inherited from Attribute )
GetType | (inherited from Object )
IsDefaultAttribute | (inherited from Attribute )
IsDefined | Overloaded. (inherited from Attribute )
Match | (inherited from Attribute )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

Explicit Interface Implementations

Name | Description
System.Runtime.InteropServices._Attribute.GetIDsOfNames | (inherited from Attribute )
System.Runtime.InteropServices._Attribute.GetTypeInfo | (inherited from Attribute )
System.Runtime.InteropServices._Attribute.GetTypeInfoCount | (inherited from Attribute )
System.Runtime.InteropServices._Attribute.Invoke | (inherited from Attribute )
Top

See Also

Reference

PosAssemblyAttribute Class
Microsoft.PointOfService Namespace


PosAssemblyAttribute Constructor

PosAssemblyAttribute Constructor |
 | See Also

1/18/2008

Creates an instance of the PosAssemblyAttribute class with the specified manufacturer name.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    manufacturerName As String _
)
public PosAssemblyAttribute (
    string manufacturerName
)
public:
PosAssemblyAttribute (
    String^ manufacturerName
)
public PosAssemblyAttribute (
    String manufacturerName
)
public function PosAssemblyAttribute (
    manufacturerName : String
)

Parameters

manufacturerName

Manufacturer name.

See Also

Reference

PosAssemblyAttribute Class
PosAssemblyAttribute Members
Microsoft.PointOfService Namespace


PosAssemblyAttribute Methods

PosAssemblyAttribute Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Attribute )
GetCustomAttribute | Overloaded. (inherited from Attribute )
GetCustomAttributes | Overloaded. (inherited from Attribute )
GetHashCode | (inherited from Attribute )
GetType | (inherited from Object )
IsDefaultAttribute | (inherited from Attribute )
IsDefined | Overloaded. (inherited from Attribute )
Match | (inherited from Attribute )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

Explicit Interface Implementations

Name | Description
System.Runtime.InteropServices._Attribute.GetIDsOfNames | (inherited from Attribute )
System.Runtime.InteropServices._Attribute.GetTypeInfo | (inherited from Attribute )
System.Runtime.InteropServices._Attribute.GetTypeInfoCount | (inherited from Attribute )
System.Runtime.InteropServices._Attribute.Invoke | (inherited from Attribute )

See Also

Reference

PosAssemblyAttribute Class
Microsoft.PointOfService Namespace


PosAssemblyAttribute Properties

PosAssemblyAttribute Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
ManufacturerName | Gets the manufacturer name.
TypeId | (inherited from Attribute )

See Also

Reference

PosAssemblyAttribute Class
Microsoft.PointOfService Namespace


PosAssemblyAttribute.ManufacturerName Property

PosAssemblyAttribute.ManufacturerName Property |
 | See Also

1/18/2008

Gets the manufacturer name.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property ManufacturerName As String
public string ManufacturerName { get; }
public:
property String^ ManufacturerName {
    String^ get ();
}
/** @property */
public String get_ManufacturerName ()

public function get ManufacturerName () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosAssemblyAttribute Class
PosAssemblyAttribute Members
Microsoft.PointOfService Namespace


PosCommon Class

PosCommon Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for constants, properties, methods, and events common to all UPOS devices.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class PosCommon
    Inherits PosDevice
public abstract class PosCommon : PosDevice
public ref class PosCommon abstract : public PosDevice
public abstract class PosCommon extends PosDevice
public abstract class PosCommon extends PosDevice

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Derived Classes

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Members
Microsoft.PointOfService Namespace


PosCommon Members

PosCommon Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for constants, properties, methods, and events common to all UPOS devices.

The following tables list the members exposed by the PosCommon type.

Protected Constructors

Name | Description
PosCommon | Creates an instance of the PosCommon class.
Top

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted.
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated.
ExtendedErrorStatisticsDependency |
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic.
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic.
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic.
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic.
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic.
StatisticInterface | Holds the programmatic name of the Interface common statistic.
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic.
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic.
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic.
StatisticModelName | Holds the programmatic name of the Model Name common statistic.
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic.
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal.
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests.
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline.
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use.
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully.
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started.
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful.
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational.
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state.
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software.
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully.
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out.
Top

Public Properties (see also Protected Properties )

Name | Description
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file.
CapPowerReporting | Gets the power reporting capabilities of the device.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method.
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods.
CheckHealthText | Gets a string that indicates the health of the device.
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access.
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
DeviceDescription | Gets a string identifying the device and the company that manufactured it.
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state.
DeviceName | Gets a short string identifying the device and any pertinent information about it.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events.
PowerNotify | Gets or sets the type of power notification selection made by the application.
PowerState | Gets the current power condition.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it.
ServiceObjectVersion | Gets the Service Object version number.
State | Gets the current state of the device.
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event.
Top

Protected Properties

Name | Description
DeviceInstanceId |
DevicePath | Gets or sets the hardware path of a device.
HardwareId |
IsExclusiveUseDevice | Gets a Boolean value that indicates whether the device is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | Tests the state of a device.
Claim | Requests exclusive access to the device.
Close | Releases the device and its resources.
CompareFirmwareVersion | Determines whether the version of the specified firmware is newer than, older than, or the same as the version of firmware in the physical device.
DirectIO | Used to communicate directly with the Service Object.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device.
ResetStatistic | Resets the specified statistic to 0 (zero).
ResetStatistics | Overloaded.
RetrieveStatistic | Retrieves the specified device statistic.
RetrieveStatistics | Overloaded.
ToString | (inherited from Object )
UpdateFirmware | Updates the firmware of a device with the version of the firmware contained or defined in the file specified by the firmwareFileName parameter regardless of whether that firmware’s version is newer than, older than, or the same as the version of the firmware already in the device.
UpdateStatistic | Updates the value of a specified device statistic.
UpdateStatistics | Overloaded.
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | Deletes the specified property from the XML configuration file.
Finalize | (inherited from Object )
GetConfigurationProperty | Used by the Service Object to retrieve the specified property from the XML configuration file.
Invoke | Used by the Service Objects to raise an event.
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | Sets a property value (or create a new property) in the XML configuration file.
Top

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change.
Top

Protected Events

Name | Description
DeviceAddedEvent |
DeviceRemovedEvent |
Top

See Also

Reference

PosCommon Class
Microsoft.PointOfService Namespace


PosCommon Fields

PosCommon Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted.
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated.
ExtendedErrorStatisticsDependency |
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic.
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic.
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic.
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic.
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic.
StatisticInterface | Holds the programmatic name of the Interface common statistic.
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic.
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic.
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic.
StatisticModelName | Holds the programmatic name of the Model Name common statistic.
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic.
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal.
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests.
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline.
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use.
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully.
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started.
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful.
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational.
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state.
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software.
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully.
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out.

See Also

Reference

PosCommon Class
Microsoft.PointOfService Namespace


PosCommon.ExtendedErrorFirmwareBadFile Field

PosCommon.ExtendedErrorFirmwareBadFile Field |
 | See Also

1/18/2008

Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorFirmwareBadFile As Integer
public const int ExtendedErrorFirmwareBadFile
public:
literal int ExtendedErrorFirmwareBadFile
public static final int ExtendedErrorFirmwareBadFile
public const var ExtendedErrorFirmwareBadFile : int

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.ExtendedErrorStatistics Field

PosCommon.ExtendedErrorStatistics Field |
 | See Also

1/18/2008

Indicates a specified statistic could not be reset or updated.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorStatistics As Integer
public const int ExtendedErrorStatistics
public:
literal int ExtendedErrorStatistics
public static final int ExtendedErrorStatistics
public const var ExtendedErrorStatistics : int

Remarks

Used by the ResetStatistics et al and UpdateStatistics et al methods.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.ExtendedErrorStatisticsDependency Field

PosCommon.ExtendedErrorStatisticsDependency Field |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorStatisticsDependency As Integer

public const int ExtendedErrorStatisticsDependency

public:
literal int ExtendedErrorStatisticsDependency

public static final int ExtendedErrorStatisticsDependency

public const var ExtendedErrorStatisticsDependency : int

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.StatisticCommunicationErrorCount Field

PosCommon.StatisticCommunicationErrorCount Field |
 | See Also

1/18/2008

Holds the programmatic name of the Communication Error Count common statistic.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticCommunicationErrorCount As String
public const string StatisticCommunicationErrorCount
public:
literal String^ StatisticCommunicationErrorCount
public static final String StatisticCommunicationErrorCount
public const var StatisticCommunicationErrorCount : String

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.StatisticDeviceCategory Field

PosCommon.StatisticDeviceCategory Field |
 | See Also

1/18/2008

Holds the programmatic name of the Device Category common statistic.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticDeviceCategory As String
public const string StatisticDeviceCategory
public:
literal String^ StatisticDeviceCategory
public static final String StatisticDeviceCategory
public const var StatisticDeviceCategory : String

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.StatisticFirmwareRevision Field

PosCommon.StatisticFirmwareRevision Field |
 | See Also

1/18/2008

Holds the programmatic name of the Firmware Revision common statistic.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticFirmwareRevision As String
public const string StatisticFirmwareRevision
public:
literal String^ StatisticFirmwareRevision
public static final String StatisticFirmwareRevision
public const var StatisticFirmwareRevision : String

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.StatisticHoursPoweredCount Field

PosCommon.StatisticHoursPoweredCount Field |
 | See Also

1/18/2008

Holds the programmatic name of the Hours Powered On common statistic.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticHoursPoweredCount As String
public const string StatisticHoursPoweredCount
public:
literal String^ StatisticHoursPoweredCount
public static final String StatisticHoursPoweredCount
public const var StatisticHoursPoweredCount : String

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.StatisticInstallationDate Field

PosCommon.StatisticInstallationDate Field |
 | See Also

1/18/2008

Holds the programmatic name of the Installation Date common statistic.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticInstallationDate As String
public const string StatisticInstallationDate
public:
literal String^ StatisticInstallationDate
public static final String StatisticInstallationDate
public const var StatisticInstallationDate : String

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.StatisticInterface Field

PosCommon.StatisticInterface Field |
 | See Also

1/18/2008

Holds the programmatic name of the Interface common statistic.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticInterface As String
public const string StatisticInterface
public:
literal String^ StatisticInterface
public static final String StatisticInterface
public const var StatisticInterface : String

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.StatisticManufactureDate Field

PosCommon.StatisticManufactureDate Field |
 | See Also

1/18/2008

Holds the programmatic name of the Manufacture Date common statistic.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticManufactureDate As String
public const string StatisticManufactureDate
public:
literal String^ StatisticManufactureDate
public static final String StatisticManufactureDate
public const var StatisticManufactureDate : String

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.StatisticManufacturerName Field

PosCommon.StatisticManufacturerName Field |
 | See Also

1/18/2008

Holds the programmatic name of the Manufacturer Name common statistic.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticManufacturerName As String
public const string StatisticManufacturerName
public:
literal String^ StatisticManufacturerName
public static final String StatisticManufacturerName
public const var StatisticManufacturerName : String

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.StatisticMechanicalRevision Field

PosCommon.StatisticMechanicalRevision Field |
 | See Also

1/18/2008

Holds the programmatic name of the Mechanical Revision common statistic.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticMechanicalRevision As String
public const string StatisticMechanicalRevision
public:
literal String^ StatisticMechanicalRevision
public static final String StatisticMechanicalRevision
public const var StatisticMechanicalRevision : String

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.StatisticModelName Field

PosCommon.StatisticModelName Field |
 | See Also

1/18/2008

Holds the programmatic name of the Model Name common statistic.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticModelName As String
public const string StatisticModelName
public:
literal String^ StatisticModelName
public static final String StatisticModelName
public const var StatisticModelName : String

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.StatisticSerialNumber Field

PosCommon.StatisticSerialNumber Field |
 | See Also

1/18/2008

Holds the programmatic name of the Serial Number common statistic.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticSerialNumber As String
public const string StatisticSerialNumber
public:
literal String^ StatisticSerialNumber
public static final String StatisticSerialNumber
public const var StatisticSerialNumber : String

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.StatisticUnifiedPOSVersion Field

PosCommon.StatisticUnifiedPOSVersion Field |
 | See Also

1/18/2008

Holds the programmatic name of the Unified POS Version common statistic.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticUnifiedPOSVersion As String
public const string StatisticUnifiedPOSVersion
public:
literal String^ StatisticUnifiedPOSVersion
public static final String StatisticUnifiedPOSVersion
public const var StatisticUnifiedPOSVersion : String

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.StatusPowerOff Field

PosCommon.StatusPowerOff Field |
 | See Also

1/18/2008

Indicates that the device’s power is turned off or it is detached from the terminal.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusPowerOff As Integer
public const int StatusPowerOff
public:
literal int StatusPowerOff
public static final int StatusPowerOff
public const var StatusPowerOff : int

Remarks

StatusPowerOff can only be used if the CapPowerReporting property is set to PowerReporting.Advanced.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
CapPowerReporting
StatusUpdateEvent
PowerReporting


PosCommon.StatusPowerOffline Field

PosCommon.StatusPowerOffline Field |
 | See Also

1/18/2008

Indicates that the device is powered on but is either not ready or unable to respond to requests.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusPowerOffline As Integer
public const int StatusPowerOffline
public:
literal int StatusPowerOffline
public static final int StatusPowerOffline
public const var StatusPowerOffline : int

Remarks

StatusPowerOffline can only be used if the CapPowerReporting property is set to PowerReporting.Advanced.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
CapPowerReporting
PowerReporting
StatusUpdateEvent


PosCommon.StatusPowerOffOffline Field

PosCommon.StatusPowerOffOffline Field |
 | See Also

1/18/2008

Indicates that either the device’s power is off or it is offline.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusPowerOffOffline As Integer
public const int StatusPowerOffOffline
public:
literal int StatusPowerOffOffline
public static final int StatusPowerOffOffline
public const var StatusPowerOffOffline : int

Remarks

StatusPowerOffOffline can only be used if the CapPowerReporting property is set to PowerReporting.Standard.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
CapPowerReporting
PowerReporting
StatusUpdateEvent


PosCommon.StatusPowerOnline Field

PosCommon.StatusPowerOnline Field |
 | See Also

1/18/2008

Indicates that the device’s power is turned on and it is ready for use.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusPowerOnline As Integer
public const int StatusPowerOnline
public:
literal int StatusPowerOnline
public static final int StatusPowerOnline
public const var StatusPowerOnline : int

Remarks

StatusPowerOnline can be used if the CapPowerReporting property is set to either PowerReporting.Standard or PowerReporting.Advanced.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
CapPowerReporting
PowerReporting
StatusUpdateEvent


PosCommon.StatusUpdateFirmwareComplete Field

PosCommon.StatusUpdateFirmwareComplete Field |
 | See Also

1/18/2008

Indicates the update firmware process has completed successfully.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusUpdateFirmwareComplete As Integer
public const int StatusUpdateFirmwareComplete
public:
literal int StatusUpdateFirmwareComplete
public static final int StatusUpdateFirmwareComplete
public const var StatusUpdateFirmwareComplete : int

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.StatusUpdateFirmwareCompleteDeviceNotRestored Field

PosCommon.StatusUpdateFirmwareCompleteDeviceNotRestored Field |
 | See Also

1/18/2008

Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusUpdateFirmwareCompleteDeviceNotRestored As Integer
public const int StatusUpdateFirmwareCompleteDeviceNotRestored
public:
literal int StatusUpdateFirmwareCompleteDeviceNotRestored
public static final int StatusUpdateFirmwareCompleteDeviceNotRestored
public const var StatusUpdateFirmwareCompleteDeviceNotRestored : int

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.StatusUpdateFirmwareFailedDeviceNeedsFirmware Field

PosCommon.StatusUpdateFirmwareFailedDeviceNeedsFirmware Field |
 | See Also

1/18/2008

Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusUpdateFirmwareFailedDeviceNeedsFirmware As Integer
public const int StatusUpdateFirmwareFailedDeviceNeedsFirmware
public:
literal int StatusUpdateFirmwareFailedDeviceNeedsFirmware
public static final int StatusUpdateFirmwareFailedDeviceNeedsFirmware
public const var StatusUpdateFirmwareFailedDeviceNeedsFirmware : int

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.StatusUpdateFirmwareFailedDeviceOk Field

PosCommon.StatusUpdateFirmwareFailedDeviceOk Field |
 | See Also

1/18/2008

Indicates the update firmware process failed. However, the device is still operational.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusUpdateFirmwareFailedDeviceOk As Integer
public const int StatusUpdateFirmwareFailedDeviceOk
public:
literal int StatusUpdateFirmwareFailedDeviceOk
public static final int StatusUpdateFirmwareFailedDeviceOk
public const var StatusUpdateFirmwareFailedDeviceOk : int

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.StatusUpdateFirmwareFailedDeviceUnknown Field

PosCommon.StatusUpdateFirmwareFailedDeviceUnknown Field |
 | See Also

1/18/2008

Indicates the update firmware process failed. The device is in an indeterminate state.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusUpdateFirmwareFailedDeviceUnknown As Integer
public const int StatusUpdateFirmwareFailedDeviceUnknown
public:
literal int StatusUpdateFirmwareFailedDeviceUnknown
public static final int StatusUpdateFirmwareFailedDeviceUnknown
public const var StatusUpdateFirmwareFailedDeviceUnknown : int

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.StatusUpdateFirmwareFailedDeviceUnrecoverable Field

PosCommon.StatusUpdateFirmwareFailedDeviceUnrecoverable Field |
 | See Also

1/18/2008

Indicates the update firmware process failed. The device is either unusable or unrecoverable through software.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusUpdateFirmwareFailedDeviceUnrecoverable As Integer
public const int StatusUpdateFirmwareFailedDeviceUnrecoverable
public:
literal int StatusUpdateFirmwareFailedDeviceUnrecoverable
public static final int StatusUpdateFirmwareFailedDeviceUnrecoverable
public const var StatusUpdateFirmwareFailedDeviceUnrecoverable : int

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.StatusUpdateFirmwareProgress Field

PosCommon.StatusUpdateFirmwareProgress Field |
 | See Also

1/18/2008

Indicates the update firmware process has completed 1 to 100 percent successfully.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusUpdateFirmwareProgress As Integer
public const int StatusUpdateFirmwareProgress
public:
literal int StatusUpdateFirmwareProgress
public static final int StatusUpdateFirmwareProgress
public const var StatusUpdateFirmwareProgress : int

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.WaitForever Field

PosCommon.WaitForever Field |
 | See Also

1/18/2008

Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const WaitForever As Integer
public const int WaitForever
public:
literal int WaitForever
public static final int WaitForever
public const var WaitForever : int

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon Constructor

PosCommon Constructor |
 | See Also

1/18/2008

Creates an instance of the PosCommon class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected PosCommon ()
protected:
PosCommon ()
protected PosCommon ()
protected function PosCommon ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon Methods

PosCommon Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | Tests the state of a device.
Claim | Requests exclusive access to the device.
Close | Releases the device and its resources.
CompareFirmwareVersion | Determines whether the version of the specified firmware is newer than, older than, or the same as the version of firmware in the physical device.
DirectIO | Used to communicate directly with the Service Object.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device.
ResetStatistic | Resets the specified statistic to 0 (zero).
ResetStatistics | Overloaded.
RetrieveStatistic | Retrieves the specified device statistic.
RetrieveStatistics | Overloaded.
ToString | (inherited from Object )
UpdateFirmware | Updates the firmware of a device with the version of the firmware contained or defined in the file specified by the firmwareFileName parameter regardless of whether that firmware’s version is newer than, older than, or the same as the version of the firmware already in the device.
UpdateStatistic | Updates the value of a specified device statistic.
UpdateStatistics | Overloaded.

Protected Methods

Name | Description
DeleteConfigurationProperty | Deletes the specified property from the XML configuration file.
Finalize | (inherited from Object )
GetConfigurationProperty | Used by the Service Object to retrieve the specified property from the XML configuration file.
Invoke | Used by the Service Objects to raise an event.
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | Sets a property value (or create a new property) in the XML configuration file.

See Also

Reference

PosCommon Class
Microsoft.PointOfService Namespace


PosCommon.CheckHealth Method

PosCommon.CheckHealth Method |
 | See Also

1/18/2008

Tests the state of a device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function CheckHealth ( _
    level As HealthCheckLevel _
) As String
public abstract string CheckHealth (
    HealthCheckLevel level
)
public:
virtual String^ CheckHealth (
    HealthCheckLevel level
) abstract
public abstract String CheckHealth (
    HealthCheckLevel level
)
public abstract function CheckHealth (
    level : HealthCheckLevel
) : String

Parameters

level

Indicates the type of health check to be performed on the device. Possible values are defined by the HealthCheckLevel enumeration.

Remarks

CheckHealth is always performed synchronously. The Service Object returns a string that indicates the health level and updates the CheckHealthText property.

CheckHealth may throw a PosControlException exception with the following ErrorCodes.

Value | Meaning
Illegal | The specified health check level is not supported by the Service Object.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
HealthCheckLevel Enumeration
CheckHealthText


PosCommon.Claim Method

PosCommon.Claim Method |
 | See Also

1/18/2008

Requests exclusive access to the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub Claim ( _
    timeout As Integer _
)
public abstract void Claim (
    int timeout
)
public:
virtual void Claim (
    int timeout
) abstract
public abstract void Claim (
    int timeout
)
public abstract function Claim (
    timeout : int
)

Parameters

timeout

Contains the maximum number of milliseconds to wait for exclusive access to be satisfied.

Remarks

Many devices require an application to claim them before they can be used.

If the timeout parameter indicates the maximum time in milliseconds that the Service Object should wait for exclusive access to be granted. If timeout is set to 0 (zero), the method tries to claim the device, and then returns the appropriate status immediately. If timeout is set to WaitForever (-1), Claim waits as long as needed for exclusive access to be satisfied.

An application can claim a device multiple times without generating an error. When the Claim method is successful, POS for .NET sets the Claimed property to true and loads the appropriate statistics counters and device information.

All base and basic class implementations of the Claim method use a system-wide name Mutex object to provide exclusive access to the device. The name of the Mutex object is derived from a combination of the DeviceName and DevicePath properties and device type.

Claim may throw a PosControlException exception with the following values:

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The device cannot currently be claimed for exclusive access;

  • A value of less than -1 has been specified for the timeout parameter.

Timeout

Another application has exclusive access to the device and did not relinquish control before timeout milliseconds expired.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
Release


PosCommon.Close Method

PosCommon.Close Method |
 | See Also

1/18/2008

Releases the device and its resources.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub Close
public abstract void Close ()
public:
virtual void Close () abstract
public abstract void Close ()
public abstract function Close ()

Remarks

POS for .NET releases the Service Object, shuts down statistics reporting, and stops all event threads.

If the DeviceEnabled property is set to true, then POS for .NET disables the device. If the Claimed property is set to true, then POS for .NET releases the device.

Close may throw a PosControlException exception with the following values:

Value | Meaning
Closed | The device is already closed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
Open


PosCommon.CompareFirmwareVersion Method

PosCommon.CompareFirmwareVersion Method |
 | See Also

1/18/2008

Determines whether the version of the specified firmware is newer than, older than, or the same as the version of firmware in the physical device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Function CompareFirmwareVersion ( _
    firmwareFileName As String _
) As CompareFirmwareResult
public virtual CompareFirmwareResult CompareFirmwareVersion (
    string firmwareFileName
)
public:
virtual CompareFirmwareResult CompareFirmwareVersion (
    String^ firmwareFileName
)
public CompareFirmwareResult CompareFirmwareVersion (
    String firmwareFileName
)
public function CompareFirmwareVersion (
    firmwareFileName : String
) : CompareFirmwareResult

Parameters

firmwareFileName

The name of the file that contains the firmware, or the name of a file that contains a list of firmware files.

Remarks

Before it tries to perform the comparison, the Service Object should verify that the specified firmware file exists and that its contents are valid for the device.

Note:
If the firmwareFileName parameter specifies a list of files, all those component firmware files should reside in the same directory as the firmware list file. This will allow for distribution of the updated firmware without requiring a modification to the firmware list file.

If it is successful, CompareFirmwareVersion returns one of the following values of the CompareFirmwareResult enumeration.

Member

Description

Different

Indicates that the version of one or more of the firmware files differs from the firmware in the device, but either:

  • The chronological relationship cannot be determined, or

  • The relationship is inconsistent, one or more are older while one or more are newer.

Newer

Indicates that the version of one or more of the firmware files is newer than the firmware in the device and that none of the firmware files is older than the firmware in the device.

Older

Indicates that the version of one or more of the firmware files is older than the firmware in the device and that none of the firmware files is newer than the firmware in the device.

Same

Indicates that the versions of all the firmware files are the same as the firmware in the device.

Unknown

Indicates that a relationship between the two firmware versions could not be determined. A possible reason for this result could be an attempt to compare Japanese and US versions of firmware.

CompareFirmwareVersion may throw a PosControlException exception with the following values:

Value | Meaning
Illegal | The CapCompareFirmwareVersion property is set to false, indicating the Service Object or device does not support firmware comparison.
NoExist | The file specified by firmwareFileName does not exist, or if firmwareFileName specifies a list of files, one or more of the component firmware files is missing.
ExtendedErrorFirmwareBadFile | ExtendedErrorFirmwareBadFile. Either the firmware file is in an incorrect format or is corrupted.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
CapCompareFirmwareVersion


PosCommon.DeleteConfigurationProperty Method

PosCommon.DeleteConfigurationProperty Method |
 | See Also

1/18/2008

Deletes the specified property from the XML configuration file.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub DeleteConfigurationProperty ( _
    propertyName As String _
)
protected void DeleteConfigurationProperty (
    string propertyName
)
protected:
void DeleteConfigurationProperty (
    String^ propertyName
)
protected void DeleteConfigurationProperty (
    String propertyName
)
protected function DeleteConfigurationProperty (
    propertyName : String
)

Parameters

propertyName

Contains the name of the property the Service Object wants to delete from the configuration XML file.

Remarks

The XML configuration file is stored at the following location:

Copy Code
HKEY_LOCAL_MACHINE\SOFTWARE\POSfor.NET\Configuration

DeleteConfigurationProperty may throw general exceptions and a PosControlException with the IllegalErrorcode if the specified property name is not valid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.DirectIO Method

PosCommon.DirectIO Method |
 | See Also

1/18/2008

Used to communicate directly with the Service Object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function DirectIO ( _
    command As Integer, _
    data As Integer, _
    obj As Object _
) As DirectIOData
public abstract DirectIOData DirectIO (
    int command,
    int data,
    Object obj
)
public:
virtual DirectIOData DirectIO (
    int command,
    int data,
    Object^ obj
) abstract
public abstract DirectIOData DirectIO (
    int command,
    int data,
    Object obj
)
public abstract function DirectIO (
    command : int,
    data : int,
    obj : Object
) : DirectIOData

Parameters

command

Command number. Specific values assigned by the Service Object.

data
obj

Remarks

Using the DirectIO method allows a Service Object to provide functionality to the application that is not otherwise supported by the standard Service Object for its device class. Depending on the Service Object’s definition of the command, the DirectIO method may be asynchronous or synchronous.

DirectIO returns an instance of the DirectIOData class.

Note:
Use of DirectIO will make an application non-portable. However, the application may maintain portability by performing DirectIO calls within conditional code. This code can be based on the value of the ServiceObjectDescription, ServiceObjectVersion, DeviceDescription, or DeviceName properties.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
DirectIOData Structure


PosCommon.GetConfigurationProperty Method

PosCommon.GetConfigurationProperty Method |
 | See Also

1/18/2008

Used by the Service Object to retrieve the specified property from the XML configuration file.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Function GetConfigurationProperty ( _
    propertyName As String _
) As String
protected string GetConfigurationProperty (
    string propertyName
)
protected:
String^ GetConfigurationProperty (
    String^ propertyName
)
protected String GetConfigurationProperty (
    String propertyName
)
protected function GetConfigurationProperty (
    propertyName : String
) : String

Parameters

propertyName

Contains the name of the property the Service Object wants to retrieve from the configuration XML file.

Remarks

The XML configuration file is stored at the following location:

Copy Code
HKEY_LOCAL_MACHINE\SOFTWARE\POSfor.NET\Configuration

GetConfigurationProperty may throw general exceptions and a PosControlException with an Illegal Errorcode if the specified property name is not valid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.Invoke Method

PosCommon.Invoke Method |
 | See Also

1/18/2008

Used by the Service Objects to raise an event.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Function Invoke ( _
    method As Delegate, _
    args As Object() _
) As Object
protected Object Invoke (
    Delegate method,
    Object[] args
)
protected:
Object^ Invoke (
    Delegate^ method,
    array<Object^>^ args
)
protected Object Invoke (
    Delegate method,
    Object[] args
)
protected function Invoke (
    method : Delegate,
    args : Object[]
) : Object

Parameters

method

Name of the event delegate.

args

Object array of the arguments taken by the delegate.

Remarks

Invoke uses the value of the SynchronizingObject property to marshal the event to the correct thread.

If SynchronizingObject is set to null, the event is raised on the calling thread.

Note:
Invoke is only used by Service Objects that do not derive from either the device’s basic or base class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.Open Method

PosCommon.Open Method |
 | See Also

1/18/2008

Opens a device for later input/output processing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub Open
public abstract void Open ()
public:
virtual void Open () abstract
public abstract void Open ()
public abstract function Open ()

Remarks

Open initializes statistics reporting and event threads for the specified device. Open also initializes the values of many properties. This includes the DataEventEnabled, FreezeEvents, AutoDisable, Claimed properties and more. For specifics about how these properties are initialized, see the individual properties.

Open may throw a PosControlException with the following values:

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The device is already opened; or

  • The DeviceName property is null or an empty string ("").

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
PosCommon.Close Method


PosCommon.Release Method

PosCommon.Release Method |
 | See Also

1/18/2008

Releases exclusive access to the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub Release
public abstract void Release ()
public:
virtual void Release () abstract
public abstract void Release ()
public abstract function Release ()

Remarks

If the DeviceEnabled property is set to true, and the device is an exclusive-use device, then POS for .NET first disables the device. (Release does not change the device-enabled state of shareable devices.) If Release is successful, it sets the Claimed property to false.

Release may throw a PosControlException with the following values:

Value | Meaning
Illegal | The device is not claimed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
PosCommon.Claim Method


PosCommon.ResetStatistic Method

PosCommon.ResetStatistic Method |
 | See Also

1/18/2008

Resets the specified statistic to 0 (zero).

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ResetStatistic ( _
    statistic As String _
)
public abstract void ResetStatistic (
    string statistic
)
public:
virtual void ResetStatistic (
    String^ statistic
) abstract
public abstract void ResetStatistic (
    String statistic
)
public abstract function ResetStatistic (
    statistic : String
)

Parameters

statistic

Specifies the statistic that is to be reset.

Remarks

For ResetStatistic to be successful, both the CapStatisticsReporting and CapUpdateStatistics properties must be set to true.

ResetStatistic is always executed synchronously.

ResetStatistic may throw a PosControlException with the following values:

Value

Meaning

Illegal

One of the following conditions has occurred:

  • Either the CapStatisticsReporting or CapUpdateStatistics property is set to false;

  • The statistic parameter is null or does not exist; or

  • The specified statistic is not resettable.

Extended

ExtendedErrorStatistics. An error occurred while it tried to reset the specified statistic.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
CapStatisticsReporting
CapUpdateStatistics


PosCommon.ResetStatistics Method

PosCommon.ResetStatistics Method |
 | See Also

1/18/2008

Overload List

Name | Description
PosCommon.ResetStatistics () | Resets all statistics associated with a device to 0 (zero).
PosCommon.ResetStatistics (StatisticCategories) | Resets all statistics for a specified category to 0 (zero).
PosCommon.ResetStatistics (String[]) | Resets the specified statistics to 0 (zero).

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
CapStatisticsReporting
CapUpdateStatistics


PosCommon.ResetStatistics Method ()

PosCommon.ResetStatistics Method () |
 | See Also

1/18/2008

Resets all statistics associated with a device to 0 (zero).

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ResetStatistics
public abstract void ResetStatistics ()
public:
virtual void ResetStatistics () abstract
public abstract void ResetStatistics ()
public abstract function ResetStatistics ()

Remarks

For ResetStatistics to be successful, both the CapStatisticsReporting and CapUpdateStatistics properties must be set to true.

ResetStatistic is always executed synchronously.

ResetStatistics may throw a PosControlException with the following values:

Value | Meaning
Illegal | The CapStatisticsReporting or CapUpdateStatistics property is set to false.
Extended | ExtendedErrorStatistics. At least one of the specified statistics could not be reset.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
CapStatisticsReporting
CapUpdateStatistics


PosCommon.ResetStatistics Method (StatisticCategories)

PosCommon.ResetStatistics Method (StatisticCategories) |
 | See Also

1/18/2008

Resets all statistics for a specified category to 0 (zero).

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ResetStatistics ( _
    statistics As StatisticCategories _
)
public abstract void ResetStatistics (
    StatisticCategories statistics
)
public:
virtual void ResetStatistics (
    StatisticCategories statistics
) abstract
public abstract void ResetStatistics (
    StatisticCategories statistics
)
public abstract function ResetStatistics (
    statistics : StatisticCategories
)

Parameters

statistics

Contains the category of statistics the application wishes to reset for the device. Possible categories are defined by the StatisticsCategories enumeration.

Remarks

For ResetStatistics to be successful, both the CapStatisticsReporting and CapUpdateStatistics properties must be set to true.

ResetStatistic is always executed synchronously.

ResetStatistics may throw a PosControlException with the following values:

Value | Meaning
Illegal | One of the following conditions has occurred:The CapStatisticsReporting or CapUpdateStatistics property is set to false; orThe specified statistics category is not valid.
Extended | ExtendedErrorStatistics. At least one of the specified statistics could not be reset.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
CapStatisticsReporting
CapUpdateStatistics


PosCommon.ResetStatistics Method (String[])

PosCommon.ResetStatistics Method (String[]) |
 | See Also

1/18/2008

Resets the specified statistics to 0 (zero).

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ResetStatistics ( _
    statistics As String() _
)
public abstract void ResetStatistics (
    string[] statistics
)
public:
virtual void ResetStatistics (
    array<String^>^ statistics
) abstract
public abstract void ResetStatistics (
    String[] statistics
)
public abstract function ResetStatistics (
    statistics : String[]
)

Parameters

statistics

Contains an array of statistic names to be reset.

Remarks

For ResetStatistics to be successful, both the CapStatisticsReporting and CapUpdateStatistics properties must be set to true.

ResetStatistic is always executed synchronously.

ResetStatistics may throw a PosControlException with the following values:

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The CapStatisticsReporting or CapUpdateStatistics property is set to false; or

  • One of the specified statistics is not defined.

Extended

ExtendedErrorStatistics. At least one of the specified statistics could not be reset.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
CapStatisticsReporting
CapUpdateStatistics


PosCommon.RetrieveStatistic Method

PosCommon.RetrieveStatistic Method |
 | See Also

1/18/2008

Retrieves the specified device statistic.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function RetrieveStatistic ( _
    statistic As String _
) As String
public abstract string RetrieveStatistic (
    string statistic
)
public:
virtual String^ RetrieveStatistic (
    String^ statistic
) abstract
public abstract String RetrieveStatistic (
    String statistic
)
public abstract function RetrieveStatistic (
    statistic : String
) : String

Parameters

statistic

Remarks

RetrieveStatistic is always executed synchronously.

RetrieveStatistic returns the requested statistic if it is successful. It may throw a PosControlException with the following values:

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The CapStatisticsReporting property is set to false. This indicates that the device does not support statistics reporting;

  • The statistic parameter is null or has a length of 0 (zero); or

  • The specified statistic does not exist.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
CapStatisticsReporting


PosCommon.RetrieveStatistics Method

PosCommon.RetrieveStatistics Method |
 | See Also

1/18/2008

Overload List

Name | Description
PosCommon.RetrieveStatistics () | Retrieves all device statistics.
PosCommon.RetrieveStatistics (StatisticCategories) | Retrieves the statistics for the specified category.
PosCommon.RetrieveStatistics (String[]) | Retrieves the specified statistics.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
CapStatisticsReporting


PosCommon.RetrieveStatistics Method ()

PosCommon.RetrieveStatistics Method () |
 | See Also

1/18/2008

Retrieves all device statistics.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function RetrieveStatistics As String
public abstract string RetrieveStatistics ()
public:
virtual String^ RetrieveStatistics () abstract
public abstract String RetrieveStatistics ()
public abstract function RetrieveStatistics () : String

Remarks

RetrieveStatistics is always executed synchronously.

RetrieveStatistics returns the requested statistics if it is successful. It may throw a PosControlException with the following values:

Value | Meaning
Illegal | The CapStatisticsReporting property is set to false. This indicates that the device does not support statistics reporting.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
CapStatisticsReporting


PosCommon.RetrieveStatistics Method (StatisticCategories)

PosCommon.RetrieveStatistics Method (StatisticCategories) |
 | See Also

1/18/2008

Retrieves the statistics for the specified category.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function RetrieveStatistics ( _
    statistics As StatisticCategories _
) As String
public abstract string RetrieveStatistics (
    StatisticCategories statistics
)
public:
virtual String^ RetrieveStatistics (
    StatisticCategories statistics
) abstract
public abstract String RetrieveStatistics (
    StatisticCategories statistics
)
public abstract function RetrieveStatistics (
    statistics : StatisticCategories
) : String

Parameters

statistics

Remarks

RetrieveStatistics is always executed synchronously.

RetrieveStatistics returns a string of statistics if it is successful. It may throw a PosControlException with the following values:

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The CapStatisticsReporting property is set to false. This indicates that the device does not support statistics reporting;

  • The statistics parameter is null or has a length of 0 (zero); or

  • The specified statistics category is invalid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
CapStatisticsReporting


PosCommon.RetrieveStatistics Method (String[])

PosCommon.RetrieveStatistics Method (String[]) |
 | See Also

1/18/2008

Retrieves the specified statistics.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function RetrieveStatistics ( _
    statistics As String() _
) As String
public abstract string RetrieveStatistics (
    string[] statistics
)
public:
virtual String^ RetrieveStatistics (
    array<String^>^ statistics
) abstract
public abstract String RetrieveStatistics (
    String[] statistics
)
public abstract function RetrieveStatistics (
    statistics : String[]
) : String

Parameters

statistics

Remarks

RetrieveStatistics is always executed synchronously.

RetrieveStatistics returns a string of statistics if it is successful. It may throw a PosControlException exception with the following values:

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The CapStatisticsReporting property is set to false. This indicates that the device does not support statistics reporting;

  • The statistics parameter is null or has a length of 0 (zero); or

  • One or more of the specified statistics do not exist.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
CapStatisticsReporting


PosCommon.SetConfigurationProperty Method

PosCommon.SetConfigurationProperty Method |
 | See Also

1/18/2008

Sets a property value (or create a new property) in the XML configuration file.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub SetConfigurationProperty ( _
    propertyName As String, _
    data As String _
)
protected void SetConfigurationProperty (
    string propertyName,
    string data
)
protected:
void SetConfigurationProperty (
    String^ propertyName,
    String^ data
)
protected void SetConfigurationProperty (
    String propertyName,
    String data
)
protected function SetConfigurationProperty (
    propertyName : String,
    data : String
)

Parameters

propertyName

Contains the name of the property the Service Object wants to set in the configuration XML file.

data

Remarks

Used by the Service Object to set a property value (or create a new property) in the XML configuration file.

The XML configuration file is stored at the following location:

Copy Code
HKEY_LOCAL_MACHINE\SOFTWARE\POSfor.NET\Configuration

SetConfigurationProperty may throw general exceptions and a PosControlException exception with an Illegal Errorcode if the specified property name is not valid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.UpdateFirmware Method

PosCommon.UpdateFirmware Method |
 | See Also

1/18/2008

Updates the firmware of a device with the version of the firmware contained or defined in the file specified by the firmwareFileName parameter regardless of whether that firmware’s version is newer than, older than, or the same as the version of the firmware already in the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Sub UpdateFirmware ( _
    firmwareFileName As String _
)
public virtual void UpdateFirmware (
    string firmwareFileName
)
public:
virtual void UpdateFirmware (
    String^ firmwareFileName
)
public void UpdateFirmware (
    String firmwareFileName
)
public function UpdateFirmware (
    firmwareFileName : String
)

Parameters

firmwareFileName

Specifies either the name of the file that contains the firmware or a file that contains a set of firmware files that are to be downloaded into the device.

Remarks

When UpdateFirmware is invoked, the Service Object should check that the specified firmware file exists and that its contents are valid for this device. If so, this method should return immediately and the rest of the update firmware process should continue asynchronously.

The Service Object should notify applying the status of the update firmware process by raising StatusUpdateEvents events with values of StatusUpdateFirmwareProgress + an integer between 1 and 100 that indicates the completion percentage of the update firmware process. For application convenience, the StatusUpdateEvent event value StatusUpdateFirmwareComplete is defined to be the same value as StatusUpdateFirmwareProgress + 100.

For consistency, the update firmware process is complete after the new firmware has been downloaded into the physical device, any necessary physical device reset has finished, and the Service Object and the physical device have been returned to the state they were in before the update firmware process began.

For consistency, a Service Object must always raise at least one StatusUpdateEvent with an incomplete progress completion percentage (that is, a percentage between 1 and 99), even if the device cannot physically report the progress of the update firmware process. If the update firmware process is completed successfully, the Service Object must raise a StatusUpdateEvent event with a progress of 100 or use the special constant StatusUpdateFirmwareComplete, which has the same value. These Service requirements allow applications that use this method to be designed to always expect some level of progress notification.

If an error is detected during the asynchronous part of an update firmware process, one of the following StatusUpdateEvent events is raised.

Value | Meaning
StatusUpdateFirmwareFailedDeviceOK | The update firmware process failed but the device is still operational.
StatusUpdateFirmwareFailedDeviceUnrecoverable | The update firmware process failed and the device is neither usable nor recoverable through software. The device requires service to be returned to an operational state.
StatusUpdateFirmwareFailedDeviceNeedsFirmware | The update firmware process failed and the device will not be operational until another try to update the firmware is successful.
StatusUpdateFirmwareFailedDeviceUnknown | The update firmware process failed and the device is in an indeterminate state.

UpdateFirmware may throw a PosControlException with the following values:

Value | Meaning
Illegal | The CapUpdateFirmware property is set to false.
NoExist | The file specified by firmwareFileName does not exist or, if firmwareFileName specifies a file list, one or more of the component firmware files are missing.
ExtendedErrorFirmwareBadFile | The specified firmware file or files exist, but one or more are either not in the correct format or are corrupted.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
CapUpdateFirmware


PosCommon.UpdateStatistic Method

PosCommon.UpdateStatistic Method |
 | See Also

1/18/2008

Updates the value of a specified device statistic.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub UpdateStatistic ( _
    name As String, _
    value As Object _
)
public abstract void UpdateStatistic (
    string name,
    Object value
)
public:
virtual void UpdateStatistic (
    String^ name,
    Object^ value
) abstract
public abstract void UpdateStatistic (
    String name,
    Object value
)
public abstract function UpdateStatistic (
    name : String,
    value : Object
)

Parameters

name
value

Remarks

For UpdateStatistic to be successful, both the CapStatisticsReporting and CapUpdateStatistics properties must be set to true.

UpdateStatistic is always executed synchronously.

UpdateStatistic may throw a PosControlException with the following values:

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The CapStatisticsReporting or CapUpdateStatistics property is set to false;

  • The statistic parameter is null; or

  • The specified statistic does not exist; or

  • The specified statistic is not updatable.

Extended

ExtendedErrorStatistics. An error occurred while it tried to update the specified statistic.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
CapStatisticsReporting
CapUpdateStatistics


PosCommon.UpdateStatistics Method

PosCommon.UpdateStatistics Method |
 | See Also

1/18/2008

Overload List

Name | Description
PosCommon.UpdateStatistics (Statistic[]) | Updates a list of statistics with the corresponding specified values.
PosCommon.UpdateStatistics (StatisticCategories, Object) | Updates the specified category of statistics with the specified value.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
CapStatisticsReporting
CapUpdateStatistics


PosCommon.UpdateStatistics Method (Statistic[])

PosCommon.UpdateStatistics Method (Statistic[]) |
 | See Also

1/18/2008

Updates a list of statistics with the corresponding specified values.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub UpdateStatistics ( _
    statistics As Statistic() _
)
public abstract void UpdateStatistics (
    Statistic[] statistics
)
public:
virtual void UpdateStatistics (
    array<Statistic^>^ statistics
) abstract
public abstract void UpdateStatistics (
    Statistic[] statistics
)
public abstract function UpdateStatistics (
    statistics : Statistic[]
)

Parameters

statistics

Contains an array of Statistic class instances (name-value pairs) that contain the names and values of the statistics to be updated.

Remarks

For UpdateStatistics to be successful, both the CapStatisticsReporting and CapUpdateStatistics properties must be set to true.

UpdateStatistics is always executed synchronously.

UpdateStatistics may throw a PosControlException with the following values:

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The CapStatisticsReporting or CapUpdateStatistics property is set to false;

  • The statistics parameter is null; or

  • One or more of the specified statistics does not exist.

Extended

ExtendedErrorStatistics. At least one of the specified statistics could not be updated.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
CapStatisticsReporting
CapUpdateStatistics


PosCommon.UpdateStatistics Method (StatisticCategories, Object)

PosCommon.UpdateStatistics Method (StatisticCategories, Object) |
 | See Also

1/18/2008

Updates the specified category of statistics with the specified value.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub UpdateStatistics ( _
    statistics As StatisticCategories, _
    value As Object _
)
public abstract void UpdateStatistics (
    StatisticCategories statistics,
    Object value
)
public:
virtual void UpdateStatistics (
    StatisticCategories statistics,
    Object^ value
) abstract
public abstract void UpdateStatistics (
    StatisticCategories statistics,
    Object value
)
public abstract function UpdateStatistics (
    statistics : StatisticCategories,
    value : Object
)

Parameters

statistics

Contains the category of statistics the application wishes to update. Possible categories are defined by the StatisticsCategories enumeration.

value

Remarks

For UpdateStatistics to be successful, both the CapStatisticsReporting and CapUpdateStatistics properties must be set to true.

UpdateStatistics is always executed synchronously.

UpdateStatistics may throw a PosControlException with the following values:

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The CapStatisticsReporting or CapUpdateStatistics property is set to false; or

  • The specified statistics category is invalid.

Extended

ExtendedErrorStatistics. At least one of the specified statistics could not be updated.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
CapStatisticsReporting
CapUpdateStatistics


PosCommon Properties

PosCommon Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file.
CapPowerReporting | Gets the power reporting capabilities of the device.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method.
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods.
CheckHealthText | Gets a string that indicates the health of the device.
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access.
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
DeviceDescription | Gets a string identifying the device and the company that manufactured it.
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state.
DeviceName | Gets a short string identifying the device and any pertinent information about it.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events.
PowerNotify | Gets or sets the type of power notification selection made by the application.
PowerState | Gets the current power condition.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it.
ServiceObjectVersion | Gets the Service Object version number.
State | Gets the current state of the device.
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event.

Protected Properties

Name | Description
DeviceInstanceId |
DevicePath | Gets or sets the hardware path of a device.
HardwareId |
IsExclusiveUseDevice | Gets a Boolean value that indicates whether the device is an exclusive-use device.

See Also

Reference

PosCommon Class
Microsoft.PointOfService Namespace


PosCommon.CapCompareFirmwareVersion Property

PosCommon.CapCompareFirmwareVersion Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CapCompareFirmwareVersion As Boolean
public virtual bool CapCompareFirmwareVersion { get; }
public:
virtual property bool CapCompareFirmwareVersion {
    bool get ();
}
/** @property */
public boolean get_CapCompareFirmwareVersion ()

public function get CapCompareFirmwareVersion () : boolean

Remarks

CapCompareFirmwareVersion is set by the Service Object.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
CompareFirmwareVersion


PosCommon.CapPowerReporting Property

PosCommon.CapPowerReporting Property |
 | See Also

1/18/2008

Gets the power reporting capabilities of the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapPowerReporting As PowerReporting
public abstract PowerReporting CapPowerReporting { get; }
public:
virtual property PowerReporting CapPowerReporting {
    PowerReporting get () abstract;
}
/** @property */
public abstract PowerReporting get_CapPowerReporting ()

public abstract function get CapPowerReporting () : PowerReporting

Remarks

Possible values are defined by the PowerReporting enumeration.

PowerReporting is initialized to PowerReporting.None. The Service Object should then set PowerReporting based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
PowerState
PowerNotify


PosCommon.CapStatisticsReporting Property

PosCommon.CapStatisticsReporting Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapStatisticsReporting As Boolean
public abstract bool CapStatisticsReporting { get; }
public:
virtual property bool CapStatisticsReporting {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapStatisticsReporting ()

public abstract function get CapStatisticsReporting () : boolean

Remarks

The information accumulated is device-specific, and can be retrieved by using the RetrieveStatistic or RetrieveStatistics method.

When statistics are created for a specific device, POS for .NET sets the CapStatisticsReporting property to true (for that device).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
PosCommon.RetrieveStatistics Method


PosCommon.CapUpdateFirmware Property

PosCommon.CapUpdateFirmware Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CapUpdateFirmware As Boolean
public virtual bool CapUpdateFirmware { get; }
public:
virtual property bool CapUpdateFirmware {
    bool get ();
}
/** @property */
public boolean get_CapUpdateFirmware ()

public function get CapUpdateFirmware () : boolean

Remarks

CapUpdateFirmware is set by the Service Object.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
UpdateFirmware


PosCommon.CapUpdateStatistics Property

PosCommon.CapUpdateStatistics Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapUpdateStatistics As Boolean
public abstract bool CapUpdateStatistics { get; }
public:
virtual property bool CapUpdateStatistics {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapUpdateStatistics ()

public abstract function get CapUpdateStatistics () : boolean

Remarks

If set to true, some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. If the CapStatisticsReporting property is set to false, CapUpdateStatistics is always be false. The device must be opened before this property can be read.

The CapUpdateStatistics property is initialized to false. When statistics are created for a specific device, and if those statistics can be reset or updated, then POS for .NET sets the CapUpdateStatistics property to true (for that device).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
PosCommon.CapStatisticsReporting Property
PosCommon.UpdateStatistics Method


PosCommon.CheckHealthText Property

PosCommon.CheckHealthText Property |
 | See Also

1/18/2008

Gets a string that indicates the health of the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CheckHealthText As String
public abstract string CheckHealthText { get; }
public:
virtual property String^ CheckHealthText {
    String^ get () abstract;
}
/** @property */
public abstract String get_CheckHealthText ()

public abstract function get CheckHealthText () : String

Remarks

Updated by the Service Object when the application calls the CheckHealth method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
PosCommon.CheckHealth Method


PosCommon.Claimed Property

PosCommon.Claimed Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device is claimed for exclusive access.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property Claimed As Boolean
public abstract bool Claimed { get; }
public:
virtual property bool Claimed {
    bool get () abstract;
}
/** @property */
public abstract boolean get_Claimed ()

public abstract function get Claimed () : boolean

Remarks

If true, the device is claimed for exclusive access. If false, the device is released for sharing with other applications.

Exclusive-use devices must be claimed by using the Claim method before the Service Object allows access to many of its methods and properties, and before the Service Object raises events to the application.

Claimed is initialized to false. State verification occurs in the basic and base classes for each device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
PosCommon.Claim Method
PosCommon.Release Method


PosCommon.DeviceDescription Property

PosCommon.DeviceDescription Property |
 | See Also

1/18/2008

Gets a string identifying the device and the company that manufactured it.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DeviceDescription As String
public abstract string DeviceDescription { get; }
public:
virtual property String^ DeviceDescription {
    String^ get () abstract;
}
/** @property */
public abstract String get_DeviceDescription ()

public abstract function get DeviceDescription () : String

Remarks

DeviceDescription is initialized to blank. State verification occurs in the basic and base classes for each device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
DeviceName


PosCommon.DeviceEnabled Property

PosCommon.DeviceEnabled Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether the device has been placed in an operational state.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property DeviceEnabled As Boolean
public abstract bool DeviceEnabled { get; set; }
public:
virtual property bool DeviceEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_DeviceEnabled ()

/** @property */
public abstract void set_DeviceEnabled (boolean value)

public abstract function get DeviceEnabled () : boolean

public abstract function set DeviceEnabled (value : boolean)

Remarks

When true, the device has been put in an operational state. If changed to true, then the device is brought to an operational state. The appropriate device statistics and device information will be loaded, if it is necessary. Exclusive-use devices must be opened and claimed before this property can be accessed. Shared devices must be opened before this property can be accessed.

When false, the device has been disabled. If changed to false, then the device is physically disabled when it is possible. Any later input is discarded, and output operations are disallowed.

Changing DeviceEnabled usually does not physically affect output devices. However, for consistency, the application must set DeviceEnabled to true before it uses output devices.

DeviceEnabled is initialized to false. State verification occurs in the basic and base classes for each device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.DeviceInstanceId Property

PosCommon.DeviceInstanceId Property |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected ReadOnly Property DeviceInstanceId As String

protected string DeviceInstanceId { get; }

protected:
property String^ DeviceInstanceId {
    String^ get ();
}

/** @property */
protected String get_DeviceInstanceId ()

protected function get DeviceInstanceId () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.DeviceName Property

PosCommon.DeviceName Property |
 | See Also

1/18/2008

Gets a short string identifying the device and any pertinent information about it.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DeviceName As String
public abstract string DeviceName { get; }
public:
virtual property String^ DeviceName {
    String^ get () abstract;
}
/** @property */
public abstract String get_DeviceName ()

public abstract function get DeviceName () : String

Remarks

This is a short version of DeviceDescription and should be limited to 30 characters.

DeviceName is typically used to identify the device in an application message box, where the full description is too verbose.

DeviceName is initialized to blank. State verification occurs in the basic and base classes for each device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
PosCommon.DeviceDescription Property


PosCommon.DevicePath Property

PosCommon.DevicePath Property |
 | See Also

1/18/2008

Gets or sets the hardware path of a device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Property DevicePath As String
protected string DevicePath { get; set; }
protected:
property String^ DevicePath {
    String^ get ();
    void set (String^ value);
}
/** @property */
protected String get_DevicePath ()

/** @property */
protected void set_DevicePath (String value)

protected function get DevicePath () : String

protected function set DevicePath (value : String)

Remarks

The PosExplorer class tries to initialize the DevicePath property to the hardware path of the physical device by using the following algorithm:

  1. If the physical hardware supports Plug and Play and the Service Object is mapped to a specific hardware ID through the HardwareId custom attribute or a configuration XML file, the PosExplorer class sets the DevicePath property to the HardwarePath property of the physical device. Service Objects can typically use this DevicePath property to directly access the device.

  2. If the device does not support Plug and Play, but has been configured through Posdm.exe or WMI, the DevicePath property will be set to the path that is specified when the device was configured.

  3. If the device does not support Plug and Play and has not been configured through Posdm.exe or WMI, the DevicePath property will be set to empty string ("") and must be set by the Service Object before the Open method in the base/basic class can be called.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
PosCommon.DeviceDescription Property
PosCommon.DeviceName Property


PosCommon.FreezeEvents Property

PosCommon.FreezeEvents Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property FreezeEvents As Boolean
public abstract bool FreezeEvents { get; set; }
public:
virtual property bool FreezeEvents {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_FreezeEvents ()

/** @property */
public abstract void set_FreezeEvents (boolean value)

public abstract function get FreezeEvents () : boolean

public abstract function set FreezeEvents (value : boolean)

Remarks

When set to true, the application has requested that the Service Object not deliver events. Events will be queued by the Service Object but not delivered until the application changes the FreezeEvents property to false. Exclusive-use devices must be opened and claimed before this property can be accessed. Shared devices must be opened before this property can be accessed.

When set to false, the application allows events to be delivered. If some events have been held while events were frozen and all other conditions are correct for delivering the events, changing the FreezeEvents property to false allows these events to be delivered.

An application can choose to freeze events for a specific sequence of code where interruption by an event is not desirable.

The FreezeEvents property is initialized to false. State verification occurs in the basic and base classes for each device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.HardwareId Property

PosCommon.HardwareId Property |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected ReadOnly Property HardwareId As String

protected string HardwareId { get; }

protected:
property String^ HardwareId {
    String^ get ();
}

/** @property */
protected String get_HardwareId ()

protected function get HardwareId () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.IsExclusiveUseDevice Property

PosCommon.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected MustOverride ReadOnly Property IsExclusiveUseDevice As Boolean
protected abstract bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () abstract;
}
/** @property */
protected abstract boolean get_IsExclusiveUseDevice ()

protected abstract function get IsExclusiveUseDevice () : boolean

Remarks

Indicates whether the device is an exclusive-use device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.PowerNotify Property

PosCommon.PowerNotify Property |
 | See Also

1/18/2008

Gets or sets the type of power notification selection made by the application.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property PowerNotify As PowerNotification
public abstract PowerNotification PowerNotify { get; set; }
public:
virtual property PowerNotification PowerNotify {
    PowerNotification get () abstract;
    void set (PowerNotification value) abstract;
}
/** @property */
public abstract PowerNotification get_PowerNotify ()

/** @property */
public abstract void set_PowerNotify (PowerNotification value)

public abstract function get PowerNotify () : PowerNotification

public abstract function set PowerNotify (value : PowerNotification)

Remarks

Possible values are defined by the PowerNotification enumeration.

The PowerNotify method can only be set while the device is disabled, that is, while the DeviceEnabled property is set to false.

The PowerNotify method is initialized to PowerNotification.Disabled. State verification occurs in the basic and base classes for each device.

Setting the PowerNotify method may throw a PosControlException with the following values:

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The device is not opened; or

  • DeviceEnabled is set to true; or

  • PowerNotify was set to an illegal value; or

  • PowerNotify = PowerNotification.Enabled but CapPowerReporting = PowerReporting.None. This indicates that the device does not support power notification.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
PosCommon.CapPowerReporting Property
PowerState


PosCommon.PowerState Property

PosCommon.PowerState Property |
 | See Also

1/18/2008

Gets the current power condition.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property PowerState As PowerState
public abstract PowerState PowerState { get; }
public:
virtual property PowerState PowerState {
    PowerState get () abstract;
}
/** @property */
public abstract PowerState get_PowerState ()

public abstract function get PowerState () : PowerState

Remarks

Possible values are defined by the PowerState enumeration.

The following table shows the valid power reporting values.

Value

Meaning

Unknown

Cannot determine the device's power state, for one of the following reasons:

  • CapPowerReporting = PowerReporting.None. The device does not support power reporting.

  • PowerNotify = PowerNotification.Disabled. Power notifications are disabled.

  • DeviceEnabled = false. Power state monitoring does not occur until the device is enabled. Under these conditions, POS for .NET returns a value of PowerState.Unknown for PowerState.

Online

The device is powered on and ready for use.Can be returned if CapPowerReporting = PowerReporting.Standard or PowerReporting.Advanced.

Off

The device is off or detached from the terminal.Can be returned only if CapPowerReporting = PowerReporting.Advanced.

Offline

The device is powered on but is either not ready or unable to respond to requests.Can be returned only if CapPowerReporting = PowerReporting.Advanced.

OffOffline

The device is either off or offline.Can be returned only if CapPowerReporting = PowerReporting.Standard.

PowerState is initialized to PowerState.Unknown. When PowerNotify is set to Enabled and DeviceEnabled is true, the Service Object must update PowerState as the Service Object detects power-condition changes. When PowerState is changed and PowerNotify is PowerNotification.Enabled, POS for .NET queues a StatusUpdateEvent event, notifying the application.

Note:
The .NET Framework version 2.0 has an enumeration (System.Windows.Forms.PowerState) that conflicts with PowerState. To avoid compile-time errors, use the fully qualified name (that is, Microsoft.PointOfService.PowerState).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
PosCommon.CapPowerReporting Property
PosCommon.PowerNotify Property


PosCommon.ServiceObjectDescription Property

PosCommon.ServiceObjectDescription Property |
 | See Also

1/18/2008

Gets a string identifying the Service Object that supports the device and the company that produced it.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ServiceObjectDescription As String
public abstract string ServiceObjectDescription { get; }
public:
virtual property String^ ServiceObjectDescription {
    String^ get () abstract;
}
/** @property */
public abstract String get_ServiceObjectDescription ()

public abstract function get ServiceObjectDescription () : String

Remarks

The ServiceObjectDescription method is initialized to blank. State verification occurs in the basic and base classes for each device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.ServiceObjectVersion Property

PosCommon.ServiceObjectVersion Property |
 | See Also

1/18/2008

Gets the Service Object version number.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property ServiceObjectVersion As Version
public virtual Version ServiceObjectVersion { get; }
public:
virtual property Version^ ServiceObjectVersion {
    Version^ get ();
}
/** @property */
public Version get_ServiceObjectVersion ()

public function get ServiceObjectVersion () : Version

Remarks

Version numbers consist of two to four integers, Major, Minor, Build, and Revision. Build and Revision are optional, but Revision is optional only if Build is not specified. The Major and Minor version numbers should be set to the UPOS version that the Service Object implements. Build and Revision can be set to the internal version of the Service Object and should be incremented when corrections are made to the implementation. For information about the structures and methods of the Version class, see the "Version Class" of the .NET Framework Class Library.

ServiceObjectVersion is initialized by the Open method. State verification occurs in the basic and base classes for each device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.State Property

PosCommon.State Property |
 | See Also

1/18/2008

Gets the current state of the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property State As ControlState
public abstract ControlState State { get; }
public:
virtual property ControlState State {
    ControlState get () abstract;
}
/** @property */
public abstract ControlState get_State ()

public abstract function get State () : ControlState

Remarks

Possible values are defined by the ControlState enumeration.

State is set to ControlState.Idle by the Open method and is always readable, regardless of the state of the device. Changes in State cause POS for .NET to queue a StateChangedEvent event.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.SynchronizingObject Property

PosCommon.SynchronizingObject Property |
 | See Also

1/18/2008

Gets or sets the object that is used to marshal the event handler calls issued because of a POS event.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Property SynchronizingObject As ISynchronizeInvoke
public ISynchronizeInvoke SynchronizingObject { get; set; }
public:
property ISynchronizeInvoke^ SynchronizingObject {
    ISynchronizeInvoke^ get ();
    void set (ISynchronizeInvoke^ value);
}
/** @property */
public ISynchronizeInvoke get_SynchronizingObject ()

/** @property */
public void set_SynchronizingObject (ISynchronizeInvoke value)

public function get SynchronizingObject () : ISynchronizeInvoke

public function set SynchronizingObject (value : ISynchronizeInvoke)

Remarks

Holds an object that implements the .NET Framework class ISynchronoizeInvoke that is used to marshal events to a particular thread. If SynchronizingObject is set to null, events are raised on a system thread owned by the Service Object.

When the POS events are handled by a visual Windows Forms component, such as a Button, accessing the component through the Service Object thread might not work, or may result in an exception. Avoid this by setting SynchronizingObject to a Windows Forms component. This causes the methods that handle the POS events to be called on the same thread on which the component was created.

The PosExplorer class initializes the SynchronizingObject method to the value of its SynchronizingObject property. This allows applications to set the SynchronizingObject property on the PosExplorer class and make sure that all Service Objects that are created by that instance of PosExplorer deliver events on the same thread.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
.NET Framework IsynchronizeInvoke
PosExplorer


PosCommon Events

PosCommon Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change.

Protected Events

Name | Description
DeviceAddedEvent |
DeviceRemovedEvent |

See Also

Reference

PosCommon Class
Microsoft.PointOfService Namespace


PosCommon.DeviceAddedEvent Event

PosCommon.DeviceAddedEvent Event |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Event DeviceAddedEvent As EventHandler(Of DeviceChangedEventArgs)

protected event EventHandler<DeviceChangedEventArgs> DeviceAddedEvent

protected:
event EventHandler<DeviceChangedEventArgs^>^ DeviceAddedEvent {
    void add (EventHandler<DeviceChangedEventArgs^>^ value);
    void remove (EventHandler<DeviceChangedEventArgs^>^ value);
}

/** @event */
protected void add_DeviceAddedEvent (EventHandler<DeviceChangedEventArgs> value)

/** @event */
protected void remove_DeviceAddedEvent (EventHandler<DeviceChangedEventArgs> value)

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.DeviceRemovedEvent Event

PosCommon.DeviceRemovedEvent Event |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Event DeviceRemovedEvent As EventHandler(Of DeviceChangedEventArgs)

protected event EventHandler<DeviceChangedEventArgs> DeviceRemovedEvent

protected:
event EventHandler<DeviceChangedEventArgs^>^ DeviceRemovedEvent {
    void add (EventHandler<DeviceChangedEventArgs^>^ value);
    void remove (EventHandler<DeviceChangedEventArgs^>^ value);
}

/** @event */
protected void add_DeviceRemovedEvent (EventHandler<DeviceChangedEventArgs> value)

/** @event */
protected void remove_DeviceRemovedEvent (EventHandler<DeviceChangedEventArgs> value)

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PosCommon.DirectIOEvent Event

PosCommon.DirectIOEvent Event |
 | See Also

1/18/2008

Raised by the Service Object to communicate information directly to the application.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event DirectIOEvent As DirectIOEventHandler
public abstract event DirectIOEventHandler DirectIOEvent
public:
virtual event DirectIOEventHandler^ DirectIOEvent {
    void add (DirectIOEventHandler^ value) abstract;
    void remove (DirectIOEventHandler^ value) abstract;
}
/** @event */
public abstract void add_DirectIOEvent (DirectIOEventHandler value)

/** @event */
public abstract void remove_DirectIOEvent (DirectIOEventHandler value)

Remarks

DirectIOEvent provides a means for a Service Object to communicate information in the form of an event to the application that would not otherwise be supported by other events or properties that are defined for the device. Use of this event may restrict the application from being used with other vendor’s devices which may not have any knowledge of the Service Object’s need for this event.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
PosCommon.DirectIO Method
DirectIOEventArgs Class


PosCommon.StatusUpdateEvent Event

PosCommon.StatusUpdateEvent Event |
 | See Also

1/18/2008

Raised by the Service Object to alert the application of a device status change.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event StatusUpdateEvent As StatusUpdateEventHandler
public abstract event StatusUpdateEventHandler StatusUpdateEvent
public:
virtual event StatusUpdateEventHandler^ StatusUpdateEvent {
    void add (StatusUpdateEventHandler^ value) abstract;
    void remove (StatusUpdateEventHandler^ value) abstract;
}
/** @event */
public abstract void add_StatusUpdateEvent (StatusUpdateEventHandler value)

/** @event */
public abstract void remove_StatusUpdateEvent (StatusUpdateEventHandler value)

Remarks

Examples are a change in the cash drawer position (open versus closed), a change in a POS printer sensor (form present vs. absent), or a change in the power state of the device.

When a device is enabled, the Service Object may raise initial StatusUpdateEvents to inform the application of the device state. However, this behavior is not required.

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace
StatusUpdateEventArgs


PosControlException Class

PosControlException Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for exceptions thrown by service objects.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<SerializableAttribute> _
Public Class PosControlException
    Inherits PosException
[SerializableAttribute]
public class PosControlException : PosException
[SerializableAttribute]
public ref class PosControlException : public PosException
/** @attribute SerializableAttribute() */
public class PosControlException extends PosException
SerializableAttribute
public class PosControlException extends PosException

Remarks

POS for .NET applications should catch exceptions of this type to retrieve information about errors generated by a device's service object.

Inheritance Hierarchy

System.Object
System.Exception
Microsoft.PointOfService.PosException
Microsoft.PointOfService.PosControlException

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosControlException Members
Microsoft.PointOfService Namespace


PosControlException Members

PosControlException Members |
 | See Also Constructors Methods Properties

1/18/2008

Defines the programmatic interface for exceptions thrown by service objects.

The following tables list the members exposed by the PosControlException type.

Public Constructors (see also Protected Constructors )

Name | Description
PosControlException | Overloaded.
Top

Protected Constructors

Name | Description
PosControlException | Overloaded.
Top

Public Properties (see also Protected Properties )

Name | Description
Data | (inherited from Exception )
ErrorCode | Gets the ErrorCode value for this exception.
ErrorCodeExtended | Gets the extended error code for this exception
HelpLink | (inherited from Exception )
InnerException | (inherited from Exception )
Message | (inherited from Exception )
Source | (inherited from Exception )
StackTrace | (inherited from Exception )
TargetSite | (inherited from Exception )
Top

Protected Properties

Name | Description
HResult | (inherited from Exception )
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetBaseException | (inherited from Exception )
GetHashCode | (inherited from Object )
GetObjectData | (inherited from PosException )
GetType | (inherited from Exception )
ReferenceEquals | (inherited from Object )
ToString | Overridden. Creates and returns a string representation of the current exception.
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

PosControlException Class
Microsoft.PointOfService Namespace


PosControlException Constructor

PosControlException Constructor |
 | See Also

1/18/2008

Overload List

Name | Description
PosControlException (SerializationInfo, StreamingContext) | Creates an instance of the PosControlException class with serialized data.
PosControlException (String, ErrorCode) | Creates an instance of the PosControlException class with a specified error message and error code.
PosControlException (String, ErrorCode, Exception) | Creates an instance of the PosControlException class with a specified error message, error code, and inner exception.
PosControlException (String, ErrorCode, Int32) | Creates an instance of the PosControlException class with a specified error message, error code, and extended error code value.
PosControlException (String, ErrorCode, Int32, Exception) | Creates an instance of the PosControlException class with a specified error message, error code, extended error code value, and the exception that is the cause of the current exception.

See Also

Reference

PosControlException Class
PosControlException Members
Microsoft.PointOfService Namespace
System.Runtime.Serialization.SerializationInfo
System.Runtime.Serialization.StreamingContext


PosControlException Constructor (SerializationInfo, StreamingContext)

PosControlException Constructor (SerializationInfo, StreamingContext) |
 | See Also

1/18/2008

Creates an instance of the PosControlException class with serialized data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New ( _
    serializationInfo As SerializationInfo, _
    streamingContext As StreamingContext _
)
protected PosControlException (
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
protected:
PosControlException (
    SerializationInfo^ serializationInfo,
    StreamingContext streamingContext
)
protected PosControlException (
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
protected function PosControlException (
    serializationInfo : SerializationInfo,
    streamingContext : StreamingContext
)

Parameters

serializationInfo

The SerializationInfo object that holds the serialized object data about the exception being thrown.

streamingContext

The StreamingContext object that contains contextual information about the source or destination.

See Also

Reference

PosControlException Class
PosControlException Members
Microsoft.PointOfService Namespace
System.Runtime.Serialization.SerializationInfo
System.Runtime.Serialization.StreamingContext


PosControlException Constructor (String, ErrorCode)

PosControlException Constructor (String, ErrorCode) |
 | See Also

1/18/2008

Creates an instance of the PosControlException class with a specified error message and error code.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    message As String, _
    errorCode As ErrorCode _
)
public PosControlException (
    string message,
    ErrorCode errorCode
)
public:
PosControlException (
    String^ message,
    ErrorCode errorCode
)
public PosControlException (
    String message,
    ErrorCode errorCode
)
public function PosControlException (
    message : String,
    errorCode : ErrorCode
)

Parameters

message

A string that contains text that explains the reason for the exception.

errorCode

An ErrorCode value that represents the error code for the exception.

See Also

Reference

PosControlException Class
PosControlException Members
Microsoft.PointOfService Namespace


PosControlException Constructor (String, ErrorCode, Exception)

PosControlException Constructor (String, ErrorCode, Exception) |
 | See Also

1/18/2008

Creates an instance of the PosControlException class with a specified error message, error code, and inner exception.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    message As String, _
    errorCode As ErrorCode, _
    e As Exception _
)
public PosControlException (
    string message,
    ErrorCode errorCode,
    Exception e
)
public:
PosControlException (
    String^ message,
    ErrorCode errorCode,
    Exception^ e
)
public PosControlException (
    String message,
    ErrorCode errorCode,
    Exception e
)
public function PosControlException (
    message : String,
    errorCode : ErrorCode,
    e : Exception
)

Parameters

message

A string that contains text that explains the reason for the exception.

errorCode

An ErrorCode value that represents the error code for the exception.

e

The exception that is the cause of the PosControlException being constructed. If this parameter is not null (Nothing in Visual Basic), the exception provided is available to exception handling code as the PosControlException's InnerException.

See Also

Reference

PosControlException Class
PosControlException Members
Microsoft.PointOfService Namespace


PosControlException Constructor (String, ErrorCode, Int32)

PosControlException Constructor (String, ErrorCode, Int32) |
 | See Also

1/18/2008

Creates an instance of the PosControlException class with a specified error message, error code, and extended error code value.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    message As String, _
    errorCode As ErrorCode, _
    errorCodeExtended As Integer _
)
public PosControlException (
    string message,
    ErrorCode errorCode,
    int errorCodeExtended
)
public:
PosControlException (
    String^ message,
    ErrorCode errorCode,
    int errorCodeExtended
)
public PosControlException (
    String message,
    ErrorCode errorCode,
    int errorCodeExtended
)
public function PosControlException (
    message : String,
    errorCode : ErrorCode,
    errorCodeExtended : int
)

Parameters

message

A string that contains text that explains the reason for the exception.

errorCode

An ErrorCode value that represents the error code for the exception. If an extended error code is provided, this value should be Extended.

errorCodeExtended

The extended error code for the exception. This value is typically device-specific. See the documentation for the POS for .NET device in question to discover what values may be passed here.

See Also

Reference

PosControlException Class
PosControlException Members
Microsoft.PointOfService Namespace


PosControlException Constructor (String, ErrorCode, Int32, Exception)

PosControlException Constructor (String, ErrorCode, Int32, Exception) |
 | See Also

1/18/2008

Creates an instance of the PosControlException class with a specified error message, error code, extended error code value, and the exception that is the cause of the current exception.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    message As String, _
    errorCode As ErrorCode, _
    errorCodeExtended As Integer, _
    e As Exception _
)
public PosControlException (
    string message,
    ErrorCode errorCode,
    int errorCodeExtended,
    Exception e
)
public:
PosControlException (
    String^ message,
    ErrorCode errorCode,
    int errorCodeExtended,
    Exception^ e
)
public PosControlException (
    String message,
    ErrorCode errorCode,
    int errorCodeExtended,
    Exception e
)
public function PosControlException (
    message : String,
    errorCode : ErrorCode,
    errorCodeExtended : int,
    e : Exception
)

Parameters

message

A string that contains text that explains the reason for the exception.

errorCode

An ErrorCode value that represents the error code for the exception. If an extended error code is provided, this value should be Extended.

errorCodeExtended

The extended error code for the exception. This value is typically device-specific. See the documentation for the POS for .NET device in question to discover what values may be passed here.

e

The exception that is the cause of the PosControlException being constructed. If this parameter is not null (Nothing in Visual Basic), the exception provided is available to exception handling code as the PosControlException's InnerException.

See Also

Reference

PosControlException Class
PosControlException Members
Microsoft.PointOfService Namespace


PosControlException Methods

PosControlException Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetBaseException | (inherited from Exception )
GetHashCode | (inherited from Object )
GetObjectData | (inherited from PosException )
GetType | (inherited from Exception )
ReferenceEquals | (inherited from Object )
ToString | Overridden. Creates and returns a string representation of the current exception.

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

PosControlException Class
Microsoft.PointOfService Namespace


PosControlException.ToString Method

PosControlException.ToString Method |
 | See Also

1/18/2008

Creates and returns a string representation of the current exception.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function ToString As String
public override string ToString ()
public:
virtual String^ ToString () override
public String ToString ()
public override function ToString () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosControlException Class
PosControlException Members
Microsoft.PointOfService Namespace


PosControlException Properties

PosControlException Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
Data | (inherited from Exception )
ErrorCode | Gets the ErrorCode value for this exception.
ErrorCodeExtended | Gets the extended error code for this exception
HelpLink | (inherited from Exception )
InnerException | (inherited from Exception )
Message | (inherited from Exception )
Source | (inherited from Exception )
StackTrace | (inherited from Exception )
TargetSite | (inherited from Exception )

Protected Properties

Name | Description
HResult | (inherited from Exception )

See Also

Reference

PosControlException Class
Microsoft.PointOfService Namespace


PosControlException.ErrorCode Property

PosControlException.ErrorCode Property |
 | See Also

1/18/2008

Gets the ErrorCode value for this exception.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property ErrorCode As ErrorCode
public ErrorCode ErrorCode { get; }
public:
property ErrorCode ErrorCode {
    ErrorCode get ();
}
/** @property */
public ErrorCode get_ErrorCode ()

public function get ErrorCode () : ErrorCode

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosControlException Class
PosControlException Members
Microsoft.PointOfService Namespace


PosControlException.ErrorCodeExtended Property

PosControlException.ErrorCodeExtended Property |
 | See Also

1/18/2008

Gets the extended error code for this exception

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property ErrorCodeExtended As Integer
public int ErrorCodeExtended { get; }
public:
property int ErrorCodeExtended {
    int get ();
}
/** @property */
public int get_ErrorCodeExtended ()

public function get ErrorCodeExtended () : int

Remarks

When the ErrorCode property contains the value Extended, this value holds the device-specific extended error code. Extended error codes are device-specific, and should be documented in the device throwing the exception.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosControlException Class
PosControlException Members
Microsoft.PointOfService Namespace


PosDevice Class

PosDevice Class |
 | See Also Members

1/18/2008

Defines the programmatic interface that represents a generic POS device. The PosCommon class inherits from the PosDevice class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Class PosDevice
public class PosDevice
public ref class PosDevice
public class PosDevice
public class PosDevice

Remarks

Used as the return value of the CreateInstance method of the PosExplorer class. The method returns an instance of the PosDevice class, which represents a service object class (based on the specified device information). The application uses the information provided by the PosDevice class to initialize a device-specific (that is, Msr, PosPrinter, and so on) service object.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosDevice Members
Microsoft.PointOfService Namespace


PosDevice Members

PosDevice Members |
 | See Also Constructors Methods Properties

1/18/2008

Defines the programmatic interface that represents a generic POS device. The PosCommon class inherits from the PosDevice class.

The following tables list the members exposed by the PosDevice type.

Public Constructors

Name | Description
PosDevice | Creates an instance of the PosDevice class.
Top

Public Properties

Name | Description
Compatibility | Gets the compatibility level of a device.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

PosDevice Class
Microsoft.PointOfService Namespace


PosDevice Constructor

PosDevice Constructor |
 | See Also

1/18/2008

Creates an instance of the PosDevice class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New
public PosDevice ()
public:
PosDevice ()
public PosDevice ()
public function PosDevice ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

PosDevice Class
PosDevice Members
Microsoft.PointOfService Namespace


PosDevice Methods

PosDevice Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

PosDevice Class
Microsoft.PointOfService Namespace


PosDevice Properties

PosDevice Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
Compatibility | Gets the compatibility level of a device.

See Also

Reference

PosDevice Class
Microsoft.PointOfService Namespace


PosDevice.Compatibility Property

PosDevice.Compatibility Property |
 | See Also

1/18/2008

Gets the compatibility level of a device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Compatibility As DeviceCompatibilities
public DeviceCompatibilities Compatibility { get; }
public:
property DeviceCompatibilities Compatibility {
    DeviceCompatibilities get ();
}
/** @property */
public DeviceCompatibilities get_Compatibility ()

public function get Compatibility () : DeviceCompatibilities

Remarks

Valid values are defined by the DeviceCompatibilities enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosDevice Class
PosDevice Members
Microsoft.PointOfService Namespace


PosEventArgs Class

PosEventArgs Class |
 | See Also Members

1/18/2008

Defines the base class for POS for .NET classes containing event data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<SerializableAttribute> _
Public MustInherit Class PosEventArgs
    Inherits EventArgs
[SerializableAttribute]
public abstract class PosEventArgs : EventArgs
[SerializableAttribute]
public ref class PosEventArgs abstract : public EventArgs
/** @attribute SerializableAttribute() */
public abstract class PosEventArgs extends EventArgs
SerializableAttribute
public abstract class PosEventArgs extends EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Microsoft.PointOfService.PosEventArgs
Microsoft.PointOfService.DataEventArgs
Microsoft.PointOfService.DeviceErrorEventArgs
Microsoft.PointOfService.DirectIOEventArgs
Microsoft.PointOfService.OutputCompleteEventArgs
Microsoft.PointOfService.StatusUpdateEventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosEventArgs Members
Microsoft.PointOfService Namespace


PosEventArgs Members

PosEventArgs Members |
 | See Also Fields Methods Properties Constructors

1/18/2008

Defines the base class for POS for .NET classes containing event data.

The following tables list the members exposed by the PosEventArgs type.

Protected Constructors

Name | Description
PosEventArgs | Creates an instance of the PosEventArgs class.
Top

Public Fields

Name | Description
Empty | (inherited from EventArgs )
Top

Public Properties

Name | Description
EventId | Gets the event identifier.
TimeStamp | Gets the DateTime of the event.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Overridden.
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

PosEventArgs Class
Microsoft.PointOfService Namespace


PosEventArgs Fields

PosEventArgs Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
Empty | (inherited from EventArgs )

See Also

Reference

PosEventArgs Class
Microsoft.PointOfService Namespace


PosEventArgs Constructor

PosEventArgs Constructor |
 | See Also

1/18/2008

Creates an instance of the PosEventArgs class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected PosEventArgs ()
protected:
PosEventArgs ()
protected PosEventArgs ()
protected function PosEventArgs ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

PosEventArgs Class
PosEventArgs Members
Microsoft.PointOfService Namespace


PosEventArgs Methods

PosEventArgs Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Overridden.

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

PosEventArgs Class
Microsoft.PointOfService Namespace


PosEventArgs.ToString Method

PosEventArgs.ToString Method |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function ToString As String
public override string ToString ()
public:
virtual String^ ToString () override
public String ToString ()
public override function ToString () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosEventArgs Class
PosEventArgs Members
Microsoft.PointOfService Namespace


PosEventArgs Properties

PosEventArgs Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
EventId | Gets the event identifier.
TimeStamp | Gets the DateTime of the event.

See Also

Reference

PosEventArgs Class
Microsoft.PointOfService Namespace


PosEventArgs.EventId Property

PosEventArgs.EventId Property |
 | See Also

1/18/2008

Gets the event identifier.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property EventId As Integer
public int EventId { get; }
public:
property int EventId {
    int get ();
}
/** @property */
public int get_EventId ()

public function get EventId () : int

Remarks

Because DateTime.Now has limited resolution, it is possible that two events can be given the same TimeStamp. Therefore, you should also verify the order of events with the EventId property.

The EventId property is an integer that is incremented after every event. The first event is number 1, the second event is number 2, and so on. The numbering is honored across service objects in the same process. This enables an application working with multiple devices to determine event order regardless of which device it came from.

EventId is set at the time the event is created. Therefore, an application is not guaranteed to receive events with sequential EventIds. For example, StatusUpdateEvent events are delivered before DataEvent events if the DataEventEnabled property is set to false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosEventArgs Class
PosEventArgs Members
Microsoft.PointOfService Namespace


PosEventArgs.TimeStamp Property

PosEventArgs.TimeStamp Property |
 | See Also

1/18/2008

Gets the DateTime of the event.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property TimeStamp As DateTime
public DateTime TimeStamp { get; }
public:
property DateTime TimeStamp {
    DateTime get ();
}
/** @property */
public DateTime get_TimeStamp ()

public function get TimeStamp () : DateTime

Remarks

Because DateTime.Now has limited resolution, it is possible that two events can be given the same TimeStamp. Therefore, you should also verify the order of events with the EventId property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosEventArgs Class
PosEventArgs Members
Microsoft.PointOfService Namespace


PosException Class

PosException Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a generic exception in the POS for .NET system. All other exception classes inherit from PosException.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<SerializableAttribute> _
Public MustInherit Class PosException
    Inherits Exception
    Implements ISerializable
[SerializableAttribute]
public abstract class PosException : Exception, ISerializable
[SerializableAttribute]
public ref class PosException abstract : public Exception, ISerializable
/** @attribute SerializableAttribute() */
public abstract class PosException extends Exception implements ISerializable
SerializableAttribute
public abstract class PosException extends Exception implements ISerializable

Inheritance Hierarchy

System.Object
System.Exception
Microsoft.PointOfService.PosException
Microsoft.PointOfService.PosControlException
Microsoft.PointOfService.PosLibraryException
Microsoft.PointOfService.PosManagementException

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosException Members
Microsoft.PointOfService Namespace


PosException Members

PosException Members |
 | See Also Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a generic exception in the POS for .NET system. All other exception classes inherit from PosException.

The following tables list the members exposed by the PosException type.

Protected Constructors

Name | Description
PosException | Overloaded.
Top

Public Properties (see also Protected Properties )

Name | Description
Data | (inherited from Exception )
HelpLink | (inherited from Exception )
InnerException | (inherited from Exception )
Message | (inherited from Exception )
Source | (inherited from Exception )
StackTrace | (inherited from Exception )
TargetSite | (inherited from Exception )
Top

Protected Properties

Name | Description
HResult | (inherited from Exception )
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetBaseException | (inherited from Exception )
GetHashCode | (inherited from Object )
GetObjectData | Overridden. Sets the SerializationInfo with information about the exception.
GetType | (inherited from Exception )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Exception )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

PosException Class
Microsoft.PointOfService Namespace


PosException Constructor

PosException Constructor |
 | See Also

1/18/2008

Overload List

Name | Description
PosException () | Creates an instance of the PosException class.
PosException (String) | Creates an instance of the PosException class with a specified error message.
PosException (SerializationInfo, StreamingContext) | Creates an instance of the PosException class with serialized data.
PosException (String, Exception) | Creates an instance of the PosException class with a specified error message and a reference to the inner exception that is the cause of this exception.
PosException (String, ErrorCode, Int32) | Creates an instance of the PosException class with a specified error message, error code, and extended error code values.
PosException (String, ErrorCode, Int32, Exception) | Creates an instance of the PosException class with a specified error message, error code, and extended error code value.

See Also

Reference

PosException Class
PosException Members
Microsoft.PointOfService Namespace


PosException Constructor ()

PosException Constructor () |
 | See Also

1/18/2008

Creates an instance of the PosException class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected PosException ()
protected:
PosException ()
protected PosException ()
protected function PosException ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

PosException Class
PosException Members
Microsoft.PointOfService Namespace


PosException Constructor (String)

PosException Constructor (String) |
 | See Also

1/18/2008

Creates an instance of the PosException class with a specified error message.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New ( _
    message As String _
)
protected PosException (
    string message
)
protected:
PosException (
    String^ message
)
protected PosException (
    String message
)
protected function PosException (
    message : String
)

Parameters

message

The error message that explains the reason for the exception.

See Also

Reference

PosException Class
PosException Members
Microsoft.PointOfService Namespace


PosException Constructor (SerializationInfo, StreamingContext)

PosException Constructor (SerializationInfo, StreamingContext) |
 | See Also

1/18/2008

Creates an instance of the PosException class with serialized data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New ( _
    serializationInfo As SerializationInfo, _
    streamingContext As StreamingContext _
)
protected PosException (
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
protected:
PosException (
    SerializationInfo^ serializationInfo,
    StreamingContext streamingContext
)
protected PosException (
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
protected function PosException (
    serializationInfo : SerializationInfo,
    streamingContext : StreamingContext
)

Parameters

serializationInfo

The SerializationInfo that holds the serialized object data about the exception being thrown.

streamingContext

The StreamingContext that contains contextual information about the source or destination.

See Also

Reference

PosException Class
PosException Members
Microsoft.PointOfService Namespace
PosException Constructor


PosException Constructor (String, Exception)

PosException Constructor (String, Exception) |
 | See Also

1/18/2008

Creates an instance of the PosException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New ( _
    message As String, _
    e As Exception _
)
protected PosException (
    string message,
    Exception e
)
protected:
PosException (
    String^ message,
    Exception^ e
)
protected PosException (
    String message,
    Exception e
)
protected function PosException (
    message : String,
    e : Exception
)

Parameters

message

The error message that explains the reason for the exception.

e

The exception that is the cause of the current exception. If the e parameter is not a null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

PosException Class
PosException Members
Microsoft.PointOfService Namespace


PosException Constructor (String, ErrorCode, Int32)

PosException Constructor (String, ErrorCode, Int32) |
 | See Also

1/18/2008

Creates an instance of the PosException class with a specified error message, error code, and extended error code values.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New ( _
    message As String, _
    errorCode As ErrorCode, _
    errorCodeExtended As Integer _
)
protected PosException (
    string message,
    ErrorCode errorCode,
    int errorCodeExtended
)
protected:
PosException (
    String^ message,
    ErrorCode errorCode,
    int errorCodeExtended
)
protected PosException (
    String message,
    ErrorCode errorCode,
    int errorCodeExtended
)
protected function PosException (
    message : String,
    errorCode : ErrorCode,
    errorCodeExtended : int
)

Parameters

message

The error message that explains the reason for the exception.

errorCode

The error code for the exception.

errorCodeExtended

The extended error code for the exception.

See Also

Reference

PosException Class
PosException Members
Microsoft.PointOfService Namespace


PosException Constructor (String, ErrorCode, Int32, Exception)

PosException Constructor (String, ErrorCode, Int32, Exception) |
 | See Also

1/18/2008

Creates an instance of the PosException class with a specified error message, error code, and extended error code value.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New ( _
    message As String, _
    errorCode As ErrorCode, _
    errorCodeExtended As Integer, _
    e As Exception _
)
protected PosException (
    string message,
    ErrorCode errorCode,
    int errorCodeExtended,
    Exception e
)
protected:
PosException (
    String^ message,
    ErrorCode errorCode,
    int errorCodeExtended,
    Exception^ e
)
protected PosException (
    String message,
    ErrorCode errorCode,
    int errorCodeExtended,
    Exception e
)
protected function PosException (
    message : String,
    errorCode : ErrorCode,
    errorCodeExtended : int,
    e : Exception
)

Parameters

message

The error message that explains the reason for the exception.

errorCode

The error code for the exception.

errorCodeExtended

The extended error code for the exception.

e

The exception that is the cause of the current exception. If the e parameter is not a null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

PosException Class
PosException Members
Microsoft.PointOfService Namespace


PosException Methods

PosException Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetBaseException | (inherited from Exception )
GetHashCode | (inherited from Object )
GetObjectData | Overridden. Sets the SerializationInfo with information about the exception.
GetType | (inherited from Exception )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Exception )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

PosException Class
Microsoft.PointOfService Namespace


PosException.GetObjectData Method

PosException.GetObjectData Method |
 | See Also

1/18/2008

Sets the SerializationInfo with information about the exception.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter:=True)> _
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
[SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter=true)]
public override void GetObjectData (
    SerializationInfo info,
    StreamingContext context
)
[SecurityPermissionAttribute(SecurityAction::Demand, SerializationFormatter=true)]
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
/** @attribute SecurityPermissionAttribute(SecurityAction.Demand, SerializationFormatter=true) */
public void GetObjectData (
    SerializationInfo info,
    StreamingContext context
)
public override function GetObjectData (
    info : SerializationInfo,
    context : StreamingContext
)

Parameters

info

The SerializationInfo that holds the serialized object data about the exception being thrown.

context

The StreamingContext that contains contextual information about the source or destination.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosException Class
PosException Members
Microsoft.PointOfService Namespace
PosException Constructor


PosException Properties

PosException Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
Data | (inherited from Exception )
HelpLink | (inherited from Exception )
InnerException | (inherited from Exception )
Message | (inherited from Exception )
Source | (inherited from Exception )
StackTrace | (inherited from Exception )
TargetSite | (inherited from Exception )

Protected Properties

Name | Description
HResult | (inherited from Exception )

See Also

Reference

PosException Class
Microsoft.PointOfService Namespace


PosExplorer Class

PosExplorer Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for enumeration and initialization of POS installed devices.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public NotInheritable Class PosExplorer
public sealed class PosExplorer
public ref class PosExplorer sealed
public final class PosExplorer
public final class PosExplorer

Remarks

The PosExplorer class is used by applications to obtain a list of installed POS devices, create instances of service objects for those devices, and receive Plug and Play events when the devices are connected or disconnected from the system.

When you use the PosExplorer class, there are five possible usage scenarios in an application. An application can do the following:

  • Assume there is only one device of a type attached, or use only one device of a type and default devices are configured.

  • Use logical device names.

  • Dynamically attach all available input devices.

  • Handle all hardware configurations.

  • Use a combination of these scenarios for different device types.

Scenario 1

In this scenario, an application assumes one device of a type attached to the computer. For this scenario, you can get the device as follows:

Copy Code
Msr msr;
PosExplorer explorer = new PosExplorer();
DeviceInfo deviceInfo = explorer.GetDevice(DeviceType.Msr);
if (deviceInfo == null)
   <report failure>;
else
   msr = explorer.CreateInstance(deviceInfo) as Msr;
msr.Open();

In this example, if more than one MSR device is attached to the system, the GetDevice method throws an exception. The advantage of this scenario is that no configuration is required.

Scenario 2

The code for this scenario is the same as that in Scenario 1. However, if there are multiple MSR devices attached and one is set as default, the GetDevice method does not throw an exception and returns a DeviceInfo object for the default MSR.

Scenario 3

An application may use logical device names. The names must be preconfigured (created) through WMI or Posdm before the application is run. The logical names the application uses for opening devices can be either hard-coded in the application or, better, can be defined in an application's configuration file <application name>.exe.config. In the latter case, the application reads the names from the configuration file by the .NET Framework ConfigurationSettings class. Because the names are defined in the XML configuration file, administrators can see and change them if necessary to avoid possible naming conflicts. If multiple applications that are running on the same device in the same manner, they configure other.NET Framework applications. The following code gets the device.

Copy Code
string myMsrName = <get the name>;
Msr msr;
PosExplorer explorer = new PosExplorer();
DeviceInfo deviceInfo = explorer.GetDevice( DeviceType.Msr, myMsrName );
if( deviceInfo == null )
   <report failure>
else
   msr = explorer.CreateInstance( deviceInfo ) as Msr;
msr.Open();

Scenario 4

For input devices, an application can enumerate and attach all available peripherals, provided it does not matter from which, for example, of two MSRs it receives card swipes from the following code.

Copy Code
ArrayList msrs = new ArrayList ();
PosExplorer explorer = new PosExplorer();
DeviceCollection devices = explorer.GetDevices( DeviceType.Msr );
foreach( DeviceInfo deviceInfo in devices )
{
    Msr msr =  explorer.CreateInstance( deviceInfo ) as Msr
    msrs.Add( msr );
    msr.Open();
}

Scenario 5

Alternatively, an application can handle all hardware configuration itself. It can enumerate all available devices of all types it can use and ask the user to make choices where there is ambiguity and then persist this configuration to its own configuration store. Then, when the application runs, it enumerates all available devices by calling GetDevices( <type> ), detects if any devices were added/removed, and updates its persisted configuration. In ambiguous cases of multiple devices of a type, it may require user selection. This approach can be used together with this example so that all input devices are handled automatically and persisted configuration is used only for output devices.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosExplorer

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosExplorer Members
Microsoft.PointOfService Namespace


PosExplorer Members

PosExplorer Members |
 | See Also Constructors Events Methods Properties

1/18/2008

Defines the programmatic interface for enumeration and initialization of POS installed devices.

The following tables list the members exposed by the PosExplorer type.

Public Constructors

Name | Description
PosExplorer | Overloaded.
Top

Public Properties

Name | Description
PosRegistryKey | Gets the POS for .NET configuration root registry key in relation to HKEY_LOCAL_MACHINE.
StatisticsFile | Gets a path of the file in which device statistics is persisted.
SynchronizingObject | Gets or sets the IsynchronizeInvoke object.
Top

Public Methods (see also Protected Methods )

Name | Description
CreateInstance | Creates an instance of the service object based on the information supplied by the property values of the DeviceInfo object.
Equals | Overloaded. (inherited from Object )
GetDevice | Overloaded.
GetDevices | Overloaded.
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
Refresh | Re-enumerates the list of attached POS devices and rebuilds internal data structures.
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

Public Events

Name | Description
DeviceAddedEvent | Notifies the application when a POS device has been added to the system.
DeviceRemovedEvent | Notifies the application when a POS device has been removed from the system.
Top

See Also

Reference

PosExplorer Class
Microsoft.PointOfService Namespace


PosExplorer Constructor

PosExplorer Constructor |
 | See Also

1/18/2008

Overload List

Name | Description
PosExplorer () | Creates an instance of the PosExplorer class.
PosExplorer (ISynchronizeInvoke) | Creates an instance of the PosExplorer class with the specified parameter and initializes the system.

See Also

Reference

PosExplorer Class
PosExplorer Members
Microsoft.PointOfService Namespace


PosExplorer Constructor ()

PosExplorer Constructor () |
 | See Also

1/18/2008

Creates an instance of the PosExplorer class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New
public PosExplorer ()
public:
PosExplorer ()
public PosExplorer ()
public function PosExplorer ()

Remarks

Default constructor for PosExplorer. Initializes system resources and creates an instance of the PosExplorer class. Use this constructor when you do not have events from the service object reported on a particular thread. To have events reported on a predefined thread, you must use the PosExplorer(IsynchronizeInvoke) constructor.

See Also

Reference

PosExplorer Class
PosExplorer Members
Microsoft.PointOfService Namespace


PosExplorer Constructor (ISynchronizeInvoke)

PosExplorer Constructor (ISynchronizeInvoke) |
 | See Also

1/18/2008

Creates an instance of the PosExplorer class with the specified parameter and initializes the system.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    synchronizingObject As ISynchronizeInvoke _
)
public PosExplorer (
    ISynchronizeInvoke synchronizingObject
)
public:
PosExplorer (
    ISynchronizeInvoke^ synchronizingObject
)
public PosExplorer (
    ISynchronizeInvoke synchronizingObject
)
public function PosExplorer (
    synchronizingObject : ISynchronizeInvoke
)

Parameters

synchronizingObject

An object that implements the .NET Framework class IsynchronizeInvoke. ISynchronizeInvoke is used to marshal events to a particular thread defined by the object. For more information, see the .NET Framework Library documentation.

Remarks

Use this constructor when you want events from the service object marshaled to a particular thread.

Windows Forms applications are required to update their UI controls only from the main application thread. By passing its main window control to the PosExplorer constructor, an application can guarantee that all PosExplorer and service object events are reported on the main application thread.

For more information about Windows Forms and threading, see the .NET Framework Library documentation.

See Also

Reference

PosExplorer Class
PosExplorer Members
Microsoft.PointOfService Namespace
SynchronizingObject


PosExplorer Methods

PosExplorer Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
CreateInstance | Creates an instance of the service object based on the information supplied by the property values of the DeviceInfo object.
Equals | Overloaded. (inherited from Object )
GetDevice | Overloaded.
GetDevices | Overloaded.
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
Refresh | Re-enumerates the list of attached POS devices and rebuilds internal data structures.
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

PosExplorer Class
Microsoft.PointOfService Namespace


PosExplorer.CreateInstance Method

PosExplorer.CreateInstance Method |
 | See Also

1/18/2008

Creates an instance of the service object based on the information supplied by the property values of the DeviceInfo object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Function CreateInstance ( _
    device As DeviceInfo _
) As PosDevice
public PosDevice CreateInstance (
    DeviceInfo device
)
public:
PosDevice^ CreateInstance (
    DeviceInfo^ device
)
public PosDevice CreateInstance (
    DeviceInfo device
)
public function CreateInstance (
    device : DeviceInfo
) : PosDevice

Parameters

device

An object that describes the device that you want to create an instance of, and which is an instance of the DeviceInfo class. DeviceInfo contains Compatibility, Description, HardwareID properties and so on for the device.

Remarks

CreateInstance returns an instance of the specified service object class cast to PosDevice. An application must then cast it to a more specific class (such as Msr, Scanner, or PosPrinter).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosExplorer Class
PosExplorer Members
Microsoft.PointOfService Namespace


PosExplorer.GetDevice Method

PosExplorer.GetDevice Method |
 | See Also

1/18/2008

Overload List

Name | Description
PosExplorer.GetDevice (String) | Retrieves a device of the specified type.
PosExplorer.GetDevice (String, String) | Retrieves a device of the specified type and logical name (or alias).

See Also

Reference

PosExplorer Class
PosExplorer Members
Microsoft.PointOfService Namespace
GetDevices


PosExplorer.GetDevice Method (String)

PosExplorer.GetDevice Method (String) |
 | See Also

1/18/2008

Retrieves a device of the specified type.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Function GetDevice ( _
    type As String _
) As DeviceInfo
public DeviceInfo GetDevice (
    string type
)
public:
DeviceInfo^ GetDevice (
    String^ type
)
public DeviceInfo GetDevice (
    String type
)
public function GetDevice (
    type : String
) : DeviceInfo

Parameters

type

A string that contains one of the 36 POS device types, as defined by the DeviceType helper class.

Remarks

There must be only one device of that type currently in the system, or if there is more than one, one must have been configured as the default device. If there is more than one device of the specified type and no device has been configured as the default device, an exception will be thrown.

This signature of GetDevice represents the simplest case for retrieving and instantiating a device in the POS for .NET system. To retrieve one device and create an instance of its service object class, the application must only perform the following actions:

  • Create an instance of the PosExplorer class.

  • Call the GetDevice method by using the previous method signature.

  • Call the CreateInstance method, passing in the DeviceInfo returned from the GetDevice method call.

POS for .NET initializes the device of the type specified or, if there is more than one device of that type, the preconfigured default device for that type.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosExplorer Class
PosExplorer Members
Microsoft.PointOfService Namespace
GetDevices


PosExplorer.GetDevice Method (String, String)

PosExplorer.GetDevice Method (String, String) |
 | See Also

1/18/2008

Retrieves a device of the specified type and logical name (or alias).

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Function GetDevice ( _
    type As String, _
    logicalName As String _
) As DeviceInfo
public DeviceInfo GetDevice (
    string type,
    string logicalName
)
public:
DeviceInfo^ GetDevice (
    String^ type,
    String^ logicalName
)
public DeviceInfo GetDevice (
    String type,
    String logicalName
)
public function GetDevice (
    type : String,
    logicalName : String
) : DeviceInfo

Parameters

type

A string that contains one of the 36 POS device types, as defined by the DeviceType helper class.

logicalName

The logical name or alias of the device.

Remarks

Before you use GetDevice, logical names must be configured for the device by using either PosDm.exe or WMI. You cannot pass the service object name for logicalName.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosExplorer Class
PosExplorer Members
Microsoft.PointOfService Namespace


PosExplorer.GetDevices Method

PosExplorer.GetDevices Method |
 | See Also

1/18/2008

Overload List

Name | Description
PosExplorer.GetDevices () | Returns a collection of all POS devices currently installed in the system.
PosExplorer.GetDevices (DeviceCompatibilities) | Retrieves all POS devices currently installed in the system, based on a compatibility level (or version number).
PosExplorer.GetDevices (String) | Retrieves all POS devices of the specified type.
PosExplorer.GetDevices (String, DeviceCompatibilities) | Retrieves all POS devices of the specified type and compatibility (or version).

See Also

Reference

PosExplorer Class
PosExplorer Members
Microsoft.PointOfService Namespace
PosExplorer.GetDevice Method


PosExplorer.GetDevices Method ()

PosExplorer.GetDevices Method () |
 | See Also

1/18/2008

Returns a collection of all POS devices currently installed in the system.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Function GetDevices As DeviceCollection
public DeviceCollection GetDevices ()
public:
DeviceCollection^ GetDevices ()
public DeviceCollection GetDevices ()
public function GetDevices () : DeviceCollection

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosExplorer Class
PosExplorer Members
Microsoft.PointOfService Namespace
PosExplorer.GetDevice Method


PosExplorer.GetDevices Method (DeviceCompatibilities)

PosExplorer.GetDevices Method (DeviceCompatibilities) |
 | See Also

1/18/2008

Retrieves all POS devices currently installed in the system, based on a compatibility level (or version number).

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Function GetDevices ( _
    compatibility As DeviceCompatibilities _
) As DeviceCollection
public DeviceCollection GetDevices (
    DeviceCompatibilities compatibility
)
public:
DeviceCollection^ GetDevices (
    DeviceCompatibilities compatibility
)
public DeviceCollection GetDevices (
    DeviceCompatibilities compatibility
)
public function GetDevices (
    compatibility : DeviceCompatibilities
) : DeviceCollection

Parameters

compatibility

DeviceCompatibilities enumeration that indicates compatibility level.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosExplorer Class
PosExplorer Members
Microsoft.PointOfService Namespace


PosExplorer.GetDevices Method (String)

PosExplorer.GetDevices Method (String) |
 | See Also

1/18/2008

Retrieves all POS devices of the specified type.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Function GetDevices ( _
    type As String _
) As DeviceCollection
public DeviceCollection GetDevices (
    string type
)
public:
DeviceCollection^ GetDevices (
    String^ type
)
public DeviceCollection GetDevices (
    String type
)
public function GetDevices (
    type : String
) : DeviceCollection

Parameters

type

A string that contains one of the 36 POS device types, as defined by the DeviceType helper class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosExplorer Class
PosExplorer Members
Microsoft.PointOfService Namespace


PosExplorer.GetDevices Method (String, DeviceCompatibilities)

PosExplorer.GetDevices Method (String, DeviceCompatibilities) |
 | See Also

1/18/2008

Retrieves all POS devices of the specified type and compatibility (or version).

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Function GetDevices ( _
    type As String, _
    compatibility As DeviceCompatibilities _
) As DeviceCollection
public DeviceCollection GetDevices (
    string type,
    DeviceCompatibilities compatibility
)
public:
DeviceCollection^ GetDevices (
    String^ type,
    DeviceCompatibilities compatibility
)
public DeviceCollection GetDevices (
    String type,
    DeviceCompatibilities compatibility
)
public function GetDevices (
    type : String,
    compatibility : DeviceCompatibilities
) : DeviceCollection

Parameters

type

A string that contains one of the 36 POS device types, as defined by the DeviceType helper class.

compatibility

DeviceCompatibilities enumeration that indicates compatibility level.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosExplorer Class
PosExplorer Members
Microsoft.PointOfService Namespace


PosExplorer.Refresh Method

PosExplorer.Refresh Method |
 | See Also

1/18/2008

Re-enumerates the list of attached POS devices and rebuilds internal data structures.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub Refresh
public void Refresh ()
public:
void Refresh ()
public void Refresh ()
public function Refresh ()

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosExplorer Class
PosExplorer Members
Microsoft.PointOfService Namespace


PosExplorer Properties

PosExplorer Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
PosRegistryKey | Gets the POS for .NET configuration root registry key in relation to HKEY_LOCAL_MACHINE.
StatisticsFile | Gets a path of the file in which device statistics is persisted.
SynchronizingObject | Gets or sets the IsynchronizeInvoke object.

See Also

Reference

PosExplorer Class
Microsoft.PointOfService Namespace


PosExplorer.PosRegistryKey Property

PosExplorer.PosRegistryKey Property |
 | See Also

1/18/2008

Gets the POS for .NET configuration root registry key in relation to HKEY_LOCAL_MACHINE.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared ReadOnly Property PosRegistryKey As String
public static string PosRegistryKey { get; }
public:
static property String^ PosRegistryKey {
    String^ get ();
}
/** @property */
public static String get_PosRegistryKey ()

public static function get PosRegistryKey () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosExplorer Class
PosExplorer Members
Microsoft.PointOfService Namespace


PosExplorer.StatisticsFile Property

PosExplorer.StatisticsFile Property |
 | See Also

1/18/2008

Gets a path of the file in which device statistics is persisted.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared ReadOnly Property StatisticsFile As String
public static string StatisticsFile { get; }
public:
static property String^ StatisticsFile {
    String^ get ();
}
/** @property */
public static String get_StatisticsFile ()

public static function get StatisticsFile () : String

Remarks

Returns a path of the file in which device statistics is persisted.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosExplorer Class
PosExplorer Members
Microsoft.PointOfService Namespace


PosExplorer.SynchronizingObject Property

PosExplorer.SynchronizingObject Property |
 | See Also

1/18/2008

Gets or sets the IsynchronizeInvoke object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Property SynchronizingObject As ISynchronizeInvoke
public ISynchronizeInvoke SynchronizingObject { get; set; }
public:
property ISynchronizeInvoke^ SynchronizingObject {
    ISynchronizeInvoke^ get ();
    void set (ISynchronizeInvoke^ value);
}
/** @property */
public ISynchronizeInvoke get_SynchronizingObject ()

/** @property */
public void set_SynchronizingObject (ISynchronizeInvoke value)

public function get SynchronizingObject () : ISynchronizeInvoke

public function set SynchronizingObject (value : ISynchronizeInvoke)

Remarks

Contains an object which is an instance of the .NET Framework class IsynchronizeInvoke. IsynchronizeInvoke is used to marshal events to a particular thread. If SynchronizingObject is set to null, events are raised on a system pool thread. Setting this property overrides the synchronizingObject parameter that is passed in the constructor.

When the events are handled by a visual Windows Forms control, such as a button, accessing the component through the system thread pool might not work, or might result in an exception. Avoid this by setting the SynchronizingObject property to a Windows Forms component that causes the methods handling the event to be called on the same thread on which the component was created.

For more information, see the .NET Framework Library documentation.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosExplorer Class
PosExplorer Members
Microsoft.PointOfService Namespace


PosExplorer Events

PosExplorer Events |
 | See Also

1/18/2008

Public Events

Name | Description
DeviceAddedEvent | Notifies the application when a POS device has been added to the system.
DeviceRemovedEvent | Notifies the application when a POS device has been removed from the system.

See Also

Reference

PosExplorer Class
Microsoft.PointOfService Namespace


PosExplorer.DeviceAddedEvent Event

PosExplorer.DeviceAddedEvent Event |
 | See Also Example

1/18/2008

Notifies the application when a POS device has been added to the system.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event DeviceAddedEvent As DeviceChangedEventHandler
public event DeviceChangedEventHandler DeviceAddedEvent
public:
event DeviceChangedEventHandler^ DeviceAddedEvent {
    void add (DeviceChangedEventHandler^ value);
    void remove (DeviceChangedEventHandler^ value);
}
/** @event */
public void add_DeviceAddedEvent (DeviceChangedEventHandler value)

/** @event */
public void remove_DeviceAddedEvent (DeviceChangedEventHandler value)

Example

The following example demonstrates how an application might handle a DeviceAddedEvent event:

Copy Code
posExplorer.DeviceAddedEvent += new (DeviceChangedEventHandler(OnDeviceAdded);

Msr msr;
private void OnDeviceAdded(object source, DeviceChangedEventArgs e)
{
      if (e.Device.Type == DeviceType.Msr)
         Msr = (Msr) posExplorer.CreateInstance(e.Device);

}

Remarks

DeviceAddedEvent only notifies for POS devices for which there is a service object installed.

The event handler receives an argument of type DeviceChangedEventArgs which contains a DeviceInfo object for the added device.

See Also

Reference

PosExplorer Class
PosExplorer Members
Microsoft.PointOfService Namespace
DeviceInfo Class
DeviceChangedEventArgs Class


PosExplorer.DeviceRemovedEvent Event

PosExplorer.DeviceRemovedEvent Event |
 | See Also Example

1/18/2008

Notifies the application when a POS device has been removed from the system.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event DeviceRemovedEvent As DeviceChangedEventHandler
public event DeviceChangedEventHandler DeviceRemovedEvent
public:
event DeviceChangedEventHandler^ DeviceRemovedEvent {
    void add (DeviceChangedEventHandler^ value);
    void remove (DeviceChangedEventHandler^ value);
}
/** @event */
public void add_DeviceRemovedEvent (DeviceChangedEventHandler value)

/** @event */
public void remove_DeviceRemovedEvent (DeviceChangedEventHandler value)

Example

The following example demonstrates how an application might handle a DeviceRemovedEventevent:

Copy Code
posExplorer.DeviceRemovedEvent += new (DeviceChangedEventHandler(OnDeviceRemoved);

Msr msr = (Msr) posExplorer.CreateInstance(deviceInfo);
msr.Open();
...

private void OnDeviceRemoved(object source, DeviceChangedEventArgs e)
{
      if (e.Device.IsDeviceInfoOf(msr))
           msr.Close();
}

Remarks

DeviceRemovedEvent only notifies for POS devices for which there is a service object installed.

The event handler receives an argument of type DeviceChangedEventArgs which contains a DeviceInfo object for the removed device.

See Also

Reference

PosExplorer Class
PosExplorer Members
Microsoft.PointOfService Namespace
DeviceInfo Class
DeviceChangedEventArgs Class


PosKeyboard Class

PosKeyboard Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a UPOS Keyboard device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class PosKeyboard
    Inherits PosCommon
public abstract class PosKeyboard : PosCommon
public ref class PosKeyboard abstract : public PosCommon
public abstract class PosKeyboard extends PosCommon
public abstract class PosKeyboard extends PosCommon

Remarks

Keyboard device classes in POS for .NET support reading keys from a keyboard. A POS Keyboard device may be an auxiliary keyboard, or it may be a virtual keyboard that consists of some or all the keys on the system keyboard.

Programming Model

The PosKeyboard class follows the general programming model for event-driven input:

  • When input is received by the service object, it queues a DataEvent event.

  • If the AutoDisable property is set to true, then the service object automatically disables the keyboard device when a DataEvent event is queued.

  • A queued DataEvent event can be delivered to the application when the DataEventEnabled property is set to true. Just before delivering this event, the service object copies the data into properties and disables additional data events by setting the DataEventEnabled property to false. This causes later input data to be queued by the service object while the application processes the current input and associated properties. When the application has finished the current input and is ready for more data, it enables events by setting DataEventEnabled property to true.

  • An ErrorEvent event (or events) is queued if the service object encounters an error while collecting or processing input, and it is delivered to the application when the DataEventEnabled property is true.

  • The DataCount property can be read to obtain the number of DataEvent events queued by the service object.

  • All input queued by the service object can be deleted by calling the ClearInput method.

Keyboard Translation

The POS keyboard’s service object must supply a mechanism for translating its internal key codes into user-defined codes that are returned by the data events. This translation should be end-user configurable.

Device Sharing

The POS keyboard is an exclusive-use device. This means that the following applies:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before the device begins reading input.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.PosKeyboard
Microsoft.PointOfService.BasicServiceObjects.PosKeyboardBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosKeyboard Members
Microsoft.PointOfService Namespace


PosKeyboard Members

PosKeyboard Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a UPOS Keyboard device.

The following tables list the members exposed by the PosKeyboard type.

Protected Constructors

Name | Description
PosKeyboard | Creates an instance of PosKeyboard class.
Top

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticKeyPressedCount | Incremented for each key-down action.
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
AutoDisable | Gets or sets a Boolean value that indicates whether POS for .NET automatically disables the device when data is received.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapKeyUp | Gets a Boolean value that indicates whether the keyboard device can generate both key-down and key-up input data, based on the value of the EventTypes property.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
DataCount | Gets the number of data events currently queued by the service object.
DataEventEnabled | Gets or sets a Boolean value that indicates whether the service object can deliver a queued event by raising a DataEvent event.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
EventTypes | Gets or sets the type of events that the application wants to receive.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
PosKeyData | Gets the value of the key from the last DataEvent event.
PosKeyEventType | Gets the type of the last keyboard event.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Indicates whether the PosKeyboard is an exclusive use device.
Top

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all device input that has been buffered.
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon)
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DataEvent | Raised by the service object to present input data from the device to the application.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
ErrorEvent | Raised by the service object to indicate an error has been detected while it is trying to read keyboard device input data.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

PosKeyboard Class
Microsoft.PointOfService Namespace


PosKeyboard Fields

PosKeyboard Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticKeyPressedCount | Incremented for each key-down action.
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

PosKeyboard Class
Microsoft.PointOfService Namespace


PosKeyboard.StatisticKeyPressedCount Field

PosKeyboard.StatisticKeyPressedCount Field |
 | See Also

1/18/2008

Incremented for each key-down action.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticKeyPressedCount As String
public const string StatisticKeyPressedCount
public:
literal String^ StatisticKeyPressedCount
public static final String StatisticKeyPressedCount
public const var StatisticKeyPressedCount : String

See Also

Reference

PosKeyboard Class
PosKeyboard Members
Microsoft.PointOfService Namespace


PosKeyboard Constructor

PosKeyboard Constructor |
 | See Also

1/18/2008

Creates an instance of PosKeyboard class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected PosKeyboard ()
protected:
PosKeyboard ()
protected PosKeyboard ()
protected function PosKeyboard ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

PosKeyboard Class
PosKeyboard Members
Microsoft.PointOfService Namespace


PosKeyboard Methods

PosKeyboard Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all device input that has been buffered.
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon )
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

PosKeyboard Class
Microsoft.PointOfService Namespace


PosKeyboard.ClearInput Method

PosKeyboard.ClearInput Method |
 | See Also

1/18/2008

Clears all device input that has been buffered.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearInput
public abstract void ClearInput ()
public:
virtual void ClearInput () abstract
public abstract void ClearInput ()
public abstract function ClearInput ()

Remarks

Any data events or input error events that were queued by the service object– usually waiting for the DataEventEnabled property to be set to true and the FreezeEvents property to be set to false, are also cleared.

The ClearInput property may cause a PosControlException exception to be thrown with the following ErrorCode:

Value | Meaning
Claimed | The device is claimed by another process.
NotClaimed | The device must be claimed before ClearInput can be used.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosKeyboard Class
PosKeyboard Members
Microsoft.PointOfService Namespace
PosCommon.FreezeEvents Property
DataEventEnabled


PosKeyboard Properties

PosKeyboard Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
AutoDisable | Gets or sets a Boolean value that indicates whether POS for .NET automatically disables the device when data is received.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapKeyUp | Gets a Boolean value that indicates whether the keyboard device can generate both key-down and key-up input data, based on the value of the EventTypes property.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
DataCount | Gets the number of data events currently queued by the service object.
DataEventEnabled | Gets or sets a Boolean value that indicates whether the service object can deliver a queued event by raising a DataEvent event.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
EventTypes | Gets or sets the type of events that the application wants to receive.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
PosKeyData | Gets the value of the key from the last DataEvent event.
PosKeyEventType | Gets the type of the last keyboard event.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Indicates whether the PosKeyboard is an exclusive use device.

See Also

Reference

PosKeyboard Class
Microsoft.PointOfService Namespace


PosKeyboard.AutoDisable Property

PosKeyboard.AutoDisable Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether POS for .NET automatically disables the device when data is received.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AutoDisable As Boolean
public abstract bool AutoDisable { get; set; }
public:
virtual property bool AutoDisable {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_AutoDisable ()

/** @property */
public abstract void set_AutoDisable (boolean value)

public abstract function get AutoDisable () : boolean

public abstract function set AutoDisable (value : boolean)

Remarks

The AutoDisable property provides the application with an additional option for controlling the receipt of input data. If the application wants to receive and process only one input, or only one input at a time, then this property can be set to true.

When true, the service object sets the DeviceEnabled property to false as soon as it receives and queues data to be raised as a DataEvent event. Before the service object raises any later events, the application must set the DeviceEnabled property back to true.

When false, the service object does not automatically disable the device when data is received; instead, it relies on the application to set the value of the DeviceEnabled property.

The AutoDisable property is typically initialized to false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosKeyboard Class
PosKeyboard Members
Microsoft.PointOfService Namespace
PosCommon.DeviceEnabled Property


PosKeyboard.CapKeyUp Property

PosKeyboard.CapKeyUp Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the keyboard device can generate both key-down and key-up input data, based on the value of the EventTypes property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapKeyUp As Boolean
public abstract bool CapKeyUp { get; }
public:
virtual property bool CapKeyUp {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapKeyUp ()

public abstract function get CapKeyUp () : boolean

Remarks

If true, the keyboard device can generate both key-down and key-up input data, based on the value of the EventTypes property.

If false, the keyboard device is only able to generate key-down input data.

CapKeyUp is typically initialized to false. The service object should then set CapKeyUp based on the capability of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosKeyboard Class
PosKeyboard Members
Microsoft.PointOfService Namespace
EventTypes


PosKeyboard.DataCount Property

PosKeyboard.DataCount Property |
 | See Also

1/18/2008

Gets the number of data events currently queued by the service object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DataCount As Integer
public abstract int DataCount { get; }
public:
virtual property int DataCount {
    int get () abstract;
}
/** @property */
public abstract int get_DataCount ()

public abstract function get DataCount () : int

Remarks

The application can read DataCount to determine whether additional input is queued from a device but has not yet been delivered (because of other application processing, freezing of events, or other causes).

DataCount is typically initialized to 0 (zero).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosKeyboard Class
PosKeyboard Members
Microsoft.PointOfService Namespace


PosKeyboard.DataEventEnabled Property

PosKeyboard.DataEventEnabled Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether the service object can deliver a queued event by raising a DataEvent event.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property DataEventEnabled As Boolean
public abstract bool DataEventEnabled { get; set; }
public:
virtual property bool DataEventEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_DataEventEnabled ()

/** @property */
public abstract void set_DataEventEnabled (boolean value)

public abstract function get DataEventEnabled () : boolean

public abstract function set DataEventEnabled (value : boolean)

Remarks

When set to true by the application, the service object can deliver a queued event by raising a DataEvent event.

Notice that conditions may exist that delay "immediate" delivery: If the FreezeEvents property is set to true, or if the AutoDisable property is set to true and the DeviceEnabled property is set to false.

When the DataEventEnabled property is set to false by the application, the service object queues data for later delivery to the application.

Note:
If an error occurs during input processing, the service object queues the error event but does not deliver it until the application sets DataEventEnabled to true.

DataEventEnabled is typically initialized to false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosKeyboard Class
PosKeyboard Members
Microsoft.PointOfService Namespace
PosKeyboard.AutoDisable Property
DataEvent
PosCommon.FreezeEvents Property
PosCommon.DeviceEnabled Property


PosKeyboard.EventTypes Property

PosKeyboard.EventTypes Property |
 | See Also

1/18/2008

Gets or sets the type of events that the application wants to receive.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property EventTypes As KeyboardEventType
public abstract KeyboardEventType EventTypes { get; set; }
public:
virtual property KeyboardEventType EventTypes {
    KeyboardEventType get () abstract;
    void set (KeyboardEventType value) abstract;
}
/** @property */
public abstract KeyboardEventType get_EventTypes ()

/** @property */
public abstract void set_EventTypes (KeyboardEventType value)

public abstract function get EventTypes () : KeyboardEventType

public abstract function set EventTypes (value : KeyboardEventType)

Remarks

EventTypes is set by the application immediately before receiving input, to tell the service object which types of key events it should generate. Possible types are defined by the KeyboardEventType enumerator.

EventTypes is typically initialized to KeyboardEventType.Down.

Accessing EventTypes may throw a PosControlException exception with the following errorcode:

Value | Meaning
Illegal | The EventTypes property was set to KeyboardEventType.DownUp but the CapKeyUp property is set to false. This indicates that key-up strokes are not captured.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosKeyboard Class
PosKeyboard Members
Microsoft.PointOfService Namespace
PosKeyboard.CapKeyUp Property
KeyboardEventType Enumeration


PosKeyboard.IsExclusiveUseDevice Property

PosKeyboard.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Indicates whether the PosKeyboard is an exclusive use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Remarks

Indicates whether the PosKeyboard is an exclusive-use device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosKeyboard Class
PosKeyboard Members
Microsoft.PointOfService Namespace


PosKeyboard.PosKeyData Property

PosKeyboard.PosKeyData Property |
 | See Also

1/18/2008

Gets the value of the key from the last DataEvent event.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property PosKeyData As Integer
public abstract int PosKeyData { get; }
public:
virtual property int PosKeyData {
    int get () abstract;
}
/** @property */
public abstract int get_PosKeyData ()

public abstract function get PosKeyData () : int

Remarks

The value is defined as a logical key code in the upper 16 bits and a scan code in the lower 16 bits, where the values do not have to match a standard computer keyboard's values.

The application may treat the value of PosKeyData as device-independent, assuming that the system installer has configured the keyboard’s service object to translate internal key codes to the codes expected by the application. Such configuration is service object-specific.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosKeyboard Class
PosKeyboard Members
Microsoft.PointOfService Namespace
DataEvent


PosKeyboard.PosKeyEventType Property

PosKeyboard.PosKeyEventType Property |
 | See Also

1/18/2008

Gets the type of the last keyboard event.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property PosKeyEventType As KeyEvent
public abstract KeyEvent PosKeyEventType { get; }
public:
virtual property KeyEvent PosKeyEventType {
    KeyEvent get () abstract;
}
/** @property */
public abstract KeyEvent get_PosKeyEventType ()

public abstract function get PosKeyEventType () : KeyEvent

Remarks

Possible types are defined by the KeyEvent enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosKeyboard Class
PosKeyboard Members
Microsoft.PointOfService Namespace
KeyDown
KeyUp
KeyEvent Enumeration


PosKeyboard Events

PosKeyboard Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DataEvent | Raised by the service object to present input data from the device to the application.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
ErrorEvent | Raised by the service object to indicate an error has been detected while it is trying to read keyboard device input data.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

PosKeyboard Class
Microsoft.PointOfService Namespace


PosKeyboard.DataEvent Event

PosKeyboard.DataEvent Event |
 | See Also

1/18/2008

Raised by the service object to present input data from the device to the application.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event DataEvent As DataEventHandler
public abstract event DataEventHandler DataEvent
public:
virtual event DataEventHandler^ DataEvent {
    void add (DataEventHandler^ value) abstract;
    void remove (DataEventHandler^ value) abstract;
}
/** @event */
public abstract void add_DataEvent (DataEventHandler value)

/** @event */
public abstract void remove_DataEvent (DataEventHandler value)

Remarks

The DataEventArgs.Status property is always zero. The logical key number is put in the PosKeyData property and the event type is put in the PosKeyEventType property, before the DataEvent event is delivered.

See Also

Reference

PosKeyboard Class
PosKeyboard Members
Microsoft.PointOfService Namespace
DataEventArgs Class
DataEventHandler Delegate


PosKeyboard.ErrorEvent Event

PosKeyboard.ErrorEvent Event |
 | See Also

1/18/2008

Raised by the service object to indicate an error has been detected while it is trying to read keyboard device input data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event ErrorEvent As DeviceErrorEventHandler
public abstract event DeviceErrorEventHandler ErrorEvent
public:
virtual event DeviceErrorEventHandler^ ErrorEvent {
    void add (DeviceErrorEventHandler^ value) abstract;
    void remove (DeviceErrorEventHandler^ value) abstract;
}
/** @event */
public abstract void add_ErrorEvent (DeviceErrorEventHandler value)

/** @event */
public abstract void remove_ErrorEvent (DeviceErrorEventHandler value)

Remarks

The DeviceErrorEventArgs.ErrorLocus property can be one of the following:

Value | Meaning
Input | Error occurred while collecting or processing event-driven input. No input data is available.
InputData | Error occurred while collecting or processing event-driven input and some previously buffered data is available.

The DeviceErrorEventArgs.ErrorResponse property is preset by the service object to a default value, based on the DeviceErrorEventArgs.ErrorLocus. The application may change it to one of the following:

Value | Meaning
Clear | Clears the buffered input data. Typically, the application has called the ClearInput method to clear all input buffers and queued events. The error state is then exited. Default when locus is Input.
ContinueInput | Use only when locus is InputData. Acknowledges the error and directs the service object to continue to process. The service object remains in the error state and delivers additional data events as directed by the DataEventEnabled property. When all input has been delivered and the DataEventEnabled property is again set to true, then another ErrorEvent is delivered with locus Input. Default when locus is InputData.
Note:
Input error events are not delivered until the application has set the DataEventEnabled property to true. This indicates that it is ready to receive more input.

See Also

Reference

PosKeyboard Class
PosKeyboard Members
Microsoft.PointOfService Namespace
DeviceErrorEventHandler Delegate
PosKeyboard.DataEventEnabled Property
DeviceErrorEventArgs Class


PosLibraryException Class

PosLibraryException Class |
 | See Also Members

1/18/2008

Defines the programmatic interface used by PosExplorer class to throw exceptions.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<SerializableAttribute> _
Public Class PosLibraryException
    Inherits PosException
[SerializableAttribute]
public class PosLibraryException : PosException
[SerializableAttribute]
public ref class PosLibraryException : public PosException
/** @attribute SerializableAttribute() */
public class PosLibraryException extends PosException
SerializableAttribute
public class PosLibraryException extends PosException

Remarks

The application should use PosLibraryException class to retrieve iinformation about errors generated during PosExplorer class operations.

Inheritance Hierarchy

System.Object
System.Exception
Microsoft.PointOfService.PosException
Microsoft.PointOfService.PosLibraryException

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosLibraryException Members
Microsoft.PointOfService Namespace


PosLibraryException Members

PosLibraryException Members |
 | See Also Constructors Methods Properties

1/18/2008

Defines the programmatic interface used by PosExplorer class to throw exceptions.

The following tables list the members exposed by the PosLibraryException type.

Public Constructors (see also Protected Constructors )

Name | Description
PosLibraryException | Overloaded.
Top

Protected Constructors

Name | Description
PosLibraryException | Overloaded.
Top

Public Properties (see also Protected Properties )

Name | Description
Data | (inherited from Exception )
HelpLink | (inherited from Exception )
InnerException | (inherited from Exception )
Message | (inherited from Exception )
Source | (inherited from Exception )
StackTrace | (inherited from Exception )
TargetSite | (inherited from Exception )
Top

Protected Properties

Name | Description
HResult | (inherited from Exception )
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetBaseException | (inherited from Exception )
GetHashCode | (inherited from Object )
GetObjectData | (inherited from PosException )
GetType | (inherited from Exception )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Exception )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

PosLibraryException Class
Microsoft.PointOfService Namespace


PosLibraryException Constructor

PosLibraryException Constructor |
 | See Also

1/18/2008

Overload List

Name | Description
PosLibraryException () |
PosLibraryException (String) | Initializes a new instance of the PosLibraryException class with a specified error message.
PosLibraryException (SerializationInfo, StreamingContext) | Initializes a new instance of the PosLibraryException class with serialized data.
PosLibraryException (String, Exception) | Initializes a new instance of the PosLibraryException class with a specified error message and a reference to the inner exception that is the cause of this exception.

See Also

Reference

PosLibraryException Class
PosLibraryException Members
Microsoft.PointOfService Namespace


PosLibraryException Constructor ()

PosLibraryException Constructor () |
 | See Also

1/18/2008

Initializes a new instance of the PosLibraryException Class .

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New

public PosLibraryException ()

public:
PosLibraryException ()

public PosLibraryException ()

public function PosLibraryException ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

PosLibraryException Class
PosLibraryException Members
Microsoft.PointOfService Namespace


PosLibraryException Constructor (String)

PosLibraryException Constructor (String) |
 | See Also

1/18/2008

Initializes a new instance of the PosLibraryException class with a specified error message.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    message As String _
)
public PosLibraryException (
    string message
)
public:
PosLibraryException (
    String^ message
)
public PosLibraryException (
    String message
)
public function PosLibraryException (
    message : String
)

Parameters

message

The error message that explains the reason for the exception.

See Also

Reference

PosLibraryException Class
PosLibraryException Members
Microsoft.PointOfService Namespace


PosLibraryException Constructor (SerializationInfo, StreamingContext)

PosLibraryException Constructor (SerializationInfo, StreamingContext) |
 | See Also

1/18/2008

Initializes a new instance of the PosLibraryException class with serialized data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New ( _
    serializationInfo As SerializationInfo, _
    streamingContext As StreamingContext _
)
protected PosLibraryException (
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
protected:
PosLibraryException (
    SerializationInfo^ serializationInfo,
    StreamingContext streamingContext
)
protected PosLibraryException (
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
protected function PosLibraryException (
    serializationInfo : SerializationInfo,
    streamingContext : StreamingContext
)

Parameters

serializationInfo

The SerializationInfo that holds the serialized object data about the exception being thrown.

streamingContext

The StreamingContext that contains contextual information about the source or destination.

See Also

Reference

PosLibraryException Class
PosLibraryException Members
Microsoft.PointOfService Namespace
System.Runtime.Serialization.SerializationInfo
System.Runtime.Serialization.StreamingContext


PosLibraryException Constructor (String, Exception)

PosLibraryException Constructor (String, Exception) |
 | See Also

1/18/2008

Initializes a new instance of the PosLibraryException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    message As String, _
    e As Exception _
)
public PosLibraryException (
    string message,
    Exception e
)
public:
PosLibraryException (
    String^ message,
    Exception^ e
)
public PosLibraryException (
    String message,
    Exception e
)
public function PosLibraryException (
    message : String,
    e : Exception
)

Parameters

message

The error message that explains the reason for the exception.

e

The exception that is the cause of the current exception. If the e parameter is not a null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

PosLibraryException Class
PosLibraryException Members
Microsoft.PointOfService Namespace


PosLibraryException Methods

PosLibraryException Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetBaseException | (inherited from Exception )
GetHashCode | (inherited from Object )
GetObjectData | (inherited from PosException )
GetType | (inherited from Exception )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Exception )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

PosLibraryException Class
Microsoft.PointOfService Namespace


PosLibraryException Properties

PosLibraryException Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
Data | (inherited from Exception )
HelpLink | (inherited from Exception )
InnerException | (inherited from Exception )
Message | (inherited from Exception )
Source | (inherited from Exception )
StackTrace | (inherited from Exception )
TargetSite | (inherited from Exception )

Protected Properties

Name | Description
HResult | (inherited from Exception )

See Also

Reference

PosLibraryException Class
Microsoft.PointOfService Namespace


PosManagementException Class

PosManagementException Class |
 | See Also Members

1/18/2008

Defines the programmatic interface used by POS for .NET management APIs to throw exceptions.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<SerializableAttribute> _
Public Class PosManagementException
    Inherits PosException
[SerializableAttribute]
public class PosManagementException : PosException
[SerializableAttribute]
public ref class PosManagementException : public PosException
/** @attribute SerializableAttribute() */
public class PosManagementException extends PosException
SerializableAttribute
public class PosManagementException extends PosException

Remarks

The application should use PosManagementException class to retrieve information about errors generated by the POS for .NET management APIs.

Inheritance Hierarchy

System.Object
System.Exception
Microsoft.PointOfService.PosException
Microsoft.PointOfService.PosManagementException

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosManagementException Members
Microsoft.PointOfService Namespace


PosManagementException Members

PosManagementException Members |
 | See Also Constructors Methods Properties

1/18/2008

Defines the programmatic interface used by POS for .NET management APIs to throw exceptions.

The following tables list the members exposed by the PosManagementException type.

Public Constructors (see also Protected Constructors )

Name | Description
PosManagementException | Overloaded.
Top

Protected Constructors

Name | Description
PosManagementException | Overloaded.
Top

Public Properties (see also Protected Properties )

Name | Description
Data | (inherited from Exception )
HelpLink | (inherited from Exception )
InnerException | (inherited from Exception )
Message | (inherited from Exception )
Source | (inherited from Exception )
StackTrace | (inherited from Exception )
TargetSite | (inherited from Exception )
Top

Protected Properties

Name | Description
HResult | (inherited from Exception )
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetBaseException | (inherited from Exception )
GetHashCode | (inherited from Object )
GetObjectData | (inherited from PosException )
GetType | (inherited from Exception )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Exception )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

PosManagementException Class
Microsoft.PointOfService Namespace


PosManagementException Constructor

PosManagementException Constructor |
 | See Also

1/18/2008

Overload List

Name | Description
PosManagementException () |
PosManagementException (String) | Initializes a new instance of the PosManagementException class with a specified error message.
PosManagementException (SerializationInfo, StreamingContext) | Initializes a new instance of the PosManagementException class with serialized data.
PosManagementException (String, Exception) | Initializes a new instance of the PosManagementException class with a specified error message and a reference to the inner exception that is the cause of this exception.

See Also

Reference

PosManagementException Class
PosManagementException Members
Microsoft.PointOfService Namespace


PosManagementException Constructor ()

PosManagementException Constructor () |
 | See Also

1/18/2008

Initializes a new instance of the PosManagementException Class .

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New

public PosManagementException ()

public:
PosManagementException ()

public PosManagementException ()

public function PosManagementException ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

PosManagementException Class
PosManagementException Members
Microsoft.PointOfService Namespace


PosManagementException Constructor (String)

PosManagementException Constructor (String) |
 | See Also

1/18/2008

Initializes a new instance of the PosManagementException class with a specified error message.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    message As String _
)
public PosManagementException (
    string message
)
public:
PosManagementException (
    String^ message
)
public PosManagementException (
    String message
)
public function PosManagementException (
    message : String
)

Parameters

message

The error message that explains the reason for the exception.

See Also

Reference

PosManagementException Class
PosManagementException Members
Microsoft.PointOfService Namespace


PosManagementException Constructor (SerializationInfo, StreamingContext)

PosManagementException Constructor (SerializationInfo, StreamingContext) |
 | See Also

1/18/2008

Initializes a new instance of the PosManagementException class with serialized data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New ( _
    serializationInfo As SerializationInfo, _
    streamingContext As StreamingContext _
)
protected PosManagementException (
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
protected:
PosManagementException (
    SerializationInfo^ serializationInfo,
    StreamingContext streamingContext
)
protected PosManagementException (
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
protected function PosManagementException (
    serializationInfo : SerializationInfo,
    streamingContext : StreamingContext
)

Parameters

serializationInfo

The SerializationInfo that holds the serialized object data about the exception being thrown.

streamingContext

The StreamingContext that contains contextual information about the source or destination.

See Also

Reference

PosManagementException Class
PosManagementException Members
Microsoft.PointOfService Namespace
System.Runtime.Serialization.SerializationInfo
System.Runtime.Serialization.StreamingContext


PosManagementException Constructor (String, Exception)

PosManagementException Constructor (String, Exception) |
 | See Also

1/18/2008

Initializes a new instance of the PosManagementException class with a specified error message and a reference to the inner exception that is the cause of this exception.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    message As String, _
    e As Exception _
)
public PosManagementException (
    string message,
    Exception e
)
public:
PosManagementException (
    String^ message,
    Exception^ e
)
public PosManagementException (
    String message,
    Exception e
)
public function PosManagementException (
    message : String,
    e : Exception
)

Parameters

message

The error message that explains the reason for the exception.

e

The exception that is the cause of the current exception. If the e parameter is not a null reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

See Also

Reference

PosManagementException Class
PosManagementException Members
Microsoft.PointOfService Namespace


PosManagementException Methods

PosManagementException Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetBaseException | (inherited from Exception )
GetHashCode | (inherited from Object )
GetObjectData | (inherited from PosException )
GetType | (inherited from Exception )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Exception )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

PosManagementException Class
Microsoft.PointOfService Namespace


PosManagementException Properties

PosManagementException Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
Data | (inherited from Exception )
HelpLink | (inherited from Exception )
InnerException | (inherited from Exception )
Message | (inherited from Exception )
Source | (inherited from Exception )
StackTrace | (inherited from Exception )
TargetSite | (inherited from Exception )

Protected Properties

Name | Description
HResult | (inherited from Exception )

See Also

Reference

PosManagementException Class
Microsoft.PointOfService Namespace


PosPower Class

PosPower Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a UPOS power system device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class PosPower
    Inherits PosCommon
public abstract class PosPower : PosCommon
public ref class PosPower abstract : public PosCommon
public abstract class PosPower extends PosCommon
public abstract class PosPower extends PosCommon

Remarks

Capabilities

The PosPower device class has the following capabilities:

  • Supports a command to "shut down" the system.

  • Supports a command to restart the system.

  • Supports a command to "suspend" the system.

  • Supports a command to have the system go to standby.

  • Supports accessing a power-handling mechanism of the underlying operating system and hardware.

  • Informs the application if a power failure has occurred.

  • Informs the application about battery level.

  • Informs the application if the UPS charge state has changed.

  • Informs the application about a high CPU temperature.

  • Informs the application about a stopped CPU fan.

  • Informs the application if an operating-system-dependent enforced shutdown mechanism is processed.

  • Allows the application to shut down the POS terminal, after saving application data locally or transferring application data to a server.

  • Informs the application about an initiated shutdown.

Model

The general model of PosPower is based on the power model of each POS device. The same common properties are used but all states relate to the POS terminal itself and not to a peripheral device.

There are three states of the PosPower device:

  • ONLINE. The POS terminal is turned on and ready for use. This is the "operational" state.

  • OFF. The POS terminal is turned off or detached from the power supply. The POS terminal runs on battery power support. This is the power failure situation.

  • OFFLINE. The POS terminal is turned on, but it is running in a "lower-power-consumption" mode. It may have to be put online by pressing a button or a key or doing something else to wake up the system.

Power reporting occurs only while the device is open and enabled, with power notification tiurned on.

In a power failure situation, when the PosPower device is in the OFF state, the POS terminal is shut down automatically after the last application has closed the PosPower device or when the time specified by EnforcedShutdownDelayTime has elapsed.

A call to the ShutdownPos method always shuts down the POS terminal independent of the system power state.

Support has been added for battery-powered devices. Additional properties report battery levels and power sources and allow for the setting of low and critically low battery levels. The POSPower device also includes the ability to request or respond to a request to enter the Standby and Suspend states. The model does not try to duplicate other power management models such as APM and ACPI, but leaves those implementation details to the provider. Generally, the Suspend state consumes less power than the Standby state, which in turn consumes less power than the On state.

Device Sharing

PosPower is a shareable device. Its device-sharing rules are as follows:

  • After opening and enabling the device, the application may access all properties and methods and receives status update events.

  • If more than one application has opened and enabled the device, all applications may access its properties and methods. Status update events are raised to all applications.

  • If one application claims the PosPower device, only that application may call the ShutdownPOS method. This feature provides a degree of security in that these methods may effectively be restricted to the main POS application if that application claims the device at startup.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.PosPower
Microsoft.PointOfService.BasicServiceObjects.PosPowerBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPower Members
Microsoft.PointOfService Namespace


PosPower Members

PosPower Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a UPOS power system device.

The following tables list the members exposed by the PosPower type.

Protected Constructors

Name | Description
PosPower | Creates an instance of the PosPower class.
Top

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusBatteryCapacityRemaining | Indicates the BatteryCapacityRemaining property has been updated.
StatusBatteryCritical | Indicates the remaining battery capacity is at or below the critically low battery threshold and the system is operating from the battery.
StatusBatteryLow | Indicates the remaining battery capacity is at or below the low battery threshold and the system is operating from the battery.
StatusFanRunning | Indicates the fan is running.
StatusFanStopped | Indicates the fan has stopped.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusPowerSource | Indicates the PowerSource property has been updated.
StatusRestart | Indicates the system will restart immediately.
StatusShutDown | Indicates the device has shut down.
StatusStandby | Indicates the system is requesting a transition to the Standby state.
StatusSuspend | Indicates the system is requesting a transition to the Suspend state.
StatusTemperatureHigh | Indicates the device is running at a high temperature.
StatusTemperatureOK | Indicates the device's temperature is within acceptable range.
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
StatusUpsCritical | Indicates the UPS battery is in a critical state.
StatusUpsFull | Indicates the UPS battery is almost full charge.
StatusUpsLow | Indicates the UPS battery is almost depleted of charge.
StatusUpsWarning | Indicates the UPS battery is near 50 percent charge.
StatusUserStandby | Indicates the system is requesting a transition to the Standby state because of user input.
StatusUserSuspend | Indicates the system is requesting a transition to the Suspend state because of user input.
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
BatteryCapacityRemaining | Gets a value between 0 and 100 that represents the percentage of remaining battery capacity.
BatteryCriticallyLowThreshold | Gets or sets the threshold percentage at which the service object generates a StatusUpdateEvent event of StatusBatteryCritical.
BatteryLowThreshold | Gets or sets the threshold percentage at which the service object generates a StatusUpdateEvent event of StatusBatteryLow.
CapBatteryCapacityRemaining | Gets a Boolean value that indicates whether the device can provide information about the remaining capacity of the battery.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapFanAlarm | Gets a Boolean value that indicates whether the device can detect the CPU fan is stopped.
CapHeatAlarm | Gets a Boolean value that indicates whether the device can detect if the CPU is running at a high temperature.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapQuickCharge | Gets a Boolean value that indicates whether power management allows charging the battery with a quick method.
CapRestartPos | Gets a Boolean value that indicates whether the device can explicitly restart the POS system.
CapShutdownPos | Gets a Boolean value that indicates whether the device can explicitly shut down the POS system.
CapStandbyPos | Gets a Boolean value that indicates whether the device can request that the POS system enter a Standby state.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapSuspendPos | Gets a Boolean value that indicates whether the device can request that the POS system enter a Suspend state.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CapUpsChargeState | Gets one or more UPS charge states.
CapVariableBatteryCriticallyLowThreshold | Gets a Boolean value that indicates whether the device supports a variable threshold for critically low battery capacity reporting that can be set by the POS application.
CapVariableBatteryLowThreshold | Gets a Boolean value that indicates whether the device supports a variable threshold for low battery capacity reporting that can be set by the POS application.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
EnforcedShutdownDelayTime | Gets or sets an integer value for a built-in mechanism to shut down the POS terminal.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
PowerFailDelayTime | Gets the time in milliseconds for power failure intervals.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerSource | Gets the current power source.
PowerState | Gets the current power condition. (inherited from PosCommon)
QuickChargeMode | Gets a Boolean value that indicates whether the battery is being recharged in a quick charge mode.
QuickChargeTime | Gets the remaining time for loading the battery.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
UpsChargeState | Gets the UPS charge state.
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether the PosPower device is exclusive-use.
Top

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon)
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RestartPos | Restarts the POS system independent of the power state.
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ShutdownPos | Shuts down the POS system independent of the power state.
StandbyPos | Requests that the POS system be put in the Standby state or responds to a request to put the system in the Standby state.
SuspendPos | Requests that the POS system be put in the Suspend state or responds to a request to put the system in the Suspend state.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

PosPower Class
Microsoft.PointOfService Namespace


PosPower Fields

PosPower Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusBatteryCapacityRemaining | Indicates the BatteryCapacityRemaining property has been updated.
StatusBatteryCritical | Indicates the remaining battery capacity is at or below the critically low battery threshold and the system is operating from the battery.
StatusBatteryLow | Indicates the remaining battery capacity is at or below the low battery threshold and the system is operating from the battery.
StatusFanRunning | Indicates the fan is running.
StatusFanStopped | Indicates the fan has stopped.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusPowerSource | Indicates the PowerSource property has been updated.
StatusRestart | Indicates the system will restart immediately.
StatusShutDown | Indicates the device has shut down.
StatusStandby | Indicates the system is requesting a transition to the Standby state.
StatusSuspend | Indicates the system is requesting a transition to the Suspend state.
StatusTemperatureHigh | Indicates the device is running at a high temperature.
StatusTemperatureOK | Indicates the device's temperature is within acceptable range.
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
StatusUpsCritical | Indicates the UPS battery is in a critical state.
StatusUpsFull | Indicates the UPS battery is almost full charge.
StatusUpsLow | Indicates the UPS battery is almost depleted of charge.
StatusUpsWarning | Indicates the UPS battery is near 50 percent charge.
StatusUserStandby | Indicates the system is requesting a transition to the Standby state because of user input.
StatusUserSuspend | Indicates the system is requesting a transition to the Suspend state because of user input.
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

PosPower Class
Microsoft.PointOfService Namespace


PosPower.StatusBatteryCapacityRemaining Field

PosPower.StatusBatteryCapacityRemaining Field |
 | See Also

1/18/2008

Indicates the BatteryCapacityRemaining property has been updated.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusBatteryCapacityRemaining As Integer
public const int StatusBatteryCapacityRemaining
public:
literal int StatusBatteryCapacityRemaining
public static final int StatusBatteryCapacityRemaining
public const var StatusBatteryCapacityRemaining : int

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.StatusBatteryCritical Field

PosPower.StatusBatteryCritical Field |
 | See Also

1/18/2008

Indicates the remaining battery capacity is at or below the critically low battery threshold and the system is operating from the battery.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusBatteryCritical As Integer
public const int StatusBatteryCritical
public:
literal int StatusBatteryCritical
public static final int StatusBatteryCritical
public const var StatusBatteryCritical : int

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.StatusBatteryLow Field

PosPower.StatusBatteryLow Field |
 | See Also

1/18/2008

Indicates the remaining battery capacity is at or below the low battery threshold and the system is operating from the battery.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusBatteryLow As Integer
public const int StatusBatteryLow
public:
literal int StatusBatteryLow
public static final int StatusBatteryLow
public const var StatusBatteryLow : int

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.StatusFanRunning Field

PosPower.StatusFanRunning Field |
 | See Also

1/18/2008

Indicates the fan is running.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusFanRunning As Integer
public const int StatusFanRunning
public:
literal int StatusFanRunning
public static final int StatusFanRunning
public const var StatusFanRunning : int

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.StatusFanStopped Field

PosPower.StatusFanStopped Field |
 | See Also

1/18/2008

Indicates the fan has stopped.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusFanStopped As Integer
public const int StatusFanStopped
public:
literal int StatusFanStopped
public static final int StatusFanStopped
public const var StatusFanStopped : int

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.StatusPowerSource Field

PosPower.StatusPowerSource Field |
 | See Also

1/18/2008

Indicates the PowerSource property has been updated.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusPowerSource As Integer
public const int StatusPowerSource
public:
literal int StatusPowerSource
public static final int StatusPowerSource
public const var StatusPowerSource : int

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.StatusRestart Field

PosPower.StatusRestart Field |
 | See Also

1/18/2008

Indicates the system will restart immediately.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusRestart As Integer
public const int StatusRestart
public:
literal int StatusRestart
public static final int StatusRestart
public const var StatusRestart : int

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.StatusShutDown Field

PosPower.StatusShutDown Field |
 | See Also

1/18/2008

Indicates the device has shut down.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusShutDown As Integer
public const int StatusShutDown
public:
literal int StatusShutDown
public static final int StatusShutDown
public const var StatusShutDown : int

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.StatusStandby Field

PosPower.StatusStandby Field |
 | See Also

1/18/2008

Indicates the system is requesting a transition to the Standby state.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusStandby As Integer
public const int StatusStandby
public:
literal int StatusStandby
public static final int StatusStandby
public const var StatusStandby : int

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.StatusSuspend Field

PosPower.StatusSuspend Field |
 | See Also

1/18/2008

Indicates the system is requesting a transition to the Suspend state.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusSuspend As Integer
public const int StatusSuspend
public:
literal int StatusSuspend
public static final int StatusSuspend
public const var StatusSuspend : int

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.StatusTemperatureHigh Field

PosPower.StatusTemperatureHigh Field |
 | See Also

1/18/2008

Indicates the device is running at a high temperature.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusTemperatureHigh As Integer
public const int StatusTemperatureHigh
public:
literal int StatusTemperatureHigh
public static final int StatusTemperatureHigh
public const var StatusTemperatureHigh : int

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.StatusTemperatureOK Field

PosPower.StatusTemperatureOK Field |
 | See Also

1/18/2008

Indicates the device's temperature is within acceptable range.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusTemperatureOK As Integer
public const int StatusTemperatureOK
public:
literal int StatusTemperatureOK
public static final int StatusTemperatureOK
public const var StatusTemperatureOK : int

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.StatusUpsCritical Field

PosPower.StatusUpsCritical Field |
 | See Also

1/18/2008

Indicates the UPS battery is in a critical state.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusUpsCritical As Integer
public const int StatusUpsCritical
public:
literal int StatusUpsCritical
public static final int StatusUpsCritical
public const var StatusUpsCritical : int

Remarks

When the UPS battery is in this state, it may be disconnected at any time without additional warning.

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.StatusUpsFull Field

PosPower.StatusUpsFull Field |
 | See Also

1/18/2008

Indicates the UPS battery is almost full charge.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusUpsFull As Integer
public const int StatusUpsFull
public:
literal int StatusUpsFull
public static final int StatusUpsFull
public const var StatusUpsFull : int

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.StatusUpsLow Field

PosPower.StatusUpsLow Field |
 | See Also

1/18/2008

Indicates the UPS battery is almost depleted of charge.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusUpsLow As Integer
public const int StatusUpsLow
public:
literal int StatusUpsLow
public static final int StatusUpsLow
public const var StatusUpsLow : int

Remarks

Application shutdown should be started to make sure that it is completed before the battery charge is depleted. A minimum of two minutes of normal system operation can be assumed when this state is entered, unless this is the first state reported upon entering the "Off" power state.

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.StatusUpsWarning Field

PosPower.StatusUpsWarning Field |
 | See Also

1/18/2008

Indicates the UPS battery is near 50 percent charge.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusUpsWarning As Integer
public const int StatusUpsWarning
public:
literal int StatusUpsWarning
public static final int StatusUpsWarning
public const var StatusUpsWarning : int

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.StatusUserStandby Field

PosPower.StatusUserStandby Field |
 | See Also

1/18/2008

Indicates the system is requesting a transition to the Standby state because of user input.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusUserStandby As Integer
public const int StatusUserStandby
public:
literal int StatusUserStandby
public static final int StatusUserStandby
public const var StatusUserStandby : int

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.StatusUserSuspend Field

PosPower.StatusUserSuspend Field |
 | See Also

1/18/2008

Indicates the system is requesting a transition to the Suspend state because of user input.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusUserSuspend As Integer
public const int StatusUserSuspend
public:
literal int StatusUserSuspend
public static final int StatusUserSuspend
public const var StatusUserSuspend : int

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower Constructor

PosPower Constructor |
 | See Also

1/18/2008

Creates an instance of the PosPower class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected PosPower ()
protected:
PosPower ()
protected PosPower ()
protected function PosPower ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower Methods

PosPower Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon )
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RestartPos | Restarts the POS system independent of the power state.
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ShutdownPos | Shuts down the POS system independent of the power state.
StandbyPos | Requests that the POS system be put in the Standby state or responds to a request to put the system in the Standby state.
SuspendPos | Requests that the POS system be put in the Suspend state or responds to a request to put the system in the Suspend state.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

PosPower Class
Microsoft.PointOfService Namespace


PosPower.RestartPos Method

PosPower.RestartPos Method |
 | See Also

1/18/2008

Restarts the POS system independent of the power state.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Sub RestartPos
public virtual void RestartPos ()
public:
virtual void RestartPos ()
public void RestartPos ()
public function RestartPos ()

Remarks

If the Claimed property for the PosPower device is set to true and an application that does not have the device claimed calls RestartPos, the service object will throw a PosControlException exception.

If the CapRestartPos property is false and the application tries to call RestartPos, the service object will throw an Illegal exception.

When the service object starts the system restart, it sends a StatusUpdateEvent event of StatusRestart to one or all applications, depending on whether the device is currently shareable.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.ShutdownPos Method

PosPower.ShutdownPos Method |
 | See Also

1/18/2008

Shuts down the POS system independent of the power state.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ShutdownPos
public abstract void ShutdownPos ()
public:
virtual void ShutdownPos () abstract
public abstract void ShutdownPos ()
public abstract function ShutdownPos ()

Remarks

If the Claimed property for the PosPower device is set to true and an application that does not have the device claimed calls ShutdownPos, the service object throws a PosControlException exception. We recommend that in a power failure situation, an application should call ShutdownPos after it saves all data and setting the application to a defined state.

If the CapShutdownPos property is false and the application tries to call the ShutdownPos method, the service object throws an Illegal exception.

If the EnforcedShutdownDelayTime property specifies a time greater than zero and the application did not call the ShutdownPos method within the time specified in EnforcedShutdownDelayTime, the system shuts down automatically. This mechanism can be provided by an underlying operating system to prevent the battery from being completely drained.

When the service object starts the system shutdown, it sends a StatusUpdateEvent event of StatusRestart to one or all applications, depending on whether the device is currently shareable.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.StandbyPos Method

PosPower.StandbyPos Method |
 | See Also

1/18/2008

Requests that the POS system be put in the Standby state or responds to a request to put the system in the Standby state.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Sub StandbyPos ( _
    reason As SystemStateChangeReason _
)
public virtual void StandbyPos (
    SystemStateChangeReason reason
)
public:
virtual void StandbyPos (
    SystemStateChangeReason reason
)
public void StandbyPos (
    SystemStateChangeReason reason
)
public function StandbyPos (
    reason : SystemStateChangeReason
)

Parameters

reason

Specifies the reason StandbyPos has been called. Possible values are defined by the SystemStateChangeReason enumeration.

Remarks

The POS application calls StandbyPos to request that the POS system be put in the Standby state or to reply to a StatusUpdateEvent event of StatusStandby, allowing or denying the request. The application sets the reason parameter to the appropriate value, based on whether it is responding to an event or requesting the status change. Possible reasons, as defined by the SystemStateChangeReason enumeration, are as follows:

Member | Description
Allow | The request should be allowed.
Deny | The request should be denied.
Request | The system should enter the requested Standby or Suspend state.

If the Claimed property for the PosPower device is set to true and an application that does not have the device claimed calls StandbyPos, the service object throws a PosControlException exception.

If the CapStandbyPos property is false and the application tries to call StandbyPos, the service object throws an Illegal exception.

When the service object starts a change to Standby state, it sends a StatusUpdateEvent of StatusStandby to one or all applications, depending on whether the device is currently shareable.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.SuspendPos Method

PosPower.SuspendPos Method |
 | See Also

1/18/2008

Requests that the POS system be put in the Suspend state or responds to a request to put the system in the Suspend state.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Sub SuspendPos ( _
    reason As SystemStateChangeReason _
)
public virtual void SuspendPos (
    SystemStateChangeReason reason
)
public:
virtual void SuspendPos (
    SystemStateChangeReason reason
)
public void SuspendPos (
    SystemStateChangeReason reason
)
public function SuspendPos (
    reason : SystemStateChangeReason
)

Parameters

reason

Specifies the reason SuspendPos has been called. Possible values are defined by the SystemStateChangeReason enumeration.

Remarks

The POS application calls SuspendPos to request that the POS system be put in the Suspend state or to respond to a StatusUpdateEvent event of StatusSuspend, allowing or denying the request. The application sets the reason parameter to the appropriate value, based on whether it is responding to an event or requesting the status change. Possible reasons, as defined by the SystemStateChangeReason enumeration, are as follows:

Member | Description
Allow | The request should be allowed.
Deny | The request should be denied.
Request | The system should enter the requested Standby or Suspend state.

If the Claimed property for the PosPower device is set to true and an application that does not have the device claimed calls SuspendPos, the service object throws a PosControlException exception.

If the CapSuspendPos property is false and the application tries to call SuspendPos, the service object throws an Illegal exception.

When the service object starts a change to Suspend state, it sends a StatusUpdateEvent of StatusSuspend to one or all applications, depending on whether the device is currently shareable.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower Properties

PosPower Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
BatteryCapacityRemaining | Gets a value between 0 and 100 that represents the percentage of remaining battery capacity.
BatteryCriticallyLowThreshold | Gets or sets the threshold percentage at which the service object generates a StatusUpdateEvent event of StatusBatteryCritical.
BatteryLowThreshold | Gets or sets the threshold percentage at which the service object generates a StatusUpdateEvent event of StatusBatteryLow.
CapBatteryCapacityRemaining | Gets a Boolean value that indicates whether the device can provide information about the remaining capacity of the battery.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapFanAlarm | Gets a Boolean value that indicates whether the device can detect the CPU fan is stopped.
CapHeatAlarm | Gets a Boolean value that indicates whether the device can detect if the CPU is running at a high temperature.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapQuickCharge | Gets a Boolean value that indicates whether power management allows charging the battery with a quick method.
CapRestartPos | Gets a Boolean value that indicates whether the device can explicitly restart the POS system.
CapShutdownPos | Gets a Boolean value that indicates whether the device can explicitly shut down the POS system.
CapStandbyPos | Gets a Boolean value that indicates whether the device can request that the POS system enter a Standby state.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapSuspendPos | Gets a Boolean value that indicates whether the device can request that the POS system enter a Suspend state.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CapUpsChargeState | Gets one or more UPS charge states.
CapVariableBatteryCriticallyLowThreshold | Gets a Boolean value that indicates whether the device supports a variable threshold for critically low battery capacity reporting that can be set by the POS application.
CapVariableBatteryLowThreshold | Gets a Boolean value that indicates whether the device supports a variable threshold for low battery capacity reporting that can be set by the POS application.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
EnforcedShutdownDelayTime | Gets or sets an integer value for a built-in mechanism to shut down the POS terminal.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
PowerFailDelayTime | Gets the time in milliseconds for power failure intervals.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerSource | Gets the current power source.
PowerState | Gets the current power condition. (inherited from PosCommon )
QuickChargeMode | Gets a Boolean value that indicates whether the battery is being recharged in a quick charge mode.
QuickChargeTime | Gets the remaining time for loading the battery.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )
UpsChargeState | Gets the UPS charge state.

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether the PosPower device is exclusive-use.

See Also

Reference

PosPower Class
Microsoft.PointOfService Namespace


PosPower.BatteryCapacityRemaining Property

PosPower.BatteryCapacityRemaining Property |
 | See Also

1/18/2008

Gets a value between 0 and 100 that represents the percentage of remaining battery capacity.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property BatteryCapacityRemaining As Integer
public virtual int BatteryCapacityRemaining { get; }
public:
virtual property int BatteryCapacityRemaining {
    int get ();
}
/** @property */
public int get_BatteryCapacityRemaining ()

public function get BatteryCapacityRemaining () : int

Remarks

BatteryCapacityRemaining is set by the service object during initialization and when the remaining battery capacity changes. Whenever the service object sets BatteryCapacityRemaining, it generates a StatusUpdateEvent event of StatusBatteryCapacityRemaining.

If the CapBatteryCapacityRemaining property is false and the application tries to read BatteryCapacityRemaining, the service object throws an exception.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.BatteryCriticallyLowThreshold Property

PosPower.BatteryCriticallyLowThreshold Property |
 | See Also

1/18/2008

Gets or sets the threshold percentage at which the service object generates a StatusUpdateEvent event of StatusBatteryCritical.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Property BatteryCriticallyLowThreshold As Integer
public virtual int BatteryCriticallyLowThreshold { get; set; }
public:
virtual property int BatteryCriticallyLowThreshold {
    int get ();
    void set (int value);
}
/** @property */
public int get_BatteryCriticallyLowThreshold ()

/** @property */
public void set_BatteryCriticallyLowThreshold (int value)

public function get BatteryCriticallyLowThreshold () : int

public function set BatteryCriticallyLowThreshold (value : int)

Remarks

The POS application sets BatteryCriticallyLowThreshold to a value of 1 to 99, based on the threshold percentage at which it wants to receive a StatusUpdateEvent event of StatusBatteryCriticallyLow from the service object. A value of zero (0) indicates the device does not support battery capacity reporting or that the battery capacity reporting feature is disabled. If the CapVariableBatteryCriticallyLow property is false and the application tries to set BatteryCriticallyLowThreshold, the service object throws an exception.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.BatteryLowThreshold Property

PosPower.BatteryLowThreshold Property |
 | See Also

1/18/2008

Gets or sets the threshold percentage at which the service object generates a StatusUpdateEvent event of StatusBatteryLow.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Property BatteryLowThreshold As Integer
public virtual int BatteryLowThreshold { get; set; }
public:
virtual property int BatteryLowThreshold {
    int get ();
    void set (int value);
}
/** @property */
public int get_BatteryLowThreshold ()

/** @property */
public void set_BatteryLowThreshold (int value)

public function get BatteryLowThreshold () : int

public function set BatteryLowThreshold (value : int)

Remarks

The POS application sets BatteryLowThreshold to a value of 1 to 99, based on the threshold percentage at which it wishes to receive a StatusUpdateEvent event of StatusBatteryLow from the service object. A value of zero (0) indicates the device does not support battery capacity reporting or that the battery capacity reporting feature is disabled. If the CapVariableBatteryCriticallyLow property is false and the application tries to set BatteryCriticallyLowThreshold, the service object throws an exception.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.CapBatteryCapacityRemaining Property

PosPower.CapBatteryCapacityRemaining Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device can provide information about the remaining capacity of the battery.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CapBatteryCapacityRemaining As Boolean
public virtual bool CapBatteryCapacityRemaining { get; }
public:
virtual property bool CapBatteryCapacityRemaining {
    bool get ();
}
/** @property */
public boolean get_CapBatteryCapacityRemaining ()

public function get CapBatteryCapacityRemaining () : boolean

Remarks

If set to true, the device can provide information about the remaining capacity of the battery.

CapBatteryCapacityRemaining is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.CapFanAlarm Property

PosPower.CapFanAlarm Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device can detect the CPU fan is stopped.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapFanAlarm As Boolean
public abstract bool CapFanAlarm { get; }
public:
virtual property bool CapFanAlarm {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapFanAlarm ()

public abstract function get CapFanAlarm () : boolean

Remarks

If true, the device can detect whether the CPU fan is stopped; otherwise, false.

CapFanAlarm is typically initialized to false. It should then be updated by the service object based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.CapHeatAlarm Property

PosPower.CapHeatAlarm Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device can detect if the CPU is running at a high temperature.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapHeatAlarm As Boolean
public abstract bool CapHeatAlarm { get; }
public:
virtual property bool CapHeatAlarm {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapHeatAlarm ()

public abstract function get CapHeatAlarm () : boolean

Remarks

If true, the device can detect whether the CPU is running at a dangerously high temperature; otherwise, false.

CapHeatAlarm is typically initialized to false. It should then be updated by the service object based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.CapQuickCharge Property

PosPower.CapQuickCharge Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether power management allows charging the battery with a quick method.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapQuickCharge As Boolean
public abstract bool CapQuickCharge { get; }
public:
virtual property bool CapQuickCharge {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapQuickCharge ()

public abstract function get CapQuickCharge () : boolean

Remarks

If true, power management allows charging the battery with a quick method. The time for charging the battery is shorter than usual. Otherwise, CapQuickCharge is false.

CapQuickCharge is typically initialized to false. It should then be updated by the service object based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace
QuickChargeMode
QuickChargeTime


PosPower.CapRestartPos Property

PosPower.CapRestartPos Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device can explicitly restart the POS system.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CapRestartPos As Boolean
public virtual bool CapRestartPos { get; }
public:
virtual property bool CapRestartPos {
    bool get ();
}
/** @property */
public boolean get_CapRestartPos ()

public function get CapRestartPos () : boolean

Remarks

If set to true, the device can explicitly restart the POS system.

CapRestartPos is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.CapShutdownPos Property

PosPower.CapShutdownPos Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device can explicitly shut down the POS system.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapShutdownPos As Boolean
public abstract bool CapShutdownPos { get; }
public:
virtual property bool CapShutdownPos {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapShutdownPos ()

public abstract function get CapShutdownPos () : boolean

Remarks

If set to true, the device can explicitly shut down the POS system.

CapShutdownPos is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace
PosPower.ShutdownPos Method


PosPower.CapStandbyPos Property

PosPower.CapStandbyPos Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device can request that the POS system enter a Standby state.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CapStandbyPos As Boolean
public virtual bool CapStandbyPos { get; }
public:
virtual property bool CapStandbyPos {
    bool get ();
}
/** @property */
public boolean get_CapStandbyPos ()

public function get CapStandbyPos () : boolean

Remarks

If set to true, the device can request that the POS system enter a Standby state.

CapStandbyPos is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.CapSuspendPos Property

PosPower.CapSuspendPos Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device can request that the POS system enter a Suspend state.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CapSuspendPos As Boolean
public virtual bool CapSuspendPos { get; }
public:
virtual property bool CapSuspendPos {
    bool get ();
}
/** @property */
public boolean get_CapSuspendPos ()

public function get CapSuspendPos () : boolean

Remarks

If set to true, the device can request that the POS system enter a Suspend state.

CapSuspendPos is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.CapUpsChargeState Property

PosPower.CapUpsChargeState Property |
 | See Also

1/18/2008

Gets one or more UPS charge states.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapUpsChargeState As UpsChargeStates
public abstract UpsChargeStates CapUpsChargeState { get; }
public:
virtual property UpsChargeStates CapUpsChargeState {
    UpsChargeStates get () abstract;
}
/** @property */
public abstract UpsChargeStates get_CapUpsChargeState ()

public abstract function get CapUpsChargeState () : UpsChargeStates

Remarks

If not equal to zero, the UPS can deliver one or more charge states. Its values can be logically ORed together.

CapUPSChargeState is typically initialized to Full. It should then be kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace
UpsChargeState


PosPower.CapVariableBatteryCriticallyLowThreshold Property

PosPower.CapVariableBatteryCriticallyLowThreshold Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device supports a variable threshold for critically low battery capacity reporting that can be set by the POS application.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CapVariableBatteryCriticallyLowThreshold As Boolean
public virtual bool CapVariableBatteryCriticallyLowThreshold { get; }
public:
virtual property bool CapVariableBatteryCriticallyLowThreshold {
    bool get ();
}
/** @property */
public boolean get_CapVariableBatteryCriticallyLowThreshold ()

public function get CapVariableBatteryCriticallyLowThreshold () : boolean

Remarks

If set to true, the device supports a variable threshold for critically low battery capacity reporting that can be set by the POS application.

CapVariableBatteryCriticallyLowThreshold is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.CapVariableBatteryLowThreshold Property

PosPower.CapVariableBatteryLowThreshold Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device supports a variable threshold for low battery capacity reporting that can be set by the POS application.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CapVariableBatteryLowThreshold As Boolean
public virtual bool CapVariableBatteryLowThreshold { get; }
public:
virtual property bool CapVariableBatteryLowThreshold {
    bool get ();
}
/** @property */
public boolean get_CapVariableBatteryLowThreshold ()

public function get CapVariableBatteryLowThreshold () : boolean

Remarks

If set to true, the device supports a variable threshold for low battery capacity reporting that can be set by the POS application.

CapVariableBatteryLowThreshold is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.EnforcedShutdownDelayTime Property

PosPower.EnforcedShutdownDelayTime Property |
 | See Also

1/18/2008

Gets or sets an integer value for a built-in mechanism to shut down the POS terminal.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property EnforcedShutdownDelayTime As Integer
public abstract int EnforcedShutdownDelayTime { get; set; }
public:
virtual property int EnforcedShutdownDelayTime {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_EnforcedShutdownDelayTime ()

/** @property */
public abstract void set_EnforcedShutdownDelayTime (int value)

public abstract function get EnforcedShutdownDelayTime () : int

public abstract function set EnforcedShutdownDelayTime (value : int)

Property Value

When EnforcedShutdownDelayTime is set, the following value is put in the ErrorCode property:
Value | Meaning
Success | EnforcedShutdownDelayTime was set successfully.
Illegal | An illegal value was specified.

Remarks

If not equal to zero, the system has a built-in mechanism to shut down the POS terminal after a determined time in a power failure situation. EnforcedShutdownDelayTime contains the time in milliseconds after which the system shuts down automatically following a power failure. A power failure is any situation when the POS terminal is turned off or detached from the power supply and runs on battery power.

If 0, no automatic shutdown is performed and the application must call the ShutdownPos method.

Applications are informed about an initiated automatic shutdown.

EnforcedShutdownDelayTime is typically initialized to 0. It should then be updated by the service object based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace
PosPower.ShutdownPos Method


PosPower.IsExclusiveUseDevice Property

PosPower.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the PosPower device is exclusive-use.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Remarks

A value of true indicates that the device is exclusive-use. If false, the device is not an exclusive use device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.PowerFailDelayTime Property

PosPower.PowerFailDelayTime Property |
 | See Also

1/18/2008

Gets the time in milliseconds for power failure intervals.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property PowerFailDelayTime As Integer
public abstract int PowerFailDelayTime { get; }
public:
virtual property int PowerFailDelayTime {
    int get () abstract;
}
/** @property */
public abstract int get_PowerFailDelayTime ()

public abstract function get PowerFailDelayTime () : int

Remarks

PowerFailDelayTime contains the time in milliseconds for power failure intervals that will not create a power failure situation. In some countries/regions, the power supply is sometimes interrupted for short intervals. Those short intervals range from milliseconds up to several seconds, and are handled by batteries or other electric equipment and should not cause a power failure situation. The power failure interval starts when the POS terminal is turned off or detached from the power supply and runs on battery power. The power failure interval ends when the POS terminal is again turned on and attached to the power supply. However, if the power failure interval is longer than the time specified in the PowerFailDelayTime property, a power failure situation is created.

Because this is usually a configuration parameter of the underlying power management, the application can only read this property.

PowerFailDelayTime is typically initialized to 0. It should then be updated by the service object based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.PowerSource Property

PosPower.PowerSource Property |
 | See Also

1/18/2008

Gets the current power source.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property PowerSource As PowerSource
public virtual PowerSource PowerSource { get; }
public:
virtual property PowerSource PowerSource {
    PowerSource get ();
}
/** @property */
public PowerSource get_PowerSource ()

public function get PowerSource () : PowerSource

Remarks

Possible values are defined by the PowerSource enumeration. Valid values for PowerSource are as follows:

Member | Description
AC | The current power source is the AC line.
Backup | The current power source is a backup source such as an UPS or backup battery.
Battery | The current power source is a system battery. This value is only presented for systems that operate normally on battery.
NotAvailable | Power source reporting is not available.

Whenever the service object updates PowerSource, it generates a StatusUpdateEvent event of StatusPowerSource.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace


PosPower.QuickChargeMode Property

PosPower.QuickChargeMode Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the battery is being recharged in a quick charge mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property QuickChargeMode As Boolean
public abstract bool QuickChargeMode { get; }
public:
virtual property bool QuickChargeMode {
    bool get () abstract;
}
/** @property */
public abstract boolean get_QuickChargeMode ()

public abstract function get QuickChargeMode () : boolean

Remarks

If true, the battery is being recharged in a quick charge mode. If false, it is being charged in a normal mode. QuickChargeMode is set only if CapQuickCharge is true.

QuickChargeMode is typically initialized to falseE. It should then be kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace
PosPower.CapQuickCharge Property
QuickChargeTime


PosPower.QuickChargeTime Property

PosPower.QuickChargeTime Property |
 | See Also

1/18/2008

Gets the remaining time for loading the battery.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property QuickChargeTime As Integer
public abstract int QuickChargeTime { get; }
public:
virtual property int QuickChargeTime {
    int get () abstract;
}
/** @property */
public abstract int get_QuickChargeTime ()

public abstract function get QuickChargeTime () : int

Remarks

QuickChargeTime specifies the remaining time for loading the battery in quick charge mode. After the time has elapsed, the battery loading mechanism of power management usually switches into the normal mode. The time is specified in milliseconds.

QuickChargeTime is set only if CapQuickCharge is trueE.

QuickChargeTime is typically initialized to 0. It should then be kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace
PosPower.QuickChargeMode Property
PosPower.CapQuickCharge Property


PosPower.UpsChargeState Property

PosPower.UpsChargeState Property |
 | See Also

1/18/2008

Gets the UPS charge state.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property UpsChargeState As UpsChargeStates
public abstract UpsChargeStates UpsChargeState { get; }
public:
virtual property UpsChargeStates UpsChargeState {
    UpsChargeStates get () abstract;
}
/** @property */
public abstract UpsChargeStates get_UpsChargeState ()

public abstract function get UpsChargeState () : UpsChargeStates

Remarks

UPSChargeState is typically initialized to FULL. It should then be kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPower Class
PosPower Members
Microsoft.PointOfService Namespace
PosPower.CapUpsChargeState Property


PosPower Events

PosPower Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

PosPower Class
Microsoft.PointOfService Namespace


PosPrinter Class

PosPrinter Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a UPOS Printer device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class PosPrinter
    Inherits PosCommon
public abstract class PosPrinter : PosCommon
public ref class PosPrinter abstract : public PosCommon
public abstract class PosPrinter extends PosCommon
public abstract class PosPrinter extends PosCommon

Remarks

PosPrinter class defines three printer "stations," as follows:

  • Journal. Used for simple text messages that log transaction and activity information kept by the store for audit and other purposes.

  • Receipt. Used to print transaction information (typically given to the customer), or for store reports. Receipt contains either a knife to automatically cut the paper between transactions, or a tear bar to manually cut the paper.

  • Slip. Used to print information on a form (typically given to the customer), or to print "validation" information on a form. The form type is usually a check or credit card slip.

    Sometimes, limited forms-handling capability is integrated with the receipt or journal station to allow validation printing. Frequently this limits the number of print lines, because of the station’s forms-handling throat depth. The service object nevertheless addresses this printer functionality as a slip station.

The default character set of POS printers can print ASCII characters 0x20 through 0x7F. This include space, digits, uppercase, lowercase, and some special characters. (If the Printer device does not support all these. Then it should translate them to close approximations, for example, lowercase to uppercase.)

POS Printer devices may have several additional capabilities. See the capabilities properties for specific information.

POS Printer devices use the general output programming model, with some improvements:

  • The following methods are always performed synchronously: BeginInsertion, EndInsertion, BeginRemoval, EndRemoval, ChangePrintSide, and CheckHealth. These methods will fail if asynchronous output is outstanding.

  • The PrintImmediate method is also always performed synchronously. PrintImmediate tries to print its data immediately (that is, as the very next printer operation). It can be called when asynchronous output is outstanding. PrintImmediate is primarily intended for use in exception conditions when asynchronous output is outstanding.

  • The following methods are performed either synchronously or asynchronously, depending on the value of the AsyncMode property: PrintNormal, PrintTwoNormal, CutPaper, RotatePrint, PrintBarCode, PrintBitmap, TransactionPrint, and MarkFeed. When the AsyncMode property is set to false, these methods print synchronously and return their completion status to the application.

  • When AsyncMode is set to true, these methods operate as follows:

    • The service object buffers the request, sets the OutputID property to an identifier for this request, and returns as soon as possible. When the device successfully completes the request, the service object raises an OutputCompleteEvent event. A parameter of this event contains the Output ID of the completed request.

      Asynchronous printer methods will not return an error status because of a printing problem, such as out of paper or printer fault. These errors will be reported only by an ErrorEvent event. An error status is returned only if the printer is not claimed and enabled, a parameter is invalid, or the request cannot be queued. The first two error cases are because of an application error. The last is a serious system resource exception.

    • If an error occurs when it performs an asynchronous request, the service object queues an ErrorEvent event and delivers it. The ErrorStation property is set to the station or stations that were printing when the error occurred. The ErrorLevel and ErrorString properties are also set.

      The event handler can call synchronous print methods (but not asynchronous methods), can then either retry the outstanding output or clear it.

    • The service object guarantees that asynchronous output is performed on a first-in first-out basis.

    • All output buffered by the application can be deleted by calling the ClearOutput method. OutputCompleteEvent events will not be raised for cleared output. This method also stops any output that may be in progress (when it is possible).

    • The property FlagWhenIdle can be set to cause the service object to raise a StatusUpdateEvent event when all outstanding outputs have finished, whether successfully or because they were cleared.

Transaction Mode

The transaction mode model is as follows:

  • A transaction is a sequence of print operations that is printed to a station as a unit. Print operations that can be included in a transaction are PrintNormal, CutPaper, RotatePrint, PrintBarCode, PrintBitmap, and MarkFeed. During a transaction, the print operations are first validated. If valid, they are added to the transaction but not yet printed. After the application has added as many operations as required, it calls the TransactionPrint method.

  • If the transaction is printed synchronously, the returned status indicates either that the transaction printed successfully or that an error occurred during the print. If the transaction is printed asynchronously, the asynchronous print rules listed here are followed. If an error occurs and the ErrorEvent handler causes a retry, the transaction is retried.

Page Mode

Page Mode printing support is modeled after Transaction Mode printing support. All activities within Page Mode are handled and recovered as a single entity. Page Mode support lets the user dynamically compose complex page printouts by using the PrintNormal, PrintBitmap, and PrintBarcode methods and additional Page Mode methods and properties. Composed pages can be printed, saved, and modified multiple times as long as Page Mode is active.

PrintCartridge Mode

The print cartridge model is as follows:

  • The application uses the CapJrnCartridgeSensor, CapRecCartridgeSensor, and CapSlpCartridgeSensor properties to determine whether the printer can detect the operating condition of the cartridge.

  • Before it determines a cartridge’s operating condition, the application selects a cartridge by using the JrnCurrentCartridge, RecCurrentCartridge, or SlpCurrentCartridge property.

  • The condition of the selected cartridge is set up by the service object by using one of the JrnCartridgeState, RecCartridgeState, or SlpCartridgeState properties. The values that these properties are can include order of high priority to low priority as follows: Unknown, Removed, Empty, Cleaning, NearEnd, OK.

  • The application uses the CapJrnColor and CapRecColor properties to determine the color capabilities of the station.

  • For Mono Color,

    • The CapJrnColor, CapRecColor, and CapSlpColor properties equal Primary.

  • For 2 Color,

    • The CapJrnColor, CapRecColor, and CapSlpColor properties are a logical OR combination of Primary and Custom1.

    • Custom1 refers to the secondary color, usually red.

    • Secondary color printing can be done by using the ESC|rC escape sequence.

  • For Custom Color,

    • The CapJrnColor, CapRecColor, and CapSlpColor properties are a logical OR combination of Primary and any of the following bit values:Custom1, Custom2, Custom3, Custom4, Custom5, Custom6.

    • Selection of a custom color can be done by using the ESC|#rC escape sequence.

  • For Full Color,

    • The CapJrnColor, CapRecColor, and CapSlpColor properties are a logical OR combination of Full and the following values: Cyan, Magenta, Yellow.

    • Full is not used to indicate that a print cartridge is currently installed in the printer. Instead, it is used to indicate that the printer can print in a full color mode.

    • Full color printing is done by using the ESC|#fC command.

  • For Full Color with Custom Color(s),

    • CapJrnColor, CapRecColor, and CapSlpColor are a logical OR combination of the settings for custom color values and Full.

The print cartridge state reporting model is as follows:

  • The application can set the CartridgeNotify property to enable cartridge state reporting by using StatusUpdateEvent events and the JrnCartridgeState, RecCartridgeState, and SlpCartridgeState properties. CartridgeNotify can be set only before the device is enabled (that is, before the DeviceEnabled property is set to true). This restriction allows for simpler implementation of cartridge status notification without a adverse effects on the application. The application is either prepared to receive notifications or does not want them, and has no need to switch between these cases. The CartridgeNotify property can be set to:

    • Disabled

    • Enabled

The following semantics are added to device enabling (setting the DeviceEnabled property to true) when the CapJrnCartridgeSensor, CapRecCartridgeSensor, and CapSlpCartridgeSensor properties are not 0 and CartridgeNotify is set to Enabled:

  • Monitoring the cartridge state begins when the service object detects that the DeviceEnabled property has changed from false to true.

  • When the service object detects that DeviceEnabled has been changed from true to false, the state of the cartridge is no longer valid. Therefore, the service object sets JrnCartridgeState, RecCartridgeState, and SlpCartridgeState properties to Unknown.

The POS printer is an exclusive-use device. Therefore:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before accessing many of the printer-specific properties.

  • The application must claim and enable the device before the application calls methods that manipulate the device.

The default character set of all POS for .NET printers is assumed to support at least the ASCII characters 20-hex through 7F-hex. This include spaces, digits, uppercase, lowercase, and some special characters. If the printer does not support lowercase characters, the service object can translate them to uppercase.

Every escape sequence begins with the escape character ESC, whose value is 27 decimal, followed by a vertical bar (‘|’). This is followed by zero or more digits and lowercase alphabetic characters. The escape sequence is stopped by an uppercase alphabetic character. Sequences that do not begin with ESC "|" are passed through to the printer. Also, sequences that begin with ESC "|" but are not valid POS for .NET escape sequences are passed through to the printer.

To determine whether escape sequences or data can be performed on a printer station, the application can call the ValidateData method. (For some escape sequences, corresponding capability properties can also be used.)

The following escape sequences are recognized. If an escape sequence specifies an operation that is not supported by the printer station, it is ignored.

One Shots - Perform indicated action.

Name | Data | Remarks
Paper cut | ESC|#P | Cuts receipt paper. The character ‘#’ is replaced by an ASCII decimal string telling the percentage cut desired. If ‘#’ is omitted, a full cut is performed. For example, the C string "\x1B|75P" requests a 75% partial cut.
Feed and Paper cut | ESC|#fP | Cuts receipt paper, after feeding the paper the number of lines specified by the RecLinesToPaperCut property. The character ‘#’ is defined by the "Paper cut" escape sequence.
Feed, Paper cut, and Stamp | ESC|#sP | Cuts and stamps receipt paper, after feeding the paper by the number of lines specified by the RecLinesToPaperCut property. The character ‘#’ is defined by the "Paper cut" escape sequence.
Fire stamp | ESC|sL | Raises the stamp solenoid that usually contains a graphical store emblem.
Print bitmap | ESC|#B | Prints the pre-stored bitmap. The character ‘#’ is replaced by the bitmap number.
Print top logo | ESC|tL | Prints the pre-stored top logo.
Print bottom logo | ESC|bL | Prints the pre-stored bottom logo.
Feed lines | ESC|#lF | Feed the paper forward by the specified lines. The character ‘#’ is replaced by an ASCII decimal string telling the number of lines to be fed. If ‘#’ is omitted, then one line is fed.
Feed units | ESC|#uF | Feed the paper forward by mapping mode units. The character ‘#’ is replaced by an ASCII decimal string telling the number of units to be fed. If ‘#’ is omitted, then one unit is fed.
Feed reverse | ESC|#rF | Feed the paper backward by the specified lines. The character ‘#’ is replaced by an ASCII decimal string telling the number of lines to be fed. If ‘#’ is omitted, then one line is fed.

Print Mode - Characteristics that are remembered until explicitly changed.

Name | Data | Remarks
Font font selection | ESC|#fT | Selects a new font for the following data. Values for the character ‘#’ are as follows: 0 = Default font.1 = Select first font from the FontTypefaceList property.2 = Select second font from the FontTypefaceList property.And so on.

Print Line - Characteristics that are reset at the end of each print method or by a "Normal" sequence.

Name | Data | Remarks
Bold | ESC|bC | Prints in bold or double-strike.
Underline | ESC|#uC | Prints with underline. The character ‘#’ is replaced by an ASCII decimal string telling the thickness of the underline in printer dot units. If ‘#’ is omitted, then a printer-specific default thickness is used.
Italic | ESC|iC | Prints in italic.
Alternate color (Custom) | ESC|#rC | Prints by using an alternate custom color. The character ‘#’ is replaced by an ASCII decimal string that indicates the desired color. The value of the decimal string is equal to the value of the cartridge constant used in the Printer device properties. If ‘#’ is omitted, the secondary color (Custom Color 1) is selected. Custom Color 1 is usually red.
Reverse video | ESC|rvC | Prints in a reverse video format.
Shading | ESC|#sC | Prints in a shaded manner. The character ‘#’ is replaced by an ASCII decimal string telling the percentage shading desired. If ‘#’ is omitted, then a printer-specific default level of shading is used.
Single high & wide | ESC|1C | Prints normal size.
Double-wide | ESC|2C | Prints double-wide characters.
Double-high | ESC|3C | Prints double-high characters.
Double-high & wide | ESC|4C | Prints double-high and double-wide characters.
Scale horizontally | ESC|#hC | Prints with the width scaled ‘#’ times the normal size, where ‘#’ is replaced by an ASCII decimal string.
Scale vertically | ESC|#vC | Prints with the height scaled ‘#’ times the normal size, where ‘#’ is replaced by an ASCII decimal string.
RGB color | ESC|#fC | Prints in # color. The character ‘#’ is replaced by an ASCII decimal string that indicates the additive amount of RGB to produce the desired color. There are 3 digits each of Red, Green, and Blue elements. Valid values range from "000" to "255". (For example, "255255000" represents yellow.) Color matching to the subtractive percentage of CMY (Cyan, Magenta, and Yellow components) to produce the desired color specified by the RGB is up to the service object. If ‘#’ is omitted, the primary color is used. Bitmap printing is not affected.
Center | ESC|cA | Aligns following text in the center.
Right justify | ESC|rA | Aligns following text at the right side.
Normal | ESC|N | Restores printer characteristics to normal condition.
SubScript | ESC|tbC | Prints subscript characters.
SuperScript | ESC|tpC | Prints superscript characters.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.PosPrinter
Microsoft.PointOfService.BasicServiceObjects.PosPrinterBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter Members

PosPrinter Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a UPOS Printer device.

The following tables list the members exposed by the PosPrinter type.

Protected Constructors

Name | Description
PosPrinter | Creates an instance of the PosPrinter class.
Top

Public Fields

Name | Description
CharacterSetAnsi | Indicates the default character set supports the ANSI character set.
CharacterSetAscii | Indicates the default character set supports the ASCII character set.
CharacterSetUnicode | Indicates the default character set supports the Unicode character set.
ExtendedErrorBadFormat | Indicates an unsupported format.
ExtendedErrorCoverOpen | Indicates that the printer cover is open.
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorJournalCartridgeEmpty | Indicates the journal cartridge is empty.
ExtendedErrorJournalCartridgeRemoved | Indicates the journal cartridge has been removed.
ExtendedErrorJournalEmpty | Indicates the journal station is out of paper.
ExtendedErrorJournalHeadCleaning | Indicates the journal cartridge head is being cleaned.
ExtendedErrorReceiptCartridgeEmpty | Indicates the receipt cartridge is empty.
ExtendedErrorReceiptCartridgeRemoved | Indicates the receipt cartridge has been removed.
ExtendedErrorReceiptEmpty | Indicates the receipt station is out of paper.
ExtendedErrorReceiptHeadCleaning | Indicates the receipt cartridge head is being cleaned.
ExtendedErrorSlipCartridgeEmpty | Indicates the slip cartridge is empty.
ExtendedErrorSlipCartridgeRemoved | Indicates the slip cartridge has been removed.
ExtendedErrorSlipEmpty | Indicates a form has not been inserted into the slip station.
ExtendedErrorSlipForm | Indicates a form is present while the printer is being taken out of from removal mode.
ExtendedErrorSlipHeadCleaning | Indicates the slip cartridge head is being cleaned.
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
ExtendedErrorTooBig | Indicates the bitmap is either too wide to print without transformation, or too big to tranform.
PrinterBarCodeCenter | Indicates the bar code should be printed aligned with the center of the station.
PrinterBarCodeLeft | Indicates the bar code should be printed aligned with the leftmost print column.
PrinterBarCodeRight | Indicates the bar code should be printed aligned with the rightmost print column.
PrinterBitmapAsIs | Indicates the bitmap should be printed with one bitmap pixel per printer dot.
PrinterBitmapCenter | Indicates the bitmap should be printed aligned with the center of the station.
PrinterBitmapLeft | Indicates the bitmap should be printed aligned with the leftmost print column.
PrinterBitmapRight | Indicates the bitmap should be printed aligned with the rightmost print column.
PrinterCutPaperFullCut | Indicates a full paper cut.
StatisticBarcodePrintedCount | Incremented when a bar code is successfully printed.
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFailedPaperCutCount | Incremented for each failed paper cut.
StatisticFailedPrintSideChangeCount | Incremented for each failed print side change or failed check flip.
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticFormInsertionCount | Incremented when a form is successfully inserted into the document/slip station.
StatisticHomeErrorCount | Incremented when a home error occurs.
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticJournalCharacterPrintedCount | Incremented for every journal character printed.
StatisticJournalCoverOpenCount | Incremented every time that the document/slip station cover opened.
StatisticJournalLinePrintedCount | Incremented for each journal line printed.
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMaximumTempReachedCount | Incremented every time that maximum temperature is reached.
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticNVRAMWriteCount | Incremented every time that NVRAM is written to.
StatisticPaperCutCount | Incremented every time that paper is cut successfully.
StatisticPrinterFaultCount | Incremented when a printer fault occurs.
StatisticPrintSideChangeCount | Incremented when the print side changes or a check flips.
StatisticReceiptCharacterPrintedCount | Incremented every time that a receipt character is printed.
StatisticReceiptCoverOpenCount | Incremented every time that the receipt cover opened.
StatisticReceiptLineFeedCount | Incremented every time that a receipt line feed is performed.
StatisticReceiptLinePrintedCount | Incremented every time that a receipt line is printed.
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticSlipCharacterPrintedCount | Incremented every time that a slip character is printed.
StatisticSlipCoverOpenCount | Incremented every time that the slip cover opened.
StatisticSlipLineFeedCount | Incremented every time that a slip line feed is performed.
StatisticSlipLinePrintedCount | Incremented every time that a slip line is printed.
StatisticStampFiredCount | Incremented for each Stamp raised.
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusCoverOK | Indicates the printer cover is closed.
StatusCoverOpen | Indicates the printer cover is open.
StatusIdle | Indicates all asynchronous output is finished, either successfully or because the output has been cleared. The printer State property is now set to ControlState.Idle.
StatusJournalCartridgeEmpty | Indicates the journal cartridge has to be replaced.
StatusJournalCartridgeNearEmpty | Indicates the journal cartridge is near its end.
StatusJournalCartridgeOK | Indicates all journal cartridges are ready.
StatusJournalCoverOK | Indicates the journal cover is closed.
StatusJournalCoverOpen | Indicates the journal cover is open.
StatusJournalEmpty | Indicates there is no journal paper.
StatusJournalHeadCleaning | Indicates the journal cartridge has begun head cleaning.
StatusJournalNearEmpty | Indicates the journal paper is low.
StatusJournalPaperOK | Indicates the journal paper is ready.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusReceiptCartridgeEmpty | Indicates the receipt cartridge has to be replaced.
StatusReceiptCartridgeNearEmpty | Indicates the receipt cartridge is nearing empty.
StatusReceiptCartridgeOK | Indicates all receipt cartridges are ready.
StatusReceiptCoverOK | Indicates the receipt cover is closed.
StatusReceiptCoverOpen | Indicates the receipt cover is open.
StatusReceiptEmpty | Indicates there is no receipt paper.
StatusReceiptHeadCleaning | Indicates the receipt cartridge has begun head cleaning.
StatusReceiptNearEmpty | Indicates the receipt paper is low.
StatusReceiptPaperOK | Indicates the receipt paper is ready.
StatusSlipCartridgeEmpty | Indicates the slip cartridge has to be replaced.
StatusSlipCartridgeNearEmpty | Indicates the slip cartridge is nearing empty.
StatusSlipCartridgeOK | Indicates all slip cartridges are ready.
StatusSlipCoverOK | Indicates the slip cover is closed.
StatusSlipCoverOpen | Indicates the slip cover is open.
StatusSlipEmpty | Indicates that no slip form is inserted and no slip form has been detected at the entrance to the slip station.
StatusSlipHeadCleaning | Indicates the receipt cartridge has begun head cleaning.
StatusSlipNearEmpty | Indicates the slip form is close to the bottom.
StatusSlipPaperOK | Indicates the slip form is inserted.
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
AsyncMode | Gets or sets a Boolean value that indicates whether certain print methods will be performed asynchronously.
CapCharacterSet | Gets the default character set capability.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapConcurrentJrnRec | Gets a Boolean value that indicates whether the journal and receipt stations can print at the same time.
CapConcurrentJrnSlp | Gets a Boolean value that indicates whether the journal and slip stations can print at the same time.
CapConcurrentPageMode | Gets a Boolean value that indicates whether the printer can support Page Mode at the same time for both the receipt and slip stations.
CapConcurrentRecSlp | Gets a Boolean value that indicates whether the receipt and slip stations can print at the same time.
CapCoverSensor | Gets a Boolean value that indicates whether the printer has a "cover open" sensor.
CapJrn2Color | Gets a Boolean value that indicates whether the journal can print dark plus an alternate color.
CapJrnBold | Gets a Boolean value that indicates whether the journal can print bold characters.
CapJrnCartridgeSensor | Gets the presence of journal cartridge monitoring sensors.
CapJrnColor | Gets available journal color cartridges.
CapJrnDHigh | Gets a Boolean value that indicates whether the journal can print double-high characters.
CapJrnDWide | Gets a Boolean value that indicates whether the journal can print double-wide characters.
CapJrnDWideDHigh | Gets a Boolean value that indicates whether the journal can print characters that are both double-high and double-wide.
CapJrnEmptySensor | Gets a Boolean value that indicates whether the journal has an out-of-paper sensor.
CapJrnItalic | Gets a Boolean value that indicates whether the journal can print italic characters.
CapJrnNearEndSensor | Gets a Boolean value that indicates whether the journal has a low-paper sensor.
CapJrnPresent | Gets a Boolean value that indicates whether the journal print station is present.
CapJrnUnderline | Gets a Boolean value that indicates whether the journal can underline characters.
CapMapCharacterSet | Gets a Boolean value that indicates whether when printing data, the service object can map the characters sent by the application (in the character set that is defined by the CharacterSet property) to the character sets that are defined by the CharacterSetList property.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapRec2Color | Gets a Boolean value that indicates whether the receipt can print dark plus an alternate color.
CapRecBarCode | Gets a Boolean value that indicates whether the receipt has bar code printing capability.
CapRecBitmap | Gets a Boolean value that indicates whether the receipt can print bitmaps.
CapRecBold | Gets a Boolean value that indicates whether the receipt can print bold characters.
CapRecCartridgeSensor | Gets the presence of receipt cartridge monitoring sensors.
CapRecColor | Gets the receipt color cartridges.
CapRecDHigh | Gets a Boolean value that indicates whether the receipt can print double-high characters.
CapRecDWide | Gets a Boolean value that indicates whether the receipt can print double-wide characters.
CapRecDWideDHigh | Gets a Boolean value that indicates whether the receipt can print double-high, double-wide characters.
CapRecEmptySensor | Gets a Boolean value that indicates whether the receipt has an out-of-paper sensor.
CapRecItalic | Gets a Boolean value that indicates whether the receipt can print italic characters.
CapRecLeft90 | Gets a Boolean value that indicates whether the receipt can print in rotated-90-degree-left mode.
CapRecMarkFeed | Gets the type of mark-sensed paper handling available.
CapRecNearEndSensor | Gets a Boolean value that indicates whether the receipt has a low-paper sensor.
CapRecPageMode | Gets a Boolean value that indicates whether the printer can support Page Mode for the receipt station.
CapRecPaperCut | Gets a Boolean value that indicates whether the receipt can perform paper cuts.
CapRecPresent | Gets a Boolean value that indicates whether the receipt print station is present.
CapRecRight90 | Gets a Boolean value that indicates whether the receipt can print in a rotated-90-degree-right mode.
CapRecRotate180 | Gets a Boolean value that indicates whether the receipt can print in a rotated upside-down mode.
CapRecStamp | Gets a Boolean value that indicates whether the receipt has a stamp capability.
CapRecUnderline | Gets a Boolean value that indicates whether the receipt can underline characters.
CapSlp2Color | Gets a Boolean value that indicates whether the slip can print dark plus an alternate color.
CapSlpBarCode | Gets a Boolean value that indicates whether the slip has bar code printing capability.
CapSlpBitmap | Gets a Boolean value that indicates whether the slip can print bitmaps.
CapSlpBold | Gets a Boolean value that indicates whether the slip can print bold characters.
CapSlpBothSidesPrint | Gets a Boolean value that indicates whether the slip print station supports printing on both sides of the document.
CapSlpCartridgeSensor | Gets the presence of slip-cartridge monitoring sensors.
CapSlpColor | Gets the type of color cartridges supported for slip printing.
CapSlpDHigh | Gets a Boolean value that indicates whether the slip can print double-high characters.
CapSlpDWide | Gets a Boolean value that indicates whether the slip can print double-wide characters.
CapSlpDWideDHigh | Gets a Boolean value that indicates whether the slip can print characters that are both double-wide and double-high.
CapSlpEmptySensor | Gets a Boolean value that indicates whether the slip has a "slip in" sensor.
CapSlpFullSlip | Gets a Boolean value that indicates whether the slip is a full slip station; it can print full-length forms.
CapSlpItalic | Gets a Boolean value that indicates whether the slip can print italic characters.
CapSlpLeft90 | Gets a Boolean value that indicates whether the slip can print in a rotated 90 degree left mode.
CapSlpNearEndSensor | Gets a Boolean value that indicates whether the slip has a "slip near end" sensor.
CapSlpPageMode | Gets a Boolean value that indicates whether the printer can support Page Mode for the slip station.
CapSlpPresent | Gets a Boolean value that indicates whether the slip print station is present.
CapSlpRight90 | Gets a Boolean value that indicates whether the slip can print in a rotated-90-degree-right mode.
CapSlpRotate180 | Gets a Boolean value that indicates whether the slip can print in an upside-down mode.
CapSlpUnderline | Gets a Boolean value that indicates whether the slip can underline characters.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapTransaction | Gets a Boolean value that indicates whether each station supports printer transactions.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CartridgeNotify | Gets or sets the type of cartridge state notification the application wants to receive.
CharacterSet | Gets or sets the numeric value that indicates the character set that the application wants to use for printing characters.
CharacterSetList | Gets the list of character set numbers supported for printing.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
CoverOpen | Gets a Boolean value that indicates whether the printer’s cover is open.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
ErrorLevel | Gets the severity of the most recent error condition.
ErrorStation | Gets the station or stations that were printing when an error was detected.
ErrorString | Gets a vendor-supplied description of the current error.
FlagWhenIdle | Gets or sets a Boolean value that indicates whether the service object queues a StatusUpdateEvent event by using the StatusIdle constant when the device is in an idle state, and reset FlagWhenIdle to false.
FontTypefaceList | Gets a string array that specifies the fonts and typefaces supported by the printer.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
JrnCartridgeState | Gets the status of the selected journal cartridge (ink, ribbon, or toner).
JrnCurrentCartridge | Gets or sets the currently selected journal cartridge.
JrnEmpty | Gets or sets a Boolean value that indicates whether the journal is out of paper.
JrnLetterQuality | Gets or sets a Boolean value that indicates whether the printer can print in high-quality mode.
JrnLineChars | Gets or sets the number of characters that the application wants to print on a journal line.
JrnLineCharsList | Gets a collection of the line widths (characters per line) supported by the journal station.
JrnLineHeight | Gets or sets the journal print line height that the application wants to use, expressed in the unit of measure indicated by the MapMode property setting.
JrnLineSpacing | Gets or sets the spacing of each single-high print line, including both the printed line height and the white space between each pair of lines that the application wants to use.
JrnLineWidth | Gets the width of a line for the number of characters indicated by the JrnLineChars property, expressed in the unit of measure indicated by the MapMode property.
JrnNearEnd | Gets a Boolean value that indicates whether the journal paper is low.
MapCharacterSet | Gets a Boolean value that indicates whether the service object maps the characters transferred by the application to the character set selected in the CharacterSet property.
MapMode | Gets or sets the mapping mode of the printer the application wants to use.
OutputId | Gets the identifier associated with the current output request.
PageModeArea | Gets the page area for the selected PageModeStation expressed in the unit of measure given by MapMode.
PageModeDescriptor | Gets the basic Page mode functionality of the printer for the selected PageModeStation property.
PageModeHorizontalPosition | Gets or sets the horizontal start position offset within the print area for the print station specified by the PageModeStation property, expressed in the unit of measure specified by the MapMode property.
PageModePrintArea | Gets or sets the print area for the print station specified by the PageModeStation property, expressed in the unit of measured specified by the MapMode property.
PageModePrintDirection | Gets the print direction, as specified by the PageModePrintDirection enumeration.
PageModeStation | Gets or sets the printer station, as specified by the PrinterStation enumeration.
PageModeVerticalPosition | Gets or sets the vertical start position offset within the print area for the print station specified by the PageModeStation property, expressed in the unit of measure specified by the MapMode property.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
RecBarCodeRotationList | Gets a list of the directions in which a receipt bar code can be rotated.
RecBitmapRotationList | Gets a list of the directions in which a receipt bitmap can be rotated.
RecCartridgeState | Gets the status of the selected receipt cartridge (ink, ribbon or toner).
RecCurrentCartridge | Gets or sets the receipt cartridge selected by the application.
RecEmpty | Gets a Boolean value that indicates whether the receipt is out of paper.
RecLetterQuality | Gets a Boolean value that indicates whether the printer prints in high-quality mode.
RecLineChars | Gets or sets the number of characters that the application wants to print on a receipt line.
RecLineCharsList | Gets a collection of the line widths (characters per line) supported by the receipt station.
RecLineHeight | Gets or sets the receipt print line height, expressed in the unit of measure indicated by the MapMode property setting, that the application wants to use.
RecLineSpacing | Gets or sets the spacing of each single-high print line. This includes both the printed line height and the white space between each pair of lines, that the application wants to use.
RecLinesToPaperCut | Gets the number of lines that must be advanced before cutting the receipt paper.
RecLineWidth | Gets the width of a line, based on the number of characters specified in the RecLineChars property, expressed in the unit of measure indicated by the MapMode property.
RecNearEnd | Gets a Boolean value that indicates whether the receipt paper is low.
RecSidewaysMaxChars | Gets the maximum number of characters that can be printed on each line in sideways mode.
RecSidewaysMaxLines | Gets the maximum number of lines that can be printed in sideways mode.
RotateSpecial | Gets or sets the rotation orientation for bar codes that the application wants to use.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
SlpBarCodeRotationList | Gets a collection of the directions in which a slip bar code may be rotated.
SlpBitmapRotationList | Gets a collection of the directions in which a slip bitmap can be rotated.
SlpCartridgeState | Gets the status of the selected slip cartridge (ink, ribbon, or toner).
SlpCurrentCartridge | Gets or sets the slip cartridge the application wants to use.
SlpEmpty | Gets a Boolean value that indicates whether a slip form is not present.
SlpLetterQuality | Gets or sets a Boolean value that indicates whether the printer prints in high-quality mode.
SlpLineChars | Gets or sets the number of characters that the application wants to print on a slip line.
SlpLineCharsList | Gets a collection of the line widths (characters per line) supported by the slip station.
SlpLineHeight | Gets or sets the slip print-line height, expressed in the unit of measure indicated by the MapMode property setting, that the application wants to use.
SlpLinesNearEndToEnd | Gets the number of lines that can be printed after the SlpNearEnd property has been set to true but before the printer reaches the end of the slip.
SlpLineSpacing | Gets or sets the spacing of each single-high print line. This includes both the printed line height and the white space between each pair of lines that the application wants to use.
SlpLineWidth | Gets the line width, based on the number of characters specified for the SlpLineChars property, expressed in the unit of measure indicated by the MapMode property.
SlpMaxLines | Gets the maximum number of lines that can be printed on a form.
SlpNearEnd | Gets a Boolean value that indicates whether the slip form is near its end.
SlpPrintSide | Gets the side of the slip print station document on which printing will occur.
SlpSidewaysMaxChars | Gets the maximum number of characters that can be printed on each line in sideways mode.
SlpSidewaysMaxLines | Gets the maximum number of lines that can be printed in sideways mode.
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether the PosPrinter is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
BeginInsertion | Starts form insertion processing. BeginInsertion is paired with the EndInsertion method to control form insertion.
BeginRemoval | Starts form removal processing.
ChangePrintSide | Selects the side of the document that it wants to print on.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearOutput | Clears all device output that has been buffered. Also, when it is possible, stops outputs that are in progress.
ClearPrintArea | Clears the area defined by the PageModePrintArea property.
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
CutPaper | Cuts the receipt paper.
DirectIO | (inherited from PosCommon )
EndInsertion | Ends form-insertion processing.
EndRemoval | Ends form-removal processing.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
MarkFeed | Uses the printer’s mark sensor for receipt paper.
Open | Opens a device for later input/output processing. (inherited from PosCommon)
PageModePrint | Starts or exits Page Mode for the station specified in the PageModeStation property.
PrintBarCode | Prints a bar code on the specified printer station.
PrintBitmap | Prints a bitmap on the specified printer station.
PrintImmediate | Prints the string immediately that is specified for data on the printer station specified by station.
PrintMemoryBitmap | Prints a bitmap from memory on the specified printer station.
PrintNormal | Prints the string specified in data on the printer station specified in station.
PrintTwoNormal | Prints two strings on two print stations concurrently. When supported, this may give increased print performance.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
RotatePrint | Enters or exits rotated print mode.
SetBitmap | Saves information about a bitmap for later printing.
SetLogo | Saves a data string as the top or bottom logo.
ToString | (inherited from Object )
TransactionPrint | Enters or exits transaction mode.
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
ValidateData | Determines whether a data sequence, possibly including one or more escape sequences, is valid for the specified station, before it calls the PrintImmediate, PrintNormal, or PrintTwoNormal methods.
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
ErrorEvent | Queued by the service object when an error is detected and the device’s State transitions into the error state.
OutputCompleteEvent | Queued by the service object to notify the application when asynchronous processing that corresponds to an OutputID has successfully completed.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

PosPrinter Class
Microsoft.PointOfService Namespace


PosPrinter Fields

PosPrinter Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
CharacterSetAnsi | Indicates the default character set supports the ANSI character set.
CharacterSetAscii | Indicates the default character set supports the ASCII character set.
CharacterSetUnicode | Indicates the default character set supports the Unicode character set.
ExtendedErrorBadFormat | Indicates an unsupported format.
ExtendedErrorCoverOpen | Indicates that the printer cover is open.
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorJournalCartridgeEmpty | Indicates the journal cartridge is empty.
ExtendedErrorJournalCartridgeRemoved | Indicates the journal cartridge has been removed.
ExtendedErrorJournalEmpty | Indicates the journal station is out of paper.
ExtendedErrorJournalHeadCleaning | Indicates the journal cartridge head is being cleaned.
ExtendedErrorReceiptCartridgeEmpty | Indicates the receipt cartridge is empty.
ExtendedErrorReceiptCartridgeRemoved | Indicates the receipt cartridge has been removed.
ExtendedErrorReceiptEmpty | Indicates the receipt station is out of paper.
ExtendedErrorReceiptHeadCleaning | Indicates the receipt cartridge head is being cleaned.
ExtendedErrorSlipCartridgeEmpty | Indicates the slip cartridge is empty.
ExtendedErrorSlipCartridgeRemoved | Indicates the slip cartridge has been removed.
ExtendedErrorSlipEmpty | Indicates a form has not been inserted into the slip station.
ExtendedErrorSlipForm | Indicates a form is present while the printer is being taken out of from removal mode.
ExtendedErrorSlipHeadCleaning | Indicates the slip cartridge head is being cleaned.
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
ExtendedErrorTooBig | Indicates the bitmap is either too wide to print without transformation, or too big to tranform.
PrinterBarCodeCenter | Indicates the bar code should be printed aligned with the center of the station.
PrinterBarCodeLeft | Indicates the bar code should be printed aligned with the leftmost print column.
PrinterBarCodeRight | Indicates the bar code should be printed aligned with the rightmost print column.
PrinterBitmapAsIs | Indicates the bitmap should be printed with one bitmap pixel per printer dot.
PrinterBitmapCenter | Indicates the bitmap should be printed aligned with the center of the station.
PrinterBitmapLeft | Indicates the bitmap should be printed aligned with the leftmost print column.
PrinterBitmapRight | Indicates the bitmap should be printed aligned with the rightmost print column.
PrinterCutPaperFullCut | Indicates a full paper cut.
StatisticBarcodePrintedCount | Incremented when a bar code is successfully printed.
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFailedPaperCutCount | Incremented for each failed paper cut.
StatisticFailedPrintSideChangeCount | Incremented for each failed print side change or failed check flip.
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticFormInsertionCount | Incremented when a form is successfully inserted into the document/slip station.
StatisticHomeErrorCount | Incremented when a home error occurs.
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticJournalCharacterPrintedCount | Incremented for every journal character printed.
StatisticJournalCoverOpenCount | Incremented every time that the document/slip station cover opened.
StatisticJournalLinePrintedCount | Incremented for each journal line printed.
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMaximumTempReachedCount | Incremented every time that maximum temperature is reached.
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticNVRAMWriteCount | Incremented every time that NVRAM is written to.
StatisticPaperCutCount | Incremented every time that paper is cut successfully.
StatisticPrinterFaultCount | Incremented when a printer fault occurs.
StatisticPrintSideChangeCount | Incremented when the print side changes or a check flips.
StatisticReceiptCharacterPrintedCount | Incremented every time that a receipt character is printed.
StatisticReceiptCoverOpenCount | Incremented every time that the receipt cover opened.
StatisticReceiptLineFeedCount | Incremented every time that a receipt line feed is performed.
StatisticReceiptLinePrintedCount | Incremented every time that a receipt line is printed.
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticSlipCharacterPrintedCount | Incremented every time that a slip character is printed.
StatisticSlipCoverOpenCount | Incremented every time that the slip cover opened.
StatisticSlipLineFeedCount | Incremented every time that a slip line feed is performed.
StatisticSlipLinePrintedCount | Incremented every time that a slip line is printed.
StatisticStampFiredCount | Incremented for each Stamp raised.
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusCoverOK | Indicates the printer cover is closed.
StatusCoverOpen | Indicates the printer cover is open.
StatusIdle | Indicates all asynchronous output is finished, either successfully or because the output has been cleared. The printer State property is now set to ControlState.Idle.
StatusJournalCartridgeEmpty | Indicates the journal cartridge has to be replaced.
StatusJournalCartridgeNearEmpty | Indicates the journal cartridge is near its end.
StatusJournalCartridgeOK | Indicates all journal cartridges are ready.
StatusJournalCoverOK | Indicates the journal cover is closed.
StatusJournalCoverOpen | Indicates the journal cover is open.
StatusJournalEmpty | Indicates there is no journal paper.
StatusJournalHeadCleaning | Indicates the journal cartridge has begun head cleaning.
StatusJournalNearEmpty | Indicates the journal paper is low.
StatusJournalPaperOK | Indicates the journal paper is ready.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusReceiptCartridgeEmpty | Indicates the receipt cartridge has to be replaced.
StatusReceiptCartridgeNearEmpty | Indicates the receipt cartridge is nearing empty.
StatusReceiptCartridgeOK | Indicates all receipt cartridges are ready.
StatusReceiptCoverOK | Indicates the receipt cover is closed.
StatusReceiptCoverOpen | Indicates the receipt cover is open.
StatusReceiptEmpty | Indicates there is no receipt paper.
StatusReceiptHeadCleaning | Indicates the receipt cartridge has begun head cleaning.
StatusReceiptNearEmpty | Indicates the receipt paper is low.
StatusReceiptPaperOK | Indicates the receipt paper is ready.
StatusSlipCartridgeEmpty | Indicates the slip cartridge has to be replaced.
StatusSlipCartridgeNearEmpty | Indicates the slip cartridge is nearing empty.
StatusSlipCartridgeOK | Indicates all slip cartridges are ready.
StatusSlipCoverOK | Indicates the slip cover is closed.
StatusSlipCoverOpen | Indicates the slip cover is open.
StatusSlipEmpty | Indicates that no slip form is inserted and no slip form has been detected at the entrance to the slip station.
StatusSlipHeadCleaning | Indicates the receipt cartridge has begun head cleaning.
StatusSlipNearEmpty | Indicates the slip form is close to the bottom.
StatusSlipPaperOK | Indicates the slip form is inserted.
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

PosPrinter Class
Microsoft.PointOfService Namespace


PosPrinter.CharacterSetAnsi Field

PosPrinter.CharacterSetAnsi Field |
 | See Also

1/18/2008

Indicates the default character set supports the ANSI character set.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const CharacterSetAnsi As Integer
public const int CharacterSetAnsi
public:
literal int CharacterSetAnsi
public static final int CharacterSetAnsi
public const var CharacterSetAnsi : int

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CharacterSetAscii Field

PosPrinter.CharacterSetAscii Field |
 | See Also

1/18/2008

Indicates the default character set supports the ASCII character set.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const CharacterSetAscii As Integer
public const int CharacterSetAscii
public:
literal int CharacterSetAscii
public static final int CharacterSetAscii
public const var CharacterSetAscii : int

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CharacterSetUnicode Field

PosPrinter.CharacterSetUnicode Field |
 | See Also

1/18/2008

Indicates the default character set supports the Unicode character set.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const CharacterSetUnicode As Integer
public const int CharacterSetUnicode
public:
literal int CharacterSetUnicode
public static final int CharacterSetUnicode
public const var CharacterSetUnicode : int

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.ExtendedErrorBadFormat Field

PosPrinter.ExtendedErrorBadFormat Field |
 | See Also

1/18/2008

Indicates an unsupported format.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorBadFormat As Integer
public const int ExtendedErrorBadFormat
public:
literal int ExtendedErrorBadFormat
public static final int ExtendedErrorBadFormat
public const var ExtendedErrorBadFormat : int

Remarks

Used as an extended error in ErrorEvent events, or thrown as an exception in print methods.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.ExtendedErrorCoverOpen Field

PosPrinter.ExtendedErrorCoverOpen Field |
 | See Also

1/18/2008

Indicates that the printer cover is open.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorCoverOpen As Integer
public const int ExtendedErrorCoverOpen
public:
literal int ExtendedErrorCoverOpen
public static final int ExtendedErrorCoverOpen
public const var ExtendedErrorCoverOpen : int

Remarks

Used as an extended error in ErrorEvent events, or thrown as an exception in print methods.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.ExtendedErrorJournalCartridgeEmpty Field

PosPrinter.ExtendedErrorJournalCartridgeEmpty Field |
 | See Also

1/18/2008

Indicates the journal cartridge is empty.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorJournalCartridgeEmpty As Integer
public const int ExtendedErrorJournalCartridgeEmpty
public:
literal int ExtendedErrorJournalCartridgeEmpty
public static final int ExtendedErrorJournalCartridgeEmpty
public const var ExtendedErrorJournalCartridgeEmpty : int

Remarks

Used as an extended error in ErrorEvent events, or thrown as an exception in print methods.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.ExtendedErrorJournalCartridgeRemoved Field

PosPrinter.ExtendedErrorJournalCartridgeRemoved Field |
 | See Also

1/18/2008

Indicates the journal cartridge has been removed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorJournalCartridgeRemoved As Integer
public const int ExtendedErrorJournalCartridgeRemoved
public:
literal int ExtendedErrorJournalCartridgeRemoved
public static final int ExtendedErrorJournalCartridgeRemoved
public const var ExtendedErrorJournalCartridgeRemoved : int

Remarks

Used as an extended error in ErrorEvent events, or thrown as an exception in print methods.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.ExtendedErrorJournalEmpty Field

PosPrinter.ExtendedErrorJournalEmpty Field |
 | See Also

1/18/2008

Indicates the journal station is out of paper.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorJournalEmpty As Integer
public const int ExtendedErrorJournalEmpty
public:
literal int ExtendedErrorJournalEmpty
public static final int ExtendedErrorJournalEmpty
public const var ExtendedErrorJournalEmpty : int

Remarks

Used as an extended error in ErrorEvent events, or thrown as an exception in print methods. Indicates that the journal paper is empty.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.ExtendedErrorJournalHeadCleaning Field

PosPrinter.ExtendedErrorJournalHeadCleaning Field |
 | See Also

1/18/2008

Indicates the journal cartridge head is being cleaned.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorJournalHeadCleaning As Integer
public const int ExtendedErrorJournalHeadCleaning
public:
literal int ExtendedErrorJournalHeadCleaning
public static final int ExtendedErrorJournalHeadCleaning
public const var ExtendedErrorJournalHeadCleaning : int

Remarks

Used as an extended error in ErrorEvent events, or thrown as an exception in print methods.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.ExtendedErrorReceiptCartridgeEmpty Field

PosPrinter.ExtendedErrorReceiptCartridgeEmpty Field |
 | See Also

1/18/2008

Indicates the receipt cartridge is empty.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorReceiptCartridgeEmpty As Integer
public const int ExtendedErrorReceiptCartridgeEmpty
public:
literal int ExtendedErrorReceiptCartridgeEmpty
public static final int ExtendedErrorReceiptCartridgeEmpty
public const var ExtendedErrorReceiptCartridgeEmpty : int

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.ExtendedErrorReceiptCartridgeRemoved Field

PosPrinter.ExtendedErrorReceiptCartridgeRemoved Field |
 | See Also

1/18/2008

Indicates the receipt cartridge has been removed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorReceiptCartridgeRemoved As Integer
public const int ExtendedErrorReceiptCartridgeRemoved
public:
literal int ExtendedErrorReceiptCartridgeRemoved
public static final int ExtendedErrorReceiptCartridgeRemoved
public const var ExtendedErrorReceiptCartridgeRemoved : int

Remarks

Used as an extended error in ErrorEvent events, or thrown as an exception in print methods.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.ExtendedErrorReceiptEmpty Field

PosPrinter.ExtendedErrorReceiptEmpty Field |
 | See Also

1/18/2008

Indicates the receipt station is out of paper.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorReceiptEmpty As Integer
public const int ExtendedErrorReceiptEmpty
public:
literal int ExtendedErrorReceiptEmpty
public static final int ExtendedErrorReceiptEmpty
public const var ExtendedErrorReceiptEmpty : int

Remarks

Used as an extended error in ErrorEvent events, or thrown as an exception in print methods. Indicates that the receipt paper is empty.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.ExtendedErrorReceiptHeadCleaning Field

PosPrinter.ExtendedErrorReceiptHeadCleaning Field |
 | See Also

1/18/2008

Indicates the receipt cartridge head is being cleaned.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorReceiptHeadCleaning As Integer
public const int ExtendedErrorReceiptHeadCleaning
public:
literal int ExtendedErrorReceiptHeadCleaning
public static final int ExtendedErrorReceiptHeadCleaning
public const var ExtendedErrorReceiptHeadCleaning : int

Remarks

Used as an extended error in ErrorEvent events, or thrown as an exception in print methods.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.ExtendedErrorSlipCartridgeEmpty Field

PosPrinter.ExtendedErrorSlipCartridgeEmpty Field |
 | See Also

1/18/2008

Indicates the slip cartridge is empty.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorSlipCartridgeEmpty As Integer
public const int ExtendedErrorSlipCartridgeEmpty
public:
literal int ExtendedErrorSlipCartridgeEmpty
public static final int ExtendedErrorSlipCartridgeEmpty
public const var ExtendedErrorSlipCartridgeEmpty : int

Remarks

Used as an extended error in ErrorEvent events, or thrown as an exception in print methods.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.ExtendedErrorSlipCartridgeRemoved Field

PosPrinter.ExtendedErrorSlipCartridgeRemoved Field |
 | See Also

1/18/2008

Indicates the slip cartridge has been removed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorSlipCartridgeRemoved As Integer
public const int ExtendedErrorSlipCartridgeRemoved
public:
literal int ExtendedErrorSlipCartridgeRemoved
public static final int ExtendedErrorSlipCartridgeRemoved
public const var ExtendedErrorSlipCartridgeRemoved : int

Remarks

Used as an extended error in ErrorEvent events, or thrown as an exception in print methods.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.ExtendedErrorSlipEmpty Field

PosPrinter.ExtendedErrorSlipEmpty Field |
 | See Also

1/18/2008

Indicates a form has not been inserted into the slip station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorSlipEmpty As Integer
public const int ExtendedErrorSlipEmpty
public:
literal int ExtendedErrorSlipEmpty
public static final int ExtendedErrorSlipEmpty
public const var ExtendedErrorSlipEmpty : int

Remarks

Used as an extended error in ErrorEvent events, or thrown as an exception in print methods. Indicates that no slip form is present.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.ExtendedErrorSlipForm Field

PosPrinter.ExtendedErrorSlipForm Field |
 | See Also

1/18/2008

Indicates a form is present while the printer is being taken out of from removal mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorSlipForm As Integer
public const int ExtendedErrorSlipForm
public:
literal int ExtendedErrorSlipForm
public static final int ExtendedErrorSlipForm
public const var ExtendedErrorSlipForm : int

Remarks

Used as an extended error in ErrorEvent events, or thrown as an exception in print methods. Indicates that a slip form is present but the printer is being taken out of form-removal mode.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.ExtendedErrorSlipHeadCleaning Field

PosPrinter.ExtendedErrorSlipHeadCleaning Field |
 | See Also

1/18/2008

Indicates the slip cartridge head is being cleaned.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorSlipHeadCleaning As Integer
public const int ExtendedErrorSlipHeadCleaning
public:
literal int ExtendedErrorSlipHeadCleaning
public static final int ExtendedErrorSlipHeadCleaning
public const var ExtendedErrorSlipHeadCleaning : int

Remarks

Used as an extended error in ErrorEvent events, or thrown as an exception in print methods.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.ExtendedErrorTooBig Field

PosPrinter.ExtendedErrorTooBig Field |
 | See Also

1/18/2008

Indicates the bitmap is either too wide to print without transformation, or too big to tranform.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorTooBig As Integer
public const int ExtendedErrorTooBig
public:
literal int ExtendedErrorTooBig
public static final int ExtendedErrorTooBig
public const var ExtendedErrorTooBig : int

Remarks

Used as an extended error in ErrorEvent events, or thrown as an exception in print methods.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.PrinterBarCodeCenter Field

PosPrinter.PrinterBarCodeCenter Field |
 | See Also

1/18/2008

Indicates the bar code should be printed aligned with the center of the station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PrinterBarCodeCenter As Integer
public const int PrinterBarCodeCenter
public:
literal int PrinterBarCodeCenter
public static final int PrinterBarCodeCenter
public const var PrinterBarCodeCenter : int

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PrintBarCode


PosPrinter.PrinterBarCodeLeft Field

PosPrinter.PrinterBarCodeLeft Field |
 | See Also

1/18/2008

Indicates the bar code should be printed aligned with the leftmost print column.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PrinterBarCodeLeft As Integer
public const int PrinterBarCodeLeft
public:
literal int PrinterBarCodeLeft
public static final int PrinterBarCodeLeft
public const var PrinterBarCodeLeft : int

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PrintBarCode


PosPrinter.PrinterBarCodeRight Field

PosPrinter.PrinterBarCodeRight Field |
 | See Also

1/18/2008

Indicates the bar code should be printed aligned with the rightmost print column.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PrinterBarCodeRight As Integer
public const int PrinterBarCodeRight
public:
literal int PrinterBarCodeRight
public static final int PrinterBarCodeRight
public const var PrinterBarCodeRight : int

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PrintBarCode


PosPrinter.PrinterBitmapAsIs Field

PosPrinter.PrinterBitmapAsIs Field |
 | See Also

1/18/2008

Indicates the bitmap should be printed with one bitmap pixel per printer dot.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PrinterBitmapAsIs As Integer
public const int PrinterBitmapAsIs
public:
literal int PrinterBitmapAsIs
public static final int PrinterBitmapAsIs
public const var PrinterBitmapAsIs : int

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PrintBitmap


PosPrinter.PrinterBitmapCenter Field

PosPrinter.PrinterBitmapCenter Field |
 | See Also

1/18/2008

Indicates the bitmap should be printed aligned with the center of the station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PrinterBitmapCenter As Integer
public const int PrinterBitmapCenter
public:
literal int PrinterBitmapCenter
public static final int PrinterBitmapCenter
public const var PrinterBitmapCenter : int

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PrintBitmap


PosPrinter.PrinterBitmapLeft Field

PosPrinter.PrinterBitmapLeft Field |
 | See Also

1/18/2008

Indicates the bitmap should be printed aligned with the leftmost print column.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PrinterBitmapLeft As Integer
public const int PrinterBitmapLeft
public:
literal int PrinterBitmapLeft
public static final int PrinterBitmapLeft
public const var PrinterBitmapLeft : int

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PrintBitmap


PosPrinter.PrinterBitmapRight Field

PosPrinter.PrinterBitmapRight Field |
 | See Also

1/18/2008

Indicates the bitmap should be printed aligned with the rightmost print column.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PrinterBitmapRight As Integer
public const int PrinterBitmapRight
public:
literal int PrinterBitmapRight
public static final int PrinterBitmapRight
public const var PrinterBitmapRight : int

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PrintBitmap


PosPrinter.PrinterCutPaperFullCut Field

PosPrinter.PrinterCutPaperFullCut Field |
 | See Also

1/18/2008

Indicates a full paper cut.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const PrinterCutPaperFullCut As Integer
public const int PrinterCutPaperFullCut
public:
literal int PrinterCutPaperFullCut
public static final int PrinterCutPaperFullCut
public const var PrinterCutPaperFullCut : int

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
CutPaper


PosPrinter.StatisticBarcodePrintedCount Field

PosPrinter.StatisticBarcodePrintedCount Field |
 | See Also

1/18/2008

Incremented when a bar code is successfully printed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticBarcodePrintedCount As String
public const string StatisticBarcodePrintedCount
public:
literal String^ StatisticBarcodePrintedCount
public static final String StatisticBarcodePrintedCount
public const var StatisticBarcodePrintedCount : String

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatisticFailedPaperCutCount Field

PosPrinter.StatisticFailedPaperCutCount Field |
 | See Also

1/18/2008

Incremented for each failed paper cut.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticFailedPaperCutCount As String
public const string StatisticFailedPaperCutCount
public:
literal String^ StatisticFailedPaperCutCount
public static final String StatisticFailedPaperCutCount
public const var StatisticFailedPaperCutCount : String

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatisticFailedPrintSideChangeCount Field

PosPrinter.StatisticFailedPrintSideChangeCount Field |
 | See Also

1/18/2008

Incremented for each failed print side change or failed check flip.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticFailedPrintSideChangeCount As String
public const string StatisticFailedPrintSideChangeCount
public:
literal String^ StatisticFailedPrintSideChangeCount
public static final String StatisticFailedPrintSideChangeCount
public const var StatisticFailedPrintSideChangeCount : String

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatisticFormInsertionCount Field

PosPrinter.StatisticFormInsertionCount Field |
 | See Also

1/18/2008

Incremented when a form is successfully inserted into the document/slip station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticFormInsertionCount As String
public const string StatisticFormInsertionCount
public:
literal String^ StatisticFormInsertionCount
public static final String StatisticFormInsertionCount
public const var StatisticFormInsertionCount : String

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatisticHomeErrorCount Field

PosPrinter.StatisticHomeErrorCount Field |
 | See Also

1/18/2008

Incremented when a home error occurs.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticHomeErrorCount As String
public const string StatisticHomeErrorCount
public:
literal String^ StatisticHomeErrorCount
public static final String StatisticHomeErrorCount
public const var StatisticHomeErrorCount : String

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatisticJournalCharacterPrintedCount Field

PosPrinter.StatisticJournalCharacterPrintedCount Field |
 | See Also

1/18/2008

Incremented for every journal character printed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticJournalCharacterPrintedCount As String
public const string StatisticJournalCharacterPrintedCount
public:
literal String^ StatisticJournalCharacterPrintedCount
public static final String StatisticJournalCharacterPrintedCount
public const var StatisticJournalCharacterPrintedCount : String

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatisticJournalCoverOpenCount Field

PosPrinter.StatisticJournalCoverOpenCount Field |
 | See Also

1/18/2008

Incremented every time that the document/slip station cover opened.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticJournalCoverOpenCount As String
public const string StatisticJournalCoverOpenCount
public:
literal String^ StatisticJournalCoverOpenCount
public static final String StatisticJournalCoverOpenCount
public const var StatisticJournalCoverOpenCount : String

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatisticJournalLinePrintedCount Field

PosPrinter.StatisticJournalLinePrintedCount Field |
 | See Also

1/18/2008

Incremented for each journal line printed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticJournalLinePrintedCount As String
public const string StatisticJournalLinePrintedCount
public:
literal String^ StatisticJournalLinePrintedCount
public static final String StatisticJournalLinePrintedCount
public const var StatisticJournalLinePrintedCount : String

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatisticMaximumTempReachedCount Field

PosPrinter.StatisticMaximumTempReachedCount Field |
 | See Also

1/18/2008

Incremented every time that maximum temperature is reached.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticMaximumTempReachedCount As String
public const string StatisticMaximumTempReachedCount
public:
literal String^ StatisticMaximumTempReachedCount
public static final String StatisticMaximumTempReachedCount
public const var StatisticMaximumTempReachedCount : String

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatisticNVRAMWriteCount Field

PosPrinter.StatisticNVRAMWriteCount Field |
 | See Also

1/18/2008

Incremented every time that NVRAM is written to.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticNVRAMWriteCount As String
public const string StatisticNVRAMWriteCount
public:
literal String^ StatisticNVRAMWriteCount
public static final String StatisticNVRAMWriteCount
public const var StatisticNVRAMWriteCount : String

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatisticPaperCutCount Field

PosPrinter.StatisticPaperCutCount Field |
 | See Also

1/18/2008

Incremented every time that paper is cut successfully.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticPaperCutCount As String
public const string StatisticPaperCutCount
public:
literal String^ StatisticPaperCutCount
public static final String StatisticPaperCutCount
public const var StatisticPaperCutCount : String

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatisticPrinterFaultCount Field

PosPrinter.StatisticPrinterFaultCount Field |
 | See Also

1/18/2008

Incremented when a printer fault occurs.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticPrinterFaultCount As String
public const string StatisticPrinterFaultCount
public:
literal String^ StatisticPrinterFaultCount
public static final String StatisticPrinterFaultCount
public const var StatisticPrinterFaultCount : String

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatisticPrintSideChangeCount Field

PosPrinter.StatisticPrintSideChangeCount Field |
 | See Also

1/18/2008

Incremented when the print side changes or a check flips.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticPrintSideChangeCount As String
public const string StatisticPrintSideChangeCount
public:
literal String^ StatisticPrintSideChangeCount
public static final String StatisticPrintSideChangeCount
public const var StatisticPrintSideChangeCount : String

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatisticReceiptCharacterPrintedCount Field

PosPrinter.StatisticReceiptCharacterPrintedCount Field |
 | See Also

1/18/2008

Incremented every time that a receipt character is printed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticReceiptCharacterPrintedCount As String
public const string StatisticReceiptCharacterPrintedCount
public:
literal String^ StatisticReceiptCharacterPrintedCount
public static final String StatisticReceiptCharacterPrintedCount
public const var StatisticReceiptCharacterPrintedCount : String

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatisticReceiptCoverOpenCount Field

PosPrinter.StatisticReceiptCoverOpenCount Field |
 | See Also

1/18/2008

Incremented every time that the receipt cover opened.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticReceiptCoverOpenCount As String
public const string StatisticReceiptCoverOpenCount
public:
literal String^ StatisticReceiptCoverOpenCount
public static final String StatisticReceiptCoverOpenCount
public const var StatisticReceiptCoverOpenCount : String

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatisticReceiptLineFeedCount Field

PosPrinter.StatisticReceiptLineFeedCount Field |
 | See Also

1/18/2008

Incremented every time that a receipt line feed is performed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticReceiptLineFeedCount As String
public const string StatisticReceiptLineFeedCount
public:
literal String^ StatisticReceiptLineFeedCount
public static final String StatisticReceiptLineFeedCount
public const var StatisticReceiptLineFeedCount : String

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatisticReceiptLinePrintedCount Field

PosPrinter.StatisticReceiptLinePrintedCount Field |
 | See Also

1/18/2008

Incremented every time that a receipt line is printed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticReceiptLinePrintedCount As String
public const string StatisticReceiptLinePrintedCount
public:
literal String^ StatisticReceiptLinePrintedCount
public static final String StatisticReceiptLinePrintedCount
public const var StatisticReceiptLinePrintedCount : String

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatisticSlipCharacterPrintedCount Field

PosPrinter.StatisticSlipCharacterPrintedCount Field |
 | See Also

1/18/2008

Incremented every time that a slip character is printed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticSlipCharacterPrintedCount As String
public const string StatisticSlipCharacterPrintedCount
public:
literal String^ StatisticSlipCharacterPrintedCount
public static final String StatisticSlipCharacterPrintedCount
public const var StatisticSlipCharacterPrintedCount : String

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatisticSlipCoverOpenCount Field

PosPrinter.StatisticSlipCoverOpenCount Field |
 | See Also

1/18/2008

Incremented every time that the slip cover opened.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticSlipCoverOpenCount As String
public const string StatisticSlipCoverOpenCount
public:
literal String^ StatisticSlipCoverOpenCount
public static final String StatisticSlipCoverOpenCount
public const var StatisticSlipCoverOpenCount : String

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatisticSlipLineFeedCount Field

PosPrinter.StatisticSlipLineFeedCount Field |
 | See Also

1/18/2008

Incremented every time that a slip line feed is performed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticSlipLineFeedCount As String
public const string StatisticSlipLineFeedCount
public:
literal String^ StatisticSlipLineFeedCount
public static final String StatisticSlipLineFeedCount
public const var StatisticSlipLineFeedCount : String

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatisticSlipLinePrintedCount Field

PosPrinter.StatisticSlipLinePrintedCount Field |
 | See Also

1/18/2008

Incremented every time that a slip line is printed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticSlipLinePrintedCount As String
public const string StatisticSlipLinePrintedCount
public:
literal String^ StatisticSlipLinePrintedCount
public static final String StatisticSlipLinePrintedCount
public const var StatisticSlipLinePrintedCount : String

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatisticStampFiredCount Field

PosPrinter.StatisticStampFiredCount Field |
 | See Also

1/18/2008

Incremented for each Stamp raised.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticStampFiredCount As String
public const string StatisticStampFiredCount
public:
literal String^ StatisticStampFiredCount
public static final String StatisticStampFiredCount
public const var StatisticStampFiredCount : String

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatusCoverOK Field

PosPrinter.StatusCoverOK Field |
 | See Also

1/18/2008

Indicates the printer cover is closed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusCoverOK As Integer
public const int StatusCoverOK
public:
literal int StatusCoverOK
public static final int StatusCoverOK
public const var StatusCoverOK : int

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatusCoverOpen Field

PosPrinter.StatusCoverOpen Field |
 | See Also

1/18/2008

Indicates the printer cover is open.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusCoverOpen As Integer
public const int StatusCoverOpen
public:
literal int StatusCoverOpen
public static final int StatusCoverOpen
public const var StatusCoverOpen : int

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatusIdle Field

PosPrinter.StatusIdle Field |
 | See Also

1/18/2008

Indicates all asynchronous output is finished, either successfully or because the output has been cleared. The printer State property is now set to ControlState.Idle.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusIdle As Integer
public const int StatusIdle
public:
literal int StatusIdle
public static final int StatusIdle
public const var StatusIdle : int

Remarks

The FlagWhenIdle property must be set to true for this event to be delivered, and the property is automatically reset to false only before the event is delivered.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
FlagWhenIdle


PosPrinter.StatusJournalCartridgeEmpty Field

PosPrinter.StatusJournalCartridgeEmpty Field |
 | See Also

1/18/2008

Indicates the journal cartridge has to be replaced.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusJournalCartridgeEmpty As Integer
public const int StatusJournalCartridgeEmpty
public:
literal int StatusJournalCartridgeEmpty
public static final int StatusJournalCartridgeEmpty
public const var StatusJournalCartridgeEmpty : int

Remarks

This StatusUpdateEvent can only be raised when the CartridgeNotify property is set to PrinterCartridgeNotification.Enabled.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatusJournalCartridgeNearEmpty Field

PosPrinter.StatusJournalCartridgeNearEmpty Field |
 | See Also

1/18/2008

Indicates the journal cartridge is near its end.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusJournalCartridgeNearEmpty As Integer
public const int StatusJournalCartridgeNearEmpty
public:
literal int StatusJournalCartridgeNearEmpty
public static final int StatusJournalCartridgeNearEmpty
public const var StatusJournalCartridgeNearEmpty : int

Remarks

This StatusUpdateEvent can only be raised when the CartridgeNotify property is set to PrinterCartridgeNotification.Enabled.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatusJournalCartridgeOK Field

PosPrinter.StatusJournalCartridgeOK Field |
 | See Also

1/18/2008

Indicates all journal cartridges are ready.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusJournalCartridgeOK As Integer
public const int StatusJournalCartridgeOK
public:
literal int StatusJournalCartridgeOK
public static final int StatusJournalCartridgeOK
public const var StatusJournalCartridgeOK : int

Remarks

This StatusUpdateEvent can only be raised when the CartridgeNotify property is set to PrinterCartridgeNotification.Enabled. Note also that this event gives no indication of the media in the cartridge.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatusJournalCoverOK Field

PosPrinter.StatusJournalCoverOK Field |
 | See Also

1/18/2008

Indicates the journal cover is closed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusJournalCoverOK As Integer
public const int StatusJournalCoverOK
public:
literal int StatusJournalCoverOK
public static final int StatusJournalCoverOK
public const var StatusJournalCoverOK : int

Remarks

Note:
If a printer has only one cover, or if the printer cannot determine or report which covers are open, then the StatusUpdateEvent event will be raised by using the StatusPrinterCoverOK constant. For printers supporting multiple covers, the service object will raise the station-specific event first, followed by a general event. If more than one cover was open, the service object will raise a general event by using the StatusPrinterCoverOK constant only after all covers are closed.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatusJournalCoverOpen Field

PosPrinter.StatusJournalCoverOpen Field |
 | See Also

1/18/2008

Indicates the journal cover is open.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusJournalCoverOpen As Integer
public const int StatusJournalCoverOpen
public:
literal int StatusJournalCoverOpen
public static final int StatusJournalCoverOpen
public const var StatusJournalCoverOpen : int

Remarks

Note:
If a printer has only one cover, or if the printer cannot determine or report which covers are open, then the StatusUpdateEvent event will be raised by using the StatusPrinterCoverOpen constant. For printers supporting multiple covers, the service object will raise the station-specific event first, followed by a general event. If more than one cover is open, the service object will raise the general event after a cover is opened, and raise a general event by using the StatusPrinterCoverOK constant only after all covers are closed.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatusJournalEmpty Field

PosPrinter.StatusJournalEmpty Field |
 | See Also

1/18/2008

Indicates there is no journal paper.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusJournalEmpty As Integer
public const int StatusJournalEmpty
public:
literal int StatusJournalEmpty
public static final int StatusJournalEmpty
public const var StatusJournalEmpty : int

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatusJournalHeadCleaning Field

PosPrinter.StatusJournalHeadCleaning Field |
 | See Also

1/18/2008

Indicates the journal cartridge has begun head cleaning.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusJournalHeadCleaning As Integer
public const int StatusJournalHeadCleaning
public:
literal int StatusJournalHeadCleaning
public static final int StatusJournalHeadCleaning
public const var StatusJournalHeadCleaning : int

Remarks

This StatusUpdateEvent can only be raised when the CartridgeNotify property is set to PrinterCartridgeNotification.Enabled.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatusJournalNearEmpty Field

PosPrinter.StatusJournalNearEmpty Field |
 | See Also

1/18/2008

Indicates the journal paper is low.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusJournalNearEmpty As Integer
public const int StatusJournalNearEmpty
public:
literal int StatusJournalNearEmpty
public static final int StatusJournalNearEmpty
public const var StatusJournalNearEmpty : int

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatusJournalPaperOK Field

PosPrinter.StatusJournalPaperOK Field |
 | See Also

1/18/2008

Indicates the journal paper is ready.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusJournalPaperOK As Integer
public const int StatusJournalPaperOK
public:
literal int StatusJournalPaperOK
public static final int StatusJournalPaperOK
public const var StatusJournalPaperOK : int

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatusReceiptCartridgeEmpty Field

PosPrinter.StatusReceiptCartridgeEmpty Field |
 | See Also

1/18/2008

Indicates the receipt cartridge has to be replaced.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusReceiptCartridgeEmpty As Integer
public const int StatusReceiptCartridgeEmpty
public:
literal int StatusReceiptCartridgeEmpty
public static final int StatusReceiptCartridgeEmpty
public const var StatusReceiptCartridgeEmpty : int

Remarks

This StatusUpdateEvent can only be raised when the CartridgeNotify property is set to PrinterCartridgeNotification.Enabled.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatusReceiptCartridgeNearEmpty Field

PosPrinter.StatusReceiptCartridgeNearEmpty Field |
 | See Also

1/18/2008

Indicates the receipt cartridge is nearing empty.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusReceiptCartridgeNearEmpty As Integer
public const int StatusReceiptCartridgeNearEmpty
public:
literal int StatusReceiptCartridgeNearEmpty
public static final int StatusReceiptCartridgeNearEmpty
public const var StatusReceiptCartridgeNearEmpty : int

Remarks

This StatusUpdateEvent can only be raised when the CartridgeNotify property is set to PrinterCartridgeNotification.Enabled.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatusReceiptCartridgeOK Field

PosPrinter.StatusReceiptCartridgeOK Field |
 | See Also

1/18/2008

Indicates all receipt cartridges are ready.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusReceiptCartridgeOK As Integer
public const int StatusReceiptCartridgeOK
public:
literal int StatusReceiptCartridgeOK
public static final int StatusReceiptCartridgeOK
public const var StatusReceiptCartridgeOK : int

Remarks

This StatusUpdateEvent can only be raised when the CartridgeNotify property is set to PrinterCartridgeNotification.Enabled. Note also that this event gives no indication of the media in the cartridge.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatusReceiptCoverOK Field

PosPrinter.StatusReceiptCoverOK Field |
 | See Also

1/18/2008

Indicates the receipt cover is closed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusReceiptCoverOK As Integer
public const int StatusReceiptCoverOK
public:
literal int StatusReceiptCoverOK
public static final int StatusReceiptCoverOK
public const var StatusReceiptCoverOK : int

Remarks

Note: If a printer has only one cover, or if the printer cannot determine or report which covers are open, then the StatusUpdateEvent event will be raised by using the StatusPrinterCoverOK constant. For printers supporting multiple covers, the service object will raise the station-specific event first, followed by a general event. If more than one cover was open, the service object will raise a general event by using the StatusPrinterCoverOK constant only after all covers are closed.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatusReceiptCoverOpen Field

PosPrinter.StatusReceiptCoverOpen Field |
 | See Also

1/18/2008

Indicates the receipt cover is open.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusReceiptCoverOpen As Integer
public const int StatusReceiptCoverOpen
public:
literal int StatusReceiptCoverOpen
public static final int StatusReceiptCoverOpen
public const var StatusReceiptCoverOpen : int

Remarks

Note: If a printer has only one cover, or if the printer cannot determine or report which covers are open, then the StatusUpdateEvent event will be raised by using the StatusPrinterCoverOpen constant. For printers supporting multiple covers, the service object will raise the station-specific event first, followed by a general event. If more than one cover is open, the service object will raise the general event after a cover is opened, and raise a general event by using the StatusPrinterCoverOK constant only after all covers are closed.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatusReceiptEmpty Field

PosPrinter.StatusReceiptEmpty Field |
 | See Also

1/18/2008

Indicates there is no receipt paper.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusReceiptEmpty As Integer
public const int StatusReceiptEmpty
public:
literal int StatusReceiptEmpty
public static final int StatusReceiptEmpty
public const var StatusReceiptEmpty : int

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatusReceiptHeadCleaning Field

PosPrinter.StatusReceiptHeadCleaning Field |
 | See Also

1/18/2008

Indicates the receipt cartridge has begun head cleaning.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusReceiptHeadCleaning As Integer
public const int StatusReceiptHeadCleaning
public:
literal int StatusReceiptHeadCleaning
public static final int StatusReceiptHeadCleaning
public const var StatusReceiptHeadCleaning : int

Remarks

This StatusUpdateEvent can only be raised when the CartridgeNotify property is set to PrinterCartridgeNotification.Enabled.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatusReceiptNearEmpty Field

PosPrinter.StatusReceiptNearEmpty Field |
 | See Also

1/18/2008

Indicates the receipt paper is low.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusReceiptNearEmpty As Integer
public const int StatusReceiptNearEmpty
public:
literal int StatusReceiptNearEmpty
public static final int StatusReceiptNearEmpty
public const var StatusReceiptNearEmpty : int

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatusReceiptPaperOK Field

PosPrinter.StatusReceiptPaperOK Field |
 | See Also

1/18/2008

Indicates the receipt paper is ready.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusReceiptPaperOK As Integer
public const int StatusReceiptPaperOK
public:
literal int StatusReceiptPaperOK
public static final int StatusReceiptPaperOK
public const var StatusReceiptPaperOK : int

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatusSlipCartridgeEmpty Field

PosPrinter.StatusSlipCartridgeEmpty Field |
 | See Also

1/18/2008

Indicates the slip cartridge has to be replaced.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusSlipCartridgeEmpty As Integer
public const int StatusSlipCartridgeEmpty
public:
literal int StatusSlipCartridgeEmpty
public static final int StatusSlipCartridgeEmpty
public const var StatusSlipCartridgeEmpty : int

Remarks

This StatusUpdateEvent can only be raised when the CartridgeNotify property is set to PrinterCartridgeNotification.Enabled.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatusSlipCartridgeNearEmpty Field

PosPrinter.StatusSlipCartridgeNearEmpty Field |
 | See Also

1/18/2008

Indicates the slip cartridge is nearing empty.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusSlipCartridgeNearEmpty As Integer
public const int StatusSlipCartridgeNearEmpty
public:
literal int StatusSlipCartridgeNearEmpty
public static final int StatusSlipCartridgeNearEmpty
public const var StatusSlipCartridgeNearEmpty : int

Remarks

This StatusUpdateEvent can only be raised when the CartridgeNotify property is set to PrinterCartridgeNotification.Enabled.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatusSlipCartridgeOK Field

PosPrinter.StatusSlipCartridgeOK Field |
 | See Also

1/18/2008

Indicates all slip cartridges are ready.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusSlipCartridgeOK As Integer
public const int StatusSlipCartridgeOK
public:
literal int StatusSlipCartridgeOK
public static final int StatusSlipCartridgeOK
public const var StatusSlipCartridgeOK : int

Remarks

This StatusUpdateEvent can only be raised when the CartridgeNotify property is set to PrinterCartridgeNotification.Enabled. Note also that this event gives no indication of the media in the cartridge.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatusSlipCoverOK Field

PosPrinter.StatusSlipCoverOK Field |
 | See Also

1/18/2008

Indicates the slip cover is closed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusSlipCoverOK As Integer
public const int StatusSlipCoverOK
public:
literal int StatusSlipCoverOK
public static final int StatusSlipCoverOK
public const var StatusSlipCoverOK : int

Remarks

Note:
If a printer has only one cover, or if the printer cannot determine or report which covers are open, then the StatusUpdateEvent event will be raised by using the StatusPrinterCoverOK constant. For printers supporting multiple covers, the service object will raise the station-specific event first, followed by a general event. If more than one cover was open, the service object will raise a general event by using the StatusPrinterCoverOK constant only after all covers are closed.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatusSlipCoverOpen Field

PosPrinter.StatusSlipCoverOpen Field |
 | See Also

1/18/2008

Indicates the slip cover is open.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusSlipCoverOpen As Integer
public const int StatusSlipCoverOpen
public:
literal int StatusSlipCoverOpen
public static final int StatusSlipCoverOpen
public const var StatusSlipCoverOpen : int

Remarks

If a printer has only one cover, or if the printer cannot determine or report which covers are open, then the StatusUpdateEvent event will be raised by using the StatusPrinterCoverOpen constant. For printers supporting multiple covers, the service object will raise the station-specific event first, followed by a general event. If more than one cover is open, the service object will raise the general event after a cover is opened, and raise a general event by using the StatusPrinterCoverOK constant only after all covers are closed.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatusSlipEmpty Field

PosPrinter.StatusSlipEmpty Field |
 | See Also

1/18/2008

Indicates that no slip form is inserted and no slip form has been detected at the entrance to the slip station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusSlipEmpty As Integer
public const int StatusSlipEmpty
public:
literal int StatusSlipEmpty
public static final int StatusSlipEmpty
public const var StatusSlipEmpty : int

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatusSlipHeadCleaning Field

PosPrinter.StatusSlipHeadCleaning Field |
 | See Also

1/18/2008

Indicates the receipt cartridge has begun head cleaning.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusSlipHeadCleaning As Integer
public const int StatusSlipHeadCleaning
public:
literal int StatusSlipHeadCleaning
public static final int StatusSlipHeadCleaning
public const var StatusSlipHeadCleaning : int

Remarks

This StatusUpdateEvent can only be raised when the CartridgeNotify property is set to PrinterCartridgeNotification.Enabled.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatusSlipNearEmpty Field

PosPrinter.StatusSlipNearEmpty Field |
 | See Also

1/18/2008

Indicates the slip form is close to the bottom.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusSlipNearEmpty As Integer
public const int StatusSlipNearEmpty
public:
literal int StatusSlipNearEmpty
public static final int StatusSlipNearEmpty
public const var StatusSlipNearEmpty : int

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.StatusSlipPaperOK Field

PosPrinter.StatusSlipPaperOK Field |
 | See Also

1/18/2008

Indicates the slip form is inserted.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusSlipPaperOK As Integer
public const int StatusSlipPaperOK
public:
literal int StatusSlipPaperOK
public static final int StatusSlipPaperOK
public const var StatusSlipPaperOK : int

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter Constructor

PosPrinter Constructor |
 | See Also

1/18/2008

Creates an instance of the PosPrinter class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected PosPrinter ()
protected:
PosPrinter ()
protected PosPrinter ()
protected function PosPrinter ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter Methods

PosPrinter Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
BeginInsertion | Starts form insertion processing. BeginInsertion is paired with the EndInsertion method to control form insertion.
BeginRemoval | Starts form removal processing.
ChangePrintSide | Selects the side of the document that it wants to print on.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearOutput | Clears all device output that has been buffered. Also, when it is possible, stops outputs that are in progress.
ClearPrintArea | Clears the area defined by the PageModePrintArea property.
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
CutPaper | Cuts the receipt paper.
DirectIO | (inherited from PosCommon )
EndInsertion | Ends form-insertion processing.
EndRemoval | Ends form-removal processing.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
MarkFeed | Uses the printer’s mark sensor for receipt paper.
Open | Opens a device for later input/output processing. (inherited from PosCommon )
PageModePrint | Starts or exits Page Mode for the station specified in the PageModeStation property.
PrintBarCode | Prints a bar code on the specified printer station.
PrintBitmap | Prints a bitmap on the specified printer station.
PrintImmediate | Prints the string immediately that is specified for data on the printer station specified by station.
PrintMemoryBitmap | Prints a bitmap from memory on the specified printer station.
PrintNormal | Prints the string specified in data on the printer station specified in station.
PrintTwoNormal | Prints two strings on two print stations concurrently. When supported, this may give increased print performance.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
RotatePrint | Enters or exits rotated print mode.
SetBitmap | Saves information about a bitmap for later printing.
SetLogo | Saves a data string as the top or bottom logo.
ToString | (inherited from Object )
TransactionPrint | Enters or exits transaction mode.
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
ValidateData | Determines whether a data sequence, possibly including one or more escape sequences, is valid for the specified station, before it calls the PrintImmediate, PrintNormal, or PrintTwoNormal methods.

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

PosPrinter Class
Microsoft.PointOfService Namespace


PosPrinter.BeginInsertion Method

PosPrinter.BeginInsertion Method |
 | See Also

1/18/2008

Starts form insertion processing. BeginInsertion is paired with the EndInsertion method to control form insertion.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub BeginInsertion ( _
    timeout As Integer _
)
public abstract void BeginInsertion (
    int timeout
)
public:
virtual void BeginInsertion (
    int timeout
) abstract
public abstract void BeginInsertion (
    int timeout
)
public abstract function BeginInsertion (
    timeout : int
)

Parameters

timeout

The timeout parameter gives the number of milliseconds before failing the method.

Remarks

The service object makes the slip station ready to receive a form by opening the form’s handling "jaws" or by starting a form-insertion mode. The service object continues to monitor form insertion until one of the following conditions is true:

The form is successfully inserted.

The form is not inserted before timeout milliseconds have elapsed. In this case, the service object throws a Timeout exception.

If an error is reported by the Printer device, the service object raises an ErrorEvent event. The Printer device remains in form-insertion mode. This allows an application to perform some user interaction and reissue the BeginInsertion method without altering the form-handling mechanism.

If set to 0 (zero), BeginInsertion tries to start insertion mode (in which a form is inserted), then returns immediately. If timeout is set to the constant WaitForever, BeginInsertion tries to start insertion mode, then waits until either the form is inserted or an error occurs.

Before it calls this method, the application must open, claim, and enable the device.

BeginInsertion may throw a PosControlException with the following ErrorCodes:

Value

Meaning

Timeout

BeginInsertion timed out (the value of the timeout parameter was exceeded) before form insertion mode was started.

Busy

The Printer device is currently being used.

Illegal

One of the following conditions has occurred:

  • The slip print station is not present on this printer (that is, the CapSlpPresent property is set to false).

  • The value given for timeout is less than -1.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
EndInsertion
BeginRemoval
EndRemoval
PosCommon.WaitForever Field


PosPrinter.BeginRemoval Method

PosPrinter.BeginRemoval Method |
 | See Also

1/18/2008

Starts form removal processing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub BeginRemoval ( _
    timeout As Integer _
)
public abstract void BeginRemoval (
    int timeout
)
public:
virtual void BeginRemoval (
    int timeout
) abstract
public abstract void BeginRemoval (
    int timeout
)
public abstract function BeginRemoval (
    timeout : int
)

Parameters

timeout

Remarks

BeginRemoval is paired with the EndRemoval method to control form removal.

The service object makes the printer ready to remove a form by opening the form handling "jaws" or by starting a form-ejection mode. If the Printer device cannot be put into removal or ejection mode, the service object throws an exception. Otherwise, the service object continues to monitor form removal until one of the following conditions is true:

The form is successfully removed.

The form is not removed before timeout milliseconds have elapsed. In this case, the service object throws a Timeout exception.

If an error is reported by the Printer device, the service throws an exception. The Printer device remains in form-removal mode. This allows an application to perform some user interaction and reissue the BeginRemoval method without altering the form-handling mechanism.

If timeout is set to 0 (zero), BeginRemoval tries to start removal mode, then returns immediately. If timeout is set to the constant WaitForever, BeginRemoval tries to start removal mode, then waits until either the form is removed or an error occurs.

Before it calls this method, the application must open, claim, and enable the device.

BeginRemoval may throw a PosControlException with the following ErrorCodes:

Value

Meaning

Timeout

BeginRemoval timed out (the value of the timeout parameter was exceeded) before form-removal mode was started.

Busy

The Printer device is currently being used.

Illegal

One of the following conditions has occurred:

  • The slip print station is not present on this printer (that is, the CapSlpPresent property is set to false).

  • The value of timeout is less than -1.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.BeginInsertion Method
EndInsertion
EndRemoval
PosCommon.WaitForever Field


PosPrinter.ChangePrintSide Method

PosPrinter.ChangePrintSide Method |
 | See Also

1/18/2008

Selects the side of the document that it wants to print on.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ChangePrintSide ( _
    side As PrinterSide _
)
public abstract void ChangePrintSide (
    PrinterSide side
)
public:
virtual void ChangePrintSide (
    PrinterSide side
) abstract
public abstract void ChangePrintSide (
    PrinterSide side
)
public abstract function ChangePrintSide (
    side : PrinterSide
)

Parameters

side

Remarks

ChangePrintSide allows printing on both sides of a document. You can do this by mechanical paper handling of the document or multiple print heads that are positioned to print on each side of the document.

If a document is not inserted, the service object throws an exception.

A side value equal to PrintSide.Side1 indicates the default print side of the document. (Default print side is defined as the side of the document that the printer uses after turn on, the side where printing will occur immediately after the document has been inserted. Therefore, PrintSide.Side1 is selected after the Begin/EndInsertion method is executed.)

A side value equal to PrintSide.Side2 indicates the opposite side of the document from the one that the printer uses after turn on (the reverse of PrintSide.Side1).

A side value equal to PrintSide.Opposite means that the current printing side is switched and printing will now occur on the opposite side of the slip. (For example, if the SlpPrintSide property was set to PrintSide.Side1, it is changed to PrintSide.Side2.)

If side is set to PrintSide.Opposite or to the same as the value of the SlpPrintSide property, the side of the document is changed and the document is fed to TOF.

If side is the same as SlpPrintSide, nothing occurs.

Executing ChangePrintSide can change the setting of the SlpPrintSide property.

If ChangePrintSide fails, the service object increments the Failed PrintSideChangedCount statistic; if ChangePrintSide succeeds and the print side was changed, the service object increments the PrintSideChangedCount statistic.

Before it calls this method, the application must open, claim, and enable the device.

ChangePrintSide may throw a PosControlException with the following ErrorCodes:

Value

Meaning

Busy

The Printer device is currently being used. (Can be returned only if AsyncMode is false.)

Illegal

One of the following conditions has occurred:

  • The slip print station is not present on this printer (that is, the CapSlpPresent property is set to false).

  • The printer does not support two-sided printing (that is, the CapSlpBothSidesPrint property is set to false).

  • No slip has been inserted—that is, the application has not called the BeginInsertion and EndInsertion methods before it calls ChangePrintSide.

  • The printer is currently in Insertion mode.

  • The printer is currently in Removal mode.

  • The side parameter contains a value that does not exist in the PrintSide enumeration.

Extended

ExtendedErrorCoverOpen: The printer cover is open.

ExtendedErrorSlpEmpty: The slip station is out of paper.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
CapSlpPresent
CapSlpBothSidesPrint
SlpPrintSide
PrinterSide


PosPrinter.ClearOutput Method

PosPrinter.ClearOutput Method |
 | See Also

1/18/2008

Clears all device output that has been buffered. Also, when it is possible, stops outputs that are in progress.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearOutput
public abstract void ClearOutput ()
public:
virtual void ClearOutput () abstract
public abstract void ClearOutput ()
public abstract function ClearOutput ()

Remarks

Any output error events that were queued by the service object—usually waiting for FreezeEvents to be set to false—are also cleared.

Before it calls this method, the application must open and claim the device.

ClearOutput may throw a PosControlException with the following ErrorCodes:

Value | Meaning
Claimed | The device is claimed by another process.
NotClaimed | The device must be claimed before this method can be used.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosCommon.FreezeEvents Property


PosPrinter.ClearPrintArea Method

PosPrinter.ClearPrintArea Method |
 | See Also

1/18/2008

Clears the area defined by the PageModePrintArea property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Sub ClearPrintArea
public virtual void ClearPrintArea ()
public:
virtual void ClearPrintArea ()
public void ClearPrintArea ()
public function ClearPrintArea ()

Remarks

The page may be cleared by setting the PageModePrintArea to be the same as the PageModeArea and then by using ClearPrintArea or by exiting Page Mode with PageModePrint (where PageModePrintControl is set to Cancel).

The PageModeStation property must be set to a valid station before invoking ClearPrintArea.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CutPaper Method

PosPrinter.CutPaper Method |
 | See Also

1/18/2008

Cuts the receipt paper.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub CutPaper ( _
    percentage As Integer _
)
public abstract void CutPaper (
    int percentage
)
public:
virtual void CutPaper (
    int percentage
) abstract
public abstract void CutPaper (
    int percentage
)
public abstract function CutPaper (
    percentage : int
)

Parameters

percentage

The percentage parameter indicates the percentage of paper to cut. If percentage is set to the constant PrinterCutPaperFullCut, this causes a full paper cut. Other percentage values request a partial cut.

Remarks

CutPaper is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

Many printers with paper cutting capability can perform both full and partial cuts. Some offer gradations of partial cuts, such as a perforated cut and an almost-full cut. Although the exact type of cut varies by printer capabilities, the following general guide may be used:

Value | Meaning
100 | Full cut.
90 | Leave only a small part of paper for very easy final separation.
70 | Perforate the paper for final separation that is somewhat more difficult and unlikely to occur by accidental handling.
50 | Partial perforation of the paper.

The service object will select an appropriate type of cut based on the capabilities of its device and these general guidelines.

An escape sequence (ESC|#P) embedded in a PrintNormal or PrintImmediate method call may also be used to cause a paper cut.

Before it calls this method, the application must open, claim, and enable the device.

CutPaper may throw a PosControlException with the following ErrorCodes:

Value

Meaning

Busy

The Printer device is currently being used. (Can be returned only if AsyncMode is false.)

Illegal

One of the following conditions has occurred:

  • The value specified for percentage is not between 0 (zero) and 100.

  • The receipt station does not exist (that is, the CapRecPresent property is set to false).

  • The receipt printer does not have paper cutting ability (that is, the CapRecPapercut property is set to false).

  • The printer is currently in Insertion mode.

  • The printer is currently in Removal mode.

  • The specified rotation mode has to be either Normal or Rotate180.

Extended

ExtendedErrorCoverOpen: The printer cover is open. (Can be thrown only if AsyncMode is false.)

ExtendedErrorRecEmpty: The receipt station is out of paper. (Can be thrown only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
CapRecPresent
CapRecPaperCut
RotateSpecial
PrintNormal
PrintImmediate


PosPrinter.EndInsertion Method

PosPrinter.EndInsertion Method |
 | See Also

1/18/2008

Ends form-insertion processing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub EndInsertion
public abstract void EndInsertion ()
public:
virtual void EndInsertion () abstract
public abstract void EndInsertion ()
public abstract function EndInsertion ()

Remarks

When it is called, the service object takes the printer out of form-insertion mode. If the slip device has form "jaws," EndInsertion closes them. If no form is present, an Extended exception is thrown, by using the ExtendedErrorSlpEmpty constant.

If it is successful, EndInsertion increments the StatisticFormInsertionCount statistic.

EndInsertion is paired with the BeginInsertion method for controlling form insertion. The application can call EndInsertion immediately after a successful BeginInsertion to use printer sensors to determine when a form is positioned within the slip printer. Alternatively, the application may prompt the user and wait for a key press before it calls EndInsertion.

Before it calls this method, the application must open, claim, and enable the device.

EndInsertion may throw a PosControlException with the following ErrorCodes:

Value | Meaning
Busy | The printer is currently being used.
Illegal | The printer is not in insertion mode (the BeginInsertion method has not been called before calling EndInsertion).
Extended | ExtendedErrorCoverOpen: The device was taken out of insertion mode while the printer cover was open. ExtendedErrorSlpEmpty: The device was taken out of insertion mode without a form being inserted.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.BeginInsertion Method
PosPrinter.BeginRemoval Method
EndRemoval


PosPrinter.EndRemoval Method

PosPrinter.EndRemoval Method |
 | See Also

1/18/2008

Ends form-removal processing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub EndRemoval
public abstract void EndRemoval ()
public:
virtual void EndRemoval () abstract
public abstract void EndRemoval ()
public abstract function EndRemoval ()

Remarks

When it is called, the printer is taken out of form-removal or ejection mode.

If a form is present, an Extended exception is thrown, by using the constant ExtendedErrorSlpForm.

EndRemoval is paired with the BeginRemoval method for controlling form removal. The application can call EndRemoval immediately after a successful BeginRemoval to use printer sensors to determine when the form has been removed. Alternatively, the application can prompt the user and wait for a key press before it calls EndRemoval.

Before it calls this method, the application must open, claim, and enable the device.

EndRemoval may throw a PosControlException with the following ErrorCodes:

Value | Meaning
Busy | The printer is currently being used.
Illegal | The printer is not in removal mode (the BeginRemoval method has not been called before calling EndRemoval).
Extended | ExtendedErrorSlpForm: The device was taken out of removal mode while a form was still present.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.BeginInsertion Method
PosPrinter.EndInsertion Method
PosPrinter.BeginRemoval Method


PosPrinter.MarkFeed Method

PosPrinter.MarkFeed Method |
 | See Also

1/18/2008

Uses the printer’s mark sensor for receipt paper.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub MarkFeed ( _
    type As PrinterMarkFeeds _
)
public abstract void MarkFeed (
    PrinterMarkFeeds type
)
public:
virtual void MarkFeed (
    PrinterMarkFeeds type
) abstract
public abstract void MarkFeed (
    PrinterMarkFeeds type
)
public abstract function MarkFeed (
    type : PrinterMarkFeeds
)

Parameters

type

Remarks

MarkFeed is performed synchronously if the AsyncMode property is set to FALSE, and asynchronously if AsyncMode is true.

If type is PrinterMarkFeeds.Takeup, the printer will feed the mark-sensed paper so that the present form is positioned to be manually removed by the operator.

If type is PrinterMarkFeeds.Cutter, the printer will feed the mark-sensed paper so that the present form is positioned to be cut off by the auto cutter. This will usually be followed by a call to the CutPaper method.

If type is PrinterMarkFeeds.CurrentTopOfForm, the printer will feed the mark-sensed paper (backward if it is necessary) so that the print head points to the top of the present form.

If type is PrinterMarkFeeds.NextTopOfForm, the printer will feed the mark-sensed paper so that the print head points to the top of the next form.

Before it calls this method, the application must open, claim, and enable the device.

MarkFeed may throw a PosControlException with the following ErrorCodes:

Value

Meaning

Busy

The printer is currently being used. (Can be returned only if AsyncMode is false.)

Illegal

One of the following conditions has occurred:

  • The receipt station does not exist (that is, the CapRecPresent property is set to false).

  • The receipt print station does not support the given mark-sensed paper-handling function (that is, the CapRecMarkFeed property is set to PrinterMarkFeeds.None).

  • The printer is currently in Insertion mode.

  • The printer is currently in Removal mode.

  • The value specified for type does not exist in the PrinterMarkFeeds enumeration.

Extended

ExtendedErrorCoverOpen: Printer cover is open. (Can be thrown only if AsyncMode is false.)

ExtendedErrorRecEmpty: Receipt paper is empty. (Can be thrown only if AsyncMode is false.)

ExtendedErrorRecCartridgeEmpty: A receipt cartridge is empty. (Can be thrown only if AsyncMode is false.)

ExtendedErrorRecCartridgeRemoved: A receipt cartridge is removed. (Can be thrown only if AsyncMode is false.)

ExtendedErrorRecHeadCleaning: A receipt head is being cleaned. (Can be thrown only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PrinterMarkFeeds
CapRecPresent
CapRecMarkFeed


PosPrinter.PageModePrint Method

PosPrinter.PageModePrint Method |
 | See Also

1/18/2008

Starts or exits Page Mode for the station specified in the PageModeStation property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Sub PageModePrint ( _
    control As PageModePrintControl _
)
public virtual void PageModePrint (
    PageModePrintControl control
)
public:
virtual void PageModePrint (
    PageModePrintControl control
)
public void PageModePrint (
    PageModePrintControl control
)
public function PageModePrint (
    control : PageModePrintControl
)

Parameters

control

The Page Mode control.

Remarks

If control is PageMode, then Page Mode is entered. Later calls to PrintNormal, PrintBarCode, and PrintBitmap buffer the print data (either at the printer or the Service, depending on the printer capabilities) until PageModePrint is called by using the control parameter set to PrintSave, Normal, or Cancel. (In this case, the print methods only validate the method parameters and buffer the data. They do not start printing. Also, the value of the AsyncMode property does not affect their operation: No OutputID will be assigned to the request, nor will an OutputCompleteEvent event be queued.)

If control is PrintSave, then Page Mode is not exited. If some data is buffered by calls to the methods PrintNormal, PrintBarCode, and PrintBitmap, then the buffered data is saved and printed. This control is used to print the same page layout with additional print items inside the page.

If control is Normal, then Page Mode is exited. If some data is buffered by calls to the methods PrintNormal, PrintBarCode, and PrintBitmap, then the buffered data is printed. The buffered data will not be saved.

If control is Cancel, then Page Mode is exited. If some data is buffered by calls to the methods PrintNormal, PrintBarCode, and PrintBitmap, then the buffered data is not printed and is not saved.

Notice that when the PageModePrint method is called, all the data that is to be printed in the PageModePrintArea property are printed and the paper is fed to the end of the PageModePrintArea. If more than one PageModePrintArea is defined, then after the PageModePrint method is called, all the data that is to be printed in the respective PageModePrintArea(s) will be printed and the paper will be fed to the end of the PageModePrintArea located the farthest "down" the sheet of paper.

The Page Mode transaction is treated as one message. This method is performed synchronously if AsyncMode is FALSE, and asynchronously if AsyncMode is TRUE.

Calling the ClearOutput method cancels Page Mode. Any buffered print lines are also cleared.

Page Mode can be used within a transaction print, but not within a rotate print.

The PageModeStation property must be set to a valid station before invoking PageModePrintControl.

PageModePrint may throw a PosControlException with the following ErrorCode:

Value | Meaning
Illegal | The specified PageModeStation does not exist (see the CapRecPresent and CapSlpPresent properties), or CapxxxPageMode is false, or the specified PageModeStation is not in Page Mode and control is set to Normal, PrintSave, or Cancel.
Busy | Cannot perform while output is in progress. (Can only apply if AsyncMode is false and control is Normal, PrintSave, or Cancel.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PageModePrintArea
PageModeStation


PosPrinter.PrintBarCode Method

PosPrinter.PrintBarCode Method |
 | See Also

1/18/2008

Prints a bar code on the specified printer station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintBarCode ( _
    station As PrinterStation, _
    data As String, _
    symbology As BarCodeSymbology, _
    height As Integer, _
    width As Integer, _
    alignment As Integer, _
    textPosition As BarCodeTextPosition _
)
public abstract void PrintBarCode (
    PrinterStation station,
    string data,
    BarCodeSymbology symbology,
    int height,
    int width,
    int alignment,
    BarCodeTextPosition textPosition
)
public:
virtual void PrintBarCode (
    PrinterStation station,
    String^ data,
    BarCodeSymbology symbology,
    int height,
    int width,
    int alignment,
    BarCodeTextPosition textPosition
) abstract
public abstract void PrintBarCode (
    PrinterStation station,
    String data,
    BarCodeSymbology symbology,
    int height,
    int width,
    int alignment,
    BarCodeTextPosition textPosition
)
public abstract function PrintBarCode (
    station : PrinterStation,
    data : String,
    symbology : BarCodeSymbology,
    height : int,
    width : int,
    alignment : int,
    textPosition : BarCodeTextPosition
)

Parameters

station

The printer station to be used. Possible values are defined by the PrinterStation enumeration. Valid values are PrinterStation.Receipt or PrinterStation.Slip.

data

Character string to be bar-coded.

symbology

Bar code symbol type to use. Possible values are defined by the BarCodeSymbology enumeration.

height

Bar code height. Expressed in the unit of measure indicated by the MapMode property.

width

Bar code width. Expressed in the unit of measure indicated by the MapMode property.

alignment

Placement of the bar code. For possible values, see Remarks in this topic.

textPosition

Placement of the readable character string. Possible values are defined by the BarCodeTextPosition enumeration.

Remarks

The alignment parameter values are as follows:

Value | Meaning
PrinterBarCodeLeft | Align with the leftmost print column.
PrinterBarCodeCenter | Align with the center of the station.
PrinterBarCodeRight | Align with the rightmost print column.
Other values | The distance from the leftmost print column to the start of the bar code, expressed in the unit of measure indicated by the MapMode property.

PrintBarCode is performed synchronously if AsyncMode is FALSE, and asynchronously if AsyncMode is true.

If the RotateSpecial property indicates that the bar code is to be rotated, then perform the rotation. The height, width, and textPosition parameters are applied to the bar code before the rotation. For example, if the bar code text position is specified as Below and the bar code is rotated left, the text will appear on the paper to the right side of the bar code.

Before it calls this method, the application must open, claim, and enable the device.

PrintBarCode may throw a PosControlException with the following ErrorCodes:

Value

Meaning

Busy

Cannot perform while output is in progress.

(Can be returned only if AsyncMode is false.)

Illegal

One of the following conditions has occurred:

  • The specified station code is invalid—it can only be Slip or Receipt.

  • The specified station is not supported (that is, the appropriate CapSlpPresent or CapRecPresent is set to false).

  • The printer is currently in Insertion mode.

  • The printer is currently in Removal mode.

  • The printer does not support bar codes for the specified station.

  • The specified height is less than or equal to 0 (zero).

  • The specified width is less than or equal to 0 (zero).

  • The specified alignment is either less than or equal to 0 (zero), or not set to one of the PrinterBarCode et al constants.

  • The specified textPosition does not exist in the BarCodeTextPositions enumeration.

  • The specified symbology does not exist in the BarCodeSymbology enumeration.

Extended

ExtendedErrorCoverOpen: The printer cover is open. (Can be returned only if AsyncMode is false.)

ExtendedErrorRecEmpty: The receipt station was specified but is out of paper. (Can be returned only if AsyncMode is false.)

ExtendedErrorRecCartridgeEmpty: A receipt cartridge is empty. (Can be returned only if AsyncMode is false.)

ExtendedErrorRecCartridgeRemoved: A receipt cartridge is removed. (Can be returned only if AsyncMode is false.)

ExtendedErrorRecHeadCleaning: A receipt head is being cleaned. (Can be returned only if AsyncMode is false.)

ExtendedErrorSlpEmpty: The slip station was specified, but a form is not inserted. (Can be returned only if AsyncMode is false.)

ExtendedErrorSlpCartridgeEmpty: A slip cartridge is empty. (Can be returned only if AsyncMode is false.)

ExtendedErrorSlpCartridgeRemoved: A slip cartridge is removed. (Can be returned only if AsyncMode is false.)

ExtendedErrorSlpHeadCleaning: A slip head is being cleaned. (Can be returned only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
MapMode
RotateSpecial
PrinterStation
BarCodeSymbology Enumeration


PosPrinter.PrintBitmap Method

PosPrinter.PrintBitmap Method |
 | See Also

1/18/2008

Prints a bitmap on the specified printer station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintBitmap ( _
    station As PrinterStation, _
    fileName As String, _
    width As Integer, _
    alignment As Integer _
)
public abstract void PrintBitmap (
    PrinterStation station,
    string fileName,
    int width,
    int alignment
)
public:
virtual void PrintBitmap (
    PrinterStation station,
    String^ fileName,
    int width,
    int alignment
) abstract
public abstract void PrintBitmap (
    PrinterStation station,
    String fileName,
    int width,
    int alignment
)
public abstract function PrintBitmap (
    station : PrinterStation,
    fileName : String,
    width : int,
    alignment : int
)

Parameters

station

The printer station to be used. Possible values are defined by the PrinterStation enumeration. Valid values are PrinterStation.Receipt or PrinterStation.Slip.

fileName

Name of Windows bitmap file. The file must be in uncompressed format.

width

Printed width of the bitmap to be performed. See Remarks in this topic.

alignment

Placement of the bitmap. For possible values, see Remarks in this topic.

Remarks

PrintBitmap is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

The width parameter values are as follows:

Value | Meaning
PrinterBitmapAsIs | Print the bitmap with one bitmap pixel per printer dot.
Other values | Bitmap width, expressed in the unit of measure indicated by the MapMode property.

The alignment parameter values are as follows:

Value | Meaning
PrinterBitmapLeft | Align with the leftmost print column.
PrinterBitmapCenter | Align with the center of the station.
PrinterBitmapRight | Align with the rightmost print column.
Other values | The distance from the leftmost print column to the start of the bitmap, expressed in the unit of measure indicated by the MapMode property.

The width parameter controls transformation of the bitmap. If width is set to PrinterBitmapAsIs, no transformation is performed. The bitmap is printed with one bitmap pixel per printer dot. Advantages of this option are that it:

  • Provides the highest performance bitmap printing.

  • Works well for bitmaps tuned for a specific printer’s aspect ratio between horizontal dots and vertical dots.

If width is nonzero, the bitmap will be transformed by stretching or compressing the bitmap in such a way that its width is the specified width and the aspect ratio is unchanged. Advantages of this option are that it:

  • Sizes a bitmap to fit many printers.

  • Maintains the bitmap’s aspect ratio.

Disadvantages are as follows:

  • Lower performance than untransformed data.

  • Some lines and images that are "smooth" in the original bitmap may show some "ratcheting."

Before it calls this method, the application must open, claim, and enable the device.

PrintBitmap may throw a PosControlException with the following ErrorCodes.

Value

Meaning

Busy

Cannot perform while output is in progress. (Can be returned only if AsyncMode is false.)

Illegal

One of the following conditions has occurred:

  • The specified station code is invalid—it can only be Slip or Receipt.

  • The specified station is not supported (that is, the appropriate CapSlpPresent or CapRecPresent is set to false).

  • The printer is currently in Insertion mode.

  • The printer is currently in Removal mode.

  • The printer does not support bitmaps for the specified station.

  • The specified width is less than or equal to 0 (zero) but is not specified as PrinterBitmapAsIs.

  • The value specified for alignment is either less than or equal to 0 (zero), or not set to one of the PrinterBitmap et al constants.

NoExist

The specified fileName was not found.

Extended

ExtendedErrorCoverOpen: The printer cover is open. (Can be returned only if AsyncMode is false.)

ExtendedErrorBadFormat: The specified file is either not a bitmap file, or it is in an unsupported format.

ExtendedErrorRecEmpty: The receipt station was specified but is out of paper. (Can be returned only if AsyncMode is false.)

ExtendedErrorRecCartridgeEmpty: A receipt cartridge is empty. (Can be returned only if AsyncMode is false.)

ExtendedErrorRecCartridgeRemoved: A receipt cartridge is removed. (Can be returned only if AsyncMode is false.)

ExtendedErrorRecHeadCleaning: A receipt head is being cleaned. (Can be returned only if AsyncMode is false.)

ExtendedErrorSlpEmpty: The slip station was specified, but a form is not inserted. (Can be returned only if AsyncMode is false.)

ExtendedErrorSlpCartridgeEmpty: A slip cartridge is empty. (Can be returned only if AsyncMode is false.)

ExtendedErrorSlpCartridgeRemoved: A slip cartridge is removed. (Can be returned only if AsyncMode is false.)

ExtendedErrorSlpHeadCleaning: A slip head is being cleaned. (Can be returned only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
MapMode
RotateSpecial
PrinterStation


PosPrinter.PrintImmediate Method

PosPrinter.PrintImmediate Method |
 | See Also

1/18/2008

Prints the string immediately that is specified for data on the printer station specified by station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintImmediate ( _
    station As PrinterStation, _
    data As String _
)
public abstract void PrintImmediate (
    PrinterStation station,
    string data
)
public:
virtual void PrintImmediate (
    PrinterStation station,
    String^ data
) abstract
public abstract void PrintImmediate (
    PrinterStation station,
    String data
)
public abstract function PrintImmediate (
    station : PrinterStation,
    data : String
)

Parameters

station

The printer station to be used. Possible values are defined by the PrinterStation enumeration. Valid values are as follows: PrinterStation.Journal, PrinterStation.Receipt, or PrinterStation.Slip.

data

The characters to be printed. May consist of printable characters, escape sequences, carriage returns (13 decimal), and new line / line feed (10 decimal).

Remarks

PrintImmediate tries to print its data immediately—that is, as the very next printer operation. PrintImmediate may be called when asynchronous output is outstanding. PrintImmediate is primarily intended for use in exception conditions when asynchronous output is outstanding, such as in an error event handler.

Special character values within data is as follows:

Value

Meaning

Newline / Line Feed (10 Decimal)

Print any data in the line buffer, and feed to the next print line. (A carriage return is not required in order to print the line.)

Carriage Return (13 Decimal)

If a carriage return immediately comes before a line feed, or if the line buffer is empty, then it is ignored.

Otherwise, the line buffer is printed and the printer does not feed to the next print line.

On some printers, print without feed may be directly supported.

On others, a print may always feed to the next line. In this case, the service object will print the line buffer and perform a reverse line feed if supported.

If the printer does not support either of these features, then the carriage return functions like a line feed.

The ValidateData method can be used to determine whether a carriage return without line feed is possible, and whether a reverse line feed is required to support it.

Before it calls this method, the application must open, claim, and enable the device.

PrintImmediate may throw a PosControlException with the following ErrorCodes:

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The specified station is invalid.

  • The current rotation is invalid—it can only be Normal or Rotate180.

  • The specified station does not exist. (that is, the appropriate CapJrnPresent, CapRecPresent, or CapSlpPresent property is set to false).

Extended

ExtendedErrorCoverOpen: The printer cover is open.

ExtendedErrorJrnEmpty: The journal station was specified but is out of paper.

ExtendedErrorJrnCartridgeEmpty: A journal cartridge is empty.

ExtendedErrorJrnCartridgeRemoved: A journal cartridge is removed.

ExtendedErrorJrnHeadCleaning: A journal head is being cleaned.

ExtendedErrorRecEmpty: The receipt station was specified but is out of paper.

ExtendedErrorRecCartridgeEmpty: A receipt cartridge is empty.

ExtendedErrorRecCartridgeRemoved: A receipt cartridge is removed.

ExtendedErrorRecHeadCleaning: A receipt head is being cleaned.

ExtendedErrorSlpEmpty: The slip station was specified, but a form is not inserted.

ExtendedErrorSlpCartridgeEmpty: A slip cartridge is empty.

ExtendedErrorSlpCartridgeRemoved: A slip cartridge is removed.

ExtendedErrorSlpHeadCleaning: A slip head is being cleaned.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
CapRecPresent
CapJrnPresent
CapSlpPresent
PrintNormal
PrintTwoNormal
ValidateData


PosPrinter.PrintMemoryBitmap Method

PosPrinter.PrintMemoryBitmap Method |
 | See Also

1/18/2008

Prints a bitmap from memory on the specified printer station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Sub PrintMemoryBitmap ( _
    station As PrinterStation, _
    data As Bitmap, _
    width As Integer, _
    alignment As Integer _
)
public virtual void PrintMemoryBitmap (
    PrinterStation station,
    Bitmap data,
    int width,
    int alignment
)
public:
virtual void PrintMemoryBitmap (
    PrinterStation station,
    Bitmap^ data,
    int width,
    int alignment
)
public void PrintMemoryBitmap (
    PrinterStation station,
    Bitmap data,
    int width,
    int alignment
)
public function PrintMemoryBitmap (
    station : PrinterStation,
    data : Bitmap,
    width : int,
    alignment : int
)

Parameters

station

The printer station to be used. Can be either PrinterStation.Slip or PrinterStation.Receipt.

data

The bitmap to be printed.

width

Printed width of the bitmap.

alignment

Placement of the bitmap.

Remarks

This method performs the same function as PrintBitmap, only instead of reading the Windows Bitmap from a file, this method prints a bitmap from memory.

PrintMemoryBitmap is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

The width parameter values are as follows:

Value | Meaning
PrinterBitmapAsIs | Print the bitmap with one bitmap pixel per printer dot.
Other values | Bitmap width, expressed in the unit of measure indicated by the MapMode property.

The alignment parameter values are as follows:

Value | Meaning
PrinterBitmapLeft | Align with the leftmost print column.
PrinterBitmapCenter | Align with the center of the station.
PrinterBitmapRight | Align with the rightmost print column.
Other values | The distance from the leftmost print column to the start of the bitmap, expressed in the unit of measure indicated by the MapMode property.

The width parameter controls transformation of the bitmap. If width is set to PrinterBitmapAsIs, no transformation is performed. The bitmap is printed with one bitmap pixel per printer dot. Advantages of this option are that it:

  • Provides the highest performance bitmap printing.

  • Works well for bitmaps tuned for a specific printer’s aspect ratio between horizontal dots and vertical dots.

If width is nonzero, the bitmap will be transformed by stretching or compressing the bitmap in such a way that its width is the specified width and the aspect ratio is unchanged. Advantages of this option are that it:

  • Sizes a bitmap to fit many printers.

  • Maintains the bitmap’s aspect ratio.

Disadvantages are as follows:

  • Decreased performance than untransformed data.

  • Some lines and images that are "smooth" in the original bitmap may show some "ratcheting."

Before it calls this method, the application must open, claim, and enable the device.

PrintBitmap may throw a PosControlException with the following ErrorCode:

Value

Meaning

Busy

Cannot perform while output is in progress. (Can be returned only if AsyncMode is false.)

Illegal

One of the following conditions has occurred:

  • The specified station code is invalid—it can only be Slip or Receipt.

  • The specified station is not supported (that is, the appropriate CapSlpPresent or CapRecPresent is set to false);

  • The printer is currently in Insertion mode.

  • The printer is currently in Removal mode.

  • The printer does not support bitmaps for the specified station.

  • The specified width is less than or equal to 0 (zero) but is not specified as PrinterBitmapAsIs.

  • The value specified for alignment is either less than or equal to 0 (zero), or not set to one of the PrinterBitmap et al constants.

NoExist

The specified fileName was not found.

Extended

ExtendedErrorCoverOpen: The printer cover is open. (Can be returned only if AsyncMode is false.)

ExtendedErrorBadFormat: The specified file is either not a bitmap file, or it is in an unsupported format.

ExtendedErrorRecEmpty: The receipt station was specified but is out of paper. (Can be returned only if AsyncMode is false.)

ExtendedErrorRecCartridgeEmpty: A receipt cartridge is empty. (Can be returned only if AsyncMode is false.)

ExtendedErrorRecCartridgeRemoved: A receipt cartridge is removed. (Can be returned only if AsyncMode is false.)

ExtendedErrorRecHeadCleaning: A receipt head is being cleaned. (Can be returned only if AsyncMode is false.)

ExtendedErrorSlpEmpty: The slip station was specified, but a form is not inserted. (Can be returned only if AsyncMode is false.)

ExtendedErrorSlpCartridgeEmpty: A slip cartridge is empty. (Can be returned only if AsyncMode is false.)

ExtendedErrorSlpCartridgeRemoved: A slip cartridge is removed. (Can be returned only if AsyncMode is false.)

ExtendedErrorSlpHeadCleaning: A slip head is being cleaned. (Can be returned only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.PrintBitmap Method
MapMode
RotateSpecial
PrinterStation


PosPrinter.PrintNormal Method

PosPrinter.PrintNormal Method |
 | See Also

1/18/2008

Prints the string specified in data on the printer station specified in station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintNormal ( _
    station As PrinterStation, _
    data As String _
)
public abstract void PrintNormal (
    PrinterStation station,
    string data
)
public:
virtual void PrintNormal (
    PrinterStation station,
    String^ data
) abstract
public abstract void PrintNormal (
    PrinterStation station,
    String data
)
public abstract function PrintNormal (
    station : PrinterStation,
    data : String
)

Parameters

station

The printer station to be used. Possible values are defined by the PrinterStation enumeration. Valid values are as follows: PrinterStation.Journal, PrinterStation.Receipt, or PrinterStation.Slip.

data

The characters to be printed. May consist of printable characters, escape sequences, carriage returns (13 decimal), and new line / line feed (10 decimal).

Remarks

PrintNormal is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

Special character values within data is as follows:

Value

Meaning

Newline / Line Feed (10 Decimal)

Print any data in the line buffer, and feed to the next print line. (A carriage return is not required in order to print the line.)

Carriage Return (13 Decimal)

If a carriage return immediately comes before a line feed, or if the line buffer is empty, then it is ignored.

Otherwise, the line buffer is printed and the printer does not feed to the next print line.

On some printers, print without feed may be directly supported.

On others, a print may always feed to the next line. In this case, the service object will print the line buffer and perform a reverse line feed if supported.

If the printer does not support either of these features, then carriage return functions like a line feed.

The ValidateData method can be used to determine whether a carriage return without line feed is possible, and whether a reverse line feed is required to support it.

Before it calls this method, the application must open, claim, and enable the device.

PrintNormal may throw a PosControlException with the following ErrorCodes:

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The specified station is invalid.

  • The specified station does not exist (that is, the appropriate CapJrnPresent, CapRecPresent, or CapSlpPresent property is set to false).

Busy

Cannot perform while output is in progress. (Can be returned only if AsyncMode is false.)

Extended

ExtendedErrorCoverOpen: The printer cover is open. (Can be returned only if AsyncMode is false.)

ExtendedErrorJrnEmpty: The journal station was specified but is out of paper. (Can be returned only if AsyncMode is false.)

ExtendedErrorJrnCartridgeEmpty: A journal cartridge is empty. (Can be returned only if AsyncMode is false.)

ExtendedErrorJrnCartridgeRemoved: A journal cartridge is removed. (Can be returned only if AsyncMode is false.)

ExtendedErrorJrnHeadCleaning: A journal head is being cleaned. (Can be returned only if AsyncMode is false.)

ExtendedErrorRecEmpty: The receipt station was specified but is out of paper. (Can be returned only if AsyncMode is false.)

ExtendedErrorRecCartridgeEmpty: A receipt cartridge is empty. (Can be returned only if AsyncMode is false.)

ExtendedErrorRecCartridgeRemoved: A receipt cartridge is removed. (Can be returned only if AsyncMode is false.)

ExtendedErrorRecHeadCleaning: A receipt head is being cleaned. (Can be returned only if AsyncMode is false.)

ExtendedErrorSlpEmpty: The slip station was specified, but a form is not inserted (can be returned only if AsyncMode is false.)

ExtendedErrorSlpCartridgeEmpty: A slip cartridge is empty. (Can be returned only if AsyncMode is false.)

ExtendedErrorSlpCartridgeRemoved: A slip cartridge is removed. (Can be returned only if AsyncMode is false.)

ExtendedErrorSlpHeadCleaning: A slip head is being cleaned. (Can be returned only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
CapRecPresent
CapJrnPresent
CapSlpPresent
PosPrinter.PrintNormal Method
PrintTwoNormal
ValidateData


PosPrinter.PrintTwoNormal Method

PosPrinter.PrintTwoNormal Method |
 | See Also

1/18/2008

Prints two strings on two print stations concurrently. When supported, this may give increased print performance.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PrintTwoNormal ( _
    stations As PrinterStation, _
    data1 As String, _
    data2 As String _
)
public abstract void PrintTwoNormal (
    PrinterStation stations,
    string data1,
    string data2
)
public:
virtual void PrintTwoNormal (
    PrinterStation stations,
    String^ data1,
    String^ data2
) abstract
public abstract void PrintTwoNormal (
    PrinterStation stations,
    String data1,
    String data2
)
public abstract function PrintTwoNormal (
    stations : PrinterStation,
    data1 : String,
    data2 : String
)

Parameters

stations

The printer stations to be used. Possible values are defined by the PrinterStation enumeration. Valid values are as follows: PrinterStation.TwoReceiptJournal, PrinterStation.TwoSlipJournal, or PrinterStation.TwoSlipReceipt.

data1

The characters to be printed on the first station. May consist of printable characters and escape sequences as listed in the PosPrinter topic. The characters must all fit on one printed line so that the printer may try to print on both stations concurrently.

data2

The characters to be printed on the second station. (Restrictions are the same as data1.) If this string is the empty string (""), then print the same data as data1. On some printers, by using this format may give additional increased print performance.

Remarks

PrintTwoNormal is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

The sequence of stations in the stations parameter (as defined by the value from the PrinterStation enumeration) does not imply the physical printing sequence on the stations. The physical sequence depends on the printer, and may be different based on bidirectional printing, multiple print heads, and so on.

Before it calls this method, the application must open, claim, and enable the device.

PrintTwoNormal may throw a PosControlException with the following ErrorCodes:

Value

Meaning

Busy

Cannot perform while output is in progress. (Can be returned only if AsyncMode is false.)

Illegal

One of the following conditions has occurred:

  • The requested print operation is not supported in the current rotation mode.

  • The specified station does not support concurrent printing (that is, the appropriate CapConcurrentJrnRec, CapConcurrentJrnSlp, CapConcurrentRecSlp property is set to false).

  • The printer is currently in Insertion mode.

  • The printer is currently in Removal mode.

Extended

ExtendedErrorCoverOpen: The printer cover is open. (Can be returned only if AsyncMode is false.)

ExtendedErrorJrnEmpty: The journal station was specified but is out of paper. (Can be returned only if AsyncMode is false.)

ExtendedErrorJrnCartridgeEmpty: A journal cartridge is empty. (Can be returned only if AsyncMode is false.)

ExtendedErrorJrnCartridgeRemoved: A journal cartridge is removed. (Can be returned only if AsyncMode is false.)

ExtendedErrorJrnHeadCleaning: A journal head is being cleaned. (Can be returned only if AsyncMode is false.)

ExtendedErrorRecEmpty: The receipt station was specified but is out of paper. (Can be returned only if AsyncMode is false.)

ExtendedErrorRecCartridgeEmpty: A receipt cartridge is empty. (Can be returned only if AsyncMode is false.)

ExtendedErrorRecCartridgeRemoved: A receipt cartridge is removed. (Can be returned only if AsyncMode is false.)

ExtendedErrorRecHeadCleaning: A receipt head is being cleaned. (Can be returned only if AsyncMode is false.)

ExtendedErrorSlpEmpty: The slip station was specified, but a form is not inserted (can be returned only if AsyncMode is false.)

ExtendedErrorSlpCartridgeEmpty: A slip cartridge is empty. (Can be returned only if AsyncMode is false.)

ExtendedErrorSlpCartridgeRemoved: A slip cartridge is removed. (Can be returned only if AsyncMode is false.)

ExtendedErrorSlpHeadCleaning: A slip head is being cleaned. (Can be returned only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
CapConcurrentJrnRec
CapConcurrentJrnSlp
CapConcurrentRecSlp
PrinterStation


PosPrinter.RotatePrint Method

PosPrinter.RotatePrint Method |
 | See Also

1/18/2008

Enters or exits rotated print mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub RotatePrint ( _
    station As PrinterStation, _
    rotation As PrintRotation _
)
public abstract void RotatePrint (
    PrinterStation station,
    PrintRotation rotation
)
public:
virtual void RotatePrint (
    PrinterStation station,
    PrintRotation rotation
) abstract
public abstract void RotatePrint (
    PrinterStation station,
    PrintRotation rotation
)
public abstract function RotatePrint (
    station : PrinterStation,
    rotation : PrintRotation
)

Parameters

station

The printer station to be used. Possible values are defined by the PrinterStation enumeration. Valid values are as follows: PrinterStation.Receipt or PrinterStation.Slip.

rotation

Direction of rotation. Possible values are defined by the PrintRotation enumeration.

Remarks

RotatePrint is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

If rotation is set to PrintRotation.Rotate180, then upside-down print mode is entered. Later calls to PrintNormal or PrintImmediate will print the data upside-down until RotatePrint is called by using the rotation parameter set to PrintRotation.Normal.

Each print line is rotated by 180 degrees. Lines are printed in the order that they are sent to the service object, with the start of each line justified at the right margin of the printer station. Only print methods PrintNormal and PrintImmediate can be used while in upside-down print mode.

If rotation is set to PrintRotation.Right90 or PrintRotation.Left90, sideways print mode is entered. Later calls to PrintNormal will buffer the print data (either at the printer or the service object, depending on the printer capabilities) until RotatePrint is called by using the rotation parameter set to PrintRotation.Normal. (In this case, PrintNormal only buffers the data. Itit does not start printing. Also, the value of the AsyncMode property does not affect its operation: No OutputID will be assigned to the request, nor will an OutputCompleteEvent event be raised.)

Each print line is rotated by 90 degrees. If the lines are not all the same length, they are justified at the start of each line. Only PrintNormal can be used while in sideways print mode.

If rotation is PrintRotation.Normal, then rotated print mode is exited. If sideways-rotated print mode was in effect and some data was buffered by calls to the PrintNormal method, the buffered data is printed. The rotated block of lines is treated as one message.

Changing the rotation mode may also change the station’s line height, line spacing, line width, and other metrics.

Calling the ClearOutput method cancels rotated print mode. Any buffered sideways-rotated print lines are also cleared.

Before it calls this method, the application must open, claim, and enable the device.

RotatePrint may throw a PosControlException with the following ErrorCodes:

Value

Meaning

Busy

Cannot perform while output is in progress. (Can be returned only if AsyncMode is false.)

Illegal

One of the following conditions has occurred:

  • The specified station does not exist (that is, the appropriate CapRecPresent or CapSlpPresent property is set to false).

  • The station does not support the specified rotation.

Extended

ExtendedErrorCoverOpen: The printer cover is open. (Can be returned only if AsyncMode is false.)

ExtendedErrorRecEmpty: The receipt station was specified but is out of paper. (Can be returned only if AsyncMode is false.)

ExtendedErrorRecCartridgeEmpty: A receipt cartridge is empty. (Can be returned only if AsyncMode is false.)

ExtendedErrorRecCartridgeRemoved: A receipt cartridge is removed. (Can be returned only if AsyncMode is false.)

ExtendedErrorRecHeadCleaning: A receipt head is being cleaned. (Can be returned only if AsyncMode is false.)

ExtendedErrorSlpEmpty: The slip station was specified, but a form is not inserted. (Can be returned only if AsyncMode is false.)

ExtendedErrorSlpCartridgeEmpty: A slip cartridge is empty. (Can be returned only if AsyncMode is false.)

ExtendedErrorSlpCartridgeRemoved: A slip cartridge is removed. (Can be returned only if AsyncMode is false.)

ExtendedErrorSlpHeadCleaning: A slip head is being cleaned. (Can be returned only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
CapRecPresent
CapSlpPresent
PosPrinter.PrintNormal Method
PosPrinter.PrintImmediate Method
PrinterStation
PrintRotation


PosPrinter.SetBitmap Method

PosPrinter.SetBitmap Method |
 | See Also

1/18/2008

Saves information about a bitmap for later printing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub SetBitmap ( _
    bitmapNumber As Integer, _
    station As PrinterStation, _
    fileName As String, _
    width As Integer, _
    alignment As Integer _
)
public abstract void SetBitmap (
    int bitmapNumber,
    PrinterStation station,
    string fileName,
    int width,
    int alignment
)
public:
virtual void SetBitmap (
    int bitmapNumber,
    PrinterStation station,
    String^ fileName,
    int width,
    int alignment
) abstract
public abstract void SetBitmap (
    int bitmapNumber,
    PrinterStation station,
    String fileName,
    int width,
    int alignment
)
public abstract function SetBitmap (
    bitmapNumber : int,
    station : PrinterStation,
    fileName : String,
    width : int,
    alignment : int
)

Parameters

bitmapNumber

The number to be assigned to this bitmap. Two bitmaps, numbered 1 and 2, may be set.

station

The printer station to be used. Possible values are defined by the PrinterStation enumeration. Valid values are as follows: PrinterStation.Receipt or PrinterStation.Slip.

fileName

Name of Windows bitmap file. The file must be in uncompressed format. If set to an empty string (""), the bitmap is unset.

width

Printed width of the bitmap to be performed. See the PrintBitmap method for values.

alignment

Placement of the bitmap.

Remarks

The alignment parameter values are as follows:

Value | Meaning
PrinterBitmapLeft | Align with the leftmost print column.
PrinterBitmapCenter | Align with the center of the station.
PrinterBitmapRight | Align with the rightmost print column.
Other values | The distance from the leftmost print column to the start of the bitmap, expressed in the unit of measure indicated by the MapMode property.

As soon as the bitmap is set, it can then be printed by calling the PrintNormal or PrintImmediate method with the print bitmap escape sequence in the print data. The print bitmap escape sequence will typically be included in a string for printing top and bottom transaction headers.

A service object may choose to cache the bitmap for later use to provide better performance. Regardless, the bitmap file and parameters are validated for correctness by SetBitmap.

The application must make sure that the printer station metrics, such as character width, line height, and line spacing are set for the station before it calls SetBitmap. The service object can perform transformations on the bitmap in preparation for later printing based on the current values.

The application can set bitmaps numbered 1 and 2 for each of the two valid stations. If you want, the same bitmap fileName can be set to the same bitmapNumber for each station so that the same print bitmap escape sequence can be used for either station.

Before it calls this method, the application must open, claim, and enable the device.

SetBitmap may throw a PosControlException with the following ErrorCodes:

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The specified station is invalid—it must be either Slip or Receipt.

  • The specified station does not support printing of bitmaps (that is, the appropriate CapSlpBitmap or CapRecBitmap property is set to false).

  • The printer is currently in Insertion mode.

  • The printer is currently in Removal mode.

  • The number that is specified for bitmapNumber is less than 1 or greater than 20 and therefore invalid.

  • The value for width is less than or equal to zero but not set to PrinterBitmapAsIs and therefore invalid.

NoExist

fileName was not found.

Extended

ExtendedErrorTooBig: The bitmap is either too wide to print without transformation, or it is too big to transform.

ExtendedErrorBadFormat: The specified file is either not a bitmap file, or it is in an unsupported format.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.PrintNormal Method
PosPrinter.PrintImmediate Method
PosPrinter.PrintBitmap Method
PrinterStation


PosPrinter.SetLogo Method

PosPrinter.SetLogo Method |
 | See Also

1/18/2008

Saves a data string as the top or bottom logo.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub SetLogo ( _
    location As PrinterLogoLocation, _
    data As String _
)
public abstract void SetLogo (
    PrinterLogoLocation location,
    string data
)
public:
virtual void SetLogo (
    PrinterLogoLocation location,
    String^ data
) abstract
public abstract void SetLogo (
    PrinterLogoLocation location,
    String data
)
public abstract function SetLogo (
    location : PrinterLogoLocation,
    data : String
)

Parameters

location

Where the logo is to be set. Possible values are defined by the PrinterLogoLocation enumeration as PrinterLogoLocation.Top or PrinterLogoLocation.Bottom.

data

The characters that produce the logo. May consist of printable characters, escape sequences, carriage returns (13 decimal), and newline / line feed (10 decimal).

Remarks

POS for .NET checks to make sure that the following is true:

  • The Printer device has been opened, claimed, and enabled; and

  • The specified location is either PrinterLogoLocation.Top or PrinterLogoLocation.Bottom.

If these validations succeed, the service object sets the logo. If either of these conditions is not met, the service object throws an exception.

The service object sets the logo by updating either the TopLogo or BottomLogo properties in the PrinterProperties helper class. After these protected properties are set, the service object can then check the properties when the application calls the PrintNormal, PrintTwoNormal, or PrintImmediate methods, to determine whether to add a top logo or bottom logo escape sequence to the print data.

Before it calls this method, the application must open, claim, and enable the device.

SetLogo may throw a PosControlException with the following ErrorCodes:

Value

Meaning

Illegal

One of the following conditions has occurred:

  • An invalid location was specified.

  • The printer is currently in Insertion mode.

  • The printer is currently in Removal mode.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.PrintNormal Method
PosPrinter.PrintTwoNormal Method
PosPrinter.PrintImmediate Method
PrinterLogoLocation


PosPrinter.TransactionPrint Method

PosPrinter.TransactionPrint Method |
 | See Also

1/18/2008

Enters or exits transaction mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub TransactionPrint ( _
    station As PrinterStation, _
    control As PrinterTransactionControl _
)
public abstract void TransactionPrint (
    PrinterStation station,
    PrinterTransactionControl control
)
public:
virtual void TransactionPrint (
    PrinterStation station,
    PrinterTransactionControl control
) abstract
public abstract void TransactionPrint (
    PrinterStation station,
    PrinterTransactionControl control
)
public abstract function TransactionPrint (
    station : PrinterStation,
    control : PrinterTransactionControl
)

Parameters

station

The printer station to be used. Possible values are defined by the PrinterStation enumeration. Valid values are as follows: PrinterStation.Journal, PrinterStation.Receipt, or PrinterStation.Slip.

control

Transaction control. Possible values are defined by the PrinterTransactionControl enumeration. See in this topic.

Remarks

If control is set to PrinterTransactionControl.Transaction, then transaction mode is entered. Later calls to the PrintNormal, CutPaper, RotatePrint, PrintBarCode, PrintBitmap and MarkFeed methods will buffer the print data (either at the printer or the service object, depending on the printer capabilities) until TransactionPrint is called by using the control parameter set to PrinterTransactionControl.Normal. (In this case, the print methods only validate the method parameters and buffer the data. They do not start printing. Also, the value of the AsyncMode property does not affect their operation: No OutputID will be assigned to the request, nor will an OutputCompleteEvent be raised.)

If control is PrinterTransactionControl.Normal, then transaction mode is exited. If some data was buffered by calls to the methods PrintNormal, CutPaper, RotatePrint, PrintBarCode, PrintBitmap and MarkFeed, the buffered data is printed. The transaction is treated as one message.

TransactionPrint is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

Calling the ClearOutput method cancels transaction mode. Any buffered print lines are also cleared.

Before it calls this method, the application must open, claim, and enable the device.

TransactionPrint may throw a PosControlException with the following ErrorCodes:

Value

Meaning

Busy

Cannot perform while output is in progress. (Can be returned only if AsyncMode is false and control is PrinterTransactionControl.Normal.)

Illegal

One of the following conditions has occurred:

  • The printer does not support transactions (that is, the CapTransaction property is set to false).

  • The specified station is invalid—it must be PrinterStation.Journal, PrinterStation.Receipt, or PrinterStation.Slip.

  • The specified station is not supported (that is, the appropriate CapJrnPresent, CapSlpPresent or CapRecPresent property is set to false).

  • The printer is currently in Insertion mode.

  • The printer is currently in Removal mode.

  • The control parameter contains an invalid value.

Extended

ExtendedErrorCoverOpen: The printer cover is open. (Can be returned only if AsyncMode is false.)

ExtendedErrorJrnEmpty: The journal station was specified but is out of paper. (Can be returned only if AsyncMode is false.)

ExtendedErrorJrnCartridgeEmpty: A journal cartridge is empty. (Can be returned only if AsyncMode is false.)

ExtendedErrorJrnCartridgeRemoved: A journal cartridge is removed. (Can be returned only if AsyncMode is false.)

ExtendedErrorJrnHeadCleaning: A journal head is being cleaned. (Can be returned only if AsyncMode is false.)

ExtendedErrorRecEmpty: The receipt station was specified but is out of paper. (Can be returned only if AsyncMode is false.)

ExtendedErrorRecCartridgeEmpty: A receipt cartridge is empty. (Can be returned only if AsyncMode is false.)

ExtendedErrorRecCartridgeRemoved: A receipt cartridge is removed. (Can be returned only if AsyncMode is false.)

ExtendedErrorRecHeadCleaning: A receipt head is being cleaned. (Can be returned only if AsyncMode is false.)

ExtendedErrorSlpEmpty: The slip station was specified, but a form is not inserted.(Can be returned only if AsyncMode is false.)

ExtendedErrorSlpCartridgeEmpty: A slip cartridge is empty. (Can be returned only if AsyncMode is false.)

ExtendedErrorSlpCartridgeRemoved: A slip cartridge is removed. (Can be returned only if AsyncMode is false.)

ExtendedErrorSlpHeadCleaning: A slip head is being cleaned. (Can be returned only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.ValidateData Method

PosPrinter.ValidateData Method |
 | See Also

1/18/2008

Determines whether a data sequence, possibly including one or more escape sequences, is valid for the specified station, before it calls the PrintImmediate, PrintNormal, or PrintTwoNormal methods.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ValidateData ( _
    station As PrinterStation, _
    data As String _
)
public abstract void ValidateData (
    PrinterStation station,
    string data
)
public:
virtual void ValidateData (
    PrinterStation station,
    String^ data
) abstract
public abstract void ValidateData (
    PrinterStation station,
    String data
)
public abstract function ValidateData (
    station : PrinterStation,
    data : String
)

Parameters

station

The printer station to be used. Possible values are defined by the PrinterStation enumeration. Valid values are as follows: PrinterStation.Journal, PrinterStation.Receipt, or PrinterStation.Slip.

data

The data to be validated. May include printable data and escape sequences. See Remarks in this topic.

Remarks

ValidateData causes no printing, but is used to determine the capabilities of the station.

Before it calls this method, the application must open, claim, and enable the device.

ValidateData may throw a PosControlException with the following values, as defined by the ValidationResult enumeration:

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The specified station is invalid.

  • The specified station does not exist (that is, the appropriate CapJrnPresent, CapRecPresent, or CapSlpPresent property is set to false).

  • Some data is not supported. See this topic.

Failure

Some data is not supported--see in this topic.

Cases which cause Illegal to be returned are as follows:

Escape Sequence | Condition
Paper cut | The percentage ‘#’ is not exactly supported: The service object will select the closest supported value.
Feed and Paper cut | The percentage ‘#’ is not precisely supported: The service object will select the closest supported value.
Feed, Paper cut, and Stamp | The percentage ‘#’ is not precisely supported: The service object will select the closest supported value.
Feed units | The unit count ‘#’ is not precisely supported: The service object will select the closest supported value.
Feed reverse | The line count ‘#’ is too large: The service object will select the maximum supported value.
Underline | The thickness ‘#’ is not precisely supported: The service object will select the closest supported value.
Shading | The percentage ‘#’ is not precisely supported: The service object will select the closest supported value.
Scale horizontally | The scaling factor ‘#’ is not supported: The service object will select the closest supported value.
Scale vertically | The scaling factor ‘#’ is not supported: The service object will select the closest supported value.
Data | Condition
data1CRdata2LF | (Where CR is a carriage return and LF is a line feed) To print data1 and remain on the same line, the service object will print with a line advance, then perform a reverse line feed. The data2 will then overprint data1.

Cases which will cause Failure to be returned are as follows:

Escape Sequence | Condition
(General) | The escape sequence format is not valid.
Paper cut | Not supported.
Feed and Paper cut | Not supported.
Feed, Paper cut, and Stamp | Not supported.
Fire stamp | Not supported.
Print bitmap | Bitmap printing is not supported, or the bitmap number ‘#’ is out of range.
Feed reverse | Not supported.
Font typeface | The font ‘#’ is not supported.
Bold | Not supported.
Underline | Not supported.
Alternate color | Not supported.
Reverse video | Not supported.
Shading | Not supported.
Single high & wide | Not supported.
Double wide | Not supported.
Double high | Not supported.
Double high & wide | Not supported.
RGB color | Not supported.
Data | Condition
data1CRdata2LF | (Where CR is a carriage return and LF is a line feed) Unable to print data and remain on the same line. The data1 will print on one line, and the data2 will print on the next line.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
ValidationResult


PosPrinter Properties

PosPrinter Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
AsyncMode | Gets or sets a Boolean value that indicates whether certain print methods will be performed asynchronously.
CapCharacterSet | Gets the default character set capability.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapConcurrentJrnRec | Gets a Boolean value that indicates whether the journal and receipt stations can print at the same time.
CapConcurrentJrnSlp | Gets a Boolean value that indicates whether the journal and slip stations can print at the same time.
CapConcurrentPageMode | Gets a Boolean value that indicates whether the printer can support Page Mode at the same time for both the receipt and slip stations.
CapConcurrentRecSlp | Gets a Boolean value that indicates whether the receipt and slip stations can print at the same time.
CapCoverSensor | Gets a Boolean value that indicates whether the printer has a "cover open" sensor.
CapJrn2Color | Gets a Boolean value that indicates whether the journal can print dark plus an alternate color.
CapJrnBold | Gets a Boolean value that indicates whether the journal can print bold characters.
CapJrnCartridgeSensor | Gets the presence of journal cartridge monitoring sensors.
CapJrnColor | Gets available journal color cartridges.
CapJrnDHigh | Gets a Boolean value that indicates whether the journal can print double-high characters.
CapJrnDWide | Gets a Boolean value that indicates whether the journal can print double-wide characters.
CapJrnDWideDHigh | Gets a Boolean value that indicates whether the journal can print characters that are both double-high and double-wide.
CapJrnEmptySensor | Gets a Boolean value that indicates whether the journal has an out-of-paper sensor.
CapJrnItalic | Gets a Boolean value that indicates whether the journal can print italic characters.
CapJrnNearEndSensor | Gets a Boolean value that indicates whether the journal has a low-paper sensor.
CapJrnPresent | Gets a Boolean value that indicates whether the journal print station is present.
CapJrnUnderline | Gets a Boolean value that indicates whether the journal can underline characters.
CapMapCharacterSet | Gets a Boolean value that indicates whether when printing data, the service object can map the characters sent by the application (in the character set that is defined by the CharacterSet property) to the character sets that are defined by the CharacterSetList property.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapRec2Color | Gets a Boolean value that indicates whether the receipt can print dark plus an alternate color.
CapRecBarCode | Gets a Boolean value that indicates whether the receipt has bar code printing capability.
CapRecBitmap | Gets a Boolean value that indicates whether the receipt can print bitmaps.
CapRecBold | Gets a Boolean value that indicates whether the receipt can print bold characters.
CapRecCartridgeSensor | Gets the presence of receipt cartridge monitoring sensors.
CapRecColor | Gets the receipt color cartridges.
CapRecDHigh | Gets a Boolean value that indicates whether the receipt can print double-high characters.
CapRecDWide | Gets a Boolean value that indicates whether the receipt can print double-wide characters.
CapRecDWideDHigh | Gets a Boolean value that indicates whether the receipt can print double-high, double-wide characters.
CapRecEmptySensor | Gets a Boolean value that indicates whether the receipt has an out-of-paper sensor.
CapRecItalic | Gets a Boolean value that indicates whether the receipt can print italic characters.
CapRecLeft90 | Gets a Boolean value that indicates whether the receipt can print in rotated-90-degree-left mode.
CapRecMarkFeed | Gets the type of mark-sensed paper handling available.
CapRecNearEndSensor | Gets a Boolean value that indicates whether the receipt has a low-paper sensor.
CapRecPageMode | Gets a Boolean value that indicates whether the printer can support Page Mode for the receipt station.
CapRecPaperCut | Gets a Boolean value that indicates whether the receipt can perform paper cuts.
CapRecPresent | Gets a Boolean value that indicates whether the receipt print station is present.
CapRecRight90 | Gets a Boolean value that indicates whether the receipt can print in a rotated-90-degree-right mode.
CapRecRotate180 | Gets a Boolean value that indicates whether the receipt can print in a rotated upside-down mode.
CapRecStamp | Gets a Boolean value that indicates whether the receipt has a stamp capability.
CapRecUnderline | Gets a Boolean value that indicates whether the receipt can underline characters.
CapSlp2Color | Gets a Boolean value that indicates whether the slip can print dark plus an alternate color.
CapSlpBarCode | Gets a Boolean value that indicates whether the slip has bar code printing capability.
CapSlpBitmap | Gets a Boolean value that indicates whether the slip can print bitmaps.
CapSlpBold | Gets a Boolean value that indicates whether the slip can print bold characters.
CapSlpBothSidesPrint | Gets a Boolean value that indicates whether the slip print station supports printing on both sides of the document.
CapSlpCartridgeSensor | Gets the presence of slip-cartridge monitoring sensors.
CapSlpColor | Gets the type of color cartridges supported for slip printing.
CapSlpDHigh | Gets a Boolean value that indicates whether the slip can print double-high characters.
CapSlpDWide | Gets a Boolean value that indicates whether the slip can print double-wide characters.
CapSlpDWideDHigh | Gets a Boolean value that indicates whether the slip can print characters that are both double-wide and double-high.
CapSlpEmptySensor | Gets a Boolean value that indicates whether the slip has a "slip in" sensor.
CapSlpFullSlip | Gets a Boolean value that indicates whether the slip is a full slip station; it can print full-length forms.
CapSlpItalic | Gets a Boolean value that indicates whether the slip can print italic characters.
CapSlpLeft90 | Gets a Boolean value that indicates whether the slip can print in a rotated 90 degree left mode.
CapSlpNearEndSensor | Gets a Boolean value that indicates whether the slip has a "slip near end" sensor.
CapSlpPageMode | Gets a Boolean value that indicates whether the printer can support Page Mode for the slip station.
CapSlpPresent | Gets a Boolean value that indicates whether the slip print station is present.
CapSlpRight90 | Gets a Boolean value that indicates whether the slip can print in a rotated-90-degree-right mode.
CapSlpRotate180 | Gets a Boolean value that indicates whether the slip can print in an upside-down mode.
CapSlpUnderline | Gets a Boolean value that indicates whether the slip can underline characters.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapTransaction | Gets a Boolean value that indicates whether each station supports printer transactions.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CartridgeNotify | Gets or sets the type of cartridge state notification the application wants to receive.
CharacterSet | Gets or sets the numeric value that indicates the character set that the application wants to use for printing characters.
CharacterSetList | Gets the list of character set numbers supported for printing.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
CoverOpen | Gets a Boolean value that indicates whether the printer’s cover is open.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
ErrorLevel | Gets the severity of the most recent error condition.
ErrorStation | Gets the station or stations that were printing when an error was detected.
ErrorString | Gets a vendor-supplied description of the current error.
FlagWhenIdle | Gets or sets a Boolean value that indicates whether the service object queues a StatusUpdateEvent event by using the StatusIdle constant when the device is in an idle state, and reset FlagWhenIdle to false.
FontTypefaceList | Gets a string array that specifies the fonts and typefaces supported by the printer.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
JrnCartridgeState | Gets the status of the selected journal cartridge (ink, ribbon, or toner).
JrnCurrentCartridge | Gets or sets the currently selected journal cartridge.
JrnEmpty | Gets or sets a Boolean value that indicates whether the journal is out of paper.
JrnLetterQuality | Gets or sets a Boolean value that indicates whether the printer can print in high-quality mode.
JrnLineChars | Gets or sets the number of characters that the application wants to print on a journal line.
JrnLineCharsList | Gets a collection of the line widths (characters per line) supported by the journal station.
JrnLineHeight | Gets or sets the journal print line height that the application wants to use, expressed in the unit of measure indicated by the MapMode property setting.
JrnLineSpacing | Gets or sets the spacing of each single-high print line, including both the printed line height and the white space between each pair of lines that the application wants to use.
JrnLineWidth | Gets the width of a line for the number of characters indicated by the JrnLineChars property, expressed in the unit of measure indicated by the MapMode property.
JrnNearEnd | Gets a Boolean value that indicates whether the journal paper is low.
MapCharacterSet | Gets a Boolean value that indicates whether the service object maps the characters transferred by the application to the character set selected in the CharacterSet property.
MapMode | Gets or sets the mapping mode of the printer the application wants to use.
OutputId | Gets the identifier associated with the current output request.
PageModeArea | Gets the page area for the selected PageModeStation expressed in the unit of measure given by MapMode.
PageModeDescriptor | Gets the basic Page mode functionality of the printer for the selected PageModeStation property.
PageModeHorizontalPosition | Gets or sets the horizontal start position offset within the print area for the print station specified by the PageModeStation property, expressed in the unit of measure specified by the MapMode property.
PageModePrintArea | Gets or sets the print area for the print station specified by the PageModeStation property, expressed in the unit of measured specified by the MapMode property.
PageModePrintDirection | Gets the print direction, as specified by the PageModePrintDirection enumeration.
PageModeStation | Gets or sets the printer station, as specified by the PrinterStation enumeration.
PageModeVerticalPosition | Gets or sets the vertical start position offset within the print area for the print station specified by the PageModeStation property, expressed in the unit of measure specified by the MapMode property.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
RecBarCodeRotationList | Gets a list of the directions in which a receipt bar code can be rotated.
RecBitmapRotationList | Gets a list of the directions in which a receipt bitmap can be rotated.
RecCartridgeState | Gets the status of the selected receipt cartridge (ink, ribbon or toner).
RecCurrentCartridge | Gets or sets the receipt cartridge selected by the application.
RecEmpty | Gets a Boolean value that indicates whether the receipt is out of paper.
RecLetterQuality | Gets a Boolean value that indicates whether the printer prints in high-quality mode.
RecLineChars | Gets or sets the number of characters that the application wants to print on a receipt line.
RecLineCharsList | Gets a collection of the line widths (characters per line) supported by the receipt station.
RecLineHeight | Gets or sets the receipt print line height, expressed in the unit of measure indicated by the MapMode property setting, that the application wants to use.
RecLineSpacing | Gets or sets the spacing of each single-high print line. This includes both the printed line height and the white space between each pair of lines, that the application wants to use.
RecLinesToPaperCut | Gets the number of lines that must be advanced before cutting the receipt paper.
RecLineWidth | Gets the width of a line, based on the number of characters specified in the RecLineChars property, expressed in the unit of measure indicated by the MapMode property.
RecNearEnd | Gets a Boolean value that indicates whether the receipt paper is low.
RecSidewaysMaxChars | Gets the maximum number of characters that can be printed on each line in sideways mode.
RecSidewaysMaxLines | Gets the maximum number of lines that can be printed in sideways mode.
RotateSpecial | Gets or sets the rotation orientation for bar codes that the application wants to use.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
SlpBarCodeRotationList | Gets a collection of the directions in which a slip bar code may be rotated.
SlpBitmapRotationList | Gets a collection of the directions in which a slip bitmap can be rotated.
SlpCartridgeState | Gets the status of the selected slip cartridge (ink, ribbon, or toner).
SlpCurrentCartridge | Gets or sets the slip cartridge the application wants to use.
SlpEmpty | Gets a Boolean value that indicates whether a slip form is not present.
SlpLetterQuality | Gets or sets a Boolean value that indicates whether the printer prints in high-quality mode.
SlpLineChars | Gets or sets the number of characters that the application wants to print on a slip line.
SlpLineCharsList | Gets a collection of the line widths (characters per line) supported by the slip station.
SlpLineHeight | Gets or sets the slip print-line height, expressed in the unit of measure indicated by the MapMode property setting, that the application wants to use.
SlpLinesNearEndToEnd | Gets the number of lines that can be printed after the SlpNearEnd property has been set to true but before the printer reaches the end of the slip.
SlpLineSpacing | Gets or sets the spacing of each single-high print line. This includes both the printed line height and the white space between each pair of lines that the application wants to use.
SlpLineWidth | Gets the line width, based on the number of characters specified for the SlpLineChars property, expressed in the unit of measure indicated by the MapMode property.
SlpMaxLines | Gets the maximum number of lines that can be printed on a form.
SlpNearEnd | Gets a Boolean value that indicates whether the slip form is near its end.
SlpPrintSide | Gets the side of the slip print station document on which printing will occur.
SlpSidewaysMaxChars | Gets the maximum number of characters that can be printed on each line in sideways mode.
SlpSidewaysMaxLines | Gets the maximum number of lines that can be printed in sideways mode.
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether the PosPrinter is an exclusive-use device.

See Also

Reference

PosPrinter Class
Microsoft.PointOfService Namespace


PosPrinter.AsyncMode Property

PosPrinter.AsyncMode Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether certain print methods will be performed asynchronously.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AsyncMode As Boolean
public abstract bool AsyncMode { get; set; }
public:
virtual property bool AsyncMode {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_AsyncMode ()

/** @property */
public abstract void set_AsyncMode (boolean value)

public abstract function get AsyncMode () : boolean

public abstract function set AsyncMode (value : boolean)

Remarks

If true, the methods CutPaper, MarkFeed, PrintNormal, PrintTwoNormal, PrintBarCode, PrintBitmap, RotatePrint, and TransactionPrint will be performed asynchronously.

If false, they will be performed synchronously.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapCharacterSet Property

PosPrinter.CapCharacterSet Property |
 | See Also

1/18/2008

Gets the default character set capability.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapCharacterSet As CharacterSetCapability
public abstract CharacterSetCapability CapCharacterSet { get; }
public:
virtual property CharacterSetCapability CapCharacterSet {
    CharacterSetCapability get () abstract;
}
/** @property */
public abstract CharacterSetCapability get_CapCharacterSet ()

public abstract function get CapCharacterSet () : CharacterSetCapability

Remarks

Possible values are defined by the CharacterSetCapability enumeration.

The default character set can contain a superset of these ranges.

The service object should set CapCharacterSet based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
CharacterSet


PosPrinter.CapConcurrentJrnRec Property

PosPrinter.CapConcurrentJrnRec Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the journal and receipt stations can print at the same time.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapConcurrentJrnRec As Boolean
public abstract bool CapConcurrentJrnRec { get; }
public:
virtual property bool CapConcurrentJrnRec {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapConcurrentJrnRec ()

public abstract function get CapConcurrentJrnRec () : boolean

Remarks

If true, the journal and receipt stations can print at the same time.

The PrintTwoNormal method can be used with the PrinterStation.TwoReceiptJournal printer station value. Printer station values are defined in the PrintStation enumeration.

If false, the application should print to only one of the stations at a time, and minimize transitions between the stations. Nonconcurrent printing can be required for reasons such as the following:

  • Higher likelihood of error, such as greater chance of paper jams when moving between the stations.

  • Higher performance when each station is printed separately.

The service object should set CapConcurrentJrnRec based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.PrintTwoNormal Method
PrinterStation


PosPrinter.CapConcurrentJrnSlp Property

PosPrinter.CapConcurrentJrnSlp Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the journal and slip stations can print at the same time.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapConcurrentJrnSlp As Boolean
public abstract bool CapConcurrentJrnSlp { get; }
public:
virtual property bool CapConcurrentJrnSlp {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapConcurrentJrnSlp ()

public abstract function get CapConcurrentJrnSlp () : boolean

Remarks

If true, the journal and slip stations can print at the same time.

The PrintTwoNormal method can be used with the PrinterStation.TwoSlipJournal printer station value. Printer station values are defined in the PrintStation enumeration.

If false, the application must use the sequence BeginInsertion/EndInsertion followed by print requests to the slip followed by BeginRemoval/EndRemoval before printing on the journal. Nonconcurrent printing may be required for reasons such as the following:

  • Physical constraints, such as the slip form being put in front of the journal station.

  • Higher likelihood of error, such as greater chance of paper jams when moving between the stations.

  • Higher performance when each station is printed separately.

The service object should set CapConcurrentJrnSlp based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.PrintTwoNormal Method
PosPrinter.BeginInsertion Method
PosPrinter.EndInsertion Method
PosPrinter.BeginRemoval Method
PosPrinter.EndRemoval Method
PrinterStation


PosPrinter.CapConcurrentPageMode Property

PosPrinter.CapConcurrentPageMode Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer can support Page Mode at the same time for both the receipt and slip stations.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CapConcurrentPageMode As Boolean
public virtual bool CapConcurrentPageMode { get; }
public:
virtual property bool CapConcurrentPageMode {
    bool get ();
}
/** @property */
public boolean get_CapConcurrentPageMode ()

public function get CapConcurrentPageMode () : boolean

Remarks

If true, then the printer can support Page Mode at the same time for both the receipt and slip stations.

If Page Mode is not supported on either station, only on one station, or only on one station at a time, then this value should be false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapConcurrentRecSlp Property

PosPrinter.CapConcurrentRecSlp Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the receipt and slip stations can print at the same time.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapConcurrentRecSlp As Boolean
public abstract bool CapConcurrentRecSlp { get; }
public:
virtual property bool CapConcurrentRecSlp {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapConcurrentRecSlp ()

public abstract function get CapConcurrentRecSlp () : boolean

Remarks

If true, the receipt and slip stations can print at the same time.

The PrintTwoNormal method can be used with the PrinterStation.TwoSlipReceipt printer station value. Printer station values are defined in the PrinterStation enumeration.

If false, the application must use the sequence BeginInsertion/EndInsertion followed by print requests to the slip followed by BeginRemoval/EndRemoval before printing on the receipt. Nonconcurrent printing may be required for reasons such as the following:

  • Physical constraints, such as the slip form being put in front of the receipt station.

  • Higher likelihood of error, such as greater chance of paper jams when moving between the stations.

  • Higher performance when each station is printed separately.

The service object should set CapConcurrentRecSlp based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.PrintTwoNormal Method
PosPrinter.BeginInsertion Method
PosPrinter.EndInsertion Method
PosPrinter.BeginRemoval Method
PosPrinter.EndRemoval Method
PrinterStation


PosPrinter.CapCoverSensor Property

PosPrinter.CapCoverSensor Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer has a "cover open" sensor.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapCoverSensor As Boolean
public abstract bool CapCoverSensor { get; }
public:
virtual property bool CapCoverSensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapCoverSensor ()

public abstract function get CapCoverSensor () : boolean

Remarks

If true, the printer has a "cover open" sensor.

CapCoverSensor is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapJrn2Color Property

PosPrinter.CapJrn2Color Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the journal can print dark plus an alternate color.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapJrn2Color As Boolean
public abstract bool CapJrn2Color { get; }
public:
virtual property bool CapJrn2Color {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapJrn2Color ()

public abstract function get CapJrn2Color () : boolean

Remarks

If true, the journal can print dark plus an alternate color.

CapJrn2Color is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapJrnBold Property

PosPrinter.CapJrnBold Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the journal can print bold characters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapJrnBold As Boolean
public abstract bool CapJrnBold { get; }
public:
virtual property bool CapJrnBold {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapJrnBold ()

public abstract function get CapJrnBold () : boolean

Remarks

If true, the journal can print bold characters.

CapJrnBold is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapJrnCartridgeSensor Property

PosPrinter.CapJrnCartridgeSensor Property |
 | See Also

1/18/2008

Gets the presence of journal cartridge monitoring sensors.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapJrnCartridgeSensor As PrinterCartridgeSensors
public abstract PrinterCartridgeSensors CapJrnCartridgeSensor { get; }
public:
virtual property PrinterCartridgeSensors CapJrnCartridgeSensor {
    PrinterCartridgeSensors get () abstract;
}
/** @property */
public abstract PrinterCartridgeSensors get_CapJrnCartridgeSensor ()

public abstract function get CapJrnCartridgeSensor () : PrinterCartridgeSensors

Remarks

Possible values are defined by the PrinterCartridgeSensors enumeration.

If the CapJrnPresent property is set to false, then CapJrnCartridgeSensor is set to PrinterCartridgeSensors.None. Otherwise, it is a logical OR combination of the other PrinterCartridgeSensors values.

CapJrnCartridgeSensor is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
JrnCartridgeState
JrnCurrentCartridge
CartridgeNotify


PosPrinter.CapJrnColor Property

PosPrinter.CapJrnColor Property |
 | See Also

1/18/2008

Gets available journal color cartridges.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapJrnColor As PrinterColors
public abstract PrinterColors CapJrnColor { get; }
public:
virtual property PrinterColors CapJrnColor {
    PrinterColors get () abstract;
}
/** @property */
public abstract PrinterColors get_CapJrnColor ()

public abstract function get CapJrnColor () : PrinterColors

Remarks

Possible values are defined by the PrinterColors enumeration.

If the CapJrnPresent property is set to false, CapJrnColor is set to PrinterColors.None. Otherwise, CapJrnColor is a logical OR combination of the other PrinterColors values.

CapJrnColor is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
CapJrnPresent
PrinterColors


PosPrinter.CapJrnDHigh Property

PosPrinter.CapJrnDHigh Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the journal can print double-high characters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapJrnDHigh As Boolean
public abstract bool CapJrnDHigh { get; }
public:
virtual property bool CapJrnDHigh {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapJrnDHigh ()

public abstract function get CapJrnDHigh () : boolean

Remarks

If true, the journal can print double-high characters.

CapJrnDhigh is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapJrnDWide Property

PosPrinter.CapJrnDWide Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the journal can print double-wide characters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapJrnDWide As Boolean
public abstract bool CapJrnDWide { get; }
public:
virtual property bool CapJrnDWide {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapJrnDWide ()

public abstract function get CapJrnDWide () : boolean

Remarks

If true, the journal can print double-wide characters.

CapJrnDwide is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapJrnDWideDHigh Property

PosPrinter.CapJrnDWideDHigh Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the journal can print characters that are both double-high and double-wide.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapJrnDWideDHigh As Boolean
public abstract bool CapJrnDWideDHigh { get; }
public:
virtual property bool CapJrnDWideDHigh {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapJrnDWideDHigh ()

public abstract function get CapJrnDWideDHigh () : boolean

Remarks

If true, the journal can print characters that are both double-high and double-wide.

The service object should set CapJrnDwideDhigh based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapJrnEmptySensor Property

PosPrinter.CapJrnEmptySensor Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the journal has an out-of-paper sensor.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapJrnEmptySensor As Boolean
public abstract bool CapJrnEmptySensor { get; }
public:
virtual property bool CapJrnEmptySensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapJrnEmptySensor ()

public abstract function get CapJrnEmptySensor () : boolean

Remarks

If true, the journal has an out-of-paper sensor.

CapJrnEmptySensor is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapJrnItalic Property

PosPrinter.CapJrnItalic Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the journal can print italic characters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapJrnItalic As Boolean
public abstract bool CapJrnItalic { get; }
public:
virtual property bool CapJrnItalic {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapJrnItalic ()

public abstract function get CapJrnItalic () : boolean

Remarks

If true, the journal can print italic characters.

CapJrnItalic is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapJrnNearEndSensor Property

PosPrinter.CapJrnNearEndSensor Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the journal has a low-paper sensor.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapJrnNearEndSensor As Boolean
public abstract bool CapJrnNearEndSensor { get; }
public:
virtual property bool CapJrnNearEndSensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapJrnNearEndSensor ()

public abstract function get CapJrnNearEndSensor () : boolean

Remarks

If true, the journal has a low-paper sensor.

CapJrnNearEndSensor is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapJrnPresent Property

PosPrinter.CapJrnPresent Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the journal print station is present.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapJrnPresent As Boolean
public abstract bool CapJrnPresent { get; }
public:
virtual property bool CapJrnPresent {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapJrnPresent ()

public abstract function get CapJrnPresent () : boolean

Remarks

If true, the journal print station is present.

CapJrnPresent is set by the service object, based on the whether the journal station is present.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapJrnUnderline Property

PosPrinter.CapJrnUnderline Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the journal can underline characters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapJrnUnderline As Boolean
public abstract bool CapJrnUnderline { get; }
public:
virtual property bool CapJrnUnderline {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapJrnUnderline ()

public abstract function get CapJrnUnderline () : boolean

Remarks

If true, the journal can underline characters.

CapJrnUnderline is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapMapCharacterSet Property

PosPrinter.CapMapCharacterSet Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether when printing data, the service object can map the characters sent by the application (in the character set that is defined by the CharacterSet property) to the character sets that are defined by the CharacterSetList property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapMapCharacterSet As Boolean
public abstract bool CapMapCharacterSet { get; }
public:
virtual property bool CapMapCharacterSet {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapMapCharacterSet ()

public abstract function get CapMapCharacterSet () : boolean

Remarks

If true, when printing data, the service object can map the characters sent by the application (in the character set that is defined by the CharacterSet property) to the character sets that are defined by the CharacterSetList property.

CapMapCharacterSet is set by the service object (together with the CharacterSetList property), based on the capabilities that are available.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
CharacterSet
MapCharacterSet
CharacterSetList


PosPrinter.CapRec2Color Property

PosPrinter.CapRec2Color Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the receipt can print dark plus an alternate color.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRec2Color As Boolean
public abstract bool CapRec2Color { get; }
public:
virtual property bool CapRec2Color {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRec2Color ()

public abstract function get CapRec2Color () : boolean

Remarks

If true, the receipt can print dark plus an alternate color.

CapRec2Color is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapRecBarCode Property

PosPrinter.CapRecBarCode Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the receipt has bar code printing capability.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRecBarCode As Boolean
public abstract bool CapRecBarCode { get; }
public:
virtual property bool CapRecBarCode {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRecBarCode ()

public abstract function get CapRecBarCode () : boolean

Remarks

If true, the receipt has bar code printing capability.

CapRecBarCode is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapRecBitmap Property

PosPrinter.CapRecBitmap Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the receipt can print bitmaps.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRecBitmap As Boolean
public abstract bool CapRecBitmap { get; }
public:
virtual property bool CapRecBitmap {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRecBitmap ()

public abstract function get CapRecBitmap () : boolean

Remarks

If true, the receipt can print bitmaps.

CapRecBitmap is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapRecBold Property

PosPrinter.CapRecBold Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the receipt can print bold characters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRecBold As Boolean
public abstract bool CapRecBold { get; }
public:
virtual property bool CapRecBold {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRecBold ()

public abstract function get CapRecBold () : boolean

Remarks

If true, the receipt can print bold characters.

CapRecBold is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapRecCartridgeSensor Property

PosPrinter.CapRecCartridgeSensor Property |
 | See Also

1/18/2008

Gets the presence of receipt cartridge monitoring sensors.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRecCartridgeSensor As PrinterCartridgeSensors
public abstract PrinterCartridgeSensors CapRecCartridgeSensor { get; }
public:
virtual property PrinterCartridgeSensors CapRecCartridgeSensor {
    PrinterCartridgeSensors get () abstract;
}
/** @property */
public abstract PrinterCartridgeSensors get_CapRecCartridgeSensor ()

public abstract function get CapRecCartridgeSensor () : PrinterCartridgeSensors

Remarks

Possible values are defined by the PrinterCartridgeSensors enumeration.

If the CapRecPresent property is set to false, CapRecCartridgeSensor is set to PrinterCartridgeSensors.None. Otherwise, it is a logical OR combination of the other PrinterCartridgeSensors values.

CapRecCartridgeSensor is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
RecCartridgeState
RecCurrentCartridge
CartridgeNotify
PrinterCartridgeSensors


PosPrinter.CapRecColor Property

PosPrinter.CapRecColor Property |
 | See Also

1/18/2008

Gets the receipt color cartridges.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRecColor As PrinterColors
public abstract PrinterColors CapRecColor { get; }
public:
virtual property PrinterColors CapRecColor {
    PrinterColors get () abstract;
}
/** @property */
public abstract PrinterColors get_CapRecColor ()

public abstract function get CapRecColor () : PrinterColors

Remarks

Possible values are defined by the PrinterColors enumeration.

If the CapRecPresent property is set to false, CapRecColor is set to PrinterColors.None. Otherwise, CapRecColor is a logical OR combination of the other PrinterColors values.

CapRecColor is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
CapRecPresent


PosPrinter.CapRecDHigh Property

PosPrinter.CapRecDHigh Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the receipt can print double-high characters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRecDHigh As Boolean
public abstract bool CapRecDHigh { get; }
public:
virtual property bool CapRecDHigh {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRecDHigh ()

public abstract function get CapRecDHigh () : boolean

Remarks

If true, the receipt can print double-high characters.

CapRecDhigh is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapRecDWide Property

PosPrinter.CapRecDWide Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the receipt can print double-wide characters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRecDWide As Boolean
public abstract bool CapRecDWide { get; }
public:
virtual property bool CapRecDWide {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRecDWide ()

public abstract function get CapRecDWide () : boolean

Remarks

If true, the receipt can print double-wide characters.

CapRecDwide is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapRecDWideDHigh Property

PosPrinter.CapRecDWideDHigh Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the receipt can print double-high, double-wide characters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRecDWideDHigh As Boolean
public abstract bool CapRecDWideDHigh { get; }
public:
virtual property bool CapRecDWideDHigh {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRecDWideDHigh ()

public abstract function get CapRecDWideDHigh () : boolean

Remarks

If true, the receipt can print double-high, double-wide characters.

The service object should set CapRecDwideDhigh based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapRecEmptySensor Property

PosPrinter.CapRecEmptySensor Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the receipt has an out-of-paper sensor.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRecEmptySensor As Boolean
public abstract bool CapRecEmptySensor { get; }
public:
virtual property bool CapRecEmptySensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRecEmptySensor ()

public abstract function get CapRecEmptySensor () : boolean

Remarks

If true, the receipt has an out-of-paper sensor.

CapRecEmptySensor is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapRecItalic Property

PosPrinter.CapRecItalic Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the receipt can print italic characters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRecItalic As Boolean
public abstract bool CapRecItalic { get; }
public:
virtual property bool CapRecItalic {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRecItalic ()

public abstract function get CapRecItalic () : boolean

Remarks

If true, the receipt can print italic characters.

CapRecItalic is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapRecLeft90 Property

PosPrinter.CapRecLeft90 Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the receipt can print in rotated-90-degree-left mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRecLeft90 As Boolean
public abstract bool CapRecLeft90 { get; }
public:
virtual property bool CapRecLeft90 {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRecLeft90 ()

public abstract function get CapRecLeft90 () : boolean

Remarks

If true, the receipt can print in rotated-90-degree-left mode.

CapRecLeft90 is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapRecMarkFeed Property

PosPrinter.CapRecMarkFeed Property |
 | See Also

1/18/2008

Gets the type of mark-sensed paper handling available.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRecMarkFeed As PrinterMarkFeeds
public abstract PrinterMarkFeeds CapRecMarkFeed { get; }
public:
virtual property PrinterMarkFeeds CapRecMarkFeed {
    PrinterMarkFeeds get () abstract;
}
/** @property */
public abstract PrinterMarkFeeds get_CapRecMarkFeed ()

public abstract function get CapRecMarkFeed () : PrinterMarkFeeds

Remarks

Possible values are defined by the PrinterMarkFeeds enumeration.

CapRecMarkFeed is a logical OR combination of the PrinterMarkFeeds values. The values are identical to those used with the MarkFeed method.

CapRecMarkFeed is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.MarkFeed Method
PrinterMarkFeeds


PosPrinter.CapRecNearEndSensor Property

PosPrinter.CapRecNearEndSensor Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the receipt has a low-paper sensor.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRecNearEndSensor As Boolean
public abstract bool CapRecNearEndSensor { get; }
public:
virtual property bool CapRecNearEndSensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRecNearEndSensor ()

public abstract function get CapRecNearEndSensor () : boolean

Remarks

If true, the receipt has a low-paper sensor.

CapRecNearEndSensor is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapRecPageMode Property

PosPrinter.CapRecPageMode Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer can support Page Mode for the receipt station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CapRecPageMode As Boolean
public virtual bool CapRecPageMode { get; }
public:
virtual property bool CapRecPageMode {
    bool get ();
}
/** @property */
public boolean get_CapRecPageMode ()

public function get CapRecPageMode () : boolean

Remarks

If true, the printer can support Page Mode for the receipt station.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapRecPaperCut Property

PosPrinter.CapRecPaperCut Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the receipt can perform paper cuts.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRecPaperCut As Boolean
public abstract bool CapRecPaperCut { get; }
public:
virtual property bool CapRecPaperCut {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRecPaperCut ()

public abstract function get CapRecPaperCut () : boolean

Remarks

If true, the receipt can perform paper cuts.

CapRecPapercut is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapRecPresent Property

PosPrinter.CapRecPresent Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the receipt print station is present.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRecPresent As Boolean
public abstract bool CapRecPresent { get; }
public:
virtual property bool CapRecPresent {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRecPresent ()

public abstract function get CapRecPresent () : boolean

Remarks

If true, the receipt print station is present.

CapRecPresent is set by the service object, based on whether the receipt station is present.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapRecRight90 Property

PosPrinter.CapRecRight90 Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the receipt can print in a rotated-90-degree-right mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRecRight90 As Boolean
public abstract bool CapRecRight90 { get; }
public:
virtual property bool CapRecRight90 {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRecRight90 ()

public abstract function get CapRecRight90 () : boolean

Remarks

If true, the receipt can print in a rotated-90-degree-right mode.

CapRecRight90 is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapRecRotate180 Property

PosPrinter.CapRecRotate180 Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the receipt can print in a rotated upside-down mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRecRotate180 As Boolean
public abstract bool CapRecRotate180 { get; }
public:
virtual property bool CapRecRotate180 {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRecRotate180 ()

public abstract function get CapRecRotate180 () : boolean

Remarks

If true, the receipt can print in a rotated upside-down mode.

CapRecRotate180 is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapRecStamp Property

PosPrinter.CapRecStamp Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the receipt has a stamp capability.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRecStamp As Boolean
public abstract bool CapRecStamp { get; }
public:
virtual property bool CapRecStamp {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRecStamp ()

public abstract function get CapRecStamp () : boolean

Remarks

If true, the receipt has a stamp capability.

CapRecStamp is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapRecUnderline Property

PosPrinter.CapRecUnderline Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the receipt can underline characters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRecUnderline As Boolean
public abstract bool CapRecUnderline { get; }
public:
virtual property bool CapRecUnderline {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRecUnderline ()

public abstract function get CapRecUnderline () : boolean

Remarks

If true, the receipt can underline characters.

CapRecUnderline is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapSlp2Color Property

PosPrinter.CapSlp2Color Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the slip can print dark plus an alternate color.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSlp2Color As Boolean
public abstract bool CapSlp2Color { get; }
public:
virtual property bool CapSlp2Color {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSlp2Color ()

public abstract function get CapSlp2Color () : boolean

Remarks

If true, the slip can print dark plus an alternate color.

CapSlp2Color is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapSlpBarCode Property

PosPrinter.CapSlpBarCode Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the slip has bar code printing capability.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSlpBarCode As Boolean
public abstract bool CapSlpBarCode { get; }
public:
virtual property bool CapSlpBarCode {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSlpBarCode ()

public abstract function get CapSlpBarCode () : boolean

Remarks

If true, the slip has bar code printing capability.

CapSlpBarCode is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapSlpBitmap Property

PosPrinter.CapSlpBitmap Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the slip can print bitmaps.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSlpBitmap As Boolean
public abstract bool CapSlpBitmap { get; }
public:
virtual property bool CapSlpBitmap {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSlpBitmap ()

public abstract function get CapSlpBitmap () : boolean

Remarks

If true, the slip can print bitmaps.

CapSlpBitmap is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapSlpBold Property

PosPrinter.CapSlpBold Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the slip can print bold characters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSlpBold As Boolean
public abstract bool CapSlpBold { get; }
public:
virtual property bool CapSlpBold {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSlpBold ()

public abstract function get CapSlpBold () : boolean

Remarks

If true, the slip can print bold characters.

CapSlpBold is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapSlpBothSidesPrint Property

PosPrinter.CapSlpBothSidesPrint Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the slip print station supports printing on both sides of the document.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSlpBothSidesPrint As Boolean
public abstract bool CapSlpBothSidesPrint { get; }
public:
virtual property bool CapSlpBothSidesPrint {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSlpBothSidesPrint ()

public abstract function get CapSlpBothSidesPrint () : boolean

Remarks

If true, the slip print station supports printing on both sides of the document.

CapSlpBothSidesPrint is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapSlpCartridgeSensor Property

PosPrinter.CapSlpCartridgeSensor Property |
 | See Also

1/18/2008

Gets the presence of slip-cartridge monitoring sensors.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSlpCartridgeSensor As PrinterCartridgeSensors
public abstract PrinterCartridgeSensors CapSlpCartridgeSensor { get; }
public:
virtual property PrinterCartridgeSensors CapSlpCartridgeSensor {
    PrinterCartridgeSensors get () abstract;
}
/** @property */
public abstract PrinterCartridgeSensors get_CapSlpCartridgeSensor ()

public abstract function get CapSlpCartridgeSensor () : PrinterCartridgeSensors

Remarks

Possible values are defined by the PrinterCartridgeSensors enumeration.

If the CapSlpPresent property is set to false, CapSlpCartridgeSensor is set to PrinterCartridgeSensors.None. Otherwise, it is a logical OR combination of the other PrinterCartridgeSensors values.

CapSlpCartridgeSensor is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
SlpCartridgeState
SlpCurrentCartridge
CartridgeNotify
PrinterCartridgeSensors


PosPrinter.CapSlpColor Property

PosPrinter.CapSlpColor Property |
 | See Also

1/18/2008

Gets the type of color cartridges supported for slip printing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSlpColor As PrinterColors
public abstract PrinterColors CapSlpColor { get; }
public:
virtual property PrinterColors CapSlpColor {
    PrinterColors get () abstract;
}
/** @property */
public abstract PrinterColors get_CapSlpColor ()

public abstract function get CapSlpColor () : PrinterColors

Remarks

Possible values are defined by the PrinterColors enumeration.

If the CapSlpPresent property is set to false, CapSlpColor is set to PrinterColors.None. Otherwise, CapSlpColor is a logical OR combination of the other PrinterColors values.

CapSlpColor is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
CapSlpPresent
PrinterColors


PosPrinter.CapSlpDHigh Property

PosPrinter.CapSlpDHigh Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the slip can print double-high characters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSlpDHigh As Boolean
public abstract bool CapSlpDHigh { get; }
public:
virtual property bool CapSlpDHigh {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSlpDHigh ()

public abstract function get CapSlpDHigh () : boolean

Remarks

If true, the slip can print double-high characters.

CapSlpDhigh is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapSlpDWide Property

PosPrinter.CapSlpDWide Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the slip can print double-wide characters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSlpDWide As Boolean
public abstract bool CapSlpDWide { get; }
public:
virtual property bool CapSlpDWide {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSlpDWide ()

public abstract function get CapSlpDWide () : boolean

Remarks

If true, the slip can print double-wide characters.

CapSlpDwide is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapSlpDWideDHigh Property

PosPrinter.CapSlpDWideDHigh Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the slip can print characters that are both double-wide and double-high.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSlpDWideDHigh As Boolean
public abstract bool CapSlpDWideDHigh { get; }
public:
virtual property bool CapSlpDWideDHigh {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSlpDWideDHigh ()

public abstract function get CapSlpDWideDHigh () : boolean

Remarks

If true, the slip can print characters that are both double-wide and double-high.

The service object should set CapSlpDwideDhigh based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapSlpEmptySensor Property

PosPrinter.CapSlpEmptySensor Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the slip has a "slip in" sensor.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSlpEmptySensor As Boolean
public abstract bool CapSlpEmptySensor { get; }
public:
virtual property bool CapSlpEmptySensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSlpEmptySensor ()

public abstract function get CapSlpEmptySensor () : boolean

Remarks

If true, the slip has a "slip in" sensor.

CapSlpEmptySensor is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapSlpFullSlip Property

PosPrinter.CapSlpFullSlip Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the slip is a full slip station; it can print full-length forms.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSlpFullSlip As Boolean
public abstract bool CapSlpFullSlip { get; }
public:
virtual property bool CapSlpFullSlip {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSlpFullSlip ()

public abstract function get CapSlpFullSlip () : boolean

Remarks

If true, the slip is a full slip station; it can print full-length forms.

If false, the slip is a validation-type station. Validation-type stations usually limit the number of print lines and disable access to the receipt and journal stations while the validation slip is being used.

CapSlpFullslip is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapSlpItalic Property

PosPrinter.CapSlpItalic Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the slip can print italic characters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSlpItalic As Boolean
public abstract bool CapSlpItalic { get; }
public:
virtual property bool CapSlpItalic {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSlpItalic ()

public abstract function get CapSlpItalic () : boolean

Remarks

If true, the slip can print italic characters.

CapSlpItalic is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapSlpLeft90 Property

PosPrinter.CapSlpLeft90 Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the slip can print in a rotated 90 degree left mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSlpLeft90 As Boolean
public abstract bool CapSlpLeft90 { get; }
public:
virtual property bool CapSlpLeft90 {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSlpLeft90 ()

public abstract function get CapSlpLeft90 () : boolean

Remarks

If true, the slip can print in a rotated 90 degree left mode.

CapSlpLeft90 is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapSlpNearEndSensor Property

PosPrinter.CapSlpNearEndSensor Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the slip has a "slip near end" sensor.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSlpNearEndSensor As Boolean
public abstract bool CapSlpNearEndSensor { get; }
public:
virtual property bool CapSlpNearEndSensor {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSlpNearEndSensor ()

public abstract function get CapSlpNearEndSensor () : boolean

Remarks

If true, the slip has a "slip near end" sensor.

CapSlpNearEndSensor is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapSlpPageMode Property

PosPrinter.CapSlpPageMode Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer can support Page Mode for the slip station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CapSlpPageMode As Boolean
public virtual bool CapSlpPageMode { get; }
public:
virtual property bool CapSlpPageMode {
    bool get ();
}
/** @property */
public boolean get_CapSlpPageMode ()

public function get CapSlpPageMode () : boolean

Remarks

If true, then the printer can support Page Mode for the slip station.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapSlpPresent Property

PosPrinter.CapSlpPresent Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the slip print station is present.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSlpPresent As Boolean
public abstract bool CapSlpPresent { get; }
public:
virtual property bool CapSlpPresent {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSlpPresent ()

public abstract function get CapSlpPresent () : boolean

Remarks

If true, the slip print station is present.

The service object should set CapSlpPresent based on whether the slip station is present.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapSlpRight90 Property

PosPrinter.CapSlpRight90 Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the slip can print in a rotated-90-degree-right mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSlpRight90 As Boolean
public abstract bool CapSlpRight90 { get; }
public:
virtual property bool CapSlpRight90 {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSlpRight90 ()

public abstract function get CapSlpRight90 () : boolean

Remarks

If true, the slip can print in a rotated-90-degree-right mode.

CapSlpRight90 is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapSlpRotate180 Property

PosPrinter.CapSlpRotate180 Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the slip can print in an upside-down mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSlpRotate180 As Boolean
public abstract bool CapSlpRotate180 { get; }
public:
virtual property bool CapSlpRotate180 {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSlpRotate180 ()

public abstract function get CapSlpRotate180 () : boolean

Remarks

If true, the slip can print in an upside-down mode.

CapSlpRotate180 is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapSlpUnderline Property

PosPrinter.CapSlpUnderline Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the slip can underline characters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSlpUnderline As Boolean
public abstract bool CapSlpUnderline { get; }
public:
virtual property bool CapSlpUnderline {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSlpUnderline ()

public abstract function get CapSlpUnderline () : boolean

Remarks

If true, the slip can underline characters.

CapSlpUnderline is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CapTransaction Property

PosPrinter.CapTransaction Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether each station supports printer transactions.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapTransaction As Boolean
public abstract bool CapTransaction { get; }
public:
virtual property bool CapTransaction {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapTransaction ()

public abstract function get CapTransaction () : boolean

Remarks

If true, each station supports printer transactions.

CapTransaction is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.CartridgeNotify Property

PosPrinter.CartridgeNotify Property |
 | See Also

1/18/2008

Gets or sets the type of cartridge state notification the application wants to receive.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property CartridgeNotify As PrinterCartridgeNotify
public abstract PrinterCartridgeNotify CartridgeNotify { get; set; }
public:
virtual property PrinterCartridgeNotify CartridgeNotify {
    PrinterCartridgeNotify get () abstract;
    void set (PrinterCartridgeNotify value) abstract;
}
/** @property */
public abstract PrinterCartridgeNotify get_CartridgeNotify ()

/** @property */
public abstract void set_CartridgeNotify (PrinterCartridgeNotify value)

public abstract function get CartridgeNotify () : PrinterCartridgeNotify

public abstract function set CartridgeNotify (value : PrinterCartridgeNotify)

Remarks

Possible values are defined in the PrinterCartridgeNotify enumeration.

CartridgeNotify can only be set when the device is disabled—that is, when the DeviceEnabled property is set to false.

The application should set CartridgeNotify based on the type of cartridge state notification it wants to receive.

If the application sets CartridgeNotify to PrinterCartridgeNotify.Enabled, the service object raises cartridge state notification StatusUpdateEvent events and updates the JrnCartridgeState, RecCartridgeState, and SlpCartidgeState properties, beginning when the DeviceEnabled property is set to true. The level of functionality depends on the values of the CapJrnCartridgeSensor, CapRecCartridgeSensor, and CapSlpCartridgeSensor properties.

If the application sets CartridgeNotify to PrinterCartridgeNotify.Disabled, no cartridge state notification StatusUpdateEvent events will be raised, and the JrnCartridgeState, RecCartridgeState, and SlpCartidgeState properties may not be set.

Accessing CartridgeNotify may cause a PosControlException to be thrown with the following ErrorCode:

Value

Meaning

Illegal

One of the following conditions occurred:

  • CartridgeNotify cannot be set while the device is enabled;

  • CartridgeNotify was set to a value that is not valid for the PrinterCartridgeNotify enumeration; or

  • CartridgeNotify is set to PrinterCartridgeNotify.Enabled but the CapJrnCartridgeSensor, CapRecCartridgeSensor, and CapSlpCartridgeSensor properties are set to PrinterCartridgeSensors.None.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.CapJrnCartridgeSensor Property
PosPrinter.CapRecCartridgeSensor Property
PosPrinter.CapSlpCartridgeSensor Property
JrnCartridgeState
RecCartridgeState
SlpCartridgeState
PrinterCartridgeNotify
PrinterCartridgeSensors
PosCommon.DeviceEnabled Property


PosPrinter.CharacterSet Property

PosPrinter.CharacterSet Property |
 | See Also

1/18/2008

Gets or sets the numeric value that indicates the character set that the application wants to use for printing characters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property CharacterSet As Integer
public abstract int CharacterSet { get; set; }
public:
virtual property int CharacterSet {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_CharacterSet ()

/** @property */
public abstract void set_CharacterSet (int value)

public abstract function get CharacterSet () : int

public abstract function set CharacterSet (value : int)

Remarks

The application should set CharacterSet to a value from those listed in the CharacterSetList property. (The service object sets CharacterSetList to the character sets available for mapping.)

Values are as follows:

Value | Meaning
VRange 101 - 199 | Device-specific character sets that do not match a code page or the ASCII or Windows ANSI character sets.
Range 400 - 990 | Code page; matches one of the standard values.
Unicode | The character set supports Unicode. The value of this constant is 997.
ASCII | The ASCII character set, supporting the ASCII characters between 0x20 and 0x7F. The value of this constant is 998.
Windows | The Windows ANSI character set. The value of this constant is 999. This is exactly the same as the Windows code page 1252.
Range 1000 and higher | Windows code page; matches one of the standard values.

Accessing CharacterSet may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The application specified a value for CharacterSet that does not exist in the list provided by the service object (that is, in the list of values specified for the CharacterSetList property).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
CharacterSetList


PosPrinter.CharacterSetList Property

PosPrinter.CharacterSetList Property |
 | See Also

1/18/2008

Gets the list of character set numbers supported for printing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CharacterSetList As Integer()
public abstract int[] CharacterSetList { get; }
public:
virtual property array<int>^ CharacterSetList {
    array<int>^ get () abstract;
}
/** @property */
public abstract int[] get_CharacterSetList ()

public abstract function get CharacterSetList () : int[]

Remarks

The service object must set CharacterSetList based on the capabilities of the device.

The array of character set numbers consists of ASCII numeric set numbers separated by commas. For example, if the list is "101,850,999", the device supports a device-specific character set, code page 850, and the Windows ANSI character set.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.CharacterSet Property


PosPrinter.CoverOpen Property

PosPrinter.CoverOpen Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer’s cover is open.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CoverOpen As Boolean
public abstract bool CoverOpen { get; }
public:
virtual property bool CoverOpen {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CoverOpen ()

public abstract function get CoverOpen () : boolean

Remarks

If true, the printer’s cover is open.

If the CapCoverSensor property is set to FALSE, the printer does not have a cover-open sensor, and CoverOpen is always set to FALSE.

CoverOpen is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.CapCoverSensor Property


PosPrinter.ErrorLevel Property

PosPrinter.ErrorLevel Property |
 | See Also

1/18/2008

Gets the severity of the most recent error condition.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ErrorLevel As PrinterErrorLevel
public abstract PrinterErrorLevel ErrorLevel { get; }
public:
virtual property PrinterErrorLevel ErrorLevel {
    PrinterErrorLevel get () abstract;
}
/** @property */
public abstract PrinterErrorLevel get_ErrorLevel ()

public abstract function get ErrorLevel () : PrinterErrorLevel

Remarks

Possible values are defined by the PrinterErrorLevel enumeration.

ErrorLevel is set by the service object only before delivering an ErrorEvent event to the application. When the error is cleared, the service object changes ErrorLevel to PrinterErrorLevel.None.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
ErrorEvent
PrinterErrorLevel


PosPrinter.ErrorStation Property

PosPrinter.ErrorStation Property |
 | See Also

1/18/2008

Gets the station or stations that were printing when an error was detected.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ErrorStation As PrinterStation
public abstract PrinterStation ErrorStation { get; }
public:
virtual property PrinterStation ErrorStation {
    PrinterStation get () abstract;
}
/** @property */
public abstract PrinterStation get_ErrorStation ()

public abstract function get ErrorStation () : PrinterStation

Remarks

Possible values are defined in the PrinterStation enumeration.

The service object sets ErrorStation only before delivering an ErrorEvent event to the application. If the ErrorLevel property is currently set to PrinterErrorLevel.None, ErrorStation will be set to PrinterStation.None.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.ErrorLevel Property
PrinterStation


PosPrinter.ErrorString Property

PosPrinter.ErrorString Property |
 | See Also

1/18/2008

Gets a vendor-supplied description of the current error.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ErrorString As String
public abstract string ErrorString { get; }
public:
virtual property String^ ErrorString {
    String^ get () abstract;
}
/** @property */
public abstract String get_ErrorString ()

public abstract function get ErrorString () : String

Remarks

If the ErrorLevel property is currently set to PrinterErrorLevel.None, ErrorString will be blank.

The service object sets ErrorString only before delivering an ErrorEvent event. If no description is available, ErrorString will be blank. When the error is cleared, the service object changes ErrorString to blank.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.FlagWhenIdle Property

PosPrinter.FlagWhenIdle Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether the service object queues a StatusUpdateEvent event by using the StatusIdle constant when the device is in an idle state, and reset FlagWhenIdle to false.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property FlagWhenIdle As Boolean
public abstract bool FlagWhenIdle { get; set; }
public:
virtual property bool FlagWhenIdle {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_FlagWhenIdle ()

/** @property */
public abstract void set_FlagWhenIdle (boolean value)

public abstract function get FlagWhenIdle () : boolean

public abstract function set FlagWhenIdle (value : boolean)

Remarks

If set to true by the application, the service object will queue a StatusUpdateEvent event by using the StatusIdle constant when the device is in an idle state, and reset FlagWhenIdle to false.

If the application sets FlagWhenIdle to true while the State property is ControlState.Idle, the event will be queued immediately.

The main use of an idle status event controlled by FlagWhenIdle is to give the application control when all outstanding asynchronous outputs have been processed. The event will be queued if the outputs were completed successfully, or if they were cleared by the ClearOutput method or by an ErrorEvent handler.

Because a StatusUpdateEvent is queued immediately after FlagWhenIdle is set to true (if the device is idle), the application can depend on the event, without a race condition between the starting of its last asynchronous output and the setting of this flag.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosCommon.State Property


PosPrinter.FontTypefaceList Property

PosPrinter.FontTypefaceList Property |
 | See Also

1/18/2008

Gets a string array that specifies the fonts and typefaces supported by the printer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property FontTypefaceList As String()
public abstract string[] FontTypefaceList { get; }
public:
virtual property array<String^>^ FontTypefaceList {
    array<String^>^ get () abstract;
}
/** @property */
public abstract String[] get_FontTypefaceList ()

public abstract function get FontTypefaceList () : String[]

Remarks

When updated by the service object based on the capability of the printer, the string array consists of font or font names. The application selects a font or font for a printer station by using the font font selection escape sequence (ESC|#fT). The "#" character is replaced by the number of the font or font within the list: 1, 2, and so on.

In Japan, FontTypefaceList will frequently include the fonts "Mincho" and "Gothic." Other fonts or typefaces may be usually supported in other countries and regions.

An empty array indicates that only the default font is supported.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.IsExclusiveUseDevice Property

PosPrinter.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the PosPrinter is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Remarks

A value of true indicates that the PosPrinter is exclusive-use, while a value of false indicates that it is not exclusive-use.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.JrnCartridgeState Property

PosPrinter.JrnCartridgeState Property |
 | See Also

1/18/2008

Gets the status of the selected journal cartridge (ink, ribbon, or toner).

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property JrnCartridgeState As PrinterCartridgeStates
public abstract PrinterCartridgeStates JrnCartridgeState { get; }
public:
virtual property PrinterCartridgeStates JrnCartridgeState {
    PrinterCartridgeStates get () abstract;
}
/** @property */
public abstract PrinterCartridgeStates get_JrnCartridgeState ()

public abstract function get JrnCartridgeState () : PrinterCartridgeStates

Remarks

Possible values are defined by the PrinterCartridgeStates enumeration.

Value

Meaning

Unknown

Cannot determine the cartridge state, for one of the following reasons:

  • The CapJrnCartridgeSensor property is set to PrinterCartridgeSensors.None. The device does not support cartridge-state reporting.

  • The CartridgeNotify property is set to PrinterCartridgeNotify.Disabled. Cartridge-state notifications are disabled.

  • The DeviceEnabled property is set to false. Cartridge state monitoring does not occur until the device is enabled.

Removed

The cartridge specified by the JrnCurrentCartridge property has been removed.

Empty

The cartridge specified by JrnCurrentCartridge is empty.

Cleaning

The head specified by JrnCurrentCartridge is being cleaned.

NearEnd

The cartridge specified by JrnCurrentCartridge is near its end.

OK

The cartridge specified by JrnCurrentCartridge is in normal condition.
Note:
These values are listed according to their priority order. The service object should set them in priority order also.

When JrnCartridgeState is set to any value other than PrinterCartridgeStates.Unknown, the service object queues a StatusUpdateEvent event by using the StatusJournal range constants, notifying the application of the change.

JrnCartridgeState is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
JrnCurrentCartridge
PosPrinter.CartridgeNotify Property
PosPrinter.CapJrnCartridgeSensor Property
PrinterCartridgeStates


PosPrinter.JrnCurrentCartridge Property

PosPrinter.JrnCurrentCartridge Property |
 | See Also

1/18/2008

Gets or sets the currently selected journal cartridge.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property JrnCurrentCartridge As PrinterColors
public abstract PrinterColors JrnCurrentCartridge { get; set; }
public:
virtual property PrinterColors JrnCurrentCartridge {
    PrinterColors get () abstract;
    void set (PrinterColors value) abstract;
}
/** @property */
public abstract PrinterColors get_JrnCurrentCartridge ()

/** @property */
public abstract void set_JrnCurrentCartridge (PrinterColors value)

public abstract function get JrnCurrentCartridge () : PrinterColors

public abstract function set JrnCurrentCartridge (value : PrinterColors)

Remarks

Possible values are defined by the PrinterColors enumeration.

JrnCurrentCartridge is set when the device is first enabled following the Open method. The application should set JrnCurrentCartridge based on the color in which it wants to print.

The value of JrnCurrentCartridge is must be one of the color cartridges specified by the CapJrnColor property. (JrnCurrentCartridge cannot be set to PrinterColors.Full.)

Setting JrnCurrentCartridge may also update the JrnCartridgeState property.

Accessing JrnCurrentCartridge may cause a PosControlException to be thrown with the following ErrorCode:

Value

Meaning

Illegal

One or more of the following conditions has occurred:

  • The CapJrnPresent property is set to false. This indicates that there is no journal station on this printer. In this case, JrnCurrentCartridge should be set to PrinterColors.None.

  • JrnCurrentCartridge was set to PrinterColors.None. However, the CapJrnPresent property is set to true. This indicates that a journal station is present.

  • JrnCurrentCartridge was either set to a value not found in the PrinterColors enumeration or set to PrinterColors.Full. Both are invalid.

  • JrnCurrentCartridge was set to a value not listed for the CapJrnColor property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.JrnCartridgeState Property
PosPrinter.CapJrnColor Property
PrinterColors


PosPrinter.JrnEmpty Property

PosPrinter.JrnEmpty Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether the journal is out of paper.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property JrnEmpty As Boolean
public abstract bool JrnEmpty { get; }
public:
virtual property bool JrnEmpty {
    bool get () abstract;
}
/** @property */
public abstract boolean get_JrnEmpty ()

public abstract function get JrnEmpty () : boolean

Remarks

whether If set to true, the journal is out of paper.

If the CapJrnEmptySensor property is set to false, the value of JrnEmpty is always set to false.

When JrnEmpty is set to true by the service object, the service object queues a StatusUpdateEvent event by using the StatusJournalEmpty constant, notifying the application of the condition. When the service object resets JrnEmpty to false. This indicates that the condition has been resolved, it queues a second StatusUpdateEvent event by using the StatusJournalPaperOK constant, notifying the application of the resolution.

JrnEmpty is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.CapJrnEmptySensor Property
JrnNearEnd


PosPrinter.JrnLetterQuality Property

PosPrinter.JrnLetterQuality Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether the printer can print in high-quality mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property JrnLetterQuality As Boolean
public abstract bool JrnLetterQuality { get; set; }
public:
virtual property bool JrnLetterQuality {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_JrnLetterQuality ()

/** @property */
public abstract void set_JrnLetterQuality (boolean value)

public abstract function get JrnLetterQuality () : boolean

public abstract function set JrnLetterQuality (value : boolean)

Remarks

If true, prints in high-quality mode. If false, prints in high-speed mode.

The application sets JrnLetterQuality to advise the service object that either high-quality or high-speed printing is desired. For example, printers with bidirectional print capability can be put in unidirectional mode for high quality so that column alignment is more precise.

Setting JrnLetterQuality may also cause the service object to update the JrnLineWidth, JrnLineHeight, and JrnLineSpacing properties if the MapMode property is set to MapMode.Dots. (See the note under PosPrinter.MapMode.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
JrnLineWidth
JrnLineHeight
JrnLineSpacing
MapMode


PosPrinter.JrnLineChars Property

PosPrinter.JrnLineChars Property |
 | See Also

1/18/2008

Gets or sets the number of characters that the application wants to print on a journal line.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property JrnLineChars As Integer
public abstract int JrnLineChars { get; set; }
public:
virtual property int JrnLineChars {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_JrnLineChars ()

/** @property */
public abstract void set_JrnLineChars (int value)

public abstract function get JrnLineChars () : int

public abstract function set JrnLineChars (value : int)

Remarks

If the specified number of characters per line can be supported, the service object sets the line width to the specified value. If the exact width cannot be supported and the value is less than the maximum value enabled for the printer, later lines will be printed with the number that most closely supports the specified characters per line. (For example, if JrnLineChars is set to 36 and the printer can print either 30 or 40 characters per line, the service object should select the line width of 40 and print up to 36 characters on each line.)

If the specified line width cannot be supported and the value is greater than the maximum value enabled for the printer, then an error is returned. (For example, if JrnLineChars is set to 42 and the printer can print either 30 or 40 characters per line, the service object cannot support the request.)

Setting JrnLineChars may also update the JrnLineWidth, JrnLineHeight, and JrnLineSpacing properties, because the character pitch or font may be changed.

The service object sets JrnLineChars to the printer’s default line width when the device is first enabled following the Open method.

Accessing JrnLineChars may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The number of characters specified is greater than the maximum enabled for the printer.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
JrnLineCharsList
JrnLineWidth
JrnLineHeight
JrnLineSpacing


PosPrinter.JrnLineCharsList Property

PosPrinter.JrnLineCharsList Property |
 | See Also

1/18/2008

Gets a collection of the line widths (characters per line) supported by the journal station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property JrnLineCharsList As Integer()
public abstract int[] JrnLineCharsList { get; }
public:
virtual property array<int>^ JrnLineCharsList {
    array<int>^ get () abstract;
}
/** @property */
public abstract int[] get_JrnLineCharsList ()

public abstract function get JrnLineCharsList () : int[]

Remarks

The array consists of ASCII numeric set numbers. For example, if the collection is "32,36,40", the station supports line widths of 32, 36, and 40 characters.

JrnLineCharsList is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.JrnLineChars Property


PosPrinter.JrnLineHeight Property

PosPrinter.JrnLineHeight Property |
 | See Also

1/18/2008

Gets or sets the journal print line height that the application wants to use, expressed in the unit of measure indicated by the MapMode property setting.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property JrnLineHeight As Integer
public abstract int JrnLineHeight { get; set; }
public:
virtual property int JrnLineHeight {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_JrnLineHeight ()

/** @property */
public abstract void set_JrnLineHeight (int value)

public abstract function get JrnLineHeight () : int

public abstract function set JrnLineHeight (value : int)

Remarks

If the specified height can be supported with the current character width setting, the service object sets the line height to this value. If the exact height cannot be supported, the height is set to the closest supported value.

When the JrnLineChars property is changed, JrnLineHeight is updated to the default line height for the selected width.

The service object sets JrnLineHeight to the printer’s default line height when the device is first enabled following the Open method.

Accessing JrnLineHeight may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The number of characters specified is less than 0 (zero).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.JrnLineChars Property
MapMode


PosPrinter.JrnLineSpacing Property

PosPrinter.JrnLineSpacing Property |
 | See Also

1/18/2008

Gets or sets the spacing of each single-high print line, including both the printed line height and the white space between each pair of lines that the application wants to use.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property JrnLineSpacing As Integer
public abstract int JrnLineSpacing { get; set; }
public:
virtual property int JrnLineSpacing {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_JrnLineSpacing ()

/** @property */
public abstract void set_JrnLineSpacing (int value)

public abstract function get JrnLineSpacing () : int

public abstract function set JrnLineSpacing (value : int)

Remarks

Depending on the printer and the current line spacing, a multi-high print line might exceed this value. Line spacing is expressed in the unit of measure indicated by the MapMode property setting.

If the specified spacing can be supported by the printer, the service object sets line spacing to this value. If the spacing cannot be supported, the spacing is set to the closest supported value.

When the JrnLineChars or JrnLineHeight properties are changed, JrnLineSpacing is updated to the default line spacing for the selected width or height.

The service object sets JrnLineSpacing to the printer’s default line spacing when the device is first enabled following the Open method.

Accessing JrnLineSpacing may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The number of characters specified is less than 0 (zero).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.JrnLineChars Property
PosPrinter.JrnLineHeight Property
MapMode


PosPrinter.JrnLineWidth Property

PosPrinter.JrnLineWidth Property |
 | See Also

1/18/2008

Gets the width of a line for the number of characters indicated by the JrnLineChars property, expressed in the unit of measure indicated by the MapMode property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property JrnLineWidth As Integer
public abstract int JrnLineWidth { get; }
public:
virtual property int JrnLineWidth {
    int get () abstract;
}
/** @property */
public abstract int get_JrnLineWidth ()

public abstract function get JrnLineWidth () : int

Remarks

Setting the JrnLineChars property may also update the JrnLineWidth property.

The service object sets the printer’s default line width when the device is first enabled following the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.JrnLineChars Property
MapMode


PosPrinter.JrnNearEnd Property

PosPrinter.JrnNearEnd Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the journal paper is low.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property JrnNearEnd As Boolean
public abstract bool JrnNearEnd { get; }
public:
virtual property bool JrnNearEnd {
    bool get () abstract;
}
/** @property */
public abstract boolean get_JrnNearEnd ()

public abstract function get JrnNearEnd () : boolean

Remarks

If true, the journal paper is low. If the CapJrnNearEndSensor property is set to false, the value of JrnNearEnd is always set to false.

When JrnNearEnd is set to true by the service object, POS for .NET queues a StatusUpdateEvent event, notifying the application of the condition. When the service object resets JrnNearEnd to false. This indicates that the condition has been resolved, POS for .NET queues a StatusUpdateEvent event, notifying the application of the resolution.

JrnNearEnd is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.CapJrnNearEndSensor Property
PosPrinter.JrnEmpty Property


PosPrinter.MapCharacterSet Property

PosPrinter.MapCharacterSet Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the service object maps the characters transferred by the application to the character set selected in the CharacterSet property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property MapCharacterSet As Boolean
public abstract bool MapCharacterSet { get; set; }
public:
virtual property bool MapCharacterSet {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_MapCharacterSet ()

/** @property */
public abstract void set_MapCharacterSet (boolean value)

public abstract function get MapCharacterSet () : boolean

public abstract function set MapCharacterSet (value : boolean)

Remarks

If set to true by the application while outputting data, the service object maps the characters transferred by the application to the character set selected in the CharacterSet property.

If false, no mapping occurs. When set to false, the application has to guarantee the mapping of the character set used by the application to the character set selected in the CharacterSet property.

If the CapMapCharacterSet property is set to false, then MapCharacterSet is always set to false.

Accessing MapCharacterSet may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | CapMapCharacterSet is set to false. This indicates that character set mapping is not supported by this device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.CharacterSet Property
PosPrinter.CapMapCharacterSet Property


PosPrinter.MapMode Property

PosPrinter.MapMode Property |
 | See Also

1/18/2008

Gets or sets the mapping mode of the printer the application wants to use.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property MapMode As MapMode
public abstract MapMode MapMode { get; set; }
public:
virtual property MapMode MapMode {
    MapMode get () abstract;
    void set (MapMode value) abstract;
}
/** @property */
public abstract MapMode get_MapMode ()

/** @property */
public abstract void set_MapMode (MapMode value)

public abstract function get MapMode () : MapMode

public abstract function set MapMode (value : MapMode)

Remarks

Possible values are defined by the MapMode enumeration.

The mapping mode defines the unit of measure used for other properties, such as line height and line spacing.

Setting MapMode may also change the JrnLineHeight, JrnLineSpacing, JrnLineWidth, RecLineHeight, RecLineSpacing, RecLineWidth, SlpLineHeight, SlpLineSpacing, and SlpLineWidth properties.

The value of MapMode is set when the device is first enabled following the Open method.

Accessing MapMode may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The specified mapping mode is not valid—that is, it does not exist in the MapMode enumeration.
Note:
From the POS printer perspective, the exact definition of a "dot" is not significant. It is a printer/service object unit used to express various metrics. For example, some printers define a "halfdot" that is used in high-density graphics printing, and perhaps in text printing. A printer’s service object may handle this case in one of these ways:

  • Consistently define a "dot" as the printer’s smallest physical size, that is, a half-dot.

  • If the service object changes bitmap graphics printing density based on the XxxLetterQuality setting, then alter the size of a dot to match the bitmap density (that is, a physical printer dot when false and a half-dot when true). Notice that this choice should not be used if the printer’s text metrics are based on half-dot sizes, because accurate values for the metrics may not then be possible.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.OutputId Property

PosPrinter.OutputId Property |
 | See Also

1/18/2008

Gets the identifier associated with the current output request.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property OutputId As Integer
public abstract int OutputId { get; }
public:
virtual property int OutputId {
    int get () abstract;
}
/** @property */
public abstract int get_OutputId ()

public abstract function get OutputId () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.PageModeArea Property

PosPrinter.PageModeArea Property |
 | See Also

1/18/2008

Gets the page area for the selected PageModeStation expressed in the unit of measure given by MapMode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property PageModeArea As Point
public virtual Point PageModeArea { get; }
public:
virtual property Point PageModeArea {
    Point get ();
}
/** @property */
public Point get_PageModeArea ()

public function get PageModeArea () : Point

Remarks

This page area can differ from the print area and is determined by the hardware capability of the printer. The string consists of two ASCII numbers separated by a comma, in the following order: horizontal size, vertical size.

For example, if the string is "450,800", then the page size is 450 horizontal units by 800 vertical units, and the station print area is a rectangle beginning at the upper-left point (0,0), and continuing up to but excluding the lower right point (450,800).

The PageModeStation property must be set to a valid station before accessing PageModeArea. Otherwise, an empty string is returned.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.PageModeDescriptor Property

PosPrinter.PageModeDescriptor Property |
 | See Also

1/18/2008

Gets the basic Page mode functionality of the printer for the selected PageModeStation property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property PageModeDescriptor As PageModeDescriptors
public virtual PageModeDescriptors PageModeDescriptor { get; }
public:
virtual property PageModeDescriptors PageModeDescriptor {
    PageModeDescriptors get ();
}
/** @property */
public PageModeDescriptors get_PageModeDescriptor ()

public function get PageModeDescriptor () : PageModeDescriptors

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.PageModeHorizontalPosition Property

PosPrinter.PageModeHorizontalPosition Property |
 | See Also

1/18/2008

Gets or sets the horizontal start position offset within the print area for the print station specified by the PageModeStation property, expressed in the unit of measure specified by the MapMode property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Property PageModeHorizontalPosition As Integer
public virtual int PageModeHorizontalPosition { get; set; }
public:
virtual property int PageModeHorizontalPosition {
    int get ();
    void set (int value);
}
/** @property */
public int get_PageModeHorizontalPosition ()

/** @property */
public void set_PageModeHorizontalPosition (int value)

public function get PageModeHorizontalPosition () : int

public function set PageModeHorizontalPosition (value : int)

Remarks

The horizontal direction is the same as the direction specified by the PageModePrintDirection property. If the exact specified position cannot be supported, the service object will set the position to the closest supported value.

Note:
Retrieving the value of PageModeHorizontalPosition returns the horizontal position offset specified by the last setting of this property and not the current position.

If PageModeStation property is set to an invalid value, PageModeHorizontalPosition is set to zero (0).

Setting PageModeHorizontalPosition may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The specified value is either less than zero or greater than the current page width minus 1.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.PageModePrintArea Property

PosPrinter.PageModePrintArea Property |
 | See Also

1/18/2008

Gets or sets the print area for the print station specified by the PageModeStation property, expressed in the unit of measured specified by the MapMode property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Property PageModePrintArea As Rectangle
public virtual Rectangle PageModePrintArea { get; set; }
public:
virtual property Rectangle PageModePrintArea {
    Rectangle get ();
    void set (Rectangle value);
}
/** @property */
public Rectangle get_PageModePrintArea ()

/** @property */
public void set_PageModePrintArea (Rectangle value)

public function get PageModePrintArea () : Rectangle

public function set PageModePrintArea (value : Rectangle)

Remarks

The maximum possible print area is the page area.

Text written to the right edge of the print area will wrap to the next line. Any text or image written beyond the bottom of the print area will be truncated.

If the PageModeStation property is set to an invalid print station, PageModePrintArea returns an empty .NET Rectangle.

PageModePrintArea may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The specified value is invalid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.PageModePrintDirection Property

PosPrinter.PageModePrintDirection Property |
 | See Also

1/18/2008

Gets the print direction, as specified by the PageModePrintDirection enumeration.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Property PageModePrintDirection As PageModePrintDirection
public virtual PageModePrintDirection PageModePrintDirection { get; set; }
public:
virtual property PageModePrintDirection PageModePrintDirection {
    PageModePrintDirection get ();
    void set (PageModePrintDirection value);
}
/** @property */
public PageModePrintDirection get_PageModePrintDirection ()

/** @property */
public void set_PageModePrintDirection (PageModePrintDirection value)

public function get PageModePrintDirection () : PageModePrintDirection

public function set PageModePrintDirection (value : PageModePrintDirection)

Remarks

Possible values are as follows:

Member | Description
BottomToTop | Print bottom to top, starting at the lower left position of the print area (that is, rotated left 90° printing).
LeftToRight | Print left to right, starting at upper-left position of the print area (that is, normal printing).
None | No valid station is selected.
RightToLeft | Print right to left, starting at the lower right position of the print area (that is, upside down printing).
TopToBottom | Print top to bottom, starting at the upper-right position of the print area (that is, rotated right 90° printing.)

If the PageModeStation property is set to PrinterStation.None, then PageModePrintDirection is set to PageModePrintDirection.None.

Setting PageModePrintDirection affects the current print area, and can also change the values of the PageModeHorizontalPosition and PageModeVerticalPostion properties.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.PageModeStation Property

PosPrinter.PageModeStation Property |
 | See Also

1/18/2008

Gets or sets the printer station, as specified by the PrinterStation enumeration.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Property PageModeStation As PrinterStation
public virtual PrinterStation PageModeStation { get; set; }
public:
virtual property PrinterStation PageModeStation {
    PrinterStation get ();
    void set (PrinterStation value);
}
/** @property */
public PrinterStation get_PageModeStation ()

/** @property */
public void set_PageModeStation (PrinterStation value)

public function get PageModeStation () : PrinterStation

public function set PageModeStation (value : PrinterStation)

Remarks

Valid values are as follows:

Member | Description
None | The current printer station is undefined.
Receipt | The current printer station is Receipt.
Slip | The current printer station is Slip.

Setting PageModeStation may throw a PosControlException with the following ErrorCode:

Value | Meaning
Illegal | The specified printer station is invalid: it can only be set to Receipt, Slip, or None. Or, the specified printer station does not exist for the printer.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.PageModeVerticalPosition Property

PosPrinter.PageModeVerticalPosition Property |
 | See Also

1/18/2008

Gets or sets the vertical start position offset within the print area for the print station specified by the PageModeStation property, expressed in the unit of measure specified by the MapMode property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Property PageModeVerticalPosition As Integer
public virtual int PageModeVerticalPosition { get; set; }
public:
virtual property int PageModeVerticalPosition {
    int get ();
    void set (int value);
}
/** @property */
public int get_PageModeVerticalPosition ()

/** @property */
public void set_PageModeVerticalPosition (int value)

public function get PageModeVerticalPosition () : int

public function set PageModeVerticalPosition (value : int)

Remarks

The vertical position is defined as perpendicular to the direction specified by the PageModePrintDirection property. If the exact specified position cannot be supported, the service object will set the position to the closest supported value.

Note:
Retrieving the value of PageModeVerticalPosition returns the vertical position offset specified by the last setting of this property and not the current position.

If PageModeStation property is set to an invalid value, PageModeVerticalPosition will be set to zero (0).

Setting PageModeVerticalPosition may throw a PosControlException with the following errorcode:

Value | Meaning
Illegal | The specified value is either less than zero or a greater than the current page height minus 1.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace


PosPrinter.RecBarCodeRotationList Property

PosPrinter.RecBarCodeRotationList Property |
 | See Also

1/18/2008

Gets a list of the directions in which a receipt bar code can be rotated.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property RecBarCodeRotationList As Rotation()
public abstract Rotation[] RecBarCodeRotationList { get; }
public:
virtual property array<Rotation>^ RecBarCodeRotationList {
    array<Rotation>^ get () abstract;
}
/** @property */
public abstract Rotation[] get_RecBarCodeRotationList ()

public abstract function get RecBarCodeRotationList () : Rotation[]

Remarks

Possible values are defined by the Rotation enumeration.

If the CapRecBarCode property is set to false. This indicates that bar codes are not supported, RecBarCodeRotationList is set to an empty array.

For example, if the list is "Normal, Rotate180", the printer can print normal bar codes and upside-down bar codes.

The service object should set RecBarCodeRotationList based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
RotateSpecial
PosPrinter.PrintBarCode Method


PosPrinter.RecBitmapRotationList Property

PosPrinter.RecBitmapRotationList Property |
 | See Also

1/18/2008

Gets a list of the directions in which a receipt bitmap can be rotated.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property RecBitmapRotationList As Rotation()
public abstract Rotation[] RecBitmapRotationList { get; }
public:
virtual property array<Rotation>^ RecBitmapRotationList {
    array<Rotation>^ get () abstract;
}
/** @property */
public abstract Rotation[] get_RecBitmapRotationList ()

public abstract function get RecBitmapRotationList () : Rotation[]

Remarks

Possible values are defined by the Rotation enumeration.

If the CapRecBitmap property is set to false. This indicates that bar codes are not supported, RecBitmapRotationList will be set to an empty array.

For example, if the list is "Normal, Rotate180", the printer can print normal bar codes and upside-down bar codes.

The service object should set RecBitmapRotationList based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
RotateSpecial
PosPrinter.PrintBitmap Method


PosPrinter.RecCartridgeState Property

PosPrinter.RecCartridgeState Property |
 | See Also

1/18/2008

Gets the status of the selected receipt cartridge (ink, ribbon or toner).

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property RecCartridgeState As PrinterCartridgeStates
public abstract PrinterCartridgeStates RecCartridgeState { get; }
public:
virtual property PrinterCartridgeStates RecCartridgeState {
    PrinterCartridgeStates get () abstract;
}
/** @property */
public abstract PrinterCartridgeStates get_RecCartridgeState ()

public abstract function get RecCartridgeState () : PrinterCartridgeStates

Remarks

Possible values are defined by the PrinterCartridgeStates enumeration.

Values, listed in order of priority level, are as follows:

Value

Meaning

Unknown

Cannot determine the cartridge state, for one of the following reasons:

  • The CapRecCartridgeSensor property is set to PrinterCartridgeSensors.None. The Printer device does not support cartridge state reporting.

  • The CartridgeNotify property is set to PrinterCartridgeNotify.Disabled. Cartridge-state notifications are disabled.

  • The DeviceEnabled property is set to false. Cartridge-state monitoring does not occur until the device is enabled.

Removed

The cartridge specified by the RecCurrentCartridge property has been removed.

Empty

The cartridge specified by the RecCurrentCartridge property is empty.

Cleaning

The head specified by the RecCurrentCartridge property is being cleaned.

NearEnd

The cartridge specified by the RecCurrentCartridge property is near its end.

OK

The cartridge specified by the RecCurrentCartridge property is in normal condition.
Note:
These values are listed according to their priority order. The service object should set them in priority order also.

When RecCartridgeState is set to any value other than Unknown, POS for .NET queues a StatusUpdateEvent event, notifying the application of the change.

RecCartridgeState is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
RecCurrentCartridge
PosPrinter.CapRecCartridgeSensor Property
PosPrinter.CartridgeNotify Property
PrinterCartridgeStates


PosPrinter.RecCurrentCartridge Property

PosPrinter.RecCurrentCartridge Property |
 | See Also

1/18/2008

Gets or sets the receipt cartridge selected by the application.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property RecCurrentCartridge As PrinterColors
public abstract PrinterColors RecCurrentCartridge { get; set; }
public:
virtual property PrinterColors RecCurrentCartridge {
    PrinterColors get () abstract;
    void set (PrinterColors value) abstract;
}
/** @property */
public abstract PrinterColors get_RecCurrentCartridge ()

/** @property */
public abstract void set_RecCurrentCartridge (PrinterColors value)

public abstract function get RecCurrentCartridge () : PrinterColors

public abstract function set RecCurrentCartridge (value : PrinterColors)

Remarks

Possible values are defined by the PrinterColors enumeration.

RecCurrentCartridge is set when the device is first enabled following the Open method.

The value of RecCurrentCartridge is must be one of the color cartridges specified by the CapRecColor property. (RecCurrentCartridge cannot be set to PrinterColors.Full.)

Setting RecCurrentCartridge may also update the RecCartridgeState property.

Accessing RecCurrentCartridge may cause a PosControlException to be thrown with the following ErrorCode:

Value

Meaning

Illegal

One or more of the following conditions has occurred:

  • The CapRecPresent property is set to false. This indicates that there is no receipt station on this printer. In this case, RecCurrentCartridge should be set to PrinterColors.None;

  • RecCurrentCartridge was set to PrinterColors.None. However, the CapRecPresent property is set to true. This indicates that a receipt station is present;

  • RecCurrentCartridge was either set to a value not found in the PrinterColors enumeration or set to PrinterColors.Full. Both are invalid;

  • RecCurrentCartridge was set to a value not listed for the CapRecColor property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.RecCartridgeState Property
PrinterColors


PosPrinter.RecEmpty Property

PosPrinter.RecEmpty Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the receipt is out of paper.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property RecEmpty As Boolean
public abstract bool RecEmpty { get; }
public:
virtual property bool RecEmpty {
    bool get () abstract;
}
/** @property */
public abstract boolean get_RecEmpty ()

public abstract function get RecEmpty () : boolean

Remarks

If true, the receipt is out of paper. If the CapRecEmptySensor property is set to false, the value of RecEmpty is always set to false.

When RecEmpty is set to true by the service object, the service object queues a StatusUpdateEvent event by using the StatusReceiptEmpty constant, notifying the application of the condition. When the service object resets RecEmpty to false. This indicates that the condition has been resolved, it queues a second StatusUpdateEvent event by using the StatusReceiptPaperOK constant, notifying the application of the resolution.

RecEmpty is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.CapRecEmptySensor Property
RecNearEnd


PosPrinter.RecLetterQuality Property

PosPrinter.RecLetterQuality Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer prints in high-quality mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property RecLetterQuality As Boolean
public abstract bool RecLetterQuality { get; set; }
public:
virtual property bool RecLetterQuality {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_RecLetterQuality ()

/** @property */
public abstract void set_RecLetterQuality (boolean value)

public abstract function get RecLetterQuality () : boolean

public abstract function set RecLetterQuality (value : boolean)

Remarks

If true, prints in high-quality mode. If false, prints in high-speed mode.

The application sets RecLetterQuality to advise the service object that either high-quality or high-speed printing is desired.

For example:

  • Printers with bidirectional print capability can be put in unidirectional mode for high quality so that column alignment is more precise.

  • Bitmaps can be printed in a high-density graphics mode for high quality, and in a low-density mode for high speed.

Setting RecLetterQuality may also cause the service object to update the RecLineWidth, RecLineHeight, and RecLineSpacing properties, if the MapMode property is set to MapMode.Dots. (See the note under MapMode property.)

RecLetterQuality is set when the device is first enabled following the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
RecLineWidth
RecLineHeight
RecLineSpacing
PosPrinter.MapMode Property


PosPrinter.RecLineChars Property

PosPrinter.RecLineChars Property |
 | See Also

1/18/2008

Gets or sets the number of characters that the application wants to print on a receipt line.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property RecLineChars As Integer
public abstract int RecLineChars { get; set; }
public:
virtual property int RecLineChars {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_RecLineChars ()

/** @property */
public abstract void set_RecLineChars (int value)

public abstract function get RecLineChars () : int

public abstract function set RecLineChars (value : int)

Remarks

If the specified number of characters per line can be supported, the service object sets the line width to the specified value. If the exact width cannot be supported and the value is less than the maximum value allowed for the printer, later lines will be printed with the number that most closely supports the specified characters per line. (For example, if RecLineChars is set to 36 and the printer can print either 30 or 40 characters per line, the service object should select the line width of 40 and print up to 36 characters on each line.)

If the specified line width cannot be supported and the value is greater than the maximum value allowed for the printer, then an error is returned. (For example, if RecLineChars is set to 42 and the printer can print either 30 or 40 characters per line, the service object cannot support the request.)

Setting RecLineChars may also update the RecLineWidth, RecLineHeight, and RecLineSpacing properties, because the character pitch or font may be changed.

The service object sets RecLineChars to the printer’s default line width when the device is first enabled following the Open method.

Accessing RecLineChars may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The specified number of characters is greater than the maximum allowed for the printer.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
RecLineWidth
RecLineHeight
RecLineSpacing
RecLineCharsList


PosPrinter.RecLineCharsList Property

PosPrinter.RecLineCharsList Property |
 | See Also

1/18/2008

Gets a collection of the line widths (characters per line) supported by the receipt station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property RecLineCharsList As Integer()
public abstract int[] RecLineCharsList { get; }
public:
virtual property array<int>^ RecLineCharsList {
    array<int>^ get () abstract;
}
/** @property */
public abstract int[] get_RecLineCharsList ()

public abstract function get RecLineCharsList () : int[]

Remarks

The array consists of ASCII numeric set numbers. For example, if the array is "32,36,40", the station supports line widths of 32, 36, and 40 characters.

The service object should set RecLineCharsList based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.RecLineChars Property


PosPrinter.RecLineHeight Property

PosPrinter.RecLineHeight Property |
 | See Also

1/18/2008

Gets or sets the receipt print line height, expressed in the unit of measure indicated by the MapMode property setting, that the application wants to use.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property RecLineHeight As Integer
public abstract int RecLineHeight { get; set; }
public:
virtual property int RecLineHeight {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_RecLineHeight ()

/** @property */
public abstract void set_RecLineHeight (int value)

public abstract function get RecLineHeight () : int

public abstract function set RecLineHeight (value : int)

Remarks

If the specified line height can be supported with the current character width, the service object sets line height to this value. If the exact height cannot be supported, the height is set to the closest supported value.

When the RecLineChars property is changed, RecLineHeight is updated to the default line height for the selected width.

The service object sets RecLineHeight to the printer’s default line height when the device is first enabled following the Open method.

Accessing RecLineHeight may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The number of characters specified is less than 0 (zero).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.RecLineChars Property


PosPrinter.RecLineSpacing Property

PosPrinter.RecLineSpacing Property |
 | See Also

1/18/2008

Gets or sets the spacing of each single-high print line. This includes both the printed line height and the white space between each pair of lines, that the application wants to use.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property RecLineSpacing As Integer
public abstract int RecLineSpacing { get; set; }
public:
virtual property int RecLineSpacing {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_RecLineSpacing ()

/** @property */
public abstract void set_RecLineSpacing (int value)

public abstract function get RecLineSpacing () : int

public abstract function set RecLineSpacing (value : int)

Remarks

Depending on the printer and the current line spacing, a multi-high print line might exceed this value. Line spacing is expressed in the unit of measure indicated by the MapMode property setting.

If the specified spacing can be supported by the printer, the service object will set line spacing to this value. If the spacing cannot be supported, the spacing is set to the closest supported value.

When the RecLineChars or RecLineHeight properties are changed, RecLineSpacing is updated to the default line spacing for the selected width or height.

The service object sets RecLineSpacing to the printer’s default line spacing when the device is first enabled following the Open method.

Accessing RecLineSpacing may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The number of characters specified is less than 0 (zero).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.RecLineHeight Property
PosPrinter.RecLineChars Property
PosPrinter.MapMode Property


PosPrinter.RecLinesToPaperCut Property

PosPrinter.RecLinesToPaperCut Property |
 | See Also

1/18/2008

Gets the number of lines that must be advanced before cutting the receipt paper.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property RecLinesToPaperCut As Integer
public abstract int RecLinesToPaperCut { get; }
public:
virtual property int RecLinesToPaperCut {
    int get () abstract;
}
/** @property */
public abstract int get_RecLinesToPaperCut ()

public abstract function get RecLinesToPaperCut () : int

Remarks

If the CapRecPapercut property is set to true, the value of RecLinesToPaperCut is the line count before reaching the paper cut mechanism. Otherwise, it is the line count before the manual tear-off bar.

Changing the RecLineChars, RecLineHeight, and RecLineSpacing properties may change RecLinesToPaperCut.

The service object should set RecLinesToPaperCut based on the specifications of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.RecLineHeight Property
PosPrinter.RecLineChars Property
PosPrinter.RecLineSpacing Property
PosPrinter.CapRecPaperCut Property


PosPrinter.RecLineWidth Property

PosPrinter.RecLineWidth Property |
 | See Also

1/18/2008

Gets the width of a line, based on the number of characters specified in the RecLineChars property, expressed in the unit of measure indicated by the MapMode property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property RecLineWidth As Integer
public abstract int RecLineWidth { get; }
public:
virtual property int RecLineWidth {
    int get () abstract;
}
/** @property */
public abstract int get_RecLineWidth ()

public abstract function get RecLineWidth () : int

Remarks

Setting RecLineChars may also update the RecLineWidth property.

The service object sets RecLineWidth to the printer’s default line width when the device is first enabled following the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.RecLineChars Property
PosPrinter.MapMode Property


PosPrinter.RecNearEnd Property

PosPrinter.RecNearEnd Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the receipt paper is low.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property RecNearEnd As Boolean
public abstract bool RecNearEnd { get; }
public:
virtual property bool RecNearEnd {
    bool get () abstract;
}
/** @property */
public abstract boolean get_RecNearEnd ()

public abstract function get RecNearEnd () : boolean

Remarks

If true, the receipt paper is low. If the CapRecNearEndSensor property is set to false, the value of RecNearEnd is always set to false.

When RecNearEnd is set to true by the service object, POS for .NET queues a StatusUpdateEvent event, notifying the application of the condition. When the service object resets RecNearEnd to false, POS for .NET queues a StatusUpdateEvent event notifying the application of the resolved condition.

RecNearEnd is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.CapRecNearEndSensor Property
PosPrinter.RecEmpty Property


PosPrinter.RecSidewaysMaxChars Property

PosPrinter.RecSidewaysMaxChars Property |
 | See Also

1/18/2008

Gets the maximum number of characters that can be printed on each line in sideways mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property RecSidewaysMaxChars As Integer
public abstract int RecSidewaysMaxChars { get; }
public:
virtual property int RecSidewaysMaxChars {
    int get () abstract;
}
/** @property */
public abstract int get_RecSidewaysMaxChars ()

public abstract function get RecSidewaysMaxChars () : int

Remarks

If the CapRecLeft90 and CapRecRight90 properties are both set to false, RecSidewaysMaxChars is always set to zero.

Changing the RecLineHeight, RecLineSpacing, and RecLineChars properties may change RecSidewaysMaxChars.

The service object should set RecSidewaysMaxChars based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.CapRecLeft90 Property
PosPrinter.CapRecRight90 Property
PosPrinter.RecSidewaysMaxChars Property
PosPrinter.RecLineHeight Property
PosPrinter.RecLineSpacing Property
PosPrinter.RecLineChars Property


PosPrinter.RecSidewaysMaxLines Property

PosPrinter.RecSidewaysMaxLines Property |
 | See Also

1/18/2008

Gets the maximum number of lines that can be printed in sideways mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property RecSidewaysMaxLines As Integer
public abstract int RecSidewaysMaxLines { get; }
public:
virtual property int RecSidewaysMaxLines {
    int get () abstract;
}
/** @property */
public abstract int get_RecSidewaysMaxLines ()

public abstract function get RecSidewaysMaxLines () : int

Remarks

If the CapRecLeft90 and CapRecRight90 properties are both set to false, RecSidewaysMaxLines is always set to zero.

Changing the RecLineHeight, RecLineSpacing, and RecLineChars properties may change RecSidewaysMaxLines.

The service object should set RecSidewaysMaxLines based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.CapRecLeft90 Property
PosPrinter.CapRecRight90 Property
PosPrinter.RecSidewaysMaxLines Property
PosPrinter.RecLineHeight Property
PosPrinter.RecLineSpacing Property
PosPrinter.RecLineChars Property


PosPrinter.RotateSpecial Property

PosPrinter.RotateSpecial Property |
 | See Also

1/18/2008

Gets or sets the rotation orientation for bar codes that the application wants to use.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property RotateSpecial As Rotation
public abstract Rotation RotateSpecial { get; set; }
public:
virtual property Rotation RotateSpecial {
    Rotation get () abstract;
    void set (Rotation value) abstract;
}
/** @property */
public abstract Rotation get_RotateSpecial ()

/** @property */
public abstract void set_RotateSpecial (Rotation value)

public abstract function get RotateSpecial () : Rotation

public abstract function set RotateSpecial (value : Rotation)

Remarks

Possible values are defined by the Rotation enumeration.

Accessing RotateSpecial may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The specified rotation orientation is not valid—that is, it does not exist in the Rotation enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.PrintBarCode Method
Rotation


PosPrinter.SlpBarCodeRotationList Property

PosPrinter.SlpBarCodeRotationList Property |
 | See Also

1/18/2008

Gets a collection of the directions in which a slip bar code may be rotated.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property SlpBarCodeRotationList As Rotation()
public abstract Rotation[] SlpBarCodeRotationList { get; }
public:
virtual property array<Rotation>^ SlpBarCodeRotationList {
    array<Rotation>^ get () abstract;
}
/** @property */
public abstract Rotation[] get_SlpBarCodeRotationList ()

public abstract function get SlpBarCodeRotationList () : Rotation[]

Remarks

Possible values are defined by the Rotation enumeration.

If the CapSlpBarCode property is set to false. This indicates that bar codes are not supported, SlpBarCodeRotationList will be set to an empty array.

For example, if the list is "Rotation.Normal, Rotation.Rotate180", the printer can print normal bar codes and upside-down bar codes.

The service object should set SlpBarCodeRotationList based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.RotateSpecial Property
PosPrinter.PrintBarCode Method
Rotation


PosPrinter.SlpBitmapRotationList Property

PosPrinter.SlpBitmapRotationList Property |
 | See Also

1/18/2008

Gets a collection of the directions in which a slip bitmap can be rotated.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property SlpBitmapRotationList As Rotation()
public abstract Rotation[] SlpBitmapRotationList { get; }
public:
virtual property array<Rotation>^ SlpBitmapRotationList {
    array<Rotation>^ get () abstract;
}
/** @property */
public abstract Rotation[] get_SlpBitmapRotationList ()

public abstract function get SlpBitmapRotationList () : Rotation[]

Remarks

Possible values are defined by the Rotation enumeration.

If the CapSlpBitmap property is set to false. This indicates that bar codes are not supported, SlpBitmapRotationList will be set to an empty array.

For example, if the list is "Rotation.Normal, Rotation.Rotate180", the printer can print normal bitmaps and upside-down bitmaps.

The service object should set SlpBitmapRotationList based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.RotateSpecial Property
PosPrinter.PrintBitmap Method
Rotation


PosPrinter.SlpCartridgeState Property

PosPrinter.SlpCartridgeState Property |
 | See Also

1/18/2008

Gets the status of the selected slip cartridge (ink, ribbon, or toner).

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property SlpCartridgeState As PrinterCartridgeStates
public abstract PrinterCartridgeStates SlpCartridgeState { get; }
public:
virtual property PrinterCartridgeStates SlpCartridgeState {
    PrinterCartridgeStates get () abstract;
}
/** @property */
public abstract PrinterCartridgeStates get_SlpCartridgeState ()

public abstract function get SlpCartridgeState () : PrinterCartridgeStates

Remarks

Possible values are defined by the PrinterCartridgeStates enumeration.

Values, listed in order of priority level, are as follows:

Value

Meaning

Unknown

Cannot determine the cartridge state, for one of the following reasons:

  • The CapSlpCartridgeSensor property is set to PrinterCartridgeSensors.None. The device does not support cartridge state reporting.

  • The CartridgeNotify property is set to PrinterCartridgeNotify.Disabled. Cartridge state notifications are disabled.

  • The DeviceEnabled property is set to false. Cartridge state monitoring does not occur until the device is enabled.

Removed

The cartridge specified by the SlpCurrentCartridge property has been removed.

Empty

The cartridge specified by the SlpCurrentCartridge property is empty.

Cleaning

The head specified by the SlpCurrentCartridge property is being cleaned.

NearEnd

The cartridge specified by the SlpCurrentCartridge property is near its end.

OK

The cartridge specified by the SlpCurrentCartridge property is in normal condition.
Note:
These values are listed in priority order. The service object should set them in priority order also.

When SlpCartridgeState is set to any value other than PrinterCartridgeStates.Unknown, the service object queues a StatusUpdateEvent event by using the StatusSlip range of constants, notifying the application of the change.

SlpCartridgeState is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
SlpCurrentCartridge
PosPrinter.CapSlpCartridgeSensor Property
PosPrinter.CartridgeNotify Property
PosCommon.DeviceEnabled Property


PosPrinter.SlpCurrentCartridge Property

PosPrinter.SlpCurrentCartridge Property |
 | See Also

1/18/2008

Gets or sets the slip cartridge the application wants to use.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property SlpCurrentCartridge As PrinterColors
public abstract PrinterColors SlpCurrentCartridge { get; set; }
public:
virtual property PrinterColors SlpCurrentCartridge {
    PrinterColors get () abstract;
    void set (PrinterColors value) abstract;
}
/** @property */
public abstract PrinterColors get_SlpCurrentCartridge ()

/** @property */
public abstract void set_SlpCurrentCartridge (PrinterColors value)

public abstract function get SlpCurrentCartridge () : PrinterColors

public abstract function set SlpCurrentCartridge (value : PrinterColors)

Remarks

Possible values are defined by the PrinterColors enumeration.

The value of SlpCurrentCartridge is must be one of the color cartridges specified by the CapSlpColor property. (It cannot be set to PrinterColors.Full.)

Setting SlpCurrentCartridge may also update the SlpCartridgeState property.

Accessing SlpCurrentCartridge may cause a PosControlException to be thrown with the following ErrorCode:

Value

Meaning

Illegal

One or more of the following conditions has occurred:

  • The CapSlpPresent property is set to false. This indicates that there is no slip station on this printer. In this case, SlpCurrentCartridge should be set to PrinterColors.None.

  • SlpCurrentCartridge was set to PrinterColors.None. However, the CapSlpPresent property is set to true. This indicates that a slip station is present.

  • SlpCurrentCartridge was either set to a value not found in the PrinterColors enumeration or set to PrinterColors.Full. Both are invalid.

  • SlpCurrentCartridge was set to a value not listed for the CapSlpColor property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.CapSlpColor Property
PosPrinter.SlpCartridgeState Property
PrinterColors


PosPrinter.SlpEmpty Property

PosPrinter.SlpEmpty Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether a slip form is not present.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property SlpEmpty As Boolean
public abstract bool SlpEmpty { get; }
public:
virtual property bool SlpEmpty {
    bool get () abstract;
}
/** @property */
public abstract boolean get_SlpEmpty ()

public abstract function get SlpEmpty () : boolean

Remarks

If true, a slip form is not present. If the CapSlpEmptySensor property is set to false, the value of SlpEmpty is always set to false.

When SlpEmpty is set to true by the service object, it also queues a StatusUpdateEvent event by using the StatusSlipEmpty constant, notifying the application of the condition. When the service object resets SlpEmpty to FALSE. This indicates that the condition has been resolved, it queues a second StatusUpdateEvent event by using the StatusSlipOK constant, notifying the application of the resolution.

SlpEmpty is set and kept current by the service object while the device is enabled.

Note:
The "slip empty" sensor should be primarily used to determine whether a form has been inserted before printing. It can be monitored to determine whether a form is still available. This sensor is usually put one or more print lines above the slip print head. However, the "slip near end" sensor (when present) should be used to determine when nearing the end of the slip. This sensor is usually put one or more print lines below the slip print head.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.CapSlpEmptySensor Property
SlpNearEnd


PosPrinter.SlpLetterQuality Property

PosPrinter.SlpLetterQuality Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether the printer prints in high-quality mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property SlpLetterQuality As Boolean
public abstract bool SlpLetterQuality { get; set; }
public:
virtual property bool SlpLetterQuality {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_SlpLetterQuality ()

/** @property */
public abstract void set_SlpLetterQuality (boolean value)

public abstract function get SlpLetterQuality () : boolean

public abstract function set SlpLetterQuality (value : boolean)

Remarks

If true, prints in high-quality mode. If false, prints in high-speed mode.

The application sets SlpLetterQuality to advise the service object that either high-quality or high-speed printing is desired.

For example:

  • Printers with bidirectional print capability can be put in unidirectional mode for high quality so that column alignment is more precise.

  • Bitmaps may be printed in a high-density graphics mode for high quality, and in a low-density mode for high speed.

Setting SlpLetterQuality may also cause the service object to update the SlpLineWidth, SlpLineHeight, and SlpLineSpacing properties if the MapMode property is set to MapMode.Dots. (See the note in PosPrinter.MapMode.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
SlpLineWidth
SlpLineHeight
SlpLineSpacing
PosPrinter.MapMode Property


PosPrinter.SlpLineChars Property

PosPrinter.SlpLineChars Property |
 | See Also

1/18/2008

Gets or sets the number of characters that the application wants to print on a slip line.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property SlpLineChars As Integer
public abstract int SlpLineChars { get; set; }
public:
virtual property int SlpLineChars {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_SlpLineChars ()

/** @property */
public abstract void set_SlpLineChars (int value)

public abstract function get SlpLineChars () : int

public abstract function set SlpLineChars (value : int)

Remarks

If the specified number of characters per line can be supported, the service object sets the line width to the specified value. If the exact width cannot be supported and the value is less than the maximum value allowed for the printer, later lines will be printed with the number that most closely supports the specified characters per line. (The service object should print the requested characters in the column positions closest to the side of the slip table at which the slip is aligned. For example, if the operator inserts the slip with the right edge against the table side, and if SlpLineChars is set to 36 and the printer prints 60 characters per line, the service object should add 24 spaces at the left margin, and print the characters in columns 25 through 60.)

If the specified line width cannot be supported and the value is greater than the maximum value allowed for the printer, then an error is returned. (For example, if SlpLineChars is set to 42 and the printer can print either 30 or 40 characters per line, the service object cannot support the request.)

Setting SlpLineChars may also update the SlpLineWidth, SlpLineHeight, and SlpLineSpacing properties, because the character pitch or font may be changed.

The service object sets SlpLineChars to the printer’s default line width when the device is first enabled following the Open method.

Accessing SlpLineChars may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The specified number of characters is greater than the maximum allowed for the printer.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.SlpLineChars Property
SlpLineWidth
SlpLineHeight
SlpLineSpacing


PosPrinter.SlpLineCharsList Property

PosPrinter.SlpLineCharsList Property |
 | See Also

1/18/2008

Gets a collection of the line widths (characters per line) supported by the slip station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property SlpLineCharsList As Integer()
public abstract int[] SlpLineCharsList { get; }
public:
virtual property array<int>^ SlpLineCharsList {
    array<int>^ get () abstract;
}
/** @property */
public abstract int[] get_SlpLineCharsList ()

public abstract function get SlpLineCharsList () : int[]

Remarks

The array consists of ASCII numeric set numbers. For example, if the array is "32,36,40," the station supports line widths of 32, 36, and 40 characters.

The service object’s implementation of the Open method should set SlpLineCharsList based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.SlpLineChars Property


PosPrinter.SlpLineHeight Property

PosPrinter.SlpLineHeight Property |
 | See Also

1/18/2008

Gets or sets the slip print-line height, expressed in the unit of measure indicated by the MapMode property setting, that the application wants to use.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property SlpLineHeight As Integer
public abstract int SlpLineHeight { get; set; }
public:
virtual property int SlpLineHeight {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_SlpLineHeight ()

/** @property */
public abstract void set_SlpLineHeight (int value)

public abstract function get SlpLineHeight () : int

public abstract function set SlpLineHeight (value : int)

Remarks

If the specified height can be supported with the current character width, the service object sets the line height to this value. If the exact height cannot be supported, the height is set to the closest supported value.

When the SlpLineChars property is changed, SlpLineHeight is updated to the default line height for the selected width.

The service object sets SlpLineHeight to the printer’s default line height when the device is first enabled following the Open method.

Accessing SlpLineHeight may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The number of characters specified is less than 0 (zero).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.SlpLineChars Property
PosPrinter.MapMode Property


PosPrinter.SlpLinesNearEndToEnd Property

PosPrinter.SlpLinesNearEndToEnd Property |
 | See Also

1/18/2008

Gets the number of lines that can be printed after the SlpNearEnd property has been set to true but before the printer reaches the end of the slip.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property SlpLinesNearEndToEnd As Integer
public abstract int SlpLinesNearEndToEnd { get; }
public:
virtual property int SlpLinesNearEndToEnd {
    int get () abstract;
}
/** @property */
public abstract int get_SlpLinesNearEndToEnd ()

public abstract function get SlpLinesNearEndToEnd () : int

Remarks

Using SlpLinesNearEndToEnd can optimize using the slip by printing the maximum number of lines.

Changing the SlpLineHeight, SlpLineSpacing, or SlpLineChars properties may change SlpLinesNearEndToEnd.

SlpLinesNearEndToEnd is updated by the service object, based on device specifications when the device is first enabled following the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.SlpEmpty Property
SlpNearEnd
PosPrinter.SlpLineHeight Property
SlpLineSpacing
PosPrinter.SlpLineChars Property


PosPrinter.SlpLineSpacing Property

PosPrinter.SlpLineSpacing Property |
 | See Also

1/18/2008

Gets or sets the spacing of each single-high print line. This includes both the printed line height and the white space between each pair of lines that the application wants to use.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property SlpLineSpacing As Integer
public abstract int SlpLineSpacing { get; set; }
public:
virtual property int SlpLineSpacing {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_SlpLineSpacing ()

/** @property */
public abstract void set_SlpLineSpacing (int value)

public abstract function get SlpLineSpacing () : int

public abstract function set SlpLineSpacing (value : int)

Remarks

Depending on the printer and the current line spacing, a multi-high print line might exceed this value. Line spacing is expressed in the unit of measure indicated by the MapMode property setting.

If the specified spacing can be supported by the printer, the service object sets line spacing to this value. If the spacing cannot be supported, the spacing is set to the closest supported value.

When the SlpLineChars or SlpLineHeight properties are changed, SlpLineSpacing is updated to the default line spacing for the selected width or height.

The service object sets SlpLineSpacing to the printer’s default line spacing when the device is first enabled following the Open method.

Accessing SlpLineSpacing may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The number of characters specified is less than 0 (zero).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.SlpLineChars Property
PosPrinter.SlpLineHeight Property
PosPrinter.MapMode Property


PosPrinter.SlpLineWidth Property

PosPrinter.SlpLineWidth Property |
 | See Also

1/18/2008

Gets the line width, based on the number of characters specified for the SlpLineChars property, expressed in the unit of measure indicated by the MapMode property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property SlpLineWidth As Integer
public abstract int SlpLineWidth { get; }
public:
virtual property int SlpLineWidth {
    int get () abstract;
}
/** @property */
public abstract int get_SlpLineWidth ()

public abstract function get SlpLineWidth () : int

Remarks

Setting the SlpLineChars property may also update SlpLineWidth.

The service object sets SlpLineWidth to the printer’s default line width when the device is first enabled following the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.SlpLineChars Property
PosPrinter.MapMode Property


PosPrinter.SlpMaxLines Property

PosPrinter.SlpMaxLines Property |
 | See Also

1/18/2008

Gets the maximum number of lines that can be printed on a form.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property SlpMaxLines As Integer
public abstract int SlpMaxLines { get; }
public:
virtual property int SlpMaxLines {
    int get () abstract;
}
/** @property */
public abstract int get_SlpMaxLines ()

public abstract function get SlpMaxLines () : int

Remarks

When the CapSlpFullslip property is set to true, SlpMaxLines will be zero. This indicates an unlimited maximum slip length. When CapSlpFullslip is false, SlpMaxLines will be nonzero.

Changing the SlpLineHeight, SlpLineSpacing, or SlpLineChars properties may change SlpMaxLines.

The service object sets SlpMaxLines when the device is first enabled following the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.CapSlpFullSlip Property
PosPrinter.SlpLineChars Property
PosPrinter.SlpLineHeight Property
PosPrinter.SlpLineSpacing Property


PosPrinter.SlpNearEnd Property

PosPrinter.SlpNearEnd Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the slip form is near its end.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property SlpNearEnd As Boolean
public abstract bool SlpNearEnd { get; }
public:
virtual property bool SlpNearEnd {
    bool get () abstract;
}
/** @property */
public abstract boolean get_SlpNearEnd ()

public abstract function get SlpNearEnd () : boolean

Remarks

If true, the slip form is near its end. The "near end" sensor is also also known as the "trailing edge" sensor, referring to the bottom edge of the slip.

When SlpNearEnd is set to true by the service object, it queues a StatusUpdateEvent event by using the StatusSlipNearEnd constant, notifying the application of the condition. When the service object resets StatusSlpNearEnd to FALSE. This indicates that the condition has been resolved, it queues a second StatusUpdateEvent event by using the StatusSlipOK constant, notifying the application of the resolution.

If the CapSlpNearEndSensor property is set to false, then SlpNearEnd is always set to FALSE.

SlpNearEnd is set and kept current by the service object while the device is enabled.

Note:
The "slip empty" sensor should be primarily used to determine whether a form has been inserted before printing. It can be monitored to determine whether a form is still available. This sensor is usually put one or more print lines above the slip print head. However, the "slip near end" sensor (when present) should be used to determine when nearing the end of the slip. This sensor is usually put one or more print lines below the slip print head.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.CapSlpNearEndSensor Property
PosPrinter.SlpEmpty Property
PosPrinter.SlpLinesNearEndToEnd Property


PosPrinter.SlpPrintSide Property

PosPrinter.SlpPrintSide Property |
 | See Also

1/18/2008

Gets the side of the slip print station document on which printing will occur.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property SlpPrintSide As PrinterSide
public abstract PrinterSide SlpPrintSide { get; }
public:
virtual property PrinterSide SlpPrintSide {
    PrinterSide get () abstract;
}
/** @property */
public abstract PrinterSide get_SlpPrintSide ()

public abstract function get SlpPrintSide () : PrinterSide

Remarks

Possible values are defined by the PrinterSide enumeration. (SlpPrintSide cannot be set to PrinterSide.Opposite).

If the slip print station is not selected, SlpPrintSide is set to PrinterSide.Unknown.

If a printer can print on both sides, the CapSlpBothSidesPrint property is set to true. When the slip is inserted, SlpPrintSide will be either PrinterSide.Side1 or PrinterSide.Side2. SlpPrintSide may be changed when the ChangePrintSide method is executed.

If a printer cannot print on both sides, the CapSlpBothSidesPrint property is set to false. When a slip is inserted, SlpPrintSide is always set to PrinterSide.Side1.

If a printer can print on both sides, SlpPrintSide is PrinterSide.Side1 after the Begin/EndInsertion methods are executed. However, after the Begin/EndInsertion methods of MICR are executed, the value of SlpPrintSide is not limited to PrinterSide.Side1. In this case, SlpPrintSide indicates the validation print side.

SlpPrintSide is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.CapSlpBothSidesPrint Property
PosPrinter.BeginInsertion Method
PosPrinter.EndInsertion Method
PosPrinter.ChangePrintSide Method
PrinterSide


PosPrinter.SlpSidewaysMaxChars Property

PosPrinter.SlpSidewaysMaxChars Property |
 | See Also

1/18/2008

Gets the maximum number of characters that can be printed on each line in sideways mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property SlpSidewaysMaxChars As Integer
public abstract int SlpSidewaysMaxChars { get; }
public:
virtual property int SlpSidewaysMaxChars {
    int get () abstract;
}
/** @property */
public abstract int get_SlpSidewaysMaxChars ()

public abstract function get SlpSidewaysMaxChars () : int

Remarks

If the CapSlpLeft90 and CapSlpRight90 properties are both set to false. Then SlpSidewaysMaxChars is always set to 0 (zero).

Changing the SlpLineHeight, SlpLineSpacing, and SlpLineChars properties may change SlpSidewaysMaxChars.

SlpSidewaysMaxChars is updated by the service object to the capability of the Printer device when the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.CapSlpLeft90 Property
PosPrinter.CapSlpRight90 Property
PosPrinter.SlpLineHeight Property
PosPrinter.SlpLineSpacing Property
PosPrinter.SlpLineChars Property
PosPrinter.MapMode Property


PosPrinter.SlpSidewaysMaxLines Property

PosPrinter.SlpSidewaysMaxLines Property |
 | See Also

1/18/2008

Gets the maximum number of lines that can be printed in sideways mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property SlpSidewaysMaxLines As Integer
public abstract int SlpSidewaysMaxLines { get; }
public:
virtual property int SlpSidewaysMaxLines {
    int get () abstract;
}
/** @property */
public abstract int get_SlpSidewaysMaxLines ()

public abstract function get SlpSidewaysMaxLines () : int

Remarks

If the CapSlpLeft90 and CapSlpRight90 properties are both set to false, SlpSidewaysMaxLines is zero.

Changing the SlpLineHeight, SlpLineSpacing, and SlpLineChars properties may change SlpSidewaysMaxLines.

The service object should set SlpSidewaysMaxLines based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.SlpSidewaysMaxChars Property


PosPrinter Events

PosPrinter Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
ErrorEvent | Queued by the service object when an error is detected and the device’s State transitions into the error state.
OutputCompleteEvent | Queued by the service object to notify the application when asynchronous processing that corresponds to an OutputID has successfully completed.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

PosPrinter Class
Microsoft.PointOfService Namespace


PosPrinter.ErrorEvent Event

PosPrinter.ErrorEvent Event |
 | See Also

1/18/2008

Queued by the service object when an error is detected and the device’s State transitions into the error state.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event ErrorEvent As DeviceErrorEventHandler
public abstract event DeviceErrorEventHandler ErrorEvent
public:
virtual event DeviceErrorEventHandler^ ErrorEvent {
    void add (DeviceErrorEventHandler^ value) abstract;
    void remove (DeviceErrorEventHandler^ value) abstract;
}
/** @event */
public abstract void add_ErrorEvent (DeviceErrorEventHandler value)

/** @event */
public abstract void remove_ErrorEvent (DeviceErrorEventHandler value)

Remarks

If DeviceErrorEventArgs.ErrorCode is Extended, DeviceErrorEventArgs.ErrorCodeExtended is set to one of the following values:

Value | Meaning
ExtendedErrorCoverOpen | The printer cover is open.
ExtendedErrorJrnEmpty | The journal station is out of paper.
ExtendedErrorRecEmpty | The receipt station is out of paper.
ExtendedErrorSlpEmpty | A form is not inserted in the slip station.
ExtendedErrorCartridgeRemoved | The journal station cartridge is not present.
ExtendedErrorJrnCartridgeEmpty | The journal cartridge is empty.
ExtendedErrorJrnHeadCleaning | The journal station head is being cleaned.
ExtendedErrorRecCartridgeRemoved | The receipt station cartridge is not present.
ExtendedErrorRecCartridgeEmpty | The receipt cartridge is empty.
ExtendedErrorRecHeadCleaning | The receipt station head is being cleaned.
ExtendedErrorSlpCartridgeRemoved | The slip station cartridge is not present.
ExtendedErrorSlpCartridgeEmpty | The slip cartridge is empty.
ExtendedErrorSlpHeadCleaning | The slip station head is being cleaned.

The DeviceErrorEventArgs.ErrorResponse property is preset to ErrorResponse.Retry. The application may set the value to one of the following:

Value | Meaning
ErrorResponse.Retry | Retry the asynchronous output. The error state is exited.
ErrorResponse.Clear | Clear the asynchronous output. The error state is exited.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
DeviceErrorEventArgs Class
ErrorResponse Enumeration


PosPrinter.OutputCompleteEvent Event

PosPrinter.OutputCompleteEvent Event |
 | See Also

1/18/2008

Queued by the service object to notify the application when asynchronous processing that corresponds to an OutputID has successfully completed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event OutputCompleteEvent As OutputCompleteEventHandler
public abstract event OutputCompleteEventHandler OutputCompleteEvent
public:
virtual event OutputCompleteEventHandler^ OutputCompleteEvent {
    void add (OutputCompleteEventHandler^ value) abstract;
    void remove (OutputCompleteEventHandler^ value) abstract;
}
/** @event */
public abstract void add_OutputCompleteEvent (OutputCompleteEventHandler value)

/** @event */
public abstract void remove_OutputCompleteEvent (OutputCompleteEventHandler value)

Remarks

Typically, the application will call a method, such as PrintNormal, to start asynchronous output processing. The service object holds the request in program memory to be delivered to the printer as soon as the printer can receive and process it. In the interim, the service object updates the PosPrinter.OutputID property that uses the identifier for the output request, then returns control from the method to the application. When the printer completes processing of the output request, the service object queues an OutputCompleteEvent event to the application. This includes the OutputID value in the OutputCompleteEventArgs.OutputID property.

If the application exits the output request before it completes—for example, by calling the ClearOutput method or responding to an ErrorEvent event with a Clear instruction, then the service object will not queue an OutputCompleteEvent event.

Note:
Asynchronous output is always performed on a first-in, first-out basis.

See Also

Reference

PosPrinter Class
PosPrinter Members
Microsoft.PointOfService Namespace
PosPrinter.OutputId Property
OutputCompleteEventHandler Delegate
PosPrinter.ErrorEvent Event


PowerNotification Enumeration

PowerNotification Enumeration |
 | See Also

1/18/2008

Enumerates the possible states of power notification for the current device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration PowerNotification
public enum PowerNotification
public enum class PowerNotification
public enum PowerNotification
public enum PowerNotification

Members

Member name | Description
Disabled | The service object will not provide power notifications to the application. No power notification StatusUpdateEvent events will be raised, and the PowerState property may not be set.
Enabled | The service object will raise power notification StatusUpdateEvent events and update the PowerState property, beginning when the DeviceEnabled property is set to true. The level of functionality available depends on the value of the CapPowerReporting property.

Remarks

Used by the PowerNotify property. Members of this enumeration replace the PN_DISABLED and PN_ENABLED UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
PosCommon.PowerNotify Property


PowerReporting Enumeration

PowerReporting Enumeration |
 | See Also

1/18/2008

Enumerates the possible power reporting capabilities of a device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration PowerReporting
public enum PowerReporting
public enum class PowerReporting
public enum PowerReporting
public enum PowerReporting

Members

Member name | Description
Advanced | The service object can determine and report all three power states, Off, Offline, and Online.
None | The service object cannot determine the state of the device. Therefore, no power reporting is possible.
Standard | The service object can determine and report two of the power states, OffOffline (that is, Off or Offline) and Online.

Remarks

Used by the CapPowerReporting property. Members of this enumeration replace the PR_NONE, PR_STANDARD, and PR_ADVANCED UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
PosCommon.CapPowerReporting Property


PowerSource Enumeration

PowerSource Enumeration |
 | See Also

1/18/2008

Enumerates possible current power sources for a device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration PowerSource
public enum PowerSource
public enum class PowerSource
public enum PowerSource
public enum PowerSource

Members

Member name | Description
AC | The current power source is the AC line.
Backup | The current power source is a backup source such as an UPS or backup battery.
Battery | The current power source is a system battery. This value is only presented for systems that operate typically on battery.
NotAvailable | Power source reporting is not available.

Remarks

Used by the PowerSource property of the PosPower class to report on the current power source of the device, or to report that power source reporting is not available for that device.

See Also

Reference

Microsoft.PointOfService Namespace


PowerState Enumeration

PowerState Enumeration |
 | See Also

1/18/2008

Enumerates the possible current power state values for a device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration PowerState
public enum PowerState
public enum class PowerState
public enum PowerState
public enum PowerState

Members

Member name | Description
Off | The device is turned off or detached from the terminal.
Offline | The device is turned on but is either not ready or unable to respond to requests.
OffOffline | The device is either turned off or offline.
Online | The device is turned on and ready for use.
Unknown | Cannot determine the device's power state.

Remarks

Used by the PowerState property. Members of this enumeration replace the PS_UNKNOWN, PS_ONLINE, PS_OFF, PS_OFFLINE, and PS_OFF_OFFLINE UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
PosCommon.PowerState Property


PrinterCartridgeNotify Enumeration

PrinterCartridgeNotify Enumeration |
 | See Also

1/18/2008

Enumerates the possible cartridge-state notification capabilities for a printer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration PrinterCartridgeNotify
public enum PrinterCartridgeNotify
public enum class PrinterCartridgeNotify
public enum PrinterCartridgeNotify
public enum PrinterCartridgeNotify

Members

Member name | Description
Disabled | Cartridge-state notifications are not available.
Enabled | Cartridge-state notifications are available.

Remarks

Used by the CartridgeNotify property. Members of this enumeration replace the PTR_CN_DISABLED and PTR_CN_ENABLED UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace


PrinterCartridgeSensors Enumeration

PrinterCartridgeSensors Enumeration |
 | See Also

1/18/2008

Enumerates the possible printer-cartridge-monitoring sensors.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration PrinterCartridgeSensors
[FlagsAttribute]
public enum PrinterCartridgeSensors
[FlagsAttribute]
public enum class PrinterCartridgeSensors
/** @attribute FlagsAttribute() */
public enum PrinterCartridgeSensors
FlagsAttribute
public enum PrinterCartridgeSensors

Members

Member name | Description
Cleaning | A sensor that indicates the head is being cleaned.
Empty | A sensor that indicates the cartridge is empty.
NearEnd | A sensor that determines whether the color cartridge is near its end.
None | The device does not support cartridge-monitoring sensors.
Removed | A sensor that indicates the cartridge has been removed.

Remarks

Used by the CapRecCartridgeSensor property. Members of this enumeration replace the PTR_CART_REMOVED, PTR_CART_EMPTY, PTR_CART_NEAREND, and PTR_CART_CLEANING UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace


PrinterCartridgeStates Enumeration

PrinterCartridgeStates Enumeration |
 | See Also

1/18/2008

Enumerates the possible printer cartridge states.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration PrinterCartridgeStates
[FlagsAttribute]
public enum PrinterCartridgeStates
[FlagsAttribute]
public enum class PrinterCartridgeStates
/** @attribute FlagsAttribute() */
public enum PrinterCartridgeStates
FlagsAttribute
public enum PrinterCartridgeStates

Members

Member name | Description
Cleaning | The printer head is being cleaned.
Empty | The cartridge is empty.
NearEnd | The cartridge is near its end.
OK | The cartridge in normal condition.
Removed | The cartridge has been removed.
Unknown | Cannot determine the cartridge state.

Remarks

Used by the JrnCartridgeState, RecCartridgeState, and SlpCartridgeState properties. Members of this enumeration replaces the PTR_CART_UNKNOWN, PTR_CART_REMOVED, PTR_CART_EMPTY, PTR_CART_CLEANING, PTR_CART_NEAREND, and PTR_CART_OK UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace


PrinterColors Enumeration

PrinterColors Enumeration |
 | See Also

1/18/2008

Enumerates the possible printer color cartridges.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration PrinterColors
[FlagsAttribute]
public enum PrinterColors
[FlagsAttribute]
public enum class PrinterColors
/** @attribute FlagsAttribute() */
public enum PrinterColors
FlagsAttribute
public enum PrinterColors

Members

Member name | Description
Custom1 | Supports first custom color (Secondary color, usually red).
Custom2 | Supports second custom color.
Custom3 | Supports third custom color.
Custom4 | Supports fourth custom color.
Custom5 | Supports fifth custom color.
Custom6 | Supports sixth custom color.
Cyan | Supports cyan color for full color printing.
Full | Supports full color.
Magenta | Supports magenta color for full color printing.
None | Supports no color.
Primary | Supports primary color.
Yellow | Supports yellow color for full color printing.

Remarks

Used by the JrnCurrentCartridge, RecCurrentCartridge, SlpCurrentCartridge, CapJrnColor, CapRecColor, and CapSlpColor properties. Members of this enumeration replace the PTR_COLOR_ range of UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace


PrinterErrorLevel Enumeration

PrinterErrorLevel Enumeration |
 | See Also

1/18/2008

Enumerates the possible severity levels for the most recent error condition.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration PrinterErrorLevel
public enum PrinterErrorLevel
public enum class PrinterErrorLevel
public enum PrinterErrorLevel
public enum PrinterErrorLevel

Members

Member name | Description
Fatal | A nonrecoverable error has occurred. (For example, internal printer failure.)
None | No errors have occurred.
Recoverable | A recoverable error has occurred. (For example, out of paper.)

Remarks

Used by the ErrorLevel property. Members of this enumeration replace the PTR_EL_NONE, PTR_EL_RECOVERABLE, and PTR_EL_FATAL UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace


PrinterLogoLocation Enumeration

PrinterLogoLocation Enumeration |
 | See Also

1/18/2008

Enumerates the possible locations for setting a logo.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration PrinterLogoLocation
public enum PrinterLogoLocation
public enum class PrinterLogoLocation
public enum PrinterLogoLocation
public enum PrinterLogoLocation

Members

Member name | Description
Bottom | Puts the logo at the bottom of the document.
Top | Puts the logo at the top of the document.

Remarks

Used by the SetLogo method. Members of this enumeration replace the PTR_L_TOP and PTR_L_BOTTOM UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace


PrinterMarkFeeds Enumeration

PrinterMarkFeeds Enumeration |
 | See Also

1/18/2008

Enumerates the possible kinds of mark-sensed paper handling.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration PrinterMarkFeeds
[FlagsAttribute]
public enum PrinterMarkFeeds
[FlagsAttribute]
public enum class PrinterMarkFeeds
/** @attribute FlagsAttribute() */
public enum PrinterMarkFeeds
FlagsAttribute
public enum PrinterMarkFeeds

Members

Member name | Description
CurrentTopOfForm | Feeds the mark-sensed paper to the present paper’s top of form. (Reverse feed if it is required).
Cutter | Feeds the mark-sensed paper to the auto cutter cutting position.
NextTopOfForm | Feeds the mark-sensed paper to the next paper’s top of form.
None | Does not feed.
Takeup | Feeds the mark-sensed paper to the paper take-up position.

Remarks

Used by the MarkFeed method and the CapRecMarkFeed property. Members of this enumeration replace the PTR_MF_TO_TAKEUP, PTR_MF_TO_CUTTER, PTR_MF_TO_CURRENT_TOF, and PTR_MF_TO_NEXT_TOF UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace


PrinterSide Enumeration

PrinterSide Enumeration |
 | See Also

1/18/2008

Enumerates possible sides of the print station document on which printing can occur.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration PrinterSide
public enum PrinterSide
public enum class PrinterSide
public enum PrinterSide
public enum PrinterSide

Members

Member name | Description
Opposite | The opposite of the current side.
Side1 | Default print side.
Side2 | The other side of the document (the reverse of default).
Unknown | Document is not inserted.

Remarks

Used by the SlpPrintSide property and the ChangePrintSide method. Members of this enumeration replace the PTR_PS_UNKNOWN, PTR_PS_SIDE1, and PTR_PS_SIDE2 UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace


PrinterStation Enumeration

PrinterStation Enumeration |
 | See Also

1/18/2008

Enumerates the possible printer station modes.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration PrinterStation
public enum PrinterStation
public enum class PrinterStation
public enum PrinterStation
public enum PrinterStation

Members

Member name | Description
Journal | The current printer station is Journal.
None | The current printer station is undefined.
Receipt | The current printer station is Receipt.
Slip | The current printer station is Slip.
TwoReceiptJournal | The current printer station combines Receipt and Journal.
TwoSlipJournal | The current printer station combines Slip and Journal.
TwoSlipReceipt | The current printer station combines Receipt and Slip.

Remarks

Used by the PageModeStation and ErrorStation property and PrintBarCode, PrintBitmap, PrintImmediate, PrintNormal, PrintTwoNormal, RotatePrint, SetBitmap, TransactionPrint, and ValidateData methods. Members of this enumeration replace the PTR_S_JOURNAL, PTR_S_RECEIPT, PTR_S_SLIP, PTR_S_JOURNAL_RECEIPT, PTR_S_JOURNAL_SLIP, PTR_S_RECEIPT_SLIP, PTR_TWO_RECEIPT_JOURNAL, PTR_TWO_SLIP_JOURNAL, PTR_TWO_SLIP_RECEIPT UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace


PrinterTransactionControl Enumeration

PrinterTransactionControl Enumeration |
 | See Also

1/18/2008

Enumerates the possible transaction modes for a printer station.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration PrinterTransactionControl
public enum PrinterTransactionControl
public enum class PrinterTransactionControl
public enum PrinterTransactionControl
public enum PrinterTransactionControl

Members

Member name | Description
Normal | Ends a transaction by printing the buffered data.
Transaction | Starts a transaction.

Remarks

Used by the TransactionPrint method. Members of this enumeration replace the PTR_TP_TRANSACTION and PTR_TP_NORMAL UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace


PrintRotation Enumeration

PrintRotation Enumeration |
 | See Also

1/18/2008

Enumerates the possible rotation settings for a printer device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration PrintRotation
public enum PrintRotation
public enum class PrintRotation
public enum PrintRotation
public enum PrintRotation

Members

Member name | Description
Barcode | Rotates bar code printing. (ORed with one of the previous rotation values.)
Bitmap | Rotates bitmap printing. (ORed with one of the previous rotation values.)
Left90 | Rotates printing 90 degrees to the left (counter-clockwise).
Normal | Ends rotated printing.
Right90 | Rotates printing 90 degrees to the right side (clockwise).
Rotate180 | Rotates printing 180 degrees (print upside-down).

Remarks

Used by the RotatePrint method. Members of this enumeration replace the PTR_RP_RIGHT90, PTR_RP_LEFT90, PTR_RP_ROTATE180, PTR_RP_BARCODE, PTR_RP_BITMAP, PTR_RP_NORMAL UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace


RangeOfCharacters Class

RangeOfCharacters Class |
 | See Also Members

1/18/2008

Defines a helper class that can be used to create an array representing custom glyphs for a Line Display device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Class RangeOfCharacters
public class RangeOfCharacters
public ref class RangeOfCharacters
public class RangeOfCharacters
public class RangeOfCharacters

Remarks

Used to provide a list supported custom glyphs for the CustomGlyphList property.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.RangeOfCharacters

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RangeOfCharacters Members
Microsoft.PointOfService Namespace


RangeOfCharacters Members

RangeOfCharacters Members |
 | See Also Constructors Methods Properties

1/18/2008

Defines a helper class that can be used to create an array representing custom glyphs for a Line Display device.

The following tables list the members exposed by the RangeOfCharacters type.

Public Constructors

Name | Description
RangeOfCharacters | Overloaded.
Top

Public Properties

Name | Description
From | Gets or sets the starting character position for a range of characters.
To | Gets or sets the ending character position for a range of characters.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Overridden.
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

RangeOfCharacters Class
Microsoft.PointOfService Namespace


RangeOfCharacters Constructor

RangeOfCharacters Constructor |
 | See Also

1/18/2008

Overload List

Name | Description
RangeOfCharacters (Char) | Creates an instance of the RangeOfCharacters class based on a single character.
RangeOfCharacters (Char, Char) | Creates an instance of the RangeOfCharacters class based on a range of characters.

See Also

Reference

RangeOfCharacters Class
RangeOfCharacters Members
Microsoft.PointOfService Namespace


RangeOfCharacters Constructor (Char)

RangeOfCharacters Constructor (Char) |
 | See Also

1/18/2008

Creates an instance of the RangeOfCharacters class based on a single character.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    singleCharacter As Char _
)
public RangeOfCharacters (
    char singleCharacter
)
public:
RangeOfCharacters (
    wchar_t singleCharacter
)
public RangeOfCharacters (
    char singleCharacter
)
public function RangeOfCharacters (
    singleCharacter : char
)

Parameters

singleCharacter

The character that the class instance should contain.

See Also

Reference

RangeOfCharacters Class
RangeOfCharacters Members
Microsoft.PointOfService Namespace


RangeOfCharacters Constructor (Char, Char)

RangeOfCharacters Constructor (Char, Char) |
 | See Also

1/18/2008

Creates an instance of the RangeOfCharacters class based on a range of characters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    fromCharacter As Char, _
    toCharacter As Char _
)
public RangeOfCharacters (
    char fromCharacter,
    char toCharacter
)
public:
RangeOfCharacters (
    wchar_t fromCharacter,
    wchar_t toCharacter
)
public RangeOfCharacters (
    char fromCharacter,
    char toCharacter
)
public function RangeOfCharacters (
    fromCharacter : char,
    toCharacter : char
)

Parameters

fromCharacter

The starting character position for the range.

toCharacter

The ending character position for the range.

See Also

Reference

RangeOfCharacters Class
RangeOfCharacters Members
Microsoft.PointOfService Namespace


RangeOfCharacters Methods

RangeOfCharacters Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Overridden.

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

RangeOfCharacters Class
Microsoft.PointOfService Namespace


RangeOfCharacters.ToString Method

RangeOfCharacters.ToString Method |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function ToString As String
public override string ToString ()
public:
virtual String^ ToString () override
public String ToString ()
public override function ToString () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RangeOfCharacters Class
RangeOfCharacters Members
Microsoft.PointOfService Namespace


RangeOfCharacters Properties

RangeOfCharacters Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
From | Gets or sets the starting character position for a range of characters.
To | Gets or sets the ending character position for a range of characters.

See Also

Reference

RangeOfCharacters Class
Microsoft.PointOfService Namespace


RangeOfCharacters.From Property

RangeOfCharacters.From Property |
 | See Also

1/18/2008

Gets or sets the starting character position for a range of characters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Property From As Char
public char From { get; set; }
public:
property wchar_t From {
    wchar_t get ();
    void set (wchar_t value);
}
/** @property */
public char get_From ()

/** @property */
public void set_From (char value)

public function get From () : char

public function set From (value : char)

Remarks

Holds the starting character position for a range of characters.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RangeOfCharacters Class
RangeOfCharacters Members
Microsoft.PointOfService Namespace


RangeOfCharacters.To Property

RangeOfCharacters.To Property |
 | See Also

1/18/2008

Gets or sets the ending character position for a range of characters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Property To As Char
public char To { get; set; }
public:
property wchar_t To {
    wchar_t get ();
    void set (wchar_t value);
}
/** @property */
public char get_To ()

/** @property */
public void set_To (char value)

public function get To () : char

public function set To (value : char)

Remarks

Holds the ending character position for a range of characters.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RangeOfCharacters Class
RangeOfCharacters Members
Microsoft.PointOfService Namespace


RemoteOrderDisplay Class

RemoteOrderDisplay Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a remote order display.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class RemoteOrderDisplay
    Inherits PosCommon
public abstract class RemoteOrderDisplay : PosCommon
public ref class RemoteOrderDisplay abstract : public PosCommon
public abstract class RemoteOrderDisplay extends PosCommon
public abstract class RemoteOrderDisplay extends PosCommon

Remarks

Capabilities

The remote order display service object has the following minimal set of capabilities:

  • Supports color or monochrome text character displays.

  • Supports eight foreground colors (or grayscale on monochrome display) with the option of using the intensity attribute.

  • Supports eight background colors (or grayscale on monochrome display) with the option of using only a blinking attribute.

  • If it is requested, individual event types can be disabled so that the application only receives a subset of data events.

  • Supports video region buffering.

  • Supports cursor functions.

  • Supports clock functions.

  • Supports resetting a video unit to power-on state.

The remote order display service object may also have the following capabilities:

  • Supports multiple video displays. Each display may have a different video mode.

  • Supports touch video input for a touch screen display unit.

  • Supports video enunciator output with frequency and duration.

  • Supports tactile feedback through an automatic tone when a video display unit is touched (for touch screen only).

  • Supports downloading alternate character sets to one or many video units.

  • Supports transaction mode display output to one or many video units.

The following capability is not addressed in this version of the POS for .NET:

  • Support for graphical displays, where the video display is addressable by individual pixels or dots. The addition of this support is under investigation for future revisions.

Model

The general model of a remote order display is as follows:

  • The RemoteOrderDisplay device class is a subsystem of video units. The initial targeted environment is food service, to display order preparation and fulfillment information. Remote order displays are frequently used together with bump bars.

    The subsystem can support up to 32 video units.

    One application on one computer or POS terminal will typically manage and control the subsystem of video units. If applications on the same or other computers and POS terminals have to access the subsystem. Then this application must act as a subsystem server and expose interfaces to other applications.

  • All specific methods are broadcast methods. This means that the method can apply to one unit, a selection of units, or all online units. The units parameter is a Long, with each bit identifying an individual video unit. (One or more of the constants Unit1 through Unit32 are joined to a bitwise OR to form the bitmask.) The service object will try to satisfy the method for all units specified by the units parameter. If an error is received from one or more units, the ErrorUnits property is updated with the appropriate units in error. The ErrorString property is updated with a description of the error or errors received. The method then returns with the corresponding POS for .NET error. If two or more units encounter different errors, the service object should return the most severe POS for .NET error.

  • The common methods CheckHealth, ClearInput, and ClearOutput are not broadcast methods and use the unit ID specified by the CurrentUnitId property. (One of the constants Unit1 through Unit32 is selected.) See the description of these common methods to understand how the current unit ID property is used.

  • When the CurrentUnitId property is set by the application, all the corresponding properties are updated to reflect the settings for that unit.

    If the CurrentUnitId property is set to a unit ID that is not online, the dependent properties will contain non-initialized values.

    The CurrentUnitId uniquely represents a single video unit. The definitions range from Unit1 to Unit32. These definitions are also used to create the bitwise parameter, units, used in the broadcast methods.

  • The rows and columns are numbered that begins with (0,0) at the upper-left corner of the video display. The dimensions are defined by the height and width parameters. All position parameters are expressed in text characters.

  • The VGA-like attribute parameter that is used in various methods is a VideoAttributes enumeration.

    If a foreground or background color is requested, but the service object does not support that color, it chooses the best fit from the colors supported.

Input – Touch Video

The remote order display service object follows the general input model for event-driven input with some differences:

  • When input is received by the service object, it queues a DataEvent event.

  • This device does not support the AutoDisable property. So, the service object will not automatically disable itself when a DataEvent is queued.

  • A queued DataEvent is delivered to the application when the DataEventEnabled property is true and other event delivery requirements are met. Just before delivering this event, the service object copies the data into properties, and disables additional data events by setting the DataEventEnabled property to false. This causes later input data to be queued by the service object while the application processes the current input and associated properties. When the application has finished the current input and is ready for more data, it re-enables events by setting DataEventEnabled to true.

  • ErrorEvent events are queued if the service object encounters an error while collecting or processing input, and are delivered to the application when the DataEventEnabled property is true and other event delivery requirements are met.

  • The VideoDataCount property can be read to obtain the number of video DataEvents for a specific unit ID queued by the service object. The DataCount property can be read to obtain the total number of data events queued by the service object.

  • Input enqueued by the service object can be deleted by calling the ClearInput method.

Output – Video and Tone

The remote order display service object follows the general output model, with some improvements:

  • The following methods are always performed synchronously: ControlClock, ControlCursor, SelectCharacterSet, ResetVideo, and SetCursor. These methods will fail if asynchronous output is outstanding. The FreeVideoRegion method is also always performed synchronously but without regard to outstanding asynchronous output.

  • The following methods are performed either synchronously or asynchronously, depending on the value of the AsyncMode property: ClearVideo, ClearVideoRegion, CopyVideoRegion, DisplayData, DrawBox, RestoreVideoRegion, SaveVideoRegion, TransactionDisplay, UpdateVideoRegionAttribute, and VideoSound. When AsyncMode is false, these methods operate synchronously and return their completion status to the application.

    When AsyncMode is true, these methods operate as follows:

    • The service object buffers the request, sets the OutputId property to an identifier for this request, and returns as soon as possible. When the device completes the request successfully, the service object updates the EventUnits property and raises an OutputCompleteEvent. A parameter of this event contains the output ID of the completed request.

      Asynchronous display methods will not return an error status because of a display problem, such as a communications failure. These errors are only reported by an ErrorEvent. An error status is returned only if the display is not claimed and enabled, a parameter is invalid, or the request cannot be queued. The first two error cases are because of an application error, while the last is a system resource exception.

    • If an error occurs while performing an asynchronous request, an ErrorEvent is queued and delivered. The EventUnits property is set to the unit or units in error. The EventString property is also set.Note:ErrorEvent updates EventUnits and EventString. If an error is reported by a synchronous broadcast method, then ErrorUnits and ErrorString are set instead.

      The event handler can call synchronous display methods (but not asynchronous methods), and then can either retry the outstanding output or clear it.

    • The service object guarantees that asynchronous output is performed on a first-in first-out basis.

    • All unit output buffered by the service object can be deleted by setting the CurrentUnitId property and calling the ClearOutput method. OutputCompleteEvent events are not raised for cleared output. This method also stops any output that may be in progress (when it is possible).

  • The remote order display service object device may support transaction mode. A transaction is a sequence of display operations that are sent to a video unit as a single unit. Display operations that can be included in a transaction are ClearVideo, ClearVideoRegion, CopyVideoRegion, DisplayData, DrawBox, RestoreVideoRegion, SaveVideoRegion, and UpdateVideoRegionAttribute. During a transaction, the display operations are first validated. If valid, they are added to the transaction but not yet displayed. After the application has added as many operations as required, the transaction display method is called.

    If the transaction is displayed synchronously, the returned status indicates either that the transaction displayed successfully or that an error occurred during the display. If the transaction is displayed asynchronously, the asynchronous display rules listed earlier are followed. If an error occurs and the ErrorEvent handler causes a retry, the transaction is retried.

Device Sharing

The remote order display is an exclusive-use device. Its device sharing rules are as follows:

  • The application must claim the device before it enables it.

  • The application must claim and enable the device before accessing many remote order display specific properties.

  • The application must claim and enable the device before it calls methods that manipulate the device.

  • When a ClaimDevice method is called again, settable device characteristics are restored to their condition at ReleaseDevice. Examples of restored characteristics are character set, video mode, and tone frequency. Region memory buffers, clock, and cursor settings are considered state characteristics and are not restored.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.RemoteOrderDisplay
Microsoft.PointOfService.BasicServiceObjects.RemoteOrderDisplayBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Members
Microsoft.PointOfService Namespace


RemoteOrderDisplay Members

RemoteOrderDisplay Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a remote order display.

The following tables list the members exposed by the RemoteOrderDisplay type.

Protected Constructors

Name | Description
RemoteOrderDisplay | Creates an instance of the RemoteOrderDisplay class.
Top

Public Fields

Name | Description
CharacterSetAnsi | A constant value that is used by the SelectCharacterSet method to set the video unit to use the ANSI character set.
CharacterSetAscii | A constant value used by the SelectCharacterSet method to set the video unit to use the ASCII character set.
CharacterSetUnicode | A constant value that is used by the SelectCharacterSet method to set the video unit to use the Unicode character set.
ClockAll | A constant value that is used by the ControlClock method to set all clocks to start at the same time.
ExtendedErrorBadClock | Indicates a Pause, Resume, Start, Stop, or Move command was requested on an uninitialized clockId for any of the video units indicated in units.
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorNoBuffers | Indicates the requested buffer exceeds the total number of video save buffers the remote order display device can support at once as specified in the SystemVideoSaveBuffers property.
ExtendedErrorNoClocks | Indicates the total number of clocks the remote order display device can support at one time as specified in the SystemClocks property has been reached.
ExtendedErrorNoRegion | Indicates bufferId does not contain a previously saved video region for the selected units.
ExtendedErrorNoRoom | Indicates all the buffer memory has been allocated for a specific unit. The ErrorUnits and ErrorString properties are updated.
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
AsyncMode | Gets or sets a Boolean value that indicates whether methods are performed asynchronously.
AutoToneDuration | Gets or sets the duration (in milliseconds) of the automatic tone for the video unit specified by the CurrentUnitId property.
AutoToneFrequency | Gets or sets the frequency (in Hertz) of the automatic tone for the video unit specified by the CurrentUnitId property.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapMapCharacterSet | Gets a Boolean value that indicates whether the service object can map characters to the character sets that are defined in CharacterSetList.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapSelectCharacterSet | Gets a Boolean value that indicates whether the video unit specified by the CurrentUnitId property can be loaded with an alternate, user-supplied character set.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapTone | Gets a Boolean value that indicates whether the video unit specified by the CurrentUnitId property supports an enunciator.
CapTouch | Gets a Boolean value that indicates whether the video unit specified by the CurrentUnitId property supports the TouchUp, TouchDown, and TouchMove event types.
CapTransaction | Gets a Boolean value that indicates whether transactions are supported by each video unit.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CharacterSet | Gets the character set for displaying characters for the video unit specified by the CurrentUnitId property.
CharacterSetList | Gets the character set for the video unit specified by the CurrentUnitId property.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Clocks | Gets the number of clocks the video unit, specified by the CurrentUnitId property, can support.
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
CurrentUnitId | Gets or sets the current video unit ID. Up to 32 units are allowed on one remote order display device. The unit ID definitions range from Unit1 to Unit32.
DataCount | Gets the total number of queued DataEvent events.
DataEventEnabled | Gets or sets a Boolean value that indicates whether a DataEvent event is delivered when input data is queued.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
ErrorString | Gets an error description that occurred to the video units.
ErrorUnits | Gets a bitwise mask of the video units that encountered an error.
EventString | Gets an error description for an error event.
EventType | Gets or sets event types.
EventUnitId | Gets a video unit ID.
EventUnits | Gets device unit(s).
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
MapCharacterSet | Gets or sets a Boolean value that indicates whether transferred characters are mapped to another character set.
OutputId | Gets the identifier of the most recently started asynchronous output.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
SystemClocks | Gets the total number of clocks the remote order display device can support at one time.
SystemVideoSaveBuffers | Gets the total number of video save buffers the remote order display device can support at one time.
Timeout | Gets or sets the timeout value in milliseconds used by the remote order display device to complete all supported output methods.
UnitsOnline | Gets which video units are online.
VideoDataCount | Gets the number of DataEvent events queued for the video unit specified by the CurrentUnitId property.
VideoMode | Gets or sets the video Mode ID selected for the video unit specified by the CurrentUnitId property.
VideoModesList | Gets the video modes supported for the video unit specified by the CurrentUnitId property.
VideoSaveBuffers | Gets the number of save buffers for the video unit specified by the CurrentUnitId property.
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether the RemoteOrderDisplay is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears the device input that has been buffered for the unit specified by the CurrentUnitId property.
ClearOutput | Clears all outputs that have been buffered for the unit specified by the CurrentUnitId property. This includes video and tone outputs.
ClearVideo | Clears the display area for the video unit(s) specified by the units parameter.
ClearVideoRegion | Clears the specified video region.
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
ControlClock | Performs the clock command requested in clockFunction on the specified video unit(s).
ControlCursor | Enables or disables the cursor for the specified video unit(s).
CopyVideoRegion | Copies a region of the display area to a new location on the display area for the specified video unit(s).
DirectIO | (inherited from PosCommon )
DisplayData | Displays the characters in data starting at the location that is specified by row and column, and continues in succeeding columns on the video unit(s) indicated in the units parameter.
DrawBox | Draws a box on the specified video unit(s).
Equals | Overloaded. (inherited from Object )
FreeVideoRegion | Frees any buffer memory allocated for the specified video unit(s).
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon)
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
ResetVideo | Sets the specified video unit(s) to a turned on state.
RestoreVideoRegion | Restores a previously saved video region of the display area from the requested bufferId for the specified video unit(s).
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
SaveVideoRegion | Saves the specified video region of the display area to one of the provided video buffers for the specified video unit(s).
SelectCharacterSet | Selects a compatible character set for the specified video unit(s).
SetCursor | Updates the cursor position on the specified video unit(s).
ToString | (inherited from Object )
TransactionDisplay | Enters or exits transaction mode for the specified video unit(s).
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
UpdateVideoRegionAttribute | Modifies the attribute on the specified video unit(s).
VideoSound | Sounds the video enunciator for the specified units.
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DataEvent | Notifies the application when input data from a video touch unit is available.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
ErrorEvent | Notifies the application that a remote order display error has been detected and a suitable response by the application is necessary to process the error condition.
OutputCompleteEvent | Notifies the application that the queued output request associated with the OutputID property has completed successfully.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

RemoteOrderDisplay Class
Microsoft.PointOfService Namespace


RemoteOrderDisplay Fields

RemoteOrderDisplay Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
CharacterSetAnsi | A constant value that is used by the SelectCharacterSet method to set the video unit to use the ANSI character set.
CharacterSetAscii | A constant value used by the SelectCharacterSet method to set the video unit to use the ASCII character set.
CharacterSetUnicode | A constant value that is used by the SelectCharacterSet method to set the video unit to use the Unicode character set.
ClockAll | A constant value that is used by the ControlClock method to set all clocks to start at the same time.
ExtendedErrorBadClock | Indicates a Pause, Resume, Start, Stop, or Move command was requested on an uninitialized clockId for any of the video units indicated in units.
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorNoBuffers | Indicates the requested buffer exceeds the total number of video save buffers the remote order display device can support at once as specified in the SystemVideoSaveBuffers property.
ExtendedErrorNoClocks | Indicates the total number of clocks the remote order display device can support at one time as specified in the SystemClocks property has been reached.
ExtendedErrorNoRegion | Indicates bufferId does not contain a previously saved video region for the selected units.
ExtendedErrorNoRoom | Indicates all the buffer memory has been allocated for a specific unit. The ErrorUnits and ErrorString properties are updated.
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

RemoteOrderDisplay Class
Microsoft.PointOfService Namespace


RemoteOrderDisplay.CharacterSetAnsi Field

RemoteOrderDisplay.CharacterSetAnsi Field |
 | See Also

1/18/2008

A constant value that is used by the SelectCharacterSet method to set the video unit to use the ANSI character set.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const CharacterSetAnsi As Integer
public const int CharacterSetAnsi
public:
literal int CharacterSetAnsi
public static final int CharacterSetAnsi
public const var CharacterSetAnsi : int

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
SelectCharacterSet


RemoteOrderDisplay.CharacterSetAscii Field

RemoteOrderDisplay.CharacterSetAscii Field |
 | See Also

1/18/2008

A constant value used by the SelectCharacterSet method to set the video unit to use the ASCII character set.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const CharacterSetAscii As Integer
public const int CharacterSetAscii
public:
literal int CharacterSetAscii
public static final int CharacterSetAscii
public const var CharacterSetAscii : int

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
SelectCharacterSet


RemoteOrderDisplay.CharacterSetUnicode Field

RemoteOrderDisplay.CharacterSetUnicode Field |
 | See Also

1/18/2008

A constant value that is used by the SelectCharacterSet method to set the video unit to use the Unicode character set.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const CharacterSetUnicode As Integer
public const int CharacterSetUnicode
public:
literal int CharacterSetUnicode
public static final int CharacterSetUnicode
public const var CharacterSetUnicode : int

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
SelectCharacterSet


RemoteOrderDisplay.ClockAll Field

RemoteOrderDisplay.ClockAll Field |
 | See Also

1/18/2008

A constant value that is used by the ControlClock method to set all clocks to start at the same time.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ClockAll As Integer
public const int ClockAll
public:
literal int ClockAll
public static final int ClockAll
public const var ClockAll : int

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace


RemoteOrderDisplay.ExtendedErrorBadClock Field

RemoteOrderDisplay.ExtendedErrorBadClock Field |
 | See Also

1/18/2008

Indicates a Pause, Resume, Start, Stop, or Move command was requested on an uninitialized clockId for any of the video units indicated in units.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorBadClock As Integer
public const int ExtendedErrorBadClock
public:
literal int ExtendedErrorBadClock
public static final int ExtendedErrorBadClock
public const var ExtendedErrorBadClock : int

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
ControlClock


RemoteOrderDisplay.ExtendedErrorNoBuffers Field

RemoteOrderDisplay.ExtendedErrorNoBuffers Field |
 | See Also

1/18/2008

Indicates the requested buffer exceeds the total number of video save buffers the remote order display device can support at once as specified in the SystemVideoSaveBuffers property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorNoBuffers As Integer
public const int ExtendedErrorNoBuffers
public:
literal int ExtendedErrorNoBuffers
public static final int ExtendedErrorNoBuffers
public const var ExtendedErrorNoBuffers : int

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
SaveVideoRegion


RemoteOrderDisplay.ExtendedErrorNoClocks Field

RemoteOrderDisplay.ExtendedErrorNoClocks Field |
 | See Also

1/18/2008

Indicates the total number of clocks the remote order display device can support at one time as specified in the SystemClocks property has been reached.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorNoClocks As Integer
public const int ExtendedErrorNoClocks
public:
literal int ExtendedErrorNoClocks
public static final int ExtendedErrorNoClocks
public const var ExtendedErrorNoClocks : int

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
ControlClock


RemoteOrderDisplay.ExtendedErrorNoRegion Field

RemoteOrderDisplay.ExtendedErrorNoRegion Field |
 | See Also

1/18/2008

Indicates bufferId does not contain a previously saved video region for the selected units.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorNoRegion As Integer
public const int ExtendedErrorNoRegion
public:
literal int ExtendedErrorNoRegion
public static final int ExtendedErrorNoRegion
public const var ExtendedErrorNoRegion : int

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
RestoreVideoRegion


RemoteOrderDisplay.ExtendedErrorNoRoom Field

RemoteOrderDisplay.ExtendedErrorNoRoom Field |
 | See Also

1/18/2008

Indicates all the buffer memory has been allocated for a specific unit. The ErrorUnits and ErrorString properties are updated.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorNoRoom As Integer
public const int ExtendedErrorNoRoom
public:
literal int ExtendedErrorNoRoom
public static final int ExtendedErrorNoRoom
public const var ExtendedErrorNoRoom : int

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
SaveVideoRegion


RemoteOrderDisplay Constructor

RemoteOrderDisplay Constructor |
 | See Also

1/18/2008

Creates an instance of the RemoteOrderDisplay class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected RemoteOrderDisplay ()
protected:
RemoteOrderDisplay ()
protected RemoteOrderDisplay ()
protected function RemoteOrderDisplay ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace


RemoteOrderDisplay Methods

RemoteOrderDisplay Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears the device input that has been buffered for the unit specified by the CurrentUnitId property.
ClearOutput | Clears all outputs that have been buffered for the unit specified by the CurrentUnitId property. This includes video and tone outputs.
ClearVideo | Clears the display area for the video unit(s) specified by the units parameter.
ClearVideoRegion | Clears the specified video region.
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
ControlClock | Performs the clock command requested in clockFunction on the specified video unit(s).
ControlCursor | Enables or disables the cursor for the specified video unit(s).
CopyVideoRegion | Copies a region of the display area to a new location on the display area for the specified video unit(s).
DirectIO | (inherited from PosCommon )
DisplayData | Displays the characters in data starting at the location that is specified by row and column, and continues in succeeding columns on the video unit(s) indicated in the units parameter.
DrawBox | Draws a box on the specified video unit(s).
Equals | Overloaded. (inherited from Object )
FreeVideoRegion | Frees any buffer memory allocated for the specified video unit(s).
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon )
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
ResetVideo | Sets the specified video unit(s) to a turned on state.
RestoreVideoRegion | Restores a previously saved video region of the display area from the requested bufferId for the specified video unit(s).
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
SaveVideoRegion | Saves the specified video region of the display area to one of the provided video buffers for the specified video unit(s).
SelectCharacterSet | Selects a compatible character set for the specified video unit(s).
SetCursor | Updates the cursor position on the specified video unit(s).
ToString | (inherited from Object )
TransactionDisplay | Enters or exits transaction mode for the specified video unit(s).
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
UpdateVideoRegionAttribute | Modifies the attribute on the specified video unit(s).
VideoSound | Sounds the video enunciator for the specified units.

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

RemoteOrderDisplay Class
Microsoft.PointOfService Namespace


RemoteOrderDisplay.ClearInput Method

RemoteOrderDisplay.ClearInput Method |
 | See Also

1/18/2008

Clears the device input that has been buffered for the unit specified by the CurrentUnitId property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearInput
public abstract void ClearInput ()
public:
virtual void ClearInput () abstract
public abstract void ClearInput ()
public abstract function ClearInput ()

Remarks

Any data events that are queued, usually waiting for DataEventEnabled to be set to true and FreezeEvents to be set to false, are also cleared.

ClearInput may cause a PosControlException exception to be thrown with the following ErrorCode:

Value | Description
Claimed | The device is claimed by another process.
NotClaimed | The device must be claimed before ClearInput can be used.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
CurrentUnitId


RemoteOrderDisplay.ClearOutput Method

RemoteOrderDisplay.ClearOutput Method |
 | See Also

1/18/2008

Clears all outputs that have been buffered for the unit specified by the CurrentUnitId property. This includes video and tone outputs.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearOutput
public abstract void ClearOutput ()
public:
virtual void ClearOutput () abstract
public abstract void ClearOutput ()
public abstract function ClearOutput ()

Remarks

Any output complete and output error events that are enqueued, usually waiting for DataEventEnabled to be set to true and FreezeEvents to be set to false, are also cleared.

ClearOutput may cause a PosControlException exception to be thrown with the following ErrorCode:

Value | Description
Claimed | The device is claimed by another process.
NotClaimed | The device must be claimed before ClearOutput can be used.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
CurrentUnitId


RemoteOrderDisplay.ClearVideo Method

RemoteOrderDisplay.ClearVideo Method |
 | See Also

1/18/2008

Clears the display area for the video unit(s) specified by the units parameter.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearVideo ( _
    units As DeviceUnits, _
    attribute As VideoAttributes _
)
public abstract void ClearVideo (
    DeviceUnits units,
    VideoAttributes attribute
)
public:
virtual void ClearVideo (
    DeviceUnits units,
    VideoAttributes attribute
) abstract
public abstract void ClearVideo (
    DeviceUnits units,
    VideoAttributes attribute
)
public abstract function ClearVideo (
    units : DeviceUnits,
    attribute : VideoAttributes
)

Parameters

units

Indicates which unit(s) to operate on.

attribute

The video attributes to clear.

Remarks

The display area is cleared by using the attribute specified in the attribute parameter.

ClearVideo is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

ClearVideo may cause a PosControlException exception to be thrown with the following ErrorCode:

Value

Description

Illegal

One of the following errors occurred:

  • The attribute parameter is illegal.

  • The units parameter is zero or a nonexistent unit was specified.

Failure

An error occurred while communicating with one of the video units specified by units. The ErrorUnits and ErrorString properties are updated before return. (Can be returned only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
AsyncMode


RemoteOrderDisplay.ClearVideoRegion Method

RemoteOrderDisplay.ClearVideoRegion Method |
 | See Also

1/18/2008

Clears the specified video region.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearVideoRegion ( _
    row As Integer, _
    column As Integer, _
    height As Integer, _
    width As Integer, _
    attribute As VideoAttributes _
)
public abstract void ClearVideoRegion (
    int row,
    int column,
    int height,
    int width,
    VideoAttributes attribute
)
public:
virtual void ClearVideoRegion (
    int row,
    int column,
    int height,
    int width,
    VideoAttributes attribute
) abstract
public abstract void ClearVideoRegion (
    int row,
    int column,
    int height,
    int width,
    VideoAttributes attribute
)
public abstract function ClearVideoRegion (
    row : int,
    column : int,
    height : int,
    width : int,
    attribute : VideoAttributes
)

Parameters

row

The region's start row.

column

The region's start column.

height

The number of rows in the region.

width

The number of columns in the region.

attribute

The attribute to clear.

Remarks

The display area is cleared by using the attribute put in the attribute parameter.

ClearVideoRegion is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

ClearVideoRegion may cause a PosControlException exception to be thrown with the following ErrorCode:

Value

Description

Illegal

One of the following errors occurred:

  • row, column, height, or width are out of range.

  • The attribute parameter is illegal.

Failure

An error occurred while communicating with one of the video units specified by units. The ErrorUnits and ErrorString properties are updated before return. (Can be returned only if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
AsyncMode
ErrorString
ErrorUnits


RemoteOrderDisplay.ControlClock Method

RemoteOrderDisplay.ControlClock Method |
 | See Also

1/18/2008

Performs the clock command requested in clockFunction on the specified video unit(s).

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ControlClock ( _
    units As DeviceUnits, _
    clockFunction As ClockFunction, _
    clockId As Integer, _
    hours As Integer, _
    minutes As Integer, _
    seconds As Integer, _
    row As Integer, _
    column As Integer, _
    attribute As VideoAttributes, _
    mode As ClockMode _
)
public abstract void ControlClock (
    DeviceUnits units,
    ClockFunction clockFunction,
    int clockId,
    int hours,
    int minutes,
    int seconds,
    int row,
    int column,
    VideoAttributes attribute,
    ClockMode mode
)
public:
virtual void ControlClock (
    DeviceUnits units,
    ClockFunction clockFunction,
    int clockId,
    int hours,
    int minutes,
    int seconds,
    int row,
    int column,
    VideoAttributes attribute,
    ClockMode mode
) abstract
public abstract void ControlClock (
    DeviceUnits units,
    ClockFunction clockFunction,
    int clockId,
    int hours,
    int minutes,
    int seconds,
    int row,
    int column,
    VideoAttributes attribute,
    ClockMode mode
)
public abstract function ControlClock (
    units : DeviceUnits,
    clockFunction : ClockFunction,
    clockId : int,
    hours : int,
    minutes : int,
    seconds : int,
    row : int,
    column : int,
    attribute : VideoAttributes,
    mode : ClockMode
)

Parameters

units

The units to operate on.

clockFunction

The requested clock function.

clockId

Clock identification number. The valid values can be from 1 - Clocks. When the clockFunction parameter is Pause, Resume, or Stop, then clockId can be ClockAll to specify all clocks started on the specified video unit(s).

hours

The initial hours for the clock display.

minutes

The initial minutes for the clock display.

seconds

The initial seconds for the clock display.

row

The clock's row.

column

The clock's start column.

attribute

The video attribute.

mode

The type of clock to display.

Remarks

The clock is displayed in the requested mode format at the location found in the row and column parameters.

The clock starts at the specified hours, minutes, and seconds time values and is updated every second until a Pause or Stop is requested for this clockId.

When a Pause, Resume, or Stop command is issued, the hours, minutes, seconds, row, column, attribute, and mode parameters are ignored. During a Pause command, the clock display updates are suspended. During a Resume command, the clock updates continue.

If a Pause, Resume, Stop or Move command is requested on an uninitialized clockId for any of the video units specified by the units parameter, an ExtendedErrorBadClock is returned. If a Resume command is requested without performing a Pause, this has no effect and no error is returned.

When a Move command is issued, the clock is moved to the new location found in the row and column parameters. The hours, minutes, seconds, attribute, and mode parameters are ignored for this command function.

Generally a video unit can support the number of clocks specified by the Clocks property. However, the Start command returns ExtendedErrorNoClocks if it exceeds the number of SystemClocks, even though the Clocks property may indicate the unit can support more clocks than allocated for that unit.

ControlClock may cause a PosControlException exception to be thrown with the following ErrorCode:

Value | Description
Busy | A Start command is requested but the specified clockId is being used. The ErrorUnits and ErrorString properties are updated.
Failure | An error occurred while communicating with one of the video units specified by units. The ErrorUnits and ErrorString properties are updated before return. (Can be returned only if AsyncMode is false.)
ExtendedErrorBadClock | A Pause, Resume, Start, or Move command was requested and the specified clockId has not been initialized by the Start command.
ExtendedErrorNoClocks | The Start command failed because the number of SystemClocks has been reached.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
Clocks
ErrorString
ErrorUnits


RemoteOrderDisplay.ControlCursor Method

RemoteOrderDisplay.ControlCursor Method |
 | See Also

1/18/2008

Enables or disables the cursor for the specified video unit(s).

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ControlCursor ( _
    units As DeviceUnits, _
    cursorType As VideoCursorType _
)
public abstract void ControlCursor (
    DeviceUnits units,
    VideoCursorType cursorType
)
public:
virtual void ControlCursor (
    DeviceUnits units,
    VideoCursorType cursorType
) abstract
public abstract void ControlCursor (
    DeviceUnits units,
    VideoCursorType cursorType
)
public abstract function ControlCursor (
    units : DeviceUnits,
    cursorType : VideoCursorType
)

Parameters

units

The units to operate on.

cursorType

The type of cursor to display.

Remarks

When the cursorType is Off, the cursor is disabled; otherwise, the cursor is enabled as the requested cursor type.

If the video unit cannot support the requested cursor type, the service object uses the next closest cursor type.

The cursorType attribute is taken from the current cursor location.

ControlCursor may cause a PosControlException to be thrown with the following ErrorCode:

Value | Description
Failure | An error occurred while communicating with one of the video units specified by units. The ErrorUnits and ErrorString properties are updated before return.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
ErrorString
ErrorUnits


RemoteOrderDisplay.CopyVideoRegion Method

RemoteOrderDisplay.CopyVideoRegion Method |
 | See Also

1/18/2008

Copies a region of the display area to a new location on the display area for the specified video unit(s).

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub CopyVideoRegion ( _
    units As DeviceUnits, _
    row As Integer, _
    column As Integer, _
    height As Integer, _
    width As Integer, _
    targetRow As Integer, _
    targetColumn As Integer _
)
public abstract void CopyVideoRegion (
    DeviceUnits units,
    int row,
    int column,
    int height,
    int width,
    int targetRow,
    int targetColumn
)
public:
virtual void CopyVideoRegion (
    DeviceUnits units,
    int row,
    int column,
    int height,
    int width,
    int targetRow,
    int targetColumn
) abstract
public abstract void CopyVideoRegion (
    DeviceUnits units,
    int row,
    int column,
    int height,
    int width,
    int targetRow,
    int targetColumn
)
public abstract function CopyVideoRegion (
    units : DeviceUnits,
    row : int,
    column : int,
    height : int,
    width : int,
    targetRow : int,
    targetColumn : int
)

Parameters

units

The video units to operate on.

row

The region's start row.

column

The region's start column.

height

The number of rows in the region.

width

The number of columns in the region.

targetRow

The start row of the target location.

targetColumn

The start column of the target location.

Remarks

The source area is defined by the row, column, height, and width parameters. The upper-left corner of the target location is defined by the targetRow and targetColumn parameters. If the ranges overlap the copy is performed in such a way that all original data is preserved.

This method is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

CopyVideoRegion may cause a PosControlException exception to be thrown with the following ErrorCode:

Value | Description
Failure | An error occurred while communicating with one of the video units specified by units. The ErrorUnits and ErrorString properties are updated before return. (Can only occur if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
AsyncMode
ErrorString
ErrorUnits


RemoteOrderDisplay.DisplayData Method

RemoteOrderDisplay.DisplayData Method |
 | See Also

1/18/2008

Displays the characters in data starting at the location that is specified by row and column, and continues in succeeding columns on the video unit(s) indicated in the units parameter.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub DisplayData ( _
    units As DeviceUnits, _
    row As Integer, _
    column As Integer, _
    attribute As VideoAttributes, _
    data As String _
)
public abstract void DisplayData (
    DeviceUnits units,
    int row,
    int column,
    VideoAttributes attribute,
    string data
)
public:
virtual void DisplayData (
    DeviceUnits units,
    int row,
    int column,
    VideoAttributes attribute,
    String^ data
) abstract
public abstract void DisplayData (
    DeviceUnits units,
    int row,
    int column,
    VideoAttributes attribute,
    String data
)
public abstract function DisplayData (
    units : DeviceUnits,
    row : int,
    column : int,
    attribute : VideoAttributes,
    data : String
)

Parameters

units

The video units to operate on.

row

The start row for the text.

column

The start column for the text.

attribute

The video attribute.

data

The string of characters to display.

Remarks

Any characters that extend beyond the last column are discarded.

This method is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

DisplayData may cause a PosControlException exception to be thrown with the following ErrorCode:

Value | Description
Failure | An error occurred while communicating with one of the video units specified by units. The ErrorUnits and ErrorString properties are updated before return. (Can only occur if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
AsyncMode
ErrorString
ErrorUnits


RemoteOrderDisplay.DrawBox Method

RemoteOrderDisplay.DrawBox Method |
 | See Also

1/18/2008

Draws a box on the specified video unit(s).

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub DrawBox ( _
    units As DeviceUnits, _
    row As Integer, _
    column As Integer, _
    height As Integer, _
    width As Integer, _
    attribute As VideoAttributes, _
    borderType As BorderType _
)
public abstract void DrawBox (
    DeviceUnits units,
    int row,
    int column,
    int height,
    int width,
    VideoAttributes attribute,
    BorderType borderType
)
public:
virtual void DrawBox (
    DeviceUnits units,
    int row,
    int column,
    int height,
    int width,
    VideoAttributes attribute,
    BorderType borderType
) abstract
public abstract void DrawBox (
    DeviceUnits units,
    int row,
    int column,
    int height,
    int width,
    VideoAttributes attribute,
    BorderType borderType
)
public abstract function DrawBox (
    units : DeviceUnits,
    row : int,
    column : int,
    height : int,
    width : int,
    attribute : VideoAttributes,
    borderType : BorderType
)

Parameters

units

The units to operate on.

row

The box's start row.

column

The box's start column.

height

The number of rows in the box.

width

The number of columns in the box.

attribute

The video attribute.

borderType

The border type.

Remarks

The remote order display tries to draw a box that uses the border type specified. If the character set does not support the chosen border type, the service object chooses the best fit from the given character set.

DrawBox is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

DrawBox may cause a PosControlException exception to be thrown with the following ErrorCode:

Value | Description
Failure | An error occurred while communicating with one of the video units specified by units. The ErrorUnits and ErrorString properties are updated before return.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
AsyncMode
ErrorString
ErrorUnits


RemoteOrderDisplay.FreeVideoRegion Method

RemoteOrderDisplay.FreeVideoRegion Method |
 | See Also

1/18/2008

Frees any buffer memory allocated for the specified video unit(s).

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub FreeVideoRegion ( _
    units As DeviceUnits, _
    bufferId As Integer _
)
public abstract void FreeVideoRegion (
    DeviceUnits units,
    int bufferId
)
public:
virtual void FreeVideoRegion (
    DeviceUnits units,
    int bufferId
) abstract
public abstract void FreeVideoRegion (
    DeviceUnits units,
    int bufferId
)
public abstract function FreeVideoRegion (
    units : DeviceUnits,
    bufferId : int
)

Parameters

units

The units to operate on.

bufferId

Integer identifying the video buffer to free. Valid values range from 1 to the VideoSaveBuffers property for the selected unit(s).

Remarks

The number of video buffers supported is stored in the VideoSaveBuffers property for each video unit online. If the bufferId was never used in a previous SaveVideoRegion method, no action is taken.

FreeVideoRegion may cause a PosControlException exception to be thrown with the following ErrorCode:

Value | Description
Failure | An error occurred while communicating with one of the video units specified by units. The ErrorUnits and ErrorString properties are updated before return.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
ErrorString
ErrorUnits
SaveVideoRegion
VideoSaveBuffers


RemoteOrderDisplay.ResetVideo Method

RemoteOrderDisplay.ResetVideo Method |
 | See Also

1/18/2008

Sets the specified video unit(s) to a turned on state.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ResetVideo ( _
    units As DeviceUnits _
)
public abstract void ResetVideo (
    DeviceUnits units
)
public:
virtual void ResetVideo (
    DeviceUnits units
) abstract
public abstract void ResetVideo (
    DeviceUnits units
)
public abstract function ResetVideo (
    units : DeviceUnits
)

Parameters

units

The units to operate on.

Remarks

All service buffers and clocks associated with the unit(s) are released. All settable characteristics are set to default values.

ResetVideo may cause a PosControlException to be thrown with the following ErrorCode:

Value | Description
Failure | An error occurred while communicating with one of the video units specified by units. The ErrorUnits and ErrorString properties are updated before return.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
ErrorString
ErrorUnits


RemoteOrderDisplay.RestoreVideoRegion Method

RemoteOrderDisplay.RestoreVideoRegion Method |
 | See Also

1/18/2008

Restores a previously saved video region of the display area from the requested bufferId for the specified video unit(s).

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub RestoreVideoRegion ( _
    units As DeviceUnits, _
    targetRow As Integer, _
    targetColumn As Integer, _
    bufferId As Integer _
)
public abstract void RestoreVideoRegion (
    DeviceUnits units,
    int targetRow,
    int targetColumn,
    int bufferId
)
public:
virtual void RestoreVideoRegion (
    DeviceUnits units,
    int targetRow,
    int targetColumn,
    int bufferId
) abstract
public abstract void RestoreVideoRegion (
    DeviceUnits units,
    int targetRow,
    int targetColumn,
    int bufferId
)
public abstract function RestoreVideoRegion (
    units : DeviceUnits,
    targetRow : int,
    targetColumn : int,
    bufferId : int
)

Parameters

units

The units to operate on.

targetRow

The start row of the target location.

targetColumn

The start column of the target location.

bufferId

Number identifying the source video buffer to use. Valid values range from 1 to the VideoSaveBuffers property for the selected unit(s).

Remarks

A region can be saved by using the SaveVideoRegion method. The number of video buffers supported is stored in the VideoSaveBuffers property for each video unit online. The target location is defined by the targetRow and targetColumn parameters. RestoreVideoRegion does not free the memory after restoring. Therefore, RestoreVideoRegion can be used to copy a video region to multiple locations on the display. Use the FreeVideoRegion method to free any memory allocated for a video buffer.

If the bufferId does not contain a previously saved video region for the units selected, an ExtendedErrorNoRegion exception is thrown.

Video regions cannot be restored between video units. For example, the SaveVideoRegion method is called by using units = 0000 1000 and bufferId = 1. This will save a video region for the Unit Id 4, in to Buffer 1 for that unit. If this method is called by using units = 0000 0100 and bufferId = 1 with the intention of restoring the previously saved buffer to Unit Id 3, then either an ExtendedErrorNoRegion is thrown, or an unwanted region would be restored.

RestoreVideoRegion is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

ResetVideoRegion may cause a PosControlException to be thrown with the following ErrorCode:

Value | Description
ExtendedErrorNoRegion | The bufferId does not contain a previously saved video region.
Failure | An error occurred while communicating with one of the video units specified by units. The ErrorUnits and ErrorString properties are updated before return. (Can only occur if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
AsyncMode
ErrorString
ErrorUnits
VideoSaveBuffers
SaveVideoRegion


RemoteOrderDisplay.SaveVideoRegion Method

RemoteOrderDisplay.SaveVideoRegion Method |
 | See Also

1/18/2008

Saves the specified video region of the display area to one of the provided video buffers for the specified video unit(s).

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub SaveVideoRegion ( _
    units As DeviceUnits, _
    row As Integer, _
    column As Integer, _
    height As Integer, _
    width As Integer, _
    bufferId As Integer _
)
public abstract void SaveVideoRegion (
    DeviceUnits units,
    int row,
    int column,
    int height,
    int width,
    int bufferId
)
public:
virtual void SaveVideoRegion (
    DeviceUnits units,
    int row,
    int column,
    int height,
    int width,
    int bufferId
) abstract
public abstract void SaveVideoRegion (
    DeviceUnits units,
    int row,
    int column,
    int height,
    int width,
    int bufferId
)
public abstract function SaveVideoRegion (
    units : DeviceUnits,
    row : int,
    column : int,
    height : int,
    width : int,
    bufferId : int
)

Parameters

units

The units to operate on.

row

The start row of the region to save.

column

The start column of the region to save.

height

The number of rows in the region to save.

width

The number of columns in the region to save.

bufferId

Number identifying the video buffer to use. Valid values range from 1 to the VideoSaveBuffers property for a selected unit(s).

Remarks

The number of video buffers supported is stored in the VideoSaveBuffers property for each video unit online. However, an exception will be thrown if the requested buffer exceeds the number of SystemVideoSaveBuffers even though the VideoSaveBuffers property may indicated the unit can support more save buffers than currently allocated for that unit.

If VideoSaveBuffers is greater than 0, the service can support at a minimum one whole video screen. This does not guarantee that the service can save a whole video screen in each supported buffer for a single unit. An exception is raised when all the buffer memory has been allocated for a specific unit.

The source area is defined by the row, column, height, and width parameters. The video region can be restored to the screen by calling the RestoreVideoRegion method. If SaveVideoRegion is called two times with the same bufferId, the previous video data is lost, and any allocated memory is returned to the system.

SaveVideoRegion is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

SaveVideoRegion may cause a PosControlException to be thrown with the following ErrorCode:

Value | Description
Illegal | bufferId, row, column, height, or width is out of range. The ErrorUnits and ErrorString properties are updated.
ExtendedErrorNoBuffers | Requested buffer exceeds the number of SystemVideoSaveBuffers.
ExtendedErrorNoRoom | All the buffer memory has been allocated for a specific unit. The ErrorUnits and ErrorString properties are updated.
Failure | An error occurred while communicating with one of the video units specified by units. The ErrorUnits and ErrorString properties are updated before return. (Can only occur if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
AsyncMode
ErrorString
ErrorUnits
SystemVideoSaveBuffers
VideoSaveBuffers
RemoteOrderDisplay.RestoreVideoRegion Method


RemoteOrderDisplay.SelectCharacterSet Method

RemoteOrderDisplay.SelectCharacterSet Method |
 | See Also

1/18/2008

Selects a compatible character set for the specified video unit(s).

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub SelectCharacterSet ( _
    units As DeviceUnits, _
    characterSet As Integer _
)
public abstract void SelectCharacterSet (
    DeviceUnits units,
    int characterSet
)
public:
virtual void SelectCharacterSet (
    DeviceUnits units,
    int characterSet
) abstract
public abstract void SelectCharacterSet (
    DeviceUnits units,
    int characterSet
)
public abstract function SelectCharacterSet (
    units : DeviceUnits,
    characterSet : int
)

Parameters

units

The units to operate on.

characterSet

The character set for displaying characters.

Remarks

The character set number is one of the following ranges or values:

Value | Description
Range 101 - 199 | A device-specific character set that does not match a code page, or the ASCII or Windows ANSI character sets.
Range 400 - 990 | Code page; matches one of the standard values.
Unicode | The character set supports UNICODE. The value of this constant is 997.
ASCII | The ASCII character set, supporting the ASCII characters between 20-hex and 7F-hex. The value of this constant is 998.
Windows | The Windows ANSI character set. The value of this constant is 999. This is exactly the same as the Windows code page 1252.
Range 1000 and higher | Windows code page; matches one of the standard values.

The CharacterSet property is updated for each video unit id that is successfully assigned a new character set.

SelectCharacterSet may cause a PosControlException to be thrown with the following ErrorCode:

Value | Description
Failure | An error occurred while communicating with one of the video units specified by units. The ErrorUnits and ErrorString properties are updated before return.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
CapSelectCharacterSet
CharacterSet
ErrorString
ErrorUnits


RemoteOrderDisplay.SetCursor Method

RemoteOrderDisplay.SetCursor Method |
 | See Also

1/18/2008

Updates the cursor position on the specified video unit(s).

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub SetCursor ( _
    units As DeviceUnits, _
    row As Integer, _
    column As Integer _
)
public abstract void SetCursor (
    DeviceUnits units,
    int row,
    int column
)
public:
virtual void SetCursor (
    DeviceUnits units,
    int row,
    int column
) abstract
public abstract void SetCursor (
    DeviceUnits units,
    int row,
    int column
)
public abstract function SetCursor (
    units : DeviceUnits,
    row : int,
    column : int
)

Parameters

units

The units to operate on.

row

Row to put the cursor on.

column

Column to put the cursor on.

Remarks

SetCursor may cause a PosControlException to be thrown with the following ErrorCode:

Value | Description
Failure | An error occurred while communicating with one of the video units specified by units. The ErrorUnits and ErrorString properties are updated before return.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
ErrorString
ErrorUnits


RemoteOrderDisplay.TransactionDisplay Method

RemoteOrderDisplay.TransactionDisplay Method |
 | See Also

1/18/2008

Enters or exits transaction mode for the specified video unit(s).

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub TransactionDisplay ( _
    units As DeviceUnits, _
    transactionFunction As RemoteOrderDisplayTransaction _
)
public abstract void TransactionDisplay (
    DeviceUnits units,
    RemoteOrderDisplayTransaction transactionFunction
)
public:
virtual void TransactionDisplay (
    DeviceUnits units,
    RemoteOrderDisplayTransaction transactionFunction
) abstract
public abstract void TransactionDisplay (
    DeviceUnits units,
    RemoteOrderDisplayTransaction transactionFunction
)
public abstract function TransactionDisplay (
    units : DeviceUnits,
    transactionFunction : RemoteOrderDisplayTransaction
)

Parameters

units

The units to operate on.

transactionFunction

Transaction control function.

Remarks

If transactionFunction is Transaction, then transaction mode is entered. Later calls to ClearVideo, ClearVideoRegion, CopyVideoRegion, DisplayData, DrawBox, RestoreVideoRegion, SaveVideoRegion, and UpdateVideoRegionAttribute will buffer the display data (either at the video unit or the service object, depending on the display capabilities) until TransactionDisplay is called by using the transactionFunction parameter set to Normal. (In this case, the display methods only validate the method parameters and buffer the data. They do not start displaying. Also, the value of the AsyncMode property does not affect their operation: No OutputID is assigned to the request, nor will an OutputCompleteEvent event be raised.)

If transactionFunction is Normal, then transaction mode is exited. If some data was buffered by calls to the ClearVideo, ClearVideoRegion, CopyVideoRegion, DisplayData, DrawBox, RestoreVideoRegion, SaveVideoRegion, and UpdateVideoRegionAttribute methods, then the buffered data is displayed. The transaction is treated as one message.

TransactionDisplay is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

Calling the ClearOutput method cancels transaction mode for the unit specified by the CurrentUnitId property. Any buffered print lines are also cleared.

TransactionDisplay may cause a PosControlException to be thrown with the following ErrorCode:

Value | Description
Busy | Cannot perform while output is in progress for one of the video units indicated in units. The ErrorUnits and ErrorString properties are updated. (Can only occur if AsyncMode is false and function is Normal.)
Failure | An error occurred while communicating with one of the video units specified by units. The ErrorUnits and ErrorString properties are updated before return.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
RemoteOrderDisplay.ClearVideo Method
RemoteOrderDisplay.ClearVideoRegion Method
RemoteOrderDisplay.CopyVideoRegion Method
RemoteOrderDisplay.DisplayData Method
RemoteOrderDisplay.DrawBox Method
RemoteOrderDisplay.RestoreVideoRegion Method
RemoteOrderDisplay.SaveVideoRegion Method
UpdateVideoRegionAttribute


RemoteOrderDisplay.UpdateVideoRegionAttribute Method

RemoteOrderDisplay.UpdateVideoRegionAttribute Method |
 | See Also

1/18/2008

Modifies the attribute on the specified video unit(s).

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub UpdateVideoRegionAttribute ( _
    units As DeviceUnits, _
    attributeFunction As VideoAttributeCommand, _
    column As Integer, _
    height As Integer, _
    width As Integer, _
    attribute As VideoAttributes _
)
public abstract void UpdateVideoRegionAttribute (
    DeviceUnits units,
    VideoAttributeCommand attributeFunction,
    int column,
    int height,
    int width,
    VideoAttributes attribute
)
public:
virtual void UpdateVideoRegionAttribute (
    DeviceUnits units,
    VideoAttributeCommand attributeFunction,
    int column,
    int height,
    int width,
    VideoAttributes attribute
) abstract
public abstract void UpdateVideoRegionAttribute (
    DeviceUnits units,
    VideoAttributeCommand attributeFunction,
    int column,
    int height,
    int width,
    VideoAttributes attribute
)
public abstract function UpdateVideoRegionAttribute (
    units : DeviceUnits,
    attributeFunction : VideoAttributeCommand,
    column : int,
    height : int,
    width : int,
    attribute : VideoAttributes
)

Parameters

units

The units to operate on.

attributeFunction

The attribute command.

column

The region’s start column.

height

The number of rows in the region.

width

The number of columns in the region.

attribute

The video attribute to use.

Remarks

When the attributeFunction parameter is set, the region's attributes are replaced with the new value in the attribute parameter; otherwise the attribute parameter is ignored and the region's attributes are modified.

The UpdateVideoRegionAttribute method is performed synchronously if the AsyncMode property is false, and asynchronously if the AsyncMode property is true.

UpdateVideoRegionAttribute may cause a PosControlException exception to be thrown with the following ErrorCode:

Value | Description
Failure | An error occurred while communicating with one of the video units specified by units. The ErrorUnits and ErrorString properties are updated before return. (Can only occur if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
AsyncMode
ErrorString
ErrorUnits


RemoteOrderDisplay.VideoSound Method

RemoteOrderDisplay.VideoSound Method |
 | See Also

1/18/2008

Sounds the video enunciator for the specified units.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub VideoSound ( _
    units As DeviceUnits, _
    frequency As Integer, _
    duration As Integer, _
    numberOfCycles As Integer, _
    interSoundWait As Integer _
)
public abstract void VideoSound (
    DeviceUnits units,
    int frequency,
    int duration,
    int numberOfCycles,
    int interSoundWait
)
public:
virtual void VideoSound (
    DeviceUnits units,
    int frequency,
    int duration,
    int numberOfCycles,
    int interSoundWait
) abstract
public abstract void VideoSound (
    DeviceUnits units,
    int frequency,
    int duration,
    int numberOfCycles,
    int interSoundWait
)
public abstract function VideoSound (
    units : DeviceUnits,
    frequency : int,
    duration : int,
    numberOfCycles : int,
    interSoundWait : int
)

Parameters

units

The unit(s) to operate on.

frequency

Tone frequency in Hertz.

duration

Tone duration in milliseconds.

numberOfCycles

If WaitForever, then start tone sounding and, repeat continuously. Otherwise, perform the specified number of cycles.

interSoundWait

When numberOfCycles is not 1, then pause for interSoundWait milliseconds before repeating the tone cycle (that is, before playing the tone again).

Remarks

The duration of a video tone cycle is as follows:

duration parameter +

After the video has started an asynchronous sound, then the ClearOutput method stops the sound. (When an interSoundWait value of WaitForever is used to start the sound, then the application must use ClearOutput to stop the continuous sounding of tones.)

If the CapTone property is false for the selected unit(s), an Illegal exception is thrown.

VideoSound may cause a PosControlException exception to be thrown with the following ErrorCode:

Value

Description

Illegal

One of the following errors occurred:

  • numberOfCycles is not a positive, nonzero value or WaitForever.

  • numberOfCycles is WaitForever, when AsyncMode is false.

  • A negative interSoundWait was specified.

  • units is zero or a nonexistent unit was specified.

  • A unit in units does not support the CapTone capability.

  • The ErrorUnits and ErrorString properties may be updated before return.

Failure

An error occurred while communicating with one of the video units specified by units. The ErrorUnits and ErrorString properties are updated before return. (Can only occur if AsyncMode is false.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
AsyncMode
CapTone
RemoteOrderDisplay.ClearOutput Method
ErrorString
ErrorUnits


RemoteOrderDisplay Properties

RemoteOrderDisplay Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
AsyncMode | Gets or sets a Boolean value that indicates whether methods are performed asynchronously.
AutoToneDuration | Gets or sets the duration (in milliseconds) of the automatic tone for the video unit specified by the CurrentUnitId property.
AutoToneFrequency | Gets or sets the frequency (in Hertz) of the automatic tone for the video unit specified by the CurrentUnitId property.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapMapCharacterSet | Gets a Boolean value that indicates whether the service object can map characters to the character sets that are defined in CharacterSetList.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapSelectCharacterSet | Gets a Boolean value that indicates whether the video unit specified by the CurrentUnitId property can be loaded with an alternate, user-supplied character set.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapTone | Gets a Boolean value that indicates whether the video unit specified by the CurrentUnitId property supports an enunciator.
CapTouch | Gets a Boolean value that indicates whether the video unit specified by the CurrentUnitId property supports the TouchUp, TouchDown, and TouchMove event types.
CapTransaction | Gets a Boolean value that indicates whether transactions are supported by each video unit.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CharacterSet | Gets the character set for displaying characters for the video unit specified by the CurrentUnitId property.
CharacterSetList | Gets the character set for the video unit specified by the CurrentUnitId property.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Clocks | Gets the number of clocks the video unit, specified by the CurrentUnitId property, can support.
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
CurrentUnitId | Gets or sets the current video unit ID. Up to 32 units are allowed on one remote order display device. The unit ID definitions range from Unit1 to Unit32.
DataCount | Gets the total number of queued DataEvent events.
DataEventEnabled | Gets or sets a Boolean value that indicates whether a DataEvent event is delivered when input data is queued.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
ErrorString | Gets an error description that occurred to the video units.
ErrorUnits | Gets a bitwise mask of the video units that encountered an error.
EventString | Gets an error description for an error event.
EventType | Gets or sets event types.
EventUnitId | Gets a video unit ID.
EventUnits | Gets device unit(s).
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
MapCharacterSet | Gets or sets a Boolean value that indicates whether transferred characters are mapped to another character set.
OutputId | Gets the identifier of the most recently started asynchronous output.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )
SystemClocks | Gets the total number of clocks the remote order display device can support at one time.
SystemVideoSaveBuffers | Gets the total number of video save buffers the remote order display device can support at one time.
Timeout | Gets or sets the timeout value in milliseconds used by the remote order display device to complete all supported output methods.
UnitsOnline | Gets which video units are online.
VideoDataCount | Gets the number of DataEvent events queued for the video unit specified by the CurrentUnitId property.
VideoMode | Gets or sets the video Mode ID selected for the video unit specified by the CurrentUnitId property.
VideoModesList | Gets the video modes supported for the video unit specified by the CurrentUnitId property.
VideoSaveBuffers | Gets the number of save buffers for the video unit specified by the CurrentUnitId property.

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether the RemoteOrderDisplay is an exclusive-use device.

See Also

Reference

RemoteOrderDisplay Class
Microsoft.PointOfService Namespace


RemoteOrderDisplay.AsyncMode Property

RemoteOrderDisplay.AsyncMode Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether methods are performed asynchronously.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AsyncMode As Boolean
public abstract bool AsyncMode { get; set; }
public:
virtual property bool AsyncMode {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_AsyncMode ()

/** @property */
public abstract void set_AsyncMode (boolean value)

public abstract function get AsyncMode () : boolean

public abstract function set AsyncMode (value : boolean)

Remarks

If true, then the ClearVideo, ClearVideoRegion, CopyVideoRegion, DisplayData, DrawBox, RestoreVideoRegion, SaveVideoRegion, TransactionDisplay, UpdateVideoRegionAttribute, and VideoSound methods are performed asynchronously.

If false, they will be performed synchronously.

AsyncMode is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace


RemoteOrderDisplay.AutoToneDuration Property

RemoteOrderDisplay.AutoToneDuration Property |
 | See Also

1/18/2008

Gets or sets the duration (in milliseconds) of the automatic tone for the video unit specified by the CurrentUnitId property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AutoToneDuration As Integer
public abstract int AutoToneDuration { get; set; }
public:
virtual property int AutoToneDuration {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_AutoToneDuration ()

/** @property */
public abstract void set_AutoToneDuration (int value)

public abstract function get AutoToneDuration () : int

public abstract function set AutoToneDuration (value : int)

Remarks

AutoToneDuration is typically initialized to the default value for each online video unit when the device is first enabled by the service object. It should then be kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
CurrentUnitId


RemoteOrderDisplay.AutoToneFrequency Property

RemoteOrderDisplay.AutoToneFrequency Property |
 | See Also

1/18/2008

Gets or sets the frequency (in Hertz) of the automatic tone for the video unit specified by the CurrentUnitId property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AutoToneFrequency As Integer
public abstract int AutoToneFrequency { get; set; }
public:
virtual property int AutoToneFrequency {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_AutoToneFrequency ()

/** @property */
public abstract void set_AutoToneFrequency (int value)

public abstract function get AutoToneFrequency () : int

public abstract function set AutoToneFrequency (value : int)

Remarks

AutoToneFrequency is typically initialized to the default value for each online video unit. It should then be kept current by the service object while the device is enabled.

Accessing AutoToneFrequency may cause a PosControlException to be thrown with the following ErrorCode:

Value | Description
Illegal | An illegal value was specified. The ErrorString property is updated before return.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
CurrentUnitId


RemoteOrderDisplay.CapMapCharacterSet Property

RemoteOrderDisplay.CapMapCharacterSet Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the service object can map characters to the character sets that are defined in CharacterSetList.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapMapCharacterSet As Boolean
public abstract bool CapMapCharacterSet { get; }
public:
virtual property bool CapMapCharacterSet {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapMapCharacterSet ()

public abstract function get CapMapCharacterSet () : boolean

Remarks

CapMapCharacterSet defines the ability of the service object to map the characters of the application to the selected character set when displaying data.

CapMapCharacterSet is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
CharacterSet
CharacterSetList
MapCharacterSet


RemoteOrderDisplay.CapSelectCharacterSet Property

RemoteOrderDisplay.CapSelectCharacterSet Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the video unit specified by the CurrentUnitId property can be loaded with an alternate, user-supplied character set.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSelectCharacterSet As Boolean
public abstract bool CapSelectCharacterSet { get; }
public:
virtual property bool CapSelectCharacterSet {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapSelectCharacterSet ()

public abstract function get CapSelectCharacterSet () : boolean

Remarks

CapSelectCharacterSet is typically initialized to false for each video unit online. It should then be kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
CurrentUnitId


RemoteOrderDisplay.CapTone Property

RemoteOrderDisplay.CapTone Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the video unit specified by the CurrentUnitId property supports an enunciator.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapTone As Boolean
public abstract bool CapTone { get; }
public:
virtual property bool CapTone {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapTone ()

public abstract function get CapTone () : boolean

Remarks

CapTone is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
CurrentUnitId


RemoteOrderDisplay.CapTouch Property

RemoteOrderDisplay.CapTouch Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the video unit specified by the CurrentUnitId property supports the TouchUp, TouchDown, and TouchMove event types.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapTouch As Boolean
public abstract bool CapTouch { get; }
public:
virtual property bool CapTouch {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapTouch ()

public abstract function get CapTouch () : boolean

Remarks

CapTouch is set and updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
CurrentUnitId
DataEvent
RemoteOrderDisplayEventTypes


RemoteOrderDisplay.CapTransaction Property

RemoteOrderDisplay.CapTransaction Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether transactions are supported by each video unit.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapTransaction As Boolean
public abstract bool CapTransaction { get; }
public:
virtual property bool CapTransaction {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapTransaction ()

public abstract function get CapTransaction () : boolean

Remarks

CapTransaction is set and updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace


RemoteOrderDisplay.CharacterSet Property

RemoteOrderDisplay.CharacterSet Property |
 | See Also

1/18/2008

Gets the character set for displaying characters for the video unit specified by the CurrentUnitId property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CharacterSet As Integer
public abstract int CharacterSet { get; }
public:
virtual property int CharacterSet {
    int get () abstract;
}
/** @property */
public abstract int get_CharacterSet ()

public abstract function get CharacterSet () : int

Remarks

When CapSelectCharacterSet is true, CharacterSet can be set with one of the character set numbers found in the CharacterSetList property.

CharacterSet is typically initialized to the default video character set used by each video unit online. It should then be kept current by the service object while the device is enabled.

CharacterSet is updated during the SelectCharacterSet method.

The character set number is one of the following ranges or values:

Value | Description
Range 101 - 199 | A device-specific character set that does not match a code page, or the ASCII or Windows ANSI character sets.
Range 400 - 990 | Code page; matches one of the standard values.
Unicode | The character set supports UNICODE. The value of this constant is 997.
Ascii | The ASCII character set, supporting the ASCII characters between 20-hex and 7F-hex. The value of this constant is 998.
Windows | The Windows ANSI character set. The value of this constant is 999. This is exactly the same as the Windows code page 1252.
Range 1000 and higher | Windows code page; matches one of the standard values.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
RemoteOrderDisplay.CapSelectCharacterSet Property
CurrentUnitId
CharacterSetList
RemoteOrderDisplay.SelectCharacterSet Method


RemoteOrderDisplay.CharacterSetList Property

RemoteOrderDisplay.CharacterSetList Property |
 | See Also

1/18/2008

Gets the character set for the video unit specified by the CurrentUnitId property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CharacterSetList As Integer()
public abstract int[] CharacterSetList { get; }
public:
virtual property array<int>^ CharacterSetList {
    array<int>^ get () abstract;
}
/** @property */
public abstract int[] get_CharacterSetList ()

public abstract function get CharacterSetList () : int[]

Remarks

If CapSelectCharacterSet is true, CharacterSetList is initialized for each video unit online when the device is first enabled by the service object; otherwise, CharacterSetList is initialized with the string "[Error]".

The character set is identified by integer values separated by commas.

For example, if the integers are "101, 850, 999", the video unit supports a device-specific character set, code page 850, and the Windows ANSI character set.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
RemoteOrderDisplay.CapSelectCharacterSet Property
CurrentUnitId
RemoteOrderDisplay.CharacterSet Property
RemoteOrderDisplay.SelectCharacterSet Method


RemoteOrderDisplay.Clocks Property

RemoteOrderDisplay.Clocks Property |
 | See Also

1/18/2008

Gets the number of clocks the video unit, specified by the CurrentUnitId property, can support.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property Clocks As Integer
public abstract int Clocks { get; }
public:
virtual property int Clocks {
    int get () abstract;
}
/** @property */
public abstract int get_Clocks ()

public abstract function get Clocks () : int

Remarks

Clocks is set and updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
CurrentUnitId


RemoteOrderDisplay.CurrentUnitId Property

RemoteOrderDisplay.CurrentUnitId Property |
 | See Also

1/18/2008

Gets or sets the current video unit ID. Up to 32 units are allowed on one remote order display device. The unit ID definitions range from Unit1 to Unit32.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property CurrentUnitId As DeviceUnits
public abstract DeviceUnits CurrentUnitId { get; set; }
public:
virtual property DeviceUnits CurrentUnitId {
    DeviceUnits get () abstract;
    void set (DeviceUnits value) abstract;
}
/** @property */
public abstract DeviceUnits get_CurrentUnitId ()

/** @property */
public abstract void set_CurrentUnitId (DeviceUnits value)

public abstract function get CurrentUnitId () : DeviceUnits

public abstract function set CurrentUnitId (value : DeviceUnits)

Remarks

The following properties and methods apply only to the selected video unit ID:

Properties: AutoToneDuration, AutoToneFrequency, CapSelectCharacterSet, CapTone, CapTouch, CharacterSet, CharacterSetList, Clocks, VideoDataCount, VideoMode, VideoModesList, VideoSaveBuffers.

Setting CurrentUnitId updates these properties to the current values for the specified unit.

Methods: CheckHealth, ClearInput, ClearOutput.

CurrentUnitId is set and kept current by the service object while the device is enabled.

Accessing CurrentUnitID may cause a PosControlException to be thrown with the following ErrorCode:

Value | Description
Illegal | An illegal unit ID was specified. The ErrorString property is updated before return.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace


RemoteOrderDisplay.DataCount Property

RemoteOrderDisplay.DataCount Property |
 | See Also

1/18/2008

Gets the total number of queued DataEvent events.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DataCount As Integer
public abstract int DataCount { get; }
public:
virtual property int DataCount {
    int get () abstract;
}
/** @property */
public abstract int get_DataCount ()

public abstract function get DataCount () : int

Remarks

All units online are included in this value. The number of queued events for a specific unit ID is stored in the VideoDataCount property.

The application can interrogate DataCount to determine whether additional input is queued from a device, but has not yet been delivered because of other application processing, freezing of events, or other causes.

DataCount is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
DataEvent
VideoDataCount


RemoteOrderDisplay.DataEventEnabled Property

RemoteOrderDisplay.DataEventEnabled Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether a DataEvent event is delivered when input data is queued.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property DataEventEnabled As Boolean
public abstract bool DataEventEnabled { get; set; }
public:
virtual property bool DataEventEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_DataEventEnabled ()

/** @property */
public abstract void set_DataEventEnabled (boolean value)

public abstract function get DataEventEnabled () : boolean

public abstract function set DataEventEnabled (value : boolean)

Remarks

If true, a DataEvent is delivered as soon as input data is queued. If changed to true and some input data is already queued, then a DataEvent event is delivered immediately. (Notice that other conditions may delay "immediate" delivery: if FreezeEvents is true or another event is already being processed at the application, the DataEvent remains queued until the condition is corrected.)

If false, input data is queued for later delivery to the application. Also, if an input error occurs, the ErrorEvent is not delivered while this property is false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
DataEvent


RemoteOrderDisplay.ErrorString Property

RemoteOrderDisplay.ErrorString Property |
 | See Also

1/18/2008

Gets an error description that occurred to the video units.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ErrorString As String
public abstract string ErrorString { get; }
public:
virtual property String^ ErrorString {
    String^ get () abstract;
}
/** @property */
public abstract String get_ErrorString ()

public abstract function get ErrorString () : String

Remarks

When an error occurs for any method that acts on a bitwise set of video units, ErrorString is set to a description of the error that occurred to the unit(s) specified by the ErrorUnits property.

If an error occurs during processing of an asynchronous request, the ErrorEvent updates the EventString property instead.

ErrorString is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
ErrorUnits


RemoteOrderDisplay.ErrorUnits Property

RemoteOrderDisplay.ErrorUnits Property |
 | See Also

1/18/2008

Gets a bitwise mask of the video units that encountered an error.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ErrorUnits As DeviceUnits
public abstract DeviceUnits ErrorUnits { get; }
public:
virtual property DeviceUnits ErrorUnits {
    DeviceUnits get () abstract;
}
/** @property */
public abstract DeviceUnits get_ErrorUnits ()

public abstract function get ErrorUnits () : DeviceUnits

Remarks

When an error occurs for any method that acts on a bitwise set of video units, ErrorUnits contains a bitwise mask of the unit(s) that encountered an error.

If an error occurs during processing of an asynchronous request, the ErrorEvent updates the EventUnits property instead.

ErrorUnits is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
RemoteOrderDisplay.ErrorString Property


RemoteOrderDisplay.EventString Property

RemoteOrderDisplay.EventString Property |
 | See Also

1/18/2008

Gets an error description for an error event.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property EventString As String
public abstract string EventString { get; }
public:
virtual property String^ EventString {
    String^ get () abstract;
}
/** @property */
public abstract String get_EventString ()

public abstract function get EventString () : String

Remarks

When an ErrorEvent is delivered, EventString is set to a description of the error that occurred to the unit(s) specified by the EventUnits property.

EventString is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
ErrorEvent
EventUnits


RemoteOrderDisplay.EventType Property

RemoteOrderDisplay.EventType Property |
 | See Also

1/18/2008

Gets or sets event types.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property EventType As RemoteOrderDisplayEventTypes
public abstract RemoteOrderDisplayEventTypes EventType { get; set; }
public:
virtual property RemoteOrderDisplayEventTypes EventType {
    RemoteOrderDisplayEventTypes get () abstract;
    void set (RemoteOrderDisplayEventTypes value) abstract;
}
/** @property */
public abstract RemoteOrderDisplayEventTypes get_EventType ()

/** @property */
public abstract void set_EventType (RemoteOrderDisplayEventTypes value)

public abstract function get EventType () : RemoteOrderDisplayEventTypes

public abstract function set EventType (value : RemoteOrderDisplayEventTypes)

Remarks

EventType is used to selectively indicate which event types are to be raised by the DataEvent, for all video units online.

EventType is typically initialized to all defined event types. It should then be kept current by the service object while the device is enabled.

Accessing EventType may cause a PosControlException to be thrown with the following ErrorCode:

Value | Description
Illegal | An illegal event type value was specified. The ErrorString property is updated before return.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
DataEvent


RemoteOrderDisplay.EventUnitId Property

RemoteOrderDisplay.EventUnitId Property |
 | See Also

1/18/2008

Gets a video unit ID.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property EventUnitId As DeviceUnits
public abstract DeviceUnits EventUnitId { get; }
public:
virtual property DeviceUnits EventUnitId {
    DeviceUnits get () abstract;
}
/** @property */
public abstract DeviceUnits get_EventUnitId ()

public abstract function get EventUnitId () : DeviceUnits

Remarks

Just before the service object delivers a DataEvent to the application, it sets EventUnitId to the video unit ID causing the event.

EventUnitId is typically initialized to Unit1. It should then be kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace


RemoteOrderDisplay.EventUnits Property

RemoteOrderDisplay.EventUnits Property |
 | See Also

1/18/2008

Gets device unit(s).

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property EventUnits As DeviceUnits
public abstract DeviceUnits EventUnits { get; }
public:
virtual property DeviceUnits EventUnits {
    DeviceUnits get () abstract;
}
/** @property */
public abstract DeviceUnits get_EventUnits ()

public abstract function get EventUnits () : DeviceUnits

Remarks

When an OutputCompleteEvent, output ErrorEvent, or StatusUpdateEvent event is raised, the EventUnits property contains the unit(s).

The EventUnits property is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
OutputCompleteEvent
ErrorEvent


RemoteOrderDisplay.IsExclusiveUseDevice Property

RemoteOrderDisplay.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the RemoteOrderDisplay is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Remarks

A value of true indicates that the remote order display is exclusive-use, while a value of false indicates that it is not.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace


RemoteOrderDisplay.MapCharacterSet Property

RemoteOrderDisplay.MapCharacterSet Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether transferred characters are mapped to another character set.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property MapCharacterSet As Boolean
public abstract bool MapCharacterSet { get; set; }
public:
virtual property bool MapCharacterSet {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_MapCharacterSet ()

/** @property */
public abstract void set_MapCharacterSet (boolean value)

public abstract function get MapCharacterSet () : boolean

public abstract function set MapCharacterSet (value : boolean)

Remarks

If MapCharacterSet is true when outputting data, the service object maps the characters transferred by the application to the character set selected in the CharacterSet property for displaying data.

If MapCharacterSet is false, then no mapping is supported. In such a case, the application has to guarantee the mapping of the character set used in the application to the character set selected in the CharacterSet property.

If CapMapCharacterSet is false, then MapCharacterSet is always false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
RemoteOrderDisplay.CapMapCharacterSet Property
RemoteOrderDisplay.CharacterSet Property


RemoteOrderDisplay.OutputId Property

RemoteOrderDisplay.OutputId Property |
 | See Also

1/18/2008

Gets the identifier of the most recently started asynchronous output.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property OutputId As Integer
public abstract int OutputId { get; }
public:
virtual property int OutputId {
    int get () abstract;
}
/** @property */
public abstract int get_OutputId ()

public abstract function get OutputId () : int

Remarks

When a method successfully starts an asynchronous output, the device assigns an identifier to the request. When the output is complete, an OutputCompleteEvent is queued with this output ID as a parameter.

The output ID numbers are assigned by POS for .NET and are guaranteed to be unique among the set of outstanding asynchronous outputs. No other facts about the ID should be assumed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
OutputCompleteEvent


RemoteOrderDisplay.SystemClocks Property

RemoteOrderDisplay.SystemClocks Property |
 | See Also

1/18/2008

Gets the total number of clocks the remote order display device can support at one time.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property SystemClocks As Integer
public abstract int SystemClocks { get; }
public:
virtual property int SystemClocks {
    int get () abstract;
}
/** @property */
public abstract int get_SystemClocks ()

public abstract function get SystemClocks () : int

Remarks

SystemClocks is set and updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
RemoteOrderDisplay.Clocks Property


RemoteOrderDisplay.SystemVideoSaveBuffers Property

RemoteOrderDisplay.SystemVideoSaveBuffers Property |
 | See Also

1/18/2008

Gets the total number of video save buffers the remote order display device can support at one time.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property SystemVideoSaveBuffers As Integer
public abstract int SystemVideoSaveBuffers { get; }
public:
virtual property int SystemVideoSaveBuffers {
    int get () abstract;
}
/** @property */
public abstract int get_SystemVideoSaveBuffers ()

public abstract function get SystemVideoSaveBuffers () : int

Remarks

SystemVideoSaveBuffers is set and updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
VideoSaveBuffers


RemoteOrderDisplay.Timeout Property

RemoteOrderDisplay.Timeout Property |
 | See Also

1/18/2008

Gets or sets the timeout value in milliseconds used by the remote order display device to complete all supported output methods.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property Timeout As Integer
public abstract int Timeout { get; set; }
public:
virtual property int Timeout {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_Timeout ()

/** @property */
public abstract void set_Timeout (int value)

public abstract function get Timeout () : int

public abstract function set Timeout (value : int)

Remarks

If the device is unable to complete an output method within the timeout value, then the method returns a failure status if AsyncMode is false, or queues an ErrorEvent if AsyncMode is true.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
RemoteOrderDisplay.AsyncMode Property


RemoteOrderDisplay.UnitsOnline Property

RemoteOrderDisplay.UnitsOnline Property |
 | See Also

1/18/2008

Gets which video units are online.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property UnitsOnline As DeviceUnits
public abstract DeviceUnits UnitsOnline { get; }
public:
virtual property DeviceUnits UnitsOnline {
    DeviceUnits get () abstract;
}
/** @property */
public abstract DeviceUnits get_UnitsOnline ()

public abstract function get UnitsOnline () : DeviceUnits

Remarks

UnitsOnline is typically initialized to Unit1. UnitsOnline is updated as changes are detected, such as before a StatusUpdateEvent event is raised and during the CheckHealth method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace


RemoteOrderDisplay.VideoDataCount Property

RemoteOrderDisplay.VideoDataCount Property |
 | See Also

1/18/2008

Gets the number of DataEvent events queued for the video unit specified by the CurrentUnitId property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property VideoDataCount As Integer
public abstract int VideoDataCount { get; }
public:
virtual property int VideoDataCount {
    int get () abstract;
}
/** @property */
public abstract int get_VideoDataCount ()

public abstract function get VideoDataCount () : int

Remarks

An application can interrogate VideoDataCount to determine whether additional input is queued by a video unit, but has not yet been delivered because of other application processing, freezing of events, or other causes.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
RemoteOrderDisplay.CurrentUnitId Property
DataEvent


RemoteOrderDisplay.VideoMode Property

RemoteOrderDisplay.VideoMode Property |
 | See Also

1/18/2008

Gets or sets the video Mode ID selected for the video unit specified by the CurrentUnitId property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property VideoMode As Integer
public abstract int VideoMode { get; set; }
public:
virtual property int VideoMode {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_VideoMode ()

/** @property */
public abstract void set_VideoMode (int value)

public abstract function get VideoMode () : int

public abstract function set VideoMode (value : int)

Remarks

The Mode ID represents one of the selections in the VideoModesList property.

VideoMode is typically initialized to the service object-dependent default video Mode ID used by each video unit online.

Accessing VideoMode may cause a PosControlException to be thrown with the following ErrorCode:

Value | Description
Illegal | The desired video mode is not supported. The ErrorString property is updated before return.
Failure | An error occurred while communicating with the video unit specified by the CurrentUnitId property. The ErrorString property is updated before return.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
RemoteOrderDisplay.CurrentUnitId Property
VideoModesList


RemoteOrderDisplay.VideoModesList Property

RemoteOrderDisplay.VideoModesList Property |
 | See Also

1/18/2008

Gets the video modes supported for the video unit specified by the CurrentUnitId property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property VideoModesList As VideoMode()
public abstract VideoMode[] VideoModesList { get; }
public:
virtual property array<VideoMode>^ VideoModesList {
    array<VideoMode>^ get () abstract;
}
/** @property */
public abstract VideoMode[] get_VideoModesList ()

public abstract function get VideoModesList () : VideoMode[]

Remarks

The Mode ID values are determined by the remote order display system. The Mode ID is used to initialize the VideoMode property for each video unit online.

VideoModesList is typically initialized to the video modes list supported by each video unit online when the device is first enabled. It should then be kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
RemoteOrderDisplay.CurrentUnitId Property
RemoteOrderDisplay.VideoMode Property


RemoteOrderDisplay.VideoSaveBuffers Property

RemoteOrderDisplay.VideoSaveBuffers Property |
 | See Also

1/18/2008

Gets the number of save buffers for the video unit specified by the CurrentUnitId property.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property VideoSaveBuffers As Integer
public abstract int VideoSaveBuffers { get; }
public:
virtual property int VideoSaveBuffers {
    int get () abstract;
}
/** @property */
public abstract int get_VideoSaveBuffers ()

public abstract function get VideoSaveBuffers () : int

Remarks

VideoSaveBuffers should be consulted when using the SaveVideoRegion, RestoreVideoRegion and FreeVideoRegion methods. When set to 0, this indicates that buffering for the selected unit is not supported. When VideoSaveBuffers is greater than 0, the remote order display device can save at least one whole video screen for the selected video unit.

VideoSaveBuffers is initialized for each video unit online when the device is first enabled following the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
RemoteOrderDisplay.CurrentUnitId Property
RemoteOrderDisplay.FreeVideoRegion Method
RemoteOrderDisplay.SaveVideoRegion Method
RemoteOrderDisplay.RestoreVideoRegion Method


RemoteOrderDisplay Events

RemoteOrderDisplay Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DataEvent | Notifies the application when input data from a video touch unit is available.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
ErrorEvent | Notifies the application that a remote order display error has been detected and a suitable response by the application is necessary to process the error condition.
OutputCompleteEvent | Notifies the application that the queued output request associated with the OutputID property has completed successfully.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

RemoteOrderDisplay Class
Microsoft.PointOfService Namespace


RemoteOrderDisplay.DataEvent Event

RemoteOrderDisplay.DataEvent Event |
 | See Also

1/18/2008

Notifies the application when input data from a video touch unit is available.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event DataEvent As DataEventHandler
public abstract event DataEventHandler DataEvent
public:
virtual event DataEventHandler^ DataEvent {
    void add (DataEventHandler^ value) abstract;
    void remove (DataEventHandler^ value) abstract;
}
/** @event */
public abstract void add_DataEvent (DataEventHandler value)

/** @event */
public abstract void remove_DataEvent (DataEventHandler value)

Remarks

The DataEventArgs.Status property is divided into four bytes. Status is divided as follows: The high word high byte is the row, the high word low byte is the column. The low word is the event type (for example, TouchUp, TouchDown, TouchMove).

The high word contains additional data depending on the event type. When the event type is TouchUp, TouchDown, or TouchMove, the high word indicates where the touch occurred. The low byte contains the column position and the high byte contains the row position, with valid values ranging from 0-255.

Data events can be filtered at the remote order display device by setting the EventType property. The EventUnitID property is updated before the event is delivered.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
RemoteOrderDisplay.DataEventEnabled Property
RemoteOrderDisplay.EventUnitId Property
PosCommon.FreezeEvents Property


RemoteOrderDisplay.ErrorEvent Event

RemoteOrderDisplay.ErrorEvent Event |
 | See Also

1/18/2008

Notifies the application that a remote order display error has been detected and a suitable response by the application is necessary to process the error condition.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event ErrorEvent As DeviceErrorEventHandler
public abstract event DeviceErrorEventHandler ErrorEvent
public:
virtual event DeviceErrorEventHandler^ ErrorEvent {
    void add (DeviceErrorEventHandler^ value) abstract;
    void remove (DeviceErrorEventHandler^ value) abstract;
}
/** @event */
public abstract void add_ErrorEvent (DeviceErrorEventHandler value)

/** @event */
public abstract void remove_ErrorEvent (DeviceErrorEventHandler value)

Remarks

The DeviceErrorEventArgs.ErrorLocus property can be one of the following:

Value | Description
Input | Error occurred while collecting or processing event-driven input. No input data is available.
InputData | Error occurred while collecting or processing event-driven input, and some previously buffered data is available.
Output | Error occurred while processing asynchronous output.

The DeviceErrorEventArgs.ErrorResponse property is preset by the service object to a default value, based on the DeviceErrorEventArgs.ErrorLocus. The application can change it to one of the following:

Value | Description
Clear | Clear all buffered output data (including all asynchronous output) or buffered input data. The error state is exited. Default when locus is Input.
ContinueInput | Use only when locus is InputData. Acknowledges the error and directs the service object to continue to process. The service object remains in the error state and will deliver additional DataEvent events as directed by the DataEventEnabled property. When all input has been delivered and the DataEventEnabled property is again set to true, then another ErrorEvent is delivered with locus Input. Default when locus is InputData.
Retry | Use only when locus is Output. Retry the asynchronous output. The error state is exited. Default when locus is Output.

Input error events are not delivered until the DataEventEnabled property is true so that correct application sequencing occurs.

The EventUnits and EventString properties are updated before the event is delivered.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
RemoteOrderDisplay.DataEventEnabled Property
RemoteOrderDisplay.EventUnits Property
RemoteOrderDisplay.EventString Property


RemoteOrderDisplay.OutputCompleteEvent Event

RemoteOrderDisplay.OutputCompleteEvent Event |
 | See Also

1/18/2008

Notifies the application that the queued output request associated with the OutputID property has completed successfully.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event OutputCompleteEvent As OutputCompleteEventHandler
public abstract event OutputCompleteEventHandler OutputCompleteEvent
public:
virtual event OutputCompleteEventHandler^ OutputCompleteEvent {
    void add (OutputCompleteEventHandler^ value) abstract;
    void remove (OutputCompleteEventHandler^ value) abstract;
}
/** @event */
public abstract void add_OutputCompleteEvent (OutputCompleteEventHandler value)

/** @event */
public abstract void remove_OutputCompleteEvent (OutputCompleteEventHandler value)

Remarks

Queued when a previously started asynchronous output request is completed successfully. The EventUnits property is updated before the event is delivered.

See Also

Reference

RemoteOrderDisplay Class
RemoteOrderDisplay Members
Microsoft.PointOfService Namespace
RemoteOrderDisplay.EventUnits Property


RemoteOrderDisplayEventTypes Enumeration

RemoteOrderDisplayEventTypes Enumeration |
 | See Also

1/18/2008

Lists the possible event types for touch video input on a Remote Order Display device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration RemoteOrderDisplayEventTypes
[FlagsAttribute]
public enum RemoteOrderDisplayEventTypes
[FlagsAttribute]
public enum class RemoteOrderDisplayEventTypes
/** @attribute FlagsAttribute() */
public enum RemoteOrderDisplayEventTypes
FlagsAttribute
public enum RemoteOrderDisplayEventTypes

Members

Member name | Description
TouchDown | Touch occurred in the down direction.
TouchMove | Touch direction moved.
TouchUp | Touch occurred in the up direction.

Remarks

Used by the EventType and CapTouch properties. Members of this enumeration replace the ROD_DE_TOUCH_UP, ROD_DE_TOUCH_DOWN, and ROD_DE_TOUCH_MOVE UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
RemoteOrderDisplay.CapTouch Property
RemoteOrderDisplay.DataEvent Event


RemoteOrderDisplayTransaction Enumeration

RemoteOrderDisplayTransaction Enumeration |
 | See Also

1/18/2008

Lists the possible transaction control functions for a Remote Order Display device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration RemoteOrderDisplayTransaction
public enum RemoteOrderDisplayTransaction
public enum class RemoteOrderDisplayTransaction
public enum RemoteOrderDisplayTransaction
public enum RemoteOrderDisplayTransaction

Members

Member name | Description
Normal | End a transaction by displaying the buffered data.
Transaction | Begin a transaction.

Remarks

Used by the TransactionDisplay method. Members of this enumeration replace the ROD_TD_TRANSACTION and ROD_TD_NORMAL UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
RemoteOrderDisplay.TransactionDisplay Method


ReportType Enumeration

ReportType Enumeration |
 | See Also

1/18/2008

Lists all report types used in POS for .NET.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration ReportType
public enum ReportType
public enum class ReportType
public enum ReportType
public enum ReportType

Members

Member name | Description
Date | Prints a report between two fiscal memory record numbers.
EndOfDayOrdinal | Prints a report between two dates.
Ordinal | Prints a report between two reports specified by report number.

Remarks

The UPOS specification includes an enumeration of values to be used when invoking the PrintReport method.

In Point of Service for .NET 1.11, these enumeration values have been eliminated. Instead, the reportType parameter has been eliminated, and two new overloaded, type-safe, versions of PrintReport have been added.

See Also

Reference

Microsoft.PointOfService Namespace
FiscalPrinter.PrintReport Method


RFIDProtocols Enumeration

RFIDProtocols Enumeration |
 | See Also

1/18/2008

Enumerates the available predefined RFID tag protocols the device supports.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration RFIDProtocols
[FlagsAttribute]
public enum RFIDProtocols
[FlagsAttribute]
public enum class RFIDProtocols
/** @attribute FlagsAttribute() */
public enum RFIDProtocols
FlagsAttribute
public enum RFIDProtocols

Members

Member name | Description
All | All protocol tags.
EpcClass0 | EPC class 0 read-only passive tags.
EpcClass1 | EPC class 1 write once passive tags.
EpcClass1Gen2 | EPC class 1 gen 2 (ISO 18000-6C) write-once passive tags.
EpcClass2 | EPC class 2 rewritable tags.
Iso14443A | ISO 14443A HF tags.
Iso14443B | ISO 14443B HF tags.
Iso15693 | ISO 15693 HF tags.
Iso180006B | ISO 18000-6B UHF tags.
Other | A tag that does not fit into one of the defined protocols.
RFIDSdt0Plus | Non-standard EPC class "0+" write-once passive tags.

Remarks

If the device supports more than one of these protocols, the value of this property is the bitwise logical OR combination of the values of the supported protocols.

Based on this property, ProtocolMask can additionally filter the tags it wants to exclude by turning off the bits.

This property is initialized by the Open method.

See Also

Reference

Microsoft.PointOfService Namespace


RFIDReadOptions Enumeration

RFIDReadOptions Enumeration |
 | See Also

1/18/2008

Enumerates the tags within range that meet a parameterized criteria.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration RFIDReadOptions
[FlagsAttribute]
public enum RFIDReadOptions
[FlagsAttribute]
public enum class RFIDReadOptions
/** @attribute FlagsAttribute() */
public enum RFIDReadOptions
FlagsAttribute
public enum RFIDReadOptions

Members

Member name | Description
FullUserData | Reads the full UserData.
IdAndFullUserData | Reads the ID and full UserData.
IdAndPartialUserData | Reads the ID and the defined partial UserData.
PartialUserData | Reads the defined partial UserData.
TagId | Reads only the ID data.

Remarks

A DataEvent or an ErrorEvent event has to be received before another ReadTags method call.

See Also

Reference

Microsoft.PointOfService Namespace


RFIDScanner Class

RFIDScanner Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for an RFID Scanner device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class RFIDScanner
    Inherits PosCommon
public abstract class RFIDScanner : PosCommon
public ref class RFIDScanner abstract : public PosCommon
public abstract class RFIDScanner extends PosCommon
public abstract class RFIDScanner extends PosCommon

Remarks

Required Version

The RFIDScanner class requires POS for .NET version 1.12 or later versions.

Capabilities

The RFID Scanner device has the following capabilities:

  • Reads TagID and UserData from RFID tags

  • Reads partial UserData

The RFID Scanner device may also support the following capabilities:

  • Continuously reads tags

  • Writes TagID to RFID tags

  • Locks a tag

  • Writes UserData to specified RFID tags

  • Disables (kills) RFID tags

  • Writes partial UserData

Programming Model

The RFID Scanner is both an event-driven input device and an output device. Input and output are always asynchronous. The tag is considered to consist of contiguous fields called the TagID and the UserData. This present standard does not currently define the TagID or UserData fields. They are determined in a device-specific manner by the RFID Scanner Service and may vary depending on the protocol property setting.

Device Sharing

The RFID Scanner is an exclusive-use device, as follows:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before accessing many of the RFID Scanner-specific properties.

  • The application must claim and enable the device before it calls methods that manipulate the device.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.RFIDScanner
Microsoft.PointOfService.BasicServiceObjects.RFIDScannerBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner Members

RFIDScanner Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for an RFID Scanner device.

The following tables list the members exposed by the RFIDScanner type.

Protected Constructors

Name | Description
RFIDScanner | Creates an instance of the RFIDScanner class.
Top

Public Fields

Name | Description
ExtendedErrorAntennaFailure | Indicates if the RF antenna is in a state of failure.
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFailedTagDisableCount | Contains the count of failed tag disable attempts.
StatisticFailedTagLockCount | Contains the count of failed tag lock attempts.
StatisticFailedTagWriteCount | Contains the count of failed tag write attempts.
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticGoodTagDisableCount | Contains the count of successful tag disable attempts.
StatisticGoodTagLockCount | Contains the count of successful tag lock attempts.
StatisticGoodTagWriteCount | Contains the count of successful tag write attempts.
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticTagReadCount | Contains the count of read tags.
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusExcessNoise | Indicates the RFIDScanner device is experiencing excess noise.
StatusLowMemory | Indicates the RFIDScanner device is low on memory.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
AutoDisable | Gets or sets a Boolean value that indicates whether the device automatically disables itself when a DataEvent event is enqueued.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapContinuousRead | Gets a Boolean value that indicates whether the device supports continuous reading.
CapDisableTag | Gets a Boolean value that indicates whether the device supports disabling a tag permanently.
CapLockTag | Gets a Boolean value that indicates whether this reader supports locking a tag.
CapMultipleProtocols | Gets a value that indicates the available predefined RFID tag protocols this device supports.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapReadTimer | Gets a Boolean value that indicates whether the device supports a read timer.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CapWriteTag | Gets a flag that indicates if the Tag ID and Tag UserData fields are writable.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
ContinuousReadMode | Gets a Boolean value that indicates whether the device is in Continuous Read mode.
CurrentTagId | Gets the TagId of the present tag.
CurrentTagProtocol | Gets the protocol that this tag was read through.
CurrentTagUserData | Gets the data that is read from the physical tag.
DataCount | Gets the number of DataEvent events enqueued by the device.
DataEventEnabled | Gets or sets a Boolean value that indicates whether the application is ready to receive input from the device.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
OutputId | Gets the integer value that indicates the ID number of the completed asynchronous output request.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
ProtocolMask | Gets or sets a bit pattern wherein each bit signifies one predefined RFID tag protocol.
ReadTimerInterval | Gets or sets the integer value that indicates the minimum time interval between tag reads in milliseconds.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
TagCount | Gets the integer value that indicates the total number of tags read by the corresponding read operation.
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether the RFIDScanner is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears the data and input error events.
ClearInputProperties | Clears all data properties and sets them to their default values.
ClearOutput | Clears the data and output error events.
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
DisableTag | Permanently disables the specific tag matching the tagID parameter.
Equals | Overloaded. (inherited from Object )
FirstTag | Resets the service’s counter to the first tag in the tag list, and copies that tag’s information into the corresponding properties.
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
LockTag | Turns the tag into a read-only mode.
NextTag | Moves the service’s counter to the next tag in the tag list, and copies that tag’s information into the corresponding properties.
Open | Opens a device for later input/output processing. (inherited from PosCommon)
PreviousTag | Moves the service’s counter to the previous tag in the tag list, and copies that tag’s information into the corresponding properties.
ReadTags | Performs a poll of all the tags within range that meet the parameterized criteria.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
StartReadTags | Performs a continuous polling of tags that meet the parameterized criteria.
StopReadTags | Stops the Continuous Read mode.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
WriteTagData | Overwrites the entire or part of the UserData field of targeted tag.
WriteTagId | Overwrites the existing tag ID with a new ID.
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DataEvent | Notifies the application that input data from the RFID Scanner is available.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
ErrorEvent | Notifies the application that an RFID Scanner device error has been detected and a suitable response by the application is necessary to process the error condition.
OutputCompleteEvent | Notifies the application that the queued output request associated with the OutputId attribute has completed successfully.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

RFIDScanner Class
Microsoft.PointOfService Namespace


RFIDScanner Fields

RFIDScanner Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorAntennaFailure | Indicates if the RF antenna is in a state of failure.
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFailedTagDisableCount | Contains the count of failed tag disable attempts.
StatisticFailedTagLockCount | Contains the count of failed tag lock attempts.
StatisticFailedTagWriteCount | Contains the count of failed tag write attempts.
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticGoodTagDisableCount | Contains the count of successful tag disable attempts.
StatisticGoodTagLockCount | Contains the count of successful tag lock attempts.
StatisticGoodTagWriteCount | Contains the count of successful tag write attempts.
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticTagReadCount | Contains the count of read tags.
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusExcessNoise | Indicates the RFIDScanner device is experiencing excess noise.
StatusLowMemory | Indicates the RFIDScanner device is low on memory.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

RFIDScanner Class
Microsoft.PointOfService Namespace


RFIDScanner.ExtendedErrorAntennaFailure Field

RFIDScanner.ExtendedErrorAntennaFailure Field |
 | See Also

1/18/2008

Indicates if the RF antenna is in a state of failure.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorAntennaFailure As Integer
public const int ExtendedErrorAntennaFailure
public:
literal int ExtendedErrorAntennaFailure
public static final int ExtendedErrorAntennaFailure
public const var ExtendedErrorAntennaFailure : int

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.StatisticFailedTagDisableCount Field

RFIDScanner.StatisticFailedTagDisableCount Field |
 | See Also

1/18/2008

Contains the count of failed tag disable attempts.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticFailedTagDisableCount As String
public const string StatisticFailedTagDisableCount
public:
literal String^ StatisticFailedTagDisableCount
public static final String StatisticFailedTagDisableCount
public const var StatisticFailedTagDisableCount : String

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.StatisticFailedTagLockCount Field

RFIDScanner.StatisticFailedTagLockCount Field |
 | See Also

1/18/2008

Contains the count of failed tag lock attempts.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticFailedTagLockCount As String
public const string StatisticFailedTagLockCount
public:
literal String^ StatisticFailedTagLockCount
public static final String StatisticFailedTagLockCount
public const var StatisticFailedTagLockCount : String

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.StatisticFailedTagWriteCount Field

RFIDScanner.StatisticFailedTagWriteCount Field |
 | See Also

1/18/2008

Contains the count of failed tag write attempts.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticFailedTagWriteCount As String
public const string StatisticFailedTagWriteCount
public:
literal String^ StatisticFailedTagWriteCount
public static final String StatisticFailedTagWriteCount
public const var StatisticFailedTagWriteCount : String

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.StatisticGoodTagDisableCount Field

RFIDScanner.StatisticGoodTagDisableCount Field |
 | See Also

1/18/2008

Contains the count of successful tag disable attempts.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticGoodTagDisableCount As String
public const string StatisticGoodTagDisableCount
public:
literal String^ StatisticGoodTagDisableCount
public static final String StatisticGoodTagDisableCount
public const var StatisticGoodTagDisableCount : String

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.StatisticGoodTagLockCount Field

RFIDScanner.StatisticGoodTagLockCount Field |
 | See Also

1/18/2008

Contains the count of successful tag lock attempts.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticGoodTagLockCount As String
public const string StatisticGoodTagLockCount
public:
literal String^ StatisticGoodTagLockCount
public static final String StatisticGoodTagLockCount
public const var StatisticGoodTagLockCount : String

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.StatisticGoodTagWriteCount Field

RFIDScanner.StatisticGoodTagWriteCount Field |
 | See Also

1/18/2008

Contains the count of successful tag write attempts.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticGoodTagWriteCount As String
public const string StatisticGoodTagWriteCount
public:
literal String^ StatisticGoodTagWriteCount
public static final String StatisticGoodTagWriteCount
public const var StatisticGoodTagWriteCount : String

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.StatisticTagReadCount Field

RFIDScanner.StatisticTagReadCount Field |
 | See Also

1/18/2008

Contains the count of read tags.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticTagReadCount As String
public const string StatisticTagReadCount
public:
literal String^ StatisticTagReadCount
public static final String StatisticTagReadCount
public const var StatisticTagReadCount : String

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.StatusExcessNoise Field

RFIDScanner.StatusExcessNoise Field |
 | See Also

1/18/2008

Indicates the RFIDScanner device is experiencing excess noise.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusExcessNoise As Integer
public const int StatusExcessNoise
public:
literal int StatusExcessNoise
public static final int StatusExcessNoise
public const var StatusExcessNoise : int

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.StatusLowMemory Field

RFIDScanner.StatusLowMemory Field |
 | See Also

1/18/2008

Indicates the RFIDScanner device is low on memory.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusLowMemory As Integer
public const int StatusLowMemory
public:
literal int StatusLowMemory
public static final int StatusLowMemory
public const var StatusLowMemory : int

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner Constructor

RFIDScanner Constructor |
 | See Also

1/18/2008

Creates an instance of the RFIDScanner class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected RFIDScanner ()
protected:
RFIDScanner ()
protected RFIDScanner ()
protected function RFIDScanner ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner Methods

RFIDScanner Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears the data and input error events.
ClearInputProperties | Clears all data properties and sets them to their default values.
ClearOutput | Clears the data and output error events.
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
DisableTag | Permanently disables the specific tag matching the tagID parameter.
Equals | Overloaded. (inherited from Object )
FirstTag | Resets the service’s counter to the first tag in the tag list, and copies that tag’s information into the corresponding properties.
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
LockTag | Turns the tag into a read-only mode.
NextTag | Moves the service’s counter to the next tag in the tag list, and copies that tag’s information into the corresponding properties.
Open | Opens a device for later input/output processing. (inherited from PosCommon )
PreviousTag | Moves the service’s counter to the previous tag in the tag list, and copies that tag’s information into the corresponding properties.
ReadTags | Performs a poll of all the tags within range that meet the parameterized criteria.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
StartReadTags | Performs a continuous polling of tags that meet the parameterized criteria.
StopReadTags | Stops the Continuous Read mode.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
WriteTagData | Overwrites the entire or part of the UserData field of targeted tag.
WriteTagId | Overwrites the existing tag ID with a new ID.

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

RFIDScanner Class
Microsoft.PointOfService Namespace


RFIDScanner.ClearInput Method

RFIDScanner.ClearInput Method |
 | See Also

1/18/2008

Clears the data and input error events.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearInput
public abstract void ClearInput ()
public:
virtual void ClearInput () abstract
public abstract void ClearInput ()
public abstract function ClearInput ()

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.ClearInputProperties Method

RFIDScanner.ClearInputProperties Method |
 | See Also

1/18/2008

Clears all data properties and sets them to their default values.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearInputProperties
public abstract void ClearInputProperties ()
public:
virtual void ClearInputProperties () abstract
public abstract void ClearInputProperties ()
public abstract function ClearInputProperties ()

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.ClearOutput Method

RFIDScanner.ClearOutput Method |
 | See Also

1/18/2008

Clears the data and output error events.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearOutput
public abstract void ClearOutput ()
public:
virtual void ClearOutput () abstract
public abstract void ClearOutput ()
public abstract function ClearOutput ()

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.DisableTag Method

RFIDScanner.DisableTag Method |
 | See Also

1/18/2008

Permanently disables the specific tag matching the tagID parameter.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub DisableTag ( _
    tagId As Byte(), _
    timeout As Integer, _
    password As Byte() _
)
public abstract void DisableTag (
    byte[] tagId,
    int timeout,
    byte[] password
)
public:
virtual void DisableTag (
    array<unsigned char>^ tagId,
    int timeout,
    array<unsigned char>^ password
) abstract
public abstract void DisableTag (
    byte[] tagId,
    int timeout,
    byte[] password
)
public abstract function DisableTag (
    tagId : byte[],
    timeout : int,
    password : byte[]
)

Parameters

tagId

The ID of the tag it is disabling.

timeout

Allowed execution time, in milliseconds, before the method fails and a time-out ErrorEvent is sent to the application. If WaitForever, the service waits as long as needed until either the operation is complete or an error occurs.

password

Authorized key for reader that might be required for this operation; null if not applicable.

Remarks

This method is always performed asynchronously and OutputId will be set on a successful start plus an OutputCompleteEvent event or an ErrorEvent event will be raised to indicate completion.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.FirstTag Method

RFIDScanner.FirstTag Method |
 | See Also

1/18/2008

Resets the service’s counter to the first tag in the tag list, and copies that tag’s information into the corresponding properties.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub FirstTag
public abstract void FirstTag ()
public:
virtual void FirstTag () abstract
public abstract void FirstTag ()
public abstract function FirstTag ()

Remarks

Used if the application has to reprocess the list of tags from its beginning. The method is synchronous, because no physical input or output occurs when it is called.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.LockTag Method

RFIDScanner.LockTag Method |
 | See Also

1/18/2008

Turns the tag into a read-only mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub LockTag ( _
    tagId As Byte(), _
    timeout As Integer, _
    password As Byte() _
)
public abstract void LockTag (
    byte[] tagId,
    int timeout,
    byte[] password
)
public:
virtual void LockTag (
    array<unsigned char>^ tagId,
    int timeout,
    array<unsigned char>^ password
) abstract
public abstract void LockTag (
    byte[] tagId,
    int timeout,
    byte[] password
)
public abstract function LockTag (
    tagId : byte[],
    timeout : int,
    password : byte[]
)

Parameters

tagId

The ID of the tag it is locking.

timeout

Allowed execution time, in milliseconds, before the method fails and a time-out ErrorEvent event is sent to the application. If WaitForever the service waits as long as needed until either the operation is complete or an error occurs.

password

Authorized key for reader that might be required for this operation, null if not applicable.

Remarks

Makes ID and UserData fields non-writable. If invoking this method with CapLockTag property being false, an exception is thrown.

This method is always performed asynchronously and the OutputId property will be set on a successful start plus an OutputCompleteEvent event or ErrorEvent event will be raised to indicate completion.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.NextTag Method

RFIDScanner.NextTag Method |
 | See Also

1/18/2008

Moves the service’s counter to the next tag in the tag list, and copies that tag’s information into the corresponding properties.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub NextTag
public abstract void NextTag ()
public:
virtual void NextTag () abstract
public abstract void NextTag ()
public abstract function NextTag ()

Remarks

Used in normal RFID read processing. The method is synchronous, because no physical input or output occurs when it is called, only memory-to-memory copies.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.PreviousTag Method

RFIDScanner.PreviousTag Method |
 | See Also

1/18/2008

Moves the service’s counter to the previous tag in the tag list, and copies that tag’s information into the corresponding properties.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub PreviousTag
public abstract void PreviousTag ()
public:
virtual void PreviousTag () abstract
public abstract void PreviousTag ()
public abstract function PreviousTag ()

Remarks

Used if the application has to process the list of tags in reverse order. The method is synchronous, because no physical input or output occurs when it is called, only memory-to-memory copies.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.ReadTags Method

RFIDScanner.ReadTags Method |
 | See Also

1/18/2008

Performs a poll of all the tags within range that meet the parameterized criteria.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ReadTags ( _
    cmd As RFIDReadOptions, _
    filterId As Byte(), _
    filterMask As Byte(), _
    start As Integer, _
    length As Integer, _
    timeout As Integer, _
    password As Byte() _
)
public abstract void ReadTags (
    RFIDReadOptions cmd,
    byte[] filterId,
    byte[] filterMask,
    int start,
    int length,
    int timeout,
    byte[] password
)
public:
virtual void ReadTags (
    RFIDReadOptions cmd,
    array<unsigned char>^ filterId,
    array<unsigned char>^ filterMask,
    int start,
    int length,
    int timeout,
    array<unsigned char>^ password
) abstract
public abstract void ReadTags (
    RFIDReadOptions cmd,
    byte[] filterId,
    byte[] filterMask,
    int start,
    int length,
    int timeout,
    byte[] password
)
public abstract function ReadTags (
    cmd : RFIDReadOptions,
    filterId : byte[],
    filterMask : byte[],
    start : int,
    length : int,
    timeout : int,
    password : byte[]
)

Parameters

cmd

Command parameters from

filterId

Holds a bit pattern to be AND-ed with filterMask to determine which tag(s) to read.

filterMask

Holds a value which is used to mask the filterID. If the bitwise AND matches the bitwise AND of a tagId and the filterMask, the tagId will be returned. To get all tags in the field, pass in a filterMask of 0.

start

Indicates the zero-based position within the tags UserData field to begin reading from. This parameter only applies when cmd is set to PartialUserData or IdAndPartialUserData. Otherwise, it is ignored.

length

Indicates the number of bytes of user data to read starting at the position indicated by the start parameter. This parameter only applies when cmd is set to PartialUserData or IdAndPartialUserData. Otherwise, it is ignored.

timeout

Allowed execution time, in milliseconds, before the method fails and a time-out ErrorEvent is sent to the application. If WaitForever, the service waits as long as needed until either the operation is complete or an error occurs.

password

Authorized key for reader that might be required for this operation; null if not applicable.

Remarks

A DataEvent event or an ErrorEvent event has to be received before another ReadTags method is called.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.StartReadTags Method

RFIDScanner.StartReadTags Method |
 | See Also

1/18/2008

Performs a continuous polling of tags that meet the parameterized criteria.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub StartReadTags ( _
    cmd As RFIDReadOptions, _
    filterId As Byte(), _
    filterMask As Byte(), _
    start As Integer, _
    length As Integer, _
    password As Byte() _
)
public abstract void StartReadTags (
    RFIDReadOptions cmd,
    byte[] filterId,
    byte[] filterMask,
    int start,
    int length,
    byte[] password
)
public:
virtual void StartReadTags (
    RFIDReadOptions cmd,
    array<unsigned char>^ filterId,
    array<unsigned char>^ filterMask,
    int start,
    int length,
    array<unsigned char>^ password
) abstract
public abstract void StartReadTags (
    RFIDReadOptions cmd,
    byte[] filterId,
    byte[] filterMask,
    int start,
    int length,
    byte[] password
)
public abstract function StartReadTags (
    cmd : RFIDReadOptions,
    filterId : byte[],
    filterMask : byte[],
    start : int,
    length : int,
    password : byte[]
)

Parameters

cmd

filterId

Holds a bit pattern to be AND-ed with filterMask to determine which tag(s) to read.

filterMask

Holds a value which is used to mask the filterID. If the bitwise AND matches the bitwise AND of a tagId and the filterMask, the tagId will be returned. To get all tags in the field, pass in a filterMask of 0.

start

Indicates the zero-based position within the tags UserData field to begin reading from. This parameter only applies when cmd is set to PartialUserData or PartialUserData. Otherwise, it is ignored.

length

Indicates the number of bytes of user data to read starting at the position indicated by the start parameter. This parameter only applies when cmd is set to PartialUserData or PartialUserData. Otherwise, it is ignored.

password

Authorized key for reader that might be required for this operation; null if not applicable.

Remarks

Each polling operation results in either a DataEvent or an ErrorEvent event being sent. The service continues polling until the StopReadTags method is invoked.

If the ContinuousReadMode property value is true during the StartReadTags method execution, invoking another StartReadTags method throws an exception.

This method is always performed asynchronously, but the OutputId property is not set and OutputCompleteEvents events are not sent because of calling this method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.StopReadTags Method

RFIDScanner.StopReadTags Method |
 | See Also

1/18/2008

Stops the Continuous Read mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub StopReadTags ( _
    password As Byte() _
)
public abstract void StopReadTags (
    byte[] password
)
public:
virtual void StopReadTags (
    array<unsigned char>^ password
) abstract
public abstract void StopReadTags (
    byte[] password
)
public abstract function StopReadTags (
    password : byte[]
)

Parameters

password

Authorized key for reader that might be required for this operation; null if not applicable.

Remarks

All read-only properties because of Continuous Read mode are writable again. Invoking this method when it is not in Continuous Read mode throws an exception.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.WriteTagData Method

RFIDScanner.WriteTagData Method |
 | See Also

1/18/2008

Overwrites the entire or part of the UserData field of targeted tag.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub WriteTagData ( _
    tagId As Byte(), _
    userData As Byte(), _
    start As Integer, _
    timeout As Integer, _
    password As Byte() _
)
public abstract void WriteTagData (
    byte[] tagId,
    byte[] userData,
    int start,
    int timeout,
    byte[] password
)
public:
virtual void WriteTagData (
    array<unsigned char>^ tagId,
    array<unsigned char>^ userData,
    int start,
    int timeout,
    array<unsigned char>^ password
) abstract
public abstract void WriteTagData (
    byte[] tagId,
    byte[] userData,
    int start,
    int timeout,
    byte[] password
)
public abstract function WriteTagData (
    tagId : byte[],
    userData : byte[],
    start : int,
    timeout : int,
    password : byte[]
)

Parameters

tagId

ID of the tag whose user data it is writing to.

userData

User data to be written.

start

Indicates the zero-based position within the tags userData field to begin writing to.

timeout

Allowed execution time, in milliseconds, before the method fails and a timeout ErrorEvent is sent to the application. If WaitForever, the service will wait as long as needed until either the operation is complete or an error occurs.

password

Authorized key for reader that might be required for this operation, null if not applicable.

Remarks

Application should query the CapWriteTag property for this operation’s supportability.

This method is always performed asynchronously and the OutputId property will be set on a successful start plus an OutputCompleteEvent event or an ErrorEvent event is raised to indicate completion.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.WriteTagId Method

RFIDScanner.WriteTagId Method |
 | See Also

1/18/2008

Overwrites the existing tag ID with a new ID.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub WriteTagId ( _
    sourceTagId As Byte(), _
    destinationTagId As Byte(), _
    timeout As Integer, _
    password As Byte() _
)
public abstract void WriteTagId (
    byte[] sourceTagId,
    byte[] destinationTagId,
    int timeout,
    byte[] password
)
public:
virtual void WriteTagId (
    array<unsigned char>^ sourceTagId,
    array<unsigned char>^ destinationTagId,
    int timeout,
    array<unsigned char>^ password
) abstract
public abstract void WriteTagId (
    byte[] sourceTagId,
    byte[] destinationTagId,
    int timeout,
    byte[] password
)
public abstract function WriteTagId (
    sourceTagId : byte[],
    destinationTagId : byte[],
    timeout : int,
    password : byte[]
)

Parameters

sourceTagId

The source tag ID from which it is writing the new ID.

destinationTagId

Destination ID of the new tag.

timeout

Allowed execution time, in milliseconds, before the method fails and a time-out ErrorEvent is sent to the application. If WaitForever, the service waits as long as needed until either the operation is complete or an error occurs.

password

Authorized key for reader that might be required for this operation; null if not applicable.

Remarks

The application should query the CapWriteTag property to verify that this is a supported method. An exception is thrown when this method is invoked with the WriteTagId bit not set in the CapWriteTag property.

This method is always performed asynchronously and OutputId will be set on a successful start plus an OutputCompleteEvent or an ErrorEvent event is raised to indicate completion.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner Properties

RFIDScanner Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
AutoDisable | Gets or sets a Boolean value that indicates whether the device automatically disables itself when a DataEvent event is enqueued.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapContinuousRead | Gets a Boolean value that indicates whether the device supports continuous reading.
CapDisableTag | Gets a Boolean value that indicates whether the device supports disabling a tag permanently.
CapLockTag | Gets a Boolean value that indicates whether this reader supports locking a tag.
CapMultipleProtocols | Gets a value that indicates the available predefined RFID tag protocols this device supports.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapReadTimer | Gets a Boolean value that indicates whether the device supports a read timer.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CapWriteTag | Gets a flag that indicates if the Tag ID and Tag UserData fields are writable.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
ContinuousReadMode | Gets a Boolean value that indicates whether the device is in Continuous Read mode.
CurrentTagId | Gets the TagId of the present tag.
CurrentTagProtocol | Gets the protocol that this tag was read through.
CurrentTagUserData | Gets the data that is read from the physical tag.
DataCount | Gets the number of DataEvent events enqueued by the device.
DataEventEnabled | Gets or sets a Boolean value that indicates whether the application is ready to receive input from the device.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
OutputId | Gets the integer value that indicates the ID number of the completed asynchronous output request.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
ProtocolMask | Gets or sets a bit pattern wherein each bit signifies one predefined RFID tag protocol.
ReadTimerInterval | Gets or sets the integer value that indicates the minimum time interval between tag reads in milliseconds.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )
TagCount | Gets the integer value that indicates the total number of tags read by the corresponding read operation.

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether the RFIDScanner is an exclusive-use device.

See Also

Reference

RFIDScanner Class
Microsoft.PointOfService Namespace


RFIDScanner.AutoDisable Property

RFIDScanner.AutoDisable Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether the device automatically disables itself when a DataEvent event is enqueued.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AutoDisable As Boolean
public abstract bool AutoDisable { get; set; }
public:
virtual property bool AutoDisable {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_AutoDisable ()

/** @property */
public abstract void set_AutoDisable (boolean value)

public abstract function get AutoDisable () : boolean

public abstract function set AutoDisable (value : boolean)

Remarks

The Boolean value of true indicates that the device automatically disables itself when a DataEvent event is enqueued.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.CapContinuousRead Property

RFIDScanner.CapContinuousRead Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device supports continuous reading.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapContinuousRead As Boolean
public abstract bool CapContinuousRead { get; }
public:
virtual property bool CapContinuousRead {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapContinuousRead ()

public abstract function get CapContinuousRead () : boolean

Remarks

The Boolean value of true indicates that the device supports continuous reading. The application should query this property before invoking the StartReadTags method and other continuous read methods.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.CapDisableTag Property

RFIDScanner.CapDisableTag Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device supports disabling a tag permanently.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapDisableTag As Boolean
public abstract bool CapDisableTag { get; }
public:
virtual property bool CapDisableTag {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapDisableTag ()

public abstract function get CapDisableTag () : boolean

Remarks

The Boolean value of true indicates that the device supports disabling a tag permanently. The application should query this property before invoking the DisableTag method.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.CapLockTag Property

RFIDScanner.CapLockTag Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether this reader supports locking a tag.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapLockTag As Boolean
public abstract bool CapLockTag { get; }
public:
virtual property bool CapLockTag {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapLockTag ()

public abstract function get CapLockTag () : boolean

Remarks

Application should query this property before invoking LockTag method.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.CapMultipleProtocols Property

RFIDScanner.CapMultipleProtocols Property |
 | See Also

1/18/2008

Gets a value that indicates the available predefined RFID tag protocols this device supports.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapMultipleProtocols As RFIDProtocols
public abstract RFIDProtocols CapMultipleProtocols { get; }
public:
virtual property RFIDProtocols CapMultipleProtocols {
    RFIDProtocols get () abstract;
}
/** @property */
public abstract RFIDProtocols get_CapMultipleProtocols ()

public abstract function get CapMultipleProtocols () : RFIDProtocols

Remarks

If the device supports more than one of these protocols, the value of this property is the bitwise logical OR combination of the values of the supported protocols.

Based on this property, the ProtocolMask property can additionally filter the tags it wants to exclude by turning off the bits.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.CapReadTimer Property

RFIDScanner.CapReadTimer Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device supports a read timer.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapReadTimer As Boolean
public abstract bool CapReadTimer { get; }
public:
virtual property bool CapReadTimer {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapReadTimer ()

public abstract function get CapReadTimer () : boolean

Remarks

The Boolean value of true indicates that the device supports a read timer. Application should query this property first before setting the ReadTimerInterval property.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.CapWriteTag Property

RFIDScanner.CapWriteTag Property |
 | See Also

1/18/2008

Gets a flag that indicates if the Tag ID and Tag UserData fields are writable.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapWriteTag As WriteTagSections
public abstract WriteTagSections CapWriteTag { get; }
public:
virtual property WriteTagSections CapWriteTag {
    WriteTagSections get () abstract;
}
/** @property */
public abstract WriteTagSections get_CapWriteTag ()

public abstract function get CapWriteTag () : WriteTagSections

Remarks

The value of this property indicates only the write capability of the device and does not imply the write ability of any specific tag. The application should query this property before invoking writing methods.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.ContinuousReadMode Property

RFIDScanner.ContinuousReadMode Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device is in Continuous Read mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ContinuousReadMode As Boolean
public abstract bool ContinuousReadMode { get; }
public:
virtual property bool ContinuousReadMode {
    bool get () abstract;
}
/** @property */
public abstract boolean get_ContinuousReadMode ()

public abstract function get ContinuousReadMode () : boolean

Remarks

The Boolean value of true indicates that the device is in Continuous Read mode. The ProtocolMask and ReadTimerInterval properties are read-only when this property is true.

This property is initialized to false by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.CurrentTagId Property

RFIDScanner.CurrentTagId Property |
 | See Also

1/18/2008

Gets the TagId of the present tag.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CurrentTagId As Byte()
public abstract byte[] CurrentTagId { get; }
public:
virtual property array<unsigned char>^ CurrentTagId {
    array<unsigned char>^ get () abstract;
}
/** @property */
public abstract byte[] get_CurrentTagId ()

public abstract function get CurrentTagId () : byte[]

Remarks

Just before a DataEvent event is delivered, the service populates this property with data from the first tag that was read. The service keeps this property up-to-date when the application calls the FirstTag, NextTag, and PreviousTag methods.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.CurrentTagProtocol Property

RFIDScanner.CurrentTagProtocol Property |
 | See Also

1/18/2008

Gets the protocol that this tag was read through.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CurrentTagProtocol As RFIDProtocols
public abstract RFIDProtocols CurrentTagProtocol { get; }
public:
virtual property RFIDProtocols CurrentTagProtocol {
    RFIDProtocols get () abstract;
}
/** @property */
public abstract RFIDProtocols get_CurrentTagProtocol ()

public abstract function get CurrentTagProtocol () : RFIDProtocols

Remarks

The value here should match one of the selections in the ProtocolMask property. This property may be updated by the service for each tag.

Just before a DataEvent event is delivered, the service populates this property with data from the first tag that was read. The service keeps this property up-to-date when the application calls the FirstTag, NextTag, and PreviousTag methods.

This property is initialized to zero by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.CurrentTagUserData Property

RFIDScanner.CurrentTagUserData Property |
 | See Also

1/18/2008

Gets the data that is read from the physical tag.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CurrentTagUserData As Byte()
public abstract byte[] CurrentTagUserData { get; }
public:
virtual property array<unsigned char>^ CurrentTagUserData {
    array<unsigned char>^ get () abstract;
}
/** @property */
public abstract byte[] get_CurrentTagUserData ()

public abstract function get CurrentTagUserData () : byte[]

Remarks

A partial or complete read will populate CurrentTagUserData with the targeted segment.

Just before a DataEventEnabled property is delivered, the service populates this property with data from the first tag that was read. The service keeps this property up-to-date when the application calls the FirstTag, NextTag, and PreviousTag methods.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.DataCount Property

RFIDScanner.DataCount Property |
 | See Also

1/18/2008

Gets the number of DataEvent events enqueued by the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DataCount As Integer
public abstract int DataCount { get; }
public:
virtual property int DataCount {
    int get () abstract;
}
/** @property */
public abstract int get_DataCount ()

public abstract function get DataCount () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.DataEventEnabled Property

RFIDScanner.DataEventEnabled Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether the application is ready to receive input from the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property DataEventEnabled As Boolean
public abstract bool DataEventEnabled { get; set; }
public:
virtual property bool DataEventEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_DataEventEnabled ()

/** @property */
public abstract void set_DataEventEnabled (boolean value)

public abstract function get DataEventEnabled () : boolean

public abstract function set DataEventEnabled (value : boolean)

Remarks

The Boolean value of true indicates that the application is ready to receive input from the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.IsExclusiveUseDevice Property

RFIDScanner.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the RFIDScanner is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Remarks

The Boolean value of true indicates that the RFIDScanner is exclusive-use. Otherwise, the value is false.

An exclusive-use device has the following properties:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before accessing some properties or calling methods that update the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.OutputId Property

RFIDScanner.OutputId Property |
 | See Also

1/18/2008

Gets the integer value that indicates the ID number of the completed asynchronous output request.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property OutputId As Integer
public abstract int OutputId { get; }
public:
virtual property int OutputId {
    int get () abstract;
}
/** @property */
public abstract int get_OutputId ()

public abstract function get OutputId () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.ProtocolMask Property

RFIDScanner.ProtocolMask Property |
 | See Also

1/18/2008

Gets or sets a bit pattern wherein each bit signifies one predefined RFID tag protocol.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property ProtocolMask As RFIDProtocols
public abstract RFIDProtocols ProtocolMask { get; set; }
public:
virtual property RFIDProtocols ProtocolMask {
    RFIDProtocols get () abstract;
    void set (RFIDProtocols value) abstract;
}
/** @property */
public abstract RFIDProtocols get_ProtocolMask ()

/** @property */
public abstract void set_ProtocolMask (RFIDProtocols value)

public abstract function get ProtocolMask () : RFIDProtocols

public abstract function set ProtocolMask (value : RFIDProtocols)

Remarks

The nonzero bit entries indicate protocols for which the read is requested. Only tags of the specified protocol type are read. If the reader is in Continuous Read mode, this property is read-only.

This property is initialized to the same value as the CapMultipleProtocols property by the Open method, and is usually updated by the application during its initialization phase.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.ReadTimerInterval Property

RFIDScanner.ReadTimerInterval Property |
 | See Also

1/18/2008

Gets or sets the integer value that indicates the minimum time interval between tag reads in milliseconds.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property ReadTimerInterval As Integer
public abstract int ReadTimerInterval { get; set; }
public:
virtual property int ReadTimerInterval {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_ReadTimerInterval ()

/** @property */
public abstract void set_ReadTimerInterval (int value)

public abstract function get ReadTimerInterval () : int

public abstract function set ReadTimerInterval (value : int)

Remarks

This property only applies to continuous reading. A value of zero indicates no delay between reads. The value of this property is zero if the CapReadTimer property is false. Tries to set this property when the CapReadTimer property is false or when the ContinuousReadMode property set to true will throw an exception.

This property is initialized to zero by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.TagCount Property

RFIDScanner.TagCount Property |
 | See Also

1/18/2008

Gets the integer value that indicates the total number of tags read by the corresponding read operation.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property TagCount As Integer
public abstract int TagCount { get; }
public:
virtual property int TagCount {
    int get () abstract;
}
/** @property */
public abstract int get_TagCount ()

public abstract function get TagCount () : int

Remarks

The service populates this property only before a DataEvent event is delivered to the application.

This property is initialized to zero by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner Events

RFIDScanner Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DataEvent | Notifies the application that input data from the RFID Scanner is available.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
ErrorEvent | Notifies the application that an RFID Scanner device error has been detected and a suitable response by the application is necessary to process the error condition.
OutputCompleteEvent | Notifies the application that the queued output request associated with the OutputId attribute has completed successfully.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

RFIDScanner Class
Microsoft.PointOfService Namespace


RFIDScanner.DataEvent Event

RFIDScanner.DataEvent Event |
 | See Also

1/18/2008

Notifies the application that input data from the RFID Scanner is available.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event DataEvent As DataEventHandler
public abstract event DataEventHandler DataEvent
public:
virtual event DataEventHandler^ DataEvent {
    void add (DataEventHandler^ value) abstract;
    void remove (DataEventHandler^ value) abstract;
}
/** @event */
public abstract void add_DataEvent (DataEventHandler value)

/** @event */
public abstract void remove_DataEvent (DataEventHandler value)

Remarks

The property TagCount is updated before this event being delivered to the application. For tag details reported by this DataEvent event, the application should start the FirstTag or NextTag method to enumerate each tag in the event, and then query a series of CurrentTag properties.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.ErrorEvent Event

RFIDScanner.ErrorEvent Event |
 | See Also

1/18/2008

Notifies the application that an RFID Scanner device error has been detected and a suitable response by the application is necessary to process the error condition.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event ErrorEvent As DeviceErrorEventHandler
public abstract event DeviceErrorEventHandler ErrorEvent
public:
virtual event DeviceErrorEventHandler^ ErrorEvent {
    void add (DeviceErrorEventHandler^ value) abstract;
    void remove (DeviceErrorEventHandler^ value) abstract;
}
/** @event */
public abstract void add_ErrorEvent (DeviceErrorEventHandler value)

/** @event */
public abstract void remove_ErrorEvent (DeviceErrorEventHandler value)

Remarks

Input error events are generated when errors occur while reading the data from the RFID Scanner device. Such events are not delivered until the DataEventEnabled property is set to true to allow correct application sequencing.

Output error events are generated and delivered when an error occurs during asynchronous output processing.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


RFIDScanner.OutputCompleteEvent Event

RFIDScanner.OutputCompleteEvent Event |
 | See Also

1/18/2008

Notifies the application that the queued output request associated with the OutputId attribute has completed successfully.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event OutputCompleteEvent As OutputCompleteEventHandler
public abstract event OutputCompleteEventHandler OutputCompleteEvent
public:
virtual event OutputCompleteEventHandler^ OutputCompleteEvent {
    void add (OutputCompleteEventHandler^ value) abstract;
    void remove (OutputCompleteEventHandler^ value) abstract;
}
/** @event */
public abstract void add_OutputCompleteEvent (OutputCompleteEventHandler value)

/** @event */
public abstract void remove_OutputCompleteEvent (OutputCompleteEventHandler value)

Remarks

This event is enqueued after the request’s data has been both sent and the service has confirmation that it was processed by the device successfully.

See Also

Reference

RFIDScanner Class
RFIDScanner Members
Microsoft.PointOfService Namespace


Rotation Enumeration

Rotation Enumeration |
 | See Also

1/18/2008

Lists the possible bitmap and bar code rotations for printing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration Rotation
public enum Rotation
public enum class Rotation
public enum Rotation
public enum Rotation

Members

Member name | Description
Left90 | Start rotated printing 90° to the left (counter-clockwise).
Normal | End rotated printing.
Right90 | Start rotated printing 90° to the right (clockwise).
Rotate180 | Start rotated printing 180° (that is, print upside-down).

Remarks

Used by the RotatePrint method of PointCardRW class, the RotatePrint method, and the RotateSpecial, SlpBarCodeRotationList, SlpBitmapRotationList, RecBarCodeRotationList, and RecBitmapRotationList properties of PosPrinter class. Members of this enumeration replace the PCRW_RP_RIGHT90, PCRW_RP_LEFT90, PCRW_RP_ROTATE180, and PCRW_RP_NORMAL UPOS constants for Point Card Reader Writer devices and the PTR_RP_RIGHT90, PTR_RP_LEFT90, PTR_RP_ROTATE180, and PTR_RP_NORMAL UPOS constants for Pos Printer devices.

See Also

Reference

Microsoft.PointOfService Namespace
PointCardRW.RotatePrint Method
PosPrinter.RecBarCodeRotationList Property
PosPrinter.RecBitmapRotationList Property
PosPrinter.RotateSpecial Property
PosPrinter.SlpBarCodeRotationList Property
PosPrinter.SlpBitmapRotationList Property


Scale Class

Scale Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a UPOS scale device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class Scale
    Inherits PosCommon
public abstract class Scale : PosCommon
public ref class Scale abstract : public PosCommon
public abstract class Scale extends PosCommon
public abstract class Scale extends PosCommon

Remarks

Capabilities

The scale device has the following capability:

  • Provides item weight to the application. The measure of weight may be in grams, kilograms, ounces, or pounds, depending upon the scale device.

The scale may have the following additional capabilities:

  • Provides item weight to the application. The measure of weight may be in grams, kilograms, ounces, or pounds, depending upon the scale device.

  • Includes an integrated display with the current weight, or with the current weight plus application-specified text.

  • Performs price calculations (weight X unit price) and returns the sale price. (This feature is mostly used in Europe.)

  • Supports application setting of tare weight.

  • Supports application zeroing of the scale.

A scale device is used to obtain weight for two distinct purposes, legal weight for calculating price, and live weight for updating customer displays. The following functionality was added to provide an interface for obtaining scale status and live weight:

  • A scale weight status update capability property, CapStatusUpdate.

  • A scale weight status notify property, StatusNotify, to enable or disable weight status event notification.

  • A ScaleLiveWeight property containing a value to be used for updating a customer display with the current scale weight.

  • Extensions to the ReadWeight method and StatusUpdateEvent for scale weight status.

Model

The general model of a scale is:

  • A scale returns the weight of an item placed on its weighing surface.

  • The primary scale method is ReadWeight. By default, it is performed synchronously. It returns after reading data from the scale. If an error occurs or if the timeout elapses, the ReadWeight method returns with an error code.

If the property AsyncMode is true when ReadWeight is called, then the method is performed asynchronously. It initiates event driven input and returns immediately. The timeout parameter specifies the maximum time the application wants to wait for a settled weight. Additional points are:

  • If an error occurs while initiating event-driven input (such as the device is offline), then an error code is returned by ReadWeight. Otherwise, ReadWeight returns a success status to the application, and scale processing continues asynchronously.

  • If a settled weight is received, then a DataEvent is queued containing the weight data in the status parameter.

  • If a scale error occurs (including a timeout with no settled weight), then an ErrorEvent is queued with an error code. The application event handler may retry the weighing process by setting the errorResponse parameter to Retry.

  • Only one asynchronous call to ReadWeight can be in progress at a time. Nesting of asynchronous scale operations is illegal.

  • An asynchronous scale operation can be cancelled with the ClearInput method.

For price-calculating scales, the application must set the UnitPrice property before calling ReadWeight. After a weight is read (and just before the DataEvent is delivered to the application, for asynchronous mode), the service object sets the SalesPrice property to the calculated price of the item.

Device Sharing

The scale is an exclusive-use device, as follows:

  • After opening the device, properties are readable.

  • The application must claim the device before enabling it.

  • The application must claim and enable the device before calling methods that manipulate the device.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.Scale
Microsoft.PointOfService.BasicServiceObjects.ScaleBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scale Members
Microsoft.PointOfService Namespace


Scale Members

Scale Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a UPOS scale device.

The following tables list the members exposed by the Scale type.

Protected Constructors

Name | Description
Scale | Creates an instance of the Scale class.
Top

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorOverWeight | Indicates the weight was over MaximumWeight.
ExtendedErrorSameWeight | Indicates the scale is reporting that the item/weight on the scale is identical to the previously reported item/weight (that is, the item has not been removed from the scale).
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
ExtendedErrorUnderZero | Indicates the scale is reporting a weight that is less than zero due to a calibration error.
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticGoodWeightReadCount | Indicates good weight read count for statistics reporting.
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusNotReady | Indicates the scale is not ready to weigh.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusStableWeight | Indicates scale weight is stable.
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
StatusWeightOverWeight | Indicates scale weight is overweight.
StatusWeightUnderZero | Indicates scale weight is less than zero.
StatusWeightUnstable | Indicates the scale weight is unstable.
StatusWeightZero | Indicates the scale weight is zero.
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
AsyncMode | Indicates whether ReadWeight is performed asynchronously.
AutoDisable | Indicates whether POS for .NET automatically disables the scale when data is received.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapDisplay | Indicates whether a scale has a display.
CapDisplayText | Indicates whether a scale can display text.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapPriceCalculating | Indicates whether a scale can calculate prices.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapStatusUpdate | If true, then the scale is capable of providing scale weight status with StatusUpdateEvents.
CapTareWeight | Indicates whether a scale supports a tare.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CapZeroScale | Indicates whether an application can set scale weight to zero.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
DataCount | Holds the number of currently queued DataEvent events.
DataEventEnabled | Indicates whether a DataEvent event is delivered when input data is queued.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
MaxDisplayTextChars | Holds the number of characters that can be displayed.
MaximumWeight | Holds the maximum weight measurement possible from the scale.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
SalesPrice | Holds the sales price read from a price-calculating scale.
ScaleLiveWeight | Holds the weight measured by the scale (if StatusUpdateEventArgs.Status is set to StatusStableWeight).
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
StatusNotify | Indicates whether the service object provides any scale weight notifications.
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
TareWeight | Holds the tare weight of scale data.
UnitPrice | Holds the unit price of the article to be weighed.
WeightUnit | Holds the unit of weight of scale data.
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Indicates whether the Scale is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all device input that has been buffered.
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
DisplayText | Updates display text.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon)
ReadWeight | Reads a weight from the scale.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
ZeroScale | Sets the scale weight to zero.
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DataEvent | Fired by the service object to notify the application that an asynchronous ReadWeight has completed.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
ErrorEvent | Fired by the service object to notify the application that a scale device error has been detected and a suitable response by the application is necessary to process the error condition.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

Scale Class
Microsoft.PointOfService Namespace


Scale Fields

Scale Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorOverWeight | Indicates the weight was over MaximumWeight.
ExtendedErrorSameWeight | Indicates the scale is reporting that the item/weight on the scale is identical to the previously reported item/weight (that is, the item has not been removed from the scale).
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
ExtendedErrorUnderZero | Indicates the scale is reporting a weight that is less than zero due to a calibration error.
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticGoodWeightReadCount | Indicates good weight read count for statistics reporting.
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusNotReady | Indicates the scale is not ready to weigh.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusStableWeight | Indicates scale weight is stable.
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
StatusWeightOverWeight | Indicates scale weight is overweight.
StatusWeightUnderZero | Indicates scale weight is less than zero.
StatusWeightUnstable | Indicates the scale weight is unstable.
StatusWeightZero | Indicates the scale weight is zero.
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

Scale Class
Microsoft.PointOfService Namespace


Scale.ExtendedErrorOverWeight Field

Scale.ExtendedErrorOverWeight Field |
 | See Also

1/18/2008

Indicates the weight was over MaximumWeight.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorOverWeight As Integer
public const int ExtendedErrorOverWeight
public:
literal int ExtendedErrorOverWeight
public static final int ExtendedErrorOverWeight
public const var ExtendedErrorOverWeight : int

Remarks

ExtendedErrorOverweight can only be returned if AsyncMode is false.

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace
ReadWeight


Scale.ExtendedErrorSameWeight Field

Scale.ExtendedErrorSameWeight Field |
 | See Also

1/18/2008

Indicates the scale is reporting that the item/weight on the scale is identical to the previously reported item/weight (that is, the item has not been removed from the scale).

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorSameWeight As Integer
public const int ExtendedErrorSameWeight
public:
literal int ExtendedErrorSameWeight
public static final int ExtendedErrorSameWeight
public const var ExtendedErrorSameWeight : int

Remarks

Thrown as an exception by the ReadWeight method. ExtendedErrorSameWeight can only be returned if AsyncMode is false and the scale hardware directly supports this capability.

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace
CapStatusUpdate
ScaleLiveWeight


Scale.ExtendedErrorUnderZero Field

Scale.ExtendedErrorUnderZero Field |
 | See Also

1/18/2008

Indicates the scale is reporting a weight that is less than zero due to a calibration error.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorUnderZero As Integer
public const int ExtendedErrorUnderZero
public:
literal int ExtendedErrorUnderZero
public static final int ExtendedErrorUnderZero
public const var ExtendedErrorUnderZero : int

Remarks

Thrown as an exception by the ReadWeight method. The scale should be recalibrated. This can only be returned if AsyncMode is false.

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace


Scale.StatisticGoodWeightReadCount Field

Scale.StatisticGoodWeightReadCount Field |
 | See Also

1/18/2008

Indicates good weight read count for statistics reporting.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticGoodWeightReadCount As String
public const string StatisticGoodWeightReadCount
public:
literal String^ StatisticGoodWeightReadCount
public static final String StatisticGoodWeightReadCount
public const var StatisticGoodWeightReadCount : String

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace
ReadWeight


Scale.StatusNotReady Field

Scale.StatusNotReady Field |
 | See Also

1/18/2008

Indicates the scale is not ready to weigh.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusNotReady As Integer
public const int StatusNotReady
public:
literal int StatusNotReady
public static final int StatusNotReady
public const var StatusNotReady : int

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace


Scale.StatusStableWeight Field

Scale.StatusStableWeight Field |
 | See Also

1/18/2008

Indicates scale weight is stable.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusStableWeight As Integer
public const int StatusStableWeight
public:
literal int StatusStableWeight
public static final int StatusStableWeight
public const var StatusStableWeight : int

Remarks

The ScaleLiveWeight property is updated before event delivery.

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace


Scale.StatusWeightOverWeight Field

Scale.StatusWeightOverWeight Field |
 | See Also

1/18/2008

Indicates scale weight is overweight.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusWeightOverWeight As Integer
public const int StatusWeightOverWeight
public:
literal int StatusWeightOverWeight
public static final int StatusWeightOverWeight
public const var StatusWeightOverWeight : int

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace


Scale.StatusWeightUnderZero Field

Scale.StatusWeightUnderZero Field |
 | See Also

1/18/2008

Indicates scale weight is less than zero.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusWeightUnderZero As Integer
public const int StatusWeightUnderZero
public:
literal int StatusWeightUnderZero
public static final int StatusWeightUnderZero
public const var StatusWeightUnderZero : int

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace


Scale.StatusWeightUnstable Field

Scale.StatusWeightUnstable Field |
 | See Also

1/18/2008

Indicates the scale weight is unstable.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusWeightUnstable As Integer
public const int StatusWeightUnstable
public:
literal int StatusWeightUnstable
public static final int StatusWeightUnstable
public const var StatusWeightUnstable : int

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace


Scale.StatusWeightZero Field

Scale.StatusWeightZero Field |
 | See Also

1/18/2008

Indicates the scale weight is zero.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusWeightZero As Integer
public const int StatusWeightZero
public:
literal int StatusWeightZero
public static final int StatusWeightZero
public const var StatusWeightZero : int

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace


Scale Constructor

Scale Constructor |
 | See Also

1/18/2008

Creates an instance of the Scale class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected Scale ()
protected:
Scale ()
protected Scale ()
protected function Scale ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace


Scale Methods

Scale Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all device input that has been buffered.
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
DisplayText | Updates display text.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon )
ReadWeight | Reads a weight from the scale.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
ZeroScale | Sets the scale weight to zero.

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

Scale Class
Microsoft.PointOfService Namespace


Scale.ClearInput Method

Scale.ClearInput Method |
 | See Also

1/18/2008

Clears all device input that has been buffered.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearInput
public abstract void ClearInput ()
public:
virtual void ClearInput () abstract
public abstract void ClearInput ()
public abstract function ClearInput ()

Remarks

Any data events or input error events that are queued – usually waiting for DataEventEnabled to be set to true and FreezeEvents to be set to false – are also cleared.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace


Scale.DisplayText Method

Scale.DisplayText Method |
 | See Also

1/18/2008

Updates display text.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub DisplayText ( _
    data As String _
)
public abstract void DisplayText (
    string data
)
public:
virtual void DisplayText (
    String^ data
) abstract
public abstract void DisplayText (
    String data
)
public abstract function DisplayText (
    data : String
)

Parameters

data

The string of characters to display.

Remarks

Call DisplayText to update the text shown on the integrated display. To clear the display, call DisplayText with an empty string ("").

If CapDisplayText is false, the device does not support text display and DisplayText will fail.

DisplayText may cause a PosControlException to be thrown with the following ErrorCode::

Value | Meaning
Illegal | An invalid text string was specified – the text contains more characters than allowed in MaxDisplayTextChars, or displaying text is not allowed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace
CapDisplay
CapDisplayText
MaxDisplayTextChars


Scale.ReadWeight Method

Scale.ReadWeight Method |
 | See Also

1/18/2008

Reads a weight from the scale.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function ReadWeight ( _
    timeout As Integer _
) As Decimal
public abstract decimal ReadWeight (
    int timeout
)
public:
virtual Decimal ReadWeight (
    int timeout
) abstract
public abstract Decimal ReadWeight (
    int timeout
)
public abstract function ReadWeight (
    timeout : int
) : decimal

Parameters

timeout

The number of milliseconds to wait for a settled weight before ReadWeight fails. If zero, ReadWeight attempts to read the scale weight, then returns the status immediately. If WaitForever, ReadWeight waits as long as needed until a weight is successfully read or an error occurs.

Remarks

The weighing process is performed synchronously and ReadWeight returns after finishing the weighing process.

If AsyncMode is false, ReadWeight operates synchronously.

If AsyncMode is true, weighing is performed asynchronously. ReadWeight initiates a read, then returns immediately. If ReadWeight returns a success status, weighing is started and a DataEvent containing the weight in its status parameter indicates its completion.

Note:
POS for .NET does not use an assumed decimal place when reading the scale weight. The returned value is the actual value and should not be shifted before use.

ReadWeight may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | An invalid timeout parameter was specified.
Timeout | A stable non-zero weight was not available before timeout milliseconds elapsed (can only be returned if AsyncMode is false).
ExtendedOverWeight | The weight was over MaximumWeight (can only be returned if AsyncMode is false).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace
UnitPrice
WeightUnit
CapPriceCalculating
SalesPrice
TareWeight


Scale.ZeroScale Method

Scale.ZeroScale Method |
 | See Also

1/18/2008

Sets the scale weight to zero.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ZeroScale
public abstract void ZeroScale ()
public:
virtual void ZeroScale () abstract
public abstract void ZeroScale ()
public abstract function ZeroScale ()

Remarks

ZeroScale can be used for initial calibration, or to account for tare weight on the scale. Can be called only if CapZeroScale is true.

ZeroScale may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | Scale zeroing is not supported.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace
CapZeroScale


Scale Properties

Scale Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
AsyncMode | Indicates whether ReadWeight is performed asynchronously.
AutoDisable | Indicates whether POS for .NET automatically disables the scale when data is received.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapDisplay | Indicates whether a scale has a display.
CapDisplayText | Indicates whether a scale can display text.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapPriceCalculating | Indicates whether a scale can calculate prices.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapStatusUpdate | If true, then the scale is capable of providing scale weight status with StatusUpdateEvents.
CapTareWeight | Indicates whether a scale supports a tare.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CapZeroScale | Indicates whether an application can set scale weight to zero.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
DataCount | Holds the number of currently queued DataEvent events.
DataEventEnabled | Indicates whether a DataEvent event is delivered when input data is queued.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
MaxDisplayTextChars | Holds the number of characters that can be displayed.
MaximumWeight | Holds the maximum weight measurement possible from the scale.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
SalesPrice | Holds the sales price read from a price-calculating scale.
ScaleLiveWeight | Holds the weight measured by the scale (if StatusUpdateEventArgs.Status is set to StatusStableWeight).
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
StatusNotify | Indicates whether the service object provides any scale weight notifications.
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )
TareWeight | Holds the tare weight of scale data.
UnitPrice | Holds the unit price of the article to be weighed.
WeightUnit | Holds the unit of weight of scale data.

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Indicates whether the Scale is an exclusive-use device.

See Also

Reference

Scale Class
Microsoft.PointOfService Namespace


Scale.AsyncMode Property

Scale.AsyncMode Property |
 | See Also

1/18/2008

Indicates whether ReadWeight is performed asynchronously.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AsyncMode As Boolean
public abstract bool AsyncMode { get; set; }
public:
virtual property bool AsyncMode {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_AsyncMode ()

/** @property */
public abstract void set_AsyncMode (boolean value)

public abstract function get AsyncMode () : boolean

public abstract function set AsyncMode (value : boolean)

Remarks

If true, the ReadWeight method is performed asynchronously.If false, AsyncMode is performed synchronously.

AsyncMode is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace
Scale.ReadWeight Method


Scale.AutoDisable Property

Scale.AutoDisable Property |
 | See Also

1/18/2008

Indicates whether POS for .NET automatically disables the scale when data is received.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AutoDisable As Boolean
public abstract bool AutoDisable { get; set; }
public:
virtual property bool AutoDisable {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_AutoDisable ()

/** @property */
public abstract void set_AutoDisable (boolean value)

public abstract function get AutoDisable () : boolean

public abstract function set AutoDisable (value : boolean)

Remarks

If true, POS for .NET sets DeviceEnabled to false after it receives and queues data as a DataEvent event. Before any additional input can be received, the application must set DeviceEnabled to true.

If false, POS for .NET does not automatically disable the device when data is received.

AutoDisable provides the application with an additional option for controlling the receipt of input data. If an application wants to receive and process only one input, or only one input at a time, then AutoDisable should be set to true.

AutoDisable is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace


Scale.CapDisplay Property

Scale.CapDisplay Property |
 | See Also

1/18/2008

Indicates whether a scale has a display.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapDisplay As Boolean
public abstract bool CapDisplay { get; }
public:
virtual property bool CapDisplay {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapDisplay ()

public abstract function get CapDisplay () : boolean

Remarks

Set to true if the scale includes an integrated display that shows weight;otherwise it is false, indicating that the application may need to show weight on another display.

CapDisplay is set and updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace


Scale.CapDisplayText Property

Scale.CapDisplayText Property |
 | See Also

1/18/2008

Indicates whether a scale can display text.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapDisplayText As Boolean
public abstract bool CapDisplayText { get; }
public:
virtual property bool CapDisplayText {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapDisplayText ()

public abstract function get CapDisplayText () : boolean

Remarks

Set to true if the scale includes an integrated display that shows weight and can also show a text description of the item being weighed. Otherwise it is false, indicating that extra text cannot be shown on the display.

If true, then CapDisplay must also be true.

CapDisplayText is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace
MaxDisplayTextChars


Scale.CapPriceCalculating Property

Scale.CapPriceCalculating Property |
 | See Also

1/18/2008

Indicates whether a scale can calculate prices.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapPriceCalculating As Boolean
public abstract bool CapPriceCalculating { get; }
public:
virtual property bool CapPriceCalculating {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapPriceCalculating ()

public abstract function get CapPriceCalculating () : boolean

Remarks

Set to true if the scale can calculate prices. Otherwise it is false, indicating that the scale returns only a weight.

For price-calculating scales, the calculation unit is in the scale rather than in the data-receiving terminal. For price-calculating scales, set the UnitPrice property before calling the ReadWeight method.

CapPriceCalculating is set and updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace
Scale.ReadWeight Method
WeightUnit
UnitPrice
SalesPrice


Scale.CapStatusUpdate Property

Scale.CapStatusUpdate Property |
 | See Also

1/18/2008

If true, then the scale is capable of providing scale weight status with StatusUpdateEvents.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property CapStatusUpdate As Boolean
public virtual bool CapStatusUpdate { get; }
public:
virtual property bool CapStatusUpdate {
    bool get ();
}
/** @property */
public boolean get_CapStatusUpdate ()

public function get CapStatusUpdate () : boolean

Remarks

If true when the device is enabled, an immediate StatusUpdateEvent will be generated to tell the application the current state of the scale.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace


Scale.CapTareWeight Property

Scale.CapTareWeight Property |
 | See Also

1/18/2008

Indicates whether a scale supports a tare.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapTareWeight As Boolean
public abstract bool CapTareWeight { get; }
public:
virtual property bool CapTareWeight {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapTareWeight ()

public abstract function get CapTareWeight () : boolean

Remarks

Set to true if the scale includes setting a tare value. Otherwise it is false, indicating that the scale does not support tare values.

CapTareWeight is set and updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace
TareWeight


Scale.CapZeroScale Property

Scale.CapZeroScale Property |
 | See Also

1/18/2008

Indicates whether an application can set scale weight to zero.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapZeroScale As Boolean
public abstract bool CapZeroScale { get; }
public:
virtual property bool CapZeroScale {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapZeroScale ()

public abstract function get CapZeroScale () : boolean

Remarks

Set to true if the application can set the scale weight to zero. Otherwise it is false, indicating that the scale does not support programmatic zeroing.

CapZeroScale is set and updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace
Scale.ZeroScale Method


Scale.DataCount Property

Scale.DataCount Property |
 | See Also

1/18/2008

Holds the number of currently queued DataEvent events.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DataCount As Integer
public abstract int DataCount { get; }
public:
virtual property int DataCount {
    int get () abstract;
}
/** @property */
public abstract int get_DataCount ()

public abstract function get DataCount () : int

Remarks

The application can read this property to determine whether additional input is queued from a device but has not yet been delivered because of other application processing, freezing of events, or other causes.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace
DataEvent


Scale.DataEventEnabled Property

Scale.DataEventEnabled Property |
 | See Also

1/18/2008

Indicates whether a DataEvent event is delivered when input data is queued.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property DataEventEnabled As Boolean
public abstract bool DataEventEnabled { get; set; }
public:
virtual property bool DataEventEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_DataEventEnabled ()

/** @property */
public abstract void set_DataEventEnabled (boolean value)

public abstract function get DataEventEnabled () : boolean

public abstract function set DataEventEnabled (value : boolean)

Remarks

If true, a DataEvent is delivered as soon as input data is queued. If changed to true and some input data is already queued, then a DataEvent event is delivered immediately. (Note that other conditions may delay "immediate" delivery: if FreezeEvents is true or another event is already being processed at the application, the DataEvent remains queued until the condition is corrected.)

If false, input data is queued for later delivery to the application. Also, if an input error occurs, the ErrorEvent is not delivered while this property is false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace
DataEvent


Scale.IsExclusiveUseDevice Property

Scale.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Indicates whether the Scale is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Property Value

A value of true indicates that the Scale is exclusive-use. Otherwise, the value will be false.

Remarks

An exclusive-use device has the following properties:

  • The application must claim the device before enabling it.

  • The application must claim and enable the device before accessing some properties or calling methods that update the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace


Scale.MaxDisplayTextChars Property

Scale.MaxDisplayTextChars Property |
 | See Also

1/18/2008

Holds the number of characters that can be displayed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property MaxDisplayTextChars As Integer
public abstract int MaxDisplayTextChars { get; }
public:
virtual property int MaxDisplayTextChars {
    int get () abstract;
}
/** @property */
public abstract int get_MaxDisplayTextChars ()

public abstract function get MaxDisplayTextChars () : int

Remarks

Contains the number of characters that can be displayed on an integrated display for article description text.

If CapDisplayText is false, the device does not support text display and MaxDisplayTextChars is always zero.

MaxDisplayTextChars is set and updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace
Scale.CapDisplayText Property


Scale.MaximumWeight Property

Scale.MaximumWeight Property |
 | See Also

1/18/2008

Holds the maximum weight measurement possible from the scale.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property MaximumWeight As Decimal
public abstract decimal MaximumWeight { get; }
public:
virtual property Decimal MaximumWeight {
    Decimal get () abstract;
}
/** @property */
public abstract Decimal get_MaximumWeight ()

public abstract function get MaximumWeight () : decimal

Remarks

The measurement unit is specified in the WeightUnit property.

Note:
POS for .NET does not use an assumed decimal place for MaximumWeight. The returned value is the actual value and should not be shifted before use.

MaximumWeight is updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace
WeightUnit


Scale.SalesPrice Property

Scale.SalesPrice Property |
 | See Also

1/18/2008

Holds the sales price read from a price-calculating scale.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property SalesPrice As Decimal
public abstract decimal SalesPrice { get; }
public:
virtual property Decimal SalesPrice {
    Decimal get () abstract;
}
/** @property */
public abstract Decimal get_SalesPrice ()

public abstract function get SalesPrice () : decimal

Remarks

To compute this value, price-calculating scales multiply the UnitPrice property by the weight.

SalesPrice is set by the control before the ReadWeight method returns (in synchronous use) or the DataEvent is delivered by the control (in asynchronous use).

If CapPriceCalculating is false, the device is not a price-calculating scale and SalesPrice is always zero.

SalesPrice is updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace
Scale.ReadWeight Method
WeightUnit
Scale.CapPriceCalculating Property
UnitPrice


Scale.ScaleLiveWeight Property

Scale.ScaleLiveWeight Property |
 | See Also

1/18/2008

Holds the weight measured by the scale (if StatusUpdateEventArgs.Status is set to StatusStableWeight).

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable ReadOnly Property ScaleLiveWeight As Decimal
public virtual decimal ScaleLiveWeight { get; }
public:
virtual property Decimal ScaleLiveWeight {
    Decimal get ();
}
/** @property */
public Decimal get_ScaleLiveWeight ()

public function get ScaleLiveWeight () : decimal

Remarks

If StatusUpdateEventArgs.Status property is not set to StatusStableWeight, ScaleLiveWeight is set to zero.

Note:
POS for .NET does not use an assumed decimal place for ScaleLiveWeight. The returned value is the actual value and should not be shifted before use.

You should use the weight in this property only for display purposes. For a weight to use for sale purposes, you should call ReadWeight.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace


Scale.StatusNotify Property

Scale.StatusNotify Property |
 | See Also

1/18/2008

Indicates whether the service object provides any scale weight notifications.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Property StatusNotify As StatusNotify
public virtual StatusNotify StatusNotify { get; set; }
public:
virtual property StatusNotify StatusNotify {
    StatusNotify get ();
    void set (StatusNotify value);
}
/** @property */
public StatusNotify get_StatusNotify ()

/** @property */
public void set_StatusNotify (StatusNotify value)

public function get StatusNotify () : StatusNotify

public function set StatusNotify (value : StatusNotify)

Remarks

Possible values are defined by the StatusNotify enumeration.

Scale weight state notification can only be set by the application if the CapStatusUpdate is true. StatusNotify can only be set while the device is disabled, that is, while DeviceEnabled is false.

StatusNotify is typically initialized to Disabled. This value provides compatibility with earlier releases.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace


Scale.TareWeight Property

Scale.TareWeight Property |
 | See Also

1/18/2008

Holds the tare weight of scale data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property TareWeight As Decimal
public abstract decimal TareWeight { get; set; }
public:
virtual property Decimal TareWeight {
    Decimal get () abstract;
    void set (Decimal value) abstract;
}
/** @property */
public abstract Decimal get_TareWeight ()

/** @property */
public abstract void set_TareWeight (Decimal value)

public abstract function get TareWeight () : decimal

public abstract function set TareWeight (value : decimal)

Remarks

The measurement unit is specified in the WeightUnit property. If the CapTareWeight property is set to false, the device does not support setting a tare value and TareWeight is always zero.

Note:
POS for .NET does not use an assumed decimal place for TareWeight. The returned value is the actual value and should not be shifted before use.

Tare weight is not included in the item weight returned by the ReadWeight method.

TareWeight is typically initialized to the scale’s default tare weight (usually zero) when the device is first enabled.

Accessing TareWeight can may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | CapTareWeight is false or an invalid tare value was specified.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace
Scale.CapTareWeight Property
Scale.ReadWeight Method
WeightUnit


Scale.UnitPrice Property

Scale.UnitPrice Property |
 | See Also

1/18/2008

Holds the unit price of the article to be weighed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property UnitPrice As Decimal
public abstract decimal UnitPrice { get; set; }
public:
virtual property Decimal UnitPrice {
    Decimal get () abstract;
    void set (Decimal value) abstract;
}
/** @property */
public abstract Decimal get_UnitPrice ()

/** @property */
public abstract void set_UnitPrice (Decimal value)

public abstract function get UnitPrice () : decimal

public abstract function set UnitPrice (value : decimal)

Remarks

For price-calculating scales, set UnitPrice before calling the ReadWeight method. The scale will calculate SalesPrice by multiplying the UnitPrice with the item's weight.

If CapPriceCalculating is false, the scale is not a price-calculating scale. In this case, setting a unit price is not supported and UnitPrice is always zero.

UnitPrice is initialized to zero when the device is first enabled following the Open method.

Accessing UnitPrice may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | CapPriceCalculating is false or an invalid price was specified.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace
Scale.ReadWeight Method
WeightUnit
Scale.CapPriceCalculating Property
Scale.SalesPrice Property


Scale.WeightUnit Property

Scale.WeightUnit Property |
 | See Also

1/18/2008

Holds the unit of weight of scale data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property WeightUnit As WeightUnit
public abstract WeightUnit WeightUnit { get; }
public:
virtual property WeightUnit WeightUnit {
    WeightUnit get () abstract;
}
/** @property */
public abstract WeightUnit get_WeightUnit ()

public abstract function get WeightUnit () : WeightUnit

Remarks

Valid units are:

Value | Meaning
Gram | Unit is a gram.
Kilogram | Unit is a kilogram (= 1000 grams).
Ounce | Unit is an ounce.
Pound | Unit is a pound (= 16 ounces).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace


Scale Events

Scale Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DataEvent | Fired by the service object to notify the application that an asynchronous ReadWeight has completed.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
ErrorEvent | Fired by the service object to notify the application that a scale device error has been detected and a suitable response by the application is necessary to process the error condition.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

Scale Class
Microsoft.PointOfService Namespace


Scale.DataEvent Event

Scale.DataEvent Event |
 | See Also

1/18/2008

Fired by the service object to notify the application that an asynchronous ReadWeight has completed.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event DataEvent As DataEventHandler
public abstract event DataEventHandler DataEvent
public:
virtual event DataEventHandler^ DataEvent {
    void add (DataEventHandler^ value) abstract;
    void remove (DataEventHandler^ value) abstract;
}
/** @event */
public abstract void add_DataEvent (DataEventHandler value)

/** @event */
public abstract void remove_DataEvent (DataEventHandler value)

Remarks

If the scale is a price-calculating scale, the unit price is placed in the UnitPrice property and the calculated sales price is placed in the SalesPrice property before DataEvent is delivered.

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace


Scale.ErrorEvent Event

Scale.ErrorEvent Event |
 | See Also

1/18/2008

Fired by the service object to notify the application that a scale device error has been detected and a suitable response by the application is necessary to process the error condition.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event ErrorEvent As DeviceErrorEventHandler
public abstract event DeviceErrorEventHandler ErrorEvent
public:
virtual event DeviceErrorEventHandler^ ErrorEvent {
    void add (DeviceErrorEventHandler^ value) abstract;
    void remove (DeviceErrorEventHandler^ value) abstract;
}
/** @event */
public abstract void add_ErrorEvent (DeviceErrorEventHandler value)

/** @event */
public abstract void remove_ErrorEvent (DeviceErrorEventHandler value)

Remarks

This event is queued when an error is detected while trying to read scale data. ErrorEvent is not delivered until DataEventEnabled property is true, so that proper application sequencing occurs.

Error information is contained in DeviceErrorEventArgs. The ErrorResponse property is preset to a default value, based on the ErrorLocus. The application's error processing can change the value of ErrorResponse.

See Also

Reference

Scale Class
Scale Members
Microsoft.PointOfService Namespace
DeviceErrorEventArgs Class


Scanner Class

Scanner Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a UPOS Scanner device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class Scanner
    Inherits PosCommon
public abstract class Scanner : PosCommon
public ref class Scanner abstract : public PosCommon
public abstract class Scanner extends PosCommon
public abstract class Scanner extends PosCommon

Remarks

The Scanner device reads encoded data from a label.

The Scanner class follows the general programming model for event-driven input:

  • When input is received by the Service Object, it queues a DataEvent.

  • If the AutoDisable property is true, the Service Object disables itself when a DataEvent is queued.

  • A queued DataEvent can be delivered to the application when the DataEventEnabled property is true. Just before delivering this event, the Service Object copies the data into properties and disables additional data events by setting the DataEventEnabled property to false. Later input data is queued by the Service Object while the application processes the current input and associated properties. When the application has finished the current input and is ready for more data, it should enable events by setting DataEventEnabled property to true.

  • One or more ErrorEvent events will be queued if the Service Object encounters an error while collecting or processing input. Those events are delivered to the application when the DataEventEnabled property is true.

  • The application can read the DataCount property to obtain the number of DataEvent events queued by the Service Object.

  • The application can delete all input queued by the Service Object by calling the ClearInput method.

The Service Object puts scanned data in the ScanData property. If the application sets the DecodeData property to true, the Service Object decodes the data and puts it in the ScanDataLabel and ScanDataType properties.

The Scanner is an exclusive-use device. Therefore:

  • The application must claim the device before it enables it.

  • The application must claim and enable the device before the device begins reading input.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.Scanner
Microsoft.PointOfService.BasicServiceObjects.ScannerBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scanner Members
Microsoft.PointOfService Namespace


Scanner Members

Scanner Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a UPOS Scanner device.

The following tables list the members exposed by the Scanner type.

Protected Constructors

Name | Description
Scanner | Creates an instance of the Scanner class.
Top

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticGoodScanCount | Incremented for each successful scan.
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
AutoDisable | Get or sets a Boolean value whether POS for .NET automatically disables the Scanner after data is received.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
DataCount | Gets the number of data events currently queued by the Service Object.
DataEventEnabled | Gets or sets a Boolean value that indicates whether POS for .NET can deliver the next queued event.
DecodeData | Gets or sets a Boolean value that indicates whether the data can be decoded.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
ScanData | Gets a byte array of the data that is read from the scanner.
ScanDataLabel | Gets the decoded bar code label.
ScanDataType | Gets the decoded bar code label type. Possible values are defined by the BarCodeSymbology enumeration.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether the Scanner is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all device input that has been buffered.
ClearInputProperties | Resets the values of properties altered by DataEvent or ErrorEvent.
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon)
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DataEvent | Raised by the Service Object to present scanned data from the device to the application.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
ErrorEvent | Raised by the Service Object to notify the application that an error has been detected while attempting to read scanned data.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

Scanner Class
Microsoft.PointOfService Namespace


Scanner Fields

Scanner Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticGoodScanCount | Incremented for each successful scan.
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

Scanner Class
Microsoft.PointOfService Namespace


Scanner.StatisticGoodScanCount Field

Scanner.StatisticGoodScanCount Field |
 | See Also

1/18/2008

Incremented for each successful scan.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticGoodScanCount As String
public const string StatisticGoodScanCount
public:
literal String^ StatisticGoodScanCount
public static final String StatisticGoodScanCount
public const var StatisticGoodScanCount : String

See Also

Reference

Scanner Class
Scanner Members
Microsoft.PointOfService Namespace


Scanner Constructor

Scanner Constructor |
 | See Also

1/18/2008

Creates an instance of the Scanner class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected Scanner ()
protected:
Scanner ()
protected Scanner ()
protected function Scanner ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

Scanner Class
Scanner Members
Microsoft.PointOfService Namespace


Scanner Methods

Scanner Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all device input that has been buffered.
ClearInputProperties | Resets the values of properties altered by DataEvent or ErrorEvent.
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon )
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

Scanner Class
Microsoft.PointOfService Namespace


Scanner.ClearInput Method

Scanner.ClearInput Method |
 | See Also

1/18/2008

Clears all device input that has been buffered.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearInput
public abstract void ClearInput ()
public:
virtual void ClearInput () abstract
public abstract void ClearInput ()
public abstract function ClearInput ()

Remarks

Any data events or input error events that were queued by the Service Object are also cleared. Usually the Service Objects waits for the DataEventEnabled property to be set to true and the FreezeEvents property to be set to false.

ClearInput may cause a PosControlException to be thrown with the following ErrorCode.

Value | Meaning
Claimed | The device is claimed by another process.
NotClaimed | The device must be claimed before the ClearInput method can be used.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scanner Class
Scanner Members
Microsoft.PointOfService Namespace
PosCommon.FreezeEvents Property
DataEventEnabled


Scanner.ClearInputProperties Method

Scanner.ClearInputProperties Method |
 | See Also

1/18/2008

Resets the values of properties altered by DataEvent or ErrorEvent.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Sub ClearInputProperties
public virtual void ClearInputProperties ()
public:
virtual void ClearInputProperties ()
public void ClearInputProperties ()
public function ClearInputProperties ()

Remarks

Sets all data properties populated by a raising of DataEvent or ErrorEvent event back to their default values. This does not reset the DataCount property or State properties.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scanner Class
Scanner Members
Microsoft.PointOfService Namespace


Scanner Properties

Scanner Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
AutoDisable | Get or sets a Boolean value whether POS for .NET automatically disables the Scanner after data is received.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
DataCount | Gets the number of data events currently queued by the Service Object.
DataEventEnabled | Gets or sets a Boolean value that indicates whether POS for .NET can deliver the next queued event.
DecodeData | Gets or sets a Boolean value that indicates whether the data can be decoded.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
ScanData | Gets a byte array of the data that is read from the scanner.
ScanDataLabel | Gets the decoded bar code label.
ScanDataType | Gets the decoded bar code label type. Possible values are defined by the BarCodeSymbology enumeration.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether the Scanner is an exclusive-use device.

See Also

Reference

Scanner Class
Microsoft.PointOfService Namespace


Scanner.AutoDisable Property

Scanner.AutoDisable Property |
 | See Also

1/18/2008

Get or sets a Boolean value whether POS for .NET automatically disables the Scanner after data is received.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AutoDisable As Boolean
public abstract bool AutoDisable { get; set; }
public:
virtual property bool AutoDisable {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_AutoDisable ()

/** @property */
public abstract void set_AutoDisable (boolean value)

public abstract function get AutoDisable () : boolean

public abstract function set AutoDisable (value : boolean)

Remarks

If the application wants to receive and process only one input, or only one input at a time, the AutoDisable property can be set to true.

When true, the Service Object sets the DeviceEnabled property to false as soon as it receives and queues data to be raised as a DataEvent event. Before the Service Object raises any later events, it expects the application to set the DeviceEnabled property back to true.

When false, the Service Object does not automatically disable the device when data is received; instead, it relies on the application to set the value of the DeviceEnabled property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scanner Class
Scanner Members
Microsoft.PointOfService Namespace
PosCommon.DeviceEnabled Property


Scanner.DataCount Property

Scanner.DataCount Property |
 | See Also

1/18/2008

Gets the number of data events currently queued by the Service Object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DataCount As Integer
public abstract int DataCount { get; }
public:
virtual property int DataCount {
    int get () abstract;
}
/** @property */
public abstract int get_DataCount ()

public abstract function get DataCount () : int

Remarks

The application can read the DataCount property to determine whether additional input is queued from a device but has not yet been delivered because of other application processing, freezing of events, or other causes.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scanner Class
Scanner Members
Microsoft.PointOfService Namespace
DataEvent


Scanner.DataEventEnabled Property

Scanner.DataEventEnabled Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether POS for .NET can deliver the next queued event.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property DataEventEnabled As Boolean
public abstract bool DataEventEnabled { get; set; }
public:
virtual property bool DataEventEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_DataEventEnabled ()

/** @property */
public abstract void set_DataEventEnabled (boolean value)

public abstract function get DataEventEnabled () : boolean

public abstract function set DataEventEnabled (value : boolean)

Remarks

When set to true by the application, POS for .NET can deliver the next queued event.

Notice that conditions may exist that delay "immediate" delivery: If the FreezeEvents property is set to true, or if the AutoDisable property is set to true and the DeviceEnabled property is set to false.

When DataEventEnabled is set to false by the application, the Service Object queues input data for later delivery to the application.

Note:
If an error occurs during input processing, the Service Object queues the error event but does not deliver it until the application sets DataEventEnabled to true.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scanner Class
Scanner Members
Microsoft.PointOfService Namespace
Scanner.AutoDisable Property
DataEvent
PosCommon.FreezeEvents Property
PosCommon.DeviceEnabled Property


Scanner.DecodeData Property

Scanner.DecodeData Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether the data can be decoded.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property DecodeData As Boolean
public abstract bool DecodeData { get; set; }
public:
virtual property bool DecodeData {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_DecodeData ()

/** @property */
public abstract void set_DecodeData (boolean value)

public abstract function get DecodeData () : boolean

public abstract function set DecodeData (value : boolean)

Remarks

When the application sets DecodeData to true, the Service Object decodes the value of the ScanData property and puts the decoded data in the ScanDataLabel and ScanDataType properties.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scanner Class
Scanner Members
Microsoft.PointOfService Namespace
ScanDataLabel
ScanDataType


Scanner.IsExclusiveUseDevice Property

Scanner.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the Scanner is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Property Value

A value of true indicates that the Scanner class is exclusive-use. Otherwise, the value is false.

Remarks

An exclusive-use device has the following properties:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before accessing some properties or calling methods that update the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scanner Class
Scanner Members
Microsoft.PointOfService Namespace


Scanner.ScanData Property

Scanner.ScanData Property |
 | See Also

1/18/2008

Gets a byte array of the data that is read from the scanner.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ScanData As Byte()
public abstract byte[] ScanData { get; }
public:
virtual property array<unsigned char>^ ScanData {
    array<unsigned char>^ get () abstract;
}
/** @property */
public abstract byte[] get_ScanData ()

public abstract function get ScanData () : byte[]

Remarks

Scan data is generally in the format delivered from the scanner. Message header and trailer information are removed, however, because they contain no useful information for an application and are likely to be scanner-specific.

Common header information is a prefix character (such as an STX character). Common trailer information is a terminator character (such as an ETX or CR character) and a block check character if the scanner generates one.

ScanData should include a symbology character if the scanner returns one (for example, an ‘A’ for UPC-A). ScanData should also include check digits if the label contains them and the scanner returns them. (Notice that both symbology characters and check digits may be present, depending on the scanner configuration. The Scanner Service Object returns them if they are present, but does not generate or calculate them if they are absent.)

Some merchandise may be marked with a supplemental bar code. This bar code is typically put to the right side of the main bar code, and consists of two or five characters of additional information. If the scanner reads merchandise that contains both main and supplemental bar codes, the supplemental characters are appended to the main characters, and the result is delivered to the application as one label. Notice that a scanner may support a configuration that enables or disables the reading of supplemental codes.

Some merchandise may be marked with multiple labels, also known as multisymbol labels or tiered labels. These bar codes are typically arranged vertically, and may be of the same or different symbology. If the scanner reads merchandise that contains multiple labels, each bar code is delivered to the application as a separate label. This is necessary because of the current lack of standardization of these bar code types. One cannot determine all variations based on the individual bar code data. Therefore, the application must determine when a multiple label bar code has been read based on the data returned. Notice that a scanner may support reading of multiple labels.

ScanData is set by the Service Object only before delivering the DataEvent event to the application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scanner Class
Scanner Members
Microsoft.PointOfService Namespace
DataEvent
BarCodeSymbology Enumeration


Scanner.ScanDataLabel Property

Scanner.ScanDataLabel Property |
 | See Also

1/18/2008

Gets the decoded bar code label.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ScanDataLabel As Byte()
public abstract byte[] ScanDataLabel { get; }
public:
virtual property array<unsigned char>^ ScanDataLabel {
    array<unsigned char>^ get () abstract;
}
/** @property */
public abstract byte[] get_ScanDataLabel ()

public abstract function get ScanDataLabel () : byte[]

Remarks

When the DecodeData property is set to false, the ScanDataLabel property is typically set to an empty byte array.

When the DecodeData property is set to true, the Service Object decodes ScanData into ScanDataLabel as follows:

  • If present, scanner-generated symbology characters are removed.

  • If the label type contains a readable check digit (such as with UPC-A and EAN-13), then it must be present in ScanDataLabel. If the scanner does not return the check digit to the Service Object, then it is to be calculated and included.

  • If present for variable length bar codes, the length identification is removed.

For example, the EAN-13 bar code that appears printed as "5 018374 827715" on a label may be received from the scanner and put into ScanData as the following:

Received from scanner | ScanData | Comment
5018374827715 | 5018374827715 | Complete bar code only.
501837482771<CR> | 501837482771 | Without check digit with carriage return.
F5018374827715<CR> | F5018374827715 | With scanner-dependent symbology character and carriage return.
<STX>F5018374827715<ETX> | F5018374827715 | With header, symbology character, and trailer.

For each of these cases (and any other variations), ScanDataLabel must always be set to the string "5018374827715", and ScanDataType must be set to EAN-13.

ScanDataLabel is set by the Service Object only before delivering the DataEvent event to the application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scanner Class
Scanner Members
Microsoft.PointOfService Namespace
Scanner.DecodeData Property
Scanner.ScanData Property
DataEvent


Scanner.ScanDataType Property

Scanner.ScanDataType Property |
 | See Also

1/18/2008

Gets the decoded bar code label type. Possible values are defined by the BarCodeSymbology enumeration.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property ScanDataType As BarCodeSymbology
public abstract BarCodeSymbology ScanDataType { get; }
public:
virtual property BarCodeSymbology ScanDataType {
    BarCodeSymbology get () abstract;
}
/** @property */
public abstract BarCodeSymbology get_ScanDataType ()

public abstract function get ScanDataType () : BarCodeSymbology

Remarks

When the DecodeData property is set to false, the ScanDataType property is typically set to Unknown.

When the DecodeData property is set to true, the Service Object tries to determine the scan label type.

ScanDataType is set by the Service Object only before delivering the DataEvent event to the application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Scanner Class
Scanner Members
Microsoft.PointOfService Namespace
Scanner.DecodeData Property
DataEvent
BarCodeSymbology Enumeration


Scanner Events

Scanner Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DataEvent | Raised by the Service Object to present scanned data from the device to the application.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
ErrorEvent | Raised by the Service Object to notify the application that an error has been detected while attempting to read scanned data.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

Scanner Class
Microsoft.PointOfService Namespace


Scanner.DataEvent Event

Scanner.DataEvent Event |
 | See Also

1/18/2008

Raised by the Service Object to present scanned data from the device to the application.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event DataEvent As DataEventHandler
public abstract event DataEventHandler DataEvent
public:
virtual event DataEventHandler^ DataEvent {
    void add (DataEventHandler^ value) abstract;
    void remove (DataEventHandler^ value) abstract;
}
/** @event */
public abstract void add_DataEvent (DataEventHandler value)

/** @event */
public abstract void remove_DataEvent (DataEventHandler value)

Remarks

The DataEventArgs.Status property is always 0 (zero). The Service Object places the scanned data in the ScanData, ScanDataLabel, and ScanDataType properties prior to delivering the DataEvent event to the application.

See Also

Reference

Scanner Class
Scanner Members
Microsoft.PointOfService Namespace
DataEventArgs Class
DataEventHandler Delegate


Scanner.ErrorEvent Event

Scanner.ErrorEvent Event |
 | See Also

1/18/2008

Raised by the Service Object to notify the application that an error has been detected while attempting to read scanned data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event ErrorEvent As DeviceErrorEventHandler
public abstract event DeviceErrorEventHandler ErrorEvent
public:
virtual event DeviceErrorEventHandler^ ErrorEvent {
    void add (DeviceErrorEventHandler^ value) abstract;
    void remove (DeviceErrorEventHandler^ value) abstract;
}
/** @event */
public abstract void add_ErrorEvent (DeviceErrorEventHandler value)

/** @event */
public abstract void remove_ErrorEvent (DeviceErrorEventHandler value)

Remarks

The DeviceErrorEventArgs.ErrorLocus property can be one of the following:

Value | Meaning
Input | Error occurred while gathering or processing event-driven input. No input data is available.
InputData | Error occurred while gathering or processing event-driven input and some previously buffered data is available.

The DeviceErrorEventArgs.ErrorResponse property is preset by the Service Object to a default value, based on the DeviceErrorEventArgs.ErrorLocus. The application may change it to one of the following:

Value | Meaning
Clear | Clear the buffered input data. Typically, the application has called the ClearInput method to clear all input buffers and queued events. The error state is then exited. Default when locus is Input.
ContinueInput | Use only when locus is InputData. Acknowledges the error and directs the Service Object to continue processing. The Service Object remains in the error state and delivers additional data events as directed by the DataEventEnabled property. When all input has been delivered and the DataEventEnabled property is again set to true, then another ErrorEvent is delivered with locus Input. Default when locus is InputData.
Note:
Input error events are not delivered until the application has set the DataEventEnabled property to true, indicating that it is ready to receive more input.

See Also

Reference

Scanner Class
Scanner Members
Microsoft.PointOfService Namespace
DeviceErrorEventArgs Class
DeviceErrorEventHandler Delegate
Scanner.DataEventEnabled Property


SensorColor Enumeration

SensorColor Enumeration |
 | See Also

1/18/2008

Lists the image capture modes for available biometric capture operations.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration SensorColor
public enum SensorColor
public enum class SensorColor
public enum SensorColor
public enum SensorColor

Members

Member name | Description
Color16 | 16 Colors
Color256 | 256 Colors
Full | Full Colors
Grayscale | Gray scale
Mono | Bi-tonal (B/W)
None | No color support specified.

Remarks

Lists the image capture modes for available biometric capture operations.

See Also

Reference

Microsoft.PointOfService Namespace


SensorOrientation Enumeration

SensorOrientation Enumeration |
 | See Also

1/18/2008

Indicates the requested orientation adjustment to the received sensor data prior to BiometricsInformationRecord creation.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration SensorOrientation
public enum SensorOrientation
public enum class SensorOrientation
public enum SensorOrientation
public enum SensorOrientation

Members

Member name | Description
Inverted | 180°
Left | 270°
None |
Normal | 0°
Right | 90°°

Remarks

Indicates the requested orientation adjustment to the received sensor data prior to BiometricsInformationRecord creation.

See Also

Reference

Microsoft.PointOfService Namespace


SensorType Enumeration

SensorType Enumeration |
 | See Also

1/18/2008

Lists the possible types of data that the Biometrics Scanner may be designed to capture.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration SensorType
public enum SensorType
public enum class SensorType
public enum SensorType
public enum SensorType

Members

Member name | Description
FacialFeatures | Captures biometrics data regarding facial features.
Fingerprint | Captures biometrics data regarding fingerprints.
Gait | Captures biometrics data regarding gait.
HandGeometry | Captures biometrics data regarding hand geometry.
Iris | Captures biometrics data regarding the iris.
KeystrokeDynamics | Captures biometrics data regarding keystroke dynamics.
LipMovement | Captures biometrics data regarding lip movement.
Password | The password.
Retina | Captures biometrics data about the retina.
SignatureDynamics | Captures biometrics data regarding the signature dynamics.
ThermalFaceImage | Captures biometrics data regarding thermal face imaging.
ThermalHandImage | Captures biometrics data regarding thermal hand imaging.
Unspecified | Captures unspecified biometrics data.
Voice | Captures biometrics data regarding voice.

Remarks

Lists the possible types of data that the Biometrics Scanner may be designed to capture.

See Also

Reference

Microsoft.PointOfService Namespace


ServiceIndex Structure

ServiceIndex Structure |
 | See Also Members

1/18/2008

Allows the extraction of information from Cash Changer subservices.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Structure ServiceIndex
public struct ServiceIndex
public value class ServiceIndex
public final class ServiceIndex extends ValueType

Remarks

The Cash Changer service can use subservices for other cash devices to create a full-function Cash Changer service. Properties in this class are added for the extraction of information from the subservices.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ServiceIndex Members
Microsoft.PointOfService Namespace
CashChanger Class
CoinAcceptor Class
CoinDispenser Class
BillAcceptor Class
BillDispenser Class


ServiceIndex Members

ServiceIndex Members |
 | See Also Constructors Methods Properties

1/18/2008

Allows the extraction of information from Cash Changer subservices.

The following tables list the members exposed by the ServiceIndex type.

Public Constructors

Name | Description
ServiceIndex | Creates an instance of the ServiceIndex structure with the specified values.
Top

Public Properties

Name | Description
IndexOfBillAcceptor | Gets the index of the BillAcceptor subservice.
IndexOfBillDispenser | Gets the index of the BillDispenser subservice.
IndexOfCoinAcceptor | Gets the index of the CoinAcceptor subservice.
IndexOfCoinDispenser | Gets the index of the CoinDispenser subservice.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from ValueType )
GetHashCode | (inherited from ValueType )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from ValueType )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ServiceIndex Structure
Microsoft.PointOfService Namespace
CashChanger Class
CoinAcceptor Class
CoinDispenser Class
BillAcceptor Class
BillDispenser Class


ServiceIndex Constructor

ServiceIndex Constructor |
 | See Also

1/18/2008

Creates an instance of the ServiceIndex structure with the specified values.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    indexOfCoinAcceptor As Integer, _
    indexOfCoinDispenser As Integer, _
    indexOfBillAcceptor As Integer, _
    indexOfBillDispenser As Integer _
)
public ServiceIndex (
    int indexOfCoinAcceptor,
    int indexOfCoinDispenser,
    int indexOfBillAcceptor,
    int indexOfBillDispenser
)
public:
ServiceIndex (
    int indexOfCoinAcceptor,
    int indexOfCoinDispenser,
    int indexOfBillAcceptor,
    int indexOfBillDispenser
)
public ServiceIndex (
    int indexOfCoinAcceptor,
    int indexOfCoinDispenser,
    int indexOfBillAcceptor,
    int indexOfBillDispenser
)
public function ServiceIndex (
    indexOfCoinAcceptor : int,
    indexOfCoinDispenser : int,
    indexOfBillAcceptor : int,
    indexOfBillDispenser : int
)

Parameters

indexOfCoinAcceptor

Index of CoinAcceptor service.

indexOfCoinDispenser

Index of CoinDispenser service.

indexOfBillAcceptor

Index of BillAcceptor service.

indexOfBillDispenser

Index of BillDispenser service.

See Also

Reference

ServiceIndex Structure
ServiceIndex Members
Microsoft.PointOfService Namespace
CashChanger Class
CoinAcceptor Class
CoinDispenser Class
BillAcceptor Class
BillDispenser Class


ServiceIndex Methods

ServiceIndex Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from ValueType )
GetHashCode | (inherited from ValueType )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from ValueType )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

ServiceIndex Structure
Microsoft.PointOfService Namespace
CashChanger Class
CoinAcceptor Class
CoinDispenser Class
BillAcceptor Class
BillDispenser Class


ServiceIndex Properties

ServiceIndex Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
IndexOfBillAcceptor | Gets the index of the BillAcceptor subservice.
IndexOfBillDispenser | Gets the index of the BillDispenser subservice.
IndexOfCoinAcceptor | Gets the index of the CoinAcceptor subservice.
IndexOfCoinDispenser | Gets the index of the CoinDispenser subservice.

See Also

Reference

ServiceIndex Structure
Microsoft.PointOfService Namespace
CashChanger Class
CoinAcceptor Class
CoinDispenser Class
BillAcceptor Class
BillDispenser Class


ServiceIndex.IndexOfBillAcceptor Property

ServiceIndex.IndexOfBillAcceptor Property |
 | See Also

1/18/2008

Gets the index of the BillAcceptor subservice.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property IndexOfBillAcceptor As Integer
public int IndexOfBillAcceptor { get; }
public:
property int IndexOfBillAcceptor {
    int get ();
}
/** @property */
public int get_IndexOfBillAcceptor ()

public function get IndexOfBillAcceptor () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ServiceIndex Structure
ServiceIndex Members
Microsoft.PointOfService Namespace
CashChanger Class
BillAcceptor Class
ServiceIndex Structure


ServiceIndex.IndexOfBillDispenser Property

ServiceIndex.IndexOfBillDispenser Property |
 | See Also

1/18/2008

Gets the index of the BillDispenser subservice.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property IndexOfBillDispenser As Integer
public int IndexOfBillDispenser { get; }
public:
property int IndexOfBillDispenser {
    int get ();
}
/** @property */
public int get_IndexOfBillDispenser ()

public function get IndexOfBillDispenser () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ServiceIndex Structure
ServiceIndex Members
Microsoft.PointOfService Namespace
CashChanger Class
BillDispenser Class
ServiceIndex Structure


ServiceIndex.IndexOfCoinAcceptor Property

ServiceIndex.IndexOfCoinAcceptor Property |
 | See Also

1/18/2008

Gets the index of the CoinAcceptor subservice.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property IndexOfCoinAcceptor As Integer
public int IndexOfCoinAcceptor { get; }
public:
property int IndexOfCoinAcceptor {
    int get ();
}
/** @property */
public int get_IndexOfCoinAcceptor ()

public function get IndexOfCoinAcceptor () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ServiceIndex Structure
ServiceIndex Members
Microsoft.PointOfService Namespace
CashChanger Class
CoinAcceptor Class
ServiceIndex Structure


ServiceIndex.IndexOfCoinDispenser Property

ServiceIndex.IndexOfCoinDispenser Property |
 | See Also

1/18/2008

Gets the index of the CoinDispenser subservice.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property IndexOfCoinDispenser As Integer
public int IndexOfCoinDispenser { get; }
public:
property int IndexOfCoinDispenser {
    int get ();
}
/** @property */
public int get_IndexOfCoinDispenser ()

public function get IndexOfCoinDispenser () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ServiceIndex Structure
ServiceIndex Members
Microsoft.PointOfService Namespace
CashChanger Class
CoinDispenser Class
ServiceIndex Structure


ServiceObjectAttribute Class

ServiceObjectAttribute Class |
 | See Also Members

1/18/2008

Defines a class-level attribute that can be used to identify the service object that implements the class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple:=False, Inherited:=False)> _
Public NotInheritable Class ServiceObjectAttribute
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple=false, Inherited=false)]
public sealed class ServiceObjectAttribute : Attribute
[AttributeUsageAttribute(AttributeTargets::Class, AllowMultiple=false, Inherited=false)]
public ref class ServiceObjectAttribute sealed : public Attribute
/** @attribute AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple=false, Inherited=false) */
public final class ServiceObjectAttribute extends Attribute
AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple=false, Inherited=false)
public final class ServiceObjectAttribute extends Attribute

Remarks

Used by PosExplorer class to determine that the class is a service object. The ServiceObjectAttribute class provides information about the device type, name, version, and so on.

Inheritance Hierarchy

System.Object
System.Attribute
Microsoft.PointOfService.ServiceObjectAttribute

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ServiceObjectAttribute Members
Microsoft.PointOfService Namespace


ServiceObjectAttribute Members

ServiceObjectAttribute Members |
 | See Also Constructors Methods Properties Explicit Interface Implementations

1/18/2008

Defines a class-level attribute that can be used to identify the service object that implements the class.

The following tables list the members exposed by the ServiceObjectAttribute type.

Public Constructors

Name | Description
ServiceObjectAttribute | Creates an instance of the ServiceObjectAttribute class with the specified parameters.
Top

Public Properties

Name | Description
Compatibility | Gets the compatibility level with any .NET or COM service object.
Description | Gets a description of the service object.
Name | Gets a name of the service object.
Type | Gets the tyoe of the service object.
TypeId | (inherited from Attribute )
UposVersion | Gets the UPOS version number of the service object.
UposVersionMajor | Gets the UPOS major version number for the service object.
UposVersionMinor | Gets the UPOS minor version number of the service object.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Attribute )
GetCustomAttribute | Overloaded. (inherited from Attribute )
GetCustomAttributes | Overloaded. (inherited from Attribute )
GetHashCode | (inherited from Attribute )
GetType | (inherited from Object )
IsDefaultAttribute | (inherited from Attribute )
IsDefined | Overloaded. (inherited from Attribute )
Match | (inherited from Attribute )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

Explicit Interface Implementations

Name | Description
System.Runtime.InteropServices._Attribute.GetIDsOfNames | (inherited from Attribute )
System.Runtime.InteropServices._Attribute.GetTypeInfo | (inherited from Attribute )
System.Runtime.InteropServices._Attribute.GetTypeInfoCount | (inherited from Attribute )
System.Runtime.InteropServices._Attribute.Invoke | (inherited from Attribute )
Top

See Also

Reference

ServiceObjectAttribute Class
Microsoft.PointOfService Namespace


ServiceObjectAttribute Constructor

ServiceObjectAttribute Constructor |
 | See Also

1/18/2008

Creates an instance of the ServiceObjectAttribute class with the specified parameters.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    type As String, _
    name As String, _
    description As String, _
    uposVersionMajor As Integer, _
    uposVersionMinor As Integer _
)
public ServiceObjectAttribute (
    string type,
    string name,
    string description,
    int uposVersionMajor,
    int uposVersionMinor
)
public:
ServiceObjectAttribute (
    String^ type,
    String^ name,
    String^ description,
    int uposVersionMajor,
    int uposVersionMinor
)
public ServiceObjectAttribute (
    String type,
    String name,
    String description,
    int uposVersionMajor,
    int uposVersionMinor
)
public function ServiceObjectAttribute (
    type : String,
    name : String,
    description : String,
    uposVersionMajor : int,
    uposVersionMinor : int
)

Parameters

type

The type of service object.

name
description

A description of the service object.

uposVersionMajor

Major version.

uposVersionMinor

Minor version.

See Also

Reference

ServiceObjectAttribute Class
ServiceObjectAttribute Members
Microsoft.PointOfService Namespace


ServiceObjectAttribute Methods

ServiceObjectAttribute Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Attribute )
GetCustomAttribute | Overloaded. (inherited from Attribute )
GetCustomAttributes | Overloaded. (inherited from Attribute )
GetHashCode | (inherited from Attribute )
GetType | (inherited from Object )
IsDefaultAttribute | (inherited from Attribute )
IsDefined | Overloaded. (inherited from Attribute )
Match | (inherited from Attribute )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

Explicit Interface Implementations

Name | Description
System.Runtime.InteropServices._Attribute.GetIDsOfNames | (inherited from Attribute )
System.Runtime.InteropServices._Attribute.GetTypeInfo | (inherited from Attribute )
System.Runtime.InteropServices._Attribute.GetTypeInfoCount | (inherited from Attribute )
System.Runtime.InteropServices._Attribute.Invoke | (inherited from Attribute )

See Also

Reference

ServiceObjectAttribute Class
Microsoft.PointOfService Namespace


ServiceObjectAttribute Properties

ServiceObjectAttribute Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
Compatibility | Gets the compatibility level with any .NET or COM service object.
Description | Gets a description of the service object.
Name | Gets a name of the service object.
Type | Gets the tyoe of the service object.
TypeId | (inherited from Attribute )
UposVersion | Gets the UPOS version number of the service object.
UposVersionMajor | Gets the UPOS major version number for the service object.
UposVersionMinor | Gets the UPOS minor version number of the service object.

See Also

Reference

ServiceObjectAttribute Class
Microsoft.PointOfService Namespace


ServiceObjectAttribute.Compatibility Property

ServiceObjectAttribute.Compatibility Property |
 | See Also

1/18/2008

Gets the compatibility level with any .NET or COM service object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Compatibility As DeviceCompatibilities
public DeviceCompatibilities Compatibility { get; }
public:
property DeviceCompatibilities Compatibility {
    DeviceCompatibilities get ();
}
/** @property */
public DeviceCompatibilities get_Compatibility ()

public function get Compatibility () : DeviceCompatibilities

Remarks

Valid compatibility levels are defined by the DeviceCompatibilities enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ServiceObjectAttribute Class
ServiceObjectAttribute Members
Microsoft.PointOfService Namespace


ServiceObjectAttribute.Description Property

ServiceObjectAttribute.Description Property |
 | See Also

1/18/2008

Gets a description of the service object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Description As String
public string Description { get; }
public:
property String^ Description {
    String^ get ();
}
/** @property */
public String get_Description ()

public function get Description () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ServiceObjectAttribute Class
ServiceObjectAttribute Members
Microsoft.PointOfService Namespace


ServiceObjectAttribute.Name Property

ServiceObjectAttribute.Name Property |
 | See Also

1/18/2008

Gets a name of the service object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Name As String
public string Name { get; }
public:
property String^ Name {
    String^ get ();
}
/** @property */
public String get_Name ()

public function get Name () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ServiceObjectAttribute Class
ServiceObjectAttribute Members
Microsoft.PointOfService Namespace


ServiceObjectAttribute.Type Property

ServiceObjectAttribute.Type Property |
 | See Also

1/18/2008

Gets the tyoe of the service object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Type As String
public string Type { get; }
public:
property String^ Type {
    String^ get ();
}
/** @property */
public String get_Type ()

public function get Type () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ServiceObjectAttribute Class
ServiceObjectAttribute Members
Microsoft.PointOfService Namespace


ServiceObjectAttribute.UposVersion Property

ServiceObjectAttribute.UposVersion Property |
 | See Also

1/18/2008

Gets the UPOS version number of the service object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property UposVersion As Version
public Version UposVersion { get; }
public:
property Version^ UposVersion {
    Version^ get ();
}
/** @property */
public Version get_UposVersion ()

public function get UposVersion () : Version

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ServiceObjectAttribute Class
ServiceObjectAttribute Members
Microsoft.PointOfService Namespace


ServiceObjectAttribute.UposVersionMajor Property

ServiceObjectAttribute.UposVersionMajor Property |
 | See Also

1/18/2008

Gets the UPOS major version number for the service object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property UposVersionMajor As Integer
public int UposVersionMajor { get; }
public:
property int UposVersionMajor {
    int get ();
}
/** @property */
public int get_UposVersionMajor ()

public function get UposVersionMajor () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ServiceObjectAttribute Class
ServiceObjectAttribute Members
Microsoft.PointOfService Namespace


ServiceObjectAttribute.UposVersionMinor Property

ServiceObjectAttribute.UposVersionMinor Property |
 | See Also

1/18/2008

Gets the UPOS minor version number of the service object.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property UposVersionMinor As Integer
public int UposVersionMinor { get; }
public:
property int UposVersionMinor {
    int get ();
}
/** @property */
public int get_UposVersionMinor ()

public function get UposVersionMinor () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ServiceObjectAttribute Class
ServiceObjectAttribute Members
Microsoft.PointOfService Namespace


SignatureCapture Class

SignatureCapture Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a UPOS signature capture device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class SignatureCapture
    Inherits PosCommon
public abstract class SignatureCapture : PosCommon
public ref class SignatureCapture abstract : public PosCommon
public abstract class SignatureCapture extends PosCommon
public abstract class SignatureCapture extends PosCommon

Remarks

Capabilities

The signature capture device has the following capability:

  • Obtains a signature captured by a signature capture device. The captured signature data is in the form of lines consisting of a series of points. Each point lies within the coordinate system defined by the resolution of the device, where (0, 0) is the upper-left point of the device, and (MaximumX, MaximumY) is the lower-right point. The signature line points are presented to the application by a DataEvent with a single array of line points

The signature capture device may have the following additional capabilities:

  • Provides a way for the user to terminate signature capture – that is, to tell the device that she or he has completed the signature.

  • Displays form/data on the signature capture device.

  • Returns the signature in “real time” as it is entered on the device. If this capability is true and has been enabled by application by setting the RealTimeDataEnabled property to true, then a series of DataEvents are generated, each with an array of one or more line points representing a partial signature.

Model

The signature capture device usage model is:

  • Open and claim the device.

  • Enable the device and set DataEventEnabled to true.

  • Begin capturing a signature by calling the BeginCapture method. This method displays a form or data screen (if the device has a display) and enables the stylus.

  • If the device is capable of supplying signature data in real time as the signature is entered (CapRealTimeData is set to true), and if the RealTimeDataEnabled property is set to true, the signature is presented to the application as a series of partial signature data events until the signature capture is terminated.

  • If the device provides a way for the user to terminate the signature, then when the user terminates, the service object raises a DataEvent. Otherwise, the application must call the EndCapture method to terminate the signature.

  • Disable the device. If the device has a display, this also clears the display.

A signature capture follows the general Input Model for event-driven input:

  • When input is received by the service object, it queues a DataEvent.

  • If the AutoDisable property is true, then the device automatically disables itself when a DataEvent is queued. However, note that setting AutoDisable probably is not very useful. If RealTimeDataEnabled is true, then AutoDisable does not make sense. If RealTimeDataEnabled is false, then the pacing of signatures is controlled by the application via the BeginCapture method. It is probably in the best interest of the application not to use the AutoDisable property for this device class.

  • A queued DataEvent can be delivered to the application when the DataEventEnabled property is true. Just before delivering this event, data is copied into properties, and further data events are disabled by setting the DataEventEnabled property to false. This causes subsequent input data to be queued while the application processes the current input and associated properties. When the application has finished processing the current input and is ready for more data, it re-enables events by setting DataEventEnabled to true.

  • An ErrorEvent (or events) is queued if an error occurs while gathering or processing input, and is delivered to the application when the DataEventEnabled property is true and other delivery requirements are met.

  • The DataCount property can be read to obtain the number of queued DataEvents.

  • All queued input can be deleted by calling the ClearInput method.

Deviations from the Input Model are:

  • The capture of signature data begins when the BeginCapture method is called.

  • If signature capture is terminated by calling EndCapture, then no DataEvent is raised.

Device Sharing

The signature capture device is an exclusive-use device, as follows:

  • The application must claim the device before enabling it.

  • The application must claim and enable the device before calling methods that manipulate the device or before changing some writable properties.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.SignatureCapture
Microsoft.PointOfService.BasicServiceObjects.SignatureCaptureBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SignatureCapture Members
Microsoft.PointOfService Namespace


SignatureCapture Members

SignatureCapture Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a UPOS signature capture device.

The following tables list the members exposed by the SignatureCapture type.

Protected Constructors

Name | Description
SignatureCapture | Creates an instance of the SignatureCapture class.
Top

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFailedSignatureReadCount | Indicates the number of failed signature reads.
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticGoodSignatureReadCount | Indicates the number of good signature reads.
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
AutoDisable | Indicates whether POS for .NET automatically disables the device when data is received.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapDisplay | Indicates whether the device can display a form or data entry screen.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapRealTimeData | Indicates whether the device can supply data in real-time.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CapUserTerminated | Indicates whether a user can terminate a signature capture.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
DataCount | Holds the number of currently queued DataEvent events.
DataEventEnabled | Indicates whether a DataEvent event is delivered when input data is queued.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
MaximumX | Holds the maximum horizontal coordinate of the signature capture device.
MaximumY | Holds the maximum vertical coordinate of the signature capture device.
PointArray | Holds the signature captured from the device.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
RawData | Holds the signature captured from the device in a device-specific format.
RealTimeDataEnabled | Indicates whether signature data can be gathered in real time.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Indicates whether or not the SignatureCapture is exclusive-use.
Top

Public Methods (see also Protected Methods )

Name | Description
BeginCapture | Begins the capture of a signature.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all device input that has been buffered.
ClearInputProperties | Resets the values of properties altered by DataEvent or ErrorEvent.
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
EndCapture | Ends signature capture.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon)
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DataEvent | Raised by the service object to notify the application that input data is available.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
ErrorEvent | Raised by the service object to notify the application that a device error has been detected and a suitable response by the application is necessary to process the error condition.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

SignatureCapture Class
Microsoft.PointOfService Namespace


SignatureCapture Fields

SignatureCapture Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFailedSignatureReadCount | Indicates the number of failed signature reads.
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticGoodSignatureReadCount | Indicates the number of good signature reads.
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

SignatureCapture Class
Microsoft.PointOfService Namespace


SignatureCapture.StatisticFailedSignatureReadCount Field

SignatureCapture.StatisticFailedSignatureReadCount Field |
 | See Also

1/18/2008

Indicates the number of failed signature reads.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticFailedSignatureReadCount As String
public const string StatisticFailedSignatureReadCount
public:
literal String^ StatisticFailedSignatureReadCount
public static final String StatisticFailedSignatureReadCount
public const var StatisticFailedSignatureReadCount : String

See Also

Reference

SignatureCapture Class
SignatureCapture Members
Microsoft.PointOfService Namespace


SignatureCapture.StatisticGoodSignatureReadCount Field

SignatureCapture.StatisticGoodSignatureReadCount Field |
 | See Also

1/18/2008

Indicates the number of good signature reads.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticGoodSignatureReadCount As String
public const string StatisticGoodSignatureReadCount
public:
literal String^ StatisticGoodSignatureReadCount
public static final String StatisticGoodSignatureReadCount
public const var StatisticGoodSignatureReadCount : String

See Also

Reference

SignatureCapture Class
SignatureCapture Members
Microsoft.PointOfService Namespace


SignatureCapture Constructor

SignatureCapture Constructor |
 | See Also

1/18/2008

Creates an instance of the SignatureCapture class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected SignatureCapture ()
protected:
SignatureCapture ()
protected SignatureCapture ()
protected function SignatureCapture ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

SignatureCapture Class
SignatureCapture Members
Microsoft.PointOfService Namespace


SignatureCapture Methods

SignatureCapture Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
BeginCapture | Begins the capture of a signature.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all device input that has been buffered.
ClearInputProperties | Resets the values of properties altered by DataEvent or ErrorEvent.
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
EndCapture | Ends signature capture.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon )
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

SignatureCapture Class
Microsoft.PointOfService Namespace


SignatureCapture.BeginCapture Method

SignatureCapture.BeginCapture Method |
 | See Also

1/18/2008

Begins the capture of a signature.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub BeginCapture ( _
    formName As String _
)
public abstract void BeginCapture (
    string formName
)
public:
virtual void BeginCapture (
    String^ formName
) abstract
public abstract void BeginCapture (
    String formName
)
public abstract function BeginCapture (
    formName : String
)

Parameters

formName

Contains the platform-specific location for obtaining form or data screen information for display on the device screen.

Remarks

If CapDisplay is true, formName is used to find information about the form or data screen to be displayed.

The format and features of each signature capture device’s form/data screen varies widely and is often built with proprietary tools. Therefore, this key’s data and additional values contain information that varies by service object. Typically, the registry key’s data is set to a form/data screen file name, and extra registry values and data are set as needed to control its display.

After displaying the form or data screen, when applicable, the signature capture stylus is enabled.

BeginCapture may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
NoExist | formName was not found.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SignatureCapture Class
SignatureCapture Members
Microsoft.PointOfService Namespace


SignatureCapture.ClearInput Method

SignatureCapture.ClearInput Method |
 | See Also

1/18/2008

Clears all device input that has been buffered.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearInput
public abstract void ClearInput ()
public:
virtual void ClearInput () abstract
public abstract void ClearInput ()
public abstract function ClearInput ()

Remarks

Any data events or input error events that are queued – usually waiting for DataEventEnabled to be set to true and FreezeEvents to be set to false — are also cleared.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SignatureCapture Class
SignatureCapture Members
Microsoft.PointOfService Namespace


SignatureCapture.ClearInputProperties Method

SignatureCapture.ClearInputProperties Method |
 | See Also

1/18/2008

Resets the values of properties altered by DataEvent or ErrorEvent.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Sub ClearInputProperties
public virtual void ClearInputProperties ()
public:
virtual void ClearInputProperties ()
public void ClearInputProperties ()
public function ClearInputProperties ()

Remarks

Sets all data properties populated by a firing of DataEvent or ErrorEvent back to their default values. This does not reset the DataCount or State properties.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SignatureCapture Class
SignatureCapture Members
Microsoft.PointOfService Namespace


SignatureCapture.EndCapture Method

SignatureCapture.EndCapture Method |
 | See Also

1/18/2008

Ends signature capture.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub EndCapture
public abstract void EndCapture ()
public:
virtual void EndCapture () abstract
public abstract void EndCapture ()
public abstract function EndCapture ()

Remarks

If the RealTimeDataEnabled property is false and a signature is captured, it is placed in the PointArray and RawData properties. If no signature is captured, the PointArray and RawData properties are set to zero.

If the RealTimeDataEnabled property is true and signature points remain that have not been delivered to the application by a DataEvent event, the remaining signature points are placed in the PointArray and RawData properties. If all signature points have been delivered to the application, the PointArray and RawData properties are set to zero.

EndCapture may throw a PosControlException with the following values:

Value | Meaning
NoExist | Signature capture was not in progress.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SignatureCapture Class
SignatureCapture Members
Microsoft.PointOfService Namespace
DataEvent


SignatureCapture Properties

SignatureCapture Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
AutoDisable | Indicates whether POS for .NET automatically disables the device when data is received.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapDisplay | Indicates whether the device can display a form or data entry screen.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapRealTimeData | Indicates whether the device can supply data in real-time.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CapUserTerminated | Indicates whether a user can terminate a signature capture.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
DataCount | Holds the number of currently queued DataEvent events.
DataEventEnabled | Indicates whether a DataEvent event is delivered when input data is queued.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
MaximumX | Holds the maximum horizontal coordinate of the signature capture device.
MaximumY | Holds the maximum vertical coordinate of the signature capture device.
PointArray | Holds the signature captured from the device.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
RawData | Holds the signature captured from the device in a device-specific format.
RealTimeDataEnabled | Indicates whether signature data can be gathered in real time.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Indicates whether or not the SignatureCapture is exclusive-use.

See Also

Reference

SignatureCapture Class
Microsoft.PointOfService Namespace


SignatureCapture.AutoDisable Property

SignatureCapture.AutoDisable Property |
 | See Also

1/18/2008

Indicates whether POS for .NET automatically disables the device when data is received.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AutoDisable As Boolean
public abstract bool AutoDisable { get; set; }
public:
virtual property bool AutoDisable {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_AutoDisable ()

/** @property */
public abstract void set_AutoDisable (boolean value)

public abstract function get AutoDisable () : boolean

public abstract function set AutoDisable (value : boolean)

Remarks

If true, POS for .NET sets DeviceEnabled to false after it receives and queues data as a DataEvent event. Before any additional input can be received, the application must set DeviceEnabled to true.

If false, POS for .NET does not automatically disable the device when data is received.

AutoDisable provides the application with an additional option for controlling the receipt of input data. If an application wants to receive and process only one input, or only one input at a time, then AutoDisable should be set to true.

AutoDisable is typically initialized to false. It should then be kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SignatureCapture Class
SignatureCapture Members
Microsoft.PointOfService Namespace


SignatureCapture.CapDisplay Property

SignatureCapture.CapDisplay Property |
 | See Also

1/18/2008

Indicates whether the device can display a form or data entry screen.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapDisplay As Boolean
public abstract bool CapDisplay { get; }
public:
virtual property bool CapDisplay {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapDisplay ()

public abstract function get CapDisplay () : boolean

Remarks

Set to true if the device can display a form or data entry screen;otherwise, false.

CapDisplay is updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SignatureCapture Class
SignatureCapture Members
Microsoft.PointOfService Namespace


SignatureCapture.CapRealTimeData Property

SignatureCapture.CapRealTimeData Property |
 | See Also

1/18/2008

Indicates whether the device can supply data in real-time.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapRealTimeData As Boolean
public abstract bool CapRealTimeData { get; }
public:
virtual property bool CapRealTimeData {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapRealTimeData ()

public abstract function get CapRealTimeData () : boolean

Remarks

Set to true if the device can supply signature data as the signature is being captured (“real time”); otherwise, false.

CapRealTimeData is updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SignatureCapture Class
SignatureCapture Members
Microsoft.PointOfService Namespace


SignatureCapture.CapUserTerminated Property

SignatureCapture.CapUserTerminated Property |
 | See Also

1/18/2008

Indicates whether a user can terminate a signature capture.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapUserTerminated As Boolean
public abstract bool CapUserTerminated { get; }
public:
virtual property bool CapUserTerminated {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapUserTerminated ()

public abstract function get CapUserTerminated () : boolean

Remarks

Set to true if the user can terminate signature capture by checking a completion box, pressing a completion button, or performing another interaction with the device.

Contains false if the application must end signature capture by calling the EndCapture method.

CapUserTerminated is updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SignatureCapture Class
SignatureCapture Members
Microsoft.PointOfService Namespace


SignatureCapture.DataCount Property

SignatureCapture.DataCount Property |
 | See Also

1/18/2008

Holds the number of currently queued DataEvent events.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DataCount As Integer
public abstract int DataCount { get; }
public:
virtual property int DataCount {
    int get () abstract;
}
/** @property */
public abstract int get_DataCount ()

public abstract function get DataCount () : int

Remarks

The application can read this property to determine whether additional input is queued from a device but has not yet been delivered because of other application processing, freezing of events, or other causes.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SignatureCapture Class
SignatureCapture Members
Microsoft.PointOfService Namespace
Scale.DataEvent Event


SignatureCapture.DataEventEnabled Property

SignatureCapture.DataEventEnabled Property |
 | See Also

1/18/2008

Indicates whether a DataEvent event is delivered when input data is queued.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property DataEventEnabled As Boolean
public abstract bool DataEventEnabled { get; set; }
public:
virtual property bool DataEventEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_DataEventEnabled ()

/** @property */
public abstract void set_DataEventEnabled (boolean value)

public abstract function get DataEventEnabled () : boolean

public abstract function set DataEventEnabled (value : boolean)

Remarks

If true, a DataEvent is delivered as soon as input data is queued. If changed to true and some input data is already queued, then a DataEvent event is delivered immediately. (Note that other conditions may delay "immediate" delivery: if FreezeEvents is true or another event is already being processed at the application, the DataEvent remains queued until the condition is corrected.)

If false, input data is queued for later delivery to the application. Also, if an input error occurs, the ErrorEvent is not delivered while this property is false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SignatureCapture Class
SignatureCapture Members
Microsoft.PointOfService Namespace
Scale.DataEvent Event


SignatureCapture.IsExclusiveUseDevice Property

SignatureCapture.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Indicates whether or not the SignatureCapture is exclusive-use.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Property Value

A value of true indicates that the SignatureCapture is exclusive-use. Otherwise, the value will be false.

Remarks

An exclusive-use device has the following properties:

  • The application must claim the device before enabling it.

  • The application must claim and enable the device before accessing some properties or calling methods that update the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SignatureCapture Class
SignatureCapture Members
Microsoft.PointOfService Namespace


SignatureCapture.MaximumX Property

SignatureCapture.MaximumX Property |
 | See Also

1/18/2008

Holds the maximum horizontal coordinate of the signature capture device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property MaximumX As Integer
public abstract int MaximumX { get; }
public:
virtual property int MaximumX {
    int get () abstract;
}
/** @property */
public abstract int get_MaximumX ()

public abstract function get MaximumX () : int

Remarks

The value must be less than 65,536.

MaximumX is updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SignatureCapture Class
SignatureCapture Members
Microsoft.PointOfService Namespace


SignatureCapture.MaximumY Property

SignatureCapture.MaximumY Property |
 | See Also

1/18/2008

Holds the maximum vertical coordinate of the signature capture device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property MaximumY As Integer
public abstract int MaximumY { get; }
public:
virtual property int MaximumY {
    int get () abstract;
}
/** @property */
public abstract int get_MaximumY ()

public abstract function get MaximumY () : int

Remarks

The value must be less than 65,536.

MaximumY is updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SignatureCapture Class
SignatureCapture Members
Microsoft.PointOfService Namespace


SignatureCapture.PointArray Property

SignatureCapture.PointArray Property |
 | See Also

1/18/2008

Holds the signature captured from the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property PointArray As Point()
public abstract Point[] PointArray { get; }
public:
virtual property array<Point>^ PointArray {
    array<Point>^ get () abstract;
}
/** @property */
public abstract Point[] get_PointArray ()

public abstract function get PointArray () : Point[]

Remarks

PointArray consists of an array of (x, y) coordinate points. Each point is represented by four characters: x (low 8 bits), x (high 8 bits), y (low 8 bits), y (high 8 bits).

A special point value is (0xFFFF, 0xFFFF), which indicates the end of a line (that is, a pen lift). Almost all signatures include more than one line.

If the RealTimeDataEnabled property is false, PointArray contains the entire captured signature. If the RealTimeDataEnabled property is true, PointArray contains at least one point of the signature. The actual number of points delivered at one time is implementation-dependent. The points from multiple data events are logically concatenated to form the entire signature, such that the last point from a data event is followed immediately by the first point of the next data event.

The point representation definition is the same if the signature is presented as a single PointArray or as a series of real-time PointArrays.

To reconstruct the signature, a line is drawn from the first point in the signature to the second point, then to the third, and so on. When an end-of-line point is encountered, the line ends, and the next line is drawn beginning with the next point. An end-of-line point is assumed (but need not be present in PointArray) at the end of the signature.

PointArray is set just before delivering the DataEvent, or by the EndCapture method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SignatureCapture Class
SignatureCapture Members
Microsoft.PointOfService Namespace
RawData


SignatureCapture.RawData Property

SignatureCapture.RawData Property |
 | See Also

1/18/2008

Holds the signature captured from the device in a device-specific format.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property RawData As Byte()
public abstract byte[] RawData { get; }
public:
virtual property array<unsigned char>^ RawData {
    array<unsigned char>^ get () abstract;
}
/** @property */
public abstract byte[] get_RawData ()

public abstract function get RawData () : byte[]

Remarks

This data is often in a compressed form to minimize signature storage requirements. Reconstruction of the signature from this data requires device-specific processing.

RawData is set by the service object just before delivering the DataEvent or by the EndCapture method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SignatureCapture Class
SignatureCapture Members
Microsoft.PointOfService Namespace
SignatureCapture.PointArray Property


SignatureCapture.RealTimeDataEnabled Property

SignatureCapture.RealTimeDataEnabled Property |
 | See Also

1/18/2008

Indicates whether signature data can be gathered in real time.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property RealTimeDataEnabled As Boolean
public abstract bool RealTimeDataEnabled { get; set; }
public:
virtual property bool RealTimeDataEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_RealTimeDataEnabled ()

/** @property */
public abstract void set_RealTimeDataEnabled (boolean value)

public abstract function get RealTimeDataEnabled () : boolean

public abstract function set RealTimeDataEnabled (value : boolean)

Remarks

When CapRealTimeData is true and RealTimeDataEnabled is set to true, a series of partial signature data events is raised as the signature is captured until signature capture is terminated.

Else, the captured signature is raised as a single data event when signature capture is terminated.

Setting RealTimeDataEnabled will not cause any change in system behavior until a subsequent BeginCapture is performed. This prevents confusion regarding what would happen if RealTimeDataEnabled were modified between a BeginCapture - EndCapture pairing.

RealTimeDataEnabled is typically initialized to false. It should then be kept current by the service object while the device is enabled.

Accessing RealTimeDataEnabled may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | Cannot set to true because CapRealTimeData is false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SignatureCapture Class
SignatureCapture Members
Microsoft.PointOfService Namespace


SignatureCapture Events

SignatureCapture Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DataEvent | Raised by the service object to notify the application that input data is available.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
ErrorEvent | Raised by the service object to notify the application that a device error has been detected and a suitable response by the application is necessary to process the error condition.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

SignatureCapture Class
Microsoft.PointOfService Namespace


SignatureCapture.DataEvent Event

SignatureCapture.DataEvent Event |
 | See Also

1/18/2008

Raised by the service object to notify the application that input data is available.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event DataEvent As DataEventHandler
public abstract event DataEventHandler DataEvent
public:
virtual event DataEventHandler^ DataEvent {
    void add (DataEventHandler^ value) abstract;
    void remove (DataEventHandler^ value) abstract;
}
/** @event */
public abstract void add_DataEvent (DataEventHandler value)

/** @event */
public abstract void remove_DataEvent (DataEventHandler value)

Remarks

DataEvent can only be queued if the user can terminate the signature--that is, if CapUserTerminated or RealTimeDataEnabled is true.

DataEventArgs.Status contains true if the user entered a signature before terminating capture. Status contains false if the user terminated capture with no signature.

Before triggering a DataEvent event, the PointArray and RawData properties are set to appropriate values.

See Also

Reference

SignatureCapture Class
SignatureCapture Members
Microsoft.PointOfService Namespace
SignatureCapture.EndCapture Method


SignatureCapture.ErrorEvent Event

SignatureCapture.ErrorEvent Event |
 | See Also

1/18/2008

Raised by the service object to notify the application that a device error has been detected and a suitable response by the application is necessary to process the error condition.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event ErrorEvent As DeviceErrorEventHandler
public abstract event DeviceErrorEventHandler ErrorEvent
public:
virtual event DeviceErrorEventHandler^ ErrorEvent {
    void add (DeviceErrorEventHandler^ value) abstract;
    void remove (DeviceErrorEventHandler^ value) abstract;
}
/** @event */
public abstract void add_ErrorEvent (DeviceErrorEventHandler value)

/** @event */
public abstract void remove_ErrorEvent (DeviceErrorEventHandler value)

Remarks

Queued when an error is detected while trying to read signature capture data.

ErrorEvent is not delivered until the DataEventEnabled property is true and other event delivery requirements are met to ensure proper application sequencing.

See Also

Reference

SignatureCapture Class
SignatureCapture Members
Microsoft.PointOfService Namespace


SmartCardInterfaceModes Enumeration

SmartCardInterfaceModes Enumeration |
 | See Also

1/18/2008

Lists the possible communication modes for Smart Card devices.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration SmartCardInterfaceModes
[FlagsAttribute]
public enum SmartCardInterfaceModes
[FlagsAttribute]
public enum class SmartCardInterfaceModes
/** @attribute FlagsAttribute() */
public enum SmartCardInterfaceModes
FlagsAttribute
public enum SmartCardInterfaceModes

Members

Member name | Description
Apdu | Same as Block mode except that the block of string data that contains commands and data sent to the SCR/W service object conforms to the ISO/IEC 7816 APDU (Application Protocol Data Units) standard for smart cards. ISO and EMV messaging formats are supported and selectable if the SCR/W has the capability to switch to one of these formats.
Block | A block of string data that contains commands and data is sent to the SCR/W device service object. The application and the SCR/W service object need to agree upon a communication protocol and data format before using this mode.
Transaction | Basic ASCII format for commands and data interchange.
Xml | A block of string data that contains commands and data is sent to the SCR/W service object. The application and the SCR/W service object agree to use a communication protocol and data format defined in this standard consistent with the XML Data Dictionary and XML schema guidelines as outlined in the NRF-ARTS IX Retail XML standard.

Remarks

Used by the InterfaceMode and CapInterfaceMode properties. Members of this enumeration replace the SC_CMODE_ and SC_MODE_ ranges of UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
CapInterfaceMode
InterfaceMode


SmartCardIsoEmvModes Enumeration

SmartCardIsoEmvModes Enumeration |
 | See Also

1/18/2008

Lists the valid message standards for a Smart Card device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration SmartCardIsoEmvModes
[FlagsAttribute]
public enum SmartCardIsoEmvModes
[FlagsAttribute]
public enum class SmartCardIsoEmvModes
/** @attribute FlagsAttribute() */
public enum SmartCardIsoEmvModes
FlagsAttribute
public enum SmartCardIsoEmvModes

Members

Member name | Description
Emv | APDU messaging format conforms to the EMV standard.
Iso | APDU messaging format conforms to the ISO standard.

Remarks

Used by the IsoEmvMode and the CapIsoEmvMode properties. Members of this enumeration replace the SC_MODE_ISO, SC_MODE_EMV, SC_CMODE_ISO, and SC_CMODE_EMV UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace


SmartCardReadAction Enumeration

SmartCardReadAction Enumeration |
 | See Also

1/18/2008

Lists the possible types of processing of the data that is to be done by the smart card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration SmartCardReadAction
public enum SmartCardReadAction
public enum class SmartCardReadAction
public enum SmartCardReadAction
public enum SmartCardReadAction

Members

Member name | Description
ExecuteAndReadData | The data being read from the smart card present in the SCR/W is data that was processed by a program currently resident on the smart card. When this action is requested the smart card program is started and sends back the data that it has processed.
ReadData | The data being read from the smart card present in the SCR/W is from the data area on the smart card.
ReadProgram | The data being read from the smart card present in the SCR/W is an executable program that was found in the smart card memory associated with executable programs.
XmlReadBlockData | The data being read is XML data that the SCR/W is sending to the application. It is up to the application to parse the data being returned.

Remarks

Used by the ReadData method. Members of this enumeration replace the SC_READ_DATA, SC_READ_PROGRAM, SC_EXECUTE_AND_READ_DATA, and SC_XML_READ_BLOCK_DATA UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
ReadData


SmartCardRW Class

SmartCardRW Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a UPOS smart card reader/writer device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class SmartCardRW
    Inherits PosCommon
public abstract class SmartCardRW : PosCommon
public ref class SmartCardRW abstract : public PosCommon
public abstract class SmartCardRW extends PosCommon
public abstract class SmartCardRW extends PosCommon

Remarks

Capabilities

The smart card reader/writer (SCR/W) device has the following capabilities.

  • Support for the reading and writing of smart cards that conform to the ISO/IEC 7816 standard (contact type) and ISO/IEC 14443 (contactless type).

  • Interface with simple memory cards, protected or segmented memory cards, stored value memory cards, and CPU/MPU multifunction cards.

  • Functions are limited to the actual smart card read and write operations only. Full function type devices such as a “Payment Terminal” (defined as a unit that incorporates a SCR/W plus additional devices such as a PIN pad, display, signature capture, and MSR reader in an integrated device) are not covered in this peripheral class.

  • Support for smart cards that use physical electrical contacts and/or close range radio frequency to exchange power and data.

  • Ability to sense when a card is present or absent is supported.

  • Optional support of Security Application Modules (SAM) for CPU/MPU cards may be provided.

  • Up to four types of API communication methods to the SCR/W can be supported:

    Model

    Meaning

    Command and Data Mode

    Very basic ASCII format for commands and data interchange.

    Data Block Mode

    A block of string data that contains commands and data is sent to the SCR/W Device Service. The application and the SCR/W Service need to agree upon a communication protocol and data format before using this mode.

    APDU Mode

    Same as Data Block Mode except that the block of string data that contains commands and data sent to the SCR/W Service conforms to the ISO/IEC 7816 APDU (Application Protocol Data Units) standard for smart cards. ISO and EMV messaging formats are supported and selectable if the SCR/W has the capability to switch to one of these formats.

    XML Data Block Mode

    A block of string data that contains commands and data is sent to the SCR/W Service. The application and the SCR/W Service agree to use a communication protocol and data format defined in this standard consistent with the XML Data Dictionary and XML schema guidelines as outlined in the NRF-ARTS IXRetail XML standard.

Model

The general model of Smart Card Reader / Writer is as follows:

The Smart Card Reader / Writer (SCR/W) device has a wide range of uses that depend upon a variety of ISO 7816 compliant smart cards. These include cards with or without physical electrical contacts and proximity types that may function as memory cards, processor cards (T0 and/or T1 TransmissionProtocol), electronic purse cards, security access module (SAM) processor cards, and security cards. The SCR/W scope is limited to providing access to the smart card so that data retrieval, data storage, or program execution on the smart card can be implemented.

It is the responsibility of the application to have knowledge of which types of smart card transactions the SCR/W device allows. To help facilitate a wide range of uses, four different communication command and data interchange methods (InterfaceMode) are provided. As part of the initialization sequence, the application should query the CapInterfaceMode property to determine what is allowed and set the InterfaceMode property to the mode to use.

To begin operation, the application must call the Open and Claim methods to set up a communication path to the SCR/W device. When the application is ready to interact with a smart card, the DeviceEnabled property must be set to true. Then the SCR/W is able to accept a smart card; a StatusUpdateEvent is fired when one has been detected. The BeginInsertion method, with its time-out value set to a finite value, provides a way to allow the application to wait for a smart card to be detected. If the time-out value expires, the program must call another BeginInsertion method to continue its quest for detecting a smart card. Once the smart card has been detected, the application must call the EndInsertion method.

Device Sharing

The SCR/W is an exclusive-use device, as follows:

  • The application must claim the device before enabling it.

  • The application must claim and enable the device before accessing many of the SCR/W specific properties.

  • The application must claim and enable the device before calling methods that manipulate the device.

Data Transfer Modes

The SCR/W has the flexibility to be able to operate in one or more modes to enable the transfer of data to and from the smart card. When the SCR/W is initialized, the application must determine what communication and operation mode will be used based upon a query of the capabilities of the SCR/W device. The InterfaceMode property is used to store the current communication mode.

In the Command / Data mode, a simple read and write data functionality is defined between the application and the SCR/W. The commands cause the data to be retrieved from, placed onto, or placed onto and executed on the smart card currently available to the SCR/W device. Greater knowledge of the specific SCR/W device is required in this mode. The application should query the PhysicalDeviceName and/or PhysicalDeviceDescription properties and create the write data and resultant read data based upon the type of SCR/W that is connected to the system.

In the Block Transfer mode, blocks of commands/data are sent to and retrieved from the SCR/W Service. It is up to the service object to parse the commands and data from the block of information sent to it from the application and invoke the necessary function and response in the smart card currently in the SCR/W. Knowledge of the message content between the application and the SCR/W must be established when the Open method is called. The application should query the PhysicalDeviceName and/or PhysicalDeviceDescription properties and base its message content upon the type of SCR/W that is connected to the system.

In the APDU Transfer mode, blocks of data are sent to and retrieved from the SCR/W Service similar to the Block Transfer mode described above. However, in this mode the commands and data consist of string data elements that conform to the ISO/IEC 7816 APDU (Application Protocol Data Units) standard for smart card communication. Provision has been made to support the messaging requirements of ISO or EMV for operating in the APDU mode. You can query the CapIsoEmvMode property to determine what modes are supported by the device. The application then sets the IsoEmvMode property to the desired messaging scheme before sending data to and receiving data from the SCR/W device.

In the XML Block Transfer mode, blocks of data are sent to and retrieved from the SCR/W Service similar to the Block Transfer mode described above. However, in this mode the commands and data are in the form of XML messages. The data elements and schemas of these messages conform to the IXRetail Standard XML messaging as they apply to the SCR/W device.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.SmartCardRW
Microsoft.PointOfService.BasicServiceObjects.SmartCardRWBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SmartCardRW Members
Microsoft.PointOfService Namespace


SmartCardRW Members

SmartCardRW Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a UPOS smart card reader/writer device.

The following tables list the members exposed by the SmartCardRW type.

Protected Constructors

Name | Description
SmartCardRW | Creates an instance of the SmartCardRW class.
Top

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorNoCard | Indicates no card is detected in the smart card reader/writer device but a card was expected.
ExtendedErrorRead | Indicates there was a read error.
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
ExtendedErrorTorn | Indicates the smart card was prematurely removed from the smart card reader/writer unexpectedly.
ExtendedErrorWrite | Indicates there was a write error.
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusCardPresent | Indicates a card is in the device.
StatusNoCard | Indicates no card is detected in the device.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
CapCardErrorDetection | Indicates whether the smart card device can report a "torn" card.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapInterfaceMode | Indicates the interface modes the device is capable of supporting.
CapIsoEmvMode | Indicates the supported message modes when InterfaceMode is APDU.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapSCPresentSensor | Indicates if the device can sense a smart card in a user-available slot.
CapSCSlots | Indicates the number of slots available to a user.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapTransmissionProtocol | Indicates the types of transmission protocols supported by the device.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
DataCount | Holds the number of currently queued DataEvent events.
DataEventEnabled | Indicates whether a DataEvent event is delivered when input data is queued.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
InterfaceMode | Holds the current communication interface mode.
IsoEmvMode | Holds the message modes the device is using when InterfaceMode is APDU.
OutputId | Holds the identifier of the most recently started asynchronous output.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
SCPresentSensor | Indicates a smart card is in position to exchange data.
SCSlot | Holds the current slot available to a user.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
TransactionInProgress | Indicates whether a smart card has been detected.
TransmissionProtocol | Holds the transmission protocols the device currently supports.
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Indicates whether the SmartCardRW is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
BeginInsertion | Initiates smart card insertion processing.
BeginRemoval | Initiates smart card removal processing.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all queued data and input error events and sets the State property to Idle.
ClearInputProperties | Resets the values of properties altered by DataEvent or ErrorEvent.
ClearOutput | Clears all buffered output data, including all asynchronous output.
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
EndInsertion | Ends smart card insertion processing.
EndRemoval | Ends smart card removal processing.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon)
ReadData | Reads data from a smart card.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
WriteData | Writes data to a smart card.
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DataEvent | Fired by the service object to present input data from the device to an application.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
ErrorEvent | Fired by the service object to notify the application that a SCR/W error has been detected and a suitable response by the application is necessary to process the error condition.
OutputCompleteEvent | Fired by the service object to notify the application that the queued output request associated with the OutputCompleteEventArgs.OutputId property has completed successfully.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

SmartCardRW Class
Microsoft.PointOfService Namespace


SmartCardRW Fields

SmartCardRW Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorNoCard | Indicates no card is detected in the smart card reader/writer device but a card was expected.
ExtendedErrorRead | Indicates there was a read error.
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
ExtendedErrorTorn | Indicates the smart card was prematurely removed from the smart card reader/writer unexpectedly.
ExtendedErrorWrite | Indicates there was a write error.
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusCardPresent | Indicates a card is in the device.
StatusNoCard | Indicates no card is detected in the device.
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

SmartCardRW Class
Microsoft.PointOfService Namespace


SmartCardRW.ExtendedErrorNoCard Field

SmartCardRW.ExtendedErrorNoCard Field |
 | See Also

1/18/2008

Indicates no card is detected in the smart card reader/writer device but a card was expected.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorNoCard As Integer
public const int ExtendedErrorNoCard
public:
literal int ExtendedErrorNoCard
public static final int ExtendedErrorNoCard
public const var ExtendedErrorNoCard : int

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace
ErrorEvent


SmartCardRW.ExtendedErrorRead Field

SmartCardRW.ExtendedErrorRead Field |
 | See Also

1/18/2008

Indicates there was a read error.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorRead As Integer
public const int ExtendedErrorRead
public:
literal int ExtendedErrorRead
public static final int ExtendedErrorRead
public const var ExtendedErrorRead : int

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace
ErrorEvent


SmartCardRW.ExtendedErrorTorn Field

SmartCardRW.ExtendedErrorTorn Field |
 | See Also

1/18/2008

Indicates the smart card was prematurely removed from the smart card reader/writer unexpectedly.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorTorn As Integer
public const int ExtendedErrorTorn
public:
literal int ExtendedErrorTorn
public static final int ExtendedErrorTorn
public const var ExtendedErrorTorn : int

Remarks

CapCardErrorDetection capability must be true before ExtendedErrorTorn can be used.

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace
ErrorEvent


SmartCardRW.ExtendedErrorWrite Field

SmartCardRW.ExtendedErrorWrite Field |
 | See Also

1/18/2008

Indicates there was a write error.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const ExtendedErrorWrite As Integer
public const int ExtendedErrorWrite
public:
literal int ExtendedErrorWrite
public static final int ExtendedErrorWrite
public const var ExtendedErrorWrite : int

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace
ErrorEvent


SmartCardRW.StatusCardPresent Field

SmartCardRW.StatusCardPresent Field |
 | See Also

1/18/2008

Indicates a card is in the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusCardPresent As Integer
public const int StatusCardPresent
public:
literal int StatusCardPresent
public static final int StatusCardPresent
public const var StatusCardPresent : int

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace
PosCommon.StatusUpdateEvent Event


SmartCardRW.StatusNoCard Field

SmartCardRW.StatusNoCard Field |
 | See Also

1/18/2008

Indicates no card is detected in the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatusNoCard As Integer
public const int StatusNoCard
public:
literal int StatusNoCard
public static final int StatusNoCard
public const var StatusNoCard : int

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace
PosCommon.StatusUpdateEvent Event


SmartCardRW Constructor

SmartCardRW Constructor |
 | See Also

1/18/2008

Creates an instance of the SmartCardRW class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected SmartCardRW ()
protected:
SmartCardRW ()
protected SmartCardRW ()
protected function SmartCardRW ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace


SmartCardRW Methods

SmartCardRW Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
BeginInsertion | Initiates smart card insertion processing.
BeginRemoval | Initiates smart card removal processing.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearInput | Clears all queued data and input error events and sets the State property to Idle.
ClearInputProperties | Resets the values of properties altered by DataEvent or ErrorEvent.
ClearOutput | Clears all buffered output data, including all asynchronous output.
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
EndInsertion | Ends smart card insertion processing.
EndRemoval | Ends smart card removal processing.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon )
ReadData | Reads data from a smart card.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
WriteData | Writes data to a smart card.

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

SmartCardRW Class
Microsoft.PointOfService Namespace


SmartCardRW.BeginInsertion Method

SmartCardRW.BeginInsertion Method |
 | See Also

1/18/2008

Initiates smart card insertion processing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub BeginInsertion ( _
    timeout As Integer _
)
public abstract void BeginInsertion (
    int timeout
)
public:
virtual void BeginInsertion (
    int timeout
) abstract
public abstract void BeginInsertion (
    int timeout
)
public abstract function BeginInsertion (
    timeout : int
)

Parameters

timeout

The number of milliseconds before failing the method.

If zero, the method initiates insertion mode and either returns immediately if successful, or raises an exception. If WaitForever, the method initiates the begin insertion mode, then waits as long as needed until either the smart card is inserted or an error occurs.

Remarks

Called to initiate smart card insertion processing in either a contact type or contactless type SCR/W. When called, SCR/W state is changed to allow the insertion of a smart card and the smart card insertion mode is entered. This method is paired with the EndInsertion method for controlling smart card insertion.

If the SCR/W device cannot be placed into insertion mode an exception is raised. Otherwise, the service object continues to monitor smart card insertion until either the smart card is not inserted before timeout milliseconds have elapsed, or an error is reported by the SCR/W device. In the latter case, the service object raises an exception with the appropriate error code. The SCR/W device remains in smart card insertion mode. This allows an application to perform some user interaction and reissue the BeginInsertion method without altering the smart card handling mechanism.

BeginInsertion may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Busy | This operation cannot be performed because asynchronous output is in progress.
Illegal | The SCR/W does not exist or an invalid timeout parameter was specified.
Timeout | The specified time has elapsed without the smart card being properly inserted.
Extended | See below.

ExtendedError codes are as follows:

Value | Meaning
ExtendedErrorNoCard | There is no card detected in the SCR/W but a card was expected.
ExtendedErrorRead | There was a read error.
ExtendedErrorTorn | The smart card was prematurely removed from the SCR/W unexpectedly. Note: CapCardErrorDetection must be true before this can be set.
ExtendedErrorWrite | There was a write error.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace
EndInsertion
BeginRemoval
EndRemoval


SmartCardRW.BeginRemoval Method

SmartCardRW.BeginRemoval Method |
 | See Also

1/18/2008

Initiates smart card removal processing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub BeginRemoval ( _
    timeout As Integer _
)
public abstract void BeginRemoval (
    int timeout
)
public:
virtual void BeginRemoval (
    int timeout
) abstract
public abstract void BeginRemoval (
    int timeout
)
public abstract function BeginRemoval (
    timeout : int
)

Parameters

timeout

The number of milliseconds before failing the method

If 0, the method initiates the begin removal mode and either returns immediately or raises an exception. If WaitForever, the method initiates the begin removal mode, then waits as long as needed until either the smart card is removed or an error occurs.

Remarks

When called, the SCR/W is made ready to be removed from either a contact type or a contactless type SCR/W. This method is paired with the EndRemoval method for controlling smart card removal.

The contact type model that has the sensor in the entrance ends normally when a card is removed from SCR/W. The contactless model (without a sensor) ends normally when the smart card has been removed from the proximity of the SCR/W device.

If the SCR/W cannot be placed into removal or ejection mode, an exception is raised. Otherwise, the service object continues to monitor smart card removal until either the smart card is not ejected before timeout milliseconds have elapsed, or an error is reported by the SCR/W. In this case, the service object raises an exception with the appropriate error code. The SCR/W remains in smart card ejection mode. This allows an application to perform some user interaction and reissue the BeginRemoval method without altering the smart card handling mechanism.

BeginRemoval may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Busy | This operation cannot be performed because asynchronous output is in progress.
Illegal | The SCR/W does not exist or an invalid timeout parameter was specified.
Timeout | The specified time has elapsed without the smart card being properly removed.
Extended | See the table below.

Possible extended errors are as follows:

Code | Meaning
ExtendedErrorNoCard | There is no card detected in the SCR/W but a card was expected.
ExtendedErrorRead | There was a read error.
ExtendedErrorTorn | The smart card was prematurely removed from the SCR/W unexpectedly. The CapCardErrorDetection property must be true before this can be set.
ExtendedErrorNoCard | There is no card detected in the SCR/W but a card was expected.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace
SmartCardRW.BeginInsertion Method
EndInsertion
EndRemoval


SmartCardRW.ClearInput Method

SmartCardRW.ClearInput Method |
 | See Also

1/18/2008

Clears all queued data and input error events and sets the State property to Idle.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearInput
public abstract void ClearInput ()
public:
virtual void ClearInput () abstract
public abstract void ClearInput ()
public abstract function ClearInput ()

Remarks

Clears the device input that has been buffered for the unit specified by the CurrentUnitId property.

Any data events that are queued – usually waiting for DataEventEnabled to be set to true and FreezeEvents to be set to false — are also cleared.

ClearInput may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Claimed | The device is claimed by another process.
NotClaimed | The device must be claimed before ClearInput can be used.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace
ClearOutput


SmartCardRW.ClearInputProperties Method

SmartCardRW.ClearInputProperties Method |
 | See Also

1/18/2008

Resets the values of properties altered by DataEvent or ErrorEvent.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overridable Sub ClearInputProperties
public virtual void ClearInputProperties ()
public:
virtual void ClearInputProperties ()
public void ClearInputProperties ()
public function ClearInputProperties ()

Remarks

Sets all data properties populated by a firing of DataEvent or ErrorEvent back to their default values. This does not reset the DataCount or State properties.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace


SmartCardRW.ClearOutput Method

SmartCardRW.ClearOutput Method |
 | See Also

1/18/2008

Clears all buffered output data, including all asynchronous output.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearOutput
public abstract void ClearOutput ()
public:
virtual void ClearOutput () abstract
public abstract void ClearOutput ()
public abstract function ClearOutput ()

Remarks

When possible, ClearOutput also halts outputs that are in progress.

Any output error events that are queued – usually waiting for FreezeEvents to be set to false — are also cleared.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace
SmartCardRW.ClearInput Method


SmartCardRW.EndInsertion Method

SmartCardRW.EndInsertion Method |
 | See Also

1/18/2008

Ends smart card insertion processing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub EndInsertion
public abstract void EndInsertion ()
public:
virtual void EndInsertion () abstract
public abstract void EndInsertion ()
public abstract function EndInsertion ()

Remarks

When called, the SCR/W is taken out of smart card insertion mode. If no smart card is present, an exception is raised.

This method is paired with the BeginInsertion method for controlling smart card insertion in either a contact type or contactless type SCR/W.

EndInsertion may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The SCR/W is not in smart card insertion mode.
Failure | A card is not inserted in the SCR/W.
Extended | See the table below.

Possible extended error codes are as follows:

Code | Meaning
ExtendedErrorNoCard | There is no card detected in the SCR/W but a card was expected.
ExtendedErrorRead | There was a read error.
ExtendedErrorTorn | The smart card was prematurely removed from the SCR/W unexpectedly. The CapCardErrorDetection property must be true before this can be set.
ExtendedErrorNoCard | There is no card detected in the SCR/W but a card was expected.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace
SmartCardRW.BeginInsertion Method
SmartCardRW.BeginRemoval Method
EndRemoval


SmartCardRW.EndRemoval Method

SmartCardRW.EndRemoval Method |
 | See Also

1/18/2008

Ends smart card removal processing.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub EndRemoval
public abstract void EndRemoval ()
public:
virtual void EndRemoval () abstract
public abstract void EndRemoval ()
public abstract function EndRemoval ()

Remarks

When called, the SCR/W is taken out of smart card removal mode in either a contact type or contactless type SCR/W. If a smart card is present, an exception is raised. This method is paired with the BeginRemoval method for controlling smart card removal.

The application can call this method immediately after a successful BeginRemoval if it wants to use the SCR/W sensors to determine when the smart card has been removed.

Alternatively, the application can prompt the user and wait for a key press before calling EndRemoval.

EndRemoval may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The SCR/W is not in smart card insertion mode.
Failure | A card is not inserted in the SCR/W.
Extended | See the table below.

Possible extended error codes are as follows:

Code | Meaning
ExtendedErrorNoCard | There is no card detected in the SCR/W but a card was expected.
ExtendedErrorRead | There was a read error.
ExtendedErrorTorn | The smart card was prematurely removed from the SCR/W unexpectedly. The CapCardErrorDetection property must be true before this can be set.
ExtendedErrorNoCard | There is no card detected in the SCR/W but a card was expected.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace
SmartCardRW.BeginInsertion Method
SmartCardRW.BeginRemoval Method
SmartCardRW.EndInsertion Method


SmartCardRW.ReadData Method

SmartCardRW.ReadData Method |
 | See Also

1/18/2008

Reads data from a smart card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Function ReadData ( _
    action As SmartCardReadAction, _
    data As Byte() _
) As Byte()
public abstract byte[] ReadData (
    SmartCardReadAction action,
    byte[] data
)
public:
virtual array<unsigned char>^ ReadData (
    SmartCardReadAction action,
    array<unsigned char>^ data
) abstract
public abstract byte[] ReadData (
    SmartCardReadAction action,
    byte[] data
)
public abstract function ReadData (
    action : SmartCardReadAction,
    data : byte[]
) : byte[]

Parameters

action

Indicates the type of data processing to be done by the smart card.

data

The data that is to be read by the smart card.

Remarks

SmartCardReadAction returns data if successful, and may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Claimed | Cannot read because the smart card present in the SCR/W is claimed by another application.
Illegal | The action is not valid for the type of smart card present in the SCR/W or the count value is not valid for the smart card present in the SCR/W.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace
WriteData


SmartCardRW.WriteData Method

SmartCardRW.WriteData Method |
 | See Also

1/18/2008

Writes data to a smart card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub WriteData ( _
    action As SmartCardWriteAction, _
    data As Byte() _
)
public abstract void WriteData (
    SmartCardWriteAction action,
    byte[] data
)
public:
virtual void WriteData (
    SmartCardWriteAction action,
    array<unsigned char>^ data
) abstract
public abstract void WriteData (
    SmartCardWriteAction action,
    byte[] data
)
public abstract function WriteData (
    action : SmartCardWriteAction,
    data : byte[]
)

Parameters

action

Indicates the type of processing of the data that is to be done by the smart card.

data

The data that is to be sent to the smart card.

Remarks

WriteData may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Claimed | Cannot write because the smart card present in the SCR/W is claimed by another application.
Illegal | The action is not valid for the type of smart card present in the SCR/W or the count value is not valid for the smart card present in the SCR/W.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace
ReadData


SmartCardRW Properties

SmartCardRW Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
CapCardErrorDetection | Indicates whether the smart card device can report a "torn" card.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapInterfaceMode | Indicates the interface modes the device is capable of supporting.
CapIsoEmvMode | Indicates the supported message modes when InterfaceMode is APDU.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapSCPresentSensor | Indicates if the device can sense a smart card in a user-available slot.
CapSCSlots | Indicates the number of slots available to a user.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapTransmissionProtocol | Indicates the types of transmission protocols supported by the device.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
DataCount | Holds the number of currently queued DataEvent events.
DataEventEnabled | Indicates whether a DataEvent event is delivered when input data is queued.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
InterfaceMode | Holds the current communication interface mode.
IsoEmvMode | Holds the message modes the device is using when InterfaceMode is APDU.
OutputId | Holds the identifier of the most recently started asynchronous output.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
SCPresentSensor | Indicates a smart card is in position to exchange data.
SCSlot | Holds the current slot available to a user.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )
TransactionInProgress | Indicates whether a smart card has been detected.
TransmissionProtocol | Holds the transmission protocols the device currently supports.

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Indicates whether the SmartCardRW is an exclusive-use device.

See Also

Reference

SmartCardRW Class
Microsoft.PointOfService Namespace


SmartCardRW.CapCardErrorDetection Property

SmartCardRW.CapCardErrorDetection Property |
 | See Also

1/18/2008

Indicates whether the smart card device can report a "torn" card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapCardErrorDetection As Boolean
public abstract bool CapCardErrorDetection { get; }
public:
virtual property bool CapCardErrorDetection {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapCardErrorDetection ()

public abstract function get CapCardErrorDetection () : boolean

Remarks

If true, then the SCR/W has the ability to report that the smart card has been "torn" (removed before all transfers have been completed) from the device; otherwise, false.

An ErrorEvent is only fired (and DeviceErrorEventArgs.ErroCodeExtended set to ExtendedErrorTorn) if a "torn" error is detected and CapCardErrorDetection is true.

CapCardErrorDetection is set and updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace
PointCardRW.ErrorEvent Event


SmartCardRW.CapInterfaceMode Property

SmartCardRW.CapInterfaceMode Property |
 | See Also

1/18/2008

Indicates the interface modes the device is capable of supporting.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapInterfaceMode As SmartCardInterfaceModes
public abstract SmartCardInterfaceModes CapInterfaceMode { get; }
public:
virtual property SmartCardInterfaceModes CapInterfaceMode {
    SmartCardInterfaceModes get () abstract;
}
/** @property */
public abstract SmartCardInterfaceModes get_CapInterfaceMode ()

public abstract function get CapInterfaceMode () : SmartCardInterfaceModes

Remarks

The modes a smart card R/W device can support are a simple transaction command and data mode, a block data mode, APDU format block data mode, or a block XML data mode that uses the IXRetail Standard for SCR/W functionality.

The InterfaceMode property reflects the currently selected interface mode that the application is using to communicate with the device. CapInterfaceMode is a bitwise logical OR combination of any of the following values:

Value | Meaning
Transaction | Simple Transaction Command and Data Mode
Block | Block Data Mode
Apdu | Same as Block Data Mode except APDU Standard Commands are used
Xml | XML Block Data Mode

The CapInterfaceMode property is updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace
InterfaceMode
IsoEmvMode


SmartCardRW.CapIsoEmvMode Property

SmartCardRW.CapIsoEmvMode Property |
 | See Also

1/18/2008

Indicates the supported message modes when InterfaceMode is APDU.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapIsoEmvMode As SmartCardIsoEmvModes
public abstract SmartCardIsoEmvModes CapIsoEmvMode { get; }
public:
virtual property SmartCardIsoEmvModes CapIsoEmvMode {
    SmartCardIsoEmvModes get () abstract;
}
/** @property */
public abstract SmartCardIsoEmvModes get_CapIsoEmvMode ()

public abstract function get CapIsoEmvMode () : SmartCardIsoEmvModes

Remarks

This capability indicates the message modes the SCR/W supports in order to interoperate with a smart card when the InterfaceMode property is set to APDU. The APDU messaging format is depends on whether you want to use the ISO or EMV standard. The IsoEmvMode property is used to select the APDU mode that the SCR/W is currently using to interoperate with the smart card.

CapIsoEmvMode is a bitwise logical OR combination of any of the following values:

Value | Meaning
Iso | APDU messaging format conforms to the ISO standard.
Emv | APDU messaging format conforms to the EMV standard.

CapIsoEmvMode is set and updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace
IsoEmvMode
InterfaceMode


SmartCardRW.CapSCPresentSensor Property

SmartCardRW.CapSCPresentSensor Property |
 | See Also

1/18/2008

Indicates if the device can sense a smart card in a user-available slot.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSCPresentSensor As Integer
public abstract int CapSCPresentSensor { get; }
public:
virtual property int CapSCPresentSensor {
    int get () abstract;
}
/** @property */
public abstract int get_CapSCPresentSensor ()

public abstract function get CapSCPresentSensor () : int

Remarks

This property indicates if the SCR/W device can sense if a smart card is present in one of the available slots (entry points and/or proximity zones) where a user can insert a smart card. The SCR/W device always has a minimum of one slot available (designated as the default slot) indicated by the LSB. CapSCPresentSensor is a bitwise logical OR combination of any of the int32 bits with bit 0 (LSB) slot 0 (default); bit 1, slot 1; bit 2, slot 2; and so on. If the bit value is 1, then the SCR/W has a sensor that can detect when a smart card is present; the bit value is 0 if it does not.

CapSCPresentSensor is set and updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace
SCPresentSensor


SmartCardRW.CapSCSlots Property

SmartCardRW.CapSCSlots Property |
 | See Also

1/18/2008

Indicates the number of slots available to a user.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapSCSlots As Integer
public abstract int CapSCSlots { get; }
public:
virtual property int CapSCSlots {
    int get () abstract;
}
/** @property */
public abstract int get_CapSCSlots ()

public abstract function get CapSCSlots () : int

Remarks

This capability indicates the number of available slots (entry points and/or proximity zones) where a user can insert a smart card for detection in the SCR/W device. The application can select the slot to use by setting the SCSlot property to one of the allowable CapSCSlots values. The device will always have a minimum of one slot available (designated as the default slot) indicated by the LSB set to one.

CapSCSlots is a bitwise logical OR combination of any of the int32 bits with bit 0 (LSB) slot 0 (default); bit 1, slot 1; bit 2, slot 2; and so on.

CapSCSlots is set and updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace
SCSlot


SmartCardRW.CapTransmissionProtocol Property

SmartCardRW.CapTransmissionProtocol Property |
 | See Also

1/18/2008

Indicates the types of transmission protocols supported by the device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapTransmissionProtocol As SmartCardTransmissionProtocols
public abstract SmartCardTransmissionProtocols CapTransmissionProtocol { get; }
public:
virtual property SmartCardTransmissionProtocols CapTransmissionProtocol {
    SmartCardTransmissionProtocols get () abstract;
}
/** @property */
public abstract SmartCardTransmissionProtocols get_CapTransmissionProtocol ()

public abstract function get CapTransmissionProtocol () : SmartCardTransmissionProtocols

Remarks

This capability indicates the types of ISO 7816-3 transmission protocols that the SCR/W device is capable of supporting, T=0 (asynchronous half-duplex character transmission protocol), T=1 (asynchronous half-duplex block transmission protocol). The TransmissionProtocol property reflects the currently selected transmission protocol being used to communicate with the device.

CapTransmissionProtocol is a bitwise logical OR combination of any of the following values:

Value | Meaning
T0 | Asynchronous, Half Duplex, Character, Transmission Protocol Mode
T1 | Asynchronous, Half Duplex, Block Transmission Protocol Mode

CapTransmissionProtocol is set and updated by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace
TransmissionProtocol


SmartCardRW.DataCount Property

SmartCardRW.DataCount Property |
 | See Also

1/18/2008

Holds the number of currently queued DataEvent events.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property DataCount As Integer
public abstract int DataCount { get; }
public:
virtual property int DataCount {
    int get () abstract;
}
/** @property */
public abstract int get_DataCount ()

public abstract function get DataCount () : int

Remarks

The application can read DataCount to determine whether additional input is queued from a device but has not yet been delivered because of other application processing, freezing of events, or other causes.

DataCount is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace


SmartCardRW.DataEventEnabled Property

SmartCardRW.DataEventEnabled Property |
 | See Also

1/18/2008

Indicates whether a DataEvent event is delivered when input data is queued.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property DataEventEnabled As Boolean
public abstract bool DataEventEnabled { get; set; }
public:
virtual property bool DataEventEnabled {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_DataEventEnabled ()

/** @property */
public abstract void set_DataEventEnabled (boolean value)

public abstract function get DataEventEnabled () : boolean

public abstract function set DataEventEnabled (value : boolean)

Remarks

If true, a DataEvent is delivered as soon as input data is queued. If changed to true and some input data is already queued, then a DataEvent event is delivered immediately. (Note that other conditions may delay "immediate" delivery: if FreezeEvents is true or another event is already being processed at the application, the DataEvent remains queued until the condition is corrected.)

If false, input data is queued for later delivery to the application. Also, if an input error occurs, the ErrorEvent is not delivered while this property is false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace


SmartCardRW.InterfaceMode Property

SmartCardRW.InterfaceMode Property |
 | See Also

1/18/2008

Holds the current communication interface mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property InterfaceMode As SmartCardInterfaceModes
public abstract SmartCardInterfaceModes InterfaceMode { get; set; }
public:
virtual property SmartCardInterfaceModes InterfaceMode {
    SmartCardInterfaceModes get () abstract;
    void set (SmartCardInterfaceModes value) abstract;
}
/** @property */
public abstract SmartCardInterfaceModes get_InterfaceMode ()

/** @property */
public abstract void set_InterfaceMode (SmartCardInterfaceModes value)

public abstract function get InterfaceMode () : SmartCardInterfaceModes

public abstract function set InterfaceMode (value : SmartCardInterfaceModes)

Remarks

Valid modes are defined by the SmartCardInterfaceModes enumeration.

InterfaceMode indicates the current communication interface mode that the SCR/W device is using to communicate with the application. The CapInterfaceMode property contains the interface modes that are supported by the SCR/ W service object. If an InterfaceMode is selected that is not consistent with CapInterfaceMode, a POS for .NET exception is thrown. InterfaceMode can be one of the following values:

Value | Meaning
Transaction | Simple Transaction Command and Data Mode
Block | Block Data Mode
Apdu | Same as Block Data Mode except APDU Standard. Defines the Commands and data.
Xml | XML Block Data Mode

InterfaceMode is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace
SmartCardRW.CapInterfaceMode Property


SmartCardRW.IsExclusiveUseDevice Property

SmartCardRW.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Indicates whether the SmartCardRW is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Property Value

A value of true indicates that the SmartCardRW is exclusive-use. Otherwise, the value is false.

Remarks

An exclusive-use device has the following properties:

  • The application must claim the device before enabling it.

  • The application must claim and enable the device before accessing some properties or calling methods that update the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace


SmartCardRW.IsoEmvMode Property

SmartCardRW.IsoEmvMode Property |
 | See Also

1/18/2008

Holds the message modes the device is using when InterfaceMode is APDU.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property IsoEmvMode As SmartCardIsoEmvModes
public abstract SmartCardIsoEmvModes IsoEmvMode { get; set; }
public:
virtual property SmartCardIsoEmvModes IsoEmvMode {
    SmartCardIsoEmvModes get () abstract;
    void set (SmartCardIsoEmvModes value) abstract;
}
/** @property */
public abstract SmartCardIsoEmvModes get_IsoEmvMode ()

/** @property */
public abstract void set_IsoEmvMode (SmartCardIsoEmvModes value)

public abstract function get IsoEmvMode () : SmartCardIsoEmvModes

public abstract function set IsoEmvMode (value : SmartCardIsoEmvModes)

Remarks

Possible message modes are defined by the SmartCardIsoEmvModes enumeration.

This IsoEmvMode indicates the message modes the SCR/W is using to interoperate with a smart card when the InterfaceMode is set to APDU. The APDU messaging format is dependent upon whether you want to use the ISO or EMV standard. The CapIsoEmvMode property defines the available modes the SCR/W supports and the IsoEmvMode property is set to reflect the mode that is in use by the SCR/W device. IsoEmvMode can be one of the following values:

Value | Meaning
Iso | APDU messaging format in use conforms to the ISO standard.
Emv | APDU messaging format in use conforms to the EMV standard.

IsoEmvMode is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace
SmartCardRW.CapIsoEmvMode Property
SmartCardRW.InterfaceMode Property


SmartCardRW.OutputId Property

SmartCardRW.OutputId Property |
 | See Also

1/18/2008

Holds the identifier of the most recently started asynchronous output.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property OutputId As Integer
public abstract int OutputId { get; }
public:
virtual property int OutputId {
    int get () abstract;
}
/** @property */
public abstract int get_OutputId ()

public abstract function get OutputId () : int

Remarks

When a method successfully initiates an asynchronous output, the device assigns an identifier to the request. When the output completes, an OutputCompleteEvent is queued with this output ID as a parameter.

The output ID numbers are assigned by POS for .NET and are guaranteed to be unique among the set of outstanding asynchronous outputs. No other facts about the ID should be assumed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace


SmartCardRW.SCPresentSensor Property

SmartCardRW.SCPresentSensor Property |
 | See Also

1/18/2008

Indicates a smart card is in position to exchange data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property SCPresentSensor As Integer
public abstract int SCPresentSensor { get; }
public:
virtual property int SCPresentSensor {
    int get () abstract;
}
/** @property */
public abstract int get_SCPresentSensor ()

public abstract function get SCPresentSensor () : int

Remarks

SCPresentSensor indicates that a smart card has been detected in one of the supported slots present in the SCR/W device and is in a position to exchange data with the application. This property is only active if the CapSCPresentSensor property confirms that a smart-card-present sensor is supported by the slot. The SCR/W device always has a minimum of one slot available (designated as the default slot) indicated by the LSB, but may or may not support a smart-card-present sensor. SCPresentSensor is a bitwise logical OR combination of any of the int32 bits with bit 0 (LSB) slot 0 (default); bit 1, slot 1; bit 2, slot 2; and so on. If the bit value is 1, then the sensor indicates that a smart card is present; the bit value is 0 if it does not.

SCPresentSensor is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace
SmartCardRW.CapSCPresentSensor Property


SmartCardRW.SCSlot Property

SmartCardRW.SCSlot Property |
 | See Also

1/18/2008

Holds the current slot available to a user.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property SCSlot As Integer
public abstract int SCSlot { get; set; }
public:
virtual property int SCSlot {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_SCSlot ()

/** @property */
public abstract void set_SCSlot (int value)

public abstract function get SCSlot () : int

public abstract function set SCSlot (value : int)

Remarks

SCSlot indicates the current slot (entry point or proximity zone) where a user can insert a smart card for detection in the SCR/W device. The application can select the slot to use by setting the SCSlot property to one of the allowable CapSCSlots values. The device always has a minimum of one slot available (designated as the default, slot 0) indicated by the LSB set to one. SCSlot can be set by the application to one of the CapSCSlots values as follows:

bit 0 (LSB) slot 0 (default); bit 1, slot 1; bit 2, slot 2; and so on.

SCSlot is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace
SmartCardRW.CapSCSlots Property


SmartCardRW.TransactionInProgress Property

SmartCardRW.TransactionInProgress Property |
 | See Also

1/18/2008

Indicates whether a smart card has been detected.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property TransactionInProgress As Boolean
public abstract bool TransactionInProgress { get; }
public:
virtual property bool TransactionInProgress {
    bool get () abstract;
}
/** @property */
public abstract boolean get_TransactionInProgress ()

public abstract function get TransactionInProgress () : boolean

Remarks

If true, a smart card has been detected and active interchange of information with the smart card is taking place.

TransactionInProgress is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace
SmartCardRW.SCPresentSensor Property


SmartCardRW.TransmissionProtocol Property

SmartCardRW.TransmissionProtocol Property |
 | See Also

1/18/2008

Holds the transmission protocols the device currently supports.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property TransmissionProtocol As SmartCardTransmissionProtocols
public abstract SmartCardTransmissionProtocols TransmissionProtocol { get; }
public:
virtual property SmartCardTransmissionProtocols TransmissionProtocol {
    SmartCardTransmissionProtocols get () abstract;
}
/** @property */
public abstract SmartCardTransmissionProtocols get_TransmissionProtocol ()

public abstract function get TransmissionProtocol () : SmartCardTransmissionProtocols

Remarks

Possible protocols are defined by the SmartCardTransmissionProtocols enumeration.

TransmissionProtocol indicates the type of ISO 7816-3 transmission protocols that the SCR/W device is currently supporting, T=0 (asynchronous half duplex character transmission protocol) or T=1 (asynchronous half duplex block transmission protocol). The TransmissionProtocol property reflects the selected transmission protocol being used to communicate with the device.

TransmissionProtocol is a bitwise data element based upon the supported modes as defined by the CapTransmissionProtocol property and can be one of the following values:

Value | Meaning
T0 | Asynchronous, half duplex, character, transmission protocol mode
T1 | Asynchronous, half duplex, block transmission protocol mode

TransmissionProtocol is set and kept current by the service object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace
SmartCardRW.CapTransmissionProtocol Property


SmartCardRW Events

SmartCardRW Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DataEvent | Fired by the service object to present input data from the device to an application.
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
ErrorEvent | Fired by the service object to notify the application that a SCR/W error has been detected and a suitable response by the application is necessary to process the error condition.
OutputCompleteEvent | Fired by the service object to notify the application that the queued output request associated with the OutputCompleteEventArgs.OutputId property has completed successfully.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

SmartCardRW Class
Microsoft.PointOfService Namespace


SmartCardRW.DataEvent Event

SmartCardRW.DataEvent Event |
 | See Also

1/18/2008

Fired by the service object to present input data from the device to an application.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event DataEvent As DataEventHandler
public abstract event DataEventHandler DataEvent
public:
virtual event DataEventHandler^ DataEvent {
    void add (DataEventHandler^ value) abstract;
    void remove (DataEventHandler^ value) abstract;
}
/** @event */
public abstract void add_DataEvent (DataEventHandler value)

/** @event */
public abstract void remove_DataEvent (DataEventHandler value)

Remarks

The smart card data is placed in each applicable property before DataEvent is delivered.

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace


SmartCardRW.ErrorEvent Event

SmartCardRW.ErrorEvent Event |
 | See Also

1/18/2008

Fired by the service object to notify the application that a SCR/W error has been detected and a suitable response by the application is necessary to process the error condition.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event ErrorEvent As DeviceErrorEventHandler
public abstract event DeviceErrorEventHandler ErrorEvent
public:
virtual event DeviceErrorEventHandler^ ErrorEvent {
    void add (DeviceErrorEventHandler^ value) abstract;
    void remove (DeviceErrorEventHandler^ value) abstract;
}
/** @event */
public abstract void add_ErrorEvent (DeviceErrorEventHandler value)

/** @event */
public abstract void remove_ErrorEvent (DeviceErrorEventHandler value)

Remarks

Input error events are generated when errors occur while reading the data from a newly inserted smart card. These error events are not delivered until the DataEventEnabled property is set to true to allow proper application sequencing. All error information is placed into the applicable properties before this event is delivered.

Output error events are generated and delivered when an error occurs during asynchronous WriteData processing. The errors are placed into the applicable properties before the event is delivered.

The DeviceErrorEventArgs object contains the error information.

If DeviceErrorEventArgs.ErrorCode is Extended, then ErrorCodeExtended has one of the following values:

Code | Meaning
ExtendedErrorNoCard | There is no card detected in the SCR/W but a card was expected.
ExtendedErrorRead | There was a read error.
ExtendedErrorTorn | The smart card was prematurely removed from the SCR/W unexpectedly. The CapCardErrorDetection property must be true before this can be set.
ExtendedErrorNoCard | There is no card detected in the SCR/W but a card was expected.

DeviceErrorEventArgs.ErrorResponse is preset to a default value based on ErrorLocus.

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace
SmartCardRW.CapCardErrorDetection Property
SmartCardRW.SCPresentSensor Property
ReadData
SmartCardRW.WriteData Method


SmartCardRW.OutputCompleteEvent Event

SmartCardRW.OutputCompleteEvent Event |
 | See Also

1/18/2008

Fired by the service object to notify the application that the queued output request associated with the OutputCompleteEventArgs.OutputId property has completed successfully.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event OutputCompleteEvent As OutputCompleteEventHandler
public abstract event OutputCompleteEventHandler OutputCompleteEvent
public:
virtual event OutputCompleteEventHandler^ OutputCompleteEvent {
    void add (OutputCompleteEventHandler^ value) abstract;
    void remove (OutputCompleteEventHandler^ value) abstract;
}
/** @event */
public abstract void add_OutputCompleteEvent (OutputCompleteEventHandler value)

/** @event */
public abstract void remove_OutputCompleteEvent (OutputCompleteEventHandler value)

Remarks

OutputCompleteEvent is queued after the request's data has been both sent and POS for .NET has confirmation that is was processed by the device successfully.

See Also

Reference

SmartCardRW Class
SmartCardRW Members
Microsoft.PointOfService Namespace


SmartCardTransmissionProtocols Enumeration

SmartCardTransmissionProtocols Enumeration |
 | See Also

1/18/2008

Lists the possible types of transmission protocols for a Smart Card device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration SmartCardTransmissionProtocols
[FlagsAttribute]
public enum SmartCardTransmissionProtocols
[FlagsAttribute]
public enum class SmartCardTransmissionProtocols
/** @attribute FlagsAttribute() */
public enum SmartCardTransmissionProtocols
FlagsAttribute
public enum SmartCardTransmissionProtocols

Members

Member name | Description
T0 | Asynchronous, Half Duplex, Character, Transmission Protocol Mode
T1 | Asynchronous, Half Duplex, Block Transmission Protocol Mode

Remarks

Used by the CapTransmissionProtocol and TransmissionProtocol properties. Members of this enumeration replace the SC_CTRANS_PROTOCOL_T0, SC_CTRANS_PROTOCOL_T1, SC_TRANS_PROTOCOL_T0, and SC_TRANS_PROTOCOL_T1 UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
SmartCardRW.CapTransmissionProtocol Property
SmartCardRW.TransmissionProtocol Property


SmartCardWriteAction Enumeration

SmartCardWriteAction Enumeration |
 | See Also

1/18/2008

Lists the possible types of processing of the data that is to be done by the smart card.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration SmartCardWriteAction
public enum SmartCardWriteAction
public enum class SmartCardWriteAction
public enum SmartCardWriteAction
public enum SmartCardWriteAction

Members

Member name | Description
ExecuteData | The data being sent to the smart card present in the SCR/W is to be stored in the data area on the smart card.
Reset | The smart card present in the SCR/W is instructed to reset to its "power on" state and ready to execute an application command.
SecurityFuse | The smart card present in the SCR/W will have its security fuse activated to prevent future data from being stored in the smart card.
StoreData | The data being sent to the smart card present in the SCR/W is to be stored in the data area on the smart card.
StoreProgram | The data being sent to the smart card present in the SCR/W is an executable program and is placed in the smart card memory associated with executable programs.
XmlBlockData | The data being sent is XML data and is to be parsed by the SCR/W to determine what actions are to take place.

Remarks

Used by the WriteData method. Members of this enumeration replace the SC_STORE_ range of UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
SmartCardRW.WriteData Method


Statistic Class

Statistic Class |
 | See Also Members

1/18/2008

Defines the programmatic interface used to create an array, or list, of device statistics.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Class Statistic
public class Statistic
public ref class Statistic
public class Statistic
public class Statistic

Remarks

Used by the UpdateStatistics method of the PosCommon class. UpdateStatistics is inherited by each of the 36 device classes. Also used by the UpdateStatistics method of the DeviceStatistics class.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.Statistic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Statistic Members
Microsoft.PointOfService Namespace


Statistic Members

Statistic Members |
 | See Also Constructors Methods Properties

1/18/2008

Defines the programmatic interface used to create an array, or list, of device statistics.

The following tables list the members exposed by the Statistic type.

Public Constructors

Name | Description
Statistic | Initializes a new instance of Statistic from parameters specifying the instance's constituent parts.
Top

Public Properties

Name | Description
Name | Holds the name of the statistic.
Value | Holds the value for the statistic specified in Name.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

Statistic Class
Microsoft.PointOfService Namespace


Statistic Constructor

Statistic Constructor |
 | See Also

1/18/2008

Initializes a new instance of Statistic from parameters specifying the instance's constituent parts.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    name As String, _
    value As Object _
)
public Statistic (
    string name,
    Object value
)
public:
Statistic (
    String^ name,
    Object^ value
)
public Statistic (
    String name,
    Object value
)
public function Statistic (
    name : String,
    value : Object
)

Parameters

name

Statistic name.

value

Statistic value.

See Also

Reference

Statistic Class
Statistic Members
Microsoft.PointOfService Namespace


Statistic Methods

Statistic Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

Statistic Class
Microsoft.PointOfService Namespace


Statistic Properties

Statistic Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
Name | Holds the name of the statistic.
Value | Holds the value for the statistic specified in Name.

See Also

Reference

Statistic Class
Microsoft.PointOfService Namespace


Statistic.Name Property

Statistic.Name Property |
 | See Also

1/18/2008

Holds the name of the statistic.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Name As String
public string Name { get; }
public:
property String^ Name {
    String^ get ();
}
/** @property */
public String get_Name ()

public function get Name () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Statistic Class
Statistic Members
Microsoft.PointOfService Namespace


Statistic.Value Property

Statistic.Value Property |
 | See Also

1/18/2008

Holds the value for the statistic specified in Name.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Property Value As Object
public Object Value { get; set; }
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
/** @property */
public Object get_Value ()

/** @property */
public void set_Value (Object value)

public function get Value () : Object

public function set Value (value : Object)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Statistic Class
Statistic Members
Microsoft.PointOfService Namespace


StatisticCategories Enumeration

StatisticCategories Enumeration |
 | See Also

1/18/2008

Lists the possible categories of device statistics that can be retrieved, reset, or updated.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration StatisticCategories
[FlagsAttribute]
public enum StatisticCategories
[FlagsAttribute]
public enum class StatisticCategories
/** @attribute FlagsAttribute() */
public enum StatisticCategories
FlagsAttribute
public enum StatisticCategories

Members

Member name | Description
All | All available statistics for the device.
Manufacturer | Manufacturer-defined statistics.
Upos | Unified POS-defined statistics.

Remarks

Used by the ResetStatistics, RetrieveStatistics, and UpdateStatistics methods. Members of this enumeration replace the ALL, U_, and M_ UPOS designations for the statistics parameters in these methods.

See Also

Reference

Microsoft.PointOfService Namespace
PosCommon.ResetStatistics Method
PosCommon.RetrieveStatistics Method
PosCommon.UpdateStatistics Method


StatusNotify Enumeration

StatusNotify Enumeration |
 | See Also

1/18/2008

Lists the possible scale weight notification capabilities a service object can use for a Scale device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration StatusNotify
public enum StatusNotify
public enum class StatusNotify
public enum StatusNotify
public enum StatusNotify

Members

Member name | Description
Disabled | The service object will not provide any scale weight state notifications to the application or set any related ExtendedErrorCode values. No scale weight state notification StatusUpdateEvents will be raised, and ScaleLiveWeight may not be set.
Enabled | The service object will raise scale weight state notification StatusUpdateEvents and update the ScaleLiveWeight property beginning when DeviceEnabled is set to TRUE.

Remarks

Used by the StatusNotify property. Members of this enumeration replace the SCL_SN_DISABLED and SCL_SN_ENABLED UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace


StatusUpdateEventArgs Class

StatusUpdateEventArgs Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for the transmission of Status Update Events.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<SerializableAttribute> _
Public Class StatusUpdateEventArgs
    Inherits PosEventArgs
[SerializableAttribute]
public class StatusUpdateEventArgs : PosEventArgs
[SerializableAttribute]
public ref class StatusUpdateEventArgs : public PosEventArgs
/** @attribute SerializableAttribute() */
public class StatusUpdateEventArgs extends PosEventArgs
SerializableAttribute
public class StatusUpdateEventArgs extends PosEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Microsoft.PointOfService.PosEventArgs
Microsoft.PointOfService.StatusUpdateEventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

StatusUpdateEventArgs Members
Microsoft.PointOfService Namespace
PosCommon.StatusUpdateEvent Event


StatusUpdateEventArgs Members

StatusUpdateEventArgs Members |
 | See Also Constructors Fields Methods Properties

1/18/2008

Defines the programmatic interface for the transmission of Status Update Events.

The following tables list the members exposed by the StatusUpdateEventArgs type.

Public Constructors

Name | Description
StatusUpdateEventArgs | Creates an instance of the StatusUpdateEventArgs class with the specified data.
Top

Public Fields

Name | Description
Empty | (inherited from EventArgs )
Top

Public Properties

Name | Description
EventId | Gets the event identifier. (inherited from PosEventArgs)
Status | Holds the device-specific status, describing the type of status change.
TimeStamp | Gets the DateTime of the event. (inherited from PosEventArgs)
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Overridden.
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

StatusUpdateEventArgs Class
Microsoft.PointOfService Namespace
PosCommon.StatusUpdateEvent Event


StatusUpdateEventArgs Fields

StatusUpdateEventArgs Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
Empty | (inherited from EventArgs )

See Also

Reference

StatusUpdateEventArgs Class
Microsoft.PointOfService Namespace
PosCommon.StatusUpdateEvent Event


StatusUpdateEventArgs Constructor

StatusUpdateEventArgs Constructor |
 | See Also

1/18/2008

Creates an instance of the StatusUpdateEventArgs class with the specified data.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    status As Integer _
)
public StatusUpdateEventArgs (
    int status
)
public:
StatusUpdateEventArgs (
    int status
)
public StatusUpdateEventArgs (
    int status
)
public function StatusUpdateEventArgs (
    status : int
)

Parameters

status

Device-specific status, describing the type of status change.

See Also

Reference

StatusUpdateEventArgs Class
StatusUpdateEventArgs Members
Microsoft.PointOfService Namespace


StatusUpdateEventArgs Methods

StatusUpdateEventArgs Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Overridden.

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

StatusUpdateEventArgs Class
Microsoft.PointOfService Namespace
PosCommon.StatusUpdateEvent Event


StatusUpdateEventArgs.ToString Method

StatusUpdateEventArgs.ToString Method |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function ToString As String
public override string ToString ()
public:
virtual String^ ToString () override
public String ToString ()
public override function ToString () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

StatusUpdateEventArgs Class
StatusUpdateEventArgs Members
Microsoft.PointOfService Namespace


StatusUpdateEventArgs Properties

StatusUpdateEventArgs Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
EventId | Gets the event identifier. (inherited from PosEventArgs )
Status | Holds the device-specific status, describing the type of status change.
TimeStamp | Gets the DateTime of the event. (inherited from PosEventArgs )

See Also

Reference

StatusUpdateEventArgs Class
Microsoft.PointOfService Namespace
PosCommon.StatusUpdateEvent Event


StatusUpdateEventArgs.Status Property

StatusUpdateEventArgs.Status Property |
 | See Also

1/18/2008

Holds the device-specific status, describing the type of status change.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Status As Integer
public int Status { get; }
public:
property int Status {
    int get ();
}
/** @property */
public int get_Status ()

public function get Status () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

StatusUpdateEventArgs Class
StatusUpdateEventArgs Members
Microsoft.PointOfService Namespace


StatusUpdateEventHandler Delegate

StatusUpdateEventHandler Delegate |
 | See Also

1/18/2008

Defines the method that will handle a StatusUpdateEventArgs events.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Delegate Sub StatusUpdateEventHandler ( _
    sender As Object, _
    e As StatusUpdateEventArgs _
)
public delegate void StatusUpdateEventHandler (
    Object sender,
    StatusUpdateEventArgs e
)
public delegate void StatusUpdateEventHandler (
    Object^ sender,
    StatusUpdateEventArgs^ e
)
/** @delegate */
public delegate void StatusUpdateEventHandler (
    Object sender,
    StatusUpdateEventArgs e
)

Parameters

sender

The object that triggers the StatusUpdateEvent.

e

A StatusUpdateEventArgs object.

Remarks

Delegate for handling StatusUpdateEvent events.

See Also

Reference

Microsoft.PointOfService Namespace


SystemStateChangeReason Enumeration

SystemStateChangeReason Enumeration |
 | See Also

1/18/2008

Lists the possible actions an application can allow for a PosPower device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration SystemStateChangeReason
public enum SystemStateChangeReason
public enum class SystemStateChangeReason
public enum SystemStateChangeReason
public enum SystemStateChangeReason

Members

Member name | Description
Allow | The request should be allowed.
Deny | The request should be denied.
Request | The system should enter the requested standby or suspend state.

Remarks

Used by the StandbyPos and SuspendPos methods. Members of this enumeration replace the PWR_REASON_REQUEST, PWR_REASON_ALLOW, and PWR_REASON_DENY UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace


ToneIndicator Class

ToneIndicator Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for a UPOS Tone Indicator device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustInherit Class ToneIndicator
    Inherits PosCommon
public abstract class ToneIndicator : PosCommon
public ref class ToneIndicator abstract : public PosCommon
public abstract class ToneIndicator extends PosCommon
public abstract class ToneIndicator extends PosCommon

Remarks

Capabilities

The Tone Indicator Service Object has the following capabilities:

  • Sound a tone device that may be the computer system speaker or another hardware device. Frequently the computer speaker is not available or is in a position that is inaudible to the operator.

  • Sound a 2-tone indicator, providing simple pitch and volume control.

  • Provide a synchronous 1-shot (play once while waiting) indicator, similar to the Win32 Beep function.

Model

The Tone Indicator device is for use when the POS hardware platform provides such capabilities external to the computer standard speaker. Many POS systems have such devices (for example, an ICL 92R keyboard) so that an indicator is always present at the point of sale.

This device supports a 2-tone sound so that "siren" tones can be produced. The indicator is generally also started asynchronously so applications can perform other functions while they wait for the user to acknowledge the tone. There are also options to start the tone asynchronously without a count so that it runs forever, and can be stopped when it runs.

When the indicator is started asynchronously, an OutputCompleteEvent event is raised when all the tones have been played. This enables the application to know that the tone has stopped. For example, when the cash drawer is opened the tone can be started quietly for a given number of cycles. If the cash drawer is closed, the tone is stopped explicitly by the application; if not, the OutputCompleteEvent enables you to alter the prompt to the operator and possibly restart the tone a bit louder.

The Tone Indicator follows the general output model. Asynchronous output is handled as follows:

  • The Service Object buffers the request, sets the OutputId property to an identifier for this request, and returns as soon as possible. When the device completes the request successfully, then the Service Object raises an OutputCompleteEvent event. A parameter of this event contains the OutputId of the completed request.

  • The Sound method does not return an error status because of a hardware problem. These errors are only reported by an ErrorEvent event. An error status is returned only if the Service Object is claimed by another application, is not enabled, a parameter is invalid, or the request cannot be queued. The first three error cases occur because of an application error, while the last is a system resource exception.

If an error occurs while it performs an asynchronous request, an ErrorEvent event is fired.

The Service Object guarantees that asynchronous output is performed on a first-in first-out basis.

All output buffered by POS for .NET can be deleted by calling the ClearOutput method. OutputCompleteEvents events are not raised for cleared output. This method also stops any output that may be in progress (when it is possible).

Device Sharing

The Tone Indicator is a shareable device. Its device-sharing rules are as follows:

After the application opens and enables the device, the application can access all properties and methods and receive StatusUpdateEvent events.

If more than one application has opened and enabled the device, all applications can access its properties and methods. StatusUpdateEvent events are raised to all the applications.

If one application claims the Tone Indicator, then only that application can call the Sound and SoundImmediate methods. Use of this feature effectively restricts the Tone Indicator to the main POS application if that application claims the device at startup.

The application that starts asynchronous sounds is the only one that receives the corresponding OutputCompleteEvent event or ErrorEvent event.

If a scenario exists in such a way that an application is playing a sound and a separate application legally claims the device and plays a sound, then the sound being played from the first application is interrupted. If the first application is in the middle of a synchronous Sound method, it returns the Claimed property from the method call. If the application has issued an asynchronous Sound method, then no consistent reporting mechanism is possible and the first sound is stopped.

Example

The following example sets up an asynchronous 2-tone indicator and sounds it 100 times. Each tone is sounded for 750 milliseconds at 50 percent volume, without a pause between each tone.

Copy Code
Indicator.Tone1Pitch = 500
Indicator.Tone1Volume = 50
Indicator.Tone1Duration = 750
Indicator.Tone2Pitch = 800
Indicator.Tone2Volume = 50
Indicator.Tone2Duration = 750
Indicator.InterToneWait = 0

Indicator.AsyncMode = True
Indicator.Sound 100, 0

The following example starts a synchronous indicator. This has a simple alternating beep, 500 milliseconds on and 500 milliseconds off.

Copy Code
Indicator.Tone1Pitch = 500
Indicator.Tone1Volume = 50
Indicator.Tone1Duration = 500
Indicator.Tone2Pitch = 0' turn off second tone
Indicator.InterToneWait = 0' no wait after tone-1

Indicator.AsyncMode = False
Indicator.Sound 100, 500

The following example causes an error, because it defines both tones to be zero.

Copy Code
Indicator.Tone1Pitch = 0' turn off first tone
Indicator.Tone2Pitch = 0' turn off second tone

Indicator.Sound 100, 0

The indicator Sound method can also be used to start an indefinite duration tone. If the numberOfCycles parameter is specified to be WaitForever, then the tone is started and must be stopped explicitly.

Copy Code
Indicator.Tone1Pitch = 500
Indicator.Tone1Volume = 50
Indicator.Tone1Duration = 500
Indicator.Tone2Pitch = 0' turn off second tone
Indicator.InterToneWait = 0' no wait after Tone1

Indicator.AsyncMode = True
Indicator.Sound WaitForever, 500

To stop an outstanding tone, you have to use the ClearOutput or SoundImmediate method.

Copy Code
…
Indicator.AsyncMode = True
Indicator.Sound WaitForever, 500
…
Indicator.ClearOutput
   or
Indicator.SoundImmediate

There is also a SoundImmediate method that causes both tones to be sounded once with the InterToneWait property. The tones are sounded synchronously. This imitates a more normal Beep function such as that provided by the Win32 API.

Copy Code
Indicator.Tone1Pitch = 500
Indicator.Tone1Volume = 50
Indicator.Tone1Duration = 500
Indicator.Tone2Pitch = 0' turn off second tone
Indicator.InterToneWait = 0' no wait after Tone1

Indicator.AsyncMode = True
Indicator.Sound 1, 0' asynchronous beep
Indicator.SoundImmediate' synchronous beep

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.ToneIndicator
Microsoft.PointOfService.BasicServiceObjects.ToneIndicatorBasic

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ToneIndicator Members
Microsoft.PointOfService Namespace


ToneIndicator Members

ToneIndicator Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Defines the programmatic interface for a UPOS Tone Indicator device.

The following tables list the members exposed by the ToneIndicator type.

Protected Constructors

Name | Description
ToneIndicator | Creates an instance of the ToneIndicator class.
Top

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticToneSoundedCount | Indicates the number of tones sounded.
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
AsyncMode | Gets or sets a Boolean value to indicate whether the Sound method is performed asynchronously.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon)
CapPitch | Gets a Boolean value to indicate whether the hardware tone generator can vary the tone pitch.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon)
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon)
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon)
CapVolume | Gets a Boolean value to indicate whether the hardware tone generator can vary the tone volume.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon)
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon)
InterToneWait | Gets or sets the number of milliseconds of silence between tone1 and tone2.
OutputId | Gets the identifier of the most recently started asynchronous output.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon)
PowerState | Gets the current power condition. (inherited from PosCommon)
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon)
State | Gets the current state of the device. (inherited from PosCommon)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Tone1Duration | Gets or sets the duration of the first tone in milliseconds.
Tone1Pitch | Gets or sets the pitch or frequency of the first tone in Hertz.
Tone1Volume | Gets or sets the volume of the first tone.
Tone2Duration | Gets or sets the duration of the second tone in milliseconds.
Tone2Pitch | Gets or sets the pitch or frequency of the second tone in Hertz.
Tone2Volume | Gets or sets the volume of the second tone.
Top

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether the ToneIndicator is an exclusive-use device.
Top

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearOutput | Clears all buffered output data. This includes all asynchronous output.
Close | Releases the device and its resources. (inherited from PosCommon)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon)
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon)
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
Sound | Sounds the indicator or starts it sounding asynchronously.
SoundImmediate | Sounds the hardware tone generator one time, synchronously.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )
Top

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )
Top

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon)
ErrorEvent | Raised by the Service Object to notify the application that an error has been detected at the device and a suitable response is necessary to process the error condition.
OutputCompleteEvent | Raised by the Service Object to notify the application that the queued output request has completed successfully.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
Top

See Also

Reference

ToneIndicator Class
Microsoft.PointOfService Namespace


ToneIndicator Fields

ToneIndicator Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticToneSoundedCount | Indicates the number of tones sounded.
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

ToneIndicator Class
Microsoft.PointOfService Namespace


ToneIndicator.StatisticToneSoundedCount Field

ToneIndicator.StatisticToneSoundedCount Field |
 | See Also

1/18/2008

Indicates the number of tones sounded.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Const StatisticToneSoundedCount As String
public const string StatisticToneSoundedCount
public:
literal String^ StatisticToneSoundedCount
public static final String StatisticToneSoundedCount
public const var StatisticToneSoundedCount : String

See Also

Reference

ToneIndicator Class
ToneIndicator Members
Microsoft.PointOfService Namespace


ToneIndicator Constructor

ToneIndicator Constructor |
 | See Also

1/18/2008

Creates an instance of the ToneIndicator class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Sub New
protected ToneIndicator ()
protected:
ToneIndicator ()
protected ToneIndicator ()
protected function ToneIndicator ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

ToneIndicator Class
ToneIndicator Members
Microsoft.PointOfService Namespace


ToneIndicator Methods

ToneIndicator Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosCommon )
ClearOutput | Clears all buffered output data. This includes all asynchronous output.
Close | Releases the device and its resources. (inherited from PosCommon )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Opens a device for later input/output processing. (inherited from PosCommon )
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosCommon )
ResetStatistic | (inherited from PosCommon )
ResetStatistics | Overloaded. (inherited from PosCommon )
RetrieveStatistic | (inherited from PosCommon )
RetrieveStatistics | Overloaded. (inherited from PosCommon )
Sound | Sounds the indicator or starts it sounding asynchronously.
SoundImmediate | Sounds the hardware tone generator one time, synchronously.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosCommon )
UpdateStatistics | Overloaded. (inherited from PosCommon )

Protected Methods

Name | Description
DeleteConfigurationProperty | (inherited from PosCommon )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
SetConfigurationProperty | (inherited from PosCommon )

See Also

Reference

ToneIndicator Class
Microsoft.PointOfService Namespace


ToneIndicator.ClearOutput Method

ToneIndicator.ClearOutput Method |
 | See Also

1/18/2008

Clears all buffered output data. This includes all asynchronous output.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub ClearOutput
public abstract void ClearOutput ()
public:
virtual void ClearOutput () abstract
public abstract void ClearOutput ()
public abstract function ClearOutput ()

Remarks

The ClearOutput method also stops any output that may be in progress (when it is possible).

Any output error events that are queued, usually waiting for the FreezeEvents property to be set to false, are also cleared.

OuputCompleteEvent events are not raised for cleared output.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ToneIndicator Class
ToneIndicator Members
Microsoft.PointOfService Namespace


ToneIndicator.Sound Method

ToneIndicator.Sound Method |
 | See Also

1/18/2008

Sounds the indicator or starts it sounding asynchronously.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub Sound ( _
    numberOfCycles As Integer, _
    interSoundWait As Integer _
)
public abstract void Sound (
    int numberOfCycles,
    int interSoundWait
)
public:
virtual void Sound (
    int numberOfCycles,
    int interSoundWait
) abstract
public abstract void Sound (
    int numberOfCycles,
    int interSoundWait
)
public abstract function Sound (
    numberOfCycles : int,
    interSoundWait : int
)

Parameters

numberOfCycles

If WaitForever, then start the indicator sounding, and repeat continuously.Otherwise, perform the specified number of cycles.

interSoundWait

When numberOfCycles is not one, then pause for InterSoundWait milliseconds before repeating the tone cycle (before playing tone1 again).

Remarks

The Sound method is performed synchronously if the AsyncMode property is false, and asynchronously if AsyncMode is true.

The duration of an indicator cycle is as follows:

Tone1Duration property +InterToneWait property +Tone2Duration property +interSoundWait parameter (except on the last tone cycle)

After the Tone Indicator has started an asynchronous sound, the sound can be stopped by using one of the following methods. (When a numberOfCycles value of WaitForever is used to start the sound, the application must use one of these to stop the continuous sounding of the tones.)

  • ClearOutput

  • SoundImmediate

The Sound method can throw general exceptions and a PosControlException exception. In this case, the PostControlException.ErrorCode property will be set to one of the following values:

Value | Meaning
Claimed | Another application has claimed the device and has taken over the speaker causing the sound from this method to be interrupted (can only be returned if AsyncMode is false).
Illegal | One of the following errors occurred: numberOfCycles is neither a positive, nonzero value nor WaitForever. numberOfCycles is WaitForever when AsyncMode is false. A negative interSoundWait was specified.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ToneIndicator Class
ToneIndicator Members
Microsoft.PointOfService Namespace


ToneIndicator.SoundImmediate Method

ToneIndicator.SoundImmediate Method |
 | See Also

1/18/2008

Sounds the hardware tone generator one time, synchronously.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Sub SoundImmediate
public abstract void SoundImmediate ()
public:
virtual void SoundImmediate () abstract
public abstract void SoundImmediate ()
public abstract function SoundImmediate ()

Remarks

Both tone1 and tone2 are sounded, with their InterToneWait property.

If asynchronous output is outstanding, then it is stopped before playing the immediate sound (as if ClearOutput were called). The SoundImmediate method is primarily intended for use in exception conditions when asynchronous output is outstanding, such as in an error event handler.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ToneIndicator Class
ToneIndicator Members
Microsoft.PointOfService Namespace


ToneIndicator Properties

ToneIndicator Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
AsyncMode | Gets or sets a Boolean value to indicate whether the Sound method is performed asynchronously.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosCommon )
CapPitch | Gets a Boolean value to indicate whether the hardware tone generator can vary the tone pitch.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosCommon )
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosCommon )
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosCommon )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosCommon )
CapVolume | Gets a Boolean value to indicate whether the hardware tone generator can vary the tone volume.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosCommon )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosCommon )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosCommon )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosCommon )
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosCommon )
InterToneWait | Gets or sets the number of milliseconds of silence between tone1 and tone2.
OutputId | Gets the identifier of the most recently started asynchronous output.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosCommon )
PowerState | Gets the current power condition. (inherited from PosCommon )
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosCommon )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosCommon )
State | Gets the current state of the device. (inherited from PosCommon )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )
Tone1Duration | Gets or sets the duration of the first tone in milliseconds.
Tone1Pitch | Gets or sets the pitch or frequency of the first tone in Hertz.
Tone1Volume | Gets or sets the volume of the first tone.
Tone2Duration | Gets or sets the duration of the second tone in milliseconds.
Tone2Pitch | Gets or sets the pitch or frequency of the second tone in Hertz.
Tone2Volume | Gets or sets the volume of the second tone.

Protected Properties

Name | Description
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Overridden. Gets a Boolean value that indicates whether the ToneIndicator is an exclusive-use device.

See Also

Reference

ToneIndicator Class
Microsoft.PointOfService Namespace


ToneIndicator.AsyncMode Property

ToneIndicator.AsyncMode Property |
 | See Also

1/18/2008

Gets or sets a Boolean value to indicate whether the Sound method is performed asynchronously.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property AsyncMode As Boolean
public abstract bool AsyncMode { get; set; }
public:
virtual property bool AsyncMode {
    bool get () abstract;
    void set (bool value) abstract;
}
/** @property */
public abstract boolean get_AsyncMode ()

/** @property */
public abstract void set_AsyncMode (boolean value)

public abstract function get AsyncMode () : boolean

public abstract function set AsyncMode (value : boolean)

Remarks

If true, the Sound method is performed asynchronously.If false, tones are generated synchronously.

AsyncMode is set and kept current by the Service Object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ToneIndicator Class
ToneIndicator Members
Microsoft.PointOfService Namespace


ToneIndicator.CapPitch Property

ToneIndicator.CapPitch Property |
 | See Also

1/18/2008

Gets a Boolean value to indicate whether the hardware tone generator can vary the tone pitch.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapPitch As Boolean
public abstract bool CapPitch { get; }
public:
virtual property bool CapPitch {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapPitch ()

public abstract function get CapPitch () : boolean

Remarks

If true, the hardware tone generator can vary the pitch of the tone; otherwise, false.

CapPitch is set and kept current by the Service Object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ToneIndicator Class
ToneIndicator Members
Microsoft.PointOfService Namespace


ToneIndicator.CapVolume Property

ToneIndicator.CapVolume Property |
 | See Also

1/18/2008

Gets a Boolean value to indicate whether the hardware tone generator can vary the tone volume.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property CapVolume As Boolean
public abstract bool CapVolume { get; }
public:
virtual property bool CapVolume {
    bool get () abstract;
}
/** @property */
public abstract boolean get_CapVolume ()

public abstract function get CapVolume () : boolean

Remarks

If true, the hardware tone generator can vary the volume of the tone; otherwise, false.

CapVolume is set and kept current by the Service Object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ToneIndicator Class
ToneIndicator Members
Microsoft.PointOfService Namespace


ToneIndicator.InterToneWait Property

ToneIndicator.InterToneWait Property |
 | See Also

1/18/2008

Gets or sets the number of milliseconds of silence between tone1 and tone2.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property InterToneWait As Integer
public abstract int InterToneWait { get; set; }
public:
virtual property int InterToneWait {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_InterToneWait ()

/** @property */
public abstract void set_InterToneWait (int value)

public abstract function get InterToneWait () : int

public abstract function set InterToneWait (value : int)

Remarks

If a gap is required after tone2, but before a repeat of tone1, set the Sound parameter interSoundWait.

InterToneWait is set and kept current by the Service Object while the device is enabled.

Accessing InterToneWait can throw general exceptions and a PosControlException exception. In this case, the PostControlException.ErrorCode property will be set to the following value:

Value | Meaning
Illegal | The value specified is not valid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ToneIndicator Class
ToneIndicator Members
Microsoft.PointOfService Namespace


ToneIndicator.IsExclusiveUseDevice Property

ToneIndicator.IsExclusiveUseDevice Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the ToneIndicator is an exclusive-use device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Protected Overrides NotOverridable ReadOnly Property IsExclusiveUseDevice As Boolean
protected override sealed bool IsExclusiveUseDevice { get; }
protected:
virtual property bool IsExclusiveUseDevice {
    bool get () override sealed;
}
/** @property */
protected final boolean get_IsExclusiveUseDevice ()

protected override final function get IsExclusiveUseDevice () : boolean

Property Value

A value of true indicates that the ToneIndicator is an exclusive-use device. Otherwise, the value is false.

Remarks

An exclusive-use device has the following properties:

  • The application must claim the device before the application enables it.

  • The application must claim and enable the device before accessing some properties or calling methods that update the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ToneIndicator Class
ToneIndicator Members
Microsoft.PointOfService Namespace


ToneIndicator.OutputId Property

ToneIndicator.OutputId Property |
 | See Also

1/18/2008

Gets the identifier of the most recently started asynchronous output.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride ReadOnly Property OutputId As Integer
public abstract int OutputId { get; }
public:
virtual property int OutputId {
    int get () abstract;
}
/** @property */
public abstract int get_OutputId ()

public abstract function get OutputId () : int

Remarks

When a method successfully starts an asynchronous output, the Service Object assigns an identifier to the request. When the output is complete, the Service Object raises an OutputCompleteEvent event passing this output ID as a parameter.

The output ID numbers are assigned by the Service Object and are guaranteed to be unique among the set of outstanding asynchronous outputs. No other facts about the ID should be assumed.

OutputId is set and kept current by the Service Object while the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ToneIndicator Class
ToneIndicator Members
Microsoft.PointOfService Namespace


ToneIndicator.Tone1Duration Property

ToneIndicator.Tone1Duration Property |
 | See Also

1/18/2008

Gets or sets the duration of the first tone in milliseconds.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property Tone1Duration As Integer
public abstract int Tone1Duration { get; set; }
public:
virtual property int Tone1Duration {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_Tone1Duration ()

/** @property */
public abstract void set_Tone1Duration (int value)

public abstract function get Tone1Duration () : int

public abstract function set Tone1Duration (value : int)

Remarks

Tone1Duration is set and kept current by the Service Object while the device is enabled.

Accessing Tone1Duration can throw general exceptions and a PosControlException exception. In this case, the PostControlException.ErrorCode property is set to the following value:

Value | Meaning
Illegal | The value specified is not valid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ToneIndicator Class
ToneIndicator Members
Microsoft.PointOfService Namespace


ToneIndicator.Tone1Pitch Property

ToneIndicator.Tone1Pitch Property |
 | See Also

1/18/2008

Gets or sets the pitch or frequency of the first tone in Hertz.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property Tone1Pitch As Integer
public abstract int Tone1Pitch { get; set; }
public:
virtual property int Tone1Pitch {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_Tone1Pitch ()

/** @property */
public abstract void set_Tone1Pitch (int value)

public abstract function get Tone1Pitch () : int

public abstract function set Tone1Pitch (value : int)

Remarks

If the device does not support user-defined pitch (that is, if CapPitch is false), any value greater than zero causes the Tone Indicator to use its default value.

Tone1Pitch is typically initialized to zero when the device is first enabled. It should then be kept current by the Service Object while the device is enabled.

Accessing Tone1Pitch can throw general exceptions and a PosControlException exception. In this case, the PostControlException.ErrorCode property is set to the following value:

Value | Meaning
Illegal | The specified value is not valid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ToneIndicator Class
ToneIndicator Members
Microsoft.PointOfService Namespace


ToneIndicator.Tone1Volume Property

ToneIndicator.Tone1Volume Property |
 | See Also

1/18/2008

Gets or sets the volume of the first tone.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property Tone1Volume As Integer
public abstract int Tone1Volume { get; set; }
public:
virtual property int Tone1Volume {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_Tone1Volume ()

/** @property */
public abstract void set_Tone1Volume (int value)

public abstract function get Tone1Volume () : int

public abstract function set Tone1Volume (value : int)

Remarks

Contains the volume of the first tone in percent of the device's capability, where 0 (or less) is silent and 100 (or more) is maximum volume.

If the device does not support user-defined volume (that is, if the CapVolume property is false), any value greater than zero causes the Tone Indicator to use its default value.

Tone1Volume is set and kept current by the Service Object while the device is enabled.

Accessing Tone1Volume can throw general exceptions and a PosControlException exception. In this case, the PostControlException.ErrorCode property is set to one of the following values:

Value | Meaning
Illegal | The specified value is not valid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ToneIndicator Class
ToneIndicator Members
Microsoft.PointOfService Namespace


ToneIndicator.Tone2Duration Property

ToneIndicator.Tone2Duration Property |
 | See Also

1/18/2008

Gets or sets the duration of the second tone in milliseconds.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property Tone2Duration As Integer
public abstract int Tone2Duration { get; set; }
public:
virtual property int Tone2Duration {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_Tone2Duration ()

/** @property */
public abstract void set_Tone2Duration (int value)

public abstract function get Tone2Duration () : int

public abstract function set Tone2Duration (value : int)

Remarks

A value of zero or less sounds no tone.

Tone2Duration is initialized to zero. It should then be kept current by the Service Object while the device is enabled.

Accessing Tone1Pitch can throw general exceptions and a PosControlException exception. In this case, the PostControlException.ErrorCode property is set to the following value:

Value | Meaning
Illegal | The specified value is not valid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ToneIndicator Class
ToneIndicator Members
Microsoft.PointOfService Namespace


ToneIndicator.Tone2Pitch Property

ToneIndicator.Tone2Pitch Property |
 | See Also

1/18/2008

Gets or sets the pitch or frequency of the second tone in Hertz.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property Tone2Pitch As Integer
public abstract int Tone2Pitch { get; set; }
public:
virtual property int Tone2Pitch {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_Tone2Pitch ()

/** @property */
public abstract void set_Tone2Pitch (int value)

public abstract function get Tone2Pitch () : int

public abstract function set Tone2Pitch (value : int)

Remarks

A value of zero or less produces no tone.

If the device does not support user-defined pitch (if the CapPitch property is false), any value greater than zero causes the Tone Indicator to use its default value.

Tone2Pitch is set and kept current by the Service Object while the device is enabled.

Accessing Tone2Pitch can throw general exceptions and a PosControlException exception. In this case, the PostControlException.ErrorCode property can be set to the following value:

Value | Meaning
Illegal | The specified value is not valid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ToneIndicator Class
ToneIndicator Members
Microsoft.PointOfService Namespace


ToneIndicator.Tone2Volume Property

ToneIndicator.Tone2Volume Property |
 | See Also

1/18/2008

Gets or sets the volume of the second tone.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public MustOverride Property Tone2Volume As Integer
public abstract int Tone2Volume { get; set; }
public:
virtual property int Tone2Volume {
    int get () abstract;
    void set (int value) abstract;
}
/** @property */
public abstract int get_Tone2Volume ()

/** @property */
public abstract void set_Tone2Volume (int value)

public abstract function get Tone2Volume () : int

public abstract function set Tone2Volume (value : int)

Remarks

The volume of the second tone in percent of the device's capability, where 0 (or less) is silent and 100 (or more) is maximum volume.

If the device does not support user-defined volume (if CapVolume is false), any value greater than zero causes the Tone Indicator to use its default value.

Tone2Volume is set and kept current by the Service Object while the device is enabled.

Accessing Tone2Volume can throw general exceptions and a PosControlException exception. In this case, the PostControlException.ErrorCode property is set to the following value:

Value | Meaning
Illegal | The specified value is not valid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ToneIndicator Class
ToneIndicator Members
Microsoft.PointOfService Namespace


ToneIndicator Events

ToneIndicator Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosCommon )
ErrorEvent | Raised by the Service Object to notify the application that an error has been detected at the device and a suitable response is necessary to process the error condition.
OutputCompleteEvent | Raised by the Service Object to notify the application that the queued output request has completed successfully.
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosCommon )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )

See Also

Reference

ToneIndicator Class
Microsoft.PointOfService Namespace


ToneIndicator.ErrorEvent Event

ToneIndicator.ErrorEvent Event |
 | See Also

1/18/2008

Raised by the Service Object to notify the application that an error has been detected at the device and a suitable response is necessary to process the error condition.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event ErrorEvent As DeviceErrorEventHandler
public abstract event DeviceErrorEventHandler ErrorEvent
public:
virtual event DeviceErrorEventHandler^ ErrorEvent {
    void add (DeviceErrorEventHandler^ value) abstract;
    void remove (DeviceErrorEventHandler^ value) abstract;
}
/** @event */
public abstract void add_ErrorEvent (DeviceErrorEventHandler value)

/** @event */
public abstract void remove_ErrorEvent (DeviceErrorEventHandler value)

Remarks

The ErrorEvent event is queued when an error is detected and the device's State transitions into the error state. ErrorEvent is not delivered until the DataEventEnabled property is true so that correct application sequencing occurs.

See Also

Reference

ToneIndicator Class
ToneIndicator Members
Microsoft.PointOfService Namespace


ToneIndicator.OutputCompleteEvent Event

ToneIndicator.OutputCompleteEvent Event |
 | See Also

1/18/2008

Raised by the Service Object to notify the application that the queued output request has completed successfully.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Event OutputCompleteEvent As OutputCompleteEventHandler
public abstract event OutputCompleteEventHandler OutputCompleteEvent
public:
virtual event OutputCompleteEventHandler^ OutputCompleteEvent {
    void add (OutputCompleteEventHandler^ value) abstract;
    void remove (OutputCompleteEventHandler^ value) abstract;
}
/** @event */
public abstract void add_OutputCompleteEvent (OutputCompleteEventHandler value)

/** @event */
public abstract void remove_OutputCompleteEvent (OutputCompleteEventHandler value)

Remarks

Notifies the application that the queued output request associated with the OutputCompleteEventArgs.OutputId property has completed successfully.

OutputCompleteEvent is queued after the request’s data has been both sent and POS for .NET has confirmation that it was successfully processed by the device.

See Also

Reference

ToneIndicator Class
ToneIndicator Members
Microsoft.PointOfService Namespace


TotalsFileInfo Structure

TotalsFileInfo Structure |
 | See Also Members

1/18/2008

Defines the programmatic structure used by the service object to identify the current totals file for the application.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Structure TotalsFileInfo
public struct TotalsFileInfo
public value class TotalsFileInfo
public final class TotalsFileInfo extends ValueType

Remarks

Used as the return value for the Find method of the HardTotals class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

TotalsFileInfo Members
Microsoft.PointOfService Namespace


TotalsFileInfo Members

TotalsFileInfo Members |
 | See Also Constructors Methods Properties

1/18/2008

Defines the programmatic structure used by the service object to identify the current totals file for the application.

The following tables list the members exposed by the TotalsFileInfo type.

Public Constructors

Name | Description
TotalsFileInfo | Creates an instance of the TotalsFileInfo structure from parameters specifying the instance's handle to the totals file and totals file size.
Top

Public Properties

Name | Description
Handle | Gets the handle to the current totals file.
Size | Gets the size of the current totals file.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. Overridden.
GetHashCode | Overridden. Returns the hash code of the current TotalsFileInfo class.
GetType | (inherited from Object )
op_Equality | Compares the specified TotalsFileInfo class and object to determine whether they are the same.
op_Inequality | Compares the specified TotalsFileInfo class and object to determine whether they are different.
ReferenceEquals | (inherited from Object )
ToString | (inherited from ValueType )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

TotalsFileInfo Structure
Microsoft.PointOfService Namespace


TotalsFileInfo Constructor

TotalsFileInfo Constructor |
 | See Also

1/18/2008

Creates an instance of the TotalsFileInfo structure from parameters specifying the instance's handle to the totals file and totals file size.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    handle As Integer, _
    size As Integer _
)
public TotalsFileInfo (
    int handle,
    int size
)
public:
TotalsFileInfo (
    int handle,
    int size
)
public TotalsFileInfo (
    int handle,
    int size
)
public function TotalsFileInfo (
    handle : int,
    size : int
)

Parameters

handle

Handle to the totals file.

size

Totals file size.

See Also

Reference

TotalsFileInfo Structure
TotalsFileInfo Members
Microsoft.PointOfService Namespace


TotalsFileInfo Methods

TotalsFileInfo Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. Overridden.
GetHashCode | Overridden. Returns the hash code of the current TotalsFileInfo class.
GetType | (inherited from Object )
op_Equality | Compares the specified TotalsFileInfo class and object to determine whether they are the same.
op_Inequality | Compares the specified TotalsFileInfo class and object to determine whether they are different.
ReferenceEquals | (inherited from Object )
ToString | (inherited from ValueType )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

TotalsFileInfo Structure
Microsoft.PointOfService Namespace


TotalsFileInfo.Equals Method

TotalsFileInfo.Equals Method |
 | See Also

1/18/2008

Overload List

Name | Description
TotalsFileInfo.Equals (Object) | Determines whether the specified object is equal to the current TotalsFileInfo.
TotalsFileInfo.Equals (TotalsFileInfo) | Determines whether the specified TotalsFileInfo class of the object is equal to the current TotalsFileinfo.
TotalsFileInfo.Equals (Object, Object) | (inherited from Equals )
TotalsFileInfo.Equals (TotalsFileInfo, TotalsFileInfo) | Determines whether the specified TotalsFileInfo instances are equal.

See Also

Reference

TotalsFileInfo Structure
TotalsFileInfo Members
Microsoft.PointOfService Namespace


TotalsFileInfo.Equals Method (Object)

TotalsFileInfo.Equals Method (Object) |
 | See Also

1/18/2008

Determines whether the specified object is equal to the current TotalsFileInfo.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public override bool Equals (
    Object obj
)
public:
virtual bool Equals (
    Object^ obj
) override
public boolean Equals (
    Object obj
)
public override function Equals (
    obj : Object
) : boolean

Parameters

obj

Return Value

True if the specified object is equal to the current TotalsFileInfo class; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

TotalsFileInfo Structure
TotalsFileInfo Members
Microsoft.PointOfService Namespace


TotalsFileInfo.Equals Method (TotalsFileInfo)

TotalsFileInfo.Equals Method (TotalsFileInfo) |
 | See Also

1/18/2008

Determines whether the specified TotalsFileInfo class of the object is equal to the current TotalsFileinfo.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Function Equals ( _
    info As TotalsFileInfo _
) As Boolean
public bool Equals (
    TotalsFileInfo info
)
public:
bool Equals (
    TotalsFileInfo info
)
public boolean Equals (
    TotalsFileInfo info
)
public function Equals (
    info : TotalsFileInfo
) : boolean

Parameters

info

The TotalsFileInfo to be compared with the current TotalsFileInfo class.

Return Value

True if the specified TotalsFileInfo is equal to the current TotalsFileInfo class; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

TotalsFileInfo Structure
TotalsFileInfo Members
Microsoft.PointOfService Namespace


TotalsFileInfo.Equals Method (TotalsFileInfo, TotalsFileInfo)

TotalsFileInfo.Equals Method (TotalsFileInfo, TotalsFileInfo) |
 | See Also

1/18/2008

Determines whether the specified TotalsFileInfo instances are equal.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Function Equals ( _
    a As TotalsFileInfo, _
    b As TotalsFileInfo _
) As Boolean
public static bool Equals (
    TotalsFileInfo a,
    TotalsFileInfo b
)
public:
static bool Equals (
    TotalsFileInfo a,
    TotalsFileInfo b
)
public static boolean Equals (
    TotalsFileInfo a,
    TotalsFileInfo b
)
public static function Equals (
    a : TotalsFileInfo,
    b : TotalsFileInfo
) : boolean

Parameters

a

The first TotalsFileInfo instance.

b

The second TotalsFileInfo instance.

Return Value

True if a is equal to b; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

TotalsFileInfo Structure
TotalsFileInfo Members
Microsoft.PointOfService Namespace


TotalsFileInfo.GetHashCode Method

TotalsFileInfo.GetHashCode Method |
 | See Also

1/18/2008

Returns the hash code of the current TotalsFileInfo class.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function GetHashCode As Integer
public override int GetHashCode ()
public:
virtual int GetHashCode () override
public int GetHashCode ()
public override function GetHashCode () : int

Return Value

An Int32 representation of the hash code for the current TotalsFileInfo class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

TotalsFileInfo Structure
TotalsFileInfo Members
Microsoft.PointOfService Namespace


TotalsFileInfo.op_Equality Method

TotalsFileInfo.op_Equality Method |
 | See Also

1/18/2008

Compares the specified TotalsFileInfo class and object to determine whether they are the same.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Operator = ( _
    a As TotalsFileInfo, _
    b As Object _
) As Boolean
public static bool operator == (
    TotalsFileInfo a,
    Object b
)
public:
static bool operator == (
    TotalsFileInfo a,
    Object^ b
)

Parameters

a

The TotalsFileInfo to be compared to b.

b

The object to be compared to a.

Return Value

True if a is equal to b; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

TotalsFileInfo Structure
TotalsFileInfo Members
Microsoft.PointOfService Namespace


TotalsFileInfo.op_Inequality Method

TotalsFileInfo.op_Inequality Method |
 | See Also

1/18/2008

Compares the specified TotalsFileInfo class and object to determine whether they are different.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Operator <> ( _
    a As TotalsFileInfo, _
    b As Object _
) As Boolean
public static bool operator != (
    TotalsFileInfo a,
    Object b
)
public:
static bool operator != (
    TotalsFileInfo a,
    Object^ b
)

Parameters

a

The TotalsFileInfo class to be compared to b.

b

The object to be compared to a.

Return Value

True if a is not equal to b; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

TotalsFileInfo Structure
TotalsFileInfo Members
Microsoft.PointOfService Namespace


TotalsFileInfo Properties

TotalsFileInfo Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
Handle | Gets the handle to the current totals file.
Size | Gets the size of the current totals file.

See Also

Reference

TotalsFileInfo Structure
Microsoft.PointOfService Namespace


TotalsFileInfo.Handle Property

TotalsFileInfo.Handle Property |
 | See Also

1/18/2008

Gets the handle to the current totals file.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Handle As Integer
public int Handle { get; }
public:
property int Handle {
    int get ();
}
/** @property */
public int get_Handle ()

public function get Handle () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

TotalsFileInfo Structure
TotalsFileInfo Members
Microsoft.PointOfService Namespace


TotalsFileInfo.Size Property

TotalsFileInfo.Size Property |
 | See Also

1/18/2008

Gets the size of the current totals file.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Size As Integer
public int Size { get; }
public:
property int Size {
    int get ();
}
/** @property */
public int get_Size ()

public function get Size () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

TotalsFileInfo Structure
TotalsFileInfo Members
Microsoft.PointOfService Namespace


TransactionControl Enumeration

TransactionControl Enumeration |
 | See Also

1/18/2008

Enumerates the transaction mode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration TransactionControl
public enum TransactionControl
public enum class TransactionControl
public enum TransactionControl
public enum TransactionControl

Members

Member name | Description
Normal | Ends the transaction mode by executing the buffer operation.
Transaction | Begins a transaction.

Remarks

If control is Transaction, then the transaction mode is entered. Subsequent calls to ReadValue, WriteValue, AddValue, SubtractValue, and CancelValue methods buffer the data until the TransactionAccess method is called with the control parameter set to Normal. It depends on the implementation if buffering occurs in the ElectronicValue R/W device or if buffering occurs within the service.

If control is Normal, then transaction mode is exited. If some requests were buffered by calls to the methods ReadValue, WriteValue, AddValue, SubtractValue, and CancelValue, then the buffered requests will be executed.

The entire transaction requests are treated as one message. This method is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

Calling the ClearOutput method cancels the transaction mode. Any buffered print lines are also cleared.

See Also

Reference

Microsoft.PointOfService Namespace


TransactionLogType Enumeration

TransactionLogType Enumeration |
 | See Also

1/18/2008

Enumerates the transaction log type.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration TransactionLogType
public enum TransactionLogType
public enum class TransactionLogType
public enum TransactionLogType
public enum TransactionLogType

Members

Member name | Description
Reporting | Gets transaction log as an intermediate total.
Settlement | The transaction log for the device is fixed and erased. (Whether it is erased or not depends on the implementation.)

See Also

Reference

Microsoft.PointOfService Namespace


UpsChargeStates Enumeration

UpsChargeStates Enumeration |
 | See Also

1/18/2008

Lists the possible UPS charge states for a PosPower device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration UpsChargeStates
[FlagsAttribute]
public enum UpsChargeStates
[FlagsAttribute]
public enum class UpsChargeStates
/** @attribute FlagsAttribute() */
public enum UpsChargeStates
FlagsAttribute
public enum UpsChargeStates

Members

Member name | Description
Critical | UPS battery is in a critical state and can be disconnected at any time without further warning.
Full | UPS battery is near full charge.
Low | UPS battery is near zero charge. Application shutdown should be started to ensure that it can be completed before the battery charge is depleted. A minimum of two minutes of normal system operation can be assumed when this state is entered, unless this is the first charge state reported upon entering the "Off" power state.
Warning | UPS battery is near 50% charge.

Remarks

Used by the CapUpsChargeState and UpsChargeState properties. Members of this enumeration replace the PWR_UPS_FULL UPS, PWR_UPS_WARNING UPS, and PWR_UPS_LOW UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
PosPower.CapUpsChargeState Property
PosPower.UpsChargeState Property


VatInfo Structure

VatInfo Structure |
 | See Also Members

1/18/2008

Defines the programmatic structure used to build a list of adjustments for value added tax (VAT) information.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Structure VatInfo
public struct VatInfo
public value class VatInfo
public final class VatInfo extends ValueType

Remarks

Used by the PrintRecPackageAdjustment and PrintRecPackageAdjustVoid methods of the FiscalPrinter class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

VatInfo Members
Microsoft.PointOfService Namespace


VatInfo Members

VatInfo Members |
 | See Also Constructors Methods Properties

1/18/2008

Defines the programmatic structure used to build a list of adjustments for value added tax (VAT) information.

The following tables list the members exposed by the VatInfo type.

Public Constructors

Name | Description
VatInfo | Creates an instance of the VatInfo structure from parameters specifying the VAT identifier and VAT amount.
Top

Public Properties

Name | Description
Amount | Gets the VAT amount.
Id | Gets the VAT identifier.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. Overridden.
GetHashCode | Overridden. Returns the hash code of the current VatInfo.
GetType | (inherited from Object )
op_Equality | Compares the specified VatInfo and object to determine whether they are the same.
op_Inequality | Compares the specified VatInfo and object to determine whether they are different.
ReferenceEquals | (inherited from Object )
ToString | (inherited from ValueType )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

VatInfo Structure
Microsoft.PointOfService Namespace


VatInfo Constructor

VatInfo Constructor |
 | See Also

1/18/2008

Creates an instance of the VatInfo structure from parameters specifying the VAT identifier and VAT amount.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    id As Integer, _
    amount As Decimal _
)
public VatInfo (
    int id,
    decimal amount
)
public:
VatInfo (
    int id,
    Decimal amount
)
public VatInfo (
    int id,
    Decimal amount
)
public function VatInfo (
    id : int,
    amount : decimal
)

Parameters

id

The VAT identifier.

amount

The VAT amount.

See Also

Reference

VatInfo Structure
VatInfo Members
Microsoft.PointOfService Namespace


VatInfo Methods

VatInfo Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. Overridden.
GetHashCode | Overridden. Returns the hash code of the current VatInfo.
GetType | (inherited from Object )
op_Equality | Compares the specified VatInfo and object to determine whether they are the same.
op_Inequality | Compares the specified VatInfo and object to determine whether they are different.
ReferenceEquals | (inherited from Object )
ToString | (inherited from ValueType )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

VatInfo Structure
Microsoft.PointOfService Namespace


VatInfo.Equals Method

VatInfo.Equals Method |
 | See Also

1/18/2008

Overload List

Name | Description
VatInfo.Equals (Object) | Determines whether the specified object is equal to the current VatInfo.
VatInfo.Equals (VatInfo) | Determines whether the specified VatInfo is equal to the current VatInfo.
VatInfo.Equals (Object, Object) | (inherited from Equals )
VatInfo.Equals (VatInfo, VatInfo) | Determines whether the specified VatInfo instances are equal.

See Also

Reference

VatInfo Structure
VatInfo Members
Microsoft.PointOfService Namespace


VatInfo.Equals Method (Object)

VatInfo.Equals Method (Object) |
 | See Also

1/18/2008

Determines whether the specified object is equal to the current VatInfo.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public override bool Equals (
    Object obj
)
public:
virtual bool Equals (
    Object^ obj
) override
public boolean Equals (
    Object obj
)
public override function Equals (
    obj : Object
) : boolean

Parameters

obj

Return Value

True if the specified object is equal to the current VatInfo; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

VatInfo Structure
VatInfo Members
Microsoft.PointOfService Namespace


VatInfo.Equals Method (VatInfo)

VatInfo.Equals Method (VatInfo) |
 | See Also

1/18/2008

Determines whether the specified VatInfo is equal to the current VatInfo.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Function Equals ( _
    vatInfo As VatInfo _
) As Boolean
public bool Equals (
    VatInfo vatInfo
)
public:
bool Equals (
    VatInfo vatInfo
)
public boolean Equals (
    VatInfo vatInfo
)
public function Equals (
    vatInfo : VatInfo
) : boolean

Parameters

vatInfo

The VatInfo to be compared.

Return Value

True if the specified VatInfo is equal to the current VatInfo; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

VatInfo Structure
VatInfo Members
Microsoft.PointOfService Namespace


VatInfo.Equals Method (VatInfo, VatInfo)

VatInfo.Equals Method (VatInfo, VatInfo) |
 | See Also

1/18/2008

Determines whether the specified VatInfo instances are equal.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Function Equals ( _
    a As VatInfo, _
    b As VatInfo _
) As Boolean
public static bool Equals (
    VatInfo a,
    VatInfo b
)
public:
static bool Equals (
    VatInfo a,
    VatInfo b
)
public static boolean Equals (
    VatInfo a,
    VatInfo b
)
public static function Equals (
    a : VatInfo,
    b : VatInfo
) : boolean

Parameters

a

The VatInfo to be compared with b.

b

The VatInfo to be compared with a.

Return Value

True if a is equal to b; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

VatInfo Structure
VatInfo Members
Microsoft.PointOfService Namespace


VatInfo.GetHashCode Method

VatInfo.GetHashCode Method |
 | See Also

1/18/2008

Returns the hash code of the current VatInfo.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function GetHashCode As Integer
public override int GetHashCode ()
public:
virtual int GetHashCode () override
public int GetHashCode ()
public override function GetHashCode () : int

Return Value

Returns an Int32 representation of the hash code for the current VatInfo.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

VatInfo Structure
VatInfo Members
Microsoft.PointOfService Namespace


VatInfo.op_Equality Method

VatInfo.op_Equality Method |
 | See Also

1/18/2008

Compares the specified VatInfo and object to determine whether they are the same.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Operator = ( _
    a As VatInfo, _
    b As Object _
) As Boolean
public static bool operator == (
    VatInfo a,
    Object b
)
public:
static bool operator == (
    VatInfo a,
    Object^ b
)

Parameters

a

The VatInfo to be compared to b.

b

The object to be compared to a.

Return Value

True if a is equal to b; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

VatInfo Structure
VatInfo Members
Microsoft.PointOfService Namespace


VatInfo.op_Inequality Method

VatInfo.op_Inequality Method |
 | See Also

1/18/2008

Compares the specified VatInfo and object to determine whether they are different.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Operator <> ( _
    a As VatInfo, _
    b As Object _
) As Boolean
public static bool operator != (
    VatInfo a,
    Object b
)
public:
static bool operator != (
    VatInfo a,
    Object^ b
)

Parameters

a

The VatInfo to be compared to b.

b

The object to be compared to a.

Return Value

True if a is not equal to b; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

VatInfo Structure
VatInfo Members
Microsoft.PointOfService Namespace


VatInfo Properties

VatInfo Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
Amount | Gets the VAT amount.
Id | Gets the VAT identifier.

See Also

Reference

VatInfo Structure
Microsoft.PointOfService Namespace


VatInfo.Amount Property

VatInfo.Amount Property |
 | See Also

1/18/2008

Gets the VAT amount.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Amount As Decimal
public decimal Amount { get; }
public:
property Decimal Amount {
    Decimal get ();
}
/** @property */
public Decimal get_Amount ()

public function get Amount () : decimal

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

VatInfo Structure
VatInfo Members
Microsoft.PointOfService Namespace


VatInfo.Id Property

VatInfo.Id Property |
 | See Also

1/18/2008

Gets the VAT identifier.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Id As Integer
public int Id { get; }
public:
property int Id {
    int get ();
}
/** @property */
public int get_Id ()

public function get Id () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

VatInfo Structure
VatInfo Members
Microsoft.PointOfService Namespace


VideoAttributeCommand Enumeration

VideoAttributeCommand Enumeration |
 | See Also Example

1/18/2008

Lists the possible video region attibutes for a Remote Order Display device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration VideoAttributeCommand
public enum VideoAttributeCommand
public enum class VideoAttributeCommand
public enum VideoAttributeCommand
public enum VideoAttributeCommand

Members

Member name | Description
BlinkOff | Turn off blinking in the region.
BlinkOn | Turn on blinking in the region.
IntensityOff | Turn off foreground intensity in the region.
IntensityOn | Turn on foreground intensity in the region.
ReverseOff | Remove reverse video from the region.
ReverseOn | Reverse video the region.
Set | Set the region with the new attribute.

Remarks

Used by the UpdateVideoRegionAttribute method. Members of this enumeration replace the ROD_UA_ range of UPOS constants.

Example

UpdateVideoRegionAttribute

See Also

Reference

Microsoft.PointOfService Namespace


VideoAttributes Enumeration

VideoAttributes Enumeration |
 | See Also

1/18/2008

Lists the possible foreground and background colors, and blinking and intensity attributes of a video display on a Remote Order Display device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration VideoAttributes
[FlagsAttribute]
public enum VideoAttributes
[FlagsAttribute]
public enum class VideoAttributes
/** @attribute FlagsAttribute() */
public enum VideoAttributes
FlagsAttribute
public enum VideoAttributes

Members

Member name | Description
BackgroundBlack | Black background
BackgroundBlue | Blue background
BackgroundBrown | Brown background
BackgroundCyan | Cyan background
BackgroundGray | Gray background
BackgroundGreen | Green background
BackgroundMagenta | Magenta background
BackgroundRed | Red background
Blink | Blinking
ForegroundBlack | Black foreground
ForegroundBlue | Blue foreground
ForegroundBrown | Brown foreground
ForegroundCyan | Cyan foreground
ForegroundGray | Gray foreground
ForegroundGreen | Green foreground
ForegroundMagenta | Magenta foreground
ForegroundRed | Red foreground
Intensity | Intensity

Remarks

Used by the ClearVideo, ClearVideoRegion, ControlClock, DisplayData, DrawBox, and UpdateVideoRegionAttribute methods. Members of this enumeration replace the ROD_ATTR_ range of UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
RemoteOrderDisplay.ClearVideo Method
RemoteOrderDisplay.ClearVideoRegion Method
RemoteOrderDisplay.ControlClock Method
RemoteOrderDisplay.DisplayData Method
RemoteOrderDisplay.DrawBox Method
RemoteOrderDisplay.UpdateVideoRegionAttribute Method


VideoCursorType Enumeration

VideoCursorType Enumeration |
 | See Also

1/18/2008

Lists the possible video cursor types for a Remote Order Display device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration VideoCursorType
public enum VideoCursorType
public enum class VideoCursorType
public enum VideoCursorType
public enum VideoCursorType

Members

Member name | Description
Block | Enable a solid block cursor.
BlockBlink | Enable a blinking solid block cursor.
Line | Enable a solid underscore line.
LineBlink | Enable a blinking solid underscore cursor.
Off | Disable the cursor.

Remarks

Used by the ControlCursor method. Members of this enumeration replace the ROD_CRS_LINE, ROD_CRS_LINE_BLINK, ROD_CRS_BLOCK, ROD_CRS_BLOCK_BLINK, and ROD_CRS_OFF UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
RemoteOrderDisplay.ControlCursor Method


VideoMode Structure

VideoMode Structure |
 | See Also Members

1/18/2008

Defines the programmatic structure used by the service object to build an array of video modes supported by each online video unit.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Structure VideoMode
public struct VideoMode
public value class VideoMode
public final class VideoMode extends ValueType

Remarks

Used by the VideoModesList property of the RemoteOrderDisplay class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

VideoMode Members
Microsoft.PointOfService Namespace


VideoMode Members

VideoMode Members |
 | See Also Constructors Methods Properties

1/18/2008

Defines the programmatic structure used by the service object to build an array of video modes supported by each online video unit.

The following tables list the members exposed by the VideoMode type.

Public Constructors

Name | Description
VideoMode | Overloaded.
Top

Public Properties

Name | Description
Colors | Gets the number of colors the video unit supports.
Columns | Gets the number of columns the video unit supports.
IsColor | Get a Boolean value that indicates whether the video unit supports color.
ModeId | Holds the video mode identifier for the video unit.
Rows | Gets the number of rows the video unit supports.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. Overridden.
GetHashCode | Overridden. Returns the hash code of the current VideoMode.
GetType | (inherited from Object )
op_Equality | Compares the specified VideoMode and object to determine whether they are the same.
op_Inequality | Compares the specified VideoMode and object to determine whether they are different.
ReferenceEquals | (inherited from Object )
ToString | (inherited from ValueType )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

VideoMode Structure
Microsoft.PointOfService Namespace


VideoMode Constructor

VideoMode Constructor |
 | See Also

1/18/2008

Overload List

Name | Description
VideoMode (Int32, Int32, Int32, Boolean) | Obsolete. Creates an instance of the VideoMode structure from parameters specifying the instance's constituent parts.
VideoMode (Int32, Int32, Int32, Int32, Boolean) | Creates an instance of the VideoMode structure from parameters specifying the instance's constituent parts.

See Also

Reference

VideoMode Structure
VideoMode Members
Microsoft.PointOfService Namespace
RemoteOrderDisplay.VideoModesList Property


VideoMode Constructor (Int32, Int32, Int32, Boolean)

VideoMode Constructor (Int32, Int32, Int32, Boolean) |
 | See Also

1/18/2008

NOTE: This constructor is now obsolete.

Creates an instance of the VideoMode structure from parameters specifying the instance's constituent parts.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<ObsoleteAttribute("Please use VideoMode(int modeId, int rows, int columns, int colors, bool isColor) instead.", True)> _
Public Sub New ( _
    rows As Integer, _
    columns As Integer, _
    colors As Integer, _
    isColor As Boolean _
)
[ObsoleteAttribute("Please use VideoMode(int modeId, int rows, int columns, int colors, bool isColor) instead.", true)]
public VideoMode (
    int rows,
    int columns,
    int colors,
    bool isColor
)
[ObsoleteAttribute(L"Please use VideoMode(int modeId, int rows, int columns, int colors, bool isColor) instead.", true)]
public:
VideoMode (
    int rows,
    int columns,
    int colors,
    bool isColor
)
/** @attribute ObsoleteAttribute("Please use VideoMode(int modeId, int rows, int columns, int colors, bool isColor) instead.", true) */
public VideoMode (
    int rows,
    int columns,
    int colors,
    boolean isColor
)
ObsoleteAttribute("Please use VideoMode(int modeId, int rows, int columns, int colors, bool isColor) instead.", true)
public function VideoMode (
    rows : int,
    columns : int,
    colors : int,
    isColor : boolean
)

Parameters

rows

Number of rows.

columns

Number of columns.

colors

Number of colors.

isColor

true if video is color; otherwise, false.

See Also

Reference

VideoMode Structure
VideoMode Members
Microsoft.PointOfService Namespace
RemoteOrderDisplay.VideoModesList Property


VideoMode Constructor (Int32, Int32, Int32, Int32, Boolean)

VideoMode Constructor (Int32, Int32, Int32, Int32, Boolean) |
 | See Also

1/18/2008

Creates an instance of the VideoMode structure from parameters specifying the instance's constituent parts.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Sub New ( _
    modeId As Integer, _
    rows As Integer, _
    columns As Integer, _
    colors As Integer, _
    isColor As Boolean _
)
public VideoMode (
    int modeId,
    int rows,
    int columns,
    int colors,
    bool isColor
)
public:
VideoMode (
    int modeId,
    int rows,
    int columns,
    int colors,
    bool isColor
)
public VideoMode (
    int modeId,
    int rows,
    int columns,
    int colors,
    boolean isColor
)
public function VideoMode (
    modeId : int,
    rows : int,
    columns : int,
    colors : int,
    isColor : boolean
)

Parameters

modeId
rows

The number of rows.

columns

The number of columns.

colors

The number of colors

isColor

true if video is color; otherwise, false.

Remarks

Initializes a new VideoMode structure from the specified VideoMode parameters.

See Also

Reference

VideoMode Structure
VideoMode Members
Microsoft.PointOfService Namespace


VideoMode Methods

VideoMode Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. Overridden.
GetHashCode | Overridden. Returns the hash code of the current VideoMode.
GetType | (inherited from Object )
op_Equality | Compares the specified VideoMode and object to determine whether they are the same.
op_Inequality | Compares the specified VideoMode and object to determine whether they are different.
ReferenceEquals | (inherited from Object )
ToString | (inherited from ValueType )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

VideoMode Structure
Microsoft.PointOfService Namespace


VideoMode.Equals Method

VideoMode.Equals Method |
 | See Also

1/18/2008

Overload List

Name | Description
VideoMode.Equals (Object) | Determines whether the specified object is equal to the current VideoMode.
VideoMode.Equals (VideoMode) | Determines whether the specified VideoMode is equal to the current VideoMode.
VideoMode.Equals (Object, Object) | (inherited from Equals )
VideoMode.Equals (VideoMode, VideoMode) | Determines whether the specified VideoMode instances are equal.

See Also

Reference

VideoMode Structure
VideoMode Members
Microsoft.PointOfService Namespace


VideoMode.Equals Method (Object)

VideoMode.Equals Method (Object) |
 | See Also

1/18/2008

Determines whether the specified object is equal to the current VideoMode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public override bool Equals (
    Object obj
)
public:
virtual bool Equals (
    Object^ obj
) override
public boolean Equals (
    Object obj
)
public override function Equals (
    obj : Object
) : boolean

Parameters

obj

Return Value

True if the specified object is equal to the current VideoMode; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

VideoMode Structure
VideoMode Members
Microsoft.PointOfService Namespace


VideoMode.Equals Method (VideoMode)

VideoMode.Equals Method (VideoMode) |
 | See Also

1/18/2008

Determines whether the specified VideoMode is equal to the current VideoMode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Function Equals ( _
    mode As VideoMode _
) As Boolean
public bool Equals (
    VideoMode mode
)
public:
bool Equals (
    VideoMode mode
)
public boolean Equals (
    VideoMode mode
)
public function Equals (
    mode : VideoMode
) : boolean

Parameters

mode

The Videomode to be compared to the current Videomode.

Return Value

True if the specified VideoMode is equal to the current VideoMode; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

VideoMode Structure
VideoMode Members
Microsoft.PointOfService Namespace


VideoMode.Equals Method (VideoMode, VideoMode)

VideoMode.Equals Method (VideoMode, VideoMode) |
 | See Also

1/18/2008

Determines whether the specified VideoMode instances are equal.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Function Equals ( _
    a As VideoMode, _
    b As VideoMode _
) As Boolean
public static bool Equals (
    VideoMode a,
    VideoMode b
)
public:
static bool Equals (
    VideoMode a,
    VideoMode b
)
public static boolean Equals (
    VideoMode a,
    VideoMode b
)
public static function Equals (
    a : VideoMode,
    b : VideoMode
) : boolean

Parameters

a

The first VideoMode to compare.

b

The second VideoMode to compare.

Return Value

True if the two instances of VideoMode contain the same values; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

VideoMode Structure
VideoMode Members
Microsoft.PointOfService Namespace


VideoMode.GetHashCode Method

VideoMode.GetHashCode Method |
 | See Also

1/18/2008

Returns the hash code of the current VideoMode.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Overrides Function GetHashCode As Integer
public override int GetHashCode ()
public:
virtual int GetHashCode () override
public int GetHashCode ()
public override function GetHashCode () : int

Return Value

Returns the Int32 representation of the hash code for the current Videomode

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

VideoMode Structure
VideoMode Members
Microsoft.PointOfService Namespace


VideoMode.op_Equality Method

VideoMode.op_Equality Method |
 | See Also

1/18/2008

Compares the specified VideoMode and object to determine whether they are the same.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Operator = ( _
    a As VideoMode, _
    b As Object _
) As Boolean
public static bool operator == (
    VideoMode a,
    Object b
)
public:
static bool operator == (
    VideoMode a,
    Object^ b
)

Parameters

a

The VideoMode to be compared to b.

b

The object to be compared to a.

Return Value

True if a is equal to b; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

VideoMode Structure
VideoMode Members
Microsoft.PointOfService Namespace


VideoMode.op_Inequality Method

VideoMode.op_Inequality Method |
 | See Also

1/18/2008

Compares the specified VideoMode and object to determine whether they are different.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Shared Operator <> ( _
    a As VideoMode, _
    b As Object _
) As Boolean
public static bool operator != (
    VideoMode a,
    Object b
)
public:
static bool operator != (
    VideoMode a,
    Object^ b
)

Parameters

a

The VideoMode to be compared to b

b

The Object to be compared to a

Return Value

True if a is not equal to b; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

VideoMode Structure
VideoMode Members
Microsoft.PointOfService Namespace


VideoMode Properties

VideoMode Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
Colors | Gets the number of colors the video unit supports.
Columns | Gets the number of columns the video unit supports.
IsColor | Get a Boolean value that indicates whether the video unit supports color.
ModeId | Holds the video mode identifier for the video unit.
Rows | Gets the number of rows the video unit supports.

See Also

Reference

VideoMode Structure
Microsoft.PointOfService Namespace


VideoMode.Colors Property

VideoMode.Colors Property |
 | See Also

1/18/2008

Gets the number of colors the video unit supports.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Colors As Integer
public int Colors { get; }
public:
property int Colors {
    int get ();
}
/** @property */
public int get_Colors ()

public function get Colors () : int

Property Value

The number of colors supported by the current video unit.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

VideoMode Structure
VideoMode Members
Microsoft.PointOfService Namespace


VideoMode.Columns Property

VideoMode.Columns Property |
 | See Also

1/18/2008

Gets the number of columns the video unit supports.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Columns As Integer
public int Columns { get; }
public:
property int Columns {
    int get ();
}
/** @property */
public int get_Columns ()

public function get Columns () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

VideoMode Structure
VideoMode Members
Microsoft.PointOfService Namespace


VideoMode.IsColor Property

VideoMode.IsColor Property |
 | See Also

1/18/2008

Get a Boolean value that indicates whether the video unit supports color.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property IsColor As Boolean
public bool IsColor { get; }
public:
property bool IsColor {
    bool get ();
}
/** @property */
public boolean get_IsColor ()

public function get IsColor () : boolean

Remarks

True if video supports color; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

VideoMode Structure
VideoMode Members
Microsoft.PointOfService Namespace


VideoMode.ModeId Property

VideoMode.ModeId Property |
 | See Also

1/18/2008

Holds the video mode identifier for the video unit.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property ModeId As Integer
public int ModeId { get; }
public:
property int ModeId {
    int get ();
}
/** @property */
public int get_ModeId ()

public function get ModeId () : int

Remarks

The Int32 representation indicates the mode identity of the current video unit.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

VideoMode Structure
VideoMode Members
Microsoft.PointOfService Namespace


VideoMode.Rows Property

VideoMode.Rows Property |
 | See Also

1/18/2008

Gets the number of rows the video unit supports.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public ReadOnly Property Rows As Integer
public int Rows { get; }
public:
property int Rows {
    int get ();
}
/** @property */
public int get_Rows ()

public function get Rows () : int

Property Value

The number of rows supported by the current video unit.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

VideoMode Structure
VideoMode Members
Microsoft.PointOfService Namespace


WeightUnit Enumeration

WeightUnit Enumeration |
 | See Also

1/18/2008

Lists the valid weight units for a Scale device.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

Public Enumeration WeightUnit
public enum WeightUnit
public enum class WeightUnit
public enum WeightUnit
public enum WeightUnit

Members

Member name | Description
Gram | gram
Kilogram | kilogram
Ounce | ounce
Pound | pound

Remarks

Used by the WeightUnit property. Members of this enumeration replace the SCAL_WU_GRAM, SCAL_WU_KILOGRAM, SCAL_WU_OUNCE, and SCAL_WU_POUND UPOS constants.

See Also

Reference

Microsoft.PointOfService Namespace
Scale.WeightUnit Property


WriteTagSections Enumeration

WriteTagSections Enumeration |
 | See Also

1/18/2008

Enumerates the writable fields in the tag.

Namespace: Microsoft.PointOfService
Assembly: Microsoft.PointOfService (in microsoft.pointofservice.dll)

Syntax

<FlagsAttribute> _
Public Enumeration WriteTagSections
[FlagsAttribute]
public enum WriteTagSections
[FlagsAttribute]
public enum class WriteTagSections
/** @attribute FlagsAttribute() */
public enum WriteTagSections
FlagsAttribute
public enum WriteTagSections

Members

Member name | Description
All | All fields in the tag are writable.
IdOnly | The ID field in the tag is writable.
None | No writable fields in the tag.
UserData | The UserData field in the tag is writable.

Remarks

The value of this property indicates only the write capability of the device and does not imply the write ability of any specific tag. The application should query this property before invoking writing methods.

This property is initialized by the Open method.

See Also

Reference

Microsoft.PointOfService Namespace


Microsoft.PointOfService.BaseServiceObjects Namespace

Microsoft.PointOfService.BaseServiceObjects Namespace
1/18/2008

Classes

Class | Description
CashDrawerBase | Exposes functionality required for support of cash drawer devices.
CashDrawerProperties | CashDrawerProperties is a helper class created by POS for .NET to simplify the retrieval and setting of property values for cash drawer devices.
Cell | A helper class created by POS for .NET to simplify the update of the array of cells used by the DisplayData method.
CheckScannerBase | Contains most of the functionality for support of check scanner devices.
CheckScannerImage | A helper class created by POS for .NET to simplify the retrieval of scanned images and setting of properties.
CheckScannerProperties | A helper class created by POS for .NET to simplify the retrieval and setting of property values for check scanner devices.
ClearPrintAreaOperation | Clears the area defined by the PageModePrintArea property.
CutPaperOperation | When the application updates printer properties and then calls the CutPaper method, the PosPrinterBase class uses an instance of the CutPaperOperation class, cast to the PrintOperation class and stored in the PrintOperationCollection array, to capture information about that method call.
DeviceStatistics | Helps a service object implement device statistics reporting.
DrawerStateChangedEventArgs | Used as the event type for the DrawerStateChangedEventHandler delegate.
LineDisplayBase | Contains most of the functionality required for support of Line Display devices, including drawing of text and graphics (glyphs and bitmaps), window management, and scrolling, marquee, and teletype functions.
LineDisplayBitmap | A helper class created by POS for .NET and used by the LineDisplayBase class for creating and displaying bitmaps.
LineDisplayProperties | A helper class created by POS for .NET to simplify the retrieval and setting of property values for line display devices.
LineDisplayScreenMode | An array of instances of DisplayScreenMode is used to provide a list of supported screen modes for the ScreenModeList property.
MarkFeedOperation | Used to capture information about the MarkFeed method call.
MsrBase | Contains most of the functionality for support of MSR devices.
MsrFieldData | An instance of a MsrFieldData class is returned by the ParseMsrFieldData protected method of the MsrBase class. The string fields and discretionary data are decoded, and then stored in their respective properties.
MsrProperties | A helper class created by POS for .NET to simplify the retrieval and setting of property values for MSR devices.
MsrTrackData | An instance of MsrTrackData is returned by the ParseMsrTrackData protected method of the MsrBase class. Tracks 1 through 4 are decoded and stored in each of the four, discrete Track properties.
PageModePrintCollection | Prints a collection of PageModePrintOperation.
PageModePrintOperation | Indicates a single page mode print operation.
PinPadBase | Implements all properties and methods for supporting PIN pad devices.
PinPadProperties | A helper class created by POS for .NET to simplify the retrieval and setting of property values for PIN pad devices.
PosKeyboardBase | Contains compete device functionality implemented by POS for .NET for support of keyboard devices.
PosKeyboardProperties | A helper class created by POS for .NET to simplify the retrieval and setting of property values for keyboard devices.
PosPrinterBase | PosPrinterBase class derives from PosPrinterBasic class and contains more complete device functionality implemented by POS for .NET for support of POS printer devices.
PrintBarCodeOperation | Captures information about a print operation method call.
PrintBitmapOperation | Captures information about the PrintBitmap method.
PrinterProperties | A helper class that simplifies the retrieval and setting of property values for printer devices.
PrinterState | Contains property values holding information about the printer state.
PrintMemoryBitmapOperation | Captures information about the PrintMemoryBitmap method.
PrintNormalOperation | Capture and holds information about a print method call.
PrintOperation | The abstract class definition from which all other <PrintMethodName>Operation classes are derived.
PrintOperationCollection | Maintains a list of print operations and their associated state information.
PrintResults | The PrintResults helper class simplifies the return of status from service object-implemented base class methods and is used by the PosPrinterBase class to maintain and update printer statistics.
PrintTwoNormalOperation | The PrintTwoNormalOperation helper class is used by PosPrinterBase to capture information about the PrintTwoNormal method call.
RFIDDataEventArgs | Defines the programmatic interface for the transmission of RFID data events.
RFIDScannerBase | Contains most of the functionality for support of RFID Scanner devices.
RFIDScannerProperties | Defines the common properties of the RFID Scanner device.
RFIDTag | A helper class created by POS for .NET and used by RFIDScannerBase class for handling RFID tags.
RotatePrintCollection | The RotatePrintCollection helper class is used to store an array, or list, of requested rotation print operations.
RotatePrintOperation | The RotatePrintOperation helper class is used by PosPrinterBase to capture the requested rotation whenever the RotatePrint method is called.
ScannerBase | Contains most of the functionality for support of scanner devices.
ScannerProperties | The ScannerProperties helper class simplifies the setting and retrieval of scanner device property values.

Delegates

Delegate | Description
DrawerStateChangedEventHandler | Delegate for the OnDrawerStateChanged event.
GetStatistic | Gets a device statistic.
LineDisplayBase.BlinkRateChangedEventHandler | Delegate for the BlinkRateChangedEvent protected event.
LineDisplayBase.CurrentWindowChangedEventHandler | Delegate for the CurrentWindowChangedEvent protected event.
LineDisplayBase.CursorTypeChangedEventHandler | Delegate for the CursorTypeChangedEvent protected event.
LineDisplayBase.ScreenModeChangedEventHandler | Delegate for the ScreenModeChangedEvent protected event.
PosPrinterBase.CancelPrintEventHandler | Delegate for the CancelPrintEvent event.
SetStatistic | Sets the specified statistic to the specified value.

Enumerations

Enumeration | Description
CardType | Enumerates the possible card types recognized by POS for .NET.
CellType | Defines the possible types of data that can be displayed on the line display device.


CardType Enumeration

CardType Enumeration |
 | See Also

1/18/2008

Enumerates the possible card types recognized by POS for .NET.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Enumeration CardType
public enum CardType
public enum class CardType
public enum CardType
public enum CardType

Members

Member name | Description
Aamva | Card type is United States and Canadian Driver's License or ID Card.
Blank | Card type is intentionally blank.
Iso | ISO card type.
JisOne | JIS Type I card type.
JisTwo | JIS Type II card type.
Other | Card type other than the ones mentioned above.
Unknown | Unknown card type.

Remarks

Used by the GoodRead, FailedRead, and UnreadableCard protected methods of the MsrBase class. CardType contains values that indicate the type of card swiped in an MSR device.

See Also

Reference

Microsoft.PointOfService.BaseServiceObjects Namespace


CashDrawerBase Class

CashDrawerBase Class |
 | See Also Members

1/18/2008

Exposes functionality required for support of cash drawer devices.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public MustInherit Class CashDrawerBase
    Inherits CashDrawerBasic
public abstract class CashDrawerBase : CashDrawerBasic
public ref class CashDrawerBase abstract : public CashDrawerBasic
public abstract class CashDrawerBase extends CashDrawerBasic
public abstract class CashDrawerBase extends CashDrawerBasic

Remarks

The CashDrawerBase class derives from the CashDrawerBasic class and contains most of the functionality required for support of cash drawer devices. When deriving from CashDrawerBase, service objects need only implement the OpenDrawerImpl, CheckHealth, and DirectIO methods. (OpenDrawerImpl is required for the physical opening of the cash drawer.) Optionally, service objects can implement the OnDrawerStateChanged event to be notified when the drawer state has been changed by other processes.

The CashDrawerBase class provides the core functionality for opening, claiming, and enabling cash drawer devices. Typically, though, the service object will want to override these methods to add its own custom processing. (An example would be to update device statistics during the Open method, or to bring the device online when the application enables it.) When overriding these methods, the service object must call the base class implementation.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.CashDrawer
Microsoft.PointOfService.BasicServiceObjects.CashDrawerBasic
Microsoft.PointOfService.BaseServiceObjects.CashDrawerBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashDrawerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


CashDrawerBase Members

CashDrawerBase Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Exposes functionality required for support of cash drawer devices.

The following tables list the members exposed by the CashDrawerBase type.

Protected Constructors

Name | Description
CashDrawerBase | Creates an instance of the CashDrawerBase.
Top

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticDrawerFailedOpenCount | Incremented during the OpenDrawer method if the cash drawer does not open. (inherited from CashDrawer)
StatisticDrawerGoodOpenCount | Incremented during the OpenDrawer method if the cash drawer successfully opens. (inherited from CashDrawer)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusClosed | Indicates that the cash drawer is closed. (inherited from CashDrawer)
StatusOpen | Indicates that the cash drawer is open. (inherited from CashDrawer)
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from CashDrawerBasic)
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from CashDrawerBasic)
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from CashDrawerBasic)
CapStatus | Overridden. Indicates that the drawer can report its status.
CapStatusMultiDrawerDetect | Overridden. Indicates that statuses unique to each drawer in multi-drawer configurations can be reported.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from CashDrawerBasic)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from CashDrawerBasic)
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from CashDrawerBasic)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from CashDrawerBasic)
DeviceEnabled | Overridden.
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from CashDrawerBasic)
DrawerOpened | Overridden. Indicates whether the drawer is open.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from CashDrawerBasic)
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from CashDrawerBasic)
PowerState | Gets the current power condition. (inherited from CashDrawerBasic)
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from CashDrawerBasic)
ServiceObjectVersion | Gets the Service Object version number. (inherited from CashDrawerBasic)
State | Gets the current state of the device. (inherited from CashDrawerBasic)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Top

Protected Properties

Name | Description
CommonProperties | (inherited from CashDrawerBasic )
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
ExternallyClaimed | (inherited from CashDrawerBasic )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Gets the Boolean value that indicates whether the Cash Drawer is an exclusive-use device. (inherited from CashDrawer)
Properties | Returns an instance of the CashDrawerProperties helper class, containing getters and setters for cash drawer and common properties.
Top

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from CashDrawerBasic )
Close | Overridden. Releases the device and its resources.
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Overridden. Opens a device for subsequent input/output processing.
OpenDrawer | Overridden. Physically opens the cash drawer.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from CashDrawerBasic)
ResetStatistic | (inherited from CashDrawerBasic )
ResetStatistics | Overloaded. (inherited from CashDrawerBasic )
RetrieveStatistic | (inherited from CashDrawerBasic )
RetrieveStatistics | Overloaded. (inherited from CashDrawerBasic )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from CashDrawerBasic )
UpdateStatistics | Overloaded. (inherited from CashDrawerBasic )
WaitForDrawerClose | Overridden. The application calls WaitForDrawerClose to wait until the cash drawer is closed.
Top

Protected Methods

Name | Description
CreateStatistic | Overloaded. (inherited from CashDrawerBasic )
DeleteConfigurationProperty | (inherited from PosCommon )
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
GetStatisticValue | (inherited from CashDrawerBasic )
IncrementStatistic | Overloaded. (inherited from CashDrawerBasic )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
OpenDrawerImpl | Implemented by the service object to physically open the cash drawer.
PreFireEvent | Overloaded.
QueueEvent | Overloaded. (inherited from CashDrawerBasic )
QueueEventAndWait | (inherited from CashDrawerBasic )
SetConfigurationProperty | (inherited from PosCommon )
SetStatisticHandlers | (inherited from CashDrawerBasic )
SetStatisticValue | (inherited from CashDrawerBasic )
VerifyState | (inherited from CashDrawerBasic )
Top

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from CashDrawerBasic)
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from CashDrawerBasic)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
OnDrawerStateChanged | The CashDrawerBase class raises OnDrawerStateChanged events to inform the service object that the value of the CashDrawerProperties.DrawerOpened property has been updated and the application has been notified of a drawer status change.
StateChangedEvent | (inherited from CashDrawerBasic )
Top

See Also

Reference

CashDrawerBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


CashDrawerBase Fields

CashDrawerBase Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticDrawerFailedOpenCount | Incremented during the OpenDrawer method if the cash drawer does not open. (inherited from CashDrawer )
StatisticDrawerGoodOpenCount | Incremented during the OpenDrawer method if the cash drawer successfully opens. (inherited from CashDrawer )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusClosed | Indicates that the cash drawer is closed. (inherited from CashDrawer )
StatusOpen | Indicates that the cash drawer is open. (inherited from CashDrawer )
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

CashDrawerBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


CashDrawerBase Constructor

CashDrawerBase Constructor |
 | See Also

1/18/2008

Creates an instance of the CashDrawerBase.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Sub New
protected CashDrawerBase ()
protected:
CashDrawerBase ()
protected CashDrawerBase ()
protected function CashDrawerBase ()

Remarks

Creates an instance of the CashDrawerBase. Initializes statistics for the UPOS Version, the Device Category, and the Installation Date.

See Also

Reference

CashDrawerBase Class
CashDrawerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


CashDrawerBase Methods

CashDrawerBase Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from CashDrawerBasic )
Close | Overridden. Releases the device and its resources.
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Overridden. Opens a device for subsequent input/output processing.
OpenDrawer | Overridden. Physically opens the cash drawer.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from CashDrawerBasic )
ResetStatistic | (inherited from CashDrawerBasic )
ResetStatistics | Overloaded. (inherited from CashDrawerBasic )
RetrieveStatistic | (inherited from CashDrawerBasic )
RetrieveStatistics | Overloaded. (inherited from CashDrawerBasic )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from CashDrawerBasic )
UpdateStatistics | Overloaded. (inherited from CashDrawerBasic )
WaitForDrawerClose | Overridden. The application calls WaitForDrawerClose to wait until the cash drawer is closed.

Protected Methods

Name | Description
CreateStatistic | Overloaded. (inherited from CashDrawerBasic )
DeleteConfigurationProperty | (inherited from PosCommon )
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
GetStatisticValue | (inherited from CashDrawerBasic )
IncrementStatistic | Overloaded. (inherited from CashDrawerBasic )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
OpenDrawerImpl | Implemented by the service object to physically open the cash drawer.
PreFireEvent | Overloaded.
QueueEvent | Overloaded. (inherited from CashDrawerBasic )
QueueEventAndWait | (inherited from CashDrawerBasic )
SetConfigurationProperty | (inherited from PosCommon )
SetStatisticHandlers | (inherited from CashDrawerBasic )
SetStatisticValue | (inherited from CashDrawerBasic )
VerifyState | (inherited from CashDrawerBasic )

See Also

Reference

CashDrawerBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


CashDrawerBase.Close Method

CashDrawerBase.Close Method |
 | See Also

1/18/2008

Releases the device and its resources.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub Close
public override void Close ()
public:
virtual void Close () override
public void Close ()
public override function Close ()

Remarks

POS for .NET releases the service object, shuts down statistics reporting, and stops all event threads.

If the DeviceEnabled property is set to true, then POS for .NET will disable the device. If the Claimed property is set to true, then POS for .NET will release the device.

Close may throw a PosControlException with the following values:

Value | Meaning
Closed | The device is already closed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashDrawerBase Class
CashDrawerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosCommon.Close Method


CashDrawerBase.Dispose Method

CashDrawerBase.Dispose Method |
 | See Also

1/18/2008

Overload List

Name | Description
CashDrawerBase.Dispose () | (inherited from Dispose )
CashDrawerBase.Dispose (Boolean) |

See Also

Reference

CashDrawerBase Class
CashDrawerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


CashDrawerBase.Dispose Method (Boolean)

CashDrawerBase.Dispose Method (Boolean) |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

protected override void Dispose (
    bool disposing
)

protected:
virtual void Dispose (
    bool disposing
) override

protected void Dispose (
    boolean disposing
)

protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashDrawerBase Class
CashDrawerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


CashDrawerBase.Open Method

CashDrawerBase.Open Method |
 | See Also

1/18/2008

Opens a device for subsequent input/output processing.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub Open
public override void Open ()
public:
virtual void Open () override
public void Open ()
public override function Open ()

Remarks

Open initializes statistics reporting and event threads for the specified device. Open also initializes the values of numerous properties, including DataEventEnabled, FreezeEvents, AutoDisable, Claimed, and so on. For specifics about how these properties are initialized, see the individual properties.

Open may throw a PosControlException with the following values:

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The device is already opened; or

  • The DeviceName property is null or an empty string ("").

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashDrawerBase Class
CashDrawerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosCommon.Open Method


CashDrawerBase.OpenDrawer Method

CashDrawerBase.OpenDrawer Method |
 | See Also

1/18/2008

Physically opens the cash drawer.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub OpenDrawer
public override void OpenDrawer ()
public:
virtual void OpenDrawer () override
public void OpenDrawer ()
public override function OpenDrawer ()

Remarks

The application calls OpenDrawer to have the service object physically open the cash drawer. The CashDrawerBase class ensures that the cash drawer device is opened and enabled by the application but not claimed by any other application, then calls the protected OpenDrawerImpl method, which must be implemented by the service object.

The CashDrawerBase class implementation of OpenDrawer can throw the following exceptions:

Value | Meaning
Closed | The cash drawer device must be opened by the application before OpenDrawer can be called.
Claimed | The cash drawer is currently claimed by another application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashDrawerBase Class
CashDrawerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CashDrawer.OpenDrawer Method
OpenDrawerImpl


CashDrawerBase.OpenDrawerImpl Method

CashDrawerBase.OpenDrawerImpl Method |
 | See Also

1/18/2008

Implemented by the service object to physically open the cash drawer.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected MustOverride Sub OpenDrawerImpl
protected abstract void OpenDrawerImpl ()
protected:
virtual void OpenDrawerImpl () abstract
protected abstract void OpenDrawerImpl ()
protected abstract function OpenDrawerImpl ()

Remarks

Implemented by the service object to physically open the cash drawer.

If the cash drawer opens properly and the device supports status reporting (the CapStatus property is set to true), the service object should set the DrawerOpened property to true before returning from this method.

The CashDrawerBase class increments the StatisticDrawerGoodOpenCount statistic or the StatisticDrawerFailedOpenCount statistic based on the following conditions:

  • If the CapStatus property is set to true after this method is called, CashDrawerBase class increments StatisticDrawerGoodOpenCount;

  • If the service object throws an exception and the CapStatus property is set to true, CashDrawerBase class increments StatisticDrawerFailedOpenCount.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashDrawerBase Class
CashDrawerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
DrawerOpened
CashDrawerBase.OpenDrawer Method
CashDrawer.StatisticDrawerGoodOpenCount Field
CashDrawer.StatisticDrawerFailedOpenCount Field
CashDrawer.CapStatus Property


CashDrawerBase.PreFireEvent Method

CashDrawerBase.PreFireEvent Method |
 | See Also

1/18/2008

Overload List

Name | Description
CashDrawerBase.PreFireEvent (DirectIOEventArgs) | (inherited from PreFireEvent )
CashDrawerBase.PreFireEvent (StatusUpdateEventArgs) | Updates the DrawerOpened property and informs applications using the cash drawer of the status change.

See Also

Reference

CashDrawerBase Class
CashDrawerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


CashDrawerBase.PreFireEvent Method (StatusUpdateEventArgs)

CashDrawerBase.PreFireEvent Method (StatusUpdateEventArgs) |
 | See Also

1/18/2008

Updates the DrawerOpened property and informs applications using the cash drawer of the status change.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overrides Sub PreFireEvent ( _
    posEvent As StatusUpdateEventArgs _
)
protected override void PreFireEvent (
    StatusUpdateEventArgs posEvent
)
protected:
virtual void PreFireEvent (
    StatusUpdateEventArgs^ posEvent
) override
protected void PreFireEvent (
    StatusUpdateEventArgs posEvent
)
protected override function PreFireEvent (
    posEvent : StatusUpdateEventArgs
)

Parameters

posEvent

An instance of the StatusUpdateEventArgs class, posEvent contains the event the service object queued to the application.

Remarks

If the value of the DrawerOpened property changes, the CashDrawerBase class’s implementation of PreFireEvent updates the CashDrawerProperties.DrawerOpened property, thus generating a StatusUpdateEvent event to all applications using the cash drawer, informing them of a drawer status change.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashDrawerBase Class
CashDrawerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
DrawerOpened
StatusUpdateEvent
StatusUpdateEventArgs Class


CashDrawerBase.WaitForDrawerClose Method

CashDrawerBase.WaitForDrawerClose Method |
 | See Also

1/18/2008

The application calls WaitForDrawerClose to wait until the cash drawer is closed.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub WaitForDrawerClose ( _
    beepTimeout As Integer, _
    beepFrequency As Integer, _
    beepDuration As Integer, _
    beepDelay As Integer _
)
public override void WaitForDrawerClose (
    int beepTimeout,
    int beepFrequency,
    int beepDuration,
    int beepDelay
)
public:
virtual void WaitForDrawerClose (
    int beepTimeout,
    int beepFrequency,
    int beepDuration,
    int beepDelay
) override
public void WaitForDrawerClose (
    int beepTimeout,
    int beepFrequency,
    int beepDuration,
    int beepDelay
)
public override function WaitForDrawerClose (
    beepTimeout : int,
    beepFrequency : int,
    beepDuration : int,
    beepDelay : int
)

Parameters

beepTimeout

Number of milliseconds to wait before starting an alert beeper.

beepFrequency

Audio frequency of the alert beeper in hertz.

beepDuration

Number of milliseconds that the beep tone will sound.

beepDelay

Number of milliseconds between the sounding of beeper tones.

Remarks

The CashDrawerBase class ensures that the device is opened and enabled by the application, and that no other application has the device claimed. If the CapStatus property is set to false, WaitForDrawerClose returns immediately. The CashDrawerBase class then waits the number of milliseconds specified by the timeout parameter and begins beeping, using the speaker. WaitForDrawerClose returns when the DrawerOpened property is set to true. If an error occurs while waiting for the drawer to close, the service object should set the State property to ControlState.Error, which will cause the CashDrawerBase class to stop waiting and throw a PosControlException of Failure to the application.

Note: It is the service object’s responsibility to update the CashDrawerProperties.DrawerOpened property to false.

The CashDrawerBase class implementation of WaitForDrawerClose may throw a PosControlException with the following values:

Value | Meaning
Closed | The cash drawer device must be opened by the application before WaitForDrawerClose can be called.
Claimed | The drawer is currently claimed by another application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashDrawerBase Class
CashDrawerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CashDrawer.WaitForDrawerClose Method


CashDrawerBase Properties

CashDrawerBase Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from CashDrawerBasic )
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from CashDrawerBasic )
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from CashDrawerBasic )
CapStatus | Overridden. Indicates that the drawer can report its status.
CapStatusMultiDrawerDetect | Overridden. Indicates that statuses unique to each drawer in multi-drawer configurations can be reported.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from CashDrawerBasic )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from CashDrawerBasic )
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from CashDrawerBasic )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from CashDrawerBasic )
DeviceEnabled | Overridden.
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from CashDrawerBasic )
DrawerOpened | Overridden. Indicates whether the drawer is open.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from CashDrawerBasic )
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from CashDrawerBasic )
PowerState | Gets the current power condition. (inherited from CashDrawerBasic )
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from CashDrawerBasic )
ServiceObjectVersion | Gets the Service Object version number. (inherited from CashDrawerBasic )
State | Gets the current state of the device. (inherited from CashDrawerBasic )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )

Protected Properties

Name | Description
CommonProperties | (inherited from CashDrawerBasic )
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
ExternallyClaimed | (inherited from CashDrawerBasic )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Gets the Boolean value that indicates whether the Cash Drawer is an exclusive-use device. (inherited from CashDrawer )
Properties | Returns an instance of the CashDrawerProperties helper class, containing getters and setters for cash drawer and common properties.

See Also

Reference

CashDrawerBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


CashDrawerBase.CapStatus Property

CashDrawerBase.CapStatus Property |
 | See Also

1/18/2008

Indicates that the drawer can report its status.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapStatus As Boolean
public override bool CapStatus { get; }
public:
virtual property bool CapStatus {
    bool get () override;
}
/** @property */
public boolean get_CapStatus ()

public override function get CapStatus () : boolean

Remarks

The CashDrawerBase class verifies that the cash drawer device has been opened, then retrieves the value of CashDrawerProperties.CapStatus.

CapStatus is initialized by the CashDrawerProperties class to false. The service object should update CapStatus to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashDrawerBase Class
CashDrawerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CashDrawer.CapStatus Property
CapStatus


CashDrawerBase.CapStatusMultiDrawerDetect Property

CashDrawerBase.CapStatusMultiDrawerDetect Property |
 | See Also

1/18/2008

Indicates that statuses unique to each drawer in multi-drawer configurations can be reported.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapStatusMultiDrawerDetect As Boolean
public override bool CapStatusMultiDrawerDetect { get; }
public:
virtual property bool CapStatusMultiDrawerDetect {
    bool get () override;
}
/** @property */
public boolean get_CapStatusMultiDrawerDetect ()

public override function get CapStatusMultiDrawerDetect () : boolean

Remarks

The CashDrawerBase class verifies that the cash drawer device has been opened, then retrieves the value of CashDrawerProperties.CapStatusMultiDrawerDetect.

CapStatusMultiDrawerDetect is initialized by the CashDrawerProperties class to false. The service object should update CapStatusMultiDrawerDetect to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashDrawerBase Class
CashDrawerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CashDrawer.CapStatusMultiDrawerDetect Property
CapStatusMultiDrawerDetect


CashDrawerBase.DeviceEnabled Property

CashDrawerBase.DeviceEnabled Property |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property DeviceEnabled As Boolean
public override bool DeviceEnabled { get; set; }
public:
virtual property bool DeviceEnabled {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_DeviceEnabled ()

/** @property */
public void set_DeviceEnabled (boolean value)

public override function get DeviceEnabled () : boolean

public override function set DeviceEnabled (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashDrawerBase Class
CashDrawerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosCommon.DeviceEnabled Property


CashDrawerBase.DrawerOpened Property

CashDrawerBase.DrawerOpened Property |
 | See Also

1/18/2008

Indicates whether the drawer is open.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property DrawerOpened As Boolean
public override bool DrawerOpened { get; }
public:
virtual property bool DrawerOpened {
    bool get () override;
}
/** @property */
public boolean get_DrawerOpened ()

public override function get DrawerOpened () : boolean

Remarks

The CashDrawerBase class verifies that the cash drawer device has been opened, then retrieves the value of CashDrawerProperties.DrawerOpened. If CashDrawerProperties.CapStatus is false and the application attempts to retrieve DrawerOpened, CashDrawerBase class ensures that the value of DrawerOpened is set to false. Otherwise, the current value of CashDrawerProperties.DrawerOpened is returned.

If CashDrawerProperties.CapStatus is false, any attempt to set CashDrawerProperties.DrawerOpened will cause the CashDrawerProperties class to throw an exception. Otherwise, when the value of CashDrawerProperties.DrawerOpened changes, CashDrawerProperties class does the following:

  • Raises a StatusUpdateEvent event informing all applications using the cash drawer that the status of the cash drawer has changed; and

  • Raises an OnDrawerStateChangedEvent to the service object, informing it of the drawer status change.

DrawerOpened is initialized by the CashDrawerProperties class to false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashDrawerBase Class
CashDrawerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CashDrawer.DrawerOpened Property
DrawerOpened
CashDrawer.CapStatus Property
OnDrawerStateChanged
StatusUpdateEvent


CashDrawerBase.Properties Property

CashDrawerBase.Properties Property |
 | See Also

1/18/2008

Returns an instance of the CashDrawerProperties helper class, containing getters and setters for cash drawer and common properties.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected ReadOnly Property Properties As CashDrawerProperties
protected CashDrawerProperties Properties { get; }
protected:
property CashDrawerProperties^ Properties {
    CashDrawerProperties^ get ();
}
/** @property */
protected CashDrawerProperties get_Properties ()

protected function get Properties () : CashDrawerProperties

Remarks

Returns an instance of the CashDrawerProperties helper class, containing getters and setters for cash drawer and common properties. The service object uses an instance of CashDrawerProperties class for two reasons: a) to set properties that are designated read-only for the application; and b) to access properties without being held to device state verification (that is, without having to open, claim, or enable the device first).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashDrawerBase Class
CashDrawerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CashDrawerProperties


CashDrawerBase Events

CashDrawerBase Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from CashDrawerBasic )
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from CashDrawerBasic )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
OnDrawerStateChanged | The CashDrawerBase class raises OnDrawerStateChanged events to inform the service object that the value of the CashDrawerProperties.DrawerOpened property has been updated and the application has been notified of a drawer status change.
StateChangedEvent | (inherited from CashDrawerBasic )

See Also

Reference

CashDrawerBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


CashDrawerBase.OnDrawerStateChanged Event

CashDrawerBase.OnDrawerStateChanged Event |
 | See Also

1/18/2008

The CashDrawerBase class raises OnDrawerStateChanged events to inform the service object that the value of the CashDrawerProperties.DrawerOpened property has been updated and the application has been notified of a drawer status change.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Event OnDrawerStateChanged As DrawerStateChangedEventHandler
protected event DrawerStateChangedEventHandler OnDrawerStateChanged
protected:
event DrawerStateChangedEventHandler^ OnDrawerStateChanged {
    void add (DrawerStateChangedEventHandler^ value);
    void remove (DrawerStateChangedEventHandler^ value);
}
/** @event */
protected void add_OnDrawerStateChanged (DrawerStateChangedEventHandler value)

/** @event */
protected void remove_OnDrawerStateChanged (DrawerStateChangedEventHandler value)

Remarks

The CashDrawerBase class raises OnDrawerStateChanged events to inform the service object that the value of the CashDrawerProperties.DrawerOpened property has been updated and the application has been notified of a drawer status change. A DrawerStateChangedEventArgs.DrawerOpened value of true indicates the drawer status has changed to “open”; a DrawerStateChangedEventArgs.DrawerOpened value of false indicates the drawer status has changed to “closed”.

Service objects should consider implementing OnDrawerStateChanged when they want to be notified by the CashDrawerBase class of drawer state changes.

See Also

Reference

CashDrawerBase Class
CashDrawerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
DrawerStateChangedEventArgs
CashDrawer.DrawerOpened Property


CashDrawerProperties Class

CashDrawerProperties Class |
 | See Also Members

1/18/2008

CashDrawerProperties is a helper class created by POS for .NET to simplify the retrieval and setting of property values for cash drawer devices.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class CashDrawerProperties
    Inherits CommonProperties
public class CashDrawerProperties : CommonProperties
public ref class CashDrawerProperties : public CommonProperties
public class CashDrawerProperties extends CommonProperties
public class CashDrawerProperties extends CommonProperties

Remarks

CashDrawerProperties is a helper class created by POS for .NET to simplify the retrieval and setting of property values for cash drawer devices. CashDrawerProperties inherits from the CommonProperties class. The protected Properties property of CashDrawerBase class returns an instance of CashDrawerProperties that includes property initializations provided by POS for .NET. CashDrawerProperties bypasses state validation—in other words, the service object can use CashDrawerProperties to set values for properties even if the device hasn’t been opened, claimed, or enabled. For information about the properties in CashDrawerProperties, refer to the CashDrawerBase class.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BasicServiceObjects.CommonProperties
Microsoft.PointOfService.BaseServiceObjects.CashDrawerProperties

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashDrawerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


CashDrawerProperties Members

CashDrawerProperties Members |
 | See Also Methods Properties

1/18/2008

CashDrawerProperties is a helper class created by POS for .NET to simplify the retrieval and setting of property values for cash drawer devices.

The following tables list the members exposed by the CashDrawerProperties type.

Public Properties

Name | Description
CapCompareFirmwareVersion | (inherited from CommonProperties )
CapPowerReporting | (inherited from CommonProperties )
CapStatisticsReporting | (inherited from CommonProperties )
CapStatus | Indicates that the drawer can report its status.
CapStatusMultiDrawerDetect | Indicates whether statuses unique to each drawer in multi-drawer configurations* can be reported.
CapUpdateFirmware | (inherited from CommonProperties )
CapUpdateStatistics | (inherited from CommonProperties )
DeviceDescription | (inherited from CommonProperties )
DeviceName | (inherited from CommonProperties )
DrawerOpened | Indicates whether the drawer is open.
PowerState | (inherited from CommonProperties )
ServiceObjectDescription | (inherited from CommonProperties )
ServiceObjectVersion | (inherited from CommonProperties )
State | (inherited from CommonProperties )
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

CashDrawerProperties Class
Microsoft.PointOfService.BaseServiceObjects Namespace


CashDrawerProperties Methods

CashDrawerProperties Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

CashDrawerProperties Class
Microsoft.PointOfService.BaseServiceObjects Namespace


CashDrawerProperties Properties

CashDrawerProperties Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
CapCompareFirmwareVersion | (inherited from CommonProperties )
CapPowerReporting | (inherited from CommonProperties )
CapStatisticsReporting | (inherited from CommonProperties )
CapStatus | Indicates that the drawer can report its status.
CapStatusMultiDrawerDetect | Indicates whether statuses unique to each drawer in multi-drawer configurations* can be reported.
CapUpdateFirmware | (inherited from CommonProperties )
CapUpdateStatistics | (inherited from CommonProperties )
DeviceDescription | (inherited from CommonProperties )
DeviceName | (inherited from CommonProperties )
DrawerOpened | Indicates whether the drawer is open.
PowerState | (inherited from CommonProperties )
ServiceObjectDescription | (inherited from CommonProperties )
ServiceObjectVersion | (inherited from CommonProperties )
State | (inherited from CommonProperties )

See Also

Reference

CashDrawerProperties Class
Microsoft.PointOfService.BaseServiceObjects Namespace


CashDrawerProperties.CapStatus Property

CashDrawerProperties.CapStatus Property |
 | See Also

1/18/2008

Indicates that the drawer can report its status.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapStatus As Boolean
public bool CapStatus { get; set; }
public:
property bool CapStatus {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapStatus ()

/** @property */
public void set_CapStatus (boolean value)

public function get CapStatus () : boolean

public function set CapStatus (value : boolean)

Remarks

CapStatus is set by the service object and then kept updated by the service object based on the capability of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashDrawerProperties Class
CashDrawerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CashDrawerBase.CapStatus Property


CashDrawerProperties.CapStatusMultiDrawerDetect Property

CashDrawerProperties.CapStatusMultiDrawerDetect Property |
 | See Also

1/18/2008

Indicates whether statuses unique to each drawer in multi-drawer configurations* can be reported.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapStatusMultiDrawerDetect As Boolean
public bool CapStatusMultiDrawerDetect { get; set; }
public:
property bool CapStatusMultiDrawerDetect {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapStatusMultiDrawerDetect ()

/** @property */
public void set_CapStatusMultiDrawerDetect (boolean value)

public function get CapStatusMultiDrawerDetect () : boolean

public function set CapStatusMultiDrawerDetect (value : boolean)

Remarks

If false, the following implications exist:

  • A DrawerOpened property value of false indicates that the drawer is closed.

  • A DrawerOpened property value of true indicates that at least one drawer is open, and it might be the particular drawer in question. This case can occur in multi-drawer configurations* where only one status is reported indicating either a) all drawers are closed, or b) one or more drawers are open.

CapStatusMultiDrawerDetect is only meaningful if the CapStatus property is set to true.

CapStatusMultiDrawerDetect is set by the service object and then kept updated by the service object based on the capability of the device.

Accessing CapStatusMultiDrawerDetect may cause a PosControlException to be thrown with the following errorcodes:

Value | Meaning
Closed | The cash drawer device must be opened before CapStatusMultiDrawerDetect can be retrieved.

*Multi-Drawer Configuration – A hardware configuration where a printer or terminal supports opening more than one drawer independently via the same channel or hardware port. A typical example is a configuration with a “Y” cable connected to a single hardware port that controls two drawers.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashDrawerProperties Class
CashDrawerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CashDrawerBase.CapStatusMultiDrawerDetect Property


CashDrawerProperties.DrawerOpened Property

CashDrawerProperties.DrawerOpened Property |
 | See Also

1/18/2008

Indicates whether the drawer is open.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property DrawerOpened As Boolean
public bool DrawerOpened { get; set; }
public:
property bool DrawerOpened {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_DrawerOpened ()

/** @property */
public void set_DrawerOpened (boolean value)

public function get DrawerOpened () : boolean

public function set DrawerOpened (value : boolean)

Remarks

This property indicates whether the drawer is open. If the boolean value is true, the drawer is open; if false, it is closed. When the value of DrawerOpened changes, a StatusUpdateEvent event is generated, indicating the drawer status change.

If the CapStatus property is set to false, the device does not support status reporting and DrawerOpened is always false.

DrawerOpened is set by the service object and then kept current by the service object while the device is enabled.

Accessing DrawerOpened may cause a PosControlException to be thrown with the following errorcodes:

Value | Meaning
Closed | The cash drawer device must be opened before DrawerOpened can be retrieved.
Illegal | The cash drawer device doesn’t support status reporting—that is, the CapStatus property is set to false.

*If the CapStatusMultiDrawerDetect property is false, then a DrawerOpened value of true indicates at least one drawer is open, and it might be the particular drawer in question for multi-drawer configurations. See CapStatusMultiDrawerDetect for clarification.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CashDrawerProperties Class
CashDrawerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CashDrawerBase.DrawerOpened Property


Cell Class

Cell Class |
 | See Also Members

1/18/2008

A helper class created by POS for .NET to simplify the update of the array of cells used by the DisplayData method.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class Cell
public class Cell
public ref class Cell
public class Cell
public class Cell

Remarks

Cell is a helper class created by POS for .NET to simplify the update of the array of cells used by the DisplayData method, which is implemented by the service object and called by the base class whenever the device must be updated. Each cell represents a single character position (or a bitmap or glyph) on the display.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BaseServiceObjects.Cell

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cell Members
Microsoft.PointOfService.BaseServiceObjects Namespace
DisplayData


Cell Members

Cell Members |
 | See Also Methods Properties

1/18/2008

A helper class created by POS for .NET to simplify the update of the array of cells used by the DisplayData method.

The following tables list the members exposed by the Cell type.

Public Properties

Name | Description
Attribute | Contains the text mode attribute used to display the data.
Bitmap | If the Type is CellType.BitMap, contains the characters to be displayed.
Character | If the Type is CellType.Character, contains the characters to be displayed.
Column | Contains the column where the data is to be displayed.
PixelData | Contains the pixels to be displayed.
Row | Contains the row where the data is to be displayed.
Type | Contains the type of character, bitmap, or glyph being displayed.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

Cell Class
Microsoft.PointOfService.BaseServiceObjects Namespace
DisplayData


Cell Methods

Cell Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

Cell Class
Microsoft.PointOfService.BaseServiceObjects Namespace
DisplayData


Cell Properties

Cell Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
Attribute | Contains the text mode attribute used to display the data.
Bitmap | If the Type is CellType.BitMap, contains the characters to be displayed.
Character | If the Type is CellType.Character, contains the characters to be displayed.
Column | Contains the column where the data is to be displayed.
PixelData | Contains the pixels to be displayed.
Row | Contains the row where the data is to be displayed.
Type | Contains the type of character, bitmap, or glyph being displayed.

See Also

Reference

Cell Class
Microsoft.PointOfService.BaseServiceObjects Namespace
DisplayData


Cell.Attribute Property

Cell.Attribute Property |
 | See Also

1/18/2008

Contains the text mode attribute used to display the data.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Attribute As DisplayTextMode
public DisplayTextMode Attribute { get; }
public:
property DisplayTextMode Attribute {
    DisplayTextMode get ();
}
/** @property */
public DisplayTextMode get_Attribute ()

public function get Attribute () : DisplayTextMode

Remarks

Contains the text mode attribute used to display the data. Valid values are defined by the DisplayTextMode enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cell Class
Cell Members
Microsoft.PointOfService.BaseServiceObjects Namespace
DisplayTextMode Enumeration


Cell.Bitmap Property

Cell.Bitmap Property |
 | See Also

1/18/2008

If the Type is CellType.BitMap, contains the characters to be displayed.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Bitmap As LineDisplayBitmap
public LineDisplayBitmap Bitmap { get; }
public:
property LineDisplayBitmap^ Bitmap {
    LineDisplayBitmap^ get ();
}
/** @property */
public LineDisplayBitmap get_Bitmap ()

public function get Bitmap () : LineDisplayBitmap

Remarks

If the Type is CellType.BitMap, contains the characters to be displayed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cell Class
Cell Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CellType


Cell.Character Property

Cell.Character Property |
 | See Also

1/18/2008

If the Type is CellType.Character, contains the characters to be displayed.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Character As Integer
public int Character { get; }
public:
property int Character {
    int get ();
}
/** @property */
public int get_Character ()

public function get Character () : int

Remarks

If the Type is CellType.Character, contains the characters to be displayed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cell Class
Cell Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CellType


Cell.Column Property

Cell.Column Property |
 | See Also

1/18/2008

Contains the column where the data is to be displayed.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Column As Integer
public int Column { get; }
public:
property int Column {
    int get ();
}
/** @property */
public int get_Column ()

public function get Column () : int

Remarks

Contains the column where the data is to be displayed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cell Class
Cell Members
Microsoft.PointOfService.BaseServiceObjects Namespace


Cell.PixelData Property

Cell.PixelData Property |
 | See Also

1/18/2008

Contains the pixels to be displayed.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property PixelData As Byte()
public byte[] PixelData { get; }
public:
property array<unsigned char>^ PixelData {
    array<unsigned char>^ get ();
}
/** @property */
public byte[] get_PixelData ()

public function get PixelData () : byte[]

Remarks

Contains the pixels to be displayed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cell Class
Cell Members
Microsoft.PointOfService.BaseServiceObjects Namespace


Cell.Row Property

Cell.Row Property |
 | See Also

1/18/2008

Contains the row where the data is to be displayed.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Row As Integer
public int Row { get; }
public:
property int Row {
    int get ();
}
/** @property */
public int get_Row ()

public function get Row () : int

Remarks

Contains the row where the data is to be displayed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cell Class
Cell Members
Microsoft.PointOfService.BaseServiceObjects Namespace


Cell.Type Property

Cell.Type Property |
 | See Also

1/18/2008

Contains the type of character, bitmap, or glyph being displayed.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Type As CellType
public CellType Type { get; }
public:
property CellType Type {
    CellType get ();
}
/** @property */
public CellType get_Type ()

public function get Type () : CellType

Remarks

Contains the type of character, bitmap, or glyph being displayed. Values are based on the CellType enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

Cell Class
Cell Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CellType


CellType Enumeration

CellType Enumeration |
 | See Also

1/18/2008

Defines the possible types of data that can be displayed on the line display device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Enumeration CellType
public enum CellType
public enum class CellType
public enum CellType
public enum CellType

Members

Member name | Description
Bitmap | The cell to be displayed contains a bitmap.
Character | The cell to be displayed contains characters.
Empty | The cell to be displayed contains no data.
Glyph | The cell to be displayed contains a glyph.

Remarks

Defines the possible types of data that can be displayed on the line display device.

See Also

Reference

Microsoft.PointOfService.BaseServiceObjects Namespace
DisplayData
Cell Class


CheckScannerBase Class

CheckScannerBase Class |
 | See Also Members

1/18/2008

Contains most of the functionality for support of check scanner devices.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public MustInherit Class CheckScannerBase
    Inherits CheckScannerBasic
public abstract class CheckScannerBase : CheckScannerBasic
public ref class CheckScannerBase abstract : public CheckScannerBasic
public abstract class CheckScannerBase extends CheckScannerBasic
public abstract class CheckScannerBase extends CheckScannerBasic

Remarks

The CheckScannerBase class derives from CheckScannerBasic class and contains most of the functionality for support of check scanner devices. When deriving from CheckScannerBase, service objects should implement the CheckHealth and DirectIO methods.

The CheckScannerBase class provides the core functionality for opening, claiming, and enabling check scanner devices. Typically, though, service objects will want to override these methods to add their own custom processing. (An example would be to update device statistics during the Open method, or to bring the device online when the application enables it.) When overriding these methods, the service object must call the base class implementation.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.CheckScanner
Microsoft.PointOfService.BasicServiceObjects.CheckScannerBasic
Microsoft.PointOfService.BaseServiceObjects.CheckScannerBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


CheckScannerBase Members

CheckScannerBase Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Contains most of the functionality for support of check scanner devices.

The following tables list the members exposed by the CheckScannerBase type.

Protected Constructors

Name | Description
CheckScannerBase | Creates an instance of the CheckScannerBase class.
Top

Public Fields

Name | Description
AutomaticContrast | Indicates the device can automatically adjust the contrast of the image. (inherited from CheckScanner)
CropAreaBottom | Indicates that the y endpoint value of the scanned image is set to the value of the DocumentHeight property. (inherited from CheckScanner)
CropAreaEntireImage | Indicates the crop area is equal to the scanned image. (inherited from CheckScanner)
CropAreaResetAll | Indicates that the crop area definitions (as specified by the value of the MaxCropAreas property) have their x,y and width/height values reset to 0,0 and DocumentWidth and DocumentHeight, respectively. (inherited from CheckScanner)
CropAreaRight | Indicates that the x endpoint value of a scanned image are set to the value of the DocumentWidth property. (inherited from CheckScanner)
ExtendedErrorCheck | Indicates that a check was detected in the check scanner device. (inherited from CheckScanner)
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorNoCheck | Indicates that no check was detected in the check scanner device. (inherited from CheckScanner)
ExtendedErrorNoRoom | Indicates there is no room for the scanned image to be stored in memory. (inherited from CheckScanner)
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
GetRawImageData | Indicates the image data from the check scanner is in a native format that cannot be converted to a bitmap. (inherited from CheckScanner)
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusScanComplete | Indicates that the check scan is complete. (inherited from CheckScanner)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
AutoDisable | Gets or sets the Boolean value that indicates whether POS for .NET automatically disables the device when data is received. (inherited from CheckScannerBasic)
CapAutoContrast | Overridden. Gets the Boolean value that indicates whether the contrast can be adjusted automatically.
CapAutoGenerateFileId | Overridden. Indicates whether the check scanner device can automatically create a file name for the captured image file.
CapAutoGenerateImageTagData | Overridden. Indicates whether the check scanner device can automatically generate tag data used in reference to the image file for the captured image.
CapAutoSize | Overridden. Indicates whether the height and width of the scanned document will be automatically placed in the DocumentHeight and DocumentWidth properties when the image is captured.
CapColor | Overridden. Indicates whether the check scanner device supports image formats other than bi-tonal.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from CheckScannerBasic)
CapConcurrentMicr | Overridden. Indicates whether a check’s MICR (Magnetic Ink Character Recognition) data can be captured during a check scanning cycle (single-pass scanning).
CapContrast | Overridden. Gets the Boolean value that indicates the ability of the device to lighten or darken the scanned image.
CapDefineCropArea | Overridden. Indicates whether the check scanner device supports a feature that allows cropping of areas of interest within the scan image area defined by the DocumentHeight and DocumentWidth properties.
CapImageFormat | Overridden. Indicates which image file formats are supported by the check scanner device.
CapImageTagData | Overridden. Indicates whether the check scanner device can set tag data, as defined by the ImageTagData property, to the image data file stored in the ImageData property.
CapMicrDevice | Overridden. Indicates whether the check scanner device supports a check MICR read function.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from CheckScannerBasic)
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from CheckScannerBasic)
CapStoreImageFiles | Overridden. Indicates whether the check scanner device can store check images in its hardware memory by using the StoreImage method.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from CheckScannerBasic)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from CheckScannerBasic)
CapValidationDevice | Overridden. Indicates that a check doesn’t have to be removed from the check scanner device prior to performing validation printing.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from CheckScannerBasic)
Color | Overridden. Specifies the image scan mode for subsequent document scan operations.
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
ConcurrentMicr | Overridden. Indicates whether the check scanner device can conduct a MICR read during a check-scanning cycle.
Contrast | Overridden. Gets or sets the contrast to adjust the darkness of the image.
CropAreaCount | Overridden. Holds the number of defined crop areas that may be applied to the captured image.
DataCount | Gets the number of data events currently queued by the service object. (inherited from CheckScannerBasic)
DataEventEnabled | Gets or sets the Boolean value that indicates whether the service object can deliver a queued event. (inherited from CheckScannerBasic)
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from CheckScannerBasic)
DeviceEnabled | Overridden. Gets or sets a Boolean value that indicates whether the device has been placed in an operational state.
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from CheckScannerBasic)
DocumentHeight | Overridden. Holds the height of the document scanned, or the height of the document to be scanned.
DocumentWidth | Overridden. Holds the width of the document scanned, or the width of the document to be scanned.
FileId | Overridden. Holds the file name associated with the image data file.
FileIndex | Overridden. Holds the file location associated with the image data file when either the StoreImage or RetrieveMemory methods are called. Its value is set prior to a DataEvent event being delivered to the application.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from CheckScannerBasic)
ImageData | Overridden. Holds the image data after the RetrieveImage or RetrieveMemory methods are called.
ImageFormat | Overridden. Holds the data format of the image file that the device will use when it captures an image.
ImageMemoryStatus | Overridden. Indicates the current memory availability status if the device has the ability to store multiple image files.
ImageTagData | Overridden. Holds a string that specifies the tag name for the captured image data. The string may be specified by the application or automatically generated by the check scanner device.
MapMode | Overridden. Holds the mapping mode of the printer the application wants to use.
MaxCropAreas | Overridden. Specifies the maximum number of crop areas the device can support.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from CheckScannerBasic)
PowerState | Gets the current power condition. (inherited from CheckScannerBasic)
Quality | Overridden. Sets the resolution of the device when a scan image is to take place. The resolution value is defined as dpi (dots per inch).
QualityList | Overridden. Defines the resolutions the check scanner device is capable of supporting.
RemainingImagesEstimate | Overridden. Provides a “best guess” estimate of the remaining number of images that can be stored.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from CheckScannerBasic)
ServiceObjectVersion | Gets the Service Object version number. (inherited from CheckScannerBasic)
State | Gets the current state of the device. (inherited from CheckScannerBasic)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Top

Protected Properties

Name | Description
CommonProperties | (inherited from CheckScannerBasic )
CropAreas |
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
ErrorCount | (inherited from CheckScannerBasic )
ExternallyClaimed | (inherited from CheckScannerBasic )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Gets the Boolean value that indicates whether the Check Scanner is an exclusive-use device. (inherited from CheckScanner)
Properties | Holds an instance of the CheckScannerProperties helper class, which contains getters and setters for CheckScanner properties.
Top

Public Methods (see also Protected Methods )

Name | Description
BeginInsertion | Overridden. Initiates the document insertion process.
BeginRemoval | Overridden. Initiates the document removal process.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from CheckScannerBasic )
ClearImage | Overridden. Clears a specific image or all the images in the device memory.
ClearInput | Clears all device input that has been buffered. (inherited from CheckScannerBasic)
ClearInputProperties | Overridden. Resets the values of properties altered by DataEvent or ErrorEvent.
Close | Releases the device and its resources. (inherited from CheckScannerBasic)
CompareFirmwareVersion | (inherited from PosCommon )
DefineCropArea | Overridden. Establishes one or more cropping areas that can be applied to a scanned image.
DirectIO | (inherited from PosCommon )
Dispose | Overloaded.
EndInsertion | Overridden. Ends the document insertion process.
EndRemoval | Overridden. Ends the document removal or ejection mode.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Overridden. Opens a device for subsequent input/output processing.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from CheckScannerBasic)
ResetStatistic | (inherited from CheckScannerBasic )
ResetStatistics | Overloaded. (inherited from CheckScannerBasic )
RetrieveImage | Overridden. Retrieves the most recently scanned image, which is resident in the working area memory, and to use it to populate the ImageData property.
RetrieveMemory | Overridden. Retrieves an image that was previously stored in memory and use it to set the ImageData property.
RetrieveStatistic | (inherited from CheckScannerBasic )
RetrieveStatistics | Overloaded. (inherited from CheckScannerBasic )
StoreImage | Overridden. Stores an image or a cropped area of the image in the memory of the device.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from CheckScannerBasic )
UpdateStatistics | Overloaded. (inherited from CheckScannerBasic )
Top

Protected Methods

Name | Description
BeginInsertionImpl | BeginInsertionImpl must be implemented by the service object to place the check scanner in check insertion processing.
BeginRemovalImpl | BeginRemovalImpl must be implemented by the service object to initiate document removal processing.
ClearImageImpl | The service object should override the default ClearImage implementation only if the check scanner device supports storage of images.
ClearInputImpl | (inherited from CheckScannerBasic )
CreateStatistic | Overloaded. (inherited from CheckScannerBasic )
DeleteConfigurationProperty | (inherited from PosCommon )
Dispose | Overloaded. Overridden.
EndInsertionImpl | EndInsertionImpl must be implemented by the service object to terminate the check insertion process.
EndRemovalImpl | EndRemovalImpl must be implemented by the service object to terminate the document removal process.
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
GetStatisticValue | (inherited from CheckScannerBasic )
IncrementStatistic | Overloaded. (inherited from CheckScannerBasic )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
PreFireEvent | Overloaded. Overridden.
QueueEvent | Overloaded. (inherited from CheckScannerBasic )
QueueEventAndWait | Overloaded. (inherited from CheckScannerBasic )
RetrieveMemoryImpl | The service object should override the default implementation only if the check scanner device supports storage of images.
ScanCheck | Returns a scanned image of the check, created from the raw data in the format specified by the value of the ImageFormat property.
SetConfigurationProperty | (inherited from PosCommon )
SetStatisticHandlers | (inherited from CheckScannerBasic )
SetStatisticValue | (inherited from CheckScannerBasic )
StoreImageImpl | The service object should override the default implementation only if the check scanner device supports the storage of images.
VerifyState | (inherited from CheckScannerBasic )
Top

Public Events (see also Protected Events )

Name | Description
DataEvent | Raised to notify the application that a scanned check image is available. (inherited from CheckScannerBasic)
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from CheckScannerBasic)
ErrorEvent | Raised to indicate an error has been detected while trying to read keyboard device input data. (inherited from CheckScannerBasic)
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from CheckScannerBasic)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
StateChangedEvent | (inherited from CheckScannerBasic )
Top

See Also

Reference

CheckScannerBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


CheckScannerBase Fields

CheckScannerBase Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
AutomaticContrast | Indicates the device can automatically adjust the contrast of the image. (inherited from CheckScanner )
CropAreaBottom | Indicates that the y endpoint value of the scanned image is set to the value of the DocumentHeight property. (inherited from CheckScanner )
CropAreaEntireImage | Indicates the crop area is equal to the scanned image. (inherited from CheckScanner )
CropAreaResetAll | Indicates that the crop area definitions (as specified by the value of the MaxCropAreas property) have their x,y and width/height values reset to 0,0 and DocumentWidth and DocumentHeight, respectively. (inherited from CheckScanner )
CropAreaRight | Indicates that the x endpoint value of a scanned image are set to the value of the DocumentWidth property. (inherited from CheckScanner )
ExtendedErrorCheck | Indicates that a check was detected in the check scanner device. (inherited from CheckScanner )
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorNoCheck | Indicates that no check was detected in the check scanner device. (inherited from CheckScanner )
ExtendedErrorNoRoom | Indicates there is no room for the scanned image to be stored in memory. (inherited from CheckScanner )
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
GetRawImageData | Indicates the image data from the check scanner is in a native format that cannot be converted to a bitmap. (inherited from CheckScanner )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusScanComplete | Indicates that the check scan is complete. (inherited from CheckScanner )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

CheckScannerBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


CheckScannerBase Constructor

CheckScannerBase Constructor |
 | See Also

1/18/2008

Creates an instance of the CheckScannerBase class.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Sub New
protected CheckScannerBase ()
protected:
CheckScannerBase ()
protected CheckScannerBase ()
protected function CheckScannerBase ()

Remarks

Creates an instance of the CheckScannerBase class. Initializes statistics for the UPOS Version, the Device Category, and the Installation Date.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


CheckScannerBase Methods

CheckScannerBase Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
BeginInsertion | Overridden. Initiates the document insertion process.
BeginRemoval | Overridden. Initiates the document removal process.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from CheckScannerBasic )
ClearImage | Overridden. Clears a specific image or all the images in the device memory.
ClearInput | Clears all device input that has been buffered. (inherited from CheckScannerBasic )
ClearInputProperties | Overridden. Resets the values of properties altered by DataEvent or ErrorEvent.
Close | Releases the device and its resources. (inherited from CheckScannerBasic )
CompareFirmwareVersion | (inherited from PosCommon )
DefineCropArea | Overridden. Establishes one or more cropping areas that can be applied to a scanned image.
DirectIO | (inherited from PosCommon )
Dispose | Overloaded.
EndInsertion | Overridden. Ends the document insertion process.
EndRemoval | Overridden. Ends the document removal or ejection mode.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Overridden. Opens a device for subsequent input/output processing.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from CheckScannerBasic )
ResetStatistic | (inherited from CheckScannerBasic )
ResetStatistics | Overloaded. (inherited from CheckScannerBasic )
RetrieveImage | Overridden. Retrieves the most recently scanned image, which is resident in the working area memory, and to use it to populate the ImageData property.
RetrieveMemory | Overridden. Retrieves an image that was previously stored in memory and use it to set the ImageData property.
RetrieveStatistic | (inherited from CheckScannerBasic )
RetrieveStatistics | Overloaded. (inherited from CheckScannerBasic )
StoreImage | Overridden. Stores an image or a cropped area of the image in the memory of the device.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from CheckScannerBasic )
UpdateStatistics | Overloaded. (inherited from CheckScannerBasic )

Protected Methods

Name | Description
BeginInsertionImpl | BeginInsertionImpl must be implemented by the service object to place the check scanner in check insertion processing.
BeginRemovalImpl | BeginRemovalImpl must be implemented by the service object to initiate document removal processing.
ClearImageImpl | The service object should override the default ClearImage implementation only if the check scanner device supports storage of images.
ClearInputImpl | (inherited from CheckScannerBasic )
CreateStatistic | Overloaded. (inherited from CheckScannerBasic )
DeleteConfigurationProperty | (inherited from PosCommon )
Dispose | Overloaded. Overridden.
EndInsertionImpl | EndInsertionImpl must be implemented by the service object to terminate the check insertion process.
EndRemovalImpl | EndRemovalImpl must be implemented by the service object to terminate the document removal process.
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
GetStatisticValue | (inherited from CheckScannerBasic )
IncrementStatistic | Overloaded. (inherited from CheckScannerBasic )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
PreFireEvent | Overloaded. Overridden.
QueueEvent | Overloaded. (inherited from CheckScannerBasic )
QueueEventAndWait | Overloaded. (inherited from CheckScannerBasic )
RetrieveMemoryImpl | The service object should override the default implementation only if the check scanner device supports storage of images.
ScanCheck | Returns a scanned image of the check, created from the raw data in the format specified by the value of the ImageFormat property.
SetConfigurationProperty | (inherited from PosCommon )
SetStatisticHandlers | (inherited from CheckScannerBasic )
SetStatisticValue | (inherited from CheckScannerBasic )
StoreImageImpl | The service object should override the default implementation only if the check scanner device supports the storage of images.
VerifyState | (inherited from CheckScannerBasic )

See Also

Reference

CheckScannerBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


CheckScannerBase.BeginInsertion Method

CheckScannerBase.BeginInsertion Method |
 | See Also

1/18/2008

Initiates the document insertion process.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub BeginInsertion ( _
    timeout As Integer _
)
public override void BeginInsertion (
    int timeout
)
public:
virtual void BeginInsertion (
    int timeout
) override
public void BeginInsertion (
    int timeout
)
public override function BeginInsertion (
    timeout : int
)

Parameters

timeout

Number of milliseconds before failing the method.

Remarks

The CheckScannerBase class verifies that the application has opened, claimed, and enabled the device, checks the validity of the timeout parameter, then calls the BeginInsertionImpl protected method.

If BeginInsertionImpl returns successfully, CheckScannerBase class places the device in Insertion mode.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.BeginInsertion Method


CheckScannerBase.BeginInsertionImpl Method

CheckScannerBase.BeginInsertionImpl Method |
 | See Also

1/18/2008

BeginInsertionImpl must be implemented by the service object to place the check scanner in check insertion processing.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected MustOverride Sub BeginInsertionImpl ( _
    timeout As Integer _
)
protected abstract void BeginInsertionImpl (
    int timeout
)
protected:
virtual void BeginInsertionImpl (
    int timeout
) abstract
protected abstract void BeginInsertionImpl (
    int timeout
)
protected abstract function BeginInsertionImpl (
    timeout : int
)

Parameters

timeout

Number of milliseconds before failing the method.

Remarks

The CheckScannerBase class calls BeginInsertionImpl from its BeginInsertion method. BeginInsertionImpl must be implemented by the service object to place the check scanner in check insertion processing. Before calling BeginInsertionImpl, the CheckScannerBase class ensures that the following is true:

  • The check scanner device has been opened, claimed, and enabled; and

  • The timeout parameter is greater than or equal to -1.

If these validations succeed, the CheckScannerBase class calls BeginInsertionImpl. If either of the above conditions aren’t met, the base class throws an exception.

The service object should throw PosControlExceptions if errors occur. If a timeout occurs before the check is inserted into the device, the service object should throw a PosControlException with ErrorCode set to ErrorCode.Timeout. If the check scanner device is a combination device and the peer device is busy, the service object should throw a PosControlException with ErrorCode set to ErrorCode.Busy.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.BeginInsertion Method


CheckScannerBase.BeginRemoval Method

CheckScannerBase.BeginRemoval Method |
 | See Also

1/18/2008

Initiates the document removal process.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub BeginRemoval ( _
    timeout As Integer _
)
public override void BeginRemoval (
    int timeout
)
public:
virtual void BeginRemoval (
    int timeout
) override
public void BeginRemoval (
    int timeout
)
public override function BeginRemoval (
    timeout : int
)

Parameters

timeout

Number of milliseconds before failing the method.

Remarks

The CheckScannerBase class verifies that the application has opened, claimed, and enabled the device, checks the validity of the timeout parameter, then calls the BeginRemovalImpl protected method.

If BeginRemovalImpl returns successfully, the CheckScannerBase class places the device in Removal mode.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
BeginRemovalImpl
CheckScannerBase.BeginRemoval Method


CheckScannerBase.BeginRemovalImpl Method

CheckScannerBase.BeginRemovalImpl Method |
 | See Also

1/18/2008

BeginRemovalImpl must be implemented by the service object to initiate document removal processing.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected MustOverride Sub BeginRemovalImpl ( _
    timeout As Integer _
)
protected abstract void BeginRemovalImpl (
    int timeout
)
protected:
virtual void BeginRemovalImpl (
    int timeout
) abstract
protected abstract void BeginRemovalImpl (
    int timeout
)
protected abstract function BeginRemovalImpl (
    timeout : int
)

Parameters

timeout

Number of milliseconds before failing the method.

Remarks

The CheckScannerBase class calls BeginRemovalImpl from its BeginRemoval method. BeginRemovalImpl must be implemented by the service object to initiate document removal processing. Before calling the BeginRemovalImpl, the CheckScannerBase class ensures that the following is true:

  • The check scanner device has been opened, claimed, and enabled; and

  • The timeout parameter is greater than or equal to -1.

If these validations succeed, the CheckScannerBase class calls BeginRemovalImpl. If any of the above conditions aren’t met, CheckScannerBase throws an exception.

The service object will throw PosControlExceptions if errors occur. If a timeout occurs before the check is removed from the device, the service object should throw a PosControlException with ErrorCode set to ErrorCode.Timeout. If the check scanner is a combination device and the peer device is busy, the service object should throw a PosControlException with ErrorCode set to ErrorCode.Busy.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.BeginRemoval Method


CheckScannerBase.ClearImage Method

CheckScannerBase.ClearImage Method |
 | See Also

1/18/2008

Clears a specific image or all the images in the device memory.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub ClearImage ( _
    by As CheckImageClear _
)
public override void ClearImage (
    CheckImageClear by
)
public:
virtual void ClearImage (
    CheckImageClear by
) override
public void ClearImage (
    CheckImageClear by
)
public override function ClearImage (
    by : CheckImageClear
)

Parameters

by

Indicates how the image file is to be located so that it can be removed from the storage.

Remarks

The CheckScannerBase class verifies that the application has opened, claimed, and enabled the device. If the CapStoreImageFiles property is set to false, CheckScannerBase throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal and returns. Otherwise, CheckScannerBase calls the ClearImageImpl protected method. If ClearImageImpl returns false, CheckScannerBase throws a PosControlException exception with ErrorCode set to ErrorCode.NoExist.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CapStoreImageFiles
ClearImageImpl


CheckScannerBase.ClearImageImpl Method

CheckScannerBase.ClearImageImpl Method |
 | See Also

1/18/2008

The service object should override the default ClearImage implementation only if the check scanner device supports storage of images.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overridable Function ClearImageImpl ( _
    by As CheckImageClear _
) As Boolean
protected virtual bool ClearImageImpl (
    CheckImageClear by
)
protected:
virtual bool ClearImageImpl (
    CheckImageClear by
)
protected boolean ClearImageImpl (
    CheckImageClear by
)
protected function ClearImageImpl (
    by : CheckImageClear
) : boolean

Parameters

by

Indicates how the image file is to be located so that it can be removed from the storage.

Remarks

The CheckScannerBase class has a default implementation of ClearImageImpl that throws a Not Implemented exception. The service object should override the default implementation only if the check scanner device supports storage of images. The CheckScannerBase class calls the service object’s implementation of ClearImageImpl from its ClearImage method. Before calling ClearImageImpl, the CheckScannerBase class ensures that the following is true:

  • The check scanner device has been opened, claimed, and enabled;

  • The check scanner is supports storage of images—that is, the CapStorageImageFiles property is set to true; and

  • The by parameter contains a valid value.

If these validations are performed successfully, the CheckScannerBase class calls ClearImageImpl. If they fail, the base class throws an exception.

The service object’s implementation should return true if the image was successfully cleared, false if the image specified wasn’t found, and throw PosControlException exceptions for all other error conditions, using the ErrorCode and ErrorCodeExtended properties.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.ClearImage Method
CapStoreImageFiles


CheckScannerBase.ClearInputProperties Method

CheckScannerBase.ClearInputProperties Method |
 | See Also

1/18/2008

Resets the values of properties altered by DataEvent or ErrorEvent.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub ClearInputProperties
public override void ClearInputProperties ()
public:
virtual void ClearInputProperties () override
public void ClearInputProperties ()
public override function ClearInputProperties ()

Remarks

Sets all data properties populated by raising the DataEvent event or ErrorEvent event back to their default values. This does not reset the DataCount or State properties.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.DataEvent Event
CheckScanner.ErrorEvent Event
CheckScanner.DataCount Property


CheckScannerBase.DefineCropArea Method

CheckScannerBase.DefineCropArea Method |
 | See Also

1/18/2008

Establishes one or more cropping areas that can be applied to a scanned image.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub DefineCropArea ( _
    cropAreaId As Integer, _
    x As Integer, _
    y As Integer, _
    width As Integer, _
    height As Integer _
)
public override void DefineCropArea (
    int cropAreaId,
    int x,
    int y,
    int width,
    int height
)
public:
virtual void DefineCropArea (
    int cropAreaId,
    int x,
    int y,
    int width,
    int height
) override
public void DefineCropArea (
    int cropAreaId,
    int x,
    int y,
    int width,
    int height
)
public override function DefineCropArea (
    cropAreaId : int,
    x : int,
    y : int,
    width : int,
    height : int
)

Parameters

cropAreaId

The numeric identifier for the defined crop area.

x

The starting X-coordinate of the cropping area.

y

The starting Y-coordinate of the cropping area.

width

The value added to the X-coordinate in order to determine the X endpoint of the cropping area.

height

The value added to the Y-coordinate in order to determine the Y endpoint of the cropping area.

Remarks

The CheckScannerBase class verifies that the application has opened, claimed, and enabled the device. If the CapDefineCropArea property is set to false, CheckScannerBase class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal and returns. If the cropAreaID parameter is set to a value less than -2, DefineCropArea returns without storing the defined crop area. If the crop areas count exceeds the value of the MaxCropAreas property, CheckScannerBase throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal. If the x, y, width or height parameters are set to invalid values, CheckScannerBase throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal.

If all of the above validations are successful, the base class either creates the specified crop area or if the cropAreaId parameter is set to CropAreaResetAll, resets all crop areas. Service objects normally will not need to override DefineCropArea.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.CapDefineCropArea Property
CheckScanner.MaxCropAreas Property


CheckScannerBase.Dispose Method

CheckScannerBase.Dispose Method |
 | See Also

1/18/2008

Overload List

Name | Description
CheckScannerBase.Dispose () | (inherited from Dispose )
CheckScannerBase.Dispose (Boolean) |

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


CheckScannerBase.Dispose Method (Boolean)

CheckScannerBase.Dispose Method (Boolean) |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

protected override void Dispose (
    bool disposing
)

protected:
virtual void Dispose (
    bool disposing
) override

protected void Dispose (
    boolean disposing
)

protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


CheckScannerBase.EndInsertion Method

CheckScannerBase.EndInsertion Method |
 | See Also

1/18/2008

Ends the document insertion process.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub EndInsertion
public override void EndInsertion ()
public:
virtual void EndInsertion () override
public void EndInsertion ()
public override function EndInsertion ()

Remarks

The CheckScannerBase class verifies that the application has opened, claimed, and enabled the device. If the check scanner device isn’t currently in insertion mode, CheckScannerBase throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal. Otherwise, CheckScannerBase takes the device out of Insertion mode and calls the EndInsertionImpl protected method.

If EndInsertionImpl returns false, then CheckScannerBase throws an ExtendedErrorNoCheckPosControlException exception. If EndInsertionImpl returns TRUE, CheckScannerBase class calls the ScanCheck protected method to perform that actual check scan operation. The ScanCheck method should be implemented by the service object and return a Bitmap class containing the scanned image. If the check scan failed (the return Bitmap is null), CheckScannerBase sets the CheckScannerProperties.DocumentHeight and CheckScannerProperties.DocumentWidth properties to 0 (zero) and throws a PosControlException exception with ErrorCode set to ErrorCode.Failure exception. Otherwise, CheckScannerBase sets the values of CheckScannerProperties.DocumentHeight and CheckScannerProperties.DocumentWidth to the scanned height and width, and then queues a DataEvent event to the application. When the DataEvent is delivered to the application, CheckScannerBase class will update the ImageData property with the scanned image.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
EndInsertionImpl
DocumentHeight
DocumentWidth
CheckScanner.EndInsertion Method
CheckScanner.ExtendedErrorNoCheck Field


CheckScannerBase.EndInsertionImpl Method

CheckScannerBase.EndInsertionImpl Method |
 | See Also

1/18/2008

EndInsertionImpl must be implemented by the service object to terminate the check insertion process.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected MustOverride Function EndInsertionImpl As Boolean
protected abstract bool EndInsertionImpl ()
protected:
virtual bool EndInsertionImpl () abstract
protected abstract boolean EndInsertionImpl ()
protected abstract function EndInsertionImpl () : boolean

Remarks

The CheckScannerBase class calls EndInsertionImpl from its EndInsertion method. EndInsertionImpl must be implemented by the service object to terminate the check insertion process. Before calling EndInsertionImpl, the CheckScannerBase class ensures that the following is true:

  • The check scanner device has been opened, claimed, and enabled; and

  • The check scanner is in check insertion mode—that is, the BeginInsertion method was called before calling EndInsertion.

If these validations are performed successfully, the CheckScannerBase class calls EndInsertionImpl. If either validation fails, CheckScannerBase class throws an exception.

The service object’s implementation should return TRUE for success, FALSE if a check is not inserted in the device, and throw exceptions for all other error conditions, using the ErrorCode and ErrorCodeExtended properties. (The CheckScannerBase class implementation of EndInsertion converts a return of TRUE to Success, and a return of FALSE to ExtendedErrorNoCheck.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.EndInsertion Method


CheckScannerBase.EndRemoval Method

CheckScannerBase.EndRemoval Method |
 | See Also

1/18/2008

Ends the document removal or ejection mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub EndRemoval
public override void EndRemoval ()
public:
virtual void EndRemoval () override
public void EndRemoval ()
public override function EndRemoval ()

Remarks

The CheckScannerBase class verifies that the application has opened, claimed, and enabled the device. If the check scanner device isn’t in check removal mode, the CheckScannerBase class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal. Otherwise, it takes the device out of Removal mode and calls the EndRemovalImpl protected method. If EndRemovalImpl returns FALSE, CheckScannerBase class throws an ExtendedErrorCheck exception.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
EndRemovalImpl
CheckScanner.EndRemoval Method
CheckScanner.ExtendedErrorCheck Field


CheckScannerBase.EndRemovalImpl Method

CheckScannerBase.EndRemovalImpl Method |
 | See Also

1/18/2008

EndRemovalImpl must be implemented by the service object to terminate the document removal process.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected MustOverride Function EndRemovalImpl As Boolean
protected abstract bool EndRemovalImpl ()
protected:
virtual bool EndRemovalImpl () abstract
protected abstract boolean EndRemovalImpl ()
protected abstract function EndRemovalImpl () : boolean

Remarks

The CheckScannerBase class calls EndRemovalImpl from its EndRemoval method. EndRemovalImpl must be implemented by the service object to terminate the document removal process. Before calling EndRemovalImpl, the CheckScannerBase class ensures that the following is true:

  • The check scanner device has been opened, claimed, and enabled; and

  • The BeginRemoval method was called before calling EndRemoval.

If these validations are performed successfully, the CheckScannerBase class calls EndRemovalImpl. If either one fails, the CheckScannerBase class throws an exception.

The service object’s implementation should return TRUE for success, FALSE if a check is inserted in the device, and throw exceptions for all other error conditions, using the ErrorCode and ErrorCodeExtended properties. (The CheckScannerBase class implementation of EndRemoval converts a return of TRUE to Success, and a return of FALSE to ExtendedErrorCheck.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.EndRemoval Method


CheckScannerBase.Open Method

CheckScannerBase.Open Method |
 | See Also

1/18/2008

Opens a device for subsequent input/output processing.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub Open
public override void Open ()
public:
virtual void Open () override
public void Open ()
public override function Open ()

Remarks

If CheckScannerProperties.QualityList is Null, CheckScannerBase throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal. Otherwise, CheckScannerBase opens the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
QualityList


CheckScannerBase.PreFireEvent Method

CheckScannerBase.PreFireEvent Method |
 | See Also

1/18/2008

Overload List

Name | Description
CheckScannerBase.PreFireEvent (DataEventArgs) | Called prior to the delivery of a DataEvent event to the application.
CheckScannerBase.PreFireEvent (DeviceErrorEventArgs) | (inherited from PreFireEvent )
CheckScannerBase.PreFireEvent (DirectIOEventArgs) | (inherited from PreFireEvent )
CheckScannerBase.PreFireEvent (StatusUpdateEventArgs) | (inherited from PreFireEvent )

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.DataEvent Event


CheckScannerBase.PreFireEvent Method (DataEventArgs)

CheckScannerBase.PreFireEvent Method (DataEventArgs) |
 | See Also

1/18/2008

Called prior to the delivery of a DataEvent event to the application.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overrides Sub PreFireEvent ( _
    posEvent As DataEventArgs _
)
protected override void PreFireEvent (
    DataEventArgs posEvent
)
protected:
virtual void PreFireEvent (
    DataEventArgs^ posEvent
) override
protected void PreFireEvent (
    DataEventArgs posEvent
)
protected override function PreFireEvent (
    posEvent : DataEventArgs
)

Parameters

posEvent

An instance of the DataEventArgs class, posEvent contains the event that was queued to the application.

Remarks

Called prior to the delivery of a DataEvent event to the application. When PreFireEvent is called, the CheckScannerBase class implementation updates the values of the ImageData, FileId, FileIndex, and ImageTagData properties. (FileId, FileIndex, and ImateTagData are updated only if the image was retrieved from memory.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.DataEvent Event


CheckScannerBase.RetrieveImage Method

CheckScannerBase.RetrieveImage Method |
 | See Also

1/18/2008

Retrieves the most recently scanned image, which is resident in the working area memory, and to use it to populate the ImageData property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub RetrieveImage ( _
    cropAreaId As Integer _
)
public override void RetrieveImage (
    int cropAreaId
)
public:
virtual void RetrieveImage (
    int cropAreaId
) override
public void RetrieveImage (
    int cropAreaId
)
public override function RetrieveImage (
    cropAreaId : int
)

Parameters

cropAreaId

Identifier to specify the storage location of the crop area parameters to be applied to the most recently scanned image held in the working area memory of the device. If the value is CropAreaEntireImage then the entire area of the most recently scanned image is retrieved.

Remarks

The CheckScannerBase class verifies that the application has opened, claimed, and enabled the device. If the scanned image can’t be retrieved, hasn’t yet been scanned, or is not in memory, the CheckScannerBase class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal. If the cropAreaID parameter contains an invalid value, the CheckScannerBase class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal. Otherwise, the CheckScannerBase class crops the most recently scanned image using the specified cropAreaId and then queues a DataEvent event to the application containing the cropped image. If the cropped image is equal to Null, CheckScannerBase class queues an ErrorEvent event.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.RetrieveImage Method


CheckScannerBase.RetrieveMemory Method

CheckScannerBase.RetrieveMemory Method |
 | See Also

1/18/2008

Retrieves an image that was previously stored in memory and use it to set the ImageData property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub RetrieveMemory ( _
    by As CheckImageLocate _
)
public override void RetrieveMemory (
    CheckImageLocate by
)
public:
virtual void RetrieveMemory (
    CheckImageLocate by
) override
public void RetrieveMemory (
    CheckImageLocate by
)
public override function RetrieveMemory (
    by : CheckImageLocate
)

Parameters

by

Indicates how the image file is to be located so that it can be retrieved from the device memory storage.

Remarks

The CheckScannerBase class verifies that the application has opened, claimed, and enabled the device. If the CapStoreImageFiles property is set to FALSE, or if the by parameter is set to an invalid CheckImageLocate enumeration value, the CheckScannerBase class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal. Otherwise, the CheckScannerBase class calls the RetrieveMemoryImpl protected method. If the method returns a valid image, the CheckScannerBase class queues a DataEvent event to the application containing the image. If the returned image is invalid or null, the CheckScannerBase class queues an ErrorEvent event to the application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
RetrieveMemoryImpl
CapStoreImageFiles
CheckImageLocate Enumeration


CheckScannerBase.RetrieveMemoryImpl Method

CheckScannerBase.RetrieveMemoryImpl Method |
 | See Also

1/18/2008

The service object should override the default implementation only if the check scanner device supports storage of images.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overridable Function RetrieveMemoryImpl ( _
    by As CheckImageLocate _
) As CheckScannerImage
protected virtual CheckScannerImage RetrieveMemoryImpl (
    CheckImageLocate by
)
protected:
virtual CheckScannerImage^ RetrieveMemoryImpl (
    CheckImageLocate by
)
protected CheckScannerImage RetrieveMemoryImpl (
    CheckImageLocate by
)
protected function RetrieveMemoryImpl (
    by : CheckImageLocate
) : CheckScannerImage

Parameters

by

Indicates how the image file is to be located so that it can be retrieved from the device memory storage.

Remarks

The CheckScannerBase class has a default implementation of RetrieveMemoryImpl that throws a Not Implemented exception. The service object should override the default implementation only if the check scanner device supports storage of images—that is, the value of CapStoreImageFiles is set to true). The CheckScannerBase class calls the service object’s implementation of RetrieveMemoryImpl from its RetrieveMemory method. Before calling RetrieveMemoryImpl, the CheckScannerBase class ensures that the following is true:

  • The check scanner device has been opened, claimed, and enabled;

  • The check scanner supports storage of images—that is, the CapStorageImageFiles property is set to true; and

  • The by parameter contains a valid value.

If these validations are performed successfully, the CheckScannerBase class calls RetrieveMemoryImpl. If any of them fail, the base class throws an exception.

The service object’s implementation should return the scanned image as an instance of the CheckScannerImage class. CheckScannerBase class will update the ImageData, FileId, FileIndex and ImageTagData properties, based on values returned in the CheckScannerImage class, when the DataEvent event is delivered to the application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.RetrieveMemory Method
CheckScannerImage


CheckScannerBase.ScanCheck Method

CheckScannerBase.ScanCheck Method |
 | See Also

1/18/2008

Returns a scanned image of the check, created from the raw data in the format specified by the value of the ImageFormat property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected MustOverride Function ScanCheck As Bitmap
protected abstract Bitmap ScanCheck ()
protected:
virtual Bitmap^ ScanCheck () abstract
protected abstract Bitmap ScanCheck ()
protected abstract function ScanCheck () : Bitmap

Remarks

Called by the CheckScannerBase class immediately after the EndInsertion method returns successfully. The service object should return the scanned image data as a .NET Bitmap class, created from the raw data in the format specified by the value of the ImageFormat property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.ScanCheck Method


CheckScannerBase.StoreImage Method

CheckScannerBase.StoreImage Method |
 | See Also

1/18/2008

Stores an image or a cropped area of the image in the memory of the device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub StoreImage ( _
    cropAreaId As Integer _
)
public override void StoreImage (
    int cropAreaId
)
public:
virtual void StoreImage (
    int cropAreaId
) override
public void StoreImage (
    int cropAreaId
)
public override function StoreImage (
    cropAreaId : int
)

Parameters

cropAreaId

Identifier to specify the storage location of the crop area parameters to be applied to the most recently scanned image held in the working area memory of the device. If the value is CropAreaEntireImage then the entire area of the most recently scanned image is retrieved.

Remarks

CheckScannerBase class verifies that the application has opened, claimed, and enabled the device. If the CapStoreImageFiles property is set to FALSE, or if there is no scanned image in memory, CheckScannerBase class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal. If the cropAreaID parameter is invalid, CheckScannerBase class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal. Otherwise, CheckScannerBase class crops the image in memory using the cropAreaId parameter and then calls the StoreImageImpl protected method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
StoreImageImpl
CapStoreImageFiles


CheckScannerBase.StoreImageImpl Method

CheckScannerBase.StoreImageImpl Method |
 | See Also

1/18/2008

The service object should override the default implementation only if the check scanner device supports the storage of images.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overridable Sub StoreImageImpl ( _
    image As Bitmap _
)
protected virtual void StoreImageImpl (
    Bitmap image
)
protected:
virtual void StoreImageImpl (
    Bitmap^ image
)
protected void StoreImageImpl (
    Bitmap image
)
protected function StoreImageImpl (
    image : Bitmap
)

Parameters

image

A bitmap.

Remarks

The CheckScannerBase class has a default implementation of StoreImageImpl that throws a Not Implemented exception. The service object should override the default implementation only if the check scanner device supports storage of images—that is, if the value of CapStoreImageFiles is set to true.

The CheckScannerBase class crops the image and then calls the service object’s implementation of StoreImageImpl from its StoreImage method, so that the service object can perform the function of actually storing the image. Before calling StoreImageImpl, the CheckScannerBase class ensures that the following is true:

  • The check scanner device has been opened, claimed, and enabled; and

  • The check scanner supports storage of images—that is, the CapStorageImageFiles property is set to true.

If these validations are performed successfully, the CheckScannerBase class calls StoreImageImpl. If either one fails, the CheckScannerBase class throws an exception.

The service object’s implementation should throw PosControlExceptions if errors occur, using the ErrorCode and ErrorCodeExtended properties.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.StoreImage Method
CapStoreImageFiles


CheckScannerBase Properties

CheckScannerBase Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
AutoDisable | Gets or sets the Boolean value that indicates whether POS for .NET automatically disables the device when data is received. (inherited from CheckScannerBasic )
CapAutoContrast | Overridden. Gets the Boolean value that indicates whether the contrast can be adjusted automatically.
CapAutoGenerateFileId | Overridden. Indicates whether the check scanner device can automatically create a file name for the captured image file.
CapAutoGenerateImageTagData | Overridden. Indicates whether the check scanner device can automatically generate tag data used in reference to the image file for the captured image.
CapAutoSize | Overridden. Indicates whether the height and width of the scanned document will be automatically placed in the DocumentHeight and DocumentWidth properties when the image is captured.
CapColor | Overridden. Indicates whether the check scanner device supports image formats other than bi-tonal.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from CheckScannerBasic )
CapConcurrentMicr | Overridden. Indicates whether a check’s MICR (Magnetic Ink Character Recognition) data can be captured during a check scanning cycle (single-pass scanning).
CapContrast | Overridden. Gets the Boolean value that indicates the ability of the device to lighten or darken the scanned image.
CapDefineCropArea | Overridden. Indicates whether the check scanner device supports a feature that allows cropping of areas of interest within the scan image area defined by the DocumentHeight and DocumentWidth properties.
CapImageFormat | Overridden. Indicates which image file formats are supported by the check scanner device.
CapImageTagData | Overridden. Indicates whether the check scanner device can set tag data, as defined by the ImageTagData property, to the image data file stored in the ImageData property.
CapMicrDevice | Overridden. Indicates whether the check scanner device supports a check MICR read function.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from CheckScannerBasic )
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from CheckScannerBasic )
CapStoreImageFiles | Overridden. Indicates whether the check scanner device can store check images in its hardware memory by using the StoreImage method.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from CheckScannerBasic )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from CheckScannerBasic )
CapValidationDevice | Overridden. Indicates that a check doesn’t have to be removed from the check scanner device prior to performing validation printing.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from CheckScannerBasic )
Color | Overridden. Specifies the image scan mode for subsequent document scan operations.
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
ConcurrentMicr | Overridden. Indicates whether the check scanner device can conduct a MICR read during a check-scanning cycle.
Contrast | Overridden. Gets or sets the contrast to adjust the darkness of the image.
CropAreaCount | Overridden. Holds the number of defined crop areas that may be applied to the captured image.
DataCount | Gets the number of data events currently queued by the service object. (inherited from CheckScannerBasic )
DataEventEnabled | Gets or sets the Boolean value that indicates whether the service object can deliver a queued event. (inherited from CheckScannerBasic )
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from CheckScannerBasic )
DeviceEnabled | Overridden. Gets or sets a Boolean value that indicates whether the device has been placed in an operational state.
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from CheckScannerBasic )
DocumentHeight | Overridden. Holds the height of the document scanned, or the height of the document to be scanned.
DocumentWidth | Overridden. Holds the width of the document scanned, or the width of the document to be scanned.
FileId | Overridden. Holds the file name associated with the image data file.
FileIndex | Overridden. Holds the file location associated with the image data file when either the StoreImage or RetrieveMemory methods are called. Its value is set prior to a DataEvent event being delivered to the application.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from CheckScannerBasic )
ImageData | Overridden. Holds the image data after the RetrieveImage or RetrieveMemory methods are called.
ImageFormat | Overridden. Holds the data format of the image file that the device will use when it captures an image.
ImageMemoryStatus | Overridden. Indicates the current memory availability status if the device has the ability to store multiple image files.
ImageTagData | Overridden. Holds a string that specifies the tag name for the captured image data. The string may be specified by the application or automatically generated by the check scanner device.
MapMode | Overridden. Holds the mapping mode of the printer the application wants to use.
MaxCropAreas | Overridden. Specifies the maximum number of crop areas the device can support.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from CheckScannerBasic )
PowerState | Gets the current power condition. (inherited from CheckScannerBasic )
Quality | Overridden. Sets the resolution of the device when a scan image is to take place. The resolution value is defined as dpi (dots per inch).
QualityList | Overridden. Defines the resolutions the check scanner device is capable of supporting.
RemainingImagesEstimate | Overridden. Provides a “best guess” estimate of the remaining number of images that can be stored.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from CheckScannerBasic )
ServiceObjectVersion | Gets the Service Object version number. (inherited from CheckScannerBasic )
State | Gets the current state of the device. (inherited from CheckScannerBasic )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )

Protected Properties

Name | Description
CommonProperties | (inherited from CheckScannerBasic )
CropAreas |
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
ErrorCount | (inherited from CheckScannerBasic )
ExternallyClaimed | (inherited from CheckScannerBasic )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Gets the Boolean value that indicates whether the Check Scanner is an exclusive-use device. (inherited from CheckScanner )
Properties | Holds an instance of the CheckScannerProperties helper class, which contains getters and setters for CheckScanner properties.

See Also

Reference

CheckScannerBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


CheckScannerBase.CapAutoContrast Property

CheckScannerBase.CapAutoContrast Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates whether the contrast can be adjusted automatically.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapAutoContrast As Boolean
public override bool CapAutoContrast { get; }
public:
virtual property bool CapAutoContrast {
    bool get () override;
}
/** @property */
public boolean get_CapAutoContrast ()

public override function get CapAutoContrast () : boolean

Remarks

If true, then when Contrast is set to AutomaticContrast, the device attempts to automatically adjust the contrast. The darkness adjustment is based on sensing the paper to produce the optimal brightness for the best image under typical circumstances.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.Contrast Property


CheckScannerBase.CapAutoGenerateFileId Property

CheckScannerBase.CapAutoGenerateFileId Property |
 | See Also

1/18/2008

Indicates whether the check scanner device can automatically create a file name for the captured image file.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapAutoGenerateFileId As Boolean
public override bool CapAutoGenerateFileId { get; }
public:
virtual property bool CapAutoGenerateFileId {
    bool get () override;
}
/** @property */
public boolean get_CapAutoGenerateFileId ()

public override function get CapAutoGenerateFileId () : boolean

Remarks

The CheckScannerBase class verifies that the check scanner device has been opened, and then retrieves the value of CheckScannerProperties.CapAutoGenerateFileId.

CapAutoGenerateFileId is initialized to false by CheckScannerProperties class. The service object should update CapAutoGenerateFileId in its Open method, based on the capability of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.CapAutoGenerateFileId Property


CheckScannerBase.CapAutoGenerateImageTagData Property

CheckScannerBase.CapAutoGenerateImageTagData Property |
 | See Also

1/18/2008

Indicates whether the check scanner device can automatically generate tag data used in reference to the image file for the captured image.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapAutoGenerateImageTagData As Boolean
public override bool CapAutoGenerateImageTagData { get; }
public:
virtual property bool CapAutoGenerateImageTagData {
    bool get () override;
}
/** @property */
public boolean get_CapAutoGenerateImageTagData ()

public override function get CapAutoGenerateImageTagData () : boolean

Remarks

The CheckScannerBase class verifies that the check scanner device has been opened, then retrieves the value of CheckScannerProperties.CapAutoGenerateImageTagData.

CapAutoGenerateImageTagData is initialized to false by CheckScannerProperties class. The service object should update CapAutoGenerateImageTagData in its Open method, based on the capability of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.CapAutoGenerateImageTagData Property


CheckScannerBase.CapAutoSize Property

CheckScannerBase.CapAutoSize Property |
 | See Also

1/18/2008

Indicates whether the height and width of the scanned document will be automatically placed in the DocumentHeight and DocumentWidth properties when the image is captured.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapAutoSize As Boolean
public override bool CapAutoSize { get; }
public:
virtual property bool CapAutoSize {
    bool get () override;
}
/** @property */
public boolean get_CapAutoSize ()

public override function get CapAutoSize () : boolean

Remarks

The CheckScannerBase class verifies that the check scanner device has been opened, and then retrieves the value of CheckScannerProperties.CapAutoSize.

CapAutoSize is initialized to true by CheckScannerProperties class. The service object should update CapAutoSize in its Open method, based on the capability of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.CapAutoSize Property


CheckScannerBase.CapColor Property

CheckScannerBase.CapColor Property |
 | See Also

1/18/2008

Indicates whether the check scanner device supports image formats other than bi-tonal.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapColor As CheckColors
public override CheckColors CapColor { get; }
public:
virtual property CheckColors CapColor {
    CheckColors get () override;
}
/** @property */
public CheckColors get_CapColor ()

public override function get CapColor () : CheckColors

Remarks

The CheckScannerBase class verifies that the check scanner device has been opened, and then retrieves the value of CheckScannerProperties.CapColor.

CapColor is initialized to CheckColors.Mono by CheckScannerProperties class. The service object should update CapColor in its Open method, based on the capability of the device. If the service object specifies an invalid CheckColors value, the CheckScannerBase class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.CapColor Property
CheckColors Enumeration


CheckScannerBase.CapConcurrentMicr Property

CheckScannerBase.CapConcurrentMicr Property |
 | See Also

1/18/2008

Indicates whether a check’s MICR (Magnetic Ink Character Recognition) data can be captured during a check scanning cycle (single-pass scanning).

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapConcurrentMicr As Boolean
public override bool CapConcurrentMicr { get; }
public:
virtual property bool CapConcurrentMicr {
    bool get () override;
}
/** @property */
public boolean get_CapConcurrentMicr ()

public override function get CapConcurrentMicr () : boolean

Remarks

The CheckScannerBase class verifies that the check scanner device has been opened, then retrieves the value of CheckScannerProperties.CapConcurrentMicr.

CapConcurrentMicr is initialized to false by CheckScannerProperties class. The service object should update CapConcurrentMicr in its Open method, based on the capability of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.CapConcurrentMicr Property


CheckScannerBase.CapContrast Property

CheckScannerBase.CapContrast Property |
 | See Also

1/18/2008

Gets the Boolean value that indicates the ability of the device to lighten or darken the scanned image.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapContrast As Boolean
public override bool CapContrast { get; }
public:
virtual property bool CapContrast {
    bool get () override;
}
/** @property */
public boolean get_CapContrast ()

public override function get CapContrast () : boolean

Remarks

This affects the image regardless of the value of the CapColor property.

If true, the darkness of the image can be adjusted by using the Contrast property. If false, the application cannot adjust the darkness of the image.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


CheckScannerBase.CapDefineCropArea Property

CheckScannerBase.CapDefineCropArea Property |
 | See Also

1/18/2008

Indicates whether the check scanner device supports a feature that allows cropping of areas of interest within the scan image area defined by the DocumentHeight and DocumentWidth properties.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapDefineCropArea As Boolean
public override bool CapDefineCropArea { get; }
public:
virtual property bool CapDefineCropArea {
    bool get () override;
}
/** @property */
public boolean get_CapDefineCropArea ()

public override function get CapDefineCropArea () : boolean

Remarks

The CheckScannerBase class verifies that the check scanner device has been opened, then retrieves the value of CheckScannerProperties.CapDefineCropArea.

CapDefineCropArea is initialized to true by CheckScannerProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.CapDefineCropArea Property


CheckScannerBase.CapImageFormat Property

CheckScannerBase.CapImageFormat Property |
 | See Also

1/18/2008

Indicates which image file formats are supported by the check scanner device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapImageFormat As CheckImageFormats
public override CheckImageFormats CapImageFormat { get; }
public:
virtual property CheckImageFormats CapImageFormat {
    CheckImageFormats get () override;
}
/** @property */
public CheckImageFormats get_CapImageFormat ()

public override function get CapImageFormat () : CheckImageFormats

Remarks

The CheckScannerBase class verifies that the check scanner device has been opened, then retrieves the value of CheckScannerProperties.CapImageFormat.

CapImageFormat is initialized to CheckImageFormats.Tiff by CheckScannerProperties class. The service object should update CapImageFormat in its Open method, based on the capability of the device. If the service object specifies an invalid CheckImageFormats value, the CheckScannerBase class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.CapImageFormat Property
CheckImageFormats Enumeration


CheckScannerBase.CapImageTagData Property

CheckScannerBase.CapImageTagData Property |
 | See Also

1/18/2008

Indicates whether the check scanner device can set tag data, as defined by the ImageTagData property, to the image data file stored in the ImageData property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapImageTagData As Boolean
public override bool CapImageTagData { get; }
public:
virtual property bool CapImageTagData {
    bool get () override;
}
/** @property */
public boolean get_CapImageTagData ()

public override function get CapImageTagData () : boolean

Remarks

The CheckScannerBase class verifies that the check scanner device has been opened, and then retrieves the value of CheckScannerProperties.CapImageTagData.

CapImageTagData is initialized to false by CheckScannerProperties class. The service object should update CapImageTagData in its Open method, based on the capability of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.CapImageTagData Property


CheckScannerBase.CapMicrDevice Property

CheckScannerBase.CapMicrDevice Property |
 | See Also

1/18/2008

Indicates whether the check scanner device supports a check MICR read function.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapMicrDevice As Boolean
public override bool CapMicrDevice { get; }
public:
virtual property bool CapMicrDevice {
    bool get () override;
}
/** @property */
public boolean get_CapMicrDevice ()

public override function get CapMicrDevice () : boolean

Remarks

The CheckScannerBase class verifies that the check scanner device has been opened, and then retrieves the value of CheckScannerProperties.CapMicrDevice.

CapMicrDevice is initialized to false by CheckScannerProperties class. The service object should update CapMicrDevice in its Open method, based on the capability of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.CapMicrDevice Property


CheckScannerBase.CapStoreImageFiles Property

CheckScannerBase.CapStoreImageFiles Property |
 | See Also

1/18/2008

Indicates whether the check scanner device can store check images in its hardware memory by using the StoreImage method.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapStoreImageFiles As Boolean
public override bool CapStoreImageFiles { get; }
public:
virtual property bool CapStoreImageFiles {
    bool get () override;
}
/** @property */
public boolean get_CapStoreImageFiles ()

public override function get CapStoreImageFiles () : boolean

Remarks

The CheckScannerBase class verifies that the check scanner device has been opened, and then retrieves the value of CheckScannerProperties.CapStoreImageFiles.

CapStoreImageFiles is initialized to false by CheckScannerProperties class. The service object should update CapStoreImageFiles in its Open method, based on the capability of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.CapStoreImageFiles Property


CheckScannerBase.CapValidationDevice Property

CheckScannerBase.CapValidationDevice Property |
 | See Also

1/18/2008

Indicates that a check doesn’t have to be removed from the check scanner device prior to performing validation printing.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapValidationDevice As Boolean
public override bool CapValidationDevice { get; }
public:
virtual property bool CapValidationDevice {
    bool get () override;
}
/** @property */
public boolean get_CapValidationDevice ()

public override function get CapValidationDevice () : boolean

Remarks

The CheckScannerBase class verifies that the check scanner device has been opened, and then retrieves the value of CheckScannerProperties.CapValidationDevice.

CapValidationDevice is initialized to false by CheckScannerProperties class. The service object should update CapValidationDevice in its Open method, based on the capability of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.CapValidationDevice Property


CheckScannerBase.Color Property

CheckScannerBase.Color Property |
 | See Also

1/18/2008

Specifies the image scan mode for subsequent document scan operations.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property Color As CheckColors
public override CheckColors Color { get; set; }
public:
virtual property CheckColors Color {
    CheckColors get () override;
    void set (CheckColors value) override;
}
/** @property */
public CheckColors get_Color ()

/** @property */
public void set_Color (CheckColors value)

public override function get Color () : CheckColors

public override function set Color (value : CheckColors)

Remarks

The CheckScannerBase class verifies that the check scanner device has been opened, and then retrieves the value of CheckScannerProperties.Color.

Color is initialized to CheckColors.Mono by CheckScannerProperties class. The service object should then set the default Color in its Open method, based on the capability of the device. If the service object specifies an invalid CheckColors value, the CheckScannerBase class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.Color Property
CheckColors Enumeration


CheckScannerBase.ConcurrentMicr Property

CheckScannerBase.ConcurrentMicr Property |
 | See Also

1/18/2008

Indicates whether the check scanner device can conduct a MICR read during a check-scanning cycle.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property ConcurrentMicr As Boolean
public override bool ConcurrentMicr { get; set; }
public:
virtual property bool ConcurrentMicr {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_ConcurrentMicr ()

/** @property */
public void set_ConcurrentMicr (boolean value)

public override function get ConcurrentMicr () : boolean

public override function set ConcurrentMicr (value : boolean)

Remarks

The CheckScannerBase class verifies that the check scanner device has been opened, then retrieves or sets the value of CheckScannerProperties.ConcurrentMicr.

ConcurrentMicr is initialized to false by the CheckScannerProperties class in the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.CapConcurrentMicr Property


CheckScannerBase.Contrast Property

CheckScannerBase.Contrast Property |
 | See Also

1/18/2008

Gets or sets the contrast to adjust the darkness of the image.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property Contrast As Integer
public override int Contrast { get; set; }
public:
virtual property int Contrast {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_Contrast ()

/** @property */
public void set_Contrast (int value)

public override function get Contrast () : int

public override function set Contrast (value : int)

Remarks

Contrast is valid only if the CapContrast property is true.

A value of 0 sets or indicates that the device generates the lightest image possible. A value of 100 sets or indicates that the device generates the darkest image possible. All values between 0 and 100 produce images with varying degrees of darkness. A value of 50 should produce an image that is the optimal brightness for the best image under typical circumstances.

If the CapAutoContrast property is true then Contrast can be set to AutomaticContrast to allow the device to automatically adjust the darkness of the image based on sensing of the paper to produce the optimal brightness for the best image under usual circumstances.

If CapAutoContrast is false, trying to set this property to AutomaticConstrast is illegal.

If CapAutoContrast is true, Contrast is initialized to AutomaticContrast when the device is enabled. If CapAutoContrast is false, Contrast is initialized either to 50 or to a user-configured value when the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.CapAutoContrast Property
CheckScanner.CapContrast Property
CheckScanner.AutomaticContrast Field


CheckScannerBase.CropAreaCount Property

CheckScannerBase.CropAreaCount Property |
 | See Also

1/18/2008

Holds the number of defined crop areas that may be applied to the captured image.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CropAreaCount As Integer
public override int CropAreaCount { get; }
public:
virtual property int CropAreaCount {
    int get () override;
}
/** @property */
public int get_CropAreaCount ()

public override function get CropAreaCount () : int

Remarks

The CheckScannerBase class verifies that the check scanner device has been opened, then retrieves the current CheckScannerBase crop area count.

CropAreaCount is initialized to 0 (zero) by the CheckScannerBase class in the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.CropAreaCount Property


CheckScannerBase.CropAreas Property

CheckScannerBase.CropAreas Property |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected ReadOnly Property CropAreas As Hashtable

protected Hashtable CropAreas { get; }

protected:
property Hashtable^ CropAreas {
    Hashtable^ get ();
}

/** @property */
protected Hashtable get_CropAreas ()

protected function get CropAreas () : Hashtable

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


CheckScannerBase.DeviceEnabled Property

CheckScannerBase.DeviceEnabled Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether the device has been placed in an operational state.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property DeviceEnabled As Boolean
public override bool DeviceEnabled { get; set; }
public:
virtual property bool DeviceEnabled {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_DeviceEnabled ()

/** @property */
public void set_DeviceEnabled (boolean value)

public override function get DeviceEnabled () : boolean

public override function set DeviceEnabled (value : boolean)

Remarks

When true, the device has been put in an operational state. If changed to true, then the device is brought to an operational state. The appropriate device statistics and device information will be loaded, if it is necessary. Exclusive-use devices must be opened and claimed before this property can be accessed. Shared devices must be opened before this property can be accessed.

When false, the device has been disabled. If changed to false, then the device is physically disabled when it is possible. Any later input is discarded, and output operations are disallowed.

Changing DeviceEnabled usually does not physically affect output devices. However, for consistency, the application must set DeviceEnabled to true before it uses output devices.

DeviceEnabled is initialized to false. State verification occurs in the basic and base classes for each device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


CheckScannerBase.DocumentHeight Property

CheckScannerBase.DocumentHeight Property |
 | See Also

1/18/2008

Holds the height of the document scanned, or the height of the document to be scanned.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property DocumentHeight As Integer
public override int DocumentHeight { get; set; }
public:
virtual property int DocumentHeight {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_DocumentHeight ()

/** @property */
public void set_DocumentHeight (int value)

public override function get DocumentHeight () : int

public override function set DocumentHeight (value : int)

Remarks

The CheckScannerBase class verifies that the check scanner device has been opened, then retrieves or sets the value of CheckScannerProperties.DocumentHeight.

DocumentHeight is initialized to 0 (zero) by the CheckScannerProperties class. The service object should update DocumentHeight in its Open method, based on the capability of the device. If the service object specifies a value less than zero for DocumentHeight, the CheckScannerBase class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.DocumentHeight Property


CheckScannerBase.DocumentWidth Property

CheckScannerBase.DocumentWidth Property |
 | See Also

1/18/2008

Holds the width of the document scanned, or the width of the document to be scanned.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property DocumentWidth As Integer
public override int DocumentWidth { get; set; }
public:
virtual property int DocumentWidth {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_DocumentWidth ()

/** @property */
public void set_DocumentWidth (int value)

public override function get DocumentWidth () : int

public override function set DocumentWidth (value : int)

Remarks

The CheckScannerBase class verifies that the check scanner device has been opened, then retrieves or sets the value of CheckScannerProperties.DocumentWidth.

DocumentWidth is initialized to 0 (zero) by the CheckScannerProperties class. The service object should update DocumentWidth in its Open method, based on the capability of the device. If the service object specifies a value less than zero for DocumentWidth, the CheckScannerBase class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.DocumentWidth Property


CheckScannerBase.FileId Property

CheckScannerBase.FileId Property |
 | See Also

1/18/2008

Holds the file name associated with the image data file.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property FileId As String
public override string FileId { get; set; }
public:
virtual property String^ FileId {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_FileId ()

/** @property */
public void set_FileId (String value)

public override function get FileId () : String

public override function set FileId (value : String)

Remarks

The CheckScannerBase class verifies that the check scanner device has been opened, then retrieves or sets the value of CheckScannerProperties.FileId. If an attempt is made to set FileId to Null, the CheckScannerBase class sets it to an empty string ("").

FileId is initialized to an empty string ("") by CheckScannerProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.FileId Property


CheckScannerBase.FileIndex Property

CheckScannerBase.FileIndex Property |
 | See Also

1/18/2008

Holds the file location associated with the image data file when either the StoreImage or RetrieveMemory methods are called. Its value is set prior to a DataEvent event being delivered to the application.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property FileIndex As Integer
public override int FileIndex { get; set; }
public:
virtual property int FileIndex {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_FileIndex ()

/** @property */
public void set_FileIndex (int value)

public override function get FileIndex () : int

public override function set FileIndex (value : int)

Remarks

The CheckScannerBase class verifies that the check scanner device has been opened, then retrieves or sets the value of CheckScannerProperties.FileIndex.

FileIndex is initialized to 0 (zero) by the CheckScannerProperties class. If the service object specifies a value less than zero for FileIndex, the CheckScannerBase class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.FileIndex Property


CheckScannerBase.ImageData Property

CheckScannerBase.ImageData Property |
 | See Also

1/18/2008

Holds the image data after the RetrieveImage or RetrieveMemory methods are called.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property ImageData As Bitmap
public override Bitmap ImageData { get; }
public:
virtual property Bitmap^ ImageData {
    Bitmap^ get () override;
}
/** @property */
public Bitmap get_ImageData ()

public override function get ImageData () : Bitmap

Remarks

The CheckScannerBase class verifies that the check scanner device has been opened, then retrieves or sets the value of CheckScannerProperties.ImageData.

ImageData is initialized to null by the CheckScannerBase class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.ImageData Property


CheckScannerBase.ImageFormat Property

CheckScannerBase.ImageFormat Property |
 | See Also

1/18/2008

Holds the data format of the image file that the device will use when it captures an image.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property ImageFormat As CheckImageFormats
public override CheckImageFormats ImageFormat { get; set; }
public:
virtual property CheckImageFormats ImageFormat {
    CheckImageFormats get () override;
    void set (CheckImageFormats value) override;
}
/** @property */
public CheckImageFormats get_ImageFormat ()

/** @property */
public void set_ImageFormat (CheckImageFormats value)

public override function get ImageFormat () : CheckImageFormats

public override function set ImageFormat (value : CheckImageFormats)

Remarks

The CheckScannerBase class verifies that the check scanner device has been opened, then retrieves or sets the value of CheckScannerProperties.ImageFormat. If ImageFormat is set to an invalid CheckImageFormats value, or to a value that differs from the setting of the CapImageFormat property, the CheckScannerBase class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal.

ImageFormat is initialized to CheckImageFormats.Tiff by CheckScannerProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.CapImageFormat Property
CheckScanner.ImageFormat Property
CheckImageFormats Enumeration


CheckScannerBase.ImageMemoryStatus Property

CheckScannerBase.ImageMemoryStatus Property |
 | See Also

1/18/2008

Indicates the current memory availability status if the device has the ability to store multiple image files.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property ImageMemoryStatus As ImageMemoryStatus
public override ImageMemoryStatus ImageMemoryStatus { get; }
public:
virtual property ImageMemoryStatus ImageMemoryStatus {
    ImageMemoryStatus get () override;
}
/** @property */
public ImageMemoryStatus get_ImageMemoryStatus ()

public override function get ImageMemoryStatus () : ImageMemoryStatus

Remarks

The CheckScannerBase class verifies that the check scanner device has been opened, then retrieves or sets the value of CheckScannerProperties.ImageMemoryStatus. If the CapStoreImageFiles property is set to false and the service object attempts to set ImageMemoryStatus to a value other than ImageMemoryStatus.Empty, the CheckScannerBase class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal. Otherwise, if the service object sets ImageMemoryStatus to an invalid ImageMemoryStatus enumeration value, the CheckScannerBase class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal.

ImageMemoryStatus is initialized to ImageMemoryStatus.Empty. The service object should then update ImageMemoryStatus in its Open method, based on the current memory availability, and keep the property current while the device is claimed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.CapStoreImageFiles Property
CheckScanner.ImageMemoryStatus Property
ImageMemoryStatus Enumeration


CheckScannerBase.ImageTagData Property

CheckScannerBase.ImageTagData Property |
 | See Also

1/18/2008

Holds a string that specifies the tag name for the captured image data. The string may be specified by the application or automatically generated by the check scanner device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property ImageTagData As String
public override string ImageTagData { get; set; }
public:
virtual property String^ ImageTagData {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_ImageTagData ()

/** @property */
public void set_ImageTagData (String value)

public override function get ImageTagData () : String

public override function set ImageTagData (value : String)

Remarks

The CheckScannerBase class verifies that the check scanner device has been opened, then retrieves or sets the value of CheckScannerProperties.ImageTagData. If an attempt is made to set ImageTagData to Null, the CheckScannerBase class sets it to an empty string ("").

ImageTagData is initialized to an empty string ("") by the CheckScannerProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.ImageTagData Property


CheckScannerBase.MapMode Property

CheckScannerBase.MapMode Property |
 | See Also

1/18/2008

Holds the mapping mode of the printer the application wants to use.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property MapMode As MapMode
public override MapMode MapMode { get; set; }
public:
virtual property MapMode MapMode {
    MapMode get () override;
    void set (MapMode value) override;
}
/** @property */
public MapMode get_MapMode ()

/** @property */
public void set_MapMode (MapMode value)

public override function get MapMode () : MapMode

public override function set MapMode (value : MapMode)

Remarks

The CheckScannerBase class verifies that the check scanner device has been opened, then retrieves or sets the value of CheckScannerProperties.MapMode. If an attempt is made to set MapMode to an invalid MapMode enumeration value, the CheckScannerBase class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal.

MapMode is initialized to MapMode.English by the CheckScannerProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.MapMode Property


CheckScannerBase.MaxCropAreas Property

CheckScannerBase.MaxCropAreas Property |
 | See Also

1/18/2008

Specifies the maximum number of crop areas the device can support.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property MaxCropAreas As Integer
public override int MaxCropAreas { get; }
public:
virtual property int MaxCropAreas {
    int get () override;
}
/** @property */
public int get_MaxCropAreas ()

public override function get MaxCropAreas () : int

Remarks

The CheckScannerBase class verifies that the check scanner device has been opened, then retrieves or sets the value of CheckScannerProperties.MaxCropAreas.

MaxCropAreas is initialized to 1000 by the CheckScannerProperties class. If the service object attempts to set MaxCropAreas to a value less than 0 (zero), the CheckScannerBase class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.MaxCropAreas Property


CheckScannerBase.Properties Property

CheckScannerBase.Properties Property |
 | See Also

1/18/2008

Holds an instance of the CheckScannerProperties helper class, which contains getters and setters for CheckScanner properties.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected ReadOnly Property Properties As CheckScannerProperties
protected CheckScannerProperties Properties { get; }
protected:
property CheckScannerProperties^ Properties {
    CheckScannerProperties^ get ();
}
/** @property */
protected CheckScannerProperties get_Properties ()

protected function get Properties () : CheckScannerProperties

Remarks

Returns an instance of the CheckScannerProperties helper class, containing getters and setters for CheckScanner properties. Service objects should use CheckScannerProperties class to set properties that are typically designated read-only for applications. The device doesn't have to be opened, claimed, or enabled to set CheckScannerProperties class properties.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


CheckScannerBase.Quality Property

CheckScannerBase.Quality Property |
 | See Also

1/18/2008

Sets the resolution of the device when a scan image is to take place. The resolution value is defined as dpi (dots per inch).

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property Quality As Integer
public override int Quality { get; set; }
public:
virtual property int Quality {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_Quality ()

/** @property */
public void set_Quality (int value)

public override function get Quality () : int

public override function set Quality (value : int)

Remarks

The CheckScannerBase class verifies that the check scanner device has been opened, then retrieves or sets the value of CheckScannerProperties.Quality. If the QualityList property is empty and an attempt is made to set Quality, the CheckScannerBase class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal. If an attempt is made to set Quality to a value not present in the QualityList property, the CheckScannerBase class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal.

Quality is initialized to 0 (zero) by the CheckScannerProperties class. The service object should then update Quality in its Open method to an appropriate value.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.Quality Property


CheckScannerBase.QualityList Property

CheckScannerBase.QualityList Property |
 | See Also

1/18/2008

Defines the resolutions the check scanner device is capable of supporting.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property QualityList As Integer()
public override int[] QualityList { get; }
public:
virtual property array<int>^ QualityList {
    array<int>^ get () override;
}
/** @property */
public int[] get_QualityList ()

public override function get QualityList () : int[]

Remarks

The CheckScannerBase class verifies that the check scanner device has been opened, then retrieves or sets the value of CheckScannerProperties.QualityList. If an attempt is made to set QualityList to Null, the CheckScannerBase class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal. If an attempt is made to include in QualityList one or more values that are less than 0 (zero), the CheckScannerBase class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal.

QualityList is initialized to an empty integer array by the CheckScannerProperties class. The service object should then update QualityList in its Open method to an array of appropriate values.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.QualityList Property


CheckScannerBase.RemainingImagesEstimate Property

CheckScannerBase.RemainingImagesEstimate Property |
 | See Also

1/18/2008

Provides a “best guess” estimate of the remaining number of images that can be stored.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property RemainingImagesEstimate As Integer
public override int RemainingImagesEstimate { get; }
public:
virtual property int RemainingImagesEstimate {
    int get () override;
}
/** @property */
public int get_RemainingImagesEstimate ()

public override function get RemainingImagesEstimate () : int

Remarks

The CheckScannerBase class verifies that the check scanner device has been opened, then retrieves or sets the value of CheckScannerProperties.RemainingImagesEstimate. If an attempt is made to set RemainingImagesEstimate to a value less than 0 (zero), the CheckScannerBase class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal.

RemainingImagesEstimate is initialized to 0 (zero) by the CheckScannerProperties class. If the check scanner device supports the storage of images (that is, if CapStoreImageFiles has been set to TRUE), the service object should update and maintain RemainingImagesEstimate to a "best guess" estimate of the number of remaining images that can be stored by the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerBase Class
CheckScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScanner.RemainingImagesEstimate Property


CheckScannerBase Events

CheckScannerBase Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DataEvent | Raised to notify the application that a scanned check image is available. (inherited from CheckScannerBasic )
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from CheckScannerBasic )
ErrorEvent | Raised to indicate an error has been detected while trying to read keyboard device input data. (inherited from CheckScannerBasic )
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from CheckScannerBasic )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
StateChangedEvent | (inherited from CheckScannerBasic )

See Also

Reference

CheckScannerBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


CheckScannerImage Class

CheckScannerImage Class |
 | See Also Members

1/18/2008

A helper class created by POS for .NET to simplify the retrieval of scanned images and setting of properties.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class CheckScannerImage
public class CheckScannerImage
public ref class CheckScannerImage
public class CheckScannerImage
public class CheckScannerImage

Remarks

CheckScannerImage is a helper class created by POS for .NET to simplify the retrieval of scanned images and setting of properties. The service object should use this class when it overrides ClearImageImpl, StoreImageImpl, and RetrieveMemoryImpl (required if the CapStoreImageFiles property is set to true). RetrieveMemoryImpl returns a CheckScannerImage class. The service object should populate the properties of CheckScannerImage with the image found in device memory. The values of FileId, FileIndex, and ImageTagData should also be updated. The base class will then use the class data to update the corresponding properties in the base class.

Properties

Name | Type | Initialized by base class to…
ImageData | Bitmap |
UpdateProps | Boolean | TRUE
FileID | String | Blank
FileIndex | Integer | 0 (zero)
ImageTagData | String | Blank

Constructor

Name

CheckScannerImage(Bitmap imageData, string fileID, int fileIndex, string imageTagData)

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BaseServiceObjects.CheckScannerImage

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerImage Members
Microsoft.PointOfService.BaseServiceObjects Namespace


CheckScannerImage Members

CheckScannerImage Members |
 | See Also Constructors Methods Properties

1/18/2008

A helper class created by POS for .NET to simplify the retrieval of scanned images and setting of properties.

The following tables list the members exposed by the CheckScannerImage type.

Public Constructors

Name | Description
CheckScannerImage | Creates an instance of the CheckScannerImage class with the specified image data, file ID, file index, and image tag data.
Top

Public Properties

Name | Description
FileId | Holds the file name associated with the image data file.
FileIndex | Holds the file location associated with the image data file.
ImageData | Holds the image data.
ImageTagData | Holds a string that specifies the tag name for the captured image data.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

CheckScannerImage Class
Microsoft.PointOfService.BaseServiceObjects Namespace


CheckScannerImage Constructor

CheckScannerImage Constructor |
 | See Also

1/18/2008

Creates an instance of the CheckScannerImage class with the specified image data, file ID, file index, and image tag data.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub New ( _
    imageData As Bitmap, _
    fileId As String, _
    fileIndex As Integer, _
    imageTagData As String _
)
public CheckScannerImage (
    Bitmap imageData,
    string fileId,
    int fileIndex,
    string imageTagData
)
public:
CheckScannerImage (
    Bitmap^ imageData,
    String^ fileId,
    int fileIndex,
    String^ imageTagData
)
public CheckScannerImage (
    Bitmap imageData,
    String fileId,
    int fileIndex,
    String imageTagData
)
public function CheckScannerImage (
    imageData : Bitmap,
    fileId : String,
    fileIndex : int,
    imageTagData : String
)

Parameters

imageData

Holds the image data

fileId

Holds the file name associated with the image data file.

fileIndex

Holds the file location associated with the image data file.

imageTagData

Holds a string that specifies the tag name for the captured image data.

Remarks

Creates an instance of the CheckScannerImage class and initializes its properties. The CheckScannerBase.RetrieveMemoryImpl protected method uses an instance of the CheckScannerImage class to return an image retrieved from memory to the application.

See Also

Reference

CheckScannerImage Class
CheckScannerImage Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.RetrieveMemoryImpl Method


CheckScannerImage Methods

CheckScannerImage Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

CheckScannerImage Class
Microsoft.PointOfService.BaseServiceObjects Namespace


CheckScannerImage Properties

CheckScannerImage Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
FileId | Holds the file name associated with the image data file.
FileIndex | Holds the file location associated with the image data file.
ImageData | Holds the image data.
ImageTagData | Holds a string that specifies the tag name for the captured image data.

See Also

Reference

CheckScannerImage Class
Microsoft.PointOfService.BaseServiceObjects Namespace


CheckScannerImage.FileId Property

CheckScannerImage.FileId Property |
 | See Also

1/18/2008

Holds the file name associated with the image data file.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property FileId As String
public string FileId { get; }
public:
property String^ FileId {
    String^ get ();
}
/** @property */
public String get_FileId ()

public function get FileId () : String

Remarks

FileID is initialized to blank by the CheckScannerImage class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerImage Class
CheckScannerImage Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.FileId Property


CheckScannerImage.FileIndex Property

CheckScannerImage.FileIndex Property |
 | See Also

1/18/2008

Holds the file location associated with the image data file.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property FileIndex As Integer
public int FileIndex { get; }
public:
property int FileIndex {
    int get ();
}
/** @property */
public int get_FileIndex ()

public function get FileIndex () : int

Remarks

FileIndex is initialized to 0 (zero) by the CheckScannerImage class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerImage Class
CheckScannerImage Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.FileIndex Property


CheckScannerImage.ImageData Property

CheckScannerImage.ImageData Property |
 | See Also

1/18/2008

Holds the image data.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property ImageData As Bitmap
public Bitmap ImageData { get; }
public:
property Bitmap^ ImageData {
    Bitmap^ get ();
}
/** @property */
public Bitmap get_ImageData ()

public function get ImageData () : Bitmap

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerImage Class
CheckScannerImage Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.ImageData Property


CheckScannerImage.ImageTagData Property

CheckScannerImage.ImageTagData Property |
 | See Also

1/18/2008

Holds a string that specifies the tag name for the captured image data.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property ImageTagData As String
public string ImageTagData { get; }
public:
property String^ ImageTagData {
    String^ get ();
}
/** @property */
public String get_ImageTagData ()

public function get ImageTagData () : String

Remarks

ImageTagData is initialized to blank by the CheckScannerImage class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerImage Class
CheckScannerImage Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.ImageTagData Property


CheckScannerProperties Class

CheckScannerProperties Class |
 | See Also Members

1/18/2008

A helper class created by POS for .NET to simplify the retrieval and setting of property values for check scanner devices.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class CheckScannerProperties
    Inherits CommonProperties
public class CheckScannerProperties : CommonProperties
public ref class CheckScannerProperties : public CommonProperties
public class CheckScannerProperties extends CommonProperties
public class CheckScannerProperties extends CommonProperties

Remarks

CheckScannerProperties is a helper class created by POS for .NET to simplify the retrieval and setting of property values for check scanner devices. CheckScannerProperties inherits from the CommonProperties class. The protected Properties property of CheckScannerBase class returns an instance of CheckScannerProperties. The service object can manage the value of a property using the syntax Properties.<propertyName>. CheckScannerProperties bypasses state validation—in other words, the service object can use CheckScannerProperties to set values for properties even though the application hasn’t opened, claimed, or enabled the check scanner device.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BasicServiceObjects.CommonProperties
Microsoft.PointOfService.BaseServiceObjects.CheckScannerProperties

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


CheckScannerProperties Members

CheckScannerProperties Members |
 | See Also Methods Properties

1/18/2008

A helper class created by POS for .NET to simplify the retrieval and setting of property values for check scanner devices.

The following tables list the members exposed by the CheckScannerProperties type.

Public Properties

Name | Description
CapAutoContrast | If true, then when Contrast is set to AutomaticContrast, the device attempts to automatically adjust the contrast.
CapAutoGenerateFileId | Indicates whether the check scanner device can automatically create a file name for the captured image file.
CapAutoGenerateImageTagData | Indicates whether the check scanner device can automatically generate tag data used in reference to the image file for the captured image.
CapAutoSize | Indicates that the height and width of the scanned document will be automatically placed in the DocumentHeight and DocumentWidth properties when the image is captured.
CapColor | Indicates that the check scanner device supports image formats other than bi-tonal.
CapCompareFirmwareVersion | (inherited from CommonProperties )
CapConcurrentMicr | Indicates whether a check’s MICR (Magnetic Ink Character Recognition) data can be captured during a check scanning cycle (single-pass scanning).
CapContrast | Indicates the ability of the device to lighten or darken the scanned image.
CapDefineCropArea | Indicates whether the check scanner device supports a feature that allows cropping of areas of interest within the scan image area defined by the DocumentHeight and DocumentWidth properties.
CapImageFormat | Indicates whether the check scanner device supports a feature that allows cropping of areas of interest within the scan image area defined by the DocumentHeight and DocumentWidth properties.
CapImageTagData | Indicates that the check scanner device can set tag data, as defined by the ImageTagData property, to the image data file stored in the ImageData property.
CapMicrDevice | Indicates that the check scanner device supports a check MICR read function.
CapPowerReporting | (inherited from CommonProperties )
CapStatisticsReporting | (inherited from CommonProperties )
CapStoreImageFiles | Indicates that the check scanner device can store check images in its hardware memory.
CapUpdateFirmware | (inherited from CommonProperties )
CapUpdateStatistics | (inherited from CommonProperties )
CapValidationDevice | Indicates that a check doesn’t have to be removed from the check scanner device prior to performing validation printing.
Color | Specifies the image scan mode for subsequent document scan operations.
ConcurrentMicr | Indicates whether the check scanner device can conduct a MICR read during a check-scanning cycle.
Contrast | Set by the application to adjust the darkness of the image.
DeviceDescription | (inherited from CommonProperties )
DeviceName | (inherited from CommonProperties )
DocumentHeight | Holds the height of the document scanned, or the height of the document to be scanned.
DocumentWidth | Holds the width of the document scanned, or the width of the document to be scanned.
FileId | Holds the file name associated with the image data file.
FileIndex | Holds the file location associated with the image data file.
ImageData | Holds the image data after the RetrieveImage or RetrieveMemory methods are called.
ImageFormat | Holds the data format of the image file that the device will use when it captures an image.
ImageMemoryStatus | Indicates the current memory availability status if the device has the ability to store multiple image files.
ImageTagData | Holds a string that specifies the tag name for the captured image data. The string may be specified by the application or automatically generated by the check scanner device.
MapMode | Specifies the units of measure that are currently valid for the check scanner device.
MaxCropAreas | Specifies the maximum number of crop areas the device can support.
PowerState | (inherited from CommonProperties )
Quality | Sets the resolution of the device when a scan image is to take place. The resolution value is defined as dpi (dots per inch).
QualityList | Defines the resolutions the check scanner device is capable of supporting.
RemainingImagesEstimate | Provides a “best guess” estimate of the remaining number of images that can be stored.
ServiceObjectDescription | (inherited from CommonProperties )
ServiceObjectVersion | (inherited from CommonProperties )
State | (inherited from CommonProperties )
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

CheckScannerProperties Class
Microsoft.PointOfService.BaseServiceObjects Namespace


CheckScannerProperties Methods

CheckScannerProperties Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

CheckScannerProperties Class
Microsoft.PointOfService.BaseServiceObjects Namespace


CheckScannerProperties Properties

CheckScannerProperties Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
CapAutoContrast | If true, then when Contrast is set to AutomaticContrast, the device attempts to automatically adjust the contrast.
CapAutoGenerateFileId | Indicates whether the check scanner device can automatically create a file name for the captured image file.
CapAutoGenerateImageTagData | Indicates whether the check scanner device can automatically generate tag data used in reference to the image file for the captured image.
CapAutoSize | Indicates that the height and width of the scanned document will be automatically placed in the DocumentHeight and DocumentWidth properties when the image is captured.
CapColor | Indicates that the check scanner device supports image formats other than bi-tonal.
CapCompareFirmwareVersion | (inherited from CommonProperties )
CapConcurrentMicr | Indicates whether a check’s MICR (Magnetic Ink Character Recognition) data can be captured during a check scanning cycle (single-pass scanning).
CapContrast | Indicates the ability of the device to lighten or darken the scanned image.
CapDefineCropArea | Indicates whether the check scanner device supports a feature that allows cropping of areas of interest within the scan image area defined by the DocumentHeight and DocumentWidth properties.
CapImageFormat | Indicates whether the check scanner device supports a feature that allows cropping of areas of interest within the scan image area defined by the DocumentHeight and DocumentWidth properties.
CapImageTagData | Indicates that the check scanner device can set tag data, as defined by the ImageTagData property, to the image data file stored in the ImageData property.
CapMicrDevice | Indicates that the check scanner device supports a check MICR read function.
CapPowerReporting | (inherited from CommonProperties )
CapStatisticsReporting | (inherited from CommonProperties )
CapStoreImageFiles | Indicates that the check scanner device can store check images in its hardware memory.
CapUpdateFirmware | (inherited from CommonProperties )
CapUpdateStatistics | (inherited from CommonProperties )
CapValidationDevice | Indicates that a check doesn’t have to be removed from the check scanner device prior to performing validation printing.
Color | Specifies the image scan mode for subsequent document scan operations.
ConcurrentMicr | Indicates whether the check scanner device can conduct a MICR read during a check-scanning cycle.
Contrast | Set by the application to adjust the darkness of the image.
DeviceDescription | (inherited from CommonProperties )
DeviceName | (inherited from CommonProperties )
DocumentHeight | Holds the height of the document scanned, or the height of the document to be scanned.
DocumentWidth | Holds the width of the document scanned, or the width of the document to be scanned.
FileId | Holds the file name associated with the image data file.
FileIndex | Holds the file location associated with the image data file.
ImageData | Holds the image data after the RetrieveImage or RetrieveMemory methods are called.
ImageFormat | Holds the data format of the image file that the device will use when it captures an image.
ImageMemoryStatus | Indicates the current memory availability status if the device has the ability to store multiple image files.
ImageTagData | Holds a string that specifies the tag name for the captured image data. The string may be specified by the application or automatically generated by the check scanner device.
MapMode | Specifies the units of measure that are currently valid for the check scanner device.
MaxCropAreas | Specifies the maximum number of crop areas the device can support.
PowerState | (inherited from CommonProperties )
Quality | Sets the resolution of the device when a scan image is to take place. The resolution value is defined as dpi (dots per inch).
QualityList | Defines the resolutions the check scanner device is capable of supporting.
RemainingImagesEstimate | Provides a “best guess” estimate of the remaining number of images that can be stored.
ServiceObjectDescription | (inherited from CommonProperties )
ServiceObjectVersion | (inherited from CommonProperties )
State | (inherited from CommonProperties )

See Also

Reference

CheckScannerProperties Class
Microsoft.PointOfService.BaseServiceObjects Namespace


CheckScannerProperties.CapAutoContrast Property

CheckScannerProperties.CapAutoContrast Property |
 | See Also

1/18/2008

If true, then when Contrast is set to AutomaticContrast, the device attempts to automatically adjust the contrast.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapAutoContrast As Boolean
public bool CapAutoContrast { get; set; }
public:
property bool CapAutoContrast {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapAutoContrast ()

/** @property */
public void set_CapAutoContrast (boolean value)

public function get CapAutoContrast () : boolean

public function set CapAutoContrast (value : boolean)

Remarks

The darkness adjustment is based on sensing the paper to produce the optimal brightness for the best image under normal circumstances.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerProperties Class
CheckScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


CheckScannerProperties.CapAutoGenerateFileId Property

CheckScannerProperties.CapAutoGenerateFileId Property |
 | See Also

1/18/2008

Indicates whether the check scanner device can automatically create a file name for the captured image file.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapAutoGenerateFileId As Boolean
public bool CapAutoGenerateFileId { get; set; }
public:
property bool CapAutoGenerateFileId {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapAutoGenerateFileId ()

/** @property */
public void set_CapAutoGenerateFileId (boolean value)

public function get CapAutoGenerateFileId () : boolean

public function set CapAutoGenerateFileId (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerProperties Class
CheckScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.CapAutoGenerateFileId Property


CheckScannerProperties.CapAutoGenerateImageTagData Property

CheckScannerProperties.CapAutoGenerateImageTagData Property |
 | See Also

1/18/2008

Indicates whether the check scanner device can automatically generate tag data used in reference to the image file for the captured image.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapAutoGenerateImageTagData As Boolean
public bool CapAutoGenerateImageTagData { get; set; }
public:
property bool CapAutoGenerateImageTagData {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapAutoGenerateImageTagData ()

/** @property */
public void set_CapAutoGenerateImageTagData (boolean value)

public function get CapAutoGenerateImageTagData () : boolean

public function set CapAutoGenerateImageTagData (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerProperties Class
CheckScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.CapAutoGenerateImageTagData Property


CheckScannerProperties.CapAutoSize Property

CheckScannerProperties.CapAutoSize Property |
 | See Also

1/18/2008

Indicates that the height and width of the scanned document will be automatically placed in the DocumentHeight and DocumentWidth properties when the image is captured.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapAutoSize As Boolean
public bool CapAutoSize { get; set; }
public:
property bool CapAutoSize {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapAutoSize ()

/** @property */
public void set_CapAutoSize (boolean value)

public function get CapAutoSize () : boolean

public function set CapAutoSize (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerProperties Class
CheckScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.CapAutoSize Property


CheckScannerProperties.CapColor Property

CheckScannerProperties.CapColor Property |
 | See Also

1/18/2008

Indicates that the check scanner device supports image formats other than bi-tonal.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapColor As CheckColors
public CheckColors CapColor { get; set; }
public:
property CheckColors CapColor {
    CheckColors get ();
    void set (CheckColors value);
}
/** @property */
public CheckColors get_CapColor ()

/** @property */
public void set_CapColor (CheckColors value)

public function get CapColor () : CheckColors

public function set CapColor (value : CheckColors)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerProperties Class
CheckScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.CapColor Property


CheckScannerProperties.CapConcurrentMicr Property

CheckScannerProperties.CapConcurrentMicr Property |
 | See Also

1/18/2008

Indicates whether a check’s MICR (Magnetic Ink Character Recognition) data can be captured during a check scanning cycle (single-pass scanning).

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapConcurrentMicr As Boolean
public bool CapConcurrentMicr { get; set; }
public:
property bool CapConcurrentMicr {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapConcurrentMicr ()

/** @property */
public void set_CapConcurrentMicr (boolean value)

public function get CapConcurrentMicr () : boolean

public function set CapConcurrentMicr (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerProperties Class
CheckScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.CapConcurrentMicr Property


CheckScannerProperties.CapContrast Property

CheckScannerProperties.CapContrast Property |
 | See Also

1/18/2008

Indicates the ability of the device to lighten or darken the scanned image.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapContrast As Boolean
public bool CapContrast { get; set; }
public:
property bool CapContrast {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapContrast ()

/** @property */
public void set_CapContrast (boolean value)

public function get CapContrast () : boolean

public function set CapContrast (value : boolean)

Remarks

This affects the image regardless of the value of the CapColor property.

If true then the darkness of the image can be adjusted using the Contrast property. If false then the application cannot adjust the darkness of the image.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerProperties Class
CheckScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


CheckScannerProperties.CapDefineCropArea Property

CheckScannerProperties.CapDefineCropArea Property |
 | See Also

1/18/2008

Indicates whether the check scanner device supports a feature that allows cropping of areas of interest within the scan image area defined by the DocumentHeight and DocumentWidth properties.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapDefineCropArea As Boolean
public bool CapDefineCropArea { get; set; }
public:
property bool CapDefineCropArea {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapDefineCropArea ()

/** @property */
public void set_CapDefineCropArea (boolean value)

public function get CapDefineCropArea () : boolean

public function set CapDefineCropArea (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerProperties Class
CheckScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.CapDefineCropArea Property


CheckScannerProperties.CapImageFormat Property

CheckScannerProperties.CapImageFormat Property |
 | See Also

1/18/2008

Indicates whether the check scanner device supports a feature that allows cropping of areas of interest within the scan image area defined by the DocumentHeight and DocumentWidth properties.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapImageFormat As CheckImageFormats
public CheckImageFormats CapImageFormat { get; set; }
public:
property CheckImageFormats CapImageFormat {
    CheckImageFormats get ();
    void set (CheckImageFormats value);
}
/** @property */
public CheckImageFormats get_CapImageFormat ()

/** @property */
public void set_CapImageFormat (CheckImageFormats value)

public function get CapImageFormat () : CheckImageFormats

public function set CapImageFormat (value : CheckImageFormats)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerProperties Class
CheckScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.CapImageFormat Property


CheckScannerProperties.CapImageTagData Property

CheckScannerProperties.CapImageTagData Property |
 | See Also

1/18/2008

Indicates that the check scanner device can set tag data, as defined by the ImageTagData property, to the image data file stored in the ImageData property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapImageTagData As Boolean
public bool CapImageTagData { get; set; }
public:
property bool CapImageTagData {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapImageTagData ()

/** @property */
public void set_CapImageTagData (boolean value)

public function get CapImageTagData () : boolean

public function set CapImageTagData (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerProperties Class
CheckScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.CapImageTagData Property


CheckScannerProperties.CapMicrDevice Property

CheckScannerProperties.CapMicrDevice Property |
 | See Also

1/18/2008

Indicates that the check scanner device supports a check MICR read function.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapMicrDevice As Boolean
public bool CapMicrDevice { get; set; }
public:
property bool CapMicrDevice {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapMicrDevice ()

/** @property */
public void set_CapMicrDevice (boolean value)

public function get CapMicrDevice () : boolean

public function set CapMicrDevice (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerProperties Class
CheckScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.CapMicrDevice Property


CheckScannerProperties.CapStoreImageFiles Property

CheckScannerProperties.CapStoreImageFiles Property |
 | See Also

1/18/2008

Indicates that the check scanner device can store check images in its hardware memory.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapStoreImageFiles As Boolean
public bool CapStoreImageFiles { get; set; }
public:
property bool CapStoreImageFiles {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapStoreImageFiles ()

/** @property */
public void set_CapStoreImageFiles (boolean value)

public function get CapStoreImageFiles () : boolean

public function set CapStoreImageFiles (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerProperties Class
CheckScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CapStorImageFiles


CheckScannerProperties.CapValidationDevice Property

CheckScannerProperties.CapValidationDevice Property |
 | See Also

1/18/2008

Indicates that a check doesn’t have to be removed from the check scanner device prior to performing validation printing.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapValidationDevice As Boolean
public bool CapValidationDevice { get; set; }
public:
property bool CapValidationDevice {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapValidationDevice ()

/** @property */
public void set_CapValidationDevice (boolean value)

public function get CapValidationDevice () : boolean

public function set CapValidationDevice (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerProperties Class
CheckScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.CapValidationDevice Property


CheckScannerProperties.Color Property

CheckScannerProperties.Color Property |
 | See Also

1/18/2008

Specifies the image scan mode for subsequent document scan operations.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Color As CheckColors
public CheckColors Color { get; set; }
public:
property CheckColors Color {
    CheckColors get ();
    void set (CheckColors value);
}
/** @property */
public CheckColors get_Color ()

/** @property */
public void set_Color (CheckColors value)

public function get Color () : CheckColors

public function set Color (value : CheckColors)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerProperties Class
CheckScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.Color Property


CheckScannerProperties.ConcurrentMicr Property

CheckScannerProperties.ConcurrentMicr Property |
 | See Also

1/18/2008

Indicates whether the check scanner device can conduct a MICR read during a check-scanning cycle.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property ConcurrentMicr As Boolean
public bool ConcurrentMicr { get; set; }
public:
property bool ConcurrentMicr {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_ConcurrentMicr ()

/** @property */
public void set_ConcurrentMicr (boolean value)

public function get ConcurrentMicr () : boolean

public function set ConcurrentMicr (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerProperties Class
CheckScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.ConcurrentMicr Property


CheckScannerProperties.Contrast Property

CheckScannerProperties.Contrast Property |
 | See Also

1/18/2008

Set by the application to adjust the darkness of the image.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Contrast As Integer
public int Contrast { get; set; }
public:
property int Contrast {
    int get ();
    void set (int value);
}
/** @property */
public int get_Contrast ()

/** @property */
public void set_Contrast (int value)

public function get Contrast () : int

public function set Contrast (value : int)

Remarks

Contrast is valid only if the CapContrast property is true.

A value of 0 sets or indicates that the device will generate the lightest image possible. A value of 100 sets or indicates that the device will generate the darkest image possible. All values between 0 and 100 produce images with varying degrees of darkness. A value of 50 should produce an image that is the optimal brightness for the best image under normal circumstances.

If the CapAutoContrast property is true then Contrast can be set to AutomaticContrast to allow the device to automatically adjust the darkness of the image based on sensing of the paper to produce the optimal brightness for the best image under normal circumstances.

If CapAutoContrast is false, then attempting to set this property to AutomaticConstrast is illegal.

If CapAutoContrast is true, then Contrast is initialized to AutomaticContrast when the device is enabled. If CapAutoContrast is false, Contrast is initialized either to 50 or to a user-configured value when the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerProperties Class
CheckScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


CheckScannerProperties.DocumentHeight Property

CheckScannerProperties.DocumentHeight Property |
 | See Also

1/18/2008

Holds the height of the document scanned, or the height of the document to be scanned.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property DocumentHeight As Integer
public int DocumentHeight { get; set; }
public:
property int DocumentHeight {
    int get ();
    void set (int value);
}
/** @property */
public int get_DocumentHeight ()

/** @property */
public void set_DocumentHeight (int value)

public function get DocumentHeight () : int

public function set DocumentHeight (value : int)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerProperties Class
CheckScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.DocumentHeight Property


CheckScannerProperties.DocumentWidth Property

CheckScannerProperties.DocumentWidth Property |
 | See Also

1/18/2008

Holds the width of the document scanned, or the width of the document to be scanned.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property DocumentWidth As Integer
public int DocumentWidth { get; set; }
public:
property int DocumentWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_DocumentWidth ()

/** @property */
public void set_DocumentWidth (int value)

public function get DocumentWidth () : int

public function set DocumentWidth (value : int)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerProperties Class
CheckScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.DocumentWidth Property


CheckScannerProperties.FileId Property

CheckScannerProperties.FileId Property |
 | See Also

1/18/2008

Holds the file name associated with the image data file.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property FileId As String
public string FileId { get; set; }
public:
property String^ FileId {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_FileId ()

/** @property */
public void set_FileId (String value)

public function get FileId () : String

public function set FileId (value : String)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerProperties Class
CheckScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.FileId Property


CheckScannerProperties.FileIndex Property

CheckScannerProperties.FileIndex Property |
 | See Also

1/18/2008

Holds the file location associated with the image data file.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property FileIndex As Integer
public int FileIndex { get; set; }
public:
property int FileIndex {
    int get ();
    void set (int value);
}
/** @property */
public int get_FileIndex ()

/** @property */
public void set_FileIndex (int value)

public function get FileIndex () : int

public function set FileIndex (value : int)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerProperties Class
CheckScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.FileIndex Property


CheckScannerProperties.ImageData Property

CheckScannerProperties.ImageData Property |
 | See Also

1/18/2008

Holds the image data after the RetrieveImage or RetrieveMemory methods are called.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property ImageData As Bitmap
public Bitmap ImageData { get; set; }
public:
property Bitmap^ ImageData {
    Bitmap^ get ();
    void set (Bitmap^ value);
}
/** @property */
public Bitmap get_ImageData ()

/** @property */
public void set_ImageData (Bitmap value)

public function get ImageData () : Bitmap

public function set ImageData (value : Bitmap)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerProperties Class
CheckScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.ImageData Property


CheckScannerProperties.ImageFormat Property

CheckScannerProperties.ImageFormat Property |
 | See Also

1/18/2008

Holds the data format of the image file that the device will use when it captures an image.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property ImageFormat As CheckImageFormats
public CheckImageFormats ImageFormat { get; set; }
public:
property CheckImageFormats ImageFormat {
    CheckImageFormats get ();
    void set (CheckImageFormats value);
}
/** @property */
public CheckImageFormats get_ImageFormat ()

/** @property */
public void set_ImageFormat (CheckImageFormats value)

public function get ImageFormat () : CheckImageFormats

public function set ImageFormat (value : CheckImageFormats)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerProperties Class
CheckScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.ImageFormat Property


CheckScannerProperties.ImageMemoryStatus Property

CheckScannerProperties.ImageMemoryStatus Property |
 | See Also

1/18/2008

Indicates the current memory availability status if the device has the ability to store multiple image files.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property ImageMemoryStatus As ImageMemoryStatus
public ImageMemoryStatus ImageMemoryStatus { get; set; }
public:
property ImageMemoryStatus ImageMemoryStatus {
    ImageMemoryStatus get ();
    void set (ImageMemoryStatus value);
}
/** @property */
public ImageMemoryStatus get_ImageMemoryStatus ()

/** @property */
public void set_ImageMemoryStatus (ImageMemoryStatus value)

public function get ImageMemoryStatus () : ImageMemoryStatus

public function set ImageMemoryStatus (value : ImageMemoryStatus)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerProperties Class
CheckScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.ImageMemoryStatus Property


CheckScannerProperties.ImageTagData Property

CheckScannerProperties.ImageTagData Property |
 | See Also

1/18/2008

Holds a string that specifies the tag name for the captured image data. The string may be specified by the application or automatically generated by the check scanner device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property ImageTagData As String
public string ImageTagData { get; set; }
public:
property String^ ImageTagData {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_ImageTagData ()

/** @property */
public void set_ImageTagData (String value)

public function get ImageTagData () : String

public function set ImageTagData (value : String)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerProperties Class
CheckScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.ImageTagData Property


CheckScannerProperties.MapMode Property

CheckScannerProperties.MapMode Property |
 | See Also

1/18/2008

Specifies the units of measure that are currently valid for the check scanner device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property MapMode As MapMode
public MapMode MapMode { get; set; }
public:
property MapMode MapMode {
    MapMode get ();
    void set (MapMode value);
}
/** @property */
public MapMode get_MapMode ()

/** @property */
public void set_MapMode (MapMode value)

public function get MapMode () : MapMode

public function set MapMode (value : MapMode)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerProperties Class
CheckScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.MapMode Property


CheckScannerProperties.MaxCropAreas Property

CheckScannerProperties.MaxCropAreas Property |
 | See Also

1/18/2008

Specifies the maximum number of crop areas the device can support.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property MaxCropAreas As Integer
public int MaxCropAreas { get; set; }
public:
property int MaxCropAreas {
    int get ();
    void set (int value);
}
/** @property */
public int get_MaxCropAreas ()

/** @property */
public void set_MaxCropAreas (int value)

public function get MaxCropAreas () : int

public function set MaxCropAreas (value : int)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerProperties Class
CheckScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.MaxCropAreas Property


CheckScannerProperties.Quality Property

CheckScannerProperties.Quality Property |
 | See Also

1/18/2008

Sets the resolution of the device when a scan image is to take place. The resolution value is defined as dpi (dots per inch).

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Quality As Integer
public int Quality { get; set; }
public:
property int Quality {
    int get ();
    void set (int value);
}
/** @property */
public int get_Quality ()

/** @property */
public void set_Quality (int value)

public function get Quality () : int

public function set Quality (value : int)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerProperties Class
CheckScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.Quality Property


CheckScannerProperties.QualityList Property

CheckScannerProperties.QualityList Property |
 | See Also

1/18/2008

Defines the resolutions the check scanner device is capable of supporting.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property QualityList As Integer()
public int[] QualityList { get; set; }
public:
property array<int>^ QualityList {
    array<int>^ get ();
    void set (array<int>^ value);
}
/** @property */
public int[] get_QualityList ()

/** @property */
public void set_QualityList (int[] value)

public function get QualityList () : int[]

public function set QualityList (value : int[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerProperties Class
CheckScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.QualityList Property


CheckScannerProperties.RemainingImagesEstimate Property

CheckScannerProperties.RemainingImagesEstimate Property |
 | See Also

1/18/2008

Provides a “best guess” estimate of the remaining number of images that can be stored.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property RemainingImagesEstimate As Integer
public int RemainingImagesEstimate { get; set; }
public:
property int RemainingImagesEstimate {
    int get ();
    void set (int value);
}
/** @property */
public int get_RemainingImagesEstimate ()

/** @property */
public void set_RemainingImagesEstimate (int value)

public function get RemainingImagesEstimate () : int

public function set RemainingImagesEstimate (value : int)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CheckScannerProperties Class
CheckScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CheckScannerBase.RemainingImagesEstimate Property


ClearPrintAreaOperation Class

ClearPrintAreaOperation Class |
 | See Also Members

1/18/2008

Clears the area defined by the PageModePrintArea property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class ClearPrintAreaOperation
    Inherits PrintOperation
public class ClearPrintAreaOperation : PrintOperation
public ref class ClearPrintAreaOperation : public PrintOperation
public class ClearPrintAreaOperation extends PrintOperation
public class ClearPrintAreaOperation extends PrintOperation

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BaseServiceObjects.PrintOperation
Microsoft.PointOfService.BaseServiceObjects.ClearPrintAreaOperation

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ClearPrintAreaOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace


ClearPrintAreaOperation Members

ClearPrintAreaOperation Members |
 | See Also Methods Properties

1/18/2008

Clears the area defined by the PageModePrintArea property.

The following tables list the members exposed by the ClearPrintAreaOperation type.

Public Properties

Name | Description
AsyncMode | Contains the AsyncMode property setting at the time of the application’s print request. (inherited from PrintOperation)
PageModePrintArea | Gets the print area for the selected PageModeStation property expressed in the unit of measure given by MapMode property. The maximum print area is the page area.
Rotation | Contains the Rotation setting, as defined by the Rotation enumeration. (inherited from PrintOperation)
State | Contains an instance of the PrinterState class, which captures the current printer property values at the time of the application’s print request. (inherited from PrintOperation)
Station | Contains the printer station setting (for example, PrinterStation.Journal). (inherited from PrintOperation)
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ClearPrintAreaOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace


ClearPrintAreaOperation Methods

ClearPrintAreaOperation Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

ClearPrintAreaOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace


ClearPrintAreaOperation Properties

ClearPrintAreaOperation Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
AsyncMode | Contains the AsyncMode property setting at the time of the application’s print request. (inherited from PrintOperation )
PageModePrintArea | Gets the print area for the selected PageModeStation property expressed in the unit of measure given by MapMode property. The maximum print area is the page area.
Rotation | Contains the Rotation setting, as defined by the Rotation enumeration. (inherited from PrintOperation )
State | Contains an instance of the PrinterState class, which captures the current printer property values at the time of the application’s print request. (inherited from PrintOperation )
Station | Contains the printer station setting (for example, PrinterStation.Journal). (inherited from PrintOperation )

See Also

Reference

ClearPrintAreaOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace


ClearPrintAreaOperation.PageModePrintArea Property

ClearPrintAreaOperation.PageModePrintArea Property |
 | See Also

1/18/2008

Gets the print area for the selected PageModeStation property expressed in the unit of measure given by MapMode property. The maximum print area is the page area.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property PageModePrintArea As Rectangle
public Rectangle PageModePrintArea { get; }
public:
property Rectangle PageModePrintArea {
    Rectangle get ();
}
/** @property */
public Rectangle get_PageModePrintArea ()

public function get PageModePrintArea () : Rectangle

Remarks

The string consists of four ASCII numeric characters separated by commas, in the following order: horizontal start, vertical start, horizontal size, vertical size. For example, if the string is "50,100,200,400", then the station print area is a rectangle beginning at the point (50,100), and continuing up to but excluding the point (250,500). This property is initialized to "0,0,0,0". Text written to the right edge of the print area wraps to the next line. Any text or image written beyond the bottom of the print area is truncated.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ClearPrintAreaOperation Class
ClearPrintAreaOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace


CutPaperOperation Class

CutPaperOperation Class |
 | See Also Members

1/18/2008

When the application updates printer properties and then calls the CutPaper method, the PosPrinterBase class uses an instance of the CutPaperOperation class, cast to the PrintOperation class and stored in the PrintOperationCollection array, to capture information about that method call.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class CutPaperOperation
    Inherits PrintOperation
public class CutPaperOperation : PrintOperation
public ref class CutPaperOperation : public PrintOperation
public class CutPaperOperation extends PrintOperation
public class CutPaperOperation extends PrintOperation

Remarks

The CutPaperOperation helper class derives from the PrintOperation helper class. When the application updates printer properties and then calls the CutPaper method, the PosPrinterBase class uses an instance of the CutPaperOperation class, cast to the PrintOperation class and stored in the PrintOperationCollection array, to capture information about that method call. The service object then retrieves the operation from the array and uses it to complete the application’s print request.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BaseServiceObjects.PrintOperation
Microsoft.PointOfService.BaseServiceObjects.CutPaperOperation

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CutPaperOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase
CutPaper
PrintOperation


CutPaperOperation Members

CutPaperOperation Members |
 | See Also Methods Properties

1/18/2008

When the application updates printer properties and then calls the CutPaper method, the PosPrinterBase class uses an instance of the CutPaperOperation class, cast to the PrintOperation class and stored in the PrintOperationCollection array, to capture information about that method call.

The following tables list the members exposed by the CutPaperOperation type.

Public Properties

Name | Description
AsyncMode | Contains the AsyncMode property setting at the time of the application’s print request. (inherited from PrintOperation)
Percentage | Contains the value of the percentage parameter set when the application made the CutPaper method call.
Rotation | Contains the Rotation setting, as defined by the Rotation enumeration. (inherited from PrintOperation)
State | Contains an instance of the PrinterState class, which captures the current printer property values at the time of the application’s print request. (inherited from PrintOperation)
Station | Contains the printer station setting (for example, PrinterStation.Journal). (inherited from PrintOperation)
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

CutPaperOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase
CutPaper
PrintOperation


CutPaperOperation Methods

CutPaperOperation Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

CutPaperOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase
CutPaper
PrintOperation


CutPaperOperation Properties

CutPaperOperation Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
AsyncMode | Contains the AsyncMode property setting at the time of the application’s print request. (inherited from PrintOperation )
Percentage | Contains the value of the percentage parameter set when the application made the CutPaper method call.
Rotation | Contains the Rotation setting, as defined by the Rotation enumeration. (inherited from PrintOperation )
State | Contains an instance of the PrinterState class, which captures the current printer property values at the time of the application’s print request. (inherited from PrintOperation )
Station | Contains the printer station setting (for example, PrinterStation.Journal). (inherited from PrintOperation )

See Also

Reference

CutPaperOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase
CutPaper
PrintOperation


CutPaperOperation.Percentage Property

CutPaperOperation.Percentage Property |
 | See Also

1/18/2008

Contains the value of the percentage parameter set when the application made the CutPaper method call.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Percentage As Integer
public int Percentage { get; }
public:
property int Percentage {
    int get ();
}
/** @property */
public int get_Percentage ()

public function get Percentage () : int

Remarks

Contains the value of the percentage parameter set when the application made the CutPaper method call.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

CutPaperOperation Class
CutPaperOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CutPaper Method


DeviceStatistics Class

DeviceStatistics Class |
 | See Also Members

1/18/2008

Helps a service object implement device statistics reporting.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class DeviceStatistics
    Implements IDisposable
public class DeviceStatistics : IDisposable
public ref class DeviceStatistics : IDisposable
public class DeviceStatistics implements IDisposable
public class DeviceStatistics implements IDisposable

Remarks

The DeviceStatistics helper class is provided by POS for .NET to help the service objects implement device statistics reporting. DeviceStatistics class supports methods to reset, retrieve, and update statistics, as well as helper methods for creating statistics, incrementing statistics, and loading or saving statistics to or from XML file storage.

DeviceStatistics supports statistics stored in either hardware or software. POS for .NET stores software-based statistics in an XML statistics file and updates those statistics at a globally-defined flush interval determined at the time of system installation and setup. When the application claims a device, POS for .NET loads the appropriate statistics from the XML file.

In general, service objects that derive from one of the Base or Basic classes defined in the Microsoft.PointOfService.BaseServiceObjects or Microsoft.PointOfService.BasicServiceObjects namespace need to write very little code to implement software-based device statistics. Typically, the service object will only write code to call the IncrementStatistic method, which increments the value of a given statistic. All other software-based statistics management is handled by the base/basic class.

To support hardware-based statistics stored in the device, the service object must specify a callback function that can reset or return the value of the statistic, which POS for .NET can then use in response to a client application's request.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BaseServiceObjects.DeviceStatistics

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace


DeviceStatistics Members

DeviceStatistics Members |
 | See Also Constructors Methods Properties

1/18/2008

Helps a service object implement device statistics reporting.

The following tables list the members exposed by the DeviceStatistics type.

Public Constructors

Name | Description
DeviceStatistics | Initializes a new instance of DeviceStatistics with the specified device information.
Top

Public Properties

Name | Description
CapStatisticsReporting | Indicates whether a device supports statistics reporting.
CapUpdateStatistics | Indicates whether at least one statistic can reset its value to zero.
FlushInterval | Contains the interval used by POS for .NET to determine when to update the device's XML statistics file with the current statistics values.
Top

Public Methods (see also Protected Methods )

Name | Description
Close | Releases the class and its resources.
CreateStatistic | Overloaded.
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
FlushStatistics | Saves the current statistics values to the XML statistics file.
GetHashCode | (inherited from Object )
GetStatisticValue | Returns the value of the specified statistic.
GetType | (inherited from Object )
IncrementStatistic | Overloaded. Increments a statistic.
LoadStatistics | Loads the saved statistics values for a device, so that they can be incremented during the current work session and then re-saved.
ReferenceEquals | (inherited from Object )
ResetStatistic | Resets the specified statistic to zero.
ResetStatistics | Overloaded.
RetrieveStatistic | Retrieves all device statistics.
RetrieveStatistics | Overloaded.
SetStatisticHandlers | Sets the statistic handlers for an existing statistic.
SetStatisticValue | Sets the value of a specified statistic.
ToString | (inherited from Object )
UpdateStatistic | Updates the value of the specified statistic.
UpdateStatistics | Overloaded.
Top

Protected Methods

Name | Description
Dispose | Overloaded.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

DeviceStatistics Class
Microsoft.PointOfService.BaseServiceObjects Namespace


DeviceStatistics Constructor

DeviceStatistics Constructor |
 | See Also

1/18/2008

Initializes a new instance of DeviceStatistics with the specified device information.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub New ( _
    deviceName As String, _
    devicePath As String, _
    deviceType As String _
)
public DeviceStatistics (
    string deviceName,
    string devicePath,
    string deviceType
)
public:
DeviceStatistics (
    String^ deviceName,
    String^ devicePath,
    String^ deviceType
)
public DeviceStatistics (
    String deviceName,
    String devicePath,
    String deviceType
)
public function DeviceStatistics (
    deviceName : String,
    devicePath : String,
    deviceType : String
)

Parameters

deviceName

Contains the name of the device or of the performance object that exposes performance counters.

devicePath

Contains the hardware path or any string that uniquely identifies the device.

deviceType

Contains the device type.

Remarks

When called, POS for .NET creates the resources to manage statistics, constructs an instance of the DeviceStatistics class and initializes all member properties.

DeviceStatistics may throw a PosControlException with the following values:

Value | Description
ArgumentException | The deviceName, devicePath, or deviceType is null or empty.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace


DeviceStatistics Methods

DeviceStatistics Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Close | Releases the class and its resources.
CreateStatistic | Overloaded.
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
FlushStatistics | Saves the current statistics values to the XML statistics file.
GetHashCode | (inherited from Object )
GetStatisticValue | Returns the value of the specified statistic.
GetType | (inherited from Object )
IncrementStatistic | Overloaded. Increments a statistic.
LoadStatistics | Loads the saved statistics values for a device, so that they can be incremented during the current work session and then re-saved.
ReferenceEquals | (inherited from Object )
ResetStatistic | Resets the specified statistic to zero.
ResetStatistics | Overloaded.
RetrieveStatistic | Retrieves all device statistics.
RetrieveStatistics | Overloaded.
SetStatisticHandlers | Sets the statistic handlers for an existing statistic.
SetStatisticValue | Sets the value of a specified statistic.
ToString | (inherited from Object )
UpdateStatistic | Updates the value of the specified statistic.
UpdateStatistics | Overloaded.

Protected Methods

Name | Description
Dispose | Overloaded.
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

DeviceStatistics Class
Microsoft.PointOfService.BaseServiceObjects Namespace


DeviceStatistics.Close Method

DeviceStatistics.Close Method |
 | See Also

1/18/2008

Releases the class and its resources.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub Close
public void Close ()
public:
void Close ()
public void Close ()
public function Close ()

Remarks

Releases the class and its resources.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosCommon.Close Method


DeviceStatistics.CreateStatistic Method

DeviceStatistics.CreateStatistic Method |
 | See Also

1/18/2008

Overload List

Name | Description
DeviceStatistics.CreateStatistic (String, Boolean) | Creates and stores a new statistic for a device, after verifying that the statistic doesn't already exist.
DeviceStatistics.CreateStatistic (String, Boolean, String) | Creates and stores a new statistic for a device, after verifying that the statistic doesn't already exist.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace


DeviceStatistics.CreateStatistic Method (String, Boolean)

DeviceStatistics.CreateStatistic Method (String, Boolean) |
 | See Also

1/18/2008

Creates and stores a new statistic for a device, after verifying that the statistic doesn't already exist.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub CreateStatistic ( _
    statisticName As String, _
    resettable As Boolean _
)
public void CreateStatistic (
    string statisticName,
    bool resettable
)
public:
void CreateStatistic (
    String^ statisticName,
    bool resettable
)
public void CreateStatistic (
    String statisticName,
    boolean resettable
)
public function CreateStatistic (
    statisticName : String,
    resettable : boolean
)

Parameters

statisticName

The name of the statistic (or the constant that refers to the statistic) to be created.

resettable

If set to true, the created statistic will be identified by POS for .NET as resettable to 0 (zero).

Remarks

If desired, the service object can implement its own statistics in a manner that is consistent with POS for .NET by defining a constant that refers to the statistic and substitute the constant for the statistic's name.

When the statistic is created, POS for .NET sets the CapStatisticsReporting property to true. If the resettable parameter was set to true, POS for .NET also sets the CapUpdateStatistics property to true.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace


DeviceStatistics.CreateStatistic Method (String, Boolean, String)

DeviceStatistics.CreateStatistic Method (String, Boolean, String) |
 | See Also

1/18/2008

Creates and stores a new statistic for a device, after verifying that the statistic doesn't already exist.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub CreateStatistic ( _
    statisticName As String, _
    resettable As Boolean, _
    unitOfMeasure As String _
)
public void CreateStatistic (
    string statisticName,
    bool resettable,
    string unitOfMeasure
)
public:
void CreateStatistic (
    String^ statisticName,
    bool resettable,
    String^ unitOfMeasure
)
public void CreateStatistic (
    String statisticName,
    boolean resettable,
    String unitOfMeasure
)
public function CreateStatistic (
    statisticName : String,
    resettable : boolean,
    unitOfMeasure : String
)

Parameters

statisticName

The name of the statistic (or the constant that refers to the statistic) to be created.

resettable

If set to true, the created statistic will be identified by POS for .NET as resettable to 0 (zero).

unitOfMeasure

The unit of measure.

Remarks

If desired, the service object can implement its own statistics in a manner that is consistent with POS for .NET by defining a constant that refers to the statistic and substitute the constant for the statistic's name.

When the statistic is created, POS for .NET sets the CapStatisticsReporting property to true. If the resettable parameter was set to true, POS for .NET also sets the CapUpdateStatistics property to true.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace


DeviceStatistics.Dispose Method

DeviceStatistics.Dispose Method |
 | See Also

1/18/2008

Overload List

Name | Description
DeviceStatistics.Dispose () | Releases all managed and unmanaged resources.
DeviceStatistics.Dispose (Boolean) | Releases the specified resources.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace


DeviceStatistics.Dispose Method ()

DeviceStatistics.Dispose Method () |
 | See Also

1/18/2008

Releases all managed and unmanaged resources.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub Dispose
public void Dispose ()
public:
virtual void Dispose () sealed
public final void Dispose ()
public final function Dispose ()

Remarks

Releases all managed and unmanaged resources.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace


DeviceStatistics.Dispose Method (Boolean)

DeviceStatistics.Dispose Method (Boolean) |
 | See Also

1/18/2008

Releases the specified resources.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
protected virtual void Dispose (
    bool disposing
)
protected:
virtual void Dispose (
    bool disposing
)
protected void Dispose (
    boolean disposing
)
protected function Dispose (
    disposing : boolean
)

Parameters

disposing

true to release both managed and unmanaged resources; false to release only unmanaged resources.

Remarks

Releases the specified resources.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace


DeviceStatistics.FlushStatistics Method

DeviceStatistics.FlushStatistics Method |
 | See Also

1/18/2008

Saves the current statistics values to the XML statistics file.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Function FlushStatistics As Boolean
public bool FlushStatistics ()
public:
bool FlushStatistics ()
public boolean FlushStatistics ()
public function FlushStatistics () : boolean

Remarks

The DeviceStatistics class calls FlushStatistics at the interval specified by the FlushInterval property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace
FlushInterval


DeviceStatistics.GetStatisticValue Method

DeviceStatistics.GetStatisticValue Method |
 | See Also

1/18/2008

Returns the value of the specified statistic.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Function GetStatisticValue ( _
    name As String _
) As String
public string GetStatisticValue (
    string name
)
public:
String^ GetStatisticValue (
    String^ name
)
public String GetStatisticValue (
    String name
)
public function GetStatisticValue (
    name : String
) : String

Parameters

name

The name of the statistic that will be read.

Remarks

Returns the value of the specified statistic.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace


DeviceStatistics.IncrementStatistic Method

DeviceStatistics.IncrementStatistic Method |
 | See Also

1/18/2008

Increments a statistic.

Remarks

The service object should call IncrementStatistic to increment software-based statistics counters.

Overload List

Name | Description
DeviceStatistics.IncrementStatistic (String) | Increments the specified statistic by 1.
DeviceStatistics.IncrementStatistic (String, Int32) | Increments a statistic by the specified amount.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace


DeviceStatistics.IncrementStatistic Method (String)

DeviceStatistics.IncrementStatistic Method (String) |
 | See Also

1/18/2008

Increments the specified statistic by 1.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub IncrementStatistic ( _
    name As String _
)
public void IncrementStatistic (
    string name
)
public:
void IncrementStatistic (
    String^ name
)
public void IncrementStatistic (
    String name
)
public function IncrementStatistic (
    name : String
)

Parameters

name

Name of the statistic to be incremented. For UPOS-defined statistics, name should contain the POS for .NET predefined constant for the statistic.

Remarks

The service object should call IncrementStatistic to increment software-based statistics counters.

IncrementStatistic may throw a PosControlException with the following values:

Value | Description
Illegal | One of the following conditions has occurred: No statistic by that name exists; or The name parameter is null.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace


DeviceStatistics.IncrementStatistic Method (String, Int32)

DeviceStatistics.IncrementStatistic Method (String, Int32) |
 | See Also

1/18/2008

Increments a statistic by the specified amount.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub IncrementStatistic ( _
    name As String, _
    increment As Integer _
)
public void IncrementStatistic (
    string name,
    int increment
)
public:
void IncrementStatistic (
    String^ name,
    int increment
)
public void IncrementStatistic (
    String name,
    int increment
)
public function IncrementStatistic (
    name : String,
    increment : int
)

Parameters

name

Name of the statistic to be incremented. For UPOS-defined statistics, name should contain the POS for .NET predefined constant for the statistic.

increment

Amount by which to increment the statistic.

Remarks

Checks the validity of the name parameter, then increments the named statistic by the specified amount. The service object should call IncrementStatistic to increment software-based statistics counters.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace


DeviceStatistics.LoadStatistics Method

DeviceStatistics.LoadStatistics Method |
 | See Also

1/18/2008

Loads the saved statistics values for a device, so that they can be incremented during the current work session and then re-saved.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Function LoadStatistics As Boolean
public bool LoadStatistics ()
public:
bool LoadStatistics ()
public boolean LoadStatistics ()
public function LoadStatistics () : boolean

Remarks

This method will not overwrite any statistics used across all devices.

LoadStatistics returns true if successful, and false if statistics were not loaded.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace


DeviceStatistics.ResetStatistic Method

DeviceStatistics.ResetStatistic Method |
 | See Also

1/18/2008

Resets the specified statistic to zero.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub ResetStatistic ( _
    statistic As String _
)
public void ResetStatistic (
    string statistic
)
public:
void ResetStatistic (
    String^ statistic
)
public void ResetStatistic (
    String statistic
)
public function ResetStatistic (
    statistic : String
)

Parameters

statistic

Specifies the statistic that is to be reset.

Remarks

If the service object needs to maintain hardware-based statistics, provide that information to the application, and allow the application to reset those statistics, it should use SetStatisticHandlers to specify handlers that can be used by POS for .NET for this purpose.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosCommon.ResetStatistic Method


DeviceStatistics.ResetStatistics Method

DeviceStatistics.ResetStatistics Method |
 | See Also

1/18/2008

Overload List

Name | Description
DeviceStatistics.ResetStatistics () | Resets all statistics associated with a device to 0 (zero).
DeviceStatistics.ResetStatistics (StatisticCategories) | Resets all statistics for a specified category to 0 (zero).
DeviceStatistics.ResetStatistics (String[]) | Resets the specified statistics to 0 (zero).

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosCommon.ResetStatistics Method


DeviceStatistics.ResetStatistics Method ()

DeviceStatistics.ResetStatistics Method () |
 | See Also

1/18/2008

Resets all statistics associated with a device to 0 (zero).

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub ResetStatistics
public void ResetStatistics ()
public:
void ResetStatistics ()
public void ResetStatistics ()
public function ResetStatistics ()

Remarks

If the service object needs to maintain hardware-based statistics, provide that information to the application, and allow the application to reset those statistics, it should use SetStatisticHandlers to specify handlers that can be used by POS for .NET for this purpose.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosCommon.ResetStatistics Method


DeviceStatistics.ResetStatistics Method (StatisticCategories)

DeviceStatistics.ResetStatistics Method (StatisticCategories) |
 | See Also

1/18/2008

Resets all statistics for a specified category to 0 (zero).

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub ResetStatistics ( _
    statistics As StatisticCategories _
)
public void ResetStatistics (
    StatisticCategories statistics
)
public:
void ResetStatistics (
    StatisticCategories statistics
)
public void ResetStatistics (
    StatisticCategories statistics
)
public function ResetStatistics (
    statistics : StatisticCategories
)

Parameters

statistics

Contains the category of statistics the application wishes to reset for the device. Possible categories are defined by the StatisticsCategories enumeration.

Remarks

If the service object needs to maintain hardware-based statistics, provide that information to the application, and allow the application to reset those statistics, it should use SetStatisticHandlers to specify handlers that can be used by POS for .NET for this purpose.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosCommon.ResetStatistics Method


DeviceStatistics.ResetStatistics Method (String[])

DeviceStatistics.ResetStatistics Method (String[]) |
 | See Also

1/18/2008

Resets the specified statistics to 0 (zero).

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub ResetStatistics ( _
    statistics As String() _
)
public void ResetStatistics (
    string[] statistics
)
public:
void ResetStatistics (
    array<String^>^ statistics
)
public void ResetStatistics (
    String[] statistics
)
public function ResetStatistics (
    statistics : String[]
)

Parameters

statistics

Contains a comma-separated string of statistics.

Remarks

If the service object needs to maintain hardware-based statistics, provide that information to the application, and allow the application to reset those statistics, it should use SetStatisticHandlers to specify handlers that can be used by POS for .NET for this purpose.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosCommon.ResetStatistics Method


DeviceStatistics.RetrieveStatistic Method

DeviceStatistics.RetrieveStatistic Method |
 | See Also

1/18/2008

Retrieves all device statistics.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Function RetrieveStatistic ( _
    statistic As String _
) As String
public string RetrieveStatistic (
    string statistic
)
public:
String^ RetrieveStatistic (
    String^ statistic
)
public String RetrieveStatistic (
    String statistic
)
public function RetrieveStatistic (
    statistic : String
) : String

Parameters

statistic

Contains a comma-separated string of statistics.

Remarks

If the service object needs to maintain hardware-based statistics, provide that information to the application, and allow the application to retrieve those statistics, it should use SetStatisticHandlers to specify handlers that can be used by POS for .NET for this purpose.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosCommon.RetrieveStatistic Method


DeviceStatistics.RetrieveStatistics Method

DeviceStatistics.RetrieveStatistics Method |
 | See Also

1/18/2008

Overload List

Name | Description
DeviceStatistics.RetrieveStatistics () | Retrieves all device statistics.
DeviceStatistics.RetrieveStatistics (StatisticCategories) | Retrieves the statistics for the specified category.
DeviceStatistics.RetrieveStatistics (String[]) | Retrieves the specified string of statistics.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosCommon.RetrieveStatistics Method


DeviceStatistics.RetrieveStatistics Method ()

DeviceStatistics.RetrieveStatistics Method () |
 | See Also

1/18/2008

Retrieves all device statistics.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Function RetrieveStatistics As String
public string RetrieveStatistics ()
public:
String^ RetrieveStatistics ()
public String RetrieveStatistics ()
public function RetrieveStatistics () : String

Remarks

If the service object needs to maintain hardware-based statistics, provide that information to the application, and allow the application to retrieve those statistics, it should use SetStatisticHandlers to specify handlers that can be used by POS for .NET for this purpose.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosCommon.RetrieveStatistics Method


DeviceStatistics.RetrieveStatistics Method (StatisticCategories)

DeviceStatistics.RetrieveStatistics Method (StatisticCategories) |
 | See Also

1/18/2008

Retrieves the statistics for the specified category.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Function RetrieveStatistics ( _
    statistics As StatisticCategories _
) As String
public string RetrieveStatistics (
    StatisticCategories statistics
)
public:
String^ RetrieveStatistics (
    StatisticCategories statistics
)
public String RetrieveStatistics (
    StatisticCategories statistics
)
public function RetrieveStatistics (
    statistics : StatisticCategories
) : String

Parameters

statistics

Contains the category of statistics the application wishes to retrieve. Possible values are defined by the StatisticsCategories enumeration.

Remarks

If the service object needs to maintain hardware-based statistics, provide that information to the application, and allow the application to retrieve those statistics, it should use SetStatisticHandlers to specify handlers that can be used by POS for .NET for this purpose.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosCommon.RetrieveStatistics Method


DeviceStatistics.RetrieveStatistics Method (String[])

DeviceStatistics.RetrieveStatistics Method (String[]) |
 | See Also

1/18/2008

Retrieves the specified string of statistics.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Function RetrieveStatistics ( _
    statistics As String() _
) As String
public string RetrieveStatistics (
    string[] statistics
)
public:
String^ RetrieveStatistics (
    array<String^>^ statistics
)
public String RetrieveStatistics (
    String[] statistics
)
public function RetrieveStatistics (
    statistics : String[]
) : String

Parameters

statistics

Contains a comma-separated string of statistics.

Remarks

If the service object needs to maintain hardware-based statistics, provide that information to the application, and allow the application to retrieve those statistics, it should use SetStatisticHandlers to specify handlers that can be used by POS for .NET for this purpose.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosCommon.RetrieveStatistics Method


DeviceStatistics.SetStatisticHandlers Method

DeviceStatistics.SetStatisticHandlers Method |
 | See Also

1/18/2008

Sets the statistic handlers for an existing statistic.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub SetStatisticHandlers ( _
    statisticName As String, _
    getStatistic As GetStatistic, _
    setStatistic As SetStatistic _
)
public void SetStatisticHandlers (
    string statisticName,
    GetStatistic getStatistic,
    SetStatistic setStatistic
)
public:
void SetStatisticHandlers (
    String^ statisticName,
    GetStatistic^ getStatistic,
    SetStatistic^ setStatistic
)
public void SetStatisticHandlers (
    String statisticName,
    GetStatistic getStatistic,
    SetStatistic setStatistic
)
public function SetStatisticHandlers (
    statisticName : String,
    getStatistic : GetStatistic,
    setStatistic : SetStatistic
)

Parameters

statisticName

Name of (or constant that refers to) the related statistic to be retrieved or set.

getStatistic

The handler to be called to get the statistic.

setStatistic

The handler to be called to set the statistic.

Remarks

A getStatistic handler must be specified if an application needs to retrieve hardware-based statistics. The setStatistic handler can be null if the statistic does not support resetting its value to zero.

SetStatisticHandlers may throw a PosControlException with the following values:

Value | Description
Illegal | One of the following conditions has occurred: The specified getStatistic was null; or The specified statisticName wasn’t found in the statistics file.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace


DeviceStatistics.SetStatisticValue Method

DeviceStatistics.SetStatisticValue Method |
 | See Also

1/18/2008

Sets the value of a specified statistic.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub SetStatisticValue ( _
    name As String, _
    value As Object _
)
public void SetStatisticValue (
    string name,
    Object value
)
public:
void SetStatisticValue (
    String^ name,
    Object^ value
)
public void SetStatisticValue (
    String name,
    Object value
)
public function SetStatisticValue (
    name : String,
    value : Object
)

Parameters

name

Name of (or the constant that refers to) the statistic whose value is to be set.

value

The value to which the statistic should be set.

Remarks

SetStatisticValue may throw a PosControlException with the following values:

Value | Description
Illegal | The specified name wasn't found in the statistics file.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace


DeviceStatistics.UpdateStatistic Method

DeviceStatistics.UpdateStatistic Method |
 | See Also

1/18/2008

Updates the value of the specified statistic.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub UpdateStatistic ( _
    name As String, _
    value As Object _
)
public void UpdateStatistic (
    string name,
    Object value
)
public:
void UpdateStatistic (
    String^ name,
    Object^ value
)
public void UpdateStatistic (
    String name,
    Object value
)
public function UpdateStatistic (
    name : String,
    value : Object
)

Parameters

name

Name of the statistic to be updated.

value

Value to which the statistic should be set.

Remarks

If the service object needs to maintain hardware-based statistics, provide that information to the application, and allow the application to update those statistics, it should use SetStatisticHandlers to specify handlers that can be used by POS for .NET for this purpose.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosCommon.UpdateStatistic Method
DeviceStatistics.SetStatisticHandlers Method


DeviceStatistics.UpdateStatistics Method

DeviceStatistics.UpdateStatistics Method |
 | See Also

1/18/2008

Overload List

Name | Description
DeviceStatistics.UpdateStatistics (Statistic[]) | Updates a list of statistics with the corresponding specified values.
DeviceStatistics.UpdateStatistics (StatisticCategories, Object) | Updates the specified category of statistics with the specified value.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosCommon.UpdateStatistics Method
DeviceStatistics.SetStatisticHandlers Method


DeviceStatistics.UpdateStatistics Method (Statistic[])

DeviceStatistics.UpdateStatistics Method (Statistic[]) |
 | See Also

1/18/2008

Updates a list of statistics with the corresponding specified values.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub UpdateStatistics ( _
    statistics As Statistic() _
)
public void UpdateStatistics (
    Statistic[] statistics
)
public:
void UpdateStatistics (
    array<Statistic^>^ statistics
)
public void UpdateStatistics (
    Statistic[] statistics
)
public function UpdateStatistics (
    statistics : Statistic[]
)

Parameters

statistics

Contains an array of Statistic class instances (name-value pairs).

Remarks

If the service object needs to maintain hardware-based statistics, provide that information to the application, and allow the application to update those statistics, it should use SetStatisticHandlers to specify handlers that can be used by POS for .NET for this purpose.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosCommon.UpdateStatistics Method
DeviceStatistics.SetStatisticHandlers Method


DeviceStatistics.UpdateStatistics Method (StatisticCategories, Object)

DeviceStatistics.UpdateStatistics Method (StatisticCategories, Object) |
 | See Also

1/18/2008

Updates the specified category of statistics with the specified value.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub UpdateStatistics ( _
    statistics As StatisticCategories, _
    value As Object _
)
public void UpdateStatistics (
    StatisticCategories statistics,
    Object value
)
public:
void UpdateStatistics (
    StatisticCategories statistics,
    Object^ value
)
public void UpdateStatistics (
    StatisticCategories statistics,
    Object value
)
public function UpdateStatistics (
    statistics : StatisticCategories,
    value : Object
)

Parameters

statistics

Contains the category of statistics the application wishes to update. Possible categories are defined by the StatisticCategories enumeration.

value

Contains the value to be used to update the statistics in the specified category.

Remarks

If the service object needs to maintain hardware-based statistics, provide that information to the application, and allow the application to update those statistics, it should use SetStatisticHandlers to specify handlers that can be used by POS for .NET for this purpose.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosCommon.UpdateStatistics Method
DeviceStatistics.SetStatisticHandlers Method


DeviceStatistics Properties

DeviceStatistics Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
CapStatisticsReporting | Indicates whether a device supports statistics reporting.
CapUpdateStatistics | Indicates whether at least one statistic can reset its value to zero.
FlushInterval | Contains the interval used by POS for .NET to determine when to update the device's XML statistics file with the current statistics values.

See Also

Reference

DeviceStatistics Class
Microsoft.PointOfService.BaseServiceObjects Namespace


DeviceStatistics.CapStatisticsReporting Property

DeviceStatistics.CapStatisticsReporting Property |
 | See Also

1/18/2008

Indicates whether a device supports statistics reporting.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapStatisticsReporting As Boolean
public bool CapStatisticsReporting { get; set; }
public:
property bool CapStatisticsReporting {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapStatisticsReporting ()

/** @property */
public void set_CapStatisticsReporting (boolean value)

public function get CapStatisticsReporting () : boolean

public function set CapStatisticsReporting (value : boolean)

Remarks

true if a device supports statistics reporting; otherwise, false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosCommon.CapStatisticsReporting Property


DeviceStatistics.CapUpdateStatistics Property

DeviceStatistics.CapUpdateStatistics Property |
 | See Also

1/18/2008

Indicates whether at least one statistic can reset its value to zero.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapUpdateStatistics As Boolean
public bool CapUpdateStatistics { get; set; }
public:
property bool CapUpdateStatistics {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapUpdateStatistics ()

/** @property */
public void set_CapUpdateStatistics (boolean value)

public function get CapUpdateStatistics () : boolean

public function set CapUpdateStatistics (value : boolean)

Remarks

Returns true if at least one statistic supports resetting its value to zero.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosCommon.CapUpdateStatistics Property


DeviceStatistics.FlushInterval Property

DeviceStatistics.FlushInterval Property |
 | See Also

1/18/2008

Contains the interval used by POS for .NET to determine when to update the device's XML statistics file with the current statistics values.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property FlushInterval As Integer
public int FlushInterval { get; set; }
public:
property int FlushInterval {
    int get ();
    void set (int value);
}
/** @property */
public int get_FlushInterval ()

/** @property */
public void set_FlushInterval (int value)

public function get FlushInterval () : int

public function set FlushInterval (value : int)

Remarks

FlushInterval is initialized to Infinite (-1), indicating that automatic flushing, or saving, of statistics to the device’s statistics file is turned off. When the application claims or enables the device, POS for .NET sets FlushInterval to the global flush interval value stored during system setup, thus enabling automatic flushing. When the application sets the DeviceEnabled property to false, FlushInterval is set back to Infinite.

Accessing FlushInterval may throw a PosControlException with the following values:

Value | Description
Illegal | The value specified was less than 0 (zero) but not set to Infinite.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DeviceStatistics Class
DeviceStatistics Members
Microsoft.PointOfService.BaseServiceObjects Namespace


DrawerStateChangedEventArgs Class

DrawerStateChangedEventArgs Class |
 | See Also Members

1/18/2008

Used as the event type for the DrawerStateChangedEventHandler delegate.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class DrawerStateChangedEventArgs
    Inherits EventArgs
public class DrawerStateChangedEventArgs : EventArgs
public ref class DrawerStateChangedEventArgs : public EventArgs
public class DrawerStateChangedEventArgs extends EventArgs
public class DrawerStateChangedEventArgs extends EventArgs

Remarks

DrawerStateChangedEventArgs class inherits from the .NET Framework EventArgs class. An instance of DrawerStateChangedEventArgs is used as the event type for the DrawerStateChangedEventHandler delegate.

Inheritance Hierarchy

System.Object
System.EventArgs
Microsoft.PointOfService.BaseServiceObjects.DrawerStateChangedEventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DrawerStateChangedEventArgs Members
Microsoft.PointOfService.BaseServiceObjects Namespace
DrawerStateChangedEventHandler


DrawerStateChangedEventArgs Members

DrawerStateChangedEventArgs Members |
 | See Also Fields Methods Properties

1/18/2008

Used as the event type for the DrawerStateChangedEventHandler delegate.

The following tables list the members exposed by the DrawerStateChangedEventArgs type.

Public Fields

Name | Description
Empty | (inherited from EventArgs )
Top

Public Properties

Name | Description
DrawerOpened | If true, the status of the cash drawer is Open. If false, the status is Closed.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

DrawerStateChangedEventArgs Class
Microsoft.PointOfService.BaseServiceObjects Namespace
DrawerStateChangedEventHandler


DrawerStateChangedEventArgs Fields

DrawerStateChangedEventArgs Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
Empty | (inherited from EventArgs )

See Also

Reference

DrawerStateChangedEventArgs Class
Microsoft.PointOfService.BaseServiceObjects Namespace
DrawerStateChangedEventHandler


DrawerStateChangedEventArgs Methods

DrawerStateChangedEventArgs Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

DrawerStateChangedEventArgs Class
Microsoft.PointOfService.BaseServiceObjects Namespace
DrawerStateChangedEventHandler


DrawerStateChangedEventArgs Properties

DrawerStateChangedEventArgs Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
DrawerOpened | If true, the status of the cash drawer is Open. If false, the status is Closed.

See Also

Reference

DrawerStateChangedEventArgs Class
Microsoft.PointOfService.BaseServiceObjects Namespace
DrawerStateChangedEventHandler


DrawerStateChangedEventArgs.DrawerOpened Property

DrawerStateChangedEventArgs.DrawerOpened Property |
 | See Also

1/18/2008

If true, the status of the cash drawer is Open. If false, the status is Closed.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property DrawerOpened As Boolean
public bool DrawerOpened { get; }
public:
property bool DrawerOpened {
    bool get ();
}
/** @property */
public boolean get_DrawerOpened ()

public function get DrawerOpened () : boolean

Remarks

If true, the status of the cash drawer is Open. If false, the status is Closed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

DrawerStateChangedEventArgs Class
DrawerStateChangedEventArgs Members
Microsoft.PointOfService.BaseServiceObjects Namespace


DrawerStateChangedEventHandler Delegate

DrawerStateChangedEventHandler Delegate |
 | See Also

1/18/2008

Delegate for the OnDrawerStateChanged event.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Delegate Sub DrawerStateChangedEventHandler ( _
    sender As Object, _
    e As DrawerStateChangedEventArgs _
)
public delegate void DrawerStateChangedEventHandler (
    Object sender,
    DrawerStateChangedEventArgs e
)
public delegate void DrawerStateChangedEventHandler (
    Object^ sender,
    DrawerStateChangedEventArgs^ e
)
/** @delegate */
public delegate void DrawerStateChangedEventHandler (
    Object sender,
    DrawerStateChangedEventArgs e
)

Parameters

sender

The service object sending the event.

e

The event, which is an instance of DrawerStateChangedEventArgs.

Remarks

Delegate for the OnDrawerStateChanged event.

See Also

Reference

Microsoft.PointOfService.BaseServiceObjects Namespace


GetStatistic Delegate

GetStatistic Delegate |
 | See Also

1/18/2008

Gets a device statistic.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Delegate Function GetStatistic ( _
    statisticName As String _
) As String
public delegate string GetStatistic (
    string statisticName
)
public delegate String^ GetStatistic (
    String^ statisticName
)
/** @delegate */
public delegate String GetStatistic (
    String statisticName
)

Parameters

statisticName

The statistic to get.

See Also

Reference

Microsoft.PointOfService.BaseServiceObjects Namespace


LineDisplayBase Class

LineDisplayBase Class |
 | See Also Members

1/18/2008

Contains most of the functionality required for support of Line Display devices, including drawing of text and graphics (glyphs and bitmaps), window management, and scrolling, marquee, and teletype functions.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public MustInherit Class LineDisplayBase
    Inherits LineDisplayBasic
public abstract class LineDisplayBase : LineDisplayBasic
public ref class LineDisplayBase abstract : public LineDisplayBasic
public abstract class LineDisplayBase extends LineDisplayBasic
public abstract class LineDisplayBase extends LineDisplayBasic

Remarks

The LineDisplayBase class derives from the LineDisplayBasic class and contains most of the functionality required for support of Line Display devices, including drawing of text and graphics (glyphs and bitmaps), window management, and scrolling, marquee, and teletype functions.

When deriving from LineDisplayBase, service objects should implement the CheckHealth and DirectIO methods. In addition, they should, at a minimum,-implement the following:

  • The DisplayData method: LineDisplayBase class calls the service object's implementation of DisplayData when data needs to be displayed on the line display screen. LineDisplayBase passes in an array of Cell classes that describe the position and the data to be displayed.

  • The LineDisplayScreenModes property: The LineDisplayScreenModes property returns a list of LineDisplayScreenMode classes that describe the supported screen sizes. Service objects should update LineDisplayScreenModes with the screen sizes supported for the line display device.

By default, LineDisplayBase class fully supports ReadBack, InterCharacterWait, and both horizontal and vertical marquee functions. In addition, the LineDisplayBase class partially supports the following:

  • Bitmaps. The service object must set the CapBitmap property to true to enable the LineDisplayBase class support of bitmaps.

  • Custom glyphs. The service object must set the CapCustomGlyph property to true to enable the LineDisplayBase class support of custom glyphs. Be default, the CustomGlyphList property is set to a full range of characters; if necessary, the service object can change the list to more accurately reflect the capabilities of the line display device.

  • Descriptors. The service object must set the CapDescriptors property to true to enable the LineDisplayBase class support of descriptors. In addition, the service object must implement the ClearDescriptorImpl and SetDescriptorImpl methods.

Note: Cursors, Blinking, Brightness, Reverse Video, and Character Sets functionality must be implemented by the service object.

The LineDisplayBase class provides the core functionality for opening, claiming, and enabling line display devices. Typically, though, service objects will want to override these methods to add their own custom processing. (An example would be to update device statistics during the Open method, or to bring the device online when the application enables it.) When overriding these methods, the service object must call the base class implementation.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.LineDisplay
Microsoft.PointOfService.BasicServiceObjects.LineDisplayBasic
Microsoft.PointOfService.BaseServiceObjects.LineDisplayBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace

Other Resources

Using Impl Methods for Synchronous or Asynchronous Output


LineDisplayBase Members

LineDisplayBase Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Contains most of the functionality required for support of Line Display devices, including drawing of text and graphics (glyphs and bitmaps), window management, and scrolling, marquee, and teletype functions.

The following tables list the members exposed by the LineDisplayBase type.

Protected Constructors

Name | Description
LineDisplayBase | Creates an instance of the LineDisplayBase class.
Top

Public Fields

Name | Description
CharacterSetAnsi | Indicates the default character set is ANSI. (inherited from LineDisplay)
CharacterSetAscii | Indicates the default character set is ASCII. (inherited from LineDisplay)
CharacterSetUnicode | Indicates the default character set is Unicode. (inherited from LineDisplay)
DisplayBitmapAsIs | Displays the bitmap with one bitmap pixel per dot. (inherited from LineDisplay)
DisplayBitmapBottom | Aligns the bitmap’s bottom edge with the bottommost pixel of the current character position, as specified by the CursorRow property setting. (inherited from LineDisplay)
DisplayBitmapCenter | Aligns the bitmap in the horizontal center of the current character position, as specified by the CursorColumn property setting. (inherited from LineDisplay)
DisplayBitmapLeft | Aligns the bitmap’s left edge with the leftmost pixel of the current character position, as specified by the CursorColumn property setting. (inherited from LineDisplay)
DisplayBitmapRight | Aligns the bitmap’s right edge with the rightmost pixel of the current character position, as specified by the CursorColumn property setting. (inherited from LineDisplay)
DisplayBitmapTop | Aligns the bitmap’s top edge with the topmost pixel of the current character position, as specified by the CursorRow property setting. (inherited from LineDisplay)
ExtendedErrorBadFormat | Indicates that the specified file is either not a bitmap file or it is in an unsupported format. (inherited from LineDisplay)
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
ExtendedErrorTooBig | Indicates that the bitmap is either too wide to display without transformation, or it is too big to transform. (inherited from LineDisplay)
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticOnlineTransitionCount | Incremented when data is successfully drawn in the line display window. (inherited from LineDisplay)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
BlinkRate | Overridden. Holds the blink cycle in milliseconds.
CapBitmap | Overridden. If true, display of bitmaps is supported.
CapBlink | Overridden. Holds the character blink capability of the line display device.
CapBlinkRate | Overridden. If true, the device’s blink rate can be controlled, and the application uses the BlinkRate property to indicate the rate at which the display blinks.
CapBrightness | Overridden. If true, brightness control is supported.
CapCharacterSet | Overridden. Holds the default character set capability of the line display device.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from LineDisplayBasic)
CapCursorType | Overridden. Holds a bitwise indication of the cursor types supported by the line display device, selectable via the CursorType property.
CapCustomGlyph | Overridden. If true, the device supports custom glyph definition.
CapDescriptors | Overridden. If true, the device supports descriptors.
CapHMarquee | Overridden. If true, the device supports horizontal marquee windows.
CapICharWait | Overridden. If true, the device supports inter-character wait.
CapMapCharacterSet | Overridden. If true, then the service object is able to map the characters provided by the application to the character sets defined in the CharacterSetList property when displaying data.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from LineDisplayBasic)
CapReadBack | Overridden. Holds the capability of the line display device to read back the data displayed on it.
CapReverse | Overridden. Holds the reverse video capability of the line display device.
CapScreenMode | Overridden. If true, the line display device supports changing the screen mode (that is, the number of text rows and columns).
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from LineDisplayBasic)
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from LineDisplayBasic)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from LineDisplayBasic)
CapVMarquee | Overridden. If true, the device supports vertical marquee windows.
CharacterSet | Overridden. Holds the character set for displaying characters.
CharacterSetList | Overridden. Holds a string of character set numbers.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from LineDisplayBasic)
Columns | Overridden. Holds the number of columns for this window.
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
CurrentWindow | Overridden.
CursorColumn | Overridden. Holds the column in the current window to which the next displayed character will be output.
CursorRow | Overridden. Holds the row in the current window to which the next displayed character will be output.
CursorType | Overridden. Holds the cursor type for the current window. Possible values are defined by the DisplayCursors enumeration.
CursorUpdate | Overridden. If true when characters are displayed using the DisplayText and DisplayTextAt methods, then the CursorRow and CursorColumn properties will be updated to point to the character beyond the last character output.
CustomGlyphList | Overridden. Holds an array of instances of the RangeOfCharacters helper class, which represents the character code ranges that are available for defining glyphs.
DeviceBrightness | Overridden. Holds the device brightness value, expressed as a percentage between 0 and 100.
DeviceColumns | Overridden. Holds the number of columns on this device.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from LineDisplayBasic)
DeviceDescriptors | Overridden. Holds the number of descriptors on this device.
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from LineDisplayBasic)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from LineDisplayBasic)
DeviceRows | Overridden. Holds the number of rows on this device.
DeviceWindows | Overridden. Holds the maximum number of windows supported by the line display device.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from LineDisplayBasic)
GlyphHeight | Overridden. Indicates the glyph height based on the number of pixels for a character cell.
GlyphWidth | Overridden. Indicates the glyph width based on the number of pixels for a character cell.
InterCharacterWait | Overridden. Holds the wait time, specified in milliseconds, between the display of each character with the DisplayText and DisplayTextAt methods.
MapCharacterSet | Overridden. If true, then the service object is able to map the characters provided by the application to the character sets defined in the CharacterSetList property when displaying data.
MarqueeFormat | Overridden. Holds the marquee format for the current window.
MarqueeRepeatWait | Overridden. Holds the wait time, specified in milliseconds, between scrolling the final character or row of the window into its viewport and restarting the marquee with the first or last character or row.
MarqueeType | Overridden. Holds the marquee type for the current window.
MarqueeUnitWait | Overridden. Holds the wait time, specified in milliseconds, between marquee scrolling of each column or row in the window.
MaximumX | Overridden. Contains the maximum number of horizontal pixels supported by the device.
MaximumY | Overridden. Contains the maximum number of vertical pixels supported by the device.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from LineDisplayBasic)
PowerState | Gets the current power condition. (inherited from LineDisplayBasic)
Rows | Overridden. Holds the number of rows for this window.
ScreenMode | Overridden. Holds the screen mode value of the device.
ScreenModeList | Overridden. Holds the array of DisplayScreenMode class instances that are supported by the device.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from LineDisplayBasic)
ServiceObjectVersion | Gets the Service Object version number. (inherited from LineDisplayBasic)
State | Gets the current state of the device. (inherited from LineDisplayBasic)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Top

Protected Properties

Name | Description
CommonProperties | (inherited from LineDisplayBasic )
CursorDeviceColumn | Translates the CursorColumn value into a device coordinate by returning an integer that represents the value of the CursorColumn property added to the current window’s start column value.
CursorDeviceRow | Translates the CursorRow value into a device coordinate by returning an integer that represents the value of the CursorRow property added to the current window’s start row value.
CursorVisible |
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
ExternallyClaimed | (inherited from LineDisplayBasic )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Gets the Boolean value that indicates whether the Line Display device is an exclusive-use device. (inherited from LineDisplay)
LineDisplayScreenModes |
Properties | Returns an instance of the LineDisplayProperties helper class, containing getters and setters for LineDisplay and common properties.
Top

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from LineDisplayBasic )
ClearDescriptors | Overridden. Turns off all descriptors.
ClearText | Overridden. Clears the current window by displaying blanks, sets the CursorRow and CursorColumn properties to zero, and then resynchronizes the beginning of the window with the start of the viewport.
Close | Clears all windows. (inherited from LineDisplayBasic)
CompareFirmwareVersion | (inherited from PosCommon )
CreateWindow | Overridden. Creates a viewport over the portion of the display specified by the first four parameters.
DefineGlyph | Overridden. Defines a glyph character.
DestroyWindow | Overridden. Destroys the current window.
DirectIO | (inherited from PosCommon )
DisplayBitmap | Overloaded. Overridden.
DisplayText | Overloaded. Overridden. Displays the specified string of characters.
DisplayTextAt | Overloaded. Overridden.
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Overridden. Creates the device window and sets its DeviceBrightness property to 100.
ReadCharacterAtCursor | Overridden. Reads the currently displayed character at the cursor position.
ReferenceEquals | (inherited from Object )
RefreshWindow | Overridden. Changes the current window to the one specified by the window parameter, then redisplays that window’s viewport.
Release | Releases exclusive access to the device. (inherited from LineDisplayBasic)
ResetStatistic | (inherited from LineDisplayBasic )
ResetStatistics | Overloaded. (inherited from LineDisplayBasic )
RetrieveStatistic | (inherited from LineDisplayBasic )
RetrieveStatistics | Overloaded. (inherited from LineDisplayBasic )
ScrollText | Overridden. Scrolls text in the current window, in the specified direction.
SetBitmap | Overloaded. Overridden.
SetDescriptor | Overridden. Sets the state of a descriptor.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from LineDisplayBasic )
UpdateStatistics | Overloaded. (inherited from LineDisplayBasic )
Top

Protected Methods

Name | Description
ClearDescriptorsImpl | Called by the LineDisplayBase.ClearDescriptors method.
CreateStatistic | Overloaded. (inherited from LineDisplayBasic )
DeleteConfigurationProperty | (inherited from PosCommon )
DisplayData | Called by the LineDisplayBase class to draw the window.
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
GetStatisticValue | (inherited from LineDisplayBasic )
IncrementStatistic | Overloaded. (inherited from LineDisplayBasic )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
PreFireEvent | Overloaded. (inherited from LineDisplayBasic )
QueueEvent | Overloaded. (inherited from LineDisplayBasic )
QueueEventAndWait | (inherited from LineDisplayBasic )
SetConfigurationProperty | (inherited from PosCommon )
SetDescriptorImpl | Called by the LineDisplayBase.SetDescriptor method.
SetStatisticHandlers | (inherited from LineDisplayBasic )
SetStatisticValue | (inherited from LineDisplayBasic )
VerifyState | (inherited from LineDisplayBasic )
Top

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from LineDisplayBasic)
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from LineDisplayBasic)
Top

Protected Events

Name | Description
BlinkRateChangedEvent | Informs the service object that the value of the BlinkRate property has changed.
CurrentWindowChangedEvent | Informs the service object that the value of the CurrentWindow property has changed.
CursorTypeChangedEvent | Inform the service object that the value of the CursorType property has changed.
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
ScreenModeChangedEvent | Inform the service object that the value of the ScreenMode property has changed.
StateChangedEvent | (inherited from LineDisplayBasic )
Top

See Also

Reference

LineDisplayBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace

Other Resources

Using Impl Methods for Synchronous or Asynchronous Output


LineDisplayBase Fields

LineDisplayBase Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
CharacterSetAnsi | Indicates the default character set is ANSI. (inherited from LineDisplay )
CharacterSetAscii | Indicates the default character set is ASCII. (inherited from LineDisplay )
CharacterSetUnicode | Indicates the default character set is Unicode. (inherited from LineDisplay )
DisplayBitmapAsIs | Displays the bitmap with one bitmap pixel per dot. (inherited from LineDisplay )
DisplayBitmapBottom | Aligns the bitmap’s bottom edge with the bottommost pixel of the current character position, as specified by the CursorRow property setting. (inherited from LineDisplay )
DisplayBitmapCenter | Aligns the bitmap in the horizontal center of the current character position, as specified by the CursorColumn property setting. (inherited from LineDisplay )
DisplayBitmapLeft | Aligns the bitmap’s left edge with the leftmost pixel of the current character position, as specified by the CursorColumn property setting. (inherited from LineDisplay )
DisplayBitmapRight | Aligns the bitmap’s right edge with the rightmost pixel of the current character position, as specified by the CursorColumn property setting. (inherited from LineDisplay )
DisplayBitmapTop | Aligns the bitmap’s top edge with the topmost pixel of the current character position, as specified by the CursorRow property setting. (inherited from LineDisplay )
ExtendedErrorBadFormat | Indicates that the specified file is either not a bitmap file or it is in an unsupported format. (inherited from LineDisplay )
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
ExtendedErrorTooBig | Indicates that the bitmap is either too wide to display without transformation, or it is too big to transform. (inherited from LineDisplay )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticOnlineTransitionCount | Incremented when data is successfully drawn in the line display window. (inherited from LineDisplay )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

LineDisplayBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace

Other Resources

Using Impl Methods for Synchronous or Asynchronous Output


LineDisplayBase Constructor

LineDisplayBase Constructor |
 | See Also

1/18/2008

Creates an instance of the LineDisplayBase class.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Sub New
protected LineDisplayBase ()
protected:
LineDisplayBase ()
protected LineDisplayBase ()
protected function LineDisplayBase ()

Remarks

Creates an instance of the LineDisplayBase class. Initializes statistics for the UPOS Version, the Device Category, and the Installation Date.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


LineDisplayBase Methods

LineDisplayBase Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from LineDisplayBasic )
ClearDescriptors | Overridden. Turns off all descriptors.
ClearText | Overridden. Clears the current window by displaying blanks, sets the CursorRow and CursorColumn properties to zero, and then resynchronizes the beginning of the window with the start of the viewport.
Close | Clears all windows. (inherited from LineDisplayBasic )
CompareFirmwareVersion | (inherited from PosCommon )
CreateWindow | Overridden. Creates a viewport over the portion of the display specified by the first four parameters.
DefineGlyph | Overridden. Defines a glyph character.
DestroyWindow | Overridden. Destroys the current window.
DirectIO | (inherited from PosCommon )
DisplayBitmap | Overloaded. Overridden.
DisplayText | Overloaded. Overridden. Displays the specified string of characters.
DisplayTextAt | Overloaded. Overridden.
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Overridden. Creates the device window and sets its DeviceBrightness property to 100.
ReadCharacterAtCursor | Overridden. Reads the currently displayed character at the cursor position.
ReferenceEquals | (inherited from Object )
RefreshWindow | Overridden. Changes the current window to the one specified by the window parameter, then redisplays that window’s viewport.
Release | Releases exclusive access to the device. (inherited from LineDisplayBasic )
ResetStatistic | (inherited from LineDisplayBasic )
ResetStatistics | Overloaded. (inherited from LineDisplayBasic )
RetrieveStatistic | (inherited from LineDisplayBasic )
RetrieveStatistics | Overloaded. (inherited from LineDisplayBasic )
ScrollText | Overridden. Scrolls text in the current window, in the specified direction.
SetBitmap | Overloaded. Overridden.
SetDescriptor | Overridden. Sets the state of a descriptor.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from LineDisplayBasic )
UpdateStatistics | Overloaded. (inherited from LineDisplayBasic )

Protected Methods

Name | Description
ClearDescriptorsImpl | Called by the LineDisplayBase.ClearDescriptors method.
CreateStatistic | Overloaded. (inherited from LineDisplayBasic )
DeleteConfigurationProperty | (inherited from PosCommon )
DisplayData | Called by the LineDisplayBase class to draw the window.
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
GetStatisticValue | (inherited from LineDisplayBasic )
IncrementStatistic | Overloaded. (inherited from LineDisplayBasic )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
PreFireEvent | Overloaded. (inherited from LineDisplayBasic )
QueueEvent | Overloaded. (inherited from LineDisplayBasic )
QueueEventAndWait | (inherited from LineDisplayBasic )
SetConfigurationProperty | (inherited from PosCommon )
SetDescriptorImpl | Called by the LineDisplayBase.SetDescriptor method.
SetStatisticHandlers | (inherited from LineDisplayBasic )
SetStatisticValue | (inherited from LineDisplayBasic )
VerifyState | (inherited from LineDisplayBasic )

See Also

Reference

LineDisplayBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace

Other Resources

Using Impl Methods for Synchronous or Asynchronous Output


LineDisplayBase.ClearDescriptors Method

LineDisplayBase.ClearDescriptors Method |
 | See Also

1/18/2008

Turns off all descriptors.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub ClearDescriptors
public override void ClearDescriptors ()
public:
virtual void ClearDescriptors () override
public void ClearDescriptors ()
public override function ClearDescriptors ()

Remarks

The LineDisplayBase class ensures that the line display device has been opened, claimed, and enabled.

ClearDescriptors may throw a PosControlException with the following ErrorCode:

Value | Meaning
Illegal | The device doesn’t support descriptors.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.ClearDescriptors Method
LineDisplay.CapDescriptors Property


LineDisplayBase.ClearDescriptorsImpl Method

LineDisplayBase.ClearDescriptorsImpl Method |
 | See Also

1/18/2008

Called by the LineDisplayBase.ClearDescriptors method.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overridable Sub ClearDescriptorsImpl
protected virtual void ClearDescriptorsImpl ()
protected:
virtual void ClearDescriptorsImpl ()
protected void ClearDescriptorsImpl ()
protected function ClearDescriptorsImpl ()

Remarks

Called by the LineDisplayBase.ClearDescriptors method. In the event that the line display device doesn’t support descriptors, a default “not implemented” version of ClearDescriptorsImpl is provided. If descriptors are supported, the service object must implement ClearDescriptorsImpl.

Before calling ClearDescriptorsImpl, the LineDisplayBase class ensures that the following is true:

  • The line display device has been opened, claimed, and enabled; and

  • The device supports descriptors—that is, that the CapDescriptors property is set to true.

If these validations are performed successfully, the base class calls ClearDescriptorsImpl. If either fails, the base class throws an exception.

ClearDescriptorsImpl should throw exceptions for all other error conditions.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.ClearDescriptors Method
LineDisplay.CapDescriptors Property


LineDisplayBase.ClearText Method

LineDisplayBase.ClearText Method |
 | See Also

1/18/2008

Clears the current window by displaying blanks, sets the CursorRow and CursorColumn properties to zero, and then resynchronizes the beginning of the window with the start of the viewport.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub ClearText
public override void ClearText ()
public:
virtual void ClearText () override
public void ClearText ()
public override function ClearText ()

Remarks

The LineDisplayBase class implementation of ClearText verifies that the line display device is opened, claimed, and enabled. If the device is in Immediate mode or Teletype mode, the viewport is also cleared immediately.

If in Marquee On mode, ClearText is illegal.

ClearText may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The device is in Marquee On mode and can’t be cleared.

Otherwise, it clears the window. If the device is in Marquee Init Mode, LineDisplayBase refreshes the window, using current property values.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.ClearText Method


LineDisplayBase.CreateWindow Method

LineDisplayBase.CreateWindow Method |
 | See Also

1/18/2008

Creates a viewport over the portion of the display specified by the first four parameters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub CreateWindow ( _
    viewportRow As Integer, _
    viewportColumn As Integer, _
    viewportHeight As Integer, _
    viewportWidth As Integer, _
    windowHeight As Integer, _
    windowWidth As Integer _
)
public override void CreateWindow (
    int viewportRow,
    int viewportColumn,
    int viewportHeight,
    int viewportWidth,
    int windowHeight,
    int windowWidth
)
public:
virtual void CreateWindow (
    int viewportRow,
    int viewportColumn,
    int viewportHeight,
    int viewportWidth,
    int windowHeight,
    int windowWidth
) override
public void CreateWindow (
    int viewportRow,
    int viewportColumn,
    int viewportHeight,
    int viewportWidth,
    int windowHeight,
    int windowWidth
)
public override function CreateWindow (
    viewportRow : int,
    viewportColumn : int,
    viewportHeight : int,
    viewportWidth : int,
    windowHeight : int,
    windowWidth : int
)

Parameters

viewportRow

The viewport’s start device row.

viewportColumn

The viewport’s start device column.

viewportHeight

The number of device rows in the viewport.

viewportWidth

The number of device columns in the viewport.

windowHeight

The number of rows in the window.

windowWidth

The number of columns in the window.

Remarks

The window size is specified by the last two parameters. Valid window row values range from (0) to (windowHeight-1) and column values range from (0) to (windowWidth-1).

The window size must be at least as large as the viewport size.

The window size can be larger than the viewport size in one direction. Using the window marquee properties MarqueeType, MarqueeFormat, MarqueeUnitWait, and MarqueeRepeatWait, such a window can be continuously scrolled in a marquee fashion.

When successful, CreateWindow sets the CurrentWindow property to the window number assigned to this window. The following properties are maintained for each window, and are initialized as given:

Property | Value
Rows | windowHeight
Columns | windowWidth
CursorRow | 0
CursorColumn | 0
CursorUpdate | true
MarqueeType | None
MarqueeFormat | Walk
MarqueeUnitWait | 0
MarqueeRepeatWait | 0
InterCharacterWait | 0

The LineDisplayBase class ensures that the line display device has been opened, claimed, and enabled.

CreateWindow may throw a PosControlException with the following ErrorCodes:

Value | Meaning
Illegal | One of the following conditions has occurred:CreateWindow can’t be called for Window 0;One or more parameters are out of their valid ranges; or All available windows are already in use.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.CreateWindow Method


LineDisplayBase.DefineGlyph Method

LineDisplayBase.DefineGlyph Method |
 | See Also

1/18/2008

Defines a glyph character.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub DefineGlyph ( _
    glyphCode As Integer, _
    glyph As Byte() _
)
public override void DefineGlyph (
    int glyphCode,
    byte[] glyph
)
public:
virtual void DefineGlyph (
    int glyphCode,
    array<unsigned char>^ glyph
) override
public void DefineGlyph (
    int glyphCode,
    byte[] glyph
)
public override function DefineGlyph (
    glyphCode : int,
    glyph : byte[]
)

Parameters

glyphCode

The character code to be defined.

glyph

Byte array that defines the glyph.

Remarks

The glyph is defined as bits representing each pixel packed into bytes, using whole bytes to represent each row.

The minimum number of bytes are sent for each row, based on the value of the GlyphWidth property, and using 8 bits per byte. Bytes are sent left-to-right across each row; if more than one byte is required per row, the leftmost byte is sent first. The lowest-order bit within a byte represents the rightmost pixel. Bits that do not represent pixels are the highest-order bits, and their value is ignored. Rows are sent from the top down.

For example, a 10-pixel wide glyph would have the two leftmost pixels represented in bits 1 and 0 of the first byte, respectively. The remaining 8 pixels would be represented in the second byte.

Enough rows must be sent to define the entire character. Whether changing the definition of a glyph causes currently displayed characters to change, or the change appears only when the next glyph is drawn, is hardware-defined.

The LineDisplayBase class ensures that the line display device has been opened, claimed, and enabled.

DefineGlyph may throw a PosControlException with the following ErrorCodes:

Value | Meaning
Illegal | One of the following conditions has occurred:The CapCustomGlyph property is set to false, indicating that the device doesn’t support custom glyphs; The glyphCode parameter contains an unsupported character code for glyph definition; or The glyph parameter contains an incorrect number of bytes, (based on the GlyphWidth and GlyphHeight properties and 8 bits per byte).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.CapCustomGlyph Property
LineDisplay.GlyphHeight Property
LineDisplay.GlyphWidth Property
LineDisplay.DefineGlyph Method


LineDisplayBase.DestroyWindow Method

LineDisplayBase.DestroyWindow Method |
 | See Also

1/18/2008

Destroys the current window.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub DestroyWindow
public override void DestroyWindow ()
public:
virtual void DestroyWindow () override
public void DestroyWindow ()
public override function DestroyWindow ()

Remarks

The characters displayed in its viewport are not changed.

DestroyWindow sets the CurrentWindow property to window 0, the device window. The device window and the associated window properties are updated.

DestroyWindow may throw a PosControlException with the following ErrorCodes:

Value | Meaning
Illegal | The current window is set to 0, the device window. This window cannot be destroyed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.CreateWindow Method
LineDisplay.CurrentWindow Property


LineDisplayBase.DisplayBitmap Method

LineDisplayBase.DisplayBitmap Method |
 | See Also

1/18/2008

Overload List

Name | Description
LineDisplayBase.DisplayBitmap (String, Int32, Int32) | Displays the bitmap with the specified alignment.
LineDisplayBase.DisplayBitmap (String, Int32, Int32, Int32) | Displays the bitmap with the specified alignment and width.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.DisplayBitmap Method
LineDisplay.CapBitmap Property


LineDisplayBase.DisplayBitmap Method (String, Int32, Int32)

LineDisplayBase.DisplayBitmap Method (String, Int32, Int32) |
 | See Also

1/18/2008

Displays the bitmap with the specified alignment.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub DisplayBitmap ( _
    fileName As String, _
    alignmentX As Integer, _
    alignmentY As Integer _
)
public override void DisplayBitmap (
    string fileName,
    int alignmentX,
    int alignmentY
)
public:
virtual void DisplayBitmap (
    String^ fileName,
    int alignmentX,
    int alignmentY
) override
public void DisplayBitmap (
    String fileName,
    int alignmentX,
    int alignmentY
)
public override function DisplayBitmap (
    fileName : String,
    alignmentX : int,
    alignmentY : int
)

Parameters

fileName

File name or URL of the bitmap file.

alignmentX

Horizontal placement of the bitmap to be displayed.

alignmentY

Vertical placement of the bitmap to be displayed.

Remarks

The alignmentX parameter has one of the following values:

Value | Meaning
DisplayBitmapLeft | Align the bitmap’s left edge with the leftmost pixel of the current character position, as specified by the CursorColumn property setting.
DisplayBitmapCenter | Align the bitmap in the horizontal center of the current character position, as specified by the CursorColumn property setting.
DisplayBitmapRight | Align the bitmap’s right edge with the rightmost pixel of the current character position, as specified by the CursorColumn property setting.
Other values | Distance from the window’s leftmost pixel column to the left edge of the bitmap, expressed in number of pixels.

The alignmentY parameter has one of the following values:

Value | Meaning
DisplayBitmapTop | Align the bitmap’s top edge with the topmost pixel of the current character position, as specified by the CursorRow property setting.
DisplayBitmapCenter | Align the bitmap in the vertical center of the current character position, as specified by the CursorRow property setting.
DisplayBitmapBottom | Align the bitmap’s bottom edge with the bottommost pixel of the current character position, as specified by the CursorRow property setting.
Other values | Distance from the window’s topmost pixel row to the start of the bitmap, expressed in number of pixels.

The application calls DisplayBitmap to display a bitmap on the line display device. The bitmap is displayed within the current window’s viewport.

If the values specified for the alignmentX and alignmentY are the values defined by the DisplayBitmap f constants, then the bitmap is displayed in relation to the character positions specified by the CursorColumn and CursorRow properties. In addition, if the CursorUpdate property is set to TRUE, then CursorColumn and CursorRow are updated to point to the first character position following the bitmap.

If the bitmap doesn’t exactly occupy a multiple of rows and columns, then the unoccupied pixels of those character positions that are partially occupied are displayed with the background color. In other words, the service object will fill all character positions partially or completely occupied by the bitmap with the background color before drawing the bitmap.

Bitmap display has the following restrictions:

  • Bitmap display is only legal when in Immediate mode;

  • The window size must match the window’s viewport size;

  • The bitmap must be displayable within the window, after consideration of the function parameters. For example, if alignmentX specifies a pixel near the bottom of the window and the bitmap height (after bitmap transformation, if required) exceeds the distance from alignmentX to the window bottom, then the bitmap isn’t displayed.

The LineDisplayBase class ensures that the line display device has been opened, claimed, and enabled.

DisplayBitmap may throw a PosControlException with the following ErrorCodes:

Value | Meaning
Illegal | One of the following errors occurred:The line display device doesn’t support bitmap display (the CapBitmap property is set to false;The alignmentX/alignmentY parameters are invalid or too big;The window is not in Immediate Mode;The window size doesn’t match its viewport size;The bitmap is either too wide to display without transformation, or it is too big to transform; orThe specified file is either not a bitmap file or it is in an unsupported format.
NoExist | The specified fileName was not found.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.DisplayBitmap Method
LineDisplay.CapBitmap Property


LineDisplayBase.DisplayBitmap Method (String, Int32, Int32, Int32)

LineDisplayBase.DisplayBitmap Method (String, Int32, Int32, Int32) |
 | See Also

1/18/2008

Displays the bitmap with the specified alignment and width.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub DisplayBitmap ( _
    fileName As String, _
    width As Integer, _
    alignmentX As Integer, _
    alignmentY As Integer _
)
public override void DisplayBitmap (
    string fileName,
    int width,
    int alignmentX,
    int alignmentY
)
public:
virtual void DisplayBitmap (
    String^ fileName,
    int width,
    int alignmentX,
    int alignmentY
) override
public void DisplayBitmap (
    String fileName,
    int width,
    int alignmentX,
    int alignmentY
)
public override function DisplayBitmap (
    fileName : String,
    width : int,
    alignmentX : int,
    alignmentY : int
)

Parameters

fileName

File name or URL of the bitmap file.

width

Width of the bitmap to be displayed.

alignmentX

Horizontal placement of the bitmap to be displayed.

alignmentY

Vertical placement of the bitmap to be displayed.

Remarks

The width parameter has one of the following values:

Value | Meaning
DisplayBitmapAsIs | Display the bitmap with one bitmap pixel per dot.
Other values | Bitmap width expressed in number of pixels.

The alignmentX parameter has one of the following values:

Value | Meaning
DisplayBitmapLeft | Align the bitmap’s left edge with the leftmost pixel of the current character position, as specified by the CursorColumn property setting.
DisplayBitmapCenter | Align the bitmap in the horizontal center of the current character position, as specified by the CursorColumn property setting.
DisplayBitmapRight | Align the bitmap’s right edge with the rightmost pixel of the current character position, as specified by the CursorColumn property setting.
Other values | Distance from the window’s leftmost pixel column to the left edge of the bitmap, expressed in number of pixels.

The alignmentY parameter has one of the following values:

Value | Meaning
DisplayBitmapTop | Align the bitmap’s top edge with the topmost pixel of the current character position, as specified by the CursorRow property setting.
DisplayBitmapCenter | Align the bitmap in the vertical center of the current character position, as specified by the CursorRow property setting.
DisplayBitmapBottom | Align the bitmap’s bottom edge with the bottommost pixel of the current character position, as specified by the CursorRow property setting.
Other values | Distance from the window’s topmost pixel row to the start of the bitmap, expressed in number of pixels.

The application calls DisplayBitmap to display a bitmap on the line display device. The bitmap is displayed within the current window’s viewport.

If the values specified for the alignmentX and alignmentY are the values defined by the DisplayBitmap constants, then the bitmap is displayed in relation to the character positions specified by the CursorColumn and CursorRow properties. In addition, if the CursorUpdate property is set to TRUE, then CursorColumn and CursorRow are updated to point to the first character position following the bitmap.

If the bitmap doesn’t exactly occupy a multiple of rows and columns, then the unoccupied pixels of those character positions that are partially occupied are displayed with the background color. In other words, the service object will fill all character positions partially or completely occupied by the bitmap with the background color before drawing the bitmap.

Bitmap display has the following restrictions:

  • Bitmap display is only legal when in Immediate mode;

  • The window size must match the window’s viewport size;

  • The bitmap must be displayable within the window, after consideration of the function parameters. For example, if alignmentX specifies a pixel near the bottom of the window and the bitmap height (after bitmap transformation, if required) exceeds the distance from alignmentX to the window bottom, then the bitmap isn’t displayed.

The width parameter controls transformation of the bitmap. If width is DisplayBitmapAsIs, then no transformation is performed. The bitmap is displayed with one bitmap pixel per line display pixel. The advantages of this option are:

  • It provides the highest performance bitmap display; and

  • It works well for bitmaps tuned for a specific line display device’s aspect ratio between horizontal and vertical dots.

If width is non-zero, then the bitmap will be transformed by stretching or compressing the bitmap such that its width is the specified width and the aspect ratio is unchanged. The advantages of this option are:

  • It sizes the bitmap to fit a variety of line display devices; and

  • It maintains the bitmap’s aspect ratio.

The disadvantages of this option are:

  • Lower performance than untransformed data; and

  • Some lines and images that are "smooth" in the original bitmap may show some "ratcheting."

The LineDisplayBase class ensures that the line display device has been opened, claimed, and enabled.

DisplayBitmap may throw a PosControlException with the following ErrorCodes:

Value | Meaning
Illegal | One of the following errors occurred:The line display device doesn’t support bitmap display (the CapBitmap property is set to false;The width parameter is invalid or too big;The alignmentX/alignmentY parameters are invalid or too big;The window is not in Immediate Mode;The window size doesn’t match its viewport size;The bitmap is either too wide to display without transformation, or it is too big to transform; orThe specified file is either not a bitmap file or it is in an unsupported format.
NoExist | The specified fileName was not found.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.DisplayBitmap Method
LineDisplay.CapBitmap Property


LineDisplayBase.DisplayData Method

LineDisplayBase.DisplayData Method |
 | See Also

1/18/2008

Called by the LineDisplayBase class to draw the window.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Friend MustOverride Sub DisplayData ( _
    cells As Cell() _
)
protected internal abstract void DisplayData (
    Cell[] cells
)
protected public:
virtual void DisplayData (
    array<Cell^>^ cells
) abstract
protected abstract void DisplayData (
    Cell[] cells
)
protected internal abstract function DisplayData (
    cells : Cell[]
)

Parameters

cells

Contains an array of Cell class instances, each of which represents a single character position on the display (or the set of pixels that occupy a single character position).

Remarks

Called by the LineDisplayBase class to draw the window. The service object must implement this method to physically display the data on the line display device. On return from DisplayData, the LineDisplayBase class increments the StatisticOnlineTransitionCount statistic.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Cell Class


LineDisplayBase.DisplayText Method

LineDisplayBase.DisplayText Method |
 | See Also

1/18/2008

Displays the specified string of characters.

Overload List

Name | Description
LineDisplayBase.DisplayText (String) |
LineDisplayBase.DisplayText (String, DisplayTextMode) |

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.DisplayText Method


LineDisplayBase.DisplayText Method (String)

LineDisplayBase.DisplayText Method (String) |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub DisplayText ( _
    data As String _
)
public override void DisplayText (
    string data
)
public:
virtual void DisplayText (
    String^ data
) override
public void DisplayText (
    String data
)
public override function DisplayText (
    data : String
)

Parameters

data

The string of characters to display.

Remarks

The characters in data are processed beginning at the location specified by the CursorRow and CursorColumn property settings, and continue in succeeding columns.

Character processing continues to the next row when the end of a window row is reached. If the end of the window is reached with additional characters to be processed, then the window is scrolled upward by one row and the bottom row is set to blanks. If the CursorUpdate property is set to true, then CursorRow and CursorColumn are updated to point to the character following the last character of data.

Note that scrolling will not occur when the last character of data is placed at the end of a row. In this case, when CursorUpdate is true, then CursorRow is set to the row containing the last character, and CursorColumn is set to the Columns setting (that is, to one more than the final character of the row). This stipulation ensures that the display does not scroll when a character is written into its last position. Instead, the window will not scroll until another character is written.

The operation of DisplayText and DisplayTextAt varies for each mode:

  • Immediate mode (The MarqueeType property = None and the InterCharacterWait property = 0): Updates the window and viewport immediately.

  • Teletype mode (MarqueeType = None and InterCharacterWait not = 0): The data is queued. Queued data requests are processed in order (typically by another thread within the service object), updating the window and viewport using a wait time in milliseconds of the InterCharacterWait property after each character is sent to the viewport.

  • Marquee Init mode (MarqueeType = Init): Updates the window, but does not change the viewport.

  • Marquee On mode (MarqueeType not = Init): Illegal.

Special character values within data are:

Value | Meaning
Carriage Return (13 Decimal) | Change the next character’s output position to the beginning of the current row.
Newline / Line Feed (10 Decimal) | Change the next character’s output position to the beginning of the next row. Scroll the window if the current row is the last row of the window.

The LineDisplayBase class ensures that the line display device has been opened, claimed, and enabled.

DisplayText may throw a PosControlException with the following ErrorCodes:

Value | Meaning
Illegal | DisplayText can’t be called when the device is in Marquee On Mode.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.DisplayText Method


LineDisplayBase.DisplayText Method (String, DisplayTextMode)

LineDisplayBase.DisplayText Method (String, DisplayTextMode) |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub DisplayText ( _
    data As String, _
    attribute As DisplayTextMode _
)
public override void DisplayText (
    string data,
    DisplayTextMode attribute
)
public:
virtual void DisplayText (
    String^ data,
    DisplayTextMode attribute
) override
public void DisplayText (
    String data,
    DisplayTextMode attribute
)
public override function DisplayText (
    data : String,
    attribute : DisplayTextMode
)

Parameters

data

The string of characters to display.

attribute

The display attribute for the text. Possible values are defined by the DisplayTextMode enumeration. Valid values are Normal or Blink.

Remarks

The characters in data are processed beginning at the location specified by the CursorRow and CursorColumn property settings, and continue in succeeding columns.

Character processing continues to the next row when the end of a window row is reached. If the end of the window is reached with additional characters to be processed, then the window is scrolled upward by one row and the bottom row is set to blanks. If the CursorUpdate property is set to true, then CursorRow and CursorColumn are updated to point to the character following the last character of data.

Note that scrolling will not occur when the last character of data is placed at the end of a row. In this case, when CursorUpdate is true, then CursorRow is set to the row containing the last character, and CursorColumn is set to the Columns setting (that is, to one more than the final character of the row). This stipulation ensures that the display does not scroll when a character is written into its last position. Instead, the window will not scroll until another character is written.

The operation of DisplayText (and DisplayTextAt) varies for each mode:

  • Immediate mode (The MarqueeType property = None and the InterCharacterWait property = 0): Updates the window and viewport immediately.

  • Teletype mode (MarqueeType = None and InterCharacterWait not = 0): The data is queued. Queued data requests are processed in order (typically by another thread within the service object), updating the window and viewport using a wait time in milliseconds of the InterCharacterWait property after each character is sent to the viewport.

  • Marquee Init mode (MarqueeType = Init): Updates the window, but does not change the viewport.

  • Marquee On mode (MarqueeType not = Init): Illegal.

If the service object has set the CapBlink property to NoBlink, then attribute is ignored. If it has been set to BlinkAll, then the entire display will blink when one or more characters have been set to blink. If it has been set to BlinkEach, then only those characters displayed with the blink attribute will blink.

Special character values within data are:

Value | Meaning
Carriage Return (13 Decimal) | Change the next character’s output position to the beginning of the current row.
Newline / Line Feed (10 Decimal) | Change the next character’s output position to the beginning of the next row. Scroll the window if the current row is the last row of the window.

The LineDisplayBase class ensures that the line display device has been opened, claimed, and enabled.

DisplayText may throw a PosControlException with the following ErrorCodes:

Value | Meaning
Illegal | One of the following conditions has occurred:The value specified for attribute wasn’t found in the DisplayTextMode enumeration; or DisplayText can’t be called when the device is in Marquee On Mode.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.DisplayText Method
DisplayTextMode Enumeration


LineDisplayBase.DisplayTextAt Method

LineDisplayBase.DisplayTextAt Method |
 | See Also

1/18/2008

Overload List

Name | Description
LineDisplayBase.DisplayTextAt (Int32, Int32, String) | Displays the string of characters at the specified row and column.
LineDisplayBase.DisplayTextAt (Int32, Int32, String, DisplayTextMode) | Displays the string of characters at the specified row and column, in the specified display mode.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.DisplayTextAt Method


LineDisplayBase.DisplayTextAt Method (Int32, Int32, String)

LineDisplayBase.DisplayTextAt Method (Int32, Int32, String) |
 | See Also

1/18/2008

Displays the string of characters at the specified row and column.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub DisplayTextAt ( _
    row As Integer, _
    column As Integer, _
    data As String _
)
public override void DisplayTextAt (
    int row,
    int column,
    string data
)
public:
virtual void DisplayTextAt (
    int row,
    int column,
    String^ data
) override
public void DisplayTextAt (
    int row,
    int column,
    String data
)
public override function DisplayTextAt (
    row : int,
    column : int,
    data : String
)

Parameters

row

The start row for the text.

column

The start column for the text.

data

The string of characters to display.

Remarks

The characters in data are processed beginning at the window location specified by the row and column parameters, and continuing in succeeding columns.

If the CapBlink property is set to NoBlink, all blink escape sequences will be filtered out for purposes of display. If the CapReverse property is set to None, all reverse escape sequences will be filtered out.

DisplayTextAt has the same effect as setting the CursorRow property to row, setting the CursorColumn property to column, and then calling the DisplayText method.

The LineDisplayBase class ensures that the line display device has been opened, claimed, and enabled.

DisplayTextAt may throw a PosControlException with the following ErrorCodes:

Value | Meaning
Illegal | One or more of the following conditions has occurred:The value specified for row or for column is out of range; orDisplayText can’t be called when the device is in Marquee On Mode.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.DisplayTextAt Method


LineDisplayBase.DisplayTextAt Method (Int32, Int32, String, DisplayTextMode)

LineDisplayBase.DisplayTextAt Method (Int32, Int32, String, DisplayTextMode) |
 | See Also

1/18/2008

Displays the string of characters at the specified row and column, in the specified display mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub DisplayTextAt ( _
    row As Integer, _
    column As Integer, _
    data As String, _
    attribute As DisplayTextMode _
)
public override void DisplayTextAt (
    int row,
    int column,
    string data,
    DisplayTextMode attribute
)
public:
virtual void DisplayTextAt (
    int row,
    int column,
    String^ data,
    DisplayTextMode attribute
) override
public void DisplayTextAt (
    int row,
    int column,
    String data,
    DisplayTextMode attribute
)
public override function DisplayTextAt (
    row : int,
    column : int,
    data : String,
    attribute : DisplayTextMode
)

Parameters

row

The start row for the text.

column

The start column for the text.

data

The string of characters to display.

attribute

The display attribute for the text. Possible values are defined by the DisplayTextMode enumeration. Must be either DisplayTextMode.Normal or DisplayTextMode.Blink.

Remarks

The characters in data are processed beginning at the window location specified by the row and column parameters, and continuing in succeeding columns.

If the CapBlink property is set to NoBlink, all blink escape sequences will be filtered out for purposes of display. If the CapReverse property is set to None, all reverse escape sequences will be filtered out.

DisplayTextAt has the same effect as setting the CursorRow property to row, setting the CursorColumn property to column, and then calling the DisplayText method.

The LineDisplayBase class ensures that the line display device has been opened, claimed, and enabled.

DisplayTextAt may throw a PosControlException with the following ErrorCodes:

Value | Meaning
Illegal | One or more of the following conditions has occurred:The value specified for row or for column is out of range; The value specified for attribute isn’t found in the DisplayTextMode enumeration; or DisplayText can’t be called when the device is in Marquee On Mode.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.DisplayTextAt Method
DisplayTextMode Enumeration


LineDisplayBase.Dispose Method

LineDisplayBase.Dispose Method |
 | See Also

1/18/2008

Overload List

Name | Description
LineDisplayBase.Dispose () | (inherited from Dispose )
LineDisplayBase.Dispose (Boolean) |

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


LineDisplayBase.Dispose Method (Boolean)

LineDisplayBase.Dispose Method (Boolean) |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

protected override void Dispose (
    bool disposing
)

protected:
virtual void Dispose (
    bool disposing
) override

protected void Dispose (
    boolean disposing
)

protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


LineDisplayBase.Open Method

LineDisplayBase.Open Method |
 | See Also

1/18/2008

Creates the device window and sets its DeviceBrightness property to 100.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub Open
public override void Open ()
public:
virtual void Open () override
public void Open ()
public override function Open ()

Remarks

Creates the device window and sets its DeviceBrightness property to 100.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosCommon.Open Method


LineDisplayBase.ReadCharacterAtCursor Method

LineDisplayBase.ReadCharacterAtCursor Method |
 | See Also

1/18/2008

Reads the currently displayed character at the cursor position.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Function ReadCharacterAtCursor As Integer
public override int ReadCharacterAtCursor ()
public:
virtual int ReadCharacterAtCursor () override
public int ReadCharacterAtCursor ()
public override function ReadCharacterAtCursor () : int

Remarks

The LineDisplayBase class ensures that the line display device has been opened, claimed, and enabled.

ReadCharacterAtCursor returns the displayed character from the current window if successful, and it may throw a PosControlException with the following ErrorCodes:

Value | Meaning
Illegal | The CapReadBack property is set to DisplayReadBack.None;The current value of CursorRow is less than zero or greater than the window height; orThe current value of CursorColumn is less than zero or greater than the window width.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.CapReadBack Property
LineDisplay.ReadCharacterAtCursor Method


LineDisplayBase.RefreshWindow Method

LineDisplayBase.RefreshWindow Method |
 | See Also

1/18/2008

Changes the current window to the one specified by the window parameter, then redisplays that window’s viewport.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub RefreshWindow ( _
    window As Integer _
)
public override void RefreshWindow (
    int window
)
public:
virtual void RefreshWindow (
    int window
) override
public void RefreshWindow (
    int window
)
public override function RefreshWindow (
    window : int
)

Parameters

window

Specifies the window to be refreshed.

Remarks

Neither the mapping of the window to its viewport nor the window’s cursor position is changed.

RefreshWindow can be used to restore a window after another window has overwritten some of its viewport.

The LineDisplayBase class ensures that the line display device has been opened, claimed, and enabled.

RefreshWindow may throw a PosControlException with the following ErrorCodes:

Value | Meaning
Illegal | RefreshWindow can’t be called while the device is in Marquee On Mode.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.RefreshWindow Method


LineDisplayBase.ScrollText Method

LineDisplayBase.ScrollText Method |
 | See Also

1/18/2008

Scrolls text in the current window, in the specified direction.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub ScrollText ( _
    direction As DisplayScrollText, _
    units As Integer _
)
public override void ScrollText (
    DisplayScrollText direction,
    int units
)
public:
virtual void ScrollText (
    DisplayScrollText direction,
    int units
) override
public void ScrollText (
    DisplayScrollText direction,
    int units
)
public override function ScrollText (
    direction : DisplayScrollText,
    units : int
)

Parameters

direction

Indicates the scrolling direction, as defined by the DisplayScrollText enumeration.

units

Indicates the number of columns or rows to scroll.

Remarks

ScrollText is legal only when the window is in Immediate mode.

If the window size for the scroll direction matches its viewport size, then the window data is scrolled, the last units rows or columns are set to spaces, and the viewport is updated.

If the window size for the scroll direction is larger than its viewport, then the window data is not changed. Instead, the mapping of the window into the viewport is moved in the specified direction. The window data is not altered, but the viewport is updated. If scrolling by units would go beyond the beginning of the window data, then the window is scrolled so that the first viewport row or column contains the first window row or column. If scrolling by units would go beyond the end of the window data, then the window is scrolled so that the last viewport row or column contains the last window row or column.

The LineDisplayBase class ensures that the line display device has been opened, claimed, and enabled.

ScrollText may throw a PosControlException with the following ErrorCodes:

Value | Meaning
Illegal | The window isn’t in Immediate Mode—that is, the MarqueeType property must be set to None and the InterCharacterWait property must be set to 0 (zero).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.ScrollText Method


LineDisplayBase.SetBitmap Method

LineDisplayBase.SetBitmap Method |
 | See Also

1/18/2008

Overload List

Name | Description
LineDisplayBase.SetBitmap (Int32, String, Int32, Int32) | Sets the bitmap number and placement.
LineDisplayBase.SetBitmap (Int32, String, Int32, Int32, Int32) | Sets the bitmap number, placement, and width.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.SetBitmap Method


LineDisplayBase.SetBitmap Method (Int32, String, Int32, Int32)

LineDisplayBase.SetBitmap Method (Int32, String, Int32, Int32) |
 | See Also

1/18/2008

Sets the bitmap number and placement.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub SetBitmap ( _
    bitmapNumber As Integer, _
    fileName As String, _
    alignmentX As Integer, _
    alignmentY As Integer _
)
public override void SetBitmap (
    int bitmapNumber,
    string fileName,
    int alignmentX,
    int alignmentY
)
public:
virtual void SetBitmap (
    int bitmapNumber,
    String^ fileName,
    int alignmentX,
    int alignmentY
) override
public void SetBitmap (
    int bitmapNumber,
    String fileName,
    int alignmentX,
    int alignmentY
)
public override function SetBitmap (
    bitmapNumber : int,
    fileName : String,
    alignmentX : int,
    alignmentY : int
)

Parameters

bitmapNumber

The number to be assigned to this bitmap.

fileName

The file name or URL of the bitmap file.

alignmentX

The horizontal placement of the bitmap.

alignmentY

The vertical placement of the bitmap.

Remarks

The alignmentX parameter has one of the following values:

Value | Meaning
DisplayBitmapLeft | Align the bitmap’s left edge with the leftmost pixel of the current character position.
DisplayBitmapCenter | Align the bitmap in the horizontal center of the current character position.
DisplayBitmapRight | Align the bitmap’s right edge with the rightmost pixel of the current character position.
Other values | Distance from the window’s leftmost pixel column to the left edge of the bitmap, expressed in number of pixels.

The alignmentY parameter has one of the following values:

Value | Meaning
DisplayBitmapTop | Align the bitmap’s top edge with the topmost pixel of the current character position.
DisplayBitmapCenter | Align the bitmap in the vertical center of the current character position.
DisplayBitmapBottom | Align the bitmap’s bottom edge with the bottommost pixel of the current character position.
Other values | Distance from the window’s topmost pixel row to the start of the bitmap, expressed in number of pixels.

Called to save information about a bitmap for later display. The bitmap may then be displayed by calling the DisplayText or DisplayTextAt methods with the display bitmap escape sequences in the display data. The display bitmap escape sequence will typically be included in a string for displaying advertisements, store logos, or icons. See the "Remarks" section of the DisplayBitmap method for restrictions on displaying the saved bitmap. If one or more restrictions are not fulfilled, then the bitmap is not displayed, and the method continues on with the next character of display data.

A service object may choose to cache the bitmap for later use to provide better performance. Regardless, the bitmap file and parameters are validated for correctness by this method.

The most frequently used bitmaps should be assigned a small bitmapNumber (close to 1), while occasionally used bitmaps should be assigned the larger bitmapNumbers. The service object will use this information to determine how best to store the bitmaps. It may download them to the device when possible, or cache them in service object memory, or simply remember the fileName and associated properties for use when it is displayed.

An application must ensure that the LineDisplay window metrics, such as viewport width and height, are set before calling this method. A service object may perform transformations on the bitmap in preparation for later displaying based on the current values of these metrics.

The LineDisplayBase class ensures that the line display device has been opened, claimed, and enabled.

SetBitmap may throw a PosControlException with the following ErrorCodes:

Value | Meaning
Illegal | One of the following errors occurred:The bitmapNumber parameter is invalid;The line display device doesn’t support bitmap display (the CapBitmap property is set to false;The alignmentX/alignmentY parameters are invalid or too big;The bitmap is either too wide to display without transformation, or it is too big to transform; orThe specified file is either not a bitmap file or it is in an unsupported format.
NoExist | The specified fileName was not found.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.SetBitmap Method


LineDisplayBase.SetBitmap Method (Int32, String, Int32, Int32, Int32)

LineDisplayBase.SetBitmap Method (Int32, String, Int32, Int32, Int32) |
 | See Also

1/18/2008

Sets the bitmap number, placement, and width.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub SetBitmap ( _
    bitmapNumber As Integer, _
    fileName As String, _
    width As Integer, _
    alignmentX As Integer, _
    alignmentY As Integer _
)
public override void SetBitmap (
    int bitmapNumber,
    string fileName,
    int width,
    int alignmentX,
    int alignmentY
)
public:
virtual void SetBitmap (
    int bitmapNumber,
    String^ fileName,
    int width,
    int alignmentX,
    int alignmentY
) override
public void SetBitmap (
    int bitmapNumber,
    String fileName,
    int width,
    int alignmentX,
    int alignmentY
)
public override function SetBitmap (
    bitmapNumber : int,
    fileName : String,
    width : int,
    alignmentX : int,
    alignmentY : int
)

Parameters

bitmapNumber

The number to be assigned to this bitmap.

fileName

The file name or URL of the bitmap file.

width

The width of the bitmap to be displayed.

alignmentX

The horizontal placement of the bitmap.

alignmentY

The vertical placement of the bitmap.

Remarks

The width parameter has one of the following values:

Value | Meaning
DisplayBitmapAsIs | Display the bitmap with one bitmap pixel per dot.
Other values | Bitmap width is expressed in number of pixels.

The alignmentX parameter has one of the following values:

Value | Meaning
DisplayBitmapLeft | Align the bitmap’s left edge with the leftmost pixel of the current character position.
DisplayBitmapCenter | Align the bitmap in the horizontal center of the current character position.
DisplayBitmapRight | Align the bitmap’s right edge with the rightmost pixel of the current character position.
Other values | Distance from the window’s leftmost pixel column to the left edge of the bitmap, expressed in number of pixels.

The alignmentY parameter has one of the following values:

Value | Meaning
DisplayBitmapTop | Align the bitmap’s top edge with the topmost pixel of the current character position.
DisplayBitmapCenter | Align the bitmap in the vertical center of the current character position.
DisplayBitmapBottom | Align the bitmap’s bottom edge with the bottommost pixel of the current character position.
Other values | Distance from the window’s topmost pixel row to the start of the bitmap, expressed in number of pixels.

Called to save information about a bitmap for later display. The bitmap may then be displayed by calling the DisplayText or DisplayTextAt methods with the display bitmap escape sequences in the display data. The display bitmap escape sequence will typically be included in a string for displaying advertisements, store logos, or icons. See the "Remarks" section of the DisplayBitmap method for restrictions on displaying the saved bitmap. If one or more restrictions are not fulfilled, then the bitmap is not displayed, and the method continues on with the next character of display data.

A service object may choose to cache the bitmap for later use to provide better performance. Regardless, the bitmap file and parameters are validated for correctness by this method.

The most frequently used bitmaps should be assigned a small bitmapNumber (close to 1), while occasionally used bitmaps should be assigned the larger bitmapNumbers. The service object will use this information to determine how best to store the bitmaps. It may download them to the device when possible, or cache them in service object memory, or simply remember the fileName and associated properties for use when it is displayed.

An application must ensure that the LineDisplay window metrics, such as viewport width and height, are set before calling this method. A service object may perform transformations on the bitmap in preparation for later displaying based on the current values of these metrics.

The LineDisplayBase class ensures that the line display device has been opened, claimed, and enabled.

SetBitmap may throw a PosControlException with the following ErrorCodes:

Value | Meaning
Illegal | One of the following errors occurred:The bitmapNumber parameter is invalid;The line display device doesn’t support bitmap display (the CapBitmap property is set to false;The width parameter is invalid or too big;The alignmentX/alignmentY parameters are invalid or too big;The bitmap is either too wide to display without transformation, or it is too big to transform; orThe specified file is either not a bitmap file or it is in an unsupported format.
NoExist | The specified fileName was not found.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.SetBitmap Method


LineDisplayBase.SetDescriptor Method

LineDisplayBase.SetDescriptor Method |
 | See Also

1/18/2008

Sets the state of a descriptor.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub SetDescriptor ( _
    descriptor As Integer, _
    attribute As DisplaySetDescriptor _
)
public override void SetDescriptor (
    int descriptor,
    DisplaySetDescriptor attribute
)
public:
virtual void SetDescriptor (
    int descriptor,
    DisplaySetDescriptor attribute
) override
public void SetDescriptor (
    int descriptor,
    DisplaySetDescriptor attribute
)
public override function SetDescriptor (
    descriptor : int,
    attribute : DisplaySetDescriptor
)

Parameters

descriptor

Indicates which descriptor to change. The value can range between zero and one less than the value of the DeviceDescriptors property.

attribute

Indicates the attribute for the descriptor. Possible values are defined by the DisplaySetDescriptor enumeration.

Remarks

Sets the state of one of the descriptors, which are small indicators with a fixed label.

If the CapDescriptors property is set to false, SetDescriptor throws an Illegal exception.

The line display’s service object determines the mapping of descriptor to its descriptors.

The LineDisplayBase class ensures that the line display device has been opened, claimed, and enabled, and that the values of the parameters are valid. It then calls LineDisplayBase.SetDescriptorImpl.

SetDescriptor may throw a PosControlException with the following ErrorCodes:

Value | Meaning
Illegal | One of the following conditions has occurred:The line display device does not support descriptors—that is, the CapDescriptors property is set to false; The value specified for descriptor is either less than zero or greater than the value of the DeviceDescriptors; or The value specified for attribute wasn’t found in the DisplaySetDescriptor enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.SetDescriptor Method
SetDescriptorImpl


LineDisplayBase.SetDescriptorImpl Method

LineDisplayBase.SetDescriptorImpl Method |
 | See Also

1/18/2008

Called by the LineDisplayBase.SetDescriptor method.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overridable Sub SetDescriptorImpl ( _
    descriptor As Integer, _
    attribute As DisplaySetDescriptor _
)
protected virtual void SetDescriptorImpl (
    int descriptor,
    DisplaySetDescriptor attribute
)
protected:
virtual void SetDescriptorImpl (
    int descriptor,
    DisplaySetDescriptor attribute
)
protected void SetDescriptorImpl (
    int descriptor,
    DisplaySetDescriptor attribute
)
protected function SetDescriptorImpl (
    descriptor : int,
    attribute : DisplaySetDescriptor
)

Parameters

descriptor

Indicates which descriptor to change. The value can range between zero and one less than the value of the DeviceDescriptors property.

attribute

Indicates the attribute for the descriptor. Possible values are defined by the DisplaySetDescriptor enumeration.

Remarks

Called by the LineDisplayBase.SetDescriptor method. In the event that the line display device doesn’t support descriptors, a default “not implemented” version of SetDescriptorImpl is provided. If the line display device supports descriptors, the service object must implement SetDescriptorImpl. Before calling SetDescriptorImpl, the LineDisplayBase class ensures that the following is true:

  • The line display device has been opened, claimed, and enabled;

  • The device supports descriptors—that is, that the CapDescriptors property is set to true;

  • That descriptor contains a legal value—that is, it isn’t less than zero or greater than the value of the DeviceDescriptors property; and

  • The value specified for attribute is a valid DisplaySetDescriptor value.

If these validations are performed successfully, the base class calls SetDescriptorImpl. If any of them fail, the base class throws an exception.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.SetDescriptor Method
LineDisplay.CapDescriptors Property
DisplaySetDescriptor Enumeration


LineDisplayBase Properties

LineDisplayBase Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
BlinkRate | Overridden. Holds the blink cycle in milliseconds.
CapBitmap | Overridden. If true, display of bitmaps is supported.
CapBlink | Overridden. Holds the character blink capability of the line display device.
CapBlinkRate | Overridden. If true, the device’s blink rate can be controlled, and the application uses the BlinkRate property to indicate the rate at which the display blinks.
CapBrightness | Overridden. If true, brightness control is supported.
CapCharacterSet | Overridden. Holds the default character set capability of the line display device.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from LineDisplayBasic )
CapCursorType | Overridden. Holds a bitwise indication of the cursor types supported by the line display device, selectable via the CursorType property.
CapCustomGlyph | Overridden. If true, the device supports custom glyph definition.
CapDescriptors | Overridden. If true, the device supports descriptors.
CapHMarquee | Overridden. If true, the device supports horizontal marquee windows.
CapICharWait | Overridden. If true, the device supports inter-character wait.
CapMapCharacterSet | Overridden. If true, then the service object is able to map the characters provided by the application to the character sets defined in the CharacterSetList property when displaying data.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from LineDisplayBasic )
CapReadBack | Overridden. Holds the capability of the line display device to read back the data displayed on it.
CapReverse | Overridden. Holds the reverse video capability of the line display device.
CapScreenMode | Overridden. If true, the line display device supports changing the screen mode (that is, the number of text rows and columns).
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from LineDisplayBasic )
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from LineDisplayBasic )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from LineDisplayBasic )
CapVMarquee | Overridden. If true, the device supports vertical marquee windows.
CharacterSet | Overridden. Holds the character set for displaying characters.
CharacterSetList | Overridden. Holds a string of character set numbers.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from LineDisplayBasic )
Columns | Overridden. Holds the number of columns for this window.
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
CurrentWindow | Overridden.
CursorColumn | Overridden. Holds the column in the current window to which the next displayed character will be output.
CursorRow | Overridden. Holds the row in the current window to which the next displayed character will be output.
CursorType | Overridden. Holds the cursor type for the current window. Possible values are defined by the DisplayCursors enumeration.
CursorUpdate | Overridden. If true when characters are displayed using the DisplayText and DisplayTextAt methods, then the CursorRow and CursorColumn properties will be updated to point to the character beyond the last character output.
CustomGlyphList | Overridden. Holds an array of instances of the RangeOfCharacters helper class, which represents the character code ranges that are available for defining glyphs.
DeviceBrightness | Overridden. Holds the device brightness value, expressed as a percentage between 0 and 100.
DeviceColumns | Overridden. Holds the number of columns on this device.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from LineDisplayBasic )
DeviceDescriptors | Overridden. Holds the number of descriptors on this device.
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from LineDisplayBasic )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from LineDisplayBasic )
DeviceRows | Overridden. Holds the number of rows on this device.
DeviceWindows | Overridden. Holds the maximum number of windows supported by the line display device.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from LineDisplayBasic )
GlyphHeight | Overridden. Indicates the glyph height based on the number of pixels for a character cell.
GlyphWidth | Overridden. Indicates the glyph width based on the number of pixels for a character cell.
InterCharacterWait | Overridden. Holds the wait time, specified in milliseconds, between the display of each character with the DisplayText and DisplayTextAt methods.
MapCharacterSet | Overridden. If true, then the service object is able to map the characters provided by the application to the character sets defined in the CharacterSetList property when displaying data.
MarqueeFormat | Overridden. Holds the marquee format for the current window.
MarqueeRepeatWait | Overridden. Holds the wait time, specified in milliseconds, between scrolling the final character or row of the window into its viewport and restarting the marquee with the first or last character or row.
MarqueeType | Overridden. Holds the marquee type for the current window.
MarqueeUnitWait | Overridden. Holds the wait time, specified in milliseconds, between marquee scrolling of each column or row in the window.
MaximumX | Overridden. Contains the maximum number of horizontal pixels supported by the device.
MaximumY | Overridden. Contains the maximum number of vertical pixels supported by the device.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from LineDisplayBasic )
PowerState | Gets the current power condition. (inherited from LineDisplayBasic )
Rows | Overridden. Holds the number of rows for this window.
ScreenMode | Overridden. Holds the screen mode value of the device.
ScreenModeList | Overridden. Holds the array of DisplayScreenMode class instances that are supported by the device.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from LineDisplayBasic )
ServiceObjectVersion | Gets the Service Object version number. (inherited from LineDisplayBasic )
State | Gets the current state of the device. (inherited from LineDisplayBasic )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )

Protected Properties

Name | Description
CommonProperties | (inherited from LineDisplayBasic )
CursorDeviceColumn | Translates the CursorColumn value into a device coordinate by returning an integer that represents the value of the CursorColumn property added to the current window’s start column value.
CursorDeviceRow | Translates the CursorRow value into a device coordinate by returning an integer that represents the value of the CursorRow property added to the current window’s start row value.
CursorVisible |
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
ExternallyClaimed | (inherited from LineDisplayBasic )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Gets the Boolean value that indicates whether the Line Display device is an exclusive-use device. (inherited from LineDisplay )
LineDisplayScreenModes |
Properties | Returns an instance of the LineDisplayProperties helper class, containing getters and setters for LineDisplay and common properties.

See Also

Reference

LineDisplayBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace

Other Resources

Using Impl Methods for Synchronous or Asynchronous Output


LineDisplayBase.BlinkRate Property

LineDisplayBase.BlinkRate Property |
 | See Also

1/18/2008

Holds the blink cycle in milliseconds.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property BlinkRate As Integer
public override int BlinkRate { get; set; }
public:
virtual property int BlinkRate {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_BlinkRate ()

/** @property */
public void set_BlinkRate (int value)

public override function get BlinkRate () : int

public override function set BlinkRate (value : int)

Remarks

A blink cycle is the period of time when text completes an on-off-on cycle during blinking. After BlinkRate is set, the service object will set the blink rate to the closest supported rate and change BlinkRate to reflect the actual rate. Performing this approximation is necessary because blink cycles are hardware dependent and probably not controllable at precise millisecond granularity.

BlinkRate is typically initialized to 0 (zero).

Accessing BlinkRate may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | BlinkRate has been set to a value less than zero, or BlinkRate has been set to a valid value but the CapBlinkRate property is set to false, indicating that the device doesn’t support blinking.

BlinkRate is initialized to 0 (zero) by the LineDisplayProperties class.

LineDisplayBase class verifies that the device has been opened, then retrieves or sets the value of LineDisplayProperties.BlinkRate.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.BlinkRate Property
LineDisplay.CapBlinkRate Property
BlinkRateChangedEvent


LineDisplayBase.CapBitmap Property

LineDisplayBase.CapBitmap Property |
 | See Also

1/18/2008

If true, display of bitmaps is supported.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapBitmap As Boolean
public override bool CapBitmap { get; }
public:
virtual property bool CapBitmap {
    bool get () override;
}
/** @property */
public boolean get_CapBitmap ()

public override function get CapBitmap () : boolean

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves the value of LineDisplayProperties.CapBitmap.

CapBitmap is initialized to false by the LineDisplayProperties class. The service object should update CapBitmap to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.CapBitmap Property


LineDisplayBase.CapBlink Property

LineDisplayBase.CapBlink Property |
 | See Also

1/18/2008

Holds the character blink capability of the line display device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapBlink As DisplayBlink
public override DisplayBlink CapBlink { get; }
public:
virtual property DisplayBlink CapBlink {
    DisplayBlink get () override;
}
/** @property */
public DisplayBlink get_CapBlink ()

public override function get CapBlink () : DisplayBlink

Remarks

Possible values are defined by the DisplayBlink enumeration. Valid values are:

Value | Meaning
None | The line display device doesn’t support blinking; the value is 0.
All | The line display supports blinking for the entire display. The service object sets the entire contents of the display to blink or to be in a steady state.
Each | The line display supports blinking for each character. The service object can set each character to blink individually or to be in a steady state.

LineDisplayBase class verifies that the device has been opened, then retrieves the value of LineDisplayProperties.CapBlink.

CapBlink is initialized to DisplayBlink.None by the LineDisplayProperties class. The LineDisplayProperties class may throw a PosControlException with the following ErrorCode:

Value | Meaning
Illegal | The service object has specified an invalid DisplayBlink value.

The service object should update CapBlink to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.CapBlink Property


LineDisplayBase.CapBlinkRate Property

LineDisplayBase.CapBlinkRate Property |
 | See Also

1/18/2008

If true, the device’s blink rate can be controlled, and the application uses the BlinkRate property to indicate the rate at which the display blinks.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapBlinkRate As Boolean
public override bool CapBlinkRate { get; }
public:
virtual property bool CapBlinkRate {
    bool get () override;
}
/** @property */
public boolean get_CapBlinkRate ()

public override function get CapBlinkRate () : boolean

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves the value of LineDisplayProperties.CapBlinkRate.

CapBlinkRate is initialized to false by the LineDisplayProperties class. The service object should update CapBlinkRate to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.CapBlinkRate Property


LineDisplayBase.CapBrightness Property

LineDisplayBase.CapBrightness Property |
 | See Also

1/18/2008

If true, brightness control is supported.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapBrightness As Boolean
public override bool CapBrightness { get; }
public:
virtual property bool CapBrightness {
    bool get () override;
}
/** @property */
public boolean get_CapBrightness ()

public override function get CapBrightness () : boolean

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves the value of LineDisplayProperties.CapBrightness.

CapBrightness is initialized to false by the LineDisplayProperties class. The service object should update CapBrightness to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.CapBrightness Property


LineDisplayBase.CapCharacterSet Property

LineDisplayBase.CapCharacterSet Property |
 | See Also

1/18/2008

Holds the default character set capability of the line display device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapCharacterSet As CharacterSetCapability
public override CharacterSetCapability CapCharacterSet { get; }
public:
virtual property CharacterSetCapability CapCharacterSet {
    CharacterSetCapability get () override;
}
/** @property */
public CharacterSetCapability get_CapCharacterSet ()

public override function get CapCharacterSet () : CharacterSetCapability

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves the value of LineDisplayProperties.CapCharacterSet.

CapCharacterSet is initialized to CharacterSetCapability.Numeric by the LineDisplayProperties class. The LineDisplayProperties class may throw a PosControlException with the following ErrorCode:

Value | Meaning
Illegal | The service object has set CapCharacterSet to an invalid CharacterSetCapability value.

The service object should update CapCharacterSet to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.CapCharacterSet Property
CharacterSetCapability Enumeration


LineDisplayBase.CapCursorType Property

LineDisplayBase.CapCursorType Property |
 | See Also

1/18/2008

Holds a bitwise indication of the cursor types supported by the line display device, selectable via the CursorType property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapCursorType As DisplayCursors
public override DisplayCursors CapCursorType { get; }
public:
virtual property DisplayCursors CapCursorType {
    DisplayCursors get () override;
}
/** @property */
public DisplayCursors get_CapCursorType ()

public override function get CapCursorType () : DisplayCursors

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves the value of LineDisplayProperties.CapCursorType.

CapCursorType is initialized to DisplayCursors.None by the LineDisplayProperties class. The service object should update CapCursorType to an appropriate value in its Open method. The LineDisplayBase class may throw a PosControlException with the following ErrorCode:

Value | Meaning
Illegal | The specified value is an invalid DisplayCursors value; or One of the specified values is DisplayCursors.Fixed but another flag wasn’t included.

Otherwise, LineDisplayProperties class uses the specified value to set LineDisplayProperties.CapCursorType.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
DisplayCursors Enumeration
LineDisplay.CapCursorType Property


LineDisplayBase.CapCustomGlyph Property

LineDisplayBase.CapCustomGlyph Property |
 | See Also

1/18/2008

If true, the device supports custom glyph definition.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapCustomGlyph As Boolean
public override bool CapCustomGlyph { get; }
public:
virtual property bool CapCustomGlyph {
    bool get () override;
}
/** @property */
public boolean get_CapCustomGlyph ()

public override function get CapCustomGlyph () : boolean

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves the value of LineDisplayProperties.CapCustomGlyph.

CapCustomGlyph is initialized to false by the LineDisplayProperties class. The service object should update CapCustomGlyph to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.CapCustomGlyph Property


LineDisplayBase.CapDescriptors Property

LineDisplayBase.CapDescriptors Property |
 | See Also

1/18/2008

If true, the device supports descriptors.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapDescriptors As Boolean
public override bool CapDescriptors { get; }
public:
virtual property bool CapDescriptors {
    bool get () override;
}
/** @property */
public boolean get_CapDescriptors ()

public override function get CapDescriptors () : boolean

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves the value of LineDisplayProperties.CapDescriptors.

CapDescriptors is initialized to false by the LineDisplayProperties class. The service object should update CapDescriptors to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.CapDescriptors Property


LineDisplayBase.CapHMarquee Property

LineDisplayBase.CapHMarquee Property |
 | See Also

1/18/2008

If true, the device supports horizontal marquee windows.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapHMarquee As Boolean
public override bool CapHMarquee { get; }
public:
virtual property bool CapHMarquee {
    bool get () override;
}
/** @property */
public boolean get_CapHMarquee ()

public override function get CapHMarquee () : boolean

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves the value of LineDisplayProperties.CapHMarquee.

CapHMarquee is initialized to true by the LineDisplayProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.CapHMarquee Property


LineDisplayBase.CapICharWait Property

LineDisplayBase.CapICharWait Property |
 | See Also

1/18/2008

If true, the device supports inter-character wait.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapICharWait As Boolean
public override bool CapICharWait { get; }
public:
virtual property bool CapICharWait {
    bool get () override;
}
/** @property */
public boolean get_CapICharWait ()

public override function get CapICharWait () : boolean

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves the value of LineDisplayProperties.CapICharWait.

CapICharWait is initialized to true by the LineDisplayProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.CapICharWait Property


LineDisplayBase.CapMapCharacterSet Property

LineDisplayBase.CapMapCharacterSet Property |
 | See Also

1/18/2008

If true, then the service object is able to map the characters provided by the application to the character sets defined in the CharacterSetList property when displaying data.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapMapCharacterSet As Boolean
public override bool CapMapCharacterSet { get; }
public:
virtual property bool CapMapCharacterSet {
    bool get () override;
}
/** @property */
public boolean get_CapMapCharacterSet ()

public override function get CapMapCharacterSet () : boolean

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves the value of LineDisplayProperties.CapMapCharacterSet.

CapMapCharacterSet is initialized to false by the LineDisplayProperties class. The service object should update CapMapCharacterSet to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.CapMapCharacterSet Property


LineDisplayBase.CapReadBack Property

LineDisplayBase.CapReadBack Property |
 | See Also

1/18/2008

Holds the capability of the line display device to read back the data displayed on it.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapReadBack As DisplayReadBack
public override DisplayReadBack CapReadBack { get; }
public:
virtual property DisplayReadBack CapReadBack {
    DisplayReadBack get () override;
}
/** @property */
public DisplayReadBack get_CapReadBack ()

public override function get CapReadBack () : DisplayReadBack

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves the value of LineDisplayProperties.CapDisplayReadBack.

CapReadBack is initialized to DisplayReadBack.Single by the LineDisplayProperties class. The LineDisplayProperties class may throw a PosControlException with the following ErrorCode:

Value | Meaning
Illegal | The CapReadBack property has been set to an invalid DisplayReadBack value.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.CapReadBack Property
DisplayReadBack Enumeration


LineDisplayBase.CapReverse Property

LineDisplayBase.CapReverse Property |
 | See Also

1/18/2008

Holds the reverse video capability of the line display device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapReverse As DisplayReverse
public override DisplayReverse CapReverse { get; }
public:
virtual property DisplayReverse CapReverse {
    DisplayReverse get () override;
}
/** @property */
public DisplayReverse get_CapReverse ()

public override function get CapReverse () : DisplayReverse

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves the value of LineDisplayProperties.CapReverse.

CapReverse is initialized to DisplayReverse.None by the LineDisplayProperties class. The service object should update CapReverse to an appropriate value in its Open method. The LineDisplayProperties class may throw a PosControlException with the following ErrorCode:

Value | Meaning
Illegal | The service object has specified an invalid DisplayReverse value.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.CapReverse Property
DisplayReverse Enumeration


LineDisplayBase.CapScreenMode Property

LineDisplayBase.CapScreenMode Property |
 | See Also

1/18/2008

If true, the line display device supports changing the screen mode (that is, the number of text rows and columns).

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapScreenMode As Boolean
public override bool CapScreenMode { get; }
public:
virtual property bool CapScreenMode {
    bool get () override;
}
/** @property */
public boolean get_CapScreenMode ()

public override function get CapScreenMode () : boolean

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves the value of LineDisplayProperties.CapScreenMode.

CapScreenMode is initialized to false by the LineDisplayProperties class. The service object should update CapScreenMode to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.CapScreenMode Property


LineDisplayBase.CapVMarquee Property

LineDisplayBase.CapVMarquee Property |
 | See Also

1/18/2008

If true, the device supports vertical marquee windows.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapVMarquee As Boolean
public override bool CapVMarquee { get; }
public:
virtual property bool CapVMarquee {
    bool get () override;
}
/** @property */
public boolean get_CapVMarquee ()

public override function get CapVMarquee () : boolean

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves the value of LineDisplayProperties.CapVMarquee.

CapVMarquee is initialized to true by the LineDisplayProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.CapVMarquee Property


LineDisplayBase.CharacterSet Property

LineDisplayBase.CharacterSet Property |
 | See Also

1/18/2008

Holds the character set for displaying characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property CharacterSet As Integer
public override int CharacterSet { get; set; }
public:
virtual property int CharacterSet {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_CharacterSet ()

/** @property */
public void set_CharacterSet (int value)

public override function get CharacterSet () : int

public override function set CharacterSet (value : int)

Remarks

LineDisplayBase class verifies that the device has been opened, claimed, and enabled, then retrieves or sets the value of LineDisplayProperties.CharacterSet.

CharacterSet may be one of the following ranges or values:

Value | Meaning
Range 101 - 199 | A device-specific character set that does not match a code page or the ASCII or Windows ANSI character sets.
Range 400 - 990 | Code page; matches one of the standard values.
CharacterSetUnicode | The character set supports Unicode. The value of this constant is 997.
CharacterSetAscii | The ASCII character set, supporting the ASCII characters between 20-hex and 7F-hex. The value of this constant is 998.
CharacterSetAnsi | The Windows ANSI character set. The value of this constant is 999. This is exactly equivalent to the Windows code page 1252.
Range 1000 and higher | Windows code page; matches one of the standard values.

Accessing CharacterSet may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | CharacterSet has been set to a value that doesn’t exist in the character sets listed for the CharacterSetList property.

CharacterSet is initialized to 0 (zero) by the LineDisplayProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.CharacterSetList Property
LineDisplay.CharacterSet Property


LineDisplayBase.CharacterSetList Property

LineDisplayBase.CharacterSetList Property |
 | See Also

1/18/2008

Holds a string of character set numbers.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CharacterSetList As Integer()
public override int[] CharacterSetList { get; }
public:
virtual property array<int>^ CharacterSetList {
    array<int>^ get () override;
}
/** @property */
public int[] get_CharacterSetList ()

public override function get CharacterSetList () : int[]

Remarks

The string consists of ASCII numeric set numbers separated by commas. For example, if the string is "101,850,999", then the device supports a device-specific character set, code page 850, and the Windows ANSI character set.

LineDisplayBase class verifies that the device has been opened, then retrieves the value of LineDisplayProperties.CharacterSetList. If the value retrieved is null, the CharacterSetList property returns an empty integer array.

CharacterSetList is initialized to an empty integer array by the LineDisplayProperties class. The service object should update CharacterSetList to an appropriate value in its Open method. The LineDisplayProperties class may throw a PosControlException with the following ErrorCode:

Value | Meaning
Illegal | The service object has set CharacterSetList to a null value, a list length of 0, or has set one of the specified values to less than 0 (zero.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.CharacterSetList Property


LineDisplayBase.Columns Property

LineDisplayBase.Columns Property |
 | See Also

1/18/2008

Holds the number of columns for this window.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property Columns As Integer
public override int Columns { get; }
public:
virtual property int Columns {
    int get () override;
}
/** @property */
public int get_Columns ()

public override function get Columns () : int

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves the value of LineDisplayProperties.Columns, which is the Columns value for the service object’s current window.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.Columns Property


LineDisplayBase.CurrentWindow Property

LineDisplayBase.CurrentWindow Property |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property CurrentWindow As Integer
public override int CurrentWindow { get; set; }
public:
virtual property int CurrentWindow {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_CurrentWindow ()

/** @property */
public void set_CurrentWindow (int value)

public override function get CurrentWindow () : int

public override function set CurrentWindow (value : int)

Remarks

Several properties are associated with each window: Rows, Columns, CursorRow, CursorColumn, CursorUpdate, CursorType, MarqueeFormat, MarqueeType, MarqueeUnitWait, MarqueeRepeatWait, and InterCharacterWait.

When the application sets CurrentWindow, it changes the current window (for display purposes) and sets the associated properties to their values for this window.

Setting a window does not refresh its viewport. If this window and another window’s viewports overlap, and the other window has changed the viewport, then the application can call the RefreshWindow method to restore this window’s viewport contents.

LineDisplayBase class verifies that the device has been opened, then retrieves or sets the value of LineDisplayProperties.CurrentWindow.

Accessing CurrentWindow may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | CurrentWindow has been set to a value that isn’t valid.

CurrentWindow is initialized to 0 (zero) by the LineDisplayProperties class. If the value of CurrentWindow changes, the LineDisplayProperties class queues a CurrentWindowChangedEvent event to the service object.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.CurrentWindow Property


LineDisplayBase.CursorColumn Property

LineDisplayBase.CursorColumn Property |
 | See Also

1/18/2008

Holds the column in the current window to which the next displayed character will be output.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property CursorColumn As Integer
public override int CursorColumn { get; set; }
public:
virtual property int CursorColumn {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_CursorColumn ()

/** @property */
public void set_CursorColumn (int value)

public override function get CursorColumn () : int

public override function set CursorColumn (value : int)

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves or sets the value of LineDisplayProperties.CursorColumn, which is the CursorColumn value for the service object’s current window. Accessing CursorColumn may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | CursorColumn was set to a value that isn’t valid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.CursorColumn Property


LineDisplayBase.CursorDeviceColumn Property

LineDisplayBase.CursorDeviceColumn Property |
 | See Also

1/18/2008

Translates the CursorColumn value into a device coordinate by returning an integer that represents the value of the CursorColumn property added to the current window’s start column value.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected ReadOnly Property CursorDeviceColumn As Integer
protected int CursorDeviceColumn { get; }
protected:
property int CursorDeviceColumn {
    int get ();
}
/** @property */
protected int get_CursorDeviceColumn ()

protected function get CursorDeviceColumn () : int

Remarks

Translates the CursorColumn value into a device coordinate by returning an integer that represents the value of the CursorColumn property added to the current window’s start column value.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


LineDisplayBase.CursorDeviceRow Property

LineDisplayBase.CursorDeviceRow Property |
 | See Also

1/18/2008

Translates the CursorRow value into a device coordinate by returning an integer that represents the value of the CursorRow property added to the current window’s start row value.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected ReadOnly Property CursorDeviceRow As Integer
protected int CursorDeviceRow { get; }
protected:
property int CursorDeviceRow {
    int get ();
}
/** @property */
protected int get_CursorDeviceRow ()

protected function get CursorDeviceRow () : int

Remarks

Translates the CursorRow value into a device coordinate by returning an integer that represents the value of the CursorRow property added to the current window’s start row value.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


LineDisplayBase.CursorRow Property

LineDisplayBase.CursorRow Property |
 | See Also

1/18/2008

Holds the row in the current window to which the next displayed character will be output.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property CursorRow As Integer
public override int CursorRow { get; set; }
public:
virtual property int CursorRow {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_CursorRow ()

/** @property */
public void set_CursorRow (int value)

public override function get CursorRow () : int

public override function set CursorRow (value : int)

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves or sets the value of LineDisplayProperties.CursorRow, which is the CursorRow value for the service object’s current window. When an attempt is made to set CursorRow, the LineDisplayBase class may throw a PosControlException with the following ErrorCode:

Value | Meaning
Illegal | The specified value is less than 0 (zero) or greater than the value of the Rows property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.CursorRow Property


LineDisplayBase.CursorType Property

LineDisplayBase.CursorType Property |
 | See Also

1/18/2008

Holds the cursor type for the current window. Possible values are defined by the DisplayCursors enumeration.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property CursorType As DisplayCursors
public override DisplayCursors CursorType { get; set; }
public:
virtual property DisplayCursors CursorType {
    DisplayCursors get () override;
    void set (DisplayCursors value) override;
}
/** @property */
public DisplayCursors get_CursorType ()

/** @property */
public void set_CursorType (DisplayCursors value)

public override function get CursorType () : DisplayCursors

public override function set CursorType (value : DisplayCursors)

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves or sets the value of LineDisplayProperties.CursorType, which is the CursorType value for the service object’s current window. When an attempt is made to set CursorType, LineDisplayProperties class may throw a PosControlException with the following ErrorCode:

Value

Meaning

Illegal

  • If the CapCursorType property is set to either DisplayCursors.None or DisplayCursors.Fixed;

  • If the specified value is DisplayCursors.Blink and blinking isn’t supported;

  • If the specified value isn’t a valid DisplayCursors value; or

  • If the specified value isn’t one of the values specified for the CapCursorType property.

When the value of CursorType changes, the LineDisplayBase class queues a CursorTypeChangedEvent event to the service object.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.CursorType Property
DisplayCursors Enumeration
LineDisplay.CapCursorType Property
CursorTypeChangedEvent


LineDisplayBase.CursorUpdate Property

LineDisplayBase.CursorUpdate Property |
 | See Also

1/18/2008

If true when characters are displayed using the DisplayText and DisplayTextAt methods, then the CursorRow and CursorColumn properties will be updated to point to the character beyond the last character output.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property CursorUpdate As Boolean
public override bool CursorUpdate { get; set; }
public:
virtual property bool CursorUpdate {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_CursorUpdate ()

/** @property */
public void set_CursorUpdate (boolean value)

public override function get CursorUpdate () : boolean

public override function set CursorUpdate (value : boolean)

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves or sets the value of LineDisplayProperties.CursorUpdate, which is the CursorUpdate value for the service object’s current window.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.CursorUpdate Property


LineDisplayBase.CursorVisible Property

LineDisplayBase.CursorVisible Property |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected ReadOnly Property CursorVisible As Boolean
protected bool CursorVisible { get; }
protected:
property bool CursorVisible {
    bool get ();
}
/** @property */
protected boolean get_CursorVisible ()

protected function get CursorVisible () : boolean

Remarks

Returns true if the values of the CursorColumn and CursorHeight properties are less than the current window’s width and height, respectively.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


LineDisplayBase.CustomGlyphList Property

LineDisplayBase.CustomGlyphList Property |
 | See Also

1/18/2008

Holds an array of instances of the RangeOfCharacters helper class, which represents the character code ranges that are available for defining glyphs.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CustomGlyphList As RangeOfCharacters()
public override RangeOfCharacters[] CustomGlyphList { get; }
public:
virtual property array<RangeOfCharacters^>^ CustomGlyphList {
    array<RangeOfCharacters^>^ get () override;
}
/** @property */
public RangeOfCharacters[] get_CustomGlyphList ()

public override function get CustomGlyphList () : RangeOfCharacters[]

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves the value of LineDisplayProperties.CustomGlyphList. If the value retrieved is null or the CapCustomGlyph property is set to false, the CustomGlyphList property returns an empty RangeOfCharacters array.

CustomGlyphList is initialized to a RangeOfCharacters array of 1 containing the full range of characters by the LineDisplayProperties class.

Note:
To support glyphs, the service object must set the GlyphHeight and GlyphWidth properties to greater than zero and set the CapCustomGlyph property to true.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.CustomGlyphList Property
RangeOfCharacters Class


LineDisplayBase.DeviceBrightness Property

LineDisplayBase.DeviceBrightness Property |
 | See Also

1/18/2008

Holds the device brightness value, expressed as a percentage between 0 and 100.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property DeviceBrightness As Integer
public override int DeviceBrightness { get; set; }
public:
virtual property int DeviceBrightness {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_DeviceBrightness ()

/** @property */
public void set_DeviceBrightness (int value)

public override function get DeviceBrightness () : int

public override function set DeviceBrightness (value : int)

Remarks

LineDisplayBase class verifies that the device has been opened, claimed, and enabled, then retrieves or sets the value of LineDisplayProperties.DeviceBrightness.

Any device can support 0% (blank) and 100% (full intensity). The service object can also support blanking by sending spaces to the device. If the CapBrightness property is set to true, then the device also supports one or more levels of dimming.

If the line display device does not support the brightness value specified by the application, then the service object will choose an appropriate substitute.

Accessing DeviceBrightness may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | One of the following conditions has occurred: The CapBrightness property is set to false, indicating the device doesn’t support the setting of brightness values, but DeviceBrightness was set to a value other than 100; or DeviceBrightness was set to a value less than 0 (zero) or greater than 100.

DeviceBrightness is initialized to 100 by the LineDisplayProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.CapBrightness Property
LineDisplay.DeviceBrightness Property


LineDisplayBase.DeviceColumns Property

LineDisplayBase.DeviceColumns Property |
 | See Also

1/18/2008

Holds the number of columns on this device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property DeviceColumns As Integer
public override int DeviceColumns { get; }
public:
virtual property int DeviceColumns {
    int get () override;
}
/** @property */
public int get_DeviceColumns ()

public override function get DeviceColumns () : int

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves the value of LineDisplayProperties.DeviceColumns, which is the ScreenModeList.Columns value for the current Screen Mode.

DeviceColumns is initialized to 0 (zero) by the LineDisplayProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.DeviceColumns Property
LineDisplay.ScreenModeList Property


LineDisplayBase.DeviceDescriptors Property

LineDisplayBase.DeviceDescriptors Property |
 | See Also

1/18/2008

Holds the number of descriptors on this device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property DeviceDescriptors As Integer
public override int DeviceDescriptors { get; }
public:
virtual property int DeviceDescriptors {
    int get () override;
}
/** @property */
public int get_DeviceDescriptors ()

public override function get DeviceDescriptors () : int

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves the value of LineDisplayProperties.DeviceDescriptors.

DeviceDescriptors is initialized to 0 (zero) by the LineDisplayProperties class. If the service object sets DeviceDescriptors, the LineDisplayProperties class may cause a PosControlException to be thrown with the following ErrorCode:

Value

Meaning

Illegal

  • The value specified is 0 (zero); or

  • The CapDescriptors property is set to false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.DeviceDescriptors Property
LineDisplayBase.CapDescriptors Property


LineDisplayBase.DeviceRows Property

LineDisplayBase.DeviceRows Property |
 | See Also

1/18/2008

Holds the number of rows on this device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property DeviceRows As Integer
public override int DeviceRows { get; }
public:
virtual property int DeviceRows {
    int get () override;
}
/** @property */
public int get_DeviceRows ()

public override function get DeviceRows () : int

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves the value of LineDisplayProperties.DeviceRows, which is the ScreenModeList.Rows value for the current Screen Mode.

DeviceRows is initialized to 0 (zero) by the LineDisplayProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.DeviceRows Property
LineDisplay.ScreenModeList Property


LineDisplayBase.DeviceWindows Property

LineDisplayBase.DeviceWindows Property |
 | See Also

1/18/2008

Holds the maximum number of windows supported by the line display device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property DeviceWindows As Integer
public override int DeviceWindows { get; }
public:
virtual property int DeviceWindows {
    int get () override;
}
/** @property */
public int get_DeviceWindows ()

public override function get DeviceWindows () : int

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves the value of LineDisplayProperties.DeviceWindows.

DeviceWindows is initialized to 7 (seven) by the LineDisplayProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.DeviceWindows Property


LineDisplayBase.GlyphHeight Property

LineDisplayBase.GlyphHeight Property |
 | See Also

1/18/2008

Indicates the glyph height based on the number of pixels for a character cell.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property GlyphHeight As Integer
public override int GlyphHeight { get; }
public:
virtual property int GlyphHeight {
    int get () override;
}
/** @property */
public int get_GlyphHeight ()

public override function get GlyphHeight () : int

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves the value of LineDisplayProperties.GlyphHeight, which is the ScreenModeList.GlyphHeight value for the current Screen Mode.

GlyphHeight is initialized to 0 (zero) by the LineDisplayProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.GlyphHeight Property
LineDisplay.ScreenModeList Property


LineDisplayBase.GlyphWidth Property

LineDisplayBase.GlyphWidth Property |
 | See Also

1/18/2008

Indicates the glyph width based on the number of pixels for a character cell.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property GlyphWidth As Integer
public override int GlyphWidth { get; }
public:
virtual property int GlyphWidth {
    int get () override;
}
/** @property */
public int get_GlyphWidth ()

public override function get GlyphWidth () : int

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves the value of LineDisplayProperties.GlyphWidth, which is the ScreenModeList.GlyphWidth value for the current Screen Mode.

GlyphWidth is initialized to 0 (zero) by the LineDisplayProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.GlyphWidth Property
LineDisplay.ScreenModeList Property


LineDisplayBase.InterCharacterWait Property

LineDisplayBase.InterCharacterWait Property |
 | See Also

1/18/2008

Holds the wait time, specified in milliseconds, between the display of each character with the DisplayText and DisplayTextAt methods.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property InterCharacterWait As Integer
public override int InterCharacterWait { get; set; }
public:
virtual property int InterCharacterWait {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_InterCharacterWait ()

/** @property */
public void set_InterCharacterWait (int value)

public override function get InterCharacterWait () : int

public override function set InterCharacterWait (value : int)

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves or sets the value of LineDisplayProperties.InterCharacterWait, which is the InterCharacterWait value for the service object’s current window. When an attempt is made to set InterCharacterWait, LineDisplayBase may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The specified value is less than 0 (zero) or the CapICharWait property is set to false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


LineDisplayBase.LineDisplayScreenModes Property

LineDisplayBase.LineDisplayScreenModes Property |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Friend MustOverride ReadOnly Property LineDisplayScreenModes As LineDisplayScreenMode()
protected internal abstract LineDisplayScreenMode[] LineDisplayScreenModes { get; }
protected public:
virtual property array<LineDisplayScreenMode^>^ LineDisplayScreenModes {
    array<LineDisplayScreenMode^>^ get () abstract;
}
/** @property */
protected abstract LineDisplayScreenMode[] get_LineDisplayScreenModes ()

protected internal abstract function get LineDisplayScreenModes () : LineDisplayScreenMode[]

Remarks

Returns an instance of the LineDisplayScreenModes helper class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.LineDisplayScreenModes Property


LineDisplayBase.MapCharacterSet Property

LineDisplayBase.MapCharacterSet Property |
 | See Also

1/18/2008

If true, then the service object is able to map the characters provided by the application to the character sets defined in the CharacterSetList property when displaying data.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property MapCharacterSet As Boolean
public override bool MapCharacterSet { get; set; }
public:
virtual property bool MapCharacterSet {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_MapCharacterSet ()

/** @property */
public void set_MapCharacterSet (boolean value)

public override function get MapCharacterSet () : boolean

public override function set MapCharacterSet (value : boolean)

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves or sets the value of LineDisplayProperties.MapCharacterSet. The LineDisplayBase class may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The application has set MapCharacterSet and CapMapCharacterSet to false.

MapCharacterSet is initialized to false by the LineDisplayProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.MapCharacterSet Property
LineDisplay.CapMapCharacterSet Property


LineDisplayBase.MarqueeFormat Property

LineDisplayBase.MarqueeFormat Property |
 | See Also

1/18/2008

Holds the marquee format for the current window.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property MarqueeFormat As DisplayMarqueeFormat
public override DisplayMarqueeFormat MarqueeFormat { get; set; }
public:
virtual property DisplayMarqueeFormat MarqueeFormat {
    DisplayMarqueeFormat get () override;
    void set (DisplayMarqueeFormat value) override;
}
/** @property */
public DisplayMarqueeFormat get_MarqueeFormat ()

/** @property */
public void set_MarqueeFormat (DisplayMarqueeFormat value)

public override function get MarqueeFormat () : DisplayMarqueeFormat

public override function set MarqueeFormat (value : DisplayMarqueeFormat)

Remarks

Value | Meaning
Walk | Begin the marquee by 'walking' data from the opposite side. For example, if the marquee type is Left, then the viewport is filled by bringing characters in from the right side and scrolling them to the left.
Place | Begin the marquee by placing data. For example, if the marquee type is Left, then the viewport is filled by placing characters starting at the left side, and beginning scrolling only after the viewport is full.

MarqueeFormat is read when a transition is made to Marquee On mode. It is not used when not in Marquee mode.

When MarqueeFormat is Walk, and a transition is made from Marquee Init mode to Marquee On mode, the following occurs:

  1. Map the window to the viewport as follows:

    Marquee Type

    Window

    Viewport

    Left

    First Column

    Last Column

    Up

    First Row

    Last Row

    Right

    Last Column

    First Column

    Down

    Last Row

    First Row

    Fill the viewport with blanks. Continue to Step 2 without waiting.

  2. Display the mapped portion of the window into the viewport, then wait MarqueeUnitWait milliseconds. Move the window mapping onto the viewport by one row or column in the marquee direction. Repeat until the viewport is full.

  3. Refresh the viewport and wait MarqueeUnitWait milliseconds. Move the window mapping by one row or column. Repeat until the last row or column is scrolled into the viewport (in which case, omit the unit wait).

  4. Wait MarqueeRepeatWait milliseconds. Then go to step back to Step 1.

When MarqueeFormat is Place, and a transition is made from Marquee Init mode to Marquee On mode, the following occurs:

  1. Map the window to the viewport as follows:

    Marquee Type

    Window

    Viewport

    Left

    Column

    First Column

    Up

    First Row

    First Row

    Right

    Last Column

    Last Column

    Down

    Last Row

    Last Row

    Fill the viewport with blanks. Continue to Step 2 without waiting.

  2. Display a row or column into viewport, then wait MarqueeUnitWait milliseconds. Repeat until the viewport is full.

  3. Move the window mapping onto the viewport by one row or column in the marquee direction, and refresh the viewport, then wait MarqueeUnitWait milliseconds. Repeat until the last row or column is scrolled into the viewport (in which case, omit the unit wait).

  4. Wait MarqueeRepeatWait milliseconds. Then go to step back to Step 1.

LineDisplayBase class verifies that the device has been opened, then retrieves or sets the value of LineDisplayProperties.MarqueeFormat, which is the MarqueeFormat value for the service object’s current window. Accessing MarqueeFormat may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | One of the following conditions occurred: The value specified for MarqueeFormat isn’t found in the DisplayMarqueeFormat enumeration, or The current window is Window 0—marquee format can’t be changed for Window 0.

Otherwise, the LineDisplayPropertiesClass sets the service object’s current window’s MarqueeFormat to the specified value.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.MarqueeFormat Property
DisplayMarqueeFormat Enumeration


LineDisplayBase.MarqueeRepeatWait Property

LineDisplayBase.MarqueeRepeatWait Property |
 | See Also

1/18/2008

Holds the wait time, specified in milliseconds, between scrolling the final character or row of the window into its viewport and restarting the marquee with the first or last character or row.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property MarqueeRepeatWait As Integer
public override int MarqueeRepeatWait { get; set; }
public:
virtual property int MarqueeRepeatWait {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_MarqueeRepeatWait ()

/** @property */
public void set_MarqueeRepeatWait (int value)

public override function get MarqueeRepeatWait () : int

public override function set MarqueeRepeatWait (value : int)

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves or sets the value of LineDisplayProperties.MarqueeRepeatWait, which is the MarqueeRepeatWait value for the service object’s current window. Accessing MarqueeRepeatWait may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The value specified is less than 0 (zero).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.MarqueeRepeatWait Property


LineDisplayBase.MarqueeType Property

LineDisplayBase.MarqueeType Property |
 | See Also

1/18/2008

Holds the marquee type for the current window.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property MarqueeType As DisplayMarqueeType
public override DisplayMarqueeType MarqueeType { get; set; }
public:
virtual property DisplayMarqueeType MarqueeType {
    DisplayMarqueeType get () override;
    void set (DisplayMarqueeType value) override;
}
/** @property */
public DisplayMarqueeType get_MarqueeType ()

/** @property */
public void set_MarqueeType (DisplayMarqueeType value)

public override function get MarqueeType () : DisplayMarqueeType

public override function set MarqueeType (value : DisplayMarqueeType)

Remarks

Possible values are defined by the DisplayMarqueeType enumeration. When not set to None, the window is in Marquee mode. Valid values are:

Value | Meaning
None | Marquees are disabled for this window.
Init | Marquee Init mode. Changes to the window are not reflected in the viewport until MarqueeType is changed to another value.
Up | Scroll the window up. Illegal unless Rows is greater than the viewportHeight parameter used for the window’s CreateWindow method, and the service object has set the CapVMarquee property to true.
Down | Scroll the window down. Illegal unless Rows is greater than the viewportHeight parameter used for the window’s CreateWindow method, and the service object has set the CapVMarquee property to true.
Left | Scroll the window left. Illegal unless Columns is greater than the viewportWidth parameter used for the window’s CreateWindow method, and the service object has set the CapHMarquee property to true.
Right | Scroll the window right. Illegal unless Columns is greater than the viewportWidth parameter used for the window’s CreateWindow method, and the service object has set the CapHMarquee property to true.

LineDisplayBase class verifies that the device has been opened, then retrieves or sets the value of LineDisplayProperties.MarqueeType, which is the MarqueeType value for the service object’s current window. When MarqueeType is set, the LineDisplayProperties class may cause a PosControlException to be thrown with the following ErrorCode:

Value

Meaning

Illegal

  • If the specified MarqueeType is not a valid DisplayMarqueeType value;

  • If the Current Window is 0 (zero);

  • If the specified MarqueeType is either DisplayMarqueeType.Up or DisplayMarqueeType.Down and the CapVMarquee property is set to false, indicating that vertical marquees aren’t supported;

  • If the specified MarqueeType is either DisplayMarqueeType.Left or DisplayMarqueeType.Right and the CapHMarquee property is set to false, indicating that horizontal marquees aren’t supported;

  • If the specified MarqueeType is either DisplayMarqueeType.Left or DisplayMarqueeType.Right and the current value of the Width property is greater than the current window’s Columns value; or

  • If the specified MarqueeType is either DisplayMarqueeType.Up or DisplayMarqueeType.Down and the current value of the Height property is greater than the current window’s Rows value.

Otherwise, the LineDisplayPropertiesClass sets the service object’s current window’s MarqueeType to the specified value.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.MarqueeType Property
DisplayMarqueeType Enumeration
LineDisplay.CapHMarquee Property
LineDisplay.CapVMarquee Property


LineDisplayBase.MarqueeUnitWait Property

LineDisplayBase.MarqueeUnitWait Property |
 | See Also

1/18/2008

Holds the wait time, specified in milliseconds, between marquee scrolling of each column or row in the window.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property MarqueeUnitWait As Integer
public override int MarqueeUnitWait { get; set; }
public:
virtual property int MarqueeUnitWait {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_MarqueeUnitWait ()

/** @property */
public void set_MarqueeUnitWait (int value)

public override function get MarqueeUnitWait () : int

public override function set MarqueeUnitWait (value : int)

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves the value of LineDisplayProperties.MarqueeUnitWait, which is the MarqueeUnitWait value for the service object’s current window. Accessing MarqueeUnitWait may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The wait value specified was less than 0 (zero).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.MarqueeUnitWait Property


LineDisplayBase.MaximumX Property

LineDisplayBase.MaximumX Property |
 | See Also

1/18/2008

Contains the maximum number of horizontal pixels supported by the device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property MaximumX As Integer
public override int MaximumX { get; }
public:
virtual property int MaximumX {
    int get () override;
}
/** @property */
public int get_MaximumX ()

public override function get MaximumX () : int

Remarks

Otherwise, MaximumX contains the maximum number of horizontal pixels supported by the device. It must be less than 65,536. Dividing MaximumX by the DeviceColumns property value gives the number of pixels required for each character.

The service object may update the MaximumX property when the ScreenMode property is changed.

LineDisplayBase class verifies that the device has been opened, then retrieves the value of LineDisplayProperties.MaximumX, which is the MaximumX value currently stored by the LineDisplayScreenMode class for the current Screen Mode. If the CapBitmap property is set to false, the MaximumX property returns 0 (zero).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.MaximumX Property
LineDisplayScreenMode


LineDisplayBase.MaximumY Property

LineDisplayBase.MaximumY Property |
 | See Also

1/18/2008

Contains the maximum number of vertical pixels supported by the device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property MaximumY As Integer
public override int MaximumY { get; }
public:
virtual property int MaximumY {
    int get () override;
}
/** @property */
public int get_MaximumY ()

public override function get MaximumY () : int

Remarks

Otherwise, MaximumY contains the maximum number of vertical pixels supported by the device. It must be less than 65, 536. Dividing MaximumY by the value of the DeviceRows property gives the number of pixels required for each character.

LineDisplayBase class verifies that the device has been opened, then retrieves the value of LineDisplayProperties.MaximumY, which is the MaximumY value currently stored by the LineDisplayScreenMode class for the current Screen Mode. If the CapBitmap property is set to false, the MaximumY property returns 0 (zero).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.MaximumY Property
LineDisplayScreenMode


LineDisplayBase.Properties Property

LineDisplayBase.Properties Property |
 | See Also

1/18/2008

Returns an instance of the LineDisplayProperties helper class, containing getters and setters for LineDisplay and common properties.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected ReadOnly Property Properties As LineDisplayProperties
protected LineDisplayProperties Properties { get; }
protected:
property LineDisplayProperties^ Properties {
    LineDisplayProperties^ get ();
}
/** @property */
protected LineDisplayProperties get_Properties ()

protected function get Properties () : LineDisplayProperties

Remarks

Returns an instance of the LineDisplayProperties helper class, containing getters and setters for LineDisplay and common properties. Service objects should use LineDisplayProperties class to set properties that are typically designated read-only for applications. The device doesn't have to be opened, claimed, or enabled to set LineDisplayProperties class properties.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


LineDisplayBase.Rows Property

LineDisplayBase.Rows Property |
 | See Also

1/18/2008

Holds the number of rows for this window.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property Rows As Integer
public override int Rows { get; }
public:
virtual property int Rows {
    int get () override;
}
/** @property */
public int get_Rows ()

public override function get Rows () : int

Remarks

For window 0, Rows is the same as the value of the DeviceRows property. For other windows, it can be less or greater than DeviceRows.

LineDisplayBase class verifies that the device has been opened, then retrieves the value of LineDisplayProperties.Rows, which is the Rows value for the service object’s current window.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.Rows Property


LineDisplayBase.ScreenMode Property

LineDisplayBase.ScreenMode Property |
 | See Also

1/18/2008

Holds the screen mode value of the device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property ScreenMode As Integer
public override int ScreenMode { get; set; }
public:
virtual property int ScreenMode {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_ScreenMode ()

/** @property */
public void set_ScreenMode (int value)

public override function get ScreenMode () : int

public override function set ScreenMode (value : int)

Remarks

LineDisplayBase class verifies that the device has been opened and claimed but not enabled, then retrieves or sets the value of LineDisplayProperties.ScreenMode. If an attempt is made to set ScreenMode while the device is enabled, the LineDisplayBase class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal. If an attempt is made to change ScreenMode, the LineDisplayProperties class may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The CapScreenMode property is set to false, indicating that screen modes aren’t supported; or The value specified doesn’t exist in the ScreenModeList property.

Otherwise, when the value of ScreenMode changes, the LineDisplayProperties class does the following:

  • If the values of the GlyphHeight and GlyphWidth properties have changed, the old values are destroyed;

  • The existing windows are destroyed;

  • The device window is recreated; and

  • A ScreenModeChangedEvent event is queued to the service object.

ScreenMode is initialized to 0 (zero) by the LineDisplayProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.ScreenMode Property
LineDisplay.GlyphHeight Property
LineDisplay.GlyphWidth Property
ScreenModeChangedEvent


LineDisplayBase.ScreenModeList Property

LineDisplayBase.ScreenModeList Property |
 | See Also

1/18/2008

Holds the array of DisplayScreenMode class instances that are supported by the device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property ScreenModeList As DisplayScreenMode()
public override DisplayScreenMode[] ScreenModeList { get; }
public:
virtual property array<DisplayScreenMode^>^ ScreenModeList {
    array<DisplayScreenMode^>^ get () override;
}
/** @property */
public DisplayScreenMode[] get_ScreenModeList ()

public override function get ScreenModeList () : DisplayScreenMode[]

Remarks

LineDisplayBase class verifies that the device has been opened, then retrieves the value of LineDisplayProperties.ScreenModeList.

ScreenModeList is initialized to an empty DisplayScreenMode array by the LineDisplayProperties class. The LineDisplayProperties class may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The service object has set ScreenModeList to an empty array or a null value.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.ScreenModeList Property
DisplayScreenMode Class


LineDisplayBase Events

LineDisplayBase Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from LineDisplayBasic )
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from LineDisplayBasic )

Protected Events

Name | Description
BlinkRateChangedEvent | Informs the service object that the value of the BlinkRate property has changed.
CurrentWindowChangedEvent | Informs the service object that the value of the CurrentWindow property has changed.
CursorTypeChangedEvent | Inform the service object that the value of the CursorType property has changed.
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
ScreenModeChangedEvent | Inform the service object that the value of the ScreenMode property has changed.
StateChangedEvent | (inherited from LineDisplayBasic )

See Also

Reference

LineDisplayBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace

Other Resources

Using Impl Methods for Synchronous or Asynchronous Output


LineDisplayBase.BlinkRateChangedEvent Event

LineDisplayBase.BlinkRateChangedEvent Event |
 | See Also

1/18/2008

Informs the service object that the value of the BlinkRate property has changed.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Event BlinkRateChangedEvent As BlinkRateChangedEventHandler
protected event BlinkRateChangedEventHandler BlinkRateChangedEvent
protected:
event BlinkRateChangedEventHandler^ BlinkRateChangedEvent {
    void add (BlinkRateChangedEventHandler^ value);
    void remove (BlinkRateChangedEventHandler^ value);
}
/** @event */
protected void add_BlinkRateChangedEvent (BlinkRateChangedEventHandler value)

/** @event */
protected void remove_BlinkRateChangedEvent (BlinkRateChangedEventHandler value)

Remarks

LineDisplayBase class queues a BlinkRateChangedEvent event to inform the service object that the value of the BlinkRate property has changed. Service objects should consider implementing BlinkRateChangedEvent when they want to be notified of blink rate changes.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.BlinkRateChangedEventHandler
LineDisplayBase.BlinkRateChangedEventHandler


LineDisplayBase.CurrentWindowChangedEvent Event

LineDisplayBase.CurrentWindowChangedEvent Event |
 | See Also

1/18/2008

Informs the service object that the value of the CurrentWindow property has changed.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Event CurrentWindowChangedEvent As CurrentWindowChangedEventHandler
protected event CurrentWindowChangedEventHandler CurrentWindowChangedEvent
protected:
event CurrentWindowChangedEventHandler^ CurrentWindowChangedEvent {
    void add (CurrentWindowChangedEventHandler^ value);
    void remove (CurrentWindowChangedEventHandler^ value);
}
/** @event */
protected void add_CurrentWindowChangedEvent (CurrentWindowChangedEventHandler value)

/** @event */
protected void remove_CurrentWindowChangedEvent (CurrentWindowChangedEventHandler value)

Remarks

LineDisplayBase class queues a CurrentWindowChangedEvent event to inform the service object that the value of the CurrentWindow property has changed. Service objects should consider implementing CurrentWindowChangedEvent when they want to be notified of window changes.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.CurrentWindowChangedEventHandler
LineDisplayBase.CurrentWindowChangedEventHandler


LineDisplayBase.CursorTypeChangedEvent Event

LineDisplayBase.CursorTypeChangedEvent Event |
 | See Also

1/18/2008

Inform the service object that the value of the CursorType property has changed.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Event CursorTypeChangedEvent As CursorTypeChangedEventHandler
protected event CursorTypeChangedEventHandler CursorTypeChangedEvent
protected:
event CursorTypeChangedEventHandler^ CursorTypeChangedEvent {
    void add (CursorTypeChangedEventHandler^ value);
    void remove (CursorTypeChangedEventHandler^ value);
}
/** @event */
protected void add_CursorTypeChangedEvent (CursorTypeChangedEventHandler value)

/** @event */
protected void remove_CursorTypeChangedEvent (CursorTypeChangedEventHandler value)

Remarks

LineDisplayBase class queues a CursorTypeChangedEvent event to inform the service object that the value of the CursorType property has changed. Service objects should consider implementing CursorTypeChangedEvent when they want to be notified of cursor type changes.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.CursorTypeChangedEventHandler
LineDisplayBase.CursorTypeChangedEventHandler


LineDisplayBase.ScreenModeChangedEvent Event

LineDisplayBase.ScreenModeChangedEvent Event |
 | See Also

1/18/2008

Inform the service object that the value of the ScreenMode property has changed.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Event ScreenModeChangedEvent As ScreenModeChangedEventHandler
protected event ScreenModeChangedEventHandler ScreenModeChangedEvent
protected:
event ScreenModeChangedEventHandler^ ScreenModeChangedEvent {
    void add (ScreenModeChangedEventHandler^ value);
    void remove (ScreenModeChangedEventHandler^ value);
}
/** @event */
protected void add_ScreenModeChangedEvent (ScreenModeChangedEventHandler value)

/** @event */
protected void remove_ScreenModeChangedEvent (ScreenModeChangedEventHandler value)

Remarks

LineDisplayBase class queues a ScreenModeChangedEvent event to inform the service object that the value of the ScreenMode property has changed. Service objects should consider implementing ScreenModeChangedEvent when they want to be notified of screen mode changes.

See Also

Reference

LineDisplayBase Class
LineDisplayBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.ScreenModeChangedEventHandler
LineDisplayBase.ScreenModeChangedEventHandler


LineDisplayBase.BlinkRateChangedEventHandler Delegate

LineDisplayBase.BlinkRateChangedEventHandler Delegate |
 | See Also

1/18/2008

Delegate for the BlinkRateChangedEvent protected event.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Delegate Sub BlinkRateChangedEventHandler ( _
    sender As Object, _
    e As EventArgs _
)
protected delegate void BlinkRateChangedEventHandler (
    Object sender,
    EventArgs e
)
private delegate void BlinkRateChangedEventHandler (
    Object^ sender,
    EventArgs^ e
)
/** @delegate */
protected delegate void BlinkRateChangedEventHandler (
    Object sender,
    EventArgs e
)

Parameters

sender

The service object sending the event.

e

The event, which is an instance of the EventArgs class.

Remarks

Delegate for the BlinkRateChangedEvent protected event.

See Also

Reference

Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.BlinkRateChangedEvent Event


LineDisplayBase.CurrentWindowChangedEventHandler Delegate

LineDisplayBase.CurrentWindowChangedEventHandler Delegate |
 | See Also

1/18/2008

Delegate for the CurrentWindowChangedEvent protected event.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Delegate Sub CurrentWindowChangedEventHandler ( _
    sender As Object, _
    e As EventArgs _
)
protected delegate void CurrentWindowChangedEventHandler (
    Object sender,
    EventArgs e
)
private delegate void CurrentWindowChangedEventHandler (
    Object^ sender,
    EventArgs^ e
)
/** @delegate */
protected delegate void CurrentWindowChangedEventHandler (
    Object sender,
    EventArgs e
)

Parameters

sender

The service object sending the event.

e

The event, which is an instance of an EventArgs class.

Remarks

Delegate for the CurrentWindowChangedEvent protected event.

See Also

Reference

Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.CurrentWindowChangedEvent Event


LineDisplayBase.CursorTypeChangedEventHandler Delegate

LineDisplayBase.CursorTypeChangedEventHandler Delegate |
 | See Also

1/18/2008

Delegate for the CursorTypeChangedEvent protected event.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Delegate Sub CursorTypeChangedEventHandler ( _
    sender As Object, _
    e As EventArgs _
)
protected delegate void CursorTypeChangedEventHandler (
    Object sender,
    EventArgs e
)
private delegate void CursorTypeChangedEventHandler (
    Object^ sender,
    EventArgs^ e
)
/** @delegate */
protected delegate void CursorTypeChangedEventHandler (
    Object sender,
    EventArgs e
)

Parameters

sender

The service object sending the event.

e

The event, which is an instance of the EventArgs class.

Remarks

Delegate for the CursorTypeChangedEvent protected event.

See Also

Reference

Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.CursorTypeChangedEvent Event


LineDisplayBase.ScreenModeChangedEventHandler Delegate

LineDisplayBase.ScreenModeChangedEventHandler Delegate |
 | See Also

1/18/2008

Delegate for the ScreenModeChangedEvent protected event.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Delegate Sub ScreenModeChangedEventHandler ( _
    sender As Object, _
    e As EventArgs _
)
protected delegate void ScreenModeChangedEventHandler (
    Object sender,
    EventArgs e
)
private delegate void ScreenModeChangedEventHandler (
    Object^ sender,
    EventArgs^ e
)
/** @delegate */
protected delegate void ScreenModeChangedEventHandler (
    Object sender,
    EventArgs e
)

Parameters

sender

The service object sending the event.

e

The event, which is an instance of an EventArgs class.

Remarks

Delegate for the ScreenModeChangedEvent protected event.

See Also

Reference

Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.ScreenModeChangedEvent Event


LineDisplayBitmap Class

LineDisplayBitmap Class |
 | See Also Members

1/18/2008

A helper class created by POS for .NET and used by the LineDisplayBase class for creating and displaying bitmaps.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class LineDisplayBitmap
public class LineDisplayBitmap
public ref class LineDisplayBitmap
public class LineDisplayBitmap
public class LineDisplayBitmap

Remarks

LineDisplayBitmap is a helper class created by POS for .NET and used by the LineDisplayBase class for creating and displaying bitmaps.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BaseServiceObjects.LineDisplayBitmap

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBitmap Members
Microsoft.PointOfService.BaseServiceObjects Namespace


LineDisplayBitmap Members

LineDisplayBitmap Members |
 | See Also Methods Properties

1/18/2008

A helper class created by POS for .NET and used by the LineDisplayBase class for creating and displaying bitmaps.

The following tables list the members exposed by the LineDisplayBitmap type.

Public Properties

Name | Description
Bitmap | Contains the bitmap to be displayed.
FileName | Contains the filename of the bitmap to be displayed.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

LineDisplayBitmap Class
Microsoft.PointOfService.BaseServiceObjects Namespace


LineDisplayBitmap Methods

LineDisplayBitmap Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

LineDisplayBitmap Class
Microsoft.PointOfService.BaseServiceObjects Namespace


LineDisplayBitmap Properties

LineDisplayBitmap Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
Bitmap | Contains the bitmap to be displayed.
FileName | Contains the filename of the bitmap to be displayed.

See Also

Reference

LineDisplayBitmap Class
Microsoft.PointOfService.BaseServiceObjects Namespace


LineDisplayBitmap.Bitmap Property

LineDisplayBitmap.Bitmap Property |
 | See Also

1/18/2008

Contains the bitmap to be displayed.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Bitmap As Bitmap
public Bitmap Bitmap { get; }
public:
property Bitmap^ Bitmap {
    Bitmap^ get ();
}
/** @property */
public Bitmap get_Bitmap ()

public function get Bitmap () : Bitmap

Remarks

Contains the bitmap to be displayed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBitmap Class
LineDisplayBitmap Members
Microsoft.PointOfService.BaseServiceObjects Namespace


LineDisplayBitmap.FileName Property

LineDisplayBitmap.FileName Property |
 | See Also

1/18/2008

Contains the filename of the bitmap to be displayed.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property FileName As String
public string FileName { get; }
public:
property String^ FileName {
    String^ get ();
}
/** @property */
public String get_FileName ()

public function get FileName () : String

Remarks

Contains the filename of the bitmap to be displayed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayBitmap Class
LineDisplayBitmap Members
Microsoft.PointOfService.BaseServiceObjects Namespace


LineDisplayProperties Class

LineDisplayProperties Class |
 | See Also Members

1/18/2008

A helper class created by POS for .NET to simplify the retrieval and setting of property values for line display devices.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class LineDisplayProperties
    Inherits CommonProperties
public class LineDisplayProperties : CommonProperties
public ref class LineDisplayProperties : public CommonProperties
public class LineDisplayProperties extends CommonProperties
public class LineDisplayProperties extends CommonProperties

Remarks

LineDisplayProperties is a helper class created by POS for .NET to simplify the retrieval and setting of property values for line display devices. LineDisplayProperties inherits from the CommonProperties class. The protected Properties property of LineDisplayProperties class returns an instance of LineDisplayProperties. The service object can manage the value of a property using the syntax Properties.<propertyName>. LineDisplayProperties bypasses state validation—in other words, the service object can use LineDisplayProperties to set values for properties even though the application hasn’t opened, claimed, or enabled the line display device.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BasicServiceObjects.CommonProperties
Microsoft.PointOfService.BaseServiceObjects.LineDisplayProperties

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


LineDisplayProperties Members

LineDisplayProperties Members |
 | See Also Methods Properties

1/18/2008

A helper class created by POS for .NET to simplify the retrieval and setting of property values for line display devices.

The following tables list the members exposed by the LineDisplayProperties type.

Public Properties

Name | Description
BlinkRate | Holds the blink cycle in milliseconds.
CapBitmap | If true, display of bitmaps is supported.
CapBlink | Holds the character blink capability of the line display device.
CapBlinkRate | If true, the device’s blink rate can be controlled, and the application uses the BlinkRate property to indicate the rate at which the display blinks.
CapBrightness | If true, brightness control is supported.
CapCharacterSet | Holds the default character set capability of the line display device.
CapCompareFirmwareVersion | (inherited from CommonProperties )
CapCursorType | Holds a bitwise indication of the cursor types supported by the line display device, selectable via the CursorType property.
CapCustomGlyph | If true, the device supports custom glyph definition.
CapDescriptors | If true, the device supports descriptors.
CapHMarquee | If true, the device supports horizontal marquee windows.
CapICharWait | If true, the device supports inter-character wait.
CapMapCharacterSet | If true, then the service object is able to map the characters provided by the application to the character sets defined in the CharacterSetList property when displaying data.
CapPowerReporting | (inherited from CommonProperties )
CapReadBack | Holds the capability of the line display device to read back the data displayed on it.
CapReverse | Holds the reverse video capability of the line display device.
CapScreenMode | If true, the line display device supports changing the screen mode (that is, the number of text rows and columns).
CapStatisticsReporting | (inherited from CommonProperties )
CapUpdateFirmware | (inherited from CommonProperties )
CapUpdateStatistics | (inherited from CommonProperties )
CapVMarquee | If true, the device supports vertical marquee windows.
CharacterSet | Holds the character set for displaying characters.
CharacterSetList | Holds a string of character set numbers.
Columns | Holds the number of columns for this window.
CurrentWindow | Holds the current window to which text is displayed.
CursorColumn | Holds the column in the current window to which the next displayed character will be output.
CursorRow | Holds the row in the current window to which the next displayed character will be output.
CursorType | Holds the cursor type for the current window.
CursorUpdate | If true when characters are displayed using the DisplayText and DisplayTextAt methods, then the CursorRow and CursorColumn properties will be updated to point to the character beyond the last character output.
CustomGlyphList | Holds an array of instances of the RangeOfCharacters helper class, which represents the character code ranges that are available for defining glyphs.
DeviceBrightness | Holds the device brightness value, expressed as a percentage between 0 and 100.
DeviceColumns | Holds the number of columns on this device.
DeviceDescription | (inherited from CommonProperties )
DeviceDescriptors | Holds the number of descriptors on this device.
DeviceName | (inherited from CommonProperties )
DeviceRows | Holds the number of rows on this device.
DeviceWindows | Holds the maximum number of windows supported by the line display device.
GlyphHeight | Indicates the glyph height based on the number of pixels for a character cell.
GlyphWidth | Indicates the glyph width based on the number of pixels for a character cell.
InterCharacterWait | Holds the wait time, specified in milliseconds, between the display of each character with the DisplayText and DisplayTextAt methods.
MapCharacterSet | If true when outputting data, the service object maps the characters transferred by the application to the character set selected in the CharacterSet property.
MarqueeFormat | Holds the marquee format for the current window.
MarqueeRepeatWait | Holds the wait time, specified in milliseconds, between scrolling the final character or row of the window into its viewport and restarting the marquee with the first or last character or row.
MarqueeType | Holds the marquee type for the current window.
MarqueeUnitWait | Holds the wait time, specified in milliseconds, between marquee scrolling of each column or row in the window.
MaximumX | A value of 0 (zero) indicates that bitmaps are not supported.
MaximumY | A value of zero indicates that bitmaps aren’t supported.
PowerState | (inherited from CommonProperties )
Rows | Holds the number of rows for this window.
ScreenMode | Holds the screen mode value of the device.
ScreenModeList | Holds the array of DisplayScreenMode class instances that are supported by the device.
ServiceObjectDescription | (inherited from CommonProperties )
ServiceObjectVersion | (inherited from CommonProperties )
State | (inherited from CommonProperties )
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

LineDisplayProperties Class
Microsoft.PointOfService.BaseServiceObjects Namespace


LineDisplayProperties Methods

LineDisplayProperties Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

LineDisplayProperties Class
Microsoft.PointOfService.BaseServiceObjects Namespace


LineDisplayProperties Properties

LineDisplayProperties Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
BlinkRate | Holds the blink cycle in milliseconds.
CapBitmap | If true, display of bitmaps is supported.
CapBlink | Holds the character blink capability of the line display device.
CapBlinkRate | If true, the device’s blink rate can be controlled, and the application uses the BlinkRate property to indicate the rate at which the display blinks.
CapBrightness | If true, brightness control is supported.
CapCharacterSet | Holds the default character set capability of the line display device.
CapCompareFirmwareVersion | (inherited from CommonProperties )
CapCursorType | Holds a bitwise indication of the cursor types supported by the line display device, selectable via the CursorType property.
CapCustomGlyph | If true, the device supports custom glyph definition.
CapDescriptors | If true, the device supports descriptors.
CapHMarquee | If true, the device supports horizontal marquee windows.
CapICharWait | If true, the device supports inter-character wait.
CapMapCharacterSet | If true, then the service object is able to map the characters provided by the application to the character sets defined in the CharacterSetList property when displaying data.
CapPowerReporting | (inherited from CommonProperties )
CapReadBack | Holds the capability of the line display device to read back the data displayed on it.
CapReverse | Holds the reverse video capability of the line display device.
CapScreenMode | If true, the line display device supports changing the screen mode (that is, the number of text rows and columns).
CapStatisticsReporting | (inherited from CommonProperties )
CapUpdateFirmware | (inherited from CommonProperties )
CapUpdateStatistics | (inherited from CommonProperties )
CapVMarquee | If true, the device supports vertical marquee windows.
CharacterSet | Holds the character set for displaying characters.
CharacterSetList | Holds a string of character set numbers.
Columns | Holds the number of columns for this window.
CurrentWindow | Holds the current window to which text is displayed.
CursorColumn | Holds the column in the current window to which the next displayed character will be output.
CursorRow | Holds the row in the current window to which the next displayed character will be output.
CursorType | Holds the cursor type for the current window.
CursorUpdate | If true when characters are displayed using the DisplayText and DisplayTextAt methods, then the CursorRow and CursorColumn properties will be updated to point to the character beyond the last character output.
CustomGlyphList | Holds an array of instances of the RangeOfCharacters helper class, which represents the character code ranges that are available for defining glyphs.
DeviceBrightness | Holds the device brightness value, expressed as a percentage between 0 and 100.
DeviceColumns | Holds the number of columns on this device.
DeviceDescription | (inherited from CommonProperties )
DeviceDescriptors | Holds the number of descriptors on this device.
DeviceName | (inherited from CommonProperties )
DeviceRows | Holds the number of rows on this device.
DeviceWindows | Holds the maximum number of windows supported by the line display device.
GlyphHeight | Indicates the glyph height based on the number of pixels for a character cell.
GlyphWidth | Indicates the glyph width based on the number of pixels for a character cell.
InterCharacterWait | Holds the wait time, specified in milliseconds, between the display of each character with the DisplayText and DisplayTextAt methods.
MapCharacterSet | If true when outputting data, the service object maps the characters transferred by the application to the character set selected in the CharacterSet property.
MarqueeFormat | Holds the marquee format for the current window.
MarqueeRepeatWait | Holds the wait time, specified in milliseconds, between scrolling the final character or row of the window into its viewport and restarting the marquee with the first or last character or row.
MarqueeType | Holds the marquee type for the current window.
MarqueeUnitWait | Holds the wait time, specified in milliseconds, between marquee scrolling of each column or row in the window.
MaximumX | A value of 0 (zero) indicates that bitmaps are not supported.
MaximumY | A value of zero indicates that bitmaps aren’t supported.
PowerState | (inherited from CommonProperties )
Rows | Holds the number of rows for this window.
ScreenMode | Holds the screen mode value of the device.
ScreenModeList | Holds the array of DisplayScreenMode class instances that are supported by the device.
ServiceObjectDescription | (inherited from CommonProperties )
ServiceObjectVersion | (inherited from CommonProperties )
State | (inherited from CommonProperties )

See Also

Reference

LineDisplayProperties Class
Microsoft.PointOfService.BaseServiceObjects Namespace


LineDisplayProperties.BlinkRate Property

LineDisplayProperties.BlinkRate Property |
 | See Also

1/18/2008

Holds the blink cycle in milliseconds.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property BlinkRate As Integer
public int BlinkRate { get; set; }
public:
property int BlinkRate {
    int get ();
    void set (int value);
}
/** @property */
public int get_BlinkRate ()

/** @property */
public void set_BlinkRate (int value)

public function get BlinkRate () : int

public function set BlinkRate (value : int)

Remarks

A blink cycle is the period of time when text completes an on-off-on cycle during blinking. After BlinkRate is set, the service object will set the blink rate to the closest supported rate and change BlinkRate to reflect the actual rate. Performing this approximation is necessary because blink cycles are hardware dependent and probably not controllable at precise millisecond granularity.

BlinkRate is typically initialized to 0 (zero).

Accessing BlinkRate may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | BlinkRate has been set to a value less than zero, or BlinkRate has been set to a valid value but the CapBlinkRate property is set to false, indicating that the device doesn’t support blinking.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.BlinkRateChangedEventHandler Delegate


LineDisplayProperties.CapBitmap Property

LineDisplayProperties.CapBitmap Property |
 | See Also

1/18/2008

If true, display of bitmaps is supported.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapBitmap As Boolean
public bool CapBitmap { get; set; }
public:
property bool CapBitmap {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapBitmap ()

/** @property */
public void set_CapBitmap (boolean value)

public function get CapBitmap () : boolean

public function set CapBitmap (value : boolean)

Remarks

CapBitmap is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.CapBitmap Property


LineDisplayProperties.CapBlink Property

LineDisplayProperties.CapBlink Property |
 | See Also

1/18/2008

Holds the character blink capability of the line display device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapBlink As DisplayBlink
public DisplayBlink CapBlink { get; set; }
public:
property DisplayBlink CapBlink {
    DisplayBlink get ();
    void set (DisplayBlink value);
}
/** @property */
public DisplayBlink get_CapBlink ()

/** @property */
public void set_CapBlink (DisplayBlink value)

public function get CapBlink () : DisplayBlink

public function set CapBlink (value : DisplayBlink)

Remarks

Possible values are defined by the DisplayBlink enumeration. Valid values are:

Value | Meaning
None | The line display device doesn’t support blinking; the value is 0.
All | The line display supports blinking for the entire display. The service object sets the entire contents of the display to blink or to be in a steady state.
Each | The line display supports blinking for each character. The service object can set each character to blink individually or to be in a steady state.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.CapBlink Property


LineDisplayProperties.CapBlinkRate Property

LineDisplayProperties.CapBlinkRate Property |
 | See Also

1/18/2008

If true, the device’s blink rate can be controlled, and the application uses the BlinkRate property to indicate the rate at which the display blinks.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapBlinkRate As Boolean
public bool CapBlinkRate { get; set; }
public:
property bool CapBlinkRate {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapBlinkRate ()

/** @property */
public void set_CapBlinkRate (boolean value)

public function get CapBlinkRate () : boolean

public function set CapBlinkRate (value : boolean)

Remarks

If true, the device’s blink rate can be controlled, and the application uses the BlinkRate property to indicate the rate at which the display blinks.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.CapBlinkRate Property


LineDisplayProperties.CapBrightness Property

LineDisplayProperties.CapBrightness Property |
 | See Also

1/18/2008

If true, brightness control is supported.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapBrightness As Boolean
public bool CapBrightness { get; set; }
public:
property bool CapBrightness {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapBrightness ()

/** @property */
public void set_CapBrightness (boolean value)

public function get CapBrightness () : boolean

public function set CapBrightness (value : boolean)

Remarks

CapBrightness is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.CapBrightness Property


LineDisplayProperties.CapCharacterSet Property

LineDisplayProperties.CapCharacterSet Property |
 | See Also

1/18/2008

Holds the default character set capability of the line display device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapCharacterSet As CharacterSetCapability
public CharacterSetCapability CapCharacterSet { get; set; }
public:
property CharacterSetCapability CapCharacterSet {
    CharacterSetCapability get ();
    void set (CharacterSetCapability value);
}
/** @property */
public CharacterSetCapability get_CapCharacterSet ()

/** @property */
public void set_CapCharacterSet (CharacterSetCapability value)

public function get CapCharacterSet () : CharacterSetCapability

public function set CapCharacterSet (value : CharacterSetCapability)

Remarks

Possible values are defined by the CharacterSetCapability enumeration.

The default character set can contain a superset of these ranges. The CharacterSet property can contain additional character set information.

CapCharacterSet is set by the service object, based on the capabilities of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.CapCharacterSet Property


LineDisplayProperties.CapCursorType Property

LineDisplayProperties.CapCursorType Property |
 | See Also

1/18/2008

Holds a bitwise indication of the cursor types supported by the line display device, selectable via the CursorType property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapCursorType As DisplayCursors
public DisplayCursors CapCursorType { get; set; }
public:
property DisplayCursors CapCursorType {
    DisplayCursors get ();
    void set (DisplayCursors value);
}
/** @property */
public DisplayCursors get_CapCursorType ()

/** @property */
public void set_CapCursorType (DisplayCursors value)

public function get CapCursorType () : DisplayCursors

public function set CapCursorType (value : DisplayCursors)

Remarks

Possible values are defined by the DisplayCursors enumeration.

If CapCursorType is set to None, then none of the other values will be set.

If CapCursorType is set to Fixed, then DisplayCursors.Blink may also be set, plus exactly one of the other values. This other value will indicate the cursor type that is always displayed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.CapCursorType Property


LineDisplayProperties.CapCustomGlyph Property

LineDisplayProperties.CapCustomGlyph Property |
 | See Also

1/18/2008

If true, the device supports custom glyph definition.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapCustomGlyph As Boolean
public bool CapCustomGlyph { get; set; }
public:
property bool CapCustomGlyph {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapCustomGlyph ()

/** @property */
public void set_CapCustomGlyph (boolean value)

public function get CapCustomGlyph () : boolean

public function set CapCustomGlyph (value : boolean)

Remarks

If true, the device supports custom glyph definition.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.CapCustomGlyph Property


LineDisplayProperties.CapDescriptors Property

LineDisplayProperties.CapDescriptors Property |
 | See Also

1/18/2008

If true, the device supports descriptors.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapDescriptors As Boolean
public bool CapDescriptors { get; set; }
public:
property bool CapDescriptors {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapDescriptors ()

/** @property */
public void set_CapDescriptors (boolean value)

public function get CapDescriptors () : boolean

public function set CapDescriptors (value : boolean)

Remarks

If true, the device supports descriptors.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.CapDescriptors Property


LineDisplayProperties.CapHMarquee Property

LineDisplayProperties.CapHMarquee Property |
 | See Also

1/18/2008

If true, the device supports horizontal marquee windows.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapHMarquee As Boolean
public bool CapHMarquee { get; set; }
public:
property bool CapHMarquee {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapHMarquee ()

/** @property */
public void set_CapHMarquee (boolean value)

public function get CapHMarquee () : boolean

public function set CapHMarquee (value : boolean)

Remarks

If true, the device supports horizontal marquee windows.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.CapHMarquee Property


LineDisplayProperties.CapICharWait Property

LineDisplayProperties.CapICharWait Property |
 | See Also

1/18/2008

If true, the device supports inter-character wait.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapICharWait As Boolean
public bool CapICharWait { get; set; }
public:
property bool CapICharWait {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapICharWait ()

/** @property */
public void set_CapICharWait (boolean value)

public function get CapICharWait () : boolean

public function set CapICharWait (value : boolean)

Remarks

If true, the device supports inter-character wait.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.CapICharWait Property


LineDisplayProperties.CapMapCharacterSet Property

LineDisplayProperties.CapMapCharacterSet Property |
 | See Also

1/18/2008

If true, then the service object is able to map the characters provided by the application to the character sets defined in the CharacterSetList property when displaying data.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapMapCharacterSet As Boolean
public bool CapMapCharacterSet { get; set; }
public:
property bool CapMapCharacterSet {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapMapCharacterSet ()

/** @property */
public void set_CapMapCharacterSet (boolean value)

public function get CapMapCharacterSet () : boolean

public function set CapMapCharacterSet (value : boolean)

Remarks

If true, then the service object is able to map the characters provided by the application to the character sets defined in the CharacterSetList property when displaying data.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.CapMapCharacterSet Property


LineDisplayProperties.CapReadBack Property

LineDisplayProperties.CapReadBack Property |
 | See Also

1/18/2008

Holds the capability of the line display device to read back the data displayed on it.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapReadBack As DisplayReadBack
public DisplayReadBack CapReadBack { get; set; }
public:
property DisplayReadBack CapReadBack {
    DisplayReadBack get ();
    void set (DisplayReadBack value);
}
/** @property */
public DisplayReadBack get_CapReadBack ()

/** @property */
public void set_CapReadBack (DisplayReadBack value)

public function get CapReadBack () : DisplayReadBack

public function set CapReadBack (value : DisplayReadBack)

Remarks

Possible values are defined by the DisplayReadBack enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.CapReadBack Property


LineDisplayProperties.CapReverse Property

LineDisplayProperties.CapReverse Property |
 | See Also

1/18/2008

Holds the reverse video capability of the line display device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapReverse As DisplayReverse
public DisplayReverse CapReverse { get; set; }
public:
property DisplayReverse CapReverse {
    DisplayReverse get ();
    void set (DisplayReverse value);
}
/** @property */
public DisplayReverse get_CapReverse ()

/** @property */
public void set_CapReverse (DisplayReverse value)

public function get CapReverse () : DisplayReverse

public function set CapReverse (value : DisplayReverse)

Remarks

Possible values are defined by the DisplayReverse enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.CapReverse Property


LineDisplayProperties.CapScreenMode Property

LineDisplayProperties.CapScreenMode Property |
 | See Also

1/18/2008

If true, the line display device supports changing the screen mode (that is, the number of text rows and columns).

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property CapScreenMode As Boolean
public bool CapScreenMode { get; }
public:
property bool CapScreenMode {
    bool get ();
}
/** @property */
public boolean get_CapScreenMode ()

public function get CapScreenMode () : boolean

Remarks

If true, the line display device supports changing the screen mode (that is, the number of text rows and columns).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.CapScreenMode Property


LineDisplayProperties.CapVMarquee Property

LineDisplayProperties.CapVMarquee Property |
 | See Also

1/18/2008

If true, the device supports vertical marquee windows.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapVMarquee As Boolean
public bool CapVMarquee { get; set; }
public:
property bool CapVMarquee {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapVMarquee ()

/** @property */
public void set_CapVMarquee (boolean value)

public function get CapVMarquee () : boolean

public function set CapVMarquee (value : boolean)

Remarks

If true, the device supports vertical marquee windows.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.CapVMarquee Property


LineDisplayProperties.CharacterSet Property

LineDisplayProperties.CharacterSet Property |
 | See Also

1/18/2008

Holds the character set for displaying characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CharacterSet As Integer
public int CharacterSet { get; set; }
public:
property int CharacterSet {
    int get ();
    void set (int value);
}
/** @property */
public int get_CharacterSet ()

/** @property */
public void set_CharacterSet (int value)

public function get CharacterSet () : int

public function set CharacterSet (value : int)

Remarks

CharacterSet may be one of the following ranges or values:

Value | Meaning
Range 101 - 199 | A device-specific character set that does not match a code page or the ASCII or Windows ANSI character sets.
Range 400 - 990 | Code page; matches one of the standard values.
CharacterSetUnicode | The character set supports Unicode. The value of this constant is 997.
CharacterSetAscii | The ASCII character set, supporting the ASCII characters between 20-hex and 7F-hex. The value of this constant is 998.
CharacterSetAnsi | The Windows ANSI character set. The value of this constant is 999. This is exactly equivalent to the Windows code page 1252.
Range 1000 and higher | Windows code page; matches one of the standard values.

CharacterSet is typically initialized to 0. This value is guaranteed to support at least the set of characters specified by the CapCharacterSet property.

Accessing CharacterSet may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | CharacterSet has been set to a value that doesn’t exist in the character sets listed for the CharacterSetList property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.CharacterSet Property


LineDisplayProperties.CharacterSetList Property

LineDisplayProperties.CharacterSetList Property |
 | See Also

1/18/2008

Holds a string of character set numbers.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CharacterSetList As Integer()
public int[] CharacterSetList { get; set; }
public:
property array<int>^ CharacterSetList {
    array<int>^ get ();
    void set (array<int>^ value);
}
/** @property */
public int[] get_CharacterSetList ()

/** @property */
public void set_CharacterSetList (int[] value)

public function get CharacterSetList () : int[]

public function set CharacterSetList (value : int[])

Remarks

The string consists of ASCII numeric set numbers separated by commas. For example, if the string is "101,850,999", then the device supports a device-specific character set, code page 850, and the Windows ANSI character set.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.CharacterSetList Property


LineDisplayProperties.Columns Property

LineDisplayProperties.Columns Property |
 | See Also

1/18/2008

Holds the number of columns for this window.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Columns As Integer
public int Columns { get; }
public:
property int Columns {
    int get ();
}
/** @property */
public int get_Columns ()

public function get Columns () : int

Remarks

For window 0, Columns is the same as the value of the DeviceColumns property. For other windows created by the application, it can be less or greater than DeviceColumns.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Column


LineDisplayProperties.CurrentWindow Property

LineDisplayProperties.CurrentWindow Property |
 | See Also

1/18/2008

Holds the current window to which text is displayed.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CurrentWindow As Integer
public int CurrentWindow { get; set; }
public:
property int CurrentWindow {
    int get ();
    void set (int value);
}
/** @property */
public int get_CurrentWindow ()

/** @property */
public void set_CurrentWindow (int value)

public function get CurrentWindow () : int

public function set CurrentWindow (value : int)

Remarks

Several properties are associated with each window: Rows, Columns, CursorRow, CursorColumn, CursorUpdate, CursorType, MarqueeFormat, MarqueeType, MarqueeUnitWait, MarqueeRepeatWait, and InterCharacterWait.

When the application sets CurrentWindow, it changes the current window (for display purposes) and sets the associated properties to their values for this window.

Setting a window does not refresh its viewport. If this window and another window’s viewports overlap, and the other window has changed the viewport, then the application can call the RefreshWindow method to restore this window’s viewport contents.

Accessing CurrentWindow may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | CurrentWindow has been set to a value that isn’t valid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.CurrentWindow Property


LineDisplayProperties.CursorColumn Property

LineDisplayProperties.CursorColumn Property |
 | See Also

1/18/2008

Holds the column in the current window to which the next displayed character will be output.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CursorColumn As Integer
public int CursorColumn { get; set; }
public:
property int CursorColumn {
    int get ();
    void set (int value);
}
/** @property */
public int get_CursorColumn ()

/** @property */
public void set_CursorColumn (int value)

public function get CursorColumn () : int

public function set CursorColumn (value : int)

Remarks

Legal values range from zero through the value of the Columns property.

Accessing CursorColumn may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | CursorColumn was set to a value that isn’t valid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.CursorColumn Property


LineDisplayProperties.CursorRow Property

LineDisplayProperties.CursorRow Property |
 | See Also

1/18/2008

Holds the row in the current window to which the next displayed character will be output.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CursorRow As Integer
public int CursorRow { get; set; }
public:
property int CursorRow {
    int get ();
    void set (int value);
}
/** @property */
public int get_CursorRow ()

/** @property */
public void set_CursorRow (int value)

public function get CursorRow () : int

public function set CursorRow (value : int)

Remarks

Legal values range from (zero) through the value of the Rows property, minus 1.

Accessing CursorRow may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | CursorRow was set to a value that isn’t valid.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.CursorRow Property


LineDisplayProperties.CursorType Property

LineDisplayProperties.CursorType Property |
 | See Also

1/18/2008

Holds the cursor type for the current window.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CursorType As DisplayCursors
public DisplayCursors CursorType { get; set; }
public:
property DisplayCursors CursorType {
    DisplayCursors get ();
    void set (DisplayCursors value);
}
/** @property */
public DisplayCursors get_CursorType ()

/** @property */
public void set_CursorType (DisplayCursors value)

public function get CursorType () : DisplayCursors

public function set CursorType (value : DisplayCursors)

Remarks

CursorType can’t be set if the CapCursorType property is set to either None or Fixed. Otherwise, CursorType can be set to one of the cursor types specified by CapCursorType. If supported, the setting of Blink can be logically combined with that cursor type to display a blinking cursor.

CursorType is maintained for each window. Setting CursorType affects only the current window, because only the current window has a displayable cursor.

Accessing CursorType may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | One of the following conditions has occurred: The CapCursorType property is set to either None or Fixed, so CursorType shouldn’t be set; CursorType was set to a value other than None but doesn’t match the setting for CapCursorType; CursorType was set to Blink, but blinking isn’t supported; or CursorType was set to a value other than Blink which isn’t defined in the DisplayCursors enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.CursorType Property


LineDisplayProperties.CursorUpdate Property

LineDisplayProperties.CursorUpdate Property |
 | See Also

1/18/2008

If true when characters are displayed using the DisplayText and DisplayTextAt methods, then the CursorRow and CursorColumn properties will be updated to point to the character beyond the last character output.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CursorUpdate As Boolean
public bool CursorUpdate { get; set; }
public:
property bool CursorUpdate {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CursorUpdate ()

/** @property */
public void set_CursorUpdate (boolean value)

public function get CursorUpdate () : boolean

public function set CursorUpdate (value : boolean)

Remarks

CursorUpdate is set and maintained for each window. It is initialized to true by the Open and CreateWindow methods, then updated when the CurrentWindow property is set or the DestroyWindow method is called.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.CursorUpdate Property


LineDisplayProperties.CustomGlyphList Property

LineDisplayProperties.CustomGlyphList Property |
 | See Also

1/18/2008

Holds an array of instances of the RangeOfCharacters helper class, which represents the character code ranges that are available for defining glyphs.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CustomGlyphList As RangeOfCharacters()
public RangeOfCharacters[] CustomGlyphList { get; set; }
public:
property array<RangeOfCharacters^>^ CustomGlyphList {
    array<RangeOfCharacters^>^ get ();
    void set (array<RangeOfCharacters^>^ value);
}
/** @property */
public RangeOfCharacters[] get_CustomGlyphList ()

/** @property */
public void set_CustomGlyphList (RangeOfCharacters[] value)

public function get CustomGlyphList () : RangeOfCharacters[]

public function set CustomGlyphList (value : RangeOfCharacters[])

Remarks

An instance in the array can contain one character, or a range of characters. Character codes are represented as two-digit ASCII or four-digit Unicode hexadecimal values. Each value can actually represent a range of values specified by using To and From properties of the RangeOfCharacters class.

For example, if the From property is set to "2D," and the To property to "4D," then the device supports glyph definitions for the characters "-" and "M," respectively. If the range is "002D" to "004D", then the device supports glyph definitions for the Unicode characters between 002D and 004D inclusive. Also, if the array contains two instances, or ranges, "2D and 2F", and "3D and 3F", then the device supports glyph definitions for the ranges of hex characters 2D through 2F and 3D through 3F.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.CustomGlyphList Property


LineDisplayProperties.DeviceBrightness Property

LineDisplayProperties.DeviceBrightness Property |
 | See Also

1/18/2008

Holds the device brightness value, expressed as a percentage between 0 and 100.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property DeviceBrightness As Integer
public int DeviceBrightness { get; set; }
public:
property int DeviceBrightness {
    int get ();
    void set (int value);
}
/** @property */
public int get_DeviceBrightness ()

/** @property */
public void set_DeviceBrightness (int value)

public function get DeviceBrightness () : int

public function set DeviceBrightness (value : int)

Remarks

Any device can support 0% (blank) and 100% (full intensity). The service object can also support blanking by sending spaces to the device. If the CapBrightness property is set to true, then the device also supports one or more levels of dimming.

If the line display device does not support the brightness value specified by the application, then the service object will choose an appropriate substitute.

DeviceBrightness is typically initialized to 100.

Accessing DeviceBrightness may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | One of the following conditions has occurred: The CapBrightness property is set to false, indicating the device doesn’t support the setting of brightness values, but DeviceBrightness was set to a value other than 100; or DeviceBrightness was set to a value less than 0 (zero) or greater than 100.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.DeviceBrightness Property


LineDisplayProperties.DeviceColumns Property

LineDisplayProperties.DeviceColumns Property |
 | See Also

1/18/2008

Holds the number of columns on this device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property DeviceColumns As Integer
public int DeviceColumns { get; }
public:
property int DeviceColumns {
    int get ();
}
/** @property */
public int get_DeviceColumns ()

public function get DeviceColumns () : int

Remarks

Holds the number of columns on this device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.DeviceColumns Property


LineDisplayProperties.DeviceDescriptors Property

LineDisplayProperties.DeviceDescriptors Property |
 | See Also

1/18/2008

Holds the number of descriptors on this device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property DeviceDescriptors As Integer
public int DeviceDescriptors { get; set; }
public:
property int DeviceDescriptors {
    int get ();
    void set (int value);
}
/** @property */
public int get_DeviceDescriptors ()

/** @property */
public void set_DeviceDescriptors (int value)

public function get DeviceDescriptors () : int

public function set DeviceDescriptors (value : int)

Remarks

If the CapDescriptors property is set to TRUE, then DeviceDescriptors is non-zero.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.DeviceDescriptors Property


LineDisplayProperties.DeviceRows Property

LineDisplayProperties.DeviceRows Property |
 | See Also

1/18/2008

Holds the number of rows on this device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property DeviceRows As Integer
public int DeviceRows { get; }
public:
property int DeviceRows {
    int get ();
}
/** @property */
public int get_DeviceRows ()

public function get DeviceRows () : int

Remarks

Holds the number of rows on this device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.DeviceRows Property


LineDisplayProperties.DeviceWindows Property

LineDisplayProperties.DeviceWindows Property |
 | See Also

1/18/2008

Holds the maximum number of windows supported by the line display device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property DeviceWindows As Integer
public int DeviceWindows { get; set; }
public:
property int DeviceWindows {
    int get ();
    void set (int value);
}
/** @property */
public int get_DeviceWindows ()

/** @property */
public void set_DeviceWindows (int value)

public function get DeviceWindows () : int

public function set DeviceWindows (value : int)

Remarks

A value of zero indicates that only the device window is supported and that no other windows can be created.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.DeviceWindows Property


LineDisplayProperties.GlyphHeight Property

LineDisplayProperties.GlyphHeight Property |
 | See Also

1/18/2008

Indicates the glyph height based on the number of pixels for a character cell.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property GlyphHeight As Integer
public int GlyphHeight { get; }
public:
property int GlyphHeight {
    int get ();
}
/** @property */
public int get_GlyphHeight ()

public function get GlyphHeight () : int

Remarks

Indicates the glyph height based on the number of pixels for a character cell.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.GlyphHeight Property


LineDisplayProperties.GlyphWidth Property

LineDisplayProperties.GlyphWidth Property |
 | See Also

1/18/2008

Indicates the glyph width based on the number of pixels for a character cell.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property GlyphWidth As Integer
public int GlyphWidth { get; }
public:
property int GlyphWidth {
    int get ();
}
/** @property */
public int get_GlyphWidth ()

public function get GlyphWidth () : int

Remarks

Indicates the glyph width based on the number of pixels for a character cell.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.GlyphWidth Property


LineDisplayProperties.InterCharacterWait Property

LineDisplayProperties.InterCharacterWait Property |
 | See Also

1/18/2008

Holds the wait time, specified in milliseconds, between the display of each character with the DisplayText and DisplayTextAt methods.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property InterCharacterWait As Integer
public int InterCharacterWait { get; set; }
public:
property int InterCharacterWait {
    int get ();
    void set (int value);
}
/** @property */
public int get_InterCharacterWait ()

/** @property */
public void set_InterCharacterWait (int value)

public function get InterCharacterWait () : int

public function set InterCharacterWait (value : int)

Remarks

InterCharacterWait can be used to give a “teletype” appearance when displaying text.

Note that InterCharacterWait is used only if the service object has set the CapICharWait property to true, indicating that the line display device supports inter-character wait.

If inter-character wait is supported, InterCharacterWait is used only if the window is not in Marquee mode; that is, when the application has set the MarqueeType property to None.

When the InterCharacterWait value is not zero and the window is not in Marquee mode, the window is in Teletype mode: DisplayText and DisplayTextAt requests are queued by the service object and processed in the order they are received. InterCharacterWait specifies the time to wait between outputting each character to the viewport. Note that the system timer resolution can reduce the precision of the wait time.

If the CursorUpdate property is set to true, the CursorRow and CursorColumn properties are updated to their final values by the DisplayText or DisplayTextAt methods before they return, even though all of the data will not yet be displayed.

When the application sets InterCharacterWait to zero and Marquee Type to None, Immediate mode goes into effect and characters are displayed as quickly as possible. If some display requests are queued by the service object when InterCharacterWait is set to zero, the requests are completed as quickly as possible.

Accessing InterCharacterWait may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | One of the following conditions occurred: InterCharacterWait was set, but the CapICharWait property is set to false, indicating the device doesn’t support inter-character wait functionality; or InterCharacterWait was set to a value less than 0 (zero).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.InterCharacterWait Property


LineDisplayProperties.MapCharacterSet Property

LineDisplayProperties.MapCharacterSet Property |
 | See Also

1/18/2008

If true when outputting data, the service object maps the characters transferred by the application to the character set selected in the CharacterSet property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property MapCharacterSet As Boolean
public bool MapCharacterSet { get; set; }
public:
property bool MapCharacterSet {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_MapCharacterSet ()

/** @property */
public void set_MapCharacterSet (boolean value)

public function get MapCharacterSet () : boolean

public function set MapCharacterSet (value : boolean)

Remarks

If false, no mapping is supported. In such a case, the application has to ensure the mapping of the character set used in the application to the character set selected in the CharacterSet property.

If CapMapCharacterSet is set to false, then MapCharacterSet is always false.

Accessing MapCharacterSet may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | MapCharacterSet was set to true, but the CapMapCharacterSet property is set to false, indicating the device doesn’t support character set mapping.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.MapCharacterSet Property


LineDisplayProperties.MarqueeFormat Property

LineDisplayProperties.MarqueeFormat Property |
 | See Also

1/18/2008

Holds the marquee format for the current window.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property MarqueeFormat As DisplayMarqueeFormat
public DisplayMarqueeFormat MarqueeFormat { get; set; }
public:
property DisplayMarqueeFormat MarqueeFormat {
    DisplayMarqueeFormat get ();
    void set (DisplayMarqueeFormat value);
}
/** @property */
public DisplayMarqueeFormat get_MarqueeFormat ()

/** @property */
public void set_MarqueeFormat (DisplayMarqueeFormat value)

public function get MarqueeFormat () : DisplayMarqueeFormat

public function set MarqueeFormat (value : DisplayMarqueeFormat)

Remarks

Value | Meaning
Walk | Begin the marquee by 'walking' data from the opposite side. For example, if the marquee type is Left, then the viewport is filled by bringing characters in from the right side and scrolling them to the left.
Place | Begin the marquee by placing data. For example, if the marquee type is Left, then the viewport is filled by placing characters starting at the left side, and beginning scrolling only after the viewport is full.

The Open and CreateWindow methods initialize the value of MarqueeFormat to Walk, and it is updated when the application sets the CurrentWindow property or calls the DestroyWindow method.

MarqueeFormat is read when a transition is made to Marquee On mode. It is not used when not in Marquee mode.

When MarqueeFormat is Walk, and a transition is made from Marquee Init mode to Marquee On mode, the following occurs:

  1. Map the window to the viewport as follows:

    Marquee Type

    Window

    Viewport

    Left

    First Column

    Last Column

    Up

    First Row

    Last Row

    Right

    Last Column

    First Column

    Down

    Last Row

    First Row

    Fill the viewport with blanks. Continue to Step 2 without waiting.

  2. Display the mapped portion of the window into the viewport, then wait MarqueeUnitWait milliseconds. Move the window mapping onto the viewport by one row or column in the marquee direction. Repeat until the viewport is full.

  3. Refresh the viewport and wait MarqueeUnitWait milliseconds. Move the window mapping by one row or column. Repeat until the last row or column is scrolled into the viewport (in which case, omit the unit wait).

  4. Wait MarqueeRepeatWait milliseconds. Then go to step back to Step 1.

When MarqueeFormat is Place, and a transition is made from Marquee Init mode to Marquee On mode, the following occurs:

  1. Map the window to the viewport as follows:

    Marquee Type

    Window

    Viewport

    Left

    Column

    First Column

    Up

    First Row

    First Row

    Right

    Last Column

    Last Column

    Down

    Last Row

    Last Row

    Fill the viewport with blanks. Continue to Step 2 without waiting.

  2. Display a row or column into viewport, then wait MarqueeUnitWait milliseconds. Repeat until the viewport is full.

  3. Move the window mapping onto the viewport by one row or column in the marquee direction, and refresh the viewport, then wait MarqueeUnitWait milliseconds. Repeat until the last row or column is scrolled into the viewport (in which case, omit the unit wait).

  4. Wait MarqueeRepeatWait milliseconds. Then go to step back to Step 1.

Accessing MarqueeFormat may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | One of the following conditions occurred: The value specified for MarqueeFormat isn’t found in the DisplayMarqueeFormat enumeration, or The current window is Window 0—marquee format can’t be changed for Window 0.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.MarqueeFormat Property


LineDisplayProperties.MarqueeRepeatWait Property

LineDisplayProperties.MarqueeRepeatWait Property |
 | See Also

1/18/2008

Holds the wait time, specified in milliseconds, between scrolling the final character or row of the window into its viewport and restarting the marquee with the first or last character or row.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property MarqueeRepeatWait As Integer
public int MarqueeRepeatWait { get; set; }
public:
property int MarqueeRepeatWait {
    int get ();
    void set (int value);
}
/** @property */
public int get_MarqueeRepeatWait ()

/** @property */
public void set_MarqueeRepeatWait (int value)

public function get MarqueeRepeatWait () : int

public function set MarqueeRepeatWait (value : int)

Remarks

Note that the timer resolution can reduce the precision of the wait time.

MarqueeRepeatWait is not used if the window isn’t in Marquee mode.

Accessing MarqueeRepeatWait may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The value specified is less than 0 (zero).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.MarqueeRepeatWait Property


LineDisplayProperties.MarqueeType Property

LineDisplayProperties.MarqueeType Property |
 | See Also

1/18/2008

Holds the marquee type for the current window.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property MarqueeType As DisplayMarqueeType
public DisplayMarqueeType MarqueeType { get; set; }
public:
property DisplayMarqueeType MarqueeType {
    DisplayMarqueeType get ();
    void set (DisplayMarqueeType value);
}
/** @property */
public DisplayMarqueeType get_MarqueeType ()

/** @property */
public void set_MarqueeType (DisplayMarqueeType value)

public function get MarqueeType () : DisplayMarqueeType

public function set MarqueeType (value : DisplayMarqueeType)

Remarks

Possible values are defined by the DisplayMarqueeType enumeration. When not set to None, the window is in Marquee mode. Valid values are:

Value | Meaning
None | Marquees are disabled for this window.
Init | Marquee Init mode. Changes to the window are not reflected in the viewport until MarqueeType is changed to another value.
Up | Scroll the window up. Illegal unless Rows is greater than the viewportHeight parameter used for the window’s CreateWindow method, and the service object has set the CapVMarquee property to true.
Down | Scroll the window down. Illegal unless Rows is greater than the viewportHeight parameter used for the window’s CreateWindow method, and the service object has set the CapVMarquee property to true.
Left | Scroll the window left. Illegal unless Columns is greater than the viewportWidth parameter used for the window’s CreateWindow method, and the service object has set the CapHMarquee property to true.
Right | Scroll the window right. Illegal unless Columns is greater than the viewportWidth parameter used for the window’s CreateWindow method, and the service object has set the CapHMarquee property to true.

Accessing MarqueeType may cause a PosControlException to be thrown with the following ErrorCode:

Value

Meaning

Illegal

One of the following conditions occurred:

The value specified for MarqueeType isn’t found in the DisplayMarqueeType enumeration;

MarqueeType was set to either Up or Down, but the CapVMarquee property is set to false, indicating that the device doesn’t support vertical marquees;

MarqueeType was set to either DisplayMarqueeType.Right or DisplayMarqueeType.Left, but the CapHMarquee property was set to false, indicating that the device doesn’t support horizontal marquees; or

The current window is Window 0—the marquee can’t be changed for Window 0.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.MarqueeType Property


LineDisplayProperties.MarqueeUnitWait Property

LineDisplayProperties.MarqueeUnitWait Property |
 | See Also

1/18/2008

Holds the wait time, specified in milliseconds, between marquee scrolling of each column or row in the window.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property MarqueeUnitWait As Integer
public int MarqueeUnitWait { get; set; }
public:
property int MarqueeUnitWait {
    int get ();
    void set (int value);
}
/** @property */
public int get_MarqueeUnitWait ()

/** @property */
public void set_MarqueeUnitWait (int value)

public function get MarqueeUnitWait () : int

public function set MarqueeUnitWait (value : int)

Remarks

Note that the timer resolution can reduce the precision of the wait time.

MarqueeUnitWait is not used if MarqueeType is None.

Accessing MarqueeUnitWait may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The wait value specified was less than 0 (zero).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.MarqueeUnitWait Property


LineDisplayProperties.MaximumX Property

LineDisplayProperties.MaximumX Property |
 | See Also

1/18/2008

A value of 0 (zero) indicates that bitmaps are not supported.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property MaximumX As Integer
public int MaximumX { get; }
public:
property int MaximumX {
    int get ();
}
/** @property */
public int get_MaximumX ()

public function get MaximumX () : int

Remarks

Otherwise, MaximumX contains the maximum number of horizontal pixels supported by the device. It must be less than 65,536. Dividing MaximumX by the DeviceColumns property value gives the number of pixels required for each character.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.MaximumX Property


LineDisplayProperties.MaximumY Property

LineDisplayProperties.MaximumY Property |
 | See Also

1/18/2008

A value of zero indicates that bitmaps aren’t supported.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property MaximumY As Integer
public int MaximumY { get; }
public:
property int MaximumY {
    int get ();
}
/** @property */
public int get_MaximumY ()

public function get MaximumY () : int

Remarks

Otherwise, MaximumY contains the maximum number of vertical pixels supported by the device. It must be less than 65, 536. Dividing MaximumY by the value of the DeviceRows property gives the number of pixels required for each character.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.MaximumY Property


LineDisplayProperties.Rows Property

LineDisplayProperties.Rows Property |
 | See Also

1/18/2008

Holds the number of rows for this window.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Rows As Integer
public int Rows { get; }
public:
property int Rows {
    int get ();
}
/** @property */
public int get_Rows ()

public function get Rows () : int

Remarks

For window 0, Rows is the same as the value of the DeviceRows property. For other windows, it can be less or greater than DeviceRows.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.Rows Property


LineDisplayProperties.ScreenMode Property

LineDisplayProperties.ScreenMode Property |
 | See Also

1/18/2008

Holds the screen mode value of the device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property ScreenMode As Integer
public int ScreenMode { get; set; }
public:
property int ScreenMode {
    int get ();
    void set (int value);
}
/** @property */
public int get_ScreenMode ()

/** @property */
public void set_ScreenMode (int value)

public function get ScreenMode () : int

public function set ScreenMode (value : int)

Remarks

If the CapScreenMode property is set to false, ScreenMode is always set to 0. If CapScreenMode is set to true, then ScreenMode can be set to index the values contained in the ScreenModeList property. For example:

0 = Default value;

1 = First setting in ScreenModeList;

2 = Second setting in ScreenModeList

Note that ScreenMode can only be updated when the device is opened and claimed, but not enabled.

Changing ScreenMode also changes the DeviceColumns and DeviceRows properties to the new screen size. Also, for some devices, the MaximumX and MaximumY properties may be changed due to the columns and/or rows requiring a different number of physical pixels.

Accessing ScreenMode may cause a PosControlException to be thrown with the following ErrorCode:

Value

Meaning

Illegal

One of the following conditions has occurred:

The device is enabled—screen mode can only be set when the device is opened and claimed, but not enabled;

The CapScreenMode property is set to false, indicating that the device doesn’t support screen mode; or

The index value specified for ScreenMode is either less than 0 (zero) or greater than the length of the ScreenModeList array.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.ScreenMode Property


LineDisplayProperties.ScreenModeList Property

LineDisplayProperties.ScreenModeList Property |
 | See Also

1/18/2008

Holds the array of DisplayScreenMode class instances that are supported by the device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property ScreenModeList As DisplayScreenMode()
public DisplayScreenMode[] ScreenModeList { get; }
public:
property array<DisplayScreenMode^>^ ScreenModeList {
    array<DisplayScreenMode^>^ get ();
}
/** @property */
public DisplayScreenMode[] get_ScreenModeList ()

public function get ScreenModeList () : DisplayScreenMode[]

Remarks

If the CapScreenMode property is set to false, the array will contain only one instance of the DisplayScreenMode structure. When ScreenModeList is set to a valid value, the CapScreenMode property is set to true.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayProperties Class
LineDisplayProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplayBase.ScreenModeList Property


LineDisplayScreenMode Class

LineDisplayScreenMode Class |
 | See Also Members

1/18/2008

An array of instances of DisplayScreenMode is used to provide a list of supported screen modes for the ScreenModeList property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class LineDisplayScreenMode
    Inherits DisplayScreenMode
public class LineDisplayScreenMode : DisplayScreenMode
public ref class LineDisplayScreenMode : public DisplayScreenMode
public class LineDisplayScreenMode extends DisplayScreenMode
public class LineDisplayScreenMode extends DisplayScreenMode

Remarks

An array of instances of DisplayScreenMode is used to provide a list of supported screen modes for the ScreenModeList property.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.DisplayScreenMode
Microsoft.PointOfService.BaseServiceObjects.LineDisplayScreenMode

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayScreenMode Members
Microsoft.PointOfService.BaseServiceObjects Namespace


LineDisplayScreenMode Members

LineDisplayScreenMode Members |
 | See Also Constructors Methods Properties

1/18/2008

An array of instances of DisplayScreenMode is used to provide a list of supported screen modes for the ScreenModeList property.

The following tables list the members exposed by the LineDisplayScreenMode type.

Public Constructors

Name | Description
LineDisplayScreenMode | Creates a new instance of the LineDisplayScreenMode class with the specified number of columns, rows, glyph width, and glyph height.
Top

Public Properties

Name | Description
Columns | Gets the number of columns supported for this screen mode. (inherited from DisplayScreenMode)
GlyphHeight | The glyph height based on the number of pixels for a character cell.
GlyphWidth | The glyph width based on the number of pixels for a character cell.
MaximumX | The maximum number of horizontal pixels supported by the device.
MaximumY | The maximum number of vertical pixels supported by the device.
Rows | Gets the number of rows supported for this screen mode. (inherited from DisplayScreenMode)
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string representation of the object. (inherited from DisplayScreenMode)
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

LineDisplayScreenMode Class
Microsoft.PointOfService.BaseServiceObjects Namespace


LineDisplayScreenMode Constructor

LineDisplayScreenMode Constructor |
 | See Also

1/18/2008

Creates a new instance of the LineDisplayScreenMode class with the specified number of columns, rows, glyph width, and glyph height.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub New ( _
    deviceColumns As Integer, _
    deviceRows As Integer, _
    glyphWidth As Integer, _
    glyphHeight As Integer _
)
public LineDisplayScreenMode (
    int deviceColumns,
    int deviceRows,
    int glyphWidth,
    int glyphHeight
)
public:
LineDisplayScreenMode (
    int deviceColumns,
    int deviceRows,
    int glyphWidth,
    int glyphHeight
)
public LineDisplayScreenMode (
    int deviceColumns,
    int deviceRows,
    int glyphWidth,
    int glyphHeight
)
public function LineDisplayScreenMode (
    deviceColumns : int,
    deviceRows : int,
    glyphWidth : int,
    glyphHeight : int
)

Parameters

deviceColumns

The number of device columns.

deviceRows

The number of device rows.

glyphWidth

The glyph width based on the number of pixels for a character cell.

glyphHeight

The glyph height based on the number of pixels for a character cell.

Remarks

Creates a new instance of the LineDisplayScreenMode class with the specified number of columns, rows, glyph width, and glyph height.

See Also

Reference

LineDisplayScreenMode Class
LineDisplayScreenMode Members
Microsoft.PointOfService.BaseServiceObjects Namespace


LineDisplayScreenMode Methods

LineDisplayScreenMode Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string representation of the object. (inherited from DisplayScreenMode )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

LineDisplayScreenMode Class
Microsoft.PointOfService.BaseServiceObjects Namespace


LineDisplayScreenMode Properties

LineDisplayScreenMode Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
Columns | Gets the number of columns supported for this screen mode. (inherited from DisplayScreenMode )
GlyphHeight | The glyph height based on the number of pixels for a character cell.
GlyphWidth | The glyph width based on the number of pixels for a character cell.
MaximumX | The maximum number of horizontal pixels supported by the device.
MaximumY | The maximum number of vertical pixels supported by the device.
Rows | Gets the number of rows supported for this screen mode. (inherited from DisplayScreenMode )

See Also

Reference

LineDisplayScreenMode Class
Microsoft.PointOfService.BaseServiceObjects Namespace


LineDisplayScreenMode.GlyphHeight Property

LineDisplayScreenMode.GlyphHeight Property |
 | See Also

1/18/2008

The glyph height based on the number of pixels for a character cell.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property GlyphHeight As Integer
public int GlyphHeight { get; }
public:
property int GlyphHeight {
    int get ();
}
/** @property */
public int get_GlyphHeight ()

public function get GlyphHeight () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayScreenMode Class
LineDisplayScreenMode Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.GlyphHeight Property


LineDisplayScreenMode.GlyphWidth Property

LineDisplayScreenMode.GlyphWidth Property |
 | See Also

1/18/2008

The glyph width based on the number of pixels for a character cell.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property GlyphWidth As Integer
public int GlyphWidth { get; }
public:
property int GlyphWidth {
    int get ();
}
/** @property */
public int get_GlyphWidth ()

public function get GlyphWidth () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayScreenMode Class
LineDisplayScreenMode Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.GlyphWidth Property


LineDisplayScreenMode.MaximumX Property

LineDisplayScreenMode.MaximumX Property |
 | See Also

1/18/2008

The maximum number of horizontal pixels supported by the device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property MaximumX As Integer
public int MaximumX { get; }
public:
property int MaximumX {
    int get ();
}
/** @property */
public int get_MaximumX ()

public function get MaximumX () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayScreenMode Class
LineDisplayScreenMode Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.MaximumX Property


LineDisplayScreenMode.MaximumY Property

LineDisplayScreenMode.MaximumY Property |
 | See Also

1/18/2008

The maximum number of vertical pixels supported by the device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property MaximumY As Integer
public int MaximumY { get; }
public:
property int MaximumY {
    int get ();
}
/** @property */
public int get_MaximumY ()

public function get MaximumY () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

LineDisplayScreenMode Class
LineDisplayScreenMode Members
Microsoft.PointOfService.BaseServiceObjects Namespace
LineDisplay.MaximumY Property


MarkFeedOperation Class

MarkFeedOperation Class |
 | See Also Members

1/18/2008

Used to capture information about the MarkFeed method call.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class MarkFeedOperation
    Inherits PrintOperation
public class MarkFeedOperation : PrintOperation
public ref class MarkFeedOperation : public PrintOperation
public class MarkFeedOperation extends PrintOperation
public class MarkFeedOperation extends PrintOperation

Remarks

The MarkFeedOperation helper class derives from the PrintOperation helper class. When the application updates printer properties and then calls the MarkFeed method, the PosPrinterBase class uses an instance of the MarkFeedOperation class, cast to the PrintOperation class and stored in the PrintOperationCollection array, to capture information about that method call. The service object then retrieves the operation from the array and uses it to complete the application’s print request.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BaseServiceObjects.PrintOperation
Microsoft.PointOfService.BaseServiceObjects.MarkFeedOperation

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MarkFeedOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase
MarkFeed
PrintOperation


MarkFeedOperation Members

MarkFeedOperation Members |
 | See Also Methods Properties

1/18/2008

Used to capture information about the MarkFeed method call.

The following tables list the members exposed by the MarkFeedOperation type.

Public Properties

Name | Description
AsyncMode | Contains the AsyncMode property setting at the time of the application’s print request. (inherited from PrintOperation)
Rotation | Contains the Rotation setting, as defined by the Rotation enumeration. (inherited from PrintOperation)
State | Contains an instance of the PrinterState class, which captures the current printer property values at the time of the application’s print request. (inherited from PrintOperation)
Station | Contains the printer station setting (for example, PrinterStation.Journal). (inherited from PrintOperation)
Type | Contains the value of the type parameter from the PosPrinter.MarkFeed method.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

MarkFeedOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase
MarkFeed
PrintOperation


MarkFeedOperation Methods

MarkFeedOperation Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

MarkFeedOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase
MarkFeed
PrintOperation


MarkFeedOperation Properties

MarkFeedOperation Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
AsyncMode | Contains the AsyncMode property setting at the time of the application’s print request. (inherited from PrintOperation )
Rotation | Contains the Rotation setting, as defined by the Rotation enumeration. (inherited from PrintOperation )
State | Contains an instance of the PrinterState class, which captures the current printer property values at the time of the application’s print request. (inherited from PrintOperation )
Station | Contains the printer station setting (for example, PrinterStation.Journal). (inherited from PrintOperation )
Type | Contains the value of the type parameter from the PosPrinter.MarkFeed method.

See Also

Reference

MarkFeedOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase
MarkFeed
PrintOperation


MarkFeedOperation.Type Property

MarkFeedOperation.Type Property |
 | See Also

1/18/2008

Contains the value of the type parameter from the PosPrinter.MarkFeed method.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Type As PrinterMarkFeeds
public PrinterMarkFeeds Type { get; }
public:
property PrinterMarkFeeds Type {
    PrinterMarkFeeds get ();
}
/** @property */
public PrinterMarkFeeds get_Type ()

public function get Type () : PrinterMarkFeeds

Remarks

Contains the value of the type parameter from the PosPrinter.MarkFeed method, as defined by the PrinterMarkFeeds enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MarkFeedOperation Class
MarkFeedOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.MarkFeed Method
PrinterMarkFeeds Enumeration


MsrBase Class

MsrBase Class |
 | See Also Members

1/18/2008

Contains most of the functionality for support of MSR devices.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public MustInherit Class MsrBase
    Inherits MsrBasic
public abstract class MsrBase : MsrBasic
public ref class MsrBase abstract : public MsrBasic
public abstract class MsrBase extends MsrBasic
public abstract class MsrBase extends MsrBasic

Remarks

The MsrBase class derives from the MsrBasic class and contains most of the functionality for support of MSR devices. When deriving from MsrBase, service objects should implement the CheckHealth and DirectIO methods. In addition, the service object should provide implementations for the ParseMsrTrackData and ParseMsrFieldData methods, which will be called by MsrBase class when appropriate. (The POS for .NET SDK includes a class called MsrDataParser, which is an example of how to parse track data in ISO format.)

The MsrBase class provides three protected methods, GoodRead, FailedRead, and UnreadableCard, for the management of swiped card data. The service object should call one of these three methods when a card swipe occurs, using the following guidelines:

  • GoodRead: Should be called when all tracks have been read successfully. The MsrBase class will queue a DataEvent event to the application and increment the StatisticGoodReadCount statistic;

  • FailedRead: Should be called when some tracks have been read successfully but others have not. The MsrBase class queues an ErrorEvent event, sets the TrackData properties for the tracks that were read successfully, and increments the StatisticFailedReadCount statistic;

  • UnreadableCard: Should be called when no track can be read successfully. The MsrBase class queues an ErrorEvent event and increments the StatisticUnreadableCardCount statistic.

The MsrBase class provides the core functionality for opening, claiming, and enabling MSR devices. Typically, though, service objects will want to override these methods to add their own custom processing. (An example would be to update device statistics during the Open method, or to bring the device online when the application enables it.) When overriding these methods, the service object must call the base class implementation.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.Msr
Microsoft.PointOfService.BasicServiceObjects.MsrBasic
Microsoft.PointOfService.BaseServiceObjects.MsrBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase Members

MsrBase Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Contains most of the functionality for support of MSR devices.

The following tables list the members exposed by the MsrBase type.

Protected Constructors

Name | Description
MsrBase | Creates a new instance of the MsrBase class.
Top

Public Fields

Name | Description
CardTypeAamva | Indicates the card type is AAMVA. (inherited from Msr)
CardTypeBank | Indicates the card type is BANK. (inherited from Msr)
ExtendedErrorDeviceAuthenticationFailed | Indicates an extended error where the device authentication process failed. (inherited from Msr)
ExtendedErrorDeviceDeauthenticationFailed | Indicates an extended error where the device deauthentication failed. (inherited from Msr)
ExtendedErrorEnd | Indicates an end sentinel error. (inherited from Msr)
ExtendedErrorFailure | Indicates a general error. (inherited from Msr)
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorLrc | Indicates an LRC error. (inherited from Msr)
ExtendedErrorParity | Indicates a parity error. (inherited from Msr)
ExtendedErrorStart | Indicates a start sentinel error. (inherited from Msr)
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
ExtendedErrorSuccess | Indicates no error. (inherited from Msr)
StatisticChallengeRequestCount | Contains the count of challenge requests. (inherited from Msr)
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFailedCardAuthenticationDataCount | Contains the count of failed card authentication attempts. (inherited from Msr)
StatisticFailedDeviceAuthenticationCount | Contains the count of failed device authentication attempts. (inherited from Msr)
StatisticFailedReadCount | This is field contains the node name used in the POS.NET XML statistics file. The number of failed card reads is stored in this node. (inherited from Msr)
StatisticFailedWriteCount | This is field contains a node name used in the POS.NET XML statistics file. The number of failed card writes is stored in this node. (inherited from Msr)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticGoodCardAuthenticationDataCount | Contains the count of successful card authentication attempts. (inherited from Msr)
StatisticGoodDeviceAuthenticationCount | Contains the count of successful device authentication attempts. (inherited from Msr)
StatisticGoodReadCount | This is field contains the node name used in the POS.NET XML statistics file. The number of successful card reads is stored in this node. (inherited from Msr)
StatisticGoodWriteCount | This is field contains a node name used in the POS.NET XML statistics file. The number of successful card writes is stored in this node. (inherited from Msr)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticMissingStartSentinelTrack1Count | This is field contains a node name used in the POS.NET XML statistics file. The number of times the track 1 sentinel was found missing is stored in this node. (inherited from Msr)
StatisticMissingStartSentinelTrack2Count | This is field contains a node name used in the POS.NET XML statistics file. The number of times the track 2 sentinel was found missing is stored in this node. (inherited from Msr)
StatisticMissingStartSentinelTrack3Count | This is field contains a node name used in the POS.NET XML statistics file. The number of times the track 3 sentinel was found missing is stored in this node. (inherited from Msr)
StatisticMissingStartSentinelTrack4Count | This is field contains a node name used in the POS.NET XML statistics file. The number of times the track 1 sentinel was found missing is stored in this node. (inherited from Msr)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticParityLrcErrorTrack1Count | This is field contains the node name used in the POS.NET XML statistics file. The number of parity errors for track 1 is stored in this node. (inherited from Msr)
StatisticParityLrcErrorTrack2Count | This is field contains the node name used in the POS.NET XML statistics file. The number of parity errors for track 2 is stored in this node. (inherited from Msr)
StatisticParityLrcErrorTrack3Count | This is field contains the node name used in the POS.NET XML statistics file. The number of parity errors for track 3 is stored in this node. (inherited from Msr)
StatisticParityLrcErrorTrack4Count | This is field contains the node name used in the POS.NET XML statistics file. The number of parity errors for track 4 is stored in this node. (inherited from Msr)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatisticUnreadableCardCount | This is field contains the node name used in the POS.NET XML statistics file. The number of failed card reads is stored in this node. (inherited from Msr)
StatusDeviceAuthenticated | Indicates if the device is authenticated. (inherited from Msr)
StatusDeviceDeauthenticated | Indicates if the device is deauthenticated. (inherited from Msr)
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
AccountNumber | Overridden. Holds the account number from the most recently swiped card.
AdditionalSecurityInformation | Overridden. Gets additional security/encryption information when a DataEvent is delivered.
AutoDisable | Indicates whether POS for .NET automatically disables the device when data is received. (inherited from MsrBasic)
CapCardAuthentication | Overridden. Gets the type, if any, of card authentication data that is supported by the device.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from MsrBasic)
CapDataEncryption | Overridden. Gets a bitwise indication of the encryption algorithms supported by the device and is selectable via the DataEncryptionAlgorithm property.
CapDeviceAuthentication | Overridden. Gets the level of device authentication supported by the service.
CapIso | Overridden. Indicates that the MSR supports ISO cards.
CapJisOne | Overridden. Indicates that the MSR device supports JIS Type-I cards.
CapJisTwo | Overridden. Indicates that the MSR device supports JIS Type-II cards.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from MsrBasic)
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from MsrBasic)
CapTrackDataMasking | Overridden. Gets a Boolean value that indicates whether the service supports track data masking.
CapTransmitSentinels | Overridden. Indicates that the MSR device can transmit start and end sentinels.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from MsrBasic)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from MsrBasic)
CapWritableTracks | Overridden. Indicates whether the MSR device can write track data and, if so, which tracks are supported.
CardAuthenticationData | Overridden. Gets the card authentication information when a DataEvent is delivered.
CardAuthenticationDataLength | Overridden. Gets the length of the raw CardAuthenticationData before it is encrypted.
CardPropertyList | Overridden. Gets a comma separated list of the names of the properties parsed from the most recently swiped card.
CardType | Overridden. Gets the card type identifier for the most recently swiped card.
CardTypeList | Overridden. Gets a comma separated list of string names of card types supported by the service.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from MsrBasic)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
DataCount | Holds the number of data events currently queued by the service object. (inherited from MsrBasic)
DataEncryptionAlgorithm | Overridden. Gets and sets the encryption algorithm that will be used to encrypt the track data.
DataEventEnabled | When set to true by the application, POS for .NET delivers the next event in the event queue. (inherited from MsrBasic)
DecodeData | Overridden. If false, the Track1Data, Track2Data, Track3Data, and Track4Data properties contain the original encoded bit sequence, known as “raw format.”
DeviceAuthenticated | Overridden. Gets a Boolean value that indicates whether the device supports authentication.
DeviceAuthenticationProtocol | Overridden. Gets the device authentication protocol supported by the device.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from MsrBasic)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from MsrBasic)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from MsrBasic)
EncodingMaxLength | Overridden. Holds the maximum length of data that can be written by the MSR to the track or tracks defined by the TracksToWrite property.
ErrorReportingType | Overridden. Holds the type of error reporting the application wants to receive. Possible values are defined by the MsrErrorReporting enumeration.
ExpirationDate | Overridden. Holds the expiration date from the most recently swiped card, as four ASCII decimal characters in the form YYMM.
FirstName | Overridden. Holds the first name from the most recently swiped card.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from MsrBasic)
MiddleInitial | Overridden. Holds the middle initial from the most recently swiped card.
ParseDecodeData | Overridden. If true, the decoded data contained within the Track1Data and Track2Data properties is further separated into fields for access via various other properties.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from MsrBasic)
PowerState | Gets the current power condition. (inherited from MsrBasic)
ServiceCode | Overridden. Holds the service code from the most recently swiped card.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from MsrBasic)
ServiceObjectVersion | Gets the Service Object version number. (inherited from MsrBasic)
State | Gets the current state of the device. (inherited from MsrBasic)
Suffix | Overridden. Holds the suffix from the most recently swiped card.
Surname | Overridden. Holds the surname from the most recently swiped card.
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Title | Overridden. Holds the title from the most recently swiped card.
Track1Data | Overridden. Holds either the Track 1 data from the most recently swiped card or an empty array.
Track1DiscretionaryData | Overridden. Holds the Track 1 discretionary data from the most recently swiped card.
Track1EncryptedData | Overridden. Gets the length of the raw Track1Data before it is encrypted.
Track1EncryptedDataLength | Overridden. Gets the encrypted track 1 data obtained from the most recently swiped card.
Track2Data | Overridden. Holds either the Track 2 data from the most recently swiped card or an empty array.
Track2DiscretionaryData | Overridden. The Track 2 discretionary data from the most recently swiped card.
Track2EncryptedData | Overridden. Holds the length of the raw Track2Data before it is encrypted.
Track2EncryptedDataLength | Overridden. Gets the encrypted track 2 data obtained from the most recently swiped card.
Track3Data | Overridden. Holds either the Track 3 data from the most recently swiped card or an empty array.
Track3EncryptedData | Overridden. Gets the length of the raw Track3Data before it is encrypted.
Track3EncryptedDataLength | Overridden. Gets the encrypted track 3 data obtained from the most recently swiped card.
Track4Data | Overridden. Holds the Track 4 data (JIS-II) from the most recently swiped card.
Track4EncryptedData | Overridden. Gets the encrypted track 4 data obtained from the most recently swiped card.
Track4EncryptedDataLength | Overridden. Gets the length of the raw Track4Data before it is encrypted.
TracksToRead | Overridden. Indicates the track data that the application wishes to place into the Track1Data, Track2Data, Track3Data and Track4Data properties following a card swipe.
TracksToWrite | Overridden. Specifies which MSR tracks will be written when the WriteTracks method is called and an MSR card swiped.
TransmitSentinels | Overridden. Indicates that the Track1Data, Track2Data, Track3Data, and Track4Data properties contain start sentinel and end sentinel values.
WriteCardType | Overridden. Holds the card type to be used the next time the WriteTracks method is called.
Top

Protected Properties

Name | Description
CommonProperties | (inherited from MsrBasic )
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
ErrorCount | (inherited from MsrBasic )
ExternallyClaimed | (inherited from MsrBasic )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Indicates whether the Msr is an exclusive-use device. (inherited from Msr)
Properties | Contains getters and setters for common and Msr specific properties.
Top

Public Methods (see also Protected Methods )

Name | Description
AuthenticateDevice | (inherited from Msr )
CheckHealth | (inherited from PosCommon )
Claim | (inherited from MsrBasic )
ClearInput | Clears all device input that has been buffered. (inherited from MsrBasic)
ClearInputProperties | Overridden. Resets the values of properties altered by DataEvent or ErrorEvent.
Close | Releases the device and its resources. (inherited from MsrBasic)
CompareFirmwareVersion | (inherited from PosCommon )
DeauthenticateDevice | (inherited from Msr )
DirectIO | (inherited from PosCommon )
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Overridden. Initializes MSR properties DecodeData, ParseDecodeData, TransmitSentinels, ErrorReprtingType, and MsrTracksToRead.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from MsrBasic)
ResetStatistic | (inherited from MsrBasic )
ResetStatistics | Overloaded. (inherited from MsrBasic )
RetrieveCardProperty | Overridden.
RetrieveDeviceAuthenticationData | Applications call this method to retrieve a challenge token that will subsequently be used to generate response tokens that will be passed to the AuthenticateDevice and DeauthenticateDevice methods. (inherited from Msr)
RetrieveStatistic | (inherited from MsrBasic )
RetrieveStatistics | Overloaded. (inherited from MsrBasic )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateKey | (inherited from Msr )
UpdateStatistic | (inherited from MsrBasic )
UpdateStatistics | Overloaded. (inherited from MsrBasic )
WriteTracks | Overridden. Initiates the encoding of data to the MSR track(s) selected in the TracksToWrite property.
Top

Protected Methods

Name | Description
ClearInputImpl | (inherited from MsrBasic )
CreateStatistic | Overloaded. (inherited from MsrBasic )
DeleteConfigurationProperty | (inherited from PosCommon )
Dispose | Overloaded. Overridden.
FailedRead | Overloaded.
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
GetStatisticValue | (inherited from MsrBasic )
GoodRead | Overloaded.
IncrementStatistic | Overloaded. (inherited from MsrBasic )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
ParseMsrFieldData | Called to decode card data into the appropriate properties.
ParseMsrTrackData | Called to decode card data into the appropriate properties.
PreFireEvent | Overloaded. Overridden.
QueueEvent | Overloaded. (inherited from MsrBasic )
QueueEventAndWait | Overloaded. (inherited from MsrBasic )
SetConfigurationProperty | (inherited from PosCommon )
SetMaxTrackEncodingLengths | Sets the maximum encoding length for the specified Msr data tracks.
SetStatisticHandlers | (inherited from MsrBasic )
SetStatisticValue | (inherited from MsrBasic )
UnreadableCard | Called by the service object when the card data is unreadable.
VerifyState | (inherited from MsrBasic )
WriteTracksImpl |
Top

Public Events (see also Protected Events )

Name | Description
DataEvent | Raised by the service object to indicate the delivery of input data from the device to the application. (inherited from MsrBasic)
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from MsrBasic)
ErrorEvent | Raised by the service object when an error is detected while trying to read MSR data. (inherited from MsrBasic)
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from MsrBasic)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
StateChangedEvent | (inherited from MsrBasic )
Top

See Also

Reference

MsrBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase Fields

MsrBase Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
CardTypeAamva | Indicates the card type is AAMVA. (inherited from Msr )
CardTypeBank | Indicates the card type is BANK. (inherited from Msr )
ExtendedErrorDeviceAuthenticationFailed | Indicates an extended error where the device authentication process failed. (inherited from Msr )
ExtendedErrorDeviceDeauthenticationFailed | Indicates an extended error where the device deauthentication failed. (inherited from Msr )
ExtendedErrorEnd | Indicates an end sentinel error. (inherited from Msr )
ExtendedErrorFailure | Indicates a general error. (inherited from Msr )
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorLrc | Indicates an LRC error. (inherited from Msr )
ExtendedErrorParity | Indicates a parity error. (inherited from Msr )
ExtendedErrorStart | Indicates a start sentinel error. (inherited from Msr )
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
ExtendedErrorSuccess | Indicates no error. (inherited from Msr )
StatisticChallengeRequestCount | Contains the count of challenge requests. (inherited from Msr )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFailedCardAuthenticationDataCount | Contains the count of failed card authentication attempts. (inherited from Msr )
StatisticFailedDeviceAuthenticationCount | Contains the count of failed device authentication attempts. (inherited from Msr )
StatisticFailedReadCount | This is field contains the node name used in the POS.NET XML statistics file. The number of failed card reads is stored in this node. (inherited from Msr )
StatisticFailedWriteCount | This is field contains a node name used in the POS.NET XML statistics file. The number of failed card writes is stored in this node. (inherited from Msr )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticGoodCardAuthenticationDataCount | Contains the count of successful card authentication attempts. (inherited from Msr )
StatisticGoodDeviceAuthenticationCount | Contains the count of successful device authentication attempts. (inherited from Msr )
StatisticGoodReadCount | This is field contains the node name used in the POS.NET XML statistics file. The number of successful card reads is stored in this node. (inherited from Msr )
StatisticGoodWriteCount | This is field contains a node name used in the POS.NET XML statistics file. The number of successful card writes is stored in this node. (inherited from Msr )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticMissingStartSentinelTrack1Count | This is field contains a node name used in the POS.NET XML statistics file. The number of times the track 1 sentinel was found missing is stored in this node. (inherited from Msr )
StatisticMissingStartSentinelTrack2Count | This is field contains a node name used in the POS.NET XML statistics file. The number of times the track 2 sentinel was found missing is stored in this node. (inherited from Msr )
StatisticMissingStartSentinelTrack3Count | This is field contains a node name used in the POS.NET XML statistics file. The number of times the track 3 sentinel was found missing is stored in this node. (inherited from Msr )
StatisticMissingStartSentinelTrack4Count | This is field contains a node name used in the POS.NET XML statistics file. The number of times the track 1 sentinel was found missing is stored in this node. (inherited from Msr )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticParityLrcErrorTrack1Count | This is field contains the node name used in the POS.NET XML statistics file. The number of parity errors for track 1 is stored in this node. (inherited from Msr )
StatisticParityLrcErrorTrack2Count | This is field contains the node name used in the POS.NET XML statistics file. The number of parity errors for track 2 is stored in this node. (inherited from Msr )
StatisticParityLrcErrorTrack3Count | This is field contains the node name used in the POS.NET XML statistics file. The number of parity errors for track 3 is stored in this node. (inherited from Msr )
StatisticParityLrcErrorTrack4Count | This is field contains the node name used in the POS.NET XML statistics file. The number of parity errors for track 4 is stored in this node. (inherited from Msr )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatisticUnreadableCardCount | This is field contains the node name used in the POS.NET XML statistics file. The number of failed card reads is stored in this node. (inherited from Msr )
StatusDeviceAuthenticated | Indicates if the device is authenticated. (inherited from Msr )
StatusDeviceDeauthenticated | Indicates if the device is deauthenticated. (inherited from Msr )
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

MsrBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase Constructor

MsrBase Constructor |
 | See Also

1/18/2008

Creates a new instance of the MsrBase class.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Sub New
protected MsrBase ()
protected:
MsrBase ()
protected MsrBase ()
protected function MsrBase ()

Remarks

Creates an instance of the MsrBase class. Initializes statistics for the UPOS Version, the Device Category, and the Installation Date.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase Methods

MsrBase Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
AuthenticateDevice | (inherited from Msr )
CheckHealth | (inherited from PosCommon )
Claim | (inherited from MsrBasic )
ClearInput | Clears all device input that has been buffered. (inherited from MsrBasic )
ClearInputProperties | Overridden. Resets the values of properties altered by DataEvent or ErrorEvent.
Close | Releases the device and its resources. (inherited from MsrBasic )
CompareFirmwareVersion | (inherited from PosCommon )
DeauthenticateDevice | (inherited from Msr )
DirectIO | (inherited from PosCommon )
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Overridden. Initializes MSR properties DecodeData, ParseDecodeData, TransmitSentinels, ErrorReprtingType, and MsrTracksToRead.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from MsrBasic )
ResetStatistic | (inherited from MsrBasic )
ResetStatistics | Overloaded. (inherited from MsrBasic )
RetrieveCardProperty | Overridden.
RetrieveDeviceAuthenticationData | Applications call this method to retrieve a challenge token that will subsequently be used to generate response tokens that will be passed to the AuthenticateDevice and DeauthenticateDevice methods. (inherited from Msr )
RetrieveStatistic | (inherited from MsrBasic )
RetrieveStatistics | Overloaded. (inherited from MsrBasic )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateKey | (inherited from Msr )
UpdateStatistic | (inherited from MsrBasic )
UpdateStatistics | Overloaded. (inherited from MsrBasic )
WriteTracks | Overridden. Initiates the encoding of data to the MSR track(s) selected in the TracksToWrite property.

Protected Methods

Name | Description
ClearInputImpl | (inherited from MsrBasic )
CreateStatistic | Overloaded. (inherited from MsrBasic )
DeleteConfigurationProperty | (inherited from PosCommon )
Dispose | Overloaded. Overridden.
FailedRead | Overloaded.
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
GetStatisticValue | (inherited from MsrBasic )
GoodRead | Overloaded.
IncrementStatistic | Overloaded. (inherited from MsrBasic )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
ParseMsrFieldData | Called to decode card data into the appropriate properties.
ParseMsrTrackData | Called to decode card data into the appropriate properties.
PreFireEvent | Overloaded. Overridden.
QueueEvent | Overloaded. (inherited from MsrBasic )
QueueEventAndWait | Overloaded. (inherited from MsrBasic )
SetConfigurationProperty | (inherited from PosCommon )
SetMaxTrackEncodingLengths | Sets the maximum encoding length for the specified Msr data tracks.
SetStatisticHandlers | (inherited from MsrBasic )
SetStatisticValue | (inherited from MsrBasic )
UnreadableCard | Called by the service object when the card data is unreadable.
VerifyState | (inherited from MsrBasic )
WriteTracksImpl |

See Also

Reference

MsrBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.ClearInputProperties Method

MsrBase.ClearInputProperties Method |
 | See Also

1/18/2008

Resets the values of properties altered by DataEvent or ErrorEvent.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub ClearInputProperties
public override void ClearInputProperties ()
public:
virtual void ClearInputProperties () override
public void ClearInputProperties ()
public override function ClearInputProperties ()

Remarks

Resets the values of properties altered by DataEvent or ErrorEvent.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.Dispose Method

MsrBase.Dispose Method |
 | See Also

1/18/2008

Overload List

Name | Description
MsrBase.Dispose () | (inherited from Dispose )
MsrBase.Dispose (Boolean) |

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.Dispose Method (Boolean)

MsrBase.Dispose Method (Boolean) |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected override void Dispose (
    bool disposing
)
protected:
virtual void Dispose (
    bool disposing
) override
protected void Dispose (
    boolean disposing
)
protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.FailedRead Method

MsrBase.FailedRead Method |
 | See Also

1/18/2008

Overload List

Name | Description
MsrBase.FailedRead (Byte[], Byte[], Byte[], Byte[], CardType, ErrorCode, Int32) | Called by the service object when an error occurs while the MSR device is attempting to read card data.
MsrBase.FailedRead (Byte[], Byte[], Byte[], Byte[], CardType, ErrorCode, Int32, Byte[]) |
MsrBase.FailedRead (Byte[], Byte[], Byte[], Byte[], CardType, ErrorCode, Int32, Byte[], Byte[], Int32) |

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
ErrorCode Enumeration
CardType Enumeration
Msr.ErrorEvent Event
Msr.StatisticFailedReadCount Field


MsrBase.FailedRead Method (Byte[], Byte[], Byte[], Byte[], CardType, ErrorCode, Int32)

MsrBase.FailedRead Method (Byte[], Byte[], Byte[], Byte[], CardType, ErrorCode, Int32) |
 | See Also

1/18/2008

Called by the service object when an error occurs while the MSR device is attempting to read card data.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Sub FailedRead ( _
    track1Data As Byte(), _
    track2Data As Byte(), _
    track3Data As Byte(), _
    track4Data As Byte(), _
    cardType As CardType, _
    errorCode As ErrorCode, _
    extendedErrorCode As Integer _
)
protected void FailedRead (
    byte[] track1Data,
    byte[] track2Data,
    byte[] track3Data,
    byte[] track4Data,
    CardType cardType,
    ErrorCode errorCode,
    int extendedErrorCode
)
protected:
void FailedRead (
    array<unsigned char>^ track1Data,
    array<unsigned char>^ track2Data,
    array<unsigned char>^ track3Data,
    array<unsigned char>^ track4Data,
    CardType cardType,
    ErrorCode errorCode,
    int extendedErrorCode
)
protected void FailedRead (
    byte[] track1Data,
    byte[] track2Data,
    byte[] track3Data,
    byte[] track4Data,
    CardType cardType,
    ErrorCode errorCode,
    int extendedErrorCode
)
protected function FailedRead (
    track1Data : byte[],
    track2Data : byte[],
    track3Data : byte[],
    track4Data : byte[],
    cardType : CardType,
    errorCode : ErrorCode,
    extendedErrorCode : int
)

Parameters

track1Data

Contains the data read for Track1.

track2Data

Contains the data read for Track2.

track3Data

Contains the data read for Track3.

track4Data

Contains the data read for Track4.

cardType

Contains the type of card swiped, as defined by the CardType enumeration.

errorCode

Contains the error reporting code, as defined by the ErrorCode enumeration.

extendedErrorCode

Contains one of the ExtendedError~ constants that describes the type of card read error.

Remarks

Called by the service object when an error occurs while the MSR device is attempting to read card data. The service object passes the appropriate error information using the function parameters. MsrBase class increments the StatisticFailedReadCount statistic, then queues an ErrorEvent event, informing the application of the error.

If the ErrorReportingType property is set to MsrErrorReporting.Track, MsrBase class updates the TrackData properties for any successful reads. In addition, if the errorCode parameter is set to ErrorCode.Extended, the service object should set the appropriate ExtendedError~ constants for each of the four bytes of the extendedErrorCode parameter, based on the status of each of the four tracks, and then build the corresponding integer to be passed as the value for the extendedErrorCode parameter.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
ErrorCode Enumeration
CardType Enumeration
Msr.ErrorEvent Event
Msr.StatisticFailedReadCount Field


MsrBase.FailedRead Method (Byte[], Byte[], Byte[], Byte[], CardType, ErrorCode, Int32, Byte[])

MsrBase.FailedRead Method (Byte[], Byte[], Byte[], Byte[], CardType, ErrorCode, Int32, Byte[]) |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Sub FailedRead ( _
    track1Data As Byte(), _
    track2Data As Byte(), _
    track3Data As Byte(), _
    track4Data As Byte(), _
    cardType As CardType, _
    errorCode As ErrorCode, _
    extendedErrorCode As Integer, _
    additionalSecurityInformation As Byte() _
)

protected void FailedRead (
    byte[] track1Data,
    byte[] track2Data,
    byte[] track3Data,
    byte[] track4Data,
    CardType cardType,
    ErrorCode errorCode,
    int extendedErrorCode,
    byte[] additionalSecurityInformation
)

protected:
void FailedRead (
    array<unsigned char>^ track1Data,
    array<unsigned char>^ track2Data,
    array<unsigned char>^ track3Data,
    array<unsigned char>^ track4Data,
    CardType cardType,
    ErrorCode errorCode,
    int extendedErrorCode,
    array<unsigned char>^ additionalSecurityInformation
)

protected void FailedRead (
    byte[] track1Data,
    byte[] track2Data,
    byte[] track3Data,
    byte[] track4Data,
    CardType cardType,
    ErrorCode errorCode,
    int extendedErrorCode,
    byte[] additionalSecurityInformation
)

protected function FailedRead (
    track1Data : byte[],
    track2Data : byte[],
    track3Data : byte[],
    track4Data : byte[],
    cardType : CardType,
    errorCode : ErrorCode,
    extendedErrorCode : int,
    additionalSecurityInformation : byte[]
)

Parameters

track1Data
track2Data
track3Data
track4Data
cardType
errorCode
extendedErrorCode
additionalSecurityInformation

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.FailedRead Method (Byte[], Byte[], Byte[], Byte[], CardType, ErrorCode, Int32, Byte[], Byte[], Int32)

MsrBase.FailedRead Method (Byte[], Byte[], Byte[], Byte[], CardType, ErrorCode, Int32, Byte[], Byte[], Int32) |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Sub FailedRead ( _
    track1Data As Byte(), _
    track2Data As Byte(), _
    track3Data As Byte(), _
    track4Data As Byte(), _
    cardType As CardType, _
    errorCode As ErrorCode, _
    extendedErrorCode As Integer, _
    additionalSecurityInformation As Byte(), _
    cardAuthenticationData As Byte(), _
    cardAuthenticationDataLength As Integer _
)

protected void FailedRead (
    byte[] track1Data,
    byte[] track2Data,
    byte[] track3Data,
    byte[] track4Data,
    CardType cardType,
    ErrorCode errorCode,
    int extendedErrorCode,
    byte[] additionalSecurityInformation,
    byte[] cardAuthenticationData,
    int cardAuthenticationDataLength
)

protected:
void FailedRead (
    array<unsigned char>^ track1Data,
    array<unsigned char>^ track2Data,
    array<unsigned char>^ track3Data,
    array<unsigned char>^ track4Data,
    CardType cardType,
    ErrorCode errorCode,
    int extendedErrorCode,
    array<unsigned char>^ additionalSecurityInformation,
    array<unsigned char>^ cardAuthenticationData,
    int cardAuthenticationDataLength
)

protected void FailedRead (
    byte[] track1Data,
    byte[] track2Data,
    byte[] track3Data,
    byte[] track4Data,
    CardType cardType,
    ErrorCode errorCode,
    int extendedErrorCode,
    byte[] additionalSecurityInformation,
    byte[] cardAuthenticationData,
    int cardAuthenticationDataLength
)

protected function FailedRead (
    track1Data : byte[],
    track2Data : byte[],
    track3Data : byte[],
    track4Data : byte[],
    cardType : CardType,
    errorCode : ErrorCode,
    extendedErrorCode : int,
    additionalSecurityInformation : byte[],
    cardAuthenticationData : byte[],
    cardAuthenticationDataLength : int
)

Parameters

track1Data
track2Data
track3Data
track4Data
cardType
errorCode
extendedErrorCode
additionalSecurityInformation
cardAuthenticationData
cardAuthenticationDataLength

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.GoodRead Method

MsrBase.GoodRead Method |
 | See Also

1/18/2008

Overload List

Name | Description
MsrBase.GoodRead (Byte[], Byte[], Byte[], Byte[], CardType) | Called by the service object when the card swipe has been successful.
MsrBase.GoodRead (Byte[], Int32, Byte[], Int32, Byte[], Int32, Byte[], Int32, CardType, Byte[]) |
MsrBase.GoodRead (Byte[], Int32, Byte[], Int32, Byte[], Int32, Byte[], Int32, Byte[], Byte[], Byte[], Byte[], CardType, Byte[], Byte[], Int32) |

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CardType Enumeration
Msr.DataEvent Event
Msr.StatisticGoodReadCount Field


MsrBase.GoodRead Method (Byte[], Byte[], Byte[], Byte[], CardType)

MsrBase.GoodRead Method (Byte[], Byte[], Byte[], Byte[], CardType) |
 | See Also

1/18/2008

Called by the service object when the card swipe has been successful.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Sub GoodRead ( _
    track1Data As Byte(), _
    track2Data As Byte(), _
    track3Data As Byte(), _
    track4Data As Byte(), _
    cardType As CardType _
)
protected void GoodRead (
    byte[] track1Data,
    byte[] track2Data,
    byte[] track3Data,
    byte[] track4Data,
    CardType cardType
)
protected:
void GoodRead (
    array<unsigned char>^ track1Data,
    array<unsigned char>^ track2Data,
    array<unsigned char>^ track3Data,
    array<unsigned char>^ track4Data,
    CardType cardType
)
protected void GoodRead (
    byte[] track1Data,
    byte[] track2Data,
    byte[] track3Data,
    byte[] track4Data,
    CardType cardType
)
protected function GoodRead (
    track1Data : byte[],
    track2Data : byte[],
    track3Data : byte[],
    track4Data : byte[],
    cardType : CardType
)

Parameters

track1Data

Contains the data read for Track1.

track2Data

Contains the data read for Track2.

track3Data

Contains the data read for Track3.

track4Data

Contains the data read for Track4.

cardType

Contains the type of card swiped, as defined by the CardType enumeration.

Remarks

Called by the service object when the card swipe has been successful. The service object passes the raw track data to the function. The MsrBase class increments the StatisticGoodReadCount statistic and queues a DataEvent event to the application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CardType Enumeration
Msr.DataEvent Event
Msr.StatisticGoodReadCount Field


MsrBase.GoodRead Method (Byte[], Int32, Byte[], Int32, Byte[], Int32, Byte[], Int32, CardType, Byte[])

MsrBase.GoodRead Method (Byte[], Int32, Byte[], Int32, Byte[], Int32, Byte[], Int32, CardType, Byte[]) |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Sub GoodRead ( _
    encryptedTrack1Data As Byte(), _
    encryptedTrack1DataLength As Integer, _
    encryptedTrack2Data As Byte(), _
    encryptedTrack2DataLength As Integer, _
    encryptedTrack3Data As Byte(), _
    encryptedTrack3DataLength As Integer, _
    encryptedTrack4Data As Byte(), _
    encryptedTrack4DataLength As Integer, _
    cardType As CardType, _
    additionalSecurityInformation As Byte() _
)

protected void GoodRead (
    byte[] encryptedTrack1Data,
    int encryptedTrack1DataLength,
    byte[] encryptedTrack2Data,
    int encryptedTrack2DataLength,
    byte[] encryptedTrack3Data,
    int encryptedTrack3DataLength,
    byte[] encryptedTrack4Data,
    int encryptedTrack4DataLength,
    CardType cardType,
    byte[] additionalSecurityInformation
)

protected:
void GoodRead (
    array<unsigned char>^ encryptedTrack1Data,
    int encryptedTrack1DataLength,
    array<unsigned char>^ encryptedTrack2Data,
    int encryptedTrack2DataLength,
    array<unsigned char>^ encryptedTrack3Data,
    int encryptedTrack3DataLength,
    array<unsigned char>^ encryptedTrack4Data,
    int encryptedTrack4DataLength,
    CardType cardType,
    array<unsigned char>^ additionalSecurityInformation
)

protected void GoodRead (
    byte[] encryptedTrack1Data,
    int encryptedTrack1DataLength,
    byte[] encryptedTrack2Data,
    int encryptedTrack2DataLength,
    byte[] encryptedTrack3Data,
    int encryptedTrack3DataLength,
    byte[] encryptedTrack4Data,
    int encryptedTrack4DataLength,
    CardType cardType,
    byte[] additionalSecurityInformation
)

protected function GoodRead (
    encryptedTrack1Data : byte[],
    encryptedTrack1DataLength : int,
    encryptedTrack2Data : byte[],
    encryptedTrack2DataLength : int,
    encryptedTrack3Data : byte[],
    encryptedTrack3DataLength : int,
    encryptedTrack4Data : byte[],
    encryptedTrack4DataLength : int,
    cardType : CardType,
    additionalSecurityInformation : byte[]
)

Parameters

encryptedTrack1Data
encryptedTrack1DataLength
encryptedTrack2Data
encryptedTrack2DataLength
encryptedTrack3Data
encryptedTrack3DataLength
encryptedTrack4Data
encryptedTrack4DataLength
cardType
additionalSecurityInformation

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.GoodRead Method (Byte[], Int32, Byte[], Int32, Byte[], Int32, Byte[], Int32, Byte[], Byte[], Byte[], Byte[], CardType, Byte[], Byte[], Int32)

MsrBase.GoodRead Method (Byte[], Int32, Byte[], Int32, Byte[], Int32, Byte[], Int32, Byte[], Byte[], Byte[], Byte[], CardType, Byte[], Byte[], Int32) |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Sub GoodRead ( _
    encryptedTrack1Data As Byte(), _
    encryptedTrack1DataLength As Integer, _
    encryptedTrack2Data As Byte(), _
    encryptedTrack2DataLength As Integer, _
    encryptedTrack3Data As Byte(), _
    encryptedTrack3DataLength As Integer, _
    encryptedTrack4Data As Byte(), _
    encryptedTrack4DataLength As Integer, _
    track1Data As Byte(), _
    track2Data As Byte(), _
    track3Data As Byte(), _
    track4Data As Byte(), _
    cardType As CardType, _
    additionalSecurityInformation As Byte(), _
    cardAuthenticationData As Byte(), _
    cardAuthenticationDataLength As Integer _
)

protected void GoodRead (
    byte[] encryptedTrack1Data,
    int encryptedTrack1DataLength,
    byte[] encryptedTrack2Data,
    int encryptedTrack2DataLength,
    byte[] encryptedTrack3Data,
    int encryptedTrack3DataLength,
    byte[] encryptedTrack4Data,
    int encryptedTrack4DataLength,
    byte[] track1Data,
    byte[] track2Data,
    byte[] track3Data,
    byte[] track4Data,
    CardType cardType,
    byte[] additionalSecurityInformation,
    byte[] cardAuthenticationData,
    int cardAuthenticationDataLength
)

protected:
void GoodRead (
    array<unsigned char>^ encryptedTrack1Data,
    int encryptedTrack1DataLength,
    array<unsigned char>^ encryptedTrack2Data,
    int encryptedTrack2DataLength,
    array<unsigned char>^ encryptedTrack3Data,
    int encryptedTrack3DataLength,
    array<unsigned char>^ encryptedTrack4Data,
    int encryptedTrack4DataLength,
    array<unsigned char>^ track1Data,
    array<unsigned char>^ track2Data,
    array<unsigned char>^ track3Data,
    array<unsigned char>^ track4Data,
    CardType cardType,
    array<unsigned char>^ additionalSecurityInformation,
    array<unsigned char>^ cardAuthenticationData,
    int cardAuthenticationDataLength
)

protected void GoodRead (
    byte[] encryptedTrack1Data,
    int encryptedTrack1DataLength,
    byte[] encryptedTrack2Data,
    int encryptedTrack2DataLength,
    byte[] encryptedTrack3Data,
    int encryptedTrack3DataLength,
    byte[] encryptedTrack4Data,
    int encryptedTrack4DataLength,
    byte[] track1Data,
    byte[] track2Data,
    byte[] track3Data,
    byte[] track4Data,
    CardType cardType,
    byte[] additionalSecurityInformation,
    byte[] cardAuthenticationData,
    int cardAuthenticationDataLength
)

protected function GoodRead (
    encryptedTrack1Data : byte[],
    encryptedTrack1DataLength : int,
    encryptedTrack2Data : byte[],
    encryptedTrack2DataLength : int,
    encryptedTrack3Data : byte[],
    encryptedTrack3DataLength : int,
    encryptedTrack4Data : byte[],
    encryptedTrack4DataLength : int,
    track1Data : byte[],
    track2Data : byte[],
    track3Data : byte[],
    track4Data : byte[],
    cardType : CardType,
    additionalSecurityInformation : byte[],
    cardAuthenticationData : byte[],
    cardAuthenticationDataLength : int
)

Parameters

encryptedTrack1Data
encryptedTrack1DataLength
encryptedTrack2Data
encryptedTrack2DataLength
encryptedTrack3Data
encryptedTrack3DataLength
encryptedTrack4Data
encryptedTrack4DataLength
track1Data
track2Data
track3Data
track4Data
cardType
additionalSecurityInformation
cardAuthenticationData
cardAuthenticationDataLength

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.Open Method

MsrBase.Open Method |
 | See Also

1/18/2008

Initializes MSR properties DecodeData, ParseDecodeData, TransmitSentinels, ErrorReprtingType, and MsrTracksToRead.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub Open
public override void Open ()
public:
virtual void Open () override
public void Open ()
public override function Open ()

Remarks

Initializes MSR properties DecodeData, ParseDecodeData, TransmitSentinels, ErrorReprtingType, and MsrTracksToRead.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
DecodeData
ParseDecodeData
TransmitSentinels
ErrorReportingType
TracksToRead


MsrBase.ParseMsrFieldData Method

MsrBase.ParseMsrFieldData Method |
 | See Also

1/18/2008

Called to decode card data into the appropriate properties.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected MustOverride Function ParseMsrFieldData ( _
    track1Data As Byte(), _
    track2Data As Byte(), _
    track3Data As Byte(), _
    track4Data As Byte(), _
    cardType As CardType _
) As MsrFieldData
protected abstract MsrFieldData ParseMsrFieldData (
    byte[] track1Data,
    byte[] track2Data,
    byte[] track3Data,
    byte[] track4Data,
    CardType cardType
)
protected:
virtual MsrFieldData^ ParseMsrFieldData (
    array<unsigned char>^ track1Data,
    array<unsigned char>^ track2Data,
    array<unsigned char>^ track3Data,
    array<unsigned char>^ track4Data,
    CardType cardType
) abstract
protected abstract MsrFieldData ParseMsrFieldData (
    byte[] track1Data,
    byte[] track2Data,
    byte[] track3Data,
    byte[] track4Data,
    CardType cardType
)
protected abstract function ParseMsrFieldData (
    track1Data : byte[],
    track2Data : byte[],
    track3Data : byte[],
    track4Data : byte[],
    cardType : CardType
) : MsrFieldData

Parameters

track1Data

Contains the data read for Track1

track2Data

Contains the data read for Track2

track3Data

Contains the data read for Track3

track4Data

Contains the data read for Track4

cardType

Contains the type of card swiped, as defined by the CardType enumeration.

Remarks

Called to decode card data into the appropriate properties. ParseMsrFieldData returns an instance of the MsrFieldData class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CardType Enumeration
MsrFieldData


MsrBase.ParseMsrTrackData Method

MsrBase.ParseMsrTrackData Method |
 | See Also

1/18/2008

Called to decode card data into the appropriate properties.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected MustOverride Function ParseMsrTrackData ( _
    track1Data As Byte(), _
    track2Data As Byte(), _
    track3Data As Byte(), _
    track4Data As Byte(), _
    cardType As CardType _
) As MsrTrackData
protected abstract MsrTrackData ParseMsrTrackData (
    byte[] track1Data,
    byte[] track2Data,
    byte[] track3Data,
    byte[] track4Data,
    CardType cardType
)
protected:
virtual MsrTrackData^ ParseMsrTrackData (
    array<unsigned char>^ track1Data,
    array<unsigned char>^ track2Data,
    array<unsigned char>^ track3Data,
    array<unsigned char>^ track4Data,
    CardType cardType
) abstract
protected abstract MsrTrackData ParseMsrTrackData (
    byte[] track1Data,
    byte[] track2Data,
    byte[] track3Data,
    byte[] track4Data,
    CardType cardType
)
protected abstract function ParseMsrTrackData (
    track1Data : byte[],
    track2Data : byte[],
    track3Data : byte[],
    track4Data : byte[],
    cardType : CardType
) : MsrTrackData

Parameters

track1Data

Contains the data read for Track1.

track2Data

Contains the data read for Track2.

track3Data

Contains the data read for Track3.

track4Data

Contains the data read for Track4.

cardType

Contains the type of card swiped, as defined by the CardType enumeration.

Remarks

Called to decode card data into the appropriate properties. ParseMsrTrackData returns an instance of the MsrTrackData class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CardType Enumeration
MsrTrackData


MsrBase.PreFireEvent Method

MsrBase.PreFireEvent Method |
 | See Also

1/18/2008

Overload List

Name | Description
MsrBase.PreFireEvent (DataEventArgs) | Called prior to the delivery of a DataEvent event to the application.
MsrBase.PreFireEvent (DeviceErrorEventArgs) | Called prior to the delivery of a DeviceErrorEvent event to the application.
MsrBase.PreFireEvent (DirectIOEventArgs) | (inherited from PreFireEvent )
MsrBase.PreFireEvent (StatusUpdateEventArgs) | (inherited from PreFireEvent )

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
MsrBase.ParseMsrTrackData Method
Msr.DataEvent Event


MsrBase.PreFireEvent Method (DataEventArgs)

MsrBase.PreFireEvent Method (DataEventArgs) |
 | See Also

1/18/2008

Called prior to the delivery of a DataEvent event to the application.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overrides Sub PreFireEvent ( _
    posEvent As DataEventArgs _
)
protected override void PreFireEvent (
    DataEventArgs posEvent
)
protected:
virtual void PreFireEvent (
    DataEventArgs^ posEvent
) override
protected void PreFireEvent (
    DataEventArgs posEvent
)
protected override function PreFireEvent (
    posEvent : DataEventArgs
)

Parameters

posEvent

An instance of the DataEventArgs class, posEvent contains the event that was queued to the application.

Remarks

Called prior to the delivery of a DataEvent event to the application. When PreFireEvent is called, the MsrBase class implementation updates the values of the various MSR track data properties by calling the ParseMsrTrackData protected method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
MsrBase.ParseMsrTrackData Method
Msr.DataEvent Event


MsrBase.PreFireEvent Method (DeviceErrorEventArgs)

MsrBase.PreFireEvent Method (DeviceErrorEventArgs) |
 | See Also

1/18/2008

Called prior to the delivery of a DeviceErrorEvent event to the application.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overrides Sub PreFireEvent ( _
    posEvent As DeviceErrorEventArgs _
)
protected override void PreFireEvent (
    DeviceErrorEventArgs posEvent
)
protected:
virtual void PreFireEvent (
    DeviceErrorEventArgs^ posEvent
) override
protected void PreFireEvent (
    DeviceErrorEventArgs posEvent
)
protected override function PreFireEvent (
    posEvent : DeviceErrorEventArgs
)

Parameters

posEvent

An instance of the DeviceErrorEventArgs class, posEvent contains the event that was queued to the application.

Remarks

Called prior to the delivery of a DeviceErrorEvent event to the application. When PreFireEvent is called, the MsrBase class implementation updates the values that will be sent as part of the ErrorEvent, based on the specified ErrorReportingType.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
MsrBase.ParseMsrTrackData Method
Msr.DataEvent Event
Msr.ErrorReportingType Property


MsrBase.RetrieveCardProperty Method

MsrBase.RetrieveCardProperty Method |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Function RetrieveCardProperty ( _
    name As String _
) As String

public override string RetrieveCardProperty (
    string name
)

public:
virtual String^ RetrieveCardProperty (
    String^ name
) override

public String RetrieveCardProperty (
    String name
)

public override function RetrieveCardProperty (
    name : String
) : String

Parameters

name

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.SetMaxTrackEncodingLengths Method

MsrBase.SetMaxTrackEncodingLengths Method |
 | See Also

1/18/2008

Sets the maximum encoding length for the specified Msr data tracks.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Sub SetMaxTrackEncodingLengths ( _
    track1MaxLength As Integer, _
    track2MaxLength As Integer, _
    track3MaxLength As Integer, _
    track4MaxLength As Integer _
)
protected void SetMaxTrackEncodingLengths (
    int track1MaxLength,
    int track2MaxLength,
    int track3MaxLength,
    int track4MaxLength
)
protected:
void SetMaxTrackEncodingLengths (
    int track1MaxLength,
    int track2MaxLength,
    int track3MaxLength,
    int track4MaxLength
)
protected void SetMaxTrackEncodingLengths (
    int track1MaxLength,
    int track2MaxLength,
    int track3MaxLength,
    int track4MaxLength
)
protected function SetMaxTrackEncodingLengths (
    track1MaxLength : int,
    track2MaxLength : int,
    track3MaxLength : int,
    track4MaxLength : int
)

Parameters

track1MaxLength

An integer representing the maximum track length for data track 1.

track2MaxLength

An integer representing the maximum track length for data track 2.

track3MaxLength

An integer representing the maximum track length for data track 3.

track4MaxLength

An integer representing the maximum track length for data track 4.

Remarks

Sets the maximum encoding length for the specified Msr data tracks.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.UnreadableCard Method

MsrBase.UnreadableCard Method |
 | See Also

1/18/2008

Called by the service object when the card data is unreadable.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Sub UnreadableCard ( _
    errorCode As ErrorCode, _
    extendedErrorCode As Integer _
)
protected void UnreadableCard (
    ErrorCode errorCode,
    int extendedErrorCode
)
protected:
void UnreadableCard (
    ErrorCode errorCode,
    int extendedErrorCode
)
protected void UnreadableCard (
    ErrorCode errorCode,
    int extendedErrorCode
)
protected function UnreadableCard (
    errorCode : ErrorCode,
    extendedErrorCode : int
)

Parameters

errorCode

Contains the error code, as defined by the ErrorCode enumeration.

extendedErrorCode

Contains one of the ExtendedError~ constants that describes the type of read error.

Remarks

Called by the service object when the card data is unreadable. The service object passes the appropriate error information in the function parameters. MsrBase class increments the StatisticUnreadableCardCount statistic and queues an ErrorEvent event, informing the application of the error.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
ErrorCode Enumeration
Msr.ErrorEvent Event
Msr.StatisticFailedReadCount Field


MsrBase.WriteTracks Method

MsrBase.WriteTracks Method |
 | See Also

1/18/2008

Initiates the encoding of data to the MSR track(s) selected in the TracksToWrite property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub WriteTracks ( _
    track1Data As Byte(), _
    track2Data As Byte(), _
    track3Data As Byte(), _
    track4Data As Byte(), _
    timeout As Integer _
)
public override void WriteTracks (
    byte[] track1Data,
    byte[] track2Data,
    byte[] track3Data,
    byte[] track4Data,
    int timeout
)
public:
virtual void WriteTracks (
    array<unsigned char>^ track1Data,
    array<unsigned char>^ track2Data,
    array<unsigned char>^ track3Data,
    array<unsigned char>^ track4Data,
    int timeout
) override
public void WriteTracks (
    byte[] track1Data,
    byte[] track2Data,
    byte[] track3Data,
    byte[] track4Data,
    int timeout
)
public override function WriteTracks (
    track1Data : byte[],
    track2Data : byte[],
    track3Data : byte[],
    track4Data : byte[],
    timeout : int
)

Parameters

track1Data

The first data track.

track2Data

The second data track.

track3Data

The third data track.

track4Data

The fourth data track.

timeout

The number of milliseconds before failing the method. If -1, the method waits as long as need before the card is swiped.

Remarks

Initiates the encoding of data to the MSR track(s) selected in the TracksToWrite property.

When called, data is prepared to be written on to the next card that is swiped within the allotted timeout period. If no card is swiped within the timeout period then an Exception is thrown.

Data that is written to the card is read back from the card in the exact same format, the Service must not decode/encode the data in any fashion.

This method is always performed synchronously, so that the write will be attempted to the next card that is swiped.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
TracksToWrite
EncodingMaxLength


MsrBase.WriteTracksImpl Method

MsrBase.WriteTracksImpl Method |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overridable Sub WriteTracksImpl ( _
    track1Data As Byte(), _
    track2Data As Byte(), _
    track3Data As Byte(), _
    track4Data As Byte(), _
    timeout As Integer _
)
protected virtual void WriteTracksImpl (
    byte[] track1Data,
    byte[] track2Data,
    byte[] track3Data,
    byte[] track4Data,
    int timeout
)
protected:
virtual void WriteTracksImpl (
    array<unsigned char>^ track1Data,
    array<unsigned char>^ track2Data,
    array<unsigned char>^ track3Data,
    array<unsigned char>^ track4Data,
    int timeout
)
protected void WriteTracksImpl (
    byte[] track1Data,
    byte[] track2Data,
    byte[] track3Data,
    byte[] track4Data,
    int timeout
)
protected function WriteTracksImpl (
    track1Data : byte[],
    track2Data : byte[],
    track3Data : byte[],
    track4Data : byte[],
    timeout : int
)

Parameters

track1Data
track2Data
track3Data
track4Data
timeout

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase Properties

MsrBase Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
AccountNumber | Overridden. Holds the account number from the most recently swiped card.
AdditionalSecurityInformation | Overridden. Gets additional security/encryption information when a DataEvent is delivered.
AutoDisable | Indicates whether POS for .NET automatically disables the device when data is received. (inherited from MsrBasic )
CapCardAuthentication | Overridden. Gets the type, if any, of card authentication data that is supported by the device.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from MsrBasic )
CapDataEncryption | Overridden. Gets a bitwise indication of the encryption algorithms supported by the device and is selectable via the DataEncryptionAlgorithm property.
CapDeviceAuthentication | Overridden. Gets the level of device authentication supported by the service.
CapIso | Overridden. Indicates that the MSR supports ISO cards.
CapJisOne | Overridden. Indicates that the MSR device supports JIS Type-I cards.
CapJisTwo | Overridden. Indicates that the MSR device supports JIS Type-II cards.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from MsrBasic )
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from MsrBasic )
CapTrackDataMasking | Overridden. Gets a Boolean value that indicates whether the service supports track data masking.
CapTransmitSentinels | Overridden. Indicates that the MSR device can transmit start and end sentinels.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from MsrBasic )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from MsrBasic )
CapWritableTracks | Overridden. Indicates whether the MSR device can write track data and, if so, which tracks are supported.
CardAuthenticationData | Overridden. Gets the card authentication information when a DataEvent is delivered.
CardAuthenticationDataLength | Overridden. Gets the length of the raw CardAuthenticationData before it is encrypted.
CardPropertyList | Overridden. Gets a comma separated list of the names of the properties parsed from the most recently swiped card.
CardType | Overridden. Gets the card type identifier for the most recently swiped card.
CardTypeList | Overridden. Gets a comma separated list of string names of card types supported by the service.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from MsrBasic )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
DataCount | Holds the number of data events currently queued by the service object. (inherited from MsrBasic )
DataEncryptionAlgorithm | Overridden. Gets and sets the encryption algorithm that will be used to encrypt the track data.
DataEventEnabled | When set to true by the application, POS for .NET delivers the next event in the event queue. (inherited from MsrBasic )
DecodeData | Overridden. If false, the Track1Data, Track2Data, Track3Data, and Track4Data properties contain the original encoded bit sequence, known as “raw format.”
DeviceAuthenticated | Overridden. Gets a Boolean value that indicates whether the device supports authentication.
DeviceAuthenticationProtocol | Overridden. Gets the device authentication protocol supported by the device.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from MsrBasic )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from MsrBasic )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from MsrBasic )
EncodingMaxLength | Overridden. Holds the maximum length of data that can be written by the MSR to the track or tracks defined by the TracksToWrite property.
ErrorReportingType | Overridden. Holds the type of error reporting the application wants to receive. Possible values are defined by the MsrErrorReporting enumeration.
ExpirationDate | Overridden. Holds the expiration date from the most recently swiped card, as four ASCII decimal characters in the form YYMM.
FirstName | Overridden. Holds the first name from the most recently swiped card.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from MsrBasic )
MiddleInitial | Overridden. Holds the middle initial from the most recently swiped card.
ParseDecodeData | Overridden. If true, the decoded data contained within the Track1Data and Track2Data properties is further separated into fields for access via various other properties.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from MsrBasic )
PowerState | Gets the current power condition. (inherited from MsrBasic )
ServiceCode | Overridden. Holds the service code from the most recently swiped card.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from MsrBasic )
ServiceObjectVersion | Gets the Service Object version number. (inherited from MsrBasic )
State | Gets the current state of the device. (inherited from MsrBasic )
Suffix | Overridden. Holds the suffix from the most recently swiped card.
Surname | Overridden. Holds the surname from the most recently swiped card.
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )
Title | Overridden. Holds the title from the most recently swiped card.
Track1Data | Overridden. Holds either the Track 1 data from the most recently swiped card or an empty array.
Track1DiscretionaryData | Overridden. Holds the Track 1 discretionary data from the most recently swiped card.
Track1EncryptedData | Overridden. Gets the length of the raw Track1Data before it is encrypted.
Track1EncryptedDataLength | Overridden. Gets the encrypted track 1 data obtained from the most recently swiped card.
Track2Data | Overridden. Holds either the Track 2 data from the most recently swiped card or an empty array.
Track2DiscretionaryData | Overridden. The Track 2 discretionary data from the most recently swiped card.
Track2EncryptedData | Overridden. Holds the length of the raw Track2Data before it is encrypted.
Track2EncryptedDataLength | Overridden. Gets the encrypted track 2 data obtained from the most recently swiped card.
Track3Data | Overridden. Holds either the Track 3 data from the most recently swiped card or an empty array.
Track3EncryptedData | Overridden. Gets the length of the raw Track3Data before it is encrypted.
Track3EncryptedDataLength | Overridden. Gets the encrypted track 3 data obtained from the most recently swiped card.
Track4Data | Overridden. Holds the Track 4 data (JIS-II) from the most recently swiped card.
Track4EncryptedData | Overridden. Gets the encrypted track 4 data obtained from the most recently swiped card.
Track4EncryptedDataLength | Overridden. Gets the length of the raw Track4Data before it is encrypted.
TracksToRead | Overridden. Indicates the track data that the application wishes to place into the Track1Data, Track2Data, Track3Data and Track4Data properties following a card swipe.
TracksToWrite | Overridden. Specifies which MSR tracks will be written when the WriteTracks method is called and an MSR card swiped.
TransmitSentinels | Overridden. Indicates that the Track1Data, Track2Data, Track3Data, and Track4Data properties contain start sentinel and end sentinel values.
WriteCardType | Overridden. Holds the card type to be used the next time the WriteTracks method is called.

Protected Properties

Name | Description
CommonProperties | (inherited from MsrBasic )
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
ErrorCount | (inherited from MsrBasic )
ExternallyClaimed | (inherited from MsrBasic )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Indicates whether the Msr is an exclusive-use device. (inherited from Msr )
Properties | Contains getters and setters for common and Msr specific properties.

See Also

Reference

MsrBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.AccountNumber Property

MsrBase.AccountNumber Property |
 | See Also

1/18/2008

Holds the account number from the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property AccountNumber As String
public override string AccountNumber { get; }
public:
virtual property String^ AccountNumber {
    String^ get () override;
}
/** @property */
public String get_AccountNumber ()

public override function get AccountNumber () : String

Remarks

The MsrBase class verifies that the MSR device has been opened, then retrieves the value of MsrFieldData.AccountNumber. If the field is null, AccountNumber property returns blank.

AccountNumber is initialized to blank by the MsrFieldData class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.AccountNumber Property


MsrBase.AdditionalSecurityInformation Property

MsrBase.AdditionalSecurityInformation Property |
 | See Also

1/18/2008

Gets additional security/encryption information when a DataEvent is delivered.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property AdditionalSecurityInformation As Byte()
public override byte[] AdditionalSecurityInformation { get; }
public:
virtual property array<unsigned char>^ AdditionalSecurityInformation {
    array<unsigned char>^ get () override;
}
/** @property */
public byte[] get_AdditionalSecurityInformation ()

public override function get AdditionalSecurityInformation () : byte[]

Remarks

The information content and internal format of this property will vary among encryption algorithms. For example, if the encryption algorithm is DUKPT, then this property will contain the “DUKPT sequence number”. If the selected encryption algorithm does not require this property, its value will be set to empty.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.CapCardAuthentication Property

MsrBase.CapCardAuthentication Property |
 | See Also

1/18/2008

Gets the type, if any, of card authentication data that is supported by the device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapCardAuthentication As String
public override string CapCardAuthentication { get; }
public:
virtual property String^ CapCardAuthentication {
    String^ get () override;
}
/** @property */
public String get_CapCardAuthentication ()

public override function get CapCardAuthentication () : String

Remarks

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.CapDataEncryption Property

MsrBase.CapDataEncryption Property |
 | See Also

1/18/2008

Gets a bitwise indication of the encryption algorithms supported by the device and is selectable via the DataEncryptionAlgorithm property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapDataEncryption As EncryptionAlgorithm
public override EncryptionAlgorithm CapDataEncryption { get; }
public:
virtual property EncryptionAlgorithm CapDataEncryption {
    EncryptionAlgorithm get () override;
}
/** @property */
public EncryptionAlgorithm get_CapDataEncryption ()

public override function get CapDataEncryption () : EncryptionAlgorithm

Remarks

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.CapDeviceAuthentication Property

MsrBase.CapDeviceAuthentication Property |
 | See Also

1/18/2008

Gets the level of device authentication supported by the service.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapDeviceAuthentication As DeviceAuthenticationLevel
public override DeviceAuthenticationLevel CapDeviceAuthentication { get; }
public:
virtual property DeviceAuthenticationLevel CapDeviceAuthentication {
    DeviceAuthenticationLevel get () override;
}
/** @property */
public DeviceAuthenticationLevel get_CapDeviceAuthentication ()

public override function get CapDeviceAuthentication () : DeviceAuthenticationLevel

Remarks

If device authentication is supported the service must keep the value of DeviceAuthenticated current when the device is enabled. The service should also queue a StatusUpdateEvent with status value set to StatusDeviceAuthenticated or StatusDeviceDeauthenticated when the authentication status changes.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.CapIso Property

MsrBase.CapIso Property |
 | See Also

1/18/2008

Indicates that the MSR supports ISO cards.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapIso As Boolean
public override bool CapIso { get; }
public:
virtual property bool CapIso {
    bool get () override;
}
/** @property */
public boolean get_CapIso ()

public override function get CapIso () : boolean

Remarks

The MsrBase class verifies that the MSR device has been opened, then retrieves the value of MsrProperties.CapIso. Because the CapJisOne property is a superset of CapIso, if either MsrProperties.CapIso or MsrProperties.CapJisOne is true, the CapIso property returns true.

CapIso is initialized to false by the MsrProperties class. The service object should update CapIso to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.CapIso Property
Msr.CapJisOne Property


MsrBase.CapJisOne Property

MsrBase.CapJisOne Property |
 | See Also

1/18/2008

Indicates that the MSR device supports JIS Type-I cards.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapJisOne As Boolean
public override bool CapJisOne { get; }
public:
virtual property bool CapJisOne {
    bool get () override;
}
/** @property */
public boolean get_CapJisOne ()

public override function get CapJisOne () : boolean

Remarks

The MsrBase class verifies that the MSR device has been opened, then retrieves the value of MsrProperties.CapJisOne.

CapJisOne is initialized to false by the MsrBase class. The service object should update CapJisOne to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.CapJisOne Property


MsrBase.CapJisTwo Property

MsrBase.CapJisTwo Property |
 | See Also

1/18/2008

Indicates that the MSR device supports JIS Type-II cards.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapJisTwo As Boolean
public override bool CapJisTwo { get; }
public:
virtual property bool CapJisTwo {
    bool get () override;
}
/** @property */
public boolean get_CapJisTwo ()

public override function get CapJisTwo () : boolean

Remarks

The MsrBase class verifies that the MSR device has been opened, then retrieves the value of MsrProperties.CapJisTwo.

CapJisTwo is initialized to false by the MsrBase class. The service object should update CapJisTwo to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.CapJisTwo Property


MsrBase.CapTrackDataMasking Property

MsrBase.CapTrackDataMasking Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the service supports track data masking.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapTrackDataMasking As Boolean
public override bool CapTrackDataMasking { get; }
public:
virtual property bool CapTrackDataMasking {
    bool get () override;
}
/** @property */
public boolean get_CapTrackDataMasking ()

public override function get CapTrackDataMasking () : boolean

Remarks

The Boolean value of true indicates that the service supports track data masking. CapTrackDataMasking can be true only if the device supports data encryption.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.CapTransmitSentinels Property

MsrBase.CapTransmitSentinels Property |
 | See Also

1/18/2008

Indicates that the MSR device can transmit start and end sentinels.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapTransmitSentinels As Boolean
public override bool CapTransmitSentinels { get; }
public:
virtual property bool CapTransmitSentinels {
    bool get () override;
}
/** @property */
public boolean get_CapTransmitSentinels ()

public override function get CapTransmitSentinels () : boolean

Remarks

The MsrBase class verifies that the MSR device has been opened, then retrieves the value of MsrProperties.CapTransmitSentinels.

CapTransmitSentinels is initialized to false by the MsrBase class. The service object should update CapTransmitSentinels to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.CapTransmitSentinels Property


MsrBase.CapWritableTracks Property

MsrBase.CapWritableTracks Property |
 | See Also

1/18/2008

Indicates whether the MSR device can write track data and, if so, which tracks are supported.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapWritableTracks As MsrTracks
public override MsrTracks CapWritableTracks { get; }
public:
virtual property MsrTracks CapWritableTracks {
    MsrTracks get () override;
}
/** @property */
public MsrTracks get_CapWritableTracks ()

public override function get CapWritableTracks () : MsrTracks

Remarks

This capability indicates if the MSR device supports the writing of track data - and which tracks are supported - or if this functionality is not supported.

For example, if set to Tracks123 then the MSR device supports writing to tracks 1, 2, and 3; if set to None, then writing to MSR tracks is not supported. Possible values are listed below:

Value | Meaning
None | The MSR does not support writing track data.
Tracks1 | Track 1 is writable.
Tracks2 | Track 2 is writable.
Tracks3 | Track 3 is writable.
Tracks12 | Tracks 1 and 2 are writable.
Tracks13 | Tracks 1 and 3 are writable.
Tracks23 | Tracks 2 and 3 are writable.
Tracks123 | Tracks 1, 2, and 3 are writable.
Tracks4 | Track 4 is writable.
Tracks14 | Tracks 1 and 4 are writable.
Tracks24 | Tracks 2 and 4 are writable.
Tracks34 | Tracks 3 and 4 are writable.
Tracks124 | Tracks 1, 2, and 4 are writable.
Tracks134 | Tracks 1, 3, and 4 are writable.
Tracks234 | Tracks 2, 3, and 4 are writable.
Tracks1234 | All four tracks are writable.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.CardAuthenticationData Property

MsrBase.CardAuthenticationData Property |
 | See Also

1/18/2008

Gets the card authentication information when a DataEvent is delivered.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CardAuthenticationData As Byte()
public override byte[] CardAuthenticationData { get; }
public:
virtual property array<unsigned char>^ CardAuthenticationData {
    array<unsigned char>^ get () override;
}
/** @property */
public byte[] get_CardAuthenticationData ()

public override function get CardAuthenticationData () : byte[]

Remarks

The information content and internal format of this property will vary among services and depends on the value of the CapCardAuthentication property. This property will be empty if CapCardAuthentication is None. The value of this property will be encrypted via the encryption algorithm contained in the DataEncryptionAlgorithm property. The length of the raw (unencrypted) value of this property is contained in the CardAuthenticationDataLength property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.CardAuthenticationDataLength Property

MsrBase.CardAuthenticationDataLength Property |
 | See Also

1/18/2008

Gets the length of the raw CardAuthenticationData before it is encrypted.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CardAuthenticationDataLength As Integer
public override int CardAuthenticationDataLength { get; }
public:
virtual property int CardAuthenticationDataLength {
    int get () override;
}
/** @property */
public int get_CardAuthenticationDataLength ()

public override function get CardAuthenticationDataLength () : int

Remarks

Many encryption algorithms require padding of the input data before it can be encrypted. This property contains the length of the original unpadded data before it is encrypted. It may be needed to restore the original data after decryption.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.CardPropertyList Property

MsrBase.CardPropertyList Property |
 | See Also

1/18/2008

Gets a comma separated list of the names of the properties parsed from the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overridable ReadOnly Property CardPropertyList As ReadOnlyCollection(Of String)
public virtual ReadOnlyCollection<string> CardPropertyList { get; }
public:
virtual property ReadOnlyCollection<String^>^ CardPropertyList {
    ReadOnlyCollection<String^>^ get ();
}
/** @property */
public ReadOnlyCollection<String> get_CardPropertyList ()

public function get CardPropertyList () : ReadOnlyCollection<String>

Remarks

This property is initialized to an empty string if the type of card swiped was not recognized or ParseDecodeData is false.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.CardType Property

MsrBase.CardType Property |
 | See Also

1/18/2008

Gets the card type identifier for the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CardType As String
public override string CardType { get; }
public:
virtual property String^ CardType {
    String^ get () override;
}
/** @property */
public String get_CardType ()

public override function get CardType () : String

Remarks

If the card's format is not recognized, this property will be empty. If this property's value begins with an underscore ('_'), the card type is vendor specific. If this property does not begin with an underscore, the card type is one of the standard card types.

The two currently defined standard card types are "BANK" and "AAMVA."

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.CardTypeList Property

MsrBase.CardTypeList Property |
 | See Also

1/18/2008

Gets a comma separated list of string names of card types supported by the service.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overridable ReadOnly Property CardTypeList As ReadOnlyCollection(Of String)
public virtual ReadOnlyCollection<string> CardTypeList { get; }
public:
virtual property ReadOnlyCollection<String^>^ CardTypeList {
    ReadOnlyCollection<String^>^ get ();
}
/** @property */
public ReadOnlyCollection<String> get_CardTypeList ()

public function get CardTypeList () : ReadOnlyCollection<String>

Remarks

The vendor is allowed to support non-standard card type by specifying names beginning with an underscore ('_'). All names not beginning with an underscore are considered to be standard card types.

The two currently defined standard card types are "BANK" and "AAMVA."

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.DataEncryptionAlgorithm Property

MsrBase.DataEncryptionAlgorithm Property |
 | See Also

1/18/2008

Gets and sets the encryption algorithm that will be used to encrypt the track data.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property DataEncryptionAlgorithm As EncryptionAlgorithm
public override EncryptionAlgorithm DataEncryptionAlgorithm { get; set; }
public:
virtual property EncryptionAlgorithm DataEncryptionAlgorithm {
    EncryptionAlgorithm get () override;
    void set (EncryptionAlgorithm value) override;
}
/** @property */
public EncryptionAlgorithm get_DataEncryptionAlgorithm ()

/** @property */
public void set_DataEncryptionAlgorithm (EncryptionAlgorithm value)

public override function get DataEncryptionAlgorithm () : EncryptionAlgorithm

public override function set DataEncryptionAlgorithm (value : EncryptionAlgorithm)

Remarks

This property may be set to any of the supported encryption algorithms as defined in the CapDataEncryption property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.DecodeData Property

MsrBase.DecodeData Property |
 | See Also

1/18/2008

If false, the Track1Data, Track2Data, Track3Data, and Track4Data properties contain the original encoded bit sequence, known as “raw format.”

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property DecodeData As Boolean
public override bool DecodeData { get; set; }
public:
virtual property bool DecodeData {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_DecodeData ()

/** @property */
public void set_DecodeData (boolean value)

public override function get DecodeData () : boolean

public override function set DecodeData (value : boolean)

Remarks

The MsrBase class verifies that the MSR device has been opened, then retrieves the value of MsrBase.DecodeData.

DecodeData is initialized to true by MsrBase class. The application sets DecodeData based on whether it wishes to receive raw data or parsed data. If the application sets DecodeData to false, MsrBase class sets the ParseDecodeData property to false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.DecodeData Property
Msr.ParseDecodeData Property


MsrBase.DeviceAuthenticated Property

MsrBase.DeviceAuthenticated Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device supports authentication.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property DeviceAuthenticated As Boolean
public override bool DeviceAuthenticated { get; }
public:
virtual property bool DeviceAuthenticated {
    bool get () override;
}
/** @property */
public boolean get_DeviceAuthenticated ()

public override function get DeviceAuthenticated () : boolean

Remarks

The Boolean value of true indicates that the device supports authentication.

If the device supports authentication, the service must keep the value of this property up to date when the device is enabled.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.DeviceAuthenticationProtocol Property

MsrBase.DeviceAuthenticationProtocol Property |
 | See Also

1/18/2008

Gets the device authentication protocol supported by the device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property DeviceAuthenticationProtocol As DeviceAuthenticationProtocol
public override DeviceAuthenticationProtocol DeviceAuthenticationProtocol { get; }
public:
virtual property DeviceAuthenticationProtocol DeviceAuthenticationProtocol {
    DeviceAuthenticationProtocol get () override;
}
/** @property */
public DeviceAuthenticationProtocol get_DeviceAuthenticationProtocol ()

public override function get DeviceAuthenticationProtocol () : DeviceAuthenticationProtocol

Remarks

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.EncodingMaxLength Property

MsrBase.EncodingMaxLength Property |
 | See Also

1/18/2008

Holds the maximum length of data that can be written by the MSR to the track or tracks defined by the TracksToWrite property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property EncodingMaxLength As Integer
public override int EncodingMaxLength { get; }
public:
virtual property int EncodingMaxLength {
    int get () override;
}
/** @property */
public int get_EncodingMaxLength ()

public override function get EncodingMaxLength () : int

Remarks

The maximum length of data that can be written by the MSR to the track or tracks defined by the TracksToWrite property. If multiple tracks are selected in the TracksToWrite property, the length of the shortest track should be reflected by this property.

This property is initialized to zero by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.ErrorReportingType Property

MsrBase.ErrorReportingType Property |
 | See Also

1/18/2008

Holds the type of error reporting the application wants to receive. Possible values are defined by the MsrErrorReporting enumeration.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property ErrorReportingType As MsrErrorReporting
public override MsrErrorReporting ErrorReportingType { get; set; }
public:
virtual property MsrErrorReporting ErrorReportingType {
    MsrErrorReporting get () override;
    void set (MsrErrorReporting value) override;
}
/** @property */
public MsrErrorReporting get_ErrorReportingType ()

/** @property */
public void set_ErrorReportingType (MsrErrorReporting value)

public override function get ErrorReportingType () : MsrErrorReporting

public override function set ErrorReportingType (value : MsrErrorReporting)

Remarks

The MsrBase class verifies that the MSR device has been opened, then retrieves the value of MsrBase.ErrorReportingType.

MsrErrorReportingType is initialized to MsrErrorReporting.Card by the MsrBase class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.ErrorReportingType Property
MsrErrorReporting Enumeration


MsrBase.ExpirationDate Property

MsrBase.ExpirationDate Property |
 | See Also

1/18/2008

Holds the expiration date from the most recently swiped card, as four ASCII decimal characters in the form YYMM.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property ExpirationDate As String
public override string ExpirationDate { get; }
public:
virtual property String^ ExpirationDate {
    String^ get () override;
}
/** @property */
public String get_ExpirationDate ()

public override function get ExpirationDate () : String

Remarks

Holds the expiration date from the most recently swiped card, as four ASCII decimal characters in the form YYMM.

The MsrBase class verifies that the MSR device has been opened, then retrieves the value of MsrFieldData.ExpirationDate. If the field is null, the ExpirationDate property returns blank.

ExpirationDate is initialized to blank by the MsrFieldData class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.ExpirationDate Property


MsrBase.FirstName Property

MsrBase.FirstName Property |
 | See Also

1/18/2008

Holds the first name from the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property FirstName As String
public override string FirstName { get; }
public:
virtual property String^ FirstName {
    String^ get () override;
}
/** @property */
public String get_FirstName ()

public override function get FirstName () : String

Remarks

Holds the first name from the most recently swiped card.

The MsrBase class verifies that the MSR device has been opened, then retrieves the value of MsrFieldData.FirstName. If the field is null, the FirstName property returns blank.

FirstName is initialized to blank by the MsrFieldData class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.FirstName Property


MsrBase.MiddleInitial Property

MsrBase.MiddleInitial Property |
 | See Also

1/18/2008

Holds the middle initial from the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property MiddleInitial As String
public override string MiddleInitial { get; }
public:
virtual property String^ MiddleInitial {
    String^ get () override;
}
/** @property */
public String get_MiddleInitial ()

public override function get MiddleInitial () : String

Remarks

Holds the middle initial from the most recently swiped card.

The MsrBase class verifies that the MSR device has been opened, then retrieves the value of MsrFieldData.MiddleInitial. If the field is null, the MiddleInitial property returns blank.

MiddleInitial is initialized to blank by the MsrFieldData class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.MiddleInitial Property


MsrBase.ParseDecodeData Property

MsrBase.ParseDecodeData Property |
 | See Also

1/18/2008

If true, the decoded data contained within the Track1Data and Track2Data properties is further separated into fields for access via various other properties.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property ParseDecodeData As Boolean
public override bool ParseDecodeData { get; set; }
public:
virtual property bool ParseDecodeData {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_ParseDecodeData ()

/** @property */
public void set_ParseDecodeData (boolean value)

public override function get ParseDecodeData () : boolean

public override function set ParseDecodeData (value : boolean)

Remarks

The MsrBase class verifies that the MSR device has been opened, then retrieves the value of MsrBase.ParseDecodeData.

ParseDecodeData is initialized to true by the MsrBase class. The application sets ParseDecodeData based on whether it wishes Track1Data and Track2Data to be further separated into additional properties. If the application sets ParseDecodeData to true, MsrBase class sets DecodeData to true.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.ParseDecodeData Property
Msr.DecodeData Property


MsrBase.Properties Property

MsrBase.Properties Property |
 | See Also

1/18/2008

Contains getters and setters for common and Msr specific properties.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected ReadOnly Property Properties As MsrProperties
protected MsrProperties Properties { get; }
protected:
property MsrProperties^ Properties {
    MsrProperties^ get ();
}
/** @property */
protected MsrProperties get_Properties ()

protected function get Properties () : MsrProperties

Remarks

Returns an instance of the MsrProperties helper class, containing getters and setters for Msr and common properties. Service objects should use MsrProperties class to set properties that are typically designated read-only for applications. The device doesn't have to be opened, claimed, or enabled to set MsrProperties class properties.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.ServiceCode Property

MsrBase.ServiceCode Property |
 | See Also

1/18/2008

Holds the service code from the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property ServiceCode As String
public override string ServiceCode { get; }
public:
virtual property String^ ServiceCode {
    String^ get () override;
}
/** @property */
public String get_ServiceCode ()

public override function get ServiceCode () : String

Remarks

Holds the service code from the most recently swiped card.

The MsrBase class verifies that the MSR device has been opened, then retrieves the value of MsrFieldData.ServiceCode. If the field is null, the ServiceCode property returns blank.

ServiceCode is initialized to blank by the MsrFieldData class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.ServiceCode Property


MsrBase.Suffix Property

MsrBase.Suffix Property |
 | See Also

1/18/2008

Holds the suffix from the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property Suffix As String
public override string Suffix { get; }
public:
virtual property String^ Suffix {
    String^ get () override;
}
/** @property */
public String get_Suffix ()

public override function get Suffix () : String

Remarks

Holds the suffix from the most recently swiped card.

The MsrBase class verifies that the MSR device has been opened, then retrieves the value of MsrFieldData.Suffix. If the field is null, the Suffix property returns blank.

Suffix is initialized to blank by the MsrFieldData class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.Suffix Property


MsrBase.Surname Property

MsrBase.Surname Property |
 | See Also

1/18/2008

Holds the surname from the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property Surname As String
public override string Surname { get; }
public:
virtual property String^ Surname {
    String^ get () override;
}
/** @property */
public String get_Surname ()

public override function get Surname () : String

Remarks

Holds the surname from the most recently swiped card.

The MsrBase class verifies that the MSR device has been opened, then retrieves the value of MsrFieldData.Surname. If the field is null, the Surname property returns blank.

Surname is initialized to blank by the MsrFieldData class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.Surname Property


MsrBase.Title Property

MsrBase.Title Property |
 | See Also

1/18/2008

Holds the title from the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property Title As String
public override string Title { get; }
public:
virtual property String^ Title {
    String^ get () override;
}
/** @property */
public String get_Title ()

public override function get Title () : String

Remarks

Holds the title from the most recently swiped card.

The MsrBase class verifies that the MSR device has been opened, then retrieves the value of MsrFieldData.Title. If the field is null, the Title property returns blank.

Title is initialized to blank by the MsrFieldData class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.Title Property


MsrBase.Track1Data Property

MsrBase.Track1Data Property |
 | See Also

1/18/2008

Holds either the Track 1 data from the most recently swiped card or an empty array.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property Track1Data As Byte()
public override byte[] Track1Data { get; }
public:
virtual property array<unsigned char>^ Track1Data {
    array<unsigned char>^ get () override;
}
/** @property */
public byte[] get_Track1Data ()

public override function get Track1Data () : byte[]

Remarks

Holds either the Track 1 data from the most recently swiped card or an empty array.

The MsrBase class verifies that the MSR device has been opened, then retrieves the value of MsrTrackData.Track1Data. If the field is null, the Track1Data property returns an empty byte array.

Track1Data is initialized to an empty byte array by the MsrTrackData class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.Track1Data Property


MsrBase.Track1DiscretionaryData Property

MsrBase.Track1DiscretionaryData Property |
 | See Also

1/18/2008

Holds the Track 1 discretionary data from the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property Track1DiscretionaryData As Byte()
public override byte[] Track1DiscretionaryData { get; }
public:
virtual property array<unsigned char>^ Track1DiscretionaryData {
    array<unsigned char>^ get () override;
}
/** @property */
public byte[] get_Track1DiscretionaryData ()

public override function get Track1DiscretionaryData () : byte[]

Remarks

Holds the Track 1 discretionary data from the most recently swiped card.

The MsrBase class verifies that the MSR device has been opened, then retrieves the value of MsrFieldData.Track1DiscretionaryData. If the field is null, the Track2Data property returns blank.

Track1DiscretionaryData is initialized to an empty byte array by the MsrFieldData class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.Track1DiscretionaryData Property


MsrBase.Track1EncryptedData Property

MsrBase.Track1EncryptedData Property |
 | See Also

1/18/2008

Gets the length of the raw Track1Data before it is encrypted.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property Track1EncryptedData As Byte()
public override byte[] Track1EncryptedData { get; }
public:
virtual property array<unsigned char>^ Track1EncryptedData {
    array<unsigned char>^ get () override;
}
/** @property */
public byte[] get_Track1EncryptedData ()

public override function get Track1EncryptedData () : byte[]

Remarks

Many encryption algorithms require padding of the input data before it can be encrypted. This property contains the length of the original unpadded track data before it is encrypted. It may be needed to restore the original track data after decryption.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.Track1EncryptedDataLength Property

MsrBase.Track1EncryptedDataLength Property |
 | See Also

1/18/2008

Gets the encrypted track 1 data obtained from the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property Track1EncryptedDataLength As Integer
public override int Track1EncryptedDataLength { get; }
public:
virtual property int Track1EncryptedDataLength {
    int get () override;
}
/** @property */
public int get_Track1EncryptedDataLength ()

public override function get Track1EncryptedDataLength () : int

Remarks

The length of this property after it is decrypted is contained in the Track1EncryptedDataLength property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.Track2Data Property

MsrBase.Track2Data Property |
 | See Also

1/18/2008

Holds either the Track 2 data from the most recently swiped card or an empty array.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property Track2Data As Byte()
public override byte[] Track2Data { get; }
public:
virtual property array<unsigned char>^ Track2Data {
    array<unsigned char>^ get () override;
}
/** @property */
public byte[] get_Track2Data ()

public override function get Track2Data () : byte[]

Remarks

Holds either the Track 2 data from the most recently swiped card or an empty array.

The MsrBase class verifies that the MSR device has been opened, then retrieves the value of MsrTrackData.Track2Data. If the field is null, the Track2Data property returns an empty byte array.

Track2Data is initialized to an empty byte array by the MsrTrackData class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.Track2Data Property


MsrBase.Track2DiscretionaryData Property

MsrBase.Track2DiscretionaryData Property |
 | See Also

1/18/2008

The Track 2 discretionary data from the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property Track2DiscretionaryData As Byte()
public override byte[] Track2DiscretionaryData { get; }
public:
virtual property array<unsigned char>^ Track2DiscretionaryData {
    array<unsigned char>^ get () override;
}
/** @property */
public byte[] get_Track2DiscretionaryData ()

public override function get Track2DiscretionaryData () : byte[]

Remarks

The Track 2 discretionary data from the most recently swiped card.

The MsrBase class verifies that the MSR device has been opened, then retrieves the value of MsrFieldData.Track2DiscretionaryData. If the field is null, the Track2DiscretionaryData property returns blank.

Track1DiscretionaryData is initialized to an empty byte array by the MsrFieldData class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.Track2DiscretionaryData Property


MsrBase.Track2EncryptedData Property

MsrBase.Track2EncryptedData Property |
 | See Also

1/18/2008

Holds the length of the raw Track2Data before it is encrypted.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property Track2EncryptedData As Byte()
public override byte[] Track2EncryptedData { get; }
public:
virtual property array<unsigned char>^ Track2EncryptedData {
    array<unsigned char>^ get () override;
}
/** @property */
public byte[] get_Track2EncryptedData ()

public override function get Track2EncryptedData () : byte[]

Remarks

Many encryption algorithms require padding of the input data before it can be encrypted. This property contains the length of the original unpadded track data before it is encrypted. It may be needed to restore the original track data after decryption.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.Track2EncryptedDataLength Property

MsrBase.Track2EncryptedDataLength Property |
 | See Also

1/18/2008

Gets the encrypted track 2 data obtained from the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property Track2EncryptedDataLength As Integer
public override int Track2EncryptedDataLength { get; }
public:
virtual property int Track2EncryptedDataLength {
    int get () override;
}
/** @property */
public int get_Track2EncryptedDataLength ()

public override function get Track2EncryptedDataLength () : int

Remarks

The length of this property after it is decrypted is contained in the Track2EncryptedDataLength property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.Track3Data Property

MsrBase.Track3Data Property |
 | See Also

1/18/2008

Holds either the Track 3 data from the most recently swiped card or an empty array.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property Track3Data As Byte()
public override byte[] Track3Data { get; }
public:
virtual property array<unsigned char>^ Track3Data {
    array<unsigned char>^ get () override;
}
/** @property */
public byte[] get_Track3Data ()

public override function get Track3Data () : byte[]

Remarks

The MsrBase class verifies that the MSR device has been opened, then retrieves the value of MsrTrackData.Track3Data. If the field is null, the Track3Data property returns an empty byte array.

Track3Data is initialized to an empty byte array by the MsrTrackData class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.Track3Data Property


MsrBase.Track3EncryptedData Property

MsrBase.Track3EncryptedData Property |
 | See Also

1/18/2008

Gets the length of the raw Track3Data before it is encrypted.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property Track3EncryptedData As Byte()
public override byte[] Track3EncryptedData { get; }
public:
virtual property array<unsigned char>^ Track3EncryptedData {
    array<unsigned char>^ get () override;
}
/** @property */
public byte[] get_Track3EncryptedData ()

public override function get Track3EncryptedData () : byte[]

Remarks

Many encryption algorithms require padding of the input data before it can be encrypted. This property contains the length of the original unpadded track data before it is encrypted. It may be needed to restore the original track data after decryption.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.Track3EncryptedDataLength Property

MsrBase.Track3EncryptedDataLength Property |
 | See Also

1/18/2008

Gets the encrypted track 3 data obtained from the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property Track3EncryptedDataLength As Integer
public override int Track3EncryptedDataLength { get; }
public:
virtual property int Track3EncryptedDataLength {
    int get () override;
}
/** @property */
public int get_Track3EncryptedDataLength ()

public override function get Track3EncryptedDataLength () : int

Remarks

The length of this property after it is decrypted is contained in the Track3EncryptedDataLength property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.Track4Data Property

MsrBase.Track4Data Property |
 | See Also

1/18/2008

Holds the Track 4 data (JIS-II) from the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property Track4Data As Byte()
public override byte[] Track4Data { get; }
public:
virtual property array<unsigned char>^ Track4Data {
    array<unsigned char>^ get () override;
}
/** @property */
public byte[] get_Track4Data ()

public override function get Track4Data () : byte[]

Remarks

The MsrBase class verifies that the MSR device has been opened, then retrieves the value of MsrTrackData.Track4Data. If the field is null, the Track4Data property returns an empty byte array.

Track4Data is initialized to an empty byte array by the MsrTrackData class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.Track4Data Property


MsrBase.Track4EncryptedData Property

MsrBase.Track4EncryptedData Property |
 | See Also

1/18/2008

Gets the encrypted track 4 data obtained from the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property Track4EncryptedData As Byte()
public override byte[] Track4EncryptedData { get; }
public:
virtual property array<unsigned char>^ Track4EncryptedData {
    array<unsigned char>^ get () override;
}
/** @property */
public byte[] get_Track4EncryptedData ()

public override function get Track4EncryptedData () : byte[]

Remarks

The length of this property after it is decrypted is contained in the Track4EncryptedDataLength property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.Track4EncryptedDataLength Property

MsrBase.Track4EncryptedDataLength Property |
 | See Also

1/18/2008

Gets the length of the raw Track4Data before it is encrypted.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property Track4EncryptedDataLength As Integer
public override int Track4EncryptedDataLength { get; }
public:
virtual property int Track4EncryptedDataLength {
    int get () override;
}
/** @property */
public int get_Track4EncryptedDataLength ()

public override function get Track4EncryptedDataLength () : int

Remarks

Many encryption algorithms require padding of the input data before it can be encrypted. This property contains the length of the original unpadded track data before it is encrypted. It may be needed to restore the original track data after decryption.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.TracksToRead Property

MsrBase.TracksToRead Property |
 | See Also

1/18/2008

Indicates the track data that the application wishes to place into the Track1Data, Track2Data, Track3Data and Track4Data properties following a card swipe.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property TracksToRead As MsrTracks
public override MsrTracks TracksToRead { get; set; }
public:
virtual property MsrTracks TracksToRead {
    MsrTracks get () override;
    void set (MsrTracks value) override;
}
/** @property */
public MsrTracks get_TracksToRead ()

/** @property */
public void set_TracksToRead (MsrTracks value)

public override function get TracksToRead () : MsrTracks

public override function set TracksToRead (value : MsrTracks)

Remarks

The MsrBase class verifies that the MSR device has been opened, then retrieves the value of MsrBase.TracksToRead.

TracksToRead is initialized to MsrTracks.Tracks123 by the MsrBase class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.TracksToRead Property
MsrTracks Enumeration


MsrBase.TracksToWrite Property

MsrBase.TracksToWrite Property |
 | See Also

1/18/2008

Specifies which MSR tracks will be written when the WriteTracks method is called and an MSR card swiped.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property TracksToWrite As MsrTracks
public override MsrTracks TracksToWrite { get; set; }
public:
virtual property MsrTracks TracksToWrite {
    MsrTracks get () override;
    void set (MsrTracks value) override;
}
/** @property */
public MsrTracks get_TracksToWrite ()

/** @property */
public void set_TracksToWrite (MsrTracks value)

public override function get TracksToWrite () : MsrTracks

public override function set TracksToWrite (value : MsrTracks)

Remarks

The contents of the TracksToWrite property can be specified using the MsrTracks enumeration. Only values which are equal to, or a subset of the CapWritableTracks property are valid.

If CapWritableTracks is set to None then writing to this MSR device is not supported and attempting to set this property will throw an exception.

Setting this property may also update the EncodingMaxLength property since each track may have a different encoding limit.

This property is set to None by default during the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase.TransmitSentinels Property

MsrBase.TransmitSentinels Property |
 | See Also

1/18/2008

Indicates that the Track1Data, Track2Data, Track3Data, and Track4Data properties contain start sentinel and end sentinel values.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property TransmitSentinels As Boolean
public override bool TransmitSentinels { get; set; }
public:
virtual property bool TransmitSentinels {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_TransmitSentinels ()

/** @property */
public void set_TransmitSentinels (boolean value)

public override function get TransmitSentinels () : boolean

public override function set TransmitSentinels (value : boolean)

Remarks

The MsrBase class verifies that the MSR device has been opened, then retrieves the value of MsrBase.TransmitSentinels.

TransmitSentinels is initialized to FALSE by the MsrBase class. The application sets TransmitSentinels based on whether it wishes begin and end sentinels to be transmitted with the data. If the application sets TransmitSentinels to TRUE and the CapTransmitSentinels property is set to FALSE, the MsrBase class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.TransmitSentinels Property
Msr.CapTransmitSentinels Property


MsrBase.WriteCardType Property

MsrBase.WriteCardType Property |
 | See Also

1/18/2008

Holds the card type to be used the next time the WriteTracks method is called.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property WriteCardType As String
public override string WriteCardType { get; set; }
public:
virtual property String^ WriteCardType {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_WriteCardType ()

/** @property */
public void set_WriteCardType (String value)

public override function get WriteCardType () : String

public override function set WriteCardType (value : String)

Remarks

If this property's value begins with an underscore ('_') the card type is vendor specific. If this property does not begin with an underscore the card type is one of the standard card types.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrBase Class
MsrBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrBase Events

MsrBase Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DataEvent | Raised by the service object to indicate the delivery of input data from the device to the application. (inherited from MsrBasic )
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from MsrBasic )
ErrorEvent | Raised by the service object when an error is detected while trying to read MSR data. (inherited from MsrBasic )
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from MsrBasic )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
StateChangedEvent | (inherited from MsrBasic )

See Also

Reference

MsrBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrFieldData Class

MsrFieldData Class |
 | See Also Members

1/18/2008

An instance of a MsrFieldData class is returned by the ParseMsrFieldData protected method of the MsrBase class. The string fields and discretionary data are decoded, and then stored in their respective properties.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class MsrFieldData
public class MsrFieldData
public ref class MsrFieldData
public class MsrFieldData
public class MsrFieldData

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BaseServiceObjects.MsrFieldData

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrFieldData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrFieldData Members

MsrFieldData Members |
 | See Also Constructors Methods Properties

1/18/2008

An instance of a MsrFieldData class is returned by the ParseMsrFieldData protected method of the MsrBase class. The string fields and discretionary data are decoded, and then stored in their respective properties.

The following tables list the members exposed by the MsrFieldData type.

Public Constructors

Name | Description
MsrFieldData | Overloaded.
Top

Public Properties

Name | Description
AccountNumber | Gets or sets the account number from the most recently swiped card.
Address | Gets or sets the address in the most recently swiped card.
BirthDate | Gets or sets the date of birth in the most recently swiped card.
City | Gets or sets the name of the city in the most recently swiped card.
Class | Gets or sets the class in the most recently swiped card.
Endorsements | Gets or sets the endorsements in the most recently swiped card.
ExpirationDate | Gets or sets the expiration date from the most recently swiped card, as four ASCII decimal characters in the form YYMM. For example, February 1998 is "9802" and August 2018 is "1808".
EyeColor | Gets or sets the eye color field in the most recently swiped card.
FirstName | Gets or sets the first name from the most recently swiped card.
Gender | Gets or sets the gender field in the most recently swiped card.
HairColor | Gets or sets the hair color field in the most recently swiped card.
Height | Gets or sets the height field in the most recently swiped card.
LicenseNumber | Gets or sets the license number in the most recently swiped card.
MiddleInitial | Gets or sets the middle initial from the most recently swiped card.
PostalCode | Gets or sets the postal code in the most recently swiped card.
Restrictions | Gets or sets the restrictions field in the most recently swiped card.
ServiceCode | Gets or sets the service code from the most recently swiped card.
State | Gets or sets the state field in the most recently swiped card.
Suffix | Gets or sets the suffix from the most recently swiped card.
Surname | Gets or sets the surname from the most recently swiped card.
Title | Gets or sets the title from the most recently swiped card.
Track1DiscretionaryData | Gets or sets the Track 1 discretionary data from the most recently swiped card.
Track2DiscretionaryData | Gets or sets the Track 2 discretionary data from the most recently swiped card.
Weight | Gets or sets the weight field in the most recently swiped card.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

MsrFieldData Class
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrFieldData Constructor

MsrFieldData Constructor |
 | See Also

1/18/2008

Overload List

Name | Description
MsrFieldData () | Creates an instance of the MsrFieldData class.
MsrFieldData (String, String, String, String, String, String, String, String, Byte[], Byte[]) | Creates an instance of the MsrFieldData class with the specified parameters.
MsrFieldData (String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String) | Creates an instance of the MsrFieldData class based on the parameters specified.

See Also

Reference

MsrFieldData Class
MsrFieldData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrFieldData Constructor ()

MsrFieldData Constructor () |
 | See Also

1/18/2008

Creates an instance of the MsrFieldData class.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub New
public MsrFieldData ()
public:
MsrFieldData ()
public MsrFieldData ()
public function MsrFieldData ()

Remarks

All properties are initialized to their default values.

See Also

Reference

MsrFieldData Class
MsrFieldData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrFieldData Constructor (String, String, String, String, String, String, String, String, Byte[], Byte[])

MsrFieldData Constructor (String, String, String, String, String, String, String, String, Byte[], Byte[]) |
 | See Also

1/18/2008

Creates an instance of the MsrFieldData class with the specified parameters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub New ( _
    accountNumber As String, _
    expirationDate As String, _
    firstName As String, _
    middleInitial As String, _
    serviceCode As String, _
    suffix As String, _
    surname As String, _
    title As String, _
    track1DiscretionaryData As Byte(), _
    track2DiscretionaryData As Byte() _
)
public MsrFieldData (
    string accountNumber,
    string expirationDate,
    string firstName,
    string middleInitial,
    string serviceCode,
    string suffix,
    string surname,
    string title,
    byte[] track1DiscretionaryData,
    byte[] track2DiscretionaryData
)
public:
MsrFieldData (
    String^ accountNumber,
    String^ expirationDate,
    String^ firstName,
    String^ middleInitial,
    String^ serviceCode,
    String^ suffix,
    String^ surname,
    String^ title,
    array<unsigned char>^ track1DiscretionaryData,
    array<unsigned char>^ track2DiscretionaryData
)
public MsrFieldData (
    String accountNumber,
    String expirationDate,
    String firstName,
    String middleInitial,
    String serviceCode,
    String suffix,
    String surname,
    String title,
    byte[] track1DiscretionaryData,
    byte[] track2DiscretionaryData
)
public function MsrFieldData (
    accountNumber : String,
    expirationDate : String,
    firstName : String,
    middleInitial : String,
    serviceCode : String,
    suffix : String,
    surname : String,
    title : String,
    track1DiscretionaryData : byte[],
    track2DiscretionaryData : byte[]
)

Parameters

accountNumber

The account number from the most recently swiped card.

expirationDate

The expiration date from the most recently swiped card, as four ASCII decimal characters in the form YYMM.

firstName

The first name from the most recently swiped card.

middleInitial

The middle initial from the most recently swiped card.

serviceCode

The service code from the most recently swiped card.

suffix

The suffix from the most recently swiped card.

surname

The surname from the most recently swiped card.

title

The title from the most recently swiped card.

track1DiscretionaryData

The Track 1 discretionary data from the most recently swiped card.

track2DiscretionaryData

The Track 2 discretionary data from the most recently swiped card.

Remarks

Creates a new instance of the MsrFieldData class with the specified parameters.

See Also

Reference

MsrFieldData Class
MsrFieldData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrFieldData Constructor (String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String)

MsrFieldData Constructor (String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String) |
 | See Also

1/18/2008

Creates an instance of the MsrFieldData class based on the parameters specified.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub New ( _
    address As String, _
    birthDate As String, _
    endorsements As String, _
    expirationDate As String, _
    eyeColor As String, _
    firstName As String, _
    gender As String, _
    hairColor As String, _
    height As String, _
    licenseNumber As String, _
    postalCode As String, _
    restrictions As String, _
    state As String, _
    suffix As String, _
    surname As String, _
    weight As String, _
    _class As String, _
    city As String _
)
public MsrFieldData (
    string address,
    string birthDate,
    string endorsements,
    string expirationDate,
    string eyeColor,
    string firstName,
    string gender,
    string hairColor,
    string height,
    string licenseNumber,
    string postalCode,
    string restrictions,
    string state,
    string suffix,
    string surname,
    string weight,
    string _class,
    string city
)
public:
MsrFieldData (
    String^ address,
    String^ birthDate,
    String^ endorsements,
    String^ expirationDate,
    String^ eyeColor,
    String^ firstName,
    String^ gender,
    String^ hairColor,
    String^ height,
    String^ licenseNumber,
    String^ postalCode,
    String^ restrictions,
    String^ state,
    String^ suffix,
    String^ surname,
    String^ weight,
    String^ _class,
    String^ city
)
public MsrFieldData (
    String address,
    String birthDate,
    String endorsements,
    String expirationDate,
    String eyeColor,
    String firstName,
    String gender,
    String hairColor,
    String height,
    String licenseNumber,
    String postalCode,
    String restrictions,
    String state,
    String suffix,
    String surname,
    String weight,
    String _class,
    String city
)
public function MsrFieldData (
    address : String,
    birthDate : String,
    endorsements : String,
    expirationDate : String,
    eyeColor : String,
    firstName : String,
    gender : String,
    hairColor : String,
    height : String,
    licenseNumber : String,
    postalCode : String,
    restrictions : String,
    state : String,
    suffix : String,
    surname : String,
    weight : String,
    _class : String,
    city : String
)

Parameters

address

The address in the most recently swiped card.

birthDate

The birth date in the most recently swiped card.

endorsements

The endorsements in the most recently swiped card.

expirationDate

The expiration date in the most recently swiped card.

eyeColor

The color of the eye in the most recently swiped card.

firstName

The first name in the most recently swiped card.

gender

The gender in the most recently swiped card.

hairColor

The color of the hair in the most recently swiped card.

height

The height in the most recently swiped card.

licenseNumber

The license number in the most recently swiped card.

postalCode

The postal code in the most recently swiped card.

restrictions

The restrictions in the most recently swiped card.

state

The name of the state in the most recently swiped card.

suffix

The suffix in the most recently swiped card.

surname

The surname in the most recently swiped card.

weight

The weight as stated in the most recently swiped card.

_class

The class in the most recently swiped card.

city

The city in the most recently swiped card.

See Also

Reference

MsrFieldData Class
MsrFieldData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrFieldData Methods

MsrFieldData Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

MsrFieldData Class
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrFieldData Properties

MsrFieldData Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
AccountNumber | Gets or sets the account number from the most recently swiped card.
Address | Gets or sets the address in the most recently swiped card.
BirthDate | Gets or sets the date of birth in the most recently swiped card.
City | Gets or sets the name of the city in the most recently swiped card.
Class | Gets or sets the class in the most recently swiped card.
Endorsements | Gets or sets the endorsements in the most recently swiped card.
ExpirationDate | Gets or sets the expiration date from the most recently swiped card, as four ASCII decimal characters in the form YYMM. For example, February 1998 is "9802" and August 2018 is "1808".
EyeColor | Gets or sets the eye color field in the most recently swiped card.
FirstName | Gets or sets the first name from the most recently swiped card.
Gender | Gets or sets the gender field in the most recently swiped card.
HairColor | Gets or sets the hair color field in the most recently swiped card.
Height | Gets or sets the height field in the most recently swiped card.
LicenseNumber | Gets or sets the license number in the most recently swiped card.
MiddleInitial | Gets or sets the middle initial from the most recently swiped card.
PostalCode | Gets or sets the postal code in the most recently swiped card.
Restrictions | Gets or sets the restrictions field in the most recently swiped card.
ServiceCode | Gets or sets the service code from the most recently swiped card.
State | Gets or sets the state field in the most recently swiped card.
Suffix | Gets or sets the suffix from the most recently swiped card.
Surname | Gets or sets the surname from the most recently swiped card.
Title | Gets or sets the title from the most recently swiped card.
Track1DiscretionaryData | Gets or sets the Track 1 discretionary data from the most recently swiped card.
Track2DiscretionaryData | Gets or sets the Track 2 discretionary data from the most recently swiped card.
Weight | Gets or sets the weight field in the most recently swiped card.

See Also

Reference

MsrFieldData Class
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrFieldData.AccountNumber Property

MsrFieldData.AccountNumber Property |
 | See Also

1/18/2008

Gets or sets the account number from the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property AccountNumber As String
public string AccountNumber { get; set; }
public:
property String^ AccountNumber {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_AccountNumber ()

/** @property */
public void set_AccountNumber (String value)

public function get AccountNumber () : String

public function set AccountNumber (value : String)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrFieldData Class
MsrFieldData Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.AccountNumber Property


MsrFieldData.Address Property

MsrFieldData.Address Property |
 | See Also

1/18/2008

Gets or sets the address in the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Address As String
public string Address { get; set; }
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Address ()

/** @property */
public void set_Address (String value)

public function get Address () : String

public function set Address (value : String)

Property Value

Returns a string.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrFieldData Class
MsrFieldData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrFieldData.BirthDate Property

MsrFieldData.BirthDate Property |
 | See Also

1/18/2008

Gets or sets the date of birth in the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property BirthDate As String
public string BirthDate { get; set; }
public:
property String^ BirthDate {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_BirthDate ()

/** @property */
public void set_BirthDate (String value)

public function get BirthDate () : String

public function set BirthDate (value : String)

Property Value

Returns a string.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrFieldData Class
MsrFieldData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrFieldData.City Property

MsrFieldData.City Property |
 | See Also

1/18/2008

Gets or sets the name of the city in the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property City As String
public string City { get; set; }
public:
property String^ City {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_City ()

/** @property */
public void set_City (String value)

public function get City () : String

public function set City (value : String)

Property Value

Returns a string.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrFieldData Class
MsrFieldData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrFieldData.Class Property

MsrFieldData.Class Property |
 | See Also

1/18/2008

Gets or sets the class in the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Class As String
public string Class { get; set; }
public:
property String^ Class {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Class ()

/** @property */
public void set_Class (String value)

public function get Class () : String

public function set Class (value : String)

Property Value

Returns a string.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrFieldData Class
MsrFieldData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrFieldData.Endorsements Property

MsrFieldData.Endorsements Property |
 | See Also

1/18/2008

Gets or sets the endorsements in the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Endorsements As String
public string Endorsements { get; set; }
public:
property String^ Endorsements {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Endorsements ()

/** @property */
public void set_Endorsements (String value)

public function get Endorsements () : String

public function set Endorsements (value : String)

Property Value

Returns a string.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrFieldData Class
MsrFieldData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrFieldData.ExpirationDate Property

MsrFieldData.ExpirationDate Property |
 | See Also

1/18/2008

Gets or sets the expiration date from the most recently swiped card, as four ASCII decimal characters in the form YYMM. For example, February 1998 is "9802" and August 2018 is "1808".

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property ExpirationDate As String
public string ExpirationDate { get; set; }
public:
property String^ ExpirationDate {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_ExpirationDate ()

/** @property */
public void set_ExpirationDate (String value)

public function get ExpirationDate () : String

public function set ExpirationDate (value : String)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrFieldData Class
MsrFieldData Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.ExpirationDate Property


MsrFieldData.EyeColor Property

MsrFieldData.EyeColor Property |
 | See Also

1/18/2008

Gets or sets the eye color field in the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property EyeColor As String
public string EyeColor { get; set; }
public:
property String^ EyeColor {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_EyeColor ()

/** @property */
public void set_EyeColor (String value)

public function get EyeColor () : String

public function set EyeColor (value : String)

Property Value

Returns a string.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrFieldData Class
MsrFieldData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrFieldData.FirstName Property

MsrFieldData.FirstName Property |
 | See Also

1/18/2008

Gets or sets the first name from the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property FirstName As String
public string FirstName { get; set; }
public:
property String^ FirstName {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_FirstName ()

/** @property */
public void set_FirstName (String value)

public function get FirstName () : String

public function set FirstName (value : String)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrFieldData Class
MsrFieldData Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.FirstName Property


MsrFieldData.Gender Property

MsrFieldData.Gender Property |
 | See Also

1/18/2008

Gets or sets the gender field in the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Gender As String
public string Gender { get; set; }
public:
property String^ Gender {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Gender ()

/** @property */
public void set_Gender (String value)

public function get Gender () : String

public function set Gender (value : String)

Property Value

Returns a string.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrFieldData Class
MsrFieldData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrFieldData.HairColor Property

MsrFieldData.HairColor Property |
 | See Also

1/18/2008

Gets or sets the hair color field in the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property HairColor As String
public string HairColor { get; set; }
public:
property String^ HairColor {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_HairColor ()

/** @property */
public void set_HairColor (String value)

public function get HairColor () : String

public function set HairColor (value : String)

Property Value

Return a string.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrFieldData Class
MsrFieldData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrFieldData.Height Property

MsrFieldData.Height Property |
 | See Also

1/18/2008

Gets or sets the height field in the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Height As String
public string Height { get; set; }
public:
property String^ Height {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Height ()

/** @property */
public void set_Height (String value)

public function get Height () : String

public function set Height (value : String)

Property Value

Returns a string.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrFieldData Class
MsrFieldData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrFieldData.LicenseNumber Property

MsrFieldData.LicenseNumber Property |
 | See Also

1/18/2008

Gets or sets the license number in the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property LicenseNumber As String
public string LicenseNumber { get; set; }
public:
property String^ LicenseNumber {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_LicenseNumber ()

/** @property */
public void set_LicenseNumber (String value)

public function get LicenseNumber () : String

public function set LicenseNumber (value : String)

Property Value

Returns a string.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrFieldData Class
MsrFieldData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrFieldData.MiddleInitial Property

MsrFieldData.MiddleInitial Property |
 | See Also

1/18/2008

Gets or sets the middle initial from the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property MiddleInitial As String
public string MiddleInitial { get; set; }
public:
property String^ MiddleInitial {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_MiddleInitial ()

/** @property */
public void set_MiddleInitial (String value)

public function get MiddleInitial () : String

public function set MiddleInitial (value : String)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrFieldData Class
MsrFieldData Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.MiddleInitial Property


MsrFieldData.PostalCode Property

MsrFieldData.PostalCode Property |
 | See Also

1/18/2008

Gets or sets the postal code in the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property PostalCode As String
public string PostalCode { get; set; }
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_PostalCode ()

/** @property */
public void set_PostalCode (String value)

public function get PostalCode () : String

public function set PostalCode (value : String)

Property Value

Returns a string.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrFieldData Class
MsrFieldData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrFieldData.Restrictions Property

MsrFieldData.Restrictions Property |
 | See Also

1/18/2008

Gets or sets the restrictions field in the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Restrictions As String
public string Restrictions { get; set; }
public:
property String^ Restrictions {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Restrictions ()

/** @property */
public void set_Restrictions (String value)

public function get Restrictions () : String

public function set Restrictions (value : String)

Property Value

Returns a string.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrFieldData Class
MsrFieldData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrFieldData.ServiceCode Property

MsrFieldData.ServiceCode Property |
 | See Also

1/18/2008

Gets or sets the service code from the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property ServiceCode As String
public string ServiceCode { get; set; }
public:
property String^ ServiceCode {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_ServiceCode ()

/** @property */
public void set_ServiceCode (String value)

public function get ServiceCode () : String

public function set ServiceCode (value : String)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrFieldData Class
MsrFieldData Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.ServiceCode Property


MsrFieldData.State Property

MsrFieldData.State Property |
 | See Also

1/18/2008

Gets or sets the state field in the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property State As String
public string State { get; set; }
public:
property String^ State {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_State ()

/** @property */
public void set_State (String value)

public function get State () : String

public function set State (value : String)

Property Value

Returns a string.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrFieldData Class
MsrFieldData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrFieldData.Suffix Property

MsrFieldData.Suffix Property |
 | See Also

1/18/2008

Gets or sets the suffix from the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Suffix As String
public string Suffix { get; set; }
public:
property String^ Suffix {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Suffix ()

/** @property */
public void set_Suffix (String value)

public function get Suffix () : String

public function set Suffix (value : String)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrFieldData Class
MsrFieldData Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.Suffix Property


MsrFieldData.Surname Property

MsrFieldData.Surname Property |
 | See Also

1/18/2008

Gets or sets the surname from the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Surname As String
public string Surname { get; set; }
public:
property String^ Surname {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Surname ()

/** @property */
public void set_Surname (String value)

public function get Surname () : String

public function set Surname (value : String)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrFieldData Class
MsrFieldData Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.Surname Property


MsrFieldData.Title Property

MsrFieldData.Title Property |
 | See Also

1/18/2008

Gets or sets the title from the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Title As String
public string Title { get; set; }
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Title ()

/** @property */
public void set_Title (String value)

public function get Title () : String

public function set Title (value : String)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrFieldData Class
MsrFieldData Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.Title Property


MsrFieldData.Track1DiscretionaryData Property

MsrFieldData.Track1DiscretionaryData Property |
 | See Also

1/18/2008

Gets or sets the Track 1 discretionary data from the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Track1DiscretionaryData As Byte()
public byte[] Track1DiscretionaryData { get; set; }
public:
property array<unsigned char>^ Track1DiscretionaryData {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
/** @property */
public byte[] get_Track1DiscretionaryData ()

/** @property */
public void set_Track1DiscretionaryData (byte[] value)

public function get Track1DiscretionaryData () : byte[]

public function set Track1DiscretionaryData (value : byte[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrFieldData Class
MsrFieldData Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.Track1DiscretionaryData Property


MsrFieldData.Track2DiscretionaryData Property

MsrFieldData.Track2DiscretionaryData Property |
 | See Also

1/18/2008

Gets or sets the Track 2 discretionary data from the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Track2DiscretionaryData As Byte()
public byte[] Track2DiscretionaryData { get; set; }
public:
property array<unsigned char>^ Track2DiscretionaryData {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
/** @property */
public byte[] get_Track2DiscretionaryData ()

/** @property */
public void set_Track2DiscretionaryData (byte[] value)

public function get Track2DiscretionaryData () : byte[]

public function set Track2DiscretionaryData (value : byte[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrFieldData Class
MsrFieldData Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.Track2DiscretionaryData Property


MsrFieldData.Weight Property

MsrFieldData.Weight Property |
 | See Also

1/18/2008

Gets or sets the weight field in the most recently swiped card.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Weight As String
public string Weight { get; set; }
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_Weight ()

/** @property */
public void set_Weight (String value)

public function get Weight () : String

public function set Weight (value : String)

Property Value

Returns a string.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrFieldData Class
MsrFieldData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrProperties Class

MsrProperties Class |
 | See Also Members

1/18/2008

A helper class created by POS for .NET to simplify the retrieval and setting of property values for MSR devices.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class MsrProperties
    Inherits CommonProperties
public class MsrProperties : CommonProperties
public ref class MsrProperties : public CommonProperties
public class MsrProperties extends CommonProperties
public class MsrProperties extends CommonProperties

Remarks

MsrProperties is a helper class created by POS for .NET to simplify the retrieval and setting of property values for MSR devices. MsrProperties inherits from the CommonProperties class. The protected Properties property of MsrBase class returns an instance of MsrProperties. The service object can manage the value of a property using the syntax Properties.<propertyName>. MsrProperties bypasses state validation—in other words, the service object can use MsrProperties to set values for properties even though the application hasn’t opened, claimed, or enabled the MSR device.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BasicServiceObjects.CommonProperties
Microsoft.PointOfService.BaseServiceObjects.MsrProperties

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrProperties Members

MsrProperties Members |
 | See Also Methods Properties

1/18/2008

A helper class created by POS for .NET to simplify the retrieval and setting of property values for MSR devices.

The following tables list the members exposed by the MsrProperties type.

Public Properties

Name | Description
CapCardAuthentication |
CapCompareFirmwareVersion | (inherited from CommonProperties )
CapDataEncryption |
CapDeviceAuthentication |
CapIso | Indicates that the MSR supports ISO cards.
CapJisOne | Indicates that the MSR device supports JIS Type-I cards.
CapJisTwo | Indicates that the MSR device supports JIS Type-II cards.
CapPowerReporting | (inherited from CommonProperties )
CapStatisticsReporting | (inherited from CommonProperties )
CapTrackDataMasking |
CapTransmitSentinels | Indicates that the MSR device can transmit start and end sentinels.
CapUpdateFirmware | (inherited from CommonProperties )
CapUpdateStatistics | (inherited from CommonProperties )
CardTypeList |
DataEncryptionAlgorithm |
DeviceAuthenticated |
DeviceAuthenticationProtocol |
DeviceDescription | (inherited from CommonProperties )
DeviceName | (inherited from CommonProperties )
PowerState | (inherited from CommonProperties )
ServiceObjectDescription | (inherited from CommonProperties )
ServiceObjectVersion | (inherited from CommonProperties )
State | (inherited from CommonProperties )
WriteCardType |
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

MsrProperties Class
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrProperties Methods

MsrProperties Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

MsrProperties Class
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrProperties Properties

MsrProperties Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
CapCardAuthentication |
CapCompareFirmwareVersion | (inherited from CommonProperties )
CapDataEncryption |
CapDeviceAuthentication |
CapIso | Indicates that the MSR supports ISO cards.
CapJisOne | Indicates that the MSR device supports JIS Type-I cards.
CapJisTwo | Indicates that the MSR device supports JIS Type-II cards.
CapPowerReporting | (inherited from CommonProperties )
CapStatisticsReporting | (inherited from CommonProperties )
CapTrackDataMasking |
CapTransmitSentinels | Indicates that the MSR device can transmit start and end sentinels.
CapUpdateFirmware | (inherited from CommonProperties )
CapUpdateStatistics | (inherited from CommonProperties )
CardTypeList |
DataEncryptionAlgorithm |
DeviceAuthenticated |
DeviceAuthenticationProtocol |
DeviceDescription | (inherited from CommonProperties )
DeviceName | (inherited from CommonProperties )
PowerState | (inherited from CommonProperties )
ServiceObjectDescription | (inherited from CommonProperties )
ServiceObjectVersion | (inherited from CommonProperties )
State | (inherited from CommonProperties )
WriteCardType |

See Also

Reference

MsrProperties Class
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrProperties.CapCardAuthentication Property

MsrProperties.CapCardAuthentication Property |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapCardAuthentication As String

public string CapCardAuthentication { get; set; }

public:
property String^ CapCardAuthentication {
    String^ get ();
    void set (String^ value);
}

/** @property */
public String get_CapCardAuthentication ()

/** @property */
public void set_CapCardAuthentication (String value)

public function get CapCardAuthentication () : String

public function set CapCardAuthentication (value : String)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrProperties Class
MsrProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrProperties.CapDataEncryption Property

MsrProperties.CapDataEncryption Property |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapDataEncryption As EncryptionAlgorithm

public EncryptionAlgorithm CapDataEncryption { get; set; }

public:
property EncryptionAlgorithm CapDataEncryption {
    EncryptionAlgorithm get ();
    void set (EncryptionAlgorithm value);
}

/** @property */
public EncryptionAlgorithm get_CapDataEncryption ()

/** @property */
public void set_CapDataEncryption (EncryptionAlgorithm value)

public function get CapDataEncryption () : EncryptionAlgorithm

public function set CapDataEncryption (value : EncryptionAlgorithm)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrProperties Class
MsrProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrProperties.CapDeviceAuthentication Property

MsrProperties.CapDeviceAuthentication Property |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapDeviceAuthentication As DeviceAuthenticationLevel

public DeviceAuthenticationLevel CapDeviceAuthentication { get; set; }

public:
property DeviceAuthenticationLevel CapDeviceAuthentication {
    DeviceAuthenticationLevel get ();
    void set (DeviceAuthenticationLevel value);
}

/** @property */
public DeviceAuthenticationLevel get_CapDeviceAuthentication ()

/** @property */
public void set_CapDeviceAuthentication (DeviceAuthenticationLevel value)

public function get CapDeviceAuthentication () : DeviceAuthenticationLevel

public function set CapDeviceAuthentication (value : DeviceAuthenticationLevel)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrProperties Class
MsrProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrProperties.CapIso Property

MsrProperties.CapIso Property |
 | See Also

1/18/2008

Indicates that the MSR supports ISO cards.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapIso As Boolean
public bool CapIso { get; set; }
public:
property bool CapIso {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapIso ()

/** @property */
public void set_CapIso (boolean value)

public function get CapIso () : boolean

public function set CapIso (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrProperties Class
MsrProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
MsrBase.CapIso Property


MsrProperties.CapJisOne Property

MsrProperties.CapJisOne Property |
 | See Also

1/18/2008

Indicates that the MSR device supports JIS Type-I cards.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapJisOne As Boolean
public bool CapJisOne { get; set; }
public:
property bool CapJisOne {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapJisOne ()

/** @property */
public void set_CapJisOne (boolean value)

public function get CapJisOne () : boolean

public function set CapJisOne (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrProperties Class
MsrProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
MsrBase.CapJisOne Property


MsrProperties.CapJisTwo Property

MsrProperties.CapJisTwo Property |
 | See Also

1/18/2008

Indicates that the MSR device supports JIS Type-II cards.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapJisTwo As Boolean
public bool CapJisTwo { get; set; }
public:
property bool CapJisTwo {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapJisTwo ()

/** @property */
public void set_CapJisTwo (boolean value)

public function get CapJisTwo () : boolean

public function set CapJisTwo (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrProperties Class
MsrProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
MsrBase.CapJisTwo Property


MsrProperties.CapTrackDataMasking Property

MsrProperties.CapTrackDataMasking Property |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapTrackDataMasking As Boolean

public bool CapTrackDataMasking { get; set; }

public:
property bool CapTrackDataMasking {
    bool get ();
    void set (bool value);
}

/** @property */
public boolean get_CapTrackDataMasking ()

/** @property */
public void set_CapTrackDataMasking (boolean value)

public function get CapTrackDataMasking () : boolean

public function set CapTrackDataMasking (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrProperties Class
MsrProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrProperties.CapTransmitSentinels Property

MsrProperties.CapTransmitSentinels Property |
 | See Also

1/18/2008

Indicates that the MSR device can transmit start and end sentinels.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapTransmitSentinels As Boolean
public bool CapTransmitSentinels { get; set; }
public:
property bool CapTransmitSentinels {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapTransmitSentinels ()

/** @property */
public void set_CapTransmitSentinels (boolean value)

public function get CapTransmitSentinels () : boolean

public function set CapTransmitSentinels (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrProperties Class
MsrProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
MsrBase.CapTransmitSentinels Property


MsrProperties.CardTypeList Property

MsrProperties.CardTypeList Property |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CardTypeList As List(Of String)

public List<string> CardTypeList { get; set; }

public:
property List<String^>^ CardTypeList {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

/** @property */
public List<String> get_CardTypeList ()

/** @property */
public void set_CardTypeList (List<String> value)

public function get CardTypeList () : List<String>

public function set CardTypeList (value : List<String>)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrProperties Class
MsrProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrProperties.DataEncryptionAlgorithm Property

MsrProperties.DataEncryptionAlgorithm Property |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property DataEncryptionAlgorithm As EncryptionAlgorithm

public EncryptionAlgorithm DataEncryptionAlgorithm { get; set; }

public:
property EncryptionAlgorithm DataEncryptionAlgorithm {
    EncryptionAlgorithm get ();
    void set (EncryptionAlgorithm value);
}

/** @property */
public EncryptionAlgorithm get_DataEncryptionAlgorithm ()

/** @property */
public void set_DataEncryptionAlgorithm (EncryptionAlgorithm value)

public function get DataEncryptionAlgorithm () : EncryptionAlgorithm

public function set DataEncryptionAlgorithm (value : EncryptionAlgorithm)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrProperties Class
MsrProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrProperties.DeviceAuthenticated Property

MsrProperties.DeviceAuthenticated Property |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property DeviceAuthenticated As Boolean

public bool DeviceAuthenticated { get; set; }

public:
property bool DeviceAuthenticated {
    bool get ();
    void set (bool value);
}

/** @property */
public boolean get_DeviceAuthenticated ()

/** @property */
public void set_DeviceAuthenticated (boolean value)

public function get DeviceAuthenticated () : boolean

public function set DeviceAuthenticated (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrProperties Class
MsrProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrProperties.DeviceAuthenticationProtocol Property

MsrProperties.DeviceAuthenticationProtocol Property |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property DeviceAuthenticationProtocol As DeviceAuthenticationProtocol

public DeviceAuthenticationProtocol DeviceAuthenticationProtocol { get; set; }

public:
property DeviceAuthenticationProtocol DeviceAuthenticationProtocol {
    DeviceAuthenticationProtocol get ();
    void set (DeviceAuthenticationProtocol value);
}

/** @property */
public DeviceAuthenticationProtocol get_DeviceAuthenticationProtocol ()

/** @property */
public void set_DeviceAuthenticationProtocol (DeviceAuthenticationProtocol value)

public function get DeviceAuthenticationProtocol () : DeviceAuthenticationProtocol

public function set DeviceAuthenticationProtocol (value : DeviceAuthenticationProtocol)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrProperties Class
MsrProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrProperties.WriteCardType Property

MsrProperties.WriteCardType Property |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property WriteCardType As String

public string WriteCardType { get; set; }

public:
property String^ WriteCardType {
    String^ get ();
    void set (String^ value);
}

/** @property */
public String get_WriteCardType ()

/** @property */
public void set_WriteCardType (String value)

public function get WriteCardType () : String

public function set WriteCardType (value : String)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrProperties Class
MsrProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrTrackData Class

MsrTrackData Class |
 | See Also Members

1/18/2008

An instance of MsrTrackData is returned by the ParseMsrTrackData protected method of the MsrBase class. Tracks 1 through 4 are decoded and stored in each of the four, discrete Track properties.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class MsrTrackData
public class MsrTrackData
public ref class MsrTrackData
public class MsrTrackData
public class MsrTrackData

Remarks

An instance of MsrTrackData is returned by the ParseMsrTrackData protected method of the MsrBase class. Tracks 1 through 4 are decoded and stored in each of the four, discrete Track properties.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BaseServiceObjects.MsrTrackData

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrTrackData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrTrackData Members

MsrTrackData Members |
 | See Also Constructors Methods Properties

1/18/2008

An instance of MsrTrackData is returned by the ParseMsrTrackData protected method of the MsrBase class. Tracks 1 through 4 are decoded and stored in each of the four, discrete Track properties.

The following tables list the members exposed by the MsrTrackData type.

Public Constructors

Name | Description
MsrTrackData | Overloaded.
Top

Public Properties

Name | Description
Track1Data | Holds decoded data from the first MSR track.
Track1EncryptedData |
Track1EncryptedDataLength |
Track2Data | Holds decoded data from the second MSR track.
Track2EncryptedData |
Track2EncryptedDataLength |
Track3Data | Holds decoded data from the third MSR track.
Track3EncryptedData |
Track3EncryptedDataLength |
Track4Data | Holds decoded data from the fourth MSR track.
Track4EncryptedData |
Track4EncryptedDataLength |
Top

Public Methods (see also Protected Methods )

Name | Description
Clone |
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

MsrTrackData Class
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrTrackData Constructor

MsrTrackData Constructor |
 | See Also

1/18/2008

Overload List

Name | Description
MsrTrackData () | Creates a new instance of the MsrTrackData class.
MsrTrackData (Byte[], Byte[], Byte[], Byte[]) | Creates a new instance of the MsrTrackData class with the specified MSR track data.
MsrTrackData (Byte[], Int32, Byte[], Int32, Byte[], Int32, Byte[], Int32) |
MsrTrackData (Byte[], Byte[], Byte[], Byte[], Byte[], Int32, Byte[], Int32, Byte[], Int32, Byte[], Int32) |

See Also

Reference

MsrTrackData Class
MsrTrackData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrTrackData Constructor ()

MsrTrackData Constructor () |
 | See Also

1/18/2008

Creates a new instance of the MsrTrackData class.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub New
public MsrTrackData ()
public:
MsrTrackData ()
public MsrTrackData ()
public function MsrTrackData ()

Remarks

This constructor creates a new instance of the MsrTrackData class. All track data properties will be empty.

See Also

Reference

MsrTrackData Class
MsrTrackData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrTrackData Constructor (Byte[], Byte[], Byte[], Byte[])

MsrTrackData Constructor (Byte[], Byte[], Byte[], Byte[]) |
 | See Also

1/18/2008

Creates a new instance of the MsrTrackData class with the specified MSR track data.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub New ( _
    track1Data As Byte(), _
    track2Data As Byte(), _
    track3Data As Byte(), _
    track4Data As Byte() _
)
public MsrTrackData (
    byte[] track1Data,
    byte[] track2Data,
    byte[] track3Data,
    byte[] track4Data
)
public:
MsrTrackData (
    array<unsigned char>^ track1Data,
    array<unsigned char>^ track2Data,
    array<unsigned char>^ track3Data,
    array<unsigned char>^ track4Data
)
public MsrTrackData (
    byte[] track1Data,
    byte[] track2Data,
    byte[] track3Data,
    byte[] track4Data
)
public function MsrTrackData (
    track1Data : byte[],
    track2Data : byte[],
    track3Data : byte[],
    track4Data : byte[]
)

Parameters

track1Data

Data from the first MSR track.

track2Data

Data from the second MSR track.

track3Data

Data from the third MSR track.

track4Data

Data from the fourth MSR track.

Remarks

Creates a new instance of the MsrTrackData class with the specified MSR track data.

See Also

Reference

MsrTrackData Class
MsrTrackData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrTrackData Constructor (Byte[], Int32, Byte[], Int32, Byte[], Int32, Byte[], Int32)

MsrTrackData Constructor (Byte[], Int32, Byte[], Int32, Byte[], Int32, Byte[], Int32) |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub New ( _
    track1EncryptedData As Byte(), _
    track1EncryptedDataLength As Integer, _
    track2EncryptedData As Byte(), _
    track2EncryptedDataLength As Integer, _
    track3EncryptedData As Byte(), _
    track3EncryptedDataLength As Integer, _
    track4EncryptedData As Byte(), _
    track4EncryptedDataLength As Integer _
)

public MsrTrackData (
    byte[] track1EncryptedData,
    int track1EncryptedDataLength,
    byte[] track2EncryptedData,
    int track2EncryptedDataLength,
    byte[] track3EncryptedData,
    int track3EncryptedDataLength,
    byte[] track4EncryptedData,
    int track4EncryptedDataLength
)

public:
MsrTrackData (
    array<unsigned char>^ track1EncryptedData,
    int track1EncryptedDataLength,
    array<unsigned char>^ track2EncryptedData,
    int track2EncryptedDataLength,
    array<unsigned char>^ track3EncryptedData,
    int track3EncryptedDataLength,
    array<unsigned char>^ track4EncryptedData,
    int track4EncryptedDataLength
)

public MsrTrackData (
    byte[] track1EncryptedData,
    int track1EncryptedDataLength,
    byte[] track2EncryptedData,
    int track2EncryptedDataLength,
    byte[] track3EncryptedData,
    int track3EncryptedDataLength,
    byte[] track4EncryptedData,
    int track4EncryptedDataLength
)

public function MsrTrackData (
    track1EncryptedData : byte[],
    track1EncryptedDataLength : int,
    track2EncryptedData : byte[],
    track2EncryptedDataLength : int,
    track3EncryptedData : byte[],
    track3EncryptedDataLength : int,
    track4EncryptedData : byte[],
    track4EncryptedDataLength : int
)

Parameters

track1EncryptedData
track1EncryptedDataLength
track2EncryptedData
track2EncryptedDataLength
track3EncryptedData
track3EncryptedDataLength
track4EncryptedData
track4EncryptedDataLength

See Also

Reference

MsrTrackData Class
MsrTrackData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrTrackData Constructor (Byte[], Byte[], Byte[], Byte[], Byte[], Int32, Byte[], Int32, Byte[], Int32, Byte[], Int32)

MsrTrackData Constructor (Byte[], Byte[], Byte[], Byte[], Byte[], Int32, Byte[], Int32, Byte[], Int32, Byte[], Int32) |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub New ( _
    track1Data As Byte(), _
    track2Data As Byte(), _
    track3Data As Byte(), _
    track4Data As Byte(), _
    track1EncryptedData As Byte(), _
    track1EncryptedDataLength As Integer, _
    track2EncryptedData As Byte(), _
    track2EncryptedDataLength As Integer, _
    track3EncryptedData As Byte(), _
    track3EncryptedDataLength As Integer, _
    track4EncryptedData As Byte(), _
    track4EncryptedDataLength As Integer _
)

public MsrTrackData (
    byte[] track1Data,
    byte[] track2Data,
    byte[] track3Data,
    byte[] track4Data,
    byte[] track1EncryptedData,
    int track1EncryptedDataLength,
    byte[] track2EncryptedData,
    int track2EncryptedDataLength,
    byte[] track3EncryptedData,
    int track3EncryptedDataLength,
    byte[] track4EncryptedData,
    int track4EncryptedDataLength
)

public:
MsrTrackData (
    array<unsigned char>^ track1Data,
    array<unsigned char>^ track2Data,
    array<unsigned char>^ track3Data,
    array<unsigned char>^ track4Data,
    array<unsigned char>^ track1EncryptedData,
    int track1EncryptedDataLength,
    array<unsigned char>^ track2EncryptedData,
    int track2EncryptedDataLength,
    array<unsigned char>^ track3EncryptedData,
    int track3EncryptedDataLength,
    array<unsigned char>^ track4EncryptedData,
    int track4EncryptedDataLength
)

public MsrTrackData (
    byte[] track1Data,
    byte[] track2Data,
    byte[] track3Data,
    byte[] track4Data,
    byte[] track1EncryptedData,
    int track1EncryptedDataLength,
    byte[] track2EncryptedData,
    int track2EncryptedDataLength,
    byte[] track3EncryptedData,
    int track3EncryptedDataLength,
    byte[] track4EncryptedData,
    int track4EncryptedDataLength
)

public function MsrTrackData (
    track1Data : byte[],
    track2Data : byte[],
    track3Data : byte[],
    track4Data : byte[],
    track1EncryptedData : byte[],
    track1EncryptedDataLength : int,
    track2EncryptedData : byte[],
    track2EncryptedDataLength : int,
    track3EncryptedData : byte[],
    track3EncryptedDataLength : int,
    track4EncryptedData : byte[],
    track4EncryptedDataLength : int
)

Parameters

track1Data
track2Data
track3Data
track4Data
track1EncryptedData
track1EncryptedDataLength
track2EncryptedData
track2EncryptedDataLength
track3EncryptedData
track3EncryptedDataLength
track4EncryptedData
track4EncryptedDataLength

See Also

Reference

MsrTrackData Class
MsrTrackData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrTrackData Methods

MsrTrackData Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Clone |
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

MsrTrackData Class
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrTrackData.Clone Method

MsrTrackData.Clone Method |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Function Clone As MsrTrackData

public MsrTrackData Clone ()

public:
MsrTrackData^ Clone ()

public MsrTrackData Clone ()

public function Clone () : MsrTrackData

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrTrackData Class
MsrTrackData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrTrackData Properties

MsrTrackData Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
Track1Data | Holds decoded data from the first MSR track.
Track1EncryptedData |
Track1EncryptedDataLength |
Track2Data | Holds decoded data from the second MSR track.
Track2EncryptedData |
Track2EncryptedDataLength |
Track3Data | Holds decoded data from the third MSR track.
Track3EncryptedData |
Track3EncryptedDataLength |
Track4Data | Holds decoded data from the fourth MSR track.
Track4EncryptedData |
Track4EncryptedDataLength |

See Also

Reference

MsrTrackData Class
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrTrackData.Track1Data Property

MsrTrackData.Track1Data Property |
 | See Also

1/18/2008

Holds decoded data from the first MSR track.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Track1Data As Byte()
public byte[] Track1Data { get; set; }
public:
property array<unsigned char>^ Track1Data {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
/** @property */
public byte[] get_Track1Data ()

/** @property */
public void set_Track1Data (byte[] value)

public function get Track1Data () : byte[]

public function set Track1Data (value : byte[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrTrackData Class
MsrTrackData Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.Track1Data Property


MsrTrackData.Track1EncryptedData Property

MsrTrackData.Track1EncryptedData Property |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Track1EncryptedData As Byte()

public byte[] Track1EncryptedData { get; set; }

public:
property array<unsigned char>^ Track1EncryptedData {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

/** @property */
public byte[] get_Track1EncryptedData ()

/** @property */
public void set_Track1EncryptedData (byte[] value)

public function get Track1EncryptedData () : byte[]

public function set Track1EncryptedData (value : byte[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrTrackData Class
MsrTrackData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrTrackData.Track1EncryptedDataLength Property

MsrTrackData.Track1EncryptedDataLength Property |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Track1EncryptedDataLength As Integer

public int Track1EncryptedDataLength { get; }

public:
property int Track1EncryptedDataLength {
    int get ();
}

/** @property */
public int get_Track1EncryptedDataLength ()

public function get Track1EncryptedDataLength () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrTrackData Class
MsrTrackData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrTrackData.Track2Data Property

MsrTrackData.Track2Data Property |
 | See Also

1/18/2008

Holds decoded data from the second MSR track.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Track2Data As Byte()
public byte[] Track2Data { get; set; }
public:
property array<unsigned char>^ Track2Data {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
/** @property */
public byte[] get_Track2Data ()

/** @property */
public void set_Track2Data (byte[] value)

public function get Track2Data () : byte[]

public function set Track2Data (value : byte[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrTrackData Class
MsrTrackData Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.Track2Data Property


MsrTrackData.Track2EncryptedData Property

MsrTrackData.Track2EncryptedData Property |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Track2EncryptedData As Byte()

public byte[] Track2EncryptedData { get; set; }

public:
property array<unsigned char>^ Track2EncryptedData {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

/** @property */
public byte[] get_Track2EncryptedData ()

/** @property */
public void set_Track2EncryptedData (byte[] value)

public function get Track2EncryptedData () : byte[]

public function set Track2EncryptedData (value : byte[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrTrackData Class
MsrTrackData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrTrackData.Track2EncryptedDataLength Property

MsrTrackData.Track2EncryptedDataLength Property |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Track2EncryptedDataLength As Integer

public int Track2EncryptedDataLength { get; }

public:
property int Track2EncryptedDataLength {
    int get ();
}

/** @property */
public int get_Track2EncryptedDataLength ()

public function get Track2EncryptedDataLength () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrTrackData Class
MsrTrackData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrTrackData.Track3Data Property

MsrTrackData.Track3Data Property |
 | See Also

1/18/2008

Holds decoded data from the third MSR track.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Track3Data As Byte()
public byte[] Track3Data { get; set; }
public:
property array<unsigned char>^ Track3Data {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
/** @property */
public byte[] get_Track3Data ()

/** @property */
public void set_Track3Data (byte[] value)

public function get Track3Data () : byte[]

public function set Track3Data (value : byte[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrTrackData Class
MsrTrackData Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.Track3Data Property


MsrTrackData.Track3EncryptedData Property

MsrTrackData.Track3EncryptedData Property |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Track3EncryptedData As Byte()

public byte[] Track3EncryptedData { get; set; }

public:
property array<unsigned char>^ Track3EncryptedData {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

/** @property */
public byte[] get_Track3EncryptedData ()

/** @property */
public void set_Track3EncryptedData (byte[] value)

public function get Track3EncryptedData () : byte[]

public function set Track3EncryptedData (value : byte[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrTrackData Class
MsrTrackData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrTrackData.Track3EncryptedDataLength Property

MsrTrackData.Track3EncryptedDataLength Property |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Track3EncryptedDataLength As Integer

public int Track3EncryptedDataLength { get; }

public:
property int Track3EncryptedDataLength {
    int get ();
}

/** @property */
public int get_Track3EncryptedDataLength ()

public function get Track3EncryptedDataLength () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrTrackData Class
MsrTrackData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrTrackData.Track4Data Property

MsrTrackData.Track4Data Property |
 | See Also

1/18/2008

Holds decoded data from the fourth MSR track.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Track4Data As Byte()
public byte[] Track4Data { get; set; }
public:
property array<unsigned char>^ Track4Data {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
/** @property */
public byte[] get_Track4Data ()

/** @property */
public void set_Track4Data (byte[] value)

public function get Track4Data () : byte[]

public function set Track4Data (value : byte[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrTrackData Class
MsrTrackData Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Msr.Track4Data Property


MsrTrackData.Track4EncryptedData Property

MsrTrackData.Track4EncryptedData Property |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Track4EncryptedData As Byte()

public byte[] Track4EncryptedData { get; set; }

public:
property array<unsigned char>^ Track4EncryptedData {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

/** @property */
public byte[] get_Track4EncryptedData ()

/** @property */
public void set_Track4EncryptedData (byte[] value)

public function get Track4EncryptedData () : byte[]

public function set Track4EncryptedData (value : byte[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrTrackData Class
MsrTrackData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


MsrTrackData.Track4EncryptedDataLength Property

MsrTrackData.Track4EncryptedDataLength Property |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Track4EncryptedDataLength As Integer

public int Track4EncryptedDataLength { get; }

public:
property int Track4EncryptedDataLength {
    int get ();
}

/** @property */
public int get_Track4EncryptedDataLength ()

public function get Track4EncryptedDataLength () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

MsrTrackData Class
MsrTrackData Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PageModePrintCollection Class

PageModePrintCollection Class |
 | See Also Members

1/18/2008

Prints a collection of PageModePrintOperation.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class PageModePrintCollection
    Inherits PrintOperationCollection
public class PageModePrintCollection : PrintOperationCollection
public ref class PageModePrintCollection : public PrintOperationCollection
public class PageModePrintCollection extends PrintOperationCollection
public class PageModePrintCollection extends PrintOperationCollection

Inheritance Hierarchy

System.Object
System.Collections.ReadOnlyCollectionBase
Microsoft.PointOfService.BaseServiceObjects.PrintOperationCollection
Microsoft.PointOfService.BaseServiceObjects.PageModePrintCollection

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PageModePrintCollection Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PageModePrintCollection Members

PageModePrintCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

1/18/2008

Prints a collection of PageModePrintOperation.

The following tables list the members exposed by the PageModePrintCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from ReadOnlyCollectionBase )
Item | (inherited from PrintOperationCollection )
Station | Retrieves the printer station, as defined by the PrinterStation enumeration, associated with the array. (inherited from PrintOperationCollection)
Top

Protected Properties

Name | Description
InnerList | (inherited from ReadOnlyCollectionBase )
Top

Public Methods (see also Protected Methods )

Name | Description
CopyTo | (inherited from PrintOperationCollection )
Equals | Overloaded. (inherited from Object )
GetEnumerator | (inherited from ReadOnlyCollectionBase )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from ReadOnlyCollectionBase )
System.Collections.ICollection.IsSynchronized | (inherited from ReadOnlyCollectionBase )
System.Collections.ICollection.SyncRoot | (inherited from ReadOnlyCollectionBase )
Top

See Also

Reference

PageModePrintCollection Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PageModePrintCollection Methods

PageModePrintCollection Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
CopyTo | (inherited from PrintOperationCollection )
Equals | Overloaded. (inherited from Object )
GetEnumerator | (inherited from ReadOnlyCollectionBase )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from ReadOnlyCollectionBase )

See Also

Reference

PageModePrintCollection Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PageModePrintCollection Properties

PageModePrintCollection Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from ReadOnlyCollectionBase )
Item | (inherited from PrintOperationCollection )
Station | Retrieves the printer station, as defined by the PrinterStation enumeration, associated with the array. (inherited from PrintOperationCollection )

Protected Properties

Name | Description
InnerList | (inherited from ReadOnlyCollectionBase )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.IsSynchronized | (inherited from ReadOnlyCollectionBase )
System.Collections.ICollection.SyncRoot | (inherited from ReadOnlyCollectionBase )

See Also

Reference

PageModePrintCollection Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PageModePrintOperation Class

PageModePrintOperation Class |
 | See Also Members

1/18/2008

Indicates a single page mode print operation.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class PageModePrintOperation
    Inherits PrintOperation
public class PageModePrintOperation : PrintOperation
public ref class PageModePrintOperation : public PrintOperation
public class PageModePrintOperation extends PrintOperation
public class PageModePrintOperation extends PrintOperation

Remarks

PageMode is entered by calling the PageModePrint method.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BaseServiceObjects.PrintOperation
Microsoft.PointOfService.BaseServiceObjects.PageModePrintOperation

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PageModePrintOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PageModePrintOperation Members

PageModePrintOperation Members |
 | See Also Methods Properties

1/18/2008

Indicates a single page mode print operation.

The following tables list the members exposed by the PageModePrintOperation type.

Public Properties

Name | Description
AsyncMode | Contains the AsyncMode property setting at the time of the application’s print request. (inherited from PrintOperation)
Collection | Gets a collection of PageModePrintOperation contained in PageModePrintCollection.
Rotation | Contains the Rotation setting, as defined by the Rotation enumeration. (inherited from PrintOperation)
State | Contains an instance of the PrinterState class, which captures the current printer property values at the time of the application’s print request. (inherited from PrintOperation)
Station | Contains the printer station setting (for example, PrinterStation.Journal). (inherited from PrintOperation)
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

PageModePrintOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PageModePrintOperation Methods

PageModePrintOperation Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

PageModePrintOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PageModePrintOperation Properties

PageModePrintOperation Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
AsyncMode | Contains the AsyncMode property setting at the time of the application’s print request. (inherited from PrintOperation )
Collection | Gets a collection of PageModePrintOperation contained in PageModePrintCollection.
Rotation | Contains the Rotation setting, as defined by the Rotation enumeration. (inherited from PrintOperation )
State | Contains an instance of the PrinterState class, which captures the current printer property values at the time of the application’s print request. (inherited from PrintOperation )
Station | Contains the printer station setting (for example, PrinterStation.Journal). (inherited from PrintOperation )

See Also

Reference

PageModePrintOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PageModePrintOperation.Collection Property

PageModePrintOperation.Collection Property |
 | See Also

1/18/2008

Gets a collection of PageModePrintOperation contained in PageModePrintCollection.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Collection As PageModePrintCollection
public PageModePrintCollection Collection { get; }
public:
property PageModePrintCollection^ Collection {
    PageModePrintCollection^ get ();
}
/** @property */
public PageModePrintCollection get_Collection ()

public function get Collection () : PageModePrintCollection

Remarks

PageMode is entered by calling the PageModePrint method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PageModePrintOperation Class
PageModePrintOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PinPadBase Class

PinPadBase Class |
 | See Also Members

1/18/2008

Implements all properties and methods for supporting PIN pad devices.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public MustInherit Class PinPadBase
    Inherits PinPadBasic
public abstract class PinPadBase : PinPadBasic
public ref class PinPadBase abstract : public PinPadBasic
public abstract class PinPadBase extends PinPadBasic
public abstract class PinPadBase extends PinPadBasic

Remarks

The PinPadBase class derives from the PinPadBasic class and implements all properties and methods for support of PIN pad devices. When deriving from PinPadBase, service objects should implement the CheckHealth and DirectIO methods. In addition, they should set all Cap~ properties and implement all ~Impl methods.

PinPadBase class provides a protected method, ExitPinEntryMode. Service objects should call this method to signal to the LineDisplayBase class when PIN entry is complete. When ExitPinEntryMode is called, LineDisplayBase class will update appropriate statistics and queue the appropriate event to the application, based on the value of the status parameter.

The PinPadBase class provides the core functionality for opening, claiming, and enabling PIN pad devices. Typically, though, service objects will want to override these methods to add their own custom processing. (An example would be to update device statistics during the Open method, or to bring the device online when the application enables it.) When overriding these methods, the service object must call the base class implementation.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.PinPad
Microsoft.PointOfService.BasicServiceObjects.PinPadBasic
Microsoft.PointOfService.BaseServiceObjects.PinPadBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PinPadBase Members

PinPadBase Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Implements all properties and methods for supporting PIN pad devices.

The following tables list the members exposed by the PinPadBase type.

Protected Constructors

Name | Description
PinPadBase | Creates an instance of the PinPadBase class.
Top

Public Fields

Name | Description
ExtendedErrorBadKey | Indicates that an encryption key is corrupted or missing. (inherited from PinPad)
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticInvalidPINEntryCount | Incremented during the ExitPinEntryMode method if PIN entry has failed. (inherited from PinPad)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatisticValidPINEntryCount | Incremented during the ExitPinEntryMode method if PIN entry has occurred successfully. (inherited from PinPad)
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
AccountNumber | Overridden. Holds the user’s account number for the current EFT transaction.
AdditionalSecurityInformation | Overridden. Holds security/encryption information, formatted as a Hex-ASCII string, after a successful PIN entry operation in which the DataEvent event is queued to the application with a DataEventArgs.Status of Success.
Amount | Overridden. Holds the amount of the current EFT transaction.
AvailableLanguagesList | Overridden. Holds an array of the languages supported by the pre-defined prompts in the PIN pad device, as defined by the CultureInfo .NET Framework Class.
AvailablePromptsList | Overridden. Holds a comma-separated string of supported values for the Prompt property.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PinPadBasic)
CapDisplay | Overridden. Indicates the operations that the application can perform on the PIN pad display.
CapKeyboard | Overridden. If set to true, the application can use the PIN pad keyboard to obtain input.
CapLanguage | Overridden. Indicates the language of pre-defined messages for the PIN pad device (for example, English, French, Arabic, and so on).
CapMacCalculation | Overridden. If set to true, the PIN pad supports MAC calculation.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PinPadBasic)
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PinPadBasic)
CapTone | Overridden. If set to true, the PIN pad has a tone indicator, which is implemented as a ToneIndicator class object.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PinPadBasic)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PinPadBasic)
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PinPadBasic)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
DataCount | Holds the number of data events currently queued by the service object. (inherited from PinPadBasic)
DataEventEnabled | When set to true by the application, the service object can deliver the next queued DataEvent event. (inherited from PinPadBasic)
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PinPadBasic)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PinPadBasic)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PinPadBasic)
EncryptedPin | Overridden. Holds the value of the encrypted PIN after the DataEvent event notifies the application that a PIN entry operation has been completed.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PinPadBasic)
MaximumPinLength | Overridden. Holds the maximum acceptable number of digits to be entered for the PIN.
MerchantId | Overridden. Holds the Merchant ID, as it is known to the EFT Transaction Host.
MinimumPinLength | Overridden. Holds the minimum acceptable number of digits to be entered for a PIN.
PinEntryEnabled | Overridden. Indicates whether the PinPad is ready to accept PIN entry.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PinPadBasic)
PowerState | Gets the current power condition. (inherited from PinPadBasic)
Prompt | Overridden. Holds a pre-defined message to be displayed on the PIN Pad.
PromptLanguage | Overridden. Specifies the language in which the message specified by the Prompt property will be displayed, as defined by the CultureInfo .NET Framework class.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PinPadBasic)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PinPadBasic)
State | Gets the current state of the device. (inherited from PinPadBasic)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
TerminalId | Overridden. Holds the Terminal ID, as it is known to the EFT Transaction Host.
Track1Data | Overridden. Holds either the decoded Track 1 data from the previous card swipe or an empty string.
Track2Data | Overridden. Holds either the decoded Track 2 data from the previous card swipe or an empty string.
Track3Data | Overridden. Holds either the decoded Track 3 data from the previous card swipe or an empty string.
Track4Data | Overridden. Holds either the decoded Track 4 data from the previous card swipe or an empty string.
TransactionType | Overridden. Holds the current EFT transaction type.
Top

Protected Properties

Name | Description
CommonProperties | (inherited from PinPadBasic )
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
ErrorCount | (inherited from PinPadBasic )
ExternallyClaimed | (inherited from PinPadBasic )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Indicates whether the PinPad is an exclusive-use device. (inherited from PinPad)
Properties | Contains getters and setters for PinPadBase and Common properties.
Top

Public Methods (see also Protected Methods )

Name | Description
BeginEftTransaction | Overridden. Informs the PIN Pad’s service object that an EFT Transaction is starting.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PinPadBasic )
ClearInput | (inherited from PinPadBasic )
ClearInputProperties | Overridden. Resets the values of properties altered by DataEvent or ErrorEvent.
Close | Releases the device and its resources. (inherited from PinPadBasic)
CompareFirmwareVersion | (inherited from PosCommon )
ComputeMac | Overridden. Tells the service object to compute a MAC value and return it to the application.
DirectIO | (inherited from PosCommon )
Dispose | Overloaded.
EnablePinEntry | Overridden. Starts PIN entry at the PIN pad device.
EndEftTransaction | Overridden. Takes the PIN pad out of EFT Transaction Mode.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Overridden. Opens a device for later input/output processing.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PinPadBasic)
ResetStatistic | (inherited from PinPadBasic )
ResetStatistics | Overloaded. (inherited from PinPadBasic )
RetrieveStatistic | (inherited from PinPadBasic )
RetrieveStatistics | Overloaded. (inherited from PinPadBasic )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateKey | Overridden. Provides a new encryption key to the PIN pad service object for those PIN Pad Management Systems in which new key values are sent to the terminal as a field in standard messages from the EFT Transaction Host.
UpdateStatistic | (inherited from PinPadBasic )
UpdateStatistics | Overloaded. (inherited from PinPadBasic )
VerifyMac | Overridden. Tells the service object to verify the MAC value in a message received from an EFT Transaction Host.
Top

Protected Methods

Name | Description
BeginEftTransactionImpl | Informs the PIN Pad’s service object that an EFT Transaction is starting.
ClearInputImpl | (inherited from PinPadBasic )
ComputeMacImpl | The PinPadBase class calls ComputeMacImpl from its ComputeMac method.
CreateStatistic | Overloaded. (inherited from PinPadBasic )
DeleteConfigurationProperty | (inherited from PosCommon )
Dispose | Overloaded. Overridden.
EnablePinEntryImpl | The PinPadBase class calls EnablePinEntryImpl from its EnablePinEntry method.
EndEftTransactionImpl | The PinPadBase class calls EndEftTransactionImpl from its EndEftTransaction method.
ExitPinEntryMode | Overloaded.
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
GetStatisticValue | (inherited from PinPadBasic )
IncrementStatistic | Overloaded. (inherited from PinPadBasic )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
PreFireEvent | Overloaded. Overridden.
QueueEvent | Overloaded. (inherited from PinPadBasic )
QueueEventAndWait | Overloaded. (inherited from PinPadBasic )
SetConfigurationProperty | (inherited from PosCommon )
SetStatisticHandlers | (inherited from PinPadBasic )
SetStatisticValue | (inherited from PinPadBasic )
UpdateKeyImpl | The PinPadBase class calls UpdateKeyImpl from its UpdateKey method.
VerifyMacImpl | The PinPadBase class calls VerifyMacImpl from its VerifyMac method.
VerifyState | (inherited from PinPadBasic )
Top

Public Events (see also Protected Events )

Name | Description
DataEvent | Raised by the service object to present input data from the PIN pad device to the application. (inherited from PinPadBasic)
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PinPadBasic)
ErrorEvent | Raised by the service object when an error is detected while trying to perform a PIN encryption function. (inherited from PinPadBasic)
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PinPadBasic)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
StateChangedEvent | (inherited from PinPadBasic )
Top

See Also

Reference

PinPadBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PinPadBase Fields

PinPadBase Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorBadKey | Indicates that an encryption key is corrupted or missing. (inherited from PinPad )
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticInvalidPINEntryCount | Incremented during the ExitPinEntryMode method if PIN entry has failed. (inherited from PinPad )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatisticValidPINEntryCount | Incremented during the ExitPinEntryMode method if PIN entry has occurred successfully. (inherited from PinPad )
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

PinPadBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PinPadBase Constructor

PinPadBase Constructor |
 | See Also

1/18/2008

Creates an instance of the PinPadBase class.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Sub New
protected PinPadBase ()
protected:
PinPadBase ()
protected PinPadBase ()
protected function PinPadBase ()

Remarks

Creates an instance of the PinPadBase class. Initializes statistics for the UPOS Version, the Device Category, and the Installation Date.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PinPadBase Methods

PinPadBase Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
BeginEftTransaction | Overridden. Informs the PIN Pad’s service object that an EFT Transaction is starting.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PinPadBasic )
ClearInput | (inherited from PinPadBasic )
ClearInputProperties | Overridden. Resets the values of properties altered by DataEvent or ErrorEvent.
Close | Releases the device and its resources. (inherited from PinPadBasic )
CompareFirmwareVersion | (inherited from PosCommon )
ComputeMac | Overridden. Tells the service object to compute a MAC value and return it to the application.
DirectIO | (inherited from PosCommon )
Dispose | Overloaded.
EnablePinEntry | Overridden. Starts PIN entry at the PIN pad device.
EndEftTransaction | Overridden. Takes the PIN pad out of EFT Transaction Mode.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Overridden. Opens a device for later input/output processing.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PinPadBasic )
ResetStatistic | (inherited from PinPadBasic )
ResetStatistics | Overloaded. (inherited from PinPadBasic )
RetrieveStatistic | (inherited from PinPadBasic )
RetrieveStatistics | Overloaded. (inherited from PinPadBasic )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateKey | Overridden. Provides a new encryption key to the PIN pad service object for those PIN Pad Management Systems in which new key values are sent to the terminal as a field in standard messages from the EFT Transaction Host.
UpdateStatistic | (inherited from PinPadBasic )
UpdateStatistics | Overloaded. (inherited from PinPadBasic )
VerifyMac | Overridden. Tells the service object to verify the MAC value in a message received from an EFT Transaction Host.

Protected Methods

Name | Description
BeginEftTransactionImpl | Informs the PIN Pad’s service object that an EFT Transaction is starting.
ClearInputImpl | (inherited from PinPadBasic )
ComputeMacImpl | The PinPadBase class calls ComputeMacImpl from its ComputeMac method.
CreateStatistic | Overloaded. (inherited from PinPadBasic )
DeleteConfigurationProperty | (inherited from PosCommon )
Dispose | Overloaded. Overridden.
EnablePinEntryImpl | The PinPadBase class calls EnablePinEntryImpl from its EnablePinEntry method.
EndEftTransactionImpl | The PinPadBase class calls EndEftTransactionImpl from its EndEftTransaction method.
ExitPinEntryMode | Overloaded.
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
GetStatisticValue | (inherited from PinPadBasic )
IncrementStatistic | Overloaded. (inherited from PinPadBasic )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
PreFireEvent | Overloaded. Overridden.
QueueEvent | Overloaded. (inherited from PinPadBasic )
QueueEventAndWait | Overloaded. (inherited from PinPadBasic )
SetConfigurationProperty | (inherited from PosCommon )
SetStatisticHandlers | (inherited from PinPadBasic )
SetStatisticValue | (inherited from PinPadBasic )
UpdateKeyImpl | The PinPadBase class calls UpdateKeyImpl from its UpdateKey method.
VerifyMacImpl | The PinPadBase class calls VerifyMacImpl from its VerifyMac method.
VerifyState | (inherited from PinPadBasic )

See Also

Reference

PinPadBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PinPadBase.BeginEftTransaction Method

PinPadBase.BeginEftTransaction Method |
 | See Also

1/18/2008

Informs the PIN Pad’s service object that an EFT Transaction is starting.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub BeginEftTransaction ( _
    pinpadSystem As PinPadSystem, _
    transactionHost As Integer _
)
public override void BeginEftTransaction (
    PinPadSystem pinpadSystem,
    int transactionHost
)
public:
virtual void BeginEftTransaction (
    PinPadSystem pinpadSystem,
    int transactionHost
) override
public void BeginEftTransaction (
    PinPadSystem pinpadSystem,
    int transactionHost
)
public override function BeginEftTransaction (
    pinpadSystem : PinPadSystem,
    transactionHost : int
)

Parameters

pinpadSystem

Name of the desired PIN Pad Management System.

transactionHost

Identifies the EFT Transaction Host to be used for this transaction.

Remarks

The PinPadBase class verifies that the application has opened, claimed, and enabled the device, checks that the device isn’t already in EFT Transaction Mode, checks the validity of the pinpadSystem parameter, and then calls the BeginEftTransactionImpl protected method. If BeginEftTransactionImpl returns successfully, the device will be placed in EFT transaction Mode.

BeginEftTransaction may cause a PosControlException to be thrown with the following ErrorCode:

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The requested PIN Pad Management System is not supported by the service object; or

  • The requested EFT Transaction Host is an illegal value for the selected PIN Pad Management System.

Busy

The PIN pad device is already performing an EFT transaction.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
BeginEftTransactionImpl
PinPad.BeginEftTransaction Method


PinPadBase.BeginEftTransactionImpl Method

PinPadBase.BeginEftTransactionImpl Method |
 | See Also

1/18/2008

Informs the PIN Pad’s service object that an EFT Transaction is starting.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected MustOverride Sub BeginEftTransactionImpl ( _
    pinpadSystem As PinPadSystem, _
    transactionHost As Integer _
)
protected abstract void BeginEftTransactionImpl (
    PinPadSystem pinpadSystem,
    int transactionHost
)
protected:
virtual void BeginEftTransactionImpl (
    PinPadSystem pinpadSystem,
    int transactionHost
) abstract
protected abstract void BeginEftTransactionImpl (
    PinPadSystem pinpadSystem,
    int transactionHost
)
protected abstract function BeginEftTransactionImpl (
    pinpadSystem : PinPadSystem,
    transactionHost : int
)

Parameters

pinpadSystem

Name of the desired PIN Pad Management System.

transactionHost

Identifies the EFT Transaction Host to be used for this transaction.

Remarks

The PinPadBase class calls BeginEftTransactionImpl from its BeginEftTransaction method. BeginEftTransactionImpl must be implemented by the service object to place the PIN pad device in EFT Transaction Mode. Before calling the BeginEftTransactionImpl, the PinPadBase class ensures that the following is true:

  • The PIN pad device has been opened, claimed, and enabled;

  • The PIN pad isn’t already performing an EFT transaction; and

  • The value specified for the pinpadSystem parameter exists in the PinPadSystem enumeration.

If these validations succeed, the PinPadBase class calls BeginEftTransactionImpl. If any of the above conditions aren’t met, the PinPadBase class throws an exception.

The service object should check to ensure the transactionHost parameter specifies a transaction host that is supported.

BeginEftTransaction may cause a PosControlException to be thrown with the following ErrorCode:

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The requested PIN Pad Management System is not supported by the service object; or

  • The requested EFT Transaction Host is an illegal value for the selected PIN Pad Management System.

Busy

The PIN pad device is already performing an EFT transaction.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.BeginEftTransaction Method
PinPad.BeginEftTransaction Method
PinPadSystem Enumeration


PinPadBase.ClearInputProperties Method

PinPadBase.ClearInputProperties Method |
 | See Also

1/18/2008

Resets the values of properties altered by DataEvent or ErrorEvent.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub ClearInputProperties
public override void ClearInputProperties ()
public:
virtual void ClearInputProperties () override
public void ClearInputProperties ()
public override function ClearInputProperties ()

Remarks

Sets all data properties populated by a firing of DataEvent or ErrorEvent back to their default values. This does not reset the DataCount or State properties.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PinPadBase.ComputeMac Method

PinPadBase.ComputeMac Method |
 | See Also

1/18/2008

Tells the service object to compute a MAC value and return it to the application.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Function ComputeMac ( _
    inMsg As String _
) As String
public override string ComputeMac (
    string inMsg
)
public:
virtual String^ ComputeMac (
    String^ inMsg
) override
public String ComputeMac (
    String inMsg
)
public override function ComputeMac (
    inMsg : String
) : String

Parameters

inMsg

Contains the message that the application intends to send to the EFT Transaction Host.

Remarks

The PinPadBase class verifies that the application has opened, claimed, and enabled the device. It may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Disabled | The application has not called the BeginEftTransaction method prior to calling ComputeMac.
Busy | The PinEntryEnabled property is set to true. The PIN pad can’t perform a MAC calculation during PIN entry.

Otherwise, PinPadBase calls the ComputeMacImpl protected method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
ComputeMacImpl
PinPad.ComputeMac Method


PinPadBase.ComputeMacImpl Method

PinPadBase.ComputeMacImpl Method |
 | See Also

1/18/2008

The PinPadBase class calls ComputeMacImpl from its ComputeMac method.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected MustOverride Function ComputeMacImpl ( _
    inMsg As String _
) As String
protected abstract string ComputeMacImpl (
    string inMsg
)
protected:
virtual String^ ComputeMacImpl (
    String^ inMsg
) abstract
protected abstract String ComputeMacImpl (
    String inMsg
)
protected abstract function ComputeMacImpl (
    inMsg : String
) : String

Parameters

inMsg

Contains the message that the application intends to send to the EFT Transaction Host.

Remarks

The PinPadBase class calls ComputeMacImpl from its ComputeMac method. ComputeMacImpl must be implemented by the service object. Before calling the ComputeMacImpl, the PinPadBase class ensures that the following is true:

  • The PIN pad has been opened, claimed, and enabled;

  • The PIN pad is in EFT Transaction Mode; and

  • The PinEntryEnabled property is set to FALSE.

If these validations succeed, the PinPadBase class calls ComputeMacImpl. If either of the above conditions aren’t met, the PinPadBase class throws an exception.

The service object should throw PosControlException exceptions when errors occur.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.ComputeMac Method
PinPadBase.ComputeMac Method
PinPad.PinEntryEnabled Property


PinPadBase.Dispose Method

PinPadBase.Dispose Method |
 | See Also

1/18/2008

Overload List

Name | Description
PinPadBase.Dispose () | (inherited from Dispose )
PinPadBase.Dispose (Boolean) |

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PinPadBase.Dispose Method (Boolean)

PinPadBase.Dispose Method (Boolean) |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

protected override void Dispose (
    bool disposing
)

protected:
virtual void Dispose (
    bool disposing
) override

protected void Dispose (
    boolean disposing
)

protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PinPadBase.EnablePinEntry Method

PinPadBase.EnablePinEntry Method |
 | See Also

1/18/2008

Starts PIN entry at the PIN pad device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub EnablePinEntry
public override void EnablePinEntry ()
public:
virtual void EnablePinEntry () override
public void EnablePinEntry ()
public override function EnablePinEntry ()

Remarks

The PinPadBase class verifies that the application has opened, claimed, and enabled the device. EnablePinEntry may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Disabled | The application has not called the BeginEftTransaction method prior to calling EnablePinEntry.
Busy | The PinEntryEnabled property was already set to true, indicating that the PIN pad device is already performing pin entry.

Otherwise, it sets the prompt message to PinPadMessage.EnterPin and calls the EnablePinEntryImpl protected method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.EnablePinEntry Method
EnablePinEntryImpl
PinPadMessage Enumeration


PinPadBase.EnablePinEntryImpl Method

PinPadBase.EnablePinEntryImpl Method |
 | See Also

1/18/2008

The PinPadBase class calls EnablePinEntryImpl from its EnablePinEntry method.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected MustOverride Sub EnablePinEntryImpl
protected abstract void EnablePinEntryImpl ()
protected:
virtual void EnablePinEntryImpl () abstract
protected abstract void EnablePinEntryImpl ()
protected abstract function EnablePinEntryImpl ()

Remarks

The PinPadBase class calls EnablePinEntryImpl from its EnablePinEntry method. EnablePinEntryImpl must be implemented by the service object to allow the user to enter a PIN. Before calling EnablePinEntryImpl, the PinPadBase class ensures that the following is true:

  • The PIN pad has been opened, claimed, and enabled;

  • The PIN pad is in EFT Transaction Mode; and

  • The PinEntryEnabled property is set to FALSE.

If any of the above conditions aren’t met, the PinPadBase class throws an exception. If the validations succeed and the CapDisplay property is set to PinPadDisplay.PinRestricted, the PinPadBase class sets the Prompt property to PinPadMessage.EnterPin and then calls EnablePinEntryImpl.

The service object should throw PosControlException exceptions when errors occur.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.EnablePinEntry Method
PinPadBase.EnablePinEntry Method
PinPadDisplay Enumeration
PinPadMessage Enumeration


PinPadBase.EndEftTransaction Method

PinPadBase.EndEftTransaction Method |
 | See Also

1/18/2008

Takes the PIN pad out of EFT Transaction Mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub EndEftTransaction ( _
    completionCode As EftTransactionCompletion _
)
public override void EndEftTransaction (
    EftTransactionCompletion completionCode
)
public:
virtual void EndEftTransaction (
    EftTransactionCompletion completionCode
) override
public void EndEftTransaction (
    EftTransactionCompletion completionCode
)
public override function EndEftTransaction (
    completionCode : EftTransactionCompletion
)

Parameters

completionCode

The transaction completion code.

Valid values for the completionCode are defined by the EftTransactionCompletion enumeration.

Remarks

The service object will perform termination functions (for example, computing next transaction keys). PinPadBase class verifies that the application has opened, claimed, and enabled the device. EndEftTransaction may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Disabled | The application has not called the BeginEftTransaction method prior to calling EndEftTransaction.
Illegal | The value specified for the completionCode parameter doesn’t exist in the EftTransactionCompletion enumerator.

Otherwise, it calls the EndEftTransactionImpl protected method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
EndEftTransactionImpl
PinPad.EndEftTransaction Method
EftTransactionCompletion Enumeration


PinPadBase.EndEftTransactionImpl Method

PinPadBase.EndEftTransactionImpl Method |
 | See Also

1/18/2008

The PinPadBase class calls EndEftTransactionImpl from its EndEftTransaction method.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected MustOverride Sub EndEftTransactionImpl ( _
    completionCode As EftTransactionCompletion _
)
protected abstract void EndEftTransactionImpl (
    EftTransactionCompletion completionCode
)
protected:
virtual void EndEftTransactionImpl (
    EftTransactionCompletion completionCode
) abstract
protected abstract void EndEftTransactionImpl (
    EftTransactionCompletion completionCode
)
protected abstract function EndEftTransactionImpl (
    completionCode : EftTransactionCompletion
)

Parameters

completionCode

The transaction completion code.

Valid values for the completionCode are defined by the EftTransactionCompletion enumeration.

Remarks

The PinPadBase class calls EndEftTransactionImpl from its EndEftTransaction method. EndEftTransactionImpl must be implemented by the service object to take the PIN pad device out of EFT Transaction Mode. Before calling the EndEftTransactionImpl, the PinPadBase class ensures that the following is true:

  • The PIN pad has been opened, claimed, and enabled;

  • The BeginEftTransaction method has been called and the device is in EFT Transaction Mode; and

  • The completionCode parameter contains a valid value.

If these validations succeed, the PinPadBase class calls EndEftTransactionImpl. If any of the above conditions aren’t met, the PinPadBase class throws an exception.

The service object should throw PosControlException exceptions when errors occur.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.EndEftTransaction Method
PinPadBase.EndEftTransaction Method


PinPadBase.ExitPinEntryMode Method

PinPadBase.ExitPinEntryMode Method |
 | See Also

1/18/2008

Overload List

Name | Description
PinPadBase.ExitPinEntryMode (ErrorCode, Int32) |
PinPadBase.ExitPinEntryMode (PinEntryStatus, String, String) | Called by the service object to exit PIN entry mode.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PinPadBase.ExitPinEntryMode Method (ErrorCode, Int32)

PinPadBase.ExitPinEntryMode Method (ErrorCode, Int32) |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Sub ExitPinEntryMode ( _
    errorCode As ErrorCode, _
    extendedErrorCode As Integer _
)

protected void ExitPinEntryMode (
    ErrorCode errorCode,
    int extendedErrorCode
)

protected:
void ExitPinEntryMode (
    ErrorCode errorCode,
    int extendedErrorCode
)

protected void ExitPinEntryMode (
    ErrorCode errorCode,
    int extendedErrorCode
)

protected function ExitPinEntryMode (
    errorCode : ErrorCode,
    extendedErrorCode : int
)

Parameters

errorCode
extendedErrorCode

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PinPadBase.ExitPinEntryMode Method (PinEntryStatus, String, String)

PinPadBase.ExitPinEntryMode Method (PinEntryStatus, String, String) |
 | See Also

1/18/2008

Called by the service object to exit PIN entry mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Sub ExitPinEntryMode ( _
    status As PinEntryStatus, _
    encryptedPin As String, _
    additionalSecurityInformation As String _
)
protected void ExitPinEntryMode (
    PinEntryStatus status,
    string encryptedPin,
    string additionalSecurityInformation
)
protected:
void ExitPinEntryMode (
    PinEntryStatus status,
    String^ encryptedPin,
    String^ additionalSecurityInformation
)
protected void ExitPinEntryMode (
    PinEntryStatus status,
    String encryptedPin,
    String additionalSecurityInformation
)
protected function ExitPinEntryMode (
    status : PinEntryStatus,
    encryptedPin : String,
    additionalSecurityInformation : String
)

Parameters

status

Contains the current status of PIN entry. Possible values are defined by the PinEntryStatus enumerator.

encryptedPin

If status is set to Success, encryptedPin should contain the encrypted data for the PIN that has been entered; otherwise, it should be set to null.

additionalSecurityInformation

If status is set to Success, additionalSecurityInformation should contain any pertinent additional security information; otherwise, it should be set to null.

Remarks

Called by the service object to exit PIN entry mode. Calling ExitPinEntryMode causes the PinPadBase class to queue either a DataEvent event or an ErrorEvent event, depending on the value of the status parameter.

  • If status is set to PinEntryStatus.Success, the PinPadBase class increments the StatisticValidPINEntryCount statistic and queues a DataEvent event containing the encrypted PIN and the any additional security information;

  • If status is set to PinEntryStatus.Cancel, the PinPadBase class queues a DataEvent event indicating the cancellation;

  • If status is set to PinEntryStatus.Timeout, the PinPadBase class queues a DataEvent event indicating the timeout;

  • If status is set to PinEntryStatus.BadKey, the PinPadBase class queues an ErrorEvent event and increments the StatisticInvalidPINEntryCount statistic.

The PinPadBase class sets the PinEntryEnabled property to false.

ExitPinEntryMode may throw a PosControlException with the following value:

Value | Meaning
Illegal | The status parameter doesn’t match any of the values listed above.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PinPadBase.Open Method

PinPadBase.Open Method |
 | See Also

1/18/2008

Opens a device for later input/output processing.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub Open
public override void Open ()
public:
virtual void Open () override
public void Open ()
public override function Open ()

Remarks

Open initializes statistics reporting and event threads for the specified device. Open also initializes the values of many properties. This includes the DataEventEnabled, FreezeEvents, AutoDisable, Claimed properties and more. For specifics about how these properties are initialized, see the individual properties.

Open may throw a PosControlException with the following values:

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The device is already opened; or

  • The DeviceName property is null or an empty string ("").

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosCommon.Close Method


PinPadBase.PreFireEvent Method

PinPadBase.PreFireEvent Method |
 | See Also

1/18/2008

Overload List

Name | Description
PinPadBase.PreFireEvent (DataEventArgs) | Called prior to the delivery of a DataEvent event to the application.
PinPadBase.PreFireEvent (DeviceErrorEventArgs) | (inherited from PreFireEvent )
PinPadBase.PreFireEvent (DirectIOEventArgs) | (inherited from PreFireEvent )
PinPadBase.PreFireEvent (StatusUpdateEventArgs) | (inherited from PreFireEvent )

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.DataEvent Event
PinPad.EncryptedPin Property
PinPad.AdditionalSecurityInformation Property


PinPadBase.PreFireEvent Method (DataEventArgs)

PinPadBase.PreFireEvent Method (DataEventArgs) |
 | See Also

1/18/2008

Called prior to the delivery of a DataEvent event to the application.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overrides Sub PreFireEvent ( _
    posEvent As DataEventArgs _
)
protected override void PreFireEvent (
    DataEventArgs posEvent
)
protected:
virtual void PreFireEvent (
    DataEventArgs^ posEvent
) override
protected void PreFireEvent (
    DataEventArgs posEvent
)
protected override function PreFireEvent (
    posEvent : DataEventArgs
)

Parameters

posEvent

An instance of the DataEventArgs class, posEvent contains the event that was queued to the application.

Remarks

Called prior to the delivery of a DataEvent event to the application. When PreFireEvent is called, the PinPadBase class implementation updates the values of the PinPadBase.EncryptedPin and PinPadBase.AdditionalSecurityInformation. If the DataEventArgs.Status property is set to PinEntryStatus.Cancel, PinPadBase class sets EncryptedPin and AdditionalSecurityInformation to blank.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.DataEvent Event
PinPad.EncryptedPin Property
PinPad.AdditionalSecurityInformation Property


PinPadBase.UpdateKey Method

PinPadBase.UpdateKey Method |
 | See Also

1/18/2008

Provides a new encryption key to the PIN pad service object for those PIN Pad Management Systems in which new key values are sent to the terminal as a field in standard messages from the EFT Transaction Host.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub UpdateKey ( _
    keyNumber As Integer, _
    key As String _
)
public override void UpdateKey (
    int keyNumber,
    string key
)
public:
virtual void UpdateKey (
    int keyNumber,
    String^ key
) override
public void UpdateKey (
    int keyNumber,
    String key
)
public override function UpdateKey (
    keyNumber : int,
    key : String
)

Parameters

keyNumber

Contains a key number.

key

Contains a Hex-ASCII value for a new key.

Remarks

The PinPadBase class verifies that the application has opened, claimed, and enabled the device. UpdateKey may cause a PosControlException to be thrown with the following ErrorCode:

Value

Meaning

Disabled

The application has not called the BeginEftTransaction method prior to calling EndEftTransaction.

Illegal

One of the following conditions occurred:

  • The selected PIN Pad Management System does not support UpdateKey;

  • The keyNumber parameter specifies an unacceptable key number; or

  • The key parameter contains a bad key (not Hex-ASCII or wrong length or bad parity).

Otherwise, it calls the UpdateKeyImpl protected method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
UpdateKeyImpl
PinPad.UpdateKey Method


PinPadBase.UpdateKeyImpl Method

PinPadBase.UpdateKeyImpl Method |
 | See Also

1/18/2008

The PinPadBase class calls UpdateKeyImpl from its UpdateKey method.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected MustOverride Sub UpdateKeyImpl ( _
    keyNumber As Integer, _
    key As String _
)
protected abstract void UpdateKeyImpl (
    int keyNumber,
    string key
)
protected:
virtual void UpdateKeyImpl (
    int keyNumber,
    String^ key
) abstract
protected abstract void UpdateKeyImpl (
    int keyNumber,
    String key
)
protected abstract function UpdateKeyImpl (
    keyNumber : int,
    key : String
)

Parameters

keyNumber

Contains a key number.

key

Contains a Hex-ASCII value for a new key.

Remarks

The PinPadBase class calls UpdateKeyImpl from its UpdateKey method. UpdateKeyImpl must be implemented by the service object. Before calling the UpdateKeyImpl, the PinPadBase class ensures that the following is true:

  • The PIN pad has been opened, claimed, and enabled; and

  • The BeginEftTransaction method has been called and the device is in EFT Transaction Mode.

If these validations succeed, the PinPadBase class calls UpdateKeyImpl. If any of the above conditions aren’t met, the PinPadBase class throws an exception.

If either of the parameter values is invalid, or if the currently selected PIN Pad Management system doesn’t support the UpdateKey method, the service object should return the appropriate exception to the PinPadBase class.

The service object should throw PosControlException exceptions when errors occur.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.UpdateKey Method
PinPadBase.UpdateKey Method


PinPadBase.VerifyMac Method

PinPadBase.VerifyMac Method |
 | See Also

1/18/2008

Tells the service object to verify the MAC value in a message received from an EFT Transaction Host.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub VerifyMac ( _
    message As String _
)
public override void VerifyMac (
    string message
)
public:
virtual void VerifyMac (
    String^ message
) override
public void VerifyMac (
    String message
)
public override function VerifyMac (
    message : String
)

Parameters

message

The message parameter contains a message received from an EFT Transaction Host.

Remarks

PinPadBase class verifies that the application has opened, claimed, and enabled the device. VerifyMac may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Disabled | The application has not called the BeginEftTransaction method.
Illegal | The PinEntryEnabled property is set to true; the PIN pad can’t perform a MAC verification during PIN entry.

Otherwise, it calls the VerifyMacImpl protected method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.VerifyMac Method
VerifyMacImpl


PinPadBase.VerifyMacImpl Method

PinPadBase.VerifyMacImpl Method |
 | See Also

1/18/2008

The PinPadBase class calls VerifyMacImpl from its VerifyMac method.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected MustOverride Sub VerifyMacImpl ( _
    message As String _
)
protected abstract void VerifyMacImpl (
    string message
)
protected:
virtual void VerifyMacImpl (
    String^ message
) abstract
protected abstract void VerifyMacImpl (
    String message
)
protected abstract function VerifyMacImpl (
    message : String
)

Parameters

message

The message parameter contains a message received from an EFT Transaction Host.

Remarks

The PinPadBase class calls VerifyMacImpl from its VerifyMac method. VerifyMacImpl must be implemented by the service object. Before calling the VerifyMacImpl, the PinPadBase class ensures that the following is true:

  • The PIN pad has been opened, claimed, and enabled; and

  • The PIN pad device is in EFT Transaction Mode; and

  • The PinEntryEnabled property is set to false.

If these validations succeed, the PinPadBase class calls VerifyMacImpl. If either of the above conditions aren’t met, the PinPadBase class throws an exception.

The service object should throw PosControlException exceptions when errors occur.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.VerifyMac Method
PinPadBase.VerifyMac Method


PinPadBase Properties

PinPadBase Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
AccountNumber | Overridden. Holds the user’s account number for the current EFT transaction.
AdditionalSecurityInformation | Overridden. Holds security/encryption information, formatted as a Hex-ASCII string, after a successful PIN entry operation in which the DataEvent event is queued to the application with a DataEventArgs.Status of Success.
Amount | Overridden. Holds the amount of the current EFT transaction.
AvailableLanguagesList | Overridden. Holds an array of the languages supported by the pre-defined prompts in the PIN pad device, as defined by the CultureInfo .NET Framework Class.
AvailablePromptsList | Overridden. Holds a comma-separated string of supported values for the Prompt property.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PinPadBasic )
CapDisplay | Overridden. Indicates the operations that the application can perform on the PIN pad display.
CapKeyboard | Overridden. If set to true, the application can use the PIN pad keyboard to obtain input.
CapLanguage | Overridden. Indicates the language of pre-defined messages for the PIN pad device (for example, English, French, Arabic, and so on).
CapMacCalculation | Overridden. If set to true, the PIN pad supports MAC calculation.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PinPadBasic )
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PinPadBasic )
CapTone | Overridden. If set to true, the PIN pad has a tone indicator, which is implemented as a ToneIndicator class object.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PinPadBasic )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PinPadBasic )
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PinPadBasic )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
DataCount | Holds the number of data events currently queued by the service object. (inherited from PinPadBasic )
DataEventEnabled | When set to true by the application, the service object can deliver the next queued DataEvent event. (inherited from PinPadBasic )
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PinPadBasic )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PinPadBasic )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PinPadBasic )
EncryptedPin | Overridden. Holds the value of the encrypted PIN after the DataEvent event notifies the application that a PIN entry operation has been completed.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PinPadBasic )
MaximumPinLength | Overridden. Holds the maximum acceptable number of digits to be entered for the PIN.
MerchantId | Overridden. Holds the Merchant ID, as it is known to the EFT Transaction Host.
MinimumPinLength | Overridden. Holds the minimum acceptable number of digits to be entered for a PIN.
PinEntryEnabled | Overridden. Indicates whether the PinPad is ready to accept PIN entry.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PinPadBasic )
PowerState | Gets the current power condition. (inherited from PinPadBasic )
Prompt | Overridden. Holds a pre-defined message to be displayed on the PIN Pad.
PromptLanguage | Overridden. Specifies the language in which the message specified by the Prompt property will be displayed, as defined by the CultureInfo .NET Framework class.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PinPadBasic )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PinPadBasic )
State | Gets the current state of the device. (inherited from PinPadBasic )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )
TerminalId | Overridden. Holds the Terminal ID, as it is known to the EFT Transaction Host.
Track1Data | Overridden. Holds either the decoded Track 1 data from the previous card swipe or an empty string.
Track2Data | Overridden. Holds either the decoded Track 2 data from the previous card swipe or an empty string.
Track3Data | Overridden. Holds either the decoded Track 3 data from the previous card swipe or an empty string.
Track4Data | Overridden. Holds either the decoded Track 4 data from the previous card swipe or an empty string.
TransactionType | Overridden. Holds the current EFT transaction type.

Protected Properties

Name | Description
CommonProperties | (inherited from PinPadBasic )
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
ErrorCount | (inherited from PinPadBasic )
ExternallyClaimed | (inherited from PinPadBasic )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Indicates whether the PinPad is an exclusive-use device. (inherited from PinPad )
Properties | Contains getters and setters for PinPadBase and Common properties.

See Also

Reference

PinPadBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PinPadBase.AccountNumber Property

PinPadBase.AccountNumber Property |
 | See Also

1/18/2008

Holds the user’s account number for the current EFT transaction.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property AccountNumber As String
public override string AccountNumber { get; set; }
public:
virtual property String^ AccountNumber {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_AccountNumber ()

/** @property */
public void set_AccountNumber (String value)

public override function get AccountNumber () : String

public override function set AccountNumber (value : String)

Remarks

The PinPadBase class verifies that the PIN pad device has been opened, then retrieves or sets the value of PinPadProperties.AccountNumber. If an attempt is made to set AccountNumber after an EFT transaction has been started, the PinPadProperties class may throw a PosControlException with the following ErrorCode:

Value | Meaning
Illegal | The BeginEftTransaction method was called before the attempt to set this property; AccountNumber can’t be changed while in EFT Transaction Mode.

AccountNumber is initialized to blank by the PinPadProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.AccountNumber Property


PinPadBase.AdditionalSecurityInformation Property

PinPadBase.AdditionalSecurityInformation Property |
 | See Also

1/18/2008

Holds security/encryption information, formatted as a Hex-ASCII string, after a successful PIN entry operation in which the DataEvent event is queued to the application with a DataEventArgs.Status of Success.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property AdditionalSecurityInformation As String
public override string AdditionalSecurityInformation { get; }
public:
virtual property String^ AdditionalSecurityInformation {
    String^ get () override;
}
/** @property */
public String get_AdditionalSecurityInformation ()

public override function get AdditionalSecurityInformation () : String

Remarks

The content and internal format of this string will vary depending on the PIN Pad Management System being used. For example, for DUKPT-based key encryption, AdditionalSecurityInformation contains the PIN pad sequence number. If the user cancels the PIN entry operation, resulting in the DataEvent event DataEventArgs.Status property set to Cancel, AdditionalSecurityInformation will contain an empty string.

The PinPadBase class verifies that the PIN pad device has been opened, then retrieves the value of PinPadProperties.AdditionalSecurityInformation.

AdditionalSecurityInformation is initialized to blank by the PinPadProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.AdditionalSecurityInformation Property


PinPadBase.Amount Property

PinPadBase.Amount Property |
 | See Also

1/18/2008

Holds the amount of the current EFT transaction.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property Amount As Decimal
public override decimal Amount { get; set; }
public:
virtual property Decimal Amount {
    Decimal get () override;
    void set (Decimal value) override;
}
/** @property */
public Decimal get_Amount ()

/** @property */
public void set_Amount (Decimal value)

public override function get Amount () : decimal

public override function set Amount (value : decimal)

Remarks

The PinPadBase class verifies that the PIN pad device has been opened, then retrieves or sets the value of PinPadProperties.Amount.

Accessing Amount may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The BeginEftTransaction method was called before setting this property: Amount can’t be changed while in EFT Transaction Mode.

Amount is initialized to 0 (zero) by the PinPadProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.Amount Property


PinPadBase.AvailableLanguagesList Property

PinPadBase.AvailableLanguagesList Property |
 | See Also

1/18/2008

Holds an array of the languages supported by the pre-defined prompts in the PIN pad device, as defined by the CultureInfo .NET Framework Class.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property AvailableLanguagesList As CultureInfo()
public override CultureInfo[] AvailableLanguagesList { get; }
public:
virtual property array<CultureInfo^>^ AvailableLanguagesList {
    array<CultureInfo^>^ get () override;
}
/** @property */
public CultureInfo[] get_AvailableLanguagesList ()

public override function get AvailableLanguagesList () : CultureInfo[]

Remarks

Languages are represented by numeric values and are Microsoft Windows Language IDs, defined in the .NET Framework Class Library documentation.

The PinPadBase class verifies that the PIN pad device has been opened, then retrieves the value of PinPadProperties.AvailableLanguagesList.

AvailableLanguagesList is initialized to an empty CultureInfo array by the PinPadProperties class. If the service object sets AvailableLanguagesList to Null, if the CapLanguage property is set to PinPadLanguage.None, or if the value represents a culture that isn’t allowed, PinPadProperties class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.AvailableLanguagesList Property
PinPad.CapLanguage Property


PinPadBase.AvailablePromptsList Property

PinPadBase.AvailablePromptsList Property |
 | See Also

1/18/2008

Holds a comma-separated string of supported values for the Prompt property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property AvailablePromptsList As PinPadMessage()
public override PinPadMessage[] AvailablePromptsList { get; }
public:
virtual property array<PinPadMessage>^ AvailablePromptsList {
    array<PinPadMessage>^ get () override;
}
/** @property */
public PinPadMessage[] get_AvailablePromptsList ()

public override function get AvailablePromptsList () : PinPadMessage[]

Remarks

Possible values are defined by the PinPadMessage enumeration.

The PinPadBase class verifies that the PIN pad device has been opened, then retrieves the value of PinPadProperties.AvailablePromptsList.

AvailablePromptsList is initialized to an empty PinPadMessage array by the PinPadProperties class. If the service object attempts to set AvailablePromptsList to Null, the PinPadProperties class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.AvailablePromptsList Property
PinPadMessage Enumeration


PinPadBase.CapDisplay Property

PinPadBase.CapDisplay Property |
 | See Also

1/18/2008

Indicates the operations that the application can perform on the PIN pad display.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapDisplay As PinPadDisplay
public override PinPadDisplay CapDisplay { get; }
public:
virtual property PinPadDisplay CapDisplay {
    PinPadDisplay get () override;
}
/** @property */
public PinPadDisplay get_CapDisplay ()

public override function get CapDisplay () : PinPadDisplay

Remarks

Possible values are defined by the PinPadDisplay enumeration. Values are:

Value | Meaning
Unrestricted | The application can use the PIN pad’s display in an unrestricted manner to display messages. The associated LineDisplay Class is the interface to the PIN pad’s display; the application must call LineDisplay methods to manipulate the display.
PinRestricted | The application can use the PIN pad’s display in an unrestricted manner except during PIN entry. The PIN pad will display a pre-defined message during PIN entry. If the application attempts to use the associated line display while PIN entry is enabled, the line display’s service object will set the ErrorCode property to Busy.
RestrictedList | The application cannot specify the text of messages to display; it can only select from a list of pre-defined messages. There is no associated line display object.
RestrictedOrder | The application cannot specify the text of messages to display; it can only select from a list of pre-defined messages. The selections must occur in a pre-defined order. There is no associated line display object.
None | The PIN pad device in use does not have a display.

The PinPadBase class verifies that the PIN pad device has been opened, then retrieves the value of PinPadProperties.CapDisplay.

CapDisplay is initialized to PinPadDisplay.None by the PinPadProperties class. The service object should then update CapDisplay in its Open method, based on the capability of the device. If the service object sets CapDisplay to an invalid PinPadDisplay value, the PinPadProperties class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.CapDisplay Property
PinPadDisplay Enumeration


PinPadBase.CapKeyboard Property

PinPadBase.CapKeyboard Property |
 | See Also

1/18/2008

If set to true, the application can use the PIN pad keyboard to obtain input.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapKeyboard As Boolean
public override bool CapKeyboard { get; }
public:
virtual property bool CapKeyboard {
    bool get () override;
}
/** @property */
public boolean get_CapKeyboard ()

public override function get CapKeyboard () : boolean

Remarks

The PinPadBase class verifies that the PIN pad device has been opened, then retrieves the value of PinPadProperties.CapKeyboard.

CapKeyboard is initialized to false by the PinPadProperties class. The service object should then update CapKeyboard in its Open method, based on the capability of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.CapKeyboard Property


PinPadBase.CapLanguage Property

PinPadBase.CapLanguage Property |
 | See Also

1/18/2008

Indicates the language of pre-defined messages for the PIN pad device (for example, English, French, Arabic, and so on).

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapLanguage As PinPadLanguage
public override PinPadLanguage CapLanguage { get; }
public:
virtual property PinPadLanguage CapLanguage {
    PinPadLanguage get () override;
}
/** @property */
public PinPadLanguage get_CapLanguage ()

public override function get CapLanguage () : PinPadLanguage

Remarks

Possible values are defined by the PinPadLanguage enumeration. Values are:

Value | Meaning
None | The PIN pad supports no pre-defined prompt messages. CapLanguage will be set to this value if the CapDisplay property is set to PinPadDisplay.RestrictedOrder. If the application tries to set the value of the PromptLanguage property, the service object sets the ErrorCode property to Illegal.
One | The PIN pad supports pre-defined prompt messages in one language. If the application tries to set the value of the PromptLanguage property, the service object will set the ErrorCode property to Illegal.
PinRestricted | The PIN pad cannot change prompt languages during PIN entry. The application must set the PromptLanguage property to the desired value before calling the EnablePinEntry method. Attempting to set the value of the PromptLanguage while the PinEntryEnabled property is set to true will cause the service object to set the ErrorCode property to Busy.
Unrestricted | The application can change the language of pre-defined prompt messages at any time, and the currently displayed message will change immediately.

CapLanguage is set by the service object, based on the capability of the device.

The PinPadBase class verifies that the PIN pad device has been opened, then retrieves the value of PinPadProperties.CapLanguage.

CapLanguage is initialized to PinPadLanguage.None by the PinPadProperties class. The service object should then update CapLanguage in its Open method, based on the capability of the device. If the service object sets CapLanguage to an invalid PinPadLanguage value, the PinPadProperties class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.CapLanguage Property
PinPadLanguage Enumeration


PinPadBase.CapMacCalculation Property

PinPadBase.CapMacCalculation Property |
 | See Also

1/18/2008

If set to true, the PIN pad supports MAC calculation.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapMacCalculation As Boolean
public override bool CapMacCalculation { get; }
public:
virtual property bool CapMacCalculation {
    bool get () override;
}
/** @property */
public boolean get_CapMacCalculation ()

public override function get CapMacCalculation () : boolean

Remarks

The PinPadBase class verifies that the PIN pad device has been opened, then retrieves the value of PinPadProperties.CapMacCalculation.

CapMacCalculation is initialized to false by the PinPadProperties class. The service object should then update CapMacCalculation in its Open method, based on the capability of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.CapMacCalculation Property


PinPadBase.CapTone Property

PinPadBase.CapTone Property |
 | See Also

1/18/2008

If set to true, the PIN pad has a tone indicator, which is implemented as a ToneIndicator class object.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapTone As Boolean
public override bool CapTone { get; }
public:
virtual property bool CapTone {
    bool get () override;
}
/** @property */
public boolean get_CapTone ()

public override function get CapTone () : boolean

Remarks

The PinPadBase class verifies that the PIN pad device has been opened, then retrieves the value of PinPadProperties.CapTone.

CapTone is initialized to false by the PinPadProperties class. The service object should then update CapTone in its Open method, based on the capability of the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.CapTone Property


PinPadBase.EncryptedPin Property

PinPadBase.EncryptedPin Property |
 | See Also

1/18/2008

Holds the value of the encrypted PIN after the DataEvent event notifies the application that a PIN entry operation has been completed.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property EncryptedPin As String
public override string EncryptedPin { get; }
public:
virtual property String^ EncryptedPin {
    String^ get () override;
}
/** @property */
public String get_EncryptedPin ()

public override function get EncryptedPin () : String

Remarks

The PinPadBase class verifies that the PIN pad device has been opened, then retrieves the value of PinPadProperties.EncryptedPin.

EncryptedPin is initialized to blank by the PinPadProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.EncryptedPin Property


PinPadBase.MaximumPinLength Property

PinPadBase.MaximumPinLength Property |
 | See Also

1/18/2008

Holds the maximum acceptable number of digits to be entered for the PIN.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property MaximumPinLength As Integer
public override int MaximumPinLength { get; set; }
public:
virtual property int MaximumPinLength {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_MaximumPinLength ()

/** @property */
public void set_MaximumPinLength (int value)

public override function get MaximumPinLength () : int

public override function set MaximumPinLength (value : int)

Remarks

The PinPadBase class verifies that the PIN pad device has been opened, then retrieves or sets the value of PinPadProperties.MaximumPinLength. If an attempt is made to set MaximumPinLength while PIN entry is enabled, the PinPadProperties class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal. If an attempt is made to set MaximumPinLength to a value less than zero or less than the value of the MinimumPinLength property, the PinPadProperties class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal.

MaximumPinLength is initialized to 0 (zero) by the PinPadProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.MaximumPinLength Property
PinPad.PinEntryEnabled Property
PinPad.MinimumPinLength Property


PinPadBase.MerchantId Property

PinPadBase.MerchantId Property |
 | See Also

1/18/2008

Holds the Merchant ID, as it is known to the EFT Transaction Host.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property MerchantId As String
public override string MerchantId { get; set; }
public:
virtual property String^ MerchantId {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_MerchantId ()

/** @property */
public void set_MerchantId (String value)

public override function get MerchantId () : String

public override function set MerchantId (value : String)

Remarks

The PinPadBase class verifies that the PIN pad device has been opened, then retrieves or sets the value of PinPadProperties.MerchantId.

MerchantId is initialized to blank by the PinPadProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.MerchantId Property


PinPadBase.MinimumPinLength Property

PinPadBase.MinimumPinLength Property |
 | See Also

1/18/2008

Holds the minimum acceptable number of digits to be entered for a PIN.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property MinimumPinLength As Integer
public override int MinimumPinLength { get; set; }
public:
virtual property int MinimumPinLength {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_MinimumPinLength ()

/** @property */
public void set_MinimumPinLength (int value)

public override function get MinimumPinLength () : int

public override function set MinimumPinLength (value : int)

Remarks

The PinPadBase class verifies that the PIN pad device has been opened, then retrieves or sets the value of PinPadProperties.MinimumPinLength. If an attempt is made to set MinimumPinLength while PIN entry is enabled, the PinPadProperties class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal. If an attempt is made to set MinimumPinLength to a value less than zero or less than the value of the MaximumPinLength property, the PinPadProperties class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal.

MinimumPinLength is initialized to 0 (zero) by the PinPadBase class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.MinimumPinLength Property
PinPad.PinEntryEnabled Property
PinPad.MaximumPinLength Property


PinPadBase.PinEntryEnabled Property

PinPadBase.PinEntryEnabled Property |
 | See Also

1/18/2008

Indicates whether the PinPad is ready to accept PIN entry.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property PinEntryEnabled As Boolean
public override bool PinEntryEnabled { get; }
public:
virtual property bool PinEntryEnabled {
    bool get () override;
}
/** @property */
public boolean get_PinEntryEnabled ()

public override function get PinEntryEnabled () : boolean

Remarks

The PinPadBase class verifies that the PIN pad device has been opened, then retrieves the value of PinPadProperties.PinEntryEnabled.

PinEntryEnabled is initialized to 0 (zero) by the PinPadProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.PinEntryEnabled Property


PinPadBase.Prompt Property

PinPadBase.Prompt Property |
 | See Also

1/18/2008

Holds a pre-defined message to be displayed on the PIN Pad.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property Prompt As PinPadMessage
public override PinPadMessage Prompt { get; set; }
public:
virtual property PinPadMessage Prompt {
    PinPadMessage get () override;
    void set (PinPadMessage value) override;
}
/** @property */
public PinPadMessage get_Prompt ()

/** @property */
public void set_Prompt (PinPadMessage value)

public override function get Prompt () : PinPadMessage

public override function set Prompt (value : PinPadMessage)

Remarks

The PinPadBase class verifies that the PIN pad device has been opened, then retrieves the value of PinPadProperties.Prompt. If an attempt is made to set Prompt to a value not in the AvailablePromptsList property, the PinPadProperties class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal.

Prompt is initialized to 0 (zero) by the PinPadProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.Prompt Property
PinPad.AvailablePromptsList Property


PinPadBase.PromptLanguage Property

PinPadBase.PromptLanguage Property |
 | See Also

1/18/2008

Specifies the language in which the message specified by the Prompt property will be displayed, as defined by the CultureInfo .NET Framework class.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property PromptLanguage As CultureInfo
public override CultureInfo PromptLanguage { get; set; }
public:
virtual property CultureInfo^ PromptLanguage {
    CultureInfo^ get () override;
    void set (CultureInfo^ value) override;
}
/** @property */
public CultureInfo get_PromptLanguage ()

/** @property */
public void set_PromptLanguage (CultureInfo value)

public override function get PromptLanguage () : CultureInfo

public override function set PromptLanguage (value : CultureInfo)

Remarks

The PinPadBase class verifies that the PIN pad device has been opened, then retrieves or sets the value of PinPadProperties.PromptLanguage. If an attempt is made to set PromptLanguage and the CapLanguage property is set to PinPadLanguage.None, the PinPadProperties class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal.

Accessing PromptLanguage may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Busy | The CapLanguage property is set to PinPadLanguage.PinRestricted and the PinEntryProperty is set to true; PIN entry is currently enabled.
Illegal | One of the following conditions occurred:The application tried to set PromptLanguage to a value that doesn’t exist in the AvailableLanguagesList property; orOnly one language is supported, and it is not the language specified.

PromptLanguage is initialized to CultureInfo.CurrentCulture by the PinPadProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.PromptLanguage Property
PinPadLanguage Enumeration
PinPad.CapLanguage Property
PinPad.AvailableLanguagesList Property


PinPadBase.Properties Property

PinPadBase.Properties Property |
 | See Also

1/18/2008

Contains getters and setters for PinPadBase and Common properties.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected ReadOnly Property Properties As PinPadProperties
protected PinPadProperties Properties { get; }
protected:
property PinPadProperties^ Properties {
    PinPadProperties^ get ();
}
/** @property */
protected PinPadProperties get_Properties ()

protected function get Properties () : PinPadProperties

Remarks

Returns an instance of the PinPadProperties helper class, containing getters and setters for PinPad and Common properties. Service objects should use PinPadProperties class to set properties that are typically designated read-only for applications. The device doesn't have to be opened, claimed, or enabled to set PinPadProperties class properties.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PinPadBase.TerminalId Property

PinPadBase.TerminalId Property |
 | See Also

1/18/2008

Holds the Terminal ID, as it is known to the EFT Transaction Host.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property TerminalId As String
public override string TerminalId { get; set; }
public:
virtual property String^ TerminalId {
    String^ get () override;
    void set (String^ value) override;
}
/** @property */
public String get_TerminalId ()

/** @property */
public void set_TerminalId (String value)

public override function get TerminalId () : String

public override function set TerminalId (value : String)

Remarks

The PinPadBase class verifies that the PIN pad device has been opened, then retrieves or sets the value of PinPadProperties.TerminalId. If an attempt is made to set TerminalId while PIN entry is enabled, the PinPadProperties class throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal.

TerminalId is initialized to blank by the PinPadProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.TerminalId Property


PinPadBase.Track1Data Property

PinPadBase.Track1Data Property |
 | See Also

1/18/2008

Holds either the decoded Track 1 data from the previous card swipe or an empty string.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property Track1Data As Byte()
public override byte[] Track1Data { get; set; }
public:
virtual property array<unsigned char>^ Track1Data {
    array<unsigned char>^ get () override;
    void set (array<unsigned char>^ value) override;
}
/** @property */
public byte[] get_Track1Data ()

/** @property */
public void set_Track1Data (byte[] value)

public override function get Track1Data () : byte[]

public override function set Track1Data (value : byte[])

Remarks

The PinPadBase class verifies that the PIN pad device has been opened, then retrieves or sets the value of PinPadProperties.Track1Data. Accessing Track1Data may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The application has called the BeginEftTransaction method-- Track1Data can’t be set while the device is in EFT Transaction Mode.

Track1Data is initialized to an empty byte array by the PinPadProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.Track1Data Property


PinPadBase.Track2Data Property

PinPadBase.Track2Data Property |
 | See Also

1/18/2008

Holds either the decoded Track 2 data from the previous card swipe or an empty string.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property Track2Data As Byte()
public override byte[] Track2Data { get; set; }
public:
virtual property array<unsigned char>^ Track2Data {
    array<unsigned char>^ get () override;
    void set (array<unsigned char>^ value) override;
}
/** @property */
public byte[] get_Track2Data ()

/** @property */
public void set_Track2Data (byte[] value)

public override function get Track2Data () : byte[]

public override function set Track2Data (value : byte[])

Remarks

The PinPadBase class verifies that the PIN pad device has been opened, then retrieves or sets the value of PinPadProperties.Track2Data. Accessing Track2Data may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The application has called the BeginEftTransaction method-- Track2Data can’t be set while the device is in EFT Transaction Mode.

Track2Data is initialized to an empty byte array by the PinPadProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.Track2Data Property


PinPadBase.Track3Data Property

PinPadBase.Track3Data Property |
 | See Also

1/18/2008

Holds either the decoded Track 3 data from the previous card swipe or an empty string.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property Track3Data As Byte()
public override byte[] Track3Data { get; set; }
public:
virtual property array<unsigned char>^ Track3Data {
    array<unsigned char>^ get () override;
    void set (array<unsigned char>^ value) override;
}
/** @property */
public byte[] get_Track3Data ()

/** @property */
public void set_Track3Data (byte[] value)

public override function get Track3Data () : byte[]

public override function set Track3Data (value : byte[])

Remarks

The PinPadBase class verifies that the PIN pad device has been opened, then retrieves or sets the value of PinPadProperties.Track3Data. Accessing Track3Data may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The application has called the BeginEftTransaction method-- Track3Data can’t be set while the device is in EFT Transaction Mode.

Track3Data is initialized to an empty byte array by the PinPadProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.Track3Data Property


PinPadBase.Track4Data Property

PinPadBase.Track4Data Property |
 | See Also

1/18/2008

Holds either the decoded Track 4 data from the previous card swipe or an empty string.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property Track4Data As Byte()
public override byte[] Track4Data { get; set; }
public:
virtual property array<unsigned char>^ Track4Data {
    array<unsigned char>^ get () override;
    void set (array<unsigned char>^ value) override;
}
/** @property */
public byte[] get_Track4Data ()

/** @property */
public void set_Track4Data (byte[] value)

public override function get Track4Data () : byte[]

public override function set Track4Data (value : byte[])

Remarks

The PinPadBase class verifies that the PIN pad device has been opened, then retrieves or sets the value of PinPadProperties.Track4Data. Accessing Track4Data may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | The application has called the BeginEftTransaction method-- Track4Data can’t be set while the device is in EFT Transaction Mode.

Track4Data is initialized to an empty byte array by the PinPadProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.Track4Data Property


PinPadBase.TransactionType Property

PinPadBase.TransactionType Property |
 | See Also

1/18/2008

Holds the current EFT transaction type.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property TransactionType As EftTransactionType
public override EftTransactionType TransactionType { get; set; }
public:
virtual property EftTransactionType TransactionType {
    EftTransactionType get () override;
    void set (EftTransactionType value) override;
}
/** @property */
public EftTransactionType get_TransactionType ()

/** @property */
public void set_TransactionType (EftTransactionType value)

public override function get TransactionType () : EftTransactionType

public override function set TransactionType (value : EftTransactionType)

Remarks

The PinPadBase class verifies that the PIN pad device has been opened, then retrieves or sets the value of PinPadProperties.TransactionType. Accessing TransactionType may cause a PosControlException to be thrown with the following ErrorCode:

Value | Meaning
Illegal | One of the following conditions has occurred:The application has called the BeginEftTransaction method—TransactionType can’t be changed while the device is in EFT Transaction Mode; orThe value specified wasn’t found in the EftTransactionType enumerator.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadBase Class
PinPadBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPad.TransactionType Property
EftTransactionType Enumeration


PinPadBase Events

PinPadBase Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DataEvent | Raised by the service object to present input data from the PIN pad device to the application. (inherited from PinPadBasic )
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PinPadBasic )
ErrorEvent | Raised by the service object when an error is detected while trying to perform a PIN encryption function. (inherited from PinPadBasic )
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PinPadBasic )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
StateChangedEvent | (inherited from PinPadBasic )

See Also

Reference

PinPadBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PinPadProperties Class

PinPadProperties Class |
 | See Also Members

1/18/2008

A helper class created by POS for .NET to simplify the retrieval and setting of property values for PIN pad devices.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class PinPadProperties
    Inherits CommonProperties
public class PinPadProperties : CommonProperties
public ref class PinPadProperties : public CommonProperties
public class PinPadProperties extends CommonProperties
public class PinPadProperties extends CommonProperties

Remarks

PinPadProperties is a helper class created by POS for .NET to simplify the retrieval and setting of property values for PIN pad devices. PinPadProperties inherits from the CommonProperties class. The protected Properties property of PinPadProperties class returns an instance of PinPadProperties. The service object can manage the value of a property using the syntax Properties.<propertyName>. PinPadProperties bypasses state validation—in other words, the service object can use PinPadProperties to set values for properties even though the application hasn’t opened, claimed, or enabled the PIN pad device.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BasicServiceObjects.CommonProperties
Microsoft.PointOfService.BaseServiceObjects.PinPadProperties

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PinPadProperties Members

PinPadProperties Members |
 | See Also Methods Properties

1/18/2008

A helper class created by POS for .NET to simplify the retrieval and setting of property values for PIN pad devices.

The following tables list the members exposed by the PinPadProperties type.

Public Properties

Name | Description
AccountNumber | Holds the user’s account number for the current EFT transaction.
AdditionalSecurityInformation | Holds security/encryption information, formatted as a Hex-ASCII string, after a successful PIN entry operation in which the DataEvent event is queued to the application with a DataEventArgs.Status of Success.
Amount | Holds the amount of the current EFT transaction.
AvailableLanguagesList | Holds an array of the languages supported by the pre-defined prompts in the PIN pad device, as defined by the CultureInfo .NET Framework Class.
AvailablePromptsList | Holds a comma-separated string of supported values for the Prompt property.
CapCompareFirmwareVersion | (inherited from CommonProperties )
CapDisplay | Indicates the operations that the application can perform on the PIN pad display.
CapKeyboard | If set to true, the application can use the PIN pad keyboard to obtain input.
CapLanguage | Indicates the language of pre-defined messages for the PIN pad device (for example, English, French, Arabic, and so on).
CapMacCalculation | If set to true, the PIN pad supports MAC calculation.
CapPowerReporting | (inherited from CommonProperties )
CapStatisticsReporting | (inherited from CommonProperties )
CapTone | If set to true, the PIN pad has a tone indicator, which is implemented as a ToneIndicator class object.
CapUpdateFirmware | (inherited from CommonProperties )
CapUpdateStatistics | (inherited from CommonProperties )
DeviceDescription | (inherited from CommonProperties )
DeviceName | (inherited from CommonProperties )
EncryptedPin | Holds the value of the encrypted PIN after the DataEvent event notifies the application that a PIN entry operation has been completed.
MaximumPinLength | Holds the maximum acceptable number of digits to be entered for the PIN.
MerchantId | Holds the Merchant ID, as it is known to the EFT Transaction Host.
MinimumPinLength | Holds the minimum acceptable number of digits to be entered for a PIN.
PinEntryEnabled | Indicates whether the PinPad is ready to accept PIN entry.
PowerState | (inherited from CommonProperties )
Prompt | Holds a pre-defined message to be displayed on the PIN Pad.
PromptLanguage | Specifies the language in which the message specified by the Prompt property will be displayed, as defined by the CultureInfo .NET Framework class.
ServiceObjectDescription | (inherited from CommonProperties )
ServiceObjectVersion | (inherited from CommonProperties )
State | (inherited from CommonProperties )
TerminalId | Holds the Terminal ID, as it is known to the EFT Transaction Host.
Track1Data | Holds either the decoded Track 1 data from the previous card swipe or an empty string.
Track2Data | Holds either the decoded Track 2 data from the previous card swipe or an empty string.
Track3Data | Holds either the decoded Track 3 data from the previous card swipe or an empty string.
Track4Data | Holds either the decoded Track 4 data from the previous card swipe or an empty string.
TransactionType | Holds the current EFT transaction type.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

PinPadProperties Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PinPadProperties Methods

PinPadProperties Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

PinPadProperties Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PinPadProperties Properties

PinPadProperties Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
AccountNumber | Holds the user’s account number for the current EFT transaction.
AdditionalSecurityInformation | Holds security/encryption information, formatted as a Hex-ASCII string, after a successful PIN entry operation in which the DataEvent event is queued to the application with a DataEventArgs.Status of Success.
Amount | Holds the amount of the current EFT transaction.
AvailableLanguagesList | Holds an array of the languages supported by the pre-defined prompts in the PIN pad device, as defined by the CultureInfo .NET Framework Class.
AvailablePromptsList | Holds a comma-separated string of supported values for the Prompt property.
CapCompareFirmwareVersion | (inherited from CommonProperties )
CapDisplay | Indicates the operations that the application can perform on the PIN pad display.
CapKeyboard | If set to true, the application can use the PIN pad keyboard to obtain input.
CapLanguage | Indicates the language of pre-defined messages for the PIN pad device (for example, English, French, Arabic, and so on).
CapMacCalculation | If set to true, the PIN pad supports MAC calculation.
CapPowerReporting | (inherited from CommonProperties )
CapStatisticsReporting | (inherited from CommonProperties )
CapTone | If set to true, the PIN pad has a tone indicator, which is implemented as a ToneIndicator class object.
CapUpdateFirmware | (inherited from CommonProperties )
CapUpdateStatistics | (inherited from CommonProperties )
DeviceDescription | (inherited from CommonProperties )
DeviceName | (inherited from CommonProperties )
EncryptedPin | Holds the value of the encrypted PIN after the DataEvent event notifies the application that a PIN entry operation has been completed.
MaximumPinLength | Holds the maximum acceptable number of digits to be entered for the PIN.
MerchantId | Holds the Merchant ID, as it is known to the EFT Transaction Host.
MinimumPinLength | Holds the minimum acceptable number of digits to be entered for a PIN.
PinEntryEnabled | Indicates whether the PinPad is ready to accept PIN entry.
PowerState | (inherited from CommonProperties )
Prompt | Holds a pre-defined message to be displayed on the PIN Pad.
PromptLanguage | Specifies the language in which the message specified by the Prompt property will be displayed, as defined by the CultureInfo .NET Framework class.
ServiceObjectDescription | (inherited from CommonProperties )
ServiceObjectVersion | (inherited from CommonProperties )
State | (inherited from CommonProperties )
TerminalId | Holds the Terminal ID, as it is known to the EFT Transaction Host.
Track1Data | Holds either the decoded Track 1 data from the previous card swipe or an empty string.
Track2Data | Holds either the decoded Track 2 data from the previous card swipe or an empty string.
Track3Data | Holds either the decoded Track 3 data from the previous card swipe or an empty string.
Track4Data | Holds either the decoded Track 4 data from the previous card swipe or an empty string.
TransactionType | Holds the current EFT transaction type.

See Also

Reference

PinPadProperties Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PinPadProperties.AccountNumber Property

PinPadProperties.AccountNumber Property |
 | See Also

1/18/2008

Holds the user’s account number for the current EFT transaction.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property AccountNumber As String
public string AccountNumber { get; set; }
public:
property String^ AccountNumber {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_AccountNumber ()

/** @property */
public void set_AccountNumber (String value)

public function get AccountNumber () : String

public function set AccountNumber (value : String)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadProperties Class
PinPadProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPadBase.AccountNumber Property


PinPadProperties.AdditionalSecurityInformation Property

PinPadProperties.AdditionalSecurityInformation Property |
 | See Also

1/18/2008

Holds security/encryption information, formatted as a Hex-ASCII string, after a successful PIN entry operation in which the DataEvent event is queued to the application with a DataEventArgs.Status of Success.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property AdditionalSecurityInformation As String
public string AdditionalSecurityInformation { get; set; }
public:
property String^ AdditionalSecurityInformation {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_AdditionalSecurityInformation ()

/** @property */
public void set_AdditionalSecurityInformation (String value)

public function get AdditionalSecurityInformation () : String

public function set AdditionalSecurityInformation (value : String)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadProperties Class
PinPadProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPadBase.AdditionalSecurityInformation Property


PinPadProperties.Amount Property

PinPadProperties.Amount Property |
 | See Also

1/18/2008

Holds the amount of the current EFT transaction.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Amount As Decimal
public decimal Amount { get; set; }
public:
property Decimal Amount {
    Decimal get ();
    void set (Decimal value);
}
/** @property */
public Decimal get_Amount ()

/** @property */
public void set_Amount (Decimal value)

public function get Amount () : decimal

public function set Amount (value : decimal)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadProperties Class
PinPadProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPadBase.Amount Property


PinPadProperties.AvailableLanguagesList Property

PinPadProperties.AvailableLanguagesList Property |
 | See Also

1/18/2008

Holds an array of the languages supported by the pre-defined prompts in the PIN pad device, as defined by the CultureInfo .NET Framework Class.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property AvailableLanguagesList As CultureInfo()
public CultureInfo[] AvailableLanguagesList { get; set; }
public:
property array<CultureInfo^>^ AvailableLanguagesList {
    array<CultureInfo^>^ get ();
    void set (array<CultureInfo^>^ value);
}
/** @property */
public CultureInfo[] get_AvailableLanguagesList ()

/** @property */
public void set_AvailableLanguagesList (CultureInfo[] value)

public function get AvailableLanguagesList () : CultureInfo[]

public function set AvailableLanguagesList (value : CultureInfo[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadProperties Class
PinPadProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPadBase.AvailableLanguagesList Property


PinPadProperties.AvailablePromptsList Property

PinPadProperties.AvailablePromptsList Property |
 | See Also

1/18/2008

Holds a comma-separated string of supported values for the Prompt property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property AvailablePromptsList As PinPadMessage()
public PinPadMessage[] AvailablePromptsList { get; set; }
public:
property array<PinPadMessage>^ AvailablePromptsList {
    array<PinPadMessage>^ get ();
    void set (array<PinPadMessage>^ value);
}
/** @property */
public PinPadMessage[] get_AvailablePromptsList ()

/** @property */
public void set_AvailablePromptsList (PinPadMessage[] value)

public function get AvailablePromptsList () : PinPadMessage[]

public function set AvailablePromptsList (value : PinPadMessage[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadProperties Class
PinPadProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPadBase.AvailablePromptsList Property


PinPadProperties.CapDisplay Property

PinPadProperties.CapDisplay Property |
 | See Also

1/18/2008

Indicates the operations that the application can perform on the PIN pad display.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapDisplay As PinPadDisplay
public PinPadDisplay CapDisplay { get; set; }
public:
property PinPadDisplay CapDisplay {
    PinPadDisplay get ();
    void set (PinPadDisplay value);
}
/** @property */
public PinPadDisplay get_CapDisplay ()

/** @property */
public void set_CapDisplay (PinPadDisplay value)

public function get CapDisplay () : PinPadDisplay

public function set CapDisplay (value : PinPadDisplay)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadProperties Class
PinPadProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPadBase.CapDisplay Property


PinPadProperties.CapKeyboard Property

PinPadProperties.CapKeyboard Property |
 | See Also

1/18/2008

If set to true, the application can use the PIN pad keyboard to obtain input.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapKeyboard As Boolean
public bool CapKeyboard { get; set; }
public:
property bool CapKeyboard {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapKeyboard ()

/** @property */
public void set_CapKeyboard (boolean value)

public function get CapKeyboard () : boolean

public function set CapKeyboard (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadProperties Class
PinPadProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPadBase.CapKeyboard Property


PinPadProperties.CapLanguage Property

PinPadProperties.CapLanguage Property |
 | See Also

1/18/2008

Indicates the language of pre-defined messages for the PIN pad device (for example, English, French, Arabic, and so on).

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapLanguage As PinPadLanguage
public PinPadLanguage CapLanguage { get; set; }
public:
property PinPadLanguage CapLanguage {
    PinPadLanguage get ();
    void set (PinPadLanguage value);
}
/** @property */
public PinPadLanguage get_CapLanguage ()

/** @property */
public void set_CapLanguage (PinPadLanguage value)

public function get CapLanguage () : PinPadLanguage

public function set CapLanguage (value : PinPadLanguage)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadProperties Class
PinPadProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPadBase.CapLanguage Property


PinPadProperties.CapMacCalculation Property

PinPadProperties.CapMacCalculation Property |
 | See Also

1/18/2008

If set to true, the PIN pad supports MAC calculation.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapMacCalculation As Boolean
public bool CapMacCalculation { get; set; }
public:
property bool CapMacCalculation {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapMacCalculation ()

/** @property */
public void set_CapMacCalculation (boolean value)

public function get CapMacCalculation () : boolean

public function set CapMacCalculation (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadProperties Class
PinPadProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPadBase.CapMacCalculation Property


PinPadProperties.CapTone Property

PinPadProperties.CapTone Property |
 | See Also

1/18/2008

If set to true, the PIN pad has a tone indicator, which is implemented as a ToneIndicator class object.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapTone As Boolean
public bool CapTone { get; set; }
public:
property bool CapTone {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapTone ()

/** @property */
public void set_CapTone (boolean value)

public function get CapTone () : boolean

public function set CapTone (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadProperties Class
PinPadProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPadBase.CapTone Property


PinPadProperties.EncryptedPin Property

PinPadProperties.EncryptedPin Property |
 | See Also

1/18/2008

Holds the value of the encrypted PIN after the DataEvent event notifies the application that a PIN entry operation has been completed.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property EncryptedPin As String
public string EncryptedPin { get; set; }
public:
property String^ EncryptedPin {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_EncryptedPin ()

/** @property */
public void set_EncryptedPin (String value)

public function get EncryptedPin () : String

public function set EncryptedPin (value : String)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadProperties Class
PinPadProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPadBase.EncryptedPin Property


PinPadProperties.MaximumPinLength Property

PinPadProperties.MaximumPinLength Property |
 | See Also

1/18/2008

Holds the maximum acceptable number of digits to be entered for the PIN.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property MaximumPinLength As Integer
public int MaximumPinLength { get; set; }
public:
property int MaximumPinLength {
    int get ();
    void set (int value);
}
/** @property */
public int get_MaximumPinLength ()

/** @property */
public void set_MaximumPinLength (int value)

public function get MaximumPinLength () : int

public function set MaximumPinLength (value : int)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadProperties Class
PinPadProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPadBase.MaximumPinLength Property


PinPadProperties.MerchantId Property

PinPadProperties.MerchantId Property |
 | See Also

1/18/2008

Holds the Merchant ID, as it is known to the EFT Transaction Host.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property MerchantId As String
public string MerchantId { get; set; }
public:
property String^ MerchantId {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_MerchantId ()

/** @property */
public void set_MerchantId (String value)

public function get MerchantId () : String

public function set MerchantId (value : String)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadProperties Class
PinPadProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPadBase.MerchantId Property


PinPadProperties.MinimumPinLength Property

PinPadProperties.MinimumPinLength Property |
 | See Also

1/18/2008

Holds the minimum acceptable number of digits to be entered for a PIN.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property MinimumPinLength As Integer
public int MinimumPinLength { get; set; }
public:
property int MinimumPinLength {
    int get ();
    void set (int value);
}
/** @property */
public int get_MinimumPinLength ()

/** @property */
public void set_MinimumPinLength (int value)

public function get MinimumPinLength () : int

public function set MinimumPinLength (value : int)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadProperties Class
PinPadProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPadBase.MinimumPinLength Property


PinPadProperties.PinEntryEnabled Property

PinPadProperties.PinEntryEnabled Property |
 | See Also

1/18/2008

Indicates whether the PinPad is ready to accept PIN entry.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property PinEntryEnabled As Boolean
public bool PinEntryEnabled { get; set; }
public:
property bool PinEntryEnabled {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_PinEntryEnabled ()

/** @property */
public void set_PinEntryEnabled (boolean value)

public function get PinEntryEnabled () : boolean

public function set PinEntryEnabled (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadProperties Class
PinPadProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPadBase.PinEntryEnabled Property


PinPadProperties.Prompt Property

PinPadProperties.Prompt Property |
 | See Also

1/18/2008

Holds a pre-defined message to be displayed on the PIN Pad.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Prompt As PinPadMessage
public PinPadMessage Prompt { get; set; }
public:
property PinPadMessage Prompt {
    PinPadMessage get ();
    void set (PinPadMessage value);
}
/** @property */
public PinPadMessage get_Prompt ()

/** @property */
public void set_Prompt (PinPadMessage value)

public function get Prompt () : PinPadMessage

public function set Prompt (value : PinPadMessage)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadProperties Class
PinPadProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPadBase.AvailablePromptsList Property


PinPadProperties.PromptLanguage Property

PinPadProperties.PromptLanguage Property |
 | See Also

1/18/2008

Specifies the language in which the message specified by the Prompt property will be displayed, as defined by the CultureInfo .NET Framework class.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property PromptLanguage As CultureInfo
public CultureInfo PromptLanguage { get; set; }
public:
property CultureInfo^ PromptLanguage {
    CultureInfo^ get ();
    void set (CultureInfo^ value);
}
/** @property */
public CultureInfo get_PromptLanguage ()

/** @property */
public void set_PromptLanguage (CultureInfo value)

public function get PromptLanguage () : CultureInfo

public function set PromptLanguage (value : CultureInfo)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadProperties Class
PinPadProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPadBase.PromptLanguage Property


PinPadProperties.TerminalId Property

PinPadProperties.TerminalId Property |
 | See Also

1/18/2008

Holds the Terminal ID, as it is known to the EFT Transaction Host.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property TerminalId As String
public string TerminalId { get; set; }
public:
property String^ TerminalId {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_TerminalId ()

/** @property */
public void set_TerminalId (String value)

public function get TerminalId () : String

public function set TerminalId (value : String)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadProperties Class
PinPadProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPadBase.TerminalId Property


PinPadProperties.Track1Data Property

PinPadProperties.Track1Data Property |
 | See Also

1/18/2008

Holds either the decoded Track 1 data from the previous card swipe or an empty string.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Track1Data As Byte()
public byte[] Track1Data { get; set; }
public:
property array<unsigned char>^ Track1Data {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
/** @property */
public byte[] get_Track1Data ()

/** @property */
public void set_Track1Data (byte[] value)

public function get Track1Data () : byte[]

public function set Track1Data (value : byte[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadProperties Class
PinPadProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPadBase.Track1Data Property


PinPadProperties.Track2Data Property

PinPadProperties.Track2Data Property |
 | See Also

1/18/2008

Holds either the decoded Track 2 data from the previous card swipe or an empty string.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Track2Data As Byte()
public byte[] Track2Data { get; set; }
public:
property array<unsigned char>^ Track2Data {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
/** @property */
public byte[] get_Track2Data ()

/** @property */
public void set_Track2Data (byte[] value)

public function get Track2Data () : byte[]

public function set Track2Data (value : byte[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadProperties Class
PinPadProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPadBase.Track2Data Property


PinPadProperties.Track3Data Property

PinPadProperties.Track3Data Property |
 | See Also

1/18/2008

Holds either the decoded Track 3 data from the previous card swipe or an empty string.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Track3Data As Byte()
public byte[] Track3Data { get; set; }
public:
property array<unsigned char>^ Track3Data {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
/** @property */
public byte[] get_Track3Data ()

/** @property */
public void set_Track3Data (byte[] value)

public function get Track3Data () : byte[]

public function set Track3Data (value : byte[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadProperties Class
PinPadProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPadBase.Track3Data Property


PinPadProperties.Track4Data Property

PinPadProperties.Track4Data Property |
 | See Also

1/18/2008

Holds either the decoded Track 4 data from the previous card swipe or an empty string.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Track4Data As Byte()
public byte[] Track4Data { get; set; }
public:
property array<unsigned char>^ Track4Data {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
/** @property */
public byte[] get_Track4Data ()

/** @property */
public void set_Track4Data (byte[] value)

public function get Track4Data () : byte[]

public function set Track4Data (value : byte[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadProperties Class
PinPadProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPadBase.Track4Data Property


PinPadProperties.TransactionType Property

PinPadProperties.TransactionType Property |
 | See Also

1/18/2008

Holds the current EFT transaction type.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property TransactionType As EftTransactionType
public EftTransactionType TransactionType { get; set; }
public:
property EftTransactionType TransactionType {
    EftTransactionType get ();
    void set (EftTransactionType value);
}
/** @property */
public EftTransactionType get_TransactionType ()

/** @property */
public void set_TransactionType (EftTransactionType value)

public function get TransactionType () : EftTransactionType

public function set TransactionType (value : EftTransactionType)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PinPadProperties Class
PinPadProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PinPadBase.TransactionType Property


PosKeyboardBase Class

PosKeyboardBase Class |
 | See Also Members

1/18/2008

Contains compete device functionality implemented by POS for .NET for support of keyboard devices.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public MustInherit Class PosKeyboardBase
    Inherits PosKeyboardBasic
public abstract class PosKeyboardBase : PosKeyboardBasic
public ref class PosKeyboardBase abstract : public PosKeyboardBasic
public abstract class PosKeyboardBase extends PosKeyboardBasic
public abstract class PosKeyboardBase extends PosKeyboardBasic

Remarks

The PosKeyboardBase class derives from the PosKeyboardBasic class and contains compete device functionality implemented by POS for .NET for support of keyboard devices. Using PosKeyboardBase, service objects can take advantage of code that implements all of the standard functionality of the device. Service objects that derive from PosKeyboardBase need only provide code for the inherited ClearInputImpl protected method, if necessary, to provide the ability to clear hardware device buffers.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.PosKeyboard
Microsoft.PointOfService.BasicServiceObjects.PosKeyboardBasic
Microsoft.PointOfService.BaseServiceObjects.PosKeyboardBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosKeyboardBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosKeyboardBase Members

PosKeyboardBase Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Contains compete device functionality implemented by POS for .NET for support of keyboard devices.

The following tables list the members exposed by the PosKeyboardBase type.

Protected Constructors

Name | Description
PosKeyboardBase | Creates an instance of the PosKeyboardBase class.
Top

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticKeyPressedCount | Incremented for each key-down action. (inherited from PosKeyboard)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
AutoDisable | Gets or sets a Boolean value that indicates whether POS for .NET automatically disables the device when data is received. (inherited from PosKeyboardBasic)
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosKeyboardBasic)
CapKeyUp | Overridden. If true, the keyboard device is able to generate both key-down and key-up input data, based on the value of the EventTypes property.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosKeyboardBasic)
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosKeyboardBasic)
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosKeyboardBasic)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosKeyboardBasic)
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosKeyboardBasic)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
DataCount | Gets the number of data events currently queued by the service object. (inherited from PosKeyboardBasic)
DataEventEnabled | Gets or sets a Boolean value that indicates whether the service object can deliver a queued event by raising a DataEvent event. (inherited from PosKeyboardBasic)
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosKeyboardBasic)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosKeyboardBasic)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosKeyboardBasic)
EventTypes | Overridden. Holds the type of events that the application wants to receive.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosKeyboardBasic)
PosKeyData | Overridden. Holds the value of the key from the last DataEvent.
PosKeyEventType | Overridden. Holds the value of the key from the last DataEvent.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosKeyboardBasic)
PowerState | Gets the current power condition. (inherited from PosKeyboardBasic)
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosKeyboardBasic)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosKeyboardBasic)
State | Gets the current state of the device. (inherited from PosKeyboardBasic)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Top

Protected Properties

Name | Description
CommonProperties | (inherited from PosKeyboardBasic )
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
ErrorCount | (inherited from PosKeyboardBasic )
ExternallyClaimed | (inherited from PosKeyboardBasic )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Indicates whether the PosKeyboard is an exclusive use device. (inherited from PosKeyboard)
Properties | Contains getters and setters for PosKeyboard and Common properties.
Top

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosKeyboardBasic )
ClearInput | Clears all device input that has been buffered. (inherited from PosKeyboardBasic)
Close | Releases the device and its resources. (inherited from PosKeyboardBasic)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Overridden. Opens a device for later input/output processing.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosKeyboardBasic)
ResetStatistic | (inherited from PosKeyboardBasic )
ResetStatistics | Overloaded. (inherited from PosKeyboardBasic )
RetrieveStatistic | (inherited from PosKeyboardBasic )
RetrieveStatistics | Overloaded. (inherited from PosKeyboardBasic )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosKeyboardBasic )
UpdateStatistics | Overloaded. (inherited from PosKeyboardBasic )
Top

Protected Methods

Name | Description
ClearInputImpl | (inherited from PosKeyboardBasic )
CreateStatistic | Overloaded. (inherited from PosKeyboardBasic )
DeleteConfigurationProperty | (inherited from PosCommon )
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
GetStatisticValue | (inherited from PosKeyboardBasic )
IncrementStatistic | Overloaded. (inherited from PosKeyboardBasic )
Invoke | (inherited from PosCommon )
KeyDown | Holds the type of the last keyboard event.
KeyUp | If true, the keyboard device is able to generate both key-down and key-up input data, based on the value of the EventTypes property.
MemberwiseClone | (inherited from Object )
PreFireEvent | Overloaded. Overridden.
QueueEvent | Overloaded. (inherited from PosKeyboardBasic )
QueueEventAndWait | Overloaded. (inherited from PosKeyboardBasic )
SetConfigurationProperty | (inherited from PosCommon )
SetStatisticHandlers | (inherited from PosKeyboardBasic )
SetStatisticValue | (inherited from PosKeyboardBasic )
VerifyState | (inherited from PosKeyboardBasic )
Top

Public Events (see also Protected Events )

Name | Description
DataEvent | Raised by the service object to present input data from the device to the application. (inherited from PosKeyboardBasic)
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosKeyboardBasic)
ErrorEvent | Raised by the service object to indicate an error has been detected while it is trying to read keyboard device input data. (inherited from PosKeyboardBasic)
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosKeyboardBasic)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
StateChangedEvent | (inherited from PosKeyboardBasic )
Top

See Also

Reference

PosKeyboardBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PosKeyboardBase Fields

PosKeyboardBase Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticKeyPressedCount | Incremented for each key-down action. (inherited from PosKeyboard )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

PosKeyboardBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PosKeyboardBase Constructor

PosKeyboardBase Constructor |
 | See Also

1/18/2008

Creates an instance of the PosKeyboardBase class.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Sub New
protected PosKeyboardBase ()
protected:
PosKeyboardBase ()
protected PosKeyboardBase ()
protected function PosKeyboardBase ()

Remarks

Creates an instance of the PosKeyboardBase class and recognizes the service object. Initializes statistics for the UPOS Version, the Device Category, and the Installation Date.

See Also

Reference

PosKeyboardBase Class
PosKeyboardBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosKeyboardBase Methods

PosKeyboardBase Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosKeyboardBasic )
ClearInput | Clears all device input that has been buffered. (inherited from PosKeyboardBasic )
Close | Releases the device and its resources. (inherited from PosKeyboardBasic )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Overridden. Opens a device for later input/output processing.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosKeyboardBasic )
ResetStatistic | (inherited from PosKeyboardBasic )
ResetStatistics | Overloaded. (inherited from PosKeyboardBasic )
RetrieveStatistic | (inherited from PosKeyboardBasic )
RetrieveStatistics | Overloaded. (inherited from PosKeyboardBasic )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosKeyboardBasic )
UpdateStatistics | Overloaded. (inherited from PosKeyboardBasic )

Protected Methods

Name | Description
ClearInputImpl | (inherited from PosKeyboardBasic )
CreateStatistic | Overloaded. (inherited from PosKeyboardBasic )
DeleteConfigurationProperty | (inherited from PosCommon )
Dispose | Overloaded. Overridden.
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
GetStatisticValue | (inherited from PosKeyboardBasic )
IncrementStatistic | Overloaded. (inherited from PosKeyboardBasic )
Invoke | (inherited from PosCommon )
KeyDown | Holds the type of the last keyboard event.
KeyUp | If true, the keyboard device is able to generate both key-down and key-up input data, based on the value of the EventTypes property.
MemberwiseClone | (inherited from Object )
PreFireEvent | Overloaded. Overridden.
QueueEvent | Overloaded. (inherited from PosKeyboardBasic )
QueueEventAndWait | Overloaded. (inherited from PosKeyboardBasic )
SetConfigurationProperty | (inherited from PosCommon )
SetStatisticHandlers | (inherited from PosKeyboardBasic )
SetStatisticValue | (inherited from PosKeyboardBasic )
VerifyState | (inherited from PosKeyboardBasic )

See Also

Reference

PosKeyboardBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PosKeyboardBase.Dispose Method

PosKeyboardBase.Dispose Method |
 | See Also

1/18/2008

Overload List

Name | Description
PosKeyboardBase.Dispose () | (inherited from Dispose )
PosKeyboardBase.Dispose (Boolean) |

See Also

Reference

PosKeyboardBase Class
PosKeyboardBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosKeyboardBase.Dispose Method (Boolean)

PosKeyboardBase.Dispose Method (Boolean) |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

protected override void Dispose (
    bool disposing
)

protected:
virtual void Dispose (
    bool disposing
) override

protected void Dispose (
    boolean disposing
)

protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosKeyboardBase Class
PosKeyboardBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosKeyboardBase.KeyDown Method

PosKeyboardBase.KeyDown Method |
 | See Also

1/18/2008

Holds the type of the last keyboard event.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Sub KeyDown ( _
    keyData As Integer _
)
protected void KeyDown (
    int keyData
)
protected:
void KeyDown (
    int keyData
)
protected void KeyDown (
    int keyData
)
protected function KeyDown (
    keyData : int
)

Parameters

keyData

The keyData parameter contains the value of the key pressed, defined as a logical key code in the upper 16 bits and a scan code in the lower 16 bits, where the values need not match a standard PC keyboard’s values.

Remarks

The service object calls KeyDown when the user presses a key (which typically generates a hardware interrupt). The PosKeyboardBase class implementation of KeyDown increments the StatisticKeyPressedCount statistic and then queues a data event to the application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosKeyboardBase Class
PosKeyboardBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosKeyboard.StatisticKeyPressedCount Field


PosKeyboardBase.KeyUp Method

PosKeyboardBase.KeyUp Method |
 | See Also

1/18/2008

If true, the keyboard device is able to generate both key-down and key-up input data, based on the value of the EventTypes property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Sub KeyUp ( _
    keyData As Integer _
)
protected void KeyUp (
    int keyData
)
protected:
void KeyUp (
    int keyData
)
protected void KeyUp (
    int keyData
)
protected function KeyUp (
    keyData : int
)

Parameters

keyData

The keyData parameter contains the value of the key pressed, defined as a logical key code in the upper 16 bits and a scan code in the lower 16 bits, where the values need not match a standard PC keyboard's values.

Remarks

If the application wants to receive key-up data, the service object calls KeyUp when the user releases a key (which typically generates a hardware interrupt). The PosKeyboardBase class implementation of KeyUp queues a data event to the application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosKeyboardBase Class
PosKeyboardBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosKeyboardBase.Open Method

PosKeyboardBase.Open Method |
 | See Also

1/18/2008

Opens a device for later input/output processing.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub Open
public override void Open ()
public:
virtual void Open () override
public void Open ()
public override function Open ()

Remarks

Open initializes statistics reporting and event threads for the specified device. Open also initializes the values of many properties. This includes the DataEventEnabled, FreezeEvents, AutoDisable, Claimed properties and more. For specifics about how these properties are initialized, see the individual properties.

Open may throw a PosControlException with the following values:

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The device is already opened; or

  • The DeviceName property is null or an empty string ("").

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosKeyboardBase Class
PosKeyboardBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosCommon.Close Method


PosKeyboardBase.PreFireEvent Method

PosKeyboardBase.PreFireEvent Method |
 | See Also

1/18/2008

Overload List

Name | Description
PosKeyboardBase.PreFireEvent (DataEventArgs) | Called prior to the delivery of a DataEvent event to the application.
PosKeyboardBase.PreFireEvent (DeviceErrorEventArgs) | (inherited from PreFireEvent )
PosKeyboardBase.PreFireEvent (DirectIOEventArgs) | (inherited from PreFireEvent )
PosKeyboardBase.PreFireEvent (StatusUpdateEventArgs) | (inherited from PreFireEvent )

See Also

Reference

PosKeyboardBase Class
PosKeyboardBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosKeyData
PosKeyEventType
DataEventArgs Class
DataEventHandler Delegate


PosKeyboardBase.PreFireEvent Method (DataEventArgs)

PosKeyboardBase.PreFireEvent Method (DataEventArgs) |
 | See Also

1/18/2008

Called prior to the delivery of a DataEvent event to the application.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overrides Sub PreFireEvent ( _
    posEvent As DataEventArgs _
)
protected override void PreFireEvent (
    DataEventArgs posEvent
)
protected:
virtual void PreFireEvent (
    DataEventArgs^ posEvent
) override
protected void PreFireEvent (
    DataEventArgs posEvent
)
protected override function PreFireEvent (
    posEvent : DataEventArgs
)

Parameters

posEvent

An instance of the DataEventArgs class, posEvent contains the event the service object queued to the application.

Remarks

Called prior to the delivery of a DataEvent event to the application. When PreFireEvent is called, the PosKeyboardBase class implementation updates the values of the PosKeyboardProperties.PosKeyData and PosKeyboardProperties.PosKeyEventType properties.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosKeyboardBase Class
PosKeyboardBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosKeyData
PosKeyEventType
DataEventArgs Class
DataEventHandler Delegate


PosKeyboardBase Properties

PosKeyboardBase Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
AutoDisable | Gets or sets a Boolean value that indicates whether POS for .NET automatically disables the device when data is received. (inherited from PosKeyboardBasic )
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosKeyboardBasic )
CapKeyUp | Overridden. If true, the keyboard device is able to generate both key-down and key-up input data, based on the value of the EventTypes property.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosKeyboardBasic )
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosKeyboardBasic )
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosKeyboardBasic )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosKeyboardBasic )
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosKeyboardBasic )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
DataCount | Gets the number of data events currently queued by the service object. (inherited from PosKeyboardBasic )
DataEventEnabled | Gets or sets a Boolean value that indicates whether the service object can deliver a queued event by raising a DataEvent event. (inherited from PosKeyboardBasic )
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosKeyboardBasic )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from PosKeyboardBasic )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosKeyboardBasic )
EventTypes | Overridden. Holds the type of events that the application wants to receive.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosKeyboardBasic )
PosKeyData | Overridden. Holds the value of the key from the last DataEvent.
PosKeyEventType | Overridden. Holds the value of the key from the last DataEvent.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosKeyboardBasic )
PowerState | Gets the current power condition. (inherited from PosKeyboardBasic )
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosKeyboardBasic )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosKeyboardBasic )
State | Gets the current state of the device. (inherited from PosKeyboardBasic )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )

Protected Properties

Name | Description
CommonProperties | (inherited from PosKeyboardBasic )
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
ErrorCount | (inherited from PosKeyboardBasic )
ExternallyClaimed | (inherited from PosKeyboardBasic )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Indicates whether the PosKeyboard is an exclusive use device. (inherited from PosKeyboard )
Properties | Contains getters and setters for PosKeyboard and Common properties.

See Also

Reference

PosKeyboardBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PosKeyboardBase.CapKeyUp Property

PosKeyboardBase.CapKeyUp Property |
 | See Also

1/18/2008

If true, the keyboard device is able to generate both key-down and key-up input data, based on the value of the EventTypes property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapKeyUp As Boolean
public override bool CapKeyUp { get; }
public:
virtual property bool CapKeyUp {
    bool get () override;
}
/** @property */
public boolean get_CapKeyUp ()

public override function get CapKeyUp () : boolean

Remarks

If false, the keyboard device is only able to generate key-down input data.

The PosKeyboardBase class verifies that the keyboard device has been opened, then retrieves the value of PosKeyboardProperties.CapKeyUp.

The PosKeyboardProperties class initializes CapKeyUp to false. It should then be updated by the service object based on the capability of the keyboard device to detect key-up actions.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosKeyboardBase Class
PosKeyboardBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosKeyboard.CapKeyUp Property


PosKeyboardBase.EventTypes Property

PosKeyboardBase.EventTypes Property |
 | See Also

1/18/2008

Holds the type of events that the application wants to receive.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property EventTypes As KeyboardEventType
public override KeyboardEventType EventTypes { get; set; }
public:
virtual property KeyboardEventType EventTypes {
    KeyboardEventType get () override;
    void set (KeyboardEventType value) override;
}
/** @property */
public KeyboardEventType get_EventTypes ()

/** @property */
public void set_EventTypes (KeyboardEventType value)

public override function get EventTypes () : KeyboardEventType

public override function set EventTypes (value : KeyboardEventType)

Remarks

The PosKeyboardBase class verifies that the keyboard device has been opened, then retrieves the value of PosKeyboardProperties.EventTypes.

The PosKeyboardProperties class initializes PosKeyboardProperties.EventTypes to KeyboardEventType.Down. It should then be updated by the service object based on the ability to generate key-up-based events. Accessing EventTypes may throw a PosControlException with the following errorcode:

Value | Meaning
Illegal | EventTypes was set to KeyboardEventType.DownUp but the CapKeyUp property is set to false, indicating that key-up strokes aren’t captured.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosKeyboardBase Class
PosKeyboardBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosKeyboard.EventTypes Property
PosKeyboard.CapKeyUp Property
KeyboardEventType Enumeration


PosKeyboardBase.PosKeyData Property

PosKeyboardBase.PosKeyData Property |
 | See Also

1/18/2008

Holds the value of the key from the last DataEvent.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property PosKeyData As Integer
public override int PosKeyData { get; }
public:
virtual property int PosKeyData {
    int get () override;
}
/** @property */
public int get_PosKeyData ()

public override function get PosKeyData () : int

Remarks

The value is defined as a logical key code in the upper 16 bits and a scan code in the lower 16 bits, where the values need not match a standard PC keyboard's values.

The application may treat the value of PosKeyData as device-independent, assuming that the system installer has configured the keyboard’s service object to translate internal key codes to the codes expected by the application. Such configuration is inherently service object-specific.

The PosKeyboardBase class verifies that the keyboard device has been opened, then retrieves the value of PosKeyboardProperties.PosKeyData.

The PosKeyboardProperties class initializes PosKeyboardProperties.PosKeyData to 0 (zero). The service object updates PosKeyboardProperties.PosKeyData when the user presses or releases a key.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosKeyboardBase Class
PosKeyboardBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosKeyboard.PosKeyData Property


PosKeyboardBase.PosKeyEventType Property

PosKeyboardBase.PosKeyEventType Property |
 | See Also

1/18/2008

Holds the value of the key from the last DataEvent.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property PosKeyEventType As KeyEvent
public override KeyEvent PosKeyEventType { get; }
public:
virtual property KeyEvent PosKeyEventType {
    KeyEvent get () override;
}
/** @property */
public KeyEvent get_PosKeyEventType ()

public override function get PosKeyEventType () : KeyEvent

Remarks

The value is defined as a logical key code in the upper 16 bits and a scan code in the lower 16 bits, where the values need not match a standard PC keyboard's values.

The application may treat the value of PosKeyData as device-independent, assuming that the system installer has configured the keyboard’s service object to translate internal key codes to the codes expected by the application. Such configuration is inherently service object-specific.

The PosKeyboardBase class verifies that the keyboard device has been opened, then retrieves the value of PosKeyboardProperties.PosKeyEventType.

The PosKeyboardProperties class initializes PosKeyboardProperties.PosKeyEventType to KeyEvent.Down. The service object updates PosKeyboardProperties.PosKeyEventType when the user presses or releases a key. If PosKeyboardProperties.PosKeyEventType is set to KeyEvent.Up and the PosKeyboardProperties.CapKeyUp property is set to false, the PosKeyboardProperties class throws an Illegal exception.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosKeyboardBase Class
PosKeyboardBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosKeyboard.PosKeyEventType Property
PosKeyboard.CapKeyUp Property
KeyEvent Enumeration


PosKeyboardBase.Properties Property

PosKeyboardBase.Properties Property |
 | See Also

1/18/2008

Contains getters and setters for PosKeyboard and Common properties.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected ReadOnly Property Properties As PosKeyboardProperties
protected PosKeyboardProperties Properties { get; }
protected:
property PosKeyboardProperties^ Properties {
    PosKeyboardProperties^ get ();
}
/** @property */
protected PosKeyboardProperties get_Properties ()

protected function get Properties () : PosKeyboardProperties

Remarks

Returns an instance of the PosKeyboardProperties helper class, containing getters and setters for PosKeyboard and Common properties.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosKeyboardBase Class
PosKeyboardBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosKeyboardBase Events

PosKeyboardBase Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DataEvent | Raised by the service object to present input data from the device to the application. (inherited from PosKeyboardBasic )
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosKeyboardBasic )
ErrorEvent | Raised by the service object to indicate an error has been detected while it is trying to read keyboard device input data. (inherited from PosKeyboardBasic )
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosKeyboardBasic )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
StateChangedEvent | (inherited from PosKeyboardBasic )

See Also

Reference

PosKeyboardBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PosKeyboardProperties Class

PosKeyboardProperties Class |
 | See Also Members

1/18/2008

A helper class created by POS for .NET to simplify the retrieval and setting of property values for keyboard devices.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class PosKeyboardProperties
    Inherits CommonProperties
public class PosKeyboardProperties : CommonProperties
public ref class PosKeyboardProperties : public CommonProperties
public class PosKeyboardProperties extends CommonProperties
public class PosKeyboardProperties extends CommonProperties

Remarks

PosKeyboardProperties is a helper class created by POS for .NET to simplify the retrieval and setting of property values for keyboard devices. PosKeyboardProperties inherits from the CommonProperties class. The protected Properties property of PosKeyboardBase class returns an instance of PosKeyboardProperties. The service object can manage the value of a property using the syntax Properties.<propertyName>. PosKeyboardProperties bypasses state validation—in other words, the service object can use PosKeyboardProperties to set and retrieve values for properties regardless of whether the keyboard device has been opened, claimed, or enabled.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BasicServiceObjects.CommonProperties
Microsoft.PointOfService.BaseServiceObjects.PosKeyboardProperties

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosKeyboardProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosKeyboardProperties Members

PosKeyboardProperties Members |
 | See Also Methods Properties

1/18/2008

A helper class created by POS for .NET to simplify the retrieval and setting of property values for keyboard devices.

The following tables list the members exposed by the PosKeyboardProperties type.

Public Properties

Name | Description
CapCompareFirmwareVersion | (inherited from CommonProperties )
CapKeyUp | If true, the keyboard device is able to generate both key-down and key-up input data, based on the value of the EventTypes property.
CapPowerReporting | (inherited from CommonProperties )
CapStatisticsReporting | (inherited from CommonProperties )
CapUpdateFirmware | (inherited from CommonProperties )
CapUpdateStatistics | (inherited from CommonProperties )
DeviceDescription | (inherited from CommonProperties )
DeviceName | (inherited from CommonProperties )
EventTypes | Holds the type of events that the application wants to receive.
PosKeyData | Holds the value of the key from the last DataEvent.
PosKeyEventType | Holds the type of the last keyboard event.
PowerState | (inherited from CommonProperties )
ServiceObjectDescription | (inherited from CommonProperties )
ServiceObjectVersion | (inherited from CommonProperties )
State | (inherited from CommonProperties )
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

PosKeyboardProperties Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PosKeyboardProperties Methods

PosKeyboardProperties Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

PosKeyboardProperties Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PosKeyboardProperties Properties

PosKeyboardProperties Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
CapCompareFirmwareVersion | (inherited from CommonProperties )
CapKeyUp | If true, the keyboard device is able to generate both key-down and key-up input data, based on the value of the EventTypes property.
CapPowerReporting | (inherited from CommonProperties )
CapStatisticsReporting | (inherited from CommonProperties )
CapUpdateFirmware | (inherited from CommonProperties )
CapUpdateStatistics | (inherited from CommonProperties )
DeviceDescription | (inherited from CommonProperties )
DeviceName | (inherited from CommonProperties )
EventTypes | Holds the type of events that the application wants to receive.
PosKeyData | Holds the value of the key from the last DataEvent.
PosKeyEventType | Holds the type of the last keyboard event.
PowerState | (inherited from CommonProperties )
ServiceObjectDescription | (inherited from CommonProperties )
ServiceObjectVersion | (inherited from CommonProperties )
State | (inherited from CommonProperties )

See Also

Reference

PosKeyboardProperties Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PosKeyboardProperties.CapKeyUp Property

PosKeyboardProperties.CapKeyUp Property |
 | See Also

1/18/2008

If true, the keyboard device is able to generate both key-down and key-up input data, based on the value of the EventTypes property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapKeyUp As Boolean
public bool CapKeyUp { get; set; }
public:
property bool CapKeyUp {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapKeyUp ()

/** @property */
public void set_CapKeyUp (boolean value)

public function get CapKeyUp () : boolean

public function set CapKeyUp (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosKeyboardProperties Class
PosKeyboardProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosKeyboard.CapKeyUp Property


PosKeyboardProperties.EventTypes Property

PosKeyboardProperties.EventTypes Property |
 | See Also

1/18/2008

Holds the type of events that the application wants to receive.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property EventTypes As KeyboardEventType
public KeyboardEventType EventTypes { get; set; }
public:
property KeyboardEventType EventTypes {
    KeyboardEventType get ();
    void set (KeyboardEventType value);
}
/** @property */
public KeyboardEventType get_EventTypes ()

/** @property */
public void set_EventTypes (KeyboardEventType value)

public function get EventTypes () : KeyboardEventType

public function set EventTypes (value : KeyboardEventType)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosKeyboardProperties Class
PosKeyboardProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosKeyboard.EventTypes Property


PosKeyboardProperties.PosKeyData Property

PosKeyboardProperties.PosKeyData Property |
 | See Also

1/18/2008

Holds the value of the key from the last DataEvent.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property PosKeyData As Integer
public int PosKeyData { get; set; }
public:
property int PosKeyData {
    int get ();
    void set (int value);
}
/** @property */
public int get_PosKeyData ()

/** @property */
public void set_PosKeyData (int value)

public function get PosKeyData () : int

public function set PosKeyData (value : int)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosKeyboardProperties Class
PosKeyboardProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosKeyboard.PosKeyData Property


PosKeyboardProperties.PosKeyEventType Property

PosKeyboardProperties.PosKeyEventType Property |
 | See Also

1/18/2008

Holds the type of the last keyboard event.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property PosKeyEventType As KeyEvent
public KeyEvent PosKeyEventType { get; set; }
public:
property KeyEvent PosKeyEventType {
    KeyEvent get ();
    void set (KeyEvent value);
}
/** @property */
public KeyEvent get_PosKeyEventType ()

/** @property */
public void set_PosKeyEventType (KeyEvent value)

public function get PosKeyEventType () : KeyEvent

public function set PosKeyEventType (value : KeyEvent)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosKeyboardProperties Class
PosKeyboardProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosKeyboard.PosKeyEventType Property


PosPrinterBase Class

PosPrinterBase Class |
 | See Also Members

1/18/2008

PosPrinterBase class derives from PosPrinterBasic class and contains more complete device functionality implemented by POS for .NET for support of POS printer devices.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public MustInherit Class PosPrinterBase
    Inherits PosPrinterBasic
public abstract class PosPrinterBase : PosPrinterBasic
public ref class PosPrinterBase abstract : public PosPrinterBasic
public abstract class PosPrinterBase extends PosPrinterBasic
public abstract class PosPrinterBase extends PosPrinterBasic

Remarks

PosPrinterBase class derives from PosPrinterBasic class and contains more complete device functionality implemented by POS for .NET for support of POS printer devices. When deriving from PosPrinterBase, service objects can take advantage of code that provides a structured environment supporting the standard functionality of printer devices.

As with all other devices, the service object should implement the CheckHealth and ClearInput methods. PosPrinterBase class provides the core functionality for opening, claiming, and enabling printer devices. Typically, though, service objects will want to override these methods to add their own custom processing. (A typical example would be to update device statistics during the Open method, or to bring the device online when the application enables it.) When overriding these methods, the service object must call the base class implementation.

PosPrinterBase class provides implementations for all UPOS-defined print methods. For each method, PosPrinterBase performs basic validations and then calls the service object's implementation. For example, for RotatePrint method, after performing validations, PosPrinterBase calls the service object's implementation of the RotatePrintImpl method. Although in most cases PosPrinterBase provides a default implementation that returns without error, service objects should plan to provide their own implementation for each of the print methods.

PosPrinterBase makes use of a number of helper classes. These are:

  • The PrintResults class, returned by a number of methods, which the service object should use to provide updates to printer statistics and to report any error conditions that have occurred;

  • The PrinterState class, used to capture and store a group of printer property values set by the application for a print operation, then passed as a parameter for several print methods;

  • PrintOperation and <PrintMethodName>Operation derived classes, which store state information for a specific print operation at the time of the method call;

  • PrintOperationCollection, which is enumerable and contains a list of requested print operations; and

  • RotatePrintCollection, which is enumerable and contains a list of requested rotate print operations.

Print operations can be performed synchronously or asynchronously, depending on the value of the AsyncMode property. When the application sets AsyncMode to TRUE, asynchronous processing is enabled. PosPrinterBase class will perform basic validations for each method called by the application, then add the print request to an internal queue and return to the application. (State and property value information is captured at the time of the call, to be processed later. See the description of the helper classes above.) Requests added to the internal queue are processed in FIFO order.

To process the print operations on the internal queue, PosPrinterBase class dequeues the next request, then calls the appropriate Print*Impl method, based on the type of print operation. (State information is captured in an instance of the PrinterState helper class and passed as a parameter to the appropriate Print*Impl method.) Service objects should process the request in the same manner that they would a synchronous operation.

When in asynchronous mode, PosPrinterBase class updates printer statistics based on the values returned by the service object in the PrintResults helper class. In addition, PosPrinterBase class sends either an OutputCompleteEvent event or an ErrorEvent event, as appropriate. If PosPrinterBase class sends an ErrorEvent event, it manages the processing of Retry or Clear logic, depending on the response from the application.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.PosPrinter
Microsoft.PointOfService.BasicServiceObjects.PosPrinterBasic
Microsoft.PointOfService.BaseServiceObjects.PosPrinterBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace

Other Resources

Using Impl Methods for Synchronous or Asynchronous Output


PosPrinterBase Members

PosPrinterBase Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

PosPrinterBase class derives from PosPrinterBasic class and contains more complete device functionality implemented by POS for .NET for support of POS printer devices.

The following tables list the members exposed by the PosPrinterBase type.

Protected Constructors

Name | Description
PosPrinterBase | Creates a new instance of the PosPrinterBase class.
Top

Public Fields

Name | Description
CharacterSetAnsi | Indicates the default character set supports the ANSI character set. (inherited from PosPrinter)
CharacterSetAscii | Indicates the default character set supports the ASCII character set. (inherited from PosPrinter)
CharacterSetUnicode | Indicates the default character set supports the Unicode character set. (inherited from PosPrinter)
ExtendedErrorBadFormat | Indicates an unsupported format. (inherited from PosPrinter)
ExtendedErrorCoverOpen | Indicates that the printer cover is open. (inherited from PosPrinter)
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorJournalCartridgeEmpty | Indicates the journal cartridge is empty. (inherited from PosPrinter)
ExtendedErrorJournalCartridgeRemoved | Indicates the journal cartridge has been removed. (inherited from PosPrinter)
ExtendedErrorJournalEmpty | Indicates the journal station is out of paper. (inherited from PosPrinter)
ExtendedErrorJournalHeadCleaning | Indicates the journal cartridge head is being cleaned. (inherited from PosPrinter)
ExtendedErrorReceiptCartridgeEmpty | Indicates the receipt cartridge is empty. (inherited from PosPrinter)
ExtendedErrorReceiptCartridgeRemoved | Indicates the receipt cartridge has been removed. (inherited from PosPrinter)
ExtendedErrorReceiptEmpty | Indicates the receipt station is out of paper. (inherited from PosPrinter)
ExtendedErrorReceiptHeadCleaning | Indicates the receipt cartridge head is being cleaned. (inherited from PosPrinter)
ExtendedErrorSlipCartridgeEmpty | Indicates the slip cartridge is empty. (inherited from PosPrinter)
ExtendedErrorSlipCartridgeRemoved | Indicates the slip cartridge has been removed. (inherited from PosPrinter)
ExtendedErrorSlipEmpty | Indicates a form has not been inserted into the slip station. (inherited from PosPrinter)
ExtendedErrorSlipForm | Indicates a form is present while the printer is being taken out of from removal mode. (inherited from PosPrinter)
ExtendedErrorSlipHeadCleaning | Indicates the slip cartridge head is being cleaned. (inherited from PosPrinter)
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
ExtendedErrorTooBig | Indicates the bitmap is either too wide to print without transformation, or too big to tranform. (inherited from PosPrinter)
PrinterBarCodeCenter | Indicates the bar code should be printed aligned with the center of the station. (inherited from PosPrinter)
PrinterBarCodeLeft | Indicates the bar code should be printed aligned with the leftmost print column. (inherited from PosPrinter)
PrinterBarCodeRight | Indicates the bar code should be printed aligned with the rightmost print column. (inherited from PosPrinter)
PrinterBitmapAsIs | Indicates the bitmap should be printed with one bitmap pixel per printer dot. (inherited from PosPrinter)
PrinterBitmapCenter | Indicates the bitmap should be printed aligned with the center of the station. (inherited from PosPrinter)
PrinterBitmapLeft | Indicates the bitmap should be printed aligned with the leftmost print column. (inherited from PosPrinter)
PrinterBitmapRight | Indicates the bitmap should be printed aligned with the rightmost print column. (inherited from PosPrinter)
PrinterCutPaperFullCut | Indicates a full paper cut. (inherited from PosPrinter)
StatisticBarcodePrintedCount | Incremented when a bar code is successfully printed. (inherited from PosPrinter)
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFailedPaperCutCount | Incremented for each failed paper cut. (inherited from PosPrinter)
StatisticFailedPrintSideChangeCount | Incremented for each failed print side change or failed check flip. (inherited from PosPrinter)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticFormInsertionCount | Incremented when a form is successfully inserted into the document/slip station. (inherited from PosPrinter)
StatisticHomeErrorCount | Incremented when a home error occurs. (inherited from PosPrinter)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticJournalCharacterPrintedCount | Incremented for every journal character printed. (inherited from PosPrinter)
StatisticJournalCoverOpenCount | Incremented every time that the document/slip station cover opened. (inherited from PosPrinter)
StatisticJournalLinePrintedCount | Incremented for each journal line printed. (inherited from PosPrinter)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMaximumTempReachedCount | Incremented every time that maximum temperature is reached. (inherited from PosPrinter)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticNVRAMWriteCount | Incremented every time that NVRAM is written to. (inherited from PosPrinter)
StatisticPaperCutCount | Incremented every time that paper is cut successfully. (inherited from PosPrinter)
StatisticPrinterFaultCount | Incremented when a printer fault occurs. (inherited from PosPrinter)
StatisticPrintSideChangeCount | Incremented when the print side changes or a check flips. (inherited from PosPrinter)
StatisticReceiptCharacterPrintedCount | Incremented every time that a receipt character is printed. (inherited from PosPrinter)
StatisticReceiptCoverOpenCount | Incremented every time that the receipt cover opened. (inherited from PosPrinter)
StatisticReceiptLineFeedCount | Incremented every time that a receipt line feed is performed. (inherited from PosPrinter)
StatisticReceiptLinePrintedCount | Incremented every time that a receipt line is printed. (inherited from PosPrinter)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticSlipCharacterPrintedCount | Incremented every time that a slip character is printed. (inherited from PosPrinter)
StatisticSlipCoverOpenCount | Incremented every time that the slip cover opened. (inherited from PosPrinter)
StatisticSlipLineFeedCount | Incremented every time that a slip line feed is performed. (inherited from PosPrinter)
StatisticSlipLinePrintedCount | Incremented every time that a slip line is printed. (inherited from PosPrinter)
StatisticStampFiredCount | Incremented for each Stamp raised. (inherited from PosPrinter)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusCoverOK | Indicates the printer cover is closed. (inherited from PosPrinter)
StatusCoverOpen | Indicates the printer cover is open. (inherited from PosPrinter)
StatusIdle | Indicates all asynchronous output is finished, either successfully or because the output has been cleared. The printer State property is now set to ControlState.Idle. (inherited from PosPrinter)
StatusJournalCartridgeEmpty | Indicates the journal cartridge has to be replaced. (inherited from PosPrinter)
StatusJournalCartridgeNearEmpty | Indicates the journal cartridge is near its end. (inherited from PosPrinter)
StatusJournalCartridgeOK | Indicates all journal cartridges are ready. (inherited from PosPrinter)
StatusJournalCoverOK | Indicates the journal cover is closed. (inherited from PosPrinter)
StatusJournalCoverOpen | Indicates the journal cover is open. (inherited from PosPrinter)
StatusJournalEmpty | Indicates there is no journal paper. (inherited from PosPrinter)
StatusJournalHeadCleaning | Indicates the journal cartridge has begun head cleaning. (inherited from PosPrinter)
StatusJournalNearEmpty | Indicates the journal paper is low. (inherited from PosPrinter)
StatusJournalPaperOK | Indicates the journal paper is ready. (inherited from PosPrinter)
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusReceiptCartridgeEmpty | Indicates the receipt cartridge has to be replaced. (inherited from PosPrinter)
StatusReceiptCartridgeNearEmpty | Indicates the receipt cartridge is nearing empty. (inherited from PosPrinter)
StatusReceiptCartridgeOK | Indicates all receipt cartridges are ready. (inherited from PosPrinter)
StatusReceiptCoverOK | Indicates the receipt cover is closed. (inherited from PosPrinter)
StatusReceiptCoverOpen | Indicates the receipt cover is open. (inherited from PosPrinter)
StatusReceiptEmpty | Indicates there is no receipt paper. (inherited from PosPrinter)
StatusReceiptHeadCleaning | Indicates the receipt cartridge has begun head cleaning. (inherited from PosPrinter)
StatusReceiptNearEmpty | Indicates the receipt paper is low. (inherited from PosPrinter)
StatusReceiptPaperOK | Indicates the receipt paper is ready. (inherited from PosPrinter)
StatusSlipCartridgeEmpty | Indicates the slip cartridge has to be replaced. (inherited from PosPrinter)
StatusSlipCartridgeNearEmpty | Indicates the slip cartridge is nearing empty. (inherited from PosPrinter)
StatusSlipCartridgeOK | Indicates all slip cartridges are ready. (inherited from PosPrinter)
StatusSlipCoverOK | Indicates the slip cover is closed. (inherited from PosPrinter)
StatusSlipCoverOpen | Indicates the slip cover is open. (inherited from PosPrinter)
StatusSlipEmpty | Indicates that no slip form is inserted and no slip form has been detected at the entrance to the slip station. (inherited from PosPrinter)
StatusSlipHeadCleaning | Indicates the receipt cartridge has begun head cleaning. (inherited from PosPrinter)
StatusSlipNearEmpty | Indicates the slip form is close to the bottom. (inherited from PosPrinter)
StatusSlipPaperOK | Indicates the slip form is inserted. (inherited from PosPrinter)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
AsyncMode | Overridden. Indicates whether certain print methods will be performed asynchronously.
CapCharacterSet | Overridden. Holds the default character set capability.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosPrinterBasic)
CapConcurrentJrnRec | Overridden. Indicates whether Journal and receipt stations can print at the same time.
CapConcurrentJrnSlp | Overridden. Indicates whether journal and slip stations can print at the same time.
CapConcurrentPageMode | Overridden. Indicates whether the printer is capable of supporting page mode for the receipt and slip stations concurrently.
CapConcurrentRecSlp | Overridden. Indicates whether receipt and slip stations can print at the same time.
CapCoverSensor | Overridden. Indicates whether the printer has a “cover open” sensor.
CapJrn2Color | Overridden. Indicates whether the journal can print dark plus an alternate color.
CapJrnBold | Overridden. Indicates whether the journal can print bold characters.
CapJrnCartridgeSensor | Overridden. Indicates the presence of journal cartridge monitoring sensors.
CapJrnColor | Overridden. Indicates available journal color cartridges.
CapJrnDHigh | Overridden. Indicates whether the journal can print double-high characters.
CapJrnDWide | Overridden. Indicates whether the journal can print double-wide characters.
CapJrnDWideDHigh | Overridden. Indicates whether the journal can print double-wide and double-high characters.
CapJrnEmptySensor | Overridden. Indicates whether the journal has an out-of-paper sensor.
CapJrnItalic | Overridden. Indicates whether the journal can print italic characters.
CapJrnNearEndSensor | Overridden. Indicates whether the journal has a low-paper sensor.
CapJrnPresent | Overridden. Indicates whether the journal print station is present.
CapJrnUnderline | Overridden. Indicates whether the journal can underline characters.
CapMapCharacterSet | Overridden. Indicates that the service object is able to map the characters sent my the application to a character set defined by the CharacterSetList property.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosPrinterBasic)
CapRec2Color | Overridden. Indicates whether the receipt can print dark plus an alternate color.
CapRecBarCode | Overridden. Indicates whether the receipt has bar code printing capability.
CapRecBitmap | Overridden. Indicates whether the receipt can print bitmaps.
CapRecBold | Overridden. Indicates whether the receipt can print bold text.
CapRecCartridgeSensor | Overridden. Indicates the presence of receipt cartridge monitoring sensors.
CapRecColor | Overridden. Indicates the receipt color cartridges.
CapRecDHigh | Overridden. Indicates whether the receipt can print double-high characters.
CapRecDWide | Overridden. Indicates whether the receipt can print double-wide characters.
CapRecDWideDHigh | Overridden. Indicates whether the receipt can print double-wide, double-high characters.
CapRecEmptySensor | Overridden. Indicates whether the receipt print station has an out-of-paper sensor.
CapRecItalic | Overridden. Indicates whether the receipt can print italic text.
CapRecLeft90 | Overridden. Indicates whether the receipt can print in rotated-90-degree-left mode.
CapRecMarkFeed | Overridden. Holds the type of mark-sensed paper handling available.
CapRecNearEndSensor | Overridden. Indicates whether the receipt has a low-paper sensor.
CapRecPageMode | Overridden. Gets a Boolean value that indicates whether the printer can support Page Mode for the receipt station.
CapRecPaperCut | Overridden. Indicates whether the receipt can perform paper cuts.
CapRecPresent | Overridden. Indicates that the receipt print station is present.
CapRecRight90 | Overridden. Indicates that the receipt can print in a rotated-90-degree-right mode.
CapRecRotate180 | Overridden. Indicates that the receipt can print in a rotated-180-degree mode.
CapRecStamp | Overridden. Indicates that the receipt has a stamp capability.
CapRecUnderline | Overridden. Indicates whether the receipt can underline characters.
CapSlp2Color | Overridden. Indicates that the slip can print dark plus an alternate color.
CapSlpBarCode | Overridden. Indicates that the slip has bar code printing capability.
CapSlpBitmap | Overridden. Indicates that the slip can print bitmaps.
CapSlpBold | Overridden. Indicates that the slip can print bold text.
CapSlpBothSidesPrint | Overridden. Indicates that the slip print station supports printing on both sides of the document.
CapSlpCartridgeSensor | Overridden. Indicates the presence of slip-cartridge monitoring sensors.
CapSlpColor | Overridden. Indicates which types of color cartridges supported for slip printing.
CapSlpDHigh | Overridden. Indicates that the slip can print double-high characters.
CapSlpDWide | Overridden. Indicates that the slip can print double-wide characters.
CapSlpDWideDHigh | Overridden. Indicates that the slip can print double-wide, double-high characters.
CapSlpEmptySensor | Overridden. Indicates that the slip has a “slip in” sensor.
CapSlpFullSlip | Overridden. Indicates whether the printer supports printing full-length forms on the slip station.
CapSlpItalic | Overridden. Indicates that the slip can print italic characters.
CapSlpLeft90 | Overridden. Indicates that the slip can print in a rotated 90 degree left mode.
CapSlpNearEndSensor | Overridden. Indicates whether the slip has a "slip near end" sensor.
CapSlpPageMode | Overridden. Indicates whether the printer is capable of supporting Page Mode for the slip station.
CapSlpPresent | Overridden. Indicates that the printer has a slip station.
CapSlpRight90 | Overridden. Indicates that the slip can print in a rotated 90 degree right mode.
CapSlpRotate180 | Overridden. Indicates that the slip can print in a rotated 180 degree mode.
CapSlpUnderline | Overridden. Indicates that the slip can print underlined characters.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosPrinterBasic)
CapTransaction | Overridden. Indicates whether or not each station supports printer transactions.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosPrinterBasic)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosPrinterBasic)
CartridgeNotify | Overridden. Holds the type of cartridge state notification the application wants to receive.
CharacterSet | Overridden. Holds a numeric value indicating the character set the application wants to use for printing characters.
CharacterSetList | Overridden. Holds a list of character set numbers supported for printing.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosPrinterBasic)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
CoverOpen | Overridden. Indicates the cover is open.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosPrinterBasic)
DeviceEnabled | Overridden. Gets or sets a Boolean value that indicates whether the device has been placed in an operational state.
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosPrinterBasic)
ErrorLevel | Overridden. Holds the severity of the most recent error condition.
ErrorStation | Overridden. Holds the station or stations that were printing when an error was detected.
ErrorString | Overridden. Holds a vendor-supplied description of the current error.
FlagWhenIdle | Overridden. If set to true by the application, the service object will queue a StatusUpdateEvent event using the StatusIdle constant when the device is in an idle state, and reset FlagWhenIdle to false.
FontTypefaceList | Overridden. Holds a string array that specifies the fonts and/or typefaces supported by the printer.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosPrinterBasic)
JrnCartridgeState | Overridden. Holds the status of the selected journal cartridge (ink, ribbon, or toner).
JrnCurrentCartridge | Overridden. Holds the currently selected journal cartridge.
JrnEmpty | Overridden. If set to true, the journal is out of paper.
JrnLetterQuality | Overridden. If true, prints in high-quality mode. If false, prints in high-speed mode.
JrnLineChars | Overridden. Holds the number of characters that the application wants to print on a journal line.
JrnLineCharsList | Overridden. Holds a collection of the line widths (characters per line) supported by the journal station.
JrnLineHeight | Overridden. Holds the journal print line height the application wants to use, expressed in the unit of measure indicated by the MapMode property setting.
JrnLineSpacing | Overridden. Holds the spacing of each single-high print line, including both the printed line height and the white space between each pair of lines that the application wants to use.
JrnLineWidth | Overridden. Holds the width of a line for the number of characters indicated by the JrnLineChars property, expressed in the unit of measure indicated by the MapMode property.
JrnNearEnd | Overridden. If true, the journal paper is low.
MapCharacterSet | Overridden. If set to true by the application while outputting data, the service object maps the characters transferred by the application to the character set selected in the CharacterSet property.
MapMode | Overridden. Holds the mapping mode of the printer the application wants to use.
OutputId | Gets the identifier associated with the current output request. (inherited from PosPrinterBasic)
PageModeArea | Overridden. Holds the page area for the selected PageModeStation expressed in the unit of measure given by MapMode.
PageModeDescriptor | Overridden. Holds a value that indicates the level of basic Page Mode functionality for the printer.
PageModeHorizontalPosition | Overridden. Holds the horizontal start position offset within the print area for the selected PageModeStation, expressed in the unit of measure given by MapMode.
PageModePrintArea | Overridden. Holds the print area for the selected PageModeStation expressed in the unit of measure given by MapMode.
PageModePrintDirection | Overridden. Holds the print direction.
PageModeStation | Overridden. Gets and sets the print station for use by other Page Mode properties
PageModeVerticalPosition | Overridden. Holds the vertical start position offset within the print area for the selected PageModeStation.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosPrinterBasic)
PowerState | Gets the current power condition. (inherited from PosPrinterBasic)
RecBarCodeRotationList | Overridden. Holds a list of the directions in which a receipt bar code can be rotated.
RecBitmapRotationList | Overridden. Holds a list of the directions in which a receipt bitmap can be rotated.
RecCartridgeState | Overridden. Holds the status of the selected receipt cartridge (ink, ribbon or toner).
RecCurrentCartridge | Overridden. Holds the receipt cartridge currently selected by the application.
RecEmpty | Overridden. If true, the receipt is out of paper.
RecLetterQuality | Overridden. If true, prints in high-quality mode. If false, prints in high-speed mode.
RecLineChars | Overridden. Holds the number of characters that the application wants to print on a receipt line.
RecLineCharsList | Overridden. Holds a collection of the line widths (characters per line) supported by the receipt station.
RecLineHeight | Overridden. Holds the receipt print line height, expressed in the unit of measure indicated by the MapMode property setting, that the application wants to use.
RecLineSpacing | Overridden. Holds the spacing of each single-high print line, including both the printed line height and the white space between each pair of lines, that the application wants to use.
RecLinesToPaperCut | Overridden. Holds the number of lines that must be advanced before cutting the receipt paper.
RecLineWidth | Overridden. Holds the width of a line, based on the number of characters specified in the RecLineChars property, expressed in the unit of measure indicated by the MapMode property.
RecNearEnd | Overridden. If true, the receipt paper is low.
RecSidewaysMaxChars | Overridden. Holds the maximum number of characters that can be printed on each line in sideways mode.
RecSidewaysMaxLines | Overridden. Holds the maximum number of lines that can be printed in sideways mode.
RotateSpecial | Overridden. Holds the rotation orientation for bar codes that the application wants to use.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosPrinterBasic)
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosPrinterBasic)
SlpBarCodeRotationList | Overridden. Holds a collection of the directions in which a slip bar code may be rotated.
SlpBitmapRotationList | Overridden. Holds a collection of the directions in which a slip bitmap can be rotated.
SlpCartridgeState | Overridden. Holds the status of the selected slip cartridge (ink, ribbon, or toner).
SlpCurrentCartridge | Overridden. Holds the slip cartridge the application wants to use.
SlpEmpty | Overridden. If true, a slip form is not present.
SlpLetterQuality | Overridden. If true, prints in high-quality mode. If false, prints in high-speed mode.
SlpLineChars | Overridden. Holds the number of characters that the application wants to print on a slip line.
SlpLineCharsList | Overridden. Holds a collection of the line widths (characters per line) supported by the slip station.
SlpLineHeight | Overridden. Holds the slip print-line height, expressed in the unit of measure indicated by the MapMode property setting, that the application wants to use.
SlpLinesNearEndToEnd | Overridden. Holds the number of lines that can be printed after the SlpNearEnd property has been set to true but before the printer reaches the end of the slip.
SlpLineSpacing | Overridden. Holds the spacing of each single-high print line, including both the printed line height and the white space between each pair of lines that the application wants to use.
SlpLineWidth | Overridden. Holds the line width, based on the number of characters specified for the SlpLineChars property, expressed in the unit of measure indicated by the MapMode property.
SlpMaxLines | Overridden. Holds the maximum number of lines that can be printed on a form.
SlpNearEnd | Overridden. If true, the slip form is near its end.
SlpPrintSide | Overridden. Holds the side of the slip print station document on which printing will occur.
SlpSidewaysMaxChars | Overridden. Holds the maximum number of characters that can be printed on each line in sideways mode.
SlpSidewaysMaxLines | Overridden. Holds the maximum number of lines that can be printed in sideways mode.
State | Gets the current state of the device. (inherited from PosPrinterBasic)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Top

Protected Properties

Name | Description
CommonProperties | (inherited from PosPrinterBasic )
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
ErrorCount | (inherited from PosPrinterBasic )
ExternallyClaimed | (inherited from PosPrinterBasic )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Gets a Boolean value that indicates whether the PosPrinter is an exclusive-use device. (inherited from PosPrinter)
OutputCount |
Properties | Returns a class of writable properties that can be used to modify the read-only properties used by applications.
StopCurrentOutput | Indicates whether output is stopped.
UseExternalPrintQueue | Indicates whether an external print queue is used.
Top

Public Methods (see also Protected Methods )

Name | Description
BeginInsertion | Overridden. Initiates form insertion processing. BeginInsertion is paired with the EndInsertion method to control form insertion.
BeginRemoval | Overridden. Initiates form removal processing.
ChangePrintSide | Overridden. Selects the side of the document it wants to print on.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosPrinterBasic )
ClearOutput | Overridden. Clears all device output that has been buffered. Also, when possible, to halt outputs that are in progress.
ClearPrintArea | Overridden. Clears the area defined by the PageModePrintArea property.
Close | Releases the device and its resources. (inherited from PosPrinterBasic)
CompareFirmwareVersion | (inherited from PosCommon )
CutPaper | Overridden. Cuts the receipt paper.
DirectIO | (inherited from PosCommon )
Dispose | Overloaded.
EndInsertion | Overridden. Ends form-insertion processing.
EndRemoval | Overridden. Ends form-removal processing.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
MarkFeed | Overridden. Holds the type of mark-sensed paper handling available.
Open | Overridden. Opens a device for later input/output processing.
PageModePrint | Overridden. Enters or exits Page Mode for the station specified in the PageModeStation property.
PrintBarCode | Overridden. Prints a bar code on the specified printer station.
PrintBitmap | Overridden. Prints a bitmap on the specified printer station.
PrintImmediate | Overridden. Immediately prints the string specified for data on the printer station specified by station.
PrintMemoryBitmap | Overridden. Prints a memory-stored bitmap on the specified printer station.
PrintNormal | Overridden. Prints the string specified in data on the printer station specified in station.
PrintTwoNormal | Overridden. Prints two strings on two print stations simultaneously. When supported, this may give increased print performance.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosPrinterBasic)
ResetStatistic | (inherited from PosPrinterBasic )
ResetStatistics | Overloaded. (inherited from PosPrinterBasic )
RetrieveStatistic | (inherited from PosPrinterBasic )
RetrieveStatistics | Overloaded. (inherited from PosPrinterBasic )
RotatePrint | Overridden. Enters or exits rotated print mode.
SetBitmap | Overridden. Saves information about a bitmap for later printing.
SetLogo | Overridden. Saves a data string as the top or bottom logo.
ToString | (inherited from Object )
TransactionPrint | Overridden. Enters or exits transaction mode.
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosPrinterBasic )
UpdateStatistics | Overloaded. (inherited from PosPrinterBasic )
ValidateData | Overridden. Validates data for a specified printer station.
Top

Protected Methods

Name | Description
BeginInsertionImpl | Implemented by service objects to process BeginInsertion requests.
BeginRemovalImpl | Implemented by service objects to process BeginRemoval requests.
ChangePrintSideImpl | Method implemented by service objects to process ChangePrintSide requests.
ClearOutputImpl | (inherited from PosPrinterBasic )
CreateStatistic | Overloaded. (inherited from PosPrinterBasic )
CutPaperImpl | Method implemented by the service object to process CutPaper requests.
DeleteConfigurationProperty | (inherited from PosCommon )
Dispose | Overloaded. Overridden.
EndInsertionImpl | Method implemented by the service object to process EndInsertion requests.
EndRemovalImpl | Method implemented by service objects to process EndRemoval requests.
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
GetStatisticValue | (inherited from PosPrinterBasic )
IncrementStatistic | Overloaded. (inherited from PosPrinterBasic )
Invoke | (inherited from PosCommon )
MarkFeedImpl | Method implemented by the service object to process MarkFeed requests.
MemberwiseClone | (inherited from Object )
PageModePrintImpl | Method implemented by service objects to process PageModePrint requests.
PreFireEvent | Overloaded. Overridden.
PreQueuePrintData | This method is called before print requests are added to the print queue.
PrintBarCodeImpl | Overloaded.
PrintBitmapImpl | Overloaded.
PrintImmediateImpl | Overloaded.
PrintMemoryBitmapImpl | Method implemented by service objects to process PrintMemoryBitmap requests.
PrintNormalImpl | Method implemented by service objects to process PrintNormal requests.
PrintTwoNormalImpl | Method implemented by service objects to process PrintTwoNormal requests.
QueueEvent | Overloaded. (inherited from PosPrinterBasic )
QueueEventAndWait | Overloaded. (inherited from PosPrinterBasic )
RotatePrintImpl | Method implemented by service objects to process RotatePrint requests.
SetBitmapImpl | Method implemented on service objects to process SetBitmap requests.
SetConfigurationProperty | (inherited from PosCommon )
SetStatisticHandlers | (inherited from PosPrinterBasic )
SetStatisticValue | (inherited from PosPrinterBasic )
TransactionPrintImpl | Method implemented by service objects to process TransactionPrint requests.
ValidateDataImpl | Method implemented by the service object to process ValidateData requests.
VerifyState | (inherited from PosPrinterBasic )
Top

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosPrinterBasic)
ErrorEvent | Queued by the service object when an error is detected and the device’s State transitions into the error state. (inherited from PosPrinterBasic)
OutputCompleteEvent | Queued by the service object to notify the application when asynchronous processing that corresponds to an OutputID has successfully completed. (inherited from PosPrinterBasic)
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosPrinterBasic)
Top

Protected Events

Name | Description
CancelPrintEvent | Raised when the current print operation should be cancelled.
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
StateChangedEvent | (inherited from PosPrinterBasic )
Top

See Also

Reference

PosPrinterBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace

Other Resources

Using Impl Methods for Synchronous or Asynchronous Output


PosPrinterBase Fields

PosPrinterBase Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
CharacterSetAnsi | Indicates the default character set supports the ANSI character set. (inherited from PosPrinter )
CharacterSetAscii | Indicates the default character set supports the ASCII character set. (inherited from PosPrinter )
CharacterSetUnicode | Indicates the default character set supports the Unicode character set. (inherited from PosPrinter )
ExtendedErrorBadFormat | Indicates an unsupported format. (inherited from PosPrinter )
ExtendedErrorCoverOpen | Indicates that the printer cover is open. (inherited from PosPrinter )
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorJournalCartridgeEmpty | Indicates the journal cartridge is empty. (inherited from PosPrinter )
ExtendedErrorJournalCartridgeRemoved | Indicates the journal cartridge has been removed. (inherited from PosPrinter )
ExtendedErrorJournalEmpty | Indicates the journal station is out of paper. (inherited from PosPrinter )
ExtendedErrorJournalHeadCleaning | Indicates the journal cartridge head is being cleaned. (inherited from PosPrinter )
ExtendedErrorReceiptCartridgeEmpty | Indicates the receipt cartridge is empty. (inherited from PosPrinter )
ExtendedErrorReceiptCartridgeRemoved | Indicates the receipt cartridge has been removed. (inherited from PosPrinter )
ExtendedErrorReceiptEmpty | Indicates the receipt station is out of paper. (inherited from PosPrinter )
ExtendedErrorReceiptHeadCleaning | Indicates the receipt cartridge head is being cleaned. (inherited from PosPrinter )
ExtendedErrorSlipCartridgeEmpty | Indicates the slip cartridge is empty. (inherited from PosPrinter )
ExtendedErrorSlipCartridgeRemoved | Indicates the slip cartridge has been removed. (inherited from PosPrinter )
ExtendedErrorSlipEmpty | Indicates a form has not been inserted into the slip station. (inherited from PosPrinter )
ExtendedErrorSlipForm | Indicates a form is present while the printer is being taken out of from removal mode. (inherited from PosPrinter )
ExtendedErrorSlipHeadCleaning | Indicates the slip cartridge head is being cleaned. (inherited from PosPrinter )
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
ExtendedErrorTooBig | Indicates the bitmap is either too wide to print without transformation, or too big to tranform. (inherited from PosPrinter )
PrinterBarCodeCenter | Indicates the bar code should be printed aligned with the center of the station. (inherited from PosPrinter )
PrinterBarCodeLeft | Indicates the bar code should be printed aligned with the leftmost print column. (inherited from PosPrinter )
PrinterBarCodeRight | Indicates the bar code should be printed aligned with the rightmost print column. (inherited from PosPrinter )
PrinterBitmapAsIs | Indicates the bitmap should be printed with one bitmap pixel per printer dot. (inherited from PosPrinter )
PrinterBitmapCenter | Indicates the bitmap should be printed aligned with the center of the station. (inherited from PosPrinter )
PrinterBitmapLeft | Indicates the bitmap should be printed aligned with the leftmost print column. (inherited from PosPrinter )
PrinterBitmapRight | Indicates the bitmap should be printed aligned with the rightmost print column. (inherited from PosPrinter )
PrinterCutPaperFullCut | Indicates a full paper cut. (inherited from PosPrinter )
StatisticBarcodePrintedCount | Incremented when a bar code is successfully printed. (inherited from PosPrinter )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFailedPaperCutCount | Incremented for each failed paper cut. (inherited from PosPrinter )
StatisticFailedPrintSideChangeCount | Incremented for each failed print side change or failed check flip. (inherited from PosPrinter )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticFormInsertionCount | Incremented when a form is successfully inserted into the document/slip station. (inherited from PosPrinter )
StatisticHomeErrorCount | Incremented when a home error occurs. (inherited from PosPrinter )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticJournalCharacterPrintedCount | Incremented for every journal character printed. (inherited from PosPrinter )
StatisticJournalCoverOpenCount | Incremented every time that the document/slip station cover opened. (inherited from PosPrinter )
StatisticJournalLinePrintedCount | Incremented for each journal line printed. (inherited from PosPrinter )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMaximumTempReachedCount | Incremented every time that maximum temperature is reached. (inherited from PosPrinter )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticNVRAMWriteCount | Incremented every time that NVRAM is written to. (inherited from PosPrinter )
StatisticPaperCutCount | Incremented every time that paper is cut successfully. (inherited from PosPrinter )
StatisticPrinterFaultCount | Incremented when a printer fault occurs. (inherited from PosPrinter )
StatisticPrintSideChangeCount | Incremented when the print side changes or a check flips. (inherited from PosPrinter )
StatisticReceiptCharacterPrintedCount | Incremented every time that a receipt character is printed. (inherited from PosPrinter )
StatisticReceiptCoverOpenCount | Incremented every time that the receipt cover opened. (inherited from PosPrinter )
StatisticReceiptLineFeedCount | Incremented every time that a receipt line feed is performed. (inherited from PosPrinter )
StatisticReceiptLinePrintedCount | Incremented every time that a receipt line is printed. (inherited from PosPrinter )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticSlipCharacterPrintedCount | Incremented every time that a slip character is printed. (inherited from PosPrinter )
StatisticSlipCoverOpenCount | Incremented every time that the slip cover opened. (inherited from PosPrinter )
StatisticSlipLineFeedCount | Incremented every time that a slip line feed is performed. (inherited from PosPrinter )
StatisticSlipLinePrintedCount | Incremented every time that a slip line is printed. (inherited from PosPrinter )
StatisticStampFiredCount | Incremented for each Stamp raised. (inherited from PosPrinter )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusCoverOK | Indicates the printer cover is closed. (inherited from PosPrinter )
StatusCoverOpen | Indicates the printer cover is open. (inherited from PosPrinter )
StatusIdle | Indicates all asynchronous output is finished, either successfully or because the output has been cleared. The printer State property is now set to ControlState.Idle. (inherited from PosPrinter )
StatusJournalCartridgeEmpty | Indicates the journal cartridge has to be replaced. (inherited from PosPrinter )
StatusJournalCartridgeNearEmpty | Indicates the journal cartridge is near its end. (inherited from PosPrinter )
StatusJournalCartridgeOK | Indicates all journal cartridges are ready. (inherited from PosPrinter )
StatusJournalCoverOK | Indicates the journal cover is closed. (inherited from PosPrinter )
StatusJournalCoverOpen | Indicates the journal cover is open. (inherited from PosPrinter )
StatusJournalEmpty | Indicates there is no journal paper. (inherited from PosPrinter )
StatusJournalHeadCleaning | Indicates the journal cartridge has begun head cleaning. (inherited from PosPrinter )
StatusJournalNearEmpty | Indicates the journal paper is low. (inherited from PosPrinter )
StatusJournalPaperOK | Indicates the journal paper is ready. (inherited from PosPrinter )
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusReceiptCartridgeEmpty | Indicates the receipt cartridge has to be replaced. (inherited from PosPrinter )
StatusReceiptCartridgeNearEmpty | Indicates the receipt cartridge is nearing empty. (inherited from PosPrinter )
StatusReceiptCartridgeOK | Indicates all receipt cartridges are ready. (inherited from PosPrinter )
StatusReceiptCoverOK | Indicates the receipt cover is closed. (inherited from PosPrinter )
StatusReceiptCoverOpen | Indicates the receipt cover is open. (inherited from PosPrinter )
StatusReceiptEmpty | Indicates there is no receipt paper. (inherited from PosPrinter )
StatusReceiptHeadCleaning | Indicates the receipt cartridge has begun head cleaning. (inherited from PosPrinter )
StatusReceiptNearEmpty | Indicates the receipt paper is low. (inherited from PosPrinter )
StatusReceiptPaperOK | Indicates the receipt paper is ready. (inherited from PosPrinter )
StatusSlipCartridgeEmpty | Indicates the slip cartridge has to be replaced. (inherited from PosPrinter )
StatusSlipCartridgeNearEmpty | Indicates the slip cartridge is nearing empty. (inherited from PosPrinter )
StatusSlipCartridgeOK | Indicates all slip cartridges are ready. (inherited from PosPrinter )
StatusSlipCoverOK | Indicates the slip cover is closed. (inherited from PosPrinter )
StatusSlipCoverOpen | Indicates the slip cover is open. (inherited from PosPrinter )
StatusSlipEmpty | Indicates that no slip form is inserted and no slip form has been detected at the entrance to the slip station. (inherited from PosPrinter )
StatusSlipHeadCleaning | Indicates the receipt cartridge has begun head cleaning. (inherited from PosPrinter )
StatusSlipNearEmpty | Indicates the slip form is close to the bottom. (inherited from PosPrinter )
StatusSlipPaperOK | Indicates the slip form is inserted. (inherited from PosPrinter )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

PosPrinterBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace

Other Resources

Using Impl Methods for Synchronous or Asynchronous Output


PosPrinterBase Constructor

PosPrinterBase Constructor |
 | See Also

1/18/2008

Creates a new instance of the PosPrinterBase class.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Sub New
protected PosPrinterBase ()
protected:
PosPrinterBase ()
protected PosPrinterBase ()
protected function PosPrinterBase ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase Methods

PosPrinterBase Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
BeginInsertion | Overridden. Initiates form insertion processing. BeginInsertion is paired with the EndInsertion method to control form insertion.
BeginRemoval | Overridden. Initiates form removal processing.
ChangePrintSide | Overridden. Selects the side of the document it wants to print on.
CheckHealth | (inherited from PosCommon )
Claim | (inherited from PosPrinterBasic )
ClearOutput | Overridden. Clears all device output that has been buffered. Also, when possible, to halt outputs that are in progress.
ClearPrintArea | Overridden. Clears the area defined by the PageModePrintArea property.
Close | Releases the device and its resources. (inherited from PosPrinterBasic )
CompareFirmwareVersion | (inherited from PosCommon )
CutPaper | Overridden. Cuts the receipt paper.
DirectIO | (inherited from PosCommon )
Dispose | Overloaded.
EndInsertion | Overridden. Ends form-insertion processing.
EndRemoval | Overridden. Ends form-removal processing.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
MarkFeed | Overridden. Holds the type of mark-sensed paper handling available.
Open | Overridden. Opens a device for later input/output processing.
PageModePrint | Overridden. Enters or exits Page Mode for the station specified in the PageModeStation property.
PrintBarCode | Overridden. Prints a bar code on the specified printer station.
PrintBitmap | Overridden. Prints a bitmap on the specified printer station.
PrintImmediate | Overridden. Immediately prints the string specified for data on the printer station specified by station.
PrintMemoryBitmap | Overridden. Prints a memory-stored bitmap on the specified printer station.
PrintNormal | Overridden. Prints the string specified in data on the printer station specified in station.
PrintTwoNormal | Overridden. Prints two strings on two print stations simultaneously. When supported, this may give increased print performance.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from PosPrinterBasic )
ResetStatistic | (inherited from PosPrinterBasic )
ResetStatistics | Overloaded. (inherited from PosPrinterBasic )
RetrieveStatistic | (inherited from PosPrinterBasic )
RetrieveStatistics | Overloaded. (inherited from PosPrinterBasic )
RotatePrint | Overridden. Enters or exits rotated print mode.
SetBitmap | Overridden. Saves information about a bitmap for later printing.
SetLogo | Overridden. Saves a data string as the top or bottom logo.
ToString | (inherited from Object )
TransactionPrint | Overridden. Enters or exits transaction mode.
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from PosPrinterBasic )
UpdateStatistics | Overloaded. (inherited from PosPrinterBasic )
ValidateData | Overridden. Validates data for a specified printer station.

Protected Methods

Name | Description
BeginInsertionImpl | Implemented by service objects to process BeginInsertion requests.
BeginRemovalImpl | Implemented by service objects to process BeginRemoval requests.
ChangePrintSideImpl | Method implemented by service objects to process ChangePrintSide requests.
ClearOutputImpl | (inherited from PosPrinterBasic )
CreateStatistic | Overloaded. (inherited from PosPrinterBasic )
CutPaperImpl | Method implemented by the service object to process CutPaper requests.
DeleteConfigurationProperty | (inherited from PosCommon )
Dispose | Overloaded. Overridden.
EndInsertionImpl | Method implemented by the service object to process EndInsertion requests.
EndRemovalImpl | Method implemented by service objects to process EndRemoval requests.
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
GetStatisticValue | (inherited from PosPrinterBasic )
IncrementStatistic | Overloaded. (inherited from PosPrinterBasic )
Invoke | (inherited from PosCommon )
MarkFeedImpl | Method implemented by the service object to process MarkFeed requests.
MemberwiseClone | (inherited from Object )
PageModePrintImpl | Method implemented by service objects to process PageModePrint requests.
PreFireEvent | Overloaded. Overridden.
PreQueuePrintData | This method is called before print requests are added to the print queue.
PrintBarCodeImpl | Overloaded.
PrintBitmapImpl | Overloaded.
PrintImmediateImpl | Overloaded.
PrintMemoryBitmapImpl | Method implemented by service objects to process PrintMemoryBitmap requests.
PrintNormalImpl | Method implemented by service objects to process PrintNormal requests.
PrintTwoNormalImpl | Method implemented by service objects to process PrintTwoNormal requests.
QueueEvent | Overloaded. (inherited from PosPrinterBasic )
QueueEventAndWait | Overloaded. (inherited from PosPrinterBasic )
RotatePrintImpl | Method implemented by service objects to process RotatePrint requests.
SetBitmapImpl | Method implemented on service objects to process SetBitmap requests.
SetConfigurationProperty | (inherited from PosCommon )
SetStatisticHandlers | (inherited from PosPrinterBasic )
SetStatisticValue | (inherited from PosPrinterBasic )
TransactionPrintImpl | Method implemented by service objects to process TransactionPrint requests.
ValidateDataImpl | Method implemented by the service object to process ValidateData requests.
VerifyState | (inherited from PosPrinterBasic )

See Also

Reference

PosPrinterBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace

Other Resources

Using Impl Methods for Synchronous or Asynchronous Output


PosPrinterBase.BeginInsertion Method

PosPrinterBase.BeginInsertion Method |
 | See Also

1/18/2008

Initiates form insertion processing. BeginInsertion is paired with the EndInsertion method to control form insertion.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub BeginInsertion ( _
    timeout As Integer _
)
public override void BeginInsertion (
    int timeout
)
public:
virtual void BeginInsertion (
    int timeout
) override
public void BeginInsertion (
    int timeout
)
public override function BeginInsertion (
    timeout : int
)

Parameters

timeout

The number of milliseconds before failing the method.

Remarks

The PosPrinterBase class verifies that the application has the device opened, claimed, and enabled. PosPrinterBase validates the parameters and device state, and it may throw PosControlException exceptions with the following ErrorCodes:

Value | Meaning
Timeout | BeginInsertion timed out (the value of the timeout parameter was exceeded) before form insertion mode was activated.
Busy | The printer device is currently in use.
Illegal | a) The slip print station is not present on this printer (that is, the CapSlpPresent property is set to false); b) The value given for timeout is less than -1; or c) the printer is currently in removal mode.

If no exceptions are thrown, PosPrinterBase class places the printer in insertion mode and calls BeginInsertionImpl.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.BeginInsertion Method


PosPrinterBase.BeginInsertionImpl Method

PosPrinterBase.BeginInsertionImpl Method |
 | See Also

1/18/2008

Implemented by service objects to process BeginInsertion requests.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overridable Sub BeginInsertionImpl ( _
    timeout As Integer _
)
protected virtual void BeginInsertionImpl (
    int timeout
)
protected:
virtual void BeginInsertionImpl (
    int timeout
)
protected void BeginInsertionImpl (
    int timeout
)
protected function BeginInsertionImpl (
    timeout : int
)

Parameters

timeout

The number of milliseconds before failing the method.

Remarks

Called by the PosPrinterBase.BeginInsertion method. By default, BeginInsertionImpl throws a NotImplemented exception, but if the printer supports a slip station, the service object must provide an implementation of BeginInsertionImpl that overrides the PosPrinterBase implementation, to handle the physical insertion of the slip into the slip station. The service object’s implementation should not call the base class implementation of the method.

For parameter definitions, see the underlying method.

BeginInsertionImpl throws PosControlException exceptions for all error conditions.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.BeginRemoval Method

PosPrinterBase.BeginRemoval Method |
 | See Also

1/18/2008

Initiates form removal processing.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub BeginRemoval ( _
    timeout As Integer _
)
public override void BeginRemoval (
    int timeout
)
public:
virtual void BeginRemoval (
    int timeout
) override
public void BeginRemoval (
    int timeout
)
public override function BeginRemoval (
    timeout : int
)

Parameters

timeout

The number of milliseconds before failing the method.

Remarks

The PosPrinterBase class verifies that the application has the device opened, claimed, and enabled. PosPrinterBase validates the parameters and device state, and may throw PosControlException exceptions with the following ErrorCodes:

Value | Meaning
Timeout | BeginRemoval timed out (the value of the timeout parameter was exceeded) before form removal mode was activated;
Busy | The printer device is currently in use; or
Illegal | a) The slip print station is not present on this printer (that is, the CapSlpPresent property is set to false); b) The value of timeout is less than -1; or c) the printer is currently in insertion mode.

If no exceptions are thrown, PosPrinterBase class places the printer in removal mode and calls BeginRemovalImpl.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.BeginRemoval Method


PosPrinterBase.BeginRemovalImpl Method

PosPrinterBase.BeginRemovalImpl Method |
 | See Also

1/18/2008

Implemented by service objects to process BeginRemoval requests.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overridable Sub BeginRemovalImpl ( _
    timeout As Integer _
)
protected virtual void BeginRemovalImpl (
    int timeout
)
protected:
virtual void BeginRemovalImpl (
    int timeout
)
protected void BeginRemovalImpl (
    int timeout
)
protected function BeginRemovalImpl (
    timeout : int
)

Parameters

timeout

The number of milliseconds before failing the method.

Remarks

Called by the PosPrinterBase.BeginRemoval method. By default, BeginRemovalImpl throws a NotImplemented exception, but if the printer supports a slip station, the service object must provide an implementation of BeginRemovalImpl that overrides the PosPrinterBase implementation, to handle the physical removal of the slip from the slip station. The service object’s implementation should not call the base class implementation of the method.

For parameter definitions, see the underlying method.

BeginRemovalImpl should throw PosControlException exceptions for all error conditions.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.ChangePrintSide Method

PosPrinterBase.ChangePrintSide Method |
 | See Also

1/18/2008

Selects the side of the document it wants to print on.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub ChangePrintSide ( _
    side As PrinterSide _
)
public override void ChangePrintSide (
    PrinterSide side
)
public:
virtual void ChangePrintSide (
    PrinterSide side
) override
public void ChangePrintSide (
    PrinterSide side
)
public override function ChangePrintSide (
    side : PrinterSide
)

Parameters

side

The side on which to print.

Remarks

The PosPrinterBase class verifies that the application has the device opened, claimed, and enabled. PosPrinterBase validates the parameters and device state, and may throw PosControlException exceptions with the following ErrorCodes:

Value | Meaning
Busy | The printer device is currently in use. (Can be returned only if AsyncMode is false.); or
Illegal | a) The slip print station is not present on this printer (that is, the CapSlpPresent property is set to false); b) The printer doesn’t support two-sided printing (that is, the CapSlpBothSidesPrint property is set to false); c) no slip has been inserted—that is, the application has not called the BeginInsertion and EndInsertion methods before calling ChangePrintSide; d) The printer is currently in insertion mode; e) the printer is currently in removal mode; or f) The side parameter contains a value that doesn’t exist in the PrintSide enumeration

If no exceptions are thrown, PosPrinterBase class calls ChangePrintSideImpl.

If an exception is thrown from the ChangePrintSideImpl method, PosPrinterBase class increments the StatisticFailedPrntSideChanged statistic. Otherwise, PosPrinterBase class updates the SlpPrintSide property and increments the StatisticPrintSideChanged statistic.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.ChangePrintSide Method
ChangePrintSideImpl


PosPrinterBase.ChangePrintSideImpl Method

PosPrinterBase.ChangePrintSideImpl Method |
 | See Also

1/18/2008

Method implemented by service objects to process ChangePrintSide requests.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overridable Sub ChangePrintSideImpl ( _
    side As PrinterSide _
)
protected virtual void ChangePrintSideImpl (
    PrinterSide side
)
protected:
virtual void ChangePrintSideImpl (
    PrinterSide side
)
protected void ChangePrintSideImpl (
    PrinterSide side
)
protected function ChangePrintSideImpl (
    side : PrinterSide
)

Parameters

side

The side on which to print.

Remarks

Called by the PosPrinterBase.ChangePrintSide method. By default, ChangePrinteSideImpl throws a NotImplemented exception, but if the printer supports slip printing on both sides (CapSlpBothSidesPrint = true), the service object must provide an implementation of ChangePrintSideImpl that overrides the PosPrinterBase implementation to handle the physical changing of the slip side in the slip station. The service object’s implementation should not call the base class implementation of the method.

For parameter definitions, see the underlying method.

ChangePrintSideImpl should throw PosControlException exceptions for all error conditions.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.ClearOutput Method

PosPrinterBase.ClearOutput Method |
 | See Also

1/18/2008

Clears all device output that has been buffered. Also, when possible, to halt outputs that are in progress.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub ClearOutput
public override void ClearOutput ()
public:
virtual void ClearOutput () override
public void ClearOutput ()
public override function ClearOutput ()

Remarks

The PosPrinterBase class verifies that the application has the device opened and claimed. POS for .NET will throw PosControlException exceptions if the device is claimed by another process, or if the application doesn’t have the device claimed. POS for .NET clears any buffered asynchronous output requests or queued error events, then sets the State property to ControlState.Idle.

Clearing all output also causes an exit from transaction mode.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.ClearOutput Method
PosCommon.State Property


PosPrinterBase.ClearPrintArea Method

PosPrinterBase.ClearPrintArea Method |
 | See Also

1/18/2008

Clears the area defined by the PageModePrintArea property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub ClearPrintArea
public override void ClearPrintArea ()
public:
virtual void ClearPrintArea () override
public void ClearPrintArea ()
public override function ClearPrintArea ()

Remarks

The page may be cleared by setting the PageModePrintArea to be the same as the PageModeArea and then by using ClearPrintArea or by exiting Page Mode with PageModePrint (where PageModePrintControl is set to Cancel).

The PageModeStation property must be set to a valid station before invoking ClearPrintArea.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.CutPaper Method

PosPrinterBase.CutPaper Method |
 | See Also

1/18/2008

Cuts the receipt paper.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub CutPaper ( _
    percentage As Integer _
)
public override void CutPaper (
    int percentage
)
public:
virtual void CutPaper (
    int percentage
) override
public void CutPaper (
    int percentage
)
public override function CutPaper (
    percentage : int
)

Parameters

percentage

The percentage of paper to cut.

Remarks

The PosPrinterBase class verifies that the application has the device opened, claimed, and enabled. PosPrinterBase validates the parameters and device state, and may throw PosControlException exceptions with the following ErrorCodes:

Value | Meaning
Other Values | A physical condition exists that would preclude the operation—for example, the cover is open, the paper is removed, and so on. A full list of these exceptions is provided under PosPrinter.CutPaper.
Busy | PosPrinterProperties.State is set to ControlState.Busy (applies only if the AsyncMode property has been set to false).
Illegal | a) The CapRecPresent property is set to false; b) The percentage parameter is less than 1 or greater than 100; or c) the CapRecPaperCut property is set to false.

If no exceptions are thrown, the PosPrinterBase class calls CutPaperImpl. PosPrinterBase class calls CutPaperImpl either synchronously (if AsyncMode is set to false) or asynchronously (if AsyncMode is set to true).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CutPaper Method
CutPaperImpl
PosPrinter.RotateSpecial Property


PosPrinterBase.CutPaperImpl Method

PosPrinterBase.CutPaperImpl Method |
 | See Also

1/18/2008

Method implemented by the service object to process CutPaper requests.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overridable Function CutPaperImpl ( _
    percentage As Integer _
) As PrintResults
protected virtual PrintResults CutPaperImpl (
    int percentage
)
protected:
virtual PrintResults^ CutPaperImpl (
    int percentage
)
protected PrintResults CutPaperImpl (
    int percentage
)
protected function CutPaperImpl (
    percentage : int
) : PrintResults

Parameters

percentage

The percentage of paper to cut.

Remarks

Called by the PosPrinterBase.CutPaper method. By default, CutPaperImpl throws a NotImplemented exception, but if the printer supports a cut paper operation (CapRecPapercut = true), the service object must provide an implementation of CutPaperImpl that overrides the PosPrinterBase implementation to handle the physical cutting of the paper. The service object’s implementation should not call the base class implementation of the method.

For parameter definitions, see the underlying method.

CutPaperImpl should throw PosControlException exceptions for all error conditions.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.Dispose Method

PosPrinterBase.Dispose Method |
 | See Also

1/18/2008

Overload List

Name | Description
PosPrinterBase.Dispose () | (inherited from Dispose )
PosPrinterBase.Dispose (Boolean) |

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.Dispose Method (Boolean)

PosPrinterBase.Dispose Method (Boolean) |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

protected override void Dispose (
    bool disposing
)

protected:
virtual void Dispose (
    bool disposing
) override

protected void Dispose (
    boolean disposing
)

protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.EndInsertion Method

PosPrinterBase.EndInsertion Method |
 | See Also

1/18/2008

Ends form-insertion processing.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub EndInsertion
public override void EndInsertion ()
public:
virtual void EndInsertion () override
public void EndInsertion ()
public override function EndInsertion ()

Remarks

The PosPrinterBase class verifies that the application has the device opened, claimed, and enabled. PosPrinterBase validates the parameters and device state, and may throw PosControlException exceptions with the following ErrorCodes:

Value | Meaning
Other Values | A physical condition exists that would preclude the operation—for example, the cover is open, the paper is removed, and so on. A full list of these exceptions is provided under PosPrinter.EndInsertion.
Busy | PosPrinterProperties.State is set to ControlState.Busy.
Illegal | a) the CapSlpPresent property is set to false; or b) the printer is not in slip insertion mode.

If no exception is thrown, the PosPrinterBase class places the printer device in slip insertion mode, sets the SlpPrintSide property to Side1, and then calls EndInsertionImpl. If EndInsertionImpl returns true, the PosPrinterBase class increments the StatisticFormInsertionCount statistic and sets the PosPrinterProperties.SlpNearEnd and PosPrinterProperties.SlpEmpty properties to false. Otherwise, it throws an ExtendedErrorSlipEmpty exception.

If the service object throws an ExtendedErrorSlipEmpty exception and the CapSlpEmptySensor property is set to true, PosPrinterBase class sets the PosPrinterProperties.SlpEmtpy property to true.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.EndInsertion Method
PosPrinter.CapSlpPresent Property
PosPrinter.CoverOpen Property
PosPrinter.CapSlpEmptySensor Property
PosPrinter.SlpEmpty Property


PosPrinterBase.EndInsertionImpl Method

PosPrinterBase.EndInsertionImpl Method |
 | See Also

1/18/2008

Method implemented by the service object to process EndInsertion requests.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overridable Function EndInsertionImpl As Boolean
protected virtual bool EndInsertionImpl ()
protected:
virtual bool EndInsertionImpl ()
protected boolean EndInsertionImpl ()
protected function EndInsertionImpl () : boolean

Remarks

Called by the PosPrinterBase.EndInsertion method. By default, EndInsertionImpl throws a NotImplemented exception, but if the printer supports a slip station, the service object must provide an implementation of EndInsertionImpl that overrides the PosPrinterBase implementation, to handle the physical removal of the slip from the slip station. The service object’s implementation should not call the base class implementation of the method.

For parameter definitions, see the underlying method.

EndInsertionImpl should return true for success, false if a slip isn’t inserted, and throw PosControlException exceptions for all other error conditions.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.EndRemoval Method

PosPrinterBase.EndRemoval Method |
 | See Also

1/18/2008

Ends form-removal processing.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub EndRemoval
public override void EndRemoval ()
public:
virtual void EndRemoval () override
public void EndRemoval ()
public override function EndRemoval ()

Remarks

The PosPrinterBase class verifies that the application has the device opened, claimed, and enabled. PosPrinterBase validates the parameters and device state, and may throw PosControlException exceptions with the following ErrorCodes:

Value | Meaning
Busy | PosPrinterProperties.State is set to ControlState.Busy;
Illegal | a) the printer device isn’t in slip removal mode; or b) the CapSlpPresent property is set to false.

If no exception is thrown, the PosPrinterBase class places the printer device in slip removal mode, sets PosPrinterProperties.SlpPrintSide to PrinterSide.Unknown, and then calls EndRemovalImpl. If EndRemovalImpl returns false, the PosPrinterBase class throws an ExtendedErrorSlipForm exception. Otherwise, it sets PosPrinterProperties.SlpEmpty to true (if the CapSlpEmptySensor property is set to true) and the PosPrinterProperties.SlpNearEnd property to true (if CapSlpNearEndSensor is set to true).

If the service object throws an ExtendedErrorSlipForm exception, PosPrinterBase sets PosPrinterProperties.SlpEmpty to false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.EndRemoval Method
PosPrinter.CapSlpPresent Property
PosPrinter.SlpPrintSide Property
PosPrinter.SlpEmpty Property
PosPrinter.CapSlpEmptySensor Property
PosPrinter.SlpNearEnd Property
PosPrinter.CapSlpNearEndSensor Property
EndRemovalImpl


PosPrinterBase.EndRemovalImpl Method

PosPrinterBase.EndRemovalImpl Method |
 | See Also

1/18/2008

Method implemented by service objects to process EndRemoval requests.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overridable Function EndRemovalImpl As Boolean
protected virtual bool EndRemovalImpl ()
protected:
virtual bool EndRemovalImpl ()
protected boolean EndRemovalImpl ()
protected function EndRemovalImpl () : boolean

Remarks

Called by the PosPrinterBase.EndRemoval method. By default, EndRemovalImpl throws a NotImplemented exception, but if the printer supports a slip station, the service object must provide an implementation of ChangePrintSideImpl that overrides the PosPrinterBase implementation, to end removal of the slip. The service object’s implementation should not call the base class implementation of the method.

For parameter definitions, see the underlying method.

EndRemovalImpl should return true for success, false if a slip is inserted, and throw PosControlException exceptions for all other error conditions.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.MarkFeed Method

PosPrinterBase.MarkFeed Method |
 | See Also

1/18/2008

Holds the type of mark-sensed paper handling available.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub MarkFeed ( _
    type As PrinterMarkFeeds _
)
public override void MarkFeed (
    PrinterMarkFeeds type
)
public:
virtual void MarkFeed (
    PrinterMarkFeeds type
) override
public void MarkFeed (
    PrinterMarkFeeds type
)
public override function MarkFeed (
    type : PrinterMarkFeeds
)

Parameters

type

Indicates the type of mark-sensed paper handling.

Remarks

The PosPrinterBase class verifies that the application has the device opened, claimed, and enabled. PosPrinterBase validates the parameters and device state, and may throw PosControlException exceptions with the following ErrorCodes:

Value | Meaning
Busy | PosPrinterProperties.State is set to ControlState.Busy (applies only if the AsyncMode property has been set to false).
Other values | A physical condition exists that would preclude the operation—for example, the cover is open, the paper is removed, and so on. A full list of these exceptions is provided under PosPrinter.MarkFeed.
Illegal | a) the CapRecPresent property is set to false; b) the type of feed specified isn’t a valid PrinterMarkFeeds value; or c) the type of feed specified is not supported (CapRecMarkFeed doesn’t match the type specified);

If no exception is thrown, the PosPrinterBase class calls MarkFeedImpl.

MarkFeedImpl is performed synchronously if the AsyncMode property is set to false, otherwise, MarkFeedImpl is performed asynchronously.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.MarkFeed Method
MarkFeedImpl
PrinterMarkFeeds Enumeration
PosPrinter.CapRecPresent Property
PosPrinter.CapRecMarkFeed Property
PosPrinter.CoverOpen Property


PosPrinterBase.MarkFeedImpl Method

PosPrinterBase.MarkFeedImpl Method |
 | See Also

1/18/2008

Method implemented by the service object to process MarkFeed requests.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Friend Overridable Function MarkFeedImpl ( _
    type As PrinterMarkFeeds _
) As PrintResults
protected internal virtual PrintResults MarkFeedImpl (
    PrinterMarkFeeds type
)
protected public:
virtual PrintResults^ MarkFeedImpl (
    PrinterMarkFeeds type
)
protected PrintResults MarkFeedImpl (
    PrinterMarkFeeds type
)
protected internal function MarkFeedImpl (
    type : PrinterMarkFeeds
) : PrintResults

Parameters

type

The type of mark-sensed paper handling.

Remarks

Called by the PosPrinterBase.MarkFeed method. By default, MarkFeedImpl throws a NotImplemented exception, but if the printer supports a mark feed operation, the service object must provide an implementation of MarkFeedImpl that overrides the PosPrinterBase implementation, to physically handle mark feed operation. The service object’s implementation should not call the base class implementation of the method.

For parameter definitions, see the underlying method.

If successful, MarkFeedImpl returns an instance of the PrintResults helper class. If an error occurs, the service object should return an instance of the PrintResults class containing the appropriately updated Error fields.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.Open Method

PosPrinterBase.Open Method |
 | See Also

1/18/2008

Opens a device for later input/output processing.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub Open
public override void Open ()
public:
virtual void Open () override
public void Open ()
public override function Open ()

Remarks

Open initializes statistics reporting and event threads for the specified device. Open also initializes the values of many properties. This includes the DataEventEnabled, FreezeEvents, AutoDisable, Claimed properties and more. For specifics about how these properties are initialized, see the individual properties.

Open may throw a PosControlException with the following values:

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The device is already opened; or

  • The DeviceName property is null or an empty string ("").

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosCommon.Close Method


PosPrinterBase.PageModePrint Method

PosPrinterBase.PageModePrint Method |
 | See Also

1/18/2008

Enters or exits Page Mode for the station specified in the PageModeStation property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub PageModePrint ( _
    control As PageModePrintControl _
)
public override void PageModePrint (
    PageModePrintControl control
)
public:
virtual void PageModePrint (
    PageModePrintControl control
) override
public void PageModePrint (
    PageModePrintControl control
)
public override function PageModePrint (
    control : PageModePrintControl
)

Parameters

control

The page mode control.

Remarks

If control is PageMode, then Page Mode is entered. Subsequent calls to PrintNormal, PrintBarCode, and PrintBitmap will buffer the print data (either at the printer or the Service, depending on the printer capabilities) until PageModePrint is called with the control parameter set to PrintSave, Normal, or Cancel. (In this case, the print methods only validate the method parameters and buffer the data – they do not initiate printing. Also, the value of the AsyncMode property does not affect their operation: No OutputID will be assigned to the request, nor will an OutputCompleteEvent be queued.)

If control is PrintSave, then Page Mode is not exited. If some data is buffered by calls to the methods PrintNormal, PrintBarCode, and PrintBitmap, then the buffered data is saved and printed. This control is used to print the same page layout with additional print items inside of the page.

If control is Normal, then Page Mode is exited. If some data is buffered by calls to the methods PrintNormal, PrintBarCode, and PrintBitmap, then the buffered data is printed. The buffered data will not be saved.

If control is Cancel, then Page Mode is exited. If some data is buffered by calls to the methods PrintNormal, PrintBarCode, and PrintBitmap, then the buffered data is not printed and is not saved.

Note that when the PageModePrint method is called, all of the data that is to be printed in the PageModePrintArea will be printed and the paper is fed to the end of the PageModePrintArea. If more than one PageModePrintArea is defined, then after the PageModePrint method is called, all of the data that is to be printed in the respective PageModePrintArea(s) will be printed and the paper will be fed to the end of the PageModePrintArea located the farthest “down” the sheet of paper.

The entire Page Mode transaction is treated as one message. This method is performed synchronously if AsyncMode is FALSE, and asynchronously if AsyncMode is TRUE.

Calling the ClearOutput method cancels Page Mode. Any buffered print lines are also cleared.

Page Mode can be used within a transaction print, but not within a rotate print.

The PageModeStation property must be set to a valid station before invoking PageModePrintControl.

PageModePrint may throw a PosControlException with the following ErrorCode:

Value | Meaning
Illegal | The specified PageModeStation does not exist (see the CapRecPresent and CapSlpPresent properties), or CapxxxPageMode is false, or the specified PageModeStation is not in Page Mode and control is set to Normal, PrintSave, or Cancel.
Busy | Cannot perform while output is in progress. (Can only apply if AsyncMode is false and control is Normal, PrintSave, or Cancel.)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.PageModePrintArea Property
PosPrinter.PageModeStation Property


PosPrinterBase.PageModePrintImpl Method

PosPrinterBase.PageModePrintImpl Method |
 | See Also

1/18/2008

Method implemented by service objects to process PageModePrint requests.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overridable Function PageModePrintImpl ( _
    collection As PageModePrintCollection _
) As PrintResults
protected virtual PrintResults PageModePrintImpl (
    PageModePrintCollection collection
)
protected:
virtual PrintResults^ PageModePrintImpl (
    PageModePrintCollection^ collection
)
protected PrintResults PageModePrintImpl (
    PageModePrintCollection collection
)
protected function PageModePrintImpl (
    collection : PageModePrintCollection
) : PrintResults

Parameters

collection

The collection of PageModePrint requests.

Remarks

This method is called from PageModePrint and is implemented by the service object to support synchronous or asynchronous requests without special code.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.PreFireEvent Method

PosPrinterBase.PreFireEvent Method |
 | See Also

1/18/2008

Overload List

Name | Description
PosPrinterBase.PreFireEvent (DeviceErrorEventArgs) | Called before the delivery of an ErrorEvent event.
PosPrinterBase.PreFireEvent (DirectIOEventArgs) | (inherited from PreFireEvent )
PosPrinterBase.PreFireEvent (OutputCompleteEventArgs) | (inherited from PreFireEvent )
PosPrinterBase.PreFireEvent (StatusUpdateEventArgs) | (inherited from PreFireEvent )

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.PreFireEvent Method (DeviceErrorEventArgs)

PosPrinterBase.PreFireEvent Method (DeviceErrorEventArgs) |
 | See Also

1/18/2008

Called before the delivery of an ErrorEvent event.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overrides Sub PreFireEvent ( _
    posEvent As DeviceErrorEventArgs _
)
protected override void PreFireEvent (
    DeviceErrorEventArgs posEvent
)
protected:
virtual void PreFireEvent (
    DeviceErrorEventArgs^ posEvent
) override
protected void PreFireEvent (
    DeviceErrorEventArgs posEvent
)
protected override function PreFireEvent (
    posEvent : DeviceErrorEventArgs
)

Parameters

posEvent

Class containing error information that will be sent to the application when the DeviceErrorEventHandler is raised.

Remarks

Called before delivery of an ErrorEvent event, and used to update the ErrorLevel, ErrorStation, and ErrorString properties returned by the service object in an instance of the PrintResults class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.PreQueuePrintData Method

PosPrinterBase.PreQueuePrintData Method |
 | See Also

1/18/2008

This method is called before print requests are added to the print queue.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overridable Sub PreQueuePrintData ( _
    printCollection As PrintOperationCollection _
)
protected virtual void PreQueuePrintData (
    PrintOperationCollection printCollection
)
protected:
virtual void PreQueuePrintData (
    PrintOperationCollection^ printCollection
)
protected void PreQueuePrintData (
    PrintOperationCollection printCollection
)
protected function PreQueuePrintData (
    printCollection : PrintOperationCollection
)

Parameters

printCollection

A collection of PrintOperation objects to be queued.

Remarks

This method is called before print requests are added to the print queue.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.PrintBarCode Method

PosPrinterBase.PrintBarCode Method |
 | See Also

1/18/2008

Prints a bar code on the specified printer station.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub PrintBarCode ( _
    station As PrinterStation, _
    data As String, _
    symbology As BarCodeSymbology, _
    height As Integer, _
    width As Integer, _
    alignment As Integer, _
    textPosition As BarCodeTextPosition _
)
public override void PrintBarCode (
    PrinterStation station,
    string data,
    BarCodeSymbology symbology,
    int height,
    int width,
    int alignment,
    BarCodeTextPosition textPosition
)
public:
virtual void PrintBarCode (
    PrinterStation station,
    String^ data,
    BarCodeSymbology symbology,
    int height,
    int width,
    int alignment,
    BarCodeTextPosition textPosition
) override
public void PrintBarCode (
    PrinterStation station,
    String data,
    BarCodeSymbology symbology,
    int height,
    int width,
    int alignment,
    BarCodeTextPosition textPosition
)
public override function PrintBarCode (
    station : PrinterStation,
    data : String,
    symbology : BarCodeSymbology,
    height : int,
    width : int,
    alignment : int,
    textPosition : BarCodeTextPosition
)

Parameters

station

The printer station to be used. Possible values are defined by the PrinterStation enumeration. Valid values are PrinterStation.Receipt or PrinterStation.Slip.

data

The bar code data to be printed.

symbology

Bar code symbol type to use. Possible values are defined by the BarCodeSymbology enumeration.

height

Bar code height. Expressed in the unit of measure indicated by the MapMode property

width

Bar code width.

alignment

Placement of the bar code. For possible values, see Remarks below.

textPosition

Placement of the readable character string. Possible values are defined by the BarCodeTextPosition enumeration.

Remarks

The PosPrinterBase class verifies that the application has the device opened, claimed, and enabled. PosPrinterBase validates the parameters and device state, and may throw PosControlException exceptions with the following values:

Value | Meaning
Busy | Busy: the State property is set to ControlState.Busy (applies only if the AsyncMode property has been set to false).
Other values | A physical condition exists that would preclude the operation—for example, the cover is open, the paper is removed, and so on. A full list of these exceptions is provided under PosPrinter.PrintBarCode.
Illegal | a) the requested printer station isn’t valid; b) the requested printer station isn’t PrinterStation.Receipt or PrinterStation.Slip; c) the specified bar code symbology isn’t valid; d) the specified bar code alignment is invalid; e) the specified bar code text position is invalid; f) the width parameter less than or equal to 0 (zero); g) the height parameter is less than or equal to 0 (zero); h) the CapRecPresent property is set to false; or h) the specified station doesn’t support barcodes.

If no exception is thrown, the PosPrinterBase class calls PrintBarCodeImpl.

PrintBarCodeImpl is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

Refer to PrintBarCode for additional information.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.PrintBarCode Method
PrintBarCodeImpl


PosPrinterBase.PrintBarCodeImpl Method

PosPrinterBase.PrintBarCodeImpl Method |
 | See Also

1/18/2008

Overload List

Name | Description
PosPrinterBase.PrintBarCodeImpl (PrinterStation, String, BarCodeSymbology, Int32, Int32, Int32, BarCodeTextPosition) | Method implemented by the service object to process PrintBarCode requests.
PosPrinterBase.PrintBarCodeImpl (PrinterStation, String, BarCodeSymbology, Int32, Int32, Int32, BarCodeTextPosition, PrinterState) | Implemented by service objects to process PrintBarCode requests.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.PrintBarCodeImpl Method (PrinterStation, String, BarCodeSymbology, Int32, Int32, Int32, BarCodeTextPosition)

PosPrinterBase.PrintBarCodeImpl Method (PrinterStation, String, BarCodeSymbology, Int32, Int32, Int32, BarCodeTextPosition) |
 | See Also

1/18/2008

Method implemented by the service object to process PrintBarCode requests.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overridable Function PrintBarCodeImpl ( _
    station As PrinterStation, _
    data As String, _
    symbology As BarCodeSymbology, _
    height As Integer, _
    width As Integer, _
    alignment As Integer, _
    textPosition As BarCodeTextPosition _
) As PrintResults
protected virtual PrintResults PrintBarCodeImpl (
    PrinterStation station,
    string data,
    BarCodeSymbology symbology,
    int height,
    int width,
    int alignment,
    BarCodeTextPosition textPosition
)
protected:
virtual PrintResults^ PrintBarCodeImpl (
    PrinterStation station,
    String^ data,
    BarCodeSymbology symbology,
    int height,
    int width,
    int alignment,
    BarCodeTextPosition textPosition
)
protected PrintResults PrintBarCodeImpl (
    PrinterStation station,
    String data,
    BarCodeSymbology symbology,
    int height,
    int width,
    int alignment,
    BarCodeTextPosition textPosition
)
protected function PrintBarCodeImpl (
    station : PrinterStation,
    data : String,
    symbology : BarCodeSymbology,
    height : int,
    width : int,
    alignment : int,
    textPosition : BarCodeTextPosition
) : PrintResults

Parameters

station

The printer station to be used. Possible values are defined by the PrinterStation enumeration. Valid values are PrinterStation.Receipt or PrinterStation.Slip.

data

The bar code data to be printed.

symbology

Bar code symbol type to use. Possible values are defined by the BarCodeSymbology enumeration.

height

Bar code height. Expressed in the unit of measure indicated by the MapMode property

width

Bar code width.

alignment

Placement of the bar code..

textPosition

Placement of the readable character string. Possible values are defined by the BarCodeTextPosition enumeration.

Remarks

Called by the PosPrinterBase.PrintBarCode method. By default, PrintBarCodeImpl throws a NotImplemented exception, but if the printer supports barcode printing, the service object must provide an implementation of PrintBarcodeImpl that overrides the PosPrinterBase implementation. The service object’s implementation should not call the base class implementation of the method.

For parameter definitions, see the underlying method.

If successful, PrintBarCodeImpl returns an instance of the PrintResults helper class. If an error occurs, the service object should return an instance of the PrintResults class containing the appropriately updated Error fields.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.PrintBarCodeImpl Method (PrinterStation, String, BarCodeSymbology, Int32, Int32, Int32, BarCodeTextPosition, PrinterState)

PosPrinterBase.PrintBarCodeImpl Method (PrinterStation, String, BarCodeSymbology, Int32, Int32, Int32, BarCodeTextPosition, PrinterState) |
 | See Also

1/18/2008

Implemented by service objects to process PrintBarCode requests.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overridable Function PrintBarCodeImpl ( _
    station As PrinterStation, _
    data As String, _
    symbology As BarCodeSymbology, _
    height As Integer, _
    width As Integer, _
    alignment As Integer, _
    textPosition As BarCodeTextPosition, _
    state As PrinterState _
) As PrintResults
protected virtual PrintResults PrintBarCodeImpl (
    PrinterStation station,
    string data,
    BarCodeSymbology symbology,
    int height,
    int width,
    int alignment,
    BarCodeTextPosition textPosition,
    PrinterState state
)
protected:
virtual PrintResults^ PrintBarCodeImpl (
    PrinterStation station,
    String^ data,
    BarCodeSymbology symbology,
    int height,
    int width,
    int alignment,
    BarCodeTextPosition textPosition,
    PrinterState^ state
)
protected PrintResults PrintBarCodeImpl (
    PrinterStation station,
    String data,
    BarCodeSymbology symbology,
    int height,
    int width,
    int alignment,
    BarCodeTextPosition textPosition,
    PrinterState state
)
protected function PrintBarCodeImpl (
    station : PrinterStation,
    data : String,
    symbology : BarCodeSymbology,
    height : int,
    width : int,
    alignment : int,
    textPosition : BarCodeTextPosition,
    state : PrinterState
) : PrintResults

Parameters

station
data
symbology

Bar code symbol type to use.

height
width
alignment

Placement of the bar code.

textPosition

Placement of the readable character string. Possible values are defined by the BarCodeTextPosition enumeration.

state

Remarks

This method is called from PrintBarCode. It is used to process synchronous or asynchronous requests without mode-specific code.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.PrintBitmap Method

PosPrinterBase.PrintBitmap Method |
 | See Also

1/18/2008

Prints a bitmap on the specified printer station.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub PrintBitmap ( _
    station As PrinterStation, _
    fileName As String, _
    width As Integer, _
    alignment As Integer _
)
public override void PrintBitmap (
    PrinterStation station,
    string fileName,
    int width,
    int alignment
)
public:
virtual void PrintBitmap (
    PrinterStation station,
    String^ fileName,
    int width,
    int alignment
) override
public void PrintBitmap (
    PrinterStation station,
    String fileName,
    int width,
    int alignment
)
public override function PrintBitmap (
    station : PrinterStation,
    fileName : String,
    width : int,
    alignment : int
)

Parameters

station

The printer station to be used. Possible values are defined by the PrinterStation enumeration. Valid values are PrinterStation.Receipt or PrinterStation.Slip.

fileName

Name of Windows bitmap file. The file must be in uncompressed format.

width

Width of the bitmap.

alignment

Placement of the bitmap.

Remarks

The PosPrinterBase class verifies that the application has the device opened, claimed, and enabled. PosPrinterBase validates the parameters and device state, and may throw PosControlException exceptions with the following values:

Value | Meaning
Busy | The State property is set to ControlState.Busy (applies only if the AsyncMode property has been set to false); or
Other values | A physical condition exists that would preclude the operation—for example, the cover is open, the paper is removed, and so on. A full list of these exceptions is provided under PosPrinter.PrintBitmap.
Illegal | a) the requested printer station isn’t valid; b) the requested printer station isn’t PrinterStation.Receipt or PrinterStation.Slip; c) the width parameter is equal to or less than zero (or not set to PrinterBitmapAsIs); d) the CapRecPresent or CapSlpPresent property is set to false; e) the specified station doesn’t support bitmaps; or f) the specified alignment is invalid.

If no exception is thrown, the PosPrinterBase class calls PrintBitmapImpl.

PrintBitmapImpl is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

See PrintBitmap for additional information about argument values.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.PrintBitmap Method
PrintBitmapImpl


PosPrinterBase.PrintBitmapImpl Method

PosPrinterBase.PrintBitmapImpl Method |
 | See Also

1/18/2008

Overload List

Name | Description
PosPrinterBase.PrintBitmapImpl (PrinterStation, String, Int32, Int32) | Method implemented by service objects to process PrintBitmap requests.
PosPrinterBase.PrintBitmapImpl (PrinterStation, String, Int32, Int32, PrinterState) | Method implemented by service objects to process PrintBitmap requests.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.PrintBitmapImpl Method (PrinterStation, String, Int32, Int32)

PosPrinterBase.PrintBitmapImpl Method (PrinterStation, String, Int32, Int32) |
 | See Also

1/18/2008

Method implemented by service objects to process PrintBitmap requests.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overridable Function PrintBitmapImpl ( _
    station As PrinterStation, _
    fileName As String, _
    width As Integer, _
    alignment As Integer _
) As PrintResults
protected virtual PrintResults PrintBitmapImpl (
    PrinterStation station,
    string fileName,
    int width,
    int alignment
)
protected:
virtual PrintResults^ PrintBitmapImpl (
    PrinterStation station,
    String^ fileName,
    int width,
    int alignment
)
protected PrintResults PrintBitmapImpl (
    PrinterStation station,
    String fileName,
    int width,
    int alignment
)
protected function PrintBitmapImpl (
    station : PrinterStation,
    fileName : String,
    width : int,
    alignment : int
) : PrintResults

Parameters

station

The printer station to be used. Possible values are defined by the PrinterStation enumeration. Valid values are PrinterStation.Receipt or PrinterStation.Slip.

fileName

Name of Windows bitmap file. The file must be in uncompressed format.

width

Width of the bitmap.

alignment

Placement of the bitmap.

Remarks

Called by the PosPrinterBase.PrintBitmap method. By default, PrintBitmapImpl throws a NotImplemented exception, but if the printer supports bitmap printing, the service object must provide an implementation of PrintBitmapImpl that overrides the PosPrinterBase implementation. The service object’s implementation should not call the base class implementation of the method.

For parameter definitions, see the underlying method.

If successful, PrintBitmapImpl returns an instance of the PrintResults helper class. The service object should throw an ExtendedErrorTooBig exception if the bitmap is too large to be printed, or update the PrintResults class for all other error conditions.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.PrintBitmapImpl Method (PrinterStation, String, Int32, Int32, PrinterState)

PosPrinterBase.PrintBitmapImpl Method (PrinterStation, String, Int32, Int32, PrinterState) |
 | See Also

1/18/2008

Method implemented by service objects to process PrintBitmap requests.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overridable Function PrintBitmapImpl ( _
    station As PrinterStation, _
    fileName As String, _
    width As Integer, _
    alignment As Integer, _
    state As PrinterState _
) As PrintResults
protected virtual PrintResults PrintBitmapImpl (
    PrinterStation station,
    string fileName,
    int width,
    int alignment,
    PrinterState state
)
protected:
virtual PrintResults^ PrintBitmapImpl (
    PrinterStation station,
    String^ fileName,
    int width,
    int alignment,
    PrinterState^ state
)
protected PrintResults PrintBitmapImpl (
    PrinterStation station,
    String fileName,
    int width,
    int alignment,
    PrinterState state
)
protected function PrintBitmapImpl (
    station : PrinterStation,
    fileName : String,
    width : int,
    alignment : int,
    state : PrinterState
) : PrintResults

Parameters

station

The printer station to be used. Possible values are defined by the PrinterStation enumeration. Valid values are PrinterStation.Receipt or PrinterStation.Slip.

fileName

Name of Windows bitmap file. The file must be in uncompressed format.

width

Printed width of the bitmap to be performed. See Remarks below.

alignment

Placement of the bitmap. For possible values, see Remarks below.

state

The state of the printer at the time of the call to PrintBitmap.

Remarks

Called by the PosPrinterBase.PrintBitmap method. By default, PrintBitmapImpl throws a NotImplemented exception, but if the printer supports bitmap printing, the service object must provide an implementation of PrintBitmapImpl that overrides the PosPrinterBase implementation. The service object’s implementation should not call the base class implementation of the method.

For parameter definitions, see the underlying method.

If successful, PrintBitmapImpl returns an instance of the PrintResults helper class. The service object should throw an ExtendedErrorTooBig exception if the bitmap is too large to be printed, or update the PrintResults class for all other error conditions.

This method is called from PrintBitmap and can process either asynchronous or synchronous events without specialized code.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.PrintImmediate Method

PosPrinterBase.PrintImmediate Method |
 | See Also

1/18/2008

Immediately prints the string specified for data on the printer station specified by station.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub PrintImmediate ( _
    station As PrinterStation, _
    data As String _
)
public override void PrintImmediate (
    PrinterStation station,
    string data
)
public:
virtual void PrintImmediate (
    PrinterStation station,
    String^ data
) override
public void PrintImmediate (
    PrinterStation station,
    String data
)
public override function PrintImmediate (
    station : PrinterStation,
    data : String
)

Parameters

station

The PrinterStation to which the data is to be written.

data

The data to be written to the printer.

Remarks

The PosPrinterBase class verifies that the application has the device opened, claimed, and enabled. PosPrinterBase validates the parameters and device state, and may throw PosControlException exceptions with the following values:

Value

Meaning

Other values

  • A physical condition exists that would preclude the operation—for example, the cover is open, the paper is removed, and so on. A full list of these exceptions is provided under PosPrinter.PrintImmediate.

Illegal

  1. The requested printer station isn’t PrinterStation.Receipt, PrinterStation.Journal, or PrinterStation.Slip.

  2. The requested printer station doesn’t exist (that is, the value of the CapRecPresent, CapJrnPresent, or CapSlpPresent property is false).

  3. The data parameter is null.

If no exception is thrown, the PosPrinterBase class calls PrintImmediateImpl and updates the appropriate printer statistics based on the values returned in the PrintResults class.

Note: A call to PrintImmediate will not pre-empt a current asynchronous print operation. PosPrinterBase class uses an internal lock to manage synchronization with any asynchronous print operations or other PrintImmediate requests. Once the current asynchronous print operation completes, the PrintImmediate request will be processed.

See PrintImmediate for more detail.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.PrintImmediate Method
PrintImmediateImpl


PosPrinterBase.PrintImmediateImpl Method

PosPrinterBase.PrintImmediateImpl Method |
 | See Also

1/18/2008

Overload List

Name | Description
PosPrinterBase.PrintImmediateImpl (PrinterStation, String) | Obsolete. Method implemented by service objects to process PrintImmediate requests.
PosPrinterBase.PrintImmediateImpl (PrinterStation, String, PrinterState) | This method is called from PrintBitmap and can process either asynchronous or synchronous events without specialized code.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
SetLogo


PosPrinterBase.PrintImmediateImpl Method (PrinterStation, String)

PosPrinterBase.PrintImmediateImpl Method (PrinterStation, String) |
 | See Also

1/18/2008

NOTE: This method is now obsolete.

Method implemented by service objects to process PrintImmediate requests.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

<ObsoleteAttribute("Please use PrintImmediateImpl(Microsoft.PointOfService.PrinterStation, string, Microsoft.PointOfService.PrinterState) instead.", True)> _
Protected Overridable Function PrintImmediateImpl ( _
    station As PrinterStation, _
    data As String _
) As PrintResults
[ObsoleteAttribute("Please use PrintImmediateImpl(Microsoft.PointOfService.PrinterStation, string, Microsoft.PointOfService.PrinterState) instead.", true)]
protected virtual PrintResults PrintImmediateImpl (
    PrinterStation station,
    string data
)
[ObsoleteAttribute(L"Please use PrintImmediateImpl(Microsoft.PointOfService.PrinterStation, string, Microsoft.PointOfService.PrinterState) instead.", true)]
protected:
virtual PrintResults^ PrintImmediateImpl (
    PrinterStation station,
    String^ data
)
/** @attribute ObsoleteAttribute("Please use PrintImmediateImpl(Microsoft.PointOfService.PrinterStation, string, Microsoft.PointOfService.PrinterState) instead.", true) */
protected PrintResults PrintImmediateImpl (
    PrinterStation station,
    String data
)
ObsoleteAttribute("Please use PrintImmediateImpl(Microsoft.PointOfService.PrinterStation, string, Microsoft.PointOfService.PrinterState) instead.", true)
protected function PrintImmediateImpl (
    station : PrinterStation,
    data : String
) : PrintResults

Parameters

station

The PrinterStation to which the data is to be written.

data

The data to be written to the printer.

Remarks

Called by the PosPrinterBase.PrintImmediate method. The service object must provide an implementation of this method. For parameter definitions, see the underlying method.

If successful, PrintImmediateImpl returns an instance of the PrintResults helper class. If a logo escape sequence is included in the print data, the service object should retrieve the logo string from the PosPrinterProperties.TopLogo and PosPrinterProperties.BottomLogo properties.

The service object should update the properties of the PrintResults class for any error conditions that occur.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
SetLogo


PosPrinterBase.PrintImmediateImpl Method (PrinterStation, String, PrinterState)

PosPrinterBase.PrintImmediateImpl Method (PrinterStation, String, PrinterState) |
 | See Also

1/18/2008

This method is called from PrintBitmap and can process either asynchronous or synchronous events without specialized code.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overridable Function PrintImmediateImpl ( _
    station As PrinterStation, _
    data As String, _
    state As PrinterState _
) As PrintResults
protected virtual PrintResults PrintImmediateImpl (
    PrinterStation station,
    string data,
    PrinterState state
)
protected:
virtual PrintResults^ PrintImmediateImpl (
    PrinterStation station,
    String^ data,
    PrinterState^ state
)
protected PrintResults PrintImmediateImpl (
    PrinterStation station,
    String data,
    PrinterState state
)
protected function PrintImmediateImpl (
    station : PrinterStation,
    data : String,
    state : PrinterState
) : PrintResults

Parameters

station

The printer station to be used. Possible values are defined by the PrinterStation enumeration. Valid values are: PrinterStation.Journal, PrinterStation.Receipt, or PrinterStation.Slip.

data

The characters to be printed. May consist of printable characters, escape sequences, carriage returns (13 decimal), and new line / line feed (10 decimal).

state

The state of the printer at the time of the original call to PrintImmediate.

Remarks

This method is called from PrintBitmap and can process either asynchronous or synchronous events without specialized code.

Example

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.PrintMemoryBitmap Method

PosPrinterBase.PrintMemoryBitmap Method |
 | See Also

1/18/2008

Prints a memory-stored bitmap on the specified printer station.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub PrintMemoryBitmap ( _
    station As PrinterStation, _
    data As Bitmap, _
    width As Integer, _
    alignment As Integer _
)
public override void PrintMemoryBitmap (
    PrinterStation station,
    Bitmap data,
    int width,
    int alignment
)
public:
virtual void PrintMemoryBitmap (
    PrinterStation station,
    Bitmap^ data,
    int width,
    int alignment
) override
public void PrintMemoryBitmap (
    PrinterStation station,
    Bitmap data,
    int width,
    int alignment
)
public override function PrintMemoryBitmap (
    station : PrinterStation,
    data : Bitmap,
    width : int,
    alignment : int
)

Parameters

station

The printer station to be used. May be either

receipt or slip.

data

Memory byte array representation of the bitmap.

width

Printed width of the bitmap to be performed. Valid widths include asIs and other bitmap width values expressed in the unit of measure given by MapMode.

alignment

Placement of the bitmap. Valid alignments include left, right, center, and other values that express a distance from the left-most print column to the start of the bitmap. These values are expressed in the unit of measure given by MapMode.

Remarks

Prints a memory-stored bitmap on the specified printer station. If a partial text line has been sent (for example, via the PrintNormal method) but not yet printed, then an implicit line feed is added to this text and the line is printed before the bitmap is printed. Text data sent after this PrintMemoryBitmap begins on the line following the bitmap.

This method is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

The width parameter controls transformation of the bitmap. If width is asIs, then no transformation is performed. The bitmap is printed with one bitmap pixel per printer dot. Advantages of this option are that it:

  • Provides the highest performance bitmap printing.

  • Works well for bitmaps tuned for a specific printer’s aspect ratio between horizontal dots and vertical dots.

If width is non-zero, then the bitmap will be transformed by stretching or compressing the bitmap such that its width is the specified width and the aspect ratio is unchanged. Advantages of this option are:

  • Sizes a bitmap to fit a variety of printers.

  • Maintains the bitmap’s aspect ratio.

Disadvantages are:

  • Lowers performance compared to untransformed data.

  • Some lines and images that are “smooth” in the original bitmap may show some “ratcheting.”

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.PrintMemoryBitmapImpl Method

PosPrinterBase.PrintMemoryBitmapImpl Method |
 | See Also

1/18/2008

Method implemented by service objects to process PrintMemoryBitmap requests.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overridable Function PrintMemoryBitmapImpl ( _
    station As PrinterStation, _
    bitmap As Bitmap, _
    width As Integer, _
    alignment As Integer, _
    state As PrinterState _
) As PrintResults
protected virtual PrintResults PrintMemoryBitmapImpl (
    PrinterStation station,
    Bitmap bitmap,
    int width,
    int alignment,
    PrinterState state
)
protected:
virtual PrintResults^ PrintMemoryBitmapImpl (
    PrinterStation station,
    Bitmap^ bitmap,
    int width,
    int alignment,
    PrinterState^ state
)
protected PrintResults PrintMemoryBitmapImpl (
    PrinterStation station,
    Bitmap bitmap,
    int width,
    int alignment,
    PrinterState state
)
protected function PrintMemoryBitmapImpl (
    station : PrinterStation,
    bitmap : Bitmap,
    width : int,
    alignment : int,
    state : PrinterState
) : PrintResults

Parameters

station

The printer station to be used. Can be either PrinterStation.Slip or PrinterStation.Receipt.

bitmap

The bitmap to be printed

width

The width of the bitmap.

alignment

The placement of the bitmap.

state

Contains printer state as it was when PrintMemoryBitmap was called.

Remarks

This method is called by PosPrinterBase.PrintMemoryBitmap and allows a service object to support bitmap printing with a minimal amount of code in either synchronous or asynchronous mode. The service object writer should implement this method as if it were to be called synchronously.

When PrintMemoryBitmap is called, it first validates incoming arguments. If the request is for a synchronous operation, PrintMemoryBitmap calls PrintMemoryBitmapImpl directly. PrintMemoryBitmap adds asynchronous requests to a queue managed by POS for .NET before returning.

The implementation of PrintMemoryBitmapImpl should set values as appropriate in the PrintResults return class before returning. If the call to PrintMemoryBitmap had been made asynchronously, the POS for .NET thread will raise either an ErrorEvent or an OutputCompleteEvent back to the application, depending on the contents of PrintResults. If the original call was synchronous, PrintMemoryBitmap will throw a PosControlException if the print operation has failed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase Class
PosPrinterBase.PrintMemoryBitmap Method


PosPrinterBase.PrintNormal Method

PosPrinterBase.PrintNormal Method |
 | See Also

1/18/2008

Prints the string specified in data on the printer station specified in station.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub PrintNormal ( _
    station As PrinterStation, _
    data As String _
)
public override void PrintNormal (
    PrinterStation station,
    string data
)
public:
virtual void PrintNormal (
    PrinterStation station,
    String^ data
) override
public void PrintNormal (
    PrinterStation station,
    String data
)
public override function PrintNormal (
    station : PrinterStation,
    data : String
)

Parameters

station

The PrinterStation to use. May be Receipt , Journal, JournalReceipt, or Slip.

data

The characters to print, consisting mostly of printable characters.

Remarks

The PosPrinterBase class verifies that the application has the device opened, claimed, and enabled. PosPrinterBase validates the parameters and device state, and may throw PosControlException exceptions with the following values:

Value | Meaning
Other values | A physical condition exists that would preclude the operation—for example, the cover is open, the paper is removed, and so on. A full list of these exceptions is provided under PosPrinter.PrintImmediate.
Busy | the State property is set to ControlState.Busy (applies only if the AsyncMode property has been set to false); or
Illegal | a) the requested printer station isn’t PrinterStation.Receipt, PrinterStation.Journal, or PrinterStation.Slip; or b) the requested printer station doesn’t exist (that is, the value of the CapRecPresent, CapJrnPresent, or CapSlpPresent property is false).

If no exception is thrown, the PosPrinterBase class calls PrintNormalImpl and updates statistics based on the values returned in the PrintResults class.

PrintNormalImpl is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

See PrintNormal for additional information about the contents of the data argument.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.PrintNormal Method
PrintNormalImpl


PosPrinterBase.PrintNormalImpl Method

PosPrinterBase.PrintNormalImpl Method |
 | See Also

1/18/2008

Method implemented by service objects to process PrintNormal requests.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected MustOverride Function PrintNormalImpl ( _
    station As PrinterStation, _
    printerState As PrinterState, _
    data As String _
) As PrintResults
protected abstract PrintResults PrintNormalImpl (
    PrinterStation station,
    PrinterState printerState,
    string data
)
protected:
virtual PrintResults^ PrintNormalImpl (
    PrinterStation station,
    PrinterState^ printerState,
    String^ data
) abstract
protected abstract PrintResults PrintNormalImpl (
    PrinterStation station,
    PrinterState printerState,
    String data
)
protected abstract function PrintNormalImpl (
    station : PrinterStation,
    printerState : PrinterState,
    data : String
) : PrintResults

Parameters

station

The PrinterStation to be used.

printerState

The current state of the printer object at the time of the call.

data

The data to be printed.

Remarks

Called by the PosPrinterBase.PrintNormal method. This method must be implemented by the service object. For parameter definitions, see the underlying method.

If successful, PrintNormalImpl returns an instance of the PrintResults helper class. If a logo escape sequence is included in the print data, the service object should retrieve the logo string from the PosPrinterProperties.TopLogo and PosPrinterProperties.BottomLogo properties.

The service object should update the properties of the PrintResults class for any error conditions.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
SetLogo


PosPrinterBase.PrintTwoNormal Method

PosPrinterBase.PrintTwoNormal Method |
 | See Also

1/18/2008

Prints two strings on two print stations simultaneously. When supported, this may give increased print performance.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub PrintTwoNormal ( _
    stations As PrinterStation, _
    data1 As String, _
    data2 As String _
)
public override void PrintTwoNormal (
    PrinterStation stations,
    string data1,
    string data2
)
public:
virtual void PrintTwoNormal (
    PrinterStation stations,
    String^ data1,
    String^ data2
) override
public void PrintTwoNormal (
    PrinterStation stations,
    String data1,
    String data2
)
public override function PrintTwoNormal (
    stations : PrinterStation,
    data1 : String,
    data2 : String
)

Parameters

stations

The printer stations to be used. Possible values are defined by the PrinterStation enumeration. Valid values are: PrinterStation.TwoReceiptJournal, PrinterStation.TwoSlipJournal, or PrinterStation.TwoSlipReceipt.

data1

The characters to be printed on the first station. May consist of printable characters and escape sequences as listed in the PosPrinter topic. The characters must all fit on one printed line, so that the printer may attempt to print on both stations simultaneously.

data2

The characters to be printed on the second station. (Restrictions are the same as data1.) If this string is the empty string (“”), then print the same data as data1. On some printers, using this format may give additional increased print performance.

Remarks

The PosPrinterBase class verifies that the application has the device opened, claimed, and enabled. PosPrinterBase validates the parameters and device state, and may throw PosControlException exceptions with the following values:

Value | Meaning
Other values | A physical condition exists that would preclude the operation—for example, the cover is open, the paper is removed, and so on. A full list of these exceptions is provided under PosPrinter.PrintTwoNormal.
Busy | The State property is set to ControlState.Busy (applies only if the AsyncMode property has been set to false); or
Illegal | a) the requested printer station isn’t PrinterStation.TwoReceiptJournal, PrinterStation.TwoSlipJournal, or PrinterStation.TwoSlipReceipt; b) the requested printer station doesn’t exist (that is, the value of the CapRecPresent, CapJrnPresent, or CapSlpPresent property is false); c) concurrent printing isn’t supported (that is, the value of CapConcurrentJrnRec, CapConcurrentRecSlp, or CapConcurrentJrnSlp is set to false); d) the stations aren’t in Rotation.Normal rotation mode; or e) the data1 parameter is null;

If no exception is thrown, the PosPrinterBase class calls PrintTwoNormalImpl and updates statistics based on the values returned in the PrintResults class.

PrintTwoNormalImpl is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.PrintTwoNormal Method
PrintTwoNormalImpl


PosPrinterBase.PrintTwoNormalImpl Method

PosPrinterBase.PrintTwoNormalImpl Method |
 | See Also

1/18/2008

Method implemented by service objects to process PrintTwoNormal requests.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overridable Function PrintTwoNormalImpl ( _
    stations As PrinterStation, _
    printerState As PrinterState, _
    data1 As String, _
    data2 As String _
) As PrintResults
protected virtual PrintResults PrintTwoNormalImpl (
    PrinterStation stations,
    PrinterState printerState,
    string data1,
    string data2
)
protected:
virtual PrintResults^ PrintTwoNormalImpl (
    PrinterStation stations,
    PrinterState^ printerState,
    String^ data1,
    String^ data2
)
protected PrintResults PrintTwoNormalImpl (
    PrinterStation stations,
    PrinterState printerState,
    String data1,
    String data2
)
protected function PrintTwoNormalImpl (
    stations : PrinterStation,
    printerState : PrinterState,
    data1 : String,
    data2 : String
) : PrintResults

Parameters

stations

The printer stations to be used. Possible values are defined by the PrinterStation enumeration. Valid values are: PrinterStation.TwoReceiptJournal, PrinterStation.TwoSlipJournal, or PrinterStation.TwoSlipReceipt.

printerState

The state of the printer at the time the time of the original call.

data1

The characters to be printed on the first station. May consist of printable characters and escape sequences as listed in the PosPrinter topic. The characters must all fit on one printed line, so that the printer may attempt to print on both stations simultaneously.

data2

The characters to be printed on the second station. (Restrictions are the same as data1.) If this string is the empty string (“”), then print the same data as data1. On some printers, using this format may give additional increased print performance.

Remarks

Called by the PosPrinterBase.PrintTwoNormal method. By default, this method throws a NotImplemented exception, but if the printer supports a dual station printing, the service object must provide an implementation of PrintTwoNormalImpl that overrides the PosPrinterBase implementation. The service object’s implementation should not call the base class implementation of the method.

For parameter definitions, see the underlying method.

If successful, PrintTwoNormalImpl returns an instance of the PrintResults helper class. If a logo escape sequence is included in the print data, the service object should retrieve the logo string from the PosPrinterProperties.TopLogo and PosPrinterProperties.BottomLogo properties.

The service object should update the properties of the PrintResults class for all any error conditions.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
SetLogo


PosPrinterBase.RotatePrint Method

PosPrinterBase.RotatePrint Method |
 | See Also

1/18/2008

Enters or exits rotated print mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub RotatePrint ( _
    station As PrinterStation, _
    rotation As PrintRotation _
)
public override void RotatePrint (
    PrinterStation station,
    PrintRotation rotation
)
public:
virtual void RotatePrint (
    PrinterStation station,
    PrintRotation rotation
) override
public void RotatePrint (
    PrinterStation station,
    PrintRotation rotation
)
public override function RotatePrint (
    station : PrinterStation,
    rotation : PrintRotation
)

Parameters

station

The PrinterStation

rotation

The type of rotation requested.

Remarks

The PosPrinterBase class verifies that the application has the device opened, claimed, and enabled. PosPrinterBase validates the parameters and device state, and may throw PosControlException exceptions with the following values:

Value | Meaning
Other values | A physical condition exists that would preclude the operation—for example, the cover is open, the paper is removed, and so on. A full list of these exceptions is provided under PosPrinter.RotatePrint.
Busy | The State property is set to ControlState.Busy (applies only if the AsyncMode property has been set to false).
Illegal | a) the requested printer station must be either PrinterStation.Receipt or PrinterStation.Slip; b) the requested rotation isn’t supported for the requested station; or c) the requested printer station doesn’t exist (that is, the value of the CapRecPresent, or CapSlpPresent property is false).

If no exception is thrown, the PosPrinterBase class either starts a new rotation transaction or ends the current transaction based on the value of the rotation parameter. When a rotation transaction is started, subsequent print calls are added to a collection and the entire collection is passed to the RotatePrintImpl method when the transaction is ended.

RotatePrintImpl is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.RotatePrint Method
RotatePrintImpl


PosPrinterBase.RotatePrintImpl Method

PosPrinterBase.RotatePrintImpl Method |
 | See Also

1/18/2008

Method implemented by service objects to process RotatePrint requests.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overridable Function RotatePrintImpl ( _
    collection As RotatePrintCollection _
) As PrintResults
protected virtual PrintResults RotatePrintImpl (
    RotatePrintCollection collection
)
protected:
virtual PrintResults^ RotatePrintImpl (
    RotatePrintCollection^ collection
)
protected PrintResults RotatePrintImpl (
    RotatePrintCollection collection
)
protected function RotatePrintImpl (
    collection : RotatePrintCollection
) : PrintResults

Parameters

collection

The collection of rotate print requests.

Remarks

Called by the PosPrinterBase.RotatePrint method. By default, RotatePrintImpl throws a NotImplemented exception, but if the printer supports rotated printing, the service object must provide an implementation of RotatePrintImpl that overrides the PosPrinterBase implementation. The service object’s implementation should not call the base class implementation of the method.

For parameter definitions, see the underlying method.

If successful, RotatePrintImpl returns an instance of the PrintResults helper class. If a logo escape sequence is included in the print data, the service object should retrieve the logo string from the PosPrinterProperties.TopLogo and PosPrinterProperties.BottomLogo properties.

The service object should update the properties of the PrintResults class for any error conditions.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
SetLogo


PosPrinterBase.SetBitmap Method

PosPrinterBase.SetBitmap Method |
 | See Also

1/18/2008

Saves information about a bitmap for later printing.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub SetBitmap ( _
    bitmapNumber As Integer, _
    station As PrinterStation, _
    fileName As String, _
    width As Integer, _
    alignment As Integer _
)
public override void SetBitmap (
    int bitmapNumber,
    PrinterStation station,
    string fileName,
    int width,
    int alignment
)
public:
virtual void SetBitmap (
    int bitmapNumber,
    PrinterStation station,
    String^ fileName,
    int width,
    int alignment
) override
public void SetBitmap (
    int bitmapNumber,
    PrinterStation station,
    String fileName,
    int width,
    int alignment
)
public override function SetBitmap (
    bitmapNumber : int,
    station : PrinterStation,
    fileName : String,
    width : int,
    alignment : int
)

Parameters

bitmapNumber

The number to be assigned to this bitmap. Two bitmaps, numbered 1 and 2, may be set.

station

The printer station to be used. Possible values are defined by the PrinterStation enumeration. Valid values are: PrinterStation.Receipt or PrinterStation.Slip.

fileName

Name of Windows bitmap file. The file must be in uncompressed format. If set to an empty string (“”), the bitmap is unset.

width

Width of the bitmap.

alignment

Placement of the bitmap.

Remarks

The PosPrinterBase class verifies that the application has the device opened, claimed, and enabled. PosPrinterBase validates the parameters and device state, and may throw PosControlException exceptions with the following values:

Value | Meaning
NoExist | the specified fileName doesn’t exist.
Illegal | a) the requested printer station isn’t PrinterStation.Receipt or PrinterStation.Slip; b) the requested printer station doesn’t exist (that is, the value of the CapRecPresent or CapSlpPresent property is false); c) the printer station doesn’t support bitmaps (CapRecBitmap or CapSlpBitmap property is set to false); d) the specified fileName doesn’t exist; e) the width parameter is equal to or less than zero (or not set to PrinterBitmapAsIs); f) the specified alignment is invalid; or g) the bitmapNumber must be from 1 to 20, inclusive.

If no exception is thrown, the PosPrinterBase class calls SetBitmapImpl.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.SetBitmap Method
SetBitmapImpl


PosPrinterBase.SetBitmapImpl Method

PosPrinterBase.SetBitmapImpl Method |
 | See Also

1/18/2008

Method implemented on service objects to process SetBitmap requests.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overridable Sub SetBitmapImpl ( _
    bitmapNumber As Integer, _
    station As PrinterStation, _
    fileName As String, _
    width As Integer, _
    alignment As Integer _
)
protected virtual void SetBitmapImpl (
    int bitmapNumber,
    PrinterStation station,
    string fileName,
    int width,
    int alignment
)
protected:
virtual void SetBitmapImpl (
    int bitmapNumber,
    PrinterStation station,
    String^ fileName,
    int width,
    int alignment
)
protected void SetBitmapImpl (
    int bitmapNumber,
    PrinterStation station,
    String fileName,
    int width,
    int alignment
)
protected function SetBitmapImpl (
    bitmapNumber : int,
    station : PrinterStation,
    fileName : String,
    width : int,
    alignment : int
)

Parameters

bitmapNumber

The number to be assigned to this bitmap. Two bitmaps, numbered 1 and 2, may be set.

station

The printer station to be used. Possible values are defined by the PrinterStation enumeration. Valid values are: PrinterStation.Receipt or PrinterStation.Slip.

fileName

Name of Windows bitmap file. The file must be in uncompressed format. If set to an empty string (“”), the bitmap is unset.

width

Width of the bitmap.

alignment

Placement of the bitmap.

Remarks

Called by the PosPrinterBase.SetBitmap method. By default, SetBitmapImpl throws a NotImplemented exception, but if the printer supports bitmap printing, the service object must provide an implementation of SetBitmapImpl that overrides the PosPrinterBase implementation. The service object’s implementation should not call the base class implementation of the method.

For parameter definitions, see the underlying method.

SetBitmapImpl should throw an ExtendedErrorTooBig exception if the bitmap is too large to print, an ExtendedErrorBadFormat if the bitmap is unprintable in its current format, and throw PosControlException exceptions for all other error conditions.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.SetLogo Method

PosPrinterBase.SetLogo Method |
 | See Also

1/18/2008

Saves a data string as the top or bottom logo.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub SetLogo ( _
    location As PrinterLogoLocation, _
    data As String _
)
public override void SetLogo (
    PrinterLogoLocation location,
    string data
)
public:
virtual void SetLogo (
    PrinterLogoLocation location,
    String^ data
) override
public void SetLogo (
    PrinterLogoLocation location,
    String data
)
public override function SetLogo (
    location : PrinterLogoLocation,
    data : String
)

Parameters

location

Where the logo is to be set. Possible values are defined by the PrinterLogoLocation enumeration as PrinterLogoLocation.Top or PrinterLogoLocation.Bottom.

data

Logo data.

Remarks

The PosPrinterBase class verifies that the application has the device opened, claimed, and enabled. PosPrinterBase validates the parameters and device state, and may throw PosControlException exceptions with the following ErrorCode:

Value | Meaning
Illegal | The specified location isn’t PrinterLogoLocation.Top or PrinterLogoLocation.Bottom;

If no exception is thrown, the PosPrinterBase class sets the PosPrinterProperties.TopLogo or PosPrinterProperties.BottomLogo properties to the specified data; or

Once these properties are set, the service object should use their values for the top or bottom logos if the application specifies the appropriate escape sequence in calls to the PrintNormal, PrintTwoNormal, or PrintImmediate methods.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.PrintNormal Method
PosPrinter.PrintTwoNormal Method
PosPrinter.PrintImmediate Method


PosPrinterBase.TransactionPrint Method

PosPrinterBase.TransactionPrint Method |
 | See Also

1/18/2008

Enters or exits transaction mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub TransactionPrint ( _
    station As PrinterStation, _
    control As PrinterTransactionControl _
)
public override void TransactionPrint (
    PrinterStation station,
    PrinterTransactionControl control
)
public:
virtual void TransactionPrint (
    PrinterStation station,
    PrinterTransactionControl control
) override
public void TransactionPrint (
    PrinterStation station,
    PrinterTransactionControl control
)
public override function TransactionPrint (
    station : PrinterStation,
    control : PrinterTransactionControl
)

Parameters

station

The printer station to be used. Possible values are defined by the PrinterStation enumeration. Valid values are: PrinterStation.Journal, PrinterStation.Receipt, or PrinterStation.Slip.

control

Transaction control. Possible values are defined by the PrinterTransactionControl enumeration.

Remarks

The PosPrinterBase class verifies that the application has the device opened, claimed, and enabled. PosPrinterBase validates the parameters and device state, and may throw PosControlException exceptions with the following values:

Value | Meaning
Other values | A physical condition exists that would preclude the operation—for example, the cover is open, the paper is removed, and so on. A full list of these exceptions is provided under PosPrinter.TransactionPrint.
Busy | The State property is set to ControlState.Busy (applies only if the AsyncMode property has been set to false and control is set to Normal);
Illegal | a) the print station must be PrinterStation.Receipt, PrinterStation.Slip, or PrinterStation.Journal; b) the requested printer station doesn’t exist (that is, the value of the CapRecPresent, CapJrnPresent, or CapSlpPresent property is false); c) the CapTransaction property is set to false, indicating that the printer doesn’t support transaction printing; d) the control parameter must be set to a valid PrinterTransactionControl value.

If no exception is thrown, the PosPrinterBase class calls TransactionPrintImpl to start or end transaction processing (as determined by the value of the control parameter).

TransactionPrintImpl is performed synchronously if AsyncMode is false, and asynchronously if AsyncMode is true.

See TransactionPrint for additional argument details.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.TransactionPrintImpl Method

PosPrinterBase.TransactionPrintImpl Method |
 | See Also

1/18/2008

Method implemented by service objects to process TransactionPrint requests.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overridable Function TransactionPrintImpl ( _
    collection As PrintOperationCollection _
) As PrintResults
protected virtual PrintResults TransactionPrintImpl (
    PrintOperationCollection collection
)
protected:
virtual PrintResults^ TransactionPrintImpl (
    PrintOperationCollection^ collection
)
protected PrintResults TransactionPrintImpl (
    PrintOperationCollection collection
)
protected function TransactionPrintImpl (
    collection : PrintOperationCollection
) : PrintResults

Parameters

collection

The collection of transaction print requests.

Remarks

Called by the PosPrinterBase.TransactionPrint method. By default, TransactionPrintImpl throws a NotImplemented exception, but if the printer supports a transaction-based printing, the service object must provide an implementation of TransactionPrintImpl that overrides the PosPrinterBase implementation. The service object’s implementation should not call the base class implementation of the method.

For parameter definitions, see the underlying method.

If errors occur, the service object should return an instance of the PrintResults class with the Error properties appropriately updated.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.ValidateData Method

PosPrinterBase.ValidateData Method |
 | See Also

1/18/2008

Validates data for a specified printer station.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub ValidateData ( _
    station As PrinterStation, _
    data As String _
)
public override void ValidateData (
    PrinterStation station,
    string data
)
public:
virtual void ValidateData (
    PrinterStation station,
    String^ data
) override
public void ValidateData (
    PrinterStation station,
    String data
)
public override function ValidateData (
    station : PrinterStation,
    data : String
)

Parameters

station

The PrinterStation for which the data will be validated.

data

The data that will be validated for the specified PrinterStation.

Remarks

The PosPrinterBase class verifies that the application has the device opened, claimed, and enabled. PosPrinterBase validates the parameters and device state, and may throw PosControlException exceptions with the following values:

Value | Meaning
Illegal | a) The requested printer station must be PrinterStation.Receipt, PrinterStation.Journal, PrinterStation.Slip; or b) the requested printer station doesn’t exist (that is, the value of the CapRecPresent, CapJrnPresent, or CapSlpPresent property is false).

If no exception is thrown, the PosPrinterBase class calls ValidatePrintImpl.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.ValidateData Method
ValidateDataImpl


PosPrinterBase.ValidateDataImpl Method

PosPrinterBase.ValidateDataImpl Method |
 | See Also

1/18/2008

Method implemented by the service object to process ValidateData requests.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected MustOverride Sub ValidateDataImpl ( _
    station As PrinterStation, _
    data As String _
)
protected abstract void ValidateDataImpl (
    PrinterStation station,
    string data
)
protected:
virtual void ValidateDataImpl (
    PrinterStation station,
    String^ data
) abstract
protected abstract void ValidateDataImpl (
    PrinterStation station,
    String data
)
protected abstract function ValidateDataImpl (
    station : PrinterStation,
    data : String
)

Parameters

station

The PrinterStation for which the data will be validated.

data

The data that will be validated for the specified PrinterStation.

Remarks

Called by the PosPrinterBase.ValidateData method. The service object must provide an implementation of ValidataDataImpl. For parameter definitions, see the underlying method.

ValidateDataImpl should throw PosControlException exceptions for all errors.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase Properties

PosPrinterBase Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
AsyncMode | Overridden. Indicates whether certain print methods will be performed asynchronously.
CapCharacterSet | Overridden. Holds the default character set capability.
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from PosPrinterBasic )
CapConcurrentJrnRec | Overridden. Indicates whether Journal and receipt stations can print at the same time.
CapConcurrentJrnSlp | Overridden. Indicates whether journal and slip stations can print at the same time.
CapConcurrentPageMode | Overridden. Indicates whether the printer is capable of supporting page mode for the receipt and slip stations concurrently.
CapConcurrentRecSlp | Overridden. Indicates whether receipt and slip stations can print at the same time.
CapCoverSensor | Overridden. Indicates whether the printer has a “cover open” sensor.
CapJrn2Color | Overridden. Indicates whether the journal can print dark plus an alternate color.
CapJrnBold | Overridden. Indicates whether the journal can print bold characters.
CapJrnCartridgeSensor | Overridden. Indicates the presence of journal cartridge monitoring sensors.
CapJrnColor | Overridden. Indicates available journal color cartridges.
CapJrnDHigh | Overridden. Indicates whether the journal can print double-high characters.
CapJrnDWide | Overridden. Indicates whether the journal can print double-wide characters.
CapJrnDWideDHigh | Overridden. Indicates whether the journal can print double-wide and double-high characters.
CapJrnEmptySensor | Overridden. Indicates whether the journal has an out-of-paper sensor.
CapJrnItalic | Overridden. Indicates whether the journal can print italic characters.
CapJrnNearEndSensor | Overridden. Indicates whether the journal has a low-paper sensor.
CapJrnPresent | Overridden. Indicates whether the journal print station is present.
CapJrnUnderline | Overridden. Indicates whether the journal can underline characters.
CapMapCharacterSet | Overridden. Indicates that the service object is able to map the characters sent my the application to a character set defined by the CharacterSetList property.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from PosPrinterBasic )
CapRec2Color | Overridden. Indicates whether the receipt can print dark plus an alternate color.
CapRecBarCode | Overridden. Indicates whether the receipt has bar code printing capability.
CapRecBitmap | Overridden. Indicates whether the receipt can print bitmaps.
CapRecBold | Overridden. Indicates whether the receipt can print bold text.
CapRecCartridgeSensor | Overridden. Indicates the presence of receipt cartridge monitoring sensors.
CapRecColor | Overridden. Indicates the receipt color cartridges.
CapRecDHigh | Overridden. Indicates whether the receipt can print double-high characters.
CapRecDWide | Overridden. Indicates whether the receipt can print double-wide characters.
CapRecDWideDHigh | Overridden. Indicates whether the receipt can print double-wide, double-high characters.
CapRecEmptySensor | Overridden. Indicates whether the receipt print station has an out-of-paper sensor.
CapRecItalic | Overridden. Indicates whether the receipt can print italic text.
CapRecLeft90 | Overridden. Indicates whether the receipt can print in rotated-90-degree-left mode.
CapRecMarkFeed | Overridden. Holds the type of mark-sensed paper handling available.
CapRecNearEndSensor | Overridden. Indicates whether the receipt has a low-paper sensor.
CapRecPageMode | Overridden. Gets a Boolean value that indicates whether the printer can support Page Mode for the receipt station.
CapRecPaperCut | Overridden. Indicates whether the receipt can perform paper cuts.
CapRecPresent | Overridden. Indicates that the receipt print station is present.
CapRecRight90 | Overridden. Indicates that the receipt can print in a rotated-90-degree-right mode.
CapRecRotate180 | Overridden. Indicates that the receipt can print in a rotated-180-degree mode.
CapRecStamp | Overridden. Indicates that the receipt has a stamp capability.
CapRecUnderline | Overridden. Indicates whether the receipt can underline characters.
CapSlp2Color | Overridden. Indicates that the slip can print dark plus an alternate color.
CapSlpBarCode | Overridden. Indicates that the slip has bar code printing capability.
CapSlpBitmap | Overridden. Indicates that the slip can print bitmaps.
CapSlpBold | Overridden. Indicates that the slip can print bold text.
CapSlpBothSidesPrint | Overridden. Indicates that the slip print station supports printing on both sides of the document.
CapSlpCartridgeSensor | Overridden. Indicates the presence of slip-cartridge monitoring sensors.
CapSlpColor | Overridden. Indicates which types of color cartridges supported for slip printing.
CapSlpDHigh | Overridden. Indicates that the slip can print double-high characters.
CapSlpDWide | Overridden. Indicates that the slip can print double-wide characters.
CapSlpDWideDHigh | Overridden. Indicates that the slip can print double-wide, double-high characters.
CapSlpEmptySensor | Overridden. Indicates that the slip has a “slip in” sensor.
CapSlpFullSlip | Overridden. Indicates whether the printer supports printing full-length forms on the slip station.
CapSlpItalic | Overridden. Indicates that the slip can print italic characters.
CapSlpLeft90 | Overridden. Indicates that the slip can print in a rotated 90 degree left mode.
CapSlpNearEndSensor | Overridden. Indicates whether the slip has a "slip near end" sensor.
CapSlpPageMode | Overridden. Indicates whether the printer is capable of supporting Page Mode for the slip station.
CapSlpPresent | Overridden. Indicates that the printer has a slip station.
CapSlpRight90 | Overridden. Indicates that the slip can print in a rotated 90 degree right mode.
CapSlpRotate180 | Overridden. Indicates that the slip can print in a rotated 180 degree mode.
CapSlpUnderline | Overridden. Indicates that the slip can print underlined characters.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from PosPrinterBasic )
CapTransaction | Overridden. Indicates whether or not each station supports printer transactions.
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from PosPrinterBasic )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from PosPrinterBasic )
CartridgeNotify | Overridden. Holds the type of cartridge state notification the application wants to receive.
CharacterSet | Overridden. Holds a numeric value indicating the character set the application wants to use for printing characters.
CharacterSetList | Overridden. Holds a list of character set numbers supported for printing.
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from PosPrinterBasic )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
CoverOpen | Overridden. Indicates the cover is open.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from PosPrinterBasic )
DeviceEnabled | Overridden. Gets or sets a Boolean value that indicates whether the device has been placed in an operational state.
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from PosPrinterBasic )
ErrorLevel | Overridden. Holds the severity of the most recent error condition.
ErrorStation | Overridden. Holds the station or stations that were printing when an error was detected.
ErrorString | Overridden. Holds a vendor-supplied description of the current error.
FlagWhenIdle | Overridden. If set to true by the application, the service object will queue a StatusUpdateEvent event using the StatusIdle constant when the device is in an idle state, and reset FlagWhenIdle to false.
FontTypefaceList | Overridden. Holds a string array that specifies the fonts and/or typefaces supported by the printer.
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from PosPrinterBasic )
JrnCartridgeState | Overridden. Holds the status of the selected journal cartridge (ink, ribbon, or toner).
JrnCurrentCartridge | Overridden. Holds the currently selected journal cartridge.
JrnEmpty | Overridden. If set to true, the journal is out of paper.
JrnLetterQuality | Overridden. If true, prints in high-quality mode. If false, prints in high-speed mode.
JrnLineChars | Overridden. Holds the number of characters that the application wants to print on a journal line.
JrnLineCharsList | Overridden. Holds a collection of the line widths (characters per line) supported by the journal station.
JrnLineHeight | Overridden. Holds the journal print line height the application wants to use, expressed in the unit of measure indicated by the MapMode property setting.
JrnLineSpacing | Overridden. Holds the spacing of each single-high print line, including both the printed line height and the white space between each pair of lines that the application wants to use.
JrnLineWidth | Overridden. Holds the width of a line for the number of characters indicated by the JrnLineChars property, expressed in the unit of measure indicated by the MapMode property.
JrnNearEnd | Overridden. If true, the journal paper is low.
MapCharacterSet | Overridden. If set to true by the application while outputting data, the service object maps the characters transferred by the application to the character set selected in the CharacterSet property.
MapMode | Overridden. Holds the mapping mode of the printer the application wants to use.
OutputId | Gets the identifier associated with the current output request. (inherited from PosPrinterBasic )
PageModeArea | Overridden. Holds the page area for the selected PageModeStation expressed in the unit of measure given by MapMode.
PageModeDescriptor | Overridden. Holds a value that indicates the level of basic Page Mode functionality for the printer.
PageModeHorizontalPosition | Overridden. Holds the horizontal start position offset within the print area for the selected PageModeStation, expressed in the unit of measure given by MapMode.
PageModePrintArea | Overridden. Holds the print area for the selected PageModeStation expressed in the unit of measure given by MapMode.
PageModePrintDirection | Overridden. Holds the print direction.
PageModeStation | Overridden. Gets and sets the print station for use by other Page Mode properties
PageModeVerticalPosition | Overridden. Holds the vertical start position offset within the print area for the selected PageModeStation.
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from PosPrinterBasic )
PowerState | Gets the current power condition. (inherited from PosPrinterBasic )
RecBarCodeRotationList | Overridden. Holds a list of the directions in which a receipt bar code can be rotated.
RecBitmapRotationList | Overridden. Holds a list of the directions in which a receipt bitmap can be rotated.
RecCartridgeState | Overridden. Holds the status of the selected receipt cartridge (ink, ribbon or toner).
RecCurrentCartridge | Overridden. Holds the receipt cartridge currently selected by the application.
RecEmpty | Overridden. If true, the receipt is out of paper.
RecLetterQuality | Overridden. If true, prints in high-quality mode. If false, prints in high-speed mode.
RecLineChars | Overridden. Holds the number of characters that the application wants to print on a receipt line.
RecLineCharsList | Overridden. Holds a collection of the line widths (characters per line) supported by the receipt station.
RecLineHeight | Overridden. Holds the receipt print line height, expressed in the unit of measure indicated by the MapMode property setting, that the application wants to use.
RecLineSpacing | Overridden. Holds the spacing of each single-high print line, including both the printed line height and the white space between each pair of lines, that the application wants to use.
RecLinesToPaperCut | Overridden. Holds the number of lines that must be advanced before cutting the receipt paper.
RecLineWidth | Overridden. Holds the width of a line, based on the number of characters specified in the RecLineChars property, expressed in the unit of measure indicated by the MapMode property.
RecNearEnd | Overridden. If true, the receipt paper is low.
RecSidewaysMaxChars | Overridden. Holds the maximum number of characters that can be printed on each line in sideways mode.
RecSidewaysMaxLines | Overridden. Holds the maximum number of lines that can be printed in sideways mode.
RotateSpecial | Overridden. Holds the rotation orientation for bar codes that the application wants to use.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from PosPrinterBasic )
ServiceObjectVersion | Gets the Service Object version number. (inherited from PosPrinterBasic )
SlpBarCodeRotationList | Overridden. Holds a collection of the directions in which a slip bar code may be rotated.
SlpBitmapRotationList | Overridden. Holds a collection of the directions in which a slip bitmap can be rotated.
SlpCartridgeState | Overridden. Holds the status of the selected slip cartridge (ink, ribbon, or toner).
SlpCurrentCartridge | Overridden. Holds the slip cartridge the application wants to use.
SlpEmpty | Overridden. If true, a slip form is not present.
SlpLetterQuality | Overridden. If true, prints in high-quality mode. If false, prints in high-speed mode.
SlpLineChars | Overridden. Holds the number of characters that the application wants to print on a slip line.
SlpLineCharsList | Overridden. Holds a collection of the line widths (characters per line) supported by the slip station.
SlpLineHeight | Overridden. Holds the slip print-line height, expressed in the unit of measure indicated by the MapMode property setting, that the application wants to use.
SlpLinesNearEndToEnd | Overridden. Holds the number of lines that can be printed after the SlpNearEnd property has been set to true but before the printer reaches the end of the slip.
SlpLineSpacing | Overridden. Holds the spacing of each single-high print line, including both the printed line height and the white space between each pair of lines that the application wants to use.
SlpLineWidth | Overridden. Holds the line width, based on the number of characters specified for the SlpLineChars property, expressed in the unit of measure indicated by the MapMode property.
SlpMaxLines | Overridden. Holds the maximum number of lines that can be printed on a form.
SlpNearEnd | Overridden. If true, the slip form is near its end.
SlpPrintSide | Overridden. Holds the side of the slip print station document on which printing will occur.
SlpSidewaysMaxChars | Overridden. Holds the maximum number of characters that can be printed on each line in sideways mode.
SlpSidewaysMaxLines | Overridden. Holds the maximum number of lines that can be printed in sideways mode.
State | Gets the current state of the device. (inherited from PosPrinterBasic )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )

Protected Properties

Name | Description
CommonProperties | (inherited from PosPrinterBasic )
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
ErrorCount | (inherited from PosPrinterBasic )
ExternallyClaimed | (inherited from PosPrinterBasic )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Gets a Boolean value that indicates whether the PosPrinter is an exclusive-use device. (inherited from PosPrinter )
OutputCount |
Properties | Returns a class of writable properties that can be used to modify the read-only properties used by applications.
StopCurrentOutput | Indicates whether output is stopped.
UseExternalPrintQueue | Indicates whether an external print queue is used.

See Also

Reference

PosPrinterBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace

Other Resources

Using Impl Methods for Synchronous or Asynchronous Output


PosPrinterBase.AsyncMode Property

PosPrinterBase.AsyncMode Property |
 | See Also

1/18/2008

Indicates whether certain print methods will be performed asynchronously.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property AsyncMode As Boolean
public override bool AsyncMode { get; set; }
public:
virtual property bool AsyncMode {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_AsyncMode ()

/** @property */
public void set_AsyncMode (boolean value)

public override function get AsyncMode () : boolean

public override function set AsyncMode (value : boolean)

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves or sets the value of PosPrinterProperties.AsyncMode.

AsyncMode is initialized to false by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.AsyncMode Property


PosPrinterBase.CapCharacterSet Property

PosPrinterBase.CapCharacterSet Property |
 | See Also

1/18/2008

Holds the default character set capability.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapCharacterSet As CharacterSetCapability
public override CharacterSetCapability CapCharacterSet { get; }
public:
virtual property CharacterSetCapability CapCharacterSet {
    CharacterSetCapability get () override;
}
/** @property */
public CharacterSetCapability get_CapCharacterSet ()

public override function get CapCharacterSet () : CharacterSetCapability

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapCharacterSet.

CapCharacterSet is initialized to CharacterSetCapability.Alpha by the PosPrinterProperties class. The service object should update CapCharacterSet to an appropriate value in its Open method. The PosPrinterProperties class may throw PosControlException exceptions with the following values:

Value | Meaning
Illegal | The service object has set the CapCharacterSet property to an invalid CharacterSetCapability value.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapCharacterSet Property


PosPrinterBase.CapConcurrentJrnRec Property

PosPrinterBase.CapConcurrentJrnRec Property |
 | See Also

1/18/2008

Indicates whether Journal and receipt stations can print at the same time.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapConcurrentJrnRec As Boolean
public override bool CapConcurrentJrnRec { get; }
public:
virtual property bool CapConcurrentJrnRec {
    bool get () override;
}
/** @property */
public boolean get_CapConcurrentJrnRec ()

public override function get CapConcurrentJrnRec () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapConcurrentJrnRec.

CapConcurrentJrnRec is initialized to false by the PosPrinterProperties class. The service object should update CapConcurrentJrnRec to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapConcurrentJrnRec Property


PosPrinterBase.CapConcurrentJrnSlp Property

PosPrinterBase.CapConcurrentJrnSlp Property |
 | See Also

1/18/2008

Indicates whether journal and slip stations can print at the same time.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapConcurrentJrnSlp As Boolean
public override bool CapConcurrentJrnSlp { get; }
public:
virtual property bool CapConcurrentJrnSlp {
    bool get () override;
}
/** @property */
public boolean get_CapConcurrentJrnSlp ()

public override function get CapConcurrentJrnSlp () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapConcurrentJrnSlp.

CapConcurrentJrnSlp is initialized to false by the PosPrinterProperties class. The service object should update CapConcurrentJrnSlp to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapConcurrentJrnSlp Property


PosPrinterBase.CapConcurrentPageMode Property

PosPrinterBase.CapConcurrentPageMode Property |
 | See Also

1/18/2008

Indicates whether the printer is capable of supporting page mode for the receipt and slip stations concurrently.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapConcurrentPageMode As Boolean
public override bool CapConcurrentPageMode { get; }
public:
virtual property bool CapConcurrentPageMode {
    bool get () override;
}
/** @property */
public boolean get_CapConcurrentPageMode ()

public override function get CapConcurrentPageMode () : boolean

Property Value

A boolean indicating whether the printer is capable of supporting page mode for the receipt and slip stations concurrently.

Remarks

If true, then the printer is capable of supporting Page Mode concurrently for both the receipt and slip stations. If Page Mode is not supported on either station, only on one station, or only on one station at a time, then this value should be false.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.CapConcurrentRecSlp Property

PosPrinterBase.CapConcurrentRecSlp Property |
 | See Also

1/18/2008

Indicates whether receipt and slip stations can print at the same time.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapConcurrentRecSlp As Boolean
public override bool CapConcurrentRecSlp { get; }
public:
virtual property bool CapConcurrentRecSlp {
    bool get () override;
}
/** @property */
public boolean get_CapConcurrentRecSlp ()

public override function get CapConcurrentRecSlp () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapConcurrentRecSlp.

CapConcurrentRecSlp is initialized to false by the PosPrinterProperties class. The service object should update CapConcurrentRecSlp to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapConcurrentRecSlp Property


PosPrinterBase.CapCoverSensor Property

PosPrinterBase.CapCoverSensor Property |
 | See Also

1/18/2008

Indicates whether the printer has a “cover open” sensor.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapCoverSensor As Boolean
public override bool CapCoverSensor { get; }
public:
virtual property bool CapCoverSensor {
    bool get () override;
}
/** @property */
public boolean get_CapCoverSensor ()

public override function get CapCoverSensor () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapCoverSensor.

CapCoverSensor is initialized to false by the PosPrinterProperties class. The service object should update CapCoverSensor to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapCoverSensor Property


PosPrinterBase.CapJrn2Color Property

PosPrinterBase.CapJrn2Color Property |
 | See Also

1/18/2008

Indicates whether the journal can print dark plus an alternate color.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapJrn2Color As Boolean
public override bool CapJrn2Color { get; }
public:
virtual property bool CapJrn2Color {
    bool get () override;
}
/** @property */
public boolean get_CapJrn2Color ()

public override function get CapJrn2Color () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapJrn2Color.

CapJrn2Color is initialized to false by the PosPrinterProperties class. The service object should update CapJrn2Color to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapJrn2Color Property


PosPrinterBase.CapJrnBold Property

PosPrinterBase.CapJrnBold Property |
 | See Also

1/18/2008

Indicates whether the journal can print bold characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapJrnBold As Boolean
public override bool CapJrnBold { get; }
public:
virtual property bool CapJrnBold {
    bool get () override;
}
/** @property */
public boolean get_CapJrnBold ()

public override function get CapJrnBold () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapJrnBold.

CapJrnBold is initialized to false by the PosPrinterProperties class. The service object should update CapJrnBold to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapJrnBold Property


PosPrinterBase.CapJrnCartridgeSensor Property

PosPrinterBase.CapJrnCartridgeSensor Property |
 | See Also

1/18/2008

Indicates the presence of journal cartridge monitoring sensors.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapJrnCartridgeSensor As PrinterCartridgeSensors
public override PrinterCartridgeSensors CapJrnCartridgeSensor { get; }
public:
virtual property PrinterCartridgeSensors CapJrnCartridgeSensor {
    PrinterCartridgeSensors get () override;
}
/** @property */
public PrinterCartridgeSensors get_CapJrnCartridgeSensor ()

public override function get CapJrnCartridgeSensor () : PrinterCartridgeSensors

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapJrnCartridgeSensor.

CapJrnCartridgeSensor is initialized to PrinterCartridgeSensors.None by the PosPrinterProperties class. The service object should update CapJrnCartridgeSensor to an appropriate value in its Open method. The PosPrinterProperties class may throw PosControlException exceptions with the following values:

Value | Meaning
Illegal | The service object has set the CapJrnCartridgeSensor property to an invalid PrinterCartridgeSensors value, or has attempted to set the CapJrnCartridgeSensor property to a value other than none while the CapJrnPresent property is set to false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapJrnCartridgeSensor Property


PosPrinterBase.CapJrnColor Property

PosPrinterBase.CapJrnColor Property |
 | See Also

1/18/2008

Indicates available journal color cartridges.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapJrnColor As PrinterColors
public override PrinterColors CapJrnColor { get; }
public:
virtual property PrinterColors CapJrnColor {
    PrinterColors get () override;
}
/** @property */
public PrinterColors get_CapJrnColor ()

public override function get CapJrnColor () : PrinterColors

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapJrnColor.

CapJrnColor is initialized to PrinterColors.None by the PosPrinterProperties class. The service object should update CapJrnColor to an appropriate value in its Open method. When the service object sets CapJrnColor, PosPrinterProperties may throw PosControlException exceptions with the following values:

Value

Meaning

Illegal

  • The CapJrnPresent property is set to false, indicating that there is no journal station on this printer. In this case, CapJrnColor should be set to PrinterColors.None;

  • CapJrnColor was set to PrinterColors.None, but the CapJrnPresent property is set to true, indicating that a journal station is present; or

  • CapJrnColor was set to a value not found in the PrinterColors enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapJrnColor Property
PrinterColors Enumeration


PosPrinterBase.CapJrnDHigh Property

PosPrinterBase.CapJrnDHigh Property |
 | See Also

1/18/2008

Indicates whether the journal can print double-high characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapJrnDHigh As Boolean
public override bool CapJrnDHigh { get; }
public:
virtual property bool CapJrnDHigh {
    bool get () override;
}
/** @property */
public boolean get_CapJrnDHigh ()

public override function get CapJrnDHigh () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapJrnDHigh.

CapJrnDHigh is initialized to false by the PosPrinterProperties class. The service object should update CapJrnDHigh to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapJrnDHigh Property


PosPrinterBase.CapJrnDWide Property

PosPrinterBase.CapJrnDWide Property |
 | See Also

1/18/2008

Indicates whether the journal can print double-wide characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapJrnDWide As Boolean
public override bool CapJrnDWide { get; }
public:
virtual property bool CapJrnDWide {
    bool get () override;
}
/** @property */
public boolean get_CapJrnDWide ()

public override function get CapJrnDWide () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves or sets the value of PosPrinterProperties.CapJrnDWide.

CapJrnDWide is initialized to false by the PosPrinterProperties class. The service object should update CapJrnDWide to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapJrnDWide Property


PosPrinterBase.CapJrnDWideDHigh Property

PosPrinterBase.CapJrnDWideDHigh Property |
 | See Also

1/18/2008

Indicates whether the journal can print double-wide and double-high characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapJrnDWideDHigh As Boolean
public override bool CapJrnDWideDHigh { get; }
public:
virtual property bool CapJrnDWideDHigh {
    bool get () override;
}
/** @property */
public boolean get_CapJrnDWideDHigh ()

public override function get CapJrnDWideDHigh () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapJrnDWideDHigh.

CapJrnDWideDHigh is initialized to false by the PosPrinterProperties class. The service object should update CapJrnDWideDHigh to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapJrnDWideDHigh Property


PosPrinterBase.CapJrnEmptySensor Property

PosPrinterBase.CapJrnEmptySensor Property |
 | See Also

1/18/2008

Indicates whether the journal has an out-of-paper sensor.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapJrnEmptySensor As Boolean
public override bool CapJrnEmptySensor { get; }
public:
virtual property bool CapJrnEmptySensor {
    bool get () override;
}
/** @property */
public boolean get_CapJrnEmptySensor ()

public override function get CapJrnEmptySensor () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapJrnEmptySensor.

CapJrnEmptySensor is initialized to false by the PosPrinterProperties class. The service object should update CapJrnEmptySensor to an appropriate value in its Open method. If the service object sets CapJrnEmptySensor to false, the PosPrinterBase class sets the PosPrinterProperties.JrnEmpty property to false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapJrnEmptySensor Property


PosPrinterBase.CapJrnItalic Property

PosPrinterBase.CapJrnItalic Property |
 | See Also

1/18/2008

Indicates whether the journal can print italic characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapJrnItalic As Boolean
public override bool CapJrnItalic { get; }
public:
virtual property bool CapJrnItalic {
    bool get () override;
}
/** @property */
public boolean get_CapJrnItalic ()

public override function get CapJrnItalic () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapJrnItalic.

CapJrnItalic is initialized by to false by the PosPrinterProperties class. The service object should update CapJrnItalic to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapJrnItalic Property


PosPrinterBase.CapJrnNearEndSensor Property

PosPrinterBase.CapJrnNearEndSensor Property |
 | See Also

1/18/2008

Indicates whether the journal has a low-paper sensor.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapJrnNearEndSensor As Boolean
public override bool CapJrnNearEndSensor { get; }
public:
virtual property bool CapJrnNearEndSensor {
    bool get () override;
}
/** @property */
public boolean get_CapJrnNearEndSensor ()

public override function get CapJrnNearEndSensor () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapJrnNearEndSensor.

CapJrnNearEndSensor is initialized to false by the PosPrinterProperties class. The service object should update CapJrnNearEndSensor to an appropriate value in its Open method. If the service object sets CapJrnNearEndSensor to false, the PosPrinterBase class sets PosPrinterProperties.JrnNearEnd to false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapJrnNearEndSensor Property


PosPrinterBase.CapJrnPresent Property

PosPrinterBase.CapJrnPresent Property |
 | See Also

1/18/2008

Indicates whether the journal print station is present.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapJrnPresent As Boolean
public override bool CapJrnPresent { get; }
public:
virtual property bool CapJrnPresent {
    bool get () override;
}
/** @property */
public boolean get_CapJrnPresent ()

public override function get CapJrnPresent () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapJrnPresent.

CapJrnPresent is initialized to false by the PosPrinterProperties class. The service object should update CapJrnPresent to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapJrnPresent Property


PosPrinterBase.CapJrnUnderline Property

PosPrinterBase.CapJrnUnderline Property |
 | See Also

1/18/2008

Indicates whether the journal can underline characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapJrnUnderline As Boolean
public override bool CapJrnUnderline { get; }
public:
virtual property bool CapJrnUnderline {
    bool get () override;
}
/** @property */
public boolean get_CapJrnUnderline ()

public override function get CapJrnUnderline () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapJrnUnderline.

CapJrnUnderline is initialized to false by the PosPrinterProperties class. The service object should update CapJrnUnderline to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapJrnUnderline Property


PosPrinterBase.CapMapCharacterSet Property

PosPrinterBase.CapMapCharacterSet Property |
 | See Also

1/18/2008

Indicates that the service object is able to map the characters sent my the application to a character set defined by the CharacterSetList property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapMapCharacterSet As Boolean
public override bool CapMapCharacterSet { get; }
public:
virtual property bool CapMapCharacterSet {
    bool get () override;
}
/** @property */
public boolean get_CapMapCharacterSet ()

public override function get CapMapCharacterSet () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapMapCharacterSet.

CapMapCharacterSet is initialized to false by the PosPrinterProperties class. The service object should update CapMapCharacterSet to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapMapCharacterSet Property


PosPrinterBase.CapRec2Color Property

PosPrinterBase.CapRec2Color Property |
 | See Also

1/18/2008

Indicates whether the receipt can print dark plus an alternate color.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapRec2Color As Boolean
public override bool CapRec2Color { get; }
public:
virtual property bool CapRec2Color {
    bool get () override;
}
/** @property */
public boolean get_CapRec2Color ()

public override function get CapRec2Color () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapRec2Color.

CapRec2Color is initialized to false by the PosPrinterProperties class. The service object should update CapRec2Color to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapRec2Color Property


PosPrinterBase.CapRecBarCode Property

PosPrinterBase.CapRecBarCode Property |
 | See Also

1/18/2008

Indicates whether the receipt has bar code printing capability.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapRecBarCode As Boolean
public override bool CapRecBarCode { get; }
public:
virtual property bool CapRecBarCode {
    bool get () override;
}
/** @property */
public boolean get_CapRecBarCode ()

public override function get CapRecBarCode () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapRecBarCode.

CapRecBarCode is initialized to false by the PosPrinterProperties class. The service object should update CapRecBarCode to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapRecBarCode Property


PosPrinterBase.CapRecBitmap Property

PosPrinterBase.CapRecBitmap Property |
 | See Also

1/18/2008

Indicates whether the receipt can print bitmaps.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapRecBitmap As Boolean
public override bool CapRecBitmap { get; }
public:
virtual property bool CapRecBitmap {
    bool get () override;
}
/** @property */
public boolean get_CapRecBitmap ()

public override function get CapRecBitmap () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapRecBitmap.

CapRecBitmap is initialized to false by the PosPrinterProperties class. The service object should update CapRecBitmap to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapRecBitmap Property


PosPrinterBase.CapRecBold Property

PosPrinterBase.CapRecBold Property |
 | See Also

1/18/2008

Indicates whether the receipt can print bold text.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapRecBold As Boolean
public override bool CapRecBold { get; }
public:
virtual property bool CapRecBold {
    bool get () override;
}
/** @property */
public boolean get_CapRecBold ()

public override function get CapRecBold () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapRecBold.

CapRecBold is initialized to false by the PosPrinterProperties class. The service object should update CapRecBold to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapRecBold Property


PosPrinterBase.CapRecCartridgeSensor Property

PosPrinterBase.CapRecCartridgeSensor Property |
 | See Also

1/18/2008

Indicates the presence of receipt cartridge monitoring sensors.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapRecCartridgeSensor As PrinterCartridgeSensors
public override PrinterCartridgeSensors CapRecCartridgeSensor { get; }
public:
virtual property PrinterCartridgeSensors CapRecCartridgeSensor {
    PrinterCartridgeSensors get () override;
}
/** @property */
public PrinterCartridgeSensors get_CapRecCartridgeSensor ()

public override function get CapRecCartridgeSensor () : PrinterCartridgeSensors

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapRecCartridgeSensor. If the CapRecPresent property is set to false, a value of PrinterCartridgeSensors.None is returned.

CapRecCartridgeSensor is initialized to PrinterCartridgeSensors.None by the PosPrinterProperties class. The service object should update CapRecCartridgeSensor to an appropriate value in its Open method. The PosPrinterProperties class may throw PosControlException exceptions with the following values:

Value | Meaning
Illegal | The service object has set the CapRecCartridgeSensor property to an invalid PrinterCartridgeSensors value.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapRecCartridgeSensor Property


PosPrinterBase.CapRecColor Property

PosPrinterBase.CapRecColor Property |
 | See Also

1/18/2008

Indicates the receipt color cartridges.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapRecColor As PrinterColors
public override PrinterColors CapRecColor { get; }
public:
virtual property PrinterColors CapRecColor {
    PrinterColors get () override;
}
/** @property */
public PrinterColors get_CapRecColor ()

public override function get CapRecColor () : PrinterColors

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapRecColor. If CapRecPresent is set to false, a value of PrinterColors.None is returned.

CapRecColor is initialized to PrinterColors.None by the PosPrinterProperties class. The service object should update CapRecColor to an appropriate value in its Open method. When the service object sets CapRecColor, the PosPrinterProperties class may throw a PosControlException exception with the following ErrorCode:

Value

Meaning

Illegal

  • The CapRecPresent property is set to false, indicating that there is no receipt station on this printer. In this case, CapRecColor should be set to PrinterColors.None;

  • CapRecColor was set to PrinterColors.None, but the CapRecPresent property is set to true, indicating that a receipt station is present; or

  • CapRecColor was set to a value not found in the PrinterColors enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapRecColor Property


PosPrinterBase.CapRecDHigh Property

PosPrinterBase.CapRecDHigh Property |
 | See Also

1/18/2008

Indicates whether the receipt can print double-high characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapRecDHigh As Boolean
public override bool CapRecDHigh { get; }
public:
virtual property bool CapRecDHigh {
    bool get () override;
}
/** @property */
public boolean get_CapRecDHigh ()

public override function get CapRecDHigh () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapRecDHigh.

CapRecDHigh is initialized to false by the PosPrinterProperties class. The service object should update CapRecDHigh to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapRecDHigh Property


PosPrinterBase.CapRecDWide Property

PosPrinterBase.CapRecDWide Property |
 | See Also

1/18/2008

Indicates whether the receipt can print double-wide characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapRecDWide As Boolean
public override bool CapRecDWide { get; }
public:
virtual property bool CapRecDWide {
    bool get () override;
}
/** @property */
public boolean get_CapRecDWide ()

public override function get CapRecDWide () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapRecDWide.

CapRecDWide is initialized to false by the PosPrinterProperties class. The service object should update CapRecDWide to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapRecDWide Property


PosPrinterBase.CapRecDWideDHigh Property

PosPrinterBase.CapRecDWideDHigh Property |
 | See Also

1/18/2008

Indicates whether the receipt can print double-wide, double-high characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapRecDWideDHigh As Boolean
public override bool CapRecDWideDHigh { get; }
public:
virtual property bool CapRecDWideDHigh {
    bool get () override;
}
/** @property */
public boolean get_CapRecDWideDHigh ()

public override function get CapRecDWideDHigh () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapRecDWideDHigh.

CapRecDWideDHigh is initialized to false by the PosPrinterProperties class. The service object should update CapRecDWideDHigh to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapRecDWideDHigh Property


PosPrinterBase.CapRecEmptySensor Property

PosPrinterBase.CapRecEmptySensor Property |
 | See Also

1/18/2008

Indicates whether the receipt print station has an out-of-paper sensor.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapRecEmptySensor As Boolean
public override bool CapRecEmptySensor { get; }
public:
virtual property bool CapRecEmptySensor {
    bool get () override;
}
/** @property */
public boolean get_CapRecEmptySensor ()

public override function get CapRecEmptySensor () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapRecEmptySensor.

CapRecEmptySensor is initialized to false by the PosPrinterProperties class. The service object should update CapRecEmptySensor to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapRecEmptySensor Property


PosPrinterBase.CapRecItalic Property

PosPrinterBase.CapRecItalic Property |
 | See Also

1/18/2008

Indicates whether the receipt can print italic text.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapRecItalic As Boolean
public override bool CapRecItalic { get; }
public:
virtual property bool CapRecItalic {
    bool get () override;
}
/** @property */
public boolean get_CapRecItalic ()

public override function get CapRecItalic () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapRecItalic.

CapRecItalic is initialized to false by the PosPrinterProperties class. The service object should update CapRecItalic to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapRecItalic Property


PosPrinterBase.CapRecLeft90 Property

PosPrinterBase.CapRecLeft90 Property |
 | See Also

1/18/2008

Indicates whether the receipt can print in rotated-90-degree-left mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapRecLeft90 As Boolean
public override bool CapRecLeft90 { get; }
public:
virtual property bool CapRecLeft90 {
    bool get () override;
}
/** @property */
public boolean get_CapRecLeft90 ()

public override function get CapRecLeft90 () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapRecLeft90.

CapRecLeft90 is initialized to false by the PosPrinterProperties class. The service object should update CapRecLeft90 to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapRecLeft90 Property


PosPrinterBase.CapRecMarkFeed Property

PosPrinterBase.CapRecMarkFeed Property |
 | See Also

1/18/2008

Holds the type of mark-sensed paper handling available.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapRecMarkFeed As PrinterMarkFeeds
public override PrinterMarkFeeds CapRecMarkFeed { get; }
public:
virtual property PrinterMarkFeeds CapRecMarkFeed {
    PrinterMarkFeeds get () override;
}
/** @property */
public PrinterMarkFeeds get_CapRecMarkFeed ()

public override function get CapRecMarkFeed () : PrinterMarkFeeds

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapRecMarkFeed.

CapRecMarkFeed is initialized to PrinterMarkFeeds.None by the PosPrinterProperties class. The service object should update CapRecMarkFeeds to an appropriate value in its Open method. If the service object sets CapRecMarkFeed to an invalid PrinterMarkFeeds value, the PosPrinterProperties class may throw PosControlException exceptions with the following values:

Value | Meaning
Illegal | The service object has set CapRecMarkFeed to an invalid PrinterMarkFeeds value.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapRecMarkFeed Property


PosPrinterBase.CapRecNearEndSensor Property

PosPrinterBase.CapRecNearEndSensor Property |
 | See Also

1/18/2008

Indicates whether the receipt has a low-paper sensor.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapRecNearEndSensor As Boolean
public override bool CapRecNearEndSensor { get; }
public:
virtual property bool CapRecNearEndSensor {
    bool get () override;
}
/** @property */
public boolean get_CapRecNearEndSensor ()

public override function get CapRecNearEndSensor () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapRecNearEndSensor.

CapRecNearEndSensor is initialized to false by the PosPrinterProperties class. The service object should update CapRecNearEndSensor to an appropriate value in its Open method. If the service object sets CapRecNearEndSensor to false, the PosPrinterProperties class sets RecNearEnd to false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapRecNearEndSensor Property


PosPrinterBase.CapRecPageMode Property

PosPrinterBase.CapRecPageMode Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the printer can support Page Mode for the receipt station.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapRecPageMode As Boolean
public override bool CapRecPageMode { get; }
public:
virtual property bool CapRecPageMode {
    bool get () override;
}
/** @property */
public boolean get_CapRecPageMode ()

public override function get CapRecPageMode () : boolean

Remarks

If true, the printer can support Page Mode for the receipt station.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.CapRecPaperCut Property

PosPrinterBase.CapRecPaperCut Property |
 | See Also

1/18/2008

Indicates whether the receipt can perform paper cuts.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapRecPaperCut As Boolean
public override bool CapRecPaperCut { get; }
public:
virtual property bool CapRecPaperCut {
    bool get () override;
}
/** @property */
public boolean get_CapRecPaperCut ()

public override function get CapRecPaperCut () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapRecPapercut.

CapRecPapercut is initialized to false by the PosPrinterProperties class. The service object should update CapRecPapercut to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapRecPaperCut Property


PosPrinterBase.CapRecPresent Property

PosPrinterBase.CapRecPresent Property |
 | See Also

1/18/2008

Indicates that the receipt print station is present.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapRecPresent As Boolean
public override bool CapRecPresent { get; }
public:
virtual property bool CapRecPresent {
    bool get () override;
}
/** @property */
public boolean get_CapRecPresent ()

public override function get CapRecPresent () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapRecPresent.

CapRecPresent is initialized to false by the PosPrinterProperties class. The service object should update CapRecPresent to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapRecPresent Property


PosPrinterBase.CapRecRight90 Property

PosPrinterBase.CapRecRight90 Property |
 | See Also

1/18/2008

Indicates that the receipt can print in a rotated-90-degree-right mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapRecRight90 As Boolean
public override bool CapRecRight90 { get; }
public:
virtual property bool CapRecRight90 {
    bool get () override;
}
/** @property */
public boolean get_CapRecRight90 ()

public override function get CapRecRight90 () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapRecRight90.

CapRecRight90 is initialized to false by the PosPrinterProperties class. The service object should update CapRecRight90 to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapRecRight90 Property


PosPrinterBase.CapRecRotate180 Property

PosPrinterBase.CapRecRotate180 Property |
 | See Also

1/18/2008

Indicates that the receipt can print in a rotated-180-degree mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapRecRotate180 As Boolean
public override bool CapRecRotate180 { get; }
public:
virtual property bool CapRecRotate180 {
    bool get () override;
}
/** @property */
public boolean get_CapRecRotate180 ()

public override function get CapRecRotate180 () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapRecRotate180.

CapRecRotate180 is initialized to false by the PosPrinterProperties class. The service object should update CapRecRotate180 to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapRecRotate180 Property


PosPrinterBase.CapRecStamp Property

PosPrinterBase.CapRecStamp Property |
 | See Also

1/18/2008

Indicates that the receipt has a stamp capability.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapRecStamp As Boolean
public override bool CapRecStamp { get; }
public:
virtual property bool CapRecStamp {
    bool get () override;
}
/** @property */
public boolean get_CapRecStamp ()

public override function get CapRecStamp () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapRecStamp.

CapRecStamp is initialized to false by the PosPrinterProperties class. The service object should update CapRecStamp to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapRecStamp Property


PosPrinterBase.CapRecUnderline Property

PosPrinterBase.CapRecUnderline Property |
 | See Also

1/18/2008

Indicates whether the receipt can underline characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapRecUnderline As Boolean
public override bool CapRecUnderline { get; }
public:
virtual property bool CapRecUnderline {
    bool get () override;
}
/** @property */
public boolean get_CapRecUnderline ()

public override function get CapRecUnderline () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapRecUnderline.

CapRecUnderline is initialized to false by the PosPrinterProperties class. The service object should update CapRecUnderline to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapRecUnderline Property


PosPrinterBase.CapSlp2Color Property

PosPrinterBase.CapSlp2Color Property |
 | See Also

1/18/2008

Indicates that the slip can print dark plus an alternate color.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapSlp2Color As Boolean
public override bool CapSlp2Color { get; }
public:
virtual property bool CapSlp2Color {
    bool get () override;
}
/** @property */
public boolean get_CapSlp2Color ()

public override function get CapSlp2Color () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapSlp2Color.

CapSlp2Color is initialized to false by the PosPrinterProperties class. The service object should update CapSlp2Color to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapSlp2Color Property


PosPrinterBase.CapSlpBarCode Property

PosPrinterBase.CapSlpBarCode Property |
 | See Also

1/18/2008

Indicates that the slip has bar code printing capability.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapSlpBarCode As Boolean
public override bool CapSlpBarCode { get; }
public:
virtual property bool CapSlpBarCode {
    bool get () override;
}
/** @property */
public boolean get_CapSlpBarCode ()

public override function get CapSlpBarCode () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapSlpBarCode.

CapSlpBarCode is initialized to false by the PosPrinterProperties class. The service object should update CapSlpBarCode to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapSlpBarCode Property


PosPrinterBase.CapSlpBitmap Property

PosPrinterBase.CapSlpBitmap Property |
 | See Also

1/18/2008

Indicates that the slip can print bitmaps.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapSlpBitmap As Boolean
public override bool CapSlpBitmap { get; }
public:
virtual property bool CapSlpBitmap {
    bool get () override;
}
/** @property */
public boolean get_CapSlpBitmap ()

public override function get CapSlpBitmap () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapSlpBitmap.

CapSlpBitmap is initialized to false by the PosPrinterProperties class. The service object should update CapSlpBitmap to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapSlpBitmap Property


PosPrinterBase.CapSlpBold Property

PosPrinterBase.CapSlpBold Property |
 | See Also

1/18/2008

Indicates that the slip can print bold text.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapSlpBold As Boolean
public override bool CapSlpBold { get; }
public:
virtual property bool CapSlpBold {
    bool get () override;
}
/** @property */
public boolean get_CapSlpBold ()

public override function get CapSlpBold () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapSlpBold.

CapSlpBold is initialized to false by the PosPrinterProperties class. The service object should update CapSlpBold to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapSlpBold Property


PosPrinterBase.CapSlpBothSidesPrint Property

PosPrinterBase.CapSlpBothSidesPrint Property |
 | See Also

1/18/2008

Indicates that the slip print station supports printing on both sides of the document.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapSlpBothSidesPrint As Boolean
public override bool CapSlpBothSidesPrint { get; }
public:
virtual property bool CapSlpBothSidesPrint {
    bool get () override;
}
/** @property */
public boolean get_CapSlpBothSidesPrint ()

public override function get CapSlpBothSidesPrint () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapSlpBothSidesPrint.

CapSlpBothSidesPrint is initialized to false by the PosPrinterProperties class. The service object should update CapSlpBothSidesPrint to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapSlpBothSidesPrint Property


PosPrinterBase.CapSlpCartridgeSensor Property

PosPrinterBase.CapSlpCartridgeSensor Property |
 | See Also

1/18/2008

Indicates the presence of slip-cartridge monitoring sensors.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapSlpCartridgeSensor As PrinterCartridgeSensors
public override PrinterCartridgeSensors CapSlpCartridgeSensor { get; }
public:
virtual property PrinterCartridgeSensors CapSlpCartridgeSensor {
    PrinterCartridgeSensors get () override;
}
/** @property */
public PrinterCartridgeSensors get_CapSlpCartridgeSensor ()

public override function get CapSlpCartridgeSensor () : PrinterCartridgeSensors

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapSlpCartridgeSensor. If the CapSlpPresent property is set to false, a value of PrinterCartridgeSensors.None is returned.

CapSlpCartridgeSensor is initialized to PrinterCartridgeSensors.None by the PosPrinterProperties class. The service object should update CapSlpCartridgeSensor to an appropriate value in its Open method. The PosPrinterProperties class may throw PosControlException exceptions with the following values:

Value | Meaning
Illegal | The service object has set the CapSlpCartridgeSensor property to an invalid PrinterCartridgeSensors value.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapSlpCartridgeSensor Property


PosPrinterBase.CapSlpColor Property

PosPrinterBase.CapSlpColor Property |
 | See Also

1/18/2008

Indicates which types of color cartridges supported for slip printing.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapSlpColor As PrinterColors
public override PrinterColors CapSlpColor { get; }
public:
virtual property PrinterColors CapSlpColor {
    PrinterColors get () override;
}
/** @property */
public PrinterColors get_CapSlpColor ()

public override function get CapSlpColor () : PrinterColors

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapSlpColor. If CapSlpPresent is set to false, a value of PrinterColors.None is returned.

CapSlpColor is initialized to PrinterColors.None by the PosPrinterProperties class. The service object should update CapSlpColor to an appropriate value in its Open method. When the service object sets CapSlpColor, the PosPrinterProperties class may throw a PosControlException exception the following Errorcode:

Value

Meaning

Illegal

  • The CapSlpPresent property is set to false, indicating that there is no receipt station on this printer. In this case, CapSlpColor should be set to PrinterColors.None;

  • CapSlpColor was set to PrinterColors.None, but the CapSlpPresent property is set to true, indicating that a receipt station is present; or

  • CapSlpColor was set to a value not found in the PrinterColors enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapSlpColor Property


PosPrinterBase.CapSlpDHigh Property

PosPrinterBase.CapSlpDHigh Property |
 | See Also

1/18/2008

Indicates that the slip can print double-high characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapSlpDHigh As Boolean
public override bool CapSlpDHigh { get; }
public:
virtual property bool CapSlpDHigh {
    bool get () override;
}
/** @property */
public boolean get_CapSlpDHigh ()

public override function get CapSlpDHigh () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapSlpDHigh.

CapSlpDHigh is initialized to false by the PosPrinterProperties class. The service object should update CapSlpDHigh to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapSlpDHigh Property


PosPrinterBase.CapSlpDWide Property

PosPrinterBase.CapSlpDWide Property |
 | See Also

1/18/2008

Indicates that the slip can print double-wide characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapSlpDWide As Boolean
public override bool CapSlpDWide { get; }
public:
virtual property bool CapSlpDWide {
    bool get () override;
}
/** @property */
public boolean get_CapSlpDWide ()

public override function get CapSlpDWide () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapSlpDWide.

CapSlpDWide is initialized to false by the PosPrinterProperties class. The service object should update CapSlpDWide to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapSlpDWide Property


PosPrinterBase.CapSlpDWideDHigh Property

PosPrinterBase.CapSlpDWideDHigh Property |
 | See Also

1/18/2008

Indicates that the slip can print double-wide, double-high characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapSlpDWideDHigh As Boolean
public override bool CapSlpDWideDHigh { get; }
public:
virtual property bool CapSlpDWideDHigh {
    bool get () override;
}
/** @property */
public boolean get_CapSlpDWideDHigh ()

public override function get CapSlpDWideDHigh () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapSlpDWideDHigh.

CapSlpDWideDHigh is initialized to false by the PosPrinterProperties class. The service object should update CapSlpDWideDHigh to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapSlpDWideDHigh Property


PosPrinterBase.CapSlpEmptySensor Property

PosPrinterBase.CapSlpEmptySensor Property |
 | See Also

1/18/2008

Indicates that the slip has a “slip in” sensor.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapSlpEmptySensor As Boolean
public override bool CapSlpEmptySensor { get; }
public:
virtual property bool CapSlpEmptySensor {
    bool get () override;
}
/** @property */
public boolean get_CapSlpEmptySensor ()

public override function get CapSlpEmptySensor () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapSlpEmptySensor.

CapSlpEmptySensor is initialized to false by the PosPrinterProperties class. The service object should update CapSlpEmptySensor to an appropriate value in its Open method. If the service object sets CapSlpEmptySensor to false, the PosPrinterProperties class sets SlpEmpty to false as well.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapSlpEmptySensor Property


PosPrinterBase.CapSlpFullSlip Property

PosPrinterBase.CapSlpFullSlip Property |
 | See Also

1/18/2008

Indicates whether the printer supports printing full-length forms on the slip station.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapSlpFullSlip As Boolean
public override bool CapSlpFullSlip { get; }
public:
virtual property bool CapSlpFullSlip {
    bool get () override;
}
/** @property */
public boolean get_CapSlpFullSlip ()

public override function get CapSlpFullSlip () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapSlpFullslip.

CapSlpFullslip is initialized to false by the PosPrinterProperties class. The service object should update CapSlpFullslip to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CapSlpFullslip


PosPrinterBase.CapSlpItalic Property

PosPrinterBase.CapSlpItalic Property |
 | See Also

1/18/2008

Indicates that the slip can print italic characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapSlpItalic As Boolean
public override bool CapSlpItalic { get; }
public:
virtual property bool CapSlpItalic {
    bool get () override;
}
/** @property */
public boolean get_CapSlpItalic ()

public override function get CapSlpItalic () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapSlpItalic.

CapSlpItalic is initialized to false by the PosPrinterProperties class. The service object should update CapSlpItalic to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapSlpItalic Property


PosPrinterBase.CapSlpLeft90 Property

PosPrinterBase.CapSlpLeft90 Property |
 | See Also

1/18/2008

Indicates that the slip can print in a rotated 90 degree left mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapSlpLeft90 As Boolean
public override bool CapSlpLeft90 { get; }
public:
virtual property bool CapSlpLeft90 {
    bool get () override;
}
/** @property */
public boolean get_CapSlpLeft90 ()

public override function get CapSlpLeft90 () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapSlpLeft90.

CapSlpLeft90 is initialized to false by the PosPrinterProperties class. The service object should update CapSlpLeft90 to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapSlpLeft90 Property


PosPrinterBase.CapSlpNearEndSensor Property

PosPrinterBase.CapSlpNearEndSensor Property |
 | See Also

1/18/2008

Indicates whether the slip has a "slip near end" sensor.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapSlpNearEndSensor As Boolean
public override bool CapSlpNearEndSensor { get; }
public:
virtual property bool CapSlpNearEndSensor {
    bool get () override;
}
/** @property */
public boolean get_CapSlpNearEndSensor ()

public override function get CapSlpNearEndSensor () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapSlpNearEndSensor.

CapSlpNearEndSensor is initialized to false by the PosPrinterProperties class. The service object should update CapSlpNearEndSensor to an appropriate value in its Open method. If the service object sets CapSlpNearEndSensor to false, the PosPrinterProperties class sets SlpNearEnd to false as well.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapSlpNearEndSensor Property


PosPrinterBase.CapSlpPageMode Property

PosPrinterBase.CapSlpPageMode Property |
 | See Also

1/18/2008

Indicates whether the printer is capable of supporting Page Mode for the slip station.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapSlpPageMode As Boolean
public override bool CapSlpPageMode { get; }
public:
virtual property bool CapSlpPageMode {
    bool get () override;
}
/** @property */
public boolean get_CapSlpPageMode ()

public override function get CapSlpPageMode () : boolean

Property Value

A boolean indicating whether the printer is capable of supporting Page Mode for the slip station.

Remarks

If true, then the printer is capable of supporting Page Mode for the slip station.

This property is initialized by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.CapSlpPresent Property

PosPrinterBase.CapSlpPresent Property |
 | See Also

1/18/2008

Indicates that the printer has a slip station.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapSlpPresent As Boolean
public override bool CapSlpPresent { get; }
public:
virtual property bool CapSlpPresent {
    bool get () override;
}
/** @property */
public boolean get_CapSlpPresent ()

public override function get CapSlpPresent () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapSlpPresent.

CapSlpPresent is initialized to false by the PosPrinterProperties class. The service object should update CapSlpPresent to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapSlpPresent Property


PosPrinterBase.CapSlpRight90 Property

PosPrinterBase.CapSlpRight90 Property |
 | See Also

1/18/2008

Indicates that the slip can print in a rotated 90 degree right mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapSlpRight90 As Boolean
public override bool CapSlpRight90 { get; }
public:
virtual property bool CapSlpRight90 {
    bool get () override;
}
/** @property */
public boolean get_CapSlpRight90 ()

public override function get CapSlpRight90 () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapSlpRight90.

CapSlpRight90 is initialized to false by the PosPrinterProperties class. The service object should update CapSlpRight90 to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapSlpRight90 Property


PosPrinterBase.CapSlpRotate180 Property

PosPrinterBase.CapSlpRotate180 Property |
 | See Also

1/18/2008

Indicates that the slip can print in a rotated 180 degree mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapSlpRotate180 As Boolean
public override bool CapSlpRotate180 { get; }
public:
virtual property bool CapSlpRotate180 {
    bool get () override;
}
/** @property */
public boolean get_CapSlpRotate180 ()

public override function get CapSlpRotate180 () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapSlpRotate180.

CapSlpRotate180 is initialized to false by the PosPrinterProperties class. The service object should update CapSlpRotate180 to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapSlpRotate180 Property


PosPrinterBase.CapSlpUnderline Property

PosPrinterBase.CapSlpUnderline Property |
 | See Also

1/18/2008

Indicates that the slip can print underlined characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapSlpUnderline As Boolean
public override bool CapSlpUnderline { get; }
public:
virtual property bool CapSlpUnderline {
    bool get () override;
}
/** @property */
public boolean get_CapSlpUnderline ()

public override function get CapSlpUnderline () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapSlpUnderline.

CapSlpUnderline is initialized to false by the PosPrinterProperties class. The service object should update CapSlpUnderline to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapSlpUnderline Property


PosPrinterBase.CapTransaction Property

PosPrinterBase.CapTransaction Property |
 | See Also

1/18/2008

Indicates whether or not each station supports printer transactions.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapTransaction As Boolean
public override bool CapTransaction { get; }
public:
virtual property bool CapTransaction {
    bool get () override;
}
/** @property */
public boolean get_CapTransaction ()

public override function get CapTransaction () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CapTransaction.

CapTransaction is initialized to false by the PosPrinterProperties class. The service object should update CapTransaction to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CapTransaction Property


PosPrinterBase.CartridgeNotify Property

PosPrinterBase.CartridgeNotify Property |
 | See Also

1/18/2008

Holds the type of cartridge state notification the application wants to receive.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property CartridgeNotify As PrinterCartridgeNotify
public override PrinterCartridgeNotify CartridgeNotify { get; set; }
public:
virtual property PrinterCartridgeNotify CartridgeNotify {
    PrinterCartridgeNotify get () override;
    void set (PrinterCartridgeNotify value) override;
}
/** @property */
public PrinterCartridgeNotify get_CartridgeNotify ()

/** @property */
public void set_CartridgeNotify (PrinterCartridgeNotify value)

public override function get CartridgeNotify () : PrinterCartridgeNotify

public override function set CartridgeNotify (value : PrinterCartridgeNotify)

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves or sets the value of PosPrinterProperties.CartridgeNotify. If the application sets CartridgeNotify to an invalid PrinterCartridgeNotify value, PosPrinterProperties throws a PosControlException exception with ErrorCode set to ErrorCode.Illegal.

CartridgeNotify is initialized to PrinterCartridgeNotify.Disabled by the PosPrinterProperties class.

Accessing CartridgeNotify can cause a PosControlException exception with the following ErrorCode to be thrown:

Value

Meaning

Illegal

  • CartridgeNotify can’t be set while the device is enabled;

  • CartridgeNotify was set to a value that isn’t valid for the PrinterCartridgeNotify enumeration; or

  • CartridgeNotify is set to PrinterCartridgeNotify.Enabled but the CapJrnCartridgeSensor, CapRecCartridgeSensor, and CapSlpCartridgeSensor properties are set to PrinterCartridgeSensors.None.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CartridgeNotify Property
PrinterCartridgeNotify Enumeration


PosPrinterBase.CharacterSet Property

PosPrinterBase.CharacterSet Property |
 | See Also

1/18/2008

Holds a numeric value indicating the character set the application wants to use for printing characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property CharacterSet As Integer
public override int CharacterSet { get; set; }
public:
virtual property int CharacterSet {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_CharacterSet ()

/** @property */
public void set_CharacterSet (int value)

public override function get CharacterSet () : int

public override function set CharacterSet (value : int)

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves or sets the value of PosPrinterProperties.CharacterSet. If the application sets CharacterSet to a value that doesn’t exist in the CharacterSetList property array, PosPrinterProperties may throw PosControlException exceptions with the following values:

Value | Meaning
Illegal | The service object has set the CharacterSet property to a value that doesn't exist in the CharacterSetList array.

CharacterSet is initialized to -1 by the PosPrinterProperties class. The service object should update CharacterSet to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CharacterSet Property


PosPrinterBase.CharacterSetList Property

PosPrinterBase.CharacterSetList Property |
 | See Also

1/18/2008

Holds a list of character set numbers supported for printing.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CharacterSetList As Integer()
public override int[] CharacterSetList { get; }
public:
virtual property array<int>^ CharacterSetList {
    array<int>^ get () override;
}
/** @property */
public int[] get_CharacterSetList ()

public override function get CharacterSetList () : int[]

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.CharacterSetList.

CharacterSetList is initialized to an empty integer array by the PosPrinterProperties class. The service object should set CharacterSetList to the character sets available for mapping in its Open method. If the service object attempts to set CharacterSetList to an empty array or null, or if any of the specified array values 0 (zero) or less than zero, PosPrinterProperties may throw PosControlException exceptions with the following values:

Value | Meaning
Illegal | The service object has set the CharacterSet property to a value that doesn't exist in the CharacterSetList array.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CharacterSetList Property


PosPrinterBase.CoverOpen Property

PosPrinterBase.CoverOpen Property |
 | See Also

1/18/2008

Indicates the cover is open.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CoverOpen As Boolean
public override bool CoverOpen { get; }
public:
virtual property bool CoverOpen {
    bool get () override;
}
/** @property */
public boolean get_CoverOpen ()

public override function get CoverOpen () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves the value of PosPrinterProperties.CoverOpen.

CoverOpen is initialized to false by the PosPrinterProperties class and should be kept current by the service object while the printer device is enabled.

The PosPrinterProperties class may throw PosControlException exceptions with the following values:

Value | Meaning
Illegal | The service object has set the CoverOpen property to true while the CapCoverSensor property is false.

Otherwise, PosPrinterProperties queues a StatusUpdateEvent event using the StatusCoverOpen constant, notifying the application of the change.

If the service object sets CoverOpen to false, or if the JrnCoverOpen, RecCoverOpen, and SlpCoverOpen properties are all set to false, PosPrinterProperties queues a StatusUpdateEvent event to the application, using the StatusCoverOK constant.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.CoverOpen Property
PosPrinter.StatusCoverOpen Field
PosPrinter.StatusCoverOK Field
StatusUpdateEventArgs Class


PosPrinterBase.DeviceEnabled Property

PosPrinterBase.DeviceEnabled Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether the device has been placed in an operational state.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property DeviceEnabled As Boolean
public override bool DeviceEnabled { get; set; }
public:
virtual property bool DeviceEnabled {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_DeviceEnabled ()

/** @property */
public void set_DeviceEnabled (boolean value)

public override function get DeviceEnabled () : boolean

public override function set DeviceEnabled (value : boolean)

Remarks

When true, the device has been put in an operational state. If changed to true, then the device is brought to an operational state. The appropriate device statistics and device information will be loaded, if it is necessary. Exclusive-use devices must be opened and claimed before this property can be accessed. Shared devices must be opened before this property can be accessed.

When false, the device has been disabled. If changed to false, then the device is physically disabled when it is possible. Any later input is discarded, and output operations are disallowed.

Changing DeviceEnabled usually does not physically affect output devices. However, for consistency, the application must set DeviceEnabled to true before it uses output devices.

DeviceEnabled is initialized to false. State verification occurs in the basic and base classes for each device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.ErrorLevel Property

PosPrinterBase.ErrorLevel Property |
 | See Also

1/18/2008

Holds the severity of the most recent error condition.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property ErrorLevel As PrinterErrorLevel
public override PrinterErrorLevel ErrorLevel { get; }
public:
virtual property PrinterErrorLevel ErrorLevel {
    PrinterErrorLevel get () override;
}
/** @property */
public PrinterErrorLevel get_ErrorLevel ()

public override function get ErrorLevel () : PrinterErrorLevel

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.ErrorLevel.

ErrorLevel is initialized to PrinterErrorLevel.None by the PosPrinterProperties class. If the service object sets ErrorLevel to an invalid PrinterErrorLevel value, the PosPrinterProperties class may throw PosControlException exceptions with the following values:

Value | Meaning
Illegal | The service object has set the ErrorLevel property to an invalid PrinterErrorLevel value.

If an error occurs, PosPrinterBase class sets ErrorLevel to the value returned in the PrintResults class. Normally, service objects should not need to set ErrorLevel.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.ErrorLevel Property


PosPrinterBase.ErrorStation Property

PosPrinterBase.ErrorStation Property |
 | See Also

1/18/2008

Holds the station or stations that were printing when an error was detected.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property ErrorStation As PrinterStation
public override PrinterStation ErrorStation { get; }
public:
virtual property PrinterStation ErrorStation {
    PrinterStation get () override;
}
/** @property */
public PrinterStation get_ErrorStation ()

public override function get ErrorStation () : PrinterStation

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.ErrorStation. If the application retrieves ErrorStation when the device isn’t in an error condition, PosPrinterProperties returns a value of PrinterStation.None.

ErrorStation is initialized to PrinterStation.None by the PosPrinterProperties class. PosPrinterProperties may throw PosControlException exceptions with the following values:

Value | Meaning
Illegal | The service object has set the ErrorStation property to an invalid PrinterStation value.

If an error occurs, PosPrinterBase class sets ErrorStation to the value returned in the PrintResults class. Normally, service objects should not need to set ErrorStation.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.ErrorStation Property
PrinterStation Enumeration


PosPrinterBase.ErrorString Property

PosPrinterBase.ErrorString Property |
 | See Also

1/18/2008

Holds a vendor-supplied description of the current error.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property ErrorString As String
public override string ErrorString { get; }
public:
virtual property String^ ErrorString {
    String^ get () override;
}
/** @property */
public String get_ErrorString ()

public override function get ErrorString () : String

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.ErrorString. If the application retrieves ErrorString when the device isn’t in an error condition, PosPrinterProperties returns an empty string.

ErrorString is initialized to an empty string by the PosPrinterProperties class. If an error occurs, PosPrinterBase class sets ErrorString to the value returned in the PrintResults class. Normally, service objects should not need to set ErrorString.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.ErrorString Property


PosPrinterBase.FlagWhenIdle Property

PosPrinterBase.FlagWhenIdle Property |
 | See Also

1/18/2008

If set to true by the application, the service object will queue a StatusUpdateEvent event using the StatusIdle constant when the device is in an idle state, and reset FlagWhenIdle to false.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property FlagWhenIdle As Boolean
public override bool FlagWhenIdle { get; set; }
public:
virtual property bool FlagWhenIdle {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_FlagWhenIdle ()

/** @property */
public void set_FlagWhenIdle (boolean value)

public override function get FlagWhenIdle () : boolean

public override function set FlagWhenIdle (value : boolean)

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves or sets the value of PosPrinterProperties.FlagWhenIdle.

FlagWhenIdle is initialized to false by the PosPrinterProperties class. If FlagWhenIdle is set to true by the application, PosPrinterBase class will queue a StatusUpdateEvent event when the value of the State property changes to ControlState.Idle. If FlagWhenIdle is set to true while the device is in Idle state, PosPrinterBase queues a StatusUpdateEvent event immediately. FlagWhenIdle is set to false when the StatusUpdateEvent event is queued.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.FlagWhenIdle Property


PosPrinterBase.FontTypefaceList Property

PosPrinterBase.FontTypefaceList Property |
 | See Also

1/18/2008

Holds a string array that specifies the fonts and/or typefaces supported by the printer.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property FontTypefaceList As String()
public override string[] FontTypefaceList { get; }
public:
virtual property array<String^>^ FontTypefaceList {
    array<String^>^ get () override;
}
/** @property */
public String[] get_FontTypefaceList ()

public override function get FontTypefaceList () : String[]

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.FontTypefaceList.

FontTypefaceList is initialized to an empty string array by the PosPrinterProperties class. The service object should update FontTypefaceList to an appropriate list of values in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.FontTypefaceList Property


PosPrinterBase.JrnCartridgeState Property

PosPrinterBase.JrnCartridgeState Property |
 | See Also

1/18/2008

Holds the status of the selected journal cartridge (ink, ribbon, or toner).

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property JrnCartridgeState As PrinterCartridgeStates
public override PrinterCartridgeStates JrnCartridgeState { get; }
public:
virtual property PrinterCartridgeStates JrnCartridgeState {
    PrinterCartridgeStates get () override;
}
/** @property */
public PrinterCartridgeStates get_JrnCartridgeState ()

public override function get JrnCartridgeState () : PrinterCartridgeStates

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves the value of PosPrinterProperties.JrnCartridgeState. If CapJrnCartridgeSensor is set to PrinterCartridgeSensors.None, or if CartridgeNotify is set to PrinterCartridgeNotify.Disabled, a value for JrnCartridgeState of PrinterCartridgeStates.Unknown is returned.

JrnCartridgeState is initialized to PrinterCartridgeStates.OK by the PosPrinterProperties class and should be kept current by the service object while the printer device is enabled. If the service object sets JrnCartridgeState to an invalid PrinterCartridgeStates value, POS for .NET may throw PosControlException exceptions with the following values:

Value | Meaning
Illegal | The service object has set the ErrorStation property to an invalid PrinterStation value.

If the CartridgeNotify property is set to PrinterCartridgeNotify.Enabled and the value of JrnCartridgeState changes, the PosPrinterProperties class queues the appropriate StatusUpdateEvent event, notifying the application of the change.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.JrnCartridgeState Property


PosPrinterBase.JrnCurrentCartridge Property

PosPrinterBase.JrnCurrentCartridge Property |
 | See Also

1/18/2008

Holds the currently selected journal cartridge.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property JrnCurrentCartridge As PrinterColors
public override PrinterColors JrnCurrentCartridge { get; set; }
public:
virtual property PrinterColors JrnCurrentCartridge {
    PrinterColors get () override;
    void set (PrinterColors value) override;
}
/** @property */
public PrinterColors get_JrnCurrentCartridge ()

/** @property */
public void set_JrnCurrentCartridge (PrinterColors value)

public override function get JrnCurrentCartridge () : PrinterColors

public override function set JrnCurrentCartridge (value : PrinterColors)

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves or sets the value of PosPrinterProperties.JrnCurrentCartridge.

JrnCurrentCartridge is initialized to PrinterColors.None by the PosPrinterProperties class.

Setting JrnCurrentCartridge can cause a PosControlException exception to be thrown with the following ErrorCode:

Value

Meaning

Illegal

  • The CapJrnPresent property is set to false, indicating that there is no receipt station on this printer. In this case, JrnCurrentCartridge should be set to PrinterColors.None;

  • JrnCurrentCartridge was set to PrinterColors.None, but the CapJrnPresent property is set to true, indicating that a receipt station is present;

  • JrnCurrentCartridge was either set to a value not found in the PrinterColors enumeration or set to PrinterColors.Full, both of which are invalid;

  • JrnCurrentCartridge was set to a value not listed for the CapJrnColor property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.JrnCurrentCartridge Property


PosPrinterBase.JrnEmpty Property

PosPrinterBase.JrnEmpty Property |
 | See Also

1/18/2008

If set to true, the journal is out of paper.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property JrnEmpty As Boolean
public override bool JrnEmpty { get; }
public:
virtual property bool JrnEmpty {
    bool get () override;
}
/** @property */
public boolean get_JrnEmpty ()

public override function get JrnEmpty () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves the value of PosPrinterProperties.JrnEmpty. If the CapJrnEmptySensor property is set to false, JrnEmpty returns false.

JrnEmpty is initialized to false by the PosPrinterProperties class and should be kept current by the service object while the printer device is enabled. The PosPrinterProperties class may throw PosControlException exceptions under the following conditions, with the specified ErrorCodes:

Value | Meaning
Illegal | The service object has set the JrnEmpty property to true and the CapJrnEmptySensor property to false.

If the value of JrnEmpty changes, PosPrinterProperties class queues the appropriate StatusUpdateEvent event.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.JrnEmpty Property


PosPrinterBase.JrnLetterQuality Property

PosPrinterBase.JrnLetterQuality Property |
 | See Also

1/18/2008

If true, prints in high-quality mode. If false, prints in high-speed mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property JrnLetterQuality As Boolean
public override bool JrnLetterQuality { get; set; }
public:
virtual property bool JrnLetterQuality {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_JrnLetterQuality ()

/** @property */
public void set_JrnLetterQuality (boolean value)

public override function get JrnLetterQuality () : boolean

public override function set JrnLetterQuality (value : boolean)

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves or sets the value of PosPrinterProperties.JrnLetterQuality.

JrnLetterQuality is initialized to false by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.JrnLetterQuality Property


PosPrinterBase.JrnLineChars Property

PosPrinterBase.JrnLineChars Property |
 | See Also

1/18/2008

Holds the number of characters that the application wants to print on a journal line.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property JrnLineChars As Integer
public override int JrnLineChars { get; set; }
public:
virtual property int JrnLineChars {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_JrnLineChars ()

/** @property */
public void set_JrnLineChars (int value)

public override function get JrnLineChars () : int

public override function set JrnLineChars (value : int)

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves or sets the value of PosPrinterProperties.JrnLineChars.

The PosPrinterBase class may throw PosControlException exceptions under the following conditions, with the specified ErrorCodes:

Value | Meaning
Illegal | The value of this property is greater than the maximum value specified in the JrnLineCharsList property, or the value of this property is less than 1.

JrnLineChars is initialized to 0 (zero) by the PosPrinterProperties class. The service object should update JrnLineChars in its Open method to the printer’s default line character width.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.JrnLineChars Property


PosPrinterBase.JrnLineCharsList Property

PosPrinterBase.JrnLineCharsList Property |
 | See Also

1/18/2008

Holds a collection of the line widths (characters per line) supported by the journal station.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property JrnLineCharsList As Integer()
public override int[] JrnLineCharsList { get; }
public:
virtual property array<int>^ JrnLineCharsList {
    array<int>^ get () override;
}
/** @property */
public int[] get_JrnLineCharsList ()

public override function get JrnLineCharsList () : int[]

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.JrnLineCharsList.

JrnLineCharsList is initialized to an empty integer array by the PosPrinterProperties class. The service object should update JrnLineCharsList to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.JrnLineCharsList Property


PosPrinterBase.JrnLineHeight Property

PosPrinterBase.JrnLineHeight Property |
 | See Also

1/18/2008

Holds the journal print line height the application wants to use, expressed in the unit of measure indicated by the MapMode property setting.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property JrnLineHeight As Integer
public override int JrnLineHeight { get; set; }
public:
virtual property int JrnLineHeight {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_JrnLineHeight ()

/** @property */
public void set_JrnLineHeight (int value)

public override function get JrnLineHeight () : int

public override function set JrnLineHeight (value : int)

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves or sets the value of PosPrinterProperties.JrnLineHeight. The PosPrinterBase class may throw PosControlException exceptions under the following conditions, with the specified ErrorCodes:

Value | Meaning
Illegal | This property has been set to a value less than 0 (zero).

JrnLineHeight is initialized to 0 (zero) by the PosPrinterProperties class. The service object should update JrnLineHeight in its Open method to the printer’s default line height.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.JrnLineHeight Property


PosPrinterBase.JrnLineSpacing Property

PosPrinterBase.JrnLineSpacing Property |
 | See Also

1/18/2008

Holds the spacing of each single-high print line, including both the printed line height and the white space between each pair of lines that the application wants to use.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property JrnLineSpacing As Integer
public override int JrnLineSpacing { get; set; }
public:
virtual property int JrnLineSpacing {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_JrnLineSpacing ()

/** @property */
public void set_JrnLineSpacing (int value)

public override function get JrnLineSpacing () : int

public override function set JrnLineSpacing (value : int)

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves or sets the value of PosPrinterProperties.JrnLineSpacing. The PosPrinterBase class may throw PosControlException exceptions under the following conditions, with the specified ErrorCodes:

Value | Meaning
Illegal | The application has set the JrnLineHeight property to a value that is less than 0 (zero).

JrnLineSpacing is initialized to 0 (zero) by the PosPrinterProperties class. The service object should update JrnLineSpacing in its Open method to the printer’s default line spacing.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.JrnLineSpacing Property


PosPrinterBase.JrnLineWidth Property

PosPrinterBase.JrnLineWidth Property |
 | See Also

1/18/2008

Holds the width of a line for the number of characters indicated by the JrnLineChars property, expressed in the unit of measure indicated by the MapMode property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property JrnLineWidth As Integer
public override int JrnLineWidth { get; }
public:
virtual property int JrnLineWidth {
    int get () override;
}
/** @property */
public int get_JrnLineWidth ()

public override function get JrnLineWidth () : int

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves the value of PosPrinterProperties.JrnLineWidth.

JrnLineWidth is initialized to 0 (zero) by the PosPrinterProperties class. The service object should update JrnLineWidth in its Open method to the printer’s default line character width.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.JrnLineWidth Property


PosPrinterBase.JrnNearEnd Property

PosPrinterBase.JrnNearEnd Property |
 | See Also

1/18/2008

If true, the journal paper is low.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property JrnNearEnd As Boolean
public override bool JrnNearEnd { get; }
public:
virtual property bool JrnNearEnd {
    bool get () override;
}
/** @property */
public boolean get_JrnNearEnd ()

public override function get JrnNearEnd () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves the value of PosPrinterProperties.JrnNearEnd.

JrnNearEnd is initialized to false by the PosPrinterProperties class and should be kept current by the service object while the printer device is enabled. If the service object sets JrnNearEnd to true and the CapJrnNearEndSensor property is set to false, the PosPrinterProperties class may throw PosControlException exceptions under the following conditions, with the specified ErrorCodes:

Value | Meaning
Illegal | The service object has set the JrnNearEnd property to true, indicating that the low-paper sensor has detected a growing scarcity of printer paper, and set the CapJrnNearEndSensor property to false, which indicates that there is no low-paper sensor.

Otherwise, if the value of JrnNearEnd changes, the PosPrinterProperties class queues the appropriate StatusUpdateEvent event, notifying the application of the change.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.JrnNearEnd Property


PosPrinterBase.MapCharacterSet Property

PosPrinterBase.MapCharacterSet Property |
 | See Also

1/18/2008

If set to true by the application while outputting data, the service object maps the characters transferred by the application to the character set selected in the CharacterSet property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property MapCharacterSet As Boolean
public override bool MapCharacterSet { get; set; }
public:
virtual property bool MapCharacterSet {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_MapCharacterSet ()

/** @property */
public void set_MapCharacterSet (boolean value)

public override function get MapCharacterSet () : boolean

public override function set MapCharacterSet (value : boolean)

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves or sets the value of PosPrinterProperties.MapCharacterSet.

MapCharacterSet is initialized to false by the PosPrinterProperties class. The service object should set MapCharacterSet to the appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.MapCharacterSet Property


PosPrinterBase.MapMode Property

PosPrinterBase.MapMode Property |
 | See Also

1/18/2008

Holds the mapping mode of the printer the application wants to use.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property MapMode As MapMode
public override MapMode MapMode { get; set; }
public:
virtual property MapMode MapMode {
    MapMode get () override;
    void set (MapMode value) override;
}
/** @property */
public MapMode get_MapMode ()

/** @property */
public void set_MapMode (MapMode value)

public override function get MapMode () : MapMode

public override function set MapMode (value : MapMode)

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves or sets the value of PosPrinterProperties.MapMode. The PosPrinterProperties class may throw PosControlException exceptions under the following conditions, with the specified ErrorCodes:

Value | Meaning
Illegal | The application has set the MapMode property to an invalid MapMode value.

MapMode is initialized to MapMode.Dots by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.MapMode Property
MapMode Enumeration


PosPrinterBase.OutputCount Property

PosPrinterBase.OutputCount Property |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected ReadOnly Property OutputCount As Integer
protected int OutputCount { get; }
protected:
property int OutputCount {
    int get ();
}
/** @property */
protected int get_OutputCount ()

protected function get OutputCount () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.PageModeArea Property

PosPrinterBase.PageModeArea Property |
 | See Also

1/18/2008

Holds the page area for the selected PageModeStation expressed in the unit of measure given by MapMode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property PageModeArea As Point
public override Point PageModeArea { get; }
public:
virtual property Point PageModeArea {
    Point get () override;
}
/** @property */
public Point get_PageModeArea ()

public override function get PageModeArea () : Point

Property Value

A point representing the total page area for the selected PageModeStation.

Remarks

This property holds the page area for the selected PageModeStation expressed in the unit of measure given by MapMode. This page area can be different than the print area and is determined by the hardware capability of the printer.

The PageModeStation property must be set to a valid station before accessing this property, otherwise an empty string is returned.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.PageModeDescriptor Property

PosPrinterBase.PageModeDescriptor Property |
 | See Also

1/18/2008

Holds a value that indicates the level of basic Page Mode functionality for the printer.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property PageModeDescriptor As PageModeDescriptors
public override PageModeDescriptors PageModeDescriptor { get; }
public:
virtual property PageModeDescriptors PageModeDescriptor {
    PageModeDescriptors get () override;
}
/** @property */
public PageModeDescriptors get_PageModeDescriptor ()

public override function get PageModeDescriptor () : PageModeDescriptors

Property Value

A PageModeDescriptors value indicating the level of basic Page Mode functionality.

Remarks

This is a bitmask indicating the basic Page Mode functionality of the printer for the selected PageModeStation.

Value | Meaning
Bitmap | Printing of bitmaps on the PageModeStation is Supported.
Barcode | Printing of barcodes on the PageModeStation is supported
BitmapRotate | Rotation of bitmaps on the PageModeStation is supported
BarcodeRotate | Rotation of barcodes on the PageModeStation is supported
Opaque | Text, graphics, and background are opaque, meaning items already placed on the page area in the specified print area will not be visible after being printed over.

The PageModeStation property must be set to a valid station before accessing this property, otherwise the value zero (0) is returned.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.PageModeHorizontalPosition Property

PosPrinterBase.PageModeHorizontalPosition Property |
 | See Also

1/18/2008

Holds the horizontal start position offset within the print area for the selected PageModeStation, expressed in the unit of measure given by MapMode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property PageModeHorizontalPosition As Integer
public override int PageModeHorizontalPosition { get; set; }
public:
virtual property int PageModeHorizontalPosition {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_PageModeHorizontalPosition ()

/** @property */
public void set_PageModeHorizontalPosition (int value)

public override function get PageModeHorizontalPosition () : int

public override function set PageModeHorizontalPosition (value : int)

Property Value

In integer that holds the horizontal start position offset within the print area for the selected PageModeStation.

Remarks

Holds the horizontal start position offset within the print area for the selected PageModeStation, expressed in the unit of measure given by MapMode. The horizontal direction is the same as the actual PageModePrintDirection property. If the exact position cannot be supported then the position is set to the closest supported value.

A read/get on this property will return the horizontal position offset set by the last write/set and not the current position.

The PageModeStation property must be set to a valid station before accessing this property, otherwise the value zero (0) is returned.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.PageModePrintArea Property

PosPrinterBase.PageModePrintArea Property |
 | See Also

1/18/2008

Holds the print area for the selected PageModeStation expressed in the unit of measure given by MapMode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property PageModePrintArea As Rectangle
public override Rectangle PageModePrintArea { get; set; }
public:
virtual property Rectangle PageModePrintArea {
    Rectangle get () override;
    void set (Rectangle value) override;
}
/** @property */
public Rectangle get_PageModePrintArea ()

/** @property */
public void set_PageModePrintArea (Rectangle value)

public override function get PageModePrintArea () : Rectangle

public override function set PageModePrintArea (value : Rectangle)

Property Value

A Rectangle indicating the print area.

Remarks

Holds the print area for the selected PageModeStation expressed in the unit of measure given by MapMode. The maximum print area is the page area.

Text written to the right edge of the print area will wrap to the next line. Any text or image written beyond the bottom of the print area will be truncated.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.PageModePrintDirection Property

PosPrinterBase.PageModePrintDirection Property |
 | See Also

1/18/2008

Holds the print direction.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property PageModePrintDirection As PageModePrintDirection
public override PageModePrintDirection PageModePrintDirection { get; set; }
public:
virtual property PageModePrintDirection PageModePrintDirection {
    PageModePrintDirection get () override;
    void set (PageModePrintDirection value) override;
}
/** @property */
public PageModePrintDirection get_PageModePrintDirection ()

/** @property */
public void set_PageModePrintDirection (PageModePrintDirection value)

public override function get PageModePrintDirection () : PageModePrintDirection

public override function set PageModePrintDirection (value : PageModePrintDirection)

Property Value

A PageModePrintDirection value that indicates the print direction.

Remarks

This property holds the print direction. Valid values, as defined in the PageModePrintDirection enumeration, are listed below:

Value | Meaning
BottomToTop | Print bottom to top, starting at the bottom left position of the print area (that is, rotated left 90° printing).
LeftToRight | Print left to right, starting at top left position of the print area (that is, normal printing).
None | No valid station is selected.
RightToLeft | Print right to left, starting at the bottom right position of the print area (that is, upside down printing).
TopToBottom | Print top to bottom, starting at the top right position of the print area (that is, rotated right 90° printing.)

This property is initialized to LeftToRight when the device is first enabled following the open method.

Setting this property may also change PageModeHorizontalPosition and

PageModeVerticalPosition. Setting this property will have an effect on the current print area. By changing the print area, it is possible to generate a receipt or slip with text printed in multiple rotations.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.PageModeStation Property

PosPrinterBase.PageModeStation Property |
 | See Also

1/18/2008

Gets and sets the print station for use by other Page Mode properties

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property PageModeStation As PrinterStation
public override PrinterStation PageModeStation { get; set; }
public:
virtual property PrinterStation PageModeStation {
    PrinterStation get () override;
    void set (PrinterStation value) override;
}
/** @property */
public PrinterStation get_PageModeStation ()

/** @property */
public void set_PageModeStation (PrinterStation value)

public override function get PageModeStation () : PrinterStation

public override function set PageModeStation (value : PrinterStation)

Property Value

A PrinterStation value that indicates the current printer mode.

Remarks

This property gets and sets the print station for subsequent Page Mode properties. Note that PageModePrint will allow for the selection of the print station that the output will be generated on. This value will only contain one Page Mode station at a time, receipt or slip.

If Page Mode is not supported on any station, the value should be zero. To control Page Mode for more than one station, this value will need to be changed between the stations.

This property is initialized to 0 by the Open method, and must be set to a valid value before Page Mode properties or methods are used.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.PageModeVerticalPosition Property

PosPrinterBase.PageModeVerticalPosition Property |
 | See Also

1/18/2008

Holds the vertical start position offset within the print area for the selected PageModeStation.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property PageModeVerticalPosition As Integer
public override int PageModeVerticalPosition { get; set; }
public:
virtual property int PageModeVerticalPosition {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_PageModeVerticalPosition ()

/** @property */
public void set_PageModeVerticalPosition (int value)

public override function get PageModeVerticalPosition () : int

public override function set PageModeVerticalPosition (value : int)

Property Value

An integer representing the vertical start position offset within the print area.

Remarks

Holds the vertical start position offset within the print area for the selected PageModeStation, expressed in the unit of measure given by MapMode. The vertical direction is perpendicular to the direction specified in the actual PageModePrintDirection property. If the exact position cannot be supported then the position is set to the closest supported value. A read/get on this property will return the vertical position offset set by the last write/set and not the current position.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.Properties Property

PosPrinterBase.Properties Property |
 | See Also

1/18/2008

Returns a class of writable properties that can be used to modify the read-only properties used by applications.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Friend ReadOnly Property Properties As PrinterProperties
protected internal PrinterProperties Properties { get; }
protected public:
property PrinterProperties^ Properties {
    PrinterProperties^ get ();
}
/** @property */
protected PrinterProperties get_Properties ()

protected internal function get Properties () : PrinterProperties

Remarks

Returns an instance of the PosPrinterProperties helper class, containing getters and setters for PosPrinter properties. Service objects should use PosPrinterProperties class to set properties that are typically designated read-only for applications. The device doesn't have to be opened, claimed, or enabled to set PosPrinterProperties class properties.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.RecBarCodeRotationList Property

PosPrinterBase.RecBarCodeRotationList Property |
 | See Also

1/18/2008

Holds a list of the directions in which a receipt bar code can be rotated.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property RecBarCodeRotationList As Rotation()
public override Rotation[] RecBarCodeRotationList { get; }
public:
virtual property array<Rotation>^ RecBarCodeRotationList {
    array<Rotation>^ get () override;
}
/** @property */
public Rotation[] get_RecBarCodeRotationList ()

public override function get RecBarCodeRotationList () : Rotation[]

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.RecBarCodeRotationList. If the CapRecBarCode property is set to false, RecBarCodeRotationList returns an empty list.

RecBarCodeRotationList is initialized to an empty Rotation array by the PosPrinterProperties class. The service object should set RecBarCodeRotationList to the appropriate value in its Open method. The PosPrinterProperties class may throw a PosControlException exception the following Errorcode:

Value | Meaning
Illegal | The service object has set RecBarCodeRotationList to an invalid Rotation value.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.RecBarCodeRotationList Property


PosPrinterBase.RecBitmapRotationList Property

PosPrinterBase.RecBitmapRotationList Property |
 | See Also

1/18/2008

Holds a list of the directions in which a receipt bitmap can be rotated.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property RecBitmapRotationList As Rotation()
public override Rotation[] RecBitmapRotationList { get; }
public:
virtual property array<Rotation>^ RecBitmapRotationList {
    array<Rotation>^ get () override;
}
/** @property */
public Rotation[] get_RecBitmapRotationList ()

public override function get RecBitmapRotationList () : Rotation[]

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.RecBitmapRotationList. If the CapRecBitmap property is set to false, RecBitmapRotationList returns an empty list.

RecBitmapRotationList is initialized to an empty Rotation array by the PosPrinterProperties class. The service object should set RecBitmapRotationList to the appropriate value in its Open method. The PosPrinterProperties class may throw PosControlException exceptions under the following conditions, with the specified ErrorCodes:

Value | Meaning
Illegal | The service object has set the RecBitmapRotationList property to an invalid Rotation value.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.RecBitmapRotationList Property


PosPrinterBase.RecCartridgeState Property

PosPrinterBase.RecCartridgeState Property |
 | See Also

1/18/2008

Holds the status of the selected receipt cartridge (ink, ribbon or toner).

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property RecCartridgeState As PrinterCartridgeStates
public override PrinterCartridgeStates RecCartridgeState { get; }
public:
virtual property PrinterCartridgeStates RecCartridgeState {
    PrinterCartridgeStates get () override;
}
/** @property */
public PrinterCartridgeStates get_RecCartridgeState ()

public override function get RecCartridgeState () : PrinterCartridgeStates

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves the value of PosPrinterProperties.RecCartridgeState. If CapRecCartridgeSensor is set to PrinterCartridgeSensors.None, or if CartridgeNotify is set to PrinterCartridgeNotify.Disabled, RecCartridgeState returns a value of PrinterCartridgeStates.Unknown.

RecCartridgeState is initialized to PrinterCartridgeStates.OK by the PosPrinterProperties class and should be kept current by the service object while the printer device is enabled.

POS for .NET may throw PosControlException exceptions under the following conditions, with the specified ErrorCodes:

Value | Meaning
Illegal | The service object has set the RecCartridgeState property to an invalid PrinterCartridgeStates value.

If the CartridgeNotify property is set to PrinterCartridgeNotify.Enabled and the value of RecCartridgeState changes, the PosPrinterProperties class queues the appropriate StatusUpdateEvent event, notifying the application of the change.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.RecCartridgeState Property


PosPrinterBase.RecCurrentCartridge Property

PosPrinterBase.RecCurrentCartridge Property |
 | See Also

1/18/2008

Holds the receipt cartridge currently selected by the application.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property RecCurrentCartridge As PrinterColors
public override PrinterColors RecCurrentCartridge { get; set; }
public:
virtual property PrinterColors RecCurrentCartridge {
    PrinterColors get () override;
    void set (PrinterColors value) override;
}
/** @property */
public PrinterColors get_RecCurrentCartridge ()

/** @property */
public void set_RecCurrentCartridge (PrinterColors value)

public override function get RecCurrentCartridge () : PrinterColors

public override function set RecCurrentCartridge (value : PrinterColors)

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves or sets the value of PosPrinterProperties.RecCurrentCartridge.

RecCurrentCartridge is initialized to PrinterColors.None by the PosPrinterProperties class.

Setting RecCurrentCartridge can cause a PosControlException exception to be thrown with the following ErrorCode:

Value

Meaning

Illegal

  • The CapRecPresent property is set to false, indicating that there is no receipt station on this printer. In this case, RecCurrentCartridge should be set to PrinterColors.None;

  • RecCurrentCartridge was set to PrinterColors.None, but the CapRecPresent property is set to true, indicating that a receipt station is present;

  • RecCurrentCartridge was either set to a value not found in the PrinterColors enumeration or set to PrinterColors.Full, both of which are invalid;

  • RecCurrentCartridge was set to a value not listed for the CapRecColor property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.RecCurrentCartridge Property


PosPrinterBase.RecEmpty Property

PosPrinterBase.RecEmpty Property |
 | See Also

1/18/2008

If true, the receipt is out of paper.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property RecEmpty As Boolean
public override bool RecEmpty { get; }
public:
virtual property bool RecEmpty {
    bool get () override;
}
/** @property */
public boolean get_RecEmpty ()

public override function get RecEmpty () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves the value of PosPrinterProperties.RecEmpty. If CapRecEmptySensor is set to false, RecEmpty returns false.

RecEmpty is initialized to false by the PosPrinterProperties class and should be kept current by the service object while the printer device is enabled. If the service object sets RecEmpty to true, the PosPrinterProperties class sets RecNearEnd to true as well. Changing RecEmpty causes the PosPrinterProperties class to queue the appropriate StatusUpdateEvent event, notifying the application of the change.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.RecEmpty Property


PosPrinterBase.RecLetterQuality Property

PosPrinterBase.RecLetterQuality Property |
 | See Also

1/18/2008

If true, prints in high-quality mode. If false, prints in high-speed mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property RecLetterQuality As Boolean
public override bool RecLetterQuality { get; set; }
public:
virtual property bool RecLetterQuality {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_RecLetterQuality ()

/** @property */
public void set_RecLetterQuality (boolean value)

public override function get RecLetterQuality () : boolean

public override function set RecLetterQuality (value : boolean)

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves or sets the value of PosPrinterProperties.RecLetterQuality.

RecLetterQuality is initialized to false by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.RecLetterQuality Property


PosPrinterBase.RecLineChars Property

PosPrinterBase.RecLineChars Property |
 | See Also

1/18/2008

Holds the number of characters that the application wants to print on a receipt line.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property RecLineChars As Integer
public override int RecLineChars { get; set; }
public:
virtual property int RecLineChars {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_RecLineChars ()

/** @property */
public void set_RecLineChars (int value)

public override function get RecLineChars () : int

public override function set RecLineChars (value : int)

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves or sets the value of PosPrinterProperties.RecLineChars. The PosPrinterBase class may throw PosControlException exceptions under the following conditions, with the specified ErrorCodes:

Value | Meaning
Illegal | The width value specified by this property is greater than the maximum width specified in the RecLineCharsList property, or is than 1.

RecLineChars is initialized to 0 (zero) by the PosPrinterProperties class. The service object should update RecLineChars in its Open method to the printer’s default line character width.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.RecLineChars Property


PosPrinterBase.RecLineCharsList Property

PosPrinterBase.RecLineCharsList Property |
 | See Also

1/18/2008

Holds a collection of the line widths (characters per line) supported by the receipt station.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property RecLineCharsList As Integer()
public override int[] RecLineCharsList { get; }
public:
virtual property array<int>^ RecLineCharsList {
    array<int>^ get () override;
}
/** @property */
public int[] get_RecLineCharsList ()

public override function get RecLineCharsList () : int[]

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.RecLineCharsList.

RecLineCharsList is initialized to an empty integer array by the PosPrinterProperties class. The service object should update RecLineCharsList to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.RecLineCharsList Property


PosPrinterBase.RecLineHeight Property

PosPrinterBase.RecLineHeight Property |
 | See Also

1/18/2008

Holds the receipt print line height, expressed in the unit of measure indicated by the MapMode property setting, that the application wants to use.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property RecLineHeight As Integer
public override int RecLineHeight { get; set; }
public:
virtual property int RecLineHeight {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_RecLineHeight ()

/** @property */
public void set_RecLineHeight (int value)

public override function get RecLineHeight () : int

public override function set RecLineHeight (value : int)

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves or sets the value of PosPrinterProperties.RecLineHeight.

The PosPrinterBase class may throw PosControlException exceptions under the following conditions, with the specified ErrorCodes:

Value | Meaning
Illegal | The RecLineHeight property has been set to a value that is less than 0 (zero).

RecLineHeight is initialized to 0 (zero) by the PosPrinterProperties class. The service object should update RecLineHeight in its Open method to the printer’s default line height.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.RecLineHeight Property


PosPrinterBase.RecLineSpacing Property

PosPrinterBase.RecLineSpacing Property |
 | See Also

1/18/2008

Holds the spacing of each single-high print line, including both the printed line height and the white space between each pair of lines, that the application wants to use.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property RecLineSpacing As Integer
public override int RecLineSpacing { get; set; }
public:
virtual property int RecLineSpacing {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_RecLineSpacing ()

/** @property */
public void set_RecLineSpacing (int value)

public override function get RecLineSpacing () : int

public override function set RecLineSpacing (value : int)

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves or sets the value of PosPrinterProperties.RecLineSpacing.

The PosPrinterBase class to throw a PosControlException exception with may throw PosControlException exceptions under the following conditions, with the specified ErrorCodes:

Value | Meaning
Illegal | The RecLineSpacing property has been set to a value that is less than 0 (zero).

RecLineSpacing is initialized to 0 (zero) by the PosPrinterProperties class. The service object should update RecLineSpacing in its Open method to the printer’s default line spacing.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.RecLineSpacing Property


PosPrinterBase.RecLinesToPaperCut Property

PosPrinterBase.RecLinesToPaperCut Property |
 | See Also

1/18/2008

Holds the number of lines that must be advanced before cutting the receipt paper.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property RecLinesToPaperCut As Integer
public override int RecLinesToPaperCut { get; }
public:
virtual property int RecLinesToPaperCut {
    int get () override;
}
/** @property */
public int get_RecLinesToPaperCut ()

public override function get RecLinesToPaperCut () : int

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves the value of PosPrinterProperties.RecLinesToPaperCut.

RecLinesToPaperCut is initialized to 0 (zero) by the PosPrinterProperties class. The service object should update RecLinesToPapercut to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.RecLinesToPaperCut Property


PosPrinterBase.RecLineWidth Property

PosPrinterBase.RecLineWidth Property |
 | See Also

1/18/2008

Holds the width of a line, based on the number of characters specified in the RecLineChars property, expressed in the unit of measure indicated by the MapMode property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property RecLineWidth As Integer
public override int RecLineWidth { get; }
public:
virtual property int RecLineWidth {
    int get () override;
}
/** @property */
public int get_RecLineWidth ()

public override function get RecLineWidth () : int

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves the value of PosPrinterProperties.RecLineWidth.

RecLineWidth is initialized to 0 (zero) by the PosPrinterProperties class. The service object should update RecLineWidth in its Open method to the printer’s default line character width.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.RecLineWidth Property


PosPrinterBase.RecNearEnd Property

PosPrinterBase.RecNearEnd Property |
 | See Also

1/18/2008

If true, the receipt paper is low.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property RecNearEnd As Boolean
public override bool RecNearEnd { get; }
public:
virtual property bool RecNearEnd {
    bool get () override;
}
/** @property */
public boolean get_RecNearEnd ()

public override function get RecNearEnd () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves the value of PosPrinterProperties.RecNearEnd.

RecNearEnd is initialized to false by the PosPrinterProperties class and should be kept current by the service object while the printer device is enabled. The PosPrinterProperties class may throw PosControlException exceptions under the following conditions, with the specified ErrorCodes:

Value | Meaning
Illegal | The CapRecNearEndSensor property is set to false, and the service object has set RecNearEnd to true.

. Changing the value of RecNearEnd causes the PosPrinterProperties class to queue the appropriate StatusUpdateEvent event, notifying the application of the change.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.RecNearEnd Property


PosPrinterBase.RecSidewaysMaxChars Property

PosPrinterBase.RecSidewaysMaxChars Property |
 | See Also

1/18/2008

Holds the maximum number of characters that can be printed on each line in sideways mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property RecSidewaysMaxChars As Integer
public override int RecSidewaysMaxChars { get; }
public:
virtual property int RecSidewaysMaxChars {
    int get () override;
}
/** @property */
public int get_RecSidewaysMaxChars ()

public override function get RecSidewaysMaxChars () : int

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves the value of PosPrinterProperties.RecSidewaysMaxChars. If the values of CapRecLeft90 and CapRecRight90 are 0 (zero), the RecSidewaysMaxChars property returns 0 (zero).

RecSidewaysMaxChars is initialized to 0 (zero) by the PosPrinterProperties class. The service object should update RecSidewaysMaxChars to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.RecSidewaysMaxChars Property


PosPrinterBase.RecSidewaysMaxLines Property

PosPrinterBase.RecSidewaysMaxLines Property |
 | See Also

1/18/2008

Holds the maximum number of lines that can be printed in sideways mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property RecSidewaysMaxLines As Integer
public override int RecSidewaysMaxLines { get; }
public:
virtual property int RecSidewaysMaxLines {
    int get () override;
}
/** @property */
public int get_RecSidewaysMaxLines ()

public override function get RecSidewaysMaxLines () : int

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves the value of PosPrinterProperties.RecSidewaysMaxLines. If the values of CapRecLeft90 and CapRecRight90 are 0 (zero), the RecSidewaysMaxLines property returns 0 (zero).

RecSidewaysMaxLines is initialized to 0 (zero) by the PosPrinterProperties class. The service object should update RecSidewaysMaxLines to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.RecSidewaysMaxLines Property


PosPrinterBase.RotateSpecial Property

PosPrinterBase.RotateSpecial Property |
 | See Also

1/18/2008

Holds the rotation orientation for bar codes that the application wants to use.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property RotateSpecial As Rotation
public override Rotation RotateSpecial { get; set; }
public:
virtual property Rotation RotateSpecial {
    Rotation get () override;
    void set (Rotation value) override;
}
/** @property */
public Rotation get_RotateSpecial ()

/** @property */
public void set_RotateSpecial (Rotation value)

public override function get RotateSpecial () : Rotation

public override function set RotateSpecial (value : Rotation)

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves or sets the value of PosPrinterProperties.RotateSpecial. The PosPrinterProperties class may throw PosControlException exceptions under the following conditions, with the specified ErrorCodes:

Value | Meaning
Illegal | The RotateSpecial property has been set to an invalid Rotation value.

RotateSpecial is initialized to Rotation.Normal by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.RotateSpecial Property
Rotation Enumeration


PosPrinterBase.SlpBarCodeRotationList Property

PosPrinterBase.SlpBarCodeRotationList Property |
 | See Also

1/18/2008

Holds a collection of the directions in which a slip bar code may be rotated.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property SlpBarCodeRotationList As Rotation()
public override Rotation[] SlpBarCodeRotationList { get; }
public:
virtual property array<Rotation>^ SlpBarCodeRotationList {
    array<Rotation>^ get () override;
}
/** @property */
public Rotation[] get_SlpBarCodeRotationList ()

public override function get SlpBarCodeRotationList () : Rotation[]

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.SlpBarCodeRotationList. If the CapSlpBarCode property is set to false, the SlpBarCodeRotationList returns an empty list.

SlpBarCodeRotationList is initialized to an empty Rotation array by the PosPrinterProperties class. The service object should update SlpBarCodeRotationList to an appropriate value in its Open method. If the service object sets SlpBarCodeRotationList to an invalid Rotation value, the PosPrinterProperties class may throw PosControlException exceptions under the following conditions, with the specified ErrorCodes:

Value | Meaning
Illegal | The SlpBarCodeRotationList property has been set to an invalid Rotation value.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.SlpBarCodeRotationList Property


PosPrinterBase.SlpBitmapRotationList Property

PosPrinterBase.SlpBitmapRotationList Property |
 | See Also

1/18/2008

Holds a collection of the directions in which a slip bitmap can be rotated.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property SlpBitmapRotationList As Rotation()
public override Rotation[] SlpBitmapRotationList { get; }
public:
virtual property array<Rotation>^ SlpBitmapRotationList {
    array<Rotation>^ get () override;
}
/** @property */
public Rotation[] get_SlpBitmapRotationList ()

public override function get SlpBitmapRotationList () : Rotation[]

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.SlpBitmapRotationList. If the CapSlpBitmap property is set to false, the SlpBitmapRotationList returns an empty list.

SlpBitmapRotationList is initialized to an empty Rotation array by the PosPrinterProperties class. The service object should update SlpBitmapRotationList to an appropriate value in its Open method. The PosPrinterProperties class the PosPrinterProperties class may throw PosControlException exceptions under the following conditions, with the specified ErrorCodes:

Value | Meaning
Illegal | The SlpBitmapRotationList property has been set to an invalid Rotation value.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.SlpBitmapRotationList Property


PosPrinterBase.SlpCartridgeState Property

PosPrinterBase.SlpCartridgeState Property |
 | See Also

1/18/2008

Holds the status of the selected slip cartridge (ink, ribbon, or toner).

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property SlpCartridgeState As PrinterCartridgeStates
public override PrinterCartridgeStates SlpCartridgeState { get; }
public:
virtual property PrinterCartridgeStates SlpCartridgeState {
    PrinterCartridgeStates get () override;
}
/** @property */
public PrinterCartridgeStates get_SlpCartridgeState ()

public override function get SlpCartridgeState () : PrinterCartridgeStates

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves the value of PosPrinterProperties.SlpCartridgeState. If CapSlpCartridgeSensor is set to PrinterCartridgeSensors.None, or if CartridgeNotify is set to PrinterCartridgeNotify.Disabled, a value of PrinterCartridgeStates.Unknown is returned.

SlpCartridgeState is initialized to PrinterCartridgeStates.OK by the PosPrinterProperties class and should be kept current by the service object while the printer device is enabled. PosControlException exception may be thrown under the following conditions, with the specified ErrorCodes:

Value | Meaning
Illegal | The SlpCartridgeState property has been set to an invalid PrinterCartridgeStates value.

If the CartridgeNotify property is set to PrinterCartridgeNotify.Enabled and the value of SlpCartridgeState changes, the PosPrinterProperties class queues the appropriate StatusUpdateEvent event, notifying the application of the change.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.SlpCartridgeState Property


PosPrinterBase.SlpCurrentCartridge Property

PosPrinterBase.SlpCurrentCartridge Property |
 | See Also

1/18/2008

Holds the slip cartridge the application wants to use.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property SlpCurrentCartridge As PrinterColors
public override PrinterColors SlpCurrentCartridge { get; set; }
public:
virtual property PrinterColors SlpCurrentCartridge {
    PrinterColors get () override;
    void set (PrinterColors value) override;
}
/** @property */
public PrinterColors get_SlpCurrentCartridge ()

/** @property */
public void set_SlpCurrentCartridge (PrinterColors value)

public override function get SlpCurrentCartridge () : PrinterColors

public override function set SlpCurrentCartridge (value : PrinterColors)

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves or sets the value of PosPrinterProperties.SlpCurrentCartridge.

SlpCurrentCartridge is initialized to PrinterColors.None by the PosPrinterProperties class.

Setting SlpCurrentCartridge can cause a PosControlException exception to be thrown with the following ErrorCode:

Value

Meaning

Illegal

  • The CapSlpPresent property is set to false, indicating that there is no receipt station on this printer. In this case, SlpCurrentCartridge should be set to PrinterColors.None;

  • SlpCurrentCartridge was set to PrinterColors.None, but the CapSlpPresent property is set to true, indicating that a receipt station is present;

  • SlpCurrentCartridge was either set to a value not found in the PrinterColors enumeration or set to PrinterColors.Full, both of which are invalid;

  • SlpCurrentCartridge was set to a value not listed for the CapSlpColor property.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.SlpCurrentCartridge Property


PosPrinterBase.SlpEmpty Property

PosPrinterBase.SlpEmpty Property |
 | See Also

1/18/2008

If true, a slip form is not present.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property SlpEmpty As Boolean
public override bool SlpEmpty { get; }
public:
virtual property bool SlpEmpty {
    bool get () override;
}
/** @property */
public boolean get_SlpEmpty ()

public override function get SlpEmpty () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves the value of PosPrinterProperties.SlpEmpty. If CapSlpEmptySensor is set to false, SlpEmpty returns false.

SlpEmpty is initialized to false by the PosPrinterProperties class and should be kept current by the service object while the printer device is enabled. If the service object sets SlpEmpty to true, the PosPrinterProperties class sets SlpNearEnd to true as well. Changing RecEmpty causes the PosPrinterProperties class to queue the appropriate StatusUpdateEvent event, notifying the application of the change.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.SlpEmpty Property


PosPrinterBase.SlpLetterQuality Property

PosPrinterBase.SlpLetterQuality Property |
 | See Also

1/18/2008

If true, prints in high-quality mode. If false, prints in high-speed mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property SlpLetterQuality As Boolean
public override bool SlpLetterQuality { get; set; }
public:
virtual property bool SlpLetterQuality {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_SlpLetterQuality ()

/** @property */
public void set_SlpLetterQuality (boolean value)

public override function get SlpLetterQuality () : boolean

public override function set SlpLetterQuality (value : boolean)

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves the value of PosPrinterProperties.SlpLetterQuality.

SlpLetterQuality is initialized to false by the Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.SlpLetterQuality Property


PosPrinterBase.SlpLineChars Property

PosPrinterBase.SlpLineChars Property |
 | See Also

1/18/2008

Holds the number of characters that the application wants to print on a slip line.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property SlpLineChars As Integer
public override int SlpLineChars { get; set; }
public:
virtual property int SlpLineChars {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_SlpLineChars ()

/** @property */
public void set_SlpLineChars (int value)

public override function get SlpLineChars () : int

public override function set SlpLineChars (value : int)

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves or sets the value of PosPrinterProperties.SlpLineChars. A PosControlException exception with the following ErrorCode may be thrown when SlpLineChars is called:

Value | Meaning
Illegal | The SlpLineCharsList property is set to a value that is less than 1

SlpLineChars is initialized to 0 (zero) by the PosPrinterProperties class. The service object should update SlpLineChars in its Open method to the printer’s default line character width.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.SlpLineChars Property


PosPrinterBase.SlpLineCharsList Property

PosPrinterBase.SlpLineCharsList Property |
 | See Also

1/18/2008

Holds a collection of the line widths (characters per line) supported by the slip station.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property SlpLineCharsList As Integer()
public override int[] SlpLineCharsList { get; }
public:
virtual property array<int>^ SlpLineCharsList {
    array<int>^ get () override;
}
/** @property */
public int[] get_SlpLineCharsList ()

public override function get SlpLineCharsList () : int[]

Remarks

PosPrinterBase class verifies that the device has been opened, then retrieves the value of PosPrinterProperties.SlpLineCharsList.

SlpLineCharsList is initialized to an empty integer array by the PosPrinterProperties class. The service object should update SlpLineCharsList to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.SlpLineCharsList Property


PosPrinterBase.SlpLineHeight Property

PosPrinterBase.SlpLineHeight Property |
 | See Also

1/18/2008

Holds the slip print-line height, expressed in the unit of measure indicated by the MapMode property setting, that the application wants to use.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property SlpLineHeight As Integer
public override int SlpLineHeight { get; set; }
public:
virtual property int SlpLineHeight {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_SlpLineHeight ()

/** @property */
public void set_SlpLineHeight (int value)

public override function get SlpLineHeight () : int

public override function set SlpLineHeight (value : int)

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves or sets the value of PosPrinterProperties.SlpLineHeight. The SlpLineHeight property may cause an exception to be thrown under the following conditions, with the specified ErrorCodes:

Value | Meaning
Illegal | The SlpLineHeight property is set to a value that is less than 0 (zero.)

SlpLineHeight is initialized to 0 (zero) by the PosPrinterProperties class. The service object should update SlpLineHeight in its Open method to the printer’s default line height.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.SlpLineHeight Property


PosPrinterBase.SlpLinesNearEndToEnd Property

PosPrinterBase.SlpLinesNearEndToEnd Property |
 | See Also

1/18/2008

Holds the number of lines that can be printed after the SlpNearEnd property has been set to true but before the printer reaches the end of the slip.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property SlpLinesNearEndToEnd As Integer
public override int SlpLinesNearEndToEnd { get; }
public:
virtual property int SlpLinesNearEndToEnd {
    int get () override;
}
/** @property */
public int get_SlpLinesNearEndToEnd ()

public override function get SlpLinesNearEndToEnd () : int

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves the value of PosPrinterProperties.SlpLinesNearEndToEnd.

SlpLinesNearEndToEnd is initialized to 0 (zero) by the PosPrinterProperties class. The service object should update SlpLinesNearEndToEnd to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.SlpLinesNearEndToEnd Property


PosPrinterBase.SlpLineSpacing Property

PosPrinterBase.SlpLineSpacing Property |
 | See Also

1/18/2008

Holds the spacing of each single-high print line, including both the printed line height and the white space between each pair of lines that the application wants to use.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property SlpLineSpacing As Integer
public override int SlpLineSpacing { get; set; }
public:
virtual property int SlpLineSpacing {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_SlpLineSpacing ()

/** @property */
public void set_SlpLineSpacing (int value)

public override function get SlpLineSpacing () : int

public override function set SlpLineSpacing (value : int)

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves or sets the value of PosPrinterProperties.SlpLineSpacing. The SlpLineSpacing property may cause an exception to be thrown under the following conditions, with the specified ErrorCodes:

Value | Meaning
Illegal | The SlpLineSpacing property is set to a value that is less than 0 (zero.)

SlpLineSpacing is initialized to 0 (zero) by the PosPrinterProperties class. The service object should update SlpLineSpacing in its Open method to the printer’s default line spacing.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.SlpLineSpacing Property


PosPrinterBase.SlpLineWidth Property

PosPrinterBase.SlpLineWidth Property |
 | See Also

1/18/2008

Holds the line width, based on the number of characters specified for the SlpLineChars property, expressed in the unit of measure indicated by the MapMode property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property SlpLineWidth As Integer
public override int SlpLineWidth { get; }
public:
virtual property int SlpLineWidth {
    int get () override;
}
/** @property */
public int get_SlpLineWidth ()

public override function get SlpLineWidth () : int

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves the value of PosPrinterProperties.SlpLineWidth.

SlpLineWidth is initialized to 0 (zero) by the PosPrinterProperties class. The service object should update SlpLineWidth in its Open method to the printer’s default line character width.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.SlpLineWidth Property


PosPrinterBase.SlpMaxLines Property

PosPrinterBase.SlpMaxLines Property |
 | See Also

1/18/2008

Holds the maximum number of lines that can be printed on a form.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property SlpMaxLines As Integer
public override int SlpMaxLines { get; }
public:
virtual property int SlpMaxLines {
    int get () override;
}
/** @property */
public int get_SlpMaxLines ()

public override function get SlpMaxLines () : int

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves the value of PosPrinterProperties.SlpMaxLines. If the CapSlpFullSlip property is set to true, SlpMaxLines returns 0 (zero).

SlpMaxLines is initialized to 0 (zero) by the PosPrinterProperties class. The service object should update SlpMaxLines to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.SlpMaxLines Property


PosPrinterBase.SlpNearEnd Property

PosPrinterBase.SlpNearEnd Property |
 | See Also

1/18/2008

If true, the slip form is near its end.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property SlpNearEnd As Boolean
public override bool SlpNearEnd { get; }
public:
virtual property bool SlpNearEnd {
    bool get () override;
}
/** @property */
public boolean get_SlpNearEnd ()

public override function get SlpNearEnd () : boolean

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves the value of PosPrinterProperties.SlpNearEnd.

SlpNearEnd is initialized to false by the PosPrinterProperties class and should be kept current by the service object while the printer device is enabled. The PosPrinterProperties may throw a PosControlException under the following conditions, with the specified ErrorCode:

Value | Meaning
Illegal | The CapSlpNearEndSensor property has been set to false, and the service object sets SlpNearEnd to true.

Changing the value of SlpNearEnd causes the PosPrinterProperties class to queue the appropriate StatusUpdateEvent event, notifying the application of the change.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.SlpNearEnd Property


PosPrinterBase.SlpPrintSide Property

PosPrinterBase.SlpPrintSide Property |
 | See Also

1/18/2008

Holds the side of the slip print station document on which printing will occur.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property SlpPrintSide As PrinterSide
public override PrinterSide SlpPrintSide { get; }
public:
virtual property PrinterSide SlpPrintSide {
    PrinterSide get () override;
}
/** @property */
public PrinterSide get_SlpPrintSide ()

public override function get SlpPrintSide () : PrinterSide

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves the value of PosPrinterProperties.SlpPrintSide.

SlpPrintSide is initialized to PrinterSide.Unknown by the PosPrinterProperties class. PosPrinterBase class update SlpPrintSide in its ChangePrintSide method. Normally, the service object should not have to update SlpPrintSide.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.SlpPrintSide Property


PosPrinterBase.SlpSidewaysMaxChars Property

PosPrinterBase.SlpSidewaysMaxChars Property |
 | See Also

1/18/2008

Holds the maximum number of characters that can be printed on each line in sideways mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property SlpSidewaysMaxChars As Integer
public override int SlpSidewaysMaxChars { get; }
public:
virtual property int SlpSidewaysMaxChars {
    int get () override;
}
/** @property */
public int get_SlpSidewaysMaxChars ()

public override function get SlpSidewaysMaxChars () : int

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves the value of PosPrinterProperties.SlpSidewaysMaxChars. If the values of CapRecLeft90 and CapRecRight90 are 0 (zero), SlpSidewaysMaxChars returns 0 (zero).

SlpSidewaysMaxChars is initialized to 0 (zero) by the PosPrinterProperties class. The service object should update SlpSidewaysMaxChars to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.SlpSidewaysMaxChars Property


PosPrinterBase.SlpSidewaysMaxLines Property

PosPrinterBase.SlpSidewaysMaxLines Property |
 | See Also

1/18/2008

Holds the maximum number of lines that can be printed in sideways mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property SlpSidewaysMaxLines As Integer
public override int SlpSidewaysMaxLines { get; }
public:
virtual property int SlpSidewaysMaxLines {
    int get () override;
}
/** @property */
public int get_SlpSidewaysMaxLines ()

public override function get SlpSidewaysMaxLines () : int

Remarks

PosPrinterBase class verifies that the device has been opened, claimed, and enabled, then retrieves the value of PosPrinterProperties.SlpSidewaysMaxLines. If the values of CapRecLeft90 and CapRecRight90 are 0 (zero), SlpSidewaysMaxLines returns 0 (zero).

SlpSidewaysMaxLines is initialized to 0 (zero) by the PosPrinterProperties class. The service object should update SlpSidewaysMaxLines to an appropriate value in its Open method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.SlpSidewaysMaxLines Property


PosPrinterBase.StopCurrentOutput Property

PosPrinterBase.StopCurrentOutput Property |
 | See Also

1/18/2008

Indicates whether output is stopped.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected ReadOnly Property StopCurrentOutput As Boolean
protected bool StopCurrentOutput { get; }
protected:
property bool StopCurrentOutput {
    bool get ();
}
/** @property */
protected boolean get_StopCurrentOutput ()

protected function get StopCurrentOutput () : boolean

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase.UseExternalPrintQueue Property

PosPrinterBase.UseExternalPrintQueue Property |
 | See Also

1/18/2008

Indicates whether an external print queue is used.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Property UseExternalPrintQueue As Boolean
protected bool UseExternalPrintQueue { get; set; }
protected:
property bool UseExternalPrintQueue {
    bool get ();
    void set (bool value);
}
/** @property */
protected boolean get_UseExternalPrintQueue ()

/** @property */
protected void set_UseExternalPrintQueue (boolean value)

protected function get UseExternalPrintQueue () : boolean

protected function set UseExternalPrintQueue (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PosPrinterBase Events

PosPrinterBase Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from PosPrinterBasic )
ErrorEvent | Queued by the service object when an error is detected and the device’s State transitions into the error state. (inherited from PosPrinterBasic )
OutputCompleteEvent | Queued by the service object to notify the application when asynchronous processing that corresponds to an OutputID has successfully completed. (inherited from PosPrinterBasic )
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from PosPrinterBasic )

Protected Events

Name | Description
CancelPrintEvent | Raised when the current print operation should be cancelled.
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
StateChangedEvent | (inherited from PosPrinterBasic )

See Also

Reference

PosPrinterBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace

Other Resources

Using Impl Methods for Synchronous or Asynchronous Output


PosPrinterBase.CancelPrintEvent Event

PosPrinterBase.CancelPrintEvent Event |
 | See Also

1/18/2008

Raised when the current print operation should be cancelled.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Event CancelPrintEvent As CancelPrintEventHandler
protected event CancelPrintEventHandler CancelPrintEvent
protected:
event CancelPrintEventHandler^ CancelPrintEvent {
    void add (CancelPrintEventHandler^ value);
    void remove (CancelPrintEventHandler^ value);
}
/** @event */
protected void add_CancelPrintEvent (CancelPrintEventHandler value)

/** @event */
protected void remove_CancelPrintEvent (CancelPrintEventHandler value)

Remarks

Raised by PosPrinterBase class when the current print operation should be canceled. The service object can subscribe to and use CancelPrintEvent to determine when to cancel current print jobs.

See Also

Reference

PosPrinterBase Class
PosPrinterBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CancelPrintEventHandler


PosPrinterBase.CancelPrintEventHandler Delegate

PosPrinterBase.CancelPrintEventHandler Delegate |
 | See Also

1/18/2008

Delegate for the CancelPrintEvent event.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Delegate Sub CancelPrintEventHandler ( _
    sender As Object, _
    e As EventArgs _
)
protected delegate void CancelPrintEventHandler (
    Object sender,
    EventArgs e
)
private delegate void CancelPrintEventHandler (
    Object^ sender,
    EventArgs^ e
)
/** @delegate */
protected delegate void CancelPrintEventHandler (
    Object sender,
    EventArgs e
)

Parameters

sender

The service object sending the event.

e

The event, which is an instance of the EventArgs class.

Remarks

Delegate for the CancelPrintEvent event.

See Also

Reference

Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CancelPrintEvent Event


PrintBarCodeOperation Class

PrintBarCodeOperation Class |
 | See Also Members

1/18/2008

Captures information about a print operation method call.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class PrintBarCodeOperation
    Inherits PrintOperation
public class PrintBarCodeOperation : PrintOperation
public ref class PrintBarCodeOperation : public PrintOperation
public class PrintBarCodeOperation extends PrintOperation
public class PrintBarCodeOperation extends PrintOperation

Remarks

The PrintBarCodeOperation helper class derives from the PrintOperation helper class. When the application updates printer properties and then calls the PrintBarCode method, the PosPrinterBase class uses an instance of the PrintBarCodeOperation class, cast to the PrintOperation class and stored in the PrintOperationCollection array, to capture information about that method call. The service object then retrieves the operation from the array and uses it to complete the application’s print request.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BaseServiceObjects.PrintOperation
Microsoft.PointOfService.BaseServiceObjects.PrintBarCodeOperation

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintBarCodeOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase Class
PosPrinterBase.PrintBarCode Method
PrintOperation


PrintBarCodeOperation Members

PrintBarCodeOperation Members |
 | See Also Methods Properties

1/18/2008

Captures information about a print operation method call.

The following tables list the members exposed by the PrintBarCodeOperation type.

Public Properties

Name | Description
Alignment | Contains the value of the alignment parameter set when the application called the PrintBarCode method.
AsyncMode | Contains the AsyncMode property setting at the time of the application’s print request. (inherited from PrintOperation)
Data | Contains the value of the data parameter set when the application called the PrintBarCode method.
Height | Contains the value of the height parameter set when the application called the PrintBarCode method.
Rotation | Contains the Rotation setting, as defined by the Rotation enumeration. (inherited from PrintOperation)
State | Contains an instance of the PrinterState class, which captures the current printer property values at the time of the application’s print request. (inherited from PrintOperation)
Station | Contains the printer station setting (for example, PrinterStation.Journal). (inherited from PrintOperation)
Symbology | Contains the value of the symbology parameter set when the application called the PrintBarCode method.
TextPosition | Contains the value of the textPosition parameter set when the application called the PrintBarCode method.
Width | Contains the value of the width parameter set when the application called the PrintBarCode method.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

PrintBarCodeOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase Class
PosPrinterBase.PrintBarCode Method
PrintOperation


PrintBarCodeOperation Methods

PrintBarCodeOperation Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

PrintBarCodeOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase Class
PosPrinterBase.PrintBarCode Method
PrintOperation


PrintBarCodeOperation Properties

PrintBarCodeOperation Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
Alignment | Contains the value of the alignment parameter set when the application called the PrintBarCode method.
AsyncMode | Contains the AsyncMode property setting at the time of the application’s print request. (inherited from PrintOperation )
Data | Contains the value of the data parameter set when the application called the PrintBarCode method.
Height | Contains the value of the height parameter set when the application called the PrintBarCode method.
Rotation | Contains the Rotation setting, as defined by the Rotation enumeration. (inherited from PrintOperation )
State | Contains an instance of the PrinterState class, which captures the current printer property values at the time of the application’s print request. (inherited from PrintOperation )
Station | Contains the printer station setting (for example, PrinterStation.Journal). (inherited from PrintOperation )
Symbology | Contains the value of the symbology parameter set when the application called the PrintBarCode method.
TextPosition | Contains the value of the textPosition parameter set when the application called the PrintBarCode method.
Width | Contains the value of the width parameter set when the application called the PrintBarCode method.

See Also

Reference

PrintBarCodeOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase Class
PosPrinterBase.PrintBarCode Method
PrintOperation


PrintBarCodeOperation.Alignment Property

PrintBarCodeOperation.Alignment Property |
 | See Also

1/18/2008

Contains the value of the alignment parameter set when the application called the PrintBarCode method.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Alignment As Integer
public int Alignment { get; }
public:
property int Alignment {
    int get ();
}
/** @property */
public int get_Alignment ()

public function get Alignment () : int

Remarks

Contains the value of the alignment parameter set when the application called the PrintBarCode method. Valid values are defined by the BarCodeAlignment enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintBarCodeOperation Class
PrintBarCodeOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.PrintBarCode Method


PrintBarCodeOperation.Data Property

PrintBarCodeOperation.Data Property |
 | See Also

1/18/2008

Contains the value of the data parameter set when the application called the PrintBarCode method.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Data As String
public string Data { get; }
public:
property String^ Data {
    String^ get ();
}
/** @property */
public String get_Data ()

public function get Data () : String

Remarks

Contains the value of the data parameter set when the application called the PrintBarCode method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintBarCodeOperation Class
PrintBarCodeOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.PrintBarCode Method


PrintBarCodeOperation.Height Property

PrintBarCodeOperation.Height Property |
 | See Also

1/18/2008

Contains the value of the height parameter set when the application called the PrintBarCode method.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Height As Integer
public int Height { get; }
public:
property int Height {
    int get ();
}
/** @property */
public int get_Height ()

public function get Height () : int

Remarks

Contains the value of the height parameter set when the application called the PrintBarCode method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintBarCodeOperation Class
PrintBarCodeOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.PrintBarCode Method


PrintBarCodeOperation.Symbology Property

PrintBarCodeOperation.Symbology Property |
 | See Also

1/18/2008

Contains the value of the symbology parameter set when the application called the PrintBarCode method.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Symbology As BarCodeSymbology
public BarCodeSymbology Symbology { get; }
public:
property BarCodeSymbology Symbology {
    BarCodeSymbology get ();
}
/** @property */
public BarCodeSymbology get_Symbology ()

public function get Symbology () : BarCodeSymbology

Remarks

Contains the value of the symbology parameter set when the application called the PrintBarCode method. Valid values are defined by the BarCodeSymbology enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintBarCodeOperation Class
PrintBarCodeOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.PrintBarCode Method
BarCodeSymbology Enumeration


PrintBarCodeOperation.TextPosition Property

PrintBarCodeOperation.TextPosition Property |
 | See Also

1/18/2008

Contains the value of the textPosition parameter set when the application called the PrintBarCode method.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property TextPosition As BarCodeTextPosition
public BarCodeTextPosition TextPosition { get; }
public:
property BarCodeTextPosition TextPosition {
    BarCodeTextPosition get ();
}
/** @property */
public BarCodeTextPosition get_TextPosition ()

public function get TextPosition () : BarCodeTextPosition

Remarks

Contains the value of the textPosition parameter set when the application called the PrintBarCode method. Valid values are defined by the BarCodeTextPosition enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintBarCodeOperation Class
PrintBarCodeOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.PrintBarCode Method
BarCodeTextPosition Enumeration


PrintBarCodeOperation.Width Property

PrintBarCodeOperation.Width Property |
 | See Also

1/18/2008

Contains the value of the width parameter set when the application called the PrintBarCode method.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Width As Integer
public int Width { get; }
public:
property int Width {
    int get ();
}
/** @property */
public int get_Width ()

public function get Width () : int

Remarks

Contains the value of the width parameter set when the application called the PrintBarCode method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintBarCodeOperation Class
PrintBarCodeOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.PrintBarCode Method


PrintBitmapOperation Class

PrintBitmapOperation Class |
 | See Also Members

1/18/2008

Captures information about the PrintBitmap method.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class PrintBitmapOperation
    Inherits PrintOperation
public class PrintBitmapOperation : PrintOperation
public ref class PrintBitmapOperation : public PrintOperation
public class PrintBitmapOperation extends PrintOperation
public class PrintBitmapOperation extends PrintOperation

Remarks

The PrintBitmapOperation helper class derives from the PrintOperation helper class. When the application updates printer properties and then calls the PrintBitmap method, the PosPrinterBase class uses an instance of the PrintBitmapOperation class, cast to the PrintOperation class and stored in the PrintOperationCollection array, to capture information about that method call. The service object then retrieves the operation from the array and uses it to complete the application’s print request.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BaseServiceObjects.PrintOperation
Microsoft.PointOfService.BaseServiceObjects.PrintBitmapOperation

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintBitmapOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase Class
PosPrinterBase.PrintBitmap Method
PrintOperation


PrintBitmapOperation Members

PrintBitmapOperation Members |
 | See Also Methods Properties

1/18/2008

Captures information about the PrintBitmap method.

The following tables list the members exposed by the PrintBitmapOperation type.

Public Properties

Name | Description
Alignment | Contains the value of the alignment parameter set when the application called the PrintBitmap method.
AsyncMode | Contains the AsyncMode property setting at the time of the application’s print request. (inherited from PrintOperation)
FileName | Contains the value of the filename parameter set when the application called the PrintBitmap method.
Rotation | Contains the Rotation setting, as defined by the Rotation enumeration. (inherited from PrintOperation)
State | Contains an instance of the PrinterState class, which captures the current printer property values at the time of the application’s print request. (inherited from PrintOperation)
Station | Contains the printer station setting (for example, PrinterStation.Journal). (inherited from PrintOperation)
Width | Contains the values of the width parameter set when the application called the PrintBitmap method.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

PrintBitmapOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase Class
PosPrinterBase.PrintBitmap Method
PrintOperation


PrintBitmapOperation Methods

PrintBitmapOperation Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

PrintBitmapOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase Class
PosPrinterBase.PrintBitmap Method
PrintOperation


PrintBitmapOperation Properties

PrintBitmapOperation Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
Alignment | Contains the value of the alignment parameter set when the application called the PrintBitmap method.
AsyncMode | Contains the AsyncMode property setting at the time of the application’s print request. (inherited from PrintOperation )
FileName | Contains the value of the filename parameter set when the application called the PrintBitmap method.
Rotation | Contains the Rotation setting, as defined by the Rotation enumeration. (inherited from PrintOperation )
State | Contains an instance of the PrinterState class, which captures the current printer property values at the time of the application’s print request. (inherited from PrintOperation )
Station | Contains the printer station setting (for example, PrinterStation.Journal). (inherited from PrintOperation )
Width | Contains the values of the width parameter set when the application called the PrintBitmap method.

See Also

Reference

PrintBitmapOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase Class
PosPrinterBase.PrintBitmap Method
PrintOperation


PrintBitmapOperation.Alignment Property

PrintBitmapOperation.Alignment Property |
 | See Also

1/18/2008

Contains the value of the alignment parameter set when the application called the PrintBitmap method.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Alignment As Integer
public int Alignment { get; }
public:
property int Alignment {
    int get ();
}
/** @property */
public int get_Alignment ()

public function get Alignment () : int

Remarks

Contains the value of the alignment parameter set when the application called the PrintBitmap method. Valid values are defined by the BitmapAlignment enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintBitmapOperation Class
PrintBitmapOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.PrintBitmap Method


PrintBitmapOperation.FileName Property

PrintBitmapOperation.FileName Property |
 | See Also

1/18/2008

Contains the value of the filename parameter set when the application called the PrintBitmap method.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property FileName As String
public string FileName { get; }
public:
property String^ FileName {
    String^ get ();
}
/** @property */
public String get_FileName ()

public function get FileName () : String

Remarks

Contains the value of the filename parameter set when the application called the PrintBitmap method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintBitmapOperation Class
PrintBitmapOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.PrintBitmap Method


PrintBitmapOperation.Width Property

PrintBitmapOperation.Width Property |
 | See Also

1/18/2008

Contains the values of the width parameter set when the application called the PrintBitmap method.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Width As Integer
public int Width { get; }
public:
property int Width {
    int get ();
}
/** @property */
public int get_Width ()

public function get Width () : int

Remarks

Contains the values of the width parameter set when the application called the PrintBitmap method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintBitmapOperation Class
PrintBitmapOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.PrintBitmap Method


PrinterProperties Class

PrinterProperties Class |
 | See Also Members

1/18/2008

A helper class that simplifies the retrieval and setting of property values for printer devices.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class PrinterProperties
    Inherits CommonProperties
public class PrinterProperties : CommonProperties
public ref class PrinterProperties : public CommonProperties
public class PrinterProperties extends CommonProperties
public class PrinterProperties extends CommonProperties

Remarks

PosPrinterProperties is a helper class created by POS for .NET to simplify the retrieval and setting of property values for printer devices. PosPrinterProperties inherits from the PosCommonProperties class. The protected Properties property of PosPrinterBase class returns an instance of PosPrinterProperties. The service object can manage the value of a property using the syntax Properties.<propertyName>. PosPrinterProperties bypasses state validation—in other words, the service object can use PosPrinterProperties to set values for properties even though the application hasn’t opened, claimed, or enabled the printer device.

PosPrinterProperties class also includes the following properties that are beyond the scope of the Unified POS specification: TopLogo, BottomLogo, RecCoverOpen, JrnCoverOpen, and SlpCoverOpen.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BasicServiceObjects.CommonProperties
Microsoft.PointOfService.BaseServiceObjects.PrinterProperties

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrinterProperties Members

PrinterProperties Members |
 | See Also Methods Properties

1/18/2008

A helper class that simplifies the retrieval and setting of property values for printer devices.

The following tables list the members exposed by the PrinterProperties type.

Public Properties

Name | Description
AsyncMode | Indicates whether certain print methods will be performed asynchronously.
BottomLogo | Determines whether to print a logo during print operations.
CapCharacterSet | Holds the default character set capability.
CapCompareFirmwareVersion | (inherited from CommonProperties )
CapConcurrentJrnRec | Indicates whether Journal and receipt stations can print at the same time.
CapConcurrentJrnSlp | Indicates whether journal and slip stations can print at the same time.
CapConcurrentPageMode | Indicates whether the printer is capable of supporting page mode for the receipt and slip stations concurrently.
CapConcurrentRecSlp | Indicates whether receipt and slip stations can print at the same time.
CapCoverSensor | Indicates whether the printer has a “cover open” sensor.
CapJrn2Color | Indicates whether the journal can print dark plus an alternate color.
CapJrnBold | Indicates whether the journal can print bold characters.
CapJrnCartridgeSensor | Indicates the presence of journal cartridge monitoring sensors.
CapJrnColor | Indicates available journal color cartridges.
CapJrnDHigh | Indicates whether the journal can print double-high characters.
CapJrnDWide | Indicates whether the journal can print double-wide characters.
CapJrnDWideDHigh | Indicates whether the journal can print double-wide and double-high characters.
CapJrnEmptySensor | Indicates whether the journal has an out-of-paper sensor.
CapJrnItalic | Indicates whether the journal can print italic characters.
CapJrnNearEndSensor | Indicates whether the journal has a low-paper sensor.
CapJrnPresent | Indicates whether the journal print station is present.
CapJrnUnderline | Indicates whether the journal can underline characters.
CapMapCharacterSet | Indicates that the service object is able to map the characters sent my the application to a character set defined by the CharacterSetList property.
CapPowerReporting | (inherited from CommonProperties )
CapRec2Color | Indicates whether the receipt can print dark plus an alternate color.
CapRecBarCode | Indicates whether the receipt has bar code printing capability.
CapRecBitmap | Indicates whether the receipt can print bitmaps.
CapRecBold | Indicates whether the receipt can print bold text.
CapRecCartridgeSensor | Indicates the presence of receipt cartridge monitoring sensors.
CapRecColor | Indicates the receipt color cartridges.
CapRecDHigh | Indicates whether the receipt can print double-high characters.
CapRecDWide | Indicates whether the receipt can print double-wide characters.
CapRecDWideDHigh | Indicates whether the receipt can print double-wide, double-high characters.
CapRecEmptySensor | Indicates whether the receipt print station has an out-of-paper sensor.
CapRecItalic | Indicates whether the receipt can print italic text.
CapRecLeft90 | Indicates whether the receipt can print in rotated-90-degree-left mode.
CapRecMarkFeed | Holds the type of mark-sensed paper handling available.
CapRecNearEndSensor | Indicates whether the receipt has a low-paper sensor.
CapRecPageMode | If set to true, the printer is capable of supporting Page Mode for the receipt station.
CapRecPaperCut | Indicates whether the receipt can perform paper cuts.
CapRecPresent | Indicates that the receipt print station is present.
CapRecRight90 | Indicates that the receipt can print in a rotated-90-degree-right mode.
CapRecRotate180 | Indicates that the receipt can print in a rotated-180-degree mode.
CapRecStamp | Indicates that the receipt has a stamp capability.
CapRecUnderline | Indicates whether the receipt can underline characters.
CapSlp2Color | Indicates that the slip can print dark plus an alternate color.
CapSlpBarCode | Indicates that the slip has bar code printing capability.
CapSlpBitmap | Indicates that the slip can print bitmaps.
CapSlpBold | Indicates that the slip can print bold text.
CapSlpBothSidesPrint | Indicates that the slip print station supports printing on both sides of the document.
CapSlpCartridgeSensor | Indicates the presence of slip-cartridge monitoring sensors.
CapSlpColor | Indicates which types of color cartridges supported for slip printing.
CapSlpDHigh | Indicates that the slip can print double-high characters.
CapSlpDWide | Indicates that the slip can print double-wide characters.
CapSlpDWideDHigh | Indicates that the slip can print double-wide, double-high characters.
CapSlpEmptySensor | Indicates that the slip has a “slip in” sensor.
CapSlpFullSlip | Indicates whether the printer supports printing full-length forms on the slip station.
CapSlpItalic | Indicates that the slip can print italic characters.
CapSlpLeft90 | Indicates that the slip can print in a rotated 90 degree left mode.
CapSlpNearEndSensor | Indicates whether the slip has a "slip near end" sensor.
CapSlpPageMode | Indicates whether the printer is capable of supporting Page Mode for the slip station.
CapSlpPresent | Indicates that the printer has a slip station.
CapSlpRight90 | Indicates that the slip can print in a rotated 90 degree right mode.
CapSlpRotate180 | Indicates that the slip can print in a rotated 180 degree mode.
CapSlpUnderline | Indicates that the slip can print underlined characters.
CapStatisticsReporting | (inherited from CommonProperties )
CapTransaction | Indicates whether or not each station supports printer transactions.
CapUpdateFirmware | (inherited from CommonProperties )
CapUpdateStatistics | (inherited from CommonProperties )
CartridgeNotify | Holds the type of cartridge state notification the application wants to receive.
CharacterSet | Holds a numeric value indicating the character set the application wants to use for printing characters.
CharacterSetList | Holds a list of character set numbers supported for printing.
CoverOpen | Indicates that the cover is open.
DeviceDescription | (inherited from CommonProperties )
DeviceName | (inherited from CommonProperties )
ErrorLevel | Holds the severity of the most recent error condition.
ErrorStation | Holds the station or stations that were printing when an error was detected.
ErrorString | Holds a vendor-supplied description of the current error.
FlagWhenIdle | If set to true by the application, the service object will queue a StatusUpdateEvent event using the StatusIdle constant when the device is in an idle state, and reset FlagWhenIdle to false.
FontTypefaceList | Holds a string array that specifies the fonts and/or typefaces supported by the printer.
JrnCartridgeState | Holds the status of the selected journal cartridge (ink, ribbon, or toner).
JrnCoverOpen | Notifies the application that the cover has been opened.
JrnCurrentCartridge | Holds the currently selected journal cartridge.
JrnEmpty | If set to true, the journal is out of paper.
JrnLetterQuality | If true, prints in high-quality mode. If false, prints in high-speed mode.
JrnLineChars | Holds the number of characters that the application wants to print on a journal line.
JrnLineCharsList | Holds a collection of the line widths (characters per line) supported by the journal station.
JrnLineHeight | Holds the journal print line height the application wants to use, expressed in the unit of measure indicated by the MapMode property setting.
JrnLineSpacing | Holds the spacing of each single-high print line, including both the printed line height and the white space between each pair of lines that the application wants to use.
JrnLineWidth | Holds the width of a line for the number of characters indicated by the JrnLineChars property, expressed in the unit of measure indicated by the MapMode property.
JrnNearEnd | If true, the journal paper is low.
MapCharacterSet | If set to true by the application while outputting data, the service object maps the characters transferred by the application to the character set selected in the CharacterSet property.
MapMode | Holds the mapping mode of the printer the application wants to use.
PageModeArea | Holds the page area for the selected PageModeStation expressed in the unit of measure given by MapMode.
PageModeDescriptor | Indicates the basic Page Mode functionality of the printer for the selected PageModeStation.
PageModeHorizontalPosition | Holds the horizontal start position offset within the print area for the selected PageModeStation, expressed in the unit of measure given by MapMode.
PageModePrintArea | Holds the print area for the selected PageModeStation expressed in the unit of measure given by MapMode.
PageModePrintDirection | Holds the print direction.
PageModeStation | Gets and sets the print station for use by other Page Mode properties
PageModeVerticalPosition | Holds the vertical start position offset within the print area for the selected PageModeStation.
PowerState | (inherited from CommonProperties )
RecBarCodeRotationList | Holds a list of the directions in which a receipt bar code can be rotated.
RecBitmapRotationList | Holds a list of the directions in which a receipt bitmap can be rotated.
RecCartridgeState | Holds the status of the selected receipt cartridge (ink, ribbon or toner).
RecCoverOpen | Indicates that a cover has been opened.
RecCurrentCartridge | Holds the receipt cartridge currently selected by the application.
RecEmpty | If true, the receipt is out of paper.
RecLetterQuality | If true, prints in high-quality mode. If false, prints in high-speed mode.
RecLineChars | Holds the number of characters that the application wants to print on a receipt line.
RecLineCharsList | Holds a collection of the line widths (characters per line) supported by the receipt station.
RecLineHeight | Holds the receipt print line height, expressed in the unit of measure indicated by the MapMode property setting, that the application wants to use.
RecLineSpacing | Holds the spacing of each single-high print line, including both the printed line height and the white space between each pair of lines, that the application wants to use.
RecLinesToPaperCut | Holds the number of lines that must be advanced before cutting the receipt paper.
RecLineWidth | Holds the width of a line, based on the number of characters specified in the RecLineChars property, expressed in the unit of measure indicated by the MapMode property.
RecNearEnd | If true, the receipt paper is low.
RecSidewaysMaxChars | Holds the maximum number of characters that can be printed on each line in sideways mode.
RecSidewaysMaxLines | Holds the maximum number of lines that can be printed in sideways mode.
RotateSpecial | Holds the rotation orientation for bar codes that the application wants to use.
ServiceObjectDescription | (inherited from CommonProperties )
ServiceObjectVersion | (inherited from CommonProperties )
SlpBarCodeRotationList | Holds a collection of the directions in which a slip bar code may be rotated.
SlpBitmapRotationList | Holds a collection of the directions in which a slip bitmap can be rotated.
SlpCartridgeState | Holds the status of the selected slip cartridge (ink, ribbon, or toner).
SlpCoverOpen | Indicates that a cover has been opened.
SlpCurrentCartridge | Holds the slip cartridge the application wants to use.
SlpEmpty | If true, a slip form is not present.
SlpLetterQuality | If true, prints in high-quality mode. If false, prints in high-speed mode.
SlpLineChars | Holds the number of characters that the application wants to print on a slip line.
SlpLineCharsList | Holds a collection of the line widths (characters per line) supported by the slip station.
SlpLineHeight | Holds the slip print-line height, expressed in the unit of measure indicated by the MapMode property setting, that the application wants to use.
SlpLinesNearEndToEnd | Holds the number of lines that can be printed after the SlpNearEnd property has been set to true but before the printer reaches the end of the slip.
SlpLineSpacing | Holds the spacing of each single-high print line, including both the printed line height and the white space between each pair of lines that the application wants to use.
SlpLineWidth | Holds the line width, based on the number of characters specified for the SlpLineChars property, expressed in the unit of measure indicated by the MapMode property.
SlpMaxLines | Holds the maximum number of lines that can be printed on a form.
SlpNearEnd | If true, the slip form is near its end.
SlpPrintSide | Holds the side of the slip print station document on which printing will occur.
SlpSidewaysMaxChars | Holds the maximum number of characters that can be printed on each line in sideways mode.
SlpSidewaysMaxLines | Holds the maximum number of lines that can be printed in sideways mode.
State | (inherited from CommonProperties )
TopLogo | Holds a value indicating whether a logo should be printed during print operations.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

PrinterProperties Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PrinterProperties Methods

PrinterProperties Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

PrinterProperties Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PrinterProperties Properties

PrinterProperties Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
AsyncMode | Indicates whether certain print methods will be performed asynchronously.
BottomLogo | Determines whether to print a logo during print operations.
CapCharacterSet | Holds the default character set capability.
CapCompareFirmwareVersion | (inherited from CommonProperties )
CapConcurrentJrnRec | Indicates whether Journal and receipt stations can print at the same time.
CapConcurrentJrnSlp | Indicates whether journal and slip stations can print at the same time.
CapConcurrentPageMode | Indicates whether the printer is capable of supporting page mode for the receipt and slip stations concurrently.
CapConcurrentRecSlp | Indicates whether receipt and slip stations can print at the same time.
CapCoverSensor | Indicates whether the printer has a “cover open” sensor.
CapJrn2Color | Indicates whether the journal can print dark plus an alternate color.
CapJrnBold | Indicates whether the journal can print bold characters.
CapJrnCartridgeSensor | Indicates the presence of journal cartridge monitoring sensors.
CapJrnColor | Indicates available journal color cartridges.
CapJrnDHigh | Indicates whether the journal can print double-high characters.
CapJrnDWide | Indicates whether the journal can print double-wide characters.
CapJrnDWideDHigh | Indicates whether the journal can print double-wide and double-high characters.
CapJrnEmptySensor | Indicates whether the journal has an out-of-paper sensor.
CapJrnItalic | Indicates whether the journal can print italic characters.
CapJrnNearEndSensor | Indicates whether the journal has a low-paper sensor.
CapJrnPresent | Indicates whether the journal print station is present.
CapJrnUnderline | Indicates whether the journal can underline characters.
CapMapCharacterSet | Indicates that the service object is able to map the characters sent my the application to a character set defined by the CharacterSetList property.
CapPowerReporting | (inherited from CommonProperties )
CapRec2Color | Indicates whether the receipt can print dark plus an alternate color.
CapRecBarCode | Indicates whether the receipt has bar code printing capability.
CapRecBitmap | Indicates whether the receipt can print bitmaps.
CapRecBold | Indicates whether the receipt can print bold text.
CapRecCartridgeSensor | Indicates the presence of receipt cartridge monitoring sensors.
CapRecColor | Indicates the receipt color cartridges.
CapRecDHigh | Indicates whether the receipt can print double-high characters.
CapRecDWide | Indicates whether the receipt can print double-wide characters.
CapRecDWideDHigh | Indicates whether the receipt can print double-wide, double-high characters.
CapRecEmptySensor | Indicates whether the receipt print station has an out-of-paper sensor.
CapRecItalic | Indicates whether the receipt can print italic text.
CapRecLeft90 | Indicates whether the receipt can print in rotated-90-degree-left mode.
CapRecMarkFeed | Holds the type of mark-sensed paper handling available.
CapRecNearEndSensor | Indicates whether the receipt has a low-paper sensor.
CapRecPageMode | If set to true, the printer is capable of supporting Page Mode for the receipt station.
CapRecPaperCut | Indicates whether the receipt can perform paper cuts.
CapRecPresent | Indicates that the receipt print station is present.
CapRecRight90 | Indicates that the receipt can print in a rotated-90-degree-right mode.
CapRecRotate180 | Indicates that the receipt can print in a rotated-180-degree mode.
CapRecStamp | Indicates that the receipt has a stamp capability.
CapRecUnderline | Indicates whether the receipt can underline characters.
CapSlp2Color | Indicates that the slip can print dark plus an alternate color.
CapSlpBarCode | Indicates that the slip has bar code printing capability.
CapSlpBitmap | Indicates that the slip can print bitmaps.
CapSlpBold | Indicates that the slip can print bold text.
CapSlpBothSidesPrint | Indicates that the slip print station supports printing on both sides of the document.
CapSlpCartridgeSensor | Indicates the presence of slip-cartridge monitoring sensors.
CapSlpColor | Indicates which types of color cartridges supported for slip printing.
CapSlpDHigh | Indicates that the slip can print double-high characters.
CapSlpDWide | Indicates that the slip can print double-wide characters.
CapSlpDWideDHigh | Indicates that the slip can print double-wide, double-high characters.
CapSlpEmptySensor | Indicates that the slip has a “slip in” sensor.
CapSlpFullSlip | Indicates whether the printer supports printing full-length forms on the slip station.
CapSlpItalic | Indicates that the slip can print italic characters.
CapSlpLeft90 | Indicates that the slip can print in a rotated 90 degree left mode.
CapSlpNearEndSensor | Indicates whether the slip has a "slip near end" sensor.
CapSlpPageMode | Indicates whether the printer is capable of supporting Page Mode for the slip station.
CapSlpPresent | Indicates that the printer has a slip station.
CapSlpRight90 | Indicates that the slip can print in a rotated 90 degree right mode.
CapSlpRotate180 | Indicates that the slip can print in a rotated 180 degree mode.
CapSlpUnderline | Indicates that the slip can print underlined characters.
CapStatisticsReporting | (inherited from CommonProperties )
CapTransaction | Indicates whether or not each station supports printer transactions.
CapUpdateFirmware | (inherited from CommonProperties )
CapUpdateStatistics | (inherited from CommonProperties )
CartridgeNotify | Holds the type of cartridge state notification the application wants to receive.
CharacterSet | Holds a numeric value indicating the character set the application wants to use for printing characters.
CharacterSetList | Holds a list of character set numbers supported for printing.
CoverOpen | Indicates that the cover is open.
DeviceDescription | (inherited from CommonProperties )
DeviceName | (inherited from CommonProperties )
ErrorLevel | Holds the severity of the most recent error condition.
ErrorStation | Holds the station or stations that were printing when an error was detected.
ErrorString | Holds a vendor-supplied description of the current error.
FlagWhenIdle | If set to true by the application, the service object will queue a StatusUpdateEvent event using the StatusIdle constant when the device is in an idle state, and reset FlagWhenIdle to false.
FontTypefaceList | Holds a string array that specifies the fonts and/or typefaces supported by the printer.
JrnCartridgeState | Holds the status of the selected journal cartridge (ink, ribbon, or toner).
JrnCoverOpen | Notifies the application that the cover has been opened.
JrnCurrentCartridge | Holds the currently selected journal cartridge.
JrnEmpty | If set to true, the journal is out of paper.
JrnLetterQuality | If true, prints in high-quality mode. If false, prints in high-speed mode.
JrnLineChars | Holds the number of characters that the application wants to print on a journal line.
JrnLineCharsList | Holds a collection of the line widths (characters per line) supported by the journal station.
JrnLineHeight | Holds the journal print line height the application wants to use, expressed in the unit of measure indicated by the MapMode property setting.
JrnLineSpacing | Holds the spacing of each single-high print line, including both the printed line height and the white space between each pair of lines that the application wants to use.
JrnLineWidth | Holds the width of a line for the number of characters indicated by the JrnLineChars property, expressed in the unit of measure indicated by the MapMode property.
JrnNearEnd | If true, the journal paper is low.
MapCharacterSet | If set to true by the application while outputting data, the service object maps the characters transferred by the application to the character set selected in the CharacterSet property.
MapMode | Holds the mapping mode of the printer the application wants to use.
PageModeArea | Holds the page area for the selected PageModeStation expressed in the unit of measure given by MapMode.
PageModeDescriptor | Indicates the basic Page Mode functionality of the printer for the selected PageModeStation.
PageModeHorizontalPosition | Holds the horizontal start position offset within the print area for the selected PageModeStation, expressed in the unit of measure given by MapMode.
PageModePrintArea | Holds the print area for the selected PageModeStation expressed in the unit of measure given by MapMode.
PageModePrintDirection | Holds the print direction.
PageModeStation | Gets and sets the print station for use by other Page Mode properties
PageModeVerticalPosition | Holds the vertical start position offset within the print area for the selected PageModeStation.
PowerState | (inherited from CommonProperties )
RecBarCodeRotationList | Holds a list of the directions in which a receipt bar code can be rotated.
RecBitmapRotationList | Holds a list of the directions in which a receipt bitmap can be rotated.
RecCartridgeState | Holds the status of the selected receipt cartridge (ink, ribbon or toner).
RecCoverOpen | Indicates that a cover has been opened.
RecCurrentCartridge | Holds the receipt cartridge currently selected by the application.
RecEmpty | If true, the receipt is out of paper.
RecLetterQuality | If true, prints in high-quality mode. If false, prints in high-speed mode.
RecLineChars | Holds the number of characters that the application wants to print on a receipt line.
RecLineCharsList | Holds a collection of the line widths (characters per line) supported by the receipt station.
RecLineHeight | Holds the receipt print line height, expressed in the unit of measure indicated by the MapMode property setting, that the application wants to use.
RecLineSpacing | Holds the spacing of each single-high print line, including both the printed line height and the white space between each pair of lines, that the application wants to use.
RecLinesToPaperCut | Holds the number of lines that must be advanced before cutting the receipt paper.
RecLineWidth | Holds the width of a line, based on the number of characters specified in the RecLineChars property, expressed in the unit of measure indicated by the MapMode property.
RecNearEnd | If true, the receipt paper is low.
RecSidewaysMaxChars | Holds the maximum number of characters that can be printed on each line in sideways mode.
RecSidewaysMaxLines | Holds the maximum number of lines that can be printed in sideways mode.
RotateSpecial | Holds the rotation orientation for bar codes that the application wants to use.
ServiceObjectDescription | (inherited from CommonProperties )
ServiceObjectVersion | (inherited from CommonProperties )
SlpBarCodeRotationList | Holds a collection of the directions in which a slip bar code may be rotated.
SlpBitmapRotationList | Holds a collection of the directions in which a slip bitmap can be rotated.
SlpCartridgeState | Holds the status of the selected slip cartridge (ink, ribbon, or toner).
SlpCoverOpen | Indicates that a cover has been opened.
SlpCurrentCartridge | Holds the slip cartridge the application wants to use.
SlpEmpty | If true, a slip form is not present.
SlpLetterQuality | If true, prints in high-quality mode. If false, prints in high-speed mode.
SlpLineChars | Holds the number of characters that the application wants to print on a slip line.
SlpLineCharsList | Holds a collection of the line widths (characters per line) supported by the slip station.
SlpLineHeight | Holds the slip print-line height, expressed in the unit of measure indicated by the MapMode property setting, that the application wants to use.
SlpLinesNearEndToEnd | Holds the number of lines that can be printed after the SlpNearEnd property has been set to true but before the printer reaches the end of the slip.
SlpLineSpacing | Holds the spacing of each single-high print line, including both the printed line height and the white space between each pair of lines that the application wants to use.
SlpLineWidth | Holds the line width, based on the number of characters specified for the SlpLineChars property, expressed in the unit of measure indicated by the MapMode property.
SlpMaxLines | Holds the maximum number of lines that can be printed on a form.
SlpNearEnd | If true, the slip form is near its end.
SlpPrintSide | Holds the side of the slip print station document on which printing will occur.
SlpSidewaysMaxChars | Holds the maximum number of characters that can be printed on each line in sideways mode.
SlpSidewaysMaxLines | Holds the maximum number of lines that can be printed in sideways mode.
State | (inherited from CommonProperties )
TopLogo | Holds a value indicating whether a logo should be printed during print operations.

See Also

Reference

PrinterProperties Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PrinterProperties.AsyncMode Property

PrinterProperties.AsyncMode Property |
 | See Also

1/18/2008

Indicates whether certain print methods will be performed asynchronously.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property AsyncMode As Boolean
public bool AsyncMode { get; set; }
public:
property bool AsyncMode {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_AsyncMode ()

/** @property */
public void set_AsyncMode (boolean value)

public function get AsyncMode () : boolean

public function set AsyncMode (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.AsyncMode Property


PrinterProperties.BottomLogo Property

PrinterProperties.BottomLogo Property |
 | See Also

1/18/2008

Determines whether to print a logo during print operations.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property BottomLogo As String
public string BottomLogo { get; }
public:
property String^ BottomLogo {
    String^ get ();
}
/** @property */
public String get_BottomLogo ()

public function get BottomLogo () : String

Remarks

Set by the PosPrinterBase class during the SetLogo method. The service object can query BottomLogo to determine whether to print a logo during print operations. If BottomLogo is null, an empty string is returned.

BottomLogo is initialized to an empty string ("") by the PosPrinterProperties class ("").

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.SetLogo Method


PrinterProperties.CapCharacterSet Property

PrinterProperties.CapCharacterSet Property |
 | See Also

1/18/2008

Holds the default character set capability.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapCharacterSet As CharacterSetCapability
public CharacterSetCapability CapCharacterSet { get; set; }
public:
property CharacterSetCapability CapCharacterSet {
    CharacterSetCapability get ();
    void set (CharacterSetCapability value);
}
/** @property */
public CharacterSetCapability get_CapCharacterSet ()

/** @property */
public void set_CapCharacterSet (CharacterSetCapability value)

public function get CapCharacterSet () : CharacterSetCapability

public function set CapCharacterSet (value : CharacterSetCapability)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapCharacterSet Property


PrinterProperties.CapConcurrentJrnRec Property

PrinterProperties.CapConcurrentJrnRec Property |
 | See Also

1/18/2008

Indicates whether Journal and receipt stations can print at the same time.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapConcurrentJrnRec As Boolean
public bool CapConcurrentJrnRec { get; set; }
public:
property bool CapConcurrentJrnRec {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapConcurrentJrnRec ()

/** @property */
public void set_CapConcurrentJrnRec (boolean value)

public function get CapConcurrentJrnRec () : boolean

public function set CapConcurrentJrnRec (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapConcurrentJrnRec Property


PrinterProperties.CapConcurrentJrnSlp Property

PrinterProperties.CapConcurrentJrnSlp Property |
 | See Also

1/18/2008

Indicates whether journal and slip stations can print at the same time.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapConcurrentJrnSlp As Boolean
public bool CapConcurrentJrnSlp { get; set; }
public:
property bool CapConcurrentJrnSlp {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapConcurrentJrnSlp ()

/** @property */
public void set_CapConcurrentJrnSlp (boolean value)

public function get CapConcurrentJrnSlp () : boolean

public function set CapConcurrentJrnSlp (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapConcurrentJrnSlp Property


PrinterProperties.CapConcurrentPageMode Property

PrinterProperties.CapConcurrentPageMode Property |
 | See Also

1/18/2008

Indicates whether the printer is capable of supporting page mode for the receipt and slip stations concurrently.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapConcurrentPageMode As Boolean
public bool CapConcurrentPageMode { get; set; }
public:
property bool CapConcurrentPageMode {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapConcurrentPageMode ()

/** @property */
public void set_CapConcurrentPageMode (boolean value)

public function get CapConcurrentPageMode () : boolean

public function set CapConcurrentPageMode (value : boolean)

Remarks

If true, then the printer is capable of supporting Page Mode concurrently for both the receipt and slip stations. If Page Mode is not supported on either station, only on one station, or only on one station at a time, then this value should be false.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrinterProperties.CapConcurrentRecSlp Property

PrinterProperties.CapConcurrentRecSlp Property |
 | See Also

1/18/2008

Indicates whether receipt and slip stations can print at the same time.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapConcurrentRecSlp As Boolean
public bool CapConcurrentRecSlp { get; set; }
public:
property bool CapConcurrentRecSlp {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapConcurrentRecSlp ()

/** @property */
public void set_CapConcurrentRecSlp (boolean value)

public function get CapConcurrentRecSlp () : boolean

public function set CapConcurrentRecSlp (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapConcurrentRecSlp Property


PrinterProperties.CapCoverSensor Property

PrinterProperties.CapCoverSensor Property |
 | See Also

1/18/2008

Indicates whether the printer has a “cover open” sensor.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapCoverSensor As Boolean
public bool CapCoverSensor { get; set; }
public:
property bool CapCoverSensor {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapCoverSensor ()

/** @property */
public void set_CapCoverSensor (boolean value)

public function get CapCoverSensor () : boolean

public function set CapCoverSensor (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapCoverSensor Property


PrinterProperties.CapJrn2Color Property

PrinterProperties.CapJrn2Color Property |
 | See Also

1/18/2008

Indicates whether the journal can print dark plus an alternate color.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapJrn2Color As Boolean
public bool CapJrn2Color { get; set; }
public:
property bool CapJrn2Color {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapJrn2Color ()

/** @property */
public void set_CapJrn2Color (boolean value)

public function get CapJrn2Color () : boolean

public function set CapJrn2Color (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapJrn2Color Property


PrinterProperties.CapJrnBold Property

PrinterProperties.CapJrnBold Property |
 | See Also

1/18/2008

Indicates whether the journal can print bold characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapJrnBold As Boolean
public bool CapJrnBold { get; set; }
public:
property bool CapJrnBold {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapJrnBold ()

/** @property */
public void set_CapJrnBold (boolean value)

public function get CapJrnBold () : boolean

public function set CapJrnBold (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapJrnBold Property


PrinterProperties.CapJrnCartridgeSensor Property

PrinterProperties.CapJrnCartridgeSensor Property |
 | See Also

1/18/2008

Indicates the presence of journal cartridge monitoring sensors.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapJrnCartridgeSensor As PrinterCartridgeSensors
public PrinterCartridgeSensors CapJrnCartridgeSensor { get; set; }
public:
property PrinterCartridgeSensors CapJrnCartridgeSensor {
    PrinterCartridgeSensors get ();
    void set (PrinterCartridgeSensors value);
}
/** @property */
public PrinterCartridgeSensors get_CapJrnCartridgeSensor ()

/** @property */
public void set_CapJrnCartridgeSensor (PrinterCartridgeSensors value)

public function get CapJrnCartridgeSensor () : PrinterCartridgeSensors

public function set CapJrnCartridgeSensor (value : PrinterCartridgeSensors)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapJrnCartridgeSensor Property


PrinterProperties.CapJrnColor Property

PrinterProperties.CapJrnColor Property |
 | See Also

1/18/2008

Indicates available journal color cartridges.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapJrnColor As PrinterColors
public PrinterColors CapJrnColor { get; set; }
public:
property PrinterColors CapJrnColor {
    PrinterColors get ();
    void set (PrinterColors value);
}
/** @property */
public PrinterColors get_CapJrnColor ()

/** @property */
public void set_CapJrnColor (PrinterColors value)

public function get CapJrnColor () : PrinterColors

public function set CapJrnColor (value : PrinterColors)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapJrnColor Property


PrinterProperties.CapJrnDHigh Property

PrinterProperties.CapJrnDHigh Property |
 | See Also

1/18/2008

Indicates whether the journal can print double-high characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapJrnDHigh As Boolean
public bool CapJrnDHigh { get; set; }
public:
property bool CapJrnDHigh {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapJrnDHigh ()

/** @property */
public void set_CapJrnDHigh (boolean value)

public function get CapJrnDHigh () : boolean

public function set CapJrnDHigh (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapJrnDHigh Property


PrinterProperties.CapJrnDWide Property

PrinterProperties.CapJrnDWide Property |
 | See Also

1/18/2008

Indicates whether the journal can print double-wide characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapJrnDWide As Boolean
public bool CapJrnDWide { get; set; }
public:
property bool CapJrnDWide {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapJrnDWide ()

/** @property */
public void set_CapJrnDWide (boolean value)

public function get CapJrnDWide () : boolean

public function set CapJrnDWide (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapJrnDWide Property


PrinterProperties.CapJrnDWideDHigh Property

PrinterProperties.CapJrnDWideDHigh Property |
 | See Also

1/18/2008

Indicates whether the journal can print double-wide and double-high characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapJrnDWideDHigh As Boolean
public bool CapJrnDWideDHigh { get; set; }
public:
property bool CapJrnDWideDHigh {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapJrnDWideDHigh ()

/** @property */
public void set_CapJrnDWideDHigh (boolean value)

public function get CapJrnDWideDHigh () : boolean

public function set CapJrnDWideDHigh (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapJrnDWideDHigh Property


PrinterProperties.CapJrnEmptySensor Property

PrinterProperties.CapJrnEmptySensor Property |
 | See Also

1/18/2008

Indicates whether the journal has an out-of-paper sensor.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapJrnEmptySensor As Boolean
public bool CapJrnEmptySensor { get; set; }
public:
property bool CapJrnEmptySensor {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapJrnEmptySensor ()

/** @property */
public void set_CapJrnEmptySensor (boolean value)

public function get CapJrnEmptySensor () : boolean

public function set CapJrnEmptySensor (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapJrnEmptySensor Property


PrinterProperties.CapJrnItalic Property

PrinterProperties.CapJrnItalic Property |
 | See Also

1/18/2008

Indicates whether the journal can print italic characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapJrnItalic As Boolean
public bool CapJrnItalic { get; set; }
public:
property bool CapJrnItalic {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapJrnItalic ()

/** @property */
public void set_CapJrnItalic (boolean value)

public function get CapJrnItalic () : boolean

public function set CapJrnItalic (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapJrnItalic Property


PrinterProperties.CapJrnNearEndSensor Property

PrinterProperties.CapJrnNearEndSensor Property |
 | See Also

1/18/2008

Indicates whether the journal has a low-paper sensor.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapJrnNearEndSensor As Boolean
public bool CapJrnNearEndSensor { get; set; }
public:
property bool CapJrnNearEndSensor {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapJrnNearEndSensor ()

/** @property */
public void set_CapJrnNearEndSensor (boolean value)

public function get CapJrnNearEndSensor () : boolean

public function set CapJrnNearEndSensor (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
CapJrnEndSensor


PrinterProperties.CapJrnPresent Property

PrinterProperties.CapJrnPresent Property |
 | See Also

1/18/2008

Indicates whether the journal print station is present.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapJrnPresent As Boolean
public bool CapJrnPresent { get; set; }
public:
property bool CapJrnPresent {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapJrnPresent ()

/** @property */
public void set_CapJrnPresent (boolean value)

public function get CapJrnPresent () : boolean

public function set CapJrnPresent (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapJrnPresent Property


PrinterProperties.CapJrnUnderline Property

PrinterProperties.CapJrnUnderline Property |
 | See Also

1/18/2008

Indicates whether the journal can underline characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapJrnUnderline As Boolean
public bool CapJrnUnderline { get; set; }
public:
property bool CapJrnUnderline {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapJrnUnderline ()

/** @property */
public void set_CapJrnUnderline (boolean value)

public function get CapJrnUnderline () : boolean

public function set CapJrnUnderline (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapJrnUnderline Property


PrinterProperties.CapMapCharacterSet Property

PrinterProperties.CapMapCharacterSet Property |
 | See Also

1/18/2008

Indicates that the service object is able to map the characters sent my the application to a character set defined by the CharacterSetList property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapMapCharacterSet As Boolean
public bool CapMapCharacterSet { get; set; }
public:
property bool CapMapCharacterSet {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapMapCharacterSet ()

/** @property */
public void set_CapMapCharacterSet (boolean value)

public function get CapMapCharacterSet () : boolean

public function set CapMapCharacterSet (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapMapCharacterSet Property


PrinterProperties.CapRec2Color Property

PrinterProperties.CapRec2Color Property |
 | See Also

1/18/2008

Indicates whether the receipt can print dark plus an alternate color.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapRec2Color As Boolean
public bool CapRec2Color { get; set; }
public:
property bool CapRec2Color {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapRec2Color ()

/** @property */
public void set_CapRec2Color (boolean value)

public function get CapRec2Color () : boolean

public function set CapRec2Color (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapRec2Color Property


PrinterProperties.CapRecBarCode Property

PrinterProperties.CapRecBarCode Property |
 | See Also

1/18/2008

Indicates whether the receipt has bar code printing capability.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapRecBarCode As Boolean
public bool CapRecBarCode { get; set; }
public:
property bool CapRecBarCode {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapRecBarCode ()

/** @property */
public void set_CapRecBarCode (boolean value)

public function get CapRecBarCode () : boolean

public function set CapRecBarCode (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapRecBarCode Property


PrinterProperties.CapRecBitmap Property

PrinterProperties.CapRecBitmap Property |
 | See Also

1/18/2008

Indicates whether the receipt can print bitmaps.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapRecBitmap As Boolean
public bool CapRecBitmap { get; set; }
public:
property bool CapRecBitmap {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapRecBitmap ()

/** @property */
public void set_CapRecBitmap (boolean value)

public function get CapRecBitmap () : boolean

public function set CapRecBitmap (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapRecBitmap Property


PrinterProperties.CapRecBold Property

PrinterProperties.CapRecBold Property |
 | See Also

1/18/2008

Indicates whether the receipt can print bold text.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapRecBold As Boolean
public bool CapRecBold { get; set; }
public:
property bool CapRecBold {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapRecBold ()

/** @property */
public void set_CapRecBold (boolean value)

public function get CapRecBold () : boolean

public function set CapRecBold (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapRecBold Property


PrinterProperties.CapRecCartridgeSensor Property

PrinterProperties.CapRecCartridgeSensor Property |
 | See Also

1/18/2008

Indicates the presence of receipt cartridge monitoring sensors.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapRecCartridgeSensor As PrinterCartridgeSensors
public PrinterCartridgeSensors CapRecCartridgeSensor { get; set; }
public:
property PrinterCartridgeSensors CapRecCartridgeSensor {
    PrinterCartridgeSensors get ();
    void set (PrinterCartridgeSensors value);
}
/** @property */
public PrinterCartridgeSensors get_CapRecCartridgeSensor ()

/** @property */
public void set_CapRecCartridgeSensor (PrinterCartridgeSensors value)

public function get CapRecCartridgeSensor () : PrinterCartridgeSensors

public function set CapRecCartridgeSensor (value : PrinterCartridgeSensors)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapRecCartridgeSensor Property


PrinterProperties.CapRecColor Property

PrinterProperties.CapRecColor Property |
 | See Also

1/18/2008

Indicates the receipt color cartridges.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapRecColor As PrinterColors
public PrinterColors CapRecColor { get; set; }
public:
property PrinterColors CapRecColor {
    PrinterColors get ();
    void set (PrinterColors value);
}
/** @property */
public PrinterColors get_CapRecColor ()

/** @property */
public void set_CapRecColor (PrinterColors value)

public function get CapRecColor () : PrinterColors

public function set CapRecColor (value : PrinterColors)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapRecColor Property


PrinterProperties.CapRecDHigh Property

PrinterProperties.CapRecDHigh Property |
 | See Also

1/18/2008

Indicates whether the receipt can print double-high characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapRecDHigh As Boolean
public bool CapRecDHigh { get; set; }
public:
property bool CapRecDHigh {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapRecDHigh ()

/** @property */
public void set_CapRecDHigh (boolean value)

public function get CapRecDHigh () : boolean

public function set CapRecDHigh (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapRecDHigh Property


PrinterProperties.CapRecDWide Property

PrinterProperties.CapRecDWide Property |
 | See Also

1/18/2008

Indicates whether the receipt can print double-wide characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapRecDWide As Boolean
public bool CapRecDWide { get; set; }
public:
property bool CapRecDWide {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapRecDWide ()

/** @property */
public void set_CapRecDWide (boolean value)

public function get CapRecDWide () : boolean

public function set CapRecDWide (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapRecDWide Property


PrinterProperties.CapRecDWideDHigh Property

PrinterProperties.CapRecDWideDHigh Property |
 | See Also

1/18/2008

Indicates whether the receipt can print double-wide, double-high characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapRecDWideDHigh As Boolean
public bool CapRecDWideDHigh { get; set; }
public:
property bool CapRecDWideDHigh {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapRecDWideDHigh ()

/** @property */
public void set_CapRecDWideDHigh (boolean value)

public function get CapRecDWideDHigh () : boolean

public function set CapRecDWideDHigh (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapRecDWideDHigh Property


PrinterProperties.CapRecEmptySensor Property

PrinterProperties.CapRecEmptySensor Property |
 | See Also

1/18/2008

Indicates whether the receipt print station has an out-of-paper sensor.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapRecEmptySensor As Boolean
public bool CapRecEmptySensor { get; set; }
public:
property bool CapRecEmptySensor {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapRecEmptySensor ()

/** @property */
public void set_CapRecEmptySensor (boolean value)

public function get CapRecEmptySensor () : boolean

public function set CapRecEmptySensor (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapRecEmptySensor Property


PrinterProperties.CapRecItalic Property

PrinterProperties.CapRecItalic Property |
 | See Also

1/18/2008

Indicates whether the receipt can print italic text.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapRecItalic As Boolean
public bool CapRecItalic { get; set; }
public:
property bool CapRecItalic {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapRecItalic ()

/** @property */
public void set_CapRecItalic (boolean value)

public function get CapRecItalic () : boolean

public function set CapRecItalic (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapRecItalic Property


PrinterProperties.CapRecLeft90 Property

PrinterProperties.CapRecLeft90 Property |
 | See Also

1/18/2008

Indicates whether the receipt can print in rotated-90-degree-left mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapRecLeft90 As Boolean
public bool CapRecLeft90 { get; set; }
public:
property bool CapRecLeft90 {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapRecLeft90 ()

/** @property */
public void set_CapRecLeft90 (boolean value)

public function get CapRecLeft90 () : boolean

public function set CapRecLeft90 (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapRecLeft90 Property


PrinterProperties.CapRecMarkFeed Property

PrinterProperties.CapRecMarkFeed Property |
 | See Also

1/18/2008

Holds the type of mark-sensed paper handling available.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapRecMarkFeed As PrinterMarkFeeds
public PrinterMarkFeeds CapRecMarkFeed { get; set; }
public:
property PrinterMarkFeeds CapRecMarkFeed {
    PrinterMarkFeeds get ();
    void set (PrinterMarkFeeds value);
}
/** @property */
public PrinterMarkFeeds get_CapRecMarkFeed ()

/** @property */
public void set_CapRecMarkFeed (PrinterMarkFeeds value)

public function get CapRecMarkFeed () : PrinterMarkFeeds

public function set CapRecMarkFeed (value : PrinterMarkFeeds)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapRecMarkFeed Property


PrinterProperties.CapRecNearEndSensor Property

PrinterProperties.CapRecNearEndSensor Property |
 | See Also

1/18/2008

Indicates whether the receipt has a low-paper sensor.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapRecNearEndSensor As Boolean
public bool CapRecNearEndSensor { get; set; }
public:
property bool CapRecNearEndSensor {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapRecNearEndSensor ()

/** @property */
public void set_CapRecNearEndSensor (boolean value)

public function get CapRecNearEndSensor () : boolean

public function set CapRecNearEndSensor (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapRecNearEndSensor Property


PrinterProperties.CapRecPageMode Property

PrinterProperties.CapRecPageMode Property |
 | See Also

1/18/2008

If set to true, the printer is capable of supporting Page Mode for the receipt station.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapRecPageMode As Boolean
public bool CapRecPageMode { get; set; }
public:
property bool CapRecPageMode {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapRecPageMode ()

/** @property */
public void set_CapRecPageMode (boolean value)

public function get CapRecPageMode () : boolean

public function set CapRecPageMode (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrinterProperties.CapRecPaperCut Property

PrinterProperties.CapRecPaperCut Property |
 | See Also

1/18/2008

Indicates whether the receipt can perform paper cuts.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapRecPaperCut As Boolean
public bool CapRecPaperCut { get; set; }
public:
property bool CapRecPaperCut {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapRecPaperCut ()

/** @property */
public void set_CapRecPaperCut (boolean value)

public function get CapRecPaperCut () : boolean

public function set CapRecPaperCut (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapRecPaperCut Property


PrinterProperties.CapRecPresent Property

PrinterProperties.CapRecPresent Property |
 | See Also

1/18/2008

Indicates that the receipt print station is present.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapRecPresent As Boolean
public bool CapRecPresent { get; set; }
public:
property bool CapRecPresent {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapRecPresent ()

/** @property */
public void set_CapRecPresent (boolean value)

public function get CapRecPresent () : boolean

public function set CapRecPresent (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapRecPresent Property


PrinterProperties.CapRecRight90 Property

PrinterProperties.CapRecRight90 Property |
 | See Also

1/18/2008

Indicates that the receipt can print in a rotated-90-degree-right mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapRecRight90 As Boolean
public bool CapRecRight90 { get; set; }
public:
property bool CapRecRight90 {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapRecRight90 ()

/** @property */
public void set_CapRecRight90 (boolean value)

public function get CapRecRight90 () : boolean

public function set CapRecRight90 (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapRecRight90 Property


PrinterProperties.CapRecRotate180 Property

PrinterProperties.CapRecRotate180 Property |
 | See Also

1/18/2008

Indicates that the receipt can print in a rotated-180-degree mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapRecRotate180 As Boolean
public bool CapRecRotate180 { get; set; }
public:
property bool CapRecRotate180 {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapRecRotate180 ()

/** @property */
public void set_CapRecRotate180 (boolean value)

public function get CapRecRotate180 () : boolean

public function set CapRecRotate180 (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapRecRotate180 Property


PrinterProperties.CapRecStamp Property

PrinterProperties.CapRecStamp Property |
 | See Also

1/18/2008

Indicates that the receipt has a stamp capability.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapRecStamp As Boolean
public bool CapRecStamp { get; set; }
public:
property bool CapRecStamp {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapRecStamp ()

/** @property */
public void set_CapRecStamp (boolean value)

public function get CapRecStamp () : boolean

public function set CapRecStamp (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapRecStamp Property


PrinterProperties.CapRecUnderline Property

PrinterProperties.CapRecUnderline Property |
 | See Also

1/18/2008

Indicates whether the receipt can underline characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapRecUnderline As Boolean
public bool CapRecUnderline { get; set; }
public:
property bool CapRecUnderline {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapRecUnderline ()

/** @property */
public void set_CapRecUnderline (boolean value)

public function get CapRecUnderline () : boolean

public function set CapRecUnderline (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapRecUnderline Property


PrinterProperties.CapSlp2Color Property

PrinterProperties.CapSlp2Color Property |
 | See Also

1/18/2008

Indicates that the slip can print dark plus an alternate color.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapSlp2Color As Boolean
public bool CapSlp2Color { get; set; }
public:
property bool CapSlp2Color {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapSlp2Color ()

/** @property */
public void set_CapSlp2Color (boolean value)

public function get CapSlp2Color () : boolean

public function set CapSlp2Color (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapSlp2Color Property


PrinterProperties.CapSlpBarCode Property

PrinterProperties.CapSlpBarCode Property |
 | See Also

1/18/2008

Indicates that the slip has bar code printing capability.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapSlpBarCode As Boolean
public bool CapSlpBarCode { get; set; }
public:
property bool CapSlpBarCode {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapSlpBarCode ()

/** @property */
public void set_CapSlpBarCode (boolean value)

public function get CapSlpBarCode () : boolean

public function set CapSlpBarCode (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapSlpBarCode Property


PrinterProperties.CapSlpBitmap Property

PrinterProperties.CapSlpBitmap Property |
 | See Also

1/18/2008

Indicates that the slip can print bitmaps.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapSlpBitmap As Boolean
public bool CapSlpBitmap { get; set; }
public:
property bool CapSlpBitmap {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapSlpBitmap ()

/** @property */
public void set_CapSlpBitmap (boolean value)

public function get CapSlpBitmap () : boolean

public function set CapSlpBitmap (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapSlpBitmap Property


PrinterProperties.CapSlpBold Property

PrinterProperties.CapSlpBold Property |
 | See Also

1/18/2008

Indicates that the slip can print bold text.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapSlpBold As Boolean
public bool CapSlpBold { get; set; }
public:
property bool CapSlpBold {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapSlpBold ()

/** @property */
public void set_CapSlpBold (boolean value)

public function get CapSlpBold () : boolean

public function set CapSlpBold (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapSlpBold Property


PrinterProperties.CapSlpBothSidesPrint Property

PrinterProperties.CapSlpBothSidesPrint Property |
 | See Also

1/18/2008

Indicates that the slip print station supports printing on both sides of the document.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapSlpBothSidesPrint As Boolean
public bool CapSlpBothSidesPrint { get; set; }
public:
property bool CapSlpBothSidesPrint {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapSlpBothSidesPrint ()

/** @property */
public void set_CapSlpBothSidesPrint (boolean value)

public function get CapSlpBothSidesPrint () : boolean

public function set CapSlpBothSidesPrint (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapSlpBothSidesPrint Property


PrinterProperties.CapSlpCartridgeSensor Property

PrinterProperties.CapSlpCartridgeSensor Property |
 | See Also

1/18/2008

Indicates the presence of slip-cartridge monitoring sensors.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapSlpCartridgeSensor As PrinterCartridgeSensors
public PrinterCartridgeSensors CapSlpCartridgeSensor { get; set; }
public:
property PrinterCartridgeSensors CapSlpCartridgeSensor {
    PrinterCartridgeSensors get ();
    void set (PrinterCartridgeSensors value);
}
/** @property */
public PrinterCartridgeSensors get_CapSlpCartridgeSensor ()

/** @property */
public void set_CapSlpCartridgeSensor (PrinterCartridgeSensors value)

public function get CapSlpCartridgeSensor () : PrinterCartridgeSensors

public function set CapSlpCartridgeSensor (value : PrinterCartridgeSensors)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapSlpCartridgeSensor Property


PrinterProperties.CapSlpColor Property

PrinterProperties.CapSlpColor Property |
 | See Also

1/18/2008

Indicates which types of color cartridges supported for slip printing.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapSlpColor As PrinterColors
public PrinterColors CapSlpColor { get; set; }
public:
property PrinterColors CapSlpColor {
    PrinterColors get ();
    void set (PrinterColors value);
}
/** @property */
public PrinterColors get_CapSlpColor ()

/** @property */
public void set_CapSlpColor (PrinterColors value)

public function get CapSlpColor () : PrinterColors

public function set CapSlpColor (value : PrinterColors)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapSlpColor Property


PrinterProperties.CapSlpDHigh Property

PrinterProperties.CapSlpDHigh Property |
 | See Also

1/18/2008

Indicates that the slip can print double-high characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapSlpDHigh As Boolean
public bool CapSlpDHigh { get; set; }
public:
property bool CapSlpDHigh {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapSlpDHigh ()

/** @property */
public void set_CapSlpDHigh (boolean value)

public function get CapSlpDHigh () : boolean

public function set CapSlpDHigh (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapSlpDHigh Property


PrinterProperties.CapSlpDWide Property

PrinterProperties.CapSlpDWide Property |
 | See Also

1/18/2008

Indicates that the slip can print double-wide characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapSlpDWide As Boolean
public bool CapSlpDWide { get; set; }
public:
property bool CapSlpDWide {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapSlpDWide ()

/** @property */
public void set_CapSlpDWide (boolean value)

public function get CapSlpDWide () : boolean

public function set CapSlpDWide (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapSlpDWide Property


PrinterProperties.CapSlpDWideDHigh Property

PrinterProperties.CapSlpDWideDHigh Property |
 | See Also

1/18/2008

Indicates that the slip can print double-wide, double-high characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapSlpDWideDHigh As Boolean
public bool CapSlpDWideDHigh { get; set; }
public:
property bool CapSlpDWideDHigh {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapSlpDWideDHigh ()

/** @property */
public void set_CapSlpDWideDHigh (boolean value)

public function get CapSlpDWideDHigh () : boolean

public function set CapSlpDWideDHigh (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapSlpDWideDHigh Property


PrinterProperties.CapSlpEmptySensor Property

PrinterProperties.CapSlpEmptySensor Property |
 | See Also

1/18/2008

Indicates that the slip has a “slip in” sensor.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapSlpEmptySensor As Boolean
public bool CapSlpEmptySensor { get; set; }
public:
property bool CapSlpEmptySensor {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapSlpEmptySensor ()

/** @property */
public void set_CapSlpEmptySensor (boolean value)

public function get CapSlpEmptySensor () : boolean

public function set CapSlpEmptySensor (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapSlpEmptySensor Property


PrinterProperties.CapSlpFullSlip Property

PrinterProperties.CapSlpFullSlip Property |
 | See Also

1/18/2008

Indicates whether the printer supports printing full-length forms on the slip station.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapSlpFullSlip As Boolean
public bool CapSlpFullSlip { get; set; }
public:
property bool CapSlpFullSlip {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapSlpFullSlip ()

/** @property */
public void set_CapSlpFullSlip (boolean value)

public function get CapSlpFullSlip () : boolean

public function set CapSlpFullSlip (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapSlpFullSlip Property


PrinterProperties.CapSlpItalic Property

PrinterProperties.CapSlpItalic Property |
 | See Also

1/18/2008

Indicates that the slip can print italic characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapSlpItalic As Boolean
public bool CapSlpItalic { get; set; }
public:
property bool CapSlpItalic {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapSlpItalic ()

/** @property */
public void set_CapSlpItalic (boolean value)

public function get CapSlpItalic () : boolean

public function set CapSlpItalic (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapSlpItalic Property


PrinterProperties.CapSlpLeft90 Property

PrinterProperties.CapSlpLeft90 Property |
 | See Also

1/18/2008

Indicates that the slip can print in a rotated 90 degree left mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapSlpLeft90 As Boolean
public bool CapSlpLeft90 { get; set; }
public:
property bool CapSlpLeft90 {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapSlpLeft90 ()

/** @property */
public void set_CapSlpLeft90 (boolean value)

public function get CapSlpLeft90 () : boolean

public function set CapSlpLeft90 (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapSlpLeft90 Property


PrinterProperties.CapSlpNearEndSensor Property

PrinterProperties.CapSlpNearEndSensor Property |
 | See Also

1/18/2008

Indicates whether the slip has a "slip near end" sensor.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapSlpNearEndSensor As Boolean
public bool CapSlpNearEndSensor { get; set; }
public:
property bool CapSlpNearEndSensor {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapSlpNearEndSensor ()

/** @property */
public void set_CapSlpNearEndSensor (boolean value)

public function get CapSlpNearEndSensor () : boolean

public function set CapSlpNearEndSensor (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapSlpNearEndSensor Property


PrinterProperties.CapSlpPageMode Property

PrinterProperties.CapSlpPageMode Property |
 | See Also

1/18/2008

Indicates whether the printer is capable of supporting Page Mode for the slip station.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapSlpPageMode As Boolean
public bool CapSlpPageMode { get; set; }
public:
property bool CapSlpPageMode {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapSlpPageMode ()

/** @property */
public void set_CapSlpPageMode (boolean value)

public function get CapSlpPageMode () : boolean

public function set CapSlpPageMode (value : boolean)

Remarks

If true, then the printer is capable of supporting Page Mode for the slip station.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrinterProperties.CapSlpPresent Property

PrinterProperties.CapSlpPresent Property |
 | See Also

1/18/2008

Indicates that the printer has a slip station.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapSlpPresent As Boolean
public bool CapSlpPresent { get; set; }
public:
property bool CapSlpPresent {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapSlpPresent ()

/** @property */
public void set_CapSlpPresent (boolean value)

public function get CapSlpPresent () : boolean

public function set CapSlpPresent (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapSlpPresent Property


PrinterProperties.CapSlpRight90 Property

PrinterProperties.CapSlpRight90 Property |
 | See Also

1/18/2008

Indicates that the slip can print in a rotated 90 degree right mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapSlpRight90 As Boolean
public bool CapSlpRight90 { get; set; }
public:
property bool CapSlpRight90 {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapSlpRight90 ()

/** @property */
public void set_CapSlpRight90 (boolean value)

public function get CapSlpRight90 () : boolean

public function set CapSlpRight90 (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapSlpRight90 Property


PrinterProperties.CapSlpRotate180 Property

PrinterProperties.CapSlpRotate180 Property |
 | See Also

1/18/2008

Indicates that the slip can print in a rotated 180 degree mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapSlpRotate180 As Boolean
public bool CapSlpRotate180 { get; set; }
public:
property bool CapSlpRotate180 {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapSlpRotate180 ()

/** @property */
public void set_CapSlpRotate180 (boolean value)

public function get CapSlpRotate180 () : boolean

public function set CapSlpRotate180 (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapSlpRotate180 Property


PrinterProperties.CapSlpUnderline Property

PrinterProperties.CapSlpUnderline Property |
 | See Also

1/18/2008

Indicates that the slip can print underlined characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapSlpUnderline As Boolean
public bool CapSlpUnderline { get; set; }
public:
property bool CapSlpUnderline {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapSlpUnderline ()

/** @property */
public void set_CapSlpUnderline (boolean value)

public function get CapSlpUnderline () : boolean

public function set CapSlpUnderline (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapSlpUnderline Property


PrinterProperties.CapTransaction Property

PrinterProperties.CapTransaction Property |
 | See Also

1/18/2008

Indicates whether or not each station supports printer transactions.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapTransaction As Boolean
public bool CapTransaction { get; set; }
public:
property bool CapTransaction {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapTransaction ()

/** @property */
public void set_CapTransaction (boolean value)

public function get CapTransaction () : boolean

public function set CapTransaction (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CapTransaction Property


PrinterProperties.CartridgeNotify Property

PrinterProperties.CartridgeNotify Property |
 | See Also

1/18/2008

Holds the type of cartridge state notification the application wants to receive.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CartridgeNotify As PrinterCartridgeNotify
public PrinterCartridgeNotify CartridgeNotify { get; set; }
public:
property PrinterCartridgeNotify CartridgeNotify {
    PrinterCartridgeNotify get ();
    void set (PrinterCartridgeNotify value);
}
/** @property */
public PrinterCartridgeNotify get_CartridgeNotify ()

/** @property */
public void set_CartridgeNotify (PrinterCartridgeNotify value)

public function get CartridgeNotify () : PrinterCartridgeNotify

public function set CartridgeNotify (value : PrinterCartridgeNotify)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CartridgeNotify Property


PrinterProperties.CharacterSet Property

PrinterProperties.CharacterSet Property |
 | See Also

1/18/2008

Holds a numeric value indicating the character set the application wants to use for printing characters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CharacterSet As Integer
public int CharacterSet { get; set; }
public:
property int CharacterSet {
    int get ();
    void set (int value);
}
/** @property */
public int get_CharacterSet ()

/** @property */
public void set_CharacterSet (int value)

public function get CharacterSet () : int

public function set CharacterSet (value : int)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CharacterSet Property


PrinterProperties.CharacterSetList Property

PrinterProperties.CharacterSetList Property |
 | See Also

1/18/2008

Holds a list of character set numbers supported for printing.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CharacterSetList As Integer()
public int[] CharacterSetList { get; set; }
public:
property array<int>^ CharacterSetList {
    array<int>^ get ();
    void set (array<int>^ value);
}
/** @property */
public int[] get_CharacterSetList ()

/** @property */
public void set_CharacterSetList (int[] value)

public function get CharacterSetList () : int[]

public function set CharacterSetList (value : int[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CharacterSetList Property


PrinterProperties.CoverOpen Property

PrinterProperties.CoverOpen Property |
 | See Also

1/18/2008

Indicates that the cover is open.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CoverOpen As Boolean
public bool CoverOpen { get; set; }
public:
property bool CoverOpen {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CoverOpen ()

/** @property */
public void set_CoverOpen (boolean value)

public function get CoverOpen () : boolean

public function set CoverOpen (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CoverOpen Property


PrinterProperties.ErrorLevel Property

PrinterProperties.ErrorLevel Property |
 | See Also

1/18/2008

Holds the severity of the most recent error condition.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property ErrorLevel As PrinterErrorLevel
public PrinterErrorLevel ErrorLevel { get; set; }
public:
property PrinterErrorLevel ErrorLevel {
    PrinterErrorLevel get ();
    void set (PrinterErrorLevel value);
}
/** @property */
public PrinterErrorLevel get_ErrorLevel ()

/** @property */
public void set_ErrorLevel (PrinterErrorLevel value)

public function get ErrorLevel () : PrinterErrorLevel

public function set ErrorLevel (value : PrinterErrorLevel)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.ErrorLevel Property


PrinterProperties.ErrorStation Property

PrinterProperties.ErrorStation Property |
 | See Also

1/18/2008

Holds the station or stations that were printing when an error was detected.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property ErrorStation As PrinterStation
public PrinterStation ErrorStation { get; set; }
public:
property PrinterStation ErrorStation {
    PrinterStation get ();
    void set (PrinterStation value);
}
/** @property */
public PrinterStation get_ErrorStation ()

/** @property */
public void set_ErrorStation (PrinterStation value)

public function get ErrorStation () : PrinterStation

public function set ErrorStation (value : PrinterStation)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.ErrorStation Property


PrinterProperties.ErrorString Property

PrinterProperties.ErrorString Property |
 | See Also

1/18/2008

Holds a vendor-supplied description of the current error.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property ErrorString As String
public string ErrorString { get; set; }
public:
property String^ ErrorString {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_ErrorString ()

/** @property */
public void set_ErrorString (String value)

public function get ErrorString () : String

public function set ErrorString (value : String)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.ErrorString Property


PrinterProperties.FlagWhenIdle Property

PrinterProperties.FlagWhenIdle Property |
 | See Also

1/18/2008

If set to true by the application, the service object will queue a StatusUpdateEvent event using the StatusIdle constant when the device is in an idle state, and reset FlagWhenIdle to false.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property FlagWhenIdle As Boolean
public bool FlagWhenIdle { get; set; }
public:
property bool FlagWhenIdle {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_FlagWhenIdle ()

/** @property */
public void set_FlagWhenIdle (boolean value)

public function get FlagWhenIdle () : boolean

public function set FlagWhenIdle (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.FlagWhenIdle Property


PrinterProperties.FontTypefaceList Property

PrinterProperties.FontTypefaceList Property |
 | See Also

1/18/2008

Holds a string array that specifies the fonts and/or typefaces supported by the printer.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property FontTypefaceList As String()
public string[] FontTypefaceList { get; set; }
public:
property array<String^>^ FontTypefaceList {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
/** @property */
public String[] get_FontTypefaceList ()

/** @property */
public void set_FontTypefaceList (String[] value)

public function get FontTypefaceList () : String[]

public function set FontTypefaceList (value : String[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.FontTypefaceList Property


PrinterProperties.JrnCartridgeState Property

PrinterProperties.JrnCartridgeState Property |
 | See Also

1/18/2008

Holds the status of the selected journal cartridge (ink, ribbon, or toner).

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property JrnCartridgeState As PrinterCartridgeStates
public PrinterCartridgeStates JrnCartridgeState { get; set; }
public:
property PrinterCartridgeStates JrnCartridgeState {
    PrinterCartridgeStates get ();
    void set (PrinterCartridgeStates value);
}
/** @property */
public PrinterCartridgeStates get_JrnCartridgeState ()

/** @property */
public void set_JrnCartridgeState (PrinterCartridgeStates value)

public function get JrnCartridgeState () : PrinterCartridgeStates

public function set JrnCartridgeState (value : PrinterCartridgeStates)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.JrnCartridgeState Property


PrinterProperties.JrnCoverOpen Property

PrinterProperties.JrnCoverOpen Property |
 | See Also

1/18/2008

Notifies the application that the cover has been opened.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property JrnCoverOpen As Boolean
public bool JrnCoverOpen { get; set; }
public:
property bool JrnCoverOpen {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_JrnCoverOpen ()

/** @property */
public void set_JrnCoverOpen (boolean value)

public function get JrnCoverOpen () : boolean

public function set JrnCoverOpen (value : boolean)

Remarks

If the printer device supports individual cover sensors, the service object has the option of using the JrnCoverOpen, RecCoverOpen, and SlpCoverOpen properties, rather than the more generic CoverOpen property, to notify the application that a cover has been opened. If JrnCoverOpen is changed to TRUE, PosPrinterProperties queues a StatusUpdateEvent event to the application with a status of StatusJournalCoverOpen and increments the StatisticJournalCoverOpenCount statistic. If JrnCoverOpen is changed to FALSE, PosPrinterProperties queues a StatusUpdateEvent event with a status of StatusJournalCoverOK. If JrnCoverOpen is changed to FALSE when the CapCoverSensor is set to FALSE, PosPrinterProperties class thows a PosControlException with ErrorCode set to ErrorCode.Illegal.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CoverOpen Property


PrinterProperties.JrnCurrentCartridge Property

PrinterProperties.JrnCurrentCartridge Property |
 | See Also

1/18/2008

Holds the currently selected journal cartridge.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property JrnCurrentCartridge As PrinterColors
public PrinterColors JrnCurrentCartridge { get; set; }
public:
property PrinterColors JrnCurrentCartridge {
    PrinterColors get ();
    void set (PrinterColors value);
}
/** @property */
public PrinterColors get_JrnCurrentCartridge ()

/** @property */
public void set_JrnCurrentCartridge (PrinterColors value)

public function get JrnCurrentCartridge () : PrinterColors

public function set JrnCurrentCartridge (value : PrinterColors)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.JrnCurrentCartridge Property


PrinterProperties.JrnEmpty Property

PrinterProperties.JrnEmpty Property |
 | See Also

1/18/2008

If set to true, the journal is out of paper.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property JrnEmpty As Boolean
public bool JrnEmpty { get; set; }
public:
property bool JrnEmpty {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_JrnEmpty ()

/** @property */
public void set_JrnEmpty (boolean value)

public function get JrnEmpty () : boolean

public function set JrnEmpty (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.JrnEmpty Property


PrinterProperties.JrnLetterQuality Property

PrinterProperties.JrnLetterQuality Property |
 | See Also

1/18/2008

If true, prints in high-quality mode. If false, prints in high-speed mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property JrnLetterQuality As Boolean
public bool JrnLetterQuality { get; set; }
public:
property bool JrnLetterQuality {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_JrnLetterQuality ()

/** @property */
public void set_JrnLetterQuality (boolean value)

public function get JrnLetterQuality () : boolean

public function set JrnLetterQuality (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.JrnLetterQuality Property


PrinterProperties.JrnLineChars Property

PrinterProperties.JrnLineChars Property |
 | See Also

1/18/2008

Holds the number of characters that the application wants to print on a journal line.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property JrnLineChars As Integer
public int JrnLineChars { get; set; }
public:
property int JrnLineChars {
    int get ();
    void set (int value);
}
/** @property */
public int get_JrnLineChars ()

/** @property */
public void set_JrnLineChars (int value)

public function get JrnLineChars () : int

public function set JrnLineChars (value : int)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.JrnLineChars Property


PrinterProperties.JrnLineCharsList Property

PrinterProperties.JrnLineCharsList Property |
 | See Also

1/18/2008

Holds a collection of the line widths (characters per line) supported by the journal station.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property JrnLineCharsList As Integer()
public int[] JrnLineCharsList { get; set; }
public:
property array<int>^ JrnLineCharsList {
    array<int>^ get ();
    void set (array<int>^ value);
}
/** @property */
public int[] get_JrnLineCharsList ()

/** @property */
public void set_JrnLineCharsList (int[] value)

public function get JrnLineCharsList () : int[]

public function set JrnLineCharsList (value : int[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.JrnLineCharsList Property


PrinterProperties.JrnLineHeight Property

PrinterProperties.JrnLineHeight Property |
 | See Also

1/18/2008

Holds the journal print line height the application wants to use, expressed in the unit of measure indicated by the MapMode property setting.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property JrnLineHeight As Integer
public int JrnLineHeight { get; set; }
public:
property int JrnLineHeight {
    int get ();
    void set (int value);
}
/** @property */
public int get_JrnLineHeight ()

/** @property */
public void set_JrnLineHeight (int value)

public function get JrnLineHeight () : int

public function set JrnLineHeight (value : int)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.JrnLineHeight Property


PrinterProperties.JrnLineSpacing Property

PrinterProperties.JrnLineSpacing Property |
 | See Also

1/18/2008

Holds the spacing of each single-high print line, including both the printed line height and the white space between each pair of lines that the application wants to use.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property JrnLineSpacing As Integer
public int JrnLineSpacing { get; set; }
public:
property int JrnLineSpacing {
    int get ();
    void set (int value);
}
/** @property */
public int get_JrnLineSpacing ()

/** @property */
public void set_JrnLineSpacing (int value)

public function get JrnLineSpacing () : int

public function set JrnLineSpacing (value : int)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.JrnLineSpacing Property


PrinterProperties.JrnLineWidth Property

PrinterProperties.JrnLineWidth Property |
 | See Also

1/18/2008

Holds the width of a line for the number of characters indicated by the JrnLineChars property, expressed in the unit of measure indicated by the MapMode property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property JrnLineWidth As Integer
public int JrnLineWidth { get; set; }
public:
property int JrnLineWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_JrnLineWidth ()

/** @property */
public void set_JrnLineWidth (int value)

public function get JrnLineWidth () : int

public function set JrnLineWidth (value : int)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.JrnLineWidth Property


PrinterProperties.JrnNearEnd Property

PrinterProperties.JrnNearEnd Property |
 | See Also

1/18/2008

If true, the journal paper is low.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property JrnNearEnd As Boolean
public bool JrnNearEnd { get; set; }
public:
property bool JrnNearEnd {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_JrnNearEnd ()

/** @property */
public void set_JrnNearEnd (boolean value)

public function get JrnNearEnd () : boolean

public function set JrnNearEnd (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.JrnNearEnd Property


PrinterProperties.MapCharacterSet Property

PrinterProperties.MapCharacterSet Property |
 | See Also

1/18/2008

If set to true by the application while outputting data, the service object maps the characters transferred by the application to the character set selected in the CharacterSet property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property MapCharacterSet As Boolean
public bool MapCharacterSet { get; set; }
public:
property bool MapCharacterSet {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_MapCharacterSet ()

/** @property */
public void set_MapCharacterSet (boolean value)

public function get MapCharacterSet () : boolean

public function set MapCharacterSet (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.MapCharacterSet Property


PrinterProperties.MapMode Property

PrinterProperties.MapMode Property |
 | See Also

1/18/2008

Holds the mapping mode of the printer the application wants to use.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property MapMode As MapMode
public MapMode MapMode { get; set; }
public:
property MapMode MapMode {
    MapMode get ();
    void set (MapMode value);
}
/** @property */
public MapMode get_MapMode ()

/** @property */
public void set_MapMode (MapMode value)

public function get MapMode () : MapMode

public function set MapMode (value : MapMode)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.MapMode Property


PrinterProperties.PageModeArea Property

PrinterProperties.PageModeArea Property |
 | See Also

1/18/2008

Holds the page area for the selected PageModeStation expressed in the unit of measure given by MapMode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property PageModeArea As Point
public Point PageModeArea { get; set; }
public:
property Point PageModeArea {
    Point get ();
    void set (Point value);
}
/** @property */
public Point get_PageModeArea ()

/** @property */
public void set_PageModeArea (Point value)

public function get PageModeArea () : Point

public function set PageModeArea (value : Point)

Remarks

This page area can be different than the print area and is determined by the hardware capability of the printer. The string consists of two ASCII numbers separated by a comma, in the following order: horizontal size, vertical size.

For example, if the string is “450,800”, then the page size is 450 horizontal units by 800 vertical units, and the station print area is a rectangle beginning at the top left point (0,0), and continuing up to but not including the bottom right point (450,800).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrinterProperties.PageModeDescriptor Property

PrinterProperties.PageModeDescriptor Property |
 | See Also

1/18/2008

Indicates the basic Page Mode functionality of the printer for the selected PageModeStation.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property PageModeDescriptor As PageModeDescriptors
public PageModeDescriptors PageModeDescriptor { get; set; }
public:
property PageModeDescriptors PageModeDescriptor {
    PageModeDescriptors get ();
    void set (PageModeDescriptors value);
}
/** @property */
public PageModeDescriptors get_PageModeDescriptor ()

/** @property */
public void set_PageModeDescriptor (PageModeDescriptors value)

public function get PageModeDescriptor () : PageModeDescriptors

public function set PageModeDescriptor (value : PageModeDescriptors)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrinterProperties.PageModeHorizontalPosition Property

PrinterProperties.PageModeHorizontalPosition Property |
 | See Also

1/18/2008

Holds the horizontal start position offset within the print area for the selected PageModeStation, expressed in the unit of measure given by MapMode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property PageModeHorizontalPosition As Integer
public int PageModeHorizontalPosition { get; set; }
public:
property int PageModeHorizontalPosition {
    int get ();
    void set (int value);
}
/** @property */
public int get_PageModeHorizontalPosition ()

/** @property */
public void set_PageModeHorizontalPosition (int value)

public function get PageModeHorizontalPosition () : int

public function set PageModeHorizontalPosition (value : int)

Remarks

Holds the horizontal start position offset within the print area for the selected PageModeStation, expressed in the unit of measure given by MapMode. The horizontal direction is the same as the actual PageModePrintDirection property. If the exact position cannot be supported then the position is set to the closest supported value.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrinterProperties.PageModePrintArea Property

PrinterProperties.PageModePrintArea Property |
 | See Also

1/18/2008

Holds the print area for the selected PageModeStation expressed in the unit of measure given by MapMode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property PageModePrintArea As Rectangle
public Rectangle PageModePrintArea { get; set; }
public:
property Rectangle PageModePrintArea {
    Rectangle get ();
    void set (Rectangle value);
}
/** @property */
public Rectangle get_PageModePrintArea ()

/** @property */
public void set_PageModePrintArea (Rectangle value)

public function get PageModePrintArea () : Rectangle

public function set PageModePrintArea (value : Rectangle)

Remarks

Holds the print area for the selected PageModeStation expressed in the unit of measure given by MapMode. The maximum print area is the page area.

Text written to the right edge of the print area will wrap to the next line. Any text or image written beyond the bottom of the print area will be truncated.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrinterProperties.PageModePrintDirection Property

PrinterProperties.PageModePrintDirection Property |
 | See Also

1/18/2008

Holds the print direction.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property PageModePrintDirection As PageModePrintDirection
public PageModePrintDirection PageModePrintDirection { get; set; }
public:
property PageModePrintDirection PageModePrintDirection {
    PageModePrintDirection get ();
    void set (PageModePrintDirection value);
}
/** @property */
public PageModePrintDirection get_PageModePrintDirection ()

/** @property */
public void set_PageModePrintDirection (PageModePrintDirection value)

public function get PageModePrintDirection () : PageModePrintDirection

public function set PageModePrintDirection (value : PageModePrintDirection)

Remarks

This property holds the print direction. Valid values, as defined in the PageModePrintDirection enumeration, are listed below:

Value | Meaning
BottomToTop | Print bottom to top, starting at the bottom left position of the print area (that is, rotated left 90° printing).
LeftToRight | Print left to right, starting at top left position of the print area (that is, normal printing).
None | No valid station is selected.
RightToLeft | Print right to left, starting at the bottom right position of the print area (that is, upside down printing).
TopToBottom | Print top to bottom, starting at the top right position of the print area (that is, rotated right 90° printing.)

This property is initialized to LeftToRight when the device is first enabled following the open method.

Setting this property may also change PageModeHorizontalPosition and

PageModeVerticalPosition. Setting this property will have an effect on the current print area. By changing the print area, it is possible to generate a receipt or slip with text printed in multiple rotations.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrinterProperties.PageModeStation Property

PrinterProperties.PageModeStation Property |
 | See Also

1/18/2008

Gets and sets the print station for use by other Page Mode properties

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property PageModeStation As PrinterStation
public PrinterStation PageModeStation { get; set; }
public:
property PrinterStation PageModeStation {
    PrinterStation get ();
    void set (PrinterStation value);
}
/** @property */
public PrinterStation get_PageModeStation ()

/** @property */
public void set_PageModeStation (PrinterStation value)

public function get PageModeStation () : PrinterStation

public function set PageModeStation (value : PrinterStation)

Remarks

This property gets and sets the print station for subsequent Page Mode properties. Note that PageModePrint will allow for the selection of the print station that the output will be generated on. This value will only contain one Page Mode station at a time, receipt or slip.

If Page Mode is not supported on any station, the value should be zero. To control Page Mode for more than one station, this value will need to be changed between the stations.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrinterProperties.PageModeVerticalPosition Property

PrinterProperties.PageModeVerticalPosition Property |
 | See Also

1/18/2008

Holds the vertical start position offset within the print area for the selected PageModeStation.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property PageModeVerticalPosition As Integer
public int PageModeVerticalPosition { get; set; }
public:
property int PageModeVerticalPosition {
    int get ();
    void set (int value);
}
/** @property */
public int get_PageModeVerticalPosition ()

/** @property */
public void set_PageModeVerticalPosition (int value)

public function get PageModeVerticalPosition () : int

public function set PageModeVerticalPosition (value : int)

Remarks

Holds the vertical start position offset within the print area for the selected PageModeStation, expressed in the unit of measure given by MapMode. The vertical direction is perpendicular to the direction specified in the actual PageModePrintDirection property. If the exact position cannot be supported then the position is set to the closest supported value. A read/get on this property will return the vertical position offset set by the last write/set and not the current position.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrinterProperties.RecBarCodeRotationList Property

PrinterProperties.RecBarCodeRotationList Property |
 | See Also

1/18/2008

Holds a list of the directions in which a receipt bar code can be rotated.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property RecBarCodeRotationList As Rotation()
public Rotation[] RecBarCodeRotationList { get; set; }
public:
property array<Rotation>^ RecBarCodeRotationList {
    array<Rotation>^ get ();
    void set (array<Rotation>^ value);
}
/** @property */
public Rotation[] get_RecBarCodeRotationList ()

/** @property */
public void set_RecBarCodeRotationList (Rotation[] value)

public function get RecBarCodeRotationList () : Rotation[]

public function set RecBarCodeRotationList (value : Rotation[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.RecBarCodeRotationList Property


PrinterProperties.RecBitmapRotationList Property

PrinterProperties.RecBitmapRotationList Property |
 | See Also

1/18/2008

Holds a list of the directions in which a receipt bitmap can be rotated.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property RecBitmapRotationList As Rotation()
public Rotation[] RecBitmapRotationList { get; set; }
public:
property array<Rotation>^ RecBitmapRotationList {
    array<Rotation>^ get ();
    void set (array<Rotation>^ value);
}
/** @property */
public Rotation[] get_RecBitmapRotationList ()

/** @property */
public void set_RecBitmapRotationList (Rotation[] value)

public function get RecBitmapRotationList () : Rotation[]

public function set RecBitmapRotationList (value : Rotation[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.RecBitmapRotationList Property


PrinterProperties.RecCartridgeState Property

PrinterProperties.RecCartridgeState Property |
 | See Also

1/18/2008

Holds the status of the selected receipt cartridge (ink, ribbon or toner).

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property RecCartridgeState As PrinterCartridgeStates
public PrinterCartridgeStates RecCartridgeState { get; set; }
public:
property PrinterCartridgeStates RecCartridgeState {
    PrinterCartridgeStates get ();
    void set (PrinterCartridgeStates value);
}
/** @property */
public PrinterCartridgeStates get_RecCartridgeState ()

/** @property */
public void set_RecCartridgeState (PrinterCartridgeStates value)

public function get RecCartridgeState () : PrinterCartridgeStates

public function set RecCartridgeState (value : PrinterCartridgeStates)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.RecCartridgeState Property


PrinterProperties.RecCoverOpen Property

PrinterProperties.RecCoverOpen Property |
 | See Also

1/18/2008

Indicates that a cover has been opened.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property RecCoverOpen As Boolean
public bool RecCoverOpen { get; set; }
public:
property bool RecCoverOpen {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_RecCoverOpen ()

/** @property */
public void set_RecCoverOpen (boolean value)

public function get RecCoverOpen () : boolean

public function set RecCoverOpen (value : boolean)

Remarks

If the printer device supports individual cover sensors, the service object has the option of using the JrnCoverOpen, RecCoverOpen, and SlpCoverOpen properties, rather than the more generic CoverOpen property, to notify the application that a cover has been opened. If RecCoverOpen is changed to TRUE, PosPrinterProperties queues a StatusUpdateEvent event to the application with a status of StatusJournalCoverOpen and increments the StatisticJournalCoverOpenCount statistic. If RecCoverOpen is changed to FALSE, PosPrinterProperties queues a StatusUpdateEvent event with a status of StatusJournalCoverOK. If RecCoverOpen is changed to FALSE when CapCoverSensor is set to FALSE, PosPrinterProperties class thows a PosControlException with ErrorCode set to ErrorCode.Illegal.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CoverOpen Property


PrinterProperties.RecCurrentCartridge Property

PrinterProperties.RecCurrentCartridge Property |
 | See Also

1/18/2008

Holds the receipt cartridge currently selected by the application.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property RecCurrentCartridge As PrinterColors
public PrinterColors RecCurrentCartridge { get; set; }
public:
property PrinterColors RecCurrentCartridge {
    PrinterColors get ();
    void set (PrinterColors value);
}
/** @property */
public PrinterColors get_RecCurrentCartridge ()

/** @property */
public void set_RecCurrentCartridge (PrinterColors value)

public function get RecCurrentCartridge () : PrinterColors

public function set RecCurrentCartridge (value : PrinterColors)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.RecCurrentCartridge Property


PrinterProperties.RecEmpty Property

PrinterProperties.RecEmpty Property |
 | See Also

1/18/2008

If true, the receipt is out of paper.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property RecEmpty As Boolean
public bool RecEmpty { get; set; }
public:
property bool RecEmpty {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_RecEmpty ()

/** @property */
public void set_RecEmpty (boolean value)

public function get RecEmpty () : boolean

public function set RecEmpty (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.RecEmpty Property


PrinterProperties.RecLetterQuality Property

PrinterProperties.RecLetterQuality Property |
 | See Also

1/18/2008

If true, prints in high-quality mode. If false, prints in high-speed mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property RecLetterQuality As Boolean
public bool RecLetterQuality { get; set; }
public:
property bool RecLetterQuality {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_RecLetterQuality ()

/** @property */
public void set_RecLetterQuality (boolean value)

public function get RecLetterQuality () : boolean

public function set RecLetterQuality (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.RecLetterQuality Property


PrinterProperties.RecLineChars Property

PrinterProperties.RecLineChars Property |
 | See Also

1/18/2008

Holds the number of characters that the application wants to print on a receipt line.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property RecLineChars As Integer
public int RecLineChars { get; set; }
public:
property int RecLineChars {
    int get ();
    void set (int value);
}
/** @property */
public int get_RecLineChars ()

/** @property */
public void set_RecLineChars (int value)

public function get RecLineChars () : int

public function set RecLineChars (value : int)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.RecLineChars Property


PrinterProperties.RecLineCharsList Property

PrinterProperties.RecLineCharsList Property |
 | See Also

1/18/2008

Holds a collection of the line widths (characters per line) supported by the receipt station.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property RecLineCharsList As Integer()
public int[] RecLineCharsList { get; set; }
public:
property array<int>^ RecLineCharsList {
    array<int>^ get ();
    void set (array<int>^ value);
}
/** @property */
public int[] get_RecLineCharsList ()

/** @property */
public void set_RecLineCharsList (int[] value)

public function get RecLineCharsList () : int[]

public function set RecLineCharsList (value : int[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.RecLineCharsList Property


PrinterProperties.RecLineHeight Property

PrinterProperties.RecLineHeight Property |
 | See Also

1/18/2008

Holds the receipt print line height, expressed in the unit of measure indicated by the MapMode property setting, that the application wants to use.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property RecLineHeight As Integer
public int RecLineHeight { get; set; }
public:
property int RecLineHeight {
    int get ();
    void set (int value);
}
/** @property */
public int get_RecLineHeight ()

/** @property */
public void set_RecLineHeight (int value)

public function get RecLineHeight () : int

public function set RecLineHeight (value : int)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.RecLineHeight Property


PrinterProperties.RecLineSpacing Property

PrinterProperties.RecLineSpacing Property |
 | See Also

1/18/2008

Holds the spacing of each single-high print line, including both the printed line height and the white space between each pair of lines, that the application wants to use.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property RecLineSpacing As Integer
public int RecLineSpacing { get; set; }
public:
property int RecLineSpacing {
    int get ();
    void set (int value);
}
/** @property */
public int get_RecLineSpacing ()

/** @property */
public void set_RecLineSpacing (int value)

public function get RecLineSpacing () : int

public function set RecLineSpacing (value : int)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.RecLineSpacing Property


PrinterProperties.RecLinesToPaperCut Property

PrinterProperties.RecLinesToPaperCut Property |
 | See Also

1/18/2008

Holds the number of lines that must be advanced before cutting the receipt paper.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property RecLinesToPaperCut As Integer
public int RecLinesToPaperCut { get; set; }
public:
property int RecLinesToPaperCut {
    int get ();
    void set (int value);
}
/** @property */
public int get_RecLinesToPaperCut ()

/** @property */
public void set_RecLinesToPaperCut (int value)

public function get RecLinesToPaperCut () : int

public function set RecLinesToPaperCut (value : int)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.RecLinesToPaperCut Property


PrinterProperties.RecLineWidth Property

PrinterProperties.RecLineWidth Property |
 | See Also

1/18/2008

Holds the width of a line, based on the number of characters specified in the RecLineChars property, expressed in the unit of measure indicated by the MapMode property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property RecLineWidth As Integer
public int RecLineWidth { get; set; }
public:
property int RecLineWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_RecLineWidth ()

/** @property */
public void set_RecLineWidth (int value)

public function get RecLineWidth () : int

public function set RecLineWidth (value : int)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.RecLineWidth Property


PrinterProperties.RecNearEnd Property

PrinterProperties.RecNearEnd Property |
 | See Also

1/18/2008

If true, the receipt paper is low.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property RecNearEnd As Boolean
public bool RecNearEnd { get; set; }
public:
property bool RecNearEnd {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_RecNearEnd ()

/** @property */
public void set_RecNearEnd (boolean value)

public function get RecNearEnd () : boolean

public function set RecNearEnd (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.RecNearEnd Property


PrinterProperties.RecSidewaysMaxChars Property

PrinterProperties.RecSidewaysMaxChars Property |
 | See Also

1/18/2008

Holds the maximum number of characters that can be printed on each line in sideways mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property RecSidewaysMaxChars As Integer
public int RecSidewaysMaxChars { get; set; }
public:
property int RecSidewaysMaxChars {
    int get ();
    void set (int value);
}
/** @property */
public int get_RecSidewaysMaxChars ()

/** @property */
public void set_RecSidewaysMaxChars (int value)

public function get RecSidewaysMaxChars () : int

public function set RecSidewaysMaxChars (value : int)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.RecSidewaysMaxChars Property


PrinterProperties.RecSidewaysMaxLines Property

PrinterProperties.RecSidewaysMaxLines Property |
 | See Also

1/18/2008

Holds the maximum number of lines that can be printed in sideways mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property RecSidewaysMaxLines As Integer
public int RecSidewaysMaxLines { get; set; }
public:
property int RecSidewaysMaxLines {
    int get ();
    void set (int value);
}
/** @property */
public int get_RecSidewaysMaxLines ()

/** @property */
public void set_RecSidewaysMaxLines (int value)

public function get RecSidewaysMaxLines () : int

public function set RecSidewaysMaxLines (value : int)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
RedSidewaysMaxLines


PrinterProperties.RotateSpecial Property

PrinterProperties.RotateSpecial Property |
 | See Also

1/18/2008

Holds the rotation orientation for bar codes that the application wants to use.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property RotateSpecial As Rotation
public Rotation RotateSpecial { get; set; }
public:
property Rotation RotateSpecial {
    Rotation get ();
    void set (Rotation value);
}
/** @property */
public Rotation get_RotateSpecial ()

/** @property */
public void set_RotateSpecial (Rotation value)

public function get RotateSpecial () : Rotation

public function set RotateSpecial (value : Rotation)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.RotateSpecial Property


PrinterProperties.SlpBarCodeRotationList Property

PrinterProperties.SlpBarCodeRotationList Property |
 | See Also

1/18/2008

Holds a collection of the directions in which a slip bar code may be rotated.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property SlpBarCodeRotationList As Rotation()
public Rotation[] SlpBarCodeRotationList { get; set; }
public:
property array<Rotation>^ SlpBarCodeRotationList {
    array<Rotation>^ get ();
    void set (array<Rotation>^ value);
}
/** @property */
public Rotation[] get_SlpBarCodeRotationList ()

/** @property */
public void set_SlpBarCodeRotationList (Rotation[] value)

public function get SlpBarCodeRotationList () : Rotation[]

public function set SlpBarCodeRotationList (value : Rotation[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.SlpBarCodeRotationList Property


PrinterProperties.SlpBitmapRotationList Property

PrinterProperties.SlpBitmapRotationList Property |
 | See Also

1/18/2008

Holds a collection of the directions in which a slip bitmap can be rotated.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property SlpBitmapRotationList As Rotation()
public Rotation[] SlpBitmapRotationList { get; set; }
public:
property array<Rotation>^ SlpBitmapRotationList {
    array<Rotation>^ get ();
    void set (array<Rotation>^ value);
}
/** @property */
public Rotation[] get_SlpBitmapRotationList ()

/** @property */
public void set_SlpBitmapRotationList (Rotation[] value)

public function get SlpBitmapRotationList () : Rotation[]

public function set SlpBitmapRotationList (value : Rotation[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.SlpBitmapRotationList Property


PrinterProperties.SlpCartridgeState Property

PrinterProperties.SlpCartridgeState Property |
 | See Also

1/18/2008

Holds the status of the selected slip cartridge (ink, ribbon, or toner).

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property SlpCartridgeState As PrinterCartridgeStates
public PrinterCartridgeStates SlpCartridgeState { get; set; }
public:
property PrinterCartridgeStates SlpCartridgeState {
    PrinterCartridgeStates get ();
    void set (PrinterCartridgeStates value);
}
/** @property */
public PrinterCartridgeStates get_SlpCartridgeState ()

/** @property */
public void set_SlpCartridgeState (PrinterCartridgeStates value)

public function get SlpCartridgeState () : PrinterCartridgeStates

public function set SlpCartridgeState (value : PrinterCartridgeStates)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.SlpCartridgeState Property


PrinterProperties.SlpCoverOpen Property

PrinterProperties.SlpCoverOpen Property |
 | See Also

1/18/2008

Indicates that a cover has been opened.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property SlpCoverOpen As Boolean
public bool SlpCoverOpen { get; set; }
public:
property bool SlpCoverOpen {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_SlpCoverOpen ()

/** @property */
public void set_SlpCoverOpen (boolean value)

public function get SlpCoverOpen () : boolean

public function set SlpCoverOpen (value : boolean)

Remarks

If the printer device supports individual cover sensors, the service object has the option of using the JrnCoverOpen, RecCoverOpen, and SlpCoverOpen properties, rather than the more generic CoverOpen property, to notify the application that a cover has been opened. If SlpCoverOpen is changed to true, PosPrinterProperties queues a StatusUpdateEvent event to the application with a status of StatusJournalCoverOpen and increments the StatisticJournalCoverOpenCount statistic. If SlpCoverOpen is changed to false, PosPrinterProperties queues a StatusUpdateEvent event with a status of StatusJournalCoverOK. If SlpCoverOpen is changed to false when CapCoverSensor is set to false, PosPrinterProperties class throws a PosControlException with ErrorCode set to ErrorCode.Illegal.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.CoverOpen Property


PrinterProperties.SlpCurrentCartridge Property

PrinterProperties.SlpCurrentCartridge Property |
 | See Also

1/18/2008

Holds the slip cartridge the application wants to use.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property SlpCurrentCartridge As PrinterColors
public PrinterColors SlpCurrentCartridge { get; set; }
public:
property PrinterColors SlpCurrentCartridge {
    PrinterColors get ();
    void set (PrinterColors value);
}
/** @property */
public PrinterColors get_SlpCurrentCartridge ()

/** @property */
public void set_SlpCurrentCartridge (PrinterColors value)

public function get SlpCurrentCartridge () : PrinterColors

public function set SlpCurrentCartridge (value : PrinterColors)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.SlpCurrentCartridge Property


PrinterProperties.SlpEmpty Property

PrinterProperties.SlpEmpty Property |
 | See Also

1/18/2008

If true, a slip form is not present.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property SlpEmpty As Boolean
public bool SlpEmpty { get; set; }
public:
property bool SlpEmpty {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_SlpEmpty ()

/** @property */
public void set_SlpEmpty (boolean value)

public function get SlpEmpty () : boolean

public function set SlpEmpty (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.SlpEmpty Property


PrinterProperties.SlpLetterQuality Property

PrinterProperties.SlpLetterQuality Property |
 | See Also

1/18/2008

If true, prints in high-quality mode. If false, prints in high-speed mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property SlpLetterQuality As Boolean
public bool SlpLetterQuality { get; set; }
public:
property bool SlpLetterQuality {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_SlpLetterQuality ()

/** @property */
public void set_SlpLetterQuality (boolean value)

public function get SlpLetterQuality () : boolean

public function set SlpLetterQuality (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.SlpLetterQuality Property


PrinterProperties.SlpLineChars Property

PrinterProperties.SlpLineChars Property |
 | See Also

1/18/2008

Holds the number of characters that the application wants to print on a slip line.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property SlpLineChars As Integer
public int SlpLineChars { get; set; }
public:
property int SlpLineChars {
    int get ();
    void set (int value);
}
/** @property */
public int get_SlpLineChars ()

/** @property */
public void set_SlpLineChars (int value)

public function get SlpLineChars () : int

public function set SlpLineChars (value : int)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.SlpLineChars Property


PrinterProperties.SlpLineCharsList Property

PrinterProperties.SlpLineCharsList Property |
 | See Also

1/18/2008

Holds a collection of the line widths (characters per line) supported by the slip station.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property SlpLineCharsList As Integer()
public int[] SlpLineCharsList { get; set; }
public:
property array<int>^ SlpLineCharsList {
    array<int>^ get ();
    void set (array<int>^ value);
}
/** @property */
public int[] get_SlpLineCharsList ()

/** @property */
public void set_SlpLineCharsList (int[] value)

public function get SlpLineCharsList () : int[]

public function set SlpLineCharsList (value : int[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.SlpLineCharsList Property


PrinterProperties.SlpLineHeight Property

PrinterProperties.SlpLineHeight Property |
 | See Also

1/18/2008

Holds the slip print-line height, expressed in the unit of measure indicated by the MapMode property setting, that the application wants to use.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property SlpLineHeight As Integer
public int SlpLineHeight { get; set; }
public:
property int SlpLineHeight {
    int get ();
    void set (int value);
}
/** @property */
public int get_SlpLineHeight ()

/** @property */
public void set_SlpLineHeight (int value)

public function get SlpLineHeight () : int

public function set SlpLineHeight (value : int)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.SlpLineHeight Property


PrinterProperties.SlpLinesNearEndToEnd Property

PrinterProperties.SlpLinesNearEndToEnd Property |
 | See Also

1/18/2008

Holds the number of lines that can be printed after the SlpNearEnd property has been set to true but before the printer reaches the end of the slip.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property SlpLinesNearEndToEnd As Integer
public int SlpLinesNearEndToEnd { get; set; }
public:
property int SlpLinesNearEndToEnd {
    int get ();
    void set (int value);
}
/** @property */
public int get_SlpLinesNearEndToEnd ()

/** @property */
public void set_SlpLinesNearEndToEnd (int value)

public function get SlpLinesNearEndToEnd () : int

public function set SlpLinesNearEndToEnd (value : int)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.SlpLinesNearEndToEnd Property


PrinterProperties.SlpLineSpacing Property

PrinterProperties.SlpLineSpacing Property |
 | See Also

1/18/2008

Holds the spacing of each single-high print line, including both the printed line height and the white space between each pair of lines that the application wants to use.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property SlpLineSpacing As Integer
public int SlpLineSpacing { get; set; }
public:
property int SlpLineSpacing {
    int get ();
    void set (int value);
}
/** @property */
public int get_SlpLineSpacing ()

/** @property */
public void set_SlpLineSpacing (int value)

public function get SlpLineSpacing () : int

public function set SlpLineSpacing (value : int)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.SlpLineSpacing Property


PrinterProperties.SlpLineWidth Property

PrinterProperties.SlpLineWidth Property |
 | See Also

1/18/2008

Holds the line width, based on the number of characters specified for the SlpLineChars property, expressed in the unit of measure indicated by the MapMode property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property SlpLineWidth As Integer
public int SlpLineWidth { get; set; }
public:
property int SlpLineWidth {
    int get ();
    void set (int value);
}
/** @property */
public int get_SlpLineWidth ()

/** @property */
public void set_SlpLineWidth (int value)

public function get SlpLineWidth () : int

public function set SlpLineWidth (value : int)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.SlpLineWidth Property


PrinterProperties.SlpMaxLines Property

PrinterProperties.SlpMaxLines Property |
 | See Also

1/18/2008

Holds the maximum number of lines that can be printed on a form.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property SlpMaxLines As Integer
public int SlpMaxLines { get; set; }
public:
property int SlpMaxLines {
    int get ();
    void set (int value);
}
/** @property */
public int get_SlpMaxLines ()

/** @property */
public void set_SlpMaxLines (int value)

public function get SlpMaxLines () : int

public function set SlpMaxLines (value : int)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.SlpMaxLines Property


PrinterProperties.SlpNearEnd Property

PrinterProperties.SlpNearEnd Property |
 | See Also

1/18/2008

If true, the slip form is near its end.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property SlpNearEnd As Boolean
public bool SlpNearEnd { get; set; }
public:
property bool SlpNearEnd {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_SlpNearEnd ()

/** @property */
public void set_SlpNearEnd (boolean value)

public function get SlpNearEnd () : boolean

public function set SlpNearEnd (value : boolean)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.SlpNearEnd Property


PrinterProperties.SlpPrintSide Property

PrinterProperties.SlpPrintSide Property |
 | See Also

1/18/2008

Holds the side of the slip print station document on which printing will occur.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property SlpPrintSide As PrinterSide
public PrinterSide SlpPrintSide { get; set; }
public:
property PrinterSide SlpPrintSide {
    PrinterSide get ();
    void set (PrinterSide value);
}
/** @property */
public PrinterSide get_SlpPrintSide ()

/** @property */
public void set_SlpPrintSide (PrinterSide value)

public function get SlpPrintSide () : PrinterSide

public function set SlpPrintSide (value : PrinterSide)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.SlpPrintSide Property


PrinterProperties.SlpSidewaysMaxChars Property

PrinterProperties.SlpSidewaysMaxChars Property |
 | See Also

1/18/2008

Holds the maximum number of characters that can be printed on each line in sideways mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property SlpSidewaysMaxChars As Integer
public int SlpSidewaysMaxChars { get; set; }
public:
property int SlpSidewaysMaxChars {
    int get ();
    void set (int value);
}
/** @property */
public int get_SlpSidewaysMaxChars ()

/** @property */
public void set_SlpSidewaysMaxChars (int value)

public function get SlpSidewaysMaxChars () : int

public function set SlpSidewaysMaxChars (value : int)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.SlpSidewaysMaxChars Property


PrinterProperties.SlpSidewaysMaxLines Property

PrinterProperties.SlpSidewaysMaxLines Property |
 | See Also

1/18/2008

Holds the maximum number of lines that can be printed in sideways mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property SlpSidewaysMaxLines As Integer
public int SlpSidewaysMaxLines { get; set; }
public:
property int SlpSidewaysMaxLines {
    int get ();
    void set (int value);
}
/** @property */
public int get_SlpSidewaysMaxLines ()

/** @property */
public void set_SlpSidewaysMaxLines (int value)

public function get SlpSidewaysMaxLines () : int

public function set SlpSidewaysMaxLines (value : int)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.SlpSidewaysMaxLines Property


PrinterProperties.TopLogo Property

PrinterProperties.TopLogo Property |
 | See Also

1/18/2008

Holds a value indicating whether a logo should be printed during print operations.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property TopLogo As String
public string TopLogo { get; }
public:
property String^ TopLogo {
    String^ get ();
}
/** @property */
public String get_TopLogo ()

public function get TopLogo () : String

Remarks

Set by the PosPrinterBase class during the SetLogo method. The service object can query TopLogo to determine whether to print a logo during print operations. If TopLogo is null, an empty string ("") is returned.

TopLogo is initialized to an empty string ("") by the PosPrinterProperties class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterProperties Class
PrinterProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase.SetLogo Method


PrinterState Class

PrinterState Class |
 | See Also Members

1/18/2008

Contains property values holding information about the printer state.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class PrinterState
public class PrinterState
public ref class PrinterState
public class PrinterState
public class PrinterState

Remarks

Under certain conditions such as asynchronous printing or transaction printing, the physical print operation may take place some time after the application makes the method call to define the print operation. During this time delay, the application may alter the values of certain properties such as the character set, line spacing, etc. The PrinterState helper class is used to capture and store the group of property values set by the application for each specific print operation.

When the application sets printer property values and then calls a method such as PrintNormal, the PosPrinterBase class creates an instance of PrinterState and captures those property values (from the values currently stored in the PosPrinterProperties class). The instance of the PrinterState class is then stored in a collection along with other PrinterState and PrintOperation class instances, to be used by the service object when the actual printing occurs. The service object retrieves the print operation request, retrieves the corresponding PrinterState class instance containing the property values, and then completes the print request.

For definitions of the properties in the PrinterState class, refer to the PosPrinter class.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BaseServiceObjects.PrinterState

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterState Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrinterState Members

PrinterState Members |
 | See Also Methods Properties

1/18/2008

Contains property values holding information about the printer state.

The following tables list the members exposed by the PrinterState type.

Public Properties

Name | Description
BottomLogo | Determines whether to print a logo during print operations.
CharacterSet | Holds the default character set capability.
JrnCurrentCartridge | Holds the currently selected journal cartridge.
JrnLetterQuality | If true, prints in high-quality mode. If false, prints in high-speed mode.
JrnLineChars | Holds the number of characters that the application wants to print on a journal line.
JrnLineHeight | Holds the journal print line height the application wants to use, expressed in the unit of measure indicated by the MapMode property setting.
JrnLineSpacing | Holds the spacing of each single-high print line, including both the printed line height and the white space between each pair of lines that the application wants to use.
MapCharacterSet | If set to true by the application while outputting data, the service object maps the characters transferred by the application to the character set selected in the CharacterSet property.
MapMode | Holds the mapping mode of the printer the application wants to use.
PageModeHorizontalPosition | Holds the horizontal start position offset within the print area for the selected PageModeStation, expressed in the unit of measure given by MapMode.
PageModePrintArea | Holds the print area for the selected PageModeStation expressed in the unit of measure given by MapMode.
PageModePrintDirection | Holds the print direction.
PageModeVerticalPosition | Holds the vertical start position offset within the print area for the selected PageModeStation.
RecCurrentCartridge | Holds the receipt cartridge currently selected by the application.
RecLetterQuality | If true, prints in high-quality mode. If false, prints in high-speed mode.
RecLineChars | Holds the number of characters that the application wants to print on a receipt line.
RecLineHeight | Holds the receipt print line height, expressed in the unit of measure indicated by the MapMode property setting, that the application wants to use.
RecLineSpacing | Holds the spacing of each single-high print line, including both the printed line height and the white space between each pair of lines, that the application wants to use.
RecRotationMode |
RotateSpecial | Holds the rotation orientation for bar codes that the application wants to use.
SlpCurrentCartridge | Holds the slip cartridge the application wants to use.
SlpLetterQuality | If true, prints in high-quality mode. If false, prints in high-speed mode.
SlpLineChars | Holds the number of characters that the application wants to print on a slip line.
SlpLineHeight | Holds the slip print-line height, expressed in the unit of measure indicated by the MapMode property setting, that the application wants to use.
SlpLineSpacing | Holds the spacing of each single-high print line, including both the printed line height and the white space between each pair of lines that the application wants to use.
SlpRotationMode |
TopLogo | Holds a value indicating whether a logo should be printed during print operations.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

PrinterState Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PrinterState Methods

PrinterState Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

PrinterState Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PrinterState Properties

PrinterState Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
BottomLogo | Determines whether to print a logo during print operations.
CharacterSet | Holds the default character set capability.
JrnCurrentCartridge | Holds the currently selected journal cartridge.
JrnLetterQuality | If true, prints in high-quality mode. If false, prints in high-speed mode.
JrnLineChars | Holds the number of characters that the application wants to print on a journal line.
JrnLineHeight | Holds the journal print line height the application wants to use, expressed in the unit of measure indicated by the MapMode property setting.
JrnLineSpacing | Holds the spacing of each single-high print line, including both the printed line height and the white space between each pair of lines that the application wants to use.
MapCharacterSet | If set to true by the application while outputting data, the service object maps the characters transferred by the application to the character set selected in the CharacterSet property.
MapMode | Holds the mapping mode of the printer the application wants to use.
PageModeHorizontalPosition | Holds the horizontal start position offset within the print area for the selected PageModeStation, expressed in the unit of measure given by MapMode.
PageModePrintArea | Holds the print area for the selected PageModeStation expressed in the unit of measure given by MapMode.
PageModePrintDirection | Holds the print direction.
PageModeVerticalPosition | Holds the vertical start position offset within the print area for the selected PageModeStation.
RecCurrentCartridge | Holds the receipt cartridge currently selected by the application.
RecLetterQuality | If true, prints in high-quality mode. If false, prints in high-speed mode.
RecLineChars | Holds the number of characters that the application wants to print on a receipt line.
RecLineHeight | Holds the receipt print line height, expressed in the unit of measure indicated by the MapMode property setting, that the application wants to use.
RecLineSpacing | Holds the spacing of each single-high print line, including both the printed line height and the white space between each pair of lines, that the application wants to use.
RecRotationMode |
RotateSpecial | Holds the rotation orientation for bar codes that the application wants to use.
SlpCurrentCartridge | Holds the slip cartridge the application wants to use.
SlpLetterQuality | If true, prints in high-quality mode. If false, prints in high-speed mode.
SlpLineChars | Holds the number of characters that the application wants to print on a slip line.
SlpLineHeight | Holds the slip print-line height, expressed in the unit of measure indicated by the MapMode property setting, that the application wants to use.
SlpLineSpacing | Holds the spacing of each single-high print line, including both the printed line height and the white space between each pair of lines that the application wants to use.
SlpRotationMode |
TopLogo | Holds a value indicating whether a logo should be printed during print operations.

See Also

Reference

PrinterState Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PrinterState.BottomLogo Property

PrinterState.BottomLogo Property |
 | See Also

1/18/2008

Determines whether to print a logo during print operations.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property BottomLogo As String
public string BottomLogo { get; }
public:
property String^ BottomLogo {
    String^ get ();
}
/** @property */
public String get_BottomLogo ()

public function get BottomLogo () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterState Class
PrinterState Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PrinterProperties.BottomLogo Property


PrinterState.CharacterSet Property

PrinterState.CharacterSet Property |
 | See Also

1/18/2008

Holds the default character set capability.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property CharacterSet As Integer
public int CharacterSet { get; }
public:
property int CharacterSet {
    int get ();
}
/** @property */
public int get_CharacterSet ()

public function get CharacterSet () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterState Class
PrinterState Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrinterState.JrnCurrentCartridge Property

PrinterState.JrnCurrentCartridge Property |
 | See Also

1/18/2008

Holds the currently selected journal cartridge.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property JrnCurrentCartridge As PrinterColors
public PrinterColors JrnCurrentCartridge { get; }
public:
property PrinterColors JrnCurrentCartridge {
    PrinterColors get ();
}
/** @property */
public PrinterColors get_JrnCurrentCartridge ()

public function get JrnCurrentCartridge () : PrinterColors

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterState Class
PrinterState Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.JrnCurrentCartridge Property


PrinterState.JrnLetterQuality Property

PrinterState.JrnLetterQuality Property |
 | See Also

1/18/2008

If true, prints in high-quality mode. If false, prints in high-speed mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property JrnLetterQuality As Boolean
public bool JrnLetterQuality { get; }
public:
property bool JrnLetterQuality {
    bool get ();
}
/** @property */
public boolean get_JrnLetterQuality ()

public function get JrnLetterQuality () : boolean

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterState Class
PrinterState Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.JrnLetterQuality Property


PrinterState.JrnLineChars Property

PrinterState.JrnLineChars Property |
 | See Also

1/18/2008

Holds the number of characters that the application wants to print on a journal line.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property JrnLineChars As Integer
public int JrnLineChars { get; }
public:
property int JrnLineChars {
    int get ();
}
/** @property */
public int get_JrnLineChars ()

public function get JrnLineChars () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterState Class
PrinterState Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.JrnLineChars Property


PrinterState.JrnLineHeight Property

PrinterState.JrnLineHeight Property |
 | See Also

1/18/2008

Holds the journal print line height the application wants to use, expressed in the unit of measure indicated by the MapMode property setting.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property JrnLineHeight As Integer
public int JrnLineHeight { get; }
public:
property int JrnLineHeight {
    int get ();
}
/** @property */
public int get_JrnLineHeight ()

public function get JrnLineHeight () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterState Class
PrinterState Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.JrnLineHeight Property


PrinterState.JrnLineSpacing Property

PrinterState.JrnLineSpacing Property |
 | See Also

1/18/2008

Holds the spacing of each single-high print line, including both the printed line height and the white space between each pair of lines that the application wants to use.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property JrnLineSpacing As Integer
public int JrnLineSpacing { get; }
public:
property int JrnLineSpacing {
    int get ();
}
/** @property */
public int get_JrnLineSpacing ()

public function get JrnLineSpacing () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterState Class
PrinterState Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.JrnLineSpacing Property


PrinterState.MapCharacterSet Property

PrinterState.MapCharacterSet Property |
 | See Also

1/18/2008

If set to true by the application while outputting data, the service object maps the characters transferred by the application to the character set selected in the CharacterSet property.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property MapCharacterSet As Boolean
public bool MapCharacterSet { get; }
public:
property bool MapCharacterSet {
    bool get ();
}
/** @property */
public boolean get_MapCharacterSet ()

public function get MapCharacterSet () : boolean

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterState Class
PrinterState Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.MapCharacterSet Property


PrinterState.MapMode Property

PrinterState.MapMode Property |
 | See Also

1/18/2008

Holds the mapping mode of the printer the application wants to use.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property MapMode As MapMode
public MapMode MapMode { get; }
public:
property MapMode MapMode {
    MapMode get ();
}
/** @property */
public MapMode get_MapMode ()

public function get MapMode () : MapMode

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterState Class
PrinterState Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.MapMode Property


PrinterState.PageModeHorizontalPosition Property

PrinterState.PageModeHorizontalPosition Property |
 | See Also

1/18/2008

Holds the horizontal start position offset within the print area for the selected PageModeStation, expressed in the unit of measure given by MapMode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property PageModeHorizontalPosition As Integer
public int PageModeHorizontalPosition { get; }
public:
property int PageModeHorizontalPosition {
    int get ();
}
/** @property */
public int get_PageModeHorizontalPosition ()

public function get PageModeHorizontalPosition () : int

Remarks

Holds the horizontal start position offset within the print area for the selected PageModeStation, expressed in the unit of measure given by MapMode. The horizontal direction is the same as the actual PageModePrintDirection property. If the exact position cannot be supported then the position is set to the closest supported value.

A read/get on this property will return the horizontal position offset set by the last write/set and not the current position.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterState Class
PrinterState Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrinterState.PageModePrintArea Property

PrinterState.PageModePrintArea Property |
 | See Also

1/18/2008

Holds the print area for the selected PageModeStation expressed in the unit of measure given by MapMode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property PageModePrintArea As Rectangle
public Rectangle PageModePrintArea { get; }
public:
property Rectangle PageModePrintArea {
    Rectangle get ();
}
/** @property */
public Rectangle get_PageModePrintArea ()

public function get PageModePrintArea () : Rectangle

Remarks

Holds the print area for the selected PageModeStation expressed in the unit of measure given by MapMode. The maximum print area is the page area.

Text written to the right edge of the print area will wrap to the next line. Any text or image written beyond the bottom of the print area will be truncated.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterState Class
PrinterState Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrinterState.PageModePrintDirection Property

PrinterState.PageModePrintDirection Property |
 | See Also

1/18/2008

Holds the print direction.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property PageModePrintDirection As PageModePrintDirection
public PageModePrintDirection PageModePrintDirection { get; }
public:
property PageModePrintDirection PageModePrintDirection {
    PageModePrintDirection get ();
}
/** @property */
public PageModePrintDirection get_PageModePrintDirection ()

public function get PageModePrintDirection () : PageModePrintDirection

Remarks

This property holds the print direction. Valid values, as defined in the PageModePrintDirection enumeration, are listed below:

Value | Meaning
BottomToTop | Print bottom to top, starting at the bottom left position of the print area (that is, rotated left 90° printing).
LeftToRight | Print left to right, starting at top left position of the print area (that is, normal printing).
None | No valid station is selected.
RightToLeft | Print right to left, starting at the bottom right position of the print area (that is, upside down printing).
TopToBottom | Print top to bottom, starting at the top right position of the print area (that is, rotated right 90° printing.)

This property is initialized to LeftToRight when the device is first enabled following the open method.

Setting this property may also change PageModeHorizontalPosition and

PageModeVerticalPosition. Setting this property will have an effect on the current print area. By changing the print area, it is possible to generate a receipt or slip with text printed in multiple rotations.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterState Class
PrinterState Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrinterState.PageModeVerticalPosition Property

PrinterState.PageModeVerticalPosition Property |
 | See Also

1/18/2008

Holds the vertical start position offset within the print area for the selected PageModeStation.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property PageModeVerticalPosition As Integer
public int PageModeVerticalPosition { get; }
public:
property int PageModeVerticalPosition {
    int get ();
}
/** @property */
public int get_PageModeVerticalPosition ()

public function get PageModeVerticalPosition () : int

Remarks

Holds the vertical start position offset within the print area for the selected PageModeStation, expressed in the unit of measure given by MapMode. The vertical direction is perpendicular to the direction specified in the actual PageModePrintDirection property. If the exact position cannot be supported then the position is set to the closest supported value. A read/get on this property will return the vertical position offset set by the last write/set and not the current position.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterState Class
PrinterState Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrinterState.RecCurrentCartridge Property

PrinterState.RecCurrentCartridge Property |
 | See Also

1/18/2008

Holds the receipt cartridge currently selected by the application.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property RecCurrentCartridge As PrinterColors
public PrinterColors RecCurrentCartridge { get; }
public:
property PrinterColors RecCurrentCartridge {
    PrinterColors get ();
}
/** @property */
public PrinterColors get_RecCurrentCartridge ()

public function get RecCurrentCartridge () : PrinterColors

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterState Class
PrinterState Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.RecCurrentCartridge Property


PrinterState.RecLetterQuality Property

PrinterState.RecLetterQuality Property |
 | See Also

1/18/2008

If true, prints in high-quality mode. If false, prints in high-speed mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property RecLetterQuality As Boolean
public bool RecLetterQuality { get; }
public:
property bool RecLetterQuality {
    bool get ();
}
/** @property */
public boolean get_RecLetterQuality ()

public function get RecLetterQuality () : boolean

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterState Class
PrinterState Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.RecLetterQuality Property


PrinterState.RecLineChars Property

PrinterState.RecLineChars Property |
 | See Also

1/18/2008

Holds the number of characters that the application wants to print on a receipt line.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property RecLineChars As Integer
public int RecLineChars { get; }
public:
property int RecLineChars {
    int get ();
}
/** @property */
public int get_RecLineChars ()

public function get RecLineChars () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterState Class
PrinterState Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.RecLineChars Property


PrinterState.RecLineHeight Property

PrinterState.RecLineHeight Property |
 | See Also

1/18/2008

Holds the receipt print line height, expressed in the unit of measure indicated by the MapMode property setting, that the application wants to use.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property RecLineHeight As Integer
public int RecLineHeight { get; }
public:
property int RecLineHeight {
    int get ();
}
/** @property */
public int get_RecLineHeight ()

public function get RecLineHeight () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterState Class
PrinterState Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.RecLineHeight Property


PrinterState.RecLineSpacing Property

PrinterState.RecLineSpacing Property |
 | See Also

1/18/2008

Holds the spacing of each single-high print line, including both the printed line height and the white space between each pair of lines, that the application wants to use.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property RecLineSpacing As Integer
public int RecLineSpacing { get; }
public:
property int RecLineSpacing {
    int get ();
}
/** @property */
public int get_RecLineSpacing ()

public function get RecLineSpacing () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterState Class
PrinterState Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.RecLineSpacing Property


PrinterState.RecRotationMode Property

PrinterState.RecRotationMode Property |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property RecRotationMode As PrintRotation
public PrintRotation RecRotationMode { get; }
public:
property PrintRotation RecRotationMode {
    PrintRotation get ();
}
/** @property */
public PrintRotation get_RecRotationMode ()

public function get RecRotationMode () : PrintRotation

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterState Class
PrinterState Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PrinterState.RecRotationMode Property


PrinterState.RotateSpecial Property

PrinterState.RotateSpecial Property |
 | See Also

1/18/2008

Holds the rotation orientation for bar codes that the application wants to use.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property RotateSpecial As Rotation
public Rotation RotateSpecial { get; }
public:
property Rotation RotateSpecial {
    Rotation get ();
}
/** @property */
public Rotation get_RotateSpecial ()

public function get RotateSpecial () : Rotation

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterState Class
PrinterState Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.RotateSpecial Property


PrinterState.SlpCurrentCartridge Property

PrinterState.SlpCurrentCartridge Property |
 | See Also

1/18/2008

Holds the slip cartridge the application wants to use.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property SlpCurrentCartridge As PrinterColors
public PrinterColors SlpCurrentCartridge { get; }
public:
property PrinterColors SlpCurrentCartridge {
    PrinterColors get ();
}
/** @property */
public PrinterColors get_SlpCurrentCartridge ()

public function get SlpCurrentCartridge () : PrinterColors

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterState Class
PrinterState Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.SlpCurrentCartridge Property


PrinterState.SlpLetterQuality Property

PrinterState.SlpLetterQuality Property |
 | See Also

1/18/2008

If true, prints in high-quality mode. If false, prints in high-speed mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property SlpLetterQuality As Boolean
public bool SlpLetterQuality { get; }
public:
property bool SlpLetterQuality {
    bool get ();
}
/** @property */
public boolean get_SlpLetterQuality ()

public function get SlpLetterQuality () : boolean

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterState Class
PrinterState Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.SlpLetterQuality Property


PrinterState.SlpLineChars Property

PrinterState.SlpLineChars Property |
 | See Also

1/18/2008

Holds the number of characters that the application wants to print on a slip line.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property SlpLineChars As Integer
public int SlpLineChars { get; }
public:
property int SlpLineChars {
    int get ();
}
/** @property */
public int get_SlpLineChars ()

public function get SlpLineChars () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterState Class
PrinterState Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.SlpLineChars Property


PrinterState.SlpLineHeight Property

PrinterState.SlpLineHeight Property |
 | See Also

1/18/2008

Holds the slip print-line height, expressed in the unit of measure indicated by the MapMode property setting, that the application wants to use.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property SlpLineHeight As Integer
public int SlpLineHeight { get; }
public:
property int SlpLineHeight {
    int get ();
}
/** @property */
public int get_SlpLineHeight ()

public function get SlpLineHeight () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterState Class
PrinterState Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.SlpLineHeight Property


PrinterState.SlpLineSpacing Property

PrinterState.SlpLineSpacing Property |
 | See Also

1/18/2008

Holds the spacing of each single-high print line, including both the printed line height and the white space between each pair of lines that the application wants to use.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property SlpLineSpacing As Integer
public int SlpLineSpacing { get; }
public:
property int SlpLineSpacing {
    int get ();
}
/** @property */
public int get_SlpLineSpacing ()

public function get SlpLineSpacing () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterState Class
PrinterState Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.SlpLineSpacing Property


PrinterState.SlpRotationMode Property

PrinterState.SlpRotationMode Property |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property SlpRotationMode As PrintRotation
public PrintRotation SlpRotationMode { get; }
public:
property PrintRotation SlpRotationMode {
    PrintRotation get ();
}
/** @property */
public PrintRotation get_SlpRotationMode ()

public function get SlpRotationMode () : PrintRotation

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterState Class
PrinterState Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PrinterState.SlpRotationMode Property


PrinterState.TopLogo Property

PrinterState.TopLogo Property |
 | See Also

1/18/2008

Holds a value indicating whether a logo should be printed during print operations.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property TopLogo As String
public string TopLogo { get; }
public:
property String^ TopLogo {
    String^ get ();
}
/** @property */
public String get_TopLogo ()

public function get TopLogo () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrinterState Class
PrinterState Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PrinterProperties.TopLogo Property


PrintMemoryBitmapOperation Class

PrintMemoryBitmapOperation Class |
 | See Also Members

1/18/2008

Captures information about the PrintMemoryBitmap method.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class PrintMemoryBitmapOperation
    Inherits PrintOperation
public class PrintMemoryBitmapOperation : PrintOperation
public ref class PrintMemoryBitmapOperation : public PrintOperation
public class PrintMemoryBitmapOperation extends PrintOperation
public class PrintMemoryBitmapOperation extends PrintOperation

Remarks

The PrintMemoryBitmap helper class derives from the PrintOperation helper class. When the application updates printer properties and then calls the PrintMemoryBitmap method, the PosPrinterBase class uses an instance of the PrintMemoryBitmap class, cast to the PrintOperation class and stored in the PrintOperationCollection array, to capture information about that method call. The service object then retrieves the operation from the array and uses it to complete the application’s print request.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BaseServiceObjects.PrintOperation
Microsoft.PointOfService.BaseServiceObjects.PrintMemoryBitmapOperation

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintMemoryBitmapOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.PrintMemoryBitmap Method


PrintMemoryBitmapOperation Members

PrintMemoryBitmapOperation Members |
 | See Also Methods Properties

1/18/2008

Captures information about the PrintMemoryBitmap method.

The following tables list the members exposed by the PrintMemoryBitmapOperation type.

Public Properties

Name | Description
Alignment | Gets the value of the alignment parameter set when the application called the PrintMemoryBitmapOperation method. Valid values are defined by the BitmapAlignment enumeration.
AsyncMode | Contains the AsyncMode property setting at the time of the application’s print request. (inherited from PrintOperation)
Bitmap | Gets the value of the filename parameter set when the application called the PrintMemoryBitmapOperation method.
Rotation | Contains the Rotation setting, as defined by the Rotation enumeration. (inherited from PrintOperation)
State | Contains an instance of the PrinterState class, which captures the current printer property values at the time of the application’s print request. (inherited from PrintOperation)
Station | Contains the printer station setting (for example, PrinterStation.Journal). (inherited from PrintOperation)
Width | Gets the values of the width parameter set when the application called the PrintMemoryBitmapOperation method.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

PrintMemoryBitmapOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.PrintMemoryBitmap Method


PrintMemoryBitmapOperation Methods

PrintMemoryBitmapOperation Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

PrintMemoryBitmapOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.PrintMemoryBitmap Method


PrintMemoryBitmapOperation Properties

PrintMemoryBitmapOperation Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
Alignment | Gets the value of the alignment parameter set when the application called the PrintMemoryBitmapOperation method. Valid values are defined by the BitmapAlignment enumeration.
AsyncMode | Contains the AsyncMode property setting at the time of the application’s print request. (inherited from PrintOperation )
Bitmap | Gets the value of the filename parameter set when the application called the PrintMemoryBitmapOperation method.
Rotation | Contains the Rotation setting, as defined by the Rotation enumeration. (inherited from PrintOperation )
State | Contains an instance of the PrinterState class, which captures the current printer property values at the time of the application’s print request. (inherited from PrintOperation )
Station | Contains the printer station setting (for example, PrinterStation.Journal). (inherited from PrintOperation )
Width | Gets the values of the width parameter set when the application called the PrintMemoryBitmapOperation method.

See Also

Reference

PrintMemoryBitmapOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.PrintMemoryBitmap Method


PrintMemoryBitmapOperation.Alignment Property

PrintMemoryBitmapOperation.Alignment Property |
 | See Also

1/18/2008

Gets the value of the alignment parameter set when the application called the PrintMemoryBitmapOperation method. Valid values are defined by the BitmapAlignment enumeration.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Alignment As Integer
public int Alignment { get; }
public:
property int Alignment {
    int get ();
}
/** @property */
public int get_Alignment ()

public function get Alignment () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintMemoryBitmapOperation Class
PrintMemoryBitmapOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.PrintMemoryBitmap Method


PrintMemoryBitmapOperation.Bitmap Property

PrintMemoryBitmapOperation.Bitmap Property |
 | See Also

1/18/2008

Gets the value of the filename parameter set when the application called the PrintMemoryBitmapOperation method.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Bitmap As Bitmap
public Bitmap Bitmap { get; }
public:
property Bitmap^ Bitmap {
    Bitmap^ get ();
}
/** @property */
public Bitmap get_Bitmap ()

public function get Bitmap () : Bitmap

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintMemoryBitmapOperation Class
PrintMemoryBitmapOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.PrintMemoryBitmap Method


PrintMemoryBitmapOperation.Width Property

PrintMemoryBitmapOperation.Width Property |
 | See Also

1/18/2008

Gets the values of the width parameter set when the application called the PrintMemoryBitmapOperation method.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Width As Integer
public int Width { get; }
public:
property int Width {
    int get ();
}
/** @property */
public int get_Width ()

public function get Width () : int

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintMemoryBitmapOperation Class
PrintMemoryBitmapOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.PrintMemoryBitmap Method


PrintNormalOperation Class

PrintNormalOperation Class |
 | See Also Members

1/18/2008

Capture and holds information about a print method call.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class PrintNormalOperation
    Inherits PrintOperation
public class PrintNormalOperation : PrintOperation
public ref class PrintNormalOperation : public PrintOperation
public class PrintNormalOperation extends PrintOperation
public class PrintNormalOperation extends PrintOperation

Remarks

The PrintNormalOperation helper class derives from the PrintOperation helper class. When the application updates printer properties and then calls the PrintNormal method, the PosPrinterBase class uses an instance of the PrintNormalOperation class, cast to the PrintOperation class and stored in the PrintOperationCollection array, to capture information about that method call. The service object then retrieves the operation from the array and uses it to complete the application’s print request.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BaseServiceObjects.PrintOperation
Microsoft.PointOfService.BaseServiceObjects.PrintNormalOperation

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintNormalOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase Class
PosPrinterBase.PrintNormal Method
PrintOperation


PrintNormalOperation Members

PrintNormalOperation Members |
 | See Also Methods Properties

1/18/2008

Capture and holds information about a print method call.

The following tables list the members exposed by the PrintNormalOperation type.

Public Properties

Name | Description
AsyncMode | Contains the AsyncMode property setting at the time of the application’s print request. (inherited from PrintOperation)
Data | Contains the value of the data parameter set when the application made the PrintNormal method call.
Rotation | Contains the Rotation setting, as defined by the Rotation enumeration. (inherited from PrintOperation)
State | Contains an instance of the PrinterState class, which captures the current printer property values at the time of the application’s print request. (inherited from PrintOperation)
Station | Contains the printer station setting (for example, PrinterStation.Journal). (inherited from PrintOperation)
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

PrintNormalOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase Class
PosPrinterBase.PrintNormal Method
PrintOperation


PrintNormalOperation Methods

PrintNormalOperation Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

PrintNormalOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase Class
PosPrinterBase.PrintNormal Method
PrintOperation


PrintNormalOperation Properties

PrintNormalOperation Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
AsyncMode | Contains the AsyncMode property setting at the time of the application’s print request. (inherited from PrintOperation )
Data | Contains the value of the data parameter set when the application made the PrintNormal method call.
Rotation | Contains the Rotation setting, as defined by the Rotation enumeration. (inherited from PrintOperation )
State | Contains an instance of the PrinterState class, which captures the current printer property values at the time of the application’s print request. (inherited from PrintOperation )
Station | Contains the printer station setting (for example, PrinterStation.Journal). (inherited from PrintOperation )

See Also

Reference

PrintNormalOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase Class
PosPrinterBase.PrintNormal Method
PrintOperation


PrintNormalOperation.Data Property

PrintNormalOperation.Data Property |
 | See Also

1/18/2008

Contains the value of the data parameter set when the application made the PrintNormal method call.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Data As String
public string Data { get; }
public:
property String^ Data {
    String^ get ();
}
/** @property */
public String get_Data ()

public function get Data () : String

Remarks

Contains the value of the data parameter set when the application made the PrintNormal method call.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintNormalOperation Class
PrintNormalOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.PrintNormal Method


PrintOperation Class

PrintOperation Class |
 | See Also Members

1/18/2008

The abstract class definition from which all other <PrintMethodName>Operation classes are derived.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public MustInherit Class PrintOperation
public abstract class PrintOperation
public ref class PrintOperation abstract
public abstract class PrintOperation
public abstract class PrintOperation

Remarks

The PrintOperation helper class is used as the abstract class definition from which all other <PrintMethodName>Operation classes are derived. The PosPrinterBase class uses these derived classes to store state information about specific print operations requested by an application. For example, when the application sets printer properties and then calls a print method such as PrintNormal, the PosPrinterBase class creates an instance of the PrintNormalOperation class, which derives from PrintOperation, to store the information associated with the application’s request. This information is used later by the service object to complete the PrintNormal request.

Each of the properties in the PrintOperation class are inherited by the <PrintMethodName>Operation classes. Information such as the rotation mode, the state of the printer properties at the time of the print method call, and the type of processing—synchronous or asynchronous—is defined herein. Information specific to the application’s method call, such as parameter values, is defined in the derived class for that method call.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BaseServiceObjects.PrintOperation
Derived Classes

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase Class


PrintOperation Members

PrintOperation Members |
 | See Also Methods Properties

1/18/2008

The abstract class definition from which all other <PrintMethodName>Operation classes are derived.

The following tables list the members exposed by the PrintOperation type.

Public Properties

Name | Description
AsyncMode | Contains the AsyncMode property setting at the time of the application’s print request.
Rotation | Contains the Rotation setting, as defined by the Rotation enumeration.
State | Contains an instance of the PrinterState class, which captures the current printer property values at the time of the application’s print request.
Station | Contains the printer station setting (for example, PrinterStation.Journal).
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

PrintOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase Class


PrintOperation Methods

PrintOperation Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

PrintOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase Class


PrintOperation Properties

PrintOperation Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
AsyncMode | Contains the AsyncMode property setting at the time of the application’s print request.
Rotation | Contains the Rotation setting, as defined by the Rotation enumeration.
State | Contains an instance of the PrinterState class, which captures the current printer property values at the time of the application’s print request.
Station | Contains the printer station setting (for example, PrinterStation.Journal).

See Also

Reference

PrintOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase Class


PrintOperation.AsyncMode Property

PrintOperation.AsyncMode Property |
 | See Also

1/18/2008

Contains the AsyncMode property setting at the time of the application’s print request.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property AsyncMode As Boolean
public bool AsyncMode { get; }
public:
property bool AsyncMode {
    bool get ();
}
/** @property */
public boolean get_AsyncMode ()

public function get AsyncMode () : boolean

Remarks

Contains the AsyncMode property setting at the time of the application’s print request.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintOperation Class
PrintOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.AsyncMode Property


PrintOperation.Rotation Property

PrintOperation.Rotation Property |
 | See Also

1/18/2008

Contains the Rotation setting, as defined by the Rotation enumeration.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Rotation As Rotation
public Rotation Rotation { get; }
public:
property Rotation Rotation {
    Rotation get ();
}
/** @property */
public Rotation get_Rotation ()

public function get Rotation () : Rotation

Remarks

Contains the Rotation setting, as defined by the Rotation enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintOperation Class
PrintOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Rotation Enumeration


PrintOperation.State Property

PrintOperation.State Property |
 | See Also

1/18/2008

Contains an instance of the PrinterState class, which captures the current printer property values at the time of the application’s print request.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property State As PrinterState
public PrinterState State { get; }
public:
property PrinterState^ State {
    PrinterState^ get ();
}
/** @property */
public PrinterState get_State ()

public function get State () : PrinterState

Remarks

Contains an instance of the PrinterState class, which captures the current printer property values at the time of the application’s print request.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintOperation Class
PrintOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PrinterState Class


PrintOperation.Station Property

PrintOperation.Station Property |
 | See Also

1/18/2008

Contains the printer station setting (for example, PrinterStation.Journal).

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Station As PrinterStation
public PrinterStation Station { get; }
public:
property PrinterStation Station {
    PrinterStation get ();
}
/** @property */
public PrinterStation get_Station ()

public function get Station () : PrinterStation

Remarks

Contains the printer station setting (for example, PrinterStation.Journal). Valid settings are defined by the PrinterStation enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintOperation Class
PrintOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PrinterStation Enumeration


PrintOperationCollection Class

PrintOperationCollection Class |
 | See Also Members

1/18/2008

Maintains a list of print operations and their associated state information.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

<DefaultMemberAttribute("Item")> _
Public Class PrintOperationCollection
    Inherits ReadOnlyCollectionBase
    Implements IEnumerable
[DefaultMemberAttribute("Item")]
public class PrintOperationCollection : ReadOnlyCollectionBase, IEnumerable
[DefaultMemberAttribute(L"Item")]
public ref class PrintOperationCollection : public ReadOnlyCollectionBase, IEnumerable
/** @attribute DefaultMemberAttribute("Item") */
public class PrintOperationCollection extends ReadOnlyCollectionBase implements IEnumerable
DefaultMemberAttribute("Item")
public class PrintOperationCollection extends ReadOnlyCollectionBase implements IEnumerable

Remarks

The PrintOperationCollection helper class derives from the .NET Framework ReadOnlyCollectionBase class and is enumerable. POS for .NET created PrintOperationCollection as a means of maintaining a list of print operations (and their associated state information).

Typically, an application sets printer properties and then calls a print method, such as PrintNormal. A series of these actions makes up a transaction for a specified printer station, just as PrinterStation.Receipt. The PosPrinterBase class captures each print request’s information in a combination of PrinterState and <PrintMethodName>Operation class instances, then casts the <PrintMethodName>Operation instance to the PrintOperation class, to be stored in the PrintOperationCollection class array. The service object retrieves instances from the array, examines them to determine the type of print operation, then performs that operation. The service object should print the items in the order in which they appear in the collection.

Inheritance Hierarchy

System.Object
System.Collections.ReadOnlyCollectionBase
Microsoft.PointOfService.BaseServiceObjects.PrintOperationCollection
Microsoft.PointOfService.BaseServiceObjects.PageModePrintCollection
Microsoft.PointOfService.BaseServiceObjects.RotatePrintCollection

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintOperationCollection Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrintOperationCollection Members

PrintOperationCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

1/18/2008

Maintains a list of print operations and their associated state information.

The following tables list the members exposed by the PrintOperationCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from ReadOnlyCollectionBase )
Item | Retrieves an instance of the PrintOperation class from the array.
Station | Retrieves the printer station, as defined by the PrinterStation enumeration, associated with the array.
Top

Protected Properties

Name | Description
InnerList | (inherited from ReadOnlyCollectionBase )
Top

Public Methods (see also Protected Methods )

Name | Description
CopyTo | Copies a PrintOperation class instance to the array.
Equals | Overloaded. (inherited from Object )
GetEnumerator | (inherited from ReadOnlyCollectionBase )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from ReadOnlyCollectionBase )
System.Collections.ICollection.IsSynchronized | (inherited from ReadOnlyCollectionBase )
System.Collections.ICollection.SyncRoot | (inherited from ReadOnlyCollectionBase )
Top

See Also

Reference

PrintOperationCollection Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PrintOperationCollection Methods

PrintOperationCollection Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
CopyTo | Copies a PrintOperation class instance to the array.
Equals | Overloaded. (inherited from Object )
GetEnumerator | (inherited from ReadOnlyCollectionBase )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from ReadOnlyCollectionBase )

See Also

Reference

PrintOperationCollection Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PrintOperationCollection.CopyTo Method

PrintOperationCollection.CopyTo Method |
 | See Also

1/18/2008

Copies a PrintOperation class instance to the array.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub CopyTo ( _
    array As PrintOperation(), _
    index As Integer _
)
public void CopyTo (
    PrintOperation[] array,
    int index
)
public:
void CopyTo (
    array<PrintOperation^>^ array,
    int index
)
public void CopyTo (
    PrintOperation[] array,
    int index
)
public function CopyTo (
    array : PrintOperation[],
    index : int
)

Parameters

array

The array of PrintOperation class instances.

index

The index number into the array.

Remarks

Copies a PrintOperation class instance to the array.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintOperationCollection Class
PrintOperationCollection Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PrintOperation Class


PrintOperationCollection Properties

PrintOperationCollection Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from ReadOnlyCollectionBase )
Item | Retrieves an instance of the PrintOperation class from the array.
Station | Retrieves the printer station, as defined by the PrinterStation enumeration, associated with the array.

Protected Properties

Name | Description
InnerList | (inherited from ReadOnlyCollectionBase )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.IsSynchronized | (inherited from ReadOnlyCollectionBase )
System.Collections.ICollection.SyncRoot | (inherited from ReadOnlyCollectionBase )

See Also

Reference

PrintOperationCollection Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PrintOperationCollection.Item Property

PrintOperationCollection.Item Property |
 | See Also

1/18/2008

Retrieves an instance of the PrintOperation class from the array.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Default Property Item ( _
    index As Integer _
) As PrintOperation
public PrintOperation this [
    int index
] { get; }
public:
property PrintOperation^ default [int] {
    PrintOperation^ get (int index);
}
/** @property */
public PrintOperation get_Item (int index)

Parameters

index

The index number for the PrintOperation class instance to be retrieved.

Remarks

Retrieves an instance of the PrintOperation class from the array.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintOperationCollection Class
PrintOperationCollection Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PrintOperation Class


PrintOperationCollection.Station Property

PrintOperationCollection.Station Property |
 | See Also

1/18/2008

Retrieves the printer station, as defined by the PrinterStation enumeration, associated with the array.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Station As PrinterStation
public PrinterStation Station { get; }
public:
property PrinterStation Station {
    PrinterStation get ();
}
/** @property */
public PrinterStation get_Station ()

public function get Station () : PrinterStation

Remarks

Retrieves the printer station, as defined by the PrinterStation enumeration, associated with the array.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintOperationCollection Class
PrintOperationCollection Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PrinterStation Enumeration


PrintResults Class

PrintResults Class |
 | See Also Members

1/18/2008

The PrintResults helper class simplifies the return of status from service object-implemented base class methods and is used by the PosPrinterBase class to maintain and update printer statistics.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class PrintResults
public class PrintResults
public ref class PrintResults
public class PrintResults
public class PrintResults

Remarks

PrintResults is a helper class created by POS for .NET to simplify the return of status from service object-implemented base class methods. PrintResults is also used by the PosPrinterBase class to maintain and update printer statistics. A number of service object-implemented printer methods (the *Impl methods) return an instance of PrintResults. For these methods, service objects must report errors by updating the error-related properties of the PrintResults class. (For methods that do not return an instance of the PrintResults class, the service object should throw exceptions.)

Any statistics that have been updated in PrintResults will be updated by the base class upon return from the *Impl method. Returning any non-zero value for ErrorCode will result in a PosControlException exception being thrown if the device is in synchronous mode, or an ErrorEvent event being queued if the device is in asynchronous mode. The ErrorLevel, ErrorStation, and ErrorString properties will also be updated when the ErrorEvent event is delivered to the application.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BaseServiceObjects.PrintResults

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintResults Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrintResults Members

PrintResults Members |
 | See Also Constructors Methods Properties

1/18/2008

The PrintResults helper class simplifies the return of status from service object-implemented base class methods and is used by the PosPrinterBase class to maintain and update printer statistics.

The following tables list the members exposed by the PrintResults type.

Public Constructors

Name | Description
PrintResults | Creates a new instance of the PrintResults class.
Top

Public Properties

Name | Description
BarcodePrintedCount | Contains the number of barcodes printed.
ErrorCode | Contains the error code for the current error condition.
ErrorCodeExtended | Contains the extended error code for the current error condition.
ErrorLevel | Contains the current error level for the printer device.
ErrorString | Contains a vendor-supplied description of the error that has occurred.
FailedPaperCutCount | Contains the number of failed paper cuts.
FailedPrintSideChangeCount | Contains the number of print side changes (or check flips) failures.
FormInsertionCount | Contains the number of forms inserted into the document/slip station.
HomeErrorCount | Contains the number of home errors.
JournalCharacterPrintedCount | Contains the number of Journal characters printed.
JournalLinePrintedCount | Contains the number of Journal lines printed.
MaximumTempReachedCount | Contains the number of times Maximum temperature was reached.
NVRAMWriteCount | Contains the number of times NVRAM is written to.
PaperCutCount | Contains the number of paper cuts.
PrinterFaultCount | Contains the number of printer faults.
PrinterStation | Contains the current printer station, as defined by the PrinterStation enumeration.
PrintSideChangeCount | Contains the number of print side changes (or check flips) performed.
ReceiptCharacterPrintedCount | Contains the number of receipt characters printed.
ReceiptLineFeedCount | Contains the number of receipt line feeds performed.
ReceiptLinePrintedCount | Contains the number of receipt lines printed.
SlipCharacterPrintedCount | Contains the number of document/slip characters printed.
SlipLineFeedCount | Contains the number of document/slip line feeds performed.
SlipLinePrintedCount | Contains the number of document/slip lines printed.
StampFiredCount | Contains the number of Stamps fired.
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

PrintResults Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PrintResults Constructor

PrintResults Constructor |
 | See Also

1/18/2008

Creates a new instance of the PrintResults class.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub New
public PrintResults ()
public:
PrintResults ()
public PrintResults ()
public function PrintResults ()

Remarks

Creates a new instance of the PrintResults class.

See Also

Reference

PrintResults Class
PrintResults Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrintResults Methods

PrintResults Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

PrintResults Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PrintResults Properties

PrintResults Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
BarcodePrintedCount | Contains the number of barcodes printed.
ErrorCode | Contains the error code for the current error condition.
ErrorCodeExtended | Contains the extended error code for the current error condition.
ErrorLevel | Contains the current error level for the printer device.
ErrorString | Contains a vendor-supplied description of the error that has occurred.
FailedPaperCutCount | Contains the number of failed paper cuts.
FailedPrintSideChangeCount | Contains the number of print side changes (or check flips) failures.
FormInsertionCount | Contains the number of forms inserted into the document/slip station.
HomeErrorCount | Contains the number of home errors.
JournalCharacterPrintedCount | Contains the number of Journal characters printed.
JournalLinePrintedCount | Contains the number of Journal lines printed.
MaximumTempReachedCount | Contains the number of times Maximum temperature was reached.
NVRAMWriteCount | Contains the number of times NVRAM is written to.
PaperCutCount | Contains the number of paper cuts.
PrinterFaultCount | Contains the number of printer faults.
PrinterStation | Contains the current printer station, as defined by the PrinterStation enumeration.
PrintSideChangeCount | Contains the number of print side changes (or check flips) performed.
ReceiptCharacterPrintedCount | Contains the number of receipt characters printed.
ReceiptLineFeedCount | Contains the number of receipt line feeds performed.
ReceiptLinePrintedCount | Contains the number of receipt lines printed.
SlipCharacterPrintedCount | Contains the number of document/slip characters printed.
SlipLineFeedCount | Contains the number of document/slip line feeds performed.
SlipLinePrintedCount | Contains the number of document/slip lines printed.
StampFiredCount | Contains the number of Stamps fired.

See Also

Reference

PrintResults Class
Microsoft.PointOfService.BaseServiceObjects Namespace


PrintResults.BarcodePrintedCount Property

PrintResults.BarcodePrintedCount Property |
 | See Also

1/18/2008

Contains the number of barcodes printed.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property BarcodePrintedCount As Integer
public int BarcodePrintedCount { get; set; }
public:
property int BarcodePrintedCount {
    int get ();
    void set (int value);
}
/** @property */
public int get_BarcodePrintedCount ()

/** @property */
public void set_BarcodePrintedCount (int value)

public function get BarcodePrintedCount () : int

public function set BarcodePrintedCount (value : int)

Remarks

Contains the number of barcodes printed.

BarCodePrintedCount is initialized to 0 (zero) by the PrintResults class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintResults Class
PrintResults Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrintResults.ErrorCode Property

PrintResults.ErrorCode Property |
 | See Also

1/18/2008

Contains the error code for the current error condition.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property ErrorCode As ErrorCode
public ErrorCode ErrorCode { get; set; }
public:
property ErrorCode ErrorCode {
    ErrorCode get ();
    void set (ErrorCode value);
}
/** @property */
public ErrorCode get_ErrorCode ()

/** @property */
public void set_ErrorCode (ErrorCode value)

public function get ErrorCode () : ErrorCode

public function set ErrorCode (value : ErrorCode)

Remarks

Contains the error code for the current error condition. Possible values are defined by the ErrorCode enumeration. The service object sets ErrorCode to communicate to the PosPrinterBase class that an error has occurred. The PosPrinterBase class will check the code and if it is non-zero, handle the error. If the PosPrinterProperties.AsyncMode property is set to TRUE, indicating asynchronous processing, the PosPrinterBase class will queue an ErrorEvent event. Otherwise, a PosControlException exception will be thrown.

ErrorCode is initialized to 0 (zero) by the PrintResults class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintResults Class
PrintResults Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrintResults.ErrorCodeExtended Property

PrintResults.ErrorCodeExtended Property |
 | See Also

1/18/2008

Contains the extended error code for the current error condition.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property ErrorCodeExtended As Integer
public int ErrorCodeExtended { get; set; }
public:
property int ErrorCodeExtended {
    int get ();
    void set (int value);
}
/** @property */
public int get_ErrorCodeExtended ()

/** @property */
public void set_ErrorCodeExtended (int value)

public function get ErrorCodeExtended () : int

public function set ErrorCodeExtended (value : int)

Remarks

Contains the extended error code for the current error condition. The service object sets ExtendedErrorCode, along with ErrorCode, to communicate to the PosPrinterBase class that an error has occurred during processing.

ErrorCodeExtended is initialized to 0 (zero) by the PrintResults class. In synchronous mode, this string is used to set the ErrorString property when the ErrorEvent is delivered to the application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintResults Class
PrintResults Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PrintResults.ErrorCode Property


PrintResults.ErrorLevel Property

PrintResults.ErrorLevel Property |
 | See Also

1/18/2008

Contains the current error level for the printer device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property ErrorLevel As PrinterErrorLevel
public PrinterErrorLevel ErrorLevel { get; set; }
public:
property PrinterErrorLevel ErrorLevel {
    PrinterErrorLevel get ();
    void set (PrinterErrorLevel value);
}
/** @property */
public PrinterErrorLevel get_ErrorLevel ()

/** @property */
public void set_ErrorLevel (PrinterErrorLevel value)

public function get ErrorLevel () : PrinterErrorLevel

public function set ErrorLevel (value : PrinterErrorLevel)

Remarks

Contains the current error level for the printer device. Possible values are defined by the PrinterErrorLevel enumeration.

ErrorLevel is initialized to PrinterErrorLevel.None by the PrintResults class. In synchronous mode, this string is used to set the ErrorLevel property when the ErrorEvent is delivered to the application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintResults Class
PrintResults Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.ErrorLevel Property


PrintResults.ErrorString Property

PrintResults.ErrorString Property |
 | See Also

1/18/2008

Contains a vendor-supplied description of the error that has occurred.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property ErrorString As String
public string ErrorString { get; set; }
public:
property String^ ErrorString {
    String^ get ();
    void set (String^ value);
}
/** @property */
public String get_ErrorString ()

/** @property */
public void set_ErrorString (String value)

public function get ErrorString () : String

public function set ErrorString (value : String)

Remarks

Contains a vendor-supplied description of the error that has occurred.

ErrorString is initialized to blank by the PrintResults class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintResults Class
PrintResults Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.ErrorString Property
PrintResults.ErrorCode Property
PrintResults.ErrorCodeExtended Property


PrintResults.FailedPaperCutCount Property

PrintResults.FailedPaperCutCount Property |
 | See Also

1/18/2008

Contains the number of failed paper cuts.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property FailedPaperCutCount As Integer
public int FailedPaperCutCount { get; set; }
public:
property int FailedPaperCutCount {
    int get ();
    void set (int value);
}
/** @property */
public int get_FailedPaperCutCount ()

/** @property */
public void set_FailedPaperCutCount (int value)

public function get FailedPaperCutCount () : int

public function set FailedPaperCutCount (value : int)

Remarks

Contains the number of failed paper cuts.

FailedPaperCutCount is initialized to 0 (zero) by the PrintResults class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintResults Class
PrintResults Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrintResults.FailedPrintSideChangeCount Property

PrintResults.FailedPrintSideChangeCount Property |
 | See Also

1/18/2008

Contains the number of print side changes (or check flips) failures.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property FailedPrintSideChangeCount As Integer
public int FailedPrintSideChangeCount { get; set; }
public:
property int FailedPrintSideChangeCount {
    int get ();
    void set (int value);
}
/** @property */
public int get_FailedPrintSideChangeCount ()

/** @property */
public void set_FailedPrintSideChangeCount (int value)

public function get FailedPrintSideChangeCount () : int

public function set FailedPrintSideChangeCount (value : int)

Remarks

Contains the number of print side changes (or check flips) failures.

FailedPrintSideChangeCount is initialized to 0 (zero) by the PrintResults class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintResults Class
PrintResults Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrintResults.FormInsertionCount Property

PrintResults.FormInsertionCount Property |
 | See Also

1/18/2008

Contains the number of forms inserted into the document/slip station.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property FormInsertionCount As Integer
public int FormInsertionCount { get; set; }
public:
property int FormInsertionCount {
    int get ();
    void set (int value);
}
/** @property */
public int get_FormInsertionCount ()

/** @property */
public void set_FormInsertionCount (int value)

public function get FormInsertionCount () : int

public function set FormInsertionCount (value : int)

Remarks

Contains the number of forms inserted into the document/slip station.

FormInsertionCount is initialized to 0 (zero) by the PrintResults class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintResults Class
PrintResults Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrintResults.HomeErrorCount Property

PrintResults.HomeErrorCount Property |
 | See Also

1/18/2008

Contains the number of home errors.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property HomeErrorCount As Integer
public int HomeErrorCount { get; set; }
public:
property int HomeErrorCount {
    int get ();
    void set (int value);
}
/** @property */
public int get_HomeErrorCount ()

/** @property */
public void set_HomeErrorCount (int value)

public function get HomeErrorCount () : int

public function set HomeErrorCount (value : int)

Remarks

Contains the number of home errors.

HomeErrorCount is initialized to 0 (zero) by the PrintResults class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintResults Class
PrintResults Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrintResults.JournalCharacterPrintedCount Property

PrintResults.JournalCharacterPrintedCount Property |
 | See Also

1/18/2008

Contains the number of Journal characters printed.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property JournalCharacterPrintedCount As Integer
public int JournalCharacterPrintedCount { get; set; }
public:
property int JournalCharacterPrintedCount {
    int get ();
    void set (int value);
}
/** @property */
public int get_JournalCharacterPrintedCount ()

/** @property */
public void set_JournalCharacterPrintedCount (int value)

public function get JournalCharacterPrintedCount () : int

public function set JournalCharacterPrintedCount (value : int)

Remarks

Contains the number of Journal characters printed.

JournalCharacterPrintedCount is initialized to 0 (zero) by the PrintResults class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintResults Class
PrintResults Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrintResults.JournalLinePrintedCount Property

PrintResults.JournalLinePrintedCount Property |
 | See Also

1/18/2008

Contains the number of Journal lines printed.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property JournalLinePrintedCount As Integer
public int JournalLinePrintedCount { get; set; }
public:
property int JournalLinePrintedCount {
    int get ();
    void set (int value);
}
/** @property */
public int get_JournalLinePrintedCount ()

/** @property */
public void set_JournalLinePrintedCount (int value)

public function get JournalLinePrintedCount () : int

public function set JournalLinePrintedCount (value : int)

Remarks

Contains the number of Journal lines printed.

JournalLinePrintedCount is initialized to 0 (zero) by the PrintResults class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintResults Class
PrintResults Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrintResults.MaximumTempReachedCount Property

PrintResults.MaximumTempReachedCount Property |
 | See Also

1/18/2008

Contains the number of times Maximum temperature was reached.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property MaximumTempReachedCount As Integer
public int MaximumTempReachedCount { get; set; }
public:
property int MaximumTempReachedCount {
    int get ();
    void set (int value);
}
/** @property */
public int get_MaximumTempReachedCount ()

/** @property */
public void set_MaximumTempReachedCount (int value)

public function get MaximumTempReachedCount () : int

public function set MaximumTempReachedCount (value : int)

Remarks

Contains the number of times Maximum temperature was reached.

MaximumTempReachedCount is initialized to 0 (zero) by the PrintResults class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintResults Class
PrintResults Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrintResults.NVRAMWriteCount Property

PrintResults.NVRAMWriteCount Property |
 | See Also

1/18/2008

Contains the number of times NVRAM is written to.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property NVRAMWriteCount As Integer
public int NVRAMWriteCount { get; set; }
public:
property int NVRAMWriteCount {
    int get ();
    void set (int value);
}
/** @property */
public int get_NVRAMWriteCount ()

/** @property */
public void set_NVRAMWriteCount (int value)

public function get NVRAMWriteCount () : int

public function set NVRAMWriteCount (value : int)

Remarks

Contains the number of times NVRAM is written to.

NVRAMWriteCount is initialized to 0 (zero) by the PrintResults class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintResults Class
PrintResults Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrintResults.PaperCutCount Property

PrintResults.PaperCutCount Property |
 | See Also

1/18/2008

Contains the number of paper cuts.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property PaperCutCount As Integer
public int PaperCutCount { get; set; }
public:
property int PaperCutCount {
    int get ();
    void set (int value);
}
/** @property */
public int get_PaperCutCount ()

/** @property */
public void set_PaperCutCount (int value)

public function get PaperCutCount () : int

public function set PaperCutCount (value : int)

Remarks

Contains the number of paper cuts.

PaperCutCount is initialized to 0 (zero) by the PrintResults class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintResults Class
PrintResults Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrintResults.PrinterFaultCount Property

PrintResults.PrinterFaultCount Property |
 | See Also

1/18/2008

Contains the number of printer faults.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property PrinterFaultCount As Integer
public int PrinterFaultCount { get; set; }
public:
property int PrinterFaultCount {
    int get ();
    void set (int value);
}
/** @property */
public int get_PrinterFaultCount ()

/** @property */
public void set_PrinterFaultCount (int value)

public function get PrinterFaultCount () : int

public function set PrinterFaultCount (value : int)

Remarks

Contains the number of printer faults.

PrinterFaultCount is initialized to 0 (zero) by the PrintResults class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintResults Class
PrintResults Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrintResults.PrinterStation Property

PrintResults.PrinterStation Property |
 | See Also

1/18/2008

Contains the current printer station, as defined by the PrinterStation enumeration.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property PrinterStation As PrinterStation
public PrinterStation PrinterStation { get; set; }
public:
property PrinterStation PrinterStation {
    PrinterStation get ();
    void set (PrinterStation value);
}
/** @property */
public PrinterStation get_PrinterStation ()

/** @property */
public void set_PrinterStation (PrinterStation value)

public function get PrinterStation () : PrinterStation

public function set PrinterStation (value : PrinterStation)

Remarks

Contains the current printer station, as defined by the PrinterStation enumeration.

PrinterStation is initialized to PrinterStation.None by the PrintResults class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintResults Class
PrintResults Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PrinterStation Enumeration


PrintResults.PrintSideChangeCount Property

PrintResults.PrintSideChangeCount Property |
 | See Also

1/18/2008

Contains the number of print side changes (or check flips) performed.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property PrintSideChangeCount As Integer
public int PrintSideChangeCount { get; set; }
public:
property int PrintSideChangeCount {
    int get ();
    void set (int value);
}
/** @property */
public int get_PrintSideChangeCount ()

/** @property */
public void set_PrintSideChangeCount (int value)

public function get PrintSideChangeCount () : int

public function set PrintSideChangeCount (value : int)

Remarks

Contains the number of print side changes (or check flips) performed.

PrintSideChangeCount is initialized to 0 (zero) by the PrintResults class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintResults Class
PrintResults Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrintResults.ReceiptCharacterPrintedCount Property

PrintResults.ReceiptCharacterPrintedCount Property |
 | See Also

1/18/2008

Contains the number of receipt characters printed.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property ReceiptCharacterPrintedCount As Integer
public int ReceiptCharacterPrintedCount { get; set; }
public:
property int ReceiptCharacterPrintedCount {
    int get ();
    void set (int value);
}
/** @property */
public int get_ReceiptCharacterPrintedCount ()

/** @property */
public void set_ReceiptCharacterPrintedCount (int value)

public function get ReceiptCharacterPrintedCount () : int

public function set ReceiptCharacterPrintedCount (value : int)

Remarks

Contains the number of receipt characters printed.

ReceiptCharacterPrintedCount is initialized to 0 (zero) by the PrintResults class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintResults Class
PrintResults Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrintResults.ReceiptLineFeedCount Property

PrintResults.ReceiptLineFeedCount Property |
 | See Also

1/18/2008

Contains the number of receipt line feeds performed.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property ReceiptLineFeedCount As Integer
public int ReceiptLineFeedCount { get; set; }
public:
property int ReceiptLineFeedCount {
    int get ();
    void set (int value);
}
/** @property */
public int get_ReceiptLineFeedCount ()

/** @property */
public void set_ReceiptLineFeedCount (int value)

public function get ReceiptLineFeedCount () : int

public function set ReceiptLineFeedCount (value : int)

Remarks

Contains the number of receipt line feeds performed.

ReceiptLineFeedCount is initialized to 0 (zero) by the PrintResults class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintResults Class
PrintResults Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrintResults.ReceiptLinePrintedCount Property

PrintResults.ReceiptLinePrintedCount Property |
 | See Also

1/18/2008

Contains the number of receipt lines printed.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property ReceiptLinePrintedCount As Integer
public int ReceiptLinePrintedCount { get; set; }
public:
property int ReceiptLinePrintedCount {
    int get ();
    void set (int value);
}
/** @property */
public int get_ReceiptLinePrintedCount ()

/** @property */
public void set_ReceiptLinePrintedCount (int value)

public function get ReceiptLinePrintedCount () : int

public function set ReceiptLinePrintedCount (value : int)

Remarks

Contains the number of receipt lines printed.

ReceiptLinePrintedCount is initialized to 0 (zero) by the PrintResults class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintResults Class
PrintResults Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrintResults.SlipCharacterPrintedCount Property

PrintResults.SlipCharacterPrintedCount Property |
 | See Also

1/18/2008

Contains the number of document/slip characters printed.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property SlipCharacterPrintedCount As Integer
public int SlipCharacterPrintedCount { get; set; }
public:
property int SlipCharacterPrintedCount {
    int get ();
    void set (int value);
}
/** @property */
public int get_SlipCharacterPrintedCount ()

/** @property */
public void set_SlipCharacterPrintedCount (int value)

public function get SlipCharacterPrintedCount () : int

public function set SlipCharacterPrintedCount (value : int)

Remarks

Contains the number of document/slip characters printed.

SlipCharacterPrintedCount is initialized to 0 (zero) by the PrintResults class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintResults Class
PrintResults Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrintResults.SlipLineFeedCount Property

PrintResults.SlipLineFeedCount Property |
 | See Also

1/18/2008

Contains the number of document/slip line feeds performed.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property SlipLineFeedCount As Integer
public int SlipLineFeedCount { get; set; }
public:
property int SlipLineFeedCount {
    int get ();
    void set (int value);
}
/** @property */
public int get_SlipLineFeedCount ()

/** @property */
public void set_SlipLineFeedCount (int value)

public function get SlipLineFeedCount () : int

public function set SlipLineFeedCount (value : int)

Remarks

Contains the number of document/slip line feeds performed.

SlipLineFeedCount is initialized to 0 (zero) by the PrintResults class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintResults Class
PrintResults Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrintResults.SlipLinePrintedCount Property

PrintResults.SlipLinePrintedCount Property |
 | See Also

1/18/2008

Contains the number of document/slip lines printed.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property SlipLinePrintedCount As Integer
public int SlipLinePrintedCount { get; set; }
public:
property int SlipLinePrintedCount {
    int get ();
    void set (int value);
}
/** @property */
public int get_SlipLinePrintedCount ()

/** @property */
public void set_SlipLinePrintedCount (int value)

public function get SlipLinePrintedCount () : int

public function set SlipLinePrintedCount (value : int)

Remarks

Contains the number of document/slip lines printed.

SlipLinePrintedCount is initialized to 0 (zero) by the PrintResults class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintResults Class
PrintResults Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrintResults.StampFiredCount Property

PrintResults.StampFiredCount Property |
 | See Also

1/18/2008

Contains the number of Stamps fired.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property StampFiredCount As Integer
public int StampFiredCount { get; set; }
public:
property int StampFiredCount {
    int get ();
    void set (int value);
}
/** @property */
public int get_StampFiredCount ()

/** @property */
public void set_StampFiredCount (int value)

public function get StampFiredCount () : int

public function set StampFiredCount (value : int)

Remarks

Contains the number of Stamps fired.

StampFiredCount is initialized to 0 (zero) by the PrintResults class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintResults Class
PrintResults Members
Microsoft.PointOfService.BaseServiceObjects Namespace


PrintTwoNormalOperation Class

PrintTwoNormalOperation Class |
 | See Also Members

1/18/2008

The PrintTwoNormalOperation helper class is used by PosPrinterBase to capture information about the PrintTwoNormal method call.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class PrintTwoNormalOperation
    Inherits PrintOperation
public class PrintTwoNormalOperation : PrintOperation
public ref class PrintTwoNormalOperation : public PrintOperation
public class PrintTwoNormalOperation extends PrintOperation
public class PrintTwoNormalOperation extends PrintOperation

Remarks

The PrintTwoNormalOperation helper class derives from the PrintOperation helper class. When the application updates printer properties and then calls the PrintTwoNormal method, the PosPrinterBase class uses an instance of the PrintTwoNormalOperation class, cast to the PrintOperation class and stored in the PrintOperationCollection array, to capture information about that method call. The service object then retrieves the operation from the array and uses it to complete the application’s print request.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BaseServiceObjects.PrintOperation
Microsoft.PointOfService.BaseServiceObjects.PrintTwoNormalOperation

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintTwoNormalOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase Class
PosPrinterBase.PrintTwoNormal Method
PrintOperation Class


PrintTwoNormalOperation Members

PrintTwoNormalOperation Members |
 | See Also Methods Properties

1/18/2008

The PrintTwoNormalOperation helper class is used by PosPrinterBase to capture information about the PrintTwoNormal method call.

The following tables list the members exposed by the PrintTwoNormalOperation type.

Public Properties

Name | Description
AsyncMode | Contains the AsyncMode property setting at the time of the application’s print request. (inherited from PrintOperation)
Data1 | Contains the value of the data1 parameter set when the application made the PrintTwoNormal method call.
Data2 | Contains the value of the data2 parameter set when the application made the PrintTwoNormal method call.
Rotation | Contains the Rotation setting, as defined by the Rotation enumeration. (inherited from PrintOperation)
State | Contains an instance of the PrinterState class, which captures the current printer property values at the time of the application’s print request. (inherited from PrintOperation)
Station | Contains the printer station setting (for example, PrinterStation.Journal). (inherited from PrintOperation)
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

PrintTwoNormalOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase Class
PosPrinterBase.PrintTwoNormal Method
PrintOperation Class


PrintTwoNormalOperation Methods

PrintTwoNormalOperation Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

PrintTwoNormalOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase Class
PosPrinterBase.PrintTwoNormal Method
PrintOperation Class


PrintTwoNormalOperation Properties

PrintTwoNormalOperation Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
AsyncMode | Contains the AsyncMode property setting at the time of the application’s print request. (inherited from PrintOperation )
Data1 | Contains the value of the data1 parameter set when the application made the PrintTwoNormal method call.
Data2 | Contains the value of the data2 parameter set when the application made the PrintTwoNormal method call.
Rotation | Contains the Rotation setting, as defined by the Rotation enumeration. (inherited from PrintOperation )
State | Contains an instance of the PrinterState class, which captures the current printer property values at the time of the application’s print request. (inherited from PrintOperation )
Station | Contains the printer station setting (for example, PrinterStation.Journal). (inherited from PrintOperation )

See Also

Reference

PrintTwoNormalOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase Class
PosPrinterBase.PrintTwoNormal Method
PrintOperation Class


PrintTwoNormalOperation.Data1 Property

PrintTwoNormalOperation.Data1 Property |
 | See Also

1/18/2008

Contains the value of the data1 parameter set when the application made the PrintTwoNormal method call.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Data1 As String
public string Data1 { get; }
public:
property String^ Data1 {
    String^ get ();
}
/** @property */
public String get_Data1 ()

public function get Data1 () : String

Remarks

Contains the value of the data1 parameter set when the application made the PrintTwoNormal method call.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintTwoNormalOperation Class
PrintTwoNormalOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.PrintTwoNormal Method


PrintTwoNormalOperation.Data2 Property

PrintTwoNormalOperation.Data2 Property |
 | See Also

1/18/2008

Contains the value of the data2 parameter set when the application made the PrintTwoNormal method call.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Data2 As String
public string Data2 { get; }
public:
property String^ Data2 {
    String^ get ();
}
/** @property */
public String get_Data2 ()

public function get Data2 () : String

Remarks

Contains the value of the data2 parameter set when the application made the PrintTwoNormal method call.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

PrintTwoNormalOperation Class
PrintTwoNormalOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinter.PrintTwoNormal Method


RFIDDataEventArgs Class

RFIDDataEventArgs Class |
 | See Also Members

1/18/2008

Defines the programmatic interface for the transmission of RFID data events.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class RFIDDataEventArgs
    Inherits DataEventArgs
public class RFIDDataEventArgs : DataEventArgs
public ref class RFIDDataEventArgs : public DataEventArgs
public class RFIDDataEventArgs extends DataEventArgs
public class RFIDDataEventArgs extends DataEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
Microsoft.PointOfService.PosEventArgs
Microsoft.PointOfService.DataEventArgs
Microsoft.PointOfService.BaseServiceObjects.RFIDDataEventArgs

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDDataEventArgs Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDDataEventArgs Members

RFIDDataEventArgs Members |
 | See Also Constructors Fields Methods Properties

1/18/2008

Defines the programmatic interface for the transmission of RFID data events.

The following tables list the members exposed by the RFIDDataEventArgs type.

Public Constructors

Name | Description
RFIDDataEventArgs | Overloaded. Creates an instance of the RFIDDataEventArgs class without defined parameters.
Top

Public Fields

Name | Description
Empty | (inherited from EventArgs )
Top

Public Properties

Name | Description
CurrentTags | Gets the list of current tags.
EventId | Gets the event identifier. (inherited from PosEventArgs)
Status | Gets the integer value for the device input status. (inherited from DataEventArgs)
TimeStamp | Gets the DateTime of the event. (inherited from PosEventArgs)
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the input status. (inherited from DataEventArgs)
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
SetStatus | (inherited from DataEventArgs )
Top

See Also

Reference

RFIDDataEventArgs Class
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDDataEventArgs Fields

RFIDDataEventArgs Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
Empty | (inherited from EventArgs )

See Also

Reference

RFIDDataEventArgs Class
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDDataEventArgs Constructor

RFIDDataEventArgs Constructor |
 | See Also

1/18/2008

Creates an instance of the RFIDDataEventArgs class without defined parameters.

Overload List

Name | Description
RFIDDataEventArgs (Generic ) | Creates an instance of the RFIDDataEventArgs class by using the currentTags parameter.
RFIDDataEventArgs (RFIDTag) | Creates an instance of the RFIDDataEventArgs class by using the tag parameter.
RFIDDataEventArgs (Byte[], Byte[], DateTime) | Creates an instance of the RFIDDataEventArgs class by using the id, data, and time parameters.

See Also

Reference

RFIDDataEventArgs Class
RFIDDataEventArgs Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDDataEventArgs Constructor (Generic )

RFIDDataEventArgs Constructor (Generic ) |
 | See Also

1/18/2008

Creates an instance of the RFIDDataEventArgs class by using the currentTags parameter.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub New ( _
    currentTags As ICollection(Of RFIDTag) _
)
public RFIDDataEventArgs (
    ICollection<RFIDTag> currentTags
)
public:
RFIDDataEventArgs (
    ICollection<RFIDTag^>^ currentTags
)
public RFIDDataEventArgs (
    ICollection<RFIDTag> currentTags
)
public function RFIDDataEventArgs (
    currentTags : ICollection<RFIDTag>
)

Parameters

currentTags

A list of currentTags.

See Also

Reference

RFIDDataEventArgs Class
RFIDDataEventArgs Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDDataEventArgs Constructor (RFIDTag)

RFIDDataEventArgs Constructor (RFIDTag) |
 | See Also

1/18/2008

Creates an instance of the RFIDDataEventArgs class by using the tag parameter.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub New ( _
    tag As RFIDTag _
)
public RFIDDataEventArgs (
    RFIDTag tag
)
public:
RFIDDataEventArgs (
    RFIDTag^ tag
)
public RFIDDataEventArgs (
    RFIDTag tag
)
public function RFIDDataEventArgs (
    tag : RFIDTag
)

Parameters

tag

The tag that contains the ID and userData.

See Also

Reference

RFIDDataEventArgs Class
RFIDDataEventArgs Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDDataEventArgs Constructor (Byte[], Byte[], DateTime)

RFIDDataEventArgs Constructor (Byte[], Byte[], DateTime) |
 | See Also

1/18/2008

Creates an instance of the RFIDDataEventArgs class by using the id, data, and time parameters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub New ( _
    id As Byte(), _
    data As Byte(), _
    time As DateTime _
)
public RFIDDataEventArgs (
    byte[] id,
    byte[] data,
    DateTime time
)
public:
RFIDDataEventArgs (
    array<unsigned char>^ id,
    array<unsigned char>^ data,
    DateTime time
)
public RFIDDataEventArgs (
    byte[] id,
    byte[] data,
    DateTime time
)
public function RFIDDataEventArgs (
    id : byte[],
    data : byte[],
    time : DateTime
)

Parameters

id

The tag ID.

data

The user data contained in the tag.

time

The time when the tag was read.

See Also

Reference

RFIDDataEventArgs Class
RFIDDataEventArgs Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDDataEventArgs Methods

RFIDDataEventArgs Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | Returns a string that represents the input status. (inherited from DataEventArgs )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
SetStatus | (inherited from DataEventArgs )

See Also

Reference

RFIDDataEventArgs Class
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDDataEventArgs Properties

RFIDDataEventArgs Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
CurrentTags | Gets the list of current tags.
EventId | Gets the event identifier. (inherited from PosEventArgs )
Status | Gets the integer value for the device input status. (inherited from DataEventArgs )
TimeStamp | Gets the DateTime of the event. (inherited from PosEventArgs )

See Also

Reference

RFIDDataEventArgs Class
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDDataEventArgs.CurrentTags Property

RFIDDataEventArgs.CurrentTags Property |
 | See Also

1/18/2008

Gets the list of current tags.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property CurrentTags As IList(Of RFIDTag)
public IList<RFIDTag> CurrentTags { get; }
public:
property IList<RFIDTag^>^ CurrentTags {
    IList<RFIDTag^>^ get ();
}
/** @property */
public IList<RFIDTag> get_CurrentTags ()

public function get CurrentTags () : IList<RFIDTag>

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDDataEventArgs Class
RFIDDataEventArgs Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase Class

RFIDScannerBase Class |
 | See Also Members

1/18/2008

Contains most of the functionality for support of RFID Scanner devices.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public MustInherit Class RFIDScannerBase
    Inherits RFIDScannerBasic
public abstract class RFIDScannerBase : RFIDScannerBasic
public ref class RFIDScannerBase abstract : public RFIDScannerBasic
public abstract class RFIDScannerBase extends RFIDScannerBasic
public abstract class RFIDScannerBase extends RFIDScannerBasic

Remarks

The RFIDScannerBase class derives from the RFIDScannerBasic class and contains most of the functionality for support of RFID Scanner devices. When deriving from RFIDScannerBase, service objects should implement the CheckHealth and DirectIO methods.

RFIDScannerBase class provides a protected method, ReadRFIDTags. Service objects should implement this method to perform the actual polling of tags when indicated by the ReadTags method.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.RFIDScanner
Microsoft.PointOfService.BasicServiceObjects.RFIDScannerBasic
Microsoft.PointOfService.BaseServiceObjects.RFIDScannerBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase Members

RFIDScannerBase Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Contains most of the functionality for support of RFID Scanner devices.

The following tables list the members exposed by the RFIDScannerBase type.

Protected Constructors

Name | Description
RFIDScannerBase | Creates an instance of the RFIDScannerBase class.
Top

Public Fields

Name | Description
ExtendedErrorAntennaFailure | Indicates if the RF antenna is in a state of failure. (inherited from RFIDScanner)
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFailedTagDisableCount | Contains the count of failed tag disable attempts. (inherited from RFIDScanner)
StatisticFailedTagLockCount | Contains the count of failed tag lock attempts. (inherited from RFIDScanner)
StatisticFailedTagWriteCount | Contains the count of failed tag write attempts. (inherited from RFIDScanner)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticGoodTagDisableCount | Contains the count of successful tag disable attempts. (inherited from RFIDScanner)
StatisticGoodTagLockCount | Contains the count of successful tag lock attempts. (inherited from RFIDScanner)
StatisticGoodTagWriteCount | Contains the count of successful tag write attempts. (inherited from RFIDScanner)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticTagReadCount | Contains the count of read tags. (inherited from RFIDScanner)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusExcessNoise | Indicates the RFIDScanner device is experiencing excess noise. (inherited from RFIDScanner)
StatusLowMemory | Indicates the RFIDScanner device is low on memory. (inherited from RFIDScanner)
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
AutoDisable | Gets or sets a Boolean value that indicates whether the device automatically disables itself when a DataEvent event is enqueued. (inherited from RFIDScannerBasic)
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from RFIDScannerBasic)
CapContinuousRead | Overridden. Gets a Boolean value that indicates whether the device supports continuous reading.
CapDisableTag | Overridden. Gets a Boolean value that indicates whether the device supports disabling a tag permanently.
CapLockTag | Overridden. Gets a Boolean value that indicates whether this reader supports locking a tag.
CapMultipleProtocols | Overridden. Gets a value that indicates the available predefined RFID tag protocols this device supports.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from RFIDScannerBasic)
CapReadTimer | Overridden. Gets a Boolean value that indicates whether the device supports a read timer.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from RFIDScannerBasic)
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from RFIDScannerBasic)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from RFIDScannerBasic)
CapWriteTag | Overridden. Gets a flag that indicates if the Tag ID and Tag UserData fields are writable.
CheckHealthText | Overridden. Gets the results of the most recent call to the CheckHealth method.
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from RFIDScannerBasic)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
ContinuousReadMode | Overridden. Gets a Boolean value that indicates whether the device is in Continuous Read mode.
CurrentTagId | Overridden. Gets the TagId of the present tag.
CurrentTagProtocol | Overridden. Gets the protocol that this tag was read through.
CurrentTagUserData | Overridden. Gets the data that is read from the physical tag.
DataCount | Gets the number of DataEvent events enqueued by the device. (inherited from RFIDScannerBasic)
DataEventEnabled | Gets or sets a Boolean value that indicates whether the application is ready to receive input from the device. (inherited from RFIDScannerBasic)
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from RFIDScannerBasic)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from RFIDScannerBasic)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from RFIDScannerBasic)
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from RFIDScannerBasic)
OutputId | Gets the integer value that indicates the ID number of the completed asynchronous output request. (inherited from RFIDScannerBasic)
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from RFIDScannerBasic)
PowerState | Gets the current power condition. (inherited from RFIDScannerBasic)
ProtocolMask | Overridden. Gets or sets a bit pattern wherein each bit signifies one predefined RFID tag protocol.
ReadTimerInterval | Overridden. Gets or sets the integer value that indicates the minimum time interval between tag reads in milliseconds.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from RFIDScannerBasic)
ServiceObjectVersion | Gets the Service Object version number. (inherited from RFIDScannerBasic)
State | Gets the current state of the device. (inherited from RFIDScannerBasic)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
TagCount | Overridden. Gets the integer value that indicates the total number of tags read by the corresponding read operation.
Top

Protected Properties

Name | Description
CommonProperties | (inherited from RFIDScannerBasic )
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
ErrorCount | (inherited from RFIDScannerBasic )
ExternallyClaimed | (inherited from RFIDScannerBasic )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Gets a Boolean value that indicates whether the RFIDScanner is an exclusive-use device. (inherited from RFIDScanner)
Properties | Gets the enumerated value of RFIDScannerProperties.
Top

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | Overridden. Indicates the current health status of the device.
Claim | (inherited from RFIDScannerBasic )
ClearInput | Clears the data and input error events. (inherited from RFIDScannerBasic)
ClearInputProperties | Overridden. Clears all data properties and sets them to their default values.
ClearOutput | Clears the data and output error events. (inherited from RFIDScannerBasic)
Close | Releases the device and its resources. (inherited from RFIDScannerBasic)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
DisableTag | (inherited from RFIDScanner )
Dispose | Overloaded. (inherited from RFIDScannerBasic )
Equals | Overloaded. (inherited from Object )
FirstTag | Overridden. Resets the service’s counter to the first tag in the tag list, and copies that tag’s information into the corresponding properties.
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
LockTag | (inherited from RFIDScanner )
NextTag | Overridden. Moves the service’s counter to the next tag in the tag list, and copies that tag’s information into the corresponding properties.
Open | Overridden. Opens a device for later input/output processing.
PreviousTag | Overridden. Moves the service’s counter to the previous tag in the tag list, and copies that tag’s information into the corresponding properties.
ReadTags | Overridden. Begins a poll of all the tags within range that meet the parameterized criteria.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from RFIDScannerBasic)
ResetStatistic | (inherited from RFIDScannerBasic )
ResetStatistics | Overloaded. (inherited from RFIDScannerBasic )
RetrieveStatistic | (inherited from RFIDScannerBasic )
RetrieveStatistics | Overloaded. (inherited from RFIDScannerBasic )
StartReadTags | Overridden. Performs a continuous polling of tags that meet the parameterized criteria.
StopReadTags | Overridden. Stops the Continuous Read mode.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from RFIDScannerBasic )
UpdateStatistics | Overloaded. (inherited from RFIDScannerBasic )
WriteTagData | Overridden. Overwrites the entire or part of the userData field of targeted tag.
WriteTagDataImpl | Overwrites all or partial user data contained in the tag.
WriteTagId | (inherited from RFIDScanner )
Top

Protected Methods

Name | Description
ClearInputImpl | (inherited from RFIDScannerBasic )
ClearOutputImpl | (inherited from RFIDScannerBasic )
CreateStatistic | Overloaded. (inherited from RFIDScannerBasic )
DeleteConfigurationProperty | (inherited from PosCommon )
Dispose | Overloaded. (inherited from RFIDScannerBasic )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
GetStatisticValue | (inherited from RFIDScannerBasic )
IncrementStatistic | Overloaded. (inherited from RFIDScannerBasic )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
PreFireEvent | Overloaded. Overridden.
QueueEvent | Overloaded. (inherited from RFIDScannerBasic )
QueueEventAndWait | Overloaded. (inherited from RFIDScannerBasic )
ReadRFIDTags | Performs a poll of all tags within range that meet the parameterized criteria.
SetConfigurationProperty | (inherited from PosCommon )
SetStatisticHandlers | (inherited from RFIDScannerBasic )
SetStatisticValue | (inherited from RFIDScannerBasic )
VerifyState | (inherited from RFIDScannerBasic )
Top

Public Events (see also Protected Events )

Name | Description
DataEvent | Notifies the application that input data from the RFID Scanner is available. (inherited from RFIDScannerBasic)
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from RFIDScannerBasic)
ErrorEvent | Notifies the application that an RFID Scanner device error has been detected and a suitable response by the application is necessary to process the error condition. (inherited from RFIDScannerBasic)
OutputCompleteEvent | Notifies the application that the queued output request associated with the OutputId attribute has completed successfully. (inherited from RFIDScannerBasic)
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from RFIDScannerBasic)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
StateChangedEvent | (inherited from RFIDScannerBasic )
Top

See Also

Reference

RFIDScannerBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase Fields

RFIDScannerBase Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorAntennaFailure | Indicates if the RF antenna is in a state of failure. (inherited from RFIDScanner )
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFailedTagDisableCount | Contains the count of failed tag disable attempts. (inherited from RFIDScanner )
StatisticFailedTagLockCount | Contains the count of failed tag lock attempts. (inherited from RFIDScanner )
StatisticFailedTagWriteCount | Contains the count of failed tag write attempts. (inherited from RFIDScanner )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticGoodTagDisableCount | Contains the count of successful tag disable attempts. (inherited from RFIDScanner )
StatisticGoodTagLockCount | Contains the count of successful tag lock attempts. (inherited from RFIDScanner )
StatisticGoodTagWriteCount | Contains the count of successful tag write attempts. (inherited from RFIDScanner )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticTagReadCount | Contains the count of read tags. (inherited from RFIDScanner )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusExcessNoise | Indicates the RFIDScanner device is experiencing excess noise. (inherited from RFIDScanner )
StatusLowMemory | Indicates the RFIDScanner device is low on memory. (inherited from RFIDScanner )
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

RFIDScannerBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase Constructor

RFIDScannerBase Constructor |
 | See Also

1/18/2008

Creates an instance of the RFIDScannerBase class.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Sub New
protected RFIDScannerBase ()
protected:
RFIDScannerBase ()
protected RFIDScannerBase ()
protected function RFIDScannerBase ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

RFIDScannerBase Class
RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase Methods

RFIDScannerBase Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | Overridden. Indicates the current health status of the device.
Claim | (inherited from RFIDScannerBasic )
ClearInput | Clears the data and input error events. (inherited from RFIDScannerBasic )
ClearInputProperties | Overridden. Clears all data properties and sets them to their default values.
ClearOutput | Clears the data and output error events. (inherited from RFIDScannerBasic )
Close | Releases the device and its resources. (inherited from RFIDScannerBasic )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
DisableTag | (inherited from RFIDScanner )
Dispose | Overloaded. (inherited from RFIDScannerBasic )
Equals | Overloaded. (inherited from Object )
FirstTag | Overridden. Resets the service’s counter to the first tag in the tag list, and copies that tag’s information into the corresponding properties.
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
LockTag | (inherited from RFIDScanner )
NextTag | Overridden. Moves the service’s counter to the next tag in the tag list, and copies that tag’s information into the corresponding properties.
Open | Overridden. Opens a device for later input/output processing.
PreviousTag | Overridden. Moves the service’s counter to the previous tag in the tag list, and copies that tag’s information into the corresponding properties.
ReadTags | Overridden. Begins a poll of all the tags within range that meet the parameterized criteria.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from RFIDScannerBasic )
ResetStatistic | (inherited from RFIDScannerBasic )
ResetStatistics | Overloaded. (inherited from RFIDScannerBasic )
RetrieveStatistic | (inherited from RFIDScannerBasic )
RetrieveStatistics | Overloaded. (inherited from RFIDScannerBasic )
StartReadTags | Overridden. Performs a continuous polling of tags that meet the parameterized criteria.
StopReadTags | Overridden. Stops the Continuous Read mode.
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from RFIDScannerBasic )
UpdateStatistics | Overloaded. (inherited from RFIDScannerBasic )
WriteTagData | Overridden. Overwrites the entire or part of the userData field of targeted tag.
WriteTagDataImpl | Overwrites all or partial user data contained in the tag.
WriteTagId | (inherited from RFIDScanner )

Protected Methods

Name | Description
ClearInputImpl | (inherited from RFIDScannerBasic )
ClearOutputImpl | (inherited from RFIDScannerBasic )
CreateStatistic | Overloaded. (inherited from RFIDScannerBasic )
DeleteConfigurationProperty | (inherited from PosCommon )
Dispose | Overloaded. (inherited from RFIDScannerBasic )
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
GetStatisticValue | (inherited from RFIDScannerBasic )
IncrementStatistic | Overloaded. (inherited from RFIDScannerBasic )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
PreFireEvent | Overloaded. Overridden.
QueueEvent | Overloaded. (inherited from RFIDScannerBasic )
QueueEventAndWait | Overloaded. (inherited from RFIDScannerBasic )
ReadRFIDTags | Performs a poll of all tags within range that meet the parameterized criteria.
SetConfigurationProperty | (inherited from PosCommon )
SetStatisticHandlers | (inherited from RFIDScannerBasic )
SetStatisticValue | (inherited from RFIDScannerBasic )
VerifyState | (inherited from RFIDScannerBasic )

See Also

Reference

RFIDScannerBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase.CheckHealth Method

RFIDScannerBase.CheckHealth Method |
 | See Also

1/18/2008

Indicates the current health status of the device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Function CheckHealth ( _
    level As HealthCheckLevel _
) As String
public override string CheckHealth (
    HealthCheckLevel level
)
public:
virtual String^ CheckHealth (
    HealthCheckLevel level
) override
public String CheckHealth (
    HealthCheckLevel level
)
public override function CheckHealth (
    level : HealthCheckLevel
) : String

Parameters

level

The type of health check to be performed on the device.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerBase Class
RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase.ClearInputProperties Method

RFIDScannerBase.ClearInputProperties Method |
 | See Also

1/18/2008

Clears all data properties and sets them to their default values.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub ClearInputProperties
public override void ClearInputProperties ()
public:
virtual void ClearInputProperties () override
public void ClearInputProperties ()
public override function ClearInputProperties ()

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerBase Class
RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase.FirstTag Method

RFIDScannerBase.FirstTag Method |
 | See Also

1/18/2008

Resets the service’s counter to the first tag in the tag list, and copies that tag’s information into the corresponding properties.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub FirstTag
public override void FirstTag ()
public:
virtual void FirstTag () override
public void FirstTag ()
public override function FirstTag ()

Remarks

Used if the application has to reprocess the list of tags from its beginning. The method is synchronous, because no physical input or output occurs when it is called.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerBase Class
RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase.NextTag Method

RFIDScannerBase.NextTag Method |
 | See Also

1/18/2008

Moves the service’s counter to the next tag in the tag list, and copies that tag’s information into the corresponding properties.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub NextTag
public override void NextTag ()
public:
virtual void NextTag () override
public void NextTag ()
public override function NextTag ()

Remarks

Used in normal RFID read processing. The method is synchronous, because no physical input or output occurs when it is called, only memory-to-memory copies.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerBase Class
RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase.Open Method

RFIDScannerBase.Open Method |
 | See Also

1/18/2008

Opens a device for later input/output processing.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub Open
public override void Open ()
public:
virtual void Open () override
public void Open ()
public override function Open ()

Remarks

Open initializes statistics reporting and event threads for the specified device. Open also initializes the values of many properties. This includes the DataEventEnabled, FreezeEvents, AutoDisable, Claimed properties and more. For specifics about how these properties are initialized, see the individual properties.

Open may throw a PosControlException with the following values:

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The device is already opened; or

  • The DeviceName property is null or an empty string ("").

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerBase Class
RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosCommon.Close Method


RFIDScannerBase.PreFireEvent Method

RFIDScannerBase.PreFireEvent Method |
 | See Also

1/18/2008

Overload List

Name | Description
RFIDScannerBase.PreFireEvent (DataEventArgs) | Called prior to the delivery of a DataEvent event to the application.
RFIDScannerBase.PreFireEvent (DeviceErrorEventArgs) | (inherited from PreFireEvent )
RFIDScannerBase.PreFireEvent (DirectIOEventArgs) | (inherited from PreFireEvent )
RFIDScannerBase.PreFireEvent (OutputCompleteEventArgs) | (inherited from PreFireEvent )
RFIDScannerBase.PreFireEvent (StatusUpdateEventArgs) | (inherited from PreFireEvent )

See Also

Reference

RFIDScannerBase Class
RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase.PreFireEvent Method (DataEventArgs)

RFIDScannerBase.PreFireEvent Method (DataEventArgs) |
 | See Also

1/18/2008

Called prior to the delivery of a DataEvent event to the application.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overrides Sub PreFireEvent ( _
    posEvent As DataEventArgs _
)
protected override void PreFireEvent (
    DataEventArgs posEvent
)
protected:
virtual void PreFireEvent (
    DataEventArgs^ posEvent
) override
protected void PreFireEvent (
    DataEventArgs posEvent
)
protected override function PreFireEvent (
    posEvent : DataEventArgs
)

Parameters

posEvent

An instance of the DataEventArgs class, posEvent contains the event that was queued to the application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerBase Class
RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase.PreviousTag Method

RFIDScannerBase.PreviousTag Method |
 | See Also

1/18/2008

Moves the service’s counter to the previous tag in the tag list, and copies that tag’s information into the corresponding properties.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub PreviousTag
public override void PreviousTag ()
public:
virtual void PreviousTag () override
public void PreviousTag ()
public override function PreviousTag ()

Remarks

Used if the application has to process the list of tags in reverse order. The method is synchronous, because no physical input or output occurs when it is called, only memory-to-memory copies.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerBase Class
RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase.ReadRFIDTags Method

RFIDScannerBase.ReadRFIDTags Method |
 | See Also

1/18/2008

Performs a poll of all tags within range that meet the parameterized criteria.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overridable Function ReadRFIDTags ( _
    option As RFIDReadOptions, _
    start As Integer, _
    length As Integer, _
    password As Byte() _
) As RFIDTag()
protected virtual RFIDTag[] ReadRFIDTags (
    RFIDReadOptions option,
    int start,
    int length,
    byte[] password
)
protected:
virtual array<RFIDTag^>^ ReadRFIDTags (
    RFIDReadOptions option,
    int start,
    int length,
    array<unsigned char>^ password
)
protected RFIDTag[] ReadRFIDTags (
    RFIDReadOptions option,
    int start,
    int length,
    byte[] password
)
protected function ReadRFIDTags (
    option : RFIDReadOptions,
    start : int,
    length : int,
    password : byte[]
) : RFIDTag[]

Parameters

option

Indicates the enumerated read option from RFIDReadOptions.

start

Indicates the zero-based position within the tags UserData field to begin reading from.

length

Indicates the number of bytes of user data to read starting at the position indicated by the start parameter.

password

Authorized key for reader that might be required for this operation, null if not applicable.

Remarks

Performs the polling process when indicated by the ReadTags method.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerBase Class
RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase.ReadTags Method

RFIDScannerBase.ReadTags Method |
 | See Also

1/18/2008

Begins a poll of all the tags within range that meet the parameterized criteria.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub ReadTags ( _
    cmd As RFIDReadOptions, _
    filterId As Byte(), _
    filterMask As Byte(), _
    start As Integer, _
    length As Integer, _
    timeout As Integer, _
    password As Byte() _
)
public override void ReadTags (
    RFIDReadOptions cmd,
    byte[] filterId,
    byte[] filterMask,
    int start,
    int length,
    int timeout,
    byte[] password
)
public:
virtual void ReadTags (
    RFIDReadOptions cmd,
    array<unsigned char>^ filterId,
    array<unsigned char>^ filterMask,
    int start,
    int length,
    int timeout,
    array<unsigned char>^ password
) override
public void ReadTags (
    RFIDReadOptions cmd,
    byte[] filterId,
    byte[] filterMask,
    int start,
    int length,
    int timeout,
    byte[] password
)
public override function ReadTags (
    cmd : RFIDReadOptions,
    filterId : byte[],
    filterMask : byte[],
    start : int,
    length : int,
    timeout : int,
    password : byte[]
)

Parameters

cmd

Optional command parameters.

filterId

Holds a bit pattern to be AND-ed with filterMask to determine which tag(s) to read.

filterMask

Holds a value which is used to mask the filterID. If the bitwise AND matches the bitwise AND of a tagId and the filterMask, the tagId will be returned. To get all tags in the field, pass in a filterMask of 0.

start

Indicates the zero-based position within the tags UserData field to begin reading from.

length

Indicates the number of bytes of user data to read starting at the position indicated by the start parameter.

timeout

Allowed execution time, in milliseconds, before the method fails and a time-out occurs.

password

Authorized key for reader that might be required for this operation, null if not applicable.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerBase Class
RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase.StartReadTags Method

RFIDScannerBase.StartReadTags Method |
 | See Also

1/18/2008

Performs a continuous polling of tags that meet the parameterized criteria.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub StartReadTags ( _
    cmd As RFIDReadOptions, _
    filterId As Byte(), _
    filterMask As Byte(), _
    start As Integer, _
    length As Integer, _
    password As Byte() _
)
public override void StartReadTags (
    RFIDReadOptions cmd,
    byte[] filterId,
    byte[] filterMask,
    int start,
    int length,
    byte[] password
)
public:
virtual void StartReadTags (
    RFIDReadOptions cmd,
    array<unsigned char>^ filterId,
    array<unsigned char>^ filterMask,
    int start,
    int length,
    array<unsigned char>^ password
) override
public void StartReadTags (
    RFIDReadOptions cmd,
    byte[] filterId,
    byte[] filterMask,
    int start,
    int length,
    byte[] password
)
public override function StartReadTags (
    cmd : RFIDReadOptions,
    filterId : byte[],
    filterMask : byte[],
    start : int,
    length : int,
    password : byte[]
)

Parameters

cmd

Optional command parameters.

filterId

Holds a bit pattern to be AND-ed with filterMask to determine which tag(s) to read.

filterMask

Holds a value which is used to mask the filterID. If the bitwise AND matches the bitwise AND of a tagId and the filterMask, the tagId will be returned. To get all tags in the field, pass in a filterMask of 0.

start

Indicates the zero-based position within the tags UserData field to begin reading from.

length

Indicates the number of bytes of user data to read starting at the position indicated by the start parameter.

password

Authorized key for reader that might be required for this operation, null if not applicable.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerBase Class
RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase.StopReadTags Method

RFIDScannerBase.StopReadTags Method |
 | See Also

1/18/2008

Stops the Continuous Read mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub StopReadTags ( _
    password As Byte() _
)
public override void StopReadTags (
    byte[] password
)
public:
virtual void StopReadTags (
    array<unsigned char>^ password
) override
public void StopReadTags (
    byte[] password
)
public override function StopReadTags (
    password : byte[]
)

Parameters

password

Authorized key for reader that might be required for this operation, null if not applicable.

Remarks

All read-only properties because of Continuous Read mode are writable again. Invoking this method when it is not in Continuous Read mode throws an exception.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerBase Class
RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase.WriteTagData Method

RFIDScannerBase.WriteTagData Method |
 | See Also

1/18/2008

Overwrites the entire or part of the userData field of targeted tag.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub WriteTagData ( _
    tagId As Byte(), _
    userData As Byte(), _
    start As Integer, _
    timeout As Integer, _
    password As Byte() _
)
public override void WriteTagData (
    byte[] tagId,
    byte[] userData,
    int start,
    int timeout,
    byte[] password
)
public:
virtual void WriteTagData (
    array<unsigned char>^ tagId,
    array<unsigned char>^ userData,
    int start,
    int timeout,
    array<unsigned char>^ password
) override
public void WriteTagData (
    byte[] tagId,
    byte[] userData,
    int start,
    int timeout,
    byte[] password
)
public override function WriteTagData (
    tagId : byte[],
    userData : byte[],
    start : int,
    timeout : int,
    password : byte[]
)

Parameters

tagId

ID of the tag whose user data it is writing to.

userData

User data to be written.

start

Indicates the zero-based position within the tags userData field to begin writing to.

timeout

Allowed execution time, in milliseconds, before the method fails and a timeout occurs.

password

Authorized key for reader that might be required for this operation, null if not applicable.

Remarks

Application should query the CapWriteTag property before calling WriteTagData.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerBase Class
RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase.WriteTagDataImpl Method

RFIDScannerBase.WriteTagDataImpl Method |
 | See Also

1/18/2008

Overwrites all or partial user data contained in the tag.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public MustOverride Sub WriteTagDataImpl ( _
    tagId As Byte(), _
    userData As Byte(), _
    start As Integer, _
    timeout As Integer, _
    password As Byte(), _
    startTime As DateTime _
)
public abstract void WriteTagDataImpl (
    byte[] tagId,
    byte[] userData,
    int start,
    int timeout,
    byte[] password,
    DateTime startTime
)
public:
virtual void WriteTagDataImpl (
    array<unsigned char>^ tagId,
    array<unsigned char>^ userData,
    int start,
    int timeout,
    array<unsigned char>^ password,
    DateTime startTime
) abstract
public abstract void WriteTagDataImpl (
    byte[] tagId,
    byte[] userData,
    int start,
    int timeout,
    byte[] password,
    DateTime startTime
)
public abstract function WriteTagDataImpl (
    tagId : byte[],
    userData : byte[],
    start : int,
    timeout : int,
    password : byte[],
    startTime : DateTime
)

Parameters

tagId

ID of the tag whose user data it is writing to.

userData

User data to be written.

start

Indicates the zero-based position within the tags userData field to begin writing to.

timeout

Allowed execution time, in milliseconds, before the method fails and a timeout occurs.

password

Authorized key for reader that might be required for this operation, null if not applicable.

startTime

Indicates the time to start writing data to the tag.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerBase Class
RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase Properties

RFIDScannerBase Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
AutoDisable | Gets or sets a Boolean value that indicates whether the device automatically disables itself when a DataEvent event is enqueued. (inherited from RFIDScannerBasic )
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from RFIDScannerBasic )
CapContinuousRead | Overridden. Gets a Boolean value that indicates whether the device supports continuous reading.
CapDisableTag | Overridden. Gets a Boolean value that indicates whether the device supports disabling a tag permanently.
CapLockTag | Overridden. Gets a Boolean value that indicates whether this reader supports locking a tag.
CapMultipleProtocols | Overridden. Gets a value that indicates the available predefined RFID tag protocols this device supports.
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from RFIDScannerBasic )
CapReadTimer | Overridden. Gets a Boolean value that indicates whether the device supports a read timer.
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from RFIDScannerBasic )
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from RFIDScannerBasic )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from RFIDScannerBasic )
CapWriteTag | Overridden. Gets a flag that indicates if the Tag ID and Tag UserData fields are writable.
CheckHealthText | Overridden. Gets the results of the most recent call to the CheckHealth method.
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from RFIDScannerBasic )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
ContinuousReadMode | Overridden. Gets a Boolean value that indicates whether the device is in Continuous Read mode.
CurrentTagId | Overridden. Gets the TagId of the present tag.
CurrentTagProtocol | Overridden. Gets the protocol that this tag was read through.
CurrentTagUserData | Overridden. Gets the data that is read from the physical tag.
DataCount | Gets the number of DataEvent events enqueued by the device. (inherited from RFIDScannerBasic )
DataEventEnabled | Gets or sets a Boolean value that indicates whether the application is ready to receive input from the device. (inherited from RFIDScannerBasic )
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from RFIDScannerBasic )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from RFIDScannerBasic )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from RFIDScannerBasic )
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from RFIDScannerBasic )
OutputId | Gets the integer value that indicates the ID number of the completed asynchronous output request. (inherited from RFIDScannerBasic )
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from RFIDScannerBasic )
PowerState | Gets the current power condition. (inherited from RFIDScannerBasic )
ProtocolMask | Overridden. Gets or sets a bit pattern wherein each bit signifies one predefined RFID tag protocol.
ReadTimerInterval | Overridden. Gets or sets the integer value that indicates the minimum time interval between tag reads in milliseconds.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from RFIDScannerBasic )
ServiceObjectVersion | Gets the Service Object version number. (inherited from RFIDScannerBasic )
State | Gets the current state of the device. (inherited from RFIDScannerBasic )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )
TagCount | Overridden. Gets the integer value that indicates the total number of tags read by the corresponding read operation.

Protected Properties

Name | Description
CommonProperties | (inherited from RFIDScannerBasic )
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
ErrorCount | (inherited from RFIDScannerBasic )
ExternallyClaimed | (inherited from RFIDScannerBasic )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Gets a Boolean value that indicates whether the RFIDScanner is an exclusive-use device. (inherited from RFIDScanner )
Properties | Gets the enumerated value of RFIDScannerProperties.

See Also

Reference

RFIDScannerBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase.CapContinuousRead Property

RFIDScannerBase.CapContinuousRead Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device supports continuous reading.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapContinuousRead As Boolean
public override bool CapContinuousRead { get; }
public:
virtual property bool CapContinuousRead {
    bool get () override;
}
/** @property */
public boolean get_CapContinuousRead ()

public override function get CapContinuousRead () : boolean

Remarks

The Boolean value of true indicates that the device supports continuous reading.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerBase Class
RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase.CapDisableTag Property

RFIDScannerBase.CapDisableTag Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device supports disabling a tag permanently.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapDisableTag As Boolean
public override bool CapDisableTag { get; }
public:
virtual property bool CapDisableTag {
    bool get () override;
}
/** @property */
public boolean get_CapDisableTag ()

public override function get CapDisableTag () : boolean

Remarks

The Boolean value of true indicates that the device supports disabling a tag permanently.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerBase Class
RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase.CapLockTag Property

RFIDScannerBase.CapLockTag Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether this reader supports locking a tag.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapLockTag As Boolean
public override bool CapLockTag { get; }
public:
virtual property bool CapLockTag {
    bool get () override;
}
/** @property */
public boolean get_CapLockTag ()

public override function get CapLockTag () : boolean

Remarks

The Boolean value of true indicates that the device supports locking a tag.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerBase Class
RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase.CapMultipleProtocols Property

RFIDScannerBase.CapMultipleProtocols Property |
 | See Also

1/18/2008

Gets a value that indicates the available predefined RFID tag protocols this device supports.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapMultipleProtocols As RFIDProtocols
public override RFIDProtocols CapMultipleProtocols { get; }
public:
virtual property RFIDProtocols CapMultipleProtocols {
    RFIDProtocols get () override;
}
/** @property */
public RFIDProtocols get_CapMultipleProtocols ()

public override function get CapMultipleProtocols () : RFIDProtocols

Remarks

If the device supports more than one of these protocols, the value of this property is the bitwise sum of the values of the supported protocols.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerBase Class
RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase.CapReadTimer Property

RFIDScannerBase.CapReadTimer Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device supports a read timer.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapReadTimer As Boolean
public override bool CapReadTimer { get; }
public:
virtual property bool CapReadTimer {
    bool get () override;
}
/** @property */
public boolean get_CapReadTimer ()

public override function get CapReadTimer () : boolean

Remarks

The Boolean value of true indicates that the device supports a read timer.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerBase Class
RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase.CapWriteTag Property

RFIDScannerBase.CapWriteTag Property |
 | See Also

1/18/2008

Gets a flag that indicates if the Tag ID and Tag UserData fields are writable.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CapWriteTag As WriteTagSections
public override WriteTagSections CapWriteTag { get; }
public:
virtual property WriteTagSections CapWriteTag {
    WriteTagSections get () override;
}
/** @property */
public WriteTagSections get_CapWriteTag ()

public override function get CapWriteTag () : WriteTagSections

Remarks

The value of this property indicates only the write capability of the device and does not imply the write ability of any specific tag. The application should query this property before invoking writing methods.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerBase Class
RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase.CheckHealthText Property

RFIDScannerBase.CheckHealthText Property |
 | See Also

1/18/2008

Gets the results of the most recent call to the CheckHealth method.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CheckHealthText As String
public override string CheckHealthText { get; }
public:
virtual property String^ CheckHealthText {
    String^ get () override;
}
/** @property */
public String get_CheckHealthText ()

public override function get CheckHealthText () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerBase Class
RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase.ContinuousReadMode Property

RFIDScannerBase.ContinuousReadMode Property |
 | See Also

1/18/2008

Gets a Boolean value that indicates whether the device is in Continuous Read mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property ContinuousReadMode As Boolean
public override bool ContinuousReadMode { get; }
public:
virtual property bool ContinuousReadMode {
    bool get () override;
}
/** @property */
public boolean get_ContinuousReadMode ()

public override function get ContinuousReadMode () : boolean

Remarks

The Boolean value of true indicates that the device is in Continuous Read mode.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerBase Class
RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase.CurrentTagId Property

RFIDScannerBase.CurrentTagId Property |
 | See Also

1/18/2008

Gets the TagId of the present tag.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CurrentTagId As Byte()
public override byte[] CurrentTagId { get; }
public:
virtual property array<unsigned char>^ CurrentTagId {
    array<unsigned char>^ get () override;
}
/** @property */
public byte[] get_CurrentTagId ()

public override function get CurrentTagId () : byte[]

Remarks

Just before a DataEvent event is delivered, the service populates this property with data from the first tag that was read.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerBase Class
RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase.CurrentTagProtocol Property

RFIDScannerBase.CurrentTagProtocol Property |
 | See Also

1/18/2008

Gets the protocol that this tag was read through.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CurrentTagProtocol As RFIDProtocols
public override RFIDProtocols CurrentTagProtocol { get; }
public:
virtual property RFIDProtocols CurrentTagProtocol {
    RFIDProtocols get () override;
}
/** @property */
public RFIDProtocols get_CurrentTagProtocol ()

public override function get CurrentTagProtocol () : RFIDProtocols

Remarks

The value here should match one of the selections in the ProtocolMask property. This property may be updated by the service for each tag.

Just before a DataEvent event is delivered, the service populates this property with data from the first tag that was read.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerBase Class
RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase.CurrentTagUserData Property

RFIDScannerBase.CurrentTagUserData Property |
 | See Also

1/18/2008

Gets the data that is read from the physical tag.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property CurrentTagUserData As Byte()
public override byte[] CurrentTagUserData { get; }
public:
virtual property array<unsigned char>^ CurrentTagUserData {
    array<unsigned char>^ get () override;
}
/** @property */
public byte[] get_CurrentTagUserData ()

public override function get CurrentTagUserData () : byte[]

Remarks

A partial or complete read will populate CurrentTagUserData with the targeted segment.

Just before a DataEventEnabled property is delivered, the service populates this property with data from the first tag that was read.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerBase Class
RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase.Properties Property

RFIDScannerBase.Properties Property |
 | See Also

1/18/2008

Gets the enumerated value of RFIDScannerProperties.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected ReadOnly Property Properties As RFIDScannerProperties
protected RFIDScannerProperties Properties { get; }
protected:
property RFIDScannerProperties^ Properties {
    RFIDScannerProperties^ get ();
}
/** @property */
protected RFIDScannerProperties get_Properties ()

protected function get Properties () : RFIDScannerProperties

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerBase Class
RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase.ProtocolMask Property

RFIDScannerBase.ProtocolMask Property |
 | See Also

1/18/2008

Gets or sets a bit pattern wherein each bit signifies one predefined RFID tag protocol.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property ProtocolMask As RFIDProtocols
public override RFIDProtocols ProtocolMask { get; set; }
public:
virtual property RFIDProtocols ProtocolMask {
    RFIDProtocols get () override;
    void set (RFIDProtocols value) override;
}
/** @property */
public RFIDProtocols get_ProtocolMask ()

/** @property */
public void set_ProtocolMask (RFIDProtocols value)

public override function get ProtocolMask () : RFIDProtocols

public override function set ProtocolMask (value : RFIDProtocols)

Remarks

The nonzero bit entries indicate protocols for which the read is requested. Only tags of the specified protocol type are read. If the reader is in Continuous Read mode, this property is read-only.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerBase Class
RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase.ReadTimerInterval Property

RFIDScannerBase.ReadTimerInterval Property |
 | See Also

1/18/2008

Gets or sets the integer value that indicates the minimum time interval between tag reads in milliseconds.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property ReadTimerInterval As Integer
public override int ReadTimerInterval { get; set; }
public:
virtual property int ReadTimerInterval {
    int get () override;
    void set (int value) override;
}
/** @property */
public int get_ReadTimerInterval ()

/** @property */
public void set_ReadTimerInterval (int value)

public override function get ReadTimerInterval () : int

public override function set ReadTimerInterval (value : int)

Remarks

This property only applies to continuous reading. A value of zero indicates no delay between reads. The value of this property is zero if the CapReadTimer property is false. Attempts to set this property when the CapReadTimer property is false or when the ContinuousReadMode property set to true will throw an exception.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerBase Class
RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase.TagCount Property

RFIDScannerBase.TagCount Property |
 | See Also

1/18/2008

Gets the integer value that indicates the total number of tags read by the corresponding read operation.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property TagCount As Integer
public override int TagCount { get; }
public:
virtual property int TagCount {
    int get () override;
}
/** @property */
public int get_TagCount ()

public override function get TagCount () : int

Remarks

The service populates this property only before a DataEvent event is delivered to the application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerBase Class
RFIDScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerBase Events

RFIDScannerBase Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DataEvent | Notifies the application that input data from the RFID Scanner is available. (inherited from RFIDScannerBasic )
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from RFIDScannerBasic )
ErrorEvent | Notifies the application that an RFID Scanner device error has been detected and a suitable response by the application is necessary to process the error condition. (inherited from RFIDScannerBasic )
OutputCompleteEvent | Notifies the application that the queued output request associated with the OutputId attribute has completed successfully. (inherited from RFIDScannerBasic )
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from RFIDScannerBasic )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
StateChangedEvent | (inherited from RFIDScannerBasic )

See Also

Reference

RFIDScannerBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerProperties Class

RFIDScannerProperties Class |
 | See Also Members

1/18/2008

Defines the common properties of the RFID Scanner device.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class RFIDScannerProperties
    Inherits CommonProperties
public class RFIDScannerProperties : CommonProperties
public ref class RFIDScannerProperties : public CommonProperties
public class RFIDScannerProperties extends CommonProperties
public class RFIDScannerProperties extends CommonProperties

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BasicServiceObjects.CommonProperties
Microsoft.PointOfService.BaseServiceObjects.RFIDScannerProperties

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerProperties Members

RFIDScannerProperties Members |
 | See Also Methods Properties

1/18/2008

Defines the common properties of the RFID Scanner device.

The following tables list the members exposed by the RFIDScannerProperties type.

Public Properties

Name | Description
CapCompareFirmwareVersion | (inherited from CommonProperties )
CapContinuousRead | Gets or sets a Boolean value that indicates whether the device supports the Continuous Read mode.
CapDisableTag | Gets or sets a Boolean value that indicates whether the device supports disabling a tag permanently.
CapLockTag | Gets or sets a Boolean value that indicates whether this reader supports locking a tag.
CapMultipleProtocols | Gets or sets a value that indicates the available predefined RFID tag protocols this device supports.
CapPowerReporting | (inherited from CommonProperties )
CapReadTimer | Gets or sets a Boolean value that indicates whether the device supports a read timer.
CapStatisticsReporting | (inherited from CommonProperties )
CapUpdateFirmware | (inherited from CommonProperties )
CapUpdateStatistics | (inherited from CommonProperties )
CapWriteTag | Gets or sets the number of writable fields in the tag.
ContinuousReadMode | Gets or sets a Boolean value that indicates whether the device is in Continuous Read mode.
CurrentTagId | Gets or sets the ID of the present tag.
CurrentTagProtocol | Gets or sets the protocol through which the tag was read.
CurrentTagUserData | Gets or sets the data that is read from the physical tag.
DeviceDescription | (inherited from CommonProperties )
DeviceName | (inherited from CommonProperties )
PowerState | (inherited from CommonProperties )
ProtocolMask | Gets or sets a bit pattern wherein each bit signifies one predefined RFID tag protocol.
ReadTimerInterval | Gets or sets the integer value that indicates the minimum time interval between tag reads in milliseconds.
ServiceObjectDescription | (inherited from CommonProperties )
ServiceObjectVersion | (inherited from CommonProperties )
State | (inherited from CommonProperties )
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

RFIDScannerProperties Class
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerProperties Methods

RFIDScannerProperties Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

RFIDScannerProperties Class
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerProperties Properties

RFIDScannerProperties Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
CapCompareFirmwareVersion | (inherited from CommonProperties )
CapContinuousRead | Gets or sets a Boolean value that indicates whether the device supports the Continuous Read mode.
CapDisableTag | Gets or sets a Boolean value that indicates whether the device supports disabling a tag permanently.
CapLockTag | Gets or sets a Boolean value that indicates whether this reader supports locking a tag.
CapMultipleProtocols | Gets or sets a value that indicates the available predefined RFID tag protocols this device supports.
CapPowerReporting | (inherited from CommonProperties )
CapReadTimer | Gets or sets a Boolean value that indicates whether the device supports a read timer.
CapStatisticsReporting | (inherited from CommonProperties )
CapUpdateFirmware | (inherited from CommonProperties )
CapUpdateStatistics | (inherited from CommonProperties )
CapWriteTag | Gets or sets the number of writable fields in the tag.
ContinuousReadMode | Gets or sets a Boolean value that indicates whether the device is in Continuous Read mode.
CurrentTagId | Gets or sets the ID of the present tag.
CurrentTagProtocol | Gets or sets the protocol through which the tag was read.
CurrentTagUserData | Gets or sets the data that is read from the physical tag.
DeviceDescription | (inherited from CommonProperties )
DeviceName | (inherited from CommonProperties )
PowerState | (inherited from CommonProperties )
ProtocolMask | Gets or sets a bit pattern wherein each bit signifies one predefined RFID tag protocol.
ReadTimerInterval | Gets or sets the integer value that indicates the minimum time interval between tag reads in milliseconds.
ServiceObjectDescription | (inherited from CommonProperties )
ServiceObjectVersion | (inherited from CommonProperties )
State | (inherited from CommonProperties )

See Also

Reference

RFIDScannerProperties Class
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerProperties.CapContinuousRead Property

RFIDScannerProperties.CapContinuousRead Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether the device supports the Continuous Read mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapContinuousRead As Boolean
public bool CapContinuousRead { get; set; }
public:
property bool CapContinuousRead {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapContinuousRead ()

/** @property */
public void set_CapContinuousRead (boolean value)

public function get CapContinuousRead () : boolean

public function set CapContinuousRead (value : boolean)

Remarks

The Boolean value of true indicates that the device supports the Continuous Read mode.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerProperties Class
RFIDScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerProperties.CapDisableTag Property

RFIDScannerProperties.CapDisableTag Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether the device supports disabling a tag permanently.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapDisableTag As Boolean
public bool CapDisableTag { get; set; }
public:
property bool CapDisableTag {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapDisableTag ()

/** @property */
public void set_CapDisableTag (boolean value)

public function get CapDisableTag () : boolean

public function set CapDisableTag (value : boolean)

Remarks

The Boolean value of true indicates that the device supports disabling a tag permanently.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerProperties Class
RFIDScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerProperties.CapLockTag Property

RFIDScannerProperties.CapLockTag Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether this reader supports locking a tag.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapLockTag As Boolean
public bool CapLockTag { get; set; }
public:
property bool CapLockTag {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapLockTag ()

/** @property */
public void set_CapLockTag (boolean value)

public function get CapLockTag () : boolean

public function set CapLockTag (value : boolean)

Remarks

The Boolean value of true indicates that the device supports locking a tag.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerProperties Class
RFIDScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerProperties.CapMultipleProtocols Property

RFIDScannerProperties.CapMultipleProtocols Property |
 | See Also

1/18/2008

Gets or sets a value that indicates the available predefined RFID tag protocols this device supports.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapMultipleProtocols As RFIDProtocols
public RFIDProtocols CapMultipleProtocols { get; set; }
public:
property RFIDProtocols CapMultipleProtocols {
    RFIDProtocols get ();
    void set (RFIDProtocols value);
}
/** @property */
public RFIDProtocols get_CapMultipleProtocols ()

/** @property */
public void set_CapMultipleProtocols (RFIDProtocols value)

public function get CapMultipleProtocols () : RFIDProtocols

public function set CapMultipleProtocols (value : RFIDProtocols)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerProperties Class
RFIDScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerProperties.CapReadTimer Property

RFIDScannerProperties.CapReadTimer Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether the device supports a read timer.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapReadTimer As Boolean
public bool CapReadTimer { get; set; }
public:
property bool CapReadTimer {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_CapReadTimer ()

/** @property */
public void set_CapReadTimer (boolean value)

public function get CapReadTimer () : boolean

public function set CapReadTimer (value : boolean)

Remarks

The Boolean value of true indicates that the device supports a read timer.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerProperties Class
RFIDScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerProperties.CapWriteTag Property

RFIDScannerProperties.CapWriteTag Property |
 | See Also

1/18/2008

Gets or sets the number of writable fields in the tag.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CapWriteTag As WriteTagSections
public WriteTagSections CapWriteTag { get; set; }
public:
property WriteTagSections CapWriteTag {
    WriteTagSections get ();
    void set (WriteTagSections value);
}
/** @property */
public WriteTagSections get_CapWriteTag ()

/** @property */
public void set_CapWriteTag (WriteTagSections value)

public function get CapWriteTag () : WriteTagSections

public function set CapWriteTag (value : WriteTagSections)

Remarks

The value of this property indicates only the write capability of the device and does not imply the write ability of any specific tag. The application should query this property before invoking writing methods.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerProperties Class
RFIDScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerProperties.ContinuousReadMode Property

RFIDScannerProperties.ContinuousReadMode Property |
 | See Also

1/18/2008

Gets or sets a Boolean value that indicates whether the device is in Continuous Read mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property ContinuousReadMode As Boolean
public bool ContinuousReadMode { get; set; }
public:
property bool ContinuousReadMode {
    bool get ();
    void set (bool value);
}
/** @property */
public boolean get_ContinuousReadMode ()

/** @property */
public void set_ContinuousReadMode (boolean value)

public function get ContinuousReadMode () : boolean

public function set ContinuousReadMode (value : boolean)

Remarks

The Boolean value of true indicates that the device is in Continuous Read mode.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerProperties Class
RFIDScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerProperties.CurrentTagId Property

RFIDScannerProperties.CurrentTagId Property |
 | See Also

1/18/2008

Gets or sets the ID of the present tag.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CurrentTagId As Byte()
public byte[] CurrentTagId { get; set; }
public:
property array<unsigned char>^ CurrentTagId {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
/** @property */
public byte[] get_CurrentTagId ()

/** @property */
public void set_CurrentTagId (byte[] value)

public function get CurrentTagId () : byte[]

public function set CurrentTagId (value : byte[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerProperties Class
RFIDScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerProperties.CurrentTagProtocol Property

RFIDScannerProperties.CurrentTagProtocol Property |
 | See Also

1/18/2008

Gets or sets the protocol through which the tag was read.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CurrentTagProtocol As RFIDProtocols
public RFIDProtocols CurrentTagProtocol { get; set; }
public:
property RFIDProtocols CurrentTagProtocol {
    RFIDProtocols get ();
    void set (RFIDProtocols value);
}
/** @property */
public RFIDProtocols get_CurrentTagProtocol ()

/** @property */
public void set_CurrentTagProtocol (RFIDProtocols value)

public function get CurrentTagProtocol () : RFIDProtocols

public function set CurrentTagProtocol (value : RFIDProtocols)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerProperties Class
RFIDScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerProperties.CurrentTagUserData Property

RFIDScannerProperties.CurrentTagUserData Property |
 | See Also

1/18/2008

Gets or sets the data that is read from the physical tag.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property CurrentTagUserData As Byte()
public byte[] CurrentTagUserData { get; set; }
public:
property array<unsigned char>^ CurrentTagUserData {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
/** @property */
public byte[] get_CurrentTagUserData ()

/** @property */
public void set_CurrentTagUserData (byte[] value)

public function get CurrentTagUserData () : byte[]

public function set CurrentTagUserData (value : byte[])

Remarks

If it is a partial read, it populates it with the targeted segment.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerProperties Class
RFIDScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerProperties.ProtocolMask Property

RFIDScannerProperties.ProtocolMask Property |
 | See Also

1/18/2008

Gets or sets a bit pattern wherein each bit signifies one predefined RFID tag protocol.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property ProtocolMask As RFIDProtocols
public RFIDProtocols ProtocolMask { get; set; }
public:
property RFIDProtocols ProtocolMask {
    RFIDProtocols get ();
    void set (RFIDProtocols value);
}
/** @property */
public RFIDProtocols get_ProtocolMask ()

/** @property */
public void set_ProtocolMask (RFIDProtocols value)

public function get ProtocolMask () : RFIDProtocols

public function set ProtocolMask (value : RFIDProtocols)

Remarks

The nonzero bit entries indicate protocols for which the read is requested. Only tags of the specified protocol type are read. If the reader is in Continuous Read mode, this property is read-only.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerProperties Class
RFIDScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDScannerProperties.ReadTimerInterval Property

RFIDScannerProperties.ReadTimerInterval Property |
 | See Also

1/18/2008

Gets or sets the integer value that indicates the minimum time interval between tag reads in milliseconds.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property ReadTimerInterval As Integer
public int ReadTimerInterval { get; set; }
public:
property int ReadTimerInterval {
    int get ();
    void set (int value);
}
/** @property */
public int get_ReadTimerInterval ()

/** @property */
public void set_ReadTimerInterval (int value)

public function get ReadTimerInterval () : int

public function set ReadTimerInterval (value : int)

Remarks

This property only applies when in Continuous Read mode. A value of zero indicates no delay between reads.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDScannerProperties Class
RFIDScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDTag Class

RFIDTag Class |
 | See Also Members

1/18/2008

A helper class created by POS for .NET and used by RFIDScannerBase class for handling RFID tags.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class RFIDTag
    Implements ICloneable
public class RFIDTag : ICloneable
public ref class RFIDTag : ICloneable
public class RFIDTag implements ICloneable
public class RFIDTag implements ICloneable

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BaseServiceObjects.RFIDTag

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDTag Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDTag Members

RFIDTag Members |
 | See Also Constructors Methods Properties

1/18/2008

A helper class created by POS for .NET and used by RFIDScannerBase class for handling RFID tags.

The following tables list the members exposed by the RFIDTag type.

Public Constructors

Name | Description
RFIDTag | Overloaded. Creates an instance of the RFIDTag class.
Top

Public Properties

Name | Description
Protocol | Gets or sets the list of supported protocols that are used to communicate with the tag reader.
TagData | Gets or sets the user data contained in the tag.
TagId | Gets or sets the ID of the tag.
Timestamp | Gets or sets the time that the tag was read.
Top

Public Methods (see also Protected Methods )

Name | Description
Clone | Creates a RFIDTag object that is identical to the current RFIDTag object.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

RFIDTag Class
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDTag Constructor

RFIDTag Constructor |
 | See Also

1/18/2008

Creates an instance of the RFIDTag class.

Overload List

Name | Description
RFIDTag () | Creates an instance of the RFIDTag class.
RFIDTag (Byte[]) | Creates an instance of the RFIDTag class and initializes the id parameter.
RFIDTag (RFIDTag) | Creates a new instance of the RFIDTag class and initializes it with the fields from the specified RFIDTag.
RFIDTag (Byte[], Byte[]) | Creates an instance of the RFIDTag class and initializes the id and data parameters.
RFIDTag (Byte[], DateTime) | Creates an instance of the RFIDTag class and initializes the id and time parameters.
RFIDTag (Byte[], Byte[], DateTime) | Creates an instance of the RFIDTag class and initializes the id, data, and time parameters.

See Also

Reference

RFIDTag Class
RFIDTag Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDTag Constructor ()

RFIDTag Constructor () |
 | See Also

1/18/2008

Creates an instance of the RFIDTag class.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub New
public RFIDTag ()
public:
RFIDTag ()
public RFIDTag ()
public function RFIDTag ()

Remarks

The default constructor initializes any fields to their default values.

See Also

Reference

RFIDTag Class
RFIDTag Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDTag Constructor (Byte[])

RFIDTag Constructor (Byte[]) |
 | See Also

1/18/2008

Creates an instance of the RFIDTag class and initializes the id parameter.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub New ( _
    id As Byte() _
)
public RFIDTag (
    byte[] id
)
public:
RFIDTag (
    array<unsigned char>^ id
)
public RFIDTag (
    byte[] id
)
public function RFIDTag (
    id : byte[]
)

Parameters

id

The tag ID.

See Also

Reference

RFIDTag Class
RFIDTag Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDTag Constructor (RFIDTag)

RFIDTag Constructor (RFIDTag) |
 | See Also

1/18/2008

Creates a new instance of the RFIDTag class and initializes it with the fields from the specified RFIDTag.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub New ( _
    tag As RFIDTag _
)
public RFIDTag (
    RFIDTag tag
)
public:
RFIDTag (
    RFIDTag^ tag
)
public RFIDTag (
    RFIDTag tag
)
public function RFIDTag (
    tag : RFIDTag
)

Parameters

tag

The data in the tag's fields.

See Also

Reference

RFIDTag Class
RFIDTag Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDTag Constructor (Byte[], Byte[])

RFIDTag Constructor (Byte[], Byte[]) |
 | See Also

1/18/2008

Creates an instance of the RFIDTag class and initializes the id and data parameters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub New ( _
    id As Byte(), _
    data As Byte() _
)
public RFIDTag (
    byte[] id,
    byte[] data
)
public:
RFIDTag (
    array<unsigned char>^ id,
    array<unsigned char>^ data
)
public RFIDTag (
    byte[] id,
    byte[] data
)
public function RFIDTag (
    id : byte[],
    data : byte[]
)

Parameters

id

The tag ID.

data

The user data contained in the tag.

See Also

Reference

RFIDTag Class
RFIDTag Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDTag Constructor (Byte[], DateTime)

RFIDTag Constructor (Byte[], DateTime) |
 | See Also

1/18/2008

Creates an instance of the RFIDTag class and initializes the id and time parameters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub New ( _
    id As Byte(), _
    time As DateTime _
)
public RFIDTag (
    byte[] id,
    DateTime time
)
public:
RFIDTag (
    array<unsigned char>^ id,
    DateTime time
)
public RFIDTag (
    byte[] id,
    DateTime time
)
public function RFIDTag (
    id : byte[],
    time : DateTime
)

Parameters

id

The tag ID.

time

The time when the tag was read.

See Also

Reference

RFIDTag Class
RFIDTag Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDTag Constructor (Byte[], Byte[], DateTime)

RFIDTag Constructor (Byte[], Byte[], DateTime) |
 | See Also

1/18/2008

Creates an instance of the RFIDTag class and initializes the id, data, and time parameters.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Sub New ( _
    id As Byte(), _
    data As Byte(), _
    time As DateTime _
)
public RFIDTag (
    byte[] id,
    byte[] data,
    DateTime time
)
public:
RFIDTag (
    array<unsigned char>^ id,
    array<unsigned char>^ data,
    DateTime time
)
public RFIDTag (
    byte[] id,
    byte[] data,
    DateTime time
)
public function RFIDTag (
    id : byte[],
    data : byte[],
    time : DateTime
)

Parameters

id

The tag ID.

data

The user data contained in the tag.

time

The time when the tag was read.

See Also

Reference

RFIDTag Class
RFIDTag Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDTag Methods

RFIDTag Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Clone | Creates a RFIDTag object that is identical to the current RFIDTag object.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

RFIDTag Class
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDTag.Clone Method

RFIDTag.Clone Method |
 | See Also

1/18/2008

Creates a RFIDTag object that is identical to the current RFIDTag object.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Function Clone As Object
public Object Clone ()
public:
virtual Object^ Clone () sealed
public final Object Clone ()
public final function Clone () : Object

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDTag Class
RFIDTag Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDTag Properties

RFIDTag Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
Protocol | Gets or sets the list of supported protocols that are used to communicate with the tag reader.
TagData | Gets or sets the user data contained in the tag.
TagId | Gets or sets the ID of the tag.
Timestamp | Gets or sets the time that the tag was read.

See Also

Reference

RFIDTag Class
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDTag.Protocol Property

RFIDTag.Protocol Property |
 | See Also

1/18/2008

Gets or sets the list of supported protocols that are used to communicate with the tag reader.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Protocol As RFIDProtocols
public RFIDProtocols Protocol { get; set; }
public:
property RFIDProtocols Protocol {
    RFIDProtocols get ();
    void set (RFIDProtocols value);
}
/** @property */
public RFIDProtocols get_Protocol ()

/** @property */
public void set_Protocol (RFIDProtocols value)

public function get Protocol () : RFIDProtocols

public function set Protocol (value : RFIDProtocols)

Remarks

RFIDProtocols enumerates the list of supported protocols.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDTag Class
RFIDTag Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDTag.TagData Property

RFIDTag.TagData Property |
 | See Also

1/18/2008

Gets or sets the user data contained in the tag.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property TagData As Byte()
public byte[] TagData { get; set; }
public:
property array<unsigned char>^ TagData {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
/** @property */
public byte[] get_TagData ()

/** @property */
public void set_TagData (byte[] value)

public function get TagData () : byte[]

public function set TagData (value : byte[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDTag Class
RFIDTag Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDTag.TagId Property

RFIDTag.TagId Property |
 | See Also

1/18/2008

Gets or sets the ID of the tag.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property TagId As Byte()
public byte[] TagId { get; set; }
public:
property array<unsigned char>^ TagId {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
/** @property */
public byte[] get_TagId ()

/** @property */
public void set_TagId (byte[] value)

public function get TagId () : byte[]

public function set TagId (value : byte[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDTag Class
RFIDTag Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RFIDTag.Timestamp Property

RFIDTag.Timestamp Property |
 | See Also

1/18/2008

Gets or sets the time that the tag was read.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property Timestamp As DateTime
public DateTime Timestamp { get; set; }
public:
property DateTime Timestamp {
    DateTime get ();
    void set (DateTime value);
}
/** @property */
public DateTime get_Timestamp ()

/** @property */
public void set_Timestamp (DateTime value)

public function get Timestamp () : DateTime

public function set Timestamp (value : DateTime)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RFIDTag Class
RFIDTag Members
Microsoft.PointOfService.BaseServiceObjects Namespace


RotatePrintCollection Class

RotatePrintCollection Class |
 | See Also Members

1/18/2008

The RotatePrintCollection helper class is used to store an array, or list, of requested rotation print operations.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class RotatePrintCollection
    Inherits PrintOperationCollection
public class RotatePrintCollection : PrintOperationCollection
public ref class RotatePrintCollection : public PrintOperationCollection
public class RotatePrintCollection extends PrintOperationCollection
public class RotatePrintCollection extends PrintOperationCollection

Remarks

The RotatePrintCollection helper class derives from the PrintOperationCollection class and is used to store an array, or list, of requested rotation print operations. The service object uses this list of rotation operations to complete a series of print operations requested by the application for a particular printer station.

Inheritance Hierarchy

System.Object
System.Collections.ReadOnlyCollectionBase
Microsoft.PointOfService.BaseServiceObjects.PrintOperationCollection
Microsoft.PointOfService.BaseServiceObjects.RotatePrintCollection

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RotatePrintCollection Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PrintOperationCollection Class


RotatePrintCollection Members

RotatePrintCollection Members |
 | See Also Methods Properties Explicit Interface Implementations

1/18/2008

The RotatePrintCollection helper class is used to store an array, or list, of requested rotation print operations.

The following tables list the members exposed by the RotatePrintCollection type.

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from ReadOnlyCollectionBase )
Item | (inherited from PrintOperationCollection )
Rotation | Contains the rotation mode.
Station | Retrieves the printer station, as defined by the PrinterStation enumeration, associated with the array. (inherited from PrintOperationCollection)
Top

Protected Properties

Name | Description
InnerList | (inherited from ReadOnlyCollectionBase )
Top

Public Methods (see also Protected Methods )

Name | Description
CopyTo | (inherited from PrintOperationCollection )
Equals | Overloaded. (inherited from Object )
GetEnumerator | (inherited from ReadOnlyCollectionBase )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from ReadOnlyCollectionBase )
System.Collections.ICollection.IsSynchronized | (inherited from ReadOnlyCollectionBase )
System.Collections.ICollection.SyncRoot | (inherited from ReadOnlyCollectionBase )
Top

See Also

Reference

RotatePrintCollection Class
Microsoft.PointOfService.BaseServiceObjects Namespace
PrintOperationCollection Class


RotatePrintCollection Methods

RotatePrintCollection Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
CopyTo | (inherited from PrintOperationCollection )
Equals | Overloaded. (inherited from Object )
GetEnumerator | (inherited from ReadOnlyCollectionBase )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.CopyTo | (inherited from ReadOnlyCollectionBase )

See Also

Reference

RotatePrintCollection Class
Microsoft.PointOfService.BaseServiceObjects Namespace
PrintOperationCollection Class


RotatePrintCollection Properties

RotatePrintCollection Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
Count | (inherited from ReadOnlyCollectionBase )
Item | (inherited from PrintOperationCollection )
Rotation | Contains the rotation mode.
Station | Retrieves the printer station, as defined by the PrinterStation enumeration, associated with the array. (inherited from PrintOperationCollection )

Protected Properties

Name | Description
InnerList | (inherited from ReadOnlyCollectionBase )

Explicit Interface Implementations

Name | Description
System.Collections.ICollection.IsSynchronized | (inherited from ReadOnlyCollectionBase )
System.Collections.ICollection.SyncRoot | (inherited from ReadOnlyCollectionBase )

See Also

Reference

RotatePrintCollection Class
Microsoft.PointOfService.BaseServiceObjects Namespace
PrintOperationCollection Class


RotatePrintCollection.Rotation Property

RotatePrintCollection.Rotation Property |
 | See Also

1/18/2008

Contains the rotation mode.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Rotation As Rotation
public Rotation Rotation { get; }
public:
property Rotation Rotation {
    Rotation get ();
}
/** @property */
public Rotation get_Rotation ()

public function get Rotation () : Rotation

Remarks

Contains the rotation mode. Valid rotation values are defined by the Rotation enumeration.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RotatePrintCollection Class
RotatePrintCollection Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Rotation Enumeration


RotatePrintOperation Class

RotatePrintOperation Class |
 | See Also Members

1/18/2008

The RotatePrintOperation helper class is used by PosPrinterBase to capture the requested rotation whenever the RotatePrint method is called.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class RotatePrintOperation
    Inherits PrintOperation
public class RotatePrintOperation : PrintOperation
public ref class RotatePrintOperation : public PrintOperation
public class RotatePrintOperation extends PrintOperation
public class RotatePrintOperation extends PrintOperation

Remarks

The RotatePrintOperation helper class derives from the PrintOperation helper class. When the application calls the RotatePrint method to enter or exit rotation mode, the PosPrinterBase class uses an instance of the RotatePrintOperation class to capture the requested rotation. These RotatePrint requests are then stored in a RotatePrintCollection array. The service object then uses the rotation information when completing the application’s print requests.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BaseServiceObjects.PrintOperation
Microsoft.PointOfService.BaseServiceObjects.RotatePrintOperation

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RotatePrintOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase Class
PosPrinterBase.RotatePrint Method
PrintOperation Class


RotatePrintOperation Members

RotatePrintOperation Members |
 | See Also Methods Properties

1/18/2008

The RotatePrintOperation helper class is used by PosPrinterBase to capture the requested rotation whenever the RotatePrint method is called.

The following tables list the members exposed by the RotatePrintOperation type.

Public Properties

Name | Description
AsyncMode | Contains the AsyncMode property setting at the time of the application’s print request. (inherited from PrintOperation)
Collection | Contains a collection, which is an instance of the RotatePrintCollection class.
Rotation | Contains the Rotation setting, as defined by the Rotation enumeration. (inherited from PrintOperation)
State | Contains an instance of the PrinterState class, which captures the current printer property values at the time of the application’s print request. (inherited from PrintOperation)
Station | Contains the printer station setting (for example, PrinterStation.Journal). (inherited from PrintOperation)
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

RotatePrintOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase Class
PosPrinterBase.RotatePrint Method
PrintOperation Class


RotatePrintOperation Methods

RotatePrintOperation Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

RotatePrintOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase Class
PosPrinterBase.RotatePrint Method
PrintOperation Class


RotatePrintOperation Properties

RotatePrintOperation Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
AsyncMode | Contains the AsyncMode property setting at the time of the application’s print request. (inherited from PrintOperation )
Collection | Contains a collection, which is an instance of the RotatePrintCollection class.
Rotation | Contains the Rotation setting, as defined by the Rotation enumeration. (inherited from PrintOperation )
State | Contains an instance of the PrinterState class, which captures the current printer property values at the time of the application’s print request. (inherited from PrintOperation )
Station | Contains the printer station setting (for example, PrinterStation.Journal). (inherited from PrintOperation )

See Also

Reference

RotatePrintOperation Class
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase Class
PosPrinterBase.RotatePrint Method
PrintOperation Class


RotatePrintOperation.Collection Property

RotatePrintOperation.Collection Property |
 | See Also

1/18/2008

Contains a collection, which is an instance of the RotatePrintCollection class.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public ReadOnly Property Collection As RotatePrintCollection
public RotatePrintCollection Collection { get; }
public:
property RotatePrintCollection^ Collection {
    RotatePrintCollection^ get ();
}
/** @property */
public RotatePrintCollection get_Collection ()

public function get Collection () : RotatePrintCollection

Remarks

Contains a collection, which is an instance of the RotatePrintCollection class.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

RotatePrintOperation Class
RotatePrintOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
RotatePrintCollection Class


ScannerBase Class

ScannerBase Class |
 | See Also Members

1/18/2008

Contains most of the functionality for support of scanner devices.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public MustInherit Class ScannerBase
    Inherits ScannerBasic
public abstract class ScannerBase : ScannerBasic
public ref class ScannerBase abstract : public ScannerBasic
public abstract class ScannerBase extends ScannerBasic
public abstract class ScannerBase extends ScannerBasic

Remarks

ScannerBase class derives from ScannerBasic class and contains most of the functionality for support of scanner devices. When deriving from ScannerBase, service objects need only implement the CheckHealth and DirectIO methods. Optionally, service objects can provide implementations for the DecodeScanDataLabel and DecodeScanDataType protected methods if they wish to delay decoding of the ScanDataLabel and ScanDataType properties until the application requests those properties.

ScannerBase class provides the core functionality for opening, claiming, and enabling scanner devices. Typically, though, service objects will want to override these methods to add their own custom processing. (A typical example would be to update device statistics during the Open method, or to bring the device online when the application enables it.) When overriding these methods, the service object must call the base class implementation.

ScannerBase class provides two protected methods, GoodScan and FailedScan, to manage scanned data. When data has been scanned, the service object should call the appropriate method. When GoodScan is called, ScannerBase class queues a DataEvent event and increments the StatisticGoodScanCount statistic. When BadScan is called, ScannerBase class queues an ErrorEvent event. The ScannerBase class event queue handles the details of firing the events to the application when the conditions are correct.

ScannerBase class allows service object writers the option of decoding the scan data into the ScanDataType and ScanDataLabel properties either at the time the data is scanned or at a later time when requested by the application. The syntax of the overloads for the GoodScan method reflect these options--one syntax takes only raw scanned data, the other takes the decoded scanned data. If the service object uses the GoodScan syntax for raw scanned data, the service object must override the DecodeScanDataLabel and DecodeScanDataType methods with its own implementations. ScannerBase class will call these implementations, passing in the raw scanned data, when the application requests the ScanDataLabel and ScanDataType properties. If the service object uses the GoodScan syntax that takes decoded scanned data, ScannerBase class doesn't call the DecodeScanDataLabel and DecodeScanDataType methods.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.PosDevice
Microsoft.PointOfService.PosCommon
Microsoft.PointOfService.Scanner
Microsoft.PointOfService.BasicServiceObjects.ScannerBasic
Microsoft.PointOfService.BaseServiceObjects.ScannerBase

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


ScannerBase Members

ScannerBase Members |
 | See Also Events Fields Methods Properties Constructors

1/18/2008

Contains most of the functionality for support of scanner devices.

The following tables list the members exposed by the ScannerBase type.

Protected Constructors

Name | Description
ScannerBase | Creates an instance of the ScannerBase class.
Top

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon)
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon)
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon)
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon)
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon)
StatisticGoodScanCount | Incremented for each successful scan. (inherited from Scanner)
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon)
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon)
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon)
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon)
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon)
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon)
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon)
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon)
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon)
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon)
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon)
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon)
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon)
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon)
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon)
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon)
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon)
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon)
Top

Public Properties (see also Protected Properties )

Name | Description
AutoDisable | Get or sets a Boolean value whether POS for .NET automatically disables the Scanner after data is received. (inherited from ScannerBasic)
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from ScannerBasic)
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from ScannerBasic)
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from ScannerBasic)
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from ScannerBasic)
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from ScannerBasic)
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon)
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from ScannerBasic)
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice)
DataCount | Gets the number of data events currently queued by the Service Object. (inherited from ScannerBasic)
DataEventEnabled | Gets or sets a Boolean value that indicates whether POS for .NET can deliver the next queued event. (inherited from ScannerBasic)
DecodeData | Overridden. When the application sets DecodeData to true, the service object decodes the value of the ScanData property and places the decoded data in the ScanDataLabel and ScanDataType properties.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from ScannerBasic)
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from ScannerBasic)
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from ScannerBasic)
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from ScannerBasic)
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from ScannerBasic)
PowerState | Gets the current power condition. (inherited from ScannerBasic)
ScanData | Overridden. Holds a byte array of the data read from the scanner.
ScanDataLabel | Overridden. Holds the decoded bar code label.
ScanDataType | Overridden. Holds the decoded bar code label type. Possible values are defined by the BarCodeSymbology enumeration.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from ScannerBasic)
ServiceObjectVersion | Gets the Service Object version number. (inherited from ScannerBasic)
State | Gets the current state of the device. (inherited from ScannerBasic)
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon)
Top

Protected Properties

Name | Description
CommonProperties | (inherited from ScannerBasic )
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon)
ErrorCount | (inherited from ScannerBasic )
ExternallyClaimed | (inherited from ScannerBasic )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Gets a Boolean value that indicates whether the Scanner is an exclusive-use device. (inherited from Scanner)
Properties | Contains getters and setters for common and scanner device properties.
Top

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from ScannerBasic )
ClearInput | Clears all device input that has been buffered. (inherited from ScannerBasic)
ClearInputProperties | Overridden. Resets the values of properties altered by DataEvent or ErrorEvent.
Close | Releases the device and its resources. (inherited from ScannerBasic)
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Overridden. Opens a device for later input/output processing.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from ScannerBasic)
ResetStatistic | (inherited from ScannerBasic )
ResetStatistics | Overloaded. (inherited from ScannerBasic )
RetrieveStatistic | (inherited from ScannerBasic )
RetrieveStatistics | Overloaded. (inherited from ScannerBasic )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from ScannerBasic )
UpdateStatistics | Overloaded. (inherited from ScannerBasic )
Top

Protected Methods

Name | Description
ClearInputImpl | (inherited from ScannerBasic )
CreateStatistic | Overloaded. (inherited from ScannerBasic )
DecodeScanDataLabel | A default implementation of DecodeScanDataLabel that returns an empty byte array.
DecodeScanDataType | A default implementation that returns a value of BarCodeSymbology.Unknown.
DeleteConfigurationProperty | (inherited from PosCommon )
Dispose | Overloaded. Overridden.
FailedScan | Called by the service object to have ScannerBase class notify the application that the current scan has failed.
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
GetStatisticValue | (inherited from ScannerBasic )
GoodScan | Overloaded. Called by the service object to have ScannerBase class notify the application that the current scan has succeeded.
IncrementStatistic | Overloaded. (inherited from ScannerBasic )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
PreFireEvent | Overloaded. Overridden.
QueueEvent | Overloaded. (inherited from ScannerBasic )
QueueEventAndWait | Overloaded. (inherited from ScannerBasic )
SetConfigurationProperty | (inherited from PosCommon )
SetStatisticHandlers | (inherited from ScannerBasic )
SetStatisticValue | (inherited from ScannerBasic )
VerifyState | (inherited from ScannerBasic )
Top

Public Events (see also Protected Events )

Name | Description
DataEvent | Raised by the Service Object to present scanned data from the device to the application. (inherited from ScannerBasic)
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from ScannerBasic)
ErrorEvent | Raised by the Service Object to notify the application that an error has been detected while attempting to read scanned data. (inherited from ScannerBasic)
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from ScannerBasic)
Top

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
StateChangedEvent | (inherited from ScannerBasic )
Top

See Also

Reference

ScannerBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


ScannerBase Fields

ScannerBase Fields |
 | See Also

1/18/2008

Public Fields

Name | Description
ExtendedErrorFirmwareBadFile | Indicates the specified firmware file or files exist, but one or more of those files are either not in the correct format or are corrupted. (inherited from PosCommon )
ExtendedErrorStatistics | Indicates a specified statistic could not be reset or updated. (inherited from PosCommon )
ExtendedErrorStatisticsDependency | (inherited from PosCommon )
StatisticCommunicationErrorCount | Holds the programmatic name of the Communication Error Count common statistic. (inherited from PosCommon )
StatisticDeviceCategory | Holds the programmatic name of the Device Category common statistic. (inherited from PosCommon )
StatisticFirmwareRevision | Holds the programmatic name of the Firmware Revision common statistic. (inherited from PosCommon )
StatisticGoodScanCount | Incremented for each successful scan. (inherited from Scanner )
StatisticHoursPoweredCount | Holds the programmatic name of the Hours Powered On common statistic. (inherited from PosCommon )
StatisticInstallationDate | Holds the programmatic name of the Installation Date common statistic. (inherited from PosCommon )
StatisticInterface | Holds the programmatic name of the Interface common statistic. (inherited from PosCommon )
StatisticManufactureDate | Holds the programmatic name of the Manufacture Date common statistic. (inherited from PosCommon )
StatisticManufacturerName | Holds the programmatic name of the Manufacturer Name common statistic. (inherited from PosCommon )
StatisticMechanicalRevision | Holds the programmatic name of the Mechanical Revision common statistic. (inherited from PosCommon )
StatisticModelName | Holds the programmatic name of the Model Name common statistic. (inherited from PosCommon )
StatisticSerialNumber | Holds the programmatic name of the Serial Number common statistic. (inherited from PosCommon )
StatisticUnifiedPOSVersion | Holds the programmatic name of the Unified POS Version common statistic. (inherited from PosCommon )
StatusPowerOff | Indicates that the device’s power is turned off or it is detached from the terminal. (inherited from PosCommon )
StatusPowerOffline | Indicates that the device is powered on but is either not ready or unable to respond to requests. (inherited from PosCommon )
StatusPowerOffOffline | Indicates that either the device’s power is off or it is offline. (inherited from PosCommon )
StatusPowerOnline | Indicates that the device’s power is turned on and it is ready for use. (inherited from PosCommon )
StatusUpdateFirmwareComplete | Indicates the update firmware process has completed successfully. (inherited from PosCommon )
StatusUpdateFirmwareCompleteDeviceNotRestored | Indicates the update firmware process succeeded. However, the Service Object and/or the physical device cannot be returned to the state they were in before the update firmware process started. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceNeedsFirmware | Indicates the update firmware process failed. The device will not be operational until another attempt to update the firmware is successful. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceOk | Indicates the update firmware process failed. However, the device is still operational. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnknown | Indicates the update firmware process failed. The device is in an indeterminate state. (inherited from PosCommon )
StatusUpdateFirmwareFailedDeviceUnrecoverable | Indicates the update firmware process failed. The device is either unusable or unrecoverable through software. (inherited from PosCommon )
StatusUpdateFirmwareProgress | Indicates the update firmware process has completed 1 to 100 percent successfully. (inherited from PosCommon )
WaitForever | Used as the value for a timeout parameter in common and device-specific methods to indicate the method should wait until it receives a response, instead of timing out. (inherited from PosCommon )

See Also

Reference

ScannerBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


ScannerBase Constructor

ScannerBase Constructor |
 | See Also

1/18/2008

Creates an instance of the ScannerBase class.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Sub New
protected ScannerBase ()
protected:
ScannerBase ()
protected ScannerBase ()
protected function ScannerBase ()

Remarks

Creates an instance of the ScannerBase class. Initializes statistics for the UPOS Version, the Device Category, and the Installation Date.

See Also

Reference

ScannerBase Class
ScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


ScannerBase Methods

ScannerBase Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
CheckHealth | (inherited from PosCommon )
Claim | (inherited from ScannerBasic )
ClearInput | Clears all device input that has been buffered. (inherited from ScannerBasic )
ClearInputProperties | Overridden. Resets the values of properties altered by DataEvent or ErrorEvent.
Close | Releases the device and its resources. (inherited from ScannerBasic )
CompareFirmwareVersion | (inherited from PosCommon )
DirectIO | (inherited from PosCommon )
Dispose | Overloaded.
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
Open | Overridden. Opens a device for later input/output processing.
ReferenceEquals | (inherited from Object )
Release | Releases exclusive access to the device. (inherited from ScannerBasic )
ResetStatistic | (inherited from ScannerBasic )
ResetStatistics | Overloaded. (inherited from ScannerBasic )
RetrieveStatistic | (inherited from ScannerBasic )
RetrieveStatistics | Overloaded. (inherited from ScannerBasic )
ToString | (inherited from Object )
UpdateFirmware | (inherited from PosCommon )
UpdateStatistic | (inherited from ScannerBasic )
UpdateStatistics | Overloaded. (inherited from ScannerBasic )

Protected Methods

Name | Description
ClearInputImpl | (inherited from ScannerBasic )
CreateStatistic | Overloaded. (inherited from ScannerBasic )
DecodeScanDataLabel | A default implementation of DecodeScanDataLabel that returns an empty byte array.
DecodeScanDataType | A default implementation that returns a value of BarCodeSymbology.Unknown.
DeleteConfigurationProperty | (inherited from PosCommon )
Dispose | Overloaded. Overridden.
FailedScan | Called by the service object to have ScannerBase class notify the application that the current scan has failed.
Finalize | (inherited from Object )
GetConfigurationProperty | (inherited from PosCommon )
GetStatisticValue | (inherited from ScannerBasic )
GoodScan | Overloaded. Called by the service object to have ScannerBase class notify the application that the current scan has succeeded.
IncrementStatistic | Overloaded. (inherited from ScannerBasic )
Invoke | (inherited from PosCommon )
MemberwiseClone | (inherited from Object )
PreFireEvent | Overloaded. Overridden.
QueueEvent | Overloaded. (inherited from ScannerBasic )
QueueEventAndWait | Overloaded. (inherited from ScannerBasic )
SetConfigurationProperty | (inherited from PosCommon )
SetStatisticHandlers | (inherited from ScannerBasic )
SetStatisticValue | (inherited from ScannerBasic )
VerifyState | (inherited from ScannerBasic )

See Also

Reference

ScannerBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


ScannerBase.ClearInputProperties Method

ScannerBase.ClearInputProperties Method |
 | See Also

1/18/2008

Resets the values of properties altered by DataEvent or ErrorEvent.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub ClearInputProperties
public override void ClearInputProperties ()
public:
virtual void ClearInputProperties () override
public void ClearInputProperties ()
public override function ClearInputProperties ()

Remarks

Sets all data properties populated by a raising of DataEvent or ErrorEvent event back to their default values. This does not reset the DataCount property or State properties.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ScannerBase Class
ScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


ScannerBase.DecodeScanDataLabel Method

ScannerBase.DecodeScanDataLabel Method |
 | See Also

1/18/2008

A default implementation of DecodeScanDataLabel that returns an empty byte array.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overridable Function DecodeScanDataLabel ( _
    scanData As Byte() _
) As Byte()
protected virtual byte[] DecodeScanDataLabel (
    byte[] scanData
)
protected:
virtual array<unsigned char>^ DecodeScanDataLabel (
    array<unsigned char>^ scanData
)
protected byte[] DecodeScanDataLabel (
    byte[] scanData
)
protected function DecodeScanDataLabel (
    scanData : byte[]
) : byte[]

Parameters

scanData

The scanData parameter contains the scanned data, from which the service object will extract the data label information.

Remarks

ScannerBase class provides a default implementation of DecodeScanDataLabel that returns an empty byte array. The service object should override the default implementation of DecodeScanDataLabel if it wishes to decode the scanned data at a later date rather than at the time of the original scan.

The service object should return the decoded data label and throw exceptions for any errors that occur.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ScannerBase Class
ScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Scanner.ScanData Property
Scanner.DecodeData Property
ScanDataLabel


ScannerBase.DecodeScanDataType Method

ScannerBase.DecodeScanDataType Method |
 | See Also

1/18/2008

A default implementation that returns a value of BarCodeSymbology.Unknown.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overridable Function DecodeScanDataType ( _
    scanData As Byte() _
) As BarCodeSymbology
protected virtual BarCodeSymbology DecodeScanDataType (
    byte[] scanData
)
protected:
virtual BarCodeSymbology DecodeScanDataType (
    array<unsigned char>^ scanData
)
protected BarCodeSymbology DecodeScanDataType (
    byte[] scanData
)
protected function DecodeScanDataType (
    scanData : byte[]
) : BarCodeSymbology

Parameters

scanData

The scanData parameter contains the scanned data from which the service object will extract the data type information.

Remarks

ScannerBase class provides a default implementation of DecodeScanDataType that returns a value of BarCodeSymbology.Unknown. The service object should override the default implementation of DecodeScanDataType if it wishes to decode the scanned data at a later date rather than at the time of the original scan.

The service object should return the decoded data type, using the BarCodeSymbology enumeration to verify its validity, and throw exceptions for any errors that occur.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ScannerBase Class
ScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Scanner.ScanData Property
Scanner.DecodeData Property
ScanDataLabel
BarCodeSymbology Enumeration


ScannerBase.Dispose Method

ScannerBase.Dispose Method |
 | See Also

1/18/2008

Overload List

Name | Description
ScannerBase.Dispose () | (inherited from Dispose )
ScannerBase.Dispose (Boolean) |

See Also

Reference

ScannerBase Class
ScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


ScannerBase.Dispose Method (Boolean)

ScannerBase.Dispose Method (Boolean) |
 | See Also

1/18/2008

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

protected override void Dispose (
    bool disposing
)

protected:
virtual void Dispose (
    bool disposing
) override

protected void Dispose (
    boolean disposing
)

protected override function Dispose (
    disposing : boolean
)

Parameters

disposing

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ScannerBase Class
ScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


ScannerBase.FailedScan Method

ScannerBase.FailedScan Method |
 | See Also

1/18/2008

Called by the service object to have ScannerBase class notify the application that the current scan has failed.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Sub FailedScan
protected void FailedScan ()
protected:
void FailedScan ()
protected void FailedScan ()
protected function FailedScan ()

Remarks

Called by the service object to have ScannerBase class notify the application that the current scan has failed. ScannerBase class queues an ErrorEvent event to inform the application of the scan failure.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ScannerBase Class
ScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


ScannerBase.GoodScan Method

ScannerBase.GoodScan Method |
 | See Also

1/18/2008

Called by the service object to have ScannerBase class notify the application that the current scan has succeeded.

Overload List

Name | Description
ScannerBase.GoodScan (Byte[]) | Called by the service object to request that ScannerBase class queue a data event containing the scanned data to the application.
ScannerBase.GoodScan (Byte[], BarCodeSymbology, Byte[]) | Called by the service object to request that ScannerBase class queue a data event containing the scanned data to the application.

See Also

Reference

ScannerBase Class
ScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Scanner.StatisticGoodScanCount Field


ScannerBase.GoodScan Method (Byte[])

ScannerBase.GoodScan Method (Byte[]) |
 | See Also

1/18/2008

Called by the service object to request that ScannerBase class queue a data event containing the scanned data to the application.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Sub GoodScan ( _
    scanData As Byte() _
)
protected void GoodScan (
    byte[] scanData
)
protected:
void GoodScan (
    array<unsigned char>^ scanData
)
protected void GoodScan (
    byte[] scanData
)
protected function GoodScan (
    scanData : byte[]
)

Parameters

scanData

Contains the scanned data.

Remarks

Called by the service object to request that ScannerBase class queue a data event containing the scanned data to the application. If the scanData parameter is null, ScannerBase class throws an exception. Otherwise, it queues a data event to the application and increments the StatisticGoodScanCount statistic.

This overload of GoodScan, which takes the raw scanned data, should be called by the service object if it intends to provide its own implementations of the DecodeScanDataLabel and DecodeScanDataType protected methods to decode the scanned data at a later time. If the service object is relying on ScannerBase class to handle the decoding of the raw scanned data, it should call the GoodScan overload that takes decoded data for the syntax.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ScannerBase Class
ScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Scanner.StatisticGoodScanCount Field


ScannerBase.GoodScan Method (Byte[], BarCodeSymbology, Byte[])

ScannerBase.GoodScan Method (Byte[], BarCodeSymbology, Byte[]) |
 | See Also

1/18/2008

Called by the service object to request that ScannerBase class queue a data event containing the scanned data to the application.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Sub GoodScan ( _
    scanData As Byte(), _
    scanDataType As BarCodeSymbology, _
    scanDataLabel As Byte() _
)
protected void GoodScan (
    byte[] scanData,
    BarCodeSymbology scanDataType,
    byte[] scanDataLabel
)
protected:
void GoodScan (
    array<unsigned char>^ scanData,
    BarCodeSymbology scanDataType,
    array<unsigned char>^ scanDataLabel
)
protected void GoodScan (
    byte[] scanData,
    BarCodeSymbology scanDataType,
    byte[] scanDataLabel
)
protected function GoodScan (
    scanData : byte[],
    scanDataType : BarCodeSymbology,
    scanDataLabel : byte[]
)

Parameters

scanData

Contains the scanned data.

scanDataType

Contains the decoded bar code label type.

scanDataLabel

Contains the decoded bar code data.

Remarks

Called by the service object to request that ScannerBase class queue a data event containing the scanned data to the application. If either scanData or scanDataLabel is null, ScannerBase class throws an exception. Otherwise, it queues a data event to the application and increments the StatisticGoodScanCount statistic.

The service object should call this GoodScan method overload when it intends to use the ScannerBase class implementation for decoding the ScanDataLabel and ScanDataType properties (that is, when it doesn't intend to provide its own implementations of the ScanDataLabel and ScanDataType protected methods).

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ScannerBase Class
ScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Scanner.StatisticGoodScanCount Field


ScannerBase.Open Method

ScannerBase.Open Method |
 | See Also

1/18/2008

Opens a device for later input/output processing.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Sub Open
public override void Open ()
public:
virtual void Open () override
public void Open ()
public override function Open ()

Remarks

Open initializes statistics reporting and event threads for the specified device. Open also initializes the values of many properties. This includes the DataEventEnabled, FreezeEvents, AutoDisable, Claimed properties and more. For specifics about how these properties are initialized, see the individual properties.

Open may throw a PosControlException with the following values:

Value

Meaning

Illegal

One of the following conditions has occurred:

  • The device is already opened; or

  • The DeviceName property is null or an empty string ("").

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ScannerBase Class
ScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosCommon.Close Method


ScannerBase.PreFireEvent Method

ScannerBase.PreFireEvent Method |
 | See Also

1/18/2008

Overload List

Name | Description
ScannerBase.PreFireEvent (DataEventArgs) | Called prior to the delivery of a DataEvent event to the application.
ScannerBase.PreFireEvent (DeviceErrorEventArgs) | (inherited from PreFireEvent )
ScannerBase.PreFireEvent (DirectIOEventArgs) | (inherited from PreFireEvent )
ScannerBase.PreFireEvent (StatusUpdateEventArgs) | (inherited from PreFireEvent )

See Also

Reference

ScannerBase Class
ScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


ScannerBase.PreFireEvent Method (DataEventArgs)

ScannerBase.PreFireEvent Method (DataEventArgs) |
 | See Also

1/18/2008

Called prior to the delivery of a DataEvent event to the application.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected Overrides Sub PreFireEvent ( _
    posEvent As DataEventArgs _
)
protected override void PreFireEvent (
    DataEventArgs posEvent
)
protected:
virtual void PreFireEvent (
    DataEventArgs^ posEvent
) override
protected void PreFireEvent (
    DataEventArgs posEvent
)
protected override function PreFireEvent (
    posEvent : DataEventArgs
)

Parameters

posEvent

An instance of the DataEventArgs class, posEvent contains the event that was queued to the application.

Remarks

Called prior to the delivery of a DataEvent event to the application. When PreFireEvent is called, the ScannerBase class implementation updates the values of the ScannerProperties.ScanData, ScannerProperties.ScanDataLabel, and ScannerProperties.ScanDataType properties.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ScannerBase Class
ScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


ScannerBase Properties

ScannerBase Properties |
 | See Also

1/18/2008

Public Properties (see also Protected Properties )

Name | Description
AutoDisable | Get or sets a Boolean value whether POS for .NET automatically disables the Scanner after data is received. (inherited from ScannerBasic )
CapCompareFirmwareVersion | Gets a Boolean value that indicates whether the Service Object/device supports comparing the firmware version in the physical device against that of a firmware file. (inherited from ScannerBasic )
CapPowerReporting | Gets the power reporting capabilities of the device. (inherited from ScannerBasic )
CapStatisticsReporting | Gets a Boolean value that indicates whether the device can accumulate and can provide various statistics regarding usage. (inherited from ScannerBasic )
CapUpdateFirmware | Gets a Boolean value that indicates whether the device's firmware can be updated through the UpdateFirmware method. (inherited from ScannerBasic )
CapUpdateStatistics | Gets a Boolean value that indicates whether some or all the device statistics can be reset to 0 (zero) by using the ResetStatistic and ResetStatistics methods, or updated by using the UpdateStatistic and UpdateStatistics methods. (inherited from ScannerBasic )
CheckHealthText | Gets a string that indicates the health of the device. (inherited from PosCommon )
Claimed | Gets a Boolean value that indicates whether the device is claimed for exclusive access. (inherited from ScannerBasic )
Compatibility | Gets the compatibility level of a device. (inherited from PosDevice )
DataCount | Gets the number of data events currently queued by the Service Object. (inherited from ScannerBasic )
DataEventEnabled | Gets or sets a Boolean value that indicates whether POS for .NET can deliver the next queued event. (inherited from ScannerBasic )
DecodeData | Overridden. When the application sets DecodeData to true, the service object decodes the value of the ScanData property and places the decoded data in the ScanDataLabel and ScanDataType properties.
DeviceDescription | Gets a string identifying the device and the company that manufactured it. (inherited from ScannerBasic )
DeviceEnabled | Gets or sets a Boolean value that indicates whether the device has been placed in an operational state. (inherited from ScannerBasic )
DeviceName | Gets a short string identifying the device and any pertinent information about it. (inherited from ScannerBasic )
FreezeEvents | Gets or sets a Boolean value that indicates whether the application has requested that the Service Object not deliver events. (inherited from ScannerBasic )
PowerNotify | Gets or sets the type of power notification selection made by the application. (inherited from ScannerBasic )
PowerState | Gets the current power condition. (inherited from ScannerBasic )
ScanData | Overridden. Holds a byte array of the data read from the scanner.
ScanDataLabel | Overridden. Holds the decoded bar code label.
ScanDataType | Overridden. Holds the decoded bar code label type. Possible values are defined by the BarCodeSymbology enumeration.
ServiceObjectDescription | Gets a string identifying the Service Object that supports the device and the company that produced it. (inherited from ScannerBasic )
ServiceObjectVersion | Gets the Service Object version number. (inherited from ScannerBasic )
State | Gets the current state of the device. (inherited from ScannerBasic )
SynchronizingObject | Gets or sets the object that is used to marshal the event handler calls issued because of a POS event. (inherited from PosCommon )

Protected Properties

Name | Description
CommonProperties | (inherited from ScannerBasic )
DeviceInstanceId | (inherited from PosCommon )
DevicePath | Gets or sets the hardware path of a device. (inherited from PosCommon )
ErrorCount | (inherited from ScannerBasic )
ExternallyClaimed | (inherited from ScannerBasic )
HardwareId | (inherited from PosCommon )
IsExclusiveUseDevice | Gets a Boolean value that indicates whether the Scanner is an exclusive-use device. (inherited from Scanner )
Properties | Contains getters and setters for common and scanner device properties.

See Also

Reference

ScannerBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


ScannerBase.DecodeData Property

ScannerBase.DecodeData Property |
 | See Also

1/18/2008

When the application sets DecodeData to true, the service object decodes the value of the ScanData property and places the decoded data in the ScanDataLabel and ScanDataType properties.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides Property DecodeData As Boolean
public override bool DecodeData { get; set; }
public:
virtual property bool DecodeData {
    bool get () override;
    void set (bool value) override;
}
/** @property */
public boolean get_DecodeData ()

/** @property */
public void set_DecodeData (boolean value)

public override function get DecodeData () : boolean

public override function set DecodeData (value : boolean)

Remarks

ScannerBase class verifies that the scanner device has been opened, then retrieves or sets the value of ScannerProperties.DecodeData.

DecodeData is initialized by ScannerProperties class to FALSE. It will then be updated by the application, depending on whether it wishes to receive scanned or decoded scanned data.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ScannerBase Class
ScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Scanner.DecodeData Property


ScannerBase.Properties Property

ScannerBase.Properties Property |
 | See Also

1/18/2008

Contains getters and setters for common and scanner device properties.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Protected ReadOnly Property Properties As ScannerProperties
protected ScannerProperties Properties { get; }
protected:
property ScannerProperties^ Properties {
    ScannerProperties^ get ();
}
/** @property */
protected ScannerProperties get_Properties ()

protected function get Properties () : ScannerProperties

Remarks

Returns an instance of the ScannerProperties helper class, containing getters and setters for scanner and common properties. The service object can use the ScannerProperties class to update properties that are typically read-only for the application. In addition, it is not necessary to have the scanner device opened, claimed, or enabled to update the properties.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ScannerBase Class
ScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace


ScannerBase.ScanData Property

ScannerBase.ScanData Property |
 | See Also

1/18/2008

Holds a byte array of the data read from the scanner.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property ScanData As Byte()
public override byte[] ScanData { get; }
public:
virtual property array<unsigned char>^ ScanData {
    array<unsigned char>^ get () override;
}
/** @property */
public byte[] get_ScanData ()

public override function get ScanData () : byte[]

Remarks

Scan data is, in general, in the format delivered from the scanner. Message header and trailer information are removed, however, because they contain no useful information for an application and are likely to be scanner-specific.

Common header information is a prefix character (such as an STX character). Common trailer information is a terminator character (such as an ETX or CR character) and a block check character if the scanner generates one.

ScanData should include a symbology character if the scanner returns one (for example, an ‘A’ for UPC-A). ScanData should also include check digits if the label contains them and the scanner returns them. (Note that both symbology characters and check digits may or may not be present, depending on the scanner configuration. The scanner service object will return them if they are present, but will not generate or calculate them if they are absent.)

Some merchandise may be marked with a supplemental bar code. This bar code is typically placed to the right of the main bar code, and consists of two or five characters of additional information. If the scanner reads merchandise that contains both main and supplemental bar codes, the supplemental characters are appended to the main characters, and the result is delivered to the application as one label. (Note that a scanner may support a configuration that enables or disables the reading of supplemental codes.)

Some merchandise may be marked with multiple labels, sometimes called multi-symbol labels or tiered labels. These bar codes are typically arranged vertically, and may be of the same or different symbology. If the scanner reads merchandise that contains multiple labels, each bar code is delivered to the application as a separate label. This is necessary due to the current lack of standardization of these bar code types. One is not able to determine all variations based upon the individual bar code data. Therefore, the application will need to determine when a multiple label bar code has been read based upon the data returned. (Note that a scanner may or may not support reading of multiple labels.)

ScannerBase class verifies that the scanner device has been opened, then retrieves the value of ScannerProperties.ScanData. If the value is null, it sets ScanData to null.

ScanData is initialized by ScannerProperties class to an empty byte array. It will then be updated by the ScannerBase class with the currently scanned data when the DataEvent event is delivered to the application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ScannerBase Class
ScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Scanner.ScanData Property


ScannerBase.ScanDataLabel Property

ScannerBase.ScanDataLabel Property |
 | See Also

1/18/2008

Holds the decoded bar code label.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property ScanDataLabel As Byte()
public override byte[] ScanDataLabel { get; }
public:
virtual property array<unsigned char>^ ScanDataLabel {
    array<unsigned char>^ get () override;
}
/** @property */
public byte[] get_ScanDataLabel ()

public override function get ScanDataLabel () : byte[]

Remarks

When the DecodeData property is set to true, the service object decodes ScanData into ScanDataLabel as follows:

  • If present, scanner-generated symbology characters are removed.

  • If the label type contains a readable check digit (such as with UPC-A and EAN-13), then it must be present in ScanDataLabel. If the scanner does not return the check digit to the service object, then it is to be calculated and included.

  • If present for variable length bar codes, the length identification is removed.

For example, the EAN-13 bar code that appears printed as "5 018374 827715" on a label may be received from the scanner and placed into ScanData as the following:

Received from scanner | ScanData | Comment
5018374827715 | 5018374827715 | Complete bar code only
501837482771<CR> | 501837482771 | Without check digit with carriage return
F5018374827715<CR> | F5018374827715 | With scanner-dependent symbology character and carriage return
<STX>F5018374827715<ETX> | F5018374827715 | With header, symbology character, and trailer

For each of these cases (and any other variations), ScanDataLabel must always be set to the string "5018374827715", and ScanDataType must be set to Ean13.

ScannerBase class verifies that the scanner device has been opened by the application. If ScannerProperties.DecodeData is set to false, ScanDataLabel returns an empty byte array. If the contents of ScanDataLabel have been decoded, the decoded bye array is returned. Otherwise, ScanDataLabel calls DecodeScanDataLabel using the current contents of ScanDataLabel before returning the decoded byte array.

ScanDataLabel is initialized by ScannerProperties class to an empty byte array.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ScannerBase Class
ScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Scanner.ScanDataLabel Property
Scanner.DecodeData Property
ScannerBase.DecodeScanDataLabel Method


ScannerBase.ScanDataType Property

ScannerBase.ScanDataType Property |
 | See Also

1/18/2008

Holds the decoded bar code label type. Possible values are defined by the BarCodeSymbology enumeration.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Overrides ReadOnly Property ScanDataType As BarCodeSymbology
public override BarCodeSymbology ScanDataType { get; }
public:
virtual property BarCodeSymbology ScanDataType {
    BarCodeSymbology get () override;
}
/** @property */
public BarCodeSymbology get_ScanDataType ()

public override function get ScanDataType () : BarCodeSymbology

Remarks

ScannerBase class verifies that the scanner device has been opened by the application. If ScannerProperties.DecodeData is set to FALSE, ScannerBase class returns a value for ScanDataType of BarCodeSymbology.Unknown. If the scanned data has been decoded, the value of ScannerProperties.ScanDataType. Otherwise, ScannerDataType class calls the service object’s implementation of the DecodeScanDataType method, using the value of ScannerProperties.ScanData.

ScanDataType is initialized by ScannerProperties class to BarCodeSymbology.Unknown.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ScannerBase Class
ScannerBase Members
Microsoft.PointOfService.BaseServiceObjects Namespace
Scanner.ScanDataType Property
Scanner.DecodeData Property
ScannerBase.DecodeScanDataType Method
BarCodeSymbology Enumeration


ScannerBase Events

ScannerBase Events |
 | See Also

1/18/2008

Public Events (see also Protected Events )

Name | Description
DataEvent | Raised by the Service Object to present scanned data from the device to the application. (inherited from ScannerBasic )
DirectIOEvent | Raised by the Service Object to communicate information directly to the application. (inherited from ScannerBasic )
ErrorEvent | Raised by the Service Object to notify the application that an error has been detected while attempting to read scanned data. (inherited from ScannerBasic )
StatusUpdateEvent | Raised by the Service Object to alert the application of a device status change. (inherited from ScannerBasic )

Protected Events

Name | Description
DeviceAddedEvent | (inherited from PosCommon )
DeviceRemovedEvent | (inherited from PosCommon )
StateChangedEvent | (inherited from ScannerBasic )

See Also

Reference

ScannerBase Class
Microsoft.PointOfService.BaseServiceObjects Namespace


ScannerProperties Class

ScannerProperties Class |
 | See Also Members

1/18/2008

The ScannerProperties helper class simplifies the setting and retrieval of scanner device property values.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Class ScannerProperties
    Inherits CommonProperties
public class ScannerProperties : CommonProperties
public ref class ScannerProperties : public CommonProperties
public class ScannerProperties extends CommonProperties
public class ScannerProperties extends CommonProperties

Remarks

ScannerProperties is a helper class created by POS for .NET to simplify the retrieval and setting of property values for scanner devices. ScannerProperties inherits from the CommonProperties class. The protected Properties property of ScannerBase class returns an instance of ScannerProperties. The service object can manage the value of a property using the syntax Properties.<propertyName>. ScannerProperties bypasses state validation—in other words, the service object can use ScannerProperties to set values for properties even though the application hasn’t opened, claimed, or enabled the scanner device.

Inheritance Hierarchy

System.Object
Microsoft.PointOfService.BasicServiceObjects.CommonProperties
Microsoft.PointOfService.BaseServiceObjects.ScannerProperties

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace


ScannerProperties Members

ScannerProperties Members |
 | See Also Methods Properties

1/18/2008

The ScannerProperties helper class simplifies the setting and retrieval of scanner device property values.

The following tables list the members exposed by the ScannerProperties type.

Public Properties

Name | Description
CapCompareFirmwareVersion | (inherited from CommonProperties )
CapPowerReporting | (inherited from CommonProperties )
CapStatisticsReporting | (inherited from CommonProperties )
CapUpdateFirmware | (inherited from CommonProperties )
CapUpdateStatistics | (inherited from CommonProperties )
DeviceDescription | (inherited from CommonProperties )
DeviceName | (inherited from CommonProperties )
PowerState | (inherited from CommonProperties )
ScanData | Holds a byte array of the data read from the scanner.
ScanDataLabel | Holds the decoded bar code label.
ScanDataType | Holds the decoded bar code label type.
ServiceObjectDescription | (inherited from CommonProperties )
ServiceObjectVersion | (inherited from CommonProperties )
State | (inherited from CommonProperties )
Top

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )
Top

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )
Top

See Also

Reference

ScannerProperties Class
Microsoft.PointOfService.BaseServiceObjects Namespace


ScannerProperties Methods

ScannerProperties Methods |
 | See Also

1/18/2008

Public Methods (see also Protected Methods )

Name | Description
Equals | Overloaded. (inherited from Object )
GetHashCode | (inherited from Object )
GetType | (inherited from Object )
ReferenceEquals | (inherited from Object )
ToString | (inherited from Object )

Protected Methods

Name | Description
Finalize | (inherited from Object )
MemberwiseClone | (inherited from Object )

See Also

Reference

ScannerProperties Class
Microsoft.PointOfService.BaseServiceObjects Namespace


ScannerProperties Properties

ScannerProperties Properties |
 | See Also

1/18/2008

Public Properties

Name | Description
CapCompareFirmwareVersion | (inherited from CommonProperties )
CapPowerReporting | (inherited from CommonProperties )
CapStatisticsReporting | (inherited from CommonProperties )
CapUpdateFirmware | (inherited from CommonProperties )
CapUpdateStatistics | (inherited from CommonProperties )
DeviceDescription | (inherited from CommonProperties )
DeviceName | (inherited from CommonProperties )
PowerState | (inherited from CommonProperties )
ScanData | Holds a byte array of the data read from the scanner.
ScanDataLabel | Holds the decoded bar code label.
ScanDataType | Holds the decoded bar code label type.
ServiceObjectDescription | (inherited from CommonProperties )
ServiceObjectVersion | (inherited from CommonProperties )
State | (inherited from CommonProperties )

See Also

Reference

ScannerProperties Class
Microsoft.PointOfService.BaseServiceObjects Namespace


ScannerProperties.ScanData Property

ScannerProperties.ScanData Property |
 | See Also

1/18/2008

Holds a byte array of the data read from the scanner.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property ScanData As Byte()
public byte[] ScanData { get; set; }
public:
property array<unsigned char>^ ScanData {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
/** @property */
public byte[] get_ScanData ()

/** @property */
public void set_ScanData (byte[] value)

public function get ScanData () : byte[]

public function set ScanData (value : byte[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ScannerProperties Class
ScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
ScannerBase.ScanDataType Property
Scanner.ScanDataType Property


ScannerProperties.ScanDataLabel Property

ScannerProperties.ScanDataLabel Property |
 | See Also

1/18/2008

Holds the decoded bar code label.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property ScanDataLabel As Byte()
public byte[] ScanDataLabel { get; set; }
public:
property array<unsigned char>^ ScanDataLabel {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
/** @property */
public byte[] get_ScanDataLabel ()

/** @property */
public void set_ScanDataLabel (byte[] value)

public function get ScanDataLabel () : byte[]

public function set ScanDataLabel (value : byte[])

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ScannerProperties Class
ScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
ScannerBase.ScanDataLabel Property
Scanner.ScanDataLabel Property


ScannerProperties.ScanDataType Property

ScannerProperties.ScanDataType Property |
 | See Also

1/18/2008

Holds the decoded bar code label type.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Property ScanDataType As BarCodeSymbology
public BarCodeSymbology ScanDataType { get; set; }
public:
property BarCodeSymbology ScanDataType {
    BarCodeSymbology get ();
    void set (BarCodeSymbology value);
}
/** @property */
public BarCodeSymbology get_ScanDataType ()

/** @property */
public void set_ScanDataType (BarCodeSymbology value)

public function get ScanDataType () : BarCodeSymbology

public function set ScanDataType (value : BarCodeSymbology)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread-safe. Any instance members are not guaranteed to be thread-safe.

See Also

Reference

ScannerProperties Class
ScannerProperties Members
Microsoft.PointOfService.BaseServiceObjects Namespace
ScannerBase.ScanData Property
Scanner.ScanData Property


SetStatistic Delegate

SetStatistic Delegate |
 | See Also

1/18/2008

Sets the specified statistic to the specified value.

Namespace: Microsoft.PointOfService.BaseServiceObjects
Assembly: Microsoft.PointOfService.ControlBase (in microsoft.pointofservice.controlbase.dll)

Syntax

Public Delegate Sub SetStatistic ( _
    statisticName As String, _
    statisticValue As String _
)
public delegate void SetStatistic (
    string statisticName,
    string statisticValue
)
public delegate void SetStatistic (
    String^ statisticName,
    String^ statisticValue
)
/** @delegate */
public delegate void SetStatistic (
    String statisticName,
    String statisticValue
)

Parameters

statisticName

The statistic to set.

statisticValue

The value to set the statistic to.

Remarks

Sets the specified statistic to the specified value.

See Also

Reference

Microsoft.PointOfService.BaseServiceObjects Namespace


PosCommon Hierarchy

PosCommon Hierarchy |
 | See Also
1/18/2008

The following table lists the classes derived from Microsoft.PointOfService.PosCommon .

Derived Classes

Class | Description
Microsoft.PointOfService.Belt |
Microsoft.PointOfService.BillAcceptor |
Microsoft.PointOfService.BillDispenser |
Microsoft.PointOfService.Biometrics |
Microsoft.PointOfService.BumpBar |
Microsoft.PointOfService.CashChanger |
Microsoft.PointOfService.CashDrawer |
Microsoft.PointOfService.Cat |
Microsoft.PointOfService.CheckScanner |
Microsoft.PointOfService.CoinAcceptor |
Microsoft.PointOfService.CoinDispenser |
Microsoft.PointOfService.ElectronicJournal |
Microsoft.PointOfService.ElectronicValueRW |
Microsoft.PointOfService.FiscalPrinter |
Microsoft.PointOfService.Gate |
Microsoft.PointOfService.HardTotals |
Microsoft.PointOfService.ImageScanner |
Microsoft.PointOfService.ItemDispenser |
Microsoft.PointOfService.Keylock |
Microsoft.PointOfService.Lights |
Microsoft.PointOfService.LineDisplay |
Microsoft.PointOfService.Micr |
Microsoft.PointOfService.MotionSensor |
Microsoft.PointOfService.Msr |
Microsoft.PointOfService.PinPad |
Microsoft.PointOfService.PointCardRW |
Microsoft.PointOfService.PosKeyboard |
Microsoft.PointOfService.PosPower |
Microsoft.PointOfService.PosPrinter |
Microsoft.PointOfService.RemoteOrderDisplay |
Microsoft.PointOfService.RFIDScanner |
Microsoft.PointOfService.Scale |
Microsoft.PointOfService.Scanner |
Microsoft.PointOfService.SignatureCapture |
Microsoft.PointOfService.SmartCardRW |
Microsoft.PointOfService.ToneIndicator |

See Also

Reference

PosCommon Class
PosCommon Members
Microsoft.PointOfService Namespace


PrintOperation Hierarchy

PrintOperation Hierarchy |
 | See Also
1/18/2008

The following table lists the classes derived from Microsoft.PointOfService.BaseServiceObjects.PrintOperation .

Derived Classes

Class | Description
Microsoft.PointOfService.BaseServiceObjects.ClearPrintAreaOperation |
Microsoft.PointOfService.BaseServiceObjects.CutPaperOperation |
Microsoft.PointOfService.BaseServiceObjects.MarkFeedOperation |
Microsoft.PointOfService.BaseServiceObjects.PageModePrintOperation |
Microsoft.PointOfService.BaseServiceObjects.PrintBarCodeOperation |
Microsoft.PointOfService.BaseServiceObjects.PrintBitmapOperation |
Microsoft.PointOfService.BaseServiceObjects.PrintMemoryBitmapOperation |
Microsoft.PointOfService.BaseServiceObjects.PrintNormalOperation |
Microsoft.PointOfService.BaseServiceObjects.PrintTwoNormalOperation |
Microsoft.PointOfService.BaseServiceObjects.RotatePrintOperation |

See Also

Reference

PrintOperation Class
PrintOperation Members
Microsoft.PointOfService.BaseServiceObjects Namespace
PosPrinterBase Class